DirectX 9.0 for Managed Code

 Language:
Note: This documentation is preliminary and is subject to change.

Purpose

Microsoft® DirectX® 9.0 is your backstage pass to multimedia applications that sizzle.

Where Applicable

DirectX is a set of low-level application programming interfaces (APIs) for creating games and other high-performance multimedia applications. It includes support for high-performance 2-D and 3-D graphics, sound and music, input, force feedback, multimedia streaming, and network communication for applications such as multiplayer games.

Developer Audience

This documentation set is for developers using the Microsoft .NET Framework. Separate documentation is available for developers using the C/C++ programming language.

Run-Time Requirements

DirectX 9.0 can be used in the Microsoft Windows® 98, Windows Millennium Edition (Windows Me), Windows 2000, and Windows XP environments.

See Also

GDI+ Leave Site

OpenGL Leave Site

Windows Image Acquisition Leave Site

© 2004 Microsoft Corporation. All rights reserved. Terms of use.


Legal Information

Note: This documentation is preliminary and is subject to change.

DirectX 9.0 Programmer's Reference

Portions of this document are preliminary and may be changed substantially prior to final commercial release. This document is provided for informational purposes only and Microsoft makes no warranties, either express or implied, in this document. Information in this document, including URL and other Internet Web site references, is subject to change without notice. The entire risk of the use or the results of the use of this document remains with the user. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1995-2004 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, Direct3D, DirectAnimation, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, Visual C++, Visual Studio, Win32, and XNA are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

BLUETOOTH is a trademark owned by Bluetooth SIG, Inc. and licensed to Microsoft Corporation.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

Note: Manufacturers of telecommunications devices implementing this application programming interface (API) must ensure compliance with section 255 of the telecommunications act of 1996.


Introducing DirectX 9.0 for Managed Code

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectX® is a set of low-level application programming interfaces (APIs) for creating games and other high-performance multimedia applications. It includes support for two-dimensional (2-D) and three-dimensional (3-D) graphics, sound effects and music, input devices, and networked applications such as multiplayer games.

DirectX 9.0 for Managed Code

With DirectX 9.0, developers can take advantage of DirectX multimedia functionality and hardware acceleration while using managed code. DirectX 9.0 for Managed Code enables access to most of the original unmanaged DirectX functionality. The following are the managed code languages supported by DirectX 9.0 and documented in the software development kit (SDK).

  • Microsoft Visual C#®
  • Microsoft Visual Basic® .NET
  • Microsoft Visual C++®
  • Microsoft JScript® .NET

Components

DirectX 9.0 for Managed Code is made up of the following major components.

  • Direct3D Graphics provides a single API that you can use for 3-D graphics programming.
  • DirectDraw provides direct low-level access to video memory for high-speed rendering. Deprecated.
  • DirectInput provides support for a variety of input devices, including full support for force-feedback technology.
  • DirectPlay provides support for multiplayer networked games. Deprecated.
  • DirectSound provides support for playing and capturing prerecorded digital samples.
  • Audio Video Playback allows for playback and simple control of audio and video media.

Benefits of DirectX 9.0 for Managed Code

By eliminating the Component Object Model (COM) interoperability layer, DirectX 9.0 for Managed Code improves performance. Managed code can reduce the volume of code and increase productivity. The interface is more intuitive, inheriting from the powerful and easy-to-use Microsoft .NET Framework common types. Managed code also frees you from having to deal with most memory management tasks, such as releasing objects. In the SDK you will find managed Visual C# samples and tutorials that duplicate many of the unmanaged code samples.

Requirements

The minimum required operating system that will support the managed DirectX 9.0 runtime is Microsoft Windows® 98. However, the minimum operating system that will run the samples and tools in the DirectX 9.0 SDK is Windows 2000.

Related Topics

  • What Is Managed Code?


Tips and Tricks Using Managed Code

Note: This documentation is preliminary and is subject to change.

This topic discusses the basics of how to install and use Microsoft® DirectX® 9.0 for Managed Code and documentation. The following sections are included.

  • Getting Started with DirectX 9.0 for Managed Code
  • Using Sample Applications
  • Class Inheritance
  • Debugging DirectX Applications
  • Using Managed DirectX Documentation in Visual Studio .NET 2003
  • Using DirectX Help Documentation
  • DirectX Redistribution

Getting Started with DirectX 9.0 for Managed Code

Install the latest Microsoft .NET Framework runtime from How to Get the .NET Framework Leave Site. This installs the Framework on your local computer, which includes the .NET runtime. The .NET runtime is a set of dynamic-link libraries (DLLs) that managed code applications require. You can install the full software development kit (SDK), but only the runtime is required.

Download the DirectX 9.0 SDK from the DirectX Leave Site Web site, or from MSDN® DirectX Downloads Leave Site. The SDK includes the set of DirectX DLLs that are required to run DirectX applications.

Note: Uninstall previous versions of DirectX before installing this release. Use the Add or Remove Programs Control Panel to remove an earlier version. Before they run, applications developed for managed code should confirm that DirectX 9.0 has been installed.

Using Sample Applications

Pre-tested code for sample applications can be found at:
(SDK root)\Samples\Managed\

The sample applications should be built with Microsoft Visual Studio® .NET 2003.

For each DirectX technology you will find the following folder structure.

  • Individual sample folders: Contain a variety of applications specifically designed for managed code. Within each subfolder you will find a complete Visual Studio .NET 2003 project and solution that will quickly get you started.
  • Bin subfolder: Contains compiled applications that you can run by double-clicking.
  • Tutorials subfolder (Microsoft Direct3D® only): Contains sample applications that will take you step-by-step through the procedures of creating a complete working application. The Direct3D C# tutorials are described in detail in Direct3D Tutorials.

Class Inheritance

DirectX 9.0 for Managed Code does not support class inheritance in applications. Inheriting from DirectX 9.0 for Managed Code classes is not recommended and the resulting behavior is undefined.

Although you may discover that certain inherited classes work with this version of DirectX 9.0 for Managed Code, such inheritance may not work in future versions.

Debugging DirectX Applications

There are two ways to get debugging information from a DirectX managed application.

From the Visual Studio .NET 2003 Integrated Development Environment (IDE):

  • Within the Solution Explorer pane, right-click your project (not the solution) and select Properties.
  • Click the Configuration Properties folder at the left, then click the Debugging selection.
  • Within the Debuggers options, set Enable Unmanaged Debugging to True. It is set to False by default.

From Dbmon.exe, which will run only on Microsoft Windows® 2000 and Windows XP:

  • From a command window, run Dbmon.exe, which is located in:
    (SDK root)\Utilities\

Using Managed DirectX Documentation in Visual Studio .NET 2003

When the SDK has been loaded using the above procedure, documentation will be readable from within Visual Studio .NET 2003. From the Visual Studio Help menu, select Contents to open a table of contents, Index to search by alphabetical words, or Search to do a text search in the documentation, as shown in the following.

Visual Studio screen shot with help menu

From within managed code, you can also view detailed documentation and syntax by clicking anywhere on the name of a class, structure, member, property, or field and then pressing F1.

Using DirectX Help Documentation

Installing DirectX documentation from both the DirectX SDK and MSDN Library can result in duplicate topics in Visual Studio .NET 2003. If this occurs, take the following steps to uninstall the DirectX documentation from the SDK.

  1. In Control Panel, click the Add/Remove Programs icon.
  2. Highlight Microsoft DirectX 9.0 SDK and then click Change.
  3. When the InstallShield Wizard opens, click Next.
  4. Select Modify. Click Next.
  5. In the DirectX Documentation list, click This feature will not be available.
  6. Click Next and the documentation will be removed.

DirectX Redistribution

Stand-alone developer runtime installers install only the DirectX developer and debug runtime for redistribution purposes. These installers are located at:
(SDK root)\Developer Runtime\Managed DirectX\

DirectX 9.0 for Managed Code includes a full set of DLLs for redistribution. To install the full set, perform the following steps.

  1. Verify that the Framework is installed.
  2. Navigate to:
    (SDK root)\Redist\DirectX9\
  3. Call DXSetup.exe with the /InstallManagedDX command line attribute, as follows.
DXSetup.exe /InstallManagedDX


What's New in DirectX 9.0 for Managed Code

Note: This documentation is preliminary and is subject to change.

The managed code documentation has not changed substantially since the Microsoft® DirectX® 9.0 SDK Update (Summer 2004). New FragmentLinker, PRTPerVertex, and SimpleAnimation samples are provided with this SDK update. Preliminary documentation on these samples is located in the sample folders at:

(SDK root)\Samples\Managed\Direct3D

The remainder of this page describes new features of DirectX 9.0 for Managed Code since the DirectX 9.0 SDK Update (Summer 2003).

New Features

  • Spherical harmonic (SH) math functions are exposed in the new SphericalHarmonics class.
  • Samples are now authored using an improved sample framework. See Sample Framework.
  • EffectStateManager was added as a user-implemented class to allow custom state management.
  • The CleanType enumeration was added for mesh operations.
  • The TextureShader class was added for using texture shaders.
  • Easier to use 2-D drawing methods were added in the Sprite and Font classes.
  • Improved interoperation is provided between DirectX 9.0 for Managed Code and native DirectX.

  • New classes supporting precomputed radiance transfer (PRT) simulation were added and include the following:

    • PrtBuffer
    • PrtCompressedBuffer
    • PrtEngine
    • SphericalHarmonics
    • TextureGutterHelper
  • Improved documentation is provided for the Microsoft.DirectX and Microsoft.DirectX.Direct3D namespaces.
  • Complete documentation is provided for the Microsoft.DirectX.AudioVideoPlayback and Microsoft.DirectX.DirectSound namespaces, plus various new overview topics.

API Changes

The following classes have changed or are new to DirectX 9.0 for Managed Code:

  • AnimationController
  • AnimationOutput
  • Device
  • Effect
  • EffectStateManager (New)
  • GraphicsStream
  • Light
  • LightsCollection (New)
  • RenderStateManager (New)
  • SamplerStateManager (New)
  • SamplerStateManagerCollection (New)
  • TextureShader
  • TextureStateManager (New)
  • TextureStateManagerCollection (New)

The following classes have been removed from DirectX 9.0 for Managed Code:

  • Lights
  • RenderStates
  • Sampler
  • SamplerStates
  • TextureState
  • TextureStates
  • XFileBinary
  • XFileDataReference

Class mappings from old classes to new classes:

  • Lights - LightsCollection (New)
  • RenderStates - RenderStateManager (New)
  • SamplerStates - SamplerStateManager (New)
  • TextureStates - TextureStateManager (New)

Methods that use the ranks parameter, such as VertexBuffer.Lock or IndexBuffer.Lock, have changed to allow an unlimited number of dimensions to be used for locking a resource into an array. The ranks parameter is now defined as an array of integers Leave Site that represents the size of each dimension of the returning array.

The Commit method was removed from the Light class. Existing code relying on Light.Commit should be modified. Now, changes made to a Light object's properties do not take effect until Light.Update is called, or Light.Enabled is set to true.

Note: The Microsoft.DirectX.PrivateImplementationDetails namespace supports the .NET Framework infrastructure and is not intended to be used directly from your code.


What Is Managed Code?

Note: This documentation is preliminary and is subject to change.

Managed code is code written in one of over twenty high-level programming languages that are available for use with the Microsoft® .NET Framework, including C#, J#, Microsoft Visual Basic® .NET, Microsoft JScript® .NET, and C++. All of these languages share a unified set of class libraries and can be encoded into an Intermediate Language (IL). A runtime-aware compiler compiles the IL into native executable code within a managed execution environment that ensures type safety, array bound and index checking, exception handling, and garbage collection.

By using managed code and compiling in this managed execution environment, you can avoid many typical programming mistakes that lead to security holes and unstable applications. Also, many unproductive programming tasks are automatically taken care of, such as type safety checking, memory management, and destruction of unneeded objects. You can therefore focus on the business logic of your applications and write them using fewer lines of code. The result is shorter development time and more secure and stable applications.

Related Topics

  • .NET Framework Technology Overview Leave Site


Direct3D Graphics

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® is a low-level graphics application programming interface (API) that enables you to manipulate visual models of 3-dimensional objects and take advantage of hardware acceleration, such as video graphics cards.

Roadmap

  • Getting Started with Direct3D

    Contains architectural descriptions, drawings of 3-D conventions, discussion of Direct3D devices and resources, and step-by-step tutorials. Code snippets are used throughout to clarify the usage of Direct3D components.

  • Microsoft.DirectX.Direct3D

    Contains the reference pages for the Direct3D namespace. This includes the syntax for methods, properties, and data structures. It includes an explanation of how the Direct3D component works, and often includes code snippets.

  • Microsoft.DirectX

    Contains the reference pages for the Microsoft DirectX® utility namespace. This namespace provides utility operations and data storage for DirectX application programming, including exception handling, simple helper methods, and structures used for matrix, clipping plane, quaternion, and vector manipulation.

  • How Do I ...?

    Explains typical tasks you may encounter in developing DirectX applications, with short snippets of C# code.


Getting Started with Direct3D

Note: This documentation is preliminary and is subject to change.

This section provides a brief introduction to the three-dimensional (3-D) graphics functionality in the Microsoft® Direct3D® application programming interface (API), plus tutorials to help you quickly get applications up and running.

  • 3-D Coordinate Systems and Geometry
  • Devices
  • Resources
  • Transforms
  • Direct3D Rendering
  • Direct3D Surfaces
  • Direct3D Textures
  • Direct3D Tutorials
  • Microsoft DirectX® 9.0 for Managed Code Samples


3-D Coordinate Systems and Geometry

Note: This documentation is preliminary and is subject to change.

Programming Microsoft® Direct3D® applications requires a working familiarity with 3-D geometric principles. This section introduces the most important geometric concepts for creating 3-D scenes. The following topics provide high-level descriptions of the basic concepts employed by a Direct3D application.

  • 3-D Coordinate Systems
  • Face and Vertex Normal Vectors
  • 3-D Primitives
  • Rasterization Rules
  • Rectangles
  • Triangle Interpolation
  • Vectors, Vertices, and Quaternions


3-D Coordinate Systems

Note: This documentation is preliminary and is subject to change.

Typically, 3-D graphics applications use two types of Cartesian coordinate systems: left-handed and right-handed. In both coordinate systems, the positive x-axis points to the right, and the positive y-axis points up. You can remember which direction the positive z-axis points by pointing the fingers of either your left or right hand in the positive x direction and curling them into the positive y direction. The direction your thumb points, either toward or away from you, is the direction that the positive z-axis points for that coordinate system. The following illustration shows these two coordinate systems.

Left- and right-handed Cartesian coordinates

Microsoft® Direct3D® uses a left-handed coordinate system. If you are porting an application that is based on a right-handed coordinate system, you must make two changes to the data passed to Direct3D.

  • Flip the order of triangle vertices so that the system traverses them clockwise from the front. In other words, if the vertices are v0, v1, v2, pass them to Direct3D as v0, v2, v1.
  • Use the view matrix to scale world space by -1 in the z direction. To do this, flip the sign of the M31, M32, M33, and M34 fields of the Matrix structure that you use for your view matrix.

To obtain what amounts to a right-handed world, use the PerspectiveRH and PerspectiveLH methods to define the projection transform. However, be careful to use the corresponding LookAtRH function, reverse the backface-culling order, and lay out the cube maps accordingly.

Although left-handed and right-handed coordinates are the most common systems, there is a variety of other coordinate systems used in 3-D software. For example, it is not unusual for 3-D modeling applications to use a coordinate system in which the y-axis points toward or away from the viewer, and the z-axis points up. In this case, right-handedness is defined as any positive axis (x, y, or z) pointing toward the viewer. Left-handedness is defined as any positive axis (x, y, or z) pointing away from the viewer. If you are porting a left-handed modeling application where the z-axis points up, you must do a rotation on all the vertex data in addition to the previous steps.

The essential operations performed on objects defined in a 3-D coordinate system are translation, rotation, and scaling. You can combine these basic transformations to create a transform matrix.

When you combine these operations, the results are not commutative: the order in which you multiply matrices is important.


Face and Vertex Normal Vectors

Note: This documentation is preliminary and is subject to change.

Each face in a mesh has a perpendicular normal vector. The vector's direction is determined by the order in which the vertices are defined and by whether the coordinate system is right- or left-handed. The face normal points away from the front side of the face. In Microsoft® Direct3D®, only the front of a face is visible. A front face is one in which vertices are defined in clockwise order.

Front face of polygon with normal vector

Any face that is not a front face is a back face. Direct3D does not always render back faces; therefore, back faces are said to be culled. You can change the culling mode to render back faces if you want.

Direct3D uses the vertex normals for Gouraud shading, lighting, and texturing effects.

Vertex normals on a pyramid

When applying Gouraud shading to a polygon, Direct3D uses the vertex normals to calculate the angle between the light source and the surface. It calculates the color and intensity values for the vertices and interpolates them for every point across all the primitive's surfaces. Direct3D calculates the light intensity value by using the angle. The greater the angle, the less light is shining on the surface.

If you are creating an object that is flat, set the vertex normals to point perpendicular to the surface, as shown in the following illustration. A flat surface composed of two triangles is defined.

Vertex normals on a flat object

It is more likely, however, that your object is made up of triangle strips and the triangles are not coplanar. One simple way to achieve smooth shading across all the triangles in the strip is to first calculate the surface normal vector for each polygonal face with which the vertex is associated. The vertex normal can be set to make an equal angle with each surface normal. However, this method might not be efficient enough for complex primitives.

This method is illustrated by the following figure, which shows two surfaces, S1 and S2, seen edge-on from above. The normal vectors for S1 and S2 are shown in blue. The vertex normal vector is shown in red. The angle that the vertex normal vector makes with the surface normal of S1 is the same as the angle between the vertex normal and the surface normal of S2. When these two surfaces are lit and shaded with Gouraud shading, the result is a smoothly shaded, smoothly rounded edge between them.

Vertex normal for the edge of two intersecting surfaces

If the vertex normal leans toward one of the faces with which it is associated, it causes the light intensity to increase or decrease for points on that surface, depending on the angle it makes with the light source. An example is shown in the following figure. Again, these surfaces are seen edge-on. The vertex normal leans toward S1, causing it to have a smaller angle with the light source than if the vertex normal had equal angles with the surface normals.

Light source illuminating the edge of two intersecting surfaces

You can use Gouraud shading to display some objects in a 3-D scene with sharp edges. To do so, duplicate the vertex normal vectors at any intersection of faces where a sharp edge is required, as shown in the following illustration.

Vertex normals used to generate Gouraud shading on a sharp edge

If you use the Device Draw...Primitives methods to render your scene, define the object with sharp edges as a triangle list, rather than a triangle strip. When you define an object as a triangle strip, Direct3D treats it as a single polygon composed of multiple triangular faces. Gouraud shading is applied both across each face of the polygon and between adjacent faces. The result is an object that is smoothly shaded from face to face. Because a triangle list is a polygon composed of a series of disjoint triangular faces, Direct3D applies Gouraud shading across each face of the polygon. However, it is not applied from face to face. If two or more triangles of a triangle list are adjacent, they appear to have a sharp edge between them.

Another alternative is to change to flat shading when rendering objects with sharp edges. This is computationally the most efficient method, but it may result in objects in the scene that are not rendered as realistically as the objects that are Gouraud-shaded.


3-D Primitives

Note: This documentation is preliminary and is subject to change.

A 3-D primitive is a collection of vertices that form a single 3-D entity. The simplest primitive is a collection of points in a 3-D coordinate system, which is called a point list.

Often, 3-D primitives are polygons. A polygon is a closed 3-D figure delineated by at least three vertices. The simplest polygon is a triangle. Microsoft® Direct3D® uses triangles to compose most of its polygons because all three vertices in a triangle are guaranteed to be coplanar. Rendering nonplanar vertices is inefficient. You can combine triangles to form large, complex polygons and meshes.

The following illustration shows a cube. Two triangles form each face of the cube. The entire set of triangles forms one cubic primitive. You can apply textures and materials to the surfaces of primitives to make them appear to be a single solid form. For details, see Direct3D Textures.

Cube created from triangles

You can also use triangles to create primitives whose surfaces appear to be smooth curves. The following illustration shows how a sphere can be simulated with triangles. After a material is applied, the sphere looks curved when it is rendered. This is especially true if you use Gouraud shading. For details, see Gouraud Shading.

Sphere approximated with triangular faces


Rasterization Rules

Note: This documentation is preliminary and is subject to change.

Often, the points specified for vertices do not precisely match the pixels on the screen. When this happens, Microsoft® Direct3D® applies triangle rasterization rules to decide which pixels apply to a given triangle.

  • Triangle Rasterization Rules
  • Point and Line Rules
  • Point Sprite Rules

Triangle Rasterization Rules

Direct3D uses a top-left filling convention for filling geometry. This is the same convention that is used for rectangles in Microsoft Windows® Graphics Device Interface (GDI) and OpenGL. In Direct3D, the center of the pixel is the decisive point. If the center is inside a triangle, the pixel is part of the triangle. Pixel centers are at integer coordinates.

This description of triangle-rasterization rules used by Direct3D does not necessarily apply to all available hardware. Your testing may uncover minor variations in the implementation of these rules.

The following illustration shows a rectangle whose upper-left corner is at (0, 0) and whose lower-right corner is at (5, 5). This rectangle fills 25 pixels, just as you would expect. The width of the rectangle is defined as right minus left. The height is defined as bottom minus top.

Numbered square divided into 6 rows and columns

In the top-left filling convention, top refers to the vertical location of horizontal spans, and left refers to the horizontal location of pixels within a span. An edge cannot be a top edge unless it is horizontal. In general, most triangles have only left and right edges.

Numbered square containing two triangles

The top-left filling convention determines the action taken by Direct3D when a triangle passes through the center of a pixel. The following illustration shows two triangles, one at (0, 0), (5, 0), and (5, 5), and the other at (0, 5), (0, 0), and (5, 5). The first triangle in this case gets 15 pixels (shown in black), whereas the second gets only 10 pixels (shown in gray) because the shared edge is the left edge of the first triangle.

Numbered square containing diagonal line

If you define a rectangle with its upper-left corner at (0.5, 0.5) and its lower-right corner at (2.5, 4.5), the center point of this rectangle is at (1.5, 2.5). When the Direct3Drasterizertessellates this rectangle, the center of each pixel is unambiguously inside each of the four triangles, and the top-left filling convention is not needed. The following illustration shows this. The pixels in the rectangle are labeled according to the triangle in which Direct3D includes them.

Rectangle divided into four triangles

If you move the rectangle in the previous example so that its upper-left corner is at (1.0, 1.0), its lower-right corner at (3.0, 5.0), and its center point at (2.0, 3.0), Direct3D applies the top-left filling convention. Most pixels in this rectangle straddle the border between two or more triangles, as the next illustration shows.

Rectangle divided into four triangles shifted one-half pixel right and down

For both rectangles, the same pixels are affected.

Direct3D top-left filling of a rectangle divided into four triangles

Point and Line Rules

Points are rendered the same as point sprites, which are both rendered as screen-aligned quadrilaterals and thus adhere to the same rules as polygon rendering.

Non-antialiased line rendering rules are exactly the same as those for GDI.

For information about antialiased line rendering, see Line.

Point Sprite Rules

Point sprites and patch primitives are rasterized as if the primitives were first tessellated into triangles and the resulting triangles rasterized.


Rectangles

Note: This documentation is preliminary and is subject to change.

Throughout Microsoft® Direct3D® and Microsoft Windows® programming, objects on the screen are referred to in terms of bounding rectangles. The sides of a bounding rectangle are always parallel to the sides of the screen. Managed code applications should use the Rectangle Leave Site structure, in the System.Drawing Leave Site namespace, for storing rectangle information and when blitting to the screen or performing collision detection.

Most unmanaged C++ applications use the RECT Leave Site structure, which requires the (x,y) coordinates of the rectangle's upper-left and lower-right corners. A managed code application typically supplies Rectangle Leave Site properties that indicate the (x,y) coordinates of the rectangle's upper-left corner, and its height and width, as shown in the following diagram.

Bounding rectangle within a display screen

In the interest of efficiency, consistency, and ease of use, all Direct3D presentation functions work with rectangles.


Triangle Interpolation

Note: This documentation is preliminary and is subject to change.

During rendering, the pipeline interpolates vertex data across each triangle. Several types of data can be interpolated.

  • Diffuse color
  • Specular color
  • Diffuse alpha (triangle opacity)
  • Specular alpha
  • Fog factor (taken from specular alpha for fixed function vertex pipeline and from fog register for programmable vertex pipeline)
  • Texture coordinates

The interpolation of the vertex data is dependent on the current shading mode, as shown in the following table.

Shading mode | Description
Flat | Only the fog factor is interpolated in flat shade mode. For all other interpolated values, the color of the first vertex in the triangle is applied across the entire face.
Gouraud | Linear interpolation is performed between all three vertices.

The color and specular interpolated values are treated differently, depending on the color model. In the RGB color model, the system uses the red, green, and blue color components in the interpolation.

The alpha component of a color is treated as a separate interpolated value because device drivers can implement transparency in two different ways: by using texture blending or by using stippling.

Use the ShadeCaps property of the Caps structure to determine what forms of interpolation the current device driver supports.


Vectors, Vertices, and Quaternions

Note: This documentation is preliminary and is subject to change.

Throughout Microsoft® Direct3D®, vertices describe position and orientation. Each vertex in a primitive is described by a vector that gives its position, color, texture coordinates, and a normal vector that gives its orientation.

Quaternions add a fourth element to the [x,y,z] values that define a three-component vector. Quaternions are an alternative to the matrix methods that are typically used for 3-D rotations. A quaternion represents an axis in 3-D space and a rotation around that axis. For example, a quaternion might represent a (1,1,2) axis and a rotation of 1 radian. Quaternions carry valuable information, but their true power comes from the two operations that you can perform on them: composition and interpolation.

Performing composition on quaternions is similar to combining them. The composition of two quaternions is notated as follows:

Quaternion composition equation

The composition of two quaternions applied to a geometry means "rotate the geometry around axis2 by rotation2, then rotate it around axis1 by rotation1." In this case, Q represents a rotation around a single axis that is the result of applying q2, then q1 to the geometry.

Using quaternion interpolation, an application can calculate a smooth and reasonable path from one axis and orientation to another. Therefore, interpolation between q1 and q2 provides a simple way to animate from one orientation to another.

When you use composition and interpolation together, they provide you with a simple way to manipulate a geometry in a manner that appears complex. For example, imagine that you have a geometry that you want to rotate to a given orientation. You know that you want to rotate it r2 degrees around axis2, then rotate it r1 degrees around axis1, but you don't know the final quaternion. By using composition, you could combine the two rotations on the geometry to get a single quaternion that is the result. Then, you could interpolate from the original to the composed quaternion to achieve a smooth transition from one to the other.

The Microsoft.DirectX namespace includes the Quaternion structure that helps you work with quaternions. For example, the RotateAxis method applies a rotation value to a vector that defines an axis of rotation, and updates the fields and properties of the original quaternion structure. Additionally, the Multiply method performs a composition of quaternions, and the Slerp method performs spherical linear interpolation between two quaternions.

Direct3D applications can also use the methods of the Microsoft.DirectX.Vector2, Vector3, and Vector4 structures to simplify the task of working with two-, three-, and four-component vectors, respectively.


Devices

Note: This documentation is preliminary and is subject to change.

A Microsoft® Direct3D® device is the rendering component of Direct3D. It encapsulates and stores the rendering state. In addition, a Direct3D device performs transformations and lighting operations and rasterizes an image to a surface. The following topics provide further details on using devices.

  • Device Types
  • Creating a Device
  • Selecting a Device
  • Lost Devices
  • Determining Hardware Support
  • Processing Vertex Data
  • Device-Supported Primitive Types

Architecturally, Direct3D devices contain a transformation module, a lighting module, and a rasterizing module, as the following illustration shows.

Direct3D device architecture

Microsoft DirectX® currently supports two main types of Direct3D devices: a hardware device with hardware-accelerated rasterization and shading with both hardware and software vertex processing; and a reference device.

You can think of these devices as two separate drivers. Software and reference devices are represented by software drivers, and the hardware device is represented by a hardware driver. The most common way to take advantage of these devices is to use the hardware device for shipping applications, and the reference device for feature testing. These are provided by third parties to emulate particular devices, for example, developmental hardware that has not yet been released.

The Direct3D device that an application creates must correspond to the capabilities of the hardware on which the application is running. Direct3D provides rendering capabilities, either by accessing 3-D hardware that is installed in the computer or by emulating the capabilities of 3-D hardware in software. Therefore, Direct3D provides devices for both hardware access and software emulation.

Hardware-accelerated devices give much better performance than software devices. The hardware device type is available on all Direct3D supported graphic adapters. In most cases, applications target computers that have hardware acceleration and rely on software emulation to accommodate lower-end computers.

With the exception of the reference device, software devices do not always support the same features as a hardware device. Applications should always query for device capabilities to determine which features are supported.

Because the behavior of the software and reference devices provided with DirectX 9.0 is identical to that of the hardware device, application code authored to work with the hardware device will work with the software or reference devices without modifications. Note that while the provided software or reference device behavior is identical to that of the hardware device, the device capabilities do vary, and a particular software device may implement a much smaller set of capabilities.

Behaviors

Direct3D enables you to specify the behavior of a device, as well the device type. The Device(Int32,DeviceType,IntPtr,CreateFlags,PresentParameters[]) method enables a combination of one or more of the CreateFlags behavior flags to control the global behaviors of the Direct3D device. These behaviors specify what is and is not maintained in the run-time portion of Direct3D, and the device types specify which driver to use. Although some combinations of device behaviors are not valid, it is possible to use all device behaviors with all device types. For example, it is valid to specify DeviceType.Software, which indicates a pluggable software device, with the device creation flag CreateFlags.PureDevice, which specifies that the device does not support vertex processing.


Device Types
Note: This documentation is preliminary and is subject to change.

Hardware Device

The primary device type is the hardware device, which supports hardware-accelerated rasterization and both hardware and software vertex processing. If the computer on which your application is running is equipped with a display adapter that supports Microsoft® Direct3D®, your application should use it for 3-D operations. Direct3D hardware devices implement all or part of the transformation, lighting, and rasterizing modules in hardware.

Applications do not access 3-D cards directly. They call Direct3D functions and methods. Direct3D accesses the hardware through a hardware abstraction layer. If the computer running your application supports the abstraction layer, it will gain the best performance by using a hardware device.

To specify hardware rasterization and shading, create a Device object using the DeviceType.Hardware constant.

Note: Hardware devices cannot render to 8-bit render target surfaces.

Reference Device

Direct3D supports an additional device type called a reference device or reference rasterizer. Unlike a software device, the reference rasterizer supports every Direct3D feature. Because these features are implemented for accuracy, rather than speed, and are implemented in software, the results are not very fast. The reference rasterizer does make use of special CPU instructions whenever it can, but it is not intended for retail applications. Use the reference rasterizer only for feature testing or demonstration purposes.

To create a reference device, create a Device object using the DeviceType.Reference constant.


Creating a Device
Note: This documentation is preliminary and is subject to change.
Note: All rendering devices created by a given Microsoft® Direct3D® object share the same physical resources. Although your application can create multiple rendering devices from a single Direct3D object, because they share the same hardware, extreme performance penalties will be incurred.

To create a Direct3D device, your managed code application should first create a PresentParameters object that contains the presentation parameters for the device. The following C# code example contains a simple initialization using the Device(Int32,DeviceType,Control,CreateFlags,PresentParameters[]) constructor that receives a PresentParameters object.

          [C#]

using Microsoft.DirectX.Direct3D;
.
.
.
// Global variables for this project
Device device = null;              // Create rendering device
PresentParameters presentParams = new PresentParameters();

device = new Device(0, DeviceType.Hardware, this,
                    CreateFlags.SoftwareVertexProcessing, presentParams);

This call also specifies the default adapter, a hardware device, and software vertex processing.

Note that a call to create, dispose, or reset the device should happen only on the same thread as the window procedure of the focus window. After creating the device, set its state.

Related Topics

  • Tutorial 1: Creating a Device


Selecting a Device

Note: This documentation is preliminary and is subject to change.

Applications can query hardware to detect the supported Microsoft® Direct3D® device types. This section contains information on the primary tasks involved in enumerating display adapters and selecting Direct3D devices.

An application must perform a series of tasks to select an appropriate Direct3D device. Note that the following steps are intended for a full-screen application. In most cases, a windowed application can skip most of these steps.

  1. Initially, the application must enumerate the display adapters on the system. An adapter is a physical piece of hardware. Note that the graphics card might contain more than a single adapter, as is the case with a dual-head display. For a detailed example of enumerating adapters, see (SDK root)\Samples\Managed\Common\dxmutenum.cs. Applications that are not concerned with multiple-monitor support can disregard this step and use the default adapter enumeration.
  2. For each adapter, the application enumerates the supported display modes with the Adapters property of the Manager object. The collection of adapters can be queried with the AdapterListCollection object.
  3. If required, the application checks for the presence of hardware acceleration in each enumerated display mode by checking the return value of the checkType parameter of Manager.CheckDeviceType. Other parameters of CheckDeviceType can provide additional information on the current display and back buffer formats of the device.
  4. The application checks for the desired level of functionality for the device on this adapter using the Device.DeviceCaps property. This property returns a Caps structure that describes the capabilities of the device. Those devices that do not support the required functionality will not contain a valid structure. The device capability returned by DeviceCaps is guaranteed to be constant for a device across all display modes verified by CheckDeviceType.
  5. Devices can always render to surfaces of the format of an enumerated display mode that is supported by the device. If the application is required to render to a surface of a different format, it can call CheckDeviceType. If the device can render to the format, then it is guaranteed that all capabilities returned by DeviceCaps are applicable.
  6. Lastly, the application can determine if multisampling techniques, such as full-scene antialiasing, are supported for a render format by using the CheckDeviceMultiSampleType method.

After completing the above steps, the application should have a list of display modes in which it can operate. The final step is to verify that enough device-accessible memory is available to accommodate the required number of buffers and antialiasing. This test is necessary because the memory consumption for the mode and multisample combination is impossible to predict without verifying it. Moreover, some display adapter architectures might not have a constant amount of device-accessible memory. This means that an application should be able to report out-of-video-memory failures when going into full-screen mode. Typically, an application should remove full-screen mode from the list of modes it offers to a user, or it should attempt to consume less memory by reducing the number of back buffers or using a simpler multisampling technique.

A windowed application performs a similar set of tasks, as follows.

  1. It determines the desktop rectangle covered by the client area of the window.
  2. It enumerates adapters, looking for the adapter for which the monitor covers the client area. If the client area is owned by more than one adapter, then the application can choose to drive each adapter independently, or to drive a single adapter and have Direct3D transfer pixels from one device to another at presentation. The application can also disregard the above two steps and use the default adapter, although this might result in slower operation when the window is placed on a secondary monitor. The default adapter is the first ordinal identified by the DeviceCreationParameters.AdapterOrdinal. The adapter ordinal value can be queried with the GetDeviceCaps method or returned by the AdapterInformation.Adapter property.
  3. The application should call CheckDeviceType to determine if the device can support rendering to a back buffer of the specified format while in desktop mode. The AdapterInformation.CurrentDisplayMode property can be used to determine the desktop display format.


Lost Devices
Note: This documentation is preliminary and is subject to change.

A Microsoft® Direct3D® device can be in either an operational state or a lost state. The operational state is the normal state of the device, in which the device runs and presents all rendering as expected. The device makes a transition to the lost state when an event, such as the loss of keyboard focus in a full-screen application, causes rendering to become impossible. The lost state is characterized by the silent failure of all rendering operations, which means that the rendering methods can return success codes even though the rendering operations fail. In this situation, the Device.DeviceLost event is triggered.

By design, the full set of scenarios that can cause a device to become lost is not specified. A typical example is a loss of focus, such as when the user presses ALT+TAB or a system dialog is initialized. Devices can also be lost due to a power management event, or when another application assumes full-screen operation. In addition, any failure from Device.Reset puts the device into a lost state.

The following two exception objects may be handled:

  • DeviceLostException: This object indicates that the device has been lost but cannot be reset, so rendering is not possible.
  • DeviceNotResetException: This object indicates that the device has been lost but can be reset at this time.

Responding to a Lost Device

A lost device must re-create resources (including video memory resources) after it has been reset. If a device is lost, the application queries the device to see if it can be restored to the operational state. If not, the application waits until the device can be restored.

If the device can be restored, the application prepares the device by destroying all video-memory resources and any swap chains. Then, the application calls the Reset method. Reset is the only method that has an effect when a device is lost, and is the only method by which an application can change the device from a lost to an operational state. The method will fail unless the application releases all resources that are allocated in Default, including those created by the CreateRenderTarget and CreateDepthStencilSurface methods.

For the most part, the high-frequency calls of Direct3D do not return any information about whether the device has been lost. The application can continue to call rendering methods, such as Device.DrawPrimitives, without receiving notification of a lost device. Internally, these operations are discarded until the device is reset to the operational state.

The application can determine whether a device is lost by querying the return value of the CheckCooperativeLevel method.

Locking Operations

Internally, Direct3D does enough work to ensure that a lock operation will succeed after a device is lost. However, it is not guaranteed that the data of the video-memory resource will be accurate during the lock operation. It is guaranteed that no error code will be returned. This allows applications to be written without concern for device loss during a lock operation.

Resources

Resources can consume video memory. Because a lost device is disconnected from the video memory owned by the adapter, it is not possible to guarantee allocation of video memory when the device is lost. As a result, all resource creation methods allocate only dummy system memory. Because any video-memory resource must be destroyed before the device is resized, there is no issue of over-allocating video memory. These dummy surfaces allow lock and copy operations to appear to function normally until the application calls Device.Present and discovers that the device has been lost.

All video memory must be released before a device can be reset from a lost state to an operational state. This means that the application should release any swap chains created with SwapChain and any resources placed in Pool.Default memory. The application need not release resources in Managed or SystemMemory memory. Other state data is automatically destroyed by the transition to an operational state.

You are encouraged to develop applications with a single code path to respond to device loss. This code path is likely to be similar, if not identical, to the code path taken to initialize the device at startup.

Retrieved Data

Direct3D allows applications to validate texture and render states against single-pass rendering by the hardware using ValidateDevice. This method, which is typically invoked during initialization of the application, will return a DeviceLostException object if the device has been lost.

Direct3D also allows applications to copy generated or previously written images from video-memory resources to nonvolatile system-memory resources. Because the source images of such transfers might be lost at any time, Direct3D allows such copy operations to fail when the device is lost.

Copy operations, using UpdateSurface and GetFrontBufferData, can return a DeviceLostException object when the source object is in volatile memory (Pool.Default) and the destination object is in nonvolatile memory (SystemMemory or Managed). A GetFrontBufferData call can fail due to retrieving data from the primary surface. Note that these cases are the only instance of DeviceLostException that will be returned outside of the Present, TestCooperativeLevel, and Reset methods.

Programmable Shaders

In Microsoft DirectX® 9.0, Vertex Shader 1_1 Leave Site and Pixel Shader 1_X Leave Site do not need to be re-created after Device.Reset is called. They will be remembered. In previous versions of DirectX, when a device was lost, shaders had to be re-created.


Determining Hardware Support

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® provides the following methods to determine hardware support.

  • CheckDeviceFormat

    Used to verify whether a surface format can be used as a texture, whether a surface format can be used as a texture and a render target, or whether a surface format can be used as a depth stencil buffer. In addition, this method is used to verify depth buffer format support and depth stencil buffer format support.

  • CheckDeviceType

    Used to verify a device's ability to perform hardware acceleration, a device's ability to build a swap chain for presentation, or a device's ability to render to the current display format.

  • CheckDepthStencilMatch

    Used to verify whether a depth stencil buffer format is compatible with a render-target format. Note that before calling this method, the application should call CheckDeviceFormat on both the depth stencil and render target formats.


Processing Vertex Data
Note: This documentation is preliminary and is subject to change.

The Device class supports vertex processing in both software and hardware. In general, the device capabilities for software and hardware vertex processing are not identical. Hardware capabilities are variable, depending on the display adapter and driver, while software capabilities are fixed.

The following constants of the CreateFlags enumeration control vertex processing behavior for the hardware and reference devices.

  • SoftwareVertexProcessing
  • HardwareVertexProcessing
  • MixedVertexProcessing

The BehaviorFlags structure can also be used to control behavior using properties that access these same constant values.

Specify one of these flags when calling the Device constructor. The MixedVertexProcessing mixed-mode flag enables the device to perform both software and hardware vertex processing. Only one of these three vertex processing flags may be set for a device at any one time; they are mutually exclusive. Note that the HardwareVertexProcessing flag is required to be set when creating a pure device (PureDevice).

To avoid dual vertex processing capabilities on a single device, only the hardware vertex processing capabilities can be queried at run time. Software vertex processing capabilities are fixed and cannot be queried at run time.

You can consult the properties of the VertexProcessingCaps structure to determine the hardware vertex processing capabilities of the device. For software vertex processing the following VertexProcessingCaps capabilities are supported (which are all but two of the available capabilities).

  • SupportsDirectionalLights
  • SupportsLocalViewer
  • SupportsMaterialSource
  • SupportsPositionalLights
  • SupportsTextureGeneration
  • SupportsTweening

In addition, the following table lists the values that are set for device capabilities (Caps) for the software vertex processing mode.

Member | Software vertex processing capabilities
MaxActiveLights | Unlimited
MaxUserClipPlanes | 6
MaxVertexBlendMatrices | 4
MaxStreams | 16
MaxVertexIndex | int(0xffffffff)

Software vertex processing provides a guaranteed set of vertex processing capabilities, including an unbounded number of lights and full support for programmable vertex shaders. You can toggle between software and hardware vertex processing at any time when using the hardware device, the only device type that supports both hardware and software vertex processing. The only requirement is that vertex buffers used for software vertex processing must be allocated in system memory, typically with the SystemMemory constant of the Pool enumeration.

Note: The performance of hardware vertex processing is comparable to that of software vertex processing. For this reason, it is a good idea to provide, within a single device type, both hardware- and software-emulation functionality for vertex processing. This is not the case for rasterization, for which host processors are much slower than specialized graphics hardware. Thus both hardware- and software-emulated rasterization are not provided within a single device type. Software vertex processing is the only instance of functionality duplicated between the run time and the hardware (driver) within a single device. All other device capabilities represent potentially variable functionality provided by the driver.


Device-Supported Primitive Types

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D®devices can create and manipulate the following types of primitives.

  • Point Lists
  • Line Lists
  • Line Strips
  • Triangle Lists
  • Triangle Strips
  • Triangle Fans

You can render primitive types from a managed code application with any of the Device rendering methods.


Point Lists

Note: This documentation is preliminary and is subject to change.

A point list is a collection of vertices that are rendered as isolated points. Your application can use them in 3-D scenes for star fields, or dotted lines on the surface of a polygon.

The following illustration depicts a rendered point list.

Rendered point list

Your application can apply materials and textures to a point list. The colors in the material or texture appear only at the points drawn, and not anywhere between the points.


Line Lists

Note: This documentation is preliminary and is subject to change.

A line list is a list of isolated, straight line segments. Line lists are useful for such tasks as adding sleet or heavy rain to a 3-D scene. Applications create a line list by filling an array of vertices, and the number of vertices in a line list must be an even number greater than or equal to two.

The following illustration shows a rendered line list.

Rendered line list

You can apply materials and textures to a line list. The colors in the material or texture appear only along the lines drawn, not at any point in between the lines.


Line Strips

Note: This documentation is preliminary and is subject to change.

A line strip is a primitive that is composed of connected line segments. Your application can use line strips for creating polygons that are not closed. A closed polygon is a polygon whose last vertex is connected to its first vertex by a line segment. If your application makes polygons based on line strips, the vertices are not guaranteed to be coplanar.

The following illustration depicts a rendered line strip.

Rendered line strip


Triangle Lists

Note: This documentation is preliminary and is subject to change.

A triangle list is a list of isolated triangles. They might or might not be near each other. A triangle list must have at least three vertices. The total number of vertices must be divisible by three.

Use triangle lists to create an object that is composed of disjoint pieces. For instance, one way to create a force-field wall in a 3-D game is to specify a large list of small, unconnected triangles. Then apply a material and texture that appears to emit light to the triangle list. Each triangle in the wall appears to glow. The scene behind the wall becomes partially visible through the gaps between the triangles, as a player might expect when looking at a force field.

Triangle lists are also useful for creating primitives that have sharp edges and are shaded with Gouraud shading. See Face and Vertex Normal Vectors.

The following illustration depicts a rendered triangle list.

Rendered triangle list


Triangle Strips

Note: This documentation is preliminary and is subject to change.

A triangle strip is a series of connected triangles. Because the triangles are connected, the application does not need to repeatedly specify all three vertices for each triangle. For example, you need only seven vertices to define the following triangle strip.

The system uses vertices v1, v2, and v3 to draw the first triangle, v2, v4, and v3 to draw the second triangle, v3, v4, and v5 to draw the third, v4, v6, and v5 to draw the fourth, and so on. Notice that the vertices of the second and fourth triangles are out of order; this is required to make sure that all the triangles are drawn in a clockwise orientation.

Most objects in 3-D scenes are composed of triangle strips. This is because triangle strips can be used to specify complex objects in a way that makes efficient use of memory and processing time.

The following illustration depicts a rendered triangle strip.

Rendered triangle strip


Triangle Fans

Note: This documentation is preliminary and is subject to change.

A triangle fan is similar to a triangle strip, except that all the triangles share one vertex. This is shown in the following illustration.

The system uses vertices v2, v3, and v1 to draw the first triangle, v3, v4, and v1 to draw the second triangle, v4, v5, and v1 to draw the third triangle, and so on. When flat shading is enabled, the system shades the triangle with the color from its first vertex.

The following illustration depicts a rendered triangle fan.

Rendered triangle fan


Resources

Note: This documentation is preliminary and is subject to change.

Resources are the textures and buffers that are used to render a scene. Applications need to create, load, copy, and use resources. This section gives a brief introduction to resources and the steps and methods used by applications when working with resources.

All resources, including the geometry resources IndexBuffer and VertexBuffer, inherit from the Resource class. The texture resources, Texture, CubeTexture, and Volume, also inherit from the BaseTexture class.

Additional information is divided into the following topics.

  • Resource Properties
  • Manipulating Resources
  • Locking Resources
  • Managing Resources
  • Application-Managed Resources and Allocation Strategies


Resource Properties

Note: This documentation is preliminary and is subject to change.

All resources share the following properties, which are specified in enumerations by the same or similar name.

Property | Enumeration | Description
Usage | Usage | The way a resource is used, for example, as a texture or a render target.
Format | Format | The format of the data, for example, the pixel format of a 2-D surface.
Pool | Pool | The type of memory where the resource is allocated.
Type | ResourceType | The type of resource, for example, a vertex buffer or render target.

Resource uses are enforced. An application that will use a resource in a certain operation must specify that operation at resource-creation time.

The RTPatches, NPatches, and Points constants of the Usage enumeration indicate to the driver that the data in these buffers is likely to be used for triangular or grid patches, N-patches, or point sprites, respectively. These flags are provided in case the hardware cannot perform these operations without host processing. Therefore, the driver should typically allocate these surfaces in system memory so that the CPU can access them. If the driver can perform these operations entirely in hardware, it can allocate these surfaces in video or accelerated graphics port (AGP) memory to avoid a host copy and improve performance at least twofold. Note that the information provided by these flags is not absolutely required. A driver can detect that such operations are being performed on the data, and it will move the buffer back to system memory for subsequent frames.

A pool cannot be mixed for different objects contained in a single resource, that is, mip levels in a mipmap, and when a pool is chosen for a resource, the pool cannot be changed.

The resource types are set implicitly at run time when the application calls a resource constructor such as CubeTexture. Applications can query these types at run time; however, it is expected that most scenarios will not require run-time type checking.


Manipulating Resources

Note: This documentation is preliminary and is subject to change.

Your application manipulates resources in order to render a scene. First, the application creates texture resources by initializing CubeTexture, Texture, or VolumeTexture objects. Note that these texture classes all inherit from the BaseTexture base class.

The texture objects returned are containers for surfaces or volumes; these containers are generically known as buffers. The buffers owned by the resource inherit the usages, format, and pool of the resource but have their own type. For more information, see Resource Properties.

The application gains access to the contained surfaces, for the purpose of loading artwork, by calling the CubeTexture.LockRectangle, Texture.LockRectangle, or VolumeTexture.LockBox methods. For details, see Locking Resources. The lock methods take arguments denoting the contained surface and return pointers to the pixels. Examples of such arguments are the mipmap sub-level or cube face of the texture. The typical application never uses a surface object directly.

In addition, the application creates geometry-oriented resources when it initializes IndexBuffer or VertexBuffer objects. Your application locks and fills the buffer resources by calling the IndexBuffer.Lock or VertexBuffer.Lock methods.

If your application is allowing the Microsoft® Direct3D® run time to manage these resources, then the resource creation process ends here. Otherwise, the application manages the promotion of system memory resources to device-accessible resources, where the hardware accelerator can use them, by calling the UpdateTexture method.

To present images rendered from resources, the application also needs color and depth stencil buffers. For typical applications, the color buffer is owned by the device's swap chain, which is a collection of back buffer surfaces and is implicitly created with the device. Depth stencil surfaces can be implicitly created, or explicitly created by using the CreateDepthStencilSurface method. The application associates a device and its depth and color buffer with a call to SetRenderTarget.


Locking Resources

Note: This documentation is preliminary and is subject to change.

Locking a resource means granting CPU access to its storage. The locking procedure is defined by the constants of the LockFlags enumeration. However, these locking flags are only hints, and the run time does not check that applications are following the functionality specified by these flags.

An application that specifies LockFlags.ReadOnly but then writes to the resource should expect undefined results. In general, working against locking flags, including the locking usage flags, is not guaranteed to work in later releases and may incur a significant performance penalty.

A lock operation is followed by an unlock operation. For example, after locking a texture, the application subsequently relinquishes direct access to locked textures by unlocking them. In addition to granting processor access, any other operations involving that resource are serialized for the duration of a lock. Only a single lock for a resource is allowed, even for non-overlapping regions, and no accelerator operations on a surface can be ongoing while a lock operation is outstanding on that surface.

Each resource class has methods for locking the contained buffers. Each texture resource can also lock a sub-portion of that resource. Two-dimensional resources (surfaces) allow the locking of sub-rectangles, and volume resources allow the locking of sub-volumes or boxes. Each lock method returns a System.Array Leave Site that contains values representing the distances between rows or planes of data, depending on the resource type. The returned array always begins with the top-left byte in the locked sub-regions.

When working with index and vertex buffers, you can make multiple lock calls; however, you must ensure that the number of lock calls matches the number of unlock calls.

The Microsoft® DirectX® Transform set of compressed texture formats, which store pixels in encoded 4x4 blocks, can only be locked on 4x4 boundaries.


Managing Resources

Note: This documentation is preliminary and is subject to change.

Resource management is the process in which resources are promoted from system-memory storage to device-accessible storage and discarded from device-accessible storage. The Microsoft® Direct3D® run time has its own management algorithm based on a least-recently-used priority technique. Direct3D switches to a most-recently-used priority technique when it detects that more resources than can coexist in device-accessible memory are used in a single frame, between Device.BeginScene and EndScene calls.

Use the Managed constant of the Pool enumeration at creation time to specify a managed resource. Managed resources persist through transitions between the lost and operational states of the device. The device can be restored with a call to Reset, and such resources continue to function normally without being reloaded with artwork. However, if the device must be destroyed and re-created, all resources created using Managed must be re-created.

Use the Default flag at creation time to specify that a resource is to be placed in the default pool. Resources in the default pool do not persist through transitions between the lost and operational states of the device. These resources must be released before calling Reset and must then be re-created.

For more information on the lost state of a device, see Lost Devices.

Note that resource management is not supported for all types and usages. For example, objects created with the RenderTarget flag are not supported. In addition, resource management is not recommended for objects whose contents are changing with high frequency. For example, a managed vertex buffer that changes every frame can significantly degrade performance for some hardware. However, this is not a problem for texture resources.


Application-Managed Resources and Allocation Strategies

Note: This documentation is preliminary and is subject to change.

Dynamic vertex buffers are intended for rendering dynamic geometry and data pulled in from binary space partitioned (BSP) trees or other visibility data structures. This type of rendering can be accomplished by pre-allocating buffers of the desired format with the Dynamic constant of the Usage enumeration. These resources are then parceled out to support application needs by a resource manager within the application.

Because there are only a few different vertex strides that an application will use simultaneously, and a different vertex buffer is required only for each unique stride, the total number of dynamic vertex buffers is small. When managing dynamic resources in this way, it is important to ensure that high-frequency demands on the resources do not significantly decrease application performance.

Managed vertex-buffer or index-buffer resources cannot be declared dynamic by setting Dynamic at creation time. This would require an additional copy for every modification to the vertex buffer contents.

When using resources managed by both Microsoft® Direct3D® and applications, allocate application-managed resources in Pool.Default memory prior to creating Direct3D-managed resources. This enables the memory manager to maintain an accurate count of available memory.


Transforms

Note: This documentation is preliminary and is subject to change.

Transformations are used to convert object geometry from one coordinate space to another. The most common transformations are done using matrices. A matrix is an essential tool for holding the transformation values and applying them to the data. The topics below introduce matrices, and explain how to use them to generate the world, view, and projection transformations.

  • View Transformation
  • World Transformation
  • Matrices
  • Projection Transformation


View Transformation

Note: This documentation is preliminary and is subject to change.

This section introduces the basic concepts of the view transformation and provides details on how to set up a view transformation matrix in a Microsoft® Direct3D® application. The information is organized into the following sections.

  • What Is a View Transformation?
  • Setting Up a View Matrix

What Is a View Transformation?

The view transformation locates the viewer in world space, transforming vertices into camera space. In camera space, the camera, or viewer, is at the origin, looking in the positive z-direction. Recall that Direct3D uses a left-handed coordinate system, so z is positive into a scene. The view matrix relocates the objects in the world around a camera's position—the origin of camera space—and orientation.

There are many ways to create a view matrix. In all cases, the camera has some logical position and orientation in world space that is used as a starting point to create a view matrix that will be applied to the models in a scene. The view matrix translates and rotates objects to place them in camera space, where the camera is at the origin. One way to create a view matrix is to combine a translation matrix with rotation matrices for each axis. In this approach, the following general matrix formula applies.

In this formula, V is the view matrix being created, T is a translation matrix that repositions objects in the world, and Rx through Rz are rotation matrices that rotate objects along the x-, y-, and z-axis. The translation and rotation matrices are based on the camera's logical position and orientation in world space. So, if the camera's logical position in the world is <10,20,100>, the aim of the translation matrix is to move objects -10 units along the x-axis, -20 units along the y-axis, and -100 units along the z-axis. The rotation matrices in the formula are based on the camera's orientation, in terms of how much the axes of camera space are rotated out of alignment with world space. For example, if the camera mentioned earlier is pointing straight down, its z-axis is 90 degrees (pi/2 radians) out of alignment with the z-axis of world space, as shown in the following illustration.

The rotation matrices apply rotations of equal, but opposite, magnitude to the models in the scene. The view matrix for this camera includes a rotation of -90 degrees around the x-axis. The rotation matrix is combined with the translation matrix to create a view matrix that adjusts the position and orientation of the objects in the scene so that their top is facing the camera, giving the appearance that the camera is above the model.

Setting Up a View Matrix

The Matrix.LookAtLH and Matrix.LookAtRH helper functions create a view matrix based on the camera location and a look-at point.

The following C# code example creates a view matrix for left-handed coordinates.

          [C#]

Vector3 eye = new Vector3(0,3,-5);
Vector3 at = new Vector3(0,0,0);
Vector3 up = new Vector3(0,1,0);

Matrix viewMatrix = Matrix.LookAtLH(eye,at,up);

Direct3D uses the world and view matrices that you set to configure several internal data structures. Each time you set a new world or view matrix, the system recalculates the associated internal structures. Setting these matrices frequently is computationally time-consuming. You can minimize the number of required calculations by concatenating your world and view matrices into a world-view matrix that you set as the world matrix, and then setting the view matrix to the identity. Keep cached copies of individual world and view matrices so that you can modify, concatenate, and reset the world matrix as needed. For clarity, the samples rarely employ this optimization.


World Transformation

Note: This documentation is preliminary and is subject to change.

This discussion of the world transformation introduces basic concepts and provides details on how to set up a world transformation matrix in a Microsoft® Direct3D® application.

What Is a World Transformation?

A world transformation changes coordinates from model space, where vertices are defined relative to a model's local origin, to world space, where vertices are defined relative to an origin common to all of the objects in a scene. In essence, the world transformation places a model into the world; hence its name. The following diagram illustrates the relationship between the world coordinate system and a model's local coordinate system.

World Coordinate System

The world transformation can include any combination of translations, rotations, and scalings. For a discussion of the mathematics of transformations, see 3-D Transformations.

Setting Up a World Matrix

As with any other transformation, you create the world transformation by concatenating a series of transformation matrices into a single matrix that contains the sum total of their effects. In the simplest case, when a model is at the world origin and its local coordinate axes are oriented the same as world space, the world matrix is the identity matrix. More commonly, the world matrix is a combination of a translation into world space and possibly one or more rotations to turn the model as needed.

The following C# code example, from a fictitious 3-D model class written in C#, creates a world matrix that includes three rotations to orient a model and a translation to relocate it relative to its position in world space.

          [C#]

public class ModelClass
{
   private float xPos=0;
   private float yPos=0;
   private float zPos=0;

   private float Pitch=0;
   private float Yaw=0;
   private float Roll=0;

   //...Other model properties and methods

   public Matrix MakeWorldMatrix(Matrix worldMatrix)
   {
      worldMatrix.Translate(xPos,yPos,zPos);

      Matrix matRot = Matrix.Identity;

      matRot.RotateYawPitchRoll(Yaw,Pitch,Roll);

      Matrix.Multiply(matRot, worldMatrix);

      return worldMatrix;

   }
}

After you prepare the world transformation matrix, call the SetTransform method to set it, specifying the TransformType.World value for the first parameter. Alternately, you can pass the world transformation matrix to the Device.Transform.World property.

Note: Direct3D uses the world and view matrices that you set to configure several internal data structures. Each time you set a new world or view matrix, the system recalculates the associated internal structures. Setting these matrices frequently—for example, thousands of times per frame—is computationally time-consuming. You can minimize the number of required calculations by concatenating your world and view matrices into a world-view matrix that you set as the world matrix, and then setting the view matrix to the identity. Keep cached copies of individual world and view matrices so that you can modify, concatenate, and reset the world matrix as needed. For clarity, Direct3D samples in this documentation rarely employ this optimization.


Matrices

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® uses matrices to perform 3-D transformations. This section explains how matrices create 3-D transformations, describes some common uses for transformations, and details how you can combine matrices to produce a single matrix that encompasses multiple transformations. Information is divided into the following topics.

  • 3-D Transformations
  • Translation and Scaling
  • Rotation
  • Matrix Concatenation


3-D Transformations

Note: This documentation is preliminary and is subject to change.

In applications that work with 3-D graphics, geometrical transformations can be used to do the following.

  • Express the location of an object relative to another object.
  • Rotate and size objects.
  • Change viewing positions, directions, and perspectives.

You can transform any point (x,y,z) into another point (x', y', z') using a 4 x 4 matrix.

Perform the following operations on (x, y, z) and the matrix to produce the point (x', y', z').

The most common transformations are translation, rotation, and scaling. You can combine the matrices that produce these effects into a single matrix to calculate several transformations at once. For example, you can build a single matrix to translate and rotate a series of points. For more information, see Matrix Concatenation.

Matrices are written in row-column order. A matrix that evenly scales vertices along each axis, a process known as uniform scaling, is represented by the following matrix using mathematical notation.

Microsoft® Direct3D® declares matrices as a two-dimensional array, using the Matrix structure. The following C# code example shows how to create a Matrix structure to act as a uniform scaling matrix.

          [C#]

// In this example, s is a variable of type float.
Matrix scale = new Matrix();

scale.M11=s;    scale.M12=0.0f; scale.M13=0.0f; scale.M14=0.0f;
scale.M21=0.0f; scale.M22=s;    scale.M23=0.0f; scale.M24=0.0f;
scale.M31=0.0f; scale.M32=0.0f; scale.M33=s;    scale.M34=0.0f;
scale.M41=0.0f; scale.M42=0.0f; scale.M43=0.0f; scale.M44=1.0f;


Translation and Scaling

Note: This documentation is preliminary and is subject to change.

Translation

The following transformation translates the point (x, y, z) to a new point (x', y', z').

You can manually create a translation matrix in managed code. The following C# code example shows the source code for a function that creates a matrix to translate vertices.

          [C#]

private Matrix TranslateMatrix(float dx, float dy, float dz)
{
   Matrix ret;

   ret = Matrix.Identity;

   ret.M41 = dx;
   ret.M42 = dy;
   ret.M43 = dz;

   return ret;
}

For convenience, managed the Microsoft® Direct3D® supplies the Translation method.

Scaling

The following transformation scales the point (x, y, z) by arbitrary values in the x-, y-, and z-directions to a new point (x', y', z').


Rotation

Note: This documentation is preliminary and is subject to change.

The transformations described here are for left-handed coordinate systems, and so might be different from transformation matrices that you have seen elsewhere. For more information, see 3-D Coordinate Systems.

The following transformation rotates the point (x, y, z) around the x-axis, producing a new point (x', y', z').

Matrix X Rotation

The following transformation rotates the point around the y-axis.

Matrix Y Rotation

The following transformation rotates the point around the z-axis.

Matrix Z Rotation

In these example matrices, the Greek letter theta (?) stands for the angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

In a managed application, use the Matrix.RotationX, Matrix.RotationY, and Matrix.RotationZ methods to create rotation matrices. The following C# code example demonstrates how the Matrix.RotationX method performs a rotation.

          [C#]

private Matrix MatrixRotationX(float angle)
{
   double sin, cos;
   sin = Math.Sin(angle);
   cos = Math.Cos(angle);

   Matrix ret;
   ret.M11 = 1.0f; ret.M12 = 0.0f; ret.M13 = 0.0f; ret.M14 = 0.0f;
   ret.M21 = 0.0f; ret.M22 = (float)cos; ret.M23 = (float)sin; ret.M24 = 0.0f;
   ret.M31 = 0.0f; ret.M32 = (float)-sin; ret.M33 = (float)cos; ret.M34 = 0.0f;
   ret.M41 = 0.0f; ret.M42 = 0.0f; ret.M43 = 0.0f; ret.M44 = 1.0f;
   return ret;
}


Matrix Concatenation

Note: This documentation is preliminary and is subject to change.

One advantage of using matrices is that you can combine the effects of two or more matrices by multiplying them. This means that, to rotate a model and then translate it to some location, you do not need to apply two matrices. Instead, you multiply the rotation and translation matrices to produce a composite matrix that contains all of their effects. This process, called matrix concatenation, can be written with the following formula.

In this formula, C is the composite matrix being created, and M1 through Mn are the individual transformations that matrix C contains. In most cases, only two or three matrices are concatenated, but there is no limit.

Use the Matrix.Multiply method to perform matrix multiplication.

The order in which the matrix multiplication is performed is crucial. The preceding formula reflects the left-to-right rule of matrix concatenation. That is, the visible effects of the matrices that you use to create a composite matrix occur in left-to-right order. A typical world transformation matrix is shown in the following example. Imagine that you are creating the world transformation matrix for a stereotypical flying saucer. You would probably want to spin the flying saucer around its center - the y-axis of model space - and translate it to some other location in your scene. To accomplish this effect, you first create a rotation matrix, and then multiply it by a translation matrix, as shown in the following formula.

World Space Explanation

In this formula, Ry is a matrix for rotation about the y-axis, and Tw is a translation to some position in world coordinates.

The order in which you multiply the matrices is important because, unlike multiplying two scalar values, matrix multiplication is not commutative. Multiplying the matrices in the opposite order has the visual effect of translating the flying saucer to its world space position, and then rotating it around the world origin.

No matter what type of matrix you are creating, remember the left-to-right rule to ensure that you achieve the expected effects.


Direct3D Rendering

Note: This documentation is preliminary and is subject to change.

Applications use the DrawPrimitive family of methods to render a 3-D scene.

  • Shading
  • Presenting a Scene
  • Rendering Primitives
  • Depth Buffers
  • Fog
  • Alpha Blending


Shading

Note: This documentation is preliminary and is subject to change.

This section describes techniques used in Microsoft® Direct3D® to control the shading of 3-D polygons.

  • Shading Modes
  • Comparing Shading Modes
  • Setting the Shading Mode


Shading Modes

Note: This documentation is preliminary and is subject to change.

The shading mode used to render a polygon has a profound effect on its appearance. Shading modes determine the intensity of color and lighting at any point on a polygon face. Microsoft® Direct3D® supports two shading modes: flat and Gouraud.

Flat Shading

In the flat shading mode, the Direct3D rendering pipeline renders a polygon, using the color of the polygon material at its first vertex as the color for the entire polygon. 3-D objects that are rendered with flat shading have visibly sharp edges between polygons if they are not coplanar.

The following figure shows a teapot rendered with flat shading. The outline of each polygon is clearly visible. Flat shading is the fastest form of shading.

Rough image of teapot

Gouraud Shading

When Direct3D renders a polygon using Gouraud shading, it computes a color for each vertex by using the vertex normal and lighting parameters. Then, it interpolates the color across the face of the polygons. The interpolation is done in a linear manner. For example, if the red component of the color of vertex 1 is 0.8 and the red component of vertex 2 is 0.4, using the Gouraud shading mode and the RGB color model, the Direct3D lighting module assigns a red component of 0.6 to the pixel at the midpoint of the line between these vertices.

The following figure demonstrates Gouraud shading. This teapot is composed of many flat, triangular polygons. However, Gouraud shading makes the surface of the object appear curved and smooth.

Smooth image of teapot

Gouraud shading also can be used to display objects with sharp edges.

For more information, see Face and Vertex Normal Vectors.


Comparing Shading Modes

Note: This documentation is preliminary and is subject to change.

In flat shading mode, the pyramid below is displayed with a sharp edge between adjoining faces. In Gouraud shading mode, however, shading values are interpolated across the edge, and the final appearance is of a curved surface.

Automatic face normals

Gouraud shading lights flat surfaces more realistically than flat shading. A face in flat shading mode is a uniform color, but Gouraud shading enables light to fall across a face more correctly. This effect is particularly obvious if there is a nearby point source.

Gouraud shading smooths the sharp edges between polygons that are visible with flat shading. However, it can result in Mach bands. An application can reduce the appearance of Mach bands by increasing the number of polygons in an object, increasing screen resolution, or increasing the color depth of the application.

Gouraud shading can miss some details. One example is shown in the following illustration, in which a spotlight is completely contained within a polygon face.

In this case, Gouraud shading, which interpolates between vertices, would miss the spotlight altogether, and the face would be rendered as though the spotlight did not exist.


Setting the Shading Mode

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® enables one shading mode to be selected at a time. Gouraud shading is selected by default. In Microsoft DirectX® 9.0 for Managed Code, the shading mode can be changed by setting the ShadeMode property of the RenderStateManager object that is returned by the Device.RenderState property.

The following C# code example illustrates how the current shading mode of a Direct3D application can be set to either flat or Gouraud.

          [C#]

// This code example assumes that device is already initialized .
// Set to flat shading.

device.RenderState.ShadeMode = ShadeMode.Flat;

// Set to Gouraud shading. This is the default for Direct3D.
device.RenderState.ShadeMode = ShadeMode.Gouraud;


Presenting a Scene

Note: This documentation is preliminary and is subject to change.

This section introduces the presentation application programming interfaces (APIs) and discusses the issues involved in presenting a scene to the display.

Information is divided into the following topics.

  • Introduction to Presenting a Scene
  • Multiple Views in Windowed Mode
  • Multiple-Monitor Operations
  • Manipulating the Depth Buffer
  • Accessing the Color Front Buffer


Introduction to Presenting a Scene

Note: This documentation is preliminary and is subject to change.

The presentation application programming interfaces (APIs) are a set of methods that control the state of the device that affects what the user sees on the monitor. The set includes methods for setting display modes as well as once-per-frame methods that are used to present images to the user.

  • Device.Present
  • Device.Reset
  • Device.GetGammaRamp
  • Device.SetGammaRamp
  • Device.GetRasterStatus

Familiarity with the following terms is necessary to understand the presentation APIs.

  • front buffer. A rectangle of memory that is translated by the graphics adapter and displayed on the monitor or other output device.
  • back buffer. A surface whose contents can be promoted to the front buffer.
  • swap chain. A collection of back buffers that can be serially presented to the front buffer. Typically, a full-screen swap chain presents subsequent images with the flipping device driver interface (DDI), and a windowed swap chain presents images with the blitting DDI.

Because Microsoft® Direct3D® for Microsoft DirectX® 9.0 has one swap chain as a property of the device, there is always at least one swap chain per device. The Device class includes a set of methods that manipulate the implicit swap chain and are a copy of the swap chain's own interface. Applications can create additional swap chains; however, this is not necessary for the typical single-window or full-screen application.

The front buffer is not directly exposed in the Direct3D API for DirectX 9.0. As a result, applications cannot lock or render to the front buffer. For more information, see Accessing the Color Front Buffer.

Note: DirectX 7.0 provides a number of presentation APIs that are called together. A good example of this is the IDirectDraw7::SetCooperativeLevel, IDirectDraw7::SetDisplayMode, and IDirectDraw7::CreateSurface sequence. Additionally, the IDirectDrawSurface7::Flip and IDirectDrawSurface7::Blt methods signal the transport of rendered frames to the monitor. DirectX 9.0 collapses these groups of APIs into two main methods, Reset and Present. Reset subsumes SetCooperativeLevel, SetDisplayMode, CreateSurface, and some of the parameters to flip. Present subsumes flip and the presentation uses of blit.

A call to Manager represents an implicit reset of the device. The DirectX 9.0 API has no notion of a primary surface; it is not possible to create an object that represents the primary surface because it is considered to be an internal property of the device.

Gamma ramps are associated with a swap chain and are manipulated with the GetGammaRamp and SetGammaRamp methods.


Multiple Views in Windowed Mode

Note: This documentation is preliminary and is subject to change.

In addition to the swap chain that is owned and manipulated through the Device object, an application can use the SwapChain.SwapChain method to create additional swap chains for presenting multiple views from the same device.

Typically, the application creates one swap chain per view, and it associates each swap chain with a particular view. The application renders images in the back buffers of each swap chain, and then uses the SwapChain.Present method to present them individually. Note that only one swap chain at a time can be full-screen on each adapter.


Multiple-Monitor Operations

Note: This documentation is preliminary and is subject to change.

When a device is successfully reset (with Device.Reset) or created (with Device.Device) in full-screen operations, the Microsoft® Direct3D® object that created the device is marked as owning all adapters on that system. This state is known as exclusive mode, and is owned by the Direct3D object. Exclusive mode means that devices created by any other Direct3D object can neither assume full-screen operations nor allocate video memory. In addition, when a Direct3D object assumes exclusive mode, all devices other than the one that went full-screen are placed in lost state. For more information, see Lost Devices.

Along with exclusive mode, the Direct3D object is informed of the focus window that the device will use. Exclusive mode is released when the final full-screen device owned by that Direct3D object is either reset to windowed mode or destroyed.

Devices can be divided into two categories when a Direct3D object owns exclusive mode. The first category of devices have the following characteristics.

  • They are created by the same Direct3D object that created the full-screen device.
  • They have the same focus window as the full-screen device.
  • They represent a different adapter from any full-screen device.

Devices in this category have no restrictions concerning their ability to be reset or created, and they are not placed in lost state. They can even be put into full-screen mode.

Devices that do not fall into the first category—those that are created by another Direct3D object, created with a different focus window, and created for an adapter with a device that is already full-screen—cannot be reset and remain in lost state until the exclusive mode is lost. As a result, a multiple-monitor application can place several devices in full-screen mode, but only if all of them are for different adapters, were created by the same Direct3D object, and share the same focus window.


Manipulating the Depth Buffer

Note: This documentation is preliminary and is subject to change.

Depth buffers are associated with the device. Applications are required to move the depth buffers when they set render targets. The Device.DepthStencilSurface property is used to manipulate depth buffers.


Accessing the Color Front Buffer

Note: This documentation is preliminary and is subject to change.

Accessing the front buffer is allowed through the Device.GetFrontBufferData method. This method is the only way to get a screen shot of an anti-aliased scene.


Rendering Primitives

Note: This documentation is preliminary and is subject to change.

The following topics provide information about drawing primitives in an application.

  • Vertex Data Streams
  • Setting the Stream Source
  • Rendering from Vertex and Index Buffers
  • Rendering from User Memory Pointers


Vertex Data Streams

Note: This documentation is preliminary and is subject to change.

The rendering interfaces for Microsoft® Direct3D® consist of methods that render primitives from vertex data stored in one or more data buffers. Vertex data consists of vertex elements that are combined to form vertex components. Vertex elements—the smallest unit of a vertex—represent entities such as position, normal, or color.

Vertex components are one or more vertex elements that are stored contiguously (interleaved per vertex) in a single memory buffer. A complete vertex consists of one or more components, where each component is in a separate memory buffer. To render a primitive, multiple vertex components are read and assembled so that complete vertices are available for vertex processing.

The illustration below shows the process of rendering primitives using vertex components.

Rendering primitives consists of two steps: setting up one or more vertex component streams, and then invoking a Device.DrawPrimitives method to render from those streams. Identification of vertex elements within these component streams is specified by the vertex shader.

The Device.DrawPrimitives methods specify an offset in the vertex data streams so that an arbitrary contiguous subset of the primitives within one set of vertex data can be rendered with each draw invocation. This enables changes to the device rendering state between groups of primitives that are rendered from the same vertex buffers.

Both indexed and nonindexed drawing methods are supported. For more information, see Rendering from Vertex and Index Buffers.


Setting the Stream Source

Note: This documentation is preliminary and is subject to change.

The Device.SetStreamSource method binds a vertex buffer to a device data stream, creating an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The actual references to the stream data do not occur until a drawing method, such as Device.DrawPrimitives, is called.

A stream is defined as a uniform array of component data, where each component consists of one or more elements that represent a single entity such as position, normal, or color. The Stride parameter of the Device.SetStreamSource method specifies the size of the component in bytes.


Rendering from Vertex and Index Buffers

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® supports both indexed and nonindexed drawing methods. The indexed methods use a single set of indices for all vertex components. Vertex data is stored in vertex buffers, and index data is stored in index buffers. Listed below are a few common scenarios for drawing primitives using vertex and index buffers. These examples compare the use of Device.DrawPrimitives and Device.DrawIndexedPrimitives.

Scenario 1: Drawing Two Triangles without Indexing

Suppose you want to draw the following quad.

Two Triangles without Indexing

If you use the Triangle List primitive type to render the two triangles, each triangle is stored as three individual vertices, resulting in a vertex buffer similar to this.

Vertex Buffer of Two Triangles without Indexing

To perform the drawing call, draw two triangles, starting at location 0 within the vertex buffer. If culling is enabled, the order of the vertices is important. This example assumes the default counterclockwise culling state, so visible triangles must be drawn in clockwise order. The Triangle List primitive type simply reads three vertices in linear order from the buffer for each triangle, so the following C# call draws triangles (0, 1, 2) and (3, 4, 5).

          [C#]

Device.DrawPrimitives(PrimitiveType.TriangleList,   // PrimitiveType
                      0,                            // StartVertex
                      2);                           // PrimitiveCount

Scenario 2: Drawing Two Triangles with Indexing

As you will notice, the vertex buffer contains duplicate data in locations 0 and 4, 2 and 5. This makes sense because the two triangles share two common vertices. This duplicate data is wasteful, and the vertex buffer can be compressed by using an index buffer. A smaller vertex buffer reduces the amount of vertex data that must be sent to the graphics adapter. Even more importantly, using an index buffer allows the adapter to store vertices in a vertex cache; if the primitive being drawn contains a recently used vertex, that vertex can be fetched from the cache instead of reading it from the vertex buffer, which results in a significant performance increase.

An index buffer 'indexes' into the vertex buffer so that each unique vertex needs to be stored only once in the vertex buffer. Here is an indexed approach to the drawing scenario above.

Index and Vertex Buffer of Two Triangles with Indexing

The index buffer stores VB Index values, which reference a particular vertex within the vertex buffer. A vertex buffer can be thought of as an array of vertices, so the VB Index is simply the index into the vertex buffer for the target vertex. Similarly, an IB Index is an index into the index buffer. This can get very confusing very quickly if you are not careful, so be sure you are clear on the vocabulary being used: VB Index values index into the vertex buffer, IB Index values index into the index buffer, and the index buffer itself stores VB Index values.

The drawing call is shown below. The meanings of all of the arguments are discussed at length for the next drawing scenario; for now, just note that this call is again instructing Direct3D to render a triangle list that contains two triangles, starting at location 0 within the index buffer. The following C# call draws the same two triangles in the exact same order as before, ensuring a proper clockwise orientation.

          [C#]

Device.DrawIndexedPrimitives(PrimitiveType.TriangleList,  // PrimitiveType
                             0,                           // BaseVertexIndex
                             0,                           // MinIndex
                             4,                           // NumVertices
                             0,                           // StartIndex
                             2);                          // PrimitiveCount

Scenario 3: Drawing One Triangle with Indexing

Suppose now that you want to draw only the second triangle, but you want to use the same vertex buffer and index buffer you used when drawing the entire quad.

Index and Vertex Buffer for Drawing One Triangle with Indexing

For this drawing call, the first IB Index used is 3; this value is called the StartIndex. The lowest VB Index used is 0; this value is called the MinIndex. Even though only three vertices are required to draw the triangle, those three vertices are spread across four adjacent locations in the vertex buffer; the number of locations within the contiguous block of vertex buffer memory required for the drawing call is called NumVertices, and is set to 4 in this call. The MinIndex and NumVertices values are really just hints to help Direct3D optimize memory access during software vertex processing, and could simply be set to include the entire vertex buffer at the price of performance.

Here is the drawing C# call for the single triangle case. The meaning of the BaseVertexIndex argument will be explained next.

          [C#]

Device.DrawIndexedPrimitives(PrimitiveType.TriangleList,  // PrimitiveType
                             0,                           // BaseVertexIndex
                             0,                           // MinIndex
                             4,                           // NumVertices
                             3,                           // StartIndex
                             1);                          // PrimitiveCount

Scenario 4: Drawing One Triangle with Offset Indexing

BaseVertexIndex is a value that is effectively added to every VB Index stored in the index buffer. For example, if a value of 50 had been passed in for BaseVertexIndex during the previous call, that would functionally be the same as using the following index buffer for the duration of the Device.DrawIndexedPrimitives call.

Index Buffer of One Triangle with Offset Indexing

This value is rarely set to anything other than 0, but it can be useful if you want to decouple the index buffer from the vertex buffer: If, when filling in the index buffer for a particular mesh, the location of the mesh within the vertex buffer is not yet known, you can simply pretend that the mesh vertices will be located at the start of the vertex buffer. When it is time to make the draw call, simply pass the actual starting location as the BaseVertexIndex.

This technique also can be used when drawing multiple instances of a mesh using a single index buffer; for example, if the vertex buffer contained two meshes with identical draw orders but slightly different vertices (perhaps different diffuse colors or texture coordinates), both meshes could be drawn by using different values for BaseVertexIndex. Taking this concept one step further, you could use one index buffer to draw multiple instances of a mesh, each contained in a different vertex buffer, simply by cycling which vertex buffer is active and adjusting the BaseVertexIndex as needed. Note that the BaseVertexIndex value also is automatically added to the MinIndex argument, which makes sense when you see how it is used.

Suppose now that you again want to draw only the second triangle of the quad using the same index buffer as before; however, a different vertex buffer is being used in which the quad is located at VB Index 50. The relative order of the quad vertices remains unchanged, and only the starting location within the vertex buffer is different. The index buffer and vertex buffer would look like this.

Index and Vertex Buffer of One Triangle with Offset Indexing

Here is the appropriate draw C# call; note that BaseVertexIndex is the only value that has changed from the previous scenario:

          [C#]

Device.DrawIndexedPrimitives(PrimitiveType.TriangleList,  // PrimitiveType
                             50,                          // BaseVertexIndex
                             0,                           // MinIndex
                             4,                           // NumVertices
                             3,                           // StartIndex
                             1);                          // PrimitiveCount


Rendering from User Memory Pointers

Note: This documentation is preliminary and is subject to change.

A secondary set of rendering interfaces supports passing vertex and index data directly from user memory pointers. These interfaces support a single stream of vertex data only. For more information, see the following reference topics.

  • Device.DrawUserPrimitives
  • Device.DrawIndexedUserPrimitives

These methods render with data specified by user memory pointers rather than vertex and index buffers.


Depth Buffers

Note: This documentation is preliminary and is subject to change.

A depth buffer, often called a z-buffer or a w-buffer, is a property of a device that stores depth information to be used by Microsoft® Direct3D®. When Direct3D renders a 3-D scene to a target surface, it can use the memory in an associated depth-buffer surface as a workspace to determine how the pixels of rasterized polygons occlude one another. Direct3D uses an offscreen Direct3D surface as the target to which final color values are written. The depth-buffer surface that is associated with the render target surface is used to store depth information that tells Direct3D how deep each visible pixel is in the scene.

When a 3-D scene is rasterized with depth buffering enabled, each point on the rendering surface is tested. The values in the depth buffer can be a point's z-coordinate or its homogeneous w-coordinate—from the point's (x,y,z,w) location in projection space. A depth buffer that uses z values is often called a z-buffer, and one that uses w values is called a w-buffer. Each type of depth buffer has advantages and disadvantages, which are discussed later.

At the beginning of the test, the depth value in the depth buffer is set to the largest possible value for the scene. The color value on the rendering surface is set to either the background color value or the color value of the background texture at that point. Each polygon in the scene is tested to see if it intersects with the current coordinate (x,y) on the rendering surface. If it does, the depth value—which will be the z coordinate in a z-buffer, and the w coordinate in a w-buffer—at the current point is tested to see if it is smaller than the depth value stored in the depth buffer. If the depth of the polygon value is smaller, it is stored in the depth buffer, and the color value from the polygon is written to the current point on the rendering surface. If the depth value of the polygon at that point is larger, the next polygon in the list is tested. This process is shown in the following illustration.

Note: Although most applications do not use this feature, it is possible to change the comparison that Direct3D uses to determine which values are placed in the depth buffer and subsequently the render-target surface. To do so, change the value for the RenderStateManager.ZBufferFunction property.

Nearly all 3-D accelerators on the market support z-buffering, making z-buffers the most common type of depth buffer today. However ubiquitous, z-buffers have their drawbacks. Due to the mathematics involved, the generated z values in a z-buffer tend not to be distributed evenly across the z-buffer range (typically 0.0 to 1.0, inclusive). Specifically, the ratio between the far and near clipping planes strongly affects how unevenly z values are distributed. Using a far-plane distance to near-plane distance ratio of 100, 90 percent of the depth buffer range is spent on the first 10 percent of the scene depth range. Typical applications for entertainment or visual simulations with exterior scenes often require far-plane/near-plane ratios of anywhere between 1000 to 10000. At a ratio of 1000, 98 percent of the range is spent on the first 2 percent of the depth range, and the distribution becomes worse with higher ratios. This can cause hidden surface artifacts in distant objects, especially when using 16-bit depth buffers, the most commonly supported bit depth.

A w-based depth buffer, on the other hand, is often more evenly distributed between the near and far clip planes than a z-buffer. The key benefit is that the ratio of distances for the far and near clipping planes is no longer an issue. This allows applications to support large maximum ranges, while still getting relatively accurate depth buffering close to the eye point. A w-based depth buffer is not perfect, and can sometimes exhibit hidden surface artifacts for near objects. Another drawback to the w-buffered approach is related to hardware support: w-buffering is not supported as widely in hardware as z-buffering.

Z-buffering requires overhead during rendering. Various techniques can be used to optimize rendering when using z-buffers. Applications can increase performance when using z-buffering and texturing by ensuring that scenes are rendered from front to back. Textured z-buffered primitives are pre-tested against the z-buffer on a scan-line basis. If a scan line is hidden by a previously rendered polygon, the system rejects it quickly and efficiently. Z-buffering can improve performance, but the technique is most useful when a scene draws the same pixels more than once. Though this is difficult to calculate exactly, close approximations often can be made. If the same pixels are drawn less than twice, the best performance can be achieved by turning z-buffering off and rendering the scene from back to front.

Note: The actual interpretation of a depth value is specific to the 3-D renderer.

The following topics present information about using depth buffers for hidden line and hidden surface removal.

  • Querying for Depth Buffer Support
  • Creating a Depth Buffer
  • Enabling Depth Buffering
  • Retrieving a Depth Buffer
  • Clearing Depth Buffers
  • Changing Depth Buffer Write Access
  • Changing Depth Buffer Comparison Functions
  • Using Z-Bias


Querying for Depth Buffer Support

Note: This documentation is preliminary and is subject to change.

As with any feature, the driver that an application uses might not support all types of depth buffering. Always check the driver's capabilities. Although most drivers support z-based depth buffering, not all support w-based depth buffering (w-buffering). Drivers do not fail if you attempt to enable an unsupported scheme. Instead, they fall back on another depth buffering method, or sometimes disable depth buffering altogether, which can result in scenes rendered with extreme depth-sorting artifacts.

To check for general support for depth buffers, query Microsoft® Direct3D® for the display device that your application will use before you create a Direct3D device. If the Direct3D object reports that it supports depth buffering, any hardware devices created from it will support z-buffering.

To query for depth buffering support, use the Manager.CheckDeviceFormat method, as shown in the following C# code example.

          [C#]

AdapterInformation ai = Manager.Adapters.Default;

// Verify that the depth format exists.
if (Manager.CheckDeviceFormat(ai.Adapter,
                                DeviceType.Hardware,
                                adapterFmt,
                                Usage.DepthStencil,
                                ResourceType.Surface,
                                DepthFormat.D16,
                                out result))
{
    return true;
}

return false;   // If the call fails, the error code is passed back in the result.

The Manager.CheckDeviceFormat method allows you to choose a device to create based on the capabilities of that device. In this case, devices that do not support 16-bit depth buffers are rejected.

Using Manager.CheckDepthStencilMatch to determine depth-stencil compatibility with a render target is illustrated in the following C# code example.

          [C#]

// Reject devices that cannot create a render target of RTFormat while
// the back buffer is of RTFormat and the depth-stencil buffer is
// at least 8 bits of stencil.
AdapterInformation ai = Manager.Adapters.Default;

if (Manager.CheckDepthStencilMatch(ai.Adapter,
                                    DeviceType.Hardware,
                                    adapterFmt,
                                    RTFormat,
                                    DepthFormat.D24S8))
{
    return true;    // Device can create the render target.
}

return false;   // Reject the device; it cannot create the render target.

When you know that the driver supports depth buffers, you can verify w-buffer support. Although depth buffers are supported for all software rasterizers, w-buffers are supported only by the reference rasterizer, which is not suited for use by real-world applications. Regardless of the type of device an application uses, support for w-buffers should be verified before any attempt is made to enable w-based depth buffering.

The following procedure demonstrates how to verify support for w-buffers.

  1. After creating the device, retrieve its Caps structure from the Device.DeviceCaps property.
  2. The Caps.LineCaps property contains a reference to a LineCaps structure that contains information about the driver's support for rendering primitives.
  3. If the driver supports w-based depth buffering for that primitive type, check the RasterCaps.SupportsWBuffer property of the RasterCaps structure contained in the Caps.RasterCaps property.


Creating a Depth Buffer

Note: This documentation is preliminary and is subject to change.

A depth buffer is a property of a device. To create a depth buffer that is managed by Microsoft® Direct3D®, set the appropriate members of the PresentParameters class as shown in the following C# code example.

          [C#]

PresentParameters presentParams = new PresentParameters();

presentParams.Windowed = true;
presentParams.SwapEffect = SwapEffect.Copy;
presentParams.EnableAutoDepthStencil = true;
presentParams.AutoDepthStencilFormat = DepthFormat.D16;

Setting the PresentParameters.EnableAutoDepthStencil member to true instructs Direct3D to manage depth buffers for the application. Note that PresentParameters.AutoDepthStencilFormat must be set to a valid depth buffer format. The DepthFormat.D16 value specifies a 16-bit depth buffer, provided one is available.

The following C# call to the Device constructor creates a device that in turn creates a depth buffer.

          [C#]

Device device;

// Create a device using the PresentParameters previously set.
device = new Device(0,
                    DeviceType.Hardware,
                    this,
                    CreateFlags.SoftwareVertexProcessing,
                    presentParams);

The depth buffer is automatically set as the render target of the device. When the device is reset, the depth buffer is automatically destroyed and re-created in the new size. To create a new depth buffer surface, use the Device.CreateDepthStencilSurface method. To set a new depth-buffer surface for the device, use the Device.DepthStencilSurface method.

To use the depth buffer in an application, the depth buffer must be enabled. For more information, see Enabling Depth Buffering.


Enabling Depth Buffering

Note: This documentation is preliminary and is subject to change.

After creating a depth buffer (as described in Creating a Depth Buffer), you enable depth buffering by setting the RenderStateManager.ZBufferEnable property of the Device.RenderState property to true. To enable w-buffering, set the device's render state RenderStateManager.UseWBuffer property to true. These steps are illustrated in the following C# code example.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Enable depth buffering.
    rs.ZBufferEnable = true;

    // Render the scene.
    .
    .
    .

    // Disable depth buffering
    // (note the different syntax; both forms are acceptable)
    device.RenderState.ZBufferEnable = false;

    // Use w-buffering.
    device.RenderState.UseWBuffer = true;
Note: To use w-buffering, an application must set a compliant projection matrix, even if it does not use the Microsoft® Direct3D® transformation pipeline. For information about providing an appropriate projection matrix, see A W-Friendly Projection Matrix. The projection matrix discussed in What Is the Projection Transformation? is compliant.


Retrieving a Depth Buffer

Note: This documentation is preliminary and is subject to change.

The following C# code example demonstrates how to use the Device.DepthStencilSurface property to retrieve a Surface object that describes the depth-buffer surface owned by the device.

          [C#]

Device device = null;
Surface surface = null;

// Create the device.
.
.
.

surface = device.DepthStencilSurface;


Clearing Depth Buffers

Note: This documentation is preliminary and is subject to change.

Many C# applications clear the depth buffer before rendering each new frame. Through Microsoft® Direct3D®, the depth buffer can be cleared explicitly by calling Device.Clear and specifying ClearFlags.ZBuffer for the flags parameter. The Device.Clear method allows specification of an arbitrary depth value in the zdepth parameter.

The following C# code example demonstrates how to clear the depth buffer.

          [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;

// Create a rendering device.
.
.
.

// Clear the depth buffer.
device.Clear(ClearFlags.ZBuffer, 0, 0.5f, 0);


Changing Depth Buffer Write Access

Note: This documentation is preliminary and is subject to change.

By default, the Microsoft® Direct3D® system is allowed to write to the depth buffer. Most applications leave writing to the depth buffer enabled, but some special effects can be achieved by disabling this functionality in the Direct3D system.

To disable depth buffer writes in C#, set the RenderStateManager.ZBufferWriteEnable property of the Device.RenderState property to false. This is illustrated in the following C# code example.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Disable depth buffer writes.
    rs.ZBufferWriteEnable = false;

    // Render the scene.
    .
    .
    .

    // Enable depth buffer writes
    // (note the different syntax; both forms are acceptable)
    device.RenderState.ZBufferWriteEnable = true;


Changing Depth Buffer Comparison Functions

Note: This documentation is preliminary and is subject to change.

By default, when depth testing is performed on a rendering surface, the Microsoft® Direct3D® system updates the render target surface if the corresponding depth value (z or w) for each point is less than the value in the depth buffer. In a C# application, changes to how the system performs comparisons on depth values are made by setting the RenderStateManager.ZBufferFunction property of the Device.RenderState property to a value of the Compare enumerated type. This is illustrated in the following C# code example.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Set the ZBuffer comparison function.
    rs.ZBufferFunction = Compare.Greater;

    // Render the scene.
    .
    .
    .

    // Change the comparison function to some other value
    // (note the different syntax; both forms are acceptable)
    device.RenderState.ZBufferFunction = Compare.LessEqual;


Using Z-Bias

Note: This documentation is preliminary and is subject to change.

Polygons that are coplanar in 3-D space can be made to appear as if they are not coplanar by adding a z-bias to each one. This is a technique commonly used to ensure that shadows in a scene are displayed properly. For instance, a shadow on a wall will likely have the same depth value as the wall does. If the wall is rendered before the shadow, the shadow might not be visible, or depth artifacts might be visible. The order in which the coplanar objects are rendered can be reversed in hopes of reversing the effect, but depth artifacts are still likely.

A C# application can help ensure that coplanar polygons are rendered properly by adding a bias to the z-values that the system uses when it renders the sets of coplanar polygons. To add a z-bias to a set of polygons, set the RenderStateManager.DepthBias property of the Device.RenderState property to a value between 0 and 16, inclusive. A higher z-bias value increases the likelihood that the rendered polygons will be visible when displayed with other coplanar polygons.

The following C# code example demonstrates how to set the z-bias value.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Set the depth bias value.
    rs.DepthBias = 7.0f;

    // Render the scene.
    .
    .
    .

    // Change the depth bias value
    // (note the different syntax; both forms are acceptable)
    device.RenderState.DepthBias = 3.0f;


Fog

Note: This documentation is preliminary and is subject to change.

Adding fog to a 3-D scene can enhance realism, provide ambiance or set a mood, and obscure artifacts that are sometimes caused when distant geometry comes into view. Microsoft® Direct3D® supports two fog models, pixel fog and vertex fog, each with its own features and programming interface.

Essentially, fog is implemented by blending the color of objects in a scene with a chosen fog color, based on the depth of an object in a scene or its distance from the viewpoint. As objects grow more distant, their original color blends more and more with the chosen fog color, creating the illusion that the object is being increasingly obscured by tiny particles floating in the scene. The following illustration shows a scene rendered without fog, and a similar scene rendered with fog enabled.

Scene rendered without fog (left), and with fog (right)

In this illustration, the scene on the left has a clear horizon, beyond which no scenery is visible, even though it would be visible in the real world. The scene on the right obscures the horizon by using a fog color that is identical to the background color, making polygons appear to fade into the distance. By combining discrete fog effects with creative scene design, it is possible to add mood and soften the color of objects in a scene.

Direct3D provides two ways to add fog to a scene: pixel fog and vertex fog, named for the manner in which the fog effects are applied. For more information, see Pixel Fog and Vertex Fog. In short, pixel fog—also called table fog—is implemented in the device driver, and vertex fog is implemented in the Direct3D lighting engine. An application can implement both types of fog simultaneously if desired.

Note: Regardless of whether pixel or vertex fog is used, an application must provide a compliant projection matrix to ensure that fog effects are properly applied. This restriction applies even to applications that do not use the Direct3D transformation and lighting engine. For more information about how to provide an appropriate matrix, see A W-Friendly Projection Matrix.

The following topics introduce fog and present information about using various fog features in Direct3D applications.

  • Fog Formulas
  • Fog Parameters
  • Fog Blending
  • Fog Color
  • Vertex Fog
  • Pixel Fog

Fog blending is controlled by render states; it is not part of the programmable pixel pipeline.


Fog Formulas

Note: This documentation is preliminary and is subject to change.

C# applications can control how fog affects the color of objects in a scene by changing the way Microsoft® Direct3D® computes fog effects over distance. The FogMode enumerated type contains members that identify the three fog formulas (linear fog and two types of exponential fog). All formulas calculate a fog factor as a function of distance, given parameters that an application sets.

Linear Fog

This is set with Linear.

Linear fog equation

where

  • start is the distance at which fog effects begin.
  • end is the distance at which fog effects no longer increase.
  • d represents depth, or the distance from the viewpoint. For range-based fog, the value for d is the distance between the camera position and a vertex. For non-range-based fog, the value for d is the absolute value of the z-coordinate in camera space.

Exponential Fog

Linear and exponential formulas are supported for both pixel fog and vertex fog.

This is set with Exp.

Exponential fog equation

where

  • e is the base of natural logarithms (approximately 2.71828).
  • density is an arbitrary fog density that can range from 0.0 to 1.0.
  • d represents depth, or the distance from the viewpoint, as stated earlier.

This is set with Exp2.

exponential square fog equation

where

  • e is the base of natural logarithms, as stated above.
  • density is an arbitrary fog density that can range from 0.0 to 1.0, as stated above.
  • d represents depth, or the distance from the viewpoint, as stated above.
Note: The system stores the fog factor in the alpha component of the specular color for a vertex. If an application performs its own transformation and lighting, fog factor values can be inserted manually, to be applied by the system during rendering.

The following illustration graphs these formulas, using common values as in the formula parameters.

Linear is 1.0 at start and 0.0 at end. It is not measured relative to the near or far planes.

When Direct3D calculates fog effects, it uses the fog factor from one of the preceding equations in a blending formula, shown here.

This formula effectively scales the color of the current polygon C by the fog factor f, and adds the product to the fog color C, scaled by the bitwise inverse of the fog factor. The resulting color value is a blend of the fog color and the original color, as a factor of distance. The formula applies to all devices supported in Microsoft DirectX® 7.0 and later. For the legacy ramp device, the fog factor scales the diffuse and specular color components, clamped to the range of 0.0 and 1.0, inclusive. The fog factor typically starts at 1.0 for the near plane and decreases to 0.0 at the far plane.


Fog Parameters

Note: This documentation is preliminary and is subject to change.

Fog parameters are controlled through device render states. Both pixel and vertex fog types support all of the fog formulas introduced in Fog Formulas. The FogMode enumerated type defines constants that can be used to identify the fog formula you want Microsoft® Direct3D® to use. The RenderStateManager.FogTableMode property controls the fog mode that Direct3D uses for pixel fog, and the RenderStateManager.FogVertexMode property controls the mode for vertex fog.

When using the linear fog formula, set the starting and ending distances through the RenderStateManager.FogStart and RenderStateManager.FogEnd properties. How the system interprets these values depends on the type of fog—pixel or vertex—an application uses, and when using pixel fog, whether z-based or w-based depth is being used. The following table summarizes fog types and their start and end units.

Fog type | Fog start/end units
Pixel (Z) | Device space [0.0,1.0]
Pixel (W) | Camera space
Vertex | Camera space

The RenderStateManager.FogDensity property controls the fog density that is applied when an exponential fog formula is enabled. Fog density is essentially a weighting factor, ranging from 0.0 to 1.0 (inclusive), that scales the distance value in the exponent.

The color that the system uses for fog blending is controlled through the RenderStateManager.FogColor device property. For more information, see Fog Color and Fog Blending.


Fog Blending

Note: This documentation is preliminary and is subject to change.

Fog blending refers to the application of the fog factor to fog and object colors to produce the final color that appears in a scene (as discussed in Fog Formulas). The RenderStateManager.FogEnable property controls fog blending. The default value is false; set this render state to true to enable fog blending, as shown in the following C# code example.

          [C#]

// For this example, device is a valid Device object.

// Get the device's render states object.
RenderStates rs = device.RenderState;

rs.FogEnable = true;

Fog blending must be enabled for both pixel fog and vertex fog. For information about using these types of fog, see Pixel Fog and Vertex Fog.


Fog Color

Note: This documentation is preliminary and is subject to change.

Fog color for both pixel and vertex fog is set through the RenderStateManager.FogColor property. The render state values can be any RGB color, specified as an RGBA color. The alpha component is ignored.

The following C# code example sets the fog color to white.

          [C#]

// For this example, device is a valid Device object.

// Get the device's render states object.
RenderStates rs = device.RenderState;

rs.FogColor = System.Color.White;

Fog is applied differently by the fixed-function pipeline and the programmable pipeline.

  1. If the driver supports MiscCaps.SupportsFogAndSpecularAlpha:
    • If the fixed-function pipeline is used and RenderStateManager.FogColor is set, v1.w (in the pixel shader) equals the value set in the fog render state.
    • If the programmable pipeline is used, v1.w (in the pixel shader) equals 0, even if oD1.w is explicitly written in a vertex shader.
  2. If the driver does not support MiscCaps.SupportsFogAndSpecularAlpha:
    • If the fixed-function pipeline is used and RenderStateManager.FogColor is set, v1.w (in the pixel shader) equals the value set in the fog render state.
    • If oFog is explicitly written in a vertex shader, v1.w (in the pixel shader) equals oFog, clamped between 0 and 1.
    • If neither of the above two cases applies, v1.w (in the pixel shader) equals 0, even if oD1.w is explicitly written in a vertex shader.

For more information, see MiscCaps.


Vertex Fog

Note: This documentation is preliminary and is subject to change.

When the system performs vertex fogging, it applies fog calculations at each vertex in a polygon, and then interpolates the results across the face of the polygon during rasterization. Vertex fog effects are computed by the Microsoft® Direct3D® lighting and transformation engine. For more information, see Fog Parameters.

If an application does not use Direct3D for transformation and lighting, the application must perform fog calculations. In this case, place the fog factor that is computed in the alpha component of the specular color for each vertex. Any formula can be used—range-based, volumetric, or otherwise. Direct3D uses the supplied fog factor to interpolate across the face of each polygon. Applications that perform their own transformation and lighting also must perform their own vertex fog calculations. As a result, such an application need only enable fog blending and set the fog color through the associated render states, as described in Fog Blending and Fog Color.

Note: When using a vertex shader, vertex fog must be used. This is accomplished by using the vertex shader to write the per-vertex fog intensity to the oFog register. After the pixel shader completes, the oFog data is used to linearly interpolate with the fog color. This intensity is not available in a pixel shader.

Range-Based Fog

Note: Direct3D uses range-based fog calculations only when using vertex fog with the Direct3D transformation and lighting engine. This is because pixel fog is implemented in the device driver, and no hardware currently exists to support per-pixel range-based fog. If an application performs its own transformation and lighting, it must perform its own fog calculations, range-based or otherwise.

Sometimes, using fog can introduce graphic artifacts that cause objects to be blended with the fog color in nonintuitive ways. For example, imagine a scene in which there are two visible objects: one distant enough to be affected by fog, and the other near enough to be unaffected. If the viewing area rotates in place, the apparent fog effects can change, even if the objects are stationary. The following illustration shows a top-down view of such a situation.

Effects on fog of changing the viewport

Range-based fog is another, more accurate, way to determine the fog effects. In range-based fog, Direct3D uses the actual distance from the viewpoint to a vertex for its fog calculations. Direct3D increases the effect of fog as the distance between the two points increases, rather than the depth of the vertex in the scene, thereby avoiding rotational artifacts.

If the current device supports range-based fog, it sets the SupportsFogRange property in the RasterCaps member of the Caps structure that is returned by a call to the Manager.GetDeviceCaps method. To enable range-based fog, set the RenderStateManager.RangeFogEnable property to true.

Range-based fog is computed by Direct3D during transformation and lighting. Applications that do not use the Direct3D transformation and lighting engine also must perform their own vertex fog calculations. In this case, provide the range-based fog factor in the alpha component of the specular component for each vertex.

Using Vertex Fog

Use the following steps to enable vertex fog in an application.

  1. Enable fog blending by setting RenderStateManager.FogEnable to true.
  2. Set the fog color in the RenderStateManager.FogColor property.
  3. Choose the desired fog formula by setting the RenderStateManager.FogVertexMode property to a member of the FogMode enumerated type.
  4. Set the fog parameters as desired for the selected fog formula in the render states.

The following C# code example shows what these steps might look like in code.

          [C#]

// For the purposes of this example, device is a valid Device object.
//
void SetupVertexFog(Color color, FogMode mode, bool bUseRange, float fDensity)
{
    float Start = 0.5f;     // Linear fog distances.
    float End   = 0.8f;

    // Enable fog blending.
    device.RenderState.FogEnable = true;

    // Set the fog color.
    device.RenderState.FogColor = color;

    // Set fog parameters.
    if (mode == FogMode.Linear)
    {
        device.RenderState.FogVertexMode = mode;
        device.RenderState.FogStart = Start;
        device.RenderState.FogEnd = End;
    }
    else
    {
        device.RenderState.FogVertexMode = mode;
        device.RenderState.FogDensity = fDensity;
    }

    // Enable range-based fog if desired (only supported for
    // vertex fog). For this example, it is assumed that bUseRange
    // is set only if the driver exposes the
    // RasterCaps.SupportsFogRange capability.
    // Note: This is slightly more performance-intensive
    // than non-range-based fog.

    if (bUseRange)
        device.RenderState.RangeFogEnable = true;
}


Pixel Fog

Note: This documentation is preliminary and is subject to change.

Pixel fog gets its name from the fact that it is calculated on a per-pixel basis in the device driver. This is different from vertex fog, which is computed by the pipeline during transformation and lighting calculations. Pixel fog is sometimes called table fog because some drivers use a precalculated lookup table to determine the fog factor, using the depth of each pixel to apply in blending computations. It can be applied using any fog formula identified by members of the FogMode enumerated type. The implementations of these formulas are driver-specific. If a driver does not support a complex fog formula, it should degrade to a less complex formula.

Eye-Relative vs. Z-Based Depth

To alleviate fog-related graphic artifacts caused by uneven distribution of z-values in a depth buffer, most hardware devices use eye-relative depth instead of z-based depth values for pixel fog. Eye-relative depth is essentially the w element from a homogeneous coordinate set. Microsoft® Direct3D® takes the reciprocal of the RHW element from a device space coordinate set to reproduce true w. If a device supports eye-relative fog, it sets the SupportsWFog property in the RasterCaps member of the Caps structure that is returned by a call to Manager.GetDeviceCaps. With the exception of the reference rasterizer, software devices always use z to calculate pixel fog effects.

When eye-relative fog is supported, the system automatically uses eye-relative depth rather than z-based depth if the provided projection matrix produces z-values in world space that are equivalent to w-values in device space. Set the projection matrix by calling the Device.SetTransform method, using the TransformType.Projection value and passing a Matrix structure that represents the desired matrix. If the projection matrix is not compliant with this requirement, fog effects are not applied properly. For details about producing a compliant matrix, see A W-Friendly Projection Matrix. The perspective projection matrix provided in What Is the Projection Transformation? produces a compliant projection matrix.

Direct3D uses the currently set projection matrix in its w-based depth calculations. As a result, an application must set a compliant projection matrix to receive the desired w-based features, even if it does not use the Direct3D transformation pipeline.

Direct3D checks the fourth column of the projection matrix. If the coefficients are [0,0,0,1] (for an affine projection) the system uses z-based depth values for fog. In this case, the start and end distances for linear fog effects must be specified in device space, which ranges from 0.0 at the nearest point to the user, and 1.0 at the farthest point.

Using Pixel Fog

Use the following steps to enable pixel fog in an application.

  1. Enable fog blending by setting the RenderStateManager.FogEnable property to true.
  2. Set the desired fog color in the RenderStateManager.FogColor property.
  3. Choose the fog formula to use by setting the RenderStateManager.FogTableMode property to the corresponding member of the FogMode enumerated type.
  4. Set the fog parameters as desired for the selected fog mode in the associated render states. This includes the start and end distances for linear fog, and fog density for exponential fog mode.

The following C# code example shows what these steps might look like in code.

          [C#]

// For the purposes of this example, device is a valid Device object.
//
void SetupPixelFog(Color color, FogMode mode)
{
    float Start   = 0.5f;   // For linear mode.
    float End     = 0.8f;   //

    float Density = 0.66f;  // For exponential modes.

    // Enable fog blending.
    device.RenderState.FogEnable = true;

    // Set the fog color.
    device.RenderState.FogColor = color;

    // Set fog parameters.
    if (mode == FogMode.Linear)
    {
        device.RenderState.FogTableMode = mode;
        device.RenderState.FogStart = Start;
        device.RenderState.FogEnd = End;
    }
    else
    {
        device.RenderState.FogTableMode = mode;
        device.RenderState.FogDensity = Density;
    }
}


Alpha Blending

Note: This documentation is preliminary and is subject to change.

Alpha blending is used to display an image that has transparent or semi-transparent pixels. In addition to a red, green, and blue color channel, each pixel in an alpha bitmap has a transparency component known as its alpha channel. The alpha channel typically contains as many bits as a color channel. For example, an 8-bit alpha channel can represent 256 levels of transparency, from 0 (meaning the entire pixel is transparent) to 255 (meaning the entire pixel is opaque).

Color can be defined with or without alpha values. Color without alpha is RGB; color with alpha is stored as ARGB. Vertex data, material data, and texture data can be used to give objects transparency. The frame buffer also can be used to generate transparency effects.

The list below shows some special effects that can be created using alpha blending.

  • Vertex Alpha
  • Material Alpha
  • Texture Alpha
  • Frame Buffer Alpha
  • Render Target Alpha

The following samples demonstrate alpha blending.

  • Billboarding
  • Clouds, Smoke, and Vapor Trails
  • Fire, Flares, and Explosions


Vertex Alpha

Note: This documentation is preliminary and is subject to change.

Alpha data can be supplied in the vertex data. To enable vertex alpha, set the device's render state RenderStateManager.DiffuseMaterialSource to ColorSource.Color1 so that the Microsoft® Direct3D® runtime takes the diffuse value from the diffuse color rather than the material.

Alpha data can be added to a color component of a vertex. The following code creates two copies of a sphere mesh, adds a color component to the vertex definition, and specifies the color for each vertex. This code can be added to the GraphicsClass.InitializeDeviceObjects method generated by the DirectX 9.0 Visual C# Wizard to demonstrate the functionality.

          [C#]

// Create the sphere geometry.
rearSphere = Mesh.Sphere(device,1f,10,10);

// Copy the sphere, adding a diffuse color to the vertices.
sphere = rearSphere.Clone(MeshFlags.Managed,VertexFormats.PositionNormal | VertexFormats.Diffuse,device);

// Add the same color componant to the original sphere.
rearSphere = rearSphere.Clone(MeshFlags.Managed,VertexFormats.PositionNormal | VertexFormats.Diffuse,device);

// Lock the vertex buffer of the rearSphere to obtain the vertex information.
CustomVertex.PositionNormalColored[] Source =
               (CustomVertex.PositionNormalColored[])rearSphere.LockVertexBuffer(typeof(CustomVertex.PositionNormalColored),
                0,rearSphere.NumberVertices);

// Loop through the vertices, adding a red transparent color to each.
for(int x=0; x < (Source.GetLength(0)); x++)
{
   Source[x].Color = Color.FromArgb(0, 255, 0, 255).ToArgb();
}
rearSphere.UnlockVertexBuffer();

// Add a color component with alpha to the second sphere.
CustomVertex.PositionNormalColored[] Destination =
             (CustomVertex.PositionNormalColored[])sphere.LockVertexBuffer(typeof(CustomVertex.PositionNormalColored),
              0,rearSphere.NumberVertices);

// Instead of adding the same alpha value to each of the vertices,
// this code increments the value, creating a gradient effect across the sphere.
int num = 256/Destination.GetLength(0);
for(int x=0; x < (Destination.GetLength(0)); x++)
{
   Destination[x].Color = Color.FromArgb(150, 255, 255, num*x).ToArgb();
}
sphere.UnlockVertexBuffer();

The color alpha value that has been added into the vertices now can be used to draw the spheres with transparency. The following code sets up a rendering Device and draws sphere in front of rearSphere to demonstrate the transparency. This code can be added to the GraphicsClass.Render method generated by the DirectX 9.0 Visual C# Wizard to demonstrate the functionality. Place the code after the Device.Transform.Projection matrix is set.

          [C#]

// A StateBlock is used to reset the device to its former state after we draw transparency.
StateBlock sb = new StateBlock(device, StateBlockType.All);
sb.Capture();

// Use the diffuse vertex color as the DiffuseMaterialSource for color lighting calculations
// (as opposed to a material).
device.RenderState.DiffuseMaterialSource = ColorSource.Color1;

// Set up the device to render the alpha information.
device.RenderState.AlphaBlendEnable = true;
device.RenderState.SourceBlend = Blend.SourceColor;
device.RenderState.DestinationBlend = Blend.InvSourceAlpha;

// Translate the rearSphere so that it is drawn behind the sphere.
Matrix m2 = m;
m.Translate(0,0,2);
device.Transform.World = m;

rearSphere.DrawSubset(0);

// Rotate the sphere so we can see the gradient a little better.
device.Transform.World = m2;
Vector3 rot = new Vector3(90,0,0);
m2.RotateAxis(rot,-45);
device.Transform.World = m2;

sphere.DrawSubset(0);

// Restore the device to its original settings.
sb.Apply();

This code results in two transparent spheres, one slightly in front of the other.


Material Alpha

Note: This documentation is preliminary and is subject to change.

Alpha data also can be supplied in a material. To enable material alpha, set the diffuse material render state so that the runtime uses the material diffuse color components rather than the vertex diffuse color components, as shown in the following C# code.

          [C#]

// Enable material alpha.
device.RenderState.DiffuseMaterialSource = ColorSource.Material;

The following C# code initializes the material with an alpha value, and sets the material before drawing.

          [C#]

Material mtrl = new Material();
Color c = Color.FromArgb(127, 255, 0, 0);

mtrl.Diffuse = c;
mtrl.Ambient = c;
mtrl.Specular = c;
mtrl.Emissive = c;

device.Material = mtrl;


Texture Alpha

Note: This documentation is preliminary and is subject to change.

Alpha data also can be supplied by textures. The texture must first be created, and then the alpha values added to it. To render with the texture, set it to a texture stage and select the appropriate texture stage operation and operands. When draw is called, the primitive is rendered with transparency.

These steps are illustrated in the following C# code example.

          [C#]

// Declare a Device.
Device device = null

// Declare a global texture variable.
Texture texture = null;

// Initialize the device.
.
.
.

// Create an alpha texture.
texture = new Texture(device, 128, 128, 0, 0, Format.A8R8G8B8, Pool.Managed);

LoadGradient();

The Texture class sets up everything by creating an empty texture. After the texture resource is created, LoadGradient is called to load the alpha channel.

          [C#]

protected void LoadGradient()
{
    uint yGrad, xGrad;
    uint dx = 128;      // width
    uint dy = 128;      // height

    uint[] buffer = new uint[dy * dx];

    GraphicsStream gs = null;

    try
    {
        gs = texture.LockRectangle(0, LockFlags.Discard);

        for (uint y = 0; y < dy; y++)
        {
            uint offset = y * dx;
            yGrad = (uint)(((float)y / (float)dx) * 255.0f);

            for (uint x = 0; x < dx;)
            {
                xGrad = (uint)(((float)x / (float)dx) * 255.0f);

                uint b = (uint)(xGrad + (255 - yGrad)) / 2 & 0xFF;
                uint g = (uint)((255 - xGrad) + yGrad) / 2 & 0xFF;
                uint r = (uint)(xGrad + yGrad) / 2 & 0xFF;
                uint a = (uint)(xGrad + yGrad) / 2 & 0xFF;

                buffer[offset + x] = ((a << 24) + (r << 16) + (g << 8) + (b));
                x++;
            }
        }

        gs.Write(buffer);
        texture.UnlockRectangle(0);
    }
    catch(InvalidCallException)
    {
        return;
    }
}

The alpha value is calculated based on the current pixel's relative x/y position within the texture size.

Next, assign the texture to a texture stage and set up the texture stage.

          [C#]

 // Assign texture.
device.SetTexture(0, texture)

// Texture stage states.
device.TextureState[0].ColorOperation = TextureOperation.Modulate;
device.TextureState[0].ColorArgument1 = TextureArgument.TextureColor;
device.TextureState[0].ColorArgument2 = TextureArgument.Diffuse;

device.TextureState[0].AlphaOperation = TextureOperation.Modulate;
device.TextureState[0].AlphaArgument1 = TextureArgument.TextureColor;
device.TextureState[0].AlphaArgument2 = TextureArgument.Diffuse;

This code results in a primitive with a transparency gradient. The gradient is transparent where x = 0, and opaque where x is its maximum value.


Frame Buffer Alpha

Note: This documentation is preliminary and is subject to change.

Frame buffer alpha blending is a bit different than vertex alpha, material alpha, and texture alpha. Vertex, material, and texture alpha set transparency values that are used only for the current primitive, and by themselves have no effect on other primitives. Frame buffer alpha blending controls how the current primitive is combined with existing pixels in the frame buffer to yield a final pixel color.

When performing alpha blending, two colors are being combined: a source color and a destination color. The source color is from the transparent object, and the destination color is the color already at the pixel location. The destination color is the result of rendering some other object that is behind the transparent object; that is, the object that will be visible through the transparent object. Alpha blending uses the following formula to control the ratio between the source and destination objects.

Final Color = ObjectColor * SourceBlendFactor
                + PixelColor * DestinationBlendFactor

ObjectColor is the contribution from the primitive being rendered at the current pixel location. PixelColor is the contribution from the frame buffer at the current pixel location.

The following set of blend factors can be used.

Blend mode factor | Description
Zero | (0, 0, 0, 0)
One | (1, 1, 1, 1)
SourceColor | (Rs,Gs,Bs,As)
InvSourceColor | (1 - Rs, 1 - Gs, 1 - Bs, 1 - As)
SourceAlpha | (As, As, As, As)
InvSourceAlpha | (1 - As, 1 - As, 1 - As, 1 - As)
DestinationAlpha | (Ad, Ad, Ad, Ad)
InvDestinationAlpha | (1 - Ad, 1 - Ad, 1 - Ad, 1 - Ad)
DestinationColor | (Rd, Gd, Bd, Ad)
InvDestinationColor | (1 - Rd, 1 - Gd, 1 - Bd, 1 - Ad)
SourceAlphaSat | (f, f, f, 1); f = min(As, 1 - Ad)
BothSourceAlpha | Obsolete. To achieve the same effect, set the source and destination blend factors to SourceAlpha and InvSourceAlpha in separate calls.
BothInvSourceAlpha | Obsolete. To achieve the same effect, set the source and destination blend factors to SourceAlpha and InvSourceAlpha in separate calls. Source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), and destination blend factor is (As, As, As, As); the destination blend selection is overridden. This blend mode is supported only if the RenderStateManager.SourceBlend property is set to true.
BlendFactor | Constant color blending factor used by the frame-buffer blender. Uses color.r, color.g, color.b, and color.a obtained from RenderStateManager.BlendFactor. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.
InvBlendFactor | Inverted constant color blending factor used by the frame-buffer blender. Uses 1-color.r, 1-color.g, 1-color.b, and 1-color.a obtained from RenderStateManager.BlendFactor. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.

Microsoft® Direct3D® uses RenderStateManager.AlphaBlendEnable to enable alpha transparency blending. The type of alpha blending that is done depends on the RenderStateManager.SourceBlend and RenderStateManager.DestBlend render states. Source and destination blend states are used in pairs. The following C# code fragment sets the source blend state to Blend.SourceColor and the destination blend state to Blend.InvSourceColor.

          [C#]

// This code fragment assumes that device is a
//   valid Device object.

// Enable alpha blending.
device.RenderState.AlphaBlendEnable = true;

// Set the source blend state.
device.RenderState.SourceBlend = Blend.SourceColor;

// Set the destination blend state.
device.RenderState.DestBlend = Blend.InvSourceColor;

This code performs a linear blend between the source color (the color of the primitive being rendered at the current location) and the destination color (the color at the current location in the frame buffer). The resulting appearance is similar to tinted glass in that some of the color of the destination object seems to be transmitted through the source object; the rest of it appears to be absorbed.

Many of these blend factors require alpha values in the texture to operate correctly. Thus, when using vertex or material alpha, the application is restricted as to which modes produce interesting results.


Render Target Alpha

Note: This documentation is preliminary and is subject to change.

The frame buffer blender can now blend alpha channels independently of color-channel blending on render targets. This control is enabled with a new render state, RenderStateManager.SeparateAlphaBlendEnabled.

When RenderStateManager.SeparateAlphaBlendEnabled is set to false (which is the default condition), the render-target blending factors and operations applied to alpha are the same as those defined for blending color channels. A driver needs to set the MiscCaps.SupportsSeparateAlphaBlend cap to indicate that it can support render-target alpha blending. Be sure to set RenderStateManager.AlphaBlendEnable to tell the pipeline that alpha blending is needed.

To control the factors in the alpha channel of the render-target blenders, the following new render states are defined.

  • RenderStateManager.AlphaDestinationBlend
  • RenderStateManager.AlphaSourceBlend

Like RenderStateManager.SourceBlend and RenderStateManager.DestinationBlend, these states can be set to one of the values in the Blend enumeration. The source and destination blend settings can be combined in several ways, depending on the settings of the BlendCaps object set in Caps.DestinationBlendCaps and Caps.SourceBlendCaps.

The alpha blending is done as follows:

renderTargetAlpha = (alphain* srcBlendOp) BlendOp (alphart* destBlendOp)

Where:

  • alphain is the input alpha value.
  • srcBlendOp is one of the blend factors in Blend.
  • BlendOp is one of the blend factors in Blend.
  • alphart is the render-target alpha value.
  • destBlendOp is one of the blend factors in Blend.
  • renderTargetAlpha is the final blended alpha value.


Alpha Examples

Note: This documentation is preliminary and is subject to change.

Alpha blending is used to display an image that has transparent or semi-transparent pixels. In addition to a red, green, and blue color channel, each pixel in an alpha bitmap has a transparency component known as its alpha channel. The alpha channel typically contains as many bits as a color channel. For example, an 8-bit alpha channel can represent 256 levels of transparency, from 0 (meaning the entire pixel is transparent) to 255 (meaning the entire pixel is opaque). The list below shows some special effects that can be created using alpha blending.

  • Billboarding
  • Clouds, Smoke, and Vapor Trails
  • Fire, Flares, and Explosions


Billboarding

Note: This documentation is preliminary and is subject to change.

When creating 3-D scenes, an application can sometimes gain performance advantages by rendering 2-D objects in a way that makes them appear to be 3-D. This is the basic idea behind the technique of billboarding.

A billboard in the normal sense of the word is a sign along a roadway. Microsoft® Direct3D® applications can create and render this type of billboard by defining a rectangular solid and applying a texture to it. Billboarding in the more specialized sense of 3-D graphics is an extension of this. The goal is to make 2-D objects appear to be 3-D, and the technique is to apply a texture that contains the object's image to a rectangular primitive. The primitive is rotated so that it always faces the user. It does not matter if the object's image is not rectangular. Portions of the billboard can be made transparent, so the parts of the billboard image that you do not want seen are not visible.

Many games employ billboarding for animated sprites. For instance, when the user is moving through a 3-D maze, he or she may see weapons or rewards that can be picked up. These are typically 2-D images textured on a rectangular primitive. Billboarding often is used in games to render images of trees, bushes, and clouds.

When an image is applied to a billboard, the rectangular primitive first must be rotated so that the resulting image faces the user. The application then must translate it into position, after which it can apply a texture to the primitive.

Billboarding works best for symmetrical objects, especially objects that are symmetrical along the vertical axis. It also requires that the altitude of the viewpoint does not increase too much. If the user is allowed to view the billboarded object from above, it becomes readily apparent that the object is 2-D rather than 3-D.


Clouds, Smoke, and Vapor Trails

Note: This documentation is preliminary and is subject to change.

Clouds, smoke, and vapor trails all can be created by an extension of the billboarding technique (see Billboarding). By rotating the billboard on two axes instead of one, an application can enable the user to view a billboard from any angle. Typically, an application rotates the billboard on the horizontal and vertical axes.

To make a simple cloud, an application can rotate a rectangular primitive on one or two axes so that the primitive faces the user. A cloud-like texture then can be applied to the primitive with transparency. The cloud can be animated by applying a series of textures over time.

An application can create more complex clouds by forming them from a group of primitives. Each part of the cloud is a rectangular primitive. The primitives can be moved independently over time to give the appearance of a dynamic mist. This concept is illustrated in the following figure.

Formation from a group of primitives

The appearance of smoke is displayed in a manner similar to clouds. It typically requires multiple billboards, like complex clouds. Smoke usually billows and rises over time, so the billboards that make up the smoke plume need to move accordingly. More billboards might need to be added as the plume rises and disperses.

A vapor trail is a smoke plume that does not rise. However, like a smoke plume, it disperses over time. The following figure illustrates the technique of using billboards to simulate a vapor trail.


Fire, Flares, and Explosions

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® can be used to simulate natural phenomena involving energy releases. For instance, an application can generate the appearance of fire by applying flame-like textures to a set of billboards. This is especially effective if the application uses a sequence of fire textures to animate the flames on each billboard in the fire. Varying the speed of the animation playback from billboard to billboard increases the appearance of real flames. The semblance of intermingled 3-D flames can be achieved by layering the billboards and the textures on the billboards.

Flares and flashes can be simulated by applying successively brighter light maps to all primitives in a scene. Although this technique is high in computational overhead, it allows an application to simulate a localized flare or flash. That is, the portion of the scene where the flare or flash originates can brighten first.

Another technique is to position a billboard in front of the scene so that the entire render target area is covered. The application applies successively whiter textures to the billboard and decreases the transparency over time. The entire scene fades to white as time passes. This is a low-overhead method of creating a flare. However, using this technique, it can be difficult to generate the appearance of a bright flash from a single point light source.

Explosions can be displayed in a 3-D scene procedure similar to those used for fire, flashes, and flares. For instance, an application might use a billboard to display a shock wave and rising plume of smoke when the explosion occurs. At the same time, the application can use a set of billboards to simulate flames. In addition, it can position a single billboard in front of the scene to add a flare of light to the entire scene.

Energy beams can be simulated using billboards. The application also can display them using primitives that are defined as line lists or line strips. For more information, see Line Lists and Line Strips.

An application can create force fields using billboards or primitives defined as triangle lists. To create a force field from triangle lists, define a set of disjoint triangles in a triangle list equally spaced over the region covered by the force field. The gaps between the triangles allow the user to see the scene behind the triangles, as might be expected when looking at a force field. Apply a texture to the triangle list that gives the triangles the appearance of glowing with energy. For more information, see Triangle Lists.


Direct3D Surfaces

Note: This documentation is preliminary and is subject to change.

A surface represents a linear area of display memory. Surfaces usually reside in the display memory of the display card, although they can exist in system memory. They are managed by the Surface class.

Familiarity with the following terms is necessary to understand surfaces.

  • front buffer. A rectangle of memory that is translated by the graphics adapter and displayed on the monitor. In Microsoft® Direct3D®, an application never writes directly to the front buffer.
  • back buffer. A rectangle of memory that an application can directly write to. The back buffer is never directly displayed on the monitor.
  • flipping surfaces. The process of moving the back buffer to the front buffer.
  • swap chain. A collection of one or more back buffers that can be serially presented to the front buffer.

Getting a Surface

To create a surface, call any of the following methods.

  • Device.CreateDepthStencilSurface
  • Device.CreateOffscreenPlainSurface
  • Device.CreateRenderTarget

Surface formats determine how data for each pixel in surface memory is interpreted. Direct3D uses the Format property of the SurfaceDescription structure to describe the surface format. The SurfaceDescription structure of an existing surface can be retrieved via its Surface.Description property.

Once a surface is created, a pointer to it can be obtained by calling any of the following methods.

  • CubeTexture.GetCubeMapSurface
  • Device.GetBackBuffer
  • Device.DepthStencilSurface
  • Device.GetFrontBufferData
  • Device.GetRenderTarget
  • SwapChain.GetBackBuffer
  • Texture.GetSurfaceLevel

The Surface class enables indirect access to memory through the UpdateSurface method. This method allows the copying of a rectangular region of pixels from one UpdateSurface class to another. The UpdateSurface class also has methods to directly access display memory. For example, the Surface.LockRectangle method can be used to lock a rectangular region of display memory. It is important to call Surface.UnlockRectangle after working with the locked rectangular region on the surface.

Additional Surface Topics

The following topics provide information about how to use surfaces.

  • Surface Formats
  • What is a Swap Chain?
  • Width vs. Pitch
  • Flipping Surfaces
  • Page Flipping and Back Buffering
  • Copying to Surfaces
  • Copying Surfaces
  • Accessing Surface Memory Directly
  • Private Surface Data
  • Gamma Controls


Surface Formats

Note: This documentation is preliminary and is subject to change.

In Microsoft® Direct3D®, all two-dimensional (2-D) images are represented by a linear range of memory called a surface. A surface can be thought of as a 2-D array in which each element holds a color value that represents a small section of the image, called a pixel. An image's detail level is defined both by the number of pixels needed to represent the image and the number of bits needed for the image's color spectrum. For example, an image that is 800 pixels wide by 600 pixels tall with 32 bits of color for each pixel (written as 800x600x32) is more detailed then an image that is 640 pixels wide by 480 pixels tall with 16 bits of color for each pixel (written as 640x480x16). Likewise, the more detailed image requires a larger surface to store the data. For an 800x600x32 image, the surface's array dimensions are 800x600, and each element holds a 32-bit value to represent its color.

All surfaces have a size and store a specific number of bits that represent color. These bits are separated into individual color elements: red, green, and blue. In Microsoft DirectX® 9.0 for Managed Code, all color elements are defined by the Format enumeration. A color format is broken down into the number of byes reserved for each color. For example, a 16-bit color format is defined as Format.R5G6B5, where five bits are reserved for red (R), six bits for green (G), and five bits for blue (B).

All formats are listed from left to right, most significant bit (MSB) to least significant bit (LSB). For example, ARGB is ordered from the MSB channel A (alpha) to the LSB channel B (blue). During traversal of surface data, the data is stored in memory from LSB to MSB, which means that the channel order in memory is from LSB (blue) to MSB (alpha).

The default value for formats that contain undefined channels is 1. The only exception is the A8 format, which is initialized to 000 for the three color channels.

Unsigned Formats

Data in an unsigned format must be positive. Unsigned formats use combinations of (R)ed, (G)reen, (B)lue, (A)lpha, (L)uminance, and (P)alette data. Palette data is also referred to as color-indexed data because the data is used to index a color palette.

Unsigned format flags | Format
R8G8B8 | A 24-bit RGB pixel format that uses 8 bits per channel.
A8R8G8B8 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
X8R8G8B8 | A 32-bit RGB pixel format in which 8 bits are reserved for each color.
R5G6B5 | A 16-bit RGB pixel format that uses 5 bits for red, 6 bits for green, and 5 bits for blue.
X1R5G5B5 | A 16-bit pixel format in which 5 bits are reserved for each color.
A1R5G5B5 | A 16-bit pixel format in which 5 bits are reserved for each color and 1 bit is reserved for alpha.
A4R4G4B4 | A 16-bit ARGB pixel format that uses 4 bits for each channel.
R3G3B2 | An 8-bit RGB texture format that uses 3 bits for red, 3 bits for green, and 2 bits for blue.
ii | An 8-bit format that uses alpha only.
A8R3G3B2 | A 16-bit ARGB texture format that uses 8 bits for alpha, 3 bits each for red and green, and 2 bits for blue.
X4R4G4B4 | A 16-bit RGB pixel format that uses 4 bits for each color.
A2B10G10R10 | A 32-bit pixel format that uses 10 bits for each color and 2 bits for alpha.
A8B8G8R8 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
X8B8G8R8 | A 32-bit RGB pixel format in which 8 bits are reserved for each color.
G16R16 | A 32-bit pixel format that uses 16 bits each for green and red.
A2R10G10B10 | A 32-bit pixel format that uses 10 bits each for red, green, and blue, and 2 bits for alpha.
A16B16G16R16 | A 64-bit pixel format that uses 16 bits for each component.
A8P8 | An 8-bit color format indexed with 8 bits of alpha.
P8 | An 8-bit color indexed format.
L8 | An 8-bit luminance-only format.
L16 | A 16-bit luminance-only format.
A8L8 | A 16-bit format that uses 8 bits each for alpha and luminance.
A4L4 | An 8-bit format that uses 4 bits each for alpha and luminance.

Signed Formats

Data in a signed format can be both positive and negative. Signed formats use combinations of (U), (V), (W), and (Q) data.

Signed-format flags | Format
V8U8 | A 16-bit bump-map format that uses 8 bits each for U and V data.
Q8W8V8U8 | A 32-bit bump-map format that uses 8 bits for each channel.
V16U16 | A 32-bit bump-map format that uses 16 bits for each channel.
Q16W16V16U16 | A 64-bit bump-map format that uses 16 bits for each component.
CxV8U8 | A 16-bit normal compression format. The texture sampler computes the C channel from C = sqrt(1 - U2 - V2).

Mixed Formats

Data in mixed formats can contain a combination of signed and unsigned data.

Mixed-format flags | Format
L6V5U5 | A 16-bit bump-map format, with luminance, that uses 6 bits for luminance and 5 bits each for v and u data.
X8L8V8U8 | A 32-bit bump-map format, with luminance, that uses 8 bits for each channel.
A2W10V10U10 | A 32-bit bump-map format that uses 2 bits for alpha and 10 bits each for w, v, and u data.

FOURCC Formats

Data in a four-character code (FOURCC) format is compressed.

MAKEFOURCC

The enumerated value of the following formats is based on a number generated by combining several integer values. This allows hardware designers to use custom enumerated values that are not explicitly listed here to indicate a FOURCC format.

The following C# code fragment generates FOURCC codes.

          [C#]

static int MakeFourCC(int ch0, int ch1, int ch2, int ch3)
{
   return ((int)(byte)(ch0)|((int)(byte)(ch1) << 8)| ((int)(byte)(ch2) << 16) | ((int)(byte)(ch3) << 24));
}

The defined FOURCC formats are as follows.

FOURCC flags | Value | Format
Multi2Argb8 | MakeFourCC('M','E','T','1') | MultiElement texture (not compressed).
G8R8G8B8 | MakeFourCC('G', 'R', 'G', 'B') | A 16-bit packed RGB format that is analogous to YUY2 (Y0U0, Y1V0, Y2U2, etc.). It requires a pixel pair to properly represent the color value. The first pixel in the pair contains 8 bits of green (in the high 8 bits) and 8 bits of red (in the low 8 bits). The second pixel contains 8 bits of green (in the high 8 bits) and 8 bits of blue (in the low 8 bits). The two pixels share the red and blue components, while each has a unique green component (G0R0, G1B0, G2R2, etc.). When looking up into a pixel shader, the texture sampler does not normalize the colors; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed-function pixel shader, the hardware should normalize to the 0.f to 1.f range and treat it as the YUY2 texture. Hardware that exposes this format must have the Caps.PixelShader1xMaxValue member set to a value capable of handling that range.
R8G8B8G8 | MakeFourCC('R', 'G', 'B', 'G') | A 16-bit packed RGB format that is analogous to UYVY (U0Y0, V0Y1, U2Y2, etc.). It requires a pixel pair ito properly represent the color value. The first pixel in the pair contains 8 bits of green (in the low 8 bits) and 8 bits of red (in the high 8 bits). The second pixel contains 8 bits of green (in the low 8 bits) and 8 bits of blue (in the high 8 bits). The two pixels share the red and blue components, while each has a unique green component (R0G0, B0G1, R2G2, etc.). When looking up into a pixel shader, the texture sampler does not normalize the colors; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed-function pixel shader, the hardware should normalize to the 0.f to 1.f range and treat it as the YUY2 texture. Hardware that exposes this format must have the Caps.PixelShader1xMaxValue member set to a value capable of handling that range.
Dxt1 | MakeFourCC('D', 'X', 'T', '1') | DXT1 compression texture format.
Dxt2 | MakeFourCC('D', 'X', 'T', '2') | DXT2 compression texture format.
Dxt3 | MakeFourCC('D', 'X', 'T', '3') | DXT3 compression texture format.
DXT4 | MakeFourCC('D', 'X', 'T', '4') | DXT4 compression texture format.
Dxt5 | MakeFourCC('D', 'X', 'T', '5') | DXT5 compression texture format.
Uyvy | MakeFourCC('U', 'Y', 'V', 'Y') | UYVY format (PC98 compliance).
Yuy2 | MakeFourCC('Y', 'U', 'Y', '2') | YUY2 format (PC98 compliance).

Buffer Formats

Depth, stencil, vertex, and index buffers each have unique formats.

Buffer flags | Format
D16Lockable | A 16-bit z-buffer bit depth.
D32 | A 32-bit z-buffer bit depth.
D15S1 | A 16-bit z-buffer bit depth in which 15 bits are reserved for the depth channel and 1 bit is reserved for the stencil channel.
D24S8 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 8 bits for the stencil channel.
D24X8 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel.
D24X4S4 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 4 bits for the stencil channel.
D32SingleLockable | A lockable format in which the depth value is represented as a standard Institute of Electrical and Electronics Engineers (IEEE) floating-point number.
D24SingleS8 | A nonlockable format that contains 24 bits of depth (in a 24-bit floating-point format - 20e4) and 8 bits of stencil.
D16 | A 16-bit z-buffer bit depth.
VertexData | Describes a vertex buffer surface.

All depth stencil formats except D16Lockable indicate no particular bit ordering per pixel, and the driver is allowed to consume more than the indicated number of bits per depth channel (but not per stencil channel).

Floating-Point Formats

These flags are used for floating-point surface formats. They use 16 bits per channel and are also known as s10e5 formats.

Floating-point flags | Format
R16F | A 16-bit floating-point format that uses 16 bits for the red channel.
G16R16F | A 32-bit floating-point format that uses 16 bits each for the red and green channels.
A16B16G16R16F | A 64-bit floating-point format that uses 16 bits for each channel (alpha, blue, green, and red).

IEEE Formats

These flags are used for floating-point surface formats. They use 32 bits per channel and are also known as s23e8 formats.

Floating-point flags | Format
R32F | A 32-bit floating-point format that uses 32 bits for the red channel.
G32R32F | A 64-bit floating-point format that uses 32 bits each for the red and green channels.
A32B32G32R32F | A 128-bit floating-point format that uses 32 bits for each channel (alpha, blue, green, and red).

Other

This flag is used for undefined formats.

Other flags | Format
Unknown | Surface format is unknown.

BackBuffer or Display Formats

These formats are the only valid formats for a back buffer or a display.

Format | Back buffer | Display
A2R10G10B10 | x | x (full-screen mode only)
A8R8G8B8 | x |
X8R8G8B8 | x | x
A1R5G5B5 | x |
X1R5G5B5 | x | x
R5G6B5 | x | x

Remarks

The order of the bits starts with the most significant byte, so A8L8 indicates that the high byte of this 2-byte format is alpha. The D16 format indicates a 16-bit integer value and an application-lockable surface.

Pixel formats have been chosen to enable the expression of extension formats defined by hardware vendors, and to include the well-established FOURCC method. The set of formats understood by the Direct3D runtime is defined by the Caps structure.

Note that formats are supplied by independent hardware vendors (IHVs), and many FOURCC codes are not listed. The formats in this enumeration are unique in that they are sanctioned by the runtime, which means that the reference rasterizer operates on all of these types. Formats supplied by IHVs are supported by the individual vendors on a card-by-card basis.

Related Topics

  • Format Enumeration


What is a Swap Chain?

Note: This documentation is preliminary and is subject to change.

A graphics adapter holds a pointer to a surface that represents the image being displayed on the monitor, called a front buffer. As the monitor is refreshed, the graphics card sends the contents of the front buffer to the monitor to be displayed. However, this leads to a problem when rendering real-time graphics. The heart of the problem is that monitor refresh rates are very slow in comparison to the rest of the computer. Common refresh rates range from 60Hz (60 times per second) to 100Hz. If an application is updating the front buffer while the monitor is in the middle of a refresh, the image that is displayed is cut in half, with the upper half of the display containing the old image and the lower half containing the new image. This problem is referred to as tearing.

Microsoft® Direct3D® implements two ways to avoid tearing: An option that allows updates of the monitor only on the vertical retrace (or vertical sync) operation, or a technique called back buffering. A monitor refreshes its image by sweeping the electron beam of the cathode ray tube (CRT) in a zigzag pattern, starting at the top left of the monitor and ending at the bottom right. When the scanning beam reaches the bottom, the monitor recalibrates the electron beam by moving it back to the upper left so that the process can start again. This recalibration is called a vertical sync. During a vertical sync, the monitor is not drawing anything, so any update to the front buffer will not be seen until the monitor starts to draw again. The vertical sync is relatively slow, but not slow enough to render a complex scene while waiting. What is needed to avoid tearing and to be able to render complex scenes is the process of back buffering.

Back buffering is the process of drawing a scene to an off-screen surface, called a back buffer. Note that any surface other than the front buffer is called an off-screen surface because it is never directly viewed by the monitor. By using a back buffer, an application has the freedom to render a scene whenever the system is idle (that is, no windows messages are waiting) without having to consider the monitor's refresh rate. Back buffering brings an additional complication of how and when to move the back buffer to the front buffer.

The process of moving the back buffer to the front buffer is called surface flipping. Remember that the graphics card simply uses a pointer to a surface to represent the front buffer. Because of this, a simple pointer change is all that is needed to set the back buffer to the front buffer. When an application asks Direct3D to present the back buffer to the front buffer, Direct3D simply flips the two surface pointers. The result is that the back buffer is now the new front buffer, and the old front buffer is the new back buffer. A surface flip is invoked whenever an application asks the Direct3D device to present the back buffer; however, Direct3D can be set up to queue the requests until a vertical sync occurs. This option is referred to as the Direct3D device's presentation interval. Note that the data in the new back buffer might not be reusable, depending on how an application specifies how Direct3D should handle surface flipping. Surface flipping is key in multimedia, animation, and game software. It is equivalent to the way that animation can be done with a pad of paper. On each page, the artist changes the figures slightly, so that when you flip rapidly between sheets, the drawing appears animated.

Related Topics

  • Flipping Surfaces


Width vs. Pitch

Note: This documentation is preliminary and is subject to change.

Although the terms width and pitch are often used interchangeably, their meanings are distinctly different. It is important to understand these meanings, and how to interpret the values that Microsoft® Direct3D® uses to describe them.

Direct3D uses the SurfaceDescription structure to carry information that describes a surface. Among other things, this structure is defined to contain information about a surface's dimensions, as well as how those dimensions are represented in memory. The structure uses the Height and Width members to describe the logical dimensions of the surface. Both members are measured in pixels. Therefore, the Height and Width values for a 640x480 surface are the same whether it is an 8-bit surface or a 24-bit RGB surface.

When a surface is locked using the Surface.LockRectangle method, and depending on the method overload called, the method returns either a GraphicsStream object or an Array Leave Site filled with the surface data. The pitch of the surface is passed back in the pitch parameter. The value returned in the pitch parameter describes the surface's memory pitch, also called stride. Pitch is the distance, in bytes, between two memory addresses that represent the beginning of one bitmap line and the beginning of the next bitmap line. Because pitch is measured in bytes rather than pixels, a 640x480x8 surface has a very different pitch value than a surface with the same dimensions but a different pixel format. Additionally, the pitch value sometimes reflects bytes that Direct3D has reserved as a cache, so it is not safe to assume that pitch is simply the width multiplied by the number of bytes per pixel. Rather, visualize the difference between width and pitch as shown in the following illustration.

Pitch and width difference

In this figure, the front buffer and back buffer are both 640x480x8, and the cache is 384x480x8.

When accessing surfaces directly, take care to stay within the memory allocated for the dimensions of the surface and stay out of any memory reserved for cache. Also, when locking only a portion of a surface, you must stay within the rectangle you specify when locking the surface. Failure to follow these guidelines will lead to unpredictable results. When rendering directly into surface memory, always use the pitch returned by the Surface.LockRectangle method. Do not assume a pitch based solely on the display mode. If your application works on some display adapters but looks garbled on others, this may be the cause of the problem.

Related Topics

  • Accessing Surface Memory Directly


Flipping Surfaces

Note: This documentation is preliminary and is subject to change.

A Microsoft® Direct3D® application typically displays an animated sequence by generating the frames of the animation in back buffers and presenting them in sequence. Back buffers are organized into swap chains. A swap chain is a series of buffers that flip to the screen one after another. A swap chain can be used to render one scene in memory and then flip the scene to the screen when rendering is complete. This prevents the phenomenon known as tearing, and allows for smoother animation.

Each device created in Direct3D has at least one swap chain. When you initialize the first Direct3D device, you set the BackBufferCount member of the PresentParameters structure, which tells Direct3D the number of back buffers that will be in the swap chain. The Device constructor then creates the Direct3D device and corresponding swap chain.

When you use the Device.Present method to request a surface flip operation, the pointers to surface memory for the front buffer and back buffers are swapped. Flipping is performed by switching pointers that the display device uses for referencing memory, not by copying surface memory. When a flipping chain contains a front buffer and more than one back buffer, the pointers are switched in a circular pattern, as shown in the following illustration.

Additional swap chains for a device can be created by calling the SwapChain constructor. An application can create one swap chain per view and associate each swap chain with a particular window. The application renders images in the back buffers of each swap chain, and then presents them individually. The two parameters that SwapChain takes are a reference to a PresentParameters object and a valid Device object. The SwapChain.Present method can then be used to display the contents of the next back buffer to the front buffer. Note that a device can have only one full-screen swap chain.

To gain access to a specific back buffer, call the Device.GetBackBuffer or SwapChain.GetBackBuffer method, which returns a Surface object that represents the returned back buffer surface.

Remember that Direct3D flips surfaces by swapping surface memory pointers within the swap chain, not by swapping the surfaces themselves. This means that you will always render to the back buffer that will be displayed next.

It is important to note the distinction between a "flipping operation" as performed by a display adapter driver, and a "present" operation applied to a swap chain that was created with SwapEffect.Flip.

The term flip conventionally denotes an operation that alters the range of video memory addresses that a display adapter uses to generate its output signal, thus causing the contents of a previously hidden back buffer to be displayed. In Microsoft DirectX® 9.0, the term is often used more generally to describe the presentation of a back buffer in any swap chain created with the SwapEffect.Flip swap effect.

While such "present" operations are almost invariably implemented by flip operations when the swap chain is a full-screen one, they are necessarily implemented by copy operations when the swap chain is windowed. Furthermore, a display adapter driver can use flipping to implement "present" operations against full-screen swap chains based on SwapEffect.Discard and SwapEffect.Copy.

For a more general discussion of the different swap effects for both windowed and full-screen swap chains, see SwapEffect.


Page Flipping and Back Buffering

Note: This documentation is preliminary and is subject to change.

Page flipping is key in multimedia, animation, and game software. It is similar to the way that animation is done with a pad of paper; that is, on each page, the artist changes the figure slightly, so that when you flip rapidly between sheets, the drawing appears to be animated.

Microsoft® Direct3D® implements page flipping functionality through a swap chain, which is a property of the device. Initially, you set up a series of Direct3D buffers that flip to the screen in the way that the artist's paper flips to the next page. The first buffer is referred to as the color front buffer. The buffers behind it are called back buffers. Your application writes to a back buffer and then flips the color front buffer so that the back buffer appears on screen. While the system displays the image, the software is again writing to a back buffer. The process continues as long as the animation, and enables you to animate images efficiently.

Direct3D makes it easy to set up page flipping schemes, from simple double-buffered schemes (that is, a color front buffer with one back buffer) to more sophisticated schemes with multiple back buffers.


Copying to Surfaces

Note: This documentation is preliminary and is subject to change.

Several restrictions apply when using Device.UpdateSurface to copy to a surface. You can pass a rectangle on the source surface, or use null to specify the entire surface. You can also pass a point on the destination surface to which the upper left position of the rectangle on the source image is copied.

The Device.UpdateSurface method does not support clipping. Unless the source rectangle and the corresponding destination rectangle are completely contained within the source and destination surfaces respectively, the operation will fail. Note that the destination and source surfaces must be distinct. The method also does not support alpha blending, color keys, or format conversion.

The following methods also are available for copying images to a Microsoft® Direct3D® surface.

  • SurfaceLoader.FromFile
  • SurfaceLoader.FromStream
  • SurfaceLoader.FromSurface

Related Topics

  • Device.StretchRectangle


Copying Surfaces

Note: This documentation is preliminary and is subject to change.

The term blit is shorthand for "bit block transfer," which is the process of transferring blocks of data from one place to another in memory. The blitting device driver interface (DDI) continues to be used in Microsoft® DirectX® 9.0 as the primary mechanism for moving large rectangles of pixels on a per-frame basis, the mechanism behind the copy-oriented Device.Present method. The transportation of artwork in the blit operation is performed by the Device.UpdateTexture method. Artwork also can be copied in DirectX 9.0 by using the Device.UpdateSurface method, which copies a rectangular subset of pixels.

Related Topics

  • Device.StretchRectangle


Accessing Surface Memory Directly

Note: This documentation is preliminary and is subject to change.

Surface memory can be accessed directly by using the Surface.LockRectangle method. When this method is called, the rect parameter is a reference to a Rectangle Leave Site structure that describes the rectangle on the surface to access directly. To request that the entire surface be locked, either call one of the Surface.LockRectangle overloads that do not take a Rectangle Leave Site structure, or set the rect parameter to the dimensions of the entire surface. It is also possible to specify a Rectangle Leave Site that covers only a portion of the surface. Providing that no two rectangles overlap, two threads or processes can simultaneously lock multiple rectangles in a surface. Note that a multisample back buffer cannot be locked.

Depending on which Surface.LockRectangle method overload is called, the method returns either a GraphicsStream object or an Array Leave Site that describes the locked region. The method call returns the pitch value in the pitch parameter. When access to the surface memory is finished, the Surface.UnlockRectangle method should be called to unlock it.

While a surface is locked, its contents can be manipulated directly. The following list provides some tips for avoiding common problems associated with directly rendering surface memory.

  • Never assume a constant display pitch. Always examine the pitch information returned by the Surface.LockRectangle method. This pitch can vary for a number of reasons, including the location of the surface memory, the display card type, or even the version of the Microsoft® Direct3D® driver. For more information, see Width vs. Pitch.
  • Be sure to copy to unlocked surfaces. Direct3D copy methods will fail if called on a locked surface.
  • Limit the application's activity while a surface is locked.
  • A surface cannot be locked if it belongs to a resource assigned to the Pool.Default memory pool, unless it is a dynamic texture or was created using Device.CreateOffscreenPlainSurface. Back buffer surfaces, which can be accessed using the Device.GetBackBuffer and SwapChain.GetBackBuffer methods, can be locked only if the swap chain was created with the PresentFlag property of the PresentParameters structure set to PresentFlag.LockableBackBuffer.


Private Surface Data

Note: This documentation is preliminary and is subject to change.

Any kind of application-specific data can be stored with a surface. For example, a surface that represents a map in a game might contain information about terrain.

A surface can have more than one private data buffer. Each buffer is identified by a globally unique identifier (GUID) that you supply when attaching the data to the surface.

To store private surface data, use Surface.SetPrivateData (inherited from the Resource class), passing an application-defined GUID for the data, and a Byte Leave Site array that contains the private data to associate with the surface. Data is passed by value, and multiple sets can be associated with a single resource.

The SetPrivateData method allocates an internal buffer for the data and copies it. Once this is done, it is safe to free the source buffer or object. The internal buffer is released when FreePrivateData is called. This occurs automatically when the surface is freed.

To retrieve private data for a surface, declare a Byte Leave Site array and then call the Surface.GetPrivateData method (also inherited from the Resource class), passing the GUID that was assigned to the data to populate the array.


Gamma Controls

Note: This documentation is preliminary and is subject to change.

Gamma controls allow you to change how the system displays the contents of the surface, without affecting those contents. Think of these controls as very simple filters that Microsoft® Direct3D® applies to data as it leaves a surface and before it is rendered on the screen.

Gamma controls are a property of a swap chain. They make it possible to dynamically change how a surface's red, green, and blue levels map to the actual levels that the system displays. By setting gamma levels, you can cause the user's screen to flash colors—red when the user's character is shot, green when the character picks up a new item, and so on—without copying new images to the frame buffer to achieve the effect. Or, you might adjust color levels to apply a color bias to the images in the back buffer.

There is always at least one swap chain (the implicit swap chain) for each device because Direct3D for Microsoft DirectX® 9.0 has one swap chain as a property of the device. Because the gamma ramp is a property of the swap chain, the gamma ramp can be applied when the swap chain is windowed. The gamma ramp takes effect immediately; there is no waiting for a vertical sync operation.

The Device.SetGammaRamp and Device.GetGammaRamp methods allow manipulation of ramp levels that affect the red, green, and blue color components of pixels from the surface before they are sent to the digital-to-analog converter (DAC) for display.

Gamma Ramp Levels

In Direct3D, the term gamma ramp describes a set of values that map the level of a particular color component—red, green, blue—for all pixels in the frame buffer to new levels that are received by the DAC for display. The remapping is performed by way of three look-up tables, one for each color component.

Here's how it works: Direct3D takes a pixel from the frame buffer and evaluates its individual red, green, and blue color components. Each component is represented by a value from 0 to 65535. Direct3D takes the original value and uses it to index a 256-element array (the ramp), where each element contains a value that replaces the original one. Direct3D performs this look-up and replace process for each color component of each pixel in the frame buffer, thereby changing the final colors for all of the on-screen pixels.

It is handy to visualize the ramp values by graphing them. In the following illustration, the left graph shows a ramp that does not modify colors at all. The right graph shows a ramp that imposes a negative bias to the color component to which it is applied.

The array elements for the graph on the left contain values identical to their index—0 in the element at index 0, and 65535 at index 255. This type of ramp is the default, as it does not change the input values before they are displayed. The right graph provides more variation; its ramp contains values that range from 0 in the first element to 32768 in the last element, with values ranging uniformly in between. The effect is that the color component that uses this ramp appears muted on the display. You are not limited to using linear graphs; your application can assign arbitrary mapping if needed. You can even set the entries to all zeroes to completely remove a color component from the display.

Setting and Retrieving Gamma Ramp Levels

Gamma ramp levels are effectively look-up tables that Direct3D uses to map the frame buffer color components to new levels that will be displayed. You can set and retrieve ramp levels for the primary surface by calling the Device.SetGammaRamp and Device.GetGammaRamp methods.

The Device.SetGammaRamp method accepts three parameters and the Device.GetGammaRamp method accepts one parameter. For Device.SetGammaRamp, the first parameter is an integer that specifies the swap chain. The second parameter, calibrate, is a Boolean value that controls whether gamma correction should be applied. The third parameter, ramp, is a GammaRamp structure that contains three 256-element arrays of short integers, one array each to contain the red, green, and blue gamma ramps. The Device.GetGammaRamp method has one parameter that takes an integer representing the swap chain that contains the GammaRamp to retrieve.

You can set the calibrate parameter of the Device.SetGammaRamp method to true to invoke the calibrator when setting new gamma levels. Calibrating gamma ramps incurs some processing overhead, and should not be used frequently. Setting a calibrated gamma ramp provides a consistent and absolute gamma value for the user, regardless of the display adapter and monitor.

Not all systems support gamma calibration. To determine whether it is supported, call Manager.GetDeviceCaps and examine the DriverCaps member of the returned Caps structure. If the DriverCaps.CanCalibrateGamma property is set to true, gamma calibration is supported.

When setting new ramp levels, keep in mind that that the levels you set in the arrays are used only when your application is in full-screen exclusive mode. Whenever your application changes to normal mode, the ramp levels are set aside, taking effect again when the application reinstates full-screen mode.

If the device does not support gamma ramps in the swap chain's current presentation mode (full-screen or windowed), no error value is returned. Applications can check the DriverCaps.SupportsFullscreenGamma and DriverCaps.CanCalibrateGamma properties to determine the capabilities of the device and whether a calibrator is installed.


Direct3D Textures

Note: This documentation is preliminary and is subject to change.

Textures are a powerful tool for creating realism in computer-generated 3-D images. Microsoft® DirectX® 9.0 for Managed Code supports an extensive texturing feature set, giving developers access to advanced texturing techniques.

This section provides an introduction to textures.

  • Basic Texturing Concepts


Basic Texturing Concepts

Note: This documentation is preliminary and is subject to change.

Early computer-generated 3-D images, although generally advanced for their time, tended to have a shiny plastic look. They lacked the types of markings—such as scuffs, cracks, fingerprints, and smudges—that give 3-D objects realistic visual complexity. In recent years, textures have gained popularity among developers as a tool for enhancing the realism of computer-generated 3-D images.

In its everyday use, the word texture refers to an object's smoothness or roughness. In computer graphics, however, a texture is a bitmap of pixel colors that give an object the appearance of texture.

Because Microsoft® Direct3D® textures are bitmaps, any bitmap can be applied to a Direct3D primitive. For instance, applications can create and manipulate objects that appear to have a wood grain pattern in them. Grass, dirt, and rocks can be applied to a set of 3-D primitives that form a hill. The result is a realistic-looking hillside. Textures also can be used to create effects such as signs along a road, rock strata in a cliff, or the appearance of marble on a floor.

In addition, Direct3D supports more advanced texturing techniques such as texture blending—with or without transparency—and light mapping.

If an application creates a hardware abstraction layer (HAL) device or a software device, it can use 8, 16, 24, 32, 64, or 128-bit textures.

Additional information is contained in the following topics.

  • Texture Addressing Modes
  • Texture Dirty Regions
  • Texture Palettes
  • Loading a Texture


Texture Addressing Modes

Note: This documentation is preliminary and is subject to change.

Your Microsoft® DirectX® 9.0 for Managed Code application can assign texture coordinates to any vertex of any primitive. Typically, the u-texture and v-texture coordinates that you assign to a vertex are in the range of 0.0 to 1.0, inclusive. However, by assigning texture coordinates outside of that range, you can create certain special texturing effects.

You control what Microsoft Direct3D® does with texture coordinates that are outside of the [0.0, 1.0] range by setting the texture addressing mode. For instance, you can have your application set the texture addressing mode so that a texture is tiled across a primitive.

Direct3D enables applications to perform texture wrapping. It is important to note that setting the texture addressing mode to TextureAddress.Wrap is not the same as performing texture wrapping. Setting the texture addressing mode to TextureAddress.Wrap results in multiple copies of the source texture being applied to the current primitive; enabling texture wrapping changes how the system rasterizes textured polygons.

Enabling texture wrapping effectively makes texture coordinates outside of the [0.0, 1.0] range invalid, and the behavior for rasterizing such delinquent texture coordinates is undefined in this case. When texture wrapping is enabled, texture addressing modes are not used. Ensure that your application does not specify texture coordinates lower than 0.0 or higher than 1.0 when texture wrapping is enabled.

Setting the Addressing Mode

You can set texture addressing modes for individual texture stages by setting the SamplerStateManager object, which is returned in the SamplerStateManagerCollection.SamplerState property that is retrieved from the Device.SamplerState property. The addressing mode can be set to any member of the TextureAddress enumeration. The following C# code example shows how to set and retrieve addressing modes.

          [C#]

// For this example, device is a valid Device object.
//
using System;
using Microsoft.DirectX.Direct3D;

// Load a texture.
Texture tx = new Texture(device, 4, 4, 0, 0, Format.X8R8G8B8, Pool.Managed);

// Set the texture in stage 0.
device.SetTexture(0, tx);

// Set some sampler states.
device.SamplerState[0].AddressU = TextureAddress.Clamp;
device.SamplerState[0].AddressV = TextureAddress.Border;

// Retrieve a sampler state.
TextureAddress ta = device.SamplerState[0].AddressU;

Device Limitations

Although the system generally allows texture coordinates outside of the range of 0.0 to 1.0, hardware limitations often affect how far outside of that range texture coordinates can be. A rendering device communicates this limit in the MaxTextureRepeat property of the Caps structure when you retrieve device capabilities. The value in this member describes the full range of texture coordinates the device allows. For instance, if this value is 128, the input texture coordinates must be kept in the range of -128.0 to +128.0. Passing vertices with texture coordinates outside of this range is invalid. The same restriction applies to the texture coordinates generated as a result of automatic texture coordinate generation and texture coordinate transformations.

The interpretation of Caps.MaxTextureRepeat also is affected by the TextureCaps.SupportsTextureRepeatNotScaledBySize property. When this property is set, the value in Caps.MaxTextureRepeat is used precisely as described. However, when TextureCaps.SupportsTextureRepeatNotScaledBySize is not set, texture-repeating limitations depend on the size of the texture indexed by the texture coordinates. In this case, Caps.MaxTextureRepeat must be scaled by the current texture size at the highest level of detail to compute the valid texture coordinate range. For example, given a texture dimension of 32 and a Caps.MaxTextureRepeat value of 512, the actual valid texture coordinate range is 512/32 = 16, so the texture coordinates for this device must be within the range of -16.0 to +16.0.

Additional information about the texture addressing modes is contained in the following topics.

  • Wrap Texture Address Mode
  • Mirror Texture Address Mode
  • Clamp Texture Address Mode
  • Border Color Texture Address Mode


Wrap Texture Address Mode

Note: This documentation is preliminary and is subject to change.

The wrap texture address mode, identified by the TextureAddress.Wrap enumerated value, makes Microsoft® Direct3D® repeat the texture on every integer junction. Suppose, for example, that an application creates a square primitive and specifies texture coordinates of (0.0,0.0), (0.0,3.0), (3.0,3.0), and (3.0,0.0). Setting the texture address mode to TextureAddress.Wrap results in the texture being applied three times in both the u-direction and the v-direction, as shown in the following illustration.

The effects of this texture address mode are similar to, but distinct from, those of the mirror mode. For more information, see Mirror Texture Address Mode.


Mirror Texture Address Mode

Note: This documentation is preliminary and is subject to change.

The mirror texture address mode, identified by the TextureAddress.Mirror enumerated value, causes Microsoft® Direct3D® to mirror the texture at every integer boundary. Suppose, for example, that an application creates a square primitive and specifies texture coordinates of (0.0,0.0), (0.0,3.0), (3.0,3.0), and (3.0,0.0). Setting the texture address mode to TextureAddress.Mirror results in the texture being applied three times in both the u-direction and the v-direction. Every other row and column to which it is applied is a mirror image of the preceding row or column, as shown in the following illustration.

The effects of this texture address mode are similar to, but distinct from, those of the wrap mode. For more information, see Wrap Texture Address Mode.


Clamp Texture Address Mode

Note: This documentation is preliminary and is subject to change.

The clamp texture address mode, identified by the TextureAddress.Clamp enumerated value, causes Microsoft® Direct3D® to clamp texture coordinates to the [0.0, 1.0] range. That is, it applies the texture once, and then smears the color of edge pixels.

For example, suppose that an application creates a square primitive and assigns texture coordinates of (0.0,0.0), (0.0,3.0), (3.0,3.0), and (3.0,0.0) to the primitive's vertices. Setting the texture address mode to TextureAddress.Clamp results in the texture being applied once. The pixel colors at the top of the columns and the end of the rows are extended to the top and right of the primitive respectively, as shown in the following illustration.


Border Color Texture Address Mode

Note: This documentation is preliminary and is subject to change.

The border color texture address mode is identified by the TextureAddress.Border enumerated value. It causes Microsoft® Direct3D® to use an arbitrary color, known as the border color, for any texture coordinates outside of the range of 0.0 through 1.0, inclusive.

In the following illustration, the application specifies that the texture be applied to the primitive using a red border.

Applications set the border color by setting the SamplerStateManager object returned in the SamplerStateManagerCollection.SamplerState property, which is retrieved from the Device.SamplerState property. In the following C# code example, the SamplerStateManagerCollection.SamplerState index parameter is set to the desired texture stage identifier, and the SamplerStateManager.BorderColor property is set to the new RGBA border color.

          [C#]

// For this example, device is a valid Device object.

using System;
using Microsoft.DirectX.Direct3D;

// Load a texture.
Texture tx = new Texture(device, 4, 4, 0, 0, Format.X8R8G8B8, Pool.Managed);

// Set the texture in stage 0.
device.SetTexture(0, tx);

// Set the address mode for the u-coord.
device.SamplerState[0].AddressU = TextureAddress.Border;

// Set the border color.
device.SamplerState[0].BorderColor = System.Drawing.Color.Blue.ToArgb();

// Get the border color.
int color = device.SamplerState[0].BorderColor;


Texture Dirty Regions

Note: This documentation is preliminary and is subject to change.

Applications can optimize which subset of a texture is copied by specifying dirty regions on textures. Only those regions marked as dirty are copied by a call to Device.UpdateTexture. However, the dirty regions can be expanded to optimize alignment. When a texture is created, the entire texture is considered dirty. Only the following operations affect this state.

  • Adding a dirty region to a texture.
  • Locking some buffer in the texture. This operation adds the locked region as a dirty region. The application can turn off this automatic dirty-region update if it has better knowledge of the actual dirty regions.
  • Using a surface level of the texture as a destination in Device.UpdateSurface marks the entire texture as dirty.
  • Using the texture as a source in Device.UpdateTexture clears all dirty regions on the source texture.
  • Using Surface.GetGraphics to return a device context.
  • Calling BaseTexture.GenerateMipSubLevels marks the entire texture as dirty.
  • Setting BaseTexture.AutoGenerateFilterType marks the entire texture as dirty.

Dirty regions are set on the top level of a mipmapped texture, and Device.UpdateTexture can expand the dirty region down the mip chain to minimize the number of bytes copied for each sublevel. Note that the sublevel dirty region coordinates are rounded outward; that is, their fractional parts are rounded toward the nearest edge of the texture.

Because each type of texture has different types of dirty regions, there are methods on each texture type, as shown in the following list. Two-dimensional (2-D) textures use dirty rectangles, and volume textures use boxes.

  • CubeTexture.AddDirtyRectangle
  • Texture.AddDirtyRectangle
  • VolumeTexture.AddDirtyBox

Omitting the rect or box parameters for the above methods expands the dirty region to cover the entire texture.

Each lock method can take LockFlags.NoDirtyUpdate, which prevents any changes to the dirty state of the texture. For more information, see Locking Resources.

When more information about the true set of regions that are changed during a lock operation is available, applications should use LockFlags.NoDirtyUpdate. Note that a lock or a copy to a texture sublevel only (that is, without locking or copying to the top level) does not update the dirty regions for that texture. Applications assume the same responsibility for updating dirty regions when they lock lower levels without locking the topmost level.


Texture Palettes

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectX® 9.0 for Managed Code supports paletted textures through a set of 256 entry palettes associated with a Device object. A palette is made current by setting the Device.CurrentTexturePalette property. The current palette is used for translating all paletted textures for all active texture stages. The Device.SetPaletteEntries method updates all of a palette's 256 entries. Each entry is a PaletteEntry structure of type Format.A8R8G8B8. All entries default to 0xFFFFFFFF.

The Device palettes contain an alpha channel that can be used when the TextureCaps.SupportsAlphaPalette device capability flag is set, indicating that the device supports alpha from the palette. The palette alpha channel is used when the texture format does not have an alpha channel. If the device does not support alpha from the palette and the texture format does not have an alpha channel, a value of 0xFF is used for alpha.

There is a maximum of 65,536 (0x0000FFFF) palettes. Because memory resources associated with the set of palettes are proportional to the maximum palette number that an application references, contiguous palette numbers starting at zero should be used.


Loading a Texture

Note: This documentation is preliminary and is subject to change.

With Microsoft® DirectX® 9.0 for Managed Code, it is relatively simple to load a texture. The following C# code example does just that. To load a texture using DirectX 9.0 for Managed Code, it is first necessary to create a valid Device and a Texture object.

          [C#]

using Microsoft.DirectX.Direct3D;
.
.
.
// Global variables for this project.
Device device = null; // Rendering device.
Texture texture = null;

// Initialize the device.
.
.
.
// Device reset method.
public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Now create the texture.
    texture = TextureLoader.FromFile(dev, Application.StartupPath +
                                              @"\..\..\banana.bmp");
}

Related Topics

  • Tutorial 5: Using Texture Maps
  • TextureLoader


Direct3D Tutorials

Note: This documentation is preliminary and is subject to change.

The following C# tutorials use the base functionality of Microsoft® Direct3D® to help you begin to create stand-alone graphics applications.

Tutorial | Description
Tutorial 1: Creating a Device | Initializes Direct3D, renders a simple blue screen, and eventually shuts down.
Tutorial 2: Rendering Vertices | Initializes the procedures of Tutorial 1, creates the simplest shape (a triangle), and renders it to the display.
Tutorial 3: Using Matrices | Introduces the concept of matrices and shows how to use them to transform the coordinates of vertices and to set up cameras and viewports.
Tutorial 4: Using Materials and Lights | Adds lights and materials to create more realism in Direct3D objects.
Tutorial 5: Using Texture Maps | Adds texture to Direct3D objects.
Tutorial 6: Using Meshes | Introduces the topic of meshes and shows how to load, render, and unload a mesh.

These tutorials follow a progression, where each retains most of the code of the previous tutorial but adds more functionality. All tutorials are located at (SDK root)\Samples\Managed\Direct3D\Tutorials\.


Tutorial 1: Creating a Device

Note: This documentation is preliminary and is subject to change.

The CreateDevice tutorial project initializes Microsoft® Direct3D®, renders a simple blue screen, and eventually shuts down.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial1

Procedure

Creating an Application Window

The first thing any Microsoft® Windows® application must do when run is to create an application window. To do this, the first call in the Main() function of the following sample code is to the constructor of an application-defined CreateDevice class that sets the size of the display window, the caption of the window, and the window icon. CreateDevice is created from the System.Windows.Forms.Form Leave Site class used in the Microsoft .NET Framework to represent a window in an application.

          [C#]

using System;
using System.Drawing;
using System.Windows.Forms;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

namespace DeviceTutorial
{
    public class CreateDevice : Form
    {
        // Our global variables for this project
        Device device = null; // Our rendering device

        public CreateDevice()
        {
            // Set the initial size of our form
            this.ClientSize = new System.Drawing.Size(400,300);
            // And its caption
            this.Text = "D3D Tutorial 01: CreateDevice";
        }
        .
        .
        .
    }
    .
    .
    .
}

Initializing the Direct3D Object

After you create the application window, you are ready to initialize the Direct3D object that you will use to render the scene. This process includes creating the object, setting the presentation parameters, and finally creating the Direct3D device.

          [C#]

public bool InitializeGraphics()
{
    try
    {
        // Now  setup our D3D stuff
        PresentParameters presentParams = new PresentParameters();
        presentParams.Windowed=true;
        presentParams.SwapEffect = SwapEffect.Discard;
        device = new Device(0, DeviceType.Hardware, this,
                CreateFlags.SoftwareVertexProcessing, presentParams);
                return true;
    }
    catch (DirectXException)
    {
         return false;
    }
}

The preceding code sample relies upon a PresentParameters object that is used to set the windows display characteristics. For example, by setting the Windowed property to true, the size of the window displayed is less than full screen. This default small-window format has no menu or child windows, but it includes Minimize, Maximize, and Close buttons common to windowed applications. In this case, the ability to quickly swap back buffer memory into system memory is disabled with the SwapEffect.Discard flag. If the Windowed property is instead false, then the created window is placed above all non-topmost windows and should stay above them, even when the window is deactivated.

The final step in the initialization procedure is to create the Direct3D device. In this example the flags input to the Device(Int32,DeviceType,Control,CreateFlags,PresentParameters[]) specify that a hardware device is preferred, and that vertex processing is to be done in software. Note that if you tell the system to use hardware vertex processing by specifying CreateFlags.HardwareVertexProcessing, you will see a significant performance gain on video cards that support hardware vertex processing.

Rendering the Direct3D Object

The application is kept running in a loop using the Application Leave Site.DoEvents Leave Site method, which here takes as its argument a CreateDevice object called frm. DoEvents Leave Site runs a standard Windows application message loop on the current thread.

          [C#]

static void Main()
{

    using (CreateDevice frm = new CreateDevice())
    {
        if (!frm.InitializeGraphics()) // Initialize Direct3D
        {
            MessageBox.Show(
                "Could not initialize Direct3D.  This tutorial will exit.");
            return;
        }
        frm.Show();

        // While the form is still valid, render and process messages
        while(frm.Created)
        {
            frm.Render();
            Application.DoEvents();
        }
    }
}

While the created CreateDevice Form Leave Site object is valid, an application-defined Render method is called to render the Direct3D object. First the viewport (the open window) is set to be a uniform blue color with the Device.Clear method. Scene rendering is begun using the Device.BeginScene method. Rendering is completed and the scene is ended with successive calls to the EndScene and Present methods.

          [C#]

private void Render()
{
    if (device == null)
        return;

    //Clear the backbuffer to a blue color
    device.Clear(ClearFlags.Target, System.Drawing.Color.Blue, 1.0f, 0);
    //Begin the scene
    device.BeginScene();

    // Rendering of scene objects can happen here

    //End the scene
    device.EndScene();
    device.Present();
}


Tutorial 2: Rendering Vertices

Note: This documentation is preliminary and is subject to change.

Applications written in Microsoft® Direct3D® use vertices to draw geometric shapes. Each three-dimensional (3-D) scene includes one or more of these geometric shapes. The Vertices tutorial project begins with the initialization procedures of Tutorial 1: Creating a Device and then creates the simplest shape, a triangle, and renders it to the display.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial2

Procedure

This tutorial renders a 2-D triangle by using three vertices. This introduces the concept of the vertex buffer, usually a VertexBuffer object that is used to store and render vertices.

Vertices can be defined in many ways through available structures in the CustomVertex custom vertex class. In this case, the vertices are transformed, so the vertices are already in 2-D window coordinates. The point (0,0) is therefore at the upper left corner, the positive x-axis is right, and the positive y-axis is down. These vertices also do not use Direct3D lighting, but instead they supply their own diffuse color. This character is specified by initializing the vertex buffer with the CustomVertex.CustomVertex.TransformedColored structure, as in the following code fragment.

          [C#]

public class Vertices : Form
{
    // Global variables for this project
    Device device = null; // Rendering device
    VertexBuffer vb = null;
    .
    .
    .
    public void OnCreateDevice(object sender, EventArgs e)
    {
    Device dev = (Device)sender;

    // Now create the vertex buffer
    vertexBuffer = new VertexBuffer(
        typeof(CustomVertex.TransformedColored), 3, dev, 0,
        CustomVertex.TransformedColored.Format, Pool.Default);
    vertexBuffer.Created +=
        new System.EventHandler(this.OnCreateVertexBuffer);
    this.OnCreateVertexBuffer(vb, null);
    }

    public void OnCreateVertexBuffer(object sender, EventArgs e)
    {
    VertexBuffer vb = (VertexBuffer)sender;
    GraphicsStream stm = vb.Lock(0, 0, 0);
    CustomVertex.TransformedColored[] verts =
        new CustomVertex.TransformedColored[3];
    .
    .
    .
    vb.Unlock();
    }
}

In the above code, the VertexBuffer.Lock method is called to grant direct CPU access to the vertex buffer data. Each lock call must be followed by an unlock call. See Locking Resources for more information on locking and unlocking.

The verts object created in the above code is an array of three CustomVertex.TransformedColored structures, one structure for each of the triangle's three vertices. The (X,Y,X), Rhw, and Color fields of each vertex structure are initialized in the following code. The ToArgb Leave Site method is used to provide color data in the required ARGB 32-bit format.

          [C#]

verts[0].X=150; verts[0].Y=50; verts[0].Z=0.5f; verts[0].Rhw=1;
verts[0].Color = System.Drawing.Color.Aqua.ToArgb();

verts[1].X=250; verts[1].Y=250; verts[1].Z=0.5f; verts[1].Rhw=1;
verts[1].Color = System.Drawing.Color.Brown.ToArgb();

verts[2].X=50; verts[2].Y=250; verts[2].Z=0.5f; verts[2].Rhw=1;
verts[2].Color = System.Drawing.Color.LightPink.ToArgb();

stm.Write(verts);

The GraphicsStream class (stm object) was introduced in the above two code fragments. A graphics stream is used to bind data to input registers for use by shaders. This code provides the GraphicsStream object direct access to the vertex buffer, or, understood in another way, it places the vertex buffer contents into the graphics stream and advances the current position within the stream by the length of the vertex buffer.

The following code fragment shows how the private Render method is expanded from Tutorial 1 to initialize the stream source, vertex format, and primitives rendering of the Device object. As in Tutorial 1, Render renders to the display as long as the current Vertices object (frm) is valid, or if a system paint event is triggered.

          [C#]

private void Render()
{
    if (device == null)
    return;

    // Clear the back buffer to a blue color (ARGB = 000000ff)
    device.Clear(ClearFlags.Target, System.Drawing.Color.Blue, 1.0f, 0);
    // Begin the scene
    device.BeginScene();

    // New for Tutorial 2
    device.SetStreamSource(0, vertexBuffer, 0);
    device.VertexFormat = CustomVertex.TransformedColored.Format;
    device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

    // End the scene
    device.EndScene();
    device.Present();
}


Tutorial 3: Using Matrices

Note: This documentation is preliminary and is subject to change.

The Matrices tutorial project introduces the concept of matrices and shows how to use them. Matrices are used to transform the coordinates of vertices and to set up cameras and viewports.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial3

Procedure

Note: For information about initializing Microsoft® Direct3D®, handling Microsoft Windows® messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 2: Rendering Vertices rendered 2-D vertices to draw a triangle. This tutorial adds to the code of Tutorial 2 to rotate the triangle using 3-D vertex transformations.

Because this project will apply transformations to the triangle object, instead of using already-transformed 2-D window coordinates as in Tutorial 2, the vertex buffer is initialized with the CustomVertex.CustomVertex.PositionColored structure, as in the following code fragment.

          [C#]

Device dev = (Device)sender;
// Now create the vertex buffer.
vertexBuffer = new VertexBuffer(typeof(CustomVertex.PositionColored),
                                3,
                                dev,
                                0,
                                CustomVertex.PositionColored.Format,
                                Pool.Default);

In addition, within the private Render method, the device vertex format is initialized to be the CustomVertex.PositionColored format, as shown in the following code. Before geometry is rendered, the application-defined SetupMatrices method, which creates and sets the 3-D matrix transformations of the triangle object, is called from Render.

          [C#]

private void Render()
{
    .
    .
    .
    // Set up the world, view, and projection matrices.
    SetupMatrices();

    device.SetStreamSource(0, vertexBuffer, 0);
    device.VertexFormat = CustomVertex.PositionColored.Format;
    device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

    // End the scene.
    device.EndScene();
    device.Present();
}

Typically, three types of transformation are set for a 3-D scene. The transformations are all defined as properties of the Transforms object, accessed from the Device.Transform property. All use a left-handed coordinate system typical of Direct3D; see 3-D Coordinate Systems.

  1. World Transformation Matrix: In this case, the triangle is rotated around the y-axis by calling the Matrix.RotateY method, as shown in the following code sample. Note that Matrix is part of the general-purpose Microsoft.DirectX namespace. This call uses the system Environment Leave Site.TickCount Leave Site method, divided by a scaling value, to provide the RotateY argument in radians. This procedure yields a smoothly-varying rotation about the y-axis.
  2. View Transformation Matrix: The view transformation matrix yields the camera view of the scene, in this sample code by calling the Matrix.RotateY method. Three Vector3 vectors form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The three vectors represent respectively the eye location, the camera look-at target (in this case the origin), and the current world's up-direction.
  3. Projection Transformation Matrix: The projection transformation matrix defines how geometry is transformed from 3-D view space to 2-D viewport space. In this sample code it is formed from the matrix returned by the left-handed PerspectiveFovLH method. Arguments to the method are the field of view in radians, the aspect ratio (view space height divided by width), the near clipping plane distance, and the far clipping plane distance.

The order in which these transformation matrices are created does not affect the layout of the objects in a scene. However, Direct3D applies the matrices to the scene in the above order.

          [C#]

private void SetupMatrices()
{
    // For our world matrix, we will just rotate the object about the y-axis.

    // Set up the rotation matrix to generate 1 full rotation (2*PI radians)
    // every 1000 ms. To avoid the loss of precision inherent in very high
    // floating point numbers, the system time is modulated by the rotation
    // period before conversion to a radian angle.
    int  iTime  = Environment.TickCount % 1000;
    float fAngle = iTime * (2.0f * (float)Math.PI) / 1000.0f;
    device.Transform.World = Matrix.RotationY( fAngle );

    // Set up our view matrix. A view matrix can be defined given an eye
    // point, a point to lookat, and a direction for which way is up. Here,
    // we set the eye five units back along the z-axis and up three units,
    // look at the origin, and define "up" to be in the y-direction.

    device.Transform.View = Matrix.LookAtLH(
        new Vector3( 0.0f, 3.0f,-5.0f ),
        new Vector3( 0.0f, 0.0f, 0.0f ),
        new Vector3( 0.0f, 1.0f, 0.0f ) );

    // For the projection matrix, we set up a perspective transform (which
    // transforms geometry from 3D view space to 2D viewport space, with
    // a perspective divide making objects smaller in the distance). To build
    // a perpsective transform, we need the field of view (1/4 pi is common),
    // the aspect ratio, and the near and far clipping planes (which define
    // at what distances geometry should be no longer be rendered).
    device.Transform.Projection = Matrix.PerspectiveFovLH(
        (float)Math.PI / 4,
        1.0f,
        1.0f,
        100.0f );
}

The character of rendering is controlled by setting properties of the RenderStateManager class. This is done in the OnResetDevice application-defined method, as shown in the following code fragment.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;
    // Turn off culling, so the user sees the front and back of the triangle
    dev.RenderState.CullMode = Cull.None;
    // Turn off Direct3D lighting, since object provides its own vertex colors
    dev.RenderState.Lighting = false;
}

In this case, culling beyond a backplane and Direct3D lighting are both turned off. These settings allow the full depth of the 3-D object to be viewed and the object to provide its own colors.


Tutorial 4: Using Materials and Lights

Note: This documentation is preliminary and is subject to change.

The Lights tutorial project adds lights and materials to create more realism in Microsoft® Direct3D® objects. Each object in the scene will be lit based on the location and type of lights that are used. Materials describe how polygons reflect ambient and diffuse light, how their specular highlights appear, and whether the polygons appear to emit light.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial4

Procedure

Note: For information about initializing Direct3D, handling Microsoft Windows® messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 3: Using Matrices transformed object vertices in 3-D. This tutorial adds to the Tutorial 3 code to create a material and a light.

Initializing a Depth Stencil

This project also adds to the Tutorial 3 initialization an initialization procedure to allow use of a z-buffer (depth buffer) and a depth stencil, as shown in the following code fragment. Depth stencils enable applications to mask sections of the rendered image so that they are not displayed. Here the depth stencil is first enabled, and then the format is set to a 16-bit z-buffer depth.

          [C#]

public bool InitializeGraphics()
{
    .
    .
    .
    // Turn on a depth stencil
    presentParams.EnableAutoDepthStencil = true;

    // Set the stencil format
    presentParams.AutoDepthStencilFormat = DepthFormat.D16;
    .
    .
    .
}

Intializing the Vertex Buffer and Render States

One of the requirements of using lights is that each surface has a normal vector. This project therefore uses a different custom vertex type than the previous tutorials, the CustomVertex.PositionNormal structure, which includes a 3-D position and a surface normal that is used internally by Direct3D for lighting calculations.

          [C#]

public void OnCreateDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Now create the vertex buffer
    vertexBuffer = new VertexBuffer(typeof(CustomVertex.PositionNormal),
                                    100,
                                    dev,
                                    Usage.WriteOnly,
                                    CustomVertex.PositionNormal.Format,
                                    Pool.Default);
    vertexBuffer.Created +=
                    new System.EventHandler(this.OnCreateVertexBuffer);
    this.OnCreateVertexBuffer(vertexBuffer, null);
}

The sample code also enables use of a z-buffer (depth buffer), for efficiently storing scene geometry, and enables Direct3D lighting with RenderStateManager properties as follows.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Turn off culling, so the user sees the front and back of the triangle
    device.RenderState.CullMode = Cull.None;

    // Turn on the z-buffer
    device.RenderState.ZBufferEnable = true;
    device.RenderState.Lighting = true;    // Make sure lighting is enabled
}

Creating the Cylinder Object

At device initialization (OnCreateDevice shown above), the application-defined OnCreateVertexBuffer method is called to create a cylinder object. A vertex buffer is initialized that stores the points of the cylinder, and then the position and normal of each point on the cylinder are loaded into the vertex buffer, as shown in the following sample code.

          [C#]

public void OnCreateVertexBuffer(object sender, EventArgs e)
{
    VertexBuffer vb = (VertexBuffer)sender;
    // Create and lock a vertex buffer (which will return the structures)
    CustomVertex.PositionNormal[] verts =
                    (CustomVertex.PositionNormal[])vb.Lock(0,0);

    for (int i = 0; i < 50; i++)
    {
        // Fill up the structs
        float theta = (float)(2 * Math.PI * i) / 49;
        verts[2 * i].SetPosition(new Vector3(
                    (float)Math.Sin(theta), -1, (float)Math.Cos(theta)));
        verts[2 * i].SetNormal(new Vector3(
                    (float)Math.Sin(theta), 0, (float)Math.Cos(theta)));
        verts[2 * i + 1].SetPosition(new Vector3(
                    (float)Math.Sin(theta), 1, (float)Math.Cos(theta)));
        verts[2 * i + 1].SetNormal(new Vector3(
                    (float)Math.Sin(theta), 0, (float)Math.Cos(theta)));
    }
    // Unlock (and copy) the data
    vb.Unlock();
}

The cylinder is rotated using the world transformation matrix in the SetupMatrices private method, as in Tutorial 3.

Creating a Material

A material defines the color that is reflected off the surface of a geometric object when a light hits it. The following code fragment uses the Material structure to create a material that is white in color. The diffuse and ambient color properties for the material are set to white. After this call is made, every primitive will be rendered with this material until the color properties are set to another value.

          [C#]

private void SetupLights()
{
    System.Drawing.Color col = System.Drawing.Color.White;

    // Set up a material. The material here just has the diffuse and ambient
    // colors set to white. Note that only one material can be used at a time.
    Direct3D.Material mtrl = new Direct3D.Material();
    mtrl.Diffuse = col;
    mtrl.Ambient = col;
    device.Material = mtrl;
    .
    .
    .
}

Creating a Light

There are three types of lights available in Direct3D: point lights, directional lights, and spotlights. This tutorial project creates a directional light, which is a light that shines in one direction, and it oscillates the direction of the light. The following code fragment uses a Light object to create a directional light with a dark turquoise color. All objects in the scene are also illuminated with a low level of monochromatic (gray) ambient lighting.

          [C#]

private void SetupLights()
{
    .
    .
    .
    // Set up a colored directional light, with an oscillating direction.
    // Note that many lights may be active at a time (but each one slows down
    // the rendering of the scene). However, here just one is used.
    device.Lights[0].Type = LightType.Directional;
    device.Lights[0].Diffuse = System.Drawing.Color.DarkTurquoise;
    device.Lights[0].Direction = new Vector3(
                    (float)Math.Cos(Environment.TickCount / 250.0f),
                    1.0f,
                    (float)Math.Sin(Environment.TickCount / 250.0f));

    device.Lights[0].Enabled = true; // Turn it on

    // Finally, turn on some ambient light.
    // Ambient light is light that scatters and lights all objects evenly.
    device.RenderState.Ambient = System.Drawing.Color.FromArgb(0x202020);


Tutorial 5: Using Texture Maps

Note: This documentation is preliminary and is subject to change.

The Textures tutorial project adds texture to Microsoft® Direct3D® objects. While lights and materials add a great deal of realism to a scene, nothing adds more realism than adding textures to surfaces. Textures can be thought of as wallpaper that is shrink-wrapped onto a surface. You could place a wood texture on a cube to make it look like the cube is actually made of wood. This tutorial project adds a "banana peel" texture to the cylinder object created in Tutorial 4: Using Materials and Lights.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial5

Procedure

Note: For information about initializing Direct3D, handling Microsoft Windows® messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 4: Using Materials and Lights created materials and lighting on the Direct3D object. This tutorial adds to the Tutorial 4 code with procedures for loading textures, setting up vertices, and displaying objects with texture.

Creating the Texture

To be able to use textures, a vertex buffer must be created that has texture coordinates in its custom vertex format. Texture coordinates tell Direct3D where to place a texture for each vector in a primitive. Texture coordinates range from 0.0 to 1.0, where (0.0, 0.0) represents the upper left side of the texture and (1.0, 1.0) represents the lower-right side of the texture.

After initializing a new Texture object, the following sample code sets the format of the vertex buffer using the CustomVertex.PositionNormalTextured structure. This initialization prepares the vertex buffer to receive (x, y, z) position and (x, y, z) normal data, and one set of (tu, tv) texture coordinates.

          [C#]

public class Textures : Form
{
    // Our global variables for this project
    Device device = null; // Our rendering device
    VertexBuffer vertexBuffer = null;
    Texture texture = null;
    .
    .
    .

    public void OnCreateDevice(object sender, EventArgs e)
    {
        Device dev = (Device)sender;

        // Now create the vertex buffer
        vertexBuffer = new VertexBuffer(
                            typeof(CustomVertex.PositionNormalTextured),
                            100,
                            dev,
                            Usage.WriteOnly,
                            CustomVertex.PositionNormalTextured.Format,
                            Pool.Default);
        vertexBuffer.Created += new System.EventHandler(
                            this.OnCreateVertexBuffer);
        this.OnCreateVertexBuffer(vertexBuffer, null);
    }
}

Loading Texture Data

The render state settings (display parameters) are similar to those of Tutorial 4, except that Direct3D lighting is disabled to allow the colors of the cylinder object to be displayed, and a "banana peel" texture is loaded from a bitmap file using the TextureLoader.FromFile method.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Turn off culling, so the user sees the front and back of the triangle
    dev.RenderState.CullMode = Cull.None;

    // Turn off Direct3D lighting
    dev.RenderState.Lighting = false;

    // Turn on the z-buffer
    dev.RenderState.ZBufferEnable = true;

    // Now create the texture
    texture = TextureLoader.FromFile(dev,
                        Application.StartupPath + @"\..\..\banana.bmp");
}

The procedure for loading the vertex buffer with the cylinder object's properties is identical to the OnCreateVertexBuffer application-defined method in Tutorial 4, with the addition of texture coordinates (tu, tv) for each point, as shown in the following code sample. This procedure causes the texture to wrap smoothly around the cylinder when rendered, and the texture remains pinned to the original cylinder.

          [C#]

public void OnCreateVertexBuffer(object sender, EventArgs e)
{
    VertexBuffer vb = (VertexBuffer)sender;

    // Create a vertex buffer
    // Lock the buffer (which will return the structures)
    CustomVertex.PositionNormalTextured[] verts =
                (CustomVertex.PositionNormalTextured[])vb.Lock(0,0);
    for (int i = 0; i < 50; i++)
    {
        // Fill up the structures
        float theta = (float)(2 * Math.PI * i) / 49;
        verts[2 * i].SetPosition(new Vector3((float)Math.Sin(theta),
                                -1,
                                (float)Math.Cos(theta)));
        verts[2 * i].SetNormal(new Vector3((float)Math.Sin(theta),
                                0,
                                (float)Math.Cos(theta)));

        verts[2 * i].Tu = ((float)i)/(50-1);
        verts[2 * i].Tv = 1.0f;

        verts[2 * i + 1].SetPosition(new Vector3((float)Math.Sin(theta),
                                1,
                                (float)Math.Cos(theta)));
        verts[2 * i + 1].SetNormal(new Vector3((float)Math.Sin(theta),
                                0,
                                (float)Math.Cos(theta)));

        verts[2 * i + 1].Tu = ((float)i)/(50-1);
        verts[2 * i + 1].Tv = 0.0f;
    }
}

Rendering the Scene

Texture stages enable you to define the behavior of how a texture or textures are to be rendered. For example, you could blend multiple textures together. This tutorial project starts with the private Render method of Tutorial 4 and sets to 0 the texture stage that the Direct3D device will use to render. A device can have up to eight set textures, so the maximum stage value is 7, but this tutorial project has only one texture and places it at stage 0. Zero is used as both the stage parameter of the Device.SetTexture method and as the array value for the Device.TextureState property.

Constants of the TextureOperation and TextureArgument enumerations control how the texture renders. For example, the settings in this code cause the output color to be the texture color multiplied by the diffuse color. For more information on color blending in textures.

          [C#]

private void Render()
{
    .
    .
    .
    // Set up our texture. Using textures introduces the texture stage states,
    // which govern how textures get blended together (in the case of multiple
    // textures) and lighting information. In this case, modulate (blend)
    // the texture with the diffuse color of the vertices.
    device.SetTexture(0,texture);
    device.TextureState[0].ColorOperation = TextureOperation.Modulate;
    device.TextureState[0].ColorArgument1 = TextureArgument.TextureColor;
    device.TextureState[0].ColorArgument2 = TextureArgument.Diffuse;
    device.TextureState[0].AlphaOperation = TextureOperation.Disable;
    .
    .
    .


Tutorial 6: Using Meshes

Note: This documentation is preliminary and is subject to change.

Complicated geometry is usually modeled using 3-D modeling software and saved to a file. An example of this is the .x file format. Microsoft® Direct3D® uses meshes to load the objects from these files. The Meshes tutorial project introduces the topic of meshes and shows how to load, render, and unload a mesh.

A mesh contains the data for a complex model. It is an abstract data container that contains resources such as textures and materials, and attributes such as position data and adjacency data. Although meshes are somewhat complicated, Direct3D contains methods that make using meshes easier.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial6

Procedure

Note: For information about initializing Direct3D, handling Microsoft Windows® messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 5: Using Texture Maps created texture on the Direct3D object. This tutorial adds to the Tutorial 5 code with procedures for handling a mesh from a file, but it drops the OnCreateDevice application-defined method and related device creation calls that were used to create a vertex buffer. The procedure used here handles vertex buffers implicitly within mesh method calls.

Initializing a Mesh Object

This tutorial project initializes multidimensional material and texture arrays as follows. Note also the using declarations of System.ComponentModel Leave Site and System.IO Leave Site namespaces.

          [C#]

using System;
using System.Drawing;
using System.ComponentModel;
using System.Windows.Forms;
using System.IO;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;
using Direct3D = Microsoft.DirectX.Direct3D;
public class Meshes : Form
{
    Device device = null;              // Rendering device
    Mesh mesh = null;                  // Mesh object in system memory
    Direct3D.Material[] meshMaterials; // Materials for the mesh
    Texture[] meshTextures;            // Textures for the mesh
    PresentParameters presentParams = new PresentParameters();
    .
    .
    .
}

The application-defined OnResetDevice method initializes an ExtendedMaterial object that is used to capture the mesh file data to a Material structure. The method sets the directory path to the mesh file, initializes a device, and turns on the z-buffer and white ambient lighting.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    ExtendedMaterial[] materials = null;

    // Set the directory up to load the right data, because the
    // default build location is Bin\debug or Bin\release.
    Directory.SetCurrentDirectory(Application.StartupPath +  @"\..\..\");

    Device dev = (Device)sender;

    // Turn on the z-buffer.
    dev.RenderState.ZBufferEnable = true;

    // Turn on ambient lighting.
    dev.RenderState.Ambient = System.Drawing.Color.White;
    .
    .
    .
}

Loading a Mesh Object

As shown in the following code fragment, the OnResetDevice method next loads a mesh that represents a texture-mapped 3-D tiger from the tiger.x file. In this Mesh.FromFile method call, the SystemMemory constant of the MeshFlags enumeration indicates that the mesh is to be loaded into system RAM not typically accessible by the device. After the mesh is loaded, a meshMaterials Material object has its members filled with the Material structures of the materials ExtendedMaterial object that came from the mesh file. The material is also set to the ambient color. Finally, a meshTextures Texture object is loaded with the texture the file with a call to the TextureLoader.FromFile method. Both meshMaterials and meshTextures are initialized to the dimension (Length Leave Site) of the materials structure from the file.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    .
    .
    .
    // Load the mesh from the specified file.
    mesh = Mesh.FromFile("tiger.x",
                         MeshFlags.SystemMemory,
                         device,
                         out materials);
    if (meshTextures == null)
    {
        // Extract the material properties and texture names.
        meshTextures  = new Texture[materials.Length];
        meshMaterials = new Direct3D.Material[materials.Length];
        for( int i=0; i<materials.Length; i++ )
        {
            meshMaterials[i] = materials[i].Material3D;

            // Set the ambient color for the material. Direct3D
            // does not do this by default.
            meshMaterials[i].Ambient = meshMaterials[i].Diffuse;

            // Create the texture.
            meshTextures[i] = TextureLoader.FromFile(dev,
                                       materials[i].TextureFilename);
        }
    }
}

Rendering a Mesh Object

After the mesh has been loaded, the private Render method is called to render the mesh object. It first begins the scene and calls the SetupMatrices application-defined method, as was done in Tutorial 5. To render the mesh, it is divided into subsets, one for each material that was loaded. As shown in the following code fragment, a loop is run to render each material subset. The loop does the following for each material:

  • The Material property of the device is set to the meshMaterials Material structure.
  • The device texture stage 0 is set to the meshTextures Texture structure.
  • The material subset is drawn with the DrawSubset method, which inherits from the BaseMesh class.

          [C#]

private void Render()
{
    .
    .
    .
    for( int i=0; i<meshMaterials.Length; i++ )
    {
        // Set the material and texture for this subset.
        device.Material = meshMaterials[i];
        device.SetTexture(0, meshTextures[i]);

        // Draw the mesh subset.
        mesh.DrawSubset(i);
    }

    // End the scene.
    device.EndScene();
    device.Present();
}


Microsoft® DirectX® 9.0 for Managed Code Samples

Note: This documentation is preliminary and is subject to change.

The samples in this section show how to use Microsoft Direct3D® and D3DX in a C# application. Once you have mastered the tutorials, you are ready to jump into the samples. Some of these samples demonstrate the latest features of DirectX 9.0 for Managed Code. Other samples demonstrate existing functionality that is fundamental to using Direct3D. All of the samples are built on top of the sample framework. See The Sample Framework and Sample Framework Reference.

Samples

These samples demonstrate the newest techniques incorporated into DirectX. Although DirectX samples include Microsoft Visual Studio® .NET solution files, you might need to verify other settings in your development environment to ensure that the samples compile properly.

Sample | Description
BasicHLSL Direct3D Sample | Shows a simple example of the high-level shader language (HLSL) using an effect interface.
CompiledEffect Direct3D Sample | Shows how an Effect object can be compiled when the project is built and loaded directly as a binary file at run time.
CustomUI Direct3D Sample | A simple demonstration of the user interface (UI) subsystem implemented by the DirectX 9.0 for Managed Code sample framework.
EmptyProject Direct3D Sample | A starting point for new Direct3D applications.
EnhancedMesh Direct3D Sample | Demonstrates mesh tessellation in Direct3D.
HDRCubeMap Direct3D Sample | Demonstrates cubic environment-mapping with floating-point textures and high dynamic range (HDR) lighting.
HLSLwithoutEffects Direct3D Sample | Shows an example of how to use Direct3D's HLSL, without the use of the D3DX effect interfaces.
ProgressiveMesh Direct3D Sample | Shows how an application can use the D3DX progressive mesh functionality to simplify meshes for faster rendering.
C# Scripting Direct3D Sample | Demonstrates one possible technique for using C# code as a 'script' in your unmanaged applications, and includes techniques to ensure scripts that are not deemed to be 'safe' cannot be executed.
Text3D Direct3D Sample | Shows how to draw 2-D text in a 3-D scene.


BasicHLSL Direct3D Sample

Note: This documentation is preliminary and is subject to change.

This sample shows a simple example of the high-level shader language (HLSL) using an effect interface.

Path

Source: | (SDK root)\Samples\Managed\Direct3D\BasicHLSL
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csBasicHLSL.exe

Sample Overview

This sample simply loads a Mesh, creates an Effect from a file, and then uses the Effect to render the Mesh. The Effect that is used is a simple vertex shader that animates the vertices based on time, along with the possibility to have multiple directional lights.

How Does It Work?

First the sample loads the geometry with Mesh.FromFile and calls ComputeNormals() to create mesh normals if there aren't any. It then calls OptimizeInplace() to optimize the mesh for the vertex cache. It then loads the textures using CreateTextureFromFile(). Finally, it calls CreateEffectFromFile() to compile the effect text file into an Effect object called effect.

Note that the CreateEffectFromFile()call takes flags which are needed to debug shaders with the Microsoft® Visual Studio® .NET shader debugger. Debugging vertex shaders requires either Refernce or software vertex processing, and debugging pixel shaders requires Refernce. The ShaderFlags.Force*SoftwareNoOptimizations flag improves the debug experience in the shader debugger. It enables source level debugging, prevents instruction reordering, prevents dead code elimination, and forces the compiler to compile against the next higher available software target, which ensures that the unoptimized shaders do not exceed the shader model limitations. Setting these flags will cause slower rendering since the shaders will be unoptimized and forced into software. All that is needed to turn these flags on with the sample code is to uncomment the #define DEBUG_VS or #define DEBUG_PS line from near the top of the file. This will also force the device into software processing by adding some code to ModifyDeviceSettings.

In OnFrameRender() it sets the technique to use with a call to effect.Technique. It passes an EffectHandle (in this case a string) to the technique. It is possible to pass a handle instead of a string, and using a handle improves performance since this high frequency call does not have to spend time on a string compare.

It then sets variables used by the technique such as the World*View*Projection matrix and the time variable with various effect.SetArrayRange calls. To render it calls effect.BeginPass() which returns the number of passes required by the technique, then it loops through each pass calling effect.BeginPass(iPass) and rendering the mesh with mesh.DrawSubset. After each pass, effect.EndPass is called. When all the passes are done, it calls effect.End.


CompiledEffect Direct3D Sample

Note: This documentation is preliminary and is subject to change.

This sample shows how an Effect object can be compiled when the project is built and loaded directly as a binary file at run time.

Path

Source: | (SDK root)\Samples\Managed\Direct3D\CompiledEffect
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csCompiledEffect.exe

Sample Overview

Large-scale projects may contain dozens or even hundreds of shader and effect files. Compiling these files at run time can cause a noticeable delay during initialization, and this delay is incurred each and every time the project is run; instead, these files can be compiled as part of your project build process, eliminating the need for any further compilation during program execution. Since these files will only need to be compiled when changes are made, no additional build time is spent on effect files which have already been compiled. Note that when developing or debugging effect files it is still beneficial to compile at run time, which allows more debugging flexibility. Also note that the process illustrated in this sample is identical whether compiling a complete Effect object or individual shaders. The only change would be the target profile command line passed to the compiler.

How Does It Work?

The code is very similar to the BasicHLSL sample except for a couple important differences:

  • The call to the CreateEffectFromFile function is passed the filename of the compiled effect (CompiledEffect.fxo) instead of the filename of the effect source (CompiledEffect.fx).
  • No debugging flags are passed to the CreateEffectFromFile function. Instead, flags are passed to the effect compiler to enable shader debugging.

The program used to compile shaders at build time is fxc. This command-line utility ships with the software development kit (SDK), and wraps the EffectCompiler calls used to perform the compilation. It's interesting to note that you could create your own shader compiler fairly easily using the EffectCompiler class, but fxc should be flexible enough for most needs. The commands used to build release and debug versions of a hypothetical MyEffect.fx file are:

Release: | fxc /Tfx_2_0 /FoMyEffect.fxo MyEffect.fx
Debug: | fxc /Od /Zi /Tfx_2_0 /FoMyEffect.fxo MyEffect.fx

Run fxc without any arguments for usage information.

Build Environment Configuration

To configure the build environment using Microsoft® Visual Studio® .NET, complete the following steps.

  1. Open the CompiledEffect sample project inside Visual Studio .NET.
  2. From within the Solution Explorer window, right click CompiledEffect project and select Properties from the context menu.
  3. Select Common Properties, then Build Events to view the custom build step directives.


CustomUI Direct3D Sample

Note: This documentation is preliminary and is subject to change.

This sample is a simple demonstration of the user interface (UI) subsystem implemented by the Microsoft® DirectX® 9.0 for Managed Code sample framework. The sample framework provides code and infrastructure common to most DirectX 9.0 for Managed Code applications. One area of the framework is user interface support. The sample framework contains commonly used control objects, such as buttons and check boxes, that both windowed and full screen Microsoft Direct3D® applications can use to implement their user interfaces.

Path

Source: | (SDK root)\Samples\Managed\Direct3D\CustomUI
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csCustomUI.exe

How Does It Work?

This sample demonstrates how an application that uses the DirectX 9.0 for Managed Code sample framework can take advantage of the framework's UI support. The sample framework supports the following control types:

Control type | Class that implements it
Statics | Microsoft.Samples.DirectX.UtilityToolkit.StaticText
Buttons | Microsoft.Samples.DirectX.UtilityToolkit.Button
Radio buttons | Microsoft.Samples.DirectX.UtilityToolkit.RadioButton
Check boxes | Microsoft.Samples.DirectX.UtilityToolkit.Checkbox
Combo boxes | Microsoft.Samples.DirectX.UtilityToolkit.ComboBox
List boxes | Microsoft.Samples.DirectX.UtilityToolkit.ListBox
Sliders | Microsoft.Samples.DirectX.UtilityToolkit.Slider
Scrollbars | Microsoft.Samples.DirectX.UtilityToolkit.Scrollbar
Edit boxes | Microsoft.Samples.DirectX.UtilityToolkit.EditBox

All of the sample framework controls work similarly to Microsoft Windows® controls. They are implemented entirely from scratch and with the exception of the EditBox do not use any Windows control underneath. They are also rendered with Direct3D, and therefore can be used by both windowed and full screen Direct3D applications.

This sample starts by defining two Dialog objects: hud and sampleUi. A Dialog serves as a container that encapsulates one or more controls. It sits between the application and the controls, so that the application can pass messages and rendering calls to Dialog, and Dialog will ensure that all of its controls receive the messages and get rendered properly. The controls themselves are designed to be used with a Dialog, not stand-alone. Applications are not limited to one Dialog object. They can use more at once, as this sample does.

As the user interacts with the UI controls, the controls can notify the sample about important events, so that it can respond accordingly. At this time the sample also initializes additional fonts that it will need. This is done with the SetFont method.

The next step that the sample has to do is create the controls it needs. This is achieved by calling the Dialog's AddXXX methods, such as AddButton. In the sample, hud contains 3 buttons that provide standard functionalities that Direct3D samples have: toggle between Hardware and Reference devices, and changing 3D device settings. sampleUi contains the rest of the controls, which are sample-specific. After a control is added, its appearance can be modified. This is demonstrated in the sample as it modifies the appearance of the static controls as well as the combo box. At creation the appropriate events are hooked for each control and responded to in the event handler methods.

Next, in OnResetDevice, are a number of calls to the Dialog's and controls' SetSize and SetLocation methods. This is because when the user resizes the application window, some dialogs and controls need to be resized and repositioned as well. It is worth noting that the Dialog's location is relative to the application window, while a control's location is relative to the Dialog it belongs.

To render the user interface, the sample calls the OnRender method of the two Dialog objects in its OnFrameRender function. Dialog will render the controls it contains in the correct order.

The final step required to make the UI work is passing messages to the controls. This lets them receive keyboard and mouse events from the user. In MsgProc, the sample calls Dialog's MsgProc method to pass down the messages. It is very important that if Dialog's MsgProc returns true indicating that the message has been handled, the sample sets the noFurtherProcessing parameter to true and returns immediately. Failure to do so will cause a message to be processed more than once.

Events

Certain events happen as the user interacts with the UI controls, such as checking or unchecking a check box, selecting a new item in a combo box, selecting a new item in a radio button group, etc. The application may be interested in such events, and it can be notified with controls events. In the sample, a series of event handler functions are defined and hooked as the controls are created. As a result, these functions will get called whenever the user performs an interesting action with a UI control. The actions that can trigger a callback are:

  • Clicking a button (Button)
  • Selecting a new item in a combo box (ComboBox)
  • Selecting a new item in a radio button group (RadioButton)
  • Changing the check state of a check box (CheckBox)
  • Changing the value of a slider (Slider)
  • Pressing Enter in an edit box (EditBox and EditBox)

In the event handlers, the control that fired the event and any necessary extra data are available to the application. The sample responds to the events by retrieving content of the firing control and displaying it on screen.


EmptyProject Microsoft® Direct3D® Sample

Note: This documentation is preliminary and is subject to change.

This sample is a starting point for new Direct3D applications.

  • Path
  • Sample Overview
  • How Does It Work?

Path

Source: | (SDK root)\Samples\Managed\Direct3D\EmptyProject
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csEmptyProject.exe

Sample Overview

This sample is a bare-bones Direct3D application provided as a convenient starting point for your own project.

How Does It Work?

This sample uses the sample framework to initialize and run a basic Direct3D application.


EnhancedMesh Microsoft® Direct3D® Sample

Note: This documentation is preliminary and is subject to change.

This sample demonstrates mesh tessellation in Direct3D. Mesh tessellation subdivides mesh triangles. This produces a mesh with finer geometry details which can produce better lighting results even with per-vertex lighting. Mesh tessellation is often used to implement a level of detail (LOD) technique where meshes closer to the viewer are rendered with more details, and meshes further away are rendered with less detail.

  • Path
  • How Does It Work?

Path

Source: | (SDK root)\Samples\Managed\Direct3D\EnhancedMesh
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csEnhancedMesh.exe

How Does It Work?

The sample can run in one of two modes: hardware tessellation or software tessellation. The user can set the tessellation level to different values and see how the mesh changes in reaction to the level adjustment.

When running in hardware tessellation mode, the sample tessellates the mesh by setting the Device.NPatchMode property which sets the number of tessellation segments into which the device will tessellate each mesh segment. For instance, specifying 3.0 will cause each original segment in the input mesh to be tessellated into three segments. This tessellation happens in real-time, after the mesh draw calls in the render loop.

When running in software tessellation mode, the sample does not rely on the hardware to do on-the-fly tessellation. Therefore, the sample must process the mesh and obtain the desired detail level before rendering it. The code achieves this by calling Mesh.TessellateNPatches which takes an input mesh and a segment count, and then outputs another mesh that represents the tessellated version of the input mesh. The sample can then render this tessellated mesh using any standard mechanism.


HDRCubeMap Microsoft® Direct3D® Sample

Note: This documentation is preliminary and is subject to change.

This sample demonstrates cubic environment-mapping with floating-point textures and high dynamic range (HDR) lighting. In Microsoft DirectX® 9.0, floating-point formats have become available for textures. These formats can store color values higher than 1.0, which can make lighting effects more realistic on the environment-mapped mesh when the material absorbs part of the light.

Note that not all cards support all features for the environment-mapping and HDR lighting techniques.

  • Path
  • User's Guide
  • Sample Overview
  • Implementation
  • The Rendering Code
  • The Shaders
  • High Dynamic Range Realism
  • Alternatives

Path

Source: | (SDK root)\Samples\Managed\Direct3D\HDRCubeMap
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csHDRCubeMap.exe

User's Guide

General controls defined in the sample:

Key | Action
E,D | Adjust material reflectivity
W,S | Adjust light intensity
F | Change cubic map format
R | Reset lighting parameters
N | Change to another mesh
F2 | Change device
Esc | Quit

Sample Overview

HDRCubeMap shows off two rendering techniques: cubic environment-mapping and HDR lighting. Cubic environment-mapping is a technique in which the environment surrounding a 3-D object is rendered into a cube texture map, so that the object can use the cube map to achieve complex lighting effects without expensive lighting calculations. HDR lighting is a technique to render highly-realistic lighting effects by using floating-point textures and high-intensity lights. The floating-point texture formats are introduced in DirectX 9.0. Unlike traditional textures in integer format, floating-point textures are capable of storing a wide range of color values. Because color values in floating-point textures do not get clamped to [0, 1], much like lights in the real world, these textures can be used to achieve greater realism.

The scene that HDRCubeMap renders is an environment-mapped mesh, along with several other objects making up the environment around the mesh. The mesh has a reflectivity setting adjustable from 0 to 1, where 0 means the mesh absorbs light completely, and 1 means it absorbs no light and reflects all. The lights used in the scene consist of four point lights, whose intensity is adjustable by the user.

Implementation

HDRCubeMap follows the DirectX sample framework architecture.

The scene that the sample renders consists of these objects:

  • A room Mesh object. This includes the walls, floor, and ceiling.
  • Four small sphere Mesh objects representing light sources.
  • A Mesh object in the center of the room with the environment map applied to it.
  • Two bi-plane Mesh objects. These orbit around the environment-mapped mesh and are reflected on the environment map. They give the visual cue that the environment map is dynamic, and changes as the surrounding environment changes.

When the sample loads, it creates two cubic textures, one in A8R8G8B8 format and the other in A16B16G16R16F format. When rendering, the sample uses one of these to construct an environment map based on the user's choice. This is done to show the visual difference between integer and floating-point textures when used with HDR lighting. A stencil surface with a size equal to the size of a cube texture face is also created at this time. This stencil surface will be used as the stencil buffer when the sample renders the scene onto the cube texture. The sample also creates an effect object that contains all of the shaders and techniques needed for rendering the scene.

The camera used in the sample is a ModelViewerCamera. This camera always looks at the origin, where the environment-mapped mesh is. The user can move the camera position around the mesh and rotate the mesh with mouse control. The camera object computes the view and projection matrices for rendering, as well as the world matrix for the environment-mapped mesh.

The Rendering Code

The rendering of the sample happens in three functions: RenderSceneIntoCubeMap(), OnFrameRender(), and RenderScene(), using vertex and pixel shaders.

RenderScene() is the function that does the actual work of rendering the scene onto the current render target. This is called both to render the scene onto the cube texture and onto the device backbuffer. It takes six parameters: the device used for rendering, a view matrix, a projection matrix, the technique group for the currently selected rendering mode, the application's current time, and a flag indicating whether it should render the environment-mapped mesh. The flag is needed because the environment-mapped mesh is not drawn when constructing the environment map. The rest of the function is straight-forward. It first updates the effect object with the latest transformation matrices, as well as the light position in view space. Then, it renders every mesh object in the scene by using an appropriate technique for each one.

The job of RenderSceneIntoCubeMap() is to render the entire scene (minus the environment-mapped mesh) onto the cube texture. First, it saves the current render target and stencil buffer, and sets the stencil surface for the cube texture as the device stencil buffer. Next, the function iterates through the six faces of the cube texture. For each face, it sets the appropriate face surface as the render target. Then, it computes the view matrix to use for that particular face, with the camera at the origin looking out in the direction of the cube face. It then calls RenderScene() with bRenderEnvMappedMesh set to false, passing along the computed view matrix and a special projection matrix. This projection matrix has a 90 degree field of view and an aspect ratio of 1, owing to the fact that the render target is a square. After this process is complete for all six faces, the function restores the old render target and stencil buffer. The environment map is now fully constructed for the frame.

OnFrameRender() is the top level rendering function called once per frame by the sample framework. It calls RenderSceneIntoCubeMap() to construct the cube texture to reflect the environment for that frame. After that, it renders the scene by calling RenderScene() with the view and projection matrices from the camera, and renderEnvMappedMesh set to true.

The Shaders

All of the rendering in this sample is done by programmable shaders, divided into three effect techniques: RenderLight, RenderHDREnvMap, and RenderScene.

The RenderLight technique is used for rendering the spheres representing the light sources. The vertex shader does a usual world-view-projection transformation, then assigns the light intensity value to the output diffuse. The pixel shader propagates the diffuse to the pipeline.

The RenderHDREnvMap technique is used for rendering the environment-mapped mesh in the scene. Besides transforming the position from object space to screen space, the vertex shader computes the eye reflection vector (the reflection of the eye-to-vertex vector) in view space. This vector is passed to the pixel shader as a cubic texture coordinate. The pixel shader samples the cube texture, applies the reflectivity to the sampled value, and returns the result to the pipeline.

The RenderScene technique is used to render everything else. Objects rendered by this technique employ per-pixel diffuse lighting. The vertex shader transforms the position from object to screen space. Then, it computes the vertex position and normal in view space and passes them to the pixel shader as texture coordinates. The pixel shader uses this information to perform per-pixel lighting. A for-loop is used to compute the amount of light received from the four light sources. The diffuse term of the pixel is computed by taking the dot product of the normal and the unit vector from the pixel to the light. The attenuation term is computed as the reciprocal of the square of the distance between the pixel and the light. These two terms are then modulated to represent the amount of light the pixel receives from one of the light sources. Once this process is done for all lights in the scene, the values are summed and modulated with the light intensity and the texel to form the output.

High Dynamic Range Realism

Prior to DirectX 9.0, only integer texture formats are supported by Direct3D. When a texture of this type is used, if a color value is higher than 1.0, it is clamped to 1.0 before being written so that the value can fit in an 8-bit integer. This means that when the cube texture is written, its texel color values will have a maximum of 1.0. When this texture is later used for environment-mapping on a material that is not 100 percent reflective (perhaps only 30 percent reflective), even the brightest texels in the texture will end up showing at 0.3 on the mesh, regardless of how high the original light intensity is. Consequently, realism is compromised. This is demonstrated in the figure below.

When DirectX 9.0's new floating-point cube texture is used with lights whose intensity is higher than 1, the texture is capable of storing color values higher than 1.0, thus preserving true luminance even after the reflectivity multiplication. The figure below shows this.

Alternatives

It is possible to achieve a high level of realism in an HDR lighting environment without using floating-point cube textures. An application can accomplish this by applying the material reflectivity multiplier when constructing the cubic environment map. Then, during rendering, the pixel shader will sample the cube texture and output the value straight back to the pipeline. This method works around color-clamping by scaling before the clamping instead of after. The drawback of this method is that if the scene has multiple environment-mapped objects with different reflectivity, a different environment map will generally need to be rendered for each of these objects.


HLSLwithoutEffects Microsoft® Direct3D® Sample

Note: This documentation is preliminary and is subject to change.

This sample shows an example of how to use Direct3D's high-level shader language (HLSL), without the use of the D3DX effect interfaces. Not using the Effect interface is a more difficult method of using HLSL. See BasicHLSL Direct3D Sample for a simpler method of using HLSL.

  • Path
  • Sample Overview
  • How Does It Work?

Path

Source: | (SDK root)\Samples\Managed\Direct3D\HLSLwithoutEffects
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csHLSLwithoutEffects.exe

Sample Overview

The sample demonstrates using HLSL to write vertex shaders without using the D3DX Effect Interfaces. HLSL is a language that closely resembles C syntax and constructs. By writing shaders in HLSL instead of assembly language, developers can take advantage of not only the features and elements of the language with which they are already familiar, but also the great optimization capabilities offered by the D3DX shader compiler.

How Does It Work?

The scene that this sample renders consists of a square grid of triangles lying on the XZ plane. In each frame, the vertices of this grid will move up or down along the Y direction based on a function of their distance to the origin and time. The vertices are also lit using another function of the distance and time. The time is incremented for each frame. Because the Y coordinate and color of the vertices are generated in each frame, they do not need to be stored. Therefore, the vertex declaration only contains a Vector2 member, for the X and Z coordinates.

During initialization, the sample calls CompileShaderFromFile to compile the sample's shader function stored in a file into binary shader code, that can be understood by the 3-D device. After this process, a GraphicsStream object containing the shader code and a ConstantTable object that allows the application to get and set the global variables of the shader are created. Then, the sample creates a new vertex shader using the shader code to obtain a VertexShader object that can be passed to the 3-D device for execution.

In OnFrameMove(), the sample uses the ConstantTable obtained from initialization to set the shader's global variables worldViewProj and appTime, in order to update the view + projection transformation and time parameter for the shader. At render time, the sample sets the VertexShader property to enable vertex shader rendering on the device. When DrawIndexedPrimitives is called after that, the vertex shader will be invoked once for every vertex processed.

In the sample, the vertex shader is written in a text file called HLSLwithoutEffects.fx. In this file, there are two global variables and a shader function called Ripple. Ripple takes a float2 as input (for X and Z of the vertex), and outputs two float4 representing the screen-space position and vertex color. The Y coordinate is generated using this formula:

Y = 0.1 * sin( 15 * L * sin(T) );

L is the distance between the vertex and the origin before the Y adjustment, so it has the value of sqrt( X^2 + Z^2 ), because the vertices are lying on the XZ plane. T is the appTime global variable.

The color of the vertex will be some shade of gray based on this formula:

C = 0.5 - 0.5 * cos( 15 * L * sin(T) );

C will be the value used for all red, green, blue, and alpha, and will range from 0 to 1, giving the vertex a color of black to white, respectively. The result looks like ripples with width changing back and forth between narrow and wide, and are properly shaded based on the slope.


ProgressiveMesh Microsoft® Direct3D® Sample

Note: This documentation is preliminary and is subject to change.

This sample shows how an application can use the D3DX progressive mesh functionality to simplify meshes for faster rendering. A progressive mesh is a specialized mesh object that can increase or decrease its geometry complexity, thereby providing flexibility when drawing the mesh so that performance can be maintained at a steady level. This feature is useful when providing level of detail (LOD) support in an application.

  • Path
  • How Does It Work?

Path

Source: | (SDK root)\Samples\Managed\Direct3D\ProgressiveMesh
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csProgressiveMesh.exe

How Does It Work?

The functionalities of progressive meshes are provided by the ProgressiveMesh object. This ProgressiveMesh object is similar to the Mesh object with additional methods for managing the mesh's complexity. The progressive mesh can be used just like a regular mesh. To render it, the sample loops through its materials and calls DrawSubset to send the geometry subset to the device. To adjust the progressive mesh's LOD, the sample sets the ProgressiveMesh.NumberVertices property to the desired number of vertices. A progressive mesh will simplify or enhance its geometry to match the number of vertices as closely as possible.

The sample also shows an optimization technique for progressive meshes by trimming multiple progressive meshes. Trimming limits the maximum and minimum number of vertices or faces a progressive mesh can have. The sample divides the range (maximum - minimum) of the progressive mesh vertices into ten sub-ranges. After the sub-ranges are computed, the sample creates ten progressive meshes by calling ProgressiveMesh.Clone on the original mesh. Then the sample calls ProgressiveMesh.TrimByVertices on each progressive mesh using a different sub-range. After setting the range of vertices, the sample calls ProgressiveMesh.OptimizeBaseLevelOfDetail to optimize the mesh's vertex and index buffers. Whenever the user changes the vertex count, the new vertex count is checked against the range of the optimized progressive mesh set, and the mesh whose range contains the desired vertex count is selected the ProgressiveMesh.NumberVertices property.

The advantage of using multiple meshes is that adjusting LOD is more efficient than using a single progressive mesh. The performance load of changing LOD is directly proportional to the difference in complexity (represented by vertex count in this sample). Simplifying a mesh by reducing the number of vertices by ten takes less time than reducing the vertex count by 100. That is why this sample achieves better performance by trimming several progressive meshes, each of which covers a smaller LOD range.


C# Scripting Microsoft® Direct3D® Sample

Note: This documentation is preliminary and is subject to change.

The sample demonstrates one possible technique for using C# code as a 'script' in your unmanaged applications, and includes techniques to ensure scripts that are not deemed to be 'safe' cannot be executed. The sample includes three scripts, one simple 'stateless' script, one more advanced script which maintains state and reacts to the environment, and a final script that is emulating a 'bad' script that attempts to delete files from your hard drive.

Path

Source: | (SDK root)\Samples\Managed\Direct3D\Scripting
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\Scripting.exe

Sample Overview

Having a robust scripting engine in your game titles can open up new avenues for development of your title. Many different aspects of the game could be controlled by these 'scripts' (although given these will actually be compiled and executed, 'script' is not entirely accurate). You could have your camera scripted for a 'cut scene' inside the game, game AI, or any other number of manipulations of your game environment. One of the more exciting prospects would be to have user added content (for example custom added units) that would use the scripts to have custom actions, and react to the environment appropriately.

This particular sample comes with three different types of scripts, each with a unique characteristic:

  • Script #1 - A simple state-less script that makes the character move slowly around the scene while rotating.
  • Script #2 - A more advanced script that maintains state, and uses this information to deteremine which action to perform. The character can bounce off walls, and the rotation will change when it does so.
  • Bad Guy Hacker Script - A script that is designed to emulate a "Bad Guy Hacker" trying to delete files from your computer. Due to the security settings set on the scripts that are allowed to run, this will not be allowed.

How Does It Work?

This sample uses the most direct technique possible to compile the C# code into scripts on the fly. It starts with the ShadowVolume C++ software development kit (SDK) Sample, and is modified to allow the character in the scene to be controllable by C# scripts. First, the sample was updated to be a mixed mode assembly by adding the /CLR compiler switch. This allows you to have your managed code that will control the scripting engine to be embedded directly into your application.

You'll notice that the unmanaged code file of the sample also includes a new #pragma unmanaged directive to let the compiler know that this code will only be unmanaged code. At startup the security policy is set and then while running, the user is allowed to pick one of the three scripts that ship with the SDK (or choose no scripts at all).

When one of the scripts is selected from the user interface, the work for compiling and loading the script's code happens. An instance of the CSharpCodeProvider Leave Site class is created, and the raw code of the script is fed into the class to be compiled. The assembly is compiled and stored in the temporary files where it is then loaded into the application. Once the assembly has been loaded, the main class of the script (which all scripts must implement) is loaded and stored; this will be used later to call the methods from the script.

Note: For this sample, any compile errors from one of the scripts will be ignored and the character will simply behave as if there are no scripts running.

Once a script has been compiled and loaded, a series of four potential methods will be called (depending on if the script implements them). The character's rotation (on each axis) can be modified, as well as the character's position.

Security Considerations

Allowing unknown code to run within your game engine can be a scary prospect to say the least. What would stop a script writer from deciding to write a script that emailed all of your important documents to everyone in your global address book, then formatted your hard drive? C# as a language is extremely powerful and could allow you to do either of these things in a fully trusted environment.

Luckily, managed code has something called Code Access Security, which was designed specifically for situations such as this. By default, any code running on the local machine (which most client applications will be) is granted Full Trust, which basically means it is allowed to do anything the language is capable of doing (like format the hard drive). To ensure these unsafe things aren't allowed the Application Domain's security policy is updated. During startup, the sample calls the Initialize() method on the script engine, which contains the following code snippet:

// Create a new, empty permission set so we don't mistakenly grant some permission we don't want
PermissionSet* pPermissions = new PermissionSet(PermissionState::None);

// Set the permissions that you will allow, in this case we only want to allow execution of code
pPermissions->AddPermission(new SecurityPermission(SecurityPermissionFlag::Execution));

// Make sure we have the permissions currently
pPermissions->Demand();

// Create the security policy level for this application domain
PolicyLevel* pSecurityLevel = PolicyLevel::CreateAppDomainLevel();

// Give the policy level's root code group a new policy statement based
// on the new permission set.
pSecurityLevel->RootCodeGroup->PolicyStatement = new PolicyStatement(pPermissions);

// Update the application domain's policy now
AppDomain::CurrentDomain->SetAppDomainPolicy(pSecurityLevel);

The code above first creates a PermissionSet, using the PermissionState::None permission state, which is essentially saying 'Do not allow this code to do anything'. Obviously, this is a little too restrictive, since at the very least, you will want the code that is running the scripts to be executed. Given that, you can add a new permission to this list that you will allow, and as you see in the code snippet, the SecurityPermissionFlag::Execution is added (there are quite a few different security permissions that can be set in this manner). After the PolicyLevel is created, and the RootCodeGroup is updated, the application domain's security policy is updated. Any assemblies loaded after this point (such as the scripts later) will have this security policy enforced. Notice when you're running the sample, the final script fails to run due to the security violations.

Performance Considerations

In this sample, you'll notice that the InvokeMember() method is called in order to execute the script methods. While this method is quick to implement and works well, this technique also relies on Reflection to make this call, which can be an order of magnitude slower than simply calling the method directly. In the scenario where you are making one (or more) calls per frame as this sample is doing, you will probably want to implement a more efficient way to call these methods.

One of the easier implementations that has much better performance than this technique is by defining an interface that the scripts must implement. You would put this interface into a managed assembly which you would then add a reference to in your application. When compiling the script, you would get the Interface type you declared in the managed assembly and call the methods on that directly. This would remove the cost of the InvokeMember() method, and instead allow you to call into the compiled scripts directly.

Implementation Considerations

It might not be possible (or practical) for your application to be compiled with the /CLR switch to be compiled as a mixed mode assembly (one that contains both managed and unmanaged code) like this sample does. There are numerous other ways you could implement techniques similar to what this sample does such as:

  • Separate mixed mode assembly that contains both the Script Engine code (like this example has) as well as an unmanaged interopability layer that your unmanaged code will call.
  • Separate purely managed assembly (for example a C# assembly) that contains the ScriptEngine code where the classes are marked as [ComImport]. This method requires much more setup time because the managed assembly will need to be registered for Component Object Model (COM) use via the RegAsm tool.
  • Require the script code themselves to implement the [ComImport] attribute. This is definitely the worst of the scenarios.


Text3D Microsoft® Direct3D® Sample

Note: This documentation is preliminary and is subject to change.

This sample shows how to draw 2-D text in a 3-D scene. This is useful for displaying statistics or game menus, for example.

Path

Source: | (SDK root)\Samples\Managed\Direct3D\Text3D
Executable: | (SDK root)\Samples\Managed\Direct3D\bin\csText3D.exe

Programming Notes

This sample uses the Font class to display 2-D text in a 3-D scene. The class uses Microsoft Windows® Graphics Device Interface (GDI) to load a font and output each letter to a bitmap. That bitmap, in turn, is used to create a texture.

When the DrawText function is called, a vertex buffer is filled with polygons that are textured using the font texture created as mentioned above. The polygons may be drawn as a 2-D overlay which may be useful for printing statistics.

The sample also creates a 3-D mesh of a text string and renders it.


Microsoft® DirectX® 9.0 for Managed Code Sample Framework

Note: This documentation is preliminary and is subject to change.

The sample framework is a layer used by most of the Microsoft Direct3D® samples and is built on top of the Microsoft Windows® application programming interface (API) and the Direct3D API. Its goal is to make Direct3D samples, prototypes, and tools as well as professional games more robust and easier to build. It simplifies the Windows and Direct3D APIs for typical usage and is designed to help make simple to moderately complex Direct3D applications.

Using the DirectX 9.0 for Managed Code Sample Framework

The DirectX 9.0 for Managed Code sample framework is included in the DirectX software development kit (SDK) as C# source files that you can include in your application. They are located in the following directory:

(SDK root)\Samples\Managed\Common Directory

To include the functionality of the sample framework in an application you can either start your application with the EmptyProject Microsoft® Direct3D® Sample or do the following:
  • Add the following classes to your project:
    • dxmut.cs
    • dxmutdata.cs
    • dxmutenum.cs
    • dxmutexception.cs
    • dxmutgui.cs
    • dxmutmesh.cs
    • dxmutmisc.cs
    • dxmutSettingsDlg.cs
  • Add the references to the following namespaces to your project:
    • Microsoft.DirectX
    • Microsoft.DirectX.Direct3D
    • Microsoft.DirectX.Direct3DX
  • Set the "Allow Unsafe Code Blocks" build flag for your project to true.

For documentation on the API elements provided by the framework, see Sample Framework Reference.


.Framework

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains properties and methods that provide helper functionality for 3-D graphics in applications such as the Microsoft® DirectX® 9.0 for Managed Code sample applications included in the Microsoft® DirectX® software development kit (SDK).

Definition

Visual Basic .NET Public Class Framework
Inherits MarshalByRefObject
Implements IDisposable
C# public class Framework : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Framework : public MarshalByRefObject,
IDisposable
JScript .NET public class Framework extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
DeviceCreated | Occurs when the Direct3D Device object is created.
DeviceLost | Occurs when the Direct3D Device object is lost.
DeviceReset | Occurs when the Direct3D Device object is reset.
Disposing | Occurs when the Framework object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
DefaultSizeHeight | Retrieves the default window height, in pixels, when the application starts.
DefaultSizeWidth | Retrieves the default window width, in pixels, when the application starts.
TrueIntPtr | Retrieves the Boolean value of true as a System.IntPtr Leave Site.

Methods

Method | Description
CloseWindow | Closes the current application window.
CreateDevice | Creates a Microsoft Direct3D® device.
CreateDeviceFromSettings | Tells the framework to change to a device created from settings described in a DeviceSettings object.
CreateWindow | Creates a window for the application.
DisplayErrorMessage | Displays a custom error message box.
Dispose | Immediately releases the unmanaged resources used by the Framework object.
Finalize | Allows the Framework object to free resources before it is destroyed by the garbage collector.
Initialize | Initializes the sample framework.
KillTimer | Uninstalls an existing timer.
LoadFirstIconFromResource | Attempts to load the first icon from the application's resources.
MainLoop | Starts the main execution loop of the sample framework.
Pause | Sets the paused state of the sample framework internal timer and/or rendering process.
Render3DEnviroment | Renders the 3-D environment and updates application and device parameters.
Reset3DEnviroment | Resets the 3-D environment.
ResetState | Resets the sample framework state to its initial default state, and all previous framework state changes are lost.
SetCallbackInterface | Sets the interface that the sample framework will use to call into samples.
SetConstantFrameTime | Enables or disables a constant frame time.
SetCursorSettings | Sets options for cursor usage in full-screen mode.
SetDevice | Sets an existing Direct3D Device for use by the sample framework.
SetDeviceCreationInterface | Sets the interface that the framework will use to determine if a device is acceptable.
SetKeyboardCallback | Sets the keyboard event callback function.
SetMouseCallback | Sets the mouse event callback function.
SetTimer | Adds a timer to the list of timers for the application.
SetWindow | Sets a previously created window for the framework to use.
SetWndProcCallback | Sets the WndProcCallback delegate to use in the sample framework.
ShowSettingsDialog | Indicates whether the sample framework's device settings dialog box is currently showing.
ToggleFullscreen | Switches the application between windowed and full-screen modes.
ToggleReference | Switches the application between hardware abstraction layer (HAL) and reference devices.

Properties

Property | Description
BackBufferSurfaceDescription | Retrieves a SurfaceDescription structure that describes the back buffer on the current adapter.
CanAutomaticallyChangeMonitor | Sets or retrieves if the current adapter can automatically change monitors.
Device | Retrieves the Device object currently used by the framework.
DeviceCaps | Retrieves a Caps structure that describes the capabilities of the current device.
DeviceSettings | Retrieves the DeviceSettings object that contains the device settings for the current Device object used by the framework.
DeviceStats | Retrieves a string containing the current device type, vertex processing behavior, and device name.
ExitCode | Retrieves the sample framework exit code.
FPS | Retrieves the number of frames per second the application is currently running.
FrameStats | Retrieves a string containing the current number of frames per second, resolution, back buffer format, and depth stencil format.
IsD3DSettingsDialogShowing | Retrieves whether the settings dialog is displayed.
IsNotifiedOnMouseMove | Retrieves whether the framework should notify for mouse moves.
IsOverridingFullScreen | Retrieves whether the framework should override and start fullscreen.
IsWindowed | Retrieves whether the current device is windowed.
PresentParameters | Retrieves the PresentParameters object for the current Device object.
Window | Retrieves the handle of the window used for rendering.
WindowClientRectangle | Retrieves the size and location of the window that is rendering.
WindowDeviceFullscreen | Retrieves the handle of the window used for fullscreen rendering.
WindowDeviceWindowed | Retrieves the handle of the window used for windowed rendering.
WindowFocus | Retrieves the handle of the window that currently has focus.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Framework

Class Information

Namespace | Framework
Assembly ()
Strong Name | , Version=, Culture=, PublicKeyToken=


Framework.CloseWindow()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CloseWindow Method

 Language:
Note: This documentation is preliminary and is subject to change.

Closes the current application window.

Definition

Visual Basic .NET | Public Sub CloseWindow()
C# | public void CloseWindow();
Managed C++ | public: void CloseWindow();
JScript .NET | public function CloseWindow();


Framework.CreateDevice(UInt32,Boolean,Int32,Int32,CreateDevice)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CreateDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a Microsoft® Direct3D® device.

Definition

Visual Basic .NET Public Sub CreateDevice( _
ByVal adapterOridinal As UInt32, _
ByVal windowed As Boolean, _
ByVal suggestedWidth As Integer, _
ByVal suggestedHeight As Integer, _
ByVal callback As IDeviceCreation _
)
C# public void CreateDevice(
uint adapterOridinal,
bool windowed,
int suggestedWidth,
int suggestedHeight,
IDeviceCreation callback
);
Managed C++ public: void CreateDevice(
unsigned int adapterOridinal,
bool windowed,
int suggestedWidth,
int suggestedHeight,
IDeviceCreation *callback
);
JScript .NET public function CreateDevice(
adapterOridinal : uint,
windowed : boolean,
suggestedWidth : int,
suggestedHeight : int,
callback : IDeviceCreation
);

Parameters

adapterOridinal | System.Int32. The index of the desired adapter.
windowed | System.Boolean. Set to true to start the application windowed. Set to false to start the application full-screen.
suggestedWidth | System.Int32. The requested initial width of the application's back buffer.
suggestedHeight | System.Int32. The requested initial height of the application's back buffer.
callback | Microsoft.Samples.DirectX.UtilityToolkit.IDeviceCreation. An interface that the framework will use to determine if a device is acceptable.

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling CreateDevice, you can call SetDevice or CreateDeviceFromSettings.

The actual height and width may be adjusted to fit device and operating system constraints. The default value is 640x480.


Framework.CreateDeviceFromSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CreateDeviceFromSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tells the framework to change to a device created from settings described in a DeviceSettings object.

Overload List

public void CreateDeviceFromSettings(DeviceSettings);
public void CreateDeviceFromSettings(DeviceSettings, bool);

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDevice.


Framework.CreateDeviceFromSettings(CreateDeviceFromSettings)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CreateDeviceFromSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tells the framework to change to a device created from settings described in a DeviceSettings object.

Definition

Visual Basic .NET Public Sub CreateDeviceFromSettings( _
ByVal deviceSettings As DeviceSettings _
)
C# public void CreateDeviceFromSettings(
DeviceSettings deviceSettings
);
Managed C++ public: void CreateDeviceFromSettings(
DeviceSettings *deviceSettings
);
JScript .NET public function CreateDeviceFromSettings(
deviceSettings : DeviceSettings
);

Parameters

deviceSettings Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings. The DeviceSettings object contains the settings for the new device.

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDevice.


Framework.CreateDeviceFromSettings(CreateDeviceFromSettings,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CreateDeviceFromSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tells the framework to change to a device created from settings described in a DeviceSettings object.

Definition

Visual Basic .NET Public Sub CreateDeviceFromSettings( _
ByVal deviceSettings As DeviceSettings, _
ByVal preserveInput As Boolean _
)
C# public void CreateDeviceFromSettings(
DeviceSettings deviceSettings,
bool preserveInput
);
Managed C++ public: void CreateDeviceFromSettings(
DeviceSettings *deviceSettings,
bool preserveInput
);
JScript .NET public function CreateDeviceFromSettings(
deviceSettings : DeviceSettings,
preserveInput : boolean
);

Parameters

deviceSettings | Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings. The DeviceSettings object contains the settings for the new device.
preserveInput | System.Boolean. Set to true if the device settings in the DeviceSettings object will be used without change. Set to false if a valid device will be created with device settings that are as near as possible to the original device settings in the DeviceSettings object.

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDevice.


Framework.CreateWindow

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CreateWindow Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a window for the application.

Overload List

public void CreateWindow(string);
public void CreateWindow(string, Icon, MainMenu, int, int);

Remarks

This method is called by the framework with default parameter if the application calls the CreateDevice, SetDevice, or CreateDeviceFromSettings methods before this method.

Instead of calling CreateWindow, you can call SetWindow to change the settings of the current window used by the application.


Framework.CreateWindow(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CreateWindow Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a window for the application.

Definition

Visual Basic .NET Public Sub CreateWindow( _
ByVal windowTitle As String _
)
C# public void CreateWindow(
string windowTitle
);
Managed C++ public: void CreateWindow(
String *windowTitle
);
JScript .NET public function CreateWindow(
windowTitle : String
);

Parameters

windowTitle System.String. The title to use for the form that is created.

Remarks

This method is called by the framework with default parameter if the application calls the CreateDevice, SetDevice, or CreateDeviceFromSettings methods before this method.

Instead of calling CreateWindow, you can call SetWindow to change the settings of the current window used by the application.


Framework.CreateWindow(String,Icon,MainMenu,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CreateWindow Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a window for the application.

Definition

Visual Basic .NET Public Sub CreateWindow( _
ByVal windowTitle As String, _
ByVal icon As Icon, _
ByVal menu As MainMenu, _
ByVal x As Integer, _
ByVal y As Integer _
)
C# public void CreateWindow(
string windowTitle,
Icon icon,
MainMenu menu,
int x,
int y
);
Managed C++ public: void CreateWindow(
String *windowTitle,
Icon *icon,
MainMenu *menu,
int x,
int y
);
JScript .NET public function CreateWindow(
windowTitle : String,
icon : Icon,
menu : MainMenu,
x : int,
y : int
);

Parameters

windowTitle | System.String. The title to use for the form that is created.
icon | System.Drawing.Icon. The icon to use for the form that is created.
menu | System.Windows.Forms.MainMenu. The menu to use for the form that is created.
x | System.Int32. The horizontal start position for the window that is created.
y | System.Int32. The vertical start position for the window that is created.

Remarks

This method is called by the framework with default parameter if the application calls the CreateDevice, SetDevice, or CreateDeviceFromSettings methods before this method.

Instead of calling CreateWindow, you can call SetWindow to change the settings of the current window used by the application.


Framework.DisplayErrorMessage(Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DisplayErrorMessage Method

 Language:
Note: This documentation is preliminary and is subject to change.

Displays a custom error message box.

Definition

Visual Basic .NET Public Sub DisplayErrorMessage( _
ByVal e As Exception _
)
C# public void DisplayErrorMessage(
Exception e
);
Managed C++ public: void DisplayErrorMessage(
Exception *e
);
JScript .NET public function DisplayErrorMessage(
e : Exception
);

Parameters

e System.Exception. The exception that the displayed message box will show.


Framework.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Framework object.

Definition

Visual Basic .NET | Public Sub Dispose()
C# | public void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public function Dispose();


Framework.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Framework object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Public Sub Finalize()
C# | public void Finalize();
Managed C++ | public: void Finalize();
JScript .NET | public function Finalize();


Framework.Initialize(Boolean,Boolean,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Initialize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes the sample framework.

Definition

Visual Basic .NET Public Sub Initialize( _
ByVal isParsingCommandLine As Boolean, _
ByVal handleDefaultKeys As Boolean, _
ByVal showMessageBoxOnError As Boolean _
)
C# public void Initialize(
bool isParsingCommandLine,
bool handleDefaultKeys,
bool showMessageBoxOnError
);
Managed C++ public: void Initialize(
bool isParsingCommandLine,
bool handleDefaultKeys,
bool showMessageBoxOnError
);
JScript .NET public function Initialize(
isParsingCommandLine : boolean,
handleDefaultKeys : boolean,
showMessageBoxOnError : boolean
);

Parameters

isParsingCommandLine | System.Boolean. Set to true if the sample framework checks for command-line arguments; otherwise, false.
handleDefaultKeys | System.Boolean. Set to true if the sample framework automatically responds to certain keyboard input; otherwise, false.
showMessageBoxOnError | System.Boolean. Set to true if the sample framework displays a message box if there is an error condition; otherwise, false.

Remarks

Command-line arguments take precedence over options set by the application when a Microsoft® Direct3D® device is first created, but they are ignored afterward to allow the user to interactively change the settings.

The following table contains descriptions of possible command-line arguments when executing a sample framework application.
Command-line Argument | Description
-adapter:# | Forces the application to use this adapter ordinal. Fails if the adapter ordinal does not exist.
-fullscreen | Starts in full-screen mode.
-windowed | Starts in windowed mode.
-startx:# | For windowed mode, sets the x-coordinate of the window position to the value of #.
-starty:# | For windowed mode, sets the y-coordinate of the window position to the value of #.
-height:# | Sets the window height to the value of #. For full-screen mode, the sample framework picks the closest possible supported mode.
-width:# | Sets the window width to the value of #. For full-screen mode, the sample framework picks the closest possible supported mode.
-forcehal | Forces the application to use a hardware abstraction layer (HAL) device type. Fails if a HAL device does not exist.
-forcehwvp | Forces the application to use hardware vertex processing. Fails if the device does not support this mode.
-forcepurehwvp | Forces the application to use pure hardware vertex processing. Fails if the device does not support this mode.
-forceref | Forces the application to use a reference device type. Fails if a reference device does not exist.
-forceswvp | Forces the application to use software vertex processing.
-constantframetime | Uses a constant frame time.
-noerrormsgboxes | Prevents the display of message boxes generated by the framework, allowing the application to be run without user interaction.
-quitafterframe:# | Forces the application to quit after frame #.

The following table lists the keyboard input that is handled by default when the handleDefaultKeys property is set to true.
Keyboard Input | Description
ALT+ENTER | Toggles between full-screen and windowed modes.
ESC | Exits the application.
F2 | Prompts the user to select a new rendering device or display mode.
F3 | Toggles between HAL and reference devices.
F8 | Toggles between wireframe and rendered views.
PAUSE | Pauses the application.


Framework.KillTimer(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.KillTimer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uninstalls an existing timer.

Definition

Visual Basic .NET Public Sub KillTimer( _
ByVal id As Integer _
)
C# public void KillTimer(
int id
);
Managed C++ public: void KillTimer(
int id
);
JScript .NET public function KillTimer(
id : int
);

Parameters

id System.Int32. The event identifier (ID) for the timer being destroyed.

Remarks

The identifier (ID) used by the id parameter is provided to the application by the SetTimer method.

Timers created with the SetTimer method can be destoryed by this method.


Framework.LoadFirstIconFromResource()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.LoadFirstIconFromResource Method

 Language:
Note: This documentation is preliminary and is subject to change.

Attempts to load the first icon from the application's resources.

Definition

Visual Basic .NET | Public Function LoadFirstIconFromResource() As Icon
C# | public Icon LoadFirstIconFromResource();
Managed C++ | public: Icon* LoadFirstIconFromResource();
JScript .NET | public function LoadFirstIconFromResource() : Icon;

Return Value

System.Drawing.Icon . The first icon from the application's resources.

Remarks

If no icon is found in the application's resources, this method wil return a null.


Framework.MainLoop()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.MainLoop Method

 Language:
Note: This documentation is preliminary and is subject to change.

Starts the main execution loop of the sample framework.

Definition

Visual Basic .NET | Public Sub MainLoop()
C# | public void MainLoop();
Managed C++ | public: void MainLoop();
JScript .NET | public function MainLoop();

Remarks

This method starts the message loop that will run for the lifetime of the application. During execution, MainLoop calls the registered callback functions to inform the application of input events and to trigger resource management and render calls.


Framework.Pause(Boolean,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Pause Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the paused state of the sample framework internal timer and/or rendering process.

Definition

Visual Basic .NET Public Sub Pause( _
ByVal pauseTime As Boolean, _
ByVal pauseRendering As Boolean _
)
C# public void Pause(
bool pauseTime,
bool pauseRendering
);
Managed C++ public: void Pause(
bool pauseTime,
bool pauseRendering
);
JScript .NET public function Pause(
pauseTime : boolean,
pauseRendering : boolean
);

Parameters

pauseTime | System.Boolean. Set to true to pause the sample framework internal timer. Set to false to resume the sample framework internal timer.
pauseRendering | System.Boolean. Set to true to keep the application from rendering. Set to false to resume the sample framework rendering.


Framework.Render3DEnviroment()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Render3DEnviroment Method

 Language:
Note: This documentation is preliminary and is subject to change.

Renders the 3-D environment and updates application and device parameters.

Definition

Visual Basic .NET | Public Sub Render3DEnviroment()
C# | public void Render3DEnviroment();
Managed C++ | public: void Render3DEnviroment();
JScript .NET | public function Render3DEnviroment();

Remarks

This method does not normally need to be called. It is useful only when the application does not use MainLoop but still wants the sample framework to assist with rendering.

This method checks whether the device is lost. If so, the method attempts to reset the device and then calls the neccessary FrameMove and Render methods.

If the application window is minimized or the application is paused, CPU time is yielded to other processes.


Framework.Reset3DEnviroment()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Reset3DEnviroment Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the 3-D environment.

Definition

Visual Basic .NET | Public Sub Reset3DEnviroment()
C# | public void Reset3DEnviroment();
Managed C++ | public: void Reset3DEnviroment();
JScript .NET | public function Reset3DEnviroment();

Remarks

When this method is called, the sample framework calls the DeviceLost event then resets the device. After that, this method stores the back buffer description, sets up the full screen Microsoft® Direct3D® cursor if requested, and then calls the DeviceReset event.


Framework.ResetState()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.ResetState Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the sample framework state to its initial default state, and all previous framework state changes are lost.

Definition

Visual Basic .NET | Public Sub ResetState()
C# | public void ResetState();
Managed C++ | public: void ResetState();
JScript .NET | public function ResetState();

Remarks

This method is useful for testing purposes because the application process does not have to be restarted.


Framework.SetCallbackInterface(SetCallbackInterface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetCallbackInterface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the interface that the sample framework will use to call into samples.

Definition

Visual Basic .NET Public Sub SetCallbackInterface( _
ByVal callback As IFrameworkCallback _
)
C# public void SetCallbackInterface(
IFrameworkCallback callback
);
Managed C++ public: void SetCallbackInterface(
IFrameworkCallback *callback
);
JScript .NET public function SetCallbackInterface(
callback : IFrameworkCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.IFrameworkCallback. The interface that the sample framework will use to call into samples.


Framework.SetConstantFrameTime

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetConstantFrameTime Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enables or disables a constant frame time.

Overload List

public void SetConstantFrameTime(bool);
public void SetConstantFrameTime(bool, float);

Remarks

The default rate is one second for every 30 frames, or 0.0333 seconds per frame.

This function is useful for saving the rendered output to a video format for playback, allowing animation at a rate independent of the actual rate at which frames were rendered.


Framework.SetConstantFrameTime(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetConstantFrameTime Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enables or disables a constant frame time.

Definition

Visual Basic .NET Public Sub SetConstantFrameTime( _
ByVal constantFrameTime As Boolean _
)
C# public void SetConstantFrameTime(
bool constantFrameTime
);
Managed C++ public: void SetConstantFrameTime(
bool constantFrameTime
);
JScript .NET public function SetConstantFrameTime(
constantFrameTime : boolean
);

Parameters

constantFrameTime System.Boolean. Set to true to enable a constant frame time; otherwise, false.

Remarks

The default rate is one second for every 30 frames, or 0.0333 seconds per frame.

This function is useful for saving the rendered output to a video format for playback, allowing animation at a rate independent of the actual rate at which frames were rendered.


Framework.SetConstantFrameTime(Boolean,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetConstantFrameTime Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enables or disables a constant frame time.

Definition

Visual Basic .NET Public Sub SetConstantFrameTime( _
ByVal constantFrameTime As Boolean, _
ByVal timePerFrame As Single _
)
C# public void SetConstantFrameTime(
bool constantFrameTime,
float timePerFrame
);
Managed C++ public: void SetConstantFrameTime(
bool constantFrameTime,
float timePerFrame
);
JScript .NET public function SetConstantFrameTime(
constantFrameTime : boolean,
timePerFrame : float
);

Parameters

constantFrameTime | System.Boolean. Set to true to enable a constant frame time; otherwise, false.
timePerFrame | System.Single. Time per frame, in seconds.

Remarks

The default rate is one second for every 30 frames, or 0.0333 seconds per frame.

This function is useful for saving the rendered output to a video format for playback, allowing animation at a rate independent of the actual rate at which frames were rendered.


Framework.SetCursorSettings(Boolean,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetCursorSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets options for cursor usage in full-screen mode.

Definition

Visual Basic .NET Public Sub SetCursorSettings( _
ByVal showCursorWhenFullscreen As Boolean, _
ByVal clipCursorWhenFullscreen As Boolean _
)
C# public void SetCursorSettings(
bool showCursorWhenFullscreen,
bool clipCursorWhenFullscreen
);
Managed C++ public: void SetCursorSettings(
bool showCursorWhenFullscreen,
bool clipCursorWhenFullscreen
);
JScript .NET public function SetCursorSettings(
showCursorWhenFullscreen : boolean,
clipCursorWhenFullscreen : boolean
);

Parameters

showCursorWhenFullscreen | System.Boolean. Set to true if the cursor will be visible when the application is running in full-screen mode; otherwise, false.
clipCursorWhenFullscreen | System.Boolean. Set to true if the cursor will be restricted from exiting the screen boundaries when the application is running in full-screen mode; otherwise, false.


Framework.SetDevice(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an existing Microsoft® Direct3D® Device for use by the sample framework.

Definition

Visual Basic .NET Public Sub SetDevice( _
ByVal device As Device _
)
C# public void SetDevice(
Device device
);
Managed C++ public: void SetDevice(
Device *device
);
JScript .NET public function SetDevice(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device. The Microsoft® Direct3D® Device the sample framework is to use.

Remarks

If the CreateWindow method has not already been called, it will call it with the default parameters. Instead of calling SetDevice, you can call CreateDevice method or CreateDeviceFromSettings method.

The application can call this method after a device has already been created to change the current device.


Framework.SetDeviceCreationInterface(SetDeviceCreationInterface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetDeviceCreationInterface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the interface that the framework will use to determine if a device is acceptable.

Definition

Visual Basic .NET Public Sub SetDeviceCreationInterface( _
ByVal callback As IDeviceCreation _
)
C# public void SetDeviceCreationInterface(
IDeviceCreation callback
);
Managed C++ public: void SetDeviceCreationInterface(
IDeviceCreation *callback
);
JScript .NET public function SetDeviceCreationInterface(
callback : IDeviceCreation
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.IDeviceCreation. The interface that the framework will use to determine if a device is acceptable.


Framework.SetKeyboardCallback(SetKeyboardCallback)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetKeyboardCallback Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the keyboard event callback function.

Definition

Visual Basic .NET Public Sub SetKeyboardCallback( _
ByVal callback As KeyboardCallback _
)
C# public void SetKeyboardCallback(
KeyboardCallback callback
);
Managed C++ public: void SetKeyboardCallback(
KeyboardCallback *callback
);
JScript .NET public function SetKeyboardCallback(
callback : KeyboardCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.KeyboardCallback. The KeyboardCallback delegate the sample framework will use.

Remarks

If the callback parameter is set to null, the sample framework will not notify the application about keyboard events.


Framework.SetMouseCallback(SetMouseCallback)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetMouseCallback Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the mouse event callback function.

Definition

Visual Basic .NET Public Sub SetMouseCallback( _
ByVal callback As MouseCallback _
)
C# public void SetMouseCallback(
MouseCallback callback
);
Managed C++ public: void SetMouseCallback(
MouseCallback *callback
);
JScript .NET public function SetMouseCallback(
callback : MouseCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.MouseCallback. The MouseCallback delegate the sample framework will use.

Remarks

If the callback parameter is set to null, the sample framework will not notify the application about mouse events.


Framework.SetTimer(SetTimer,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetTimer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a timer to the list of timers for the application.

Definition

Visual Basic .NET Public Function SetTimer( _
ByVal callbackTimer As TimerCallback, _
ByVal timeoutInSeconds As Single _
) As Integer
C# public int SetTimer(
TimerCallback callbackTimer,
float timeoutInSeconds
);
Managed C++ public: int SetTimer(
TimerCallback *callbackTimer,
float timeoutInSeconds
);
JScript .NET public function SetTimer(
callbackTimer : TimerCallback,
timeoutInSeconds : float
) : int;

Parameters

callbackTimer | Microsoft.Samples.DirectX.UtilityToolkit.TimerCallback. The TimerCallback delegate that handles the timer events.
timeoutInSeconds | System.Single. Interval, in seconds, between successive calls to the TimerCallback delegate.

Return Value

System.Int32 . The unique identifier (ID) of the timer.

Remarks

Timers that are created with this method can be destroyed by the KillTimer method.


Framework.SetWindow(IntPtr,IntPtr,IntPtr,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetWindow Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a previously created window for the framework to use.

Definition

Visual Basic .NET Public Sub SetWindow( _
ByVal windowFocus As IntPtr, _
ByVal windowDeviceFullscreen As IntPtr, _
ByVal windowDeviceWindowed As IntPtr, _
ByVal handleMessages As Boolean _
)
C# public void SetWindow(
IntPtr windowFocus,
IntPtr windowDeviceFullscreen,
IntPtr windowDeviceWindowed,
bool handleMessages
);
Managed C++ public: void SetWindow(
IntPtr windowFocus,
IntPtr windowDeviceFullscreen,
IntPtr windowDeviceWindowed,
bool handleMessages
);
JScript .NET public function SetWindow(
windowFocus : IntPtr,
windowDeviceFullscreen : IntPtr,
windowDeviceWindowed : IntPtr,
handleMessages : boolean
);

Parameters

windowFocus | System.IntPtr. Handle of the Microsoft® Direct3D® focus window.
windowDeviceFullscreen | System.IntPtr. Handle of the Microsoft® Direct3D® window used in full-screen mode.
windowDeviceWindowed | System.IntPtr. Handle of the Microsoft® Direct3D® window used in windowed mode.
handleMessages | System.Boolean. Set to true if the framework will handle and respond to messages for the window. Set to false the framework will not handle messages for the window, giving the application full responsibility for responding to messages.

Remarks

If the SetWindow method has not already been called, it will call it with default parameters. Instead of calling SetWindow you can call the CreateWindow method to create a new window.

No input parameter may be null. However, the same handle may be used for more than one parameter.


Framework.SetWndProcCallback(SetWndProcCallback)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.SetWndProcCallback Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the WndProcCallback delegate to use in the sample framework.

Definition

Visual Basic .NET Public Sub SetWndProcCallback( _
ByVal callback As WndProcCallback _
)
C# public void SetWndProcCallback(
WndProcCallback callback
);
Managed C++ public: void SetWndProcCallback(
WndProcCallback *callback
);
JScript .NET public function SetWndProcCallback(
callback : WndProcCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.WndProcCallback. The WndProcCallback delegate to use in the sample framework.


Framework.ShowSettingsDialog(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.ShowSettingsDialog Method

 Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the sample framework's device settings dialog box is currently showing.

Definition

Visual Basic .NET Public Sub ShowSettingsDialog( _
ByVal show As Boolean _
)
C# public void ShowSettingsDialog(
bool show
);
Managed C++ public: void ShowSettingsDialog(
bool show
);
JScript .NET public function ShowSettingsDialog(
show : boolean
);

Parameters

show System.Boolean. Set to true if the sample framework's device settings dialog box is currently showing; otherwise, false.


Framework.ToggleFullscreen()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.ToggleFullscreen Method

 Language:
Note: This documentation is preliminary and is subject to change.

Switches the application between windowed and full-screen modes.

Definition

Visual Basic .NET | Public Sub ToggleFullscreen()
C# | public void ToggleFullscreen();
Managed C++ | public: void ToggleFullscreen();
JScript .NET | public function ToggleFullscreen();

Remarks

Toggling between windowed and full-screen modes will result in the Microsoft® Direct3D® device being reset or recreated.


Framework.ToggleReference()

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.ToggleReference Method

 Language:
Note: This documentation is preliminary and is subject to change.

Switches the application between hardware abstraction layer (HAL) and reference devices.

Definition

Visual Basic .NET | Public Sub ToggleReference()
C# | public void ToggleReference();
Managed C++ | public: void ToggleReference();
JScript .NET | public function ToggleReference();

Remarks

Toggling between hardware abstraction layer (HAL) and reference devices will result in the Microsoft® Direct3D® device being recreated.


Framework.BackBufferSurfaceDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.BackBufferSurfaceDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a SurfaceDescription structure that describes the back buffer on the current adapter.

Definition

Visual Basic .NET | Public ReadOnly Property BackBufferSurfaceDescription As SurfaceDescription
C# | public SurfaceDescription BackBufferSurfaceDescription { get; }
Managed C++ | public: __property SurfaceDescription get_BackBufferSurfaceDescription();
JScript .NET | public function get BackBufferSurfaceDescription() : SurfaceDescription

Property Value

Microsoft.DirectX.Direct3D.SurfaceDescription . A SurfaceDescription structure that describes the back buffer on the current adapter.

This property is read-only.


Framework.CanAutomaticallyChangeMonitor

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.CanAutomaticallyChangeMonitor Property

Language:
Note: This documentation is preliminary and is subject to change.

Sets or retrieves if the current adapter can automatically change monitors.

Definition

Visual Basic .NET | Public Property CanAutomaticallyChangeMonitor As Boolean
C# | public bool CanAutomaticallyChangeMonitor { get; set; }
Managed C++ public: __property bool get_CanAutomaticallyChangeMonitor();
public: __property void set_CanAutomaticallyChangeMonitor(bool);
JScript .NET public function get CanAutomaticallyChangeMonitor() : boolean
public function set CanAutomaticallyChangeMonitor(boolean);

Property Value

System.Boolean . A value that is set to true if the current adapter can automatically change monitors; otherwise, false.

This property is read/write.


Framework.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device object currently used by the framework.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object currently used by the framework.

This property is read-only.

Remarks

This property will return a null if no device has been created by the framework.


Framework.DeviceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DeviceCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a Caps structure that describes the capabilities of the current device.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceCaps As Caps
C# | public Caps DeviceCaps { get; }
Managed C++ | public: __property Caps get_DeviceCaps();
JScript .NET | public function get DeviceCaps() : Caps

Property Value

Microsoft.DirectX.Direct3D.Caps . A Caps structure that describes the capabilities of the current device.

This property is read-only.


Framework.DeviceSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DeviceSettings Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the DeviceSettings object that contains the device settings for the current Device object used by the framework.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceSettings As DeviceSettings
C# | public DeviceSettings DeviceSettings { get; }
Managed C++ | public: __property DeviceSettings* get_DeviceSettings();
JScript .NET | public function get DeviceSettings() : DeviceSettings

Property Value

Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings . The DeviceSettings object that contains the device settings for the current Device object used by the framework.

This property is read-only.

Remarks

If there is no current Device object used by the framework, the DeviceSettings object will contain blank settings.


Framework.DeviceStats

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DeviceStats Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a string containing the current device type, vertex processing behavior, and device name.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceStats As String
C# | public string DeviceStats { get; }
Managed C++ | public: __property String* get_DeviceStats();
JScript .NET | public function get DeviceStats() : String

Property Value

System.String . A string containing the current device type, vertex processing behavior, and device name.

This property is read-only.


Framework.ExitCode

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.ExitCode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the sample framework exit code.

Definition

Visual Basic .NET | Public ReadOnly Property ExitCode As Integer
C# | public int ExitCode { get; }
Managed C++ | public: __property int get_ExitCode();
JScript .NET | public function get ExitCode() : int

Property Value

System.Int32 . The sample framework exit code.

This property is read-only.

Remarks

This table contains descriptions of possible ExitCode property values. There is no exit code value of 1.
Value | Description
0 | Successful execution.
2 | No compatible Microsoft® Direct3D® device could be found.
3 | No Device object could be found with the specified device settings.
4 | The Microsoft DirectX® software development kit (SDK) media file could not be found.
5 | The Device object has a nonzero reference count, meaning that some objects were not released.
6 | An error occurred when attempting to create the Device object.
7 | An error occurred when attempting to reset the Device object.
8 | An error occurred in the device creation callback function.
9 | An error occurred in the device creation callback function.
10 | The incorrect version of DirectX or D3DX is installed.


Framework.FPS

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.FPS Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of frames per second the application is currently running.

Definition

Visual Basic .NET | Public ReadOnly Property FPS As Single
C# | public float FPS { get; }
Managed C++ | public: __property float get_FPS();
JScript .NET | public function get FPS() : float

Property Value

System.Single . The number of frames per second the application is currently running.

This property is read-only.


Framework.FrameStats

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.FrameStats Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a string containing the current number of frames per second, resolution, back buffer format, and depth stencil format.

Definition

Visual Basic .NET | Public ReadOnly Property FrameStats As String
C# | public string FrameStats { get; }
Managed C++ | public: __property String* get_FrameStats();
JScript .NET | public function get FrameStats() : String

Property Value

System.String . A string containing the current number of frames per second, resolution, back buffer format, and depth stencil format.

This property is read-only.


Framework.IsD3DSettingsDialogShowing

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.IsD3DSettingsDialogShowing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the settings dialog is displayed.

Definition

Visual Basic .NET | Public ReadOnly Property IsD3DSettingsDialogShowing As Boolean
C# | public bool IsD3DSettingsDialogShowing { get; }
Managed C++ | public: __property bool get_IsD3DSettingsDialogShowing();
JScript .NET | public function get IsD3DSettingsDialogShowing() : boolean

Property Value

System.Boolean . Set to true if the settings dialog is displayed; otherwise, false.

This property is read-only.


Framework.IsNotifiedOnMouseMove

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.IsNotifiedOnMouseMove Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the framework should notify for mouse moves.

Definition

Visual Basic .NET | Public Property IsNotifiedOnMouseMove As Boolean
C# | public bool IsNotifiedOnMouseMove { get; set; }
Managed C++ public: __property bool get_IsNotifiedOnMouseMove();
public: __property void set_IsNotifiedOnMouseMove(bool);
JScript .NET public function get IsNotifiedOnMouseMove() : boolean
public function set IsNotifiedOnMouseMove(boolean);

Property Value

System.Boolean . Set to true if the framework should notify for mouse moves; otherwise, false.

This property is read/write.


Framework.IsOverridingFullScreen

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.IsOverridingFullScreen Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the framework should override and start fullscreen.

Definition

Visual Basic .NET | Public Property IsOverridingFullScreen As Boolean
C# | public bool IsOverridingFullScreen { get; set; }
Managed C++ public: __property bool get_IsOverridingFullScreen();
public: __property void set_IsOverridingFullScreen(bool);
JScript .NET public function get IsOverridingFullScreen() : boolean
public function set IsOverridingFullScreen(boolean);

Property Value

System.Boolean . Set to true if the framework should override and start full-screen; otherwise, false.

This property is read/write.


Framework.IsWindowed

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.IsWindowed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the current device is windowed.

Definition

Visual Basic .NET | Public ReadOnly Property IsWindowed As Boolean
C# | public bool IsWindowed { get; }
Managed C++ | public: __property bool get_IsWindowed();
JScript .NET | public function get IsWindowed() : boolean

Property Value

System.Boolean . Set to true if the current device is windowed; otherwise, false.

This property is read-only.

Remarks

If no device exists yet, return false.


Framework.PresentParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.PresentParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the PresentParameters object for the current Device object.

Definition

Visual Basic .NET | Public ReadOnly Property PresentParameters As PresentParameters
C# | public PresentParameters PresentParameters { get; }
Managed C++ | public: __property PresentParameters* get_PresentParameters();
JScript .NET | public function get PresentParameters() : PresentParameters

Property Value

Microsoft.DirectX.Direct3D.PresentParameters . The PresentParameters object for the current Device.

This property is read-only.

Remarks

If no Device object exists yet, then PresentParameters returns a PresentParameters object with blank parameters.


Framework.Window

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Window Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the handle of the window used for rendering.

Definition

Visual Basic .NET | Public ReadOnly Property Window As IntPtr
C# | public IntPtr Window { get; }
Managed C++ | public: __property IntPtr get_Window();
JScript .NET | public function get Window() : IntPtr

Property Value

System.IntPtr . The handle of the window used for rendering.

This property is read-only.


Framework.WindowClientRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.WindowClientRectangle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size and location of the window that is rendering.

Definition

Visual Basic .NET | Public ReadOnly Property WindowClientRectangle As Rectangle
C# | public Rectangle WindowClientRectangle { get; }
Managed C++ | public: __property Rectangle get_WindowClientRectangle();
JScript .NET | public function get WindowClientRectangle() : Rectangle

Property Value

System.Drawing.Rectangle . Retrieves the size and location of the window that is rendering.

This property is read-only.


Framework.WindowDeviceFullscreen

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.WindowDeviceFullscreen Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the handle of the window used for fullscreen rendering.

Definition

Visual Basic .NET | Public ReadOnly Property WindowDeviceFullscreen As IntPtr
C# | public IntPtr WindowDeviceFullscreen { get; }
Managed C++ | public: __property IntPtr get_WindowDeviceFullscreen();
JScript .NET | public function get WindowDeviceFullscreen() : IntPtr

Property Value

System.IntPtr . The handle of the window used for fullscreen rendering.

This property is read-only.


Framework.WindowDeviceWindowed

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.WindowDeviceWindowed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the handle of the window used for windowed rendering.

Definition

Visual Basic .NET | Public ReadOnly Property WindowDeviceWindowed As IntPtr
C# | public IntPtr WindowDeviceWindowed { get; }
Managed C++ | public: __property IntPtr get_WindowDeviceWindowed();
JScript .NET | public function get WindowDeviceWindowed() : IntPtr

Property Value

System.IntPtr . The handle of the window used for windowed rendering.

This property is read-only.


Framework.WindowFocus

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.WindowFocus Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the handle of the window that currently has focus.

Definition

Visual Basic .NET | Public ReadOnly Property WindowFocus As IntPtr
C# | public IntPtr WindowFocus { get; }
Managed C++ | public: __property IntPtr get_WindowFocus();
JScript .NET | public function get WindowFocus() : IntPtr

Property Value

System.IntPtr . The handle of the window that currently has focus.

This property is read-only.


Framework.DefaultSizeHeight

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DefaultSizeHeight Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default window height, in pixels, when the application starts.

Definition

Visual Basic .NET | Public DefaultSizeHeight As Int32
C# | public Int32 DefaultSizeHeight;
Managed C++ | public: Int32 DefaultSizeHeight;
JScript .NET | public var DefaultSizeHeight : Int32

Field Value

System.Int32 . The default window height, in pixels, when the application starts.

This field is read-only.


Framework.DefaultSizeWidth

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DefaultSizeWidth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default window width, in pixels, when the application starts.

Definition

Visual Basic .NET | Public DefaultSizeWidth As Int32
C# | public Int32 DefaultSizeWidth;
Managed C++ | public: Int32 DefaultSizeWidth;
JScript .NET | public var DefaultSizeWidth : Int32

Field Value

System.Int32 . The default window width, in pixels, when the application starts.

This field is read-only.


Framework.TrueIntPtr

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.TrueIntPtr Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Boolean value of true as a System.IntPtr Leave Site.

Definition

Visual Basic .NET | Public TrueIntPtr As IntPtr
C# | public IntPtr TrueIntPtr;
Managed C++ | public: IntPtr TrueIntPtr;
JScript .NET | public var TrueIntPtr : IntPtr

Field Value

System.IntPtr . The Boolean value of true as a System.IntPtr Leave Site.

This field is read-only.

Remarks

This value is used as a return value for certain message handling events, which return the type System.IntPtr Leave Site.


Framework.DeviceCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DeviceCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Microsoft® Direct3D® Device object is created.

Definition

Visual Basic .NET | Event DeviceCreated As Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler
C# | event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler DeviceCreated;
Managed C++ | : __event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler DeviceCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

When this event is triggered, it will return a Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventArgs object that contains the Microsoft® Direct3D® Device object created and a description of the back buffer as a SurfaceDescription object.


Framework.DeviceLost

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DeviceLost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Microsoft® Direct3D® Device object is lost.

Definition

Visual Basic .NET | Event DeviceLost As EventHandler
C# | event EventHandler DeviceLost;
Managed C++ | : __event EventHandler DeviceLost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Framework.DeviceReset

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.DeviceReset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Microsoft® Direct3D® Device object is reset.

Definition

Visual Basic .NET | Event DeviceReset As Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler
C# | event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler DeviceReset;
Managed C++ | : __event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler DeviceReset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

When this event is triggered, it will return a Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventArgs object that contains the Microsoft® Direct3D® Device object that was reset and a description of the back buffer as a SurfaceDescription object.


Framework.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Framework.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Framework object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Event Disposing As EventHandler
C# | event EventHandler Disposing;
Managed C++ | : __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


DirectDraw

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectDraw® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The DirectDraw application programming interface (API) is the component of DirectX that enables you to directly manipulate display memory, the hardware blitter, hardware overlay support, and flipping surface support. For more information, see the Microsoft.DirectX.DirectDraw managed code reference documentation.


DirectInput

Note: This documentation is preliminary and is subject to change.

This section provides information about the Microsoft® DirectInput® component of the Microsoft DirectX® application programming interface (API). The DirectInput API is used to process data from a keyboard, mouse, joystick, or other game controller. For more information, see the Microsoft.DirectX.DirectInput managed code reference documentation.


Enumerating Microsoft® DirectInput® Devices

Note: This documentation is preliminary and is subject to change.

In order to capture device input using DirectInput, you have to know from which device you want to capture, and if it is currently attached to the user's computer. You can do this by enumerating DeviceInstance objects using several different static methods of the Manager class.

  • Enumerating All Available DirectInput Devices
  • Enumerating a Particular Type of Device
  • Enumerating a Certain Class of Device
  • Enumerating All Force Feedback Devices

Enumerating All Available DirectInput Devices

You should enumerate when you are looking for a particular kind of device, want to offer the user a choice of devices, or need to work with two or more devices.

Enumeration serves three purposes:

  • Reports what DirectInput devices are available.
  • Supplies a globally unique identifier (GUID) for each DirectInput device.
  • Enables you to create a DeviceInstance object for each DirectInput device as it is enumerated so that you can check the type of device it is and its capabilities.
You can enumerate all the available DirectInput devices on the user's computer by using the Devices property of the Manager class. The following C# sample code is used to populate a TreeView control with all available DirectInput devices.
[C#]
private void PopulateAllDevices(TreeView tvDevices)
{
    //Add "All Devices" node to TreeView
    TreeNode allNode = new TreeNode("All Devices");
    tvDevices.Nodes.Add(allNode);

    //Populate All devices
    foreach(DeviceInstance di in Manager.Devices)
    {

        //Get Device name
        TreeNode nameNode = new TreeNode(di.InstanceName);

        //Is device attached?
        TreeNode attachedNode = new TreeNode(
            "Attached = " +
            Manager.GetDeviceAttached(di.ProductGuid));

        //Get device Guid
        TreeNode guidNode = new TreeNode(
            "Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(attachedNode);
        nameNode.Nodes.Add(guidNode);
        allNode.Nodes.Add(nameNode);
    }

}

Enumerating a Particular Type of Device

To enumerate a particular type of device, such as keyboards, you can use the GetDevices method of the Manager class. GetDevices is a static method allows you to retrieve a collection of DeviceInstance objects of a certain type, like keyboards. It has a parameter that gives you the ability to pass it a flag or a combination of flags in order to filter the collection. In this way, you can retrieve a list containing only attached keyboards.

The following C# sample code is used to populate a TreeView control with all attached keyboards.
[C#]
private void PopulateKeyboards(TreeView tvDevices)
{
    //Add "Keyboard Devices" node to TreeView
    TreeNode keyboardNode = new TreeNode("Keyboard Devices");
    tvInputDevices.Nodes.Add(keyboardNode);

    //Populate Attached Keyboards
    foreach(DeviceInstance di in
        Manager.GetDevices(DeviceType.Keyboard,EnumDevicesFlags.AttachedOnly))
    {

        //Get device name
        TreeNode nameNode = new TreeNode(di.InstanceName);
        TreeNode guidNode = new TreeNode(
            "Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(guidNode);
        keyboardNode.Nodes.Add(nameNode);
    }

}

Enumerating a Certain Class of Device

When enumerating pointing devices on the user's computer, you likely will not want to limit yourself to just a mouse pointer. Some laptops use track-pads or other types of pointing devices.

The C# sample below illustrates how to use the DeviceClass enumeration with the GetDevices method to populate a TreeView control with all attached devices that fall into the screen pointer class, such as mice or track-pads.
[C#]
private void PopulatePointers(TreeView tvDevices)
{
    //Add "Pointer Devices" node to TreeView
    TreeNode pointerNode = new TreeNode("Pointer Devices");
    tvInputDevices.Nodes.Add(pointerNode);

    //Populate Attached Mouse/Pointing Devices
    foreach(DeviceInstance di in
        Manager.GetDevices(DeviceClass.Pointer,EnumDevicesFlags.AttachedOnly))
    {

        //Get device name
        TreeNode nameNode = new TreeNode(di.InstanceName);
        nameNode.Tag = di;
        TreeNode guidNode = new TreeNode(
            "Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(guidNode);
        pointerNode.Nodes.Add(nameNode);
    }

}
Note: This code can also be used to enumerate all types of joysticks by using the DeviceClass.GameControl value in the GetDevices method.

Enumerating All Force Feedback Devices

Sometimes you may want to just enumerate devices that have force feedback capabilities. Because many different types of devices use force feedback, you may need to look for any type of device that supports it.

The following C# sample code illustrates how to enumerate all devices that support force feedback, and populate a TreeView control with those devices.
[C#]
private void PopulateForceFeedback(TreeView tvDevices)
{
    //Add "ForceFeedback Devices" node to TreeView
    TreeNode forcefeedbackNode = new TreeNode("ForceFeedback Devices");
    tvInputDevices.Nodes.Add(forcefeedbackNode);

    //Populate ForceFeedback Devices
    foreach(DeviceInstance di in
        Manager.GetDevices( DeviceClass.All,EnumDevicesFlags.ForceFeedback))
    {
        //Get device name
        TreeNode nameNode = new TreeNode(di.InstanceName);
        nameNode.Tag = di;
        TreeNode guidNode = new TreeNode("Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(guidNode);
        forcefeedbackNode.Nodes.Add(nameNode);
    }
}


Capturing from Microsoft® DirectInput® Devices

Note: This documentation is preliminary and is subject to change.

Capturing device input using DirectInput can be done in three simple steps. First you create a Device object that represents the input device you wish to capture. After you create the device object, you do any necessary configuration, such as calling the SetCooperativeLevel method. Once you have configured the device you can start checking the state of the device in your application.

  • Creating DirectInput Device Objects
  • Configuring DirectInput Device Objects
  • Capturing from DirectInput Device Objects

Creating DirectInput Device Objects

As discussed in Enumerating DirectInput Devices, there are many ways to find out what input devices are currently attached to the user's computer. More often than not, you will have to capture input from more than one device.

The following C# example code illustrates how to create three different Device objects: one for the default keyboard on the user's computer, one for the default mouse, and one for a joystick.
[C#]
private void InitDevices()
{
    //create keyboard device.
    keyboard = new Device(SystemGuid.Keyboard);
    if(keyboard == null) throw new Exception("No keyboard found.");

    //create mouse device.
    mouse = new Device(SystemGuid.Mouse);
    if(mouse == null)
    {
        throw new Exception("No mouse found.");
    }

    //create joystick device.
    foreach(
        DeviceInstance di in
        Manager.GetDevices(
            DeviceClass.GameControl,
            EnumDevicesFlags.AttachedOnly))
    {
        joystick = new Device(di.InstanceGuid);
        break;
    }

    if(joystick == null)
    {
        //Throw exception if joystick not found.
        throw new Exception("No joystick found.");
    }
}

Configuring DirectInput Device Objects

Because the input devices you capture from are a shared system resource, you have to configure them to cooperate with other system resources. You do this by calling the SetCooperativeLevel method of the Device objects you created with a combination of flags from the CooperativeLevelFlags enumeration.

The following table describes CooperativeLevelFlags that can be used when setting the cooperative level.
Flag | Description
CooperativeLevelFlags.Background | This device can be used in the background and can be acquired at any time, even if the application window is not active.
CooperativeLevelFlags.Foreground | This device can only be used when the application window is in the foreground. When the application window loses focus, the device will no linger be acquired.
CooperativeLevelFlags.Exclusive | This device requires exclusive access. No other application can acquire this device. For security reasons, this flag cannot be used in conjunction with the background flag on certain devices such as a keyboard and mouse.
CooperativeLevelFlags.NonExclusive | This device can be shared with any other application that does not require exclusive access.
CooperativeLevelFlags.NoWindowsKey | This flag disables the window's key.

Another configuration task is setting the range of a joystick axis. This allows you to set a numeric range to the complete distance traveled on a joystick axis. Even if the joystick you are using does not support the resolution of the range you assign, DirectInput will translate the joystick's resolution into the range you assign.

The following C# example code demonstrates how to configure the devices created in the previous sample.
[C#]
//Set mouse axis mode absolute.
mouse.Properties.AxisModeAbsolute = true;

//Set joystick axis ranges.
foreach(DeviceObjectInstance doi in joystick.Objects)
{
    if((doi.ObjectId & (int)DeviceObjectTypeFlags.Axis) != 0)
    {
        joystick.Properties.SetRange(
            ParameterHow.ById,
            doi.ObjectId,
            new InputRange(-5000,5000));
    }
}

//Set joystick axis mode absolute.
joystick.Properties.AxisModeAbsolute = true;

//set cooperative level.
keyboard.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.NonExclusive |
    CooperativeLevelFlags.Background);

mouse.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.NonExclusive |
    CooperativeLevelFlags.Background);

joystick.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.NonExclusive |
    CooperativeLevelFlags.Background);

//Acquire devices for capturing.
keyboard.Acquire();
mouse.Acquire();
joystick.Acquire();

Capturing from DirectInput Device Objects

Normally you would want to capture the device object's state at a certain point of your application.

The C# example code below contains methods for capturing device input from the devices created in the previous examples, and updating a label control. They can be called by an application whenever you need to capture DirectInput device input.
[C#]
private void UpdateKeyboard()
{
    string info = "Keyboard: ";

    //Capture pressed keys.
    foreach(Key k in keyboard.GetPressedKeys())
    {
        info += k.ToString() + " ";
    }
    lbKeyboard.Text = info;
}

private void UpdateMouse()
{
    string info = "Mouse: ";

    //Get Mouse State.
    MouseState state = mouse.CurrentMouseState;

    //Capture Position.
    info += "X:" + state.X + " ";
    info += "Y:" + state.Y + " ";
    info += "Z:" + state.Z + " ";

    //Capture Buttons.
    byte[] buttons = state.GetMouseButtons();
    for(int i = 0; i < buttons.Length; i++)
    {
        if(buttons[i] != 0)
        {
            info += "Button:" + i + " ";
        }
    }

    lbMouse.Text = info;
}

private void UpdateJoystick()
{
    string info = "Joystick: ";

    //Get Mouse State.
    JoystickState state = joystick.CurrentJoystickState;

    //Capture Position.
    info += "X:" + state.X + " ";
    info += "Y:" + state.Y + " ";
    info += "Z:" + state.Z + " ";

    //Capture Buttons.
    byte[] buttons = state.GetButtons();
    for(int i = 0; i < buttons.Length; i++)
    {
        if(buttons[i] != 0)
        {
            info += "Button:" + i + " ";
        }
    }

    lbJoystick.Text = info;
}


Using Force Feedback

Note: This documentation is preliminary and is subject to change.

Force Feedback allows you to send messages and properties to a user's Microsoft® DirectInput® device to relay feedback in the form of physical force. This is only applicable to DirectInput devices that support force feedback.

  • Types of Force Feedback
  • Creating and Configuring a Device for Force Feedback
  • Loading a Force Feedback Effect File
  • Assigning a Predefined Effect to a Device

Types of Force Feedback

There are two methods to relay physical force to an input device. One method is to download a force feedback effect file into the device. A force feedback effect file contains a collection of effects that can be played at any time once they are downloaded into the device.

The other method is to assign a particular effect that is supported by the device. These effects have parameters that can be configured and assigned to axes on the device. The following is a list of effects that are included in Microsoft DirectX® 9.0 for Managed Code.

  • ForceFeedbackGuid.ConstantForce
  • ForceFeedbackGuid.CustomForce
  • ForceFeedbackGuid.Damper
  • ForceFeedbackGuid.Friction
  • ForceFeedbackGuid.Inertia
  • ForceFeedbackGuid.RampForce
  • ForceFeedbackGuid.SawtoothDown
  • ForceFeedbackGuid.SawtoothUp
  • ForceFeedbackGuid.Sine
  • ForceFeedbackGuid.Spring
  • ForceFeedbackGuid.Square
  • ForceFeedbackGuid.Triangle

Creating and Configuring a Device for Force Feedback

In order to use force feedback, you must first create a Device object for the force feedback compatible device. The following C# sample code creates a Device object from the first available force feedback-capable game control.
[C#]
//create force feedback capable joystick device.
foreach(DeviceInstance di in Manager.GetDevices(
    DeviceClass.GameControl,
    EnumDevicesFlags.AttachedOnly | EnumDevicesFlags.ForceFeedback))
{
    joystick = new Device(di.InstanceGuid);
    break;
}
if (joystick == null)
{
    //Throw exception if joystick not found.
    throw new Exception("No joystick that supports forced feedback found.");
}

Once the Device object is created, it needs to be configured properly to work with force feedback. In order for force feedback to work properly, you must set the cooperative level to exclusive. You also need to create an array of axes to use with the force feedback.

The following C# sample code illustrates how to configure the Device object created in the previous code.
[C#]
//set cooperative level.
joystick.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.Exclusive | CooperativeLevelFlags.Background);

//Set axis mode absolute.
joystick.Properties.AxisModeAbsolute = true;

//Acquire joystick for capturing.
joystick.Acquire();

//Configure axes
int[] axis = null;
foreach(DeviceObjectInstance doi in joystick.Objects)
{

    //Set axes ranges.
    if((doi.ObjectId & (int)DeviceObjectTypeFlags.Axis) != 0)
    {
        joystick.Properties.SetRange(
        ParameterHow.ById,
        doi.ObjectId,
        new InputRange(-5000,5000));
    }

    int[] temp;

    // Get info about first two FF axii on the device
    if ((doi.Flags & (int)ObjectInstanceFlags.Actuator) != 0)
    {
        if (axis != null)
        {
            temp = new int[axis.Length + 1];
            axis.CopyTo(temp,0);
            axis = temp;
        }
        else
        {
            axis = new int[1];
        }

        // Store the offset of each axis.
        axis[axis.Length - 1] = doi.Offset;
        if (axis.Length == 2)
        {
            break;
        }
    }
}

Loading a Force Feedback Effect File

The following C# sample code shows you how to download a force feedback effect file into the Device object created and configured in previous samples.
[C#]
//Load force feedback effect file
string path =
    @"C:\Program Files\Microsoft DirectX 9.0 SDK (October 2004)\Samples\Managed\DirectInput\ReadFFE\guna.ffe";

EffectList el = null;
el = joystick.GetEffects(path,FileEffectsFlags.ModifyIfNeeded);
foreach(FileEffect fe in el)
{
    EffectObject feo = new EffectObject(
        fe.EffectGuid,
        fe.EffectStruct,
        joystick);
    try
    {
        feo.Download();
    }
    catch(Exception ex)
    {
        throw new Exception("Could not download force feedback effect file.", ex);
    }
    fxList.Add(feo);

}
 Once the above force feedback effect file is downloaded into the Device object, it can be played by using the following C# sample code.
[C#]
//Play gun force feedback file effect
foreach(EffectObject eo in fxList)
{
    eo.Start(1,EffectStartFlags.NoDownload);
}
button0pressed = true;

Assigning a Predefined Effect to a Device

If you want to relay a physical force such as a constant force to the axes of a Device object, you can do this by assigning a predefined effect to its axes. The following C# sample code first checks to see if the Device object supports the effect. It then creates the effects, sets some parameters for the effects, then applies them to the axes of the Device object.
[C#]
//See if joystick supports ConstantForce and set it.
EffectObject eo = null;
Effect e;

foreach (EffectInformation ei in joystick.GetEffects(EffectType.All))
{
    //If the joystick supports ConstantForce, then apply it.

    if (DInputHelper.GetTypeCode(ei.EffectType)
        == (int)EffectType.ConstantForce)
    {
        // Fill in some generic values for the effect.
        e = new Effect();
        e.SetDirection(new int[axis.Length]);
        e.SetAxes(new int[axis.Length]);
        e.ConditionStruct =  new Condition[axis.Length];

        e.EffectType = EffectType.ConstantForce;
        e.Duration = (int)DI.Infinite;
        e.Gain = 10000;
        e.SamplePeriod = 0;
        e.TriggerButton = (int)Microsoft.DirectX.DirectInput.Button.NoTrigger;
        e.TriggerRepeatInterval = (int)DI.Infinite;
        e.Flags = EffectFlags.ObjectOffsets | EffectFlags.Cartesian;
        e.SetAxes(axis);

        // Create the effect, using the passed in guid.
        eo = new EffectObject(ei.EffectGuid, e, joystick);

    }
}

if (eo == null)
{
    throw new Exception("ConstantForce is not supported.");
}


DirectPlay

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The DirectPlay application programming interface (API) provides developers with the tools to develop multiplayer applications such as games or chat clients. For simplicity, this documentation will refer to all such applications as "games." A multiplayer application has two basic characteristics:

  • Two or more individual users, each with a game client on their computer.
  • Network links that enable the users' computers to communicate with each other, perhaps through a centralized server.

DirectPlay provides a layer that largely isolates your application from the underlying network. For most purposes, your application can just use the DirectPlay API, and enable DirectPlay to handle the details of network communication. DirectPlay provides many features that simplify the process of implementing many aspects of a multiplayer application, including:

  • Creating and managing both peer-to-peer and client/server sessions
  • Managing users and groups within a session
  • Managing messaging between the members of a session over different network links and varying network conditions
  • Enabling applications to interact with lobbies
  • Enabling users to communicate with each other by voice

This documentation provides a high-level overview of the capabilities of DirectPlay. Subsequent sections will take you into the details of how to use DirectPlay in your multiplayer game.

For more information, see the Microsoft.DirectX.DirectPlay managed code reference documentation.


Client/Server Topology

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A client/server game consists of the individual players' computers (the "game clients") connected to a central server computer. The topology of a four-player client/server game is depicted in the following illustration.

Game play is handled by having each user's game client communicate with the server. The server is responsible for passing information on to the other users. For instance, when one user moves, the user's computer sends a message to the server. The server then sends messages to the other players to inform them of a change in game state. The server can have a number of responsibilities; it can:

  • Act as the session's messaging hub. Each computer needs to send messages only to the server. The server handles the logistics of synchronizing all the other users. This arrangement can substantially reduce message traffic, especially for large games.
  • Host the game. The server typically takes care of the tasks that must be handled by the session host in a peer-to-peer game.
  • Support many aspects of the game. The server often does much more than support game logistics. With many games, especially large ones, much of the processing that maintains the "game universe" takes place on the server. The game clients are primarily responsible for handling the user interface (UI).

A client/server game is typically arranged and launched through a lobby client application that resides on the user's computer. The lobby client acts as a link to a lobby server application, which usually runs on the same remote computer that is hosting the game. When the game has been launched, the game server application becomes the host and handles tasks such as admitting new users to the game.

There are a number of advantages to client/server games.

  • They are more efficient, especially for large-scale games. In particular, they scale much better than peer-to-peer games because additional players cause only a linear increase in the messaging traffic. The client/server topology is necessary for massively multiplayer games.
  • You are not limited by the processing power of your users' computers. You can locate much of the processing required to maintain a large complex "game universe" on a single powerful computer, and let the users' computers handle the UI.
  • You can control key aspects of your game at a central site. For instance, you can often update the game or fix bugs by modifying the server application, thereby avoiding the need to update large numbers of game clients.

Once you have developed and shipped a peer-to-peer game, you are essentially finished. The game clients are largely self-sufficient. However, with a client/server game, you have an ongoing responsibility to your users that goes beyond providing support services. You must also provide and maintain a game server computer and the associated software, along with the network links to handle all the messaging, for the lifetime of the application. In the case of massively multiplayer games, you may need to operate your servers for extended periods with few or no breaks in service, or risk angering users by disrupting their game play.


Communicating with DirectPlay Objects

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

DirectPlay essentially consists of a collection of Component Object Model (COM) objects. Each object exposes one or more interfaces that enable you to control various aspects of DirectPlay. For instance, the DirectPlay Peer object is used to manage peer-to-peer games.

You communicate with a DirectPlay object by calling the methods exposed by its interfaces. For instance, to send some data to another user in a peer-to-peer game, you would send a message by calling the SendTo method. DirectPlay then takes care of getting the message to its target.

DirectPlay communicates with your application through one or more callback functions. Your application implements the callback function and passes a pointer to the function to DirectPlay during initialization. When DirectPlay needs to communicate with your application, it calls the callback function and passes in two key items of information:

  • A message identifier (ID) that identifies the message type
  • A pointer to a block of data, typically a structure, that provides any needed details.

Because much of DirectPlay messaging is multithreaded, it is critical that callback functions be properly implemented.


Creating and Managing Sessions

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A game session is an instance of a particular multiplayer game. A session has two or more users playing simultaneously, each with the same game client on his or her computer. A player is an entity in the game itself, and is defined by the particular game. Each user may have more than one player in a game. However, the game application must manage these players itself, using separate DirectPlay interfaces or objects for each player.

The first step in creating a session is to collect a group of users. There are two basic approaches:

  • Many game sessions are arranged by a lobby application running on a remote computer. This approach is used by most Internet-based games.
  • It is also possible to arrange games by having the individual users' computers communicate with each other. This approach is typically limited such situations as a group of potential users that are all on the same local area network (LAN).

Once the session has been arranged, the game is launched and gameplay begins. As the session proceeds, players may be eliminated from the session or new players added. The details are up to the individual game.

With a multiplayer game, each user's user interface (UI) can be synchronized with that of all other users in the session. Managing a multiplayer session thus requires a continual stream of messages to and from each user. For example, every time a player moves, a message must be sent to update that player's position on all the other game clients in the session. The core of DirectPlay is that part of the application programming interface (API) that supports efficient and flexible messaging between all the computers in a session.

There are two basic ways to structure the messaging topology of a session: peer-to-peer and client/server. Both topologies have their advantages and limitations, so you will need to evaluate which is most appropriate for your game.

This section includes the following topics.

  • Peer-to-Peer Topology
  • Client/Server Topology


DirectPlay Lobby Support

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A lobby is an application whose primary purpose is to enable players to meet and arrange games. It is typically located on a remote computer, and accessed over the Internet. Lobby servers often also perform a variety of other functions, such as hosting chat rooms, posting news and information, and selling merchandise. While lobby servers are convenient and commonly used to arrange multiplayer games, they aren't required. Multiplayer games can also be arranged by direct communication between lobby clients.

There are normally three components that are needed to enable a game to interact with a lobby:

  • A lobby server
  • A lobby client
  • A lobbyable game.

DirectPlay does not specify how you should implement a lobby server application. Instead, DirectPlay provides support for a lobby client. A lobby client is an application that is implemented by a lobby server vendor, and installed on each user's system. It serves as a link between the user and the lobby. While you could handle such communication directly, you would have to know the specific implementation details of every lobby that might launch your game.

The lobby client application handles the details of communicating with its associated lobby server, using whatever protocols are appropriate. The lobby client communicates with the user and their game applications through a DirectPlay interface. DirectPlay then passes messages to the application. The application can also use a DirectPlay interface to pass messages to the lobby client.

A lobby can launch virtually any application. However, the application must have some specific lobby-aware components to take full advantage of lobby-launching. In particular, a lobbyable application can communicate with the lobby client throughout the course of the session. If an application is registered as lobbyable, the lobby client also automatically receives updates for various changes in game status, such as host migration.


DirectPlay Network Communication

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The primary function of DirectPlay is to provide you with efficient and flexible messaging support that largely isolates your application from the underlying network hardware and software. If you need to send a status update, you can call the relevant DirectPlay application programming interface (API), regardless of what kind of network link is involved. DirectPlay network service providers support communication over Transmission Control Protocol/Internet Protocol (TCP/IP), Internetwork Packet Exchange (IPX), modem, and serial links.

Note: DirectPlay does not support secure communications.

To use modems on Microsoft Windows® 95 systems, you must install version 2.0 of the Telephony API (TAPI). You can download TAPI 2.0 from http://www.microsoft.com.

  • DirectPlay Transport Protocol
  • DirectPlay Addresses

DirectPlay Transport Protocol

The core of the DirectPlay networking capabilities is the DirectPlay protocol. This transport-layer protocol has been completely overhauled for DirectPlay 8, and is now used for all messaging. The DirectPlay protocol is focused on making it simple for you to send data from the sending application to the target application, without needing to worry about what happens in between. The protocol offers a number of features that are tailored to the needs of multiplayer games, including:

  • Reliable and unreliable delivery of messages. Reliable messages will be resent until the target application receives them. You can assign the delivery type on a message-by-message basis.
  • Sequential and non-sequential delivery of messages. Sequential messages will be passed to the target application in the order they were sent.
  • Message fragmentation and reassembly. If message size exceeds the capacity of a particular network, DirectPlay automatically fragments and reassembles the message.
  • Congestion control. DirectPlay automatically throttles your outgoing messages to a level that can be handled by the target. This feature prevents you from flooding the target with more messages than it can process.
  • Send prioritization. To ensure that the most important messages get sent first, DirectPlay enables you to designate messages as low, medium, or high priority. The high priority messages are sent to the front of the output queue, followed by medium and low priority messages.
  • Message timeouts. To prevent the outgoing message queue from being clogged with messages that have been superseded by more recent messages, DirectPlay enables you to assign a timeout value to all messages. When a message times out, it is removed from the outgoing message queue, regardless of whether it has been sent or not.

DirectPlay Addresses

In order to deliver messages, each participant in a multiplayer game must have a unique address. Addresses can refer either to the computer that your application is running on (device address), or a computer that your application needs to communicate with (host address).

DirectPlay addresses are in the form of URL strings. These strings consist of a scheme, scheme separator, and data string in the following general format:

x-directplay:/[data string]

The data string contains several elements that specify everything that is needed to enable communication to take place between sender and target, over a variety of different types of network link.

In use, the URL strings are embedded in a DirectPlay address object which is passed to or from DirectPlay API methods. You have the option of either manipulating the URL string directly, or using the methods exposed by the address object to handle each element of the data string separately.


DirectPlay Voice Communication

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The current trend toward team-based multiplayer games makes player-to-player communication an essential part of gameplay. Historically, this has been confined to text-based communication, where players type out the messages to their teammates. Although suitable for slower, turn-based games, text-based communication is at best an inconvenience for real-time games. Not only does it put slow typists at a disadvantage during gameplay, but it is also a significant break in the reality that games attempt to create for the player. An obvious solution to the problem is the use of speech as a means for communication. It requires no training and increases the immersion of the game itself.

The windows platform provides all the tools required to provide real-time voice conferencing to video game developers, but it requires a significant amount of effort on the part of the game developer. This, combined with the cost and difficulty of obtaining the rights to compression technology capable of handling extremely low-bandwidth situations, has prevented the wide-spread use of voice in games.

DirectPlay 9.0 provides the game developer with a robust real-time voice conferencing system that requires a minimal amount of effort to use.


Peer-to-Peer Topology

Note: This documentation is preliminary and is subject to change.
Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A peer-to-peer game consists of the individual players' computers, connected by network links. Schematically, the topology of a four-player peer-to-peer game looks like:

Gameplay is handled by having each user's game client communicate directly with the other users' clients. For instance, when one user moves, the game client must send three update messages, one to each of the other users' computers.

A peer-to-peer game is normally arranged and launched through a lobby client application that resides on the user's computer. There are two basic ways the lobby client can arrange a session:

  • The lobby client communicates directly with other potential users' lobby clients. This approach can be used, for instance, to arrange a game among users on the same local area network (LAN) subnet.
  • The lobby client acts as a link to lobby server application running on a remote computer. This is the way Internet-based games are normally arranged.

Once a session has been arranged and launched, most or all of the messaging will be user to user. If a lobby server is involved, it will only be handling such tasks as updating its list of session members when a player leaves the game, or enabling a new user to request entry to the session. Otherwise, the server stays in the background, and is typically not even aware of most of the messages that are being sent.

Because the server is either non-existent or at least not directly involved with the game play, one user is designated as the game host. They are responsible for handling logistical details such as bringing new players into an ongoing session.

Peer-to-peer games have the advantage of simplicity. All that is needed is a collection of players with game clients, and a way to organize a session. The primary drawback of the peer-to-peer topology is scalability. As the number of users increase, the number of messages needed to facilitate game play increases geometrically. The maximum number of users that can be accommodated depends on the game and the network bandwidth, but is typically no more than thirty.


DirectSound

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectSound® provides a system to capture sounds from input devices and play sounds through various playback devices using advanced 3-dimensional positioning effects, and filters for echo, distortion, reverberation, and other effects.

Information is presented in the following topics.

Playing Sounds | This section is a guide to playing WAV sounds through DirectSound buffers.
3-D Sound | Using DirectSound, you can locate sounds in space and apply Doppler shift to moving sounds. 3-D effects are applied to individual DirectSound buffers. Global parameters are set on an object called the listener.
Using Effects | DirectSound provides support for effects processing of sounds by Microsoft DirectX® Media Objects (DMOs).
Capturing Waveforms | DirectSound enables you to capture sounds from a microphone or other input to the sound card, for immediate playback or storage in a file. Data can be captured in Pulse Code Modulation (PCM) or compressed formats.
Optimizing Performance | This section offers some miscellaneous tips for improving the performance of applications that play their audio data directly into DirectSound buffers.

For more information, see the Microsoft.DirectX.DirectSound managed code reference documentation.


Playing Sounds

Note: This documentation is preliminary and is subject to change.

This section is a guide to playing WAV sounds through Microsoft® DirectSound® buffers.

Information in this section is contained in the following topics.

  • Playback Overview
  • Devices
  • Buffers
  • Using WAV Data

Related Topics

  • Using Effects


Playback Overview

Note: This documentation is preliminary and is subject to change.

The Microsoft® DirectSound® Device object represents a sound playback device and is used to manage that device and create sound buffers.

Multiple applications can create Device objects for the same sound device. When the input focus changes between applications, the audio output automatically switches from one application's streams to the other's. As a result, applications do not have to repeatedly play and stop their buffers when the input focus changes.

The primary buffer holds the audio that the listener will hear. Secondary sound buffers each contain a single sound or stream of audio. DirectSound automatically creates a primary buffer, but it is the application's responsibility to create secondary buffers. When sounds in secondary buffers are played, DirectSound mixes them in the primary buffer and sends them to the output device. Only the available processing time limits the number of buffers that DirectSound can mix.

Buffers are represented by either the Buffer class or the SecondaryBuffer class. Most applications use only the SecondaryBuffer class, which inherits from Buffer. However, an object representing the primary buffer must be a Buffer object.

A short sound can be loaded into a buffer in its entirety and played at any time by a simple method call. Longer sounds have to be streamed. An application can ascertain when it is time to stream more data into the buffer either by polling the position of the play cursor or by requesting notification when the play cursor reaches certain points.

Managed Microsoft DirectX® provides a method for loading nonstreaming (static) buffers from a WAV file directly into a secondary buffer but, for streaming buffers, you are responsible for parsing the file and copying the data into the buffer.


Devices

Note: This documentation is preliminary and is subject to change.

The first step in implementing Microsoft® DirectSound® in an application is to create a Device object, which represents a sound device.

This section describes how your application can enumerate available sound devices, create the Device object, and use the methods of the object to set the cooperative level, retrieve the capabilities of the device, create sound buffers, set the configuration of the system's speakers, and compact hardware memory.

  • Enumeration of Sound Devices
  • Creating the Device Object
  • Cooperative Levels
  • Device Capabilities
  • Speaker Configuration
  • Compacting Hardware Memory

Enumeration of Sound Devices

For an application that is simply going to play sounds through the user's preferred playback device, you do not need to enumerate the available devices. For more information, see Creating the Device Object.

If you are looking for a particular kind of device, want to offer the user a choice of devices, or need to work with two or more devices, you must enumerate the devices available on the system.

Enumeration serves three purposes.

  • Reports what hardware is available.
  • Supplies a globally unique identifier (GUID) for each device.
  • Enables you to create a temporary Device object for each device as it is enumerated, so that you can check the capabilities of the device.

To enumerate devices, instantiate a DevicesCollection object, and use its methods and properties to query for the available devices. The description, driver GUID, and module name of each device can be obtained from the properties of the DeviceInformation structure.

The following C# sample code retrieves the available devices. The same procedure can be used to identify available capture devices by substituting CaptureDevicesCollection for DevicesCollection.
[C#]
using Microsoft.DirectX.DirectSound;
public class wfEnum : System.Windows.Forms.Form
private DevicesCollection myDevices = null;
private struct myDeviceDescription
{
    public DeviceInformation info;
    public override string ToString()
    {
        return info.Description;
    }
        public myDeviceDescription(DeviceInformation di)
        {
            info = di;
        }
}
public wfEnum()
{
    // Retrieve the available DirectSound devices
    myDevices = new DevicesCollection();

    foreach (DeviceInformation dev in myDevices)
    {
        myDeviceDescription dd = new myDeviceDescription(dev);

        // Use DevicesCollection and DeviceInformation to query for devices.
    }
Note: The first device enumerated is always called the Primary Sound Driver. This device represents the preferred playback device set by the user in Control Panel. It is enumerated separately to make it easy for the application to add "Primary Sound Driver" to a list when presenting the user with a choice of devices. The primary device is also enumerated with its proper name and GUID.

Creating the Device Object

The following C# example show how to create a Device object for the default device.
[C#]
private Device dsDevice = null;
dsDevice = new Device();
The following C# example creates a device from a GUID, represented by the deviceGuid variable. This GUID can be obtained by enumeration of devices.
[C#]
dsDevice = new Device(deviceGuid);

You can also use one of the following values to specify a default device.

Value | Description
DSoundHelper.DefaultPlaybackDevice | The default system audio device. This is the same as the device created when no parameter is passed to the Device constructor.
DSoundHelper.DefaultVoicePlaybackDevice | The default voice communications device. Typically this is a secondary device such as a USB headset with microphone.

The object cannot be created if there is no sound device or, under VxD virtual device drivers, if the sound device is under the control of an application using the standard Microsoft Win32® waveform-audio functions.

See also Capturing Waveforms.

Cooperative Levels

Because Windows is a multitasking environment, more than one application can be working with a device driver at any one time. Through the use of cooperative levels, Microsoft DirectX® makes sure that each application does not gain access to the device in the wrong way or at the wrong time. Each DirectSound application has a cooperative level that determines the extent to which it is allowed to access the device.

After creating a Device object, you must set the cooperative level for the device by using the Device.SetCooperativeLevel method before you can play sounds.

DirectSound defines three cooperative levels for sound devices, represented by the values of the CooperativeLevel enumeration.

Normal Cooperative Level

At the normal cooperative level, the application cannot set the format of the primary buffer, write to the primary buffer, or compact the on-board memory of the device. All applications at this cooperative level use a primary buffer format of 22 kHz, stereo sound, and 8-bit samples, so that the device can switch between applications as smoothly as possible.

Priority Cooperative Level

When using a DirectSound device with the priority cooperative level, the application has first rights to hardware resources, such as hardware mixing, and can set the format of the primary sound buffer and compact the on-board memory of the device.

Game applications should use the priority cooperative level in almost all circumstances. This level gives the most robust behavior while allowing the application control over sampling rate and bit depth. The priority cooperative level also allows audio from other applications, such as IP telephony, to be heard along with the audio from the game.

Write-primary Cooperative Level

The highest cooperative level is write-primary. When using a DirectSound device with this cooperative level, your application has direct access to the primary sound buffer. In this mode, the application must write directly to the primary buffer. Secondary buffers cannot be played while this is happening.

An application must be set to the write-primary level in order to obtain direct write access to the audio samples in the primary buffer. If the application is not set to this level, then all calls to the Buffer.Write or the Buffer.Read method will fail.

When your application is set to the write-primary cooperative level and gains the foreground, all secondary buffers for other applications are stopped and marked as lost. When your application in turn moves to the background, its primary buffer is marked as lost and must be restored when the application again moves to the foreground.

You cannot set the write-primary cooperative level if a DirectSound driver is not present on the user's system. To determine whether this is the case, check the Caps.EmulateDriver property of Device.Caps. If EmulateDriver is true, the DirectSound driver is being emulated for the device, and the write-primary level cannot be set.

Device Capabilities

DirectSound enables your application to retrieve the hardware capabilities of the sound device. Most applications will not need to do this, because DirectSound automatically takes advantage of any available hardware acceleration. However, high-performance applications can use the information to scale their sound requirements to the available hardware. For example, an application might choose to play more sounds if hardware mixing is available than if it is not.

After creating a Device object, your application can retrieve the capabilities of the sound device from the Device.Caps property. The Caps structure contains information about the performance and resources of the sound device, including the maximum resources of each type and the resources that are currently available.

If your application scales to hardware capabilities, you should check the Caps property after every buffer allocation to determine if there are enough resources to create the next buffer.

Speaker Configuration

DirectSound uses the speaker configuration-that is, the position of the speakers relative to the listener-to optimize 3-D effects for the user's sound system.

In Microsoft Windows® 98, Windows 2000, and later operating systems, the speaker configuration can be set by the user in Control Panel. An application can retrieve this value from the Device.SpeakerConfig property. Although this property can be set, applications should not do so, as this is a global setting that affects other users and applications.

Compacting Hardware Memory

As long as it has at least the priority cooperative level, your application can use the Device.Compact method to move any on-board sound memory into a contiguous block to make the largest portion of free memory available. This method is not useful on most modern sound cards, which use system memory.


Buffers

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectSound® buffer objects control the delivery of waveform data from a source to a destination. For most buffers, the destination is a mixing engine called the primary buffer. From the primary buffer, the data goes to the hardware that converts digital samples to sound waves.

Information about using DirectSound buffers is contained in the following topics.

For information about capture buffers, see Capturing Waveforms.

  • Buffer Basics
  • Creating Secondary Buffers
  • Buffer Control Options
  • 3-D Algorithms for Buffers
  • Filling and Playing Static Buffers
  • Using Streaming Buffers
  • Playback Controls
  • Play and Write Cursors
  • Play Buffer Notification
  • Mixing Sounds
  • Losing and Restoring Buffers

Buffer Basics

When DirectSound is initialized, it automatically creates and manages a primary buffer for mixing sounds and sending them to the output device.

Your application must create at least one secondary sound buffer for storing and playing individual sounds. For more information on how to do this, see Creating Secondary Buffers.

A secondary buffer has a waveform format that must match the format of the data. This format is described in a WaveFormat structure. The format of a secondary buffer cannot be changed. Sounds of different formats can be played in different secondary buffers, and are automatically mixed to a common format in the primary buffer.

A secondary buffer can exist throughout the life of an application or it can be destroyed when no longer needed. It can contain a single sound that is to be played repeatedly, such as a sound effect in a game, or it can be filled with new data from time to time. The application can play a sound stored in a secondary buffer as a single event or as a looping sound that plays continuously. Secondary buffers can also be used to stream data, in cases where a sound file contains more data than can conveniently be stored in memory.

Buffers can be located either in hardware or in software. Hardware buffers are mixed by the sound card processor, and software buffers are mixed by the CPU. Software buffer data is always in system memory; hardware buffer data can be in system memory or, if the application requests it and resources are available, in on-board memory. For more information, see Dynamic Voice Management and Hardware Acceleration on ISA and PCI Cards.

You mix sounds from different secondary buffers simply by playing them at the same time. Any number of secondary buffers can be played at one time, up to the limits of available processing power.

Normally, you do not have to concern yourself at all with the primary buffer; DirectSound manages it behind the scenes. However, if your application is to perform its own mixing, DirectSound will let you write directly to the primary buffer. If you do this, you cannot also use secondary buffers.

Creating Secondary Buffers

To create a secondary sound buffer, use one of the five overloaded constructors of SecondaryBuffer, with an instantiated Device object passed to the constructor. As appropriate, also pass to the constructor a Stream Leave Site source data stream object, or a String Leave Site file name object.

Buffer objects are owned by the Device object that created them. When the Device object is released, all buffers created by that object also will be released and should not be referenced.

DirectSound allocates hardware resources to the first buffer that can take advantage of them. Because hardware buffers are mixed by the sound card processor, they have much less impact on application performance. To specify the buffer location, pass a BufferDescription object to the constructor as follows.

BufferDescription Options

An instantiated BufferDescription object may be passed to the SecondaryBuffer constructor in order to describe the characteristics and location of the buffer.

If you want to specify the location of a buffer instead of letting DirectSound decide where it belongs, set either the BufferDescription.LocateInHardware property or BufferDescription.LocateInSoftware property. If LocateInHardware is set and there are insufficient hardware resources, the buffer creation request fails.

To take advantage of the voice management features of DirectSound, set the BufferDescription.DeferLocation property when creating the buffer. This property defers the allocation of resources for the buffer until it is played. For more information, see Dynamic Voice Management.

You can ascertain the location of an existing buffer by getting the Buffer.Caps property (inherited by SecondaryBuffer). Check the BufferCaps structure for either LocateInHardware or LocateInSoftware properties. One or the other is always specified.

Setting BufferDescription.StaticBuffer lets DirectSound know that the buffer should be created in on-board hardware memory if possible. Buffer creation does not fail if a hardware buffer is not available. Hardware static buffers should be used only for short sounds that are to be played repeatedly. This property has no effect on most modern sound cards, which use system memory for their buffers.

See Also

Hardware Acceleration on ISA and PCI Cards.

Buffer Control Options

When creating a sound buffer, your application must specify the control options needed for that buffer. This is done with the BufferDescription class, which can contain one or more of the following control properties from the BufferCaps structure. This is not a complete list of all available properties.

Property | Description
Control3D | Buffer supports 3-D control. Cannot be combined with ControlPan.
ControlFrequency | Buffer supports frequency control.
ControlEffects | Buffer supports effects processing.
ControlPan | Buffer supports pan control. Cannot be combined with Control3D.
ControlPositionNotify | Buffer supports notifications of cursor position.
ControlVolume | Buffer supports volume control.

To obtain the best performance on all sound cards, your application should specify only control options it will use.

DirectSound uses the control options in determining whether hardware resources can be allocated to sound buffers. For example, a device might support hardware buffers but provide no pan control on those buffers. In this case, DirectSound would use hardware acceleration only if the ControlPan property was not specified.

If your application attempts to use a control that a buffer lacks, the method call fails. For example, if you attempt to set the Buffer.Volume property, an exception occurs unless the ControlVolume property was specified when the buffer was created.

See Also

Playback Controls

3-D Algorithms for Buffers

When you create a secondary buffer with the BufferCaps.Control3D property and the buffer is in software, you can specify an algorithm to simulate 3-D spatial location of a sound. By default, no head-related transfer function (HRTF) processing is performed, and the location of the sound relative to the listener is indicated by panning and volume only. You can request two levels of HRTF for the buffer.

See Also

BufferDescription.Guid3DAlgorithm.

Filling and Playing Static Buffers

A secondary buffer that contains an entire self-contained sound is called a static buffer. Although it is possible to reuse the same buffer for different sounds, typically data is written to a static buffer only once.

Static buffers are created and managed just like streaming buffers. The only difference is in the way they are used: static buffers are filled once and then played, but streaming buffers are constantly refreshed with data as they are playing.

Note: A static buffer is not necessarily one created by setting the BufferCaps.StaticBuffer property in the buffer description. This property requests allocation of memory on the sound card, which is not available on most modern hardware. A static buffer can exist in system memory and can be created with either the LocateInHardware or LocateInHardware properties. For more information, see Hardware Acceleration on ISA and PCI Cards.

When you create a secondary buffer using the SecondaryBuffer(String,BufferDescription,Device) or SecondaryBuffer(Stream,BufferDescription,Device) constructors, the buffer is automatically given the correct format and size, and is filled with the data. If you use the SecondaryBuffer(String,Device) or SecondaryBuffer(Stream,Device) constructors, you are responsible for setting the format and size of the buffer, and you must write the data to the buffer by using the Buffer.Write method (inherited by SecondaryBuffer).

To play the buffer, call Buffer.Play.

The following C# example creates a buffer from a file and plays it. The buffer supports volume control, panning, and frequency control. Assume that FileName is a valid path to a WAV file, and device is a Device object.
[C#]
SecondaryBuffer secBuff = null;
BufferDescription desc = new BufferDescription();
desc.Flags = BufferCaps.ControlPan | BufferCaps.ControlVolume | BufferCaps.ControlFrequency;
secBuff = new SecondaryBuffer(FileName, desc, device);
secBuff.Play(0, 0);

Because the BufferPlayFlags.Looping flag is not set in the example, the buffer automatically stops when it reaches the end. You can also stop it prematurely, or stop a looping buffer, by using Buffer.Stop.

Using Streaming Buffers

A streaming buffer plays a long sound that cannot all fit into the buffer at once. As the buffer plays, old data is periodically replaced with new data. Play a streaming sound with the following procedure.

  1. Call SecondaryBuffer(Stream,BufferDescription,Device) to create a buffer with the correct waveform format, and of a convenient size. A buffer large enough to hold one or two seconds of data is typical; smaller buffers can be used, but they have to be refreshed more frequently, which can be inefficient.
  2. Set notification positions so that your application knows when to refresh a portion of the buffer. For example, you can set notifications halfway through the buffer and at the end. When the play cursor reaches the halfway point, the first part of the buffer is refreshed; when it reaches the end, the second part is refreshed. Alternatively, you can poll the play cursor as the buffer plays, but this is less efficient than notification. For more information, see Play and Write Cursors.
  3. Load the entire buffer with data by using Buffer.Write.
  4. Call Buffer.Play (inherited by SecondaryBuffer), specifying the BufferStatus.Looping property.
  5. When the play cursor reaches the first point at which you want to refresh data, call Write again, writing new data from the start of the buffer up to the play cursor. Save the position of the last byte written.
  6. Call Write each time the cursor reaches a refresh point, writing data to the part of the buffer that lies between the saved position and the play cursor. Note that wraparound is handled automatically: if the buffer is 10,000 bytes long, and you write 2000 bytes to offset 9000, the last 1000 bytes are written to the front of the buffer.
  7. When all data has been written to the buffer, set a notification position at the last valid byte, or poll for this position. When the cursor reaches the end of the data, call Buffer.Stop.

Never write to the entire buffer while it is playing. Refresh only a portion of the buffer each time. Do not write to the part of the buffer that lies between the play cursor and the write cursor.

Playback Controls

To retrieve and set the volume at which a buffer is played, your application can use the Buffer.Volume property. (All properties are inherited by SecondaryBuffer.) Setting the volume on the primary buffer changes the waveform-audio volume of the sound card. Volume is measured in hundredths of a decibel and is a negative value. Because the decibel scale is not linear, effective silence may occur long before the minimum volume of -10,000 is reached.

The Buffer.Frequency property controls the frequency at which audio samples play, in samples per second. Set this property to 0 to reset the frequency to the original value, as specified in the WaveFormat structure that describes the format of the buffer. You cannot change the frequency of the primary buffer.

The Buffer.Pan property controls the right-left position of the sound. The pan effect is achieved by attenuating one channel. When the sound is at the center (a Pan value of 0), both channels are at full volume.

In order to use any of these controls, you must set the appropriate flags when creating the buffer. See Buffer Control Options.

Play and Write Cursors

DirectSound maintains two pointers into the buffer: the play cursor and the write cursor. These positions are byte offsets into the buffer.

The Buffer.Play method always starts playing at the buffer's play cursor. When a buffer is created, the cursor position is set to 0. As a sound is played, the cursor moves and always points to the next byte of data to be output. When the buffer is stopped, the cursor remains at the next byte of data.

The write cursor is the point after which it is safe to write data into the buffer. The block between the current play position and the current write position is already committed to be played, and it cannot be changed safely.

You might visualize the buffer as a clock face, with data written to it in a clockwise direction. The play position and the write position are like two hands sweeping around the face at the same speed, the write position always keeping a little ahead of the play position. If the play position points to the 1 and the write position points to the 2, it is only safe to write data after the 2. Data between the 1 and the 2 may already have been queued for playback by DirectSound and should not be touched.

The write position moves with the play position, not with data written to the buffer. If you are streaming data, you are responsible for maintaining your own pointer into the buffer to indicate where the next block of data should be written.

An application can retrieve the play and write cursors from the PlayPosition and WritePosition properties. You can also set the PlayPosition property, which indirectly changes WritePosition.

To ensure that the play cursor is reported as accurately as possible, always specify the BufferCaps.CanGetCurrentPosition property when creating a secondary buffer.

Play Buffer Notification

When streaming audio, you may want your application to be notified when the play cursor reaches a certain point in the buffer, or when playback is stopped. By using the Notify.SetNotificationPositions method, you can set any number of points within the buffer where events are to be signaled. You cannot do this while the buffer is playing.

To set up notifications, do the following:

  1. Create an AutoResetEvent Leave Site for each notification position.
  2. Obtain the Notify object by passing the SecondaryBuffer object to the Notify constructor.
  3. Create an array of BufferPositionNotify structures, one for each notification position. Set the Offset property to the byte offset where you want to be notified. Set the EventNotifyHandle property to the AutoResetEvent Leave Site.Handle Leave Site of one of the events you created in step 1.
  4. Call Notify.SetNotificationPositions, passing in the array of BufferPositionNotify structures.

You can now play the buffer in a separate thread and use WaitHandle Leave Site.WaitAny Leave Site to wait for notifications.

Mixing Sounds

Mixing is done automatically when you play multiple secondary buffers at the same time.

Under earlier driver models, the DirectSound mixer produces the best sound quality if all your application's sounds use the same WAV format and the hardware output format is matched to the format of the sounds. If this is done, the mixer does not need to perform any format conversion.

Your application can change the hardware output format by creating a primary sound buffer object and setting the Buffer.Format property. This primary buffer object is for control purposes only; creating it is not the same as obtaining write access to the primary buffer, and you do not need the CooperativeLevel.WritePrimary cooperative level. However, you do need a cooperative level of CooperativeLevel.Priority. DirectSound will restore the hardware format to the format specified in the last call every time the application gains the input focus.

You must set the format of the primary buffer before creating any secondary buffers.

Note: With Microsoft Windows® Driver Model (WDM) drivers, setting the primary buffer format has no effect. The format is determined by the kernel mixer. For more information, see DirectSound Driver Models.

Losing and Restoring Buffers

Memory for a sound buffer can be lost in certain situations: for example, when buffers are located in sound card memory and another application gains control of the hardware resources. Loss can also occur when an application with the write-primary cooperative level moves to the foreground; in this case, DirectSound makes all other sound buffers lost so that the foreground application can write directly to the primary buffer.

An exception is raised when the application attempts to play or write data to a lost buffer. When the application that caused the loss either lowers its cooperative level from write-primary or moves to the background, other applications can attempt to reallocate the buffer memory by calling the Buffer.Restore method. If successful, this method restores the buffer memory and all other settings for the buffer, such as volume and pan settings. However, a restored buffer may not contain valid sound data, so the owning application should rewrite the data to the buffer.


Using WAV Data

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectSound® buffers play only waveform audio data consisting of digital samples of the sound at a fixed sampling rate. The representation of an analog signal by a sequence of numbers is known as Pulse Code Modulation (PCM).

WAV data is usually stored in files or resources in Resource Interchange File Format (RIFF). The data includes a description of the WAV format, including parameters such as the sampling rate and number of output channels. The format of a sound is described by a WaveFormat structure. Managed DirectSound does not support audio formats with more than two channels, as described in a C++ WAVEFORMATEXTENSIBLE structure.

DirectSound does not support compressed WAV formats. Applications should use the Audio Compression Manager (ACM) functions, provided with the Microsoft Win32® application programming interfaces (APIs) in the Microsoft Platform Software Development Kit (SDK), to convert compressed audio to PCM format before writing the data to a sound buffer.

For short sounds, you can create a SecondaryBuffer from a WAV file by using SecondaryBuffer(String,Device) or SecondaryBuffer(String,BufferDescription,Device). To access streaming buffers, you can use the SecondaryBuffer(Stream,Device) or SecondaryBuffer(Stream,BufferDescription,Device) constructors.


3-D Sound

Note: This documentation is preliminary and is subject to change.

Using Microsoft® DirectSound®, you can locate sounds in space and apply Doppler shift to moving sounds. 3-D effects are applied to individual DirectSound buffers. Global parameters are set on an object called the listener.

The following topics cover some general aspects of 3-D sound.

  • Coordinates of 3-D Space
  • Perception of Sound Positions

Information about how to use 3-D sound in an application is found in the following sections.

  • 3-D Buffers
  • 3-D Listeners


Coordinates of 3-D Space

Note: This documentation is preliminary and is subject to change.

The position, velocity, and orientation of sound sources and listeners in 3-D space are represented by Cartesian coordinates, which are values on three axes: the x-axis, the y-axis, and the z-axis. The axes are relative to a viewpoint established by the application. Values on the x-axis increase from left to right, on the y-axis from down to up, and on the z-axis from near to far.

Conventionally, vectors are expressed as three values enclosed in parentheses and separated by commas, in the order (x, y, z). In Microsoft® DirectSound®, coordinates of position, velocity, or orientation on the three axes are described in a Vector3 structure.

For position, the values are in meters by default. If your application does not use the meter as its unit of measure for 3-D graphics, you can set a distance factor, which is a floating-point value representing meters per application-specified distance unit. For example, if your application uses the foot as the distance unit, it could specify a distance factor of 0.3048, which is the number of meters in a foot. For more information, see Distance Factor.

For velocity, the vector describes the rate of movement along each axis in units per second. Again, the default unit is meters, but this can be changed by the application.

For orientation, the values are in arbitrary units and are relative to one another. If the base view of the 3-D world is facing north, level to the ground, and the orientation of the listener is (1, 0, 0)-that is, positive on the x-axis and neutral on the other two axes-then the listener is facing due east. If the vector is (1, 0, 1), the listener's orientation is to the northeast. If it is (-1, 0, 1), the listener is facing northwest. Because the values within a vector are not in absolute units, the last example could equally well be expressed in many other ways, such as (-5, 0, 5) or (-0.25, 0, 0.25).

You can see how vectors in 2-D space work by drawing them on a sheet of graph paper. Let the values increase from the bottom of the paper to the top and from left to right. A line drawn from (0, 0) to (1, 1) has the same orientation, or direction, as one drawn from (0, 0), to (5, 5). However, the second line indicates a greater distance, or velocity. 3-D vectors work in just the same way, with an additional axis.


Perception of Sound Positions

Note: This documentation is preliminary and is subject to change.

In the real world, the perception of a sound's position in space is influenced by several factors. Not all of these factors are acoustical; one of the most important is sight. Clues from the sounds themselves include the following:

  • Overall loudness. As a sound source moves away from the listener, its perceived volume decreases at a fixed rate. This phenomenon is known as rolloff.
  • Interaural intensity difference. For example, a sound coming from the listener's right sounds louder in the right ear than in the left.
  • Interaural time difference. For example, a sound coming from the listener's right arrives at the right ear slightly before it arrives at the left ear. The difference is approximately a millisecond.
  • Muffling. The shape and orientation of the ears ensures that sounds coming from behind the listener are slightly muffled compared with sounds coming from the front. In addition, if a sound is coming from the right, the sound reaching the left ear will be muffled by the mass of the listener's head as well as by the orientation of the left ear.
  • Effect of the pinnae. The ridges of the earlobes alter the pitch and timing of sounds arriving from different directions, giving subtle clues to the brain about the location of the sound source. The mathematics behind this effect are known as the head-related transfer function (HRTF).

Microsoft® DirectSound® creates virtual 3-D effects on two speakers or headphones, or on multichannel systems with Microsoft Windows® Driver Model (WDM) drivers if the user has chosen a surround sound speaker configuration in Control Panel. For more information, see BufferDescription.


3-D Buffers

Note: This documentation is preliminary and is subject to change.

Each sound source in a 3-D environment is represented by an object of the Buffer3D class. This class is supported only by sound buffers created with the BufferCaps.Control3D property.

Applications must supply monaural sound sources when using the 3-D capabilities of Microsoft® DirectSound®. If you attempt to create a buffer with the Control3D property set and a WAV format with more than one channel, an exception is raised.

This section describes how your applications can obtain and manage Buffer3D objects. The following topics are discussed.

  • Obtaining the Buffer3D Object
  • Batch Parameters for 3-D Buffers
  • Minimum and Maximum Distances
  • Processing Mode
  • Buffer Position and Velocity
  • Sound Cones

Obtaining the Buffer3D Object

Create a Buffer3D object by passing a SecondaryBuffer object to the Buffer3D constructor. The BufferDescription.Control3D property must have been set to true.

See Also

Buffer3D(SecondaryBuffer)

Batch Parameters for 3-D Buffers

Applications can retrieve or set a 3-D sound buffer's parameters individually or in batches. To set individual values, your application can use the applicable Buffer3D property. However, applications often must set or retrieve several values at once as the sound source moves about, changes velocity, and so on. You can do this by using the Buffer3D.AllParameters property.

Parameter changes can also be made more efficiently by flagging them as deferred and then running them all at once. For more information, see Deferred Settings.

Minimum and Maximum Distances

As a listener approaches a sound source, the sound gets louder; the volume doubles when the distance is halved. Past a certain point, however, it is not practical for the volume to continue to increase. This is the minimum distance for the sound source.

The minimum distance is especially useful when an application must compensate for the difference in absolute volume levels of different sounds. Although a jet engine is much louder than a bee, for practical reasons these sounds must be recorded at similar absolute volumes. An application might use a minimum distance of 100 meters for the jet engine and 2 centimeters for the bee. With these settings, the jet engine would be at half volume when the listener was 200 meters away, but the bee would be at half volume when the listener was 4 centimeters away.

The default minimum distance for a sound buffer is defined as 1 unit, or 1 meter at the default distance factor. Unless you change this value, the sound is at full volume when it is 1 meter away from the listener, at half volume 2 meters away, at quarter volume 4 meters away, and so on. For most sounds you will probably want to set a larger minimum distance so that the sound does not fade so rapidly as it moves away.

The maximum distance for a sound source is the distance beyond which the volume does not get any lower. The default maximum distance for a DirectSound 3-D buffer is 1 billion, meaning that in most cases the attenuation will continue to be calculated long after the sound has moved out of hearing range. To avoid unnecessary processing on software buffers under VxD virtual device drivers, applications should set a reasonable maximum distance and include the Mute3DAtMaximumDistance property when creating the buffer.

The maximum distance can also be used to prevent a sound from becoming inaudible. For example, if you have set the minimum distance for a sound at 100 meters, that sound might become effectively inaudible at 1,000 meters or less. By setting the maximum distance at 800 meters, you ensure that the sound always has at least one-eighth of its maximum volume regardless of the distance. In this case, of course, you should not set the Mute3DAtMaximumDistance property.

The following illustration shows how minimum and maximum distance affect the sound volume of a jet and a bee at increasing distances.

Graph of effects of minimum and maximum distances on sound volume

By default, distance values are expressed in meters. See Distance Factor.

To adjust the effect of distance on volume for all sound buffers, you can change the Rolloff Factor.

See Also

Buffer3D.AllParameters property

Buffer3D.MaxDistance property

Buffer3D.MinDistance property

Processing Mode

Sound buffers have three processing modes: normal, head-relative, and disabled.

In normal mode, the sound source is positioned and oriented absolutely in world space. This is the default mode, and is used for sound sources that do not move and turn with the listener.

In head-relative mode, the 3-D properties of the sound source are all relative to the current position, velocity, and orientation of the listener. As the listener moves and turns, the buffer is automatically repositioned in world space. Head-relative mode can be used for sounds such as the listener's own footsteps. However, most head-relative sounds do not have to be 3-D sounds at all.

In disabled mode, 3-D sound processing is disabled and the sound seems to originate from the center of the listener's head.

See Also

Buffer3D.AllParameters property

Buffer3D.Mode property

Buffer Position and Velocity

As a sound source moves, it is up to the application to specify values for its position and velocity.

Position is measured in distance units along each of the three axes, relative to either world space or the listener, depending on the processing mode.

Velocity is measured in distance units per second along each of the three axes of a vector. By default, distance units are meters. Velocity is used by DirectSound only to calculate the effects of Doppler shift.

See Also

Buffer3D.AllParameters property

Buffer3D.Position property

Buffer3D.Velocity property

Distance Factor

Doppler Factor

Processing Mode

Sound Cones

A sound with no orientation has the same amplitude at a given distance in all directions. A sound with an orientation is loudest in the direction of orientation. The model that describes the loudness of the oriented sound is called a sound cone, which has its apex located at the source of the sound. Sound cones are made up of an inside (or inner) cone and an outside (or outer) cone. The outside cone angle must always be equal to or greater than the inside cone angle.

At any angle within the inner cone, the volume of the sound is just what it would be if there were no cone, after taking into account the basic volume of the buffer, the distance from the listener, the listener's orientation, and so on.

At any angle outside the outer cone, the normal volume is attenuated by a factor set by the application. The outside cone volume is expressed in hundredths of decibels and is a negative value, because it represents attenuation from the default volume of 0.

Between the inner and outer cones is a zone of transition from the inside volume to the outside volume. The volume decreases as the angle increases.

The following illustration shows the concept of sound cones.

Diagram of listener within inside and outside sound cones

Every 3-D sound buffer has a sound cone, but by default a buffer behaves like an omnidirectional sound source, because the outside volume is not attenuated, and the inside and outside cone angles are 360 degrees. Unless the application changes these values, the sound does not have any apparent orientation.

Designing sound cones properly can add dramatic effects to your application. For example, you could position a sound source in the center of a room, setting its orientation toward an open door in a hallway. Then set the angle of the inside cone so that it extends to the width of the doorway, make the outside cone a bit wider, and set the outside cone volume to inaudible. A listener moving along the hallway will begin to hear the sound only when near the doorway, and the sound will be loudest as the listener passes in front of the open door.

See Also

Buffer3D.ConeAngles property

Buffer3D.ConeOrientation property

Buffer3D.ConeOutsideVolume property


3-D Listeners

Note: This documentation is preliminary and is subject to change.

In a virtual 3-D environment as in the real world, sounds exist in relation to a point of reception. The 3-D sound effects in a Microsoft® DirectSound® application are affected not only by the position, orientation, and velocity values of the sound sources, but also by the position, orientation, and velocity of the virtual listener.

By default, the listener is stationary at the zero point of all vectors, oriented with the nose toward the positive z-axis and the top of the head toward the positive y-axis. By obtaining an object to represent the listener, the application can change all these values to reflect the movement and "facing" of the user within virtual space. The listener object also controls the general parameters of the acoustic environment, such as the amount of Doppler shift and the rate of volume attenuation over distance.

This section describes how your application can obtain a listener and manage global 3-D sound parameters. The following topics are discussed.

  • Obtaining the 3-D Listener
  • Batch Parameters for 3-D Listeners
  • Deferred Settings
  • Distance Factor
  • Listener Orientation
  • Listener Position and Velocity
  • Doppler Factor
  • Rolloff Factor

Obtaining the 3-D Listener

Global sound parameters are set and retrieved by using the Listener3D object, which is obtained from the primary buffer. Only one listener exists in an application.

The following Microsoft Visual Basic® function creates a Buffer object representing the primary buffer, which is created with the Control3D property. The function then creates and returns a Listener3D object.
[Visual Basic .NET]
Private Function getListener(ByVal dev As Device) As Listener3D
    Dim primaryBuffer As Buffer
    Dim desc As New BufferDescription()
    Dim caps As New BufferCaps()
    desc.PrimaryBuffer = True
    desc.Flags = caps.PrimaryBuffer OR caps.Control3D
    primaryBuffer = New Buffer(desc, dev)
    Dim listener = New Listener3D(primaryBuffer)
    Return listener
End Function

Batch Parameters for 3-D Listeners

Applications can retrieve or set a listener's parameters individually or in batches. To set individual values, your application can use the applicable Listener3D property. However, applications often must set or retrieve several values at once as the sound source moves about, changes velocity, and so on. You can do this by using the Listener3D.AllParameters property.

Parameter changes can also be made more efficiently by flagging them as deferred and then executing them all at once. For more information, see Deferred Settings.

Deferred Settings

Every change to 3-D sound buffer and listener settings causes remixing, at the expense of CPU cycles. To minimize the performance impact of changing 3-D settings, set the Deferred property on the Listener3D object and all Buffer3D objects. When this property is true, no other properties are changed until you call Listener3D.CommitDeferredSettings.

Note: CommitDeferredSettings settings are replaced by immediate settings. For example, if you set Listener3D.Deferred to true and set the listener velocity to (1.0, 0.0, 0.0), and then you set Deferred to false and set the velocity to (2.0, 0.0, 0.0), the velocity immediately becomes (2.0, 0.0, 0.0) and does not change when CommitDeferredSettings is called.

Distance Factor

The distance factor is the number of meters in a vector unit. By default, the distance factor is 1.0. If the velocity of a buffer is (2.0, 0.0, 0.0), the sound source is considered to be moving along the positive x-axis at 2 meters per second. Applications that are using a different unit of measurement for 3-D graphics vectors might want to change the distance factor accordingly.

Suppose, for example, that the basic unit of measurement in your application is the foot, or 0.3048 meters. You set the Listener3D.DistanceFactor property to 0.3048. From then on, properties such as position and velocity are measured in feet.

The distance factor mainly affects Doppler shift, by changing the actual velocity represented by n units per second. It does not directly affect rolloff, because the rate of attenuation over distance is based on the minimum distance in unspecified units. If you set the minimum distance for a given sound at 2 units, the volume will be halved at a distance of 4 units, whether those units are in feet, meters, or any other measure.

See Also

Minimum and Maximum Distances

Listener Orientation

Listener orientation is defined by the relationship between two vectors that share an origin at the center of the listener's head: the top and front vectors. The top vector points straight up through the top of the head, and the front vector points forward through the listener's face at right angles to the top vector, as in the following illustration.

Diagram of listener top and front vectors

By default, the front vector is (0.0, 0.0, 1.0), and the top vector is (0.0, 1.0, 0.0). The two vectors must always be at right angles to one another. If necessary, DirectSound will adjust the front vector so that it is at right angles to the top vector.

See Also

Listener3D.Orientation property

Listener Position and Velocity

As the listener moves, it is up to the application to specify values for its position and velocity.

Position is measured in distance units along each of the three axes, relative to either world space or the listener, depending on the processing mode.

Velocity is measured in distance units per second along each of the three axes of a vector. By default, distance units are meters. To calculate Doppler shift, DirectSound combines the velocity of the sound source with the velocity of the listener.

See Also

Listener3D.AllParameters property

Listener3D.Position property

Listener3D.Velocity property

Distance Factor

Doppler Factor

Doppler Factor

DirectSound automatically creates Doppler shift effects for 3-D sound buffers based on their velocity relative to the listener.

In order to have realistic Doppler shift effects in your application, you must calculate the speed of any object that is moving, whether a sound source or a listener, and set the appropriate velocity. You are free to exaggerate or lessen this value in a particular case in order to create special effects. You can also globally increase or decrease Doppler shift by changing the Listener3D.DopplerFactor property.

The Doppler factor can range from 0.0 (DSoundHelper.MinDopplerFactor) to 10.0 (DSoundHelper.MaxDopplerFactor). A value of 0 means no Doppler shift is applied to a sound. Every other value represents a multiple of the real-world Doppler shift. In other words, a value of 1 (DSoundHelper.DefaultDopplerFactor) means the Doppler shift that would be experienced in the real world is applied to the sound, a value of 2 means twice the real-world Doppler shift, and so on.

See Also

Buffer3D.Velocity property

Listener3D.Velocity property

Rolloff Factor

Rolloff is the amount of attenuation that is applied to sounds, based on the listener's distance from the sound source. DirectSound can ignore rolloff, exaggerate it, or give it the same effect as in the real world, depending on the value of the Listener3D.RolloffFactor property.

The rolloff factor can range from 0.0 (DSoundHelper.MinRolloffFactor) to 10.0 (DSoundHelper.MaxRolloffFactor). A value of 0 means no rolloff is applied to a sound. Every other value represents a multiple of the real-world rolloff. In other words, a value of 1 (DSoundHelper.DefaultRolloffFactor) means the rolloff that would be experienced in the real world is applied to the sound, a value of 2 means twice the real-world rolloff, and so on.

To change the effect of distance for an individual sound buffer, you can set the minimum distance for the buffer. For more information, see Minimum and Maximum Distances.


Using Effects

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectSound® provides support for effects processing of sounds by Microsoft DirectX® Media Objects (DMOs).

All the standard DMOs except Waves reverberation can process 8-bit or 16-bit Pulse Code Modulation (PCM) data with one or two channels at any sample rate supported by DirectSound. Waves reverberation does not support 8-bit samples.

The following topics contain information on setting up and using effects.

  • Setting Effects on Buffers
  • Effect Parameters
  • Standard Effects


Setting Effects on Buffers

Note: This documentation is preliminary and is subject to change.

Any number of effects can be set on a secondary buffer that was created with the BufferCaps.ControlEffects property. Effects might not work smoothly on very small buffers, and Microsoft® DirectSound® does not permit the creation of effects-capable buffers that hold less than 150 (BufferSize.FxMin) milliseconds of data.

To implement an effect on a buffer, use the SecondaryBuffer.SetEffects method. This method takes an array of EffectDescription structures that describe the effects. You can also use SetEffects to remove effects, by passing a null reference instead of an array. In either case, the buffer must not be playing.

Effects can be instantiated in hardware (that is, implemented by the sound card driver) or in software. For more information, see EffectDescription.

The following Microsoft Visual Basic® sample function sets the standard echo effect on a buffer.
[Visual Basic .NET]
Private Sub SetEcho(ByVal b As SecondaryBuffer)
    Dim fx As EffectDescription()
    ReDim fx(0)
    fx(0).GuidEffectClass = DSoundHelper.StandardEchoGuid
    Try
        b.SetEffects(fx)
    Catch e As ControlUnavailableException
        Debug.WriteLine("BufferDescription does not have ControlEffects set.")
    End Try
End Sub


Effect Parameters

Note: This documentation is preliminary and is subject to change.

To set or retrieve parameters of sound effects, you must first obtain the appropriate effect object from the buffer that contains the effect.

Objects of the following classes give you access to parameters of the Microsoft® DirectX® Media Objects (DMOs) supplied with DirectX.

  • ChorusEffect class
  • CompressorEffect class
  • DistortionEffect class
  • EchoEffect class
  • FlangerEffect class
  • GargleEffect class
  • Interactive3DLevel2ReverbEffect class
  • ParamEqEffect class
  • WavesReverbEffect class

To retrieve an effect object, use the SecondaryBuffer.GetEffects method. This method can retrieve a single object or an array of objects.

The following Microsoft Visual Basic® sample code retrieves an EchoEffect object representing the first effect set on a buffer, and sets two parameters on the effect. Assume that fxBuffer is a SecondaryBuffer object.
[Visual Basic .NET]
Dim echoFx As EchoEffect
Dim echoParams As EffectsEcho
echoFx = fxBuffer.GetEffects(0)
echoParams = echoFx.AllParameters
echoParams.LeftDelay = 500
echoParams.RightDelay = 500
echoFx.AllParameters = echoParams

Effect parameters can be changed while the buffer is playing.

For efficiency, Microsoft DirectSound® preprocesses 100 milliseconds of sound data in a buffer, starting at the play cursor, before SecondaryBuffer.Play is called. This can happen after any of the following calls.

  • SecondaryBuffer.SetCurrentPosition
  • SecondaryBuffer.SetEffects
  • SecondaryBuffer.Stop
  • SecondaryBuffer.Write

If you call any of these methods and then change effect parameters, the new parameters will not be heard until the preprocessed data has been played. To avoid this situation, do one of the following:

  • Write data to the buffer after effect parameters have been changed, not before.
  • Call Stop or SetCurrentPosition on the buffer to force preprocessing after you have set the parameters.


Standard Effects

Note: This documentation is preliminary and is subject to change.

This topic is an introduction to the sound effects provided with Microsoft® DirectSound®.

The following effects are covered.

  • Chorus
  • Compression
  • Distortion
  • Echo
  • Environmental Reverberation
  • Flange
  • Gargle
  • Parametric Equalizer
  • Waves Reverberation

Chorus

Chorus is a voice-doubling effect created by echoing the original sound with a slight delay and slightly modulating the delay of the echo.

This effect is represented by the ChorusEffect class. Its parameters are contained in the EffectsChorus structure.

Compression

Compression is a reduction in the fluctuation of a signal above a certain amplitude.

This effect is represented by the CompressorEffect class. Its parameters are contained in the EffectsCompressor structure.

Distortion

Distortion is achieved by adding harmonics to the signal in such a way that, as the level increases, the top of the waveform becomes squared off or clipped.

This effect is represented by the DistortionEffect class. Its parameters are contained in the EffectsDistortion structure.

Echo

An echo effect causes sounds to be repeated after a fixed delay, usually at a diminished volume. As the repeated sounds are fed back into the mix, they are repeated again.

This effect is represented by the EchoEffect class. Its parameters are contained in the EffectsEcho structure.

Environmental Reverberation

DirectX supports environmental reverberation in accordance with the Interactive 3-D Audio, Level 2 (I3DL2) specification, published by the Interactive Audio Special Interest Group.

The Microsoft DirectX® environmental reverb effect is an implementation of the listener properties in the I3DL2 specification. Source properties are not supported.

Sounds reaching the listener have three temporal components.

  • The direct path is the audio signal that goes straight from the sound source to the listener, without bouncing off any surface. There is therefore only one direct path signal.
  • Early reflections are the audio signals that reach the listener after one or two reflections off surfaces such as the walls, floor, and ceiling. If a signal is the result of the sound hitting only one wall on its way to the listener, it is called a first-order reflection. If it bounces off two walls before reaching the listener, it is called a second-order reflection. Humans can typically perceive individual reflections only of the first or second order.
  • Late reverberation, or simply reverb, consists of the combined lower-order reflections, usually a dense succession of echoes of diminishing intensity.

The combination of early reflections and late reverberation is sometimes called the room effect.

Reverb properties include the following:

  • Attenuation of the early reflections and late reverberation.
  • Rolloff factor, or the rate at which reflected signals become attenuated with distance. The rolloff factor for the direct path is managed by the DirectSound listener.
  • Reflections delay, which is the interval between the arrival of the direct-path signals and the arrival of the first early reflections.
  • Reverb delay, which is the interval between the first of the early reflections and the onset of late reverberation.
  • Decay time, which is the interval between the onset of late reverberation and the time when its intensity has been reduced by 60 decibels (dB).
  • Diffusion, which is proportional to the number of echoes per second in the late reverberation. Depending on the implementation, the density can change as the reverberation decays. In DirectX, the application can control this property by setting a percentage of the range allowed by the implementation.
  • Density, which is is proportional to the number of resonances per hertz in the late reverberation. Lower densities produce hollower sounds like those found in small rooms. In DirectX, the application can control this property by setting a percentage of the range allowed by the implementation.

Reverb properties are represented by an Interactive3DLevel2ReverbEffect class, and the parameters of the environment are contained in an EffectsInteractive3DLevel2Reverb structure.

DirectSound supports many sets of default parameters, or presets, that describe the reverb properties of audio environments ranging from mountains to sewer pipes. Most applications can simply choose one of these environments by using the Interactive3DLevel2ReverbEffect.Preset property.

To set and retrieve custom properties, use the Interactive3DLevel2ReverbEffect.AllParameters property.

Flange

Flange, also called flanger, is an echo effect in which the delay between the original signal and its echo is very short and varies over time. The result is sometimes referred to as a sweeping sound. The term flange originated with the practice of grabbing the flanges of a tape reel to change the speed.

This effect is represented by the FlangerEffect class. Its parameters are contained in the EffectsFlanger structure.

Gargle

The gargle effect modulates the amplitude of the signal.

This effect is represented by the GargleEffect class. Its parameters are contained in the EffectsGargle structure.

Parametric Equalizer

A parametric equalizer amplifies or attenuates signals of a given frequency.

Parametric equalizer effects for different pitches can be applied in parallel by setting multiple instances of the effect on the same buffer. In this way, the application can have tone control similar to that provided by a hardware equalizer.

This effect is represented by the ParamEqEffect class. Its parameters are contained in the EffectsParamEq structure.

Waves Reverberation

The Waves reverberation effect is intended for use with music. The Waves reverberation DirectX Media Object (DMO) is based on the Waves MaxxVerb technology, which is licensed to Microsoft.

This effect is represented by the WavesReverbEffect class. Its parameters are contained in the EffectsWavesReverb structure.


Capturing Waveforms

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectSound® enables you to capture sounds from a microphone or other input to the sound card, for immediate playback or storage in a file. Data can be captured in Pulse Code Modulation (PCM) or compressed formats.

The Capture object is used to query the capabilities of sound capture devices and to create buffers for capturing sound samples.

The CaptureBuffer object represents a buffer used for receiving data from the input device. This buffer is conceptually circular: When input reaches the end of the buffer, it automatically starts again at the beginning.

The methods of CaptureBuffer enable you to retrieve the properties of the buffer, start and stop audio capture, and retrieve data. On operating systems that support capture effects, it also provides methods for retrieving effect objects and ascertaining the status of effects.

More information about WAV capture is found in the following topics.

  • Enumeration of Capture Devices
  • Creating the Capture Object
  • Capture Device Capabilities
  • Creating a Capture Buffer
  • Capture Buffer Information
  • Capture Buffer Notification
  • Capture Buffer Effects
  • Using the Capture Buffer


Enumeration of Capture Devices

Note: This documentation is preliminary and is subject to change.

If you are looking for a particular kind of device, want to offer the user a choice of devices, or need to work with two or more devices, you must enumerate the devices available on the system. For an application that is just going to capture sounds through the user's preferred capture device, you don't need to enumerate the available devices. For more information, see Creating the Capture Object.

Enumeration serves three purposes.

  • Reports what hardware is available.
  • Supplies a globally unique identifier (GUID) for each device.
  • Enables you to create a temporary Capture object for each device as it is enumerated, so that you can check the capabilities of the device.

To enumerate devices, first create a capture device using CaptureDevicesCollection.


Creating the Capture Object

Note: This documentation is preliminary and is subject to change.

If your application will capture and record sounds, you will create and use a Capture object.

The following C# example shows how to initialize a Capture object for the default device.
[C#]
private Capture dsCapture = null;
dsCapture = new Capture();
The following C# example creates a device from a globally unique identifier (GUID), represented by the deviceGuid variable. This GUID can be obtained by enumeration of devices.
[C#]
dsCapture = new Capture(deviceGuid);

You can also use one of the following values to specify a default device.

Value | Description
DSoundHelper.DefaultCaptureDevice | The default system capture device. This is the same as the device created when no parameter is passed to the Capture constructor.
DSoundHelper.DefaultVoiceCaptureDevice | The default voice capture device. Typically this is a secondary device such as a USB headset with microphone.

The object cannot be created if there is no capture device or, under VxD virtual device drivers, if the sound device is under the control of an application using the standard Microsoft® Win32® waveform-audio functions.

If your application will capture sounds as well as play them, you should create both Device and Capture objects.

If you want the playback and capture objects to coexist, you should create and initialize the Device object before creating and initializing the Capture object.

Some audio devices are not configured for full duplex audio by default. If your application has problems with creating and initializing both a Device object and a Capture object, you should advise the user to check the audio device properties to ensure that full duplex is enabled.


Capture Device Capabilities

Note: This documentation is preliminary and is subject to change.

The capabilities of a capture device are described in the CaptureCaps structure, which contains the number of channels the device supports, as well as a combination of standard audio formats that are supported, equivalent to the values in the WAVEINCAPS structure used in the Microsoft® Win32® waveform audio functions.

On non-WDM (Microsoft Windows® Driver Model) drivers, a capture device can be used by only one application at a time. Each application can set its own format for the capture buffer by setting the properties in CaptureCaps.


Creating a Capture Buffer

Note: This documentation is preliminary and is subject to change.

Create a capture buffer for storing sound data by creating a CaptureBuffer object.

The capture buffer can be specified directly using the CaptureBuffer(IntPtr,Capture) constructor, or a new capture buffer can be created with the CaptureBuffer(CaptureBufferDescription,Capture) constructor, which takes a CaptureBufferDescription structure that specifies the characteristics of the desired buffer. The Format member of this structure is a WaveFormat structure, which must be initialized with the details of the desired WAV format.

Note that if your application is using Microsoft® DirectSound® playback as well as DirectSound capture, capture buffer creation can fail when the format of the capture buffer is not the same as that of the primary buffer. The reason is that some cards have only a single clock and cannot support capture and playback at two different frequencies.


Capture Buffer Information

Note: This documentation is preliminary and is subject to change.

Properties of a capture buffer are obtained from the CaptureBuffer.Caps property.

The CaptureBufferCaps structure describes the size of the buffer, whether it supports effects, and whether it supports the format specified when it was created or must use the Microsoft® Win32® wave mapper.

To retrieve information about the format of the data in the buffer, as set when the buffer was created, use the CaptureBuffer.Format property.

To find out what a capture buffer is currently doing, check the CaptureBuffer properties. The Capturing property is set if the buffer is capturing. Looping is set if Looping was set in the last call to the CaptureBuffer.Start method, as will usually be the case.

The CaptureBuffer.GetCurrentPosition method returns the offsets of the read and capture cursors within the buffer. The read cursor is at the end of the data that has been fully captured into the buffer at this point. The capture cursor is at the end of the block of data that is currently being copied into the buffer. You cannot safely retrieve data between the read cursor and the capture cursor.


Capture Buffer Notification

Note: This documentation is preliminary and is subject to change.

When capturing audio, you might want your application to be notified when the read cursor reaches a certain point in the buffer, or when the buffer is stopped. By using the Notify.SetNotificationPositions method, you can set any number of points within the buffer where events are to be signaled. You cannot do this while the buffer is capturing.

To set up notifications, do the following.

  1. Create an AutoResetEvent Leave Site for each notification position.
  2. Obtain the Notify object by passing the CaptureBuffer object to the Notify constructor.
  3. Create an array of BufferPositionNotify structures, one for each notification position. Set the Offset member to the byte offset where you want to be notified. Set the EventNotifyHandle member to the AutoResetEvent Leave Site.Handle Leave Site of one of the events you created in step 1.
  4. Call Notify.SetNotificationPositions, passing in the array of BufferPositionNotify structures.

You can now start the buffer in a separate thread and use WaitHandle Leave Site.WaitAny Leave Site to wait for notifications.


Capture Buffer Effects

Note: This documentation is preliminary and is subject to change.

Two capture buffer effects are available as kernel mode implementations on Microsoft® Windows® XP Home Edition and Windows XP Professional and later operating systems.

  • Acoustic echo cancellation (AEC)
  • Noise suppression
These effects can be used only in conjunction with a FullDuplex object.

The CaptureBuffer constructor takes either a predefined buffer location in memory or a CaptureBufferDescription structure that contains a CaptureEffectDescription structure that describes desired effects.

For each CaptureEffectDescription structure, you must specify either the LocateInHardware property or the LocateInSoftware property. In most cases, specify LocateInSoftware. Buffer creation fails if the effect is not available in the specified location.

The effect is identified in the CaptureEffectDescription.GuidEffectsClass property. To obtain the Microsoft software implementation, specify DSoundHelper.CaptureEffectsMsAcousticEchoCancellation or DSoundHelper.CaptureEffectsMsNoiseSuppression. To use another implementation available in hardware or software, obtain the class and instance globally unique identifier (GUID) from the manufacturer.

After the buffer has been created, you can retrieve information about the effects by using the CaptureBuffer.GetEffectsStatus method.

AEC is primarily of interest for applications that use voice communication from one site to another. Without echo cancellation, the signal from a microphone at site A is output from the speakers at site B, picked up by the microphone at site B, and rebroadcast at site A, possibly resulting in a feedback loop. AEC overcomes this problem by monitoring the incoming signal, adjusting it to take the room environment into account, and then removing it from the outgoing signal.

AEC has the following limitations.

  • If the acoustic environment changes, the adaptive filter can take two seconds or more to adjust.
  • Any late reverberations occurring more than 128 milliseconds after the original signal are not removed from the outgoing signal.
  • Only one capture buffer at a time can use AEC.
  • AEC cannot be created if another application is capturing.

The effect objects are obtained from the capture buffer object by using CaptureBuffer.GetObjectInPath.

Use the CaptureAcousticEchoCancellationEffect object to set and retrieve AEC parameters on a capture buffer that contains the AEC effect. You can also enable noise fill, which is a means of preventing complete silence when there is no new data in the outgoing signal.

Noise suppression can be applied only if AEC is also enabled. The noise suppression capture effect removes constant background noise, such as fan noise. Use the CaptureNoiseSuppressEffect object to set and retrieve parameters.


Using the Capture Buffer

Note: This documentation is preliminary and is subject to change.

Once you have created a CaptureBuffer object, you will need to control the process of reading and recording sound data. Capturing a sound consists of these steps.

  1. Start the buffer by calling CaptureBuffer.Start(true), which sets the capture buffer to a looping mode.
  2. Wait until the desired amount of data is available. For one method of determining when the capture cursor reaches a certain point, see Capture Buffer Notification. Alternatively, you can poll the read cursor by using CaptureBuffer.GetCurrentPosition.
  3. When sufficient data is available, read data from the buffer by calling CaptureBuffer.Read.
  4. Repeat steps 2 and 3 until you are ready to stop capturing data. Then call CaptureBuffer.Stop.


Optimizing Performance

Note: This documentation is preliminary and is subject to change.

This section offers some miscellaneous tips for improving the performance of applications that play their audio data directly into Microsoft® DirectSound® buffers.

The following topics are covered.

  • Matching Buffer Formats
  • Using Hardware Mixing
  • Dynamic Voice Management
  • Hardware Acceleration on ISA and PCI Cards
  • Minimizing Control Changes
  • CPU Considerations for 3-D Buffers
  • DirectSound Driver Models


Matching Buffer Formats

Note: This documentation is preliminary and is subject to change.

The Microsoft® DirectSound® mixer converts the data from each secondary sound buffer into the format of the primary buffer. This conversion is done on the fly as data is mixed into the primary buffer, and costs CPU cycles. You can eliminate this overhead by ensuring that your secondary buffers and primary buffer have the same format. Normally, this means setting the primary buffer format to the format of the WAV files used for data.

Because of the way DirectSound does format conversion, you only need to match the sample rate and number of channels. It does not matter if there is a difference in sample size (8-bit or 16-bit).


Using Hardware Mixing

Note: This documentation is preliminary and is subject to change.

Most sound cards support some level of hardware mixing if there is a Microsoft® DirectSound® driver for the card.

The following tips will enable you to make the most of hardware mixing.

  • At run time, use the Device.Caps property to determine what formats are supported by the sound-accelerator hardware, and use only those formats if possible.
  • Create sound buffers first for the sounds you use the most. There is a limit to the number of buffers that can be mixed by hardware.
  • To force a buffer to be created in hardware, set the BufferDescription.LocateInHardware property. If you do this and resources for hardware mixing are not available, buffer creation will fail.
  • Use voice management to enable DirectSound to assign buffers to hardware resources when they are available, and to force termination of less important buffers in order to free hardware resources. See Dynamic Voice Management.


Dynamic Voice Management

Note: This documentation is preliminary and is subject to change.

A number of options are available for handling multiple voices in hardware or software devices. Many sound cards maintain their own secondary buffers and handle 3-D effects and mixing for them. These hardware buffers, as they are called, usually reside in system memory rather than on the card itself, but because they are mixed by the device, they make far smaller demands on the system processor than do software buffers. It is therefore most efficient to have as many buffers as possible allocated to hardware, especially 3-D buffers.

By default, Microsoft® DirectSound® allocates buffers to hardware whenever it can. However, it can create only as many hardware buffers as the device can play at one time. The number of hardware buffers is therefore limited by the hardware voices available. DirectSound allocates a hardware voice when a buffer is created and releases it only when the buffer is destroyed; the voice is not free even when the buffer is not playing. If an application creates many buffers, chances are that some of them will end up being in software that is, they will be managed and mixed by the CPU rather than the sound card.

To defer the allocation of resources for hardware mixing and 3-D effects to the moment when the buffer is played, set the DeferLocation property in the BufferDescription object passed to the Buffer(BufferDescription,Device) buffer creation method. When you call SecondaryBuffer.Play or SecondaryBuffer.AcquireResources on the buffer, DirectSound places the buffer in hardware if possible, and in software otherwise.

When calling Play, you can attempt to free a hardware voice for the buffer by passing one of the following BufferPlayFlags, or one of the first two flags in combination with the third. DirectSound then searches for a playing buffer that is suitable for termination as specified by the flags.

Flag | Action
TerminateByTime | Select the buffer that has been playing longer than any other candidate buffers.
TerminateByDistance | Select the 3-D candidate buffer farthest from the listener.
TerminateByPriority | Select the buffer that has the lowest priority of candidate buffers, as set in the call to Play. If this is combined with one of the other two flags, the other flag is used only to resolve ties.

If it finds a suitable buffer, DirectSound stops it and allocates the voice it was using to the newly played buffer. If no buffer is suitable for termination, the newly played buffer is played in software, unless the LocateInHardware flag was specified, in which case the call to Play fails.

For more information on how deferred buffers are dealt with when played, see Buffer.Play.

Note: Do not use the StaticBuffer property in combination with DeferLocation when creating buffers. When StaticBuffer is specified, buffers are placed in on-card memory when this is available, as is the case for some Peripheral Component Interconnect (PCI) cards. If you create such a buffer with the DeferLocation property, the buffer memory is not copied to the sound card until the buffer is played for the first time, which can result in unacceptable delays. For more information, see Hardware Acceleration on ISA and PCI Cards.


Hardware Acceleration on ISA and PCI Cards

Note: This documentation is preliminary and is subject to change.

In the past few years, sound cards have moved from the Industry Standard Architecture (ISA) bus to the Peripheral Component Interconnect (PCI) bus. This design change has fundamentally altered the way Microsoft® DirectSound®-accelerated cards handle audio data. In addition, DirectSound has introduced voice management, which enables applications to make more efficient use of limited hardware acceleration resources.

This section discusses some considerations in allocating buffers and using voice management on the two kinds of sound cards. The following topics are discussed.

  • DirectSound Buffers on ISA Cards
  • DirectSound Buffers on PCI Cards
  • Voice Management on ISA and PCI Cards

DirectSound Buffers on ISA Cards

When DirectSound was first introduced, all audio devices operated on the ISA bus. The ISA bus was sufficient to stream 16-bit, 22-kHz stereo data from the CPU to the sound card without unduly affecting overall system performance, but attempting to send more data often placed an undue burden on the bus. This limitation had a strong influence on audio hardware design.

To mix DirectSound buffers, a chip on the sound card has two choices: it can reach across the ISA bus into system memory, or it can have dedicated memory on the card itself. Owing to the ISA bus's limited bandwidth, reading audio data from system memory is not practical. Therefore, ISA-based sound cards that do DirectSound acceleration almost always have dedicated on-card RAM.

When such a sound card is used to accelerate DirectSound, the sound data must first be copied from system memory, across the ISA bus, and into the dedicated memory on the card. This copying can take some time. However, once the data is on the card, there is almost no cost to the system for starting, stopping, and mixing sounds; all that work is handled by the audio processor chip accessing its own dedicated memory.

ISA-based DirectSound accelerators support static buffers on the card, but not streaming buffers, because it is impractical to stream data across the slow ISA bus. DirectSound buffers created with the BufferDescription.StaticBuffer property are located in card memory if it is available. Others are created in system memory.

DirectSound Buffers on PCI Cards

Modern audio cards are designed to connect to the PCI bus. With the movement to this bus comes a large increase in the available bandwidth between the system and the audio card. It is now practical to have the audio chip reach directly into system memory to retrieve audio data for hardware mixing. As a result, it is no longer worthwhile to have on-board memory for buffers.

On PCI cards, static buffers and streaming buffers are effectively the same. The BufferDescription.StaticBuffer property does not affect the location of the buffer, because all buffers are located in system memory.

Note: Most sound cards report in the Device.Caps property that they have static buffers, even though they have no on-card RAM. The streaming and static buffers reported by these cards are often the same buffers.

Voice Management on ISA and PCI Cards

By using the BufferDescription.DeferLocation when creating a buffer, you can defer the allocation of buffers to hardware-mixed or software-mixed memory until the moment when they are played. For information, see Dynamic Voice Management.

The effect of deferred allocation on application performance depends on the type of DirectSound accelerator in the user's system.

Consider the case of a PCI accelerator. When a deferred buffer is played, DirectSound first determines if there is hardware available to play the sound. Assuming that there is, DirectSound then ensures that the hardware has access to the sound data, which remains where it is. Finally, DirectSound tells the hardware to start playing. This process is both efficient and fast.

Note: The DirectSound voice manager allocates hardware mixing resources, not memory. On a PCI card, the buffer occupies the same memory before and after it is allocated, regardless of whether it is allocated to the hardware mixer or the software mixer.

If the user has an ISA-based accelerator, the situation is quite different. In this case, the act of getting audio data to a hardware-mixed buffer is very slow, because the data needs to cross the ISA bus and be loaded into memory on the sound card before it can be mixed. For deferred buffers, this can introduce an unacceptable delay between when the play call is made and when the sound starts. For this reason, using voice management is not recommended on ISA-based DirectSound accelerator cards.

It is easy to prevent your application from using voice management on ISA devices. A buffer will not be assigned to on-card memory unless the BufferDescription.StaticBuffer property is set. Therefore, as long as you do not combine StaticBuffer and DeferLocation, there is no danger that buffers will be assigned to on-card memory at play time.

Using StaticBuffer by itself ensures that the buffer will take advantage of any existing memory on an ISA card, but it has no effect on a PCI card. In the absence of other properties, DirectSound will attempt to place the buffer under hardware control but still in system memory. Using DeferLocation by itself has no effect on an ISA card, since the buffer is always placed in system memory and is not managed by the hardware.

The following table summarizes the effects of the StaticBuffer and DeferLocation properties on buffers created for ISA and PCI devices.

Card | BufferDescription property | Memory | Hardware acceleration
ISA | StaticBuffer | Hardware if available. | Yes, if in hardware memory.
PCI | StaticBuffer | System. | Yes, if hardware voice available; property setting has no effect.
ISA | DeferLocation | Hardware if available, if BufferCaps.StaticBuffer set. | Yes, if in hardware memory, but latency on first play.
PCI | DeferLocation | System. | Yes, if hardware voice available.

To take advantage of acceleration on ISA cards without running into the dangers presented by deferred allocation, first check the capabilities of the device. If the card reports more than zero static buffers and no streaming buffers, it is probably an older ISA card with on-card memory. You can then use the StaticBuffer property, but do not use DeferLocation. If the card reports more than zero streaming buffers, it is probably a newer PCI-based accelerator card. In this case, you'll want to use DeferLocation, and not StaticBuffer, to make maximum use of the hardware voices.


Minimizing Control Changes

Note: This documentation is preliminary and is subject to change.

Performance is affected when you change the pan, volume, or frequency on a secondary buffer. To prevent interruptions in sound output, the Microsoft® DirectSound® mixer must mix ahead from 20 to 100 or more milliseconds. Whenever you make a control change, the mixer has to flush its mix-ahead buffer and remix with the changed sound.

It is a good idea to minimize the number of control changes you send. Try reducing the frequency of calls to routines that use SecondaryBuffer.Volume, .Pan, and .Frequency. For example, if you have a routine that moves a sound from the left to the right speaker in synchronization with animation frames, try setting Pan only every second or third frame.

Note: 3-D control changes (orientation, position, velocity, Doppler factor, and so on) also cause DirectSound to remix its mix-ahead buffer. However, you can group a number of 3-D control changes together and cause only a single remix. See 3-D Listeners.


CPU Considerations for 3-D Buffers

Note: This documentation is preliminary and is subject to change.

Software-emulated 3-D buffers are computationally time consuming. You should take this into consideration when deciding when and how to use 3-D buffers in your applications.

Use as few 3-D sounds as you can, and do not use 3-D on sounds that will not really benefit from the effect. Design your application so that it is easy to enable and disable 3-D effects on each sound. You can set the Buffer3D.Mode property to Mode3D.Disable to disable 3-D processing on any 3-D sound buffer.

You can also ensure that 3-D processing is suspended on buffers that are too far away from the listener to be heard. See Minimum and Maximum Distances.


DirectSound Driver Models

Note: This documentation is preliminary and is subject to change.

Under the virtual device driver (VxD) model, all Microsoft® DirectSound® mixing is done in Dsound.vxd, a virtual device driver. Dsound.vxd also provides close access to the actual direct memory access (DMA) buffer that the sound card uses to receive data from the host CPU. This is the same as the DirectSound primary buffer. A DirectSound application can set specific properties of the primary buffer, such as sampling rate and bit depth, thus changing the properties of the hardware itself.

Under the Microsoft Windows® Driver Model (WDM), DirectSound does not have direct access to the sound hardware, except in the case of hardware-accelerated buffers. Instead, DirectSound works with the kernel mixer, or Kmixer. The job of Kmixer is to convert the format of multiple audio streams to a common format, mix them together and send the result to the hardware. In a sense, it does what Dsound.vxd does. One major difference is that Dsound.vxd only mixes DirectSound buffer data, but Kmixer mixes all Windows audio data, including data from applications that use the Microsoft Win32®waveOut functions. The rule that DirectSound and the waveform-audio output device cannot both be open at the same time is not true on systems with WDM drivers.

Of particular importance is Kmixer's relationship with the audio hardware. Kmixer is the only software on the system that can specify the format of the hardware's DMA buffer. It selects the format on the basis of sounds it is asked to mix. It sets the output format to the highest-quality format of sounds that it is asked to mix, or to the closest format to this that the hardware supports.

This has one very important implication: DirectSound cannot set the format of the hardware's DMA buffer. For your application, this means that the hardware format is based on the data you actually play. If you play a 44-kHz file, Kmixer will mix all data up to 44 kHz and ensure that the hardware is running at 44 kHz.

As an application developer, you do not choose the driver model used. That is completely determined by the type of sound card, the version of Windows, and the particular driver the user has installed. For that reason, it is very important that you cover all possibilities when you test your application. DirectSound might be using Dsound.vxd or it might be using Kmixer, and you should ensure that your application's behavior and performance are acceptable on both.


Audio Video Playback

Note: This documentation is preliminary and is subject to change.

The AudioVideoPlayback application programming interface (API) provides for basic playback and simple control of audio and video files. For more information, see the Microsoft.DirectX.AudioVideoPlayback managed code reference documentation.

Use the Video class to play video files, including those that contain audio. Use the Audio class to play audio-only files. You can also use the Audio class to control the audio properties when you play a video file. The SeekPositionFlags enumeration controls seek operations, and the StateFlags enumeration has flags to denote whether the media file is running, paused, or stopped.

Note: The Audio class is primarily designed for very simple playback scenarios, or for use with the Video class. You can also use Microsoft® DirectSound® to play audio files, which gives you much greater control over the audio playback.

  • Playing a Video File
  • Playing an Audio File

Playing a Video File

To play a video file, start by creating an instance of the Video class. You can specify the file name in the Video constructor as in the following C# code example, or else call the Open method with the file name.

[C#]
using Microsoft.DirectX.AudioVideoPlayback;
public class MyVideoPlayer : System.Windows.Forms.Form
{
    /* ... */
    private void OpenFile()
    {
        try
        {
            Video ourVideo = new Video("C:\\Example.avi");
            /* ... */
        }
    }
    /* ... */
}

The Video object throws an exception if you try to open a file that contains no video. Next, specify a parent window in your application to hold the Video object's video window, as follows:

[C#]
ourVideo.Owner = this;  // 'this' refers to the application's Form object.

Control playback by calling the Play, Pause, and Stop methods. For example, the following event handler stops playback.

[C#]
private void mnuStop_Click(object sender, System.EventArgs e)
{
    if (ourVideo != null)
    {
        ourVideo.Stop();
        }
}

To set the size of the playback window, set the Size property, which takes a System.Drawing.Size Leave Site object, as follows:

[C#]
ourVideo.Size = new Size(480, 320);

You can get the native video size by examining the DefaultSize property. If the video file contains audio, the Video.Audio property returns an Audio object. You can use this object to set the volume or the stereo balance for the audio. If the file does not contain audio, setting these properties causes an exception. Use a try block around the code, as follows:

[C#]
try
{
    Video.Audio.Volume = 100;
}

Playing an Audio File

The Audio object is similar to the Video object, but it supports properties that relate to audio, such as Volume and Balance. To play an audio file, specify the file name in the Audio constructor, as in the following C# code example, or call the Open method with the file name.

[C#]
Audio ourAudio = new Audio("C:\MyAudioFile.wav");


Audio and Video Playback Error Codes

Note: This documentation is preliminary and is subject to change.

Below is a list of possible error codes that can occur in Microsoft.DirectX.AudioVideoPlayback.

Audio Video Playback Error Code Table

ErrorCode | ErrorString | Description
-2147220992 | VFW_E_INVALIDMEDIATYPE | The specified media type is invalid.
-2147220991 | VFW_E_INVALIDSUBTYPE | The specified media subtype is invalid.
-2147220990 | VFW_E_NEED_OWNER | This object can only be created as an aggregated object.
-2147220989 | VFW_E_ENUM_OUT_OF_SYNC | The state of the enumerated object has changed and is now inconsistent with the state of the enumerator. Discard any data obtained from previous calls to the enumerator and then update the enumerator by calling the enumerator's Reset method.
-2147220988 | VFW_E_ALREADY_CONNECTED | At least one of the pins involved in the operation is already connected.
-2147220987 | VFW_E_FILTER_ACTIVE | This operation cannot be performed because the filter is active.
-2147220986 | VFW_E_NO_TYPES | One of the specified pins supports no media types.
-2147220985 | VFW_E_NO_ACCEPTABLE_TYPES | There is no common media type between these pins.
-2147220984 | VFW_E_INVALID_DIRECTION | Two pins of the same direction cannot be connected.
-2147220983 | VFW_E_NOT_CONNECTED | The operation cannot be performed because the pins are not connected.
-2147220982 | VFW_E_NO_ALLOCATOR | No sample buffer allocator is available.
-2147220981 | VFW_E_RUNTIME_ERROR | A run-time error occurred.
-2147220980 | VFW_E_BUFFER_NOTSET | No buffer space has been set.
-2147220979 | VFW_E_BUFFER_OVERFLOW | The buffer is not sufficiently large.
-2147220978 | VFW_E_BADALIGN | An invalid alignment was specified.
-2147220977 | VFW_E_ALREADY_COMMITTED | The allocator was not committed.
-2147220976 | VFW_E_BUFFERS_OUTSTANDING | One or more buffers are still active.
-2147220975 | VFW_E_NOT_COMMITTED | Cannot allocate a sample when the allocator is not active.
-2147220974 | VFW_E_SIZENOTSET | Cannot allocate memory because no size has been set.
-2147220973 | VFW_E_NO_CLOCK | Cannot lock for synchronization because no clock has been defined.
-2147220972 | VFW_E_NO_SINK | Quality messages could not be sent because no quality sink has been defined.
-2147220971 | VFW_E_NO_INTERFACE | A required interface has not been implemented.
-2147220970 | VFW_E_NOT_FOUND | An object or name was not found.
-2147220969 | VFW_E_CANNOT_CONNECT | No combination of intermediate filters could be found to make the connection.
-2147220968 | VFW_E_CANNOT_RENDER | No combination of filters could be found to render the stream.
-2147220967 | VFW_E_CHANGING_FORMAT | Could not change formats dynamically.
-2147220966 | VFW_E_NO_COLOR_KEY_SET | No color key has been set.
-2147220965 | VFW_E_NOT_OVERLAY_CONNECTION | Transport.
-2147220964 | VFW_E_NOT_SAMPLE_CONNECTION | Current pin connection is not using the correct transport.
-2147220963 | VFW_E_PALETTE_SET | Setting a color key would conflict with the palette already set.
-2147220962 | VFW_E_COLOR_KEY_SET | Setting a palette would conflict with the color key already set.
-2147220961 | VFW_E_NO_COLOR_KEY_FOUND | No matching color key is available.
-2147220960 | VFW_E_NO_PALETTE_AVAILABLE | No palette is available.
-2147220959 | VFW_E_NO_DISPLAY_PALETTE | Display does not use a palette.
-2147220958 | VFW_E_TOO_MANY_COLORS | Too many colors for the current display settings.
-2147220957 | VFW_E_STATE_CHANGED | The state changed while waiting to process the sample.
-2147220956 | VFW_E_NOT_STOPPED | The operation could not be performed because the filter is not stopped.
-2147220955 | VFW_E_NOT_PAUSED | The operation could not be performed because the filter is not paused.
-2147220954 | VFW_E_NOT_RUNNING | The operation could not be performed because the filter is not running.
-2147220953 | VFW_E_WRONG_STATE | The operation could not be performed because the filter is in the wrong state.
-2147220952 | VFW_E_START_TIME_AFTER_END | The sample start time is after the sample end time.
-2147220951 | VFW_E_INVALID_RECT | The supplied rectangle is invalid.
-2147220950 | VFW_E_TYPE_NOT_ACCEPTED | This pin cannot use the supplied media type.
-2147220949 | VFW_E_SAMPLE_REJECTED | This sample cannot be rendered.
-2147220948 | VFW_E_SAMPLE_REJECTED_EOS | This sample cannot be rendered because the end of the stream has been reached.
-2147220947 | VFW_E_DUPLICATE_NAME | An attempt to add a filter with a duplicate name failed.
-2147220946 | VFW_E_TIMEOUT | A time-out has expired.
-2147220945 | VFW_E_INVALID_FILE_FORMAT | The file format is invalid.
-2147220944 | VFW_E_ENUM_OUT_OF_RANGE | The list has already been exhausted.
-2147220943 | VFW_E_CIRCULAR_GRAPH | The filter graph is circular.
-2147220942 | VFW_E_NOT_ALLOWED_TO_SAVE | Updates are not allowed in this state.
-2147220941 | VFW_E_TIME_ALREADY_PASSED | An attempt was made to queue a command for a time in the past.
-2147220940 | VFW_E_ALREADY_CANCELLED | The queued command was already canceled.
-2147220939 | VFW_E_CORRUPT_GRAPH_FILE | Cannot render the file because it is corrupt.
-2147220938 | VFW_E_ADVISE_ALREADY_SET | Advise link already exists.
-2147220936 | VFW_E_NO_MODEX_AVAILABLE | No full-screen modes are available.
-2147220935 | VFW_E_NO_ADVISE_SET | This Advise cannot be canceled because it was not successfully set.
-2147220934 | VFW_E_NO_FULLSCREEN | Full-screen mode is not available.
-2147220933 | VFW_E_IN_FULLSCREEN_MODE | Window methods while in full-screen mode.
-2147220928 | VFW_E_UNKNOWN_FILE_TYPE | The media type of this file is not recognized.
-2147220927 | VFW_E_CANNOT_LOAD_SOURCE_FILTER | The source filter for this file could not be loaded.
-2147220925 | VFW_E_FILE_TOO_SHORT | A file appeared to be incomplete.
-2147220924 | VFW_E_INVALID_FILE_VERSION | The file's version number is invalid.
-2147220921 | VFW_E_INVALID_CLSID | This file is corrupt: it contains an invalid class identifier.
-2147220920 | VFW_E_INVALID_MEDIA_TYPE | This file is corrupt: it contains an invalid media type.
-2147220919 | VFW_E_SAMPLE_TIME_NOT_SET | No time stamp has been set for this sample.
-2147220911 | VFW_E_MEDIA_TIME_NOT_SET | No media time was set for this sample.
-2147220910 | VFW_E_NO_TIME_FORMAT_SET | No media time format was selected.
-2147220909 | VFW_E_MONO_AUDIO_HW | Cannot change balance because audio device is monaural only.
-2147220907 | VFW_E_NO_DECOMPRESSOR | Cannot play back the video stream: could not find a suitable decompressor.
-2147220906 | VFW_E_NO_AUDIO_HARDWARE | Cannot play back the audio stream: no audio hardware is available, or the hardware is not supported.
-2147220903 | VFW_E_RPZA | Cannot play back the video stream: format 'RPZA' is not supported.
-2147220901 | VFW_E_PROCESSOR_NOT_SUITABLE | Microsoft® DirectShow® cannot play MPEG movies on this processor.
-2147220900 | VFW_E_UNSUPPORTED_AUDIO | Cannot play back the audio stream: the audio format is not supported.
-2147220899 | VFW_E_UNSUPPORTED_VIDEO | Cannot play back the video stream: the video format is not supported.
-2147220898 | VFW_E_MPEG_NOT_CONSTRAINED | DirectShow cannot play this video stream because it falls outside the constrained standard.
-2147220897 | VFW_E_NOT_IN_GRAPH | Cannot perform the requested function on an object that is not in the filter graph.
-2147220895 | VFW_E_NO_TIME_FORMAT | Cannot access the time format on an object.
-2147220894 | VFW_E_READ_ONLY | Could not make the connection because the stream is read-only and the filter alters the data.
-2147220892 | VFW_E_BUFFER_UNDERFLOW | The buffer is not full enough.
-2147220891 | VFW_E_UNSUPPORTED_STREAM | Cannot play back the file: the format is not supported.
-2147220890 | VFW_E_NO_TRANSPORT | Pins cannot connect because they don't support the same transport.
-2147220887 | VFW_E_BAD_VIDEOCD | The Video CD can't be read correctly by the device or the data is corrupt.
-2147220880 | VFW_S_NO_STOP_TIME | The sample had a start time but not a stop time. In this case, the stop time that is returned is set to the start time plus one.
-2147220879 | VFW_E_OUT_OF_VIDEO_MEMORY | There is not enough video memory at this display resolution and number of colors. Reducing resolution might help.
-2147220878 | VFW_E_VP_NEGOTIATION_FAILED | The video port connection negotiation process has failed.
-2147220877 | VFW_E_DDRAW_CAPS_NOT_SUITABLE | Either Microsoft DirectDraw® has not been installed or the video card capabilities are not suitable. Make sure the display is not in 16-color mode.
-2147220876 | VFW_E_NO_VP_HARDWARE | No video port hardware is available, or the hardware is not responding.
-2147220875 | VFW_E_NO_CAPTURE_HARDWARE | No capture hardware is available, or the hardware is not responding.
-2147220874 | VFW_E_DVD_OPERATION_INHIBITED | This user operation is inhibited by digital video disc (DVD) content at this time.
-2147220873 | VFW_E_DVD_INVALIDDOMAIN | This operation is not permitted in the current domain.
-2147220872 | VFW_E_DVD_NO_BUTTON | Requested button is not available.
-2147220871 | VFW_E_DVD_GRAPHNOTREADY | DVD-Video playback graph has not been built yet.
-2147220870 | VFW_E_DVD_RENDERFAIL | DVD-Video playback graph building failed.
-2147220869 | VFW_E_DVD_DECNOTENOUGH | DVD-Video playback graph could not be built due to insufficient decoders.
-2147220853 | VFW_E_DVD_NOT_IN_KARAOKE_MODE | The DVD Navigator is not in karaoke mode.
-2147220850 | VFW_E_FRAME_STEP_UNSUPPORTED | Frame stepping is not supported.
-2147220845 | VFW_E_PIN_ALREADY_BLOCKED_ON_THIS_THREAD | Pin is already blocked on the calling thread.
-2147220844 | VFW_E_PIN_ALREADY_BLOCKED | Pin is already blocked on another thread.
-2147220843 | VFW_E_CERTIFICATION_FAILURE | Use of this filter is restricted by a software key. The application must unlock the filter.
-2147220842 | VFW_E_VMR_NOT_IN_MIXER_MODE | The Video Mixing Renderer (VMR) is not in mixing mode.
-2147220841 | VFW_E_VMR_NO_AP_SUPPLIED | The application has not yet provided the VMR filter with a valid allocator-presenter object.
-2147220840 | VFW_E_VMR_NO_DEINTERLACE_HW | The VMR could not find any deinterlacing hardware on the current display device.
-2147220839 | VFW_E_VMR_NO_PROCAMP_HW | The VMR could not find any hardware that supports ProcAmp controls on the current display device.
-2147220838 | VFW_E_DVD_VMR9_INCOMPATIBLEDEC | The hardware decoder uses video port extensions (VPE), which are not compatible with the VMR-9 filter.
-2147220494 | VFW_E_BAD_KEY | A registry entry is corrupt.


How Do I ...?

Note: This documentation is preliminary and is subject to change.

The documents in this section show you how to accomplish commonly encountered development tasks in Microsoft® DirectX®.

The following tables list tasks available for DirectX feature areas using C# code examples.

Handle a Device (Direct3D)

Check for Shader Support | This example shows how to check the hardware device for shader support.
Create an Additional Swap Chain | This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.
Maintain Floating Point Precision after Device Creation | When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.
Record and Apply StateBlocks | This example demonstrates how to use state blocks to set and retrieve a device's state.

Render a 3-D Scene (Direct3D)

Draw A Sprite | This example demonstrates how to draw a sprite.
Generate a Scene | This example shows how to begin scene generation and draw primitives.
Render Mesh with Texture using HLSL | This example demonstrates how to render a mesh texture using the high-level shader language (HLSL).
Set Up a Projection Matrix | This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.
Set Up a View Matrix | This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.
Using an Effect | This example demonstrates how to use an effect technique that was loaded from a file.

Use Meshes, Textures, and Effects (Direct3D)

Check For HDR Texture Support | This example demonstrates how to check a device to determine whether a specific texture format is supported.
Clean a Mesh | This example shows how to clean a mesh in preparation for simplification.
Clone a Mesh | This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.
Compute a Bounding Sphere from a Mesh | This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method.
Copy a Texture | This example demonstrates how to copy a texture.
Create a Cube Texture | This example demonstrates how to create a cube texture.
Create a Mesh Object | This example shows how to create a Mesh object.
Save a Screenshot | This example demonstrates how to save a screen shot to a file.
Simplify a Mesh | This example demonstrates how to simplify a mesh.

Use Vertex and Index Buffers (Direct3D)

Create a Vertex Declaration | This example demonstrates how to create a vertex declaration.
Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams | This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.
Read and Write VertexBuffer Data With Arrays | This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

Use Effects on Sound (DirectSound)

Add Effects to a SecondaryBuffer Object | This C# example demonstrates how to add effect objects to a SecondaryBuffer object.
Use Effect Parameters | This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.


Check for Shader Support

Note: This documentation is preliminary and is subject to change.

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Microsoft® Direct3D® allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

          [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


Create an Additional Swap Chain

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft® DirectX® 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


Maintain Floating Point Precision after Device Creation

Note: This documentation is preliminary and is subject to change.

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);


Record and Apply StateBlocks

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to use state blocks to set and retrieve a device's state.

A StateBlock instance can be used to return a device to a default state. It also can be stored as a member of a class to quickly restore a desired rendering state for that class. A StateBlock is most useful when used to save default device state once a device is created. This allows for rapid restoration of default state when needed during rendering.

To record and apply a state block:

  1. Call Device.BeginStateBlock to begin recording device state.
  2. Tell the device the states and values to record.
  3. Call Device.EndStateBlock to stop recording device state and return a StateBlock instance containing the recorded states.
  4. Capture the device's current state by calling StateBlock.Capture using the previously obtained StateBlock instance.
  5. Do some processing that changes device state.
  6. Restore the device's saved states by calling StateBlock.Apply.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

// begin recording device state
device.BeginStateBlock();

// tell device the states and values to record
device.RenderState.FogStart = 0.3f;
device.RenderState.FogEnd = 100.0f;
device.RenderState.FogColor = Color.Gray;

// stop recording device state
StateBlock sb = device.EndStateBlock();

// save device states recorded above
sb.Capture;

// change device states
device.RenderState.FogStart = 2000.0f;
device.RenderState.FogEnd = 35000.0f;
device.RenderState.FogColor = Color.Yellow;

// render scene w/changed states
device.DrawPrimitives();

// restore device's saved states
sb.Apply();

// render scene w/saved states
device.DrawPrimitives();


Draw A Sprite

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, device is assumed to be the rendering Device. The texture variable is a loaded Texture object.

          [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();


Generate a Scene

Note: This documentation is preliminary and is subject to change.

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

          [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();


Render Mesh with Texture using HLSL

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to render a mesh texture using the high-level shader language (HLSL).

In the following C# code example, the following assumptions are made:

  1. effect is a valid HLSL Effect with its technique set.
  2. The code occurs between calls to Effect.BeginPass and Effect.EndPass.
  3. mesh is a valid Mesh.
  4. meshTextures is a valid array of textures for the mesh.

          [C#]

effect.SetValue("WorldViewProjection", worldMatrix);

// Iterate through each subset and render with its texture
for (int m = 0; m < meshTextures.Length; ++m)
{
    effect.SetValue("SceneTexture", meshTextures[m]));
    effect.CommitChanges();
    mesh.DrawSubset(m);
}


Set Up a Projection Matrix

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

          [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );


Set Up a View Matrix

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

          [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));


Using an Effect

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}


Check For HDR Texture Support

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

          [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Clean a Mesh

Note: This documentation is preliminary and is subject to change.

This example shows how to clean a mesh in preparation for simplification.

In the following C# procedure, the Mesh.Clean method cleans the mesh by adding another vertex where two fans of triangles originally shared the same vertex. This vertex splitting results in two new triangles being added to the polygon on either side of the line segment connecting the two new vertices.

          [C#]

GraphicsStream adj = null;

// Load the mesh from the specified file
Mesh pMesh = Mesh.FromFile("tiger.x", MeshFlags.Managed, device, out adj);

// perform simple cleaning operation on the mesh
Mesh pTempMesh = Mesh.Clean(CleanType.Optimization, pMesh, adj, adj);
pMesh.Dispose();
pMesh = pTempMesh;


Clone a Mesh

Note: This documentation is preliminary and is subject to change.

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

          [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}


Compute a Bounding Sphere from a Mesh

Note: This documentation is preliminary and is subject to change.

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

          [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Copy a Texture

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

          [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


Create a Cube Texture

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

          [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


Create a Mesh Object

Note: This documentation is preliminary and is subject to change.

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Save a Screenshot

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

          [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


Simplify a Mesh

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

          [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

Related Topics

  • Clean a Mesh


Create a Vertex Declaration

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);


Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Related Topics

  • Read and Write VertexBuffer Data With Arrays


Read and Write VertexBuffer Data With Arrays

Note: This documentation is preliminary and is subject to change.

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft® Direct3D® resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Related Topics

  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams


Add Effects to a SecondaryBuffer Object

Note: This documentation is preliminary and is subject to change.

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

          [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Related Topics

  • Use Effect Parameters


Use Effect Parameters

Note: This documentation is preliminary and is subject to change.

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

          [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Related Topics

  • Add Effects to a SecondaryBuffer Object


References

Note: This documentation is preliminary and is subject to change.

The following table lists the namespaces available in Microsoft® DirectX®.

Microsoft.DirectX | This namespace provides utility operations and data storage for DirectX application programming, including exception handling, simple helper methods, and structures used for matrix, clipping plane, quaternion, and vector manipulation.
Microsoft.DirectX.AudioVideoPlayback | The AudioVideoPlayback application programming interface (API) provides for basic playback and simple control of audio and video files.
Microsoft.DirectX.Diagnostics | The DirectX Diagnostics application programming interface (API) enables you to programmatically query the information gathered by the DirectX Diagnostics Tool (DxDiag).
Microsoft.DirectX.Direct3D | Microsoft Direct3D® is a low-level graphics API that enables you to manipulate visual models of 3-D objects and take advantage of hardware acceleration.
Microsoft.DirectX.DirectDraw
Warning: Microsoft DirectDraw® has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw enables you to directly manipulate display memory, the hardware blitter, hardware overlay support, and flipping surface support.
Microsoft.DirectX.DirectInput | Microsoft DirectInput® is used to process data from a keyboard, mouse, joystick, or other game controller.
Microsoft.DirectX.DirectPlay
Warning: DirectPlay has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay enables you to write network applications such as multiplayer games.
Microsoft.DirectX.DirectPlay.Lobby
Warning: Microsoft DirectPlay® Lobby has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Lobby enables a DirectX application to interact with an application hosted on a remote server.
Microsoft.DirectX.DirectPlay.Voice
Warning: DirectPlay Voice has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Voice provides media-independent network transport and client management, but it does not duplicate DirectPlay session control features.
Microsoft.DirectX.DirectSound | Microsoft DirectSound® provides a system to capture sounds from input devices and play sounds through various playback devices using advanced 3-D positioning effects, and filters for echo, distortion, reverberation, and other effects.
Microsoft.DirectX.PrivateImplementationDetails | The PrivateImplementationDetails namespace contains structures and interfaces that allow the managed API to have access to the unmanaged portions of the DirectX API. These structures and interfaces are not intended to be used directly from your code.
Microsoft.DirectX.Security | Controls permissions related to Direct3D, DirectInput, DirectPlay, and DirectSound.
Microsoft.DirectX.Security.Permissions | Allows security actions to be applied to code using declarative security.


Microsoft.DirectX.AudioVideoPlayback

Note: This documentation is preliminary and is subject to change.

The AudioVideoPlayback application programming interface (API) provides for basic playback and simple control of audio and video files. The following tables list the members exposed by the Microsoft.DirectX.AudioVideoPlayback namespace.

Classes

Audio | The Audio class is primarily designed for very simple playback scenarios, or for use with the Video class.
TextureRenderEventArgs | Contains properties for retrieving arguments from a called Video.TextureReadyToRender event.
Video | Contains the properties and methods to play video files, including those that contain audio.

Enumerations

SeekPositionFlags | Contains constants for specifiying the type of seek for the Audio or Video objects.
StateFlags | Contains constants for specifiying the state of the Audio or Video objects.

Structures

SeekingCaps Collection of properties that describe the capabilities of a media stream.

Delegates

TextureRenderEventHandler Represents the method that handles the Video.TextureReadyToRender event.


Microsoft.DirectX.AudioVideoPlayback.Audio

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio Class

Language:
Note: This documentation is preliminary and is subject to change.

The Audio class is primarily designed for very simple playback scenarios, or for use with the Video class.

Definition

Visual Basic .NET NotInheritable Public Class Audio
Inherits Object
Implements IDisposable
C# public sealed class Audio : Object,
IDisposable
Managed C++ public __gc __sealed class Audio : public Object,
IDisposable
JScript .NET public class Audio extends Object
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.
Ending | Occurs when the playback is ending.
Pausing | Occurs when the playback is pausing.
Starting | Occurs when the playback is starting.
Stopping | Occurs when the playback is stopping.

Methods

Method | Description
Audio | Initializes a new instance of the object and opens an audio file for playback.
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FromFile | Creates an Audio object from a file.
static (Shared in Visual Basic .NET) FromUrl | Creates an Audio object from a Uri Leave Site object.
Open | Loads a new file into the Audio object.
Pause | Pauses playback.
Play | Starts playback.
raise_Disposing | Raises the Audio.Disposing event when called from within a derived class.
raise_Ending | Raises the Audio.Ending event when called from within a derived class.
raise_Pausing | Raises the Audio.Pausing event when called from within a derived class.
raise_Starting | Raises the Audio.Starting event when called from within a derived class.
raise_Stopping | Raises the Audio.Stopping event when called from within a derived class.
SeekCurrentPosition | Seeks to a specific playback position.
SeekStopPosition | Sets a new stop position in playback.
Stop | Stops playback.
StopWhenReady | Stops playback when the Audio object is ready.

Properties

Property | Description
Balance | Retrieves and sets the playback position in the stereo field.
CurrentPosition | Retrieves and sets the current position of playback.
Disposed | Retrieves a value that is true if the object is disposed; otherwise the value is false.
Duration | Retrieves the length, in seconds, of the audio file.
Paused | Retrieves the current playback state, whether playback is currently paused.
Playing | Retrieves the current playback state, whether playback is currently playing.
SeekingCaps | Retrieves the seeking capabilities of playback.
State | Retrieves the current state of playback.
Stopped | Retrieves the current playback state, whether playback is currently stopped.
StopPosition | Retrieves the position where playback stopped.
Volume | Retrieves and sets the amount to attenuate the volume of audio playback.

Inheritance Hierarchy

Object Leave Site
Audio

Class Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Audio.Audio

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Audio Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object and opens an audio file for playback.

Overload List

public Audio(string);
public Audio(string, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Audio(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Audio Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object and opens an audio file for playback, but does not start playback.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String _
)
C# public Audio(
string fileName
);
Managed C++ public: Audio(
String *fileName
);
JScript .NET public function Audio(
fileName : String
);

Parameters

fileName System.String. Specifies the name of the file.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Audio(String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Audio Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object and opens an audio file for playback, and optionally starts playback.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public Audio(
string fileName,
bool autoRun
);
Managed C++ public: Audio(
String *fileName,
bool autoRun
);
JScript .NET public function Audio(
fileName : String,
autoRun : boolean
);

Parameters

fileName | System.String. Specifies the name of the file.
autoRun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Audio.Disposed
  • Audio.Disposing


Audio.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Audio();
Managed C++ | ~Audio();
JScript .NET | protected override function Finalize();


Audio.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an Audio object from a file.

Overload List

public static Audio FromFile(string);
public static Audio FromFile(string, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromFile(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an Audio object from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String _
) As Audio
C# public static Audio FromFile(
string filename
);
Managed C++ public: static Audio* FromFile(
String *filename
);
JScript .NET public static function FromFile(
filename : String
) : Audio;

Parameters

filename System.String. The path to the audio file.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio . Returns the Audio object from filename.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromFile(String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an Audio object from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal autorun As Boolean _
) As Audio
C# public static Audio FromFile(
string filename,
bool autorun
);
Managed C++ public: static Audio* FromFile(
String *filename,
bool autorun
);
JScript .NET public static function FromFile(
filename : String,
autorun : boolean
) : Audio;

Parameters

filename | System.String. The path to the audio file.
autorun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio . Returns the Audio object from filename.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromUrl

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.FromUrl Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an Audio object from a Uri Leave Site object.

Overload List

public static Audio FromUrl(Uri);
public static Audio FromUrl(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromUrl(Uri)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.FromUrl Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an Audio object from a Uri Leave Site object.

Definition

Visual Basic .NET Public Shared Function FromUrl( _
ByVal address As Uri _
) As Audio
C# public static Audio FromUrl(
Uri address
);
Managed C++ public: static Audio* FromUrl(
Uri *address
);
JScript .NET public static function FromUrl(
address : Uri
) : Audio;

Parameters

address System.Uri. A Uri Leave Site that points to an audio file to create the Audio object.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio . Returns the Audio object from address.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromUrl(Uri,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.FromUrl Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an Audio object from a Uri Leave Site object.

Definition

Visual Basic .NET Public Shared Function FromUrl( _
ByVal address As Uri, _
ByVal autorun As Boolean _
) As Audio
C# public static Audio FromUrl(
Uri address,
bool autorun
);
Managed C++ public: static Audio* FromUrl(
Uri *address,
bool autorun
);
JScript .NET public static function FromUrl(
address : Uri,
autorun : boolean
) : Audio;

Parameters

address | System.Uri. A Uri Leave Site that points to an audio file to create the Audio object.
autorun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio . Returns the Audio object from address.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Audio object.

Overload List

public void Open(string);
public void Open(string, bool);
public void Open(Uri);
public void Open(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(Uri)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Audio object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal address As Uri _
)
C# public void Open(
Uri address
);
Managed C++ public: void Open(
Uri *address
);
JScript .NET public function Open(
address : Uri
);

Parameters

address System.Uri. The Uri Leave Site to open a file from.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(Uri,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Audio object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal address As Uri, _
ByVal autoRun As Boolean _
)
C# public void Open(
Uri address,
bool autoRun
);
Managed C++ public: void Open(
Uri *address,
bool autoRun
);
JScript .NET public function Open(
address : Uri,
autoRun : boolean
);

Parameters

address | System.Uri. The Uri Leave Site to open a file from.
autoRun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Audio object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal fileName As String _
)
C# public void Open(
string fileName
);
Managed C++ public: void Open(
String *fileName
);
JScript .NET public function Open(
fileName : String
);

Parameters

fileName System.String. The path to the audio file.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Audio object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public void Open(
string fileName,
bool autoRun
);
Managed C++ public: void Open(
String *fileName,
bool autoRun
);
JScript .NET public function Open(
fileName : String,
autoRun : boolean
);

Parameters

fileName | System.String. The path to the audio file.
autoRun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Pause()

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Pause Method

 Language:
Note: This documentation is preliminary and is subject to change.

Pauses playback.

Definition

Visual Basic .NET | Public Sub Pause()
C# | public void Pause();
Managed C++ | public: void Pause();
JScript .NET | public function Pause();

Remarks

When playback is paused, playback will be stopped. When playback resumes, it will continue from the same position where playback was paused.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Play()

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Play Method

 Language:
Note: This documentation is preliminary and is subject to change.

Starts playback.

Definition

Visual Basic .NET | Public Sub Play()
C# | public void Play();
Managed C++ | public: void Play();
JScript .NET | public function Play();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Audio.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Audio.raise_Ending(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.raise_Ending Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Audio.Ending event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Ending( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Ending(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Ending(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Ending(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Audio.raise_Pausing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.raise_Pausing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Audio.Pausing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Pausing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Pausing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Pausing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Pausing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Audio.raise_Starting(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.raise_Starting Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Audio.Starting event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Starting( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Starting(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Starting(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Starting(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Audio.raise_Stopping(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.raise_Stopping Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Audio.Stopping event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Stopping( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Stopping(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Stopping(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Stopping(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Audio.SeekCurrentPosition(Double,SeekPositionFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.SeekCurrentPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Seeks to a specific playback position.

Definition

Visual Basic .NET Public Function SeekCurrentPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
Managed C++ public: double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
JScript .NET public function SeekCurrentPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time | System.Double. Position to seek.
flags | Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags. The position seek type to use.

Return Value

System.Double . Returns the position after the seek.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.SeekStopPosition(Double,SeekPositionFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.SeekStopPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a new stop position in playback.

Definition

Visual Basic .NET Public Function SeekStopPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekStopPosition(
double time,
SeekPositionFlags flags
);
Managed C++ public: double SeekStopPosition(
double time,
SeekPositionFlags flags
);
JScript .NET public function SeekStopPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time | System.Double. Position that is the new stop time for playback.
flags | Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags. The position seek type to use to set the new stop position.

Return Value

System.Double . Returns the new stop position.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Stop()

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Stop Method

 Language:
Note: This documentation is preliminary and is subject to change.

Stops playback.

Definition

Visual Basic .NET | Public Sub Stop()
C# | public void Stop();
Managed C++ | public: void Stop();
JScript .NET | public function Stop();

Remarks

Stopping playback will cause the position to be reset to the beginning.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.StopWhenReady()

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.StopWhenReady Method

 Language:
Note: This documentation is preliminary and is subject to change.

Stops playback when the Audio object is ready.

Definition

Visual Basic .NET | Public Sub StopWhenReady()
C# | public void StopWhenReady();
Managed C++ | public: void StopWhenReady();
JScript .NET | public function StopWhenReady();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Balance

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Balance Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the playback position in the stereo field.

Definition

Visual Basic .NET | Public Property Balance As Integer
C# | public int Balance { get; set; }
Managed C++ public: __property int get_Balance();
public: __property void set_Balance(int);
JScript .NET public function get Balance() : int
public function set Balance(int);

Property Value

System.Int32 . The playback position in the stereo field.

This property is read/write.

Remarks

When this property is set to -10000, playback in the left channel is at normal volume and the right channel is effectively silent.

When this property is set to 10000, playback in the right channel is at normal volume and the left channel is effectively silent.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.CurrentPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.CurrentPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the current position of playback.

Definition

Visual Basic .NET | Public Property CurrentPosition As Double
C# | public double CurrentPosition { get; set; }
Managed C++ public: __property double get_CurrentPosition();
public: __property void set_CurrentPosition(double);
JScript .NET public function get CurrentPosition() : double
public function set CurrentPosition(double);

Property Value

System.Double . The current position of playback.

This property is read/write.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that is true if the object is disposed; otherwise the value is false.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Audio.Duration

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Duration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the length, in seconds, of the audio file.

Definition

Visual Basic .NET | Public ReadOnly Property Duration As Double
C# | public double Duration { get; }
Managed C++ | public: __property double get_Duration();
JScript .NET | public function get Duration() : double

Property Value

System.Double . The length, in seconds, of the audio file.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Paused

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Paused Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current playback state, whether playback is currently paused.

Definition

Visual Basic .NET | Public ReadOnly Property Paused As Boolean
C# | public bool Paused { get; }
Managed C++ | public: __property bool get_Paused();
JScript .NET | public function get Paused() : boolean

Property Value

System.Boolean . A value that is set to true, if the playback is currently paused; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Playing

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Playing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current playback state, whether playback is currently playing.

Definition

Visual Basic .NET | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
Managed C++ | public: __property bool get_Playing();
JScript .NET | public function get Playing() : boolean

Property Value

System.Boolean . A value that is set to true, if the playback is currently playing; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.SeekingCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.SeekingCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the seeking capabilities of playback.

Definition

Visual Basic .NET | Public ReadOnly Property SeekingCaps As SeekingCaps
C# | public SeekingCaps SeekingCaps { get; }
Managed C++ | public: __property SeekingCaps get_SeekingCaps();
JScript .NET | public function get SeekingCaps() : SeekingCaps

Property Value

Microsoft.DirectX.AudioVideoPlayback.SeekingCaps . The seeking capabilities of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.State

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.State Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current state of playback.

Definition

Visual Basic .NET | Public ReadOnly Property State As StateFlags
C# | public StateFlags State { get; }
Managed C++ | public: __property StateFlags get_State();
JScript .NET | public function get State() : StateFlags

Property Value

Microsoft.DirectX.AudioVideoPlayback.StateFlags . The current state of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Stopped

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Stopped Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current playback state, whether playback is currently stopped.

Definition

Visual Basic .NET | Public ReadOnly Property Stopped As Boolean
C# | public bool Stopped { get; }
Managed C++ | public: __property bool get_Stopped();
JScript .NET | public function get Stopped() : boolean

Property Value

System.Boolean . A value that is set to true, if the playback is stopped; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.StopPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.StopPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the position where playback stopped.

Definition

Visual Basic .NET | Public ReadOnly Property StopPosition As Double
C# | public double StopPosition { get; }
Managed C++ | public: __property double get_StopPosition();
JScript .NET | public function get StopPosition() : double

Property Value

System.Double . The position where playback stopped.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Volume

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Volume Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the amount to attenuate the volume of audio playback.

Definition

Visual Basic .NET | Public Property Volume As Integer
C# | public int Volume { get; set; }
Managed C++ public: __property int get_Volume();
public: __property void set_Volume(int);
JScript .NET public function get Volume() : int
public function set Volume(int);

Property Value

System.Int32 . The amount to attenuate the audio playback volume.

This property is read/write.

Remarks

When this property is set to 0, playback will be at maximum volume.

When this property is set to -10000, playback will be effectively silent.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Audio.Disposing event, use the following code.

audio.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Audio.Ending

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Ending Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is ending.

Definition

Visual Basic .NET | Public Event Ending As EventHandler
C# | public event EventHandler Ending;
Managed C++ | public: __event EventHandler Ending;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Audio.Pausing

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Pausing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is pausing.

Definition

Visual Basic .NET | Public Event Pausing As EventHandler
C# | public event EventHandler Pausing;
Managed C++ | public: __event EventHandler Pausing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Audio.Starting

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Starting Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is starting.

Definition

Visual Basic .NET | Public Event Starting As EventHandler
C# | public event EventHandler Starting;
Managed C++ | public: __event EventHandler Starting;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Audio.Stopping

Microsoft DirectX 9.0 SDK Update (October 2004)

Audio.Stopping Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is stopping.

Definition

Visual Basic .NET | Public Event Stopping As EventHandler
C# | public event EventHandler Stopping;
Managed C++ | public: __event EventHandler Stopping;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.AudioVideoPlayback.TextureRenderEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRenderEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains properties for retrieving arguments from a called Video.TextureReadyToRender event.

Definition

Visual Basic .NET NotInheritable Public Class TextureRenderEventArgs
Inherits EventArgs
C# | public sealed class TextureRenderEventArgs : EventArgs
Managed C++ | public __gc __sealed class TextureRenderEventArgs : public EventArgs
JScript .NET | public class TextureRenderEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
Texture | Retrieves a Direct3D.Texture from the Video object when the Video.TextureReadyToRender event is triggered.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
TextureRenderEventArgs

Class Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureRenderEventArgs.Texture

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRenderEventArgs.Texture Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a Direct3D.Texture from the Video object when the Video.TextureReadyToRender event is triggered.

Definition

Visual Basic .NET | Public ReadOnly Property Texture As Texture
C# | public Texture Texture { get; }
Managed C++ | public: __property Texture* get_Texture();
JScript .NET | public function get Texture() : Texture

Property Value

Microsoft.DirectX.Direct3D.Texture . A Direct3D.Texture from the Video object when the Video.TextureReadyToRender event is triggered.

This property is read-only.

Remarks

The Direct3D.Texture object is the current frame of video that can be used as a texture in Microsoft® Direct3D®.


Microsoft.DirectX.AudioVideoPlayback.Video

Microsoft DirectX 9.0 SDK Update (October 2004)

Video Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains the properties and methods to play video files, including those that contain audio.

Definition

Visual Basic .NET NotInheritable Public Class Video
Inherits Object
Implements IDisposable
C# public sealed class Video : Object,
IDisposable
Managed C++ public __gc __sealed class Video : public Object,
IDisposable
JScript .NET public class Video extends Object
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.
Ending | Occurs when the playback is ending.
Pausing | Occurs when the playback is pausing.
Starting | Occurs when the playback is starting.
Stopping | Occurs when the playback is stopping.
TextureReadyToRender | Occurs when target texture is ready to render video playback.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FromFile | Creates a Video object from a file.
static (Shared in Visual Basic .NET) FromUrl | Creates a Video object from a Uri Leave Site object.
HideCursor | Hides the cursor while playing video.
Open | Loads a new file into the Video object.
Pause | Pauses playback.
Play | Starts playback.
raise_Disposing | Raises the Video.Disposing event when called from within a derived class.
raise_Ending | Raises the Video.Ending event when called from within a derived class.
raise_Pausing | Raises the Video.Pausing event when called from within a derived class.
raise_Starting | Raises the Video.Starting event when called from within a derived class.
raise_Stopping | Raises the Video.Stopping event when called from within a derived class.
raise_TextureReadyToRender | Raises the Video.TextureReadyToRender event when called from within a derived class.
RenderToTexture | Enables the Video to trigger the TextureReadyToRender event to generate Texture objects for rendering video in Microsoft® Direct3D®.
SeekCurrentPosition | Seeks to a specific playback postion.
SeekStopPosition | Sets a new stop postion in playback.
ShowCursor | Shows the cursor while playing video.
Stop | Stops playback.
StopWhenReady | Stops playback when the Video object is ready.
Video | Initializes a new instance of the object.

Properties

Property | Description
Audio | Retrieves the Audio object the video is using for audio playback.
AverageTimePerFrame | Retrieves the average time per frame during playback.
Caption | Retrieves and sets the caption of the Form Leave Site playing the video.
CurrentPosition | Retrieves and sets the current position of playback.
DefaultSize | Retrieves the default size of the video for playback.
Disposed | Retrieves a value that is true if the object is disposed; otherwise the value is false.
Duration | Retrieves the length, in seconds, of the video file.
Fullscreen | Retrieves and sets whether the video plays back in fullscreen mode.
IsCursorHidden | Retrieves whether the cursor is hidden for the video.
MaximumIdealSize | Retrieves the maximum ideal size of the video for playback.
MinimumIdealSize | Retrieves the minimum ideal size of the video for playback.
Owner | Retrieves or sets the Control Leave Site where the video will be played.
Paused | Retrieves whether playback is currently paused.
Playing | Retrieves whether playback is currently playing.
SeekingCaps | Retrieves the seeking capabilities of playback.
Size | Retrieves and sets the size of the video for playback.
State | Retrieves the current state of playback.
Stopped | Retrieves whether playback is currently stopped.
StopPosition | Retrieves the position where playback stopped.

Inheritance Hierarchy

Object Leave Site
Video

Class Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Video.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Video.Disposed
  • Video.Disposing


Video.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Video();
Managed C++ | ~Video();
JScript .NET | protected override function Finalize();


Video.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a Video object from a file.

Overload List

public static Video FromFile(string);
public static Video FromFile(string, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromFile(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a Video object from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String _
) As Video
C# public static Video FromFile(
string filename
);
Managed C++ public: static Video* FromFile(
String *filename
);
JScript .NET public static function FromFile(
filename : String
) : Video;

Parameters

filename System.String. The path to the video file.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video . The Video object created from the file indicated by the filename parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromFile(String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a Video object from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal autorun As Boolean _
) As Video
C# public static Video FromFile(
string filename,
bool autorun
);
Managed C++ public: static Video* FromFile(
String *filename,
bool autorun
);
JScript .NET public static function FromFile(
filename : String,
autorun : boolean
) : Video;

Parameters

filename | System.String. The path to the video file.
autorun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video . The Video object created from the file indicated by the filename parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromUrl

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.FromUrl Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a Video object from a Uri Leave Site object.

Overload List

public static Video FromUrl(Uri);
public static Video FromUrl(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromUrl(Uri)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.FromUrl Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a Video object from a Uri Leave Site object.

Definition

Visual Basic .NET Public Shared Function FromUrl( _
ByVal address As Uri _
) As Video
C# public static Video FromUrl(
Uri address
);
Managed C++ public: static Video* FromUrl(
Uri *address
);
JScript .NET public static function FromUrl(
address : Uri
) : Video;

Parameters

address System.Uri. A Uri Leave Site that points to a video file to create the Audio object.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video . The Video object created from the Uri Leave Site indicated by the address parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromUrl(Uri,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.FromUrl Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a Video object from a Uri Leave Site object.

Definition

Visual Basic .NET Public Shared Function FromUrl( _
ByVal address As Uri, _
ByVal autorun As Boolean _
) As Video
C# public static Video FromUrl(
Uri address,
bool autorun
);
Managed C++ public: static Video* FromUrl(
Uri *address,
bool autorun
);
JScript .NET public static function FromUrl(
address : Uri,
autorun : boolean
) : Video;

Parameters

address | System.Uri. A Uri Leave Site that points to a video file to create the Audio object.
autorun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video . The Video object created from the Uri Leave Site indicated by the address parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.HideCursor()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.HideCursor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Hides the cursor while playing video.

Definition

Visual Basic .NET | Public Sub HideCursor()
C# | public void HideCursor();
Managed C++ | public: void HideCursor();
JScript .NET | public function HideCursor();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Video object.

Overload List

public void Open(string);
public void Open(string, bool);
public void Open(Uri);
public void Open(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(Uri)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Video object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal address As Uri _
)
C# public void Open(
Uri address
);
Managed C++ public: void Open(
Uri *address
);
JScript .NET public function Open(
address : Uri
);

Parameters

address System.Uri. The Uri Leave Site to open a file from.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(Uri,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Video object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal address As Uri, _
ByVal autoRun As Boolean _
)
C# public void Open(
Uri address,
bool autoRun
);
Managed C++ public: void Open(
Uri *address,
bool autoRun
);
JScript .NET public function Open(
address : Uri,
autoRun : boolean
);

Parameters

address | System.Uri. The Uri Leave Site to open a file from.
autoRun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Video object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal fileName As String _
)
C# public void Open(
string fileName
);
Managed C++ public: void Open(
String *fileName
);
JScript .NET public function Open(
fileName : String
);

Parameters

fileName System.String. The path to the video file.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a new file into the Video object.

Definition

Visual Basic .NET Public Sub Open( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public void Open(
string fileName,
bool autoRun
);
Managed C++ public: void Open(
String *fileName,
bool autoRun
);
JScript .NET public function Open(
fileName : String,
autoRun : boolean
);

Parameters

fileName | System.String. The path to the video file.
autoRun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Pause()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Pause Method

 Language:
Note: This documentation is preliminary and is subject to change.

Pauses playback.

Definition

Visual Basic .NET | Public Sub Pause()
C# | public void Pause();
Managed C++ | public: void Pause();
JScript .NET | public function Pause();

Remarks

Pausing playback will maintain the playback position when playback is resumed.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Play()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Play Method

 Language:
Note: This documentation is preliminary and is subject to change.

Starts playback.

Definition

Visual Basic .NET | Public Sub Play()
C# | public void Play();
Managed C++ | public: void Play();
JScript .NET | public function Play();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Video.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Video.raise_Ending(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.raise_Ending Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Video.Ending event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Ending( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Ending(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Ending(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Ending(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Video.raise_Pausing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.raise_Pausing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Video.Pausing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Pausing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Pausing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Pausing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Pausing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Video.raise_Starting(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.raise_Starting Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Video.Starting event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Starting( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Starting(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Starting(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Starting(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Video.raise_Stopping(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.raise_Stopping Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Video.Stopping event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Stopping( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Stopping(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Stopping(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Stopping(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Video.raise_TextureReadyToRender(Object,TextureRenderEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.raise_TextureReadyToRender Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Video.TextureReadyToRender event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_TextureReadyToRender( _
ByVal i1 As Object, _
ByVal i2 As TextureRenderEventArgs _
)
C# protected void raise_TextureReadyToRender(
object i1,
TextureRenderEventArgs i2
);
Managed C++ protected: void raise_TextureReadyToRender(
Object *i1,
TextureRenderEventArgs *i2
);
JScript .NET protected function raise_TextureReadyToRender(
i1 : Object,
i2 : TextureRenderEventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | Microsoft.DirectX.AudioVideoPlayback.TextureRenderEventArgs. Arguments to pass to the event handler.


Video.RenderToTexture(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.RenderToTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enables the Video to trigger the TextureReadyToRender event to generate Texture objects for rendering video in Microsoft® Direct3D®.

Definition

Visual Basic .NET Public Sub RenderToTexture( _
ByVal graphicsDevice As Device _
)
C# public void RenderToTexture(
Device graphicsDevice
);
Managed C++ public: void RenderToTexture(
Device *graphicsDevice
);
JScript .NET public function RenderToTexture(
graphicsDevice : Device
);

Parameters

graphicsDevice Microsoft.DirectX.Direct3D.Device. The parent Direct3D.Device that renders the video textures.

Remarks

When rendering a video in Microsoft® Direct3D® using this method, be sure to hook the TextureReadyToRender event to retrieve the Texture objects.


Video.SeekCurrentPosition(Double,SeekPositionFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.SeekCurrentPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Seeks to a specific playback postion.

Definition

Visual Basic .NET Public Function SeekCurrentPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
Managed C++ public: double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
JScript .NET public function SeekCurrentPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time | System.Double. Position to seek.
flags | Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags. The position seek type to use.

Return Value

System.Double . Returns the position after the seek.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.SeekStopPosition(Double,SeekPositionFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.SeekStopPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a new stop postion in playback.

Definition

Visual Basic .NET Public Function SeekStopPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekStopPosition(
double time,
SeekPositionFlags flags
);
Managed C++ public: double SeekStopPosition(
double time,
SeekPositionFlags flags
);
JScript .NET public function SeekStopPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time | System.Double. Position that is the new stop time for playback.
flags | Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags. The position seek type to use to set the new stop position.

Return Value

System.Double . Returns the new stop position.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.ShowCursor()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.ShowCursor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Shows the cursor while playing video.

Definition

Visual Basic .NET | Public Sub ShowCursor()
C# | public void ShowCursor();
Managed C++ | public: void ShowCursor();
JScript .NET | public function ShowCursor();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Stop()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Stop Method

 Language:
Note: This documentation is preliminary and is subject to change.

Stops playback.

Definition

Visual Basic .NET | Public Sub Stop()
C# | public void Stop();
Managed C++ | public: void Stop();
JScript .NET | public function Stop();

Remarks

Stopping playback will cause the position to be reset to the beginning.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.StopWhenReady()

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.StopWhenReady Method

 Language:
Note: This documentation is preliminary and is subject to change.

Stops playback when the Video object is ready.

Definition

Visual Basic .NET | Public Sub StopWhenReady()
C# | public void StopWhenReady();
Managed C++ | public: void StopWhenReady();
JScript .NET | public function StopWhenReady();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Video

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Video Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public Video(string);
public Video(string, bool);


Video.Video(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Video Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Video class.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String _
)
C# public Video(
string fileName
);
Managed C++ public: Video(
String *fileName
);
JScript .NET public function Video(
fileName : String
);

Parameters

fileName System.String. Path to the video file this object will play.


Video.Video(String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Video Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public Video(
string fileName,
bool autoRun
);
Managed C++ public: Video(
String *fileName,
bool autoRun
);
JScript .NET public function Video(
fileName : String,
autoRun : boolean
);

Parameters

fileName | System.String. Path to the video file this object will play.
autoRun | System.Boolean. Set to true to automatically start playback. Set to false to open the file but not play it.


Video.Audio

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Audio Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Audio object the video is using for audio playback.

Definition

Visual Basic .NET | Public ReadOnly Property Audio As Audio
C# | public Audio Audio { get; }
Managed C++ | public: __property Audio* get_Audio();
JScript .NET | public function get Audio() : Audio

Property Value

Microsoft.DirectX.AudioVideoPlayback.Audio . The Audio object the video is using for audio playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.AverageTimePerFrame

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.AverageTimePerFrame Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the average time per frame during playback.

Definition

Visual Basic .NET | Public ReadOnly Property AverageTimePerFrame As Double
C# | public double AverageTimePerFrame { get; }
Managed C++ | public: __property double get_AverageTimePerFrame();
JScript .NET | public function get AverageTimePerFrame() : double

Property Value

System.Double . The average time per frame during playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Caption

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Caption Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the caption of the Form Leave Site playing the video.

Definition

Visual Basic .NET | Public Property Caption As String
C# | public string Caption { get; set; }
Managed C++ public: __property String* get_Caption();
public: __property void set_Caption(String*);
JScript .NET public function get Caption() : String
public function set Caption(String);

Property Value

System.String . The caption of the Form Leave Site playing the video.

This property is read/write.

Remarks

This property only applies to videos that are played in their own Form Leave Site when the Owner property is not set.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.CurrentPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.CurrentPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the current position of playback.

Definition

Visual Basic .NET | Public Property CurrentPosition As Double
C# | public double CurrentPosition { get; set; }
Managed C++ public: __property double get_CurrentPosition();
public: __property void set_CurrentPosition(double);
JScript .NET public function get CurrentPosition() : double
public function set CurrentPosition(double);

Property Value

System.Double . The current position of playback.

This property is read/write.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.DefaultSize

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.DefaultSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default size of the video for playback.

Definition

Visual Basic .NET | Public ReadOnly Property DefaultSize As System.Drawing.Size
C# | public System.Drawing.Size DefaultSize { get; }
Managed C++ | public: __property System.Drawing.Size* get_DefaultSize();
JScript .NET | public function get DefaultSize() : System.Drawing.Size

Property Value

System.Drawing.Size . The default size of the video for playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that is true if the object is disposed; otherwise the value is false.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Video.Duration

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Duration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the length, in seconds, of the video file.

Definition

Visual Basic .NET | Public ReadOnly Property Duration As Double
C# | public double Duration { get; }
Managed C++ | public: __property double get_Duration();
JScript .NET | public function get Duration() : double

Property Value

System.Double . The length, in seconds, of the video file.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Fullscreen

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Fullscreen Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the video plays back in fullscreen mode.

Definition

Visual Basic .NET | Public Property Fullscreen As Boolean
C# | public bool Fullscreen { get; set; }
Managed C++ public: __property bool get_Fullscreen();
public: __property void set_Fullscreen(bool);
JScript .NET public function get Fullscreen() : boolean
public function set Fullscreen(boolean);

Property Value

System.Boolean . When set to true, the video plays back in fullscreen mode.

This property is read/write.

Remarks

When playing a video in fullscreen mode, the Owner property can not be set. If you attempt to set the Owner property after setting the Fullscreen property to true, a DirectXException will be thrown. If you try to set the Fullscreen property to true after you set the Owner property, the video will play back in the control and not in fullscreen mode.

If focus is taken away from the application playing the video, the video will no longer play in fullscreen mode and will return to windowed mode.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.IsCursorHidden

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.IsCursorHidden Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the cursor is hidden for the video.

Definition

Visual Basic .NET | Public ReadOnly Property IsCursorHidden As Boolean
C# | public bool IsCursorHidden { get; }
Managed C++ | public: __property bool get_IsCursorHidden();
JScript .NET | public function get IsCursorHidden() : boolean

Property Value

System.Boolean . A value that is set to true if the cursor is hidden for the video; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.MaximumIdealSize

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.MaximumIdealSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum ideal size of the video for playback.

Definition

Visual Basic .NET | Public ReadOnly Property MaximumIdealSize As System.Drawing.Size
C# | public System.Drawing.Size MaximumIdealSize { get; }
Managed C++ | public: __property System.Drawing.Size* get_MaximumIdealSize();
JScript .NET | public function get MaximumIdealSize() : System.Drawing.Size

Property Value

System.Drawing.Size . The maximum ideal size of the video for playback.

This property is read-only.

Remarks

The maximum ideal size may differ from the native video size, because the video hardware might have specific stretching requirements.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.MinimumIdealSize

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.MinimumIdealSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum ideal size of the video for playback.

Definition

Visual Basic .NET | Public ReadOnly Property MinimumIdealSize As System.Drawing.Size
C# | public System.Drawing.Size MinimumIdealSize { get; }
Managed C++ | public: __property System.Drawing.Size* get_MinimumIdealSize();
JScript .NET | public function get MinimumIdealSize() : System.Drawing.Size

Property Value

System.Drawing.Size . The minimum ideal size of the video for playback.

This property is read-only.

Remarks

The minimum ideal size may differ from the native video size, because the video hardware might have specific stretching requirements.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Owner

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Owner Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Control Leave Site where the video will be played.

Definition

Visual Basic .NET | Public Property Owner As Control
C# | public Control Owner { get; set; }
Managed C++ public: __property Control* get_Owner();
public: __property void set_Owner(Control*);
JScript .NET public function get Owner() : Control
public function set Owner(Control);

Property Value

System.Windows.Forms.Control . The Control Leave Site where the video will be played.

This property is read/write.

Remarks

If this property is not set before playback, a new Form Leave Site will be created for playback.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Paused

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Paused Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether playback is currently paused.

Definition

Visual Basic .NET | Public ReadOnly Property Paused As Boolean
C# | public bool Paused { get; }
Managed C++ | public: __property bool get_Paused();
JScript .NET | public function get Paused() : boolean

Property Value

System.Boolean . A value that is set to true if the playback is currently paused; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Playing

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Playing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether playback is currently playing.

Definition

Visual Basic .NET | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
Managed C++ | public: __property bool get_Playing();
JScript .NET | public function get Playing() : boolean

Property Value

System.Boolean . A value that is set to true if the playback is currently playing; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.SeekingCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.SeekingCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the seeking capabilities of playback.

Definition

Visual Basic .NET | Public ReadOnly Property SeekingCaps As SeekingCaps
C# | public SeekingCaps SeekingCaps { get; }
Managed C++ | public: __property SeekingCaps get_SeekingCaps();
JScript .NET | public function get SeekingCaps() : SeekingCaps

Property Value

Microsoft.DirectX.AudioVideoPlayback.SeekingCaps . The seeking capabilities of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Size

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Size Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the size of the video for playback.

Definition

Visual Basic .NET | Public Property Size As System.Drawing.Size
C# | public System.Drawing.Size Size { get; set; }
Managed C++ public: __property System.Drawing.Size* get_Size();
public: __property void set_Size(System.Drawing.Size*);
JScript .NET public function get Size() : System.Drawing.Size
public function set Size(System.Drawing.Size);

Property Value

System.Drawing.Size . The size of the video for playback.

This property is read/write.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.State

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.State Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current state of playback.

Definition

Visual Basic .NET | Public ReadOnly Property State As StateFlags
C# | public StateFlags State { get; }
Managed C++ | public: __property StateFlags get_State();
JScript .NET | public function get State() : StateFlags

Property Value

Microsoft.DirectX.AudioVideoPlayback.StateFlags . The current state of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Stopped

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Stopped Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether playback is currently stopped.

Definition

Visual Basic .NET | Public ReadOnly Property Stopped As Boolean
C# | public bool Stopped { get; }
Managed C++ | public: __property bool get_Stopped();
JScript .NET | public function get Stopped() : boolean

Property Value

System.Boolean . A value that is set to true if the playback is stopped; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.StopPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.StopPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the position where playback stopped.

Definition

Visual Basic .NET | Public ReadOnly Property StopPosition As Double
C# | public double StopPosition { get; }
Managed C++ | public: __property double get_StopPosition();
JScript .NET | public function get StopPosition() : double

Property Value

System.Double . The position where playback stopped.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Video.Disposing event, use the following code.

video.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Video.Ending

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Ending Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is ending.

Definition

Visual Basic .NET | Public Event Ending As EventHandler
C# | public event EventHandler Ending;
Managed C++ | public: __event EventHandler Ending;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Video.Pausing

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Pausing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is pausing.

Definition

Visual Basic .NET | Public Event Pausing As EventHandler
C# | public event EventHandler Pausing;
Managed C++ | public: __event EventHandler Pausing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Video.Starting

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Starting Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is starting.

Definition

Visual Basic .NET | Public Event Starting As EventHandler
C# | public event EventHandler Starting;
Managed C++ | public: __event EventHandler Starting;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Video.Stopping

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.Stopping Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the playback is stopping.

Definition

Visual Basic .NET | Public Event Stopping As EventHandler
C# | public event EventHandler Stopping;
Managed C++ | public: __event EventHandler Stopping;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Video.TextureReadyToRender

Microsoft DirectX 9.0 SDK Update (October 2004)

Video.TextureReadyToRender Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when target texture is ready to render video playback.

Definition

Visual Basic .NET | Public Event TextureReadyToRender As TextureRenderEventHandler
C# | public event TextureRenderEventHandler TextureReadyToRender;
Managed C++ | public: __event TextureRenderEventHandler TextureReadyToRender;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


SeekPositionFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekPositionFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants for specifiying the type of seek for the Audio or Video objects.

Definition

Visual Basic .NET | Public Enum SeekPositionFlags
C# | public enum SeekPositionFlags
Managed C++ | __value public enum SeekPositionFlags
JScript .NET | public enum SeekPositionFlags

Members

Member | Value | Description
NoFlush | 32 | Do not flush
SeekToKeyFrame | 4 | Seek to the nearest key frame. This might be faster, but less accurate.
IncrementalPositioning | 3 | The stop position is relative to the current position.
RelativePositioning | 2 | The specified position is relative to the previous value.
AbsolutePositioning | 1 | The specified position is absolute.

Enumeration Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Audio.SeekCurrentPosition
  • Audio.SeekStopPosition
  • Video.SeekCurrentPosition
  • Video.SeekStopPosition


StateFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

StateFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants for specifiying the state of the Audio or Video objects.

Definition

Visual Basic .NET | Public Enum StateFlags
C# | public enum StateFlags
Managed C++ | __value public enum StateFlags
JScript .NET | public enum StateFlags

Members

Member | Value | Description
Running | 2 | The Audio or Video object is running.
Paused | 1 | The Audio or Video object is paused.
Stopped | 0 | The Audio or Video object is stopped.

Enumeration Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Audio.State
  • Video.State


SeekingCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekingCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Collection of properties that describe the capabilities of a media stream.

Definition

Visual Basic .NET | Public Structure SeekingCaps
C# | public struct SeekingCaps
Managed C++ | public __value struct SeekingCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
CanGetCurrentPosition | Retrieves whether the stream can report its current position.
CanGetDuration | Retrieves whether the stream can report its duration.
CanGetStopPosition | Retrieves whether the stream can report its stop position.
CanSeekAbsolute | Retrieves whether the stream can seek to an absolute position.
CanSeekBackwards | Retrieves whether the stream can seek backward
CanSeekForwards | Retrieves whether the stream can seek forward.

Structure Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Auido.SeekingCaps
  • Video.SeekingCaps


SeekingCaps.CanGetCurrentPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekingCaps.CanGetCurrentPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the stream can report its current position.

Definition

Visual Basic .NET | Public ReadOnly Property CanGetCurrentPosition As Boolean
C# | public bool CanGetCurrentPosition { get; }
Managed C++ | public: __property bool get_CanGetCurrentPosition();
JScript .NET | public function get CanGetCurrentPosition() : boolean

Property Value

System.Boolean . A value that is set to true if the stream can report its current position; otherwise, false.

This property is read-only.


SeekingCaps.CanGetDuration

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekingCaps.CanGetDuration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the stream can report its duration.

Definition

Visual Basic .NET | Public ReadOnly Property CanGetDuration As Boolean
C# | public bool CanGetDuration { get; }
Managed C++ | public: __property bool get_CanGetDuration();
JScript .NET | public function get CanGetDuration() : boolean

Property Value

System.Boolean . A value that is set to true if the stream can report its duration; otherwise, false.

This property is read-only.


SeekingCaps.CanGetStopPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekingCaps.CanGetStopPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the stream can report its stop position.

Definition

Visual Basic .NET | Public ReadOnly Property CanGetStopPosition As Boolean
C# | public bool CanGetStopPosition { get; }
Managed C++ | public: __property bool get_CanGetStopPosition();
JScript .NET | public function get CanGetStopPosition() : boolean

Property Value

System.Boolean . A value that is set to true if the stream can report its stop position; otherwise, false.

This property is read-only.


SeekingCaps.CanSeekAbsolute

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekingCaps.CanSeekAbsolute Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the stream can seek to an absolute position.

Definition

Visual Basic .NET | Public ReadOnly Property CanSeekAbsolute As Boolean
C# | public bool CanSeekAbsolute { get; }
Managed C++ | public: __property bool get_CanSeekAbsolute();
JScript .NET | public function get CanSeekAbsolute() : boolean

Property Value

System.Boolean . A value that is set to true if the stream can seek to an absolute position; otherwise, false.

This property is read-only.


SeekingCaps.CanSeekBackwards

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekingCaps.CanSeekBackwards Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the stream can seek backward

Definition

Visual Basic .NET | Public ReadOnly Property CanSeekBackwards As Boolean
C# | public bool CanSeekBackwards { get; }
Managed C++ | public: __property bool get_CanSeekBackwards();
JScript .NET | public function get CanSeekBackwards() : boolean

Property Value

System.Boolean . A value that is set to true if the stream can seek backward; otherwise, false.

This property is read-only.


SeekingCaps.CanSeekForwards

Microsoft DirectX 9.0 SDK Update (October 2004)

SeekingCaps.CanSeekForwards Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the stream can seek forward.

Definition

Visual Basic .NET | Public ReadOnly Property CanSeekForwards As Boolean
C# | public bool CanSeekForwards { get; }
Managed C++ | public: __property bool get_CanSeekForwards();
JScript .NET | public function get CanSeekForwards() : boolean

Property Value

System.Boolean . A value that is set to true if the stream can seek forward; otherwise, false.

This property is read-only.


TextureRenderEventHandler(Object,TextureRenderEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRenderEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Represents the method that handles the Video.TextureReadyToRender event.

Definition

Visual Basic .NET Public Delegate Sub TextureRenderEventHandler( _
ByVal sender As Object, _
ByVal e As TextureRenderEventArgs _
)
C# public sealed delegate void TextureRenderEventHandler(
object sender,
TextureRenderEventArgs e
);
Managed C++ public: __gc __delegate void TextureRenderEventHandler(
Object *sender,
TextureRenderEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object. The System.Object Leave Site that is calling the event.
e | Microsoft.DirectX.AudioVideoPlayback.TextureRenderEventArgs. A TextureRenderEventArgs object that allows you to pass an argument to the Video.TextureReadyToRender event.

Delegate Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.Diagnostics

Note: This documentation is preliminary and is subject to change.

The Microsoft® DirectX® Diagnostics application programming interface (API) enables you to programmatically query the information gathered by the DirectX Diagnostics Tool (DxDiag). DxDiag gathers information about the system and the DirectX components installed on it, as well as providing a number of tests to ensure that components are working properly.

A sample application is provided at (SDK root)\Samples\Managed\Misc\DxDiagOutput. The executable is at %windir%\system32\dxdiag.exe.

The following tables list the members exposed by the Microsoft.DirectX.Diagnostics namespace.

Classes

Container | A diagnostics container. Contains properties and other containers.
ContainerList | Maintains a list of containers.
PropertyList | Maintains a list of properties.

Structures

ContainerData | Holds the Container and its name.
PropertyData | Contains the property name and value.


Microsoft.DirectX.Diagnostics.Container

Microsoft DirectX 9.0 SDK Update (October 2004)

Container Class

Language:
Note: This documentation is preliminary and is subject to change.

A diagnostics container. Contains properties and other containers.

Definition

Visual Basic .NET Public Class Container
Inherits MarshalByRefObject
Implements IDisposable
C# public class Container : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Container : public MarshalByRefObject,
IDisposable
JScript .NET public class Container extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Container | Initializes a new instance of the Container class.
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetContainer | Retrieves a container with a specified name or index.
GetProperty | Retrieves a property with a specified name or index.

Properties

Property | Description
Containers | Retrieves a ContainerList object that holds the containers for the current container object.
NumberContainers | Retrieves the number of containers stored in the ContainerList.
NumberProperties | Retrieves the number of properties stored in the PropertyList.
Properties | Retrieves a PropertyList object that holds the properties for the current container object.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Container

Class Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Container.Container(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.Container Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Container class.

Definition

Visual Basic .NET Public Sub New( _
ByVal allowWhqlChecks As Boolean _
)
C# public Container(
bool allowWhqlChecks
);
Managed C++ public: Container(
bool allowWhqlChecks
);
JScript .NET public function Container(
allowWhqlChecks : boolean
);

Parameters

allowWhqlChecks System.Boolean. Set to true if Windows Hardware Quality Labs (WHQL) checks are allowed; otherwise, false.


Container.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


Container.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Container();
Managed C++ | ~Container();
JScript .NET | protected override function Finalize();


Container.GetContainer

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.GetContainer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a container with a specified name or index.

Overload List

public ContainerData GetContainer(int);
public ContainerData GetContainer(string);


Container.GetContainer(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.GetContainer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Container with the specified name.

Definition

Visual Basic .NET Public Function GetContainer( _
ByVal name As String _
) As ContainerData
C# public ContainerData GetContainer(
string name
);
Managed C++ public: ContainerData GetContainer(
String *name
);
JScript .NET public function GetContainer(
name : String
) : ContainerData;

Parameters

name System.String. String that represents the name of the container to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.ContainerData . Requested ContainerData object.


Container.GetContainer(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.GetContainer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Container with the specified index.

Definition

Visual Basic .NET Public Function GetContainer( _
ByVal index As Integer _
) As ContainerData
C# public ContainerData GetContainer(
int index
);
Managed C++ public: ContainerData GetContainer(
int index
);
JScript .NET public function GetContainer(
index : int
) : ContainerData;

Parameters

index System.Int32. Integer that represents the index of the container to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.ContainerData . Requested ContainerData object.


Container.GetProperty

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.GetProperty Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a property with a specified name or index.

Overload List

public PropertyData GetProperty(int);
public PropertyData GetProperty(string);


Container.GetProperty(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.GetProperty Method

 Language:
Note: This documentation is preliminary and is subject to change.

Property with the specified name.

Definition

Visual Basic .NET Public Function GetProperty( _
ByVal name As String _
) As PropertyData
C# public PropertyData GetProperty(
string name
);
Managed C++ public: PropertyData GetProperty(
String *name
);
JScript .NET public function GetProperty(
name : String
) : PropertyData;

Parameters

name System.String. String that represents the name of the property to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.PropertyData . Requested PropertyData object.


Container.GetProperty(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.GetProperty Method

 Language:
Note: This documentation is preliminary and is subject to change.

Property with the specified index.

Definition

Visual Basic .NET Public Function GetProperty( _
ByVal index As Integer _
) As PropertyData
C# public PropertyData GetProperty(
int index
);
Managed C++ public: PropertyData GetProperty(
int index
);
JScript .NET public function GetProperty(
index : int
) : PropertyData;

Parameters

index System.Int32. Integer that represents the index of the property to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.PropertyData . Requested PropertyData object.


Container.Containers

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.Containers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a ContainerList object that holds the containers for the current container object.

Definition

Visual Basic .NET | Public ReadOnly Property Containers As ContainerList
C# | public ContainerList Containers { get; }
Managed C++ | public: __property ContainerList* get_Containers();
JScript .NET | public function get Containers() : ContainerList

Property Value

Microsoft.DirectX.Diagnostics.ContainerList . A ContainerList object to retrieve.

This property is read-only.


Container.NumberContainers

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.NumberContainers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of containers stored in the ContainerList.

Definition

Visual Basic .NET | Public ReadOnly Property NumberContainers As Integer
C# | public int NumberContainers { get; }
Managed C++ | public: __property int get_NumberContainers();
JScript .NET | public function get NumberContainers() : int

Property Value

System.Int32 . Integer value that represents the number of containers stored in the ContainerList.

This property is read-only.


Container.NumberProperties

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.NumberProperties Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of properties stored in the PropertyList.

Definition

Visual Basic .NET | Public ReadOnly Property NumberProperties As Integer
C# | public int NumberProperties { get; }
Managed C++ | public: __property int get_NumberProperties();
JScript .NET | public function get NumberProperties() : int

Property Value

System.Int32 . Integer value that represents the number of properties stored in the PropertyList.

This property is read-only.


Container.Properties

Microsoft DirectX 9.0 SDK Update (October 2004)

Container.Properties Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a PropertyList object that holds the properties for the current container object.

Definition

Visual Basic .NET | Public ReadOnly Property Properties As PropertyList
C# | public PropertyList Properties { get; }
Managed C++ | public: __property PropertyList* get_Properties();
JScript .NET | public function get Properties() : PropertyList

Property Value

Microsoft.DirectX.Diagnostics.PropertyList . A PropertyList object to retrieve.

This property is read-only.


Microsoft.DirectX.Diagnostics.ContainerList

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerList Class

Language:
Note: This documentation is preliminary and is subject to change.

Maintains a list of containers.

Definition

Visual Basic .NET Public Class ContainerList
Inherits Object
Implements IEnumerable, IEnumerator
C# public class ContainerList : Object,
IEnumerable, IEnumerator
Managed C++ public __gc class ContainerList : public Object,
IEnumerable, IEnumerator
JScript .NET public class ContainerList extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can iterate through the ContainerList.
MoveNext | Advances the enumerator to the next item in the list.
Reset | Resets the current enumerator to point to the beginning of the list.

Properties

Property | Description
Count | Retrieves the number of Objects Leave Site in the ContainerList.
Current | Retrieves the current Object Leave Site in the list.

Inheritance Hierarchy

Object Leave Site
ContainerList

Class Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ContainerList.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerList.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an enumerator that can iterate through the ContainerList.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator . Enumerator that can iterate through the ContainerList.


ContainerList.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerList.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next item in the list.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean . Value that is true if the move to the next item was successful, or false if it was not.


ContainerList.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerList.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the current enumerator to point to the beginning of the list.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the list.

After Reset is called, the cursor is undefined. Call MoveNext initially to point to the first item in the list.


ContainerList.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerList.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of Objects Leave Site in the ContainerList.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 . Number of Objects Leave Site in the ContainerList.

This property is read-only.


ContainerList.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerList.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current Object Leave Site in the list.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object . Current Object Leave Site in the list.

This property is read-only.


Microsoft.DirectX.Diagnostics.PropertyList

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyList Class

Language:
Note: This documentation is preliminary and is subject to change.

Maintains a list of properties.

Definition

Visual Basic .NET Public Class PropertyList
Inherits Object
Implements IEnumerable, IEnumerator
C# public class PropertyList : Object,
IEnumerable, IEnumerator
Managed C++ public __gc class PropertyList : public Object,
IEnumerable, IEnumerator
JScript .NET public class PropertyList extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can iterate through the PropertyList.
MoveNext | Advances the enumerator to the next item in the list.
Reset | Resets the current enumerator to point to the beginning of the list.

Properties

Property | Description
Count | Retrieves the number of Objects Leave Site in the PropertyList.
Current | Retrieves the current Object Leave Site in the list.

Inheritance Hierarchy

Object Leave Site
PropertyList

Class Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PropertyList.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyList.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an enumerator that can iterate through the PropertyList.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator . Enumerator that can iterate through the PropertyList.


PropertyList.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyList.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next item in the list.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean . Value that is true if the move to the next item was successful, or false if it was not.


PropertyList.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyList.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the current enumerator to point to the beginning of the list.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the list.

After Reset is called, the cursor is undefined. Call MoveNext initially to point to the first item in the list.


PropertyList.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyList.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of Objects Leave Site in the PropertyList.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 . Number of Objects Leave Site in the PropertyList.

This property is read-only.


PropertyList.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyList.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current Object Leave Site in the list.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object . Current Object Leave Site in the list.

This property is read-only.


ContainerData

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Holds the Container and its name.

Definition

Visual Basic .NET | Public Structure ContainerData
C# | public struct ContainerData
Managed C++ | public __value struct ContainerData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ContainerData | Initializes a new instance of the ContainerData class.

Properties

Property | Description
Container | Retrieves the Container associated with the current object.
Name | Retrieves the name of the Container associated with the current object.

Structure Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ContainerData.ContainerData()

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerData.ContainerData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ContainerData class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ContainerData();
Managed C++ | public: ContainerData();
JScript .NET | public function ContainerData();


ContainerData.Container

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerData.Container Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Container associated with the current object.

Definition

Visual Basic .NET | Public ReadOnly Property Container As Container
C# | public Container Container { get; }
Managed C++ | public: __property Container* get_Container();
JScript .NET | public function get Container() : Container

Property Value

Microsoft.DirectX.Diagnostics.Container . A Container to retrieve.

This property is read-only.


ContainerData.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ContainerData.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the name of the Container associated with the current object.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . String that contains the name of the Container.

This property is read-only.


PropertyData

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains the property name and value.

Definition

Visual Basic .NET | Public Structure PropertyData
C# | public struct PropertyData
Managed C++ | public __value struct PropertyData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PropertyData | Initializes a new instance of the PropertyData class.

Properties

Property | Description
Data | Retrieves the property's value in the form of an Object Leave Site.
Name | Retrieves the name of the Data associated with the current object.

Structure Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PropertyData.PropertyData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyData.PropertyData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PropertyData class.

Definition

Visual Basic .NET | Public Sub New()
C# | public PropertyData();
Managed C++ | public: PropertyData();
JScript .NET | public function PropertyData();


PropertyData.Data

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyData.Data Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the property's value in the form of an Object Leave Site.

Definition

Visual Basic .NET | Public ReadOnly Property Data As Object
C# | public object Data { get; }
Managed C++ | public: __property Object* get_Data();
JScript .NET | public function get Data() : Object

Property Value

System.Object . An Object Leave Site that represents the property value.

This property is read-only.


PropertyData.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyData.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the name of the Data associated with the current object.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . String that contains the name of the Data.

This property is read-only.


Microsoft.DirectX.Direct3D

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® is a low-level graphics application programming interface (API) that enables you to manipulate visual models of 3-D objects and take advantage of hardware acceleration. The following tables list the members exposed by the Microsoft.DirectX.Direct3D namespace.

See also the Microsoft.DirectX namespace, which provides utility and data storage operations.

Classes

AdapterInformation | Manipulates adapter information.
AdapterListCollection | Manipulates a collection of adapters.
AllocateHierarchy | Derived by the application to allocate/free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.
AnimationController | Controls animation functionality, connecting animation sets to the transformation frames being animated.
AnimationOutput | Encapsulates matrix, scale, rotate, and translate (SRT) transformation objects.
AnimationSet Encapsulates the minimum functionality required of an animation set by an animation controller.

Advanced users might want to implement this class themselves to suit their specialized needs. For most users, however, the derived CompressedAnimationSet and KeyframedAnimationSet classes should suffice.
BaseEffect | Provides methods for retrieving and setting effect parameters such as constants, functions, shaders, and techniques.
BaseMesh | Manipulates and queries mesh objects and derived mesh objects.
BaseTexture | Manipulates texture resources, including cube and volume textures.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique. For more information, see MeshFlags.OptimizeAttrSort.
CannotModifyIndexBufferException | The index buffer cannot be modified.
ClipPlane | Defines the clipping plane for a device.
ClipPlanes | Contains the clipping planes on the device.
ColorOperator | Contains methods for manipulating colors.
CompressedAnimationSet | Implements a keyframe animation set that is stored in a compressed data format.
ConflictingRenderStateException | The currently set render states cannot be used together.
ConflictingTextureFilterException | The current texture filters cannot be used together.
ConflictingTexturePaletteException | The current textures cannot be used simultaneously.
ConstantTable | Provides access to the constant table, which contains the variables that are used by high-level language shaders and effects.
CubeTexture | Manipulates a cube texture resource.
CustomVertex | Defines various custom fixed-format vertex types. This class is a container of structures. See the individual structures for more information.
D3DX | Contains default constant values for Direct3D extensions.
Device | Performs primitive-based rendering, creates resources, handles system-level variables, adjusts gamma ramp levels, gets and sets palettes, and creates shaders.
DeviceInformation | Contains functionality for retrieving the driver level for a device.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
DeviceNotResetException | The device has been lost but can be reset at this time.
Direct3DXException | Base exception class for D3DX. Derives from DirectXException.
DisplayModeCollection | Manipulates a collection of DisplayMode structures.
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DriverInvalidCallException | The driver reports that the current method call is invalid.
DuplicateNamedFragmentException | There is a duplicate named fragment.
Effect | Used to set and query effects and choose techniques.
EffectCompiler | Compiles an effect from a function or vertex shader.
EffectHandle | Represents a handle to specific effects.
EffectPool | Allows applications to share resources between effects.
EffectStateManager EffectStateManager is a user-implemented class that allows an application to set the device state from an effect. Each of the methods in this class must be implemented by the user and will then be used as a callback to the application when either of the following occur:
  • Effect.BeginPass is called.
  • Effect state is dynamically updated by calling the appropriate state change API. See individual method pages for details.
Font | Encapsulates the textures and resources needed to render a specific font on a specific device.
FragmentLinker | Links shader fragments at runtime.
Frame | Encapsulates a transform frame in a transformation frame hierarchy.
Geometry | Contains miscellaneous math-related functions.
GraphicsException | Base exception type for graphics. Derives from DirectXException.
Include | Provides access to include-file directives.
IndexBuffer | Manipulates an index buffer resource.
InterfaceGuid | Encapsulates various object globally unique identifiers (GUIDs) for use with the Surface.GetContainer and Volume.GetContainer methods.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
InvalidDataException | The data is invalid.
InvalidDeviceException | The requested device type is not valid.
InvalidMeshException | The mesh is invalid.
KeyframedAnimationSet | Implements a keyframe animation set.
Light | Defines a set of lighting properties.
LightsCollection | Defines a collection of lights.
Line | Implements line drawing using textured triangles.
LoadedMeshHasNoDataException | The mesh has no data.
LoadUserData | Derived by the application to allocate or free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.
Manager | Provides information about the environment, and enumerates and retrieves device capabilities.
Mesh | Manipulates mesh objects.
MeshContainer | Encapsulates a mesh object in a transformation frame hierarchy.
MoreDataException | More data is available than the specified buffer size can hold.
NotAvailableException | This device does not support the queried technique.
NotFoundException | The requested item was not found.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
PatchMesh | Provides patch mesh functionality.
PixelShader | Encapsulates the functionality of a pixel shader.
PresentParameters | Describes the presentation parameters.
ProgressiveMesh | Manipulates progressive mesh objects.
PrtBuffer | Used as a data buffer to store vertex and pixel data for use with precomputed radiance transfer (PRT) methods and functions.
PrtCompressedBuffer | Stores a compressed version of a PrtBuffer object for use with principal component analysis (PCA).
PrtEngine | The PrtEngine class is used to compute a PRT simulation. Its methods are typically used offline to compute per-vertex or per-texel transfer vectors in advance of real-time 3-D modeling.
Query | Performs asynchronous queries on a driver.
RenderStateManager | Defines device render states.
RenderToEnvironmentMap | Generalizes the process of rendering to environment maps. An environment map is used to texture-map scene geometry to provide a more sophisticated scene without using complex geometry. This class supports the creation of surfaces for the following kinds of geometry: cube, half sphere or hemispheric, parabolic, and sphere.
RenderToSurface | Generalizes the process of rendering to surfaces. Surfaces can be used in a variety of ways; for example, as render targets, or for off-screen rendering and rendering to textures.
Resource | Queries and prepares resources.
SamplerStateManager | Contains sampler states for the device.
SamplerStateManagerCollection | Collection of SamplerStateManager objects.
SaveUserData | Implemented by the application to save frame and mesh container objects.
ShaderLoader | Encapsulates the functionality for loading shader objects.
SimplificationMesh | Manipulates simplification mesh objects.
SkinInformation | Manipulates bone matrices, which are used to skin vertex data for animation.
SkinningNotSupportedException | Skinning is not supported.
SphericalHarmonics | Encapsulates spherical harmonic (SH) mathematical functions.
Sprite | Provides methods and properties that simplify the process of drawing sprites using Direct3D.
StateBlock | Encapsulates render states.
Surface | Queries and prepares surfaces.
SurfaceLoader | Loads and saves surfaces.
SwapChain | Manipulates a swap chain.
Texture | Manipulates a texture resource.
TextureGutterHelper | Used to build and manage gutter regions in a texture. Gutter regions separate textures and allow for bilinear interpolation to avoid rendering artifacts at texture boundaries.
TextureLoader | Contains functions to load and save textures.
TextureShader | Encapsulates the functionality of a texture shader.
TextureStateManager | Contains texture states for the device.
TextureStateManagerCollection | Collection of TextureStateManager objects.
TooManyInfluencesException | Too many influences specified.
TooManyOperationsException | The application is requesting more texture-filtering operations than the device supports.
Transforms | Allows applications to specify and obtain matrix transformations; for example, the world, view, and transformation matrices used for Direct3D object rendering.
UnsupportedAlphaArgumentException | The device does not support a specified texture-blending argument for the alpha channel.
UnsupportedAlphaOperationException | The device does not support a specified texture-blending operation for the alpha channel.
UnsupportedColorArgumentException | The device does not support a specified texture-blending argument for color values.
UnsupportedColorOperationException | The device does not support a specified texture-blending operation for color values.
UnsupportedFactorValueException | The device does not support the specified texture factor value. Not used; provided only to support older drivers.
UnsupportedTextureFilterException | The device does not support the specified texture filter.
VertexBuffer | Manipulates vertex buffer resources.
VertexDeclaration | Encapsulates the vertex shader declaration.
VertexInformation | Retrieves vertex information.
VertexShader | Encapsulates the functionality of a vertex shader.
VertexTextureCoordinate | Constructs bit patterns that are used to identify texture coordinate formats in a flexible vertex format description.
Volume | Manipulates volume resources.
VolumeLoader | Contains functions for loading and saving volumes.
VolumeTexture | Manipulates a volume texture resource.
WasStillDrawingException | The device was still drawing.
WrongTextureFormatException | The pixel format of the texture surface is not valid.
XFile | Retrieves information about XFile file objects.
XFileData | Builds or accesses the immediate hierarchy of a data object.
XFileGuid | Provides various GUID values for use with XFiles (.x files).
XFileManager | Manages XFile (.x) objects.
XFileSaveData | Applications use the methods of the XFileSaveData class to add data objects as children of a .x file data node.
XFileSaveObject | Creates and saves data objects and templates.

Enumerations

AnimationOutputFlags | Defines the flags used to create an AnimationOutput object.
BackBufferType | Defines constants that identify the type of back buffers in a swap chain.
BasisType | Defines the basis type of a high-order patch surface.
Blend | Defines the supported . (The RGBA values of the source and destination are indicated by the subscripts s and d.)
BlendOperation | Defines the supported blend operations.
CallbackSearchFlags | Defines the flags used to obtain callback information.
Channel | Defines flags that specify which channels in a texture to operate on.
CharacterSet | Defines a character set.
CleanType | Defines vertex operations to perform in preparation for mesh cleaning.
ClearFlags | Specifies the buffer to use when calling the Device.Clear method.
ClipStatusFlags | Defines the current clip status.
ColorSource | Defines the location at which a color or color component must be accessed for lighting calculations.
ColorWriteEnable | Defines values that are used to specify a channel in the RenderStateManager class type.
Compare | Defines the supported compare functions in the RenderStateManager class type.
CompressionFlags | Defines the compression mode to use for storing compressed animation set data.
CompressionQuality | Defines SH compression settings.
CreateFlags | Defines the flags to use when creating a device.
CubeMapFace | Defines the faces of a cube map in the CubeTexture class type.
Cull | Defines the supported culling modes, which specify how back faces are culled during geometry rendering.
DeclarationMethod | Defines the declaration methods for a vertex declaration.
DeclarationType | Defines declaration types for a vertex declaration.
DeclarationUsage | Defines declaration usage for a vertex declaration.
DegreeType | Defines the degree of the variables in an equation that describes a curve.
DepthFormat | Defines depth buffer formats.
DeviceType | Specifies a device type.
DisplacementMap | Identifies a texture sampler stage.
DrawTextFormat | Specifies the method of formatting text.
EffectDefaultType | Defines effect data types.
EventType | Defines the types of events that can be keyed by the animation controller.
FillMode | Defines constants that describe the fill mode.
Filter | Defines texture filtering modes for a texture stage.
FogMode | Defines constants that describe the fog mode.
FontQuality | Specifies the level of font quality.
FontWeight | Specifies font weights.
Format | Defines various types of surface formats. For a more complete discussion, see Surface Formats.
FX | Defines flags for saving shader state.
GpuSimulatorOption | Describes the resolution of the shadow z-buffer that will be used in PRT direct lighting simulation on the graphics processing unit (GPU). A higher quality z-buffer can also be specified to reduce noise in the results of the direct lighting simulation, although the simulation will be slower.
ImageFileFormat | Defines the supported image file formats.
IncludeType | Defines an include file.
IssueFlags | Defines issue flags.
LightType | Defines the light type.
LockFlags | Defines the type of lock to perform.
MeshFlags | Defines flags used to specify creation options for a mesh.
MultiSampleType | Defines the levels of full-scene multisampling that the device can apply.
NormalMap | Defines the flags used to convert a height map into a normal map.
ParameterClass | Defines the class of the object.
ParameterFlags | Defines shader and effect constants.
ParameterType | Defines the data contained by the enumeration.
PatchEdge | Defines whether the current tessellation mode is discrete or continuous.
PatchType | Defines mesh patch types.
PitchAndFamily | Defines font families.
PlaybackType | Defines the type of looping mode to use for playback of an animation set.
Pool | Defines the memory class that holds buffers for a resource.
Precision | Specifies the desired output precision.
Present | Defines flags that allow the application to request that the SwapChain.Present return immediately when the driver reports that it cannot schedule a presentation.
PresentFlag | Defines flags that control a Device.Present operation.
PresentInterval | Defines flags that describe the relationship between the adapter refresh rate and the rate at which Device.Present operations are completed.
PrimitiveType | Defines the primitives supported by Direct3D.
PriorityType | Defines the priority type an animation track is assigned to.
QueryType | Defines the query type.
RegisterSet | Defines the data type of the register.
RenderStates | Defines device render states.
RenderTargetsMax | Defines the maximum number of simultaneous render targets supported.
ResourceType | Defines resource types.
ResultCode | Defines result codes.
SamplerStageStates | Defines the sampler state types.
ShadeMode | Defines constants that describe the supported shading modes.
ShaderFlags | Defines the compiler options to use during a shader compilation.
SpriteFlags | Defines flags used to specify sprite rendering options.
StateBlockType | Defines logical groups of device states.
StencilOperation | Defines the supported stencil operations.
SwapEffect | Defines swap effects.
TextureAddress | Defines constants that describe the supported texture-addressing modes.
TextureArgument | Defines the supported texture arguments.
TextureCoordinateIndex | Defines the supported texture coordinate index values.
TextureFilter | Defines texture filtering modes for a texture stage.
TextureOperation | Defines per-stage texture-blending operations.
TextureStageStates | Defines texture stage states.
TextureTransform | Defines texture-stage state values.
TransformType | Defines constants that describe transformation state values.
TransitionType | Defines the transition style between values of a mesh animation.
Usage | Defines supported usage types for the current resource.
VertexBlend | Defines enumerated values used to control the number of matrices that the system applies when performing multimatrix vertex blending.
VertexFormats | Describes values that define a vertex format used to describe the contents of vertices that are stored interleaved in a single data stream.
WeldEpsilonsFlags | Defines the options for welding vertices together.
Wrap | Defines texture wrapping.
WrapCoordinates | Defines supported wrap coordinates.
XFileErrorCodes | Defines XFile error codes. The methods used to work with Microsoft DirectX® XFiles can return the following return values. Exceptions thrown from methods that use XFiles can also contain these values.
XFileFormat | Defines file formats for XFiles.

Structures

AdapterDetails | Contains information that identifies the adapter.
AddressCaps | Contains the texture addressing capabilities for Texture objects.
AnimationRootFrame | Contains the root frame and animation controller in a frame hierarchy.
AttributeRange | Stores an attribute table entry.
AttributeWeights | Specifies mesh weight attributes.
BandwidthTimings | Provides throughput measurement comparisons for help in understanding the performance of an application.
BehaviorFlags | Contains a set of properties that indicate the global behavior of a device.
BlendCaps | Indicates the supported capabilities.
BoneCombination | Describes a subset of the mesh that has the same attribute and bone combination.
BoneInfluences | Describes the vertices and weights that a bone influences.
Box | Defines a volume.
CacheUtilization | Measures the cache hit rate performance for textures and indexed vertices.
CallbackData | Retrieves information about animation callbacks.
Caps | Represents the capabilities of the hardware exposed through the Direct3D object.
ClipStatus | Describes the current clip status.
ColorValue | Stores the red, green, blue, and alpha channel values that together define a specific color.
ComparisonCaps | Retrieves comparison capabilities.
ConstantDescription | Describes a constant in a constant table.
ConstantTableDescription | Describes the constant table.
CubeTextureRequirements | Contains cube texture creation parameters.
CursorCaps | Indicates the hardware support that is available for cursors.
CustomVertex.PositionColored | Describes a custom vertex format structure that contains position and color information.
CustomVertex.PositionColoredTextured | Describes a custom vertex format structure that contains position, color, and one set of texture coordinates.
CustomVertex.PositionNormal | Describes a custom vertex format structure that contains position and normal data.
CustomVertex.PositionNormalColored | Describes a custom vertex format structure that contains position, color, and normal data.
CustomVertex.PositionNormalTextured | Describes a custom vertex format structure that contains position, normal data, and one set of texture coordinates.
CustomVertex.PositionOnly | Describes a custom vertex format structure that contains only position data.
CustomVertex.PositionTextured | Describes a custom vertex format structure that contains position and one set of texture coordinates.
CustomVertex.Transformed | Describes a custom vertex format structure that contains transformed vertices.
CustomVertex.TransformedColored | Describes a custom vertex format structure that contains transformed vertices and color information.
CustomVertex.TransformedColoredTextured | Describes a custom vertex format structure that contains transformed vertices, color, and one set of texture coordinates.
CustomVertex.TransformedTextured | Describes a custom vertex format structure that contains transformed vertices and one set of texture coordinates.
DeclarationTypeCaps | Indicates the type of data formats that are supported in a vertex declaration.
DegenerateItems | Indicates the index of patches and vertices that cause the PatchMesh.Validate method to fail.
DeviceCaps | Retrieves device-specific information about a device.
DeviceCreationParameters | Describes the creation parameters for a device.
DisplacementParameter | Contains mesh geometry displacement parameters.
DisplayMode | Describes the display mode.
DriverCaps | Indicates driver-specific capabilities.
EffectDefault | Manages a default effect parameter.
EffectDescription | Describes an effect object.
EffectInstance | Manages a set of default effect parameters.
EventDescription | Describes an animation event.
ExtendedMaterial | Returns material information that is saved in DirectX (.x) files.
FilterCaps | Indicates texture filter capabilities.
FontDescription | Defines the attributes of a font.
FormatList | Contains a list of formats supported by the device.
FragmentDescription | Describes an annotation used by an effect object.
FunctionDescription | Describes a function used by an effect.
GammaRamp | Contains red, green, and blue ramp data.
GlyphMetricsFloat | Contains information about the position and orientation of the corresponding glyph in the string.
ImageInformation | Contains a description of the original contents of an image file.
IndexBufferDescription | Describes an index buffer.
InterfaceTimings | Provides percentage of time processing data in the driver. These statistics may help identify cases when the driver is waiting for other resources.
IntersectInformation | Describes the intersection of a ray and a triangle.
KeyCallback | Describes a callback key for use in keyframe animation.
KeyQuaternion | Describes a quaternion key for use in keyframe animation, and specifies a quaternion value at a given time.
KeyVector3 | Describes a vector key for use in keyframe animation, and specifies a vector at a given time.
LineCaps | Defines the capabilities for line-drawing primitives.
LinePattern | Describes a line pattern.
LockedBox | Describes a locked box (volume).
Macro | Describes preprocessor definitions used by an effect object.
Material | Specifies material properties.
MeshData | Contains mesh data.
MeshOptions | Specifies the type of mesh optimization to perform.
MiscCaps | Contains miscellaneous driver primitive capabilities.
MyD3DXAllocateHierarchy | Not supported.
MyD3DXAnimationCallback | Not supported.
MyD3DXFrame | Not supported.
MyD3DXIncludeClass | Not supported.
MyD3DXLoadUserData | Not supported.
MyD3DXMeshContainer | Not supported.
MyD3DXSaveUserData | Not supported.
PaletteEntry | Specifies the color and usage of an entry in a logical palette.
ParameterDescription | Describes a parameter that is used for an effect object.
PassDescription | Describes a pass for an effect object.
PatchInformation | Contains the attributes of a patch mesh.
PipelineTimings | Provides percentage of time spent processing data in the pipeline.
PixelShaderCaps | Contains pixel shader capabilities.
PropertyDescription | Describes a property used for an effect object.
PrtSplitMeshClusterData | Contains PRT split mesh cluster data.
PrtSplitMeshVertexData | Contains PRT split mesh vertex data.
RasterCaps | Contains information about raster drawing capabilities.
RasterStatus | Describes the raster status.
RectanglePatchInformation | Describes a rectangular high-order patch.
RenderToEnvironmentDescription | Describes an off-screen render target.
RenderToSurfaceDescription | Describes a render surface.
ResourceManager | Contains resource manager usage statistics.
ResourceStats | Contains information about the resource manager.
ScaleRotateTranslate | Encapsulates scale, rotate and translate structures.
Semantic | Maps a parameter to vertex or pixel shader registers.
ShadeCaps | Defines shading operation capabilities.
ShaderConstantInformation | Contains shader constant information.
ShaderConstantTable | Contains the shader constant table that is embedded inside the shader.
ShaderDebugInformation | Contains shader debug information.
ShaderFileInformation | Contains information about the shader file.
ShaderInstructionInformation | Contains data for retrieving shader instruction information.
ShaderStructMemberInformation | Contains the shader structure member information.
ShaderTypeInformation | Contains shader type information.
ShaderVariableInformation | Contains shader variable information.
ShaderWriteInformation | Contains the shader write information.
SkinMesh | Contains skin information and mesh data.
SphericalHarmonicMaterial | Contains SH PRT material characteristics.
StageTimings | Provides percentage of time spent processing shader data.
StencilCaps | Contains flags that specify supported stencil-buffer operations.
SurfaceDescription | Describes a surface.
TechniqueDescription | Describes a technique used by an effect.
TextureCaps | Contains miscellaneous texture-mapping capabilities.
TextureOperationCaps | Contains values that describe the texture operations that the current device supports.
TextureRequirements | Contains texture creation parameters.
TrackDescription | Describes an animation track and specifies its weight and speed at a given time.
TrianglePatchInformation | Describes a triangular high-order patch.
ValidateDeviceParams | Describes the number of passes and the result code returned from a ValidateDevice call.
VertexBufferDescription | Describes a vertex buffer.
VertexCache | Defines vertex cache optimization hints.
VertexElement | Defines input vertex data to the pipeline.
VertexFormatCaps | Specifies the flexible vertex format (FVF) capabilities supported by a device.
VertexProcessingCaps | Describes vertex processing capabilities.
VertexShaderCaps | Describes vertex shader capabilities.
VertexStats | Reports the number of triangles that have been processed and clipped by the runtime's software vertex processing.
Viewport | Defines the window dimensions of a render target surface onto which a 3-D volume projects.
VolumeDescription | Describes a volume.
VolumeTextureRequirements | Contains volume texture creation parameters.
WeldEpsilons | Specifies a per-vertex value that is used to weld similar vertices together.

Delegates

Fill2DTextureCallback | Represents the method that handles the FillTexture(Texture,Fill2DTextureCallback) call.
Fill3DTextureCallback | Represents the method that handles the FillTexture(VolumeTexture,Fill3DTextureCallback) or FillTexture(CubeTexture,Fill3DTextureCallback) call.
HandleAnimationCallback | This delegate is used to handle callbacks triggered by KeyCallbacks in an animation track.
PrtEngineCallback | Represents an optional callback method that computes the percentage of SH computations completed and gives the caller the option of aborting the simulator.

Related Topics

  • Microsoft.DirectX


Microsoft.DirectX.Direct3D.AdapterInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates adapter information.

Definition

Visual Basic .NET NotInheritable Public Class AdapterInformation
Inherits Object
C# | public sealed class AdapterInformation : Object
Managed C++ | public __gc __sealed class AdapterInformation : public Object
JScript .NET | public class AdapterInformation extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
GetWhqlInformation | Retrieves adapter information that includes Windows Hardware Quality Labs (WHQL) information.

Properties

Property | Description
Adapter | Retrieves the adapter ordinal number.
CurrentDisplayMode | Retrieves the current display mode.
Information | Retrieves information about the current adapter.
SupportedDisplayModes | Returns a collection of supported display modes for the current adapter.

Inheritance Hierarchy

Object Leave Site
AdapterInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AdapterInformation.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


AdapterInformation.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


AdapterInformation.GetWhqlInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation.GetWhqlInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves adapter information that includes Windows Hardware Quality Labs (WHQL) information.

Definition

Visual Basic .NET | Public Function GetWhqlInformation() As AdapterDetails
C# | public AdapterDetails GetWhqlInformation();
Managed C++ | public: AdapterDetails GetWhqlInformation();
JScript .NET | public function GetWhqlInformation() : AdapterDetails;

Return Value

Microsoft.DirectX.Direct3D.AdapterDetails . An AdapterDetails structure that contains the adapter information.

Remarks

This method returns information about a specific hardware device and its drivers.


AdapterInformation.Adapter

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation.Adapter Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the adapter ordinal number.

Definition

Visual Basic .NET | Public ReadOnly Property Adapter As Integer
C# | public int Adapter { get; }
Managed C++ | public: __property int get_Adapter();
JScript .NET | public function get Adapter() : int

Property Value

System.Int32 . Integer that specifies the adapter to retrieve.

This property is read-only.


AdapterInformation.CurrentDisplayMode

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation.CurrentDisplayMode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current display mode.

Definition

Visual Basic .NET | Public ReadOnly Property CurrentDisplayMode As DisplayMode
C# | public DisplayMode CurrentDisplayMode { get; }
Managed C++ | public: __property DisplayMode get_CurrentDisplayMode();
JScript .NET | public function get CurrentDisplayMode() : DisplayMode

Property Value

Microsoft.DirectX.Direct3D.DisplayMode . A DisplayMode structure that represents the current display mode.

This property is read-only.


AdapterInformation.Information

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation.Information Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about the current adapter.

Definition

Visual Basic .NET | Public ReadOnly Property Information As AdapterDetails
C# | public AdapterDetails Information { get; }
Managed C++ | public: __property AdapterDetails get_Information();
JScript .NET | public function get Information() : AdapterDetails

Property Value

Microsoft.DirectX.Direct3D.AdapterDetails . An AdapterDetails structure that represents the current adapter information.

This property is read-only.


AdapterInformation.SupportedDisplayModes

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterInformation.SupportedDisplayModes Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns a collection of supported display modes for the current adapter.

Definition

Visual Basic .NET | Public ReadOnly Property SupportedDisplayModes As DisplayModeCollection
C# | public DisplayModeCollection SupportedDisplayModes { get; }
Managed C++ | public: __property DisplayModeCollection* get_SupportedDisplayModes();
JScript .NET | public function get SupportedDisplayModes() : DisplayModeCollection

Property Value

Microsoft.DirectX.Direct3D.DisplayModeCollection . A DisplayModeCollection class containing DisplayMode structures that represent the supported display modes for the adapter.

This property is read-only.


Microsoft.DirectX.Direct3D.AdapterListCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates a collection of adapters.

Definition

Visual Basic .NET NotInheritable Public Class AdapterListCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class AdapterListCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class AdapterListCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class AdapterListCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetEnumerator | Returns an enumerator that can iterate through the AdapterListCollection.
GetHashCode | Returns the hash code for the current instance.
MoveNext | Advances the enumerator to the next light.
Reset | Resets the current enumerator to point to the head of the queue.

Properties

Property | Description
Count | Retrieves the number of AdapterInformation objects in AdapterListCollection.
Current | Retrieves the current AdapterInformation object in the queue.
Default | Retrieves the default adapter.
Item | Retrieves a specific AdapterInformation object using an index value.

Inheritance Hierarchy

Object Leave Site
AdapterListCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AdapterListCollection.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


AdapterListCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an enumerator that can iterate through the AdapterListCollection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator . Enumerator that can iterate through the AdapterListCollection.


AdapterListCollection.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


AdapterListCollection.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next light.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean . Value that is true if the move to the next item was successful, or false if it was not.


AdapterListCollection.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the current enumerator to point to the head of the queue.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the queue.

After Reset Leave Site is called, the cursor is undefined. Call MoveNext Leave Site initially to point to the first item in the list.


AdapterListCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of AdapterInformation objects in AdapterListCollection.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 . Number of AdapterInformation objects in AdapterListCollection.

This property is read-only.


AdapterListCollection.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current AdapterInformation object in the queue.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object . Current AdapterInformation object in the queue.

This property is read-only.


AdapterListCollection.Default

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.Default Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default adapter.

Definition

Visual Basic .NET | Public ReadOnly Property Default As AdapterInformation
C# | public AdapterInformation Default { get; }
Managed C++ | public: __property AdapterInformation* get_Default();
JScript .NET | public function get Default() : AdapterInformation

Property Value

Microsoft.DirectX.Direct3D.AdapterInformation . An AdapterInformation object that represents the default adapter.

This property is read-only.


AdapterListCollection.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterListCollection.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a specific AdapterInformation object using an index value.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal adapter As Integer _
) As AdapterInformation
C# public AdapterInformation this[
int adapter
] { get; }
Managed C++ public: __property AdapterInformation* get_Item(
int adapter
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.Direct3D.AdapterInformation . An AdapterInformation object at the param_Int32_index.

This property is read-only.

Parameters

adapter System.Int32. Index value of the adapter to retrieve.


Microsoft.DirectX.Direct3D.AllocateHierarchy

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocateHierarchy Class

Language:
Note: This documentation is preliminary and is subject to change.

Derived by the application to allocate/free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.

Definition

Visual Basic .NET MustInherit Public Class AllocateHierarchy
Inherits Object
C# | public abstract class AllocateHierarchy : Object
Managed C++ | public __gc __abstract class AllocateHierarchy : public Object
JScript .NET | public abstract class AllocateHierarchy extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AllocateHierarchy | Initializes a new instance of the AllocateHierarchy class.
CreateFrame | Requests allocation of a frame object.
CreateMeshContainer | Requests allocation of a MeshContainer object.
Finalize | Allows the AllocateHierarchy object to free resources before it is destroyed by the garbage collector.

Inheritance Hierarchy

Object Leave Site
AllocateHierarchy

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AllocateHierarchy.AllocateHierarchy()

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocateHierarchy.AllocateHierarchy Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AllocateHierarchy class.

Definition

Visual Basic .NET | Public Sub New()
C# | public AllocateHierarchy();
Managed C++ | public: AllocateHierarchy();
JScript .NET | public function AllocateHierarchy();


AllocateHierarchy.CreateFrame(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocateHierarchy.CreateFrame Method

 Language:
Note: This documentation is preliminary and is subject to change.

Requests allocation of a frame object.

Definition

Visual Basic .NET MustOverride Public Function CreateFrame( _
ByVal name As String _
) As Frame
C# public abstract Frame CreateFrame(
string name
);
Managed C++ public: virtual Frame* CreateFrame(
String *name
) = 0;
JScript .NET public abstract function CreateFrame(
name : String
) : Frame;

Parameters

name System.String. Name of the frame to create.

Return Value

Microsoft.DirectX.Direct3D.Frame . Created frame object.


AllocateHierarchy.CreateMeshContainer(String,MeshData,ExtendedMaterial[],EffectInstance[],GraphicsStream,SkinInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocateHierarchy.CreateMeshContainer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Requests allocation of a MeshContainer object.

Definition

Visual Basic .NET MustOverride Public Function CreateMeshContainer( _
ByVal name As String, _
ByVal meshData As MeshData, _
ByVal materials() As ExtendedMaterial, _
ByVal effectInstances() As EffectInstance, _
ByVal adjacency As GraphicsStream, _
ByVal skinInfo As SkinInformation _
) As MeshContainer
C# public abstract MeshContainer CreateMeshContainer(
string name,
MeshData meshData,
ExtendedMaterial[] materials,
EffectInstance[] effectInstances,
GraphicsStream adjacency,
SkinInformation skinInfo
);
Managed C++ public: virtual MeshContainer* CreateMeshContainer(
String *name,
MeshData meshData,
ExtendedMaterial materials __gc[],
EffectInstance effectInstances __gc[],
GraphicsStream *adjacency,
SkinInformation *skinInfo
) = 0;
JScript .NET public abstract function CreateMeshContainer(
name : String,
meshData : MeshData,
materials : ExtendedMaterial[],
effectInstances : EffectInstance[],
adjacency : GraphicsStream,
skinInfo : SkinInformation
) : MeshContainer;

Parameters

name | System.String. String that represents the name of the mesh.
meshData | Microsoft.DirectX.Direct3D.MeshData. Reference to a MeshData structure.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures used in the mesh.
effectInstances | Microsoft.DirectX.Direct3D.EffectInstance[]. Array of EffectInstance structures used in the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. Array of GraphicsStream objects that represent an adjacency array for the mesh.
skinInfo | Microsoft.DirectX.Direct3D.SkinInformation. Reference to the SkinInformation object, if skin data is found.

Return Value

Microsoft.DirectX.Direct3D.MeshContainer . Created MeshContainer.


AllocateHierarchy.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocateHierarchy.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the AllocateHierarchy object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~AllocateHierarchy();
Managed C++ | ~AllocateHierarchy();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Microsoft.DirectX.Direct3D.AnimationController

AnimationController Class

Note: This documentation is preliminary and is subject to change.

Controls animation functionality, connecting animation sets to the transformation frames being animated.

Definition

Visual Basic .NET NotInheritable Public Class AnimationController
Inherits Object
Implements ICloneable, IDisposable
C# public sealed class AnimationController : Object,
ICloneable, IDisposable
Managed C++ public __gc __sealed class AnimationController : public Object,
ICloneable, IDisposable
JScript .NET public class AnimationController extends Object
implements IDisposable, ICloneable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the AnimationController object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AdvanceTime | Animates the mesh and advances the global animation time by a specified amount.
AnimationController | Initializes a new instance of the AnimationController class.
Clone | Clones, or copies, an animation controller.
Dispose | Immediately releases the unmanaged resources used by the AnimationController object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the AnimationController object to free resources before it is destroyed by the garbage collector.
GetAnimationSet | Retrieves the animation set.
GetCurrentPriorityBlend | Returns an event handle to a priority blend event that is currently running.
GetCurrentTrackEvent | Returns an event handle to the event that is currently running on the specified animation track.
GetEventDescription | Retrieves a description of a specified animation event.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetTrackAnimationSet | Retrieves the animation set for a given track.
GetTrackDescription | Retrieves the description for a track.
GetUpcomingPriorityBlend | Returns an event handle to the next priority blend event scheduled to occur after a specified event.
GetUpcomingTrackEvent | Returns an event handle to the next event scheduled to occur after a specified event on an animation track.
IsEventValid | Determines whether a specified event handle is valid and an animation event has completed.
KeyPriorityBlend | Sets blending event keys for the specified animation track.
KeyTrackEnable | Sets an event key that enables or disables an animation track.
KeyTrackPosition | Sets an event key that changes the local time of an animation track.
KeyTrackSpeed | Sets an event key that changes the local time of an animation track.
KeyTrackWeight | Sets an event key that changes the weight of an animation track.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.AnimationController.Disposing event when called from within a derived class.
RegisterAnimationOutput | Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.
RegisterAnimationSet | Adds an animation set to the animation controller.
ResetTime | Resets the global animation time to zero. Any pending events retain their original schedules, but in the new time frame.
SetTrackAnimationSet | Applies the animation set to the specified track.
SetTrackDescription | Sets the track description.
SetTrackEnable | Enables or disables a track in the animation controller.
SetTrackPosition | Sets the track to the specified local animation time.
SetTrackPriority | Sets the priority blending weight for the specified animation track.
SetTrackSpeed | Sets the priority blending weight for the specified animation track.
SetTrackWeight | Sets the track weight, which is used to determine how to blend multiple tracks together.
UnkeyAllPriorityBlends | Removes all scheduled priority blend events from the animation controller.
UnkeyAllTrackEvents | Removes all events from a specified animation track.
UnkeyEvent | Removes a specified event from an animation track, preventing the event from being run.
UnregisterAnimationOutput | Removes an animation output from the animation controller.
UnregisterAnimationSet | Removes an animation set from the animation controller.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationController object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
ValidateEvent | Determines whether a specified event handle is valid and the animation event has completed.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
MaxNumberAnimationOutputs | Retrieves the maximum number of animation outputs the controller can support.
MaxNumberAnimationSets | Retrieves the maximum number of animation sets the controller can support.
MaxNumberEvents | Retrieves the maximum number of events the controller can support.
MaxNumberTracks | Retrieves the maximum number of tracks in the mixer.
NumberAnimationSets | Returns the number of animation sets currently registered in the animation controller.
PriorityBlend | Retrieves or sets the track blending weight.
Time | Retrieves the local animation time.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXAnimationController interface pointer.

Inheritance Hierarchy

Object Leave Site
AnimationController

Remarks

The methods of this class mix multiple animations and modify blending parameters over time to enable smooth transitions and other effects.

An AnimationController is typically obtained from a valid DirectX (.x) file loaded into an AnimationRootFrame. This structure has an AnimationController property that exposes the AnimationController. The following C# code example demonstrates how to create an AnimationController from a file. The allocH variable is an instance of a class derived from AllocateHierarchy. The device variable is the current rendering Device.

[C#]
  ...
    AnimationRootFrame animRoot = new AnimationRootFrame();

    animRoot = Mesh.LoadHierarchyFromFile("tiny.x", MeshFlags.Managed, device, allocH, null);

    AnimationController animController = animRoot.AnimationController;
  ...
The AnimationController can then be used to play and manipulate the animations loaded from the file.

An AnimationController class loaded from a file typically has a number of animation tracks, each of which is identified by an index value. Using SetTrackAnimationSet, an AnimationSet (or a class derived from one) can be assigned to a track. The AnimationController class can then blend the animations in different tracks to create one smooth animation.

The AnimationController class also provides methods that allow changes to be made to each track over time. Key values that enable or disable a track (KeyTrackEnable) or change a track's speed (KeyTrackSpeed), its position in time (KeyTrackPosition), its weight (KeyTrackWeight), and its blend values (KeyPriorityBlend) can be set for specific times.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.AdvanceTime

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.AdvanceTime Method

 Language:
Note: This documentation is preliminary and is subject to change.

Animates the mesh and advances the global animation time by a specified amount.

Overload List

public void AdvanceTime(double);
public void AdvanceTime(double, HandleAnimationCallback);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.AdvanceTime(Double)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.AdvanceTime Method

 Language:
Note: This documentation is preliminary and is subject to change.

Animates the mesh and advances the global animation time by a specified amount.

Definition

Visual Basic .NET Public Sub AdvanceTime( _
ByVal timeDelta As Double _
)
C# public void AdvanceTime(
double timeDelta
);
Managed C++ public: void AdvanceTime(
double timeDelta
);
JScript .NET public function AdvanceTime(
timeDelta : double
);

Parameters

timeDelta System.Double. Amount, in seconds, by which to advance the global animation time. This value must be non-negative or 0.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.AdvanceTime(Double,HandleAnimationCallback)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.AdvanceTime Method

 Language:
Note: This documentation is preliminary and is subject to change.

Animates the mesh and advances the global animation time by a specified amount.

Definition

Visual Basic .NET Public Sub AdvanceTime( _
ByVal timeDelta As Double, _
ByVal callbackHandler As HandleAnimationCallback _
)
C# public void AdvanceTime(
double timeDelta,
HandleAnimationCallback callbackHandler
);
Managed C++ public: void AdvanceTime(
double timeDelta,
HandleAnimationCallback *callbackHandler
);
JScript .NET public function AdvanceTime(
timeDelta : double,
callbackHandler : HandleAnimationCallback
);

Parameters

timeDelta | System.Double. Amount, in seconds, by which to advance the global animation time. This value must be non-negative or 0.
callbackHandler | Microsoft.DirectX.Direct3D.HandleAnimationCallback. A HandleAnimationCallback user-defined animation callback handler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.AnimationController

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.AnimationController Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationController class.

Overload List

public AnimationController(ID3DXAnimationController);
public AnimationController(int, int, int, int);
public AnimationController(IntPtr);

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.AnimationController(ID3DXAnimationController)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.AnimationController Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationController class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXAnimationController _
)
C# public AnimationController(
ID3DXAnimationController pUnk
);
Managed C++ public: AnimationController(
ID3DXAnimationController pUnk
);
JScript .NET public function AnimationController(
pUnk : ID3DXAnimationController
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationController. Unmanaged Component Object Model (COM) ID3DXAnimationController interface pointer.

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.AnimationController(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.AnimationController Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationController class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public AnimationController(
IntPtr unmanagedObject
);
Managed C++ public: AnimationController(
IntPtr unmanagedObject
);
JScript .NET public function AnimationController(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXAnimationController interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.AnimationController(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.AnimationController Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationController class.

Definition

Visual Basic .NET Public Sub New( _
ByVal maxNumberMatrices As Integer, _
ByVal maxNumberAnimationSets As Integer, _
ByVal maxNumberTracks As Integer, _
ByVal maxNumberEvents As Integer _
)
C# public AnimationController(
int maxNumberMatrices,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
Managed C++ public: AnimationController(
int maxNumberMatrices,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
JScript .NET public function AnimationController(
maxNumberMatrices : int,
maxNumberAnimationSets : int,
maxNumberTracks : int,
maxNumberEvents : int
);

Parameters

maxNumberMatrices | System.Int32. Maximum number of matrices that can be animated.
maxNumberAnimationSets | System.Int32. Maximum number of animation sets that can be mixed.
maxNumberTracks | System.Int32. Maximum number of animation sets that can be mixed simultaneously.
maxNumberEvents | System.Int32. Maximum number of outstanding events that the controller will support.

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.Clone(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones, or copies, an animation controller.

Definition

Visual Basic .NET Public Function Clone( _
ByVal maxNumberAnimationOutputs As Integer, _
ByVal maxNumberAnimationSets As Integer, _
ByVal maxNumberTracks As Integer, _
ByVal maxNumberEvents As Integer _
) As AnimationController
C# public AnimationController Clone(
int maxNumberAnimationOutputs,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
Managed C++ public: AnimationController* Clone(
int maxNumberAnimationOutputs,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
JScript .NET public function Clone(
maxNumberAnimationOutputs : int,
maxNumberAnimationSets : int,
maxNumberTracks : int,
maxNumberEvents : int
) : AnimationController;

Parameters

maxNumberAnimationOutputs | System.Int32. Maximum number of animation outputs the controller can support.
maxNumberAnimationSets | System.Int32. Maximum number of animation sets the controller can support.
maxNumberTracks | System.Int32. Maximum number of tracks the controller can support.
maxNumberEvents | System.Int32. Maximum number of events the controller can support.

Return Value

Microsoft.DirectX.Direct3D.AnimationController . A cloned AnimationController object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the AnimationController object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.AnimationController.Disposed
  • Microsoft.DirectX.Direct3D.AnimationController.Disposing


AnimationController.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


AnimationController.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the AnimationController object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~AnimationController();
Managed C++ | ~AnimationController();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


AnimationController.GetAnimationSet

AnimationController.GetAnimationSet Method

Note: This documentation is preliminary and is subject to change.

Retrieves the animation set.

Overload List

public AnimationSet GetAnimationSet(int);
public AnimationSet GetAnimationSet(string);

Remarks

The animation controller contains an array of animation sets. This method returns one of them at the given index or animationName.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.GetAnimationSet(String)

AnimationController.GetAnimationSet Method

Note: This documentation is preliminary and is subject to change.

Retrieves the animation set.

Definition

Visual Basic .NET Public Function GetAnimationSet( _
ByVal animationName As String _
) As AnimationSet
C# public AnimationSet GetAnimationSet(
string animationName
);
Managed C++ public: AnimationSet* GetAnimationSet(
String *animationName
);
JScript .NET public function GetAnimationSet(
animationName : String
) : AnimationSet;

Parameters

animationName System.String. A string that contains the name of the animation set to retrieve.

Return Value

Microsoft.DirectX.Direct3D.AnimationSet . An AnimationSet object at the given animationName.

Remarks

The animation controller contains an array of animation sets. This method returns one of them at the given index or animationName.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.GetAnimationSet(Int32)

AnimationController.GetAnimationSet Method

Note: This documentation is preliminary and is subject to change.

Retrieves the animation set.

Definition

Visual Basic .NET Public Function GetAnimationSet( _
ByVal index As Integer _
) As AnimationSet
C# public AnimationSet GetAnimationSet(
int index
);
Managed C++ public: AnimationSet* GetAnimationSet(
int index
);
JScript .NET public function GetAnimationSet(
index : int
) : AnimationSet;

Parameters

index System.Int32. An integer that represent the index of the animation set to retrieve.

Return Value

Microsoft.DirectX.Direct3D.AnimationSet . An AnimationSet object at the given index.

Remarks

The animation controller contains an array of animation sets. This method returns one of them at the given index or animationName.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.GetCurrentPriorityBlend()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetCurrentPriorityBlend Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an event handle to a priority blend event that is currently running.

Definition

Visual Basic .NET | Public Function GetCurrentPriorityBlend() As Integer
C# | public int GetCurrentPriorityBlend();
Managed C++ | public: int GetCurrentPriorityBlend();
JScript .NET | public function GetCurrentPriorityBlend() : int;

Return Value

System.Int32 . Priority event. If no priority blend event is currently running, a value of 0 is returned.


AnimationController.GetCurrentTrackEvent(Int32,EventType)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetCurrentTrackEvent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an event handle to the event that is currently running on the specified animation track.

Definition

Visual Basic .NET Public Function GetCurrentTrackEvent( _
ByVal track As Integer, _
ByVal eventType As EventType _
) As Integer
C# public int GetCurrentTrackEvent(
int track,
EventType eventType
);
Managed C++ public: int GetCurrentTrackEvent(
int track,
EventType eventType
);
JScript .NET public function GetCurrentTrackEvent(
track : int,
eventType : EventType
) : int;

Parameters

track | System.Int32. Track identifier.
eventType | Microsoft.DirectX.Direct3D.EventType. Type of event to query.

Return Value

System.Int32 . Event currently running on the specified track. If no event is running on the specified track, a value of 0 is returned.


AnimationController.GetEventDescription(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetEventDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a description of a specified animation event.

Definition

Visual Basic .NET Public Function GetEventDescription( _
ByVal eventHandle As Integer _
) As EventDescription
C# public EventDescription GetEventDescription(
int eventHandle
);
Managed C++ public: EventDescription GetEventDescription(
int eventHandle
);
JScript .NET public function GetEventDescription(
eventHandle : int
) : EventDescription;

Parameters

eventHandle System.Int32. Event handle to the animation event to describe.

Return Value

Microsoft.DirectX.Direct3D.EventDescription . An EventDescription structure that contains a description of the animation event.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


AnimationController.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXAnimationController, which allows unmanaged COM clients to create an instance of the managed AnimationController class. Not supported.


AnimationController.GetTrackAnimationSet(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetTrackAnimationSet Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the animation set for a given track.

Definition

Visual Basic .NET Public Function GetTrackAnimationSet( _
ByVal track As Integer _
) As AnimationSet
C# public AnimationSet GetTrackAnimationSet(
int track
);
Managed C++ public: AnimationSet* GetTrackAnimationSet(
int track
);
JScript .NET public function GetTrackAnimationSet(
track : int
) : AnimationSet;

Parameters

track System.Int32. Track identifier.

Return Value

Microsoft.DirectX.Direct3D.AnimationSet . An AnimationSet class for the given track.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.GetTrackDescription(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetTrackDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the description for a track.

Definition

Visual Basic .NET Public Function GetTrackDescription( _
ByVal trackNumber As Integer _
) As TrackDescription
C# public TrackDescription GetTrackDescription(
int trackNumber
);
Managed C++ public: TrackDescription GetTrackDescription(
int trackNumber
);
JScript .NET public function GetTrackDescription(
trackNumber : int
) : TrackDescription;

Parameters

trackNumber System.Int32. Track identifier.

Return Value

Microsoft.DirectX.Direct3D.TrackDescription . A TrackDescription structure.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.GetUpcomingPriorityBlend(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetUpcomingPriorityBlend Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an event handle to the next priority blend event scheduled to occur after a specified event.

Definition

Visual Basic .NET Public Function GetUpcomingPriorityBlend( _
ByVal eventHandle As Integer _
) As Integer
C# public int GetUpcomingPriorityBlend(
int eventHandle
);
Managed C++ public: int GetUpcomingPriorityBlend(
int eventHandle
);
JScript .NET public function GetUpcomingPriorityBlend(
eventHandle : int
) : int;

Parameters

eventHandle System.Int32. Event handle to the specified event. If set to 0, the method returns the next scheduled priority blend event.

Return Value

System.Int32 . Event handle to the next scheduled priority blend event. If no new priority blend event is scheduled, a value of 0 is returned.

Remarks

This method can be used iteratively to locate a desired priority blend event by repeatedly passing in 0 for param_Int32_eventHandle.

Note: Do not iterate further after the method returns 0.


AnimationController.GetUpcomingTrackEvent(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.GetUpcomingTrackEvent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an event handle to the next event scheduled to occur after a specified event on an animation track.

Definition

Visual Basic .NET Public Function GetUpcomingTrackEvent( _
ByVal track As Integer, _
ByVal eventHandle As Integer _
) As Integer
C# public int GetUpcomingTrackEvent(
int track,
int eventHandle
);
Managed C++ public: int GetUpcomingTrackEvent(
int track,
int eventHandle
);
JScript .NET public function GetUpcomingTrackEvent(
track : int,
eventHandle : int
) : int;

Parameters

track | System.Int32. Track identifier.
eventHandle | System.Int32. Event handle to the specified event. If set to 0, the method returns the next scheduled event.

Return Value

System.Int32 . Event handle to the next event scheduled to run on the specified track. If no new event is scheduled, a value of 0 is returned.

Remarks

This method can be used iteratively to locate a desired priority blend event by repeatedly passing in 0 for param_Int32_eventHandle.

Note: Do not iterate further after the method returns 0.


AnimationController.IsEventValid

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.IsEventValid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a specified event handle is valid and an animation event has completed.

Overload List

public bool IsEventValid(int);
public bool IsEventValid(int, out int);

Remarks

This method indicates whether an event handle is valid even if the event is still running.


AnimationController.IsEventValid(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.IsEventValid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a specified event handle is valid and an animation event has completed.

Definition

Visual Basic .NET Public Function IsEventValid( _
ByVal eventHandle As Integer _
) As Boolean
C# public bool IsEventValid(
int eventHandle
);
Managed C++ public: bool IsEventValid(
int eventHandle
);
JScript .NET public function IsEventValid(
eventHandle : int
) : boolean;

Parameters

eventHandle System.Int32. Event handle to the animation event.

Return Value

System.Boolean . Returns true if the method succeeds; false if it fails.

Remarks

This method indicates whether an event handle is valid even if the event is still running.


AnimationController.IsEventValid(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.IsEventValid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a specified event handle is valid and an animation event has completed.

Definition

Visual Basic .NET Public Function IsEventValid( _
ByVal eventHandle As Integer, _
ByRef result As Integer _
) As Boolean
C# public bool IsEventValid(
int eventHandle,
out int result
);
Managed C++ public: bool IsEventValid(
int eventHandle,
int *result
);
JScript .NET public function IsEventValid(
eventHandle : int,
result : int
) : boolean;

Parameters

eventHandle | System.Int32. Event handle to the animation event.
result | System.Int32. HRESULT code passed back from the method.

Return Value

System.Boolean . Returns true if the method succeeds; false if it fails.

Remarks

This method indicates whether an event handle is valid even if the event is still running.


AnimationController.KeyPriorityBlend(Single,Double,Double,TransitionType)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.KeyPriorityBlend Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets blending event keys for the specified animation track.

Definition

Visual Basic .NET Public Function KeyPriorityBlend( _
ByVal newBlendWeight As Single, _
ByVal startTime As Double, _
ByVal duration As Double, _
ByVal method As TransitionType _
) As Integer
C# public int KeyPriorityBlend(
float newBlendWeight,
double startTime,
double duration,
TransitionType method
);
Managed C++ public: int KeyPriorityBlend(
float newBlendWeight,
double startTime,
double duration,
TransitionType method
);
JScript .NET public function KeyPriorityBlend(
newBlendWeight : float,
startTime : double,
duration : double,
method : TransitionType
) : int;

Parameters

newBlendWeight | System.Single. Number between 0 and 1 that is used to blend tracks.
startTime | System.Double. Global time at which to start the blend.
duration | System.Double. Global time duration of the blend.
method | Microsoft.DirectX.Direct3D.TransitionType. Transition type used for the duration of the blend. For more information, see TransitionType.

Return Value

System.Int32 . Handle to the priority blend event. If one or more of the input parameters is invalid, or if no free event is available, a value of 0 is returned.

Remarks

The animation controller blends in three phases: low-priority tracks are blended first, high-priority tracks are blended second, and then the results of both are blended.

See Also

  • PriorityBlend


AnimationController.KeyTrackEnable(Int32,Boolean,Double)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.KeyTrackEnable Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an event key that enables or disables an animation track.

Definition

Visual Basic .NET Public Function KeyTrackEnable( _
ByVal track As Integer, _
ByVal newEnable As Boolean, _
ByVal startTime As Double _
) As Integer
C# public int KeyTrackEnable(
int track,
bool newEnable,
double startTime
);
Managed C++ public: int KeyTrackEnable(
int track,
bool newEnable,
double startTime
);
JScript .NET public function KeyTrackEnable(
track : int,
newEnable : boolean,
startTime : double
) : int;

Parameters

track | System.Int32. Identifier of the animation track to modify.
newEnable | System.Boolean. Set to true to enable the animation track. Set to false to disable the animation track.
startTime | System.Double. Global time key that specifies the global time at which the change will occur.

Return Value

System.Int32 . Priority blend event. If the track is invalid, a value of 0 is returned.


AnimationController.KeyTrackPosition(Int32,Double,Double)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.KeyTrackPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an event key that changes the local time of an animation track.

Definition

Visual Basic .NET Public Function KeyTrackPosition( _
ByVal track As Integer, _
ByVal newPosition As Double, _
ByVal startTime As Double _
) As Integer
C# public int KeyTrackPosition(
int track,
double newPosition,
double startTime
);
Managed C++ public: int KeyTrackPosition(
int track,
double newPosition,
double startTime
);
JScript .NET public function KeyTrackPosition(
track : int,
newPosition : double,
startTime : double
) : int;

Parameters

track | System.Int32. Identifier of the track to modify.
newPosition | System.Double. New local time of the animation track.
startTime | System.Double. Global time key that specifies the global time at which the change will occur.

Return Value

System.Int32 . Priority blend event. If track is invalid, or if no free event is available, a value of 0 is returned.


AnimationController.KeyTrackSpeed(Int32,Single,Double,Double,TransitionType)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.KeyTrackSpeed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an event key that changes the local time of an animation track.

Definition

Visual Basic .NET Public Function KeyTrackSpeed( _
ByVal track As Integer, _
ByVal newSpeed As Single, _
ByVal startTime As Double, _
ByVal duration As Double, _
ByVal method As TransitionType _
) As Integer
C# public int KeyTrackSpeed(
int track,
float newSpeed,
double startTime,
double duration,
TransitionType method
);
Managed C++ public: int KeyTrackSpeed(
int track,
float newSpeed,
double startTime,
double duration,
TransitionType method
);
JScript .NET public function KeyTrackSpeed(
track : int,
newSpeed : float,
startTime : double,
duration : double,
method : TransitionType
) : int;

Parameters

track | System.Int32. Identifier of the track to modify.
newSpeed | System.Single. New speed of the animation track.
startTime | System.Double. Global time key that specifies the global time at which the change will occur.
duration | System.Double. Transition time, which specifies how long the smooth transition will take to complete.
method | Microsoft.DirectX.Direct3D.TransitionType. Transition type used for transitioning between speeds. For more information, see TransitionType.

Return Value

System.Int32 . Event handle to the priority blend event. If one or more of the input parameters is invalid, or if no free event is available, a value of 0 is returned.


AnimationController.KeyTrackWeight(Int32,Single,Double,Double,TransitionType)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.KeyTrackWeight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an event key that changes the weight of an animation track.

Definition

Visual Basic .NET Public Function KeyTrackWeight( _
ByVal track As Integer, _
ByVal newWeight As Single, _
ByVal startTime As Double, _
ByVal duration As Double, _
ByVal method As TransitionType _
) As Integer
C# public int KeyTrackWeight(
int track,
float newWeight,
double startTime,
double duration,
TransitionType method
);
Managed C++ public: int KeyTrackWeight(
int track,
float newWeight,
double startTime,
double duration,
TransitionType method
);
JScript .NET public function KeyTrackWeight(
track : int,
newWeight : float,
startTime : double,
duration : double,
method : TransitionType
) : int;

Parameters

track | System.Int32. Identifier of the track to modify.
newWeight | System.Single. New weight of the track.
startTime | System.Double. Global time key that specifies the global time at which the change will occur.
duration | System.Double. Transition time, which specifies how long the smooth transition will take to complete.
method | Microsoft.DirectX.Direct3D.TransitionType. Transition type used for transitioning between weights. For more information, see TransitionType.

Return Value

System.Int32 . Event handle to the priority blend event. If one or more of the input parameters is invalid, or if no free event is available, a value of 0 is returned.

Remarks

The weight of an animation track is used as a multiplier to determine how much of the current track to blend with other tracks.


AnimationController.op_Equality(AnimationController,AnimationController)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As AnimationController, _
ByVal right As AnimationController _
) As Boolean
C# public static bool op_Equality(
AnimationController left,
AnimationController right
);
Managed C++ public: static bool op_Equality(
AnimationController *left,
AnimationController *right
);
JScript .NET public static function op_Equality(
left : AnimationController,
right : AnimationController
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.AnimationController. The AnimationController object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.AnimationController. The AnimationController object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


AnimationController.op_Inequality(AnimationController,AnimationController)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As AnimationController, _
ByVal right As AnimationController _
) As Boolean
C# public static bool op_Inequality(
AnimationController left,
AnimationController right
);
Managed C++ public: static bool op_Inequality(
AnimationController *left,
AnimationController *right
);
JScript .NET public static function op_Inequality(
left : AnimationController,
right : AnimationController
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.AnimationController. The AnimationController object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.AnimationController. The AnimationController object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


AnimationController.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.AnimationController.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


AnimationController.RegisterAnimationOutput

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.RegisterAnimationOutput Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.

Overload List

public void RegisterAnimationOutput(AnimationOutput);
public void RegisterAnimationOutput(Frame);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.RegisterAnimationOutput(Frame)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.RegisterAnimationOutput Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.

Definition

Visual Basic .NET Public Sub RegisterAnimationOutput( _
ByVal animationFrame As Frame _
)
C# public void RegisterAnimationOutput(
Frame animationFrame
);
Managed C++ public: void RegisterAnimationOutput(
Frame *animationFrame
);
JScript .NET public function RegisterAnimationOutput(
animationFrame : Frame
);

Parameters

animationFrame Microsoft.DirectX.Direct3D.Frame. A Frame object that encapsulates a transform frame in a transformation frame hierarchy. Uses the Frame.TransformationMatrix property.

Remarks

If the animation output is already registered, animationFrame. TransformationMatrix is filled with the input transformation data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.RegisterAnimationOutput(AnimationOutput)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.RegisterAnimationOutput Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.

Definition

Visual Basic .NET Public Sub RegisterAnimationOutput( _
ByVal output As AnimationOutput _
)
C# public void RegisterAnimationOutput(
AnimationOutput output
);
Managed C++ public: void RegisterAnimationOutput(
AnimationOutput *output
);
JScript .NET public function RegisterAnimationOutput(
output : AnimationOutput
);

Parameters

output Microsoft.DirectX.Direct3D.AnimationOutput. An AnimationOutput object that encapsulates the scale, rotate, and translate (SRT) transformations objects.

Remarks

If the animation output is already registered, output. Matrix is filled with the input transformation data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.RegisterAnimationSet(AnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.RegisterAnimationSet Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds an animation set to the animation controller.

Definition

Visual Basic .NET Public Sub RegisterAnimationSet( _
ByVal animationSet As AnimationSet _
)
C# public void RegisterAnimationSet(
AnimationSet animationSet
);
Managed C++ public: void RegisterAnimationSet(
AnimationSet *animationSet
);
JScript .NET public function RegisterAnimationSet(
animationSet : AnimationSet
);

Parameters

animationSet Microsoft.DirectX.Direct3D.AnimationSet. The AnimationSet to add.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.ResetTime()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.ResetTime Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the global animation time to zero. Any pending events retain their original schedules, but in the new time frame.

Definition

Visual Basic .NET | Public Sub ResetTime()
C# | public void ResetTime();
Managed C++ | public: void ResetTime();
JScript .NET | public function ResetTime();

Remarks

This method is typically used when the global animation time value nears the maximum precision of DOUBLE storage, or 264 - 1.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.SetTrackAnimationSet(Int32,AnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.SetTrackAnimationSet Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies the animation set to the specified track.

Definition

Visual Basic .NET Public Sub SetTrackAnimationSet( _
ByVal track As Integer, _
ByVal animationSet As AnimationSet _
)
C# public void SetTrackAnimationSet(
int track,
AnimationSet animationSet
);
Managed C++ public: void SetTrackAnimationSet(
int track,
AnimationSet *animationSet
);
JScript .NET public function SetTrackAnimationSet(
track : int,
animationSet : AnimationSet
);

Parameters

track | System.Int32. Identifier of the track to which the animation set is applied.
animationSet | Microsoft.DirectX.Direct3D.AnimationSet. The AnimationSet to add to the track.

Remarks

This method sets the animation set to the specified track for mixing. The animation set for each track is blended according to the track weight and speed when AnimationController.AdvanceTime is called.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.SetTrackDescription(Int32,TrackDescription)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.SetTrackDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the track description.

Definition

Visual Basic .NET Public Sub SetTrackDescription( _
ByVal trackNumber As Integer, _
ByVal value As TrackDescription _
)
C# public void SetTrackDescription(
int trackNumber,
TrackDescription value
);
Managed C++ public: void SetTrackDescription(
int trackNumber,
TrackDescription value
);
JScript .NET public function SetTrackDescription(
trackNumber : int,
value : TrackDescription
);

Parameters

trackNumber | System.Int32. Identifier of the track to modify.
value | Microsoft.DirectX.Direct3D.TrackDescription. Description of the track.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.SetTrackEnable(Int32,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.SetTrackEnable Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enables or disables a track in the animation controller.

Definition

Visual Basic .NET Public Sub SetTrackEnable( _
ByVal track As Integer, _
ByVal enable As Boolean _
)
C# public void SetTrackEnable(
int track,
bool enable
);
Managed C++ public: void SetTrackEnable(
int track,
bool enable
);
JScript .NET public function SetTrackEnable(
track : int,
enable : boolean
);

Parameters

track | System.Int32. Track identifier.
enable | System.Boolean. Set to true if the track is enabled in the controller. Set to false if the track should not be mixed.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.SetTrackPosition(Int32,Double)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.SetTrackPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the track to the specified local animation time.

Definition

Visual Basic .NET Public Sub SetTrackPosition( _
ByVal track As Integer, _
ByVal position As Double _
)
C# public void SetTrackPosition(
int track,
double position
);
Managed C++ public: void SetTrackPosition(
int track,
double position
);
JScript .NET public function SetTrackPosition(
track : int,
position : double
);

Parameters

track | System.Int32. Track identifier.
position | System.Double. Local animation time value to assign to the track.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.SetTrackPriority(Int32,PriorityType)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.SetTrackPriority Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the priority blending weight for the specified animation track.

Definition

Visual Basic .NET Public Sub SetTrackPriority( _
ByVal track As Integer, _
ByVal priority As PriorityType _
)
C# public void SetTrackPriority(
int track,
PriorityType priority
);
Managed C++ public: void SetTrackPriority(
int track,
PriorityType priority
);
JScript .NET public function SetTrackPriority(
track : int,
priority : PriorityType
);

Parameters

track | System.Int32. Track identifier.
priority | Microsoft.DirectX.Direct3D.PriorityType. Track priority; should be set to one of the PriorityType constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.SetTrackSpeed(Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.SetTrackSpeed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the priority blending weight for the specified animation track.

Definition

Visual Basic .NET Public Sub SetTrackSpeed( _
ByVal track As Integer, _
ByVal speed As Single _
)
C# public void SetTrackSpeed(
int track,
float speed
);
Managed C++ public: void SetTrackSpeed(
int track,
float speed
);
JScript .NET public function SetTrackSpeed(
track : int,
speed : float
);

Parameters

track | System.Int32. Track identifier.
speed | System.Single. Track priority; should be set to one of the constants from PriorityType.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.SetTrackWeight(Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.SetTrackWeight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the track weight, which is used to determine how to blend multiple tracks together.

Definition

Visual Basic .NET Public Sub SetTrackWeight( _
ByVal track As Integer, _
ByVal weight As Single _
)
C# public void SetTrackWeight(
int track,
float weight
);
Managed C++ public: void SetTrackWeight(
int track,
float weight
);
JScript .NET public function SetTrackWeight(
track : int,
weight : float
);

Parameters

track | System.Int32. Identifier of the track for which to set the weight.
weight | System.Single. Weight value.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


AnimationController.UnkeyAllPriorityBlends()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.UnkeyAllPriorityBlends Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes all scheduled priority blend events from the animation controller.

Definition

Visual Basic .NET | Public Sub UnkeyAllPriorityBlends()
C# | public void UnkeyAllPriorityBlends();
Managed C++ | public: void UnkeyAllPriorityBlends();
JScript .NET | public function UnkeyAllPriorityBlends();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.UnkeyAllTrackEvents(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.UnkeyAllTrackEvents Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes all events from a specified animation track.

Definition

Visual Basic .NET Public Sub UnkeyAllTrackEvents( _
ByVal track As Integer _
)
C# public void UnkeyAllTrackEvents(
int track
);
Managed C++ public: void UnkeyAllTrackEvents(
int track
);
JScript .NET public function UnkeyAllTrackEvents(
track : int
);

Parameters

track System.Int32. Identifier of the track from which to remove events.

Remarks

This method prevents the execution of all events previously scheduled on the track, and discards all data associated with those events.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.UnkeyEvent(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.UnkeyEvent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes a specified event from an animation track, preventing the event from being run.

Definition

Visual Basic .NET Public Sub UnkeyEvent( _
ByVal eventHandle As Integer _
)
C# public void UnkeyEvent(
int eventHandle
);
Managed C++ public: void UnkeyEvent(
int eventHandle
);
JScript .NET public function UnkeyEvent(
eventHandle : int
);

Parameters

eventHandle System.Int32. Event handle to the event to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.UnregisterAnimationOutput

AnimationController.UnregisterAnimationOutput Method

Note: This documentation is preliminary and is subject to change.

Removes an animation output from the animation controller.

Overload List

public void UnregisterAnimationOutput(AnimationOutput);
public void UnregisterAnimationOutput(Frame);
public void UnregisterAnimationOutput(string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationOutput(Frame)

AnimationController.UnregisterAnimationOutput Method

Note: This documentation is preliminary and is subject to change.

Removes an animation output from the animation controller.

Definition

Visual Basic .NET Public Sub UnregisterAnimationOutput( _
ByVal animationFrame As Frame _
)
C# public void UnregisterAnimationOutput(
Frame animationFrame
);
Managed C++ public: void UnregisterAnimationOutput(
Frame *animationFrame
);
JScript .NET public function UnregisterAnimationOutput(
animationFrame : Frame
);

Parameters

animationFrame Microsoft.DirectX.Direct3D.Frame. A Frame object to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationOutput(AnimationOutput)

AnimationController.UnregisterAnimationOutput Method

Note: This documentation is preliminary and is subject to change.

Removes an animation output from the animation controller.

Definition

Visual Basic .NET Public Sub UnregisterAnimationOutput( _
ByVal output As AnimationOutput _
)
C# public void UnregisterAnimationOutput(
AnimationOutput output
);
Managed C++ public: void UnregisterAnimationOutput(
AnimationOutput *output
);
JScript .NET public function UnregisterAnimationOutput(
output : AnimationOutput
);

Parameters

output Microsoft.DirectX.Direct3D.AnimationOutput. An AnimationOutput object to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationOutput(String)

AnimationController.UnregisterAnimationOutput Method

Note: This documentation is preliminary and is subject to change.

Removes an animation output from the animation controller.

Definition

Visual Basic .NET Public Sub UnregisterAnimationOutput( _
ByVal name As String _
)
C# public void UnregisterAnimationOutput(
string name
);
Managed C++ public: void UnregisterAnimationOutput(
String *name
);
JScript .NET public function UnregisterAnimationOutput(
name : String
);

Parameters

name System.String. A string that represents the name of the animation output to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationSet(AnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.UnregisterAnimationSet Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes an animation set from the animation controller.

Definition

Visual Basic .NET Public Sub UnregisterAnimationSet( _
ByVal animationSet As AnimationSet _
)
C# public void UnregisterAnimationSet(
AnimationSet animationSet
);
Managed C++ public: void UnregisterAnimationSet(
AnimationSet *animationSet
);
JScript .NET public function UnregisterAnimationSet(
animationSet : AnimationSet
);

Parameters

animationSet Microsoft.DirectX.Direct3D.AnimationSet. The AnimationSet to remove.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested item was not found.


AnimationController.UpdateUnmanagedPointer(ID3DXAnimationController)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this AnimationController object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXAnimationController _
)
C# public void UpdateUnmanagedPointer(
ID3DXAnimationController pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXAnimationController pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXAnimationController
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationController. Pointer to the ID3DXAnimationController structure used to update the unmanaged pointer for this AnimationController object.


AnimationController.ValidateEvent(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.ValidateEvent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a specified event handle is valid and the animation event has completed.

Definition

Visual Basic .NET Public Sub ValidateEvent( _
ByVal eventHandle As Integer _
)
C# public void ValidateEvent(
int eventHandle
);
Managed C++ public: void ValidateEvent(
int eventHandle
);
JScript .NET public function ValidateEvent(
eventHandle : int
);

Parameters

eventHandle System.Int32. Event handle to the animation event.

Remarks

This method indicates whether an event handle is valid even if the event is still running.

Exceptions
Direct3DXException The event handle is invalid and/or the event has completed.


AnimationController.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


AnimationController.MaxNumberAnimationOutputs

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.MaxNumberAnimationOutputs Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of animation outputs the controller can support.

Definition

Visual Basic .NET | Public ReadOnly Property MaxNumberAnimationOutputs As Integer
C# | public int MaxNumberAnimationOutputs { get; }
Managed C++ | public: __property int get_MaxNumberAnimationOutputs();
JScript .NET | public function get MaxNumberAnimationOutputs() : int

Property Value

System.Int32 . Maximum number of animation outputs.

This property is read-only.

See Also

  • MaxNumberAnimationSets
  • MaxNumberEvents
  • MaxNumberTracks


AnimationController.MaxNumberAnimationSets

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.MaxNumberAnimationSets Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of animation sets the controller can support.

Definition

Visual Basic .NET | Public ReadOnly Property MaxNumberAnimationSets As Integer
C# | public int MaxNumberAnimationSets { get; }
Managed C++ | public: __property int get_MaxNumberAnimationSets();
JScript .NET | public function get MaxNumberAnimationSets() : int

Property Value

System.Int32 . Maximum number of animation sets.

This property is read-only.


AnimationController.MaxNumberEvents

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.MaxNumberEvents Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of events the controller can support.

Definition

Visual Basic .NET | Public ReadOnly Property MaxNumberEvents As Integer
C# | public int MaxNumberEvents { get; }
Managed C++ | public: __property int get_MaxNumberEvents();
JScript .NET | public function get MaxNumberEvents() : int

Property Value

System.Int32 . Maximum number of events.

This property is read-only.


AnimationController.MaxNumberTracks

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.MaxNumberTracks Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of tracks in the mixer.

Definition

Visual Basic .NET | Public ReadOnly Property MaxNumberTracks As Integer
C# | public int MaxNumberTracks { get; }
Managed C++ | public: __property int get_MaxNumberTracks();
JScript .NET | public function get MaxNumberTracks() : int

Property Value

System.Int32 . Maximum number of tracks.

This property is read-only.


AnimationController.NumberAnimationSets

AnimationController.NumberAnimationSets Property

Note: This documentation is preliminary and is subject to change.

Returns the number of animation sets currently registered in the animation controller.

Definition

Visual Basic .NET | Public ReadOnly Property NumberAnimationSets As Integer
C# | public int NumberAnimationSets { get; }
Managed C++ | public: __property int get_NumberAnimationSets();
JScript .NET | public function get NumberAnimationSets() : int

Property Value

System.Int32 . An integer that represents the number of animation sets in the animation controller.

This property is read-only.

Remarks

The AnimationController contains any number of animations sets and tracks. Animation sets can be registered with RegisterAnimationSet. An AnimationController created by a call to Mesh.LoadHierarchyFromFile will automatically register loaded animation sets.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationController.PriorityBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.PriorityBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the track blending weight.

Definition

Visual Basic .NET | Public Property PriorityBlend As Single
C# | public float PriorityBlend { get; set; }
Managed C++ public: __property float get_PriorityBlend();
public: __property void set_PriorityBlend(float);
JScript .NET public function get PriorityBlend() : float
public function set PriorityBlend(float);

Property Value

System.Single . Track blending weight.

This property is read/write.


AnimationController.Time

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.Time Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the local animation time.

Definition

Visual Basic .NET | Public ReadOnly Property Time As Double
C# | public double Time { get; }
Managed C++ | public: __property double get_Time();
JScript .NET | public function get Time() : double

Property Value

System.Double . Local animation time.

This property is read-only.


AnimationController.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXAnimationController interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXAnimationController
C# | public ID3DXAnimationController UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXAnimationController get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXAnimationController

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationController . Unmanaged ID3DXAnimationController interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


AnimationController.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the AnimationController object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.AnimationController.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the AnimationController object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.AnimationOutput

AnimationOutput Class

Note: This documentation is preliminary and is subject to change.

Encapsulates matrix, scale, rotate, and translate (SRT) transformation objects.

Definition

Visual Basic .NET Public Class AnimationOutput
Inherits Object
Implements IDisposable
C# public class AnimationOutput : Object,
IDisposable
Managed C++ public __gc class AnimationOutput : public Object,
IDisposable
JScript .NET public class AnimationOutput extends Object
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AnimationOutput | Initializes a new instance of the AnimationOutput class.
Dispose | Immediately releases the unmanaged resources used by the AnimationOutput object.
Finalize | Allows the AnimationOutput object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
Matrix | Retrieves the matrix output for the animation.
Name | Retrieves the name of the animation output.
Rotation | Retrieves the rotation output for the animation.
Scale | Retrieves the scale output for the animation.
Translation | Retrieves the translation output for the animation.

Inheritance Hierarchy

Object Leave Site
AnimationOutput

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • AnimationController
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.AnimationOutput(String,AnimationOutputFlags)

AnimationOutput.AnimationOutput Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationOutput class.

Definition

Visual Basic .NET Public Sub New( _
ByVal name As String, _
ByVal flags As AnimationOutputFlags _
)
C# public AnimationOutput(
string name,
AnimationOutputFlags flags
);
Managed C++ public: AnimationOutput(
String *name,
AnimationOutputFlags flags
);
JScript .NET public function AnimationOutput(
name : String,
flags : AnimationOutputFlags
);

Parameters

name | System.String. Name of the animation output.
flags | Microsoft.DirectX.Direct3D.AnimationOutputFlags. One or more values of the AnimationOutputFlags enumeration that specify which outputs to receive.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationOutput.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the AnimationOutput object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


AnimationOutput.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationOutput.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the AnimationOutput object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~AnimationOutput();
Managed C++ | ~AnimationOutput();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


AnimationOutput.Matrix

AnimationOutput.Matrix Property

Note: This documentation is preliminary and is subject to change.

Retrieves the matrix output for the animation.

Definition

Visual Basic .NET | Public ReadOnly Property Matrix As Matrix
C# | public Matrix Matrix { get; }
Managed C++ | public: __property Matrix get_Matrix();
JScript .NET | public function get Matrix() : Matrix

Property Value

Microsoft.DirectX.Matrix . A Matrix object that contains the animation's matrix transformation data.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Name

AnimationOutput.Name Property

Note: This documentation is preliminary and is subject to change.

Retrieves the name of the animation output.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . A string that represents the name of the animation output.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Rotation

AnimationOutput.Rotation Property

Note: This documentation is preliminary and is subject to change.

Retrieves the rotation output for the animation.

Definition

Visual Basic .NET | Public ReadOnly Property Rotation As Quaternion
C# | public Quaternion Rotation { get; }
Managed C++ | public: __property Quaternion get_Rotation();
JScript .NET | public function get Rotation() : Quaternion

Property Value

Microsoft.DirectX.Quaternion . A Quaternion object that contains the animation's rotation data.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Scale

AnimationOutput.Scale Property

Note: This documentation is preliminary and is subject to change.

Retrieves the scale output for the animation.

Definition

Visual Basic .NET | Public ReadOnly Property Scale As Vector3
C# | public Vector3 Scale { get; }
Managed C++ | public: __property Vector3 get_Scale();
JScript .NET | public function get Scale() : Vector3

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the animation's scale data.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Translation

AnimationOutput.Translation Property

Note: This documentation is preliminary and is subject to change.

Retrieves the translation output for the animation.

Definition

Visual Basic .NET | Public ReadOnly Property Translation As Vector3
C# | public Vector3 Translation { get; }
Managed C++ | public: __property Vector3 get_Translation();
JScript .NET | public function get Translation() : Vector3

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the animation's translation data.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.AnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates the minimum functionality required of an animation set by an animation controller.

Advanced users might want to implement this class themselves to suit their specialized needs. For most users, however, the derived CompressedAnimationSet and KeyframedAnimationSet classes should suffice.

Definition

Visual Basic .NET Public Class AnimationSet
Inherits Object
Implements IDisposable
C# public class AnimationSet : Object,
IDisposable
Managed C++ public __gc class AnimationSet : public Object,
IDisposable
JScript .NET public class AnimationSet extends Object
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the AnimationSet object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
AnimationSet | Initializes a new instance of the AnimationSet class.
Dispose | Immediately releases the unmanaged resources used by the AnimationSet object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the AnimationSet object to free resources before it is destroyed by the garbage collector.
GetAnimationIndex | Retrieves the index of an animation, given its name.
GetAnimationName | Retrieves the name of an animation, given its index.
GetCallback | Retrieves information about a specific callback in an animation set.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPeriodicPosition | Returns the time position in the local timeframe of an animation set.
GetScaleRotateTranslate | Retrieves the scale, rotate, and translate (SRT) values of an animation set.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.AnimationSet.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Name | Retrieves the name of an animation set.
NumberAnimations | Retrieves a value that indicates the number of animations in the animation set.
Period | Retrieves the period of an animation set.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer.

Inheritance Hierarchy

Object Leave Site
AnimationSet
CompressedAnimationSet
KeyframedAnimationSet

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AnimationSet.AnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.AnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationSet class.

Overload List

public AnimationSet(ID3DXAnimationSet);
public AnimationSet(IntPtr);


AnimationSet.AnimationSet(ID3DXAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.AnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationSet class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXAnimationSet _
)
C# public AnimationSet(
ID3DXAnimationSet pUnk
);
Managed C++ public: AnimationSet(
ID3DXAnimationSet pUnk
);
JScript .NET public function AnimationSet(
pUnk : ID3DXAnimationSet
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationSet. Unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer.


AnimationSet.AnimationSet(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.AnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AnimationSet class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public AnimationSet(
IntPtr unmanagedObject
);
Managed C++ public: AnimationSet(
IntPtr unmanagedObject
);
JScript .NET public function AnimationSet(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXAnimationSet interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


AnimationSet.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the AnimationSet object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

Applies To

CompressedAnimationSet, KeyframedAnimationSet

See Also

  • Microsoft.DirectX.Direct3D.AnimationSet.Disposed
  • Microsoft.DirectX.Direct3D.AnimationSet.Disposing


AnimationSet.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the AnimationSet object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~AnimationSet();
Managed C++ | ~AnimationSet();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetAnimationIndex(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.GetAnimationIndex Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the index of an animation, given its name.

Definition

Visual Basic .NET Public Function GetAnimationIndex( _
ByVal name As String _
) As Integer
C# public int GetAnimationIndex(
string name
);
Managed C++ public: int GetAnimationIndex(
String *name
);
JScript .NET public function GetAnimationIndex(
name : String
) : int;

Parameters

name System.String. Animation name.

Return Value

System.Int32 . Returns the index of the named animation; otherwise, throws a Direct3DXException.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetAnimationName(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.GetAnimationName Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the name of an animation, given its index.

Definition

Visual Basic .NET Public Function GetAnimationName( _
ByVal index As Integer _
) As String
C# public string GetAnimationName(
int index
);
Managed C++ public: String* GetAnimationName(
int index
);
JScript .NET public function GetAnimationName(
index : int
) : String;

Parameters

index System.Int32. Animation index.

Return Value

System.String . Returns a string that contains the animation name; otherwise, throws a Direct3DXException.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetCallback(Double,CallbackSearchFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.GetCallback Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about a specific callback in an animation set.

Definition

Visual Basic .NET Public Function GetCallback( _
ByVal position As Double, _
ByVal flags As CallbackSearchFlags _
) As CallbackData
C# public CallbackData GetCallback(
double position,
CallbackSearchFlags flags
);
Managed C++ public: CallbackData GetCallback(
double position,
CallbackSearchFlags flags
);
JScript .NET public function GetCallback(
position : double,
flags : CallbackSearchFlags
) : CallbackData;

Parameters

position | System.Double. Position from which to find callbacks.
flags | Microsoft.DirectX.Direct3D.CallbackSearchFlags. Callback search flags. This parameter can be set to one or more CallbackSearchFlags constants.

Return Value

Microsoft.DirectX.Direct3D.CallbackData . This method's return values are implemented by an application programmer. In general, if no error occurs, the method should return an empty structure; otherwise, it should throw an exception. For more information, see DirectXException.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXAnimationSet, which allows unmanaged COM clients to create an instance of the managed AnimationSet class. Not supported.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetPeriodicPosition(Double)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.GetPeriodicPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the time position in the local timeframe of an animation set.

Definition

Visual Basic .NET Public Function GetPeriodicPosition( _
ByVal position As Double _
) As Double
C# public double GetPeriodicPosition(
double position
);
Managed C++ public: double GetPeriodicPosition(
double position
);
JScript .NET public function GetPeriodicPosition(
position : double
) : double;

Parameters

position System.Double. Local time of the animation set.

Return Value

System.Double . Time position as measured in the timeframe of the animation set. This value is bounded by the period of the animation set.

Remarks

The time position this method returns can be used as the periodicPosition parameter of GetScaleRotateTranslate.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetScaleRotateTranslate(Double,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.GetScaleRotateTranslate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the scale, rotate, and translate (SRT) values of an animation set.

Definition

Visual Basic .NET Public Function GetScaleRotateTranslate( _
ByVal periodicPosition As Double, _
ByVal animation As Integer _
) As ScaleRotateTranslate
C# public ScaleRotateTranslate GetScaleRotateTranslate(
double periodicPosition,
int animation
);
Managed C++ public: ScaleRotateTranslate GetScaleRotateTranslate(
double periodicPosition,
int animation
);
JScript .NET public function GetScaleRotateTranslate(
periodicPosition : double,
animation : int
) : ScaleRotateTranslate;

Parameters

periodicPosition | System.Double. Position of the animation set; can be obtained by calling GetPeriodicPosition.
animation | System.Int32. Animation index.

Return Value

Microsoft.DirectX.Direct3D.ScaleRotateTranslate . Returns a ScaleRotateTranslate structure.

Applies To

CompressedAnimationSet, KeyframedAnimationSet

See Also

  • GetPeriodicPosition


AnimationSet.op_Equality(AnimationSet,AnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As AnimationSet, _
ByVal right As AnimationSet _
) As Boolean
C# public static bool op_Equality(
AnimationSet left,
AnimationSet right
);
Managed C++ public: static bool op_Equality(
AnimationSet *left,
AnimationSet *right
);
JScript .NET public static function op_Equality(
left : AnimationSet,
right : AnimationSet
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.AnimationSet. The AnimationSet object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.AnimationSet. The AnimationSet object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.op_Inequality(AnimationSet,AnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As AnimationSet, _
ByVal right As AnimationSet _
) As Boolean
C# public static bool op_Inequality(
AnimationSet left,
AnimationSet right
);
Managed C++ public: static bool op_Inequality(
AnimationSet *left,
AnimationSet *right
);
JScript .NET public static function op_Inequality(
left : AnimationSet,
right : AnimationSet
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.AnimationSet. The AnimationSet object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.AnimationSet. The AnimationSet object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.AnimationSet.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.UpdateUnmanagedPointer(ID3DXAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXAnimationSet _
)
C# public void UpdateUnmanagedPointer(
ID3DXAnimationSet pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXAnimationSet pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXAnimationSet
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationSet. Pointer to the ID3DXAnimationSet structure used to update the unmanaged pointer for this AnimationSet object.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the name of an animation set.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . Animation set name.

This property is read-only.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.NumberAnimations

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.NumberAnimations Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the number of animations in the animation set.

Definition

Visual Basic .NET | Public ReadOnly Property NumberAnimations As Integer
C# | public int NumberAnimations { get; }
Managed C++ | public: __property int get_NumberAnimations();
JScript .NET | public function get NumberAnimations() : int

Property Value

System.Int32 . Number of animations in the set.

This property is read-only.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Period

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.Period Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the period of an animation set.

Definition

Visual Basic .NET | Public ReadOnly Property Period As Double
C# | public double Period { get; }
Managed C++ | public: __property double get_Period();
JScript .NET | public function get Period() : double

Property Value

System.Double . Animation set period.

This property is read-only.

Remarks

The period is the range of time in which the animation key frames are valid. For looping animations, this is the period of the loop. The application determines the time units (for example, seconds) in which the key frames are specified.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXAnimationSet
C# | public ID3DXAnimationSet UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXAnimationSet get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXAnimationSet

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationSet . Unmanaged ID3DXAnimationSet interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationSet.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the AnimationSet object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.AnimationSet.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the AnimationSet object indicates whether that object has been disposed.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


Microsoft.DirectX.Direct3D.BaseEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect Class

Language:
Note: This documentation is preliminary and is subject to change.

Provides methods for retrieving and setting effect parameters such as constants, functions, shaders, and techniques.

Definition

Visual Basic .NET Public Class BaseEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class BaseEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class BaseEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class BaseEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the BaseEffect object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
BaseEffect | Initializes a new instance of the BaseEffect class.
Dispose | Immediately releases the unmanaged resources used by the BaseEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseEffect object to free resources before it is destroyed by the garbage collector.
GetAnnotation | Retrieves an annotation.
GetFunction | Retrieves a function.
GetFunctionDescription | Retrieves a function description.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetParameter | Retrieves a top-level parameter or a structure member parameter.
GetParameterBySemantic | Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic.
GetParameterDescription | Retrieves a parameter or annotation description.
GetParameterElement | Retrieves the EffectHandle of an array element parameter.
GetPass | Retrieves the EffectHandle of a pass.
GetPassDescription | Retrieves a pass description.
GetTechnique | Retrieves the EffectHandle of a technique.
GetTechniqueDescription | Retrieves a technique description.
GetValue | Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.
GetValueBoolean | Retrieves a Boolean value.
GetValueBooleanArray | Retrieves an array of Boolean values.
GetValueColor | Retrieves a ColorValue structure.
GetValueColorArray | Retrieves an array of ColorValue structures.
GetValueFloat | Retrieves a floating-point value.
GetValueFloatArray | Retrieves an array of floating-point values.
GetValueInteger | Retrieves an integer.
GetValueIntegerArray | Retrieves an array of integers.
GetValueMatrix | Retrieves a nontransposed matrix.
GetValueMatrixArray | Retrieves an array of nontransposed matrices.
GetValueMatrixTranspose | Retrieves a transposed matrix.
GetValueMatrixTransposeArray | Retrieves an array of transposed matrices.
GetValuePixelShader | Retrieves a pixel shader.
GetValueString | Retrieves a string.
GetValueTexture | Retrieves a texture.
GetValueVector | Retrieves a vector.
GetValueVectorArray | Retrieves an array of vectors.
GetValueVertexShader | Retrieves a vertex shader.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.BaseEffect.Disposing event when called from within a derived class.
SetValueTranspose | Sets a transposed matrix.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves an effect description.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseEffect
Effect
EffectCompiler

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BaseEffect.BaseEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.BaseEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseEffect class.

Overload List

public BaseEffect(ID3DXBaseEffect);
public BaseEffect(IntPtr);


BaseEffect.BaseEffect(ID3DXBaseEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.BaseEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseEffect class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXBaseEffect _
)
C# public BaseEffect(
ID3DXBaseEffect pUnk
);
Managed C++ public: BaseEffect(
ID3DXBaseEffect pUnk
);
JScript .NET public function BaseEffect(
pUnk : ID3DXBaseEffect
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseEffect. Unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer.


BaseEffect.BaseEffect(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.BaseEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseEffect class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public BaseEffect(
IntPtr unmanagedObject
);
Managed C++ public: BaseEffect(
IntPtr unmanagedObject
);
JScript .NET public function BaseEffect(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXBaseEffect interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


BaseEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the BaseEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

Applies To

Effect, EffectCompiler

See Also

  • Microsoft.DirectX.Direct3D.BaseEffect.Disposed
  • Microsoft.DirectX.Direct3D.BaseEffect.Disposing


BaseEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

Effect, EffectCompiler


BaseEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the BaseEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~BaseEffect();
Managed C++ | ~BaseEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

Effect, EffectCompiler


BaseEffect.GetAnnotation

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetAnnotation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an annotation.

Overload List

public EffectHandle GetAnnotation(EffectHandle, int);
public EffectHandle GetAnnotation(EffectHandle, string);

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


BaseEffect.GetAnnotation(EffectHandle,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetAnnotation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an annotation.

Definition

Visual Basic .NET Public Function GetAnnotation( _
ByVal technique As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetAnnotation(
EffectHandle technique,
string name
);
Managed C++ public: EffectHandle* GetAnnotation(
EffectHandle *technique,
String *name
);
JScript .NET public function GetAnnotation(
technique : EffectHandle,
name : String
) : EffectHandle;

Parameters

technique | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents a technique, pass, or top-level parameter.
name | System.String. Annotation name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . A EffectHandle object that specifies the annotation, or null if the annotation is not found.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.

Applies To

Effect, EffectCompiler


BaseEffect.GetAnnotation(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetAnnotation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an annotation.

Definition

Visual Basic .NET Public Function GetAnnotation( _
ByVal technique As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetAnnotation(
EffectHandle technique,
int index
);
Managed C++ public: EffectHandle* GetAnnotation(
EffectHandle *technique,
int index
);
JScript .NET public function GetAnnotation(
technique : EffectHandle,
index : int
) : EffectHandle;

Parameters

technique | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents a technique, pass, or top-level parameter.
index | System.Int32. Annotation index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . A EffectHandle object that specifies the annotation, or null if the annotation is not found.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.

Applies To

Effect, EffectCompiler


BaseEffect.GetFunction

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetFunction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a function.

Overload List

public EffectHandle GetFunction(int);
public EffectHandle GetFunction(string);


BaseEffect.GetFunction(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetFunction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a function.

Definition

Visual Basic .NET Public Function GetFunction( _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetFunction(
string name
);
Managed C++ public: EffectHandle* GetFunction(
String *name
);
JScript .NET public function GetFunction(
name : String
) : EffectHandle;

Parameters

name System.String. String that contains the name of the function.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . Specified EffectHandle associated with the function, or null if it is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetFunction(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetFunction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a function.

Definition

Visual Basic .NET Public Function GetFunction( _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetFunction(
int index
);
Managed C++ public: EffectHandle* GetFunction(
int index
);
JScript .NET public function GetFunction(
index : int
) : EffectHandle;

Parameters

index System.Int32. Index of the function.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . Specified EffectHandle associated with the function, or null if it is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetFunctionDescription(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetFunctionDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a function description.

Definition

Visual Basic .NET Public Function GetFunctionDescription( _
ByVal shader As EffectHandle _
) As FunctionDescription
C# public FunctionDescription GetFunctionDescription(
EffectHandle shader
);
Managed C++ public: FunctionDescription GetFunctionDescription(
EffectHandle *shader
);
JScript .NET public function GetFunctionDescription(
shader : EffectHandle
) : FunctionDescription;

Parameters

shader Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that indicates the function form from which to retrieve the description.

Return Value

Microsoft.DirectX.Direct3D.FunctionDescription . A FunctionDescription structure that describes the function.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

Applies To

Effect, EffectCompiler


BaseEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXBaseEffect, which allows unmanaged COM clients to create an instance of the managed BaseEffect class. Not supported.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameter

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetParameter Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a top-level parameter or a structure member parameter.

Overload List

public EffectHandle GetParameter(EffectHandle, int);
public EffectHandle GetParameter(EffectHandle, string);


BaseEffect.GetParameter(EffectHandle,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetParameter Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a top-level parameter or a structure member parameter.

Definition

Visual Basic .NET Public Function GetParameter( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetParameter(
EffectHandle constant,
string name
);
Managed C++ public: EffectHandle* GetParameter(
EffectHandle *constant,
String *name
);
JScript .NET public function GetParameter(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that indicates the parameter, or null for top-level parameters.
name | System.String. String that contains the parameter name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle of the specified parameter, or null if the parameter is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameter(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetParameter Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a top-level parameter or a structure member parameter.

Definition

Visual Basic .NET Public Function GetParameter( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetParameter(
EffectHandle constant,
int index
);
Managed C++ public: EffectHandle* GetParameter(
EffectHandle *constant,
int index
);
JScript .NET public function GetParameter(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that indicates the parameter, or null for top-level parameters.
index | System.Int32. Parameter index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle of the specified parameter, or null if the parameter is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameterBySemantic(EffectHandle,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetParameterBySemantic Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic.

Definition

Visual Basic .NET Public Function GetParameterBySemantic( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetParameterBySemantic(
EffectHandle constant,
string name
);
Managed C++ public: EffectHandle* GetParameterBySemantic(
EffectHandle *constant,
String *name
);
JScript .NET public function GetParameterBySemantic(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle of the parameter, or null for top-level parameters.
name | System.String. String that contains the semantic name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . The EffectHandle of the first parameter that matches the specified semantic, or null if the semantic is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameterDescription(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetParameterDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a parameter or annotation description.

Definition

Visual Basic .NET Public Function GetParameterDescription( _
ByVal parameter As EffectHandle _
) As ParameterDescription
C# public ParameterDescription GetParameterDescription(
EffectHandle parameter
);
Managed C++ public: ParameterDescription GetParameterDescription(
EffectHandle *parameter
);
JScript .NET public function GetParameterDescription(
parameter : EffectHandle
) : ParameterDescription;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that indicates the parameter or annotation handle.

Return Value

Microsoft.DirectX.Direct3D.ParameterDescription . Description of the specified parameter or annotation. For more information, see ParameterDescription.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameterElement(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetParameterElement Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the EffectHandle of an array element parameter.

Definition

Visual Basic .NET Public Function GetParameterElement( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetParameterElement(
EffectHandle constant,
int index
);
Managed C++ public: EffectHandle* GetParameterElement(
EffectHandle *constant,
int index
);
JScript .NET public function GetParameterElement(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle associated with the array.
index | System.Int32. Array element index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . Handle of the specified parameter, or null if either param_EffectHandle_constant or param_Int32_index is invalid.

Remarks

This method is used to get an element of a parameter that is an array.

Applies To

Effect, EffectCompiler


BaseEffect.GetPass

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetPass Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the EffectHandle of a pass.

Overload List

public EffectHandle GetPass(EffectHandle, int);
public EffectHandle GetPass(EffectHandle, string);


BaseEffect.GetPass(EffectHandle,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetPass Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the EffectHandle of a pass.

Definition

Visual Basic .NET Public Function GetPass( _
ByVal technique As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetPass(
EffectHandle technique,
string name
);
Managed C++ public: EffectHandle* GetPass(
EffectHandle *technique,
String *name
);
JScript .NET public function GetPass(
technique : EffectHandle,
name : String
) : EffectHandle;

Parameters

technique | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle of the parent technique.
name | System.String. String that contains the name of the pass.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . The EffectHandle of the specified pass inside the specified technique, or null if the index is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetPass(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetPass Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the EffectHandle of a pass.

Definition

Visual Basic .NET Public Function GetPass( _
ByVal technique As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetPass(
EffectHandle technique,
int index
);
Managed C++ public: EffectHandle* GetPass(
EffectHandle *technique,
int index
);
JScript .NET public function GetPass(
technique : EffectHandle,
index : int
) : EffectHandle;

Parameters

technique | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle of the parent technique.
index | System.Int32. Index for the pass.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . The EffectHandle of the specified pass inside the specified technique, or null if the index is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetPassDescription(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetPassDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a pass description.

Definition

Visual Basic .NET Public Function GetPassDescription( _
ByVal pass As EffectHandle _
) As PassDescription
C# public PassDescription GetPassDescription(
EffectHandle pass
);
Managed C++ public: PassDescription GetPassDescription(
EffectHandle *pass
);
JScript .NET public function GetPassDescription(
pass : EffectHandle
) : PassDescription;

Parameters

pass Microsoft.DirectX.Direct3D.EffectHandle. Pass EffectHandle.

Return Value

Microsoft.DirectX.Direct3D.PassDescription . A PassDescription of the specified pass.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetTechnique

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetTechnique Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the EffectHandle of a technique.

Overload List

public EffectHandle GetTechnique(int);
public EffectHandle GetTechnique(string);


BaseEffect.GetTechnique(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetTechnique Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the EffectHandle of a technique.

Definition

Visual Basic .NET Public Function GetTechnique( _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetTechnique(
string name
);
Managed C++ public: EffectHandle* GetTechnique(
String *name
);
JScript .NET public function GetTechnique(
name : String
) : EffectHandle;

Parameters

name System.String. String that contains the technique name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . The EffectHandle of the first technique that has the specified name, or null if the name is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetTechnique(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetTechnique Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the EffectHandle of a technique.

Definition

Visual Basic .NET Public Function GetTechnique( _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetTechnique(
int index
);
Managed C++ public: EffectHandle* GetTechnique(
int index
);
JScript .NET public function GetTechnique(
index : int
) : EffectHandle;

Parameters

index System.Int32. Technique index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . The EffectHandle of the first technique that has the specified name, or null if the name is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetTechniqueDescription(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetTechniqueDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a technique description.

Definition

Visual Basic .NET Public Function GetTechniqueDescription( _
ByVal technique As EffectHandle _
) As TechniqueDescription
C# public TechniqueDescription GetTechniqueDescription(
EffectHandle technique
);
Managed C++ public: TechniqueDescription GetTechniqueDescription(
EffectHandle *technique
);
JScript .NET public function GetTechniqueDescription(
technique : EffectHandle
) : TechniqueDescription;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle. Technique EffectHandle.

Return Value

Microsoft.DirectX.Direct3D.TechniqueDescription . A TechniqueDescription of the specified technique.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValue(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic .NET Public Function GetValue( _
ByVal parameter As EffectHandle, _
ByVal numberBytes As Integer _
) As GraphicsStream
C# public GraphicsStream GetValue(
EffectHandle parameter,
int numberBytes
);
Managed C++ public: GraphicsStream* GetValue(
EffectHandle *parameter,
int numberBytes
);
JScript .NET public function GetValue(
parameter : EffectHandle,
numberBytes : int
) : GraphicsStream;

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
numberBytes | System.Int32. Number of bytes in the GraphicsStream. To skip size validation, pass in 0, provided the GraphicsStream is large enough to contain the entire parameter.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the value.

Remarks

Exceptions
InvalidCallException | The call is invalid.
BaseEffect | This method can be used in place of nearly all of the Get* calls in BaseEffect.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueBoolean(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueBoolean Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a Boolean value.

Definition

Visual Basic .NET Public Function GetValueBoolean( _
ByVal parameter As EffectHandle _
) As Boolean
C# public bool GetValueBoolean(
EffectHandle parameter
);
Managed C++ public: bool GetValueBoolean(
EffectHandle *parameter
);
JScript .NET public function GetValueBoolean(
parameter : EffectHandle
) : boolean;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

System.Boolean . Boolean value.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueBooleanArray(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueBooleanArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of Boolean values.

Definition

Visual Basic .NET Public Function GetValueBooleanArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Boolean()
C# public bool[] GetValueBooleanArray(
EffectHandle parameter,
int count
);
Managed C++ public: bool GetValueBooleanArray(
EffectHandle *parameter,
int count
) __gc[];
JScript .NET public function GetValueBooleanArray(
parameter : EffectHandle,
count : int
) : boolean[];

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
count | System.Int32. Number of Boolean values in the returned array.

Return Value

System.Boolean[]. Array of Boolean values.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueColor(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueColor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a ColorValue structure.

Definition

Visual Basic .NET Public Function GetValueColor( _
ByVal parameter As EffectHandle _
) As ColorValue
C# public ColorValue GetValueColor(
EffectHandle parameter
);
Managed C++ public: ColorValue GetValueColor(
EffectHandle *parameter
);
JScript .NET public function GetValueColor(
parameter : EffectHandle
) : ColorValue;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle associated with the color value.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueColorArray(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueColorArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of ColorValue structures.

Definition

Visual Basic .NET Public Function GetValueColorArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As ColorValue()
C# public ColorValue[] GetValueColorArray(
EffectHandle parameter,
int count
);
Managed C++ public: ColorValue GetValueColorArray(
EffectHandle *parameter,
int count
) __gc[];
JScript .NET public function GetValueColorArray(
parameter : EffectHandle,
count : int
) : ColorValue[];

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle associated with the color value array.
count | System.Int32. Number of values in the returned array.

Return Value

Microsoft.DirectX.Direct3D.ColorValue[]. Array of ColorValue structures.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueFloat(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueFloat Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a floating-point value.

Definition

Visual Basic .NET Public Function GetValueFloat( _
ByVal parameter As EffectHandle _
) As Single
C# public float GetValueFloat(
EffectHandle parameter
);
Managed C++ public: float GetValueFloat(
EffectHandle *parameter
);
JScript .NET public function GetValueFloat(
parameter : EffectHandle
) : float;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

System.Single . A Single Leave Site value.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueFloatArray(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueFloatArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of floating-point values.

Definition

Visual Basic .NET Public Function GetValueFloatArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Single()
C# public float[] GetValueFloatArray(
EffectHandle parameter,
int count
);
Managed C++ public: float GetValueFloatArray(
EffectHandle *parameter,
int count
) __gc[];
JScript .NET public function GetValueFloatArray(
parameter : EffectHandle,
count : int
) : float[];

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
count | System.Int32. Number of floating-point values in the returned array.

Return Value

System.Single[]. Array of Single Leave Site values.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueInteger(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueInteger Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an integer.

Definition

Visual Basic .NET Public Function GetValueInteger( _
ByVal parameter As EffectHandle _
) As Integer
C# public int GetValueInteger(
EffectHandle parameter
);
Managed C++ public: int GetValueInteger(
EffectHandle *parameter
);
JScript .NET public function GetValueInteger(
parameter : EffectHandle
) : int;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

System.Int32 . Integer.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueIntegerArray(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueIntegerArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of integers.

Definition

Visual Basic .NET Public Function GetValueIntegerArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Integer()
C# public int[] GetValueIntegerArray(
EffectHandle parameter,
int count
);
Managed C++ public: int GetValueIntegerArray(
EffectHandle *parameter,
int count
) __gc[];
JScript .NET public function GetValueIntegerArray(
parameter : EffectHandle,
count : int
) : int[];

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
count | System.Int32. Number of integers in the returned array.

Return Value

System.Int32[]. Array of integers.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrix(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a nontransposed matrix.

Definition

Visual Basic .NET Public Function GetValueMatrix( _
ByVal parameter As EffectHandle _
) As Matrix
C# public Matrix GetValueMatrix(
EffectHandle parameter
);
Managed C++ public: Matrix GetValueMatrix(
EffectHandle *parameter
);
JScript .NET public function GetValueMatrix(
parameter : EffectHandle
) : Matrix;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Matrix . Nontransposed Matrix.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrixArray(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueMatrixArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of nontransposed matrices.

Definition

Visual Basic .NET Public Function GetValueMatrixArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Matrix()
C# public Matrix[] GetValueMatrixArray(
EffectHandle parameter,
int count
);
Managed C++ public: Matrix GetValueMatrixArray(
EffectHandle *parameter,
int count
) __gc[];
JScript .NET public function GetValueMatrixArray(
parameter : EffectHandle,
count : int
) : Matrix[];

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
count | System.Int32. Number of matrices in the returned array.

Return Value

Microsoft.DirectX.Matrix[]. Nontransposed matrices.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrixTranspose(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueMatrixTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a transposed matrix.

Definition

Visual Basic .NET Public Function GetValueMatrixTranspose( _
ByVal parameter As EffectHandle _
) As Matrix
C# public Matrix GetValueMatrixTranspose(
EffectHandle parameter
);
Managed C++ public: Matrix GetValueMatrixTranspose(
EffectHandle *parameter
);
JScript .NET public function GetValueMatrixTranspose(
parameter : EffectHandle
) : Matrix;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Matrix . Transposed Matrix.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrixTransposeArray(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueMatrixTransposeArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of transposed matrices.

Definition

Visual Basic .NET Public Function GetValueMatrixTransposeArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Matrix()
C# public Matrix[] GetValueMatrixTransposeArray(
EffectHandle parameter,
int count
);
Managed C++ public: Matrix GetValueMatrixTransposeArray(
EffectHandle *parameter,
int count
) __gc[];
JScript .NET public function GetValueMatrixTransposeArray(
parameter : EffectHandle,
count : int
) : Matrix[];

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
count | System.Int32. Number of matrices in the returned array.

Return Value

Microsoft.DirectX.Matrix[]. Array of transposed matrices.

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValuePixelShader(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValuePixelShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a pixel shader.

Definition

Visual Basic .NET Public Function GetValuePixelShader( _
ByVal parameter As EffectHandle _
) As PixelShader
C# public PixelShader GetValuePixelShader(
EffectHandle parameter
);
Managed C++ public: PixelShader* GetValuePixelShader(
EffectHandle *parameter
);
JScript .NET public function GetValuePixelShader(
parameter : EffectHandle
) : PixelShader;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Direct3D.PixelShader . A PixelShader object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueString(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a string.

Definition

Visual Basic .NET Public Function GetValueString( _
ByVal parameter As EffectHandle _
) As String
C# public string GetValueString(
EffectHandle parameter
);
Managed C++ public: String* GetValueString(
EffectHandle *parameter
);
JScript .NET public function GetValueString(
parameter : EffectHandle
) : String;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

System.String . String identified by the effect handle param_EffectHandle_parameter.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueTexture(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a texture.

Definition

Visual Basic .NET Public Function GetValueTexture( _
ByVal parameter As EffectHandle _
) As Texture
C# public Texture GetValueTexture(
EffectHandle parameter
);
Managed C++ public: Texture* GetValueTexture(
EffectHandle *parameter
);
JScript .NET public function GetValueTexture(
parameter : EffectHandle
) : Texture;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueVector(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueVector Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a vector.

Definition

Visual Basic .NET Public Function GetValueVector( _
ByVal parameter As EffectHandle _
) As Vector4
C# public Vector4 GetValueVector(
EffectHandle parameter
);
Managed C++ public: Vector4 GetValueVector(
EffectHandle *parameter
);
JScript .NET public function GetValueVector(
parameter : EffectHandle
) : Vector4;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueVectorArray(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueVectorArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of vectors.

Definition

Visual Basic .NET Public Function GetValueVectorArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Vector4()
C# public Vector4[] GetValueVectorArray(
EffectHandle parameter,
int count
);
Managed C++ public: Vector4 GetValueVectorArray(
EffectHandle *parameter,
int count
) __gc[];
JScript .NET public function GetValueVectorArray(
parameter : EffectHandle,
count : int
) : Vector4[];

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
count | System.Int32. Number of vectors in the returned array.

Return Value

Microsoft.DirectX.Vector4[]. Array of Vector4 objects.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueVertexShader(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.GetValueVertexShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a vertex shader.

Definition

Visual Basic .NET Public Function GetValueVertexShader( _
ByVal parameter As EffectHandle _
) As VertexShader
C# public VertexShader GetValueVertexShader(
EffectHandle parameter
);
Managed C++ public: VertexShader* GetValueVertexShader(
EffectHandle *parameter
);
JScript .NET public function GetValueVertexShader(
parameter : EffectHandle
) : VertexShader;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Direct3D.VertexShader . A VertexShader object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.op_Equality(BaseEffect,BaseEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As BaseEffect, _
ByVal right As BaseEffect _
) As Boolean
C# public static bool op_Equality(
BaseEffect left,
BaseEffect right
);
Managed C++ public: static bool op_Equality(
BaseEffect *left,
BaseEffect *right
);
JScript .NET public static function op_Equality(
left : BaseEffect,
right : BaseEffect
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.BaseEffect. The BaseEffect object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.BaseEffect. The BaseEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

Effect, EffectCompiler


BaseEffect.op_Inequality(BaseEffect,BaseEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As BaseEffect, _
ByVal right As BaseEffect _
) As Boolean
C# public static bool op_Inequality(
BaseEffect left,
BaseEffect right
);
Managed C++ public: static bool op_Inequality(
BaseEffect *left,
BaseEffect *right
);
JScript .NET public static function op_Inequality(
left : BaseEffect,
right : BaseEffect
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.BaseEffect. The BaseEffect object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.BaseEffect. The BaseEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

Applies To

Effect, EffectCompiler


BaseEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.BaseEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.

Applies To

Effect, EffectCompiler


BaseEffect.SetValueTranspose

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a transposed matrix.

Overload List

public void SetValueTranspose(EffectHandle, Matrix);
public void SetValueTranspose(EffectHandle, Matrix[]);

Remarks

Exceptions
InvalidCallException The call is invalid.


BaseEffect.SetValueTranspose(EffectHandle,Matrix[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a transposed matrix.

Definition

Visual Basic .NET Public Sub SetValueTranspose( _
ByVal parameter As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValueTranspose(
EffectHandle parameter,
Matrix[] matrix
);
Managed C++ public: void SetValueTranspose(
EffectHandle *parameter,
Matrix matrix __gc[]
);
JScript .NET public function SetValueTranspose(
parameter : EffectHandle,
matrix : Matrix[]
);

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
matrix | Microsoft.DirectX.Matrix[]. Array of Matrix structures to set.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.SetValueTranspose(EffectHandle,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a transposed matrix.

Definition

Visual Basic .NET Public Sub SetValueTranspose( _
ByVal parameter As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValueTranspose(
EffectHandle parameter,
Matrix matrix
);
Managed C++ public: void SetValueTranspose(
EffectHandle *parameter,
Matrix matrix
);
JScript .NET public function SetValueTranspose(
parameter : EffectHandle,
matrix : Matrix
);

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. Unique EffectHandle identifier.
matrix | Microsoft.DirectX.Matrix. A Matrix structure to set.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.UpdateUnmanagedPointer(ID3DXBaseEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXBaseEffect _
)
C# public void UpdateUnmanagedPointer(
ID3DXBaseEffect pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXBaseEffect pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXBaseEffect
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseEffect. Pointer to the ID3DXBaseEffect structure used to update the unmanaged pointer for this BaseEffect object.

Applies To

Effect, EffectCompiler


BaseEffect.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an effect description.

Definition

Visual Basic .NET | Public ReadOnly Property Description As EffectDescription
C# | public EffectDescription Description { get; }
Managed C++ | public: __property EffectDescription get_Description();
JScript .NET | public function get Description() : EffectDescription

Property Value

Microsoft.DirectX.Direct3D.EffectDescription . An EffectDescription object that contains the effect description.

This property is read-only.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

Effect, EffectCompiler


BaseEffect.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXBaseEffect
C# | public ID3DXBaseEffect UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXBaseEffect get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXBaseEffect

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseEffect . Unmanaged ID3DXBaseEffect interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.

Applies To

Effect, EffectCompiler


BaseEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the BaseEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.BaseEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the BaseEffect object indicates whether that object has been disposed.

Applies To

Effect, EffectCompiler


Microsoft.DirectX.Direct3D.BaseMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates and queries mesh objects and derived mesh objects.

Definition

Visual Basic .NET MustInherit Public Class BaseMesh
Inherits MarshalByRefObject
Implements IDisposable
C# public abstract class BaseMesh : MarshalByRefObject,
IDisposable
Managed C++ public __gc __abstract class BaseMesh : public MarshalByRefObject,
IDisposable
JScript .NET public abstract class BaseMesh extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the BaseMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
BaseMesh | Initializes a new instance of the BaseMesh class.
Clone | Clones, or copies, a mesh object.
ComputeNormals | Computes normals for each vertex in a mesh.
ConvertAdjacencyToPointReps | Converts mesh adjacency information to an array of point representatives.
ConvertPointRepsToAdjacency | Converts point representative data to mesh adjacency information.
Dispose | Immediately releases the unmanaged resources used by the BaseMesh object.
DrawSubset | Draws a subset of a mesh.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseMesh object to free resources before it is destroyed by the garbage collector.
GenerateAdjacency | Generates adjacency information based on mesh indices.
GetAttributeTable | Retrieves an attribute table for a mesh.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
LockIndexBuffer | Locks an index buffer and obtains the index buffer data.
LockVertexBuffer | Locks a vertex buffer and obtains a pointer to the vertex buffer memory.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.BaseMesh.Disposing event when called from within a derived class.
SetIndexBufferData | Sets index buffer data.
SetVertexBufferData | Sets vertex buffer data.
UnlockIndexBuffer | Unlocks an index buffer.
UnlockVertexBuffer | Unlocks a vertex buffer.
UpdateSemantics Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Declaration | Retrieves a declaration that describes the vertices in a mesh.
Device | Retrieves the device associated with a mesh.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the data in an index buffer.
NumberAttributes | Retrieves the number of entries stored in an attribute table for a mesh.
NumberBytesPerVertex | Retrieves the number of bytes per vertex.
NumberFaces | Retrieves the number of faces in a mesh.
NumberVertices | Retrieves the number of vertices in a mesh.
Options | Retrieves the mesh options enabled for the current mesh at creation time.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer.
VertexBuffer | Retrieves the vertex buffer of a mesh.
VertexFormat | Retrieves the vertex format that describes the contents of vertices.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseMesh
Mesh
ProgressiveMesh

Remarks

A mesh is an object made up of a set of polygonal faces. It defines a set of vertices and a set of faces. The faces are defined in terms of the vertices and normals of the mesh.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Mesh
  • PatchMesh
  • ProgressiveMesh
  • SimplificationMesh


BaseMesh.BaseMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.BaseMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseMesh class.

Overload List

public BaseMesh(ID3DXBaseMesh);
public BaseMesh(IntPtr);


BaseMesh.BaseMesh(ID3DXBaseMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.BaseMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXBaseMesh _
)
C# public BaseMesh(
ID3DXBaseMesh pUnk
);
Managed C++ public: BaseMesh(
ID3DXBaseMesh pUnk
);
JScript .NET public function BaseMesh(
pUnk : ID3DXBaseMesh
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseMesh. Unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer.


BaseMesh.BaseMesh(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.BaseMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public BaseMesh(
IntPtr unmanagedObject
);
Managed C++ public: BaseMesh(
IntPtr unmanagedObject
);
JScript .NET public function BaseMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXBaseMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


BaseMesh.Clone

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Overload List

public Mesh Clone(MeshFlags, GraphicsStream, Device);
public Mesh Clone(MeshFlags, VertexElement[], Device);
public Mesh Clone(MeshFlags, VertexFormats, Device);

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.Clone(MeshFlags,GraphicsStream,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration As GraphicsStream, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
GraphicsStream declaration,
Device device
);
Managed C++ public: Mesh* Clone(
MeshFlags options,
GraphicsStream *declaration,
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
declaration : GraphicsStream,
device : Device
) : Mesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, as specified with one or more MeshFlags flags (excepting the Simplify* and Optimize* flags, which should not be used for this purpose).
declaration | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the mesh data to duplicate.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Cloned mesh.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.Clone(MeshFlags,VertexElement[],Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexElement[] declaration,
Device device
);
Managed C++ public: Mesh* Clone(
MeshFlags options,
VertexElement declaration __gc[],
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
declaration : VertexElement[],
device : Device
) : Mesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, as specified with one or more MeshFlags flags (excepting the Simplify* and Optimize* flags, which should not be used for this purpose).
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. Vertex data, as defined with an array of VertexElement structures.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Cloned mesh.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.Clone(MeshFlags,VertexFormats,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
Managed C++ public: Mesh* Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
) : Mesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, as specified with one or more MeshFlags flags (excepting the Simplify* and Optimize* flags, which should not be used for this purpose).
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Mesh vertex format, as specified with one or more VertexFormats flags.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Cloned mesh.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.ComputeNormals

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ComputeNormals Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Overload List

public void ComputeNormals();
public void ComputeNormals(GraphicsStream);
public void ComputeNormals(int[]);

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}


BaseMesh.ComputeNormals()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ComputeNormals Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Definition

Visual Basic .NET | Public Sub ComputeNormals()
C# | public void ComputeNormals();
Managed C++ | public: void ComputeNormals();
JScript .NET | public function ComputeNormals();

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.ComputeNormals(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ComputeNormals Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Definition

Visual Basic .NET Public Sub ComputeNormals( _
ByVal adjacency() As Integer _
)
C# public void ComputeNormals(
int[] adjacency
);
Managed C++ public: void ComputeNormals(
int adjacency __gc[]
);
JScript .NET public function ComputeNormals(
adjacency : int[]
);

Parameters

adjacency System.Int32[]. Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.ComputeNormals(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ComputeNormals Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Definition

Visual Basic .NET Public Sub ComputeNormals( _
ByVal adjacency As GraphicsStream _
)
C# public void ComputeNormals(
GraphicsStream adjacency
);
Managed C++ public: void ComputeNormals(
GraphicsStream *adjacency
);
JScript .NET public function ComputeNormals(
adjacency : GraphicsStream
);

Parameters

adjacency Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.ConvertAdjacencyToPointReps

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ConvertAdjacencyToPointReps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts mesh adjacency information to an array of point representatives.

Overload List

public int[] ConvertAdjacencyToPointReps(GraphicsStream);
public int[] ConvertAdjacencyToPointReps(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • BaseMesh.ConvertPointRepsToAdjacency


BaseMesh.ConvertAdjacencyToPointReps(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ConvertAdjacencyToPointReps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts mesh adjacency information to an array of point representatives.

Definition

Visual Basic .NET Public Function ConvertAdjacencyToPointReps( _
ByVal adjacency As GraphicsStream _
) As Integer()
C# public int[] ConvertAdjacencyToPointReps(
GraphicsStream adjacency
);
Managed C++ public: int ConvertAdjacencyToPointReps(
GraphicsStream *adjacency
) __gc[];
JScript .NET public function ConvertAdjacencyToPointReps(
adjacency : GraphicsStream
) : int[];

Parameters

adjacency Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Return Value

System.Int32[]. Array that contains one Int32 Leave Site per vertex of the mesh that is filled with point representative data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.ConvertPointRepsToAdjacency


BaseMesh.ConvertAdjacencyToPointReps(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ConvertAdjacencyToPointReps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts mesh adjacency information to an array of point representatives.

Definition

Visual Basic .NET Public Function ConvertAdjacencyToPointReps( _
ByVal adjaceny() As Integer _
) As Integer()
C# public int[] ConvertAdjacencyToPointReps(
int[] adjaceny
);
Managed C++ public: int ConvertAdjacencyToPointReps(
int adjaceny __gc[]
) __gc[];
JScript .NET public function ConvertAdjacencyToPointReps(
adjaceny : int[]
) : int[];

Parameters

adjaceny System.Int32[]. Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Return Value

System.Int32[]. Array that contains one Int32 Leave Site per vertex of the mesh that is filled with point representative data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.ConvertPointRepsToAdjacency


BaseMesh.ConvertPointRepsToAdjacency

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ConvertPointRepsToAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts point representative data to mesh adjacency information.

Overload List

public int[] ConvertPointRepsToAdjacency(GraphicsStream);
public int[] ConvertPointRepsToAdjacency(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • ConvertAdjacencyToPointReps


BaseMesh.ConvertPointRepsToAdjacency(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ConvertPointRepsToAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts point representative data to mesh adjacency information.

Definition

Visual Basic .NET Public Function ConvertPointRepsToAdjacency( _
ByVal pointReps As GraphicsStream _
) As Integer()
C# public int[] ConvertPointRepsToAdjacency(
GraphicsStream pointReps
);
Managed C++ public: int ConvertPointRepsToAdjacency(
GraphicsStream *pointReps
) __gc[];
JScript .NET public function ConvertPointRepsToAdjacency(
pointReps : GraphicsStream
) : int[];

Parameters

pointReps Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains one Int32 Leave Site per vertex of the mesh that represents point representative data. This parameter is optional; supplying a value of 0 causes it to be interpreted as an "identity" array.

Return Value

System.Int32[]. Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • ConvertAdjacencyToPointReps


BaseMesh.ConvertPointRepsToAdjacency(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.ConvertPointRepsToAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts point representative data to mesh adjacency information.

Definition

Visual Basic .NET Public Function ConvertPointRepsToAdjacency( _
ByVal pointReps() As Integer _
) As Integer()
C# public int[] ConvertPointRepsToAdjacency(
int[] pointReps
);
Managed C++ public: int ConvertPointRepsToAdjacency(
int pointReps __gc[]
) __gc[];
JScript .NET public function ConvertPointRepsToAdjacency(
pointReps : int[]
) : int[];

Parameters

pointReps System.Int32[]. Array that contains one Int32 Leave Site per vertex of the mesh that contains point representative data. This parameter is optional; supplying a value of 0 causes it to be interpreted as an "identity" array.

Return Value

System.Int32[]. Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • ConvertAdjacencyToPointReps


BaseMesh.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the BaseMesh object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

Applies To

Mesh, ProgressiveMesh

See Also

  • Microsoft.DirectX.Direct3D.BaseMesh.Disposed
  • Microsoft.DirectX.Direct3D.BaseMesh.Disposing


BaseMesh.DrawSubset(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.DrawSubset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws a subset of a mesh.

Definition

Visual Basic .NET Public Sub DrawSubset( _
ByVal attributeID As Integer _
)
C# public void DrawSubset(
int attributeID
);
Managed C++ public: void DrawSubset(
int attributeID
);
JScript .NET public function DrawSubset(
attributeID : int
);

Parameters

attributeID System.Int32. An Int32 Leave Site that specifies which subset of the mesh to draw. This value is used to differentiate faces in a mesh as belonging to one or more attribute groups.

Remarks

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states and materials. The application can use the attribute table to hide portions of a mesh by leaving out a given attribute identifier (attributeID) when drawing the frame. Attribute tables can also be used for application defined purposes.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • GetAttributeTable


BaseMesh.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the BaseMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~BaseMesh();
Managed C++ | ~BaseMesh();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GenerateAdjacency(Single,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.GenerateAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates adjacency information based on mesh indices.

Definition

Visual Basic .NET Public Sub GenerateAdjacency( _
ByVal epsilon As Single, _
ByVal adjacency() As Integer _
)
C# public void GenerateAdjacency(
float epsilon,
int[] adjacency
);
Managed C++ public: void GenerateAdjacency(
float epsilon,
int adjacency __gc[]
);
JScript .NET public function GenerateAdjacency(
epsilon : float,
adjacency : int[]
);

Parameters

epsilon | System.Single. Specifies that vertices that differ in position by less than epsilon should be treated as coincident.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face to be filled with adjacent face indices. The size of this array must be at least 3 * BaseMesh.NumberFaces.

Remarks

The GenerateAdjacency method determines which patches are adjacent (within the provided tolerance). This information is used internally to optimize tessellation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GetAttributeTable()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.GetAttributeTable Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an attribute table for a mesh.

Definition

Visual Basic .NET | Public Function GetAttributeTable() As AttributeRange()
C# | public AttributeRange[] GetAttributeTable();
Managed C++ | public: AttributeRange GetAttributeTable() __gc[];
JScript .NET | public function GetAttributeTable() : AttributeRange[];

Return Value

Microsoft.DirectX.Direct3D.AttributeRange[]. Array of AttributeRange structures, which represent each entry in the attribute table.

Remarks

An attribute table is created by calling Mesh.Optimize and passing OptimizeAttrSort for the param_MeshFlags_flags parameter.

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states and materials. The application can use the attribute table to hide portions of a mesh by leaving out a given attribute identifier (attributeID) when drawing the frame. Attribute tables can also be used for application defined purposes.

Exceptions
ArgumentException Leave Site | There is no attribute table.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXBaseMesh, which allows unmanaged COM clients to create an instance of the managed BaseMesh class. Not supported.

Applies To

Mesh, ProgressiveMesh


BaseMesh.LockIndexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.LockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks an index buffer and obtains the index buffer data.

Overload List

public GraphicsStream LockIndexBuffer(LockFlags);
public Array LockIndexBuffer(Type, LockFlags, int[]);

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set index buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • IndexBuffer
  • SetIndexBufferData
  • UnlockIndexBuffer


BaseMesh.LockIndexBuffer(Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.LockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks an index buffer and obtains the index buffer data.

Definition

Visual Basic .NET Public Function LockIndexBuffer( _
ByVal typeIndex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockIndexBuffer(
Type typeIndex,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockIndexBuffer(
Type *typeIndex,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockIndexBuffer(
typeIndex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeIndex | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set index buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • IndexBuffer
  • SetIndexBufferData
  • UnlockIndexBuffer


BaseMesh.LockIndexBuffer(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.LockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks an index buffer and obtains the index buffer data.

Definition

Visual Basic .NET Public Function LockIndexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockIndexBuffer(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockIndexBuffer(
LockFlags flags
);
JScript .NET public function LockIndexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set index buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • IndexBuffer
  • SetIndexBufferData
  • UnlockIndexBuffer


BaseMesh.LockVertexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.LockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a vertex buffer and obtains a pointer to the vertex buffer memory.

Overload List

public GraphicsStream LockVertexBuffer(LockFlags);
public Array LockVertexBuffer(Type, LockFlags, int[]);

Remarks

When working with vertex buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set vertex buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • VertexBuffer
  • UnlockVertexBuffer
  • SetVertexBufferData


BaseMesh.LockVertexBuffer(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.LockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a vertex buffer and obtains a pointer to the vertex buffer memory.

Definition

Visual Basic .NET Public Function LockVertexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockVertexBuffer(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockVertexBuffer(
LockFlags flags
);
JScript .NET public function LockVertexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set vertex buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • VertexBuffer
  • UnlockVertexBuffer
  • SetVertexBufferData


BaseMesh.LockVertexBuffer(Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.LockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a vertex buffer and obtains a pointer to the vertex buffer memory.

Definition

Visual Basic .NET Public Function LockVertexBuffer( _
ByVal typeVertex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockVertexBuffer(
Type typeVertex,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockVertexBuffer(
Type *typeVertex,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockVertexBuffer(
typeVertex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeVertex | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set vertex buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • VertexBuffer
  • UnlockVertexBuffer
  • SetVertexBufferData


BaseMesh.op_Equality(BaseMesh,BaseMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As BaseMesh, _
ByVal right As BaseMesh _
) As Boolean
C# public static bool op_Equality(
BaseMesh left,
BaseMesh right
);
Managed C++ public: static bool op_Equality(
BaseMesh *left,
BaseMesh *right
);
JScript .NET public static function op_Equality(
left : BaseMesh,
right : BaseMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.BaseMesh. The BaseMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.BaseMesh. The BaseMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

Mesh, ProgressiveMesh


BaseMesh.op_Inequality(BaseMesh,BaseMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As BaseMesh, _
ByVal right As BaseMesh _
) As Boolean
C# public static bool op_Inequality(
BaseMesh left,
BaseMesh right
);
Managed C++ public: static bool op_Inequality(
BaseMesh *left,
BaseMesh *right
);
JScript .NET public static function op_Inequality(
left : BaseMesh,
right : BaseMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.BaseMesh. The BaseMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.BaseMesh. The BaseMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

Applies To

Mesh, ProgressiveMesh


BaseMesh.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.BaseMesh.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.

Applies To

Mesh, ProgressiveMesh


BaseMesh.SetIndexBufferData(Object,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.SetIndexBufferData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets index buffer data.

Definition

Visual Basic .NET Public Sub SetIndexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetIndexBufferData(
object data,
LockFlags flags
);
Managed C++ public: void SetIndexBufferData(
Object *data,
LockFlags flags
);
JScript .NET public function SetIndexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data | System.Object. An Object Leave Site that contains the data to copy into the index buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetIndexBufferData method locks, sets, and then unlocks the index buffer. A call to UnlockIndexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.SetVertexBufferData(Object,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.SetVertexBufferData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets vertex buffer data.

Definition

Visual Basic .NET Public Sub SetVertexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetVertexBufferData(
object data,
LockFlags flags
);
Managed C++ public: void SetVertexBufferData(
Object *data,
LockFlags flags
);
JScript .NET public function SetVertexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data | System.Object. An Object Leave Site that contains the data to copy into the vertex buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetVertexBufferData method locks, sets, and then unlocks the vertex buffer. A call to UnlockVertexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UnlockIndexBuffer()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.UnlockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks an index buffer.

Definition

Visual Basic .NET | Public Sub UnlockIndexBuffer()
C# | public void UnlockIndexBuffer();
Managed C++ | public: void UnlockIndexBuffer();
JScript .NET | public function UnlockIndexBuffer();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • LockIndexBuffer
  • SetIndexBufferData
  • IndexBuffer


BaseMesh.UnlockVertexBuffer()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.UnlockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks a vertex buffer.

Definition

Visual Basic .NET | Public Sub UnlockVertexBuffer()
C# | public void UnlockVertexBuffer();
Managed C++ | public: void UnlockVertexBuffer();
JScript .NET | public function UnlockVertexBuffer();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • LockVertexBuffer
  • SetVertexBufferData
  • IndexBuffer


BaseMesh.UpdateSemantics

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.UpdateSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.

Overload List

public void UpdateSemantics(GraphicsStream);
public void UpdateSemantics(VertexElement[]);

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout. For example, it can be used to add space for new normals, texture coordinates, colors, and weights that were not present before.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. For example, it can be used to re-label a 3-D texture coordinate as a binormal or a tangent, or vice versa.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


BaseMesh.UpdateSemantics(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.UpdateSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.

Definition

Visual Basic .NET Public Sub UpdateSemantics( _
ByVal declaration As GraphicsStream _
)
C# public void UpdateSemantics(
GraphicsStream declaration
);
Managed C++ public: void UpdateSemantics(
GraphicsStream *declaration
);
JScript .NET public function UpdateSemantics(
declaration : GraphicsStream
);

Parameters

declaration Microsoft.DirectX.GraphicsStream. A GraphicsStream containing VertexElement structures that describe the vertex format of the mesh vertices.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout. For example, it can be used to add space for new normals, texture coordinates, colors, and weights that were not present before.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. For example, it can be used to re-label a 3-D texture coordinate as a binormal or a tangent, or vice versa.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UpdateSemantics(VertexElement[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.UpdateSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.

Definition

Visual Basic .NET Public Sub UpdateSemantics( _
ByVal declaration() As VertexElement _
)
C# public void UpdateSemantics(
VertexElement[] declaration
);
Managed C++ public: void UpdateSemantics(
VertexElement declaration __gc[]
);
JScript .NET public function UpdateSemantics(
declaration : VertexElement[]
);

Parameters

declaration Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that describe the vertex format of the mesh vertices.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout. For example, it can be used to add space for new normals, texture coordinates, colors, and weights that were not present before.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. For example, it can be used to re-label a 3-D texture coordinate as a binormal or a tangent, or vice versa.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UpdateUnmanagedPointer(ID3DXBaseMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXBaseMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXBaseMesh pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXBaseMesh pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXBaseMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseMesh. Pointer to the ID3DXBaseMesh structure used to update the unmanaged pointer for this BaseMesh object.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Declaration

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Declaration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a declaration that describes the vertices in a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; }
Managed C++ | public: __property VertexElement get_Declaration();
JScript .NET | public function get Declaration() : VertexElement[]

Property Value

Microsoft.DirectX.Direct3D.VertexElement[] . Array of VertexElement structures that describe the vertex format of the mesh vertices. The vertex element array ends with the value specified in the VertexElement.VertexDeclarationEnd field.

This property is read-only.

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.VertexFormatTopic


BaseMesh.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the device associated with a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . A Device object that represents the Microsoft® Direct3D® device object associated with the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.IndexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.IndexBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the data in an index buffer.

Definition

Visual Basic .NET | Public ReadOnly Property IndexBuffer As IndexBuffer
C# | public IndexBuffer IndexBuffer { get; }
Managed C++ | public: __property IndexBuffer* get_IndexBuffer();
JScript .NET | public function get IndexBuffer() : IndexBuffer

Property Value

Microsoft.DirectX.Direct3D.IndexBuffer . An IndexBuffer object that represents the index buffer object associated with the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberAttributes

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.NumberAttributes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of entries stored in an attribute table for a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberAttributes As Integer
C# | public int NumberAttributes { get; }
Managed C++ | public: __property int get_NumberAttributes();
JScript .NET | public function get NumberAttributes() : int

Property Value

System.Int32 . An integer value that represents the number of entries stored in the attribute table for the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberBytesPerVertex

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.NumberBytesPerVertex Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of bytes per vertex.

Definition

Visual Basic .NET | Public ReadOnly Property NumberBytesPerVertex As Integer
C# | public int NumberBytesPerVertex { get; }
Managed C++ | public: __property int get_NumberBytesPerVertex();
JScript .NET | public function get NumberBytesPerVertex() : int

Property Value

System.Int32 . Number of bytes per vertex.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.NumberFaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of faces in a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberFaces As Integer
C# | public int NumberFaces { get; }
Managed C++ | public: __property int get_NumberFaces();
JScript .NET | public function get NumberFaces() : int

Property Value

System.Int32 . Number of faces in the mesh.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.NumberVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of vertices in a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
Managed C++ | public: __property int get_NumberVertices();
JScript .NET | public function get NumberVertices() : int

Property Value

System.Int32 . Number of vertices in the mesh.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Options

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Options Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the mesh options enabled for the current mesh at creation time.

Definition

Visual Basic .NET | Public ReadOnly Property Options As MeshOptions
C# | public MeshOptions Options { get; }
Managed C++ | public: __property MeshOptions get_Options();
JScript .NET | public function get Options() : MeshOptions

Property Value

Microsoft.DirectX.Direct3D.MeshOptions . A MeshOptions structure that contains the options enabled for the mesh at creation time.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXBaseMesh
C# | public ID3DXBaseMesh UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXBaseMesh get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXBaseMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseMesh . Unmanaged ID3DXBaseMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.

Applies To

Mesh, ProgressiveMesh


BaseMesh.VertexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.VertexBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Compute a Bounding Sphere from a Mesh

Retrieves the vertex buffer of a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property VertexBuffer As VertexBuffer
C# | public VertexBuffer VertexBuffer { get; }
Managed C++ | public: __property VertexBuffer* get_VertexBuffer();
JScript .NET | public function get VertexBuffer() : VertexBuffer

Property Value

Microsoft.DirectX.Direct3D.VertexBuffer . A VertexBuffer object that contains the vertex data associated with the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.VertexFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.VertexFormat Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Clone a Mesh

Retrieves the vertex format that describes the contents of vertices.

Definition

Visual Basic .NET | Public ReadOnly Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; }
Managed C++ | public: __property VertexFormats get_VertexFormat();
JScript .NET | public function get VertexFormat() : VertexFormats

Property Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object that describes the content of the vertices associated with the mesh.

This property is read-only.

Remarks

If the vertex format cannot be mapped directly to a flexible vertex format (FVF) code, this method can return 0. This can occur when a mesh created from a vertex declaration does not have the same order and elements as those supported by the FVF codes.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseMesh.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the BaseMesh object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.BaseMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the BaseMesh object indicates whether that object has been disposed.

Applies To

Mesh, ProgressiveMesh


Microsoft.DirectX.Direct3D.BaseTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates texture resources, including cube and volume textures.

Definition

Visual Basic .NET MustInherit Public Class BaseTexture
Inherits Resource
C# | public abstract class BaseTexture : Resource
Managed C++ | public __gc __abstract class BaseTexture : public Resource
JScript .NET | public abstract class BaseTexture extends Resource

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BaseTexture | Initializes a new instance of the BaseTexture class.
Dispose | Immediately releases the unmanaged resources used by the Resource object. Inherited from Resource.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GenerateMipSubLevels | Generates mipmap sublevels.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels.
Device | Retrieves the device associated with a resource. Inherited from Resource.
LevelCount | Retrieves the number of texture levels in a multilevel texture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
CubeTexture
Texture
VolumeTexture

Remarks

The BaseTexture object assigned to a particular stage for a device is obtained by calling the Device.GetTexture method.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BaseTexture.BaseTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.BaseTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseTexture class.

Overload List

public BaseTexture(IDirect3DBaseTexture9);
public BaseTexture(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


BaseTexture.BaseTexture(IDirect3DBaseTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.BaseTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As IDirect3DBaseTexture9 _
)
C# public BaseTexture(
IDirect3DBaseTexture9 pInterop
);
Managed C++ public: BaseTexture(
IDirect3DBaseTexture9 pInterop
);
JScript .NET public function BaseTexture(
pInterop : IDirect3DBaseTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DBaseTexture9. Unmanaged Component Object Model (COM) IDirect3DBaseTexture9 interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


BaseTexture.BaseTexture(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.BaseTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BaseTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public BaseTexture(
IntPtr unmanagedObject
);
Managed C++ public: BaseTexture(
IntPtr unmanagedObject
);
JScript .NET public function BaseTexture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DBaseTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


BaseTexture.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.GenerateMipSubLevels()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.GenerateMipSubLevels Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates mipmap sublevels.

Definition

Visual Basic .NET | Public Sub GenerateMipSubLevels()
C# | public void GenerateMipSubLevels();
Managed C++ | public: void GenerateMipSubLevels();
JScript .NET | public function GenerateMipSubLevels();

Remarks

An application can generate mipmap sublevels at any time by calling BaseTexture.GenerateMipSubLevels. To have mipmap sublevels generated automatically at texture creation time, specify AutoGenerateMipMap when calling the Texture, CubeTexture, and VolumeTexture constructors. For more information about usage constants, see Usage.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • BaseTexture.AutoGenerateFilterType


BaseTexture.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DBaseTexture9, which allows unmanaged COM clients to create an instance of the managed BaseTexture class. Not supported.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.op_Equality(BaseTexture,BaseTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As BaseTexture, _
ByVal right As BaseTexture _
) As Boolean
C# public static bool op_Equality(
BaseTexture left,
BaseTexture right
);
Managed C++ public: static bool op_Equality(
BaseTexture *left,
BaseTexture *right
);
JScript .NET public static function op_Equality(
left : BaseTexture,
right : BaseTexture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.BaseTexture. The BaseTexture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.BaseTexture. The BaseTexture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.op_Inequality(BaseTexture,BaseTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As BaseTexture, _
ByVal right As BaseTexture _
) As Boolean
C# public static bool op_Inequality(
BaseTexture left,
BaseTexture right
);
Managed C++ public: static bool op_Inequality(
BaseTexture *left,
BaseTexture *right
);
JScript .NET public static function op_Inequality(
left : BaseTexture,
right : BaseTexture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.BaseTexture. The BaseTexture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.BaseTexture. The BaseTexture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.SetLevelOfDetail(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.SetLevelOfDetail Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the most detailed level of detail (LOD) for a managed texture.

Definition

Visual Basic .NET Public Function SetLevelOfDetail( _
ByVal lodNew As Integer _
) As Integer
C# public int SetLevelOfDetail(
int lodNew
);
Managed C++ public: int SetLevelOfDetail(
int lodNew
);
JScript .NET public function SetLevelOfDetail(
lodNew : int
) : int;

Parameters

lodNew System.Int32. Most detailed LOD value to set for the chain.

Return Value

System.Int32 . An Int32 Leave Site value, clamped to the maximum LOD value (one less than the total number of levels). Subsequent calls to this method return the maximum value, not the previously set LOD value.

Remarks

The BaseTexture.SetLevelOfDetail method is used for LOD control of managed textures. The method communicates to the Microsoft® Direct3D® texture manager the most detailed mipmap in the chain that should be loaded into local video memory. For example, in a five-level mipmap chain, setting param_Int32_lodNew to 2 indicates that the texture manager should load only mipmap levels 2 through 4 into local video memory at any given time.

More specifically, if the texture was created with the dimensions of 256x256, setting the most detailed level to 0 indicates that 256x256 is the largest mipmap available, setting the most detailed level to 1 indicates that 128x128 is the largest mipmap available, and so on, up to the most detailed mip level (the smallest texture size) for the chain.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • BaseTexture.LevelOfDetail


BaseTexture.UpdateUnmanagedPointer(IDirect3DBaseTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this BaseTexture object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DBaseTexture9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DBaseTexture9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DBaseTexture9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DBaseTexture9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DBaseTexture9. Pointer to the IDirect3DBaseTexture9 structure used to update the unmanaged pointer for this BaseTexture object.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.AutoGenerateFilterType

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.AutoGenerateFilterType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the filter type used for automatically generated sublevels.

Definition

Visual Basic .NET | Public Property AutoGenerateFilterType As TextureFilter
C# | public TextureFilter AutoGenerateFilterType { get; set; }
Managed C++ public: __property TextureFilter get_AutoGenerateFilterType();
public: __property void set_AutoGenerateFilterType(TextureFilter);
JScript .NET public function get AutoGenerateFilterType() : TextureFilter
public function set AutoGenerateFilterType(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter . A TextureFilter. A texture must be created with Usage.AutoGenerateMipMap to use this property. Any other usage value sets this property to TextureFilter.None.

This property is read/write.

Remarks

Changing the filter type "dirties" the mipmap sublevels and causes them to be regenerated.

The (default) filter type set at texture creation time is Linear. If the driver does not support a linear filter, the filter type is set to Point. All filter types supported by the driver for regular texture filtering are supported for autogeneration except None. Setting the AutoGenerateFilterType property fails unless the driver sets the appropriate SupportsMinify* caps. These values are specified in the Caps.FilterCaps and/or Caps.CubeTextureFilterCaps members. For more information about texture filter types, see TextureFilter.

If the texture is not created with AutoGenerateMipMap, this method has no effect. In this case, an exception is not thrown. For more information about usage constants, see Usage.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • GenerateMipSubLevels


BaseTexture.LevelCount

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.LevelCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of texture levels in a multilevel texture.

Definition

Visual Basic .NET | Public ReadOnly Property LevelCount As Integer
C# | public int LevelCount { get; }
Managed C++ | public: __property int get_LevelCount();
JScript .NET | public function get LevelCount() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of texture levels in the multilevel texture.

This property is read-only.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.LevelOfDetail

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.LevelOfDetail Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the most detailed level of detail (LOD) for a managed texture.

Definition

Visual Basic .NET | Public Property LevelOfDetail As Integer
C# | public int LevelOfDetail { get; set; }
Managed C++ public: __property int get_LevelOfDetail();
public: __property void set_LevelOfDetail(int);
JScript .NET public function get LevelOfDetail() : int
public function set LevelOfDetail(int);

Property Value

System.Int32 . Most detailed LOD value to set in the chain.

This property is read/write.

Remarks

This property returns 0 on nonmanaged textures.

Setting LevelOfDetail communicates to the Microsoft® Direct3D® texture manager the most detailed mipmap in the chain that should be loaded into local video memory. For example, in a five-level mipmap chain, setting LevelOfDetail to 2 indicates that the texture manager should load only mipmap levels 2 through 4 into local video memory at any given time.

More specifically, if the texture was created with the dimensions of 256x256, setting the most detailed level to 0 indicates that 256x256 is the largest mipmap available, setting the most detailed level to 1 indicates that 128x128 is the largest mipmap available, and so on, up to the most detailed mip level (the smallest texture size) for the chain.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • SetLevelOfDetail


BaseTexture.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

BaseTexture.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DBaseTexture9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DBaseTexture9
C# | public IDirect3DBaseTexture9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DBaseTexture9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DBaseTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DBaseTexture9 . Unmanaged IDirect3DBaseTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.

Applies To

CubeTexture, Texture, VolumeTexture


Microsoft.DirectX.Direct3D.CannotAttributeSortException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotAttributeSortException Class

Language:
Note: This documentation is preliminary and is subject to change.

Attribute sort is not supported as an optimization technique. For more information, see MeshFlags.OptimizeAttrSort.

Definition

Visual Basic .NET Public Class CannotAttributeSortException
Inherits Direct3DXException
C# | public class CannotAttributeSortException : Direct3DXException
Managed C++ | public __gc class CannotAttributeSortException : public Direct3DXException
JScript .NET | public class CannotAttributeSortException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotAttributeSortException | Initializes a new instance of the CannotAttributeSortException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
CannotAttributeSortException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotAttributeSortException.CannotAttributeSortException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotAttributeSortException class.

Overload List

public CannotAttributeSortException();
protected CannotAttributeSortException(SerializationInfo, StreamingContext);
public CannotAttributeSortException(string);
public CannotAttributeSortException(string, Exception);


CannotAttributeSortException.CannotAttributeSortException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotAttributeSortException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotAttributeSortException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotAttributeSortException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


CannotAttributeSortException.CannotAttributeSortException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotAttributeSortException(
string message,
Exception inner
);
Managed C++ public: CannotAttributeSortException(
String *message,
Exception *inner
);
JScript .NET public function CannotAttributeSortException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


CannotAttributeSortException.CannotAttributeSortException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotAttributeSortException(
string message
);
Managed C++ public: CannotAttributeSortException(
String *message
);
JScript .NET public function CannotAttributeSortException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


CannotAttributeSortException.CannotAttributeSortException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotAttributeSortException();
Managed C++ | public: CannotAttributeSortException();
JScript .NET | public function CannotAttributeSortException();


Microsoft.DirectX.Direct3D.CannotModifyIndexBufferException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotModifyIndexBufferException Class

Language:
Note: This documentation is preliminary and is subject to change.

The index buffer cannot be modified.

Definition

Visual Basic .NET Public Class CannotModifyIndexBufferException
Inherits Direct3DXException
C# | public class CannotModifyIndexBufferException : Direct3DXException
Managed C++ | public __gc class CannotModifyIndexBufferException : public Direct3DXException
JScript .NET | public class CannotModifyIndexBufferException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotModifyIndexBufferException | Initializes a new instance of the CannotModifyIndexBufferException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
CannotModifyIndexBufferException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotModifyIndexBufferException.CannotModifyIndexBufferException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotModifyIndexBufferException class.

Overload List

public CannotModifyIndexBufferException();
protected CannotModifyIndexBufferException(SerializationInfo, StreamingContext);
public CannotModifyIndexBufferException(string);
public CannotModifyIndexBufferException(string, Exception);


CannotModifyIndexBufferException.CannotModifyIndexBufferException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotModifyIndexBufferException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotModifyIndexBufferException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotModifyIndexBufferException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


CannotModifyIndexBufferException.CannotModifyIndexBufferException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotModifyIndexBufferException(
string message,
Exception inner
);
Managed C++ public: CannotModifyIndexBufferException(
String *message,
Exception *inner
);
JScript .NET public function CannotModifyIndexBufferException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


CannotModifyIndexBufferException.CannotModifyIndexBufferException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotModifyIndexBufferException(
string message
);
Managed C++ public: CannotModifyIndexBufferException(
String *message
);
JScript .NET public function CannotModifyIndexBufferException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


CannotModifyIndexBufferException.CannotModifyIndexBufferException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotModifyIndexBufferException();
Managed C++ | public: CannotModifyIndexBufferException();
JScript .NET | public function CannotModifyIndexBufferException();


Microsoft.DirectX.Direct3D.ClipPlane

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlane Class

Language:
Note: This documentation is preliminary and is subject to change.

Defines the clipping plane for a device.

Definition

Visual Basic .NET NotInheritable Public Class ClipPlane
Inherits Object
C# | public sealed class ClipPlane : Object
Managed C++ | public __gc __sealed class ClipPlane : public Object
JScript .NET | public class ClipPlane extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetSingleArray | Retrieves the coefficients of a user-defined clipping plane for the device.
SetSingleArray | Sets the coefficients of a user-defined clipping plane for the device.

Properties

Property | Description
Enabled | Enables or disables a clipping plane.
Plane | Retrieves or sets the coefficients of a user-defined clipping plane for the device.

Inheritance Hierarchy

Object Leave Site
ClipPlane

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ClipPlanes
  • Device


ClipPlane.GetSingleArray()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlane.GetSingleArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the coefficients of a user-defined clipping plane for the device.

Definition

Visual Basic .NET | Public Function GetSingleArray() As Single()
C# | public float[] GetSingleArray();
Managed C++ | public: float GetSingleArray() __gc[];
JScript .NET | public function GetSingleArray() : float[];

Return Value

System.Single[]. Returns a four-element array of values that represent the coefficients of the clipping plane, in the form of the general plane equation. See Remarks.

Remarks

The coefficients that this method reports take the form of the general plane equation. If the values in the array at pPlane are labeled A, B, C, and D in the order in which they appear in the array, they will fit into the general plane equation so that Ax + By + Cz + Dw = 0. A point with homogeneous coordinates (x, y, z, w) is visible in the half space of the plane if Ax + By + Cz + Dw > = 0. Points that exist on or behind the clipping plane are clipped from the scene.

The plane equation this method uses exists in world space and is set by a previous call to ClipPlane.SetSingleArray.


ClipPlane.SetSingleArray(Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlane.SetSingleArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the coefficients of a user-defined clipping plane for the device.

Definition

Visual Basic .NET Public Sub SetSingleArray( _
ByVal value() As Single _
)
C# public void SetSingleArray(
float[] value
);
Managed C++ public: void SetSingleArray(
float value __gc[]
);
JScript .NET public function SetSingleArray(
value : float[]
);

Parameters

value System.Single[]. A four-element array of values that represent the clipping plane coefficients to set, in the form of the general plane equation. See Remarks.

Remarks

The coefficients that this method sets take the form of the general plane equation. If the values in the array are labeled A, B, C, and D in the order in which they appear in the array, they will fit into the general plane equation so that Ax + By + Cz + Dw = 0. A point with homogeneous coordinates (x, y, z, w) is visible in the half space of the plane if Ax + By + Cz + Dw > = 0. Points that exist behind the clipping plane are clipped from the scene.

When the fixed function pipeline is used, the plane equations are assumed to be in world space. When the programmable pipeline is used, the plane equations are assumed to be in the clipping space (the same space as output vertices).

This method does not enable the clipping plane equation to be set. To enable a clipping plane, set ClipPlane.Enabled to true.

Exceptions
ArgumentException Leave Site | value cannot be null or 0.
IndexOutOfRangeException Leave Site | value must be a four-element array.

See Also

  • ClipPlane.GetSingleArray


ClipPlane.Enabled

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlane.Enabled Property

Language:
Note: This documentation is preliminary and is subject to change.

Enables or disables a clipping plane.

Definition

Visual Basic .NET | Public Property Enabled As Boolean
C# | public bool Enabled { get; set; }
Managed C++ public: __property bool get_Enabled();
public: __property void set_Enabled(bool);
JScript .NET public function get Enabled() : boolean
public function set Enabled(boolean);

Property Value

System.Boolean . Set to true to enable a clipping plane, or false to disable it.

This property is read/write.


ClipPlane.Plane

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlane.Plane Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the coefficients of a user-defined clipping plane for the device.

Definition

Visual Basic .NET | Public Property Plane As Plane
C# | public Plane Plane { get; set; }
Managed C++ public: __property Plane get_Plane();
public: __property void set_Plane(Plane);
JScript .NET public function get Plane() : Plane
public function set Plane(Plane);

Property Value

Microsoft.DirectX.Plane . User-defined clipping Plane.

This property is read/write.


Microsoft.DirectX.Direct3D.ClipPlanes

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlanes Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains the clipping planes on the device.

Definition

Visual Basic .NET NotInheritable Public Class ClipPlanes
Inherits Object
C# | public sealed class ClipPlanes : Object
Managed C++ | public __gc __sealed class ClipPlanes : public Object
JScript .NET | public class ClipPlanes extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DisableAll | Disables all clipping planes on the device.
EnableAll | Enables all clipping planes that have been set.

Properties

Property | Description
Item | Retrieves the ClipPlane object referenced by index.

Inheritance Hierarchy

Object Leave Site
ClipPlanes

Remarks

This class is a collection of ClipPlane objects that are associated with a Device.

ClipPlanes supports a maximum of 32 ClipPlane objects.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClipPlanes.DisableAll()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlanes.DisableAll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Disables all clipping planes on the device.

Definition

Visual Basic .NET | Public Sub DisableAll()
C# | public void DisableAll();
Managed C++ | public: void DisableAll();
JScript .NET | public function DisableAll();


ClipPlanes.EnableAll()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlanes.EnableAll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enables all clipping planes that have been set.

Definition

Visual Basic .NET | Public Sub EnableAll()
C# | public void EnableAll();
Managed C++ | public: void EnableAll();
JScript .NET | public function EnableAll();


ClipPlanes.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipPlanes.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the ClipPlane object referenced by index.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal index As Integer _
) As ClipPlane
C# public ClipPlane this[
int index
] { get; }
Managed C++ public: __property ClipPlane* get_Item(
int index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.Direct3D.ClipPlane . The ClipPlane referenced by index.

This property is read-only.

Parameters

index System.Int32. Index of the ClipPlane to retrieve.

Remarks

The maximum number of clipping planes is 32.

Exceptions
ArgumentOutOfRangeException Leave Site The index parameter is out of range. It must be a value between 0 and 31.


Microsoft.DirectX.Direct3D.ColorOperator

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains methods for manipulating colors.

Definition

Visual Basic .NET NotInheritable Public Class ColorOperator
Inherits Object
C# | public sealed class ColorOperator : Object
Managed C++ | public __gc __sealed class ColorOperator : public Object
JScript .NET | public class ColorOperator extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) Add | Adds two color values together to create a new color value.
static (Shared in Visual Basic .NET) AdjustContrast | Adjusts the contrast value of a color.
static (Shared in Visual Basic .NET) AdjustSaturation | Adjusts the saturation value of a color.
static (Shared in Visual Basic .NET) Lerp | Creates a color value using linear interpolation.
static (Shared in Visual Basic .NET) Modulate | Blends two colors.
static (Shared in Visual Basic .NET) Negative | Creates a negative color value from a given color value.
static (Shared in Visual Basic .NET) Scale | Scales a color value.
static (Shared in Visual Basic .NET) Subtract | Subtracts two color values to create a new color value.

Inheritance Hierarchy

Object Leave Site
ColorOperator

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorOperator.Add

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two color values together to create a new color value.

Overload List

public static Color Add(Color, Color);
public static ColorValue Add(ColorValue, ColorValue);
public static int Add(int, int);

See Also

  • ColorOperator.Subtract


ColorOperator.Add(ColorValue,ColorValue)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two color values together to create a new color value.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue _
) As ColorValue
C# public static ColorValue Add(
ColorValue c1,
ColorValue c2
);
Managed C++ public: static ColorValue Add(
ColorValue c1,
ColorValue c2
);
JScript .NET public static function Add(
c1 : ColorValue,
c2 : ColorValue
) : ColorValue;

Parameters

c1 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the color to add.
c2 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the color to add.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . Returns a ColorValue object that represents the sum of the two colors added together.

See Also

  • ColorOperator.Subtract


ColorOperator.Add(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two color values together to create a new color value.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal c1 As Integer, _
ByVal c2 As Integer _
) As Integer
C# public static int Add(
int c1,
int c2
);
Managed C++ public: static int Add(
int c1,
int c2
);
JScript .NET public static function Add(
c1 : int,
c2 : int
) : int;

Parameters

c1 | System.Int32.
c2 | System.Int32.

Return Value

System.Int32 .

See Also

  • ColorOperator.Subtract


ColorOperator.Add(Color,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two color values together to create a new color value.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal c1 As Color, _
ByVal c2 As Color _
) As Color
C# public static Color Add(
Color c1,
Color c2
);
Managed C++ public: static Color Add(
Color c1,
Color c2
);
JScript .NET public static function Add(
c1 : Color,
c2 : Color
) : Color;

Parameters

c1 | System.Drawing.Color. A Color Leave Site object that specifies the color to add.
c2 | System.Drawing.Color. A Color Leave Site object that specifies the color to add.

Return Value

System.Drawing.Color . Returns a Color Leave Site object that represents the sum of the two colors added together.

See Also

  • ColorOperator.Subtract


ColorOperator.AdjustContrast

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustContrast Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the contrast value of a color.

Overload List

public static Color AdjustContrast(Color, float);
public static ColorValue AdjustContrast(ColorValue, float);
public static int AdjustContrast(int, float);

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustContrast(ColorValue,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustContrast Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the contrast value of a color.

Definition

Visual Basic .NET Public Shared Function AdjustContrast( _
ByVal c As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue AdjustContrast(
ColorValue c,
float s
);
Managed C++ public: static ColorValue AdjustContrast(
ColorValue c,
float s
);
JScript .NET public static function AdjustContrast(
c : ColorValue,
s : float
) : ColorValue;

Parameters

c | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the color to adjust.
s | System.Single. Floating-point value that represents the contrast value to apply to the given color. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the result of the contrast adjustment.

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustContrast(Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustContrast Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the contrast value of a color.

Definition

Visual Basic .NET Public Shared Function AdjustContrast( _
ByVal c As Integer, _
ByVal s As Single _
) As Integer
C# public static int AdjustContrast(
int c,
float s
);
Managed C++ public: static int AdjustContrast(
int c,
float s
);
JScript .NET public static function AdjustContrast(
c : int,
s : float
) : int;

Parameters

c | System.Int32.
s | System.Single. Floating-point value that represents the contrast value to apply to the given color. See Remarks.

Return Value

System.Int32 .

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustContrast(Color,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustContrast Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the contrast value of a color.

Definition

Visual Basic .NET Public Shared Function AdjustContrast( _
ByVal c As Color, _
ByVal s As Single _
) As Color
C# public static Color AdjustContrast(
Color c,
float s
);
Managed C++ public: static Color AdjustContrast(
Color c,
float s
);
JScript .NET public static function AdjustContrast(
c : Color,
s : float
) : Color;

Parameters

c | System.Drawing.Color. A Color Leave Site object that specifies the color to adjust.
s | System.Single. Floating-point value that represents the contrast value to apply to the given color. See Remarks.

Return Value

System.Drawing.Color . Returns a Color Leave Site object that represents the result of the contrast adjustment.

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustSaturation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the saturation value of a color.

Overload List

public static Color AdjustSaturation(Color, float);
public static ColorValue AdjustSaturation(ColorValue, float);
public static int AdjustSaturation(int, float);

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation(ColorValue,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustSaturation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the saturation value of a color.

Definition

Visual Basic .NET Public Shared Function AdjustSaturation( _
ByVal c As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue AdjustSaturation(
ColorValue c,
float s
);
Managed C++ public: static ColorValue AdjustSaturation(
ColorValue c,
float s
);
JScript .NET public static function AdjustSaturation(
c : ColorValue,
s : float
) : ColorValue;

Parameters

c | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the color to adjust.
s | System.Single. Floating-point value that represents the saturation value to apply to the given color. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the result of the saturation adjustment.

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation(Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustSaturation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the saturation value of a color.

Definition

Visual Basic .NET Public Shared Function AdjustSaturation( _
ByVal c As Integer, _
ByVal s As Single _
) As Integer
C# public static int AdjustSaturation(
int c,
float s
);
Managed C++ public: static int AdjustSaturation(
int c,
float s
);
JScript .NET public static function AdjustSaturation(
c : int,
s : float
) : int;

Parameters

c | System.Int32.
s | System.Single. Floating-point value that represents the saturation value to apply to the given color. See Remarks.

Return Value

System.Int32 .

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation(Color,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.AdjustSaturation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adjusts the saturation value of a color.

Definition

Visual Basic .NET Public Shared Function AdjustSaturation( _
ByVal c As Color, _
ByVal s As Single _
) As Color
C# public static Color AdjustSaturation(
Color c,
float s
);
Managed C++ public: static Color AdjustSaturation(
Color c,
float s
);
JScript .NET public static function AdjustSaturation(
c : Color,
s : float
) : Color;

Parameters

c | System.Drawing.Color. A Color Leave Site object that specifies the color to adjust.
s | System.Single. Floating-point value that represents the saturation value to apply to the given color. See Remarks.

Return Value

System.Drawing.Color . Returns a Color Leave Site object that represents the result of the saturation adjustment.

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Lerp

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a color value using linear interpolation.

Overload List

public static Color Lerp(Color, Color, float);
public static ColorValue Lerp(ColorValue, ColorValue, float);
public static int Lerp(int, int, float);

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Lerp(ColorValue,ColorValue,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a color value using linear interpolation.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue Lerp(
ColorValue c1,
ColorValue c2,
float s
);
Managed C++ public: static ColorValue Lerp(
ColorValue c1,
ColorValue c2,
float s
);
JScript .NET public static function Lerp(
c1 : ColorValue,
c2 : ColorValue,
s : float
) : ColorValue;

Parameters

c1 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the first source color.
c2 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the second source color.
s | System.Single. Floating-point value that linearly interpolates between the colors c1 and c2, treating them both as 4-D vectors. There are no limits on this parameter's value.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the result of the linear interpolation.

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Lerp(Int32,Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a color value using linear interpolation.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal c1 As Integer, _
ByVal c2 As Integer, _
ByVal s As Single _
) As Integer
C# public static int Lerp(
int c1,
int c2,
float s
);
Managed C++ public: static int Lerp(
int c1,
int c2,
float s
);
JScript .NET public static function Lerp(
c1 : int,
c2 : int,
s : float
) : int;

Parameters

c1 | System.Int32.
c2 | System.Int32.
s | System.Single. Floating-point value that linearly interpolates between the colors c1 and c2, treating them both as 4-D vectors. There are no limits on this parameter's value.

Return Value

System.Int32 .

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Lerp(Color,Color,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a color value using linear interpolation.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal c1 As Color, _
ByVal c2 As Color, _
ByVal s As Single _
) As Color
C# public static Color Lerp(
Color c1,
Color c2,
float s
);
Managed C++ public: static Color Lerp(
Color c1,
Color c2,
float s
);
JScript .NET public static function Lerp(
c1 : Color,
c2 : Color,
s : float
) : Color;

Parameters

c1 | System.Drawing.Color. A Color Leave Site object that specifies the first source color.
c2 | System.Drawing.Color. A Color Leave Site object that specifies the second source color.
s | System.Single. Floating-point value that linearly interpolates between the colors c1 and c2, treating them both as 4-D vectors. There are no limits on this parameter's value.

Return Value

System.Drawing.Color . A Color Leave Site object that represents the result of the linear interpolation.

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Modulate

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Modulate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Blends two colors.

Overload List

public static Color Modulate(Color, Color);
public static ColorValue Modulate(ColorValue, ColorValue);
public static int Modulate(int, int);

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Modulate(ColorValue,ColorValue)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Modulate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Blends two colors.

Definition

Visual Basic .NET Public Shared Function Modulate( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue _
) As ColorValue
C# public static ColorValue Modulate(
ColorValue c1,
ColorValue c2
);
Managed C++ public: static ColorValue Modulate(
ColorValue c1,
ColorValue c2
);
JScript .NET public static function Modulate(
c1 : ColorValue,
c2 : ColorValue
) : ColorValue;

Parameters

c1 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the first source color to modulate.
c2 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the second source color to modulate.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the result of the blending operation.

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Modulate(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Modulate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Blends two colors.

Definition

Visual Basic .NET Public Shared Function Modulate( _
ByVal c1 As Integer, _
ByVal c2 As Integer _
) As Integer
C# public static int Modulate(
int c1,
int c2
);
Managed C++ public: static int Modulate(
int c1,
int c2
);
JScript .NET public static function Modulate(
c1 : int,
c2 : int
) : int;

Parameters

c1 | System.Int32.
c2 | System.Int32.

Return Value

System.Int32 .

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Modulate(Color,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Modulate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Blends two colors.

Definition

Visual Basic .NET Public Shared Function Modulate( _
ByVal c1 As Color, _
ByVal c2 As Color _
) As Color
C# public static Color Modulate(
Color c1,
Color c2
);
Managed C++ public: static Color Modulate(
Color c1,
Color c2
);
JScript .NET public static function Modulate(
c1 : Color,
c2 : Color
) : Color;

Parameters

c1 | System.Drawing.Color. A Color Leave Site object that specifies the first source color to modulate.
c2 | System.Drawing.Color. A Color Leave Site object that specifies the second source color to modulate.

Return Value

System.Drawing.Color . A Color Leave Site object that represents the result of the blending operation.

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Negative

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Negative Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a negative color value from a given color value.

Overload List

public static Color Negative(Color);
public static ColorValue Negative(ColorValue);
public static int Negative(int);

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Negative(ColorValue)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Negative Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a negative color value from a given color value.

Definition

Visual Basic .NET Public Shared Function Negative( _
ByVal c As ColorValue _
) As ColorValue
C# public static ColorValue Negative(
ColorValue c
);
Managed C++ public: static ColorValue Negative(
ColorValue c
);
JScript .NET public static function Negative(
c : ColorValue
) : ColorValue;

Parameters

c Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the source color.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the negative color value of the source color.

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Negative(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Negative Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a negative color value from a given color value.

Definition

Visual Basic .NET Public Shared Function Negative( _
ByVal c As Integer _
) As Integer
C# public static int Negative(
int c
);
Managed C++ public: static int Negative(
int c
);
JScript .NET public static function Negative(
c : int
) : int;

Parameters

c System.Int32.

Return Value

System.Int32 .

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Negative(Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Negative Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a negative color value from a given color value.

Definition

Visual Basic .NET Public Shared Function Negative( _
ByVal c As Color _
) As Color
C# public static Color Negative(
Color c
);
Managed C++ public: static Color Negative(
Color c
);
JScript .NET public static function Negative(
c : Color
) : Color;

Parameters

c System.Drawing.Color. A Color Leave Site object that specifies the source color.

Return Value

System.Drawing.Color . A Color Leave Site object that represents the negative color value of the source color.

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a color value.

Overload List

public static Color Scale(Color, float);
public static ColorValue Scale(ColorValue, float);
public static int Scale(int, float);


ColorOperator.Scale(ColorValue,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a color value.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal c As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue Scale(
ColorValue c,
float s
);
Managed C++ public: static ColorValue Scale(
ColorValue c,
float s
);
JScript .NET public static function Scale(
c : ColorValue,
s : float
) : ColorValue;

Parameters

c | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the source color to scale.
s | System.Single. Floating-point value that represents the scaling factor to apply. The scaling factor scales the color, treating it like a 4-D vector. There are no limits on this parameter's value. If s is 1, the resulting color is the original color.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that is the scaled color value.


ColorOperator.Scale(Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a color value.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal c As Integer, _
ByVal s As Single _
) As Integer
C# public static int Scale(
int c,
float s
);
Managed C++ public: static int Scale(
int c,
float s
);
JScript .NET public static function Scale(
c : int,
s : float
) : int;

Parameters

c | System.Int32.
s | System.Single. Floating-point value that represents the scaling factor to apply. The scaling factor scales the color, treating it like a 4-D vector. There are no limits on this parameter's value. If s is 1, the resulting color is the original color.

Return Value

System.Int32 .


ColorOperator.Scale(Color,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a color value.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal c As Color, _
ByVal s As Single _
) As Color
C# public static Color Scale(
Color c,
float s
);
Managed C++ public: static Color Scale(
Color c,
float s
);
JScript .NET public static function Scale(
c : Color,
s : float
) : Color;

Parameters

c | System.Drawing.Color. A Color Leave Site object that specifies the source color to scale.
s | System.Single. Floating-point value that represents the scaling factor to apply. The scaling factor scales the color, treating it like a 4-D vector. There are no limits on this parameter's value. If s is 1, the resulting color is the original color.

Return Value

System.Drawing.Color . A Color Leave Site object that is the scaled color value.


ColorOperator.Subtract

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two color values to create a new color value.

Overload List

public static Color Subtract(Color, Color);
public static ColorValue Subtract(ColorValue, ColorValue);
public static int Subtract(int, int);

See Also

  • ColorOperator.Add


ColorOperator.Subtract(ColorValue,ColorValue)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two color values to create a new color value.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue _
) As ColorValue
C# public static ColorValue Subtract(
ColorValue c1,
ColorValue c2
);
Managed C++ public: static ColorValue Subtract(
ColorValue c1,
ColorValue c2
);
JScript .NET public static function Subtract(
c1 : ColorValue,
c2 : ColorValue
) : ColorValue;

Parameters

c1 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the color to subtract.
c2 | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object that specifies the color to subtract.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the difference between the two colors.

See Also

  • ColorOperator.Add


ColorOperator.Subtract(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two color values to create a new color value.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal c1 As Integer, _
ByVal c2 As Integer _
) As Integer
C# public static int Subtract(
int c1,
int c2
);
Managed C++ public: static int Subtract(
int c1,
int c2
);
JScript .NET public static function Subtract(
c1 : int,
c2 : int
) : int;

Parameters

c1 | System.Int32.
c2 | System.Int32.

Return Value

System.Int32 .

See Also

  • ColorOperator.Add


ColorOperator.Subtract(Color,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorOperator.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two color values to create a new color value.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal c1 As Color, _
ByVal c2 As Color _
) As Color
C# public static Color Subtract(
Color c1,
Color c2
);
Managed C++ public: static Color Subtract(
Color c1,
Color c2
);
JScript .NET public static function Subtract(
c1 : Color,
c2 : Color
) : Color;

Parameters

c1 | System.Drawing.Color. A Color Leave Site object that specifies the color to subtract.
c2 | System.Drawing.Color. A Color Leave Site object that specifies the color to subtract.

Return Value

System.Drawing.Color . A Color Leave Site object that represents the difference between the two colors.

See Also

  • ColorOperator.Add


Microsoft.DirectX.Direct3D.CompressedAnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet Class

Language:
Note: This documentation is preliminary and is subject to change.

Implements a keyframe animation set that is stored in a compressed data format.

Definition

Visual Basic .NET NotInheritable Public Class CompressedAnimationSet
Inherits AnimationSet
C# | public sealed class CompressedAnimationSet : AnimationSet
Managed C++ | public __gc __sealed class CompressedAnimationSet : public AnimationSet
JScript .NET | public class CompressedAnimationSet extends AnimationSet

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CompressedAnimationSet object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
CompressedAnimationSet | Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.
Dispose | Immediately releases the unmanaged resources used by the CompressedAnimationSet object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CompressedAnimationSet object to free resources before it is destroyed by the garbage collector.
GetAnimationIndex | Retrieves the index of an animation, given its name. Inherited from AnimationSet.
GetAnimationName | Retrieves the name of an animation, given its index. Inherited from AnimationSet.
GetCallback | Retrieves information about a specific callback in an animation set. Inherited from AnimationSet.
GetCallbackKeys | Fills an array with callback key data that is used for keyframe animation.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPeriodicPosition | Returns the time position in the local timeframe of an animation set. Inherited from AnimationSet.
GetScaleRotateTranslate | Retrieves the scale, rotate, and translate (SRT) values of an animation set. Inherited from AnimationSet.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from AnimationSet.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from AnimationSet.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this CompressedAnimationSet object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code. Inherited from AnimationSet.

Properties

Property | Description
CompressedData | Retrieves the data buffer that stores compressed keyframe animation data.
Disposed | Gets a value that indicates whether the object is disposed.
Name | Retrieves the name of an animation set. Inherited from AnimationSet.
NumberAnimations | Retrieves a value that indicates the number of animations in the animation set. Inherited from AnimationSet.
NumberCallbackKeys | Retrieves the number of callback keys in the animation set.
Period | Retrieves the period of an animation set. Inherited from AnimationSet.
PlaybackType | Retrieves the type of the animation set playback loop.
SourceTicksPerSecond | Retrieves the number of animation keyframe ticks that occur per second.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer. Inherited from AnimationSet.
UnmanagedComPointer | Returns the unmanaged COM ID3DXCompressedAnimationSet interface pointer.

Inheritance Hierarchy

Object Leave Site
AnimationSet
CompressedAnimationSet

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CompressedAnimationSet.CompressedAnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.CompressedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Overload List

public CompressedAnimationSet(ID3DXCompressedAnimationSet);
public CompressedAnimationSet(IntPtr);
public CompressedAnimationSet(string, double, PlaybackType, GraphicsStream, KeyCallback[]);


CompressedAnimationSet.CompressedAnimationSet(ID3DXCompressedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.CompressedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As ID3DXCompressedAnimationSet _
)
C# public CompressedAnimationSet(
ID3DXCompressedAnimationSet pInterop
);
Managed C++ public: CompressedAnimationSet(
ID3DXCompressedAnimationSet pInterop
);
JScript .NET public function CompressedAnimationSet(
pInterop : ID3DXCompressedAnimationSet
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXCompressedAnimationSet. Unmanaged Component Object Model (COM) ID3DXCompressedAnimationSet interface pointer.


CompressedAnimationSet.CompressedAnimationSet(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.CompressedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public CompressedAnimationSet(
IntPtr unmanagedObject
);
Managed C++ public: CompressedAnimationSet(
IntPtr unmanagedObject
);
JScript .NET public function CompressedAnimationSet(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXCompressedAnimationSet interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


CompressedAnimationSet.CompressedAnimationSet(String,Double,PlaybackType,GraphicsStream,KeyCallback[])

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.CompressedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Definition

Visual Basic .NET Public Sub New( _
ByVal name As String, _
ByVal ticksPerSecond As Double, _
ByVal playback As PlaybackType, _
ByVal compressedData As GraphicsStream, _
ByVal callbackKeys() As KeyCallback _
)
C# public CompressedAnimationSet(
string name,
double ticksPerSecond,
PlaybackType playback,
GraphicsStream compressedData,
KeyCallback[] callbackKeys
);
Managed C++ public: CompressedAnimationSet(
String *name,
double ticksPerSecond,
PlaybackType playback,
GraphicsStream *compressedData,
KeyCallback callbackKeys __gc[]
);
JScript .NET public function CompressedAnimationSet(
name : String,
ticksPerSecond : double,
playback : PlaybackType,
compressedData : GraphicsStream,
callbackKeys : KeyCallback[]
);

Parameters

name | System.String. Animation set name.
ticksPerSecond | System.Double. Number of key-frame ticks that elapse per second.
playback | Microsoft.DirectX.Direct3D.PlaybackType. Type of the animation set playback loop. See PlaybackType.
compressedData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the animation set graphics data.
callbackKeys | Microsoft.DirectX.Direct3D.KeyCallback[]. Array of KeyCallback objects that store user callback data.


CompressedAnimationSet.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the CompressedAnimationSet object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposed
  • Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing


CompressedAnimationSet.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CompressedAnimationSet.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the CompressedAnimationSet object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~CompressedAnimationSet();
Managed C++ | ~CompressedAnimationSet();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


CompressedAnimationSet.GetCallbackKeys()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.GetCallbackKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Fills an array with callback key data that is used for keyframe animation.

Definition

Visual Basic .NET | Public Function GetCallbackKeys() As KeyCallback()
C# | public KeyCallback[] GetCallbackKeys();
Managed C++ | public: KeyCallback GetCallbackKeys() __gc[];
JScript .NET | public function GetCallbackKeys() : KeyCallback[];

Return Value

Microsoft.DirectX.Direct3D.KeyCallback[]. Returns an array of KeyCallback objects filled with callback data.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


CompressedAnimationSet.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


CompressedAnimationSet.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXCompressedAnimationSet, which allows unmanaged COM clients to create an instance of the managed CompressedAnimationSet class. Not supported.


CompressedAnimationSet.op_Equality(CompressedAnimationSet,CompressedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As CompressedAnimationSet, _
ByVal right As CompressedAnimationSet _
) As Boolean
C# public static bool op_Equality(
CompressedAnimationSet left,
CompressedAnimationSet right
);
Managed C++ public: static bool op_Equality(
CompressedAnimationSet *left,
CompressedAnimationSet *right
);
JScript .NET public static function op_Equality(
left : CompressedAnimationSet,
right : CompressedAnimationSet
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.CompressedAnimationSet. The CompressedAnimationSet object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.CompressedAnimationSet. The CompressedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CompressedAnimationSet.op_Inequality(CompressedAnimationSet,CompressedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As CompressedAnimationSet, _
ByVal right As CompressedAnimationSet _
) As Boolean
C# public static bool op_Inequality(
CompressedAnimationSet left,
CompressedAnimationSet right
);
Managed C++ public: static bool op_Inequality(
CompressedAnimationSet *left,
CompressedAnimationSet *right
);
JScript .NET public static function op_Inequality(
left : CompressedAnimationSet,
right : CompressedAnimationSet
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.CompressedAnimationSet. The CompressedAnimationSet object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.CompressedAnimationSet. The CompressedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


CompressedAnimationSet.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


CompressedAnimationSet.UpdateUnmanagedPointer(ID3DXCompressedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this CompressedAnimationSet object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXCompressedAnimationSet _
)
C# public void UpdateUnmanagedPointer(
ID3DXCompressedAnimationSet pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXCompressedAnimationSet pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXCompressedAnimationSet
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXCompressedAnimationSet. Pointer to the ID3DXCompressedAnimationSet structure used to update the unmanaged pointer for this CompressedAnimationSet object.


CompressedAnimationSet.CompressedData

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.CompressedData Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the data buffer that stores compressed keyframe animation data.

Definition

Visual Basic .NET | Public ReadOnly Property CompressedData As GraphicsStream
C# | public GraphicsStream CompressedData { get; }
Managed C++ | public: __property GraphicsStream* get_CompressedData();
JScript .NET | public function get CompressedData() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains compressed keyframe animation data.

This property is read-only.


CompressedAnimationSet.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


CompressedAnimationSet.NumberCallbackKeys

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.NumberCallbackKeys Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of callback keys in the animation set.

Definition

Visual Basic .NET | Public ReadOnly Property NumberCallbackKeys As Integer
C# | public int NumberCallbackKeys { get; }
Managed C++ | public: __property int get_NumberCallbackKeys();
JScript .NET | public function get NumberCallbackKeys() : int

Property Value

System.Int32 . Number of callback keys in the animation set.

This property is read-only.


CompressedAnimationSet.PlaybackType

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.PlaybackType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the type of the animation set playback loop.

Definition

Visual Basic .NET | Public ReadOnly Property PlaybackType As PlaybackType
C# | public PlaybackType PlaybackType { get; }
Managed C++ | public: __property PlaybackType get_PlaybackType();
JScript .NET | public function get PlaybackType() : PlaybackType

Property Value

Microsoft.DirectX.Direct3D.PlaybackType . Type of the animation set playback loop.

This property is read-only.


CompressedAnimationSet.SourceTicksPerSecond

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.SourceTicksPerSecond Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of animation keyframe ticks that occur per second.

Definition

Visual Basic .NET | Public ReadOnly Property SourceTicksPerSecond As Double
C# | public double SourceTicksPerSecond { get; }
Managed C++ | public: __property double get_SourceTicksPerSecond();
JScript .NET | public function get SourceTicksPerSecond() : double

Property Value

System.Double . Number of animation keyframe ticks per second.

This property is read-only.


CompressedAnimationSet.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXCompressedAnimationSet interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXCompressedAnimationSet
C# | public ID3DXCompressedAnimationSet UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXCompressedAnimationSet get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXCompressedAnimationSet

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXCompressedAnimationSet . Unmanaged ID3DXCompressedAnimationSet interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


CompressedAnimationSet.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressedAnimationSet.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the CompressedAnimationSet object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CompressedAnimationSet object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.ConflictingRenderStateException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingRenderStateException Class

Language:
Note: This documentation is preliminary and is subject to change.

The currently set render states cannot be used together.

Definition

Visual Basic .NET Public Class ConflictingRenderStateException
Inherits GraphicsException
C# | public class ConflictingRenderStateException : GraphicsException
Managed C++ | public __gc class ConflictingRenderStateException : public GraphicsException
JScript .NET | public class ConflictingRenderStateException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConflictingRenderStateException | Initializes a new instance of the ConflictingRenderStateException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingRenderStateException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConflictingRenderStateException.ConflictingRenderStateException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingRenderStateException class.

Overload List

public ConflictingRenderStateException();
protected ConflictingRenderStateException(SerializationInfo, StreamingContext);
public ConflictingRenderStateException(string);
public ConflictingRenderStateException(string, Exception);


ConflictingRenderStateException.ConflictingRenderStateException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConflictingRenderStateException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConflictingRenderStateException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConflictingRenderStateException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


ConflictingRenderStateException.ConflictingRenderStateException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConflictingRenderStateException(
string message,
Exception inner
);
Managed C++ public: ConflictingRenderStateException(
String *message,
Exception *inner
);
JScript .NET public function ConflictingRenderStateException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


ConflictingRenderStateException.ConflictingRenderStateException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConflictingRenderStateException(
string message
);
Managed C++ public: ConflictingRenderStateException(
String *message
);
JScript .NET public function ConflictingRenderStateException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


ConflictingRenderStateException.ConflictingRenderStateException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConflictingRenderStateException();
Managed C++ | public: ConflictingRenderStateException();
JScript .NET | public function ConflictingRenderStateException();


Microsoft.DirectX.Direct3D.ConflictingTextureFilterException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTextureFilterException Class

Language:
Note: This documentation is preliminary and is subject to change.

The current texture filters cannot be used together.

Definition

Visual Basic .NET Public Class ConflictingTextureFilterException
Inherits GraphicsException
C# | public class ConflictingTextureFilterException : GraphicsException
Managed C++ | public __gc class ConflictingTextureFilterException : public GraphicsException
JScript .NET | public class ConflictingTextureFilterException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConflictingTextureFilterException | Initializes a new instance of the ConflictingTextureFilterException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingTextureFilterException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConflictingTextureFilterException.ConflictingTextureFilterException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTextureFilterException class.

Overload List

public ConflictingTextureFilterException();
protected ConflictingTextureFilterException(SerializationInfo, StreamingContext);
public ConflictingTextureFilterException(string);
public ConflictingTextureFilterException(string, Exception);


ConflictingTextureFilterException.ConflictingTextureFilterException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConflictingTextureFilterException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConflictingTextureFilterException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConflictingTextureFilterException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


ConflictingTextureFilterException.ConflictingTextureFilterException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConflictingTextureFilterException(
string message,
Exception inner
);
Managed C++ public: ConflictingTextureFilterException(
String *message,
Exception *inner
);
JScript .NET public function ConflictingTextureFilterException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


ConflictingTextureFilterException.ConflictingTextureFilterException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConflictingTextureFilterException(
string message
);
Managed C++ public: ConflictingTextureFilterException(
String *message
);
JScript .NET public function ConflictingTextureFilterException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


ConflictingTextureFilterException.ConflictingTextureFilterException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConflictingTextureFilterException();
Managed C++ | public: ConflictingTextureFilterException();
JScript .NET | public function ConflictingTextureFilterException();


Microsoft.DirectX.Direct3D.ConflictingTexturePaletteException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTexturePaletteException Class

Language:
Note: This documentation is preliminary and is subject to change.

The current textures cannot be used simultaneously.

Definition

Visual Basic .NET Public Class ConflictingTexturePaletteException
Inherits GraphicsException
C# | public class ConflictingTexturePaletteException : GraphicsException
Managed C++ | public __gc class ConflictingTexturePaletteException : public GraphicsException
JScript .NET | public class ConflictingTexturePaletteException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConflictingTexturePaletteException | Initializes a new instance of the ConflictingTexturePaletteException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingTexturePaletteException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConflictingTexturePaletteException.ConflictingTexturePaletteException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTexturePaletteException class.

Overload List

public ConflictingTexturePaletteException();
protected ConflictingTexturePaletteException(SerializationInfo, StreamingContext);
public ConflictingTexturePaletteException(string);
public ConflictingTexturePaletteException(string, Exception);


ConflictingTexturePaletteException.ConflictingTexturePaletteException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConflictingTexturePaletteException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConflictingTexturePaletteException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConflictingTexturePaletteException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


ConflictingTexturePaletteException.ConflictingTexturePaletteException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConflictingTexturePaletteException(
string message,
Exception inner
);
Managed C++ public: ConflictingTexturePaletteException(
String *message,
Exception *inner
);
JScript .NET public function ConflictingTexturePaletteException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


ConflictingTexturePaletteException.ConflictingTexturePaletteException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConflictingTexturePaletteException(
string message
);
Managed C++ public: ConflictingTexturePaletteException(
String *message
);
JScript .NET public function ConflictingTexturePaletteException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


ConflictingTexturePaletteException.ConflictingTexturePaletteException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConflictingTexturePaletteException();
Managed C++ | public: ConflictingTexturePaletteException();
JScript .NET | public function ConflictingTexturePaletteException();


Microsoft.DirectX.Direct3D.ConstantTable

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable Class

Language:
Note: This documentation is preliminary and is subject to change.

Provides access to the constant table, which contains the variables that are used by high-level language shaders and effects.

Definition

Visual Basic .NET NotInheritable Public Class ConstantTable
Inherits Object
Implements IDisposable
C# public sealed class ConstantTable : Object,
IDisposable
Managed C++ public __gc __sealed class ConstantTable : public Object,
IDisposable
JScript .NET public class ConstantTable extends Object
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ConstantTable object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
ConstantTable | Initializes a new instance of the ConstantTable class.
Dispose | Immediately releases the unmanaged resources used by the ConstantTable object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ConstantTable object to free resources before it is destroyed by the garbage collector.
GetConstant | Retrieves a constant by looking up its index or by name.
GetConstantDescription | Retrieves an array of constant descriptions in the constant table.
GetConstantElement | Retrieves a constant from an array of constants.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetSamplerIndex | Retrieves the sampler index.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.ConstantTable.Disposing event when called from within a derived class.
SetDefaults | Sets constants to their default values, which are declared in the variable declarations in the shader.
SetValue | Sets the value to the constant table.
SetValueTranspose | Sets a Matrix or an array of matrices to the constant table.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this ConstantTable object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves a description of the constant table.
Disposed | Gets a value that indicates whether the object is disposed.
StreamData | Retrieves a GraphicsStream object that contains the constant table.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXConstantTable interface pointer.

Inheritance Hierarchy

Object Leave Site
ConstantTable

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConstantTable.ConstantTable

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.ConstantTable Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConstantTable class.

Overload List

public ConstantTable(ID3DXConstantTable);
public ConstantTable(IntPtr);


ConstantTable.ConstantTable(ID3DXConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.ConstantTable Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConstantTable class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXConstantTable _
)
C# public ConstantTable(
ID3DXConstantTable pUnk
);
Managed C++ public: ConstantTable(
ID3DXConstantTable pUnk
);
JScript .NET public function ConstantTable(
pUnk : ID3DXConstantTable
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXConstantTable. Unmanaged Component Object Model (COM) ID3DXConstantTable interface pointer.


ConstantTable.ConstantTable(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.ConstantTable Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConstantTable class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public ConstantTable(
IntPtr unmanagedObject
);
Managed C++ public: ConstantTable(
IntPtr unmanagedObject
);
JScript .NET public function ConstantTable(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXConstantTable interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


ConstantTable.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the ConstantTable object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.ConstantTable.Disposed
  • Microsoft.DirectX.Direct3D.ConstantTable.Disposing


ConstantTable.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ConstantTable.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the ConstantTable object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ConstantTable();
Managed C++ | ~ConstantTable();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


ConstantTable.GetConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.GetConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a constant by looking up its index or by name.

Overload List

public EffectHandle GetConstant(EffectHandle, int);
public EffectHandle GetConstant(EffectHandle, string);


ConstantTable.GetConstant(EffectHandle,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.GetConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a constant by looking up its index or by name.

Definition

Visual Basic .NET Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
string name
);
Managed C++ public: EffectHandle* GetConstant(
EffectHandle *constant,
String *name
);
JScript .NET public function GetConstant(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that serves as a unique identifier to the parent data structure. If the constant is a top-level parameter (that is, if there is no parent data structure), use 0.
name | System.String. Name of the constant.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle class that represents the constant.


ConstantTable.GetConstant(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.GetConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a constant by looking up its index or by name.

Definition

Visual Basic .NET Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
int index
);
Managed C++ public: EffectHandle* GetConstant(
EffectHandle *constant,
int index
);
JScript .NET public function GetConstant(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that serves as a unique identifier to the parent data structure. If the constant is a top-level parameter (that is, if there is no parent data structure), use 0.
index | System.Int32. Zero-based index of the constant.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle class that represents the constant.


ConstantTable.GetConstantDescription(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.GetConstantDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of constant descriptions in the constant table.

Definition

Visual Basic .NET Public Function GetConstantDescription( _
ByVal constant As EffectHandle, _
ByVal numberConstants As Integer _
) As ConstantDescription()
C# public ConstantDescription[] GetConstantDescription(
EffectHandle constant,
int numberConstants
);
Managed C++ public: ConstantDescription GetConstantDescription(
EffectHandle *constant,
int numberConstants
) __gc[];
JScript .NET public function GetConstantDescription(
constant : EffectHandle,
numberConstants : int
) : ConstantDescription[];

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle class that uniquely identifies a constant.
numberConstants | System.Int32. [in, out] Input supplied must be the maximum size of the array. Output is the number of elements that are filled in the array when the function returns.

Return Value

Microsoft.DirectX.Direct3D.ConstantDescription[]. Array of descriptions. For more information, see ConstantDescription.

Remarks

Because samplers can appear more than once in a constant table, this method can return an array of descriptions, each with a different register index.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • ConstantTable.Description


ConstantTable.GetConstantElement(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.GetConstantElement Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a constant from an array of constants.

Definition

Visual Basic .NET Public Function GetConstantElement( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstantElement(
EffectHandle constant,
int index
);
Managed C++ public: EffectHandle* GetConstantElement(
EffectHandle *constant,
int index
);
JScript .NET public function GetConstantElement(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle class that uniquely identifies the array of constants. This value cannot be 0.
index | System.Int32. Zero-based index of the element in the array.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle that uniquely identifies the constant.

Remarks

To get a constant that is not part of an array, use ConstantTable.GetConstant.


ConstantTable.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


ConstantTable.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXConstantTable, which allows unmanaged COM clients to create an instance of the managed ConstantTable class. Not supported.


ConstantTable.GetSamplerIndex(EffectHandle)

ConstantTable.GetSamplerIndex Method

Note: This documentation is preliminary and is subject to change.

Retrieves the sampler index.

Definition

Visual Basic .NET Public Function GetSamplerIndex( _
ByVal constant As EffectHandle _
) As Integer
C# public int GetSamplerIndex(
EffectHandle constant
);
Managed C++ public: int GetSamplerIndex(
EffectHandle *constant
);
JScript .NET public function GetSamplerIndex(
constant : EffectHandle
) : int;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier for the sampler whose index is to be retrieved.

Return Value

System.Int32 . The sampler index number from the constant table.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.op_Equality(ConstantTable,ConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As ConstantTable, _
ByVal right As ConstantTable _
) As Boolean
C# public static bool op_Equality(
ConstantTable left,
ConstantTable right
);
Managed C++ public: static bool op_Equality(
ConstantTable *left,
ConstantTable *right
);
JScript .NET public static function op_Equality(
left : ConstantTable,
right : ConstantTable
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.ConstantTable. The ConstantTable object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.ConstantTable. The ConstantTable object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ConstantTable.op_Inequality(ConstantTable,ConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As ConstantTable, _
ByVal right As ConstantTable _
) As Boolean
C# public static bool op_Inequality(
ConstantTable left,
ConstantTable right
);
Managed C++ public: static bool op_Inequality(
ConstantTable *left,
ConstantTable *right
);
JScript .NET public static function op_Inequality(
left : ConstantTable,
right : ConstantTable
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.ConstantTable. The ConstantTable object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.ConstantTable. The ConstantTable object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


ConstantTable.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.ConstantTable.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


ConstantTable.SetDefaults(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.SetDefaults Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets constants to their default values, which are declared in the variable declarations in the shader.

Definition

Visual Basic .NET Public Sub SetDefaults( _
ByVal device As Device _
)
C# public void SetDefaults(
Device device
);
Managed C++ public: void SetDefaults(
Device *device
);
JScript .NET public function SetDefaults(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.SetValue

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Overload List

public void SetValue(Device, EffectHandle, bool);
public void SetValue(Device, EffectHandle, bool[]);
public void SetValue(Device, EffectHandle, ColorValue);
public void SetValue(Device, EffectHandle, ColorValue[]);
public void SetValue(Device, EffectHandle, GraphicsStream);
public void SetValue(Device, EffectHandle, int);
public void SetValue(Device, EffectHandle, int[]);
public void SetValue(Device, EffectHandle, Matrix);
public void SetValue(Device, EffectHandle, Matrix[]);
public void SetValue(Device, EffectHandle, float);
public void SetValue(Device, EffectHandle, float[]);
public void SetValue(Device, EffectHandle, Vector4);
public void SetValue(Device, EffectHandle, Vector4[]);
public void SetValue(Device, EffectHandle, void, int);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Matrix[])

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Matrix[] matrix
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
Matrix matrix __gc[]
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
matrix | Microsoft.DirectX.Matrix[]. Array of nontransposed matrices to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Matrix)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Matrix matrix
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
Matrix matrix
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
matrix : Matrix
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
matrix | Microsoft.DirectX.Matrix. Nontransposed Matrix to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,ColorValue[])

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal color() As ColorValue _
)
C# public void SetValue(
Device device,
EffectHandle constant,
ColorValue[] color
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
ColorValue color __gc[]
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
color : ColorValue[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
color | Microsoft.DirectX.Direct3D.ColorValue[]. Array of ColorValue structures to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,ColorValue)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal color As ColorValue _
)
C# public void SetValue(
Device device,
EffectHandle constant,
ColorValue color
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
ColorValue color
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
color : ColorValue
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
color | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue structure to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Vector4[])

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal vector() As Vector4 _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Vector4[] vector
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
Vector4 vector __gc[]
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
vector : Vector4[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
vector | Microsoft.DirectX.Vector4[]. Array of Vector4 structures to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Vector4)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal vector As Vector4 _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Vector4 vector
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
Vector4 vector
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
vector : Vector4
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
vector | Microsoft.DirectX.Vector4. A Vector4 structure to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Single[])

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal f() As Single _
)
C# public void SetValue(
Device device,
EffectHandle constant,
float[] f
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
float f __gc[]
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
f : float[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
f | System.Single[]. Array of Single Leave Site values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Single)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal f As Single _
)
C# public void SetValue(
Device device,
EffectHandle constant,
float f
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
float f
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
f : float
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
f | System.Single. A Single Leave Site value to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Int32[])

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal n() As Integer _
)
C# public void SetValue(
Device device,
EffectHandle constant,
int[] n
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
int n __gc[]
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
n : int[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
n | System.Int32[]. Array of Int32 Leave Site values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Int32)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal n As Integer _
)
C# public void SetValue(
Device device,
EffectHandle constant,
int n
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
int n
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
n : int
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
n | System.Int32. An Int32 Leave Site value to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Boolean[])

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal b() As Boolean _
)
C# public void SetValue(
Device device,
EffectHandle constant,
bool[] b
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
bool b __gc[]
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
b : boolean[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
b | System.Boolean[]. Array of Boolean Leave Site values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Boolean)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal b As Boolean _
)
C# public void SetValue(
Device device,
EffectHandle constant,
bool b
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
bool b
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
b : boolean
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
b | System.Boolean. A Boolean Leave Site value to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,GraphicsStream)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal data As GraphicsStream _
)
C# public void SetValue(
Device device,
EffectHandle constant,
GraphicsStream data
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
GraphicsStream *data
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
data : GraphicsStream
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
data | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Void,Int32)

ConstantTable.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the value to the constant table.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal data As Void, _
ByVal dataSize As Integer _
)
C# public void SetValue(
Device device,
EffectHandle constant,
void data,
int dataSize
);
Managed C++ public: void SetValue(
Device *device,
EffectHandle *constant,
void data,
int dataSize
);
JScript .NET public function SetValue(
device : Device,
constant : EffectHandle,
data : void,
dataSize : int
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
data | System.Void. A buffer containing the data to set.
dataSize | System.Int32. Number of bytes in the data buffer.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValueTranspose

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a Matrix or an array of matrices to the constant table.

Overload List

public void SetValueTranspose(Device, EffectHandle, Matrix);
public void SetValueTranspose(Device, EffectHandle, Matrix[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.SetValueTranspose(Device,EffectHandle,Matrix[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a Matrix or an array of matrices to the constant table.

Definition

Visual Basic .NET Public Sub SetValueTranspose( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValueTranspose(
Device device,
EffectHandle constant,
Matrix[] matrix
);
Managed C++ public: void SetValueTranspose(
Device *device,
EffectHandle *constant,
Matrix matrix __gc[]
);
JScript .NET public function SetValueTranspose(
device : Device,
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
matrix | Microsoft.DirectX.Matrix[]. Array of transposed matrices to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.SetValueTranspose(Device,EffectHandle,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a Matrix or an array of matrices to the constant table.

Definition

Visual Basic .NET Public Sub SetValueTranspose( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValueTranspose(
Device device,
EffectHandle constant,
Matrix matrix
);
Managed C++ public: void SetValueTranspose(
Device *device,
EffectHandle *constant,
Matrix matrix
);
JScript .NET public function SetValueTranspose(
device : Device,
constant : EffectHandle,
matrix : Matrix
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the constant table.
constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that represents a unique identifier of a constant.
matrix | Microsoft.DirectX.Matrix. Transposed matrix to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.UpdateUnmanagedPointer(ID3DXConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this ConstantTable object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXConstantTable _
)
C# public void UpdateUnmanagedPointer(
ID3DXConstantTable pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXConstantTable pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXConstantTable
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXConstantTable. Pointer to the ID3DXConstantTable structure used to update the unmanaged pointer for this ConstantTable object.


ConstantTable.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a description of the constant table.

Definition

Visual Basic .NET | Public ReadOnly Property Description As ConstantTableDescription
C# | public ConstantTableDescription Description { get; }
Managed C++ | public: __property ConstantTableDescription get_Description();
JScript .NET | public function get Description() : ConstantTableDescription

Property Value

Microsoft.DirectX.Direct3D.ConstantTableDescription . A ConstantTableDescription structure.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • GetConstantDescription


ConstantTable.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


ConstantTable.StreamData

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.StreamData Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a GraphicsStream object that contains the constant table.

Definition

Visual Basic .NET | Public ReadOnly Property StreamData As GraphicsStream
C# | public GraphicsStream StreamData { get; }
Managed C++ | public: __property GraphicsStream* get_StreamData();
JScript .NET | public function get StreamData() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the constant table.

This property is read-only.


ConstantTable.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXConstantTable interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXConstantTable
C# | public ID3DXConstantTable UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXConstantTable get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXConstantTable

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXConstantTable . Unmanaged ID3DXConstantTable interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


ConstantTable.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTable.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the ConstantTable object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.ConstantTable.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ConstantTable object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.CubeTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates a cube texture resource.

Definition

Visual Basic .NET NotInheritable Public Class CubeTexture
Inherits BaseTexture
Implements IDisposable
C# public sealed class CubeTexture : BaseTexture,
IDisposable
Managed C++ public __gc __sealed class CubeTexture : public BaseTexture,
IDisposable
JScript .NET public class CubeTexture extends BaseTexture
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CubeTexture object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDirtyRectangle | Adds a dirty region to a cube texture resource.
CubeTexture | Initializes a new instance of the CubeTexture class.
Dispose | Immediately releases the unmanaged resources used by the CubeTexture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CubeTexture object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GenerateMipSubLevels | Generates mipmap sublevels. Inherited from BaseTexture.
GetCubeMapSurface | Retrieves a cube texture map surface.
GetHashCode | Returns the hash code for the current instance.
GetLevelDescription | Retrieves a description of one face of a specified cube texture level.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
LockRectangle | Locks a rectangle on a cube texture resource.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseTexture.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseTexture.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.CubeTexture.Disposing event when called from within a derived class.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
UnlockRectangle | Unlocks a rectangle on a cube texture resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this CubeTexture object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseTexture.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels. Inherited from BaseTexture.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
LevelCount | Retrieves the number of texture levels in a multilevel texture. Inherited from BaseTexture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer. Inherited from BaseTexture.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
CubeTexture

Remarks

This class inherits additional functionality from the BaseTexture class.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CubeTexture.AddDirtyRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.AddDirtyRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a cube texture resource.

Overload List

public void AddDirtyRectangle(CubeMapFace);
public void AddDirtyRectangle(CubeMapFace, Rectangle);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CubeTexture.LockRectangle
  • CubeTexture.UnlockRectangle
  • CubeTexture.GetLevelDescription


CubeTexture.AddDirtyRectangle(CubeMapFace)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.AddDirtyRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a cube texture resource.

Definition

Visual Basic .NET Public Sub AddDirtyRectangle( _
ByVal faceType As CubeMapFace _
)
C# public void AddDirtyRectangle(
CubeMapFace faceType
);
Managed C++ public: void AddDirtyRectangle(
CubeMapFace faceType
);
JScript .NET public function AddDirtyRectangle(
faceType : CubeMapFace
);

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace. A CubeMapFace value that identifies the face where the dirty region will be added. Omitting the sig_CubeMapFace_Rectangle parameter indicates that the dirty region should expand to cover the full face.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CubeTexture.LockRectangle
  • CubeTexture.UnlockRectangle
  • CubeTexture.GetLevelDescription


CubeTexture.AddDirtyRectangle(CubeMapFace,Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.AddDirtyRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a cube texture resource.

Definition

Visual Basic .NET Public Sub AddDirtyRectangle( _
ByVal faceType As CubeMapFace, _
ByVal rect As Rectangle _
)
C# public void AddDirtyRectangle(
CubeMapFace faceType,
Rectangle rect
);
Managed C++ public: void AddDirtyRectangle(
CubeMapFace faceType,
Rectangle rect
);
JScript .NET public function AddDirtyRectangle(
faceType : CubeMapFace,
rect : Rectangle
);

Parameters

faceType | Microsoft.DirectX.Direct3D.CubeMapFace. A CubeMapFace value that identifies the face where the dirty region will be added. Omitting the sig_CubeMapFace_Rectangle parameter indicates that the dirty region should expand to cover the full face.
rect | System.Drawing.Rectangle. A Rectangle Leave Site that specifies the dirty region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CubeTexture.LockRectangle
  • CubeTexture.UnlockRectangle
  • CubeTexture.GetLevelDescription


CubeTexture.CubeTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.CubeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Overload List

public CubeTexture(Device, int, int, Usage, Format, Pool);
public CubeTexture(IDirect3DCubeTexture9);
public CubeTexture(IDirect3DCubeTexture9, Device, Pool);
public CubeTexture(IntPtr);

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(IDirect3DCubeTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.CubeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As IDirect3DCubeTexture9 _
)
C# public CubeTexture(
IDirect3DCubeTexture9 pInterop
);
Managed C++ public: CubeTexture(
IDirect3DCubeTexture9 pInterop
);
JScript .NET public function CubeTexture(
pInterop : IDirect3DCubeTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DCubeTexture9. Unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.CubeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public CubeTexture(
IntPtr unmanagedObject
);
Managed C++ public: CubeTexture(
IntPtr unmanagedObject
);
JScript .NET public function CubeTexture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(IDirect3DCubeTexture9,Device,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.CubeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DCubeTexture9, _
ByVal device As Device, _
ByVal pool As Pool _
)
C# public CubeTexture(
IDirect3DCubeTexture9 lp,
Device device,
Pool pool
);
Managed C++ public: CubeTexture(
IDirect3DCubeTexture9 lp,
Device *device,
Pool pool
);
JScript .NET public function CubeTexture(
lp : IDirect3DCubeTexture9,
device : Device,
pool : Pool
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DCubeTexture9. Unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. A Device object.
pool | Microsoft.DirectX.Direct3D.Pool. A Pool value that describes the memory class into which the cube texture should be placed.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(Device,Int32,Int32,Usage,Format,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.CubeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal edgeLength As Integer, _
ByVal levels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool _
)
C# public CubeTexture(
Device device,
int edgeLength,
int levels,
Usage usage,
Format format,
Pool pool
);
Managed C++ public: CubeTexture(
Device *device,
int edgeLength,
int levels,
Usage usage,
Format format,
Pool pool
);
JScript .NET public function CubeTexture(
device : Device,
edgeLength : int,
levels : int,
usage : Usage,
format : Format,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object.
edgeLength | System.Int32. Size of the edges of all top-level faces of the cube texture. The pixel dimensions of subsequent levels of each face are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0, 1 is taken instead.
levels | System.Int32. Number of levels in each face of the cube texture. If this value is 0, Microsoft® Direct3D® generates all cube texture sublevels down to 1x1 pixels for each face, for hardware that supports cube textures. To see the number of levels generated, check the BaseTexture.LevelCount property.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage values. It is good practice to match the usage parameter in the CubeTexture constructor with the behavior flags in the Device constructor. See Remarks.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the format of all levels in all faces of the cube texture.
pool | Microsoft.DirectX.Direct3D.Pool. A Pool value that describes the memory class into which the cube texture should be placed.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the CubeTexture object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.CubeTexture.Disposed
  • Microsoft.DirectX.Direct3D.CubeTexture.Disposing


CubeTexture.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CubeTexture.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the CubeTexture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~CubeTexture();
Managed C++ | ~CubeTexture();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


CubeTexture.GetCubeMapSurface(CubeMapFace,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.GetCubeMapSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a cube texture map surface.

Definition

Visual Basic .NET Public Function GetCubeMapSurface( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer _
) As Surface
C# public Surface GetCubeMapSurface(
CubeMapFace faceType,
int level
);
Managed C++ public: Surface* GetCubeMapSurface(
CubeMapFace faceType,
int level
);
JScript .NET public function GetCubeMapSurface(
faceType : CubeMapFace,
level : int
) : Surface;

Parameters

faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a mipmapped cube texture.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface object that represents the returned cube texture map surface.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


CubeTexture.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


CubeTexture.GetLevelDescription(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.GetLevelDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a description of one face of a specified cube texture level.

Definition

Visual Basic .NET Public Function GetLevelDescription( _
ByVal level As Integer _
) As SurfaceDescription
C# public SurfaceDescription GetLevelDescription(
int level
);
Managed C++ public: SurfaceDescription GetLevelDescription(
int level
);
JScript .NET public function GetLevelDescription(
level : int
) : SurfaceDescription;

Parameters

level System.Int32. Level of a mipmapped cube texture.

Return Value

Microsoft.DirectX.Direct3D.SurfaceDescription . A SurfaceDescription structure that describes one face of the specified cube texture level.

Remarks

The SurfaceDescription structure contains Height and Width members, which indicate the size of one face of the cube. To get the size of the entire cube, multiply the data by 6.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • AddDirtyRectangle
  • LockRectangle
  • UnlockRectangle


CubeTexture.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DCubeTexture9, which allows unmanaged COM clients to create an instance of the managed CubeTexture class. Not supported.


CubeTexture.LockRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Overload List

public GraphicsStream LockRectangle(CubeMapFace, int, LockFlags);
public GraphicsStream LockRectangle(CubeMapFace, int, LockFlags, out int);
public GraphicsStream LockRectangle(CubeMapFace, int, Rectangle, LockFlags);
public GraphicsStream LockRectangle(CubeMapFace, int, Rectangle, LockFlags, out int);
public Array LockRectangle(Type, CubeMapFace, int, LockFlags, out int, int[]);
public Array LockRectangle(Type, CubeMapFace, int, LockFlags, int[]);
public Array LockRectangle(Type, CubeMapFace, int, Rectangle, LockFlags, out int, int[]);
public Array LockRectangle(Type, CubeMapFace, int, Rectangle, LockFlags, int[]);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,Rectangle,LockFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
out int pitch
);
Managed C++ public: GraphicsStream* LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
int *pitch
);
JScript .NET public function LockRectangle(
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch | System.Int32. Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,LockFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags,
out int pitch
);
Managed C++ public: GraphicsStream* LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags,
int *pitch
);
JScript .NET public function LockRectangle(
faceType : CubeMapFace,
level : int,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch | System.Int32. Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,Rectangle,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags
);
JScript .NET public function LockRectangle(
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags
) : GraphicsStream;

Parameters

faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags
);
JScript .NET public function LockRectangle(
faceType : CubeMapFace,
level : int,
flags : LockFlags
) : GraphicsStream;

Parameters

faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,Rectangle,LockFlags,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
out int pitch,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
int *pitch,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch | System.Int32. Pitch of the returning data.
ranks | System.Int32[]. Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,LockFlags,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
out int pitch,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
int *pitch,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch | System.Int32. Pitch of the returning data.
ranks | System.Int32[]. Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,Rectangle,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.
ranks | System.Int32[]. Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a cube texture.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags enumerated values that describe the type of lock to perform.
ranks | System.Int32[]. Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.op_Equality(CubeTexture,CubeTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As CubeTexture, _
ByVal right As CubeTexture _
) As Boolean
C# public static bool op_Equality(
CubeTexture left,
CubeTexture right
);
Managed C++ public: static bool op_Equality(
CubeTexture *left,
CubeTexture *right
);
JScript .NET public static function op_Equality(
left : CubeTexture,
right : CubeTexture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.CubeTexture. The CubeTexture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.CubeTexture. The CubeTexture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CubeTexture.op_Inequality(CubeTexture,CubeTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As CubeTexture, _
ByVal right As CubeTexture _
) As Boolean
C# public static bool op_Inequality(
CubeTexture left,
CubeTexture right
);
Managed C++ public: static bool op_Inequality(
CubeTexture *left,
CubeTexture *right
);
JScript .NET public static function op_Inequality(
left : CubeTexture,
right : CubeTexture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.CubeTexture. The CubeTexture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.CubeTexture. The CubeTexture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


CubeTexture.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.CubeTexture.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


CubeTexture.UnlockRectangle(CubeMapFace,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.UnlockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks a rectangle on a cube texture resource.

Definition

Visual Basic .NET Public Sub UnlockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer _
)
C# public void UnlockRectangle(
CubeMapFace faceType,
int level
);
Managed C++ public: void UnlockRectangle(
CubeMapFace faceType,
int level
);
JScript .NET public function UnlockRectangle(
faceType : CubeMapFace,
level : int
);

Parameters

faceType | Microsoft.DirectX.Direct3D.CubeMapFace. Member of the CubeMapFace enumerated type that identifies a cube map face.
level | System.Int32. Level of a mipmapped cube texture.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • LockRectangle
  • AddDirtyRectangle


CubeTexture.UpdateUnmanagedPointer(IDirect3DCubeTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this CubeTexture object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DCubeTexture9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DCubeTexture9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DCubeTexture9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DCubeTexture9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DCubeTexture9. Pointer to the IDirect3DCubeTexture9 structure used to update the unmanaged pointer for this CubeTexture object.


CubeTexture.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


CubeTexture.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DCubeTexture9
C# | public IDirect3DCubeTexture9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DCubeTexture9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DCubeTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DCubeTexture9 . Unmanaged IDirect3DCubeTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


CubeTexture.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTexture.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the CubeTexture object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.CubeTexture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CubeTexture object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.CustomVertex

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object
  • Generate a Scene

Defines various custom fixed-format vertex types. This class is a container of structures. See the individual structures for more information.

Definition

Visual Basic .NET NotInheritable Public Class CustomVertex
Inherits Object
C# | public sealed class CustomVertex : Object
Managed C++ | public __gc __sealed class CustomVertex : public Object
JScript .NET | public class CustomVertex extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Structures

Structure | Description
CustomVertex.PositionColored | Describes a custom vertex format structure that contains position and color information.
CustomVertex.PositionColoredTextured | Describes a custom vertex format structure that contains position, color, and one set of texture coordinates.
CustomVertex.PositionNormal | Describes a custom vertex format structure that contains position and normal data.
CustomVertex.PositionNormalColored | Describes a custom vertex format structure that contains position, color, and normal data.
CustomVertex.PositionNormalTextured | Describes a custom vertex format structure that contains position, normal data, and one set of texture coordinates.
CustomVertex.PositionOnly | Describes a custom vertex format structure that contains only position data.
CustomVertex.PositionTextured | Describes a custom vertex format structure that contains position and one set of texture coordinates.
CustomVertex.Transformed | Describes a custom vertex format structure that contains transformed vertices.
CustomVertex.TransformedColored | Describes a custom vertex format structure that contains transformed vertices and color information.
CustomVertex.TransformedColoredTextured | Describes a custom vertex format structure that contains transformed vertices, color, and one set of texture coordinates.
CustomVertex.TransformedTextured | Describes a custom vertex format structure that contains transformed vertices and one set of texture coordinates.

Inheritance Hierarchy

Object Leave Site
CustomVertex

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.Direct3D.D3DX

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DX Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains default constant values for Microsoft® Direct3D® extensions.

Definition

Visual Basic .NET NotInheritable Public Class D3DX
Inherits Object
C# | public sealed class D3DX : Object
Managed C++ | public __gc __sealed class D3DX : public Object
JScript .NET | public class D3DX extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Default | Retrieves the value of the Default constant for Direct3D extensions.
static (Shared in Visual Basic .NET) DefaultFloat | Retrieves the value of the DefaultFloat constant for Direct3D extensions.
static (Shared in Visual Basic .NET) DefaultNonPowerOf2 | Retrieves the value of the DefaultNonPowerOf2 constant for Direct3D extensions.
static (Shared in Visual Basic .NET) FormatFromFile | Retrieves the value of the FormatFromFile constant for Direct3D extensions.
static (Shared in Visual Basic .NET) FromFile | Retrieves the value of the FromFile constant for Direct3D extensions.

Methods

Method | Description
D3DX | Initializes a new instance of the D3DX class.

Inheritance Hierarchy

Object Leave Site
D3DX

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DX.D3DX()

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DX.D3DX Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the D3DX class.

Definition

Visual Basic .NET | Public Sub New()
C# | public D3DX();
Managed C++ | public: D3DX();
JScript .NET | public function D3DX();


D3DX.Default

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DX.Default Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of the Default constant for Microsoft® Direct3D® extensions.

Definition

Visual Basic .NET | Public Shared Default As Int32
C# | public static Int32 Default;
Managed C++ | public: static Int32 Default;
JScript .NET | public static var Default : Int32

Field Value

System.Int32 . Returned value is -1.

This field is read-only.


D3DX.DefaultFloat

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DX.DefaultFloat Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of the DefaultFloat constant for Microsoft® Direct3D® extensions.

Definition

Visual Basic .NET | Public Shared DefaultFloat As Single
C# | public static Single DefaultFloat;
Managed C++ | public: static Single DefaultFloat;
JScript .NET | public static var DefaultFloat : Single

Field Value

System.Single . Returned value is 3.402823466e+38F.

This field is read-only.


D3DX.DefaultNonPowerOf2

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DX.DefaultNonPowerOf2 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of the DefaultNonPowerOf2 constant for Microsoft® Direct3D® extensions.

Definition

Visual Basic .NET | Public Shared DefaultNonPowerOf2 As Int32
C# | public static Int32 DefaultNonPowerOf2;
Managed C++ | public: static Int32 DefaultNonPowerOf2;
JScript .NET | public static var DefaultNonPowerOf2 : Int32

Field Value

System.Int32 . Returned value is -2.

This field is read-only.


D3DX.FormatFromFile

D3DX.FormatFromFile Field

Note: This documentation is preliminary and is subject to change.

Retrieves the value of the FormatFromFile constant for Microsoft® Direct3D® extensions.

Definition

Visual Basic .NET | Public Shared FormatFromFile As Int32
C# | public static Int32 FormatFromFile;
Managed C++ | public: static Int32 FormatFromFile;
JScript .NET | public static var FormatFromFile : Int32

Field Value

System.Int32 . Returned value is -3.

This field is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


D3DX.FromFile

D3DX.FromFile Field

Note: This documentation is preliminary and is subject to change.

Retrieves the value of the FromFile constant for Microsoft® Direct3D® extensions.

Definition

Visual Basic .NET | Public Shared FromFile As Int32
C# | public static Int32 FromFile;
Managed C++ | public: static Int32 FromFile;
JScript .NET | public static var FromFile : Int32

Field Value

System.Int32 . Returned value is -3.

This field is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Device Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Generate a Scene

Performs primitive-based rendering, creates resources, handles system-level variables, adjusts gamma ramp levels, gets and sets palettes, and creates shaders.

Definition

Visual Basic .NET NotInheritable Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class Device : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class Device : public MarshalByRefObject,
IDisposable
JScript .NET public class Device extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
DeviceLost | Occurs when a device is about to be lost (for example, immediately prior to a reset).
DeviceReset | Occurs after a device is reset, allowing an application to re-create all Pool.Default resources.
DeviceResizing | Occurs when a device is resizing, allowing the application to cancel the default handling of the resize.
Disposing | Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
BeginScene | Begins a scene.
BeginStateBlock | Signals Direct3D to begin recording a device state block.
CheckCooperativeLevel | Reports the current cooperative-level status of the Direct3D device for a windowed or full-screen application.
Clear | Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.
ColorFill | Allows an application to fill a rectangular area of a Default surface with a specified color.
CreateDepthStencilSurface | Creates a depth stencil resource.
CreateOffscreenPlainSurface | Creates an off-screen surface.
CreateRenderTarget | Creates a render target surface.
DeletePatch | Frees a cached high-order patch.
Device | Initializes a new instance of the current class.
Dispose | Immediately releases the unmanaged resources used by the Device object.
DrawIndexedPrimitives | Renders the specified geometric primitive, based on indexing into an array of vertices.
DrawIndexedUserPrimitives | Renders the specified geometric primitive with data specified by a user memory pointer.
DrawPrimitives | Renders a sequence of non-indexed geometric primitives of the specified type from the current set of data input streams.
DrawRectanglePatch | Draws a rectangular patch using the currently set streams.
DrawTrianglePatch | Draws a triangular patch using the currently set streams.
DrawUserPrimitives | Renders data specified by a user memory pointer as a sequence of geometric primitives of the specified type.
EndScene | Ends a scene that was started by calling the Device.BeginScene method.
EndStateBlock | Signals Microsoft® Direct3D® to stop recording a device state block and retrieve a pointer to the state block interface.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
EvictManagedResources | Evicts all managed resources, including Direct3D resources and those that are driver-managed.
Finalize | Allows the Device object to free resources before it is destroyed by the garbage collector.
GetBackBuffer | Retrieves a back buffer from a device's swap chain.
GetCubeTexture | Retrieves the cube texture assigned to a stage for a device.
GetFrontBufferData | Generates a copy of a device's front buffer and places it in a system memory buffer provided by the application.
GetGammaRamp | Retrieves the gamma correction ramp for the swap chain.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPaletteEntries | Retrieves palette entries.
GetPixelShaderBooleanConstant | Retrieves a Boolean shader constant.
GetPixelShaderInt32Constant | Retrieves an integer shader constant.
GetPixelShaderSingleConstant | Retrieves a floating-point shader constant.
GetRasterStatus | Returns information that describes the raster of the monitor on which the swap chain is presented.
GetRenderStateBoolean | Retrieves the Boolean value of a given render state.
GetRenderStateInt32 | Retrieves the integer value of a given render state.
GetRenderStateSingle | Retrieves the floating-point value of a given render state.
GetRenderTarget | Retrieves a render target surface.
GetRenderTargetData | Copies the render target data from device memory to system memory.
GetSamplerStageStateBoolean | Retrieves the Boolean value of a given sampler stage state.
GetSamplerStageStateInt32 | Retrieves the integer value of a given sampler stage state.
GetSamplerStageStateSingle | Retrieves the floating-point value of a given sampler stage state.
GetStreamSource | Retrieves a vertex buffer bound to the specified data stream.
GetStreamSourceFrequency | Retrieves the stream source frequency divider value.
GetSwapChain | Retrieves a reference to a swap chain.
GetTexture | Retrieves a texture assigned to a stage for a device.
GetTextureStageStateBoolean | Retrieves the Boolean value of a given texture stage state.
GetTextureStageStateInt32 | Retrieves the integer value of a given texture stage state.
GetTextureStageStateSingle | Retrieves the floating-point value of a given texture stage state.
GetTransform | Retrieves a matrix that describes a transformation state.
GetVertexShaderBooleanConstant | Retrieves a Boolean vertex shader constant.
GetVertexShaderInt32Constant | Retrieves an integer vertex shader constant.
GetVertexShaderSingleConstant | Retrieves a floating-point vertex shader constant.
GetVolumeTexture | Retrieves the volume texture assigned to a stage for a device.
MultiplyTransform | Multiplies a device's world, view, or projection matrices by a specified matrix.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Present | Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.
ProcessVertices | Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.
raise_DeviceLost | Raises a Device.DeviceLost event when called from within a derived class.
raise_DeviceReset | Raises a Device.DeviceReset event when called from within a derived class.
raise_DeviceResizing | Raises a Device.DeviceResizing event when called from within a derived class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Device.Disposing event when called from within a derived class.
Reset | Resets the presentation parameters for the current device.
SetCursor | Sets the current cursor.
SetCursorPosition | Sets the cursor position and update options.
SetCursorProperties | Sets properties for the cursor.
SetDialogBoxesEnabled | Enables the use of Microsoft Windows® Graphics Device Interface (GDI) dialog boxes in full-screen applications.
SetGammaRamp | Sets the gamma correction ramp for the implicit swap chain.
SetPaletteEntries | Sets palette entries.
SetPixelShaderConstant | Sets a pixel shader constant.
SetPixelShaderConstantBoolean | Sets Boolean shader constants.
SetPixelShaderConstantInt32 | Sets integer shader constants.
SetPixelShaderConstantSingle | Sets floating-point shader constants.
SetRenderState | Sets a render state value.
SetRenderTarget | Sets a new color buffer for a device.
SetSamplerState | Sets a sampler stage state value.
SetStreamSource | Binds a vertex buffer to a device data stream.
SetStreamSourceFrequency | Sets the stream source frequency divider value.
SetTexture | Assigns a texture to a device stage.
SetTextureStageState | Sets a texture stage state value.
SetTransform | Sets a single device transform.
SetVertexShaderConstant | Sets a vertex shader constant.
SetVertexShaderConstantBoolean | Sets Boolean vertex shader constants.
SetVertexShaderConstantInt32 | Sets integer vertex shader constants.
SetVertexShaderConstantSingle | Sets floating-point vertex shader constants.
ShowCursor | Displays or hides the cursor.
StretchRectangle | Copies the contents of the source rectangle to the destination rectangle.
TestCooperativeLevel | Reports the current cooperative-level status of the Direct3D device for a windowed or full-screen application.
UpdateSurface | Copies rectangular subsets of pixels from one surface to another.
UpdateTexture | Updates the dirty portions of a texture.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Device object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
ValidateDevice | Reports the device's ability to render the current texture-blending operations and arguments in a single pass.

Properties

Property | Description
AvailableTextureMemory | Retrieves an estimate of the amount of available texture memory.
ClipPlanes | Retrieves the clipping planes on the current device.
ClipStatus | Retrieves or sets a ClipStatus object.
CreationParameters | Retrieves the creation parameters of the device.
CurrentTexturePalette | Retrieves or sets the current texture palette.
DepthStencilSurface | Retrieves or sets the depth stencil surface owned by the Device object.
DeviceCaps | Retrieves the capabilities of the rendering device.
DisplayMode | Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.
Disposed | Gets a value that indicates whether the object is disposed.
Indices | Retrieves or sets index data.
static (Shared in Visual Basic .NET) IsUsingEventHandlers | Retrieves or sets a value that indicates whether the device should use event handlers.
Lights | Retrieves the LightsCollection collection on the current device.
Material | Retrieves or sets the current material properties for the device.
NPatchMode | Retrieves or sets the N-patch mode segments.
NumberOfSwapChains | Retrieves the number of implicit swap chains.
PixelShader | Retrieves or sets the current pixel shader.
PresentationParameters | Retrieves presentation parameters for a device.
RasterStatus | Retrieves information that describes the raster of the monitor on which the swap chain is presented.
RenderState | Retrieves a render-state value for a device.
SamplerState | Retrieves a device's sampler states.
ScissorRectangle | Retrieves or sets the scissor rectangle.
SoftwareVertexProcessing | Retrieves or sets the vertex processing mode.
TextureState | Retrieves a state value for an assigned texture.
Transform | Retrieves a matrix that describes a transformation state.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DDevice9 interface pointer.
VertexDeclaration | Retrieves or sets a vertex shader declaration.
VertexFormat | Retrieves or sets the supported flexible vertex formats.
VertexShader | Retrieves or sets the current vertex shader.
Viewport | Retrieves or sets the viewport parameters for the current device.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Device.BeginScene()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.BeginScene Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Generate a Scene

Begins a scene.

Definition

Visual Basic .NET | Public Sub BeginScene()
C# | public void BeginScene();
Managed C++ | public: void BeginScene();
JScript .NET | public function BeginScene();

Remarks

Every call to BeginScene should eventually be followed by a call to EndScene before the display is updated with Device.Present.

If the method fails, the device was unable to begin the scene, and there is no need to call EndScene. In fact, calls to EndScene fail if the previous call to BeginScene fails.

Exceptions
InvalidCallException The method call is invalid. This occurs when BeginScene is called while already in a BeginScene ... EndScene pair. Never call BeginScene twice without first calling EndScene.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();


Device.BeginStateBlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.BeginStateBlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Signals Microsoft® Direct3D® to begin recording a device state block.

Definition

Visual Basic .NET | Public Sub BeginStateBlock()
C# | public void BeginStateBlock();
Managed C++ | public: void BeginStateBlock();
JScript .NET | public function BeginStateBlock();

Remarks

To ensure that all recorded states are valid, an application can call the Device.ValidateDevice method prior to calling this method.

The following properties and methods can be recorded in a state block, after calling Device.BeginStateBlock and before calling Device.EndStateBlock.

  • ClipPlane.SetSingleArray
  • ClipPlane.Plane
  • Device.CurrentTexturePalette
  • Device.VertexFormat
  • Device.Indices
  • Device.Material
  • Device.NPatchMode
  • Device.PixelShader
  • Device.SetPixelShaderConstant
  • Device.RenderState
  • Device.SamplerState
  • Device.ScissorRectangle
  • Device.SetStreamSource
  • Device.SetStreamSourceFrequency
  • Device.SetTexture
  • Device.TextureState
  • Device.VertexDeclaration
  • Device.VertexShader
  • Device.SetVertexShaderConstant
  • All of the Light properties that are committed.
  • All of the parameters and methods in ClipPlane (except GetSingleArray).
  • All of the ClipPlanes methods.
  • All of the SamplerStateManager properties.
  • All of the TextureStateManager properties.
  • All of the Transforms properties.
  • All of the RenderStateManager properties.

The ordering of state changes in a state block is not guaranteed. If the same state is specified multiple times in a state block, only the last value is used.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • StateBlock


Device.CheckCooperativeLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CheckCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reports the current cooperative-level status of the Microsoft® Direct3D® device for a windowed or full-screen application.

Overload List

public bool CheckCooperativeLevel();
public bool CheckCooperativeLevel(out int);

Remarks

If the device is lost but cannot be restored at the current time, Device.CheckCooperativeLevel returns the DeviceLost result code in the param_Int32R_result parameter. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.CheckCooperativeLevel until it receives a return value of DeviceNotReset. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is lost or not reset.

A call to CheckCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

See Also

  • DeviceNotResetException
  • Lost Devices


Device.CheckCooperativeLevel()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CheckCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reports the current cooperative-level status of the Microsoft® Direct3D® device for a windowed or full-screen application.

Definition

Visual Basic .NET | Public Function CheckCooperativeLevel() As Boolean
C# | public bool CheckCooperativeLevel();
Managed C++ | public: bool CheckCooperativeLevel();
JScript .NET | public function CheckCooperativeLevel() : boolean;

Return Value

System.Boolean . Current cooperative-level status of the device for a windowed or full-screen application. A return value of true indicates that the device is operational and that the calling application can continue; a value of false indicates that the device is lost or needs to be reset.

Remarks

If the device is lost but cannot be restored at the current time, Device.CheckCooperativeLevel returns the DeviceLost result code in the param_Int32R_result parameter. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.CheckCooperativeLevel until it receives a return value of DeviceNotReset. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is lost or not reset.

A call to CheckCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

See Also

  • DeviceNotResetException
  • Lost Devices


Device.CheckCooperativeLevel(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CheckCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reports the current cooperative-level status of the Microsoft® Direct3D® device for a windowed or full-screen application.

Definition

Visual Basic .NET Public Function CheckCooperativeLevel( _
ByRef result As Integer _
) As Boolean
C# public bool CheckCooperativeLevel(
out int result
);
Managed C++ public: bool CheckCooperativeLevel(
int *result
);
JScript .NET public function CheckCooperativeLevel(
result : int
) : boolean;

Parameters

result System.Int32. [in, out] Current cooperative-level status of the device for a windowed or full-screen application, reported using a ResultCode value. A Success result indicates that the device is operational and that the calling application can continue. A DeviceLost result indicates that the device is lost but cannot be reset at this time; therefore, rendering is not possible. A DeviceNotReset result indicates that the device is lost but can be reset at this time.

Return Value

System.Boolean . Current cooperative-level status of the device for a windowed or full-screen application. A return value of true indicates that the device is operational and that the calling application can continue; a value of false indicates that the device is lost or needs to be reset.

Remarks

If the device is lost but cannot be restored at the current time, Device.CheckCooperativeLevel returns the DeviceLost result code in the param_Int32R_result parameter. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.CheckCooperativeLevel until it receives a return value of DeviceNotReset. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is lost or not reset.

A call to CheckCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

See Also

  • DeviceNotResetException
  • Lost Devices


Device.Clear

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Overload List

public void Clear(ClearFlags, Color, float, int);
public void Clear(ClearFlags, Color, float, int, Rectangle[]);
public void Clear(ClearFlags, int, float, int);
public void Clear(ClearFlags, int, float, int, Rectangle[]);

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Color,Single,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic .NET Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Color, _
ByVal zdepth As Single, _
ByVal stencil As Integer _
)
C# public void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil
);
Managed C++ public: void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil
);
JScript .NET public function Clear(
flags : ClearFlags,
color : Color,
zdepth : float,
stencil : int
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags. Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color | System.Drawing.Color. A Color Leave Site object that represents the color to which the render target surface is cleared.
zdepth | System.Single. New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil | System.Int32. Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Color,Single,Int32,Rectangle[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic .NET Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Color, _
ByVal zdepth As Single, _
ByVal stencil As Integer, _
ByVal rect() As Rectangle _
)
C# public void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil,
Rectangle[] rect
);
Managed C++ public: void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil,
Rectangle rect __gc[]
);
JScript .NET public function Clear(
flags : ClearFlags,
color : Color,
zdepth : float,
stencil : int,
rect : Rectangle[]
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags. Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color | System.Drawing.Color. A Color Leave Site object that represents the color to which the render target surface is cleared.
zdepth | System.Single. New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil | System.Int32. Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.
rect | System.Drawing.Rectangle[]. Array of Rectangle Leave Site structures that describe the rectangles to clear. To clear the entire surface, set a rectangle to the dimensions of the rendering target. Each rectangle uses screen coordinates that correspond to points on the render target surface. Coordinates are clipped to the bounds of the viewport rectangle.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Int32,Single,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic .NET Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Integer, _
ByVal zdepth As Single, _
ByVal stencil As Integer _
)
C# public void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil
);
Managed C++ public: void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil
);
JScript .NET public function Clear(
flags : ClearFlags,
color : int,
zdepth : float,
stencil : int
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags. Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color | System.Int32. A 32-bit ARGB color value to which the render target surface is cleared.
zdepth | System.Single. New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil | System.Int32. Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Int32,Single,Int32,Rectangle[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic .NET Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Integer, _
ByVal zdepth As Single, _
ByVal stencil As Integer, _
ByVal regions() As Rectangle _
)
C# public void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil,
Rectangle[] regions
);
Managed C++ public: void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil,
Rectangle regions __gc[]
);
JScript .NET public function Clear(
flags : ClearFlags,
color : int,
zdepth : float,
stencil : int,
regions : Rectangle[]
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags. Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color | System.Int32. A 32-bit ARGB color value to which the render target surface is cleared.
zdepth | System.Single. New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil | System.Int32. Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.
regions | System.Drawing.Rectangle[]. Array of Rectangle Leave Site structures that describe the rectangles to clear. To clear the entire surface, set a rectangle to the dimensions of the rendering target. Each rectangle uses screen coordinates that correspond to points on the render target surface. Coordinates are clipped to the bounds of the viewport rectangle.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.ColorFill

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows an application to fill a rectangular area of a Default surface with a specified color.

Overload List

public void ColorFill(Surface, Rectangle, Color);
public void ColorFill(Surface, Rectangle, int);

Remarks

This method can be applied only to a render target, a render-target texture surface, or an off-screen plain surface with a pool type of Default.

Device.ColorFill works with all formats. However, when using a reference or a software device, the only formats supported are X1R5G5B5, A1R5G5B5, R5G6B5, X8R8G8B8, A8R8G8B8, YUY2, G8R8G8B8, UYVY, R8G8B8G8, R16F, G16R16F, A16B16G16R16F, R32F, G32R32F, and A32B32G32R32F.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Pool


Device.ColorFill(Surface,Rectangle,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows an application to fill a rectangular area of a Default surface with a specified color.

Definition

Visual Basic .NET Public Sub ColorFill( _
ByVal surface As Surface, _
ByVal rect As Rectangle, _
ByVal color As Color _
)
C# public void ColorFill(
Surface surface,
Rectangle rect,
Color color
);
Managed C++ public: void ColorFill(
Surface *surface,
Rectangle rect,
Color color
);
JScript .NET public function ColorFill(
surface : Surface,
rect : Rectangle,
color : Color
);

Parameters

surface | Microsoft.DirectX.Direct3D.Surface. Surface to be filled.
rect | System.Drawing.Rectangle. Source rectangle. To fill the entire surface, specify null.
color | System.Drawing.Color. Color used for filling.

Remarks

This method can be applied only to a render target, a render-target texture surface, or an off-screen plain surface with a pool type of Default.

Device.ColorFill works with all formats. However, when using a reference or a software device, the only formats supported are X1R5G5B5, A1R5G5B5, R5G6B5, X8R8G8B8, A8R8G8B8, YUY2, G8R8G8B8, UYVY, R8G8B8G8, R16F, G16R16F, A16B16G16R16F, R32F, G32R32F, and A32B32G32R32F.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Pool


Device.ColorFill(Surface,Rectangle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows an application to fill a rectangular area of a Default surface with a specified color.

Definition

Visual Basic .NET Public Sub ColorFill( _
ByVal surface As Surface, _
ByVal rect As Rectangle, _
ByVal color As Integer _
)
C# public void ColorFill(
Surface surface,
Rectangle rect,
int color
);
Managed C++ public: void ColorFill(
Surface *surface,
Rectangle rect,
int color
);
JScript .NET public function ColorFill(
surface : Surface,
rect : Rectangle,
color : int
);

Parameters

surface | Microsoft.DirectX.Direct3D.Surface. Surface to be filled.
rect | System.Drawing.Rectangle. Source rectangle. To fill the entire surface, specify null.
color | System.Int32. Color used for filling.

Remarks

This method can be applied only to a render target, a render-target texture surface, or an off-screen plain surface with a pool type of Default.

Device.ColorFill works with all formats. However, when using a reference or a software device, the only formats supported are X1R5G5B5, A1R5G5B5, R5G6B5, X8R8G8B8, A8R8G8B8, YUY2, G8R8G8B8, UYVY, R8G8B8G8, R16F, G16R16F, A16B16G16R16F, R32F, G32R32F, and A32B32G32R32F.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Pool


Device.CreateDepthStencilSurface(Int32,Int32,DepthFormat,MultiSampleType,Int32,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CreateDepthStencilSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a depth stencil resource.

Definition

Visual Basic .NET Public Function CreateDepthStencilSurface( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As DepthFormat, _
ByVal multiSample As MultiSampleType, _
ByVal multiSampleQuality As Integer, _
ByVal discard As Boolean _
) As Surface
C# public Surface CreateDepthStencilSurface(
int width,
int height,
DepthFormat format,
MultiSampleType multiSample,
int multiSampleQuality,
bool discard
);
Managed C++ public: Surface* CreateDepthStencilSurface(
int width,
int height,
DepthFormat format,
MultiSampleType multiSample,
int multiSampleQuality,
bool discard
);
JScript .NET public function CreateDepthStencilSurface(
width : int,
height : int,
format : DepthFormat,
multiSample : MultiSampleType,
multiSampleQuality : int,
discard : boolean
) : Surface;

Parameters

width | System.Int32. Width of the depth stencil surface in pixels.
height | System.Int32. Height of the depth stencil surface in pixels.
format | Microsoft.DirectX.Direct3D.DepthFormat. Member of the DepthFormat enumerated type that describes the format of the depth stencil surface. This value must be one of the enumerated depth stencil formats for the current device.
multiSample | Microsoft.DirectX.Direct3D.MultiSampleType. Member of the MultiSampleType enumerated type that describes the multisampling buffer type. This value must be one of the supported multisample types. When this surface is passed to the Device.DepthStencilSurface property, its multisample type must be the same as that of the render target set by Device.SetRenderTarget.
multiSampleQuality | System.Int32. Quality level. The valid range is between 0 and one less than the level returned by the param_MultiSampleType_multiSampleType parameter of the Manager.CheckDeviceMultiSampleType method. Passing a larger value results in a GraphicsException with an InvalidCall value. The param_Int32_multiSampleQuality values of paired render targets, depth stencil surfaces, and the param_MultiSampleType_multiSample type must all match.
discard System.Boolean. Set to true to enable z-buffer discarding; otherwise false.

If this flag is set, the contents of the depth stencil buffer are invalid after Device.Present is called or when Device.DepthStencilSurface is set with a different depth surface.

This flag's behavior is the same as passing the enumerated value PresentFlag.DiscardDepthStencil to the Device.Present method.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface that represents the created depth stencil surface resource.

Remarks

The memory class of the depth stencil buffer is always Default.

Exceptions
NotAvailableException | The current device does not support the queried multisample type.
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


Device.CreateOffscreenPlainSurface(Int32,Int32,Format,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CreateOffscreenPlainSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Creates an off-screen surface.

Definition

Visual Basic .NET Public Function CreateOffscreenPlainSurface( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As Format, _
ByVal pool As Pool _
) As Surface
C# public Surface CreateOffscreenPlainSurface(
int width,
int height,
Format format,
Pool pool
);
Managed C++ public: Surface* CreateOffscreenPlainSurface(
int width,
int height,
Format format,
Pool pool
);
JScript .NET public function CreateOffscreenPlainSurface(
width : int,
height : int,
format : Format,
pool : Pool
) : Surface;

Parameters

width | System.Int32. Width of the surface in pixels.
height | System.Int32. Height of the surface in pixels.
format | Microsoft.DirectX.Direct3D.Format. Format of the surface. For more information, see Format.
pool | Microsoft.DirectX.Direct3D.Pool. Surface pool type. For more information, see Pool.

Return Value

Microsoft.DirectX.Direct3D.Surface . The Surface object that is created.

Remarks

The Default pool is appropriate for use with Device.StretchRectangle and Device.ColorFill.

The Managed pool is not allowed when creating an off-screen plain surface. For more information about memory pools, see Pool.

Off-screen plain surfaces are always lockable, regardless of their pool type.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


Device.CreateRenderTarget(Int32,Int32,Format,MultiSampleType,Int32,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CreateRenderTarget Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a render target surface.

Definition

Visual Basic .NET Public Function CreateRenderTarget( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As Format, _
ByVal multiSample As MultiSampleType, _
ByVal multiSampleQuality As Integer, _
ByVal lockable As Boolean _
) As Surface
C# public Surface CreateRenderTarget(
int width,
int height,
Format format,
MultiSampleType multiSample,
int multiSampleQuality,
bool lockable
);
Managed C++ public: Surface* CreateRenderTarget(
int width,
int height,
Format format,
MultiSampleType multiSample,
int multiSampleQuality,
bool lockable
);
JScript .NET public function CreateRenderTarget(
width : int,
height : int,
format : Format,
multiSample : MultiSampleType,
multiSampleQuality : int,
lockable : boolean
) : Surface;

Parameters

width | System.Int32. Width of the render-target surface in pixels.
height | System.Int32. Height of the render-target surface in pixels.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the format of the render target.
multiSample | Microsoft.DirectX.Direct3D.MultiSampleType. Member of the MultiSampleType enumerated type that describes the multisampling buffer type. This parameter specifies the antialiasing type for the render target. When this surface is passed to Device.SetRenderTarget, its multisample type must be the same as that of the depth stencil property Device.DepthStencilSurface.
multiSampleQuality | System.Int32. Quality level. The valid range is between 0 and one less than the level returned by the param_Int32R_qualityLevels parameter of the Manager.CheckDeviceMultiSampleType. Passing a larger value causes an InvalidCallException. The param_Int32_multiSampleQuality values of paired render targets, depth stencil surfaces, and the multisample type must all match.
lockable | System.Boolean. Set to true if render targets are lockable; otherwise, false. Note that lockable render targets reduce performance on some graphics hardware.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface.

Remarks

Render-target surfaces are placed in the Pool memory class.

The creation of lockable, multisampled render targets is not supported.

Exceptions
NotAvailableException | The device does not support the queried multisample type.
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


Device.DeletePatch(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DeletePatch Method

 Language:
Note: This documentation is preliminary and is subject to change.

Frees a cached high-order patch.

Definition

Visual Basic .NET Public Sub DeletePatch( _
ByVal handle As Integer _
)
C# public void DeletePatch(
int handle
);
Managed C++ public: void DeletePatch(
int handle
);
JScript .NET public function DeletePatch(
handle : int
);

Parameters

handle System.Int32. Handle of the cached high-order patch to delete.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Overload List

public Device(IDirect3DDevice9);
public Device(int, DeviceType, Control, CreateFlags, PresentParameters[]);
public Device(int, DeviceType, IntPtr, CreateFlags, PresentParameters[]);
public Device(IntPtr);

Remarks

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(IDirect3DDevice9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DDevice9 _
)
C# public Device(
IDirect3DDevice9 pUnk
);
Managed C++ public: Device(
IDirect3DDevice9 pUnk
);
JScript .NET public function Device(
pUnk : IDirect3DDevice9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DDevice9. Unmanaged Component Object Model (COM) IDirect3DDevice9 interface pointer.

Remarks

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Device(
IntPtr unmanagedObject
);
Managed C++ public: Device(
IntPtr unmanagedObject
);
JScript .NET public function Device(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DDevice9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(Int32,DeviceType,IntPtr,CreateFlags,PresentParameters[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic .NET Public Sub New( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal renderWindowHandle As IntPtr, _
ByVal behaviorFlags As CreateFlags, _
ByVal presentationParameters() As PresentParameters _
)
C# public Device(
int adapter,
DeviceType deviceType,
IntPtr renderWindowHandle,
CreateFlags behaviorFlags,
PresentParameters[] presentationParameters
);
Managed C++ public: Device(
int adapter,
DeviceType deviceType,
IntPtr renderWindowHandle,
CreateFlags behaviorFlags,
PresentParameters *presentationParameters __gc[]
);
JScript .NET public function Device(
adapter : int,
deviceType : DeviceType,
renderWindowHandle : IntPtr,
behaviorFlags : CreateFlags,
presentationParameters : PresentParameters[]
);

Parameters

adapter | System.Int32. Ordinal number that identifies which physical device the object represents. Device 0 is the default device. The highest value that can be used in this parameter is one less than the total number of physical devices.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumerated type that denotes the desired device type. If the desired device type is not available, the method fails.
renderWindowHandle System.IntPtr. Handle to a Form Leave Site, Panel Leave Site, or any other Control Leave Site derived class. This parameter indicates the surface to bind to the device.

For full-screen mode, the window specified must be a top-level window.

For windowed mode, this parameter can be null. If null is specified, a non-null handle must be specified when calling Device.Present. This can be done either by setting the PresentParameters.DeviceWindow property or by using the optional param_Control_overrideWindow parameter of the Device.Present method.
behaviorFlags | Microsoft.DirectX.Direct3D.CreateFlags. Combination of one or more options that control device creation.
presentationParameters Microsoft.DirectX.Direct3D.PresentParameters[]. [in, out] Pointer to a PresentParameters object that describes the presentation parameters for the device to create. For Microsoft® Windows® 2000 and Microsoft® Windows® XP, the full-screen device display refresh rate is set in the following order.
  1. User-specified nonzero ForcedRefreshRate registry key, if supported by the device.
  2. Application-specified nonzero refresh rate value in the presentation parameter.
  3. Refresh rate of the latest desktop mode, if supported by the device.
  4. 75 hertz if supported by the device.
  5. 60 hertz if supported by the device.
  6. Device default.
By default, if a refresh rate is unsupported, the closest supported refresh rate below it is used. For example, if the application specifies 63 hertz, 60 hertz is used. No refresh rates below 57 hertz are supported.

Calling this method changes the value of several members of PresentParameters.
  • BackBufferCount, BackBufferWidth, and BackBufferHeight = 0 for windowed or full-screen mode.
  • BackBufferFormat = Unknown for windowed mode only. Full-screen mode must specify a format.
If AdapterGroupDevice is set, param_PresentParametersA_presentationParameters is an array. Regardless of the number of heads that exist, only one depth stencil surface is automatically created.

Remarks

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(Int32,DeviceType,Control,CreateFlags,PresentParameters[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic .NET Public Sub New( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal renderWindow As Control, _
ByVal behaviorFlags As CreateFlags, _
ByVal presentationParameters() As PresentParameters _
)
C# public Device(
int adapter,
DeviceType deviceType,
Control renderWindow,
CreateFlags behaviorFlags,
PresentParameters[] presentationParameters
);
Managed C++ public: Device(
int adapter,
DeviceType deviceType,
Control *renderWindow,
CreateFlags behaviorFlags,
PresentParameters *presentationParameters __gc[]
);
JScript .NET public function Device(
adapter : int,
deviceType : DeviceType,
renderWindow : Control,
behaviorFlags : CreateFlags,
presentationParameters : PresentParameters[]
);

Parameters

adapter | System.Int32. Ordinal number that identifies which physical device the object represents. Device 0 is the default device. The highest value that can be used in this parameter is one less than the total number of physical devices.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumerated type that denotes the desired device type. If the desired device type is not available, the method fails.
renderWindow | System.Windows.Forms.Control. Pointer to an unmanaged (or non-Windows form) window handle.
behaviorFlags | Microsoft.DirectX.Direct3D.CreateFlags. Combination of one or more options that control device creation.
presentationParameters Microsoft.DirectX.Direct3D.PresentParameters[]. [in, out] Pointer to a PresentParameters object that describes the presentation parameters for the device to create. For Microsoft® Windows® 2000 and Microsoft® Windows® XP, the full-screen device display refresh rate is set in the following order.
  1. User-specified nonzero ForcedRefreshRate registry key, if supported by the device.
  2. Application-specified nonzero refresh rate value in the presentation parameter.
  3. Refresh rate of the latest desktop mode, if supported by the device.
  4. 75 hertz if supported by the device.
  5. 60 hertz if supported by the device.
  6. Device default.
By default, if a refresh rate is unsupported, the closest supported refresh rate below it is used. For example, if the application specifies 63 hertz, 60 hertz is used. No refresh rates below 57 hertz are supported.

Calling this method changes the value of several members of PresentParameters.
  • BackBufferCount, BackBufferWidth, and BackBufferHeight = 0 for windowed or full-screen mode.
  • BackBufferFormat = Unknown for windowed mode only. Full-screen mode must specify a format.
If AdapterGroupDevice is set, param_PresentParametersA_presentationParameters is an array. Regardless of the number of heads that exist, only one depth stencil surface is automatically created.

Remarks

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Device object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Device.Disposed
  • Microsoft.DirectX.Direct3D.Device.Disposing


Device.DrawIndexedPrimitives(PrimitiveType,Int32,Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DrawIndexedPrimitives Method

 Language:
Note: This documentation is preliminary and is subject to change.

Renders the specified geometric primitive, based on indexing into an array of vertices.

Definition

Visual Basic .NET Public Sub DrawIndexedPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal baseVertex As Integer, _
ByVal minVertexIndex As Integer, _
ByVal numVertices As Integer, _
ByVal startIndex As Integer, _
ByVal primCount As Integer _
)
C# public void DrawIndexedPrimitives(
PrimitiveType primitiveType,
int baseVertex,
int minVertexIndex,
int numVertices,
int startIndex,
int primCount
);
Managed C++ public: void DrawIndexedPrimitives(
PrimitiveType primitiveType,
int baseVertex,
int minVertexIndex,
int numVertices,
int startIndex,
int primCount
);
JScript .NET public function DrawIndexedPrimitives(
primitiveType : PrimitiveType,
baseVertex : int,
minVertexIndex : int,
numVertices : int,
startIndex : int,
primCount : int
);

Parameters

primitiveType | Microsoft.DirectX.Direct3D.PrimitiveType. Member of the PrimitiveType enumerated type that describes the type of primitive to render. The PointList constant is not supported with this method. See Remarks.
baseVertex | System.Int32. Offset from the start of the index buffer to the first vertex index.
minVertexIndex | System.Int32. Minimum vertex index for vertices used during the call.
numVertices | System.Int32. Number of vertices used during the call, starting from param_Int32_baseVertex + param_Int32_minVertexIndex.
startIndex | System.Int32. Location in the index array at which to start reading vertices.
primCount | System.Int32. Number of primitives to render. The number of vertices used is a function of the param_Int32_primCount and param_PrimitiveType_primitiveType. To determine the maximum number of primitives allowed, check the MaxPrimitiveCount member of the Caps structure.

Remarks

This method draws indexed primitives from the current set of data input streams.

The param_Int32_minVertexIndex parameter and all of the indices in the index stream are relative to the param_Int32_baseVertex.

The param_Int32_minVertexIndex and param_Int32_numVertices parameters specify the range of vertex indices used for each Device.DrawIndexedPrimitives call. These vertex indices are used to optimize vertex processing of indexed primitives by processing a sequential range of vertices prior to indexing into them. Indices used during this call cannot reference any vertices outside of this range.

If no index array is set, Device.DrawIndexedPrimitives fails.

The PointList member of the PrimitiveType enumerated type is not supported and is not a valid type for this method.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Device.DrawPrimitives
  • Device.SetStreamSource


Device.DrawIndexedUserPrimitives(PrimitiveType,Int32,Int32,Int32,Object,Boolean,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DrawIndexedUserPrimitives Method

 Language:
Note: This documentation is preliminary and is subject to change.

Renders the specified geometric primitive with data specified by a user memory pointer.

Definition

Visual Basic .NET Public Sub DrawIndexedUserPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal minVertexIndex As Integer, _
ByVal numVertexIndices As Integer, _
ByVal primitiveCount As Integer, _
ByVal indexData As Object, _
ByVal sixteenBitIndices As Boolean, _
ByVal vertexStreamZeroData As Object _
)
C# public void DrawIndexedUserPrimitives(
PrimitiveType primitiveType,
int minVertexIndex,
int numVertexIndices,
int primitiveCount,
object indexData,
bool sixteenBitIndices,
object vertexStreamZeroData
);
Managed C++ public: void DrawIndexedUserPrimitives(
PrimitiveType primitiveType,
int minVertexIndex,
int numVertexIndices,
int primitiveCount,
Object *indexData,
bool sixteenBitIndices,
Object *vertexStreamZeroData
);
JScript .NET public function DrawIndexedUserPrimitives(
primitiveType : PrimitiveType,
minVertexIndex : int,
numVertexIndices : int,
primitiveCount : int,
indexData : Object,
sixteenBitIndices : boolean,
vertexStreamZeroData : Object
);

Parameters

primitiveType | Microsoft.DirectX.Direct3D.PrimitiveType. Member of the PrimitiveType enumerated type that describes the type of primitive to render.
minVertexIndex | System.Int32. Minimum vertex index, relative to 0 (the start of param_Object_vertexStreamZeroData), for vertices used during the call.
numVertexIndices | System.Int32. Number of vertices used during the call, starting from param_Int32_minVertexIndex.
primitiveCount | System.Int32. Number of primitives to render. The number of indices used is a function of the primitive count and primitive type. To determine the maximum number of primitives allowed, check the MaxPrimitiveCount member of the Caps structure.
indexData | System.Object. User memory pointer to the index data.
sixteenBitIndices | System.Boolean. Set to true to indicate 16-bit indices. Set to false if to indicate 32-bit indices.
vertexStreamZeroData | System.Object. User memory pointer to the vertex data to use for vertex stream 0.

Remarks

This method is intended for use in applications that are unable to store their vertex data in vertex buffers.

It supports only a single vertex stream, which must be declared as stream 0.

Following any Device.DrawIndexedUserPrimitives call, the stream 0 settings referenced by Device.GetStreamSource are set to null. The index buffer setting for Indices also is set to null.

The vertex data passed to DrawIndexedUserPrimitives does not need to persist after the call. Microsoft® Direct3D® completes its access to that data prior to returning from the call.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Device.DrawIndexedPrimitives
  • Device.DrawPrimitives
  • Device.SetStreamSource


Device.DrawPrimitives(PrimitiveType,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DrawPrimitives Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Generate a Scene

Renders a sequence of non-indexed geometric primitives of the specified type from the current set of data input streams.

Definition

Visual Basic .NET Public Sub DrawPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal startVertex As Integer, _
ByVal primitiveCount As Integer _
)
C# public void DrawPrimitives(
PrimitiveType primitiveType,
int startVertex,
int primitiveCount
);
Managed C++ public: void DrawPrimitives(
PrimitiveType primitiveType,
int startVertex,
int primitiveCount
);
JScript .NET public function DrawPrimitives(
primitiveType : PrimitiveType,
startVertex : int,
primitiveCount : int
);

Parameters

primitiveType | Microsoft.DirectX.Direct3D.PrimitiveType. Member of the PrimitiveType enumerated type that describes the type of primitive to render.
startVertex | System.Int32. Index of the first vertex to load. Beginning at param_Int32_startVertex, the correct number of vertices is read out of the vertex buffer.
primitiveCount | System.Int32. Number of primitives to render. To determine the maximum number of primitives allowed, check Caps.MaxPrimitiveCount. The param_Int32_primitiveCount is the number of primitives as determined by the primitive type. If it is a line list, each primitive has two vertices. If it is a triangle list, each primitive has three vertices.

Remarks

Device.DrawPrimitives should not be called with a single triangle at a time.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • Device.DrawIndexedPrimitives
  • Device.SetStreamSource


Device.DrawRectanglePatch

Device.DrawRectanglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a rectangular patch using the currently set streams.

Overload List

public void DrawRectanglePatch(int, Plane);
public void DrawRectanglePatch(int, Plane, RectanglePatchInformation);
public void DrawRectanglePatch(int, Plane, RectanglePatchInformation);
public void DrawRectanglePatch(int, float[]);
public void DrawRectanglePatch(int, float[], RectanglePatchInformation);
public void DrawRectanglePatch(int, float[], RectanglePatchInformation);

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Plane,RectanglePatchInformation)

Device.DrawRectanglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
Managed C++ public: void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
JScript .NET public function DrawRectanglePatch(
handle : int,
numSegs : Plane,
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle | System.Int32. Handle to the rectangular patch to draw.
numSegs | Microsoft.DirectX.Plane. A Plane structure. The A, B, C and D fields identify the number of segments each edge of the rectangle patch should be divided into when tessellated.
rectPatchInformation | Microsoft.DirectX.Direct3D.RectanglePatchInformation.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Single[],RectanglePatchInformation)

Device.DrawRectanglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
float[] numSegs,
RectanglePatchInformation rectPatchInformation
);
Managed C++ public: void DrawRectanglePatch(
int handle,
float numSegs __gc[],
RectanglePatchInformation rectPatchInformation
);
JScript .NET public function DrawRectanglePatch(
handle : int,
numSegs : float[],
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle | System.Int32. Handle to the rectangular patch to draw.
numSegs | System.Single[]. Array of four floating-point values that identify the number of segments into which each edge of the rectangle patch should be divided when tessellated. For more information, see RectanglePatchInformation.
rectPatchInformation | Microsoft.DirectX.Direct3D.RectanglePatchInformation.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Plane,RectanglePatchInformation)

Device.DrawRectanglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
Managed C++ public: void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
JScript .NET public function DrawRectanglePatch(
handle : int,
numSegs : Plane,
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle | System.Int32. Handle to the rectangular patch to draw.
numSegs | Microsoft.DirectX.Plane. A Plane structure. The A, B, C and D fields identify the number of segments each edge of the rectangle patch should be divided into when tessellated.
rectPatchInformation | Microsoft.DirectX.Direct3D.RectanglePatchInformation. A pointer to a RectanglePatchInformation structure that describes the rectangular patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Single[],RectanglePatchInformation)

Device.DrawRectanglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
float[] numSegs,
RectanglePatchInformation rectPatchInformation
);
Managed C++ public: void DrawRectanglePatch(
int handle,
float numSegs __gc[],
RectanglePatchInformation rectPatchInformation
);
JScript .NET public function DrawRectanglePatch(
handle : int,
numSegs : float[],
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle | System.Int32. Handle to the rectangular patch to draw.
numSegs | System.Single[]. Array of four floating-point values that identify the number of segments into which each edge of the rectangle patch should be divided when tessellated. For more information, see RectanglePatchInformation.
rectPatchInformation | Microsoft.DirectX.Direct3D.RectanglePatchInformation. A pointer to a RectanglePatchInformation structure that describes the rectangular patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Plane)

Device.DrawRectanglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane _
)
C# public void DrawRectanglePatch(
int handle,
Plane numSegs
);
Managed C++ public: void DrawRectanglePatch(
int handle,
Plane numSegs
);
JScript .NET public function DrawRectanglePatch(
handle : int,
numSegs : Plane
);

Parameters

handle | System.Int32. Handle to the rectangular patch to draw.
numSegs | Microsoft.DirectX.Plane. A Plane structure. The A, B, C and D fields identify the number of segments each edge of the rectangle patch should be divided into when tessellated.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Single[])

Device.DrawRectanglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single _
)
C# public void DrawRectanglePatch(
int handle,
float[] numSegs
);
Managed C++ public: void DrawRectanglePatch(
int handle,
float numSegs __gc[]
);
JScript .NET public function DrawRectanglePatch(
handle : int,
numSegs : float[]
);

Parameters

handle | System.Int32. Handle to the rectangular patch to draw.
numSegs | System.Single[]. Array of four floating-point values that identify the number of segments into which each edge of the rectangle patch should be divided when tessellated. For more information, see RectanglePatchInformation.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch

Device.DrawTrianglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a triangular patch using the currently set streams.

Overload List

public void DrawTrianglePatch(int, Plane);
public void DrawTrianglePatch(int, Plane, TrianglePatchInformation);
public void DrawTrianglePatch(int, Plane, TrianglePatchInformation);
public void DrawTrianglePatch(int, float[]);
public void DrawTrianglePatch(int, float[], TrianglePatchInformation);
public void DrawTrianglePatch(int, float[], TrianglePatchInformation);

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Plane,TrianglePatchInformation)

Device.DrawTrianglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a triangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
Managed C++ public: void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
JScript .NET public function DrawTrianglePatch(
handle : int,
numSegs : Plane,
triPatchInformation : TrianglePatchInformation
);

Parameters

handle | System.Int32. Handle to the triangular patch to draw.
numSegs | Microsoft.DirectX.Plane. A Plane structure. The A, B, C, and D fields identify the number of segments into which each edge of the triangle patch should be divided when tessellated.
triPatchInformation | Microsoft.DirectX.Direct3D.TrianglePatchInformation. A TrianglePatchInformation structure that describes the triangular high-order patch to draw.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Single[],TrianglePatchInformation)

Device.DrawTrianglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a triangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
float[] numSegs,
TrianglePatchInformation triPatchInformation
);
Managed C++ public: void DrawTrianglePatch(
int handle,
float numSegs __gc[],
TrianglePatchInformation triPatchInformation
);
JScript .NET public function DrawTrianglePatch(
handle : int,
numSegs : float[],
triPatchInformation : TrianglePatchInformation
);

Parameters

handle | System.Int32. Handle to the triangular patch to draw.
numSegs | System.Single[]. Pointer to an array of three floating-point values that identify the number of segments each edge of the triangle patch should be divided into when tessellated. For more information, see TrianglePatchInformation.
triPatchInformation | Microsoft.DirectX.Direct3D.TrianglePatchInformation. A TrianglePatchInformation structure that describes the triangular high-order patch to draw.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Plane,TrianglePatchInformation)

Device.DrawTrianglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a triangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
Managed C++ public: void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
JScript .NET public function DrawTrianglePatch(
handle : int,
numSegs : Plane,
triPatchInformation : TrianglePatchInformation
);

Parameters

handle | System.Int32. Handle to the triangular patch to draw.
numSegs | Microsoft.DirectX.Plane. A Plane structure. The A, B, C, and D fields identify the number of segments into which each edge of the triangle patch should be divided when tessellated.
triPatchInformation | Microsoft.DirectX.Direct3D.TrianglePatchInformation. A pointer to a TrianglePatchInformation structure that describes the triangular high-order patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Single[],TrianglePatchInformation)

Device.DrawTrianglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a triangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
float[] numSegs,
TrianglePatchInformation triPatchInformation
);
Managed C++ public: void DrawTrianglePatch(
int handle,
float numSegs __gc[],
TrianglePatchInformation triPatchInformation
);
JScript .NET public function DrawTrianglePatch(
handle : int,
numSegs : float[],
triPatchInformation : TrianglePatchInformation
);

Parameters

handle | System.Int32. Handle to the triangular patch to draw.
numSegs | System.Single[]. Pointer to an array of three floating-point values that identify the number of segments each edge of the triangle patch should be divided into when tessellated. For more information, see TrianglePatchInformation.
triPatchInformation | Microsoft.DirectX.Direct3D.TrianglePatchInformation. A pointer to a TrianglePatchInformation structure that describes the triangular high-order patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Plane)

Device.DrawTrianglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a triangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane _
)
C# public void DrawTrianglePatch(
int handle,
Plane numSegs
);
Managed C++ public: void DrawTrianglePatch(
int handle,
Plane numSegs
);
JScript .NET public function DrawTrianglePatch(
handle : int,
numSegs : Plane
);

Parameters

handle | System.Int32. Handle to the triangular patch to draw.
numSegs | Microsoft.DirectX.Plane. A Plane structure. The A, B, C, and D fields identify the number of segments into which each edge of the triangle patch should be divided when tessellated.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Single[])

Device.DrawTrianglePatch Method

Note: This documentation is preliminary and is subject to change.

Draws a triangular patch using the currently set streams.

Definition

Visual Basic .NET Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single _
)
C# public void DrawTrianglePatch(
int handle,
float[] numSegs
);
Managed C++ public: void DrawTrianglePatch(
int handle,
float numSegs __gc[]
);
JScript .NET public function DrawTrianglePatch(
handle : int,
numSegs : float[]
);

Parameters

handle | System.Int32. Handle to the triangular patch to draw.
numSegs | System.Single[]. Pointer to an array of three floating-point values that identify the number of segments each edge of the triangle patch should be divided into when tessellated. For more information, see TrianglePatchInformation.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft® Direct3D® can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.DrawUserPrimitives(PrimitiveType,Int32,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DrawUserPrimitives Method

 Language:
Note: This documentation is preliminary and is subject to change.

Renders data specified by a user memory pointer as a sequence of geometric primitives of the specified type.

Definition

Visual Basic .NET Public Sub DrawUserPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal primitiveCount As Integer, _
ByVal vertexStreamZeroData As Object _
)
C# public void DrawUserPrimitives(
PrimitiveType primitiveType,
int primitiveCount,
object vertexStreamZeroData
);
Managed C++ public: void DrawUserPrimitives(
PrimitiveType primitiveType,
int primitiveCount,
Object *vertexStreamZeroData
);
JScript .NET public function DrawUserPrimitives(
primitiveType : PrimitiveType,
primitiveCount : int,
vertexStreamZeroData : Object
);

Parameters

primitiveType | Microsoft.DirectX.Direct3D.PrimitiveType. Member of the PrimitiveType enumerated type that describes the type of primitive to render.
primitiveCount | System.Int32. Number of primitives to render. To determine the maximum number of primitives allowed, check the Caps.MaxPrimitiveCount member.
vertexStreamZeroData | System.Object. User memory vertex data to use for vertex stream 0.

Remarks

This method is intended for use in applications that are unable to store their vertex data in vertex buffers. It supports only a single vertex stream, and uses the provided vertex data pointer and stride for vertex stream 0. It is invalid for the declaration of the current vertex shader to refer to vertex streams other than stream 0.

Following any Device.DrawUserPrimitives call, the stream 0 settings referenced by Device.GetStreamSource are set to null.

The vertex data passed to Device.DrawUserPrimitives does not need to persist after the call. Microsoft® Direct3D® completes its access to that data prior to returning from the call.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.EndScene()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.EndScene Method

 Language:
Note: This documentation is preliminary and is subject to change.

Ends a scene that was started by calling the Device.BeginScene method.

Definition

Visual Basic .NET | Public Sub EndScene()
C# | public void EndScene();
Managed C++ | public: void EndScene();
JScript .NET | public function EndScene();

Remarks

Every call to BeginScene should eventually be followed by a call to EndScene before the display is updated with Device.Present.

When EndScene succeeds, the scene is queued up for rendering by the driver. The method is not synchronous, so the scene is not guaranteed to have completed rendering when the method returns.

When scene rendering begins successfully, this method must be called before calling the Device.BeginScene method to start rendering another scene. If a prior call to Device.BeginScene fails, the scene did not begin and this method should not be called.

Exceptions
InvalidCallException The method failed because EndScene was called before BeginScene.


Device.EndStateBlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.EndStateBlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Signals Microsoft® Direct3D® to stop recording a device state block and retrieve a pointer to the state block interface.

Definition

Visual Basic .NET | Public Function EndStateBlock() As StateBlock
C# | public StateBlock EndStateBlock();
Managed C++ | public: StateBlock* EndStateBlock();
JScript .NET | public function EndStateBlock() : StateBlock;

Return Value

Microsoft.DirectX.Direct3D.StateBlock . State block object. For more information, see StateBlock.

Remarks

Exceptions
InvalidCallException The method call is invalid. This can occur if EndStateBlock is called without a corresponding BeginStateBlock.


Device.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Device.EvictManagedResources()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.EvictManagedResources Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evicts all managed resources, including Microsoft® Direct3D® resources and those that are driver-managed.

Definition

Visual Basic .NET | Public Sub EvictManagedResources()
C# | public void EvictManagedResources();
Managed C++ | public: void EvictManagedResources();
JScript .NET | public function EvictManagedResources();

Remarks

This method causes only the Default copy of resources to be evicted. The resource copy in system memory is retained. For more information, see Pool.

Exceptions
OutOfVideoMemoryException Microsoft® Direct3D® does not have enough display memory to perform the operation.


Device.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Device object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Device();
Managed C++ | ~Device();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Device.GetBackBuffer(Int32,Int32,BackBufferType)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetBackBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Save a Screenshot

Retrieves a back buffer from a device's swap chain.

Definition

Visual Basic .NET Public Function GetBackBuffer( _
ByVal swapChain As Integer, _
ByVal backBuffer As Integer, _
ByVal backBufferType As BackBufferType _
) As Surface
C# public Surface GetBackBuffer(
int swapChain,
int backBuffer,
BackBufferType backBufferType
);
Managed C++ public: Surface* GetBackBuffer(
int swapChain,
int backBuffer,
BackBufferType backBufferType
);
JScript .NET public function GetBackBuffer(
swapChain : int,
backBuffer : int,
backBufferType : BackBufferType
) : Surface;

Parameters

swapChain | System.Int32. Unsigned integer that specifies the swap chain.
backBuffer | System.Int32. Index of the back buffer object to return.
backBufferType | Microsoft.DirectX.Direct3D.BackBufferType. Stereo view is not supported in Microsoft® DirectX® 9.0, so the only valid value for this parameter is Mono.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface that represents the returned back buffer surface.

Remarks

Back buffers are numbered from 0 to the total number of back buffers - 1. A value of 0 returns the first back buffer, not the front buffer. The front buffer is not accessible through this method.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


Device.GetCubeTexture(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetCubeTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the cube texture assigned to a stage for a device.

Definition

Visual Basic .NET Public Function GetCubeTexture( _
ByVal stage As Integer _
) As CubeTexture
C# public CubeTexture GetCubeTexture(
int stage
);
Managed C++ public: CubeTexture* GetCubeTexture(
int stage
);
JScript .NET public function GetCubeTexture(
stage : int
) : CubeTexture;

Parameters

stage System.Int32. Stage identifier of the CubeTexture to retrieve. Stage identifiers are zero-based.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the returned CubeTexture.

Remarks

Exceptions
InvalidOperationException Leave Site The texture returned was not of type CubeTexture.


Device.GetFrontBufferData(Int32,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetFrontBufferData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a copy of a device's front buffer and places it in a system memory buffer provided by the application.

Definition

Visual Basic .NET Public Sub GetFrontBufferData( _
ByVal swapChain As Integer, _
ByVal buffer As Surface _
)
C# public void GetFrontBufferData(
int swapChain,
Surface buffer
);
Managed C++ public: void GetFrontBufferData(
int swapChain,
Surface *buffer
);
JScript .NET public function GetFrontBufferData(
swapChain : int,
buffer : Surface
);

Parameters

swapChain System.Int32. Unsigned integer that specifies the swap chain.
buffer Microsoft.DirectX.Direct3D.Surface. [in, out] A Surface class that receives a copy of the front buffer's contents. The data is returned in successive rows with no intervening space, proceeding from the highest vertical row on the device's output to the lowest.

For windowed mode, the size of the destination surface should be the desktop size. For full-screen mode, the size of the destination surface should be the screen size.

Remarks

The param_Surface_buffer parameter is filled with a representation of the front buffer, converted to the standard 32-bits-per-pixel format A8R8G8B8.

This method is the only way to capture an antialiased screen shot.

The method is slow by design, and therefore should not be used in a performance-critical path.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.


Device.GetGammaRamp(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetGammaRamp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the gamma correction ramp for the swap chain.

Definition

Visual Basic .NET Public Function GetGammaRamp( _
ByVal swapChain As Integer _
) As GammaRamp
C# public GammaRamp GetGammaRamp(
int swapChain
);
Managed C++ public: GammaRamp GetGammaRamp(
int swapChain
);
JScript .NET public function GetGammaRamp(
swapChain : int
) : GammaRamp;

Parameters

swapChain System.Int32. Unsigned integer that specifies the swap chain.

Return Value

Microsoft.DirectX.Direct3D.GammaRamp . [in, out] Application-supplied GammaRamp structure to fill with the gamma correction ramp.

See Also

  • SwapChain
  • Device.SetGammaRamp


Device.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Device.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DDevice9, which allows unmanaged COM clients to create an instance of the managed Device class. Not supported.


Device.GetPaletteEntries(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetPaletteEntries Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves palette entries.

Definition

Visual Basic .NET Public Function GetPaletteEntries( _
ByVal paletteNumber As Integer _
) As PaletteEntry()
C# public PaletteEntry[] GetPaletteEntries(
int paletteNumber
);
Managed C++ public: PaletteEntry GetPaletteEntries(
int paletteNumber
) __gc[];
JScript .NET public function GetPaletteEntries(
paletteNumber : int
) : PaletteEntry[];

Parameters

paletteNumber System.Int32. Ordinal value that identifies the palette to retrieve.

Return Value

Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry structure that represents the returned palette entries.

Remarks

For more information about PaletteEntry, see the Microsoft® Platform Software Development Kit (SDK).

In Microsoft DirectX® 9.0 and later, the Flags member of the PaletteEntry structure does not work as documented in the Platform SDK. The Flags member is now the alpha channel for 8-bit palletized formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.CurrentTexturePalette
  • Device.SetPaletteEntries


Device.GetPixelShaderBooleanConstant(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetPixelShaderBooleanConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a Boolean shader constant.

Definition

Visual Basic .NET Public Function GetPixelShaderBooleanConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Boolean()
C# public bool[] GetPixelShaderBooleanConstant(
int startRegister,
int constantCount
);
Managed C++ public: bool GetPixelShaderBooleanConstant(
int startRegister,
int constantCount
) __gc[];
JScript .NET public function GetPixelShaderBooleanConstant(
startRegister : int,
constantCount : int
) : boolean[];

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantCount | System.Int32. Number of Boolean values in the array of constants.

Return Value

System.Boolean[]. Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetPixelShaderConstant


Device.GetPixelShaderInt32Constant(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetPixelShaderInt32Constant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an integer shader constant.

Definition

Visual Basic .NET Public Function GetPixelShaderInt32Constant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Integer()
C# public int[] GetPixelShaderInt32Constant(
int startRegister,
int constantCount
);
Managed C++ public: int GetPixelShaderInt32Constant(
int startRegister,
int constantCount
) __gc[];
JScript .NET public function GetPixelShaderInt32Constant(
startRegister : int,
constantCount : int
) : int[];

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantCount | System.Int32. Number of four-integer vectors in the array of constants.

Return Value

System.Int32[]. Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetPixelShaderConstant


Device.GetPixelShaderSingleConstant(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetPixelShaderSingleConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a floating-point shader constant.

Definition

Visual Basic .NET Public Function GetPixelShaderSingleConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Single()
C# public float[] GetPixelShaderSingleConstant(
int startRegister,
int constantCount
);
Managed C++ public: float GetPixelShaderSingleConstant(
int startRegister,
int constantCount
) __gc[];
JScript .NET public function GetPixelShaderSingleConstant(
startRegister : int,
constantCount : int
) : float[];

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantCount | System.Int32. Number of four-float vectors in the array of constants.

Return Value

System.Single[]. Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetPixelShaderConstant


Device.GetRasterStatus(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetRasterStatus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns information that describes the raster of the monitor on which the swap chain is presented.

Definition

Visual Basic .NET Public Function GetRasterStatus( _
ByVal swapChain As Integer _
) As RasterStatus
C# public RasterStatus GetRasterStatus(
int swapChain
);
Managed C++ public: RasterStatus GetRasterStatus(
int swapChain
);
JScript .NET public function GetRasterStatus(
swapChain : int
) : RasterStatus;

Parameters

swapChain System.Int32. Unsigned integer that specifies the swap chain.

Return Value

Microsoft.DirectX.Direct3D.RasterStatus . A RasterStatus structure that contains information about the position or other status of the raster on the monitor driven by this adapter.

Remarks

This method does not return device state for a device created using PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException The device does not support reading the current scan line. To determine whether a device supports reading the scan line, check for the DriverCaps.ReadScanLine property in Caps.DriverCaps.


Device.GetRenderStateBoolean(RenderStates)

Device.GetRenderStateBoolean Method

Note: This documentation is preliminary and is subject to change.

Retrieves the Boolean value of a given render state.

Definition

Visual Basic .NET Public Function GetRenderStateBoolean( _
ByVal state As RenderStates _
) As Boolean
C# public bool GetRenderStateBoolean(
RenderStates state
);
Managed C++ public: bool GetRenderStateBoolean(
RenderStates state
);
JScript .NET public function GetRenderStateBoolean(
state : RenderStates
) : boolean;

Parameters

state Microsoft.DirectX.Direct3D.RenderStates. A member from the RenderStates enumeration that represents the render state value to retreive.

Return Value

System.Boolean . The render state value retrieved.

Remarks

Use this method to retrieve render states with Boolean values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetRenderStateInt32(RenderStates)

Device.GetRenderStateInt32 Method

Note: This documentation is preliminary and is subject to change.

Retrieves the integer value of a given render state.

Definition

Visual Basic .NET Public Function GetRenderStateInt32( _
ByVal state As RenderStates _
) As Integer
C# public int GetRenderStateInt32(
RenderStates state
);
Managed C++ public: int GetRenderStateInt32(
RenderStates state
);
JScript .NET public function GetRenderStateInt32(
state : RenderStates
) : int;

Parameters

state Microsoft.DirectX.Direct3D.RenderStates. A member from the RenderStates enumeration that represents the render state value to retreive.

Return Value

System.Int32 . The render state value retrieved.

Remarks

Use this method to retrieve render states with integer values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetRenderStateSingle(RenderStates)

Device.GetRenderStateSingle Method

Note: This documentation is preliminary and is subject to change.

Retrieves the floating-point value of a given render state.

Definition

Visual Basic .NET Public Function GetRenderStateSingle( _
ByVal state As RenderStates _
) As Single
C# public float GetRenderStateSingle(
RenderStates state
);
Managed C++ public: float GetRenderStateSingle(
RenderStates state
);
JScript .NET public function GetRenderStateSingle(
state : RenderStates
) : float;

Parameters

state Microsoft.DirectX.Direct3D.RenderStates. A member from the RenderStates enumeration that represents the render state value to retreive.

Return Value

System.Single . The render state value retrieved.

Remarks

Use this method to retrieve render states with floating-point values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetRenderTarget(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetRenderTarget Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a render target surface.

Definition

Visual Basic .NET Public Function GetRenderTarget( _
ByVal renderTargetIndex As Integer _
) As Surface
C# public Surface GetRenderTarget(
int renderTargetIndex
);
Managed C++ public: Surface* GetRenderTarget(
int renderTargetIndex
);
JScript .NET public function GetRenderTarget(
renderTargetIndex : int
) : Surface;

Parameters

renderTargetIndex System.Int32. Index of the render target. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface that represents the returned render target surface for the current device.

Remarks

Typically, methods that return state do not work on devices created using PureDevice. This method, however, is an exception because it returns an interface.

The device can support multiple render targets. The number of render targets supported by a device is contained in the Caps.NumberSimultaneousRts member.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | No render target is available for the given index.

See Also

  • SetRenderTarget


Device.GetRenderTargetData(Surface,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetRenderTargetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies the render target data from device memory to system memory.

Definition

Visual Basic .NET Public Sub GetRenderTargetData( _
ByVal renderTarget As Surface, _
ByVal destSurface As Surface _
)
C# public void GetRenderTargetData(
Surface renderTarget,
Surface destSurface
);
Managed C++ public: void GetRenderTargetData(
Surface *renderTarget,
Surface *destSurface
);
JScript .NET public function GetRenderTargetData(
renderTarget : Surface,
destSurface : Surface
);

Parameters

renderTarget | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents a render target.
destSurface | Microsoft.DirectX.Direct3D.Surface. [in, out] A Surface object that represents a destination surface.

Remarks

The destination surface must be either an off-screen plain surface or a level of a texture (either mipmap or cube) created with SystemMemory.

The source surface must be a regular render target or a level of a render target texture (either mipmap or cube) created with Default.

This method will fail if:

  • The render target is multisampled.
  • The source render target is of a different size than the destination surface.
  • The source render target and destination surface formats do not match.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.GetSamplerStageStateBoolean(Int32,SamplerStageStates)

Device.GetSamplerStageStateBoolean Method

Note: This documentation is preliminary and is subject to change.

Retrieves the Boolean value of a given sampler stage state.

Definition

Visual Basic .NET Public Function GetSamplerStageStateBoolean( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates _
) As Boolean
C# public bool GetSamplerStageStateBoolean(
int stage,
SamplerStageStates state
);
Managed C++ public: bool GetSamplerStageStateBoolean(
int stage,
SamplerStageStates state
);
JScript .NET public function GetSamplerStageStateBoolean(
stage : int,
state : SamplerStageStates
) : boolean;

Parameters

stage | System.Int32. Index value of the sampler stage to retrieve.
state | Microsoft.DirectX.Direct3D.SamplerStageStates. A member from the SamplerStageStates enumeration that represents the sampler stage state value to retreive.

Return Value

System.Boolean . The sampler stage state value retrieved.

Remarks

Use this method to retrieve sampler stage states with Boolean values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetSamplerStageStateInt32(Int32,SamplerStageStates)

Device.GetSamplerStageStateInt32 Method

Note: This documentation is preliminary and is subject to change.

Retrieves the integer value of a given sampler stage state.

Definition

Visual Basic .NET Public Function GetSamplerStageStateInt32( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates _
) As Integer
C# public int GetSamplerStageStateInt32(
int stage,
SamplerStageStates state
);
Managed C++ public: int GetSamplerStageStateInt32(
int stage,
SamplerStageStates state
);
JScript .NET public function GetSamplerStageStateInt32(
stage : int,
state : SamplerStageStates
) : int;

Parameters

stage | System.Int32. Index value of the sampler stage to retrieve.
state | Microsoft.DirectX.Direct3D.SamplerStageStates. A member from the SamplerStageStates enumeration that represents the sampler stage state value to retreive.

Return Value

System.Int32 . The sampler stage state value retrieved.

Remarks

Use this method to retrieve sampler stage states with integer values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetSamplerStageStateSingle(Int32,SamplerStageStates)

Device.GetSamplerStageStateSingle Method

Note: This documentation is preliminary and is subject to change.

Retrieves the floating-point value of a given sampler stage state.

Definition

Visual Basic .NET Public Function GetSamplerStageStateSingle( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates _
) As Single
C# public float GetSamplerStageStateSingle(
int stage,
SamplerStageStates state
);
Managed C++ public: float GetSamplerStageStateSingle(
int stage,
SamplerStageStates state
);
JScript .NET public function GetSamplerStageStateSingle(
stage : int,
state : SamplerStageStates
) : float;

Parameters

stage | System.Int32. Index value of the sampler stage to retrieve.
state | Microsoft.DirectX.Direct3D.SamplerStageStates. A member from the SamplerStageStates enumeration that represents the sampler stage state value to retreive.

Return Value

System.Single . The sampler stage state value retrieved.

Remarks

Use this method to retrieve sampler stage states with floating-point values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetStreamSource(Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetStreamSource Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a vertex buffer bound to the specified data stream.

Definition

Visual Basic .NET Public Function GetStreamSource( _
ByVal streamNumber As Integer, _
ByRef offsetInBytes As Integer, _
ByRef stride As Integer _
) As VertexBuffer
C# public VertexBuffer GetStreamSource(
int streamNumber,
out int offsetInBytes,
out int stride
);
Managed C++ public: VertexBuffer* GetStreamSource(
int streamNumber,
int *offsetInBytes,
int *stride
);
JScript .NET public function GetStreamSource(
streamNumber : int,
offsetInBytes : int,
stride : int
) : VertexBuffer;

Parameters

streamNumber | System.Int32. Number of the data stream, in the range of 0 to the maximum number of streams -1.
offsetInBytes | System.Int32. Offset from the beginning of the stream to the beginning of the vertex data, in bytes. See Remarks.
stride | System.Int32. Pointer to a returned stride of the component, in bytes. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.VertexBuffer . A VertexBuffer class that represents the returned vertex buffer bound to the specified data stream.

Remarks

A stream is a uniform array of component data in which each component consists of one or more elements that represent a single entity such as position, normal, or color.

When a flexible vertex format (FVF) vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the FVF. When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetStreamSource


Device.GetStreamSourceFrequency(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetStreamSourceFrequency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the stream source frequency divider value.

Definition

Visual Basic .NET Public Function GetStreamSourceFrequency( _
ByVal streamNumber As Integer _
) As Integer
C# public int GetStreamSourceFrequency(
int streamNumber
);
Managed C++ public: int GetStreamSourceFrequency(
int streamNumber
);
JScript .NET public function GetStreamSourceFrequency(
streamNumber : int
) : int;

Parameters

streamNumber System.Int32. Stream source number.

Return Value

System.Int32 . Frequency divider value.

Remarks

Vertex shaders can be invoked more than once per vertex.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetStreamSourceFrequency


Device.GetSwapChain(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetSwapChain Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a reference to a swap chain.

Definition

Visual Basic .NET Public Function GetSwapChain( _
ByVal swapChain As Integer _
) As SwapChain
C# public SwapChain GetSwapChain(
int swapChain
);
Managed C++ public: SwapChain* GetSwapChain(
int swapChain
);
JScript .NET public function GetSwapChain(
swapChain : int
) : SwapChain;

Parameters

swapChain System.Int32. Swap chain ordinal value. For more information, see Caps.NumberOfAdaptersInGroup.

Return Value

Microsoft.DirectX.Direct3D.SwapChain . A SwapChain class that receives a copy of the swap chain.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.GetTexture(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a texture assigned to a stage for a device.

Definition

Visual Basic .NET Public Function GetTexture( _
ByVal stage As Integer _
) As Texture
C# public Texture GetTexture(
int stage
);
Managed C++ public: Texture* GetTexture(
int stage
);
JScript .NET public function GetTexture(
stage : int
) : Texture;

Parameters

stage System.Int32. Stage identifier of the texture to retrieve. Stage identifiers are zero-based.

Return Value

Microsoft.DirectX.Direct3D.Texture . A BaseTexture object that represents the returned texture.

Remarks

Typically, methods that return state do not work on devices created using PureDevice. This method, however, is an exception.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetTexture
  • Device.TextureState


Device.GetTextureStageStateBoolean(Int32,TextureStageStates)

Device.GetTextureStageStateBoolean Method

Note: This documentation is preliminary and is subject to change.

Retrieves the Boolean value of a given texture stage state.

Definition

Visual Basic .NET Public Function GetTextureStageStateBoolean( _
ByVal stage As Integer, _
ByVal state As TextureStageStates _
) As Boolean
C# public bool GetTextureStageStateBoolean(
int stage,
TextureStageStates state
);
Managed C++ public: bool GetTextureStageStateBoolean(
int stage,
TextureStageStates state
);
JScript .NET public function GetTextureStageStateBoolean(
stage : int,
state : TextureStageStates
) : boolean;

Parameters

stage | System.Int32. Index value of the texture stage to retrieve.
state | Microsoft.DirectX.Direct3D.TextureStageStates. A member from the TextureStageStates enumeration that represents the texture stage state value to retreive.

Return Value

System.Boolean . The texture stage state value retrieved.

Remarks

Use this method to retrieve texture stage states with Boolean values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetTextureStageStateInt32(Int32,TextureStageStates)

Device.GetTextureStageStateInt32 Method

Note: This documentation is preliminary and is subject to change.

Retrieves the integer value of a given texture stage state.

Definition

Visual Basic .NET Public Function GetTextureStageStateInt32( _
ByVal stage As Integer, _
ByVal state As TextureStageStates _
) As Integer
C# public int GetTextureStageStateInt32(
int stage,
TextureStageStates state
);
Managed C++ public: int GetTextureStageStateInt32(
int stage,
TextureStageStates state
);
JScript .NET public function GetTextureStageStateInt32(
stage : int,
state : TextureStageStates
) : int;

Parameters

stage | System.Int32. Index value of the texture stage to retrieve.
state | Microsoft.DirectX.Direct3D.TextureStageStates. A member from the TextureStageStates enumeration that represents the texture stage state value to retreive.

Return Value

System.Int32 . The texture stage state value retrieved.

Remarks

Use this method to retrieve texture stage states with integer values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetTextureStageStateSingle(Int32,TextureStageStates)

Device.GetTextureStageStateSingle Method

Note: This documentation is preliminary and is subject to change.

Retrieves the floating-point value of a given texture stage state.

Definition

Visual Basic .NET Public Function GetTextureStageStateSingle( _
ByVal stage As Integer, _
ByVal state As TextureStageStates _
) As Single
C# public float GetTextureStageStateSingle(
int stage,
TextureStageStates state
);
Managed C++ public: float GetTextureStageStateSingle(
int stage,
TextureStageStates state
);
JScript .NET public function GetTextureStageStateSingle(
stage : int,
state : TextureStageStates
) : float;

Parameters

stage | System.Int32. Index value of the texture stage to retrieve.
state | Microsoft.DirectX.Direct3D.TextureStageStates. A member from the TextureStageStates enumeration that represents the texture stage state value to retreive.

Return Value

System.Single . The texture stage state value retrieved.

Remarks

Use this method to retrieve texture stage states with floating-point values.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.GetTransform(TransformType)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetTransform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a matrix that describes a transformation state.

Definition

Visual Basic .NET Public Function GetTransform( _
ByVal state As TransformType _
) As Matrix
C# public Matrix GetTransform(
TransformType state
);
Managed C++ public: Matrix GetTransform(
TransformType state
);
JScript .NET public function GetTransform(
state : TransformType
) : Matrix;

Parameters

state Microsoft.DirectX.Direct3D.TransformType. Transform that is being retrieved. This parameter can be any member of the TransformType enumerated type.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that describes the returned transformation state.

Remarks

This method does not return device state for devices created using PureDevice. To use this method, create a device with any of the other flag values in CreateFlags.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetTransform


Device.GetVertexShaderBooleanConstant(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetVertexShaderBooleanConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a Boolean vertex shader constant.

Definition

Visual Basic .NET Public Function GetVertexShaderBooleanConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Boolean()
C# public bool[] GetVertexShaderBooleanConstant(
int startRegister,
int constantCount
);
Managed C++ public: bool GetVertexShaderBooleanConstant(
int startRegister,
int constantCount
) __gc[];
JScript .NET public function GetVertexShaderBooleanConstant(
startRegister : int,
constantCount : int
) : boolean[];

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantCount | System.Int32. Number of Boolean values in the array of constants.

Return Value

System.Boolean[]. Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetVertexShaderConstantBoolean


Device.GetVertexShaderInt32Constant(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetVertexShaderInt32Constant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an integer vertex shader constant.

Definition

Visual Basic .NET Public Function GetVertexShaderInt32Constant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Integer()
C# public int[] GetVertexShaderInt32Constant(
int startRegister,
int constantCount
);
Managed C++ public: int GetVertexShaderInt32Constant(
int startRegister,
int constantCount
) __gc[];
JScript .NET public function GetVertexShaderInt32Constant(
startRegister : int,
constantCount : int
) : int[];

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantCount | System.Int32. Number of four-integer vectors in the array of constants.

Return Value

System.Int32[]. Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetVertexShaderConstantInt32


Device.GetVertexShaderSingleConstant(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetVertexShaderSingleConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a floating-point vertex shader constant.

Definition

Visual Basic .NET Public Function GetVertexShaderSingleConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Single()
C# public float[] GetVertexShaderSingleConstant(
int startRegister,
int constantCount
);
Managed C++ public: float GetVertexShaderSingleConstant(
int startRegister,
int constantCount
) __gc[];
JScript .NET public function GetVertexShaderSingleConstant(
startRegister : int,
constantCount : int
) : float[];

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantCount | System.Int32. Number of four-float vectors in the array of constants.

Return Value

System.Single[]. Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetVertexShaderConstantSingle


Device.GetVolumeTexture(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetVolumeTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the volume texture assigned to a stage for a device.

Definition

Visual Basic .NET Public Function GetVolumeTexture( _
ByVal stage As Integer _
) As VolumeTexture
C# public VolumeTexture GetVolumeTexture(
int stage
);
Managed C++ public: VolumeTexture* GetVolumeTexture(
int stage
);
JScript .NET public function GetVolumeTexture(
stage : int
) : VolumeTexture;

Parameters

stage System.Int32. Stage identifier of the VolumeTexture to retrieve. Stage identifiers are zero-based.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . A VolumeTexture object that represents the returned VolumeTexture.

Remarks

Exceptions
InvalidOperationException Leave Site The texture returned was not of type VolumeTexture.


Device.MultiplyTransform(TransformType,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.MultiplyTransform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies a device's world, view, or projection matrices by a specified matrix.

Definition

Visual Basic .NET Public Sub MultiplyTransform( _
ByVal state As TransformType, _
ByVal matrix As Matrix _
)
C# public void MultiplyTransform(
TransformType state,
Matrix matrix
);
Managed C++ public: void MultiplyTransform(
TransformType state,
Matrix matrix
);
JScript .NET public function MultiplyTransform(
state : TransformType,
matrix : Matrix
);

Parameters

state | Microsoft.DirectX.Direct3D.TransformType. Member of the TransformType enumerated type that identifies which device matrix to modify. The most common setting, World, modifies the world matrix, but the view or projection matrices also can be modified.
matrix | Microsoft.DirectX.Matrix. A Matrix structure that modifies the current transformation.

Remarks

The multiplication order is param_Matrix_matrix x param_TransformType_state.

An application might use the Device.MultiplyTransform method to work with hierarchies of transformations. For example, the geometry and transformations describing an arm might be arranged in the following hierarchy.

shoulder_transformation
    upper_arm geometry
    elbow transformation
        lower_arm geometry
        wrist transformation
            hand geometry

An application might use the following series of calls to render this hierarchy. Not all the parameters are shown in this C# pseudocode.

[C#]
Device.SetTransform(TransformType.World, shoulder_transform);
Device.DrawPrimitive(upper_arm);
Device.MultiplyTransform(TransformType.World, elbow_transform);
Device.DrawPrimitive(lower_arm);
Device.MultiplyTransform(TransformType.World, wrist_transform);
Device.DrawPrimitive(hand);

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.op_Equality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
Managed C++ public: static bool op_Equality(
Device *left,
Device *right
);
JScript .NET public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Device. The Device object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Device. The Device object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Device.op_Inequality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
Managed C++ public: static bool op_Inequality(
Device *left,
Device *right
);
JScript .NET public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Device. The Device object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Device. The Device object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Device.Present

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Overload List

public void Present();
public void Present(Control);
public void Present(IntPtr);
public void Present(Rectangle, bool);
public void Present(Rectangle, Control, bool);
public void Present(Rectangle, IntPtr, bool);
public void Present(Rectangle, Rectangle, Control);
public void Present(Rectangle, Rectangle, IntPtr);

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,IntPtr,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
overrideWindowHandle : IntPtr,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. The Rectangle Leave Site to present.
overrideWindowHandle | System.IntPtr. Destination window whose client area is taken as the target for this presentation. If this parameter is not used, PresentParameters.DeviceWindow is taken.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET Public Sub Present( _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
IntPtr overrideWindowHandle
);
Managed C++ public: void Present(
IntPtr overrideWindowHandle
);
JScript .NET public function Present(
overrideWindowHandle : IntPtr
);

Parameters

overrideWindowHandle System.IntPtr. Destination window whose client area is taken as the target for this presentation. If this parameter is not used, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Rectangle,IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
Managed C++ public: void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
JScript .NET public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindowHandle : IntPtr
);

Parameters

sourceRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the source rectangle. If the rectangle exceeds the source surface, it is clipped to the source surface. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the destination rectangle. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
overrideWindowHandle | System.IntPtr. Destination window whose client area is taken as the target for this presentation. If this parameter is not used, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. The Rectangle Leave Site to present.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Control,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindow As Control, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Control overrideWindow,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
Control *overrideWindow,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
overrideWindow : Control,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. The Rectangle Leave Site to present.
overrideWindow | System.Windows.Forms.Control. Pointer to a destination window whose client area is taken as the target for this presentation. If this parameter is omitted, PresentParameters.DeviceWindow is taken.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Control)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET Public Sub Present( _
ByVal overrideWindow As Control _
)
C# public void Present(
Control overrideWindow
);
Managed C++ public: void Present(
Control *overrideWindow
);
JScript .NET public function Present(
overrideWindow : Control
);

Parameters

overrideWindow System.Windows.Forms.Control. Pointer to a destination window whose client area is taken as the target for this presentation. If this parameter is omitted, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET | Public Sub Present()
C# | public void Present();
Managed C++ | public: void Present();
JScript .NET | public function Present();

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Rectangle,Control)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic .NET Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindow As Control _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control overrideWindow
);
Managed C++ public: void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control *overrideWindow
);
JScript .NET public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindow : Control
);

Parameters

sourceRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the source rectangle. If the rectangle exceeds the source surface, it is clipped to the source surface. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the destination rectangle. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
overrideWindow | System.Windows.Forms.Control. Pointer to a destination window whose client area is taken as the target for this presentation. If this parameter is omitted, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.ProcessVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ProcessVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.

Overload List

public void ProcessVertices(int, int, int, VertexBuffer, VertexDeclaration);
public void ProcessVertices(int, int, int, VertexBuffer, VertexDeclaration, bool);

Remarks

The order of operations for this method is as follows.

  • Transform vertices to projection space using the world + view + projection matrix.
  • Compute screen coordinates using viewport settings.
  • If clipping is enabled, compute clipping codes and store them in an internal buffer that is associated with the destination vertex buffer. If a vertex is inside of the viewing frustum, its screen coordinates are computed. If the vertex is outside of the viewing frustum, it is stored in the destination vertex buffer in projection space coordinates.

Note that the user does not have access to the internal clip code buffer. No clipping is done on triangles or any other primitives.

The destination vertex buffer, param_VertexBuffer_destBuffer, must be created with a nonzero flexible vertex format parameter. The flexible vertex format (FVF) code specified during the call to the VertexBuffer constructor method specifies the vertex elements present in the destination vertex buffer.

When Microsoft® Direct3D® generates texture coordinates or copies or transforms input texture coordinates, and the output texture coordinate format defines more texture coordinate components than Direct3D generates, Direct3D does not change the extra components.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.ProcessVertices(Int32,Int32,Int32,VertexBuffer,VertexDeclaration)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ProcessVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.

Definition

Visual Basic .NET Public Sub ProcessVertices( _
ByVal srcStartIndex As Integer, _
ByVal destIndex As Integer, _
ByVal vertexCount As Integer, _
ByVal destBuffer As VertexBuffer, _
ByVal vertexDeclaration As VertexDeclaration _
)
C# public void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer destBuffer,
VertexDeclaration vertexDeclaration
);
Managed C++ public: void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer *destBuffer,
VertexDeclaration *vertexDeclaration
);
JScript .NET public function ProcessVertices(
srcStartIndex : int,
destIndex : int,
vertexCount : int,
destBuffer : VertexBuffer,
vertexDeclaration : VertexDeclaration
);

Parameters

srcStartIndex | System.Int32. Index of first vertex to load.
destIndex | System.Int32. Index of first vertex in the destination vertex buffer into which the results are placed.
vertexCount | System.Int32. Number of vertices to process.
destBuffer | Microsoft.DirectX.Direct3D.VertexBuffer. A VertexBuffer class; the destination vertex buffer that represents the stream of interleaved vertex data.
vertexDeclaration | Microsoft.DirectX.Direct3D.VertexDeclaration. A VertexDeclaration class that represents the output vertex data declaration. When vertex shader 3.0 or later is set as the current vertex shader, the output vertex declaration must be present.

Remarks

The order of operations for this method is as follows.

  • Transform vertices to projection space using the world + view + projection matrix.
  • Compute screen coordinates using viewport settings.
  • If clipping is enabled, compute clipping codes and store them in an internal buffer that is associated with the destination vertex buffer. If a vertex is inside of the viewing frustum, its screen coordinates are computed. If the vertex is outside of the viewing frustum, it is stored in the destination vertex buffer in projection space coordinates.

Note that the user does not have access to the internal clip code buffer. No clipping is done on triangles or any other primitives.

The destination vertex buffer, param_VertexBuffer_destBuffer, must be created with a nonzero flexible vertex format parameter. The flexible vertex format (FVF) code specified during the call to the VertexBuffer constructor method specifies the vertex elements present in the destination vertex buffer.

When Microsoft® Direct3D® generates texture coordinates or copies or transforms input texture coordinates, and the output texture coordinate format defines more texture coordinate components than Direct3D generates, Direct3D does not change the extra components.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.ProcessVertices(Int32,Int32,Int32,VertexBuffer,VertexDeclaration,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ProcessVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.

Definition

Visual Basic .NET Public Sub ProcessVertices( _
ByVal srcStartIndex As Integer, _
ByVal destIndex As Integer, _
ByVal vertexCount As Integer, _
ByVal destBuffer As VertexBuffer, _
ByVal vertexDeclaration As VertexDeclaration, _
ByVal copyData As Boolean _
)
C# public void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer destBuffer,
VertexDeclaration vertexDeclaration,
bool copyData
);
Managed C++ public: void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer *destBuffer,
VertexDeclaration *vertexDeclaration,
bool copyData
);
JScript .NET public function ProcessVertices(
srcStartIndex : int,
destIndex : int,
vertexCount : int,
destBuffer : VertexBuffer,
vertexDeclaration : VertexDeclaration,
copyData : boolean
);

Parameters

srcStartIndex | System.Int32. Index of first vertex to load.
destIndex | System.Int32. Index of first vertex in the destination vertex buffer into which the results are placed.
vertexCount | System.Int32. Number of vertices to process.
destBuffer | Microsoft.DirectX.Direct3D.VertexBuffer. A VertexBuffer class; the destination vertex buffer that represents the stream of interleaved vertex data.
vertexDeclaration | Microsoft.DirectX.Direct3D.VertexDeclaration. A VertexDeclaration class that represents the output vertex data declaration. When vertex shader 3.0 or later is set as the current vertex shader, the output vertex declaration must be present.
copyData | System.Boolean. Set to true for default processing. Set to false to prevent the system from copying vertex data not affected by the vertex operation into the destination buffer.

Remarks

The order of operations for this method is as follows.

  • Transform vertices to projection space using the world + view + projection matrix.
  • Compute screen coordinates using viewport settings.
  • If clipping is enabled, compute clipping codes and store them in an internal buffer that is associated with the destination vertex buffer. If a vertex is inside of the viewing frustum, its screen coordinates are computed. If the vertex is outside of the viewing frustum, it is stored in the destination vertex buffer in projection space coordinates.

Note that the user does not have access to the internal clip code buffer. No clipping is done on triangles or any other primitives.

The destination vertex buffer, param_VertexBuffer_destBuffer, must be created with a nonzero flexible vertex format parameter. The flexible vertex format (FVF) code specified during the call to the VertexBuffer constructor method specifies the vertex elements present in the destination vertex buffer.

When Microsoft® Direct3D® generates texture coordinates or copies or transforms input texture coordinates, and the output texture coordinate format defines more texture coordinate components than Direct3D generates, Direct3D does not change the extra components.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.raise_DeviceLost(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.raise_DeviceLost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Device.DeviceLost event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_DeviceLost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_DeviceLost(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_DeviceLost(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_DeviceLost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Device.raise_DeviceReset(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.raise_DeviceReset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Device.DeviceReset event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_DeviceReset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_DeviceReset(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_DeviceReset(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_DeviceReset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Device.raise_DeviceResizing(Object,CancelEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.raise_DeviceResizing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Device.DeviceResizing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_DeviceResizing( _
ByVal i1 As Object, _
ByVal i2 As CancelEventArgs _
)
C# protected void raise_DeviceResizing(
object i1,
CancelEventArgs i2
);
Managed C++ protected: void raise_DeviceResizing(
Object *i1,
CancelEventArgs *i2
);
JScript .NET protected function raise_DeviceResizing(
i1 : Object,
i2 : CancelEventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.ComponentModel.CancelEventArgs.


Device.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Device.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Device.Reset(PresentParameters[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the presentation parameters for the current device.

Definition

Visual Basic .NET Public Sub Reset( _
ByVal presentationParameters() As PresentParameters _
)
C# public void Reset(
PresentParameters[] presentationParameters
);
Managed C++ public: void Reset(
PresentParameters *presentationParameters __gc[]
);
JScript .NET public function Reset(
presentationParameters : PresentParameters[]
);

Parameters

presentationParameters Microsoft.DirectX.Direct3D.PresentParameters[]. [in, out] A PresentParameters structure that describes the new presentation parameters. This value cannot be null.

Remarks

When switching to full-screen mode, Microsoft® Direct3D® tries to find a desktop format that matches the back buffer format, so that back and front buffer formats are identical. This eliminates the need for color conversion.

If a call to Device.Reset fails, the device is placed in the "lost" state (as indicated by a return value of false from a call to CheckCooperativeLevel) unless it is already in the "not reset" state (as indicated by a ResultCode.DeviceNotReset returned from the param_Int32R_result parameter of the Device.CheckCooperativeLevel method). For more information about the use of Reset in the context of lost devices, see CheckCooperativeLevel.

Calling Device.Reset causes all texture memory surfaces and state information to be lost, and managed textures to be flushed from video memory. Before calling Device.Reset for a device, an application should release any explicit render targets, depth stencil surfaces, additional swap chains, state blocks, and Default resources associated with the device.

Swap chains are either full-screen or windowed. If the new swap chain is full-screen, the adapter is placed in the display mode that matches the new size.

Microsoft DirectX® 9.0 applications can expect messages to be sent to them during this call (for example, before the call is returned); applications should take precautions not to call into Direct3D at this time. In addition, when Device.Reset fails, the only valid methods that can be called are Device.Reset, Device.CheckCooperativeLevel, Device.TestCooperativeLevel, and the various Release member functions. Calling any other method can result in an exception.

A call to Device.Reset fails if made on a different thread than the one used to create the device being reset.

Pixel shaders and vertex shaders survive Device.Reset calls for DirectX 9.0. They do not need to be re-created explicitly by the application.

Unknown can be specified for the windowed mode back buffer format when calling Device.Device, Device.Reset, and SwapChain. This means the application does not have to query the current desktop format before calling Device.Device for windowed mode. For full-screen mode, the back buffer format must be specified. Setting PresentParameters.BackBufferCount = 0 results in the creation of one back buffer.

When trying to reset more than one display adapter in a group, pass in an array of PresentParameters objects, one for each display in the adapter group.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Device.Present
  • SwapEffect


Device.SetCursor(Cursor,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetCursor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the current cursor.

Definition

Visual Basic .NET Public Sub SetCursor( _
ByVal cursor As Cursor, _
ByVal addWaterMark As Boolean _
)
C# public void SetCursor(
Cursor cursor,
bool addWaterMark
);
Managed C++ public: void SetCursor(
Cursor *cursor,
bool addWaterMark
);
JScript .NET public function SetCursor(
cursor : Cursor,
addWaterMark : boolean
);

Parameters

cursor | System.Windows.Forms.Cursor. Handle to the cursor.
addWaterMark | System.Boolean. Set to true to add small grey characters that read "D3D" to the upper-left corner of the cursor image.

See Also

  • Device.SetCursorPosition
  • Device.SetCursorProperties


Device.SetCursorPosition(Int32,Int32,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetCursorPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the cursor position and update options.

Definition

Visual Basic .NET Public Sub SetCursorPosition( _
ByVal positionX As Integer, _
ByVal positionY As Integer, _
ByVal updateImmediate As Boolean _
)
C# public void SetCursorPosition(
int positionX,
int positionY,
bool updateImmediate
);
Managed C++ public: void SetCursorPosition(
int positionX,
int positionY,
bool updateImmediate
);
JScript .NET public function SetCursorPosition(
positionX : int,
positionY : int,
updateImmediate : boolean
);

Parameters

positionX | System.Int32. New X-position of the cursor in virtual desktop coordinates. See Remarks.
positionY | System.Int32. New Y-position of the cursor in virtual desktop coordinates. See Remarks.
updateImmediate System.Boolean. Set to true if the system guarantees that the cursor is updated at a minimum of half of the display refresh rate, but never more frequently than the display refresh rate. Set to false if the method delays cursor updates until the next Device.Present call.

Setting this parameter to false usually results in better performance. However, applications should use true if the rate of calls to Present is low enough that users would notice a significant delay in cursor motion. This flag has no effect in an application in windowed mode. Some video cards implement hardware color cursors; this flag does not affect these cards.

Remarks

When running in full-screen mode, screen space coordinates are the back buffer coordinates appropriately scaled to the current display mode. When running in windowed mode, screen space coordinates are the desktop coordinates. The cursor image is drawn at the specified position minus the hot spot offset specified by Device.SetCursorProperties.

If the cursor is hidden by Device.ShowCursor, it is not drawn.

See Also

  • Device.SetCursor


Device.SetCursorProperties(Int32,Int32,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetCursorProperties Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets properties for the cursor.

Definition

Visual Basic .NET Public Sub SetCursorProperties( _
ByVal hotSpotX As Integer, _
ByVal hotSpotY As Integer, _
ByVal cursorBitmap As Surface _
)
C# public void SetCursorProperties(
int hotSpotX,
int hotSpotY,
Surface cursorBitmap
);
Managed C++ public: void SetCursorProperties(
int hotSpotX,
int hotSpotY,
Surface *cursorBitmap
);
JScript .NET public function SetCursorProperties(
hotSpotX : int,
hotSpotY : int,
cursorBitmap : Surface
);

Parameters

hotSpotX | System.Int32. X-coordinate offset (in pixels) that marks the center of the cursor. The offset is relative to the upper-left corner of the cursor. When the cursor is given a new position, the image is drawn at an offset from the new position. The offset is determined by subtracting the hot spot coordinates from the position.
hotSpotY | System.Int32. Y-coordinate offset (in pixels) that marks the center of the cursor. The offset is relative to the upper-left corner of the cursor. When the cursor is given a new position, the image is drawn at an offset from the new position. The offset is determined by subtracting the hot spot coordinates from the position.
cursorBitmap | Microsoft.DirectX.Direct3D.Surface. A Surface object. This parameter must be an 8888 ARGB surface (format A8R8G8B8). The contents of this surface are copied and potentially converted into an internal buffer from which the cursor is displayed. The dimensions of this surface must be less than the dimensions of the display mode, and must be a power of two in each direction, although not necessarily the same power of two. The alpha channel must be either 0.0 or 1.0.

Remarks

An operating system cursor is created and used under either of the following conditions.

  • The hardware set CursorCaps.SupportsColor to true and the cursor size is 32x32 (which is the cursor size in the operating system).
  • The application is running in windowed mode.

If neither condition is present, Microsoft® DirectX® uses an emulated cursor. An application uses Device.SetCursorPosition to move an emulated cursor in order to follow mouse movement.

To determine which hardware support is available for cursors, an application can examine appropriate members of the Caps structure. Typically, hardware supports only 32x32 cursors, and the system, when windowed, also might support only 32x32 cursors. In this case, Device.SetCursorProperties still succeeds, but the cursor might be reduced to that size. The hot spot is scaled appropriately.

The cursor does not survive when the device is lost. This method must be called after the device is reset.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetCursor
  • Device.ShowCursor


Device.SetDialogBoxesEnabled(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetDialogBoxesEnabled Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enables the use of Microsoft® Windows® Graphics Device Interface (GDI) dialog boxes in full-screen applications.

Definition

Visual Basic .NET Public Sub SetDialogBoxesEnabled( _
ByVal value As Boolean _
)
C# public void SetDialogBoxesEnabled(
bool value
);
Managed C++ public: void SetDialogBoxesEnabled(
bool value
);
JScript .NET public function SetDialogBoxesEnabled(
value : boolean
);

Parameters

value System.Boolean. Set to true to enable Microsoft® Windows® Graphics Device Interface (GDI) dialog boxes. Set to false to disable Microsoft® Windows® Graphics Device Interface (GDI) dialog boxes.

Remarks

The Microsoft® Windows® Graphics Device Interface (GDI) dialog boxes must be created as child elements to the device window. They should also be created within the same thread that created the device, because this enables the parent window to manage redrawing of the child window.

This method has no effect on applications in windowed mode, but its setting takes effect if the application resets the device into full-screen mode. If SetDialogBoxesEnabled succeeds in a windowed-mode application, any subsequent reset to full-screen mode is checked against the restrictions cited above. Also, because SetDialogBoxesEnabled causes all back buffers on the swap chain to be discarded, an application is expected to refresh its content for all back buffers after the call.

Exceptions

InvalidCallException: The method call is invalid. For example, a method's parameter might contain an invalid value.

This method also might fail if the all of the following are conditions are present.

  • The application specified a back buffer format compatible with GDI; that is, X1R5G5B5, R5G6B5, or X8R8G8B8.
  • The application specified no multisampling.
  • The application specified SwapEffect.Discard.
  • The application specified PresentFlag.LockableBackBuffer.
  • The application did not specify CreateFlags.AdapterGroupDevice.
  • The application is not in a BeginScene ... EndScene pair.


Device.SetGammaRamp(Int32,Boolean,GammaRamp)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetGammaRamp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the gamma correction ramp for the implicit swap chain.

Definition

Visual Basic .NET Public Sub SetGammaRamp( _
ByVal swapChain As Integer, _
ByVal calibrate As Boolean, _
ByVal ramp As GammaRamp _
)
C# public void SetGammaRamp(
int swapChain,
bool calibrate,
GammaRamp ramp
);
Managed C++ public: void SetGammaRamp(
int swapChain,
bool calibrate,
GammaRamp ramp
);
JScript .NET public function SetGammaRamp(
swapChain : int,
calibrate : boolean,
ramp : GammaRamp
);

Parameters

swapChain | System.Int32. Unsigned integer that specifies the swap chain.
calibrate | System.Boolean. Set to true to indicate that correction should be applied. Set to false to indicate that no gamma correction should be applied. The supplied gamma table is transferred directly to the device.
ramp | Microsoft.DirectX.Direct3D.GammaRamp. A GammaRamp structure that represents the gamma correction ramp to set for the implicit swap chain.

Remarks

Each device always has at least one swap chain (the implicit swap chain), because Microsoft® DirectX® 9.0 sets a swap chain as a device property.

Gamma correction results in a more consistent display, but can incur processing overhead and should not be used frequently. Short-duration effects, such as flashing the entire screen red, should not be calibrated, but long-duration gamma changes should be. If a gamma calibrator is installed, the ramp is modified before being sent to the device to account for the system and monitor response curves. If no calibrator is installed, the ramp is passed directly to the device.

For windowed gamma correction presentation, use SwapChain.Present if the hardware supports the feature.

The gamma ramp takes effect immediately. No wait for a vertical sync operation is performed.

If the device does not support gamma ramps in the swap chain's current presentation mode (full-screen or windowed), no error is returned. Applications can check DriverCaps.SupportsFullscreenGamma and DriverCaps.CanCalibrateGamma to determine the capabilities of the device and whether a calibrator is installed.

See Also

  • SwapChain
  • GetGammaRamp


Device.SetPaletteEntries(Int32,PaletteEntry[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPaletteEntries Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets palette entries.

Definition

Visual Basic .NET Public Sub SetPaletteEntries( _
ByVal paletteNumber As Integer, _
ByVal entries() As PaletteEntry _
)
C# public void SetPaletteEntries(
int paletteNumber,
PaletteEntry[] entries
);
Managed C++ public: void SetPaletteEntries(
int paletteNumber,
PaletteEntry entries __gc[]
);
JScript .NET public function SetPaletteEntries(
paletteNumber : int,
entries : PaletteEntry[]
);

Parameters

paletteNumber | System.Int32. Ordinal value that identifies the palette on which the operation is performed.
entries | Microsoft.DirectX.Direct3D.PaletteEntry[]. Pointer to a PaletteEntry structure that represents the palette entries to set. The number of PaletteEntry structures passed into param_PaletteEntryA_entries is assumed to be 256. See Remarks.

Remarks

For Microsoft® DirectX® 9.0 applications, any palette sent to this method must conform to the TextureCaps.SupportsAlphaPalette capability bit of Caps.TextureCaps. If TextureCaps.SupportsAlphaPalette is not set, every entry in the palette must have alpha set to 1.0, or this method will fail and throw an InvalidCallException. If TextureCaps.SupportsAlphaPalette is set, any set of alpha values is allowed. Note that the debug runtime prints a warning message if all palette entries have alpha set to 0.

A single logical palette is associated with the device, and is shared by all texture stages.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.CurrentTexturePalette
  • Device.GetPaletteEntries


Device.SetPixelShaderConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Overload List

public void SetPixelShaderConstant(int, bool[]);
public void SetPixelShaderConstant(int, int[]);
public void SetPixelShaderConstant(int, Matrix);
public void SetPixelShaderConstant(int, Matrix);
public void SetPixelShaderConstant(int, Matrix[]);
public void SetPixelShaderConstant(int, float[]);
public void SetPixelShaderConstant(int, Vector4);
public void SetPixelShaderConstant(int, Vector4);
public void SetPixelShaderConstant(int, Vector4[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Vector4. A pointer to a Vector4 object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Matrix. A pointer to a Matrix object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Vector4. A Vector4 object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Matrix. A Matrix object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Boolean[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Boolean _
)
C# public void SetPixelShaderConstant(
int startRegister,
bool[] constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
bool constantData __gc[]
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : boolean[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | System.Boolean[]. Array of Boolean Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Integer _
)
C# public void SetPixelShaderConstant(
int startRegister,
int[] constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
int constantData __gc[]
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : int[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | System.Int32[]. Array of Int32 Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Vector4[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Vector4 _
)
C# public void SetPixelShaderConstant(
int startRegister,
Vector4[] constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
Vector4 constantData __gc[]
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : Vector4[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Vector4[]. Array of Vector4 constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Matrix[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Matrix _
)
C# public void SetPixelShaderConstant(
int startRegister,
Matrix[] constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
Matrix constantData __gc[]
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : Matrix[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Matrix[]. Array of Matrix constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetPixelShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a pixel shader constant.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Single _
)
C# public void SetPixelShaderConstant(
int startRegister,
float[] constantData
);
Managed C++ public: void SetPixelShaderConstant(
int startRegister,
float constantData __gc[]
);
JScript .NET public function SetPixelShaderConstant(
startRegister : int,
constantData : float[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | System.Single[]. Array of Single Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstantBoolean(Int32,GraphicsStream,Int32)

Device.SetPixelShaderConstantBoolean Method

Note: This documentation is preliminary and is subject to change.

Sets Boolean shader constants.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstantBoolean( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetPixelShaderConstantBoolean(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
Managed C++ public: void SetPixelShaderConstantBoolean(
int startRegister,
GraphicsStream *constantData,
int numberRegisters
);
JScript .NET public function SetPixelShaderConstantBoolean(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister | System.Int32. Register number that will contain the first constant value.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader constants to set.
numberRegisters | System.Int32. Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetPixelShaderBooleanConstant
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetPixelShaderConstantInt32(Int32,GraphicsStream,Int32)

Device.SetPixelShaderConstantInt32 Method

Note: This documentation is preliminary and is subject to change.

Sets integer shader constants.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstantInt32( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetPixelShaderConstantInt32(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
Managed C++ public: void SetPixelShaderConstantInt32(
int startRegister,
GraphicsStream *constantData,
int numberRegisters
);
JScript .NET public function SetPixelShaderConstantInt32(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister | System.Int32. Register number that will contain the first constant value.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader constants to set.
numberRegisters | System.Int32. Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetPixelShaderInt32Constant
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetPixelShaderConstantSingle(Int32,GraphicsStream,Int32)

Device.SetPixelShaderConstantSingle Method

Note: This documentation is preliminary and is subject to change.

Sets floating-point shader constants.

Definition

Visual Basic .NET Public Sub SetPixelShaderConstantSingle( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetPixelShaderConstantSingle(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
Managed C++ public: void SetPixelShaderConstantSingle(
int startRegister,
GraphicsStream *constantData,
int numberRegisters
);
JScript .NET public function SetPixelShaderConstantSingle(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister | System.Int32. Register number that will contain the first constant value.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader constants to set.
numberRegisters | System.Int32. Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetPixelShaderSingleConstant
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState

Device.SetRenderState Method

Note: This documentation is preliminary and is subject to change.

Sets a render state value.

Overload List

public void SetRenderState(RenderStates, bool);
public void SetRenderState(RenderStates, int);
public void SetRenderState(RenderStates, float);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState(RenderStates,Single)

Device.SetRenderState Method

Note: This documentation is preliminary and is subject to change.

Sets a render state value.

Definition

Visual Basic .NET Public Sub SetRenderState( _
ByVal state As RenderStates, _
ByVal value As Single _
)
C# public void SetRenderState(
RenderStates state,
float value
);
Managed C++ public: void SetRenderState(
RenderStates state,
float value
);
JScript .NET public function SetRenderState(
state : RenderStates,
value : float
);

Parameters

state | Microsoft.DirectX.Direct3D.RenderStates. A member from the RenderStates enumeration that represents the render state value to set.
value | System.Single. A floating-point render state value to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState(RenderStates,Boolean)

Device.SetRenderState Method

Note: This documentation is preliminary and is subject to change.

Sets a render state value.

Definition

Visual Basic .NET Public Sub SetRenderState( _
ByVal state As RenderStates, _
ByVal value As Boolean _
)
C# public void SetRenderState(
RenderStates state,
bool value
);
Managed C++ public: void SetRenderState(
RenderStates state,
bool value
);
JScript .NET public function SetRenderState(
state : RenderStates,
value : boolean
);

Parameters

state | Microsoft.DirectX.Direct3D.RenderStates. A member from the RenderStates enumeration that represents the render state value to set.
value | System.Boolean. A Boolean render state value to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState(RenderStates,Int32)

Device.SetRenderState Method

Note: This documentation is preliminary and is subject to change.

Sets a render state value.

Definition

Visual Basic .NET Public Sub SetRenderState( _
ByVal state As RenderStates, _
ByVal value As Integer _
)
C# public void SetRenderState(
RenderStates state,
int value
);
Managed C++ public: void SetRenderState(
RenderStates state,
int value
);
JScript .NET public function SetRenderState(
state : RenderStates,
value : int
);

Parameters

state | Microsoft.DirectX.Direct3D.RenderStates. A member from the RenderStates enumeration that represents the render state value to set.
value | System.Int32. An integer render state value to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderTarget(Int32,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetRenderTarget Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a new color buffer for a device.

Definition

Visual Basic .NET Public Sub SetRenderTarget( _
ByVal renderTargetIndex As Integer, _
ByVal renderTarget As Surface _
)
C# public void SetRenderTarget(
int renderTargetIndex,
Surface renderTarget
);
Managed C++ public: void SetRenderTarget(
int renderTargetIndex,
Surface *renderTarget
);
JScript .NET public function SetRenderTarget(
renderTargetIndex : int,
renderTarget : Surface
);

Parameters

renderTargetIndex System.Int32. Index of the render target. See Remarks.
renderTarget Microsoft.DirectX.Direct3D.Surface. New color buffer. If set to null, the color buffer for the corresponding param_Int32_renderTargetIndex is disabled. Devices must always be associated with a color buffer.

The new render-target surface must have at least RenderTarget specified.

Remarks

The device can support multiple render targets. The number of render targets supported by a device is contained in Caps.NumberSimultaneousRts.

Some hardware tests the compatibility of the depth stencil buffer with the color buffer. If this is done, it is done only in a debug build.

The following restrictions apply when using this method.

  • The multisample type must be the same for the render target and the depth stencil surface.
  • The formats must be compatible for the render target and the depth stencil surface. For more information, see Manager.CheckDepthStencilMatch.
  • The size of the depth stencil surface must be greater than or equal to the size of the render target.

These restrictions are validated only when using the debug runtime when any of the Device Draw methods are called.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

Exceptions
InvalidCallException The method call is invalid. Either param_Surface_renderTarget = null and param_Int32_renderTargetIndex = 0, or param_Surface_renderTarget != null and the render target is invalid.


Device.SetSamplerState

Device.SetSamplerState Method

Note: This documentation is preliminary and is subject to change.

Sets a sampler stage state value.

Overload List

public void SetSamplerState(int, SamplerStageStates, bool);
public void SetSamplerState(int, SamplerStageStates, int);
public void SetSamplerState(int, SamplerStageStates, float);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetSamplerState(Int32,SamplerStageStates,Single)

Device.SetSamplerState Method

Note: This documentation is preliminary and is subject to change.

Sets a sampler stage state value.

Definition

Visual Basic .NET Public Sub SetSamplerState( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Single _
)
C# public void SetSamplerState(
int stage,
SamplerStageStates state,
float value
);
Managed C++ public: void SetSamplerState(
int stage,
SamplerStageStates state,
float value
);
JScript .NET public function SetSamplerState(
stage : int,
state : SamplerStageStates,
value : float
);

Parameters

stage | System.Int32. Index value of the sampler stage to set.
state | Microsoft.DirectX.Direct3D.SamplerStageStates. A member from the SamplerStageStates enumeration that represents the sampler stage state value to set.
value | System.Single. A floating-point value to set for the given sampler stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetSamplerState(Int32,SamplerStageStates,Boolean)

Device.SetSamplerState Method

Note: This documentation is preliminary and is subject to change.

Sets a sampler stage state value.

Definition

Visual Basic .NET Public Sub SetSamplerState( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Boolean _
)
C# public void SetSamplerState(
int stage,
SamplerStageStates state,
bool value
);
Managed C++ public: void SetSamplerState(
int stage,
SamplerStageStates state,
bool value
);
JScript .NET public function SetSamplerState(
stage : int,
state : SamplerStageStates,
value : boolean
);

Parameters

stage | System.Int32. Index value of the sampler stage to set.
state | Microsoft.DirectX.Direct3D.SamplerStageStates. A member from the SamplerStageStates enumeration that represents the sampler stage state value to set.
value | System.Boolean. A Boolean value to set for the given sampler stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetSamplerState(Int32,SamplerStageStates,Int32)

Device.SetSamplerState Method

Note: This documentation is preliminary and is subject to change.

Sets a sampler stage state value.

Definition

Visual Basic .NET Public Sub SetSamplerState( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Integer _
)
C# public void SetSamplerState(
int stage,
SamplerStageStates state,
int value
);
Managed C++ public: void SetSamplerState(
int stage,
SamplerStageStates state,
int value
);
JScript .NET public function SetSamplerState(
stage : int,
state : SamplerStageStates,
value : int
);

Parameters

stage | System.Int32. Index value of the sampler stage to set.
state | Microsoft.DirectX.Direct3D.SamplerStageStates. A member from the SamplerStageStates enumeration that represents the sampler stage state value to set.
value | System.Int32. An integer value to set for the given sampler stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetStreamSource

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetStreamSource Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Generate a Scene

Binds a vertex buffer to a device data stream.

Overload List

public void SetStreamSource(int, VertexBuffer, int);
public void SetStreamSource(int, VertexBuffer, int, int);

Remarks

When a flexible vertex format vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the flexible vertex format (FVF). When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • DrawUserPrimitives
  • DrawIndexedPrimitives
  • GetStreamSource
  • DrawIndexedUserPrimitives


Device.SetStreamSource(Int32,VertexBuffer,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetStreamSource Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Generate a Scene

Binds a vertex buffer to a device data stream.

Definition

Visual Basic .NET Public Sub SetStreamSource( _
ByVal streamNumber As Integer, _
ByVal streamData As VertexBuffer, _
ByVal offsetInBytes As Integer _
)
C# public void SetStreamSource(
int streamNumber,
VertexBuffer streamData,
int offsetInBytes
);
Managed C++ public: void SetStreamSource(
int streamNumber,
VertexBuffer *streamData,
int offsetInBytes
);
JScript .NET public function SetStreamSource(
streamNumber : int,
streamData : VertexBuffer,
offsetInBytes : int
);

Parameters

streamNumber | System.Int32. Data stream in the range of 0 to the maximum number of streams -1.
streamData | Microsoft.DirectX.Direct3D.VertexBuffer. Pointer to a VertexBuffer class that represents the vertex buffer to bind to the specified data stream.
offsetInBytes | System.Int32. Offset from the beginning of the stream to the beginning of the vertex data, in bytes. To determine whether the device supports stream offsets, see DeviceCaps.SupportsStreamOffset.

Remarks

When a flexible vertex format vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the flexible vertex format (FVF). When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • DrawUserPrimitives
  • DrawIndexedPrimitives
  • GetStreamSource
  • DrawIndexedUserPrimitives


Device.SetStreamSource(Int32,VertexBuffer,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetStreamSource Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Generate a Scene

Binds a vertex buffer to a device data stream.

Definition

Visual Basic .NET Public Sub SetStreamSource( _
ByVal streamNumber As Integer, _
ByVal streamData As VertexBuffer, _
ByVal offsetInBytes As Integer, _
ByVal stride As Integer _
)
C# public void SetStreamSource(
int streamNumber,
VertexBuffer streamData,
int offsetInBytes,
int stride
);
Managed C++ public: void SetStreamSource(
int streamNumber,
VertexBuffer *streamData,
int offsetInBytes,
int stride
);
JScript .NET public function SetStreamSource(
streamNumber : int,
streamData : VertexBuffer,
offsetInBytes : int,
stride : int
);

Parameters

streamNumber | System.Int32. Data stream in the range of 0 to the maximum number of streams -1.
streamData | Microsoft.DirectX.Direct3D.VertexBuffer. Pointer to a VertexBuffer class that represents the vertex buffer to bind to the specified data stream.
offsetInBytes | System.Int32. Offset from the beginning of the stream to the beginning of the vertex data, in bytes. To determine whether the device supports stream offsets, see DeviceCaps.SupportsStreamOffset.
stride | System.Int32. Stride of the component, in bytes. See Remarks.

Remarks

When a flexible vertex format vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the flexible vertex format (FVF). When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • DrawUserPrimitives
  • DrawIndexedPrimitives
  • GetStreamSource
  • DrawIndexedUserPrimitives


Device.SetStreamSourceFrequency(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetStreamSourceFrequency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the stream source frequency divider value.

Definition

Visual Basic .NET Public Sub SetStreamSourceFrequency( _
ByVal streamNumber As Integer, _
ByVal divider As Integer _
)
C# public void SetStreamSourceFrequency(
int streamNumber,
int divider
);
Managed C++ public: void SetStreamSourceFrequency(
int streamNumber,
int divider
);
JScript .NET public function SetStreamSourceFrequency(
streamNumber : int,
divider : int
);

Parameters

streamNumber | System.Int32. Stream source number.
divider | System.Int32. Frequency divider value.

Remarks

Vertex shaders can be invoked more than once per vertex.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetStreamSourceFrequency


Device.SetTexture(Int32,BaseTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Render Mesh with Texture using HLSL

Assigns a texture to a device stage.

Definition

Visual Basic .NET Public Sub SetTexture( _
ByVal stage As Integer, _
ByVal texture As BaseTexture _
)
C# public void SetTexture(
int stage,
BaseTexture texture
);
Managed C++ public: void SetTexture(
int stage,
BaseTexture *texture
);
JScript .NET public function SetTexture(
stage : int,
texture : BaseTexture
);

Parameters

stage | System.Int32. Index value for the device stage.
texture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that represents the texture being set.

Remarks

This method is not allowed if the texture is created with a pool type of Scratch, nor is it allowed with a pool type of SystemMemory, unless DeviceCaps.SupportsTextureSystemMemory is set to true.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Render Mesh with Texture using HLSL

This example demonstrates how to render a mesh texture using the high-level shader language (HLSL).

In the following C# code example, the following assumptions are made:

  1. effect is a valid HLSL Effect with its technique set.
  2. The code occurs between calls to Effect.BeginPass and Effect.EndPass.
  3. mesh is a valid Mesh.
  4. meshTextures is a valid array of textures for the mesh.

              [C#]

effect.SetValue("WorldViewProjection", worldMatrix);

// Iterate through each subset and render with its texture
for (int m = 0; m < meshTextures.Length; ++m)
{
    effect.SetValue("SceneTexture", meshTextures[m]));
    effect.CommitChanges();
    mesh.DrawSubset(m);
}

See Also

  • GetTexture


Device.SetTextureStageState

Device.SetTextureStageState Method

Note: This documentation is preliminary and is subject to change.

Sets a texture stage state value.

Overload List

public void SetTextureStageState(int, TextureStageStates, bool);
public void SetTextureStageState(int, TextureStageStates, int);
public void SetTextureStageState(int, TextureStageStates, float);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetTextureStageState(Int32,TextureStageStates,Single)

Device.SetTextureStageState Method

Note: This documentation is preliminary and is subject to change.

Sets a texture stage state value.

Definition

Visual Basic .NET Public Sub SetTextureStageState( _
ByVal stage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Single _
)
C# public void SetTextureStageState(
int stage,
TextureStageStates state,
float value
);
Managed C++ public: void SetTextureStageState(
int stage,
TextureStageStates state,
float value
);
JScript .NET public function SetTextureStageState(
stage : int,
state : TextureStageStates,
value : float
);

Parameters

stage | System.Int32. Index value of the texture stage to set.
state | Microsoft.DirectX.Direct3D.TextureStageStates. A member from the TextureStageStates enumeration that represents the texture stage state value to set.
value | System.Single. A floating-point value to set for the given texture stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetTextureStageState(Int32,TextureStageStates,Boolean)

Device.SetTextureStageState Method

Note: This documentation is preliminary and is subject to change.

Sets a texture stage state value.

Definition

Visual Basic .NET Public Sub SetTextureStageState( _
ByVal stage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Boolean _
)
C# public void SetTextureStageState(
int stage,
TextureStageStates state,
bool value
);
Managed C++ public: void SetTextureStageState(
int stage,
TextureStageStates state,
bool value
);
JScript .NET public function SetTextureStageState(
stage : int,
state : TextureStageStates,
value : boolean
);

Parameters

stage | System.Int32. Index value of the texture stage to set.
state | Microsoft.DirectX.Direct3D.TextureStageStates. A member from the TextureStageStates enumeration that represents the texture stage state value to set.
value | System.Boolean. A Boolean value to set for the given texture stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetTextureStageState(Int32,TextureStageStates,Int32)

Device.SetTextureStageState Method

Note: This documentation is preliminary and is subject to change.

Sets a texture stage state value.

Definition

Visual Basic .NET Public Sub SetTextureStageState( _
ByVal stage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Integer _
)
C# public void SetTextureStageState(
int stage,
TextureStageStates state,
int value
);
Managed C++ public: void SetTextureStageState(
int stage,
TextureStageStates state,
int value
);
JScript .NET public function SetTextureStageState(
stage : int,
state : TextureStageStates,
value : int
);

Parameters

stage | System.Int32. Index value of the texture stage to set.
state | Microsoft.DirectX.Direct3D.TextureStageStates. A member from the TextureStageStates enumeration that represents the texture stage state value to set.
value | System.Int32. An integer value to set for the given texture stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetTransform(TransformType,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetTransform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a single device transform.

Definition

Visual Basic .NET Public Sub SetTransform( _
ByVal state As TransformType, _
ByVal matrix As Matrix _
)
C# public void SetTransform(
TransformType state,
Matrix matrix
);
Managed C++ public: void SetTransform(
TransformType state,
Matrix matrix
);
JScript .NET public function SetTransform(
state : TransformType,
matrix : Matrix
);

Parameters

state | Microsoft.DirectX.Direct3D.TransformType. Type of transform that is being modified; can be any member of the TransformType enumerated type.
matrix | Microsoft.DirectX.Matrix. A Matrix structure that modifies the current transform.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetTransform


Device.SetVertexShaderConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Overload List

public void SetVertexShaderConstant(int, bool[]);
public void SetVertexShaderConstant(int, int[]);
public void SetVertexShaderConstant(int, Matrix);
public void SetVertexShaderConstant(int, Matrix);
public void SetVertexShaderConstant(int, Matrix[]);
public void SetVertexShaderConstant(int, float[]);
public void SetVertexShaderConstant(int, Vector4);
public void SetVertexShaderConstant(int, Vector4);
public void SetVertexShaderConstant(int, Vector4[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Vector4. A pointer to a Vector4 object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Matrix. A pointer to a Matrix object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Vector4. A Vector4 object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Matrix. A Matrix object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Boolean[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Boolean _
)
C# public void SetVertexShaderConstant(
int startRegister,
bool[] constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
bool constantData __gc[]
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : boolean[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | System.Boolean[]. Array of Boolean Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Integer _
)
C# public void SetVertexShaderConstant(
int startRegister,
int[] constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
int constantData __gc[]
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : int[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | System.Int32[]. Array of Int32 Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Vector4[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Vector4 _
)
C# public void SetVertexShaderConstant(
int startRegister,
Vector4[] constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
Vector4 constantData __gc[]
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : Vector4[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Vector4[]. Array of Vector4 constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Matrix[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Matrix _
)
C# public void SetVertexShaderConstant(
int startRegister,
Matrix[] constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
Matrix constantData __gc[]
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : Matrix[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | Microsoft.DirectX.Matrix[]. Array of Matrix constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetVertexShaderConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a vertex shader constant.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Single _
)
C# public void SetVertexShaderConstant(
int startRegister,
float[] constantData
);
Managed C++ public: void SetVertexShaderConstant(
int startRegister,
float constantData __gc[]
);
JScript .NET public function SetVertexShaderConstant(
startRegister : int,
constantData : float[]
);

Parameters

startRegister | System.Int32. Register number that contains the first constant value.
constantData | System.Single[]. Array of Single Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstantBoolean(Int32,GraphicsStream,Int32)

Device.SetVertexShaderConstantBoolean Method

Note: This documentation is preliminary and is subject to change.

Sets Boolean vertex shader constants.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstantBoolean( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetVertexShaderConstantBoolean(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
Managed C++ public: void SetVertexShaderConstantBoolean(
int startRegister,
GraphicsStream *constantData,
int numberRegisters
);
JScript .NET public function SetVertexShaderConstantBoolean(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister | System.Int32. Register number that will contain the first constant value.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader constants to set.
numberRegisters | System.Int32. Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetVertexShaderBooleanConstant
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetVertexShaderConstantInt32(Int32,GraphicsStream,Int32)

Device.SetVertexShaderConstantInt32 Method

Note: This documentation is preliminary and is subject to change.

Sets integer vertex shader constants.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstantInt32( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetVertexShaderConstantInt32(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
Managed C++ public: void SetVertexShaderConstantInt32(
int startRegister,
GraphicsStream *constantData,
int numberRegisters
);
JScript .NET public function SetVertexShaderConstantInt32(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister | System.Int32. Register number that will contain the first constant value.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader constants to set.
numberRegisters | System.Int32. Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetVertexShaderInt32Constant
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetVertexShaderConstantSingle(Int32,GraphicsStream,Int32)

Device.SetVertexShaderConstantSingle Method

Note: This documentation is preliminary and is subject to change.

Sets floating-point vertex shader constants.

Definition

Visual Basic .NET Public Sub SetVertexShaderConstantSingle( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetVertexShaderConstantSingle(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
Managed C++ public: void SetVertexShaderConstantSingle(
int startRegister,
GraphicsStream *constantData,
int numberRegisters
);
JScript .NET public function SetVertexShaderConstantSingle(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister | System.Int32. Register number that will contain the first constant value.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader constants to set.
numberRegisters | System.Int32. Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetVertexShaderSingleConstant
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.ShowCursor(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ShowCursor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Displays or hides the cursor.

Definition

Visual Basic .NET Public Function ShowCursor( _
ByVal canShow As Boolean _
) As Boolean
C# public bool ShowCursor(
bool canShow
);
Managed C++ public: bool ShowCursor(
bool canShow
);
JScript .NET public function ShowCursor(
canShow : boolean
) : boolean;

Parameters

canShow System.Boolean. Set to true if the cursor is shown. Set to false if the cursor is hidden.

Return Value

System.Boolean . Value that indicates whether the cursor was previously visible. If set to true, the cursor was visible; if set to false, it was not.

Remarks

Microsoft® Direct3D® cursor functions use either the Microsoft Windows® Graphics Device Interface (GDI) cursor or software emulation, depending on the hardware.

See Also

  • SetCursor
  • SetCursorPosition
  • SetCursorProperties


Device.StretchRectangle(Surface,Rectangle,Surface,Rectangle,TextureFilter)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.StretchRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies the contents of the source rectangle to the destination rectangle.

Definition

Visual Basic .NET Public Sub StretchRectangle( _
ByVal sourceSurface As Surface, _
ByVal sourceRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal filter As TextureFilter _
)
C# public void StretchRectangle(
Surface sourceSurface,
Rectangle sourceRectangle,
Surface destSurface,
Rectangle destRectangle,
TextureFilter filter
);
Managed C++ public: void StretchRectangle(
Surface *sourceSurface,
Rectangle sourceRectangle,
Surface *destSurface,
Rectangle destRectangle,
TextureFilter filter
);
JScript .NET public function StretchRectangle(
sourceSurface : Surface,
sourceRectangle : Rectangle,
destSurface : Surface,
destRectangle : Rectangle,
filter : TextureFilter
);

Parameters

sourceSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourceRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle. If set to null, the entire source surface is used.
destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle. If set to null, the entire destination surface is used.
filter | Microsoft.DirectX.Direct3D.TextureFilter. Filter type. Allowable values are None, Point, or Linear. For more information, see TextureFilter.

Remarks

The source rectangle can be stretched and filtered by the copy. This method is often used to change the aspect ratio of a video stream.

General Restrictions

There are many restrictions on which surface combinations are valid for Device.StretchRectangle. Factors include whether the driver is part of Microsoft® DirectX® 9.0 or an earlier version, and whether the operation will result in stretching or shrinking. Since applications are not expected to recognize whether the driver is a DirectX 9.0 driver, Microsoft Direct3D® automatically sets a new value in the DeviceCaps.CanStretchRectangleFromTextures property for drivers from DirectX 9.0 and later.

The following tables show the possible surface combinations.

DirectX 9.0 driver (no stretching)

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | No | Yes | Yes | No
RT texture | No | Yes | Yes | No
RT | No | Yes | Yes | No
Off-screen plain | No | Yes | Yes | Yes

DirectX 9.0 driver (stretching)

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | No | Yes | Yes | No
RT texture | No | Yes | Yes | No
RT | No | Yes | Yes | No
Off-screen plain | No | Yes | Yes | No

Device.StretchRectangle requires that both source and destination surfaces be Pool.Default surfaces.

If filtering is specified, Device.StretchRectangle fails unless the driver sets Caps.StretchRectangleFilterCaps. If TextureFilter.None is specified, the driver chooses a filtering algorithm.

The stretch operation supports color-space conversion from YUV to high-precision RGBA only. Stretching between rectangles on the same surface is not supported. To test the hardware for color conversion, use Manager.CheckDeviceFormatConversion, because software emulation for the conversion is not supported.

Texture Restrictions

Device.StretchRectangle works for a texture surface or cube texture surface only for DirectX 9.0 drivers (those that set DeviceCaps.CanStretchRectangleFromTextures).

Depth and Stencil Restrictions

Depth and stencil surfaces can be copied using Device.StretchRectangle with the following restrictions.

  • Because both source and destination surfaces must be plain depth stencil surfaces and not textures, they must be created with Device.CreateDepthStencilSurface.
  • Both surfaces must be of the same format; that is, no format conversion is allowed.
  • No stretching or shrinking is allowed.
  • Subrectangle copies are not allowed. The entire surface must be copied; that is, sourceRectangle and destRectangle must be null or must point to rectangles that cover the whole surface.
  • Device.StretchRectangle cannot be called inside of a Device.BeginScene ... Device.EndScene pair.
  • The source or destination surface cannot be a mip level of a texture or cube texture created with Usage.DepthStencil.
  • Neither of the surfaces can be created with their Discard values set to true.
  • Drivers must set DeviceCaps.CanStretchRectangleFromTextures.

Device.StretchRectangle will fail in any of the following situations.

  • The sourceSurface and destSurface parameters are the same.
  • Stretching or shrinking is involved and either surface has a DXTn compressed format.
  • The destination surface is an off-screen plain surface, but the source is not.
  • The destination surface is an off-screen plain surface, and stretching is involved.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.TestCooperativeLevel()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.TestCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reports the current cooperative-level status of the Microsoft® Direct3D® device for a windowed or full-screen application.

Definition

Visual Basic .NET | Public Sub TestCooperativeLevel()
C# | public void TestCooperativeLevel();
Managed C++ | public: void TestCooperativeLevel();
JScript .NET | public function TestCooperativeLevel();

Remarks

If the device is lost and cannot be restored at the current time, Device.TestCooperativeLevel throws a DeviceLostException. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.TestCooperativeLevel until no exceptions are thrown. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is either "lost" or "not reset".

A call to Device.TestCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

Exceptions
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
DeviceNotResetException | The device is lost but can be reset at this time.


Device.UpdateSurface

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UpdateSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies rectangular subsets of pixels from one surface to another.

Overload List

public void UpdateSurface(Surface, Rectangle, Surface);
public void UpdateSurface(Surface, Rectangle, Surface, Point);
public void UpdateSurface(Surface, Surface);
public void UpdateSurface(Surface, Surface, Point);

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UpdateSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic .NET Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal destinationSurface As Surface _
)
C# public void UpdateSurface(
Surface sourceSurface,
Surface destinationSurface
);
Managed C++ public: void UpdateSurface(
Surface *sourceSurface,
Surface *destinationSurface
);
JScript .NET public function UpdateSurface(
sourceSurface : Surface,
destinationSurface : Surface
);

Parameters

sourceSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface; must point to a surface other than destinationSurface.
destinationSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Surface,Point)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UpdateSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic .NET Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal destinationSurface As Surface, _
ByVal destPoint As Point _
)
C# public void UpdateSurface(
Surface sourceSurface,
Surface destinationSurface,
Point destPoint
);
Managed C++ public: void UpdateSurface(
Surface *sourceSurface,
Surface *destinationSurface,
Point destPoint
);
JScript .NET public function UpdateSurface(
sourceSurface : Surface,
destinationSurface : Surface,
destPoint : Point
);

Parameters

sourceSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface; must point to a surface other than destinationSurface.
destinationSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPoint | System.Drawing.Point. A Point Leave Site object that represents the upper-left corner of the destination rectangle. Specifying null for this parameter causes the entire surface to be copied.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Rectangle,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UpdateSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic .NET Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal sourceRect As Rectangle, _
ByVal destinationSurface As Surface _
)
C# public void UpdateSurface(
Surface sourceSurface,
Rectangle sourceRect,
Surface destinationSurface
);
Managed C++ public: void UpdateSurface(
Surface *sourceSurface,
Rectangle sourceRect,
Surface *destinationSurface
);
JScript .NET public function UpdateSurface(
sourceSurface : Surface,
sourceRect : Rectangle,
destinationSurface : Surface
);

Parameters

sourceSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface; must point to a surface other than destinationSurface.
sourceRect | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the rectangle on the source surface. Specifying null for this parameter causes the entire surface to be copied.
destinationSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Rectangle,Surface,Point)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UpdateSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic .NET Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal sourceRect As Rectangle, _
ByVal destinationSurface As Surface, _
ByVal destPoint As Point _
)
C# public void UpdateSurface(
Surface sourceSurface,
Rectangle sourceRect,
Surface destinationSurface,
Point destPoint
);
Managed C++ public: void UpdateSurface(
Surface *sourceSurface,
Rectangle sourceRect,
Surface *destinationSurface,
Point destPoint
);
JScript .NET public function UpdateSurface(
sourceSurface : Surface,
sourceRect : Rectangle,
destinationSurface : Surface,
destPoint : Point
);

Parameters

sourceSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface; must point to a surface other than destinationSurface.
sourceRect | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the rectangle on the source surface. Specifying null for this parameter causes the entire surface to be copied.
destinationSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPoint | System.Drawing.Point. A Point Leave Site object that represents the upper-left corner of the destination rectangle. Specifying null for this parameter causes the entire surface to be copied.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateTexture(BaseTexture,BaseTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UpdateTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the dirty portions of a texture.

Definition

Visual Basic .NET Public Sub UpdateTexture( _
ByVal sourceTexture As BaseTexture, _
ByVal destinationTexture As BaseTexture _
)
C# public void UpdateTexture(
BaseTexture sourceTexture,
BaseTexture destinationTexture
);
Managed C++ public: void UpdateTexture(
BaseTexture *sourceTexture,
BaseTexture *destinationTexture
);
JScript .NET public function UpdateTexture(
sourceTexture : BaseTexture,
destinationTexture : BaseTexture
);

Parameters

sourceTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that represents the source texture, which must be in system memory (Pool.SystemMemory).
destinationTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that represents the destination texture, which must be in the default memory pool (Pool.Default).

Remarks

To dirty a portion of a texture, either lock it or call one of the following methods.

  • CubeTexture.AddDirtyRectangle
  • Texture.AddDirtyRectangle
  • VolumeTexture.AddDirtyBox
  • Device.UpdateSurface

Device.UpdateTexture retrieves the dirty portions of the texture by calculating what has been accumulated since the last update operation.

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when Texture.LockRectangle or VolumeTexture.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. Also, the destination surface of Device.UpdateSurface is marked dirty.

This method fails if the textures are of different types, if their bottom-level buffers are of different sizes, or if their matching levels do not match. For example, consider a six-level source texture with the following dimensions:

32x16, 16x8, 8x4, 4x2, 2x1, 1x1

This six-level source texture could be the source for the following one-level destination:

1x1

For the following two-level destination:

2x1, 1x1

Or for the following three-level destination:

4x2, 2x1, 1x1

In addition, this method fails if the textures are of different formats. If the destination texture has fewer levels than the source, only the matching levels are copied. If the source texture has fewer levels than the destination, the method fails.

If the source texture contains dirty regions, the copy operation can be optimized by restricting it to those regions only. It is not guaranteed that only those bytes marked dirty will be copied.

The following scenarios are supported for source and destination surface combinations.

  • If sourceTexture is a non-autogenerated mipmap and destinationTexture is an autogenerated mipmap, only the topmost matching level is updated, and the destination sublevels are regenerated. All other source sublevels are ignored.
  • If both sourceTexture and destinationTexture are autogenerated mipmaps, only the topmost matching level is updated. The sublevels from the source are ignored and the destination sublevels are regenerated.
  • If sourceTexture is an autogenerated mipmap and destinationTexture a non-autogenerated mipmap, this method fails.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateUnmanagedPointer(IDirect3DDevice9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Device object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DDevice9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DDevice9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DDevice9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DDevice9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DDevice9. Pointer to the IDirect3DDevice9 structure used to update the unmanaged pointer for this Device object.


Device.ValidateDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ValidateDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reports the device's ability to render the current texture-blending operations and arguments in a single pass.

Definition

Visual Basic .NET | Public Function ValidateDevice() As ValidateDeviceParams
C# | public ValidateDeviceParams ValidateDevice();
Managed C++ | public: ValidateDeviceParams ValidateDevice();
JScript .NET | public function ValidateDevice() : ValidateDeviceParams;

Return Value

Microsoft.DirectX.Direct3D.ValidateDeviceParams . A ValidateDeviceParams object that provides the number of passes and the result code of the validation check.

Remarks

The Device.ValidateDevice method should be used to validate scenarios only when other capabilities are deficient. For example, in a multistage texturing scenario, the Caps.MaxTextureBlendStages and Caps.MaxSimultaneousTextures properties could be queried to determine whether multistage texturing is possible on the device.

Current hardware does not necessarily implement all possible combinations of operations and arguments. To determine whether a particular blending operation can be performed with given arguments, set the desired blending operation and then call the Device.ValidateDevice method.

The Device.ValidateDevice method uses the current render states, textures, and texture-stage states to perform validation at the time of the call. Changes to these factors after the call invalidate the previous result, and the method must be called again before rendering a scene.

For best performance, call Device.ValidateDevice at initialization time; do not use it within a render loop.

Using diffuse iterated values, either as an argument or as an operation (TextureArgument.Diffuse, TextureOperation.BlendDiffuseAlpha), is rarely supported on current hardware. Most hardware can introduce iterated color data only at the last texture operation stage.

In general, specify the texture TextureArgument.TextureColor for each stage as the first argument rather than the second argument.

Many video cards do not support the use of diffuse or scalar values at arbitrary texture stages. Often, these values are available only at the first or last texture-blending stage.

Many cards do not have a blending unit associated with the first texture that is capable of more than replicating alpha to color channels or inverting the input. Therefore, an application might need to use only the second texture stage, if possible. On such hardware, the first unit is presumed to be in its default state, in which the first color argument is set to TextureArgument.TextureColor with the TextureOperation.SelectArg1 operation.

Operations on the output alpha that are more intricate than or substantially different from the color operations are less likely to be supported.

Some hardware does not support simultaneous use of TextureArgument.TFactor and TextureArgument.Diffuse.

Many cards do not support simultaneous use of multiple textures and mipmapped trilinear filtering. If trilinear filtering is requested for a texture involved in multitexture blending operations and validation fails, turn off trilinear filtering and revalidate. In this case, performing multipass rendering might be a better alternative.

Exceptions
ConflictingRenderStateException | Currently set render states cannot be used together.
ConflictingTextureFilterException | Current texture filters cannot be used together.
DeviceLostException | Device has been lost and cannot be reset at this time; therefore, rendering is not possible.
DriverInternalErrorException | An internal driver error occurred. Generally, an application should shut down when it receives this error.
TooManyOperationsException | Application is requesting more texture-filtering operations than the device supports.
UnsupportedAlphaArgumentException | Device does not support a specified texture-blending argument for the alpha channel.
UnsupportedAlphaOperationException | Device does not support a specified texture-blending operation for the alpha channel.
UnsupportedColorArgumentException | Device does not support a specified texture-blending argument for color values.
UnsupportedColorOperationException | Device does not support a specified texture-blending operation for color values.
UnsupportedFactorValueException | Device does not support the specified texture factor value.
UnsupportedTextureFilterException | Device does not support the specified texture filter.
WrongTextureFormatException | Pixel format of the texture surface is not valid.

See Also

  • Tutorial 5: Using Texture Maps
  • Device.TextureState


Device.AvailableTextureMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.AvailableTextureMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an estimate of the amount of available texture memory.

Definition

Visual Basic .NET | Public ReadOnly Property AvailableTextureMemory As Integer
C# | public int AvailableTextureMemory { get; }
Managed C++ | public: __property int get_AvailableTextureMemory();
JScript .NET | public function get AvailableTextureMemory() : int

Property Value

System.Int32 . Returns an estimate of the available texture memory.

This property is read-only.

Remarks

The returned value is rounded to the nearest megabyte. This is done to reflect the fact that video memory estimates are never precise, due to alignment and other issues that affect consumption by certain resources. Applications can use the value to make gross estimates of memory availability for use in large-scale resource decisions (such as how many levels of a mipmap to attempt to allocate), but not to make small-scale decisions (such as whether enough memory is left to allocate another resource).


Device.ClipPlanes

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ClipPlanes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the clipping planes on the current device.

Definition

Visual Basic .NET | Public ReadOnly Property ClipPlanes As ClipPlanes
C# | public ClipPlanes ClipPlanes { get; }
Managed C++ | public: __property ClipPlanes* get_ClipPlanes();
JScript .NET | public function get ClipPlanes() : ClipPlanes

Property Value

Microsoft.DirectX.Direct3D.ClipPlanes . Clipping planes on the current device.

This property is read-only.

See Also

  • ClipPlane
  • ClipPlanes


Device.ClipStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ClipStatus Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a ClipStatus object.

Definition

Visual Basic .NET | Public Property ClipStatus As ClipStatus
C# | public ClipStatus ClipStatus { get; set; }
Managed C++ public: __property ClipStatus get_ClipStatus();
public: __property void set_ClipStatus(ClipStatus);
JScript .NET public function get ClipStatus() : ClipStatus
public function set ClipStatus(ClipStatus);

Property Value

Microsoft.DirectX.Direct3D.ClipStatus . A ClipStatus object that describes the current clip status.

This property is read/write.

Remarks

Clip status is used during software vertex processing; therefore, this method is not supported on hardware processing devices, whether or not they are pure. For more information about pure devices, see CreateFlags.

When clipping is enabled during vertex processing (by Device.ProcessVertices, Device.DrawPrimitives, or other drawing functions), Microsoft® DirectX® 9.0 computes a clip code for every vertex. The clip code is a combination of ClipStatusFlags values. When a vertex is outside of a particular clipping plane, the corresponding bit is set in the clip code. Microsoft Direct3D® maintains the clip status using ClipStatus, which has ClipUnion and ClipIntersection members. ClipUnion is a bitwise OR of all vertex clip codes and has an initial value of 0; ClipIntersection is a bitwise AND of all vertex clip codes and has an initial value of 0xFFFFFFFF. When RenderStateManager.Clipping is set to false, ClipUnion and ClipIntersection are set to 0. Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion and ClipIntersection to their initial values and continue drawing.

Clip status is not updated by Device.DrawRectanglePatch and Device.DrawTrianglePatch because there is no software emulation for them.

Exceptions
InvalidCallException One of the arguments is invalid.


Device.CreationParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CreationParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the creation parameters of the device.

Definition

Visual Basic .NET | Public ReadOnly Property CreationParameters As DeviceCreationParameters
C# | public DeviceCreationParameters CreationParameters { get; }
Managed C++ | public: __property DeviceCreationParameters get_CreationParameters();
JScript .NET | public function get CreationParameters() : DeviceCreationParameters

Property Value

Microsoft.DirectX.Direct3D.DeviceCreationParameters . Returns a DeviceCreationParameters object that describes the device's creation parameters.

This property is read-only.

Remarks

To retrieve the ordinal of the adapter represented by the device, query the DeviceCreationParameters.AdapterOrdinal member of the returned object.


Device.CurrentTexturePalette

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CurrentTexturePalette Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the current texture palette.

Definition

Visual Basic .NET | Public Property CurrentTexturePalette As Integer
C# | public int CurrentTexturePalette { get; set; }
Managed C++ public: __property int get_CurrentTexturePalette();
public: __property void set_CurrentTexturePalette(int);
JScript .NET public function get CurrentTexturePalette() : int
public function set CurrentTexturePalette(int);

Property Value

System.Int32 . Current texture palette.

This property is read/write.

Remarks

Microsoft® Direct3D® for Microsoft DirectX® 9.0 supports paletted textures through a set of 256 entry palettes associated with the Device object. A palette is made current by setting the Device.CurrentTexturePalette property. The current palette is used for translating all paletted textures for all active texture stages. Device.SetPaletteEntries updates all 256 of a palette's entries, each of which is a PaletteEntry object formatted with Format.A8R8G8B8. By default, all entries are set to 0xFFFFFFFF.

The Device palettes contain an alpha channel, which can be used when the TextureCaps.SupportsAlphaPalette device capability flag is set, indicating that the device supports alpha from the palette. The palette alpha channel is used when the texture format does not have an alpha channel. If the device does not support alpha from the palette and the texture format does not have an alpha channel, a value of 0xFF is used for alpha.

A maximum of 65,536 (0x0000FFFF) palettes is allowed. Because memory resources associated with the set of palettes are proportional to the maximum palette number that an application references, use contiguous palette numbers starting at zero.


Device.DepthStencilSurface

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DepthStencilSurface Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the depth stencil surface owned by the Device object.

Definition

Visual Basic .NET | Public Property DepthStencilSurface As Surface
C# | public Surface DepthStencilSurface { get; set; }
Managed C++ public: __property Surface* get_DepthStencilSurface();
public: __property void set_DepthStencilSurface(Surface*);
JScript .NET public function get DepthStencilSurface() : Surface
public function set DepthStencilSurface(Surface);

Property Value

Microsoft.DirectX.Direct3D.Surface . Returns a Surface object that represents the depth stencil surface. If no depth stencil buffer is associated with the device, the return value is null.

Setting this value to null disables the depth stencil operation.

This property is read/write.

Remarks

The following restrictions apply when using this property.

  • The multisample type must be the same for the render target and the depth stencil surface.
  • The formats for the render target and depth stencil surface must be compatible. For more information, see Manager.CheckDepthStencilMatch.
  • The size of the depth stencil surface must be greater than or equal to the size of the render target.

These restrictions are validated only when using the debug runtime when any of the Device drawing methods are called.

Cube textures differ from other surfaces in that they are collections of surfaces. To set a new depth stencil surface with a cube texture, choose an individual face using CubeTexture.GetCubeMapSurface, and pass the resulting surface to this property.

Exceptions
NotFoundException | Occurs if the device does not have a depth stencil buffer associated with it.
InvalidCallException | Occurs if the method call is invalid. For example, a parameter may have an invalid value.


Device.DeviceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DeviceCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the capabilities of the rendering device.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceCaps As Caps
C# | public Caps DeviceCaps { get; }
Managed C++ | public: __property Caps get_DeviceCaps();
JScript .NET | public function get DeviceCaps() : Caps

Property Value

Microsoft.DirectX.Direct3D.Caps . A Caps object that describes the returned device.

This property is read-only.

Remarks

Device.DeviceCaps retrieves the software vertex pipeline capabilities when the device is used in software vertex processing mode.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.DisplayMode

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DisplayMode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.

Definition

Visual Basic .NET | Public ReadOnly Property DisplayMode As DisplayMode
C# | public DisplayMode DisplayMode { get; }
Managed C++ | public: __property DisplayMode get_DisplayMode();
JScript .NET | public function get DisplayMode() : DisplayMode

Property Value

Microsoft.DirectX.Direct3D.DisplayMode . A DisplayMode object that contains data about the display mode of the adapter (as opposed to the display mode of the device, which might not be active if the device does not own full-screen mode).

This property is read-only.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Device.Indices

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Indices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets index data.

Definition

Visual Basic .NET | Public Property Indices As IndexBuffer
C# | public IndexBuffer Indices { get; set; }
Managed C++ public: __property IndexBuffer* get_Indices();
public: __property void set_Indices(IndexBuffer*);
JScript .NET public function get Indices() : IndexBuffer
public function set Indices(IndexBuffer);

Property Value

Microsoft.DirectX.Direct3D.IndexBuffer . An IndexBuffer object that represents the index data.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.IsUsingEventHandlers

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.IsUsingEventHandlers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that indicates whether the device should use event handlers.

Definition

Visual Basic .NET | Public Shared Property IsUsingEventHandlers As Boolean
C# | public static bool IsUsingEventHandlers { get; set; }
Managed C++ public: __property static bool get_IsUsingEventHandlers();
public: __property void set_IsUsingEventHandlers(bool);
JScript .NET public static function get IsUsingEventHandlers() : boolean
public function set IsUsingEventHandlers(boolean);

Property Value

System.Boolean . A value of true indicates that event handlers are enabled; false indicates that they are disabled.

This property is read/write.


Device.Lights

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Lights Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the LightsCollection collection on the current device.

Definition

Visual Basic .NET | Public ReadOnly Property Lights As LightsCollection
C# | public LightsCollection Lights { get; }
Managed C++ | public: __property LightsCollection* get_Lights();
JScript .NET | public function get Lights() : LightsCollection

Property Value

Microsoft.DirectX.Direct3D.LightsCollection . A LightsCollection collection object.

This property is read-only.


Device.Material

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Material Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the current material properties for the device.

Definition

Visual Basic .NET | Public Property Material As Material
C# | public Material Material { get; set; }
Managed C++ public: __property Material get_Material();
public: __property void set_Material(Material);
JScript .NET public function get Material() : Material
public function set Material(Material);

Property Value

Microsoft.DirectX.Direct3D.Material . A Material object that represents the current material properties or the material properties to set.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if properties of the Material object are invalid.


Device.NPatchMode

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.NPatchMode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the N-patch mode segments.

Definition

Visual Basic .NET | Public Property NPatchMode As Single
C# | public float NPatchMode { get; set; }
Managed C++ public: __property float get_NPatchMode();
public: __property void set_NPatchMode(float);
JScript .NET public function get NPatchMode() : float
public function set NPatchMode(float);

Property Value

System.Single . Specifies the number of subdivision segments. If the number is less than 1.0, N-patches are disabled. The default value is 0.0.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.NumberOfSwapChains

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.NumberOfSwapChains Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of implicit swap chains.

Definition

Visual Basic .NET | Public ReadOnly Property NumberOfSwapChains As Integer
C# | public int NumberOfSwapChains { get; }
Managed C++ | public: __property int get_NumberOfSwapChains();
JScript .NET | public function get NumberOfSwapChains() : int

Property Value

System.Int32 . Number of implicit swap chains.

This property is read-only.

Remarks

Implicit swap chains are created by the device during a call to the Device constructor.

An application can create additional swap chains using the SwapChain class.


Device.PixelShader

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.PixelShader Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the current pixel shader.

Definition

Visual Basic .NET | Public Property PixelShader As PixelShader
C# | public PixelShader PixelShader { get; set; }
Managed C++ public: __property PixelShader* get_PixelShader();
public: __property void set_PixelShader(PixelShader*);
JScript .NET public function get PixelShader() : PixelShader
public function set PixelShader(PixelShader);

Property Value

Microsoft.DirectX.Direct3D.PixelShader . A PixelShader object that represents the current pixel shader or a pixel shader object to set.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.PresentationParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.PresentationParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves presentation parameters for a device.

Definition

Visual Basic .NET | Public ReadOnly Property PresentationParameters As PresentParameters
C# | public PresentParameters PresentationParameters { get; }
Managed C++ | public: __property PresentParameters* get_PresentationParameters();
JScript .NET | public function get PresentationParameters() : PresentParameters

Property Value

Microsoft.DirectX.Direct3D.PresentParameters . A PresentParameters object that describes the device's presentation parameters.

This property is read-only.


Device.RasterStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.RasterStatus Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information that describes the raster of the monitor on which the swap chain is presented.

Definition

Visual Basic .NET | Public ReadOnly Property RasterStatus As RasterStatus
C# | public RasterStatus RasterStatus { get; }
Managed C++ | public: __property RasterStatus get_RasterStatus();
JScript .NET | public function get RasterStatus() : RasterStatus

Property Value

Microsoft.DirectX.Direct3D.RasterStatus . A RasterStatus object that contains information about the position or other status of the raster on the monitor driven by the current adapter.

This property is read-only.

Remarks

This method does not return device state for a device created using CreateFlags.PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException Occurs if the device does not support reading the current scan line. To determine whether the device supports reading the scan line, check DriverCaps.ReadScanLine.


Device.RenderState

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.RenderState Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a render-state value for a device.

Definition

Visual Basic .NET | Public ReadOnly Property RenderState As RenderStateManager
C# | public RenderStateManager RenderState { get; }
Managed C++ | public: __property RenderStateManager* get_RenderState();
JScript .NET | public function get RenderState() : RenderStateManager

Property Value

Microsoft.DirectX.Direct3D.RenderStateManager . Returns the RenderStateManager object for the device.

This property is read-only.

Remarks

This method returns the last render state that was set for the device, or the default device render state, if not previously set, for a device created using CreateFlags.PureDevice.


Device.SamplerState

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SamplerState Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a device's sampler states.

Definition

Visual Basic .NET | Public ReadOnly Property SamplerState As SamplerStateManagerCollection
C# | public SamplerStateManagerCollection SamplerState { get; }
Managed C++ | public: __property SamplerStateManagerCollection* get_SamplerState();
JScript .NET | public function get SamplerState() : SamplerStateManagerCollection

Property Value

Microsoft.DirectX.Direct3D.SamplerStateManagerCollection . Returns the SamplerStateManagerCollection object for the device.

This property is read-only.

Remarks

This method returns the last sampler state that was set for the device, or the default device sampler state, if not previously set, for a device created using CreateFlags.PureDevice.


Device.ScissorRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ScissorRectangle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the scissor rectangle.

Definition

Visual Basic .NET | Public Property ScissorRectangle As Rectangle
C# | public Rectangle ScissorRectangle { get; set; }
Managed C++ public: __property Rectangle get_ScissorRectangle();
public: __property void set_ScissorRectangle(Rectangle);
JScript .NET public function get ScissorRectangle() : Rectangle
public function set ScissorRectangle(Rectangle);

Property Value

System.Drawing.Rectangle . A Rectangle Leave Site object that defines the rendering area within the render target, if scissor testing is enabled.

This property is read/write.

Remarks

The scissor rectangle is used as a rectangular clipping region. For more information about the use of rectangles in Microsoft® DirectX®, see Rectangle Leave Site.

Exceptions
InvalidCallException Occurs if any properties of the Rectangle Leave Site object are invalid.


Device.SoftwareVertexProcessing

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SoftwareVertexProcessing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex processing mode.

Definition

Visual Basic .NET | Public Property SoftwareVertexProcessing As Boolean
C# | public bool SoftwareVertexProcessing { get; set; }
Managed C++ public: __property bool get_SoftwareVertexProcessing();
public: __property void set_SoftwareVertexProcessing(bool);
JScript .NET public function get SoftwareVertexProcessing() : boolean
public function set SoftwareVertexProcessing(boolean);

Property Value

System.Boolean . Value that is true for software vertex processing; false for hardware vertex processing.

This property is read/write.

Remarks

The following restrictions apply when changing modes.

  • If a device is created with CreateFlags.SoftwareVertexProcessing, vertex processing is done in software and cannot be changed.
  • If a device is created with CreateFlags.HardwareVertexProcessing, vertex processing is done in hardware and cannot be changed.
  • If a device is created with CreateFlags.MixedVertexProcessing, vertex processing is done in hardware by default, and can be switched between software and hardware. An application can create a mixed-mode device to use both software and hardware vertex processing. Use this property to switch between the two vertex processing modes.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Processing Vertex Data


Device.TextureState

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.TextureState Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a state value for an assigned texture.

Definition

Visual Basic .NET | Public ReadOnly Property TextureState As TextureStateManagerCollection
C# | public TextureStateManagerCollection TextureState { get; }
Managed C++ | public: __property TextureStateManagerCollection* get_TextureState();
JScript .NET | public function get TextureState() : TextureStateManagerCollection

Property Value

Microsoft.DirectX.Direct3D.TextureStateManagerCollection . Returns a TextureStateManagerCollection object that contains the device's texture states. To retrieve the TextureStateManager object that contains the actual texture states for the device, use the TextureStateManagerCollection.TextureState property.

This property is read-only.

Remarks

This method returns the last texture state that was set for the device, or the default device texture state, if not previously set, for a device created using CreateFlags.PureDevice.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.Transform

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Transform Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a matrix that describes a transformation state.

Definition

Visual Basic .NET | Public ReadOnly Property Transform As Transforms
C# | public Transforms Transform { get; }
Managed C++ | public: __property Transforms* get_Transform();
JScript .NET | public function get Transform() : Transforms

Property Value

Microsoft.DirectX.Direct3D.Transforms . A Transforms object that describes the returned transformation state.

This property is read-only.

Remarks

This method does not return device state for a device created using CreateFlags.PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DDevice9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DDevice9
C# | public IDirect3DDevice9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DDevice9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DDevice9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DDevice9 . Unmanaged IDirect3DDevice9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Device.VertexDeclaration

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.VertexDeclaration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a vertex shader declaration.

Definition

Visual Basic .NET | Public Property VertexDeclaration As VertexDeclaration
C# | public VertexDeclaration VertexDeclaration { get; set; }
Managed C++ public: __property VertexDeclaration* get_VertexDeclaration();
public: __property void set_VertexDeclaration(VertexDeclaration*);
JScript .NET public function get VertexDeclaration() : VertexDeclaration
public function set VertexDeclaration(VertexDeclaration);

Property Value

Microsoft.DirectX.Direct3D.VertexDeclaration . A VertexDeclaration object that contains the vertex shader declaration.

This property is read/write.

Remarks

A vertex shader declaration is made up of an array of vertex elements.


Device.VertexFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.VertexFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the supported flexible vertex formats.

Definition

Visual Basic .NET | Public Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; set; }
Managed C++ public: __property VertexFormats get_VertexFormat();
public: __property void set_VertexFormat(VertexFormats);
JScript .NET public function get VertexFormat() : VertexFormats
public function set VertexFormat(VertexFormats);

Property Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object that represents the current flexible vertex format values or the flexible vertex format values to set.

This property is read/write.

Remarks

The fixed vertex function declaration is a set of flexible vertex format (FVF) flags that determine how vertices processed by the fixed function pipeline are used. For more information, see Processing Vertex Data.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.VertexShader

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.VertexShader Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the current vertex shader.

Definition

Visual Basic .NET | Public Property VertexShader As VertexShader
C# | public VertexShader VertexShader { get; set; }
Managed C++ public: __property VertexShader* get_VertexShader();
public: __property void set_VertexShader(VertexShader*);
JScript .NET public function get VertexShader() : VertexShader
public function set VertexShader(VertexShader);

Property Value

Microsoft.DirectX.Direct3D.VertexShader . A VertexShader object that represents the device's current vertex shader or a vertex shader object to set.

This property is read/write.

Remarks

To set a fixed-function vertex shader (after having set a programmable vertex shader), set this property to null to release the programmable shader, and then set the Device.VertexFormat property with the fixed-function vertex format.

Exceptions
InvalidCallException Occurs if the method fails.


Device.Viewport

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Viewport Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the viewport parameters for the current device.

Definition

Visual Basic .NET | Public Property Viewport As Viewport
C# | public Viewport Viewport { get; set; }
Managed C++ public: __property Viewport get_Viewport();
public: __property void set_Viewport(Viewport);
JScript .NET public function get Viewport() : Viewport
public function set Viewport(Viewport);

Property Value

Microsoft.DirectX.Direct3D.Viewport . A Viewport object that represents the returned viewport parameters or specifies the viewport parameters to set.

This property is read/write.

Remarks

Device.Viewport can be used to draw on part of the screen. It should be set before any geometry is drawn so the Viewport will take effect.

To draw multiple views within a scene, repeat setting Device.Viewport and draw a geometry sequence for each view.

Exceptions
InvalidCallException Occurs if Viewport is invalid, or if Viewport describes a region that cannot exist within the render target surface.


Device.DeviceLost

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DeviceLost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when a device is about to be lost (for example, immediately prior to a reset).

Definition

Visual Basic .NET | Public Event DeviceLost As EventHandler
C# | public event EventHandler DeviceLost;
Managed C++ | public: __event EventHandler DeviceLost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.DeviceLost event, use the following C# code.

[C#]
device.DeviceLost += new System.EventHandler(this.DeviceLostEventHandler);


Device.DeviceReset

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DeviceReset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after a device is reset, allowing an application to re-create all Pool.Default resources.

Definition

Visual Basic .NET | Public Event DeviceReset As EventHandler
C# | public event EventHandler DeviceReset;
Managed C++ | public: __event EventHandler DeviceReset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.DeviceReset event, use the following C# code.

[C#]
device.DeviceReset += new System.EventHandler(this.DeviceResetEventHandler);


Device.DeviceResizing

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DeviceResizing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when a device is resizing, allowing the application to cancel the default handling of the resize.

Definition

Visual Basic .NET | Public Event DeviceResizing As CancelEventHandler
C# | public event CancelEventHandler DeviceResizing;
Managed C++ | public: __event CancelEventHandler DeviceResizing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.DeviceResizing event, use the following C# code.

[C#]
device.DeviceResizing += new System.CancelEventHandler(this.DeviceResizingEventHandler);

See Also

  • System.CancelEventHandler Leave Site


Device.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Device.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Device object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.DeviceInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains functionality for retrieving the driver level for a device.

Definition

Visual Basic .NET NotInheritable Public Class DeviceInformation
Inherits Object
C# | public sealed class DeviceInformation : Object
Managed C++ | public __gc __sealed class DeviceInformation : public Object
JScript .NET | public class DeviceInformation extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) GetDriverLevel | Retrieves the driver level for a device.

Inheritance Hierarchy

Object Leave Site
DeviceInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceInformation.GetDriverLevel(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.GetDriverLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the driver level for a device.

Definition

Visual Basic .NET Public Shared Function GetDriverLevel( _
ByVal device As Device _
) As Integer
C# public static int GetDriverLevel(
Device device
);
Managed C++ public: static int GetDriverLevel(
Device *device
);
JScript .NET public static function GetDriverLevel(
device : Device
) : int;

Parameters

device Microsoft.DirectX.Direct3D.Device. A Device object that is used to retrieve the driver level.

Return Value

System.Int32 . An Int32 Leave Site value that indicates the driver level of the device.


Microsoft.DirectX.Direct3D.DeviceLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.

Definition

Visual Basic .NET Public Class DeviceLostException
Inherits GraphicsException
C# | public class DeviceLostException : GraphicsException
Managed C++ | public __gc class DeviceLostException : public GraphicsException
JScript .NET | public class DeviceLostException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceLostException | Initializes a new instance of the DeviceLostException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DeviceLostException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceLostException.DeviceLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceLostException.DeviceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceLostException class.

Overload List

public DeviceLostException();
protected DeviceLostException(SerializationInfo, StreamingContext);
public DeviceLostException(string);
public DeviceLostException(string, Exception);


DeviceLostException.DeviceLostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceLostException.DeviceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceLostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DeviceLostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DeviceLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


DeviceLostException.DeviceLostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceLostException.DeviceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceLostException(
string message,
Exception inner
);
Managed C++ public: DeviceLostException(
String *message,
Exception *inner
);
JScript .NET public function DeviceLostException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


DeviceLostException.DeviceLostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceLostException.DeviceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DeviceLostException(
string message
);
Managed C++ public: DeviceLostException(
String *message
);
JScript .NET public function DeviceLostException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


DeviceLostException.DeviceLostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceLostException.DeviceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceLostException();
Managed C++ | public: DeviceLostException();
JScript .NET | public function DeviceLostException();


Microsoft.DirectX.Direct3D.DeviceNotResetException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotResetException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device has been lost but can be reset at this time.

Definition

Visual Basic .NET Public Class DeviceNotResetException
Inherits GraphicsException
C# | public class DeviceNotResetException : GraphicsException
Managed C++ | public __gc class DeviceNotResetException : public GraphicsException
JScript .NET | public class DeviceNotResetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceNotResetException | Initializes a new instance of the DeviceNotResetException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DeviceNotResetException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceNotResetException.DeviceNotResetException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotResetException.DeviceNotResetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceNotResetException class.

Overload List

public DeviceNotResetException();
protected DeviceNotResetException(SerializationInfo, StreamingContext);
public DeviceNotResetException(string);
public DeviceNotResetException(string, Exception);


DeviceNotResetException.DeviceNotResetException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotResetException.DeviceNotResetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceNotResetException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DeviceNotResetException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DeviceNotResetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


DeviceNotResetException.DeviceNotResetException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotResetException.DeviceNotResetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceNotResetException(
string message,
Exception inner
);
Managed C++ public: DeviceNotResetException(
String *message,
Exception *inner
);
JScript .NET public function DeviceNotResetException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


DeviceNotResetException.DeviceNotResetException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotResetException.DeviceNotResetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DeviceNotResetException(
string message
);
Managed C++ public: DeviceNotResetException(
String *message
);
JScript .NET public function DeviceNotResetException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


DeviceNotResetException.DeviceNotResetException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotResetException.DeviceNotResetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceNotResetException();
Managed C++ | public: DeviceNotResetException();
JScript .NET | public function DeviceNotResetException();


Microsoft.DirectX.Direct3D.Direct3DXException

Microsoft DirectX 9.0 SDK Update (October 2004)

Direct3DXException Class

Language:
Note: This documentation is preliminary and is subject to change.

Base exception class for D3DX. Derives from DirectXException.

Definition

Visual Basic .NET Public Class Direct3DXException
Inherits DirectXException
C# | public class Direct3DXException : DirectXException
Managed C++ | public __gc class Direct3DXException : public DirectXException
JScript .NET | public class Direct3DXException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
Direct3DXException | Initializes a new instance of the Direct3DXException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
CannotAttributeSortException
CannotModifyIndexBufferException
DuplicateNamedFragmentException
InvalidDataException
InvalidMeshException
LoadedMeshHasNoDataException
SkinningNotSupportedException
TooManyInfluencesException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Direct3DXException.Direct3DXException

Microsoft DirectX 9.0 SDK Update (October 2004)

Direct3DXException.Direct3DXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Direct3DXException class.

Overload List

public Direct3DXException();
protected Direct3DXException(SerializationInfo, StreamingContext);
public Direct3DXException(string);
public Direct3DXException(string, Exception);


Direct3DXException.Direct3DXException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

Direct3DXException.Direct3DXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Direct3DXException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: Direct3DXException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function Direct3DXException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


Direct3DXException.Direct3DXException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

Direct3DXException.Direct3DXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Direct3DXException(
string message,
Exception inner
);
Managed C++ public: Direct3DXException(
String *message,
Exception *inner
);
JScript .NET public function Direct3DXException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


Direct3DXException.Direct3DXException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Direct3DXException.Direct3DXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public Direct3DXException(
string message
);
Managed C++ public: Direct3DXException(
String *message
);
JScript .NET public function Direct3DXException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


Direct3DXException.Direct3DXException()

Microsoft DirectX 9.0 SDK Update (October 2004)

Direct3DXException.Direct3DXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Direct3DXException();
Managed C++ | public: Direct3DXException();
JScript .NET | public function Direct3DXException();


Direct3DXException.GetExceptionFromResultInternal(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Direct3DXException.GetExceptionFromResultInternal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an Exception Leave Site object that represents the result code passed in.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32. Integer that represents the result code of the exception.

Return Value

System.Exception . An Exception Leave Site object that represents the error that occurred.

Applies To

CannotAttributeSortException, CannotModifyIndexBufferException, DuplicateNamedFragmentException, InvalidDataException, InvalidMeshException, LoadedMeshHasNoDataException, SkinningNotSupportedException, TooManyInfluencesException


Microsoft.DirectX.Direct3D.DisplayModeCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates a collection of DisplayMode structures.

Definition

Visual Basic .NET NotInheritable Public Class DisplayModeCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class DisplayModeCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class DisplayModeCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class DisplayModeCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetEnumerator | Returns an enumerator that can iterate through the DisplayModeCollection.
GetHashCode | Returns the hash code for the current instance.
MoveNext | Advances the enumerator to the next DisplayMode.
Reset | Resets the current enumerator to point to the head of the queue.

Properties

Property | Description
Count | Retrieves the number of DisplayMode structures in DisplayModeCollection.
Current | Retrieves the current DisplayMode object in the queue.
Item | Retrieves the DisplayMode structure with the specified Format.

Inheritance Hierarchy

Object Leave Site
DisplayModeCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisplayModeCollection.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


DisplayModeCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an enumerator that can iterate through the DisplayModeCollection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator . Enumerator that can iterate through the DisplayModeCollection.


DisplayModeCollection.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


DisplayModeCollection.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next DisplayMode.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean . Value that is true if the move to the next item was successful, or false if it was not.


DisplayModeCollection.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the current enumerator to point to the head of the queue.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the queue.

After Reset Leave Site is called, the cursor is undefined. Call MoveNext Leave Site initially to point to the first item in the list.


DisplayModeCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of DisplayMode structures in DisplayModeCollection.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 . Number of DisplayMode structures in DisplayModeCollection.

This property is read-only.


DisplayModeCollection.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current DisplayMode object in the queue.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object . Current DisplayMode object in the queue as an Object Leave Site.

This property is read-only.


DisplayModeCollection.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModeCollection.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the DisplayMode structure with the specified Format.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal f As Format _
) As DisplayModeCollection
C# public DisplayModeCollection this[
Format f
] { get; }
Managed C++ public: __property DisplayModeCollection* get_Item(
Format f
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.Direct3D.DisplayModeCollection .

This property is read-only.

Parameters

f Microsoft.DirectX.Direct3D.Format. A Format flag that indicates the format of the DisplayMode to retrieve.


Microsoft.DirectX.Direct3D.DriverInternalErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInternalErrorException Class

Language:
Note: This documentation is preliminary and is subject to change.

Internal driver error. Applications should generally shut down when receiving this error.

Definition

Visual Basic .NET Public Class DriverInternalErrorException
Inherits GraphicsException
C# | public class DriverInternalErrorException : GraphicsException
Managed C++ | public __gc class DriverInternalErrorException : public GraphicsException
JScript .NET | public class DriverInternalErrorException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DriverInternalErrorException | Initializes a new instance of the DriverInternalErrorException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DriverInternalErrorException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DriverInternalErrorException.DriverInternalErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInternalErrorException class.

Overload List

public DriverInternalErrorException();
protected DriverInternalErrorException(SerializationInfo, StreamingContext);
public DriverInternalErrorException(string);
public DriverInternalErrorException(string, Exception);


DriverInternalErrorException.DriverInternalErrorException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DriverInternalErrorException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DriverInternalErrorException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DriverInternalErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


DriverInternalErrorException.DriverInternalErrorException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DriverInternalErrorException(
string message,
Exception inner
);
Managed C++ public: DriverInternalErrorException(
String *message,
Exception *inner
);
JScript .NET public function DriverInternalErrorException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


DriverInternalErrorException.DriverInternalErrorException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DriverInternalErrorException(
string message
);
Managed C++ public: DriverInternalErrorException(
String *message
);
JScript .NET public function DriverInternalErrorException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


DriverInternalErrorException.DriverInternalErrorException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DriverInternalErrorException();
Managed C++ | public: DriverInternalErrorException();
JScript .NET | public function DriverInternalErrorException();


Microsoft.DirectX.Direct3D.DriverInvalidCallException

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInvalidCallException Class

Language:
Note: This documentation is preliminary and is subject to change.

The driver reports that the current method call is invalid.

Definition

Visual Basic .NET Public Class DriverInvalidCallException
Inherits GraphicsException
C# | public class DriverInvalidCallException : GraphicsException
Managed C++ | public __gc class DriverInvalidCallException : public GraphicsException
JScript .NET | public class DriverInvalidCallException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DriverInvalidCallException | Initializes a new instance of the DriverInvalidCallException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DriverInvalidCallException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DriverInvalidCallException.DriverInvalidCallException

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInvalidCallException class.

Overload List

public DriverInvalidCallException();
protected DriverInvalidCallException(SerializationInfo, StreamingContext);
public DriverInvalidCallException(string);
public DriverInvalidCallException(string, Exception);


DriverInvalidCallException.DriverInvalidCallException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DriverInvalidCallException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DriverInvalidCallException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DriverInvalidCallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


DriverInvalidCallException.DriverInvalidCallException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DriverInvalidCallException(
string message,
Exception inner
);
Managed C++ public: DriverInvalidCallException(
String *message,
Exception *inner
);
JScript .NET public function DriverInvalidCallException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


DriverInvalidCallException.DriverInvalidCallException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DriverInvalidCallException(
string message
);
Managed C++ public: DriverInvalidCallException(
String *message
);
JScript .NET public function DriverInvalidCallException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


DriverInvalidCallException.DriverInvalidCallException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DriverInvalidCallException();
Managed C++ | public: DriverInvalidCallException();
JScript .NET | public function DriverInvalidCallException();


Microsoft.DirectX.Direct3D.DuplicateNamedFragmentException

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateNamedFragmentException Class

Language:
Note: This documentation is preliminary and is subject to change.

There is a duplicate named fragment.

Definition

Visual Basic .NET Public Class DuplicateNamedFragmentException
Inherits Direct3DXException
C# | public class DuplicateNamedFragmentException : Direct3DXException
Managed C++ | public __gc class DuplicateNamedFragmentException : public Direct3DXException
JScript .NET | public class DuplicateNamedFragmentException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DuplicateNamedFragmentException | Initializes a new instance of the DuplicateNamedFragmentException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
DuplicateNamedFragmentException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DuplicateNamedFragmentException.DuplicateNamedFragmentException

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DuplicateNamedFragmentException class.

Overload List

public DuplicateNamedFragmentException();
protected DuplicateNamedFragmentException(SerializationInfo, StreamingContext);
public DuplicateNamedFragmentException(string);
public DuplicateNamedFragmentException(string, Exception);


DuplicateNamedFragmentException.DuplicateNamedFragmentException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DuplicateNamedFragmentException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DuplicateNamedFragmentException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DuplicateNamedFragmentException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


DuplicateNamedFragmentException.DuplicateNamedFragmentException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DuplicateNamedFragmentException(
string message,
Exception inner
);
Managed C++ public: DuplicateNamedFragmentException(
String *message,
Exception *inner
);
JScript .NET public function DuplicateNamedFragmentException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


DuplicateNamedFragmentException.DuplicateNamedFragmentException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DuplicateNamedFragmentException(
string message
);
Managed C++ public: DuplicateNamedFragmentException(
String *message
);
JScript .NET public function DuplicateNamedFragmentException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


DuplicateNamedFragmentException.DuplicateNamedFragmentException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DuplicateNamedFragmentException();
Managed C++ | public: DuplicateNamedFragmentException();
JScript .NET | public function DuplicateNamedFragmentException();


Microsoft.DirectX.Direct3D.Effect

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Used to set and query effects and choose techniques.

Definition

Visual Basic .NET NotInheritable Public Class Effect
Inherits BaseEffect
C# | public sealed class Effect : BaseEffect
Managed C++ | public __gc __sealed class Effect : public BaseEffect
JScript .NET | public class Effect extends BaseEffect

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Effect object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally just before a device is reset.
Reset | Occurs after the Effect.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
ApplyParameterBlock | Assigns a state value to each effect parameter in a parameter block.
Begin | Begins the application of an effect technique.
BeginParameterBlock | Captures parameter effect state changes.
BeginPass | Applies the state settings for the specified pass of a technique.
Clone | Creates a clone of an effect.
CommitChanges | Propagates the state change that occurs inside of an active pass to the device before rendering.
Disassemble | Disassembles an effect.
Dispose | Immediately releases the unmanaged resources used by the Effect object.
Effect | Initializes a new instance of the Effect class.
End | Ends the application of the current effect technique.
EndParameterBlock | Stops the capturing of effect parameter state changes.
EndPass | Signals the end of an effect pass.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseEffect object to free resources before it is destroyed by the garbage collector. Inherited from BaseEffect.
FindNextValidTechnique | Searches for the next valid technique, starting at the technique after the one specified.
static (Shared in Visual Basic .NET) FromFile | Creates an effect from an ASCII or binary effect description.
static (Shared in Visual Basic .NET) FromStream | Creates an effect from an ASCII or binary effect description.
static (Shared in Visual Basic .NET) FromString | Creates an effect from an ASCII or binary effect description in a string.
GetAnnotation | Retrieves an annotation. Inherited from BaseEffect.
GetFunction | Retrieves a function. Inherited from BaseEffect.
GetFunctionDescription | Retrieves a function description. Inherited from BaseEffect.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetParameter | Retrieves a top-level parameter or a structure member parameter. Inherited from BaseEffect.
GetParameterBySemantic | Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic. Inherited from BaseEffect.
GetParameterDescription | Retrieves a parameter or annotation description. Inherited from BaseEffect.
GetParameterElement | Retrieves the EffectHandle of an array element parameter. Inherited from BaseEffect.
GetPass | Retrieves the EffectHandle of a pass. Inherited from BaseEffect.
GetPassDescription | Retrieves a pass description. Inherited from BaseEffect.
GetTechnique | Retrieves the EffectHandle of a technique. Inherited from BaseEffect.
GetTechniqueDescription | Retrieves a technique description. Inherited from BaseEffect.
GetValue | Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures. Inherited from BaseEffect.
GetValueBoolean | Retrieves a Boolean value. Inherited from BaseEffect.
GetValueBooleanArray | Retrieves an array of Boolean values. Inherited from BaseEffect.
GetValueColor | Retrieves a ColorValue structure. Inherited from BaseEffect.
GetValueColorArray | Retrieves an array of ColorValue structures. Inherited from BaseEffect.
GetValueFloat | Retrieves a floating-point value. Inherited from BaseEffect.
GetValueFloatArray | Retrieves an array of floating-point values. Inherited from BaseEffect.
GetValueInteger | Retrieves an integer. Inherited from BaseEffect.
GetValueIntegerArray | Retrieves an array of integers. Inherited from BaseEffect.
GetValueMatrix | Retrieves a nontransposed matrix. Inherited from BaseEffect.
GetValueMatrixArray | Retrieves an array of nontransposed matrices. Inherited from BaseEffect.
GetValueMatrixTranspose | Retrieves a transposed matrix. Inherited from BaseEffect.
GetValueMatrixTransposeArray | Retrieves an array of transposed matrices. Inherited from BaseEffect.
GetValuePixelShader | Retrieves a pixel shader. Inherited from BaseEffect.
GetValueString | Retrieves a string. Inherited from BaseEffect.
GetValueTexture | Retrieves a texture. Inherited from BaseEffect.
GetValueVector | Retrieves a vector. Inherited from BaseEffect.
GetValueVectorArray | Retrieves an array of vectors. Inherited from BaseEffect.
GetValueVertexShader | Retrieves a vertex shader. Inherited from BaseEffect.
IsParameterUsed | Determines whether a parameter is used by a technique.
IsTechniqueValid | Validates a technique.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseEffect.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseEffect.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Effect.Disposing event when called from within a derived class.
raise_Lost | Raises an Effect.Lost event when called from within a derived class.
raise_Reset | Raises an Effect.Reset event when called from within a derived class.
SetArrayRange | Sets the range of an array to pass to the device.
SetValueTranspose | Sets a transposed matrix. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Effect object. This method supports the Framework infrastructure and is not intended to be used directly in your code.
ValidateTechnique | Validates a technique.

Properties

Property | Description
Description | Retrieves an effect description. Inherited from BaseEffect.
Device | Retrieves the device associated with an effect.
Disposed | Gets a value that indicates whether the object is disposed.
Pool | Retrieves an effect pool object that represents the pool of shared parameters.
StateManager | Retrieves or sets the EffectStateManager object for this effect.
Technique | Retreives and sets the active technique.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer. Inherited from BaseEffect.
UnmanagedComPointer | Returns the unmanaged COM ID3DXEffect interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseEffect
Effect

Remarks

An effect object can contain multiple techniques to render the same effect.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Effect.ApplyParameterBlock(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.ApplyParameterBlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assigns a state value to each effect parameter in a parameter block.

Definition

Visual Basic .NET Public Sub ApplyParameterBlock( _
ByVal parameterBlock As EffectHandle _
)
C# public void ApplyParameterBlock(
EffectHandle parameterBlock
);
Managed C++ public: void ApplyParameterBlock(
EffectHandle *parameterBlock
);
JScript .NET public function ApplyParameterBlock(
parameterBlock : EffectHandle
);

Parameters

parameterBlock Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that is returned by Effect.EndParameterBlock.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Effect.Begin(FX)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Begin Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Begins the application of an effect technique.

Definition

Visual Basic .NET Public Function Begin( _
ByVal flags As FX _
) As Integer
C# public int Begin(
FX flags
);
Managed C++ public: int Begin(
FX flags
);
JScript .NET public function Begin(
flags : FX
) : int;

Parameters

flags Microsoft.DirectX.Direct3D.FX. One or more FX enumerated values that determine whether state modified by an effect will be saved and restored. The default value, 0, specifies that Effect.Begin and Effect.End will save and restore all state modified by the effect (including pixel and vertex shader constants). DoNotSaveShaderState indicates that shader device state will not be saved or restored; DoNotSaveState indicates that device state will not be saved or restored.

Return Value

System.Int32 . An integer value that indicates the number of passes needed to render the current effect technique.

Remarks

This method returns the number of passes needed to render the current effect technique. The application must incrementally call Effect.BeginPass for each pass before drawing the geometry to which the effect needs to be applied, followed by a call to Effect.EndPass. After all passes are rendered, Effect.End must be called.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}


Effect.BeginParameterBlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.BeginParameterBlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Captures parameter effect state changes.

Definition

Visual Basic .NET | Public Sub BeginParameterBlock()
C# | public void BeginParameterBlock();
Managed C++ | public: void BeginParameterBlock();
JScript .NET | public function BeginParameterBlock();

Remarks

This method captures effect parameter state changes until Effect.EndParameterBlock is called. Effect parameters include any state changes outside of a pass.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Effect.BeginPass(Int32)

Effect.BeginPass Method

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Applies the state settings for the specified pass of a technique.

Definition

Visual Basic .NET Public Sub BeginPass( _
ByVal passNumber As Integer _
)
C# public void BeginPass(
int passNumber
);
Managed C++ public: void BeginPass(
int passNumber
);
JScript .NET public function BeginPass(
passNumber : int
);

Parameters

passNumber System.Int32. An integer that identifies the pass to apply. This value is returned by Effect.Begin, which must be called before rendering an effect.

Remarks

Before entering the rendering loop for the effect, Effect.Begin must be called to obtain the number of effect passes.

After calling Effect.BeginPass, the application must draw the geometry to the device to which the effect is set and then call Effect.EndPass.

After all passes are rendered, Effect.End must be called.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.End
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.Clone(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a clone of an effect.

Definition

Visual Basic .NET Public Function Clone( _
ByVal dev As Device _
) As Effect
C# public Effect Clone(
Device dev
);
Managed C++ public: Effect* Clone(
Device *dev
);
JScript .NET public function Clone(
dev : Device
) : Effect;

Parameters

dev Microsoft.DirectX.Direct3D.Device. The Device associated with the effect.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect object that contains the cloned effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Effect.CommitChanges()

Effect.CommitChanges Method

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Propagates the state change that occurs inside of an active pass to the device before rendering.

Definition

Visual Basic .NET | Public Sub CommitChanges()
C# | public void CommitChanges();
Managed C++ | public: void CommitChanges();
JScript .NET | public function CommitChanges();

Remarks

If the application changes any effect state using the Effect class members that modify state, such as Effect.StateManager, inside of an Effect.BeginPass/Effect.EndPass matching pair, the application must call Effect.CommitChanges before any of the various Device.DrawPrimitives methods are called to propagate state changes to the device before rendering. If no state changes occur within an Effect.BeginPass/Effect.EndPass matching pair, it is not necessary to call Effect.CommitChanges.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.Disassemble

Effect.Disassemble Method

Note: This documentation is preliminary and is subject to change.

Disassembles an effect.

Overload List

public string Disassemble(bool);
public static string Disassemble(Effect, bool);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.Disassemble(Boolean)

Effect.Disassemble Method

Note: This documentation is preliminary and is subject to change.

Disassembles an effect.

Definition

Visual Basic .NET Public Function Disassemble( _
ByVal enableColorCode As Boolean _
) As String
C# public string Disassemble(
bool enableColorCode
);
Managed C++ public: String* Disassemble(
bool enableColorCode
);
JScript .NET public function Disassemble(
enableColorCode : boolean
) : String;

Parameters

enableColorCode System.Boolean. Set to true to enable color coding to make the disassembly easier to read. Set to false for no color coding.

Return Value

System.String . A string that contains the disassembled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.Disassemble(Effect,Boolean)

Effect.Disassemble Method

Note: This documentation is preliminary and is subject to change.

Disassembles an effect.

Definition

Visual Basic .NET Public Shared Function Disassemble( _
ByVal effect As Effect, _
ByVal enableColorCode As Boolean _
) As String
C# public static string Disassemble(
Effect effect,
bool enableColorCode
);
Managed C++ public: static String* Disassemble(
Effect *effect,
bool enableColorCode
);
JScript .NET public static function Disassemble(
effect : Effect,
enableColorCode : boolean
) : String;

Parameters

effect | Microsoft.DirectX.Direct3D.Effect. An Effect object that contains the effect to disassemble.
enableColorCode | System.Boolean. Set to true to enable color coding to make the disassembly easier to read. Set to false for no color coding.

Return Value

System.String . A string that contains the disassembled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Effect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Effect.Disposed
  • Microsoft.DirectX.Direct3D.Effect.Disposing


Effect.Effect

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Effect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Effect class.

Overload List

public Effect(ID3DXEffect);
public Effect(ID3DXEffect, Device);
public Effect(IntPtr);


Effect.Effect(ID3DXEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Effect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Effect class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As ID3DXEffect _
)
C# public Effect(
ID3DXEffect pInterop
);
Managed C++ public: Effect(
ID3DXEffect pInterop
);
JScript .NET public function Effect(
pInterop : ID3DXEffect
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect. Unmanaged Component Object Model (COM) ID3DXEffect interface pointer.


Effect.Effect(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Effect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Effect class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Effect(
IntPtr unmanagedObject
);
Managed C++ public: Effect(
IntPtr unmanagedObject
);
JScript .NET public function Effect(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXEffect interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Effect.Effect(ID3DXEffect,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Effect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Effect class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pData As ID3DXEffect, _
ByVal device As Device _
)
C# public Effect(
ID3DXEffect pData,
Device device
);
Managed C++ public: Effect(
ID3DXEffect pData,
Device *device
);
JScript .NET public function Effect(
pData : ID3DXEffect,
device : Device
);

Parameters

pData | Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect. Unmanaged Component Object Model (COM) ID3DXEffect interface pointer.
device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the Effect object.


Effect.End()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.End Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Ends the application of the current effect technique.

Definition

Visual Basic .NET | Public Sub End()
C# | public void End();
Managed C++ | public: void End();
JScript .NET | public function End();

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.Begin
  • Effect.BeginPass


Effect.EndParameterBlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.EndParameterBlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Stops the capturing of effect parameter state changes.

Definition

Visual Basic .NET | Public Function EndParameterBlock() As EffectHandle
C# | public EffectHandle EndParameterBlock();
Managed C++ | public: EffectHandle* EndParameterBlock();
JScript .NET | public function EndParameterBlock() : EffectHandle;

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle for the parameter state block.

Remarks

To start capturing effect parameter state changes, call Effect.BeginParameterBlock. All effect parameters that change state (before Effect.EndParameterBlock is called) are saved in an effect parameter state block, and then Effect.ApplyParameterBlock is used to apply this block of state changes to effect parameters. Effect parameters include any state changes outside of a pass.


Effect.EndPass()

Effect.EndPass Method

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Signals the end of an effect pass.

Definition

Visual Basic .NET | Public Sub EndPass()
C# | public void EndPass();
Managed C++ | public: void EndPass();
JScript .NET | public function EndPass();

Remarks

After calling Effect.BeginPass, the application must draw the geometry to the device to which the effect is set and then call Effect.EndPass.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.BeginPass
  • Effect.Begin
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Effect.FindNextValidTechnique(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FindNextValidTechnique Method

 Language:
Note: This documentation is preliminary and is subject to change.

Searches for the next valid technique, starting at the technique after the one specified.

Definition

Visual Basic .NET Public Function FindNextValidTechnique( _
ByVal technique As EffectHandle _
) As EffectHandle
C# public EffectHandle FindNextValidTechnique(
EffectHandle technique
);
Managed C++ public: EffectHandle* FindNextValidTechnique(
EffectHandle *technique
);
JScript .NET public function FindNextValidTechnique(
technique : EffectHandle
) : EffectHandle;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle. Unique identifier of a technique. For more information, see EffectHandle. Specify null for this parameter to find the first valid technique.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle object that identifies the next technique, or null if the current technique is the last.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Effect.ValidateTechnique
  • TechniqueDescription


Effect.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Overload List

public static Effect FromFile(Device, string, Include, ShaderFlags, EffectPool);
public static Effect FromFile(Device, string, Include, ShaderFlags, EffectPool, out string);
public static Effect FromFile(Device, string, Macro[], Include, ShaderFlags, EffectPool, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromFile(Device,String,Include,ShaderFlags,EffectPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal sourceDataFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool _
) As Effect
C# public static Effect FromFile(
Device device,
string sourceDataFile,
Include includeFile,
ShaderFlags flags,
EffectPool pool
);
Managed C++ public: static Effect* FromFile(
Device *device,
String *sourceDataFile,
Include *includeFile,
ShaderFlags flags,
EffectPool *pool
);
JScript .NET public static function FromFile(
device : Device,
sourceDataFile : String,
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that creates the effect.
sourceDataFile | System.String. A String Leave Site object that indicates the file name.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromFile(Device,String,Include,ShaderFlags,EffectPool,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal sourceDataFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromFile(
Device device,
string sourceDataFile,
Include includeFile,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
Managed C++ public: static Effect* FromFile(
Device *device,
String *sourceDataFile,
Include *includeFile,
ShaderFlags flags,
EffectPool *pool,
String **compilationErrors
);
JScript .NET public static function FromFile(
device : Device,
sourceDataFile : String,
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that creates the effect.
sourceDataFile | System.String. A String Leave Site object that indicates the file name.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromFile(Device,String,Macro[],Include,ShaderFlags,EffectPool,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal sourceDataFile As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromFile(
Device device,
string sourceDataFile,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
Managed C++ public: static Effect* FromFile(
Device *device,
String *sourceDataFile,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
EffectPool *pool,
String **compilationErrors
);
JScript .NET public static function FromFile(
device : Device,
sourceDataFile : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that creates the effect.
sourceDataFile | System.String. A String Leave Site object that indicates the file name.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description.

Overload List

public static Effect FromStream(Device, Stream, Include, ShaderFlags, EffectPool);
public static Effect FromStream(Device, Stream, Include, ShaderFlags, EffectPool, out string);
public static Effect FromStream(Device, Stream, Macro[], Include, ShaderFlags, EffectPool, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromStream(Device,Stream,Include,ShaderFlags,EffectPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool _
) As Effect
C# public static Effect FromStream(
Device device,
Stream data,
Include includeFile,
ShaderFlags flags,
EffectPool pool
);
Managed C++ public: static Effect* FromStream(
Device *device,
Stream *data,
Include *includeFile,
ShaderFlags flags,
EffectPool *pool
);
JScript .NET public static function FromStream(
device : Device,
data : Stream,
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that will create the effect.
data | System.IO.Stream. A Stream Leave Site object that contains the data used to create the Effect.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromStream(Device,Stream,Include,ShaderFlags,EffectPool,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromStream(
Device device,
Stream data,
Include includeFile,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
Managed C++ public: static Effect* FromStream(
Device *device,
Stream *data,
Include *includeFile,
ShaderFlags flags,
EffectPool *pool,
String **compilationErrors
);
JScript .NET public static function FromStream(
device : Device,
data : Stream,
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that will create the effect.
data | System.IO.Stream. A Stream Leave Site object that contains the data used to create the Effect.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromStream(Device,Stream,Macro[],Include,ShaderFlags,EffectPool,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromStream(
Device device,
Stream data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
Managed C++ public: static Effect* FromStream(
Device *device,
Stream *data,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
EffectPool *pool,
String **compilationErrors
);
JScript .NET public static function FromStream(
device : Device,
data : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that will create the effect.
data | System.IO.Stream. A Stream Leave Site object that contains the data used to create the Effect.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromString

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description in a string.

Overload List

public static Effect FromString(Device, string, Include, ShaderFlags, EffectPool);
public static Effect FromString(Device, string, Include, ShaderFlags, EffectPool, out string);
public static Effect FromString(Device, string, Macro[], Include, ShaderFlags, EffectPool, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Effect.FromString(Device,String,Include,ShaderFlags,EffectPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description in a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal device As Device, _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool _
) As Effect
C# public static Effect FromString(
Device device,
string sourceData,
Include includeFile,
ShaderFlags flags,
EffectPool pool
);
Managed C++ public: static Effect* FromString(
Device *device,
String *sourceData,
Include *includeFile,
ShaderFlags flags,
EffectPool *pool
);
JScript .NET public static function FromString(
device : Device,
sourceData : String,
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that will create the effect.
sourceData | System.String. A String Leave Site that describes the Effect to create.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Effect.FromString(Device,String,Include,ShaderFlags,EffectPool,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description in a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal device As Device, _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromString(
Device device,
string sourceData,
Include includeFile,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
Managed C++ public: static Effect* FromString(
Device *device,
String *sourceData,
Include *includeFile,
ShaderFlags flags,
EffectPool *pool,
String **compilationErrors
);
JScript .NET public static function FromString(
device : Device,
sourceData : String,
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that will create the effect.
sourceData | System.String. A String Leave Site that describes the Effect to create.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Effect.FromString(Device,String,Macro[],Include,ShaderFlags,EffectPool,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect from an ASCII or binary effect description in a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal device As Device, _
ByVal sourceData As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromString(
Device device,
string sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
Managed C++ public: static Effect* FromString(
Device *device,
String *sourceData,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
EffectPool *pool,
String **compilationErrors
);
JScript .NET public static function FromString(
device : Device,
sourceData : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device that will create the effect.
sourceData | System.String. A String Leave Site that describes the Effect to create.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Optional null-terminated array of preprocessor macro definitions. For more information, see Macro.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
pool | Microsoft.DirectX.Direct3D.EffectPool. An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect . An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Effect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Effect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXEffect, which allows unmanaged COM clients to create an instance of the managed Effect class. Not supported.


Effect.IsParameterUsed(EffectHandle,EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.IsParameterUsed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a parameter is used by a technique.

Definition

Visual Basic .NET Public Function IsParameterUsed( _
ByVal parameter As EffectHandle, _
ByVal technique As EffectHandle _
) As Boolean
C# public bool IsParameterUsed(
EffectHandle parameter,
EffectHandle technique
);
Managed C++ public: bool IsParameterUsed(
EffectHandle *parameter,
EffectHandle *technique
);
JScript .NET public function IsParameterUsed(
parameter : EffectHandle,
technique : EffectHandle
) : boolean;

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that acts as a unique identifier for the parameter.
technique | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that acts as a unique identifier for the technique.

Return Value

System.Boolean . Value that is true if the parameter is being used, or false if it is not being used.


Effect.IsTechniqueValid

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.IsTechniqueValid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a technique.

Overload List

public bool IsTechniqueValid(EffectHandle);
public bool IsTechniqueValid(EffectHandle, out int);


Effect.IsTechniqueValid(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.IsTechniqueValid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a technique.

Definition

Visual Basic .NET Public Function IsTechniqueValid( _
ByVal technique As EffectHandle _
) As Boolean
C# public bool IsTechniqueValid(
EffectHandle technique
);
Managed C++ public: bool IsTechniqueValid(
EffectHandle *technique
);
JScript .NET public function IsTechniqueValid(
technique : EffectHandle
) : boolean;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle of a technique.

Return Value

System.Boolean . A value that is set to true, if the technique is valid; otherwise, true.


Effect.IsTechniqueValid(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.IsTechniqueValid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a technique.

Definition

Visual Basic .NET Public Function IsTechniqueValid( _
ByVal technique As EffectHandle, _
ByRef returnValue As Integer _
) As Boolean
C# public bool IsTechniqueValid(
EffectHandle technique,
out int returnValue
);
Managed C++ public: bool IsTechniqueValid(
EffectHandle *technique,
int *returnValue
);
JScript .NET public function IsTechniqueValid(
technique : EffectHandle,
returnValue : int
) : boolean;

Parameters

technique | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle of a technique.
returnValue | System.Int32. Return code for validation.

Return Value

System.Boolean . A value that is set to true, if the technique is valid; otherwise, true.


Effect.OnLostDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.OnLostDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic .NET | Public Sub OnLostDevice()
C# | public void OnLostDevice();
Managed C++ | public: void OnLostDevice();
JScript .NET | public function OnLostDevice();

Remarks

This method should be called whenever a device is lost. Before the object can be used again, the device must be reset and the Effect.OnResetDevice method called.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Effect.OnResetDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.OnResetDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic .NET | Public Sub OnResetDevice()
C# | public void OnResetDevice();
Managed C++ | public: void OnResetDevice();
JScript .NET | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Effect.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Effect.OnResetDevice should be called immediately after the device is reset.


Effect.op_Equality(Effect,Effect)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Effect, _
ByVal right As Effect _
) As Boolean
C# public static bool op_Equality(
Effect left,
Effect right
);
Managed C++ public: static bool op_Equality(
Effect *left,
Effect *right
);
JScript .NET public static function op_Equality(
left : Effect,
right : Effect
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Effect. The Effect object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Effect. The Effect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Effect.op_Inequality(Effect,Effect)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Effect, _
ByVal right As Effect _
) As Boolean
C# public static bool op_Inequality(
Effect left,
Effect right
);
Managed C++ public: static bool op_Inequality(
Effect *left,
Effect *right
);
JScript .NET public static function op_Inequality(
left : Effect,
right : Effect
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Effect. The Effect object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Effect. The Effect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Effect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Effect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Effect.raise_Lost(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.raise_Lost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises an Effect.Lost event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Lost(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Effect.raise_Reset(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.raise_Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises an Effect.Reset event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Reset(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Effect.SetArrayRange(EffectHandle,Int32,Int32)

Effect.SetArrayRange Method

Note: This documentation is preliminary and is subject to change.

Sets the range of an array to pass to the device.

Definition

Visual Basic .NET Public Sub SetArrayRange( _
ByVal parameter As EffectHandle, _
ByVal start As Integer, _
ByVal end As Integer _
)
C# public void SetArrayRange(
EffectHandle parameter,
int start,
int end
);
Managed C++ public: void SetArrayRange(
EffectHandle *parameter,
int start,
int end
);
JScript .NET public function SetArrayRange(
parameter : EffectHandle,
start : int,
end : int
);

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the effect.
start | System.Int32. The array starting index.
end | System.Int32. The array ending index.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.UpdateUnmanagedPointer(ID3DXEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Effect object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXEffect _
)
C# public void UpdateUnmanagedPointer(
ID3DXEffect pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXEffect pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXEffect
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect. Pointer to the ID3DXEffect structure used to update the unmanaged pointer for this Effect object.


Effect.ValidateTechnique(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.ValidateTechnique Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a technique.

Definition

Visual Basic .NET Public Sub ValidateTechnique( _
ByVal technique As EffectHandle _
)
C# public void ValidateTechnique(
EffectHandle technique
);
Managed C++ public: void ValidateTechnique(
EffectHandle *technique
);
JScript .NET public function ValidateTechnique(
technique : EffectHandle
);

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object used as a unique identifier for the effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Effect.Technique


Effect.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the device associated with an effect.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object associated with the effect.

This property is read-only.


Effect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Effect.Pool

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Pool Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an effect pool object that represents the pool of shared parameters.

Definition

Visual Basic .NET | Public ReadOnly Property Pool As EffectPool
C# | public EffectPool Pool { get; }
Managed C++ | public: __property EffectPool* get_Pool();
JScript .NET | public function get Pool() : EffectPool

Property Value

Microsoft.DirectX.Direct3D.EffectPool . An EffectPool object that represents the pool of shared parameters.

This property is read-only.

Remarks

Pools contain parameters that are shared between effects.


Effect.StateManager

Effect.StateManager Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the EffectStateManager object for this effect.

Definition

Visual Basic .NET | Public Property StateManager As EffectStateManager
C# | public EffectStateManager StateManager { get; set; }
Managed C++ public: __property EffectStateManager* get_StateManager();
public: __property void set_StateManager(EffectStateManager*);
JScript .NET public function get StateManager() : EffectStateManager
public function set StateManager(EffectStateManager);

Property Value

Microsoft.DirectX.Direct3D.EffectStateManager . An EffectStateManager object to set or retrieve.

This property is read/write.

Remarks

EffectStateManager is a user-implemented class whose methods are used as callbacks to the application during effect rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Effect.Technique

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Technique Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Using an Effect

Retreives and sets the active technique.

Definition

Visual Basic .NET | Public Property Technique As EffectHandle
C# | public EffectHandle Technique { get; set; }
Managed C++ public: __property EffectHandle* get_Technique();
public: __property void set_Technique(EffectHandle*);
JScript .NET public function get Technique() : EffectHandle
public function set Technique(EffectHandle);

Property Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle object that is a unique identifier for the active technique.

This property is read/write.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}


Effect.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXEffect interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXEffect
C# | public ID3DXEffect UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXEffect get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXEffect

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect . Unmanaged ID3DXEffect interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Effect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Effect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Effect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Effect object indicates whether that object has been disposed.


Effect.Lost

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Lost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when an object is lost, normally just before a device is reset.

Definition

Visual Basic .NET | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
Managed C++ | public: __event EventHandler Lost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Effect.Lost event, use the following C# code.

[C#]
effect.Lost += new System.EventHandler(this.LostEventHandler);


Effect.Reset

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Reset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after the Effect.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic .NET | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
Managed C++ | public: __event EventHandler Reset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Effect.Reset event, use the following C# code.

[C#]
effect.Reset += new System.EventHandler(this.ResetEventHandler);


Microsoft.DirectX.Direct3D.EffectCompiler

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler Class

Language:
Note: This documentation is preliminary and is subject to change.

Compiles an effect from a function or vertex shader.

Definition

Visual Basic .NET NotInheritable Public Class EffectCompiler
Inherits BaseEffect
C# | public sealed class EffectCompiler : BaseEffect
Managed C++ | public __gc __sealed class EffectCompiler : public BaseEffect
JScript .NET | public class EffectCompiler extends BaseEffect

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the EffectCompiler object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
CompileEffect | Compiles an effect.
CompileShader | Compiles a shader from an effect that contains one or more functions.
Dispose | Immediately releases the unmanaged resources used by the BaseEffect object. Inherited from BaseEffect.
EffectCompiler | Initializes a new instance of the EffectCompiler class.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseEffect object to free resources before it is destroyed by the garbage collector. Inherited from BaseEffect.
static (Shared in Visual Basic .NET) FromFile | Creates an effect compiler from an ASCII or binary effect description.
static (Shared in Visual Basic .NET) FromStream | Creates an effect compiler from an ASCII or binary effect description in a stream.
static (Shared in Visual Basic .NET) FromString | Creates an effect compiler from an ASCII or binary effect description in a string.
GetAnnotation | Retrieves an annotation. Inherited from BaseEffect.
GetFunction | Retrieves a function. Inherited from BaseEffect.
GetFunctionDescription | Retrieves a function description. Inherited from BaseEffect.
GetHashCode | Returns the hash code for the current instance.
GetLiteral | Retrieves a literal status of a parameter.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetParameter | Retrieves a top-level parameter or a structure member parameter. Inherited from BaseEffect.
GetParameterBySemantic | Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic. Inherited from BaseEffect.
GetParameterDescription | Retrieves a parameter or annotation description. Inherited from BaseEffect.
GetParameterElement | Retrieves the EffectHandle of an array element parameter. Inherited from BaseEffect.
GetPass | Retrieves the EffectHandle of a pass. Inherited from BaseEffect.
GetPassDescription | Retrieves a pass description. Inherited from BaseEffect.
GetTechnique | Retrieves the EffectHandle of a technique. Inherited from BaseEffect.
GetTechniqueDescription | Retrieves a technique description. Inherited from BaseEffect.
GetValue | Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures. Inherited from BaseEffect.
GetValueBoolean | Retrieves a Boolean value. Inherited from BaseEffect.
GetValueBooleanArray | Retrieves an array of Boolean values. Inherited from BaseEffect.
GetValueColor | Retrieves a ColorValue structure. Inherited from BaseEffect.
GetValueColorArray | Retrieves an array of ColorValue structures. Inherited from BaseEffect.
GetValueFloat | Retrieves a floating-point value. Inherited from BaseEffect.
GetValueFloatArray | Retrieves an array of floating-point values. Inherited from BaseEffect.
GetValueInteger | Retrieves an integer. Inherited from BaseEffect.
GetValueIntegerArray | Retrieves an array of integers. Inherited from BaseEffect.
GetValueMatrix | Retrieves a nontransposed matrix. Inherited from BaseEffect.
GetValueMatrixArray | Retrieves an array of nontransposed matrices. Inherited from BaseEffect.
GetValueMatrixTranspose | Retrieves a transposed matrix. Inherited from BaseEffect.
GetValueMatrixTransposeArray | Retrieves an array of transposed matrices. Inherited from BaseEffect.
GetValuePixelShader | Retrieves a pixel shader. Inherited from BaseEffect.
GetValueString | Retrieves a string. Inherited from BaseEffect.
GetValueTexture | Retrieves a texture. Inherited from BaseEffect.
GetValueVector | Retrieves a vector. Inherited from BaseEffect.
GetValueVectorArray | Retrieves an array of vectors. Inherited from BaseEffect.
GetValueVertexShader | Retrieves a vertex shader. Inherited from BaseEffect.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseEffect.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseEffect.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.EffectCompiler.Disposing event when called from within a derived class.
SetArrayRange | Sets the range of an array to pass to the device.
SetLiteral | Toggles the literal status of a parameter.
SetValueTranspose | Sets a transposed matrix. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this EffectCompiler object. This method supports the Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves an effect description. Inherited from BaseEffect.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer. Inherited from BaseEffect.
UnmanagedComPointer | Returns the unmanaged COM ID3DXEffectCompiler interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseEffect
EffectCompiler

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectCompiler.CompileEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles an effect.

Overload List

public GraphicsStream CompileEffect();
public GraphicsStream CompileEffect(ShaderFlags);
public GraphicsStream CompileEffect(ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileEffect()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles an effect.

Definition

Visual Basic .NET | Public Function CompileEffect() As GraphicsStream
C# | public GraphicsStream CompileEffect();
Managed C++ | public: GraphicsStream* CompileEffect();
JScript .NET | public function CompileEffect() : GraphicsStream;

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileEffect(ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles an effect.

Definition

Visual Basic .NET Public Function CompileEffect( _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public GraphicsStream CompileEffect(
ShaderFlags flags
);
Managed C++ public: GraphicsStream* CompileEffect(
ShaderFlags flags
);
JScript .NET public function CompileEffect(
flags : ShaderFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.ShaderFlags. One or more ShaderFlags that specify compile options, or 0.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileEffect(ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles an effect.

Definition

Visual Basic .NET Public Function CompileEffect( _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String _
) As GraphicsStream
C# public GraphicsStream CompileEffect(
ShaderFlags flags,
out string errorMessages
);
Managed C++ public: GraphicsStream* CompileEffect(
ShaderFlags flags,
String **errorMessages
);
JScript .NET public function CompileEffect(
flags : ShaderFlags,
errorMessages : String
) : GraphicsStream;

Parameters

flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more ShaderFlags that specify compile options, or 0.
errorMessages | System.String. String that contains at least the first compile error message that occurs, including effect compiler errors and high-level language compile errors.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles a shader from an effect that contains one or more functions.

Overload List

public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags);
public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags, out ConstantTable);
public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags, out string);
public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags, out string, out ConstantTable);

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic .NET Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags
);
Managed C++ public: GraphicsStream* CompileShader(
EffectHandle *functionName,
String *target,
ShaderFlags flags
);
JScript .NET public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

functionName | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target | System.String. String that identifies the shader version. See Remarks.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more ShaderFlags flags that specify compile options, or 0.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags,ConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic .NET Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags,
out ConstantTable table
);
Managed C++ public: GraphicsStream* CompileShader(
EffectHandle *functionName,
String *target,
ShaderFlags flags,
ConstantTable **table
);
JScript .NET public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags,
table : ConstantTable
) : GraphicsStream;

Parameters

functionName | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target | System.String. String that identifies the shader version. See Remarks.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more ShaderFlags flags that specify compile options, or 0.
table | Microsoft.DirectX.Direct3D.ConstantTable. A ConstantTable object that can be used to access shader constants. This value can be null.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic .NET Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags,
out string errorMessages
);
Managed C++ public: GraphicsStream* CompileShader(
EffectHandle *functionName,
String *target,
ShaderFlags flags,
String **errorMessages
);
JScript .NET public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags,
errorMessages : String
) : GraphicsStream;

Parameters

functionName | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target | System.String. String that identifies the shader version. See Remarks.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more ShaderFlags flags that specify compile options, or 0.
errorMessages | System.String. String that contains at least the first compile error message that occurred. This includes effect compiler errors and high-level language compile errors.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags,String,ConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic .NET Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
Managed C++ public: GraphicsStream* CompileShader(
EffectHandle *functionName,
String *target,
ShaderFlags flags,
String **errorMessages,
ConstantTable **table
);
JScript .NET public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

functionName | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target | System.String. String that identifies the shader version. See Remarks.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more ShaderFlags flags that specify compile options, or 0.
errorMessages | System.String. String that contains at least the first compile error message that occurred. This includes effect compiler errors and high-level language compile errors.
table | Microsoft.DirectX.Direct3D.ConstantTable. A ConstantTable object that can be used to access shader constants. This value can be null.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.EffectCompiler

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.EffectCompiler Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectCompiler class.

Overload List

public EffectCompiler(ID3DXEffectCompiler);
public EffectCompiler(IntPtr);


EffectCompiler.EffectCompiler(ID3DXEffectCompiler)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.EffectCompiler Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectCompiler class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As ID3DXEffectCompiler _
)
C# public EffectCompiler(
ID3DXEffectCompiler pInterop
);
Managed C++ public: EffectCompiler(
ID3DXEffectCompiler pInterop
);
JScript .NET public function EffectCompiler(
pInterop : ID3DXEffectCompiler
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectCompiler. Unmanaged Component Object Model (COM) ID3DXEffectCompiler interface pointer.


EffectCompiler.EffectCompiler(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.EffectCompiler Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectCompiler class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public EffectCompiler(
IntPtr unmanagedObject
);
Managed C++ public: EffectCompiler(
IntPtr unmanagedObject
);
JScript .NET public function EffectCompiler(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXEffectCompiler interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


EffectCompiler.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EffectCompiler.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description.

Overload List

public static EffectCompiler FromFile(string, Include, ShaderFlags);
public static EffectCompiler FromFile(string, Include, ShaderFlags, out string);
public static EffectCompiler FromFile(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromFile(String,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As EffectCompiler
C# public static EffectCompiler FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static EffectCompiler* FromFile(
String *sourceFile,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags
) : EffectCompiler;

Parameters

sourceFile | System.String. String that indicates the file name.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromFile(String,Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static EffectCompiler* FromFile(
String *sourceFile,
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceFile | System.String. String that indicates the file name.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromFile(String,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromFile(
string sourceFile,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static EffectCompiler* FromFile(
String *sourceFile,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromFile(
sourceFile : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceFile | System.String. String that indicates the file name.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a stream.

Overload List

public static EffectCompiler FromStream(Stream, Include, ShaderFlags);
public static EffectCompiler FromStream(Stream, Include, ShaderFlags, out string);
public static EffectCompiler FromStream(Stream, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromStream(Stream,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a stream.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As EffectCompiler
C# public static EffectCompiler FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static EffectCompiler* FromStream(
Stream *sourceData,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags
) : EffectCompiler;

Parameters

sourceData | System.IO.Stream. A Stream Leave Site object that contains the data used to create the EffectCompiler.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromStream(Stream,Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a stream.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static EffectCompiler* FromStream(
Stream *sourceData,
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData | System.IO.Stream. A Stream Leave Site object that contains the data used to create the EffectCompiler.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromStream(Stream,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a stream.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromStream(
Stream sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static EffectCompiler* FromStream(
Stream *sourceData,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromStream(
sourceData : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData | System.IO.Stream. A Stream Leave Site object that contains the data used to create the EffectCompiler.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromString

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a string.

Overload List

public static EffectCompiler FromString(string, Include, ShaderFlags);
public static EffectCompiler FromString(string, Include, ShaderFlags, out string);
public static EffectCompiler FromString(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.FromString(String,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As EffectCompiler
C# public static EffectCompiler FromString(
string sourceData,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static EffectCompiler* FromString(
String *sourceData,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags
) : EffectCompiler;

Parameters

sourceData | System.String. A String Leave Site that describes the EffectCompiler to create.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.FromString(String,Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromString(
string sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static EffectCompiler* FromString(
String *sourceData,
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData | System.String. A String Leave Site that describes the EffectCompiler to create.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.FromString(String,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect compiler from an ASCII or binary effect description in a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromString(
string sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static EffectCompiler* FromString(
String *sourceData,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromString(
sourceData : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData | System.String. A String Leave Site that describes the EffectCompiler to create.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile | Microsoft.DirectX.Direct3D.Include. Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. One or more compile options identified by the ShaderFlags enumeration.
compilationErrors | System.String. String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler . An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


EffectCompiler.GetLiteral(EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.GetLiteral Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a literal status of a parameter.

Definition

Visual Basic .NET Public Function GetLiteral( _
ByVal parameter As EffectHandle _
) As Boolean
C# public bool GetLiteral(
EffectHandle parameter
);
Managed C++ public: bool GetLiteral(
EffectHandle *parameter
);
JScript .NET public function GetLiteral(
parameter : EffectHandle
) : boolean;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that is used as the unique identifier of the parameter.

Return Value

System.Boolean . Value that is true if the parameter is a literal, or false if it is not.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectCompiler.SetLiteral


EffectCompiler.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXEffectCompiler, which allows unmanaged COM clients to create an instance of the managed EffectCompiler class. Not supported.


EffectCompiler.op_Equality(EffectCompiler,EffectCompiler)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As EffectCompiler, _
ByVal right As EffectCompiler _
) As Boolean
C# public static bool op_Equality(
EffectCompiler left,
EffectCompiler right
);
Managed C++ public: static bool op_Equality(
EffectCompiler *left,
EffectCompiler *right
);
JScript .NET public static function op_Equality(
left : EffectCompiler,
right : EffectCompiler
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.EffectCompiler. The EffectCompiler object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.EffectCompiler. The EffectCompiler object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EffectCompiler.op_Inequality(EffectCompiler,EffectCompiler)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As EffectCompiler, _
ByVal right As EffectCompiler _
) As Boolean
C# public static bool op_Inequality(
EffectCompiler left,
EffectCompiler right
);
Managed C++ public: static bool op_Inequality(
EffectCompiler *left,
EffectCompiler *right
);
JScript .NET public static function op_Inequality(
left : EffectCompiler,
right : EffectCompiler
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.EffectCompiler. The EffectCompiler object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.EffectCompiler. The EffectCompiler object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


EffectCompiler.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.EffectCompiler.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


EffectCompiler.SetArrayRange(EffectHandle,Int32,Int32)

EffectCompiler.SetArrayRange Method

Note: This documentation is preliminary and is subject to change.

Sets the range of an array to pass to the device.

Definition

Visual Basic .NET Public Sub SetArrayRange( _
ByVal parameter As EffectHandle, _
ByVal start As Integer, _
ByVal end As Integer _
)
C# public void SetArrayRange(
EffectHandle parameter,
int start,
int end
);
Managed C++ public: void SetArrayRange(
EffectHandle *parameter,
int start,
int end
);
JScript .NET public function SetArrayRange(
parameter : EffectHandle,
start : int,
end : int
);

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the effect.
start | System.Int32. The array starting index.
end | System.Int32. The array ending index.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectCompiler.SetLiteral(EffectHandle,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.SetLiteral Method

 Language:
Note: This documentation is preliminary and is subject to change.

Toggles the literal status of a parameter.

Definition

Visual Basic .NET Public Sub SetLiteral( _
ByVal parameter As EffectHandle, _
ByVal value As Boolean _
)
C# public void SetLiteral(
EffectHandle parameter,
bool value
);
Managed C++ public: void SetLiteral(
EffectHandle *parameter,
bool value
);
JScript .NET public function SetLiteral(
parameter : EffectHandle,
value : boolean
);

Parameters

parameter | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle that is used as a unique identifier for the parameter.
value | System.Boolean. Set to true to make the parameter a literal. Set to false if the parameter can change value during the shader lifetime.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectCompiler.GetLiteral


EffectCompiler.UpdateUnmanagedPointer(ID3DXEffectCompiler)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this EffectCompiler object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXEffectCompiler _
)
C# public void UpdateUnmanagedPointer(
ID3DXEffectCompiler pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXEffectCompiler pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXEffectCompiler
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectCompiler. Pointer to the ID3DXEffectCompiler structure used to update the unmanaged pointer for this EffectCompiler object.


EffectCompiler.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


EffectCompiler.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXEffectCompiler interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXEffectCompiler
C# | public ID3DXEffectCompiler UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXEffectCompiler get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXEffectCompiler

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectCompiler . Unmanaged ID3DXEffectCompiler interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


EffectCompiler.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectCompiler.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the EffectCompiler object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.EffectCompiler.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the EffectCompiler object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.EffectHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle Class

Language:
Note: This documentation is preliminary and is subject to change.

Represents a handle to specific effects.

Definition

Visual Basic .NET NotInheritable Public Class EffectHandle
Inherits Object
C# | public sealed class EffectHandle : Object
Managed C++ | public __gc __sealed class EffectHandle : public Object
JScript .NET | public class EffectHandle extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the EffectHandle object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FromString | Creates an effect handle object from a string.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Implicit | This method has the same functionality as FromString, but is not supported.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.

Inheritance Hierarchy

Object Leave Site
EffectHandle

Remarks

An EffectHandle object is used as a unique identifier for a specific effect. Methods that work with effects often require the effect handle object of the effect.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectHandle.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EffectHandle.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the EffectHandle object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~EffectHandle();
Managed C++ | ~EffectHandle();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


EffectHandle.FromString(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an effect handle object from a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal value As String _
) As EffectHandle
C# public static EffectHandle FromString(
string value
);
Managed C++ public: static EffectHandle* FromString(
String *value
);
JScript .NET public static function FromString(
value : String
) : EffectHandle;

Parameters

value System.String. A String Leave Site that describes the EffectHandle to create.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle that represents the created effect handle.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


EffectHandle.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


EffectHandle.op_Equality(EffectHandle,EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As EffectHandle, _
ByVal right As EffectHandle _
) As Boolean
C# public static bool op_Equality(
EffectHandle left,
EffectHandle right
);
Managed C++ public: static bool op_Equality(
EffectHandle *left,
EffectHandle *right
);
JScript .NET public static function op_Equality(
left : EffectHandle,
right : EffectHandle
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EffectHandle.op_Implicit(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle.op_Implicit Method

 Language:
Note: This documentation is preliminary and is subject to change.

This method has the same functionality as FromString, but is not supported.

Definition

Visual Basic .NET Public Shared Function op_Implicit( _
ByVal value As String _
) As EffectHandle
C# public static EffectHandle op_Implicit(
string value
);
Managed C++ public: static EffectHandle* op_Implicit(
String *value
);
JScript .NET public static function op_Implicit(
value : String
) : EffectHandle;

Parameters

value System.String.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle .


EffectHandle.op_Inequality(EffectHandle,EffectHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectHandle.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As EffectHandle, _
ByVal right As EffectHandle _
) As Boolean
C# public static bool op_Inequality(
EffectHandle left,
EffectHandle right
);
Managed C++ public: static bool op_Inequality(
EffectHandle *left,
EffectHandle *right
);
JScript .NET public static function op_Inequality(
left : EffectHandle,
right : EffectHandle
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.EffectHandle. The EffectHandle object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Microsoft.DirectX.Direct3D.EffectPool

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool Class

Language:
Note: This documentation is preliminary and is subject to change.

Allows applications to share resources between effects.

Definition

Visual Basic .NET NotInheritable Public Class EffectPool
Inherits Object
Implements IDisposable
C# public sealed class EffectPool : Object,
IDisposable
Managed C++ public __gc __sealed class EffectPool : public Object,
IDisposable
JScript .NET public class EffectPool extends Object
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the EffectPool object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the EffectPool object.
EffectPool | Creates a new instance of an EffectPool object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the EffectPool object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.EffectPool.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this EffectPool object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXEffectPool interface pointer.

Inheritance Hierarchy

Object Leave Site
EffectPool

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectPool.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the EffectPool object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.EffectPool.Disposed
  • Microsoft.DirectX.Direct3D.EffectPool.Disposing


EffectPool.EffectPool

EffectPool.EffectPool Constructor

Note: This documentation is preliminary and is subject to change.

Creates a new instance of an EffectPool object.

Overload List

public EffectPool();
public EffectPool(ID3DXEffectPool);
public EffectPool(IntPtr);

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectPool.EffectPool(ID3DXEffectPool)

EffectPool.EffectPool Constructor

Note: This documentation is preliminary and is subject to change.

Creates a new instance of an EffectPool object.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXEffectPool _
)
C# public EffectPool(
ID3DXEffectPool pUnk
);
Managed C++ public: EffectPool(
ID3DXEffectPool pUnk
);
JScript .NET public function EffectPool(
pUnk : ID3DXEffectPool
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectPool. Unmanaged Component Object Model (COM) ID3DXEffectPool interface pointer.

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectPool.EffectPool(IntPtr)

EffectPool.EffectPool Constructor

Note: This documentation is preliminary and is subject to change.

Creates a new instance of an EffectPool object.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public EffectPool(
IntPtr unmanagedObject
);
Managed C++ public: EffectPool(
IntPtr unmanagedObject
);
JScript .NET public function EffectPool(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXEffectPool interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectPool.EffectPool()

EffectPool.EffectPool Constructor

Note: This documentation is preliminary and is subject to change.

Creates a new instance of an EffectPool object.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectPool();
Managed C++ | public: EffectPool();
JScript .NET | public function EffectPool();

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectPool.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EffectPool.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the EffectPool object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~EffectPool();
Managed C++ | ~EffectPool();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


EffectPool.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


EffectPool.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXEffectPool, which allows unmanaged COM clients to create an instance of the managed EffectPool class. Not supported.


EffectPool.op_Equality(EffectPool,EffectPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As EffectPool, _
ByVal right As EffectPool _
) As Boolean
C# public static bool op_Equality(
EffectPool left,
EffectPool right
);
Managed C++ public: static bool op_Equality(
EffectPool *left,
EffectPool *right
);
JScript .NET public static function op_Equality(
left : EffectPool,
right : EffectPool
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.EffectPool. The EffectPool object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.EffectPool. The EffectPool object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EffectPool.op_Inequality(EffectPool,EffectPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As EffectPool, _
ByVal right As EffectPool _
) As Boolean
C# public static bool op_Inequality(
EffectPool left,
EffectPool right
);
Managed C++ public: static bool op_Inequality(
EffectPool *left,
EffectPool *right
);
JScript .NET public static function op_Inequality(
left : EffectPool,
right : EffectPool
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.EffectPool. The EffectPool object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.EffectPool. The EffectPool object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


EffectPool.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.EffectPool.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


EffectPool.UpdateUnmanagedPointer(ID3DXEffectPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this EffectPool object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXEffectPool _
)
C# public void UpdateUnmanagedPointer(
ID3DXEffectPool pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXEffectPool pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXEffectPool
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectPool. Pointer to the ID3DXEffectPool structure used to update the unmanaged pointer for this EffectPool object.


EffectPool.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


EffectPool.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXEffectPool interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXEffectPool
C# | public ID3DXEffectPool UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXEffectPool get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXEffectPool

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectPool . Unmanaged ID3DXEffectPool interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


EffectPool.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPool.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the EffectPool object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.EffectPool.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the EffectPool object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.EffectStateManager

EffectStateManager Class

Note: This documentation is preliminary and is subject to change.

EffectStateManager is a user-implemented class that allows an application to set the device state from an effect. Each of the methods in this class must be implemented by the user and will then be used as a callback to the application when either of the following occur:

  • Effect.BeginPass is called.
  • Effect state is dynamically updated by calling the appropriate state change application programming interface (API). See individual method pages for details.

Definition

Visual Basic .NET MustInherit Public Class EffectStateManager
Inherits Object
C# | public abstract class EffectStateManager : Object
Managed C++ | public __gc __abstract class EffectStateManager : public Object
JScript .NET | public abstract class EffectStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectStateManager | Initializes a new instance of the EffectStateManager class.
Finalize | Allows the EffectStateManager object to free resources before it is destroyed by the garbage collector.
LightEnable | Enables or disables a light.
SetLight | Sets a light.
SetMaterial | Sets a material.
SetNPatchMode | Sets the number of subdivision segments for N-patches.
SetPixelShader | Sets a pixel shader.
SetPixelShaderConstantBoolean | Sets an array of pixel shader Boolean constants.
SetPixelShaderConstantInt32 | Sets an array of pixel shader integer constants.
SetPixelShaderConstantSingle | Sets an array of pixel shader floating-point constants.
SetRenderState | Sets a render state.
SetSamplerState | Sets a sampler state.
SetTexture | Sets a texture.
SetTextureStageState | Sets a texture stage state.
SetTransform | Sets a transform.
SetVertexFormat | Sets a vertex format code.
SetVertexShader | Sets a vertex shader.
SetVertexShaderConstantBoolean | Sets an array of vertex shader Boolean constants.
SetVertexShaderConstantInt32 | Sets an array of vertex shader integer constants.
SetVertexShaderConstantSingle | Sets an array of vertex shader floating-point constants.

Inheritance Hierarchy

Object Leave Site
EffectStateManager

Remarks

A user creates a class that inherits from EffectStateManager and implements all the methods. Once the derived class is created, you can get or set the state manager within an effect using Effect.StateManager.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.EffectStateManager()

EffectStateManager.EffectStateManager Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectStateManager class.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectStateManager();
Managed C++ | public: EffectStateManager();
JScript .NET | public function EffectStateManager();
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.Finalize()

EffectStateManager.Finalize Method

Note: This documentation is preliminary and is subject to change.

Allows the EffectStateManager object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~EffectStateManager();
Managed C++ | ~EffectStateManager();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.LightEnable(Int32,Boolean)

EffectStateManager.LightEnable Method

Note: This documentation is preliminary and is subject to change.

Enables or disables a light.

Definition

Visual Basic .NET MustOverride Public Sub LightEnable( _
ByVal lightIndex As Integer, _
ByVal isEnabled As Boolean _
)
C# public abstract void LightEnable(
int lightIndex,
bool isEnabled
);
Managed C++ public: virtual void LightEnable(
int lightIndex,
bool isEnabled
) = 0;
JScript .NET public abstract function LightEnable(
lightIndex : int,
isEnabled : boolean
);

Parameters

lightIndex | System.Int32. An integer that represents the index of the light to enable or disable.
isEnabled | System.Boolean. Set to true to enable the light. Set to false to disable the light.

Remarks

LightEnable is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetLight(Int32,Light)

EffectStateManager.SetLight Method

Note: This documentation is preliminary and is subject to change.

Sets a light.

Definition

Visual Basic .NET MustOverride Public Sub SetLight( _
ByVal lightIndex As Integer, _
ByVal light As Light _
)
C# public abstract void SetLight(
int lightIndex,
Light light
);
Managed C++ public: virtual void SetLight(
int lightIndex,
Light *light
) = 0;
JScript .NET public abstract function SetLight(
lightIndex : int,
light : Light
);

Parameters

lightIndex | System.Int32. The zero-based index of the light.
light | Microsoft.DirectX.Direct3D.Light. The Light object to set.

Remarks

SetLight is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetMaterial(Material)

EffectStateManager.SetMaterial Method

Note: This documentation is preliminary and is subject to change.

Sets a material.

Definition

Visual Basic .NET MustOverride Public Sub SetMaterial( _
ByRef material As Material _
)
C# public abstract void SetMaterial(
ref Material material
);
Managed C++ public: virtual void SetMaterial(
Material *material
) = 0;
JScript .NET public abstract function SetMaterial(
material : Material
);

Parameters

material Microsoft.DirectX.Direct3D.Material. The Material object to set.

Remarks

SetMaterial is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetNPatchMode(Single)

EffectStateManager.SetNPatchMode Method

Note: This documentation is preliminary and is subject to change.

Sets the number of subdivision segments for N-patches.

Definition

Visual Basic .NET MustOverride Public Sub SetNPatchMode( _
ByVal numberSegments As Single _
)
C# public abstract void SetNPatchMode(
float numberSegments
);
Managed C++ public: virtual void SetNPatchMode(
float numberSegments
) = 0;
JScript .NET public abstract function SetNPatchMode(
numberSegments : float
);

Parameters

numberSegments System.Single. A float value that represents the number of segments for N-patches.

Remarks

SetNPatchMode is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShader(PixelShader)

EffectStateManager.SetPixelShader Method

Note: This documentation is preliminary and is subject to change.

Sets a pixel shader.

Definition

Visual Basic .NET MustOverride Public Sub SetPixelShader( _
ByVal pixelShader As PixelShader _
)
C# public abstract void SetPixelShader(
PixelShader pixelShader
);
Managed C++ public: virtual void SetPixelShader(
PixelShader *pixelShader
) = 0;
JScript .NET public abstract function SetPixelShader(
pixelShader : PixelShader
);

Parameters

pixelShader Microsoft.DirectX.Direct3D.PixelShader. The PixelShader object to set.

Remarks

SetPixelShader is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShaderConstantBoolean(Int32,GraphicsStream,Int32)

EffectStateManager.SetPixelShaderConstantBoolean Method

Note: This documentation is preliminary and is subject to change.

Sets an array of pixel shader Boolean constants.

Definition

Visual Basic .NET MustOverride Public Sub SetPixelShaderConstantBoolean( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetPixelShaderConstantBoolean(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
Managed C++ public: virtual void SetPixelShaderConstantBoolean(
int registerIndex,
GraphicsStream *constantData,
int registerCount
) = 0;
JScript .NET public abstract function SetPixelShaderConstantBoolean(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex | System.Int32. The zero-based index of the first constant register.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents an array of Boolean constants.
registerCount | System.Int32. The number of registers in constantData

Remarks

SetPixelShaderConstantBoolean is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShaderConstantInt32(Int32,GraphicsStream,Int32)

EffectStateManager.SetPixelShaderConstantInt32 Method

Note: This documentation is preliminary and is subject to change.

Sets an array of pixel shader integer constants.

Definition

Visual Basic .NET MustOverride Public Sub SetPixelShaderConstantInt32( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetPixelShaderConstantInt32(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
Managed C++ public: virtual void SetPixelShaderConstantInt32(
int registerIndex,
GraphicsStream *constantData,
int registerCount
) = 0;
JScript .NET public abstract function SetPixelShaderConstantInt32(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex | System.Int32. The zero-based index of the first constant register.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents an array of integer constants.
registerCount | System.Int32. The number of registers in constantData.

Remarks

SetPixelShaderConstantInt32 is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShaderConstantSingle(Int32,GraphicsStream,Int32)

EffectStateManager.SetPixelShaderConstantSingle Method

Note: This documentation is preliminary and is subject to change.

Sets an array of pixel shader floating-point constants.

Definition

Visual Basic .NET MustOverride Public Sub SetPixelShaderConstantSingle( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetPixelShaderConstantSingle(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
Managed C++ public: virtual void SetPixelShaderConstantSingle(
int registerIndex,
GraphicsStream *constantData,
int registerCount
) = 0;
JScript .NET public abstract function SetPixelShaderConstantSingle(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex | System.Int32. The zero-based index of the first constant register.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents an array of floating-point constants.
registerCount | System.Int32. The number of registers in >constantData.

Remarks

SetPixelShaderConstantSingle is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetRenderState(RenderStates,Int32)

EffectStateManager.SetRenderState Method

Note: This documentation is preliminary and is subject to change.

Sets a render state.

Definition

Visual Basic .NET MustOverride Public Sub SetRenderState( _
ByVal renderState As RenderStates, _
ByVal stateValue As Integer _
)
C# public abstract void SetRenderState(
RenderStates renderState,
int stateValue
);
Managed C++ public: virtual void SetRenderState(
RenderStates renderState,
int stateValue
) = 0;
JScript .NET public abstract function SetRenderState(
renderState : RenderStates,
stateValue : int
);

Parameters

renderState | Microsoft.DirectX.Direct3D.RenderStates. A value from the RenderStates enumeration to set.
stateValue | System.Int32. The render state value to set for the given render state.

Remarks

SetRenderState is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetSamplerState(Int32,SamplerStageStates,Int32)

EffectStateManager.SetSamplerState Method

Note: This documentation is preliminary and is subject to change.

Sets a sampler state.

Definition

Visual Basic .NET MustOverride Public Sub SetSamplerState( _
ByVal samplerStage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Integer _
)
C# public abstract void SetSamplerState(
int samplerStage,
SamplerStageStates state,
int value
);
Managed C++ public: virtual void SetSamplerState(
int samplerStage,
SamplerStageStates state,
int value
) = 0;
JScript .NET public abstract function SetSamplerState(
samplerStage : int,
state : SamplerStageStates,
value : int
);

Parameters

samplerStage | System.Int32. The zero-based sampler stage index.
state | Microsoft.DirectX.Direct3D.SamplerStageStates. A SamplerStageStates enumeration that identifies sampler state, which can specify the filtering, addressing, or the border color.
value | System.Int32. The value to set for the sampler state type specified in state.

Remarks

SetSamplerState is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetTexture(Int32,BaseTexture)

EffectStateManager.SetTexture Method

Note: This documentation is preliminary and is subject to change.

Sets a texture.

Definition

Visual Basic .NET MustOverride Public Sub SetTexture( _
ByVal textureStage As Integer, _
ByVal texture As BaseTexture _
)
C# public abstract void SetTexture(
int textureStage,
BaseTexture texture
);
Managed C++ public: virtual void SetTexture(
int textureStage,
BaseTexture *texture
) = 0;
JScript .NET public abstract function SetTexture(
textureStage : int,
texture : BaseTexture
);

Parameters

textureStage | System.Int32. The zero-based texture stage index.
texture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that represents the texture to set.

Remarks

SetTexture is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetTextureStageState(Int32,TextureStageStates,Int32)

EffectStateManager.SetTextureStageState Method

Note: This documentation is preliminary and is subject to change.

Sets a texture stage state.

Definition

Visual Basic .NET MustOverride Public Sub SetTextureStageState( _
ByVal textureStage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Integer _
)
C# public abstract void SetTextureStageState(
int textureStage,
TextureStageStates state,
int value
);
Managed C++ public: virtual void SetTextureStageState(
int textureStage,
TextureStageStates state,
int value
) = 0;
JScript .NET public abstract function SetTextureStageState(
textureStage : int,
state : TextureStageStates,
value : int
);

Parameters

textureStage | System.Int32. The zero-based texture stage index.
state | Microsoft.DirectX.Direct3D.TextureStageStates. A TextureStageStates enumeration that identifies texture state to set.
value | System.Int32. The value to set for the texture state type specified in state.

Remarks

SetTextureStageState is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetTransform(TransformType,Matrix)

EffectStateManager.SetTransform Method

Note: This documentation is preliminary and is subject to change.

Sets a transform.

Definition

Visual Basic .NET MustOverride Public Sub SetTransform( _
ByVal transformType As TransformType, _
ByRef transform As Matrix _
)
C# public abstract void SetTransform(
TransformType transformType,
ref Matrix transform
);
Managed C++ public: virtual void SetTransform(
TransformType transformType,
Matrix *transform
) = 0;
JScript .NET public abstract function SetTransform(
transformType : TransformType,
transform : Matrix
);

Parameters

transformType | Microsoft.DirectX.Direct3D.TransformType. A value from the TransformType enumeration to set.
transform | Microsoft.DirectX.Matrix. A transformation Matrix to set.

Remarks

SetTransform is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexFormat(VertexFormats)

EffectStateManager.SetVertexFormat Method

Note: This documentation is preliminary and is subject to change.

Sets a vertex format code.

Definition

Visual Basic .NET MustOverride Public Sub SetVertexFormat( _
ByVal vertexFormat As VertexFormats _
)
C# public abstract void SetVertexFormat(
VertexFormats vertexFormat
);
Managed C++ public: virtual void SetVertexFormat(
VertexFormats vertexFormat
) = 0;
JScript .NET public abstract function SetVertexFormat(
vertexFormat : VertexFormats
);

Parameters

vertexFormat Microsoft.DirectX.Direct3D.VertexFormats. A value of the VertexFormats enumeration that detemines how to interpret vertex data.

Remarks

SetVertexFormat is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShader(VertexShader)

EffectStateManager.SetVertexShader Method

Note: This documentation is preliminary and is subject to change.

Sets a vertex shader.

Definition

Visual Basic .NET MustOverride Public Sub SetVertexShader( _
ByVal vertexShader As VertexShader _
)
C# public abstract void SetVertexShader(
VertexShader vertexShader
);
Managed C++ public: virtual void SetVertexShader(
VertexShader *vertexShader
) = 0;
JScript .NET public abstract function SetVertexShader(
vertexShader : VertexShader
);

Parameters

vertexShader Microsoft.DirectX.Direct3D.VertexShader. The VertexShader object to set.

Remarks

SetVertexShader is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShaderConstantBoolean(Int32,GraphicsStream,Int32)

EffectStateManager.SetVertexShaderConstantBoolean Method

Note: This documentation is preliminary and is subject to change.

Sets an array of vertex shader Boolean constants.

Definition

Visual Basic .NET MustOverride Public Sub SetVertexShaderConstantBoolean( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetVertexShaderConstantBoolean(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
Managed C++ public: virtual void SetVertexShaderConstantBoolean(
int registerIndex,
GraphicsStream *constantData,
int registerCount
) = 0;
JScript .NET public abstract function SetVertexShaderConstantBoolean(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex | System.Int32. The zero-based index of the first constant register.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents an array of Boolean constants.
registerCount | System.Int32. The number of registers in constantData.

Remarks

SetVertexShaderConstantBoolean is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShaderConstantInt32(Int32,GraphicsStream,Int32)

EffectStateManager.SetVertexShaderConstantInt32 Method

Note: This documentation is preliminary and is subject to change.

Sets an array of vertex shader integer constants.

Definition

Visual Basic .NET MustOverride Public Sub SetVertexShaderConstantInt32( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetVertexShaderConstantInt32(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
Managed C++ public: virtual void SetVertexShaderConstantInt32(
int registerIndex,
GraphicsStream *constantData,
int registerCount
) = 0;
JScript .NET public abstract function SetVertexShaderConstantInt32(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex | System.Int32. The zero-based index of the first constant register.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents an array of integer constants.
registerCount | System.Int32. The number of registers in constantData.

Remarks

SetVertexShaderConstantInt32 is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShaderConstantSingle(Int32,GraphicsStream,Int32)

EffectStateManager.SetVertexShaderConstantSingle Method

Note: This documentation is preliminary and is subject to change.

Sets an array of vertex shader floating-point constants.

Definition

Visual Basic .NET MustOverride Public Sub SetVertexShaderConstantSingle( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetVertexShaderConstantSingle(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
Managed C++ public: virtual void SetVertexShaderConstantSingle(
int registerIndex,
GraphicsStream *constantData,
int registerCount
) = 0;
JScript .NET public abstract function SetVertexShaderConstantSingle(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex | System.Int32. The zero-based index of the first constant register.
constantData | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents an array of floating-point constants.
registerCount | System.Int32. The number of registers in constantData.

Remarks

SetVertexShaderConstantSingle is a user-implemented method that is called from an effect during rendering.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.Font

Microsoft DirectX 9.0 SDK Update (October 2004)

Font Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates the textures and resources needed to render a specific font on a specific device.

Definition

Visual Basic .NET NotInheritable Public Class Font
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class Font : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class Font : public MarshalByRefObject,
IDisposable
JScript .NET public class Font extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Font object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally just before a device is reset.
Reset | Occurs after the Font.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Font object.
DrawText | Draws formatted text.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Font object to free resources before it is destroyed by the garbage collector.
Font | Creates a new instance of a Font class.
GetGlyphData | Returns information about the placement and orientation of a glyph in a character cell.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreloadCharacters | Loads a series of characters into video memory to improve the efficiency of rendering to a device.
PreloadGlyphs | Loads a series of glyphs into video memory to improve the efficiency of rendering to a device.
PreloadText | Loads formatted text into video memory to improve the efficiency of rendering to a device.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Font.Disposing event when called from within a derived class.
raise_Lost | Raises a Font.Lost event when called from within a derived class.
raise_Reset | Raises a Font.Reset event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Font object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves a description of the current font object.
Device | Retrieves the Microsoft Direct3D® device associated with a font object.
DeviceContext | Returns a handle to a display device context (DC) that includes the font set.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFont interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Font

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Font.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Font object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Font.Disposed
  • Microsoft.DirectX.Direct3D.Font.Disposing


Font.DrawText

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Overload List

public int DrawText(Sprite, string, int, int, Color);
public int DrawText(Sprite, string, int, int, int);
public int DrawText(Sprite, string, Point, Color);
public int DrawText(Sprite, string, Point, int);
public int DrawText(Sprite, string, ref Rectangle, DrawTextFormat, Color);
public int DrawText(Sprite, string, Rectangle, DrawTextFormat, Color);
public int DrawText(Sprite, string, ref Rectangle, DrawTextFormat, int);
public int DrawText(Sprite, string, Rectangle, DrawTextFormat, int);

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Rectangle,DrawTextFormat,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByRef rect As Rectangle, _
ByVal format As DrawTextFormat, _
ByVal color As Color _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
ref Rectangle rect,
DrawTextFormat format,
Color color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
Rectangle *rect,
DrawTextFormat format,
Color color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
rect : Rectangle,
format : DrawTextFormat,
color : Color
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
rect | System.Drawing.Rectangle. A reference to a Rectangle Leave Site structure that contains the rectangle, in logical coordinates, in which the text is being formatted. Also used to return modified values when calling Font.DrawText with the value of DrawTextFormat.CalculateRect in the format parameter.
format | Microsoft.DirectX.Direct3D.DrawTextFormat. Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color | System.Drawing.Color. Color of the text. For more information, see Color Leave Site.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block. The only exception is when an application calls DrawText with CalculateRect to calculate the size of a given block of text.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Rectangle,DrawTextFormat,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByRef rect As Rectangle, _
ByVal format As DrawTextFormat, _
ByVal color As Integer _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
ref Rectangle rect,
DrawTextFormat format,
int color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
Rectangle *rect,
DrawTextFormat format,
int color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
rect : Rectangle,
format : DrawTextFormat,
color : int
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
rect | System.Drawing.Rectangle. A reference to a Rectangle Leave Site structure that contains the rectangle, in logical coordinates, in which the text is being formatted. Also used to return modified values when calling Font.DrawText with the value of DrawTextFormat.CalculateRect in the format parameter.
format | Microsoft.DirectX.Direct3D.DrawTextFormat. Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color | System.Int32. Integer color value.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block. The only exception is when an application calls DrawText with CalculateRect to calculate the size of a given block of text.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Int32,Int32,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal color As Color _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
int x,
int y,
Color color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
int x,
int y,
Color color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
x : int,
y : int,
color : Color
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
x | System.Int32. The x-coordinate where to draw the font.
y | System.Int32. The y-coordinate where to draw the font.
color | System.Drawing.Color. Color of the text. For more information, see Color Leave Site.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal color As Integer _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
int x,
int y,
int color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
int x,
int y,
int color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
x : int,
y : int,
color : int
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
x | System.Int32. The x-coordinate where to draw the font.
y | System.Int32. The y-coordinate where to draw the font.
color | System.Int32. Integer color value.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Point,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal pos As Point, _
ByVal color As Color _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Point pos,
Color color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
Point pos,
Color color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
pos : Point,
color : Color
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
pos | System.Drawing.Point. A Point Leave Site structure that specifies the upper left-hand coordinates of where to draw the font.
color | System.Drawing.Color. Color of the text. For more information, see Color Leave Site.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Point,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal pos As Point, _
ByVal color As Integer _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Point pos,
int color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
Point pos,
int color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
pos : Point,
color : int
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
pos | System.Drawing.Point. A Point Leave Site structure that specifies the upper left-hand coordinates of where to draw the font.
color | System.Int32. Integer color value.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Rectangle,DrawTextFormat,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal rect As Rectangle, _
ByVal format As DrawTextFormat, _
ByVal color As Color _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Rectangle rect,
DrawTextFormat format,
Color color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
Rectangle rect,
DrawTextFormat format,
Color color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
rect : Rectangle,
format : DrawTextFormat,
color : Color
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
rect | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the rectangle, in logical coordinates, in which the text is being formatted.
format | Microsoft.DirectX.Direct3D.DrawTextFormat. Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color | System.Drawing.Color. Color of the text. For more information, see Color Leave Site.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Rectangle,DrawTextFormat,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws formatted text.

Definition

Visual Basic .NET Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal rect As Rectangle, _
ByVal format As DrawTextFormat, _
ByVal color As Integer _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Rectangle rect,
DrawTextFormat format,
int color
);
Managed C++ public: int DrawText(
Sprite *sprite,
String *text,
Rectangle rect,
DrawTextFormat format,
int color
);
JScript .NET public function DrawText(
sprite : Sprite,
text : String,
rect : Rectangle,
format : DrawTextFormat,
color : int
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite. A Sprite object that contains the string. Can be null, in which case Microsoft® Direct3D® renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text | System.String. String to draw.
rect | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the rectangle, in logical coordinates, in which the text is being formatted.
format | Microsoft.DirectX.Direct3D.DrawTextFormat. Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color | System.Int32. Integer color value.

Return Value

System.Int32 . If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Font.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Font object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Font();
Managed C++ | ~Font();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Font.Font

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Font Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of a Font class.

Overload List

public Font(Device, Font);
public Font(Device, FontDescription);
public Font(Device, int, int, FontWeight, int, bool, CharacterSet, Precision, FontQuality, PitchAndFamily, string);
public Font(ID3DXFont);
public Font(IntPtr);


Font.Font(ID3DXFont)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Font Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of a Font class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXFont _
)
C# public Font(
ID3DXFont pUnk
);
Managed C++ public: Font(
ID3DXFont pUnk
);
JScript .NET public function Font(
pUnk : ID3DXFont
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFont. Unmanaged Component Object Model (COM) ID3DXFont interface pointer.


Font.Font(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Font Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of a Font class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Font(
IntPtr unmanagedObject
);
Managed C++ public: Font(
IntPtr unmanagedObject
);
JScript .NET public function Font(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXFont interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Font.Font(Device,Font)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Font Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of a Font class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal font As Font _
)
C# public Font(
Device device,
Font font
);
Managed C++ public: Font(
Device *device,
Font *font
);
JScript .NET public function Font(
device : Device,
font : Font
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the font object.
font | System.Drawing.Font. The Font Leave Site object.


Font.Font(Device,FontDescription)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Font Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of a Font class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal description As FontDescription _
)
C# public Font(
Device device,
FontDescription description
);
Managed C++ public: Font(
Device *device,
FontDescription description
);
JScript .NET public function Font(
device : Device,
description : FontDescription
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the font object.
description | Microsoft.DirectX.Direct3D.FontDescription. A FontDescription structure.


Font.Font(Device,Int32,Int32,FontWeight,Int32,Boolean,CharacterSet,Precision,FontQuality,PitchAndFamily,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Font Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of a Font class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal height As Integer, _
ByVal width As Integer, _
ByVal weight As FontWeight, _
ByVal miplevels As Integer, _
ByVal italic As Boolean, _
ByVal charset As CharacterSet, _
ByVal outputPrecision As Precision, _
ByVal quality As FontQuality, _
ByVal pitchFamily As PitchAndFamily, _
ByVal faceName As String _
)
C# public Font(
Device device,
int height,
int width,
FontWeight weight,
int miplevels,
bool italic,
CharacterSet charset,
Precision outputPrecision,
FontQuality quality,
PitchAndFamily pitchFamily,
string faceName
);
Managed C++ public: Font(
Device *device,
int height,
int width,
FontWeight weight,
int miplevels,
bool italic,
CharacterSet charset,
Precision outputPrecision,
FontQuality quality,
PitchAndFamily pitchFamily,
String *faceName
);
JScript .NET public function Font(
device : Device,
height : int,
width : int,
weight : FontWeight,
miplevels : int,
italic : boolean,
charset : CharacterSet,
outputPrecision : Precision,
quality : FontQuality,
pitchFamily : PitchAndFamily,
faceName : String
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the font object.
height | System.Int32. Height of the font.
width | System.Int32. Width of the font.
weight | Microsoft.DirectX.Direct3D.FontWeight. Weight of the font.
miplevels | System.Int32. Number of mip levels.
italic | System.Boolean. Set to true if the font is in italics; otherwise, false.
charset | Microsoft.DirectX.Direct3D.CharacterSet. A CharacterSet enumerated value that indicates the type of characters to use.
outputPrecision | Microsoft.DirectX.Direct3D.Precision. A Precision constant that indicates the font precision.
quality | Microsoft.DirectX.Direct3D.FontQuality. A FontQuality value that indicates the quality of the font.
pitchFamily | Microsoft.DirectX.Direct3D.PitchAndFamily. A PitchAndFamily value that indicates the font pitch and family.
faceName | System.String. A string that indicates the name of the font.


Font.GetGlyphData

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.GetGlyphData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns information about the placement and orientation of a glyph in a character cell.

Overload List

public Texture GetGlyphData(int);
public Texture GetGlyphData(int, out Rectangle, out Point);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.GetGlyphData(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.GetGlyphData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns information about the placement and orientation of a glyph in a character cell.

Definition

Visual Basic .NET Public Function GetGlyphData( _
ByVal glyph As Integer _
) As Texture
C# public Texture GetGlyphData(
int glyph
);
Managed C++ public: Texture* GetGlyphData(
int glyph
);
JScript .NET public function GetGlyphData(
glyph : int
) : Texture;

Parameters

glyph System.Int32. Glyph identifier.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that contains the glyph.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.GetGlyphData(Int32,Rectangle,Point)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.GetGlyphData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns information about the placement and orientation of a glyph in a character cell.

Definition

Visual Basic .NET Public Function GetGlyphData( _
ByVal glyph As Integer, _
ByRef blackBox As Rectangle, _
ByRef cellInc As Point _
) As Texture
C# public Texture GetGlyphData(
int glyph,
out Rectangle blackBox,
out Point cellInc
);
Managed C++ public: Texture* GetGlyphData(
int glyph,
Rectangle *blackBox,
Point *cellInc
);
JScript .NET public function GetGlyphData(
glyph : int,
blackBox : Rectangle,
cellInc : Point
) : Texture;

Parameters

glyph | System.Int32. Glyph identifier.
blackBox | System.Drawing.Rectangle. Smallest Rectangle Leave Site object that completely encloses the glyph (its black box).
cellInc | System.Drawing.Point. A Vector2 structure that connects the origin of the current character cell to the origin of the next character cell.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that contains the glyph.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Font.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFont, which allows unmanaged COM clients to create an instance of the managed Font class. Not supported.


Font.OnLostDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.OnLostDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic .NET | Public Sub OnLostDevice()
C# | public void OnLostDevice();
Managed C++ | public: void OnLostDevice();
JScript .NET | public function OnLostDevice();


Font.OnResetDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.OnResetDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic .NET | Public Sub OnResetDevice()
C# | public void OnResetDevice();
Managed C++ | public: void OnResetDevice();
JScript .NET | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Font.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Font.OnResetDevice should be called immediately after the device is reset.


Font.op_Equality(Font,Font)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Font, _
ByVal right As Font _
) As Boolean
C# public static bool op_Equality(
Font left,
Font right
);
Managed C++ public: static bool op_Equality(
Font *left,
Font *right
);
JScript .NET public static function op_Equality(
left : Font,
right : Font
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Font. The Font object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Font. The Font object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Font.op_Inequality(Font,Font)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Font, _
ByVal right As Font _
) As Boolean
C# public static bool op_Inequality(
Font left,
Font right
);
Managed C++ public: static bool op_Inequality(
Font *left,
Font *right
);
JScript .NET public static function op_Inequality(
left : Font,
right : Font
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Font. The Font object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Font. The Font object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Font.PreloadCharacters(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.PreloadCharacters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a series of characters into video memory to improve the efficiency of rendering to a device.

Definition

Visual Basic .NET Public Sub PreloadCharacters( _
ByVal first As Integer, _
ByVal last As Integer _
)
C# public void PreloadCharacters(
int first,
int last
);
Managed C++ public: void PreloadCharacters(
int first,
int last
);
JScript .NET public function PreloadCharacters(
first : int,
last : int
);

Parameters

first | System.Int32. Identifier of the first character to load into video memory.
last | System.Int32. Identifier of the last character to load into video memory.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.PreloadGlyphs(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.PreloadGlyphs Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a series of glyphs into video memory to improve the efficiency of rendering to a device.

Definition

Visual Basic .NET Public Sub PreloadGlyphs( _
ByVal first As Integer, _
ByVal last As Integer _
)
C# public void PreloadGlyphs(
int first,
int last
);
Managed C++ public: void PreloadGlyphs(
int first,
int last
);
JScript .NET public function PreloadGlyphs(
first : int,
last : int
);

Parameters

first | System.Int32. Identifier of the first glyph to load into video memory.
last | System.Int32. Identifier of the last glyph to load into video memory.

Remarks

This method does not render the glyphs to the device; Font.DrawText still must be called to render the glyphs. However, pre-loading glyphs into video memory causes Font.DrawText to use substantially fewer CPU resources.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.PreloadText(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.PreloadText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads formatted text into video memory to improve the efficiency of rendering to a device.

Definition

Visual Basic .NET Public Sub PreloadText( _
ByVal text As String _
)
C# public void PreloadText(
string text
);
Managed C++ public: void PreloadText(
String *text
);
JScript .NET public function PreloadText(
text : String
);

Parameters

text System.String. String of characters to load into video memory.

Remarks

This method does not render text to the device; Font.DrawText must still be called to render the text. However, pre-loading text into video memory causes Font.DrawText to use substantially fewer CPU resources.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Font.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Font.raise_Lost(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.raise_Lost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Font.Lost event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Lost(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Font.raise_Reset(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.raise_Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Font.Reset event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Reset(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Font.UpdateUnmanagedPointer(ID3DXFont)

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Font object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFont _
)
C# public void UpdateUnmanagedPointer(
ID3DXFont pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXFont pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXFont
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFont. Pointer to the ID3DXFont structure used to update the unmanaged pointer for this Font object.


Font.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a description of the current font object.

Definition

Visual Basic .NET | Public ReadOnly Property Description As FontDescription
C# | public FontDescription Description { get; }
Managed C++ | public: __property FontDescription get_Description();
JScript .NET | public function get Description() : FontDescription

Property Value

Microsoft.DirectX.Direct3D.FontDescription . A FontDescription structure that describes the font object.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Microsoft® Direct3D® device associated with a font object.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . A Device class that represents the Microsoft® Direct3D® device associated with the font object.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.DeviceContext

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.DeviceContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns a handle to a display device context (DC) that includes the font set.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceContext As IntPtr
C# | public IntPtr DeviceContext { get; }
Managed C++ | public: __property IntPtr get_DeviceContext();
JScript .NET | public function get DeviceContext() : IntPtr

Property Value

System.IntPtr . Handle to a display DC.

This property is read-only.


Font.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Font.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXFont interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXFont
C# | public ID3DXFont UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXFont get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXFont

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFont . Unmanaged ID3DXFont interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Font.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Font object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Font.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Font object indicates whether that object has been disposed.


Font.Lost

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Lost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when an object is lost, normally just before a device is reset.

Definition

Visual Basic .NET | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
Managed C++ | public: __event EventHandler Lost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Font.Lost event, use the following C# code.

[C#]
Font.Lost += new System.EventHandler(this.LostEventHandler);


Font.Reset

Microsoft DirectX 9.0 SDK Update (October 2004)

Font.Reset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after the Font.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic .NET | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
Managed C++ | public: __event EventHandler Reset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Font.Reset event, use the following C# code.

[C#]
Font.Reset += new System.EventHandler(this.ResetEventHandler);


Microsoft.DirectX.Direct3D.FragmentLinker

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker Class

Language:
Note: This documentation is preliminary and is subject to change.

Links shader fragments at runtime.

Definition

Visual Basic .NET NotInheritable Public Class FragmentLinker
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class FragmentLinker : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class FragmentLinker : public MarshalByRefObject,
IDisposable
JScript .NET public class FragmentLinker extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the FragmentLinker object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddFragments | Adds fragments to the existing fragment linker.
ClearCache | Clears the fragment linker cache.
Dispose | Immediately releases the unmanaged resources used by the FragmentLinker object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the FragmentLinker object to free resources before it is destroyed by the garbage collector.
FragmentLinker | Initializes a new instance of the FragmentLinker class.
static (Shared in Visual Basic .NET) GatherFragmentsFromFile | Assembles shader fragments and creates a new fragment linker object.
static (Shared in Visual Basic .NET) GatherFragmentsFromStream | Assembles shader fragments and creates a new fragment linker object.
static (Shared in Visual Basic .NET) GatherFragmentsFromString | Assembles shader fragments and creates a new fragment linker object.
GetFragment | Retrieves a GraphicsStream object that contains the compiled shader fragment.
GetFragmentDescription | Retrieves a FragmentDescription object.
GetFragmentHandle | Retrieves an EffectHandle object by name or by index.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
LinkPixelShader | Links a compiled pixel shader at run time.
LinkShader | Links a compiled shader at run time.
LinkVertexShader | Links a compiled shader at run time.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.FragmentLinker.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this FragmentLinker object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
AllFragments | Retrieves a GraphicsStream object that contains the compiled linker fragments.
Device | Retrieves the Device for the current fragment linker.
Disposed | Gets a value that indicates whether the object is disposed.
NumberOfFragments | Retrieves the number of fragments in the linker.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFragmentLinker interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
FragmentLinker

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FragmentLinker.AddFragments(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.AddFragments Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds fragments to the existing fragment linker.

Definition

Visual Basic .NET Public Sub AddFragments( _
ByVal fragments As GraphicsStream _
)
C# public void AddFragments(
GraphicsStream fragments
);
Managed C++ public: void AddFragments(
GraphicsStream *fragments
);
JScript .NET public function AddFragments(
fragments : GraphicsStream
);

Parameters

fragments Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains shader fragments to add.

Remarks

Exceptions
DuplicateNamedFragmentException Multiple fragments with the same name were found. No fragments were added.


FragmentLinker.ClearCache()

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.ClearCache Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clears the fragment linker cache.

Definition

Visual Basic .NET | Public Sub ClearCache()
C# | public void ClearCache();
Managed C++ | public: void ClearCache();
JScript .NET | public function ClearCache();


FragmentLinker.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the FragmentLinker object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.FragmentLinker.Disposed
  • Microsoft.DirectX.Direct3D.FragmentLinker.Disposing


FragmentLinker.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


FragmentLinker.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the FragmentLinker object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~FragmentLinker();
Managed C++ | ~FragmentLinker();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


FragmentLinker.FragmentLinker

FragmentLinker.FragmentLinker Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FragmentLinker class.

Overload List

public FragmentLinker(Device, int);
public FragmentLinker(ID3DXFragmentLinker);
public FragmentLinker(IntPtr);
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.FragmentLinker(ID3DXFragmentLinker)

FragmentLinker.FragmentLinker Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FragmentLinker class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXFragmentLinker _
)
C# public FragmentLinker(
ID3DXFragmentLinker pUnk
);
Managed C++ public: FragmentLinker(
ID3DXFragmentLinker pUnk
);
JScript .NET public function FragmentLinker(
pUnk : ID3DXFragmentLinker
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFragmentLinker. Unmanaged Component Object Model (COM) ID3DXFragmentLinker interface pointer.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.FragmentLinker(IntPtr)

FragmentLinker.FragmentLinker Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FragmentLinker class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public FragmentLinker(
IntPtr unmanagedObject
);
Managed C++ public: FragmentLinker(
IntPtr unmanagedObject
);
JScript .NET public function FragmentLinker(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXFragmentLinker interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.FragmentLinker(Device,Int32)

FragmentLinker.FragmentLinker Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FragmentLinker class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal shaderCacheSize As Integer _
)
C# public FragmentLinker(
Device device,
int shaderCacheSize
);
Managed C++ public: FragmentLinker(
Device *device,
int shaderCacheSize
);
JScript .NET public function FragmentLinker(
device : Device,
shaderCacheSize : int
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device to associate with the FragmentLinker.
shaderCacheSize | System.Int32. Integer that represents the shader cache size.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.GatherFragmentsFromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Overload List

public static GraphicsStream GatherFragmentsFromFile(string, Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromFile(string, Macro[], Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromFile(string, Macro[], Include, ShaderFlags, out string);
public static GraphicsStream GatherFragmentsFromFile(string, ShaderFlags);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromFile(
String *file,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromFile(
file : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file | System.String. String that represents the name of the file that contains the shader fragments.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromFile(
String *file,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromFile(
file : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file | System.String. String that represents the name of the file that contains the shader fragments.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,Macro[],Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromFile(
String *file,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromFile(
file : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file | System.String. String that represents the name of the file that contains the shader fragments.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Array of Macro objects that specify the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromFile(
String *file,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function GatherFragmentsFromFile(
file : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

file | System.String. String that represents the name of the file that contains the shader fragments.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Array of Macro objects that specify the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.
compilationErrors | System.String. A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Overload List

public static GraphicsStream GatherFragmentsFromStream(Stream, Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromStream(Stream, Macro[], Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromStream(Stream, Macro[], Include, ShaderFlags, out string);
public static GraphicsStream GatherFragmentsFromStream(Stream, ShaderFlags);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromStream(
Stream *data,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromStream(
data : Stream,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.IO.Stream. A Stream Leave Site object that contains the shader fragments.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromStream(
Stream *data,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromStream(
data : Stream,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.IO.Stream. A Stream Leave Site object that contains the shader fragments.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,Macro[],Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromStream(
Stream *data,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromStream(
data : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.IO.Stream. A Stream Leave Site object that contains the shader fragments.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Array of Macro objects that specify the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromStream(
Stream *data,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function GatherFragmentsFromStream(
data : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

data | System.IO.Stream. A Stream Leave Site object that contains the shader fragments.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Array of Macro objects that specify the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.
compilationErrors | System.String. A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Overload List

public static GraphicsStream GatherFragmentsFromString(string, Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromString(string, Macro[], Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromString(string, Macro[], Include, ShaderFlags, out string);
public static GraphicsStream GatherFragmentsFromString(string, ShaderFlags);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromString(
String *data,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromString(
data : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.String. A String Leave Site that contains the shader fragments.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromString(
String *data,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromString(
data : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.String. A String Leave Site that contains the shader fragments.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,Macro[],Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromString(
String *data,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function GatherFragmentsFromString(
data : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.String. A String Leave Site that contains the shader fragments.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Array of Macro objects that specify the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GatherFragmentsFromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic .NET Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* GatherFragmentsFromString(
String *data,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function GatherFragmentsFromString(
data : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

data | System.String. A String Leave Site that contains the shader fragments.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Array of Macro objects that specify the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. An Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the shader compiler options to use.
compilationErrors | System.String. A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragment(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GetFragment Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a GraphicsStream object that contains the compiled shader fragment.

Definition

Visual Basic .NET Public Function GetFragment( _
ByVal name As String _
) As GraphicsStream
C# public GraphicsStream GetFragment(
string name
);
Managed C++ public: GraphicsStream* GetFragment(
String *name
);
JScript .NET public function GetFragment(
name : String
) : GraphicsStream;

Parameters

name System.String. String that represents the name of the shader fragment.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader fragment.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragmentDescription(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GetFragmentDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a FragmentDescription object.

Definition

Visual Basic .NET Public Function GetFragmentDescription( _
ByVal name As String _
) As FragmentDescription
C# public FragmentDescription GetFragmentDescription(
string name
);
Managed C++ public: FragmentDescription GetFragmentDescription(
String *name
);
JScript .NET public function GetFragmentDescription(
name : String
) : FragmentDescription;

Parameters

name System.String. String that represents the name of the shader fragment.

Return Value

Microsoft.DirectX.Direct3D.FragmentDescription . A FragmentDescription object that contains the fragment description.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragmentHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GetFragmentHandle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an EffectHandle object by name or by index.

Overload List

public EffectHandle GetFragmentHandle(int);
public EffectHandle GetFragmentHandle(string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragmentHandle(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GetFragmentHandle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an EffectHandle object by name or by index.

Definition

Visual Basic .NET Public Function GetFragmentHandle( _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetFragmentHandle(
string name
);
Managed C++ public: EffectHandle* GetFragmentHandle(
String *name
);
JScript .NET public function GetFragmentHandle(
name : String
) : EffectHandle;

Parameters

name System.String. String that represents the name of the shader fragment.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle object that contains the fragment handle.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragmentHandle(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GetFragmentHandle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an EffectHandle object by name or by index.

Definition

Visual Basic .NET Public Function GetFragmentHandle( _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetFragmentHandle(
int index
);
Managed C++ public: EffectHandle* GetFragmentHandle(
int index
);
JScript .NET public function GetFragmentHandle(
index : int
) : EffectHandle;

Parameters

index System.Int32. Integer that represents the zero-based index of the shader fragment.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle object that contains the fragment handle.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


FragmentLinker.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFragmentLinker, which allows unmanaged COM clients to create an instance of the managed FragmentLinker class. Not supported.


FragmentLinker.LinkPixelShader(String,ShaderFlags,EffectHandle[],String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.LinkPixelShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Links a compiled pixel shader at run time.

Definition

Visual Basic .NET Public Function LinkPixelShader( _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByVal fragmentHandles() As EffectHandle, _
ByRef errors As String _
) As PixelShader
C# public PixelShader LinkPixelShader(
string profile,
ShaderFlags flags,
EffectHandle[] fragmentHandles,
out string errors
);
Managed C++ public: PixelShader* LinkPixelShader(
String *profile,
ShaderFlags flags,
EffectHandle *fragmentHandles __gc[],
String **errors
);
JScript .NET public function LinkPixelShader(
profile : String,
flags : ShaderFlags,
fragmentHandles : EffectHandle[],
errors : String
) : PixelShader;

Parameters

profile | System.String. A String Leave Site that contains the pixel shader profile that determines the shader instruction set.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the link options to use.
fragmentHandles | Microsoft.DirectX.Direct3D.EffectHandle[]. Array of EffectHandle objects that represent the handles of the fragments to link.
errors | System.String. A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.Direct3D.PixelShader . A PixelShader object that contains the linked pixel shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.LinkShader(String,ShaderFlags,EffectHandle[],String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.LinkShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Links a compiled shader at run time.

Definition

Visual Basic .NET Public Function LinkShader( _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByVal fragmentHandles() As EffectHandle, _
ByRef errors As String _
) As GraphicsStream
C# public GraphicsStream LinkShader(
string profile,
ShaderFlags flags,
EffectHandle[] fragmentHandles,
out string errors
);
Managed C++ public: GraphicsStream* LinkShader(
String *profile,
ShaderFlags flags,
EffectHandle *fragmentHandles __gc[],
String **errors
);
JScript .NET public function LinkShader(
profile : String,
flags : ShaderFlags,
fragmentHandles : EffectHandle[],
errors : String
) : GraphicsStream;

Parameters

profile | System.String. A String Leave Site that contains the compiled shader profile that determines the shader instruction set.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the link options to use.
fragmentHandles | Microsoft.DirectX.Direct3D.EffectHandle[]. Array of EffectHandle objects that represent the handles of the fragments to link.
errors | System.String. A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the linked shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.LinkVertexShader(String,ShaderFlags,EffectHandle[],String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.LinkVertexShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Links a compiled shader at run time.

Definition

Visual Basic .NET Public Function LinkVertexShader( _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByVal fragmentHandles() As EffectHandle, _
ByRef errors As String _
) As VertexShader
C# public VertexShader LinkVertexShader(
string profile,
ShaderFlags flags,
EffectHandle[] fragmentHandles,
out string errors
);
Managed C++ public: VertexShader* LinkVertexShader(
String *profile,
ShaderFlags flags,
EffectHandle *fragmentHandles __gc[],
String **errors
);
JScript .NET public function LinkVertexShader(
profile : String,
flags : ShaderFlags,
fragmentHandles : EffectHandle[],
errors : String
) : VertexShader;

Parameters

profile | System.String. A String Leave Site that contains the vertex shader profile that determines the shader instruction set.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. A ShaderFlags enumeration that specifies the link options to use.
fragmentHandles | Microsoft.DirectX.Direct3D.EffectHandle[]. Array of EffectHandle objects that represent the handles of the fragments to link.
errors | System.String. A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.Direct3D.VertexShader . A VertexShader object that contains the linked vertex shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.op_Equality(FragmentLinker,FragmentLinker)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As FragmentLinker, _
ByVal right As FragmentLinker _
) As Boolean
C# public static bool op_Equality(
FragmentLinker left,
FragmentLinker right
);
Managed C++ public: static bool op_Equality(
FragmentLinker *left,
FragmentLinker *right
);
JScript .NET public static function op_Equality(
left : FragmentLinker,
right : FragmentLinker
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.FragmentLinker. The FragmentLinker object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.FragmentLinker. The FragmentLinker object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


FragmentLinker.op_Inequality(FragmentLinker,FragmentLinker)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As FragmentLinker, _
ByVal right As FragmentLinker _
) As Boolean
C# public static bool op_Inequality(
FragmentLinker left,
FragmentLinker right
);
Managed C++ public: static bool op_Inequality(
FragmentLinker *left,
FragmentLinker *right
);
JScript .NET public static function op_Inequality(
left : FragmentLinker,
right : FragmentLinker
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.FragmentLinker. The FragmentLinker object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.FragmentLinker. The FragmentLinker object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


FragmentLinker.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.FragmentLinker.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


FragmentLinker.UpdateUnmanagedPointer(ID3DXFragmentLinker)

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this FragmentLinker object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFragmentLinker _
)
C# public void UpdateUnmanagedPointer(
ID3DXFragmentLinker pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXFragmentLinker pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXFragmentLinker
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFragmentLinker. Pointer to the ID3DXFragmentLinker structure used to update the unmanaged pointer for this FragmentLinker object.


FragmentLinker.AllFragments

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.AllFragments Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a GraphicsStream object that contains the compiled linker fragments.

Definition

Visual Basic .NET | Public ReadOnly Property AllFragments As GraphicsStream
C# | public GraphicsStream AllFragments { get; }
Managed C++ | public: __property GraphicsStream* get_AllFragments();
JScript .NET | public function get AllFragments() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled linker fragments.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


FragmentLinker.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device for the current fragment linker.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object associated with the current fragment linker.

This property is read-only.


FragmentLinker.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


FragmentLinker.NumberOfFragments

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.NumberOfFragments Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of fragments in the linker.

Definition

Visual Basic .NET | Public ReadOnly Property NumberOfFragments As Integer
C# | public int NumberOfFragments { get; }
Managed C++ | public: __property int get_NumberOfFragments();
JScript .NET | public function get NumberOfFragments() : int

Property Value

System.Int32 . Integer that represents the number of fragments in the linker.

This property is read-only.


FragmentLinker.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXFragmentLinker interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXFragmentLinker
C# | public ID3DXFragmentLinker UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXFragmentLinker get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXFragmentLinker

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFragmentLinker . Unmanaged ID3DXFragmentLinker interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


FragmentLinker.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentLinker.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the FragmentLinker object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.FragmentLinker.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the FragmentLinker object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.Frame

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates a transform frame in a transformation frame hierarchy.

Definition

Visual Basic .NET MustInherit Public Class Frame
Inherits Object
C# | public abstract class Frame : Object
Managed C++ | public __gc __abstract class Frame : public Object
JScript .NET | public abstract class Frame extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) AppendChild | Adds a child frame to a frame.
static (Shared in Visual Basic .NET) CalculateBoundingSphere | Computes the bounding sphere of all meshes in the frame hierarchy.
static (Shared in Visual Basic .NET) Destroy | Destroys the subtree of frames under the root, including the root.
Finalize | Allows the Frame object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) Find | Finds the child frame of a root frame.
Frame | Initializes a new instance of the Frame class.
static (Shared in Visual Basic .NET) GetNumberNamedMatrices | Retrieves the number of frames in a subtree that have non-null names.
static (Shared in Visual Basic .NET) RegisterNamedMatrices | Given a frame hierarchy, registers all named matrices in the animation mixer.

Properties

Property | Description
FrameFirstChild | Retrieves the first child of the frame.
FrameSibling | Retrieves the first sibling of the current frame in the hierarchy.
MeshContainer | Retrieves or sets a MeshContainer object in a transformation frame hierarchy.
Name | Retrieves or sets the name of a frame.
TransformationMatrix | Retrieves or sets the transformation Matrix of a frame.

Inheritance Hierarchy

Object Leave Site
Frame

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Frame.AppendChild(Frame,Frame)

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.AppendChild Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a child frame to a frame.

Definition

Visual Basic .NET Public Shared Sub AppendChild( _
ByVal parent As Frame, _
ByVal child As Frame _
)
C# public static void AppendChild(
Frame parent,
Frame child
);
Managed C++ public: static void AppendChild(
Frame *parent,
Frame *child
);
JScript .NET public static function AppendChild(
parent : Frame,
child : Frame
);

Parameters

parent | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the parent node in the frame hierarchy.
child | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the child node to add to the frame hierarchy.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Frame.CalculateBoundingSphere(Frame,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.CalculateBoundingSphere Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the bounding sphere of all meshes in the frame hierarchy.

Definition

Visual Basic .NET Public Shared Function CalculateBoundingSphere( _
ByVal frameRoot As Frame, _
ByRef center As Vector3 _
) As Single
C# public static float CalculateBoundingSphere(
Frame frameRoot,
out Vector3 center
);
Managed C++ public: static float CalculateBoundingSphere(
Frame *frameRoot,
Vector3 *center
);
JScript .NET public static function CalculateBoundingSphere(
frameRoot : Frame,
center : Vector3
) : float;

Parameters

frameRoot | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the root node in the frame hierarchy.
center | Microsoft.DirectX.Vector3. A Vector3 object that contains the center coordinates of the bounding sphere.

Return Value

System.Single . Floating-point value that represents the radius of the bounding sphere.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Frame.Destroy(Frame,AllocateHierarchy)

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.Destroy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Destroys the subtree of frames under the root, including the root.

Definition

Visual Basic .NET Public Shared Sub Destroy( _
ByVal frameRoot As Frame, _
ByVal allocHierarchy As AllocateHierarchy _
)
C# public static void Destroy(
Frame frameRoot,
AllocateHierarchy allocHierarchy
);
Managed C++ public: static void Destroy(
Frame *frameRoot,
AllocateHierarchy *allocHierarchy
);
JScript .NET public static function Destroy(
frameRoot : Frame,
allocHierarchy : AllocateHierarchy
);

Parameters

frameRoot | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the root node in the frame hierarchy.
allocHierarchy | Microsoft.DirectX.Direct3D.AllocateHierarchy. An AllocateHierarchy object used to deallocate nodes of the frame hierarchy.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Frame.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Frame object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Frame();
Managed C++ | ~Frame();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Frame.Find(Frame,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.Find Method

 Language:
Note: This documentation is preliminary and is subject to change.

Finds the child frame of a root frame.

Definition

Visual Basic .NET Public Shared Function Find( _
ByVal frameRoot As Frame, _
ByVal name As String _
) As Frame
C# public static Frame Find(
Frame frameRoot,
string name
);
Managed C++ public: static Frame* Find(
Frame *frameRoot,
String *name
);
JScript .NET public static function Find(
frameRoot : Frame,
name : String
) : Frame;

Parameters

frameRoot | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the root node in the frame hierarchy.
name | System.String. String that represents the name of the child frame to find.

Return Value

Microsoft.DirectX.Direct3D.Frame . A Frame object that represents the located child frame.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Frame.Frame()

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.Frame Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Frame class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Frame();
Managed C++ | public: Frame();
JScript .NET | public function Frame();


Frame.GetNumberNamedMatrices(Frame)

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.GetNumberNamedMatrices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of frames in a subtree that have non-null names.

Definition

Visual Basic .NET Public Shared Function GetNumberNamedMatrices( _
ByVal frameRoot As Frame _
) As Integer
C# public static int GetNumberNamedMatrices(
Frame frameRoot
);
Managed C++ public: static int GetNumberNamedMatrices(
Frame *frameRoot
);
JScript .NET public static function GetNumberNamedMatrices(
frameRoot : Frame
) : int;

Parameters

frameRoot Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the root node of the subtree.

Return Value

System.Int32 . Integer that represents the number of frames that have non-null names.


Frame.RegisterNamedMatrices(Frame,AnimationController)

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.RegisterNamedMatrices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Given a frame hierarchy, registers all named matrices in the animation mixer.

Definition

Visual Basic .NET Public Shared Sub RegisterNamedMatrices( _
ByVal frameRoot As Frame, _
ByVal animationMixer As AnimationController _
)
C# public static void RegisterNamedMatrices(
Frame frameRoot,
AnimationController animationMixer
);
Managed C++ public: static void RegisterNamedMatrices(
Frame *frameRoot,
AnimationController *animationMixer
);
JScript .NET public static function RegisterNamedMatrices(
frameRoot : Frame,
animationMixer : AnimationController
);

Parameters

frameRoot | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the root node in the frame hierarchy.
animationMixer | Microsoft.DirectX.Direct3D.AnimationController. An AnimationController object that represents the animation mixer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Frame.FrameFirstChild

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.FrameFirstChild Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the first child of the frame.

Definition

Visual Basic .NET | Public ReadOnly Property FrameFirstChild As Frame
C# | public Frame FrameFirstChild { get; }
Managed C++ | public: __property Frame* get_FrameFirstChild();
JScript .NET | public function get FrameFirstChild() : Frame

Property Value

Microsoft.DirectX.Direct3D.Frame . A Frame object that represents the first child of the frame.

This property is read-only.


Frame.FrameSibling

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.FrameSibling Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the first sibling of the current frame in the hierarchy.

Definition

Visual Basic .NET | Public ReadOnly Property FrameSibling As Frame
C# | public Frame FrameSibling { get; }
Managed C++ | public: __property Frame* get_FrameSibling();
JScript .NET | public function get FrameSibling() : Frame

Property Value

Microsoft.DirectX.Direct3D.Frame . A Frame object that represents the first sibling of the frame.

This property is read-only.


Frame.MeshContainer

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.MeshContainer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a MeshContainer object in a transformation frame hierarchy.

Definition

Visual Basic .NET | Public Property MeshContainer As MeshContainer
C# | public MeshContainer MeshContainer { get; set; }
Managed C++ public: __property MeshContainer* get_MeshContainer();
public: __property void set_MeshContainer(MeshContainer*);
JScript .NET public function get MeshContainer() : MeshContainer
public function set MeshContainer(MeshContainer);

Property Value

Microsoft.DirectX.Direct3D.MeshContainer . A MeshContainer object.

This property is read/write.


Frame.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the name of a frame.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String . A String Leave Site that represents the name of the frame.

This property is read/write.


Frame.TransformationMatrix

Microsoft DirectX 9.0 SDK Update (October 2004)

Frame.TransformationMatrix Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the transformation Matrix of a frame.

Definition

Visual Basic .NET | Public Property TransformationMatrix As Matrix
C# | public Matrix TransformationMatrix { get; set; }
Managed C++ public: __property Matrix get_TransformationMatrix();
public: __property void set_TransformationMatrix(Matrix);
JScript .NET public function get TransformationMatrix() : Matrix
public function set TransformationMatrix(Matrix);

Property Value

Microsoft.DirectX.Matrix . A Matrix object that represents the transformation matrix of the frame.

This property is read/write.


Microsoft.DirectX.Direct3D.Geometry

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Compute a Bounding Sphere from a Mesh

Contains miscellaneous math-related functions.

Definition

Visual Basic .NET NotInheritable Public Class Geometry
Inherits Object
C# | public sealed class Geometry : Object
Managed C++ | public __gc __sealed class Geometry : public Object
JScript .NET | public class Geometry extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) BoxBoundProbe | Determines whether a ray intersects the volume of a bounding box.
static (Shared in Visual Basic .NET) ComputeBoundingBox | Computes a coordinate axis-oriented bounding box.
static (Shared in Visual Basic .NET) ComputeBoundingSphere | Computes a bounding sphere for a mesh.
static (Shared in Visual Basic .NET) DegreeToRadian | Converts degrees to radians.
static (Shared in Visual Basic .NET) FresnelTerm | Calculates the Fresnel term.
static (Shared in Visual Basic .NET) IntersectTri | Computes the intersection of a ray and a triangle.
static (Shared in Visual Basic .NET) OptimizeFaces | Optimizes a set of faces.
static (Shared in Visual Basic .NET) OptimizeVertices | Optimizes a set of vertices.
static (Shared in Visual Basic .NET) RadianToDegree | Converts radians to degrees.
static (Shared in Visual Basic .NET) SphereBoundProbe | Determines whether a ray intersects the volume of a sphere's bounding box.

Inheritance Hierarchy

Object Leave Site
Geometry

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Geometry.BoxBoundProbe(Vector3,Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.BoxBoundProbe Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a ray intersects the volume of a bounding box.

Definition

Visual Basic .NET Public Shared Function BoxBoundProbe( _
ByVal min As Vector3, _
ByVal max As Vector3, _
ByVal rayPosition As Vector3, _
ByVal rayDirection As Vector3 _
) As Boolean
C# public static bool BoxBoundProbe(
Vector3 min,
Vector3 max,
Vector3 rayPosition,
Vector3 rayDirection
);
Managed C++ public: static bool BoxBoundProbe(
Vector3 min,
Vector3 max,
Vector3 rayPosition,
Vector3 rayDirection
);
JScript .NET public static function BoxBoundProbe(
min : Vector3,
max : Vector3,
rayPosition : Vector3,
rayDirection : Vector3
) : boolean;

Parameters

min | Microsoft.DirectX.Vector3. A Vector3 structure that describes the lower-left corner of the bounding box. See Remarks.
max | Microsoft.DirectX.Vector3. A Vector3 structure that describes the upper-right corner of the bounding box. See Remarks.
rayPosition | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDirection | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray. This vector should not be (0,0,0), but does not need to be normalized.

Return Value

System.Boolean . Value that is true if the ray intersects the volume of the bounding box, or false if it does not.

Remarks

The Geometry.BoxBoundProbe method determines whether the ray intersects the volume of the bounding box, not just the surface of the box.

The values passed to Geometry.BoxBoundProbe are xmin, xmax, ymin, ymax, zmin, and zmax. Thus, the following defines the corners of the bounding box.

xmax, ymax, zmax
xmax, ymax, zmin
xmax, ymin, zmax
xmax, ymin, zmin
xmin, ymax, zmax
xmin, ymax, zmin
xmin, ymin, zmax
xmin, ymin, zmin

The depth of the bounding box is zmax - zmin in the z direction; ymax - ymin in the y direction, and xmax - xmin in the x direction. For example, with the following minimum and maximum vectors, min (-1, -1, -1) and max (1, 1, 1), the bounding box is defined as follows.

 1,  1,  1
 1,  1, -1
 1, -1,  1
 1, -1, -1
-1,  1,  1
-1,  1, -1
-1, -1,  1
-1, -1, -1

See Also

  • ComputeBoundingBox


Geometry.ComputeBoundingBox

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a coordinate axis-oriented bounding box.

Overload List

public static void ComputeBoundingBox(Array, int, out Vector3, out Vector3);
public static void ComputeBoundingBox(Array, VertexFormats, out Vector3, out Vector3);
public static void ComputeBoundingBox(GraphicsStream, int, int, out Vector3, out Vector3);
public static void ComputeBoundingBox(GraphicsStream, int, VertexFormats, out Vector3, out Vector3);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(GraphicsStream,Int32,VertexFormats,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic .NET Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal vertexFormat As VertexFormats, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
GraphicsStream pointsFvf,
int numVertices,
VertexFormats vertexFormat,
out Vector3 min,
out Vector3 max
);
Managed C++ public: static void ComputeBoundingBox(
GraphicsStream *pointsFvf,
int numVertices,
VertexFormats vertexFormat,
Vector3 *min,
Vector3 *max
);
JScript .NET public static function ComputeBoundingBox(
pointsFvf : GraphicsStream,
numVertices : int,
vertexFormat : VertexFormats,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the points around which the bounding box is constructed.
numVertices | System.Int32. Number of vertices.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. A VertexFormats object that specifies the format of the vertices that are passed in.
min | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned lower-left corner of the bounding box.
max | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(Array,VertexFormats,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic .NET Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As Array, _
ByVal vertexFormat As VertexFormats, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
Array pointsFvf,
VertexFormats vertexFormat,
out Vector3 min,
out Vector3 max
);
Managed C++ public: static void ComputeBoundingBox(
Array *pointsFvf,
VertexFormats vertexFormat,
Vector3 *min,
Vector3 *max
);
JScript .NET public static function ComputeBoundingBox(
pointsFvf : Array,
vertexFormat : VertexFormats,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf | System.Array. Array that contains the points around which the bounding box is constructed.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. A VertexFormats object that specifies the format of the vertices that are passed in.
min | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned lower-left corner of the bounding box.
max | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(GraphicsStream,Int32,Int32,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic .NET Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal strideSize As Integer, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
GraphicsStream pointsFvf,
int numVertices,
int strideSize,
out Vector3 min,
out Vector3 max
);
Managed C++ public: static void ComputeBoundingBox(
GraphicsStream *pointsFvf,
int numVertices,
int strideSize,
Vector3 *min,
Vector3 *max
);
JScript .NET public static function ComputeBoundingBox(
pointsFvf : GraphicsStream,
numVertices : int,
strideSize : int,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the points around which the bounding box is constructed.
numVertices | System.Int32. Number of vertices.
strideSize | System.Int32.
min | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned lower-left corner of the bounding box.
max | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(Array,Int32,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic .NET Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As Array, _
ByVal strideSize As Integer, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
Array pointsFvf,
int strideSize,
out Vector3 min,
out Vector3 max
);
Managed C++ public: static void ComputeBoundingBox(
Array *pointsFvf,
int strideSize,
Vector3 *min,
Vector3 *max
);
JScript .NET public static function ComputeBoundingBox(
pointsFvf : Array,
strideSize : int,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf | System.Array. Array that contains the points around which the bounding box is constructed.
strideSize | System.Int32.
min | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned lower-left corner of the bounding box.
max | Microsoft.DirectX.Vector3. A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingSphere

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingSphere Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Overload List

public static float ComputeBoundingSphere(Array, int, out Vector3);
public static float ComputeBoundingSphere(Array, VertexFormats, out Vector3);
public static float ComputeBoundingSphere(GraphicsStream, int, int, out Vector3);
public static float ComputeBoundingSphere(GraphicsStream, int, VertexFormats, out Vector3);

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(GraphicsStream,Int32,VertexFormats,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingSphere Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic .NET Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal vertexFormat As VertexFormats, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
GraphicsStream pointsFvf,
int numVertices,
VertexFormats vertexFormat,
out Vector3 center
);
Managed C++ public: static float ComputeBoundingSphere(
GraphicsStream *pointsFvf,
int numVertices,
VertexFormats vertexFormat,
Vector3 *center
);
JScript .NET public static function ComputeBoundingSphere(
pointsFvf : GraphicsStream,
numVertices : int,
vertexFormat : VertexFormats,
center : Vector3
) : float;

Parameters

pointsFvf | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the points around which the bounding sphere is constructed.
numVertices | System.Int32. Number of vertices.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. A VertexFormats object that specifies the format of the vertices that are passed in.
center | Microsoft.DirectX.Vector3. A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single . Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(Array,VertexFormats,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingSphere Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic .NET Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As Array, _
ByVal vertexFormat As VertexFormats, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
Array pointsFvf,
VertexFormats vertexFormat,
out Vector3 center
);
Managed C++ public: static float ComputeBoundingSphere(
Array *pointsFvf,
VertexFormats vertexFormat,
Vector3 *center
);
JScript .NET public static function ComputeBoundingSphere(
pointsFvf : Array,
vertexFormat : VertexFormats,
center : Vector3
) : float;

Parameters

pointsFvf | System.Array. Array that contains the points around which the bounding box is constructed.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. A VertexFormats object that specifies the format of the vertices that are passed in.
center | Microsoft.DirectX.Vector3. A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single . Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(GraphicsStream,Int32,Int32,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingSphere Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic .NET Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal strideSize As Integer, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
GraphicsStream pointsFvf,
int numVertices,
int strideSize,
out Vector3 center
);
Managed C++ public: static float ComputeBoundingSphere(
GraphicsStream *pointsFvf,
int numVertices,
int strideSize,
Vector3 *center
);
JScript .NET public static function ComputeBoundingSphere(
pointsFvf : GraphicsStream,
numVertices : int,
strideSize : int,
center : Vector3
) : float;

Parameters

pointsFvf | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the points around which the bounding sphere is constructed.
numVertices | System.Int32. Number of vertices.
strideSize | System.Int32.
center | Microsoft.DirectX.Vector3. A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single . Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(Array,Int32,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.ComputeBoundingSphere Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic .NET Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As Array, _
ByVal strideSize As Integer, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
Array pointsFvf,
int strideSize,
out Vector3 center
);
Managed C++ public: static float ComputeBoundingSphere(
Array *pointsFvf,
int strideSize,
Vector3 *center
);
JScript .NET public static function ComputeBoundingSphere(
pointsFvf : Array,
strideSize : int,
center : Vector3
) : float;

Parameters

pointsFvf | System.Array. Array that contains the points around which the bounding box is constructed.
strideSize | System.Int32.
center | Microsoft.DirectX.Vector3. A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single . Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.DegreeToRadian(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.DegreeToRadian Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts degrees to radians.

Definition

Visual Basic .NET Public Shared Function DegreeToRadian( _
ByVal degree As Single _
) As Single
C# public static float DegreeToRadian(
float degree
);
Managed C++ public: static float DegreeToRadian(
float degree
);
JScript .NET public static function DegreeToRadian(
degree : float
) : float;

Parameters

degree System.Single. Value, in degrees, to convert to radians.

Return Value

System.Single . Converted value in radians.

Remarks

This method uses the following formula to compute radians:

degree * (3.141592654f/180.0f)

See Also

  • Geometry.RadianToDegree


Geometry.FresnelTerm(Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.FresnelTerm Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the Fresnel term.

Definition

Visual Basic .NET Public Shared Function FresnelTerm( _
ByVal cosTheta As Single, _
ByVal refractionIndex As Single _
) As Single
C# public static float FresnelTerm(
float cosTheta,
float refractionIndex
);
Managed C++ public: static float FresnelTerm(
float cosTheta,
float refractionIndex
);
JScript .NET public static function FresnelTerm(
cosTheta : float,
refractionIndex : float
) : float;

Parameters

cosTheta | System.Single. Cosine of the incident angle; must be between 0 and 1.
refractionIndex | System.Single. Refraction index of a material; must be greater than 1.

Return Value

System.Single . Fresnel term for unpolarized light.

Remarks

To find the Fresnel term, use the following equation.

If F is the Fresnel term, A is the angle of incidence, and B is the angle of refraction, then

F = 0.5 * [tan2(A - B) / tan2(A + B) + sin2(A - B) / sin2(A + B)]
  = 0.5 * sin2(A - B) / sin2(A + B) * [cos2(A + B) / cos2(A - B) + 1]

Let r   = sina(A) / sin(B)      (the relative refractive index)
Let c   = cos(A)
Let g   = (r2 + c2 - 1)1/2

Then, expand using the trigonometric identities and simplifying to produce the following result.

F = 0.5 * (g + c)2 / (g - c)2 * ([c(g + c) - 1]2 / [c(g - c) + 1]2 + 1)


Geometry.IntersectTri(Vector3,Vector3,Vector3,Vector3,Vector3,IntersectInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.IntersectTri Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the intersection of a ray and a triangle.

Definition

Visual Basic .NET Public Shared Function IntersectTri( _
ByVal zero As Vector3, _
ByVal one As Vector3, _
ByVal two As Vector3, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef hitLocation As IntersectInformation _
) As Boolean
C# public static bool IntersectTri(
Vector3 zero,
Vector3 one,
Vector3 two,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation hitLocation
);
Managed C++ public: static bool IntersectTri(
Vector3 zero,
Vector3 one,
Vector3 two,
Vector3 rayPos,
Vector3 rayDir,
IntersectInformation *hitLocation
);
JScript .NET public static function IntersectTri(
zero : Vector3,
one : Vector3,
two : Vector3,
rayPos : Vector3,
rayDir : Vector3,
hitLocation : IntersectInformation
) : boolean;

Parameters

zero | Microsoft.DirectX.Vector3. A Vector3 structure that describes the first triangle vertex position.
one | Microsoft.DirectX.Vector3. A Vector3 structure that describes the second triangle vertex position.
two | Microsoft.DirectX.Vector3. A Vector3 structure that describes the third triangle vertex position.
rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the position of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the position of the ray.
hitLocation | Microsoft.DirectX.Direct3D.IntersectInformation. An IntersectInformation structure that indicates the coordinates at which the ray intersects with the triangle.

Return Value

System.Boolean . Value that is true if the ray intersects the area of the triangle, or false if it does not.

Remarks

The IntersectTri method provides a way to understand points in and around a triangle, regardless of its location. This function returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, while the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using barycentric coordinates represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.


Geometry.OptimizeFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.OptimizeFaces Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes a set of faces.

Overload List

public static int[] OptimizeFaces(short[], int);
public static int[] OptimizeFaces(int[], int);


Geometry.OptimizeFaces(Int32[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.OptimizeFaces Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes a set of faces.

Definition

Visual Basic .NET Public Shared Function OptimizeFaces( _
ByVal indices() As Integer, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeFaces(
int[] indices,
int numberVertices
);
Managed C++ public: static int OptimizeFaces(
int indices __gc[],
int numberVertices
) __gc[];
JScript .NET public static function OptimizeFaces(
indices : int[],
numberVertices : int
) : int[];

Parameters

indices | System.Int32[]. Array of 32-bit indices that indicate the mesh faces to optimize.
numberVertices | System.Int32. Number of vertices in the mesh to optimize.

Return Value

System.Int32[]. Array of Int32 Leave Site values that represent the optimized faces.


Geometry.OptimizeFaces(Int16[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.OptimizeFaces Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes a set of faces.

Definition

Visual Basic .NET Public Shared Function OptimizeFaces( _
ByVal indices() As Short, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeFaces(
short[] indices,
int numberVertices
);
Managed C++ public: static int OptimizeFaces(
short indices __gc[],
int numberVertices
) __gc[];
JScript .NET public static function OptimizeFaces(
indices : short[],
numberVertices : int
) : int[];

Parameters

indices | System.Int16[]. Array of 16-bit indices that indicate the mesh faces to optimize.
numberVertices | System.Int32. Number of vertices in the mesh to optimize.

Return Value

System.Int32[]. Array of Int32 Leave Site values that represent the optimized faces.


Geometry.OptimizeVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.OptimizeVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes a set of vertices.

Overload List

public static int[] OptimizeVertices(short[], int);
public static int[] OptimizeVertices(int[], int);


Geometry.OptimizeVertices(Int32[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.OptimizeVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes a set of vertices.

Definition

Visual Basic .NET Public Shared Function OptimizeVertices( _
ByVal indices() As Integer, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeVertices(
int[] indices,
int numberVertices
);
Managed C++ public: static int OptimizeVertices(
int indices __gc[],
int numberVertices
) __gc[];
JScript .NET public static function OptimizeVertices(
indices : int[],
numberVertices : int
) : int[];

Parameters

indices | System.Int32[]. Array of 32-bit indices that indicate the vertices to optimize.
numberVertices | System.Int32. Number of vertices to optimize.

Return Value

System.Int32[]. Optimized vertices.


Geometry.OptimizeVertices(Int16[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.OptimizeVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes a set of vertices.

Definition

Visual Basic .NET Public Shared Function OptimizeVertices( _
ByVal indices() As Short, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeVertices(
short[] indices,
int numberVertices
);
Managed C++ public: static int OptimizeVertices(
short indices __gc[],
int numberVertices
) __gc[];
JScript .NET public static function OptimizeVertices(
indices : short[],
numberVertices : int
) : int[];

Parameters

indices | System.Int16[]. Array of 16-bit indices that indicate the vertices to optimize.
numberVertices | System.Int32. Number of vertices to optimize.

Return Value

System.Int32[]. Optimized vertices.


Geometry.RadianToDegree(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.RadianToDegree Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts radians to degrees.

Definition

Visual Basic .NET Public Shared Function RadianToDegree( _
ByVal radian As Single _
) As Single
C# public static float RadianToDegree(
float radian
);
Managed C++ public: static float RadianToDegree(
float radian
);
JScript .NET public static function RadianToDegree(
radian : float
) : float;

Parameters

radian System.Single. Value, in radians, to convert to degrees.

Return Value

System.Single . Converted value in degrees.

Remarks

This method uses the following value for pi to compute radians:

3.141592654f


Geometry.SphereBoundProbe(Vector3,Single,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Geometry.SphereBoundProbe Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a ray intersects the volume of a sphere's bounding box.

Definition

Visual Basic .NET Public Shared Function SphereBoundProbe( _
ByVal center As Vector3, _
ByVal radius As Single, _
ByVal rayPosition As Vector3, _
ByVal rayDirection As Vector3 _
) As Boolean
C# public static bool SphereBoundProbe(
Vector3 center,
float radius,
Vector3 rayPosition,
Vector3 rayDirection
);
Managed C++ public: static bool SphereBoundProbe(
Vector3 center,
float radius,
Vector3 rayPosition,
Vector3 rayDirection
);
JScript .NET public static function SphereBoundProbe(
center : Vector3,
radius : float,
rayPosition : Vector3,
rayDirection : Vector3
) : boolean;

Parameters

center | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the center coordinate of the sphere.
radius | System.Single. Radius of the sphere.
rayPosition | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDirection | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray. This vector should not be (0,0,0), but does not need to be normalized.

Return Value

System.Boolean . Value that is true if the ray intersects the volume of the sphere's bounding box, or false if it does not.

Remarks

The SphereBoundProbe method determines whether the ray intersects the volume of the sphere, not just its surface.


Microsoft.DirectX.Direct3D.GraphicsException

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Base exception type for graphics. Derives from DirectXException.

Definition

Visual Basic .NET Public Class GraphicsException
Inherits DirectXException
C# | public class GraphicsException : DirectXException
Managed C++ | public __gc class GraphicsException : public DirectXException
JScript .NET | public class GraphicsException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in.
GraphicsException | Initializes a new instance of the GraphicsException class.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingRenderStateException
ConflictingTextureFilterException
ConflictingTexturePaletteException
DeviceLostException
DeviceNotResetException
DriverInternalErrorException
DriverInvalidCallException
InvalidCallException
InvalidDeviceException
MoreDataException
NotAvailableException
NotFoundException
OutOfVideoMemoryException
TooManyOperationsException
UnsupportedAlphaArgumentException
UnsupportedAlphaOperationException
UnsupportedColorArgumentException
UnsupportedColorOperationException
UnsupportedFactorValueException
UnsupportedTextureFilterException
WasStillDrawingException
WrongTextureFormatException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GraphicsException.GetExceptionFromResultInternal(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GetExceptionFromResultInternal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an Exception Leave Site object that represents the result code passed in.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32. Integer that represents the result code of the exception to retrieve.

Return Value

System.Exception . An Exception Leave Site object that represents the error that occurred.

Applies To

ConflictingRenderStateException, ConflictingTextureFilterException, ConflictingTexturePaletteException, DeviceLostException, DeviceNotResetException, DriverInternalErrorException, DriverInvalidCallException, InvalidCallException, InvalidDeviceException, MoreDataException, NotAvailableException, NotFoundException, OutOfVideoMemoryException, TooManyOperationsException, UnsupportedAlphaArgumentException, UnsupportedAlphaOperationException, UnsupportedColorArgumentException, UnsupportedColorOperationException, UnsupportedFactorValueException, UnsupportedTextureFilterException, WasStillDrawingException, WrongTextureFormatException


GraphicsException.GraphicsException

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsException class.

Overload List

public GraphicsException();
protected GraphicsException(SerializationInfo, StreamingContext);
public GraphicsException(string);
public GraphicsException(string, Exception);


GraphicsException.GraphicsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GraphicsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: GraphicsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function GraphicsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


GraphicsException.GraphicsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GraphicsException(
string message,
Exception inner
);
Managed C++ public: GraphicsException(
String *message,
Exception *inner
);
JScript .NET public function GraphicsException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


GraphicsException.GraphicsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public GraphicsException(
string message
);
Managed C++ public: GraphicsException(
String *message
);
JScript .NET public function GraphicsException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


GraphicsException.GraphicsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public GraphicsException();
Managed C++ | public: GraphicsException();
JScript .NET | public function GraphicsException();


Microsoft.DirectX.Direct3D.Include

Microsoft DirectX 9.0 SDK Update (October 2004)

Include Class

Language:
Note: This documentation is preliminary and is subject to change.

Provides access to include-file directives.

Definition

Visual Basic .NET MustInherit Public Class Include
Inherits Object
C# | public abstract class Include : Object
Managed C++ | public __gc __abstract class Include : public Object
JScript .NET | public abstract class Include extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Finalize | Allows the Include object to free resources before it is destroyed by the garbage collector.
Include | Initializes a new instance of the Include class.
Open | Opens and reads the contents of a shader #include file.

Inheritance Hierarchy

Object Leave Site
Include

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Include.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Include.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Include object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Include();
Managed C++ | ~Include();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Include.Include()

Microsoft DirectX 9.0 SDK Update (October 2004)

Include.Include Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Include class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Include();
Managed C++ | public: Include();
JScript .NET | public function Include();


Include.Open(IncludeType,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Include.Open Method

 Language:
Note: This documentation is preliminary and is subject to change.

Opens and reads the contents of a shader #include file.

Definition

Visual Basic .NET MustOverride Public Function Open( _
ByVal includeType As IncludeType, _
ByVal filename As String _
) As Stream
C# public abstract Stream Open(
IncludeType includeType,
string filename
);
Managed C++ public: virtual Stream* Open(
IncludeType includeType,
String *filename
) = 0;
JScript .NET public abstract function Open(
includeType : IncludeType,
filename : String
) : Stream;

Parameters

includeType | Microsoft.DirectX.Direct3D.IncludeType. An IncludeType object that represents the #include file to open.
filename | System.String. A String Leave Site that contains the name of the #include file to open.

Return Value

System.IO.Stream . A Stream Leave Site object that contains the #include file data.


Microsoft.DirectX.Direct3D.IndexBuffer

IndexBuffer Class

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams
  • Read and Write VertexBuffer Data With Arrays

Manipulates an index buffer resource.

Definition

Visual Basic .NET NotInheritable Public Class IndexBuffer
Inherits Resource
Implements IDisposable
C# public sealed class IndexBuffer : Resource,
IDisposable
Managed C++ public __gc __sealed class IndexBuffer : public Resource,
IDisposable
JScript .NET public class IndexBuffer extends Resource
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Created | Occurs after a device is reset and the IndexBuffer is re-created.
Disposing | Occurs when the Dispose method is called or when the IndexBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the IndexBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object. Inherited from Resource.
Finalize | Allows the IndexBuffer object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GetHashCode | Returns the hash code for the current instance. Inherited from Resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
IndexBuffer | Creates a new instance of the IndexBuffer class.
Lock | Locks a range of index data and obtains a pointer to the index buffer memory.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Created | Raises an IndexBuffer.Created event when called from within a derived class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.IndexBuffer.Disposing event when called from within a derived class.
SetData | Locks, sets, and unlocks a range of vertex data.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Unlock | Unlocks index data.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this IndexBuffer object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
Description | Retrieves a description of the index buffer resource.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
SizeInBytes | Retrieves the size of the IndexBuffer data, in bytes.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DIndexBuffer9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
IndexBuffer

Remarks

This object inherits additional functionality from the Resource object.

How Do I...?

Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Read and Write VertexBuffer Data With Arrays

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a FVF type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft Direct3D® resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


IndexBuffer.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the IndexBuffer object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.IndexBuffer.Disposed
  • Microsoft.DirectX.Direct3D.IndexBuffer.Disposing


IndexBuffer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the IndexBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~IndexBuffer();
Managed C++ | ~IndexBuffer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


IndexBuffer.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DIndexBuffer9, which allows unmanaged COM clients to create an instance of the managed IndexBuffer class. Not supported.


IndexBuffer.IndexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.IndexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the IndexBuffer class.

Overload List

public IndexBuffer(Device, int, Usage, Pool, bool);
public IndexBuffer(IDirect3DIndexBuffer9);
public IndexBuffer(IDirect3DIndexBuffer9, Device, Usage, Pool);
public IndexBuffer(IDirect3DIndexBuffer9, Type, int, Device, Usage, Pool);
public IndexBuffer(IntPtr);
public IndexBuffer(Type, int, Device, Usage, Pool);

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft® Direct3D® to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IDirect3DIndexBuffer9)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.IndexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As IDirect3DIndexBuffer9 _
)
C# public IndexBuffer(
IDirect3DIndexBuffer9 pInterop
);
Managed C++ public: IndexBuffer(
IDirect3DIndexBuffer9 pInterop
);
JScript .NET public function IndexBuffer(
pInterop : IDirect3DIndexBuffer9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9. Unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft® Direct3D® to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.IndexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public IndexBuffer(
IntPtr unmanagedObject
);
Managed C++ public: IndexBuffer(
IntPtr unmanagedObject
);
JScript .NET public function IndexBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft® Direct3D® to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IDirect3DIndexBuffer9,Type,Int32,Device,Usage,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.IndexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DIndexBuffer9, _
ByVal typeIndexType As Type, _
ByVal numberIndices As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public IndexBuffer(
IDirect3DIndexBuffer9 lp,
Type typeIndexType,
int numberIndices,
Device device,
Usage usage,
Pool pool
);
Managed C++ public: IndexBuffer(
IDirect3DIndexBuffer9 lp,
Type *typeIndexType,
int numberIndices,
Device *device,
Usage usage,
Pool pool
);
JScript .NET public function IndexBuffer(
lp : IDirect3DIndexBuffer9,
typeIndexType : Type,
numberIndices : int,
device : Device,
usage : Usage,
pool : Pool
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9. Unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.
typeIndexType | System.Type. Member of the Type Leave Site that indicates the type of index data the buffer holds. This can be a value type or any type that contains only value types.
numberIndices | System.Int32. Maximum number of indices the buffer can hold.
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the index buffer.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes a valid memory class into which to place the resource.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft® Direct3D® to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IDirect3DIndexBuffer9,Device,Usage,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.IndexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DIndexBuffer9, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public IndexBuffer(
IDirect3DIndexBuffer9 lp,
Device device,
Usage usage,
Pool pool
);
Managed C++ public: IndexBuffer(
IDirect3DIndexBuffer9 lp,
Device *device,
Usage usage,
Pool pool
);
JScript .NET public function IndexBuffer(
lp : IDirect3DIndexBuffer9,
device : Device,
usage : Usage,
pool : Pool
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9. Unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the index buffer.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes a valid memory class into which to place the resource.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft® Direct3D® to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(Device,Int32,Usage,Pool,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.IndexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal sizeOfBufferInBytes As Integer, _
ByVal usage As Usage, _
ByVal pool As Pool, _
ByVal sixteenBitIndices As Boolean _
)
C# public IndexBuffer(
Device device,
int sizeOfBufferInBytes,
Usage usage,
Pool pool,
bool sixteenBitIndices
);
Managed C++ public: IndexBuffer(
Device *device,
int sizeOfBufferInBytes,
Usage usage,
Pool pool,
bool sixteenBitIndices
);
JScript .NET public function IndexBuffer(
device : Device,
sizeOfBufferInBytes : int,
usage : Usage,
pool : Pool,
sixteenBitIndices : boolean
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the index buffer.
sizeOfBufferInBytes | System.Int32. Size of the index buffer in bytes.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes a valid memory class into which to place the resource.
sixteenBitIndices | System.Boolean. Set to true if the index buffer contains 16-bit indices. Set to false if the index buffer contains 32-bit indices.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft® Direct3D® to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(Type,Int32,Device,Usage,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.IndexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal typeIndexType As Type, _
ByVal numberIndices As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public IndexBuffer(
Type typeIndexType,
int numberIndices,
Device device,
Usage usage,
Pool pool
);
Managed C++ public: IndexBuffer(
Type *typeIndexType,
int numberIndices,
Device *device,
Usage usage,
Pool pool
);
JScript .NET public function IndexBuffer(
typeIndexType : Type,
numberIndices : int,
device : Device,
usage : Usage,
pool : Pool
);

Parameters

typeIndexType | System.Type. Member of the Type Leave Site that indicates the type of index data the buffer holds. This can be a value type or any type that contains only value types.
numberIndices | System.Int32. Maximum number of indices the buffer can hold.
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the index buffer.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes a valid memory class into which to place the resource.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft® Direct3D® to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.Lock

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Overload List

public GraphicsStream Lock(int, int, LockFlags);
public Array Lock(int, LockFlags);
public Array Lock(int, Type, LockFlags, int[]);

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.Lock(Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Definition

Visual Basic .NET Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal flags As LockFlags _
) As Array
C# public Array Lock(
int offsetToLock,
LockFlags flags
);
Managed C++ public: Array* Lock(
int offsetToLock,
LockFlags flags
);
JScript .NET public function Lock(
offsetToLock : int,
flags : LockFlags
) : Array;

Parameters

offsetToLock | System.Int32. Offset into the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, NoOverwrite, and ReadOnly.

Return Value

System.Array . An Array Leave Site that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.Lock(Int32,Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Definition

Visual Basic .NET Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal sizeToLock As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
Managed C++ public: GraphicsStream* Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
JScript .NET public function Lock(
offsetToLock : int,
sizeToLock : int,
flags : LockFlags
) : GraphicsStream;

Parameters

offsetToLock | System.Int32. Offset into the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
sizeToLock | System.Int32. Size of the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, NoOverwrite, and ReadOnly.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.Lock(Int32,Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Definition

Visual Basic .NET Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal typeIndex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array Lock(
int offsetToLock,
Type typeIndex,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* Lock(
int offsetToLock,
Type *typeIndex,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function Lock(
offsetToLock : int,
typeIndex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

offsetToLock | System.Int32. Offset into the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
typeIndex | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, NoOverwrite, and ReadOnly.
ranks | System.Int32[]. Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.raise_Created(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.raise_Created Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises an IndexBuffer.Created event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Created( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Created(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Created(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Created(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


IndexBuffer.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.IndexBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


IndexBuffer.SetData(Object,Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.SetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks, sets, and unlocks a range of vertex data.

Definition

Visual Basic .NET Public Sub SetData( _
ByVal data As Object, _
ByVal lockAtOffset As Integer, _
ByVal flags As LockFlags _
)
C# public void SetData(
object data,
int lockAtOffset,
LockFlags flags
);
Managed C++ public: void SetData(
Object *data,
int lockAtOffset,
LockFlags flags
);
JScript .NET public function SetData(
data : Object,
lockAtOffset : int,
flags : LockFlags
);

Parameters

data | System.Object. An Object Leave Site that contains the data to copy into the index buffer.
lockAtOffset | System.Int32. Offset to set in the index buffer. To set the entire buffer, set this parameter to 0.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags locking flags that describe the type of lock to perform when setting the buffer. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Remarks

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


IndexBuffer.Unlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Unlock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Unlocks index data.

Definition

Visual Basic .NET | Public Sub Unlock()
C# | public void Unlock();
Managed C++ | public: void Unlock();
JScript .NET | public function Unlock();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


IndexBuffer.UpdateUnmanagedPointer(IDirect3DIndexBuffer9)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this IndexBuffer object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DIndexBuffer9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DIndexBuffer9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DIndexBuffer9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DIndexBuffer9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9. Pointer to the IDirect3DIndexBuffer9 structure used to update the unmanaged pointer for this IndexBuffer object.


IndexBuffer.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a description of the index buffer resource.

Definition

Visual Basic .NET | Public ReadOnly Property Description As IndexBufferDescription
C# | public IndexBufferDescription Description { get; }
Managed C++ | public: __property IndexBufferDescription get_Description();
JScript .NET | public function get Description() : IndexBufferDescription

Property Value

Microsoft.DirectX.Direct3D.IndexBufferDescription . An IndexBufferDescription structure that describes the returned index buffer.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


IndexBuffer.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


IndexBuffer.SizeInBytes

IndexBuffer.SizeInBytes Property

Note: This documentation is preliminary and is subject to change.

Retrieves the size of the IndexBuffer data, in bytes.

Definition

Visual Basic .NET | Public ReadOnly Property SizeInBytes As Integer
C# | public int SizeInBytes { get; }
Managed C++ | public: __property int get_SizeInBytes();
JScript .NET | public function get SizeInBytes() : int

Property Value

System.Int32 . The size of the IndexBuffer data, in bytes.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


IndexBuffer.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DIndexBuffer9
C# | public IDirect3DIndexBuffer9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DIndexBuffer9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DIndexBuffer9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9 . Unmanaged IDirect3DIndexBuffer9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


IndexBuffer.Created

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Created Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after a device is reset and the IndexBuffer is re-created.

Definition

Visual Basic .NET | Public Event Created As EventHandler
C# | public event EventHandler Created;
Managed C++ | public: __event EventHandler Created;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

Note: This event occurs only on Pool.Default resources.

To add an event handler that listens for an IndexBuffer.Created event, use the following C# code.

[C#]
indexBuffer.Created += new System.EventHandler(this.CreatedEventHandler);


IndexBuffer.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBuffer.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the IndexBuffer object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.IndexBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the IndexBuffer object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.InterfaceGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates various object globally unique identifiers (GUIDs) for use with the Surface.GetContainer and Volume.GetContainer methods.

Definition

Visual Basic .NET NotInheritable Public Class InterfaceGuid
Inherits Object
C# | public sealed class InterfaceGuid : Object
Managed C++ | public __gc __sealed class InterfaceGuid : public Object
JScript .NET | public class InterfaceGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) BaseTexture | Specifies the BaseTexture GUID.
static (Shared in Visual Basic .NET) CubeTexture | Specifies the CubeTexture GUID.
static (Shared in Visual Basic .NET) Device | Specifies the Device GUID.
static (Shared in Visual Basic .NET) IndexBuffer | Specifies the IndexBuffer GUID.
static (Shared in Visual Basic .NET) PixelShader | Specifies the PixelShader GUID.
static (Shared in Visual Basic .NET) Resource | Specifies the Resource GUID.
static (Shared in Visual Basic .NET) StateBlock | Specifies the StateBlock GUID.
static (Shared in Visual Basic .NET) Surface | Specifies the Surface GUID.
static (Shared in Visual Basic .NET) SwapChain | Specifies the SwapChain GUID.
static (Shared in Visual Basic .NET) VertexBuffer | Specifies the VertexBuffer GUID.
static (Shared in Visual Basic .NET) VertexDeclaration | Specifies the VertexDeclaration GUID.
static (Shared in Visual Basic .NET) VertexShader | Specifies the VertexShader GUID.
static (Shared in Visual Basic .NET) Volume | Specifies the Volume GUID.
static (Shared in Visual Basic .NET) VolumeTexture | Specifies the VolumeTexture GUID.

Inheritance Hierarchy

Object Leave Site
InterfaceGuid

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InterfaceGuid.BaseTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.BaseTexture Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the BaseTexture globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared BaseTexture As Guid
C# | public static Guid BaseTexture;
Managed C++ | public: static Guid BaseTexture;
JScript .NET | public static var BaseTexture : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the BaseTexture GUID.

This field is read-only.


InterfaceGuid.CubeTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.CubeTexture Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the CubeTexture globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared CubeTexture As Guid
C# | public static Guid CubeTexture;
Managed C++ | public: static Guid CubeTexture;
JScript .NET | public static var CubeTexture : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the CubeTexture GUID.

This field is read-only.


InterfaceGuid.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.Device Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the Device globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared Device As Guid
C# | public static Guid Device;
Managed C++ | public: static Guid Device;
JScript .NET | public static var Device : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the Device GUID.

This field is read-only.


InterfaceGuid.IndexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.IndexBuffer Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the IndexBuffer globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared IndexBuffer As Guid
C# | public static Guid IndexBuffer;
Managed C++ | public: static Guid IndexBuffer;
JScript .NET | public static var IndexBuffer : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the IndexBuffer GUID.

This field is read-only.


InterfaceGuid.PixelShader

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.PixelShader Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the PixelShader globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared PixelShader As Guid
C# | public static Guid PixelShader;
Managed C++ | public: static Guid PixelShader;
JScript .NET | public static var PixelShader : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the PixelShader GUID.

This field is read-only.


InterfaceGuid.Resource

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.Resource Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the Resource globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared Resource As Guid
C# | public static Guid Resource;
Managed C++ | public: static Guid Resource;
JScript .NET | public static var Resource : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the Resource GUID.

This field is read-only.


InterfaceGuid.StateBlock

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.StateBlock Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the StateBlock globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared StateBlock As Guid
C# | public static Guid StateBlock;
Managed C++ | public: static Guid StateBlock;
JScript .NET | public static var StateBlock : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the StateBlock GUID.

This field is read-only.


InterfaceGuid.Surface

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.Surface Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the Surface globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared Surface As Guid
C# | public static Guid Surface;
Managed C++ | public: static Guid Surface;
JScript .NET | public static var Surface : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the Surface GUID.

This field is read-only.


InterfaceGuid.SwapChain

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.SwapChain Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the SwapChain globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared SwapChain As Guid
C# | public static Guid SwapChain;
Managed C++ | public: static Guid SwapChain;
JScript .NET | public static var SwapChain : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the SwapChain GUID.

This field is read-only.


InterfaceGuid.VertexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.VertexBuffer Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the VertexBuffer globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared VertexBuffer As Guid
C# | public static Guid VertexBuffer;
Managed C++ | public: static Guid VertexBuffer;
JScript .NET | public static var VertexBuffer : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the VertexBuffer GUID.

This field is read-only.


InterfaceGuid.VertexDeclaration

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.VertexDeclaration Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the VertexDeclaration globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared VertexDeclaration As Guid
C# | public static Guid VertexDeclaration;
Managed C++ | public: static Guid VertexDeclaration;
JScript .NET | public static var VertexDeclaration : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the VertexDeclaration GUID.

This field is read-only.


InterfaceGuid.VertexShader

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.VertexShader Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the VertexShader globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared VertexShader As Guid
C# | public static Guid VertexShader;
Managed C++ | public: static Guid VertexShader;
JScript .NET | public static var VertexShader : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the VertexShader GUID.

This field is read-only.


InterfaceGuid.Volume

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.Volume Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the Volume globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared Volume As Guid
C# | public static Guid Volume;
Managed C++ | public: static Guid Volume;
JScript .NET | public static var Volume : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the Volume GUID.

This field is read-only.


InterfaceGuid.VolumeTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceGuid.VolumeTexture Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the VolumeTexture globally unique identifier (GUID).

Definition

Visual Basic .NET | Public Shared VolumeTexture As Guid
C# | public static Guid VolumeTexture;
Managed C++ | public: static Guid VolumeTexture;
JScript .NET | public static var VolumeTexture : Guid

Field Value

System.Guid . A Guid Leave Site object that represents the VolumeTexture GUID.

This field is read-only.


Microsoft.DirectX.Direct3D.InvalidCallException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCallException Class

Language:
Note: This documentation is preliminary and is subject to change.

The method call is invalid. For example, a method's parameter might not be valid.

Definition

Visual Basic .NET Public Class InvalidCallException
Inherits GraphicsException
C# | public class InvalidCallException : GraphicsException
Managed C++ | public __gc class InvalidCallException : public GraphicsException
JScript .NET | public class InvalidCallException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCallException | Initializes a new instance of the InvalidCallException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidCallException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidCallException.InvalidCallException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCallException.InvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidCallException class.

Overload List

public InvalidCallException();
protected InvalidCallException(SerializationInfo, StreamingContext);
public InvalidCallException(string);
public InvalidCallException(string, Exception);


InvalidCallException.InvalidCallException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCallException.InvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidCallException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidCallException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidCallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidCallException.InvalidCallException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCallException.InvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidCallException(
string message,
Exception inner
);
Managed C++ public: InvalidCallException(
String *message,
Exception *inner
);
JScript .NET public function InvalidCallException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


InvalidCallException.InvalidCallException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCallException.InvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidCallException(
string message
);
Managed C++ public: InvalidCallException(
String *message
);
JScript .NET public function InvalidCallException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


InvalidCallException.InvalidCallException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCallException.InvalidCallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidCallException();
Managed C++ | public: InvalidCallException();
JScript .NET | public function InvalidCallException();


Microsoft.DirectX.Direct3D.InvalidDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDataException Class

Language:
Note: This documentation is preliminary and is subject to change.

The data is invalid.

Definition

Visual Basic .NET Public Class InvalidDataException
Inherits Direct3DXException
C# | public class InvalidDataException : Direct3DXException
Managed C++ | public __gc class InvalidDataException : public Direct3DXException
JScript .NET | public class InvalidDataException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDataException | Initializes a new instance of the InvalidDataException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
InvalidDataException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidDataException.InvalidDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDataException.InvalidDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDataException class.

Overload List

public InvalidDataException();
protected InvalidDataException(SerializationInfo, StreamingContext);
public InvalidDataException(string);
public InvalidDataException(string, Exception);


InvalidDataException.InvalidDataException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDataException.InvalidDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDataException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidDataException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidDataException.InvalidDataException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDataException.InvalidDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDataException(
string message,
Exception inner
);
Managed C++ public: InvalidDataException(
String *message,
Exception *inner
);
JScript .NET public function InvalidDataException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


InvalidDataException.InvalidDataException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDataException.InvalidDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidDataException(
string message
);
Managed C++ public: InvalidDataException(
String *message
);
JScript .NET public function InvalidDataException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


InvalidDataException.InvalidDataException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDataException.InvalidDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidDataException();
Managed C++ | public: InvalidDataException();
JScript .NET | public function InvalidDataException();


Microsoft.DirectX.Direct3D.InvalidDeviceException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException Class

Language:
Note: This documentation is preliminary and is subject to change.

The requested device type is not valid.

Definition

Visual Basic .NET Public Class InvalidDeviceException
Inherits GraphicsException
C# | public class InvalidDeviceException : GraphicsException
Managed C++ | public __gc class InvalidDeviceException : public GraphicsException
JScript .NET | public class InvalidDeviceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDeviceException | Initializes a new instance of the InvalidDeviceException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidDeviceException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidDeviceException.InvalidDeviceException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDeviceException class.

Overload List

public InvalidDeviceException();
protected InvalidDeviceException(SerializationInfo, StreamingContext);
public InvalidDeviceException(string);
public InvalidDeviceException(string, Exception);


InvalidDeviceException.InvalidDeviceException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDeviceException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidDeviceException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidDeviceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidDeviceException.InvalidDeviceException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDeviceException(
string message,
Exception inner
);
Managed C++ public: InvalidDeviceException(
String *message,
Exception *inner
);
JScript .NET public function InvalidDeviceException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


InvalidDeviceException.InvalidDeviceException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidDeviceException(
string message
);
Managed C++ public: InvalidDeviceException(
String *message
);
JScript .NET public function InvalidDeviceException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


InvalidDeviceException.InvalidDeviceException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidDeviceException();
Managed C++ | public: InvalidDeviceException();
JScript .NET | public function InvalidDeviceException();


Microsoft.DirectX.Direct3D.InvalidMeshException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidMeshException Class

Language:
Note: This documentation is preliminary and is subject to change.

The mesh is invalid.

Definition

Visual Basic .NET Public Class InvalidMeshException
Inherits Direct3DXException
C# | public class InvalidMeshException : Direct3DXException
Managed C++ | public __gc class InvalidMeshException : public Direct3DXException
JScript .NET | public class InvalidMeshException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidMeshException | Initializes a new instance of the InvalidMeshException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
InvalidMeshException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidMeshException.InvalidMeshException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidMeshException.InvalidMeshException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidMeshException class.

Overload List

public InvalidMeshException();
protected InvalidMeshException(SerializationInfo, StreamingContext);
public InvalidMeshException(string);
public InvalidMeshException(string, Exception);


InvalidMeshException.InvalidMeshException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidMeshException.InvalidMeshException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidMeshException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidMeshException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidMeshException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidMeshException.InvalidMeshException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidMeshException.InvalidMeshException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidMeshException(
string message,
Exception inner
);
Managed C++ public: InvalidMeshException(
String *message,
Exception *inner
);
JScript .NET public function InvalidMeshException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


InvalidMeshException.InvalidMeshException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidMeshException.InvalidMeshException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidMeshException(
string message
);
Managed C++ public: InvalidMeshException(
String *message
);
JScript .NET public function InvalidMeshException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


InvalidMeshException.InvalidMeshException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidMeshException.InvalidMeshException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidMeshException();
Managed C++ | public: InvalidMeshException();
JScript .NET | public function InvalidMeshException();


Microsoft.DirectX.Direct3D.KeyframedAnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet Class

Language:
Note: This documentation is preliminary and is subject to change.

Implements a keyframe animation set.

Definition

Visual Basic .NET NotInheritable Public Class KeyframedAnimationSet
Inherits AnimationSet
C# | public sealed class KeyframedAnimationSet : AnimationSet
Managed C++ | public __gc __sealed class KeyframedAnimationSet : public AnimationSet
JScript .NET | public class KeyframedAnimationSet extends AnimationSet

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the KeyframedAnimationSet object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Compress | Transforms animations in an animation set into a compressed format and returns the compressed data.
Dispose | Immediately releases the unmanaged resources used by the KeyframedAnimationSet object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the KeyframedAnimationSet object to free resources before it is destroyed by the garbage collector.
GetAnimationIndex | Retrieves the index of an animation, given its name. Inherited from AnimationSet.
GetAnimationName | Retrieves the name of an animation, given its index. Inherited from AnimationSet.
GetCallback | Retrieves information about a specific callback in an animation set. Inherited from AnimationSet.
GetCallbackKey | Retrieves information about a specific callback in the animation set.
GetCallbackKeys | Fills an array with callback key data used for keyframe animation.
GetHashCode | Returns the hash code for the current instance.
GetNumberRotationKeys | Retrieves the number of rotation keys in the specified keyframe animation.
GetNumberScaleKeys | Retrieves the number of scale keys in the specified keyframe animation.
GetNumberTranslationKeys | Retrieves the number of translation keys in the specified keyframe animation.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPeriodicPosition | Returns the time position in the local timeframe of an animation set. Inherited from AnimationSet.
GetRotationKey | Retrieves rotation information for a specific key frame in the animation set.
GetRotationKeys | Fills an array with rotational key data used for keyframe animation.
GetScaleKey | Retrieves scale information for a specific key frame in the animation set.
GetScaleKeys | Fills an array with scale key data used for keyframe animation.
GetScaleRotateTranslate | Retrieves the scale, rotate, and translate (SRT) values of an animation set. Inherited from AnimationSet.
GetTranslationKey | Retrieves translation information for a specific key frame in the animation set.
GetTranslationKeys | Fills an array with translational key data used for keyframe animation.
KeyframedAnimationSet | Creates a KeyframedAnimationSet.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from AnimationSet.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from AnimationSet.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing event when called from within a derived class.
RegisterAnimationKeys | Registers all of the scale, rotate, and translate (SRT) keyframe data of an animation, and fills arrays with SRT key data used for keyframe animation.
SetCallbackKey | Sets information about a specific callback in the animation set.
SetRotationKey | Sets rotation information for a specific key frame in the animation set.
SetScaleKey | Sets scale information for a specific key frame in the animation set.
SetTranslationKey | Sets translation information for a specific key frame in the animation set.
UnregisterAnimation | Removes the animation data from the animation set.
UnregisterRotationKey | Removes the rotation data at the specified key frame.
UnregisterScaleKey | Removes the scale data at the specified key frame.
UnregisterTranslationKey | Removes the translation data at the specified key frame.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code. Inherited from AnimationSet.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this KeyframedAnimationSet object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Name | Retrieves the name of an animation set. Inherited from AnimationSet.
NumberAnimations | Retrieves a value that indicates the number of animations in the animation set. Inherited from AnimationSet.
NumberCallbackKeys | Retrieves the number of callback keys in an animation set.
Period | Retrieves the period of an animation set. Inherited from AnimationSet.
PlaybackType | Retrieves the type of the animation set playback loop.
SourceTicksPerSecond | Retrieves the number of animation keyframe ticks that occur per second.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface pointer.
UnmanagedComPointer | Returns the unmanaged COM ID3DXAnimationSet interface pointer. Inherited from AnimationSet.

Inheritance Hierarchy

Object Leave Site
AnimationSet
KeyframedAnimationSet

Remarks

A KeyframedAnimationSet is a class that encapsulates a set of rotation, translation, and scale data over time. Typically, this class is used to manipulate a set of animations that represent the actions of a character, such as walking, running, or sitting. Multiple KeyframedAnimationSet classes can run animations in different tracks of an AnimationController class, which can blend the animations together to create a single seamless animation.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CompressedAnimationSet


KeyframedAnimationSet.Compress(CompressionFlags,Single,Frame)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.Compress Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms animations in an animation set into a compressed format and returns the compressed data.

Definition

Visual Basic .NET Public Function Compress( _
ByVal flags As CompressionFlags, _
ByVal lossiness As Single, _
ByVal hierarchy As Frame _
) As GraphicsStream
C# public GraphicsStream Compress(
CompressionFlags flags,
float lossiness,
Frame hierarchy
);
Managed C++ public: GraphicsStream* Compress(
CompressionFlags flags,
float lossiness,
Frame *hierarchy
);
JScript .NET public function Compress(
flags : CompressionFlags,
lossiness : float,
hierarchy : Frame
) : GraphicsStream;

Parameters

flags | Microsoft.DirectX.Direct3D.CompressionFlags. One of the CompressionFlags values that define the compression mode used for storing compressed animation set data.
lossiness | System.Single. Desired compression loss ratio, in the range of 0 to 1.
hierarchy | Microsoft.DirectX.Direct3D.Frame. A Frame transformation frame hierarchy. Can be null.

Return Value

Microsoft.DirectX.GraphicsStream . A CompressedAnimationSet object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the KeyframedAnimationSet object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposed
  • Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing


KeyframedAnimationSet.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


KeyframedAnimationSet.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the KeyframedAnimationSet object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~KeyframedAnimationSet();
Managed C++ | ~KeyframedAnimationSet();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


KeyframedAnimationSet.GetCallbackKey(Int32)

KeyframedAnimationSet.GetCallbackKey Method

Note: This documentation is preliminary and is subject to change.

Retrieves information about a specific callback in the animation set.

Definition

Visual Basic .NET Public Function GetCallbackKey( _
ByVal index As Integer _
) As KeyCallback
C# public KeyCallback GetCallbackKey(
int index
);
Managed C++ public: KeyCallback GetCallbackKey(
int index
);
JScript .NET public function GetCallbackKey(
index : int
) : KeyCallback;

Parameters

index System.Int32. An integer that represents the animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyCallback . A KeyCallback object that describes the animation's callback key.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetCallbackKeys()

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetCallbackKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Fills an array with callback key data used for keyframe animation.

Definition

Visual Basic .NET | Public Function GetCallbackKeys() As KeyCallback()
C# | public KeyCallback[] GetCallbackKeys();
Managed C++ | public: KeyCallback GetCallbackKeys() __gc[];
JScript .NET | public function GetCallbackKeys() : KeyCallback[];

Return Value

Microsoft.DirectX.Direct3D.KeyCallback[]. Array of KeyCallback structures that contain callback data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • KeyframedAnimationSet.NumberCallbackKeys


KeyframedAnimationSet.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


KeyframedAnimationSet.GetNumberRotationKeys(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetNumberRotationKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of rotation keys in the specified keyframe animation.

Definition

Visual Basic .NET Public Function GetNumberRotationKeys( _
ByVal animation As Integer _
) As Integer
C# public int GetNumberRotationKeys(
int animation
);
Managed C++ public: int GetNumberRotationKeys(
int animation
);
JScript .NET public function GetNumberRotationKeys(
animation : int
) : int;

Parameters

animation System.Int32. Animation index.

Return Value

System.Int32 . Number of rotation keys in the specified keyframe animation.


KeyframedAnimationSet.GetNumberScaleKeys(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetNumberScaleKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of scale keys in the specified keyframe animation.

Definition

Visual Basic .NET Public Function GetNumberScaleKeys( _
ByVal animation As Integer _
) As Integer
C# public int GetNumberScaleKeys(
int animation
);
Managed C++ public: int GetNumberScaleKeys(
int animation
);
JScript .NET public function GetNumberScaleKeys(
animation : int
) : int;

Parameters

animation System.Int32. Animation index.

Return Value

System.Int32 . Number of scale keys in the specified keyframe animation.


KeyframedAnimationSet.GetNumberTranslationKeys(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetNumberTranslationKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of translation keys in the specified keyframe animation.

Definition

Visual Basic .NET Public Function GetNumberTranslationKeys( _
ByVal animation As Integer _
) As Integer
C# public int GetNumberTranslationKeys(
int animation
);
Managed C++ public: int GetNumberTranslationKeys(
int animation
);
JScript .NET public function GetNumberTranslationKeys(
animation : int
) : int;

Parameters

animation System.Int32. Animation index.

Return Value

System.Int32 . Number of translation keys in the specified keyframe animation.


KeyframedAnimationSet.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXKeyframedAnimationSet, which allows unmanaged COM clients to create an instance of the managed KeyframedAnimationSet class. Not supported.


KeyframedAnimationSet.GetRotationKey(Int32,Int32)

KeyframedAnimationSet.GetRotationKey Method

Note: This documentation is preliminary and is subject to change.

Retrieves rotation information for a specific key frame in the animation set.

Definition

Visual Basic .NET Public Function GetRotationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
) As KeyQuaternion
C# public KeyQuaternion GetRotationKey(
int animation,
int key
);
Managed C++ public: KeyQuaternion GetRotationKey(
int animation,
int key
);
JScript .NET public function GetRotationKey(
animation : int,
key : int
) : KeyQuaternion;

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.

Return Value

Microsoft.DirectX.Direct3D.KeyQuaternion . A KeyQuaternion object that contains the key frame's rotation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetRotationKeys(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetRotationKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Fills an array with rotational key data used for keyframe animation.

Definition

Visual Basic .NET Public Function GetRotationKeys( _
ByVal animation As Integer _
) As KeyQuaternion()
C# public KeyQuaternion[] GetRotationKeys(
int animation
);
Managed C++ public: KeyQuaternion GetRotationKeys(
int animation
) __gc[];
JScript .NET public function GetRotationKeys(
animation : int
) : KeyQuaternion[];

Parameters

animation System.Int32. Animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyQuaternion[]. Array of KeyQuaternion structures that contain animation rotation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberRotationKeys


KeyframedAnimationSet.GetScaleKey(Int32,Int32)

KeyframedAnimationSet.GetScaleKey Method

Note: This documentation is preliminary and is subject to change.

Retrieves scale information for a specific key frame in the animation set.

Definition

Visual Basic .NET Public Function GetScaleKey( _
ByVal animation As Integer, _
ByVal key As Integer _
) As KeyVector3
C# public KeyVector3 GetScaleKey(
int animation,
int key
);
Managed C++ public: KeyVector3 GetScaleKey(
int animation,
int key
);
JScript .NET public function GetScaleKey(
animation : int,
key : int
) : KeyVector3;

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3 . A KeyVector3 object that contains the key frame's scale data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetScaleKeys(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetScaleKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Fills an array with scale key data used for keyframe animation.

Definition

Visual Basic .NET Public Function GetScaleKeys( _
ByVal animation As Integer _
) As KeyVector3()
C# public KeyVector3[] GetScaleKeys(
int animation
);
Managed C++ public: KeyVector3 GetScaleKeys(
int animation
) __gc[];
JScript .NET public function GetScaleKeys(
animation : int
) : KeyVector3[];

Parameters

animation System.Int32. Animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3[]. Array of KeyVector3 structures that contain animation scale data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberScaleKeys


KeyframedAnimationSet.GetTranslationKey(Int32,Int32)

KeyframedAnimationSet.GetTranslationKey Method

Note: This documentation is preliminary and is subject to change.

Retrieves translation information for a specific key frame in the animation set.

Definition

Visual Basic .NET Public Function GetTranslationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
) As KeyVector3
C# public KeyVector3 GetTranslationKey(
int animation,
int key
);
Managed C++ public: KeyVector3 GetTranslationKey(
int animation,
int key
);
JScript .NET public function GetTranslationKey(
animation : int,
key : int
) : KeyVector3;

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3 . A KeyVector3 object that contains the key frame's translation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetTranslationKeys(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.GetTranslationKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Fills an array with translational key data used for keyframe animation.

Definition

Visual Basic .NET Public Function GetTranslationKeys( _
ByVal animation As Integer _
) As KeyVector3()
C# public KeyVector3[] GetTranslationKeys(
int animation
);
Managed C++ public: KeyVector3 GetTranslationKeys(
int animation
) __gc[];
JScript .NET public function GetTranslationKeys(
animation : int
) : KeyVector3[];

Parameters

animation System.Int32. Animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3[]. Array of KeyVector3 structures that contain animation translation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberTranslationKeys


KeyframedAnimationSet.KeyframedAnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.KeyframedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a KeyframedAnimationSet.

Overload List

public KeyframedAnimationSet(ID3DXKeyframedAnimationSet);
public KeyframedAnimationSet(IntPtr);
public KeyframedAnimationSet(string, double, PlaybackType, int, KeyCallback[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.KeyframedAnimationSet(ID3DXKeyframedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.KeyframedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a KeyframedAnimationSet.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As ID3DXKeyframedAnimationSet _
)
C# public KeyframedAnimationSet(
ID3DXKeyframedAnimationSet pInterop
);
Managed C++ public: KeyframedAnimationSet(
ID3DXKeyframedAnimationSet pInterop
);
JScript .NET public function KeyframedAnimationSet(
pInterop : ID3DXKeyframedAnimationSet
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXKeyframedAnimationSet. Unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.KeyframedAnimationSet(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.KeyframedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a KeyframedAnimationSet.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public KeyframedAnimationSet(
IntPtr unmanagedObject
);
Managed C++ public: KeyframedAnimationSet(
IntPtr unmanagedObject
);
JScript .NET public function KeyframedAnimationSet(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.KeyframedAnimationSet(String,Double,PlaybackType,Int32,KeyCallback[])

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.KeyframedAnimationSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a KeyframedAnimationSet.

Definition

Visual Basic .NET Public Sub New( _
ByVal name As String, _
ByVal ticksPerSecond As Double, _
ByVal playback As PlaybackType, _
ByVal numberAnimations As Integer, _
ByVal callbackKeys() As KeyCallback _
)
C# public KeyframedAnimationSet(
string name,
double ticksPerSecond,
PlaybackType playback,
int numberAnimations,
KeyCallback[] callbackKeys
);
Managed C++ public: KeyframedAnimationSet(
String *name,
double ticksPerSecond,
PlaybackType playback,
int numberAnimations,
KeyCallback callbackKeys __gc[]
);
JScript .NET public function KeyframedAnimationSet(
name : String,
ticksPerSecond : double,
playback : PlaybackType,
numberAnimations : int,
callbackKeys : KeyCallback[]
);

Parameters

name | System.String. String that contains the name of the animation set.
ticksPerSecond | System.Double. Number of key-frame ticks that elapse per second.
playback | Microsoft.DirectX.Direct3D.PlaybackType. Type of the animation set playback loop. For more information, see PlaybackType.
numberAnimations | System.Int32. Number of scale, rotate, and translate (SRT) animation sets.
callbackKeys | Microsoft.DirectX.Direct3D.KeyCallback[]. Array that contains the callback keys.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.op_Equality(KeyframedAnimationSet,KeyframedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As KeyframedAnimationSet, _
ByVal right As KeyframedAnimationSet _
) As Boolean
C# public static bool op_Equality(
KeyframedAnimationSet left,
KeyframedAnimationSet right
);
Managed C++ public: static bool op_Equality(
KeyframedAnimationSet *left,
KeyframedAnimationSet *right
);
JScript .NET public static function op_Equality(
left : KeyframedAnimationSet,
right : KeyframedAnimationSet
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.KeyframedAnimationSet. The KeyframedAnimationSet object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.KeyframedAnimationSet. The KeyframedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


KeyframedAnimationSet.op_Inequality(KeyframedAnimationSet,KeyframedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As KeyframedAnimationSet, _
ByVal right As KeyframedAnimationSet _
) As Boolean
C# public static bool op_Inequality(
KeyframedAnimationSet left,
KeyframedAnimationSet right
);
Managed C++ public: static bool op_Inequality(
KeyframedAnimationSet *left,
KeyframedAnimationSet *right
);
JScript .NET public static function op_Inequality(
left : KeyframedAnimationSet,
right : KeyframedAnimationSet
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.KeyframedAnimationSet. The KeyframedAnimationSet object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.KeyframedAnimationSet. The KeyframedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


KeyframedAnimationSet.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


KeyframedAnimationSet.RegisterAnimationKeys(String,KeyVector3[],KeyQuaternion[],KeyVector3[])

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.RegisterAnimationKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Registers all of the scale, rotate, and translate (SRT) keyframe data of an animation, and fills arrays with SRT key data used for keyframe animation.

Definition

Visual Basic .NET Public Function RegisterAnimationKeys( _
ByVal animationName As String, _
ByVal scaleKeys() As KeyVector3, _
ByVal rotationKeys() As KeyQuaternion, _
ByVal translationKeys() As KeyVector3 _
) As Integer
C# public int RegisterAnimationKeys(
string animationName,
KeyVector3[] scaleKeys,
KeyQuaternion[] rotationKeys,
KeyVector3[] translationKeys
);
Managed C++ public: int RegisterAnimationKeys(
String *animationName,
KeyVector3 scaleKeys __gc[],
KeyQuaternion rotationKeys __gc[],
KeyVector3 translationKeys __gc[]
);
JScript .NET public function RegisterAnimationKeys(
animationName : String,
scaleKeys : KeyVector3[],
rotationKeys : KeyQuaternion[],
translationKeys : KeyVector3[]
) : int;

Parameters

animationName | System.String. String that contains the animation name.
scaleKeys | Microsoft.DirectX.Direct3D.KeyVector3[]. Array of KeyVector3 structures that contain animation scale data.
rotationKeys | Microsoft.DirectX.Direct3D.KeyQuaternion[]. Array of KeyQuaternion structures that contain animation rotation data.
translationKeys | Microsoft.DirectX.Direct3D.KeyVector3[]. Array of KeyVector3 structures that contain animation translation data.

Return Value

System.Int32 . The animation index.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberRotationKeys
  • GetNumberScaleKeys
  • GetNumberTranslationKeys


KeyframedAnimationSet.SetCallbackKey(Int32,KeyCallback)

KeyframedAnimationSet.SetCallbackKey Method

Note: This documentation is preliminary and is subject to change.

Sets information about a specific callback in the animation set.

Definition

Visual Basic .NET Public Sub SetCallbackKey( _
ByVal index As Integer, _
ByVal value As KeyCallback _
)
C# public void SetCallbackKey(
int index,
KeyCallback value
);
Managed C++ public: void SetCallbackKey(
int index,
KeyCallback value
);
JScript .NET public function SetCallbackKey(
index : int,
value : KeyCallback
);

Parameters

index | System.Int32. An integer that represents the animation index.
value | Microsoft.DirectX.Direct3D.KeyCallback. A KeyCallback object that describes the animation's callback key.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.SetRotationKey(Int32,Int32,KeyQuaternion)

KeyframedAnimationSet.SetRotationKey Method

Note: This documentation is preliminary and is subject to change.

Sets rotation information for a specific key frame in the animation set.

Definition

Visual Basic .NET Public Sub SetRotationKey( _
ByVal animation As Integer, _
ByVal key As Integer, _
ByVal value As KeyQuaternion _
)
C# public void SetRotationKey(
int animation,
int key,
KeyQuaternion value
);
Managed C++ public: void SetRotationKey(
int animation,
int key,
KeyQuaternion value
);
JScript .NET public function SetRotationKey(
animation : int,
key : int,
value : KeyQuaternion
);

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.
value | Microsoft.DirectX.Direct3D.KeyQuaternion. A KeyQuaternion object that contains the key frame's rotation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.SetScaleKey(Int32,Int32,KeyVector3)

KeyframedAnimationSet.SetScaleKey Method

Note: This documentation is preliminary and is subject to change.

Sets scale information for a specific key frame in the animation set.

Definition

Visual Basic .NET Public Sub SetScaleKey( _
ByVal animation As Integer, _
ByVal key As Integer, _
ByVal value As KeyVector3 _
)
C# public void SetScaleKey(
int animation,
int key,
KeyVector3 value
);
Managed C++ public: void SetScaleKey(
int animation,
int key,
KeyVector3 value
);
JScript .NET public function SetScaleKey(
animation : int,
key : int,
value : KeyVector3
);

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.
value | Microsoft.DirectX.Direct3D.KeyVector3. A KeyVector3 object that contains the key frame's scale data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.SetTranslationKey(Int32,Int32,KeyVector3)

KeyframedAnimationSet.SetTranslationKey Method

Note: This documentation is preliminary and is subject to change.

Sets translation information for a specific key frame in the animation set.

Definition

Visual Basic .NET Public Sub SetTranslationKey( _
ByVal animation As Integer, _
ByVal key As Integer, _
ByVal value As KeyVector3 _
)
C# public void SetTranslationKey(
int animation,
int key,
KeyVector3 value
);
Managed C++ public: void SetTranslationKey(
int animation,
int key,
KeyVector3 value
);
JScript .NET public function SetTranslationKey(
animation : int,
key : int,
value : KeyVector3
);

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.
value | Microsoft.DirectX.Direct3D.KeyVector3. A KeyVector3 object that contains the key frame's translation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterAnimation(Int32)

KeyframedAnimationSet.UnregisterAnimation Method

Note: This documentation is preliminary and is subject to change.

Removes the animation data from the animation set.

Definition

Visual Basic .NET Public Sub UnregisterAnimation( _
ByVal index As Integer _
)
C# public void UnregisterAnimation(
int index
);
Managed C++ public: void UnregisterAnimation(
int index
);
JScript .NET public function UnregisterAnimation(
index : int
);

Parameters

index System.Int32. An integer that represents the index of the animation data to be removed.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterRotationKey(Int32,Int32)

KeyframedAnimationSet.UnregisterRotationKey Method

Note: This documentation is preliminary and is subject to change.

Removes the rotation data at the specified key frame.

Definition

Visual Basic .NET Public Sub UnregisterRotationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
)
C# public void UnregisterRotationKey(
int animation,
int key
);
Managed C++ public: void UnregisterRotationKey(
int animation,
int key
);
JScript .NET public function UnregisterRotationKey(
animation : int,
key : int
);

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterScaleKey(Int32,Int32)

KeyframedAnimationSet.UnregisterScaleKey Method

Note: This documentation is preliminary and is subject to change.

Removes the scale data at the specified key frame.

Definition

Visual Basic .NET Public Sub UnregisterScaleKey( _
ByVal animation As Integer, _
ByVal key As Integer _
)
C# public void UnregisterScaleKey(
int animation,
int key
);
Managed C++ public: void UnregisterScaleKey(
int animation,
int key
);
JScript .NET public function UnregisterScaleKey(
animation : int,
key : int
);

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterTranslationKey(Int32,Int32)

KeyframedAnimationSet.UnregisterTranslationKey Method

Note: This documentation is preliminary and is subject to change.

Removes the translation data at the specified key frame.

Definition

Visual Basic .NET Public Sub UnregisterTranslationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
)
C# public void UnregisterTranslationKey(
int animation,
int key
);
Managed C++ public: void UnregisterTranslationKey(
int animation,
int key
);
JScript .NET public function UnregisterTranslationKey(
animation : int,
key : int
);

Parameters

animation | System.Int32. An integer that represents the animation index.
key | System.Int32. An integer that represents the animation key frame.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UpdateUnmanagedPointer(ID3DXKeyframedAnimationSet)

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this KeyframedAnimationSet object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXKeyframedAnimationSet _
)
C# public void UpdateUnmanagedPointer(
ID3DXKeyframedAnimationSet pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXKeyframedAnimationSet pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXKeyframedAnimationSet
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXKeyframedAnimationSet. Pointer to the ID3DXKeyframedAnimationSet structure used to update the unmanaged pointer for this KeyframedAnimationSet object.


KeyframedAnimationSet.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


KeyframedAnimationSet.NumberCallbackKeys

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.NumberCallbackKeys Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of callback keys in an animation set.

Definition

Visual Basic .NET | Public ReadOnly Property NumberCallbackKeys As Integer
C# | public int NumberCallbackKeys { get; }
Managed C++ | public: __property int get_NumberCallbackKeys();
JScript .NET | public function get NumberCallbackKeys() : int

Property Value

System.Int32 . Number of callback keys in the animation set.

This property is read-only.


KeyframedAnimationSet.PlaybackType

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.PlaybackType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the type of the animation set playback loop.

Definition

Visual Basic .NET | Public ReadOnly Property PlaybackType As PlaybackType
C# | public PlaybackType PlaybackType { get; }
Managed C++ | public: __property PlaybackType get_PlaybackType();
JScript .NET | public function get PlaybackType() : PlaybackType

Property Value

Microsoft.DirectX.Direct3D.PlaybackType . Type of the animation set playback loop. For more information, see PlaybackType.

This property is read-only.


KeyframedAnimationSet.SourceTicksPerSecond

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.SourceTicksPerSecond Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of animation keyframe ticks that occur per second.

Definition

Visual Basic .NET | Public ReadOnly Property SourceTicksPerSecond As Double
C# | public double SourceTicksPerSecond { get; }
Managed C++ | public: __property double get_SourceTicksPerSecond();
JScript .NET | public function get SourceTicksPerSecond() : double

Property Value

System.Double . Number of animation keyframe ticks that occur per second.

This property is read-only.


KeyframedAnimationSet.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXKeyframedAnimationSet
C# | public ID3DXKeyframedAnimationSet UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXKeyframedAnimationSet get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXKeyframedAnimationSet

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXKeyframedAnimationSet . Unmanaged ID3DXKeyframedAnimationSet interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


KeyframedAnimationSet.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyframedAnimationSet.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the KeyframedAnimationSet object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the KeyframedAnimationSet object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.Light

Microsoft DirectX 9.0 SDK Update (October 2004)

Light Class

Language:
Note: This documentation is preliminary and is subject to change.

Defines a set of lighting properties.

Definition

Visual Basic .NET NotInheritable Public Class Light
Inherits Object
C# | public sealed class Light : Object
Managed C++ | public __gc __sealed class Light : public Object
JScript .NET | public class Light extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FromLight | Creates a new light based on an existing light.
Light | Creates a new instance of the Light class.
ToString | Obtains a string representation of the current instance.
Update | Updates the settings for the current Light object.

Properties

Property | Description
Ambient Retrieves or sets the ambient color emitted by the light.

This member is a Color Leave Site structure.
AmbientColor Retrieves or sets the ambient color emitted by the light.

This member is a ColorValue structure.
Attenuation0 | Retrieves or sets a value that specifies how light intensity changes over distance.
Attenuation1 | Retrieves or sets a value that specifies how light intensity changes over distance.
Attenuation2 | Retrieves or sets a value that specifies how light intensity changes over distance.
Diffuse Retrieves or sets the diffuse color emitted by the light.

This member is a Color Leave Site structure.
DiffuseColor Retrieves or sets the diffuse color emitted by the light.

This member is a ColorValue structure.
Direction | Retrieves or sets the direction in which the light is pointing in world space, as specified by a Vector3 structure.
Enabled | Retrieves or sets a Boolean value that enables or disables a set of lighting parameters within a device.
Falloff | Retrieves or sets the decrease in illumination between a spotlight's inner cone (the angle specified by InnerConeAngle) and the outer edge of the outer cone (the angle specified by OuterConeAngle).
InnerConeAngle | Retrieves or sets the angle, in radians, of a spotlight's inner cone; that is, the fully illuminated spotlight cone.
OuterConeAngle | Retrieves or sets the angle, in radians, that defines the outer edge of a spotlight's outer cone.
Position | Retrieves or sets the position of the light in world space, as specified by a Vector3 structure.
Range | Retrieves or sets the distance beyond which the light has no effect.
Specular Retrieves or sets the specular color emitted by the light.

This member is a Color Leave Site structure.
SpecularColor Retrieves or sets the specular color emitted by the light.

This member is a ColorValue structure.
Type | Retrieves or sets the type of the light source.
XDirection | Retrieves or sets an X-axis value that indicates the direction in which the light points.
XPosition | Retrieves or sets an X-coordinate value that indicates the position of the light.
YDirection | Retrieves or sets a Y-axis value that indicates the direction of the light.
YPosition | Retrieves or sets a Y-coordinate value that indicates the position of the light.
ZDirection | Retrieves or sets a Z-axis value that indicates the direction of the light.
ZPosition | Retrieves or sets a Z-coordinate value that indicates the position of the light.

Inheritance Hierarchy

Object Leave Site
Light

Remarks

Light properties are not updated on the device until either Light.Update is called to commit the changes or Light.Enabled is set to true.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • LightsCollection


Light.FromLight(Light)

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.FromLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new light based on an existing light.

Definition

Visual Basic .NET Public Sub FromLight( _
ByVal light As Light _
)
C# public void FromLight(
Light light
);
Managed C++ public: void FromLight(
Light *light
);
JScript .NET public function FromLight(
light : Light
);

Parameters

light Microsoft.DirectX.Direct3D.Light. Existing light that is used to create the new light.


Light.Light

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Light Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Light class.

Overload List

public Light();
public Light(_D3DLIGHT9);


Light.Light(_D3DLIGHT9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Light Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Light class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pLight As _D3DLIGHT9 _
)
C# public Light(
_D3DLIGHT9 pLight
);
Managed C++ public: Light(
_D3DLIGHT9 pLight
);
JScript .NET public function Light(
pLight : _D3DLIGHT9
);

Parameters

pLight Microsoft.DirectX.PrivateImplementationDetails._D3DLIGHT9. Unmanaged _D3DLIGHT9 structure pointer.


Light.Light()

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Light Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Light class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Light();
Managed C++ | public: Light();
JScript .NET | public function Light();


Light.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Light.Update()

Light.Update Method

Note: This documentation is preliminary and is subject to change.

Updates the settings for the current Light object.

Definition

Visual Basic .NET | Public Sub Update()
C# | public void Update();
Managed C++ | public: void Update();
JScript .NET | public function Update();

Remarks

Changes made to the Light object's properties do not take effect until this method is called, or Light.Enabled is set to true.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Light.Ambient

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Ambient Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ambient color emitted by the light.

This member is a Color Leave Site structure.

Definition

Visual Basic .NET | Public Property Ambient As Color
C# | public Color Ambient { get; set; }
Managed C++ public: __property Color get_Ambient();
public: __property void set_Ambient(Color);
JScript .NET public function get Ambient() : Color
public function set Ambient(Color);

Property Value

System.Drawing.Color . A Color Leave Site structure that represents the ambient color emitted by the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.AmbientColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.AmbientColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ambient color emitted by the light.

This member is a ColorValue structure.

Definition

Visual Basic .NET | Public Property AmbientColor As ColorValue
C# | public ColorValue AmbientColor { get; set; }
Managed C++ public: __property ColorValue get_AmbientColor();
public: __property void set_AmbientColor(ColorValue);
JScript .NET public function get AmbientColor() : ColorValue
public function set AmbientColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . ColorValue structure that represents the ambient color emitted by the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.Attenuation0

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Attenuation0 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies how light intensity changes over distance.

Definition

Visual Basic .NET | Public Property Attenuation0 As Single
C# | public float Attenuation0 { get; set; }
Managed C++ public: __property float get_Attenuation0();
public: __property void set_Attenuation0(float);
JScript .NET public function get Attenuation0() : float
public function set Attenuation0(float);

Property Value

System.Single . Value that specifies how light intensity changes over distance.

This property is read/write.

Remarks

Attenuation values are ignored for directional lights. This member represents an attenuation constant. Its valid values range from 0.0 to infinity. For non-directional lights, all three attenuation values should not be set to 0.0 simultaneously.

Exceptions
InvalidCallException The property value is invalid.


Light.Attenuation1

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Attenuation1 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies how light intensity changes over distance.

Definition

Visual Basic .NET | Public Property Attenuation1 As Single
C# | public float Attenuation1 { get; set; }
Managed C++ public: __property float get_Attenuation1();
public: __property void set_Attenuation1(float);
JScript .NET public function get Attenuation1() : float
public function set Attenuation1(float);

Property Value

System.Single . Value that specifies how light intensity changes over distance.

This property is read/write.

Remarks

Attenuation values are ignored for directional lights. This member represents an attenuation constant. Its valid values range from 0.0 to infinity. For non-directional lights, all three attenuation values should not be set to 0.0 simultaneously.

Exceptions
InvalidCallException The property value is invalid.


Light.Attenuation2

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Attenuation2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies how light intensity changes over distance.

Definition

Visual Basic .NET | Public Property Attenuation2 As Single
C# | public float Attenuation2 { get; set; }
Managed C++ public: __property float get_Attenuation2();
public: __property void set_Attenuation2(float);
JScript .NET public function get Attenuation2() : float
public function set Attenuation2(float);

Property Value

System.Single . Value that specifies how light intensity changes over distance.

This property is read/write.

Remarks

Attenuation values are ignored for directional lights. This member represents an attenuation constant. Its valid values range from 0.0 to infinity. For non-directional lights, all three attenuation values should not be set to 0.0 simultaneously.

Exceptions
InvalidCallException The property value is invalid.


Light.Diffuse

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Diffuse Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the diffuse color emitted by the light.

This member is a Color Leave Site structure.

Definition

Visual Basic .NET | Public Property Diffuse As Color
C# | public Color Diffuse { get; set; }
Managed C++ public: __property Color get_Diffuse();
public: __property void set_Diffuse(Color);
JScript .NET public function get Diffuse() : Color
public function set Diffuse(Color);

Property Value

System.Drawing.Color . A Color Leave Site structure that represents the diffuse color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.DiffuseColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.DiffuseColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the diffuse color emitted by the light.

This member is a ColorValue structure.

Definition

Visual Basic .NET | Public Property DiffuseColor As ColorValue
C# | public ColorValue DiffuseColor { get; set; }
Managed C++ public: __property ColorValue get_DiffuseColor();
public: __property void set_DiffuseColor(ColorValue);
JScript .NET public function get DiffuseColor() : ColorValue
public function set DiffuseColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure that represents the diffuse color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.Direction

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Direction Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the direction in which the light is pointing in world space, as specified by a Vector3 structure.

Definition

Visual Basic .NET | Public Property Direction As Vector3
C# | public Vector3 Direction { get; set; }
Managed C++ public: __property Vector3 get_Direction();
public: __property void set_Direction(Vector3);
JScript .NET public function get Direction() : Vector3
public function set Direction(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 structure that represents the direction in which the light is pointing.

This property is read/write.

Remarks

This member has meaning only for directional light and spotlights. The vector need not be normalized, but it should have a nonzero length.

Exceptions
InvalidCallException The property value is invalid.


Light.Enabled

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Enabled Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Boolean value that enables or disables a set of lighting parameters within a device.

Definition

Visual Basic .NET | Public Property Enabled As Boolean
C# | public bool Enabled { get; set; }
Managed C++ public: __property bool get_Enabled();
public: __property void set_Enabled(bool);
JScript .NET public function get Enabled() : boolean
public function set Enabled(boolean);

Property Value

System.Boolean . Value that enables or disables the lighting parameters.

This property is read/write.


Light.Falloff

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Falloff Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the decrease in illumination between a spotlight's inner cone (the angle specified by InnerConeAngle) and the outer edge of the outer cone (the angle specified by OuterConeAngle).

Definition

Visual Basic .NET | Public Property Falloff As Single
C# | public float Falloff { get; set; }
Managed C++ public: __property float get_Falloff();
public: __property void set_Falloff(float);
JScript .NET public function get Falloff() : float
public function set Falloff(float);

Property Value

System.Single . Value that indicates the decrease in illumination.

This property is read/write.

Remarks

The effect of falloff, the light attenuation between a spotlight's inner and outer cones, on the lighting is subtle. Furthermore, a small performance penalty is incurred by shaping the falloff curve. For these reasons, most developers set this value to 1.0.

Exceptions
InvalidCallException The property value is invalid.


Light.InnerConeAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.InnerConeAngle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the angle, in radians, of a spotlight's inner cone; that is, the fully illuminated spotlight cone.

Definition

Visual Basic .NET | Public Property InnerConeAngle As Single
C# | public float InnerConeAngle { get; set; }
Managed C++ public: __property float get_InnerConeAngle();
public: __property void set_InnerConeAngle(float);
JScript .NET public function get InnerConeAngle() : float
public function set InnerConeAngle(float);

Property Value

System.Single . Value that indicates the angle of the spotlight's inner cone.

This property is read/write.

Remarks

This value must be in the range of 0 through the value specified by OuterConeAngle.

Exceptions
InvalidCallException The property value is invalid.


Light.OuterConeAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.OuterConeAngle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the angle, in radians, that defines the outer edge of a spotlight's outer cone.

Definition

Visual Basic .NET | Public Property OuterConeAngle As Single
C# | public float OuterConeAngle { get; set; }
Managed C++ public: __property float get_OuterConeAngle();
public: __property void set_OuterConeAngle(float);
JScript .NET public function get OuterConeAngle() : float
public function set OuterConeAngle(float);

Property Value

System.Single . Value that indicates the angle of the outer edge of the spotlight's outer cone.

This property is read/write.

Remarks

Points outside of the cone are not lit by the spotlight.

This value must fall between 0 and pi.

Exceptions
InvalidCallException The property value is invalid.

See Also

  • InnerConeAngle


Light.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the light in world space, as specified by a Vector3 structure.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 structure that represents the position of the light in world space.

This property is read/write.

Remarks

This member has no effect on directional lights.

Exceptions
InvalidCallException The property value is invalid.


Light.Range

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Range Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the distance beyond which the light has no effect.

Definition

Visual Basic .NET | Public Property Range As Single
C# | public float Range { get; set; }
Managed C++ public: __property float get_Range();
public: __property void set_Range(float);
JScript .NET public function get Range() : float
public function set Range(float);

Property Value

System.Single . Value that indicates the distance beyond which the light has no effect.

This property is read/write.

Remarks

The maximum allowable value for this member is the square root of MaxValue Leave Site.

This member does not affect directional lights.

Exceptions
InvalidCallException The property value is invalid.


Light.Specular

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Specular Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the specular color emitted by the light.

This member is a Color Leave Site structure.

Definition

Visual Basic .NET | Public Property Specular As Color
C# | public Color Specular { get; set; }
Managed C++ public: __property Color get_Specular();
public: __property void set_Specular(Color);
JScript .NET public function get Specular() : Color
public function set Specular(Color);

Property Value

System.Drawing.Color . A Color Leave Site structure that represents the specular color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.SpecularColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.SpecularColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the specular color emitted by the light.

This member is a ColorValue structure.

Definition

Visual Basic .NET | Public Property SpecularColor As ColorValue
C# | public ColorValue SpecularColor { get; set; }
Managed C++ public: __property ColorValue get_SpecularColor();
public: __property void set_SpecularColor(ColorValue);
JScript .NET public function get SpecularColor() : ColorValue
public function set SpecularColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure that represents the specular color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the type of the light source.

Definition

Visual Basic .NET | Public Property Type As LightType
C# | public LightType Type { get; set; }
Managed C++ public: __property LightType get_Type();
public: __property void set_Type(LightType);
JScript .NET public function get Type() : LightType
public function set Type(LightType);

Property Value

Microsoft.DirectX.Direct3D.LightType . A value that represents the light source's type.

This property is read/write.

Remarks

This value is a member of the LightType enumerated type.

Exceptions
InvalidCallException The property value is invalid.


Light.XDirection

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.XDirection Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets an X-axis value that indicates the direction in which the light points.

Definition

Visual Basic .NET | Public Property XDirection As Single
C# | public float XDirection { get; set; }
Managed C++ public: __property float get_XDirection();
public: __property void set_XDirection(float);
JScript .NET public function get XDirection() : float
public function set XDirection(float);

Property Value

System.Single . Value that indicates the direction in which the light points.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.XPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.XPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets an X-coordinate value that indicates the position of the light.

Definition

Visual Basic .NET | Public Property XPosition As Single
C# | public float XPosition { get; set; }
Managed C++ public: __property float get_XPosition();
public: __property void set_XPosition(float);
JScript .NET public function get XPosition() : float
public function set XPosition(float);

Property Value

System.Single . Value that indicates the position of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.YDirection

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.YDirection Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Y-axis value that indicates the direction of the light.

Definition

Visual Basic .NET | Public Property YDirection As Single
C# | public float YDirection { get; set; }
Managed C++ public: __property float get_YDirection();
public: __property void set_YDirection(float);
JScript .NET public function get YDirection() : float
public function set YDirection(float);

Property Value

System.Single . Value that indicates the direction of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.YPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.YPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Y-coordinate value that indicates the position of the light.

Definition

Visual Basic .NET | Public Property YPosition As Single
C# | public float YPosition { get; set; }
Managed C++ public: __property float get_YPosition();
public: __property void set_YPosition(float);
JScript .NET public function get YPosition() : float
public function set YPosition(float);

Property Value

System.Single . Value that indicates the position of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.ZDirection

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.ZDirection Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Z-axis value that indicates the direction of the light.

Definition

Visual Basic .NET | Public Property ZDirection As Single
C# | public float ZDirection { get; set; }
Managed C++ public: __property float get_ZDirection();
public: __property void set_ZDirection(float);
JScript .NET public function get ZDirection() : float
public function set ZDirection(float);

Property Value

System.Single . Value that indicates the direction of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.ZPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Light.ZPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Z-coordinate value that indicates the position of the light.

Definition

Visual Basic .NET | Public Property ZPosition As Single
C# | public float ZPosition { get; set; }
Managed C++ public: __property float get_ZPosition();
public: __property void set_ZPosition(float);
JScript .NET public function get ZPosition() : float
public function set ZPosition(float);

Property Value

System.Single . Value that indicates the position of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Microsoft.DirectX.Direct3D.LightsCollection

LightsCollection Class

Note: This documentation is preliminary and is subject to change.

Defines a collection of lights.

Definition

Visual Basic .NET NotInheritable Public Class LightsCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class LightsCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class LightsCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class LightsCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can iterate through the LightsCollection.
MoveNext | Advances the enumerator to the next light.
Reset | Resets the current enumerator to point to the head of the queue.

Properties

Property | Description
Count | Retrieves the number of Light objects in the LightsCollection.
Current | Retrieves the current Light object in the LightsCollection.
Item | Retrieves a specific Light object within the LightsCollection.

Inheritance Hierarchy

Object Leave Site
LightsCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


LightsCollection.GetEnumerator()

LightsCollection.GetEnumerator Method

Note: This documentation is preliminary and is subject to change.

Returns an enumerator that can iterate through the LightsCollection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator . An enumerator that can iterate through the LightsCollection.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


LightsCollection.MoveNext()

LightsCollection.MoveNext Method

Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next light.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean . Set to true if the move to the next item was sucessful; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Reset()

LightsCollection.Reset Method

Note: This documentation is preliminary and is subject to change.

Resets the current enumerator to point to the head of the queue.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the queue.

After Reset Leave Site is called, the cursor is undefined. Call MoveNext Leave Site initially to point to the first item in the list.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Count

LightsCollection.Count Property

Note: This documentation is preliminary and is subject to change.

Retrieves the number of Light objects in the LightsCollection.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 . Number of Light objects in the LightsCollection.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Current

LightsCollection.Current Property

Note: This documentation is preliminary and is subject to change.

Retrieves the current Light object in the LightsCollection.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object . Current Light object in the LightsCollection.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Item

LightsCollection.Item Property

Note: This documentation is preliminary and is subject to change.

Retrieves a specific Light object within the LightsCollection.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal index As Integer _
) As Light
C# public Light this[
int index
] { get; }
Managed C++ public: __property Light* get_Item(
int index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.Direct3D.Light . The Light object at the given index.

This property is read-only.

Parameters

index System.Int32. Index value of the light to retrieve.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.Line

Microsoft DirectX 9.0 SDK Update (October 2004)

Line Class

Language:
Note: This documentation is preliminary and is subject to change.

Implements line drawing using textured triangles.

Definition

Visual Basic .NET NotInheritable Public Class Line
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class Line : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class Line : public MarshalByRefObject,
IDisposable
JScript .NET public class Line extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Line object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally just before a device is reset.
Reset | Occurs after the Line.OnResetDevice method is called or after the Line is reset.

Methods

Method | Description
Begin | Prepares a device to draw lines.
Dispose | Immediately releases the unmanaged resources used by the Line object.
Draw | Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.
DrawTransform | Draws a line strip in screen space with a specified input transformation matrix.
End | Restores the device to the state it was in when Line.Begin was called.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Line object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
Line | Uses a left-handed coordinate system to create a line.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Line.Disposing event when called from within a derived class.
raise_Lost | Raises a Line.Lost event when called from within a derived class.
raise_Reset | Raises a Line.Reset event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Line object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Antialias | Retrieves or sets the antialiasing switch value for a line.
Device | Retrieves the Direct3D device associated with a line object.
Disposed | Gets a value that indicates whether the object is disposed.
GlLines | Retrieves or sets a value that switches between Microsoft Direct3D® and OpenGL line-drawing modes.
Pattern | Retrieves or sets the line stipple pattern.
PatternScale | Retrieves or sets the stipple-pattern scale value.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXLine interface pointer.
Width | Retrieves or sets the thickness of a line.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Line

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Line.Begin()

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Begin Method

 Language:
Note: This documentation is preliminary and is subject to change.

Prepares a device to draw lines.

Definition

Visual Basic .NET | Public Sub Begin()
C# | public void Begin();
Managed C++ | public: void Begin();
JScript .NET | public function Begin();

Remarks

Calling Begin is optional. If called outside of a Begin ... Line.End sequence, the draw methods internally call Begin and End. If more than one draw method will be called successively, use this method to avoid extra overhead.

This method must be called from inside of a Device.BeginScene ... Device.EndScene sequence.

The Begin method cannot be used as a substitute for either Device.BeginScene or RenderToSurface.BeginScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Line object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Line.Disposed
  • Microsoft.DirectX.Direct3D.Line.Disposing


Line.Draw

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.

Overload List

public void Draw(Vector2[], Color);
public void Draw(Vector2[], int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • DrawTransform


Line.Draw(Vector2[],Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal vertexList() As Vector2, _
ByVal color As Color _
)
C# public void Draw(
Vector2[] vertexList,
Color color
);
Managed C++ public: void Draw(
Vector2 vertexList __gc[],
Color color
);
JScript .NET public function Draw(
vertexList : Vector2[],
color : Color
);

Parameters

vertexList | Microsoft.DirectX.Vector2[]. Array of vertices that make up the line. For more information, see Vector2.
color | System.Drawing.Color. A Color Leave Site object that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • DrawTransform


Line.Draw(Vector2[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal vertexList() As Vector2, _
ByVal color As Integer _
)
C# public void Draw(
Vector2[] vertexList,
int color
);
Managed C++ public: void Draw(
Vector2 vertexList __gc[],
int color
);
JScript .NET public function Draw(
vertexList : Vector2[],
color : int
);

Parameters

vertexList | Microsoft.DirectX.Vector2[]. Array of vertices that make up the line. For more information, see Vector2.
color | System.Int32. An Int32 Leave Site color value that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • DrawTransform


Line.DrawTransform

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.DrawTransform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws a line strip in screen space with a specified input transformation matrix.

Overload List

public void DrawTransform(Vector3[], Matrix, Color);
public void DrawTransform(Vector3[], Matrix, int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Draw


Line.DrawTransform(Vector3[],Matrix,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.DrawTransform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws a line strip in screen space with a specified input transformation matrix.

Definition

Visual Basic .NET Public Sub DrawTransform( _
ByVal vertexList() As Vector3, _
ByVal transform As Matrix, _
ByVal color As Color _
)
C# public void DrawTransform(
Vector3[] vertexList,
Matrix transform,
Color color
);
Managed C++ public: void DrawTransform(
Vector3 vertexList __gc[],
Matrix transform,
Color color
);
JScript .NET public function DrawTransform(
vertexList : Vector3[],
transform : Matrix,
color : Color
);

Parameters

vertexList | Microsoft.DirectX.Vector3[]. Array of vertices that make up the line. For more information, see Vector2.
transform | Microsoft.DirectX.Matrix. Scale, rotate, and translate (SRT) matrix for transforming the points. For more information, see Matrix. If this matrix is a projection matrix, any stippled lines are drawn with a perspective-correct stippling pattern. Or, vertices can be transformed and Line.Draw used to draw the line with a stipple pattern and no perspective correction.
color | System.Drawing.Color. A Color Leave Site object that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Draw


Line.DrawTransform(Vector3[],Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.DrawTransform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Draws a line strip in screen space with a specified input transformation matrix.

Definition

Visual Basic .NET Public Sub DrawTransform( _
ByVal vertexList() As Vector3, _
ByVal transform As Matrix, _
ByVal color As Integer _
)
C# public void DrawTransform(
Vector3[] vertexList,
Matrix transform,
int color
);
Managed C++ public: void DrawTransform(
Vector3 vertexList __gc[],
Matrix transform,
int color
);
JScript .NET public function DrawTransform(
vertexList : Vector3[],
transform : Matrix,
color : int
);

Parameters

vertexList | Microsoft.DirectX.Vector3[]. Array of vertices that make up the line. For more information, see Vector2.
transform | Microsoft.DirectX.Matrix. Scale, rotate, and translate (SRT) matrix for transforming the points. For more information, see Matrix. If this matrix is a projection matrix, any stippled lines are drawn with a perspective-correct stippling pattern. Or, vertices can be transformed and Line.Draw used to draw the line with a stipple pattern and no perspective correction.
color | System.Int32. An Int32 Leave Site color value that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Draw


Line.End()

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.End Method

 Language:
Note: This documentation is preliminary and is subject to change.

Restores the device to the state it was in when Line.Begin was called.

Definition

Visual Basic .NET | Public Sub End()
C# | public void End();
Managed C++ | public: void End();
JScript .NET | public function End();

Remarks

The End method cannot be used as a substitute for either Device.EndScene or RenderToSurface.EndScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Line.Begin


Line.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Line.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Line object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Line();
Managed C++ | ~Line();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Line.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Line.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXLine, which allows unmanaged COM clients to create an instance of the managed Line class. Not supported.


Line.Line

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Line Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a line.

Overload List

public Line(Device);
public Line(ID3DXLine);
public Line(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Line.Line(ID3DXLine)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Line Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a line.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXLine _
)
C# public Line(
ID3DXLine pUnk
);
Managed C++ public: Line(
ID3DXLine pUnk
);
JScript .NET public function Line(
pUnk : ID3DXLine
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXLine. Unmanaged Component Object Model (COM) ID3DXLine interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Line.Line(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Line Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a line.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Line(
IntPtr unmanagedObject
);
Managed C++ public: Line(
IntPtr unmanagedObject
);
JScript .NET public function Line(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXLine interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Line.Line(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Line Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a line.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device _
)
C# public Line(
Device device
);
Managed C++ public: Line(
Device *device
);
JScript .NET public function Line(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Line.OnLostDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.OnLostDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic .NET | Public Sub OnLostDevice()
C# | public void OnLostDevice();
Managed C++ | public: void OnLostDevice();
JScript .NET | public function OnLostDevice();


Line.OnResetDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.OnResetDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic .NET | Public Sub OnResetDevice()
C# | public void OnResetDevice();
Managed C++ | public: void OnResetDevice();
JScript .NET | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Line.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Line.OnResetDevice should be called immediately after the device is reset.


Line.op_Equality(Line,Line)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Line, _
ByVal right As Line _
) As Boolean
C# public static bool op_Equality(
Line left,
Line right
);
Managed C++ public: static bool op_Equality(
Line *left,
Line *right
);
JScript .NET public static function op_Equality(
left : Line,
right : Line
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Line. The Line object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Line. The Line object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Line.op_Inequality(Line,Line)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Line, _
ByVal right As Line _
) As Boolean
C# public static bool op_Inequality(
Line left,
Line right
);
Managed C++ public: static bool op_Inequality(
Line *left,
Line *right
);
JScript .NET public static function op_Inequality(
left : Line,
right : Line
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Line. The Line object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Line. The Line object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Line.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Line.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Line.raise_Lost(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.raise_Lost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Line.Lost event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Lost(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Line.raise_Reset(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.raise_Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Line.Reset event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Reset(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Line.UpdateUnmanagedPointer(ID3DXLine)

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Line object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXLine _
)
C# public void UpdateUnmanagedPointer(
ID3DXLine pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXLine pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXLine
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXLine. Pointer to the ID3DXLine structure used to update the unmanaged pointer for this Line object.


Line.Antialias

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Antialias Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the antialiasing switch value for a line.

Definition

Visual Basic .NET | Public Property Antialias As Boolean
C# | public bool Antialias { get; set; }
Managed C++ public: __property bool get_Antialias();
public: __property void set_Antialias(bool);
JScript .NET public function get Antialias() : boolean
public function set Antialias(boolean);

Property Value

System.Boolean . Value that indicates antialiasing state. If true, antialiasing is on; if false, it is off.

This property is read/write.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Microsoft® Direct3D® device associated with a line object.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device that is associated with the line.

This property is read-only.

Remarks

The End method cannot be used as a substitute for either Device.EndScene or RenderToSurface.EndScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Line.GlLines

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.GlLines Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that switches between Microsoft® Direct3D® and OpenGL line-drawing modes.

Definition

Visual Basic .NET | Public Property GlLines As Boolean
C# | public bool GlLines { get; set; }
Managed C++ public: __property bool get_GlLines();
public: __property void set_GlLines(bool);
JScript .NET public function get GlLines() : boolean
public function set GlLines(boolean);

Property Value

System.Boolean . Value that is true if lines based on OpenGL are enabled; false if lines based on Microsoft® Direct3D® are enabled.

This property is read/write.

Remarks

As a software interface for graphics hardware, OpenGL renders multidimensional objects into a frame buffer.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Pattern

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Pattern Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the line stipple pattern.

Definition

Visual Basic .NET | Public Property Pattern As Integer
C# | public int Pattern { get; set; }
Managed C++ public: __property int get_Pattern();
public: __property void set_Pattern(int);
JScript .NET public function get Pattern() : int
public function set Pattern(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the line stipple pattern: either 1 (opaque) or 0 (transparent).

This property is read/write.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.PatternScale

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.PatternScale Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the stipple-pattern scale value.

Definition

Visual Basic .NET | Public Property PatternScale As Single
C# | public float PatternScale { get; set; }
Managed C++ public: __property float get_PatternScale();
public: __property void set_PatternScale(float);
JScript .NET public function get PatternScale() : float
public function set PatternScale(float);

Property Value

System.Single . Value that scales the stipple pattern; 1.0f is the default and represents no scaling. A value less than 1.0f shrinks the pattern, and a value greater than 1.0 stretches it.

This property is read/write.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXLine interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXLine
C# | public ID3DXLine UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXLine get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXLine

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXLine . Unmanaged ID3DXLine interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Line.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the thickness of a line.

Definition

Visual Basic .NET | Public Property Width As Single
C# | public float Width { get; set; }
Managed C++ public: __property float get_Width();
public: __property void set_Width(float);
JScript .NET public function get Width() : float
public function set Width(float);

Property Value

System.Single . Line thickness.

This property is read/write.


Line.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Line object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Line.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Line object indicates whether that object has been disposed.


Line.Lost

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Lost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when an object is lost, normally just before a device is reset.

Definition

Visual Basic .NET | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
Managed C++ | public: __event EventHandler Lost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Line.Lost event, use the following C# code.

[C#]
line.Lost += new System.EventHandler(this.LostEventHandler);


Line.Reset

Microsoft DirectX 9.0 SDK Update (October 2004)

Line.Reset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after the Line.OnResetDevice method is called or after the Line is reset.

Definition

Visual Basic .NET | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
Managed C++ | public: __event EventHandler Reset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Line.Reset event, use the following C# code.

[C#]
line.Reset += new System.EventHandler(this.ResetEventHandler);


Microsoft.DirectX.Direct3D.LoadedMeshHasNoDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadedMeshHasNoDataException Class

Language:
Note: This documentation is preliminary and is subject to change.

The mesh has no data.

Definition

Visual Basic .NET Public Class LoadedMeshHasNoDataException
Inherits Direct3DXException
C# | public class LoadedMeshHasNoDataException : Direct3DXException
Managed C++ | public __gc class LoadedMeshHasNoDataException : public Direct3DXException
JScript .NET | public class LoadedMeshHasNoDataException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
LoadedMeshHasNoDataException | Initializes a new instance of the LoadedMeshHasNoDataException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
LoadedMeshHasNoDataException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LoadedMeshHasNoDataException class.

Overload List

public LoadedMeshHasNoDataException();
protected LoadedMeshHasNoDataException(SerializationInfo, StreamingContext);
public LoadedMeshHasNoDataException(string);
public LoadedMeshHasNoDataException(string, Exception);


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected LoadedMeshHasNoDataException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: LoadedMeshHasNoDataException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function LoadedMeshHasNoDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public LoadedMeshHasNoDataException(
string message,
Exception inner
);
Managed C++ public: LoadedMeshHasNoDataException(
String *message,
Exception *inner
);
JScript .NET public function LoadedMeshHasNoDataException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public LoadedMeshHasNoDataException(
string message
);
Managed C++ public: LoadedMeshHasNoDataException(
String *message
);
JScript .NET public function LoadedMeshHasNoDataException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException()

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public LoadedMeshHasNoDataException();
Managed C++ | public: LoadedMeshHasNoDataException();
JScript .NET | public function LoadedMeshHasNoDataException();


Microsoft.DirectX.Direct3D.LoadUserData

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadUserData Class

Language:
Note: This documentation is preliminary and is subject to change.

Derived by the application to allocate or free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.

Definition

Visual Basic .NET MustInherit Public Class LoadUserData
Inherits Object
C# | public abstract class LoadUserData : Object
Managed C++ | public __gc __abstract class LoadUserData : public Object
JScript .NET | public abstract class LoadUserData extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Finalize | Allows the LoadUserData object to free resources before it is destroyed by the garbage collector.
LoadFrameChildData | Loads frame child data from a Microsoft® DirectX® (.x) file.
LoadMeshChildData | Loads mesh child data from a DirectX (.x) file.
LoadTopLevelData | Loads top-level data from a DirectX (.x) file.
LoadUserData | Initializes a new instance of the LoadUserData class.

Inheritance Hierarchy

Object Leave Site
LoadUserData

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LoadUserData.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadUserData.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the LoadUserData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~LoadUserData();
Managed C++ | ~LoadUserData();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


LoadUserData.LoadFrameChildData(Frame,XFileData)

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadUserData.LoadFrameChildData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads frame child data from a Microsoft® DirectX® (.x) file.

Definition

Visual Basic .NET MustOverride Public Sub LoadFrameChildData( _
ByVal frame As Frame, _
ByVal xofChildData As XFileData _
)
C# public abstract void LoadFrameChildData(
Frame frame,
XFileData xofChildData
);
Managed C++ public: virtual void LoadFrameChildData(
Frame *frame,
XFileData *xofChildData
) = 0;
JScript .NET public abstract function LoadFrameChildData(
frame : Frame,
xofChildData : XFileData
);

Parameters

frame | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the frame hierarchy.
xofChildData | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the .x file data to load.


LoadUserData.LoadMeshChildData(MeshContainer,XFileData)

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadUserData.LoadMeshChildData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads mesh child data from a Microsoft® DirectX® (.x) file.

Definition

Visual Basic .NET MustOverride Public Sub LoadMeshChildData( _
ByVal meshContainer As MeshContainer, _
ByVal xofChildData As XFileData _
)
C# public abstract void LoadMeshChildData(
MeshContainer meshContainer,
XFileData xofChildData
);
Managed C++ public: virtual void LoadMeshChildData(
MeshContainer *meshContainer,
XFileData *xofChildData
) = 0;
JScript .NET public abstract function LoadMeshChildData(
meshContainer : MeshContainer,
xofChildData : XFileData
);

Parameters

meshContainer | Microsoft.DirectX.Direct3D.MeshContainer. A MeshContainer object that represents the mesh container.
xofChildData | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the .x file data.


LoadUserData.LoadTopLevelData(XFileData)

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadUserData.LoadTopLevelData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads top-level data from a Microsoft® DirectX® (.x) file.

Definition

Visual Basic .NET MustOverride Public Sub LoadTopLevelData( _
ByVal xofChildData As XFileData _
)
C# public abstract void LoadTopLevelData(
XFileData xofChildData
);
Managed C++ public: virtual void LoadTopLevelData(
XFileData *xofChildData
) = 0;
JScript .NET public abstract function LoadTopLevelData(
xofChildData : XFileData
);

Parameters

xofChildData Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the .x file data.


LoadUserData.LoadUserData()

Microsoft DirectX 9.0 SDK Update (October 2004)

LoadUserData.LoadUserData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LoadUserData class.

Definition

Visual Basic .NET | Public Sub New()
C# | public LoadUserData();
Managed C++ | public: LoadUserData();
JScript .NET | public function LoadUserData();


Microsoft.DirectX.Direct3D.Manager

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager Class

Language:
Note: This documentation is preliminary and is subject to change.

Provides information about the environment, and enumerates and retrieves device capabilities.

Definition

Visual Basic .NET NotInheritable Public Class Manager
Inherits MarshalByRefObject
C# | public sealed class Manager : MarshalByRefObject
Managed C++ | public __gc __sealed class Manager : public MarshalByRefObject
JScript .NET | public class Manager extends MarshalByRefObject

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) CheckDepthStencilMatch | Determines whether a depth stencil format is compatible with a render target format in a particular display mode.
static (Shared in Visual Basic .NET) CheckDeviceFormat | Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.
static (Shared in Visual Basic .NET) CheckDeviceFormatConversion | Tests a device to determine whether it supports conversion from one display format to another.
static (Shared in Visual Basic .NET) CheckDeviceMultiSampleType | Determines whether a multisampling technique is available on the current device.
static (Shared in Visual Basic .NET) CheckDeviceType | Specifies whether a hardware-accelerated device type can be used on the current adapter.
static (Shared in Visual Basic .NET) DisableD3DSpy | Blocks D3DSpy from monitoring an application.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Manager object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) GenerateD3DSpyBreak | Generates a breakpoint in D3DSpy when called within the application.
static (Shared in Visual Basic .NET) GetAdapterMonitor | Returns the handle of the monitor associated with the Microsoft® Direct3D® object.
static (Shared in Visual Basic .NET) GetDeviceCaps | Retrieves information specific to a device.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.

Properties

Property | Description
static (Shared in Visual Basic .NET) Adapters | Collection of adapters on the system.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Manager

Remarks

In managed code, the Manager class replaces most of the functionality of the C++ IDirect3D9 interface, except that it does not create a device. For device creation and manipulation options, see Device. Also note that the Manager class cannot be inherited or directly instantiated.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Manager.CheckDepthStencilMatch

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDepthStencilMatch Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a depth stencil format is compatible with a render target format in a particular display mode.

Overload List

public static bool CheckDepthStencilMatch(int, DeviceType, Format, Format, DepthFormat);
public static bool CheckDepthStencilMatch(int, DeviceType, Format, Format, DepthFormat, out int);

Remarks

The CheckDepthStencilMatch method enables applications to work with hardware that requires that certain depth formats work only with certain render-target formats.

The following C# code fragment demonstrates the use of CheckDeviceFormat to validate a depth stencil format.

              [C#]

public void TestFunc()
{
    int result;

    // Test some formats
    IsDepthFormatOK(DepthFormat.D16, Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result == (int)ResultCode.NotAvailable)
        System.Windows.Forms.MessageBox.Show(String.Format("The depth stencil format is invalid:  {0}", result));
}

private bool IsDepthFormatOK (DepthFormat depthFmt, Format adapterFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the depth format exists
    if (Manager.CheckDeviceFormat(ai.Adapter, DeviceType.Hardware, adapterFmt, Usage.DepthStencil, ResourceType.Surface, depthFmt, out result))
    {
        // Verify that the depth format is compatible
        if (Manager.CheckDepthStencilMatch(ai.Adapter, DeviceType.Hardware, adapterFmt, backbufferFmt, depthFmt, out result))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding call returns false if depthFmt cannot be used in conjunction with adapterFmt and backbufferFmt.


Manager.CheckDepthStencilMatch(Int32,DeviceType,Format,Format,DepthFormat,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDepthStencilMatch Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a depth stencil format is compatible with a render target format in a particular display mode.

Definition

Visual Basic .NET Public Shared Function CheckDepthStencilMatch( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal renderTargetFormat As Format, _
ByVal depthStencilFormat As DepthFormat, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat,
out int result
);
Managed C++ public: static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat,
int *result
);
JScript .NET public static function CheckDepthStencilMatch(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
renderTargetFormat : Format,
depthStencilFormat : DepthFormat,
result : int
) : boolean;

Parameters

adapter | System.Int32. Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that identifies the device type.
adapterFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
renderTargetFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the render-target surface to be tested.
depthStencilFormat | Microsoft.DirectX.Direct3D.DepthFormat. Member of the DepthFormat enumeration that identifies the format of the depth stencil surface to be tested.
result | System.Int32. HRESULT code passed back from the method.

Return Value

System.Boolean . Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned. If a depth stencil format is not compatible with the render target in the display mode, result is set to ResultCode.NotAvailable.

Remarks

The CheckDepthStencilMatch method enables applications to work with hardware that requires that certain depth formats work only with certain render-target formats.

The following C# code fragment demonstrates the use of CheckDeviceFormat to validate a depth stencil format.

              [C#]

public void TestFunc()
{
    int result;

    // Test some formats
    IsDepthFormatOK(DepthFormat.D16, Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result == (int)ResultCode.NotAvailable)
        System.Windows.Forms.MessageBox.Show(String.Format("The depth stencil format is invalid:  {0}", result));
}

private bool IsDepthFormatOK (DepthFormat depthFmt, Format adapterFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the depth format exists
    if (Manager.CheckDeviceFormat(ai.Adapter, DeviceType.Hardware, adapterFmt, Usage.DepthStencil, ResourceType.Surface, depthFmt, out result))
    {
        // Verify that the depth format is compatible
        if (Manager.CheckDepthStencilMatch(ai.Adapter, DeviceType.Hardware, adapterFmt, backbufferFmt, depthFmt, out result))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding call returns false if depthFmt cannot be used in conjunction with adapterFmt and backbufferFmt.


Manager.CheckDepthStencilMatch(Int32,DeviceType,Format,Format,DepthFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDepthStencilMatch Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a depth stencil format is compatible with a render target format in a particular display mode.

Definition

Visual Basic .NET Public Shared Function CheckDepthStencilMatch( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal renderTargetFormat As Format, _
ByVal depthStencilFormat As DepthFormat _
) As Boolean
C# public static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat
);
Managed C++ public: static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat
);
JScript .NET public static function CheckDepthStencilMatch(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
renderTargetFormat : Format,
depthStencilFormat : DepthFormat
) : boolean;

Parameters

adapter | System.Int32. Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that identifies the device type.
adapterFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
renderTargetFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the render-target surface to be tested.
depthStencilFormat | Microsoft.DirectX.Direct3D.DepthFormat. Member of the DepthFormat enumeration that identifies the format of the depth stencil surface to be tested.

Return Value

System.Boolean . Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned. If a depth stencil format is not compatible with the render target in the display mode, result is set to ResultCode.NotAvailable.

Remarks

The CheckDepthStencilMatch method enables applications to work with hardware that requires that certain depth formats work only with certain render-target formats.

The following C# code fragment demonstrates the use of CheckDeviceFormat to validate a depth stencil format.

              [C#]

public void TestFunc()
{
    int result;

    // Test some formats
    IsDepthFormatOK(DepthFormat.D16, Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result == (int)ResultCode.NotAvailable)
        System.Windows.Forms.MessageBox.Show(String.Format("The depth stencil format is invalid:  {0}", result));
}

private bool IsDepthFormatOK (DepthFormat depthFmt, Format adapterFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the depth format exists
    if (Manager.CheckDeviceFormat(ai.Adapter, DeviceType.Hardware, adapterFmt, Usage.DepthStencil, ResourceType.Surface, depthFmt, out result))
    {
        // Verify that the depth format is compatible
        if (Manager.CheckDepthStencilMatch(ai.Adapter, DeviceType.Hardware, adapterFmt, backbufferFmt, depthFmt, out result))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding call returns false if depthFmt cannot be used in conjunction with adapterFmt and backbufferFmt.


Manager.CheckDeviceFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Overload List

public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, DepthFormat);
public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, DepthFormat, out int);
public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, Format);
public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, Format, out int);

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,DepthFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic .NET Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As DepthFormat _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat
);
Managed C++ public: static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat
);
JScript .NET public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : DepthFormat
) : boolean;

Parameters

adapter | System.Int32. Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that identifies the device type.
adapterFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage | Microsoft.DirectX.Direct3D.Usage. Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType | Microsoft.DirectX.Direct3D.ResourceType. A ResourceType requested for use with the queried format.
checkFormat | Microsoft.DirectX.Direct3D.DepthFormat. Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.

Return Value

System.Boolean . Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,DepthFormat,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic .NET Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As DepthFormat, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat,
out int result
);
Managed C++ public: static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat,
int *result
);
JScript .NET public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : DepthFormat,
result : int
) : boolean;

Parameters

adapter | System.Int32. Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that identifies the device type.
adapterFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage | Microsoft.DirectX.Direct3D.Usage. Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType | Microsoft.DirectX.Direct3D.ResourceType. A ResourceType requested for use with the queried format.
checkFormat | Microsoft.DirectX.Direct3D.DepthFormat. Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.
result | System.Int32. HRESULT code passed back from the method.

Return Value

System.Boolean . Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,Format)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic .NET Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As Format _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat
);
Managed C++ public: static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat
);
JScript .NET public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : Format
) : boolean;

Parameters

adapter | System.Int32. Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that identifies the device type.
adapterFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage | Microsoft.DirectX.Direct3D.Usage. Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType | Microsoft.DirectX.Direct3D.ResourceType. A ResourceType requested for use with the queried format.
checkFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.

Return Value

System.Boolean . Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,Format,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic .NET Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As Format, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat,
out int result
);
Managed C++ public: static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat,
int *result
);
JScript .NET public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : Format,
result : int
) : boolean;

Parameters

adapter | System.Int32. Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that identifies the device type.
adapterFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage | Microsoft.DirectX.Direct3D.Usage. Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType | Microsoft.DirectX.Direct3D.ResourceType. A ResourceType requested for use with the queried format.
checkFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.
result | System.Int32. HRESULT code passed back from the method.

Return Value

System.Boolean . Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormatConversion

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormatConversion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tests a device to determine whether it supports conversion from one display format to another.

Overload List

public static bool CheckDeviceFormatConversion(int, DeviceType, Format, Format);
public static bool CheckDeviceFormatConversion(int, DeviceType, Format, Format, out int);

Remarks

Using Manager.CheckDeviceType to test for compatibility between a back buffer and the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back buffer format, the call still returns ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, the return value is also ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.

Manager.CheckDeviceFormatConversion also can be used to determine which combinations of source surface formats and destination surface formats are permissible in calls to Device.StretchRectangle.

Color conversion is restricted to the following source and target formats.

  • Source format must be a four-character code (FOURCC) format or a valid back buffer format. For a list of these, see FOURCC Formats and BackBuffer or Display Formats.
  • Target format must be one of the following unsigned formats. For more information, see Unsigned Formats.

    X1R5G5B5 | A1R5G5B5 | R5G6B5
    R8G8B8 | X8R8G8B8 | A8R8G8B8
    A2R10G10B10 | A16B16G16R16 | A2B10G10R10
    A8B8G8R8 | X8B8G8R8 | A16B16G16R16F
    A32B32G32R32F

See Also

  • Format
  • Surface Formats
  • Device.ColorFill


Manager.CheckDeviceFormatConversion(Int32,DeviceType,Format,Format,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormatConversion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tests a device to determine whether it supports conversion from one display format to another.

Definition

Visual Basic .NET Public Shared Function CheckDeviceFormatConversion( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal sourceFormat As Format, _
ByVal targetFormat As Format, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat,
out int result
);
Managed C++ public: static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat,
int *result
);
JScript .NET public static function CheckDeviceFormatConversion(
adapter : int,
deviceType : DeviceType,
sourceFormat : Format,
targetFormat : Format,
result : int
) : boolean;

Parameters

adapter | System.Int32. Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Device type. Member of the DeviceType enumeration.
sourceFormat | Microsoft.DirectX.Direct3D.Format. Source adapter format. Member of the Format enumeration.
targetFormat | Microsoft.DirectX.Direct3D.Format. Target adapter format. Member of the Format enumeration.
result | System.Int32. HRESULT code passed back from the method.

Return Value

System.Boolean . Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall.

If the hardware does not support conversion between the two formats, result is set to ResultCode.NotAvailable.

Remarks

Using Manager.CheckDeviceType to test for compatibility between a back buffer and the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back buffer format, the call still returns ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, the return value is also ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.

Manager.CheckDeviceFormatConversion also can be used to determine which combinations of source surface formats and destination surface formats are permissible in calls to Device.StretchRectangle.

Color conversion is restricted to the following source and target formats.

  • Source format must be a four-character code (FOURCC) format or a valid back buffer format. For a list of these, see FOURCC Formats and BackBuffer or Display Formats.
  • Target format must be one of the following unsigned formats. For more information, see Unsigned Formats.

    X1R5G5B5 | A1R5G5B5 | R5G6B5
    R8G8B8 | X8R8G8B8 | A8R8G8B8
    A2R10G10B10 | A16B16G16R16 | A2B10G10R10
    A8B8G8R8 | X8B8G8R8 | A16B16G16R16F
    A32B32G32R32F

See Also

  • Format
  • Surface Formats
  • Device.ColorFill


Manager.CheckDeviceFormatConversion(Int32,DeviceType,Format,Format)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceFormatConversion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tests a device to determine whether it supports conversion from one display format to another.

Definition

Visual Basic .NET Public Shared Function CheckDeviceFormatConversion( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal sourceFormat As Format, _
ByVal targetFormat As Format _
) As Boolean
C# public static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat
);
Managed C++ public: static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat
);
JScript .NET public static function CheckDeviceFormatConversion(
adapter : int,
deviceType : DeviceType,
sourceFormat : Format,
targetFormat : Format
) : boolean;

Parameters

adapter | System.Int32. Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Device type. Member of the DeviceType enumeration.
sourceFormat | Microsoft.DirectX.Direct3D.Format. Source adapter format. Member of the Format enumeration.
targetFormat | Microsoft.DirectX.Direct3D.Format. Target adapter format. Member of the Format enumeration.

Return Value

System.Boolean . Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall.

If the hardware does not support conversion between the two formats, result is set to ResultCode.NotAvailable.

Remarks

Using Manager.CheckDeviceType to test for compatibility between a back buffer and the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back buffer format, the call still returns ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, the return value is also ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.

Manager.CheckDeviceFormatConversion also can be used to determine which combinations of source surface formats and destination surface formats are permissible in calls to Device.StretchRectangle.

Color conversion is restricted to the following source and target formats.

  • Source format must be a four-character code (FOURCC) format or a valid back buffer format. For a list of these, see FOURCC Formats and BackBuffer or Display Formats.
  • Target format must be one of the following unsigned formats. For more information, see Unsigned Formats.

    X1R5G5B5 | A1R5G5B5 | R5G6B5
    R8G8B8 | X8R8G8B8 | A8R8G8B8
    A2R10G10B10 | A16B16G16R16 | A2B10G10R10
    A8B8G8R8 | X8B8G8R8 | A16B16G16R16F
    A32B32G32R32F

See Also

  • Format
  • Surface Formats
  • Device.ColorFill


Manager.CheckDeviceMultiSampleType

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceMultiSampleType Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a multisampling technique is available on the current device.

Overload List

public static bool CheckDeviceMultiSampleType(int, DeviceType, Format, bool, MultiSampleType);
public static bool CheckDeviceMultiSampleType(int, DeviceType, Format, bool, MultiSampleType, out int, out int);

Remarks

This method is intended for use with both render-target and depth stencil surfaces because they must be created multisampled to be used together.

The following C# code fragment demonstrates the use of CheckDeviceMultiSampleType to test for devices that support a specific multisampling method.

              [C#]

public void Test_Manager_CheckDeviceMultiSampleType()
{
    int result;

    // Test some formats
    IsDeviceMultiSampleOK(DepthFormat.D16, Format.A8R8G8B8, MultiSampleType.TwoSamples, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The multisample options are invalid:  {0}", result));
}

public bool IsDeviceMultiSampleOK (DepthFormat depthFmt, Format backbufferFmt, MultiSampleType multisampleType, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;
    int qualityLevels = 0;

    // Verify that the render target surface supports the given multisample type
    if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, backbufferFmt, false, multisampleType, out result, ref qualityLevels))
    {
        // Verify that the depth stencil surface supports the given multisample type
        if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, (Format)depthFmt, false, multisampleType, out result, ref qualityLevels))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device supports the full-screen MultiSampleType.TwoSamples multisampling method with the surface format.


Manager.CheckDeviceMultiSampleType(Int32,DeviceType,Format,Boolean,MultiSampleType,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceMultiSampleType Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a multisampling technique is available on the current device.

Definition

Visual Basic .NET Public Shared Function CheckDeviceMultiSampleType( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal surfaceFormat As Format, _
ByVal windowed As Boolean, _
ByVal multiSampleType As MultiSampleType, _
ByRef result As Integer, _
ByRef qualityLevels As Integer _
) As Boolean
C# public static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType,
out int result,
out int qualityLevels
);
Managed C++ public: static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType,
int *result,
int *qualityLevels
);
JScript .NET public static function CheckDeviceMultiSampleType(
adapter : int,
deviceType : DeviceType,
surfaceFormat : Format,
windowed : boolean,
multiSampleType : MultiSampleType,
result : int,
qualityLevels : int
) : boolean;

Parameters

adapter | System.Int32. Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration.
surfaceFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that specifies the format of the surface to be multisampled. See Remarks.
windowed | System.Boolean. Set to true to inquire about windowed multisampling. Set to false to inquire about full-screen multisampling.
multiSampleType | Microsoft.DirectX.Direct3D.MultiSampleType. Member of the MultiSampleType enumeration that identifies the multisampling technique to test.
result | System.Int32. HRESULT code passed back from the method.
qualityLevels | System.Int32. Number of quality stops available for a given multisample type; can be null if it is not necessary to return the values.

Return Value

System.Boolean . Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to one of the following values: ResultCode.InvalidCall if the adapter or multiSampleType parameters are invalid, ResultCode.NotAvailable if the device does not support the queried multisampling technique, or ResultCode.InvalidDevice if deviceType does not apply to the adapter.

Remarks

This method is intended for use with both render-target and depth stencil surfaces because they must be created multisampled to be used together.

The following C# code fragment demonstrates the use of CheckDeviceMultiSampleType to test for devices that support a specific multisampling method.

              [C#]

public void Test_Manager_CheckDeviceMultiSampleType()
{
    int result;

    // Test some formats
    IsDeviceMultiSampleOK(DepthFormat.D16, Format.A8R8G8B8, MultiSampleType.TwoSamples, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The multisample options are invalid:  {0}", result));
}

public bool IsDeviceMultiSampleOK (DepthFormat depthFmt, Format backbufferFmt, MultiSampleType multisampleType, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;
    int qualityLevels = 0;

    // Verify that the render target surface supports the given multisample type
    if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, backbufferFmt, false, multisampleType, out result, ref qualityLevels))
    {
        // Verify that the depth stencil surface supports the given multisample type
        if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, (Format)depthFmt, false, multisampleType, out result, ref qualityLevels))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device supports the full-screen MultiSampleType.TwoSamples multisampling method with the surface format.


Manager.CheckDeviceMultiSampleType(Int32,DeviceType,Format,Boolean,MultiSampleType)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceMultiSampleType Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a multisampling technique is available on the current device.

Definition

Visual Basic .NET Public Shared Function CheckDeviceMultiSampleType( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal surfaceFormat As Format, _
ByVal windowed As Boolean, _
ByVal multiSampleType As MultiSampleType _
) As Boolean
C# public static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType
);
Managed C++ public: static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType
);
JScript .NET public static function CheckDeviceMultiSampleType(
adapter : int,
deviceType : DeviceType,
surfaceFormat : Format,
windowed : boolean,
multiSampleType : MultiSampleType
) : boolean;

Parameters

adapter | System.Int32. Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration.
surfaceFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that specifies the format of the surface to be multisampled. See Remarks.
windowed | System.Boolean. Set to true to inquire about windowed multisampling. Set to false to inquire about full-screen multisampling.
multiSampleType | Microsoft.DirectX.Direct3D.MultiSampleType. Member of the MultiSampleType enumeration that identifies the multisampling technique to test.

Return Value

System.Boolean . Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to one of the following values: ResultCode.InvalidCall if the adapter or multiSampleType parameters are invalid, ResultCode.NotAvailable if the device does not support the queried multisampling technique, or ResultCode.InvalidDevice if deviceType does not apply to the adapter.

Remarks

This method is intended for use with both render-target and depth stencil surfaces because they must be created multisampled to be used together.

The following C# code fragment demonstrates the use of CheckDeviceMultiSampleType to test for devices that support a specific multisampling method.

              [C#]

public void Test_Manager_CheckDeviceMultiSampleType()
{
    int result;

    // Test some formats
    IsDeviceMultiSampleOK(DepthFormat.D16, Format.A8R8G8B8, MultiSampleType.TwoSamples, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The multisample options are invalid:  {0}", result));
}

public bool IsDeviceMultiSampleOK (DepthFormat depthFmt, Format backbufferFmt, MultiSampleType multisampleType, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;
    int qualityLevels = 0;

    // Verify that the render target surface supports the given multisample type
    if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, backbufferFmt, false, multisampleType, out result, ref qualityLevels))
    {
        // Verify that the depth stencil surface supports the given multisample type
        if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, (Format)depthFmt, false, multisampleType, out result, ref qualityLevels))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device supports the full-screen MultiSampleType.TwoSamples multisampling method with the surface format.


Manager.CheckDeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceType Method

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a hardware-accelerated device type can be used on the current adapter.

Overload List

public static bool CheckDeviceType(int, DeviceType, Format, Format, bool);
public static bool CheckDeviceType(int, DeviceType, Format, Format, bool, out int);

Remarks

A hardware abstraction layer (HAL) device type requires hardware acceleration. Applications can use Manager.CheckDeviceType to determine whether the hardware and drivers necessary to support a HAL device are present.

Full-screen applications should not specify a displayFormat that contains an alpha channel; doing so will result in a failed call. Note that an alpha channel can be present in the back buffer, but the two display formats must be identical in all other respects. For example, if displayFormat = Format.X1R5G5B5, valid values for backBufferFormat include Format.X1R5G5B5 and Format.A1R5G5B5 but exclude Format.R5G6B5.

The following C# code fragment demonstrates the use of CheckDeviceType to determine whether a certain device type can be used on the adapter.

              [C#]

public void Test_Manager_CheckDeviceType()
{
    int result;

    // Test some formats
    IsDeviceTypeOK(Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The device check failed:  {0}", result));
}

public bool IsDeviceTypeOK (Format displayFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the device can be used on the default adapter with the given surface format
    if (Manager.CheckDeviceType(ai.Adapter, DeviceType.Hardware, displayFmt, backbufferFmt, false, out result))
    {
        return true;    // if the call succeeds
    }

    return false;   // otherwise fail.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device can be used on the default adapter with the specified surface format.

Using Manager.CheckDeviceType to test for compatibility between a back buffer that differs from the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back-buffer format, result is still set to ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, result is also set to ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.


Manager.CheckDeviceType(Int32,DeviceType,Format,Format,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceType Method

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a hardware-accelerated device type can be used on the current adapter.

Definition

Visual Basic .NET Public Shared Function CheckDeviceType( _
ByVal adapter As Integer, _
ByVal checkType As DeviceType, _
ByVal displayFormat As Format, _
ByVal backBufferFormat As Format, _
ByVal windowed As Boolean _
) As Boolean
C# public static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed
);
Managed C++ public: static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed
);
JScript .NET public static function CheckDeviceType(
adapter : int,
checkType : DeviceType,
displayFormat : Format,
backBufferFormat : Format,
windowed : boolean
) : boolean;

Parameters

adapter | System.Int32. Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
checkType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that indicates the device type to check.
displayFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that indicates the format of the adapter display mode for which the device type is being checked. For example, some devices operate only in modes of 16 bits per pixel.
backBufferFormat Microsoft.DirectX.Direct3D.Format. Back buffer format. For more information about formats, see Format. This value must be one of the render target formats. Device.DisplayMode can be used to obtain the current format.

For windowed applications, the back buffer format does not need to match the display mode format if the hardware supports color conversion. The set of possible back buffer formats is constrained, but the runtime allows any valid back buffer format to be presented to any desktop format. Additionally, the device must be operable in desktop mode because devices typically do not operate in modes of 8 bits per pixel.

Full-screen applications cannot perform color conversion.

Format.Unknown is allowed for windowed mode.
windowed | System.Boolean. Set to true if the device type will be used in windowed mode. Set to false if the device type will be used in full-screen.

Return Value

System.Boolean . Returns true if the method succeeds and the device can be used on this adapter; false if the method fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall, provided adapter equals or exceeds the number of display adapters in the system. ResultCode.InvalidCall also is returned if CheckDeviceType specified a device that does not exist.

If the requested back buffer format is not supported, or if hardware acceleration is not available for the specified formats, result is set to ResultCode.NotAvailable.

Remarks

A hardware abstraction layer (HAL) device type requires hardware acceleration. Applications can use Manager.CheckDeviceType to determine whether the hardware and drivers necessary to support a HAL device are present.

Full-screen applications should not specify a displayFormat that contains an alpha channel; doing so will result in a failed call. Note that an alpha channel can be present in the back buffer, but the two display formats must be identical in all other respects. For example, if displayFormat = Format.X1R5G5B5, valid values for backBufferFormat include Format.X1R5G5B5 and Format.A1R5G5B5 but exclude Format.R5G6B5.

The following C# code fragment demonstrates the use of CheckDeviceType to determine whether a certain device type can be used on the adapter.

              [C#]

public void Test_Manager_CheckDeviceType()
{
    int result;

    // Test some formats
    IsDeviceTypeOK(Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The device check failed:  {0}", result));
}

public bool IsDeviceTypeOK (Format displayFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the device can be used on the default adapter with the given surface format
    if (Manager.CheckDeviceType(ai.Adapter, DeviceType.Hardware, displayFmt, backbufferFmt, false, out result))
    {
        return true;    // if the call succeeds
    }

    return false;   // otherwise fail.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device can be used on the default adapter with the specified surface format.

Using Manager.CheckDeviceType to test for compatibility between a back buffer that differs from the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back-buffer format, result is still set to ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, result is also set to ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.


Manager.CheckDeviceType(Int32,DeviceType,Format,Format,Boolean,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.CheckDeviceType Method

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a hardware-accelerated device type can be used on the current adapter.

Definition

Visual Basic .NET Public Shared Function CheckDeviceType( _
ByVal adapter As Integer, _
ByVal checkType As DeviceType, _
ByVal displayFormat As Format, _
ByVal backBufferFormat As Format, _
ByVal windowed As Boolean, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed,
out int result
);
Managed C++ public: static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed,
int *result
);
JScript .NET public static function CheckDeviceType(
adapter : int,
checkType : DeviceType,
displayFormat : Format,
backBufferFormat : Format,
windowed : boolean,
result : int
) : boolean;

Parameters

adapter | System.Int32. Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
checkType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that indicates the device type to check.
displayFormat | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that indicates the format of the adapter display mode for which the device type is being checked. For example, some devices operate only in modes of 16 bits per pixel.
backBufferFormat Microsoft.DirectX.Direct3D.Format. Back buffer format. For more information about formats, see Format. This value must be one of the render target formats. Device.DisplayMode can be used to obtain the current format.

For windowed applications, the back buffer format does not need to match the display mode format if the hardware supports color conversion. The set of possible back buffer formats is constrained, but the runtime allows any valid back buffer format to be presented to any desktop format. Additionally, the device must be operable in desktop mode because devices typically do not operate in modes of 8 bits per pixel.

Full-screen applications cannot perform color conversion.

Format.Unknown is allowed for windowed mode.
windowed | System.Boolean. Set to true if the device type will be used in windowed mode. Set to false if the device type will be used in full-screen.
result | System.Int32. HRESULT code passed back from the method.

Return Value

System.Boolean . Returns true if the method succeeds and the device can be used on this adapter; false if the method fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall, provided adapter equals or exceeds the number of display adapters in the system. ResultCode.InvalidCall also is returned if CheckDeviceType specified a device that does not exist.

If the requested back buffer format is not supported, or if hardware acceleration is not available for the specified formats, result is set to ResultCode.NotAvailable.

Remarks

A hardware abstraction layer (HAL) device type requires hardware acceleration. Applications can use Manager.CheckDeviceType to determine whether the hardware and drivers necessary to support a HAL device are present.

Full-screen applications should not specify a displayFormat that contains an alpha channel; doing so will result in a failed call. Note that an alpha channel can be present in the back buffer, but the two display formats must be identical in all other respects. For example, if displayFormat = Format.X1R5G5B5, valid values for backBufferFormat include Format.X1R5G5B5 and Format.A1R5G5B5 but exclude Format.R5G6B5.

The following C# code fragment demonstrates the use of CheckDeviceType to determine whether a certain device type can be used on the adapter.

              [C#]

public void Test_Manager_CheckDeviceType()
{
    int result;

    // Test some formats
    IsDeviceTypeOK(Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The device check failed:  {0}", result));
}

public bool IsDeviceTypeOK (Format displayFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the device can be used on the default adapter with the given surface format
    if (Manager.CheckDeviceType(ai.Adapter, DeviceType.Hardware, displayFmt, backbufferFmt, false, out result))
    {
        return true;    // if the call succeeds
    }

    return false;   // otherwise fail.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device can be used on the default adapter with the specified surface format.

Using Manager.CheckDeviceType to test for compatibility between a back buffer that differs from the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back-buffer format, result is still set to ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, result is also set to ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.


Manager.DisableD3DSpy()

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.DisableD3DSpy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Blocks D3DSpy from monitoring an application.

Definition

Visual Basic .NET | Public Shared Function DisableD3DSpy() As Boolean
C# | public static bool DisableD3DSpy();
Managed C++ | public: static bool DisableD3DSpy();
JScript .NET | public static function DisableD3DSpy() : boolean;

Return Value

System.Boolean . Returns true if D3DSpy is monitoring this application; otherwise, false.

Remarks

D3DSpy is a utility that monitors function calls to the Microsoft® Direct3D® application programming interface (API), and shows a representation of Direct3D's internal state. This is valuable when writing a Direct3D program, or when trying to understand why a program is behaving as it is.


Manager.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Manager.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Manager object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Manager();
Managed C++ | ~Manager();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Manager.GenerateD3DSpyBreak()

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GenerateD3DSpyBreak Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a breakpoint in D3DSpy when called within the application.

Definition

Visual Basic .NET | Public Shared Function GenerateD3DSpyBreak() As Boolean
C# | public static bool GenerateD3DSpyBreak();
Managed C++ | public: static bool GenerateD3DSpyBreak();
JScript .NET | public static function GenerateD3DSpyBreak() : boolean;

Return Value

System.Boolean . Returns true if D3DSpy is monitoring this application; otherwise, false.

Remarks

D3DSpy is a utility that monitors function calls to the Microsoft® Direct3D® application programming interface (API), and shows a representation of Direct3D's internal state. This is valuable when writing a Direct3D program, or when trying to understand why a program is behaving as it is.


Manager.GetAdapterMonitor(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetAdapterMonitor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the handle of the monitor associated with the Microsoft® Direct3D® object.

Definition

Visual Basic .NET Public Shared Function GetAdapterMonitor( _
ByVal adapter As Integer _
) As IntPtr
C# public static IntPtr GetAdapterMonitor(
int adapter
);
Managed C++ public: static IntPtr GetAdapterMonitor(
int adapter
);
JScript .NET public static function GetAdapterMonitor(
adapter : int
) : IntPtr;

Parameters

adapter System.Int32. Ordinal number that denotes the display adapter. AdapterListCollection.Default is always the primary display adapter.

Return Value

System.IntPtr . Handle of the monitor associated with the Microsoft® Direct3D® object.

Remarks

The following C# code fragment illustrates how to obtain a handle to the monitor associated with a given device.

              [C#]

IntPtr hMonitor;
AdapterInformation ai = Manager.Adapters.Default;

hMonitor = Manager.GetAdapterMonitor(ai.Adapter);


Manager.GetDeviceCaps(Int32,DeviceType)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetDeviceCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check for Shader Support

Retrieves information specific to a device.

Definition

Visual Basic .NET Public Shared Function GetDeviceCaps( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType _
) As Caps
C# public static Caps GetDeviceCaps(
int adapter,
DeviceType deviceType
);
Managed C++ public: static Caps GetDeviceCaps(
int adapter,
DeviceType deviceType
);
JScript .NET public static function GetDeviceCaps(
adapter : int,
deviceType : DeviceType
) : Caps;

Parameters

adapter | System.Int32. Ordinal number that denotes the display adapter. AdapterListCollection.Default is always the primary display adapter.
deviceType | Microsoft.DirectX.Direct3D.DeviceType. Member of the DeviceType enumeration that identifies the device type.

Return Value

Microsoft.DirectX.Direct3D.Caps . If the method succeeds, the return value is a Caps object that contains information that describes the device's capabilities.

Remarks

The application should not assume the persistence of vertex processing capabilities across Microsoft® Direct3D® device objects. The particular capabilities that a physical device exposes might depend on parameters supplied to Device.Device. For example, the capabilities might yield different vertex processing capabilities before and after creating a Direct3D Device object with hardware vertex processing enabled. For more information, see Caps.

Exceptions
InvalidCallException | Method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDeviceException | Requested device type is not valid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.

How Do I...?

Check for Shader Support

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Direct3D allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

              [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


Manager.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Manager.op_Equality(Manager,Manager)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Manager, _
ByVal right As Manager _
) As Boolean
C# public static bool op_Equality(
Manager left,
Manager right
);
Managed C++ public: static bool op_Equality(
Manager *left,
Manager *right
);
JScript .NET public static function op_Equality(
left : Manager,
right : Manager
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Manager. The Manager object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Manager. The Manager object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Manager.op_Inequality(Manager,Manager)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Manager, _
ByVal right As Manager _
) As Boolean
C# public static bool op_Inequality(
Manager left,
Manager right
);
Managed C++ public: static bool op_Inequality(
Manager *left,
Manager *right
);
JScript .NET public static function op_Inequality(
left : Manager,
right : Manager
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Manager. The Manager object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Manager. The Manager object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Manager.Adapters

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.Adapters Property

Language:
Note: This documentation is preliminary and is subject to change.

Collection of adapters on the system.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Adapters As AdapterListCollection
C# | public static AdapterListCollection Adapters { get; }
Managed C++ | public: __property static AdapterListCollection* get_Adapters();
JScript .NET | public static function get Adapters() : AdapterListCollection

Property Value

Microsoft.DirectX.Direct3D.AdapterListCollection .

This property is read-only.


Microsoft.DirectX.Direct3D.Mesh

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Manipulates mesh objects.

Definition

Visual Basic .NET NotInheritable Public Class Mesh
Inherits BaseMesh
C# | public sealed class Mesh : BaseMesh
Managed C++ | public __gc __sealed class Mesh : public BaseMesh
JScript .NET | public class Mesh extends BaseMesh

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Mesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
static (Shared in Visual Basic .NET) Box | Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.
static (Shared in Visual Basic .NET) Clean | Cleans a mesh, preparing it for simplification.
Clone | Clones, or copies, a mesh object. Inherited from BaseMesh.
ComputeNormals | Computes normals for each vertex in a mesh. Inherited from BaseMesh.
ComputeTangent | Computes the tangent vectors for the texture coordinates given in a texture stage.
ConvertAdjacencyToPointReps | Converts mesh adjacency information to an array of point representatives. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) ConvertMeshSubsetToSingleStrip | Converts the specified mesh subset into a single triangle strip.
static (Shared in Visual Basic .NET) ConvertMeshSubsetToStrips | Converts the specified mesh subset into a series of strips.
ConvertPointRepsToAdjacency | Converts point representative data to mesh adjacency information. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) Cylinder | Uses a left-handed coordinate system to create a mesh that contains a cylinder.
Dispose | Immediately releases the unmanaged resources used by the Mesh object.
DrawSubset | Draws a subset of a mesh. Inherited from BaseMesh.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Mesh object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FromFile | Loads a mesh from a .x file.
static (Shared in Visual Basic .NET) FromStream | Loads a mesh from a Stream Leave Site.
static (Shared in Visual Basic .NET) FromX | Loads a mesh from an XFileData object.
GenerateAdjacency | Generates adjacency information based on mesh indices. Inherited from BaseMesh.
GetAttributeTable | Retrieves an attribute table for a mesh. Inherited from BaseMesh.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
Intersect | Determines whether a ray intersects with a mesh.
IntersectSubset | Intersects the specified ray with a given mesh subset.
static (Shared in Visual Basic .NET) LoadHierarchy | Loads the first frame hierarchy from a Stream Leave Site.
static (Shared in Visual Basic .NET) LoadHierarchyFromFile | Loads the first frame hierarchy in a DirectX (.x) file.
LockAttributeBuffer | Locks an attribute buffer and obtains its memory.
LockAttributeBufferArray | Locks an attribute buffer and obtains its memory.
LockIndexBuffer | Locks an index buffer and obtains the index buffer data. Inherited from BaseMesh.
LockVertexBuffer | Locks a vertex buffer and obtains a pointer to the vertex buffer memory. Inherited from BaseMesh.
Mesh | Creates a new Mesh instance.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Optimize | Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.
OptimizeInPlace | Controls the reordering of mesh faces and vertices to optimize performance.
static (Shared in Visual Basic .NET) Polygon | Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Mesh.Disposing event when called from within a derived class.
Save | Saves the mesh to the specified stream object.
static (Shared in Visual Basic .NET) SaveHierarchyToFile | Creates a DirectX (.x) file and saves the mesh hierarchy and corresponding animations in it.
SetAttributeTable | Sets a mesh's attribute table and specifies the number of entries stored in it.
SetIndexBufferData | Sets index buffer data. Inherited from BaseMesh.
SetVertexBufferData | Sets vertex buffer data. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) Simplify | Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.
static (Shared in Visual Basic .NET) Sphere | Uses a left-handed coordinate system to create a mesh that contains a sphere.
static (Shared in Visual Basic .NET) Split | Splits a mesh into multiple meshes that are smaller than the specified size.
static (Shared in Visual Basic .NET) Teapot | Uses a left-handed coordinate system to create a mesh that contains a teapot.
static (Shared in Visual Basic .NET) TessellateNPatches | Tessellates the given mesh using the N-patch tessellation scheme.
static (Shared in Visual Basic .NET) TextFromFont | Creates a mesh that contains the specified text, using a .NET font object.
static (Shared in Visual Basic .NET) Torus | Uses a left-handed coordinate system to create a mesh that contains a torus.
UnlockAttributeBuffer | Unlocks an attribute buffer.
UnlockIndexBuffer | Unlocks an index buffer. Inherited from BaseMesh.
UnlockVertexBuffer | Unlocks a vertex buffer. Inherited from BaseMesh.
UpdateSemantics Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Mesh object. This method supports the Framework infrastructure and is not intended to be used directly in your code.
Validate | Validates a mesh.
WeldVertices | Welds together replicated vertices that have equal attributes.

Properties

Property | Description
Declaration | Retrieves a declaration that describes the vertices in a mesh. Inherited from BaseMesh.
Device | Retrieves the device associated with a mesh. Inherited from BaseMesh.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the data in an index buffer. Inherited from BaseMesh.
NumberAttributes | Retrieves the number of entries stored in an attribute table for a mesh. Inherited from BaseMesh.
NumberBytesPerVertex | Retrieves the number of bytes per vertex. Inherited from BaseMesh.
NumberFaces | Retrieves the number of faces in a mesh. Inherited from BaseMesh.
NumberVertices | Retrieves the number of vertices in a mesh. Inherited from BaseMesh.
Options | Retrieves the mesh options enabled for the current mesh at creation time. Inherited from BaseMesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXMesh interface pointer.
UnmanagedComPointer | Returns the unmanaged COM ID3DXBaseMesh interface pointer. Inherited from BaseMesh.
VertexBuffer | Retrieves the vertex buffer of a mesh. Inherited from BaseMesh.
VertexFormat | Retrieves the vertex format that describes the contents of vertices. Inherited from BaseMesh.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseMesh
Mesh

Remarks

This object inherits additional functionality from the BaseMesh object.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Mesh.Box

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Box Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.

Overload List

public static Mesh Box(Device, float, float, float);
public static Mesh Box(Device, float, float, float, out GraphicsStream);

Remarks

The created box is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Box(Device,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Box Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.

Definition

Visual Basic .NET Public Shared Function Box( _
ByVal device As Device, _
ByVal width As Single, _
ByVal height As Single, _
ByVal depth As Single _
) As Mesh
C# public static Mesh Box(
Device device,
float width,
float height,
float depth
);
Managed C++ public: static Mesh* Box(
Device *device,
float width,
float height,
float depth
);
JScript .NET public static function Box(
device : Device,
width : float,
height : float,
depth : float
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object.
width | System.Single. Width of the box along the x-axis.
height | System.Single. Height of the box along the y-axis.
depth | System.Single. Depth of the box along the z-axis.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that contains the box.

Remarks

The created box is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Box(Device,Single,Single,Single,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Box Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.

Definition

Visual Basic .NET Public Shared Function Box( _
ByVal device As Device, _
ByVal width As Single, _
ByVal height As Single, _
ByVal depth As Single, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Box(
Device device,
float width,
float height,
float depth,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* Box(
Device *device,
float width,
float height,
float depth,
GraphicsStream **adjacency
);
JScript .NET public static function Box(
device : Device,
width : float,
height : float,
depth : float,
adjacency : GraphicsStream
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object.
width | System.Single. Width of the box along the x-axis.
height | System.Single. Height of the box along the y-axis.
depth | System.Single. Depth of the box along the z-axis.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object. When the method returns, this parameter is filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that contains the box.

Remarks

The created box is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Clean

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Clean Method

 Language:
Note: This documentation is preliminary and is subject to change.

Cleans a mesh, preparing it for simplification.

Overload List

public static Mesh Clean(CleanType, Mesh, GraphicsStream, GraphicsStream);
public static Mesh Clean(CleanType, Mesh, GraphicsStream, GraphicsStream, out string);
public static Mesh Clean(CleanType, Mesh, int[], out int);
public static Mesh Clean(CleanType, Mesh, int[], out int, out string);

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,Int32[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Clean Method

 Language:
Note: This documentation is preliminary and is subject to change.

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic .NET Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByRef adjacencyOut As Integer _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
int[] adjacency,
out int adjacencyOut
);
Managed C++ public: static Mesh* Clean(
CleanType cleanType,
Mesh *mesh,
int adjacency __gc[],
int *adjacencyOut
);
JScript .NET public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : int[],
adjacencyOut : int
) : Mesh;

Parameters

cleanType | Microsoft.DirectX.Direct3D.CleanType. A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to clean.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,Int32[],Int32,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Clean Method

 Language:
Note: This documentation is preliminary and is subject to change.

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic .NET Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef errorsAndWarnings As String _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
int[] adjacency,
out int adjacencyOut,
out string errorsAndWarnings
);
Managed C++ public: static Mesh* Clean(
CleanType cleanType,
Mesh *mesh,
int adjacency __gc[],
int *adjacencyOut,
String **errorsAndWarnings
);
JScript .NET public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : int[],
adjacencyOut : int,
errorsAndWarnings : String
) : Mesh;

Parameters

cleanType | Microsoft.DirectX.Direct3D.CleanType. A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to clean.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.
errorsAndWarnings | System.String. A String Leave Site that contains a list of errors and warnings that explain the problems found in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Clean Method

 Language:
Note: This documentation is preliminary and is subject to change.

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic .NET Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream adjacencyOut
);
Managed C++ public: static Mesh* Clean(
CleanType cleanType,
Mesh *mesh,
GraphicsStream *adjacency,
GraphicsStream *adjacencyOut
);
JScript .NET public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : GraphicsStream,
adjacencyOut : GraphicsStream
) : Mesh;

Parameters

cleanType | Microsoft.DirectX.Direct3D.CleanType. A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to clean.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut | Microsoft.DirectX.GraphicsStream. A GraphicsStream object. When the method returns, this parameter is filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,GraphicsStream,GraphicsStream,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Clean Method

 Language:
Note: This documentation is preliminary and is subject to change.

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic .NET Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream, _
ByRef errorsAndWarnings As String _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream adjacencyOut,
out string errorsAndWarnings
);
Managed C++ public: static Mesh* Clean(
CleanType cleanType,
Mesh *mesh,
GraphicsStream *adjacency,
GraphicsStream *adjacencyOut,
String **errorsAndWarnings
);
JScript .NET public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : GraphicsStream,
adjacencyOut : GraphicsStream,
errorsAndWarnings : String
) : Mesh;

Parameters

cleanType | Microsoft.DirectX.Direct3D.CleanType. A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to clean.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut | Microsoft.DirectX.GraphicsStream. A GraphicsStream object. When the method returns, this parameter is filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.
errorsAndWarnings | System.String. A String Leave Site that contains a list of errors and warnings that explain the problems found in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.ComputeTangent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the tangent vectors for the texture coordinates given in a texture stage.

Overload List

public void ComputeTangent(int, int, int, int);
public void ComputeTangent(int, int, int, int, GraphicsStream);
public void ComputeTangent(int, int, int, int, int[]);

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.ComputeTangent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the tangent vectors for the texture coordinates given in a texture stage.

Definition

Visual Basic .NET Public Sub ComputeTangent( _
ByVal texStage As Integer, _
ByVal tangentIndex As Integer, _
ByVal binormIndex As Integer, _
ByVal wrap As Integer _
)
C# public void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap
);
Managed C++ public: void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap
);
JScript .NET public function ComputeTangent(
texStage : int,
tangentIndex : int,
binormIndex : int,
wrap : int
);

Parameters

texStage | System.Int32. Index that represents the TextureStateManager in TextureStateManagerCollection.
tangentIndex | System.Int32. Index that provides the usage index for the tangent data. The vertex declaration implies the usage; this index modifies it.
binormIndex | System.Int32. Index that provides the usage index for the binormal data. The vertex declaration implies the usage; this index modifies it.
wrap | System.Int32. Value that is set to 0 to specify no wrapping, or to 1 to specify wrapping in the u and v directions.

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent(Int32,Int32,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.ComputeTangent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the tangent vectors for the texture coordinates given in a texture stage.

Definition

Visual Basic .NET Public Sub ComputeTangent( _
ByVal texStage As Integer, _
ByVal tangentIndex As Integer, _
ByVal binormIndex As Integer, _
ByVal wrap As Integer, _
ByVal adjacency As GraphicsStream _
)
C# public void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
GraphicsStream adjacency
);
Managed C++ public: void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
GraphicsStream *adjacency
);
JScript .NET public function ComputeTangent(
texStage : int,
tangentIndex : int,
binormIndex : int,
wrap : int,
adjacency : GraphicsStream
);

Parameters

texStage | System.Int32. Index that represents the TextureStateManager in TextureStateManagerCollection.
tangentIndex | System.Int32. Index that provides the usage index for the tangent data. The vertex declaration implies the usage; this index modifies it.
binormIndex | System.Int32. Index that provides the usage index for the binormal data. The vertex declaration implies the usage; this index modifies it.
wrap | System.Int32. Value that is set to 0 to specify no wrapping, or to 1 to specify wrapping in the u and v directions.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object filled with an array of three Int32 Leave Site values per face to be filled with adjacent face indices.

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent(Int32,Int32,Int32,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.ComputeTangent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the tangent vectors for the texture coordinates given in a texture stage.

Definition

Visual Basic .NET Public Sub ComputeTangent( _
ByVal texStage As Integer, _
ByVal tangentIndex As Integer, _
ByVal binormIndex As Integer, _
ByVal wrap As Integer, _
ByVal adjacency() As Integer _
)
C# public void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
int[] adjacency
);
Managed C++ public: void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
int adjacency __gc[]
);
JScript .NET public function ComputeTangent(
texStage : int,
tangentIndex : int,
binormIndex : int,
wrap : int,
adjacency : int[]
);

Parameters

texStage | System.Int32. Index that represents the TextureStateManager in TextureStateManagerCollection.
tangentIndex | System.Int32. Index that provides the usage index for the tangent data. The vertex declaration implies the usage; this index modifies it.
binormIndex | System.Int32. Index that provides the usage index for the binormal data. The vertex declaration implies the usage; this index modifies it.
wrap | System.Int32. Value that is set to 0 to specify no wrapping, or to 1 to specify wrapping in the u and v directions.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh. The size of this array must be at least 3 * BaseMesh.NumberFaces.

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.ConvertMeshSubsetToSingleStrip(Mesh,Int32,MeshFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.ConvertMeshSubsetToSingleStrip Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts the specified mesh subset into a single triangle strip.

Definition

Visual Basic .NET Public Shared Function ConvertMeshSubsetToSingleStrip( _
ByVal mesh As Mesh, _
ByVal attributeIdentifier As Integer, _
ByVal indexBufferOptions As MeshFlags, _
ByRef numIndices As Integer _
) As IndexBuffer
C# public static IndexBuffer ConvertMeshSubsetToSingleStrip(
Mesh mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
out int numIndices
);
Managed C++ public: static IndexBuffer* ConvertMeshSubsetToSingleStrip(
Mesh *mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
int *numIndices
);
JScript .NET public static function ConvertMeshSubsetToSingleStrip(
mesh : Mesh,
attributeIdentifier : int,
indexBufferOptions : MeshFlags,
numIndices : int
) : IndexBuffer;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A BaseMesh object that represents the mesh to convert.
attributeIdentifier | System.Int32. Attribute identifier of the mesh subset to convert.
indexBufferOptions | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify options for creating the single strip mesh (excepting the Simplify* and Optimize* flags).
numIndices | System.Int32. Number of indices in the buffer returned in the ret_IndexBuffer.

Return Value

Microsoft.DirectX.Direct3D.IndexBuffer . An IndexBuffer object that contains the strip.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.ConvertMeshSubsetToStrips(BaseMesh,Int32,MeshFlags,Int32,GraphicsStream,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.ConvertMeshSubsetToStrips Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts the specified mesh subset into a series of strips.

Definition

Visual Basic .NET Public Shared Function ConvertMeshSubsetToStrips( _
ByVal mesh As BaseMesh, _
ByVal attributeIdentifier As Integer, _
ByVal indexBufferOptions As MeshFlags, _
ByRef numIndices As Integer, _
ByRef stripLengths As GraphicsStream, _
ByRef numStrips As Integer _
) As IndexBuffer
C# public static IndexBuffer ConvertMeshSubsetToStrips(
BaseMesh mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
out int numIndices,
out GraphicsStream stripLengths,
out int numStrips
);
Managed C++ public: static IndexBuffer* ConvertMeshSubsetToStrips(
BaseMesh *mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
int *numIndices,
GraphicsStream **stripLengths,
int *numStrips
);
JScript .NET public static function ConvertMeshSubsetToStrips(
mesh : BaseMesh,
attributeIdentifier : int,
indexBufferOptions : MeshFlags,
numIndices : int,
stripLengths : GraphicsStream,
numStrips : int
) : IndexBuffer;

Parameters

mesh | Microsoft.DirectX.Direct3D.BaseMesh. A BaseMesh class that represents the mesh to convert.
attributeIdentifier | System.Int32. Attribute identifier of the mesh subset to convert.
indexBufferOptions | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify options for creating the new strip mesh (excepting the Simplify* and Optimize* flags).
numIndices | System.Int32. Number of indices in the buffer returned in the ret_IndexBuffer.
stripLengths | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains one Int32 Leave Site value per strip, which specifies the number of triangles in that strip.
numStrips | System.Int32. Number of individual strips in the index buffer and the corresponding strip length array.

Return Value

Microsoft.DirectX.Direct3D.IndexBuffer . An IndexBuffer class that represents the index buffer containing the strip.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Cylinder

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Cylinder Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a cylinder.

Overload List

public static Mesh Cylinder(Device, float, float, float, int, int);
public static Mesh Cylinder(Device, float, float, float, int, int, out GraphicsStream);

Remarks

The created cylinder is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Cylinder(Device,Single,Single,Single,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Cylinder Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a cylinder.

Definition

Visual Basic .NET Public Shared Function Cylinder( _
ByVal device As Device, _
ByVal radius1 As Single, _
ByVal radius2 As Single, _
ByVal length As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer _
) As Mesh
C# public static Mesh Cylinder(
Device device,
float radius1,
float radius2,
float length,
int slices,
int stacks
);
Managed C++ public: static Mesh* Cylinder(
Device *device,
float radius1,
float radius2,
float length,
int slices,
int stacks
);
JScript .NET public static function Cylinder(
device : Device,
radius1 : float,
radius2 : float,
length : float,
slices : int,
stacks : int
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created cylinder mesh.
radius1 | System.Single. Radius at the negative Z end. Value should be greater than or equal to 0.0f.
radius2 | System.Single. Radius at the positive Z end. Value should be greater than or equal to 0.0f.
length | System.Single. Length of the cylinder along the z-axis.
slices | System.Int32. Number of slices around the main axis.
stacks | System.Int32. Number of stacks along the main axis.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the cylinder mesh.

Remarks

The created cylinder is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Cylinder(Device,Single,Single,Single,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Cylinder Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a cylinder.

Definition

Visual Basic .NET Public Shared Function Cylinder( _
ByVal device As Device, _
ByVal radius1 As Single, _
ByVal radius2 As Single, _
ByVal length As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Cylinder(
Device device,
float radius1,
float radius2,
float length,
int slices,
int stacks,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* Cylinder(
Device *device,
float radius1,
float radius2,
float length,
int slices,
int stacks,
GraphicsStream **adjacency
);
JScript .NET public static function Cylinder(
device : Device,
radius1 : float,
radius2 : float,
length : float,
slices : int,
stacks : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created cylinder mesh.
radius1 | System.Single. Radius at the negative Z end. Value should be greater than or equal to 0.0f.
radius2 | System.Single. Radius at the positive Z end. Value should be greater than or equal to 0.0f.
length | System.Single. Length of the cylinder along the z-axis.
slices | System.Int32. Number of slices around the main axis.
stacks | System.Int32. Number of stacks along the main axis.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the cylinder mesh.

Remarks

The created cylinder is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Mesh object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Mesh.Disposed
  • Microsoft.DirectX.Direct3D.Mesh.Disposing


Mesh.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Mesh.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Mesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Mesh();
Managed C++ | ~Mesh();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Mesh.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Overload List

public static Mesh FromFile(string, MeshFlags, Device);
public static Mesh FromFile(string, MeshFlags, Device, out EffectInstance);
public static Mesh FromFile(string, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromFile(string, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device,
EffectInstance *effects
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
EffectInstance *effects
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device,
GraphicsStream **adjacency
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device,
ExtendedMaterial *materials
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a .x file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromFile(
String *filename,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Overload List

public static Mesh FromStream(Stream, int, MeshFlags, Device);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out EffectInstance);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device);
public static Mesh FromStream(Stream, MeshFlags, Device, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromStream(Stream, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device, out GraphicsStream);
public static Mesh FromStream(Stream, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
MeshFlags options,
Device *device,
EffectInstance *effects
);
JScript .NET public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,GraphicsStream,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
EffectInstance *effects
);
JScript .NET public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
MeshFlags options,
Device *device,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
MeshFlags options,
Device *device
);
JScript .NET public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
MeshFlags options,
Device *device,
GraphicsStream **adjacency
);
JScript .NET public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
MeshFlags options,
Device *device,
ExtendedMaterial *materials
);
JScript .NET public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,GraphicsStream,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials
);
JScript .NET public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
EffectInstance *effects
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
EffectInstance *effects
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
GraphicsStream **adjacency
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
ExtendedMaterial *materials
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromStream(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh data.
readBytes | System.Int32. Size of the file in memory in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Overload List

public static Mesh FromX(XFileData, MeshFlags, Device);
public static Mesh FromX(XFileData, MeshFlags, Device, out EffectInstance);
public static Mesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromX(XFileData, MeshFlags, Device, out GraphicsStream);
public static Mesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device
);
Managed C++ public: static Mesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
GraphicsStream **adjacency
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
Managed C++ public: static Mesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
ExtendedMaterial *materials
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static Mesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that contains the mesh data.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Mesh.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXMesh, which allows unmanaged COM clients to create an instance of the managed Mesh class. Not supported.


Mesh.Intersect

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a ray intersects with a mesh.

Overload List

public bool Intersect(Vector3, Vector3);
public bool Intersect(Vector3, Vector3, out IntersectInformation);
public bool Intersect(Vector3, Vector3, out IntersectInformation, out IntersectInformation);
public bool Intersect(Vector3, Vector3, out IntersectInformation);

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a ray intersects with a mesh.

Definition

Visual Basic .NET Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3 _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir
);
Managed C++ public: bool Intersect(
Vector3 rayPos,
Vector3 rayDir
);
JScript .NET public function Intersect(
rayPos : Vector3,
rayDir : Vector3
) : boolean;

Parameters

rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3,IntersectInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a ray intersects with a mesh.

Definition

Visual Basic .NET Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation allHits
);
Managed C++ public: bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
IntersectInformation *allHits
);
JScript .NET public function Intersect(
rayPos : Vector3,
rayDir : Vector3,
allHits : IntersectInformation
) : boolean;

Parameters

rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.
allHits | Microsoft.DirectX.Direct3D.IntersectInformation[]. Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3,IntersectInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a ray intersects with a mesh.

Definition

Visual Basic .NET Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit
);
Managed C++ public: bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
IntersectInformation *closestHit
);
JScript .NET public function Intersect(
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation
) : boolean;

Parameters

rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.
closestHit | Microsoft.DirectX.Direct3D.IntersectInformation. An IntersectInformation object that describes the closest intersection between the array and the mesh.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3,IntersectInformation,IntersectInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a ray intersects with a mesh.

Definition

Visual Basic .NET Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit,
out IntersectInformation allHits
);
Managed C++ public: bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
IntersectInformation *closestHit,
IntersectInformation *allHits
);
JScript .NET public function Intersect(
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation,
allHits : IntersectInformation
) : boolean;

Parameters

rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.
closestHit | Microsoft.DirectX.Direct3D.IntersectInformation. An IntersectInformation object that describes the closest intersection between the array and the mesh.
allHits | Microsoft.DirectX.Direct3D.IntersectInformation[]. Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.IntersectSubset

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.IntersectSubset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Intersects the specified ray with a given mesh subset.

Overload List

public bool IntersectSubset(int, Vector3, Vector3);
public bool IntersectSubset(int, Vector3, Vector3, out IntersectInformation);
public bool IntersectSubset(int, Vector3, Vector3, out IntersectInformation, out IntersectInformation);
public bool IntersectSubset(int, Vector3, Vector3, out IntersectInformation);

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.IntersectSubset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic .NET Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3 _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir
);
Managed C++ public: bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir
);
JScript .NET public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3
) : boolean;

Parameters

attributeId | System.Int32. Attribute identifier of the subset to intersect with.
rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3,IntersectInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.IntersectSubset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic .NET Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation allHits
);
Managed C++ public: bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
IntersectInformation *allHits
);
JScript .NET public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3,
allHits : IntersectInformation
) : boolean;

Parameters

attributeId | System.Int32. Attribute identifier of the subset to intersect with.
rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.
allHits | Microsoft.DirectX.Direct3D.IntersectInformation[]. Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3,IntersectInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.IntersectSubset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic .NET Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit
);
Managed C++ public: bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
IntersectInformation *closestHit
);
JScript .NET public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation
) : boolean;

Parameters

attributeId | System.Int32. Attribute identifier of the subset to intersect with.
rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.
closestHit | Microsoft.DirectX.Direct3D.IntersectInformation. An IntersectInformation object that describes the closest intersection between the array and the mesh.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3,IntersectInformation,IntersectInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.IntersectSubset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic .NET Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit,
out IntersectInformation allHits
);
Managed C++ public: bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
IntersectInformation *closestHit,
IntersectInformation *allHits
);
JScript .NET public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation,
allHits : IntersectInformation
) : boolean;

Parameters

attributeId | System.Int32. Attribute identifier of the subset to intersect with.
rayPos | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the origin coordinate of the ray.
rayDir | Microsoft.DirectX.Vector3. A Vector3 structure that specifies the direction of the ray.
closestHit | Microsoft.DirectX.Direct3D.IntersectInformation. An IntersectInformation object that describes the closest intersection between the array and the mesh.
allHits | Microsoft.DirectX.Direct3D.IntersectInformation[]. Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean . Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchy

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.LoadHierarchy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads the first frame hierarchy from a Stream Leave Site.

Overload List

public static AnimationRootFrame LoadHierarchy(Stream, int, MeshFlags, Device, AllocateHierarchy, LoadUserData);
public static AnimationRootFrame LoadHierarchy(Stream, MeshFlags, Device, AllocateHierarchy, LoadUserData);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchy(Stream,MeshFlags,Device,AllocateHierarchy,LoadUserData)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.LoadHierarchy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads the first frame hierarchy from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function LoadHierarchy( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByVal allocHierarchy As AllocateHierarchy, _
ByVal userDataLoader As LoadUserData _
) As AnimationRootFrame
C# public static AnimationRootFrame LoadHierarchy(
Stream stream,
MeshFlags options,
Device device,
AllocateHierarchy allocHierarchy,
LoadUserData userDataLoader
);
Managed C++ public: static AnimationRootFrame LoadHierarchy(
Stream *stream,
MeshFlags options,
Device *device,
AllocateHierarchy *allocHierarchy,
LoadUserData *userDataLoader
);
JScript .NET public static function LoadHierarchy(
stream : Stream,
options : MeshFlags,
device : Device,
allocHierarchy : AllocateHierarchy,
userDataLoader : LoadUserData
) : AnimationRootFrame;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh hierarchy to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
allocHierarchy | Microsoft.DirectX.Direct3D.AllocateHierarchy. An AllocateHierarchy object.
userDataLoader | Microsoft.DirectX.Direct3D.LoadUserData. Application-provided object that allows loading of user data. For more information, see LoadUserData.

Return Value

Microsoft.DirectX.Direct3D.AnimationRootFrame . An AnimationRootFrame. The AnimationRootFrame.AnimationController property contains an AnimationController that corresponds to an animation, created with default tracks and events, in the DirectX (.x) file.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchy(Stream,Int32,MeshFlags,Device,AllocateHierarchy,LoadUserData)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.LoadHierarchy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads the first frame hierarchy from a Stream Leave Site.

Definition

Visual Basic .NET Public Shared Function LoadHierarchy( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByVal allocHierarchy As AllocateHierarchy, _
ByVal userDataLoader As LoadUserData _
) As AnimationRootFrame
C# public static AnimationRootFrame LoadHierarchy(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
AllocateHierarchy allocHierarchy,
LoadUserData userDataLoader
);
Managed C++ public: static AnimationRootFrame LoadHierarchy(
Stream *stream,
int readBytes,
MeshFlags options,
Device *device,
AllocateHierarchy *allocHierarchy,
LoadUserData *userDataLoader
);
JScript .NET public static function LoadHierarchy(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
allocHierarchy : AllocateHierarchy,
userDataLoader : LoadUserData
) : AnimationRootFrame;

Parameters

stream | System.IO.Stream. A Stream Leave Site object that contains the mesh hierarchy to load.
readBytes | System.Int32. Size of the param_Stream_stream in bytes.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Deviceto associate with the mesh.
allocHierarchy | Microsoft.DirectX.Direct3D.AllocateHierarchy. An AllocateHierarchy object.
userDataLoader | Microsoft.DirectX.Direct3D.LoadUserData. Application-provided object that allows loading of user data. For more information, see LoadUserData.

Return Value

Microsoft.DirectX.Direct3D.AnimationRootFrame . An AnimationRootFrame. The AnimationRootFrame.AnimationController property contains an AnimationController that corresponds to an animation, created with default tracks and events, in the DirectX (.x) file.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchyFromFile(String,MeshFlags,Device,AllocateHierarchy,LoadUserData)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.LoadHierarchyFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads the first frame hierarchy in a DirectX (.x) file.

Definition

Visual Basic .NET Public Shared Function LoadHierarchyFromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByVal allocHierarchy As AllocateHierarchy, _
ByVal userDataLoader As LoadUserData _
) As AnimationRootFrame
C# public static AnimationRootFrame LoadHierarchyFromFile(
string filename,
MeshFlags options,
Device device,
AllocateHierarchy allocHierarchy,
LoadUserData userDataLoader
);
Managed C++ public: static AnimationRootFrame LoadHierarchyFromFile(
String *filename,
MeshFlags options,
Device *device,
AllocateHierarchy *allocHierarchy,
LoadUserData *userDataLoader
);
JScript .NET public static function LoadHierarchyFromFile(
filename : String,
options : MeshFlags,
device : Device,
allocHierarchy : AllocateHierarchy,
userDataLoader : LoadUserData
) : AnimationRootFrame;

Parameters

filename | System.String. String that specifies the file name.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.
allocHierarchy | Microsoft.DirectX.Direct3D.AllocateHierarchy. An AllocateHierarchy object. See Remarks.
userDataLoader | Microsoft.DirectX.Direct3D.LoadUserData. Application-provided object that allows loading of user data. For more information, see LoadUserData.

Return Value

Microsoft.DirectX.Direct3D.AnimationRootFrame . An AnimationRootFrame. The AnimationRootFrame.AnimationController property contains an AnimationController that corresponds to an animation, created with default tracks and events, in the .x file.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

The LoadHierarchyFromFile method loads the animation data and frame hierarchy from a .x file. It scans the .x file and builds a frame hierarchy and animation controller according to the object, derived from AllocateHierarchy, that is passed to it through param_AllocateHierarchy_allocHierarchy. Loading the data requires the following steps.

  1. Derive AllocateHierarchy, implementing each method. This controls how frames and meshes are allocated and freed.
  2. Derive LoadUserData, implementing each method. If the .x file has no embedded user-defined data, or if it is not needed, this step can be skipped.
  3. Create an object of the AllocateHierarchy class, and optionally of the LoadUserData class. You do not need to call any methods of these objects yourself.
  4. Call LoadHierarchyFromFile, passing in the AllocateHierarchy and LoadUserData objects (or null) to create the frame hierarchy and animation controller. All of the animation sets and frames are automatically registered to the animation controller.

During the load, AllocateHierarchy.CreateFrame and LoadUserData.LoadFrameChildData are called back on each frame to control its loading and allocation. The application defines these methods to control how frames are stored.

The AllocateHierarchy.CreateMeshContainer and LoadUserData.LoadMeshChildData methods are called back on each mesh object to control their loading and allocation. The LoadUserData.LoadTopLevelData method is called back for each top-level object that is not loaded by the other methods.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.LockAttributeBuffer(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.LockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks an attribute buffer and obtains its memory.

Definition

Visual Basic .NET Public Function LockAttributeBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockAttributeBuffer(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockAttributeBuffer(
LockFlags flags
);
JScript .NET public function LockAttributeBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream .

Remarks

If Mesh.Optimize is called, the mesh attribute buffer contains an attribute table.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetAttributeTable
  • UnlockAttributeBuffer


Mesh.LockAttributeBufferArray(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.LockAttributeBufferArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks an attribute buffer and obtains its memory.

Definition

Visual Basic .NET Public Function LockAttributeBufferArray( _
ByVal flags As LockFlags _
) As Integer()
C# public int[] LockAttributeBufferArray(
LockFlags flags
);
Managed C++ public: int LockAttributeBufferArray(
LockFlags flags
) __gc[];
JScript .NET public function LockAttributeBufferArray(
flags : LockFlags
) : int[];

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly.

Return Value

System.Int32[]. Returns an array that contains three Int32 Leave Site values for each face in the mesh.

Remarks

If Mesh.Optimize is called, the mesh attribute buffer contains an attribute table.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetAttributeTable
  • UnlockAttributeBuffer


Mesh.Mesh

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Mesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Overload List

public Mesh(ID3DXMesh);
public Mesh(int, int, MeshFlags, GraphicsStream, Device);
public Mesh(int, int, MeshFlags, VertexElement[], Device);
public Mesh(int, int, MeshFlags, VertexFormats, Device);
public Mesh(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(ID3DXMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Mesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As ID3DXMesh _
)
C# public Mesh(
ID3DXMesh pInterop
);
Managed C++ public: Mesh(
ID3DXMesh pInterop
);
JScript .NET public function Mesh(
pInterop : ID3DXMesh
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXMesh. Unmanaged Component Object Model (COM) ID3DXMesh interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Mesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Mesh(
IntPtr unmanagedObject
);
Managed C++ public: Mesh(
IntPtr unmanagedObject
);
JScript .NET public function Mesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(Int32,Int32,MeshFlags,VertexFormats,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Mesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic .NET Public Sub New( _
ByVal numFaces As Integer, _
ByVal numVertices As Integer, _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
)
C# public Mesh(
int numFaces,
int numVertices,
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
Managed C++ public: Mesh(
int numFaces,
int numVertices,
MeshFlags options,
VertexFormats vertexFormat,
Device *device
);
JScript .NET public function Mesh(
numFaces : int,
numVertices : int,
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
);

Parameters

numFaces | System.Int32. Number of faces for the mesh. The valid range is greater than 0 and one less than the maximum Int32 Leave Site (typically 65534), because the last index is reserved.
numVertices | System.Int32. Number of vertices for the mesh. This parameter must be greater than 0.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. One or more flags from the VertexFormats enumeration that specify the format of the mesh vertices.
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(Int32,Int32,MeshFlags,GraphicsStream,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Mesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic .NET Public Sub New( _
ByVal numFaces As Integer, _
ByVal numVertices As Integer, _
ByVal options As MeshFlags, _
ByVal declaration As GraphicsStream, _
ByVal device As Device _
)
C# public Mesh(
int numFaces,
int numVertices,
MeshFlags options,
GraphicsStream declaration,
Device device
);
Managed C++ public: Mesh(
int numFaces,
int numVertices,
MeshFlags options,
GraphicsStream *declaration,
Device *device
);
JScript .NET public function Mesh(
numFaces : int,
numVertices : int,
options : MeshFlags,
declaration : GraphicsStream,
device : Device
);

Parameters

numFaces | System.Int32. Number of faces for the mesh. The valid range is greater than 0 and one less than the maximum Int32 Leave Site (typically 65534), because the last index is reserved.
numVertices | System.Int32. Number of vertices for the mesh. This parameter must be greater than 0.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing an array of VertexFormats enumeration values that specify the format of the mesh vertices.
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(Int32,Int32,MeshFlags,VertexElement[],Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Mesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic .NET Public Sub New( _
ByVal numFaces As Integer, _
ByVal numVertices As Integer, _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
)
C# public Mesh(
int numFaces,
int numVertices,
MeshFlags options,
VertexElement[] declaration,
Device device
);
Managed C++ public: Mesh(
int numFaces,
int numVertices,
MeshFlags options,
VertexElement declaration __gc[],
Device *device
);
JScript .NET public function Mesh(
numFaces : int,
numVertices : int,
options : MeshFlags,
declaration : VertexElement[],
device : Device
);

Parameters

numFaces | System.Int32. Number of faces for the mesh. The valid range is greater than 0 and one less than the maximum Int32 Leave Site (typically 65534), because the last index is reserved.
numVertices | System.Int32. Number of vertices for the mesh. This parameter must be greater than 0.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. An array of VertexElement objects, that describes the vertex format for the returned mesh. This parameter must map directly to a flexible vertex format (FVF).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.op_Equality(Mesh,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Mesh, _
ByVal right As Mesh _
) As Boolean
C# public static bool op_Equality(
Mesh left,
Mesh right
);
Managed C++ public: static bool op_Equality(
Mesh *left,
Mesh *right
);
JScript .NET public static function op_Equality(
left : Mesh,
right : Mesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Mesh. The Mesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Mesh. The Mesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Mesh.op_Inequality(Mesh,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Mesh, _
ByVal right As Mesh _
) As Boolean
C# public static bool op_Inequality(
Mesh left,
Mesh right
);
Managed C++ public: static bool op_Inequality(
Mesh *left,
Mesh *right
);
JScript .NET public static function op_Inequality(
left : Mesh,
right : Mesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Mesh. The Mesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Mesh. The Mesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Mesh.Optimize

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Overload List

public Mesh Optimize(MeshFlags, GraphicsStream);
public Mesh Optimize(MeshFlags, GraphicsStream, out int, out int, out GraphicsStream);
public Mesh Optimize(MeshFlags, int[]);
public Mesh Optimize(MeshFlags, int[], out int, out int, out GraphicsStream);

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic .NET Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
GraphicsStream adjacencyIn
);
Managed C++ public: Mesh* Optimize(
MeshFlags flags,
GraphicsStream *adjacencyIn
);
JScript .NET public function Optimize(
flags : MeshFlags,
adjacencyIn : GraphicsStream
) : Mesh;

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,GraphicsStream,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic .NET Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
GraphicsStream adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: Mesh* Optimize(
MeshFlags flags,
GraphicsStream *adjacencyIn,
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function Optimize(
flags : MeshFlags,
adjacencyIn : GraphicsStream,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut | System.Int32[]. [in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap | System.Int32[]. [in, out] Destination buffer that contains the new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains the new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic .NET Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
int[] adjacencyIn
);
Managed C++ public: Mesh* Optimize(
MeshFlags flags,
int adjacencyIn __gc[]
);
JScript .NET public function Optimize(
flags : MeshFlags,
adjacencyIn : int[]
) : Mesh;

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,Int32[],Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic .NET Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
int[] adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: Mesh* Optimize(
MeshFlags flags,
int adjacencyIn __gc[],
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function Optimize(
flags : MeshFlags,
adjacencyIn : int[],
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut | System.Int32[]. [in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap | System.Int32[]. [in, out] Destination buffer that contains the new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains the new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.OptimizeInPlace

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.OptimizeInPlace Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance.

Overload List

public void OptimizeInPlace(MeshFlags, GraphicsStream);
public void OptimizeInPlace(MeshFlags, GraphicsStream, out int, out int, out GraphicsStream);
public void OptimizeInPlace(MeshFlags, int[]);
public void OptimizeInPlace(MeshFlags, int[], out int, out int, out GraphicsStream);

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.OptimizeInPlace Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic .NET Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream _
)
C# public void OptimizeInPlace(
MeshFlags flags,
GraphicsStream adjacencyIn
);
Managed C++ public: void OptimizeInPlace(
MeshFlags flags,
GraphicsStream *adjacencyIn
);
JScript .NET public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : GraphicsStream
);

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.OptimizeInPlace Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic .NET Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer _
)
C# public void OptimizeInPlace(
MeshFlags flags,
int[] adjacencyIn
);
Managed C++ public: void OptimizeInPlace(
MeshFlags flags,
int adjacencyIn __gc[]
);
JScript .NET public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : int[]
);

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,GraphicsStream,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.OptimizeInPlace Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic .NET Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void OptimizeInPlace(
MeshFlags flags,
GraphicsStream adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: void OptimizeInPlace(
MeshFlags flags,
GraphicsStream *adjacencyIn,
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : GraphicsStream,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut | System.Int32[]. [in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap | System.Int32[]. [in, out] Destination buffer that contains the new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains the new index for each vertex.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,Int32[],Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.OptimizeInPlace Method

 Language:
Note: This documentation is preliminary and is subject to change.

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic .NET Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void OptimizeInPlace(
MeshFlags flags,
int[] adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: void OptimizeInPlace(
MeshFlags flags,
int adjacencyIn __gc[],
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : int[],
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut | System.Int32[]. [in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap | System.Int32[]. [in, out] Destination buffer that contains the new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains the new index for each vertex.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.Polygon

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Polygon Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.

Overload List

public static Mesh Polygon(Device, float, int);
public static Mesh Polygon(Device, float, int, out GraphicsStream);

Remarks

The created polygon is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Cylinder
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Polygon(Device,Single,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Polygon Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.

Definition

Visual Basic .NET Public Shared Function Polygon( _
ByVal device As Device, _
ByVal length As Single, _
ByVal sides As Integer _
) As Mesh
C# public static Mesh Polygon(
Device device,
float length,
int sides
);
Managed C++ public: static Mesh* Polygon(
Device *device,
float length,
int sides
);
JScript .NET public static function Polygon(
device : Device,
length : float,
sides : int
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created polygon mesh.
length | System.Single. Length of each side.
sides | System.Int32. Number of sides for the polygon; must be greater than or equal to 3.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the polygon mesh.

Remarks

The created polygon is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Cylinder
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Polygon(Device,Single,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Polygon Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.

Definition

Visual Basic .NET Public Shared Function Polygon( _
ByVal device As Device, _
ByVal length As Single, _
ByVal sides As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Polygon(
Device device,
float length,
int sides,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* Polygon(
Device *device,
float length,
int sides,
GraphicsStream **adjacency
);
JScript .NET public static function Polygon(
device : Device,
length : float,
sides : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created polygon mesh.
length | System.Single. Length of each side.
sides | System.Int32. Number of sides for the polygon; must be greater than or equal to 3.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the polygon mesh.

Remarks

The created polygon is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Cylinder
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Mesh.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Mesh.Save

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Overload List

public void Save(Stream, GraphicsStream, ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(Stream, GraphicsStream, ExtendedMaterial[], XFileFormat);
public void Save(Stream, int[], ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(Stream, int[], ExtendedMaterial[], XFileFormat);
public void Save(string, GraphicsStream, ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(string, GraphicsStream, ExtendedMaterial[], XFileFormat);
public void Save(string, int[], ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(string, int[], ExtendedMaterial[], XFileFormat);

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,GraphicsStream,ExtendedMaterial[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal filename As String, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
Managed C++ public: void Save(
String *filename,
GraphicsStream *adjacency,
ExtendedMaterial materials __gc[],
XFileFormat format
);
JScript .NET public function Save(
filename : String,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

filename | System.String. String that specifies the file name.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,GraphicsStream,ExtendedMaterial[],EffectInstance[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal filename As String, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
Managed C++ public: void Save(
String *filename,
GraphicsStream *adjacency,
ExtendedMaterial materials __gc[],
EffectInstance effects __gc[],
XFileFormat format
);
JScript .NET public function Save(
filename : String,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

filename | System.String. String that specifies the file name.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,Int32[],ExtendedMaterial[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal filename As String, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
int[] adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
Managed C++ public: void Save(
String *filename,
int adjacency __gc[],
ExtendedMaterial materials __gc[],
XFileFormat format
);
JScript .NET public function Save(
filename : String,
adjacency : int[],
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

filename | System.String. String that specifies the file name.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,Int32[],ExtendedMaterial[],EffectInstance[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal filename As String, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
int[] adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
Managed C++ public: void Save(
String *filename,
int adjacency __gc[],
ExtendedMaterial materials __gc[],
EffectInstance effects __gc[],
XFileFormat format
);
JScript .NET public function Save(
filename : String,
adjacency : int[],
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

filename | System.String. String that specifies the file name.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,GraphicsStream,ExtendedMaterial[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
Managed C++ public: void Save(
Stream *stream,
GraphicsStream *adjacency,
ExtendedMaterial materials __gc[],
XFileFormat format
);
JScript .NET public function Save(
stream : Stream,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

stream | System.IO.Stream. The Stream Leave Site in which to save the .x file.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,GraphicsStream,ExtendedMaterial[],EffectInstance[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
Managed C++ public: void Save(
Stream *stream,
GraphicsStream *adjacency,
ExtendedMaterial materials __gc[],
EffectInstance effects __gc[],
XFileFormat format
);
JScript .NET public function Save(
stream : Stream,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

stream | System.IO.Stream. The Stream Leave Site in which to save the .x file.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,Int32[],ExtendedMaterial[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
int[] adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
Managed C++ public: void Save(
Stream *stream,
int adjacency __gc[],
ExtendedMaterial materials __gc[],
XFileFormat format
);
JScript .NET public function Save(
stream : Stream,
adjacency : int[],
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

stream | System.IO.Stream. The Stream Leave Site in which to save the .x file.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,Int32[],ExtendedMaterial[],EffectInstance[],XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves the mesh to the specified stream object.

Definition

Visual Basic .NET Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
int[] adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
Managed C++ public: void Save(
Stream *stream,
int adjacency __gc[],
ExtendedMaterial materials __gc[],
EffectInstance effects __gc[],
XFileFormat format
);
JScript .NET public function Save(
stream : Stream,
adjacency : int[],
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

stream | System.IO.Stream. The Stream Leave Site in which to save the .x file.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.SaveHierarchyToFile(String,XFileFormat,Frame,AnimationController,SaveUserData)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.SaveHierarchyToFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a DirectX (.x) file and saves the mesh hierarchy and corresponding animations in it.

Definition

Visual Basic .NET Public Shared Sub SaveHierarchyToFile( _
ByVal filename As String, _
ByVal format As XFileFormat, _
ByVal frameRoot As Frame, _
ByVal animationMixer As AnimationController, _
ByVal saveUserData As SaveUserData _
)
C# public static void SaveHierarchyToFile(
string filename,
XFileFormat format,
Frame frameRoot,
AnimationController animationMixer,
SaveUserData saveUserData
);
Managed C++ public: static void SaveHierarchyToFile(
String *filename,
XFileFormat format,
Frame *frameRoot,
AnimationController *animationMixer,
SaveUserData *saveUserData
);
JScript .NET public static function SaveHierarchyToFile(
filename : String,
format : XFileFormat,
frameRoot : Frame,
animationMixer : AnimationController,
saveUserData : SaveUserData
);

Parameters

filename | System.String. String that specifies the file name.
format | Microsoft.DirectX.Direct3D.XFileFormat. An XFileFormat that indicates the format to use when saving the .x file. See Remarks.
frameRoot | Microsoft.DirectX.Direct3D.Frame. Root node of the hierarchy to save. For more information, see Frame.
animationMixer | Microsoft.DirectX.Direct3D.AnimationController. An AnimationController whose animation sets will be stored.
saveUserData | Microsoft.DirectX.Direct3D.SaveUserData. Application-provided object that allows saving of user data. For more information, see SaveUserData.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and text Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Mesh.Save


Mesh.SetAttributeTable(AttributeRange[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.SetAttributeTable Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a mesh's attribute table and specifies the number of entries stored in it.

Definition

Visual Basic .NET Public Sub SetAttributeTable( _
ByVal table() As AttributeRange _
)
C# public void SetAttributeTable(
AttributeRange[] table
);
Managed C++ public: void SetAttributeTable(
AttributeRange table __gc[]
);
JScript .NET public function SetAttributeTable(
table : AttributeRange[]
);

Parameters

table Microsoft.DirectX.Direct3D.AttributeRange[]. Array of AttributeRange structures that represent the entries in the mesh attribute table.

Remarks

If an application tracks the information in an attribute table and rearranges the table as a result of changes to attributes or faces, the SetAttributeTable method allows the application to update the attribute tables instead of calling Optimize again.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • UnlockAttributeBuffer
  • LockAttributeBuffer


Mesh.Simplify

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Simplify Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Overload List

public static Mesh Simplify(Mesh, GraphicsStream, AttributeWeights, GraphicsStream, int, MeshFlags);
public static Mesh Simplify(Mesh, GraphicsStream, GraphicsStream, int, MeshFlags);
public static Mesh Simplify(Mesh, int[], AttributeWeights, int, MeshFlags);
public static Mesh Simplify(Mesh, int[], AttributeWeights, float[], int, MeshFlags);
public static Mesh Simplify(Mesh, int[], int, MeshFlags);
public static Mesh Simplify(Mesh, int[], float[], int, MeshFlags);

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Simplify Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic .NET Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
int minValue,
MeshFlags options
);
Managed C++ public: static Mesh* Simplify(
Mesh *mesh,
int adjacency __gc[],
int minValue,
MeshFlags options
);
JScript .NET public static function Simplify(
mesh : Mesh,
adjacency : int[],
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
minValue | System.Int32. Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],Single[],Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Simplify Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic .NET Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
float[] vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: static Mesh* Simplify(
Mesh *mesh,
int adjacency __gc[],
float vertexWeights __gc[],
int minValue,
MeshFlags options
);
JScript .NET public static function Simplify(
mesh : Mesh,
adjacency : int[],
vertexWeights : float[],
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexWeights | System.Single[]. Array of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue | System.Int32. Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],AttributeWeights,Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Simplify Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic .NET Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
Managed C++ public: static Mesh* Simplify(
Mesh *mesh,
int adjacency __gc[],
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
JScript .NET public static function Simplify(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
minValue | System.Int32. Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],AttributeWeights,Single[],Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Simplify Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic .NET Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
float[] vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: static Mesh* Simplify(
Mesh *mesh,
int adjacency __gc[],
AttributeWeights vertexAttributeWeights,
float vertexWeights __gc[],
int minValue,
MeshFlags options
);
JScript .NET public static function Simplify(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : float[],
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights | System.Single[]. Array of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue | System.Int32. Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,GraphicsStream,GraphicsStream,Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Simplify Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic .NET Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: static Mesh* Simplify(
Mesh *mesh,
GraphicsStream *adjacency,
GraphicsStream *vertexWeights,
int minValue,
MeshFlags options
);
JScript .NET public static function Simplify(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | Microsoft.DirectX.GraphicsStream. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue | System.Int32. Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,GraphicsStream,AttributeWeights,GraphicsStream,Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Simplify Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic .NET Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: static Mesh* Simplify(
Mesh *mesh,
GraphicsStream *adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream *vertexWeights,
int minValue,
MeshFlags options
);
JScript .NET public static function Simplify(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | Microsoft.DirectX.GraphicsStream. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue | System.Int32. Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Sphere

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Sphere Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a sphere.

Overload List

public static Mesh Sphere(Device, float, int, int);
public static Mesh Sphere(Device, float, int, int, out GraphicsStream);

Remarks

The created sphere is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Sphere(Device,Single,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Sphere Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a sphere.

Definition

Visual Basic .NET Public Shared Function Sphere( _
ByVal device As Device, _
ByVal radius As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer _
) As Mesh
C# public static Mesh Sphere(
Device device,
float radius,
int slices,
int stacks
);
Managed C++ public: static Mesh* Sphere(
Device *device,
float radius,
int slices,
int stacks
);
JScript .NET public static function Sphere(
device : Device,
radius : float,
slices : int,
stacks : int
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created sphere mesh.
radius | System.Single. Radius of the sphere. This value should be greater than or equal to 0.0f.
slices | System.Int32. Number of slices around the main axis.
stacks | System.Int32. Number of stacks along the main axis.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the sphere mesh.

Remarks

The created sphere is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Sphere(Device,Single,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Sphere Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a sphere.

Definition

Visual Basic .NET Public Shared Function Sphere( _
ByVal device As Device, _
ByVal radius As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Sphere(
Device device,
float radius,
int slices,
int stacks,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* Sphere(
Device *device,
float radius,
int slices,
int stacks,
GraphicsStream **adjacency
);
JScript .NET public static function Sphere(
device : Device,
radius : float,
slices : int,
stacks : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created sphere mesh.
radius | System.Single. Radius of the sphere. This value should be greater than or equal to 0.0f.
slices | System.Int32. Number of slices around the main axis.
stacks | System.Int32. Number of stacks along the main axis.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the sphere mesh.

Remarks

The created sphere is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Split

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Split Method

 Language:
Note: This documentation is preliminary and is subject to change.

Splits a mesh into multiple meshes that are smaller than the specified size.

Overload List

public static Mesh[] Split(Mesh, int[], int, MeshFlags);
public static Mesh[] Split(Mesh, int[], int, MeshFlags, out GraphicsStream, out GraphicsStream, out GraphicsStream);

Remarks

This method is commonly used to split a mesh with 32-bit indices (more than 65,535 vertices) into multiple meshes, each of which has 16-bit indices.

The param_GraphicsStreamR_adjacencyArrayOut, param_GraphicsStreamR_vertRemapArrayOut, and param_GraphicsStreamR_faceRemapArrayOut arrays have two dimensions. The first dimension specifies the mesh, and the second specifies the data. For example, to obtain the face remap information for face 3 in mesh 2, the following C# code could be used, assuming the face remap data is returned in a variable named faceRemapArrayOut.

[C#]
int remap = FaceRemapArrayOut[2][3];

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Split(Mesh,Int32[],Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Split Method

 Language:
Note: This documentation is preliminary and is subject to change.

Splits a mesh into multiple meshes that are smaller than the specified size.

Definition

Visual Basic .NET Public Shared Function Split( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal maxSize As Integer, _
ByVal options As MeshFlags _
) As Mesh()
C# public static Mesh[] Split(
Mesh mesh,
int[] adjacencyIn,
int maxSize,
MeshFlags options
);
Managed C++ public: static Mesh* Split(
Mesh *mesh,
int adjacencyIn __gc[],
int maxSize,
MeshFlags options
) __gc[];
JScript .NET public static function Split(
mesh : Mesh,
adjacencyIn : int[],
maxSize : int,
options : MeshFlags
) : Mesh[];

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
maxSize | System.Int32. Maximum number of vertices in the resulting mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more of the Option* MeshFlags for the new meshes.

Return Value

Microsoft.DirectX.Direct3D.Mesh[]. Array of Mesh objects for the new meshes. For a source mesh split into n meshes, the ret_MeshA value is an array of n Mesh objects.

Remarks

This method is commonly used to split a mesh with 32-bit indices (more than 65,535 vertices) into multiple meshes, each of which has 16-bit indices.

The param_GraphicsStreamR_adjacencyArrayOut, param_GraphicsStreamR_vertRemapArrayOut, and param_GraphicsStreamR_faceRemapArrayOut arrays have two dimensions. The first dimension specifies the mesh, and the second specifies the data. For example, to obtain the face remap information for face 3 in mesh 2, the following C# code could be used, assuming the face remap data is returned in a variable named faceRemapArrayOut.

[C#]
int remap = FaceRemapArrayOut[2][3];

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Split(Mesh,Int32[],Int32,MeshFlags,GraphicsStream,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Split Method

 Language:
Note: This documentation is preliminary and is subject to change.

Splits a mesh into multiple meshes that are smaller than the specified size.

Definition

Visual Basic .NET Public Shared Function Split( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal maxSize As Integer, _
ByVal options As MeshFlags, _
ByRef adjacencyArrayOut As GraphicsStream, _
ByRef faceRemapArrayOut As GraphicsStream, _
ByRef vertRemapArrayOut As GraphicsStream _
) As Mesh()
C# public static Mesh[] Split(
Mesh mesh,
int[] adjacencyIn,
int maxSize,
MeshFlags options,
out GraphicsStream adjacencyArrayOut,
out GraphicsStream faceRemapArrayOut,
out GraphicsStream vertRemapArrayOut
);
Managed C++ public: static Mesh* Split(
Mesh *mesh,
int adjacencyIn __gc[],
int maxSize,
MeshFlags options,
GraphicsStream **adjacencyArrayOut,
GraphicsStream **faceRemapArrayOut,
GraphicsStream **vertRemapArrayOut
) __gc[];
JScript .NET public static function Split(
mesh : Mesh,
adjacencyIn : int[],
maxSize : int,
options : MeshFlags,
adjacencyArrayOut : GraphicsStream,
faceRemapArrayOut : GraphicsStream,
vertRemapArrayOut : GraphicsStream
) : Mesh[];

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
maxSize | System.Int32. Maximum number of vertices in the resulting mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more of the Option* MeshFlags for the new meshes.
adjacencyArrayOut | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains adjacency arrays (Int32 Leave Site values) for the new meshes.
faceRemapArrayOut | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains an array of face remap arrays (Int32 Leave Site values) for the new meshes.
vertRemapArrayOut | Microsoft.DirectX.GraphicsStream. A GraphicsStream that contains an array of vertex remap arrays for the new meshes.

Return Value

Microsoft.DirectX.Direct3D.Mesh[]. Array of Mesh objects for the new meshes. For a source mesh split into n meshes, the ret_MeshA value is an array of n Mesh objects.

Remarks

This method is commonly used to split a mesh with 32-bit indices (more than 65,535 vertices) into multiple meshes, each of which has 16-bit indices.

The param_GraphicsStreamR_adjacencyArrayOut, param_GraphicsStreamR_vertRemapArrayOut, and param_GraphicsStreamR_faceRemapArrayOut arrays have two dimensions. The first dimension specifies the mesh, and the second specifies the data. For example, to obtain the face remap information for face 3 in mesh 2, the following C# code could be used, assuming the face remap data is returned in a variable named faceRemapArrayOut.

[C#]
int remap = FaceRemapArrayOut[2][3];

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Teapot

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Teapot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a teapot.

Overload List

public static Mesh Teapot(Device);
public static Mesh Teapot(Device, out GraphicsStream);

Remarks

The created mesh is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus


Mesh.Teapot(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Teapot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a teapot.

Definition

Visual Basic .NET Public Shared Function Teapot( _
ByVal device As Device _
) As Mesh
C# public static Mesh Teapot(
Device device
);
Managed C++ public: static Mesh* Teapot(
Device *device
);
JScript .NET public static function Teapot(
device : Device
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created teapot mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the teapot mesh.

Remarks

The created mesh is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus


Mesh.Teapot(Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Teapot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a teapot.

Definition

Visual Basic .NET Public Shared Function Teapot( _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Teapot(
Device device,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* Teapot(
Device *device,
GraphicsStream **adjacency
);
JScript .NET public static function Teapot(
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the created teapot mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing an array filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the teapot mesh.

Remarks

The created mesh is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus


Mesh.TessellateNPatches

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TessellateNPatches Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tessellates the given mesh using the N-patch tessellation scheme.

Overload List

public static Mesh TessellateNPatches(Mesh, GraphicsStream, float, bool);
public static Mesh TessellateNPatches(Mesh, GraphicsStream, float, bool, out GraphicsStream);
public static Mesh TessellateNPatches(Mesh, int[], float, bool);
public static Mesh TessellateNPatches(Mesh, int[], float, bool, out GraphicsStream);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,GraphicsStream,Single,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TessellateNPatches Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic .NET Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn As GraphicsStream, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
GraphicsStream adjacencyIn,
float numSegs,
bool quadraticInterpNormals
);
Managed C++ public: static Mesh* TessellateNPatches(
Mesh *mesh,
GraphicsStream *adjacencyIn,
float numSegs,
bool quadraticInterpNormals
);
JScript .NET public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : GraphicsStream,
numSegs : float,
quadraticInterpNormals : boolean
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to tessellate.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs | System.Single. Number of segments per edge to tessellate.
quadraticInterpNormals | System.Boolean. Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,GraphicsStream,Single,Boolean,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TessellateNPatches Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic .NET Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn As GraphicsStream, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean, _
ByRef adjacencyOut As GraphicsStream _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
GraphicsStream adjacencyIn,
float numSegs,
bool quadraticInterpNormals,
out GraphicsStream adjacencyOut
);
Managed C++ public: static Mesh* TessellateNPatches(
Mesh *mesh,
GraphicsStream *adjacencyIn,
float numSegs,
bool quadraticInterpNormals,
GraphicsStream **adjacencyOut
);
JScript .NET public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : GraphicsStream,
numSegs : float,
quadraticInterpNormals : boolean,
adjacencyOut : GraphicsStream
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to tessellate.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs | System.Single. Number of segments per edge to tessellate.
quadraticInterpNormals | System.Boolean. Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.
adjacencyOut | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,Int32[],Single,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TessellateNPatches Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic .NET Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
int[] adjacencyIn,
float numSegs,
bool quadraticInterpNormals
);
Managed C++ public: static Mesh* TessellateNPatches(
Mesh *mesh,
int adjacencyIn __gc[],
float numSegs,
bool quadraticInterpNormals
);
JScript .NET public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : int[],
numSegs : float,
quadraticInterpNormals : boolean
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to tessellate.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs | System.Single. Number of segments per edge to tessellate.
quadraticInterpNormals | System.Boolean. Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,Int32[],Single,Boolean,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TessellateNPatches Method

 Language:
Note: This documentation is preliminary and is subject to change.

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic .NET Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean, _
ByRef adjacencyOut As GraphicsStream _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
int[] adjacencyIn,
float numSegs,
bool quadraticInterpNormals,
out GraphicsStream adjacencyOut
);
Managed C++ public: static Mesh* TessellateNPatches(
Mesh *mesh,
int adjacencyIn __gc[],
float numSegs,
bool quadraticInterpNormals,
GraphicsStream **adjacencyOut
);
JScript .NET public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : int[],
numSegs : float,
quadraticInterpNormals : boolean,
adjacencyOut : GraphicsStream
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to tessellate.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs | System.Single. Number of segments per edge to tessellate.
quadraticInterpNormals | System.Boolean. Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.
adjacencyOut | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.TextFromFont

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TextFromFont Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh that contains the specified text, using a .NET font object.

Overload List

public static Mesh TextFromFont(Device, Font, string, float, float);
public static Mesh TextFromFont(Device, Font, string, float, float, out GlyphMetricsFloat);
public static Mesh TextFromFont(Device, Font, string, float, float, out GraphicsStream);
public static Mesh TextFromFont(Device, Font, string, float, float, out GraphicsStream, out GlyphMetricsFloat);

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TextFromFont Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic .NET Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion
);
Managed C++ public: static Mesh* TextFromFont(
Device *device,
Font *font,
String *text,
float deviation,
float extrusion
);
JScript .NET public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the text mesh.
font | System.Drawing.Font. A Font Leave Site object that creates the mesh.
text | System.String. String that specifies the text to generate.
deviation | System.Single. Maximum chordal deviation from font outlines.
extrusion | System.Single. Amount to extrude text in the negative z-direction.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single,GlyphMetricsFloat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TextFromFont Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic .NET Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single, _
ByRef glyphMetrics As GlyphMetricsFloat _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion,
out GlyphMetricsFloat glyphMetrics
);
Managed C++ public: static Mesh* TextFromFont(
Device *device,
Font *font,
String *text,
float deviation,
float extrusion,
GlyphMetricsFloat *glyphMetrics
);
JScript .NET public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float,
glyphMetrics : GlyphMetricsFloat
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the text mesh.
font | System.Drawing.Font. A Font Leave Site object that creates the mesh.
text | System.String. String that specifies the text to generate.
deviation | System.Single. Maximum chordal deviation from font outlines.
extrusion | System.Single. Amount to extrude text in the negative z-direction.
glyphMetrics | Microsoft.DirectX.Direct3D.GlyphMetricsFloat[]. Array of GlyphMetricsFloat structures that contain the glyph metric data. See Remarks. If glyph sizes are not a concern, this parameter can be omitted.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TextFromFont Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic .NET Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* TextFromFont(
Device *device,
Font *font,
String *text,
float deviation,
float extrusion,
GraphicsStream **adjacency
);
JScript .NET public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float,
adjacency : GraphicsStream
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the text mesh.
font | System.Drawing.Font. A Font Leave Site object that creates the mesh.
text | System.String. String that specifies the text to generate.
deviation | System.Single. Maximum chordal deviation from font outlines.
extrusion | System.Single. Amount to extrude text in the negative z-direction.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single,GraphicsStream,GlyphMetricsFloat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.TextFromFont Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic .NET Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single, _
ByRef adjacency As GraphicsStream, _
ByRef glyphMetrics As GlyphMetricsFloat _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion,
out GraphicsStream adjacency,
out GlyphMetricsFloat glyphMetrics
);
Managed C++ public: static Mesh* TextFromFont(
Device *device,
Font *font,
String *text,
float deviation,
float extrusion,
GraphicsStream **adjacency,
GlyphMetricsFloat *glyphMetrics
);
JScript .NET public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float,
adjacency : GraphicsStream,
glyphMetrics : GlyphMetricsFloat
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the text mesh.
font | System.Drawing.Font. A Font Leave Site object that creates the mesh.
text | System.String. String that specifies the text to generate.
deviation | System.Single. Maximum chordal deviation from font outlines.
extrusion | System.Single. Amount to extrude text in the negative z-direction.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
glyphMetrics | Microsoft.DirectX.Direct3D.GlyphMetricsFloat[]. Array of GlyphMetricsFloat structures that contain the glyph metric data. See Remarks. If glyph sizes are not a concern, this parameter can be omitted.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.Torus

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Torus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a torus.

Overload List

public static Mesh Torus(Device, float, float, int, int);
public static Mesh Torus(Device, float, float, int, int, out GraphicsStream);

Remarks

The Mesh.Torus method draws a doughnut shape, centered at (0, 0, 0), whose axis is aligned with the z-axis. The inner radius of the torus is the radius of the cross section (the minor radius), and the outer radius of the torus is the radius of the central hole.

The mesh that this method returns can later be used by the application for drawing or manipulation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont


Mesh.Torus(Device,Single,Single,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Torus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a torus.

Definition

Visual Basic .NET Public Shared Function Torus( _
ByVal device As Device, _
ByVal innerRadius As Single, _
ByVal outerRadius As Single, _
ByVal sides As Integer, _
ByVal rings As Integer _
) As Mesh
C# public static Mesh Torus(
Device device,
float innerRadius,
float outerRadius,
int sides,
int rings
);
Managed C++ public: static Mesh* Torus(
Device *device,
float innerRadius,
float outerRadius,
int sides,
int rings
);
JScript .NET public static function Torus(
device : Device,
innerRadius : float,
outerRadius : float,
sides : int,
rings : int
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the text mesh.
innerRadius | System.Single. Inner radius of the torus; should be greater than or equal to 0.0f.
outerRadius | System.Single. Outer radius of the torus; should be greater than or equal to 0.0f.
sides | System.Int32. Number of sides in a cross section; must be greater than or equal to 3.
rings | System.Int32. Number of rings in the torus; must be greater than or equal to 3.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the torus mesh.

Remarks

The Mesh.Torus method draws a doughnut shape, centered at (0, 0, 0), whose axis is aligned with the z-axis. The inner radius of the torus is the radius of the cross section (the minor radius), and the outer radius of the torus is the radius of the central hole.

The mesh that this method returns can later be used by the application for drawing or manipulation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont


Mesh.Torus(Device,Single,Single,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Torus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses a left-handed coordinate system to create a mesh that contains a torus.

Definition

Visual Basic .NET Public Shared Function Torus( _
ByVal device As Device, _
ByVal innerRadius As Single, _
ByVal outerRadius As Single, _
ByVal sides As Integer, _
ByVal rings As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Torus(
Device device,
float innerRadius,
float outerRadius,
int sides,
int rings,
out GraphicsStream adjacency
);
Managed C++ public: static Mesh* Torus(
Device *device,
float innerRadius,
float outerRadius,
int sides,
int rings,
GraphicsStream **adjacency
);
JScript .NET public static function Torus(
device : Device,
innerRadius : float,
outerRadius : float,
sides : int,
rings : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device associated with the text mesh.
innerRadius | System.Single. Inner radius of the torus; should be greater than or equal to 0.0f.
outerRadius | System.Single. Outer radius of the torus; should be greater than or equal to 0.0f.
sides | System.Int32. Number of sides in a cross section; must be greater than or equal to 3.
rings | System.Int32. Number of rings in the torus; must be greater than or equal to 3.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the torus mesh.

Remarks

The Mesh.Torus method draws a doughnut shape, centered at (0, 0, 0), whose axis is aligned with the z-axis. The inner radius of the torus is the radius of the cross section (the minor radius), and the outer radius of the torus is the radius of the central hole.

The mesh that this method returns can later be used by the application for drawing or manipulation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont


Mesh.UnlockAttributeBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.UnlockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks an attribute buffer.

Overload List

public void UnlockAttributeBuffer();
public void UnlockAttributeBuffer(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
ArgumentException Leave Site | The buffer must be locked before it is unlocked.

See Also

  • SetAttributeTable
  • LockAttributeBuffer


Mesh.UnlockAttributeBuffer()

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.UnlockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks an attribute buffer.

Definition

Visual Basic .NET | Public Sub UnlockAttributeBuffer()
C# | public void UnlockAttributeBuffer();
Managed C++ | public: void UnlockAttributeBuffer();
JScript .NET | public function UnlockAttributeBuffer();

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
ArgumentException Leave Site | The buffer must be locked before it is unlocked.

See Also

  • SetAttributeTable
  • LockAttributeBuffer


Mesh.UnlockAttributeBuffer(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.UnlockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks an attribute buffer.

Definition

Visual Basic .NET Public Sub UnlockAttributeBuffer( _
ByVal dataAttribute() As Integer _
)
C# public void UnlockAttributeBuffer(
int[] dataAttribute
);
Managed C++ public: void UnlockAttributeBuffer(
int dataAttribute __gc[]
);
JScript .NET public function UnlockAttributeBuffer(
dataAttribute : int[]
);

Parameters

dataAttribute System.Int32[]. Array of pointers that represents the attribute buffer to unlock.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
ArgumentException Leave Site | The buffer must be locked before it is unlocked.

See Also

  • SetAttributeTable
  • LockAttributeBuffer


Mesh.UpdateUnmanagedPointer(ID3DXMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Mesh object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXMesh pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXMesh pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXMesh. Pointer to the ID3DXMesh structure used to update the unmanaged pointer for this Mesh object.


Mesh.Validate

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a mesh.

Overload List

public void Validate(GraphicsStream);
public void Validate(GraphicsStream, out string);
public void Validate(int[]);
public void Validate(int[], out string);

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Validate(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a mesh.

Definition

Visual Basic .NET Public Sub Validate( _
ByVal adjacency() As Integer _
)
C# public void Validate(
int[] adjacency
);
Managed C++ public: void Validate(
int adjacency __gc[]
);
JScript .NET public function Validate(
adjacency : int[]
);

Parameters

adjacency System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Validate(Int32[],String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a mesh.

Definition

Visual Basic .NET Public Sub Validate( _
ByVal adjacency() As Integer, _
ByRef errorsAndWarnings As String _
)
C# public void Validate(
int[] adjacency,
out string errorsAndWarnings
);
Managed C++ public: void Validate(
int adjacency __gc[],
String **errorsAndWarnings
);
JScript .NET public function Validate(
adjacency : int[],
errorsAndWarnings : String
);

Parameters

adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.
errorsAndWarnings | System.String. Returns a buffer that contains a string of errors and warnings, which explain the problems found in the mesh.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Validate(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a mesh.

Definition

Visual Basic .NET Public Sub Validate( _
ByVal adjacency As GraphicsStream _
)
C# public void Validate(
GraphicsStream adjacency
);
Managed C++ public: void Validate(
GraphicsStream *adjacency
);
JScript .NET public function Validate(
adjacency : GraphicsStream
);

Parameters

adjacency Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Validate(GraphicsStream,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a mesh.

Definition

Visual Basic .NET Public Sub Validate( _
ByVal adjacency As GraphicsStream, _
ByRef errorsAndWarnings As String _
)
C# public void Validate(
GraphicsStream adjacency,
out string errorsAndWarnings
);
Managed C++ public: void Validate(
GraphicsStream *adjacency,
String **errorsAndWarnings
);
JScript .NET public function Validate(
adjacency : GraphicsStream,
errorsAndWarnings : String
);

Parameters

adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.
errorsAndWarnings | System.String. Returns a buffer that contains a string of errors and warnings, which explain the problems found in the mesh.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.WeldVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.WeldVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Welds together replicated vertices that have equal attributes.

Overload List

public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, GraphicsStream, out GraphicsStream);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, GraphicsStream, out GraphicsStream, out int, out GraphicsStream);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, int[]);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, int[], out GraphicsStream);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, int[], out int, out int, out GraphicsStream);

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,Int32[],GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.WeldVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic .NET Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn() As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int[] adjacencyIn,
out GraphicsStream vertexRemap
);
Managed C++ public: void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int adjacencyIn __gc[],
GraphicsStream **vertexRemap
);
JScript .NET public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : int[],
vertexRemap : GraphicsStream
);

Parameters

flags | Microsoft.DirectX.Direct3D.WeldEpsilonsFlags. One or more flags from WeldEpsilonsFlags.
epsilons | Microsoft.DirectX.Direct3D.WeldEpsilons. A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the new index for each vertex.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.WeldVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic .NET Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn() As Integer _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int[] adjacencyIn
);
Managed C++ public: void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int adjacencyIn __gc[]
);
JScript .NET public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : int[]
);

Parameters

flags | Microsoft.DirectX.Direct3D.WeldEpsilonsFlags. One or more flags from WeldEpsilonsFlags.
epsilons | Microsoft.DirectX.Direct3D.WeldEpsilons. A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,Int32[],Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.WeldVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic .NET Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int[] adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int adjacencyIn __gc[],
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : int[],
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags | Microsoft.DirectX.Direct3D.WeldEpsilonsFlags. One or more flags from WeldEpsilonsFlags.
epsilons | Microsoft.DirectX.Direct3D.WeldEpsilons. A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
adjacencyOut | System.Int32[]. [in, out] Face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap | System.Int32[]. Array that contains the new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the new index for each vertex.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.WeldVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic .NET Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream adjacencyIn,
out GraphicsStream adjacencyOut
);
Managed C++ public: void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream *adjacencyIn,
GraphicsStream *adjacencyOut
);
JScript .NET public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : GraphicsStream,
adjacencyOut : GraphicsStream
);

Parameters

flags | Microsoft.DirectX.Direct3D.WeldEpsilonsFlags. One or more flags from WeldEpsilonsFlags.
epsilons | Microsoft.DirectX.Direct3D.WeldEpsilons. A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
adjacencyOut | Microsoft.DirectX.GraphicsStream. [in, out] A GraphicsStream that contains the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outer array is one set of face adjacencies per triangle in the mesh.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,GraphicsStream,GraphicsStream,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.WeldVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic .NET Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream adjacencyIn,
out GraphicsStream adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream *adjacencyIn,
GraphicsStream *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : GraphicsStream,
adjacencyOut : GraphicsStream,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags | Microsoft.DirectX.Direct3D.WeldEpsilonsFlags. One or more flags from WeldEpsilonsFlags.
epsilons | Microsoft.DirectX.Direct3D.WeldEpsilons. A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
adjacencyOut | Microsoft.DirectX.GraphicsStream. [in, out] A GraphicsStream that contains the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outer array is one set of face adjacencies per triangle in the mesh.
faceRemap | System.Int32[]. Array that contains the new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the new index for each vertex.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


Mesh.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Mesh.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXMesh interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXMesh
C# | public ID3DXMesh UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXMesh get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXMesh . Unmanaged ID3DXMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Mesh.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Mesh.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Mesh object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Mesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Mesh object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.MeshContainer

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates a mesh object in a transformation frame hierarchy.

Definition

Visual Basic .NET MustInherit Public Class MeshContainer
Inherits Object
C# | public abstract class MeshContainer : Object
Managed C++ | public __gc __abstract class MeshContainer : public Object
JScript .NET | public abstract class MeshContainer extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Finalize | Allows the MeshContainer object to free resources before it is destroyed by the garbage collector.
GetAdjacency | Retrieves an array that contains the mesh adjacency information.
GetAdjacencyStream | Retrieves a GraphicsStream object that contains the mesh adjacency information.
GetEffectInstances | Retrieves an array of EffectInstance objects that contain the effects for the mesh.
GetMaterials | Retrieves an array of mesh materials.
MeshContainer | Initializes a new instance of the MeshContainer class.
SetAdjacency | Sets the mesh adjacency information.
SetEffectInstances | Sets an array of EffectInstance objects that contain the effects for the mesh.
SetMaterials | Sets an array of mesh materials.

Properties

Property | Description
MeshData | Retrieves or sets a MeshData object that contains the type of data in the mesh.
Name | Retrieves or sets the mesh name.
NextContainer | Retrieves the next mesh container.
SkinInformation | Retrieves or sets a SkinInformation object that contains information about animating bones in a skin mesh.

Inheritance Hierarchy

Object Leave Site
MeshContainer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MeshContainer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the MeshContainer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~MeshContainer();
Managed C++ | ~MeshContainer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


MeshContainer.GetAdjacency()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.GetAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array that contains the mesh adjacency information.

Definition

Visual Basic .NET | Public Function GetAdjacency() As Integer()
C# | public int[] GetAdjacency();
Managed C++ | public: int GetAdjacency() __gc[];
JScript .NET | public function GetAdjacency() : int[];

Return Value

System.Int32[]. Array of integers that represent the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.


MeshContainer.GetAdjacencyStream()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.GetAdjacencyStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a GraphicsStream object that contains the mesh adjacency information.

Definition

Visual Basic .NET | Public Function GetAdjacencyStream() As GraphicsStream
C# | public GraphicsStream GetAdjacencyStream();
Managed C++ | public: GraphicsStream* GetAdjacencyStream();
JScript .NET | public function GetAdjacencyStream() : GraphicsStream;

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outer array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.


MeshContainer.GetEffectInstances()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.GetEffectInstances Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of EffectInstance objects that contain the effects for the mesh.

Definition

Visual Basic .NET | Public Function GetEffectInstances() As EffectInstance()
C# | public EffectInstance[] GetEffectInstances();
Managed C++ | public: EffectInstance GetEffectInstances() __gc[];
JScript .NET | public function GetEffectInstances() : EffectInstance[];

Return Value

Microsoft.DirectX.Direct3D.EffectInstance[]. Returns an array of EffectInstance objects.


MeshContainer.GetMaterials()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.GetMaterials Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of mesh materials.

Definition

Visual Basic .NET | Public Function GetMaterials() As ExtendedMaterial()
C# | public ExtendedMaterial[] GetMaterials();
Managed C++ | public: ExtendedMaterial GetMaterials() __gc[];
JScript .NET | public function GetMaterials() : ExtendedMaterial[];

Return Value

Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial objects that contain the mesh materials.


MeshContainer.MeshContainer()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.MeshContainer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MeshContainer class.

Definition

Visual Basic .NET | Public Sub New()
C# | public MeshContainer();
Managed C++ | public: MeshContainer();
JScript .NET | public function MeshContainer();


MeshContainer.SetAdjacency

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.SetAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the mesh adjacency information.

Overload List

public void SetAdjacency(GraphicsStream);
public void SetAdjacency(int[]);

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.

Exceptions
OutOfMemoryException Leave Site Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


MeshContainer.SetAdjacency(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.SetAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the mesh adjacency information.

Definition

Visual Basic .NET Public Sub SetAdjacency( _
ByVal adj As GraphicsStream _
)
C# public void SetAdjacency(
GraphicsStream adj
);
Managed C++ public: void SetAdjacency(
GraphicsStream *adj
);
JScript .NET public function SetAdjacency(
adj : GraphicsStream
);

Parameters

adj Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.

Exceptions
OutOfMemoryException Leave Site Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


MeshContainer.SetAdjacency(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.SetAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the mesh adjacency information.

Definition

Visual Basic .NET Public Sub SetAdjacency( _
ByVal adj() As Integer _
)
C# public void SetAdjacency(
int[] adj
);
Managed C++ public: void SetAdjacency(
int adj __gc[]
);
JScript .NET public function SetAdjacency(
adj : int[]
);

Parameters

adj System.Int32[]. Array of integers that represent the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.

Exceptions
OutOfMemoryException Leave Site Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


MeshContainer.SetEffectInstances(EffectInstance[])

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.SetEffectInstances Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an array of EffectInstance objects that contain the effects for the mesh.

Definition

Visual Basic .NET Public Sub SetEffectInstances( _
ByVal effects() As EffectInstance _
)
C# public void SetEffectInstances(
EffectInstance[] effects
);
Managed C++ public: void SetEffectInstances(
EffectInstance effects __gc[]
);
JScript .NET public function SetEffectInstances(
effects : EffectInstance[]
);

Parameters

effects Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance objects.


MeshContainer.SetMaterials(ExtendedMaterial[])

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.SetMaterials Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an array of mesh materials.

Definition

Visual Basic .NET Public Sub SetMaterials( _
ByVal mtrl() As ExtendedMaterial _
)
C# public void SetMaterials(
ExtendedMaterial[] mtrl
);
Managed C++ public: void SetMaterials(
ExtendedMaterial mtrl __gc[]
);
JScript .NET public function SetMaterials(
mtrl : ExtendedMaterial[]
);

Parameters

mtrl Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial objects that contain the mesh materials to set.

Remarks

Exceptions
OutOfMemoryException Leave Site Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


MeshContainer.MeshData

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.MeshData Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a MeshData object that contains the type of data in the mesh.

Definition

Visual Basic .NET | Public Property MeshData As MeshData
C# | public MeshData MeshData { get; set; }
Managed C++ public: __property MeshData get_MeshData();
public: __property void set_MeshData(MeshData);
JScript .NET public function get MeshData() : MeshData
public function set MeshData(MeshData);

Property Value

Microsoft.DirectX.Direct3D.MeshData . A MeshData object that represents the type of mesh data.

This property is read/write.


MeshContainer.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the mesh name.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String . String that contains the name of the mesh.

This property is read/write.


MeshContainer.NextContainer

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.NextContainer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the next mesh container.

Definition

Visual Basic .NET | Public ReadOnly Property NextContainer As MeshContainer
C# | public MeshContainer NextContainer { get; }
Managed C++ | public: __property MeshContainer* get_NextContainer();
JScript .NET | public function get NextContainer() : MeshContainer

Property Value

Microsoft.DirectX.Direct3D.MeshContainer . A MeshContainer object to retrieve.

This property is read-only.


MeshContainer.SkinInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshContainer.SkinInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a SkinInformation object that contains information about animating bones in a skin mesh.

Definition

Visual Basic .NET | Public Property SkinInformation As SkinInformation
C# | public SkinInformation SkinInformation { get; set; }
Managed C++ public: __property SkinInformation* get_SkinInformation();
public: __property void set_SkinInformation(SkinInformation*);
JScript .NET public function get SkinInformation() : SkinInformation
public function set SkinInformation(SkinInformation);

Property Value

Microsoft.DirectX.Direct3D.SkinInformation . A SkinInformation object.

This property is read/write.


Microsoft.DirectX.Direct3D.MoreDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException Class

Language:
Note: This documentation is preliminary and is subject to change.

More data is available than the specified buffer size can hold.

Definition

Visual Basic .NET Public Class MoreDataException
Inherits GraphicsException
C# | public class MoreDataException : GraphicsException
Managed C++ | public __gc class MoreDataException : public GraphicsException
JScript .NET | public class MoreDataException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MoreDataException | Initializes a new instance of the MoreDataException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
MoreDataException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MoreDataException.MoreDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MoreDataException class.

Overload List

public MoreDataException();
protected MoreDataException(SerializationInfo, StreamingContext);
public MoreDataException(string);
public MoreDataException(string, Exception);


MoreDataException.MoreDataException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MoreDataException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: MoreDataException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function MoreDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


MoreDataException.MoreDataException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MoreDataException(
string message,
Exception inner
);
Managed C++ public: MoreDataException(
String *message,
Exception *inner
);
JScript .NET public function MoreDataException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


MoreDataException.MoreDataException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public MoreDataException(
string message
);
Managed C++ public: MoreDataException(
String *message
);
JScript .NET public function MoreDataException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


MoreDataException.MoreDataException()

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public MoreDataException();
Managed C++ | public: MoreDataException();
JScript .NET | public function MoreDataException();


Microsoft.DirectX.Direct3D.NotAvailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAvailableException Class

Language:
Note: This documentation is preliminary and is subject to change.

This device does not support the queried technique.

Definition

Visual Basic .NET Public Class NotAvailableException
Inherits GraphicsException
C# | public class NotAvailableException : GraphicsException
Managed C++ | public __gc class NotAvailableException : public GraphicsException
JScript .NET | public class NotAvailableException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAvailableException | Initializes a new instance of the NotAvailableException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotAvailableException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotAvailableException.NotAvailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAvailableException.NotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotAvailableException class.

Overload List

public NotAvailableException();
protected NotAvailableException(SerializationInfo, StreamingContext);
public NotAvailableException(string);
public NotAvailableException(string, Exception);


NotAvailableException.NotAvailableException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAvailableException.NotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAvailableException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotAvailableException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotAvailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


NotAvailableException.NotAvailableException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAvailableException.NotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAvailableException(
string message,
Exception inner
);
Managed C++ public: NotAvailableException(
String *message,
Exception *inner
);
JScript .NET public function NotAvailableException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


NotAvailableException.NotAvailableException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAvailableException.NotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotAvailableException(
string message
);
Managed C++ public: NotAvailableException(
String *message
);
JScript .NET public function NotAvailableException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


NotAvailableException.NotAvailableException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAvailableException.NotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotAvailableException();
Managed C++ | public: NotAvailableException();
JScript .NET | public function NotAvailableException();


Microsoft.DirectX.Direct3D.NotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException Class

Language:
Note: This documentation is preliminary and is subject to change.

The requested item was not found.

Definition

Visual Basic .NET Public Class NotFoundException
Inherits GraphicsException
C# | public class NotFoundException : GraphicsException
Managed C++ | public __gc class NotFoundException : public GraphicsException
JScript .NET | public class NotFoundException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFoundException | Initializes a new instance of the NotFoundException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotFoundException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotFoundException.NotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotFoundException class.

Overload List

public NotFoundException();
protected NotFoundException(SerializationInfo, StreamingContext);
public NotFoundException(string);
public NotFoundException(string, Exception);


NotFoundException.NotFoundException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFoundException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotFoundException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


NotFoundException.NotFoundException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFoundException(
string message,
Exception inner
);
Managed C++ public: NotFoundException(
String *message,
Exception *inner
);
JScript .NET public function NotFoundException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


NotFoundException.NotFoundException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotFoundException(
string message
);
Managed C++ public: NotFoundException(
String *message
);
JScript .NET public function NotFoundException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


NotFoundException.NotFoundException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotFoundException();
Managed C++ | public: NotFoundException();
JScript .NET | public function NotFoundException();


Microsoft.DirectX.Direct3D.OutOfVideoMemoryException

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException Class

Language:
Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® does not have enough display memory to perform the operation.

Definition

Visual Basic .NET Public Class OutOfVideoMemoryException
Inherits GraphicsException
C# | public class OutOfVideoMemoryException : GraphicsException
Managed C++ | public __gc class OutOfVideoMemoryException : public GraphicsException
JScript .NET | public class OutOfVideoMemoryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OutOfVideoMemoryException | Initializes a new instance of the OutOfVideoMemoryException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OutOfVideoMemoryException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OutOfVideoMemoryException.OutOfVideoMemoryException

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OutOfVideoMemoryException class.

Overload List

public OutOfVideoMemoryException();
protected OutOfVideoMemoryException(SerializationInfo, StreamingContext);
public OutOfVideoMemoryException(string);
public OutOfVideoMemoryException(string, Exception);


OutOfVideoMemoryException.OutOfVideoMemoryException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OutOfVideoMemoryException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OutOfVideoMemoryException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OutOfVideoMemoryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


OutOfVideoMemoryException.OutOfVideoMemoryException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OutOfVideoMemoryException(
string message,
Exception inner
);
Managed C++ public: OutOfVideoMemoryException(
String *message,
Exception *inner
);
JScript .NET public function OutOfVideoMemoryException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


OutOfVideoMemoryException.OutOfVideoMemoryException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OutOfVideoMemoryException(
string message
);
Managed C++ public: OutOfVideoMemoryException(
String *message
);
JScript .NET public function OutOfVideoMemoryException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


OutOfVideoMemoryException.OutOfVideoMemoryException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public OutOfVideoMemoryException();
Managed C++ | public: OutOfVideoMemoryException();
JScript .NET | public function OutOfVideoMemoryException();


Microsoft.DirectX.Direct3D.PatchMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh Class

Language:
Note: This documentation is preliminary and is subject to change.

Provides patch mesh functionality.

Definition

Visual Basic .NET NotInheritable Public Class PatchMesh
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class PatchMesh : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class PatchMesh : public MarshalByRefObject,
IDisposable
JScript .NET public class PatchMesh extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PatchMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Creates a new patch mesh with the specified vertex declaration.
static (Shared in Visual Basic .NET) CreateNPatchMesh | Creates an N-patch mesh from a triangle mesh.
Dispose | Immediately releases the unmanaged resources used by the PatchMesh object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the PatchMesh object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FromX | Loads a patch mesh from an XFileData object.
GenerateAdjacency | Generates adjacency information based on mesh indices.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetTessellateSize | Retrieves the size of the tessellated mesh, given a tessellation level.
LockAttributeBuffer | Locks the attribute buffer and obtains its memory.
LockAttributeBufferArray | Locks the attribute buffer and obtains its memory.
LockIndexBuffer | Locks the index buffer.
LockVertexBuffer | Locks the vertex buffer.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Optimize | Optimizes the patch mesh for efficient tessellation.
PatchMesh | Creates a mesh from a control patch mesh.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PatchMesh.Disposing event when called from within a derived class.
SetIndexBufferData | Sets index buffer data.
SetVertexBufferData | Sets vertex buffer data.
Tessellate | Performs uniform tessellation based on the tessellation level.
TessellateAdaptive | Performs adaptive tessellation based on the z-based adaptive tessellation criterion.
UnlockAttributeBuffer | Unlocks the attribute buffer.
UnlockIndexBuffer | Unlocks the index buffer.
UnlockVertexBuffer | Unlocks the vertex buffer.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PatchMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
Validate | Validates a patch mesh.

Properties

Property | Description
ControlVerticesPerPatch | Retrieves the number of control vertices per patch.
Declaration | Retrieves the vertex declaration.
Device | Retrieves the Device that created the mesh.
DisplacementParameter | Retrieves or sets mesh geometry displacement parameters.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the mesh index buffer.
NumberPatches | Retrieves the number of patches in a mesh.
NumberVertices | Retrieves the number of vertices for a mesh.
Options | Retrieves a MeshOptions structure that contains information about the patch mesh.
PatchInformation | Retrieves the attributes of the patch mesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPatchMesh interface pointer.
VertexBuffer | Retrieves the mesh vertex buffer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PatchMesh

Remarks

A patch mesh is a mesh that consists of a series of patches.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PatchMesh.Clone

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new patch mesh with the specified vertex declaration.

Overload List

public PatchMesh Clone(MeshFlags, GraphicsStream);
public PatchMesh Clone(MeshFlags, VertexElement[]);

Remarks

The PatchMesh.Clone method converts the vertex buffer to the new vertex declaration. Entries in the vertex declaration that are new to the original mesh are set to 0. If the current mesh has adjacency, the new mesh will have it also.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Clone(MeshFlags,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new patch mesh with the specified vertex declaration.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal decl As GraphicsStream _
) As PatchMesh
C# public PatchMesh Clone(
MeshFlags options,
GraphicsStream decl
);
Managed C++ public: PatchMesh* Clone(
MeshFlags options,
GraphicsStream *decl
);
JScript .NET public function Clone(
options : MeshFlags,
decl : GraphicsStream
) : PatchMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
decl | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing VertexElement structures that specify the vertex format for the vertices in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh . Cloned patch mesh.

Remarks

The PatchMesh.Clone method converts the vertex buffer to the new vertex declaration. Entries in the vertex declaration that are new to the original mesh are set to 0. If the current mesh has adjacency, the new mesh will have it also.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Clone(MeshFlags,VertexElement[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new patch mesh with the specified vertex declaration.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal decl() As VertexElement _
) As PatchMesh
C# public PatchMesh Clone(
MeshFlags options,
VertexElement[] decl
);
Managed C++ public: PatchMesh* Clone(
MeshFlags options,
VertexElement decl __gc[]
);
JScript .NET public function Clone(
options : MeshFlags,
decl : VertexElement[]
) : PatchMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
decl | Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that specify the vertex format for the vertices in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh . Cloned patch mesh.

Remarks

The PatchMesh.Clone method converts the vertex buffer to the new vertex declaration. Entries in the vertex declaration that are new to the original mesh are set to 0. If the current mesh has adjacency, the new mesh will have it also.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.CreateNPatchMesh(Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.CreateNPatchMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an N-patch mesh from a triangle mesh.

Definition

Visual Basic .NET Public Shared Function CreateNPatchMesh( _
ByVal mesh As Mesh _
) As PatchMesh
C# public static PatchMesh CreateNPatchMesh(
Mesh mesh
);
Managed C++ public: static PatchMesh* CreateNPatchMesh(
Mesh *mesh
);
JScript .NET public static function CreateNPatchMesh(
mesh : Mesh
) : PatchMesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh. A Mesh triangle mesh object to convert to a patch mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh . A PatchMesh object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the PatchMesh object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PatchMesh.Disposed
  • Microsoft.DirectX.Direct3D.PatchMesh.Disposing


PatchMesh.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PatchMesh.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the PatchMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~PatchMesh();
Managed C++ | ~PatchMesh();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


PatchMesh.FromX

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a patch mesh from an XFileData object.

Overload List

public static PatchMesh FromX(XFileData, MeshFlags, Device);
public static PatchMesh FromX(XFileData, MeshFlags, Device, out EffectInstance);
public static PatchMesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial);
public static PatchMesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a patch mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out EffectInstance effects
);
Managed C++ public: static PatchMesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : PatchMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh . Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a patch mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device
);
Managed C++ public: static PatchMesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device
) : PatchMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh . Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a patch mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
Managed C++ public: static PatchMesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
ExtendedMaterial *materials
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : PatchMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh . Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a patch mesh from an XFileData object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static PatchMesh* FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : PatchMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh . Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.GenerateAdjacency(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.GenerateAdjacency Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates adjacency information based on mesh indices.

Definition

Visual Basic .NET Public Sub GenerateAdjacency( _
ByVal tolerance As Single _
)
C# public void GenerateAdjacency(
float tolerance
);
Managed C++ public: void GenerateAdjacency(
float tolerance
);
JScript .NET public function GenerateAdjacency(
tolerance : float
);

Parameters

tolerance System.Single. Specifies that vertices that differ in position by less than the tolerance be treated as coincident.

Remarks

This method determines which patches are adjacent (within the provided tolerance). This information is used internally to optimize tessellation.

Exceptions
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


PatchMesh.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPatchMesh, which allows unmanaged COM clients to create an instance of the managed PatchMesh class. Not supported.


PatchMesh.GetTessellateSize(Single,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.GetTessellateSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the tessellated mesh, given a tessellation level.

Definition

Visual Basic .NET Public Sub GetTessellateSize( _
ByVal tessLevel As Single, _
ByVal adaptive As Integer, _
ByRef numTriangles As Integer, _
ByRef numVertices As Integer _
)
C# public void GetTessellateSize(
float tessLevel,
int adaptive,
out int numTriangles,
out int numVertices
);
Managed C++ public: void GetTessellateSize(
float tessLevel,
int adaptive,
int *numTriangles,
int *numVertices
);
JScript .NET public function GetTessellateSize(
tessLevel : float,
adaptive : int,
numTriangles : int,
numVertices : int
);

Parameters

tessLevel | System.Single. Tessellation level.
adaptive | System.Int32. Value that specifies adaptive tessellation. For adaptive tessellation, set this parameter to -1 and set param_Single_tessLevel to the maximum tessellation value. This results in the maximum mesh size necessary for adaptive tessellation. To specify no tessellation, set this parameter to 0.
numTriangles | System.Int32. Number of triangles generated by the tessellated mesh.
numVertices | System.Int32. Number of vertices generated by the tessellated mesh.

Remarks

This method assumes uniform tessellation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.LockAttributeBuffer(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the attribute buffer and obtains its memory.

Definition

Visual Basic .NET Public Function LockAttributeBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockAttributeBuffer(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockAttributeBuffer(
LockFlags flags
);
JScript .NET public function LockAttributeBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. Valid flags for this method are Discard, NoDirtyUpdate, NoSysLock, and ReadOnly.

Return Value

Microsoft.DirectX.GraphicsStream . Returns the locked buffer as a GraphicsStream object.

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • UnlockAttributeBuffer


PatchMesh.LockAttributeBufferArray(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockAttributeBufferArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the attribute buffer and obtains its memory.

Definition

Visual Basic .NET Public Function LockAttributeBufferArray( _
ByVal flags As LockFlags _
) As Integer()
C# public int[] LockAttributeBufferArray(
LockFlags flags
);
Managed C++ public: int LockAttributeBufferArray(
LockFlags flags
) __gc[];
JScript .NET public function LockAttributeBufferArray(
flags : LockFlags
) : int[];

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. Valid flags for this method are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly.

Return Value

System.Int32[]. Returns the locked buffer in an array.

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • UnlockAttributeBuffer


PatchMesh.LockIndexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the index buffer.

Overload List

public GraphicsStream LockIndexBuffer(LockFlags);
public Array LockIndexBuffer(Type, LockFlags, int[]);

Remarks

The index buffer is usually locked, written to, and then unlocked for reading. Patch mesh index buffers are 16-bit buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PatchMesh.PatchMesh


PatchMesh.LockIndexBuffer(Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the index buffer.

Definition

Visual Basic .NET Public Function LockIndexBuffer( _
ByVal typeIndex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockIndexBuffer(
Type typeIndex,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockIndexBuffer(
Type *typeIndex,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockIndexBuffer(
typeIndex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeIndex | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSysLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked index buffer.

Remarks

The index buffer is usually locked, written to, and then unlocked for reading. Patch mesh index buffers are 16-bit buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PatchMesh.PatchMesh


PatchMesh.LockIndexBuffer(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the index buffer.

Definition

Visual Basic .NET Public Function LockIndexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockIndexBuffer(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockIndexBuffer(
LockFlags flags
);
JScript .NET public function LockIndexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSysLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked index buffer.

Remarks

The index buffer is usually locked, written to, and then unlocked for reading. Patch mesh index buffers are 16-bit buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PatchMesh.PatchMesh


PatchMesh.LockVertexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the vertex buffer.

Overload List

public GraphicsStream LockVertexBuffer(LockFlags);
public Array LockVertexBuffer(Type, LockFlags, int[]);

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Patch meshes use 16-bit index buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.LockVertexBuffer(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the vertex buffer.

Definition

Visual Basic .NET Public Function LockVertexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockVertexBuffer(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockVertexBuffer(
LockFlags flags
);
JScript .NET public function LockVertexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked vertex buffer.

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Patch meshes use 16-bit index buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.LockVertexBuffer(Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.LockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks the vertex buffer.

Definition

Visual Basic .NET Public Function LockVertexBuffer( _
ByVal typeVertex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockVertexBuffer(
Type typeVertex,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockVertexBuffer(
Type *typeVertex,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockVertexBuffer(
typeVertex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeVertex | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked vertex buffer.

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Patch meshes use 16-bit index buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.op_Equality(PatchMesh,PatchMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As PatchMesh, _
ByVal right As PatchMesh _
) As Boolean
C# public static bool op_Equality(
PatchMesh left,
PatchMesh right
);
Managed C++ public: static bool op_Equality(
PatchMesh *left,
PatchMesh *right
);
JScript .NET public static function op_Equality(
left : PatchMesh,
right : PatchMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PatchMesh. The PatchMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PatchMesh. The PatchMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PatchMesh.op_Inequality(PatchMesh,PatchMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As PatchMesh, _
ByVal right As PatchMesh _
) As Boolean
C# public static bool op_Inequality(
PatchMesh left,
PatchMesh right
);
Managed C++ public: static bool op_Inequality(
PatchMesh *left,
PatchMesh *right
);
JScript .NET public static function op_Inequality(
left : PatchMesh,
right : PatchMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PatchMesh. The PatchMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PatchMesh. The PatchMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


PatchMesh.Optimize()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes the patch mesh for efficient tessellation.

Definition

Visual Basic .NET | Public Sub Optimize()
C# | public void Optimize();
Managed C++ | public: void Optimize();
JScript .NET | public function Optimize();

Remarks

The Optimize method performs one-time optimization for patch meshes that need to be tessellated repeatedly (by calling the Tessellate method). The optimization is independent of the actual tessellation level used. If vertices are changed, this method must be called again.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.PatchMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.PatchMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh from a control patch mesh.

Overload List

public PatchMesh(Device, PatchInformation, int, int, VertexElement[]);
public PatchMesh(ID3DXPatchMesh);
public PatchMesh(IntPtr);

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.PatchMesh(ID3DXPatchMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.PatchMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh from a control patch mesh.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXPatchMesh _
)
C# public PatchMesh(
ID3DXPatchMesh pUnk
);
Managed C++ public: PatchMesh(
ID3DXPatchMesh pUnk
);
JScript .NET public function PatchMesh(
pUnk : ID3DXPatchMesh
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPatchMesh. Unmanaged Component Object Model (COM) ID3DXPatchMesh interface pointer.

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.PatchMesh(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.PatchMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh from a control patch mesh.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PatchMesh(
IntPtr unmanagedObject
);
Managed C++ public: PatchMesh(
IntPtr unmanagedObject
);
JScript .NET public function PatchMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXPatchMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.PatchMesh(Device,PatchInformation,Int32,Int32,VertexElement[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.PatchMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a mesh from a control patch mesh.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal information As PatchInformation, _
ByVal numberPatches As Integer, _
ByVal numberVertices As Integer, _
ByVal declaration() As VertexElement _
)
C# public PatchMesh(
Device device,
PatchInformation information,
int numberPatches,
int numberVertices,
VertexElement[] declaration
);
Managed C++ public: PatchMesh(
Device *device,
PatchInformation information,
int numberPatches,
int numberVertices,
VertexElement declaration __gc[]
);
JScript .NET public function PatchMesh(
device : Device,
information : PatchInformation,
numberPatches : int,
numberVertices : int,
declaration : VertexElement[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device to associate with the patch mesh.
information | Microsoft.DirectX.Direct3D.PatchInformation. Patch information structure. For more information, see PatchInformation.
numberPatches | System.Int32. Number of patches.
numberVertices | System.Int32. Number of control vertices in the patch.
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that describe the vertex format for the returned mesh.

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.PatchMesh.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


PatchMesh.SetIndexBufferData(Object,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.SetIndexBufferData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets index buffer data.

Definition

Visual Basic .NET Public Sub SetIndexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetIndexBufferData(
object data,
LockFlags flags
);
Managed C++ public: void SetIndexBufferData(
Object *data,
LockFlags flags
);
JScript .NET public function SetIndexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data | System.Object. An Object Leave Site that contains the data to copy into the index buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetIndexBufferData method locks, sets, and then unlocks the index buffer. A call to UnlockIndexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PatchMesh.SetVertexBufferData(Object,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.SetVertexBufferData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets vertex buffer data.

Definition

Visual Basic .NET Public Sub SetVertexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetVertexBufferData(
object data,
LockFlags flags
);
Managed C++ public: void SetVertexBufferData(
Object *data,
LockFlags flags
);
JScript .NET public function SetVertexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data | System.Object. An Object Leave Site that contains the data to copy into the vertex buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetVertexBufferData method locks, sets, and then unlocks the vertex buffer. A call to UnlockVertexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PatchMesh.Tessellate(Single,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Tessellate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs uniform tessellation based on the tessellation level.

Definition

Visual Basic .NET Public Sub Tessellate( _
ByVal tessLevel As Single, _
ByVal mesh As Mesh _
)
C# public void Tessellate(
float tessLevel,
Mesh mesh
);
Managed C++ public: void Tessellate(
float tessLevel,
Mesh *mesh
);
JScript .NET public function Tessellate(
tessLevel : float,
mesh : Mesh
);

Parameters

tessLevel | System.Single. Tessellation level. This is the number of vertices introduced between existing vertices. The range of this floating-point parameter is between 0 and 32.
mesh | Microsoft.DirectX.Direct3D.Mesh. Resulting tessellated mesh. For more information, see Mesh.

Remarks

This method performs most efficiently if the patch mesh is optimized using PatchMesh.Optimize.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.TessellateAdaptive(Vector4,Int32,Int32,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.TessellateAdaptive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs adaptive tessellation based on the z-based adaptive tessellation criterion.

Definition

Visual Basic .NET Public Sub TessellateAdaptive( _
ByVal trans As Vector4, _
ByVal maxTessellate As Integer, _
ByVal minTessellate As Integer, _
ByVal mesh As Mesh _
)
C# public void TessellateAdaptive(
Vector4 trans,
int maxTessellate,
int minTessellate,
Mesh mesh
);
Managed C++ public: void TessellateAdaptive(
Vector4 trans,
int maxTessellate,
int minTessellate,
Mesh *mesh
);
JScript .NET public function TessellateAdaptive(
trans : Vector4,
maxTessellate : int,
minTessellate : int,
mesh : Mesh
);

Parameters

trans | Microsoft.DirectX.Vector4. Specifies a 4-D vector (Vector4) that is dotted with the vertices to get the per-vertex adaptive tessellation amount. Each edge is tessellated to the average value of the tessellation levels for the two vertices it connects.
maxTessellate | System.Int32. Maximum limit for adaptive tessellation. This is the number of vertices introduced between existing vertices. The range of this integer value is between param_Int32_minTessellate and 32.
minTessellate | System.Int32. Minimum limit for adaptive tessellation. This is the number of vertices introduced between existing vertices. The range of this integer value is between 1 and param_Int32_maxTessellate.
mesh | Microsoft.DirectX.Direct3D.Mesh. Resulting tessellated mesh. For more information, see Mesh.

Remarks

This method performs most efficiently if the patch mesh is optimized using PatchMesh.Optimize.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.UnlockAttributeBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.UnlockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks the attribute buffer.

Overload List

public void UnlockAttributeBuffer();
public void UnlockAttributeBuffer(int[]);

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.UnlockAttributeBuffer()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.UnlockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks the attribute buffer.

Definition

Visual Basic .NET | Public Sub UnlockAttributeBuffer()
C# | public void UnlockAttributeBuffer();
Managed C++ | public: void UnlockAttributeBuffer();
JScript .NET | public function UnlockAttributeBuffer();

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.UnlockAttributeBuffer(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.UnlockAttributeBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks the attribute buffer.

Definition

Visual Basic .NET Public Sub UnlockAttributeBuffer( _
ByVal dataAttribute() As Integer _
)
C# public void UnlockAttributeBuffer(
int[] dataAttribute
);
Managed C++ public: void UnlockAttributeBuffer(
int dataAttribute __gc[]
);
JScript .NET public function UnlockAttributeBuffer(
dataAttribute : int[]
);

Parameters

dataAttribute System.Int32[]. Array of values that contains the attribute buffer to unlock.

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.UnlockIndexBuffer()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.UnlockIndexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks the index buffer.

Definition

Visual Basic .NET | Public Sub UnlockIndexBuffer()
C# | public void UnlockIndexBuffer();
Managed C++ | public: void UnlockIndexBuffer();
JScript .NET | public function UnlockIndexBuffer();

Remarks

The index buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.UnlockVertexBuffer()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.UnlockVertexBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks the vertex buffer.

Definition

Visual Basic .NET | Public Sub UnlockVertexBuffer()
C# | public void UnlockVertexBuffer();
Managed C++ | public: void UnlockVertexBuffer();
JScript .NET | public function UnlockVertexBuffer();

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.UpdateUnmanagedPointer(ID3DXPatchMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this PatchMesh object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPatchMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXPatchMesh pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXPatchMesh pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXPatchMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPatchMesh. Pointer to the ID3DXPatchMesh structure used to update the unmanaged pointer for this PatchMesh object.


PatchMesh.Validate

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a patch mesh.

Overload List

public DegenerateItems Validate();
public DegenerateItems Validate(out string);

Remarks

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Validate()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a patch mesh.

Definition

Visual Basic .NET | Public Function Validate() As DegenerateItems
C# | public DegenerateItems Validate();
Managed C++ | public: DegenerateItems Validate();
JScript .NET | public function Validate() : DegenerateItems;

Return Value

Microsoft.DirectX.Direct3D.DegenerateItems . Returns a DegenerateItems structure that contains the indexes of patches and vertices that caused validation to fail.

Remarks

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Validate(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Validate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Validates a patch mesh.

Definition

Visual Basic .NET Public Function Validate( _
ByRef errorsAndWarnings As String _
) As DegenerateItems
C# public DegenerateItems Validate(
out string errorsAndWarnings
);
Managed C++ public: DegenerateItems Validate(
String **errorsAndWarnings
);
JScript .NET public function Validate(
errorsAndWarnings : String
) : DegenerateItems;

Parameters

errorsAndWarnings System.String. Returns a buffer that contains a string of errors and warnings, which explain the problems found in the mesh.

Return Value

Microsoft.DirectX.Direct3D.DegenerateItems . Returns a DegenerateItems structure that contains the indexes of patches and vertices that caused validation to fail.

Remarks

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.ControlVerticesPerPatch

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.ControlVerticesPerPatch Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of control vertices per patch.

Definition

Visual Basic .NET | Public ReadOnly Property ControlVerticesPerPatch As Integer
C# | public int ControlVerticesPerPatch { get; }
Managed C++ | public: __property int get_ControlVerticesPerPatch();
JScript .NET | public function get ControlVerticesPerPatch() : int

Property Value

System.Int32 . Number of control vertices per patch.

This property is read-only.


PatchMesh.Declaration

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Declaration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the vertex declaration.

Definition

Visual Basic .NET | Public ReadOnly Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; }
Managed C++ | public: __property VertexElement get_Declaration();
JScript .NET | public function get Declaration() : VertexElement[]

Property Value

Microsoft.DirectX.Direct3D.VertexElement[] . Array of VertexElement elements that describe the vertex format of the mesh vertices. The vertex element array ends with the value found in the VertexDeclarationEnd field.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device that created the mesh.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device associated with the patch mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.DisplacementParameter

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.DisplacementParameter Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets mesh geometry displacement parameters.

Definition

Visual Basic .NET | Public Property DisplacementParameter As DisplacementParameter
C# | public DisplacementParameter DisplacementParameter { get; set; }
Managed C++ public: __property DisplacementParameter get_DisplacementParameter();
public: __property void set_DisplacementParameter(DisplacementParameter);
JScript .NET public function get DisplacementParameter() : DisplacementParameter
public function set DisplacementParameter(DisplacementParameter);

Property Value

Microsoft.DirectX.Direct3D.DisplacementParameter . The DisplacementParameter for the mesh.

This property is read/write.

Remarks

Displacement maps can only be 2-D textures. Mipmapping is ignored for nonadaptive tessellating.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


PatchMesh.IndexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.IndexBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the mesh index buffer.

Definition

Visual Basic .NET | Public ReadOnly Property IndexBuffer As IndexBuffer
C# | public IndexBuffer IndexBuffer { get; }
Managed C++ | public: __property IndexBuffer* get_IndexBuffer();
JScript .NET | public function get IndexBuffer() : IndexBuffer

Property Value

Microsoft.DirectX.Direct3D.IndexBuffer . The IndexBuffer for the mesh.

This property is read-only.

Remarks

The index buffer contains the vertex ordering in the vertex buffer. The index buffer is used to access the vertex buffer when the mesh is rendered.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.NumberPatches

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.NumberPatches Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of patches in a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberPatches As Integer
C# | public int NumberPatches { get; }
Managed C++ | public: __property int get_NumberPatches();
JScript .NET | public function get NumberPatches() : int

Property Value

System.Int32 . Number of patches.

This property is read-only.


PatchMesh.NumberVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.NumberVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of vertices for a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
Managed C++ | public: __property int get_NumberVertices();
JScript .NET | public function get NumberVertices() : int

Property Value

System.Int32 . Number of vertices.

This property is read-only.


PatchMesh.Options

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Options Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a MeshOptions structure that contains information about the patch mesh.

Definition

Visual Basic .NET | Public ReadOnly Property Options As MeshOptions
C# | public MeshOptions Options { get; }
Managed C++ | public: __property MeshOptions get_Options();
JScript .NET | public function get Options() : MeshOptions

Property Value

Microsoft.DirectX.Direct3D.MeshOptions . A MeshOptions structure that contains information about the patch mesh.

This property is read-only.


PatchMesh.PatchInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.PatchInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the attributes of the patch mesh.

Definition

Visual Basic .NET | Public ReadOnly Property PatchInformation As PatchInformation
C# | public PatchInformation PatchInformation { get; }
Managed C++ | public: __property PatchInformation get_PatchInformation();
JScript .NET | public function get PatchInformation() : PatchInformation

Property Value

Microsoft.DirectX.Direct3D.PatchInformation . A PatchInformation structure that contains information about the patch mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXPatchMesh interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXPatchMesh
C# | public ID3DXPatchMesh UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXPatchMesh get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXPatchMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPatchMesh . Unmanaged ID3DXPatchMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


PatchMesh.VertexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.VertexBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the mesh vertex buffer.

Definition

Visual Basic .NET | Public ReadOnly Property VertexBuffer As VertexBuffer
C# | public VertexBuffer VertexBuffer { get; }
Managed C++ | public: __property VertexBuffer* get_VertexBuffer();
JScript .NET | public function get VertexBuffer() : VertexBuffer

Property Value

Microsoft.DirectX.Direct3D.VertexBuffer . A VertexBuffer object that represents the mesh vertex buffer.

This property is read-only.

Remarks

This method assumes uniform tessellation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PatchMesh.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchMesh.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the PatchMesh object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PatchMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PatchMesh object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.PixelShader

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates the functionality of a pixel shader.

Definition

Visual Basic .NET NotInheritable Public Class PixelShader
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class PixelShader : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class PixelShader : public MarshalByRefObject,
IDisposable
JScript .NET public class PixelShader extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PixelShader object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the PixelShader object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the PixelShader object to free resources before it is destroyed by the garbage collector.
GetFunction | Retrieves an array that contains the shader data.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PixelShader | Initializes a new instance of the PixelShader class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PixelShader.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PixelShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Microsoft Direct3D® device associated with a pixel shader object.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PixelShader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PixelShader.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the PixelShader object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PixelShader.Disposed
  • Microsoft.DirectX.Direct3D.PixelShader.Disposing


PixelShader.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PixelShader.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the PixelShader object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~PixelShader();
Managed C++ | ~PixelShader();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


PixelShader.GetFunction()

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.GetFunction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array that contains the shader data.

Definition

Visual Basic .NET | Public Function GetFunction() As Integer()
C# | public int[] GetFunction();
Managed C++ | public: int GetFunction() __gc[];
JScript .NET | public function GetFunction() : int[];

Return Value

System.Int32[]. Array that contains the shader data.

Remarks

Exceptions
ArgumentException Leave Site | An error occurred while trying to retrieve the shader data.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.


PixelShader.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


PixelShader.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DPixelShader9, which allows unmanaged COM clients to create an instance of the managed PixelShader class. Not supported.


PixelShader.op_Equality(PixelShader,PixelShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As PixelShader, _
ByVal right As PixelShader _
) As Boolean
C# public static bool op_Equality(
PixelShader left,
PixelShader right
);
Managed C++ public: static bool op_Equality(
PixelShader *left,
PixelShader *right
);
JScript .NET public static function op_Equality(
left : PixelShader,
right : PixelShader
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PixelShader. The PixelShader object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PixelShader. The PixelShader object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PixelShader.op_Inequality(PixelShader,PixelShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As PixelShader, _
ByVal right As PixelShader _
) As Boolean
C# public static bool op_Inequality(
PixelShader left,
PixelShader right
);
Managed C++ public: static bool op_Inequality(
PixelShader *left,
PixelShader *right
);
JScript .NET public static function op_Inequality(
left : PixelShader,
right : PixelShader
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PixelShader. The PixelShader object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PixelShader. The PixelShader object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


PixelShader.PixelShader

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.PixelShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PixelShader class.

Overload List

public PixelShader(Device, GraphicsStream);
public PixelShader(Device, int[]);
public PixelShader(IDirect3DPixelShader9);
public PixelShader(IDirect3DPixelShader9, Device);
public PixelShader(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(IDirect3DPixelShader9)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.PixelShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PixelShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DPixelShader9 _
)
C# public PixelShader(
IDirect3DPixelShader9 pUnk
);
Managed C++ public: PixelShader(
IDirect3DPixelShader9 pUnk
);
JScript .NET public function PixelShader(
pUnk : IDirect3DPixelShader9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9. Unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.PixelShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PixelShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PixelShader(
IntPtr unmanagedObject
);
Managed C++ public: PixelShader(
IntPtr unmanagedObject
);
JScript .NET public function PixelShader(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(IDirect3DPixelShader9,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.PixelShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PixelShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DPixelShader9, _
ByVal device As Device _
)
C# public PixelShader(
IDirect3DPixelShader9 lp,
Device device
);
Managed C++ public: PixelShader(
IDirect3DPixelShader9 lp,
Device *device
);
JScript .NET public function PixelShader(
lp : IDirect3DPixelShader9,
device : Device
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9. Unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. Reference to an instance of a Device object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(Device,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.PixelShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PixelShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal functionToken() As Integer _
)
C# public PixelShader(
Device device,
int[] functionToken
);
Managed C++ public: PixelShader(
Device *device,
int functionToken __gc[]
);
JScript .NET public function PixelShader(
device : Device,
functionToken : int[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to an instance of a Device object.
functionToken | System.Int32[]. Integer array representing the pixel shader function tokens that specify the blending operations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.PixelShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PixelShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal functionToken As GraphicsStream _
)
C# public PixelShader(
Device device,
GraphicsStream functionToken
);
Managed C++ public: PixelShader(
Device *device,
GraphicsStream *functionToken
);
JScript .NET public function PixelShader(
device : Device,
functionToken : GraphicsStream
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to an instance of a Device object.
functionToken | Microsoft.DirectX.GraphicsStream. Reference to a GraphicsStream object that represents the pixel shader function tokens to use.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.PixelShader.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


PixelShader.UpdateUnmanagedPointer(IDirect3DPixelShader9)

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this PixelShader object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DPixelShader9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DPixelShader9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DPixelShader9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DPixelShader9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9. Pointer to the IDirect3DPixelShader9 structure used to update the unmanaged pointer for this PixelShader object.


PixelShader.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Microsoft® Direct3D® device associated with a pixel shader object.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . A Device reference that represents the Microsoft® Direct3D® device object associated with the pixel shader object.

This property is read-only.


PixelShader.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


PixelShader.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DPixelShader9
C# | public IDirect3DPixelShader9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DPixelShader9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DPixelShader9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9 . Unmanaged IDirect3DPixelShader9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


PixelShader.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShader.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the PixelShader object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PixelShader.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PixelShader object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.PresentParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes the presentation parameters.

Definition

Visual Basic .NET NotInheritable Public Class PresentParameters
Inherits Object
Implements ICloneable
C# public sealed class PresentParameters : Object,
ICloneable
Managed C++ public __gc __sealed class PresentParameters : public Object,
ICloneable
JScript .NET public class PresentParameters extends Object
implements ICloneable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) DefaultPresentRate | Returns the default rate at which a swap chain's back buffers can be presented.

Methods

Method | Description
Clone | Clones, or copies, a PresentParameters object.
PresentParameters | Creates a new instance of the PresentParameters class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AutoDepthStencilFormat | Retrieves or sets the DepthFormat of the depth stencil surface the device creates.
BackBufferCount | Retrieves or sets the number of back buffers.
BackBufferFormat | Retrieves or sets the format of the back buffer.
BackBufferHeight | Retrieves or sets the height of a swap chain's back buffers, in pixels.
BackBufferWidth | Retrieves or sets the width of a swap chain's back buffers, in pixels.
DeviceWindow | Retrieves or sets the display window.
DeviceWindowHandle | Retrieves or sets the display window.
EnableAutoDepthStencil | Retrieves or sets a Boolean value that indicates whether Microsoft® Direct3D® manages depth buffers for an application.
ForceNoMultiThreadedFlag | Retrieves or sets a Boolean value that indicates whether an application can use multithreading.
FullScreenRefreshRateInHz | Retrieves or sets the rate at which the display adapter refreshes the screen.
MultiSample | Retrieves or sets the MultiSampleType.
MultiSampleQuality | Retrieves or sets the multisample quality level.
PresentationInterval | Retrieves or sets the maximum rate at which the swap chain's back buffers can be presented.
PresentFlag | Retrieves or sets the present flag.
SwapEffect | Retrieves or sets the swap effect.
Windowed | Boolean value that indicates whether an application is running in a windowed mode.

Inheritance Hierarchy

Object Leave Site
PresentParameters

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Device
  • SwapChain
  • Device.Present
  • Device.Reset


PresentParameters.Clone()

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones, or copies, a PresentParameters object.

Definition

Visual Basic .NET | Overrides Public Function Clone() As Object
C# | public override object Clone();
Managed C++ | public: Object* Clone();
JScript .NET | public override function Clone() : Object;

Return Value

System.Object . An Object Leave Site that represents the copied device.

Remarks

Exceptions
OutOfMemoryException Leave Site Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PresentParameters.PresentParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.PresentParameters Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the PresentParameters class.

Overload List

public PresentParameters();
public PresentParameters(PresentParameters);


PresentParameters.PresentParameters()

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.PresentParameters Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the PresentParameters class.

Definition

Visual Basic .NET | Public Sub New()
C# | public PresentParameters();
Managed C++ | public: PresentParameters();
JScript .NET | public function PresentParameters();


PresentParameters.PresentParameters(PresentParameters)

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.PresentParameters Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the PresentParameters class.

Definition

Visual Basic .NET Public Sub New( _
ByVal original As PresentParameters _
)
C# public PresentParameters(
PresentParameters original
);
Managed C++ public: PresentParameters(
PresentParameters *original
);
JScript .NET public function PresentParameters(
original : PresentParameters
);

Parameters

original Microsoft.DirectX.Direct3D.PresentParameters. A PresentParameters object from which to create the new object.


PresentParameters.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PresentParameters.AutoDepthStencilFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.AutoDepthStencilFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the DepthFormat of the depth stencil surface the device creates.

Definition

Visual Basic .NET | Public Property AutoDepthStencilFormat As DepthFormat
C# | public DepthFormat AutoDepthStencilFormat { get; set; }
Managed C++ public: __property DepthFormat get_AutoDepthStencilFormat();
public: __property void set_AutoDepthStencilFormat(DepthFormat);
JScript .NET public function get AutoDepthStencilFormat() : DepthFormat
public function set AutoDepthStencilFormat(DepthFormat);

Property Value

Microsoft.DirectX.Direct3D.DepthFormat . A DepthFormat enumerated type that describes the format of the automatic depth stencil surface the device creates.

This property is read/write.

Remarks

This member is ignored unless EnableAutoDepthStencil is set to true.


PresentParameters.BackBufferCount

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.BackBufferCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of back buffers.

Definition

Visual Basic .NET | Public Property BackBufferCount As Integer
C# | public int BackBufferCount { get; set; }
Managed C++ public: __property int get_BackBufferCount();
public: __property void set_BackBufferCount(int);
JScript .NET public function get BackBufferCount() : int
public function set BackBufferCount(int);

Property Value

System.Int32 . Number of back buffers.

This property is read/write.

Remarks

This value can be 0 (or 1), 2, or 3. Zero is treated as 1. If the specified number of back buffers cannot be created, the runtime fails the method call and fills the value with the number of back buffers that it was able to create. This behavior means that an application can call the method twice with the same PresentParameters structure and expect it to work the second time.

The method fails if one back buffer cannot be created. The value of BackBufferCount influences which set of swap effects is allowed; specifically, any SwapEffect.Copy swap effect requires that there be exactly one back buffer.


PresentParameters.BackBufferFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.BackBufferFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the format of the back buffer.

Definition

Visual Basic .NET | Public Property BackBufferFormat As Format
C# | public Format BackBufferFormat { get; set; }
Managed C++ public: __property Format get_BackBufferFormat();
public: __property void set_BackBufferFormat(Format);
JScript .NET public function get BackBufferFormat() : Format
public function set BackBufferFormat(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . Back buffer Format.

This property is read/write.

Remarks

This value must be one of the render target formats as validated by Manager.CheckDeviceType. Use Device.DisplayMode to obtain the current format. For more information about formats, see Format.

While in windowed mode, Unknown can be specified for the BackBufferFormat. This tells the runtime to use the current display-mode format and eliminates the need to call Device.DisplayMode.

For windowed applications, the back buffer format does not need to match the display-mode format because color conversion can be done by the hardware (provided the hardware supports it). The set of possible back buffer formats is constrained, but the runtime allows any valid back buffer format to be presented to any desktop format. The device also must be operable in desktop mode, since devices typically do not operate in 8-bits-per-pixel modes.

Full-screen applications cannot perform color conversion.


PresentParameters.BackBufferHeight

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.BackBufferHeight Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height of a swap chain's back buffers, in pixels.

Definition

Visual Basic .NET | Public Property BackBufferHeight As Integer
C# | public int BackBufferHeight { get; set; }
Managed C++ public: __property int get_BackBufferHeight();
public: __property void set_BackBufferHeight(int);
JScript .NET public function get BackBufferHeight() : int
public function set BackBufferHeight(int);

Property Value

System.Int32 . Height of the swap chain's back buffers, in pixels.

This property is read/write.

Remarks

If the Windowed property is false (that is, if the presentation is full-screen), the height must equal the height of one of the enumerated display modes found through the DisplayModeCollection. If Windowed is true and height is 0, the corresponding dimension of the client area of the DeviceWindow (or the focus window, if DeviceWindow is null) is taken.


PresentParameters.BackBufferWidth

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.BackBufferWidth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of a swap chain's back buffers, in pixels.

Definition

Visual Basic .NET | Public Property BackBufferWidth As Integer
C# | public int BackBufferWidth { get; set; }
Managed C++ public: __property int get_BackBufferWidth();
public: __property void set_BackBufferWidth(int);
JScript .NET public function get BackBufferWidth() : int
public function set BackBufferWidth(int);

Property Value

System.Int32 . Width of the swap chain's back buffers, in pixels.

This property is read/write.

Remarks

If the Windowed property is false (that is, if the presentation is full-screen), the width must equal the width of one of the enumerated display modes found through the DisplayModeCollection. If Windowed is true and width is 0, the corresponding dimension of the client area of the DeviceWindow (or the focus window, if DeviceWindow is null) is taken.


PresentParameters.DeviceWindow

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.DeviceWindow Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the display window.

Definition

Visual Basic .NET | Public Property DeviceWindow As Control
C# | public Control DeviceWindow { get; set; }
Managed C++ public: __property Control* get_DeviceWindow();
public: __property void set_DeviceWindow(Control*);
JScript .NET public function get DeviceWindow() : Control
public function set DeviceWindow(Control);

Property Value

System.Windows.Forms.Control . A Control Leave Site that represents the display window.

This property is read/write.

Remarks

For a full-screen application, the display window is the cover window. For applications that use multiple full-screen devices (such as a system with multiple monitors), exactly one device can use the focus window as the device window. All other devices must have unique device windows.

For a windowed-mode application, the display window is the default target window for Device.Present. If this property is null, the focus window is taken.

Note that the runtime does not attempt to reflect user changes in window size. The back buffer is not implicitly reset when this window is reset. However, the Device.Present method does automatically track window position changes.


PresentParameters.DeviceWindowHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.DeviceWindowHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the display window.

Definition

Visual Basic .NET | Public Property DeviceWindowHandle As IntPtr
C# | public IntPtr DeviceWindowHandle { get; set; }
Managed C++ public: __property IntPtr get_DeviceWindowHandle();
public: __property void set_DeviceWindowHandle(IntPtr);
JScript .NET public function get DeviceWindowHandle() : IntPtr
public function set DeviceWindowHandle(IntPtr);

Property Value

System.IntPtr . Pointer to an object that represents the display window.

This property is read/write.

Remarks

For a full-screen application, the display window is the cover window. For applications that use multiple full-screen devices (such as a system with multiple monitors), exactly one device can use the focus window as the device window. All other devices must have unique device windows.

For a windowed-mode application, the display window is the default target window for Device.Present. If this property is null, the focus window is taken.

Note that the runtime does not attempt to reflect user changes in window size. The back buffer is not implicitly reset when this window is reset. However, the Device.Present method does automatically track window position changes.


PresentParameters.EnableAutoDepthStencil

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.EnableAutoDepthStencil Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Boolean value that indicates whether Microsoft® Direct3D® manages depth buffers for an application.

Definition

Visual Basic .NET | Public Property EnableAutoDepthStencil As Boolean
C# | public bool EnableAutoDepthStencil { get; set; }
Managed C++ public: __property bool get_EnableAutoDepthStencil();
public: __property void set_EnableAutoDepthStencil(bool);
JScript .NET public function get EnableAutoDepthStencil() : boolean
public function set EnableAutoDepthStencil(boolean);

Property Value

System.Boolean . Value that is true if Microsoft® Direct3D® manages the depth buffers, or false if it does not.

This property is read/write.

Remarks

When the device is created, it creates a depth stencil buffer that is automatically set as its render target. When the device is reset, the depth stencil buffer is automatically destroyed and re-created in the new size.

If EnableAutoDepthStencil is true, AutoDepthStencilFormat must be a valid depth stencil format.


PresentParameters.ForceNoMultiThreadedFlag

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.ForceNoMultiThreadedFlag Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Boolean value that indicates whether an application can use multithreading.

Definition

Visual Basic .NET | Public Property ForceNoMultiThreadedFlag As Boolean
C# | public bool ForceNoMultiThreadedFlag { get; set; }
Managed C++ public: __property bool get_ForceNoMultiThreadedFlag();
public: __property void set_ForceNoMultiThreadedFlag(bool);
JScript .NET public function get ForceNoMultiThreadedFlag() : boolean
public function set ForceNoMultiThreadedFlag(boolean);

Property Value

System.Boolean . Value that is true if multithreading is allowed in the application, or false if it is not.

This property is read/write.


PresentParameters.FullScreenRefreshRateInHz

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.FullScreenRefreshRateInHz Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the rate at which the display adapter refreshes the screen.

Definition

Visual Basic .NET | Public Property FullScreenRefreshRateInHz As Integer
C# | public int FullScreenRefreshRateInHz { get; set; }
Managed C++ public: __property int get_FullScreenRefreshRateInHz();
public: __property void set_FullScreenRefreshRateInHz(int);
JScript .NET public function get FullScreenRefreshRateInHz() : int
public function set FullScreenRefreshRateInHz(int);

Property Value

System.Int32 . Refresh rate in hertz.

This property is read/write.

Remarks

The value depends on the mode in which the application is running. For windowed mode, the refresh rate must be 0. For full-screen mode, the refresh rate is one of those found through DisplayModeCollection.


PresentParameters.MultiSample

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.MultiSample Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the MultiSampleType.

Definition

Visual Basic .NET | Public Property MultiSample As MultiSampleType
C# | public MultiSampleType MultiSample { get; set; }
Managed C++ public: __property MultiSampleType get_MultiSample();
public: __property void set_MultiSample(MultiSampleType);
JScript .NET public function get MultiSample() : MultiSampleType
public function set MultiSample(MultiSampleType);

Property Value

Microsoft.DirectX.Direct3D.MultiSampleType . Member of the MultiSampleType enumeration that indicates the level of multisampling used by the swap chain.

This property is read/write.

Remarks

The value must be None unless the SwapEffect property is set to SwapEffect.Discard. Multisampling is supported only if the swap effect is SwapEffect.Discard.


PresentParameters.MultiSampleQuality

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.MultiSampleQuality Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the multisample quality level.

Definition

Visual Basic .NET | Public Property MultiSampleQuality As Integer
C# | public int MultiSampleQuality { get; set; }
Managed C++ public: __property int get_MultiSampleQuality();
public: __property void set_MultiSampleQuality(int);
JScript .NET public function get MultiSampleQuality() : int
public function set MultiSampleQuality(int);

Property Value

System.Int32 . Multisample quality level.

This property is read/write.

Remarks

The valid range is between 0 and one less than the level returned by the param_Int32R_qualityLevels parameter used by Manager.CheckDeviceMultiSampleType. Passing a larger value causes an InvalidCallException. Paired values of render targets or depth stencil surfaces must match MultiSample.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PresentParameters.PresentationInterval

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.PresentationInterval Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the maximum rate at which the swap chain's back buffers can be presented.

Definition

Visual Basic .NET | Public Property PresentationInterval As PresentInterval
C# | public PresentInterval PresentationInterval { get; set; }
Managed C++ public: __property PresentInterval get_PresentationInterval();
public: __property void set_PresentationInterval(PresentInterval);
JScript .NET public function get PresentationInterval() : PresentInterval
public function set PresentationInterval(PresentInterval);

Property Value

Microsoft.DirectX.Direct3D.PresentInterval . Maximum rate at which the swap chain's back buffers can be presented.

This property is read/write.

Remarks

For a windowed swap chain, this value must be PresentInterval.Default (0). For a full-screen swap chain, it can be PresentInterval.Default or the value that corresponds exactly to one of the flags enumerated in Present.


PresentParameters.PresentFlag

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.PresentFlag Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the present flag.

Definition

Visual Basic .NET | Public Property PresentFlag As PresentFlag
C# | public PresentFlag PresentFlag { get; set; }
Managed C++ public: __property PresentFlag get_PresentFlag();
public: __property void set_PresentFlag(PresentFlag);
JScript .NET public function get PresentFlag() : PresentFlag
public function set PresentFlag(PresentFlag);

Property Value

Microsoft.DirectX.Direct3D.PresentFlag . A PresentFlag value.

This property is read/write.

Remarks

The present flag controls a Device.Present operation.


PresentParameters.SwapEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.SwapEffect Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the swap effect.

Definition

Visual Basic .NET | Public Property SwapEffect As SwapEffect
C# | public SwapEffect SwapEffect { get; set; }
Managed C++ public: __property SwapEffect get_SwapEffect();
public: __property void set_SwapEffect(SwapEffect);
JScript .NET public function get SwapEffect() : SwapEffect
public function set SwapEffect(SwapEffect);

Property Value

Microsoft.DirectX.Direct3D.SwapEffect . Member of the SwapEffect enumerated type that indicates how buffers are swapped.

This property is read/write.

Remarks

The runtime guarantees the implied semantics concerning buffer swap behavior. So if Windowed is set to true and SwapEffect is set to SwapEffect.Flip, the runtime creates one extra back buffer and copies whichever becomes the front buffer at presentation time.

The SwapEffect.Copy setting requires that BackBufferCount be set to 1. This setting is enforced in the debug runtime, which fills any buffer with noise after it is presented.


PresentParameters.Windowed

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.Windowed Property

Language:
Note: This documentation is preliminary and is subject to change.

Boolean value that indicates whether an application is running in a windowed mode.

Definition

Visual Basic .NET | Public Property Windowed As Boolean
C# | public bool Windowed { get; set; }
Managed C++ public: __property bool get_Windowed();
public: __property void set_Windowed(bool);
JScript .NET public function get Windowed() : boolean
public function set Windowed(boolean);

Property Value

System.Boolean . Value that is true if the application is running windowed, or false if it is running full-screen.

This property is read/write.


PresentParameters.DefaultPresentRate

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentParameters.DefaultPresentRate Field

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the default rate at which a swap chain's back buffers can be presented.

Definition

Visual Basic .NET | Public Shared DefaultPresentRate As Int32
C# | public static Int32 DefaultPresentRate;
Managed C++ | public: static Int32 DefaultPresentRate;
JScript .NET | public static var DefaultPresentRate : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the default present rate.

This field is read-only.


Microsoft.DirectX.Direct3D.ProgressiveMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates progressive mesh objects.

Definition

Visual Basic .NET NotInheritable Public Class ProgressiveMesh
Inherits BaseMesh
C# | public sealed class ProgressiveMesh : BaseMesh
Managed C++ | public __gc __sealed class ProgressiveMesh : public BaseMesh
JScript .NET | public class ProgressiveMesh extends BaseMesh

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ProgressiveMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Clones, or copies, a mesh object. Inherited from BaseMesh.
Clone | Clones a progressive mesh.
ComputeNormals | Computes normals for each vertex in a mesh. Inherited from BaseMesh.
ConvertAdjacencyToPointReps | Converts mesh adjacency information to an array of point representatives. Inherited from BaseMesh.
ConvertPointRepsToAdjacency | Converts point representative data to mesh adjacency information. Inherited from BaseMesh.
Dispose | Immediately releases the unmanaged resources used by the ProgressiveMesh object.
DrawSubset | Draws a subset of a mesh. Inherited from BaseMesh.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ProgressiveMesh object to free resources before it is destroyed by the garbage collector.
GenerateAdjacency | Generates adjacency information based on mesh indices. Inherited from BaseMesh.
GetAttributeTable | Retrieves an attribute table for a mesh. Inherited from BaseMesh.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
LockIndexBuffer | Locks an index buffer and obtains the index buffer data. Inherited from BaseMesh.
LockVertexBuffer | Locks a vertex buffer and obtains a pointer to the vertex buffer memory. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseMesh.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Optimize | Generates an output mesh with reordered faces and vertices to optimize performance.
OptimizeBaseLevelOfDetail | Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.
ProgressiveMesh | Creates a new instance of the ProgressiveMesh class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing event when called from within a derived class.
SetIndexBufferData | Sets index buffer data. Inherited from BaseMesh.
SetVertexBufferData | Sets vertex buffer data. Inherited from BaseMesh.
TrimByFaces | Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.
TrimByVertices | Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.
UnlockIndexBuffer | Unlocks an index buffer. Inherited from BaseMesh.
UnlockVertexBuffer | Unlocks a vertex buffer. Inherited from BaseMesh.
UpdateSemantics Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this ProgressiveMesh object. This method supports the Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Adjacency | Retrieves the face adjacency array of the mesh.
Declaration | Retrieves a declaration that describes the vertices in a mesh. Inherited from BaseMesh.
Device | Retrieves the device associated with a mesh. Inherited from BaseMesh.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the data in an index buffer. Inherited from BaseMesh.
MaxFaces | Retrieves the maximum number of faces that a progressive mesh can support.
MaxVertices | Retrieves the maximum number of vertices that a progressive mesh can support.
MinFaces | Retrieves the minimum number of faces that a progressive mesh can support.
MinVertices | Retrieves the minimum number of vertices that a progressive mesh can support.
NumberAttributes | Retrieves the number of entries stored in an attribute table for a mesh. Inherited from BaseMesh.
NumberBytesPerVertex | Retrieves the number of bytes per vertex. Inherited from BaseMesh.
NumberFaces | Retrieves the currently set number of faces, or sets the current level of detail (LOD) to as close to the specified number of faces as possible.
NumberVertices | Sets the current level of detail (LOD) to as close to the specified number of vertices as possible.
Options | Retrieves the mesh options enabled for the current mesh at creation time. Inherited from BaseMesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer. Inherited from BaseMesh.
UnmanagedComPointer | Returns the unmanaged COM ID3DXPMesh interface pointer.
VertexBuffer | Retrieves the vertex buffer of a mesh. Inherited from BaseMesh.
VertexFormat | Retrieves the vertex format that describes the contents of vertices. Inherited from BaseMesh.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseMesh
ProgressiveMesh

Remarks

A progressive mesh enables progressive refinement of the mesh object.

This interface inherits additional functionality from the BaseMesh class.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ProgressiveMesh.Clone

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh.

Overload List

public ProgressiveMesh Clone(MeshFlags, GraphicsStream, Device);
public ProgressiveMesh Clone(MeshFlags, VertexElement[], Device);
public ProgressiveMesh Clone(MeshFlags, VertexFormats, Device);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.Clone(MeshFlags,GraphicsStream,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration As GraphicsStream, _
ByVal device As Device _
) As ProgressiveMesh
C# public ProgressiveMesh Clone(
MeshFlags options,
GraphicsStream declaration,
Device device
);
Managed C++ public: ProgressiveMesh* Clone(
MeshFlags options,
GraphicsStream *declaration,
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
declaration : GraphicsStream,
device : Device
) : ProgressiveMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing VertexElement structures that describe the vertex format for the returned mesh. This parameter must map directly to a flexible vertex format (FVF).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . Returns a cloned ProgressiveMesh object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.Clone(MeshFlags,VertexElement[],Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As ProgressiveMesh
C# public ProgressiveMesh Clone(
MeshFlags options,
VertexElement[] declaration,
Device device
);
Managed C++ public: ProgressiveMesh* Clone(
MeshFlags options,
VertexElement declaration __gc[],
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
declaration : VertexElement[],
device : Device
) : ProgressiveMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. Array containing VertexElement structures that describe the vertex format for the returned mesh. This parameter must map directly to a flexible vertex format (FVF).
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . Returns a cloned ProgressiveMesh object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.Clone(MeshFlags,VertexFormats,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
) As ProgressiveMesh
C# public ProgressiveMesh Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
Managed C++ public: ProgressiveMesh* Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
) : ProgressiveMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. A VertexFormats enumerated value that indicates the vertex format of the returned mesh.
device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . Returns a cloned ProgressiveMesh object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the ProgressiveMesh object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposed
  • Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing


ProgressiveMesh.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ProgressiveMesh.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the ProgressiveMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ProgressiveMesh();
Managed C++ | ~ProgressiveMesh();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


ProgressiveMesh.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


ProgressiveMesh.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPMesh, which allows unmanaged COM clients to create an instance of the managed ProgressiveMesh class. Not supported.


ProgressiveMesh.op_Equality(ProgressiveMesh,ProgressiveMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As ProgressiveMesh, _
ByVal right As ProgressiveMesh _
) As Boolean
C# public static bool op_Equality(
ProgressiveMesh left,
ProgressiveMesh right
);
Managed C++ public: static bool op_Equality(
ProgressiveMesh *left,
ProgressiveMesh *right
);
JScript .NET public static function op_Equality(
left : ProgressiveMesh,
right : ProgressiveMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.ProgressiveMesh. The ProgressiveMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.ProgressiveMesh. The ProgressiveMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ProgressiveMesh.op_Inequality(ProgressiveMesh,ProgressiveMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As ProgressiveMesh, _
ByVal right As ProgressiveMesh _
) As Boolean
C# public static bool op_Inequality(
ProgressiveMesh left,
ProgressiveMesh right
);
Managed C++ public: static bool op_Inequality(
ProgressiveMesh *left,
ProgressiveMesh *right
);
JScript .NET public static function op_Inequality(
left : ProgressiveMesh,
right : ProgressiveMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.ProgressiveMesh. The ProgressiveMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.ProgressiveMesh. The ProgressiveMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


ProgressiveMesh.Optimize

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates an output mesh with reordered faces and vertices to optimize performance.

Overload List

public Mesh Optimize(MeshFlags);
public Mesh Optimize(MeshFlags, out int, out int);
public Mesh Optimize(MeshFlags, out int, out int, out GraphicsStream);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.Optimize(MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates an output mesh with reordered faces and vertices to optimize performance.

Definition

Visual Basic .NET Public Function Optimize( _
ByVal flags As MeshFlags _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags
);
Managed C++ public: Mesh* Optimize(
MeshFlags flags
);
JScript .NET public function Optimize(
flags : MeshFlags
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform. This parameter can be set to one or more flags from MeshFlags (except Use32Bit, WriteOnly, IbWriteOnly, SimplifyFace, or SimplifyVertex).

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the optimized mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.Optimize(MeshFlags,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates an output mesh with reordered faces and vertices to optimize performance.

Definition

Visual Basic .NET Public Function Optimize( _
ByVal flags As MeshFlags, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
out int adjacencyOut,
out int faceRemap
);
Managed C++ public: Mesh* Optimize(
MeshFlags flags,
int *adjacencyOut,
int *faceRemap
);
JScript .NET public function Optimize(
flags : MeshFlags,
adjacencyOut : int,
faceRemap : int
) : Mesh;

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform. This parameter can be set to one or more flags from MeshFlags (except Use32Bit, WriteOnly, IbWriteOnly, SimplifyFace, or SimplifyVertex).
adjacencyOut | System.Int32[]. Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh. The size of this array is the maximum number of faces multiplied by 3.
faceRemap | System.Int32[]. Array that contains the new index for each face.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the optimized mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.Optimize(MeshFlags,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Optimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates an output mesh with reordered faces and vertices to optimize performance.

Definition

Visual Basic .NET Public Function Optimize( _
ByVal flags As MeshFlags, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: Mesh* Optimize(
MeshFlags flags,
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function Optimize(
flags : MeshFlags,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. Type of optimization to perform. This parameter can be set to one or more flags from MeshFlags (except Use32Bit, WriteOnly, IbWriteOnly, SimplifyFace, or SimplifyVertex).
adjacencyOut | System.Int32[]. Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh. The size of this array is the maximum number of faces multiplied by 3.
faceRemap | System.Int32[]. Array that contains the new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the optimized mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.OptimizeBaseLevelOfDetail

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.OptimizeBaseLevelOfDetail Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.

Overload List

public void OptimizeBaseLevelOfDetail(MeshFlags);
public void OptimizeBaseLevelOfDetail(MeshFlags, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.OptimizeBaseLevelOfDetail(MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.OptimizeBaseLevelOfDetail Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.

Definition

Visual Basic .NET Public Sub OptimizeBaseLevelOfDetail( _
ByVal flags As MeshFlags _
)
C# public void OptimizeBaseLevelOfDetail(
MeshFlags flags
);
Managed C++ public: void OptimizeBaseLevelOfDetail(
MeshFlags flags
);
JScript .NET public function OptimizeBaseLevelOfDetail(
flags : MeshFlags
);

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags. One or more Optimize* flags from the MeshFlags enumeration that specify the type of optimization to perform.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.OptimizeBaseLevelOfDetail(MeshFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.OptimizeBaseLevelOfDetail Method

 Language:
Note: This documentation is preliminary and is subject to change.

Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.

Definition

Visual Basic .NET Public Sub OptimizeBaseLevelOfDetail( _
ByVal flags As MeshFlags, _
ByRef faceRemap As Integer _
)
C# public void OptimizeBaseLevelOfDetail(
MeshFlags flags,
out int faceRemap
);
Managed C++ public: void OptimizeBaseLevelOfDetail(
MeshFlags flags,
int *faceRemap
);
JScript .NET public function OptimizeBaseLevelOfDetail(
flags : MeshFlags,
faceRemap : int
);

Parameters

flags | Microsoft.DirectX.Direct3D.MeshFlags. One or more Optimize* flags from the MeshFlags enumeration that specify the type of optimization to perform.
faceRemap | System.Int32[]. Array of Int32 Leave Site values that indicate how the triangles were rearranged.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Overload List

public ProgressiveMesh(ID3DXPMesh);
public ProgressiveMesh(IntPtr);
public ProgressiveMesh(Mesh, GraphicsStream, AttributeWeights, GraphicsStream, int, MeshFlags);
public ProgressiveMesh(Mesh, GraphicsStream, GraphicsStream, int, MeshFlags);
public ProgressiveMesh(Mesh, int[], AttributeWeights, int, MeshFlags);
public ProgressiveMesh(Mesh, int[], AttributeWeights, float[], int, MeshFlags);
public ProgressiveMesh(Mesh, int[], int, MeshFlags);
public ProgressiveMesh(Mesh, int[], float[], int, MeshFlags);

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(ID3DXPMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As ID3DXPMesh _
)
C# public ProgressiveMesh(
ID3DXPMesh pInterop
);
Managed C++ public: ProgressiveMesh(
ID3DXPMesh pInterop
);
JScript .NET public function ProgressiveMesh(
pInterop : ID3DXPMesh
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXPMesh. Unmanaged Component Object Model (COM) ID3DXPMesh interface pointer.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public ProgressiveMesh(
IntPtr unmanagedObject
);
Managed C++ public: ProgressiveMesh(
IntPtr unmanagedObject
);
JScript .NET public function ProgressiveMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXPMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
int minValue,
MeshFlags options
);
Managed C++ public: ProgressiveMesh(
Mesh *mesh,
int adjacency __gc[],
int minValue,
MeshFlags options
);
JScript .NET public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
minValue : int,
options : MeshFlags
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
minValue | System.Int32. Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],Single[],Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
float[] vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: ProgressiveMesh(
Mesh *mesh,
int adjacency __gc[],
float vertexWeights __gc[],
int minValue,
MeshFlags options
);
JScript .NET public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
vertexWeights : float[],
minValue : int,
options : MeshFlags
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexWeights | System.Single[]. Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue | System.Int32. Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],AttributeWeights,Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
Managed C++ public: ProgressiveMesh(
Mesh *mesh,
int adjacency __gc[],
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
JScript .NET public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
minValue : int,
options : MeshFlags
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
minValue | System.Int32. Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],AttributeWeights,Single[],Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
float[] vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: ProgressiveMesh(
Mesh *mesh,
int adjacency __gc[],
AttributeWeights vertexAttributeWeights,
float vertexWeights __gc[],
int minValue,
MeshFlags options
);
JScript .NET public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : float[],
minValue : int,
options : MeshFlags
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights | System.Single[]. Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue | System.Int32. Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,GraphicsStream,GraphicsStream,Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: ProgressiveMesh(
Mesh *mesh,
GraphicsStream *adjacency,
GraphicsStream *vertexWeights,
int minValue,
MeshFlags options
);
JScript .NET public function ProgressiveMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue | System.Int32. Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,GraphicsStream,AttributeWeights,GraphicsStream,Int32,MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.ProgressiveMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
Managed C++ public: ProgressiveMesh(
Mesh *mesh,
GraphicsStream *adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream *vertexWeights,
int minValue,
MeshFlags options
);
JScript .NET public function ProgressiveMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the source mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue | System.Int32. Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ProgressiveMesh.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


ProgressiveMesh.TrimByFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.TrimByFaces Method

 Language:
Note: This documentation is preliminary and is subject to change.

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Overload List

public void TrimByFaces(int, int);
public void TrimByFaces(int, int, out int, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • TrimByVertices


ProgressiveMesh.TrimByFaces(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.TrimByFaces Method

 Language:
Note: This documentation is preliminary and is subject to change.

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic .NET Public Sub TrimByFaces( _
ByVal newFacesMin As Integer, _
ByVal newFacesMax As Integer _
)
C# public void TrimByFaces(
int newFacesMin,
int newFacesMax
);
Managed C++ public: void TrimByFaces(
int newFacesMin,
int newFacesMax
);
JScript .NET public function TrimByFaces(
newFacesMin : int,
newFacesMax : int
);

Parameters

newFacesMin | System.Int32. New minimum number of faces. This value must fall between the current minimum and maximum number of faces.
newFacesMax | System.Int32. New maximum number of faces. This value must fall between the current minimum and maximum number of faces.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • TrimByVertices


ProgressiveMesh.TrimByFaces(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.TrimByFaces Method

 Language:
Note: This documentation is preliminary and is subject to change.

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic .NET Public Sub TrimByFaces( _
ByVal newFacesMin As Integer, _
ByVal newFacesMax As Integer, _
ByRef faceRemap As Integer, _
ByRef vertRemap As Integer _
)
C# public void TrimByFaces(
int newFacesMin,
int newFacesMax,
out int faceRemap,
out int vertRemap
);
Managed C++ public: void TrimByFaces(
int newFacesMin,
int newFacesMax,
int *faceRemap,
int *vertRemap
);
JScript .NET public function TrimByFaces(
newFacesMin : int,
newFacesMax : int,
faceRemap : int,
vertRemap : int
);

Parameters

newFacesMin | System.Int32. New minimum number of faces. This value must fall between the current minimum and maximum number of faces.
newFacesMax | System.Int32. New maximum number of faces. This value must fall between the current minimum and maximum number of faces.
faceRemap | System.Int32[]. Array of one Int32 Leave Site value per face that contains face remap information.
vertRemap | System.Int32[]. Array of one Int32 Leave Site value per vertex that contains vertex remap information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • TrimByVertices


ProgressiveMesh.TrimByVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.TrimByVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Overload List

public void TrimByVertices(int, int);
public void TrimByVertices(int, int, out int, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • TrimByFaces


ProgressiveMesh.TrimByVertices(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.TrimByVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic .NET Public Sub TrimByVertices( _
ByVal newVerticesMin As Integer, _
ByVal newVerticesMax As Integer _
)
C# public void TrimByVertices(
int newVerticesMin,
int newVerticesMax
);
Managed C++ public: void TrimByVertices(
int newVerticesMin,
int newVerticesMax
);
JScript .NET public function TrimByVertices(
newVerticesMin : int,
newVerticesMax : int
);

Parameters

newVerticesMin | System.Int32. New minimum number of vertices. This value must fall between the current minimum and maximum number of vertices.
newVerticesMax | System.Int32. New maximum number of vertices. This value must fall between the current minimum and maximum number of vertices.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • TrimByFaces


ProgressiveMesh.TrimByVertices(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.TrimByVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic .NET Public Sub TrimByVertices( _
ByVal newVerticesMin As Integer, _
ByVal newVerticesMax As Integer, _
ByRef faceRemap As Integer, _
ByRef vertRemap As Integer _
)
C# public void TrimByVertices(
int newVerticesMin,
int newVerticesMax,
out int faceRemap,
out int vertRemap
);
Managed C++ public: void TrimByVertices(
int newVerticesMin,
int newVerticesMax,
int *faceRemap,
int *vertRemap
);
JScript .NET public function TrimByVertices(
newVerticesMin : int,
newVerticesMax : int,
faceRemap : int,
vertRemap : int
);

Parameters

newVerticesMin | System.Int32. New minimum number of vertices. This value must fall between the current minimum and maximum number of vertices.
newVerticesMax | System.Int32. New maximum number of vertices. This value must fall between the current minimum and maximum number of vertices.
faceRemap | System.Int32[]. Array of one Int32 Leave Site value per face that contains face remap information.
vertRemap | System.Int32[]. Array of one Int32 Leave Site value per vertex that contains vertex remap information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • TrimByFaces


ProgressiveMesh.UpdateUnmanagedPointer(ID3DXPMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this ProgressiveMesh object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXPMesh pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXPMesh pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXPMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPMesh. Pointer to the ID3DXPMesh structure used to update the unmanaged pointer for this ProgressiveMesh object.


ProgressiveMesh.Adjacency

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Adjacency Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the face adjacency array of the mesh.

Definition

Visual Basic .NET | Public ReadOnly Property Adjacency As Integer()
C# | public int[] Adjacency { get; }
Managed C++ | public: __property int get_Adjacency();
JScript .NET | public function get Adjacency() : int[]

Property Value

System.Int32[] . Returned face adjacency array of the mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff. The size of the adjacency array is the maximum number of faces multiplied by 3.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MaxFaces


ProgressiveMesh.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


ProgressiveMesh.MaxFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.MaxFaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of faces that a progressive mesh can support.

Definition

Visual Basic .NET | Public ReadOnly Property MaxFaces As Integer
C# | public int MaxFaces { get; }
Managed C++ | public: __property int get_MaxFaces();
JScript .NET | public function get MaxFaces() : int

Property Value

System.Int32 . Maximum number of supported faces.

This property is read-only.


ProgressiveMesh.MaxVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.MaxVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of vertices that a progressive mesh can support.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertices As Integer
C# | public int MaxVertices { get; }
Managed C++ | public: __property int get_MaxVertices();
JScript .NET | public function get MaxVertices() : int

Property Value

System.Int32 . Maximum number of supported vertices.

This property is read-only.


ProgressiveMesh.MinFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.MinFaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum number of faces that a progressive mesh can support.

Definition

Visual Basic .NET | Public ReadOnly Property MinFaces As Integer
C# | public int MinFaces { get; }
Managed C++ | public: __property int get_MinFaces();
JScript .NET | public function get MinFaces() : int

Property Value

System.Int32 . Minimum number of supported faces.

This property is read-only.


ProgressiveMesh.MinVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.MinVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum number of vertices that a progressive mesh can support.

Definition

Visual Basic .NET | Public ReadOnly Property MinVertices As Integer
C# | public int MinVertices { get; }
Managed C++ | public: __property int get_MinVertices();
JScript .NET | public function get MinVertices() : int

Property Value

System.Int32 . Minimum number of supported vertices.

This property is read-only.


ProgressiveMesh.NumberFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.NumberFaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the currently set number of faces, or sets the current level of detail (LOD) to as close to the specified number of faces as possible.

Definition

Visual Basic .NET Public Property NumberFaces( _
ByVal faces As Integer _
) As Integer
C# public int this[
int faces
] { set; }
Managed C++ public: __property void set_NumberFaces(
int faces,
int
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

System.Int32 .

This property is write-only.

Parameters

faces System.Int32. Target number of faces. This value specifies the desired change in the LOD.

Remarks

If the current number of faces is greater than the maximum allowed, it is capped at the maximum number of faces returned by ProgressiveMesh.MaxFaces. If the current number of faces is less than the minimum required, it is capped at the minimum number of faces returned by ProgressiveMesh.MinFaces.

After this method is called, the number of faces might be slightly off, because edge collapse can sometimes introduce or remove a few faces. For example, setting the number of faces to an intermediate value such as 5, when 4 and 6 are possible, always produces a result of 4.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ProgressiveMesh.NumberVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.NumberVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Sets the current level of detail (LOD) to as close to the specified number of vertices as possible.

Definition

Visual Basic .NET Public Property NumberVertices( _
ByVal vertices As Integer _
) As Integer
C# public int this[
int vertices
] { set; }
Managed C++ public: __property void set_NumberVertices(
int vertices,
int
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

System.Int32 .

This property is write-only.

Parameters

vertices System.Int32. Target number of vertices. This value specifies the desired change in the LOD.

Remarks

If the number of vertices is greater than the maximum allowed, it is capped at the maximum number of vertices returned by ProgressiveMesh.MaxVertices. If the number of vertices is less than the minimum required, it is capped at the minimum number of vertices returned by ProgressiveMesh.MinVertices.

After this method is called, the number of faces might be slightly off, because edge collapse can sometimes introduce or remove a few faces. For example, setting the number of faces to an intermediate value such as 5, when 4 and 6 are possible, always produces a result of 4.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ProgressiveMesh.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXPMesh interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXPMesh
C# | public ID3DXPMesh UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXPMesh get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXPMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPMesh . Unmanaged ID3DXPMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


ProgressiveMesh.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgressiveMesh.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the ProgressiveMesh object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ProgressiveMesh object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.PrtBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer Class

Language:
Note: This documentation is preliminary and is subject to change.

Used as a data buffer to store vertex and pixel data for use with precomputed radiance transfer (PRT) methods and functions.

Definition

Visual Basic .NET Public Class PrtBuffer
Inherits MarshalByRefObject
Implements IDisposable
C# public class PrtBuffer : MarshalByRefObject,
IDisposable
Managed C++ public __gc class PrtBuffer : public MarshalByRefObject,
IDisposable
JScript .NET public class PrtBuffer extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PrtBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddBuffer | Adds another buffer to the PrtBuffer and stores the results in PrtBuffer.
AttachGutterHelper | Associates a TextureGutterHelper object with the PrtBuffer object.
Dispose | Immediately releases the unmanaged resources used by the PrtBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
EvaluateGutterHelper | Applies stored texture gutter data to a PrtBuffer texture buffer.
ExtractTexture | Extracts coefficient data from a color channel of the buffer for a specified range of coefficients, and adds the data to a Texture object.
ExtractToMesh | Extracts coefficient data from a single-channel buffer and adds the data to a Mesh object.
Finalize | Allows the PrtBuffer object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FromFile | Loads into memory a PRT buffer that was saved to disk.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
LockBuffer | Locks a range of vertex or texel sample data and returns a GraphicsStream object containing the locked buffer memory.
LockBufferSingleArray | Locks a range of vertex or texel sample data and returns an array containing the locked buffer memory.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PrtBuffer | Initializes a new instance of the PrtBuffer class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PrtBuffer.Disposing event when called from within a derived class.
ReleaseGutterHelper | Disassociates an attached TextureGutterHelper object with the PrtBuffer object.
Resize | Changes the number of samples contained in the buffer.
Save | Saves a PRT buffer to disk.
ScaleBuffer | Multiplies every value in the buffer by a constant value.
UnlockBuffer | Unlocks the buffer locked by PrtBuffer.LockBuffer or PrtBuffer.LockBufferSingleArray.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PrtBuffer object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Height | Retrieves the height of the texture, in pixels.
IsTexture | Indicates whether the buffer contains a texture.
NumberChannels | Retrieves the number of color channels used in memory to store samples.
NumberCoefficients | Retrieves the number of scalars per color channel used in memory to store samples.
NumberSamples | Retrieves the number of vertices (or texels) sampled.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPRTBuffer interface pointer.
Width | Retrieves the width of the texture, in pixels.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PrtBuffer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrtBuffer.AddBuffer(PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.AddBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds another buffer to the PrtBuffer and stores the results in PrtBuffer.

Definition

Visual Basic .NET Public Sub AddBuffer( _
ByVal buffer As PrtBuffer _
)
C# public void AddBuffer(
PrtBuffer buffer
);
Managed C++ public: void AddBuffer(
PrtBuffer *buffer
);
JScript .NET public function AddBuffer(
buffer : PrtBuffer
);

Parameters

buffer Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer that contains members to be added to the respective members of the PrtBuffer buffer.

Remarks

buffer and PrtBuffer must have the same number of samples, coefficients, and color channels; otherwise, the method will fail.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtBuffer.AttachGutterHelper(TextureGutterHelper)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.AttachGutterHelper Method

 Language:
Note: This documentation is preliminary and is subject to change.

Associates a TextureGutterHelper object with the PrtBuffer object.

Definition

Visual Basic .NET Public Sub AttachGutterHelper( _
ByVal helper As TextureGutterHelper _
)
C# public void AttachGutterHelper(
TextureGutterHelper helper
);
Managed C++ public: void AttachGutterHelper(
TextureGutterHelper *helper
);
JScript .NET public function AttachGutterHelper(
helper : TextureGutterHelper
);

Parameters

helper Microsoft.DirectX.Direct3D.TextureGutterHelper. A TextureGutterHelper object that contains texture gutter data.

Remarks

You must ensure that the number of PrtBuffer.AttachGutterHelper calls matches the number of PrtBuffer.ReleaseGutterHelper calls.

See Also

  • PrtBuffer.ReleaseGutterHelper


PrtBuffer.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the PrtBuffer object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PrtBuffer.Disposed
  • Microsoft.DirectX.Direct3D.PrtBuffer.Disposing


PrtBuffer.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PrtBuffer.EvaluateGutterHelper()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.EvaluateGutterHelper Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies stored texture gutter data to a PrtBuffer texture buffer.

Definition

Visual Basic .NET | Public Sub EvaluateGutterHelper()
C# | public void EvaluateGutterHelper();
Managed C++ | public: void EvaluateGutterHelper();
JScript .NET | public function EvaluateGutterHelper();

Remarks

This method makes an internal call to TextureGutterHelper.ApplyGutters to retrieve and apply texture gutter data.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtBuffer.ExtractTexture(Int32,Int32,Int32,Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.ExtractTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts coefficient data from a color channel of the buffer for a specified range of coefficients, and adds the data to a Texture object.

Definition

Visual Basic .NET Public Sub ExtractTexture( _
ByVal channel As Integer, _
ByVal startCoefficient As Integer, _
ByVal numberCoefficients As Integer, _
ByVal texture As Texture _
)
C# public void ExtractTexture(
int channel,
int startCoefficient,
int numberCoefficients,
Texture texture
);
Managed C++ public: void ExtractTexture(
int channel,
int startCoefficient,
int numberCoefficients,
Texture *texture
);
JScript .NET public function ExtractTexture(
channel : int,
startCoefficient : int,
numberCoefficients : int,
texture : Texture
);

Parameters

channel | System.Int32. Buffer color channel from which to extract texture data.
startCoefficient | System.Int32. Starting value of the buffer coefficient from which to extract texture data.
numberCoefficients | System.Int32. Number of scalars, beginning at startCoefficient, from which to extract texture data.
texture | Microsoft.DirectX.Direct3D.Texture. A Texture object that will store coefficients.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.ExtractToMesh(Int32,DeclarationUsage,Int32,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.ExtractToMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts coefficient data from a single-channel buffer and adds the data to a Mesh object.

Definition

Visual Basic .NET Public Sub ExtractToMesh( _
ByVal numberCoefficients As Integer, _
ByVal usage As DeclarationUsage, _
ByVal usageIndexStart As Integer, _
ByVal scene As Mesh _
)
C# public void ExtractToMesh(
int numberCoefficients,
DeclarationUsage usage,
int usageIndexStart,
Mesh scene
);
Managed C++ public: void ExtractToMesh(
int numberCoefficients,
DeclarationUsage usage,
int usageIndexStart,
Mesh *scene
);
JScript .NET public function ExtractToMesh(
numberCoefficients : int,
usage : DeclarationUsage,
usageIndexStart : int,
scene : Mesh
);

Parameters

numberCoefficients | System.Int32. Number of coefficients per sample location. When using spherical harmonic (SH) precomputed radiance transfer (PRT), the number of coefficients should be Order2, where Order is the order of the spherical harmonic (SH) evaluation. Order must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive.
usage | Microsoft.DirectX.Direct3D.DeclarationUsage. A DeclarationUsage object that describes vertex usage of the mesh.
usageIndexStart | System.Int32. Starting index for coefficients to be stored in the mesh.
scene | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that will store coefficients.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the PrtBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~PrtBuffer();
Managed C++ | ~PrtBuffer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


PrtBuffer.FromFile(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads into memory a precomputed radiance transfer (PRT) buffer that was saved to disk.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String _
) As PrtBuffer
C# public static PrtBuffer FromFile(
string filename
);
Managed C++ public: static PrtBuffer* FromFile(
String *filename
);
JScript .NET public static function FromFile(
filename : String
) : PrtBuffer;

Parameters

filename System.String. Name of the file from which to load the buffer data.

Return Value

Microsoft.DirectX.Direct3D.PrtBuffer . Returns a PrtBuffer object that contains the precomputed radiance transfer (PRT) buffer data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PrtBuffer.Save


PrtBuffer.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


PrtBuffer.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPRTBuffer, which allows unmanaged COM clients to create an instance of the managed PrtBuffer class. Not supported.


PrtBuffer.LockBuffer(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.LockBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a range of vertex or texel sample data and returns a GraphicsStream object containing the locked buffer memory.

Definition

Visual Basic .NET Public Function LockBuffer( _
ByVal start As Integer, _
ByVal numberSamples As Integer _
) As GraphicsStream
C# public GraphicsStream LockBuffer(
int start,
int numberSamples
);
Managed C++ public: GraphicsStream* LockBuffer(
int start,
int numberSamples
);
JScript .NET public function LockBuffer(
start : int,
numberSamples : int
) : GraphicsStream;

Parameters

start | System.Int32. Starting index of the sample of vertex or texel data.
numberSamples | System.Int32. Number of vertices (or texels) sampled.

Return Value

Microsoft.DirectX.GraphicsStream . Returns a GraphicsStream object containing the locked buffer memory.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.LockBufferSingleArray(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.LockBufferSingleArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a range of vertex or texel sample data and returns an array containing the locked buffer memory.

Definition

Visual Basic .NET Public Function LockBufferSingleArray( _
ByVal start As Integer, _
ByVal numberSamples As Integer _
) As Single()
C# public float[] LockBufferSingleArray(
int start,
int numberSamples
);
Managed C++ public: float LockBufferSingleArray(
int start,
int numberSamples
) __gc[];
JScript .NET public function LockBufferSingleArray(
start : int,
numberSamples : int
) : float[];

Parameters

start | System.Int32. Starting index of the sample of vertex or texel data.
numberSamples | System.Int32. Number of vertices (or texels) sampled.

Return Value

System.Single[]. Returns a floating-point array containing the locked buffer memory.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.op_Equality(PrtBuffer,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As PrtBuffer, _
ByVal right As PrtBuffer _
) As Boolean
C# public static bool op_Equality(
PrtBuffer left,
PrtBuffer right
);
Managed C++ public: static bool op_Equality(
PrtBuffer *left,
PrtBuffer *right
);
JScript .NET public static function op_Equality(
left : PrtBuffer,
right : PrtBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PrtBuffer. The PrtBuffer object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PrtBuffer. The PrtBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PrtBuffer.op_Inequality(PrtBuffer,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As PrtBuffer, _
ByVal right As PrtBuffer _
) As Boolean
C# public static bool op_Inequality(
PrtBuffer left,
PrtBuffer right
);
Managed C++ public: static bool op_Inequality(
PrtBuffer *left,
PrtBuffer *right
);
JScript .NET public static function op_Inequality(
left : PrtBuffer,
right : PrtBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PrtBuffer. The PrtBuffer object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PrtBuffer. The PrtBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


PrtBuffer.PrtBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.PrtBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtBuffer class.

Overload List

public PrtBuffer(ID3DXPRTBuffer);
public PrtBuffer(int, int, int);
public PrtBuffer(int, int, int, int);
public PrtBuffer(IntPtr);
public PrtBuffer(string);

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(ID3DXPRTBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.PrtBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXPRTBuffer _
)
C# public PrtBuffer(
ID3DXPRTBuffer pUnk
);
Managed C++ public: PrtBuffer(
ID3DXPRTBuffer pUnk
);
JScript .NET public function PrtBuffer(
pUnk : ID3DXPRTBuffer
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTBuffer. Unmanaged Component Object Model (COM) ID3DXPRTBuffer interface pointer.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.PrtBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PrtBuffer(
IntPtr unmanagedObject
);
Managed C++ public: PrtBuffer(
IntPtr unmanagedObject
);
JScript .NET public function PrtBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXPRTBuffer interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.PrtBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal filename As String _
)
C# public PrtBuffer(
string filename
);
Managed C++ public: PrtBuffer(
String *filename
);
JScript .NET public function PrtBuffer(
filename : String
);

Parameters

filename System.String. Name of the file from which to load the buffer data.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.PrtBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal numberCoefficients As Integer, _
ByVal numberChannels As Integer _
)
C# public PrtBuffer(
int width,
int height,
int numberCoefficients,
int numberChannels
);
Managed C++ public: PrtBuffer(
int width,
int height,
int numberCoefficients,
int numberChannels
);
JScript .NET public function PrtBuffer(
width : int,
height : int,
numberCoefficients : int,
numberChannels : int
);

Parameters

width | System.Int32. Width of the texture, in pixels
height | System.Int32. Height of the texture, in pixels.
numberCoefficients | System.Int32. Number of coefficients per sample location. When using spherical harmonic (SH) precomputed radiance transfer (PRT), the number of coefficients should be Order2, where Order is the order of the spherical harmonic (SH) evaluation. Order must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is Order - 1.
numberChannels | System.Int32. Number of color channels to set in the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.PrtBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal numberSamples As Integer, _
ByVal numberCoefficients As Integer, _
ByVal numberChannels As Integer _
)
C# public PrtBuffer(
int numberSamples,
int numberCoefficients,
int numberChannels
);
Managed C++ public: PrtBuffer(
int numberSamples,
int numberCoefficients,
int numberChannels
);
JScript .NET public function PrtBuffer(
numberSamples : int,
numberCoefficients : int,
numberChannels : int
);

Parameters

numberSamples | System.Int32. Number of vertices (or texels) sampled.
numberCoefficients | System.Int32. Number of coefficients per sample location. When using spherical harmonic (SH) precomputed radiance transfer (PRT), the number of coefficients should be Order2, where Order is the order of the spherical harmonic (SH) evaluation. Order must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is Order - 1.
numberChannels | System.Int32. Number of color channels to set in the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.PrtBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


PrtBuffer.ReleaseGutterHelper()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.ReleaseGutterHelper Method

 Language:
Note: This documentation is preliminary and is subject to change.

Disassociates an attached TextureGutterHelper object with the PrtBuffer object.

Definition

Visual Basic .NET | Public Sub ReleaseGutterHelper()
C# | public void ReleaseGutterHelper();
Managed C++ | public: void ReleaseGutterHelper();
JScript .NET | public function ReleaseGutterHelper();

Remarks

You must ensure that the number of PrtBuffer.AttachGutterHelper calls matches the number of PrtBuffer.ReleaseGutterHelper calls.

See Also

  • PrtBuffer.AttachGutterHelper


PrtBuffer.Resize(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Resize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Changes the number of samples contained in the buffer.

Definition

Visual Basic .NET Public Sub Resize( _
ByVal newSize As Integer _
)
C# public void Resize(
int newSize
);
Managed C++ public: void Resize(
int newSize
);
JScript .NET public function Resize(
newSize : int
);

Parameters

newSize System.Int32. Number of samples to be contained in the buffer.

Remarks

Exceptions
OutOfMemoryException Leave Site Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtBuffer.Save

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a precomputed radiance transfer (PRT) buffer to disk.

Overload List

public static void Save(PrtBuffer, string);
public void Save(string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtBuffer.FromFile


PrtBuffer.Save(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic .NET Public Sub Save( _
ByVal filename As String _
)
C# public void Save(
string filename
);
Managed C++ public: void Save(
String *filename
);
JScript .NET public function Save(
filename : String
);

Parameters

filename System.String. Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtBuffer.FromFile


PrtBuffer.Save(PrtBuffer,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal buffer As PrtBuffer, _
ByVal filename As String _
)
C# public static void Save(
PrtBuffer buffer,
string filename
);
Managed C++ public: static void Save(
PrtBuffer *buffer,
String *filename
);
JScript .NET public static function Save(
buffer : PrtBuffer,
filename : String
);

Parameters

buffer | Microsoft.DirectX.Direct3D.PrtBuffer. PrtBuffer object to be saved.
filename | System.String. Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtBuffer.FromFile


PrtBuffer.ScaleBuffer(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.ScaleBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies every value in the buffer by a constant value.

Definition

Visual Basic .NET Public Sub ScaleBuffer( _
ByVal scaleFactor As Single _
)
C# public void ScaleBuffer(
float scaleFactor
);
Managed C++ public: void ScaleBuffer(
float scaleFactor
);
JScript .NET public function ScaleBuffer(
scaleFactor : float
);

Parameters

scaleFactor System.Single. Constant value used to scale the buffer. Every value in the buffer is replaced by the product of this value and the original buffer value.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtBuffer.UnlockBuffer()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.UnlockBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks the buffer locked by PrtBuffer.LockBuffer or PrtBuffer.LockBufferSingleArray.

Definition

Visual Basic .NET | Public Sub UnlockBuffer()
C# | public void UnlockBuffer();
Managed C++ | public: void UnlockBuffer();
JScript .NET | public function UnlockBuffer();


PrtBuffer.UpdateUnmanagedPointer(ID3DXPRTBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this PrtBuffer object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPRTBuffer _
)
C# public void UpdateUnmanagedPointer(
ID3DXPRTBuffer pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXPRTBuffer pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXPRTBuffer
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTBuffer. Pointer to the ID3DXPRTBuffer structure used to update the unmanaged pointer for this PrtBuffer object.


PrtBuffer.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


PrtBuffer.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the height of the texture, in pixels.

Definition

Visual Basic .NET | Public ReadOnly Property Height As Integer
C# | public int Height { get; }
Managed C++ | public: __property int get_Height();
JScript .NET | public function get Height() : int

Property Value

System.Int32 . An integer that represents the height of the texture, in pixels.

This property is read-only.

See Also

  • PrtBuffer.Width


PrtBuffer.IsTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.IsTexture Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the buffer contains a texture.

Definition

Visual Basic .NET | Public ReadOnly Property IsTexture As Boolean
C# | public bool IsTexture { get; }
Managed C++ | public: __property bool get_IsTexture();
JScript .NET | public function get IsTexture() : boolean

Property Value

System.Boolean . A value that is true if the buffer contains a texture; otherwise, false.

This property is read-only.


PrtBuffer.NumberChannels

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.NumberChannels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of color channels used in memory to store samples.

Definition

Visual Basic .NET | Public ReadOnly Property NumberChannels As Integer
C# | public int NumberChannels { get; }
Managed C++ | public: __property int get_NumberChannels();
JScript .NET | public function get NumberChannels() : int

Property Value

System.Int32 . An integer that represents the number of color channels used in memory to store samples. The value generally will be either 1 to represent luminance values, or 3 to represent RGB values.

This property is read-only.


PrtBuffer.NumberCoefficients

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.NumberCoefficients Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of scalars per color channel used in memory to store samples.

Definition

Visual Basic .NET | Public ReadOnly Property NumberCoefficients As Integer
C# | public int NumberCoefficients { get; }
Managed C++ | public: __property int get_NumberCoefficients();
JScript .NET | public function get NumberCoefficients() : int

Property Value

System.Int32 . An integer that represents the number of scalars per color channel used in memory to store samples.

This property is read-only.


PrtBuffer.NumberSamples

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.NumberSamples Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of vertices (or texels) sampled.

Definition

Visual Basic .NET | Public ReadOnly Property NumberSamples As Integer
C# | public int NumberSamples { get; }
Managed C++ | public: __property int get_NumberSamples();
JScript .NET | public function get NumberSamples() : int

Property Value

System.Int32 . An integer that represents the number of vertices (or texels) sampled.

This property is read-only.


PrtBuffer.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXPRTBuffer interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXPRTBuffer
C# | public ID3DXPRTBuffer UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXPRTBuffer get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXPRTBuffer

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTBuffer . Unmanaged ID3DXPRTBuffer interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


PrtBuffer.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the width of the texture, in pixels.

Definition

Visual Basic .NET | Public ReadOnly Property Width As Integer
C# | public int Width { get; }
Managed C++ | public: __property int get_Width();
JScript .NET | public function get Width() : int

Property Value

System.Int32 . An integer that represents the width of the texture, in pixels.

This property is read-only.

See Also

  • PrtBuffer.Height


PrtBuffer.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtBuffer.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the PrtBuffer object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PrtBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PrtBuffer object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.PrtCompressedBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer Class

Language:
Note: This documentation is preliminary and is subject to change.

Stores a compressed version of a PrtBuffer object for use with principal component analysis (PCA).

Definition

Visual Basic .NET Public Class PrtCompressedBuffer
Inherits MarshalByRefObject
Implements IDisposable
C# public class PrtCompressedBuffer : MarshalByRefObject,
IDisposable
Managed C++ public __gc class PrtCompressedBuffer : public MarshalByRefObject,
IDisposable
JScript .NET public class PrtCompressedBuffer extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PrtCompressedBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the PrtCompressedBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
ExtractBasis | Extracts the mean and PCA basis vectors for a given cluster from a PrtCompressedBuffer object.
ExtractClusterIDs | Extracts the per-sample cluster identifiers (IDs) from a PrtCompressedBuffer object.
ExtractPca | Extracts the per-sample PCA projection coefficients from a PrtCompressedBuffer object.
ExtractTexture | Extracts the per-sample PCA projection coefficients from a PrtCompressedBuffer object and adds the data to a Texture object.
ExtractToMesh | Extracts the per-sample PCA projection coefficients from a PrtCompressedBuffer object and adds the data to a Mesh object.
Finalize | Allows the PrtCompressedBuffer object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FromFile | Loads into memory a compressed PRT buffer that was saved to disk.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
NormalizeData | Normalizes all PCA weights so that they are between -1 and 1. Basis vectors are modified to reflect this normalization.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PrtCompressedBuffer | Initializes a new instance of the PrtCompressedBuffer class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing event when called from within a derived class.
Save | Saves a compressed precomputed radiance transfer (PRT) buffer to disk.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PrtCompressedBuffer object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Height | Retrieves the height of the texture, in pixels.
IsTexture | Indicates whether the compressed buffer contains a texture.
NumberChannels | Retrieves the number of color channels used in memory to store samples.
NumberClusters | Retrieves the number of clusters to use for compression.
NumberCoefficients | Retrieves the number of scalars per color channel used in memory to store samples.
NumberPcaVectors | Retrieves the number of PCA basis vectors to use in each cluster.
NumberSamples | Retrieves the number of vertices (or texels) sampled.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface pointer.
Width | Retrieves the width of the texture, in pixels.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PrtCompressedBuffer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrtCompressedBuffer.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the PrtCompressedBuffer object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposed
  • Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing


PrtCompressedBuffer.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PrtCompressedBuffer.ExtractBasis(Int32,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.ExtractBasis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts the mean and principal component analysis (PCA) basis vectors for a given cluster from a PrtCompressedBuffer object.

Definition

Visual Basic .NET Public Sub ExtractBasis( _
ByVal cluster As Integer, _
ByVal clusterBasis() As Single _
)
C# public void ExtractBasis(
int cluster,
float[] clusterBasis
);
Managed C++ public: void ExtractBasis(
int cluster,
float clusterBasis __gc[]
);
JScript .NET public function ExtractBasis(
cluster : int,
clusterBasis : float[]
);

Parameters

cluster | System.Int32. Cluster for which the basis will be extracted.
clusterBasis | System.Single[]. An array of basis vector data for cluster.

Remarks

The size of the clusterBasis data will be:

(1 + Number of PCA vectors per cluster) * (Number of coefficients) * (Number of color channels)

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractClusterIDs(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.ExtractClusterIDs Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts the per-sample cluster identifiers (IDs) from a PrtCompressedBuffer object.

Definition

Visual Basic .NET Public Sub ExtractClusterIDs( _
ByVal clusterIds() As Integer _
)
C# public void ExtractClusterIDs(
int[] clusterIds
);
Managed C++ public: void ExtractClusterIDs(
int clusterIds __gc[]
);
JScript .NET public function ExtractClusterIDs(
clusterIds : int[]
);

Parameters

clusterIds System.Int32[]. An integer array that will contain the cluster identifiers (IDs). The required size of the array is the value returned by PrtCompressedBuffer.NumberSamples.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractPca(Int32,Int32,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.ExtractPca Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts the per-sample principal component analysis (PCA) projection coefficients from a PrtCompressedBuffer object.

Definition

Visual Basic .NET Public Sub ExtractPca( _
ByVal startPca As Integer, _
ByVal numberExtract As Integer, _
ByVal pcaCoefficients() As Single _
)
C# public void ExtractPca(
int startPca,
int numberExtract,
float[] pcaCoefficients
);
Managed C++ public: void ExtractPca(
int startPca,
int numberExtract,
float pcaCoefficients __gc[]
);
JScript .NET public function ExtractPca(
startPca : int,
numberExtract : int,
pcaCoefficients : float[]
);

Parameters

startPca | System.Int32. Starting index for principal component analysis (PCA) projection coefficients to extract from the buffer.
numberExtract | System.Int32. Number of principal component analysis (PCA) projection coefficients to extract from the buffer.
pcaCoefficients | System.Single[]. Pointer to the location where clustered principal component analysis (CPCA) coefficients are written. The size of the data written is (Number of Samples) * (Number of PCA Coefficients).

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractTexture(Int32,Int32,Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.ExtractTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts the per-sample principal component analysis (PCA) projection coefficients from a PrtCompressedBuffer object and adds the data to a Texture object.

Definition

Visual Basic .NET Public Sub ExtractTexture( _
ByVal startPca As Integer, _
ByVal numberPca As Integer, _
ByVal texture As Texture _
)
C# public void ExtractTexture(
int startPca,
int numberPca,
Texture texture
);
Managed C++ public: void ExtractTexture(
int startPca,
int numberPca,
Texture *texture
);
JScript .NET public function ExtractTexture(
startPca : int,
numberPca : int,
texture : Texture
);

Parameters

startPca | System.Int32. Starting value of the buffer coefficient from which to extract texture data.
numberPca | System.Int32. Number of principal component analysis (PCA) coefficients to extract from the buffer.
texture | Microsoft.DirectX.Direct3D.Texture. A Texture object that will store principal component analysis (PCA) coefficients.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractToMesh(Int32,DeclarationUsage,Int32,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.ExtractToMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts the per-sample principal component analysis (PCA) projection coefficients from a PrtCompressedBuffer object and adds the data to a Mesh object.

Definition

Visual Basic .NET Public Sub ExtractToMesh( _
ByVal numberPca As Integer, _
ByVal usage As DeclarationUsage, _
ByVal usageIndexStart As Integer, _
ByVal scene As Mesh _
)
C# public void ExtractToMesh(
int numberPca,
DeclarationUsage usage,
int usageIndexStart,
Mesh scene
);
Managed C++ public: void ExtractToMesh(
int numberPca,
DeclarationUsage usage,
int usageIndexStart,
Mesh *scene
);
JScript .NET public function ExtractToMesh(
numberPca : int,
usage : DeclarationUsage,
usageIndexStart : int,
scene : Mesh
);

Parameters

numberPca | System.Int32. Number of principal component analysis (PCA) coefficients to extract from the buffer.
usage | Microsoft.DirectX.Direct3D.DeclarationUsage. Vertex usage descriptions of the mesh.
usageIndexStart | System.Int32. Starting index for principal component analysis (PCA) coefficients to be stored in the mesh.
scene | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that will store principal component analysis (PCA) coefficients.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the PrtCompressedBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~PrtCompressedBuffer();
Managed C++ | ~PrtCompressedBuffer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


PrtCompressedBuffer.FromFile(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads into memory a compressed precomputed radiance transfer (PRT) buffer that was saved to disk.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal filename As String _
) As PrtCompressedBuffer
C# public static PrtCompressedBuffer FromFile(
string filename
);
Managed C++ public: static PrtCompressedBuffer* FromFile(
String *filename
);
JScript .NET public static function FromFile(
filename : String
) : PrtCompressedBuffer;

Parameters

filename System.String. Name of the file from which to load the compressed buffer data.

Return Value

Microsoft.DirectX.Direct3D.PrtCompressedBuffer . Returns a PrtCompressedBuffer object that contains the compressed precomputed radiance transfer (PRT) buffer data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PrtCompressedBuffer.Save


PrtCompressedBuffer.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


PrtCompressedBuffer.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPRTCompBuffer, which allows unmanaged COM clients to create an instance of the managed PrtCompressedBuffer class. Not supported.


PrtCompressedBuffer.NormalizeData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.NormalizeData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Normalizes all principal component analysis (PCA) weights so that they are between -1 and 1. Basis vectors are modified to reflect this normalization.

Definition

Visual Basic .NET | Public Sub NormalizeData()
C# | public void NormalizeData();
Managed C++ | public: void NormalizeData();
JScript .NET | public function NormalizeData();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.op_Equality(PrtCompressedBuffer,PrtCompressedBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As PrtCompressedBuffer, _
ByVal right As PrtCompressedBuffer _
) As Boolean
C# public static bool op_Equality(
PrtCompressedBuffer left,
PrtCompressedBuffer right
);
Managed C++ public: static bool op_Equality(
PrtCompressedBuffer *left,
PrtCompressedBuffer *right
);
JScript .NET public static function op_Equality(
left : PrtCompressedBuffer,
right : PrtCompressedBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PrtCompressedBuffer. The PrtCompressedBuffer object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PrtCompressedBuffer. The PrtCompressedBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PrtCompressedBuffer.op_Inequality(PrtCompressedBuffer,PrtCompressedBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As PrtCompressedBuffer, _
ByVal right As PrtCompressedBuffer _
) As Boolean
C# public static bool op_Inequality(
PrtCompressedBuffer left,
PrtCompressedBuffer right
);
Managed C++ public: static bool op_Inequality(
PrtCompressedBuffer *left,
PrtCompressedBuffer *right
);
JScript .NET public static function op_Inequality(
left : PrtCompressedBuffer,
right : PrtCompressedBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PrtCompressedBuffer. The PrtCompressedBuffer object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PrtCompressedBuffer. The PrtCompressedBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


PrtCompressedBuffer.PrtCompressedBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtCompressedBuffer class.

Overload List

public PrtCompressedBuffer(CompressionQuality, int, int, PrtBuffer);
public PrtCompressedBuffer(ID3DXPRTCompBuffer);
public PrtCompressedBuffer(IntPtr);
public PrtCompressedBuffer(string);

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(ID3DXPRTCompBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXPRTCompBuffer _
)
C# public PrtCompressedBuffer(
ID3DXPRTCompBuffer pUnk
);
Managed C++ public: PrtCompressedBuffer(
ID3DXPRTCompBuffer pUnk
);
JScript .NET public function PrtCompressedBuffer(
pUnk : ID3DXPRTCompBuffer
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTCompBuffer. Unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface pointer.

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PrtCompressedBuffer(
IntPtr unmanagedObject
);
Managed C++ public: PrtCompressedBuffer(
IntPtr unmanagedObject
);
JScript .NET public function PrtCompressedBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal filename As String _
)
C# public PrtCompressedBuffer(
string filename
);
Managed C++ public: PrtCompressedBuffer(
String *filename
);
JScript .NET public function PrtCompressedBuffer(
filename : String
);

Parameters

filename System.String. Name of the file from which to load the buffer data.

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(CompressionQuality,Int32,Int32,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal quality As CompressionQuality, _
ByVal numberClusters As Integer, _
ByVal numberPca As Integer, _
ByVal buffer As PrtBuffer _
)
C# public PrtCompressedBuffer(
CompressionQuality quality,
int numberClusters,
int numberPca,
PrtBuffer buffer
);
Managed C++ public: PrtCompressedBuffer(
CompressionQuality quality,
int numberClusters,
int numberPca,
PrtBuffer *buffer
);
JScript .NET public function PrtCompressedBuffer(
quality : CompressionQuality,
numberClusters : int,
numberPca : int,
buffer : PrtBuffer
);

Parameters

quality | Microsoft.DirectX.Direct3D.CompressionQuality. Quality of spherical harmonic (SH) compression.
numberClusters | System.Int32. Number of clusters to use for compression.
numberPca | System.Int32. Number of principal component analysis (PCA) basis vectors to use in each cluster.
buffer | Microsoft.DirectX.Direct3D.PrtBuffer. Uncompressed PrtBuffer object to compress.

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


PrtCompressedBuffer.Save

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a compressed precomputed radiance transfer (PRT) buffer to disk.

Overload List

public static void Save(PrtCompressedBuffer, string);
public void Save(string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtCompressedBuffer.FromFile


PrtCompressedBuffer.Save(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a compressed precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic .NET Public Sub Save( _
ByVal filename As String _
)
C# public void Save(
string filename
);
Managed C++ public: void Save(
String *filename
);
JScript .NET public function Save(
filename : String
);

Parameters

filename System.String. Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtCompressedBuffer.FromFile


PrtCompressedBuffer.Save(PrtCompressedBuffer,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a compressed precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal buffer As PrtCompressedBuffer, _
ByVal filename As String _
)
C# public static void Save(
PrtCompressedBuffer buffer,
string filename
);
Managed C++ public: static void Save(
PrtCompressedBuffer *buffer,
String *filename
);
JScript .NET public static function Save(
buffer : PrtCompressedBuffer,
filename : String
);

Parameters

buffer | Microsoft.DirectX.Direct3D.PrtCompressedBuffer. PrtCompressedBuffer object to be saved.
filename | System.String. Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtCompressedBuffer.FromFile


PrtCompressedBuffer.UpdateUnmanagedPointer(ID3DXPRTCompBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this PrtCompressedBuffer object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPRTCompBuffer _
)
C# public void UpdateUnmanagedPointer(
ID3DXPRTCompBuffer pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXPRTCompBuffer pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXPRTCompBuffer
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTCompBuffer. Pointer to the ID3DXPRTCompBuffer structure used to update the unmanaged pointer for this PrtCompressedBuffer object.


PrtCompressedBuffer.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


PrtCompressedBuffer.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the height of the texture, in pixels.

Definition

Visual Basic .NET | Public ReadOnly Property Height As Integer
C# | public int Height { get; }
Managed C++ | public: __property int get_Height();
JScript .NET | public function get Height() : int

Property Value

System.Int32 . An integer that represents the height of the texture, in pixels.

This property is read-only.

See Also

  • PrtCompressedBuffer.Width


PrtCompressedBuffer.IsTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.IsTexture Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the compressed buffer contains a texture.

Definition

Visual Basic .NET | Public ReadOnly Property IsTexture As Boolean
C# | public bool IsTexture { get; }
Managed C++ | public: __property bool get_IsTexture();
JScript .NET | public function get IsTexture() : boolean

Property Value

System.Boolean . A value that is true if the compressed buffer contains a texture, or false if it does not.

This property is read-only.


PrtCompressedBuffer.NumberChannels

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.NumberChannels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of color channels used in memory to store samples.

Definition

Visual Basic .NET | Public ReadOnly Property NumberChannels As Integer
C# | public int NumberChannels { get; }
Managed C++ | public: __property int get_NumberChannels();
JScript .NET | public function get NumberChannels() : int

Property Value

System.Int32 . An integer that represents the number of color channels used in memory to store samples. The value generally will be either 1 to represent luminance values, or 3 to represent RGB values.

This property is read-only.


PrtCompressedBuffer.NumberClusters

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.NumberClusters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of clusters to use for compression.

Definition

Visual Basic .NET | Public ReadOnly Property NumberClusters As Integer
C# | public int NumberClusters { get; }
Managed C++ | public: __property int get_NumberClusters();
JScript .NET | public function get NumberClusters() : int

Property Value

System.Int32 . An integer that represents the number of clusters to use for compression.

This property is read-only.


PrtCompressedBuffer.NumberCoefficients

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.NumberCoefficients Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of scalars per color channel used in memory to store samples.

Definition

Visual Basic .NET | Public ReadOnly Property NumberCoefficients As Integer
C# | public int NumberCoefficients { get; }
Managed C++ | public: __property int get_NumberCoefficients();
JScript .NET | public function get NumberCoefficients() : int

Property Value

System.Int32 . An integer that represents the number of scalars per color channel used in memory to store samples.

This property is read-only.


PrtCompressedBuffer.NumberPcaVectors

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.NumberPcaVectors Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of principal component analysis (PCA) basis vectors to use in each cluster.

Definition

Visual Basic .NET | Public ReadOnly Property NumberPcaVectors As Integer
C# | public int NumberPcaVectors { get; }
Managed C++ | public: __property int get_NumberPcaVectors();
JScript .NET | public function get NumberPcaVectors() : int

Property Value

System.Int32 . An integer that represents the number of principal component analysis (PCA) basis vectors to use in each cluster.

This property is read-only.


PrtCompressedBuffer.NumberSamples

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.NumberSamples Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of vertices (or texels) sampled.

Definition

Visual Basic .NET | Public ReadOnly Property NumberSamples As Integer
C# | public int NumberSamples { get; }
Managed C++ | public: __property int get_NumberSamples();
JScript .NET | public function get NumberSamples() : int

Property Value

System.Int32 . An integer that represents the number of vertices (or texels) sampled.

This property is read-only.


PrtCompressedBuffer.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXPRTCompBuffer
C# | public ID3DXPRTCompBuffer UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXPRTCompBuffer get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXPRTCompBuffer

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTCompBuffer . Unmanaged ID3DXPRTCompBuffer interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


PrtCompressedBuffer.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the width of the texture, in pixels.

Definition

Visual Basic .NET | Public ReadOnly Property Width As Integer
C# | public int Width { get; }
Managed C++ | public: __property int get_Width();
JScript .NET | public function get Width() : int

Property Value

System.Int32 . An integer that represents the width of the texture, in pixels.

This property is read-only.

See Also

  • PrtCompressedBuffer.Height


PrtCompressedBuffer.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtCompressedBuffer.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the PrtCompressedBuffer object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PrtCompressedBuffer object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.PrtEngine

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine Class

Language:
Note: This documentation is preliminary and is subject to change.

The PrtEngine class is used to compute a precomputed radiance transfer (PRT) simulation. Its methods are typically used offline to compute per-vertex or per-texel transfer vectors in advance of real-time 3-D modeling.

Definition

Visual Basic .NET Public Class PrtEngine
Inherits MarshalByRefObject
Implements IDisposable
C# public class PrtEngine : MarshalByRefObject,
IDisposable
Managed C++ public __gc class PrtEngine : public MarshalByRefObject,
IDisposable
JScript .NET public class PrtEngine extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PrtEngine object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
ComputeBounce | Computes the source radiance resulting from a single bounce of interreflected light. This method can be used for any lit scene, including a SH-based PRT model.
ComputeBounceAdaptive | Computes the source radiance resulting from a single bounce of interreflected light, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the PRT signal. This method can be used for any lit scene, including a SH-based PRT model.
ComputeConvolutionCoefficients | Computes convolution coefficients relative to per-sample normal vectors to minimize the least-squares error with respect to input PRT data. The convolution coefficients can be used with skinned or transformed normals to model global effects on dynamic objects.
ComputeDirectLightingSphericalHarmonics | Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation.
ComputeDirectLightingSphericalHarmonicsAdaptive | Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a SH approximation, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the PRT signal.
ComputeDirectLightingSphericalHarmonicsGpu | Uses the graphics processing unit (GPU) to compute the direct-lighting contribution to 3-D objects where the source radiance is represented by a SH approximation. Computing the lighting on the GPU will generally be much faster than on the CPU.
ComputeSubsurfaceScattering | Computes the source radiance resulting from subsurface scattering, using material properties set by PrtEngine.SetMeshMaterials. This method can be used only for materials defined per-vertex in a mesh object.
static (Shared in Visual Basic .NET) ComputeSuperClusters | Used with compressed results of the vertex version of the PRT simulator. Generates "superclusters," which are groups of clusters that can be drawn in the same draw call. A greedy algorithm that minimizes overdraw is used to group the clusters.
ComputeVolumeSamples | Computes a projection of the direct lighting from the previous light bounce into SH basis vectors that represent incident radiance at specified locations.
ComputeVolumeSamplesDirectSphericalHarmonics | Computes a projection of distant lighting into SH basis vectors that represent incident radiance at specified locations.
static (Shared in Visual Basic .NET) ConcatenateMeshes | Concatenates a group of meshes into one common mesh. This method can optionally apply a matrix transformation to each input mesh and its texture coordinates.
Dispose | Immediately releases the unmanaged resources used by the PrtEngine object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
ExtractPerVertexAlbedo | Copies per-vertex albedo values from a mesh.
Finalize | Allows the PrtEngine object to free resources before it is destroyed by the garbage collector.
FreeBounceData | Frees memory used for temporary bounced-light simulation data.
FreeSubsurfaceScatteringData | Frees memory used for temporary subsurface light scattering simulation data.
GetAdaptedMesh | Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetVertexAlbedo | Retrieves albedo values of the mesh vertices.
MultiplyAlbedo | Multiplies each PRT vector by the per-vertex albedo.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PrtEngine | Initializes a new instance of the PrtEngine class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PrtEngine.Disposing event when called from within a derived class.
ResampleBuffer | Resamples an input PrtBuffer object and saves it to an output PrtBuffer object. This method can be used to convert a vertex buffer to a texture buffer and vice-versa. It can also be used to convert single-channel buffers to 3-channel buffers and vice-versa.
RobustMeshRefine | Subdivides faces on a mesh, allowing for conservative adaptive sampling that will not eliminate features on the mesh.
ScaleMeshChunk | Scales all the samples associated with a given submesh. The method is useful for computing subsurface scattering.
SetCallback | Sets a delegate to an optional callback method that computes the percentage of SH computations completed and gives the caller the option of aborting the simulator.
SetMeshMaterials | Sets mesh material properties in the 3-D scene. Use this method to specify subsurface scattering parameters.
SetPerTexelAlbedo | Sets an albedo value for each texel, overwriting previous albedo values.
SetPerTexelNormal | Sets a normal vector for each texel in a texture object. This method is used to store vertex normal vectors from a mesh (or interpolated vertex normals if pixel-based PRT is being computed).
SetPerVertexAlbedo | Sets an albedo value for each mesh vertex, overwriting previous albedo values.
SetSamplingInfo | Sets sampling properties used by the PRT simulator.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PrtEngine object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
NumberFaces | Retrieves the number of faces in the mesh, including any new faces added as a result of adaptive spatial sampling.
NumberVertices | Retrieves the number of vertices in the mesh, including any new vertices added as a result of adaptive spatial sampling.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPRTEngine interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PrtEngine

Remarks

To convert from RGB to luminance values, the following formula is used:

Luminance = R * 0.2125 + G * 0.7154 + B * 0.0721

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrtEngine.ComputeBounce(PrtBuffer,PrtBuffer,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeBounce Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the source radiance resulting from a single bounce of interreflected light. This method can be used for any lit scene, including a spherical harmonic (SH)-based precomputed radiance transfer (PRT) model.

Definition

Visual Basic .NET Public Sub ComputeBounce( _
ByVal bufferIn As PrtBuffer, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeBounce(
PrtBuffer bufferIn,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
Managed C++ public: void ComputeBounce(
PrtBuffer *bufferIn,
PrtBuffer *bufferOut,
PrtBuffer *dataComputed
);
JScript .NET public function ComputeBounce(
bufferIn : PrtBuffer,
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
bufferOut | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that models a single bounce of the interreflected light. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

The output does not include albedo, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each precomputed radiance transfer (PRT) vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.ComputeBounceAdaptive(PrtBuffer,Single,Single,Int32,PrtBuffer,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeBounceAdaptive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the source radiance resulting from a single bounce of interreflected light, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the precomputed radiance transfer (PRT) signal. This method can be used for any lit scene, including a spherical harmonic (SH)-based precomputed radiance transfer (PRT) model.

Definition

Visual Basic .NET Public Sub ComputeBounceAdaptive( _
ByVal bufferIn As PrtBuffer, _
ByVal adaptiveThreshold As Single, _
ByVal minEdgeLength As Single, _
ByVal maxSubDiv As Integer, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeBounceAdaptive(
PrtBuffer bufferIn,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
Managed C++ public: void ComputeBounceAdaptive(
PrtBuffer *bufferIn,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer *bufferOut,
PrtBuffer *dataComputed
);
JScript .NET public function ComputeBounceAdaptive(
bufferIn : PrtBuffer,
adaptiveThreshold : float,
minEdgeLength : float,
maxSubDiv : int,
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
adaptiveThreshold | System.Single. Threshold on the precomputed radiance transfer (PRT) vector to use for subdividing mesh vertices and faces. If less than 1e-6f, a default value of 1e-6f is specified.
minEdgeLength | System.Single. Minimum face edge length that will be generated in adaptive sampling. If the method determines that the value is too small, a model-dependent value is specified. If zero, a default value of 4 is specified.
maxSubDiv | System.Int32. Maximum level of subdivision of a face that will be used in adaptive sampling.
bufferOut | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that models a single bounce of the interreflected light. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.ComputeConvolutionCoefficients(PrtBuffer,Int32,Vector3[],PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeConvolutionCoefficients Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes convolution coefficients relative to per-sample normal vectors to minimize the least-squares error with respect to input precomputed radiance transfer (PRT) data. The convolution coefficients can be used with skinned or transformed normals to model global effects on dynamic objects.

Definition

Visual Basic .NET Public Sub ComputeConvolutionCoefficients( _
ByVal bufferIn As PrtBuffer, _
ByVal shOrder As Integer, _
ByVal normalData() As Vector3, _
ByVal bufferOut As PrtBuffer _
)
C# public void ComputeConvolutionCoefficients(
PrtBuffer bufferIn,
int shOrder,
Vector3[] normalData,
PrtBuffer bufferOut
);
Managed C++ public: void ComputeConvolutionCoefficients(
PrtBuffer *bufferIn,
int shOrder,
Vector3 normalData __gc[],
PrtBuffer *bufferOut
);
JScript .NET public function ComputeConvolutionCoefficients(
bufferIn : PrtBuffer,
shOrder : int,
normalData : Vector3[],
bufferOut : PrtBuffer
);

Parameters

bufferIn | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that represents the spherical harmonic (SH) precomputed radiance transfer (PRT) data.
shOrder | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
normalData | Microsoft.DirectX.Vector3[]. A Vector3 array to be filled with shader-optimal normal vectors for which convolution coefficients are optimized. This array must be the same size as the number of samples in bufferIn.
bufferOut | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that contains shOrder convolution coefficients per color channel per sample.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.ComputeDirectLightingSphericalHarmonics(Int32,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeDirectLightingSphericalHarmonics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation.

Definition

Visual Basic .NET Public Sub ComputeDirectLightingSphericalHarmonics( _
ByVal shOrder As Integer, _
ByVal data As PrtBuffer _
)
C# public void ComputeDirectLightingSphericalHarmonics(
int shOrder,
PrtBuffer data
);
Managed C++ public: void ComputeDirectLightingSphericalHarmonics(
int shOrder,
PrtBuffer *data
);
JScript .NET public function ComputeDirectLightingSphericalHarmonics(
shOrder : int,
data : PrtBuffer
);

Parameters

shOrder | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
data | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that models the direct lighting contribution with the spherical harmonic (SH) approximation. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

The output does not include albedo, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each precomputed radiance transfer (PRT) vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.ComputeDirectLightingSphericalHarmonicsAdaptive(Int32,Single,Single,Int32,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeDirectLightingSphericalHarmonicsAdaptive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the precomputed radiance transfer (PRT) signal.

Definition

Visual Basic .NET Public Sub ComputeDirectLightingSphericalHarmonicsAdaptive( _
ByVal shOrder As Integer, _
ByVal adaptiveThreshold As Single, _
ByVal minEdgeLength As Single, _
ByVal maxSubDiv As Integer, _
ByVal data As PrtBuffer _
)
C# public void ComputeDirectLightingSphericalHarmonicsAdaptive(
int shOrder,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer data
);
Managed C++ public: void ComputeDirectLightingSphericalHarmonicsAdaptive(
int shOrder,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer *data
);
JScript .NET public function ComputeDirectLightingSphericalHarmonicsAdaptive(
shOrder : int,
adaptiveThreshold : float,
minEdgeLength : float,
maxSubDiv : int,
data : PrtBuffer
);

Parameters

shOrder | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
adaptiveThreshold | System.Single. Threshold on the precomputed radiance transfer (PRT) vector to use for subdividing mesh vertices and faces. If less than 1e-6f, a default value of 1e-6f is specified.
minEdgeLength | System.Single. Minimum face edge length that will be generated in adaptive sampling. If the method determines that the value is too small, a model-dependent value is specified. If zero, a default value of 4 is specified.
maxSubDiv | System.Int32. Maximum level of subdivision of a face that will be used in adaptive sampling.
data | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that contains the output data. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.RobustMeshRefine


PrtEngine.ComputeDirectLightingSphericalHarmonicsGpu(Device,GpuSimulatorOption,Int32,Single,Single,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeDirectLightingSphericalHarmonicsGpu Method

 Language:
Note: This documentation is preliminary and is subject to change.

Uses the graphics processing unit (GPU) to compute the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation. Computing the lighting on the graphics processing unit (GPU) will generally be much faster than on the CPU.

Definition

Visual Basic .NET Public Sub ComputeDirectLightingSphericalHarmonicsGpu( _
ByVal device As Device, _
ByVal flags As GpuSimulatorOption, _
ByVal shOrder As Integer, _
ByVal zbias As Single, _
ByVal zangleBias As Single, _
ByVal data As PrtBuffer _
)
C# public void ComputeDirectLightingSphericalHarmonicsGpu(
Device device,
GpuSimulatorOption flags,
int shOrder,
float zbias,
float zangleBias,
PrtBuffer data
);
Managed C++ public: void ComputeDirectLightingSphericalHarmonicsGpu(
Device *device,
GpuSimulatorOption flags,
int shOrder,
float zbias,
float zangleBias,
PrtBuffer *data
);
JScript .NET public function ComputeDirectLightingSphericalHarmonicsGpu(
device : Device,
flags : GpuSimulatorOption,
shOrder : int,
zbias : float,
zangleBias : float,
data : PrtBuffer
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device used to run the simulation on the graphics processing unit (GPU). The device must support pixel shader version 2.0 or higher.
flags | Microsoft.DirectX.Direct3D.GpuSimulatorOption. The graphics processing unit (GPU) simulation parameter that defines the resolution of the shadow z-buffer. Should be set to one of the GpuSimulatorOption enumeration values. To specifiy higher precision simulation, the GpuSimulatorOption.HighQuality value may be combined with one of the GpuSimulatorOption.ShadowResxxxx values.
shOrder | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
zbias | System.Single. Bias in the normal direction.
zangleBias | System.Single. Bias in the normal direction, scaled by one minus the cosine of the angle with the light ray.
data | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that contains the output data. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

In this method, the albedo is not multiplied by the light signal, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each precomputed radiance transfer (PRT) vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.ComputeSubsurfaceScattering(PrtBuffer,PrtBuffer,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeSubsurfaceScattering Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the source radiance resulting from subsurface scattering, using material properties set by PrtEngine.SetMeshMaterials. This method can be used only for materials defined per-vertex in a mesh object.

Definition

Visual Basic .NET Public Sub ComputeSubsurfaceScattering( _
ByVal bufferIn As PrtBuffer, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeSubsurfaceScattering(
PrtBuffer bufferIn,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
Managed C++ public: void ComputeSubsurfaceScattering(
PrtBuffer *bufferIn,
PrtBuffer *bufferOut,
PrtBuffer *dataComputed
);
JScript .NET public function ComputeSubsurfaceScattering(
bufferIn : PrtBuffer,
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
bufferOut | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that models a single bounce of the subsurface-scattered light. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

To model subsurface scattering, call this method for each bounce after a PrtEngine.ComputeDirectLighting... method is called.

The output does not include albedo, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each precomputed radiance transfer (PRT) vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.ComputeSuperClusters(Int32[],Mesh,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeSuperClusters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Used with compressed results of the vertex version of the precomputed radiance transfer (PRT) simulator. Generates "superclusters," which are groups of clusters that can be drawn in the same draw call. A greedy algorithm that minimizes overdraw is used to group the clusters.

Definition

Visual Basic .NET Public Shared Function ComputeSuperClusters( _
ByVal clusterIds() As Integer, _
ByVal scene As Mesh, _
ByVal maxNumberClusters As Integer, _
ByVal superClusterIds() As Integer _
) As Integer
C# public static int ComputeSuperClusters(
int[] clusterIds,
Mesh scene,
int maxNumberClusters,
int[] superClusterIds
);
Managed C++ public: static int ComputeSuperClusters(
int clusterIds __gc[],
Mesh *scene,
int maxNumberClusters,
int superClusterIds __gc[]
);
JScript .NET public static function ComputeSuperClusters(
clusterIds : int[],
scene : Mesh,
maxNumberClusters : int,
superClusterIds : int[]
) : int;

Parameters

clusterIds | System.Int32[]. An array of cluster identifiers (IDs) extracted from a compressed buffer by calling PrtCompressedBuffer.ExtractClusterIDs.
scene | Microsoft.DirectX.Direct3D.Mesh. A Mesh that represents the composite scene passed to the simulator.
maxNumberClusters | System.Int32. Maximum number of clusters allocated per super cluster.
superClusterIds | System.Int32[]. An integer array that contains the index of the super cluster to which the corresponding cluster was assigned.

Return Value

System.Int32 . Number of super clusters allocated.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.ComputeVolumeSamples(PrtBuffer,Int32,Vector3[],PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeVolumeSamples Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a projection of the direct lighting from the previous light bounce into spherical harmonic (SH) basis vectors that represent incident radiance at specified locations.

Definition

Visual Basic .NET Public Sub ComputeVolumeSamples( _
ByVal previousData As PrtBuffer, _
ByVal shOrder As Integer, _
ByVal sampleLocations() As Vector3, _
ByVal dataOut As PrtBuffer _
)
C# public void ComputeVolumeSamples(
PrtBuffer previousData,
int shOrder,
Vector3[] sampleLocations,
PrtBuffer dataOut
);
Managed C++ public: void ComputeVolumeSamples(
PrtBuffer *previousData,
int shOrder,
Vector3 sampleLocations __gc[],
PrtBuffer *dataOut
);
JScript .NET public function ComputeVolumeSamples(
previousData : PrtBuffer,
shOrder : int,
sampleLocations : Vector3[],
dataOut : PrtBuffer
);

Parameters

previousData | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that represents the 3-D object from the previous light bounce. This buffer must have the proper number of color channels allocated for the simulation.
shOrder | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
sampleLocations | Microsoft.DirectX.Vector3[]. An integer array that contains the position for each sample.
dataOut | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that projects the direct lighting from the previous light bounce into spherical harmonic (SH) basis vectors. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

This method computes how the light from the source radiance function is reflected off the surface that represents the scene (previousData) and arrives at each point in space specified by sampleLocations. The spherical harmonic (SH) coefficients represent the mapping, at each sampleLocations point, of source radiance to transferred incident radiance.

To use this method successfully, you must set sampling over a sphere with the parameter isUsingSphere set to true and the parameter isUsingCosine set to false in a call to PrtEngine.SetSamplingInfo, otherwise an exception is thrown.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeVolumeSamplesDirectSphericalHarmonics


PrtEngine.ComputeVolumeSamplesDirectSphericalHarmonics(Int32,Int32,Vector3[],PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ComputeVolumeSamplesDirectSphericalHarmonics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a projection of distant lighting into spherical harmonic (SH) basis vectors that represent incident radiance at specified locations.

Definition

Visual Basic .NET Public Sub ComputeVolumeSamplesDirectSphericalHarmonics( _
ByVal shOrderIn As Integer, _
ByVal shOrder As Integer, _
ByVal sampleLocations() As Vector3, _
ByVal dataOut As PrtBuffer _
)
C# public void ComputeVolumeSamplesDirectSphericalHarmonics(
int shOrderIn,
int shOrder,
Vector3[] sampleLocations,
PrtBuffer dataOut
);
Managed C++ public: void ComputeVolumeSamplesDirectSphericalHarmonics(
int shOrderIn,
int shOrder,
Vector3 sampleLocations __gc[],
PrtBuffer *dataOut
);
JScript .NET public function ComputeVolumeSamplesDirectSphericalHarmonics(
shOrderIn : int,
shOrder : int,
sampleLocations : Vector3[],
dataOut : PrtBuffer
);

Parameters

shOrderIn | System.Int32. Order of the spherical harmonic (SH) representation of distant lighting. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is shOrderIn - 1.
shOrder | System.Int32. Order of the spherical harmonic (SH) representation of local lighting. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is shOrder - 1.
sampleLocations | Microsoft.DirectX.Vector3[]. An integer array that contains the position for each sample.
dataOut | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object that projects the distant lighting into spherical harmonic (SH) basis vectors. This buffer must have the proper number of color channels allocated for the simulation. This method generates shOrderIn2 * shOrder2 scalars per channel at each sample location.

Remarks

This method computes how light from a distant source arrives at each point in space specified by sampleLocations. The spherical harmonic (SH) coefficients represent the mapping, at each sampleLocations point, of source radiance to transferred incident radiance.

To use this method successfully, you must set sampling over a sphere with the parameter isUsingSphere set to true and the parameter isUsingCosine set to false in a call to PrtEngine.SetSamplingInfo, otherwise an exception is thrown.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeVolumeSamples


PrtEngine.ConcatenateMeshes(Mesh[],MeshFlags,Matrix[],Matrix[],VertexElement[],Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ConcatenateMeshes Method

 Language:
Note: This documentation is preliminary and is subject to change.

Concatenates a group of meshes into one common mesh. This method can optionally apply a matrix transformation to each input mesh and its texture coordinates.

Definition

Visual Basic .NET Public Shared Function ConcatenateMeshes( _
ByVal meshes() As Mesh, _
ByVal options As MeshFlags, _
ByVal geometryTransforms() As Matrix, _
ByVal textureTransforms() As Matrix, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As Mesh
C# public static Mesh ConcatenateMeshes(
Mesh[] meshes,
MeshFlags options,
Matrix[] geometryTransforms,
Matrix[] textureTransforms,
VertexElement[] declaration,
Device device
);
Managed C++ public: static Mesh* ConcatenateMeshes(
Mesh *meshes __gc[],
MeshFlags options,
Matrix geometryTransforms __gc[],
Matrix textureTransforms __gc[],
VertexElement declaration __gc[],
Device *device
);
JScript .NET public static function ConcatenateMeshes(
meshes : Mesh[],
options : MeshFlags,
geometryTransforms : Matrix[],
textureTransforms : Matrix[],
declaration : VertexElement[],
device : Device
) : Mesh;

Parameters

meshes | Microsoft.DirectX.Direct3D.Mesh[]. An array of Mesh objects to concatenate. These meshes can store precomputed radiance transfer (PRT) vectors.
options | Microsoft.DirectX.Direct3D.MeshFlags. Combination of one or more flags from the MeshFlags enumeration, specifying creation options for the output mesh. Equivalent to the options parameter of the Mesh constructor.
geometryTransforms | Microsoft.DirectX.Matrix[]. A geometry transformation Matrix array to apply to each submesh.
textureTransforms | Microsoft.DirectX.Matrix[]. A texture transformation Matrix array to apply to the (u, v) coordinates of each submesh.
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. An array of VertexElement objects representing the vertex declaration to use for merging mesh data.
device | Microsoft.DirectX.Direct3D.Device. A Device that is used to create the new mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . An Mesh object that represents the concatenated meshes.

Remarks

If no vertex declaration is given as part of the options parameter in the Mesh constructor, the method will generate a union of all of the vertex declarations of the submeshes, promoting channels and types if necessary.

The method will create an attribute table from attribute tables of the input meshes. To ensure creation of an attribute table, call ProgressiveMesh.Optimize with flags set to MeshFlags.OptimizeCompact and MeshFlags.OptimizeAttributeSort.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the PrtEngine object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PrtEngine.Disposed
  • Microsoft.DirectX.Direct3D.PrtEngine.Disposing


PrtEngine.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PrtEngine.ExtractPerVertexAlbedo(Mesh,DeclarationUsage,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ExtractPerVertexAlbedo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies per-vertex albedo values from a mesh.

Definition

Visual Basic .NET Public Sub ExtractPerVertexAlbedo( _
ByVal mesh As Mesh, _
ByVal usage As DeclarationUsage, _
ByVal numberChannels As Integer _
)
C# public void ExtractPerVertexAlbedo(
Mesh mesh,
DeclarationUsage usage,
int numberChannels
);
Managed C++ public: void ExtractPerVertexAlbedo(
Mesh *mesh,
DeclarationUsage usage,
int numberChannels
);
JScript .NET public function ExtractPerVertexAlbedo(
mesh : Mesh,
usage : DeclarationUsage,
numberChannels : int
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. The Mesh object used to create the PrtEngine.
usage | Microsoft.DirectX.Direct3D.DeclarationUsage. Vertex DeclarationUsage descriptions to copy from the mesh.
numberChannels | System.Int32. Number of color channels to copy from the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the PrtEngine object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~PrtEngine();
Managed C++ | ~PrtEngine();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


PrtEngine.FreeBounceData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.FreeBounceData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Frees memory used for temporary bounced-light simulation data.

Definition

Visual Basic .NET | Public Sub FreeBounceData()
C# | public void FreeBounceData();
Managed C++ | public: void FreeBounceData();
JScript .NET | public function FreeBounceData();


PrtEngine.FreeSubsurfaceScatteringData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.FreeSubsurfaceScatteringData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Frees memory used for temporary subsurface light scattering simulation data.

Definition

Visual Basic .NET | Public Sub FreeSubsurfaceScatteringData()
C# | public void FreeSubsurfaceScatteringData();
Managed C++ | public: void FreeSubsurfaceScatteringData();
JScript .NET | public function FreeSubsurfaceScatteringData();


PrtEngine.GetAdaptedMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetAdaptedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Overload List

public Mesh GetAdaptedMesh(Device);
public Mesh GetAdaptedMesh(Device, int[]);
public Mesh GetAdaptedMesh(Device, int[], int[], float[]);
public Mesh GetAdaptedMesh(Device, int[], float[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetAdaptedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic .NET Public Function GetAdaptedMesh( _
ByVal device As Device _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device
);
Managed C++ public: Mesh* GetAdaptedMesh(
Device *device
);
JScript .NET public function GetAdaptedMesh(
device : Device
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device. The Device used to create the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . The output Mesh object.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device,Int32[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetAdaptedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic .NET Public Function GetAdaptedMesh( _
ByVal device As Device, _
ByVal vertRemap() As Integer, _
ByVal vertWeights() As Single _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device,
int[] vertRemap,
float[] vertWeights
);
Managed C++ public: Mesh* GetAdaptedMesh(
Device *device,
int vertRemap __gc[],
float vertWeights __gc[]
);
JScript .NET public function GetAdaptedMesh(
device : Device,
vertRemap : int[],
vertWeights : float[]
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device used to create the output mesh.
vertRemap | System.Int32[]. A destination array containing the three original mesh vertices that are the parents of the current vertex.
vertWeights | System.Single[]. A destination array containing blending factors for the vertRemap vertices.

Return Value

Microsoft.DirectX.Direct3D.Mesh . The output Mesh object.

Remarks

vertRemap and vertWeights can be used to interpolate any per-vertex value over the mesh.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetAdaptedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic .NET Public Function GetAdaptedMesh( _
ByVal device As Device, _
ByVal faceRemap() As Integer _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device,
int[] faceRemap
);
Managed C++ public: Mesh* GetAdaptedMesh(
Device *device,
int faceRemap __gc[]
);
JScript .NET public function GetAdaptedMesh(
device : Device,
faceRemap : int[]
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device used to create the output mesh.
faceRemap | System.Int32[]. The original mesh face that was split to generate the current face.

Return Value

Microsoft.DirectX.Direct3D.Mesh . The output Mesh object.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device,Int32[],Int32[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetAdaptedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic .NET Public Function GetAdaptedMesh( _
ByVal device As Device, _
ByVal faceRemap() As Integer, _
ByVal vertRemap() As Integer, _
ByVal vertWeights() As Single _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device,
int[] faceRemap,
int[] vertRemap,
float[] vertWeights
);
Managed C++ public: Mesh* GetAdaptedMesh(
Device *device,
int faceRemap __gc[],
int vertRemap __gc[],
float vertWeights __gc[]
);
JScript .NET public function GetAdaptedMesh(
device : Device,
faceRemap : int[],
vertRemap : int[],
vertWeights : float[]
) : Mesh;

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device used to create the output mesh.
faceRemap | System.Int32[]. The original mesh face that was split to generate the current face.
vertRemap | System.Int32[]. A destination array containing the three original mesh vertices that are the parents of the current vertex.
vertWeights | System.Single[]. A destination array containing blending factors for the vertRemap vertices.

Return Value

Microsoft.DirectX.Direct3D.Mesh . The output Mesh object.

Remarks

vertRemap and vertWeights can be used to interpolate any per-vertex value over the mesh.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


PrtEngine.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPRTEngine, which allows unmanaged COM clients to create an instance of the managed PrtEngine class. Not supported.


PrtEngine.GetVertexAlbedo(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.GetVertexAlbedo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves albedo values of the mesh vertices.

Definition

Visual Basic .NET Public Function GetVertexAlbedo( _
ByVal numberVerts As Integer _
) As ColorValue()
C# public ColorValue[] GetVertexAlbedo(
int numberVerts
);
Managed C++ public: ColorValue GetVertexAlbedo(
int numberVerts
) __gc[];
JScript .NET public function GetVertexAlbedo(
numberVerts : int
) : ColorValue[];

Parameters

numberVerts System.Int32. Number of vertices in the mesh.

Return Value

Microsoft.DirectX.Direct3D.ColorValue[]. A ColorValue array that contains albedo values of the mesh vertices.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.MultiplyAlbedo(PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.MultiplyAlbedo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies each precomputed radiance transfer (PRT) vector by the per-vertex albedo.

Definition

Visual Basic .NET Public Sub MultiplyAlbedo( _
ByVal data As PrtBuffer _
)
C# public void MultiplyAlbedo(
PrtBuffer data
);
Managed C++ public: void MultiplyAlbedo(
PrtBuffer *data
);
JScript .NET public function MultiplyAlbedo(
data : PrtBuffer
);

Parameters

data Microsoft.DirectX.Direct3D.PrtBuffer. An output PrtBuffer object that will contain precomputed radiance transfer (PRT) vectors multiplied by the per-vertex albedo.

Remarks

If this output buffer is a texture object, then care must be taken to store the albedo of the texture at the same resolution as the simulation buffer.

The Compute... methods compute output buffers in which the light signal has not been multiplied by albedo. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

To include albedo in the rendered light model, call this method after one of the Compute... methods.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeDirectLightingSphericalHarmonics


PrtEngine.op_Equality(PrtEngine,PrtEngine)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As PrtEngine, _
ByVal right As PrtEngine _
) As Boolean
C# public static bool op_Equality(
PrtEngine left,
PrtEngine right
);
Managed C++ public: static bool op_Equality(
PrtEngine *left,
PrtEngine *right
);
JScript .NET public static function op_Equality(
left : PrtEngine,
right : PrtEngine
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PrtEngine. The PrtEngine object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PrtEngine. The PrtEngine object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


PrtEngine.op_Inequality(PrtEngine,PrtEngine)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As PrtEngine, _
ByVal right As PrtEngine _
) As Boolean
C# public static bool op_Inequality(
PrtEngine left,
PrtEngine right
);
Managed C++ public: static bool op_Inequality(
PrtEngine *left,
PrtEngine *right
);
JScript .NET public static function op_Inequality(
left : PrtEngine,
right : PrtEngine
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.PrtEngine. The PrtEngine object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.PrtEngine. The PrtEngine object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


PrtEngine.PrtEngine

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.PrtEngine Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtEngine class.

Overload List

public PrtEngine(ID3DXPRTEngine);
public PrtEngine(IntPtr);
public PrtEngine(Mesh, bool, Mesh);

Remarks

The PrtEngine class efficiently generates precomputed radiance transfer (PRT) simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.PrtEngine(ID3DXPRTEngine)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.PrtEngine Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtEngine class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXPRTEngine _
)
C# public PrtEngine(
ID3DXPRTEngine pUnk
);
Managed C++ public: PrtEngine(
ID3DXPRTEngine pUnk
);
JScript .NET public function PrtEngine(
pUnk : ID3DXPRTEngine
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTEngine. Unmanaged Component Object Model (COM) ID3DXPRTEngine interface pointer.

Remarks

The PrtEngine class efficiently generates precomputed radiance transfer (PRT) simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.PrtEngine(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.PrtEngine Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtEngine class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PrtEngine(
IntPtr unmanagedObject
);
Managed C++ public: PrtEngine(
IntPtr unmanagedObject
);
JScript .NET public function PrtEngine(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXPRTEngine interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The PrtEngine class efficiently generates precomputed radiance transfer (PRT) simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.PrtEngine(Mesh,Boolean,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.PrtEngine Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtEngine class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal extractUvs As Boolean, _
ByVal blockerMesh As Mesh _
)
C# public PrtEngine(
Mesh mesh,
bool extractUvs,
Mesh blockerMesh
);
Managed C++ public: PrtEngine(
Mesh *mesh,
bool extractUvs,
Mesh *blockerMesh
);
JScript .NET public function PrtEngine(
mesh : Mesh,
extractUvs : boolean,
blockerMesh : Mesh
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. An input Mesh object that models the 3-D scene. This mesh must have an attribute table in which vertices are in a unique attribute.
extractUvs | System.Boolean. Set to true if textures will be used to store albedos or precomputed radiance transfer (PRT) vectors; otherwise, false.
blockerMesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that blocks the 3-D scene.

Remarks

The PrtEngine class efficiently generates precomputed radiance transfer (PRT) simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.PrtEngine.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


PrtEngine.ResampleBuffer(PrtBuffer,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ResampleBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resamples an input PrtBuffer object and saves it to an output PrtBuffer object. This method can be used to convert a vertex buffer to a texture buffer and vice-versa. It can also be used to convert single-channel buffers to 3-channel buffers and vice-versa.

Definition

Visual Basic .NET Public Sub ResampleBuffer( _
ByVal bufferIn As PrtBuffer, _
ByVal bufferOut As PrtBuffer _
)
C# public void ResampleBuffer(
PrtBuffer bufferIn,
PrtBuffer bufferOut
);
Managed C++ public: void ResampleBuffer(
PrtBuffer *bufferIn,
PrtBuffer *bufferOut
);
JScript .NET public function ResampleBuffer(
bufferIn : PrtBuffer,
bufferOut : PrtBuffer
);

Parameters

bufferIn | Microsoft.DirectX.Direct3D.PrtBuffer. The input PrtBuffer object.
bufferOut | Microsoft.DirectX.Direct3D.PrtBuffer. The output PrtBuffer object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.RobustMeshRefine(Single,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.RobustMeshRefine Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subdivides faces on a mesh, allowing for conservative adaptive sampling that will not eliminate features on the mesh.

Definition

Visual Basic .NET Public Sub RobustMeshRefine( _
ByVal minEdgeLength As Single, _
ByVal maxSubDiv As Integer _
)
C# public void RobustMeshRefine(
float minEdgeLength,
int maxSubDiv
);
Managed C++ public: void RobustMeshRefine(
float minEdgeLength,
int maxSubDiv
);
JScript .NET public function RobustMeshRefine(
minEdgeLength : float,
maxSubDiv : int
);

Parameters

minEdgeLength | System.Single. Minimum face edge length that will be generated in adaptive sampling. If zero, a reasonable default value will be substituted.
maxSubDiv | System.Int32. Maximum level of subdivision of a face that will be used in adaptive sampling. If zero, a default value of 5 will be substituted.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeBounceAdaptive
  • PrtEngine.ComputeDirectLightingSphericalHarmonicsAdaptive


PrtEngine.ScaleMeshChunk(Int32,Single,PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.ScaleMeshChunk Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales all the samples associated with a given submesh. The method is useful for computing subsurface scattering.

Definition

Visual Basic .NET Public Sub ScaleMeshChunk( _
ByVal meshChunk As Integer, _
ByVal scale As Single, _
ByVal data As PrtBuffer _
)
C# public void ScaleMeshChunk(
int meshChunk,
float scale,
PrtBuffer data
);
Managed C++ public: void ScaleMeshChunk(
int meshChunk,
float scale,
PrtBuffer *data
);
JScript .NET public function ScaleMeshChunk(
meshChunk : int,
scale : float,
data : PrtBuffer
);

Parameters

meshChunk | System.Int32. Location in the mesh at which to start scaling samples.
scale | System.Single. Value by which to multiply each vector in the submesh.
data | Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object to receive rescaled samples in the submesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.SetCallback(PrtEngineCallback,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.SetCallback Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a delegate to an optional callback method that computes the percentage of spherical harmonic (SH) computations completed and gives the caller the option of aborting the simulator.

Definition

Visual Basic .NET Public Sub SetCallback( _
ByVal callback As PrtEngineCallback, _
ByVal frequency As Single _
)
C# public void SetCallback(
PrtEngineCallback callback,
float frequency
);
Managed C++ public: void SetCallback(
PrtEngineCallback *callback,
float frequency
);
JScript .NET public function SetCallback(
callback : PrtEngineCallback,
frequency : float
);

Parameters

callback | Microsoft.DirectX.Direct3D.PrtEngineCallback. A PrtEngineCallback delegate to assign as the callback method.
frequency | System.Single. Frequency of callback calls. The inverse of frequency is approximately the number of times the callback method will be called.


PrtEngine.SetMeshMaterials(SphericalHarmonicMaterial[],Int32,Boolean,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.SetMeshMaterials Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets mesh material properties in the 3-D scene. Use this method to specify subsurface scattering parameters.

Definition

Visual Basic .NET Public Sub SetMeshMaterials( _
ByVal materials() As SphericalHarmonicMaterial, _
ByVal numberChannels As Integer, _
ByVal setAlbedo As Boolean, _
ByVal lengthScale As Single _
)
C# public void SetMeshMaterials(
SphericalHarmonicMaterial[] materials,
int numberChannels,
bool setAlbedo,
float lengthScale
);
Managed C++ public: void SetMeshMaterials(
SphericalHarmonicMaterial materials __gc[],
int numberChannels,
bool setAlbedo,
float lengthScale
);
JScript .NET public function SetMeshMaterials(
materials : SphericalHarmonicMaterial[],
numberChannels : int,
setAlbedo : boolean,
lengthScale : float
);

Parameters

materials | Microsoft.DirectX.Direct3D.SphericalHarmonicMaterial[]. An array of SphericalHarmonicMaterial structures that contain the mesh material properties to set.
numberChannels | System.Int32. Number of color channels to set in the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects. If you intend to change this parameter, first set the albedo using another method such as PrtEngine.SetPerTexelAlbedo or PrtEngine.SetPerVertexAlbedo.
setAlbedo | System.Boolean. Set to true to set the albedo of the mesh to materials, overwriting all existing texel and vertex albedo values. Set to false to preserve all existing texel and vertex albedo values set by other methods; numberChannels must match the numberChannels parameter of the PrtBuffer constructor used to create the buffer.
lengthScale | System.Single. Scale of the 3-D scene relative to a 1 mm cube. Used for subsurface scattering computations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.SetPerTexelAlbedo(Texture,Int32,TextureGutterHelper)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.SetPerTexelAlbedo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an albedo value for each texel, overwriting previous albedo values.

Definition

Visual Basic .NET Public Sub SetPerTexelAlbedo( _
ByVal albedoTexture As Texture, _
ByVal numberChannels As Integer, _
ByVal gutterHelper As TextureGutterHelper _
)
C# public void SetPerTexelAlbedo(
Texture albedoTexture,
int numberChannels,
TextureGutterHelper gutterHelper
);
Managed C++ public: void SetPerTexelAlbedo(
Texture *albedoTexture,
int numberChannels,
TextureGutterHelper *gutterHelper
);
JScript .NET public function SetPerTexelAlbedo(
albedoTexture : Texture,
numberChannels : int,
gutterHelper : TextureGutterHelper
);

Parameters

albedoTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object in which to store albedo values.
numberChannels | System.Int32. Number of color channels to set. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.
gutterHelper | Microsoft.DirectX.Direct3D.TextureGutterHelper. A TextureGutterHelper object used to set gutter regions for the texture.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
WasStillDrawingException | The previous blit operation that is transferring information to or from this surface is incomplete.


PrtEngine.SetPerTexelNormal(Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.SetPerTexelNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a normal vector for each texel in a texture object. This method is used to store vertex normal vectors from a mesh (or interpolated vertex normals if pixel-based precomputed radiance transfer (PRT) is being computed).

Definition

Visual Basic .NET Public Sub SetPerTexelNormal( _
ByVal normalTexture As Texture _
)
C# public void SetPerTexelNormal(
Texture normalTexture
);
Managed C++ public: void SetPerTexelNormal(
Texture *normalTexture
);
JScript .NET public function SetPerTexelNormal(
normalTexture : Texture
);

Parameters

normalTexture Microsoft.DirectX.Direct3D.Texture. A Texture object that serves as an object space normal map in which to store normal vectors. The texture must have the same dimensions as PrtBuffer and must be able to store signed texture formats.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.SetPerVertexAlbedo(Array,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.SetPerVertexAlbedo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets an albedo value for each mesh vertex, overwriting previous albedo values.

Definition

Visual Basic .NET Public Sub SetPerVertexAlbedo( _
ByVal dataIn As Array, _
ByVal numberChannel As Integer _
)
C# public void SetPerVertexAlbedo(
Array dataIn,
int numberChannel
);
Managed C++ public: void SetPerVertexAlbedo(
Array *dataIn,
int numberChannel
);
JScript .NET public function SetPerVertexAlbedo(
dataIn : Array,
numberChannel : int
);

Parameters

dataIn | System.Array. An array of albedo data of the first sample.
numberChannel | System.Int32. Number of color channels to set. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.SetSamplingInfo(Int32,Boolean,Boolean,Boolean,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.SetSamplingInfo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets sampling properties used by the precomputed radiance transfer (PRT) simulator.

Definition

Visual Basic .NET Public Sub SetSamplingInfo( _
ByVal numberRays As Integer, _
ByVal isUsingSphere As Boolean, _
ByVal isUsingCosine As Boolean, _
ByVal isAdaptive As Boolean, _
ByVal adaptiveThreshold As Single _
)
C# public void SetSamplingInfo(
int numberRays,
bool isUsingSphere,
bool isUsingCosine,
bool isAdaptive,
float adaptiveThreshold
);
Managed C++ public: void SetSamplingInfo(
int numberRays,
bool isUsingSphere,
bool isUsingCosine,
bool isAdaptive,
float adaptiveThreshold
);
JScript .NET public function SetSamplingInfo(
numberRays : int,
isUsingSphere : boolean,
isUsingCosine : boolean,
isAdaptive : boolean,
adaptiveThreshold : float
);

Parameters

numberRays | System.Int32. Number of light rays to direct at each sample. Must be greater than zero.
isUsingSphere | System.Boolean. Set to true if samples will be computed over a full sphere. Set to false if samples will be computed over a hemisphere.
isUsingCosine | System.Boolean. Set to true to use a cosine weighting of samples. If both isUsingCosine and isUsingSphere are true, the method will fail.
isAdaptive | System.Boolean. Must be false. Adaptive sampling is currently not implemented.
adaptiveThreshold | System.Single. Ignored.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotImplementedException Leave Site | Not implemented.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


PrtEngine.UpdateUnmanagedPointer(ID3DXPRTEngine)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this PrtEngine object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPRTEngine _
)
C# public void UpdateUnmanagedPointer(
ID3DXPRTEngine pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXPRTEngine pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXPRTEngine
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTEngine. Pointer to the ID3DXPRTEngine structure used to update the unmanaged pointer for this PrtEngine object.


PrtEngine.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


PrtEngine.NumberFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.NumberFaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of faces in the mesh, including any new faces added as a result of adaptive spatial sampling.

Definition

Visual Basic .NET | Public ReadOnly Property NumberFaces As Integer
C# | public int NumberFaces { get; }
Managed C++ | public: __property int get_NumberFaces();
JScript .NET | public function get NumberFaces() : int

Property Value

System.Int32 . Number of faces in the mesh, including any new faces added as a result of adaptive sampling.

This property is read-only.


PrtEngine.NumberVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.NumberVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of vertices in the mesh, including any new vertices added as a result of adaptive spatial sampling.

Definition

Visual Basic .NET | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
Managed C++ | public: __property int get_NumberVertices();
JScript .NET | public function get NumberVertices() : int

Property Value

System.Int32 . Number of vertices in the mesh, including any new vertices added as a result of adaptive sampling.

This property is read-only.


PrtEngine.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXPRTEngine interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXPRTEngine
C# | public ID3DXPRTEngine UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXPRTEngine get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXPRTEngine

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTEngine . Unmanaged ID3DXPRTEngine interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


PrtEngine.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngine.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the PrtEngine object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PrtEngine.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PrtEngine object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.Query

Microsoft DirectX 9.0 SDK Update (October 2004)

Query Class

Language:
Note: This documentation is preliminary and is subject to change.

Performs asynchronous queries on a driver.

Definition

Visual Basic .NET NotInheritable Public Class Query
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class Query : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class Query : public MarshalByRefObject,
IDisposable
JScript .NET public class Query extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Query object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Query object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Query object to free resources before it is destroyed by the garbage collector.
GetData | Retrieves the query information.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
Issue | Issues a query.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Query | Initializes a new instance of the Query class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Query.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Query object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Device for the current query.
Disposed | Gets a value that indicates whether the object is disposed.
QueryType | Retrieves the query type for the current query.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Query

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Query.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Query object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Query.Disposed
  • Microsoft.DirectX.Direct3D.Query.Disposing


Query.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Query.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Query object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Query();
Managed C++ | ~Query();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Query.GetData

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.GetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the query information.

Overload List

public object GetData(Type, bool);
public object GetData(Type, bool, out bool);


Query.GetData(Type,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.GetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the query information.

Definition

Visual Basic .NET Public Function GetData( _
ByVal returnDataType As Type, _
ByVal flush As Boolean _
) As Object
C# public object GetData(
Type returnDataType,
bool flush
);
Managed C++ public: Object* GetData(
Type *returnDataType,
bool flush
);
JScript .NET public function GetData(
returnDataType : Type,
flush : boolean
) : Object;

Parameters

returnDataType | System.Type. Specifies the Type Leave Site of the data to be queried.
flush | System.Boolean. Set to true to flush the internally batched queries to the driver. Set to false to take no action.

Return Value

System.Object . An Object Leave Site that represents the returned query data.


Query.GetData(Type,Boolean,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.GetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the query information.

Definition

Visual Basic .NET Public Function GetData( _
ByVal returnDataType As Type, _
ByVal flush As Boolean, _
ByRef dataReturned As Boolean _
) As Object
C# public object GetData(
Type returnDataType,
bool flush,
out bool dataReturned
);
Managed C++ public: Object* GetData(
Type *returnDataType,
bool flush,
bool *dataReturned
);
JScript .NET public function GetData(
returnDataType : Type,
flush : boolean,
dataReturned : boolean
) : Object;

Parameters

returnDataType | System.Type. Specifies the Type Leave Site of the data to be queried.
flush | System.Boolean. Set to true to flush the internally batched queries to the driver. Set to false to take no action.
dataReturned | System.Boolean. Set to true if data is returned immediately; otherwise, false.

Return Value

System.Object . An Object Leave Site that represents the returned query data.


Query.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Query.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DQuery9, which allows unmanaged COM clients to create an instance of the managed Query class. Not supported.


Query.Issue(IssueFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Issue Method

 Language:
Note: This documentation is preliminary and is subject to change.

Issues a query.

Definition

Visual Basic .NET Public Sub Issue( _
ByVal flags As IssueFlags _
)
C# public void Issue(
IssueFlags flags
);
Managed C++ public: void Issue(
IssueFlags flags
);
JScript .NET public function Issue(
flags : IssueFlags
);

Parameters

flags Microsoft.DirectX.Direct3D.IssueFlags. Member of the IssueFlags enumeration that specifies the type of state change for the query.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Query.op_Equality(Query,Query)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Query, _
ByVal right As Query _
) As Boolean
C# public static bool op_Equality(
Query left,
Query right
);
Managed C++ public: static bool op_Equality(
Query *left,
Query *right
);
JScript .NET public static function op_Equality(
left : Query,
right : Query
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Query. The Query object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Query. The Query object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Query.op_Inequality(Query,Query)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Query, _
ByVal right As Query _
) As Boolean
C# public static bool op_Inequality(
Query left,
Query right
);
Managed C++ public: static bool op_Inequality(
Query *left,
Query *right
);
JScript .NET public static function op_Inequality(
left : Query,
right : Query
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Query. The Query object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Query. The Query object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Query.Query

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Query Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Query class.

Overload List

public Query(Device, QueryType);
public Query(IDirect3DQuery9);
public Query(IDirect3DQuery9, Device);
public Query(IntPtr);


Query.Query(IDirect3DQuery9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Query Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Query class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DQuery9 _
)
C# public Query(
IDirect3DQuery9 pUnk
);
Managed C++ public: Query(
IDirect3DQuery9 pUnk
);
JScript .NET public function Query(
pUnk : IDirect3DQuery9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9. Unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.


Query.Query(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Query Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Query class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Query(
IntPtr unmanagedObject
);
Managed C++ public: Query(
IntPtr unmanagedObject
);
JScript .NET public function Query(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DQuery9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Query.Query(IDirect3DQuery9,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Query Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Query class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DQuery9, _
ByVal device As Device _
)
C# public Query(
IDirect3DQuery9 lp,
Device device
);
Managed C++ public: Query(
IDirect3DQuery9 lp,
Device *device
);
JScript .NET public function Query(
lp : IDirect3DQuery9,
device : Device
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9. Unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. Reference to the Device being queried.


Query.Query(Device,QueryType)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Query Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Query class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal queryType As QueryType _
)
C# public Query(
Device device,
QueryType queryType
);
Managed C++ public: Query(
Device *device,
QueryType queryType
);
JScript .NET public function Query(
device : Device,
queryType : QueryType
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to the Device being queried.
queryType | Microsoft.DirectX.Direct3D.QueryType. Member of the QueryType enumeration that specifies the query type.


Query.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Query.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Query.UpdateUnmanagedPointer(IDirect3DQuery9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Query object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DQuery9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DQuery9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DQuery9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DQuery9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9. Pointer to the IDirect3DQuery9 structure used to update the unmanaged pointer for this Query object.


Query.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device for the current query.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object associated with the current query.

This property is read-only.


Query.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Query.QueryType

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.QueryType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the query type for the current query.

Definition

Visual Basic .NET | Public ReadOnly Property QueryType As QueryType
C# | public QueryType QueryType { get; }
Managed C++ | public: __property QueryType get_QueryType();
JScript .NET | public function get QueryType() : QueryType

Property Value

Microsoft.DirectX.Direct3D.QueryType . Member of the QueryType enumeration to retrieve.

This property is read-only.


Query.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DQuery9
C# | public IDirect3DQuery9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DQuery9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DQuery9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9 . Unmanaged IDirect3DQuery9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Query.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Query.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Query object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Query.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Query object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.RenderStateManager

RenderStateManager Class

Note: This documentation is preliminary and is subject to change.

Defines device render states.

Definition

Visual Basic .NET NotInheritable Public Class RenderStateManager
Inherits Object
C# | public sealed class RenderStateManager : Object
Managed C++ | public __gc __sealed class RenderStateManager : public Object
JScript .NET | public class RenderStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdaptiveTessellateW | Amount to adaptively tessellate in the w direction. The default value is 0.0f.
AdaptiveTessellateX | Amount to adaptively tessellate in the x direction. The default value is 0.0f.
AdaptiveTessellateY | Amount to adaptively tessellate in the y direction. The default value is 0.0f.
AdaptiveTessellateZ | Amount to adaptively tessellate in the z direction. The default value is 1.0f.
AlphaBlendEnable | Retrieves or sets a value to enable alpha-blended transparency.
AlphaBlendOperation | Retrieves or sets a value to select the arithmetic operation applied to the separate for the alpha channel (also known as separate alpha blending) when the render state, RenderStateManager.SeparateAlphaBlendEnabled, is set to true.
AlphaDestinationBlend | Contains a member of the Blend enumeration that represents the destination .
AlphaFunction | Retrieves or sets the comparison function for the alpha test.
AlphaSourceBlend | Contains a member of the Blend enumeration that represents the source .
AlphaTestEnable | Retrieves or sets a render state that enables a per-pixel alpha test.
Ambient | Retrieves or sets the ambient light color.
AmbientColor | Retrieves or sets the ambient light color.
AmbientMaterialSource | Retrieves or sets the ambient color source for lighting calculations.
AntiAliasedLineEnable | Retrieves or sets antialiasing of lines.
BlendFactor | Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.
BlendFactorColor | Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.
BlendOperation | Retrieves or sets a value used to select the arithmetic operation to apply when the alpha blend render state, RenderStateManager.AlphaBlendEnable, is set to true.
Clipping | Retrieves or sets a value to enable primitive clipping by Microsoft® Direct3D®.
ColorVertex | Retrieves or sets a value to enable or disable per-vertex color.
ColorWriteEnable | Retrieves or sets a value that enables a per-channel write for the render target color buffer.
ColorWriteEnable1 | Retrieves or sets additional RenderStateManager.ColorWriteEnable values for the device.
ColorWriteEnable2 | Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.
ColorWriteEnable3 | Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.
CounterClockwiseStencilFail | Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test fails.
CounterClockwiseStencilFunction | Retrieves or sets the comparison function used by the counterclockwise (CCW) stencil test.
CounterClockwiseStencilPass | Retrieves the StencilOperation or sets it to perform, if both counterclockwise (CCW) stencil and z-tests pass.
CounterClockwiseStencilZBufferFail | Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test passes and the z-test fails.
CullMode | Specifies how back-facing triangles are culled, if at all.
DebugMonitorTokenEnabled | Enables or disables the debug monitor token.
DepthBias | Sets or retrieves the depth bias for polygons.
DestinationBlend | Contains a member of the Blend enumeration that represents the destination .
DiffuseMaterialSource | Retrieves or sets the diffuse color source for lighting calculations.
DitherEnable | Enables or disables dithering.
EmissiveMaterialSource | Retrieves or sets the emissive color source for lighting calculations.
EnableAdaptiveTessellation | Enables or disables adaptive tessellation.
FillMode | Contains a member of the FillMode enumeration that represents the fill mode.
FogColor | Retrieves or sets the fog color.
FogColorValue | Retrieves or sets the fog color.
FogDensity | Retrieves or sets the fog density for pixel or vertex fog used in exponential fog modes.
FogEnable | Enables or disables fog blending.
FogEnd | Retrieves or sets the depth at which pixel or vertex fog effects end for linear fog mode.
FogStart | Retrieves or sets the depth at which pixel or vertex fog effects begin for linear fog mode.
FogTableMode | Retrieves or sets the fog formula to use for pixel fog.
FogVertexMode | Retrieves or sets the fog formula to use for vertex fog.
IndexedVertexBlendEnable | Enables or disables indexed vertex blending.
LastPixel | Enables or disables drawing of the last pixel in a line.
Lighting | Enables or disables Direct3D lighting.
LocalViewer | Specifies whether to use camera-relative specular highlights or orthogonal specular highlights.
MaxTessellationLevel | Retrieves or sets the maximum tessellation level.
MinTessellationLevel | Retrieves or sets the minimum tessellation level.
MultiSampleAntiAlias | Determines how individual samples are computed when using a multisample render target buffer.
MultiSampleMask | Retrieves or sets a render state that enables use of a multisample buffer as an accumulation buffer.
NormalDegree | Retrieves or sets the degree of interpolation (linear, cubic, quadratic, or quintic) using the N-patch normal.
NormalizeNormals | Enables or disables automatic normalization of vertex normals.
PatchEdgeStyle | Retrieves or sets the tessellation mode for patch edges.
PointScaleA | Controls the distance-based size attenuation for point primitives.
PointScaleB | Controls the distance-based size attenuation for point primitives.
PointScaleC | Controls the distance-based size attenuation for point primitives.
PointScaleEnable | Controls how the computation of size for point sprites is handled.
PointSize | Specifies the size to use for point size computation in cases in which point size is not specified for each vertex.
PointSizeMax | Specifies the maximum size to which point sprites can be set.
PointSizeMin | Specifies the minimum size to which point sprites can be set.
PointSpriteEnable | Controls how point sprites are rendered.
PositionDegree | Retrieves or sets the N-patch position interpolation degree.
RangeFogEnable | Retrieves or sets enabling of range-based vertex fog.
ReferenceAlpha | Specifies a reference alpha value against which pixels are tested when alpha testing is enabled.
ReferenceStencil | Specifies a reference value to use for the stencil test.
ScissorTestEnable | Enables or disables scissor testing.
SeparateAlphaBlendEnabled | Enables or disables the separate for the alpha channel.
ShadeMode | Contains one or more members of the ShadeMode enumeration.
SlopeScaleDepthBias | Retrieves or sets a value used to determine how much bias can be applied to coplanar primitives to reduce z-fighting.
SourceBlend | Contains a member of the Blend enumeration.
SpecularEnable | Retrieves or sets a render state that enables specular highlights.
SpecularMaterialSource | Retrieves or sets the specular color source for lighting calculations.
SrgbWriteEnable | Retrieves or sets a render state that enables render-target writes to be gamma corrected to sRGB.
StencilEnable | Retrieves or sets stencil enabling.
StencilFail | Retrieves or sets the stencil operation to perform if the stencil test fails.
StencilFunction | Retrieves or sets the comparison function for the stencil test.
StencilMask | Retrieves or sets the mask applied to the reference value and each stencil buffer entry to determine the significant bits for the stencil test.
StencilPass | Retrieves or sets the stencil operation to perform if both the stencil test and the depth test (z-test) pass.
StencilWriteMask | Retrieves or sets the write mask applied to values written into the stencil buffer.
StencilZBufferFail | Retrieves or sets the stencil operation to perform if the stencil test passes and the depth test (z-test) fails.
TextureFactor | Retrieves or sets the color used for multiple-texture blending with the TextureArgument.TFactor texture blending argument or the TextureOperation.BlendFactorAlpha texture blending operation.
TweenFactor | Retrieves or sets a floating-point value that controls the tween factor.
TwoSidedStencilMode | Enables or disables two-sided stenciling.
UseWBuffer | Enables or disables w-buffering.
VertexBlend | Retrieves or sets the number of matrices to use to perform geometry blending.
Wrap0 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap1 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap10 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap11 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap12 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap13 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap14 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap15 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap2 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap3 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap4 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap5 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap6 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap7 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap8 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap9 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
ZBufferEnable | Enables or disables depth buffering.
ZBufferFunction | Retrieves or sets the comparison function for the z-buffer test.
ZBufferWriteEnable | Enables or disables writing to the depth buffer.

Inheritance Hierarchy

Object Leave Site
RenderStateManager

Remarks

The Device.RenderState property can be used to obtain the RenderStateManager object for the device.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ToString()

RenderStateManager.ToString Method

Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateW

RenderStateManager.AdaptiveTessellateW Property

Note: This documentation is preliminary and is subject to change.

Amount to adaptively tessellate in the w direction. The default value is 0.0f.

Definition

Visual Basic .NET | Public Property AdaptiveTessellateW As Single
C# | public float AdaptiveTessellateW { get; set; }
Managed C++ public: __property float get_AdaptiveTessellateW();
public: __property void set_AdaptiveTessellateW(float);
JScript .NET public function get AdaptiveTessellateW() : float
public function set AdaptiveTessellateW(float);

Property Value

System.Single . A Single Leave Site that sets or receives the value.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateX

RenderStateManager.AdaptiveTessellateX Property

Note: This documentation is preliminary and is subject to change.

Amount to adaptively tessellate in the x direction. The default value is 0.0f.

Definition

Visual Basic .NET | Public Property AdaptiveTessellateX As Single
C# | public float AdaptiveTessellateX { get; set; }
Managed C++ public: __property float get_AdaptiveTessellateX();
public: __property void set_AdaptiveTessellateX(float);
JScript .NET public function get AdaptiveTessellateX() : float
public function set AdaptiveTessellateX(float);

Property Value

System.Single . A Single Leave Site that sets or receives the value.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateY

RenderStateManager.AdaptiveTessellateY Property

Note: This documentation is preliminary and is subject to change.

Amount to adaptively tessellate in the y direction. The default value is 0.0f.

Definition

Visual Basic .NET | Public Property AdaptiveTessellateY As Single
C# | public float AdaptiveTessellateY { get; set; }
Managed C++ public: __property float get_AdaptiveTessellateY();
public: __property void set_AdaptiveTessellateY(float);
JScript .NET public function get AdaptiveTessellateY() : float
public function set AdaptiveTessellateY(float);

Property Value

System.Single . A Single Leave Site that sets or receives the value.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateZ

RenderStateManager.AdaptiveTessellateZ Property

Note: This documentation is preliminary and is subject to change.

Amount to adaptively tessellate in the z direction. The default value is 1.0f.

Definition

Visual Basic .NET | Public Property AdaptiveTessellateZ As Single
C# | public float AdaptiveTessellateZ { get; set; }
Managed C++ public: __property float get_AdaptiveTessellateZ();
public: __property void set_AdaptiveTessellateZ(float);
JScript .NET public function get AdaptiveTessellateZ() : float
public function set AdaptiveTessellateZ(float);

Property Value

System.Single . A Single Leave Site that sets or receives the value.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaBlendEnable

RenderStateManager.AlphaBlendEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value to enable alpha-blended transparency.

Definition

Visual Basic .NET | Public Property AlphaBlendEnable As Boolean
C# | public bool AlphaBlendEnable { get; set; }
Managed C++ public: __property bool get_AlphaBlendEnable();
public: __property void set_AlphaBlendEnable(bool);
JScript .NET public function get AlphaBlendEnable() : boolean
public function set AlphaBlendEnable(boolean);

Property Value

System.Boolean . Set to true to enable alpha-blended transparency, or false to disable it.

This property is read/write.

Remarks

The default value is false. The type of alpha blending is determined by the RenderStateManager.SourceBlend and RenderStateManager.DestinationBlend render states.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaBlendOperation

RenderStateManager.AlphaBlendOperation Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value to select the arithmetic operation applied to the separate for the alpha channel (also known as separate alpha blending) when the render state, RenderStateManager.SeparateAlphaBlendEnabled, is set to true.

Definition

Visual Basic .NET | Public Property AlphaBlendOperation As BlendOperation
C# | public BlendOperation AlphaBlendOperation { get; set; }
Managed C++ public: __property BlendOperation get_AlphaBlendOperation();
public: __property void set_AlphaBlendOperation(BlendOperation);
JScript .NET public function get AlphaBlendOperation() : BlendOperation
public function set AlphaBlendOperation(BlendOperation);

Property Value

Microsoft.DirectX.Direct3D.BlendOperation . A value of the BlendOperation enumeration that represents the blend operation to set or retrieve.

This property is read/write.

Remarks

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaDestinationBlend

RenderStateManager.AlphaDestinationBlend Property

Note: This documentation is preliminary and is subject to change.

Contains a member of the Blend enumeration that represents the destination .

Definition

Visual Basic .NET | Public Property AlphaDestinationBlend As Blend
C# | public Blend AlphaDestinationBlend { get; set; }
Managed C++ public: __property Blend get_AlphaDestinationBlend();
public: __property void set_AlphaDestinationBlend(Blend);
JScript .NET public function get AlphaDestinationBlend() : Blend
public function set AlphaDestinationBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend . A Blend object that represents the current blend mode or the blend mode to set.

This property is read/write.

Remarks

This value is ignored unless RenderStateManager.SeparateAlphaBlendEnabled is true. The default value is Blend.Zero.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaFunction

RenderStateManager.AlphaFunction Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the comparison function for the alpha test.

Definition

Visual Basic .NET | Public Property AlphaFunction As Compare
C# | public Compare AlphaFunction { get; set; }
Managed C++ public: __property Compare get_AlphaFunction();
public: __property void set_AlphaFunction(Compare);
JScript .NET public function get AlphaFunction() : Compare
public function set AlphaFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare . Value of the Compare enumeration that represents the comparison function to set or retrieve.

This property is read/write.

Remarks

The default value is Compare.Always.

The AlphaFunction property enables an application to accept or reject a pixel based on its alpha value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaSourceBlend

RenderStateManager.AlphaSourceBlend Property

Note: This documentation is preliminary and is subject to change.

Contains a member of the Blend enumeration that represents the source .

Definition

Visual Basic .NET | Public Property AlphaSourceBlend As Blend
C# | public Blend AlphaSourceBlend { get; set; }
Managed C++ public: __property Blend get_AlphaSourceBlend();
public: __property void set_AlphaSourceBlend(Blend);
JScript .NET public function get AlphaSourceBlend() : Blend
public function set AlphaSourceBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend . A Blend object that represents the current blend mode or the blend mode to set.

This property is read/write.

Remarks

This value is ignored unless RenderStateManager.SeparateAlphaBlendEnabled is true. The default value is Blend.One.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaTestEnable

RenderStateManager.AlphaTestEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a render state that enables a per-pixel alpha test.

Definition

Visual Basic .NET | Public Property AlphaTestEnable As Boolean
C# | public bool AlphaTestEnable { get; set; }
Managed C++ public: __property bool get_AlphaTestEnable();
public: __property void set_AlphaTestEnable(bool);
JScript .NET public function get AlphaTestEnable() : boolean
public function set AlphaTestEnable(boolean);

Property Value

System.Boolean . Set to true to enable per-pixel alpha testing, or false to disable it. The default value is false.

This property is read/write.

Remarks

If the test passes, the pixel is processed by the frame buffer. Otherwise, all frame-buffer processing is skipped for the pixel. The test is done by comparing the incoming alpha value with the reference alpha value, using the comparison function provided by RenderStateManager.AlphaFunction. The reference alpha value is determined by the value set for RenderStateManager.ReferenceAlpha.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Ambient

RenderStateManager.Ambient Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ambient light color.

Definition

Visual Basic .NET | Public Property Ambient As Color
C# | public Color Ambient { get; set; }
Managed C++ public: __property Color get_Ambient();
public: __property void set_Ambient(Color);
JScript .NET public function get Ambient() : Color
public function set Ambient(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that specifies the ambient color value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AmbientColor

RenderStateManager.AmbientColor Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ambient light color.

Definition

Visual Basic .NET | Public Property AmbientColor As Integer
C# | public int AmbientColor { get; set; }
Managed C++ public: __property int get_AmbientColor();
public: __property void set_AmbientColor(int);
JScript .NET public function get AmbientColor() : int
public function set AmbientColor(int);

Property Value

System.Int32 . An Int32 Leave Site that specifies the ambient color value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AmbientMaterialSource

RenderStateManager.AmbientMaterialSource Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ambient color source for lighting calculations.

Definition

Visual Basic .NET | Public Property AmbientMaterialSource As ColorSource
C# | public ColorSource AmbientMaterialSource { get; set; }
Managed C++ public: __property ColorSource get_AmbientMaterialSource();
public: __property void set_AmbientMaterialSource(ColorSource);
JScript .NET public function get AmbientMaterialSource() : ColorSource
public function set AmbientMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource . Value of the ColorSource enumeration that specifies the ambient color source value to set or retrieve.

This property is read/write.

Remarks

Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AntiAliasedLineEnable

RenderStateManager.AntiAliasedLineEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets antialiasing of lines.

Definition

Visual Basic .NET | Public Property AntiAliasedLineEnable As Boolean
C# | public bool AntiAliasedLineEnable { get; set; }
Managed C++ public: __property bool get_AntiAliasedLineEnable();
public: __property void set_AntiAliasedLineEnable(bool);
JScript .NET public function get AntiAliasedLineEnable() : boolean
public function set AntiAliasedLineEnable(boolean);

Property Value

System.Boolean . Set to true to enable antialiasing of lines, or false to disable it. The default value is false.

This property is read/write.

Remarks

The AntiAliasedLineEnable property applies to triangles drawn in wireframe mode as well as line-drawing primitive types.

When rendering to a multisample render target, this render state is ignored, and all lines are rendered aliased. For antialiased line rendering in multisample render targets, use a Line object, which generates textured polygons.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.BlendFactor

RenderStateManager.BlendFactor Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.

Definition

Visual Basic .NET | Public Property BlendFactor As Color
C# | public Color BlendFactor { get; set; }
Managed C++ public: __property Color get_BlendFactor();
public: __property void set_BlendFactor(Color);
JScript .NET public function get BlendFactor() : Color
public function set BlendFactor(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that specifies the constant blend factor to set or retrieve.

This property is read/write.

Remarks

The BlendFactor property is available if BlendCaps.SupportsBlendFactor is set in Caps.SourceBlendCaps or Caps.DestinationBlendCaps for the device.

See Also

  • SourceBlend
  • AlphaBlendEnable
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.BlendFactorColor

RenderStateManager.BlendFactorColor Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.

Definition

Visual Basic .NET | Public Property BlendFactorColor As Integer
C# | public int BlendFactorColor { get; set; }
Managed C++ public: __property int get_BlendFactorColor();
public: __property void set_BlendFactorColor(int);
JScript .NET public function get BlendFactorColor() : int
public function set BlendFactorColor(int);

Property Value

System.Int32 . An Int32 Leave Site that specifies the constant blend factor to set or retrieve.

This property is read/write.

Remarks

The BlendFactor property is available if BlendCaps.SupportsBlendFactor is set in Caps.SourceBlendCaps or Caps.DestinationBlendCaps for the device.

See Also

  • SourceBlend
  • AlphaBlendEnable
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.BlendOperation

RenderStateManager.BlendOperation Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value used to select the arithmetic operation to apply when the alpha blend render state, RenderStateManager.AlphaBlendEnable, is set to true.

Definition

Visual Basic .NET | Public Property BlendOperation As BlendOperation
C# | public BlendOperation BlendOperation { get; set; }
Managed C++ public: __property BlendOperation get_BlendOperation();
public: __property void set_BlendOperation(BlendOperation);
JScript .NET public function get BlendOperation() : BlendOperation
public function set BlendOperation(BlendOperation);

Property Value

Microsoft.DirectX.Direct3D.BlendOperation . Value of the BlendOperation enumeration that represents the blend operation to set or retrieve.

This property is read/write.

Remarks

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Clipping

RenderStateManager.Clipping Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value to enable primitive clipping by Microsoft® Direct3D®.

Definition

Visual Basic .NET | Public Property Clipping As Boolean
C# | public bool Clipping { get; set; }
Managed C++ public: __property bool get_Clipping();
public: __property void set_Clipping(bool);
JScript .NET public function get Clipping() : boolean
public function set Clipping(boolean);

Property Value

System.Boolean . Set to true to enable primitive clipping, or false to disable it.

This property is read/write.

Remarks

The default value is true.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorVertex

RenderStateManager.ColorVertex Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value to enable or disable per-vertex color.

Definition

Visual Basic .NET | Public Property ColorVertex As Boolean
C# | public bool ColorVertex { get; set; }
Managed C++ public: __property bool get_ColorVertex();
public: __property void set_ColorVertex(bool);
JScript .NET public function get ColorVertex() : boolean
public function set ColorVertex(boolean);

Property Value

System.Boolean . Set to true to enable per-vertex color, or false to disable it.

This property is read/write.

Remarks

The default value is true.

Enabling per-vertex color allows the system to include the color defined for individual vertices in its lighting calculations. For more information, see the following topics.

  • DiffuseMaterialSource
  • SpecularMaterialSource
  • AmbientMaterialSource
  • EmissiveMaterialSource

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable

RenderStateManager.ColorWriteEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that enables a per-channel write for the render target color buffer.

Definition

Visual Basic .NET | Public Property ColorWriteEnable As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable { get; set; }
Managed C++ public: __property ColorWriteEnable get_ColorWriteEnable();
public: __property void set_ColorWriteEnable(ColorWriteEnable);
JScript .NET public function get ColorWriteEnable() : ColorWriteEnable
public function set ColorWriteEnable(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable . Value of the ColorWriteEnable enumeration that specifies the color channel to set or retrieve.

This property is read/write.

Remarks

Additional ColorWriteEnable* properties are available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable1

RenderStateManager.ColorWriteEnable1 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets additional RenderStateManager.ColorWriteEnable values for the device.

Definition

Visual Basic .NET | Public Property ColorWriteEnable1 As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable1 { get; set; }
Managed C++ public: __property ColorWriteEnable get_ColorWriteEnable1();
public: __property void set_ColorWriteEnable1(ColorWriteEnable);
JScript .NET public function get ColorWriteEnable1() : ColorWriteEnable
public function set ColorWriteEnable1(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable . Value of the ColorWriteEnable enumeration that specifies the color channel(s) to write enable.

This property is read/write.

Remarks

The ColorWriteEnable1 property is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable2

RenderStateManager.ColorWriteEnable2 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.

Definition

Visual Basic .NET | Public Property ColorWriteEnable2 As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable2 { get; set; }
Managed C++ public: __property ColorWriteEnable get_ColorWriteEnable2();
public: __property void set_ColorWriteEnable2(ColorWriteEnable);
JScript .NET public function get ColorWriteEnable2() : ColorWriteEnable
public function set ColorWriteEnable2(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable . Value of the ColorWriteEnable enumeration that specifies the color channel(s) to write enable.

This property is read/write.

Remarks

The ColorWriteEnable2 property is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable3

RenderStateManager.ColorWriteEnable3 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.

Definition

Visual Basic .NET | Public Property ColorWriteEnable3 As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable3 { get; set; }
Managed C++ public: __property ColorWriteEnable get_ColorWriteEnable3();
public: __property void set_ColorWriteEnable3(ColorWriteEnable);
JScript .NET public function get ColorWriteEnable3() : ColorWriteEnable
public function set ColorWriteEnable3(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable . Value of the ColorWriteEnable enumeration that specifies the color channel(s) to write enable.

This property is read/write.

Remarks

The ColorWriteEnable3 property is available if the MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilFail

RenderStateManager.CounterClockwiseStencilFail Property

Note: This documentation is preliminary and is subject to change.

Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test fails.

Definition

Visual Basic .NET | Public Property CounterClockwiseStencilFail As StencilOperation
C# | public StencilOperation CounterClockwiseStencilFail { get; set; }
Managed C++ public: __property StencilOperation get_CounterClockwiseStencilFail();
public: __property void set_CounterClockwiseStencilFail(StencilOperation);
JScript .NET public function get CounterClockwiseStencilFail() : StencilOperation
public function set CounterClockwiseStencilFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation . Value of the StencilOperation enumeration that specifies the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilFunction

RenderStateManager.CounterClockwiseStencilFunction Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the comparison function used by the counterclockwise (CCW) stencil test.

Definition

Visual Basic .NET | Public Property CounterClockwiseStencilFunction As Compare
C# | public Compare CounterClockwiseStencilFunction { get; set; }
Managed C++ public: __property Compare get_CounterClockwiseStencilFunction();
public: __property void set_CounterClockwiseStencilFunction(Compare);
JScript .NET public function get CounterClockwiseStencilFunction() : Compare
public function set CounterClockwiseStencilFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare . Value of the Compare enumeration that specifies the comparison operation to set or retrieve.

This property is read/write.

Remarks

The test passes if ((ref & mask) stencil_compare_function (stencil & mask)) == true.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilPass

RenderStateManager.CounterClockwiseStencilPass Property

Note: This documentation is preliminary and is subject to change.

Retrieves the StencilOperation or sets it to perform, if both counterclockwise (CCW) stencil and z-tests pass.

Definition

Visual Basic .NET | Public Property CounterClockwiseStencilPass As StencilOperation
C# | public StencilOperation CounterClockwiseStencilPass { get; set; }
Managed C++ public: __property StencilOperation get_CounterClockwiseStencilPass();
public: __property void set_CounterClockwiseStencilPass(StencilOperation);
JScript .NET public function get CounterClockwiseStencilPass() : StencilOperation
public function set CounterClockwiseStencilPass(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation . Value of the StencilOperation enumeration that specifies the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilZBufferFail

RenderStateManager.CounterClockwiseStencilZBufferFail Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test passes and the z-test fails.

Definition

Visual Basic .NET | Public Property CounterClockwiseStencilZBufferFail As StencilOperation
C# | public StencilOperation CounterClockwiseStencilZBufferFail { get; set; }
Managed C++ public: __property StencilOperation get_CounterClockwiseStencilZBufferFail();
public: __property void set_CounterClockwiseStencilZBufferFail(StencilOperation);
JScript .NET public function get CounterClockwiseStencilZBufferFail() : StencilOperation
public function set CounterClockwiseStencilZBufferFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation . Value of the StencilOperation enumeration that specifies the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CullMode

RenderStateManager.CullMode Property

Note: This documentation is preliminary and is subject to change.

Specifies how back-facing triangles are culled, if at all.

Definition

Visual Basic .NET | Public Property CullMode As Cull
C# | public Cull CullMode { get; set; }
Managed C++ public: __property Cull get_CullMode();
public: __property void set_CullMode(Cull);
JScript .NET public function get CullMode() : Cull
public function set CullMode(Cull);

Property Value

Microsoft.DirectX.Direct3D.Cull . Value of the Cull enumeration that specifies the culling mode to set or retrieve.

This property is read/write.

Remarks

The default value is Cull.CounterClockwise.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DebugMonitorTokenEnabled

RenderStateManager.DebugMonitorTokenEnabled Property

Note: This documentation is preliminary and is subject to change.

Enables or disables the debug monitor token.

Definition

Visual Basic .NET | Public Property DebugMonitorTokenEnabled As Boolean
C# | public bool DebugMonitorTokenEnabled { get; set; }
Managed C++ public: __property bool get_DebugMonitorTokenEnabled();
public: __property void set_DebugMonitorTokenEnabled(bool);
JScript .NET public function get DebugMonitorTokenEnabled() : boolean
public function set DebugMonitorTokenEnabled(boolean);

Property Value

System.Boolean . Set to true to enable the debug monitor, or false to disable it.

This property is read/write.

Remarks

The default value for the debug monitor is true.

This property should be set only for debugging the monitor. It is useful for debug builds only.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DepthBias

RenderStateManager.DepthBias Property

Note: This documentation is preliminary and is subject to change.

Sets or retrieves the depth bias for polygons.

Definition

Visual Basic .NET | Public Property DepthBias As Single
C# | public float DepthBias { get; set; }
Managed C++ public: __property float get_DepthBias();
public: __property void set_DepthBias(float);
JScript .NET public function get DepthBias() : float
public function set DepthBias(float);

Property Value

System.Single . Depth bias for polygons.

This property is read/write.

Remarks

The DepthBias property specifies an integer value in the range of 0 through 16 that causes polygons that are physically coplanar to appear separate.

Polygons with a high z-bias value appear in front of polygons with a low value, without requiring sorting for drawing order. For example, polygons with a value of 1 appear in front of polygons with a value of 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DestinationBlend

RenderStateManager.DestinationBlend Property

Note: This documentation is preliminary and is subject to change.

Contains a member of the Blend enumeration that represents the destination .

Definition

Visual Basic .NET | Public Property DestinationBlend As Blend
C# | public Blend DestinationBlend { get; set; }
Managed C++ public: __property Blend get_DestinationBlend();
public: __property void set_DestinationBlend(Blend);
JScript .NET public function get DestinationBlend() : Blend
public function set DestinationBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend . A Blend object that represents the current blend mode or the blend mode to set.

This property is read/write.

Remarks

The default value is Blend.Zero.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DiffuseMaterialSource

RenderStateManager.DiffuseMaterialSource Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the diffuse color source for lighting calculations.

Definition

Visual Basic .NET | Public Property DiffuseMaterialSource As ColorSource
C# | public ColorSource DiffuseMaterialSource { get; set; }
Managed C++ public: __property ColorSource get_DiffuseMaterialSource();
public: __property void set_DiffuseMaterialSource(ColorSource);
JScript .NET public function get DiffuseMaterialSource() : ColorSource
public function set DiffuseMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource . A ColorSource object that specifies the diffuse color source value to set or retrieve.

This property is read/write.

Remarks

Valid values are members of the ColorSource enumerated type. The default value is ColorSource.Color1. The value for this render state is used only if RenderStateManager.ColorVertex is set to true.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DitherEnable

RenderStateManager.DitherEnable Property

Note: This documentation is preliminary and is subject to change.

Enables or disables dithering.

Definition

Visual Basic .NET | Public Property DitherEnable As Boolean
C# | public bool DitherEnable { get; set; }
Managed C++ public: __property bool get_DitherEnable();
public: __property void set_DitherEnable(bool);
JScript .NET public function get DitherEnable() : boolean
public function set DitherEnable(boolean);

Property Value

System.Boolean . Set to true to enable dithering, or false to disable it.

This property is read/write.

Remarks

The default value is false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.EmissiveMaterialSource

RenderStateManager.EmissiveMaterialSource Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the emissive color source for lighting calculations.

Definition

Visual Basic .NET | Public Property EmissiveMaterialSource As ColorSource
C# | public ColorSource EmissiveMaterialSource { get; set; }
Managed C++ public: __property ColorSource get_EmissiveMaterialSource();
public: __property void set_EmissiveMaterialSource(ColorSource);
JScript .NET public function get EmissiveMaterialSource() : ColorSource
public function set EmissiveMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource . A ColorSource object that specifies the emissive color source value to set or retrieve.

This property is read/write.

Remarks

Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.EnableAdaptiveTessellation

RenderStateManager.EnableAdaptiveTessellation Property

Note: This documentation is preliminary and is subject to change.

Enables or disables adaptive tessellation.

Definition

Visual Basic .NET | Public Property EnableAdaptiveTessellation As Boolean
C# | public bool EnableAdaptiveTessellation { get; set; }
Managed C++ public: __property bool get_EnableAdaptiveTessellation();
public: __property void set_EnableAdaptiveTessellation(bool);
JScript .NET public function get EnableAdaptiveTessellation() : boolean
public function set EnableAdaptiveTessellation(boolean);

Property Value

System.Boolean . Set to true to enable adaptive tessellation, or false to disable it.

This property is read/write.

Remarks

The default value is false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FillMode

RenderStateManager.FillMode Property

Note: This documentation is preliminary and is subject to change.

Contains a member of the FillMode enumeration that represents the fill mode.

Definition

Visual Basic .NET | Public Property FillMode As FillMode
C# | public FillMode FillMode { get; set; }
Managed C++ public: __property FillMode get_FillMode();
public: __property void set_FillMode(FillMode);
JScript .NET public function get FillMode() : FillMode
public function set FillMode(FillMode);

Property Value

Microsoft.DirectX.Direct3D.FillMode . Value of the FillMode enumeration that specifies the fill mode to set or retrieve.

This property is read/write.

Remarks

The default value is FillMode.Solid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogColor

RenderStateManager.FogColor Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the fog color.

Definition

Visual Basic .NET | Public Property FogColor As Color
C# | public Color FogColor { get; set; }
Managed C++ public: __property Color get_FogColor();
public: __property void set_FogColor(Color);
JScript .NET public function get FogColor() : Color
public function set FogColor(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that specifies the fog color to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogColorValue

RenderStateManager.FogColorValue Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the fog color.

Definition

Visual Basic .NET | Public Property FogColorValue As Integer
C# | public int FogColorValue { get; set; }
Managed C++ public: __property int get_FogColorValue();
public: __property void set_FogColorValue(int);
JScript .NET public function get FogColorValue() : int
public function set FogColorValue(int);

Property Value

System.Int32 . An integer that specifies the fog color to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogDensity

RenderStateManager.FogDensity Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the fog density for pixel or vertex fog used in exponential fog modes.

Definition

Visual Basic .NET | Public Property FogDensity As Single
C# | public float FogDensity { get; set; }
Managed C++ public: __property float get_FogDensity();
public: __property void set_FogDensity(float);
JScript .NET public function get FogDensity() : float
public function set FogDensity(float);

Property Value

System.Single . Floating-point value that represents the fog density to set or retrieve.

This property is read/write.

Remarks

Valid fog density values range from 0.0 through 1.0. The default value is 1.0.

See Also

  • Fog
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogEnable

RenderStateManager.FogEnable Property

Note: This documentation is preliminary and is subject to change.

Enables or disables fog blending.

Definition

Visual Basic .NET | Public Property FogEnable As Boolean
C# | public bool FogEnable { get; set; }
Managed C++ public: __property bool get_FogEnable();
public: __property void set_FogEnable(bool);
JScript .NET public function get FogEnable() : boolean
public function set FogEnable(boolean);

Property Value

System.Boolean . Set to true to enable fog blending, or false to disable it.

This property is read/write.

Remarks

The default value is false.

See Also

  • Fog
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogEnd

RenderStateManager.FogEnd Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the depth at which pixel or vertex fog effects end for linear fog mode.

Definition

Visual Basic .NET | Public Property FogEnd As Single
C# | public float FogEnd { get; set; }
Managed C++ public: __property float get_FogEnd();
public: __property void set_FogEnd(float);
JScript .NET public function get FogEnd() : float
public function set FogEnd(float);

Property Value

System.Single . Floating-point value that represents the ending depth to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f. Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog).

See Also

  • Fog
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogStart

RenderStateManager.FogStart Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the depth at which pixel or vertex fog effects begin for linear fog mode.

Definition

Visual Basic .NET | Public Property FogStart As Single
C# | public float FogStart { get; set; }
Managed C++ public: __property float get_FogStart();
public: __property void set_FogStart(float);
JScript .NET public function get FogStart() : float
public function set FogStart(float);

Property Value

System.Single . Floating-point value that represents the beginning depth to set or retrieve.

This property is read/write.

Remarks

The default value is 0.0f. Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog).

See Also

  • Fog
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogTableMode

RenderStateManager.FogTableMode Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the fog formula to use for pixel fog.

Definition

Visual Basic .NET | Public Property FogTableMode As FogMode
C# | public FogMode FogTableMode { get; set; }
Managed C++ public: __property FogMode get_FogTableMode();
public: __property void set_FogTableMode(FogMode);
JScript .NET public function get FogTableMode() : FogMode
public function set FogTableMode(FogMode);

Property Value

Microsoft.DirectX.Direct3D.FogMode . Value of the FogMode enumeration that specifies the fog mode to set or retrieve.

This property is read/write.

Remarks

The default fog mode is FogMode.None.

See Also

  • Fog
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogVertexMode

RenderStateManager.FogVertexMode Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the fog formula to use for vertex fog.

Definition

Visual Basic .NET | Public Property FogVertexMode As FogMode
C# | public FogMode FogVertexMode { get; set; }
Managed C++ public: __property FogMode get_FogVertexMode();
public: __property void set_FogVertexMode(FogMode);
JScript .NET public function get FogVertexMode() : FogMode
public function set FogVertexMode(FogMode);

Property Value

Microsoft.DirectX.Direct3D.FogMode . Value of the FogMode enumeration that specifies the fog mode to set or retrieve.

This property is read/write.

Remarks

The default fog mode is FogMode.None.

See Also

  • Fog
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.IndexedVertexBlendEnable

RenderStateManager.IndexedVertexBlendEnable Property

Note: This documentation is preliminary and is subject to change.

Enables or disables indexed vertex blending.

Definition

Visual Basic .NET | Public Property IndexedVertexBlendEnable As Boolean
C# | public bool IndexedVertexBlendEnable { get; set; }
Managed C++ public: __property bool get_IndexedVertexBlendEnable();
public: __property void set_IndexedVertexBlendEnable(bool);
JScript .NET public function get IndexedVertexBlendEnable() : boolean
public function set IndexedVertexBlendEnable(boolean);

Property Value

System.Boolean . Set to true to enable indexed vertex blending, or false to disable it.

This property is read/write.

Remarks

The default value is false.

When indexed vertex blending is disabled and vertex blending is enabled through RenderStateManager.VertexBlend, it is equivalent to having matrix indices 0, 1, 2, and 3 in every vertex.

If indexed vertex blending is enabled (set to true), the user must pass matrix indices with every vertex.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.LastPixel

RenderStateManager.LastPixel Property

Note: This documentation is preliminary and is subject to change.

Enables or disables drawing of the last pixel in a line.

Definition

Visual Basic .NET | Public Property LastPixel As Boolean
C# | public bool LastPixel { get; set; }
Managed C++ public: __property bool get_LastPixel();
public: __property void set_LastPixel(bool);
JScript .NET public function get LastPixel() : boolean
public function set LastPixel(boolean);

Property Value

System.Boolean . Set to true to enable drawing of the last pixel in a line, or false to prevent it.

This property is read/write.

Remarks

The default value is true.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Lighting

RenderStateManager.Lighting Property

Note: This documentation is preliminary and is subject to change.

Enables or disables Microsoft® Direct3D® lighting.

Definition

Visual Basic .NET | Public Property Lighting As Boolean
C# | public bool Lighting { get; set; }
Managed C++ public: __property bool get_Lighting();
public: __property void set_Lighting(bool);
JScript .NET public function get Lighting() : boolean
public function set Lighting(boolean);

Property Value

System.Boolean . Set to true to enable Microsoft® Direct3D® lighting, or false to disable it.

This property is read/write.

Remarks

The default value is true.

Only vertices that include a vertex normal are properly lit; vertices that do not contain a vertex normal employ a dot product of 0 in all lighting calculations.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.LocalViewer

RenderStateManager.LocalViewer Property

Note: This documentation is preliminary and is subject to change.

Specifies whether to use camera-relative specular highlights or orthogonal specular highlights.

Definition

Visual Basic .NET | Public Property LocalViewer As Boolean
C# | public bool LocalViewer { get; set; }
Managed C++ public: __property bool get_LocalViewer();
public: __property void set_LocalViewer(bool);
JScript .NET public function get LocalViewer() : boolean
public function set LocalViewer(boolean);

Property Value

System.Boolean . Set to true to enable camera-relative specular highlights, or false to use orthogonal specular highlights.

This property is read/write.

Remarks

The default value is true.

Applications that use orthogonal projection should specify false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MaxTessellationLevel

RenderStateManager.MaxTessellationLevel Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the maximum tessellation level.

Definition

Visual Basic .NET | Public Property MaxTessellationLevel As Single
C# | public float MaxTessellationLevel { get; set; }
Managed C++ public: __property float get_MaxTessellationLevel();
public: __property void set_MaxTessellationLevel(float);
JScript .NET public function get MaxTessellationLevel() : float
public function set MaxTessellationLevel(float);

Property Value

System.Single . Floating-point value that represents the maximum tessellation level to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MinTessellationLevel

RenderStateManager.MinTessellationLevel Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the minimum tessellation level.

Definition

Visual Basic .NET | Public Property MinTessellationLevel As Single
C# | public float MinTessellationLevel { get; set; }
Managed C++ public: __property float get_MinTessellationLevel();
public: __property void set_MinTessellationLevel(float);
JScript .NET public function get MinTessellationLevel() : float
public function set MinTessellationLevel(float);

Property Value

System.Single . Floating-point value that represents the minimum tessellation level to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MultiSampleAntiAlias

RenderStateManager.MultiSampleAntiAlias Property

Note: This documentation is preliminary and is subject to change.

Determines how individual samples are computed when using a multisample render target buffer.

Definition

Visual Basic .NET | Public Property MultiSampleAntiAlias As Boolean
C# | public bool MultiSampleAntiAlias { get; set; }
Managed C++ public: __property bool get_MultiSampleAntiAlias();
public: __property void set_MultiSampleAntiAlias(bool);
JScript .NET public function get MultiSampleAntiAlias() : boolean
public function set MultiSampleAntiAlias(boolean);

Property Value

System.Boolean . When set to true, the multiple samples are computed so that full-scene antialiasing is performed by sampling at different sample positions for each multiple sample. When set to false, the multiple samples are all written with the same sample value, sampled at the pixel center, which allows non-antialiased rendering to a multisample buffer.

This property is read/write.

Remarks

The default value is true.

This render state has no effect when rendering to a single sample buffer.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MultiSampleMask

RenderStateManager.MultiSampleMask Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a render state that enables use of a multisample buffer as an accumulation buffer.

Definition

Visual Basic .NET | Public Property MultiSampleMask As Integer
C# | public int MultiSampleMask { get; set; }
Managed C++ public: __property int get_MultiSampleMask();
public: __property void set_MultiSampleMask(int);
JScript .NET public function get MultiSampleMask() : int
public function set MultiSampleMask(int);

Property Value

System.Int32 . Integer value that represents the multisample mask to set or retrieve.

This property is read/write.

Remarks

The default value is 0xFFFFFFFF.

This render state allows multipass rendering of geometry, in which each pass updates a subset of samples. The state has no effect when rendering to a single sample buffer.

Each bit in the MultiSampleMask, starting at the least significant bit (LSB), controls modification of one of the samples in a multisample render target. Thus, for an 8-sample render target, the low byte contains the eight write enables for each of the eight samples. This property enables use of a multisample buffer as an accumulation buffer. If there are n multisamples and k enabled samples, the resulting intensity of the rendered image should be k/n. Each component RGB of every pixel is factored by k/n.

See Also

  • MultiSampleType
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.NormalDegree

RenderStateManager.NormalDegree Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the degree of interpolation (linear, cubic, quadratic, or quintic) using the N-patch normal.

Definition

Visual Basic .NET | Public Property NormalDegree As DegreeType
C# | public DegreeType NormalDegree { get; set; }
Managed C++ public: __property DegreeType get_NormalDegree();
public: __property void set_NormalDegree(DegreeType);
JScript .NET public function get NormalDegree() : DegreeType
public function set NormalDegree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType . Value of the DegreeType enumeration that represents the degree of interpolation to set or retrieve.

This property is read/write.

Remarks

The default render state is DegreeType.Linear.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.NormalizeNormals

RenderStateManager.NormalizeNormals Property

Note: This documentation is preliminary and is subject to change.

Enables or disables automatic normalization of vertex normals.

Definition

Visual Basic .NET | Public Property NormalizeNormals As Boolean
C# | public bool NormalizeNormals { get; set; }
Managed C++ public: __property bool get_NormalizeNormals();
public: __property void set_NormalizeNormals(bool);
JScript .NET public function get NormalizeNormals() : boolean
public function set NormalizeNormals(boolean);

Property Value

System.Boolean . Set to true to enable normalization of vertex normals, or false to disable it.

This property is read/write.

Remarks

The default value is false.

Enabling this feature causes the system to normalize the vertex normals for vertices after transforming them to camera space, an operation that can slow down the system.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PatchEdgeStyle

RenderStateManager.PatchEdgeStyle Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the tessellation mode for patch edges.

Definition

Visual Basic .NET | Public Property PatchEdgeStyle As PatchEdge
C# | public PatchEdge PatchEdgeStyle { get; set; }
Managed C++ public: __property PatchEdge get_PatchEdgeStyle();
public: __property void set_PatchEdgeStyle(PatchEdge);
JScript .NET public function get PatchEdgeStyle() : PatchEdge
public function set PatchEdgeStyle(PatchEdge);

Property Value

Microsoft.DirectX.Direct3D.PatchEdge . Value of the PatchEdge enumeration that represents the degree of interpolation to set or retrieve.

This property is read/write.

Remarks

The default render state is PatchEdge.Discrete.

Using the PatchEdge.Continuous tessellation mode helps reduce rendering artifacts.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleA

RenderStateManager.PointScaleA Property

Note: This documentation is preliminary and is subject to change.

Controls the distance-based size attenuation for point primitives.

Definition

Visual Basic .NET | Public Property PointScaleA As Single
C# | public float PointScaleA { get; set; }
Managed C++ public: __property float get_PointScaleA();
public: __property void set_PointScaleA(float);
JScript .NET public function get PointScaleA() : float
public function set PointScaleA(float);

Property Value

System.Single . Floating-point value that specifies the range or size of the attenuation for point primitives.

This property is read/write.

Remarks

The default value is 1.0f.

This property is active only when RenderStateManager.PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleB

RenderStateManager.PointScaleB Property

Note: This documentation is preliminary and is subject to change.

Controls the distance-based size attenuation for point primitives.

Definition

Visual Basic .NET | Public Property PointScaleB As Single
C# | public float PointScaleB { get; set; }
Managed C++ public: __property float get_PointScaleB();
public: __property void set_PointScaleB(float);
JScript .NET public function get PointScaleB() : float
public function set PointScaleB(float);

Property Value

System.Single . Floating-point value that specifies the range or size of the attenuation for point primitives.

This property is read/write.

Remarks

The default value is 1.0f.

This property is active only when RenderStateManager.PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleC

RenderStateManager.PointScaleC Property

Note: This documentation is preliminary and is subject to change.

Controls the distance-based size attenuation for point primitives.

Definition

Visual Basic .NET | Public Property PointScaleC As Single
C# | public float PointScaleC { get; set; }
Managed C++ public: __property float get_PointScaleC();
public: __property void set_PointScaleC(float);
JScript .NET public function get PointScaleC() : float
public function set PointScaleC(float);

Property Value

System.Single . Floating-point value that specifies the range or size of the attenuation for point primitives.

This property is read/write.

Remarks

The default value is 1.0f.

This property is active only when RenderStateManager.PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleEnable

RenderStateManager.PointScaleEnable Property

Note: This documentation is preliminary and is subject to change.

Controls how the computation of size for point sprites is handled.

Definition

Visual Basic .NET | Public Property PointScaleEnable As Boolean
C# | public bool PointScaleEnable { get; set; }
Managed C++ public: __property bool get_PointScaleEnable();
public: __property void set_PointScaleEnable(bool);
JScript .NET public function get PointScaleEnable() : boolean
public function set PointScaleEnable(boolean);

Property Value

System.Boolean . When set to true, the point size is interpreted as a camera space value. To compute the final screen-space point size, it is scaled by the distance function and the frustum to viewport y-axis scaling. When set to false, the point size is interpreted as screen space and used directly.

This property is read/write.

Remarks

The default value is false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSize

RenderStateManager.PointSize Property

Note: This documentation is preliminary and is subject to change.

Specifies the size to use for point size computation in cases in which point size is not specified for each vertex.

Definition

Visual Basic .NET | Public Property PointSize As Single
C# | public float PointSize { get; set; }
Managed C++ public: __property float get_PointSize();
public: __property void set_PointSize(float);
JScript .NET public function get PointSize() : float
public function set PointSize(float);

Property Value

System.Single . Floating-point value that specifies the point size to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f.

This value is not used when the vertex contains a point size. The value is defined in screen space units if RenderStateManager.PointScaleEnable is set to false; otherwise, it is defined in world space units. The range for the value is greater than or equal to 0.0f.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSizeMax

RenderStateManager.PointSizeMax Property

Note: This documentation is preliminary and is subject to change.

Specifies the maximum size to which point sprites can be set.

Definition

Visual Basic .NET | Public Property PointSizeMax As Single
C# | public float PointSizeMax { get; set; }
Managed C++ public: __property float get_PointSizeMax();
public: __property void set_PointSizeMax(float);
JScript .NET public function get PointSizeMax() : float
public function set PointSizeMax(float);

Property Value

System.Single . Floating-point value that specifies the maximum size of point sprites.

This property is read/write.

Remarks

The default value is 64.0f.

The value must be less than or equal to Caps.MaxPointSize and greater than or equal to RenderStateManager.PointSizeMin.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSizeMin

RenderStateManager.PointSizeMin Property

Note: This documentation is preliminary and is subject to change.

Specifies the minimum size to which point sprites can be set.

Definition

Visual Basic .NET | Public Property PointSizeMin As Single
C# | public float PointSizeMin { get; set; }
Managed C++ public: __property float get_PointSizeMin();
public: __property void set_PointSizeMin(float);
JScript .NET public function get PointSizeMin() : float
public function set PointSizeMin(float);

Property Value

System.Single . Floating-point value that specifies the minimum size of point sprites.

This property is read/write.

Remarks

The default value is 1.0f. The range for this value is greater than or equal to 0.0f.

Point sprites are clamped to the specified size during rendering.

Setting the size to less than 1.0 results in points dropping out if the point does not cover a pixel center and antialiasing is disabled. Points also will drop out if the size is less than 1.0, if they are being rendered with reduced intensity, and if antialiasing is enabled.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSpriteEnable

RenderStateManager.PointSpriteEnable Property

Note: This documentation is preliminary and is subject to change.

Controls how point sprites are rendered.

Definition

Visual Basic .NET | Public Property PointSpriteEnable As Boolean
C# | public bool PointSpriteEnable { get; set; }
Managed C++ public: __property bool get_PointSpriteEnable();
public: __property void set_PointSpriteEnable(bool);
JScript .NET public function get PointSpriteEnable() : boolean
public function set PointSpriteEnable(boolean);

Property Value

System.Boolean . When set to true, the texture coordinates of point sprites are set so that full textures are mapped on each point. When set to false, the vertex texture coordinates are used for the entire point.

This property is read/write.

Remarks

The default value is false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PositionDegree

RenderStateManager.PositionDegree Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the N-patch position interpolation degree.

Definition

Visual Basic .NET | Public Property PositionDegree As DegreeType
C# | public DegreeType PositionDegree { get; set; }
Managed C++ public: __property DegreeType get_PositionDegree();
public: __property void set_PositionDegree(DegreeType);
JScript .NET public function get PositionDegree() : DegreeType
public function set PositionDegree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType . Value of the DegreeType enumeration that specifies the degree.

This property is read/write.

Remarks

The default value is DegreeType.Cubic. The DegreeType.Linear value also can be used.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.RangeFogEnable

RenderStateManager.RangeFogEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets enabling of range-based vertex fog.

Definition

Visual Basic .NET | Public Property RangeFogEnable As Boolean
C# | public bool RangeFogEnable { get; set; }
Managed C++ public: __property bool get_RangeFogEnable();
public: __property void set_RangeFogEnable(bool);
JScript .NET public function get RangeFogEnable() : boolean
public function set RangeFogEnable(boolean);

Property Value

System.Boolean . Set to true to enable range-based vertex fog, or false to use depth-based fog.

This property is read/write.

Remarks

The default value is false.

In range-based fog, the distance of an object from the viewer is used to compute fog effects, not the depth of the object (that is, the z-coordinate) in the scene. All fog methods work as usual, except that they use range instead of depth in the computations.

Range is the correct factor to use for fog computations, but depth is commonly used instead because it is generally already available, and range is resource-intensive to compute. Using depth to calculate fog has the undesirable effect of making the fogginess of peripheral objects change as the viewer's eye moves; in this case, the depth changes and the range remains constant.

Because no hardware currently supports per-pixel range-based fog, range correction is offered only for Vertex Fog.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ReferenceAlpha

RenderStateManager.ReferenceAlpha Property

Note: This documentation is preliminary and is subject to change.

Specifies a reference alpha value against which pixels are tested when alpha testing is enabled.

Definition

Visual Basic .NET | Public Property ReferenceAlpha As Integer
C# | public int ReferenceAlpha { get; set; }
Managed C++ public: __property int get_ReferenceAlpha();
public: __property void set_ReferenceAlpha(int);
JScript .NET public function get ReferenceAlpha() : int
public function set ReferenceAlpha(int);

Property Value

System.Int32 . Integer that specifies the reference alpha value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Values can range from 0x00000000 to 0x000000FF.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ReferenceStencil

RenderStateManager.ReferenceStencil Property

Note: This documentation is preliminary and is subject to change.

Specifies a reference value to use for the stencil test.

Definition

Visual Basic .NET | Public Property ReferenceStencil As Integer
C# | public int ReferenceStencil { get; set; }
Managed C++ public: __property int get_ReferenceStencil();
public: __property void set_ReferenceStencil(int);
JScript .NET public function get ReferenceStencil() : int
public function set ReferenceStencil(int);

Property Value

System.Int32 . Integer that specifies the stencil test value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ScissorTestEnable

RenderStateManager.ScissorTestEnable Property

Note: This documentation is preliminary and is subject to change.

Enables or disables scissor testing.

Definition

Visual Basic .NET | Public Property ScissorTestEnable As Boolean
C# | public bool ScissorTestEnable { get; set; }
Managed C++ public: __property bool get_ScissorTestEnable();
public: __property void set_ScissorTestEnable(bool);
JScript .NET public function get ScissorTestEnable() : boolean
public function set ScissorTestEnable(boolean);

Property Value

System.Boolean . Set to true to enable scissor testing, or false to disable it.

This property is read/write.

Remarks

The default value is false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SeparateAlphaBlendEnabled

RenderStateManager.SeparateAlphaBlendEnabled Property

Note: This documentation is preliminary and is subject to change.

Enables or disables the separate for the alpha channel.

Definition

Visual Basic .NET | Public Property SeparateAlphaBlendEnabled As Boolean
C# | public bool SeparateAlphaBlendEnabled { get; set; }
Managed C++ public: __property bool get_SeparateAlphaBlendEnabled();
public: __property void set_SeparateAlphaBlendEnabled(bool);
JScript .NET public function get SeparateAlphaBlendEnabled() : boolean
public function set SeparateAlphaBlendEnabled(boolean);

Property Value

System.Boolean . Set to true to enable separate alpha blend, or false to disable it.

This property is read/write.

Remarks

The default value is false.

When set to false, the render target blending factors and operations applied to alpha are forced to be the same as those defined for color. This mode is effectively hard-wired to false on implementations that do not set MiscCaps.SupportsSeparateAlphaBlend.

The type of separate alpha blending is determined by RenderStateManager.AlphaSourceBlend and RenderStateManager.AlphaDestinationBlend.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ShadeMode

RenderStateManager.ShadeMode Property

Note: This documentation is preliminary and is subject to change.

Contains one or more members of the ShadeMode enumeration.

Definition

Visual Basic .NET | Public Property ShadeMode As ShadeMode
C# | public ShadeMode ShadeMode { get; set; }
Managed C++ public: __property ShadeMode get_ShadeMode();
public: __property void set_ShadeMode(ShadeMode);
JScript .NET public function get ShadeMode() : ShadeMode
public function set ShadeMode(ShadeMode);

Property Value

Microsoft.DirectX.Direct3D.ShadeMode . Value of the ShadeMode enumeration to set or retrieve.

This property is read/write.

Remarks

The default value is ShadeMode.Gouraud.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SlopeScaleDepthBias

RenderStateManager.SlopeScaleDepthBias Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value used to determine how much bias can be applied to coplanar primitives to reduce z-fighting.

Definition

Visual Basic .NET | Public Property SlopeScaleDepthBias As Single
C# | public float SlopeScaleDepthBias { get; set; }
Managed C++ public: __property float get_SlopeScaleDepthBias();
public: __property void set_SlopeScaleDepthBias(float);
JScript .NET public function get SlopeScaleDepthBias() : float
public function set SlopeScaleDepthBias(float);

Property Value

System.Single . Floating-point value that specifies the slope scale bias to apply.

This property is read/write.

Remarks

The default value is 0.

Polygons that are coplanar in your 3-D space can be made to appear as if they are not coplanar by adding a z-bias to each one. An application can help ensure that coplanar polygons are rendered properly by adding a bias to the z-values that the system uses when rendering sets of coplanar polygons.

The following formula shows how to calculate the bias to be applied to coplanar primitives.

bias = (m * SlopeScaleDepthBias) + DepthBias

where m is the maximum depth slope of the triangle being rendered, defined as:

m = max(abs(delta z / delta x), abs(delta z / delta y))

See Also

  • Depth Buffers
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SourceBlend

RenderStateManager.SourceBlend Property

Note: This documentation is preliminary and is subject to change.

Contains a member of the Blend enumeration.

Definition

Visual Basic .NET | Public Property SourceBlend As Blend
C# | public Blend SourceBlend { get; set; }
Managed C++ public: __property Blend get_SourceBlend();
public: __property void set_SourceBlend(Blend);
JScript .NET public function get SourceBlend() : Blend
public function set SourceBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend . The Blend mode to set or retrieve.

This property is read/write.

Remarks

The default value is Blend.One.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SpecularEnable

RenderStateManager.SpecularEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a render state that enables specular highlights.

Definition

Visual Basic .NET | Public Property SpecularEnable As Boolean
C# | public bool SpecularEnable { get; set; }
Managed C++ public: __property bool get_SpecularEnable();
public: __property void set_SpecularEnable(bool);
JScript .NET public function get SpecularEnable() : boolean
public function set SpecularEnable(boolean);

Property Value

System.Boolean . Set to true to enable specular highlights, or false to disable them.

This property is read/write.

Remarks

The default value is false.

Specular highlights are calculated as though every vertex in the object being lit is at the object's origin. This gives the expected results as long as the object is modeled around the origin and the distance from the light to the object is relatively large. In other cases, the results are undefined.

When this state is set to true, the specular color is added to the base color after the texture cascade but before alpha blending.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SpecularMaterialSource

RenderStateManager.SpecularMaterialSource Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the specular color source for lighting calculations.

Definition

Visual Basic .NET | Public Property SpecularMaterialSource As ColorSource
C# | public ColorSource SpecularMaterialSource { get; set; }
Managed C++ public: __property ColorSource get_SpecularMaterialSource();
public: __property void set_SpecularMaterialSource(ColorSource);
JScript .NET public function get SpecularMaterialSource() : ColorSource
public function set SpecularMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource . Value of the ColorSource enumeration that specifies the specular color source value to set or retrieve.

This property is read/write.

Remarks

The default value is ColorSource.Color2.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SrgbWriteEnable

RenderStateManager.SrgbWriteEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a render state that enables render-target writes to be gamma corrected to sRGB.

Definition

Visual Basic .NET | Public Property SrgbWriteEnable As Boolean
C# | public bool SrgbWriteEnable { get; set; }
Managed C++ public: __property bool get_SrgbWriteEnable();
public: __property void set_SrgbWriteEnable(bool);
JScript .NET public function get SrgbWriteEnable() : boolean
public function set SrgbWriteEnable(boolean);

Property Value

System.Boolean . Set to true to enable sRGB writes, or false to disable it. The default value is false.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilEnable

RenderStateManager.StencilEnable Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets stencil enabling.

Definition

Visual Basic .NET | Public Property StencilEnable As Boolean
C# | public bool StencilEnable { get; set; }
Managed C++ public: __property bool get_StencilEnable();
public: __property void set_StencilEnable(bool);
JScript .NET public function get StencilEnable() : boolean
public function set StencilEnable(boolean);

Property Value

System.Boolean . Set to true to enable stenciling, or false to disable it.

This property is read/write.

Remarks

The default value is false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilFail

RenderStateManager.StencilFail Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the stencil operation to perform if the stencil test fails.

Definition

Visual Basic .NET | Public Property StencilFail As StencilOperation
C# | public StencilOperation StencilFail { get; set; }
Managed C++ public: __property StencilOperation get_StencilFail();
public: __property void set_StencilFail(StencilOperation);
JScript .NET public function get StencilFail() : StencilOperation
public function set StencilFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation . Value of the StencilOperation enumeration that represents the value of the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilFunction

RenderStateManager.StencilFunction Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the comparison function for the stencil test.

Definition

Visual Basic .NET | Public Property StencilFunction As Compare
C# | public Compare StencilFunction { get; set; }
Managed C++ public: __property Compare get_StencilFunction();
public: __property void set_StencilFunction(Compare);
JScript .NET public function get StencilFunction() : Compare
public function set StencilFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare . A value of the Compare enumeration that represents the comparison function to set or retrieve.

This property is read/write.

Remarks

The default value is Compare.Always.

The comparison function is used to compare the reference value to a stencil buffer entry. This comparison applies only to the bits in the reference value and stencil buffer entry that are set in the stencil mask (by RenderStateManager.StencilMask). If the comparison is true, the stencil test passes.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilMask

RenderStateManager.StencilMask Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the mask applied to the reference value and each stencil buffer entry to determine the significant bits for the stencil test.

Definition

Visual Basic .NET | Public Property StencilMask As Integer
C# | public int StencilMask { get; set; }
Managed C++ public: __property int get_StencilMask();
public: __property void set_StencilMask(int);
JScript .NET public function get StencilMask() : int
public function set StencilMask(int);

Property Value

System.Int32 . Integer value that represents the mask to set or retrieve.

This property is read/write.

Remarks

The default mask is 0xFFFFFFFF.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilPass

RenderStateManager.StencilPass Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the stencil operation to perform if both the stencil test and the depth test (z-test) pass.

Definition

Visual Basic .NET | Public Property StencilPass As StencilOperation
C# | public StencilOperation StencilPass { get; set; }
Managed C++ public: __property StencilOperation get_StencilPass();
public: __property void set_StencilPass(StencilOperation);
JScript .NET public function get StencilPass() : StencilOperation
public function set StencilPass(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation . Value of the StencilOperation enumeration that represents the value of the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilWriteMask

RenderStateManager.StencilWriteMask Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the write mask applied to values written into the stencil buffer.

Definition

Visual Basic .NET | Public Property StencilWriteMask As Integer
C# | public int StencilWriteMask { get; set; }
Managed C++ public: __property int get_StencilWriteMask();
public: __property void set_StencilWriteMask(int);
JScript .NET public function get StencilWriteMask() : int
public function set StencilWriteMask(int);

Property Value

System.Int32 . Integer value that represents the write mask to set or retrieve.

This property is read/write.

Remarks

The default mask is 0xFFFFFFFF.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilZBufferFail

RenderStateManager.StencilZBufferFail Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the stencil operation to perform if the stencil test passes and the depth test (z-test) fails.

Definition

Visual Basic .NET | Public Property StencilZBufferFail As StencilOperation
C# | public StencilOperation StencilZBufferFail { get; set; }
Managed C++ public: __property StencilOperation get_StencilZBufferFail();
public: __property void set_StencilZBufferFail(StencilOperation);
JScript .NET public function get StencilZBufferFail() : StencilOperation
public function set StencilZBufferFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation . Value of the StencilOperation enumeration that represents the value of the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.TextureFactor

RenderStateManager.TextureFactor Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the color used for multiple-texture blending with the TextureArgument.TFactor texture blending argument or the TextureOperation.BlendFactorAlpha texture blending operation.

Definition

Visual Basic .NET | Public Property TextureFactor As Integer
C# | public int TextureFactor { get; set; }
Managed C++ public: __property int get_TextureFactor();
public: __property void set_TextureFactor(int);
JScript .NET public function get TextureFactor() : int
public function set TextureFactor(int);

Property Value

System.Int32 . Integer value that represents the color value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.TweenFactor

RenderStateManager.TweenFactor Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a floating-point value that controls the tween factor.

Definition

Visual Basic .NET | Public Property TweenFactor As Single
C# | public float TweenFactor { get; set; }
Managed C++ public: __property float get_TweenFactor();
public: __property void set_TweenFactor(float);
JScript .NET public function get TweenFactor() : float
public function set TweenFactor(float);

Property Value

System.Single . Value that controls the tween factor.

This property is read/write.

Remarks

The default value is 0.0f.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.TwoSidedStencilMode

RenderStateManager.TwoSidedStencilMode Property

Note: This documentation is preliminary and is subject to change.

Enables or disables two-sided stenciling.

Definition

Visual Basic .NET | Public Property TwoSidedStencilMode As Boolean
C# | public bool TwoSidedStencilMode { get; set; }
Managed C++ public: __property bool get_TwoSidedStencilMode();
public: __property void set_TwoSidedStencilMode(bool);
JScript .NET public function get TwoSidedStencilMode() : boolean
public function set TwoSidedStencilMode(boolean);

Property Value

System.Boolean . Set to true to enable two-sided stenciling, or false to disable it.

This property is read/write.

Remarks

The application should set RenderStateManager.CullMode to Cull.None to enable two-sided stencil mode. If the triangle winding order is clockwise, the RenderStateManager.Stencil* operations are used. If the winding order is counterclockwise, the RenderStateManager.CounterClockwiseStencil* operations are used.

See Also

  • StencilOperation
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.UseWBuffer

RenderStateManager.UseWBuffer Property

Note: This documentation is preliminary and is subject to change.

Enables or disables w-buffering.

Definition

Visual Basic .NET | Public Property UseWBuffer As Boolean
C# | public bool UseWBuffer { get; set; }
Managed C++ public: __property bool get_UseWBuffer();
public: __property void set_UseWBuffer(bool);
JScript .NET public function get UseWBuffer() : boolean
public function set UseWBuffer(boolean);

Property Value

System.Boolean . Value that is set to true to enable w-buffering, or false to disable it.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.VertexBlend

RenderStateManager.VertexBlend Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of matrices to use to perform geometry blending.

Definition

Visual Basic .NET | Public Property VertexBlend As VertexBlend
C# | public VertexBlend VertexBlend { get; set; }
Managed C++ public: __property VertexBlend get_VertexBlend();
public: __property void set_VertexBlend(VertexBlend);
JScript .NET public function get VertexBlend() : VertexBlend
public function set VertexBlend(VertexBlend);

Property Value

Microsoft.DirectX.Direct3D.VertexBlend . Value of the VertexBlend enumeration to set or retrieve.

This property is read/write.

Remarks

The default value is VertexBlend.Disable.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap0

RenderStateManager.Wrap0 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap0 As WrapCoordinates
C# | public WrapCoordinates Wrap0 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap0();
public: __property void set_Wrap0(WrapCoordinates);
JScript .NET public function get Wrap0() : WrapCoordinates
public function set Wrap0(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap1

RenderStateManager.Wrap1 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap1 As WrapCoordinates
C# | public WrapCoordinates Wrap1 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap1();
public: __property void set_Wrap1(WrapCoordinates);
JScript .NET public function get Wrap1() : WrapCoordinates
public function set Wrap1(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap10

RenderStateManager.Wrap10 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap10 As WrapCoordinates
C# | public WrapCoordinates Wrap10 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap10();
public: __property void set_Wrap10(WrapCoordinates);
JScript .NET public function get Wrap10() : WrapCoordinates
public function set Wrap10(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap11

RenderStateManager.Wrap11 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap11 As WrapCoordinates
C# | public WrapCoordinates Wrap11 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap11();
public: __property void set_Wrap11(WrapCoordinates);
JScript .NET public function get Wrap11() : WrapCoordinates
public function set Wrap11(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap12

RenderStateManager.Wrap12 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap12 As WrapCoordinates
C# | public WrapCoordinates Wrap12 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap12();
public: __property void set_Wrap12(WrapCoordinates);
JScript .NET public function get Wrap12() : WrapCoordinates
public function set Wrap12(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap13

RenderStateManager.Wrap13 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap13 As WrapCoordinates
C# | public WrapCoordinates Wrap13 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap13();
public: __property void set_Wrap13(WrapCoordinates);
JScript .NET public function get Wrap13() : WrapCoordinates
public function set Wrap13(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap14

RenderStateManager.Wrap14 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap14 As WrapCoordinates
C# | public WrapCoordinates Wrap14 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap14();
public: __property void set_Wrap14(WrapCoordinates);
JScript .NET public function get Wrap14() : WrapCoordinates
public function set Wrap14(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap15

RenderStateManager.Wrap15 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap15 As WrapCoordinates
C# | public WrapCoordinates Wrap15 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap15();
public: __property void set_Wrap15(WrapCoordinates);
JScript .NET public function get Wrap15() : WrapCoordinates
public function set Wrap15(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap2

RenderStateManager.Wrap2 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap2 As WrapCoordinates
C# | public WrapCoordinates Wrap2 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap2();
public: __property void set_Wrap2(WrapCoordinates);
JScript .NET public function get Wrap2() : WrapCoordinates
public function set Wrap2(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap3

RenderStateManager.Wrap3 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap3 As WrapCoordinates
C# | public WrapCoordinates Wrap3 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap3();
public: __property void set_Wrap3(WrapCoordinates);
JScript .NET public function get Wrap3() : WrapCoordinates
public function set Wrap3(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap4

RenderStateManager.Wrap4 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap4 As WrapCoordinates
C# | public WrapCoordinates Wrap4 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap4();
public: __property void set_Wrap4(WrapCoordinates);
JScript .NET public function get Wrap4() : WrapCoordinates
public function set Wrap4(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap5

RenderStateManager.Wrap5 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap5 As WrapCoordinates
C# | public WrapCoordinates Wrap5 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap5();
public: __property void set_Wrap5(WrapCoordinates);
JScript .NET public function get Wrap5() : WrapCoordinates
public function set Wrap5(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap6

RenderStateManager.Wrap6 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap6 As WrapCoordinates
C# | public WrapCoordinates Wrap6 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap6();
public: __property void set_Wrap6(WrapCoordinates);
JScript .NET public function get Wrap6() : WrapCoordinates
public function set Wrap6(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap7

RenderStateManager.Wrap7 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap7 As WrapCoordinates
C# | public WrapCoordinates Wrap7 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap7();
public: __property void set_Wrap7(WrapCoordinates);
JScript .NET public function get Wrap7() : WrapCoordinates
public function set Wrap7(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap8

RenderStateManager.Wrap8 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap8 As WrapCoordinates
C# | public WrapCoordinates Wrap8 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap8();
public: __property void set_Wrap8(WrapCoordinates);
JScript .NET public function get Wrap8() : WrapCoordinates
public function set Wrap8(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap9

RenderStateManager.Wrap9 Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic .NET | Public Property Wrap9 As WrapCoordinates
C# | public WrapCoordinates Wrap9 { get; set; }
Managed C++ public: __property WrapCoordinates get_Wrap9();
public: __property void set_Wrap9(WrapCoordinates);
JScript .NET public function get Wrap9() : WrapCoordinates
public function set Wrap9(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates . Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ZBufferEnable

RenderStateManager.ZBufferEnable Property

Note: This documentation is preliminary and is subject to change.

Enables or disables depth buffering.

Definition

Visual Basic .NET | Public Property ZBufferEnable As Boolean
C# | public bool ZBufferEnable { get; set; }
Managed C++ public: __property bool get_ZBufferEnable();
public: __property void set_ZBufferEnable(bool);
JScript .NET public function get ZBufferEnable() : boolean
public function set ZBufferEnable(boolean);

Property Value

System.Boolean . Set to true to enable depth buffering, or false to disable it.

This property is read/write.

Remarks

The default value is true.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ZBufferFunction

RenderStateManager.ZBufferFunction Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the comparison function for the z-buffer test.

Definition

Visual Basic .NET | Public Property ZBufferFunction As Compare
C# | public Compare ZBufferFunction { get; set; }
Managed C++ public: __property Compare get_ZBufferFunction();
public: __property void set_ZBufferFunction(Compare);
JScript .NET public function get ZBufferFunction() : Compare
public function set ZBufferFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare . Value of the Compare enumeration that represents the comparison function to set or retrieve.

This property is read/write.

Remarks

The depth value of the pixel is compared to the depth-buffer value. If the depth value of the pixel passes the comparison function, the pixel is written.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ZBufferWriteEnable

RenderStateManager.ZBufferWriteEnable Property

Note: This documentation is preliminary and is subject to change.

Enables or disables writing to the depth buffer.

Definition

Visual Basic .NET | Public Property ZBufferWriteEnable As Boolean
C# | public bool ZBufferWriteEnable { get; set; }
Managed C++ public: __property bool get_ZBufferWriteEnable();
public: __property void set_ZBufferWriteEnable(bool);
JScript .NET public function get ZBufferWriteEnable() : boolean
public function set ZBufferWriteEnable(boolean);

Property Value

System.Boolean . Set to true to enable writing to the depth buffer, or false to disable it.

This property is read/write.

Remarks

The default value is true.

This member enables an application to prevent the system from updating the depth buffer with new depth values.

If false, depth comparisons are still made according to the render state ZBufferFunction, assuming that depth buffering is taking place, but depth values are not written to the buffer.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.RenderToEnvironmentMap

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap Class

Language:
Note: This documentation is preliminary and is subject to change.

Generalizes the process of rendering to environment maps. An environment map is used to texture-map scene geometry to provide a more sophisticated scene without using complex geometry. This class supports the creation of surfaces for the following kinds of geometry: cube, half sphere or hemispheric, parabolic, and sphere.

Definition

Visual Basic .NET NotInheritable Public Class RenderToEnvironmentMap
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class RenderToEnvironmentMap : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class RenderToEnvironmentMap : public MarshalByRefObject,
IDisposable
JScript .NET public class RenderToEnvironmentMap extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the RenderToEnvironmentMap object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally immediately prior to a device reset.
Reset | Occurs after the RenderToEnvironmentMap.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
BeginCube | Initiates the rendering of a cubic environment map.
BeginHemisphere | Initiates the rendering of a hemisphere environment map.
BeginParabolic | Initiates the rendering of a parabolic environment map.
BeginSphere | Initiates the rendering of a spherical environment map.
Dispose | Immediately releases the unmanaged resources used by the RenderToEnvironmentMap object.
End | Ends a scene for an environmental map.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Face | Initiates the drawing of each face of an environment map.
Finalize | Allows the RenderToEnvironmentMap object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing event when called from within a derived class.
raise_Lost | Raises a RenderToEnvironmentMap.Lost event when called from within a derived class.
raise_Reset | Raises a RenderToEnvironmentMap.Reset event when called from within a derived class.
RenderToEnvironmentMap | Initializes a new instance of the RenderToEnvironmentMap class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this RenderToEnvironmentMap object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves the description of the render surface.
Device | Retrieves the Device associated with the environment map.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
RenderToEnvironmentMap

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RenderToEnvironmentMap.BeginCube(CubeTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.BeginCube Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initiates the rendering of a cubic environment map.

Definition

Visual Basic .NET Public Sub BeginCube( _
ByVal cubeTexture As CubeTexture _
)
C# public void BeginCube(
CubeTexture cubeTexture
);
Managed C++ public: void BeginCube(
CubeTexture *cubeTexture
);
JScript .NET public function BeginCube(
cubeTexture : CubeTexture
);

Parameters

cubeTexture Microsoft.DirectX.Direct3D.CubeTexture. A CubeTexture object that represents the cube texture to render.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.BeginHemisphere(Texture,Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.BeginHemisphere Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initiates the rendering of a hemisphere environment map.

Definition

Visual Basic .NET Public Sub BeginHemisphere( _
ByVal textureZPos As Texture, _
ByVal textureZNeg As Texture _
)
C# public void BeginHemisphere(
Texture textureZPos,
Texture textureZNeg
);
Managed C++ public: void BeginHemisphere(
Texture *textureZPos,
Texture *textureZNeg
);
JScript .NET public function BeginHemisphere(
textureZPos : Texture,
textureZNeg : Texture
);

Parameters

textureZPos | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the positive texture render surface.
textureZNeg | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the negative texture render surface.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.BeginParabolic(Texture,Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.BeginParabolic Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initiates the rendering of a parabolic environment map.

Definition

Visual Basic .NET Public Sub BeginParabolic( _
ByVal textureZPos As Texture, _
ByVal textureZNeg As Texture _
)
C# public void BeginParabolic(
Texture textureZPos,
Texture textureZNeg
);
Managed C++ public: void BeginParabolic(
Texture *textureZPos,
Texture *textureZNeg
);
JScript .NET public function BeginParabolic(
textureZPos : Texture,
textureZNeg : Texture
);

Parameters

textureZPos | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the positive render texture.
textureZNeg | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the negative render texture.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.BeginSphere(Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.BeginSphere Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initiates the rendering of a spherical environment map.

Definition

Visual Basic .NET Public Sub BeginSphere( _
ByVal texture As Texture _
)
C# public void BeginSphere(
Texture texture
);
Managed C++ public: void BeginSphere(
Texture *texture
);
JScript .NET public function BeginSphere(
texture : Texture
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the texture to render.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the RenderToEnvironmentMap object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposed
  • Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing


RenderToEnvironmentMap.End(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.End Method

 Language:
Note: This documentation is preliminary and is subject to change.

Ends a scene for an environmental map.

Definition

Visual Basic .NET Public Sub End( _
ByVal faceMapFilter As Integer _
)
C# public void End(
int faceMapFilter
);
Managed C++ public: void End(
int faceMapFilter
);
JScript .NET public function End(
faceMapFilter : int
);

Parameters

faceMapFilter System.Int32. Valid combination of Filter enumeration values.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


RenderToEnvironmentMap.Face(CubeMapFace,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Face Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initiates the drawing of each face of an environment map.

Definition

Visual Basic .NET Public Sub Face( _
ByVal face As CubeMapFace, _
ByVal faceMapFilter As Integer _
)
C# public void Face(
CubeMapFace face,
int faceMapFilter
);
Managed C++ public: void Face(
CubeMapFace face,
int faceMapFilter
);
JScript .NET public function Face(
face : CubeMapFace,
faceMapFilter : int
);

Parameters

face | Microsoft.DirectX.Direct3D.CubeMapFace. A CubeMapFace object that represents the first face of the environmental cube map.
faceMapFilter | System.Int32. Valid combination of Filter enumeration values.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the RenderToEnvironmentMap object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~RenderToEnvironmentMap();
Managed C++ | ~RenderToEnvironmentMap();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


RenderToEnvironmentMap.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


RenderToEnvironmentMap.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXRenderToEnvMap, which allows unmanaged COM clients to create an instance of the managed RenderToEnvironmentMap class. Not supported.


RenderToEnvironmentMap.OnLostDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.OnLostDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic .NET | Public Sub OnLostDevice()
C# | public void OnLostDevice();
Managed C++ | public: void OnLostDevice();
JScript .NET | public function OnLostDevice();

Remarks

This method should be called whenever a device is lost. Before the object can be used again, the device must be reset and the RenderToEnvironmentMap.OnResetDevice method called.


RenderToEnvironmentMap.OnResetDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.OnResetDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic .NET | Public Sub OnResetDevice()
C# | public void OnResetDevice();
Managed C++ | public: void OnResetDevice();
JScript .NET | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, under normal circumstances it is unnecessary to call RenderToEnvironmentMap.OnResetDevice. However, if at any point Device.IsUsingEventHandlers is set to false, RenderToEnvironmentMap.OnResetDevice should be called immediately after the device is reset.


RenderToEnvironmentMap.op_Equality(RenderToEnvironmentMap,RenderToEnvironmentMap)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As RenderToEnvironmentMap, _
ByVal right As RenderToEnvironmentMap _
) As Boolean
C# public static bool op_Equality(
RenderToEnvironmentMap left,
RenderToEnvironmentMap right
);
Managed C++ public: static bool op_Equality(
RenderToEnvironmentMap *left,
RenderToEnvironmentMap *right
);
JScript .NET public static function op_Equality(
left : RenderToEnvironmentMap,
right : RenderToEnvironmentMap
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.RenderToEnvironmentMap. The RenderToEnvironmentMap object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.RenderToEnvironmentMap. The RenderToEnvironmentMap object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


RenderToEnvironmentMap.op_Inequality(RenderToEnvironmentMap,RenderToEnvironmentMap)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As RenderToEnvironmentMap, _
ByVal right As RenderToEnvironmentMap _
) As Boolean
C# public static bool op_Inequality(
RenderToEnvironmentMap left,
RenderToEnvironmentMap right
);
Managed C++ public: static bool op_Inequality(
RenderToEnvironmentMap *left,
RenderToEnvironmentMap *right
);
JScript .NET public static function op_Inequality(
left : RenderToEnvironmentMap,
right : RenderToEnvironmentMap
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.RenderToEnvironmentMap. The RenderToEnvironmentMap object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.RenderToEnvironmentMap. The RenderToEnvironmentMap object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


RenderToEnvironmentMap.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


RenderToEnvironmentMap.raise_Lost(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.raise_Lost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a RenderToEnvironmentMap.Lost event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Lost(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


RenderToEnvironmentMap.raise_Reset(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.raise_Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a RenderToEnvironmentMap.Reset event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Reset(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


RenderToEnvironmentMap.RenderToEnvironmentMap

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.RenderToEnvironmentMap Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToEnvironmentMap class.

Overload List

public RenderToEnvironmentMap(Device, int, int, Format, bool, DepthFormat);
public RenderToEnvironmentMap(ID3DXRenderToEnvMap);
public RenderToEnvironmentMap(IntPtr);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.RenderToEnvironmentMap(ID3DXRenderToEnvMap)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.RenderToEnvironmentMap Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToEnvironmentMap class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXRenderToEnvMap _
)
C# public RenderToEnvironmentMap(
ID3DXRenderToEnvMap pUnk
);
Managed C++ public: RenderToEnvironmentMap(
ID3DXRenderToEnvMap pUnk
);
JScript .NET public function RenderToEnvironmentMap(
pUnk : ID3DXRenderToEnvMap
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToEnvMap. Unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface pointer.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.RenderToEnvironmentMap(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.RenderToEnvironmentMap Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToEnvironmentMap class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public RenderToEnvironmentMap(
IntPtr unmanagedObject
);
Managed C++ public: RenderToEnvironmentMap(
IntPtr unmanagedObject
);
JScript .NET public function RenderToEnvironmentMap(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.RenderToEnvironmentMap(Device,Int32,Int32,Format,Boolean,DepthFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.RenderToEnvironmentMap Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToEnvironmentMap class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal format As Format, _
ByVal depthStencil As Boolean, _
ByVal depthStencilFormat As DepthFormat _
)
C# public RenderToEnvironmentMap(
Device device,
int size,
int mipLevels,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
Managed C++ public: RenderToEnvironmentMap(
Device *device,
int size,
int mipLevels,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
JScript .NET public function RenderToEnvironmentMap(
device : Device,
size : int,
mipLevels : int,
format : Format,
depthStencil : boolean,
depthStencilFormat : DepthFormat
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device to associate with the render surface.
size | System.Int32. Value that represents the size of the render surface.
mipLevels | System.Int32. Value that represents the number of mipmap levels.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that describes the pixel format of the environment map.
depthStencil | System.Boolean. Set to true if the render surface supports a depth-stencil surface; otherwise, false.
depthStencilFormat | Microsoft.DirectX.Direct3D.DepthFormat. If depthStencil is true, this parameter is a member of the Format enumeration that describes the environment map's depth-stencil format.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.UpdateUnmanagedPointer(ID3DXRenderToEnvMap)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this RenderToEnvironmentMap object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXRenderToEnvMap _
)
C# public void UpdateUnmanagedPointer(
ID3DXRenderToEnvMap pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXRenderToEnvMap pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXRenderToEnvMap
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToEnvMap. Pointer to the ID3DXRenderToEnvMap structure used to update the unmanaged pointer for this RenderToEnvironmentMap object.


RenderToEnvironmentMap.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the description of the render surface.

Definition

Visual Basic .NET | Public ReadOnly Property Description As RenderToEnvironmentDescription
C# | public RenderToEnvironmentDescription Description { get; }
Managed C++ | public: __property RenderToEnvironmentDescription get_Description();
JScript .NET | public function get Description() : RenderToEnvironmentDescription

Property Value

Microsoft.DirectX.Direct3D.RenderToEnvironmentDescription . A RenderToEnvironmentDescription object that contains the render surface description.

This property is read-only.


RenderToEnvironmentMap.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device associated with the environment map.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object associated with the environment map.

This property is read-only.


RenderToEnvironmentMap.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


RenderToEnvironmentMap.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXRenderToEnvMap
C# | public ID3DXRenderToEnvMap UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXRenderToEnvMap get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXRenderToEnvMap

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToEnvMap . Unmanaged ID3DXRenderToEnvMap interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


RenderToEnvironmentMap.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the RenderToEnvironmentMap object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the RenderToEnvironmentMap object indicates whether that object has been disposed.


RenderToEnvironmentMap.Lost

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Lost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when an object is lost, normally immediately prior to a device reset.

Definition

Visual Basic .NET | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
Managed C++ | public: __event EventHandler Lost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToEnvironmentMap.Lost event, use the following C# code.

[C#]
rtem.Lost += new System.EventHandler(this.LostEventHandler);


RenderToEnvironmentMap.Reset

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentMap.Reset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after the RenderToEnvironmentMap.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic .NET | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
Managed C++ | public: __event EventHandler Reset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToEnvironmentMap.OnResetDevice event, use the following C# code.

[C#]
rtem.Reset += new System.EventHandler(this.ResetEventHandler);


Microsoft.DirectX.Direct3D.RenderToSurface

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface Class

Language:
Note: This documentation is preliminary and is subject to change.

Generalizes the process of rendering to surfaces. Surfaces can be used in a variety of ways; for example, as render targets, or for off-screen rendering and rendering to textures.

Definition

Visual Basic .NET NotInheritable Public Class RenderToSurface
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class RenderToSurface : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class RenderToSurface : public MarshalByRefObject,
IDisposable
JScript .NET public class RenderToSurface extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the RenderToSurface object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally immediately prior to a device reset.
Reset | Occurs after the RenderToSurface.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
BeginScene | Begins a scene.
Dispose | Immediately releases the unmanaged resources used by the RenderToSurface object.
EndScene | Ends a scene.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the RenderToSurface object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.RenderToSurface.Disposing event when called from within a derived class.
raise_Lost | Raises a RenderToSurface.Lost event when called from within a derived class.
raise_Reset | Raises a RenderToSurface.Reset event when called from within a derived class.
RenderToSurface | Initializes a new instance of the RenderToSurface class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this RenderToSurface object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves the description of the render surface.
Device | Retrieves the Device associated with the render surface.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXRenderToSurface interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
RenderToSurface

Remarks

To provide a custom render view, a surface can be configured using a separate viewport by calling RenderToSurface.BeginScene.

If the surface is not a render target, a compatible render target is used, and the result is copied to the surface at the end of the scene.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RenderToSurface.BeginScene

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.BeginScene Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begins a scene.

Overload List

public void BeginScene(Surface);
public void BeginScene(Surface, Viewport);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • RenderToSurface.EndScene


RenderToSurface.BeginScene(Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.BeginScene Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begins a scene.

Definition

Visual Basic .NET Public Sub BeginScene( _
ByVal surface As Surface _
)
C# public void BeginScene(
Surface surface
);
Managed C++ public: void BeginScene(
Surface *surface
);
JScript .NET public function BeginScene(
surface : Surface
);

Parameters

surface Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the render surface.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • RenderToSurface.EndScene


RenderToSurface.BeginScene(Surface,Viewport)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.BeginScene Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begins a scene.

Definition

Visual Basic .NET Public Sub BeginScene( _
ByVal surface As Surface, _
ByVal viewport As Viewport _
)
C# public void BeginScene(
Surface surface,
Viewport viewport
);
Managed C++ public: void BeginScene(
Surface *surface,
Viewport viewport
);
JScript .NET public function BeginScene(
surface : Surface,
viewport : Viewport
);

Parameters

surface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the render surface.
viewport | Microsoft.DirectX.Direct3D.Viewport. A Viewport object that describes the viewport for the scene.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • RenderToSurface.EndScene


RenderToSurface.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the RenderToSurface object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.RenderToSurface.Disposed
  • Microsoft.DirectX.Direct3D.RenderToSurface.Disposing


RenderToSurface.EndScene(Filter)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.EndScene Method

 Language:
Note: This documentation is preliminary and is subject to change.

Ends a scene.

Definition

Visual Basic .NET Public Sub EndScene( _
ByVal mipFilter As Filter _
)
C# public void EndScene(
Filter mipFilter
);
Managed C++ public: void EndScene(
Filter mipFilter
);
JScript .NET public function EndScene(
mipFilter : Filter
);

Parameters

mipFilter Microsoft.DirectX.Direct3D.Filter. Valid combination of Filter enumeration values.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • RenderToSurface.BeginScene


RenderToSurface.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


RenderToSurface.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the RenderToSurface object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~RenderToSurface();
Managed C++ | ~RenderToSurface();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


RenderToSurface.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


RenderToSurface.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXRenderToSurface, which allows unmanaged COM clients to create an instance of the managed RenderToSurface class. Not supported.


RenderToSurface.OnLostDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.OnLostDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic .NET | Public Sub OnLostDevice()
C# | public void OnLostDevice();
Managed C++ | public: void OnLostDevice();
JScript .NET | public function OnLostDevice();

Remarks

This method should be called whenever the device is lost. Before the object can be used again, the device must be reset and the RenderToSurface.OnResetDevice method called.


RenderToSurface.OnResetDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.OnResetDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic .NET | Public Sub OnResetDevice()
C# | public void OnResetDevice();
Managed C++ | public: void OnResetDevice();
JScript .NET | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, under normal circumstances it is unnecessary to call RenderToSurface.OnResetDevice. However, if at any point Device.IsUsingEventHandlers is set to false, RenderToSurface.OnResetDevice should be called immediately after the device is reset.


RenderToSurface.op_Equality(RenderToSurface,RenderToSurface)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As RenderToSurface, _
ByVal right As RenderToSurface _
) As Boolean
C# public static bool op_Equality(
RenderToSurface left,
RenderToSurface right
);
Managed C++ public: static bool op_Equality(
RenderToSurface *left,
RenderToSurface *right
);
JScript .NET public static function op_Equality(
left : RenderToSurface,
right : RenderToSurface
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.RenderToSurface. The RenderToSurface object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.RenderToSurface. The RenderToSurface object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


RenderToSurface.op_Inequality(RenderToSurface,RenderToSurface)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As RenderToSurface, _
ByVal right As RenderToSurface _
) As Boolean
C# public static bool op_Inequality(
RenderToSurface left,
RenderToSurface right
);
Managed C++ public: static bool op_Inequality(
RenderToSurface *left,
RenderToSurface *right
);
JScript .NET public static function op_Inequality(
left : RenderToSurface,
right : RenderToSurface
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.RenderToSurface. The RenderToSurface object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.RenderToSurface. The RenderToSurface object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


RenderToSurface.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.RenderToSurface.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


RenderToSurface.raise_Lost(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.raise_Lost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a RenderToSurface.Lost event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Lost(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


RenderToSurface.raise_Reset(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.raise_Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a RenderToSurface.Reset event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Reset(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


RenderToSurface.RenderToSurface

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.RenderToSurface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToSurface class.

Overload List

public RenderToSurface(Device, int, int, Format, bool, DepthFormat);
public RenderToSurface(ID3DXRenderToSurface);
public RenderToSurface(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


RenderToSurface.RenderToSurface(ID3DXRenderToSurface)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.RenderToSurface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToSurface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXRenderToSurface _
)
C# public RenderToSurface(
ID3DXRenderToSurface pUnk
);
Managed C++ public: RenderToSurface(
ID3DXRenderToSurface pUnk
);
JScript .NET public function RenderToSurface(
pUnk : ID3DXRenderToSurface
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToSurface. Unmanaged Component Object Model (COM) ID3DXRenderToSurface interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


RenderToSurface.RenderToSurface(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.RenderToSurface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToSurface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public RenderToSurface(
IntPtr unmanagedObject
);
Managed C++ public: RenderToSurface(
IntPtr unmanagedObject
);
JScript .NET public function RenderToSurface(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXRenderToSurface interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


RenderToSurface.RenderToSurface(Device,Int32,Int32,Format,Boolean,DepthFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.RenderToSurface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToSurface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As Format, _
ByVal depthStencil As Boolean, _
ByVal depthStencilFormat As DepthFormat _
)
C# public RenderToSurface(
Device device,
int width,
int height,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
Managed C++ public: RenderToSurface(
Device *device,
int width,
int height,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
JScript .NET public function RenderToSurface(
device : Device,
width : int,
height : int,
format : Format,
depthStencil : boolean,
depthStencilFormat : DepthFormat
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device to associate with the render surface.
width | System.Int32. Value that represents the width of the render surface, in pixels.
height | System.Int32. Value that represents the height of the render surface, in pixels.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumeration that describes the pixel format of the render surface.
depthStencil | System.Boolean. Set to true if the render surface supports a depth-stencil surface; otherwise, false.
depthStencilFormat | Microsoft.DirectX.Direct3D.DepthFormat. If depthStencil is set to true, this parameter is a member of the Format enumeration that describes the depth-stencil format of the render surface.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


RenderToSurface.UpdateUnmanagedPointer(ID3DXRenderToSurface)

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this RenderToSurface object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXRenderToSurface _
)
C# public void UpdateUnmanagedPointer(
ID3DXRenderToSurface pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXRenderToSurface pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXRenderToSurface
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToSurface. Pointer to the ID3DXRenderToSurface structure used to update the unmanaged pointer for this RenderToSurface object.


RenderToSurface.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the description of the render surface.

Definition

Visual Basic .NET | Public ReadOnly Property Description As RenderToSurfaceDescription
C# | public RenderToSurfaceDescription Description { get; }
Managed C++ | public: __property RenderToSurfaceDescription get_Description();
JScript .NET | public function get Description() : RenderToSurfaceDescription

Property Value

Microsoft.DirectX.Direct3D.RenderToSurfaceDescription . A RenderToSurfaceDescription object that contains the render surface description.

This property is read-only.


RenderToSurface.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device associated with the render surface.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object associated with the render surface.

This property is read-only.


RenderToSurface.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


RenderToSurface.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXRenderToSurface interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXRenderToSurface
C# | public ID3DXRenderToSurface UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXRenderToSurface get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXRenderToSurface

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToSurface . Unmanaged ID3DXRenderToSurface interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


RenderToSurface.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the RenderToSurface object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.RenderToSurface.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the RenderToSurface object indicates whether that object has been disposed.


RenderToSurface.Lost

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Lost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when an object is lost, normally immediately prior to a device reset.

Definition

Visual Basic .NET | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
Managed C++ | public: __event EventHandler Lost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToSurface.Lost event, use the following C# code.

[C#]
rts.Lost += new System.EventHandler(this.LostEventHandler);


RenderToSurface.Reset

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurface.Reset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after the RenderToSurface.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic .NET | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
Managed C++ | public: __event EventHandler Reset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToSurface.OnResetDevice event, use the following C# code.

[C#]
rts.Reset += new System.EventHandler(this.ResetEventHandler);


Microsoft.DirectX.Direct3D.Resource

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource Class

Language:
Note: This documentation is preliminary and is subject to change.

Queries and prepares resources.

Definition

Visual Basic .NET MustInherit Public Class Resource
Inherits MarshalByRefObject
C# | public abstract class Resource : MarshalByRefObject
Managed C++ | public __gc __abstract class Resource : public MarshalByRefObject
JScript .NET | public abstract class Resource extends MarshalByRefObject

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Resource object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
FreePrivateData | Frees the specified private data associated with the current resource.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreLoad | Preloads a managed resource.
Resource | Initializes a new instance of the Resource class.
SetPriority | Assigns the resource-management priority for the current resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the device associated with a resource.
Priority | Retrieves or sets the priority for the current resource.
Type | Retrieves the type of a resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
IndexBuffer
Surface
VertexBuffer

Remarks

To create a texture resource, use one of the following objects.

  • CubeTexture
  • Texture
  • VolumeTexture

To create a geometry-oriented resource, call one of the following methods.

  • IndexBuffer
  • VertexBuffer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Resource.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Resource object.

Definition

Visual Basic .NET | MustOverride Public Sub Dispose()
C# | public abstract void Dispose();
Managed C++ | public: virtual void Dispose() = 0;
JScript .NET | public abstract function Dispose();

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.FreePrivateData(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.FreePrivateData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Frees the specified private data associated with the current resource.

Definition

Visual Basic .NET Public Sub FreePrivateData( _
ByVal guidData As Guid _
)
C# public void FreePrivateData(
Guid guidData
);
Managed C++ public: void FreePrivateData(
Guid guidData
);
JScript .NET public function FreePrivateData(
guidData : Guid
);

Parameters

guidData System.Guid. Represents a globally unique identifier (GUID) that identifies the private data to free.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested Guid Leave Site was not found.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DResource9, which allows unmanaged COM clients to create an instance of the managed Resource class. Not supported.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.GetPrivateData(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.GetPrivateData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies the private data associated with a resource to a buffer.

Definition

Visual Basic .NET Public Function GetPrivateData( _
ByVal guidData As Guid _
) As Byte()
C# public byte[] GetPrivateData(
Guid guidData
);
Managed C++ public: Byte GetPrivateData(
Guid guidData
) __gc[];
JScript .NET public function GetPrivateData(
guidData : Guid
) : byte[];

Parameters

guidData System.Guid. Represents a globally unique identifier (GUID) that identifies the private data to retrieve.

Return Value

System.Byte[]. Returns an array of bytes Leave Site that contains the requested private data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested Guid Leave Site was not found.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.op_Equality(Resource,Resource)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Resource, _
ByVal right As Resource _
) As Boolean
C# public static bool op_Equality(
Resource left,
Resource right
);
Managed C++ public: static bool op_Equality(
Resource *left,
Resource *right
);
JScript .NET public static function op_Equality(
left : Resource,
right : Resource
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Resource. The Resource object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Resource. The Resource object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.op_Inequality(Resource,Resource)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Resource, _
ByVal right As Resource _
) As Boolean
C# public static bool op_Inequality(
Resource left,
Resource right
);
Managed C++ public: static bool op_Inequality(
Resource *left,
Resource *right
);
JScript .NET public static function op_Inequality(
left : Resource,
right : Resource
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Resource. The Resource object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Resource. The Resource object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.PreLoad()

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.PreLoad Method

 Language:
Note: This documentation is preliminary and is subject to change.

Preloads a managed resource.

Definition

Visual Basic .NET | Public Sub PreLoad()
C# | public void PreLoad();
Managed C++ | public: void PreLoad();
JScript .NET | public function PreLoad();

Remarks

Calling this method indicates that the application will need the managed resource shortly. This method has no effect on nonmanaged resources.

Resource.PreLoad detects "thrashing" conditions, in which more resources are used in each frame than can fit in video memory simultaneously. Under such circumstances, Resource.PreLoad silently does nothing.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Resource

Resource.Resource Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Resource class.

Overload List

public Resource(IDirect3DResource9);
public Resource(IntPtr);
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Resource.Resource(IDirect3DResource9)

Resource.Resource Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Resource class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DResource9 _
)
C# public Resource(
IDirect3DResource9 pUnk
);
Managed C++ public: Resource(
IDirect3DResource9 pUnk
);
JScript .NET public function Resource(
pUnk : IDirect3DResource9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DResource9. Unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Resource.Resource(IntPtr)

Resource.Resource Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Resource class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Resource(
IntPtr unmanagedObject
);
Managed C++ public: Resource(
IntPtr unmanagedObject
);
JScript .NET public function Resource(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DResource9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Resource.SetPriority(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.SetPriority Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assigns the resource-management priority for the current resource.

Definition

Visual Basic .NET Public Function SetPriority( _
ByVal priorityNew As Integer _
) As Integer
C# public int SetPriority(
int priorityNew
);
Managed C++ public: int SetPriority(
int priorityNew
);
JScript .NET public function SetPriority(
priorityNew : int
) : int;

Parameters

priorityNew System.Int32. New resource-management priority for the resource.

Return Value

System.Int32 . Previous priority value for the resource.

Remarks

Resource.SetPriority is used for priority control of managed resources. This method returns 0 on nonmanaged resources.

Priorities are used to determine when managed resources should be removed from memory. A resource assigned a low priority is removed before a resource with a high priority. If two resources have the same priority, the one that was used more recently is kept in memory, while the other is removed. Managed resources have a default priority of 0.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.SetPrivateData(Guid,Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.SetPrivateData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource.

Definition

Visual Basic .NET Public Sub SetPrivateData( _
ByVal guidData As Guid, _
ByVal privateData() As Byte _
)
C# public void SetPrivateData(
Guid guidData,
byte[] privateData
);
Managed C++ public: void SetPrivateData(
Guid guidData,
Byte privateData __gc[]
);
JScript .NET public function SetPrivateData(
guidData : Guid,
privateData : byte[]
);

Parameters

guidData | System.Guid. A globally unique identifier (GUID) that identifies the private data to set.
privateData | System.Byte[]. A Byte Leave Site array that contains the private data to associate with the resource.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® DirectX® could not allocate sufficient memory to complete the method call.
ArgumentNullException Leave Site | The privateData parameter is null.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.UpdateUnmanagedPointer(IDirect3DResource9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Resource object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DResource9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DResource9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DResource9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DResource9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DResource9. Pointer to the IDirect3DResource9 structure used to update the unmanaged pointer for this Resource object.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the device associated with a resource.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . Returns a Device object for the resource.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Priority

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.Priority Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the priority for the current resource.

Definition

Visual Basic .NET | Public Property Priority As Integer
C# | public int Priority { get; set; }
Managed C++ public: __property int get_Priority();
public: __property void set_Priority(int);
JScript .NET public function get Priority() : int
public function set Priority(int);

Property Value

System.Int32 . An Int32 Leave Site that represents the current priority of the resource, or a value to set that specifies the new priority for the resource.

This property is read/write.

Remarks

Resource.Priority is used for priority control of managed resources. It returns 0 on nonmanaged resources.

Priorities are used to determine when managed resources should be removed from memory. A resource assigned a low priority is removed before one with a high priority. If two resources have the same priority, the one that was used more recently is kept in memory, while the other is removed. Managed resources have a default priority of 0.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the type of a resource.

Definition

Visual Basic .NET | Public ReadOnly Property Type As ResourceType
C# | public ResourceType Type { get; }
Managed C++ | public: __property ResourceType get_Type();
JScript .NET | public function get Type() : ResourceType

Property Value

Microsoft.DirectX.Direct3D.ResourceType . Returns the ResourceType that identifies the type of the resource.

This property is read-only.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Resource.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DResource9
C# | public IDirect3DResource9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DResource9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DResource9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DResource9 . Unmanaged IDirect3DResource9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Microsoft.DirectX.Direct3D.SamplerStateManager

SamplerStateManager Class

Note: This documentation is preliminary and is subject to change.

Contains sampler states for the device.

Definition

Visual Basic .NET NotInheritable Public Class SamplerStateManager
Inherits Object
C# | public sealed class SamplerStateManager : Object
Managed C++ | public __gc __sealed class SamplerStateManager : public Object
JScript .NET | public class SamplerStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AddressU | Retrieves or sets the texture-address mode for the u-coordinate.
AddressV | Retrieves or sets the texture-address mode for the v-coordinate.
AddressW | Retrieves or sets the texture-address mode for the w-coordinate.
BorderColor | Retrieves or sets the border color.
BorderColorValue | Retrieves or sets the border color.
DMapOffset | Retrieves or sets the vertex offset in the presampled displacement map.
ElementIndex | Retrieves or sets the element index to use when an element with multiple textures is assigned to the sampler.
MagFilter | Retrieves or sets a magnification filter.
MaxAnisotropy | Retrieves or sets the maximum anisotropy.
MaxMipLevel | Retrieves or sets the LOD index of the largest map to use.
MinFilter | Retrieves or sets a minification filter.
MipFilter | Retrieves or sets a mipmap filter to use during minification.
MipMapLevelOfDetailBias | Retrieves or sets the mipmap level of detail (LOD) bias.
SrgbTexture | Determines whether to use gamma correction.

Inheritance Hierarchy

Object Leave Site
SamplerStateManager

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.ToString()

SamplerStateManager.ToString Method

Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.AddressU

SamplerStateManager.AddressU Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-address mode for the u-coordinate.

Definition

Visual Basic .NET | Public Property AddressU As TextureAddress
C# | public TextureAddress AddressU { get; set; }
Managed C++ public: __property TextureAddress get_AddressU();
public: __property void set_AddressU(TextureAddress);
JScript .NET public function get AddressU() : TextureAddress
public function set AddressU(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress . Member of the TextureAddress enumeration to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.AddressV

SamplerStateManager.AddressV Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-address mode for the v-coordinate.

Definition

Visual Basic .NET | Public Property AddressV As TextureAddress
C# | public TextureAddress AddressV { get; set; }
Managed C++ public: __property TextureAddress get_AddressV();
public: __property void set_AddressV(TextureAddress);
JScript .NET public function get AddressV() : TextureAddress
public function set AddressV(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress . Member of the TextureAddress enumeration to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.AddressW

SamplerStateManager.AddressW Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture-address mode for the w-coordinate.

Definition

Visual Basic .NET | Public Property AddressW As TextureAddress
C# | public TextureAddress AddressW { get; set; }
Managed C++ public: __property TextureAddress get_AddressW();
public: __property void set_AddressW(TextureAddress);
JScript .NET public function get AddressW() : TextureAddress
public function set AddressW(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress . Member of the TextureAddress enumeration to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.BorderColor

SamplerStateManager.BorderColor Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the border color.

Definition

Visual Basic .NET | Public Property BorderColor As Color
C# | public Color BorderColor { get; set; }
Managed C++ public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color);
JScript .NET public function get BorderColor() : Color
public function set BorderColor(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the border color to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.BorderColorValue

SamplerStateManager.BorderColorValue Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the border color.

Definition

Visual Basic .NET | Public Property BorderColorValue As Integer
C# | public int BorderColorValue { get; set; }
Managed C++ public: __property int get_BorderColorValue();
public: __property void set_BorderColorValue(int);
JScript .NET public function get BorderColorValue() : int
public function set BorderColorValue(int);

Property Value

System.Int32 . Integer that represents the border color to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.DMapOffset

SamplerStateManager.DMapOffset Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex offset in the presampled displacement map.

Definition

Visual Basic .NET | Public Property DMapOffset As Integer
C# | public int DMapOffset { get; set; }
Managed C++ public: __property int get_DMapOffset();
public: __property void set_DMapOffset(int);
JScript .NET public function get DMapOffset() : int
public function set DMapOffset(int);

Property Value

System.Int32 . Integer that represents the vertex offset in the displacement map to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.ElementIndex

SamplerStateManager.ElementIndex Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element index to use when an element with multiple textures is assigned to the sampler.

Definition

Visual Basic .NET | Public Property ElementIndex As Integer
C# | public int ElementIndex { get; set; }
Managed C++ public: __property int get_ElementIndex();
public: __property void set_ElementIndex(int);
JScript .NET public function get ElementIndex() : int
public function set ElementIndex(int);

Property Value

System.Int32 . Integer that represents the element index to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MagFilter

SamplerStateManager.MagFilter Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a magnification filter.

Definition

Visual Basic .NET | Public Property MagFilter As TextureFilter
C# | public TextureFilter MagFilter { get; set; }
Managed C++ public: __property TextureFilter get_MagFilter();
public: __property void set_MagFilter(TextureFilter);
JScript .NET public function get MagFilter() : TextureFilter
public function set MagFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter . Member of the TextureFilter enumeration that represents the magnification filter to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MaxAnisotropy

SamplerStateManager.MaxAnisotropy Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the maximum anisotropy.

Definition

Visual Basic .NET | Public Property MaxAnisotropy As Integer
C# | public int MaxAnisotropy { get; set; }
Managed C++ public: __property int get_MaxAnisotropy();
public: __property void set_MaxAnisotropy(int);
JScript .NET public function get MaxAnisotropy() : int
public function set MaxAnisotropy(int);

Property Value

System.Int32 . Integer that represents the maximum anisotropy value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MaxMipLevel

SamplerStateManager.MaxMipLevel Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the level of detail (LOD) index of the largest map to use.

Definition

Visual Basic .NET | Public Property MaxMipLevel As Integer
C# | public int MaxMipLevel { get; set; }
Managed C++ public: __property int get_MaxMipLevel();
public: __property void set_MaxMipLevel(int);
JScript .NET public function get MaxMipLevel() : int
public function set MaxMipLevel(int);

Property Value

System.Int32 . Integer that represents the maximum level of detail (LOD) to set or retrieve.

This property is read/write.

Remarks

The index value can range from 0 to (n-1), where 0 is the largest map.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MinFilter

SamplerStateManager.MinFilter Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a minification filter.

Definition

Visual Basic .NET | Public Property MinFilter As TextureFilter
C# | public TextureFilter MinFilter { get; set; }
Managed C++ public: __property TextureFilter get_MinFilter();
public: __property void set_MinFilter(TextureFilter);
JScript .NET public function get MinFilter() : TextureFilter
public function set MinFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter . Member of the TextureFilter enumeration that represents the minification filter to set or retrieve.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MipFilter

SamplerStateManager.MipFilter Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a mipmap filter to use during minification.

Definition

Visual Basic .NET | Public Property MipFilter As TextureFilter
C# | public TextureFilter MipFilter { get; set; }
Managed C++ public: __property TextureFilter get_MipFilter();
public: __property void set_MipFilter(TextureFilter);
JScript .NET public function get MipFilter() : TextureFilter
public function set MipFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter . Member of the TextureFilter enumeration that represents the minification filter to set or retrieve.

This property is read/write.

See Also

  • MaxMipLevel
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MipMapLevelOfDetailBias

SamplerStateManager.MipMapLevelOfDetailBias Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the mipmap level of detail (LOD) bias.

Definition

Visual Basic .NET | Public Property MipMapLevelOfDetailBias As Single
C# | public float MipMapLevelOfDetailBias { get; set; }
Managed C++ public: __property float get_MipMapLevelOfDetailBias();
public: __property void set_MipMapLevelOfDetailBias(float);
JScript .NET public function get MipMapLevelOfDetailBias() : float
public function set MipMapLevelOfDetailBias(float);

Property Value

System.Single . Floating-point value that represents the mipmap bias to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.SrgbTexture

SamplerStateManager.SrgbTexture Property

Note: This documentation is preliminary and is subject to change.

Determines whether to use gamma correction.

Definition

Visual Basic .NET | Public Property SrgbTexture As Boolean
C# | public bool SrgbTexture { get; set; }
Managed C++ public: __property bool get_SrgbTexture();
public: __property void set_SrgbTexture(bool);
JScript .NET public function get SrgbTexture() : boolean
public function set SrgbTexture(boolean);

Property Value

System.Boolean . Value that is true if gamma correction is used, or false if it is not.

This property is read/write.

Remarks

The default value is false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.SamplerStateManagerCollection

SamplerStateManagerCollection Class

Note: This documentation is preliminary and is subject to change.

Collection of SamplerStateManager objects.

Definition

Visual Basic .NET NotInheritable Public Class SamplerStateManagerCollection
Inherits Object
C# | public sealed class SamplerStateManagerCollection : Object
Managed C++ | public __gc __sealed class SamplerStateManagerCollection : public Object
JScript .NET | public class SamplerStateManagerCollection extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
SamplerState | Retrieves the SamplerStateManager object at the given index.

Inheritance Hierarchy

Object Leave Site
SamplerStateManagerCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SamplerStateManagerCollection.SamplerState

SamplerStateManagerCollection.SamplerState Property

Note: This documentation is preliminary and is subject to change.

Retrieves the SamplerStateManager object at the given index.

Definition

Visual Basic .NET Public ReadOnly Property SamplerState( _
ByVal index As Integer _
) As SamplerStateManager
C# public SamplerStateManager this[
int index
] { get; }
Managed C++ public: __property SamplerStateManager* get_SamplerState(
int index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.Direct3D.SamplerStateManager . A SamplerStateManager object retrieved from the given index.

This property is read-only.

Parameters

index System.Int32. Integer that represents the SamplerStateManager object to retrieve.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.SaveUserData

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData Class

Language:
Note: This documentation is preliminary and is subject to change.

Implemented by the application to save frame and mesh container objects.

Definition

Visual Basic .NET MustInherit Public Class SaveUserData
Inherits Object
C# | public abstract class SaveUserData : Object
Managed C++ | public __gc __abstract class SaveUserData : public Object
JScript .NET | public abstract class SaveUserData extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AddFrameChildData | Adds child data to a frame.
AddMeshChildData | Adds child data to a mesh.
AddTopLevelDataObjectsPost | Adds a top-level object after the frame hierarchy.
AddTopLevelDataObjectsPre | Adds a top-level object before the frame hierarchy.
Finalize | Allows the SaveUserData object to free resources before it is destroyed by the garbage collector.
RegisterTemplates | Registers a .x file template.
SaveTemplates | Saves a .x file template.
SaveUserData | Initializes a new instance of the SaveUserData class.

Inheritance Hierarchy

Object Leave Site
SaveUserData

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SaveUserData.AddFrameChildData(Frame,XFileSaveObject,XFileSaveData)

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.AddFrameChildData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds child data to a frame.

Definition

Visual Basic .NET MustOverride Public Sub AddFrameChildData( _
ByVal frame As Frame, _
ByVal xofSave As XFileSaveObject, _
ByVal xofFrameData As XFileSaveData _
)
C# public abstract void AddFrameChildData(
Frame frame,
XFileSaveObject xofSave,
XFileSaveData xofFrameData
);
Managed C++ public: virtual void AddFrameChildData(
Frame *frame,
XFileSaveObject *xofSave,
XFileSaveData *xofFrameData
) = 0;
JScript .NET public abstract function AddFrameChildData(
frame : Frame,
xofSave : XFileSaveObject,
xofFrameData : XFileSaveData
);

Parameters

frame | Microsoft.DirectX.Direct3D.Frame. A Frame object that represents the frame hierarchy to which to add child data.
xofSave | Microsoft.DirectX.Direct3D.XFileSaveObject. Reference to an XFileSaveObject object.
xofFrameData | Microsoft.DirectX.Direct3D.XFileSaveData.


SaveUserData.AddMeshChildData(MeshContainer,XFileSaveObject,XFileSaveData)

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.AddMeshChildData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds child data to a mesh.

Definition

Visual Basic .NET MustOverride Public Sub AddMeshChildData( _
ByVal meshContainer As MeshContainer, _
ByVal xofSave As XFileSaveObject, _
ByVal xofFrameData As XFileSaveData _
)
C# public abstract void AddMeshChildData(
MeshContainer meshContainer,
XFileSaveObject xofSave,
XFileSaveData xofFrameData
);
Managed C++ public: virtual void AddMeshChildData(
MeshContainer *meshContainer,
XFileSaveObject *xofSave,
XFileSaveData *xofFrameData
) = 0;
JScript .NET public abstract function AddMeshChildData(
meshContainer : MeshContainer,
xofSave : XFileSaveObject,
xofFrameData : XFileSaveData
);

Parameters

meshContainer | Microsoft.DirectX.Direct3D.MeshContainer. A MeshContainer object that represents the mesh container to which to add child data.
xofSave | Microsoft.DirectX.Direct3D.XFileSaveObject. Reference to an XFileSaveObject object.
xofFrameData | Microsoft.DirectX.Direct3D.XFileSaveData.


SaveUserData.AddTopLevelDataObjectsPost(XFileSaveObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.AddTopLevelDataObjectsPost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a top-level object after the frame hierarchy.

Definition

Visual Basic .NET MustOverride Public Sub AddTopLevelDataObjectsPost( _
ByVal xofSave As XFileSaveObject _
)
C# public abstract void AddTopLevelDataObjectsPost(
XFileSaveObject xofSave
);
Managed C++ public: virtual void AddTopLevelDataObjectsPost(
XFileSaveObject *xofSave
) = 0;
JScript .NET public abstract function AddTopLevelDataObjectsPost(
xofSave : XFileSaveObject
);

Parameters

xofSave Microsoft.DirectX.Direct3D.XFileSaveObject. An XFileSaveObject that contains the .x file save data to add to the frame hierarchy.


SaveUserData.AddTopLevelDataObjectsPre(XFileSaveObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.AddTopLevelDataObjectsPre Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a top-level object before the frame hierarchy.

Definition

Visual Basic .NET MustOverride Public Sub AddTopLevelDataObjectsPre( _
ByVal xofSave As XFileSaveObject _
)
C# public abstract void AddTopLevelDataObjectsPre(
XFileSaveObject xofSave
);
Managed C++ public: virtual void AddTopLevelDataObjectsPre(
XFileSaveObject *xofSave
) = 0;
JScript .NET public abstract function AddTopLevelDataObjectsPre(
xofSave : XFileSaveObject
);

Parameters

xofSave Microsoft.DirectX.Direct3D.XFileSaveObject. An XFileSaveObject that contains the .x file save data to add to the frame hierarchy.


SaveUserData.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the SaveUserData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~SaveUserData();
Managed C++ | ~SaveUserData();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


SaveUserData.RegisterTemplates(XFileManager)

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.RegisterTemplates Method

 Language:
Note: This documentation is preliminary and is subject to change.

Registers a .x file template.

Definition

Visual Basic .NET MustOverride Public Sub RegisterTemplates( _
ByVal xfileApi As XFileManager _
)
C# public abstract void RegisterTemplates(
XFileManager xfileApi
);
Managed C++ public: virtual void RegisterTemplates(
XFileManager *xfileApi
) = 0;
JScript .NET public abstract function RegisterTemplates(
xfileApi : XFileManager
);

Parameters

xfileApi Microsoft.DirectX.Direct3D.XFileManager. An XFileManager object that contains data about the .x file template to register.

Remarks

The SaveUserData.RegisterTemplates and SaveUserData.SaveTemplates methods provide a mechanism for saving user data by adding a template to a .x file.


SaveUserData.SaveTemplates(XFileSaveObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.SaveTemplates Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a .x file template.

Definition

Visual Basic .NET MustOverride Public Sub SaveTemplates( _
ByVal xofSave As XFileSaveObject _
)
C# public abstract void SaveTemplates(
XFileSaveObject xofSave
);
Managed C++ public: virtual void SaveTemplates(
XFileSaveObject *xofSave
) = 0;
JScript .NET public abstract function SaveTemplates(
xofSave : XFileSaveObject
);

Parameters

xofSave Microsoft.DirectX.Direct3D.XFileSaveObject. An XFileSaveObject object that contains data about the .x file template to save.

Remarks

The SaveUserData.RegisterTemplates and SaveUserData.SaveTemplates methods provide a mechanism for saving user data by adding a template to a .x file.


SaveUserData.SaveUserData()

Microsoft DirectX 9.0 SDK Update (October 2004)

SaveUserData.SaveUserData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SaveUserData class.

Definition

Visual Basic .NET | Public Sub New()
C# | public SaveUserData();
Managed C++ | public: SaveUserData();
JScript .NET | public function SaveUserData();


Microsoft.DirectX.Direct3D.ShaderLoader

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates the functionality for loading shader objects.

Definition

Visual Basic .NET NotInheritable Public Class ShaderLoader
Inherits Object
C# | public sealed class ShaderLoader : Object
Managed C++ | public __gc __sealed class ShaderLoader : public Object
JScript .NET | public class ShaderLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) CompileShader
static (Shared in Visual Basic .NET) CompileShaderFromFile
static (Shared in Visual Basic .NET) CompileShaderFromStream
static (Shared in Visual Basic .NET) DisassembleShader | Disassembles a shader.
static (Shared in Visual Basic .NET) FromFile | Assembles a shader from a file.
static (Shared in Visual Basic .NET) FromStream | Assembles a shader from a stream.
static (Shared in Visual Basic .NET) FromString | Assembles a shader from a string.
static (Shared in Visual Basic .NET) GetPixelShaderProfile | Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.
static (Shared in Visual Basic .NET) GetSamplers | Gets the sampler names referenced in a shader.
static (Shared in Visual Basic .NET) GetShaderInputSemantics | Retrieves the semantics for all shader input elements.
static (Shared in Visual Basic .NET) GetShaderOutputSemantics | Retrieves the semantics for all shader output elements.
static (Shared in Visual Basic .NET) GetShaderSize | Returns the size of the shader byte code, in bytes.
static (Shared in Visual Basic .NET) GetShaderVersion | Returns the version of the compiled shader.
static (Shared in Visual Basic .NET) GetVertexShaderProfile | Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.

Inheritance Hierarchy

Object Leave Site
ShaderLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderLoader.CompileShader

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Overload List

public static GraphicsStream CompileShader(string, string, Include, string, ShaderFlags);
public static GraphicsStream CompileShader(string, string, Macro[], Include, string, ShaderFlags);
public static GraphicsStream CompileShader(string, string, Macro[], Include, string, ShaderFlags, out string, out ConstantTable);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShader(String,String,Include,String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShader( _
ByVal data As String, _
ByVal functionName As String, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShader(
string data,
string functionName,
Include includeFile,
string profile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* CompileShader(
String *data,
String *functionName,
Include *includeFile,
String *profile,
ShaderFlags flags
);
JScript .NET public static function CompileShader(
data : String,
functionName : String,
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.String. String that contains the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShader(String,String,Macro[],Include,String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShader( _
ByVal data As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShader(
string data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* CompileShader(
String *data,
String *functionName,
Macro preprocessorDefines __gc[],
Include *includeFile,
String *profile,
ShaderFlags flags
);
JScript .NET public static function CompileShader(
data : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.String. String that contains the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShader(String,String,Macro[],Include,String,ShaderFlags,String,ConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShader( _
ByVal data As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public static GraphicsStream CompileShader(
string data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
Managed C++ public: static GraphicsStream* CompileShader(
String *data,
String *functionName,
Macro preprocessorDefines __gc[],
Include *includeFile,
String *profile,
ShaderFlags flags,
String **errorMessages,
ConstantTable **table
);
JScript .NET public static function CompileShader(
data : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

data | System.String. String that contains the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.
errorMessages | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.
table | Microsoft.DirectX.Direct3D.ConstantTable. Reference to a ConstantTable object that can be used to access shader constants.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Overload List

public static GraphicsStream CompileShaderFromFile(string, string, Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromFile(string, string, Macro[], Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromFile(string, string, Macro[], Include, string, ShaderFlags, out string, out ConstantTable);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile(String,String,Include,String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShaderFromFile( _
ByVal file As String, _
ByVal functionName As String, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromFile(
string file,
string functionName,
Include includeFile,
string profile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* CompileShaderFromFile(
String *file,
String *functionName,
Include *includeFile,
String *profile,
ShaderFlags flags
);
JScript .NET public static function CompileShaderFromFile(
file : String,
functionName : String,
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file | System.String. String that specifies the file name containing the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile(String,String,Macro[],Include,String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShaderFromFile( _
ByVal file As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromFile(
string file,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* CompileShaderFromFile(
String *file,
String *functionName,
Macro preprocessorDefines __gc[],
Include *includeFile,
String *profile,
ShaderFlags flags
);
JScript .NET public static function CompileShaderFromFile(
file : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file | System.String. String that specifies the file name containing the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile(String,String,Macro[],Include,String,ShaderFlags,String,ConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShaderFromFile( _
ByVal file As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromFile(
string file,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
Managed C++ public: static GraphicsStream* CompileShaderFromFile(
String *file,
String *functionName,
Macro preprocessorDefines __gc[],
Include *includeFile,
String *profile,
ShaderFlags flags,
String **errorMessages,
ConstantTable **table
);
JScript .NET public static function CompileShaderFromFile(
file : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

file | System.String. String that specifies the file name containing the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.
errorMessages | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.
table | Microsoft.DirectX.Direct3D.ConstantTable. Reference to a ConstantTable object that can be used to access shader constants.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Overload List

public static GraphicsStream CompileShaderFromStream(Stream, string, Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromStream(Stream, string, Macro[], Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromStream(Stream, string, Macro[], Include, string, ShaderFlags, out string, out ConstantTable);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream(Stream,String,Include,String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShaderFromStream( _
ByVal data As Stream, _
ByVal functionName As String, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromStream(
Stream data,
string functionName,
Include includeFile,
string profile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* CompileShaderFromStream(
Stream *data,
String *functionName,
Include *includeFile,
String *profile,
ShaderFlags flags
);
JScript .NET public static function CompileShaderFromStream(
data : Stream,
functionName : String,
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.IO.Stream. A Stream Leave Site object that contains the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream(Stream,String,Macro[],Include,String,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShaderFromStream( _
ByVal data As Stream, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromStream(
Stream data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* CompileShaderFromStream(
Stream *data,
String *functionName,
Macro preprocessorDefines __gc[],
Include *includeFile,
String *profile,
ShaderFlags flags
);
JScript .NET public static function CompileShaderFromStream(
data : Stream,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data | System.IO.Stream. A Stream Leave Site object that contains the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream(Stream,String,Macro[],Include,String,ShaderFlags,String,ConstantTable)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.CompileShaderFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function CompileShaderFromStream( _
ByVal data As Stream, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromStream(
Stream data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
Managed C++ public: static GraphicsStream* CompileShaderFromStream(
Stream *data,
String *functionName,
Macro preprocessorDefines __gc[],
Include *includeFile,
String *profile,
ShaderFlags flags,
String **errorMessages,
ConstantTable **table
);
JScript .NET public static function CompileShaderFromStream(
data : Stream,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

data | System.IO.Stream. A Stream Leave Site object that contains the shader code to compile.
functionName | System.String. String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
profile | System.String. String containing the shader profile that determines the shader instruction set to use.
flags | Microsoft.DirectX.Direct3D.ShaderFlags.
errorMessages | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.
table | Microsoft.DirectX.Direct3D.ConstantTable. Reference to a ConstantTable object that can be used to access shader constants.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the compiled shader code.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.DisassembleShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Disassembles a shader.

Overload List

public static string DisassembleShader(GraphicsStream, bool, string);
public static string DisassembleShader(int, bool, string);
public static string DisassembleShader(int[], bool, string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader(Int32[],Boolean,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.DisassembleShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Disassembles a shader.

Definition

Visual Basic .NET Public Shared Function DisassembleShader( _
ByVal function() As Integer, _
ByVal enableColorCode As Boolean, _
ByVal comments As String _
) As String
C# public static string DisassembleShader(
int[] function,
bool enableColorCode,
string comments
);
Managed C++ public: static String* DisassembleShader(
int function __gc[],
bool enableColorCode,
String *comments
);
JScript .NET public static function DisassembleShader(
function : int[],
enableColorCode : boolean,
comments : String
) : String;

Parameters

function | System.Int32[]. An integer array that contains the compiled shader code.
enableColorCode | System.Boolean. Set to true to enable color code to make it easier to read the disassembly; otherwise, false.
comments | System.String. String that contains comments about the disassembly.

Return Value

System.String . Returns a string containing the disassembled shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader(GraphicsStream,Boolean,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.DisassembleShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Disassembles a shader.

Definition

Visual Basic .NET Public Shared Function DisassembleShader( _
ByVal function As GraphicsStream, _
ByVal enableColorCode As Boolean, _
ByVal comments As String _
) As String
C# public static string DisassembleShader(
GraphicsStream function,
bool enableColorCode,
string comments
);
Managed C++ public: static String* DisassembleShader(
GraphicsStream *function,
bool enableColorCode,
String *comments
);
JScript .NET public static function DisassembleShader(
function : GraphicsStream,
enableColorCode : boolean,
comments : String
) : String;

Parameters

function | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the compiled shader code.
enableColorCode | System.Boolean. Set to true to enable color code to make it easier to read the disassembly; otherwise, false.
comments | System.String. String that contains comments about the disassembly.

Return Value

System.String . Returns a string containing the disassembled shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader(Int32,Boolean,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.DisassembleShader Method

 Language:
Note: This documentation is preliminary and is subject to change.

Disassembles a shader.

Definition

Visual Basic .NET Public Shared Function DisassembleShader( _
ByVal pFunction As Integer, _
ByVal enableColorCode As Boolean, _
ByVal comments As String _
) As String
C# public static string DisassembleShader(
int pFunction,
bool enableColorCode,
string comments
);
Managed C++ public: static String* DisassembleShader(
int pFunction,
bool enableColorCode,
String *comments
);
JScript .NET public static function DisassembleShader(
pFunction : int,
enableColorCode : boolean,
comments : String
) : String;

Parameters

pFunction | System.Int32. An integer pointer that represents the compiled shader code.
enableColorCode | System.Boolean. Set to true to enable color code to make it easier to read the disassembly; otherwise, false.
comments | System.String. String that contains comments about the disassembly.

Return Value

System.String . Returns a string containing the disassembled shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a file.

Overload List

public static GraphicsStream FromFile(string, Include, ShaderFlags);
public static GraphicsStream FromFile(string, Include, ShaderFlags, out string);
public static GraphicsStream FromFile(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile(String,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* FromFile(
String *sourceFile,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

sourceFile | System.String. String that specifies the file name containing the shader code to assemble.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile(String,Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* FromFile(
String *sourceFile,
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceFile | System.String. String that specifies the file name containing the shader code to assemble.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile(String,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromFile(
string sourceFile,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* FromFile(
String *sourceFile,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromFile(
sourceFile : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceFile | System.String. String that specifies the file name containing the shader code to assemble.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a stream.

Overload List

public static GraphicsStream FromStream(Stream, Include, ShaderFlags);
public static GraphicsStream FromStream(Stream, Include, ShaderFlags, out string);
public static GraphicsStream FromStream(Stream, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream(Stream,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a stream.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* FromStream(
Stream *sourceData,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

sourceData | System.IO.Stream. A Stream Leave Site object that contains the shader code to assemble.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream(Stream,Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a stream.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* FromStream(
Stream *sourceData,
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData | System.IO.Stream. A Stream Leave Site object that contains the shader code to assemble.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream(Stream,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a stream.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromStream(
Stream sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* FromStream(
Stream *sourceData,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromStream(
sourceData : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData | System.IO.Stream. A Stream Leave Site object that contains the shader code to assemble.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromString

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a string.

Overload List

public static GraphicsStream FromString(string, Include, ShaderFlags);
public static GraphicsStream FromString(string, Include, ShaderFlags, out string);
public static GraphicsStream FromString(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromString(String,Include,ShaderFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream FromString(
string sourceData,
Include includeFile,
ShaderFlags flags
);
Managed C++ public: static GraphicsStream* FromString(
String *sourceData,
Include *includeFile,
ShaderFlags flags
);
JScript .NET public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

sourceData | System.String. String that contains the shader code to assemble.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromString(String,Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromString(
string sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* FromString(
String *sourceData,
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData | System.String. String that contains the shader code to assemble.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.FromString(String,Macro[],Include,ShaderFlags,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.FromString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Assembles a shader from a string.

Definition

Visual Basic .NET Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromString(
string sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
Managed C++ public: static GraphicsStream* FromString(
String *sourceData,
Macro preprocessorDefines __gc[],
Include *includeFile,
ShaderFlags flags,
String **compilationErrors
);
JScript .NET public static function FromString(
sourceData : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData | System.String. String that contains the shader code to assemble.
preprocessorDefines | Microsoft.DirectX.Direct3D.Macro[]. Reference to a Macro object that describes the preprocessor definitions to use.
includeFile | Microsoft.DirectX.Direct3D.Include. Reference to an Include object that provides access to include-file directives.
flags | Microsoft.DirectX.Direct3D.ShaderFlags. Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors | System.String. String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetPixelShaderProfile(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetPixelShaderProfile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.

Definition

Visual Basic .NET Public Shared Function GetPixelShaderProfile( _
ByVal device As Device _
) As String
C# public static string GetPixelShaderProfile(
Device device
);
Managed C++ public: static String* GetPixelShaderProfile(
Device *device
);
JScript .NET public static function GetPixelShaderProfile(
device : Device
) : String;

Parameters

device Microsoft.DirectX.Direct3D.Device. Reference to the Device.

Return Value

System.String . String that contains the HLSL profile name.

Remarks

A shader profile specifies the assembly shader version to use and the capabilities available to the HLSL compiler when compiling a shader. The following table lists the supported pixel shader profiles.

Shader Profile | Description
ps_1_1 | Compile to ps_1_1 version.
ps_1_2 | Compile to ps_1_2 version.
ps_1_3 | Compile to ps_1_3 version.
ps_1_4 | Compile to ps_1_4 version.
ps_2_0 | Compile to ps_2_0 version.
ps_2_a Same as the ps_2_0 profile, with the following additional capabilities available for the compiler to target:
  • Number of temporary registers (r#) is greater than or equal to 28.
  • Arbitrary source swizzle.
  • Gradient instructions: dsx, dsy.
  • Predication.
  • No dependent texture read limit.
  • No limit for the number of texture instructions.
ps_2_sw | Compile to ps_2_sw version.


ShaderLoader.GetSamplers

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetSamplers Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets the sampler names referenced in a shader.

Overload List

public static string[] GetSamplers(GraphicsStream);
public static string[] GetSamplers(int);
public static string[] GetSamplers(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetSamplers(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetSamplers Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets the sampler names referenced in a shader.

Definition

Visual Basic .NET Public Shared Function GetSamplers( _
ByVal function() As Integer _
) As String()
C# public static string[] GetSamplers(
int[] function
);
Managed C++ public: static String* GetSamplers(
int function __gc[]
) __gc[];
JScript .NET public static function GetSamplers(
function : int[]
) : String[];

Parameters

function System.Int32[]. An integer array that contains the shader function stream.

Return Value

System.String[]. Returns a string array that contains the sampler names in the shader function stream.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetSamplers(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetSamplers Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets the sampler names referenced in a shader.

Definition

Visual Basic .NET Public Shared Function GetSamplers( _
ByVal function As GraphicsStream _
) As String()
C# public static string[] GetSamplers(
GraphicsStream function
);
Managed C++ public: static String* GetSamplers(
GraphicsStream *function
) __gc[];
JScript .NET public static function GetSamplers(
function : GraphicsStream
) : String[];

Parameters

function Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader function stream.

Return Value

System.String[]. Returns a string array that contains the sampler names in the shader function stream.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetSamplers(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetSamplers Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets the sampler names referenced in a shader.

Definition

Visual Basic .NET Public Shared Function GetSamplers( _
ByVal function As Integer _
) As String()
C# public static string[] GetSamplers(
int function
);
Managed C++ public: static String* GetSamplers(
int function
) __gc[];
JScript .NET public static function GetSamplers(
function : int
) : String[];

Parameters

function System.Int32. An integer pointer that represents the shader function stream.

Return Value

System.String[]. Returns a string array that contains the sampler names in the shader function stream.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderInputSemantics

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderInputSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the semantics for all shader input elements.

Overload List

public static Semantic[] GetShaderInputSemantics(GraphicsStream);
public static Semantic[] GetShaderInputSemantics(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderInputSemantics(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderInputSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the semantics for all shader input elements.

Definition

Visual Basic .NET Public Shared Function GetShaderInputSemantics( _
ByVal function() As Integer _
) As Semantic()
C# public static Semantic[] GetShaderInputSemantics(
int[] function
);
Managed C++ public: static Semantic GetShaderInputSemantics(
int function __gc[]
) __gc[];
JScript .NET public static function GetShaderInputSemantics(
function : int[]
) : Semantic[];

Parameters

function System.Int32[]. Integer that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]. Array of Semantic objects that represent the semantics for each input element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderInputSemantics(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderInputSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the semantics for all shader input elements.

Definition

Visual Basic .NET Public Shared Function GetShaderInputSemantics( _
ByVal function As GraphicsStream _
) As Semantic()
C# public static Semantic[] GetShaderInputSemantics(
GraphicsStream function
);
Managed C++ public: static Semantic GetShaderInputSemantics(
GraphicsStream *function
) __gc[];
JScript .NET public static function GetShaderInputSemantics(
function : GraphicsStream
) : Semantic[];

Parameters

function Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]. Array of Semantic objects that represent the semantics for each input element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderOutputSemantics

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderOutputSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the semantics for all shader output elements.

Overload List

public static Semantic[] GetShaderOutputSemantics(GraphicsStream);
public static Semantic[] GetShaderOutputSemantics(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderOutputSemantics(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderOutputSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the semantics for all shader output elements.

Definition

Visual Basic .NET Public Shared Function GetShaderOutputSemantics( _
ByVal function() As Integer _
) As Semantic()
C# public static Semantic[] GetShaderOutputSemantics(
int[] function
);
Managed C++ public: static Semantic GetShaderOutputSemantics(
int function __gc[]
) __gc[];
JScript .NET public static function GetShaderOutputSemantics(
function : int[]
) : Semantic[];

Parameters

function System.Int32[]. Integer that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]. Array of Semantic objects that represent the semantics for each output element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderOutputSemantics(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderOutputSemantics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the semantics for all shader output elements.

Definition

Visual Basic .NET Public Shared Function GetShaderOutputSemantics( _
ByVal function As GraphicsStream _
) As Semantic()
C# public static Semantic[] GetShaderOutputSemantics(
GraphicsStream function
);
Managed C++ public: static Semantic GetShaderOutputSemantics(
GraphicsStream *function
) __gc[];
JScript .NET public static function GetShaderOutputSemantics(
function : GraphicsStream
) : Semantic[];

Parameters

function Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]. Array of Semantic objects that represent the semantics for each output element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderSize

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the size of the shader byte code, in bytes.

Overload List

public static int GetShaderSize(GraphicsStream);
public static int GetShaderSize(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderSize(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the size of the shader byte code, in bytes.

Definition

Visual Basic .NET Public Shared Function GetShaderSize( _
ByVal function() As Integer _
) As Integer
C# public static int GetShaderSize(
int[] function
);
Managed C++ public: static int GetShaderSize(
int function __gc[]
);
JScript .NET public static function GetShaderSize(
function : int[]
) : int;

Parameters

function System.Int32[]. An integer array that contains the shader function stream.

Return Value

System.Int32 . An integer that represents the size of the shader byte code, in bytes.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderSize(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the size of the shader byte code, in bytes.

Definition

Visual Basic .NET Public Shared Function GetShaderSize( _
ByVal function As GraphicsStream _
) As Integer
C# public static int GetShaderSize(
GraphicsStream function
);
Managed C++ public: static int GetShaderSize(
GraphicsStream *function
);
JScript .NET public static function GetShaderSize(
function : GraphicsStream
) : int;

Parameters

function Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the shader function stream.

Return Value

System.Int32 . An integer that represents the size of the shader byte code, in bytes.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderVersion

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderVersion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the version of the compiled shader.

Overload List

public static Version GetShaderVersion(GraphicsStream);
public static Version GetShaderVersion(int[]);


ShaderLoader.GetShaderVersion(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderVersion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the version of the compiled shader.

Definition

Visual Basic .NET Public Shared Function GetShaderVersion( _
ByVal function() As Integer _
) As Version
C# public static Version GetShaderVersion(
int[] function
);
Managed C++ public: static Version* GetShaderVersion(
int function __gc[]
);
JScript .NET public static function GetShaderVersion(
function : int[]
) : Version;

Parameters

function System.Int32[]. Integer that represents a pointer to the shader function stream.

Return Value

System.Version . A Version Leave Site object that represents the shader version.


ShaderLoader.GetShaderVersion(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetShaderVersion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the version of the compiled shader.

Definition

Visual Basic .NET Public Shared Function GetShaderVersion( _
ByVal function As GraphicsStream _
) As Version
C# public static Version GetShaderVersion(
GraphicsStream function
);
Managed C++ public: static Version* GetShaderVersion(
GraphicsStream *function
);
JScript .NET public static function GetShaderVersion(
function : GraphicsStream
) : Version;

Parameters

function Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents a pointer to the shader function stream.

Return Value

System.Version . A Version Leave Site object that represents the shader version.


ShaderLoader.GetVertexShaderProfile(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderLoader.GetVertexShaderProfile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.

Definition

Visual Basic .NET Public Shared Function GetVertexShaderProfile( _
ByVal device As Device _
) As String
C# public static string GetVertexShaderProfile(
Device device
);
Managed C++ public: static String* GetVertexShaderProfile(
Device *device
);
JScript .NET public static function GetVertexShaderProfile(
device : Device
) : String;

Parameters

device Microsoft.DirectX.Direct3D.Device. Reference to the Device.

Return Value

System.String . String that contains the HLSL profile name.

Remarks

A shader profile specifies the assembly shader version to use and the capabilities available to the HLSL compiler when compiling a shader. The following table lists the supported vertex shader profiles.

Shader Profile | Description
vs_1_1 | Compile to vs_1_1 version.
vs_2_0 | Compile to vs_2_0 version.
vs_2_a Same as the vs_2_0 profile, with the following additional capabilities available for the compiler to target:
  • Number of temporary registers (r#) is greater than or equal to 13.
  • Dynamic flow control instruction.
  • Predication.
vs_2_sw | Compile to vs_2_sw version.


Microsoft.DirectX.Direct3D.SimplificationMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates simplification mesh objects.

Definition

Visual Basic .NET NotInheritable Public Class SimplificationMesh
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class SimplificationMesh : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class SimplificationMesh : public MarshalByRefObject,
IDisposable
JScript .NET public class SimplificationMesh extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SimplificationMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Clones, or copies, a SimplificationMesh object.
CloneProgressiveMesh | Clones a progressive mesh object.
Dispose | Immediately releases the unmanaged resources used by the SimplificationMesh object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SimplificationMesh object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing event when called from within a derived class.
ReduceFaces | Reduces the number of faces in a simplification mesh.
ReduceVertices | Reduces the number of vertices in a simplification mesh.
SimplificationMesh | Creates a new instance of the SimplificationMesh class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this SimplificationMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Declaration | Retrieves a declaration that describes the vertices in a mesh.
Device | Retrieves the device object associated with a simplification mesh.
Disposed | Gets a value that indicates whether the object is disposed.
MaxFaces | Retrieves the maximum number of faces that a simplification mesh can support.
MaxVertices | Retrieves the maximum number of vertices that a simplification mesh can support.
NumberFaces | Retrieves the number of faces in the simplification mesh.
NumberVertices | Retrieves the number of vertices in the simplification mesh.
Options | Retrieves the mesh options enabled for the current simplification mesh at creation time.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXSPMesh interface pointer.
VertexAttributeWeights | Retrieves the per-vertex attribute weights used to create a SimplificationMesh object.
VertexFormat | Retrieves the VertexFormats of the vertices in the SimplificationMesh.
VertexWeights | Retrieves the per-vertex weights used to create the SimplificationMesh object.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
SimplificationMesh

Remarks

A simplification mesh is used to simplify a given mesh to a lower number of faces.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SimplificationMesh.Clone

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Overload List

public Mesh Clone(MeshFlags, VertexElement[], Device);
public Mesh Clone(MeshFlags, VertexElement[], Device, out int, out int);
public Mesh Clone(MeshFlags, VertexFormats, Device);
public Mesh Clone(MeshFlags, VertexFormats, Device, out int, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexElement[],Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexElement[] declaration,
Device device
);
Managed C++ public: Mesh* Clone(
MeshFlags options,
VertexElement declaration __gc[],
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
declaration : VertexElement[],
device : Device
) : Mesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. Vertex data, defined with an array of VertexElement structures.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexElement[],Device,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device, _
ByRef adjacencyOut As Integer, _
ByRef vertexRemap As Integer _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexElement[] declaration,
Device device,
out int adjacencyOut,
out int vertexRemap
);
Managed C++ public: Mesh* Clone(
MeshFlags options,
VertexElement declaration __gc[],
Device *device,
int *adjacencyOut,
int *vertexRemap
);
JScript .NET public function Clone(
options : MeshFlags,
declaration : VertexElement[],
device : Device,
adjacencyOut : int,
vertexRemap : int
) : Mesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. Vertex data, defined with an array of VertexElement structures.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.
adjacencyOut | System.Int32[]. Array of three Int32 Leave Site values per face that specifies the three neighbors for each face in the source mesh.
vertexRemap | System.Int32[]. Array that contains the index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexFormats,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
Managed C++ public: Mesh* Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device *device
);
JScript .NET public function Clone(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
) : Mesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Vertex format of the mesh, indicated by one or more VertexFormats members.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexFormats,Device,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device, _
ByRef adjacencyOut As Integer, _
ByRef vertexRemap As Integer _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device device,
out int adjacencyOut,
out int vertexRemap
);
Managed C++ public: Mesh* Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device *device,
int *adjacencyOut,
int *vertexRemap
);
JScript .NET public function Clone(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device,
adjacencyOut : int,
vertexRemap : int
) : Mesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Vertex format of the mesh, indicated by one or more VertexFormats members.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.
adjacencyOut | System.Int32[]. Array of three Int32 Leave Site values per face that specifies the three neighbors for each face in the source mesh.
vertexRemap | System.Int32[]. Array that contains the index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.CloneProgressiveMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.CloneProgressiveMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh object.

Overload List

public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexElement[], Device);
public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexElement[], Device, out int, out float);
public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexFormats, Device);
public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexFormats, Device, out int, out float);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexElement[],Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.CloneProgressiveMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh object.

Definition

Visual Basic .NET Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexElement[] declaration,
Device device
);
Managed C++ public: ProgressiveMesh* CloneProgressiveMesh(
MeshFlags options,
VertexElement declaration __gc[],
Device *device
);
JScript .NET public function CloneProgressiveMesh(
options : MeshFlags,
declaration : VertexElement[],
device : Device
) : ProgressiveMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. Vertex data, defined with an array of VertexElement structures. This parameter must map directly to a flexible vertex format (FVF).
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexElement[],Device,Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.CloneProgressiveMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh object.

Definition

Visual Basic .NET Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device, _
ByRef vertexRemapOut As Integer, _
ByRef errorsByFace As Single _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexElement[] declaration,
Device device,
out int vertexRemapOut,
out float errorsByFace
);
Managed C++ public: ProgressiveMesh* CloneProgressiveMesh(
MeshFlags options,
VertexElement declaration __gc[],
Device *device,
int *vertexRemapOut,
float *errorsByFace
);
JScript .NET public function CloneProgressiveMesh(
options : MeshFlags,
declaration : VertexElement[],
device : Device,
vertexRemapOut : int,
errorsByFace : float
) : ProgressiveMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration | Microsoft.DirectX.Direct3D.VertexElement[]. Vertex data, defined with an array of VertexElement structures. This parameter must map directly to a flexible vertex format (FVF).
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.
vertexRemapOut | System.Int32[]. Array that contains the index for each vertex.
errorsByFace | System.Single[]. Array that contains error values.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexFormats,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.CloneProgressiveMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh object.

Definition

Visual Basic .NET Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
Managed C++ public: ProgressiveMesh* CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device *device
);
JScript .NET public function CloneProgressiveMesh(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
) : ProgressiveMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Vertex format of the mesh, indicated by one or more VertexFormats members.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexFormats,Device,Int32,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.CloneProgressiveMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a progressive mesh object.

Definition

Visual Basic .NET Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device, _
ByRef vertexRemapOut As Integer, _
ByRef errorsByFace As Single _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device device,
out int vertexRemapOut,
out float errorsByFace
);
Managed C++ public: ProgressiveMesh* CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device *device,
int *vertexRemapOut,
float *errorsByFace
);
JScript .NET public function CloneProgressiveMesh(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device,
vertexRemapOut : int,
errorsByFace : float
) : ProgressiveMesh;

Parameters

options | Microsoft.DirectX.Direct3D.MeshFlags. Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Vertex format of the mesh, indicated by one or more VertexFormats members.
device | Microsoft.DirectX.Direct3D.Device. The Device object associated with the mesh.
vertexRemapOut | System.Int32[]. Array that contains the index for each vertex.
errorsByFace | System.Single[]. Array that contains error values.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SimplificationMesh.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the SimplificationMesh object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.SimplificationMesh.Disposed
  • Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing


SimplificationMesh.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


SimplificationMesh.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the SimplificationMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~SimplificationMesh();
Managed C++ | ~SimplificationMesh();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


SimplificationMesh.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


SimplificationMesh.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXSPMesh, which allows unmanaged COM clients to create an instance of the managed SimplificationMesh class. Not supported.


SimplificationMesh.op_Equality(SimplificationMesh,SimplificationMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As SimplificationMesh, _
ByVal right As SimplificationMesh _
) As Boolean
C# public static bool op_Equality(
SimplificationMesh left,
SimplificationMesh right
);
Managed C++ public: static bool op_Equality(
SimplificationMesh *left,
SimplificationMesh *right
);
JScript .NET public static function op_Equality(
left : SimplificationMesh,
right : SimplificationMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.SimplificationMesh. The SimplificationMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.SimplificationMesh. The SimplificationMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


SimplificationMesh.op_Inequality(SimplificationMesh,SimplificationMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As SimplificationMesh, _
ByVal right As SimplificationMesh _
) As Boolean
C# public static bool op_Inequality(
SimplificationMesh left,
SimplificationMesh right
);
Managed C++ public: static bool op_Inequality(
SimplificationMesh *left,
SimplificationMesh *right
);
JScript .NET public static function op_Inequality(
left : SimplificationMesh,
right : SimplificationMesh
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.SimplificationMesh. The SimplificationMesh object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.SimplificationMesh. The SimplificationMesh object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


SimplificationMesh.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


SimplificationMesh.ReduceFaces(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.ReduceFaces Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Reduces the number of faces in a simplification mesh.

Definition

Visual Basic .NET Public Sub ReduceFaces( _
ByVal faces As Integer _
)
C# public void ReduceFaces(
int faces
);
Managed C++ public: void ReduceFaces(
int faces
);
JScript .NET public function ReduceFaces(
faces : int
);

Parameters

faces System.Int32. Target number of faces by which to reduce the primitive count.

Remarks

This method performs edge collapses to reduce the number of primitives to the value specified in param_Int32_faces. Note that, due to certain restrictions, it is not always possible to reduce a mesh to the requested value.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.ReduceVertices(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.ReduceVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Reduces the number of vertices in a simplification mesh.

Definition

Visual Basic .NET Public Sub ReduceVertices( _
ByVal vertices As Integer _
)
C# public void ReduceVertices(
int vertices
);
Managed C++ public: void ReduceVertices(
int vertices
);
JScript .NET public function ReduceVertices(
vertices : int
);

Parameters

vertices System.Int32. Number of vertices by which to reduce the primitive count.

Remarks

This method performs edge collapses to reduce the number of primitives to the value specified in param_Int32_vertices. Note that, due to certain restrictions, it is not always possible to reduce a mesh to the requested value.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Overload List

public SimplificationMesh(ID3DXSPMesh);
public SimplificationMesh(IntPtr);
public SimplificationMesh(Mesh, GraphicsStream);
public SimplificationMesh(Mesh, GraphicsStream, AttributeWeights);
public SimplificationMesh(Mesh, GraphicsStream, AttributeWeights, GraphicsStream);
public SimplificationMesh(Mesh, GraphicsStream, GraphicsStream);
public SimplificationMesh(Mesh, GraphicsStream, float[]);
public SimplificationMesh(Mesh, int[]);
public SimplificationMesh(Mesh, int[], AttributeWeights);
public SimplificationMesh(Mesh, int[], AttributeWeights, GraphicsStream);
public SimplificationMesh(Mesh, int[], AttributeWeights, float[]);
public SimplificationMesh(Mesh, int[], GraphicsStream);
public SimplificationMesh(Mesh, int[], float[]);

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(ID3DXSPMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXSPMesh _
)
C# public SimplificationMesh(
ID3DXSPMesh pUnk
);
Managed C++ public: SimplificationMesh(
ID3DXSPMesh pUnk
);
JScript .NET public function SimplificationMesh(
pUnk : ID3DXSPMesh
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXSPMesh. Unmanaged Component Object Model (COM) ID3DXSPMesh interface pointer.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public SimplificationMesh(
IntPtr unmanagedObject
);
Managed C++ public: SimplificationMesh(
IntPtr unmanagedObject
);
JScript .NET public function SimplificationMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXSPMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
GraphicsStream vertexWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
int adjacency __gc[],
GraphicsStream *vertexWeights
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexWeights : GraphicsStream
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],AttributeWeights,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
int adjacency __gc[],
AttributeWeights vertexAttributeWeights,
GraphicsStream *vertexWeights
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights() As Single _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
float[] vertexWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
GraphicsStream *adjacency,
float vertexWeights __gc[]
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : float[]
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexWeights | System.Single[]. Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
GraphicsStream *adjacency
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream vertexWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
GraphicsStream *adjacency,
GraphicsStream *vertexWeights
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : GraphicsStream
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,AttributeWeights)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
GraphicsStream *adjacency,
AttributeWeights vertexAttributeWeights
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,AttributeWeights,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
GraphicsStream *adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream *vertexWeights
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
int adjacency __gc[]
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : int[]
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights() As Single _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
float[] vertexWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
int adjacency __gc[],
float vertexWeights __gc[]
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexWeights : float[]
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexWeights | System.Single[]. Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],AttributeWeights)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
int adjacency __gc[],
AttributeWeights vertexAttributeWeights
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],AttributeWeights,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.SimplificationMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic .NET Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights() As Single _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
float[] vertexWeights
);
Managed C++ public: SimplificationMesh(
Mesh *mesh,
int adjacency __gc[],
AttributeWeights vertexAttributeWeights,
float vertexWeights __gc[]
);
JScript .NET public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : float[]
);

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. A Mesh object that represents the mesh to simplify.
adjacency | System.Int32[]. Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexAttributeWeights | Microsoft.DirectX.Direct3D.AttributeWeights. An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights | System.Single[]. Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.UpdateUnmanagedPointer(ID3DXSPMesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this SimplificationMesh object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXSPMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXSPMesh pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXSPMesh pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXSPMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXSPMesh. Pointer to the ID3DXSPMesh structure used to update the unmanaged pointer for this SimplificationMesh object.


SimplificationMesh.Declaration

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Declaration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a declaration that describes the vertices in a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; }
Managed C++ | public: __property VertexElement get_Declaration();
JScript .NET | public function get Declaration() : VertexElement[]

Property Value

Microsoft.DirectX.Direct3D.VertexElement[] . Array of VertexElement structures that describe the vertex format of the mesh vertices. The vertex element array ends with the value found in the VertexDeclarationEnd field.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SimplificationMesh.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the device object associated with a simplification mesh.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . A Device object that represents the Microsoft® Direct3D® device object associated with the simplification mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SimplificationMesh.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


SimplificationMesh.MaxFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.MaxFaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of faces that a simplification mesh can support.

Definition

Visual Basic .NET | Public ReadOnly Property MaxFaces As Integer
C# | public int MaxFaces { get; }
Managed C++ | public: __property int get_MaxFaces();
JScript .NET | public function get MaxFaces() : int

Property Value

System.Int32 . Maximum number of faces in the original mesh.

This property is read-only.


SimplificationMesh.MaxVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.MaxVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of vertices that a simplification mesh can support.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertices As Integer
C# | public int MaxVertices { get; }
Managed C++ | public: __property int get_MaxVertices();
JScript .NET | public function get MaxVertices() : int

Property Value

System.Int32 . Maximum number of vertices in the original mesh.

This property is read-only.


SimplificationMesh.NumberFaces

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.NumberFaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of faces in the simplification mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberFaces As Integer
C# | public int NumberFaces { get; }
Managed C++ | public: __property int get_NumberFaces();
JScript .NET | public function get NumberFaces() : int

Property Value

System.Int32 . Number of faces in the simplification mesh.

This property is read-only.


SimplificationMesh.NumberVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.NumberVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of vertices in the simplification mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
Managed C++ | public: __property int get_NumberVertices();
JScript .NET | public function get NumberVertices() : int

Property Value

System.Int32 . Number of vertices in the simplification mesh.

This property is read-only.


SimplificationMesh.Options

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Options Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the mesh options enabled for the current simplification mesh at creation time.

Definition

Visual Basic .NET | Public ReadOnly Property Options As MeshOptions
C# | public MeshOptions Options { get; }
Managed C++ | public: __property MeshOptions get_Options();
JScript .NET | public function get Options() : MeshOptions

Property Value

Microsoft.DirectX.Direct3D.MeshOptions . One or more flags from the MeshFlags enumeration that indicate the options enabled for the mesh at creation time.

This property is read-only.


SimplificationMesh.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXSPMesh interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXSPMesh
C# | public ID3DXSPMesh UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXSPMesh get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXSPMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXSPMesh . Unmanaged ID3DXSPMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


SimplificationMesh.VertexAttributeWeights

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.VertexAttributeWeights Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the per-vertex attribute weights used to create a SimplificationMesh object.

Definition

Visual Basic .NET | Public ReadOnly Property VertexAttributeWeights As AttributeWeights()
C# | public AttributeWeights[] VertexAttributeWeights { get; }
Managed C++ | public: __property AttributeWeights get_VertexAttributeWeights();
JScript .NET | public function get VertexAttributeWeights() : AttributeWeights[]

Property Value

Microsoft.DirectX.Direct3D.AttributeWeights[] . Array of vertex attribute weights. For more information, see AttributeWeights.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • SimplificationMesh


SimplificationMesh.VertexFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.VertexFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats of the vertices in the SimplificationMesh.

Definition

Visual Basic .NET | Public ReadOnly Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; }
Managed C++ | public: __property VertexFormats get_VertexFormat();
JScript .NET | public function get VertexFormat() : VertexFormats

Property Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object that contains the format of the vertices in the SimplificationMesh.

This property is read-only.


SimplificationMesh.VertexWeights

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.VertexWeights Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the per-vertex weights used to create the SimplificationMesh object.

Definition

Visual Basic .NET | Public ReadOnly Property VertexWeights As Single()
C# | public float[] VertexWeights { get; }
Managed C++ | public: __property float get_VertexWeights();
JScript .NET | public function get VertexWeights() : float[]

Property Value

System.Single[] . Array of Single Leave Site values to be filled with vertex weights. Each floating-point value contains one vertex.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • SimplificationMesh


SimplificationMesh.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

SimplificationMesh.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the SimplificationMesh object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SimplificationMesh object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.SkinInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates bone matrices, which are used to skin vertex data for animation.

Definition

Visual Basic .NET NotInheritable Public Class SkinInformation
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class SkinInformation : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class SkinInformation : public MarshalByRefObject,
IDisposable
JScript .NET public class SkinInformation extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SkinInformation object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Clones a SkinInformation object.
ConvertToBlendedMesh | Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.
ConvertToIndexedBlendedMesh | Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.
Dispose | Immediately releases the unmanaged resources used by the SkinInformation object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SkinInformation object to free resources before it is destroyed by the garbage collector.
GetBoneInfluence | Retrieves the vertices and weights that a bone influences.
GetBoneName | Retrieves the bone name from the bone index.
GetBoneOffsetMatrix | Retrieves the bone offset matrix.
GetHashCode | Returns the hash code for the current instance.
GetMaxFaceInfluences | Retrieves the maximum face influences in a triangle mesh with the specified index buffer.
GetNumBoneInfluences | Retrieves the number of influences for a bone.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.SkinInformation.Disposing event when called from within a derived class.
Remap | Updates bone influence information to match vertices after they are reordered.
SetBoneInfluence | Sets the influence value for a bone.
SetBoneName | Sets the bone name associated with a bone number.
SetBoneOffsetMatrix | Sets the bone offset matrix.
SkinInformation | Initializes a new instance of the SkinInformation class.
UpdateSkinnedMesh | Applies software skinning to target vertices that are based on the current matrices.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this SkinInformation object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Declaration | Retrieves or sets the vertex declaration.
Disposed | Gets a value that indicates whether the object is disposed.
MaxVertexInfluences | Retrieves the maximum number of influences for any vertex in a mesh.
MinBoneInfluence | Retrieves or sets the minimum bone influence.
NumberBones | Retrieves the number of bones in a mesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXSkinInfo interface pointer.
VertexFormat | Retrieves or sets the fixed function vertex value.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
SkinInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SkinInformation.Clone()

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clones a SkinInformation object.

Definition

Visual Basic .NET | Public Function Clone() As SkinInformation
C# | public SkinInformation Clone();
Managed C++ | public: SkinInformation* Clone();
JScript .NET | public function Clone() : SkinInformation;

Return Value

Microsoft.DirectX.Direct3D.SkinInformation . A SkinInformation object that contains the cloned object.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Overload List

public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, GraphicsStream, out int, out BoneCombination);
public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, GraphicsStream, out int, out BoneCombination, out int, out int, out GraphicsStream);
public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, int[], out int, out BoneCombination);
public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, int[], out int, out BoneCombination, out int, out int, out GraphicsStream);

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,Int32[],Int32,BoneCombination)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
Managed C++ public: Mesh* ConvertToBlendedMesh(
Mesh *mesh,
MeshFlags options,
int adjacencyIn __gc[],
int *maxFaceInfluence,
BoneCombination *boneCombinationTable
);
JScript .NET public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | System.Int32[]. Array that contains the input mesh adjacency information.
maxFaceInfluence | System.Int32. Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,Int32[],Int32,BoneCombination,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: Mesh* ConvertToBlendedMesh(
Mesh *mesh,
MeshFlags options,
int adjacencyIn __gc[],
int *maxFaceInfluence,
BoneCombination *boneCombinationTable,
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | System.Int32[]. Array that contains the input mesh adjacency information.
maxFaceInfluence | System.Int32. Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.
adjacencyOut | System.Int32[]. Array that contains the output mesh adjacency information.
faceRemap | System.Int32[]. Array that contains a new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,BoneCombination)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
Managed C++ public: Mesh* ConvertToBlendedMesh(
Mesh *mesh,
MeshFlags options,
GraphicsStream *adjacencyIn,
int *maxFaceInfluence,
BoneCombination *boneCombinationTable
);
JScript .NET public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the input mesh adjacency information.
maxFaceInfluence | System.Int32. Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,BoneCombination,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: Mesh* ConvertToBlendedMesh(
Mesh *mesh,
MeshFlags options,
GraphicsStream *adjacencyIn,
int *maxFaceInfluence,
BoneCombination *boneCombinationTable,
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the input mesh adjacency information.
maxFaceInfluence | System.Int32. Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.
adjacencyOut | System.Int32[]. Array that contains the output mesh adjacency information.
faceRemap | System.Int32[]. Array that contains a new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToIndexedBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Overload List

public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, GraphicsStream, int, out int, out BoneCombination);
public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, GraphicsStream, int, out int, out BoneCombination, out int, out int, out GraphicsStream);
public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, int[], int, out int, out BoneCombination);
public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, int[], int, out int, out BoneCombination, out int, out int, out GraphicsStream);

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,Int32[],Int32,Int32,BoneCombination)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToIndexedBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
Managed C++ public: Mesh* ConvertToIndexedBlendedMesh(
Mesh *mesh,
MeshFlags options,
int adjacencyIn __gc[],
int paletteSize,
int *maxFaceInfluence,
BoneCombination *boneCombinationTable
);
JScript .NET public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | System.Int32[]. Array that contains the input mesh adjacency information.
paletteSize | System.Int32. Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence | System.Int32. Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,Int32[],Int32,Int32,BoneCombination,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToIndexedBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: Mesh* ConvertToIndexedBlendedMesh(
Mesh *mesh,
MeshFlags options,
int adjacencyIn __gc[],
int paletteSize,
int *maxFaceInfluence,
BoneCombination *boneCombinationTable,
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | System.Int32[]. Array that contains the input mesh adjacency information.
paletteSize | System.Int32. Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence | System.Int32. Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.
adjacencyOut | System.Int32[]. Array that contains the output mesh adjacency information.
faceRemap | System.Int32[]. Array that contains a new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,Int32,BoneCombination)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToIndexedBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
Managed C++ public: Mesh* ConvertToIndexedBlendedMesh(
Mesh *mesh,
MeshFlags options,
GraphicsStream *adjacencyIn,
int paletteSize,
int *maxFaceInfluence,
BoneCombination *boneCombinationTable
);
JScript .NET public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the input mesh adjacency information.
paletteSize | System.Int32. Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence | System.Int32. Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,Int32,BoneCombination,Int32,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.ConvertToIndexedBlendedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic .NET Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
Managed C++ public: Mesh* ConvertToIndexedBlendedMesh(
Mesh *mesh,
MeshFlags options,
GraphicsStream *adjacencyIn,
int paletteSize,
int *maxFaceInfluence,
BoneCombination *boneCombinationTable,
int *adjacencyOut,
int *faceRemap,
GraphicsStream **vertexRemap
);
JScript .NET public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh | Microsoft.DirectX.Direct3D.Mesh. Source Mesh.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the input mesh adjacency information.
paletteSize | System.Int32. Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence | System.Int32. Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.
adjacencyOut | System.Int32[]. Array that contains the output mesh adjacency information.
faceRemap | System.Int32[]. Array that contains a new index for each face.
vertexRemap | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the SkinInformation object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.SkinInformation.Disposed
  • Microsoft.DirectX.Direct3D.SkinInformation.Disposing


SkinInformation.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


SkinInformation.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the SkinInformation object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~SkinInformation();
Managed C++ | ~SkinInformation();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


SkinInformation.GetBoneInfluence(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.GetBoneInfluence Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the vertices and weights that a bone influences.

Definition

Visual Basic .NET Public Function GetBoneInfluence( _
ByVal bone As Integer _
) As BoneInfluences
C# public BoneInfluences GetBoneInfluence(
int bone
);
Managed C++ public: BoneInfluences GetBoneInfluence(
int bone
);
JScript .NET public function GetBoneInfluence(
bone : int
) : BoneInfluences;

Parameters

bone System.Int32. Integer that represents the bone number.

Return Value

Microsoft.DirectX.Direct3D.BoneInfluences . A BoneInfluences object that contains the bone influences.

Remarks

Use SkinInformation.GetNumBoneInfluences to determine how many vertices the bone influences.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SkinInformation.SetBoneInfluence


SkinInformation.GetBoneName(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.GetBoneName Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the bone name from the bone index.

Definition

Visual Basic .NET Public Function GetBoneName( _
ByVal bone As Integer _
) As String
C# public string GetBoneName(
int bone
);
Managed C++ public: String* GetBoneName(
int bone
);
JScript .NET public function GetBoneName(
bone : int
) : String;

Parameters

bone System.Int32. Value that represents the bone number of the bone name to retrieve.

Return Value

System.String . String that contains the bone name.

See Also

  • SkinInformation.NumberBones
  • SkinInformation.SetBoneName


SkinInformation.GetBoneOffsetMatrix(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.GetBoneOffsetMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the bone offset matrix.

Definition

Visual Basic .NET Public Function GetBoneOffsetMatrix( _
ByVal bone As Integer _
) As Matrix
C# public Matrix GetBoneOffsetMatrix(
int bone
);
Managed C++ public: Matrix GetBoneOffsetMatrix(
int bone
);
JScript .NET public function GetBoneOffsetMatrix(
bone : int
) : Matrix;

Parameters

bone System.Int32. Value that represents the bone number of the bone offset matrix to retrieve.

Return Value

Microsoft.DirectX.Matrix . A Matrix object that represents the bone offset matrix.

See Also

  • SkinInformation.NumberBones
  • SkinInformation.SetBoneOffsetMatrix


SkinInformation.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


SkinInformation.GetMaxFaceInfluences(IndexBuffer,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.GetMaxFaceInfluences Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum face influences in a triangle mesh with the specified index buffer.

Definition

Visual Basic .NET Public Function GetMaxFaceInfluences( _
ByVal indexBuffer As IndexBuffer, _
ByVal numFaces As Integer _
) As Integer
C# public int GetMaxFaceInfluences(
IndexBuffer indexBuffer,
int numFaces
);
Managed C++ public: int GetMaxFaceInfluences(
IndexBuffer *indexBuffer,
int numFaces
);
JScript .NET public function GetMaxFaceInfluences(
indexBuffer : IndexBuffer,
numFaces : int
) : int;

Parameters

indexBuffer | Microsoft.DirectX.Direct3D.IndexBuffer. An IndexBuffer object that contains the mesh index data.
numFaces | System.Int32. Value that represents the number of faces in the mesh.

Return Value

System.Int32 . Value that contains the maximum face influences.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.GetNumBoneInfluences(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.GetNumBoneInfluences Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of influences for a bone.

Definition

Visual Basic .NET Public Function GetNumBoneInfluences( _
ByVal bone As Integer _
) As Integer
C# public int GetNumBoneInfluences(
int bone
);
Managed C++ public: int GetNumBoneInfluences(
int bone
);
JScript .NET public function GetNumBoneInfluences(
bone : int
) : int;

Parameters

bone System.Int32. Value that represents the bone number for which to retrieve the number of influences.

Return Value

System.Int32 . Value that contains the number of influences for the bone.


SkinInformation.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXSkinInfo, which allows unmanaged COM clients to create an instance of the managed SkinInformation class. Not supported.


SkinInformation.op_Equality(SkinInformation,SkinInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As SkinInformation, _
ByVal right As SkinInformation _
) As Boolean
C# public static bool op_Equality(
SkinInformation left,
SkinInformation right
);
Managed C++ public: static bool op_Equality(
SkinInformation *left,
SkinInformation *right
);
JScript .NET public static function op_Equality(
left : SkinInformation,
right : SkinInformation
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.SkinInformation. The SkinInformation object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.SkinInformation. The SkinInformation object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


SkinInformation.op_Inequality(SkinInformation,SkinInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As SkinInformation, _
ByVal right As SkinInformation _
) As Boolean
C# public static bool op_Inequality(
SkinInformation left,
SkinInformation right
);
Managed C++ public: static bool op_Inequality(
SkinInformation *left,
SkinInformation *right
);
JScript .NET public static function op_Inequality(
left : SkinInformation,
right : SkinInformation
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.SkinInformation. The SkinInformation object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.SkinInformation. The SkinInformation object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


SkinInformation.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.SkinInformation.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


SkinInformation.Remap(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Remap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates bone influence information to match vertices after they are reordered.

Definition

Visual Basic .NET Public Sub Remap( _
ByVal vertRemap() As Integer _
)
C# public void Remap(
int[] vertRemap
);
Managed C++ public: void Remap(
int vertRemap __gc[]
);
JScript .NET public function Remap(
vertRemap : int[]
);

Parameters

vertRemap System.Int32[]. Array of integers that represent the vertices to remap.

Remarks

This method should be called if the target vertex buffer is reordered externally.

Each element in vertRemap specifies the previous vertex index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.SetBoneInfluence(Int32,Int32,Int32[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SetBoneInfluence Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the influence value for a bone.

Definition

Visual Basic .NET Public Sub SetBoneInfluence( _
ByVal bone As Integer, _
ByVal numInfluences As Integer, _
ByVal vertices() As Integer, _
ByVal weights() As Single _
)
C# public void SetBoneInfluence(
int bone,
int numInfluences,
int[] vertices,
float[] weights
);
Managed C++ public: void SetBoneInfluence(
int bone,
int numInfluences,
int vertices __gc[],
float weights __gc[]
);
JScript .NET public function SetBoneInfluence(
bone : int,
numInfluences : int,
vertices : int[],
weights : float[]
);

Parameters

bone | System.Int32. Value that represents the bone number.
numInfluences | System.Int32. Value that represents the number of influences.
vertices | System.Int32[]. Array of integers that represent the vertices influenced by the bone.
weights | System.Single[]. Array of floating-point values that represent the weights influenced by the bone.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SkinInformation.GetBoneInfluence
  • SkinInformation.GetNumBoneInfluences


SkinInformation.SetBoneName(Int32,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SetBoneName Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the bone name associated with a bone number.

Definition

Visual Basic .NET Public Sub SetBoneName( _
ByVal bone As Integer, _
ByVal name As String _
)
C# public void SetBoneName(
int bone,
string name
);
Managed C++ public: void SetBoneName(
int bone,
String *name
);
JScript .NET public function SetBoneName(
bone : int,
name : String
);

Parameters

bone | System.Int32. Value that represents the bone number.
name | System.String. String that contains the bone name.

See Also

  • SkinInformation.NumberBones
  • SkinInformation.SetBoneName


SkinInformation.SetBoneOffsetMatrix(Int32,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SetBoneOffsetMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the bone offset matrix.

Definition

Visual Basic .NET Public Sub SetBoneOffsetMatrix( _
ByVal bone As Integer, _
ByVal boneTransform As Matrix _
)
C# public void SetBoneOffsetMatrix(
int bone,
Matrix boneTransform
);
Managed C++ public: void SetBoneOffsetMatrix(
int bone,
Matrix boneTransform
);
JScript .NET public function SetBoneOffsetMatrix(
bone : int,
boneTransform : Matrix
);

Parameters

bone | System.Int32. Value that represents the bone number of the bone offset matrix.
boneTransform | Microsoft.DirectX.Matrix. A Matrix object that represents the bone offset matrix.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SkinInformation.GetBoneOffsetMatrix


SkinInformation.SkinInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Overload List

public SkinInformation(BaseMesh, BoneCombination[]);
public SkinInformation(BaseMesh, int, GraphicsStream);
public SkinInformation(ID3DXSkinInfo);
public SkinInformation(int, GraphicsStream, int);
public SkinInformation(int, VertexElement[], int);
public SkinInformation(int, VertexFormats, int);
public SkinInformation(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(ID3DXSkinInfo)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXSkinInfo _
)
C# public SkinInformation(
ID3DXSkinInfo pUnk
);
Managed C++ public: SkinInformation(
ID3DXSkinInfo pUnk
);
JScript .NET public function SkinInformation(
pUnk : ID3DXSkinInfo
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXSkinInfo. Unmanaged Component Object Model (COM) ID3DXSkinInfo interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public SkinInformation(
IntPtr unmanagedObject
);
Managed C++ public: SkinInformation(
IntPtr unmanagedObject
);
JScript .NET public function SkinInformation(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXSkinInfo interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(BaseMesh,Int32,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic .NET Public Sub New( _
ByVal baseMesh As BaseMesh, _
ByVal boneCombinationTableLength As Integer, _
ByVal boneCombinationTable As GraphicsStream _
)
C# public SkinInformation(
BaseMesh baseMesh,
int boneCombinationTableLength,
GraphicsStream boneCombinationTable
);
Managed C++ public: SkinInformation(
BaseMesh *baseMesh,
int boneCombinationTableLength,
GraphicsStream *boneCombinationTable
);
JScript .NET public function SkinInformation(
baseMesh : BaseMesh,
boneCombinationTableLength : int,
boneCombinationTable : GraphicsStream
);

Parameters

baseMesh | Microsoft.DirectX.Direct3D.BaseMesh. A BaseMesh object from which to create the skin mesh.
boneCombinationTableLength | System.Int32. Value that represents the bone combination table length.
boneCombinationTable | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the bone combinations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(BaseMesh,BoneCombination[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic .NET Public Sub New( _
ByVal baseMesh As BaseMesh, _
ByVal boneCombinationTable() As BoneCombination _
)
C# public SkinInformation(
BaseMesh baseMesh,
BoneCombination[] boneCombinationTable
);
Managed C++ public: SkinInformation(
BaseMesh *baseMesh,
BoneCombination boneCombinationTable __gc[]
);
JScript .NET public function SkinInformation(
baseMesh : BaseMesh,
boneCombinationTable : BoneCombination[]
);

Parameters

baseMesh | Microsoft.DirectX.Direct3D.BaseMesh. A BaseMesh object from which to create the skin mesh.
boneCombinationTable | Microsoft.DirectX.Direct3D.BoneCombination[]. Array of BoneCombination objects.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(Int32,VertexFormats,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic .NET Public Sub New( _
ByVal numVertices As Integer, _
ByVal vertexFormat As VertexFormats, _
ByVal numBones As Integer _
)
C# public SkinInformation(
int numVertices,
VertexFormats vertexFormat,
int numBones
);
Managed C++ public: SkinInformation(
int numVertices,
VertexFormats vertexFormat,
int numBones
);
JScript .NET public function SkinInformation(
numVertices : int,
vertexFormat : VertexFormats,
numBones : int
);

Parameters

numVertices | System.Int32. Value that represents the number of vertices in the skin mesh.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. A VertexFormats object that describes the vertex format for the skin mesh.
numBones | System.Int32. Value that represents the number of bones for the skin mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(Int32,VertexElement[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic .NET Public Sub New( _
ByVal numVertices As Integer, _
ByVal decl() As VertexElement, _
ByVal numBones As Integer _
)
C# public SkinInformation(
int numVertices,
VertexElement[] decl,
int numBones
);
Managed C++ public: SkinInformation(
int numVertices,
VertexElement decl __gc[],
int numBones
);
JScript .NET public function SkinInformation(
numVertices : int,
decl : VertexElement[],
numBones : int
);

Parameters

numVertices | System.Int32. Value that represents the number of vertices in the skin mesh.
decl | Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement objects that describe the vertex format for the skin mesh.
numBones | System.Int32. Value that represents the number of bones for the skin mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(Int32,GraphicsStream,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.SkinInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic .NET Public Sub New( _
ByVal numVertices As Integer, _
ByVal declaration As GraphicsStream, _
ByVal numBones As Integer _
)
C# public SkinInformation(
int numVertices,
GraphicsStream declaration,
int numBones
);
Managed C++ public: SkinInformation(
int numVertices,
GraphicsStream *declaration,
int numBones
);
JScript .NET public function SkinInformation(
numVertices : int,
declaration : GraphicsStream,
numBones : int
);

Parameters

numVertices | System.Int32. Value that represents the number of vertices in the skin mesh.
declaration | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains vertex format data for the skin mesh.
numBones | System.Int32. Value that represents the number of bones for the skin mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinInformation.UpdateSkinnedMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.UpdateSkinnedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies software skinning to target vertices that are based on the current matrices.

Overload List

public Array UpdateSkinnedMesh(Matrix[], Matrix[], Array);
public void UpdateSkinnedMesh(Matrix[], Matrix[], GraphicsStream, GraphicsStream);

Remarks

When used to skin vertices with two position elements, this method skins the second position element with the inverse of the bone instead of the bone itself.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.UpdateSkinnedMesh(Matrix[],Matrix[],GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.UpdateSkinnedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies software skinning to target vertices that are based on the current matrices.

Definition

Visual Basic .NET Public Sub UpdateSkinnedMesh( _
ByVal boneTransforms() As Matrix, _
ByVal boneInvTransforms() As Matrix, _
ByVal sourceVertices As GraphicsStream, _
ByVal destinationVertices As GraphicsStream _
)
C# public void UpdateSkinnedMesh(
Matrix[] boneTransforms,
Matrix[] boneInvTransforms,
GraphicsStream sourceVertices,
GraphicsStream destinationVertices
);
Managed C++ public: void UpdateSkinnedMesh(
Matrix boneTransforms __gc[],
Matrix boneInvTransforms __gc[],
GraphicsStream *sourceVertices,
GraphicsStream *destinationVertices
);
JScript .NET public function UpdateSkinnedMesh(
boneTransforms : Matrix[],
boneInvTransforms : Matrix[],
sourceVertices : GraphicsStream,
destinationVertices : GraphicsStream
);

Parameters

boneTransforms | Microsoft.DirectX.Matrix[]. Array of Matrix objects that represent bone transforms.
boneInvTransforms | Microsoft.DirectX.Matrix[]. Array of Matrix objects that represent the inverse transpose of the bone transform matrix.
sourceVertices | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the source vertices.
destinationVertices | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains destination vertices.

Remarks

When used to skin vertices with two position elements, this method skins the second position element with the inverse of the bone instead of the bone itself.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.UpdateSkinnedMesh(Matrix[],Matrix[],Array)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.UpdateSkinnedMesh Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies software skinning to target vertices that are based on the current matrices.

Definition

Visual Basic .NET Public Function UpdateSkinnedMesh( _
ByVal boneTransforms() As Matrix, _
ByVal boneInvTransforms() As Matrix, _
ByVal verticesSource As Array _
) As Array
C# public Array UpdateSkinnedMesh(
Matrix[] boneTransforms,
Matrix[] boneInvTransforms,
Array verticesSource
);
Managed C++ public: Array* UpdateSkinnedMesh(
Matrix boneTransforms __gc[],
Matrix boneInvTransforms __gc[],
Array *verticesSource
);
JScript .NET public function UpdateSkinnedMesh(
boneTransforms : Matrix[],
boneInvTransforms : Matrix[],
verticesSource : Array
) : Array;

Parameters

boneTransforms | Microsoft.DirectX.Matrix[]. Array of Matrix objects that represent bone transforms.
boneInvTransforms | Microsoft.DirectX.Matrix[]. Array of Matrix objects that represent the inverse transpose of the bone transform matrix.
verticesSource | System.Array. An Array Leave Site of source vertices.

Return Value

System.Array . An Array Leave Site of destination vertices.

Remarks

When used to skin vertices with two position elements, this method skins the second position element with the inverse of the bone instead of the bone itself.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.UpdateUnmanagedPointer(ID3DXSkinInfo)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this SkinInformation object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXSkinInfo _
)
C# public void UpdateUnmanagedPointer(
ID3DXSkinInfo pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXSkinInfo pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXSkinInfo
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXSkinInfo. Pointer to the ID3DXSkinInfo structure used to update the unmanaged pointer for this SkinInformation object.


SkinInformation.Declaration

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Declaration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex declaration.

Definition

Visual Basic .NET | Public Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; set; }
Managed C++ public: __property VertexElement get_Declaration();
public: __property void set_Declaration(VertexElement);
JScript .NET public function get Declaration() : VertexElement[]
public function set Declaration(VertexElement[]);

Property Value

Microsoft.DirectX.Direct3D.VertexElement[] . Array of VertexElement structures that contain the vertex declarations.

This property is read/write.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


SkinInformation.MaxVertexInfluences

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.MaxVertexInfluences Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of influences for any vertex in a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertexInfluences As Integer
C# | public int MaxVertexInfluences { get; }
Managed C++ | public: __property int get_MaxVertexInfluences();
JScript .NET | public function get MaxVertexInfluences() : int

Property Value

System.Int32 . Value that represents the maximum vertex influence.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.MinBoneInfluence

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.MinBoneInfluence Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the minimum bone influence.

Definition

Visual Basic .NET | Public Property MinBoneInfluence As Single
C# | public float MinBoneInfluence { get; set; }
Managed C++ public: __property float get_MinBoneInfluence();
public: __property void set_MinBoneInfluence(float);
JScript .NET public function get MinBoneInfluence() : float
public function set MinBoneInfluence(float);

Property Value

System.Single . Floating-point value that represents the minimum bone influence.

This property is read/write.

Remarks

Influence values smaller than the minimum value are ignored.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.NumberBones

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.NumberBones Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of bones in a mesh.

Definition

Visual Basic .NET | Public ReadOnly Property NumberBones As Integer
C# | public int NumberBones { get; }
Managed C++ | public: __property int get_NumberBones();
JScript .NET | public function get NumberBones() : int

Property Value

System.Int32 . Value that represents the number of bones.

This property is read-only.


SkinInformation.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXSkinInfo interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXSkinInfo
C# | public ID3DXSkinInfo UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXSkinInfo get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXSkinInfo

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXSkinInfo . Unmanaged ID3DXSkinInfo interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


SkinInformation.VertexFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.VertexFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the fixed function vertex value.

Definition

Visual Basic .NET | Public Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; set; }
Managed C++ public: __property VertexFormats get_VertexFormat();
public: __property void set_VertexFormat(VertexFormats);
JScript .NET public function get VertexFormat() : VertexFormats
public function set VertexFormat(VertexFormats);

Property Value

Microsoft.DirectX.Direct3D.VertexFormats . Valid combination of VertexFormats enumeration values that describe the vertex format.

This property is read/write.


SkinInformation.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinInformation.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the SkinInformation object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.SkinInformation.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SkinInformation object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.SkinningNotSupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinningNotSupportedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Skinning is not supported.

Definition

Visual Basic .NET Public Class SkinningNotSupportedException
Inherits Direct3DXException
C# | public class SkinningNotSupportedException : Direct3DXException
Managed C++ | public __gc class SkinningNotSupportedException : public Direct3DXException
JScript .NET | public class SkinningNotSupportedException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SkinningNotSupportedException | Initializes a new instance of the SkinningNotSupportedException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
SkinningNotSupportedException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SkinningNotSupportedException.SkinningNotSupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinningNotSupportedException class.

Overload List

public SkinningNotSupportedException();
protected SkinningNotSupportedException(SerializationInfo, StreamingContext);
public SkinningNotSupportedException(string);
public SkinningNotSupportedException(string, Exception);


SkinningNotSupportedException.SkinningNotSupportedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SkinningNotSupportedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SkinningNotSupportedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SkinningNotSupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


SkinningNotSupportedException.SkinningNotSupportedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SkinningNotSupportedException(
string message,
Exception inner
);
Managed C++ public: SkinningNotSupportedException(
String *message,
Exception *inner
);
JScript .NET public function SkinningNotSupportedException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


SkinningNotSupportedException.SkinningNotSupportedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SkinningNotSupportedException(
string message
);
Managed C++ public: SkinningNotSupportedException(
String *message
);
JScript .NET public function SkinningNotSupportedException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


SkinningNotSupportedException.SkinningNotSupportedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public SkinningNotSupportedException();
Managed C++ | public: SkinningNotSupportedException();
JScript .NET | public function SkinningNotSupportedException();


Microsoft.DirectX.Direct3D.SphericalHarmonics

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates spherical harmonic (SH) mathematical functions.

Definition

Visual Basic .NET NotInheritable Public Class SphericalHarmonics
Inherits Object
C# | public sealed class SphericalHarmonics : Object
Managed C++ | public __gc __sealed class SphericalHarmonics : public Object
JScript .NET | public class SphericalHarmonics extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) MaximumOrder | Retrieves the maximum order for SH evaluation.
static (Shared in Visual Basic .NET) MinimumOrder | Retrieves the minimum order for SH evaluation.

Methods

Method | Description
static (Shared in Visual Basic .NET) Add | Adds two SH vectors together; in other words, Out[i] = A[i] + B[i].
static (Shared in Visual Basic .NET) Dot | Computes the dot product of two SH vectors.
static (Shared in Visual Basic .NET) EvaluateConeLight | Evaluates a light that is a cone of constant intensity and returns spectral SH data.
static (Shared in Visual Basic .NET) EvaluateDirection | Evaluates the SH basis functions from an input direction vector.
static (Shared in Visual Basic .NET) EvaluateDirectionalLight | Evaluates a directional light and returns spectral SH data.
static (Shared in Visual Basic .NET) EvaluateHemisphereLight | Evaluates a light that is a linear interpolation between two colors over the sphere.
static (Shared in Visual Basic .NET) EvaluateSphericalLight | Evaluates a spherical light and returns spectral SH data.
static (Shared in Visual Basic .NET) ProjectCubeMap | Projects a function represented on a cube map into SH.
static (Shared in Visual Basic .NET) Rotate | Rotates the SH vector by the given matrix.
static (Shared in Visual Basic .NET) RotateZ | Rotates the SH vector in the z-axis by the given angle.
static (Shared in Visual Basic .NET) Scale | Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Inheritance Hierarchy

Object Leave Site
SphericalHarmonics

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SphericalHarmonics.Add

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Overload List

public static void Add(GraphicsStream, int, GraphicsStream, GraphicsStream);
public static void Add(GraphicsStream, int, float[], float[]);
public static void Add(float[], int, GraphicsStream, GraphicsStream);
public static void Add(float[], int, float[], float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(Single[],Int32,Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic .NET Public Shared Sub Add( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal vectorA() As Single, _
ByVal vectorB() As Single _
)
C# public static void Add(
float[] output,
int order,
float[] vectorA,
float[] vectorB
);
Managed C++ public: static void Add(
float output __gc[],
int order,
float vectorA __gc[],
float vectorB __gc[]
);
JScript .NET public static function Add(
output : float[],
order : int,
vectorA : float[],
vectorB : float[]
);

Parameters

output | System.Single[]. An array of floating point values that represent the output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA | System.Single[]. An array of floating point values that represent the first spherical harmonic (SH) vector to add to the second vector.
vectorB | System.Single[]. An array of floating point values that represent the second spherical harmonic (SH) vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(Single[],Int32,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic .NET Public Shared Sub Add( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal vectorA As GraphicsStream, _
ByVal vectorB As GraphicsStream _
)
C# public static void Add(
float[] output,
int order,
GraphicsStream vectorA,
GraphicsStream vectorB
);
Managed C++ public: static void Add(
float output __gc[],
int order,
GraphicsStream *vectorA,
GraphicsStream *vectorB
);
JScript .NET public static function Add(
output : float[],
order : int,
vectorA : GraphicsStream,
vectorB : GraphicsStream
);

Parameters

output | System.Single[]. An array of floating point values that represent the output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the first spherical harmonic (SH) vector to add to the second vector.
vectorB | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the second spherical harmonic (SH) vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(GraphicsStream,Int32,Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic .NET Public Shared Sub Add( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal vectorA() As Single, _
ByVal vectorB() As Single _
)
C# public static void Add(
GraphicsStream output,
int order,
float[] vectorA,
float[] vectorB
);
Managed C++ public: static void Add(
GraphicsStream *output,
int order,
float vectorA __gc[],
float vectorB __gc[]
);
JScript .NET public static function Add(
output : GraphicsStream,
order : int,
vectorA : float[],
vectorB : float[]
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA | System.Single[]. An array of floating point values that represent the first spherical harmonic (SH) vector to add to the second vector.
vectorB | System.Single[]. An array of floating point values that represent the second spherical harmonic (SH) vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(GraphicsStream,Int32,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic .NET Public Shared Sub Add( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal vectorA As GraphicsStream, _
ByVal vectorB As GraphicsStream _
)
C# public static void Add(
GraphicsStream output,
int order,
GraphicsStream vectorA,
GraphicsStream vectorB
);
Managed C++ public: static void Add(
GraphicsStream *output,
int order,
GraphicsStream *vectorA,
GraphicsStream *vectorB
);
JScript .NET public static function Add(
output : GraphicsStream,
order : int,
vectorA : GraphicsStream,
vectorB : GraphicsStream
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the first spherical harmonic (SH) vector to add to the second vector.
vectorB | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the second spherical harmonic (SH) vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Dot

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of two spherical harmonic (SH) vectors.

Overload List

public static float Dot(int, GraphicsStream, GraphicsStream);
public static float Dot(int, float[], float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Dot(Int32,Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of two spherical harmonic (SH) vectors.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal order As Integer, _
ByVal vectorA() As Single, _
ByVal vectorB() As Single _
) As Single
C# public static float Dot(
int order,
float[] vectorA,
float[] vectorB
);
Managed C++ public: static float Dot(
int order,
float vectorA __gc[],
float vectorB __gc[]
);
JScript .NET public static function Dot(
order : int,
vectorA : float[],
vectorB : float[]
) : float;

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA | System.Single[]. An array of floating point values that represent the first spherical harmonic (SH) vector.
vectorB | System.Single[]. An array of floating point values that represent the second spherical harmonic (SH) vector.

Return Value

System.Single . A floating point value that represents the dot product of the two vectors.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Dot(Int32,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of two spherical harmonic (SH) vectors.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal order As Integer, _
ByVal vectorA As GraphicsStream, _
ByVal vectorB As GraphicsStream _
) As Single
C# public static float Dot(
int order,
GraphicsStream vectorA,
GraphicsStream vectorB
);
Managed C++ public: static float Dot(
int order,
GraphicsStream *vectorA,
GraphicsStream *vectorB
);
JScript .NET public static function Dot(
order : int,
vectorA : GraphicsStream,
vectorB : GraphicsStream
) : float;

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the first spherical harmonic (SH) vector.
vectorB | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the second spherical harmonic (SH) vector.

Return Value

System.Single . A floating point value that represents the dot product of the two vectors.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.EvaluateConeLight

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateConeLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data.

Overload List

public static void EvaluateConeLight(int, Vector3, float, float, float, float, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateConeLight(int, Vector3, float, float, float, float, float[], float[], float[]);

Remarks

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the exit radiance of a point directly under the light (oriented in the cone direction on a diffuse object with an albedo of 1) would be 1.0. This will compute 3 spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateConeLight(Int32,Vector3,Single,Single,Single,Single,Single[],Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateConeLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic .NET Public Shared Sub EvaluateConeLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
Managed C++ public: static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
float redOutput __gc[],
float greenOutput __gc[],
float blueOutput __gc[]
);
JScript .NET public static function EvaluateConeLight(
order : int,
direction : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
radius | System.Single. Radius of the light cone in radians.
redIntensity | System.Single. The red intensity of the light.
greenIntensity | System.Single. The green intensity of the light.
blueIntensity | System.Single. The blue intensity of the light.
redOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.
greenOutput | System.Single[]. Output spherical harmonic (SH) vector for the green component.
blueOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.

Remarks

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the exit radiance of a point directly under the light (oriented in the cone direction on a diffuse object with an albedo of 1) would be 1.0. This will compute 3 spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateConeLight(Int32,Vector3,Single,Single,Single,Single,GraphicsStream,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateConeLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic .NET Public Shared Sub EvaluateConeLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
Managed C++ public: static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream *redOutput,
GraphicsStream *greenOutput,
GraphicsStream *blueOutput
);
JScript .NET public static function EvaluateConeLight(
order : int,
direction : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
radius | System.Single. Radius of the light cone in radians.
redIntensity | System.Single. The red intensity of the light.
greenIntensity | System.Single. The green intensity of the light.
blueIntensity | System.Single. The blue intensity of the light.
redOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.
greenOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the green component.
blueOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.

Remarks

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the exit radiance of a point directly under the light (oriented in the cone direction on a diffuse object with an albedo of 1) would be 1.0. This will compute 3 spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateDirection

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateDirection Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates the spherical harmonic (SH) basis functions from an input direction vector.

Overload List

public static void EvaluateDirection(GraphicsStream, int, Vector3);
public static void EvaluateDirection(float[], int, Vector3);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations


SphericalHarmonics.EvaluateDirection(Single[],Int32,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateDirection Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates the spherical harmonic (SH) basis functions from an input direction vector.

Definition

Visual Basic .NET Public Shared Sub EvaluateDirection( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal direction As Vector3 _
)
C# public static void EvaluateDirection(
float[] output,
int order,
Vector3 direction
);
Managed C++ public: static void EvaluateDirection(
float output __gc[],
int order,
Vector3 direction
);
JScript .NET public static function EvaluateDirection(
output : float[],
order : int,
direction : Vector3
);

Parameters

output | System.Single[]. spherical harmonic (SH) output coefficients. The basis function Ylm is stored at location l2 + m + l.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. (x, y, z) direction vector in which to evaluate the spherical harmonic (SH) basis functions. Must be normalized. See Remarks.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations


SphericalHarmonics.EvaluateDirection(GraphicsStream,Int32,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateDirection Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates the spherical harmonic (SH) basis functions from an input direction vector.

Definition

Visual Basic .NET Public Shared Sub EvaluateDirection( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal direction As Vector3 _
)
C# public static void EvaluateDirection(
GraphicsStream output,
int order,
Vector3 direction
);
Managed C++ public: static void EvaluateDirection(
GraphicsStream *output,
int order,
Vector3 direction
);
JScript .NET public static function EvaluateDirection(
output : GraphicsStream,
order : int,
direction : Vector3
);

Parameters

output | Microsoft.DirectX.GraphicsStream. spherical harmonic (SH) output coefficients. The basis function Ylm is stored at location l2 + m + l.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. (x, y, z) direction vector in which to evaluate the spherical harmonic (SH) basis functions. Must be normalized. See Remarks.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations


SphericalHarmonics.EvaluateDirectionalLight

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateDirectionalLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a directional light and returns spectral spherical harmonic (SH) data.

Overload List

public static void EvaluateDirectionalLight(int, Vector3, float, float, float, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateDirectionalLight(int, Vector3, float, float, float, float[], float[], float[]);

Remarks

Evaluates a directional light and returns spectral spherical harmonic (SH) data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the resulting exit radiance of a point directly under the light on a diffuse object with an albedo of 1 would be 1.0. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateDirectionalLight(Int32,Vector3,Single,Single,Single,Single[],Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateDirectionalLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a directional light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic .NET Public Shared Sub EvaluateDirectionalLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
Managed C++ public: static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
float redOutput __gc[],
float greenOutput __gc[],
float blueOutput __gc[]
);
JScript .NET public static function EvaluateDirectionalLight(
order : int,
direction : Vector3,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
redIntensity | System.Single. The red intensity of the light.
greenIntensity | System.Single. The green intensity of the light.
blueIntensity | System.Single. The blue intensity of the light.
redOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.
greenOutput | System.Single[]. Output spherical harmonic (SH) vector for the green component.
blueOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.

Remarks

Evaluates a directional light and returns spectral spherical harmonic (SH) data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the resulting exit radiance of a point directly under the light on a diffuse object with an albedo of 1 would be 1.0. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateDirectionalLight(Int32,Vector3,Single,Single,Single,GraphicsStream,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateDirectionalLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a directional light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic .NET Public Shared Sub EvaluateDirectionalLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
Managed C++ public: static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream *redOutput,
GraphicsStream *greenOutput,
GraphicsStream *blueOutput
);
JScript .NET public static function EvaluateDirectionalLight(
order : int,
direction : Vector3,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
redIntensity | System.Single. The red intensity of the light.
greenIntensity | System.Single. The green intensity of the light.
blueIntensity | System.Single. The blue intensity of the light.
redOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.
greenOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the green component.
blueOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.

Remarks

Evaluates a directional light and returns spectral spherical harmonic (SH) data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the resulting exit radiance of a point directly under the light on a diffuse object with an albedo of 1 would be 1.0. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateHemisphereLight

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateHemisphereLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a light that is a linear interpolation between two colors over the sphere.

Overload List

public static void EvaluateHemisphereLight(int, Vector3, ColorValue, ColorValue, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateHemisphereLight(int, Vector3, ColorValue, ColorValue, float[], float[], float[]);

Remarks

The interpolation is done linearly between the two points, not over the surface of the sphere (that is, if the axis were (0,0,1), it is linear in Z, not in the azimuthal angle). The resulting spherical lighting function is normalized so that a point on a perfectly diffuse surface with no shadowing and a normal pointed towards direction would result in exit radiance with a value of 1 (if the top color were white and the bottom color were black). This is a very simple model where top represents the intensity of the "sky" and bottom represents the intensity of the "ground".

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateHemisphereLight(Int32,Vector3,ColorValue,ColorValue,Single[],Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateHemisphereLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a light that is a linear interpolation between two colors over the sphere.

Definition

Visual Basic .NET Public Shared Sub EvaluateHemisphereLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal top As ColorValue, _
ByVal bottom As ColorValue, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
Managed C++ public: static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
float redOutput __gc[],
float greenOutput __gc[],
float blueOutput __gc[]
);
JScript .NET public static function EvaluateHemisphereLight(
order : int,
direction : Vector3,
top : ColorValue,
bottom : ColorValue,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
top | Microsoft.DirectX.Direct3D.ColorValue. The sky color.
bottom | Microsoft.DirectX.Direct3D.ColorValue. The ground color.
redOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.
greenOutput | System.Single[]. Output spherical harmonic (SH) vector for the green component.
blueOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.

Remarks

The interpolation is done linearly between the two points, not over the surface of the sphere (that is, if the axis were (0,0,1), it is linear in Z, not in the azimuthal angle). The resulting spherical lighting function is normalized so that a point on a perfectly diffuse surface with no shadowing and a normal pointed towards direction would result in exit radiance with a value of 1 (if the top color were white and the bottom color were black). This is a very simple model where top represents the intensity of the "sky" and bottom represents the intensity of the "ground".

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateHemisphereLight(Int32,Vector3,ColorValue,ColorValue,GraphicsStream,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateHemisphereLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a light that is a linear interpolation between two colors over the sphere.

Definition

Visual Basic .NET Public Shared Sub EvaluateHemisphereLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal top As ColorValue, _
ByVal bottom As ColorValue, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
Managed C++ public: static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
GraphicsStream *redOutput,
GraphicsStream *greenOutput,
GraphicsStream *blueOutput
);
JScript .NET public static function EvaluateHemisphereLight(
order : int,
direction : Vector3,
top : ColorValue,
bottom : ColorValue,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
top | Microsoft.DirectX.Direct3D.ColorValue. The sky color.
bottom | Microsoft.DirectX.Direct3D.ColorValue. The ground color.
redOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.
greenOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the green component.
blueOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.

Remarks

The interpolation is done linearly between the two points, not over the surface of the sphere (that is, if the axis were (0,0,1), it is linear in Z, not in the azimuthal angle). The resulting spherical lighting function is normalized so that a point on a perfectly diffuse surface with no shadowing and a normal pointed towards direction would result in exit radiance with a value of 1 (if the top color were white and the bottom color were black). This is a very simple model where top represents the intensity of the "sky" and bottom represents the intensity of the "ground".

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateSphericalLight

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateSphericalLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a spherical light and returns spectral spherical harmonic (SH) data.

Overload List

public static void EvaluateSphericalLight(int, Vector3, float, float, float, float, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateSphericalLight(int, Vector3, float, float, float, float, float[], float[], float[]);

Remarks

Evaluates a spherical light and returns spectral spherical harmonic (SH) data. There is no normalization of the intensity of the light like there is for directional lights, so care has to be taken when specifying the intensities. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateSphericalLight(Int32,Vector3,Single,Single,Single,Single,Single[],Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateSphericalLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a spherical light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic .NET Public Shared Sub EvaluateSphericalLight( _
ByVal order As Integer, _
ByVal position As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
Managed C++ public: static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
float redOutput __gc[],
float greenOutput __gc[],
float blueOutput __gc[]
);
JScript .NET public static function EvaluateSphericalLight(
order : int,
position : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
position | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
radius | System.Single. Radius of the spherical light source.
redIntensity | System.Single. The red intensity of the light.
greenIntensity | System.Single. The green intensity of the light.
blueIntensity | System.Single. The blue intensity of the light.
redOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.
greenOutput | System.Single[]. Output spherical harmonic (SH) vector for the green component.
blueOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.

Remarks

Evaluates a spherical light and returns spectral spherical harmonic (SH) data. There is no normalization of the intensity of the light like there is for directional lights, so care has to be taken when specifying the intensities. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateSphericalLight(Int32,Vector3,Single,Single,Single,Single,GraphicsStream,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.EvaluateSphericalLight Method

 Language:
Note: This documentation is preliminary and is subject to change.

Evaluates a spherical light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic .NET Public Shared Sub EvaluateSphericalLight( _
ByVal order As Integer, _
ByVal position As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
Managed C++ public: static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream *redOutput,
GraphicsStream *greenOutput,
GraphicsStream *blueOutput
);
JScript .NET public static function EvaluateSphericalLight(
order : int,
position : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
position | Microsoft.DirectX.Vector3. The (x, y, z) hemisphere axis direction vector in which to evaluate the spherical harmonic (SH) basis functions. See Remarks.
radius | System.Single. Radius of the spherical light source.
redIntensity | System.Single. The red intensity of the light.
greenIntensity | System.Single. The green intensity of the light.
blueIntensity | System.Single. The blue intensity of the light.
redOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.
greenOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the green component.
blueOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.

Remarks

Evaluates a spherical light and returns spectral spherical harmonic (SH) data. There is no normalization of the intensity of the light like there is for directional lights, so care has to be taken when specifying the intensities. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical Coordinates Equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.ProjectCubeMap

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.ProjectCubeMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a function represented on a cube map into spherical harmonics (SH).

Overload List

public static void ProjectCubeMap(int, CubeTexture, GraphicsStream, GraphicsStream, GraphicsStream);
public static void ProjectCubeMap(int, CubeTexture, float[], float[], float[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.ProjectCubeMap(Int32,CubeTexture,Single[],Single[],Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.ProjectCubeMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a function represented on a cube map into spherical harmonics (SH).

Definition

Visual Basic .NET Public Shared Sub ProjectCubeMap( _
ByVal order As Integer, _
ByVal cubeMap As CubeTexture, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void ProjectCubeMap(
int order,
CubeTexture cubeMap,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
Managed C++ public: static void ProjectCubeMap(
int order,
CubeTexture *cubeMap,
float redOutput __gc[],
float greenOutput __gc[],
float blueOutput __gc[]
);
JScript .NET public static function ProjectCubeMap(
order : int,
cubeMap : CubeTexture,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
cubeMap | Microsoft.DirectX.Direct3D.CubeTexture. A CubeTexture object used as the source cube map.
redOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.
greenOutput | System.Single[]. Output spherical harmonic (SH) vector for the green component.
blueOutput | System.Single[]. Output spherical harmonic (SH) vector for the red component.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.ProjectCubeMap(Int32,CubeTexture,GraphicsStream,GraphicsStream,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.ProjectCubeMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a function represented on a cube map into spherical harmonics (SH).

Definition

Visual Basic .NET Public Shared Sub ProjectCubeMap( _
ByVal order As Integer, _
ByVal cubeMap As CubeTexture, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void ProjectCubeMap(
int order,
CubeTexture cubeMap,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
Managed C++ public: static void ProjectCubeMap(
int order,
CubeTexture *cubeMap,
GraphicsStream *redOutput,
GraphicsStream *greenOutput,
GraphicsStream *blueOutput
);
JScript .NET public static function ProjectCubeMap(
order : int,
cubeMap : CubeTexture,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
cubeMap | Microsoft.DirectX.Direct3D.CubeTexture. A CubeTexture object used as the source cube map.
redOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.
greenOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the green component.
blueOutput | Microsoft.DirectX.GraphicsStream. Output spherical harmonic (SH) vector for the blue component.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.Rotate

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Rotate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector by the given matrix.

Overload List

public static void Rotate(GraphicsStream, int, Matrix, GraphicsStream);
public static void Rotate(GraphicsStream, int, Matrix, float[]);
public static void Rotate(float[], int, Matrix, GraphicsStream);
public static void Rotate(float[], int, Matrix, float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(Single[],Int32,Matrix,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Rotate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic .NET Public Shared Sub Rotate( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input() As Single _
)
C# public static void Rotate(
float[] output,
int order,
Matrix rotation,
float[] input
);
Managed C++ public: static void Rotate(
float output __gc[],
int order,
Matrix rotation,
float input __gc[]
);
JScript .NET public static function Rotate(
output : float[],
order : int,
rotation : Matrix,
input : float[]
);

Parameters

output | System.Single[]. An array of floating point values that represent spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation | Microsoft.DirectX.Matrix. The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input | System.Single[]. An array of floating point values that represent rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(Single[],Int32,Matrix,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Rotate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic .NET Public Shared Sub Rotate( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input As GraphicsStream _
)
C# public static void Rotate(
float[] output,
int order,
Matrix rotation,
GraphicsStream input
);
Managed C++ public: static void Rotate(
float output __gc[],
int order,
Matrix rotation,
GraphicsStream *input
);
JScript .NET public static function Rotate(
output : float[],
order : int,
rotation : Matrix,
input : GraphicsStream
);

Parameters

output | System.Single[]. An array of floating point values that represent spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation | Microsoft.DirectX.Matrix. The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(GraphicsStream,Int32,Matrix,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Rotate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic .NET Public Shared Sub Rotate( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input() As Single _
)
C# public static void Rotate(
GraphicsStream output,
int order,
Matrix rotation,
float[] input
);
Managed C++ public: static void Rotate(
GraphicsStream *output,
int order,
Matrix rotation,
float input __gc[]
);
JScript .NET public static function Rotate(
output : GraphicsStream,
order : int,
rotation : Matrix,
input : float[]
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation | Microsoft.DirectX.Matrix. The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input | System.Single[]. An array of floating point values that represent rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(GraphicsStream,Int32,Matrix,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Rotate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic .NET Public Shared Sub Rotate( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input As GraphicsStream _
)
C# public static void Rotate(
GraphicsStream output,
int order,
Matrix rotation,
GraphicsStream input
);
Managed C++ public: static void Rotate(
GraphicsStream *output,
int order,
Matrix rotation,
GraphicsStream *input
);
JScript .NET public static function Rotate(
output : GraphicsStream,
order : int,
rotation : Matrix,
input : GraphicsStream
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation | Microsoft.DirectX.Matrix. The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.RotateZ Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Overload List

public static void RotateZ(GraphicsStream, int, float, GraphicsStream);
public static void RotateZ(GraphicsStream, int, float, float[]);
public static void RotateZ(float[], int, float, GraphicsStream);
public static void RotateZ(float[], int, float, float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(Single[],Int32,Single,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.RotateZ Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic .NET Public Shared Sub RotateZ( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input() As Single _
)
C# public static void RotateZ(
float[] output,
int order,
float angle,
float[] input
);
Managed C++ public: static void RotateZ(
float output __gc[],
int order,
float angle,
float input __gc[]
);
JScript .NET public static function RotateZ(
output : float[],
order : int,
angle : float,
input : float[]
);

Parameters

output | System.Single[]. An array of floating point values that represent spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle | System.Single. Rotation angle in radians. The rotation is performed around the z-axis.
input | System.Single[]. An array of floating point values that represent rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(Single[],Int32,Single,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.RotateZ Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic .NET Public Shared Sub RotateZ( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input As GraphicsStream _
)
C# public static void RotateZ(
float[] output,
int order,
float angle,
GraphicsStream input
);
Managed C++ public: static void RotateZ(
float output __gc[],
int order,
float angle,
GraphicsStream *input
);
JScript .NET public static function RotateZ(
output : float[],
order : int,
angle : float,
input : GraphicsStream
);

Parameters

output | System.Single[]. An array of floating point values that represent spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle | System.Single. Rotation angle in radians. The rotation is performed around the z-axis.
input | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(GraphicsStream,Int32,Single,Single[])

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.RotateZ Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic .NET Public Shared Sub RotateZ( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input() As Single _
)
C# public static void RotateZ(
GraphicsStream output,
int order,
float angle,
float[] input
);
Managed C++ public: static void RotateZ(
GraphicsStream *output,
int order,
float angle,
float input __gc[]
);
JScript .NET public static function RotateZ(
output : GraphicsStream,
order : int,
angle : float,
input : float[]
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle | System.Single. Rotation angle in radians. The rotation is performed around the z-axis.
input | System.Single[]. An array of floating point values that represent rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(GraphicsStream,Int32,Single,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.RotateZ Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic .NET Public Shared Sub RotateZ( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input As GraphicsStream _
)
C# public static void RotateZ(
GraphicsStream output,
int order,
float angle,
GraphicsStream input
);
Managed C++ public: static void RotateZ(
GraphicsStream *output,
int order,
float angle,
GraphicsStream *input
);
JScript .NET public static function RotateZ(
output : GraphicsStream,
order : int,
angle : float,
input : GraphicsStream
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle | System.Single. Rotation angle in radians. The rotation is performed around the z-axis.
input | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents rotated spherical harmonic (SH) coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Overload List

public static void Scale(GraphicsStream, int, GraphicsStream, float);
public static void Scale(GraphicsStream, int, float[], float);
public static void Scale(float[], int, GraphicsStream, float);
public static void Scale(float[], int, float[], float);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(Single[],Int32,Single[],Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic .NET Public Shared Sub Scale( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal input() As Single, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
float[] output,
int order,
float[] input,
float scaleFactor
);
Managed C++ public: static void Scale(
float output __gc[],
int order,
float input __gc[],
float scaleFactor
);
JScript .NET public static function Scale(
output : float[],
order : int,
input : float[],
scaleFactor : float
);

Parameters

output | System.Single[]. An array of floating point values that represent spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input | System.Single[]. An array of floating point values that represents the spherical harmonic (SH) vector to scale.
scaleFactor | System.Single. The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(Single[],Int32,GraphicsStream,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic .NET Public Shared Sub Scale( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal input As GraphicsStream, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
float[] output,
int order,
GraphicsStream input,
float scaleFactor
);
Managed C++ public: static void Scale(
float output __gc[],
int order,
GraphicsStream *input,
float scaleFactor
);
JScript .NET public static function Scale(
output : float[],
order : int,
input : GraphicsStream,
scaleFactor : float
);

Parameters

output | System.Single[]. An array of floating point values that represent spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the spherical harmonic (SH) vector to scale.
scaleFactor | System.Single. The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(GraphicsStream,Int32,Single[],Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic .NET Public Shared Sub Scale( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal input() As Single, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
GraphicsStream output,
int order,
float[] input,
float scaleFactor
);
Managed C++ public: static void Scale(
GraphicsStream *output,
int order,
float input __gc[],
float scaleFactor
);
JScript .NET public static function Scale(
output : GraphicsStream,
order : int,
input : float[],
scaleFactor : float
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input | System.Single[]. An array of floating point values that represents the spherical harmonic (SH) vector to scale.
scaleFactor | System.Single. The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(GraphicsStream,Int32,GraphicsStream,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic .NET Public Shared Sub Scale( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal input As GraphicsStream, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
GraphicsStream output,
int order,
GraphicsStream input,
float scaleFactor
);
Managed C++ public: static void Scale(
GraphicsStream *output,
int order,
GraphicsStream *input,
float scaleFactor
);
JScript .NET public static function Scale(
output : GraphicsStream,
order : int,
input : GraphicsStream,
scaleFactor : float
);

Parameters

output | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order | System.Int32. Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input | Microsoft.DirectX.GraphicsStream. A GraphicsStream object that represents the spherical harmonic (SH) vector to scale.
scaleFactor | System.Single. The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.MaximumOrder

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.MaximumOrder Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum order for spherical harmonic (SH) evaluation.

Definition

Visual Basic .NET | Public Shared MaximumOrder As Int32
C# | public static Int32 MaximumOrder;
Managed C++ | public: static Int32 MaximumOrder;
JScript .NET | public static var MaximumOrder : Int32

Field Value

System.Int32 . Returns the maximum order for spherical harmonic (SH) evaluation; which is 6.

This field is read-only.

Remarks

The maximum order for spherical harmonic (SH) evaluation is 6 to maintain the mathematical complexity at a manageable level.


SphericalHarmonics.MinimumOrder

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonics.MinimumOrder Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum order for spherical harmonic (SH) evaluation.

Definition

Visual Basic .NET | Public Shared MinimumOrder As Int32
C# | public static Int32 MinimumOrder;
Managed C++ | public: static Int32 MinimumOrder;
JScript .NET | public static var MinimumOrder : Int32

Field Value

System.Int32 . Returns the minimum order for spherical harmonic (SH) evaluation, which is 2.

This field is read-only.

Remarks

The lowest minimum order for spherical harmonic (SH) evaluation is 2 because anything less than that would have no effect.


Microsoft.DirectX.Direct3D.Sprite

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite Class

Language:
Note: This documentation is preliminary and is subject to change.

Provides methods and properties that simplify the process of drawing sprites using Microsoft® Direct3D®.

Definition

Visual Basic .NET NotInheritable Public Class Sprite
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class Sprite : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class Sprite : public MarshalByRefObject,
IDisposable
JScript .NET public class Sprite extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Sprite object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally immediately prior to a device reset.
Reset | Occurs after the Sprite.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
Begin | Prepares a device for drawing sprites.
Dispose | Immediately releases the unmanaged resources used by the Sprite object.
Draw | Adds a sprite to the list of batched sprites.
Draw2D | Adds a sprite to the list of batched sprites.
End | Restores the device to the state it was in before Sprite.Begin was called.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Sprite object to free resources before it is destroyed by the garbage collector.
Flush | Forces all batched sprites to be submitted to the device.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Sprite.Disposing event when called from within a derived class.
raise_Lost | Raises a Sprite.Lost event when called from within a derived class.
raise_Reset | Raises a Sprite.Reset event when called from within a derived class.
SetWorldViewLH Sets the left-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.
SetWorldViewRH Sets the right-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.
Sprite | Initializes a new instance of the Sprite class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Sprite object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Direct3D device associated with a sprite object.
Disposed | Gets a value that indicates whether the object is disposed.
Transform | Retrieves or sets a Matrix object.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXSprite interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Sprite

Remarks

Typically, the application first calls Sprite.Begin, which allows control over the device render state, alpha blending, and sprite transformation and sorting. Then, for each sprite to display, the application calls Sprite.Draw, which can be called repeatedly to store any number of sprites. To display the batched sprites to the device, the application calls Sprite.End or Sprite.Flush.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Sprite.Begin(SpriteFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Begin Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Draw A Sprite

Prepares a device for drawing sprites.

Definition

Visual Basic .NET Public Sub Begin( _
ByVal flags As SpriteFlags _
)
C# public void Begin(
SpriteFlags flags
);
Managed C++ public: void Begin(
SpriteFlags flags
);
JScript .NET public function Begin(
flags : SpriteFlags
);

Parameters

flags Microsoft.DirectX.Direct3D.SpriteFlags. Combination of zero or more values from the SpriteFlags enumeration that describe sprite rendering options.

Remarks

This method must be called from inside of a Device.BeginScene . . . Device.EndScene pair. Sprite.Begin cannot be used as a substitute for either Device.BeginScene or RenderToSurface.BeginScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, device is assumed to be the rendering Device. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.End


Sprite.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Sprite object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Sprite.Disposed
  • Microsoft.DirectX.Direct3D.Sprite.Disposing


Sprite.Draw

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites.

Overload List

public void Draw(Texture, Rectangle, Vector3, Vector3, Color);
public void Draw(Texture, Rectangle, Vector3, Vector3, int);
public void Draw(Texture, Rectangle, Vector3, Vector3, int);
public void Draw(Texture, Vector3, Vector3, int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, device is assumed to be the rendering Device. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();


Sprite.Draw(Texture,Rectangle,Vector3,Vector3,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal center As Vector3, _
ByVal position As Vector3, _
ByVal color As Color _
)
C# public void Draw(
Texture srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
Color color
);
Managed C++ public: void Draw(
Texture *srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
Color color
);
JScript .NET public function Draw(
srcTexture : Texture,
srcRectangle : Rectangle,
center : Vector3,
position : Vector3,
color : Color
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
center | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the center of the sprite. A value of (0,0,0) indicates the upper-left corner.
position | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the position of the sprite. A value of (0,0,0) indicates the upper-left corner.
color | System.Drawing.Color. A Color Leave Site structure. The color and alpha channels are modulated by this value. The Color.Transparent Leave Site value maintains the original source color and alpha data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, device is assumed to be the rendering Device. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();


Sprite.Draw(Texture,Vector3,Vector3,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal srcTexture As Texture, _
ByVal center As Vector3, _
ByVal position As Vector3, _
ByVal color As Integer _
)
C# public void Draw(
Texture srcTexture,
Vector3 center,
Vector3 position,
int color
);
Managed C++ public: void Draw(
Texture *srcTexture,
Vector3 center,
Vector3 position,
int color
);
JScript .NET public function Draw(
srcTexture : Texture,
center : Vector3,
position : Vector3,
color : int
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
center | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the center of the sprite. A value of (0,0,0) indicates the upper-left corner.
position | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the position of the sprite. A value of (0,0,0) indicates the upper-left corner.
color | System.Int32. Color value represented as an integer. The color and alpha channels are modulated by this value. A value of 16777215 maintains the original source color and alpha data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, device is assumed to be the rendering Device. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();


Sprite.Draw(Texture,Rectangle,Vector3,Vector3,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal center As Vector3, _
ByVal position As Vector3, _
ByVal color As Integer _
)
C# public void Draw(
Texture srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
int color
);
Managed C++ public: void Draw(
Texture *srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
int color
);
JScript .NET public function Draw(
srcTexture : Texture,
srcRectangle : Rectangle,
center : Vector3,
position : Vector3,
color : int
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
center | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the center of the sprite. A value of (0,0,0) indicates the upper-left corner.
position | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the position of the sprite. A value of (0,0,0) indicates the upper-left corner.
color | System.Int32. Color value represented as an integer. The color and alpha channels are modulated by this value. A value of 16777215 maintains the original source color and alpha data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, device is assumed to be the rendering Device. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();


Sprite.Draw2D

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Overload List

public void Draw2D(Texture, Point, float, Point, Color);
public void Draw2D(Texture, Point, float, Point, int);
public void Draw2D(Texture, Rectangle, Rectangle, Point, Color);
public void Draw2D(Texture, Rectangle, Rectangle, Point, int);
public void Draw2D(Texture, Rectangle, Rectangle, Point, float, Point, Color);
public void Draw2D(Texture, Rectangle, Rectangle, Point, float, Point, int);
public void Draw2D(Texture, Rectangle, Rectangle, Point, float, Point, int);


Sprite.Draw2D(Texture,Point,Single,Point,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Color _
)
C# public void Draw2D(
Texture srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
Managed C++ public: void Draw2D(
Texture *srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
JScript .NET public function Draw2D(
srcTexture : Texture,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : Color
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
rotationCenter | System.Drawing.Point. A Point Leave Site object that represents the sprite's rotational center.
rotationAngle | System.Single. A floating point value that specifies the rotation angle around the rotational center of the sprite.
position | System.Drawing.Point. A Point Leave Site object that represents the position of the sprite in 2D-space.
color | System.Drawing.Color. A Color Leave Site


Sprite.Draw2D(Texture,Point,Single,Point,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
Managed C++ public: void Draw2D(
Texture *srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
JScript .NET public function Draw2D(
srcTexture : Texture,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : int
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
rotationCenter | System.Drawing.Point. A Point Leave Site object that represents the sprite's rotational center.
rotationAngle | System.Single. A floating point value that specifies the rotation angle around the rotational center of the sprite.
position | System.Drawing.Point. A Point Leave Site object that represents the position of the sprite in 2D-space.
color | System.Int32. Color value represented as an integer.


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Single,Point,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Color _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
Managed C++ public: void Draw2D(
Texture *srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
JScript .NET public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : Color
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the size of the destination rectangle.
rotationCenter | System.Drawing.Point. A Point Leave Site object that represents the sprite's rotational center.
rotationAngle | System.Single. A floating point value that specifies the rotation angle around the rotational center of the sprite.
position | System.Drawing.Point. A Point Leave Site object that represents the position of the sprite in 2D-space.
color | System.Drawing.Color. A Color Leave Site


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Single,Point,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
Managed C++ public: void Draw2D(
Texture *srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
JScript .NET public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : int
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the size of the destination rectangle.
rotationCenter | System.Drawing.Point. A Point Leave Site object that represents the sprite's rotational center.
rotationAngle | System.Single. A floating point value that specifies the rotation angle around the rotational center of the sprite.
position | System.Drawing.Point. A Point Leave Site object that represents the position of the sprite in 2D-space.
color | System.Int32. Color value represented as an integer.


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal position As Point, _
ByVal color As Color _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
Color color
);
Managed C++ public: void Draw2D(
Texture *srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
Color color
);
JScript .NET public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
position : Point,
color : Color
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the size of the destination rectangle.
position | System.Drawing.Point. A Point Leave Site object that represents the position of the sprite in 2D-space.
color | System.Drawing.Color. A Color Leave Site


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
int color
);
Managed C++ public: void Draw2D(
Texture *srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
int color
);
JScript .NET public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
position : Point,
color : int
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the size of the destination rectangle.
position | System.Drawing.Point. A Point Leave Site object that represents the position of the sprite in 2D-space.
color | System.Int32. Color value represented as an integer.


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Single,Point,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Draw2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a sprite to the list of batched sprites.

Definition

Visual Basic .NET Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal center As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point center,
float rotationAngle,
Point position,
int color
);
Managed C++ public: void Draw2D(
Texture *srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point center,
float rotationAngle,
Point position,
int color
);
JScript .NET public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
center : Point,
rotationAngle : float,
position : Point,
color : int
);

Parameters

srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the sprite texture.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that indicates the size of the destination rectangle.
center | System.Drawing.Point. A Vector3 structure that identifies the center of the sprite. A value of (0,0) indicates the upper-left corner.
rotationAngle | System.Single. A floating point value that specifies the rotation angle around the rotational center of the sprite.
position | System.Drawing.Point. A Point Leave Site object that represents the position of the sprite in 2D-space.
color | System.Int32. Color value represented as an integer.


Sprite.End()

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.End Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Draw A Sprite

Restores the device to the state it was in before Sprite.Begin was called.

Definition

Visual Basic .NET | Public Sub End()
C# | public void End();
Managed C++ | public: void End();
JScript .NET | public function End();

Remarks

Sprite.End cannot be used as a substitute for either Device.EndScene or RenderToSurface.EndScene.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, device is assumed to be the rendering Device. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Begin


Sprite.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Sprite.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Sprite object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Sprite();
Managed C++ | ~Sprite();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Sprite.Flush()

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Flush Method

 Language:
Note: This documentation is preliminary and is subject to change.

Forces all batched sprites to be submitted to the device.

Definition

Visual Basic .NET | Public Sub Flush()
C# | public void Flush();
Managed C++ | public: void Flush();
JScript .NET | public function Flush();

Remarks

Device states remain as they were after the last call to Sprite.Begin. The list of batched sprites is then cleared.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Sprite.End


Sprite.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Sprite.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXSprite, which allows unmanaged COM clients to create an instance of the managed Sprite class. Not supported.


Sprite.OnLostDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.OnLostDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic .NET | Public Sub OnLostDevice()
C# | public void OnLostDevice();
Managed C++ | public: void OnLostDevice();
JScript .NET | public function OnLostDevice();

Remarks

This method should be called whenever the device is lost. Before the object can be used again, the device must be reset and the Sprite.OnResetDevice method called.


Sprite.OnResetDevice()

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.OnResetDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic .NET | Public Sub OnResetDevice()
C# | public void OnResetDevice();
Managed C++ | public: void OnResetDevice();
JScript .NET | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Sprite.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Sprite.OnResetDevice should be called immediately after the device is reset.


Sprite.op_Equality(Sprite,Sprite)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Sprite, _
ByVal right As Sprite _
) As Boolean
C# public static bool op_Equality(
Sprite left,
Sprite right
);
Managed C++ public: static bool op_Equality(
Sprite *left,
Sprite *right
);
JScript .NET public static function op_Equality(
left : Sprite,
right : Sprite
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Sprite. The Sprite object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Sprite. The Sprite object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Sprite.op_Inequality(Sprite,Sprite)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Sprite, _
ByVal right As Sprite _
) As Boolean
C# public static bool op_Inequality(
Sprite left,
Sprite right
);
Managed C++ public: static bool op_Inequality(
Sprite *left,
Sprite *right
);
JScript .NET public static function op_Inequality(
left : Sprite,
right : Sprite
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Sprite. The Sprite object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Sprite. The Sprite object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Sprite.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Sprite.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Sprite.raise_Lost(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.raise_Lost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Sprite.Lost event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Lost(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Sprite.raise_Reset(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.raise_Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a Sprite.Reset event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Reset(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


Sprite.SetWorldViewLH(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.SetWorldViewLH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the left-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.

Definition

Visual Basic .NET Public Sub SetWorldViewLH( _
ByVal world As Matrix, _
ByVal view As Matrix _
)
C# public void SetWorldViewLH(
Matrix world,
Matrix view
);
Managed C++ public: void SetWorldViewLH(
Matrix world,
Matrix view
);
JScript .NET public function SetWorldViewLH(
world : Matrix,
view : Matrix
);

Parameters

world | Microsoft.DirectX.Matrix. A Matrix object that contains a world transform.
view | Microsoft.DirectX.Matrix. A Matrix object that contains a view transform.

Remarks

A call to this method (or to Sprite.SetWorldViewRH) is required if the sprite will be rendered with the Billboard, SortDepthFrontToBack, or SortDepthBackToFront flags parameter in Sprite.Begin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • 3-D Coordinate Systems


Sprite.SetWorldViewRH(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.SetWorldViewRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the right-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.

Definition

Visual Basic .NET Public Sub SetWorldViewRH( _
ByVal world As Matrix, _
ByVal view As Matrix _
)
C# public void SetWorldViewRH(
Matrix world,
Matrix view
);
Managed C++ public: void SetWorldViewRH(
Matrix world,
Matrix view
);
JScript .NET public function SetWorldViewRH(
world : Matrix,
view : Matrix
);

Parameters

world | Microsoft.DirectX.Matrix. A Matrix object that contains a world transform.
view | Microsoft.DirectX.Matrix. A Matrix object that contains a view transform.

Remarks

A call to this method (or to Sprite.SetWorldViewLH) is required if the sprite will be rendered with the Billboard, SortDepthFrontToBack, or SortDepthBackToFront flags parameter in Sprite.Begin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • 3-D Coordinate Systems


Sprite.Sprite

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Sprite Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Sprite class.

Overload List

public Sprite(Device);
public Sprite(ID3DXSprite);
public Sprite(IntPtr);


Sprite.Sprite(ID3DXSprite)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Sprite Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Sprite class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXSprite _
)
C# public Sprite(
ID3DXSprite pUnk
);
Managed C++ public: Sprite(
ID3DXSprite pUnk
);
JScript .NET public function Sprite(
pUnk : ID3DXSprite
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXSprite. Unmanaged Component Object Model (COM) ID3DXSprite interface pointer.


Sprite.Sprite(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Sprite Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Sprite class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Sprite(
IntPtr unmanagedObject
);
Managed C++ public: Sprite(
IntPtr unmanagedObject
);
JScript .NET public function Sprite(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXSprite interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Sprite.Sprite(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Sprite Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Sprite class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device _
)
C# public Sprite(
Device device
);
Managed C++ public: Sprite(
Device *device
);
JScript .NET public function Sprite(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device. Reference to an instance of a Device object.


Sprite.UpdateUnmanagedPointer(ID3DXSprite)

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Sprite object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXSprite _
)
C# public void UpdateUnmanagedPointer(
ID3DXSprite pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXSprite pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXSprite
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXSprite. Pointer to the ID3DXSprite structure used to update the unmanaged pointer for this Sprite object.


Sprite.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Microsoft® Direct3D® device associated with a sprite object.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . A Device reference that represents the Microsoft® Direct3D® device object associated with the sprite object.

This property is read-only.


Sprite.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Sprite.Transform

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Transform Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Matrix object.

Definition

Visual Basic .NET | Public Property Transform As Matrix
C# | public Matrix Transform { get; set; }
Managed C++ public: __property Matrix get_Transform();
public: __property void set_Transform(Matrix);
JScript .NET public function get Transform() : Matrix
public function set Transform(Matrix);

Property Value

Microsoft.DirectX.Matrix . A Matrix object used to transform a Sprite object.

This property is read/write.

Remarks

The following C# code fragment demonstrates the use of Transform.

              [C#]

using Microsoft.DirectX.Direct3D;

Sprite s = new Sprite(device);
Matrix m = new Matrix();

// Set Sprite.Transform
s.Transform = m;

// Retrieve the matrix
m = s.Transform;

Exceptions
Direct3DXException Occurs if the method fails.


Sprite.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXSprite interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXSprite
C# | public ID3DXSprite UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXSprite get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXSprite

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXSprite . Unmanaged ID3DXSprite interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Sprite.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Sprite object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Sprite.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Sprite object indicates whether that object has been disposed.


Sprite.Lost

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Lost Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when an object is lost, normally immediately prior to a device reset.

Definition

Visual Basic .NET | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
Managed C++ | public: __event EventHandler Lost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Sprite.Lost event, use the following C# code.

[C#]
sprite.Lost += new System.EventHandler(this.LostEventHandler);


Sprite.Reset

Microsoft DirectX 9.0 SDK Update (October 2004)

Sprite.Reset Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after the Sprite.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic .NET | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
Managed C++ | public: __event EventHandler Reset;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Sprite.OnResetDevice event, use the following C# code.

[C#]
sprite.Reset += new System.EventHandler(this.ResetEventHandler);


Microsoft.DirectX.Direct3D.StateBlock

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates render states.

Definition

Visual Basic .NET NotInheritable Public Class StateBlock
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class StateBlock : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class StateBlock : public MarshalByRefObject,
IDisposable
JScript .NET public class StateBlock extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the StateBlock object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Apply | Applies the state block to the current device state.
Capture | Captures a device's current state.
Dispose | Immediately releases the unmanaged resources used by the StateBlock object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the StateBlock object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.StateBlock.Disposing event when called from within a derived class.
StateBlock | Initializes a new instance of the StateBlock class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this StateBlock object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Device associated with a state block.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
StateBlock

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StateBlock.Apply()

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Apply Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Record and Apply StateBlocks

Applies the state block to the current device state.

Definition

Visual Basic .NET | Public Sub Apply()
C# | public void Apply();
Managed C++ | public: void Apply();
JScript .NET | public function Apply();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Record and Apply StateBlocks

This example demonstrates how to use state blocks to set and retrieve a device's state.

A StateBlock instance can be used to return a device to a default state. It also can be stored as a member of a class to quickly restore a desired rendering state for that class. A StateBlock is most useful when used to save default device state once a device is created. This allows for rapid restoration of default state when needed during rendering.

To record and apply a state block:

  1. Call Device.BeginStateBlock to begin recording device state.
  2. Tell the device the states and values to record.
  3. Call Device.EndStateBlock to stop recording device state and return a StateBlock instance containing the recorded states.
  4. Capture the device's current state by calling StateBlock.Capture using the previously obtained StateBlock instance.
  5. Do some processing that changes device state.
  6. Restore the device's saved states by calling StateBlock.Apply.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

// begin recording device state
device.BeginStateBlock();

// tell device the states and values to record
device.RenderState.FogStart = 0.3f;
device.RenderState.FogEnd = 100.0f;
device.RenderState.FogColor = Color.Gray;

// stop recording device state
StateBlock sb = device.EndStateBlock();

// save device states recorded above
sb.Capture;

// change device states
device.RenderState.FogStart = 2000.0f;
device.RenderState.FogEnd = 35000.0f;
device.RenderState.FogColor = Color.Yellow;

// render scene w/changed states
device.DrawPrimitives();

// restore device's saved states
sb.Apply();

// render scene w/saved states
device.DrawPrimitives();


StateBlock.Capture()

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Capture Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Record and Apply StateBlocks

Captures a device's current state.

Definition

Visual Basic .NET | Public Sub Capture()
C# | public void Capture();
Managed C++ | public: void Capture();
JScript .NET | public function Capture();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Record and Apply StateBlocks

This example demonstrates how to use state blocks to set and retrieve a device's state.

A StateBlock instance can be used to return a device to a default state. It also can be stored as a member of a class to quickly restore a desired rendering state for that class. A StateBlock is most useful when used to save default device state once a device is created. This allows for rapid restoration of default state when needed during rendering.

To record and apply a state block:

  1. Call Device.BeginStateBlock to begin recording device state.
  2. Tell the device the states and values to record.
  3. Call Device.EndStateBlock to stop recording device state and return a StateBlock instance containing the recorded states.
  4. Capture the device's current state by calling StateBlock.Capture using the previously obtained StateBlock instance.
  5. Do some processing that changes device state.
  6. Restore the device's saved states by calling StateBlock.Apply.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

// begin recording device state
device.BeginStateBlock();

// tell device the states and values to record
device.RenderState.FogStart = 0.3f;
device.RenderState.FogEnd = 100.0f;
device.RenderState.FogColor = Color.Gray;

// stop recording device state
StateBlock sb = device.EndStateBlock();

// save device states recorded above
sb.Capture;

// change device states
device.RenderState.FogStart = 2000.0f;
device.RenderState.FogEnd = 35000.0f;
device.RenderState.FogColor = Color.Yellow;

// render scene w/changed states
device.DrawPrimitives();

// restore device's saved states
sb.Apply();

// render scene w/saved states
device.DrawPrimitives();


StateBlock.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the StateBlock object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.StateBlock.Disposed
  • Microsoft.DirectX.Direct3D.StateBlock.Disposing


StateBlock.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


StateBlock.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the StateBlock object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~StateBlock();
Managed C++ | ~StateBlock();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


StateBlock.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


StateBlock.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DStateBlock9, which allows unmanaged COM clients to create an instance of the managed StateBlock class. Not supported.


StateBlock.op_Equality(StateBlock,StateBlock)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As StateBlock, _
ByVal right As StateBlock _
) As Boolean
C# public static bool op_Equality(
StateBlock left,
StateBlock right
);
Managed C++ public: static bool op_Equality(
StateBlock *left,
StateBlock *right
);
JScript .NET public static function op_Equality(
left : StateBlock,
right : StateBlock
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.StateBlock. The StateBlock object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.StateBlock. The StateBlock object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


StateBlock.op_Inequality(StateBlock,StateBlock)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As StateBlock, _
ByVal right As StateBlock _
) As Boolean
C# public static bool op_Inequality(
StateBlock left,
StateBlock right
);
Managed C++ public: static bool op_Inequality(
StateBlock *left,
StateBlock *right
);
JScript .NET public static function op_Inequality(
left : StateBlock,
right : StateBlock
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.StateBlock. The StateBlock object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.StateBlock. The StateBlock object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


StateBlock.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.StateBlock.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


StateBlock.StateBlock

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.StateBlock Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the StateBlock class.

Overload List

public StateBlock(Device, StateBlockType);
public StateBlock(IDirect3DStateBlock9);
public StateBlock(IDirect3DStateBlock9, Device);
public StateBlock(IntPtr);


StateBlock.StateBlock(IDirect3DStateBlock9)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.StateBlock Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the StateBlock class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DStateBlock9 _
)
C# public StateBlock(
IDirect3DStateBlock9 pUnk
);
Managed C++ public: StateBlock(
IDirect3DStateBlock9 pUnk
);
JScript .NET public function StateBlock(
pUnk : IDirect3DStateBlock9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9. Unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.


StateBlock.StateBlock(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.StateBlock Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the StateBlock class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public StateBlock(
IntPtr unmanagedObject
);
Managed C++ public: StateBlock(
IntPtr unmanagedObject
);
JScript .NET public function StateBlock(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


StateBlock.StateBlock(IDirect3DStateBlock9,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.StateBlock Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the StateBlock class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DStateBlock9, _
ByVal device As Device _
)
C# public StateBlock(
IDirect3DStateBlock9 lp,
Device device
);
Managed C++ public: StateBlock(
IDirect3DStateBlock9 lp,
Device *device
);
JScript .NET public function StateBlock(
lp : IDirect3DStateBlock9,
device : Device
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9. Unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. Reference to the Device associated with the current state block.


StateBlock.StateBlock(Device,StateBlockType)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.StateBlock Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the StateBlock class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal stateBlockType As StateBlockType _
)
C# public StateBlock(
Device device,
StateBlockType stateBlockType
);
Managed C++ public: StateBlock(
Device *device,
StateBlockType stateBlockType
);
JScript .NET public function StateBlock(
device : Device,
stateBlockType : StateBlockType
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to the Device associated with the current state block.
stateBlockType | Microsoft.DirectX.Direct3D.StateBlockType. Member of the StateBlockType enumeration that specifies the state block type.


StateBlock.UpdateUnmanagedPointer(IDirect3DStateBlock9)

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this StateBlock object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DStateBlock9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DStateBlock9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DStateBlock9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DStateBlock9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9. Pointer to the IDirect3DStateBlock9 structure used to update the unmanaged pointer for this StateBlock object.


StateBlock.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device associated with a state block.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object associated with the state block.

This property is read-only.


StateBlock.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


StateBlock.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DStateBlock9
C# | public IDirect3DStateBlock9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DStateBlock9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DStateBlock9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9 . Unmanaged IDirect3DStateBlock9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


StateBlock.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlock.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the StateBlock object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.StateBlock.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the StateBlock object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.Surface

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface Class

Language:
Note: This documentation is preliminary and is subject to change.

Queries and prepares surfaces.

Definition

Visual Basic .NET NotInheritable Public Class Surface
Inherits Resource
Implements IDisposable
C# public sealed class Surface : Resource,
IDisposable
Managed C++ public __gc __sealed class Surface : public Resource,
IDisposable
JScript .NET public class Surface extends Resource
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Surface object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Surface object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object. Inherited from Resource.
Finalize | Allows the Surface object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
static (Shared in Visual Basic .NET) FromBitmap | Creates a surface from a .NET bitmap object.
static (Shared in Visual Basic .NET) FromStream | Creates a surface from a Microsoft® .NET stream object.
GetContainer | Provides access to the parent cube texture or texture (mipmap) object.
GetGraphics | Retrieves a device context.
GetHashCode | Returns the hash code for the current instance. Inherited from Resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
LockRectangle | Locks a rectangle on a surface.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Surface.Disposing event when called from within a derived class.
ReleaseGraphics | Releases the device context obtained by calling Surface.GetGraphics.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Surface | Initializes a new instance of the Surface class.
UnlockRectangle | Unlocks a rectangle on a surface.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Surface object. This method supports the .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
Description | Retrieves the description of a surface.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DSurface9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
Surface

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Surface.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Surface object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Surface.Disposed
  • Microsoft.DirectX.Direct3D.Surface.Disposing


Surface.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Surface object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Surface();
Managed C++ | ~Surface();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Surface.FromBitmap(Device,Bitmap,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.FromBitmap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a surface from a Microsoft® .NET bitmap object.

Definition

Visual Basic .NET Public Shared Function FromBitmap( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal pool As Pool _
) As Surface
C# public static Surface FromBitmap(
Device device,
Bitmap image,
Pool pool
);
Managed C++ public: static Surface* FromBitmap(
Device *device,
Bitmap *image,
Pool pool
);
JScript .NET public static function FromBitmap(
device : Device,
image : Bitmap,
pool : Pool
) : Surface;

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to the Device associated with the surface.
image | System.Drawing.Bitmap. Reference to a Bitmap Leave Site object that contains the bitmap for the surface.
pool | Microsoft.DirectX.Direct3D.Pool. A Pool object that defines the memory class of the surface.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface object that represents the newly created surface.


Surface.FromStream(Device,Stream,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a surface from a Microsoft® .NET stream object.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal pool As Pool _
) As Surface
C# public static Surface FromStream(
Device device,
Stream data,
Pool pool
);
Managed C++ public: static Surface* FromStream(
Device *device,
Stream *data,
Pool pool
);
JScript .NET public static function FromStream(
device : Device,
data : Stream,
pool : Pool
) : Surface;

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to the Device associated with the surface.
data | System.IO.Stream. Reference to a Stream Leave Site object that contains image data for the surface.
pool | Microsoft.DirectX.Direct3D.Pool. A Pool object that defines the memory class of the surface.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface object that represents the newly created surface.


Surface.GetContainer(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetContainer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Provides access to the parent cube texture or texture (mipmap) object.

Definition

Visual Basic .NET Public Function GetContainer( _
ByVal interfaceId As Guid _
) As Object
C# public object GetContainer(
Guid interfaceId
);
Managed C++ public: Object* GetContainer(
Guid interfaceId
);
JScript .NET public function GetContainer(
interfaceId : Guid
) : Object;

Parameters

interfaceId System.Guid.

Return Value

System.Object . An Object Leave Site that represents the newly created container.

Remarks

This method provides access to the parent cube texture or texture mipmap object if the surface is a child level of a cube texture or mipmap. It also can provide access to the parent swap chain if the surface is a back buffer child.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • InterfaceGuid


Surface.GetGraphics()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetGraphics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a device context.

Definition

Visual Basic .NET | Public Function GetGraphics() As Graphics
C# | public Graphics GetGraphics();
Managed C++ | public: Graphics* GetGraphics();
JScript .NET | public function GetGraphics() : Graphics;

Return Value

System.Drawing.Graphics . A Graphics Leave Site object that represents the device context for the surface.

Remarks

The following restrictions apply.

  • The GetGraphics method is valid only on the following formats: Format.R5G6B5, Format.X1R5G5B5, Format.R8G8B8, and Format.X8R8G8B8. Formats that contain alpha are not supported because the Microsoft® Windows® Graphics Device Interface (GDI) implementations do not have a well-defined behavior on the alpha channel. For more information about formats, see Format.
  • Only one device context per surface can be returned at a time.
  • This method fails if the surface is already locked. It also fails if the surface is a member of a mipmap or cube map, and any other mipmap or cube map member is locked.
  • This method fails on render targets unless they were created as lockable (or, in the case of back buffers, with PresentFlag.LockableBackBuffer).
  • It fails on surfaces created with Pool.Default, unless they are Usage.Dynamic or are lockable render targets.
  • It fails on surfaces created with Pool.Scratch.

When a device context is outstanding on a surface, the application cannot call the following methods.

  • CubeTexture.LockRectangle
  • Device.ColorFill
  • Device.StretchRectangle
  • Device.UpdateSurface
  • Device.UpdateTexture
  • Surface.LockRectangle
  • SwapChain.Present (on a swap chain that contains the surface)
  • Texture.LockRectangle

The GetGraphics method causes an implicit lock; do not retain the device context for later use. Call Surface.ReleaseGraphics to release it.

It is valid to call Surface.GetGraphics and Surface.ReleaseGraphics on levels of a mipmap or cube map; however, these calls are slow to all mip levels except the topmost level, and GDI operations to these mip levels are not accelerated.

The Graphics Leave Site object provides access to Microsoft Win32® and GDI functionality.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.ReleaseGraphics
  • Pool
  • Usage


Surface.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DSurface9, which allows unmanaged COM clients to create an instance of the managed Surface class. Not supported.


Surface.LockRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Overload List

public GraphicsStream LockRectangle(LockFlags);
public GraphicsStream LockRectangle(LockFlags, out int);
public GraphicsStream LockRectangle(Rectangle, LockFlags);
public GraphicsStream LockRectangle(Rectangle, LockFlags, out int);
public Array LockRectangle(Type, LockFlags, out int, int[]);
public Array LockRectangle(Type, LockFlags, int[]);
public Array LockRectangle(Type, Rectangle, LockFlags, out int, int[]);
public Array LockRectangle(Type, Rectangle, LockFlags, int[]);

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Rectangle,LockFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
Rectangle rect,
LockFlags flags,
out int pitch
);
Managed C++ public: GraphicsStream* LockRectangle(
Rectangle rect,
LockFlags flags,
int *pitch
);
JScript .NET public function LockRectangle(
rect : Rectangle,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

rect | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the rectangle to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.
pitch | System.Int32. Integer that represents the returned pitch value of the locked region.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(LockFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
LockFlags flags,
out int pitch
);
Managed C++ public: GraphicsStream* LockRectangle(
LockFlags flags,
int *pitch
);
JScript .NET public function LockRectangle(
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

flags | Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.
pitch | System.Int32. Integer that represents the returned pitch value of the locked region.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Rectangle,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal rect As Rectangle, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
Rectangle rect,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockRectangle(
Rectangle rect,
LockFlags flags
);
JScript .NET public function LockRectangle(
rect : Rectangle,
flags : LockFlags
) : GraphicsStream;

Parameters

rect | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the rectangle to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockRectangle(
LockFlags flags
);
JScript .NET public function LockRectangle(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,Rectangle,LockFlags,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
Rectangle rect,
LockFlags flags,
out int pitch,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
Rectangle rect,
LockFlags flags,
int *pitch,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
rect : Rectangle,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that specifies the type of array to create.
rect | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the rectangle to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.
pitch | System.Int32. Integer that represents the returned pitch value of the locked region.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,LockFlags,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
LockFlags flags,
out int pitch,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
LockFlags flags,
int *pitch,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that specifies the type of array to create.
flags | Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.
pitch | System.Int32. Integer that represents the returned pitch value of the locked region.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,Rectangle,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
Rectangle rect,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
Rectangle rect,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
rect : Rectangle,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that specifies the type of array to create.
rect | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the rectangle to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a surface.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that specifies the type of array to create.
flags | Microsoft.DirectX.Direct3D.LockFlags. A LockFlags object that specifies the type of lock to apply.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Surface.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Surface.ReleaseGraphics()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ReleaseGraphics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases the device context obtained by calling Surface.GetGraphics.

Definition

Visual Basic .NET | Public Sub ReleaseGraphics()
C# | public void ReleaseGraphics();
Managed C++ | public: void ReleaseGraphics();
JScript .NET | public function ReleaseGraphics();

Remarks

A device context is a Microsoft® Windows® resource and must be released after use so the operating system can return it to the pool of available resources.

This method releases only the device context returned by Surface.GetGraphics, otherwise the method fails.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.GetGraphics


Surface.Surface

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Surface class.

Overload List

public Surface(Device, Bitmap, Pool);
public Surface(Device, Stream, Pool);
public Surface(IDirect3DSurface9);
public Surface(IDirect3DSurface9, object);
public Surface(IntPtr);


Surface.Surface(IDirect3DSurface9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Surface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As IDirect3DSurface9 _
)
C# public Surface(
IDirect3DSurface9 pInterop
);
Managed C++ public: Surface(
IDirect3DSurface9 pInterop
);
JScript .NET public function Surface(
pInterop : IDirect3DSurface9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9. Unmanaged Component Object Model (COM) IDirect3DSurface9 interface pointer.


Surface.Surface(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Surface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Surface(
IntPtr unmanagedObject
);
Managed C++ public: Surface(
IntPtr unmanagedObject
);
JScript .NET public function Surface(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DSurface9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Surface.Surface(IDirect3DSurface9,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Surface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DSurface9, _
ByVal device As Object _
)
C# public Surface(
IDirect3DSurface9 lp,
object device
);
Managed C++ public: Surface(
IDirect3DSurface9 lp,
Object *device
);
JScript .NET public function Surface(
lp : IDirect3DSurface9,
device : Object
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9. Unmanaged Component Object Model (COM) IDirect3DSurface9 interface pointer.
device | System.Object. Object reference of the device associated with the surface.


Surface.Surface(Device,Stream,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Surface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal pool As Pool _
)
C# public Surface(
Device device,
Stream data,
Pool pool
);
Managed C++ public: Surface(
Device *device,
Stream *data,
Pool pool
);
JScript .NET public function Surface(
device : Device,
data : Stream,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to the Device associated with the surface.
data | System.IO.Stream. Reference to a Stream Leave Site object that contains image data for the surface.
pool | Microsoft.DirectX.Direct3D.Pool. A Pool object that defines the memory class of the surface.


Surface.Surface(Device,Bitmap,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Surface class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal pool As Pool _
)
C# public Surface(
Device device,
Bitmap image,
Pool pool
);
Managed C++ public: Surface(
Device *device,
Bitmap *image,
Pool pool
);
JScript .NET public function Surface(
device : Device,
image : Bitmap,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to the Device associated with the surface.
image | System.Drawing.Bitmap. Reference to a Bitmap Leave Site object that contains the bitmap for the surface.
pool | Microsoft.DirectX.Direct3D.Pool. A Pool object that defines the memory class of the surface.


Surface.UnlockRectangle()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UnlockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks a rectangle on a surface.

Definition

Visual Basic .NET | Public Sub UnlockRectangle()
C# | public void UnlockRectangle();
Managed C++ | public: void UnlockRectangle();
JScript .NET | public function UnlockRectangle();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Surface.UpdateUnmanagedPointer(IDirect3DSurface9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Surface object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DSurface9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DSurface9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DSurface9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DSurface9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9. Pointer to the IDirect3DSurface9 structure used to update the unmanaged pointer for this Surface object.


Surface.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the description of a surface.

Definition

Visual Basic .NET | Public ReadOnly Property Description As SurfaceDescription
C# | public SurfaceDescription Description { get; }
Managed C++ | public: __property SurfaceDescription get_Description();
JScript .NET | public function get Description() : SurfaceDescription

Property Value

Microsoft.DirectX.Direct3D.SurfaceDescription . A SurfaceDescription object that contains the surface description.

This property is read-only.


Surface.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Surface.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DSurface9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DSurface9
C# | public IDirect3DSurface9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DSurface9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DSurface9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9 . Unmanaged IDirect3DSurface9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Surface.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Surface object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Surface.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Surface object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.SurfaceLoader

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader Class

Language:
Note: This documentation is preliminary and is subject to change.

Loads and saves surfaces.

Definition

Visual Basic .NET NotInheritable Public Class SurfaceLoader
Inherits Object
C# | public sealed class SurfaceLoader : Object
Managed C++ | public __gc __sealed class SurfaceLoader : public Object
JScript .NET | public class SurfaceLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) FromFile | Loads a surface from a file.
static (Shared in Visual Basic .NET) FromStream | Loads a surface from a stream.
static (Shared in Visual Basic .NET) FromSurface | Loads a surface from another surface with color conversion.
static (Shared in Visual Basic .NET) Save | Saves a surface to a file.
static (Shared in Visual Basic .NET) SaveToStream | Saves a surface to a stream.

Inheritance Hierarchy

Object Leave Site
SurfaceLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceLoader.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Overload List

public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Filter, int);
public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Filter, int, ref ImageInformation);
public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Rectangle, Filter, int);
public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Rectangle, Filter, int, ref ImageInformation);
public static void FromFile(Surface, out PaletteEntry, string, Filter, int);
public static void FromFile(Surface, out PaletteEntry, string, Filter, int, ref ImageInformation);
public static void FromFile(Surface, out PaletteEntry, string, Rectangle, Filter, int);
public static void FromFile(Surface, out PaletteEntry, string, Rectangle, Filter, int, ref ImageInformation);
public static void FromFile(Surface, Rectangle, string, Rectangle, Filter, int);
public static void FromFile(Surface, Rectangle, string, Rectangle, Filter, int, ref ImageInformation);
public static void FromFile(Surface, string, Filter, int);
public static void FromFile(Surface, string, Filter, int, ref ImageInformation);
public static void FromFile(Surface, string, Rectangle, Filter, int);
public static void FromFile(Surface, string, Rectangle, Filter, int, ref ImageInformation);

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,Rectangle,String,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Surface *destSurface,
Rectangle destRectangle,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destSurface : Surface,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,Rectangle,String,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Surface *destSurface,
Rectangle destRectangle,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destSurface : Surface,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Surface *destSurface,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destSurface : Surface,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Surface *destSurface,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destSurface : Surface,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Surface *destSurface,
String *srcFile,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destSurface : Surface,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcFile | System.String. String that contains the source file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Surface *destSurface,
String *srcFile,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destSurface : Surface,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcFile | System.String. String that contains the source file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
String *srcFile,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcFile | System.String. String that contains the source file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
String *srcFile,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcFile | System.String. String that contains the source file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
String *srcFile,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcFile | System.String. String that contains the source file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
String *srcFile,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcFile | System.String. String that contains the source file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
String *srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcFile | System.String. String that contains the source file name.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Overload List

public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Rectangle, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, Rectangle, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Rectangle, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, Rectangle, Stream, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, Filter, int);
public static void FromStream(Surface, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, int, Filter, int);
public static void FromStream(Surface, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, Stream, Rectangle, Filter, int, ref ImageInformation);

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Rectangle destRectangle,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Rectangle destRectangle,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Int32,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Rectangle destRectangle,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Int32,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Rectangle destRectangle,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
int readBytes,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
Stream *stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
int readBytes,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Rectangle,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a surface from a stream.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Stream *stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
stream | System.IO.Stream. A Stream Leave Site object that contains the source surface data.
readBytes | System.Int32. Size, in bytes, of the stream data in memory.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromSurface

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Overload List

public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, Rectangle, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, Rectangle, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, Rectangle, Filter, int);
public static void FromSurface(Surface, Surface, Filter, int);
public static void FromSurface(Surface, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, Surface, Rectangle, Filter, int);

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Rectangle destRectangle,
Surface *srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Surface *srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Rectangle destRectangle,
Surface *srcSurface,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Surface *srcSurface,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Surface *srcSurface,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Rectangle destRectangle,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,PaletteEntry,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Surface *srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Surface *srcSurface,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,PaletteEntry,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
Rectangle destRectangle,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,PaletteEntry,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Surface *srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,PaletteEntry,Rectangle,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.FromSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic .NET Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
Managed C++ public: static void FromSurface(
Surface *destSurface,
PaletteEntry *destPalette,
Rectangle destRectangle,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript .NET public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the destination surface.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the destination palette entries.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the destination rectangle.
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.
filter | Microsoft.DirectX.Direct3D.Filter. One or more members of the Filter enumeration that control how the image is filtered.
colorKey | System.Int32. Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.Save

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Overload List

public static void Save(string, ImageFileFormat, Surface);
public static void Save(string, ImageFileFormat, Surface, out PaletteEntry);
public static void Save(string, ImageFileFormat, Surface, out PaletteEntry, Rectangle);
public static void Save(string, ImageFileFormat, Surface, Rectangle);

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Surface *srcSurface
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface
);

Parameters

destFile | System.String. String that contains the destination file name.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Surface *srcSurface,
PaletteEntry *sourcePalette
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry
);

Parameters

destFile | System.String. String that contains the destination file name.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface,Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface,
Rectangle srcRectangle
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Surface *srcSurface,
Rectangle srcRectangle
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface,
srcRectangle : Rectangle
);

Parameters

destFile | System.String. String that contains the destination file name.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface,PaletteEntry,Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Rectangle srcRectangle
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle
);

Parameters

destFile | System.String. String that contains the destination file name.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.SaveToStream

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a surface to a stream.

Overload List

public static GraphicsStream SaveToStream(ImageFileFormat, Surface);
public static GraphicsStream SaveToStream(ImageFileFormat, Surface, out PaletteEntry);
public static GraphicsStream SaveToStream(ImageFileFormat, Surface, out PaletteEntry, Rectangle);
public static GraphicsStream SaveToStream(ImageFileFormat, Surface, Rectangle);

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a surface to a stream.

Definition

Visual Basic .NET Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface
);
Managed C++ public: static GraphicsStream* SaveToStream(
ImageFileFormat destFormat,
Surface *srcSurface
);
JScript .NET public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface
) : GraphicsStream;

Parameters

destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a surface to a stream.

Definition

Visual Basic .NET Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette
);
Managed C++ public: static GraphicsStream* SaveToStream(
ImageFileFormat destFormat,
Surface *srcSurface,
PaletteEntry *sourcePalette
);
JScript .NET public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry
) : GraphicsStream;

Parameters

destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface,Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a surface to a stream.

Definition

Visual Basic .NET Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface,
Rectangle srcRectangle
);
Managed C++ public: static GraphicsStream* SaveToStream(
ImageFileFormat destFormat,
Surface *srcSurface,
Rectangle srcRectangle
);
JScript .NET public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface,
srcRectangle : Rectangle
) : GraphicsStream;

Parameters

destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface,PaletteEntry,Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a surface to a stream.

Definition

Visual Basic .NET Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle
);
Managed C++ public: static GraphicsStream* SaveToStream(
ImageFileFormat destFormat,
Surface *srcSurface,
PaletteEntry *sourcePalette,
Rectangle srcRectangle
);
JScript .NET public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle
) : GraphicsStream;

Parameters

destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface | Microsoft.DirectX.Direct3D.Surface. A Surface object that represents the source surface to save to a file.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry array that contains the source palette entries.
srcRectangle | System.Drawing.Rectangle. A Rectangle Leave Site object that represents the source rectangle.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Microsoft.DirectX.Direct3D.SwapChain

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create an Additional Swap Chain

Manipulates a swap chain.

Definition

Visual Basic .NET NotInheritable Public Class SwapChain
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class SwapChain : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class SwapChain : public MarshalByRefObject,
IDisposable
JScript .NET public class SwapChain extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SwapChain object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the SwapChain object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SwapChain object to free resources before it is destroyed by the garbage collector.
GetBackBuffer | Retrieves a back buffer from the swap chain of a device.
GetFrontBufferData | Generates a copy of the swap chain's front buffer and places it in a Surface object provided by the application.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Present | Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.SwapChain.Disposing event when called from within a derived class.
SwapChain | Creates a new instance of the SwapChain class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this SwapChain object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the device associated with a swap chain.
DisplayMode | Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.
Disposed | Gets a value that indicates whether the object is disposed.
PresentParameters | Retrieves the presentation parameters associated with a swap chain.
RasterStatus | Returns information that describes the raster of the monitor on which the swap chain is presented.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
SwapChain

Remarks

Each device always has at least one swap chain, which is known as the implicit swap chain. Additional SwapChain objects can be created for rendering multiple views from the same device.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SwapChain.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the SwapChain object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.SwapChain.Disposed
  • Microsoft.DirectX.Direct3D.SwapChain.Disposing


SwapChain.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


SwapChain.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the SwapChain object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~SwapChain();
Managed C++ | ~SwapChain();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


SwapChain.GetBackBuffer(Int32,BackBufferType)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.GetBackBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a back buffer from the swap chain of a device.

Definition

Visual Basic .NET Public Function GetBackBuffer( _
ByVal backBuffer As Integer, _
ByVal typeBuffer As BackBufferType _
) As Surface
C# public Surface GetBackBuffer(
int backBuffer,
BackBufferType typeBuffer
);
Managed C++ public: Surface* GetBackBuffer(
int backBuffer,
BackBufferType typeBuffer
);
JScript .NET public function GetBackBuffer(
backBuffer : int,
typeBuffer : BackBufferType
) : Surface;

Parameters

backBuffer | System.Int32. Index of the back buffer object to return. See Remarks.
typeBuffer | Microsoft.DirectX.Direct3D.BackBufferType. Because stereo view is not supported in Microsoft® DirectX® 9.0, the only valid value for this parameter is Mono.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface object that represents the returned back buffer surface.

Remarks

Back buffers are numbered from 0 to the total number of back buffers - 1. A value of 0 returns the first back buffer, not the front buffer. The front buffer is not accessible through this method.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SwapChain.GetFrontBufferData(Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.GetFrontBufferData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates a copy of the swap chain's front buffer and places it in a Surface object provided by the application.

Definition

Visual Basic .NET Public Sub GetFrontBufferData( _
ByVal frontBuffer As Surface _
)
C# public void GetFrontBufferData(
Surface frontBuffer
);
Managed C++ public: void GetFrontBufferData(
Surface *frontBuffer
);
JScript .NET public function GetFrontBufferData(
frontBuffer : Surface
);

Parameters

frontBuffer Microsoft.DirectX.Direct3D.Surface. [in, out] A Surface object that receives a copy of the swap chain's front buffer. The data is returned in successive rows with no intervening space, from the vertically highest row to the lowest.

Remarks

For windowed mode, the size of the destination surface should be the size of the desktop. For full-screen mode, the size of the destination surface should be the screen size.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SwapChain.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


SwapChain.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DSwapChain9, which allows unmanaged COM clients to create an instance of the managed SwapChain class. Not supported.


SwapChain.op_Equality(SwapChain,SwapChain)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As SwapChain, _
ByVal right As SwapChain _
) As Boolean
C# public static bool op_Equality(
SwapChain left,
SwapChain right
);
Managed C++ public: static bool op_Equality(
SwapChain *left,
SwapChain *right
);
JScript .NET public static function op_Equality(
left : SwapChain,
right : SwapChain
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.SwapChain. The SwapChain object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.SwapChain. The SwapChain object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


SwapChain.op_Inequality(SwapChain,SwapChain)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As SwapChain, _
ByVal right As SwapChain _
) As Boolean
C# public static bool op_Inequality(
SwapChain left,
SwapChain right
);
Managed C++ public: static bool op_Inequality(
SwapChain *left,
SwapChain *right
);
JScript .NET public static function op_Inequality(
left : SwapChain,
right : SwapChain
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.SwapChain. The SwapChain object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.SwapChain. The SwapChain object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


SwapChain.Present

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Overload List

public void Present();
public void Present(Control);
public void Present(Control, Present);
public void Present(IntPtr);
public void Present(IntPtr, Present);
public void Present(Present);
public void Present(Rectangle, bool);
public void Present(Rectangle, Control, bool);
public void Present(Rectangle, Control, Present, bool);
public void Present(Rectangle, IntPtr, bool);
public void Present(Rectangle, IntPtr, Present, bool);
public void Present(Rectangle, Present, bool);
public void Present(Rectangle, Rectangle, Control);
public void Present(Rectangle, Rectangle, Control, Present);
public void Present(Rectangle, Rectangle, IntPtr);
public void Present(Rectangle, Rectangle, IntPtr, Present);

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,IntPtr,Present,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal flags As Present, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
Present flags,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
Present flags,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
overrideWindowHandle : IntPtr,
flags : Present,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindowHandle | System.IntPtr. Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags | Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(IntPtr,Present)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal overrideWindowHandle As IntPtr, _
ByVal flags As Present _
)
C# public void Present(
IntPtr overrideWindowHandle,
Present flags
);
Managed C++ public: void Present(
IntPtr overrideWindowHandle,
Present flags
);
JScript .NET public function Present(
overrideWindowHandle : IntPtr,
flags : Present
);

Parameters

overrideWindowHandle | System.IntPtr. Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags | Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,IntPtr,Present)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal flags As Present _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle,
Present flags
);
Managed C++ public: void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle,
Present flags
);
JScript .NET public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindowHandle : IntPtr,
flags : Present
);

Parameters

sourceRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindowHandle | System.IntPtr. Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags | Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,IntPtr,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
overrideWindowHandle : IntPtr,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindowHandle | System.IntPtr. Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
IntPtr overrideWindowHandle
);
Managed C++ public: void Present(
IntPtr overrideWindowHandle
);
JScript .NET public function Present(
overrideWindowHandle : IntPtr
);

Parameters

overrideWindowHandle System.IntPtr. Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
Managed C++ public: void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
JScript .NET public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindowHandle : IntPtr
);

Parameters

sourceRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindowHandle | System.IntPtr. Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Present,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal flags As Present, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Present flags,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
Present flags,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
flags : Present,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
flags | Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Control,Present,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindow As Control, _
ByVal flags As Present, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Control overrideWindow,
Present flags,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
Control *overrideWindow,
Present flags,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
overrideWindow : Control,
flags : Present,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindow | System.Windows.Forms.Control. A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags | Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Control,Present)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal overrideWindow As Control, _
ByVal flags As Present _
)
C# public void Present(
Control overrideWindow,
Present flags
);
Managed C++ public: void Present(
Control *overrideWindow,
Present flags
);
JScript .NET public function Present(
overrideWindow : Control,
flags : Present
);

Parameters

overrideWindow | System.Windows.Forms.Control. A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags | Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Present)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal flags As Present _
)
C# public void Present(
Present flags
);
Managed C++ public: void Present(
Present flags
);
JScript .NET public function Present(
flags : Present
);

Parameters

flags Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,Control,Present)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindow As Control, _
ByVal flags As Present _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control overrideWindow,
Present flags
);
Managed C++ public: void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control *overrideWindow,
Present flags
);
JScript .NET public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindow : Control,
flags : Present
);

Parameters

sourceRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindow | System.Windows.Forms.Control. A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags | Microsoft.DirectX.Direct3D.Present. Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Control,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindow As Control, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Control overrideWindow,
bool sourceRectangle
);
Managed C++ public: void Present(
Rectangle rectPresent,
Control *overrideWindow,
bool sourceRectangle
);
JScript .NET public function Present(
rectPresent : Rectangle,
overrideWindow : Control,
sourceRectangle : boolean
);

Parameters

rectPresent | System.Drawing.Rectangle. A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindow | System.Windows.Forms.Control. A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
sourceRectangle | System.Boolean. Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Control)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal overrideWindow As Control _
)
C# public void Present(
Control overrideWindow
);
Managed C++ public: void Present(
Control *overrideWindow
);
JScript .NET public function Present(
overrideWindow : Control
);

Parameters

overrideWindow System.Windows.Forms.Control. A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present()

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET | Public Sub Present()
C# | public void Present();
Managed C++ | public: void Present();
JScript .NET | public function Present();

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,Control)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Present Method

 Language:
Note: This documentation is preliminary and is subject to change.

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic .NET Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindow As Control _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control overrideWindow
);
Managed C++ public: void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control *overrideWindow
);
JScript .NET public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindow : Control
);

Parameters

sourceRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle | System.Drawing.Rectangle. A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindow | System.Windows.Forms.Control. A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.SwapChain.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


SwapChain.SwapChain

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.SwapChain Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Overload List

public SwapChain(Device, PresentParameters);
public SwapChain(IDirect3DSwapChain9);
public SwapChain(IDirect3DSwapChain9, Device);
public SwapChain(IntPtr);

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft® Direct3D® sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX® 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(IDirect3DSwapChain9)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.SwapChain Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DSwapChain9 _
)
C# public SwapChain(
IDirect3DSwapChain9 pUnk
);
Managed C++ public: SwapChain(
IDirect3DSwapChain9 pUnk
);
JScript .NET public function SwapChain(
pUnk : IDirect3DSwapChain9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9. Unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft® Direct3D® sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX® 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.SwapChain Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public SwapChain(
IntPtr unmanagedObject
);
Managed C++ public: SwapChain(
IntPtr unmanagedObject
);
JScript .NET public function SwapChain(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft® Direct3D® sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX® 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(IDirect3DSwapChain9,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.SwapChain Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DSwapChain9, _
ByVal device As Device _
)
C# public SwapChain(
IDirect3DSwapChain9 lp,
Device device
);
Managed C++ public: SwapChain(
IDirect3DSwapChain9 lp,
Device *device
);
JScript .NET public function SwapChain(
lp : IDirect3DSwapChain9,
device : Device
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9. Unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. The Device object that represents the device to associate with the swap chain.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft® Direct3D® sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX® 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(Device,PresentParameters)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.SwapChain Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal presentationParameters As PresentParameters _
)
C# public SwapChain(
Device device,
PresentParameters presentationParameters
);
Managed C++ public: SwapChain(
Device *device,
PresentParameters *presentationParameters
);
JScript .NET public function SwapChain(
device : Device,
presentationParameters : PresentParameters
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device object that represents the device to associate with the swap chain.
presentationParameters | Microsoft.DirectX.Direct3D.PresentParameters. A PresentParameters object that contains the presentation parameters for the new swap chain. See Remarks.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft® Direct3D® sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX® 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.UpdateUnmanagedPointer(IDirect3DSwapChain9)

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this SwapChain object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DSwapChain9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DSwapChain9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DSwapChain9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DSwapChain9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9. Pointer to the IDirect3DSwapChain9 structure used to update the unmanaged pointer for this SwapChain object.


SwapChain.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the device associated with a swap chain.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . The Device object associated with the swap chain.

This property is read-only.


SwapChain.DisplayMode

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.DisplayMode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.

Definition

Visual Basic .NET | Public ReadOnly Property DisplayMode As DisplayMode
C# | public DisplayMode DisplayMode { get; }
Managed C++ | public: __property DisplayMode get_DisplayMode();
JScript .NET | public function get DisplayMode() : DisplayMode

Property Value

Microsoft.DirectX.Direct3D.DisplayMode . A DisplayMode structure that contains data about the display mode of the adapter. This is different than the display mode of the device, which might not be active if the device does not own full-screen mode.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SwapChain.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


SwapChain.PresentParameters

SwapChain.PresentParameters Property

Note: This documentation is preliminary and is subject to change.

Retrieves the presentation parameters associated with a swap chain.

Definition

Visual Basic .NET | Public ReadOnly Property PresentParameters As PresentParameters
C# | public PresentParameters PresentParameters { get; }
Managed C++ | public: __property PresentParameters* get_PresentParameters();
JScript .NET | public function get PresentParameters() : PresentParameters

Property Value

Microsoft.DirectX.Direct3D.PresentParameters . Presentation parameters. For more information, see PresentParameters.

This property is read-only.

Remarks

This method can be used to view the presentation parameters of the parent swap chain of a surface (a back buffer, for instance). The parent swap chain can be retrieved with Surface.GetContainer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SwapChain.RasterStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.RasterStatus Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns information that describes the raster of the monitor on which the swap chain is presented.

Definition

Visual Basic .NET | Public ReadOnly Property RasterStatus As RasterStatus
C# | public RasterStatus RasterStatus { get; }
Managed C++ | public: __property RasterStatus get_RasterStatus();
JScript .NET | public function get RasterStatus() : RasterStatus

Property Value

Microsoft.DirectX.Direct3D.RasterStatus . A RasterStatus structure that contains information about the position or other status of the raster on the monitor driven by the current adapter.

This property is read-only.

Remarks

This method does not return device state for a device created using PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException Occurs if ret_RasterStatus_get is invalid or if the device does not support reading the current scan line. To determine whether the device supports reading the scan line, check the Caps.DriverCaps.ReadScanLine property. It should be set to true.


SwapChain.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DSwapChain9
C# | public IDirect3DSwapChain9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DSwapChain9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DSwapChain9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9 . Unmanaged IDirect3DSwapChain9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


SwapChain.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapChain.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the SwapChain object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.SwapChain.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SwapChain object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.Texture

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates a texture resource.

Definition

Visual Basic .NET NotInheritable Public Class Texture
Inherits BaseTexture
Implements IDisposable
C# public sealed class Texture : BaseTexture,
IDisposable
Managed C++ public __gc __sealed class Texture : public BaseTexture,
IDisposable
JScript .NET public class Texture extends BaseTexture
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Texture object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDirtyRectangle | Adds a dirty region to a texture resource.
Dispose | Immediately releases the unmanaged resources used by the Texture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Texture object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
static (Shared in Visual Basic .NET) FromBitmap | Creates a texture resource from a bitmap.
static (Shared in Visual Basic .NET) FromStream | Creates a texture resource from a stream object.
GenerateMipSubLevels | Generates mipmap sublevels. Inherited from BaseTexture.
GetHashCode | Returns the hash code for the current instance.
GetLevelDescription | Retrieves a level description of a texture resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
GetSurfaceLevel | Retrieves the specified texture surface level.
LockRectangle | Locks a rectangle on a texture resource.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseTexture.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseTexture.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Texture.Disposing event when called from within a derived class.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Texture | Creates a new instance of the Texture class.
UnlockRectangle | Unlocks a rectangle on a texture resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Texture object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseTexture.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels. Inherited from BaseTexture.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
LevelCount | Retrieves the number of texture levels in a multilevel texture. Inherited from BaseTexture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer. Inherited from BaseTexture.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
Texture

Remarks

This object inherits additional functionality from the BaseTexture object.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Texture.AddDirtyRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.AddDirtyRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a texture resource.

Overload List

public void AddDirtyRectangle();
public void AddDirtyRectangle(Rectangle);

Remarks

Omitting the param_Rectangle_rect parameter expands the dirty region to cover the entire texture.

For performance reasons, dirty regions are recorded only for level zero of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box also is dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Texture.AddDirtyRectangle()

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.AddDirtyRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a texture resource.

Definition

Visual Basic .NET | Public Sub AddDirtyRectangle()
C# | public void AddDirtyRectangle();
Managed C++ | public: void AddDirtyRectangle();
JScript .NET | public function AddDirtyRectangle();

Remarks

Omitting the param_Rectangle_rect parameter expands the dirty region to cover the entire texture.

For performance reasons, dirty regions are recorded only for level zero of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box also is dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Texture.AddDirtyRectangle(Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.AddDirtyRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a texture resource.

Definition

Visual Basic .NET Public Sub AddDirtyRectangle( _
ByVal rect As Rectangle _
)
C# public void AddDirtyRectangle(
Rectangle rect
);
Managed C++ public: void AddDirtyRectangle(
Rectangle rect
);
JScript .NET public function AddDirtyRectangle(
rect : Rectangle
);

Parameters

rect System.Drawing.Rectangle. A Rectangle Leave Site structure that specifies the dirty region to add.

Remarks

Omitting the param_Rectangle_rect parameter expands the dirty region to cover the entire texture.

For performance reasons, dirty regions are recorded only for level zero of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box also is dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Texture.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Texture object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Texture.Disposed
  • Microsoft.DirectX.Direct3D.Texture.Disposing


Texture.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Texture.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Texture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Texture();
Managed C++ | ~Texture();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Texture.FromBitmap(Device,Bitmap,Usage,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.FromBitmap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture resource from a bitmap.

Definition

Visual Basic .NET Public Shared Function FromBitmap( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal usage As Usage, _
ByVal pool As Pool _
) As Texture
C# public static Texture FromBitmap(
Device device,
Bitmap image,
Usage usage,
Pool pool
);
Managed C++ public: static Texture* FromBitmap(
Device *device,
Bitmap *image,
Usage usage,
Pool pool
);
JScript .NET public static function FromBitmap(
device : Device,
image : Bitmap,
usage : Usage,
pool : Pool
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the Texture.
image | System.Drawing.Bitmap. A Bitmap Leave Site used to create the texture.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • Texture


Texture.FromStream(Device,Stream,Usage,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture resource from a stream object.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal usage As Usage, _
ByVal pool As Pool _
) As Texture
C# public static Texture FromStream(
Device device,
Stream data,
Usage usage,
Pool pool
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *data,
Usage usage,
Pool pool
);
JScript .NET public static function FromStream(
device : Device,
data : Stream,
usage : Usage,
pool : Pool
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the Texture object.
data | System.IO.Stream. A Stream Leave Site used to create the texture.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromBitmap
  • Texture


Texture.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Texture.GetLevelDescription(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.GetLevelDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a level description of a texture resource.

Definition

Visual Basic .NET Public Function GetLevelDescription( _
ByVal level As Integer _
) As SurfaceDescription
C# public SurfaceDescription GetLevelDescription(
int level
);
Managed C++ public: SurfaceDescription GetLevelDescription(
int level
);
JScript .NET public function GetLevelDescription(
level : int
) : SurfaceDescription;

Parameters

level System.Int32. Level of the texture resource. This method returns a surface description for the level specified by this parameter.

Return Value

Microsoft.DirectX.Direct3D.SurfaceDescription . A SurfaceDescription structure that describes the returned level.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Texture.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DTexture9, which allows unmanaged COM clients to create an instance of the managed Texture class. Not supported.


Texture.GetSurfaceLevel(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.GetSurfaceLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the specified texture surface level.

Definition

Visual Basic .NET Public Function GetSurfaceLevel( _
ByVal level As Integer _
) As Surface
C# public Surface GetSurfaceLevel(
int level
);
Managed C++ public: Surface* GetSurfaceLevel(
int level
);
JScript .NET public function GetSurfaceLevel(
level : int
) : Surface;

Parameters

level System.Int32. Level of the texture resource. This method returns a surface for the level specified by this parameter. The top-level surface is denoted by 0.

Return Value

Microsoft.DirectX.Direct3D.Surface . A Surface object that represents the returned surface.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Texture.LockRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Overload List

public GraphicsStream LockRectangle(int, LockFlags);
public GraphicsStream LockRectangle(int, LockFlags, out int);
public GraphicsStream LockRectangle(int, Rectangle, LockFlags);
public GraphicsStream LockRectangle(int, Rectangle, LockFlags, out int);
public Array LockRectangle(Type, int, LockFlags, out int, int[]);
public Array LockRectangle(Type, int, LockFlags, int[]);
public Array LockRectangle(Type, int, Rectangle, LockFlags, out int, int[]);
public Array LockRectangle(Type, int, Rectangle, LockFlags, int[]);

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,Rectangle,LockFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
Rectangle rect,
LockFlags flags,
out int pitch
);
Managed C++ public: GraphicsStream* LockRectangle(
int level,
Rectangle rect,
LockFlags flags,
int *pitch
);
JScript .NET public function LockRectangle(
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

level | System.Int32. A level of the texture resource to lock.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch | System.Int32. Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,LockFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
LockFlags flags,
out int pitch
);
Managed C++ public: GraphicsStream* LockRectangle(
int level,
LockFlags flags,
int *pitch
);
JScript .NET public function LockRectangle(
level : int,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

level | System.Int32. A level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch | System.Int32. Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,Rectangle,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
Rectangle rect,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockRectangle(
int level,
Rectangle rect,
LockFlags flags
);
JScript .NET public function LockRectangle(
level : int,
rect : Rectangle,
flags : LockFlags
) : GraphicsStream;

Parameters

level | System.Int32. A level of the texture resource to lock.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal level As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockRectangle(
int level,
LockFlags flags
);
JScript .NET public function LockRectangle(
level : int,
flags : LockFlags
) : GraphicsStream;

Parameters

level | System.Int32. A level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,Rectangle,LockFlags,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
Rectangle rect,
LockFlags flags,
out int pitch,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
int level,
Rectangle rect,
LockFlags flags,
int *pitch,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. A level of the texture resource to lock.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch | System.Int32. Pitch of the returning data.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,LockFlags,Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
LockFlags flags,
out int pitch,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
int level,
LockFlags flags,
int *pitch,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
level : int,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. A level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch | System.Int32. Pitch of the returning data.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,Rectangle,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
Rectangle rect,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
int level,
Rectangle rect,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
level : int,
rect : Rectangle,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. A level of the texture resource to lock.
rect | System.Drawing.Rectangle. A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.LockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockRectangle(
Type *typeLock,
int level,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockRectangle(
typeLock : Type,
level : int,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. A level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft® DirectX® 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.op_Equality(Texture,Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Texture, _
ByVal right As Texture _
) As Boolean
C# public static bool op_Equality(
Texture left,
Texture right
);
Managed C++ public: static bool op_Equality(
Texture *left,
Texture *right
);
JScript .NET public static function op_Equality(
left : Texture,
right : Texture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Texture. The Texture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Texture. The Texture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Texture.op_Inequality(Texture,Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Texture, _
ByVal right As Texture _
) As Boolean
C# public static bool op_Inequality(
Texture left,
Texture right
);
Managed C++ public: static bool op_Inequality(
Texture *left,
Texture *right
);
JScript .NET public static function op_Inequality(
left : Texture,
right : Texture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Texture. The Texture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Texture. The Texture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Texture.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Texture.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Texture.Texture

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Texture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Texture class.

Overload List

public Texture(Device, Bitmap, Usage, Pool);
public Texture(Device, int, int, int, Usage, Format, Pool);
public Texture(Device, Stream, Usage, Pool);
public Texture(IDirect3DTexture9);
public Texture(IDirect3DTexture9, Device, Pool);
public Texture(IntPtr);

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(IDirect3DTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Texture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Texture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As IDirect3DTexture9 _
)
C# public Texture(
IDirect3DTexture9 pInterop
);
Managed C++ public: Texture(
IDirect3DTexture9 pInterop
);
JScript .NET public function Texture(
pInterop : IDirect3DTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DTexture9. Unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Texture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Texture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Texture(
IntPtr unmanagedObject
);
Managed C++ public: Texture(
IntPtr unmanagedObject
);
JScript .NET public function Texture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(IDirect3DTexture9,Device,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Texture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Texture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DTexture9, _
ByVal device As Device, _
ByVal pool As Pool _
)
C# public Texture(
IDirect3DTexture9 lp,
Device device,
Pool pool
);
Managed C++ public: Texture(
IDirect3DTexture9 lp,
Device *device,
Pool pool
);
JScript .NET public function Texture(
lp : IDirect3DTexture9,
device : Device,
pool : Pool
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DTexture9. Unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the Texture.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(Device,Stream,Usage,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Texture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Texture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public Texture(
Device device,
Stream data,
Usage usage,
Pool pool
);
Managed C++ public: Texture(
Device *device,
Stream *data,
Usage usage,
Pool pool
);
JScript .NET public function Texture(
device : Device,
data : Stream,
usage : Usage,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the Texture.
data | System.IO.Stream. A Stream Leave Site object that contains the image data. The texture is created with the data in the stream.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(Device,Bitmap,Usage,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Texture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Texture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public Texture(
Device device,
Bitmap image,
Usage usage,
Pool pool
);
Managed C++ public: Texture(
Device *device,
Bitmap *image,
Usage usage,
Pool pool
);
JScript .NET public function Texture(
device : Device,
image : Bitmap,
usage : Usage,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the Texture.
image | System.Drawing.Bitmap. A Bitmap Leave Site used to create the texture.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(Device,Int32,Int32,Int32,Usage,Format,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Texture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Texture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal numLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool _
)
C# public Texture(
Device device,
int width,
int height,
int numLevels,
Usage usage,
Format format,
Pool pool
);
Managed C++ public: Texture(
Device *device,
int width,
int height,
int numLevels,
Usage usage,
Format format,
Pool pool
);
JScript .NET public function Texture(
device : Device,
width : int,
height : int,
numLevels : int,
usage : Usage,
format : Format,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the Texture.
width | System.Int32. Width of the texture's top level, in pixels. The pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of one pixel. Thus, if the division by 2 results in 0, 1 is taken instead.
height | System.Int32. Height of the texture's top level, in pixels. The pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of one pixel. Thus, if the division by 2 results in 0, 1 is taken instead.
numLevels | System.Int32. Number of levels in the texture. If this is 0, Microsoft® Direct3D® generates all texture sublevels down to 1 by 1 pixels for hardware that supports mipmapped textures. Check the BaseTexture.LevelCount parameter to see the number of levels generated.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the format of all levels in the texture.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.UnlockRectangle(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.UnlockRectangle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks a rectangle on a texture resource.

Definition

Visual Basic .NET Public Sub UnlockRectangle( _
ByVal level As Integer _
)
C# public void UnlockRectangle(
int level
);
Managed C++ public: void UnlockRectangle(
int level
);
JScript .NET public function UnlockRectangle(
level : int
);

Parameters

level System.Int32. Level of the texture resource to unlock.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Texture.LockRectangle


Texture.UpdateUnmanagedPointer(IDirect3DTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Texture object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DTexture9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DTexture9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DTexture9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DTexture9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DTexture9. Pointer to the IDirect3DTexture9 structure used to update the unmanaged pointer for this Texture object.


Texture.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Texture.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DTexture9
C# | public IDirect3DTexture9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DTexture9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DTexture9 . Unmanaged IDirect3DTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Texture.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Texture.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Texture object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Texture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Texture object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.TextureGutterHelper

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper Class

Language:
Note: This documentation is preliminary and is subject to change.

Used to build and manage gutter regions in a texture. Gutter regions separate textures and allow for bilinear interpolation to avoid rendering artifacts at texture boundaries.

Definition

Visual Basic .NET Public Class TextureGutterHelper
Inherits MarshalByRefObject
Implements IDisposable
C# public class TextureGutterHelper : MarshalByRefObject,
IDisposable
Managed C++ public __gc class TextureGutterHelper : public MarshalByRefObject,
IDisposable
JScript .NET public class TextureGutterHelper extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the TextureGutterHelper object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
ApplyGutters | Applies gutters to a texture object.
Dispose | Immediately releases the unmanaged resources used by the TextureGutterHelper object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the TextureGutterHelper object to free resources before it is destroyed by the garbage collector.
GetBaryMap | Retrieves texel barycentric coordinates.
GetFaceMap | Retrieves the index of the mesh face to which each texel belongs.
GetGutterMap | Receives a texel class value that indicates texel class according to each texel's location.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetTexelMap | Retrieves the (u, v) texture coordinates of each texel.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing event when called from within a derived class.
SetBaryMap | Sets texel barycentric coordinates.
SetFaceMap | Sets the index of the mesh face to which each texel belongs.
SetGutterMap | Sets a texel class value that indicates texel class according to each texel's location.
SetTexelMap | Sets the (u, v) texture coordinates of each texel.
TextureGutterHelper | Initializes a new instance of the TextureGutterHelper class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this TextureGutterHelper object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Height | Retrieves the height of the texture, in pixels.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface pointer.
Width | Retrieves the width of the texture, in pixels.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
TextureGutterHelper

Remarks

Note: When used with precomputed radiance transfer (PRT), this class requires a unique parameterization of the model. Every texel must correspond to a single point on the surface of the model and vice-versa. If the model includes multiple textures, it must be split into separate pieces that each contain one gutter helper object per texture.

This class can be used to generate a map in texture space in which each texel is in one of four classes.

Texel Class | Texel Location
0 | Invalid point; texel will not be used.
1 | Inside triangle.
2 | Inside gutter.
4 | Inside gutter; texel will be evaluated as a full sample in the ApplyGutters method.

For classes 1 and 2, a texel is stored with the face it belongs to, along with barycentric coordinates of the first two vertices of that face. Gutter vertices are assigned to the closest edge in texture space.

There is no texel class 3.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureGutterHelper.ApplyGutters

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.ApplyGutters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies gutters to a texture object.

Overload List

public void ApplyGutters(GraphicsStream, int, int, int);
public void ApplyGutters(PrtBuffer);
public void ApplyGutters(float[], int, int, int);
public void ApplyGutters(Texture);

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.


TextureGutterHelper.ApplyGutters(PrtBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.ApplyGutters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies gutters to a texture object.

Definition

Visual Basic .NET Public Sub ApplyGutters( _
ByVal buffer As PrtBuffer _
)
C# public void ApplyGutters(
PrtBuffer buffer
);
Managed C++ public: void ApplyGutters(
PrtBuffer *buffer
);
JScript .NET public function ApplyGutters(
buffer : PrtBuffer
);

Parameters

buffer Microsoft.DirectX.Direct3D.PrtBuffer. A PrtBuffer object to add gutters to.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureGutterHelper.ApplyGutters(Texture)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.ApplyGutters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies gutters to a texture object.

Definition

Visual Basic .NET Public Sub ApplyGutters( _
ByVal texture As Texture _
)
C# public void ApplyGutters(
Texture texture
);
Managed C++ public: void ApplyGutters(
Texture *texture
);
JScript .NET public function ApplyGutters(
texture : Texture
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture. A Texture object to added gutters to.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
WasStillDrawingException | The previous blit operation that is transferring information to or from this surface is incomplete.


TextureGutterHelper.ApplyGutters(Single[],Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.ApplyGutters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies gutters to a texture object.

Definition

Visual Basic .NET Public Sub ApplyGutters( _
ByVal data() As Single, _
ByVal numCoefficients As Integer, _
ByVal width As Integer, _
ByVal height As Integer _
)
C# public void ApplyGutters(
float[] data,
int numCoefficients,
int width,
int height
);
Managed C++ public: void ApplyGutters(
float data __gc[],
int numCoefficients,
int width,
int height
);
JScript .NET public function ApplyGutters(
data : float[],
numCoefficients : int,
width : int,
height : int
);

Parameters

data | System.Single[]. A floating-point array of texture data to add gutters to.
numCoefficients | System.Int32. Number of scalars per color channel used in memory to store samples.
width | System.Int32. Width of the texture, in pixels, obtained from the TextureGutterHelper.Width property.
height | System.Int32. Height of the texture, in pixels, obtained from the TextureGutterHelper.Height property.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureGutterHelper.ApplyGutters(GraphicsStream,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.ApplyGutters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Applies gutters to a texture object.

Definition

Visual Basic .NET Public Sub ApplyGutters( _
ByVal data As GraphicsStream, _
ByVal numCoefficients As Integer, _
ByVal width As Integer, _
ByVal height As Integer _
)
C# public void ApplyGutters(
GraphicsStream data,
int numCoefficients,
int width,
int height
);
Managed C++ public: void ApplyGutters(
GraphicsStream *data,
int numCoefficients,
int width,
int height
);
JScript .NET public function ApplyGutters(
data : GraphicsStream,
numCoefficients : int,
width : int,
height : int
);

Parameters

data | Microsoft.DirectX.GraphicsStream. A GraphicsStream object of texture data to add gutters to.
numCoefficients | System.Int32. Number of scalars per color channel used in memory to store samples.
width | System.Int32. Width of the texture, in pixels, obtained from the TextureGutterHelper.Width property.
height | System.Int32. Height of the texture, in pixels, obtained from the TextureGutterHelper.Height property.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureGutterHelper.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the TextureGutterHelper object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposed
  • Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing


TextureGutterHelper.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


TextureGutterHelper.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the TextureGutterHelper object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~TextureGutterHelper();
Managed C++ | ~TextureGutterHelper();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


TextureGutterHelper.GetBaryMap(Vector2[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.GetBaryMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves texel barycentric coordinates.

Definition

Visual Basic .NET Public Sub GetBaryMap( _
ByVal baryData() As Vector2 _
)
C# public void GetBaryMap(
Vector2[] baryData
);
Managed C++ public: void GetBaryMap(
Vector2 baryData __gc[]
);
JScript .NET public function GetBaryMap(
baryData : Vector2[]
);

Parameters

baryData Microsoft.DirectX.Vector2[]. An array of Vector2 objects that contain the first two barycentric coordinates of each texel.

Remarks

The third barycentric coordinate is given by:

1 - (baryData.x + baryData.y)

Barycentric coordinates are always specified with respect to the triangle returned by TextureGutterHelper.GetFaceMap.

The barycentric coordinates returned by this method are valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return nonzero values for valid texels.

Class 2 texels are mapped to the nearest point on the triangle in texel space.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetBaryMap


TextureGutterHelper.GetFaceMap(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.GetFaceMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the index of the mesh face to which each texel belongs.

Definition

Visual Basic .NET Public Sub GetFaceMap( _
ByVal faceData() As Integer _
)
C# public void GetFaceMap(
int[] faceData
);
Managed C++ public: void GetFaceMap(
int faceData __gc[]
);
JScript .NET public function GetFaceMap(
faceData : int[]
);

Parameters

faceData System.Int32[]. An integer array containing index values of the mesh face to which each texel belongs.

Remarks

The mesh face data returned by this method is valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return nonzero values for valid (non-class 0) texels.

This method retrieves the closest face for class 2 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetFaceMap


TextureGutterHelper.GetGutterMap(Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.GetGutterMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Receives a texel class value that indicates texel class according to each texel's location.

Definition

Visual Basic .NET Public Sub GetGutterMap( _
ByVal gutterData() As Byte _
)
C# public void GetGutterMap(
byte[] gutterData
);
Managed C++ public: void GetGutterMap(
Byte gutterData __gc[]
);
JScript .NET public function GetGutterMap(
gutterData : byte[]
);

Parameters

gutterData System.Byte[]. A Byte Leave Site array that receives the texel class.

Remarks

Possible texel classes are as follows:

Texel Class | Texel Location
0 | Invalid point; texel will not be used.
1 | Inside triangle.
2 | Inside gutter.
4 | Inside gutter; texel will be evaluated as a full sample in the ApplyGutters method.

There is no texel class 3.

The application must allocate and manage gutterData, with size given by:

size = texture width * texture height * sizeof(BYTE)

Texture width and height are obtained from the TextureGutterHelper.Width and TextureGutterHelper.Height properties.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetGutterMap


TextureGutterHelper.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


TextureGutterHelper.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXTextureGutterHelper, which allows unmanaged COM clients to create an instance of the managed TextureGutterHelper class. Not supported.


TextureGutterHelper.GetTexelMap(Vector2[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.GetTexelMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the (u, v) texture coordinates of each texel.

Definition

Visual Basic .NET Public Sub GetTexelMap( _
ByVal texelData() As Vector2 _
)
C# public void GetTexelMap(
Vector2[] texelData
);
Managed C++ public: void GetTexelMap(
Vector2 texelData __gc[]
);
JScript .NET public function GetTexelMap(
texelData : Vector2[]
);

Parameters

texelData Microsoft.DirectX.Vector2[]. An array of Vector2 objects that contain the location in pixel (u, v) texture coordinates where each texel is located.

Remarks

For class 2 and 4 texels, the returned (u, v) texture coordinates correspond to the closest point on the closest triangle.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetTexelMap


TextureGutterHelper.op_Equality(TextureGutterHelper,TextureGutterHelper)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As TextureGutterHelper, _
ByVal right As TextureGutterHelper _
) As Boolean
C# public static bool op_Equality(
TextureGutterHelper left,
TextureGutterHelper right
);
Managed C++ public: static bool op_Equality(
TextureGutterHelper *left,
TextureGutterHelper *right
);
JScript .NET public static function op_Equality(
left : TextureGutterHelper,
right : TextureGutterHelper
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.TextureGutterHelper. The TextureGutterHelper object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.TextureGutterHelper. The TextureGutterHelper object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


TextureGutterHelper.op_Inequality(TextureGutterHelper,TextureGutterHelper)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As TextureGutterHelper, _
ByVal right As TextureGutterHelper _
) As Boolean
C# public static bool op_Inequality(
TextureGutterHelper left,
TextureGutterHelper right
);
Managed C++ public: static bool op_Inequality(
TextureGutterHelper *left,
TextureGutterHelper *right
);
JScript .NET public static function op_Inequality(
left : TextureGutterHelper,
right : TextureGutterHelper
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.TextureGutterHelper. The TextureGutterHelper object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.TextureGutterHelper. The TextureGutterHelper object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


TextureGutterHelper.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


TextureGutterHelper.SetBaryMap(Vector2[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.SetBaryMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets texel barycentric coordinates.

Definition

Visual Basic .NET Public Sub SetBaryMap( _
ByVal baryData() As Vector2 _
)
C# public void SetBaryMap(
Vector2[] baryData
);
Managed C++ public: void SetBaryMap(
Vector2 baryData __gc[]
);
JScript .NET public function SetBaryMap(
baryData : Vector2[]
);

Parameters

baryData Microsoft.DirectX.Vector2[]. An array of Vector2 objects that contain the first two barycentric coordinates of each texel.

Remarks

The third barycentric coordinate is given by:

1 - (baryData.x + baryData.y)

The barycentric coordinates input to this method are valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return non-zero values for valid texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetBaryMap


TextureGutterHelper.SetFaceMap(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.SetFaceMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the index of the mesh face to which each texel belongs.

Definition

Visual Basic .NET Public Sub SetFaceMap( _
ByVal faceData() As Integer _
)
C# public void SetFaceMap(
int[] faceData
);
Managed C++ public: void SetFaceMap(
int faceData __gc[]
);
JScript .NET public function SetFaceMap(
faceData : int[]
);

Parameters

faceData System.Int32[]. An integer array containing index values of the mesh face to which each texel belongs.

Remarks

The mesh face data input to this method is valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return nonzero values for valid (non-class 0) texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetFaceMap


TextureGutterHelper.SetGutterMap(Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.SetGutterMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a texel class value that indicates texel class according to each texel's location.

Definition

Visual Basic .NET Public Sub SetGutterMap( _
ByVal gutterData() As Byte _
)
C# public void SetGutterMap(
byte[] gutterData
);
Managed C++ public: void SetGutterMap(
Byte gutterData __gc[]
);
JScript .NET public function SetGutterMap(
gutterData : byte[]
);

Parameters

gutterData System.Byte[]. A Byte Leave Site array that contains texel class data, to set.

Remarks

Possible texel classes are as follows:

Texel Class | Texel Location
0 | Invalid point; texel will not be used.
1 | Inside triangle.
2 | Inside gutter.
4 | Inside gutter; texel will be evaluated as a full sample in the ApplyGutters method.

There is no texel class 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetGutterMap


TextureGutterHelper.SetTexelMap(Vector2[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.SetTexelMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the (u, v) texture coordinates of each texel.

Definition

Visual Basic .NET Public Sub SetTexelMap( _
ByVal texelData() As Vector2 _
)
C# public void SetTexelMap(
Vector2[] texelData
);
Managed C++ public: void SetTexelMap(
Vector2 texelData __gc[]
);
JScript .NET public function SetTexelMap(
texelData : Vector2[]
);

Parameters

texelData Microsoft.DirectX.Vector2[]. An array of Vector2 objects that contain the location in pixel (u, v) texture coordinates where each texel is located.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetTexelMap


TextureGutterHelper.TextureGutterHelper

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.TextureGutterHelper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureGutterHelper class.

Overload List

public TextureGutterHelper(ID3DXTextureGutterHelper);
public TextureGutterHelper(int, int, float, Mesh);
public TextureGutterHelper(IntPtr);

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


TextureGutterHelper.TextureGutterHelper(ID3DXTextureGutterHelper)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.TextureGutterHelper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureGutterHelper class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXTextureGutterHelper _
)
C# public TextureGutterHelper(
ID3DXTextureGutterHelper pUnk
);
Managed C++ public: TextureGutterHelper(
ID3DXTextureGutterHelper pUnk
);
JScript .NET public function TextureGutterHelper(
pUnk : ID3DXTextureGutterHelper
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureGutterHelper. Unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface pointer.

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


TextureGutterHelper.TextureGutterHelper(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.TextureGutterHelper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureGutterHelper class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public TextureGutterHelper(
IntPtr unmanagedObject
);
Managed C++ public: TextureGutterHelper(
IntPtr unmanagedObject
);
JScript .NET public function TextureGutterHelper(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


TextureGutterHelper.TextureGutterHelper(Int32,Int32,Single,Mesh)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.TextureGutterHelper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureGutterHelper class.

Definition

Visual Basic .NET Public Sub New( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal gutterSize As Single, _
ByVal mesh As Mesh _
)
C# public TextureGutterHelper(
int width,
int height,
float gutterSize,
Mesh mesh
);
Managed C++ public: TextureGutterHelper(
int width,
int height,
float gutterSize,
Mesh *mesh
);
JScript .NET public function TextureGutterHelper(
width : int,
height : int,
gutterSize : float,
mesh : Mesh
);

Parameters

width | System.Int32. Width of the texture, in pixels
height | System.Int32. Height of the texture, in pixels.
gutterSize | System.Single. Number of texels by which to over-sample the texture and create the gutter region. Must be at least 1.
mesh | Microsoft.DirectX.Direct3D.Mesh. An input Mesh object.

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


TextureGutterHelper.UpdateUnmanagedPointer(ID3DXTextureGutterHelper)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this TextureGutterHelper object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXTextureGutterHelper _
)
C# public void UpdateUnmanagedPointer(
ID3DXTextureGutterHelper pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXTextureGutterHelper pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXTextureGutterHelper
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureGutterHelper. Pointer to the ID3DXTextureGutterHelper structure used to update the unmanaged pointer for this TextureGutterHelper object.


TextureGutterHelper.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


TextureGutterHelper.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the height of the texture, in pixels.

Definition

Visual Basic .NET | Public ReadOnly Property Height As Integer
C# | public int Height { get; }
Managed C++ | public: __property int get_Height();
JScript .NET | public function get Height() : int

Property Value

System.Int32 . The height of the texture, in pixels.

This property is read-only.

See Also

  • TextureGutterHelper.Width


TextureGutterHelper.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXTextureGutterHelper
C# | public ID3DXTextureGutterHelper UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXTextureGutterHelper get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXTextureGutterHelper

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureGutterHelper . Unmanaged ID3DXTextureGutterHelper interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


TextureGutterHelper.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the width of the texture, in pixels.

Definition

Visual Basic .NET | Public ReadOnly Property Width As Integer
C# | public int Width { get; }
Managed C++ | public: __property int get_Width();
JScript .NET | public function get Width() : int

Property Value

System.Int32 . The width of the texture, in pixels.

This property is read-only.

See Also

  • TextureGutterHelper.Height


TextureGutterHelper.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureGutterHelper.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the TextureGutterHelper object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the TextureGutterHelper object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.TextureLoader

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains functions to load and save textures.

Definition

Visual Basic .NET NotInheritable Public Class TextureLoader
Inherits Object
C# | public sealed class TextureLoader : Object
Managed C++ | public __gc __sealed class TextureLoader : public Object
JScript .NET | public class TextureLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) CheckCubeTextureRequirements | Checks creation parameters for a cube texture.
static (Shared in Visual Basic .NET) CheckTextureRequirements | Checks creation parameters for a texture.
static (Shared in Visual Basic .NET) CheckVolumeTextureRequirements | Checks creation parameters for a volume texture.
static (Shared in Visual Basic .NET) ComputeNormalMap | Converts a height map into a normal map.
static (Shared in Visual Basic .NET) FillTexture | Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.
static (Shared in Visual Basic .NET) FilterTexture | Filters mipmap levels of a texture.
static (Shared in Visual Basic .NET) FromCubeFile | Creates a cube texture from a file.
static (Shared in Visual Basic .NET) FromCubeStream | Creates a cube texture from a file in memory.
static (Shared in Visual Basic .NET) FromFile | Creates a texture from a file.
static (Shared in Visual Basic .NET) FromStream | Creates a texture from a file in memory.
static (Shared in Visual Basic .NET) FromVolumeFile | Creates a volume texture from a file.
static (Shared in Visual Basic .NET) FromVolumeStream | Creates a volume texture from a file in memory.
static (Shared in Visual Basic .NET) ImageInformationFromFile | Retrieves information about a given image file.
static (Shared in Visual Basic .NET) ImageInformationFromStream | Retrieves information about an image file in memory.
static (Shared in Visual Basic .NET) Save | Saves a texture to a file.
static (Shared in Visual Basic .NET) SaveToStream | Saves a volume to a graphics stream.

Inheritance Hierarchy

Object Leave Site
TextureLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureLoader.CheckCubeTextureRequirements(Device,Usage,Pool,CubeTextureRequirements)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.CheckCubeTextureRequirements Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Cube Texture

Checks creation parameters for a cube texture.

Definition

Visual Basic .NET Public Shared Sub CheckCubeTextureRequirements( _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool, _
ByRef requirements As CubeTextureRequirements _
)
C# public static void CheckCubeTextureRequirements(
Device device,
Usage usage,
Pool pool,
out CubeTextureRequirements requirements
);
Managed C++ public: static void CheckCubeTextureRequirements(
Device *device,
Usage usage,
Pool pool,
CubeTextureRequirements *requirements
);
JScript .NET public static function CheckCubeTextureRequirements(
device : Device,
usage : Usage,
pool : Pool,
requirements : CubeTextureRequirements
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device class that represents the device to associate with the cube texture.
usage | Microsoft.DirectX.Direct3D.Usage. Value that is either 0 or Usage.RenderTarget. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.
requirements | Microsoft.DirectX.Direct3D.CubeTextureRequirements. A CubeTextureRequirements structure that contains the cube texture creation parameters.

Remarks

If invalid parameters are passed to this method, it returns corrected parameters.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

Exceptions
NotAvailableException | This device does not support the queried technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );

See Also

  • CheckTextureRequirements
  • CheckVolumeTextureRequirements


TextureLoader.CheckTextureRequirements(Device,Usage,Pool,TextureRequirements)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.CheckTextureRequirements Method

 Language:
Note: This documentation is preliminary and is subject to change.

Checks creation parameters for a texture.

Definition

Visual Basic .NET Public Shared Sub CheckTextureRequirements( _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool, _
ByRef requirements As TextureRequirements _
)
C# public static void CheckTextureRequirements(
Device device,
Usage usage,
Pool pool,
out TextureRequirements requirements
);
Managed C++ public: static void CheckTextureRequirements(
Device *device,
Usage usage,
Pool pool,
TextureRequirements *requirements
);
JScript .NET public static function CheckTextureRequirements(
device : Device,
usage : Usage,
pool : Pool,
requirements : TextureRequirements
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
usage | Microsoft.DirectX.Direct3D.Usage. Value that is either 0 or Usage.RenderTarget. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.
requirements | Microsoft.DirectX.Direct3D.TextureRequirements. A TextureRequirements structure that contains the texture creation parameters.

Remarks

If invalid parameters are passed to this method, it returns corrected parameters.

Exceptions
NotAvailableException | This device does not support the queried technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CheckCubeTextureRequirements
  • CheckVolumeTextureRequirements


TextureLoader.CheckVolumeTextureRequirements(Device,Pool,VolumeTextureRequirements)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.CheckVolumeTextureRequirements Method

 Language:
Note: This documentation is preliminary and is subject to change.

Checks creation parameters for a volume texture.

Definition

Visual Basic .NET Public Shared Sub CheckVolumeTextureRequirements( _
ByVal device As Device, _
ByVal pool As Pool, _
ByRef requirements As VolumeTextureRequirements _
)
C# public static void CheckVolumeTextureRequirements(
Device device,
Pool pool,
out VolumeTextureRequirements requirements
);
Managed C++ public: static void CheckVolumeTextureRequirements(
Device *device,
Pool pool,
VolumeTextureRequirements *requirements
);
JScript .NET public static function CheckVolumeTextureRequirements(
device : Device,
pool : Pool,
requirements : VolumeTextureRequirements
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the texture should be placed.
requirements | Microsoft.DirectX.Direct3D.VolumeTextureRequirements. A VolumeTextureRequirements structure that contains the volume texture creation parameters.

Remarks

If invalid parameters are passed to this method, it returns corrected parameters.

Exceptions
NotAvailableException | This device does not support the queried technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CheckTextureRequirements
  • CheckCubeTextureRequirements


TextureLoader.ComputeNormalMap

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.ComputeNormalMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts a height map into a normal map.

Overload List

public static void ComputeNormalMap(Texture, Texture, NormalMap, Channel, float);
public static void ComputeNormalMap(Texture, Texture, out PaletteEntry, NormalMap, Channel, float);

Remarks

This method computes the normal by using the central difference with a kernel size of 3x3. The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture. RGB channels in the destination contain biased (x,y,z) components of the normal.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ComputeNormalMap(Texture,Texture,NormalMap,Channel,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.ComputeNormalMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts a height map into a normal map.

Definition

Visual Basic .NET Public Shared Sub ComputeNormalMap( _
ByVal texture As Texture, _
ByVal srcTexture As Texture, _
ByVal flags As NormalMap, _
ByVal channel As Channel, _
ByVal amplitude As Single _
)
C# public static void ComputeNormalMap(
Texture texture,
Texture srcTexture,
NormalMap flags,
Channel channel,
float amplitude
);
Managed C++ public: static void ComputeNormalMap(
Texture *texture,
Texture *srcTexture,
NormalMap flags,
Channel channel,
float amplitude
);
JScript .NET public static function ComputeNormalMap(
texture : Texture,
srcTexture : Texture,
flags : NormalMap,
channel : Channel,
amplitude : float
);

Parameters

texture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the destination texture.
srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the source height-map texture.
flags | Microsoft.DirectX.Direct3D.NormalMap. One or more NormalMap flags that indicate creation options.
channel | Microsoft.DirectX.Direct3D.Channel. A Channel flag that specifies the source of the height information.
amplitude | System.Single. Constant value by which the height information is multiplied.

Remarks

This method computes the normal by using the central difference with a kernel size of 3x3. The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture. RGB channels in the destination contain biased (x,y,z) components of the normal.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ComputeNormalMap(Texture,Texture,PaletteEntry,NormalMap,Channel,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.ComputeNormalMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Converts a height map into a normal map.

Definition

Visual Basic .NET Public Shared Sub ComputeNormalMap( _
ByVal texture As Texture, _
ByVal srcTexture As Texture, _
ByRef sourcePalette As PaletteEntry, _
ByVal flags As NormalMap, _
ByVal channel As Channel, _
ByVal amplitude As Single _
)
C# public static void ComputeNormalMap(
Texture texture,
Texture srcTexture,
out PaletteEntry sourcePalette,
NormalMap flags,
Channel channel,
float amplitude
);
Managed C++ public: static void ComputeNormalMap(
Texture *texture,
Texture *srcTexture,
PaletteEntry *sourcePalette,
NormalMap flags,
Channel channel,
float amplitude
);
JScript .NET public static function ComputeNormalMap(
texture : Texture,
srcTexture : Texture,
sourcePalette : PaletteEntry,
flags : NormalMap,
channel : Channel,
amplitude : float
);

Parameters

texture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the destination texture.
srcTexture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the source height-map texture.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the mapped normals.
flags | Microsoft.DirectX.Direct3D.NormalMap. One or more NormalMap flags that indicate creation options.
channel | Microsoft.DirectX.Direct3D.Channel. A Channel flag that specifies the source of the height information.
amplitude | System.Single. Constant value by which the height information is multiplied.

Remarks

This method computes the normal by using the central difference with a kernel size of 3x3. The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture. RGB channels in the destination contain biased (x,y,z) components of the normal.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.FillTexture

TextureLoader.FillTexture Method

Note: This documentation is preliminary and is subject to change.

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Overload List

public static void FillTexture(CubeTexture, Fill3DTextureCallback);
public static void FillTexture(CubeTexture, TextureShader);
public static void FillTexture(Texture, Fill2DTextureCallback);
public static void FillTexture(Texture, TextureShader);
public static void FillTexture(VolumeTexture, Fill3DTextureCallback);
public static void FillTexture(VolumeTexture, TextureShader);

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(VolumeTexture,TextureShader)

TextureLoader.FillTexture Method

Note: This documentation is preliminary and is subject to change.

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic .NET Public Shared Sub FillTexture( _
ByVal texture As VolumeTexture, _
ByVal textureShader As TextureShader _
)
C# public static void FillTexture(
VolumeTexture texture,
TextureShader textureShader
);
Managed C++ public: static void FillTexture(
VolumeTexture *texture,
TextureShader *textureShader
);
JScript .NET public static function FillTexture(
texture : VolumeTexture,
textureShader : TextureShader
);

Parameters

texture | Microsoft.DirectX.Direct3D.VolumeTexture. A VolumeTexture object that represents the filled texture.
textureShader | Microsoft.DirectX.Direct3D.TextureShader. A TextureShader object that contains the compiled HLSL function. This can be created using ShaderLoader.CompileShader, ShaderLoader.CompileShaderFromStream, or ShaderLoader.CompileShaderFromFile.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(CubeTexture,TextureShader)

TextureLoader.FillTexture Method

Note: This documentation is preliminary and is subject to change.

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic .NET Public Shared Sub FillTexture( _
ByVal texture As CubeTexture, _
ByVal textureShader As TextureShader _
)
C# public static void FillTexture(
CubeTexture texture,
TextureShader textureShader
);
Managed C++ public: static void FillTexture(
CubeTexture *texture,
TextureShader *textureShader
);
JScript .NET public static function FillTexture(
texture : CubeTexture,
textureShader : TextureShader
);

Parameters

texture | Microsoft.DirectX.Direct3D.CubeTexture. A CubeTexture object that represents the filled texture.
textureShader | Microsoft.DirectX.Direct3D.TextureShader. A TextureShader object that contains the compiled HLSL function. This can be created using ShaderLoader.CompileShader, ShaderLoader.CompileShaderFromStream, or ShaderLoader.CompileShaderFromFile.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(Texture,TextureShader)

TextureLoader.FillTexture Method

Note: This documentation is preliminary and is subject to change.

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic .NET Public Shared Sub FillTexture( _
ByVal texture As Texture, _
ByVal textureShader As TextureShader _
)
C# public static void FillTexture(
Texture texture,
TextureShader textureShader
);
Managed C++ public: static void FillTexture(
Texture *texture,
TextureShader *textureShader
);
JScript .NET public static function FillTexture(
texture : Texture,
textureShader : TextureShader
);

Parameters

texture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the filled texture.
textureShader | Microsoft.DirectX.Direct3D.TextureShader. A TextureShader object that contains the compiled HLSL function. This can be created using ShaderLoader.CompileShader, ShaderLoader.CompileShaderFromStream, or ShaderLoader.CompileShaderFromFile.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(VolumeTexture,Fill3DTextureCallback)

TextureLoader.FillTexture Method

Note: This documentation is preliminary and is subject to change.

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic .NET Public Shared Sub FillTexture( _
ByVal texture As VolumeTexture, _
ByVal callbackFunction As Fill3DTextureCallback _
)
C# public static void FillTexture(
VolumeTexture texture,
Fill3DTextureCallback callbackFunction
);
Managed C++ public: static void FillTexture(
VolumeTexture *texture,
Fill3DTextureCallback *callbackFunction
);
JScript .NET public static function FillTexture(
texture : VolumeTexture,
callbackFunction : Fill3DTextureCallback
);

Parameters

texture | Microsoft.DirectX.Direct3D.VolumeTexture. A VolumeTexture object that represents the filled texture.
callbackFunction | Microsoft.DirectX.Direct3D.Fill3DTextureCallback. User-provided Fill3DTextureCallback delegate that is used to compute the value of each texel.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(CubeTexture,Fill3DTextureCallback)

TextureLoader.FillTexture Method

Note: This documentation is preliminary and is subject to change.

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic .NET Public Shared Sub FillTexture( _
ByVal texture As CubeTexture, _
ByVal callbackFunction As Fill3DTextureCallback _
)
C# public static void FillTexture(
CubeTexture texture,
Fill3DTextureCallback callbackFunction
);
Managed C++ public: static void FillTexture(
CubeTexture *texture,
Fill3DTextureCallback *callbackFunction
);
JScript .NET public static function FillTexture(
texture : CubeTexture,
callbackFunction : Fill3DTextureCallback
);

Parameters

texture | Microsoft.DirectX.Direct3D.CubeTexture. A CubeTexture object that represents the filled texture.
callbackFunction | Microsoft.DirectX.Direct3D.Fill3DTextureCallback. User-provided Fill3DTextureCallback delegate that is used to compute the value of each texel.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(Texture,Fill2DTextureCallback)

TextureLoader.FillTexture Method

Note: This documentation is preliminary and is subject to change.

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic .NET Public Shared Sub FillTexture( _
ByVal texture As Texture, _
ByVal callbackFunction As Fill2DTextureCallback _
)
C# public static void FillTexture(
Texture texture,
Fill2DTextureCallback callbackFunction
);
Managed C++ public: static void FillTexture(
Texture *texture,
Fill2DTextureCallback *callbackFunction
);
JScript .NET public static function FillTexture(
texture : Texture,
callbackFunction : Fill2DTextureCallback
);

Parameters

texture | Microsoft.DirectX.Direct3D.Texture. A Texture object that represents the filled texture.
callbackFunction | Microsoft.DirectX.Direct3D.Fill2DTextureCallback. User-provided Fill2DTextureCallback delegate that is used to compute the value of each texel.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FilterTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FilterTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Filters mipmap levels of a texture.

Overload List

public static void FilterTexture(BaseTexture, int, Filter);
public static void FilterTexture(BaseTexture, out PaletteEntry, int, Filter);

Remarks

A filter is recursively applied to each texture level to generate the next texture level.

Writing to a surface that is not on the "zero" level of the texture does not cause the dirty rectangle to be updated. If FilterTexture is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRectangle on the texture.

Textures created in the default pool (Pool.Default) cannot be used with FilterTexture (unless created with Usage.Dynamic), because a lock operation on the object is necessary. Note that locks are prohibited on textures in the default pool (unless they are dynamic).

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


TextureLoader.FilterTexture(BaseTexture,Int32,Filter)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FilterTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Filters mipmap levels of a texture.

Definition

Visual Basic .NET Public Shared Sub FilterTexture( _
ByVal baseTexture As BaseTexture, _
ByVal srcLevel As Integer, _
ByVal filter As Filter _
)
C# public static void FilterTexture(
BaseTexture baseTexture,
int srcLevel,
Filter filter
);
Managed C++ public: static void FilterTexture(
BaseTexture *baseTexture,
int srcLevel,
Filter filter
);
JScript .NET public static function FilterTexture(
baseTexture : BaseTexture,
srcLevel : int,
filter : Filter
);

Parameters

baseTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that represents the texture object to filter.
srcLevel | System.Int32. Level whose image is used to generate subsequent levels. A common value for this parameter is 0.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter values that control how the mipmap is filtered.

Remarks

A filter is recursively applied to each texture level to generate the next texture level.

Writing to a surface that is not on the "zero" level of the texture does not cause the dirty rectangle to be updated. If FilterTexture is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRectangle on the texture.

Textures created in the default pool (Pool.Default) cannot be used with FilterTexture (unless created with Usage.Dynamic), because a lock operation on the object is necessary. Note that locks are prohibited on textures in the default pool (unless they are dynamic).

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


TextureLoader.FilterTexture(BaseTexture,PaletteEntry,Int32,Filter)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FilterTexture Method

 Language:
Note: This documentation is preliminary and is subject to change.

Filters mipmap levels of a texture.

Definition

Visual Basic .NET Public Shared Sub FilterTexture( _
ByVal baseTexture As BaseTexture, _
ByRef palette As PaletteEntry, _
ByVal srcLevel As Integer, _
ByVal filter As Filter _
)
C# public static void FilterTexture(
BaseTexture baseTexture,
out PaletteEntry palette,
int srcLevel,
Filter filter
);
Managed C++ public: static void FilterTexture(
BaseTexture *baseTexture,
PaletteEntry *palette,
int srcLevel,
Filter filter
);
JScript .NET public static function FilterTexture(
baseTexture : BaseTexture,
palette : PaletteEntry,
srcLevel : int,
filter : Filter
);

Parameters

baseTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that represents the texture object to filter.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in. For formats that are not palletized, use 0. If a palette is not specified, the default Microsoft® Direct3D® palette (an all-opaque white palette) is provided. See Remarks.
srcLevel | System.Int32. Level whose image is used to generate subsequent levels. A common value for this parameter is 0.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter values that control how the mipmap is filtered.

Remarks

A filter is recursively applied to each texture level to generate the next texture level.

Writing to a surface that is not on the "zero" level of the texture does not cause the dirty rectangle to be updated. If FilterTexture is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRectangle on the texture.

Textures created in the default pool (Pool.Default) cannot be used with FilterTexture (unless created with Usage.Dynamic), because a lock operation on the object is necessary. Note that locks are prohibited on textures in the default pool (unless they are dynamic).

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


TextureLoader.FromCubeFile

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file.

Overload List

public static CubeTexture FromCubeFile(Device, string);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file.

Definition

Visual Basic .NET Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static CubeTexture* FromCubeFile(
Device *device,
String *srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
srcFile | System.String. String that specifies the file name.
size | System.Int32. Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file.

Definition

Visual Basic .NET Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static CubeTexture* FromCubeFile(
Device *device,
String *srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
srcFile | System.String. String that specifies the file name.
size | System.Int32. Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file.

Definition

Visual Basic .NET Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static CubeTexture* FromCubeFile(
Device *device,
String *srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
srcFile | System.String. String that specifies the file name.
size | System.Int32. Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file.

Definition

Visual Basic .NET Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
Managed C++ public: static CubeTexture* FromCubeFile(
Device *device,
String *srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation,
PaletteEntry *palette
);
JScript .NET public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
srcFile | System.String. String that specifies the file name.
size | System.Int32. Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure to fill with a description of the data in the source image file, or 0.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file.

Definition

Visual Basic .NET Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile
);
Managed C++ public: static CubeTexture* FromCubeFile(
Device *device,
String *srcFile
);
JScript .NET public static function FromCubeFile(
device : Device,
srcFile : String
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
srcFile | System.String. String that specifies the file name.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeStream

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Overload List

public static CubeTexture FromCubeStream(Device, Stream);
public static CubeTexture FromCubeStream(Device, Stream, int);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);
public static CubeTexture FromCubeStream(Device, Stream, int, int, Usage, Format, Pool, Filter, Filter, int);
public static CubeTexture FromCubeStream(Device, Stream, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static CubeTexture FromCubeStream(Device, Stream, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
size | System.Int32. Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
size | System.Int32. Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
size | System.Int32. Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes | System.Int32. Size of the file in memory, in bytes.
size | System.Int32. Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes | System.Int32. Size of the file in memory, in bytes.
size | System.Int32. Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes | System.Int32. Size of the file in memory, in bytes.
size | System.Int32. Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation,
PaletteEntry *palette
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes | System.Int32. Size of the file in memory, in bytes.
size | System.Int32. Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromCubeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a cube texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes
);
Managed C++ public: static CubeTexture* FromCubeStream(
Device *device,
Stream *stream,
int readBytes
);
JScript .NET public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int
) : CubeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the cube texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes | System.Int32. Size of the file in memory, in bytes.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture . A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft® DirectDraw® surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file.

Overload List

public static Texture FromFile(Device, string);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft® DirectX® texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static Texture* FromFile(
Device *device,
String *srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height | System.Int32. Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft® DirectX® texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static Texture* FromFile(
Device *device,
String *srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height | System.Int32. Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft® DirectX® texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static Texture* FromFile(
Device *device,
String *srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height | System.Int32. Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft® DirectX® texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
Managed C++ public: static Texture* FromFile(
Device *device,
String *srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation,
PaletteEntry *palette
);
JScript .NET public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height | System.Int32. Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft® DirectX® texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file.

Definition

Visual Basic .NET Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile
);
Managed C++ public: static Texture* FromFile(
Device *device,
String *srcFile
);
JScript .NET public static function FromFile(
device : Device,
srcFile : String
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
srcFile | System.String. String that specifies the file name.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft® DirectX® texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Overload List

public static Texture FromStream(Device, Stream);
public static Texture FromStream(Device, Stream, int);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);
public static Texture FromStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static Texture FromStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static Texture FromStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation,
PaletteEntry *palette
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes
);
Managed C++ public: static Texture* FromStream(
Device *device,
Stream *stream,
int readBytes
);
JScript .NET public static function FromStream(
device : Device,
stream : Stream,
readBytes : int
) : Texture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture. See Remarks.
readBytes | System.Int32. Size, in bytes, of the file in memory.

Return Value

Microsoft.DirectX.Direct3D.Texture . A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromVolumeFile

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file.

Overload List

public static VolumeTexture FromVolumeFile(Device, string);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file.

Definition

Visual Basic .NET Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static VolumeTexture* FromVolumeFile(
Device *device,
String *srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file.

Definition

Visual Basic .NET Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static VolumeTexture* FromVolumeFile(
Device *device,
String *srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file.

Definition

Visual Basic .NET Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static VolumeTexture* FromVolumeFile(
Device *device,
String *srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file.

Definition

Visual Basic .NET Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
Managed C++ public: static VolumeTexture* FromVolumeFile(
Device *device,
String *srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation,
PaletteEntry *palette
);
JScript .NET public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
srcFile | System.String. String that specifies the file name.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file.

Definition

Visual Basic .NET Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile
);
Managed C++ public: static VolumeTexture* FromVolumeFile(
Device *device,
String *srcFile
);
JScript .NET public static function FromVolumeFile(
device : Device,
srcFile : String
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
srcFile | System.String. String that specifies the file name.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeStream

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Overload List

public static VolumeTexture FromVolumeStream(Device, Stream);
public static VolumeTexture FromVolumeStream(Device, Stream, int);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
PaletteEntry *palette
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation *srcInformation,
PaletteEntry *palette
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
readBytes | System.Int32. Size, in bytes, of the file in memory.
width | System.Int32. Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height | System.Int32. Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth | System.Int32. Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels | System.Int32. Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage | Microsoft.DirectX.Direct3D.Usage. Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
mipFilter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the mipmaps are filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. [in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.FromVolumeStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume texture from a file in memory.

Definition

Visual Basic .NET Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes
);
Managed C++ public: static VolumeTexture* FromVolumeStream(
Device *device,
Stream *stream,
int readBytes
);
JScript .NET public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int
) : VolumeTexture;

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object that represents the device to associate with the volume texture.
stream | System.IO.Stream. A Stream Leave Site from which to create the texture.
readBytes | System.Int32. Size, in bytes, of the file in memory.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture . Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.ImageInformationFromFile(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.ImageInformationFromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about a given image file.

Definition

Visual Basic .NET Public Shared Function ImageInformationFromFile( _
ByVal srcFile As String _
) As ImageInformation
C# public static ImageInformation ImageInformationFromFile(
string srcFile
);
Managed C++ public: static ImageInformation ImageInformationFromFile(
String *srcFile
);
JScript .NET public static function ImageInformationFromFile(
srcFile : String
) : ImageInformation;

Parameters

srcFile System.String. File name of the image whose information is being retrieved.

Return Value

Microsoft.DirectX.Direct3D.ImageInformation . An ImageInformation structure that contains the description of the data in the source file.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ImageInformationFromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.ImageInformationFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about an image file in memory.

Overload List

public static ImageInformation ImageInformationFromStream(Stream);
public static ImageInformation ImageInformationFromStream(Stream, int);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ImageInformationFromStream(Stream)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.ImageInformationFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about an image file in memory.

Definition

Visual Basic .NET Public Shared Function ImageInformationFromStream( _
ByVal sourceStream As Stream _
) As ImageInformation
C# public static ImageInformation ImageInformationFromStream(
Stream sourceStream
);
Managed C++ public: static ImageInformation ImageInformationFromStream(
Stream *sourceStream
);
JScript .NET public static function ImageInformationFromStream(
sourceStream : Stream
) : ImageInformation;

Parameters

sourceStream System.IO.Stream. A Stream Leave Site object containing the image whose information is being retrieved.

Return Value

Microsoft.DirectX.Direct3D.ImageInformation . An ImageInformation structure that contains the description of the data in sourceStream.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ImageInformationFromStream(Stream,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.ImageInformationFromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about an image file in memory.

Definition

Visual Basic .NET Public Shared Function ImageInformationFromStream( _
ByVal sourceStream As Stream, _
ByVal readLength As Integer _
) As ImageInformation
C# public static ImageInformation ImageInformationFromStream(
Stream sourceStream,
int readLength
);
Managed C++ public: static ImageInformation ImageInformationFromStream(
Stream *sourceStream,
int readLength
);
JScript .NET public static function ImageInformationFromStream(
sourceStream : Stream,
readLength : int
) : ImageInformation;

Parameters

sourceStream | System.IO.Stream. A Stream Leave Site object containing the image whose information is being retrieved.
readLength | System.Int32. The size of the sourceStream data to read.

Return Value

Microsoft.DirectX.Direct3D.ImageInformation . An ImageInformation structure that contains the description of the data in sourceStream.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.Save

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a texture to a file.

Overload List

public static void Save(string, ImageFileFormat, BaseTexture);
public static void Save(string, ImageFileFormat, BaseTexture, out PaletteEntry);

Remarks

The Save method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is not dynamic (because a usage parameter was set to 0 at its creation) and is located in video memory (that is, the memory pool set to Default), this method fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SurfaceLoader.Save
  • VolumeLoader.Save


TextureLoader.Save(String,ImageFileFormat,BaseTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a texture to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
BaseTexture srcTexture
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
BaseTexture *srcTexture
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcTexture : BaseTexture
);

Parameters

destFile | System.String. String that specifies the file name of the source image.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that contains the texture to save.

Remarks

The Save method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is not dynamic (because a usage parameter was set to 0 at its creation) and is located in video memory (that is, the memory pool set to Default), this method fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SurfaceLoader.Save
  • VolumeLoader.Save


TextureLoader.Save(String,ImageFileFormat,BaseTexture,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a texture to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture, _
ByRef sourcePalette As PaletteEntry _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
BaseTexture srcTexture,
out PaletteEntry sourcePalette
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
BaseTexture *srcTexture,
PaletteEntry *sourcePalette
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcTexture : BaseTexture,
sourcePalette : PaletteEntry
);

Parameters

destFile | System.String. String that specifies the file name of the source image.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that contains the texture to save.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry structure that contains a 256-color palette. This parameter can be 0.

Remarks

The Save method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is not dynamic (because a usage parameter was set to 0 at its creation) and is located in video memory (that is, the memory pool set to Default), this method fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SurfaceLoader.Save
  • VolumeLoader.Save


TextureLoader.SaveToStream

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a graphics stream.

Overload List

public static GraphicsStream SaveToStream(ImageFileFormat, BaseTexture);
public static GraphicsStream SaveToStream(ImageFileFormat, BaseTexture, out PaletteEntry);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Save


TextureLoader.SaveToStream(ImageFileFormat,BaseTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a graphics stream.

Definition

Visual Basic .NET Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
BaseTexture srcTexture
);
Managed C++ public: static GraphicsStream* SaveToStream(
ImageFileFormat destFormat,
BaseTexture *srcTexture
);
JScript .NET public static function SaveToStream(
destFormat : ImageFileFormat,
srcTexture : BaseTexture
) : GraphicsStream;

Parameters

destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that contains the texture to save.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the source image.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Save


TextureLoader.SaveToStream(ImageFileFormat,BaseTexture,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureLoader.SaveToStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a graphics stream.

Definition

Visual Basic .NET Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture, _
ByRef sourcePalette As PaletteEntry _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
BaseTexture srcTexture,
out PaletteEntry sourcePalette
);
Managed C++ public: static GraphicsStream* SaveToStream(
ImageFileFormat destFormat,
BaseTexture *srcTexture,
PaletteEntry *sourcePalette
);
JScript .NET public static function SaveToStream(
destFormat : ImageFileFormat,
srcTexture : BaseTexture,
sourcePalette : PaletteEntry
) : GraphicsStream;

Parameters

destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture | Microsoft.DirectX.Direct3D.BaseTexture. A BaseTexture object that contains the texture to save.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. A PaletteEntry structure that contains a 256-color palette. This parameter can be 0.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the source image.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Save


Microsoft.DirectX.Direct3D.TextureShader

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates the functionality of a texture shader.

Definition

Visual Basic .NET NotInheritable Public Class TextureShader
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class TextureShader : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class TextureShader : public MarshalByRefObject,
IDisposable
JScript .NET public class TextureShader extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the TextureShader object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the TextureShader object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the TextureShader object to free resources before it is destroyed by the garbage collector.
GetConstant | Retrieves an effect constant.
GetConstantDescription | Retrieves an array of effect constants in the effect's constant table.
GetConstantElement | Retrieves an effect constant element.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.TextureShader.Disposing event when called from within a derived class.
SetDefaults | Sets the effect constants to the default values declared in the texture shader.
SetValue | Sets the constant table with the data in the buffer.
SetValueTranspose | Sets a transposed matrix.
TextureShader | Initializes a new instance of the TextureShader class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this TextureShader object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
ConstantBuffer | Retrieves the constant table.
Description | Retrieves a description of the constant table.
Disposed | Gets a value that indicates whether the object is disposed.
Function | Retrieves the shader function stream.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXTextureShader interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
TextureShader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureShader.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the TextureShader object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.TextureShader.Disposed
  • Microsoft.DirectX.Direct3D.TextureShader.Disposing


TextureShader.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


TextureShader.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the TextureShader object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~TextureShader();
Managed C++ | ~TextureShader();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


TextureShader.GetConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.GetConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an effect constant.

Overload List

public EffectHandle GetConstant(EffectHandle, int);
public EffectHandle GetConstant(EffectHandle, string);


TextureShader.GetConstant(EffectHandle,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.GetConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an effect constant.

Definition

Visual Basic .NET Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
string name
);
Managed C++ public: EffectHandle* GetConstant(
EffectHandle *constant,
String *name
);
JScript .NET public function GetConstant(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the parent data structure. If the constant is a top-level parameter (there is no parent data structure), use null.
name | System.String. A string that contains the name of the constant to retrieve.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle that represents the effect constant.


TextureShader.GetConstant(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.GetConstant Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an effect constant.

Definition

Visual Basic .NET Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
int index
);
Managed C++ public: EffectHandle* GetConstant(
EffectHandle *constant,
int index
);
JScript .NET public function GetConstant(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the parent data structure. If the constant is a top-level parameter (there is no parent data structure), use null.
index | System.Int32. Zero-based index of the constant.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . An EffectHandle that represents the effect constant.


TextureShader.GetConstantDescription(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.GetConstantDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of effect constants in the effect's constant table.

Definition

Visual Basic .NET Public Function GetConstantDescription( _
ByVal constant As EffectHandle, _
ByVal numberConstants As Integer _
) As ConstantDescription()
C# public ConstantDescription[] GetConstantDescription(
EffectHandle constant,
int numberConstants
);
Managed C++ public: ConstantDescription GetConstantDescription(
EffectHandle *constant,
int numberConstants
) __gc[];
JScript .NET public function GetConstantDescription(
constant : EffectHandle,
numberConstants : int
) : ConstantDescription[];

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the effect constant.
numberConstants | System.Int32. Number of constants to retrieve.

Return Value

Microsoft.DirectX.Direct3D.ConstantDescription[]. Returns an array of ConstantDescription objects that represent the effect constant descriptions.

Remarks

Samplers can appear more than once in a constant table, therefore, GetConstantDescription can return an array of descriptions each with a different register index.


TextureShader.GetConstantElement(EffectHandle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.GetConstantElement Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an effect constant element.

Definition

Visual Basic .NET Public Function GetConstantElement( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstantElement(
EffectHandle constant,
int index
);
Managed C++ public: EffectHandle* GetConstantElement(
EffectHandle *constant,
int index
);
JScript .NET public function GetConstantElement(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the array of constants.
index | System.Int32. Zero-based index of the element in the constant table.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle . Returns an EffectHandle that represents the effect constant element.


TextureShader.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


TextureShader.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXTextureShader, which allows unmanaged COM clients to create an instance of the managed TextureShader class. Not supported.


TextureShader.op_Equality(TextureShader,TextureShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As TextureShader, _
ByVal right As TextureShader _
) As Boolean
C# public static bool op_Equality(
TextureShader left,
TextureShader right
);
Managed C++ public: static bool op_Equality(
TextureShader *left,
TextureShader *right
);
JScript .NET public static function op_Equality(
left : TextureShader,
right : TextureShader
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.TextureShader. The TextureShader object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.TextureShader. The TextureShader object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


TextureShader.op_Inequality(TextureShader,TextureShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As TextureShader, _
ByVal right As TextureShader _
) As Boolean
C# public static bool op_Inequality(
TextureShader left,
TextureShader right
);
Managed C++ public: static bool op_Inequality(
TextureShader *left,
TextureShader *right
);
JScript .NET public static function op_Inequality(
left : TextureShader,
right : TextureShader
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.TextureShader. The TextureShader object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.TextureShader. The TextureShader object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


TextureShader.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.TextureShader.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


TextureShader.SetDefaults()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.SetDefaults Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the effect constants to the default values declared in the texture shader.

Definition

Visual Basic .NET | Public Sub SetDefaults()
C# | public void SetDefaults();
Managed C++ | public: void SetDefaults();
JScript .NET | public function SetDefaults();


TextureShader.SetValue

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the constant table with the data in the buffer.

Overload List

public void SetValue(EffectHandle, bool);
public void SetValue(EffectHandle, bool[]);
public void SetValue(EffectHandle, ColorValue);
public void SetValue(EffectHandle, ColorValue[]);
public void SetValue(EffectHandle, GraphicsStream);
public void SetValue(EffectHandle, int);
public void SetValue(EffectHandle, int[]);
public void SetValue(EffectHandle, Matrix);
public void SetValue(EffectHandle, Matrix[]);
public void SetValue(EffectHandle, float);
public void SetValue(EffectHandle, float[]);
public void SetValue(EffectHandle, Vector4);
public void SetValue(EffectHandle, Vector4[]);
public void SetValue(EffectHandle, void, int);
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Matrix[])

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets an array of Matrix objects.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValue(
EffectHandle constant,
Matrix[] matrix
);
Managed C++ public: void SetValue(
EffectHandle *constant,
Matrix matrix __gc[]
);
JScript .NET public function SetValue(
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
matrix | Microsoft.DirectX.Matrix[]. An array of Matrix objects to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Matrix)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets a Matrix object.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValue(
EffectHandle constant,
Matrix matrix
);
Managed C++ public: void SetValue(
EffectHandle *constant,
Matrix matrix
);
JScript .NET public function SetValue(
constant : EffectHandle,
matrix : Matrix
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
matrix | Microsoft.DirectX.Matrix. A Matrix object to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,ColorValue[])

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets an array of ColorValue objects.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal color() As ColorValue _
)
C# public void SetValue(
EffectHandle constant,
ColorValue[] color
);
Managed C++ public: void SetValue(
EffectHandle *constant,
ColorValue color __gc[]
);
JScript .NET public function SetValue(
constant : EffectHandle,
color : ColorValue[]
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
color | Microsoft.DirectX.Direct3D.ColorValue[]. An array of ColorValue objects to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,ColorValue)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets a ColorValue object.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal color As ColorValue _
)
C# public void SetValue(
EffectHandle constant,
ColorValue color
);
Managed C++ public: void SetValue(
EffectHandle *constant,
ColorValue color
);
JScript .NET public function SetValue(
constant : EffectHandle,
color : ColorValue
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
color | Microsoft.DirectX.Direct3D.ColorValue. A ColorValue object to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Vector4[])

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets an array of Vector4 objects.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal vector() As Vector4 _
)
C# public void SetValue(
EffectHandle constant,
Vector4[] vector
);
Managed C++ public: void SetValue(
EffectHandle *constant,
Vector4 vector __gc[]
);
JScript .NET public function SetValue(
constant : EffectHandle,
vector : Vector4[]
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
vector | Microsoft.DirectX.Vector4[]. An array of Vector4 objects to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Vector4)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets a Vector4 object.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal vector As Vector4 _
)
C# public void SetValue(
EffectHandle constant,
Vector4 vector
);
Managed C++ public: void SetValue(
EffectHandle *constant,
Vector4 vector
);
JScript .NET public function SetValue(
constant : EffectHandle,
vector : Vector4
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
vector | Microsoft.DirectX.Vector4. A Vector4 object to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Single[])

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets an array of Single Leave Site values.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal f() As Single _
)
C# public void SetValue(
EffectHandle constant,
float[] f
);
Managed C++ public: void SetValue(
EffectHandle *constant,
float f __gc[]
);
JScript .NET public function SetValue(
constant : EffectHandle,
f : float[]
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
f | System.Single[]. An array of Single Leave Site values to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Single)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets a Single Leave Site value.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal f As Single _
)
C# public void SetValue(
EffectHandle constant,
float f
);
Managed C++ public: void SetValue(
EffectHandle *constant,
float f
);
JScript .NET public function SetValue(
constant : EffectHandle,
f : float
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
f | System.Single. A Single Leave Site value to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Int32[])

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets an array of Int32 Leave Site values.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal n() As Integer _
)
C# public void SetValue(
EffectHandle constant,
int[] n
);
Managed C++ public: void SetValue(
EffectHandle *constant,
int n __gc[]
);
JScript .NET public function SetValue(
constant : EffectHandle,
n : int[]
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
n | System.Int32[]. An array of Int32 Leave Site values to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Int32)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets a Int32 Leave Site value.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal n As Integer _
)
C# public void SetValue(
EffectHandle constant,
int n
);
Managed C++ public: void SetValue(
EffectHandle *constant,
int n
);
JScript .NET public function SetValue(
constant : EffectHandle,
n : int
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
n | System.Int32. An Int32 Leave Site value to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Boolean[])

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets an array of Boolean Leave Site values.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal b() As Boolean _
)
C# public void SetValue(
EffectHandle constant,
bool[] b
);
Managed C++ public: void SetValue(
EffectHandle *constant,
bool b __gc[]
);
JScript .NET public function SetValue(
constant : EffectHandle,
b : boolean[]
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
b | System.Boolean[]. An array of Boolean Leave Site values to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Boolean)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets a Boolean Leave Site value.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal b As Boolean _
)
C# public void SetValue(
EffectHandle constant,
bool b
);
Managed C++ public: void SetValue(
EffectHandle *constant,
bool b
);
JScript .NET public function SetValue(
constant : EffectHandle,
b : boolean
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
b | System.Boolean. A Boolean Leave Site value to set.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,GraphicsStream)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the constant table with the data in the buffer.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal data As GraphicsStream _
)
C# public void SetValue(
EffectHandle constant,
GraphicsStream data
);
Managed C++ public: void SetValue(
EffectHandle *constant,
GraphicsStream *data
);
JScript .NET public function SetValue(
constant : EffectHandle,
data : GraphicsStream
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
data | Microsoft.DirectX.GraphicsStream. A GraphicsStream object the contains the texture shader constant data.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Void,Int32)

TextureShader.SetValue Method

Note: This documentation is preliminary and is subject to change.

Sets the constant table with the data in the buffer.

Definition

Visual Basic .NET Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal data As Void, _
ByVal dataSize As Integer _
)
C# public void SetValue(
EffectHandle constant,
void data,
int dataSize
);
Managed C++ public: void SetValue(
EffectHandle *constant,
void data,
int dataSize
);
JScript .NET public function SetValue(
constant : EffectHandle,
data : void,
dataSize : int
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
data | System.Void. A buffer containing the data to set.
dataSize | System.Int32. Number of bytes in the data buffer.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValueTranspose

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a transposed matrix.

Overload List

public void SetValueTranspose(EffectHandle, Matrix);
public void SetValueTranspose(EffectHandle, Matrix[]);

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureShader.SetValueTranspose(EffectHandle,Matrix[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a transposed matrix.

Definition

Visual Basic .NET Public Sub SetValueTranspose( _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValueTranspose(
EffectHandle constant,
Matrix[] matrix
);
Managed C++ public: void SetValueTranspose(
EffectHandle *constant,
Matrix matrix __gc[]
);
JScript .NET public function SetValueTranspose(
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
matrix | Microsoft.DirectX.Matrix[]. An array of transposed Matrix objects to set.

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureShader.SetValueTranspose(EffectHandle,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.SetValueTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets a transposed matrix.

Definition

Visual Basic .NET Public Sub SetValueTranspose( _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValueTranspose(
EffectHandle constant,
Matrix matrix
);
Managed C++ public: void SetValueTranspose(
EffectHandle *constant,
Matrix matrix
);
JScript .NET public function SetValueTranspose(
constant : EffectHandle,
matrix : Matrix
);

Parameters

constant | Microsoft.DirectX.Direct3D.EffectHandle. An EffectHandle object that represents the unique identifier to a constant.
matrix | Microsoft.DirectX.Matrix. A transposed Matrix object to set.

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureShader.TextureShader

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.TextureShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureShader class.

Overload List

public TextureShader(GraphicsStream);
public TextureShader(ID3DXTextureShader);
public TextureShader(int[]);
public TextureShader(IntPtr);


TextureShader.TextureShader(ID3DXTextureShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.TextureShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXTextureShader _
)
C# public TextureShader(
ID3DXTextureShader pUnk
);
Managed C++ public: TextureShader(
ID3DXTextureShader pUnk
);
JScript .NET public function TextureShader(
pUnk : ID3DXTextureShader
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureShader. Unmanaged Component Object Model (COM) ID3DXTextureShader interface pointer.


TextureShader.TextureShader(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.TextureShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public TextureShader(
IntPtr unmanagedObject
);
Managed C++ public: TextureShader(
IntPtr unmanagedObject
);
JScript .NET public function TextureShader(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXTextureShader interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


TextureShader.TextureShader(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.TextureShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal function() As Integer _
)
C# public TextureShader(
int[] function
);
Managed C++ public: TextureShader(
int function __gc[]
);
JScript .NET public function TextureShader(
function : int[]
);

Parameters

function System.Int32[]. An integer array that contains the texture shader function stream.


TextureShader.TextureShader(GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.TextureShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal function As GraphicsStream _
)
C# public TextureShader(
GraphicsStream function
);
Managed C++ public: TextureShader(
GraphicsStream *function
);
JScript .NET public function TextureShader(
function : GraphicsStream
);

Parameters

function Microsoft.DirectX.GraphicsStream. A GraphicsStream object that contains the texture shader function stream.


TextureShader.UpdateUnmanagedPointer(ID3DXTextureShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this TextureShader object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXTextureShader _
)
C# public void UpdateUnmanagedPointer(
ID3DXTextureShader pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXTextureShader pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXTextureShader
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureShader. Pointer to the ID3DXTextureShader structure used to update the unmanaged pointer for this TextureShader object.


TextureShader.ConstantBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.ConstantBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the constant table.

Definition

Visual Basic .NET | Public ReadOnly Property ConstantBuffer As GraphicsStream
C# | public GraphicsStream ConstantBuffer { get; }
Managed C++ | public: __property GraphicsStream* get_ConstantBuffer();
JScript .NET | public function get ConstantBuffer() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the constant table.

This property is read-only.


TextureShader.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a description of the constant table.

Definition

Visual Basic .NET | Public ReadOnly Property Description As ConstantTableDescription
C# | public ConstantTableDescription Description { get; }
Managed C++ | public: __property ConstantTableDescription get_Description();
JScript .NET | public function get Description() : ConstantTableDescription

Property Value

Microsoft.DirectX.Direct3D.ConstantTableDescription . A ConstantTableDescription object that contains the attributes of the constant table.

This property is read-only.


TextureShader.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


TextureShader.Function

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.Function Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the shader function stream.

Definition

Visual Basic .NET | Public ReadOnly Property Function As GraphicsStream
C# | public GraphicsStream Function { get; }
Managed C++ | public: __property GraphicsStream* get_Function();
JScript .NET | public function get Function() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the shader function stream.

This property is read-only.


TextureShader.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXTextureShader interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXTextureShader
C# | public ID3DXTextureShader UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXTextureShader get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXTextureShader

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureShader . Unmanaged ID3DXTextureShader interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


TextureShader.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureShader.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the TextureShader object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.TextureShader.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the TextureShader object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.TextureStateManager

TextureStateManager Class

Note: This documentation is preliminary and is subject to change.

Contains texture states for the device.

Definition

Visual Basic .NET NotInheritable Public Class TextureStateManager
Inherits Object
C# | public sealed class TextureStateManager : Object
Managed C++ | public __gc __sealed class TextureStateManager : public Object
JScript .NET | public class TextureStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AlphaArgument0 | Defines settings for the alpha channel selector operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.
AlphaArgument1 | Defines the texture-stage state as the first alpha argument for the stage identified by the TextureArgument enumeration.
AlphaArgument2 | Defines the texture-stage state as the second alpha argument for the stage identified by the TextureArgument enumeration.
AlphaOperation | Defines the texture-stage state as a texture alpha-blending operation identified by the TextureOperation enumeration.
BumpEnvironmentLuminanceOffset | Defines a floating-point offset value for bump-map luminance.
BumpEnvironmentLuminanceScale | Defines a floating-point scale value for bump-map luminance.
BumpEnvironmentMaterial00 | Defines the texture-stage state as a floating-point value for the [0][0] coefficient in a bump-mapping matrix.
BumpEnvironmentMaterial01 | Defines the texture-stage state as a floating-point value for the [0][1] coefficient in a bump-mapping matrix.
BumpEnvironmentMaterial10 | Defines the texture-stage state as a floating-point value for the [1][0] coefficient in a bump-mapping matrix.
BumpEnvironmentMaterial11 | Defines the texture-stage state as a floating-point value for the [1][1] coefficient in a bump-mapping matrix.
ColorArgument0 | Defines settings for the third color operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.
ColorArgument1 | Defines the texture-stage state as the first color argument for the stage identified by the TextureArgument enumeration.
ColorArgument2 | Defines the texture-stage state as the second color argument for the stage identified by the TextureArgument enumeration.
ColorOperation | Defines the texture-stage state as a texture color-blending operation identified by the TextureOperation enumeration.
ConstantColor | Defines the per-stage constant color.
ConstantColorValue | Defines the per-stage constant color.
ResultArgument | Selects the destination register for the result of the current stage identified by TextureArgument.
TextureCoordinateIndex | Defines the index of the texture coordinate set to use with the current texture stage.
TextureTransform | Controls the transformation of texture coordinates for the current texture stage.

Inheritance Hierarchy

Object Leave Site
TextureStateManager

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ToString()

TextureStateManager.ToString Method

Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaArgument0

TextureStateManager.AlphaArgument0 Property

Note: This documentation is preliminary and is subject to change.

Defines settings for the alpha channel selector operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

Definition

Visual Basic .NET | Public Property AlphaArgument0 As TextureArgument
C# | public TextureArgument AlphaArgument0 { get; set; }
Managed C++ public: __property TextureArgument get_AlphaArgument0();
public: __property void set_AlphaArgument0(TextureArgument);
JScript .NET public function get AlphaArgument0() : TextureArgument
public function set AlphaArgument0(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument . A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

AlphaArgument0 is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current. To select a temporary register color for read or write, specify TextureArgument.Temp, which is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default argument is (0.0, 0.0, 0.0, 0.0).

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaArgument1

TextureStateManager.AlphaArgument1 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as the first alpha argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic .NET | Public Property AlphaArgument1 As TextureArgument
C# | public TextureArgument AlphaArgument1 { get; set; }
Managed C++ public: __property TextureArgument get_AlphaArgument1();
public: __property void set_AlphaArgument1(TextureArgument);
JScript .NET public function get AlphaArgument1() : TextureArgument
public function set AlphaArgument1(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument . A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.TextureColor. If no texture is set for this stage, the default argument is TextureArgument.Diffuse. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaArgument2

TextureStateManager.AlphaArgument2 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as the second alpha argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic .NET | Public Property AlphaArgument2 As TextureArgument
C# | public TextureArgument AlphaArgument2 { get; set; }
Managed C++ public: __property TextureArgument get_AlphaArgument2();
public: __property void set_AlphaArgument2(TextureArgument);
JScript .NET public function get AlphaArgument2() : TextureArgument
public function set AlphaArgument2(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument . A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaOperation

TextureStateManager.AlphaOperation Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as a texture alpha-blending operation identified by the TextureOperation enumeration.

Definition

Visual Basic .NET | Public Property AlphaOperation As TextureOperation
C# | public TextureOperation AlphaOperation { get; set; }
Managed C++ public: __property TextureOperation get_AlphaOperation();
public: __property void set_AlphaOperation(TextureOperation);
JScript .NET public function get AlphaOperation() : TextureOperation
public function set AlphaOperation(TextureOperation);

Property Value

Microsoft.DirectX.Direct3D.TextureOperation . A TextureOperation object that represents the current texture operation.

This property is read/write.

Remarks

The default value for the first texture stage (stage 0) is TextureOperation.SelectArg1, and for all other stages is TextureOperation.Disable.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentLuminanceOffset

TextureStateManager.BumpEnvironmentLuminanceOffset Property

Note: This documentation is preliminary and is subject to change.

Defines a floating-point offset value for bump-map luminance.

Definition

Visual Basic .NET | Public Property BumpEnvironmentLuminanceOffset As Single
C# | public float BumpEnvironmentLuminanceOffset { get; set; }
Managed C++ public: __property float get_BumpEnvironmentLuminanceOffset();
public: __property void set_BumpEnvironmentLuminanceOffset(float);
JScript .NET public function get BumpEnvironmentLuminanceOffset() : float
public function set BumpEnvironmentLuminanceOffset(float);

Property Value

System.Single . Floating-point value that represents the offset for bump-map luminance. The default value is 0.0.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentLuminanceScale

TextureStateManager.BumpEnvironmentLuminanceScale Property

Note: This documentation is preliminary and is subject to change.

Defines a floating-point scale value for bump-map luminance.

Definition

Visual Basic .NET | Public Property BumpEnvironmentLuminanceScale As Single
C# | public float BumpEnvironmentLuminanceScale { get; set; }
Managed C++ public: __property float get_BumpEnvironmentLuminanceScale();
public: __property void set_BumpEnvironmentLuminanceScale(float);
JScript .NET public function get BumpEnvironmentLuminanceScale() : float
public function set BumpEnvironmentLuminanceScale(float);

Property Value

System.Single . Floating-point value that represents the scale for bump-map luminance. The default value is 0.0.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial00

TextureStateManager.BumpEnvironmentMaterial00 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as a floating-point value for the [0][0] coefficient in a bump-mapping matrix.

Definition

Visual Basic .NET | Public Property BumpEnvironmentMaterial00 As Single
C# | public float BumpEnvironmentMaterial00 { get; set; }
Managed C++ public: __property float get_BumpEnvironmentMaterial00();
public: __property void set_BumpEnvironmentMaterial00(float);
JScript .NET public function get BumpEnvironmentMaterial00() : float
public function set BumpEnvironmentMaterial00(float);

Property Value

System.Single . Floating-point value that represents the [0][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial01

TextureStateManager.BumpEnvironmentMaterial01 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as a floating-point value for the [0][1] coefficient in a bump-mapping matrix.

Definition

Visual Basic .NET | Public Property BumpEnvironmentMaterial01 As Single
C# | public float BumpEnvironmentMaterial01 { get; set; }
Managed C++ public: __property float get_BumpEnvironmentMaterial01();
public: __property void set_BumpEnvironmentMaterial01(float);
JScript .NET public function get BumpEnvironmentMaterial01() : float
public function set BumpEnvironmentMaterial01(float);

Property Value

System.Single . Floating-point value that represents the [0][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial10

TextureStateManager.BumpEnvironmentMaterial10 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as a floating-point value for the [1][0] coefficient in a bump-mapping matrix.

Definition

Visual Basic .NET | Public Property BumpEnvironmentMaterial10 As Single
C# | public float BumpEnvironmentMaterial10 { get; set; }
Managed C++ public: __property float get_BumpEnvironmentMaterial10();
public: __property void set_BumpEnvironmentMaterial10(float);
JScript .NET public function get BumpEnvironmentMaterial10() : float
public function set BumpEnvironmentMaterial10(float);

Property Value

System.Single . Floating-point value that represents the [1][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial11

TextureStateManager.BumpEnvironmentMaterial11 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as a floating-point value for the [1][1] coefficient in a bump-mapping matrix.

Definition

Visual Basic .NET | Public Property BumpEnvironmentMaterial11 As Single
C# | public float BumpEnvironmentMaterial11 { get; set; }
Managed C++ public: __property float get_BumpEnvironmentMaterial11();
public: __property void set_BumpEnvironmentMaterial11(float);
JScript .NET public function get BumpEnvironmentMaterial11() : float
public function set BumpEnvironmentMaterial11(float);

Property Value

System.Single . Floating-point value that represents the [1][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorArgument0

TextureStateManager.ColorArgument0 Property

Note: This documentation is preliminary and is subject to change.

Defines settings for the third color operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

Definition

Visual Basic .NET | Public Property ColorArgument0 As TextureArgument
C# | public TextureArgument ColorArgument0 { get; set; }
Managed C++ public: __property TextureArgument get_ColorArgument0();
public: __property void set_ColorArgument0(TextureArgument);
JScript .NET public function get ColorArgument0() : TextureArgument
public function set ColorArgument0(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument . A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

This setting is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorArgument1

TextureStateManager.ColorArgument1 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as the first color argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic .NET | Public Property ColorArgument1 As TextureArgument
C# | public TextureArgument ColorArgument1 { get; set; }
Managed C++ public: __property TextureArgument get_ColorArgument1();
public: __property void set_ColorArgument1(TextureArgument);
JScript .NET public function get ColorArgument1() : TextureArgument
public function set ColorArgument1(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument . A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.Texture. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorArgument2

TextureStateManager.ColorArgument2 Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as the second color argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic .NET | Public Property ColorArgument2 As TextureArgument
C# | public TextureArgument ColorArgument2 { get; set; }
Managed C++ public: __property TextureArgument get_ColorArgument2();
public: __property void set_ColorArgument2(TextureArgument);
JScript .NET public function get ColorArgument2() : TextureArgument
public function set ColorArgument2(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument . A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorOperation

TextureStateManager.ColorOperation Property

Note: This documentation is preliminary and is subject to change.

Defines the texture-stage state as a texture color-blending operation identified by the TextureOperation enumeration.

Definition

Visual Basic .NET | Public Property ColorOperation As TextureOperation
C# | public TextureOperation ColorOperation { get; set; }
Managed C++ public: __property TextureOperation get_ColorOperation();
public: __property void set_ColorOperation(TextureOperation);
JScript .NET public function get ColorOperation() : TextureOperation
public function set ColorOperation(TextureOperation);

Property Value

Microsoft.DirectX.Direct3D.TextureOperation . A TextureOperation object that represents the current texture operation.

This property is read/write.

Remarks

The default value for the first texture stage (stage 0) is TextureOperation.Modulate, and for all other stages is TextureOperation.Disable.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ConstantColor

TextureStateManager.ConstantColor Property

Note: This documentation is preliminary and is subject to change.

Defines the per-stage constant color.

Definition

Visual Basic .NET | Public Property ConstantColor As Color
C# | public Color ConstantColor { get; set; }
Managed C++ public: __property Color get_ConstantColor();
public: __property void set_ConstantColor(Color);
JScript .NET public function get ConstantColor() : Color
public function set ConstantColor(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the drawing color.

This property is read/write.

Remarks

To determine whether the current device supports a per-stage constant color, use the MiscCaps.SupportsPerStageConstant property. The ConstantColor property is used by TextureArgument.Constant.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ConstantColorValue

TextureStateManager.ConstantColorValue Property

Note: This documentation is preliminary and is subject to change.

Defines the per-stage constant color.

Definition

Visual Basic .NET | Public Property ConstantColorValue As Integer
C# | public int ConstantColorValue { get; set; }
Managed C++ public: __property int get_ConstantColorValue();
public: __property void set_ConstantColorValue(int);
JScript .NET public function get ConstantColorValue() : int
public function set ConstantColorValue(int);

Property Value

System.Int32 . An Int32 Leave Site that represents the drawing color.

This property is read/write.

Remarks

To determine whether the current device supports a per-stage constant color, use the MiscCaps.SupportsPerStageConstant property. The ConstantColorValue property is used by TextureArgument.Constant.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ResultArgument

TextureStateManager.ResultArgument Property

Note: This documentation is preliminary and is subject to change.

Selects the destination register for the result of the current stage identified by TextureArgument.

Definition

Visual Basic .NET | Public Property ResultArgument As TextureArgument
C# | public TextureArgument ResultArgument { get; set; }
Managed C++ public: __property TextureArgument get_ResultArgument();
public: __property void set_ResultArgument(TextureArgument);
JScript .NET public function get ResultArgument() : TextureArgument
public function set ResultArgument(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument . A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

This value can be set to TextureArgument.Current (the default value) or to TextureArgument.Temp, which is a single temporary register that can be read into subsequent stages as an input argument. The final color passed to the fog blender and frame buffer is taken from TextureArgument.Current, so the last active texture stage state must be set to TextureArgument.Current. This setting is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.TextureCoordinateIndex

TextureStateManager.TextureCoordinateIndex Property

Note: This documentation is preliminary and is subject to change.

Defines the index of the texture coordinate set to use with the current texture stage.

Definition

Visual Basic .NET | Public Property TextureCoordinateIndex As Integer
C# | public int TextureCoordinateIndex { get; set; }
Managed C++ public: __property int get_TextureCoordinateIndex();
public: __property void set_TextureCoordinateIndex(int);
JScript .NET public function get TextureCoordinateIndex() : int
public function set TextureCoordinateIndex(int);

Property Value

System.Int32 . Index of the texture coordinate set.

This property is read/write.

Remarks

Up to eight sets of texture coordinates per vertex can be specified. If a vertex does not include a set of texture coordinates at the specified index, the system reverts to the u and v coordinates (0,0) by default.

When rendering with vertex shaders, each stage's texture coordinate index must be set to its default value. The default index for each stage is equal to the stage index. Set this state to the zero-based index of the coordinate set for each vertex that this texture stage uses.

Additionally, applications can include TextureCoordinateIndex values as part of a logical OR with the index being set, to request that Microsoft® DirectX® automatically generate the input texture coordinates for a texture transformation.

The system uses the index strictly to determine texture wrapping mode when using a TextureCoordinateIndex value other than PassThru, which resolves to zero. These flags are most useful when performing environment mapping.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.TextureTransform

TextureStateManager.TextureTransform Property

Note: This documentation is preliminary and is subject to change.

Controls the transformation of texture coordinates for the current texture stage.

Definition

Visual Basic .NET | Public Property TextureTransform As TextureTransform
C# | public TextureTransform TextureTransform { get; set; }
Managed C++ public: __property TextureTransform get_TextureTransform();
public: __property void set_TextureTransform(TextureTransform);
JScript .NET public function get TextureTransform() : TextureTransform
public function set TextureTransform(TextureTransform);

Property Value

Microsoft.DirectX.Direct3D.TextureTransform . A TextureTransform object that represents the texture-stage state values.

This property is read/write.

Remarks

The default value is TextureTransform.Disable.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.TextureStateManagerCollection

TextureStateManagerCollection Class

Note: This documentation is preliminary and is subject to change.

Collection of TextureStateManager objects.

Definition

Visual Basic .NET NotInheritable Public Class TextureStateManagerCollection
Inherits Object
C# | public sealed class TextureStateManagerCollection : Object
Managed C++ | public __gc __sealed class TextureStateManagerCollection : public Object
JScript .NET | public class TextureStateManagerCollection extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
TextureState | Retrieves the TextureStateManager object at the given index.

Inheritance Hierarchy

Object Leave Site
TextureStateManagerCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureStateManagerCollection.TextureState

TextureStateManagerCollection.TextureState Property

Note: This documentation is preliminary and is subject to change.

Retrieves the TextureStateManager object at the given index.

Definition

Visual Basic .NET Public ReadOnly Property TextureState( _
ByVal index As Integer _
) As TextureStateManager
C# public TextureStateManager this[
int index
] { get; }
Managed C++ public: __property TextureStateManager* get_TextureState(
int index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.Direct3D.TextureStateManager . A TextureStateManager object retrieved from the given index.

This property is read-only.

Parameters

index System.Int32. Integer that represents the TextureStateManager object to retrieve.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.TooManyInfluencesException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyInfluencesException Class

Language:
Note: This documentation is preliminary and is subject to change.

Too many influences specified.

Definition

Visual Basic .NET Public Class TooManyInfluencesException
Inherits Direct3DXException
C# | public class TooManyInfluencesException : Direct3DXException
Managed C++ | public __gc class TooManyInfluencesException : public Direct3DXException
JScript .NET | public class TooManyInfluencesException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooManyInfluencesException | Initializes a new instance of the TooManyInfluencesException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
TooManyInfluencesException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TooManyInfluencesException.TooManyInfluencesException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyInfluencesException class.

Overload List

public TooManyInfluencesException();
protected TooManyInfluencesException(SerializationInfo, StreamingContext);
public TooManyInfluencesException(string);
public TooManyInfluencesException(string, Exception);


TooManyInfluencesException.TooManyInfluencesException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooManyInfluencesException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TooManyInfluencesException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TooManyInfluencesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


TooManyInfluencesException.TooManyInfluencesException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooManyInfluencesException(
string message,
Exception inner
);
Managed C++ public: TooManyInfluencesException(
String *message,
Exception *inner
);
JScript .NET public function TooManyInfluencesException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


TooManyInfluencesException.TooManyInfluencesException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TooManyInfluencesException(
string message
);
Managed C++ public: TooManyInfluencesException(
String *message
);
JScript .NET public function TooManyInfluencesException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


TooManyInfluencesException.TooManyInfluencesException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public TooManyInfluencesException();
Managed C++ | public: TooManyInfluencesException();
JScript .NET | public function TooManyInfluencesException();


Microsoft.DirectX.Direct3D.TooManyOperationsException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyOperationsException Class

Language:
Note: This documentation is preliminary and is subject to change.

The application is requesting more texture-filtering operations than the device supports.

Definition

Visual Basic .NET Public Class TooManyOperationsException
Inherits GraphicsException
C# | public class TooManyOperationsException : GraphicsException
Managed C++ | public __gc class TooManyOperationsException : public GraphicsException
JScript .NET | public class TooManyOperationsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooManyOperationsException | Initializes a new instance of the TooManyOperationsException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooManyOperationsException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TooManyOperationsException.TooManyOperationsException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyOperationsException class.

Overload List

public TooManyOperationsException();
protected TooManyOperationsException(SerializationInfo, StreamingContext);
public TooManyOperationsException(string);
public TooManyOperationsException(string, Exception);


TooManyOperationsException.TooManyOperationsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooManyOperationsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TooManyOperationsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TooManyOperationsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


TooManyOperationsException.TooManyOperationsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooManyOperationsException(
string message,
Exception inner
);
Managed C++ public: TooManyOperationsException(
String *message,
Exception *inner
);
JScript .NET public function TooManyOperationsException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


TooManyOperationsException.TooManyOperationsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TooManyOperationsException(
string message
);
Managed C++ public: TooManyOperationsException(
String *message
);
JScript .NET public function TooManyOperationsException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


TooManyOperationsException.TooManyOperationsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public TooManyOperationsException();
Managed C++ | public: TooManyOperationsException();
JScript .NET | public function TooManyOperationsException();


Microsoft.DirectX.Direct3D.Transforms

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms Class

Language:
Note: This documentation is preliminary and is subject to change.

Allows applications to specify and obtain matrix transformations; for example, the world, view, and transformation matrices used for Microsoft® Direct3D® object rendering.

Definition

Visual Basic .NET NotInheritable Public Class Transforms
Inherits Object
C# | public sealed class Transforms : Object
Managed C++ | public __gc __sealed class Transforms : public Object
JScript .NET | public class Transforms extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetWorldMatrixByIndex | Retrieves a world matrix transform by its index.
SetWorldMatrixByIndex | Sets the world matrix by its index.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Projection | Retrieves or sets the projection transformation Matrix.
Texture0 | Retrieves or sets the Texture0 transformation Matrix.
Texture1 | Retrieves or sets the Texture1 transformation Matrix.
Texture2 | Retrieves or sets the Texture2 transformation Matrix.
Texture3 | Retrieves or sets the Texture3 transformation Matrix.
Texture4 | Retrieves or sets the Texture4 transformation Matrix.
Texture5 | Retrieves or sets the Texture5 transformation Matrix.
Texture6 | Retrieves or sets the Texture6 transformation Matrix.
Texture7 | Retrieves or sets the Texture7 transformation Matrix.
View | Retrieves or sets the view transformation matrix.
World | Retrieves or sets the first world matrix.
World1 | Retrieves or sets the second world matrix.
World2 | Retrieves or sets the third world matrix.
World3 | Retrieves or sets the fourth world matrix.

Inheritance Hierarchy

Object Leave Site
Transforms

Remarks

An instance of this class is stored in the Device.Transform property, which is typically used to manipulate matrices. For instance, the following line of C# code moves the View transform back five units, points the view at the origin, and defines "up" as the y-direction.

[C#]

device.Transform.View = Matrix.LookAtLH(
            new Vector3( 0.0f, 3.0f,-5.0f ),
                        new Vector3( 0.0f, 0.0f, 0.0f ),
                        new Vector3( 0.0f, 1.0f, 0.0f ) );

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Tutorial 3: Using Matrices
  • GetTransform
  • SetTransform


Transforms.GetWorldMatrixByIndex(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.GetWorldMatrixByIndex Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a world matrix transform by its index.

Definition

Visual Basic .NET Public Function GetWorldMatrixByIndex( _
ByVal index As Integer _
) As Matrix
C# public Matrix GetWorldMatrixByIndex(
int index
);
Managed C++ public: Matrix GetWorldMatrixByIndex(
int index
);
JScript .NET public function GetWorldMatrixByIndex(
index : int
) : Matrix;

Parameters

index System.Int32. Value between 0 and 255 that indicates the index of the world matrix to retrieve.

Return Value

Microsoft.DirectX.Matrix .

See Also

  • GetTransform


Transforms.SetWorldMatrixByIndex(Int32,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.SetWorldMatrixByIndex Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the world matrix by its index.

Definition

Visual Basic .NET Public Sub SetWorldMatrixByIndex( _
ByVal index As Integer, _
ByVal value As Matrix _
)
C# public void SetWorldMatrixByIndex(
int index,
Matrix value
);
Managed C++ public: void SetWorldMatrixByIndex(
int index,
Matrix value
);
JScript .NET public function SetWorldMatrixByIndex(
index : int,
value : Matrix
);

Parameters

index | System.Int32. Value between 0 and 255 that indicates the index of the world matrix to set.
value | Microsoft.DirectX.Matrix. A Matrix value to which the specified world matrix is set.

See Also

  • SetTransform


Transforms.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Transforms.Projection

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Projection Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Set Up a Projection Matrix

Retrieves or sets the projection transformation Matrix.

Definition

Visual Basic .NET | Public Property Projection As Matrix
C# | public Matrix Projection { get; set; }
Managed C++ public: __property Matrix get_Projection();
public: __property void set_Projection(Matrix);
JScript .NET public function get Projection() : Matrix
public function set Projection(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

Remarks

The default projection transformation Matrix is the identity Matrix.

How Do I...?

Set Up a Projection Matrix

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

              [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );

See Also

  • SetTransform


Transforms.Texture0

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture0 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture0 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture0 As Matrix
C# | public Matrix Texture0 { get; set; }
Managed C++ public: __property Matrix get_Texture0();
public: __property void set_Texture0(Matrix);
JScript .NET public function get Texture0() : Matrix
public function set Texture0(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture1

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture1 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture1 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture1 As Matrix
C# | public Matrix Texture1 { get; set; }
Managed C++ public: __property Matrix get_Texture1();
public: __property void set_Texture1(Matrix);
JScript .NET public function get Texture1() : Matrix
public function set Texture1(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture2

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture2 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture2 As Matrix
C# | public Matrix Texture2 { get; set; }
Managed C++ public: __property Matrix get_Texture2();
public: __property void set_Texture2(Matrix);
JScript .NET public function get Texture2() : Matrix
public function set Texture2(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture3

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture3 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture3 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture3 As Matrix
C# | public Matrix Texture3 { get; set; }
Managed C++ public: __property Matrix get_Texture3();
public: __property void set_Texture3(Matrix);
JScript .NET public function get Texture3() : Matrix
public function set Texture3(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture4

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture4 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture4 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture4 As Matrix
C# | public Matrix Texture4 { get; set; }
Managed C++ public: __property Matrix get_Texture4();
public: __property void set_Texture4(Matrix);
JScript .NET public function get Texture4() : Matrix
public function set Texture4(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture5

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture5 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture5 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture5 As Matrix
C# | public Matrix Texture5 { get; set; }
Managed C++ public: __property Matrix get_Texture5();
public: __property void set_Texture5(Matrix);
JScript .NET public function get Texture5() : Matrix
public function set Texture5(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture6

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture6 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture6 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture6 As Matrix
C# | public Matrix Texture6 { get; set; }
Managed C++ public: __property Matrix get_Texture6();
public: __property void set_Texture6(Matrix);
JScript .NET public function get Texture6() : Matrix
public function set Texture6(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture7

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.Texture7 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Texture7 transformation Matrix.

Definition

Visual Basic .NET | Public Property Texture7 As Matrix
C# | public Matrix Texture7 { get; set; }
Managed C++ public: __property Matrix get_Texture7();
public: __property void set_Texture7(Matrix);
JScript .NET public function get Texture7() : Matrix
public function set Texture7(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.View

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.View Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Set Up a View Matrix

Retrieves or sets the view transformation matrix.

Definition

Visual Basic .NET | Public Property View As Matrix
C# | public Matrix View { get; set; }
Managed C++ public: __property Matrix get_View();
public: __property void set_View(Matrix);
JScript .NET public function get View() : Matrix
public function set View(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

Remarks

The default view transformation matrix is the identity matrix.

How Do I...?

Set Up a View Matrix

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

              [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));

See Also

  • GetTransform
  • SetTransform


Transforms.World

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.World Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the first world matrix.

Definition

Visual Basic .NET | Public Property World As Matrix
C# | public Matrix World { get; set; }
Managed C++ public: __property Matrix get_World();
public: __property void set_World(Matrix);
JScript .NET public function get World() : Matrix
public function set World(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.World1

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.World1 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the second world matrix.

Definition

Visual Basic .NET | Public Property World1 As Matrix
C# | public Matrix World1 { get; set; }
Managed C++ public: __property Matrix get_World1();
public: __property void set_World1(Matrix);
JScript .NET public function get World1() : Matrix
public function set World1(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.World2

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.World2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the third world matrix.

Definition

Visual Basic .NET | Public Property World2 As Matrix
C# | public Matrix World2 { get; set; }
Managed C++ public: __property Matrix get_World2();
public: __property void set_World2(Matrix);
JScript .NET public function get World2() : Matrix
public function set World2(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.World3

Microsoft DirectX 9.0 SDK Update (October 2004)

Transforms.World3 Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the fourth world matrix.

Definition

Visual Basic .NET | Public Property World3 As Matrix
C# | public Matrix World3 { get; set; }
Managed C++ public: __property Matrix get_World3();
public: __property void set_World3(Matrix);
JScript .NET public function get World3() : Matrix
public function set World3(Matrix);

Property Value

Microsoft.DirectX.Matrix .

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Microsoft.DirectX.Direct3D.UnsupportedAlphaArgumentException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaArgumentException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device does not support a specified texture-blending argument for the alpha channel.

Definition

Visual Basic .NET Public Class UnsupportedAlphaArgumentException
Inherits GraphicsException
C# | public class UnsupportedAlphaArgumentException : GraphicsException
Managed C++ | public __gc class UnsupportedAlphaArgumentException : public GraphicsException
JScript .NET | public class UnsupportedAlphaArgumentException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedAlphaArgumentException | Initializes a new instance of the UnsupportedAlphaArgumentException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedAlphaArgumentException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Overload List

public UnsupportedAlphaArgumentException();
protected UnsupportedAlphaArgumentException(SerializationInfo, StreamingContext);
public UnsupportedAlphaArgumentException(string);
public UnsupportedAlphaArgumentException(string, Exception);


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedAlphaArgumentException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedAlphaArgumentException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedAlphaArgumentException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedAlphaArgumentException(
string message,
Exception inner
);
Managed C++ public: UnsupportedAlphaArgumentException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedAlphaArgumentException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedAlphaArgumentException(
string message
);
Managed C++ public: UnsupportedAlphaArgumentException(
String *message
);
JScript .NET public function UnsupportedAlphaArgumentException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedAlphaArgumentException();
Managed C++ | public: UnsupportedAlphaArgumentException();
JScript .NET | public function UnsupportedAlphaArgumentException();


Microsoft.DirectX.Direct3D.UnsupportedAlphaOperationException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaOperationException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device does not support a specified texture-blending operation for the alpha channel.

Definition

Visual Basic .NET Public Class UnsupportedAlphaOperationException
Inherits GraphicsException
C# | public class UnsupportedAlphaOperationException : GraphicsException
Managed C++ | public __gc class UnsupportedAlphaOperationException : public GraphicsException
JScript .NET | public class UnsupportedAlphaOperationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedAlphaOperationException | Initializes a new instance of the UnsupportedAlphaOperationException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedAlphaOperationException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaOperationException class.

Overload List

public UnsupportedAlphaOperationException();
protected UnsupportedAlphaOperationException(SerializationInfo, StreamingContext);
public UnsupportedAlphaOperationException(string);
public UnsupportedAlphaOperationException(string, Exception);


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedAlphaOperationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedAlphaOperationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedAlphaOperationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedAlphaOperationException(
string message,
Exception inner
);
Managed C++ public: UnsupportedAlphaOperationException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedAlphaOperationException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedAlphaOperationException(
string message
);
Managed C++ public: UnsupportedAlphaOperationException(
String *message
);
JScript .NET public function UnsupportedAlphaOperationException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedAlphaOperationException();
Managed C++ | public: UnsupportedAlphaOperationException();
JScript .NET | public function UnsupportedAlphaOperationException();


Microsoft.DirectX.Direct3D.UnsupportedColorArgumentException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorArgumentException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device does not support a specified texture-blending argument for color values.

Definition

Visual Basic .NET Public Class UnsupportedColorArgumentException
Inherits GraphicsException
C# | public class UnsupportedColorArgumentException : GraphicsException
Managed C++ | public __gc class UnsupportedColorArgumentException : public GraphicsException
JScript .NET | public class UnsupportedColorArgumentException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedColorArgumentException | Initializes a new instance of the UnsupportedColorArgumentException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedColorArgumentException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedColorArgumentException.UnsupportedColorArgumentException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorArgumentException class.

Overload List

public UnsupportedColorArgumentException();
protected UnsupportedColorArgumentException(SerializationInfo, StreamingContext);
public UnsupportedColorArgumentException(string);
public UnsupportedColorArgumentException(string, Exception);


UnsupportedColorArgumentException.UnsupportedColorArgumentException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedColorArgumentException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedColorArgumentException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedColorArgumentException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedColorArgumentException.UnsupportedColorArgumentException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedColorArgumentException(
string message,
Exception inner
);
Managed C++ public: UnsupportedColorArgumentException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedColorArgumentException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedColorArgumentException.UnsupportedColorArgumentException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedColorArgumentException(
string message
);
Managed C++ public: UnsupportedColorArgumentException(
String *message
);
JScript .NET public function UnsupportedColorArgumentException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


UnsupportedColorArgumentException.UnsupportedColorArgumentException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedColorArgumentException();
Managed C++ | public: UnsupportedColorArgumentException();
JScript .NET | public function UnsupportedColorArgumentException();


Microsoft.DirectX.Direct3D.UnsupportedColorOperationException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorOperationException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device does not support a specified texture-blending operation for color values.

Definition

Visual Basic .NET Public Class UnsupportedColorOperationException
Inherits GraphicsException
C# | public class UnsupportedColorOperationException : GraphicsException
Managed C++ | public __gc class UnsupportedColorOperationException : public GraphicsException
JScript .NET | public class UnsupportedColorOperationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedColorOperationException | Initializes a new instance of the UnsupportedColorOperationException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedColorOperationException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedColorOperationException.UnsupportedColorOperationException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorOperationException class.

Overload List

public UnsupportedColorOperationException();
protected UnsupportedColorOperationException(SerializationInfo, StreamingContext);
public UnsupportedColorOperationException(string);
public UnsupportedColorOperationException(string, Exception);


UnsupportedColorOperationException.UnsupportedColorOperationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedColorOperationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedColorOperationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedColorOperationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedColorOperationException.UnsupportedColorOperationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedColorOperationException(
string message,
Exception inner
);
Managed C++ public: UnsupportedColorOperationException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedColorOperationException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedColorOperationException.UnsupportedColorOperationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedColorOperationException(
string message
);
Managed C++ public: UnsupportedColorOperationException(
String *message
);
JScript .NET public function UnsupportedColorOperationException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


UnsupportedColorOperationException.UnsupportedColorOperationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedColorOperationException();
Managed C++ | public: UnsupportedColorOperationException();
JScript .NET | public function UnsupportedColorOperationException();


Microsoft.DirectX.Direct3D.UnsupportedFactorValueException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFactorValueException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device does not support the specified texture factor value. Not used; provided only to support older drivers.

Definition

Visual Basic .NET Public Class UnsupportedFactorValueException
Inherits GraphicsException
C# | public class UnsupportedFactorValueException : GraphicsException
Managed C++ | public __gc class UnsupportedFactorValueException : public GraphicsException
JScript .NET | public class UnsupportedFactorValueException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedFactorValueException | Initializes a new instance of the UnsupportedFactorValueException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedFactorValueException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedFactorValueException.UnsupportedFactorValueException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedFactorValueException class.

Overload List

public UnsupportedFactorValueException();
protected UnsupportedFactorValueException(SerializationInfo, StreamingContext);
public UnsupportedFactorValueException(string);
public UnsupportedFactorValueException(string, Exception);


UnsupportedFactorValueException.UnsupportedFactorValueException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedFactorValueException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedFactorValueException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedFactorValueException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedFactorValueException.UnsupportedFactorValueException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedFactorValueException(
string message,
Exception inner
);
Managed C++ public: UnsupportedFactorValueException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedFactorValueException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedFactorValueException.UnsupportedFactorValueException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedFactorValueException(
string message
);
Managed C++ public: UnsupportedFactorValueException(
String *message
);
JScript .NET public function UnsupportedFactorValueException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


UnsupportedFactorValueException.UnsupportedFactorValueException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedFactorValueException();
Managed C++ | public: UnsupportedFactorValueException();
JScript .NET | public function UnsupportedFactorValueException();


Microsoft.DirectX.Direct3D.UnsupportedTextureFilterException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedTextureFilterException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device does not support the specified texture filter.

Definition

Visual Basic .NET Public Class UnsupportedTextureFilterException
Inherits GraphicsException
C# | public class UnsupportedTextureFilterException : GraphicsException
Managed C++ | public __gc class UnsupportedTextureFilterException : public GraphicsException
JScript .NET | public class UnsupportedTextureFilterException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedTextureFilterException | Initializes a new instance of the UnsupportedTextureFilterException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedTextureFilterException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedTextureFilterException.UnsupportedTextureFilterException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedTextureFilterException class.

Overload List

public UnsupportedTextureFilterException();
protected UnsupportedTextureFilterException(SerializationInfo, StreamingContext);
public UnsupportedTextureFilterException(string);
public UnsupportedTextureFilterException(string, Exception);


UnsupportedTextureFilterException.UnsupportedTextureFilterException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedTextureFilterException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedTextureFilterException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedTextureFilterException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedTextureFilterException.UnsupportedTextureFilterException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedTextureFilterException(
string message,
Exception inner
);
Managed C++ public: UnsupportedTextureFilterException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedTextureFilterException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedTextureFilterException.UnsupportedTextureFilterException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedTextureFilterException(
string message
);
Managed C++ public: UnsupportedTextureFilterException(
String *message
);
JScript .NET public function UnsupportedTextureFilterException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


UnsupportedTextureFilterException.UnsupportedTextureFilterException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedTextureFilterException();
Managed C++ | public: UnsupportedTextureFilterException();
JScript .NET | public function UnsupportedTextureFilterException();


Microsoft.DirectX.Direct3D.VertexBuffer

VertexBuffer Class

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams
  • Read and Write VertexBuffer Data With Arrays

Manipulates vertex buffer resources.

Definition

Visual Basic .NET NotInheritable Public Class VertexBuffer
Inherits Resource
Implements IDisposable
C# public sealed class VertexBuffer : Resource,
IDisposable
Managed C++ public __gc __sealed class VertexBuffer : public Resource,
IDisposable
JScript .NET public class VertexBuffer extends Resource
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Created | Occurs after a device is reset and the VertexBuffer is re-created.
Disposing | Occurs when the Dispose method is called or when the VertexBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the VertexBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object. Inherited from Resource.
Finalize | Allows the VertexBuffer object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GetHashCode | Returns the hash code for the current instance. Inherited from Resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
Lock | Locks a range of vertex data and obtains the vertex buffer memory.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Created | Raises a VertexBuffer.Created event when called from within a derived class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VertexBuffer.Disposing event when called from within a derived class.
SetData | Locks, sets, and unlocks a range of vertex data.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Unlock | Unlocks vertex data.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this VertexBuffer object. This method supports the Framework infrastructure and is not intended to be used directly in your code.
VertexBuffer | Creates a new instance of the VertexBuffer class.

Properties

Property | Description
Description | Retrieves a description of the vertex buffer resource.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
SizeInBytes | Retrieves the size of the VertexBuffer data, in bytes.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DVertexBuffer9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
VertexBuffer

Remarks

This object inherits additional functionality from the Resource object.

How Do I...?

Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Read and Write VertexBuffer Data With Arrays

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a FVF type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft Direct3D® resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


VertexBuffer.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the VertexBuffer object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VertexBuffer.Disposed
  • Microsoft.DirectX.Direct3D.VertexBuffer.Disposing


VertexBuffer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the VertexBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~VertexBuffer();
Managed C++ | ~VertexBuffer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


VertexBuffer.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVertexBuffer9, which allows unmanaged COM clients to create an instance of the managed VertexBuffer class. Not supported.


VertexBuffer.Lock

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Overload List

public GraphicsStream Lock(int, int, LockFlags);
public Array Lock(int, LockFlags);
public Array Lock(int, Type, LockFlags, int[]);

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.Lock(Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Definition

Visual Basic .NET Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal flags As LockFlags _
) As Array
C# public Array Lock(
int offsetToLock,
LockFlags flags
);
Managed C++ public: Array* Lock(
int offsetToLock,
LockFlags flags
);
JScript .NET public function Lock(
offsetToLock : int,
flags : LockFlags
) : Array;

Parameters

offsetToLock | System.Int32. Offset into the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

System.Array . An Array Leave Site that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.Lock(Int32,Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Definition

Visual Basic .NET Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal sizeToLock As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
Managed C++ public: GraphicsStream* Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
JScript .NET public function Lock(
offsetToLock : int,
sizeToLock : int,
flags : LockFlags
) : GraphicsStream;

Parameters

offsetToLock | System.Int32. Offset into the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
sizeToLock | System.Int32. Size of the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.Lock(Int32,Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Definition

Visual Basic .NET Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal typeVertex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array Lock(
int offsetToLock,
Type typeVertex,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* Lock(
int offsetToLock,
Type *typeVertex,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function Lock(
offsetToLock : int,
typeVertex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

offsetToLock | System.Int32. Offset into the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
typeVertex | System.Type. A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.raise_Created(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.raise_Created Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a VertexBuffer.Created event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Created( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Created(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Created(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Created(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass into the event handler.


VertexBuffer.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.VertexBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


VertexBuffer.SetData(Object,Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.SetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks, sets, and unlocks a range of vertex data.

Definition

Visual Basic .NET Public Sub SetData( _
ByVal data As Object, _
ByVal lockAtOffset As Integer, _
ByVal flags As LockFlags _
)
C# public void SetData(
object data,
int lockAtOffset,
LockFlags flags
);
Managed C++ public: void SetData(
Object *data,
int lockAtOffset,
LockFlags flags
);
JScript .NET public function SetData(
data : Object,
lockAtOffset : int,
flags : LockFlags
);

Parameters

data | System.Object. An Object Leave Site that contains the data to copy into the vertex buffer. This can be any value type or any type that contains only value types.
lockAtOffset | System.Int32. Offset in the vertex buffer to set. To set the entire buffer, set this parameter to 0.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more LockFlags locking flags that describe the type of lock to perform when setting the buffer. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Remarks

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexBuffer.Unlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Unlock Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Unlocks vertex data.

Definition

Visual Basic .NET | Public Sub Unlock()
C# | public void Unlock();
Managed C++ | public: void Unlock();
JScript .NET | public function Unlock();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


VertexBuffer.UpdateUnmanagedPointer(IDirect3DVertexBuffer9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this VertexBuffer object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVertexBuffer9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVertexBuffer9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DVertexBuffer9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DVertexBuffer9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9. Pointer to the IDirect3DVertexBuffer9 structure used to update the unmanaged pointer for this VertexBuffer object.


VertexBuffer.VertexBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.VertexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexBuffer class.

Overload List

public VertexBuffer(Device, int, Usage, VertexFormats, Pool);
public VertexBuffer(IDirect3DVertexBuffer9);
public VertexBuffer(IDirect3DVertexBuffer9, Device, Usage, VertexFormats, Pool);
public VertexBuffer(IDirect3DVertexBuffer9, Type, int, Device, Usage, VertexFormats, Pool);
public VertexBuffer(IntPtr);
public VertexBuffer(Type, int, Device, Usage, VertexFormats, Pool);

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IDirect3DVertexBuffer9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.VertexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As IDirect3DVertexBuffer9 _
)
C# public VertexBuffer(
IDirect3DVertexBuffer9 pInterop
);
Managed C++ public: VertexBuffer(
IDirect3DVertexBuffer9 pInterop
);
JScript .NET public function VertexBuffer(
pInterop : IDirect3DVertexBuffer9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9. Unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.VertexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VertexBuffer(
IntPtr unmanagedObject
);
Managed C++ public: VertexBuffer(
IntPtr unmanagedObject
);
JScript .NET public function VertexBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IDirect3DVertexBuffer9,Type,Int32,Device,Usage,VertexFormats,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.VertexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DVertexBuffer9, _
ByVal tType As Type, _
ByVal iNumVerts As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal Pool As Pool _
)
C# public VertexBuffer(
IDirect3DVertexBuffer9 lp,
Type tType,
int iNumVerts,
Device device,
Usage usage,
VertexFormats vertexFormat,
Pool Pool
);
Managed C++ public: VertexBuffer(
IDirect3DVertexBuffer9 lp,
Type *tType,
int iNumVerts,
Device *device,
Usage usage,
VertexFormats vertexFormat,
Pool Pool
);
JScript .NET public function VertexBuffer(
lp : IDirect3DVertexBuffer9,
tType : Type,
iNumVerts : int,
device : Device,
usage : Usage,
vertexFormat : VertexFormats,
Pool : Pool
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9. Unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.
tType | System.Type.
iNumVerts | System.Int32.
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the vertex buffer.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
Pool | Microsoft.DirectX.Direct3D.Pool.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IDirect3DVertexBuffer9,Device,Usage,VertexFormats,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.VertexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DVertexBuffer9, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal pool As Pool _
)
C# public VertexBuffer(
IDirect3DVertexBuffer9 lp,
Device device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
Managed C++ public: VertexBuffer(
IDirect3DVertexBuffer9 lp,
Device *device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
JScript .NET public function VertexBuffer(
lp : IDirect3DVertexBuffer9,
device : Device,
usage : Usage,
vertexFormat : VertexFormats,
pool : Pool
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9. Unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the vertex buffer.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes a valid memory class in which to place the resource.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(Device,Int32,Usage,VertexFormats,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.VertexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal sizeOfBufferInBytes As Integer, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal pool As Pool _
)
C# public VertexBuffer(
Device device,
int sizeOfBufferInBytes,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
Managed C++ public: VertexBuffer(
Device *device,
int sizeOfBufferInBytes,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
JScript .NET public function VertexBuffer(
device : Device,
sizeOfBufferInBytes : int,
usage : Usage,
vertexFormat : VertexFormats,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the vertex buffer.
sizeOfBufferInBytes | System.Int32. Size of the vertex buffer in bytes. If param_VertexFormats_vertexFormat is set to 0, param_Int32_sizeOfBufferInBytes must be large enough to contain at least one vertex, but it need not be a multiple of the vertex size. If param_VertexFormats_vertexFormat is not set to 0, param_Int32_sizeOfBufferInBytes is not validated. See Remarks.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes a valid memory class in which to place the resource.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(Type,Int32,Device,Usage,VertexFormats,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.VertexBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal typeVertexType As Type, _
ByVal numVerts As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal pool As Pool _
)
C# public VertexBuffer(
Type typeVertexType,
int numVerts,
Device device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
Managed C++ public: VertexBuffer(
Type *typeVertexType,
int numVerts,
Device *device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
JScript .NET public function VertexBuffer(
typeVertexType : Type,
numVerts : int,
device : Device,
usage : Usage,
vertexFormat : VertexFormats,
pool : Pool
);

Parameters

typeVertexType | System.Type. Member of the Type Leave Site enumerated type that indicates the type of vertex data the buffer holds. This can be a value type or any type that contains only value types.
numVerts | System.Int32. Maximum number of vertices the buffer can hold.
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the vertex buffer.
usage | Microsoft.DirectX.Direct3D.Usage. Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat | Microsoft.DirectX.Direct3D.VertexFormats. Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes a valid memory class in which to place the resource.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a description of the vertex buffer resource.

Definition

Visual Basic .NET | Public ReadOnly Property Description As VertexBufferDescription
C# | public VertexBufferDescription Description { get; }
Managed C++ | public: __property VertexBufferDescription get_Description();
JScript .NET | public function get Description() : VertexBufferDescription

Property Value

Microsoft.DirectX.Direct3D.VertexBufferDescription . A VertexBufferDescription structure that describes the returned vertex buffer.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexBuffer.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


VertexBuffer.SizeInBytes

VertexBuffer.SizeInBytes Property

Note: This documentation is preliminary and is subject to change.

Retrieves the size of the VertexBuffer data, in bytes.

Definition

Visual Basic .NET | Public ReadOnly Property SizeInBytes As Integer
C# | public int SizeInBytes { get; }
Managed C++ | public: __property int get_SizeInBytes();
JScript .NET | public function get SizeInBytes() : int

Property Value

System.Int32 . The size of the VertexBuffer data, in bytes.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


VertexBuffer.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DVertexBuffer9
C# | public IDirect3DVertexBuffer9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DVertexBuffer9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DVertexBuffer9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9 . Unmanaged IDirect3DVertexBuffer9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


VertexBuffer.Created

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Created Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs after a device is reset and the VertexBuffer is re-created.

Definition

Visual Basic .NET | Public Event Created As EventHandler
C# | public event EventHandler Created;
Managed C++ | public: __event EventHandler Created;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

Note: This event occurs only on Pool.Default resources.

To add an event handler that listens for a VertexBuffer.Created event, use the following C# code.

[C#]
vBuffer.Created += new System.EventHandler(this.CreatedEventHandler);


VertexBuffer.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBuffer.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the VertexBuffer object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VertexBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VertexBuffer object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.VertexDeclaration

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Vertex Declaration

Encapsulates the vertex shader declaration.

Definition

Visual Basic .NET NotInheritable Public Class VertexDeclaration
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class VertexDeclaration : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class VertexDeclaration : public MarshalByRefObject,
IDisposable
JScript .NET public class VertexDeclaration extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the VertexDeclaration object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the VertexDeclaration object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the VertexDeclaration object to free resources before it is destroyed by the garbage collector.
GetDeclaration | Gets the vertex shader declaration.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this VertexDeclaration object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
VertexDeclaration | Creates a new instance of the VertexDeclaration class.

Properties

Property | Description
Device | Retrieves the Device used to create the current vertex declaration.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
VertexDeclaration

Remarks

A vertex shader declaration is made up of an array of vertex elements.

How Do I...?

Create a Vertex Declaration

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexDeclaration.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the VertexDeclaration object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VertexDeclaration.Disposed
  • Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing


VertexDeclaration.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


VertexDeclaration.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the VertexDeclaration object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~VertexDeclaration();
Managed C++ | ~VertexDeclaration();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


VertexDeclaration.GetDeclaration()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.GetDeclaration Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets the vertex shader declaration.

Definition

Visual Basic .NET | Public Function GetDeclaration() As VertexElement()
C# | public VertexElement[] GetDeclaration();
Managed C++ | public: VertexElement GetDeclaration() __gc[];
JScript .NET | public function GetDeclaration() : VertexElement[];

Return Value

Microsoft.DirectX.Direct3D.VertexElement[]. Array of vertex elements that make up a vertex shader declaration. The array ends with the value in the VertexDeclarationEnd field.

Remarks

The size of the array includes the VertexDeclarationEnd field, which ends the declaration. This means that the array count is actually higher than the number of valid vertex elements by one.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexDeclaration.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


VertexDeclaration.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVertexDeclaration9, which allows unmanaged COM clients to create an instance of the managed VertexDeclaration class. Not supported.


VertexDeclaration.op_Equality(VertexDeclaration,VertexDeclaration)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As VertexDeclaration, _
ByVal right As VertexDeclaration _
) As Boolean
C# public static bool op_Equality(
VertexDeclaration left,
VertexDeclaration right
);
Managed C++ public: static bool op_Equality(
VertexDeclaration *left,
VertexDeclaration *right
);
JScript .NET public static function op_Equality(
left : VertexDeclaration,
right : VertexDeclaration
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.VertexDeclaration. The VertexDeclaration object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.VertexDeclaration. The VertexDeclaration object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


VertexDeclaration.op_Inequality(VertexDeclaration,VertexDeclaration)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As VertexDeclaration, _
ByVal right As VertexDeclaration _
) As Boolean
C# public static bool op_Inequality(
VertexDeclaration left,
VertexDeclaration right
);
Managed C++ public: static bool op_Inequality(
VertexDeclaration *left,
VertexDeclaration *right
);
JScript .NET public static function op_Inequality(
left : VertexDeclaration,
right : VertexDeclaration
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.VertexDeclaration. The VertexDeclaration object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.VertexDeclaration. The VertexDeclaration object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


VertexDeclaration.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


VertexDeclaration.UpdateUnmanagedPointer(IDirect3DVertexDeclaration9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this VertexDeclaration object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVertexDeclaration9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVertexDeclaration9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DVertexDeclaration9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DVertexDeclaration9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9. Pointer to the IDirect3DVertexDeclaration9 structure used to update the unmanaged pointer for this VertexDeclaration object.


VertexDeclaration.VertexDeclaration

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.VertexDeclaration Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexDeclaration class.

Overload List

public VertexDeclaration(Device, GraphicsStream);
public VertexDeclaration(Device, VertexElement[]);
public VertexDeclaration(IDirect3DVertexDeclaration9);
public VertexDeclaration(IDirect3DVertexDeclaration9, Device);
public VertexDeclaration(IntPtr);


VertexDeclaration.VertexDeclaration(IDirect3DVertexDeclaration9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.VertexDeclaration Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DVertexDeclaration9 _
)
C# public VertexDeclaration(
IDirect3DVertexDeclaration9 pUnk
);
Managed C++ public: VertexDeclaration(
IDirect3DVertexDeclaration9 pUnk
);
JScript .NET public function VertexDeclaration(
pUnk : IDirect3DVertexDeclaration9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9. Unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.


VertexDeclaration.VertexDeclaration(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.VertexDeclaration Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VertexDeclaration(
IntPtr unmanagedObject
);
Managed C++ public: VertexDeclaration(
IntPtr unmanagedObject
);
JScript .NET public function VertexDeclaration(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


VertexDeclaration.VertexDeclaration(IDirect3DVertexDeclaration9,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.VertexDeclaration Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DVertexDeclaration9, _
ByVal device As Device _
)
C# public VertexDeclaration(
IDirect3DVertexDeclaration9 lp,
Device device
);
Managed C++ public: VertexDeclaration(
IDirect3DVertexDeclaration9 lp,
Device *device
);
JScript .NET public function VertexDeclaration(
lp : IDirect3DVertexDeclaration9,
device : Device
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9. Unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the VertexDeclaration.


VertexDeclaration.VertexDeclaration(Device,VertexElement[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.VertexDeclaration Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal vertexElements() As VertexElement _
)
C# public VertexDeclaration(
Device device,
VertexElement[] vertexElements
);
Managed C++ public: VertexDeclaration(
Device *device,
VertexElement vertexElements __gc[]
);
JScript .NET public function VertexDeclaration(
device : Device,
vertexElements : VertexElement[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the VertexDeclaration.
vertexElements | Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement flags that make up a vertex shader declaration. The array must end with the value in the VertexElement.VertexDeclarationEnd field.


VertexDeclaration.VertexDeclaration(Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.VertexDeclaration Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal vertexElements As GraphicsStream _
)
C# public VertexDeclaration(
Device device,
GraphicsStream vertexElements
);
Managed C++ public: VertexDeclaration(
Device *device,
GraphicsStream *vertexElements
);
JScript .NET public function VertexDeclaration(
device : Device,
vertexElements : GraphicsStream
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. The Device object to associate with the VertexDeclaration.
vertexElements | Microsoft.DirectX.GraphicsStream. A GraphicsStream object containing VertexElement flags that make up a vertex shader declaration.


VertexDeclaration.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Device used to create the current vertex declaration.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . Device used to create the vertex declaration.

This property is read-only.


VertexDeclaration.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


VertexDeclaration.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DVertexDeclaration9
C# | public IDirect3DVertexDeclaration9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DVertexDeclaration9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DVertexDeclaration9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9 . Unmanaged IDirect3DVertexDeclaration9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


VertexDeclaration.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexDeclaration.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the VertexDeclaration object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VertexDeclaration object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.VertexInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexInformation Class

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves vertex information.

Definition

Visual Basic .NET NotInheritable Public Class VertexInformation
Inherits Object
C# | public sealed class VertexInformation : Object
Managed C++ | public __gc __sealed class VertexInformation : public Object
JScript .NET | public class VertexInformation extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) DeclaratorFromFormat | Returns a declaration from a vertex format.
static (Shared in Visual Basic .NET) FormatFromDeclarator | Returns a VertexFormats structure from a declaration.
static (Shared in Visual Basic .NET) GenerateDeclaration | Generates an output vertex declaration from the input declaration.
static (Shared in Visual Basic .NET) GetDeclarationVertexSize | Returns the size of the vertex declaration for a flexible vertex format (FVF).
static (Shared in Visual Basic .NET) GetFormatSize | Returns the size of the vertex format.

Inheritance Hierarchy

Object Leave Site
VertexInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexInformation.DeclaratorFromFormat(VertexFormats)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexInformation.DeclaratorFromFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a declaration from a vertex format.

Definition

Visual Basic .NET Public Shared Function DeclaratorFromFormat( _
ByVal vertexFormat As VertexFormats _
) As VertexElement()
C# public static VertexElement[] DeclaratorFromFormat(
VertexFormats vertexFormat
);
Managed C++ public: static VertexElement DeclaratorFromFormat(
VertexFormats vertexFormat
) __gc[];
JScript .NET public static function DeclaratorFromFormat(
vertexFormat : VertexFormats
) : VertexElement[];

Parameters

vertexFormat Microsoft.DirectX.Direct3D.VertexFormats. One or more VertexFormats flags that describe the vertex format from which to generate the returned declaration array.

Return Value

Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that describe the vertex format of the mesh vertices.

Remarks

Exceptions
InvalidMeshException The mesh is invalid.

See Also

  • FormatFromDeclarator


VertexInformation.FormatFromDeclarator(VertexElement[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexInformation.FormatFromDeclarator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a VertexFormats structure from a declaration.

Definition

Visual Basic .NET Public Shared Function FormatFromDeclarator( _
ByVal declarator() As VertexElement _
) As VertexFormats
C# public static VertexFormats FormatFromDeclarator(
VertexElement[] declarator
);
Managed C++ public: static VertexFormats FormatFromDeclarator(
VertexElement declarator __gc[]
);
JScript .NET public static function FormatFromDeclarator(
declarator : VertexElement[]
) : VertexFormats;

Parameters

declarator Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that describe the VertexFormats code.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats . Combination of VertexFormats flags that describe the vertex format returned from the declaration.

Remarks

This method fails for any declaration that does not map directly to a vertex format.

Exceptions
InvalidCallException The call is invalid.

See Also

  • DeclaratorFromFormat


VertexInformation.GenerateDeclaration(VertexElement[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexInformation.GenerateDeclaration Method

 Language:
Note: This documentation is preliminary and is subject to change.

Generates an output vertex declaration from the input declaration.

Definition

Visual Basic .NET Public Shared Function GenerateDeclaration( _
ByVal declarator() As VertexElement _
) As VertexElement()
C# public static VertexElement[] GenerateDeclaration(
VertexElement[] declarator
);
Managed C++ public: static VertexElement GenerateDeclaration(
VertexElement declarator __gc[]
) __gc[];
JScript .NET public static function GenerateDeclaration(
declarator : VertexElement[]
) : VertexElement[];

Parameters

declarator Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that represent the input vertex declaration.

Return Value

Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that represent the output vertex declaration.

Remarks

The output declaration is used by the mesh tessellation functions.

Exceptions
InvalidCallException The call is invalid.


VertexInformation.GetDeclarationVertexSize(VertexElement[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexInformation.GetDeclarationVertexSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the size of the vertex declaration for a flexible vertex format (FVF).

Definition

Visual Basic .NET Public Shared Function GetDeclarationVertexSize( _
ByVal declarator() As VertexElement, _
ByVal stream As Integer _
) As Integer
C# public static int GetDeclarationVertexSize(
VertexElement[] declarator,
int stream
);
Managed C++ public: static int GetDeclarationVertexSize(
VertexElement declarator __gc[],
int stream
);
JScript .NET public static function GetDeclarationVertexSize(
declarator : VertexElement[],
stream : int
) : int;

Parameters

declarator | Microsoft.DirectX.Direct3D.VertexElement[]. Array of VertexElement structures that represent the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).
stream | System.Int32. Specifies the vertex data stream, in the range from 0 to the maximum number of streams -1.

Return Value

System.Int32 . The vertex declaration size, in bytes.

Remarks

A stream is defined as a uniform array of component data, where each component consists of one or more elements representing a single entity such as position, normal, color, and so on.


VertexInformation.GetFormatSize(VertexFormats)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexInformation.GetFormatSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the size of the vertex format.

Definition

Visual Basic .NET Public Shared Function GetFormatSize( _
ByVal vertexFormat As VertexFormats _
) As Integer
C# public static int GetFormatSize(
VertexFormats vertexFormat
);
Managed C++ public: static int GetFormatSize(
VertexFormats vertexFormat
);
JScript .NET public static function GetFormatSize(
vertexFormat : VertexFormats
) : int;

Parameters

vertexFormat Microsoft.DirectX.Direct3D.VertexFormats. Vertex format for which to return size.

Return Value

System.Int32 . An Int32 Leave Site value that indicates the size of the vertex format.

Remarks

Exceptions
InvalidMeshException The mesh is invalid.


Microsoft.DirectX.Direct3D.VertexShader

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader Class

Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates the functionality of a vertex shader.

Definition

Visual Basic .NET Public Class VertexShader
Inherits MarshalByRefObject
Implements IDisposable
C# public class VertexShader : MarshalByRefObject,
IDisposable
Managed C++ public __gc class VertexShader : public MarshalByRefObject,
IDisposable
JScript .NET public class VertexShader extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the VertexShader object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the VertexShader object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the VertexShader object to free resources before it is destroyed by the garbage collector.
GetFunction | Retrieves an array that contains shader data.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VertexShader.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this VertexShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
VertexShader | Initializes a new instance of the VertexShader class.

Properties

Property | Description
Device | Retrieves the Microsoft Direct3D® device associated with a vertex shader object.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
VertexShader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexShader.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the VertexShader object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VertexShader.Disposed
  • Microsoft.DirectX.Direct3D.VertexShader.Disposing


VertexShader.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


VertexShader.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the VertexShader object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~VertexShader();
Managed C++ | ~VertexShader();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


VertexShader.GetFunction()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.GetFunction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array that contains shader data.

Definition

Visual Basic .NET | Public Function GetFunction() As Integer()
C# | public int[] GetFunction();
Managed C++ | public: int GetFunction() __gc[];
JScript .NET | public function GetFunction() : int[];

Return Value

System.Int32[]. Array that contains the shader data.

Remarks

Exceptions
ArgumentException Leave Site | An error occurred while trying to retrieve the shader data.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexShader.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


VertexShader.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVertexShader9, which allows unmanaged COM clients to create an instance of the managed VertexShader class. Not supported.


VertexShader.op_Equality(VertexShader,VertexShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As VertexShader, _
ByVal right As VertexShader _
) As Boolean
C# public static bool op_Equality(
VertexShader left,
VertexShader right
);
Managed C++ public: static bool op_Equality(
VertexShader *left,
VertexShader *right
);
JScript .NET public static function op_Equality(
left : VertexShader,
right : VertexShader
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.VertexShader. The VertexShader object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.VertexShader. The VertexShader object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


VertexShader.op_Inequality(VertexShader,VertexShader)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As VertexShader, _
ByVal right As VertexShader _
) As Boolean
C# public static bool op_Inequality(
VertexShader left,
VertexShader right
);
Managed C++ public: static bool op_Inequality(
VertexShader *left,
VertexShader *right
);
JScript .NET public static function op_Inequality(
left : VertexShader,
right : VertexShader
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.VertexShader. The VertexShader object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.VertexShader. The VertexShader object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


VertexShader.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.VertexShader.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


VertexShader.UpdateUnmanagedPointer(IDirect3DVertexShader9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this VertexShader object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVertexShader9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVertexShader9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DVertexShader9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DVertexShader9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9. Pointer to the IDirect3DVertexShader9 structure used to update the unmanaged pointer for this VertexShader object.


VertexShader.VertexShader

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.VertexShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexShader class.

Overload List

public VertexShader(Device, GraphicsStream);
public VertexShader(Device, int[]);
public VertexShader(IDirect3DVertexShader9);
public VertexShader(IDirect3DVertexShader9, Device);
public VertexShader(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(IDirect3DVertexShader9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.VertexShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DVertexShader9 _
)
C# public VertexShader(
IDirect3DVertexShader9 pUnk
);
Managed C++ public: VertexShader(
IDirect3DVertexShader9 pUnk
);
JScript .NET public function VertexShader(
pUnk : IDirect3DVertexShader9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9. Unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.VertexShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VertexShader(
IntPtr unmanagedObject
);
Managed C++ public: VertexShader(
IntPtr unmanagedObject
);
JScript .NET public function VertexShader(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(IDirect3DVertexShader9,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.VertexShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DVertexShader9, _
ByVal device As Device _
)
C# public VertexShader(
IDirect3DVertexShader9 lp,
Device device
);
Managed C++ public: VertexShader(
IDirect3DVertexShader9 lp,
Device *device
);
JScript .NET public function VertexShader(
lp : IDirect3DVertexShader9,
device : Device
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9. Unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. Reference to an instance of a Device object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.VertexShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal functionToken As GraphicsStream _
)
C# public VertexShader(
Device device,
GraphicsStream functionToken
);
Managed C++ public: VertexShader(
Device *device,
GraphicsStream *functionToken
);
JScript .NET public function VertexShader(
device : Device,
functionToken : GraphicsStream
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to an instance of a Device object.
functionToken | Microsoft.DirectX.GraphicsStream. Reference to a GraphicsStream object that represents the vertex shader function tokens to use.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(Device,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.VertexShader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexShader class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal functionToken() As Integer _
)
C# public VertexShader(
Device device,
int[] functionToken
);
Managed C++ public: VertexShader(
Device *device,
int functionToken __gc[]
);
JScript .NET public function VertexShader(
device : Device,
functionToken : int[]
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. Reference to an instance of a Device object.
functionToken | System.Int32[]. Integer array representing the vertex shader function tokens that specify the blending operations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Microsoft® Direct3D® device associated with a vertex shader object.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . A Device reference that represents the Microsoft® Direct3D® device object associated with the vertex shader object.

This property is read-only.


VertexShader.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


VertexShader.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DVertexShader9
C# | public IDirect3DVertexShader9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DVertexShader9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DVertexShader9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9 . Unmanaged IDirect3DVertexShader9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


VertexShader.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShader.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the VertexShader object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VertexShader.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VertexShader object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.VertexTextureCoordinate

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexTextureCoordinate Class

Language:
Note: This documentation is preliminary and is subject to change.

Constructs bit patterns that are used to identify texture coordinate formats in a flexible vertex format description.

Definition

Visual Basic .NET NotInheritable Public Class VertexTextureCoordinate
Inherits Object
C# | public sealed class VertexTextureCoordinate : Object
Managed C++ | public __gc __sealed class VertexTextureCoordinate : public Object
JScript .NET | public class VertexTextureCoordinate extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) Size1 | Constructs bit patterns that are used to identify texture coordinate size-1 formats within a flexible vertex format description.
static (Shared in Visual Basic .NET) Size2 | Constructs bit patterns that are used to identify texture coordinate size-2 formats within a flexible vertex format description.
static (Shared in Visual Basic .NET) Size3 | Constructs bit patterns that are used to identify texture coordinate size-3 formats within a flexible vertex format description.
static (Shared in Visual Basic .NET) Size4 | Constructs bit patterns that are used to identify texture coordinate size-4 formats within a flexible vertex format description.

Inheritance Hierarchy

Object Leave Site
VertexTextureCoordinate

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexTextureCoordinate.Size1(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexTextureCoordinate.Size1 Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs bit patterns that are used to identify texture coordinate size-1 formats within a flexible vertex format description.

Definition

Visual Basic .NET Public Shared Function Size1( _
ByVal coordIndex As Integer _
) As VertexFormats
C# public static VertexFormats Size1(
int coordIndex
);
Managed C++ public: static VertexFormats Size1(
int coordIndex
);
JScript .NET public static function Size1(
coordIndex : int
) : VertexFormats;

Parameters

coordIndex System.Int32. Value that identifies the texture coordinate set to which the texture coordinate size (1-, 2-, 3-, or 4-dimensional) applies.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats . One or more VertexFormats flags that indicate the texture coordinate.


VertexTextureCoordinate.Size2()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexTextureCoordinate.Size2 Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs bit patterns that are used to identify texture coordinate size-2 formats within a flexible vertex format description.

Definition

Visual Basic .NET | Public Shared Function Size2() As VertexFormats
C# | public static VertexFormats Size2();
Managed C++ | public: static VertexFormats Size2();
JScript .NET | public static function Size2() : VertexFormats;

Return Value

Microsoft.DirectX.Direct3D.VertexFormats . One or more VertexFormats flags that indicate the texture coordinate.


VertexTextureCoordinate.Size3(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexTextureCoordinate.Size3 Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs bit patterns that are used to identify texture coordinate size-3 formats within a flexible vertex format description.

Definition

Visual Basic .NET Public Shared Function Size3( _
ByVal coordIndex As Integer _
) As VertexFormats
C# public static VertexFormats Size3(
int coordIndex
);
Managed C++ public: static VertexFormats Size3(
int coordIndex
);
JScript .NET public static function Size3(
coordIndex : int
) : VertexFormats;

Parameters

coordIndex System.Int32. Value that identifies the texture coordinate set to which the texture coordinate size (1-, 2-, 3-, or 4-dimensional) applies.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats . One or more VertexFormats flags that indicate the texture coordinate.


VertexTextureCoordinate.Size4(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexTextureCoordinate.Size4 Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs bit patterns that are used to identify texture coordinate size-4 formats within a flexible vertex format description.

Definition

Visual Basic .NET Public Shared Function Size4( _
ByVal coordIndex As Integer _
) As VertexFormats
C# public static VertexFormats Size4(
int coordIndex
);
Managed C++ public: static VertexFormats Size4(
int coordIndex
);
JScript .NET public static function Size4(
coordIndex : int
) : VertexFormats;

Parameters

coordIndex System.Int32. Value that identifies the texture coordinate set to which the texture coordinate size (1-, 2-, 3-, or 4-dimensional) applies.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats . One or more VertexFormats flags that indicate the texture coordinate.


Microsoft.DirectX.Direct3D.Volume

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates volume resources.

Definition

Visual Basic .NET NotInheritable Public Class Volume
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class Volume : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class Volume : public MarshalByRefObject,
IDisposable
JScript .NET public class Volume extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Volume object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Volume object.
Finalize | Allows the Volume object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current volume.
GetContainer | Provides access to the parent volume texture object, if the current surface is a child level of a volume texture.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with the volume to a provided buffer.
LockBox | Locks a box on a volume resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Volume.Disposing event when called from within a derived class.
SetPrivateData | Associates data with the volume that is intended for use by the application, not by Microsoft Direct3D®.
UnlockBox | Unlocks a box on a volume resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Volume object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
Volume | Initializes a new instance of the Volume class.

Properties

Property | Description
Description | Retrieves the description of a volume.
Device | Retrieves the Direct3D device associated with a sprite object.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Volume

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Volume.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Volume object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Volume.Disposed
  • Microsoft.DirectX.Direct3D.Volume.Disposing


Volume.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Volume object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Volume();
Managed C++ | ~Volume();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Volume.FreePrivateData(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.FreePrivateData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Frees the specified private data associated with the current volume.

Definition

Visual Basic .NET Public Sub FreePrivateData( _
ByVal guidData As Guid _
)
C# public void FreePrivateData(
Guid guidData
);
Managed C++ public: void FreePrivateData(
Guid guidData
);
JScript .NET public function FreePrivateData(
guidData : Guid
);

Parameters

guidData System.Guid. A Guid Leave Site that identifies the private data to free.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested item was not found.

See Also

  • Volume.GetPrivateData
  • Volume.SetPrivateData


Volume.GetContainer(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.GetContainer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Provides access to the parent volume texture object, if the current surface is a child level of a volume texture.

Definition

Visual Basic .NET Public Function GetContainer( _
ByVal interfaceId As Guid _
) As Object
C# public object GetContainer(
Guid interfaceId
);
Managed C++ public: Object* GetContainer(
Guid interfaceId
);
JScript .NET public function GetContainer(
interfaceId : Guid
) : Object;

Parameters

interfaceId System.Guid.

Return Value

System.Object . An Object Leave Site that represents the returned container.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVolume9, which allows unmanaged COM clients to create an instance of the managed Volume class. Not supported.


Volume.GetPrivateData(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.GetPrivateData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies the private data associated with the volume to a provided buffer.

Definition

Visual Basic .NET Public Function GetPrivateData( _
ByVal guidData As Guid _
) As Byte()
C# public byte[] GetPrivateData(
Guid guidData
);
Managed C++ public: Byte GetPrivateData(
Guid guidData
) __gc[];
JScript .NET public function GetPrivateData(
guidData : Guid
) : byte[];

Parameters

guidData System.Guid. A Guid Leave Site that represents the identifier of the private data being requested.

Return Value

System.Byte[]. A Byte Leave Site array that contains the requested data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested item was not found.
MoreDataException | More data is available than the specified buffer size can hold.

See Also

  • Volume.FreePrivateData
  • Volume.SetPrivateData


Volume.LockBox

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Overload List

public GraphicsStream LockBox(Box, LockFlags);
public GraphicsStream LockBox(Box, LockFlags, out LockedBox);
public GraphicsStream LockBox(LockFlags);
public GraphicsStream LockBox(LockFlags, out LockedBox);
public Array LockBox(Type, Box, LockFlags, int[]);
public Array LockBox(Type, Box, LockFlags, out LockedBox, int[]);
public Array LockBox(Type, LockFlags, int[]);
public Array LockBox(Type, LockFlags, out LockedBox, int[]);

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Box,LockFlags,LockedBox)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
Box box,
LockFlags flags,
out LockedBox lockedVolume
);
Managed C++ public: GraphicsStream* LockBox(
Box box,
LockFlags flags,
LockedBox *lockedVolume
);
JScript .NET public function LockBox(
box : Box,
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

box | Microsoft.DirectX.Direct3D.Box. A Box object that represents the box to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox object that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(LockFlags,LockedBox)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
LockFlags flags,
out LockedBox lockedVolume
);
Managed C++ public: GraphicsStream* LockBox(
LockFlags flags,
LockedBox *lockedVolume
);
JScript .NET public function LockBox(
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox object that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Box,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal box As Box, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
Box box,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockBox(
Box box,
LockFlags flags
);
JScript .NET public function LockBox(
box : Box,
flags : LockFlags
) : GraphicsStream;

Parameters

box | Microsoft.DirectX.Direct3D.Box. A Box object that represents the box to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
LockFlags flags
);
Managed C++ public: GraphicsStream* LockBox(
LockFlags flags
);
JScript .NET public function LockBox(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,Box,LockFlags,LockedBox,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
Box box,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
Box box,
LockFlags flags,
LockedBox *lockedVolume,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
box : Box,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. Value that specifies the Type Leave Site of the lock.
box | Microsoft.DirectX.Direct3D.Box. A Box object that represents the box to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox object that describes the locked region.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,LockFlags,LockedBox,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
LockFlags flags,
LockedBox *lockedVolume,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. Value that specifies the Type Leave Site of the lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox object that describes the locked region.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,Box,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
Box box,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
Box box,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
box : Box,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. Value that specifies the Type Leave Site of the lock.
box | Microsoft.DirectX.Direct3D.Box. A Box object that represents the box to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. Value that specifies the Type Leave Site of the lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.Volume.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Volume.SetPrivateData(Guid,Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.SetPrivateData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Associates data with the volume that is intended for use by the application, not by Microsoft® Direct3D®.

Definition

Visual Basic .NET Public Sub SetPrivateData( _
ByVal guidData As Guid, _
ByVal privateData() As Byte _
)
C# public void SetPrivateData(
Guid guidData,
byte[] privateData
);
Managed C++ public: void SetPrivateData(
Guid guidData,
Byte privateData __gc[]
);
JScript .NET public function SetPrivateData(
guidData : Guid,
privateData : byte[]
);

Parameters

guidData | System.Guid. A Guid Leave Site that represents the identifier of the private data to set.
privateData | System.Byte[]. A Byte Leave Site array that contains the private data for the current volume.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

See Also

  • Volume.FreePrivateData
  • Volume.GetPrivateData


Volume.UnlockBox()

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.UnlockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks a box on a volume resource.

Definition

Visual Basic .NET | Public Sub UnlockBox()
C# | public void UnlockBox();
Managed C++ | public: void UnlockBox();
JScript .NET | public function UnlockBox();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Volume.LockBox


Volume.UpdateUnmanagedPointer(IDirect3DVolume9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this Volume object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVolume9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVolume9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DVolume9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DVolume9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9. Pointer to the IDirect3DVolume9 structure used to update the unmanaged pointer for this Volume object.


Volume.Volume

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Volume Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Volume class.

Overload List

public Volume(IDirect3DVolume9);
public Volume(IDirect3DVolume9, VolumeTexture);
public Volume(IntPtr);


Volume.Volume(IDirect3DVolume9)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Volume Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Volume class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As IDirect3DVolume9 _
)
C# public Volume(
IDirect3DVolume9 pUnk
);
Managed C++ public: Volume(
IDirect3DVolume9 pUnk
);
JScript .NET public function Volume(
pUnk : IDirect3DVolume9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9. Unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.


Volume.Volume(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Volume Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Volume class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Volume(
IntPtr unmanagedObject
);
Managed C++ public: Volume(
IntPtr unmanagedObject
);
JScript .NET public function Volume(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DVolume9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Volume.Volume(IDirect3DVolume9,VolumeTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Volume Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Volume class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DVolume9, _
ByVal device As VolumeTexture _
)
C# public Volume(
IDirect3DVolume9 lp,
VolumeTexture device
);
Managed C++ public: Volume(
IDirect3DVolume9 lp,
VolumeTexture *device
);
JScript .NET public function Volume(
lp : IDirect3DVolume9,
device : VolumeTexture
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9. Unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.
device | Microsoft.DirectX.Direct3D.VolumeTexture. A VolumeTexture associated with the volume.


Volume.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the description of a volume.

Definition

Visual Basic .NET | Public ReadOnly Property Description As VolumeDescription
C# | public VolumeDescription Description { get; }
Managed C++ | public: __property VolumeDescription get_Description();
JScript .NET | public function get Description() : VolumeDescription

Property Value

Microsoft.DirectX.Direct3D.VolumeDescription . A VolumeDescription object that contains the volume description.

This property is read-only.


Volume.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the Microsoft® Direct3D® device associated with a sprite object.

Definition

Visual Basic .NET | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
Managed C++ | public: __property Device* get_Device();
JScript .NET | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device . A Device reference that represents the Microsoft® Direct3D® device object associated with the sprite object.

This property is read-only.


Volume.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Volume.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DVolume9
C# | public IDirect3DVolume9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DVolume9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DVolume9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9 . Unmanaged IDirect3DVolume9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


Volume.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Volume object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Volume.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Volume object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.VolumeLoader

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains functions for loading and saving volumes.

Definition

Visual Basic .NET NotInheritable Public Class VolumeLoader
Inherits Object
C# | public sealed class VolumeLoader : Object
Managed C++ | public __gc __sealed class VolumeLoader : public Object
JScript .NET | public class VolumeLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) FromFile | Loads a volume from a file.
static (Shared in Visual Basic .NET) FromStream | Creates a volume from a file in memory.
static (Shared in Visual Basic .NET) FromVolume | Loads a volume from another volume.
static (Shared in Visual Basic .NET) Save | Saves a volume to a file.

Inheritance Hierarchy

Object Leave Site
VolumeLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VolumeLoader.FromFile

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Overload List

public static void FromFile(Volume, Box, string, Box, Filter, int);
public static void FromFile(Volume, Box, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, Box, string, Box, Filter, int);
public static void FromFile(Volume, out PaletteEntry, Box, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, Box, string, Filter, int);
public static void FromFile(Volume, out PaletteEntry, Box, string, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, string, Box, Filter, int);
public static void FromFile(Volume, out PaletteEntry, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, string, Filter, int);
public static void FromFile(Volume, out PaletteEntry, string, Filter, int, ref ImageInformation);
public static void FromFile(Volume, string, Box, Filter, int);
public static void FromFile(Volume, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, string, Filter, int);
public static void FromFile(Volume, string, Filter, int, ref ImageInformation);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,Box,String,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Volume *destVolume,
Box destBox,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destVolume : Volume,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,Box,String,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Volume *destVolume,
Box destBox,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destVolume : Volume,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Volume *destVolume,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destVolume : Volume,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Volume *destVolume,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destVolume : Volume,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Volume *destVolume,
String *srcFile,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destVolume : Volume,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcFile | System.String. String that specifies the file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Volume *destVolume,
String *srcFile,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destVolume : Volume,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcFile | System.String. String that specifies the file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
String *srcFile,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile | System.String. String that specifies the file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
String *srcFile,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile | System.String. String that specifies the file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
String *srcFile,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile | System.String. String that specifies the file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
String *srcFile,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile | System.String. String that specifies the file name.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromFile Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from a file.

Definition

Visual Basic .NET Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromFile(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
String *srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile | System.String. String that specifies the file name.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromStream

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Overload List

public static void FromStream(Volume, Box, Stream, Box, Filter, int);
public static void FromStream(Volume, Box, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Box, Stream, int, Box, Filter, int);
public static void FromStream(Volume, Box, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, Box, Filter, int);
public static void FromStream(Volume, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, Filter, int);
public static void FromStream(Volume, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, int, Box, Filter, int);
public static void FromStream(Volume, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, int, Filter, int);
public static void FromStream(Volume, Stream, int, Filter, int, ref ImageInformation);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Box destBox,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Box destBox,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Int32,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Box destBox,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Int32,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Box destBox,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
int readBytes,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
Stream *stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Stream *stream,
int readBytes,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
int readBytes,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Box,Filter,Int32,ImageInformation)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation *srcInformation
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation | Microsoft.DirectX.Direct3D.ImageInformation. An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromStream Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a volume from a file in memory.

Definition

Visual Basic .NET Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromStream(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Stream *stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream | System.IO.Stream. A Stream Leave Site that contains the source volume texture in memory.
readBytes | System.Int32. Size of the file in memory, in bytes.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Overload List

public static void FromVolume(Volume, Box, Volume, Box, Filter, int);
public static void FromVolume(Volume, Box, Volume, Filter, int);
public static void FromVolume(Volume, Box, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, Box, Volume, out PaletteEntry, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, out PaletteEntry, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, out PaletteEntry, Filter, int);
public static void FromVolume(Volume, Volume, Box, Filter, int);
public static void FromVolume(Volume, Volume, Filter, int);
public static void FromVolume(Volume, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, Volume, out PaletteEntry, Filter, int);

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Box destBox,
Volume *srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Volume *srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Box destBox,
Volume *srcVolume,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Volume *srcVolume,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Volume *srcVolume,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Box destBox,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,PaletteEntry,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Volume *srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Volume *srcVolume,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,PaletteEntry,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
Box destBox,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,PaletteEntry,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Volume *srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,PaletteEntry,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,PaletteEntry,Box,Filter,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.FromVolume Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a volume from another volume.

Definition

Visual Basic .NET Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
Managed C++ public: static void FromVolume(
Volume *destVolume,
PaletteEntry *destPalette,
Box destBox,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript .NET public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the destination volume.
destPalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that specifies the source volume.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter | Microsoft.DirectX.Direct3D.Filter. One or more Filter flags that control how the image is filtered.
colorKey | System.Int32. An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.Save

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a file.

Overload List

public static void Save(string, ImageFileFormat, Volume);
public static void Save(string, ImageFileFormat, Volume, Box);
public static void Save(string, ImageFileFormat, Volume, out PaletteEntry);
public static void Save(string, ImageFileFormat, Volume, out PaletteEntry, Box);

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Volume *srcVolume
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume
);

Parameters

destFile | System.String. String that specifies the file name of the source image.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that contains the image to save.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume,PaletteEntry)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume,
out PaletteEntry sourcePalette
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Volume *srcVolume,
PaletteEntry *sourcePalette
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume,
sourcePalette : PaletteEntry
);

Parameters

destFile | System.String. String that specifies the file name of the source image.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that contains the image to save.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that contain a 256-color palette. This parameter can be 0.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume,Box)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume,
Box srcBox
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Volume *srcVolume,
Box srcBox
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume,
srcBox : Box
);

Parameters

destFile | System.String. String that specifies the file name of the source image.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that contains the image to save.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume,PaletteEntry,Box)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeLoader.Save Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves a volume to a file.

Definition

Visual Basic .NET Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox
);
Managed C++ public: static void Save(
String *destFile,
ImageFileFormat destFormat,
Volume *srcVolume,
PaletteEntry *sourcePalette,
Box srcBox
);
JScript .NET public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box
);

Parameters

destFile | System.String. String that specifies the file name of the source image.
destFormat | Microsoft.DirectX.Direct3D.ImageFileFormat. An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume | Microsoft.DirectX.Direct3D.Volume. A Volume object that contains the image to save.
sourcePalette | Microsoft.DirectX.Direct3D.PaletteEntry[]. Array of PaletteEntry structures that contain a 256-color palette. This parameter can be 0.
srcBox | Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the source box. Omit this parameter to specify the entire volume.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft® Direct3D® cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Microsoft.DirectX.Direct3D.VolumeTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture Class

Language:
Note: This documentation is preliminary and is subject to change.

Manipulates a volume texture resource.

Definition

Visual Basic .NET NotInheritable Public Class VolumeTexture
Inherits BaseTexture
Implements IDisposable
C# public sealed class VolumeTexture : BaseTexture,
IDisposable
Managed C++ public __gc __sealed class VolumeTexture : public BaseTexture,
IDisposable
JScript .NET public class VolumeTexture extends BaseTexture
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the VolumeTexture object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDirtyBox | Adds a dirty region to a volume texture resource.
Dispose | Immediately releases the unmanaged resources used by the VolumeTexture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the VolumeTexture object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GenerateMipSubLevels | Generates mipmap sublevels. Inherited from BaseTexture.
GetHashCode | Returns the hash code for the current instance.
GetLevelDescription | Retrieves a level description of a volume texture resource.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
GetVolumeLevel | Retrieves the specified volume texture level.
LockBox | Locks a box on a volume texture resource.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseTexture.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseTexture.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VolumeTexture.Disposing event when called from within a derived class.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
UnlockBox | Unlocks a box on a volume texture resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this VolumeTexture object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseTexture.
VolumeTexture | Creates a new instance of the VolumeTexture class.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels. Inherited from BaseTexture.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
LevelCount | Retrieves the number of texture levels in a multilevel texture. Inherited from BaseTexture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer. Inherited from BaseTexture.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DVolumeTexture9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
VolumeTexture

Remarks

This object inherits additional functionality from the BaseTexture class.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VolumeTexture.AddDirtyBox

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.AddDirtyBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a volume texture resource.

Overload List

public void AddDirtyBox();
public void AddDirtyBox(Box);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeTexture.AddDirtyBox(Box)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.AddDirtyBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a volume texture resource.

Definition

Visual Basic .NET Public Sub AddDirtyBox( _
ByVal box As Box _
)
C# public void AddDirtyBox(
Box box
);
Managed C++ public: void AddDirtyBox(
Box box
);
JScript .NET public function AddDirtyBox(
box : Box
);

Parameters

box Microsoft.DirectX.Direct3D.Box. A Box structure that specifies the dirty region to add. Omitting this parameter expands the dirty region to cover the entire volume texture.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeTexture.AddDirtyBox()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.AddDirtyBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a dirty region to a volume texture resource.

Definition

Visual Basic .NET | Public Sub AddDirtyBox()
C# | public void AddDirtyBox();
Managed C++ | public: void AddDirtyBox();
JScript .NET | public function AddDirtyBox();

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeTexture.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the VolumeTexture object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VolumeTexture.Disposed
  • Microsoft.DirectX.Direct3D.VolumeTexture.Disposing


VolumeTexture.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


VolumeTexture.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the VolumeTexture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~VolumeTexture();
Managed C++ | ~VolumeTexture();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


VolumeTexture.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


VolumeTexture.GetLevelDescription(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.GetLevelDescription Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a level description of a volume texture resource.

Definition

Visual Basic .NET Public Function GetLevelDescription( _
ByVal level As Integer _
) As VolumeDescription
C# public VolumeDescription GetLevelDescription(
int level
);
Managed C++ public: VolumeDescription GetLevelDescription(
int level
);
JScript .NET public function GetLevelDescription(
level : int
) : VolumeDescription;

Parameters

level System.Int32. Value that identifies a level of the volume texture resource.

Return Value

Microsoft.DirectX.Direct3D.VolumeDescription . A VolumeDescription structure that describes the returned volume texture level.

Remarks

This method returns a volume description for the level specified by the level parameter.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


VolumeTexture.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVolumeTexture9, which allows unmanaged COM clients to create an instance of the managed VolumeTexture class. Not supported.


VolumeTexture.GetVolumeLevel(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.GetVolumeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the specified volume texture level.

Definition

Visual Basic .NET Public Function GetVolumeLevel( _
ByVal level As Integer _
) As Volume
C# public Volume GetVolumeLevel(
int level
);
Managed C++ public: Volume* GetVolumeLevel(
int level
);
JScript .NET public function GetVolumeLevel(
level : int
) : Volume;

Parameters

level System.Int32. Value that identifies a level of the volume texture resource.

Return Value

Microsoft.DirectX.Direct3D.Volume . A Volume object that represents the returned volume level.

Remarks

This method returns a volume for the level specified by the level parameter.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


VolumeTexture.LockBox

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Overload List

public GraphicsStream LockBox(int, Box, LockFlags);
public GraphicsStream LockBox(int, Box, LockFlags, out LockedBox);
public GraphicsStream LockBox(int, LockFlags);
public GraphicsStream LockBox(int, LockFlags, out LockedBox);
public Array LockBox(Type, int, Box, LockFlags, int[]);
public Array LockBox(Type, int, Box, LockFlags, out LockedBox, int[]);
public Array LockBox(Type, int, LockFlags, int[]);
public Array LockBox(Type, int, LockFlags, out LockedBox, int[]);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,Box,LockFlags,LockedBox)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
Box box,
LockFlags flags,
out LockedBox lockedVolume
);
Managed C++ public: GraphicsStream* LockBox(
int level,
Box box,
LockFlags flags,
LockedBox *lockedVolume
);
JScript .NET public function LockBox(
level : int,
box : Box,
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

level | System.Int32. Value that specifies a level of the texture resource to lock.
box | Microsoft.DirectX.Direct3D.Box. A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox structure that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,LockFlags,LockedBox)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
LockFlags flags,
out LockedBox lockedVolume
);
Managed C++ public: GraphicsStream* LockBox(
int level,
LockFlags flags,
LockedBox *lockedVolume
);
JScript .NET public function LockBox(
level : int,
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

level | System.Int32. Value that specifies a level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox structure that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,Box,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
Box box,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockBox(
int level,
Box box,
LockFlags flags
);
JScript .NET public function LockBox(
level : int,
box : Box,
flags : LockFlags
) : GraphicsStream;

Parameters

level | System.Int32. Value that specifies a level of the texture resource to lock.
box | Microsoft.DirectX.Direct3D.Box. A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal level As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
LockFlags flags
);
Managed C++ public: GraphicsStream* LockBox(
int level,
LockFlags flags
);
JScript .NET public function LockBox(
level : int,
flags : LockFlags
) : GraphicsStream;

Parameters

level | System.Int32. Value that specifies a level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,Box,LockFlags,LockedBox,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
Box box,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
int level,
Box box,
LockFlags flags,
LockedBox *lockedVolume,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
level : int,
box : Box,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. Value that specifies a level of the texture resource to lock.
box | Microsoft.DirectX.Direct3D.Box. A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox structure that describes the locked region.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,LockFlags,LockedBox,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
int level,
LockFlags flags,
LockedBox *lockedVolume,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
level : int,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. Value that specifies a level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume | Microsoft.DirectX.Direct3D.LockedBox. A LockedBox structure that describes the locked region.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,Box,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
Box box,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
int level,
Box box,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
level : int,
box : Box,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. Value that specifies a level of the texture resource to lock.
box | Microsoft.DirectX.Direct3D.Box. A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,LockFlags,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.LockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Locks a box on a volume texture resource.

Definition

Visual Basic .NET Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
LockFlags flags,
int[] ranks
);
Managed C++ public: Array* LockBox(
Type *typeLock,
int level,
LockFlags flags,
int ranks __gc[]
);
JScript .NET public function LockBox(
typeLock : Type,
level : int,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock | System.Type. A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level | System.Int32. Value that specifies a level of the texture resource to lock.
flags | Microsoft.DirectX.Direct3D.LockFlags. Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array . An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.op_Equality(VolumeTexture,VolumeTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As VolumeTexture, _
ByVal right As VolumeTexture _
) As Boolean
C# public static bool op_Equality(
VolumeTexture left,
VolumeTexture right
);
Managed C++ public: static bool op_Equality(
VolumeTexture *left,
VolumeTexture *right
);
JScript .NET public static function op_Equality(
left : VolumeTexture,
right : VolumeTexture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.VolumeTexture. The VolumeTexture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.VolumeTexture. The VolumeTexture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


VolumeTexture.op_Inequality(VolumeTexture,VolumeTexture)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As VolumeTexture, _
ByVal right As VolumeTexture _
) As Boolean
C# public static bool op_Inequality(
VolumeTexture left,
VolumeTexture right
);
Managed C++ public: static bool op_Inequality(
VolumeTexture *left,
VolumeTexture *right
);
JScript .NET public static function op_Inequality(
left : VolumeTexture,
right : VolumeTexture
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.VolumeTexture. The VolumeTexture object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.VolumeTexture. The VolumeTexture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


VolumeTexture.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.VolumeTexture.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


VolumeTexture.UnlockBox(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.UnlockBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Unlocks a box on a volume texture resource.

Definition

Visual Basic .NET Public Sub UnlockBox( _
ByVal level As Integer _
)
C# public void UnlockBox(
int level
);
Managed C++ public: void UnlockBox(
int level
);
JScript .NET public function UnlockBox(
level : int
);

Parameters

level System.Int32. Value that specifies a level of the volume texture resource to unlock.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • LockBox


VolumeTexture.UpdateUnmanagedPointer(IDirect3DVolumeTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this VolumeTexture object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVolumeTexture9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVolumeTexture9 pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
IDirect3DVolumeTexture9 pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : IDirect3DVolumeTexture9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolumeTexture9. Pointer to the IDirect3DVolumeTexture9 structure used to update the unmanaged pointer for this VolumeTexture object.


VolumeTexture.VolumeTexture

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.VolumeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VolumeTexture class.

Overload List

public VolumeTexture(Device, int, int, int, int, Usage, Format, Pool);
public VolumeTexture(IDirect3DVolumeTexture9);
public VolumeTexture(IDirect3DVolumeTexture9, Device, Pool);
public VolumeTexture(IntPtr);

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(IDirect3DVolumeTexture9)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.VolumeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pInterop As IDirect3DVolumeTexture9 _
)
C# public VolumeTexture(
IDirect3DVolumeTexture9 pInterop
);
Managed C++ public: VolumeTexture(
IDirect3DVolumeTexture9 pInterop
);
JScript .NET public function VolumeTexture(
pInterop : IDirect3DVolumeTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolumeTexture9. Unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface pointer.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.VolumeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VolumeTexture(
IntPtr unmanagedObject
);
Managed C++ public: VolumeTexture(
IntPtr unmanagedObject
);
JScript .NET public function VolumeTexture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(IDirect3DVolumeTexture9,Device,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.VolumeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IDirect3DVolumeTexture9, _
ByVal device As Device, _
ByVal pool As Pool _
)
C# public VolumeTexture(
IDirect3DVolumeTexture9 lp,
Device device,
Pool pool
);
Managed C++ public: VolumeTexture(
IDirect3DVolumeTexture9 lp,
Device *device,
Pool pool
);
JScript .NET public function VolumeTexture(
lp : IDirect3DVolumeTexture9,
device : Device,
pool : Pool
);

Parameters

lp | Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolumeTexture9. Unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface pointer.
device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the VolumeTexture object.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the volume texture should be placed.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(Device,Int32,Int32,Int32,Int32,Usage,Format,Pool)

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.VolumeTexture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal numLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool _
)
C# public VolumeTexture(
Device device,
int width,
int height,
int depth,
int numLevels,
Usage usage,
Format format,
Pool pool
);
Managed C++ public: VolumeTexture(
Device *device,
int width,
int height,
int depth,
int numLevels,
Usage usage,
Format format,
Pool pool
);
JScript .NET public function VolumeTexture(
device : Device,
width : int,
height : int,
depth : int,
numLevels : int,
usage : Usage,
format : Format,
pool : Pool
);

Parameters

device | Microsoft.DirectX.Direct3D.Device. A Device object to associate with the VolumeTexture object.
width | System.Int32. Width of the top level of the volume texture, in pixels. This value must be a power of two if the Caps.TextureCaps.SupportsVolumeMapPower2 member is set. See Remarks.
height | System.Int32. Height of the top level of the volume texture, in pixels. This value must be a power of two if the Caps.TextureCaps.SupportsVolumeMapPower2 member is set. See Remarks.
depth | System.Int32. Depth of the top level of the volume texture, in pixels. This value must be a power of two if the Caps.TextureCaps.SupportsVolumeMapPower2 member is set. See Remarks.
numLevels | System.Int32. Number of levels in the texture. If this value is 0, Microsoft® Direct3D® generates all texture sublevels down to 1x1 pixels for hardware that supports mipmapped volume textures. Check the BaseTexture.LevelCount parameter for the number of levels generated.
usage | Microsoft.DirectX.Direct3D.Usage. Usage type for this VolumeTexture.
format | Microsoft.DirectX.Direct3D.Format. Member of the Format enumerated type that describes the format of all levels in the volume texture.
pool | Microsoft.DirectX.Direct3D.Pool. Member of the Pool enumerated type that describes the memory class into which the volume texture should be placed.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft® Direct3D® does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


VolumeTexture.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As IDirect3DVolumeTexture9
C# | public IDirect3DVolumeTexture9 UnmanagedComPointer { get; }
Managed C++ | public: __property IDirect3DVolumeTexture9 get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : IDirect3DVolumeTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolumeTexture9 . Unmanaged IDirect3DVolumeTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


VolumeTexture.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTexture.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the VolumeTexture object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VolumeTexture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VolumeTexture object indicates whether that object has been disposed.


Microsoft.DirectX.Direct3D.WasStillDrawingException

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device was still drawing.

Definition

Visual Basic .NET Public Class WasStillDrawingException
Inherits GraphicsException
C# | public class WasStillDrawingException : GraphicsException
Managed C++ | public __gc class WasStillDrawingException : public GraphicsException
JScript .NET | public class WasStillDrawingException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WasStillDrawingException | Initializes a new instance of the WasStillDrawingException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WasStillDrawingException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WasStillDrawingException.WasStillDrawingException

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WasStillDrawingException class.

Overload List

public WasStillDrawingException();
protected WasStillDrawingException(SerializationInfo, StreamingContext);
public WasStillDrawingException(string);
public WasStillDrawingException(string, Exception);


WasStillDrawingException.WasStillDrawingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WasStillDrawingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: WasStillDrawingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function WasStillDrawingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


WasStillDrawingException.WasStillDrawingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WasStillDrawingException(
string message,
Exception inner
);
Managed C++ public: WasStillDrawingException(
String *message,
Exception *inner
);
JScript .NET public function WasStillDrawingException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


WasStillDrawingException.WasStillDrawingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public WasStillDrawingException(
string message
);
Managed C++ public: WasStillDrawingException(
String *message
);
JScript .NET public function WasStillDrawingException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


WasStillDrawingException.WasStillDrawingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public WasStillDrawingException();
Managed C++ | public: WasStillDrawingException();
JScript .NET | public function WasStillDrawingException();


Microsoft.DirectX.Direct3D.WrongTextureFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongTextureFormatException Class

Language:
Note: This documentation is preliminary and is subject to change.

The pixel format of the texture surface is not valid.

Definition

Visual Basic .NET Public Class WrongTextureFormatException
Inherits GraphicsException
C# | public class WrongTextureFormatException : GraphicsException
Managed C++ | public __gc class WrongTextureFormatException : public GraphicsException
JScript .NET | public class WrongTextureFormatException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WrongTextureFormatException | Initializes a new instance of the WrongTextureFormatException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WrongTextureFormatException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WrongTextureFormatException.WrongTextureFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WrongTextureFormatException class.

Overload List

public WrongTextureFormatException();
protected WrongTextureFormatException(SerializationInfo, StreamingContext);
public WrongTextureFormatException(string);
public WrongTextureFormatException(string, Exception);


WrongTextureFormatException.WrongTextureFormatException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WrongTextureFormatException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: WrongTextureFormatException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function WrongTextureFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


WrongTextureFormatException.WrongTextureFormatException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WrongTextureFormatException(
string message,
Exception inner
);
Managed C++ public: WrongTextureFormatException(
String *message,
Exception *inner
);
JScript .NET public function WrongTextureFormatException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


WrongTextureFormatException.WrongTextureFormatException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public WrongTextureFormatException(
string message
);
Managed C++ public: WrongTextureFormatException(
String *message
);
JScript .NET public function WrongTextureFormatException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


WrongTextureFormatException.WrongTextureFormatException()

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public WrongTextureFormatException();
Managed C++ | public: WrongTextureFormatException();
JScript .NET | public function WrongTextureFormatException();


Microsoft.DirectX.Direct3D.XFile

Microsoft DirectX 9.0 SDK Update (October 2004)

XFile Class

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about XFile file objects.

Definition

Visual Basic .NET NotInheritable Public Class XFile
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class XFile : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class XFile : public MarshalByRefObject,
IDisposable
JScript .NET public class XFile extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFile object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the XFile object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFile object to free resources before it is destroyed by the garbage collector.
GetChild | Retrieves an XFileData child object in this XFile object.
GetDataObject | Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).
GetHashCode | Returns the hash code for the current instance.
GetManager | Returns an XFileManager instance for this XFile object.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFile.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFile object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
XFile | Initializes a new instance of the XFile class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
NumberChildren | Retrieves the number of child objects in this file data object.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileEnumObject interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFile

Remarks

The object for which information is being retrieved should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


XFile.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFile.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the XFile object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFile.Disposed
  • Microsoft.DirectX.Direct3D.XFile.Disposing


XFile.Equals(Object)

XFile.Equals Method

Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFile.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the XFile object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~XFile();
Managed C++ | ~XFile();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


XFile.GetChild(Int32)

XFile.GetChild Method

Note: This documentation is preliminary and is subject to change.

Retrieves an XFileData child object in this XFile object.

Definition

Visual Basic .NET Public Function GetChild( _
ByVal index As Integer _
) As XFileData
C# public XFileData GetChild(
int index
);
Managed C++ public: XFileData* GetChild(
int index
);
JScript .NET public function GetChild(
index : int
) : XFileData;

Parameters

index System.Int32. Identifier (ID) of the child object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData . The XFileData child object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NoMoreObjects | No more child objects are available.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.GetDataObject

XFile.GetDataObject Method

Note: This documentation is preliminary and is subject to change.

Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).

Overload List

public XFileData GetDataObject(Guid);
public XFileData GetDataObject(string);

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NotFound | Object could not be found from the specified parameters.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.GetDataObject(String)

XFile.GetDataObject Method

Note: This documentation is preliminary and is subject to change.

Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).

Definition

Visual Basic .NET Public Function GetDataObject( _
ByVal dataName As String _
) As XFileData
C# public XFileData GetDataObject(
string dataName
);
Managed C++ public: XFileData* GetDataObject(
String *dataName
);
JScript .NET public function GetDataObject(
dataName : String
) : XFileData;

Parameters

dataName System.String. Specifies the name of the data object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData . The XFileData object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NotFound | Object could not be found from the specified parameters.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.GetDataObject(Guid)

XFile.GetDataObject Method

Note: This documentation is preliminary and is subject to change.

Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).

Definition

Visual Basic .NET Public Function GetDataObject( _
ByVal dataId As Guid _
) As XFileData
C# public XFileData GetDataObject(
Guid dataId
);
Managed C++ public: XFileData* GetDataObject(
Guid dataId
);
JScript .NET public function GetDataObject(
dataId : Guid
) : XFileData;

Parameters

dataId System.Guid. Specifies the globally unique identifier (GUID) of the data object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData . The XFileData object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NotFound | Object could not be found from the specified parameters.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.GetHashCode()

XFile.GetHashCode Method

Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.GetManager()

XFile.GetManager Method

Note: This documentation is preliminary and is subject to change.

Returns an XFileManager instance for this XFile object.

Definition

Visual Basic .NET | Public Function GetManager() As XFileManager
C# | public XFileManager GetManager();
Managed C++ | public: XFileManager* GetManager();
JScript .NET | public function GetManager() : XFileManager;

Return Value

Microsoft.DirectX.Direct3D.XFileManager . The XFileManager instance for this XFile object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.GetObjectByValue(Int32)

XFile.GetObjectByValue Method

Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFile, which allows unmanaged COM clients to create an instance of the managed XFile class. Not supported.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.op_Equality(XFile,XFile)

XFile.op_Equality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As XFile, _
ByVal right As XFile _
) As Boolean
C# public static bool op_Equality(
XFile left,
XFile right
);
Managed C++ public: static bool op_Equality(
XFile *left,
XFile *right
);
JScript .NET public static function op_Equality(
left : XFile,
right : XFile
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFile. The XFile object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFile. The XFile object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.op_Inequality(XFile,XFile)

XFile.op_Inequality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As XFile, _
ByVal right As XFile _
) As Boolean
C# public static bool op_Inequality(
XFile left,
XFile right
);
Managed C++ public: static bool op_Inequality(
XFile *left,
XFile *right
);
JScript .NET public static function op_Inequality(
left : XFile,
right : XFile
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFile. The XFile object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFile. The XFile object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.raise_Disposing(Object,EventArgs)

XFile.raise_Disposing Method

Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.XFile.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.UpdateUnmanagedPointer(ID3DXFileEnumObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFile.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this XFile object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileEnumObject _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileEnumObject pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXFileEnumObject pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXFileEnumObject
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileEnumObject. Pointer to the ID3DXFileEnumObject structure used to update the unmanaged pointer for this XFile object.


XFile.XFile

XFile.XFile Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFile class.

Overload List

public XFile(ID3DXFileEnumObject);
public XFile(IntPtr);
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.XFile(ID3DXFileEnumObject)

XFile.XFile Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFile class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXFileEnumObject _
)
C# public XFile(
ID3DXFileEnumObject pUnk
);
Managed C++ public: XFile(
ID3DXFileEnumObject pUnk
);
JScript .NET public function XFile(
pUnk : ID3DXFileEnumObject
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileEnumObject. Unmanaged Component Object Model (COM) ID3DXFileEnumObject interface pointer.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.XFile(IntPtr)

XFile.XFile Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFile class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFile(
IntPtr unmanagedObject
);
Managed C++ public: XFile(
IntPtr unmanagedObject
);
JScript .NET public function XFile(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXFileEnumObject interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.Disposed

XFile.Disposed Property

Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.NumberChildren

XFile.NumberChildren Property

Note: This documentation is preliminary and is subject to change.

Retrieves the number of child objects in this file data object.

Definition

Visual Basic .NET | Public ReadOnly Property NumberChildren As Integer
C# | public int NumberChildren { get; }
Managed C++ | public: __property int get_NumberChildren();
JScript .NET | public function get NumberChildren() : int

Property Value

System.Int32 . Number of child objects.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFile.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

XFile.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXFileEnumObject interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXFileEnumObject
C# | public ID3DXFileEnumObject UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXFileEnumObject get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXFileEnumObject

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileEnumObject . Unmanaged ID3DXFileEnumObject interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


XFile.Disposing

XFile.Disposing Event

Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the XFile object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFile.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFile object indicates whether that object has been disposed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.XFileData

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData Class

Language:
Note: This documentation is preliminary and is subject to change.

Builds or accesses the immediate hierarchy of a data object.

Definition

Visual Basic .NET NotInheritable Public Class XFileData
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class XFileData : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class XFileData : public MarshalByRefObject,
IDisposable
JScript .NET public class XFileData extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileData object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the XFileData object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileData object to free resources before it is destroyed by the garbage collector.
GetChild | Retrieves an XFileData child object in this XFileData object.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetXFile | Retrieves an XFile instance for this XFileData object.
Lock | Accesses the .x file data.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileData.Disposing event when called from within a derived class.
SetData | Sets a range of data.
Unlock | Ends access to the GraphicsStream object returned by XFileData.Lock.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileData object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
XFileData | Initializes a new instance of the XFileData class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Id | Retrieves the GUID of this file data object.
IsReference | Indicates whether this file data object is a reference object that points to another child data object.
Name | Retrieves the name of this file data object.
NumberChildren | Retrieves the number of children in this file data object.
Type | Retrieves the globally unique identifier (GUID) of an object's template.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileData interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileData

Remarks

Template restrictions determine the hierarchy of data objects. Data types allowed by the template are called optional members. While optional members are not required, an object might miss important information without them. These members, which are saved as child members of the data object, can be additional data objects, references to earlier data objects, or binary objects.

The object should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


XFileData.Dispose()

XFileData.Dispose Method

Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the XFileData object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileData.Disposed
  • Microsoft.DirectX.Direct3D.XFileData.Disposing
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.Equals(Object)

XFileData.Equals Method

Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the XFileData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~XFileData();
Managed C++ | ~XFileData();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


XFileData.GetChild(Int32)

XFileData.GetChild Method

Note: This documentation is preliminary and is subject to change.

Retrieves an XFileData child object in this XFileData object.

Definition

Visual Basic .NET Public Function GetChild( _
ByVal index As Integer _
) As XFileData
C# public XFileData GetChild(
int index
);
Managed C++ public: XFileData* GetChild(
int index
);
JScript .NET public function GetChild(
index : int
) : XFileData;

Parameters

index System.Int32. Identifier (ID) of the child object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData . The XFileData child object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NoMoreObjects | No more child objects are available.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.GetHashCode()

XFileData.GetHashCode Method

Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFileData, which allows unmanaged COM clients to create an instance of the managed XFileData class. Not supported.


XFileData.GetXFile()

XFileData.GetXFile Method

Note: This documentation is preliminary and is subject to change.

Retrieves an XFile instance for this XFileData object.

Definition

Visual Basic .NET | Public Function GetXFile() As XFile
C# | public XFile GetXFile();
Managed C++ | public: XFile* GetXFile();
JScript .NET | public function GetXFile() : XFile;

Return Value

Microsoft.DirectX.Direct3D.XFile . The XFile instance for this XFileData object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.Lock()

XFileData.Lock Method

Note: This documentation is preliminary and is subject to change.

Accesses the .x file data.

Definition

Visual Basic .NET | Public Function Lock() As GraphicsStream
C# | public GraphicsStream Lock();
Managed C++ | public: GraphicsStream* Lock();
JScript .NET | public function Lock() : GraphicsStream;

Return Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the locked data buffer.

Remarks

You can make multiple lock calls. However, you must ensure that the number of lock calls matches the number of unlock calls.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.op_Equality(XFileData,XFileData)

XFileData.op_Equality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As XFileData, _
ByVal right As XFileData _
) As Boolean
C# public static bool op_Equality(
XFileData left,
XFileData right
);
Managed C++ public: static bool op_Equality(
XFileData *left,
XFileData *right
);
JScript .NET public static function op_Equality(
left : XFileData,
right : XFileData
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileData. The XFileData object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileData. The XFileData object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.op_Inequality(XFileData,XFileData)

XFileData.op_Inequality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As XFileData, _
ByVal right As XFileData _
) As Boolean
C# public static bool op_Inequality(
XFileData left,
XFileData right
);
Managed C++ public: static bool op_Inequality(
XFileData *left,
XFileData *right
);
JScript .NET public static function op_Inequality(
left : XFileData,
right : XFileData
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileData. The XFileData object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileData. The XFileData object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.raise_Disposing(Object,EventArgs)

XFileData.raise_Disposing Method

Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.XFileData.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.SetData(Object)

XFileData.SetData Method

Note: This documentation is preliminary and is subject to change.

Sets a range of data.

Definition

Visual Basic .NET Public Sub SetData( _
ByVal data As Object _
)
C# public void SetData(
object data
);
Managed C++ public: void SetData(
Object *data
);
JScript .NET public function SetData(
data : Object
);

Parameters

data System.Object. An Object Leave Site that contains the data to set into this XFileData object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NoMoreObjects | No more child objects are available.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.Unlock()

XFileData.Unlock Method

Note: This documentation is preliminary and is subject to change.

Ends access to the GraphicsStream object returned by XFileData.Lock.

Definition

Visual Basic .NET | Public Sub Unlock()
C# | public void Unlock();
Managed C++ | public: void Unlock();
JScript .NET | public function Unlock();

Remarks

You must ensure that the number of lock calls matches the number of unlock calls.

After calling XFileData.Unlock, the GraphicsStream object returned by XFileData.Lock should no longer be used.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.UpdateUnmanagedPointer(ID3DXFileData)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this XFileData object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileData _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileData pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXFileData pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXFileData
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileData. Pointer to the ID3DXFileData structure used to update the unmanaged pointer for this XFileData object.


XFileData.XFileData

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.XFileData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileData class.

Overload List

public XFileData(ID3DXFileData);
public XFileData(IntPtr);

Remarks

The object should be disposed immediately when it is no longer needed.


XFileData.XFileData(ID3DXFileData)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.XFileData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileData class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXFileData _
)
C# public XFileData(
ID3DXFileData pUnk
);
Managed C++ public: XFileData(
ID3DXFileData pUnk
);
JScript .NET public function XFileData(
pUnk : ID3DXFileData
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileData. Unmanaged Component Object Model (COM) ID3DXFileData interface pointer.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileData.XFileData(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.XFileData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileData class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileData(
IntPtr unmanagedObject
);
Managed C++ public: XFileData(
IntPtr unmanagedObject
);
JScript .NET public function XFileData(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXFileData interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileData.Disposed

XFileData.Disposed Property

Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.Id

XFileData.Id Property

Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) of this file data object.

Definition

Visual Basic .NET | Public ReadOnly Property Id As Guid
C# | public Guid Id { get; }
Managed C++ | public: __property Guid get_Id();
JScript .NET | public function get Id() : Guid

Property Value

System.Guid . A globally unique identifier (GUID) that represents this file data object.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.IsReference

XFileData.IsReference Property

Note: This documentation is preliminary and is subject to change.

Indicates whether this file data object is a reference object that points to another child data object.

Definition

Visual Basic .NET | Public ReadOnly Property IsReference As Boolean
C# | public bool IsReference { get; }
Managed C++ | public: __property bool get_IsReference();
JScript .NET | public function get IsReference() : boolean

Property Value

System.Boolean . A value that is true if the file data object is a reference object; otherwise, the value is false.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.Name

XFileData.Name Property

Note: This documentation is preliminary and is subject to change.

Retrieves the name of this file data object.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . The name of this file data object.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.NumberChildren

XFileData.NumberChildren Property

Note: This documentation is preliminary and is subject to change.

Retrieves the number of children in this file data object.

Definition

Visual Basic .NET | Public ReadOnly Property NumberChildren As Integer
C# | public int NumberChildren { get; }
Managed C++ | public: __property int get_NumberChildren();
JScript .NET | public function get NumberChildren() : int

Property Value

System.Int32 . The number of children in this file data object.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileData.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) of an object's template.

Definition

Visual Basic .NET | Public ReadOnly Property Type As Guid
C# | public Guid Type { get; }
Managed C++ | public: __property Guid get_Type();
JScript .NET | public function get Type() : Guid

Property Value

System.Guid . A Guid Leave Site instance that contains the globally unique identifier (GUID) of the object's template.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | If a variable is outside its expected range; typically returned when an object is invalid.


XFileData.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileData.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXFileData interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXFileData
C# | public ID3DXFileData UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXFileData get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXFileData

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileData . Unmanaged ID3DXFileData interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


XFileData.Disposing

XFileData.Disposing Event

Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the XFileData object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileData.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileData object indicates whether that object has been disposed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.XFileGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid Class

Language:
Note: This documentation is preliminary and is subject to change.

Provides various globally unique identifier (GUID) values for use with XFiles (.x files).

Definition

Visual Basic .NET NotInheritable Public Class XFileGuid
Inherits Object
C# | public sealed class XFileGuid : Object
Managed C++ | public __gc __sealed class XFileGuid : public Object
JScript .NET | public class XFileGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Animation | Retrieves the GUID for animation.
static (Shared in Visual Basic .NET) AnimationKey | Retrieves the GUID for animation keys.
static (Shared in Visual Basic .NET) AnimationOptions | Retrieves the GUID for animation options.
static (Shared in Visual Basic .NET) AnimationSet | Retrieves the GUID for an animation set.
static (Shared in Visual Basic .NET) ApplicationData | Retrieves the GUID for application data. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) Boolean | Retrieves the GUID for simple Boolean types.
static (Shared in Visual Basic .NET) Boolean2d | Retrieves the GUID for a set of two Boolean values that are used in the MeshFaceWraps template to define the texture topology of an individual face.
static (Shared in Visual Basic .NET) Camera | Retrieves the GUID for a camera. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) ColorRgb | Retrieves the GUID for a basic RGB color object.
static (Shared in Visual Basic .NET) ColorRgba | Retrieves the GUID for an RGB color object that has an alpha component.
static (Shared in Visual Basic .NET) Coordinates2D | Retrieves the GUID for a two-dimensional vector that is used to define a mesh's (u, v) texture coordinates.
static (Shared in Visual Basic .NET) ExternalVisual | Retrieves the GUID for an external visual. Used internally by DirectX. Do not use.
static (Shared in Visual Basic .NET) FloatKeys | Retrieves the GUID for an array of floating-point numbers (floats) and the number of floats in the array.
static (Shared in Visual Basic .NET) Frame | Retrieves the GUID for a frame.
static (Shared in Visual Basic .NET) FramePosition | Retrieves the GUID for a frame position. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) FrameRotation | Retrieves the GUID for a frame rotation. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) FrameTransformMatrix | Retrieves the GUID for a frame transform matrix.
static (Shared in Visual Basic .NET) FrameVelocity | Retrieves the GUID for a frame velocity. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) IndexedColor | Retrieves the GUID for indexed color.
static (Shared in Visual Basic .NET) Info | Retrieves the GUID for information. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) InlineData | Retrieves the GUID for inline data. Used internally by DirectX. Do not use.
static (Shared in Visual Basic .NET) Light | Retrieves the GUID for light templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) LightAttenuation | Retrieves the GUID for light attenuation templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) LightPenumbra | Retrieves the GUID for light penumbra templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) LightRange | Retrieves the GUID for light range templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) LightUmbra | Retrieves the GUID for light umbra templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) Material | Retrieves the GUID for material templates.
static (Shared in Visual Basic .NET) MaterialAmbientColor | Retrieves the GUID for material ambient color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) MaterialArray | Retrieves the GUID for material array templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) MaterialDiffuseColor | Retrieves the GUID for material diffuse color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) MaterialEmissiveColor | Retrieves the GUID for material emissive color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) MaterialPower | Retrieves the GUID for material power templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) MaterialSpecularColor | Retrieves the GUID for material specular color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) MaterialWrap | Retrieves the GUID for material wrap templates.
static (Shared in Visual Basic .NET) Matrix4x4 | Retrieves the GUID for matrix 4x4 templates.
static (Shared in Visual Basic .NET) Mesh | Retrieves the GUID for mesh templates.
static (Shared in Visual Basic .NET) MeshFace | Retrieves the GUID for mesh face templates.
static (Shared in Visual Basic .NET) MeshFaceWraps | Retrieves the GUID for mesh face wrap templates.
static (Shared in Visual Basic .NET) MeshMaterialList | Retrieves the GUID for mesh material list templates.
static (Shared in Visual Basic .NET) MeshNormals | Retrieves the GUID for mesh normal templates.
static (Shared in Visual Basic .NET) MeshTextureCoords | Retrieves the GUID for mesh texture coordinate templates.
static (Shared in Visual Basic .NET) MeshVertexColors | Retrieves the GUID for mesh vertex color templates.
static (Shared in Visual Basic .NET) ProgressiveMesh | Retrieves the GUID for progressive mesh templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic .NET) PropertyBag | Retrieves the GUID for property bag templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic .NET) RightHanded | Retrieves the GUID for right-handed templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic .NET) RmGuid | Retrieves the GUID for RMGuid templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) StringProperty | Retrieves the GUID for string property templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic .NET) TextureFilename | Retrieves the GUID for texture file-name templates.
static (Shared in Visual Basic .NET) TextureReference | Retrieves the GUID for texture reference templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic .NET) TimedFloatKeys | Retrieves the GUID for timed float-key templates.
static (Shared in Visual Basic .NET) Url | Retrieves the GUID for URL templates. Used internally by Microsoft® DirectX®. Do not use.
static (Shared in Visual Basic .NET) Vector | Retrieves the GUID for vector templates.

Inheritance Hierarchy

Object Leave Site
XFileGuid

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


XFileGuid.Animation

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Animation Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for animation.

Definition

Visual Basic .NET | Public Shared Animation As Guid
C# | public static Guid Animation;
Managed C++ | public: static Guid Animation;
JScript .NET | public static var Animation : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for animation templates in XFiles (.x files).

This field is read-only.

Remarks

Animation templates in XFiles contain animations that reference a previous frame. The template should contain one reference to a frame and at least one set of AnimationKey templates. It also can contain an AnimationOptions data object. The following C# code provides an example.

              [C#]

template Animation
{
    < 3D82AB4F-62DA-11cf-AB39-0020AF71E433 >
    [...]
}
Where:
  • [ ... ] - Any .x file template can be used here making the architecture extensible.


XFileGuid.AnimationKey

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.AnimationKey Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for animation keys.

Definition

Visual Basic .NET | Public Shared AnimationKey As Guid
C# | public static Guid AnimationKey;
Managed C++ | public: static Guid AnimationKey;
JScript .NET | public static var AnimationKey : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for animation key templates in XFiles (.x files).

This field is read-only.

Remarks

The following C# code is an AnimationKey template.

[C#]
template AnimationKey
{
    < 10DD46A8-775B-11CF-8F52-0040333594A3 >
    DWORD keyType;
    DWORD nKeys;
    array TimedFloatKeys keys[nKeys];
}
Where:
  • keyType - Specifies whether the keys are rotation, scale, position, or matrix keys (using the integers 0, 1, 2, or 3 respectively).
  • nKeys - Number of keys.
  • keys - Array of keys. See TimedFloatKeys.


XFileGuid.AnimationOptions

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.AnimationOptions Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for animation options.

Definition

Visual Basic .NET | Public Shared AnimationOptions As Guid
C# | public static Guid AnimationOptions;
Managed C++ | public: static Guid AnimationOptions;
JScript .NET | public static var AnimationOptions : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for animation option templates in XFiles (.x files).

This field is read-only.

Remarks

The following C# code provides an example of an AnimationOptions template.

[C#]
template AnimationOptions
{
    < E2BF56C0-840F-11cf-8F52-0040333594A3 >
    DWORD openclosed;
    DWORD positionquality;
}
Where:
  • openclosed - Use 0 for a closed animation, or 1 for an open animation. An animation is closed by default.
  • positionquality - Set the position quality for any position keys specified. Use 0 for spline positions, or 1 for linear positions.


XFileGuid.AnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.AnimationSet Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for an animation set.

Definition

Visual Basic .NET | Public Shared AnimationSet As Guid
C# | public static Guid AnimationSet;
Managed C++ | public: static Guid AnimationSet;
JScript .NET | public static var AnimationSet : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for animation set templates in XFiles (.x files).

This field is read-only.

Remarks

Animation sets contain one or more Animation objects. Each animation within a set has the same time at any given point, so increasing the animation set's time increases the time for all animations it contains.

The following C# code provides an example of an AnimationSet template.

[C#]
template AnimationSet
{
    < 3D82AB50-62DA-11cf-AB39-0020AF71E433 >
    [ Animation < 3D82AB4F-62DA-11cf-AB39-0020AF71E433 > ]
}
Where:
  • [ Animation < 3D82AB4F-62DA-11cf-AB39-0020AF71E433 > ] - Optional animation template.


XFileGuid.ApplicationData

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.ApplicationData Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for application data. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared ApplicationData As Guid
C# | public static Guid ApplicationData;
Managed C++ | public: static Guid ApplicationData;
JScript .NET | public static var ApplicationData : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for application data templates in XFiles (.x files).

This field is read-only.


XFileGuid.Boolean

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Boolean Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for simple Boolean types.

Definition

Visual Basic .NET | Public Shared Boolean As Guid
C# | public static Guid Boolean;
Managed C++ | public: static Guid Boolean;
JScript .NET | public static var Boolean : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for simple Boolean type templates in XFiles (.x files).

This field is read-only.

Remarks

Boolean templates define a simple boolean type, as shown in the following example.

[C#]
template Boolean
{
    < 537da6a0-ca37-11d0-941c-0080c80cfa7b >
    DWORD truefalse;
}
Where:
  • truefalse - True for a Boolean, otherwise false.


XFileGuid.Boolean2d

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Boolean2d Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a set of two Boolean values that are used in the MeshFaceWraps template to define the texture topology of an individual face.

Definition

Visual Basic .NET | Public Shared Boolean2d As Guid
C# | public static Guid Boolean2d;
Managed C++ | public: static Guid Boolean2d;
JScript .NET | public static var Boolean2d : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for templates with a set of two Boolean values in XFiles (.x files).

This field is read-only.

Remarks

The following is a Boolean2d template

[C#]
template Boolean2d
{
    < 4885AE63-78E8-11cf-8F52-0040333594A3 >
    Boolean u;
    Boolean v;
}
Where:
  • u - Boolean value. See Boolean.
  • v - Boolean value. See Boolean.


XFileGuid.Camera

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Camera Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a camera. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared Camera As Guid
C# | public static Guid Camera;
Managed C++ | public: static Guid Camera;
JScript .NET | public static var Camera : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for camera templates in XFiles (.x files).

This field is read-only.


XFileGuid.ColorRgb

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.ColorRgb Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a basic RGB color object.

Definition

Visual Basic .NET | Public Shared ColorRgb As Guid
C# | public static Guid ColorRgb;
Managed C++ | public: static Guid ColorRgb;
JScript .NET | public static var ColorRgb : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for basic RGB color object templates in XFiles (.x files).

This field is read-only.

Remarks

The following is an example of a ColorRGB template.

[C#]
template ColorRGB
{
    < D3E16E81-7835-11cf-8F52-0040333594A3 >
    float red;
    float green;
    float blue;
}


XFileGuid.ColorRgba

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.ColorRgba Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for an RGB color object that has an alpha component.

Definition

Visual Basic .NET | Public Shared ColorRgba As Guid
C# | public static Guid ColorRgba;
Managed C++ | public: static Guid ColorRgba;
JScript .NET | public static var ColorRgba : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for an RGB color object that has alpha component templates in XFiles (.x files).

This field is read-only.

Remarks

The following template is used for the face color in the material template definition.

              [C#]

template ColorRGBA
{
    < 35FF44E0-6C7C-11cf-8F52-0040333594A3 >
    float red;
    float green;
    float blue;
    float alpha;
}


XFileGuid.Coordinates2D

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Coordinates2D Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a two-dimensional vector that is used to define a mesh's (u, v) texture coordinates.

Definition

Visual Basic .NET | Public Shared Coordinates2D As Guid
C# | public static Guid Coordinates2D;
Managed C++ | public: static Guid Coordinates2D;
JScript .NET | public static var Coordinates2D : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for 2-D vector templates in XFiles (.x files).

This field is read-only.

Remarks

The following is a Coords2d template.

[C#]
template Coords2d
{
    < F6F23F44-7686-11cf-8F52-0040333594A3 >
    float u;
    float v;
}
Where:
  • u - u coordinate value.
  • v - v coordinate value.


XFileGuid.ExternalVisual

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.ExternalVisual Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for an external visual. Used internally by Microsoft® DirectX®. Do not use.

Definition

Visual Basic .NET | Public Shared ExternalVisual As Guid
C# | public static Guid ExternalVisual;
Managed C++ | public: static Guid ExternalVisual;
JScript .NET | public static var ExternalVisual : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for external visual templates in XFiles (.x files).

This field is read-only.


XFileGuid.FloatKeys

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.FloatKeys Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for an array of floating-point numbers (floats) and the number of floats in the array.

Definition

Visual Basic .NET | Public Shared FloatKeys As Guid
C# | public static Guid FloatKeys;
Managed C++ | public: static Guid FloatKeys;
JScript .NET | public static var FloatKeys : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for templates that consist of an array of floating-point numbers, and the number of floats in that array in XFiles (.x).

This field is read-only.

Remarks

This field is used for defining sets of animation keys.

The following is a FloatKeys template.

[C#]
template FloatKeys
{
    < 10DD46A9-775B-11cf-8F52-0040333594A3 >
    DWORD nValues;
    array float values[nValues];
}
Where:
  • nValues - Number of floats.
  • values[nValues] - Array of float values.


XFileGuid.Frame

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Frame Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a frame.

Definition

Visual Basic .NET | Public Shared Frame As Guid
C# | public static Guid Frame;
Managed C++ | public: static Guid Frame;
JScript .NET | public static var Frame : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for frames.

This field is read-only.

Remarks

A frame is a coordinate frame, or "frame of reference." The Frame template is open and can contain any object. The mesh-loading functions recognize Mesh, FrameTransformMatrix, and Frame template instances as child objects when loading a Frame instance.

The following is a Frame template.

[C#]
template Frame
{
    < 3D82AB46-62DA-11CF-AB39-0020AF71E433 >
    [...]
}
  • [ ... ] - Any .x file template can be used here making the architecture extensible.
The frame template recognizes child Frame and Mesh nodes inside of a frame, and user-defined templates through a callback function.


XFileGuid.FramePosition

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.FramePosition Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a frame position. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared FramePosition As Guid
C# | public static Guid FramePosition;
Managed C++ | public: static Guid FramePosition;
JScript .NET | public static var FramePosition : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for frame positions.

This field is read-only.


XFileGuid.FrameRotation

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.FrameRotation Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a frame rotation. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared FrameRotation As Guid
C# | public static Guid FrameRotation;
Managed C++ | public: static Guid FrameRotation;
JScript .NET | public static var FrameRotation : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for frame rotation templates.

This field is read-only.


XFileGuid.FrameTransformMatrix

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.FrameTransformMatrix Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a frame transform matrix.

Definition

Visual Basic .NET | Public Shared FrameTransformMatrix As Guid
C# | public static Guid FrameTransformMatrix;
Managed C++ | public: static Guid FrameTransformMatrix;
JScript .NET | public static var FrameTransformMatrix : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for frame transform matrix templates.

This field is read-only.

Remarks

A frame transform matrix template defines a local transform for a frame and all of its child objects, as shown in the following example.

[C#]
template FrameTransformMatrix
{
    < F6F23F41-7686-11cf-8F52-0040333594A3 >
    Matrix4x4 frameMatrix;
}
Where:
  • frameMatrix - A Matrix4x4 template. For more information, see Matrix4x4.


XFileGuid.FrameVelocity

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.FrameVelocity Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for a frame velocity. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared FrameVelocity As Guid
C# | public static Guid FrameVelocity;
Managed C++ | public: static Guid FrameVelocity;
JScript .NET | public static var FrameVelocity : Guid

Field Value

System.Guid . A Guid Leave Site value that is used for frame velocity templates.

This field is read-only.


XFileGuid.IndexedColor

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.IndexedColor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for indexed color.

Definition

Visual Basic .NET | Public Shared IndexedColor As Guid
C# | public static Guid IndexedColor;
Managed C++ | public: static Guid IndexedColor;
JScript .NET | public static var IndexedColor : Guid

Field Value

System.Guid . A Guid Leave Site instance that contains the globally unique identifier (GUID) for indexed color templates.

This field is read-only.

Remarks

An index color template contains an index parameter and an RGBA color, and is used to define mesh vertex colors. The index defines the vertex to which the color is applied, as shown in the following example.

[C#]
template IndexedColor
{
    < 1630B820-7842-11cf-8F52-0040333594A3 >
    DWORD index;
    ColorRGBA indexColor;
}
Where:
  • index - A DWORD. See the description above.
  • indexColor - A ColorRgba template.


XFileGuid.Info

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Info Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for information. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared Info As Guid
C# | public static Guid Info;
Managed C++ | public: static Guid Info;
JScript .NET | public static var Info : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for information templates.

This field is read-only.


XFileGuid.InlineData

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.InlineData Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for inline data. Used internally by Microsoft® DirectX®. Do not use.

Definition

Visual Basic .NET | Public Shared InlineData As Guid
C# | public static Guid InlineData;
Managed C++ | public: static Guid InlineData;
JScript .NET | public static var InlineData : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for inline data templates.

This field is read-only.


XFileGuid.Light

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Light Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for light templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared Light As Guid
C# | public static Guid Light;
Managed C++ | public: static Guid Light;
JScript .NET | public static var Light : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for light templates.

This field is read-only.


XFileGuid.LightAttenuation

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.LightAttenuation Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for light attenuation templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared LightAttenuation As Guid
C# | public static Guid LightAttenuation;
Managed C++ | public: static Guid LightAttenuation;
JScript .NET | public static var LightAttenuation : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for light attenuation templates.

This field is read-only.


XFileGuid.LightPenumbra

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.LightPenumbra Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for light penumbra templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared LightPenumbra As Guid
C# | public static Guid LightPenumbra;
Managed C++ | public: static Guid LightPenumbra;
JScript .NET | public static var LightPenumbra : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for light penumbra templates.

This field is read-only.


XFileGuid.LightRange

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.LightRange Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for light range templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared LightRange As Guid
C# | public static Guid LightRange;
Managed C++ | public: static Guid LightRange;
JScript .NET | public static var LightRange : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for light range templates.

This field is read-only.


XFileGuid.LightUmbra

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.LightUmbra Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for light umbra templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared LightUmbra As Guid
C# | public static Guid LightUmbra;
Managed C++ | public: static Guid LightUmbra;
JScript .NET | public static var LightUmbra : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for light umbra templates.

This field is read-only.


XFileGuid.Material

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Material Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material templates.

Definition

Visual Basic .NET | Public Shared Material As Guid
C# | public static Guid Material;
Managed C++ | public: static Guid Material;
JScript .NET | public static var Material : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material templates.

This field is read-only.

Remarks

Material templates define a basic material color that can be applied to a complete mesh or a mesh's individual faces. The power is the specular exponent of the material.

Note: The ambient color requires an alpha component.
TextureFilename is an optional data object. If it is not present, the face is not textured. The following is a Material template.
[C#]
template Material
{
    < 3D82AB4D-62DA-11CF-AB39-0020AF71E433 >
    ColorRGBA faceColor;
    FLOAT power;
    ColorRGB specularColor;
    ColorRGB emissiveColor;
    [...]
}
 Where:
  • faceColor - Face color. A ColorRgba template.
  • power - Material specular color exponent.
  • specularColor - Material specular color. A ColorRgb template.
  • emissiveColor - Material emissive color. A ColorRgb template.


XFileGuid.MaterialAmbientColor

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MaterialAmbientColor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material ambient color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared MaterialAmbientColor As Guid
C# | public static Guid MaterialAmbientColor;
Managed C++ | public: static Guid MaterialAmbientColor;
JScript .NET | public static var MaterialAmbientColor : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material ambient color templates.

This field is read-only.


XFileGuid.MaterialArray

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MaterialArray Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material array templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared MaterialArray As Guid
C# | public static Guid MaterialArray;
Managed C++ | public: static Guid MaterialArray;
JScript .NET | public static var MaterialArray : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material array templates.

This field is read-only.


XFileGuid.MaterialDiffuseColor

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MaterialDiffuseColor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material diffuse color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared MaterialDiffuseColor As Guid
C# | public static Guid MaterialDiffuseColor;
Managed C++ | public: static Guid MaterialDiffuseColor;
JScript .NET | public static var MaterialDiffuseColor : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material diffuse color templates.

This field is read-only.


XFileGuid.MaterialEmissiveColor

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MaterialEmissiveColor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material emissive color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared MaterialEmissiveColor As Guid
C# | public static Guid MaterialEmissiveColor;
Managed C++ | public: static Guid MaterialEmissiveColor;
JScript .NET | public static var MaterialEmissiveColor : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material emissive color templates.

This field is read-only.


XFileGuid.MaterialPower

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MaterialPower Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material power templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared MaterialPower As Guid
C# | public static Guid MaterialPower;
Managed C++ | public: static Guid MaterialPower;
JScript .NET | public static var MaterialPower : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material power templates.

This field is read-only.


XFileGuid.MaterialSpecularColor

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MaterialSpecularColor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material specular color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared MaterialSpecularColor As Guid
C# | public static Guid MaterialSpecularColor;
Managed C++ | public: static Guid MaterialSpecularColor;
JScript .NET | public static var MaterialSpecularColor : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material specular color templates.

This field is read-only.


XFileGuid.MaterialWrap

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MaterialWrap Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for material wrap templates.

Definition

Visual Basic .NET | Public Shared MaterialWrap As Guid
C# | public static Guid MaterialWrap;
Managed C++ | public: static Guid MaterialWrap;
JScript .NET | public static var MaterialWrap : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for material wrap templates.

This field is read-only.

Remarks

Material wrap templates define a set of two Boolean values that are used in the MeshFaceWraps template to define the texture topology of an individual face. Use this template instead of Boolean2d when the texture coordinates (u, v) span the range of 0 to 2 instead of 0 to 1. The following is a MaterialWrap template.

[C#]
template MaterialWrap
{
    < 4885ae60-78e8-11cf-8f52-0040333594a3 >
    Boolean u;
    Boolean v;
}
Where:
  • u - Boolean value.
  • v - Boolean value.
Note: The MeshFaceWraps template is no longer used.


XFileGuid.Matrix4x4

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Matrix4x4 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for matrix 4x4 templates.

Definition

Visual Basic .NET | Public Shared Matrix4x4 As Guid
C# | public static Guid Matrix4x4;
Managed C++ | public: static Guid Matrix4x4;
JScript .NET | public static var Matrix4x4 : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for matrix 4x4 templates.

This field is read-only.

Remarks

Material wrap templates define a 4x4 matrix, which is used as a frame transformation matrix. The following is a Matrix4x4.

[C#]
template Matrix4x4
{
    < F6F23F45-7686-11cf-8F52-0040333594A3 >
    array float matrix[16];
}
Where:
  • array float matrix[16] - Array of 16 floats.


XFileGuid.Mesh

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Mesh Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for mesh templates.

Definition

Visual Basic .NET | Public Shared Mesh As Guid
C# | public static Guid Mesh;
Managed C++ | public: static Guid Mesh;
JScript .NET | public static var Mesh : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for mesh templates.

This field is read-only.

Remarks

Mesh templates define a simple mesh. In the following Mesh template, the first array is a list of vertices, and the second array defines the faces of the mesh by indexing into the vertex array.

[C#]
template Mesh
{
    <3D82AB44-62DA-11CF-AB39-0020AF71E433>
    DWORD nVertices;
    array Vector vertices[nVertices];
    DWORD nFaces;
    array MeshFace faces[nFaces];
    [...]
}
Where:
  • nVertices - Number of vertices.
  • array Vector vertices[nVertices] - Array of vertices, each of type Vector.
  • nFaces - Number of faces.
  • array MeshFace faces[nFaces] - Array of faces, each of type MeshFace.
  • [ ... ] - Any .x file template which makes the architecture extensible. The Material and TextureFilename templates typically are used.


XFileGuid.MeshFace

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MeshFace Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for mesh face templates.

Definition

Visual Basic .NET | Public Shared MeshFace As Guid
C# | public static Guid MeshFace;
Managed C++ | public: static Guid MeshFace;
JScript .NET | public static var MeshFace : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for mesh face templates.

This field is read-only.

Remarks

Mesh face templates are used by the Mesh template to define a mesh's faces. In the following MeshFace, each element of the nFaceVertexIndices array references a mesh vertex used to build the face.

[C#]
template MeshFace
{
    < 3D82AB5F-62DA-11cf-AB39-0020AF71E433 >
    DWORD nFaceVertexIndices;
    array DWORD faceVertexIndices[nFaceVertexIndices];
}
Where:
  • nFaceVertexIndices - Number of indices.
  • array DWORD faceVertexIndices[nFaceVertexIndices] - Array of indices.


XFileGuid.MeshFaceWraps

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MeshFaceWraps Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for mesh face wrap templates.

Definition

Visual Basic .NET | Public Shared MeshFaceWraps As Guid
C# | public static Guid MeshFaceWraps;
Managed C++ | public: static Guid MeshFaceWraps;
JScript .NET | public static var MeshFaceWraps : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for mesh face wrap templates.

This field is read-only.

Remarks

Mesh face wrap templates are used to define the texture topology of each face in a wrap. The value of the nFaceWrapValues member should be equal to the number of faces in a mesh, as in the following example.

[C#]
template MeshFaceWraps
{
    < ED1EC5C0-C0A8-11D0-941C-0080C80CFA7B >
    DWORD nFaceWrapValues;
    array Boolean2d faceWrapValues[nFaceWrapValues];
}
Note: This template is provided for backward compatibility and is no longer used.


XFileGuid.MeshMaterialList

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MeshMaterialList Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for mesh material list templates.

Definition

Visual Basic .NET | Public Shared MeshMaterialList As Guid
C# | public static Guid MeshMaterialList;
Managed C++ | public: static Guid MeshMaterialList;
JScript .NET | public static var MeshMaterialList : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for mesh material list templates.

This field is read-only.

Remarks

Mesh material list templates are used in a mesh object to specify which material applies to particular faces. In the following MeshMaterialList, the nMaterials member specifies how many materials are present, and the materials member specifies which material to apply.

[C#]
template MeshMaterialList
{
    < F6F23F42-7686-11CF-8F52-0040333594A3 >
    DWORD nMaterials;
    DWORD nFaceIndexes;
    array DWORD faceIndexes[nFaceIndexes];
    [Material <3D82AB4D-62DA-11CF-AB39-0020AF71E433>]
}
Where:
  • nMaterials - A DWORD. The number of materials.
  • nFaceIndexes - A DWORD. The number of indices.
  • faceIndexes[nFaceIndexes] - An array of DWORDs that contain the face indices.


XFileGuid.MeshNormals

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MeshNormals Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for mesh normal templates.

Definition

Visual Basic .NET | Public Shared MeshNormals As Guid
C# | public static Guid MeshNormals;
Managed C++ | public: static Guid MeshNormals;
JScript .NET | public static var MeshNormals : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for mesh normal templates.

This field is read-only.

Remarks

Mesh normal templates define normals for a mesh. The first array of vectors is the normal vectors themselves, and the second array is an array of indexes that specify which normals should be applied to a given face. The value of the nFaceNormals member should be equal to the number of faces in a mesh. The following is a MeshNormals template .

[C#]
template MeshNormals
{
    < F6F23F43-7686-11cf-8F52-0040333594A3 >
    DWORD nNormals;
    array Vector normals[nNormals];
    DWORD nFaceNormals;
    array MeshFace meshFaces[nFaceNormals];
}
Where:
  • nNormals - Number of normals.
  • array Vector normals[nNormals] - Array of normals. See Vector.
  • nFaceNormals - Number of face normals.
  • array MeshFace meshFaces[nFaceNormals] - Array of mesh face normals. For more information, see MeshFace.


XFileGuid.MeshTextureCoords

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MeshTextureCoords Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for mesh texture coordinate templates.

Definition

Visual Basic .NET | Public Shared MeshTextureCoords As Guid
C# | public static Guid MeshTextureCoords;
Managed C++ | public: static Guid MeshTextureCoords;
JScript .NET | public static var MeshTextureCoords : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for mesh coordinate templates.

This field is read-only.

Remarks

Mesh texture coordinate templates define a mesh's texture coordinates, as shown in the following example.

[C#]
template MeshTextureCoords
{
    < F6F23F40-7686-11cf-8F52-0040333594A3 >
    DWORD nTextureCoords;
    array Coords2d textureCoords[nTextureCoords] ;
}
Where:
  • nTextureCoords - Number of texture coordinates.
  • array Coords2d textureCoords[nTextureCoords] - Array of 2-D texture coordinates. For more information, see Coordinates2D.


XFileGuid.MeshVertexColors

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.MeshVertexColors Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for mesh vertex color templates.

Definition

Visual Basic .NET | Public Shared MeshVertexColors As Guid
C# | public static Guid MeshVertexColors;
Managed C++ | public: static Guid MeshVertexColors;
JScript .NET | public static var MeshVertexColors : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for mesh vertex color templates.

This field is read-only.

Remarks

Mesh vertex color templates specify vertex colors for a mesh, rather than applying a material per face or per mesh. The following is an example of a MeshVertexColors template.

[C#]
template MeshVertexColors
{
    <1630B821-7842-11cf-8F52-0040333594A3>
    DWORD nVertexColors;
    array IndexColor vertexColors[nVertexColors];
}
Where:
  • nVertexColors - Number of colors. This matches the number of vertices in the mesh.
  • array IndexColor vertexColors[nVertexColors] - Array of indexed colors. For more information, see IndexedColor.


XFileGuid.ProgressiveMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.ProgressiveMesh Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for progressive mesh templates. Used internally by Microsoft® DirectX®. Do not use.

Definition

Visual Basic .NET | Public Shared ProgressiveMesh As Guid
C# | public static Guid ProgressiveMesh;
Managed C++ | public: static Guid ProgressiveMesh;
JScript .NET | public static var ProgressiveMesh : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for progressive mesh templates.

This field is read-only.


XFileGuid.PropertyBag

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.PropertyBag Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for property bag templates. Used internally by Microsoft® DirectX®. Do not use.

Definition

Visual Basic .NET | Public Shared PropertyBag As Guid
C# | public static Guid PropertyBag;
Managed C++ | public: static Guid PropertyBag;
JScript .NET | public static var PropertyBag : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for property bag templates.

This field is read-only.


XFileGuid.RightHanded

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.RightHanded Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for right-handed templates. Used internally by Microsoft® DirectX®. Do not use.

Definition

Visual Basic .NET | Public Shared RightHanded As Guid
C# | public static Guid RightHanded;
Managed C++ | public: static Guid RightHanded;
JScript .NET | public static var RightHanded : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for right-handed templates.

This field is read-only.


XFileGuid.RmGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.RmGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for RMGuid templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared RmGuid As Guid
C# | public static Guid RmGuid;
Managed C++ | public: static Guid RmGuid;
JScript .NET | public static var RmGuid : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for RMGuid templates.

This field is read-only.


XFileGuid.StringProperty

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.StringProperty Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for string property templates. Used internally by Microsoft® DirectX®. Do not use.

Definition

Visual Basic .NET | Public Shared StringProperty As Guid
C# | public static Guid StringProperty;
Managed C++ | public: static Guid StringProperty;
JScript .NET | public static var StringProperty : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for string property templates.

This field is read-only.


XFileGuid.TextureFilename

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.TextureFilename Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for texture file-name templates.

Definition

Visual Basic .NET | Public Shared TextureFilename As Guid
C# | public static Guid TextureFilename;
Managed C++ | public: static Guid TextureFilename;
JScript .NET | public static var TextureFilename : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for texture file-name templates.

This field is read-only.

Remarks

Texture file-name templates enable the specification of a texture's file name to apply to a mesh or face. This template should appear within a material object. The following is a TextureFilename template.

[C#]
template TextureFilename
{
    < A42790E1-7810-11cf-8F52-0040333594A3 >
    string filename;
}


XFileGuid.TextureReference

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.TextureReference Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for texture reference templates. Provided for legacy applications. Not supported.

Definition

Visual Basic .NET | Public Shared TextureReference As Guid
C# | public static Guid TextureReference;
Managed C++ | public: static Guid TextureReference;
JScript .NET | public static var TextureReference : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for texture reference templates.

This field is read-only.


XFileGuid.TimedFloatKeys

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.TimedFloatKeys Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for timed float-key templates.

Definition

Visual Basic .NET | Public Shared TimedFloatKeys As Guid
C# | public static Guid TimedFloatKeys;
Managed C++ | public: static Guid TimedFloatKeys;
JScript .NET | public static var TimedFloatKeys : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for timed float-key templates.

This field is read-only.

Remarks

Timed float-key templates define a set of floating-point values (floats) and a positive time for use in animations. The following is a TimedFloatKeys template.

[C#]
template TimedFloatKeys
{
    < F406B180-7B3B-11cf-8F52-0040333594A3 >
    DWORD time;
    FloatKeys tfkeys;
}
Where: tfkeys - See FloatKeys.


XFileGuid.Url

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Url Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for URL templates. Used internally by Microsoft® DirectX®. Do not use.

Definition

Visual Basic .NET | Public Shared Url As Guid
C# | public static Guid Url;
Managed C++ | public: static Guid Url;
JScript .NET | public static var Url : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for URL templates.

This field is read-only.


XFileGuid.Vector

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileGuid.Vector Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for vector templates.

Definition

Visual Basic .NET | Public Shared Vector As Guid
C# | public static Guid Vector;
Managed C++ | public: static Guid Vector;
JScript .NET | public static var Vector : Guid

Field Value

System.Guid . A Guid Leave Site value that contains the globally unique identifier (GUID) for vector templates.

This field is read-only.

Remarks

Vector templates define a vector, as shown in the following example.

[C#]
template Vector
{
    < 3D82AB5E-62DA-11cf-AB39-0020AF71E433 >
    float x;
    float y;
    float z;
}


Microsoft.DirectX.Direct3D.XFileManager

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager Class

Language:
Note: This documentation is preliminary and is subject to change.

Manages XFile (.x) objects.

Definition

Visual Basic .NET NotInheritable Public Class XFileManager
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class XFileManager : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class XFileManager : public MarshalByRefObject,
IDisposable
JScript .NET public class XFileManager extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileManager object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
CreateSaveObject | Creates a save object.
Dispose | Immediately releases the unmanaged resources used by the XFileManager object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileManager object to free resources before it is destroyed by the garbage collector.
FromFile | Creates an XFile object used to read a .x file.
FromStream | Creates an XFile object from a data stream.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileManager.Disposing event when called from within a derived class.
RegisterDefaultTemplates | Registers default templates.
RegisterTemplates | Registers custom templates.
RegisterXFileTemplates | Registers custom templates from an XFile object.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileManager object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
XFileManager | Initializes a new instance of the XFileManager class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFile interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileManager

Remarks

The object should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


XFileManager.CreateSaveObject(String,XFileFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.CreateSaveObject Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a save object.

Definition

Visual Basic .NET Public Function CreateSaveObject( _
ByVal fileName As String, _
ByVal fileFormat As XFileFormat _
) As XFileSaveObject
C# public XFileSaveObject CreateSaveObject(
string fileName,
XFileFormat fileFormat
);
Managed C++ public: XFileSaveObject* CreateSaveObject(
String *fileName,
XFileFormat fileFormat
);
JScript .NET public function CreateSaveObject(
fileName : String,
fileFormat : XFileFormat
) : XFileSaveObject;

Parameters

fileName | System.String. A String Leave Site instance that contains the name of the file to use for saving data.
fileFormat | Microsoft.DirectX.Direct3D.XFileFormat. Format to use when saving the XFile (.x file). This value can be one of the XFileFormat enumerated vales. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.XFileSaveObject . An XFileSaveObject instance that represents the created save object.

Remarks

The object should be disposed immediately when it is no longer needed.

To create data objects and to save templates or data, use methods of the XFileSaveObject after using this method.

The default value for the file format is Binary. File format values can be combined in a logical or to create compressed text or binary files. If a file is specified as both binary (0) and text (1), it is saved as a text file, because the value is indistinguishable from the text file format value (0 + 1 = 1). If a file is specified as text and compressed, it is first written out as text and then compressed. However, because compressed text files are not as efficient as binary text files, specifying binary and compressed is recommended in most cases. Setting a file to be compressed without specifying a format results in a binary compressed file.

Exceptions
GraphicsException If a parameter is invalid, the GraphicsException.ErrorCode member contains the XFileErrorCodes.BadValue enumerated value. If the file is invalid, GraphicsException.ErrorCode contains the XFileErrorCodes.BadFile enumerated value. If the memory allocation failed, GraphicsException.ErrorCode contains the XFileErrorCodes.BadAlloc enumerated value.

See Also

  • XFileSaveObject


XFileManager.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the XFileManager object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileManager.Disposed
  • Microsoft.DirectX.Direct3D.XFileManager.Disposing


XFileManager.Equals(Object)

XFileManager.Equals Method

Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the XFileManager object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~XFileManager();
Managed C++ | ~XFileManager();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


XFileManager.FromFile(String)

XFileManager.FromFile Method

Note: This documentation is preliminary and is subject to change.

Creates an XFile object used to read a .x file.

Definition

Visual Basic .NET Public Function FromFile( _
ByVal filename As String _
) As XFile
C# public XFile FromFile(
string filename
);
Managed C++ public: XFile* FromFile(
String *filename
);
JScript .NET public function FromFile(
filename : String
) : XFile;

Parameters

filename System.String. The filename of the .x file to read.

Return Value

Microsoft.DirectX.Direct3D.XFile . A newly created XFile object to read the .x file.

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.FromStream

XFileManager.FromStream Method

Note: This documentation is preliminary and is subject to change.

Creates an XFile object from a data stream.

Overload List

public XFile FromStream(Stream);
public XFile FromStream(Stream, int);

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.
ArgumentOutOfRangeException Leave Site | N/A | Length must be greater than zero.
NotSupportedException Leave Site | N/A | The stream must support reading.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.FromStream(Stream)

XFileManager.FromStream Method

Note: This documentation is preliminary and is subject to change.

Creates an XFile object from a data stream.

Definition

Visual Basic .NET Public Function FromStream( _
ByVal data As Stream _
) As XFile
C# public XFile FromStream(
Stream data
);
Managed C++ public: XFile* FromStream(
Stream *data
);
JScript .NET public function FromStream(
data : Stream
) : XFile;

Parameters

data System.IO.Stream. A Stream Leave Site that contains the .x file data.

Return Value

Microsoft.DirectX.Direct3D.XFile . A newly created XFile object.

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.
ArgumentOutOfRangeException Leave Site | N/A | Length must be greater than zero.
NotSupportedException Leave Site | N/A | The stream must support reading.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.FromStream(Stream,Int32)

XFileManager.FromStream Method

Note: This documentation is preliminary and is subject to change.

Creates an XFile object from a data stream.

Definition

Visual Basic .NET Public Function FromStream( _
ByVal data As Stream, _
ByVal length As Integer _
) As XFile
C# public XFile FromStream(
Stream data,
int length
);
Managed C++ public: XFile* FromStream(
Stream *data,
int length
);
JScript .NET public function FromStream(
data : Stream,
length : int
) : XFile;

Parameters

data | System.IO.Stream. A Stream Leave Site that contains the .x file data.
length | System.Int32. The length of the data stream.

Return Value

Microsoft.DirectX.Direct3D.XFile . A newly created XFile object.

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.
ArgumentOutOfRangeException Leave Site | N/A | Length must be greater than zero.
NotSupportedException Leave Site | N/A | The stream must support reading.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.GetHashCode()

XFileManager.GetHashCode Method

Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.GetObjectByValue(Int32)

XFileManager.GetObjectByValue Method

Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFile, which allows unmanaged COM clients to create an instance of the managed XFileManager class. Not supported.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.op_Equality(XFileManager,XFileManager)

XFileManager.op_Equality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As XFileManager, _
ByVal right As XFileManager _
) As Boolean
C# public static bool op_Equality(
XFileManager left,
XFileManager right
);
Managed C++ public: static bool op_Equality(
XFileManager *left,
XFileManager *right
);
JScript .NET public static function op_Equality(
left : XFileManager,
right : XFileManager
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileManager. The XFileManager object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileManager. The XFileManager object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.op_Inequality(XFileManager,XFileManager)

XFileManager.op_Inequality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As XFileManager, _
ByVal right As XFileManager _
) As Boolean
C# public static bool op_Inequality(
XFileManager left,
XFileManager right
);
Managed C++ public: static bool op_Inequality(
XFileManager *left,
XFileManager *right
);
JScript .NET public static function op_Inequality(
left : XFileManager,
right : XFileManager
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileManager. The XFileManager object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileManager. The XFileManager object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.raise_Disposing(Object,EventArgs)

XFileManager.raise_Disposing Method

Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.XFileManager.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.RegisterDefaultTemplates()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.RegisterDefaultTemplates Method

 Language:
Note: This documentation is preliminary and is subject to change.

Registers default templates.

Definition

Visual Basic .NET | Public Sub RegisterDefaultTemplates()
C# | public void RegisterDefaultTemplates();
Managed C++ | public: void RegisterDefaultTemplates();
JScript .NET | public function RegisterDefaultTemplates();


XFileManager.RegisterTemplates(Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.RegisterTemplates Method

 Language:
Note: This documentation is preliminary and is subject to change.

Registers custom templates.

Definition

Visual Basic .NET Public Sub RegisterTemplates( _
ByVal data() As Byte _
)
C# public void RegisterTemplates(
byte[] data
);
Managed C++ public: void RegisterTemplates(
Byte data __gc[]
);
JScript .NET public function RegisterTemplates(
data : byte[]
);

Parameters

data System.Byte[]. Array of Byte Leave Site values that contain the templates.

Remarks

The object should be disposed immediately when it is no longer needed.

Exceptions
GraphicsException
  • If a floating-point size is invalid, the GraphicsException.ErrorCode member contains the XFileErrorCodes.BadFileFloatSize enumerated value.
  • If the file is not an XFile (.x file), GraphicsException.ErrorCode contains the XFileErrorCodes.BadFileType enumerated value.
  • If the file version is not valid, GraphicsException.ErrorCode contains the XFileErrorCodes.BadFileVersion enumerated value.
  • If a parameter is invalid, GraphicsException.ErrorCode contains the XFileErrorCodes.BadValue enumerated value.
  • If the file could not be parsed, GraphicsException.ErrorCode contains the XFileErrorCodes.ParseError enumerated value.


XFileManager.RegisterXFileTemplates(XFile)

XFileManager.RegisterXFileTemplates Method

Note: This documentation is preliminary and is subject to change.

Registers custom templates from an XFile object.

Definition

Visual Basic .NET Public Sub RegisterXFileTemplates( _
ByVal xfileObj As XFile _
)
C# public void RegisterXFileTemplates(
XFile xfileObj
);
Managed C++ public: void RegisterXFileTemplates(
XFile *xfileObj
);
JScript .NET public function RegisterXFileTemplates(
xfileObj : XFile
);

Parameters

xfileObj Microsoft.DirectX.Direct3D.XFile. An XFile object that contains the templates to register.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

See Also

  • XFileManager.RegisterTemplates
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.UpdateUnmanagedPointer(ID3DXFile)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this XFileManager object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFile _
)
C# public void UpdateUnmanagedPointer(
ID3DXFile pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXFile pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXFile
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFile. Pointer to the ID3DXFile structure used to update the unmanaged pointer for this XFileManager object.


XFileManager.XFileManager

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.XFileManager Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileManager class.

Overload List

public XFileManager();
public XFileManager(ID3DXFile);
public XFileManager(IntPtr);


XFileManager.XFileManager(ID3DXFile)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.XFileManager Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileManager class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXFile _
)
C# public XFileManager(
ID3DXFile pUnk
);
Managed C++ public: XFileManager(
ID3DXFile pUnk
);
JScript .NET public function XFileManager(
pUnk : ID3DXFile
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFile. Unmanaged Component Object Model (COM) ID3DXFile interface pointer.


XFileManager.XFileManager(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.XFileManager Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileManager class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileManager(
IntPtr unmanagedObject
);
Managed C++ public: XFileManager(
IntPtr unmanagedObject
);
JScript .NET public function XFileManager(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXFile interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


XFileManager.XFileManager()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.XFileManager Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileManager class.

Definition

Visual Basic .NET | Public Sub New()
C# | public XFileManager();
Managed C++ | public: XFileManager();
JScript .NET | public function XFileManager();


XFileManager.Disposed

XFileManager.Disposed Property

Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileManager.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileManager.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXFile interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXFile
C# | public ID3DXFile UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXFile get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXFile

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFile . Unmanaged ID3DXFile interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


XFileManager.Disposing

XFileManager.Disposing Event

Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the XFileManager object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileManager.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileManager object indicates whether that object has been disposed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.XFileSaveData

XFileSaveData Class

Note: This documentation is preliminary and is subject to change.

Applications use the methods of the XFileSaveData class to add data objects as children of a .x file data node.

Definition

Visual Basic .NET NotInheritable Public Class XFileSaveData
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class XFileSaveData : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class XFileSaveData : public MarshalByRefObject,
IDisposable
JScript .NET public class XFileSaveData extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileSaveData object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDataObject | Adds a data object as a child of the XFileSaveData file data node.
AddDataReference | Adds a data reference as a child of this XFileSaveData file data node. The data reference points to a file data object.
Dispose | Immediately releases the unmanaged resources used by the XFileSaveData object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileSaveData object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetSaveObject | Retrieves the XFileSaveObject for this file data node.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileSaveData.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileSaveData object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.
XFileSaveData | Initializes a new instance of the XFileSaveData class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Id | Retrieves the GUID of this XFileSaveData file data node.
Name | Retrieves the name of this XFileSaveData file data node.
Type | Retrieves the template globally unique identifier (GUID) of this file data node.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileSaveData interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileSaveData

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.AddDataObject(Guid,String,Guid,Byte[])

XFileSaveData.AddDataObject Method

Note: This documentation is preliminary and is subject to change.

Adds a data object as a child of the XFileSaveData file data node.

Definition

Visual Basic .NET Public Function AddDataObject( _
ByVal guidTemplate As Guid, _
ByVal name As String, _
ByVal guidData As Guid, _
ByVal data() As Byte _
) As XFileSaveData
C# public XFileSaveData AddDataObject(
Guid guidTemplate,
string name,
Guid guidData,
byte[] data
);
Managed C++ public: XFileSaveData* AddDataObject(
Guid guidTemplate,
String *name,
Guid guidData,
Byte data __gc[]
);
JScript .NET public function AddDataObject(
guidTemplate : Guid,
name : String,
guidData : Guid,
data : byte[]
) : XFileSaveData;

Parameters

guidTemplate | System.Guid. The globally unique identifier (GUID) representing the data object's template.
name | System.String. The name of the data object to add.
guidData | System.Guid. A globally unique identifier (GUID) representing the data object. The data object must have been registered with XFileManager.RegisterTemplates or XFileManager.RegisterXFileTemplates. Specify null if the object does not have a globally unique identifier (GUID).
data | System.Byte[]. A Byte Leave Site array representing the buffer containing all required data in the data object.

Return Value

Microsoft.DirectX.Direct3D.XFileSaveData . An XFileSaveData object representing the file data node to which the data object will be added.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.AddDataReference(String,Guid)

XFileSaveData.AddDataReference Method

Note: This documentation is preliminary and is subject to change.

Adds a data reference as a child of this XFileSaveData file data node. The data reference points to a file data object.

Definition

Visual Basic .NET Public Sub AddDataReference( _
ByVal name As String, _
ByVal guidData As Guid _
)
C# public void AddDataReference(
string name,
Guid guidData
);
Managed C++ public: void AddDataReference(
String *name,
Guid guidData
);
JScript .NET public function AddDataReference(
name : String,
guidData : Guid
);

Parameters

name | System.String. The name of the data object to add by reference. Specify null if the data object does not have a name.
guidData | System.Guid. The globally unique identifier (GUID) representing the data object to add by reference. If null, a reference will be added that points to the data object with the given name.

Remarks

The file data object being referenced must have either a name or a globally unique identifier (GUID). The file data object must also derive from a different parent XFileSaveData object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Dispose()

XFileSaveData.Dispose Method

Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the XFileSaveData object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileSaveData.Disposed
  • Microsoft.DirectX.Direct3D.XFileSaveData.Disposing
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Equals(Object)

XFileSaveData.Equals Method

Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Finalize()

XFileSaveData.Finalize Method

Note: This documentation is preliminary and is subject to change.

Allows the XFileSaveData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~XFileSaveData();
Managed C++ | ~XFileSaveData();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.GetHashCode()

XFileSaveData.GetHashCode Method

Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.GetObjectByValue(Int32)

XFileSaveData.GetObjectByValue Method

Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFileSaveData, which allows unmanaged COM clients to create an instance of the managed XFileSaveData class. Not supported.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.GetSaveObject()

XFileSaveData.GetSaveObject Method

Note: This documentation is preliminary and is subject to change.

Retrieves the XFileSaveObject for this file data node.

Definition

Visual Basic .NET | Public Function GetSaveObject() As XFileSaveObject
C# | public XFileSaveObject GetSaveObject();
Managed C++ | public: XFileSaveObject* GetSaveObject();
JScript .NET | public function GetSaveObject() : XFileSaveObject;

Return Value

Microsoft.DirectX.Direct3D.XFileSaveObject . An XFileSaveObject representing this file data node.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.op_Equality(XFileSaveData,XFileSaveData)

XFileSaveData.op_Equality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As XFileSaveData, _
ByVal right As XFileSaveData _
) As Boolean
C# public static bool op_Equality(
XFileSaveData left,
XFileSaveData right
);
Managed C++ public: static bool op_Equality(
XFileSaveData *left,
XFileSaveData *right
);
JScript .NET public static function op_Equality(
left : XFileSaveData,
right : XFileSaveData
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileSaveData. The XFileSaveData object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileSaveData. The XFileSaveData object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.op_Inequality(XFileSaveData,XFileSaveData)

XFileSaveData.op_Inequality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As XFileSaveData, _
ByVal right As XFileSaveData _
) As Boolean
C# public static bool op_Inequality(
XFileSaveData left,
XFileSaveData right
);
Managed C++ public: static bool op_Inequality(
XFileSaveData *left,
XFileSaveData *right
);
JScript .NET public static function op_Inequality(
left : XFileSaveData,
right : XFileSaveData
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileSaveData. The XFileSaveData object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileSaveData. The XFileSaveData object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.raise_Disposing(Object,EventArgs)

XFileSaveData.raise_Disposing Method

Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.XFileSaveData.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.UpdateUnmanagedPointer(ID3DXFileSaveData)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveData.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this XFileSaveData object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileSaveData _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileSaveData pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXFileSaveData pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXFileSaveData
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveData. Pointer to the ID3DXFileSaveData structure used to update the unmanaged pointer for this XFileSaveData object.


XFileSaveData.XFileSaveData

XFileSaveData.XFileSaveData Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileSaveData class.

Overload List

public XFileSaveData(ID3DXFileSaveData);
public XFileSaveData(IntPtr);
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.XFileSaveData(ID3DXFileSaveData)

XFileSaveData.XFileSaveData Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileSaveData class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXFileSaveData _
)
C# public XFileSaveData(
ID3DXFileSaveData pUnk
);
Managed C++ public: XFileSaveData(
ID3DXFileSaveData pUnk
);
JScript .NET public function XFileSaveData(
pUnk : ID3DXFileSaveData
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveData. Unmanaged Component Object Model (COM) ID3DXFileSaveData interface pointer.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.XFileSaveData(IntPtr)

XFileSaveData.XFileSaveData Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileSaveData class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileSaveData(
IntPtr unmanagedObject
);
Managed C++ public: XFileSaveData(
IntPtr unmanagedObject
);
JScript .NET public function XFileSaveData(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXFileSaveData interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Disposed

XFileSaveData.Disposed Property

Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Id

XFileSaveData.Id Property

Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) of this XFileSaveData file data node.

Definition

Visual Basic .NET | Public ReadOnly Property Id As Guid
C# | public Guid Id { get; }
Managed C++ | public: __property Guid get_Id();
JScript .NET | public function get Id() : Guid

Property Value

System.Guid . The globally unique identifier (GUID) of this file data node. If the object has no globally unique identifier (GUID), the returned value will be GUID_NULL.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Name

XFileSaveData.Name Property

Note: This documentation is preliminary and is subject to change.

Retrieves the name of this XFileSaveData file data node.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . The name of this file data node.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Type

XFileSaveData.Type Property

Note: This documentation is preliminary and is subject to change.

Retrieves the template globally unique identifier (GUID) of this file data node.

Definition

Visual Basic .NET | Public ReadOnly Property Type As Guid
C# | public Guid Type { get; }
Managed C++ | public: __property Guid get_Type();
JScript .NET | public function get Type() : Guid

Property Value

System.Guid . The globally unique identifier (GUID) representing the template in this file data node.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveData.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXFileSaveData interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXFileSaveData
C# | public ID3DXFileSaveData UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXFileSaveData get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXFileSaveData

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveData . Unmanaged ID3DXFileSaveData interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


XFileSaveData.Disposing

XFileSaveData.Disposing Event

Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the XFileSaveData object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileSaveData.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileSaveData object indicates whether that object has been disposed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.Direct3D.XFileSaveObject

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject Class

Language:
Note: This documentation is preliminary and is subject to change.

Creates and saves data objects and templates.

Definition

Visual Basic .NET NotInheritable Public Class XFileSaveObject
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class XFileSaveObject : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class XFileSaveObject : public MarshalByRefObject,
IDisposable
JScript .NET public class XFileSaveObject extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileSaveObject object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDataObject | Adds a data object as a child of the XFileSaveData object.
Dispose | Immediately releases the unmanaged resources used by the XFileSaveObject object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileSaveObject object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetManager | Retrieves the XFileManager object of the object that created this XFileSaveObject object.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing event when called from within a derived class.
Save | Saves a data object and its children to a .x file on disk.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileSaveObject object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
XFileSaveObject | Initializes a new instance of the XFileSaveObject class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileSaveObject interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileSaveObject

Remarks

Templates are not required in every file. For example, all templates can be placed in a single XFile file rather than being duplicated in every XFile.

The object should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


XFileSaveObject.AddDataObject(Guid,String,Guid,Byte[])

XFileSaveObject.AddDataObject Method

Note: This documentation is preliminary and is subject to change.

Adds a data object as a child of the XFileSaveData object.

Definition

Visual Basic .NET Public Function AddDataObject( _
ByVal guidTemplate As Guid, _
ByVal name As String, _
ByVal guidData As Guid, _
ByVal data() As Byte _
) As XFileSaveData
C# public XFileSaveData AddDataObject(
Guid guidTemplate,
string name,
Guid guidData,
byte[] data
);
Managed C++ public: XFileSaveData* AddDataObject(
Guid guidTemplate,
String *name,
Guid guidData,
Byte data __gc[]
);
JScript .NET public function AddDataObject(
guidTemplate : Guid,
name : String,
guidData : Guid,
data : byte[]
) : XFileSaveData;

Parameters

guidTemplate | System.Guid. The globally unique identifier (GUID) representing the data object's template.
name | System.String. The name of the data object. Specify null if the data object does not have a name.
guidData | System.Guid. A globally unique identifier (GUID) representing the data object. Specify null if the object does not have a globally unique identifier (GUID).
data | System.Byte[]. A Byte Leave Site array as a buffer containing all required data in the data object.

Return Value

Microsoft.DirectX.Direct3D.XFileSaveData . An XFileSaveData object representing the file data node to which the data object will be added.

Remarks

If a data reference object will reference the data object, either the name or guidData parameter must be non-null.

Save the created data to disk by using the XFileSaveObject.Save method.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the XFileSaveObject object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileSaveObject.Disposed
  • Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing


XFileSaveObject.Equals(Object)

XFileSaveObject.Equals Method

Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the XFileSaveObject object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~XFileSaveObject();
Managed C++ | ~XFileSaveObject();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


XFileSaveObject.GetHashCode()

XFileSaveObject.GetHashCode Method

Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.GetManager()

XFileSaveObject.GetManager Method

Note: This documentation is preliminary and is subject to change.

Retrieves the XFileManager object of the object that created this XFileSaveObject object.

Definition

Visual Basic .NET | Public Function GetManager() As XFileManager
C# | public XFileManager GetManager();
Managed C++ | public: XFileManager* GetManager();
JScript .NET | public function GetManager() : XFileManager;

Return Value

Microsoft.DirectX.Direct3D.XFileManager . The XFileManager object of the object that created this XFileSaveObject object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
InvalidCastException Leave Site | N/A | No object interface is available.
NullReferenceException Leave Site | N/A | An invalid pointer, usually null, was passed as a parameter.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.GetObjectByValue(Int32)

XFileSaveObject.GetObjectByValue Method

Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
Managed C++ public: IntPtr GetObjectByValue(
int uniqueKey
);
JScript .NET public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFileSaveObject, which allows unmanaged COM clients to create an instance of the managed XFileSaveObject class. Not supported.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.op_Equality(XFileSaveObject,XFileSaveObject)

XFileSaveObject.op_Equality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As XFileSaveObject, _
ByVal right As XFileSaveObject _
) As Boolean
C# public static bool op_Equality(
XFileSaveObject left,
XFileSaveObject right
);
Managed C++ public: static bool op_Equality(
XFileSaveObject *left,
XFileSaveObject *right
);
JScript .NET public static function op_Equality(
left : XFileSaveObject,
right : XFileSaveObject
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileSaveObject. The XFileSaveObject object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileSaveObject. The XFileSaveObject object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.op_Inequality(XFileSaveObject,XFileSaveObject)

XFileSaveObject.op_Inequality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As XFileSaveObject, _
ByVal right As XFileSaveObject _
) As Boolean
C# public static bool op_Inequality(
XFileSaveObject left,
XFileSaveObject right
);
Managed C++ public: static bool op_Inequality(
XFileSaveObject *left,
XFileSaveObject *right
);
JScript .NET public static function op_Inequality(
left : XFileSaveObject,
right : XFileSaveObject
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.XFileSaveObject. The XFileSaveObject object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.XFileSaveObject. The XFileSaveObject object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.raise_Disposing(Object,EventArgs)

XFileSaveObject.raise_Disposing Method

Note: This documentation is preliminary and is subject to change.

Raises the Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.Save()

XFileSaveObject.Save Method

Note: This documentation is preliminary and is subject to change.

Saves a data object and its children to a .x file on disk.

Definition

Visual Basic .NET | Public Sub Save()
C# | public void Save();
Managed C++ | public: void Save();
JScript .NET | public function Save();

Remarks

After this method succeeds, XFileSaveObject.AddDataObject, XFileSaveData.AddDataObject, and XFileSaveData.AddDataReference can no longer be called until a new XFile object is created.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.UpdateUnmanagedPointer(ID3DXFileSaveObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject.UpdateUnmanagedPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Updates the unmanaged pointer for this XFileSaveObject object. This method supports the Microsoft® .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileSaveObject _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileSaveObject pInterface
);
Managed C++ public: void UpdateUnmanagedPointer(
ID3DXFileSaveObject pInterface
);
JScript .NET public function UpdateUnmanagedPointer(
pInterface : ID3DXFileSaveObject
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveObject. Pointer to the ID3DXFileSaveObject structure used to update the unmanaged pointer for this XFileSaveObject object.


XFileSaveObject.XFileSaveObject

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject.XFileSaveObject Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileSaveObject class.

Overload List

public XFileSaveObject(ID3DXFileSaveObject);
public XFileSaveObject(IntPtr);

Remarks

The object should be disposed immediately when it is no longer needed.


XFileSaveObject.XFileSaveObject(ID3DXFileSaveObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject.XFileSaveObject Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileSaveObject class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pUnk As ID3DXFileSaveObject _
)
C# public XFileSaveObject(
ID3DXFileSaveObject pUnk
);
Managed C++ public: XFileSaveObject(
ID3DXFileSaveObject pUnk
);
JScript .NET public function XFileSaveObject(
pUnk : ID3DXFileSaveObject
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveObject. Unmanaged Component Object Model (COM) ID3DXFileSaveObject interface pointer.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileSaveObject.XFileSaveObject(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject.XFileSaveObject Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the XFileSaveObject class.

Definition

Visual Basic .NET Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileSaveObject(
IntPtr unmanagedObject
);
Managed C++ public: XFileSaveObject(
IntPtr unmanagedObject
);
JScript .NET public function XFileSaveObject(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr. Pointer to an unmanaged Component Object Model (COM) ID3DXFileSaveObject interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileSaveObject.Disposed

XFileSaveObject.Disposed Property

Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.UnmanagedComPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileSaveObject.UnmanagedComPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the unmanaged Component Object Model (COM) ID3DXFileSaveObject interface pointer.

Definition

Visual Basic .NET | Public ReadOnly Property UnmanagedComPointer As ID3DXFileSaveObject
C# | public ID3DXFileSaveObject UnmanagedComPointer { get; }
Managed C++ | public: __property ID3DXFileSaveObject get_UnmanagedComPointer();
JScript .NET | public function get UnmanagedComPointer() : ID3DXFileSaveObject

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveObject . Unmanaged ID3DXFileSaveObject interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.


XFileSaveObject.Disposing

XFileSaveObject.Disposing Event

Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the XFileSaveObject object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileSaveObject object indicates whether that object has been disposed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AnimationOutputFlags

AnimationOutputFlags Enumeration

Note: This documentation is preliminary and is subject to change.

Defines the flags used to create an AnimationOutput object.

Definition

Visual Basic .NET | Public Enum AnimationOutputFlags
C# | public enum AnimationOutputFlags
Managed C++ | __value public enum AnimationOutputFlags
JScript .NET | public enum AnimationOutputFlags

Members

Member | Value | Description
Rotation | 8 | Enable retrieval of the animation's rotation data.
Scale | 2 | Enable retrieval of the animation's scaling data.
Translation | 4 | Enable retrieval of the animation's translation data.
TransformationMatrix | 1 | Enable retrieval of the animation's matrix transformation data.
None | 0 | No output desired.

Remarks

These flags control the outputs an AnimationOutput object encapsulates. A combination of one or more flags is valid when creating an AnimationOutput object.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


BackBufferType

Microsoft DirectX 9.0 SDK Update (October 2004)

BackBufferType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines constants that identify the type of back buffers in a swap chain.

Definition

Visual Basic .NET | Public Enum BackBufferType
C# | public enum BackBufferType
Managed C++ | __value public enum BackBufferType
JScript .NET | public enum BackBufferType

Members

Member | Value | Description
Right | 2 | Not supported.
Left | 1 | Not supported.
Mono | 0 | Nonstereo swap chain (one or more nonstereo back buffers).

Remarks

In stereo view, a stereo pair contains both a right-eye and a left-eye view of a 3-D scene. Microsoft® DirectX® 9.0 does not support stereo view, so neither the Right nor the Left values of this enumerated type are supported.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Device.GetBackBuffer
  • SwapChain.GetBackBuffer


BasisType

Microsoft DirectX 9.0 SDK Update (October 2004)

BasisType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the basis type of a high-order patch surface.

Definition

Visual Basic .NET | Public Enum BasisType
C# | public enum BasisType
Managed C++ | __value public enum BasisType
JScript .NET | public enum BasisType

Members

Member | Value | Description
CatMullRom | 2 | An interpolating basis defines the surface so that it passes through all of the specified input vertices.
BSpline | 1 | Input vertices are treated as control points of a B-spline surface. In general, the generated surface does not contain the specified control vertices.
Bezier | 0 | Input vertices are treated as a series of Bezier patches. The number of vertices specified must be divisible by 3 + 1; portions of the mesh beyond this criterion are not rendered. Full continuity is assumed between sub-patches in the interior of the surface rendered by each call. Only the vertices at the corners of each sub-patch are guaranteed to lie on the resulting surface.

Remarks

The flags in this type specify the formulation to use in evaluating the high-order patch surface primitive during tessellation.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • RectanglePatchInformation
  • TrianglePatchInformation


Blend

Microsoft DirectX 9.0 SDK Update (October 2004)

Blend Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported . (The RGBA values of the source and destination are indicated by the subscripts s and d.)

Definition

Visual Basic .NET | Public Enum Blend
C# | public enum Blend
Managed C++ | __value public enum Blend
JScript .NET | public enum Blend

Members

Member | Value | Description
Zero | 1 | Blend factor is (0, 0, 0, 0).
InvBlendFactor | 15 | Inverted constant color blending factor used by the frame-buffer blender. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.
BlendFactor | 14 | Constant color blending factor used by the frame-buffer blender. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.
BothInvSourceAlpha | 13 | Source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), and destination blend factor is (As, As, As, As); the destination blend selection is overridden. This blend mode is supported only if the RenderStateManager.SourceBlend property is set to true.
BothSourceAlpha | 12 | Obsolete. To achieve the same effect, set the source and destination blend factors to SourceAlpha and InvSourceAlpha in separate calls.
SourceAlphaSat | 11 | Blend factor is (f, f, f, 1); f = min(A, 1 - Ad).
InvDestinationColor | 10 | Blend factor is (1 - Rd, 1 - Gd, 1 - Bd, 1 - Ad).
DestinationColor | 9 | Blend factor is (Rd, Gd, Bd, Ad).
InvDestinationAlpha | 8 | Blend factor is (1 - Ad, 1 - Ad, 1 - Ad, 1 - Ad).
DestinationAlpha | 7 | Blend factor is (Ad, Ad, Ad, Ad).
InvSourceAlpha | 6 | Blend factor is ( 1 - As, 1 - As, 1 - As, 1 - As).
SourceAlpha | 5 | Blend factor is (As, As, As, As).
InvSourceColor | 4 | Blend factor is (1 - Rs, 1 - Gs, 1 - Bs, 1 - As).
SourceColor | 3 | Blend factor is (Rs, Gs, Bs, As).
One | 2 | Blend factor is (1, 1, 1, 1).

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BlendOperation

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendOperation Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported blend operations.

Definition

Visual Basic .NET | Public Enum BlendOperation
C# | public enum BlendOperation
Managed C++ | __value public enum BlendOperation
JScript .NET | public enum BlendOperation

Members

Member Value Description
Subtract 2 Result is the destination subtracted from the source.

Result = Source - Destination
Max 5 Result is the maximum of the source and destination.

Result = MAX(Source, Destination)
Min 4 Result is the minimum of the source and destination.

Result = MIN(Source, Destination)
RevSubtract 3 Result is the source subtracted from the destination.

Result = Destination - Source
Add 1 Result is the destination added to the source.

Result = Source + Destination

Remarks

This enumeration is used by the RenderStateManager.BlendOperation property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • DeviceCaps
  • RenderStateManager


CallbackSearchFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

CallbackSearchFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the flags used to obtain callback information.

Definition

Visual Basic .NET | Public Enum CallbackSearchFlags
C# | public enum CallbackSearchFlags
Managed C++ | __value public enum CallbackSearchFlags
JScript .NET | public enum CallbackSearchFlags

Members

Member | Value | Description
BehindInitialPosition | 2 | Reverses the direction of the callback search.
ExcludingInitialPosition | 1 | Excludes callbacks at the initial position from the search.

Remarks

This enumeration is used by the AnimationSet.GetCallback method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Channel

Microsoft DirectX 9.0 SDK Update (October 2004)

Channel Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines flags that specify which channels in a texture to operate on.

Definition

Visual Basic .NET | Public Enum Channel
C# | public enum Channel
Managed C++ | __value public enum Channel
JScript .NET | public enum Channel

Members

Member | Value | Description
Alpha | 8 | Operation is performed on the alpha channel.
Green | 4 | Operation is performed on the green channel.
Blue | 2 | Operation is performed on the blue channel.
Red | 1 | Operation is performed on the red channel.
Luminance | 16 | Operation is performed on the luminance channel.

Remarks

This enumeration is used by the TextureLoader.ComputeNormalMap method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CharacterSet

Microsoft DirectX 9.0 SDK Update (October 2004)

CharacterSet Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines a character set.

Definition

Visual Basic .NET | Public Enum CharacterSet
C# | public enum CharacterSet
Managed C++ | __value public enum CharacterSet
JScript .NET | public enum CharacterSet

Members

Member | Value | Description
Baltic | 186 | Baltic character set.
Mac | 77 | Characters used by Macintosh.
Russian | 204 | Russian character set.
EastEurope | 238 | Eastern European character set.
Thai | 222 | Thai character set.
Vietnamese | 163 | Vietnamese character set.
Turkish | 162 | Turkish character set.
Greek | 161 | Greek character set.
Arabic | 178 | Arabic character set.
Hebrew | 177 | Hebrew character set.
Johab | 130 | Korean character set.
Oem | 255 | Extended ASCII character set used with disk operating system (DOS) and some Microsoft® Windows® fonts.
ChineseBig5 | 136 | Chinese character set used mostly in Hong Kong SAR and Taiwan.
GB2312 | 134 | Chinese character set used in mainland China.
Hangul | 129 | Korean character set.
Hangeul | 129 | Another common spelling of the Korean character set.
ShiftJIS | 128 | Japanese character set.
Symbol | 2 | Symbol character set.
Default | 1 | System default character set.
Ansi | 0 | ASCII character set.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Font


CleanType

CleanType Enumeration

Note: This documentation is preliminary and is subject to change.

Defines vertex operations to perform in preparation for mesh cleaning.

Definition

Visual Basic .NET | Public Enum CleanType
C# | public enum CleanType
Managed C++ | __value public enum CleanType
JScript .NET | public enum CleanType

Members

Member | Value | Description
Simplification | 3 | Use the Skinning or BowTies flags only as required to prevent infinite loops during mesh operations.
Optimization | 1 | Use the BackFacing flag only as required to prevent infinite loops during mesh operations.
Skinning | 1 | Use the BackFacing flag only as required to prevent infinite loops during mesh operations. Typically used to avoid breaking skinning operations.
BowTies | 2 | If a vertex is the apex of two triangle fans (a bowtie) and mesh operations will affect one of the fans, then split the shared vertex into two new vertices.
BackFacing | 1 | Merge triangles that share the same vertex indices but have face normals pointing in opposite directions (back-facing triangles). Unless vertex indices are corrected so that the triangles have the same vertex winding order, mesh adjacency data from the two triangles may conflict.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ClearFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ClearFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the buffer to use when calling the Device.Clear method.

Definition

Visual Basic .NET | Public Enum ClearFlags
C# | public enum ClearFlags
Managed C++ | __value public enum ClearFlags
JScript .NET | public enum ClearFlags

Members

Member | Value | Description
Target | 1 | Specifies a render target.
Stencil | 4 | Specifies a stencil buffer.
ZBuffer | 2 | Specifies a z-buffer.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClipStatusFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipStatusFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the current clip status.

Definition

Visual Basic .NET | Public Enum ClipStatusFlags
C# | public enum ClipStatusFlags
Managed C++ | __value public enum ClipStatusFlags
JScript .NET | public enum ClipStatusFlags

Members

Member | Value | Description
Back | 32 | All vertices are clipped by the back plane of the viewing frustum.
Front | 16 | All vertices are clipped by the front plane of the viewing frustum.
Plane5 | 2048 | All vertices are clipped by the application-defined clipping plane.
Plane4 | 1024 | All vertices are clipped by the application-defined clipping plane.
Plane3 | 512 | All vertices are clipped by the application-defined clipping plane.
Plane2 | 256 | All vertices are clipped by the application-defined clipping plane.
Plane1 | 128 | All vertices are clipped by the application-defined clipping plane.
Plane0 | 64 | All vertices are clipped by the application-defined clipping plane.
All | 4095 | Combination of all clip flags.
Bottom | 8 | All vertices are clipped by the bottom plane of the viewing frustum.
Top | 4 | All vertices are clipped by the top plane of the viewing frustum.
Right | 2 | All vertices are clipped by the right plane of the viewing frustum.
Left | 1 | All vertices are clipped by the left plane of the viewing frustum.

Remarks

When clipping is enabled during vertex processing (by Device.ProcessVertices, Device.DrawPrimitives, or other drawing functions), Microsoft® Direct3D® computes a clip code for every vertex. The clip code is a combination of ClipStatusFlags. When a vertex is outside a particular clipping plane, the corresponding bit is set in the clip code. Direct3D maintains the clip status using ClipStatus, which has ClipIntersection and ClipUnion properties. ClipUnion is a bitwise OR of all vertex clip codes, and ClipIntersection is a bitwise AND of all vertex clip codes. Initial values are 0 for ClipUnion and 0xFFFFFFFF for ClipIntersection. When the RenderStateManager.Clipping property is set to false, ClipUnion and ClipIntersection are set to 0. Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion and ClipIntersection to their initial values and continue drawing.

Clip status is not updated by Device.DrawRectanglePatch and Device.DrawTrianglePatch because there is no software emulation for these methods.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorSource

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSource Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the location at which a color or color component must be accessed for lighting calculations.

Definition

Visual Basic .NET | Public Enum ColorSource
C# | public enum ColorSource
Managed C++ | __value public enum ColorSource
JScript .NET | public enum ColorSource

Members

Member | Value | Description
Color2 | 2 | Use the specular vertex color.
Color1 | 1 | Use the diffuse vertex color.
Material | 0 | Use the color from the current material.

Remarks

This enumeration is used to set the DiffuseMaterialSource, EmissiveMaterialSource, SpecularMaterialSource, and AmbientMaterialSource properties in the RenderStateManager class type.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorWriteEnable

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorWriteEnable Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines values that are used to specify a channel in the RenderStateManager class type.

Definition

Visual Basic .NET | Public Enum ColorWriteEnable
C# | public enum ColorWriteEnable
Managed C++ | __value public enum ColorWriteEnable
JScript .NET | public enum ColorWriteEnable

Members

Member | Value | Description
Alpha | 8 | Alpha channel of a buffer.
Blue | 4 | Blue channel of a buffer.
Green | 2 | Green channel of a buffer.
Red | 1 | Red channel of a buffer.
RedGreenBlueAlpha | 15 | All channels of a buffer.
RedGreenBlue | 7 | The red, green, and blue channels of a buffer.

Remarks

This enumeration is used by the ColorWriteEnable, ColorWriteEnable1, ColorWriteEnable2, and ColorWriteEnable3 properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • RenderStates


Compare

Microsoft DirectX 9.0 SDK Update (October 2004)

Compare Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported compare functions in the RenderStateManager class type.

Definition

Visual Basic .NET | Public Enum Compare
C# | public enum Compare
Managed C++ | __value public enum Compare
JScript .NET | public enum Compare

Members

Member | Value | Description
Always | 8 | Always pass the test.
Never | 1 | Always fail the test.
GreaterEqual | 7 | Accept the new pixel if its value is greater than or equal to the value of the current pixel.
NotEqual | 6 | Accept the new pixel if its value does not equal the value of the current pixel.
Greater | 5 | Accept the new pixel if its value is greater than the value of the current pixel.
LessEqual | 4 | Accept the new pixel if its value is less than or equal to the value of the current pixel.
Equal | 3 | Accept the new pixel if its value is equal to the value of the current pixel.
Less | 2 | Accept the new pixel if its value is less than the value of the current pixel.

Remarks

The StencilFunction, AlphaFunction, CounterClockwiseStencilFunction, and ZBufferFunction properties use this enumeration.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • RenderStateManager


CompressionFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the compression mode to use for storing compressed animation set data.

Definition

Visual Basic .NET | Public Enum CompressionFlags
C# | public enum CompressionFlags
Managed C++ | __value public enum CompressionFlags
JScript .NET | public enum CompressionFlags

Members

Member | Value | Description
Default | 0 | Implements fast compression.

Remarks

This enumeration is used by the KeyframedAnimationSet.Compress method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • KeyframedAnimationSet


CompressionQuality

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionQuality Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines spherical harmonic (SH) compression settings.

Definition

Visual Basic .NET | Public Enum CompressionQuality
C# | public enum CompressionQuality
Managed C++ | __value public enum CompressionQuality
JScript .NET | public enum CompressionQuality

Members

Member | Value | Description
SlowHighQuality | 2 | The data compression is high quality, but is slow to compress.
FastLowQuality | 1 | The data compression is low quality, but is fast to compress.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CreateFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the flags to use when creating a device.

Definition

Visual Basic .NET | Public Enum CreateFlags
C# | public enum CreateFlags
Managed C++ | __value public enum CreateFlags
JScript .NET | public enum CreateFlags

Members

Member | Value | Description
NoWindowChanges | 2048 | Indicates to the Microsoft® Direct3D® runtime not to alter the focus window in any way. Use with caution! The burden of supporting focus management events (alt-tab, etc.) falls on the application, and appropriate responses (switching display mode, etc.) should be coded.
DisableDriverManagementEx | 1024 | Specifies that resources be managed by Microsoft® Direct3D® instead of the driver. Microsoft® Direct3D® calls will fail for resource errors such as insufficient video memory.
AdapterGroupDevice | 512 | The application requests that the device drive all heads that the master adapter owns (this flag is illegal on non-master adapters). If the flag is set, the presentation parameters passed to Device should be an array of PresentParameters that contains exactly NumberOfAdaptersInGroup elements. The runtime assigns each element to each head in AdapterOrdinalInGroup numeric order.
DisableDriverManagement | 256 | Specifies that resources be managed by Microsoft® Direct3D® instead of the driver. Microsoft® Direct3D® calls will not fail for resource errors such as insufficient video memory.
MixedVertexProcessing | 128 | Specifies mixed vertex processing (both software and hardware).
HardwareVertexProcessing | 64 | Specifies hardware vertex processing.
SoftwareVertexProcessing | 32 | Specifies software vertex processing.
PureDevice | 16 | Specifies that Microsoft® Direct3D® not support Get calls for anything that can be stored in a state block. Also instructs Microsoft® Direct3D® to withhold emulation services for vertex processing, which means that if the device does not support vertex processing, the application can use only post-transformed vertices.
MultiThreaded | 4 | Indicates that the application requested multithread safety in Microsoft® Direct3D®. This causes Microsoft® Direct3D® to check its global critical section more frequently, which can degrade performance. In Microsoft® DirectX® 9.1 for Managed Code, this enumerated value is always specified unless the PresentParameters.ForceNoMultiThreadedFlag is set to true.
FpuPreserve 2 Indicates that the application needs either floating-point unit (FPU) exceptions or double-precision FPU exceptions enabled. By default, Microsoft® Direct3D® uses single precision.

Because Microsoft® Direct3D® sets the FPU state every time it is called, setting this flag reduces Microsoft® Direct3D® performance.

Remarks

This enumeration is used by the Device constructor. The HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing constants are mutually exclusive. One of them must be specified during creation of a Device.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Creating a Device
  • Processing Vertex Data
  • BehaviorFlags


CubeMapFace

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeMapFace Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the faces of a cube map in the CubeTexture class type.

Definition

Visual Basic .NET | Public Enum CubeMapFace
C# | public enum CubeMapFace
Managed C++ | __value public enum CubeMapFace
JScript .NET | public enum CubeMapFace

Members

Member | Value | Description
NegativeZ | 5 | Negative z-face of the cube map.
PositiveZ | 4 | Positive z-face of the cube map.
NegativeY | 3 | Negative y-face of the cube map.
PositiveY | 2 | Positive y-face of the cube map.
NegativeX | 1 | Negative x-face of the cube map.
PositiveX | 0 | Positive x-face of the cube map.

Remarks

This enumeration is used by the AddDirtyRectangle, GetCubeMapSurface, LockRectangle, and UnlockRectangle methods.

The values in this enumerated type also define faces of a cube map in the RenderToEnvironmentMap.Face method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • RenderToEnvironmentMap


Cull

Microsoft DirectX 9.0 SDK Update (October 2004)

Cull Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported culling modes, which specify how back faces are culled during geometry rendering.

Definition

Visual Basic .NET | Public Enum Cull
C# | public enum Cull
Managed C++ | __value public enum Cull
JScript .NET | public enum Cull

Members

Member | Value | Description
CounterClockwise | 3 | Cull back faces with counterclockwise vertices.
Clockwise | 2 | Cull back faces with clockwise vertices.
None | 1 | Do not cull back faces.

Remarks

This enumeration is used by the RenderStateManager.CullMode property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeclarationMethod

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationMethod Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the declaration methods for a vertex declaration.

Definition

Visual Basic .NET | Public Enum DeclarationMethod
C# | public enum DeclarationMethod
Managed C++ | __value public enum DeclarationMethod
JScript .NET | public enum DeclarationMethod

Members

Member | Value | Description
LookUpPresampled | 6 | Looks up a pre-sampled displacement map. The input type must be set to Unused, and the stream index and stream offset must be set to 0. The output type for this operation is always Float1. The device must support displacement mapping. This constant is supported only by the programmable pipeline on N-patch data, if N-patches are enabled.
LookUp | 5 | Looks up a displacement map. The input type can be Float2, Float3, or Float4. Only the .x and .y components are used for the texture map lookup. The output type is always Float1. The device must support displacement mapping. This constant is supported only by the programmable pipeline on N-patch data, if N-patches are enabled.
UV | 4 | Copies out the u and v values at a point on the rectangle or triangle patch. This results in a 2-D float. The input type must be set to Unused; the output type is always Float2. The input stream and offset also are unused, but must be set to 0.
CrossUv | 3 | Computes the normal at a point on the rectangle or triangle patch as the cross product of the two tangents. The input type can be any of the DeclarationType float values, Color, Ubyte4, or Short4. The output type is always Float3.
PartialV | 2 | Computes the tangent at a point on the rectangle or triangle patch in the v direction. The input type can be Float3, Float4, Color, Ubyte4, or Short4. The output type is always Float3.
PartialU | 1 | Computes the tangent at a point on the rectangle or triangle patch in the u direction. The input type can be Float3, Float4, Color, Ubyte4, or Short4. The output type is always Float3.
Default | 0 | Default value. The tessellator copies the vertex data (or the spline data if it is operating on a patch) without performing additional calculations on it. The input and output types can be any value. When the tessellator is used, this element is interpolated; otherwise, vertex data is copied into the input register.

Remarks

The VertexElement structure uses DeclarationMethod values to determine which vertex data to calculate during tessellation. These values can be passed into the constructor or to the DeclarationMethod property. Mesh data should use the default value. Patches can use any of the other implemented types.

Vertex data is declared with an array of VertexElement structures. Each element in the array contains a vertex declaration method.

In addition to using Default, a normal mesh can use LookUp and LookUpPresampled when N-patches are enabled.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeclarationType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines declaration types for a vertex declaration.

Definition

Visual Basic .NET | Public Enum DeclarationType
C# | public enum DeclarationType
Managed C++ | __value public enum DeclarationType
JScript .NET | public enum DeclarationType

Members

Member | Value | Description
Float16Four | 16 | Four 16-bit floating-point values expanded to (value, value, value, value). This type is valid for vertex shader version 2.0 or higher.
Float16Two | 15 | Two 16-bit floating-point values expanded to (value, value, 0, 1). This type is valid for vertex shader version 2.0 or higher.
Dec3N | 14 | 3-D signed 10 10 10 format, normalized and expanded to (v[0]/511.0, v[1]/511.0, v[2]/511.0, 1).
UDec3 | 13 | 3-D unsigned 10 10 10 format, expanded to (value, value, value, 1).
UShort4N | 12 | Normalized 4-D unsigned short, expanded to (First byte/65535.0, second byte/65535.0, third byte/65535.0, fourth byte/65535.0). This type is valid for vertex shader version 2.0 or higher.
UShort2N | 11 | Normalized, 2-D unsigned short, expanded to (First byte/65535.0, second byte/65535.0, 0, 1). This type is valid for vertex shader version 2.0 or higher.
Short4N | 10 | Normalized, 4-D signed short, expanded to (First byte/32767.0, second byte/32767.0, third byte/32767.0, fourth byte/32767.0). This type is valid for vertex shader version 2.0 or higher.
Short2N | 9 | Normalized, 2-D signed short, expanded to (First byte/32767.0, second byte/32767.0, 0, 1). This type is valid for vertex shader version 2.0 or higher.
Ubyte4N | 8 | Each of 4 bytes is normalized by dividing to 255.0. This type is valid for vertex shader version 2.0 or higher.
Short4 | 7 | 4-D signed short, expanded to (value, value, value, value).
Short2 | 6 | 2-D signed short, expanded to (value, value, 0, 1).
Ubyte4 | 5 | 4-D unsigned byte.
Float4 | 3 | 4-D float, expanded to (float, float, float, float).
Float3 | 2 | 3-D float, expanded to (float, float, float, 1).
Float2 | 1 | 2-D float, expanded to (float, float, 0, 1).
Float1 | 0 | 1-D float, expanded to (float, 0, 0, 1).
Unused | 17 | Type field in the declaration is unused. This is designed for use with UV and LookUpPresampled.
Color | 4 | 4-D packed unsigned bytes, mapped to 0 to 1 range. Input is in Int32 Leave Site format (ARGB) expanded to (R, G, B, A).

Remarks

Vertex data is declared with an array of VertexElement structures. Each element in the array contains a vertex declaration method. These values can be passed into the constructor or to the DeclarationMethod property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeclarationUsage

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationUsage Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines declaration usage for a vertex declaration.

Definition

Visual Basic .NET | Public Enum DeclarationUsage
C# | public enum DeclarationUsage
Managed C++ | __value public enum DeclarationUsage
JScript .NET | public enum DeclarationUsage

Members

Member | Value | Description
Depth | 12 | Vertex data contains depth data.
Sample | 13 | Vertex data contains sampler data. (Sample with VertexElement.UsageIndex = 0) specifies the displacement value to look up. This flag can be used only with LookUpPresampled or LookUp.
Fog | 11 | Vertex data contains fog data. (Fog with VertexElement.UsageIndex = 0) specifies a fog blend value to use after pixel shading is finished. This flag applies to pixel shaders prior to version ps_3_0.
PositionTransformed | 9 | Vertex data contains transformed position data. (PositionTransformed with VertexElement.UsageIndex = 0) specifies the transformed position. When a declaration that contains this flag is set, the pipeline does not perform vertex processing.
TessellateFactor | 8 | Single positive floating-point value. (TessellateFactor with VertexElement.UsageIndex = 0) specifies a tessellation factor used in the tessellation unit to control the rate of tessellation. For more information about the data type, see Float1.
BiNormal | 7 | Vertex binormal data.
Tangent | 6 | Vertex tangent data.
TextureCoordinate | 5 | Texture coordinate data. (TextureCoordinate, n) specifies texture coordinates in fixed function vertex processing and in pixel shaders prior to ps_3_0. These coordinates can be used to pass user-defined data.
BlendIndices | 2 | Blending indices data. (BlendIndices with VertexElement.UsageIndex = 0) specifies matrix indices for fixed function vertex processing using indexed paletted skinning.
BlendWeight | 1 | Blending weight data. (BlendWeight with VertexElement.UsageIndex = 0) specifies the blend weights in fixed function vertex processing.
Color | 10 | Vertex data contains diffuse or specular color. (Color with VertexElement.UsageIndex = 0) specifies the diffuse color in the fixed function vertex shader and in pixel shaders prior to ps_3_0. (Color with VertexElement.UsageIndex = 1) specifies the specular color in the fixed function vertex shader and in pixel shaders prior to ps_3_0.
PointSize | 4 | Point size data. (PointSize with VertexElement.UsageIndex = 0) specifies the point-size attribute used by the setup engine of the rasterizer to expand a point into a quad for the point-sprite functionality.
Normal | 3 | Vertex normal data. (Normal with VertexElement.UsageIndex = 0) specifies vertex normals for fixed function vertex processing and the N-patch tessellator. (Normal with VertexElement.UsageIndex = 1) specifies vertex normals for fixed function vertex processing for skinning.
Position | 0 | Position data. (Position with VertexElement.UsageIndex = 0 ) specifies the nontransformed position in fixed function vertex processing and the N-patch tessellator. (Position with VertexElement.UsageIndex = 1) specifies the nontransformed position in the fixed function vertex shader for skinning.

Remarks

Vertex data is declared with an array of VertexElement structures. Each element in the array contains a usage type.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DegreeType

Microsoft DirectX 9.0 SDK Update (October 2004)

DegreeType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the degree of the variables in an equation that describes a curve.

Definition

Visual Basic .NET | Public Enum DegreeType
C# | public enum DegreeType
Managed C++ | __value public enum DegreeType
JScript .NET | public enum DegreeType

Members

Member | Value | Description
Quintic | 5 | Curve is described by variables of fourth order.
Cubic | 3 | Curve is described by variables of third order.
Quadratic | 2 | Curve is described by variables of second order.
Linear | 1 | Curve is described by variables of first order.

Remarks

This enumeration is used to describe the curves used by rectangle and triangle patches.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • RenderStateManager
  • Caps


DepthFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

DepthFormat Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines depth buffer formats.

Definition

Visual Basic .NET | Public Enum DepthFormat
C# | public enum DepthFormat
Managed C++ | __value public enum DepthFormat
JScript .NET | public enum DepthFormat

Members

Member | Value | Description
Unknown | 0 | Format is unknown.
D24SingleS8 | 83 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 8 bits for the stencil channel.
D32SingleLockable | 82 | A lockable format in which the depth value is represented as a standard IEEE floating-point number.
D24X4S4 | 79 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 4 bits for the stencil channel.
D24X8 | 77 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel.
L16 | 81 | A 16-bit luminance format.
D16 | 80 | A 16-bit z-buffer bit depth.
D24S8 | 75 | A nonlockable format that contains 24 bits of depth (in a 24-bit floating-point format - 20E4) and 8 bits of stencil.
D15S1 | 73 | A 16-bit z-buffer bit depth in which 15 bits are reserved for the depth channel and 1 bit is reserved for the stencil channel.
D32 | 71 | A 32-bit z-buffer bit depth.
D16Lockable | 70 | A 16-bit z-buffer bit depth.

Remarks

All depth-stencil formats except D16Lockable indicate no particular bit ordering per pixel, and the driver is allowed to consume more than the indicated number of bits per depth channel (but not stencil channel).

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CreateDepthStencilSurface
  • Tutorial 4: Using Materials and Lights


DeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies a device type.

Definition

Visual Basic .NET | Public Enum DeviceType
C# | public enum DeviceType
Managed C++ | __value public enum DeviceType
JScript .NET | public enum DeviceType

Members

Member | Value | Description
NullReference | 4 | A null version of the reference rasterizer.
Software | 3 | A pluggable software device.
Reference | 2 | Microsoft® Direct3D® features are implemented in software; however, the reference rasterizer uses special CPU instructions whenever possible.
Hardware | 1 | Hardware rasterization. Shading is done with software, hardware, or mixed transform and lighting.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Manager
  • GetDeviceCaps
  • Caps
  • DeviceType
  • DeviceCreationParameters
  • DeviceType


DisplacementMap

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementMap Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Identifies a texture sampler stage.

Definition

Visual Basic .NET | Public Enum DisplacementMap
C# | public enum DisplacementMap
Managed C++ | __value public enum DisplacementMap
JScript .NET | public enum DisplacementMap

Members

Member | Value | Description
VertexTextureSampler3 | 260 | Texture sampler stage 3.
VertexTextureSampler2 | 259 | Texture sampler stage 2.
VertexTextureSampler1 | 258 | Texture sampler stage 1.
VertexTextureSampler0 | 257 | Texture sampler stage 0.
Sampler | 256 | Internal constant used by the texture sampler in the tessellator.

Remarks

These values are returned by the Manager.CheckDeviceFormat method. They also can be used in the Device.SetTexture method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrawTextFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawTextFormat Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the method of formatting text.

Definition

Visual Basic .NET | Public Enum DrawTextFormat
C# | public enum DrawTextFormat
Managed C++ | __value public enum DrawTextFormat
JScript .NET | public enum DrawTextFormat

Members

Member | Value | Description
Top | 0 | Top-justifies text (on a single line only).
Right | 2 | Aligns text to right.
Left | 0 | Aligns text to left.
Bottom | 8 | Justifies text to the bottom of the rectangle. This value must be combined with SingleLine.
WordBreak | 16 | Breaks words. Lines are automatically broken between words if a word extends past the edge of the rectangle specified by the rect parameter. A carriage return/line feed sequence also breaks the line.
VerticalCenter | 4 | Centers text vertically (on a single line only).
SingleLine | 32 | Displays text on a single line only. Carriage returns and line feeds do not break the line.
RightToLeftReading | 131072 | Displays text in right-to-left reading order for bidirectional text when a Hebrew or Arabic font is selected. The default reading order for all text is left-to-right.
NoClip | 256 | Draws without clipping. Font.DrawText is somewhat faster when NoClip is used.
ExpandTabs | 64 | Expands tab characters. The default number of characters per tab is eight. The PathEllipsis and EndEllipsis values cannot be used with the ExpandTabs value.
Center | 1 | Centers text horizontally in the rectangle.
CalculateRect | 1024 | Determines the width and height of the rectangle. If there are multiple lines of text, Font.DrawText uses the width of the rectangle specified by the rect parameter and extends the base of the rectangle to bound the last line of text. If there is only one line of text, Font.DrawText modifies the right side of the rectangle so that it bounds the last character in the line. In either case, Font.DrawText returns the height of the formatted text but does not draw the text.
None | 0 | Specifies no formatting.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectDefaultType

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDefaultType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines effect data types.

Definition

Visual Basic .NET | Public Enum EffectDefaultType
C# | public enum EffectDefaultType
Managed C++ | __value public enum EffectDefaultType
JScript .NET | public enum EffectDefaultType

Members

Member | Value | Description
Floats | 2 | Data type is an array of floating-point values.
Integer | 3 | Forces this enumeration to compile to 32 bits in size. This value is not used.
String | 1 | Data type is a String Leave Site object.

Remarks

This enumeration is used by the EffectDefault.Data property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EventType

Microsoft DirectX 9.0 SDK Update (October 2004)

EventType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the types of events that can be keyed by the animation controller.

Definition

Visual Basic .NET | Public Enum EventType
C# | public enum EventType
Managed C++ | __value public enum EventType
JScript .NET | public enum EventType

Members

Member | Value | Description
PriorityBlend | 4 | Priority blend value.
TrackEnable | 3 | Enable flag.
TrackPosition | 2 | Track position.
TrackWeight | 1 | Track weight.
TrackSpeed | 0 | Track speed.

Remarks

This enumeration is used by the EventDescription.EventType property, which can be passed to an AnimationController class type.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FillMode

Microsoft DirectX 9.0 SDK Update (October 2004)

FillMode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines constants that describe the fill mode.

Definition

Visual Basic .NET | Public Enum FillMode
C# | public enum FillMode
Managed C++ | __value public enum FillMode
JScript .NET | public enum FillMode

Members

Member | Value | Description
Solid | 3 | Fill solids.
WireFrame | 2 | Fill wireframes.
Point | 1 | Fill points.

Remarks

This enumeration is used by the RenderStateManager.FillMode property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Filter

Microsoft DirectX 9.0 SDK Update (October 2004)

Filter Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines texture filtering modes for a texture stage.

Definition

Visual Basic .NET | Public Enum Filter
C# | public enum Filter
Managed C++ | __value public enum Filter
JScript .NET | public enum Filter

Members

Member | Value | Description
Box | 5 | Each pixel is computed by averaging a 2x2(x2) box of pixels from the source image. This filter works only when the dimensions of the destination are half those of the source, as is the case with mipmaps.
Point | 2 | Each destination pixel is computed by sampling the nearest pixel from the source image.
Srgb | 6291456 | Same as specifying SrgbIn | SrgbOut.
SrgbOut | 4194304 | Output data is in sRGB (gamma 2.2) color space.
SrgbIn | 2097152 | Input data is in sRGB (gamma 2.2) color space.
DitherDiffusion | 1048576 | Resulting image must be dithered using a 4x4 ordered dither algorithm.
Dither | 524288 | Resulting image must be dithered using a 4x4 ordered dither algorithm.
Mirror | 458752 | Same as specifying the MirrorU, MirrorV, and MirrorW flags. This flag is always used internally for this function.
MirrorW | 262144 | Pixels off the edge of the texture on the w-axis should be mirrored, not wrapped.
MirrorV | 131072 | Pixels off the edge of the texture on the v-axis should be mirrored, not wrapped.
MirrorU | 65536 | Pixels off the edge of the texture on the u-axis should be mirrored, not wrapped.
Triangle | 4 | Each pixel in the source image contributes equally to the destination image. This is the slowest of the filters.
Linear | 3 | Bilinear interpolation filtering is used as a texture magnification or minification filter. A weighted average of a 2x2 area of texels surrounding the desired pixel is used. The texture filter to use between mipmap levels is trilinear mipmap interpolation. The rasterizer interpolates pixel color in a linear manner, using the texels of the two nearest textures.
None | 1 | Mipmapping disabled. The rasterizer uses the magnification filter instead.

Remarks

Each valid filter must contain exactly one of the following flags: None, Point, Linear, Triangle, or Box. In addition, the bitwise OR operator can be used to specify zero or more of the following optional flags with a valid filter: MirrorU, MirrorV, MirrorW, Mirror, or Dither.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • TextureLoader
  • VolumeLoader
  • SurfaceLoader


FogMode

Microsoft DirectX 9.0 SDK Update (October 2004)

FogMode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines constants that describe the fog mode.

Definition

Visual Basic .NET | Public Enum FogMode
C# | public enum FogMode
Managed C++ | __value public enum FogMode
JScript .NET | public enum FogMode

Members

Member | Value | Description
Linear 3 Fog effect intensifies in a linear manner between the start and end points, according to the following formula.

Linear fog equation

Exp2 2 Fog effect intensifies exponentially with the square of the distance, according to the following formula.

exponential square fog equation

Exp 1 Fog effect intensifies exponentially, according to the following formula.

Exponential fog equation

None | 0 | No fog effect.

Remarks

This enumeration is used by the RenderStateManager.FogTableMode and RenderStateManager.FogVertexMode properties.

Fog can be considered a measure of visibility. The lower the fog value produced by a fog equation, the less visible an object is.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FontQuality

Microsoft DirectX 9.0 SDK Update (October 2004)

FontQuality Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the level of font quality.

Definition

Visual Basic .NET | Public Enum FontQuality
C# | public enum FontQuality
Managed C++ | __value public enum FontQuality
JScript .NET | public enum FontQuality

Members

Member | Value | Description
ClearTypeNatural | 6 | Text is rendered using the Microsoft® ClearType® antialiasing (smoothing) method when possible. The font quality is given more importance than maintaining the text size; thus, the text width can change. When using this mode for measuring and rendering, ensure that the application does not cache any layout information. If it does, remote users who do not have Microsoft® ClearType® enabled will view different width and metrics.
ClearType | 5 | Microsoft® Windows® XP: Text is rendered using the Microsoft® ClearType® antialiasing method when possible. The font quality is given less importance than maintaining the text size.
AntiAliased 4 Microsoft® Windows NT® 4.0 and later: Font is antialiased, if it supports antialiasing and if its size falls within the accepted range.

Microsoft® Windows® 95 with Microsoft® Plus!, Microsoft® Windows® 98/Microsoft® Windows® Millennium Edition (Windows Me): The display must be greater than 8-bit color, must be a single plane device, cannot be a palette display, and cannot be part of a multiple-display monitor setup. In addition, a TrueType® font must be selected into a screen device context before it is used in a DIBSection (a structure that contains information about a device-independent bitmap); otherwise, antialiasing does not occur.
NonAntiAliased | 3 | Microsoft® Windows® 95 with Microsoft® Plus!, Microsoft® Windows® 98/Microsoft® Windows® Millennium Edition (Windows Me), Microsoft® Windows NT® 4.0 and later: Font is never antialiased.
Proof | 2 | Font's character quality is given more importance than exact matching of the logical-font attributes. For Microsoft® Windows® Graphics Device Interface (GDI) raster fonts, scaling is disabled and the font closest in size is chosen. Although this size might not correspond exactly when Proof is used, the font's quality is high and its appearance is not distorted. Bold, italic, underline, and strikeout fonts are synthesized if necessary.
Draft | 1 | Font's appearance is given less importance than when the Proof value is used. Scaling is enabled for Microsoft® Windows® Graphics Device Interface (GDI) raster fonts, which means that more font sizes are available, but their quality might be lower. Bold, italic, underline, and strikeout fonts are synthesized if necessary.
Default | 0 | Font's appearance does not matter.

Remarks

In Microsoft® Windows® XP, the following situations do not support Microsoft ClearType® antialiasing:

  • Text rendered on a printer.
  • A display set for 256 colors or less.
  • Text rendered on a Terminal Server client.
  • The font is not a TrueType® font or an OpenType® font with TrueType outlines. For example, the following do not support ClearType antialiasing:

    Type 1 fonts, Postscript OpenType® fonts without TrueType outlines, bitmap fonts, vector fonts, and device fonts.

  • The font has tuned embedded bitmaps only for the font sizes that contain the embedded bitmaps. For example, this occurs commonly in East Asian fonts.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FontWeight

Microsoft DirectX 9.0 SDK Update (October 2004)

FontWeight Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies font weights.

Definition

Visual Basic .NET | Public Enum FontWeight
C# | public enum FontWeight
Managed C++ | __value public enum FontWeight
JScript .NET | public enum FontWeight

Members

Member | Value | Description
Black | 900 | 900 font weight.
UltraBold | 800 | 800 font weight.
DemiBold | 600 | 600 font weight.
Regular | 400 | 400 font weight.
UltraLight | 200 | 200 font weight.
Heavy | 900 | 900 font weight.
ExtraBold | 800 | 800 font weight.
Bold | 700 | 700 font weight.
SemiBold | 600 | 600 font weight.
Medium | 500 | 500 font weight.
ExtraLight | 200 | 200 font weight.
Thin | 100 | 100 font weight.
DoNotCare | 0 | 0 font weight.
Normal | 400 | 400 font weight.
Light | 300 | 300 font weight.

Remarks

These enumerated values are defined as a convenience for different numerical font weights.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Format

Microsoft DirectX 9.0 SDK Update (October 2004)

Format Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines various types of surface formats. For a more complete discussion, see Surface Formats.

Definition

Visual Basic .NET | Public Enum Format
C# | public enum Format
Managed C++ | __value public enum Format
JScript .NET | public enum Format

Members

Member | Value | Description
D24SingleS8 | 83 | Nonlockable format that contains 24 bits of depth (in a 24-bit floating-point format - 20e4) and 8 bits of stencil.
D32SingleLockable | 82 | Lockable format in which the depth value is represented as a standard IEEE floating-point number.
D24X4S4 | 79 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 4 bits for the stencil channel.
D24X8 | 77 | A 2-bit z-buffer bit depth that uses 24 bits for the depth channel.
L16 | 81 | 16-bit luminance only.
D16 | 80 | A 16-bit z-buffer bit depth.
D24S8 | 75 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 8 bits for the stencil channel.
D15S1 | 73 | A 16-bit z-buffer bit depth that reserves 15 bits for the depth channel and 1 bit for the stencil channel.
D32 | 71 | A 32-bit z-buffer bit depth.
D16Lockable | 70 | A 16-bit z-buffer bit depth.
G8R8G8B8 | 1111970375 | A 16-bit packed RGB format analogous to YUY2 (Y0U0, Y1V0, Y2U2, etc.). It requires a pixel pair to properly represent the color value. The first pixel in the pair contains 8 bits of green (in the high 8 bits) and 8 bits of red (in the low 8 bits). The second pixel contains 8 bits of green (in the high 8 bits) and 8 bits of blue (in the low 8 bits). Together, the two pixels share the red and blue components, and each has a unique green component (G0R0, G1B0, G2R2, etc.). The texture sampler does not normalize the colors when looking up into a pixel shader; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed function pixel shader, the hardware should normalize to the range of 0.f to 1.f and treat it as the YUY2 texture. Hardware that exposes this format must have Caps.PixelShader1xMaxValue set to a value capable of handling that range.
R8G8B8G8 | 1195525970 | A 16-bit packed RGB format analogous to UYVY (U0Y0, V0Y1, U2Y2, etc.). It requires a pixel pair to properly represent the color value. The first pixel in the pair contains 8 bits of green (in the low 8 bits) and 8 bits of red (in the high 8 bits). The second pixel contains 8 bits of green (in the low 8 bits) and 8 bits of blue (in the high 8 bits). Together, the two pixels share the red and blue components, and each has a unique green component (R0G0, B0G1, R2G2, etc.). The texture sampler does not normalize the colors when looking up into a pixel shader; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed function pixel shader, the hardware should normalize to the range of 0.f to 1.f and treat it as the YUY2 texture. Hardware that exposes this format must have Caps.PixelShader1xMaxValue set to a value capable of handling that range.
CxV8U8 | 117 | A 32-bit normal compression format. The texture sampler computes the C channel from the signed most significant byte and least significant byte values.
A32B32G32R32F | 116 | Floating-point surface format that uses 32 bits per channel.
G32R32F | 115 | Floating-point surface format that uses 32 bits per channel.
R32F | 114 | Floating-point surface format that uses 32 bits per channel.
A16B16G16R16F | 113 | A 64-bit float format that uses 16 bits per channel (alpha, blue, green, red).
G16R16F | 112 | Floating-point surface format that uses 16 bits per channel.
R16F | 111 | Floating-point surface format that uses 16 bits per channel.
Multi2Argb8 | 827606349 | MET1 compression texture format.
Q16W16V16U16 | 110 | A 64-bit bump-map format that uses 16 bits for each component.
VertexData | 100 | Vertex buffer surface.
Dxt5 | 894720068 | DXT5 compression texture format.
Dxt4 | 877942852 | DXT4 compression texture format.
Dxt3 | 861165636 | DXT3 compression texture format.
Dxt2 | 844388420 | DXT2 compression texture format.
Dxt1 | 827611204 | DXT1 compression texture format.
Yuy2 | 844715353 | YUY2 format (PC98 compliance).
Uyvy | 1498831189 | UYVY format (PC98 compliance).
A2W10V10U10 | 67 | A 32-bit bump-map format that uses 2 bits for alpha and 10 bits each for w, v, and u data.
V16U16 | 64 | A 32-bit bump-map format that uses 16 bits per channel.
Q8W8V8U8 | 63 | A 32-bit bump-map format that uses 8 bits per channel.
X8L8V8U8 | 62 | A 32-bit bump-map format with luminance that uses 8 bits per channel.
L6V5U5 | 61 | A 16-bit bump-map format with luminance that uses 6 bits for luminance and 5 bits each for v and u data.
V8U8 | 60 | A 16-bit bump-map format that uses 8 bits each for u and v data.
A4L4 | 52 | An 8-bit format that uses 4 bits each for alpha and luminance.
A8L8 | 51 | A 16-bit format that uses 8 bits each for alpha and luminance.
L8 | 50 | An 8-bit format with luminance only.
P8 | 41 | An 8-bit format, color indexed.
A8P8 | 40 | An 8-bit format, color indexed with 8 bits of alpha.
A16B16G16R16 | 36 | A 64-bit pixel format that uses 16 bits per component.
A2R10G10B10 | 35 | A 32-bit pixel format that uses 10 bits each for red, green, and blue, and 2 bits for alpha.
G16R16 | 34 | A 32-bit pixel format that uses 16 bits each for green and red.
X8B8G8R8 | 33 | A 32-bit RGB pixel format that reserves 8 bits for each color.
A8B8G8R8 | 32 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
A2B10G10R10 | 31 | A 32-bit pixel format that uses 10 bits for each color and 2 bits for alpha.
X4R4G4B4 | 30 | A 16-bit RGB pixel format that uses 4 bits per color.
A8R3G3B2 | 29 | A 16-bit ARGB texture format that uses 8 bits for alpha, 3 bits each for red and green, and 2 bits for blue.
A8 | 28 | 8-bit alpha only.
R3G3B2 | 27 | An 8-bit RGB texture format that uses 3 bits for red, 3 bits for green, and 2 bits for blue.
A4R4G4B4 | 26 | A 16-bit ARGB pixel format that uses 4 bits per channel.
A1R5G5B5 | 25 | A 16-bit pixel format that reserves 5 bits for each color and 1 bit for alpha.
X1R5G5B5 | 24 | A 16-bit pixel format that reserves 5 bits for each color.
R5G6B5 | 23 | A 16-bit RGB pixel format that uses 5 bits for red, 6 bits for green, and 5 bits for blue.
X8R8G8B8 | 22 | A 32-bit RGB pixel format that reserves 8 bits for each color.
A8R8G8B8 | 21 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
R8G8B8 | 20 | A 24-bit RGB pixel format that uses 8 bits per channel.
Unknown | 0 | Unknown surface format.

Remarks

For a more complete discussion, see Surface Formats.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Surface Formats
  • Resource Properties
  • CheckDeviceFormat


FX

Microsoft DirectX 9.0 SDK Update (October 2004)

FX Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines flags for saving shader state.

Definition

Visual Basic .NET | Public Enum FX
C# | public enum FX
Managed C++ | __value public enum FX
JScript .NET | public enum FX

Members

Member | Value | Description
None | 0 | No state is saved or restored.
DoNotSaveSamplerState | 4 | Sampler state is not saved when calling Effect.Begin, or restored when calling Effect.End.
DoNotSaveShaderState | 2 | Shader state is not saved when calling Effect.Begin, or restored when calling Effect.End.
DoNotSaveState | 1 | Device state is not saved when calling Effect.Begin, or restored when calling Effect.End.

Remarks

This enumeration is used in the Effect class to determine whether the state modified by an effect is saved and restored.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GpuSimulatorOption

Microsoft DirectX 9.0 SDK Update (October 2004)

GpuSimulatorOption Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the resolution of the shadow z-buffer that will be used in precomputed radiance transfer (PRT) direct lighting simulation on the graphics processing unit (GPU). A higher quality z-buffer can also be specified to reduce noise in the results of the direct lighting simulation, although the simulation will be slower.

Definition

Visual Basic .NET | Public Enum GpuSimulatorOption
C# | public enum GpuSimulatorOption
Managed C++ | __value public enum GpuSimulatorOption
JScript .NET | public enum GpuSimulatorOption

Members

Member | Value | Description
Default | 0 | Same as ShadowRes512.
HighQuality | 4 | The simulation is of high precision, regardless of the selected resolution. Setting this value will reduce noise in the results of the direct lighting simulation, although the simulation will be slower. May be combined with one of the other values.
ShadowRes2048 | 3 | Highest resolution simulation. A 2048 x 2048 pixel texture is used in the simulation to encode the shadow z-buffer.
ShadowRes1024 | 2 | High resolution simulation. A 1024 x 1024 pixel texture is used in the simulation to encode the shadow z-buffer.
ShadowRes512 | 0 | Medium resolution simulation. A 512 x 512 pixel texture is used in the simulation to encode the shadow z-buffer. This is the default value.
ShadowRes256 | 1 | Low resolution simulation. A 256 x 256 pixel texture is used in the simulation to encode the shadow z-buffer.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ImageFileFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageFileFormat Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported image file formats.

Definition

Visual Basic .NET | Public Enum ImageFileFormat
C# | public enum ImageFileFormat
Managed C++ | __value public enum ImageFileFormat
JScript .NET | public enum ImageFileFormat

Members

Member | Value | Description
Pfm | 8 | Portable float map file format.
Hdr | 7 | High dynamic-range file format.
Dib | 6 | Microsoft® Windows® bitmap file format.
Ppm | 5 | Portable pixmap file format.
Dds | 4 | DirectDrawSurface file format.
Png | 3 | Portable Network Graphics file format.
Tga | 2 | Truevision Targa image file format.
Jpg | 1 | Joint Photographic Experts Group (JPEG) compressed file format.
Bmp | 0 | Microsoft® Windows® bitmap file format.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ImageFileFormat
  • Save
  • Save


IncludeType

Microsoft DirectX 9.0 SDK Update (October 2004)

IncludeType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines an include file.

Definition

Visual Basic .NET | Public Enum IncludeType
C# | public enum IncludeType
Managed C++ | __value public enum IncludeType
JScript .NET | public enum IncludeType

Members

Member | Value | Description
System | 1 | Indicates a system resource.
Local | 0 | Indicates a local resource.

Remarks

This enumeration is used by the Include.Open method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IssueFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

IssueFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines issue flags.

Definition

Visual Basic .NET | Public Enum IssueFlags
C# | public enum IssueFlags
Managed C++ | __value public enum IssueFlags
JScript .NET | public enum IssueFlags

Members

Member | Value | Description
End | 1 | Specifies that the runtime issue the beginning of a query.
Begin | 2 | Specifies that the runtime issue the end of a query.

Remarks

This enumeration is used with the Query.Issue method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LightType

Microsoft DirectX 9.0 SDK Update (October 2004)

LightType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the light type.

Definition

Visual Basic .NET | Public Enum LightType
C# | public enum LightType
Managed C++ | __value public enum LightType
JScript .NET | public enum LightType

Members

Member | Value | Description
Directional | 3 | Light is a directional light source. It is equivalent to using a point light source at an infinite distance.
Spot | 2 | Light is a spotlight source. It is similar to a point light, except that the area of illumination is limited to a cone. This light type has a direction and several other parameters that determine the shape of the cone it produces. For more information, see the Light class.
Point | 1 | Light is a point source. The light has a position in space and radiates light in all directions.

Remarks

Directional lights are slightly faster than point lights, but point lights look a little better. Spotlights offer interesting visual effects but are slow.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LockFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

LockFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the type of lock to perform.

Definition

Visual Basic .NET | Public Enum LockFlags
C# | public enum LockFlags
Managed C++ | __value public enum LockFlags
JScript .NET | public enum LockFlags

Members

Member | Value | Description
Discard 8192 The application overwrites every location within the region being locked, using a write-only operation. This is a valid option when using dynamic textures, dynamic vertex buffers, and dynamic index buffers.

For vertex and index buffers, the application discards the entire buffer. A pointer to a new memory area is returned so that the direct memory access (DMA) and rendering from the previous area do not stall. For textures, the application overwrites every location within the region being locked, using a write-only operation.
DoNotWait 16384 The application is allowed to gain back CPU cycles if the driver cannot lock the surface immediately. When this is the case, the lock call throws WasStillDrawingException.

This flag can be used only when calling Surface.LockRectangle on surfaces created using Device.CreateOffscreenPlainSurface, Device.CreateRenderTarget, or Device.CreateDepthStencilSurface. It also can be used with a back buffer.
NoDirtyUpdate | 32768 | By default, a lock on a resource adds a dirty region to that resource. This flag prevents any changes to the dirty state of the resource. Applications should use this flag when they have additional information about the set of regions changed during the lock operation.
NoSystemLock 2048 By default, a video memory lock reserves a system-wide critical section, guaranteeing that no display mode changes will occur for the duration of the lock. This flag prevents the system-wide critical section from being held while the lock is on.

While the lock operation is time-consuming, it enables the system to perform other duties, such as moving the mouse cursor. This flag is useful for locks of long duration; for example, locking the back buffer for software rendering that otherwise would slow the system.
NoOverwrite | 4096 | The application is guaranteed not to overwrite any data in the vertex and index buffers. This flag allows the driver to return immediately and continue rendering, using this vertex buffer. If the flag is not used, the driver must finish rendering before returning from locking.
ReadOnly | 16 | The application does not write to the buffer. This flag enables resources stored in non-native formats to save the recompression step when unlocking.
None | 0 | Use no locks.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Locking Resources


MeshFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines flags used to specify creation options for a mesh.

Definition

Visual Basic .NET | Public Enum MeshFlags
C# | public enum MeshFlags
Managed C++ | __value public enum MeshFlags
JScript .NET | public enum MeshFlags

Members

Member | Value | Description
SimplifyFace | 2 | Simplifies the mesh by the number of faces specified in the minValue parameter of the Mesh.Simplify method.
SimplifyVertex | 1 | Simplifies the mesh by the number of vertices specified in the minValue parameter of the Mesh.Simplify method.
OptimizeDeviceIndependent | 4194304 | Specifies a default vertex cache size that works well on older hardware.
OptimizeDoNotSplit | 536870912 | Specifies that vertices shared between attribute groups should not be split during attribute sorting.
OptimizeIgnoreVerts | 268435456 | Optimizes the faces only; does not optimize the vertices.
OptimizeStripeReorder | 134217728 | Reorders faces to maximize the length of adjacent triangles.
OptimizeVertexCache | 67108864 | Reorders faces to increase the cache hit rate of vertex caches.
OptimizeAttributeSort | 33554432 | Reorders faces to optimize for fewer attribute bundle state changes and enhanced BaseMesh.DrawSubset performance.
OptimizeCompact | 16777216 | Reorders faces to remove unused vertices and faces.
SoftwareProcessing | 98304 | Equivalent to specifying both VbSoftwareProcessing and IbSoftwareProcessing.
Dynamic | 2176 | Equivalent to specifying both VbDynamic and IbDynamic.
WriteOnly | 1088 | Equivalent to specifying both VbWriteOnly and IbWriteOnly.
Managed | 544 | Equivalent to specifying both VbManaged and IbManaged.
SystemMemory | 272 | Equivalent to specifying both VbSystemMem and IbSystemMem.
UseHardwareOnly | 8192 | Specifies use of hardware processing only. For mixed-mode devices, this flag causes the system to use hardware processing if it is supported, and software processing otherwise.
VbShare | 4096 | Forces the cloned meshes to share vertex buffers.
IbSoftwareProcessing | 65536 | Specifies use of the SoftwareProcessing usage flag for index buffers.
IbDynamic | 2048 | Specifies use of the Dynamic usage flag for index buffers.
IbWriteOnly | 1024 | Specifies use of the WriteOnly usage flag for index buffers.
IbManaged | 512 | Specifies use of the Managed memory class for index buffers.
IbSystemMem | 256 | Specifies use of the SystemMemory memory class for index buffers.
VbSoftwareProcessing | 32768 | Specifies use of the SoftwareProcessing usage flag for vertex buffers.
VbDynamic | 128 | Specifies use of the Dynamic usage flag for vertex buffers.
VbWriteOnly | 64 | Specifies use of the WriteOnly usage flag for vertex buffers.
VbManaged | 32 | Specifies use of the Managed memory class for vertex buffers.
VbSystemMem | 16 | Specifies use of the SystemMemory memory class for vertex buffers.
NPatches | 16384 | Causes the vertex and index buffer of the mesh to be created with the NPatches flag. This is required if the mesh object will be rendered using N-patch enhancement with Microsoft® Direct3D®.
RtPatches | 8 | Used for vertex and index buffers.
Points | 4 | Used for vertex and index buffers.
DoNotClip | 2 | Used for vertex and index buffers.
Use32Bit | 1 | Specifies 32-bit indices instead of 16-bit indices for the mesh.

Remarks

A 32-bit mesh can theoretically support (232)-1 faces and vertices. However, allocating memory for such a large mesh is not practical on a 32-bit operating system.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Tutorial 6: Using Meshes


MultiSampleType

Microsoft DirectX 9.0 SDK Update (October 2004)

MultiSampleType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the levels of full-scene multisampling that the device can apply.

Definition

Visual Basic .NET | Public Enum MultiSampleType
C# | public enum MultiSampleType
Managed C++ | __value public enum MultiSampleType
JScript .NET | public enum MultiSampleType

Members

Member | Value | Description
SixteenSamples | 16 | Enables 16 levels of full-scene multisampling.
FifteenSamples | 15 | Enables 15 levels of full-scene multisampling.
FourteenSamples | 14 | Enables 14 levels of full-scene multisampling.
ThirteenSamples | 13 | Enables 13 levels of full-scene multisampling.
TwelveSamples | 12 | Enables 12 levels of full-scene multisampling.
ElevenSamples | 11 | Enables 11 levels of full-scene multisampling.
TenSamples | 10 | Enables 10 levels of full-scene multisampling.
NineSamples | 9 | Enables nine levels of full-scene multisampling.
EightSamples | 8 | Enables eight levels of full-scene multisampling.
SevenSamples | 7 | Enables seven levels of full-scene multisampling.
SixSamples | 6 | Enables six levels of full-scene multisampling.
FiveSamples | 5 | Enables five levels of full-scene multisampling.
FourSamples | 4 | Enables four levels of full-scene multisampling.
ThreeSamples | 3 | Enables three levels of full-scene multisampling.
TwoSamples | 2 | Enables two levels of full-scene multisampling.
NonMaskable | 1 | Enables the multisample quality value.
None | 0 | Specifies no full-scene multisampling, and enables swap effects other than SwapEffect.Discard.

Remarks

When multisampling is enabled, all subsamples of a pixel are updated in one pass. However, when subsamples are used for other effects that involve multiple rendering passes, the application can specify that only some of them be affected by a given rendering pass. This latter approach enables simulation of motion blur, depth-of-field focus effects, reflection blur, and other effects.

In addition to enabling full-scene multisampling when a Device.Reset occurs, there are render states that turn various multisampling aspects on and off at fine-grained levels. For more information, see RenderStateManager.

Multisampling is valid only on a swap chain that is created or reset with SwapEffect.Discard.

The multisampling antialiasing value can be set with the parameters or sub-parameters in the following methods.

Module | Parameters | Sub-Parameters
Manager.CheckDeviceMultiSampleType | multiSampleType, qualityLevels | None
Device.CreateDepthStencilSurface | multiSample, multiSampleQuality | None
Device.CreateRenderTarget | multiSample, multiSampleQuality | None
SwapChain.SwapChain | presentationParameters | multiSample, multiSampleQuality
Device.Device | presentationParameters | multiSample, multiSampleQuality
Device.Reset | presentationParameters | multiSample, multiSampleQuality

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • PresentParameters
  • SurfaceDescription


NormalMap

Microsoft DirectX 9.0 SDK Update (October 2004)

NormalMap Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the flags used to convert a height map into a normal map.

Definition

Visual Basic .NET | Public Enum NormalMap
C# | public enum NormalMap
Managed C++ | __value public enum NormalMap
JScript .NET | public enum NormalMap

Members

Member | Value | Description
ComputeOcclusion | 1048576 | Computes the per-pixel occlusion term and encodes it into the alpha. An alpha of 1 means that the pixel is not obscured in any way; an alpha of 0 means that the pixel is completely obscured.
InvertSign | 524288 | Inverts the direction of each normal.
Mirror | 196608 | Same as specifying MirrorU and MirrorV.
MirrorV | 131072 | Indicates that pixels off the edge of the texture on the v-axis should be mirrored, not wrapped.
MirrorU | 65536 | Indicates that pixels off the edge of the texture on the u-axis should be mirrored, not wrapped.

Remarks

The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • TextureLoader.ComputeNormalMap


ParameterClass

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterClass Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the class of the object.

Definition

Visual Basic .NET | Public Enum ParameterClass
C# | public enum ParameterClass
Managed C++ | __value public enum ParameterClass
JScript .NET | public enum ParameterClass

Members

Member | Value | Description
Struct | 5 | Object is a structure.
Object | 4 | Object is a texture, a shader, or a string.
MatrixColumns | 3 | Object is a column major matrix.
MatrixRows | 2 | Object is a row major matrix.
Vector | 1 | Object is a vector.
Scalar | 0 | Object is a scalar.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ShaderTypeInformation
  • ConstantDescription


ParameterFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines shader and effect constants.

Definition

Visual Basic .NET | Public Enum ParameterFlags
C# | public enum ParameterFlags
Managed C++ | __value public enum ParameterFlags
JScript .NET | public enum ParameterFlags

Members

Member | Value | Description
Annotation | 4 | The parameter is marked as an annotation.
Shared | 1 | The value of a parameter will be shared by all effects in the same namespace. Changing the value in one effect will change it in all shared effects.
Literal | 2 | The parameter is marked as a literal value. Literal parameters cannot change after compile, allowing the compiler to optimize their usage. Shared parameters cannot be marked as a literal.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ParameterType

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the data contained by the enumeration.

Definition

Visual Basic .NET | Public Enum ParameterType
C# | public enum ParameterType
Managed C++ | __value public enum ParameterType
JScript .NET | public enum ParameterType

Members

Member | Value | Description
Sampler | 10 | Parameter is a sampler.
Boolean | 1 | Parameter is a Boolean Leave Site value.
Void | 0 | Parameter is a Void Leave Site object.
SamplerCube | 14 | Parameter is a cube sampler.
Sampler3D | 13 | Parameter is a 3-D sampler.
Sampler2D | 12 | Parameter is a 2-D sampler.
Sampler1D | 11 | Parameter is a 1-D sampler.
TextureCube | 9 | Parameter is a cube texture.
Texture3D | 8 | Parameter is a 3-D texture.
Texture2D | 7 | Parameter is a 2-D texture.
Texture1D | 6 | Parameter is a 1-D texture.
String | 4 | Parameter is a String Leave Site object.
Float | 3 | Parameter is a floating-point number.
Integer | 2 | Parameter is an Int32 Leave Site value.
VertexShader | 16 | Parameter is a vertex shader.
PixelShader | 15 | Parameter is a pixel shader.
Texture | 5 | Parameter is a texture.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ShaderTypeInformation
  • ConstantDescription


PatchEdge

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchEdge Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines whether the current tessellation mode is discrete or continuous.

Definition

Visual Basic .NET | Public Enum PatchEdge
C# | public enum PatchEdge
Managed C++ | __value public enum PatchEdge
JScript .NET | public enum PatchEdge

Members

Member | Value | Description
Continuous | 1 | Continuous edge style. Tessellation is specified as float values, which can be varied smoothly to reduce popping artifacts.
Discrete | 0 | Discrete edge style. Tessellation can be specified as float values, but they will be truncated to integers.

Remarks

Continuous and discrete tessellation produce completely different patterns for the same tessellation values; for example, 4.0 continuous is not the same as 4 discrete. This difference is more apparent in wireframe mode than when rendering fully textured or color-filled scenes.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • RenderStateManager.PatchEdgeStyle


PatchType

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines mesh patch types.

Definition

Visual Basic .NET | Public Enum PatchType
C# | public enum PatchType
Managed C++ | __value public enum PatchType
JScript .NET | public enum PatchType

Members

Member | Value | Description
Rectangle | 1 | Rectangle patch mesh type.
NPatch | 3 | N-patch mesh type.
Triangle | 2 | Triangle patch mesh type.

Remarks

Triangle patches are three-sided; rectangle patches are four-sided. For more information, see TrianglePatchInformation and RectanglePatchInformation.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • PatchInformation


PitchAndFamily

Microsoft DirectX 9.0 SDK Update (October 2004)

PitchAndFamily Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines font families.

Definition

Visual Basic .NET | Public Enum PitchAndFamily
C# | public enum PitchAndFamily
Managed C++ | __value public enum PitchAndFamily
JScript .NET | public enum PitchAndFamily

Members

Member | Value | Description
FamilyDecorative | 80 | Specifies a novelty font; for example, Old English.
FamilyScript | 64 | Specifies a font that is designed to look like handwriting; for example, Script and Cursive.
FamilyModern | 48 | Specifies a monospace font with or without serifs. Monospace fonts are usually modern; examples include Pica, Elite, and Courier New.
FamilySwiss | 32 | Specifies a proportional font without serifs; for example, Arial.
FamilyRoman | 16 | Specifies a proportional font with serifs; for example, Times New Roman.
FamilyDoNotCare | 0 | Specifies a generic family name, which is used when information about a font does not exist or does not matter. The default font is used.
MonoFont | 8 | Specifies a monospace font.
VariablePitch | 2 | Specifies a variable-pitch font.
FixedPitch | 1 | Specifies a fixed-pitch font.
DefaultPitch | 0 | Specifies default pitch.

Remarks

A font family is a set of fonts that have common stroke width and serif characteristics. There are five font families; a sixth family allows an application to use the default font.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlaybackType

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the type of looping mode to use for playback of an animation set.

Definition

Visual Basic .NET | Public Enum PlaybackType
C# | public enum PlaybackType
Managed C++ | __value public enum PlaybackType
JScript .NET | public enum PlaybackType

Members

Member | Value | Description
PingPong | 2 | Animation alternates endlessly between playing forward and playing backward.
Once | 1 | Animation plays once, then stops on the last frame.
Loop | 0 | Animation repeats endlessly.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Pool

Microsoft DirectX 9.0 SDK Update (October 2004)

Pool Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the memory class that holds buffers for a resource.

Definition

Visual Basic .NET | Public Enum Pool
C# | public enum Pool
Managed C++ | __value public enum Pool
JScript .NET | public enum Pool

Members

Member | Value | Description
Scratch | 3 | Resources are placed in system RAM and do not need to be re-created when a device is lost. These resources are not bound by device size or format restrictions; therefore, they cannot be accessed by the Microsoft® Direct3D® device or set as textures or render targets. They can, however, always be created, locked, and copied.
SystemMemory | 2 | Resources consume system RAM but do not reduce pageable RAM. System memory is not typically accessible by the 3-D device. These resources do not need to be re-created when a device is lost. They can be locked and also used as the source for a Device.UpdateSurface or Device.UpdateTexture operation to a memory resource created with Default.
Managed | 1 | Resources are copied automatically to device-accessible memory as needed. Managed resources are backed by system memory and do not need to be re-created when a device is lost. For more information, see Managing Resources.
Default 0 Resources are placed in the memory pool most appropriate for the set of usages requested for the given resource. This is usually video memory, including both local video memory and accelerated graphics port memory. The Default pool is separate from Managed and SystemMemory, and it specifies that the resource be placed in the preferred memory for device access. Note that Default never indicates that either Managed or SystemMemory should be chosen as the memory pool type for this resource.

Textures placed in the Default pool cannot be locked unless they are dynamic textures or private four-character code (FOURCC) driver formats. Accessing unlockable textures requires the use of functions such as Device.UpdateSurface or Device.UpdateTexture. Managed is probably a better choice than Default for most applications.

Some textures can be locked; for example, those created in driver proprietary pixel formats that are unknown to the Microsoft® Direct3D® runtime. Swap-chain back buffers, render targets, vertex buffers, and index buffers can be locked. When a device is lost, resources created using Default must be disposed of before calling Device.Reset. Microsoft® DirectX® 9.0 for Managed Code automatically handles disposal of resources that need it, provided the Device.IsUsingEventHandlers property is set to true (the default setting). For more information, see Lost Devices.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Resource Properties


Precision

Microsoft DirectX 9.0 SDK Update (October 2004)

Precision Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the desired output precision.

Definition

Visual Basic .NET | Public Enum Precision
C# | public enum Precision
Managed C++ | __value public enum Precision
JScript .NET | public enum Precision

Members

Member | Value | Description
Device | 5 | When more than one font has a given name, use the device font if available.
PsOnly | 10 | Microsoft® Windows® 2000/Microsoft® Windows® XP: When more than one font has a given name, choose a PostScript font if available.
ScreenOutline | 9 | Specifies an outline-based screen font.
Outline | 8 | Microsoft® Windows NT®/Microsoft® Windows® 2000/Microsoft® Windows® XP: This value instructs the font mapper to choose from TrueType and other outline-based fonts.
TtOnly | 7 | Microsoft® Windows® 2000/Microsoft® Windows® XP: When more than one font has a given name, use the TrueType® font if available.
Raster | 6 | When more than one font has a given name, use the raster font if available.
Tt | 4 | When more than one font has a given name, use the TrueType® font if available.
Stroke | 3 | Specifies a font with attributes that exactly match the requested attributes.
Character | 2 | Specifies the font with a size (height and width) that most closely matches the requested size. The driver may disregard the requested orientation, but other attributes must match.
String | 1 | Specifies a font with a size (height and width) that most closely matches the requested size. The driver may disregard the requested orientation and escapement, but other attributes must match.
Default | 0 | Specifies any reasonable font.

Remarks

The output precision defines how closely the output must match the requested fonts height, width, character orientation, escapement, and pitch.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Present

Microsoft DirectX 9.0 SDK Update (October 2004)

Present Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines flags that allow the application to request that the SwapChain.Present return immediately when the driver reports that it cannot schedule a presentation.

Definition

Visual Basic .NET | Public Enum Present
C# | public enum Present
Managed C++ | __value public enum Present
JScript .NET | public enum Present

Members

Member | Value | Description
LinearContent | 2 | Performs gamma correction from linear space to sRGB for windowed swap chains. This flag takes effect only when the driver exposes SupportsLinearToSrgbPresentation.
DoNotWait | 1 | Performs the presentation operation without waiting. If the hardware is busy processing or waiting for a vertical sync interval, the method throws WasStillDrawingException.
BackBuffersMax | 3 | Returns the maximum number of back buffers supported.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PresentFlag

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentFlag Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines flags that control a Device.Present operation.

Definition

Visual Basic .NET | Public Enum PresentFlag
C# | public enum PresentFlag
Managed C++ | __value public enum PresentFlag
JScript .NET | public enum PresentFlag

Members

Member | Value | Description
Video | 16 | Informs the driver that the back buffers contain video data.
DeviceClip | 4 | Clips a windowed Device.Present blit into the window client area, within the monitor screen area of the video adapter that created the Microsoft® Direct3D® device. This flag works only on Microsoft® Windows® 2000 and Microsoft® Windows® XP.
DiscardDepthStencil 2 Enables z-buffer discarding if set when the device or swap chain is created. When this flag is set, the contents of the depth stencil buffer are invalid after either Device.Present or Device.DepthStencilSurface are called.

Discarding z-buffer data can increase performance and is dependent on the driver. The debug runtime enforces discarding by clearing the z-buffer to some constant value after calling either Device.Present or Device.DepthStencilSurface with a different depth surface.

Discarding z-buffer data is illegal for all lockable formats, D16Lockable, and D32Lockable. Using Device.Device to specify a lockable format and z-buffer discarding will result in failure. For more information about formats, see Format.
LockableBackBuffer 1 Gives the application the ability to lock the back buffer directly. Note that back buffers are not lockable unless the application specifies LockableBackBuffer when calling Device.Device or Device.Reset. Lockable back buffers incur a performance cost on some graphics hardware configurations.

Performing a lock operation (or using Device.UpdateSurface to write on the lockable back buffer) decreases performance on many cards. In this case, consider using textured triangles to move data to the back buffer.
None | 0 | Use no presentation flags.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PresentInterval

Microsoft DirectX 9.0 SDK Update (October 2004)

PresentInterval Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines flags that describe the relationship between the adapter refresh rate and the rate at which Device.Present operations are completed.

Definition

Visual Basic .NET | Public Enum PresentInterval
C# | public enum PresentInterval
Managed C++ | __value public enum PresentInterval
JScript .NET | public enum PresentInterval

Members

Member | Value | Description
Immediate | -2147483648 | The runtime updates the window client area immediately, and might do so more than once during the adapter refresh period. Device.Present operations might be affected immediately. This option is always available for both windowed and full-screen swap chains.
Four | 8 | The driver waits for the vertical retrace period. Device.Present operations are not affected more frequently than every fourth screen refresh. Check the Caps.PresentationIntervals property to determine whether the driver supports this option.
Three | 4 | The driver waits for the vertical retrace period. Device.Present operations are not affected more frequently than every third screen refresh. Check the Caps.PresentationIntervals property to determine whether the driver supports this option.
Two | 2 | The driver waits for the vertical retrace period. Device.Present operations are not affected more frequently than every second screen refresh. Check the Caps.PresentationIntervals property to determine whether the driver supports this option.
One | 1 | The driver waits for the vertical retrace period (the runtime will beam trace to prevent tearing). Device.Present operations are not affected more frequently than the screen refresh rate; the runtime completes one Device.Present operation per adapter refresh period, at most. This option is always available for both windowed and full-screen swap chains.
Default | 0 | Equivalent to setting One.

Remarks

This enumeration is used by the Caps.PresentationIntervals and PresentParameters.PresentationInterval properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrimitiveType

Microsoft DirectX 9.0 SDK Update (October 2004)

PrimitiveType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Generate a Scene

Defines the primitives supported by Microsoft® Direct3D®.

Definition

Visual Basic .NET | Public Enum PrimitiveType
C# | public enum PrimitiveType
Managed C++ | __value public enum PrimitiveType
JScript .NET | public enum PrimitiveType

Members

Member | Value | Description
TriangleFan | 6 | Renders the vertices as a triangle fan.
TriangleStrip | 5 | Renders the vertices as a triangle strip. The back face culling flag is flipped automatically on even-numbered triangles.
TriangleList | 4 | Renders the specified vertices as a sequence of isolated triangles. Each group of three vertices defines a separate triangle. Back face culling is affected by the current winding-order render state.
LineStrip | 3 | Renders the vertices as a single polyline. Calls that use this primitive type fail if the count is less than two.
LineList | 2 | Renders the vertices as a list of isolated straight line segments. Calls that use this primitive type fail if the count is less than two or is odd.
PointList | 1 | Renders the vertices as a collection of isolated points. This value is unsupported for indexed primitives.

Remarks

Using Triangle Strips or Triangle Fans is often more efficient than using Triangle Lists because fewer vertices are duplicated.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Device-Supported Primitive Types


PriorityType

Microsoft DirectX 9.0 SDK Update (October 2004)

PriorityType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the priority type an animation track is assigned to.

Definition

Visual Basic .NET | Public Enum PriorityType
C# | public enum PriorityType
Managed C++ | __value public enum PriorityType
JScript .NET | public enum PriorityType

Members

Member | Value | Description
High | 1 | Blends the track with all high-priority tracks before the high-priority blend is mixed with the low-priority blend.
Low | 0 | Blends the track with all low-priority tracks before the low-priority blend is mixed with the high-priority blend.

Remarks

Tracks with the same priority are blended together, and the two resulting values are then blended using the priority blend factor.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


QueryType

Microsoft DirectX 9.0 SDK Update (October 2004)

QueryType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the query type.

Definition

Visual Basic .NET | Public Enum QueryType
C# | public enum QueryType
Managed C++ | __value public enum QueryType
JScript .NET | public enum QueryType

Members

Member | Value | Description
Event | 8 | Queries for any asynchronous events issued from application programming interface (API) calls.
CacheUtilization | 18 | Queries for the cache hit rate performance measurement for textures and indexed vertices.
BandwidthTimings | 17 | Queries throughput measurement comparisons for help in understanding the performance of an application.
PixelTimings | 16 | Queries for the percentage of time spent processing pixel shader data.
VertexTimings | 15 | Queries for the percentage of time spent processing vertex shader data.
InterfaceTimings | 14 | Queries for the percentage of time spent processing data in the driver.
PipelineTimings | 13 | Queries for the percentage of time spent processing pipeline data.
TimeStampFrequency | 12 | This query result is true if the values from TimeStamp queries cannot be guarenteed to be continuous throughout the duration of the TimeStampDisjoint query. Otherwise, the query result is false.
TimeStampDisjoint | 11 | This query notifies an application if the counter frequency has changed from the TimeStamp.
TimeStamp | 10 | Returns a 64-bit timestamp.
Occlusion | 9 | Queries for the number of pixels that pass z-testing. These pixels are for primitives drawn between Begin and End. This option enables an application to check the occlusion result against zero. Zero is fully occluded, which means the pixels are not visible from the current camera position.
VertexStats | 6 | Queries vertex statistics. For more information, see VertexStats.
VertexCache | 4 | Queries for driver hints about data layout for vertex caching.
ResourceManager | 5 | Queries the resource manager. For more information, see ResourceManager.

Remarks

Available query types are given in the following table.

QueryType | Valid issue flag | GetData buffer | Runtime | Implicit beginning of query
VertexCache | End | VertexCache | Retail/Debug | Device
ResourceManager | End | ResourceManager | Debug only | Present
VertexStats | End | VertexStats | Debug only | Present
Occlusion | End | Boolean Leave Site | Retail/Debug | Device
Event | Begin, End | UInt32 Leave Site | Retail/Debug | Not applicable

For a ResourceManager query, the device behavior flags must include CreateFlags.DisableDriverManagement.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Query


RegisterSet

Microsoft DirectX 9.0 SDK Update (October 2004)

RegisterSet Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the data type of the register.

Definition

Visual Basic .NET | Public Enum RegisterSet
C# | public enum RegisterSet
Managed C++ | __value public enum RegisterSet
JScript .NET | public enum RegisterSet

Members

Member | Value | Description
Sampler | 3 | 4-D sampler data.
Boolean | 0 | Boolean value.
Float4 | 2 | 4-D floating-point number.
Int4 | 1 | 4-D integer number.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ShaderConstantInformation
  • ConstantDescription


RenderStates

RenderStates Enumeration

Note: This documentation is preliminary and is subject to change.

Defines device render states.

Definition

Visual Basic .NET | Public Enum RenderStates
C# | public enum RenderStates
Managed C++ | __value public enum RenderStates
JScript .NET | public enum RenderStates

Members

Member | Value | Description
Wrap15 | 205 | See Wrap0
Wrap14 | 204 | See Wrap0
Wrap13 | 203 | See Wrap0
Wrap12 | 202 | See Wrap0
Wrap11 | 201 | See Wrap0
Wrap10 | 200 | See Wrap0
Wrap9 | 199 | See Wrap0
Wrap8 | 198 | See Wrap0
PointScaleA 158 Controls the distance-based size attenuation for point primitives. The default value is 1.0f.

This render state is active only when PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.
PointScaleEnable 157 Controls how point sprites are rendered. When set to true, texture coordinates of point sprites are set so that full textures are mapped on each point. When set to false, the vertex texture coordinates are used for the entire point.

The default value is false.
PointSpriteEnable 156 Controls how point sprites are rendered. When set to true, texture coordinates of point sprites are set so that full textures are mapped on each point. When set to false, the vertex texture coordinates are used for the entire point.

The default value is false.
PointSizeMin 155 Specifies the minimum size to which point sprites can be set. The default value is 1.0f. The range for this value is greater than or equal to 0.0f.

Point sprites are clamped to the specified size during rendering. Setting the size to less than 1.0 results in points dropping out, if the point does not cover a pixel center and antialiasing is disabled.

Points also will drop out if the size is less than 1.0, if they are being rendered with reduced intensity, and if antialiasing is enabled.
EmissiveMaterialSource | 148 | Emissive color source for lighting calculations. Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.
AmbientMaterialSource | 147 | Ambient color source for lighting calculations. Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.
SpecularMaterialSource | 146 | Specular color source for lighting calculations. Valid values are members of the ColorSource enumeration. The default value is ColorSource.Color2.
DiffuseMaterialSource | 145 | Diffuse color source for lighting calculations. Valid values are members of the ColorSource enumerated type. The default value is ColorSource.Color1. The value for this render state is used only if ColorVertex is set to true.
NormalizeNormals 143 Enables or disables automatic normalization of vertex normals. Set to true to enable normalization of vertex normals, or false to disable it. The default value is false.

Enabling this feature causes the system to normalize the vertex normals for vertices after transforming them to camera space, an operation that can slow down the system.
LocalViewer | 142 | Specifies whether to use camera-relative specular highlights or orthogonal specular highlights. Set to true to enable camera-relative specular highlights, or false to use orthogonal specular highlights. The default value is true. Applications that use orthogonal projection should specify false.
ColorVertex 141 Enables or disables per-vertex color. Set to true to enable per-vertex color, or false to disable it. The default value is true.

Enabling per-vertex color allows the system to include the color defined for individual vertices in its lighting calculations. For more information, see the following topics.

  • AmbientMaterialSource
  • DiffuseMaterialSource
  • EmissiveMaterialSource
  • SpecularMaterialSource
FogVertexMode | 140 | The fog formula to use for vertex fog. Valid values are from the FogMode enumeration. The default fog mode is FogMode.None. See Fog.
Ambient | 139 | Ambient light color. This value is a Color Leave Site object that specifies the ambient color value. The default value is 0.
Lighting 137 Enables or disables Microsoft® Direct3D® lighting. Set to true to enable Microsoft® Direct3D® lighting, or false to disable it. The default value is true.

Only vertices that include a vertex normal are properly lit; vertices that do not contain a vertex normal employ a dot product of 0 in all lighting calculations.
Clipping | 136 | Enables or disables primitive clipping by Microsoft® Direct3D®. Set to true to enable primitive clipping, or false to disable it. The default value is true.
Wrap7 | 135 | See Wrap0
Wrap6 | 134 | See Wrap0
Wrap5 | 133 | See Wrap0
Wrap4 | 132 | See Wrap0
Wrap3 | 131 | See Wrap0
Wrap2 | 130 | See Wrap0
Wrap1 | 129 | See Wrap0
Wrap0 128 Texture-wrapping behavior for multiple sets of texture coordinates.

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

The default value for this render state is 0 (wrapping disabled in all directions).
TextureFactor | 60 | Specifies the color used for multiple-texture blending with the TextureArgument.TFactor texture blending argument or the TextureOperation.BlendFactorAlpha texture blending operation. The default value is 0.
StencilWriteMask | 59 | Specifies the write mask applied to values written into the stencil buffer. The default mask is 0xFFFFFFFF.
StencilMask | 58 | Specifies the stencil mask to apply to the reference value and each stencil buffer entry to determine the significant bits for the stencil test. The default mask is 0xFFFFFFFF.
ReferenceStencil | 57 | Specifies a reference value to use for the stencil test. The default value is 0.
StencilFunction 56 Specifies the comparison function to use for the stencil test. Valid values are members of the Compare enumeration. The default value is Compare.Always.

The comparison function is used to compare the reference value to a stencil buffer entry. This comparison applies only to the bits in the reference value and stencil buffer entry that are set in the stencil mask (by StencilMask).

If the comparison is true, the stencil test passes.
StencilPass | 55 | Specifies the stencil operation to perform if both the stencil test and the depth test (z-test) pass. Valid values are members of the StencilOperation enumeration. The default value is StencilOperation.Keep.
StencilZBufferFail | 54 | Specifies the stencil operation to perform if the stencil test passes and the depth test (z-test) fails. Valid values are members of the StencilOperation enumeration. The default value is StencilOperation.Keep.
StencilFail | 53 | Specifies the stencil operation to perform if the stencil test fails. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
StencilEnable | 52 | Enables or disables stenciling. Set to true to enable stenciling, or false to disable it. The default value is false.
RangeFogEnable 48 Enables or disables range-based vertex fog. Set to true to enable range-based vertex fog, or false to use depth-based fog. The default value is false.

In range-based fog, the distance of an object from the viewer is used to compute fog effects, not the depth of the object (that is, the z-coordinate) in the scene. All fog methods work as usual, except that they use range instead of depth in the computations. See Fog.

Range is the correct factor to use for fog computations, but depth is commonly used instead because it is generally already available, and range is resource-intensive to compute. Using depth to calculate fog has the undesirable effect of making the fogginess of peripheral objects change as the viewer's eye moves; in this case, the depth changes and the range remains constant. Because no hardware currently supports per-pixel range-based fog, range correction is offered only for Vertex Fog.
FogDensity | 38 | Fog density for pixel or vertex fog used in exponential fog modes. Valid fog density values range from 0.0 through 1.0. The default value is 1.0. See Fog.
FogEnd 37 The depth at which pixel or vertex fog effects end for linear fog mode. The default value is 1.0f.

Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog). See Fog.
FogStart 36 The depth at which pixel or vertex fog effects begin for linear fog mode. The default value is 0.0f.

Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog). See Fog.
FogTableMode | 35 | The fog formula to use for pixel fog. Valid values are from the FogMode enumeration. The default fog mode is FogMode.None. See Fog.
SpecularEnable 29 Enables or disables specular highlights. Set to true to enable specular highlights, or false to disable them. The default value is false.

Specular highlights are calculated as though every vertex in the object being lit is at the object's origin. This gives the expected results as long as the object is modeled around the origin and the distance from the light to the object is relatively large. In other cases, the results are undefined.

When this state is set to true, the specular color is added to the base color after the texture cascade but before alpha blending.
FogEnable | 28 | Enables or disables fog blending. Set to true to enable fog blending, or false to disable it. The default value is false. See Fog.
AlphaBlendEnable 27 Set to true to enable alpha-blended transparency, or false to disable it.

The default value is false. The type of alpha blending is determined by the SourceBlend and DestinationBlend render states.
DitherEnable | 26 | Enables or disables dither. Set to true to enable dithering, or false to disable it. The default value is false.
AlphaFunction 25 A member of the Compare enumeration that represents the alpha comparison function.

The default value is Compare.Always.

The AlphaFunction member enables an application to accept or reject a pixel based on its alpha value.
ReferenceAlpha | 24 | Specifies a reference alpha value against which pixels are tested when alpha testing is enabled. The default value is 0. Values can range from 0x00000000 to 0x000000FF.
ZBufferFunction 23 Specifies the comparison function for the z-buffer test. Valid values are members of the Compare enumeration.

The depth value of the pixel is compared to the depth-buffer value. If the depth value of the pixel passes the comparison function, the pixel is written.
CullMode | 22 | Specifies how back-facing triangles are culled, if at all. Set to a member of the Cull enumeration that specifies the culling mode. The default value is Cull.CounterClockwise.
DestinationBlend | 20 | Contains a member of the Blend enumeration that represents the destination . The default value is Blend.Zero.
SourceBlend | 19 | Contains a member of the Blend enumeration that represents the source . The default value is Blend.One.
LastPixel | 16 | Enables or disables drawing of the last pixel in a line. Set to true to enable drawing of the last pixel in a line, or false to prevent it. The default value is true.
AlphaTestEnable 15 Enables a per-pixel alpha test. Set to true to enable per-pixel alpha testing, or false to disable it.

If the test passes, the pixel is processed by the frame buffer. Otherwise, all frame-buffer processing is skipped for the pixel.

The test is done by comparing the incoming alpha value with the reference alpha value, using the comparison function provided by AlphaFunction. The reference alpha value is determined by the value set for ReferenceAlpha.

The default value is false.
ZBufferWriteEnable 14 Set to true to enable writing to the depth buffer, or false to disable it.

The default value is true.

This member enables an application to prevent the system from updating the depth buffer with new depth values.

If false, depth comparisons are still made according to the render state ZBufferFunction, assuming that depth buffering is taking place, but depth values are not written to the buffer.
BlendOperationAlpha 209 Value used to select the arithmetic operation applied to separate alpha blend when the render state, SeparateAlphaBlendEnabled, is set to true.

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.
DestinationBlendAlpha 208 A member of the Blend enumeration that represents the destination .

This value is ignored unless SeparateAlphaBlendEnabled is true.

The default value is Blend.Zero.
SourceBlendAlpha 207 A member of the Blend enumeration that represents the source .

This value is ignored unless SeparateAlphaBlendEnabled is true.

The default value is Blend.One.
SeparateAlphaBlendEnable 206 Enables or disables the separate for the alpha channel. Set to true to enable separate alpha blend, or false disable it. The default value is false.

When set to false, the render target blending factors and operations applied to alpha are forced to be the same as those defined for color. This mode is effectively hardwired to false on implementations that do not set MiscCaps.SupportsSeparateAlphaBlend.

The type of separate alpha blending is determined by SourceBlendAlpha and DestinationBlendAlpha.
DepthBias 195 Sets or retrieves the depth bias for polygons.

The DepthBias value is an integer in the range of 0 through 16 which causes polygons that are physically coplanar to appear separate. Polygons with a high z-bias value appear in front of polygons with a low value, without requiring sorting for drawing order. For example, polygons with a value of 1 appear in front of polygons with a value of 0.
SrgbWriteEnable | 194 | Enables render-target writes to be gamma corrected to sRGB. Set to true to enable sRGB writes, or false to disable them. The default value is false.
BlendFactor 193 A Color Leave Site object used for a constant blend factor during alpha blending.

BlendFactor member is available if BlendCaps.SupportsBlendFactor is set in Caps.SourceBlendCaps or Caps.DestinationBlendCaps for the device.
ColorWriteEnable3 192 Additional ColorWriteEnable values for a device. See ColorWriteEnable.

ColorWriteEnable3 is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.
ColorWriteEnable2 191 Additional ColorWriteEnable values for a device. See ColorWriteEnable.

ColorWriteEnable2 is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.
ColorWriteEnable1 190 Additional ColorWriteEnable values for a device. See ColorWriteEnable.

ColorWriteEnable1 is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.
CounterClockwiseStencilFunction 189 The comparison function used by the counterclockwise (CCW) stencil test. Valid values are from the Compare enumeration.

The test passes if ((ref & mask) stencil_compare_function (stencil & mask)) == true.
CounterClockwiseStencilPass | 188 | The StencilOperation to perform if both counterclockwise (CCW) stencil and z-tests pass. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
CounterClockwiseStencilZBufferFail | 187 | The StencilOperation to perform if the counterclockwise (CCW) stencil test passes and the z-test fails. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
CounterClockwiseStencilFail | 186 | The StencilOperation to perform if the counterclockwise (CCW) stencil test fails. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
TwoSidedStencilMode 185 Enables or disables two-sided stenciling. Set to true to enable two-sided stenciling, or false to disable it.

The application should set CullMode to Cull.None to enable two-sided stencil mode. If the triangle winding order is clockwise, the Stencil* operations are used. If the winding order is counterclockwise, the CounterClockwiseStencil* operations are used. See StencilOperation
EnableAdaptiveTessellation | 184 | Enables or disables adaptive tessellation. Set to true to enable adaptive tessellation, or false to disable it. The default value is false.
AdaptiveTessellateW | 183 | Amount to adaptively tessellate in the w direction. The default value is 0.0f.
AdaptiveTessellateZ | 182 | Amount to adaptively tessellate in the z direction. The default value is 1.0f.
AdaptiveTessellateY | 181 | Amount to adaptively tessellate in the y direction. The default value is 0.0f.
AdaptiveTessellateX | 180 | Amount to adaptively tessellate in the x direction. The default value is 0.0f.
MaxTessellationLevel | 179 | The maximum tessellation level. The default value is 1.0f.
MinTessellationLevel | 178 | The minimum tessellation level. The default value is 1.0f.
AntialiasedLineEnable 176 Set to true to enable antialiasing of lines, or false to disable it. The default value is false.

The AntialiasedLineEnable member applies to triangles drawn in wireframe mode as well as line-drawing primitive types.

When rendering to a multisample render target, this render state is ignored, and all lines are rendered aliased. For antialiased line rendering in multisample render targets, use a Line object, which generates textured polygons.
SlopeScaleDepthBias 175 Used to determine how much bias can be applied to coplanar primitives to reduce z-fighting. The default value is 0.

bias = (max * SlopeScaleDepthBias) + DepthBias

where max is the maximum depth slope of the triangle being rendered. See Depth Buffers.
ScissorTestEnable | 174 | Enables or disables scissor testing. Set to true to enable scissor testing, or false to disable it. The default value is false.
NormalDegree | 173 | The degree of interpolation (linear, cubic, quadratic, or quintic) using the N-patch normal. Valid values are from the DegreeType enumeration. The default render state is DegreeType.Linear.
PositionDegree 172 The N-patch position interpolation degree. Valid values are from the DegreeType enumeration that specifies the degree. The default value is DegreeType.Cubic.

The DegreeType.Linear value also can be used.
BlendOperation 171 A value used to select the arithmetic operation to apply when the alpha blend render state, AlphaBlendEnable is set to true.

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.
TweenFactor | 170 | Specifies a floating-point value that controls the tween factor. The default value is 0.0f.
ColorWriteEnable | 168 | Enables a per-channel write for the render target color buffer. Valid values for this render state can be any combination of ColorWriteEnable enumeration members.
IndexedVertexBlendEnable 167 Enables or disables indexed vertex blending. Set to true to enable indexed vertex blending, or false to disable it. The default value is false.

When indexed vertex blending is disabled and vertex blending is enabled through VertexBlend, it is equivalent to having matrix indices 0, 1, 2, and 3 in every vertex. If indexed vertex blending is enabled (set to true), the user must pass matrix indices with every vertex.
PointSizeMax | 166 | Specifies the maximum size to which point sprites can be set. The default value is 64.0f. The value must be less than or equal to Caps.MaxPointSize and greater than or equal to PointSizeMin.
DebugMonitorToken 165 Enables or disables the debug monitor token. Set to true to enable the debug monitor, or false to disable it. Should be set only for debugging the monitor and is useful for debug builds only.

The default value for the debug monitor is true.
PatchEdgeStyle 163 The tessellation mode for patch edges. Valid value are from the PatchEdge enumeration. The default render state is PatchEdge.Discrete.

Using the PatchEdge.Continuous tessellation mode helps reduce rendering artifacts.
MultisampleMask 162 Enables use of a multisample buffer as an accumulation buffer. The default value is 0xFFFFFFFF.

This render state allows multipass rendering of geometry, in which each pass updates a subset of samples. The state has no effect when rendering to a single sample buffer.

Each bit in the MultisampleMask, starting at the least significant bit (LSB), controls modification of one of the samples in a multisample render target. Thus, for an 8-sample render target, the low byte contains the eight write enables for each of the eight samples. This property enables use of a multisample buffer as an accumulation buffer. If there are n multisamples and k enabled samples, the resulting intensity of the rendered image should be k/n. Each component RGB of every pixel is factored by k/n. See MultiSampleType
MultisampleAntiAlias 161 Determines how individual samples are computed when using a multisample render target buffer.

When set to true, the multiple samples are computed so that full-scene antialiasing is performed by sampling at different sample positions for each multiple sample.

When set to false, the multiple samples are all written with the same sample value, sampled at the pixel center, which allows non-antialiased rendering to a multisample buffer. The default value is true. This render state has no effect when rendering to a single sample buffer.
PointScaleC 160 Controls the distance-based size attenuation for point primitives. The default value is 1.0f.

This render state is active only when PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.
PointScaleB 159 Controls the distance-based size attenuation for point primitives. The default value is 1.0f.

This render state is active only when PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.
ClipPlaneEnable 152 Enables or disables user-defined clipping planes. Valid values are any DWORD in which the status of each bit (set or not set) toggles the activation state of a corresponding user-defined clipping plane. The default value is 0.

The least significant bit (bit 0) controls the first clipping plane at index 0, and subsequent bits control the activation of clipping planes at higher indexes. If a bit is set, the system applies the appropriate clipping plane during scene rendering.
VertexBlend | 151 | Specifies the number of matrices to use to perform geometry blending. Valid values are members of the VertexBlend enumeration. The default value is VertexBlend.Disable.
FogColor | 34 | Retrieves or sets the fog color as a Color Leave Site object.
ShadeMode | 9 | Specifies the shade mode to use for rendering. Valid values are from the ShadeMode enumeration. The default value is ShadeMode.Gouraud.
ZEnable | 7 | Enables or disables depth buffering. Set to true to enable depth buffering, or false to disable it. The default value is true.
PointSize 154 Specifies the size to use for point size computation in cases in which point size is not specified for each vertex. The default value is 1.0f.

This value is not used when the vertex contains a point size. The value is defined in screen space units if PointScaleEnable is set to false; otherwise, it is defined in world space units. The range for the value is greater than or equal to 0.0f.
FillMode | 8 | A value from the FillMode enumeration that represents the fill mode to apply. The default value is FillMode.Solid.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • RenderStateManager
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


RenderTargetsMax

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderTargetsMax Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the maximum number of simultaneous render targets supported.

Definition

Visual Basic .NET | Public Enum RenderTargetsMax
C# | public enum RenderTargetsMax
Managed C++ | __value public enum RenderTargetsMax
JScript .NET | public enum RenderTargetsMax

Members

Member | Value | Description
Simultaneous | 4 | Allows four simultaneous render targets.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ResourceType

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines resource types.

Definition

Visual Basic .NET | Public Enum ResourceType
C# | public enum ResourceType
Managed C++ | __value public enum ResourceType
JScript .NET | public enum ResourceType

Members

Member | Value | Description
IndexBuffer | 7 | Index buffer resource.
VertexBuffer | 6 | Vertex buffer resource.
CubeTexture | 5 | Cube texture resource.
VolumeTexture | 4 | Volume texture resource.
Volume | 2 | Volume resource.
Surface | 1 | Surface resource.
Textures | 3 | Texture resource.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Resource Properties


ResultCode

Microsoft DirectX 9.0 SDK Update (October 2004)

ResultCode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines result codes.

Definition

Visual Basic .NET | Public Enum ResultCode
C# | public enum ResultCode
Managed C++ | __value public enum ResultCode
JScript .NET | public enum ResultCode

Members

Member | Value | Description
InvalidCall | -2005530516 | Method call is invalid; for example, a method's parameter might not be a valid pointer.
InvalidDevice | -2005530517 | Requested device type is not valid.
NotAvailable | -2005530518 | Device does not support the queried technique.
DeviceNotReset | -2005530519 | Device has been lost but can be reset at this time.
DeviceLost | -2005530520 | Device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
UnsupportedTextureFilter | -2005530590 | Device does not support the specified texture filter.
UnsupportedFactorValue | -2005530593 | Device does not support the specified texture factor value.
ConflictingTextureFilter | -2005530594 | Current texture filters cannot be used together.
TooManyOperations | -2005530595 | Application is requesting more texture-filtering operations than the device supports.
UnsupportedAlphaArgument | -2005530596 | Device does not support a specified texture-blending argument for the alpha channel.
UnsupportedAlphaOperation | -2005530597 | Device does not support a specified texture-blending operation for the alpha channel.
UnsupportedColorArgument | -2005530598 | Device does not support a specified texture-blending argument for color values.
UnsupportedColorOperation | -2005530599 | Device does not support a specified texture-blending operation for color values.
WrongTextureFormat | -2005530600 | Pixel format of the texture surface is not valid.
Success | 0 | Operation was successful.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SamplerStageStates

SamplerStageStates Enumeration

Note: This documentation is preliminary and is subject to change.

Defines the sampler state types.

Definition

Visual Basic .NET | Public Enum SamplerStageStates
C# | public enum SamplerStageStates
Managed C++ | __value public enum SamplerStageStates
JScript .NET | public enum SamplerStageStates

Members

Member | Value | Description
DMapOffset | 13 | Vertex offset in the presampled displacement map. This is a constant used by the tessellator, its default value is zero.
ElementIndex | 12 | Element index to use when an element with multiple textures is assigned to the sampler.
SrgbTexture | 11 | Determines whether to use gamma correction. Set to true to enable gamma correction. The default value is false.
MaxMipLevel | 9 | The level of detail (LOD) index of the largest map to use. Index values range from 0 to (n-1) where 0 is the largest map. The default value is zero.
MipMapLevelOfDetailBias | 8 | Mipmap level of detail (LOD) bias. The default value is zero.
BorderColor | 4 | Border color represented as a member of the Color Leave Site structure.
AddressW | 3 | Texture-address mode for the w coordinate. The default value is TextureAddress.Wrap. See TextureAddress.
AddressV | 2 | Texture-address mode for the v coordinate. The default value is TextureAddress.Wrap. See TextureAddress.
AddressU | 1 | Texture-address mode for the u coordinate. The default value is TextureAddress.Wrap. See TextureAddress.
MinFilter | 6 | Minification filter. The default value is TextureFilter.None. See TextureFilter.
MagFilter | 5 | Magnification filter. The default value is TextureFilter.None. See TextureFilter.
MaxAnisotropy | 10 | Maximum anisotropy value. The default value is zero.
MipFilter | 7 | Mipmap filter to use during minification. The default value is TextureFilter.None. See TextureFilter.

Remarks

These enumeration constants and values are used by the Device.SetSamplerState method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • SamplerStateManager
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ShadeMode

Microsoft DirectX 9.0 SDK Update (October 2004)

ShadeMode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines constants that describe the supported shading modes.

Definition

Visual Basic .NET | Public Enum ShadeMode
C# | public enum ShadeMode
Managed C++ | __value public enum ShadeMode
JScript .NET | public enum ShadeMode

Members

Member | Value | Description
Phong | 3 | Not supported.
Gouraud | 2 | Gouraud shading mode. The color and specular components of the face are determined by a linear interpolation between all three of the triangle's vertices.
Flat | 1 | Flat shading mode. The color and specular component of the first vertex in the triangle are used to determine the color and specular component of the face. These colors remain constant across the triangle; that is, they are not interpolated. The specular alpha is interpolated.

Remarks

The first vertex of a triangle for flat shading mode is defined in the following manner.

  • For a Triangle Lists, the first vertex of the triangle i is i * 3.
  • For a Triangle Strips, the first vertex of the triangle i is vertex i.
  • For a Triangle Fans, the first vertex of the triangle i is vertex i + 1.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the compiler options to use during a shader compilation.

Definition

Visual Basic .NET | Public Enum ShaderFlags
C# | public enum ShaderFlags
Managed C++ | __value public enum ShaderFlags
JScript .NET | public enum ShaderFlags

Members

Member | Value | Description
Debug | 1 | Inserts debug file name and line number information during compilation.
None | 0 | Instructs the compiler to use no options during compilation. Value resolves to 0.
PreferFlowControl | 1024 | Instructs the compiler to prefer using flow-control instructions.
AvoidFlowControl | 512 | Instructs the compiler to avoid using flow-control instructions.
NoPreShader | 256 | Disables preshaders; that is, the compiler will not pull out static expressions for evaluation on the host CPU.
ForcePixelShaderSoftwareNoOptimizations | 128 | Instructs the compiler to use software pixel shaders.
ForceVertexShaderSoftwareNoOptimizations | 64 | Instructs the compiler to use software vertex shaders.
PartialPrecision | 32 | Indicates to the device that the operation can be performed and the result stored at a lower precision (at least s10e5).
PackMatrixColumnMajor | 16 | Instructs the compiler to pack matrices in column major order (that is, each vector in a single column).
PackMatrixRowMajor | 8 | Instructs the compiler to pack matrices in row major order (that is, each vector in a single row).
SkipOptimization | 4 | Instructs the compiler to skip optimization steps during code generation. This option is valid only when calling ShaderLoader.CompileShader; it is not recommended unless you are trying to isolate a code problem that you suspect originates in the compiler.
SkipValidation | 2 | Prevents the compiler from validating the generated code against known capabilities and constraints. This option is recommended only when compiling shaders that are known to work (that is, those that have compiled before without this option). Shaders are always validated before they are set to the device.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SpriteFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SpriteFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines flags used to specify sprite rendering options.

Definition

Visual Basic .NET | Public Enum SpriteFlags
C# | public enum SpriteFlags
Managed C++ | __value public enum SpriteFlags
JScript .NET | public enum SpriteFlags

Members

Member | Value | Description
AlphaBlend | 16 | Enables alpha blending with RenderStateManager.AlphaTestEnable set to true (for nonzero alpha). SourceAlpha is the source blend state, and InvSourceAlpha is the destination blend state in calls to RenderStateManager. The Font class requires this flag to be set when drawing text.
SortDepthBackToFront | 128 | Sorts sprites by depth in back-to-front order prior to drawing. This option is recommended when drawing transparent sprites of varying depths.
SortDepthFrontToBack | 64 | Sorts sprites by depth in front-to-back order prior to drawing. This option is recommended when drawing opaque sprites of varying depths.
SortTexture | 32 | Sorts sprites by texture prior to drawing. This option is recommended when drawing non-overlapping sprites of uniform depth; for example, drawing screen-aligned text with Font.
Billboard | 8 | Rotates each sprite around its center so that it is facing the viewer. Sprite.SetWorldViewLH or Sprite.SetWorldViewRH must be called first.
ObjectSpace | 4 | Specifies no modification of the world, view, and projection transforms. The transforms currently set to the device are used to transform sprites when the batched sprites are drawn (that is, when Sprite.Flush or Sprite.End is called). If this option is not specified, the world, view, and projection transforms are modified so that sprites are drawn in screen-space coordinates.
DoNotModifyRenderState | 2 | Specifies no changes to the device render state when Sprite.Begin is called. The device is assumed to be in a valid state to draw vertices when the VertexElement.UsageIndex property equals 0 and VertexElement.DeclarationUsage is set to DeclarationUsage.Position, DeclarationUsage.TextureCoordinate, or DeclarationUsage.Color.
DoNotSaveState | 1 | Prevents the device state from being saved or restored when Sprite.Begin or Sprite.End is called.
None | 0 | Resolves the value to 0.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StateBlockType

Microsoft DirectX 9.0 SDK Update (October 2004)

StateBlockType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines logical groups of device states.

Definition

Visual Basic .NET | Public Enum StateBlockType
C# | public enum StateBlockType
Managed C++ | __value public enum StateBlockType
JScript .NET | public enum StateBlockType

Members

Member | Value | Description
VertexState | 3 | Captures all of the current lights, the current vertex shader and its constants, and the texture stage states specified by TextureCoordinateIndex and TextureTransform.
PixelState | 2 | Captures the current pixel shader and its constants.
All | 1 | Captures all device states.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StencilOperation

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilOperation Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported stencil operations.

Definition

Visual Basic .NET | Public Enum StencilOperation
C# | public enum StencilOperation
Managed C++ | __value public enum StencilOperation
JScript .NET | public enum StencilOperation

Members

Member | Value | Description
Zero | 2 | Sets the stencil-buffer entry to 0.
Decrement | 8 | Decrements the stencil-buffer entry, wrapping to the maximum value if the new value is less than 0.
Increment | 7 | Increments the stencil-buffer entry, wrapping to 0 if the new value exceeds the maximum value.
Invert | 6 | Inverts the bits in the stencil-buffer entry.
DecrementSaturation | 5 | Decrements the stencil-buffer entry, clamping to 0.
IncrementSaturation | 4 | Increments the stencil-buffer entry, clamping to the maximum value.
Keep | 1 | Does not update the stencil-buffer entry. This is the default value.
Replace | 3 | Replaces the stencil-buffer entry with a reference value.

Remarks

Stencil buffer entries are integer values that range from 0 to 2n - 1, where n is the bit depth of the stencil buffer.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SwapEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

SwapEffect Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines swap effects.

Definition

Visual Basic .NET | Public Enum SwapEffect
C# | public enum SwapEffect
Managed C++ | __value public enum SwapEffect
JScript .NET | public enum SwapEffect

Members

Member Value Description
Discard 1 When a swap chain is created with a swap effect of Flip or Copy, the runtime guarantees that a Present operation will not affect the content of any of the back buffers. However, meeting this guarantee can involve substantial video memory or processing overheads, especially when implementing flip semantics for a windowed swap chain or copy semantics for a full-screen swap chain.

An application can use the Discard swap effect to avoid these overheads and to enable the display driver to choose the most efficient presentation technique for the swap chain.

Discard is also the only swap effect that can be used when specifying a value other than None for PresentParameters.MultiSampleType. Like a swap chain that uses Flip, a swap chain that uses Discard might include more than one back buffer, any of which can be accessed using Device.GetBackBuffer or SwapChain.GetBackBuffer.

The swap chain is essentially a queue where 0 always indexes the back buffer that will be displayed by the next Present operation and from which buffers are discarded once they have been displayed. An application that uses this swap effect should update an entire back buffer before invoking a Present operation that displays it.

The debug version of the runtime overwrites the contents of discarded back buffers with random data, to enable developers to verify that their applications are updating the entire back buffer surface correctly.

For a full-screen swap chain, the presentation rate is determined by the value assigned to PresentParameters.PresentationInterval when the device or swap chain is created. Unless this value is Immediate, the presentation is synchronized with the vertical sync of the monitor. For a windowed swap chain, the presentation is implemented by means of copy operations, and always occurs immediately.
Copy 3 This swap effect can be specified only for a swap chain that comprises a single back buffer.

Whether the swap chain is windowed or full-screen, the runtime guarantees the semantics implied by a copy-based Present operation; specifically, that the operation leaves the content of the back buffer unchanged, instead of replacing it with the content of the front buffer as a flip-based Present operation would.

For a windowed swap chain, a Present operation causes the back buffer content to be copied immediately to the client area of the target window. No attempt is made to synchronize the copy with the vertical retrace period of the display adapter, so tearing effects may be observed.

For a full-screen swap chain, the runtime uses a combination of flip and copy operations, which are supported by hidden back buffers if necessary, to accomplish the Present operation. Accordingly, the presentation is synchronized with the display adapter's vertical retrace and its rate is constrained by the chosen presentation interval. A swap chain specified with the Immediate flag is the only exception. (For more information, see PresentParameters.PresentationInterval.) In this case, a Present operation copies the back buffer content directly to the front buffer without waiting for the vertical retrace.
Flip 2 The swap chain might include multiple back buffers and is essentially a circular queue that includes the front buffer. Within this queue, the back buffers are always numbered sequentially from 0 to (n - 1), where n is the number of back buffers, so that 0 denotes the least recently presented buffer.

When Present is invoked, the queue is rotated so that the front buffer becomes the back buffer (n - 1), while the back buffer 0 becomes the new front buffer.

For a full-screen swap chain, the presentation rate is determined by the value assigned to the PresentParameters.PresentationInterval when the device or swap chain is created. Unless this value is Immediate, the presentation is synchronized with the vertical sync of the monitor.

For a windowed swap chain, the flipping is implemented by means of copy operations, and the presentation always occurs immediately.

Remarks

The state of the back buffer after a call to Present is well-defined by each of these swap effects, and whether the Microsoft® Direct3D® device was created with a full-screen swap chain or a windowed swap chain has no effect on this state. In particular, the Flip swap effect operates the same whether windowed or full-screen, and the Direct3D runtime guarantees this by creating extra buffers. As a result, it is recommended that applications use Discard whenever possible to avoid any performance penalties, because the current swap effect is always the most efficient in terms of memory consumption and performance.

Full-screen destination alpha will not work with applications that use Flip or Discard. This means that the DestinationBlend render state will not work as expected because, from the driver's point of view, full-screen swap chains with these swap effects do not have an explicit pixel format. The driver infers that it should take on the display format, which does not have an alpha channel. To work around this, use Copy and check the DriverCaps.SupportsAlphaFullscreenFlipOrDiscard property, which indicates whether the driver can perform alpha blending when Flip or Discard are used.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Reset


TextureAddress

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureAddress Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines constants that describe the supported texture-addressing modes.

Definition

Visual Basic .NET | Public Enum TextureAddress
C# | public enum TextureAddress
Managed C++ | __value public enum TextureAddress
JScript .NET | public enum TextureAddress

Members

Member | Value | Description
MirrorOnce | 5 | Similar to Mirror and Clamp. Takes the absolute value of the texture coordinate (thus, mirroring around 0), and then clamps to the maximum value. The most common usage is for volume textures, where support for the full MirrorOnce texture-addressing mode is not necessary, but the data is symmetrical around the one axis.
Border | 4 | Texture coordinates outside the range [0.0, 1.0] are set to the border color.
Clamp | 3 | Texture coordinates outside the range [0.0, 1.0] are set to the texture color at 0.0 or 1.0, respectively.
Mirror | 2 | Similar to Wrap, except that the texture is flipped at every integer junction. For u values between 0 and 1, for example, the texture is addressed normally; between 1 and 2, the texture is flipped (mirrored); between 2 and 3, the texture is normal again, and so on.
Wrap | 1 | Tiles the texture at every integer junction. For example, for u values between 0 and 3, the texture is repeated three times. No mirroring is performed.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • SamplerStateManagerCollection


TextureArgument

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureArgument Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported texture arguments.

Definition

Visual Basic .NET | Public Enum TextureArgument
C# | public enum TextureArgument
Managed C++ | __value public enum TextureArgument
JScript .NET | public enum TextureArgument

Members

Member | Value | Description
Constant | 6 | Select a constant from a texture stage.
AlphaReplicate | 32 | Replicate the alpha value to the color components. During sampling, AlphaReplicate acts as a read modifier.
Complement | 16 | Take the complement, or 1.0 - x. This is a read modifier.
Temp | 5 | Specifies a temporary register color for read or write. Temp is supported if the SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0). Permissions are read/write.
TFactor | 3 | Specifies the texture factor set in the RenderStateManager.TextureFactor property. Permissions are read-only.
TextureColor | 2 | Contains the texture color for the current texture stage. Permissions are read-only.
SelectMask | 15 | Mask value for all arguments; not used when setting texture arguments.
Specular | 4 | Specifies the specular color interpolated from vertex components during Gouraud shading. If the vertex does not contain a specular color, the default color is 0xFFFFFFFF. Permissions are read-only.
Current | 1 | Gets the current element in the collection.
Diffuse | 0 | Specifies the diffuse color interpolated from vertex components during Gouraud shading. If the vertex does not contain a diffuse color, the default color is 0xFFFFFFFF. Permissions are read-only.

Remarks

This enumeration is used by the ColorArgument0, ColorArgument1, ColorArgument2, AlphaArgument0, AlphaArgument1, AlphaArgument2, and ResultArgument members of the TextureStateManager class.

Use the TextureState property to set and retrieve texture arguments.

An argument flag can be combined with a modifier, but two argument flags cannot be combined.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureCoordinateIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCoordinateIndex Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the supported texture coordinate index values.

Definition

Visual Basic .NET | Public Enum TextureCoordinateIndex
C# | public enum TextureCoordinateIndex
Managed C++ | __value public enum TextureCoordinateIndex
JScript .NET | public enum TextureCoordinateIndex

Members

Member | Value | Description
SphereMap | 262144 | Uses the specified texture coordinates for sphere mapping.
CameraSpaceReflectionVector | 196608 | Uses the reflection vector, transformed to camera space, as the input texture coordinate for the current stage's texture transformation. The reflection vector is computed from the input vertex position and normal vector.
CameraSpacePosition | 131072 | Uses the vertex position, transformed to camera space, as the input texture coordinates for the current stage's texture transformation.
CameraSpaceNormal | 65536 | Uses the vertex normal, transformed to camera space, as the input texture coordinates for the current stage's texture transformation.
PassThru | 0 | Uses the specified texture coordinates contained in the vertex format. This value resolves to 0.

Remarks

This enumeration is used by the TextureStateManager.TextureCoordinateIndex property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureFilter

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureFilter Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines texture filtering modes for a texture stage.

Definition

Visual Basic .NET | Public Enum TextureFilter
C# | public enum TextureFilter
Managed C++ | __value public enum TextureFilter
JScript .NET | public enum TextureFilter

Members

Member | Value | Description
GaussianQuad | 7 | A 4-sample Gaussian filter used as a texture magnification or minification filter.
PyramidalQuad | 6 | A 4-sample tent filter used as a texture magnification or minification filter.
Anisotropic | 3 | Anisotropic texture filtering used as a texture magnification or minification filter. This type of filtering compensates for distortion caused by the difference in angle between the texture polygon and the plane of the screen.
Linear | 2 | Bilinear interpolation filtering used as a texture magnification or minification filter. A weighted average of a 2x2 area of texels surrounding the desired pixel is used. The texture filter used between mipmap levels is trilinear mipmap interpolation, in which the rasterizer performs linear interpolation on pixel color, using the texels of the two nearest mipmap textures.
Point | 1 | Point filtering used as a texture magnification or minification filter. The texel with coordinates nearest to the desired pixel value is used. The texture filter used between mipmap levels is based on the nearest point; that is, the rasterizer uses the color from the texel of the nearest mipmap texture.
None | 0 | Mipmapping disabled. The rasterizer uses the magnification filter instead.

Remarks

To determine whether a format supports texture filter types other than Point (which is always supported), call Manager.CheckDeviceFormat with QueryFilter.

The following C# example shows how to set a texture stage's magnification filter by setting the SamplerStateManager.MagFilter property to a member of this enumeration.

              [C#]

     ...
       device.SamplerState[0].MagFilter = TextureFilter.Linear;
     ...

The following C# code example shows how to set a texture stage's minification filter by setting the SamplerStateManager.MinFilter property to a member of this enumeration.

              [C#]

     ...
       device.SamplerState[0].MinFilter = TextureFilter.Linear;
     ...

The following C# code example shows how to set the texture filter to use between mipmap levels by setting the SamplerStateManager.MipFilter property to a member of this enumeration.

              [C#]

     ...
       device.SamplerState[0].MipFilter = TextureFilter.Linear;
     ...

Not all valid filtering modes for a device apply to volume maps. In general, Point and Linear magnification filters are supported for volume maps. If the TextureCaps.SupportsMipVolumeMap property is set to true (the TextureCaps can be found in the Caps.TextureCaps property), the Point mipmap filter and the Point and Linear minification filters are supported for volume maps. The device might or might not support the Linear mipmap filter for volume maps. Devices that support anisotropic filtering for 2-D maps do not necessarily support it for volume maps. However, applications that enable anisotropic filtering, even if they do not support it, receive the best available filtering (probably linear).

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureOperation

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperation Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines per-stage texture-blending operations.

Definition

Visual Basic .NET | Public Enum TextureOperation
C# | public enum TextureOperation
Managed C++ | __value public enum TextureOperation
JScript .NET | public enum TextureOperation

Members

Member | Value | Description
Subtract 10 Subtracts the components of the second argument from those of the first argument.

SRGBA = Arg1 - Arg2
Lerp 26 Performs linear interpolation between the second and third source arguments by a proportion specified in the first source argument.

SRGBA = (Arg1) * Arg2 + (1- Arg1) * Arg3.
MultiplyAdd 25 Performs a multiply-accumulate operation, in which it multiplies the last two arguments, adds them to the remaining input/source argument, and places that into the result.

SRGBA = Arg1 + Arg2 *Arg3
DotProduct3 24 Modulates the components of each argument as signed components, adds their products, and replicates the sum to all color channels, including alpha. This operation is supported for color and alpha operations.

SRGBA = (Arg1R * Arg2R + Arg1G * Arg2G + Arg1B * Arg2B)
BumpEnvironmentMapLuminance | 23 | Performs per-pixel bump mapping, using the environment map in the next texture stage with luminance. This operation is supported only for color operations (TextureState.ColorOperation).
BumpEnvironmentMap | 22 | Performs bump mapping on each pixel, using the environment map in the next texture stage without luminance. This operation is supported only for color operations (TextureState.ColorOperation).
ModulateInvColorAddAlpha 21 Similar to ModulateColorAddAlpha, but uses the inverse of the color of the first argument. This operation is supported only for color operations (TextureState.ColorOperation).

SRGBA = (1 - Arg1RGB) * Arg2RGB + Arg1A
ModulateInvAlphaAddColor 20 Similar to ModulateAlphaAddColor, but uses the inverse of the alpha of the first argument. This operation is supported only for color operations (TextureState.ColorOperation).

SRGBA = (1 - Arg1A) * Arg2RGB + Arg1RGB
ModulateColorAddAlpha 19 Modulates the arguments, then adds the alpha of the first argument. This operation is supported only for color operations (TextureState.ColorOperation).

SRGBA = Arg1RGB * Arg2RGB + Arg1A
ModulateAlphaAddColor 18 Modulates the color of the second argument using the alpha of the first argument, then adds the result to argument one. This operation is supported only for color operations (TextureStateManager.ColorOperation).

SRGBA = Arg1RGB + Arg1A * Arg2RGB
PreModulate | 17 | This flag is set in stage n, the output of which is arg1. If stage n + 1 contains a texture, any Current value in stage n + 1 is premultiplied by that texture.
BlendCurrentAlpha 16 Performs linear blending on the current texture stage, using the alpha taken from the previous texture stage.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
BlendTextureAlphaPM 15 Performs linear blending on the current texture stage that uses a premultiplied alpha.

SRGBA = Arg1 + Arg2 * (1 - Alpha)
BlendFactorAlpha 14 Performs linear blending on the current texture stage, using a scalar alpha set with the RenderStateManager.TextureFactor property.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
BlendTextureAlpha 13 Performs linear blending on the current texture stage, using the interpolated alpha from each vertex.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
BlendDiffuseAlpha 12 Performs linear blending on the current texture stage, using the interpolated alpha from each vertex.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
AddSmooth 11 Adds the first and second arguments, then subtracts their product from the sum.

SRGBA = Arg1 + Arg2 - Arg1 * Arg2
AddSigned2X 9 Adds the components of the arguments with a -0.5 bias and shifts the products 1 bit to the left.

SRGBA = (Arg1 + Arg2 - 0.5) << 1
AddSigned 8 Adds the components of the arguments with a -0.5 bias, making the effective range of values -0.5 through 0.5.

SRGBA = Arg1 + Arg2 -0.5
Add 7 Adds the components of the arguments.

SRGBA = Arg1 + Arg2
Modulate4X 6 Multiplies the components of the arguments, then shifts the products 2 bits to the left (effectively multiplying them by 4) for brightening.

SRGBA = (Arg1 * Arg2) << 2
Modulate2X 5 Multiplies the components of the arguments, then shifts the products 1 bit to the left (effectively multiplying them by 2) for brightening.

SRGBA = (Arg1 * Arg2) << 1
Modulate 4 Multiplies the components of the arguments.

SRGBA = Arg1 * Arg2
SelectArg2 3 Uses this texture stage's second color or alpha argument, unmodified, as the output. This operation affects the color argument when used with the TextureStateManager.ColorOperation property, and the alpha argument when used with the TextureStateManager.AlphaOperation property.

SRGBA = Arg2
SelectArg1 2 Uses this texture stage's first color or alpha argument, unmodified, as the output. This operation affects the color argument when used with the TextureStateManager.ColorOperation property, and the alpha argument when used with the TextureStateManager.AlphaOperation property.

SRGBA = Arg1
Disable | 1 | Disables output from the texture stage and all stages with a higher index. To disable texture mapping, set this flag as the color operation for the first texture stage (stage 0). Alpha operations cannot be disabled when color operations are enabled. Setting the alpha operation to Disable when color blending is enabled causes undefined behavior.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • TextureOperationCaps


TextureStageStates

TextureStageStates Enumeration

Note: This documentation is preliminary and is subject to change.

Defines texture stage states.

Definition

Visual Basic .NET | Public Enum TextureStageStates
C# | public enum TextureStageStates
Managed C++ | __value public enum TextureStageStates
JScript .NET | public enum TextureStageStates

Members

Member | Value | Description
ResultArgument 28 Selects the destination register for the result of the current stage identified by TextureArgument.

This value can be set to TextureArgument.Current (the default value) or to TextureArgument.Temp, which is a single temporary register that can be read into subsequent stages as an input argument. The final color passed to the fog blender and frame buffer is taken from TextureArgument.Current, so the last active texture stage state must be set to TextureArgument.Current. This setting is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present.
AlphaArgument0 27 Defines settings for the alpha channel selector operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

AlphaArgument0 is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current.

To select a temporary register color for read or write, specify TextureArgument.Temp, which is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default argument is (0.0, 0.0, 0.0, 0.0).
ColorArgument0 26 Defines settings for the third color operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

This setting is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current.

Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
TextureTransform | 24 | Controls the transformation of texture coordinates for the current texture stage. The default value is TextureTransform.Disable.
BumpEnvironmentLuminanceOffset | 23 | Defines a floating-point offset value for bump-map luminance. The default value is 0.0.
BumpEnvironmentLuminanceScale | 22 | Defines a floating-point scale value for bump-map luminance. The default value is 0.0.
BumpEnvironmentMaterial11 | 10 | Defines the texture-stage state as a floating-point value for the [1][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
BumpEnvironmentMaterial10 | 9 | Defines the texture-stage state as a floating-point value for the [1][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
BumpEnvironmentMaterial01 | 8 | Defines the texture-stage state as a floating-point value for the [0][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
BumpEnvironmentMaterial00 | 7 | Defines the texture-stage state as a floating-point value for the [0][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
AlphaArgument2 6 Defines the texture-stage state as the second alpha argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
Constant | 32 | Defines the per-stage constant color. To determine whether the current device supports a per-stage constant color, use the MiscCaps.SupportsPerStageConstant property. The ConstantColor property is used by TextureArgument.Constant.
TextureCoordinateIndex 11 Defines the index of the texture coordinate set to use with the current texture stage.

Up to eight sets of texture coordinates per vertex can be specified. If a vertex does not include a set of texture coordinates at the specified index, the system reverts to the u and v coordinates (0, 0) by default.

When rendering with vertex shaders, each stage's texture coordinate index must be set to its default value. The default index for each stage is equal to the stage index. Set this state to the zero-based index of the coordinate set for each vertex that this texture stage uses.

Additionally, applications can include TextureCoordinateIndex values as part of a logical OR with the index being set, to request that Microsoft® DirectX® automatically generate the input texture coordinates for a texture transformation.

The system uses the index strictly to determine texture wrapping mode when using a TextureCoordinateIndex value other than PassThru, which resolves to zero. These flags are most useful when performing environment mapping.
AlphaArgument1 5 Defines the texture-stage state as the first alpha argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.TextureColor. If no texture is set for this stage, the default argument is TextureArgument.Diffuse. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
AlphaOperation 4 Defines the texture-stage state as a texture alpha-blending operation identified by the TextureOperation enumeration.

The default value for the first texture stage (stage 0) is TextureOperation.SelectArg1, and for all other stages is TextureOperation.Disable.
ColorArgument2 3 Defines the texture-stage state as the second color argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
ColorArgument1 2 Defines the texture-stage state as the first color argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.Texture. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
ColorOperation 1 Defines the texture-stage state as a texture color-blending operation identified by the TextureOperation enumeration.

The default value for the first texture stage (stage 0) is TextureOperation.Modulate, and for all other stages is TextureOperation.Disable.

Remarks

These enumeration constants and values are used by the Device.SetTextureStageState method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • TextureStateManager
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


TextureTransform

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureTransform Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines texture-stage state values.

Definition

Visual Basic .NET | Public Enum TextureTransform
C# | public enum TextureTransform
Managed C++ | __value public enum TextureTransform
JScript .NET | public enum TextureTransform

Members

Member | Value | Description
Projected | 256 | All texture coordinates are divided by the last element before being passed to the rasterizer. For example, if this flag is specified with the Count3 flag, the first and second texture coordinates are divided by the third coordinate before being passed to the rasterizer.
Count4 | 4 | 4-D texture coordinates are passed to the rasterizer.
Count3 | 3 | 3-D texture coordinates are passed to the rasterizer.
Count2 | 2 | 2-D texture coordinates are passed to the rasterizer.
Count1 | 1 | 1-D texture coordinates are passed to the rasterizer.
Disable | 0 | Texture coordinates are passed directly to the rasterizer.

Remarks

This enumeration is used by the TextureStateManager.TextureTransform property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TransformType

Microsoft DirectX 9.0 SDK Update (October 2004)

TransformType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines constants that describe transformation state values.

Definition

Visual Basic .NET | Public Enum TransformType
C# | public enum TransformType
Managed C++ | __value public enum TransformType
JScript .NET | public enum TransformType

Members

Member | Value | Description
World3 | 259 | Identifies the world matrix being set for the specified texture stage.
World2 | 258 | Identifies the world matrix being set for the specified texture stage.
World1 | 257 | Identifies the world matrix being set for the specified texture stage.
World | 256 | Identifies the world matrix being set for the specified texture stage.
Texture7 | 23 | Identifies the transformation matrix being set for the specified texture stage.
Texture6 | 22 | Identifies the transformation matrix being set for the specified texture stage.
Texture5 | 21 | Identifies the transformation matrix being set for the specified texture stage.
Texture4 | 20 | Identifies the transformation matrix being set for the specified texture stage.
Texture3 | 19 | Identifies the transformation matrix being set for the specified texture stage.
Texture2 | 18 | Identifies the transformation matrix being set for the specified texture stage.
Texture1 | 17 | Identifies the transformation matrix being set for the specified texture stage.
Texture0 | 16 | Identifies the transformation matrix being set for the specified texture stage.
Projection | 3 | Identifies the transformation matrix being set as the projection transformation matrix. The default value is the identity matrix.
View | 2 | Identifies the transformation matrix being set as the view transformation matrix. The default value is the identity matrix.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • SetTransform
  • GetTransform
  • MultiplyTransform


TransitionType

Microsoft DirectX 9.0 SDK Update (October 2004)

TransitionType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the transition style between values of a mesh animation.

Definition

Visual Basic .NET | Public Enum TransitionType
C# | public enum TransitionType
Managed C++ | __value public enum TransitionType
JScript .NET | public enum TransitionType

Members

Member | Value | Description
EaseInEaseOut | 1 | Ease-in, ease-out spline transition between values.
Linear | 0 | Linear transition between values.

Remarks

The calculation for the ramp from ease-in to ease-out is calculated as follows.

Q(t) = 2(x - y)t3 + 3(y - x)t2 + x.

where the ramp is a function Q(t) with the following properties:

  • Q(t) is a cubic spline.
  • Q(t) interpolates between x and y as t ranges from 0 to 1.
  • Q(t) is horizontal when t = 0 and t = 1.

Mathematically, this translates into:

Q(t) = At3 + Bt2 + Ct + D (and therefore, Q'(t) = 3At2 + 2Bt + C)

Q(0) = x (2a)

Q(1) = y (2b)

Q'(0) = 0 (3a)

Q'(1) = 0 (3b)

Solving for A, B, C, D:

D = x (from 2a)

C = 0 (from 3a)

3A + 2B = 0 (from 3b)

A + B = y - x (from 2b and D = x)

Therefore:

A = 2(x - y), B = 3(y - x), C = 0, D = x.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • AnimationController


Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

Usage Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines supported usage types for the current resource.

Definition

Visual Basic .NET | Public Enum Usage
C# | public enum Usage
Managed C++ | __value public enum Usage
JScript .NET | public enum Usage

Members

Member | Value | Description
None | 0 | Specifies no usage type for the current resource.
QueryWrapAndMip | 2097152 | Queries the resource to verify support for texture wrapping and mip-mapping.
QueryVertexTexture | 1048576 | Queries the resource to verify support for vertex shader texture sampling.
QueryPostPixelShaderBlending | 524288 | Queries the resource to verify support for post pixel shader blending. If Manager.CheckDeviceFormat fails with QueryPostPixelShaderBlending, post pixel blending operations are not supported. These operations include alpha test, pixel fog, render-target blending, color write enable, and dither.
QuerySrgbWrite | 262144 | Queries the resource to determine whether a texture supports gamma correction during a write operation.
QueryFilter | 131072 | Queries the resource format to determine whether it supports texture filter types other than Point (which is always supported).
QuerySrgbRead | 65536 | Queries the resource to determine whether a texture supports gamma correction during a read operation.
QueryLegacyBumpMap | 32768 | Queries the resource about a legacy bump map.
QueryDisplacementMap | 16384 | Queries the resource to determine whether it will be a displacement map.
AutoGenerateMipMap | 1024 | Specifies that the resource automatically generate mipmaps. Automatic mipmap generation is not supported for volume textures and depth stencil surfaces/textures. This usage is not valid for resources in system memory (SystemMemory).
Dynamic | 512 | Indicates that the vertex buffer requires dynamic memory use, which is useful for drivers because it enables them to determine where to place the buffer. In general, static vertex buffers are placed in video memory and dynamic vertex buffers are placed in accelerated graphics port (AGP) memory. Note that there is no separate static use. If Dynamic is not specified, the vertex buffer is made static.
NPatches | 256 | Indicates when the vertex buffer will be used for drawing N-patches.
RTPatches | 128 | Indicates when the vertex buffer will be used for drawing high-order primitives.
Points | 64 | Indicates when the vertex buffer will be used for drawing points.
DoNotClip | 32 | Indicates that the vertex buffer content will never require clipping. When rendering with buffers that have this flag set, the RenderStateManager.Clipping property must be set to false.
SoftwareProcessing | 16 | Specifies that vertex processing be done in software. If this flag is not used, vertex processing is done in hardware. SoftwareProcessing is used with Manager.CheckDeviceFormat to determine whether a particular texture format can be used as a vertex texture during software vertex processing. If it can, the texture must be created with Scratch.
WriteOnly | 8 | Informs the system that the application writes only to the vertex buffer. Using this flag enables the driver to choose the best memory location, which results in efficient write operations and rendering. Attempts to read from a vertex buffer created with this capability will fail. Buffers that are created with Default and that do not specify WriteOnly might experience significant drops in performance.
DepthStencil | 2 | Specifies that the resource will be a depth stencil buffer. DepthStencil can be used only with Default.
RenderTarget | 1 | Specifies that the resource will be a render target. RenderTarget can be used only with Default.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Resource Properties
  • SurfaceDescription.Usage
  • VertexBufferDescription.Usage
  • IndexBufferDescription.Usage


VertexBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBlend Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines enumerated values used to control the number of matrices that the system applies when performing multimatrix vertex blending.

Definition

Visual Basic .NET | Public Enum VertexBlend
C# | public enum VertexBlend
Managed C++ | __value public enum VertexBlend
JScript .NET | public enum VertexBlend

Members

Member | Value | Description
ZeroWeights | 256 | Uses a single matrix with a weight of 1.0.
Tweening | 255 | Uses the value assigned to RenderStateManager.TweenFactor.
ThreeWeights | 3 | Enables vertex blending between the four matrices set by the Transforms.SetWorldMatrixByIndex method, where the index values for the transformation states are 0, 1, 2, and 3. These matrices also can be set using the device.Transform.World, device.Transform.World1, device.Transform.World2, and device.Transform.World3 properties.
TwoWeights | 2 | Enables vertex blending between the three matrices set by the Transforms.SetWorldMatrixByIndex method, where the index values for the transformation states are 0, 1, and 2. These matrices also can be set using the device.Transform.World, device.Transform.World1, and device.Transform.World2 properties.
OneWeights | 1 | Enables vertex blending between the two matrices set by the Transforms.SetWorldMatrixByIndex method, where the index values for the transformation states are 0 and 1. These matrices also can be set using the device.Transform.World and device.Transform.World1 properties.
Disable | 0 | Disables vertex blending and applies only the world matrix (set by the Transforms.SetWorldMatrixByIndex method, where the index value for the transformation state is 0, or with the Device.Transform.World property).

Remarks

This enumeration is used by the RenderStateManager.VertexBlend parameters.

Multimatrix vertex blending (also known as geometry blending) requires that an application use a vertex format that has blending (beta) weights for each vertex.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexFormats

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexFormats Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Describes values that define a vertex format used to describe the contents of vertices that are stored interleaved in a single data stream.

Definition

Visual Basic .NET | Public Enum VertexFormats
C# | public enum VertexFormats
Managed C++ | __value public enum VertexFormats
JScript .NET | public enum VertexFormats

Members

Member | Value | Description
PositionNormal | 18 | Vertex format includes a vertex normal vector. This value cannot be used with the Transformed value.
LastBetaD3DColor | 32768 | Last beta field in the vertex position data will be of type Int32 Leave Site. The data in the beta fields are used with matrix palette skinning to specify matrix indices.
LastBetaUByte4 | 4096 | Last beta field in the vertex position data will be of type UBYTE4. The data in the beta fields are used with matrix palette skinning to specify matrix indices. The vertex format is declared as PositionBlend5 | LastBetaUByte4. Both weights and MatrixIndices are included in beta[], where LastBetaUByte4 directs the compiler to interpret the last uint (beta[5]) as type UBYTE4. The last beta is determined by VertexBlend, not by the number of betas in the position format. For example, if VertexBlend is TwoWeights, and the position format is as specified above, the last beta will be beta[2] and will be used as a uint with 4-byte indices.
Texture8 | 2048 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture7 | 1792 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture6 | 1536 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture5 | 1280 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture4 | 1024 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture3 | 768 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture2 | 512 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture1 | 256 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture0 | 0 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
TextureCountShift | 8 | Number of bits by which to shift an integer value that identifies the number of texture coordinates for a vertex.
TextureCountMask | 3840 | Mask value for texture flag bits.
Specular | 128 | Vertex format includes a specular color component.
Diffuse | 64 | Vertex format includes a diffuse color component.
PointSize | 32 | Vertex format is specified in point size. This size is expressed in camera space units for vertices that are not transformed and lit, and in device-space units for vertices that are transformed and lit.
Normal | 16 | Vertex format includes a vertex normal vector. This value cannot be used with the Transformed flag.
PositionW | 16386 | Vertex format contains transformed and clipped x, y, z, w data. Device.ProcessVertices does not invoke the clipper, but instead outputs data in clip coordinates. This constant is designed for, and can only be used with, the programmable vertex pipeline.
PositionBlend5 | 14 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Microsoft® Direct3D® can blend with up to three weighting values and four blending matrices.
PositionBlend4 | 12 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Microsoft® Direct3D® can blend with up to three weighting values and four blending matrices.
PositionBlend3 | 10 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Microsoft® Direct3D® can blend with up to three weighting values and four blending matrices.
PositionBlend2 | 8 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Microsoft® Direct3D® can blend with up to three weighting values and four blending matrices.
PositionBlend1 | 6 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Microsoft® Direct3D® can blend with up to three weighting values and four blending matrices.
Transformed | 4 | Vertex format includes the position of a transformed vertex. This flag cannot be used with the Position or Normal flags.
Position | 2 | Mask for position bits.
PositionMask | 16398 | Mask for position bits.
None | 0 | No vertex format.

Remarks

Vertex format codes generally are used to specify data to be processed by fixed function vertex processing.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WeldEpsilonsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilonsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the options for welding vertices together.

Definition

Visual Basic .NET | Public Enum WeldEpsilonsFlags
C# | public enum WeldEpsilonsFlags
Managed C++ | __value public enum WeldEpsilonsFlags
JScript .NET | public enum WeldEpsilonsFlags

Members

Member | Value | Description
DoNotSplit | 8 | Instructs the weld to allow vertices to be modified only, not removed. This flag is valid only if WeldPartialMatches is set. It is useful to modify vertices so that they are equal, but not to allow vertices to be removed.
DoNotRemoveVertices | 4 | Instructs the weld to allow vertices to be modified only, not removed. This flag is valid only if WeldPartialMatches is set. It is useful to modify vertices to be equal, but not to allow vertices to be removed.
WeldPartialMatches | 2 | If a given vertex component is within epsilon, instructs the weld to modify partially matched vertices so that both components are equal. If all components are equal, one of the vertices is removed.
WeldAll | 1 | Welds all vertices that are marked by adjacency as being overlapping.

Remarks

This enumeration is used with the Mesh.WeldVertices method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Wrap

Microsoft DirectX 9.0 SDK Update (October 2004)

Wrap Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines texture wrapping.

Definition

Visual Basic .NET | Public Enum Wrap
C# | public enum Wrap
Managed C++ | __value public enum Wrap
JScript .NET | public enum Wrap

Members

Member | Value | Description
W | 4 | W texture wrapping (wrapping in the direction of the third dimension).
V | 2 | V texture wrapping (wrapping in the direction of the second dimension).
U | 1 | U texture wrapping (wrapping in the direction of the first dimension).

Remarks

This enumeration is used by the RenderStateManager.Wrap0 property and the Wrap1 through Wrap15 properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • WrapCoordinates


WrapCoordinates

Microsoft DirectX 9.0 SDK Update (October 2004)

WrapCoordinates Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines supported wrap coordinates.

Definition

Visual Basic .NET | Public Enum WrapCoordinates
C# | public enum WrapCoordinates
Managed C++ | __value public enum WrapCoordinates
JScript .NET | public enum WrapCoordinates

Members

Member | Value | Description
Zero | 1 | U texture wrapping (wrapping in the direction of the first dimension).
Three | 8 | Texture wrapping in the direction of the fourth dimension.
Two | 4 | W texture wrapping (wrapping in the direction of the third dimension).
One | 2 | V texture wrapping (wrapping in the direction of the second dimension).

Remarks

This enumeration is used by the RenderStateManager.Wrap0 property and the Wrap1 through Wrap15 properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Wrap


XFileErrorCodes

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileErrorCodes Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines XFile error codes. The methods used to work with Microsoft® DirectX® XFiles can return the following return values. Exceptions thrown from methods that use XFiles can also contain these values.

Definition

Visual Basic .NET | Public Enum XFileErrorCodes
C# | public enum XFileErrorCodes
Managed C++ | __value public enum XFileErrorCodes
JScript .NET | public enum XFileErrorCodes

Members

Member | Value | Description
BadCacheFile | -2005531755 | A cache file could not be read.
NoMoreData | -2005531756 | No further data is available.
NoMoreObjects | -2005531757 | All objects have been enumerated.
BadDataReference | -2005531758 | Template member data could not be retrieved.
BadArraySize | -2005531759 | Array size exceeds the allowable size.
ParseError | -2005531760 | File could not be parsed.
BadFile | -2005531761 | A file read or write operation failed.
BadFileFloatSize | -2005531762 | File is not the expected size.
BadFileVersion | -2005531763 | File has an invalid format version.
BadFileType | -2005531764 | File has an invalid format.
BadResource | -2005531765 | Resource is invalid.
ResourceNotFound | -2005531766 | Resource could not be found.
FileNotFound | -2005531767 | File could not be found.
NotDoneYet | -2005531768 | Operation has not completed.
NotFound | -2005531769 | Object could not be found.
BadType | -2005531770 | File did not match known template types.
BadValue | -2005531771 | A variable is outside its expected range; typically returned when an object is invalid.
BadObject | -2005531772 | Data could not be read from or written to an object.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


XFileFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

XFileFormat Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Defines file formats for XFiles.

Definition

Visual Basic .NET | Public Enum XFileFormat
C# | public enum XFileFormat
Managed C++ | __value public enum XFileFormat
JScript .NET | public enum XFileFormat

Members

Member | Value | Description
Compressed | 2 | Indicates a compressed file.
Text | 1 | Indicates a text file.
Binary | 0 | Indicates a binary file.

Remarks

This enumeration is used by Mesh.Save and XFileManager.CreateSaveObject.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AdapterDetails

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains information that identifies the adapter.

Definition

Visual Basic .NET | Public Structure AdapterDetails
C# | public struct AdapterDetails
Managed C++ | public __value struct AdapterDetails
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AdapterDetails | Creates a new instance of the AdapterDetails structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Description | Retrieves a string used for presentation to the user.
DeviceId | Retrieves a value that is used to help identify a particular chip set.
DeviceIdentifier | Retrieves a globally unique identifier (GUID) object that can be used to check changes in the driver and chip set.
DeviceName | Retrieves a string that contains the device name for a Microsoft® Windows® Graphics Device Interface (GDI).
DriverName | Retrieves a string that is used to present the driver name to the user.
DriverVersion | Retrieves a value that identifies the version of the Microsoft Direct3D® driver.
Revision | Retrieves a value used to help identify the revision level of a particular chip set.
SubSystemId | Retrieves a value used to identify the subsystem.
VendorId | Retrieves a value used to identify the manufacturer.
WhqlLevel | Retrieves a value that is used to determine the Windows Hardware Quality Labs (WHQL) validation level for the driver and device pair.

Remarks

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AdapterDetails.AdapterDetails()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.AdapterDetails Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the AdapterDetails structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public AdapterDetails();
Managed C++ | public: AdapterDetails();
JScript .NET | public function AdapterDetails();


AdapterDetails.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


AdapterDetails.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a string used for presentation to the user.

Definition

Visual Basic .NET | Public ReadOnly Property Description As String
C# | public string Description { get; }
Managed C++ | public: __property String* get_Description();
JScript .NET | public function get Description() : String

Property Value

System.String . A String Leave Site object that describes the adapter to the user.

This property is read-only.


AdapterDetails.DeviceId

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.DeviceId Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that is used to help identify a particular chip set.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceId As Integer
C# | public int DeviceId { get; }
Managed C++ | public: __property int get_DeviceId();
JScript .NET | public function get DeviceId() : int

Property Value

System.Int32 . Value that helps identify the chip set.

This property is read-only.

Remarks

The returned value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.DeviceIdentifier

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.DeviceIdentifier Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a globally unique identifier (GUID) object that can be used to check changes in the driver and chip set.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceIdentifier As Guid
C# | public Guid DeviceIdentifier { get; }
Managed C++ | public: __property Guid get_DeviceIdentifier();
JScript .NET | public function get DeviceIdentifier() : Guid

Property Value

System.Guid . A Guid Leave Site object that is used as a unique identifier for the driver and chip set pair.

This property is read-only.

Remarks

Use this member to track changes to the driver and chip set to generate a new profile for the graphics subsystem. It also can be used to identify problematic drivers.


AdapterDetails.DeviceName

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.DeviceName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a string that contains the device name for a Microsoft® Windows® Graphics Device Interface (GDI).

Definition

Visual Basic .NET | Public ReadOnly Property DeviceName As String
C# | public string DeviceName { get; }
Managed C++ | public: __property String* get_DeviceName();
JScript .NET | public function get DeviceName() : String

Property Value

System.String . A String Leave Site object that contains the name of the device.

This property is read-only.


AdapterDetails.DriverName

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.DriverName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a string that is used to present the driver name to the user.

Definition

Visual Basic .NET | Public ReadOnly Property DriverName As String
C# | public string DriverName { get; }
Managed C++ | public: __property String* get_DriverName();
JScript .NET | public function get DriverName() : String

Property Value

System.String . A String Leave Site object that contains the driver name.

This property is read-only.

Remarks

This member should not be used to identify particular drivers, because many different strings might be associated with the same device and driver from different vendors.


AdapterDetails.DriverVersion

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.DriverVersion Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that identifies the version of the Microsoft® Direct3D® driver.

Definition

Visual Basic .NET | Public ReadOnly Property DriverVersion As Version
C# | public Version DriverVersion { get; }
Managed C++ | public: __property Version* get_DriverVersion();
JScript .NET | public function get DriverVersion() : Version

Property Value

System.Version . A Version Leave Site object that represents the driver version.

This property is read-only.


AdapterDetails.Revision

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.Revision Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value used to help identify the revision level of a particular chip set.

Definition

Visual Basic .NET | Public ReadOnly Property Revision As Integer
C# | public int Revision { get; }
Managed C++ | public: __property int get_Revision();
JScript .NET | public function get Revision() : int

Property Value

System.Int32 . Value used to help identify the revision level of the chip set.

This property is read-only.

Remarks

The value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.SubSystemId

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.SubSystemId Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value used to identify the subsystem.

Definition

Visual Basic .NET | Public ReadOnly Property SubSystemId As Integer
C# | public int SubSystemId { get; }
Managed C++ | public: __property int get_SubSystemId();
JScript .NET | public function get SubSystemId() : int

Property Value

System.Int32 . Value used to identify the subsystem, typically the particular board.

This property is read-only.

Remarks

The value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.VendorId

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.VendorId Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value used to identify the manufacturer.

Definition

Visual Basic .NET | Public ReadOnly Property VendorId As Integer
C# | public int VendorId { get; }
Managed C++ | public: __property int get_VendorId();
JScript .NET | public function get VendorId() : int

Property Value

System.Int32 . Value used to identify the manufacturer.

This property is read-only.

Remarks

The value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.WhqlLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

AdapterDetails.WhqlLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that is used to determine the Microsoft® Windows® Hardware Quality Labs (WHQL) validation level for the driver and device pair.

Definition

Visual Basic .NET | Public ReadOnly Property WhqlLevel As Integer
C# | public int WhqlLevel { get; }
Managed C++ | public: __property int get_WhqlLevel();
JScript .NET | public function get WhqlLevel() : int

Property Value

System.Int32 . Value used to determine the validation level for the driver and device pair.

This property is read-only.

Remarks

The Int32 Leave Site is a packed date structure that defines the date of the release of the most recent Microsoft® Windows® Hardware Quality Labs (WHQL) test passed by the driver. It is permissible to perform "greater than" and "less than" operations on this value. The following table illustrates the date format.

Bits | Description
31-16 | The year, a decimal number from 1999 upwards.
15-8 | The month, a decimal number from 1 to 12.
7-0 | The day, a decimal number from 1 to 31.

The following values also are used.

Value | Description
0 | Not certified.
1 | Validated by WHQL, but no date information is available.


AddressCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains the texture addressing capabilities for Texture objects.

Definition

Visual Basic .NET | Public Structure AddressCaps
C# | public struct AddressCaps
Managed C++ | public __value struct AddressCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsBorder | Retrieves a value that determines whether the device supports the setting of coordinates outside the range [0.0, 1.0] to the border color.
SupportsClamp | Retrieves a value that indicates whether the device supports the clamping of textures to addresses.
SupportsIndependentUV | Retrieves a value that indicates whether the device can separate the texture-addressing modes of the texture's u and v coordinates.
SupportsMirror | Retrieves a value that indicates whether a device can mirror textures to addresses.
SupportsMirrorOnce | Retrieves a value that indicates whether a device can take the absolute value of the texture coordinate (thus, mirroring around 0) and then clamp to the maximum value.
SupportsWrap | Retrieves a value that indicates whether a device can wrap textures to addresses.

Remarks

This structure is found in the Caps.TextureAddressCaps and Caps.VolumeTextureAddressCaps members.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AddressCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


AddressCaps.SupportsBorder

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps.SupportsBorder Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that determines whether the device supports the setting of coordinates outside the range [0.0, 1.0] to the border color.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBorder As Boolean
C# | public bool SupportsBorder { get; }
Managed C++ | public: __property bool get_SupportsBorder();
JScript .NET | public function get SupportsBorder() : boolean

Property Value

System.Boolean . Value that is true if the device supports the setting of coordinates outside the range to the border color, or false if it does not.

This property is read-only.

Remarks

The SamplerStateManager.BorderColor member sets the border color.


AddressCaps.SupportsClamp

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps.SupportsClamp Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether the device supports the clamping of textures to addresses.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsClamp As Boolean
C# | public bool SupportsClamp { get; }
Managed C++ | public: __property bool get_SupportsClamp();
JScript .NET | public function get SupportsClamp() : boolean

Property Value

System.Boolean . Value that is true if the device supports clamping textures to addresses, or false if it does not.

This property is read-only.


AddressCaps.SupportsIndependentUV

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps.SupportsIndependentUV Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether the device can separate the texture-addressing modes of the texture's u and v coordinates.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsIndependentUV As Boolean
C# | public bool SupportsIndependentUV { get; }
Managed C++ | public: __property bool get_SupportsIndependentUV();
JScript .NET | public function get SupportsIndependentUV() : boolean

Property Value

System.Boolean . Value that is true if the device supports separating the texture-addressing modes of the u and v coordinates, or false if it does not.

This property is read-only.

Remarks

This property's ability corresponds to the SamplerStateManager.AddressU and SamplerStateManager.AddressV render-state values.


AddressCaps.SupportsMirror

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps.SupportsMirror Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether a device can mirror textures to addresses.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMirror As Boolean
C# | public bool SupportsMirror { get; }
Managed C++ | public: __property bool get_SupportsMirror();
JScript .NET | public function get SupportsMirror() : boolean

Property Value

System.Boolean . Value that is true if the device supports mirroring textures to addresses, or false if it does not.

This property is read-only.


AddressCaps.SupportsMirrorOnce

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps.SupportsMirrorOnce Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether a device can take the absolute value of the texture coordinate (thus, mirroring around 0) and then clamp to the maximum value.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMirrorOnce As Boolean
C# | public bool SupportsMirrorOnce { get; }
Managed C++ | public: __property bool get_SupportsMirrorOnce();
JScript .NET | public function get SupportsMirrorOnce() : boolean

Property Value

System.Boolean . Value that is true if the device can take the absolute value of the texture coordinate and then clamp to the maximum value, or false if it cannot.

This property is read-only.


AddressCaps.SupportsWrap

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressCaps.SupportsWrap Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether a device can wrap textures to addresses.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsWrap As Boolean
C# | public bool SupportsWrap { get; }
Managed C++ | public: __property bool get_SupportsWrap();
JScript .NET | public function get SupportsWrap() : boolean

Property Value

System.Boolean . Value that is true if the device can wrap textures to addresses, or false if it cannot.

This property is read-only.


AnimationRootFrame

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationRootFrame Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains the root frame and animation controller in a frame hierarchy.

Definition

Visual Basic .NET | Public Structure AnimationRootFrame
C# | public struct AnimationRootFrame
Managed C++ | public __value struct AnimationRootFrame
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AnimationRootFrame | Creates a new instance of the AnimationRootFrame structure.

Properties

Property | Description
AnimationController | Retrieves the animation controller.
FrameHierarchy | Retrieves the root node reference of the loaded frame hierarchy.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AnimationRootFrame.AnimationRootFrame()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationRootFrame.AnimationRootFrame Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the AnimationRootFrame structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public AnimationRootFrame();
Managed C++ | public: AnimationRootFrame();
JScript .NET | public function AnimationRootFrame();

See Also

  • LoadHierarchyFromFile


AnimationRootFrame.AnimationController

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationRootFrame.AnimationController Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the animation controller.

Definition

Visual Basic .NET | Public ReadOnly Property AnimationController As AnimationController
C# | public AnimationController AnimationController { get; }
Managed C++ | public: __property AnimationController* get_AnimationController();
JScript .NET | public function get AnimationController() : AnimationController

Property Value

Microsoft.DirectX.Direct3D.AnimationController . The AnimationController object.

This property is read-only.

Remarks

Animations loaded from a DirectX (.x) file have an AnimationController object that corresponds to the animation in the .x file. The controller is created with default maximum tracks and events.

See Also

  • LoadHierarchyFromFile


AnimationRootFrame.FrameHierarchy

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationRootFrame.FrameHierarchy Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the root node reference of the loaded frame hierarchy.

Definition

Visual Basic .NET | Public ReadOnly Property FrameHierarchy As Frame
C# | public Frame FrameHierarchy { get; }
Managed C++ | public: __property Frame* get_FrameHierarchy();
JScript .NET | public function get FrameHierarchy() : Frame

Property Value

Microsoft.DirectX.Direct3D.Frame . A Frame object that represents the root node of the frame hierarchy.

This property is read-only.


AttributeRange

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeRange Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Stores an attribute table entry.

Definition

Visual Basic .NET | Public Structure AttributeRange
C# | public struct AttributeRange
Managed C++ | public __value struct AttributeRange
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AttributeRange | Creates a new instance of the AttributeRange structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AttributeId | Retrieves or sets the attribute table identifier.
FaceCount | Retrieves or sets the number of faces included in an attribute table entry.
FaceStart | Retrieves or sets the first face in an attribute group.
VertexCount | Retrieves or sets the number of vertices in the attribute group.
VertexStart | Retrieves or sets the first vertex in an attribute group.

Remarks

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states, and materials. In addition, an application can use the attribute table to hide portions of a mesh by not drawing a given attribute identifier (AttributeRange.AttribId) when it draws the frame. Attribute tables also can be used to identify application-defined areas of a mesh that are handled by custom code.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • BaseMesh.DrawSubset


AttributeRange.AttributeRange()

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeRange.AttributeRange Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the AttributeRange structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public AttributeRange();
Managed C++ | public: AttributeRange();
JScript .NET | public function AttributeRange();


AttributeRange.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeRange.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


AttributeRange.AttributeId

AttributeRange.AttributeId Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the attribute table identifier.

Definition

Visual Basic .NET | Public Property AttributeId As Integer
C# | public int AttributeId { get; set; }
Managed C++ public: __property int get_AttributeId();
public: __property void set_AttributeId(int);
JScript .NET public function get AttributeId() : int
public function set AttributeId(int);

Property Value

System.Int32 . An Int32 Leave Site value that specifies the number used to identify the attribute table entry.

This property is read/write.

Remarks

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states, and materials. In addition, an application can use the attribute table to hide portions of a mesh by not drawing a given attribute identifier (attributeID) when it draws the frame. Attribute tables also can be used to identify application-defined areas of a mesh that are handled by custom code.

See Also

  • BaseMesh.DrawSubset
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


AttributeRange.FaceCount

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeRange.FaceCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of faces included in an attribute table entry.

Definition

Visual Basic .NET | Public Property FaceCount As Integer
C# | public int FaceCount { get; set; }
Managed C++ public: __property int get_FaceCount();
public: __property void set_FaceCount(int);
JScript .NET public function get FaceCount() : int
public function set FaceCount(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of faces in the attribute range.

This property is read/write.


AttributeRange.FaceStart

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeRange.FaceStart Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the first face in an attribute group.

Definition

Visual Basic .NET | Public Property FaceStart As Integer
C# | public int FaceStart { get; set; }
Managed C++ public: __property int get_FaceStart();
public: __property void set_FaceStart(int);
JScript .NET public function get FaceStart() : int
public function set FaceStart(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the index of the first face in the attribute group.

This property is read/write.


AttributeRange.VertexCount

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeRange.VertexCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of vertices in the attribute group.

Definition

Visual Basic .NET | Public Property VertexCount As Integer
C# | public int VertexCount { get; set; }
Managed C++ public: __property int get_VertexCount();
public: __property void set_VertexCount(int);
JScript .NET public function get VertexCount() : int
public function set VertexCount(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of vertices in the attribute group.

This property is read/write.


AttributeRange.VertexStart

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeRange.VertexStart Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the first vertex in an attribute group.

Definition

Visual Basic .NET | Public Property VertexStart As Integer
C# | public int VertexStart { get; set; }
Managed C++ public: __property int get_VertexStart();
public: __property void set_VertexStart(int);
JScript .NET public function get VertexStart() : int
public function set VertexStart(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the index of the first vertex in the attribute group.

This property is read/write.


AttributeWeights

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies mesh weight attributes.

Definition

Visual Basic .NET | Public Structure AttributeWeights
C# | public struct AttributeWeights
Managed C++ | public __value struct AttributeWeights
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AttributeWeights | Creates a new instance of the AttributeWeights structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Binormal | Retrieves or sets a numerical value that indicates the degree to which binormal data is used in simplification operations.
Boundary | Retrieves or sets a numerical value that indicates the degree to which boundary data is used in simplification operations.
Diffuse | Retrieves or sets a numerical value that indicates the degree to which diffuse data is used in simplification operations.
Normal | Retrieves or sets a numerical value that indicates the degree to which normal data is used in simplification operations.
Position | Retrieves or sets a numerical value that indicates the degree to which position data is used in simplification operations.
Specular | Retrieves or sets a numerical value that indicates the degree to which specular data is used in simplification operations.
Tangent | Retrieves or sets a numerical value that indicates the degree to which tangent data is used in simplification operations.
TextureCoordinate | Retrieves or sets a numerical value that indicates the degree to which texture coordinate data is used in simplification operations.

Remarks

This structure describes how a simplification operation considers vertex data when calculating relative costs between collapsing edges. For example, if the Normal field is 0.0, the simplification operation ignores the vertex normal component when it calculates the error for the collapse. However, if the Normal field is 1.0, the simplification operation uses the vertex normal component. If the Normal field is 2.0, double the amount of errors; if the Binormal field is 4.0, quadruple the number of errors, and so on.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.AttributeWeights()

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.AttributeWeights Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the AttributeWeights structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public AttributeWeights();
Managed C++ | public: AttributeWeights();
JScript .NET | public function AttributeWeights();


AttributeWeights.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


AttributeWeights.Binormal

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.Binormal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which binormal data is used in simplification operations.

Definition

Visual Basic .NET | Public Property Binormal As Single
C# | public float Binormal { get; set; }
Managed C++ public: __property float get_Binormal();
public: __property void set_Binormal(float);
JScript .NET public function get Binormal() : float
public function set Binormal(float);

Property Value

System.Single . A Single Leave Site value that indicates the degree to which binormal data is used in simplification operations.

This property is read/write.

Remarks

If the Binormal field is 0.0, the simplification operation ignores the vertex binormal component when it calculates the error for collapsing the edges of a mesh. However, if the Binormal field is 1.0, the simplification operation uses the vertex binormal component. If the Binormal field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Boundary

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.Boundary Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which boundary data is used in simplification operations.

Definition

Visual Basic .NET | Public Property Boundary As Single
C# | public float Boundary { get; set; }
Managed C++ public: __property float get_Boundary();
public: __property void set_Boundary(float);
JScript .NET public function get Boundary() : float
public function set Boundary(float);

Property Value

System.Single . A Single Leave Site value that indicates the degree to which boundary data is used in simplification operations.

This property is read/write.

Remarks

If the Boundary field is 0.0, the simplification operation ignores the boundary component when it calculates the error for collapsing the edges of a mesh. However, if the Boundary field is 1.0, the simplification operation uses the boundary component. If the Boundary field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Diffuse

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.Diffuse Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which diffuse data is used in simplification operations.

Definition

Visual Basic .NET | Public Property Diffuse As Single
C# | public float Diffuse { get; set; }
Managed C++ public: __property float get_Diffuse();
public: __property void set_Diffuse(float);
JScript .NET public function get Diffuse() : float
public function set Diffuse(float);

Property Value

System.Single . A Single Leave Site value that indicates the degree to which diffuse data is used in simplification operations.

This property is read/write.

Remarks

If the Diffuse field is 0.0, the simplification operation ignores the diffuse component when it calculates the error for collapsing the edges of a mesh. However, if the Diffuse field is 1.0, the simplification operation uses the diffuse component. If the Diffuse field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Normal

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.Normal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which normal data is used in simplification operations.

Definition

Visual Basic .NET | Public Property Normal As Single
C# | public float Normal { get; set; }
Managed C++ public: __property float get_Normal();
public: __property void set_Normal(float);
JScript .NET public function get Normal() : float
public function set Normal(float);

Property Value

System.Single . A Single Leave Site value that indicates the degree to which normal data is used in simplification operations.

This property is read/write.

Remarks

This structure describes how a simplification operation considers vertex data when calculating relative costs between collapsing edges. For example, if the Normal field is 0.0, the simplification operation ignores the vertex normal component when it calculates the error for the collapse. However, if the Normal field is 1.0, the simplification operation uses the vertex normal component. If the Normal field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which position data is used in simplification operations.

Definition

Visual Basic .NET | Public Property Position As Single
C# | public float Position { get; set; }
Managed C++ public: __property float get_Position();
public: __property void set_Position(float);
JScript .NET public function get Position() : float
public function set Position(float);

Property Value

System.Single . A Single Leave Site value that indicates the degree to which position data is used in simplification operations.

This property is read/write.

Remarks

If the Position field is 0.0, the simplification operation ignores the position component when it calculates the error for collapsing the edges of a mesh. However, if the Position field is 1.0, the simplification operation uses the position component. If the Position field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Specular

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.Specular Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which specular data is used in simplification operations.

Definition

Visual Basic .NET | Public Property Specular As Single
C# | public float Specular { get; set; }
Managed C++ public: __property float get_Specular();
public: __property void set_Specular(float);
JScript .NET public function get Specular() : float
public function set Specular(float);

Property Value

System.Single . A Single Leave Site value that indicates the degree to which specular data is used in simplification operations.

This property is read/write.

Remarks

If the Specular field is 0.0, the simplification operation ignores the specular component when it calculates the error for collapsing the edges of a mesh. However, if the Specular field is 1.0, the simplification operation uses the specular component. If the Specular field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Tangent

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.Tangent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which tangent data is used in simplification operations.

Definition

Visual Basic .NET | Public Property Tangent As Single
C# | public float Tangent { get; set; }
Managed C++ public: __property float get_Tangent();
public: __property void set_Tangent(float);
JScript .NET public function get Tangent() : float
public function set Tangent(float);

Property Value

System.Single . A Single Leave Site value that indicates the degree to which tangent data is used in simplification operations.

This property is read/write.

Remarks

If the Tangent field is 0.0, the simplification operation ignores the tangent component when it calculates the error for collapsing the edges of a mesh. However, if the Tangent field is 1.0, the simplification operation uses the tangent component. If the Tangent field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.TextureCoordinate

Microsoft DirectX 9.0 SDK Update (October 2004)

AttributeWeights.TextureCoordinate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a numerical value that indicates the degree to which texture coordinate data is used in simplification operations.

Definition

Visual Basic .NET | Public Property TextureCoordinate As Single()
C# | public float[] TextureCoordinate { get; set; }
Managed C++ public: __property float get_TextureCoordinate();
public: __property void set_TextureCoordinate(float);
JScript .NET public function get TextureCoordinate() : float[]
public function set TextureCoordinate(float[]);

Property Value

System.Single[] .

This property is read/write.

Remarks

If the TextureCoordinate field is 0.0, the simplification operation ignores the texture coordinate component when it calculates the error for collapsing the edges of a mesh. However, if the TextureCoordinate field is 1.0, the simplification operation uses the texture coordinate component. If the TextureCoordinate field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


BandwidthTimings

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Provides throughput measurement comparisons for help in understanding the performance of an application.

Definition

Visual Basic .NET | Public Structure BandwidthTimings
C# | public struct BandwidthTimings
Managed C++ | public __value struct BandwidthTimings
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BandwidthTimings | Creates a new instance of the BandwidthTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
FillRateUtilizedPercent | Retrieves the pixel fill throughput percentage. This is the number of pixels that are filled compared to the theoretical pixel fill.
FrontEndUploadMemoryUtilizedPercent | Retrieves the bandwidth or maximum data transfer rate for uploading data from the host GPU to the CPU.
MaxBandwidthUtilized | Retrieves the bandwidth or maximum data transfer rate from the host CPU to the graphics processing unit (GPU). This is typically the bandwidth of the Peripheral Component Interconnect (PCI) or accelerated graphics port (AGP) bus which connects the CPU and the GPU.
TriangleSetupRateUtilizedPercent | Retrieves the triangle set-up throughput percentage. This is the number of triangles that are set-up for rasterization compared to the theoretical maximum triangle set-up rate.
VertexRateUtilizedPercent | Retrieves the vertex throughput percentage. This is the number of vertices processed compared to the theoretical maximum vertex processing rate. A high percentage is the target.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BandwidthTimings.BandwidthTimings()

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings.BandwidthTimings Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the BandwidthTimings structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public BandwidthTimings();
Managed C++ | public: BandwidthTimings();
JScript .NET | public function BandwidthTimings();


BandwidthTimings.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


BandwidthTimings.FillRateUtilizedPercent

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings.FillRateUtilizedPercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the pixel fill throughput percentage. This is the number of pixels that are filled compared to the theoretical pixel fill.

Definition

Visual Basic .NET | Public ReadOnly Property FillRateUtilizedPercent As Single
C# | public float FillRateUtilizedPercent { get; }
Managed C++ | public: __property float get_FillRateUtilizedPercent();
JScript .NET | public function get FillRateUtilizedPercent() : float

Property Value

System.Single . A Single Leave Site value that represents the pixel fill throughput percentage.

This property is read-only.


BandwidthTimings.FrontEndUploadMemoryUtilizedPercent

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings.FrontEndUploadMemoryUtilizedPercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the bandwidth or maximum data transfer rate for uploading data from the host graphics processing unit (GPU) to the CPU.

Definition

Visual Basic .NET | Public ReadOnly Property FrontEndUploadMemoryUtilizedPercent As Single
C# | public float FrontEndUploadMemoryUtilizedPercent { get; }
Managed C++ | public: __property float get_FrontEndUploadMemoryUtilizedPercent();
JScript .NET | public function get FrontEndUploadMemoryUtilizedPercent() : float

Property Value

System.Single . A Single Leave Site value that represents the bandwidth or maximum data transfer rate for uploading data from the host graphics processing unit (GPU) to the CPU.

This property is read-only.


BandwidthTimings.MaxBandwidthUtilized

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings.MaxBandwidthUtilized Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the bandwidth or maximum data transfer rate from the host CPU to the graphics processing unit (GPU). This is typically the bandwidth of the Peripheral Component Interconnect (PCI) or accelerated graphics port (AGP) bus which connects the CPU and the graphics processing unit (GPU).

Definition

Visual Basic .NET | Public ReadOnly Property MaxBandwidthUtilized As Single
C# | public float MaxBandwidthUtilized { get; }
Managed C++ | public: __property float get_MaxBandwidthUtilized();
JScript .NET | public function get MaxBandwidthUtilized() : float

Property Value

System.Single . A Single Leave Site value that represents the bandwidth or maximum data transfer rate from the host CPU to the graphics processing unit (GPU).

This property is read-only.


BandwidthTimings.TriangleSetupRateUtilizedPercent

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings.TriangleSetupRateUtilizedPercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the triangle set-up throughput percentage. This is the number of triangles that are set-up for rasterization compared to the theoretical maximum triangle set-up rate.

Definition

Visual Basic .NET | Public ReadOnly Property TriangleSetupRateUtilizedPercent As Single
C# | public float TriangleSetupRateUtilizedPercent { get; }
Managed C++ | public: __property float get_TriangleSetupRateUtilizedPercent();
JScript .NET | public function get TriangleSetupRateUtilizedPercent() : float

Property Value

System.Single . A Single Leave Site value that represents the triangle set-up throughput percentage.

This property is read-only.


BandwidthTimings.VertexRateUtilizedPercent

Microsoft DirectX 9.0 SDK Update (October 2004)

BandwidthTimings.VertexRateUtilizedPercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the vertex throughput percentage. This is the number of vertices processed compared to the theoretical maximum vertex processing rate. A high percentage is the target.

Definition

Visual Basic .NET | Public ReadOnly Property VertexRateUtilizedPercent As Single
C# | public float VertexRateUtilizedPercent { get; }
Managed C++ | public: __property float get_VertexRateUtilizedPercent();
JScript .NET | public function get VertexRateUtilizedPercent() : float

Property Value

System.Single . A Single Leave Site value that represents the vertex throughput percentage.

This property is read-only.


BehaviorFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains a set of properties that indicate the global behavior of a device.

Definition

Visual Basic .NET | Public Structure BehaviorFlags
C# | public struct BehaviorFlags
Managed C++ | public __value struct BehaviorFlags
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BehaviorFlags | Creates a new instance of the BehaviorFlags structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdapterGroupDevice | Retrieves a value that indicates whether the device should drive all of the heads that the master adapter owns.
DisableDriverManagement | Retrieves a value that indicates whether Direct3D, rather than the driver, manages resources.
FpuPreserve | Retrieves a value that indicates whether floating-point unit (FPU) exceptions or double-precision FPU exceptions are enabled in an application.
HardwareVertexProcessing | Retrieves a value that indicates whether hardware vertex processing is enabled.
MixedVertexProcessing | Retrieves a value that indicates whether mixed vertex processing (for both software and hardware) is enabled.
MultiThreaded | Retrieves a value that indicates whether Microsoft® Direct3D® is set to be multithread safe.
PureDevice | Retrieves a value that indicates whether Direct3D supports Get calls for anything that can be stored in a state block. This value also indicates whether Direct3D is withholding emulation services for vertex processing.
SoftwareVertexProcessing | Retrieves a value that specifies whether software vertex processing is being used.
Value | Retrieves or sets one or more CreateFlags values.

Remarks

The values in the BehaviorFlags structure mirror the creation options used to create the device.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BehaviorFlags.BehaviorFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.BehaviorFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the BehaviorFlags structure.

Overload List

public BehaviorFlags();
public BehaviorFlags(CreateFlags);
public BehaviorFlags(CreateFlags[]);


BehaviorFlags.BehaviorFlags(CreateFlags[])

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.BehaviorFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the BehaviorFlags structure.

Definition

Visual Basic .NET Public Sub New( _
ByVal newBehavior() As CreateFlags _
)
C# public BehaviorFlags(
CreateFlags[] newBehavior
);
Managed C++ public: BehaviorFlags(
CreateFlags newBehavior __gc[]
);
JScript .NET public function BehaviorFlags(
newBehavior : CreateFlags[]
);

Parameters

newBehavior Microsoft.DirectX.Direct3D.CreateFlags[]. Array of CreateFlags that indicate the initial values with which to set the BehaviorFlags properties.


BehaviorFlags.BehaviorFlags(CreateFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.BehaviorFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the BehaviorFlags structure.

Definition

Visual Basic .NET Public Sub New( _
ByVal initialBehavior As CreateFlags _
)
C# public BehaviorFlags(
CreateFlags initialBehavior
);
Managed C++ public: BehaviorFlags(
CreateFlags initialBehavior
);
JScript .NET public function BehaviorFlags(
initialBehavior : CreateFlags
);

Parameters

initialBehavior Microsoft.DirectX.Direct3D.CreateFlags. A combination of CreateFlags that indicate the initial values with which to set the BehaviorFlags properties.


BehaviorFlags.BehaviorFlags()

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.BehaviorFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the BehaviorFlags structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public BehaviorFlags();
Managed C++ | public: BehaviorFlags();
JScript .NET | public function BehaviorFlags();


BehaviorFlags.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


BehaviorFlags.AdapterGroupDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.AdapterGroupDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether the device should drive all of the heads that the master adapter owns.

Definition

Visual Basic .NET | Public ReadOnly Property AdapterGroupDevice As Boolean
C# | public bool AdapterGroupDevice { get; }
Managed C++ | public: __property bool get_AdapterGroupDevice();
JScript .NET | public function get AdapterGroupDevice() : boolean

Property Value

System.Boolean . Value that is true if the device drives all of the heads the master adapter owns, or false if it does not.

This property is read-only.

See Also

  • CreateFlags.AdapterGroupDevice


BehaviorFlags.DisableDriverManagement

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.DisableDriverManagement Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether Microsoft® Direct3D®, rather than the driver, manages resources.

Definition

Visual Basic .NET | Public ReadOnly Property DisableDriverManagement As Boolean
C# | public bool DisableDriverManagement { get; }
Managed C++ | public: __property bool get_DisableDriverManagement();
JScript .NET | public function get DisableDriverManagement() : boolean

Property Value

System.Boolean . Value that is true if Microsoft® Direct3D® manages resources, or false if it does not.

This property is read-only.

See Also

  • CreateFlags.DisableDriverManagement


BehaviorFlags.FpuPreserve

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.FpuPreserve Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether floating-point unit (FPU) exceptions or double-precision FPU exceptions are enabled in an application.

Definition

Visual Basic .NET | Public ReadOnly Property FpuPreserve As Boolean
C# | public bool FpuPreserve { get; }
Managed C++ | public: __property bool get_FpuPreserve();
JScript .NET | public function get FpuPreserve() : boolean

Property Value

System.Boolean . Value that is true if FPU exceptions or double-precision FPU exceptions are enabled, or false if they are not.

This property is read-only.

Remarks

If this value is true, Microsoft® Direct3D® performance can degrade.

See Also

  • CreateFlags.FpuPreserve


BehaviorFlags.HardwareVertexProcessing

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.HardwareVertexProcessing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether hardware vertex processing is enabled.

Definition

Visual Basic .NET | Public ReadOnly Property HardwareVertexProcessing As Boolean
C# | public bool HardwareVertexProcessing { get; }
Managed C++ | public: __property bool get_HardwareVertexProcessing();
JScript .NET | public function get HardwareVertexProcessing() : boolean

Property Value

System.Boolean . Value that is true if hardware vertex processing is enabled, or false if it is not.

This property is read-only.

See Also

  • CreateFlags.HardwareVertexProcessing


BehaviorFlags.MixedVertexProcessing

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.MixedVertexProcessing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether mixed vertex processing (for both software and hardware) is enabled.

Definition

Visual Basic .NET | Public ReadOnly Property MixedVertexProcessing As Boolean
C# | public bool MixedVertexProcessing { get; }
Managed C++ | public: __property bool get_MixedVertexProcessing();
JScript .NET | public function get MixedVertexProcessing() : boolean

Property Value

System.Boolean . Value that is true if mixed vertex processing is enabled, or false if it is not.

This property is read-only.

See Also

  • CreateFlags.MixedVertexProcessing


BehaviorFlags.MultiThreaded

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.MultiThreaded Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether Microsoft® Direct3D® is set to be multithread safe.

Definition

Visual Basic .NET | Public ReadOnly Property MultiThreaded As Boolean
C# | public bool MultiThreaded { get; }
Managed C++ | public: __property bool get_MultiThreaded();
JScript .NET | public function get MultiThreaded() : boolean

Property Value

System.Boolean . Value that is true if Microsoft® Direct3D® is set to be multithread safe, or false if it is not.

This property is read-only.

Remarks

An application with Microsoft® Direct3D® set to be safe for multithreading might experience degraded performance.

See Also

  • CreateFlags.MultiThreaded


BehaviorFlags.PureDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.PureDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether Microsoft® Direct3D® supports Get calls for anything that can be stored in a state block. This value also indicates whether Microsoft® Direct3D® is withholding emulation services for vertex processing.

Definition

Visual Basic .NET | Public ReadOnly Property PureDevice As Boolean
C# | public bool PureDevice { get; }
Managed C++ | public: __property bool get_PureDevice();
JScript .NET | public function get PureDevice() : boolean

Property Value

System.Boolean . Value that is true if Microsoft® Direct3D® does not support Get calls for anything that can be stored in a state block. A true value also indicates that Microsoft® Direct3D® is withholding emulation services for vertex processing. If Get calls are supported and Microsoft® Direct3D® is not withholding emulation services, the value is false.

This property is read-only.

Remarks

If the device is withholding emulation services for vertex processing, it does not support vertex processing, and the application can use only post-transformed vertices.

See Also

  • CreateFlags.PureDevice
  • StateBlock


BehaviorFlags.SoftwareVertexProcessing

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.SoftwareVertexProcessing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that specifies whether software vertex processing is being used.

Definition

Visual Basic .NET | Public ReadOnly Property SoftwareVertexProcessing As Boolean
C# | public bool SoftwareVertexProcessing { get; }
Managed C++ | public: __property bool get_SoftwareVertexProcessing();
JScript .NET | public function get SoftwareVertexProcessing() : boolean

Property Value

System.Boolean . Value that is true if software vertex processing is in use, or false if it is not.

This property is read-only.

See Also

  • CreateFlags.SoftwareVertexProcessing


BehaviorFlags.Value

Microsoft DirectX 9.0 SDK Update (October 2004)

BehaviorFlags.Value Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets one or more CreateFlags values.

Definition

Visual Basic .NET | Public Property Value As CreateFlags
C# | public CreateFlags Value { get; set; }
Managed C++ public: __property CreateFlags get_Value();
public: __property void set_Value(CreateFlags);
JScript .NET public function get Value() : CreateFlags
public function set Value(CreateFlags);

Property Value

Microsoft.DirectX.Direct3D.CreateFlags . One or more CreateFlags values that reflect the values of the other BehaviorFlags properties.

This property is read/write.

See Also

  • CreateFlags


BlendCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Indicates the supported capabilities.

Definition

Visual Basic .NET | Public Structure BlendCaps
C# | public struct BlendCaps
Managed C++ | public __value struct BlendCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsBlendFactor | Indicates that the driver supports the BlendFactor and InvBlendFactor constants.
SupportsBothInverseSourceAlpha | Indicates that the driver supports a in which the source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), the destination blend factor is (As, As, As, As), and the destination blend selection is overridden.
SupportsBothSourceAlpha | Indicates that the driver supports the SourceAlpha and InvSourceAlpha blend modes. The SupportsBothSourceAlpha blend mode is obsolete. To achieve the same effect, set the source and destination blend factors to Blend.SourceAlpha and Blend.InvSourceAlpha in separate calls.
SupportsDestinationAlpha | Indicates that the driver supports the DestinationAlpha blend mode.
SupportsDestinationColor | Indicates that the driver supports the DestinationColor blend mode.
SupportsInverseDestinationAlpha | Indicates that the driver supports the InvDestinationAlpha blend mode.
SupportsInverseDestinationColor | Indicates that the driver supports the InvDestinationColor blend mode.
SupportsInverseSourceAlpha | Indicates that the driver supports the InvSourceAlpha blend mode.
SupportsInverseSourceColor | Indicates that the driver supports the InvSourceColor blend mode.
SupportsOne | Indicates that the driver supports the One blend mode.
SupportsSourceAlpha | Indicates that the driver supports the SourceAlpha blend mode.
SupportsSourceAlphaSat | Indicates that the driver supports the SourceAlphaSat blend mode.
SupportsSourceColor | Indicates that the driver supports the SourceColor blend mode.
SupportsZero | Indicates that the driver supports the Zero blend mode.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BlendCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


BlendCaps.SupportsBlendFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsBlendFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the BlendFactor and InvBlendFactor constants.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlendFactor As Boolean
C# | public bool SupportsBlendFactor { get; }
Managed C++ | public: __property bool get_SupportsBlendFactor();
JScript .NET | public function get SupportsBlendFactor() : boolean

Property Value

System.Boolean . Value that is true if the driver supports BlendFactor and InvBlendFactor.

This property is read-only.


BlendCaps.SupportsBothInverseSourceAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsBothInverseSourceAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports a in which the source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), the destination blend factor is (As, As, As, As), and the destination blend selection is overridden.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBothInverseSourceAlpha As Boolean
C# | public bool SupportsBothInverseSourceAlpha { get; }
Managed C++ | public: __property bool get_SupportsBothInverseSourceAlpha();
JScript .NET | public function get SupportsBothInverseSourceAlpha() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the SupportsBothInverseSourceAlpha blend mode, or false if it does not.

This property is read-only.

See Also

  • Blend


BlendCaps.SupportsBothSourceAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsBothSourceAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the SourceAlpha and InvSourceAlpha blend modes. The SupportsBothSourceAlpha blend mode is obsolete. To achieve the same effect, set the source and destination blend factors to Blend.SourceAlpha and Blend.InvSourceAlpha in separate calls.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBothSourceAlpha As Boolean
C# | public bool SupportsBothSourceAlpha { get; }
Managed C++ | public: __property bool get_SupportsBothSourceAlpha();
JScript .NET | public function get SupportsBothSourceAlpha() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the SourceAlpha and InvSourceAlpha blend modes, or false if it does not.

This property is read-only.


BlendCaps.SupportsDestinationAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsDestinationAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the DestinationAlpha blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDestinationAlpha As Boolean
C# | public bool SupportsDestinationAlpha { get; }
Managed C++ | public: __property bool get_SupportsDestinationAlpha();
JScript .NET | public function get SupportsDestinationAlpha() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the DestinationAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The DestinationAlpha blend factor is (Ad, Ad, Ad, Ad), where Ad is the destination alpha value.


BlendCaps.SupportsDestinationColor

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsDestinationColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the DestinationColor blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDestinationColor As Boolean
C# | public bool SupportsDestinationColor { get; }
Managed C++ | public: __property bool get_SupportsDestinationColor();
JScript .NET | public function get SupportsDestinationColor() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the DestinationColor blend mode, or false if it does not.

This property is read-only.

Remarks

The DestinationColor blend factor is (Rd, Gd, Bd, Ad), where R, G, B, and A respectively stand for red, green, blue, and alpha destination values.


BlendCaps.SupportsInverseDestinationAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsInverseDestinationAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the InvDestinationAlpha blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsInverseDestinationAlpha As Boolean
C# | public bool SupportsInverseDestinationAlpha { get; }
Managed C++ | public: __property bool get_SupportsInverseDestinationAlpha();
JScript .NET | public function get SupportsInverseDestinationAlpha() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the InvDestinationAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The InvDestinationAlpha blend factor is (1 - Ad, 1 - Ad, 1 - Ad, 1 - Ad), where Ad is the alpha destination value.


BlendCaps.SupportsInverseDestinationColor

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsInverseDestinationColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the InvDestinationColor blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsInverseDestinationColor As Boolean
C# | public bool SupportsInverseDestinationColor { get; }
Managed C++ | public: __property bool get_SupportsInverseDestinationColor();
JScript .NET | public function get SupportsInverseDestinationColor() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the InvDestinationColor blend mode, or false if it does not.

This property is read-only.

Remarks

The InvDestinationColor blend factor is (1 - Rd, 1 - Gd, 1 - Bd, 1 - Ad), where Rd, Gd, Bd, and Ad respectively stand for the red, green, blue, and alpha destination values.


BlendCaps.SupportsInverseSourceAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsInverseSourceAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the InvSourceAlpha blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsInverseSourceAlpha As Boolean
C# | public bool SupportsInverseSourceAlpha { get; }
Managed C++ | public: __property bool get_SupportsInverseSourceAlpha();
JScript .NET | public function get SupportsInverseSourceAlpha() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the InvSourceAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The InvSourceAlpha blend factor is ( 1 - As, 1 - As, 1 - As, 1 - As), where As is the alpha destination value.


BlendCaps.SupportsInverseSourceColor

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsInverseSourceColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the InvSourceColor blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsInverseSourceColor As Boolean
C# | public bool SupportsInverseSourceColor { get; }
Managed C++ | public: __property bool get_SupportsInverseSourceColor();
JScript .NET | public function get SupportsInverseSourceColor() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the InvSourceColor blend mode, or false if it does not.

This property is read-only.

Remarks

The InvSourceColor blend factor is (1 - Rs, 1 - Gs, 1 - Bs, 1 - As) where R, G, B, and A respectively stand for the red, green, blue, and alpha destination values.


BlendCaps.SupportsOne

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsOne Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the One blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsOne As Boolean
C# | public bool SupportsOne { get; }
Managed C++ | public: __property bool get_SupportsOne();
JScript .NET | public function get SupportsOne() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the One blend mode, or false if it does not.

This property is read-only.

Remarks

The InvSourceColor blend factor is (1, 1, 1, 1).


BlendCaps.SupportsSourceAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsSourceAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the SourceAlpha blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSourceAlpha As Boolean
C# | public bool SupportsSourceAlpha { get; }
Managed C++ | public: __property bool get_SupportsSourceAlpha();
JScript .NET | public function get SupportsSourceAlpha() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the SourceAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The SourceAlpha blend factor is (As, As, As, As), where As is the alpha source value.


BlendCaps.SupportsSourceAlphaSat

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsSourceAlphaSat Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the SourceAlphaSat blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSourceAlphaSat As Boolean
C# | public bool SupportsSourceAlphaSat { get; }
Managed C++ | public: __property bool get_SupportsSourceAlphaSat();
JScript .NET | public function get SupportsSourceAlphaSat() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the SourceAlphaSat blend mode, or false if it does not.

This property is read-only.

Remarks

The SourceAlphaSat blend factor is (f, f, f, 1), where f = min(A, 1 - Ad).


BlendCaps.SupportsSourceColor

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsSourceColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the SourceColor blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSourceColor As Boolean
C# | public bool SupportsSourceColor { get; }
Managed C++ | public: __property bool get_SupportsSourceColor();
JScript .NET | public function get SupportsSourceColor() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the SourceColor blend mode, or false if it does not.

This property is read-only.

Remarks

The SourceColor blend factor is (Rs, Gs, Bs, As), where R, G, B, and A respectively stand for the red, green, blue, and alpha source values.


BlendCaps.SupportsZero

Microsoft DirectX 9.0 SDK Update (October 2004)

BlendCaps.SupportsZero Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver supports the Zero blend mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsZero As Boolean
C# | public bool SupportsZero { get; }
Managed C++ | public: __property bool get_SupportsZero();
JScript .NET | public function get SupportsZero() : boolean

Property Value

System.Boolean . Value that is true if the driver supports the Zero blend mode, or false if it does not.

This property is read-only.

Remarks

The Zero blend factor is (0, 0, 0, 0).


BoneCombination

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a subset of the mesh that has the same attribute and bone combination.

Definition

Visual Basic .NET | Public Structure BoneCombination
C# | public struct BoneCombination
Managed C++ | public __value struct BoneCombination
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BoneCombination | Creates a new instance of the BoneCombination structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AttributeId | Retrieves or sets the attribute table identifier.
BoneId | Retrieves or sets an array of values that identify each of the bones that can be drawn in a single drawing call.
FaceCount | Retrieves or sets the face count for the bone combination.
FaceStart | Retrieves or sets the starting face for the bone combination.
VertexCount | Retrieves or sets the vertex count of the bone combination.
VertexStart | Retrieves or sets the starting vertex in the bone combination.

Remarks

The subset of the mesh that BoneCombination describes can be rendered in a single drawing call.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BoneCombination.BoneCombination()

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination.BoneCombination Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the BoneCombination structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public BoneCombination();
Managed C++ | public: BoneCombination();
JScript .NET | public function BoneCombination();


BoneCombination.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


BoneCombination.AttributeId

BoneCombination.AttributeId Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the attribute table identifier.

Definition

Visual Basic .NET | Public Property AttributeId As Integer
C# | public int AttributeId { get; set; }
Managed C++ public: __property int get_AttributeId();
public: __property void set_AttributeId(int);
JScript .NET public function get AttributeId() : int
public function set AttributeId(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the attribute table identifier for the BoneCombination.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


BoneCombination.BoneId

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination.BoneId Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets an array of values that identify each of the bones that can be drawn in a single drawing call.

Definition

Visual Basic .NET | Public Property BoneId As Integer()
C# | public int[] BoneId { get; set; }
Managed C++ public: __property int get_BoneId();
public: __property void set_BoneId(int);
JScript .NET public function get BoneId() : int[]
public function set BoneId(int[]);

Property Value

System.Int32[] . Array of Int32 Leave Site values that identify the bones that can be drawn in a single drawing call.

This property is read/write.

Remarks

The array can be of variable length to accommodate variable-length bone combinations of SkinInformation.ConvertToIndexedBlendedMesh. The size of the array varies based on the type of mesh generated. A non-indexed mesh array size is equal to the number of weights per vertex. An indexed mesh array size is equal to the number of bone matrix palette entries.


BoneCombination.FaceCount

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination.FaceCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the face count for the bone combination.

Definition

Visual Basic .NET | Public Property FaceCount As Integer
C# | public int FaceCount { get; set; }
Managed C++ public: __property int get_FaceCount();
public: __property void set_FaceCount(int);
JScript .NET public function get FaceCount() : int
public function set FaceCount(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the face count for the bone combination.

This property is read/write.


BoneCombination.FaceStart

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination.FaceStart Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the starting face for the bone combination.

Definition

Visual Basic .NET | Public Property FaceStart As Integer
C# | public int FaceStart { get; set; }
Managed C++ public: __property int get_FaceStart();
public: __property void set_FaceStart(int);
JScript .NET public function get FaceStart() : int
public function set FaceStart(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the starting face.

This property is read/write.


BoneCombination.VertexCount

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination.VertexCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex count of the bone combination.

Definition

Visual Basic .NET | Public Property VertexCount As Integer
C# | public int VertexCount { get; set; }
Managed C++ public: __property int get_VertexCount();
public: __property void set_VertexCount(int);
JScript .NET public function get VertexCount() : int
public function set VertexCount(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of vertices in the bone combination.

This property is read/write.


BoneCombination.VertexStart

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneCombination.VertexStart Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the starting vertex in the bone combination.

Definition

Visual Basic .NET | Public Property VertexStart As Integer
C# | public int VertexStart { get; set; }
Managed C++ public: __property int get_VertexStart();
public: __property void set_VertexStart(int);
JScript .NET public function get VertexStart() : int
public function set VertexStart(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the starting vertex.

This property is read/write.


BoneInfluences

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneInfluences Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the vertices and weights that a bone influences.

Definition

Visual Basic .NET | Public Structure BoneInfluences
C# | public struct BoneInfluences
Managed C++ | public __value struct BoneInfluences
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BoneInfluences | Creates a new instance of the BoneInfluences structure.
GetVertices | Retrieves or sets an array of vertices that are influenced by the bone associated with the current BoneInfluences structure.
GetWeights | Retrieves or sets an array of weights associated with the current BoneInfluences structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BoneInfluences.BoneInfluences()

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneInfluences.BoneInfluences Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the BoneInfluences structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public BoneInfluences();
Managed C++ | public: BoneInfluences();
JScript .NET | public function BoneInfluences();


BoneInfluences.GetVertices()

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneInfluences.GetVertices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets an array of vertices that are influenced by the bone associated with the current BoneInfluences structure.

Definition

Visual Basic .NET | Public Function GetVertices() As Integer()
C# | public int[] GetVertices();
Managed C++ | public: int GetVertices() __gc[];
JScript .NET | public function GetVertices() : int[];

Return Value

System.Int32[]. Array of Int32 Leave Site values indicating the vertices that are influenced by the bone associated with the current BoneInfluences structure.


BoneInfluences.GetWeights()

Microsoft DirectX 9.0 SDK Update (October 2004)

BoneInfluences.GetWeights Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets an array of weights associated with the current BoneInfluences structure.

Definition

Visual Basic .NET | Public Function GetWeights() As Single()
C# | public float[] GetWeights();
Managed C++ | public: float GetWeights() __gc[];
JScript .NET | public function GetWeights() : float[];

Return Value

System.Single[]. Array of Single Leave Site values indicating the weight values that the bone exerts on the vertices associated with the current BoneInfluences structure.


Box

Microsoft DirectX 9.0 SDK Update (October 2004)

Box Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Defines a volume.

Definition

Visual Basic .NET | Public Structure Box
C# | public struct Box
Managed C++ | public __value struct Box
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Box | Creates a new instance of the Box structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Back | Retrieves or sets the position of the back of a box on the z-axis.
Bottom | Retrieves or sets the position of the bottom of a box on the y-axis.
Front | Retrieves or sets the position of the front of a box on the z-axis.
Left | Retrieves or sets the position of the left side of a box on the x-axis.
Right | Retrieves or sets the position of the right side of a box on the x-axis.
Top | Retrieves or sets the position of the top of a box on the y-axis.

Remarks

The Box structure includes the left, top, and front edges, but not the right, bottom, or back edges. For example, a box that is 100 units wide and begins at 0 (thus, including the points up to and including 99) would be expressed with a value of 0 for the Left member and a value of 100 for the Right member. Note that a value of 99 is not used for the Right member.

The restrictions on side ordering for Box are left to right, top to bottom, and front to back.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Box.Box()

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.Box Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Box structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Box();
Managed C++ | public: Box();
JScript .NET | public function Box();


Box.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Box.Back

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.Back Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the back of a box on the z-axis.

Definition

Visual Basic .NET | Public Property Back As Integer
C# | public int Back { get; set; }
Managed C++ public: __property int get_Back();
public: __property void set_Back(int);
JScript .NET public function get Back() : int
public function set Back(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the position of the back of the box.

This property is read/write.

Remarks

This value indicates the distance of the back from the front of the box on the z-axis.


Box.Bottom

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.Bottom Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the bottom of a box on the y-axis.

Definition

Visual Basic .NET | Public Property Bottom As Integer
C# | public int Bottom { get; set; }
Managed C++ public: __property int get_Bottom();
public: __property void set_Bottom(int);
JScript .NET public function get Bottom() : int
public function set Bottom(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the position of the bottom of the box.

This property is read/write.

Remarks

This value indicates the distance of the bottom from the top of the box on the y-axis.


Box.Front

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.Front Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the front of a box on the z-axis.

Definition

Visual Basic .NET | Public Property Front As Integer
C# | public int Front { get; set; }
Managed C++ public: __property int get_Front();
public: __property void set_Front(int);
JScript .NET public function get Front() : int
public function set Front(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the position of the front of the box on the z-axis.

This property is read/write.


Box.Left

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.Left Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the left side of a box on the x-axis.

Definition

Visual Basic .NET | Public Property Left As Integer
C# | public int Left { get; set; }
Managed C++ public: __property int get_Left();
public: __property void set_Left(int);
JScript .NET public function get Left() : int
public function set Left(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the position of the left side of the box.

This property is read/write.


Box.Right

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.Right Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the right side of a box on the x-axis.

Definition

Visual Basic .NET | Public Property Right As Integer
C# | public int Right { get; set; }
Managed C++ public: __property int get_Right();
public: __property void set_Right(int);
JScript .NET public function get Right() : int
public function set Right(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the right side of the box on the x-axis.

This property is read/write.

Remarks

This value indicates the distance of the right side from the left side of the box on the x-axis.


Box.Top

Microsoft DirectX 9.0 SDK Update (October 2004)

Box.Top Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the top of a box on the y-axis.

Definition

Visual Basic .NET | Public Property Top As Integer
C# | public int Top { get; set; }
Managed C++ public: __property int get_Top();
public: __property void set_Top(int);
JScript .NET public function get Top() : int
public function set Top(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the position of the top of the box.

This property is read/write.


CacheUtilization

Microsoft DirectX 9.0 SDK Update (October 2004)

CacheUtilization Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Measures the cache hit rate performance for textures and indexed vertices.

Definition

Visual Basic .NET | Public Structure CacheUtilization
C# | public struct CacheUtilization
Managed C++ | public __value struct CacheUtilization
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CacheUtilization | Creates a new instance of the CacheUtilization structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
PostTransformVertexCacheHitRate | Retrieves the hit rate for finding transformed vertices in the vertex cache.
TextureCacheHitRate | Retrieves the hit rate for finding a texture in the texture cache.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CacheUtilization.CacheUtilization()

Microsoft DirectX 9.0 SDK Update (October 2004)

CacheUtilization.CacheUtilization Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the CacheUtilization structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public CacheUtilization();
Managed C++ | public: CacheUtilization();
JScript .NET | public function CacheUtilization();


CacheUtilization.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CacheUtilization.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CacheUtilization.PostTransformVertexCacheHitRate

Microsoft DirectX 9.0 SDK Update (October 2004)

CacheUtilization.PostTransformVertexCacheHitRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the hit rate for finding transformed vertices in the vertex cache.

Definition

Visual Basic .NET | Public ReadOnly Property PostTransformVertexCacheHitRate As Single
C# | public float PostTransformVertexCacheHitRate { get; }
Managed C++ | public: __property float get_PostTransformVertexCacheHitRate();
JScript .NET | public function get PostTransformVertexCacheHitRate() : float

Property Value

System.Single . A Single Leave Site value that represents the hit rate for finding transformed vertices in the vertex cache.

This property is read-only.

Remarks

The graphics processing unit (GPU) is designed to transform indexed vertices and store them in a vertex cache. If you are using meshes, Mesh.Optimize may result in better vertex cache utilization.


CacheUtilization.TextureCacheHitRate

Microsoft DirectX 9.0 SDK Update (October 2004)

CacheUtilization.TextureCacheHitRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the hit rate for finding a texture in the texture cache.

Definition

Visual Basic .NET | Public ReadOnly Property TextureCacheHitRate As Single
C# | public float TextureCacheHitRate { get; }
Managed C++ | public: __property float get_TextureCacheHitRate();
JScript .NET | public function get TextureCacheHitRate() : float

Property Value

System.Single . A Single Leave Site value that represents the hit rate for finding a texture in the texture cache.

This property is read-only.

Remarks

This assumes there is a texture cache. Increasing the level of detail (LOD) bias to use the most detailed texture, using many large textures, or producing a near random texture access pattern on large textures with custom shader code can dramatically affect the texture cache hit rate.


CallbackData

Microsoft DirectX 9.0 SDK Update (October 2004)

CallbackData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about animation callbacks.

Definition

Visual Basic .NET | Public Structure CallbackData
C# | public struct CallbackData
Managed C++ | public __value struct CallbackData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CallbackData | Initializes a new instance of the CallbackData class.

Properties

Property | Description
CallbackPosition | Retrieves or sets a value that indicates the position of the callback.
Data | Points to data for the callback.

Remarks

This structure is typically found in the KeyCallback.CallBackData member. The KeyCallback is used to pass information to a HandleAnimationCallback delegate.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CallbackData.CallbackData()

Microsoft DirectX 9.0 SDK Update (October 2004)

CallbackData.CallbackData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CallbackData class.

Definition

Visual Basic .NET | Public Sub New()
C# | public CallbackData();
Managed C++ | public: CallbackData();
JScript .NET | public function CallbackData();


CallbackData.CallbackPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

CallbackData.CallbackPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that indicates the position of the callback.

Definition

Visual Basic .NET | Public Property CallbackPosition As Double
C# | public double CallbackPosition { get; set; }
Managed C++ public: __property double get_CallbackPosition();
public: __property void set_CallbackPosition(double);
JScript .NET public function get CallbackPosition() : double
public function set CallbackPosition(double);

Property Value

System.Double . A Double Leave Site value that indicates the position of the callback.

This property is read/write.


CallbackData.Data

Microsoft DirectX 9.0 SDK Update (October 2004)

CallbackData.Data Property

Language:
Note: This documentation is preliminary and is subject to change.

Points to data for the callback.

Definition

Visual Basic .NET | Public Property Data As IntPtr
C# | public IntPtr Data { get; set; }
Managed C++ public: __property IntPtr get_Data();
public: __property void set_Data(IntPtr);
JScript .NET public function get Data() : IntPtr
public function set Data(IntPtr);

Property Value

System.IntPtr . An IntPtr Leave Site instance that points to data for the callback.

This property is read/write.


Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Represents the capabilities of the hardware exposed through the Microsoft® Direct3D® object.

Definition

Visual Basic .NET | Public Structure Caps
C# | public struct Caps
Managed C++ | public __value struct Caps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Caps | Creates a new instance of the Caps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdapterOrdinal | Retrieves a number that represents the ordinal of the adapter on which the Device was created.
AdapterOrdinalInGroup | Retrieves a number that indicates the order in which heads are referenced by the application programming object.
AlphaCompareCaps | Retrieves an object that contains all alpha-test comparison capabilities.
CubeTextureFilterCaps | Retrieves texture-filtering capabilities for a CubeTexture object.
CursorCaps | Retrieves an object that indicates the available hardware support for cursors.
DeclTypes | Retrieves an object that describes the vertex data types a device supports.
DestinationBlendCaps | Retrieves an object that indicates a device's destination blending capabilities.
DeviceCaps | Retrieves an object that identifies a device's capabilities.
DeviceType | Retrieves an object that identifies the type of resources used for processing vertices.
DriverCaps | Retrieves an object that identifies driver-specific capabilities.
ExtentsAdjust | Retrieves a value that indicates the number of pixels to adjust the extents rectangle outward to accommodate antialiasing kernels.
GuardBandBottom | Retrieves a value that indicates the screen-space coordinate of the bottom guard band clipping region.
GuardBandLeft | Retrieves a value that indicates the screen-space coordinate of the left guard band clipping region.
GuardBandRight | Retrieves a value that indicates the screen-space coordinate of the right guard band clipping region.
GuardBandTop | Retrieves a value that indicates the screen-space coordinate of the top guard band clipping region.
LineCaps | Retrieves an object that defines the capabilities for line-drawing primitives.
MasterAdapterOrdinal | Retrieves a value that indicates which device is the master for the current subordinate.
MaxActiveLights | Retrieves the maximum number of lights that can be active simultaneously.
MaxAnisotropy | Retrieves a value that indicates the maximum valid value for anisotropic filtering.
MaxNPatchTessellationLevel | Retrieves a value that indicates the maximum number of N-patch subdivision levels.
MaxPixelShader30InstructionSlots | Retrieves a value that indicates the maximum number of vertex shader instruction slots supported.
MaxPointSize | Retrieves the maximum size of a point primitive.
MaxPrimitiveCount | Retrieves the maximum number of primitives for each Device.DrawPrimitives call.
MaxSimultaneousTextures | Retrieves the maximum number of textures that can simultaneously be bound to the texture-blending stages.
MaxStreams | Indicates the maximum number of concurrent data streams for Device.SetStreamSource.
MaxStreamStride | Retrieves the maximum stride for Device.SetStreamSource.
MaxTextureAspectRatio | Retrieves the maximum texture aspect ratio supported by the hardware.
MaxTextureBlendStages | Retrieves the maximum number of texture-blending stages supported.
MaxTextureHeight | Retrieves the maximum texture height for the current device.
MaxTextureRepeat | Retrieves the maximum range of the integer bits for post-normalized texture coordinates.
MaxTextureWidth | Retrieves the maximum texture width for the current device.
MaxUserClipPlanes | Retrieves the maximum number of user-defined clipping planes supported.
MaxVertexBlendMatrices | Retrieves the maximum number of matrices that the current device can apply when performing multimatrix vertex blending.
MaxVertexBlendMatrixIndex | Retrieves the maximum matrix index that can be indexed into using pre-vertex indices.
MaxVertexIndex | Retrieves the maximum size of indices supported for hardware vertex processing.
MaxVertexShader30InstructionSlots | Retrieves the maximum number of vertex shader instruction slots supported.
MaxVertexShaderConst | Retrieves the number of vertex shader registers that are reserved for constants.
MaxVertexW | Retrieves the maximum w-based depth value that a device supports.
MaxVolumeExtent | Retrieves the maximum value for any of the three dimensions (width, height, and depth) of a volume texture.
NumberOfAdaptersInGroup | Retrieves the number of adapters in the current adapter group.
NumberSimultaneousRts | Retrieves the number of simultaneous render targets.
PixelShader1xMaxValue | Retrieves the maximum value of a pixel shader arithmetic component.
PixelShaderCaps | Retrieves a structure that contains the supported pixel shader capabilities.
PixelShaderVersion | Retrieves an object that reports the main and subordinate pixel shader versions.
PresentationIntervals | Retrieves a set of values that represent the available presentation swap intervals.
PrimitiveMiscCaps | Retrieves miscellaneous driver primitive capabilities.
RasterCaps | Retrieves information about raster drawing capabilities.
ShadeCaps | Retrieves shading operation capabilities.
SourceBlendCaps | Retrieves the source-blending capabilities.
StencilCaps | Retrieves an object that indicates the supported stencil buffer operations.
StretchRectangleFilterCaps | Retrieves a structure that describes the operations supported by StretchRectangle.
TextureAddressCaps | Retrieves a structure that contains texture-addressing capabilities for Texture objects.
TextureCaps | Retrieves a structure that contains miscellaneous texture-mapping capabilities.
TextureFilterCaps | Retrieves a structure that contains texture-filtering capabilities for Texture objects.
TextureOperationCaps | Retrieves a structure that describes supported texture operations.
VertexFormatCaps | Retrieves a structure that describes supported vertex format capabilities.
VertexProcessingCaps | Retrieves a structure that contains supported vertex processing capabilities.
VertexShaderCaps | Retrieves a structure that contains supported vertex shader capabilities.
VertexShaderVersion | Retrieves a structure that indicates the main and subordinate vertex shader versions supported by a device.
VertexTextureFilterCaps | Retrieves a structure that indicates which types of vertex shader texture filters are supported.
VolumeTextureAddressCaps | Retrieves a structure that indicates the supported texture-addressing capabilities for VolumeTexture objects.
VolumeTextureFilterCaps | Retrieves a structure that indicates the texture-filtering capabilities of VolumeTexture objects.
ZCompareCaps | Retrieves a structure that contains the supported z-buffer comparison capabilities.

Remarks

The MaxTextureBlendStages and MaxSimultaneousTextures members might seem similar, but they contain different information. The MaxTextureBlendStages member contains the total number of texture-blending stages supported by the current device, while the MaxSimultaneousTextures member describes how many of those stages can have textures bound to them by using the Device.SetTexture method.

Performance problems can occur if a texture is used and then modified during a scene. Ensure that no texture used in the current Device.BeginScene ... Device.EndScene block is evicted unless absolutely necessary. In the case of extremely high texture usage within a scene, the results are undefined. This occurs when a texture used in the scene is modified and no spare texture memory is available. For such systems, the contents of the z-buffer become invalid at Device.EndScene. Applications should not call Device.UpdateSurface to or from the back buffer on this type of hardware inside a BeginScene ... EndScene pair. In addition, applications should not try to access the z-buffer if the Caps.RasterCaps.SupportsZBufferLessHsr capability flag is set to true. Finally, applications should not lock the back buffer or the z-buffer inside a BeginScene ... EndScene pair.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • DeviceCaps


Caps.Caps()

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Caps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the Caps structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Caps();
Managed C++ | public: Caps();
JScript .NET | public function Caps();


Caps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Caps.AdapterOrdinal

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AdapterOrdinal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a number that represents the ordinal of the adapter on which the Device was created.

Definition

Visual Basic .NET | Public ReadOnly Property AdapterOrdinal As Integer
C# | public int AdapterOrdinal { get; }
Managed C++ | public: __property int get_AdapterOrdinal();
JScript .NET | public function get AdapterOrdinal() : int

Property Value

System.Int32 . An Int32 Leave Site value that represents the ordinal of the adapter on which the Device was created.

This property is read-only.

Remarks

This ordinal is valid only for passing to methods of the Manager object.


Caps.AdapterOrdinalInGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AdapterOrdinalInGroup Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a number that indicates the order in which heads are referenced by the application programming object.

Definition

Visual Basic .NET | Public ReadOnly Property AdapterOrdinalInGroup As Integer
C# | public int AdapterOrdinalInGroup { get; }
Managed C++ | public: __property int get_AdapterOrdinalInGroup();
JScript .NET | public function get AdapterOrdinalInGroup() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the order in which heads are referenced by the application programming object.

This property is read-only.

Remarks

The master adapter always sets AdapterOrdinalInGroup to 0. These values do not correspond to the adapter ordinals passed to the Manager. They apply only to heads within a group.


Caps.AlphaCompareCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlphaCompareCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that contains all alpha-test comparison capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property AlphaCompareCaps As ComparisonCaps
C# | public ComparisonCaps AlphaCompareCaps { get; }
Managed C++ | public: __property ComparisonCaps get_AlphaCompareCaps();
JScript .NET | public function get AlphaCompareCaps() : ComparisonCaps

Property Value

Microsoft.DirectX.Direct3D.ComparisonCaps . A ComparisonCaps object that contains the alpha-test comparison capabilities.

This property is read-only.

Remarks

This member can include the same capability flags defined for the Caps member. If this member contains a comparison Caps object with only the ComparisonCaps.SupportsAlways member or the ComparisonCaps.SupportsNever member set to true, the driver does not support alpha tests. Otherwise, the Caps members identify the individual comparisons that are supported for alpha testing.


Caps.CubeTextureFilterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CubeTextureFilterCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves texture-filtering capabilities for a CubeTexture object.

Definition

Visual Basic .NET | Public ReadOnly Property CubeTextureFilterCaps As FilterCaps
C# | public FilterCaps CubeTextureFilterCaps { get; }
Managed C++ | public: __property FilterCaps get_CubeTextureFilterCaps();
JScript .NET | public function get CubeTextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps . A FilterCaps structure that contains supported cube texture filtering capabilities.

This property is read-only.

Remarks

Per-stage filtering capabilities reflect which filtering modes are supported for texture stages during performance of multiple-texture blending with the Device object. This member can be any combination of the per-stage texture-filtering flags defined for the Caps.FilterCaps member.


Caps.CursorCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CursorCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that indicates the available hardware support for cursors.

Definition

Visual Basic .NET | Public ReadOnly Property CursorCaps As CursorCaps
C# | public CursorCaps CursorCaps { get; }
Managed C++ | public: __property CursorCaps get_CursorCaps();
JScript .NET | public function get CursorCaps() : CursorCaps

Property Value

Microsoft.DirectX.Direct3D.CursorCaps . A CursorCaps object that contains indicators of available hardware support for cursors.

This property is read-only.

Remarks

Alpha-blending cursor capabilities are not defined.


Caps.DeclTypes

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DeclTypes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that describes the vertex data types a device supports.

Definition

Visual Basic .NET | Public ReadOnly Property DeclTypes As DeclarationTypeCaps
C# | public DeclarationTypeCaps DeclTypes { get; }
Managed C++ | public: __property DeclarationTypeCaps get_DeclTypes();
JScript .NET | public function get DeclTypes() : DeclarationTypeCaps

Property Value

Microsoft.DirectX.Direct3D.DeclarationTypeCaps . A DeclarationTypeCaps object that describes the vertex data types the device supports.

This property is read-only.


Caps.DestinationBlendCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DestinationBlendCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that indicates a device's destination blending capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationBlendCaps As BlendCaps
C# | public BlendCaps DestinationBlendCaps { get; }
Managed C++ | public: __property BlendCaps get_DestinationBlendCaps();
JScript .NET | public function get DestinationBlendCaps() : BlendCaps

Property Value

Microsoft.DirectX.Direct3D.BlendCaps . A BlendCaps object that indicates the device's destination blending capabilities.

This property is read-only.

Remarks

This member can indicate the same capabilities that are defined in the SourceBlendCaps member.


Caps.DeviceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DeviceCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that identifies a device's capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceCaps As DeviceCaps
C# | public DeviceCaps DeviceCaps { get; }
Managed C++ | public: __property DeviceCaps get_DeviceCaps();
JScript .NET | public function get DeviceCaps() : DeviceCaps

Property Value

Microsoft.DirectX.Direct3D.DeviceCaps . A DeviceCaps object that identifies the device's capabilities.

This property is read-only.


Caps.DeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DeviceType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that identifies the type of resources used for processing vertices.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
Managed C++ | public: __property DeviceType get_DeviceType();
JScript .NET | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.Direct3D.DeviceType . A DeviceType object that identifies the type of resources used for processing vertices.

This property is read-only.


Caps.DriverCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DriverCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that identifies driver-specific capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property DriverCaps As DriverCaps
C# | public DriverCaps DriverCaps { get; }
Managed C++ | public: __property DriverCaps get_DriverCaps();
JScript .NET | public function get DriverCaps() : DriverCaps

Property Value

Microsoft.DirectX.Direct3D.DriverCaps . A DriverCaps object that identifies driver-specific capabilities.

This property is read-only.


Caps.ExtentsAdjust

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ExtentsAdjust Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the number of pixels to adjust the extents rectangle outward to accommodate antialiasing kernels.

Definition

Visual Basic .NET | Public ReadOnly Property ExtentsAdjust As Single
C# | public float ExtentsAdjust { get; }
Managed C++ | public: __property float get_ExtentsAdjust();
JScript .NET | public function get ExtentsAdjust() : float

Property Value

System.Single . A Single Leave Site value that indicates the number of pixels to adjust the extents rectangle outward.

This property is read-only.


Caps.GuardBandBottom

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.GuardBandBottom Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the screen-space coordinate of the bottom guard band clipping region.

Definition

Visual Basic .NET | Public ReadOnly Property GuardBandBottom As Single
C# | public float GuardBandBottom { get; }
Managed C++ | public: __property float get_GuardBandBottom();
JScript .NET | public function get GuardBandBottom() : float

Property Value

System.Single . A Single Leave Site value that indicates the screen-space coordinate of the bottom guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.GuardBandLeft

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.GuardBandLeft Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the screen-space coordinate of the left guard band clipping region.

Definition

Visual Basic .NET | Public ReadOnly Property GuardBandLeft As Single
C# | public float GuardBandLeft { get; }
Managed C++ | public: __property float get_GuardBandLeft();
JScript .NET | public function get GuardBandLeft() : float

Property Value

System.Single . A Single Leave Site value that indicates the screen-space coordinate of the left guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.GuardBandRight

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.GuardBandRight Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the screen-space coordinate of the right guard band clipping region.

Definition

Visual Basic .NET | Public ReadOnly Property GuardBandRight As Single
C# | public float GuardBandRight { get; }
Managed C++ | public: __property float get_GuardBandRight();
JScript .NET | public function get GuardBandRight() : float

Property Value

System.Single . A Single Leave Site value that indicates the right guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.GuardBandTop

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.GuardBandTop Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the screen-space coordinate of the top guard band clipping region.

Definition

Visual Basic .NET | Public ReadOnly Property GuardBandTop As Single
C# | public float GuardBandTop { get; }
Managed C++ | public: __property float get_GuardBandTop();
JScript .NET | public function get GuardBandTop() : float

Property Value

System.Single . A Single Leave Site value that indicates the screen-space coordinate of the top guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.LineCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.LineCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that defines the capabilities for line-drawing primitives.

Definition

Visual Basic .NET | Public ReadOnly Property LineCaps As LineCaps
C# | public LineCaps LineCaps { get; }
Managed C++ | public: __property LineCaps get_LineCaps();
JScript .NET | public function get LineCaps() : LineCaps

Property Value

Microsoft.DirectX.Direct3D.LineCaps . A LineCaps object that defines the capabilities for line-drawing primitives.

This property is read-only.


Caps.MasterAdapterOrdinal

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MasterAdapterOrdinal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates which device is the master for the current subordinate.

Definition

Visual Basic .NET | Public ReadOnly Property MasterAdapterOrdinal As Integer
C# | public int MasterAdapterOrdinal { get; }
Managed C++ | public: __property int get_MasterAdapterOrdinal();
JScript .NET | public function get MasterAdapterOrdinal() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates which device is the master for the current subordinate.

This property is read-only.

Remarks

This number is taken from the adapter values passed into the Manager.Adapters member.

For multihead support, one head is denoted the master head, and all other heads on the same card are denoted subordinate heads. If more than one multihead adapter is present in a system, the master and its subordinates from one multihead adapter are referred to as a group.


Caps.MaxActiveLights

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxActiveLights Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of lights that can be active simultaneously.

Definition

Visual Basic .NET | Public ReadOnly Property MaxActiveLights As Integer
C# | public int MaxActiveLights { get; }
Managed C++ | public: __property int get_MaxActiveLights();
JScript .NET | public function get MaxActiveLights() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum number of lights that can be active simultaneously.

This property is read-only.

Remarks

For a given physical device, this capability might vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxAnisotropy

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxAnisotropy Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the maximum valid value for anisotropic filtering.

Definition

Visual Basic .NET | Public ReadOnly Property MaxAnisotropy As Integer
C# | public int MaxAnisotropy { get; }
Managed C++ | public: __property int get_MaxAnisotropy();
JScript .NET | public function get MaxAnisotropy() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum valid value for anisotropic filtering.

This property is read-only.

Remarks

This property indicates the maximum valid value for the SamplerStateManager.MaxAnisotropy property.


Caps.MaxNPatchTessellationLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxNPatchTessellationLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the maximum number of N-patch subdivision levels.

Definition

Visual Basic .NET | Public ReadOnly Property MaxNPatchTessellationLevel As Single
C# | public float MaxNPatchTessellationLevel { get; }
Managed C++ | public: __property float get_MaxNPatchTessellationLevel();
JScript .NET | public function get MaxNPatchTessellationLevel() : float

Property Value

System.Single . A Single Leave Site value that indicates the maximum number of N-patch subdivision levels.

This property is read-only.

Remarks

The driver clamps applications to this value, provided they are using presampled displacement mapping.


Caps.MaxPixelShader30InstructionSlots

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxPixelShader30InstructionSlots Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the maximum number of vertex shader instruction slots supported.

Definition

Visual Basic .NET | Public ReadOnly Property MaxPixelShader30InstructionSlots As Integer
C# | public int MaxPixelShader30InstructionSlots { get; }
Managed C++ | public: __property int get_MaxPixelShader30InstructionSlots();
JScript .NET | public function get MaxPixelShader30InstructionSlots() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum number of vertex shader instruction slots supported.

This property is read-only.

Remarks

The maximum value that this member can have is 32768. Devices that support vs_3_0 are required to support at least 512 instruction slots.


Caps.MaxPointSize

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxPointSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum size of a point primitive.

Definition

Visual Basic .NET | Public ReadOnly Property MaxPointSize As Single
C# | public float MaxPointSize { get; }
Managed C++ | public: __property float get_MaxPointSize();
JScript .NET | public function get MaxPointSize() : float

Property Value

System.Single . A Single Leave Site value that indicates the maximum size of a point primitive.

This property is read-only.

Remarks

If this member is 1.0f, the device does not support point-size control. The range is greater than or equal to 1.0f.


Caps.MaxPrimitiveCount

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxPrimitiveCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of primitives for each Device.DrawPrimitives call.

Definition

Visual Basic .NET | Public ReadOnly Property MaxPrimitiveCount As Integer
C# | public int MaxPrimitiveCount { get; }
Managed C++ | public: __property int get_MaxPrimitiveCount();
JScript .NET | public function get MaxPrimitiveCount() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum number of primitives for each Device.DrawPrimitives call.

This property is read-only.

Remarks

Note that when Microsoft® Direct3D® is working with a Microsoft DirectX® 6.0 or DirectX 7.0 driver, this field is set to 0xFFFF. This means that not only the number of primitives but also the number of vertices is limited by this value.


Caps.MaxSimultaneousTextures

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxSimultaneousTextures Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of textures that can simultaneously be bound to the texture-blending stages.

Definition

Visual Basic .NET | Public ReadOnly Property MaxSimultaneousTextures As Integer
C# | public int MaxSimultaneousTextures { get; }
Managed C++ | public: __property int get_MaxSimultaneousTextures();
JScript .NET | public function get MaxSimultaneousTextures() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum number of textures that can simultaneously be bound to the texture-blending stages.

This property is read-only.

Remarks

This value is the number of textures that can be used in a single pass. If the same texture is used in two blending stages, it counts as two when compared to the MaxSimultaneousTextures value. In the programmable pipeline, the value indicates the number of texture/sampler registers supported by pixel shaders on this particular piece of hardware, as well as the number of texture-declaration instructions that can be present.


Caps.MaxStreams

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxStreams Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates the maximum number of concurrent data streams for Device.SetStreamSource.

Definition

Visual Basic .NET | Public ReadOnly Property MaxStreams As Integer
C# | public int MaxStreams { get; }
Managed C++ | public: __property int get_MaxStreams();
JScript .NET | public function get MaxStreams() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum number of concurrent data streams for Device.SetStreamSource.

This property is read-only.

Remarks

The valid range is 1 to 16. Note that if this value is 0, the driver is not a Microsoft® DirectX® 9.0 driver.


Caps.MaxStreamStride

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxStreamStride Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum stride for Device.SetStreamSource.

Definition

Visual Basic .NET | Public ReadOnly Property MaxStreamStride As Integer
C# | public int MaxStreamStride { get; }
Managed C++ | public: __property int get_MaxStreamStride();
JScript .NET | public function get MaxStreamStride() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum stride for Device.SetStreamSource.

This property is read-only.


Caps.MaxTextureAspectRatio

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxTextureAspectRatio Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum texture aspect ratio supported by the hardware.

Definition

Visual Basic .NET | Public ReadOnly Property MaxTextureAspectRatio As Integer
C# | public int MaxTextureAspectRatio { get; }
Managed C++ | public: __property int get_MaxTextureAspectRatio();
JScript .NET | public function get MaxTextureAspectRatio() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum texture aspect ratio.

This property is read-only.

Remarks

This value is typically a power of 2.


Caps.MaxTextureBlendStages

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxTextureBlendStages Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of texture-blending stages supported.

Definition

Visual Basic .NET | Public ReadOnly Property MaxTextureBlendStages As Integer
C# | public int MaxTextureBlendStages { get; }
Managed C++ | public: __property int get_MaxTextureBlendStages();
JScript .NET | public function get MaxTextureBlendStages() : int

Property Value

System.Int32 . An Int32 Leave Site that indicates the number of texture-blending stages supported.

This property is read-only.

Remarks

This value corresponds to the number of unique texture registers used by pixel shader instructions.


Caps.MaxTextureHeight

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxTextureHeight Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum texture height for the current device.

Definition

Visual Basic .NET | Public ReadOnly Property MaxTextureHeight As Integer
C# | public int MaxTextureHeight { get; }
Managed C++ | public: __property int get_MaxTextureHeight();
JScript .NET | public function get MaxTextureHeight() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum texture height for the current device.

This property is read-only.


Caps.MaxTextureRepeat

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxTextureRepeat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum range of the integer bits for post-normalized texture coordinates.

Definition

Visual Basic .NET | Public ReadOnly Property MaxTextureRepeat As Integer
C# | public int MaxTextureRepeat { get; }
Managed C++ | public: __property int get_MaxTextureRepeat();
JScript .NET | public function get MaxTextureRepeat() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum range of the integer bits for the post-normalized texture coordinates.

This property is read-only.

Remarks

A texture coordinate is stored as a 32-bit signed integer that uses 27 bits to store the integer and five bits to store the floating-point fraction. The maximum integer index, 227, is used to determine the maximum texture coordinate, depending on how the hardware performs texture-coordinate scaling.

Some hardware sets the Caps.TextureCaps.SupportsTextureRepeatNotScaledBySize capability to true. In this case, the device defers the scaling of texture coordinates by texture size until after interpolation and application of the texture address mode. This means that the number of times a texture can be wrapped is specified by the integer value in MaxTextureRepeat.

Other hardware sets the Caps.TextureCaps.SupportsTextureRepeatNotScaledBySize capability to false, and the device scales the texture coordinates by texture size (using the highest level of detail) before interpolation. This limits the number of times a texture can be wrapped to MaxTextureRepeat / texture size.

For example, assume that MaxTextureRepeat is equal to 32 KB, and the size of the texture is 4 KB. If the hardware sets Caps.TextureCaps.SupportsTextureRepeatNotScaledBySize to true, the number of times a texture can be wrapped is equal to MaxTextureRepeat, which is 32 KB. Otherwise, the number of times a texture can be wrapped is equal to MaxTextureRepeat divided by texture size, which is 227 / 4 KB.


Caps.MaxTextureWidth

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxTextureWidth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum texture width for the current device.

Definition

Visual Basic .NET | Public ReadOnly Property MaxTextureWidth As Integer
C# | public int MaxTextureWidth { get; }
Managed C++ | public: __property int get_MaxTextureWidth();
JScript .NET | public function get MaxTextureWidth() : int

Property Value

System.Int32 . Maximum texture width for the device.

This property is read-only.


Caps.MaxUserClipPlanes

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxUserClipPlanes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of user-defined clipping planes supported.

Definition

Visual Basic .NET | Public ReadOnly Property MaxUserClipPlanes As Integer
C# | public int MaxUserClipPlanes { get; }
Managed C++ | public: __property int get_MaxUserClipPlanes();
JScript .NET | public function get MaxUserClipPlanes() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum number of user-defined clipping planes supported.

This property is read-only.

Remarks

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxVertexBlendMatrices

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVertexBlendMatrices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of matrices that the current device can apply when performing multimatrix vertex blending.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertexBlendMatrices As Integer
C# | public int MaxVertexBlendMatrices { get; }
Managed C++ | public: __property int get_MaxVertexBlendMatrices();
JScript .NET | public function get MaxVertexBlendMatrices() : int

Property Value

System.Int32 . Maximum number of matrices that the device can apply when performing multimatrix vertex blending.

This property is read-only.

Remarks

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxVertexBlendMatrixIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVertexBlendMatrixIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum matrix index that can be indexed into using pre-vertex indices.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertexBlendMatrixIndex As Integer
C# | public int MaxVertexBlendMatrixIndex { get; }
Managed C++ | public: __property int get_MaxVertexBlendMatrixIndex();
JScript .NET | public function get MaxVertexBlendMatrixIndex() : int

Property Value

System.Int32 . Maximum matrix index that can be indexed into using pre-vertex indices.

This property is read-only.

Remarks

The number of matrices is MaxVertexBlendMatrixIndex + 1, which is the size of the matrix palette. If normals are present in the vertex data that need to be blended for lighting, the number of matrices is half the number specified by this capability flag. If MaxVertexBlendMatrixIndex is 0, the driver does not support indexed vertex blending. If the value is not 0, the valid range of indices is 0 through MaxVertexBlendMatrixIndex.

A 0 value for MaxVertexBlendMatrixIndex indicates that the driver does not support indexed matrices.

When software vertex processing is used, 256 matrices can be used for indexed vertex blending, with or without normal blending.

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxVertexIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVertexIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum size of indices supported for hardware vertex processing.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertexIndex As Integer
C# | public int MaxVertexIndex { get; }
Managed C++ | public: __property int get_MaxVertexIndex();
JScript .NET | public function get MaxVertexIndex() : int

Property Value

System.Int32 . Maximum size of indices supported for hardware vertex processing.

This property is read-only.

Remarks

It is possible to create 32-bit index buffers by specifying that the sixteenBitIndices parameter is false in the IndexBuffer constructor; however, rendering with the index buffer is not possible unless MaxVertexIndex is greater than 0x0000FFFF.


Caps.MaxVertexShader30InstructionSlots

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVertexShader30InstructionSlots Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of vertex shader instruction slots supported.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertexShader30InstructionSlots As Integer
C# | public int MaxVertexShader30InstructionSlots { get; }
Managed C++ | public: __property int get_MaxVertexShader30InstructionSlots();
JScript .NET | public function get MaxVertexShader30InstructionSlots() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the maximum number of vertex shader instruction slots supported.

This property is read-only.

Remarks

The maximum value that can be set is 32768. Devices that support vs_3_0 are required to support at least 512 instruction slots.


Caps.MaxVertexShaderConst

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVertexShaderConst Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of vertex shader registers that are reserved for constants.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertexShaderConst As Integer
C# | public int MaxVertexShaderConst { get; }
Managed C++ | public: __property int get_MaxVertexShaderConst();
JScript .NET | public function get MaxVertexShaderConst() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of vertex shader registers that are reserved for constants.

This property is read-only.


Caps.MaxVertexW

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVertexW Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum w-based depth value that a device supports.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVertexW As Single
C# | public float MaxVertexW { get; }
Managed C++ | public: __property float get_MaxVertexW();
JScript .NET | public function get MaxVertexW() : float

Property Value

System.Single . Indicates the maximum w-based depth value that a device supports.

This property is read-only.


Caps.MaxVolumeExtent

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVolumeExtent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for any of the three dimensions (width, height, and depth) of a volume texture.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVolumeExtent As Integer
C# | public int MaxVolumeExtent { get; }
Managed C++ | public: __property int get_MaxVolumeExtent();
JScript .NET | public function get MaxVolumeExtent() : int

Property Value

System.Int32 . Maximum value for any of the three dimensions of a volume texture.

This property is read-only.


Caps.NumberOfAdaptersInGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NumberOfAdaptersInGroup Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of adapters in the current adapter group.

Definition

Visual Basic .NET | Public ReadOnly Property NumberOfAdaptersInGroup As Integer
C# | public int NumberOfAdaptersInGroup { get; }
Managed C++ | public: __property int get_NumberOfAdaptersInGroup();
JScript .NET | public function get NumberOfAdaptersInGroup() : int

Property Value

System.Int32 . Number of adapters in the current adapter group.

This property is read-only.

Remarks

If the current Caps object is associated with a conventional adapter, this property reports 1. It reports a value greater than 1 for the master adapter of a multihead card, and 0 for a subordinate adapter of a multihead card. Each card can have only one master, but many subordinates.


Caps.NumberSimultaneousRts

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NumberSimultaneousRts Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of simultaneous render targets.

Definition

Visual Basic .NET | Public ReadOnly Property NumberSimultaneousRts As Integer
C# | public int NumberSimultaneousRts { get; }
Managed C++ | public: __property int get_NumberSimultaneousRts();
JScript .NET | public function get NumberSimultaneousRts() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of simultaneous render targets.

This property is read-only.

Remarks

This property value must be at least 1.


Caps.PixelShader1xMaxValue

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PixelShader1xMaxValue Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value of a pixel shader arithmetic component.

Definition

Visual Basic .NET | Public ReadOnly Property PixelShader1xMaxValue As Single
C# | public float PixelShader1xMaxValue { get; }
Managed C++ | public: __property float get_PixelShader1xMaxValue();
JScript .NET | public function get PixelShader1xMaxValue() : float

Property Value

System.Single . A Single Leave Site value that indicates the maximum value of the pixel shader arithmetic component.

This property is read-only.

Remarks

This property's value indicates the internal range of values supported for pixel color-blending operations. Implementations must allow data within this range to pass through pixel processing unmodified (that is, unclamped).

Normally, the value of this member is absolute. For example, a value of 1.0 indicates that the range is -1.0 to 1, and an 8.0 indicates that the range is -8.0 to 8.0. The value is >= 1.0 for any hardware that supports pixel shaders.


Caps.PixelShaderCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PixelShaderCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that contains the supported pixel shader capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property PixelShaderCaps As PixelShaderCaps
C# | public PixelShaderCaps PixelShaderCaps { get; }
Managed C++ | public: __property PixelShaderCaps get_PixelShaderCaps();
JScript .NET | public function get PixelShaderCaps() : PixelShaderCaps

Property Value

Microsoft.DirectX.Direct3D.PixelShaderCaps . A PixelShaderCaps structure that contains the supported pixel shader capabilities.

This property is read-only.


Caps.PixelShaderVersion

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PixelShaderVersion Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that reports the main and subordinate pixel shader versions.

Definition

Visual Basic .NET | Public ReadOnly Property PixelShaderVersion As Version
C# | public Version PixelShaderVersion { get; }
Managed C++ | public: __property Version* get_PixelShaderVersion();
JScript .NET | public function get PixelShaderVersion() : Version

Property Value

System.Version . A Version Leave Site object that contains the main and subordinate pixel shader versions.

This property is read-only.


Caps.PresentationIntervals

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PresentationIntervals Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a set of values that represent the available presentation swap intervals.

Definition

Visual Basic .NET | Public ReadOnly Property PresentationIntervals As PresentInterval
C# | public PresentInterval PresentationIntervals { get; }
Managed C++ | public: __property PresentInterval get_PresentationIntervals();
JScript .NET | public function get PresentationIntervals() : PresentInterval

Property Value

Microsoft.DirectX.Direct3D.PresentInterval . A combination of PresentInterval values that indicate the available presentation swap intervals.

This property is read-only.


Caps.PrimitiveMiscCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PrimitiveMiscCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves miscellaneous driver primitive capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property PrimitiveMiscCaps As MiscCaps
C# | public MiscCaps PrimitiveMiscCaps { get; }
Managed C++ | public: __property MiscCaps get_PrimitiveMiscCaps();
JScript .NET | public function get PrimitiveMiscCaps() : MiscCaps

Property Value

Microsoft.DirectX.Direct3D.MiscCaps . A MiscCaps structure that contains miscellaneous driver primitive capabilities.

This property is read-only.


Caps.RasterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.RasterCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about raster drawing capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property RasterCaps As RasterCaps
C# | public RasterCaps RasterCaps { get; }
Managed C++ | public: __property RasterCaps get_RasterCaps();
JScript .NET | public function get RasterCaps() : RasterCaps

Property Value

Microsoft.DirectX.Direct3D.RasterCaps . A RasterCaps structure that contains raster drawing capabilities.

This property is read-only.


Caps.ShadeCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ShadeCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves shading operation capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property ShadeCaps As ShadeCaps
C# | public ShadeCaps ShadeCaps { get; }
Managed C++ | public: __property ShadeCaps get_ShadeCaps();
JScript .NET | public function get ShadeCaps() : ShadeCaps

Property Value

Microsoft.DirectX.Direct3D.ShadeCaps . A ShadeCaps structure that contains shading operation capabilities.

This property is read-only.

Remarks

Generally, it is assumed that if a device supports a shading operation at all, it at least supports flat shading. For more information, see ShadeMode.

When alpha components are not supported, the alpha value of generated colors is implicitly 255. This is the maximum possible alpha (that is, the alpha component is at full intensity).


Caps.SourceBlendCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SourceBlendCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the source-blending capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property SourceBlendCaps As BlendCaps
C# | public BlendCaps SourceBlendCaps { get; }
Managed C++ | public: __property BlendCaps get_SourceBlendCaps();
JScript .NET | public function get SourceBlendCaps() : BlendCaps

Property Value

Microsoft.DirectX.Direct3D.BlendCaps . A BlendCaps object that contains the source-blending capabilities.

This property is read-only.


Caps.StencilCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.StencilCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object that indicates the supported stencil buffer operations.

Definition

Visual Basic .NET | Public ReadOnly Property StencilCaps As StencilCaps
C# | public StencilCaps StencilCaps { get; }
Managed C++ | public: __property StencilCaps get_StencilCaps();
JScript .NET | public function get StencilCaps() : StencilCaps

Property Value

Microsoft.DirectX.Direct3D.StencilCaps . A StencilCaps object that indicates the supported stencil-buffer operations.

This property is read-only.

Remarks

The supported stencil operations are assumed to be valid for all three stencil-buffer operation render states (RenderStateManager.StencilFail, RenderStateManager.StencilPass, and RenderStateManager.StencilZBufferFail). For more information, see the StencilOperation enumerated type.


Caps.StretchRectangleFilterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.StretchRectangleFilterCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that describes the operations supported by StretchRectangle.

Definition

Visual Basic .NET | Public ReadOnly Property StretchRectangleFilterCaps As FilterCaps
C# | public FilterCaps StretchRectangleFilterCaps { get; }
Managed C++ | public: __property FilterCaps get_StretchRectangleFilterCaps();
JScript .NET | public function get StretchRectangleFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps . A FilterCaps structure that describes the operations supported by Device.StretchRectangle.

This property is read-only.


Caps.TextureAddressCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.TextureAddressCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that contains texture-addressing capabilities for Texture objects.

Definition

Visual Basic .NET | Public ReadOnly Property TextureAddressCaps As AddressCaps
C# | public AddressCaps TextureAddressCaps { get; }
Managed C++ | public: __property AddressCaps get_TextureAddressCaps();
JScript .NET | public function get TextureAddressCaps() : AddressCaps

Property Value

Microsoft.DirectX.Direct3D.AddressCaps . An AddressCaps structure that contains the texture-addressing capabilities for Texture objects.

This property is read-only.


Caps.TextureCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.TextureCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that contains miscellaneous texture-mapping capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property TextureCaps As TextureCaps
C# | public TextureCaps TextureCaps { get; }
Managed C++ | public: __property TextureCaps get_TextureCaps();
JScript .NET | public function get TextureCaps() : TextureCaps

Property Value

Microsoft.DirectX.Direct3D.TextureCaps . A TextureCaps structure that contains miscellaneous texture-mapping capabilities.

This property is read-only.


Caps.TextureFilterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.TextureFilterCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that contains texture-filtering capabilities for Texture objects.

Definition

Visual Basic .NET | Public ReadOnly Property TextureFilterCaps As FilterCaps
C# | public FilterCaps TextureFilterCaps { get; }
Managed C++ | public: __property FilterCaps get_TextureFilterCaps();
JScript .NET | public function get TextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps . A FilterCaps structure that contains the texture-filtering capabilities for Texture objects.

This property is read-only.

Remarks

Per-stage filtering capabilities reflect which filtering modes are supported for texture stages when multiple-texture blending is performed.


Caps.TextureOperationCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.TextureOperationCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that describes supported texture operations.

Definition

Visual Basic .NET | Public ReadOnly Property TextureOperationCaps As TextureOperationCaps
C# | public TextureOperationCaps TextureOperationCaps { get; }
Managed C++ | public: __property TextureOperationCaps get_TextureOperationCaps();
JScript .NET | public function get TextureOperationCaps() : TextureOperationCaps

Property Value

Microsoft.DirectX.Direct3D.TextureOperationCaps . A TextureOperationCaps structure that describes the supported texture operations.

This property is read-only.


Caps.VertexFormatCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VertexFormatCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that describes supported vertex format capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property VertexFormatCaps As VertexFormatCaps
C# | public VertexFormatCaps VertexFormatCaps { get; }
Managed C++ | public: __property VertexFormatCaps get_VertexFormatCaps();
JScript .NET | public function get VertexFormatCaps() : VertexFormatCaps

Property Value

Microsoft.DirectX.Direct3D.VertexFormatCaps . A VertexFormatCaps structure that describes supported vertex format capabilities.

This property is read-only.


Caps.VertexProcessingCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VertexProcessingCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that contains supported vertex processing capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property VertexProcessingCaps As VertexProcessingCaps
C# | public VertexProcessingCaps VertexProcessingCaps { get; }
Managed C++ | public: __property VertexProcessingCaps get_VertexProcessingCaps();
JScript .NET | public function get VertexProcessingCaps() : VertexProcessingCaps

Property Value

Microsoft.DirectX.Direct3D.VertexProcessingCaps . A VertexProcessingCaps structure that contains the supported vertex processing capabilities.

This property is read-only.

Remarks

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.VertexShaderCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VertexShaderCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that contains supported vertex shader capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property VertexShaderCaps As VertexShaderCaps
C# | public VertexShaderCaps VertexShaderCaps { get; }
Managed C++ | public: __property VertexShaderCaps get_VertexShaderCaps();
JScript .NET | public function get VertexShaderCaps() : VertexShaderCaps

Property Value

Microsoft.DirectX.Direct3D.VertexShaderCaps . A VertexShaderCaps structure that contains the supported vertex shader capabilities.

This property is read-only.


Caps.VertexShaderVersion

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VertexShaderVersion Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check for Shader Support

Retrieves a structure that indicates the main and subordinate vertex shader versions supported by a device.

Definition

Visual Basic .NET | Public ReadOnly Property VertexShaderVersion As Version
C# | public Version VertexShaderVersion { get; }
Managed C++ | public: __property Version* get_VertexShaderVersion();
JScript .NET | public function get VertexShaderVersion() : Version

Property Value

System.Version . A Version Leave Site object that indicates the main and subordinate vertex shader versions supported by the device.

This property is read-only.

Remarks

Only vertex shaders with version numbers equal to or less than the value indicated by this member succeed in calls to the VertexShader constructor.

How Do I...?

Check for Shader Support

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Microsoft® Direct3D® allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

              [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


Caps.VertexTextureFilterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VertexTextureFilterCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that indicates which types of vertex shader texture filters are supported.

Definition

Visual Basic .NET | Public ReadOnly Property VertexTextureFilterCaps As FilterCaps
C# | public FilterCaps VertexTextureFilterCaps { get; }
Managed C++ | public: __property FilterCaps get_VertexTextureFilterCaps();
JScript .NET | public function get VertexTextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps . A FilterCaps structure that indicates which types of vertex shader texture filters are supported.

This property is read-only.


Caps.VolumeTextureAddressCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VolumeTextureAddressCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that indicates the supported texture-addressing capabilities for VolumeTexture objects.

Definition

Visual Basic .NET | Public ReadOnly Property VolumeTextureAddressCaps As AddressCaps
C# | public AddressCaps VolumeTextureAddressCaps { get; }
Managed C++ | public: __property AddressCaps get_VolumeTextureAddressCaps();
JScript .NET | public function get VolumeTextureAddressCaps() : AddressCaps

Property Value

Microsoft.DirectX.Direct3D.AddressCaps . An AddressCaps structure that indicates the supported texture-addressing capabilities for VolumeTexture objects.

This property is read-only.


Caps.VolumeTextureFilterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VolumeTextureFilterCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that indicates the texture-filtering capabilities of VolumeTexture objects.

Definition

Visual Basic .NET | Public ReadOnly Property VolumeTextureFilterCaps As FilterCaps
C# | public FilterCaps VolumeTextureFilterCaps { get; }
Managed C++ | public: __property FilterCaps get_VolumeTextureFilterCaps();
JScript .NET | public function get VolumeTextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps . A FilterCaps structure that indicates the texture-filtering capabilities of VolumeTexture objects.

This property is read-only.

Remarks

Per-stage filtering capabilities reflect which filtering modes are supported for texture stages when multiple-texture blending is performed with the Device object.


Caps.ZCompareCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ZCompareCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a structure that contains the supported z-buffer comparison capabilities.

Definition

Visual Basic .NET | Public ReadOnly Property ZCompareCaps As ComparisonCaps
C# | public ComparisonCaps ZCompareCaps { get; }
Managed C++ | public: __property ComparisonCaps get_ZCompareCaps();
JScript .NET | public function get ZCompareCaps() : ComparisonCaps

Property Value

Microsoft.DirectX.Direct3D.ComparisonCaps . A ComparisonCaps structure that contains the supported z-buffer comparison capabilities.

This property is read-only.

Remarks

This member can be one or more of the following ComparisonCaps:

  • SupportsAlways: Always pass the z-test.
  • SupportsEqual: Pass the z-test if the new z equals the current z.
  • SupportsGreater: Pass the z-test if the new z is greater than the current z.
  • SupportsGreaterEqual: Pass the z-test if the new z is greater than or equal to the current z.
  • SupportsLess: Pass the z-test if the new z is less than the current z.
  • SupportsLessEqual: Pass the z-test if the new z is less than or equal to the current z.
  • SupportsNever: Always fail the z-test.
  • SupportsNotEqual: Pass the z-test if the new z does not equal the current z.


ClipStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipStatus Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the current clip status.

Definition

Visual Basic .NET | Public Structure ClipStatus
C# | public struct ClipStatus
Managed C++ | public __value struct ClipStatus
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ClipStatus | Initializes a new instance of the ClipStatus class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ClipIntersection | Retrieves or sets a value that is the bitwise intersection of all current clip status flags.
ClipUnion | Retrieves or sets a value that is the bitwise union of all current clip status flags.

Remarks

When clipping is enabled during vertex processing (by Device.ProcessVertices, Device.DrawPrimitives, or other drawing functions), Microsoft® Direct3D® computes a clip code for each vertex. When a vertex is outside of a particular clipping plane, the corresponding bit is set in the clipping code. Direct3D maintains the clip status using ClipStatus, which has ClipUnion and ClipIntersection members. ClipUnion is a bitwise OR of all vertex clip codes and ClipIntersection is a bitwise AND of all vertex clip codes. Initial values are zero for ClipUnion and 0xFFFFFFFF for ClipIntersection. When RenderStateManager is set to false, ClipUnion and ClipIntersection are set to zero. Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion and ClipIntersection to their initial values and continue drawing.

Clip status is not updated by Device.DrawRectanglePatch and Device.DrawTrianglePatch because there is no software emulation for them.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClipStatus.ClipStatus()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipStatus.ClipStatus Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ClipStatus class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ClipStatus();
Managed C++ | public: ClipStatus();
JScript .NET | public function ClipStatus();


ClipStatus.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipStatus.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ClipStatus.ClipIntersection

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipStatus.ClipIntersection Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that is the bitwise intersection of all current clip status flags.

Definition

Visual Basic .NET | Public Property ClipIntersection As ClipStatusFlags
C# | public ClipStatusFlags ClipIntersection { get; set; }
Managed C++ public: __property ClipStatusFlags get_ClipIntersection();
public: __property void set_ClipIntersection(ClipStatusFlags);
JScript .NET public function get ClipIntersection() : ClipStatusFlags
public function set ClipIntersection(ClipStatusFlags);

Property Value

Microsoft.DirectX.Direct3D.ClipStatusFlags . Value that represents a bitwise AND of all current ClipStatusFlags.

This property is read/write.

Remarks

Microsoft® Direct3D® updates the clip status during drawing calls. To compute clip status for a particular object, set ClipIntersection to its initial value and continue drawing.

See Also

  • ClipUnion


ClipStatus.ClipUnion

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipStatus.ClipUnion Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that is the bitwise union of all current clip status flags.

Definition

Visual Basic .NET | Public Property ClipUnion As ClipStatusFlags
C# | public ClipStatusFlags ClipUnion { get; set; }
Managed C++ public: __property ClipStatusFlags get_ClipUnion();
public: __property void set_ClipUnion(ClipStatusFlags);
JScript .NET public function get ClipUnion() : ClipStatusFlags
public function set ClipUnion(ClipStatusFlags);

Property Value

Microsoft.DirectX.Direct3D.ClipStatusFlags . Value that represents a bitwise OR of all current ClipStatusFlags.

This property is read/write.

Remarks

Microsoft® Direct3D® updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion to its initial value and continue drawing.

See Also

  • ClipIntersection


ColorValue

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Stores the red, green, blue, and alpha channel values that together define a specific color.

Definition

Visual Basic .NET | Public Structure ColorValue
C# | public struct ColorValue
Managed C++ | public __value struct ColorValue
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ColorValue | Initializes a new instance of the ColorValue structure.
FillD3DColor | Fills a _D3DCOLORVALUE structure with the color values of the current instance.
static (Shared in Visual Basic .NET) FromArgb | Initializes and returns an instance of a ColorValue structure using an Int32 Leave Site value.
static (Shared in Visual Basic .NET) FromColor | Initializes and returns an instance of a ColorValue structure using a Color Leave Site value.
static (Shared in Visual Basic .NET) FromD3DColor | Initializes and returns an instance of a ColorValue structure using an _D3DCOLORVALUE value.
ToArgb | Returns an Int32 Leave Site value that represents the color value of the current instance.

Properties

Property | Description
Alpha | Retrieves or sets the alpha channel value of the current color.
Blue | Retrieves or sets the blue value of the current color.
Green | Retrieves or sets the green value of the current color.
Red | Retrieves or sets the red value of the current color.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorValue.ColorValue

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.ColorValue Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ColorValue structure.

Overload List

public ColorValue(int, int, int);
public ColorValue(int, int, int, int);
public ColorValue(float, float, float);
public ColorValue(float, float, float, float);


ColorValue.ColorValue(Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.ColorValue Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic .NET Public Sub New( _
ByVal r As Integer, _
ByVal g As Integer, _
ByVal b As Integer _
)
C# public ColorValue(
int r,
int g,
int b
);
Managed C++ public: ColorValue(
int r,
int g,
int b
);
JScript .NET public function ColorValue(
r : int,
g : int,
b : int
);

Parameters

r | System.Int32. An integer value that represents the level of red in the color.
g | System.Int32. An integer value that represents the level of green in the color.
b | System.Int32. An integer value that represents the level of blue in the color.


ColorValue.ColorValue(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.ColorValue Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic .NET Public Sub New( _
ByVal r As Integer, _
ByVal g As Integer, _
ByVal b As Integer, _
ByVal a As Integer _
)
C# public ColorValue(
int r,
int g,
int b,
int a
);
Managed C++ public: ColorValue(
int r,
int g,
int b,
int a
);
JScript .NET public function ColorValue(
r : int,
g : int,
b : int,
a : int
);

Parameters

r | System.Int32. An integer value that represents the level of red in the color.
g | System.Int32. An integer value that represents the level of green in the color.
b | System.Int32. An integer value that represents the level of blue in the color.
a | System.Int32. An integer value that represents the alpha channel value of the color.


ColorValue.ColorValue(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.ColorValue Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic .NET Public Sub New( _
ByVal r As Single, _
ByVal g As Single, _
ByVal b As Single _
)
C# public ColorValue(
float r,
float g,
float b
);
Managed C++ public: ColorValue(
float r,
float g,
float b
);
JScript .NET public function ColorValue(
r : float,
g : float,
b : float
);

Parameters

r | System.Single. A Single Leave Site value that represents the level of red in the color.
g | System.Single. A Single Leave Site value that represents the level of green in the color.
b | System.Single. A Single Leave Site value that represents the level of blue in the color.


ColorValue.ColorValue(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.ColorValue Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic .NET Public Sub New( _
ByVal r As Single, _
ByVal g As Single, _
ByVal b As Single, _
ByVal a As Single _
)
C# public ColorValue(
float r,
float g,
float b,
float a
);
Managed C++ public: ColorValue(
float r,
float g,
float b,
float a
);
JScript .NET public function ColorValue(
r : float,
g : float,
b : float,
a : float
);

Parameters

r | System.Single. A Single Leave Site value that represents the level of red in the color.
g | System.Single. A Single Leave Site value that represents the level of green in the color.
b | System.Single. A Single Leave Site value that represents the level of blue in the color.
a | System.Single. A Single Leave Site value that represents the alpha channel value of the color.


ColorValue.FillD3DColor(_D3DCOLORVALUE)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.FillD3DColor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Fills a _D3DCOLORVALUE structure with the color values of the current instance.

Definition

Visual Basic .NET Public Sub FillD3DColor( _
ByVal pColor As _D3DCOLORVALUE _
)
C# public void FillD3DColor(
_D3DCOLORVALUE pColor
);
Managed C++ public: void FillD3DColor(
_D3DCOLORVALUE pColor
);
JScript .NET public function FillD3DColor(
pColor : _D3DCOLORVALUE
);

Parameters

pColor Microsoft.DirectX.PrivateImplementationDetails._D3DCOLORVALUE. A _D3DCOLORVALUE structure to contain the current color values.


ColorValue.FromArgb(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.FromArgb Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes and returns an instance of a ColorValue structure using an Int32 Leave Site value.

Definition

Visual Basic .NET Public Shared Function FromArgb( _
ByVal color As Integer _
) As ColorValue
C# public static ColorValue FromArgb(
int color
);
Managed C++ public: static ColorValue FromArgb(
int color
);
JScript .NET public static function FromArgb(
color : int
) : ColorValue;

Parameters

color System.Int32. An Int32 Leave Site value that is used to initialize a ColorValue structure.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure whose properties are initialized to the color value.


ColorValue.FromColor(Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.FromColor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes and returns an instance of a ColorValue structure using a Color Leave Site value.

Definition

Visual Basic .NET Public Shared Function FromColor( _
ByVal color As Color _
) As ColorValue
C# public static ColorValue FromColor(
Color color
);
Managed C++ public: static ColorValue FromColor(
Color color
);
JScript .NET public static function FromColor(
color : Color
) : ColorValue;

Parameters

color System.Drawing.Color. A ColorValue used to initialize a ColorValue structure.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure whose properties are initialized to the color value.


ColorValue.FromD3DColor(_D3DCOLORVALUE)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.FromD3DColor Method

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes and returns an instance of a ColorValue structure using an _D3DCOLORVALUE value.

Definition

Visual Basic .NET Public Shared Function FromD3DColor( _
ByVal color As _D3DCOLORVALUE _
) As ColorValue
C# public static ColorValue FromD3DColor(
_D3DCOLORVALUE color
);
Managed C++ public: static ColorValue FromD3DColor(
_D3DCOLORVALUE color
);
JScript .NET public static function FromD3DColor(
color : _D3DCOLORVALUE
) : ColorValue;

Parameters

color Microsoft.DirectX.PrivateImplementationDetails._D3DCOLORVALUE. A _D3DCOLORVALUE used to initialize a ColorValue structure.

Return Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure whose properties are initialized to the color value.


ColorValue.ToArgb()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.ToArgb Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns an Int32 Leave Site value that represents the color value of the current instance.

Definition

Visual Basic .NET | Public Function ToArgb() As Integer
C# | public int ToArgb();
Managed C++ | public: int ToArgb();
JScript .NET | public function ToArgb() : int;

Return Value

System.Int32 . An Int32 Leave Site value that represents the color value of the current instance.


ColorValue.Alpha

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.Alpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the alpha channel value of the current color.

Definition

Visual Basic .NET | Public Property Alpha As Single
C# | public float Alpha { get; set; }
Managed C++ public: __property float get_Alpha();
public: __property void set_Alpha(float);
JScript .NET public function get Alpha() : float
public function set Alpha(float);

Property Value

System.Single . A Single Leave Site value that represents the alpha value of the current color.

This property is read/write.


ColorValue.Blue

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.Blue Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the blue value of the current color.

Definition

Visual Basic .NET | Public Property Blue As Single
C# | public float Blue { get; set; }
Managed C++ public: __property float get_Blue();
public: __property void set_Blue(float);
JScript .NET public function get Blue() : float
public function set Blue(float);

Property Value

System.Single . A Single Leave Site value that represents the blue value of the current color.

This property is read/write.


ColorValue.Green

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.Green Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the green value of the current color.

Definition

Visual Basic .NET | Public Property Green As Single
C# | public float Green { get; set; }
Managed C++ public: __property float get_Green();
public: __property void set_Green(float);
JScript .NET public function get Green() : float
public function set Green(float);

Property Value

System.Single . A Single Leave Site value that represents the green value of the current color.

This property is read/write.


ColorValue.Red

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorValue.Red Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the red value of the current color.

Definition

Visual Basic .NET | Public Property Red As Single
C# | public float Red { get; set; }
Managed C++ public: __property float get_Red();
public: __property void set_Red(float);
JScript .NET public function get Red() : float
public function set Red(float);

Property Value

System.Single . A Single Leave Site value that represents the red value of the current color.

This property is read/write.


ComparisonCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves comparison capabilities.

Definition

Visual Basic .NET | Public Structure ComparisonCaps
C# | public struct ComparisonCaps
Managed C++ | public __value struct ComparisonCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlways | Retrieves a value that indicates whether always passing the comparison test is supported.
SupportsEqual | Retrieves a value that indicates whether comparison tests in which the new value equals the current value are supported.
SupportsGreater | Retrieves a value that indicates whether comparison tests in which the new value is greater than the current value are supported.
SupportsGreaterEqual | Retrieves a value that indicates whether comparison tests in which the new value is greater than or equal to the current value are supported.
SupportsLess | Retrieves a value that indicates whether comparison tests in which the new value is less than the current value are supported.
SupportsLessEqual | Retrieves a value that indicates whether comparison tests in which the new value is less than or equal to the current value are supported.
SupportsNever | Retrieves a value that indicates whether never passing the comparison test is supported.
SupportsNotEqual | Retrieves a value that indicates whether comparison tests in which the new value does not equal the current value are supported.

Remarks

Comparison capabilities are used in Caps.ZCompareCaps and Caps.AlphaCompareCaps to indicate the supported comparison operations.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ComparisonCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ComparisonCaps.SupportsAlways

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsAlways Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether always passing the comparison test is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAlways As Boolean
C# | public bool SupportsAlways { get; }
Managed C++ | public: __property bool get_SupportsAlways();
JScript .NET | public function get SupportsAlways() : boolean

Property Value

System.Boolean . Value that is true if always passing the comparison test is supported, or false if it is not.

This property is read-only.


ComparisonCaps.SupportsEqual

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsEqual Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether comparison tests in which the new value equals the current value are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsEqual As Boolean
C# | public bool SupportsEqual { get; }
Managed C++ | public: __property bool get_SupportsEqual();
JScript .NET | public function get SupportsEqual() : boolean

Property Value

System.Boolean . Value that is true if comparison tests in which the new value equals the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsGreater

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsGreater Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether comparison tests in which the new value is greater than the current value are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsGreater As Boolean
C# | public bool SupportsGreater { get; }
Managed C++ | public: __property bool get_SupportsGreater();
JScript .NET | public function get SupportsGreater() : boolean

Property Value

System.Boolean . Value that is true if comparison tests in which the new value is greater than the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsGreaterEqual

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsGreaterEqual Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether comparison tests in which the new value is greater than or equal to the current value are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsGreaterEqual As Boolean
C# | public bool SupportsGreaterEqual { get; }
Managed C++ | public: __property bool get_SupportsGreaterEqual();
JScript .NET | public function get SupportsGreaterEqual() : boolean

Property Value

System.Boolean . Value that is true if comparison tests in which the new value is greater than or equal to the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsLess

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsLess Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether comparison tests in which the new value is less than the current value are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsLess As Boolean
C# | public bool SupportsLess { get; }
Managed C++ | public: __property bool get_SupportsLess();
JScript .NET | public function get SupportsLess() : boolean

Property Value

System.Boolean . Value that is true if comparison tests in which the new value is less than the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsLessEqual

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsLessEqual Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether comparison tests in which the new value is less than or equal to the current value are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsLessEqual As Boolean
C# | public bool SupportsLessEqual { get; }
Managed C++ | public: __property bool get_SupportsLessEqual();
JScript .NET | public function get SupportsLessEqual() : boolean

Property Value

System.Boolean . Value that is true if comparison tests in which the new value is less than or equal to the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsNever

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsNever Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether never passing the comparison test is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNever As Boolean
C# | public bool SupportsNever { get; }
Managed C++ | public: __property bool get_SupportsNever();
JScript .NET | public function get SupportsNever() : boolean

Property Value

System.Boolean . Value that is true if never passing the comparison test is supported, or false if it is not.

This property is read-only.


ComparisonCaps.SupportsNotEqual

Microsoft DirectX 9.0 SDK Update (October 2004)

ComparisonCaps.SupportsNotEqual Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether comparison tests in which the new value does not equal the current value are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNotEqual As Boolean
C# | public bool SupportsNotEqual { get; }
Managed C++ | public: __property bool get_SupportsNotEqual();
JScript .NET | public function get SupportsNotEqual() : boolean

Property Value

System.Boolean . Value that is true if comparison tests in which the new value does not equal the current value are supported, or false if they are not.

This property is read-only.


ConstantDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a constant in a constant table.

Definition

Visual Basic .NET | Public Structure ConstantDescription
C# | public struct ConstantDescription
Managed C++ | public __value struct ConstantDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConstantDescription | Initializes a new instance of the ConstantDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Class | Retrieves or sets the parameter class of the constant.
Columns | Retrieves or sets a value that indicates the number of columns.
DefaultData | Retrieves or sets a reference to the default value for the constant.
Elements | Retrieves or sets the number of elements in the array.
Name | Retrieves or sets the name of the constant.
ParameterType | Retrieves or sets the parameter type of the constant.
RegisterCount | Retrieves or sets the number of registers that contain data.
RegisterIndex | Retrieves or sets the index of the constant in the constant table.
RegisterSet | Retrieves or sets the constant data type.
Rows | Retrieves or sets a value that indicates the number of rows.
StructMembers | Retrieves or sets a value that indicates the number of structure member sub-parameters.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ConstantTable.GetConstantDescription
  • ConstantTableDescription


ConstantDescription.ConstantDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.ConstantDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConstantDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConstantDescription();
Managed C++ | public: ConstantDescription();
JScript .NET | public function ConstantDescription();


ConstantDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConstantDescription.Class

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.Class Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the parameter class of the constant.

Definition

Visual Basic .NET | Public Property Class As ParameterClass
C# | public ParameterClass Class { get; set; }
Managed C++ public: __property ParameterClass get_Class();
public: __property void set_Class(ParameterClass);
JScript .NET public function get Class() : ParameterClass
public function set Class(ParameterClass);

Property Value

Microsoft.DirectX.Direct3D.ParameterClass . The ParameterClass object of the constant.

This property is read/write.


ConstantDescription.Columns

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.Columns Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that indicates the number of columns.

Definition

Visual Basic .NET | Public Property Columns As Integer
C# | public int Columns { get; set; }
Managed C++ public: __property int get_Columns();
public: __property void set_Columns(int);
JScript .NET public function get Columns() : int
public function set Columns(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of columns.

This property is read/write.


ConstantDescription.DefaultData

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.DefaultData Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a reference to the default value for the constant.

Definition

Visual Basic .NET | Public Property DefaultData As GraphicsStream
C# | public GraphicsStream DefaultData { get; set; }
Managed C++ public: __property GraphicsStream* get_DefaultData();
public: __property void set_DefaultData(GraphicsStream*);
JScript .NET public function get DefaultData() : GraphicsStream
public function set DefaultData(GraphicsStream);

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the default value for the constant.

This property is read/write.


ConstantDescription.Elements

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.Elements Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of elements in the array.

Definition

Visual Basic .NET | Public Property Elements As Integer
C# | public int Elements { get; set; }
Managed C++ public: __property int get_Elements();
public: __property void set_Elements(int);
JScript .NET public function get Elements() : int
public function set Elements(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of elements in the array.

This property is read/write.


ConstantDescription.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the name of the constant.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String . A String Leave Site object that contains the name of the constant.

This property is read/write.


ConstantDescription.ParameterType

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.ParameterType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the parameter type of the constant.

Definition

Visual Basic .NET | Public Property ParameterType As ParameterType
C# | public ParameterType ParameterType { get; set; }
Managed C++ public: __property ParameterType get_ParameterType();
public: __property void set_ParameterType(ParameterType);
JScript .NET public function get ParameterType() : ParameterType
public function set ParameterType(ParameterType);

Property Value

Microsoft.DirectX.Direct3D.ParameterType . A ParameterType instance that indicates the parameter type of the constant.

This property is read/write.


ConstantDescription.RegisterCount

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.RegisterCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of registers that contain data.

Definition

Visual Basic .NET | Public Property RegisterCount As Integer
C# | public int RegisterCount { get; set; }
Managed C++ public: __property int get_RegisterCount();
public: __property void set_RegisterCount(int);
JScript .NET public function get RegisterCount() : int
public function set RegisterCount(int);

Property Value

System.Int32 . An Int32 Leave Site object that indicates the number of registers that contain data.

This property is read/write.


ConstantDescription.RegisterIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.RegisterIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the index of the constant in the constant table.

Definition

Visual Basic .NET | Public Property RegisterIndex As Integer
C# | public int RegisterIndex { get; set; }
Managed C++ public: __property int get_RegisterIndex();
public: __property void set_RegisterIndex(int);
JScript .NET public function get RegisterIndex() : int
public function set RegisterIndex(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the index of the constant in the ConstantTable.

This property is read/write.

Remarks

The constant table index is zero-based.


ConstantDescription.RegisterSet

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.RegisterSet Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the constant data type.

Definition

Visual Basic .NET | Public Property RegisterSet As RegisterSet
C# | public RegisterSet RegisterSet { get; set; }
Managed C++ public: __property RegisterSet get_RegisterSet();
public: __property void set_RegisterSet(RegisterSet);
JScript .NET public function get RegisterSet() : RegisterSet
public function set RegisterSet(RegisterSet);

Property Value

Microsoft.DirectX.Direct3D.RegisterSet . A RegisterSet instance that indicates the constant data type.

This property is read/write.


ConstantDescription.Rows

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.Rows Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that indicates the number of rows.

Definition

Visual Basic .NET | Public Property Rows As Integer
C# | public int Rows { get; set; }
Managed C++ public: __property int get_Rows();
public: __property void set_Rows(int);
JScript .NET public function get Rows() : int
public function set Rows(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of rows.

This property is read/write.


ConstantDescription.StructMembers

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantDescription.StructMembers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that indicates the number of structure member sub-parameters.

Definition

Visual Basic .NET | Public Property StructMembers As Integer
C# | public int StructMembers { get; set; }
Managed C++ public: __property int get_StructMembers();
public: __property void set_StructMembers(int);
JScript .NET public function get StructMembers() : int
public function set StructMembers(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of structure member sub-parameters.

This property is read/write.


ConstantTableDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTableDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the constant table.

Definition

Visual Basic .NET | Public Structure ConstantTableDescription
C# | public struct ConstantTableDescription
Managed C++ | public __value struct ConstantTableDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConstantTableDescription | Initializes a new instance of the ConstantTableDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Constants | Retrieves or sets the number of constants in the constant table.
Creator | Retrieves or sets the name of the constant table creator.
Version | Retrieves or sets a value that indicates the shader version of the constant table.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ConstantDescription


ConstantTableDescription.ConstantTableDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTableDescription.ConstantTableDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ConstantTableDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConstantTableDescription();
Managed C++ | public: ConstantTableDescription();
JScript .NET | public function ConstantTableDescription();


ConstantTableDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTableDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConstantTableDescription.Constants

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTableDescription.Constants Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of constants in the constant table.

Definition

Visual Basic .NET | Public Property Constants As Integer
C# | public int Constants { get; set; }
Managed C++ public: __property int get_Constants();
public: __property void set_Constants(int);
JScript .NET public function get Constants() : int
public function set Constants(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of constants in the ConstantTable.

This property is read/write.


ConstantTableDescription.Creator

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTableDescription.Creator Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the name of the constant table creator.

Definition

Visual Basic .NET | Public Property Creator As String
C# | public string Creator { get; set; }
Managed C++ public: __property String* get_Creator();
public: __property void set_Creator(String*);
JScript .NET public function get Creator() : String
public function set Creator(String);

Property Value

System.String . A String Leave Site object that contains the name of the constant table creator.

This property is read/write.


ConstantTableDescription.Version

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantTableDescription.Version Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that indicates the shader version of the constant table.

Definition

Visual Basic .NET | Public Property Version As Integer
C# | public int Version { get; set; }
Managed C++ public: __property int get_Version();
public: __property void set_Version(int);
JScript .NET public function get Version() : int
public function set Version(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the shader version of the constant table.

This property is read/write.


CubeTextureRequirements

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTextureRequirements Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains cube texture creation parameters.

Definition

Visual Basic .NET | Public Structure CubeTextureRequirements
C# | public struct CubeTextureRequirements
Managed C++ | public __value struct CubeTextureRequirements
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CubeTextureRequirements | Initializes a new instance of the CubeTextureRequirements class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets the desired pixel format.
NumberMipLevels | Retrieves or sets the number of mipmap levels for a cube texture.
Size | Retrieves or sets the size of a cube texture.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CubeTextureRequirements.CubeTextureRequirements()

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTextureRequirements.CubeTextureRequirements Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTextureRequirements class.

Definition

Visual Basic .NET | Public Sub New()
C# | public CubeTextureRequirements();
Managed C++ | public: CubeTextureRequirements();
JScript .NET | public function CubeTextureRequirements();

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTextureRequirements.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTextureRequirements.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CubeTextureRequirements.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTextureRequirements.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the desired pixel format.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . A Format value that specifies the pixel format to set or retrieve.

This property is read/write.


CubeTextureRequirements.NumberMipLevels

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTextureRequirements.NumberMipLevels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of mipmap levels for a cube texture.

Definition

Visual Basic .NET | Public Property NumberMipLevels As Integer
C# | public int NumberMipLevels { get; set; }
Managed C++ public: __property int get_NumberMipLevels();
public: __property void set_NumberMipLevels(int);
JScript .NET public function get NumberMipLevels() : int
public function set NumberMipLevels(int);

Property Value

System.Int32 . Integer value that represents the mipmap levels to set or retrieve.

This property is read/write.


CubeTextureRequirements.Size

Microsoft DirectX 9.0 SDK Update (October 2004)

CubeTextureRequirements.Size Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the size of a cube texture.

Definition

Visual Basic .NET | Public Property Size As Integer
C# | public int Size { get; set; }
Managed C++ public: __property int get_Size();
public: __property void set_Size(int);
JScript .NET public function get Size() : int
public function set Size(int);

Property Value

System.Int32 . Integer value that represents the height and width of the cube texture, in pixels.

This property is read/write.


CursorCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

CursorCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Indicates the hardware support that is available for cursors.

Definition

Visual Basic .NET | Public Structure CursorCaps
C# | public struct CursorCaps
Managed C++ | public __value struct CursorCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsColor | Retrieves a value that indicates that a full-color cursor is supported in hardware.
SupportsLowResolution | Retrieves a value that indicates that a full-color cursor is supported in both high-resolution and low-resolution modes.

Remarks

Microsoft® DirectX® 9.0 does not define alpha-blending cursor capabilities.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CursorCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CursorCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CursorCaps.SupportsColor

Microsoft DirectX 9.0 SDK Update (October 2004)

CursorCaps.SupportsColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates that a full-color cursor is supported in hardware.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsColor As Boolean
C# | public bool SupportsColor { get; }
Managed C++ | public: __property bool get_SupportsColor();
JScript .NET | public function get SupportsColor() : boolean

Property Value

System.Boolean . Value that is true if a full-color cursor is supported in hardware, or false otherwise.

This property is read-only.

Remarks

Specifically, this flag indicates that the driver supports at least a hardware color cursor in high-resolution modes (with scan lines greater than or equal to 400).


CursorCaps.SupportsLowResolution

Microsoft DirectX 9.0 SDK Update (October 2004)

CursorCaps.SupportsLowResolution Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates that a full-color cursor is supported in both high-resolution and low-resolution modes.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsLowResolution As Boolean
C# | public bool SupportsLowResolution { get; }
Managed C++ | public: __property bool get_SupportsLowResolution();
JScript .NET | public function get SupportsLowResolution() : boolean

Property Value

System.Boolean . Value that is true if a full-color cursor is supported in both high-resolution and low-resolution modes, or false otherwise.

This property is read-only.


DeclarationTypeCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Indicates the type of data formats that are supported in a vertex declaration.

Definition

Visual Basic .NET | Public Structure DeclarationTypeCaps
C# | public struct DeclarationTypeCaps
Managed C++ | public __value struct DeclarationTypeCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDec3N | Indicates that a 3-dimension signed 10 10 10 format is supported for vertex declarations.
SupportsFloat16Four | Indicates that a 4-dimension 16-bit floating-point numbers format is supported for vertex declarations.
SupportsFloat16Two | Indicates that a 2-dimension 16-bit floating-point numbers format is supported for vertex declarations.
SupportsShort2N | Indicates that a normalized, 2-D signed short format is supported for vertex declarations.
SupportsShort4N | Indicates that a normalized, 4-D signed short format is supported for vertex declarations.
SupportsUByte4 | Indicates that a 4-dimension unsigned byte format is supported for vertex declarations.
SupportsUByte4N | Indicates that a normalized, 4-dimension unsigned byte format is supported for vertex declarations.
SupportsUDec3 | Indicates that a 3-dimension unsigned 10 10 10 format is supported for vertex declarations.
SupportsUShort2N | Indicates that a normalized, 2-dimension unsigned short format is supported for vertex declarations.
SupportsUShort4N | Indicates that a normalized 4-D unsigned short format is supported for vertex declarations.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeclarationTypeCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeclarationTypeCaps.SupportsDec3N

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsDec3N Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a 3-dimension signed 10 10 10 format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDec3N As Boolean
C# | public bool SupportsDec3N { get; }
Managed C++ | public: __property bool get_SupportsDec3N();
JScript .NET | public function get SupportsDec3N() : boolean

Property Value

System.Boolean . Value that is true if a 3-dimension signed 10 10 10 format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (v[0]/511.0, v[1]/511.0, v[2]/511.0, 1).


DeclarationTypeCaps.SupportsFloat16Four

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsFloat16Four Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a 4-dimension 16-bit floating-point numbers format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFloat16Four As Boolean
C# | public bool SupportsFloat16Four { get; }
Managed C++ | public: __property bool get_SupportsFloat16Four();
JScript .NET | public function get SupportsFloat16Four() : boolean

Property Value

System.Boolean . Value that is true if a 4-dimension 16-bit floating-point numbers format is supported for vertex declarations, or false if it is not.

This property is read-only.


DeclarationTypeCaps.SupportsFloat16Two

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsFloat16Two Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a 2-dimension 16-bit floating-point numbers format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFloat16Two As Boolean
C# | public bool SupportsFloat16Two { get; }
Managed C++ | public: __property bool get_SupportsFloat16Two();
JScript .NET | public function get SupportsFloat16Two() : boolean

Property Value

System.Boolean . Value that is true if a 2-dimension 16-bit floating-point numbers format is supported for vertex declarations, or false if it is not.

This property is read-only.


DeclarationTypeCaps.SupportsShort2N

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsShort2N Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a normalized, 2-D signed short format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsShort2N As Boolean
C# | public bool SupportsShort2N { get; }
Managed C++ | public: __property bool get_SupportsShort2N();
JScript .NET | public function get SupportsShort2N() : boolean

Property Value

System.Boolean . Value that is true if a 2-D signed short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/32767.0, second byte/32767.0, 0, 1).


DeclarationTypeCaps.SupportsShort4N

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsShort4N Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a normalized, 4-D signed short format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsShort4N As Boolean
C# | public bool SupportsShort4N { get; }
Managed C++ | public: __property bool get_SupportsShort4N();
JScript .NET | public function get SupportsShort4N() : boolean

Property Value

System.Boolean . Value that is true if a normalized, 4-D signed short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/65535.0, second byte/65535.0, third byte/65535.0, fourth byte/65535.0).


DeclarationTypeCaps.SupportsUByte4

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsUByte4 Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a 4-dimension unsigned byte format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsUByte4 As Boolean
C# | public bool SupportsUByte4 { get; }
Managed C++ | public: __property bool get_SupportsUByte4();
JScript .NET | public function get SupportsUByte4() : boolean

Property Value

System.Boolean . Value that is true if a normalized, 4-dimension unsigned byte format is supported for vertex declarations, or false if it is not.

This property is read-only.


DeclarationTypeCaps.SupportsUByte4N

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsUByte4N Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a normalized, 4-dimension unsigned byte format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsUByte4N As Boolean
C# | public bool SupportsUByte4N { get; }
Managed C++ | public: __property bool get_SupportsUByte4N();
JScript .NET | public function get SupportsUByte4N() : boolean

Property Value

System.Boolean . Value that is true if a normalized, 4-dimension unsigned byte format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

Each of the four bytes is normalized by dividing by 255.0.


DeclarationTypeCaps.SupportsUDec3

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsUDec3 Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a 3-dimension unsigned 10 10 10 format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsUDec3 As Boolean
C# | public bool SupportsUDec3 { get; }
Managed C++ | public: __property bool get_SupportsUDec3();
JScript .NET | public function get SupportsUDec3() : boolean

Property Value

System.Boolean . Value that is true if a 3-dimension unsigned 10 10 10 format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (value, value, value, 1).


DeclarationTypeCaps.SupportsUShort2N

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsUShort2N Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a normalized, 2-dimension unsigned short format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsUShort2N As Boolean
C# | public bool SupportsUShort2N { get; }
Managed C++ | public: __property bool get_SupportsUShort2N();
JScript .NET | public function get SupportsUShort2N() : boolean

Property Value

System.Boolean . Value that is true if a normalized, 2-dimension unsigned short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/32767.0, second byte/32767.0, 0, 1).


DeclarationTypeCaps.SupportsUShort4N

Microsoft DirectX 9.0 SDK Update (October 2004)

DeclarationTypeCaps.SupportsUShort4N Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that a normalized 4-D unsigned short format is supported for vertex declarations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsUShort4N As Boolean
C# | public bool SupportsUShort4N { get; }
Managed C++ | public: __property bool get_SupportsUShort4N();
JScript .NET | public function get SupportsUShort4N() : boolean

Property Value

System.Boolean . Value that is true if a normalized 4-D unsigned short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/32767.0, second byte/32767.0, third byte/32767.0, fourth byte/32767.0).


DegenerateItems

Microsoft DirectX 9.0 SDK Update (October 2004)

DegenerateItems Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Indicates the index of patches and vertices that cause the PatchMesh.Validate method to fail.

Definition

Visual Basic .NET | Public Structure DegenerateItems
C# | public struct DegenerateItems
Managed C++ | public __value struct DegenerateItems
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DegenerateItems | Initializes a new instance of the DegenerateItems class.

Properties

Property | Description
DegeneratePatches | Retrieves the index of patches that cause the PatchMesh.Validate method to fail.
DegenerateVertices | Retrieves the index of vertices that cause the PatchMesh.Validate method to fail.

Remarks

The PatchMesh.Validate method returns an instance of this class.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DegenerateItems.DegenerateItems()

Microsoft DirectX 9.0 SDK Update (October 2004)

DegenerateItems.DegenerateItems Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DegenerateItems class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DegenerateItems();
Managed C++ | public: DegenerateItems();
JScript .NET | public function DegenerateItems();


DegenerateItems.DegeneratePatches

Microsoft DirectX 9.0 SDK Update (October 2004)

DegenerateItems.DegeneratePatches Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the index of patches that cause the PatchMesh.Validate method to fail.

Definition

Visual Basic .NET | Public ReadOnly Property DegeneratePatches As Integer
C# | public int DegeneratePatches { get; }
Managed C++ | public: __property int get_DegeneratePatches();
JScript .NET | public function get DegeneratePatches() : int

Property Value

System.Int32 . An Int32 Leave Site value that represents the index of patches that cause the PatchMesh.Validate method to fail.

This property is read-only.


DegenerateItems.DegenerateVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

DegenerateItems.DegenerateVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the index of vertices that cause the PatchMesh.Validate method to fail.

Definition

Visual Basic .NET | Public ReadOnly Property DegenerateVertices As Integer
C# | public int DegenerateVertices { get; }
Managed C++ | public: __property int get_DegenerateVertices();
JScript .NET | public function get DegenerateVertices() : int

Property Value

System.Int32 . An Int32 Leave Site value that represents the index of vertices that cause the PatchMesh.Validate method to fail.

This property is read-only.


DeviceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves device-specific information about a device.

Definition

Visual Basic .NET | Public Structure DeviceCaps
C# | public struct DeviceCaps
Managed C++ | public __value struct DeviceCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CanDrawSystemToNonLocal | Indicates whether the device supports copying from system memory textures to nonlocal video memory textures.
CanRenderAfterFlip | Indicates whether the device supports queue-rendering commands after a page flip.
CanStretchRectangleFromTextures | Indicates whether the device supports Device.StretchRectangle using a texture as the source.
SupportsAdaptiveTessellateNPatch | Indicates whether the device supports adaptive tessellation of N-patches.
SupportsAdaptiveTessellateRtPatch | Indicates whether the device supports adaptive tessellation of RT-patches.
SupportsDMapNPatch | Indicates whether the device supports displacement maps for N-patches.
SupportsDrawPrimitives2 | Indicates whether the device supports DrawPrimitives2.
SupportsDrawPrimitives2Ex | Indicates whether the device supports extended DrawPrimitives2.
SupportsDrawPrimitivesTransformedVertex | Indicates whether the device exports a hardware abstraction layer (HAL) that is aware of DrawPrimitives.
SupportsExecuteSystemMemory | Indicates whether the device uses executable buffers from system memory.
SupportsExecuteVideoMemory | Indicates whether the device uses executable buffers from video memory.
SupportsHardwareRasterization | Indicates whether the device has hardware acceleration for scene rasterization.
SupportsHardwareTransformAndLight | Indicates whether the device supports transformation and lighting in hardware.
SupportsNPatches | Indicates whether the device supports N-patches.
SupportsPreSampledDMapNPatch | Indicates whether the device supports presampled displacement maps for N-patches.
SupportsPureDevice | Indicates whether the device supports rasterization, transformations, lighting, and shading in hardware.
SupportsQuinticRtPatches | Indicates whether the device supports quintic cubic Bezier curves and B-splines.
SupportsRtPatches | Indicates whether the device supports rectangular and triangular patches.
SupportsRtPatchHandleZero | Indicates whether the hardware architecture does not require caching of any information and whether uncached (handle-zero) patches are drawn as efficiently as cached ones.
SupportsSeparateTextureMemories | Indicates whether the device is texturing from separate memory pools.
SupportsStreamOffset | Indicates whether the device supports stream offsets.
SupportsTextureNonLocalVideoMemory | Indicates whether the device can retrieve textures from nonlocal video memory.
SupportsTextureSystemMemory | Indicates whether the device can retrieve textures from system memory.
SupportsTextureVideoMemory | Indicates whether the device can retrieve textures from device memory.
SupportsTransformedVertexSystemMemory | Indicates whether the device uses buffers from system memory for transformed and lit vertices.
SupportsTransformedVertexVideoMemory | Indicates whether the device uses buffers from video memory for transformed and lit vertices.
VertexElementScanSharesStreamOffset | Indicates whether multiple vertex elements share the same offset in a stream.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String representation of the object.


DeviceCaps.CanDrawSystemToNonLocal

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.CanDrawSystemToNonLocal Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports copying from system memory textures to nonlocal video memory textures.

Definition

Visual Basic .NET | Public ReadOnly Property CanDrawSystemToNonLocal As Boolean
C# | public bool CanDrawSystemToNonLocal { get; }
Managed C++ | public: __property bool get_CanDrawSystemToNonLocal();
JScript .NET | public function get CanDrawSystemToNonLocal() : boolean

Property Value

System.Boolean . Value that is true if the device supports copying from system memory textures to nonlocal video memory textures, or false if it does not.

This property is read-only.


DeviceCaps.CanRenderAfterFlip

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.CanRenderAfterFlip Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports queue-rendering commands after a page flip.

Definition

Visual Basic .NET | Public ReadOnly Property CanRenderAfterFlip As Boolean
C# | public bool CanRenderAfterFlip { get; }
Managed C++ | public: __property bool get_CanRenderAfterFlip();
JScript .NET | public function get CanRenderAfterFlip() : boolean

Property Value

System.Boolean . Value that is true if the device supports queue-rendering commands after a page flip, or false if it does not.

This property is read-only.

Remarks

Applications do not change their behavior if this flag is set; this capability means that the device is relatively fast.


DeviceCaps.CanStretchRectangleFromTextures

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.CanStretchRectangleFromTextures Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports Device.StretchRectangle using a texture as the source.

Definition

Visual Basic .NET | Public ReadOnly Property CanStretchRectangleFromTextures As Boolean
C# | public bool CanStretchRectangleFromTextures { get; }
Managed C++ | public: __property bool get_CanStretchRectangleFromTextures();
JScript .NET | public function get CanStretchRectangleFromTextures() : boolean

Property Value

System.Boolean . Value that is true if the device supports Device.StretchRectangle using a texture as the source, or false if it does not.

This property is read-only.


DeviceCaps.SupportsAdaptiveTessellateNPatch

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsAdaptiveTessellateNPatch Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports adaptive tessellation of N-patches.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAdaptiveTessellateNPatch As Boolean
C# | public bool SupportsAdaptiveTessellateNPatch { get; }
Managed C++ | public: __property bool get_SupportsAdaptiveTessellateNPatch();
JScript .NET | public function get SupportsAdaptiveTessellateNPatch() : boolean

Property Value

System.Boolean . Value that is true if the device supports adaptive tessellation of N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsAdaptiveTessellateRtPatch

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsAdaptiveTessellateRtPatch Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports adaptive tessellation of RT-patches.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAdaptiveTessellateRtPatch As Boolean
C# | public bool SupportsAdaptiveTessellateRtPatch { get; }
Managed C++ | public: __property bool get_SupportsAdaptiveTessellateRtPatch();
JScript .NET | public function get SupportsAdaptiveTessellateRtPatch() : boolean

Property Value

System.Boolean . Value that is true if the device supports adaptive tessellation of RT-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsDMapNPatch

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsDMapNPatch Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports displacement maps for N-patches.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDMapNPatch As Boolean
C# | public bool SupportsDMapNPatch { get; }
Managed C++ | public: __property bool get_SupportsDMapNPatch();
JScript .NET | public function get SupportsDMapNPatch() : boolean

Property Value

System.Boolean . Value that is true if the device supports displacement maps for N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsDrawPrimitives2

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsDrawPrimitives2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports DrawPrimitives2.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDrawPrimitives2 As Boolean
C# | public bool SupportsDrawPrimitives2 { get; }
Managed C++ | public: __property bool get_SupportsDrawPrimitives2();
JScript .NET | public function get SupportsDrawPrimitives2() : boolean

Property Value

System.Boolean . Value that is true if the device supports DrawPrimitives2, or false if it does not.

This property is read-only.


DeviceCaps.SupportsDrawPrimitives2Ex

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsDrawPrimitives2Ex Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports extended DrawPrimitives2.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDrawPrimitives2Ex As Boolean
C# | public bool SupportsDrawPrimitives2Ex { get; }
Managed C++ | public: __property bool get_SupportsDrawPrimitives2Ex();
JScript .NET | public function get SupportsDrawPrimitives2Ex() : boolean

Property Value

System.Boolean . Value that is true if the device supports extended DrawPrimitives2, or false if it does not.

This property is read-only.

Remarks

DrawPrimitives2 is a Microsoft® DirectX® 7.0 method.


DeviceCaps.SupportsDrawPrimitivesTransformedVertex

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsDrawPrimitivesTransformedVertex Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device exports a hardware abstraction layer (HAL) that is aware of DrawPrimitives.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDrawPrimitivesTransformedVertex As Boolean
C# | public bool SupportsDrawPrimitivesTransformedVertex { get; }
Managed C++ | public: __property bool get_SupportsDrawPrimitivesTransformedVertex();
JScript .NET | public function get SupportsDrawPrimitivesTransformedVertex() : boolean

Property Value

System.Boolean . Value that is true if the device exports a HAL that is aware of DrawPrimitives, or false if it does not.

This property is read-only.


DeviceCaps.SupportsExecuteSystemMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsExecuteSystemMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device uses executable buffers from system memory.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsExecuteSystemMemory As Boolean
C# | public bool SupportsExecuteSystemMemory { get; }
Managed C++ | public: __property bool get_SupportsExecuteSystemMemory();
JScript .NET | public function get SupportsExecuteSystemMemory() : boolean

Property Value

System.Boolean . Value that is true if the device uses executable buffers from system memory, or false if it does not.

This property is read-only.

Remarks

This property is provided for legacy compatibility. Executable buffers are a Microsoft® DirectX® 5.0 feature.


DeviceCaps.SupportsExecuteVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsExecuteVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device uses executable buffers from video memory.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsExecuteVideoMemory As Boolean
C# | public bool SupportsExecuteVideoMemory { get; }
Managed C++ | public: __property bool get_SupportsExecuteVideoMemory();
JScript .NET | public function get SupportsExecuteVideoMemory() : boolean

Property Value

System.Boolean . Value that is true if the device uses executable buffers from video memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsHardwareRasterization

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsHardwareRasterization Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device has hardware acceleration for scene rasterization.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsHardwareRasterization As Boolean
C# | public bool SupportsHardwareRasterization { get; }
Managed C++ | public: __property bool get_SupportsHardwareRasterization();
JScript .NET | public function get SupportsHardwareRasterization() : boolean

Property Value

System.Boolean . Value that is true if the device has hardware acceleration for scene rasterization, or false if it does not.

This property is read-only.


DeviceCaps.SupportsHardwareTransformAndLight

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsHardwareTransformAndLight Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Check for Shader Support

Indicates whether the device supports transformation and lighting in hardware.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsHardwareTransformAndLight As Boolean
C# | public bool SupportsHardwareTransformAndLight { get; }
Managed C++ | public: __property bool get_SupportsHardwareTransformAndLight();
JScript .NET | public function get SupportsHardwareTransformAndLight() : boolean

Property Value

System.Boolean . Value that is true if the device supports transformation and lighting in hardware, or false if it does not.

This property is read-only.

How Do I...?

Check for Shader Support

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Microsoft® Direct3D® allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

              [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


DeviceCaps.SupportsNPatches

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsNPatches Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports N-patches.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNPatches As Boolean
C# | public bool SupportsNPatches { get; }
Managed C++ | public: __property bool get_SupportsNPatches();
JScript .NET | public function get SupportsNPatches() : boolean

Property Value

System.Boolean . Value that is true if the device supports N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsPreSampledDMapNPatch

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsPreSampledDMapNPatch Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports presampled displacement maps for N-patches.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPreSampledDMapNPatch As Boolean
C# | public bool SupportsPreSampledDMapNPatch { get; }
Managed C++ | public: __property bool get_SupportsPreSampledDMapNPatch();
JScript .NET | public function get SupportsPreSampledDMapNPatch() : boolean

Property Value

System.Boolean . Value that is true if the device supports presampled displacement maps for N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsPureDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsPureDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports rasterization, transformations, lighting, and shading in hardware.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPureDevice As Boolean
C# | public bool SupportsPureDevice { get; }
Managed C++ | public: __property bool get_SupportsPureDevice();
JScript .NET | public function get SupportsPureDevice() : boolean

Property Value

System.Boolean . Value that is true if the device supports rasterization, transformations, lighting, and shading in hardware, or false if it does not.

This property is read-only.


DeviceCaps.SupportsQuinticRtPatches

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsQuinticRtPatches Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports quintic cubic Bezier curves and B-splines.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsQuinticRtPatches As Boolean
C# | public bool SupportsQuinticRtPatches { get; }
Managed C++ | public: __property bool get_SupportsQuinticRtPatches();
JScript .NET | public function get SupportsQuinticRtPatches() : boolean

Property Value

System.Boolean . Value that is true if the device supports quintic cubic Bezier curves and B-splines, or false if it does not.

This property is read-only.


DeviceCaps.SupportsRtPatches

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsRtPatches Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports rectangular and triangular patches.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsRtPatches As Boolean
C# | public bool SupportsRtPatches { get; }
Managed C++ | public: __property bool get_SupportsRtPatches();
JScript .NET | public function get SupportsRtPatches() : boolean

Property Value

System.Boolean . Value that is true if the device supports rectangular and triangular patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsRtPatchHandleZero

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsRtPatchHandleZero Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the hardware architecture does not require caching of any information and whether uncached (handle-zero) patches are drawn as efficiently as cached ones.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsRtPatchHandleZero As Boolean
C# | public bool SupportsRtPatchHandleZero { get; }
Managed C++ | public: __property bool get_SupportsRtPatchHandleZero();
JScript .NET | public function get SupportsRtPatchHandleZero() : boolean

Property Value

System.Boolean . Value that is true if the hardware architecture does not require caching of any information, or false if it does.

This property is read-only.

Remarks

Note that a handle-zero patch can always be drawn, regardless of whether this capability is set.


DeviceCaps.SupportsSeparateTextureMemories

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsSeparateTextureMemories Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device is texturing from separate memory pools.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSeparateTextureMemories As Boolean
C# | public bool SupportsSeparateTextureMemories { get; }
Managed C++ | public: __property bool get_SupportsSeparateTextureMemories();
JScript .NET | public function get SupportsSeparateTextureMemories() : boolean

Property Value

System.Boolean . Value that is true if the device is texturing from separate memory pools, or false if it is not.

This property is read-only.


DeviceCaps.SupportsStreamOffset

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsStreamOffset Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device supports stream offsets.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsStreamOffset As Boolean
C# | public bool SupportsStreamOffset { get; }
Managed C++ | public: __property bool get_SupportsStreamOffset();
JScript .NET | public function get SupportsStreamOffset() : boolean

Property Value

System.Boolean . Value that is true if the device supports stream offsets, or false if it does not.

This property is read-only.


DeviceCaps.SupportsTextureNonLocalVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsTextureNonLocalVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device can retrieve textures from nonlocal video memory.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureNonLocalVideoMemory As Boolean
C# | public bool SupportsTextureNonLocalVideoMemory { get; }
Managed C++ | public: __property bool get_SupportsTextureNonLocalVideoMemory();
JScript .NET | public function get SupportsTextureNonLocalVideoMemory() : boolean

Property Value

System.Boolean . Value that is true if the device can retrieve textures from nonlocal video memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsTextureSystemMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsTextureSystemMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device can retrieve textures from system memory.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureSystemMemory As Boolean
C# | public bool SupportsTextureSystemMemory { get; }
Managed C++ | public: __property bool get_SupportsTextureSystemMemory();
JScript .NET | public function get SupportsTextureSystemMemory() : boolean

Property Value

System.Boolean . Value that is true if the device can retrieve textures from system memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsTextureVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsTextureVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device can retrieve textures from device memory.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureVideoMemory As Boolean
C# | public bool SupportsTextureVideoMemory { get; }
Managed C++ | public: __property bool get_SupportsTextureVideoMemory();
JScript .NET | public function get SupportsTextureVideoMemory() : boolean

Property Value

System.Boolean . Value that is true if the device can retrieve textures from device memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsTransformedVertexSystemMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsTransformedVertexSystemMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device uses buffers from system memory for transformed and lit vertices.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTransformedVertexSystemMemory As Boolean
C# | public bool SupportsTransformedVertexSystemMemory { get; }
Managed C++ | public: __property bool get_SupportsTransformedVertexSystemMemory();
JScript .NET | public function get SupportsTransformedVertexSystemMemory() : boolean

Property Value

System.Boolean . Value that is true if the device uses buffers from system memory for transformed and lit vertices, or false if it does not.

This property is read-only.


DeviceCaps.SupportsTransformedVertexVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.SupportsTransformedVertexVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device uses buffers from video memory for transformed and lit vertices.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTransformedVertexVideoMemory As Boolean
C# | public bool SupportsTransformedVertexVideoMemory { get; }
Managed C++ | public: __property bool get_SupportsTransformedVertexVideoMemory();
JScript .NET | public function get SupportsTransformedVertexVideoMemory() : boolean

Property Value

System.Boolean . Value that is true if the device uses buffers from video memory for transformed and lit vertices, or false if it does not.

This property is read-only.


DeviceCaps.VertexElementScanSharesStreamOffset

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.VertexElementScanSharesStreamOffset Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether multiple vertex elements share the same offset in a stream.

Definition

Visual Basic .NET | Public ReadOnly Property VertexElementScanSharesStreamOffset As Boolean
C# | public bool VertexElementScanSharesStreamOffset { get; }
Managed C++ | public: __property bool get_VertexElementScanSharesStreamOffset();
JScript .NET | public function get VertexElementScanSharesStreamOffset() : boolean

Property Value

System.Boolean . Value that is true if multiple vertex elements share the same offset in a stream, or false if they do not.

This property is read-only.

Remarks

For multiple vertex elements to share the same offset in a stream, the vertex declaration must not have an element that contains DeclarationUsage.Position.


DeviceCreationParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the creation parameters for a device.

Definition

Visual Basic .NET | Public Structure DeviceCreationParameters
C# | public struct DeviceCreationParameters
Managed C++ | public __value struct DeviceCreationParameters
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceCreationParameters | Initializes a new instance of the DeviceCreationParameters class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdapterOrdinal | Retrieves an ordinal number that denotes the display adapter.
Behavior | Retrieves a BehaviorFlags structure with properties that indicate the global behavior of a device.
DeviceType | Retrieves a DeviceType instance that denotes the amount of emulated functionality for the device.
FocusWindow | Retrieves the window to which focus belongs for the current device.
FocusWindowHandle | Retrieves a pointer to the window to which focus belongs for the current device.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceCreationParameters.DeviceCreationParameters()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters.DeviceCreationParameters Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceCreationParameters class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceCreationParameters();
Managed C++ | public: DeviceCreationParameters();
JScript .NET | public function DeviceCreationParameters();


DeviceCreationParameters.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String representation of the object.


DeviceCreationParameters.AdapterOrdinal

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters.AdapterOrdinal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an ordinal number that denotes the display adapter.

Definition

Visual Basic .NET | Public ReadOnly Property AdapterOrdinal As Integer
C# | public int AdapterOrdinal { get; }
Managed C++ | public: __property int get_AdapterOrdinal();
JScript .NET | public function get AdapterOrdinal() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates an ordinal number that denotes the display adapter.

This property is read-only.

Remarks

Use this ordinal as the adapter parameter for any of the Manager methods.

Note that different instances of Microsoft® Direct3D® objects can use different ordinals. For example, adapters can enter or leave a system when users add or remove monitors from a multiple-monitor system, or when they hot-swap a laptop. Consequently, this ordinal should be used only in a Direct3D instance known to be valid, such as the Direct3D object that created this Device.


DeviceCreationParameters.Behavior

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters.Behavior Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a BehaviorFlags structure with properties that indicate the global behavior of a device.

Definition

Visual Basic .NET | Public ReadOnly Property Behavior As BehaviorFlags
C# | public BehaviorFlags Behavior { get; }
Managed C++ | public: __property BehaviorFlags get_Behavior();
JScript .NET | public function get Behavior() : BehaviorFlags

Property Value

Microsoft.DirectX.Direct3D.BehaviorFlags . A BehaviorFlags structure with properties that indicate the global behavior of a device.

This property is read-only.


DeviceCreationParameters.DeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters.DeviceType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a DeviceType instance that denotes the amount of emulated functionality for the device.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
Managed C++ | public: __property DeviceType get_DeviceType();
JScript .NET | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.Direct3D.DeviceType . A DeviceType instance that denotes the amount of emulated functionality for the device.

This property is read-only.

Remarks

The value of these parameters mirrors the value passed to the Device constructor call that created the device.


DeviceCreationParameters.FocusWindow

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters.FocusWindow Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the window to which focus belongs for the current device.

Definition

Visual Basic .NET | Public ReadOnly Property FocusWindow As Control
C# | public Control FocusWindow { get; }
Managed C++ | public: __property Control* get_FocusWindow();
JScript .NET | public function get FocusWindow() : Control

Property Value

System.Windows.Forms.Control . A Control Leave Site instance that represents the window to which focus belongs for the device.

This property is read-only.


DeviceCreationParameters.FocusWindowHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCreationParameters.FocusWindowHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a pointer to the window to which focus belongs for the current device.

Definition

Visual Basic .NET | Public ReadOnly Property FocusWindowHandle As IntPtr
C# | public IntPtr FocusWindowHandle { get; }
Managed C++ | public: __property IntPtr get_FocusWindowHandle();
JScript .NET | public function get FocusWindowHandle() : IntPtr

Property Value

System.IntPtr . An IntPtr Leave Site value that points to the window to which focus belongs for the device.

This property is read-only.


DisplacementParameter

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains mesh geometry displacement parameters.

Definition

Visual Basic .NET | Public Structure DisplacementParameter
C# | public struct DisplacementParameter
Managed C++ | public __value struct DisplacementParameter
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DisplacementParameter | Initializes a new instance of the DisplacementParameter class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
LevelOfDetailBias | Retrieves or sets the level-of-detail bias value.
MagFilter | Retrieves or sets the texture filter to use in magnification.
MinFilter | Retrieves or sets the texture filter to use in minification.
MipFilter | Retrieves or sets the texture filter for mipmapping.
Texture | Retrieves or sets a texture for displacement mapping.
Wrap | Retrieves or sets the texture address wrap mode.

Remarks

Displacement maps can be 2-D textures only. Mipmapping is ignored for nonadaptive tessellation.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisplacementParameter.DisplacementParameter()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.DisplacementParameter Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DisplacementParameter class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DisplacementParameter();
Managed C++ | public: DisplacementParameter();
JScript .NET | public function DisplacementParameter();


DisplacementParameter.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DisplacementParameter.LevelOfDetailBias

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.LevelOfDetailBias Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the level-of-detail bias value.

Definition

Visual Basic .NET | Public Property LevelOfDetailBias As Integer
C# | public int LevelOfDetailBias { get; set; }
Managed C++ public: __property int get_LevelOfDetailBias();
public: __property void set_LevelOfDetailBias(int);
JScript .NET public function get LevelOfDetailBias() : int
public function set LevelOfDetailBias(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the level-of-detail bias value.

This property is read/write.


DisplacementParameter.MagFilter

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.MagFilter Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture filter to use in magnification.

Definition

Visual Basic .NET | Public Property MagFilter As TextureFilter
C# | public TextureFilter MagFilter { get; set; }
Managed C++ public: __property TextureFilter get_MagFilter();
public: __property void set_MagFilter(TextureFilter);
JScript .NET public function get MagFilter() : TextureFilter
public function set MagFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter . A TextureFilter instance that represents the filter to use in magnification.

This property is read/write.


DisplacementParameter.MinFilter

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.MinFilter Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture filter to use in minification.

Definition

Visual Basic .NET | Public Property MinFilter As TextureFilter
C# | public TextureFilter MinFilter { get; set; }
Managed C++ public: __property TextureFilter get_MinFilter();
public: __property void set_MinFilter(TextureFilter);
JScript .NET public function get MinFilter() : TextureFilter
public function set MinFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter . A TextureFilter instance that represents the filter to use in minification.

This property is read/write.


DisplacementParameter.MipFilter

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.MipFilter Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture filter for mipmapping.

Definition

Visual Basic .NET | Public Property MipFilter As TextureFilter
C# | public TextureFilter MipFilter { get; set; }
Managed C++ public: __property TextureFilter get_MipFilter();
public: __property void set_MipFilter(TextureFilter);
JScript .NET public function get MipFilter() : TextureFilter
public function set MipFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter . A TextureFilter instance that represents the filters to use in mipmapping.

This property is read/write.

Remarks

Mipmapping is ignored for nonadaptive tessellation.


DisplacementParameter.Texture

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.Texture Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a texture for displacement mapping.

Definition

Visual Basic .NET | Public Property Texture As BaseTexture
C# | public BaseTexture Texture { get; set; }
Managed C++ public: __property BaseTexture* get_Texture();
public: __property void set_Texture(BaseTexture*);
JScript .NET public function get Texture() : BaseTexture
public function set Texture(BaseTexture);

Property Value

Microsoft.DirectX.Direct3D.BaseTexture . A BaseTexture instance that contains displacement data.

This property is read/write.

Remarks

Displacement maps can be 2-D textures only.


DisplacementParameter.Wrap

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplacementParameter.Wrap Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the texture address wrap mode.

Definition

Visual Basic .NET | Public Property Wrap As TextureAddress
C# | public TextureAddress Wrap { get; set; }
Managed C++ public: __property TextureAddress get_Wrap();
public: __property void set_Wrap(TextureAddress);
JScript .NET public function get Wrap() : TextureAddress
public function set Wrap(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress . A TextureAddress instance that represents the texture address wrap mode.

This property is read/write.

See Also

  • TextureAddress


DisplayMode

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayMode Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the display mode.

Definition

Visual Basic .NET | Public Structure DisplayMode
C# | public struct DisplayMode
Managed C++ | public __value struct DisplayMode
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DisplayMode | Initializes a new instance of the DisplayMode class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets the surface format of the display mode.
Height | Retrieves or sets the screen height, in pixels.
RefreshRate | Retrieves or sets the refresh rate.
Width | Retrieves or sets the screen width, in pixels.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisplayMode.DisplayMode()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayMode.DisplayMode Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DisplayMode class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DisplayMode();
Managed C++ | public: DisplayMode();
JScript .NET | public function DisplayMode();


DisplayMode.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayMode.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DisplayMode.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayMode.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the surface format of the display mode.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . A Format value that represents the surface format of the display mode.

This property is read/write.


DisplayMode.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayMode.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the screen height, in pixels.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the screen height in pixels.

This property is read/write.


DisplayMode.RefreshRate

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayMode.RefreshRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the refresh rate.

Definition

Visual Basic .NET | Public Property RefreshRate As Integer
C# | public int RefreshRate { get; set; }
Managed C++ public: __property int get_RefreshRate();
public: __property void set_RefreshRate(int);
JScript .NET public function get RefreshRate() : int
public function set RefreshRate(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the refresh rate.

This property is read/write.

Remarks

A value of 0 indicates the adapter default refresh rate.


DisplayMode.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayMode.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the screen width, in pixels.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . An Int32 Leave Site value that indicates the screen width in pixels.

This property is read/write.


DriverCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Indicates driver-specific capabilities.

Definition

Visual Basic .NET | Public Structure DriverCaps
C# | public struct DriverCaps
Managed C++ | public __value struct DriverCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CanAutoGenerateMipMap | Indicates that the driver is capable of automatically generating mipmaps.
CanCalibrateGamma | Indicates that the system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator.
CanManageResource | Indicates that the driver is capable of managing resources.
ReadScanLine | Indicates that the display hardware is capable of returning the current scan line.
SupportsAlphaFullscreenFlipOrDiscard | Indicates that the device can respect RenderStateManager.AlphaBlendEnable in full-screen mode while using the RenderStateManager.Flip or RenderStateManager.Discard swap effect.
SupportsCopyToSystemMemory | Indicates that the device can accelerate a memory copy from local video memory to system memory.
SupportsCopyToVideoMemory | Indicates that the device can accelerate a memory copy from system memory to local video memory.
SupportsDynamicTextures | Indicates whether the driver supports dynamic textures.
SupportsFullscreenGamma | Indicates whether the driver supports dynamic gamma-ramp adjustment in full-screen mode.
SupportsLinearToSrgbPresentation | Indicates whether the device can perform gamma correction from a windowed back buffer (that contains linear content) to an sRGB desktop.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DriverCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DriverCaps.CanAutoGenerateMipMap

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.CanAutoGenerateMipMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver is capable of automatically generating mipmaps.

Definition

Visual Basic .NET | Public ReadOnly Property CanAutoGenerateMipMap As Boolean
C# | public bool CanAutoGenerateMipMap { get; }
Managed C++ | public: __property bool get_CanAutoGenerateMipMap();
JScript .NET | public function get CanAutoGenerateMipMap() : boolean

Property Value

System.Boolean . Value that is true if the driver can automatically generate mipmaps, or false if it cannot.

This property is read-only.


DriverCaps.CanCalibrateGamma

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.CanCalibrateGamma Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator.

Definition

Visual Basic .NET | Public ReadOnly Property CanCalibrateGamma As Boolean
C# | public bool CanCalibrateGamma { get; }
Managed C++ | public: __property bool get_CanCalibrateGamma();
JScript .NET | public function get CanCalibrateGamma() : boolean

Property Value

System.Boolean . Value that is true if the system has a calibrator installed, or false if it does not.

This property is read-only.

Remarks

To invoke the calibrator when setting new gamma levels, set the param_Boolean_calibrate parameter to true during a call to Device.SetGammaRamp. Calibrating gamma ramps incurs some processing overhead and should not be used frequently.


DriverCaps.CanManageResource

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.CanManageResource Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the driver is capable of managing resources.

Definition

Visual Basic .NET | Public ReadOnly Property CanManageResource As Boolean
C# | public bool CanManageResource { get; }
Managed C++ | public: __property bool get_CanManageResource();
JScript .NET | public function get CanManageResource() : boolean

Property Value

System.Boolean . Value that is true if the driver can manage resources, or false if it cannot.

This property is read-only.

Remarks

On drivers that are capable of managing resources, Pool.Managed resources are managed by the driver.


DriverCaps.ReadScanLine

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.ReadScanLine Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the display hardware is capable of returning the current scan line.

Definition

Visual Basic .NET | Public ReadOnly Property ReadScanLine As Boolean
C# | public bool ReadScanLine { get; }
Managed C++ | public: __property bool get_ReadScanLine();
JScript .NET | public function get ReadScanLine() : boolean

Property Value

System.Boolean . Value that is true if the display hardware can return the current scan line, or false if it cannot.

This property is read-only.


DriverCaps.SupportsAlphaFullscreenFlipOrDiscard

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.SupportsAlphaFullscreenFlipOrDiscard Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device can respect RenderStateManager.AlphaBlendEnable in full-screen mode while using the RenderStateManager.Flip or RenderStateManager.Discard swap effect.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAlphaFullscreenFlipOrDiscard As Boolean
C# | public bool SupportsAlphaFullscreenFlipOrDiscard { get; }
Managed C++ | public: __property bool get_SupportsAlphaFullscreenFlipOrDiscard();
JScript .NET | public function get SupportsAlphaFullscreenFlipOrDiscard() : boolean

Property Value

System.Boolean . Value that is true if the device can respect RenderStateManager.AlphaBlendEnable in full-screen mode while using RenderStateManager.Flip or RenderStateManager.Discard, or false if it cannot.

This property is read-only.

Remarks

The RenderStateManager.Copy swap effect works regardless of whether this flag is set.

This property is relevant only when RenderStateManager.AlphaSourceBlend or RenderStateManager.AlphaDestinationBlend are set to DestinationAlpha, InvDestinationAlpha, DestinationColor, or InvDestinationColor.


DriverCaps.SupportsCopyToSystemMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.SupportsCopyToSystemMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device can accelerate a memory copy from local video memory to system memory.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsCopyToSystemMemory As Boolean
C# | public bool SupportsCopyToSystemMemory { get; }
Managed C++ | public: __property bool get_SupportsCopyToSystemMemory();
JScript .NET | public function get SupportsCopyToSystemMemory() : boolean

Property Value

System.Boolean . Value that is true if the device can accelerate a memory copy from local video memory to system memory, or false if it cannot.

This property is read-only.

Remarks

This capability guarantees that Device.GetRenderTargetData calls are hardware-accelerated. If this capability is absent, the call succeeds, but is slower.


DriverCaps.SupportsCopyToVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.SupportsCopyToVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device can accelerate a memory copy from system memory to local video memory.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsCopyToVideoMemory As Boolean
C# | public bool SupportsCopyToVideoMemory { get; }
Managed C++ | public: __property bool get_SupportsCopyToVideoMemory();
JScript .NET | public function get SupportsCopyToVideoMemory() : boolean

Property Value

System.Boolean . Value that is true if the device can accelerate a memory copy from system memory to local video memory, or false if it cannot.

This property is read-only.

Remarks

This capability guarantees that Device.UpdateSurface and Device.UpdateTexture calls are hardware-accelerated. If this capability is absent, the calls succeed, but are slower.


DriverCaps.SupportsDynamicTextures

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.SupportsDynamicTextures Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the driver supports dynamic textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDynamicTextures As Boolean
C# | public bool SupportsDynamicTextures { get; }
Managed C++ | public: __property bool get_SupportsDynamicTextures();
JScript .NET | public function get SupportsDynamicTextures() : boolean

Property Value

System.Boolean . Value that is true if the driver supports dynamic textures, or false if it does not.

This property is read-only.


DriverCaps.SupportsFullscreenGamma

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.SupportsFullscreenGamma Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the driver supports dynamic gamma-ramp adjustment in full-screen mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFullscreenGamma As Boolean
C# | public bool SupportsFullscreenGamma { get; }
Managed C++ | public: __property bool get_SupportsFullscreenGamma();
JScript .NET | public function get SupportsFullscreenGamma() : boolean

Property Value

System.Boolean . Value that is true if the driver supports dynamic gamma-ramp adjustment in full-screen mode, or false if it does not.

This property is read-only.


DriverCaps.SupportsLinearToSrgbPresentation

Microsoft DirectX 9.0 SDK Update (October 2004)

DriverCaps.SupportsLinearToSrgbPresentation Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates whether the device can perform gamma correction from a windowed back buffer (that contains linear content) to an sRGB desktop.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsLinearToSrgbPresentation As Boolean
C# | public bool SupportsLinearToSrgbPresentation { get; }
Managed C++ | public: __property bool get_SupportsLinearToSrgbPresentation();
JScript .NET | public function get SupportsLinearToSrgbPresentation() : boolean

Property Value

System.Boolean . Value that is true if the device can perform gamma correction from a windowed back buffer to an sRGB desktop, or false if it cannot.

This property is read-only.


EffectDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDefault Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Manages a default effect parameter.

Definition

Visual Basic .NET | Public Structure EffectDefault
C# | public struct EffectDefault
Managed C++ | public __value struct EffectDefault
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectDefault | Initializes a new instance of the EffectDefault class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Data | Retrieves or sets the effect parameter data.
ParameterName | Retrieves or sets the parameter name.
Type | Retrieves or sets the data type in the Data property.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectDefault.EffectDefault()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDefault.EffectDefault Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectDefault class.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectDefault();
Managed C++ | public: EffectDefault();
JScript .NET | public function EffectDefault();


EffectDefault.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDefault.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectDefault.Data

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDefault.Data Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the effect parameter data.

Definition

Visual Basic .NET | Public Property Data As Object
C# | public object Data { get; set; }
Managed C++ public: __property Object* get_Data();
public: __property void set_Data(Object*);
JScript .NET public function get Data() : Object
public function set Data(Object);

Property Value

System.Object . An Object Leave Site that contains the effect parameter data.

This property is read/write.

Remarks

The type of data passed into this property should match the EffectDefault.Type property.


EffectDefault.ParameterName

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDefault.ParameterName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the parameter name.

Definition

Visual Basic .NET | Public Property ParameterName As String
C# | public string ParameterName { get; set; }
Managed C++ public: __property String* get_ParameterName();
public: __property void set_ParameterName(String*);
JScript .NET public function get ParameterName() : String
public function set ParameterName(String);

Property Value

System.String . A String Leave Site object that contains the name of the parameter.

This property is read/write.


EffectDefault.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDefault.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the data type in the Data property.

Definition

Visual Basic .NET | Public Property Type As EffectDefaultType
C# | public EffectDefaultType Type { get; set; }
Managed C++ public: __property EffectDefaultType get_Type();
public: __property void set_Type(EffectDefaultType);
JScript .NET public function get Type() : EffectDefaultType
public function set Type(EffectDefaultType);

Property Value

Microsoft.DirectX.Direct3D.EffectDefaultType . An EffectDefaultType value that indicates the data type in the Data property.

This property is read/write.


EffectDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes an effect object.

Definition

Visual Basic .NET | Public Structure EffectDescription
C# | public struct EffectDescription
Managed C++ | public __value struct EffectDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectDescription | Initializes a new instance of the EffectDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Creator | Retrieves the name of the effect creator.
Functions | Retrieves the number of functions that can render the effect.
Parameters | Retrieves the number of parameters used for the effect.
Techniques | Retrieves the number of techniques that can render the effect.

Remarks

An effect object can contain multiple rendering techniques and parameters for the same effect.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectDescription.EffectDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.EffectDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectDescription();
Managed C++ | public: EffectDescription();
JScript .NET | public function EffectDescription();


EffectDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectDescription.Creator

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.Creator Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the name of the effect creator.

Definition

Visual Basic .NET | Public ReadOnly Property Creator As String
C# | public string Creator { get; }
Managed C++ | public: __property String* get_Creator();
JScript .NET | public function get Creator() : String

Property Value

System.String . A String Leave Site object that contains the name of the effect creator.

This property is read-only.


EffectDescription.Functions

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.Functions Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of functions that can render the effect.

Definition

Visual Basic .NET | Public ReadOnly Property Functions As Integer
C# | public int Functions { get; }
Managed C++ | public: __property int get_Functions();
JScript .NET | public function get Functions() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of functions that can render the effect.

This property is read-only.


EffectDescription.Parameters

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.Parameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of parameters used for the effect.

Definition

Visual Basic .NET | Public ReadOnly Property Parameters As Integer
C# | public int Parameters { get; }
Managed C++ | public: __property int get_Parameters();
JScript .NET | public function get Parameters() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of parameters used for the effect.

This property is read-only.


EffectDescription.Techniques

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.Techniques Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of techniques that can render the effect.

Definition

Visual Basic .NET | Public ReadOnly Property Techniques As Integer
C# | public int Techniques { get; }
Managed C++ | public: __property int get_Techniques();
JScript .NET | public function get Techniques() : int

Property Value

System.Int32 . An Int32 Leave Site value that indicates the number of techniques that can render the effect.

This property is read-only.


EffectInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInstance Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Manages a set of default effect parameters.

Definition

Visual Basic .NET | Public Structure EffectInstance
C# | public struct EffectInstance
Managed C++ | public __value struct EffectInstance
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectInstance | Initializes a new instance of the EffectInstance class.
GetDefaults | Retrieves the default effect parameters managed by the current EffectInstance.
SetDefaults | Sets the default effect parameters managed by the current EffectInstance.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
EffectFilename | Retrieves or sets the name of the effect file.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectInstance.EffectInstance()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInstance.EffectInstance Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectInstance class.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectInstance();
Managed C++ | public: EffectInstance();
JScript .NET | public function EffectInstance();


EffectInstance.GetDefaults()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInstance.GetDefaults Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default effect parameters managed by the current EffectInstance.

Definition

Visual Basic .NET | Public Function GetDefaults() As EffectDefault()
C# | public EffectDefault[] GetDefaults();
Managed C++ | public: EffectDefault GetDefaults() __gc[];
JScript .NET | public function GetDefaults() : EffectDefault[];

Return Value

Microsoft.DirectX.Direct3D.EffectDefault[]. Array of EffectDefault instances that represent the default effect parameters managed by the EffectInstance.


EffectInstance.SetDefaults(EffectDefault[])

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInstance.SetDefaults Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the default effect parameters managed by the current EffectInstance.

Definition

Visual Basic .NET Public Sub SetDefaults( _
ByVal value() As EffectDefault _
)
C# public void SetDefaults(
EffectDefault[] value
);
Managed C++ public: void SetDefaults(
EffectDefault value __gc[]
);
JScript .NET public function SetDefaults(
value : EffectDefault[]
);

Parameters

value Microsoft.DirectX.Direct3D.EffectDefault[]. Array of EffectDefault instances that represent the default effect parameters managed by the EffectInstance.


EffectInstance.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInstance.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectInstance.EffectFilename

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInstance.EffectFilename Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the name of the effect file.

Definition

Visual Basic .NET | Public Property EffectFilename As String
C# | public string EffectFilename { get; set; }
Managed C++ public: __property String* get_EffectFilename();
public: __property void set_EffectFilename(String*);
JScript .NET public function get EffectFilename() : String
public function set EffectFilename(String);

Property Value

System.String . A String Leave Site instance that contains the name of the effect file.

This property is read/write.


EventDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes an animation event.

Definition

Visual Basic .NET | Public Structure EventDescription
C# | public struct EventDescription
Managed C++ | public __value struct EventDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EventDescription | Initializes a new instance of an object.

Properties

Property | Description
Duration | Retrieves the duration of the event in global time.
Enable | Retrieves the enable flag.
EventType | Retrieves the event type as defined in EventType.
Position | Retrieves the track position for the event.
Speed | Retrieves the track speed for the event.
StartTime | Retrieves the start time of the event in global time.
Track | Retrieves the event track identifier.
TransitionType | Retrieves the transition style of the event as defined in TransitionType.
Weight | Retrieves the track weight for the event.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EventDescription.EventDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.EventDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of an object.

Definition

Visual Basic .NET | Public Sub New()
C# | public EventDescription();
Managed C++ | public: EventDescription();
JScript .NET | public function EventDescription();


EventDescription.Duration

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.Duration Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the duration of the event in global time.

Definition

Visual Basic .NET | Public ReadOnly Property Duration As Double
C# | public double Duration { get; }
Managed C++ | public: __property double get_Duration();
JScript .NET | public function get Duration() : double

Property Value

System.Double . Duration of the event.

This property is read-only.


EventDescription.Enable

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.Enable Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the enable flag.

Definition

Visual Basic .NET | Public ReadOnly Property Enable As Boolean
C# | public bool Enable { get; }
Managed C++ | public: __property bool get_Enable();
JScript .NET | public function get Enable() : boolean

Property Value

System.Boolean . Enable flag.

This property is read-only.


EventDescription.EventType

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.EventType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the event type as defined in EventType.

Definition

Visual Basic .NET | Public ReadOnly Property EventType As EventType
C# | public EventType EventType { get; }
Managed C++ | public: __property EventType get_EventType();
JScript .NET | public function get EventType() : EventType

Property Value

Microsoft.DirectX.Direct3D.EventType . Event type.

This property is read-only.


EventDescription.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the track position for the event.

Definition

Visual Basic .NET | Public ReadOnly Property Position As Double
C# | public double Position { get; }
Managed C++ | public: __property double get_Position();
JScript .NET | public function get Position() : double

Property Value

System.Double . Track position for the event.

This property is read-only.


EventDescription.Speed

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.Speed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the track speed for the event.

Definition

Visual Basic .NET | Public ReadOnly Property Speed As Single
C# | public float Speed { get; }
Managed C++ | public: __property float get_Speed();
JScript .NET | public function get Speed() : float

Property Value

System.Single . Track speed for the event.

This property is read-only.


EventDescription.StartTime

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.StartTime Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the start time of the event in global time.

Definition

Visual Basic .NET | Public ReadOnly Property StartTime As Double
C# | public double StartTime { get; }
Managed C++ | public: __property double get_StartTime();
JScript .NET | public function get StartTime() : double

Property Value

System.Double . Start time of the event.

This property is read-only.


EventDescription.Track

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.Track Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the event track identifier.

Definition

Visual Basic .NET | Public ReadOnly Property Track As Integer
C# | public int Track { get; }
Managed C++ | public: __property int get_Track();
JScript .NET | public function get Track() : int

Property Value

System.Int32 . Event track identifier.

This property is read-only.


EventDescription.TransitionType

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.TransitionType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the transition style of the event as defined in TransitionType.

Definition

Visual Basic .NET | Public ReadOnly Property TransitionType As TransitionType
C# | public TransitionType TransitionType { get; }
Managed C++ | public: __property TransitionType get_TransitionType();
JScript .NET | public function get TransitionType() : TransitionType

Property Value

Microsoft.DirectX.Direct3D.TransitionType . Transition style of the event.

This property is read-only.


EventDescription.Weight

Microsoft DirectX 9.0 SDK Update (October 2004)

EventDescription.Weight Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the track weight for the event.

Definition

Visual Basic .NET | Public ReadOnly Property Weight As Single
C# | public float Weight { get; }
Managed C++ | public: __property float get_Weight();
JScript .NET | public function get Weight() : float

Property Value

System.Single . Track weight for the event.

This property is read-only.


ExtendedMaterial

Microsoft DirectX 9.0 SDK Update (October 2004)

ExtendedMaterial Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Returns material information that is saved in DirectX (.x) files.

Definition

Visual Basic .NET | Public Structure ExtendedMaterial
C# | public struct ExtendedMaterial
Managed C++ | public __value struct ExtendedMaterial
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ExtendedMaterial | Initializes a new instance of the ExtendedMaterial class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Material3D | Retrieves or sets the Material structure that describes the material properties.
TextureFilename | Retrieves or sets a string that specifies the file name of the texture.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Tutorial 6: Using Meshes


ExtendedMaterial.ExtendedMaterial()

Microsoft DirectX 9.0 SDK Update (October 2004)

ExtendedMaterial.ExtendedMaterial Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ExtendedMaterial class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ExtendedMaterial();
Managed C++ | public: ExtendedMaterial();
JScript .NET | public function ExtendedMaterial();


ExtendedMaterial.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ExtendedMaterial.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ExtendedMaterial.Material3D

Microsoft DirectX 9.0 SDK Update (October 2004)

ExtendedMaterial.Material3D Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Material structure that describes the material properties.

Definition

Visual Basic .NET | Public Property Material3D As Material
C# | public Material Material3D { get; set; }
Managed C++ public: __property Material get_Material3D();
public: __property void set_Material3D(Material);
JScript .NET public function get Material3D() : Material
public function set Material3D(Material);

Property Value

Microsoft.DirectX.Direct3D.Material . A Material structure that describes the material properties.

This property is read/write.


ExtendedMaterial.TextureFilename

Microsoft DirectX 9.0 SDK Update (October 2004)

ExtendedMaterial.TextureFilename Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a string that specifies the file name of the texture.

Definition

Visual Basic .NET | Public Property TextureFilename As String
C# | public string TextureFilename { get; set; }
Managed C++ public: __property String* get_TextureFilename();
public: __property void set_TextureFilename(String*);
JScript .NET public function get TextureFilename() : String
public function set TextureFilename(String);

Property Value

System.String . A String Leave Site instance that specifies the file name of the texture.

This property is read/write.


FilterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Indicates texture filter capabilities.

Definition

Visual Basic .NET | Public Structure FilterCaps
C# | public struct FilterCaps
Managed C++ | public __value struct FilterCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsMagnifyAnisotropic | Indicates that the device supports per-stage anisotropic filtering for magnifying textures.
SupportsMagnifyGaussianQuad | Indicates that the device supports per-stage Guassian quad filtering for textures.
SupportsMagnifyLinear | Indicates that the device supports per-stage bilinear interpolation filtering for magnifying textures.
SupportsMagnifyPoint | Indicates that the device supports per-stage point-sample filtering for magnifying textures.
SupportsMagnifyPyramidalQuad | Indicates that the device supports per-stage pyramidal quad filtering for magnifying textures.
SupportsMinifyAnisotropic | Indicates that the device supports per-stage anisotropic filtering for minifying textures.
SupportsMinifyGaussianQuad | Indicates that the device supports per-stage Guassian quad filtering for minifying textures.
SupportsMinifyLinear | Indicates that the device supports per-stage bilinear interpolation filtering for minifying textures.
SupportsMinifyPoint | Indicates that the device supports per-stage point-sample filtering for minifying textures.
SupportsMinifyPyramidalQuad | Indicates that the device supports per-stage pyramidal quad filtering for minifying textures.
SupportsMipMapLinear | Indicates that the device supports per-stage trilinear interpolation filtering for mipmaps.
SupportsMipMapPoint | Indicates that the device supports per-stage point-sample filtering for mipmaps.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FilterCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FilterCaps.SupportsMagnifyAnisotropic

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMagnifyAnisotropic Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage anisotropic filtering for magnifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMagnifyAnisotropic As Boolean
C# | public bool SupportsMagnifyAnisotropic { get; }
Managed C++ | public: __property bool get_SupportsMagnifyAnisotropic();
JScript .NET | public function get SupportsMagnifyAnisotropic() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage anisotropic filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

Anisotropic filters compensate for distortion caused by the difference in angle between the texture polygon and the plane of the screen.

The anisotropic magnification filter is represented by the TextureFilter.Anisotropic enumerated value.


FilterCaps.SupportsMagnifyGaussianQuad

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMagnifyGaussianQuad Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage Guassian quad filtering for textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMagnifyGaussianQuad As Boolean
C# | public bool SupportsMagnifyGaussianQuad { get; }
Managed C++ | public: __property bool get_SupportsMagnifyGaussianQuad();
JScript .NET | public function get SupportsMagnifyGaussianQuad() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage Guassian quad filtering for textures, or false if it does not.

This property is read-only.


FilterCaps.SupportsMagnifyLinear

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMagnifyLinear Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage bilinear interpolation filtering for magnifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMagnifyLinear As Boolean
C# | public bool SupportsMagnifyLinear { get; }
Managed C++ | public: __property bool get_SupportsMagnifyLinear();
JScript .NET | public function get SupportsMagnifyLinear() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage bilinear interpolation filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

The bilinear interpolation mipmapping filter is represented by the TextureFilter.Linear enumerated value.


FilterCaps.SupportsMagnifyPoint

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMagnifyPoint Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage point-sample filtering for magnifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMagnifyPoint As Boolean
C# | public bool SupportsMagnifyPoint { get; }
Managed C++ | public: __property bool get_SupportsMagnifyPoint();
JScript .NET | public function get SupportsMagnifyPoint() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage point-sample filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

The point-sample magnification filter is represented by the TextureFilter.Point enumerated value.


FilterCaps.SupportsMagnifyPyramidalQuad

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMagnifyPyramidalQuad Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage pyramidal quad filtering for magnifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMagnifyPyramidalQuad As Boolean
C# | public bool SupportsMagnifyPyramidalQuad { get; }
Managed C++ | public: __property bool get_SupportsMagnifyPyramidalQuad();
JScript .NET | public function get SupportsMagnifyPyramidalQuad() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage pyramidal quad filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

The pyramidal magnifying filter is represented by the TextureFilter.PyramidalQuad enumerated value.


FilterCaps.SupportsMinifyAnisotropic

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMinifyAnisotropic Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage anisotropic filtering for minifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMinifyAnisotropic As Boolean
C# | public bool SupportsMinifyAnisotropic { get; }
Managed C++ | public: __property bool get_SupportsMinifyAnisotropic();
JScript .NET | public function get SupportsMinifyAnisotropic() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage anisotropic filtering for minifying textures, or false if it does not.

This property is read-only.

Remarks

The anisotropic minification filter is represented by the TextureFilter.Anisotropic enumerated value.


FilterCaps.SupportsMinifyGaussianQuad

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMinifyGaussianQuad Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage Guassian quad filtering for minifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMinifyGaussianQuad As Boolean
C# | public bool SupportsMinifyGaussianQuad { get; }
Managed C++ | public: __property bool get_SupportsMinifyGaussianQuad();
JScript .NET | public function get SupportsMinifyGaussianQuad() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage Guassian quad filtering for minifying textures, or false if it does not.

This property is read-only.


FilterCaps.SupportsMinifyLinear

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMinifyLinear Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage bilinear interpolation filtering for minifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMinifyLinear As Boolean
C# | public bool SupportsMinifyLinear { get; }
Managed C++ | public: __property bool get_SupportsMinifyLinear();
JScript .NET | public function get SupportsMinifyLinear() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage bilinear interpolation filtering for minifying textures, or false if it does not.

This property is read-only.

Remarks

The linear minification filter is represented by the TextureFilter.Linear enumerated value.


FilterCaps.SupportsMinifyPoint

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMinifyPoint Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage point-sample filtering for minifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMinifyPoint As Boolean
C# | public bool SupportsMinifyPoint { get; }
Managed C++ | public: __property bool get_SupportsMinifyPoint();
JScript .NET | public function get SupportsMinifyPoint() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage point-sample filtering for minifying textures, or false if it does not.

This property is read-only.

Remarks

The point-sample minification filter is represented by the TextureFilter.Point enumerated value.


FilterCaps.SupportsMinifyPyramidalQuad

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMinifyPyramidalQuad Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage pyramidal quad filtering for minifying textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMinifyPyramidalQuad As Boolean
C# | public bool SupportsMinifyPyramidalQuad { get; }
Managed C++ | public: __property bool get_SupportsMinifyPyramidalQuad();
JScript .NET | public function get SupportsMinifyPyramidalQuad() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage pyramidal quad filtering for minifying textures, or false if it does not.

This property is read-only.


FilterCaps.SupportsMipMapLinear

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMipMapLinear Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage trilinear interpolation filtering for mipmaps.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMipMapLinear As Boolean
C# | public bool SupportsMipMapLinear { get; }
Managed C++ | public: __property bool get_SupportsMipMapLinear();
JScript .NET | public function get SupportsMipMapLinear() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage trilinear interpolation filtering for mipmaps, or false if it does not.

This property is read-only.

Remarks

The bilinear interpolation mipmapping filter is represented by the TextureFilter.Linear enumerated value.


FilterCaps.SupportsMipMapPoint

Microsoft DirectX 9.0 SDK Update (October 2004)

FilterCaps.SupportsMipMapPoint Property

Language:
Note: This documentation is preliminary and is subject to change.

Indicates that the device supports per-stage point-sample filtering for mipmaps.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMipMapPoint As Boolean
C# | public bool SupportsMipMapPoint { get; }
Managed C++ | public: __property bool get_SupportsMipMapPoint();
JScript .NET | public function get SupportsMipMapPoint() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage point-sample filtering for mipmaps, or false if it does not.

This property is read-only.

Remarks

The point-sample mipmapping filter is represented by the TextureFilter.Point enumerated value.


FontDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the attributes of a font.

Definition

Visual Basic .NET | Public Structure FontDescription
C# | public struct FontDescription
Managed C++ | public __value struct FontDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FontDescription | Initializes a new instance of the FontDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CharSet | Retrieves or sets the character set for the font.
FaceName | Retrieves or sets the name of the font.
Height | Retrieves or sets the height of the font in logical units.
IsItalic | Determines whether a font is italic.
MipLevels | Retrieves or sets the number of mip levels requested.
OutputPrecision | Retrieves or sets the output precision for a font.
PitchAndFamily | Retrieves or sets the pitch and family of a font.
Quality | Retrieves or sets the output quality of a font.
Weight | Retrieves or sets the weight of a font.
Width | Retrieves or sets the width of a font in logical units.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FontDescription.FontDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.FontDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FontDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public FontDescription();
Managed C++ | public: FontDescription();
JScript .NET | public function FontDescription();


FontDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FontDescription.CharSet

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.CharSet Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the character set for the font.

Definition

Visual Basic .NET | Public Property CharSet As CharacterSet
C# | public CharacterSet CharSet { get; set; }
Managed C++ public: __property CharacterSet get_CharSet();
public: __property void set_CharSet(CharacterSet);
JScript .NET public function get CharSet() : CharacterSet
public function set CharSet(CharacterSet);

Property Value

Microsoft.DirectX.Direct3D.CharacterSet . A CharacterSet enumeration that represents the character set associated with the font.

This property is read/write.


FontDescription.FaceName

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.FaceName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the name of the font.

Definition

Visual Basic .NET | Public Property FaceName As String
C# | public string FaceName { get; set; }
Managed C++ public: __property String* get_FaceName();
public: __property void set_FaceName(String*);
JScript .NET public function get FaceName() : String
public function set FaceName(String);

Property Value

System.String . String up to 32 characters in length that represents the font name.

This property is read/write.

Remarks

If FaceName is an empty string, the first font that matches the other specified attributes is used.


FontDescription.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height of the font in logical units.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height of the font in logical units.

This property is read/write.


FontDescription.IsItalic

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.IsItalic Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a font is italic.

Definition

Visual Basic .NET | Public Property IsItalic As Boolean
C# | public bool IsItalic { get; set; }
Managed C++ public: __property bool get_IsItalic();
public: __property void set_IsItalic(bool);
JScript .NET public function get IsItalic() : boolean
public function set IsItalic(boolean);

Property Value

System.Boolean . Value that is true if the font is italic, or false if it is not.

This property is read/write.


FontDescription.MipLevels

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.MipLevels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of mip levels requested.

Definition

Visual Basic .NET | Public Property MipLevels As Integer
C# | public int MipLevels { get; set; }
Managed C++ public: __property int get_MipLevels();
public: __property void set_MipLevels(int);
JScript .NET public function get MipLevels() : int
public function set MipLevels(int);

Property Value

System.Int32 . Integer that represents the number of mip levels.

This property is read/write.

Remarks

If this value is 0, a complete mipmap chain is created. If the value is 1, the texture space is mapped identically to the screen space.


FontDescription.OutputPrecision

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.OutputPrecision Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the output precision for a font.

Definition

Visual Basic .NET | Public Property OutputPrecision As Precision
C# | public Precision OutputPrecision { get; set; }
Managed C++ public: __property Precision get_OutputPrecision();
public: __property void set_OutputPrecision(Precision);
JScript .NET public function get OutputPrecision() : Precision
public function set OutputPrecision(Precision);

Property Value

Microsoft.DirectX.Direct3D.Precision . Member of the Precision enumeration to set or retrieve.

This property is read/write.

Remarks

The output precision defines how closely the output must match the requested font height, width, character orientation, escapement, pitch, and font type.


FontDescription.PitchAndFamily

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.PitchAndFamily Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the pitch and family of a font.

Definition

Visual Basic .NET | Public Property PitchAndFamily As PitchAndFamily
C# | public PitchAndFamily PitchAndFamily { get; set; }
Managed C++ public: __property PitchAndFamily get_PitchAndFamily();
public: __property void set_PitchAndFamily(PitchAndFamily);
JScript .NET public function get PitchAndFamily() : PitchAndFamily
public function set PitchAndFamily(PitchAndFamily);

Property Value

Microsoft.DirectX.Direct3D.PitchAndFamily . Member of the PitchAndFamily enumeration to set or retrieve.

This property is read/write.


FontDescription.Quality

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.Quality Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the output quality of a font.

Definition

Visual Basic .NET | Public Property Quality As FontQuality
C# | public FontQuality Quality { get; set; }
Managed C++ public: __property FontQuality get_Quality();
public: __property void set_Quality(FontQuality);
JScript .NET public function get Quality() : FontQuality
public function set Quality(FontQuality);

Property Value

Microsoft.DirectX.Direct3D.FontQuality . Member of the FontQuality enumeration to set or retrieve.

This property is read/write.


FontDescription.Weight

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.Weight Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the weight of a font.

Definition

Visual Basic .NET | Public Property Weight As FontWeight
C# | public FontWeight Weight { get; set; }
Managed C++ public: __property FontWeight get_Weight();
public: __property void set_Weight(FontWeight);
JScript .NET public function get Weight() : FontWeight
public function set Weight(FontWeight);

Property Value

Microsoft.DirectX.Direct3D.FontWeight . Member of the FontWeight enumeration to set or retrieve.

This property is read/write.


FontDescription.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

FontDescription.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of a font in logical units.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width of the font in logical units.

This property is read/write.


FormatList

Microsoft DirectX 9.0 SDK Update (October 2004)

FormatList Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains a list of formats supported by the device.

Definition

Visual Basic .NET | Public Structure FormatList
C# | public struct FormatList
Managed C++ | public __value struct FormatList
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FormatList | Initializes a new instance of the FormatList class.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FormatList.FormatList()

Microsoft DirectX 9.0 SDK Update (October 2004)

FormatList.FormatList Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FormatList class.

Definition

Visual Basic .NET | Public Sub New()
C# | public FormatList();
Managed C++ | public: FormatList();
JScript .NET | public function FormatList();


FragmentDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes an annotation used by an effect object.

Definition

Visual Basic .NET | Public Structure FragmentDescription
C# | public struct FragmentDescription
Managed C++ | public __value struct FragmentDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FragmentDescription | Initializes a new instance of the FragmentDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets a fragment name.
Target | Retrieves or sets a fragment compile target.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FragmentDescription.FragmentDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentDescription.FragmentDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FragmentDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public FragmentDescription();
Managed C++ | public: FragmentDescription();
JScript .NET | public function FragmentDescription();


FragmentDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FragmentDescription.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentDescription.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a fragment name.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String . String that contains the fragment name.

This property is read/write.


FragmentDescription.Target

Microsoft DirectX 9.0 SDK Update (October 2004)

FragmentDescription.Target Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a fragment compile target.

Definition

Visual Basic .NET | Public Property Target As Integer
C# | public int Target { get; set; }
Managed C++ public: __property int get_Target();
public: __property void set_Target(int);
JScript .NET public function get Target() : int
public function set Target(int);

Property Value

System.Int32 . Integer that represents the compile target.

This property is read/write.

Remarks

The compile target identifies the shader type (vertex or pixel) and the version number.


FunctionDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

FunctionDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a function used by an effect.

Definition

Visual Basic .NET | Public Structure FunctionDescription
C# | public struct FunctionDescription
Managed C++ | public __value struct FunctionDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FunctionDescription | Initializes a new instance of the FunctionDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Unused. This member is always set to 0 by BaseEffect.GetFunctionDescription.
Name | Retrieves the function name.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FunctionDescription.FunctionDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

FunctionDescription.FunctionDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FunctionDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public FunctionDescription();
Managed C++ | public: FunctionDescription();
JScript .NET | public function FunctionDescription();


FunctionDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FunctionDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FunctionDescription.Annotations

Microsoft DirectX 9.0 SDK Update (October 2004)

FunctionDescription.Annotations Property

Language:
Note: This documentation is preliminary and is subject to change.

Unused. This member is always set to 0 by BaseEffect.GetFunctionDescription.

Definition

Visual Basic .NET | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
Managed C++ | public: __property int get_Annotations();
JScript .NET | public function get Annotations() : int

Property Value

System.Int32 .

This property is read-only.


FunctionDescription.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

FunctionDescription.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the function name.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . String that contains the function name to retrieve.

This property is read-only.


GammaRamp

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains red, green, and blue ramp data.

Definition

Visual Basic .NET | Public Structure GammaRamp
C# | public struct GammaRamp
Managed C++ | public __value struct GammaRamp
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GammaRamp | Initializes a new instance of the GammaRamp class.
GetBlue | Retrieves the blue component of the gamma ramp.
GetGreen | Retrieves the green component of the gamma ramp.
GetRed | Retrieves the red component of the gamma ramp.
SetBlue | Sets the blue component of the gamma ramp.
SetGreen | Sets the green component of the gamma ramp.
SetRed | Sets the red component of the gamma ramp.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GammaRamp.GammaRamp()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp.GammaRamp Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GammaRamp class.

Definition

Visual Basic .NET | Public Sub New()
C# | public GammaRamp();
Managed C++ | public: GammaRamp();
JScript .NET | public function GammaRamp();


GammaRamp.GetBlue()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp.GetBlue Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the blue component of the gamma ramp.

Definition

Visual Basic .NET | Public Function GetBlue() As Short()
C# | public short[] GetBlue();
Managed C++ | public: short GetBlue() __gc[];
JScript .NET | public function GetBlue() : short[];

Return Value

System.Int16[]. A 256-element integer array that represents the blue component.


GammaRamp.GetGreen()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp.GetGreen Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the green component of the gamma ramp.

Definition

Visual Basic .NET | Public Function GetGreen() As Short()
C# | public short[] GetGreen();
Managed C++ | public: short GetGreen() __gc[];
JScript .NET | public function GetGreen() : short[];

Return Value

System.Int16[]. A 256-element integer array that represents the green component.


GammaRamp.GetRed()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp.GetRed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the red component of the gamma ramp.

Definition

Visual Basic .NET | Public Function GetRed() As Short()
C# | public short[] GetRed();
Managed C++ | public: short GetRed() __gc[];
JScript .NET | public function GetRed() : short[];

Return Value

System.Int16[]. A 256-element integer array that represents the red component.


GammaRamp.SetBlue(Int16[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp.SetBlue Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the blue component of the gamma ramp.

Definition

Visual Basic .NET Public Sub SetBlue( _
ByVal value() As Short _
)
C# public void SetBlue(
short[] value
);
Managed C++ public: void SetBlue(
short value __gc[]
);
JScript .NET public function SetBlue(
value : short[]
);

Parameters

value System.Int16[]. A 256-element integer array that represents the blue component.

Remarks

Exceptions
ArgumentException Leave Site The value parameter is not a 256-element integer array. The array must have a size of 256.


GammaRamp.SetGreen(Int16[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp.SetGreen Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the green component of the gamma ramp.

Definition

Visual Basic .NET Public Sub SetGreen( _
ByVal value() As Short _
)
C# public void SetGreen(
short[] value
);
Managed C++ public: void SetGreen(
short value __gc[]
);
JScript .NET public function SetGreen(
value : short[]
);

Parameters

value System.Int16[]. A 256-element integer array that represents the green component.

Remarks

Exceptions
ArgumentException Leave Site The value parameter is not a 256-element integer array. The array must have a size of 256.


GammaRamp.SetRed(Int16[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamp.SetRed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the red component of the gamma ramp.

Definition

Visual Basic .NET Public Sub SetRed( _
ByVal value() As Short _
)
C# public void SetRed(
short[] value
);
Managed C++ public: void SetRed(
short value __gc[]
);
JScript .NET public function SetRed(
value : short[]
);

Parameters

value System.Int16[]. A 256-element integer array that represents the red component.

Remarks

Exceptions
ArgumentException Leave Site The value parameter is not a 256-element integer array. The array must have a size of 256.


GlyphMetricsFloat

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains information about the position and orientation of the corresponding glyph in the string.

Definition

Visual Basic .NET | Public Structure GlyphMetricsFloat
C# | public struct GlyphMetricsFloat
Managed C++ | public __value struct GlyphMetricsFloat
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GlyphMetricsFloat | Initializes a new instance of the GlyphMetricsFloat class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BlackBoxX | Specifies the width of the smallest rectangle (the glyph's black box) that completely encloses the glyph.
BlackBoxY | Specifies the height of the smallest rectangle (the glyph's black box) that completely encloses the glyph.
CellIncX | Specifies the horizontal distance from the origin of the current character cell to the origin of the next character cell.
CellIncY | Specifies the vertical distance from the origin of the current character cell to the origin of the next character cell.
GlyphOrigin | Specifies the x and y coordinates of the upper-left corner of the smallest rectangle that completely encloses the glyph.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GlyphMetricsFloat.GlyphMetricsFloat()

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat.GlyphMetricsFloat Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GlyphMetricsFloat class.

Definition

Visual Basic .NET | Public Sub New()
C# | public GlyphMetricsFloat();
Managed C++ | public: GlyphMetricsFloat();
JScript .NET | public function GlyphMetricsFloat();


GlyphMetricsFloat.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


GlyphMetricsFloat.BlackBoxX

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat.BlackBoxX Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies the width of the smallest rectangle (the glyph's black box) that completely encloses the glyph.

Definition

Visual Basic .NET | Public Property BlackBoxX As Single
C# | public float BlackBoxX { get; set; }
Managed C++ public: __property float get_BlackBoxX();
public: __property void set_BlackBoxX(float);
JScript .NET public function get BlackBoxX() : float
public function set BlackBoxX(float);

Property Value

System.Single . Floating-point value that represents the width of the glyph's black box.

This property is read/write.


GlyphMetricsFloat.BlackBoxY

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat.BlackBoxY Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies the height of the smallest rectangle (the glyph's black box) that completely encloses the glyph.

Definition

Visual Basic .NET | Public Property BlackBoxY As Single
C# | public float BlackBoxY { get; set; }
Managed C++ public: __property float get_BlackBoxY();
public: __property void set_BlackBoxY(float);
JScript .NET public function get BlackBoxY() : float
public function set BlackBoxY(float);

Property Value

System.Single . Floating-point value that represents the height of the glyph's black box.

This property is read/write.


GlyphMetricsFloat.CellIncX

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat.CellIncX Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies the horizontal distance from the origin of the current character cell to the origin of the next character cell.

Definition

Visual Basic .NET | Public Property CellIncX As Single
C# | public float CellIncX { get; set; }
Managed C++ public: __property float get_CellIncX();
public: __property void set_CellIncX(float);
JScript .NET public function get CellIncX() : float
public function set CellIncX(float);

Property Value

System.Single . Floating-point value that represents the horizontal distance between character-cell origin points.

This property is read/write.


GlyphMetricsFloat.CellIncY

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat.CellIncY Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies the vertical distance from the origin of the current character cell to the origin of the next character cell.

Definition

Visual Basic .NET | Public Property CellIncY As Single
C# | public float CellIncY { get; set; }
Managed C++ public: __property float get_CellIncY();
public: __property void set_CellIncY(float);
JScript .NET public function get CellIncY() : float
public function set CellIncY(float);

Property Value

System.Single . Floating-point value that represents the vertical distance between character-cell origin points.

This property is read/write.


GlyphMetricsFloat.GlyphOrigin

Microsoft DirectX 9.0 SDK Update (October 2004)

GlyphMetricsFloat.GlyphOrigin Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies the x and y coordinates of the upper-left corner of the smallest rectangle that completely encloses the glyph.

Definition

Visual Basic .NET | Public Property GlyphOrigin As PointF
C# | public PointF GlyphOrigin { get; set; }
Managed C++ public: __property PointF get_GlyphOrigin();
public: __property void set_GlyphOrigin(PointF);
JScript .NET public function get GlyphOrigin() : PointF
public function set GlyphOrigin(PointF);

Property Value

System.Drawing.PointF . A PointF Leave Site object to set or retrieve.

This property is read/write.


ImageInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains a description of the original contents of an image file.

Definition

Visual Basic .NET | Public Structure ImageInformation
C# | public struct ImageInformation
Managed C++ | public __value struct ImageInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ImageInformation | Initializes a new instance of the ImageInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Depth | Retrieves or sets the depth of the original image.
Format | Retrieves or sets a value that most closely describes the data in the original image.
Height | Retrieves or sets the height of the original image.
ImageFileFormat | Retrieves or sets the format of the image file.
MipLevels | Retrieves or sets the number of mip levels in the original image.
ResourceType | Retrieves or sets a value that represents the type of the texture stored in the file.
Width | Retrieves or sets the width of the original image.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ImageInformation.ImageInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.ImageInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ImageInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ImageInformation();
Managed C++ | public: ImageInformation();
JScript .NET | public function ImageInformation();


ImageInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ImageInformation.Depth

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.Depth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the depth of the original image.

Definition

Visual Basic .NET | Public Property Depth As Integer
C# | public int Depth { get; set; }
Managed C++ public: __property int get_Depth();
public: __property void set_Depth(int);
JScript .NET public function get Depth() : int
public function set Depth(int);

Property Value

System.Int32 . Integer that represents the depth of the original image in pixels.

This property is read/write.


ImageInformation.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that most closely describes the data in the original image.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . Member of the Format enumeration to set or retrieve.

This property is read/write.


ImageInformation.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height of the original image.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height of the original image in pixels.

This property is read/write.


ImageInformation.ImageFileFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.ImageFileFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the format of the image file.

Definition

Visual Basic .NET | Public Property ImageFileFormat As ImageFileFormat
C# | public ImageFileFormat ImageFileFormat { get; set; }
Managed C++ public: __property ImageFileFormat get_ImageFileFormat();
public: __property void set_ImageFileFormat(ImageFileFormat);
JScript .NET public function get ImageFileFormat() : ImageFileFormat
public function set ImageFileFormat(ImageFileFormat);

Property Value

Microsoft.DirectX.Direct3D.ImageFileFormat . Member of the ImageFileFormat enumeration to set or retrieve.

This property is read/write.


ImageInformation.MipLevels

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.MipLevels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of mip levels in the original image.

Definition

Visual Basic .NET | Public Property MipLevels As Integer
C# | public int MipLevels { get; set; }
Managed C++ public: __property int get_MipLevels();
public: __property void set_MipLevels(int);
JScript .NET public function get MipLevels() : int
public function set MipLevels(int);

Property Value

System.Int32 . Integer that represents the number of mip levels.

This property is read/write.


ImageInformation.ResourceType

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.ResourceType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that represents the type of the texture stored in the file.

Definition

Visual Basic .NET | Public Property ResourceType As ResourceType
C# | public ResourceType ResourceType { get; set; }
Managed C++ public: __property ResourceType get_ResourceType();
public: __property void set_ResourceType(ResourceType);
JScript .NET public function get ResourceType() : ResourceType
public function set ResourceType(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType . Member of the ResourceType enumeration to set or retrieve.

This property is read/write.

Remarks

The type of texture stored in the file can be ResourceType.Texture, ResourceType.VolumeTexture, or ResourceType.CubeTexture.


ImageInformation.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageInformation.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of the original image.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width of the original image in pixels.

This property is read/write.


IndexBufferDescription

IndexBufferDescription Structure

Note: This documentation is preliminary and is subject to change.

Describes an index buffer.

Definition

Visual Basic .NET | Public Structure IndexBufferDescription
C# | public struct IndexBufferDescription
Managed C++ | public __value struct IndexBufferDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
IndexBufferDescription | Initializes a new instance of the IndexBufferDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Is16BitIndices | Determines whether the index buffer has 16-bit indices or 32-bit indices.
Pool | Retrieves a value that specifies the class of memory allocated for the current index buffer.
Size | Retrieves the size of the index buffer.
Type | Retrieves a value that identifies the current resource as an index buffer.
Usage | Retrieves values that specify usage for the current resource.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


IndexBufferDescription.IndexBufferDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBufferDescription.IndexBufferDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the IndexBufferDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public IndexBufferDescription();
Managed C++ | public: IndexBufferDescription();
JScript .NET | public function IndexBufferDescription();


IndexBufferDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBufferDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


IndexBufferDescription.Is16BitIndices

IndexBufferDescription.Is16BitIndices Property

Note: This documentation is preliminary and is subject to change.

Determines whether the index buffer has 16-bit indices or 32-bit indices.

Definition

Visual Basic .NET | Public ReadOnly Property Is16BitIndices As Boolean
C# | public bool Is16BitIndices { get; }
Managed C++ | public: __property bool get_Is16BitIndices();
JScript .NET | public function get Is16BitIndices() : boolean

Property Value

System.Boolean . Returns true if the index buffer has 16-bit indices, or false if the index buffer has 32-bit indices.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


IndexBufferDescription.Pool

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBufferDescription.Pool Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that specifies the class of memory allocated for the current index buffer.

Definition

Visual Basic .NET | Public ReadOnly Property Pool As Pool
C# | public Pool Pool { get; }
Managed C++ | public: __property Pool get_Pool();
JScript .NET | public function get Pool() : Pool

Property Value

Microsoft.DirectX.Direct3D.Pool . Member of the Pool enumeration to retrieve.

This property is read-only.


IndexBufferDescription.Size

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBufferDescription.Size Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the index buffer.

Definition

Visual Basic .NET | Public ReadOnly Property Size As Integer
C# | public int Size { get; }
Managed C++ | public: __property int get_Size();
JScript .NET | public function get Size() : int

Property Value

System.Int32 . An integer that specifies the size of the index buffer, in bytes.

This property is read-only.


IndexBufferDescription.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBufferDescription.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that identifies the current resource as an index buffer.

Definition

Visual Basic .NET | Public ReadOnly Property Type As ResourceType
C# | public ResourceType Type { get; }
Managed C++ | public: __property ResourceType get_Type();
JScript .NET | public function get Type() : ResourceType

Property Value

Microsoft.DirectX.Direct3D.ResourceType . Member of the ResourceType enumeration that identifies the current resource.

This property is read-only.


IndexBufferDescription.Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

IndexBufferDescription.Usage Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves values that specify usage for the current resource.

Definition

Visual Basic .NET | Public ReadOnly Property Usage As Usage
C# | public Usage Usage { get; }
Managed C++ | public: __property Usage get_Usage();
JScript .NET | public function get Usage() : Usage

Property Value

Microsoft.DirectX.Direct3D.Usage . One or more members of the Usage enumeration to retrieve.

This property is read-only.


InterfaceTimings

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Provides percentage of time processing data in the driver. These statistics may help identify cases when the driver is waiting for other resources.

Definition

Visual Basic .NET | Public Structure InterfaceTimings
C# | public struct InterfaceTimings
Managed C++ | public __value struct InterfaceTimings
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
InterfaceTimings | Creates a new instance of the InterfaceTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
WaitingForGpuExclusiveResourceTimePercent | Retrieves the percentage of time the driver spent waiting for a resource that cannot be pipelined (that is, operated in parallel).
WaitingForGpuOtherTimePercent | Retrieves the percentage of time the driver spent waiting for other GPU processing.
WaitingForGpuToAcceptMoreCommandsTimePercent | Retrieves the percentage of time the driver spent waiting for the GPU to finish processing some commands before the driver could send more. This indicates the driver has run out of room to send commands to the GPU.
WaitingForGpuToStayWithinLatencyTimePercent | Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) latency to reduce to less than 3 rendering frames.
WaitingForGpuToUseApplicationResourceTimePercent | Retrieves the percentage of time the driver spent waiting for the GPU to finish using a locked resource (and LockFlags.DoNotWait wasn't specified).

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InterfaceTimings.InterfaceTimings()

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings.InterfaceTimings Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the InterfaceTimings structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public InterfaceTimings();
Managed C++ | public: InterfaceTimings();
JScript .NET | public function InterfaceTimings();


InterfaceTimings.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


InterfaceTimings.WaitingForGpuExclusiveResourceTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings.WaitingForGpuExclusiveResourceTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time the driver spent waiting for a resource that cannot be pipelined (that is, operated in parallel).

Definition

Visual Basic .NET | Public ReadOnly Property WaitingForGpuExclusiveResourceTimePercent As Single
C# | public float WaitingForGpuExclusiveResourceTimePercent { get; }
Managed C++ | public: __property float get_WaitingForGpuExclusiveResourceTimePercent();
JScript .NET | public function get WaitingForGpuExclusiveResourceTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time the driver spent waiting for a resource that cannot be pipelined.

This property is read-only.

Remarks

Generally, this indicates the possible absence of first-class support of a certain feature. An application may want to avoid using a non-pipelined resource for performance reasons.


InterfaceTimings.WaitingForGpuOtherTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings.WaitingForGpuOtherTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time the driver spent waiting for other graphics processing unit (GPU) processing.

Definition

Visual Basic .NET | Public ReadOnly Property WaitingForGpuOtherTimePercent As Single
C# | public float WaitingForGpuOtherTimePercent { get; }
Managed C++ | public: __property float get_WaitingForGpuOtherTimePercent();
JScript .NET | public function get WaitingForGpuOtherTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time the driver spent waiting for other graphics processing unit (GPU) processing.

This property is read-only.


InterfaceTimings.WaitingForGpuToAcceptMoreCommandsTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings.WaitingForGpuToAcceptMoreCommandsTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) to finish processing some commands before the driver could send more. This indicates the driver has run out of room to send commands to the graphics processing unit (GPU).

Definition

Visual Basic .NET | Public ReadOnly Property WaitingForGpuToAcceptMoreCommandsTimePercent As Single
C# | public float WaitingForGpuToAcceptMoreCommandsTimePercent { get; }
Managed C++ | public: __property float get_WaitingForGpuToAcceptMoreCommandsTimePercent();
JScript .NET | public function get WaitingForGpuToAcceptMoreCommandsTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time the driver spent waiting for the graphics processing unit (GPU) to finish processing some commands before the driver could send more.

This property is read-only.


InterfaceTimings.WaitingForGpuToStayWithinLatencyTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings.WaitingForGpuToStayWithinLatencyTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) latency to reduce to less than 3 rendering frames.

Definition

Visual Basic .NET | Public ReadOnly Property WaitingForGpuToStayWithinLatencyTimePercent As Single
C# | public float WaitingForGpuToStayWithinLatencyTimePercent { get; }
Managed C++ | public: __property float get_WaitingForGpuToStayWithinLatencyTimePercent();
JScript .NET | public function get WaitingForGpuToStayWithinLatencyTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time the driver spent waiting for the graphics processing unit (GPU) latency to reduce to less than 3 rendering frames.

This property is read-only.

Remarks

If an application is graphics processing unit (GPU) limited, the driver must stall the CPU until the GPU gets within 3 frames. This prevents an application from queueing up many seconds' worth of rendering calls which may dramatically increase the latency between when the user provides new data and when the user sees the results of that input. In general, the driver can track the number of times Device.Present is called to prevent queueing up more than three frames of rendering work.


InterfaceTimings.WaitingForGpuToUseApplicationResourceTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

InterfaceTimings.WaitingForGpuToUseApplicationResourceTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) to finish using a locked resource (and LockFlags.DoNotWait wasn't specified).

Definition

Visual Basic .NET | Public ReadOnly Property WaitingForGpuToUseApplicationResourceTimePercent As Single
C# | public float WaitingForGpuToUseApplicationResourceTimePercent { get; }
Managed C++ | public: __property float get_WaitingForGpuToUseApplicationResourceTimePercent();
JScript .NET | public function get WaitingForGpuToUseApplicationResourceTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time the driver spent waiting for the graphics processing unit (GPU) to finish using a locked resource.

This property is read-only.


IntersectInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

IntersectInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the intersection of a ray and a triangle.

Definition

Visual Basic .NET | Public Structure IntersectInformation
C# | public struct IntersectInformation
Managed C++ | public __value struct IntersectInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
IntersectInformation | Initializes a new instance of the IntersectInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Dist | Retrieves or sets the distance along the ray where the intersection occurred.
FaceIndex | Retrieves or sets the index of the triangle that intersected the ray.
U | Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.
V | Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IntersectInformation.IntersectInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

IntersectInformation.IntersectInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the IntersectInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public IntersectInformation();
Managed C++ | public: IntersectInformation();
JScript .NET | public function IntersectInformation();


IntersectInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

IntersectInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


IntersectInformation.Dist

Microsoft DirectX 9.0 SDK Update (October 2004)

IntersectInformation.Dist Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the distance along the ray where the intersection occurred.

Definition

Visual Basic .NET | Public Property Dist As Single
C# | public float Dist { get; set; }
Managed C++ public: __property float get_Dist();
public: __property void set_Dist(float);
JScript .NET public function get Dist() : float
public function set Dist(float);

Property Value

System.Single . Floating-point value that represents the distance of the intersection.

This property is read/write.


IntersectInformation.FaceIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

IntersectInformation.FaceIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the index of the triangle that intersected the ray.

Definition

Visual Basic .NET | Public Property FaceIndex As Integer
C# | public int FaceIndex { get; set; }
Managed C++ public: __property int get_FaceIndex();
public: __property void set_FaceIndex(int);
JScript .NET public function get FaceIndex() : int
public function set FaceIndex(int);

Property Value

System.Int32 . Integer that represents the triangle ray.

This property is read/write.


IntersectInformation.U

Microsoft DirectX 9.0 SDK Update (October 2004)

IntersectInformation.U Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.

Definition

Visual Basic .NET | Public Property U As Single
C# | public float U { get; set; }
Managed C++ public: __property float get_U();
public: __property void set_U(float);
JScript .NET public function get U() : float
public function set U(float);

Property Value

System.Single . Floating-point value that represents the barycentric coordinate.

This property is read/write.


IntersectInformation.V

Microsoft DirectX 9.0 SDK Update (October 2004)

IntersectInformation.V Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.

Definition

Visual Basic .NET | Public Property V As Single
C# | public float V { get; set; }
Managed C++ public: __property float get_V();
public: __property void set_V(float);
JScript .NET public function get V() : float
public function set V(float);

Property Value

System.Single . Floating-point value that represents the barycentric coordinate.

This property is read/write.


KeyCallback

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyCallback Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a callback key for use in keyframe animation.

Definition

Visual Basic .NET | Public Structure KeyCallback
C# | public struct KeyCallback
Managed C++ | public __value struct KeyCallback
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
CallBackData | Retrieves or sets user callback data.
Time | Retrieves or sets a time value that indicates when the callback is triggered.

Methods

Method | Description
KeyCallback | Creates a new instance of a KeyCallback structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


KeyCallback.KeyCallback()

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyCallback.KeyCallback Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of a KeyCallback structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public KeyCallback();
Managed C++ | public: KeyCallback();
JScript .NET | public function KeyCallback();


KeyCallback.CallBackData

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyCallback.CallBackData Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets user callback data.

Definition

Visual Basic .NET | Public CallBackData As IntPtr
C# | public IntPtr CallBackData;
Managed C++ | public: IntPtr CallBackData;
JScript .NET | public var CallBackData : IntPtr

Field Value

System.IntPtr . User callback data.

This field is read/write.


KeyCallback.Time

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyCallback.Time Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a time value that indicates when the callback is triggered.

Definition

Visual Basic .NET | Public Time As Single
C# | public Single Time;
Managed C++ | public: Single Time;
JScript .NET | public var Time : Single

Field Value

System.Single . Time value.

This field is read/write.


KeyQuaternion

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyQuaternion Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a quaternion key for use in keyframe animation, and specifies a quaternion value at a given time.

Definition

Visual Basic .NET | Public Structure KeyQuaternion
C# | public struct KeyQuaternion
Managed C++ | public __value struct KeyQuaternion
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Time | Retrieves or sets the time of the quaternion key.
Value | Retrieves or sets the value of the quaternion key.

Methods

Method | Description
KeyQuaternion | Initializes a new instance of the KeyQuaternion class.

Remarks

This structure is used for rotation keys.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


KeyQuaternion.KeyQuaternion()

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyQuaternion.KeyQuaternion Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the KeyQuaternion class.

Definition

Visual Basic .NET | Public Sub New()
C# | public KeyQuaternion();
Managed C++ | public: KeyQuaternion();
JScript .NET | public function KeyQuaternion();


KeyQuaternion.Time

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyQuaternion.Time Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the time of the quaternion key.

Definition

Visual Basic .NET | Public Time As Single
C# | public Single Time;
Managed C++ | public: Single Time;
JScript .NET | public var Time : Single

Field Value

System.Single . Floating-point value that represents the time of the quaternion key.

This field is read/write.


KeyQuaternion.Value

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyQuaternion.Value Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the value of the quaternion key.

Definition

Visual Basic .NET | Public Value As Quaternion
C# | public Quaternion Value;
Managed C++ | public: Quaternion Value;
JScript .NET | public var Value : Quaternion

Field Value

Microsoft.DirectX.Quaternion . A Quaternion that supplies rotation values.

This field is read/write.


KeyVector3

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyVector3 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a vector key for use in keyframe animation, and specifies a vector at a given time.

Definition

Visual Basic .NET | Public Structure KeyVector3
C# | public struct KeyVector3
Managed C++ | public __value struct KeyVector3
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Time | Retrieves or sets the keyframe time stamp.
Value | Retrieves or sets a Vector3 object that supplies scale and/or translation values.

Methods

Method | Description
KeyVector3 | Initializes a new instance of the KeyVector3 class.

Remarks

This structure is used for scale and translation keys.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


KeyVector3.KeyVector3()

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyVector3.KeyVector3 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the KeyVector3 class.

Definition

Visual Basic .NET | Public Sub New()
C# | public KeyVector3();
Managed C++ | public: KeyVector3();
JScript .NET | public function KeyVector3();


KeyVector3.Time

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyVector3.Time Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the keyframe time stamp.

Definition

Visual Basic .NET | Public Time As Single
C# | public Single Time;
Managed C++ | public: Single Time;
JScript .NET | public var Time : Single

Field Value

System.Single . Floating-point value that represents the keyframe time stamp.

This field is read/write.


KeyVector3.Value

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyVector3.Value Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Vector3 object that supplies scale and/or translation values.

Definition

Visual Basic .NET | Public Value As Vector3
C# | public Vector3 Value;
Managed C++ | public: Vector3 Value;
JScript .NET | public var Value : Vector3

Field Value

Microsoft.DirectX.Vector3 . A Vector3 object to set or retrieve.

This field is read/write.


LineCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the capabilities for line-drawing primitives.

Definition

Visual Basic .NET | Public Structure LineCaps
C# | public struct LineCaps
Managed C++ | public __value struct LineCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlphaCompare | Specifies whether the device supports alpha-test comparisons.
SupportsAntiAlias | Specifies whether the device supports antialiased lines.
SupportsBlend | Specifies whether the device supports source blending.
SupportsFog | Specifies whether the device supports fog.
SupportsTextureMapping | Specifies whether the device supports texture mapping.
SupportsZBufferTest | Specifies whether the device supports z-buffer comparisons.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LineCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


LineCaps.SupportsAlphaCompare

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps.SupportsAlphaCompare Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports alpha-test comparisons.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAlphaCompare As Boolean
C# | public bool SupportsAlphaCompare { get; }
Managed C++ | public: __property bool get_SupportsAlphaCompare();
JScript .NET | public function get SupportsAlphaCompare() : boolean

Property Value

System.Boolean . Value that is true if the device supports alpha-test comparisons, or false if it does not.

This property is read-only.


LineCaps.SupportsAntiAlias

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps.SupportsAntiAlias Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports antialiased lines.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAntiAlias As Boolean
C# | public bool SupportsAntiAlias { get; }
Managed C++ | public: __property bool get_SupportsAntiAlias();
JScript .NET | public function get SupportsAntiAlias() : boolean

Property Value

System.Boolean . Value that is true if the device supports antialiased lines, or false if it does not.

This property is read-only.


LineCaps.SupportsBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps.SupportsBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports source blending.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlend As Boolean
C# | public bool SupportsBlend { get; }
Managed C++ | public: __property bool get_SupportsBlend();
JScript .NET | public function get SupportsBlend() : boolean

Property Value

System.Boolean . Value that is true if the device supports source blending, or false if it does not.

This property is read-only.


LineCaps.SupportsFog

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps.SupportsFog Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports fog.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFog As Boolean
C# | public bool SupportsFog { get; }
Managed C++ | public: __property bool get_SupportsFog();
JScript .NET | public function get SupportsFog() : boolean

Property Value

System.Boolean . Value that is true if the device supports fog, or false if it does not.

This property is read-only.


LineCaps.SupportsTextureMapping

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps.SupportsTextureMapping Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports texture mapping.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureMapping As Boolean
C# | public bool SupportsTextureMapping { get; }
Managed C++ | public: __property bool get_SupportsTextureMapping();
JScript .NET | public function get SupportsTextureMapping() : boolean

Property Value

System.Boolean . Value that is true if the device supports texture mapping, or false if it does not.

This property is read-only.


LineCaps.SupportsZBufferTest

Microsoft DirectX 9.0 SDK Update (October 2004)

LineCaps.SupportsZBufferTest Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports z-buffer comparisons.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsZBufferTest As Boolean
C# | public bool SupportsZBufferTest { get; }
Managed C++ | public: __property bool get_SupportsZBufferTest();
JScript .NET | public function get SupportsZBufferTest() : boolean

Property Value

System.Boolean . Value that is true if the device supports z-buffer comparisons, or false if it does not.

This property is read-only.


LinePattern

Microsoft DirectX 9.0 SDK Update (October 2004)

LinePattern Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a line pattern.

Definition

Visual Basic .NET | Public Structure LinePattern
C# | public struct LinePattern
Managed C++ | public __value struct LinePattern
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
LinePattern | Initializes a new instance of the LinePattern class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Linepattern | Retrieves or sets bits that specify the line pattern.
RepeatFactor | Retrieves or sets the number of times to repeat each series of ones and zeros specified in the Linepattern property.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LinePattern.LinePattern()

Microsoft DirectX 9.0 SDK Update (October 2004)

LinePattern.LinePattern Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LinePattern class.

Definition

Visual Basic .NET | Public Sub New()
C# | public LinePattern();
Managed C++ | public: LinePattern();
JScript .NET | public function LinePattern();


LinePattern.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

LinePattern.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


LinePattern.Linepattern

Microsoft DirectX 9.0 SDK Update (October 2004)

LinePattern.Linepattern Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets bits that specify the line pattern.

Definition

Visual Basic .NET | Public Property Linepattern As Short
C# | public short Linepattern { get; set; }
Managed C++ public: __property short get_Linepattern();
public: __property void set_Linepattern(short);
JScript .NET public function get Linepattern() : short
public function set Linepattern(short);

Property Value

System.Int16 . Integer that contains the line pattern bits.

This property is read/write.

Remarks

For example, the following value produces a dotted line: 1100110011001100.


LinePattern.RepeatFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

LinePattern.RepeatFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of times to repeat each series of ones and zeros specified in the Linepattern property.

Definition

Visual Basic .NET | Public Property RepeatFactor As Short
C# | public short RepeatFactor { get; set; }
Managed C++ public: __property short get_RepeatFactor();
public: __property void set_RepeatFactor(short);
JScript .NET public function get RepeatFactor() : short
public function set RepeatFactor(short);

Property Value

System.Int16 . Integer that represents the number of times to repeat the Linepattern.

This property is read/write.

Remarks

This property allows an application to stretch the line pattern.


LockedBox

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBox Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a locked box (volume).

Definition

Visual Basic .NET | Public Structure LockedBox
C# | public struct LockedBox
Managed C++ | public __value struct LockedBox
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
LockedBox | Initializes a new instance of the LockedBox class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
RowPitch | Retrieves or sets the byte offset from the left edge of one row to the left edge of the next row.
SlicePitch | Retrieves or sets the byte offset from the top left of one slice to the top left of the next-deepest slice.

Remarks

Volumes can be visualized as being organized into slices of width x height 2-D surfaces that are stacked up to make a width x height x depth volume.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LockedBox.LockedBox()

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBox.LockedBox Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the LockedBox class.

Definition

Visual Basic .NET | Public Sub New()
C# | public LockedBox();
Managed C++ | public: LockedBox();
JScript .NET | public function LockedBox();


LockedBox.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBox.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


LockedBox.RowPitch

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBox.RowPitch Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the byte offset from the left edge of one row to the left edge of the next row.

Definition

Visual Basic .NET | Public Property RowPitch As Integer
C# | public int RowPitch { get; set; }
Managed C++ public: __property int get_RowPitch();
public: __property void set_RowPitch(int);
JScript .NET public function get RowPitch() : int
public function set RowPitch(int);

Property Value

System.Int32 . Integer that represents the row pitch in bytes.

This property is read/write.


LockedBox.SlicePitch

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBox.SlicePitch Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the byte offset from the top left of one slice to the top left of the next-deepest slice.

Definition

Visual Basic .NET | Public Property SlicePitch As Integer
C# | public int SlicePitch { get; set; }
Managed C++ public: __property int get_SlicePitch();
public: __property void set_SlicePitch(int);
JScript .NET public function get SlicePitch() : int
public function set SlicePitch(int);

Property Value

System.Int32 . Integer that represents the slice pitch in bytes.

This property is read/write.


Macro

Microsoft DirectX 9.0 SDK Update (October 2004)

Macro Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes preprocessor definitions used by an effect object.

Definition

Visual Basic .NET | Public Structure Macro
C# | public struct Macro
Managed C++ | public __value struct Macro
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Macro | Initializes a new instance of the Macro class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Definition | Retrieves or sets the definition name.
Name | Retrieves or sets the preprocessor name.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Macro.Macro()

Microsoft DirectX 9.0 SDK Update (October 2004)

Macro.Macro Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Macro class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Macro();
Managed C++ | public: Macro();
JScript .NET | public function Macro();


Macro.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Macro.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Macro.Definition

Microsoft DirectX 9.0 SDK Update (October 2004)

Macro.Definition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the definition name.

Definition

Visual Basic .NET | Public Property Definition As String
C# | public string Definition { get; set; }
Managed C++ public: __property String* get_Definition();
public: __property void set_Definition(String*);
JScript .NET public function get Definition() : String
public function set Definition(String);

Property Value

System.String . String that represents the definition name.

This property is read/write.


Macro.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

Macro.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the preprocessor name.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String . String that represents the preprocessor name.

This property is read/write.


Material

Microsoft DirectX 9.0 SDK Update (October 2004)

Material Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies material properties.

Definition

Visual Basic .NET | Public Structure Material
C# | public struct Material
Managed C++ | public __value struct Material
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
Material | Initializes a new instance of the Material class.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Ambient | Retrieves or sets a value that specifies the ambient color.
AmbientColor | Retrieves or sets the ambient ColorValue.
Diffuse | Retrieves or sets a value that specifies the diffuse color.
DiffuseColor | Retrieves or sets the diffuse ColorValue.
Emissive | Retrieves or sets a value that specifies the emissive color.
EmissiveColor | Retrieves or sets the emissive ColorValue.
Specular | Retrieves or sets a value that specifies the specular color.
SpecularColor | Retrieves or sets the specular ColorValue.
SpecularSharpness | Retrieves or sets a value that specifies the sharpness of specular highlights.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • ExtendedMaterial
  • Tutorial 6: Using Meshes


Material.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Material.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Material.Material()

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.Material Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Material class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Material();
Managed C++ | public: Material();
JScript .NET | public function Material();


Material.op_Equality(Material,Material)

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Material, _
ByVal right As Material _
) As Boolean
C# public static bool op_Equality(
Material left,
Material right
);
Managed C++ public: static bool op_Equality(
Material left,
Material right
);
JScript .NET public static function op_Equality(
left : Material,
right : Material
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Material. The Material object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Material. The Material object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Material.op_Inequality(Material,Material)

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Material, _
ByVal right As Material _
) As Boolean
C# public static bool op_Inequality(
Material left,
Material right
);
Managed C++ public: static bool op_Inequality(
Material left,
Material right
);
JScript .NET public static function op_Inequality(
left : Material,
right : Material
) : boolean;

Parameters

left | Microsoft.DirectX.Direct3D.Material. The Material object to the left of the equality operator.
right | Microsoft.DirectX.Direct3D.Material. The Material object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Material.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Material.Ambient

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.Ambient Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies the ambient color.

Definition

Visual Basic .NET | Public Property Ambient As Color
C# | public Color Ambient { get; set; }
Managed C++ public: __property Color get_Ambient();
public: __property void set_Ambient(Color);
JScript .NET public function get Ambient() : Color
public function set Ambient(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the ambient color.

This property is read/write.


Material.AmbientColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.AmbientColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ambient ColorValue.

Definition

Visual Basic .NET | Public Property AmbientColor As ColorValue
C# | public ColorValue AmbientColor { get; set; }
Managed C++ public: __property ColorValue get_AmbientColor();
public: __property void set_AmbientColor(ColorValue);
JScript .NET public function get AmbientColor() : ColorValue
public function set AmbientColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure to set or retrieve.

This property is read/write.


Material.Diffuse

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.Diffuse Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies the diffuse color.

Definition

Visual Basic .NET | Public Property Diffuse As Color
C# | public Color Diffuse { get; set; }
Managed C++ public: __property Color get_Diffuse();
public: __property void set_Diffuse(Color);
JScript .NET public function get Diffuse() : Color
public function set Diffuse(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the diffuse color to set or retrieve.

This property is read/write.


Material.DiffuseColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.DiffuseColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the diffuse ColorValue.

Definition

Visual Basic .NET | Public Property DiffuseColor As ColorValue
C# | public ColorValue DiffuseColor { get; set; }
Managed C++ public: __property ColorValue get_DiffuseColor();
public: __property void set_DiffuseColor(ColorValue);
JScript .NET public function get DiffuseColor() : ColorValue
public function set DiffuseColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure to set or retrieve.

This property is read/write.


Material.Emissive

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.Emissive Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies the emissive color.

Definition

Visual Basic .NET | Public Property Emissive As Color
C# | public Color Emissive { get; set; }
Managed C++ public: __property Color get_Emissive();
public: __property void set_Emissive(Color);
JScript .NET public function get Emissive() : Color
public function set Emissive(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the emissive color to set or retrieve.

This property is read/write.


Material.EmissiveColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.EmissiveColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the emissive ColorValue.

Definition

Visual Basic .NET | Public Property EmissiveColor As ColorValue
C# | public ColorValue EmissiveColor { get; set; }
Managed C++ public: __property ColorValue get_EmissiveColor();
public: __property void set_EmissiveColor(ColorValue);
JScript .NET public function get EmissiveColor() : ColorValue
public function set EmissiveColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure to set or retrieve.

This property is read/write.


Material.Specular

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.Specular Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies the specular color.

Definition

Visual Basic .NET | Public Property Specular As Color
C# | public Color Specular { get; set; }
Managed C++ public: __property Color get_Specular();
public: __property void set_Specular(Color);
JScript .NET public function get Specular() : Color
public function set Specular(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the specular color to set or retrieve.

This property is read/write.


Material.SpecularColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.SpecularColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the specular ColorValue.

Definition

Visual Basic .NET | Public Property SpecularColor As ColorValue
C# | public ColorValue SpecularColor { get; set; }
Managed C++ public: __property ColorValue get_SpecularColor();
public: __property void set_SpecularColor(ColorValue);
JScript .NET public function get SpecularColor() : ColorValue
public function set SpecularColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue structure to set or retrieve.

This property is read/write.


Material.SpecularSharpness

Microsoft DirectX 9.0 SDK Update (October 2004)

Material.SpecularSharpness Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies the sharpness of specular highlights.

Definition

Visual Basic .NET | Public Property SpecularSharpness As Single
C# | public float SpecularSharpness { get; set; }
Managed C++ public: __property float get_SpecularSharpness();
public: __property void set_SpecularSharpness(float);
JScript .NET public function get SpecularSharpness() : float
public function set SpecularSharpness(float);

Property Value

System.Single . Floating-point value that represents the sharpness of specular highlights.

This property is read/write.

Remarks

The higher the value, the sharper the highlight.


MeshData

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains mesh data.

Definition

Visual Basic .NET | Public Structure MeshData
C# | public struct MeshData
Managed C++ | public __value struct MeshData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
MeshData | Initializes a new instance of the MeshData class.

Properties

Property | Description
Mesh | Retrieves or sets the Mesh contained in the current object.
PatchMesh | Retrieves or sets the PatchMesh contained in the current object.
ProgressiveMesh | Retrieves or sets the ProgressiveMesh contained in the current object.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MeshData.MeshData()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshData.MeshData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MeshData class.

Definition

Visual Basic .NET | Public Sub New()
C# | public MeshData();
Managed C++ | public: MeshData();
JScript .NET | public function MeshData();


MeshData.Mesh

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshData.Mesh Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Mesh contained in the current object.

Definition

Visual Basic .NET | Public Property Mesh As Mesh
C# | public Mesh Mesh { get; set; }
Managed C++ public: __property Mesh* get_Mesh();
public: __property void set_Mesh(Mesh*);
JScript .NET public function get Mesh() : Mesh
public function set Mesh(Mesh);

Property Value

Microsoft.DirectX.Direct3D.Mesh . The Mesh object contained in the current object.

This property is read/write.


MeshData.PatchMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshData.PatchMesh Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the PatchMesh contained in the current object.

Definition

Visual Basic .NET | Public Property PatchMesh As PatchMesh
C# | public PatchMesh PatchMesh { get; set; }
Managed C++ public: __property PatchMesh* get_PatchMesh();
public: __property void set_PatchMesh(PatchMesh*);
JScript .NET public function get PatchMesh() : PatchMesh
public function set PatchMesh(PatchMesh);

Property Value

Microsoft.DirectX.Direct3D.PatchMesh . The PatchMesh object contained in the current object.

This property is read/write.


MeshData.ProgressiveMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshData.ProgressiveMesh Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ProgressiveMesh contained in the current object.

Definition

Visual Basic .NET | Public Property ProgressiveMesh As ProgressiveMesh
C# | public ProgressiveMesh ProgressiveMesh { get; set; }
Managed C++ public: __property ProgressiveMesh* get_ProgressiveMesh();
public: __property void set_ProgressiveMesh(ProgressiveMesh*);
JScript .NET public function get ProgressiveMesh() : ProgressiveMesh
public function set ProgressiveMesh(ProgressiveMesh);

Property Value

Microsoft.DirectX.Direct3D.ProgressiveMesh . The ProgressiveMesh object contained in the current object.

This property is read/write.


MeshOptions

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the type of mesh optimization to perform.

Definition

Visual Basic .NET | Public Structure MeshOptions
C# | public struct MeshOptions
Managed C++ | public __value struct MeshOptions
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
MeshOptions | Initializes a new instance of the MeshOptions class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DoNotClip | Specifies whether Usage.DoNotClip should be used for vertex and index buffers.
Dynamic | Specifies whether Usage.Dynamic should be used for vertex and index buffers.
IndexBufferDynamic | Specifies whether Usage.Dynamic should be used for index buffers.
IndexBufferManaged | Specifies whether Pool.Managed should be used for index buffers.
IndexBufferSoftwareProcessing | Specifies whether Usage.SoftwareProcessing should be used for index buffers.
IndexBufferSystemMem | Specifies whether Pool.SystemMemory should be used for index buffers.
IndexBufferWriteOnly | Specifies whether Usage.WriteOnly should be used for index buffers.
Managed | Specifies whether Pool.Managed should be used for vertex and index buffers.
NPatches | Specifies whether the index and vertex buffers of the mesh should be created with Usage.NPatches.
Points | Specifies whether Usage.Points should be used for index and vertex buffers.
RtPatches | Specifies whether Usage.RTPatches should be used for index and vertex buffers.
SoftwareProcessing | Specifies whether Usage.SoftwareProcessing should be used for vertex and index buffers.
SystemMem | Specifies whether Pool.SystemMemory should be used for vertex and index buffers.
Use32Bit | Specifies whether the mesh uses 32-bit indices instead of 16-bit indices.
Value | Specifies creation options for a mesh.
VertexBufferDynamic | Specifies whether Usage.Dynamic should be used for vertex buffers.
VertexBufferManaged | Specifies whether Pool.Managed should be used for vertex buffers.
VertexBufferSoftwareProcessing | Specifies whether Usage.SoftwareProcessing should be used for vertex buffers.
VertexBufferSystemMem | Specifies whether Pool.SystemMemory should be used for vertex buffers.
VertexBufferWriteOnly | Specifies whether Usage.WriteOnly should be used for vertex buffers.
WriteOnly | Specifies whether Usage.WriteOnly should be used for vertex and index buffers.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MeshOptions.MeshOptions

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.MeshOptions Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MeshOptions class.

Overload List

public MeshOptions();
public MeshOptions(MeshFlags);
public MeshOptions(MeshFlags[]);


MeshOptions.MeshOptions(MeshFlags[])

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.MeshOptions Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MeshOptions class.

Definition

Visual Basic .NET Public Sub New( _
ByVal initialFlags() As MeshFlags _
)
C# public MeshOptions(
MeshFlags[] initialFlags
);
Managed C++ public: MeshOptions(
MeshFlags initialFlags __gc[]
);
JScript .NET public function MeshOptions(
initialFlags : MeshFlags[]
);

Parameters

initialFlags Microsoft.DirectX.Direct3D.MeshFlags[]. Array of MeshFlags objects that specify the mesh creation options.


MeshOptions.MeshOptions(MeshFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.MeshOptions Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MeshOptions class.

Definition

Visual Basic .NET Public Sub New( _
ByVal initialFlag As MeshFlags _
)
C# public MeshOptions(
MeshFlags initialFlag
);
Managed C++ public: MeshOptions(
MeshFlags initialFlag
);
JScript .NET public function MeshOptions(
initialFlag : MeshFlags
);

Parameters

initialFlag Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags object that specifies the mesh creation options.


MeshOptions.MeshOptions()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.MeshOptions Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MeshOptions class.

Definition

Visual Basic .NET | Public Sub New()
C# | public MeshOptions();
Managed C++ | public: MeshOptions();
JScript .NET | public function MeshOptions();


MeshOptions.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


MeshOptions.DoNotClip

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.DoNotClip Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.DoNotClip should be used for vertex and index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property DoNotClip As Boolean
C# | public bool DoNotClip { get; }
Managed C++ | public: __property bool get_DoNotClip();
JScript .NET | public function get DoNotClip() : boolean

Property Value

System.Boolean . Value that is true if Usage.DoNotClip should be used, or false if it should not.

This property is read-only.


MeshOptions.Dynamic

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.Dynamic Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.Dynamic should be used for vertex and index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property Dynamic As Boolean
C# | public bool Dynamic { get; }
Managed C++ | public: __property bool get_Dynamic();
JScript .NET | public function get Dynamic() : boolean

Property Value

System.Boolean . Value that is true if Usage.Dynamic should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferDynamic and MeshOptions.VertexBufferDynamic.


MeshOptions.IndexBufferDynamic

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.IndexBufferDynamic Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.Dynamic should be used for index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property IndexBufferDynamic As Boolean
C# | public bool IndexBufferDynamic { get; }
Managed C++ | public: __property bool get_IndexBufferDynamic();
JScript .NET | public function get IndexBufferDynamic() : boolean

Property Value

System.Boolean . Value that is true if Usage.Dynamic should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferManaged

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.IndexBufferManaged Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Pool.Managed should be used for index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property IndexBufferManaged As Boolean
C# | public bool IndexBufferManaged { get; }
Managed C++ | public: __property bool get_IndexBufferManaged();
JScript .NET | public function get IndexBufferManaged() : boolean

Property Value

System.Boolean . Value that is true if Pool.Managed should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferSoftwareProcessing

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.IndexBufferSoftwareProcessing Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.SoftwareProcessing should be used for index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property IndexBufferSoftwareProcessing As Boolean
C# | public bool IndexBufferSoftwareProcessing { get; }
Managed C++ | public: __property bool get_IndexBufferSoftwareProcessing();
JScript .NET | public function get IndexBufferSoftwareProcessing() : boolean

Property Value

System.Boolean . Value that is true if Usage.SoftwareProcessing should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferSystemMem

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.IndexBufferSystemMem Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Pool.SystemMemory should be used for index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property IndexBufferSystemMem As Boolean
C# | public bool IndexBufferSystemMem { get; }
Managed C++ | public: __property bool get_IndexBufferSystemMem();
JScript .NET | public function get IndexBufferSystemMem() : boolean

Property Value

System.Boolean . Value that is true if Pool.SystemMemory should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferWriteOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.IndexBufferWriteOnly Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.WriteOnly should be used for index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property IndexBufferWriteOnly As Boolean
C# | public bool IndexBufferWriteOnly { get; }
Managed C++ | public: __property bool get_IndexBufferWriteOnly();
JScript .NET | public function get IndexBufferWriteOnly() : boolean

Property Value

System.Boolean . Value that is true if Usage.WriteOnly should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.Managed

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.Managed Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Pool.Managed should be used for vertex and index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property Managed As Boolean
C# | public bool Managed { get; }
Managed C++ | public: __property bool get_Managed();
JScript .NET | public function get Managed() : boolean

Property Value

System.Boolean . Value that is true if Pool.Managed should be used for vertex and index buffers, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferManaged and MeshOptions.VertexBufferManaged.


MeshOptions.NPatches

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.NPatches Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the index and vertex buffers of the mesh should be created with Usage.NPatches.

Definition

Visual Basic .NET | Public ReadOnly Property NPatches As Boolean
C# | public bool NPatches { get; }
Managed C++ | public: __property bool get_NPatches();
JScript .NET | public function get NPatches() : boolean

Property Value

System.Boolean . Value that is true if Usage.NPatches should be used, or false if it should not.

This property is read-only.

Remarks

This property is required if the mesh object is rendered with N-patch enhancement using Microsoft® Direct3D®.


MeshOptions.Points

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.Points Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.Points should be used for index and vertex buffers.

Definition

Visual Basic .NET | Public ReadOnly Property Points As Boolean
C# | public bool Points { get; }
Managed C++ | public: __property bool get_Points();
JScript .NET | public function get Points() : boolean

Property Value

System.Boolean . Value that is true if Usage.Points should be used for index and vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.RtPatches

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.RtPatches Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.RTPatches should be used for index and vertex buffers.

Definition

Visual Basic .NET | Public ReadOnly Property RtPatches As Boolean
C# | public bool RtPatches { get; }
Managed C++ | public: __property bool get_RtPatches();
JScript .NET | public function get RtPatches() : boolean

Property Value

System.Boolean . Value that is true if Usage.RTPatches should be used for index and vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.SoftwareProcessing

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.SoftwareProcessing Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.SoftwareProcessing should be used for vertex and index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property SoftwareProcessing As Boolean
C# | public bool SoftwareProcessing { get; }
Managed C++ | public: __property bool get_SoftwareProcessing();
JScript .NET | public function get SoftwareProcessing() : boolean

Property Value

System.Boolean . Value that is true if Usage.SoftwareProcessing should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferSoftwareProcessing and MeshOptions.VertexBufferSoftwareProcessing.


MeshOptions.SystemMem

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.SystemMem Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Pool.SystemMemory should be used for vertex and index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property SystemMem As Boolean
C# | public bool SystemMem { get; }
Managed C++ | public: __property bool get_SystemMem();
JScript .NET | public function get SystemMem() : boolean

Property Value

System.Boolean . Value that is true if Pool.SystemMemory should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferSystemMemory and MeshOptions.VertexBufferSystemMemory.


MeshOptions.Use32Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.Use32Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the mesh uses 32-bit indices instead of 16-bit indices.

Definition

Visual Basic .NET | Public ReadOnly Property Use32Bit As Boolean
C# | public bool Use32Bit { get; }
Managed C++ | public: __property bool get_Use32Bit();
JScript .NET | public function get Use32Bit() : boolean

Property Value

System.Boolean . Value that is true if the mesh uses 32-bit indices, or false if it uses 16-bit indices.

This property is read-only.


MeshOptions.Value

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.Value Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies creation options for a mesh.

Definition

Visual Basic .NET | Public Property Value As MeshFlags
C# | public MeshFlags Value { get; set; }
Managed C++ public: __property MeshFlags get_Value();
public: __property void set_Value(MeshFlags);
JScript .NET public function get Value() : MeshFlags
public function set Value(MeshFlags);

Property Value

Microsoft.DirectX.Direct3D.MeshFlags . One or more values of the MeshFlags enumeration to set or retrieve.

This property is read/write.


MeshOptions.VertexBufferDynamic

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.VertexBufferDynamic Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.Dynamic should be used for vertex buffers.

Definition

Visual Basic .NET | Public ReadOnly Property VertexBufferDynamic As Boolean
C# | public bool VertexBufferDynamic { get; }
Managed C++ | public: __property bool get_VertexBufferDynamic();
JScript .NET | public function get VertexBufferDynamic() : boolean

Property Value

System.Boolean . Value that is true if Usage.Dynamic should be used, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferManaged

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.VertexBufferManaged Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Pool.Managed should be used for vertex buffers.

Definition

Visual Basic .NET | Public ReadOnly Property VertexBufferManaged As Boolean
C# | public bool VertexBufferManaged { get; }
Managed C++ | public: __property bool get_VertexBufferManaged();
JScript .NET | public function get VertexBufferManaged() : boolean

Property Value

System.Boolean . Value that is true if Pool.Managed should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferSoftwareProcessing

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.VertexBufferSoftwareProcessing Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.SoftwareProcessing should be used for vertex buffers.

Definition

Visual Basic .NET | Public ReadOnly Property VertexBufferSoftwareProcessing As Boolean
C# | public bool VertexBufferSoftwareProcessing { get; }
Managed C++ | public: __property bool get_VertexBufferSoftwareProcessing();
JScript .NET | public function get VertexBufferSoftwareProcessing() : boolean

Property Value

System.Boolean . Value that is true if Usage.SoftwareProcessing should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferSystemMem

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.VertexBufferSystemMem Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Pool.SystemMemory should be used for vertex buffers.

Definition

Visual Basic .NET | Public ReadOnly Property VertexBufferSystemMem As Boolean
C# | public bool VertexBufferSystemMem { get; }
Managed C++ | public: __property bool get_VertexBufferSystemMem();
JScript .NET | public function get VertexBufferSystemMem() : boolean

Property Value

System.Boolean . Value that is true if Pool.SystemMemory should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferWriteOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.VertexBufferWriteOnly Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.WriteOnly should be used for vertex buffers.

Definition

Visual Basic .NET | Public ReadOnly Property VertexBufferWriteOnly As Boolean
C# | public bool VertexBufferWriteOnly { get; }
Managed C++ | public: __property bool get_VertexBufferWriteOnly();
JScript .NET | public function get VertexBufferWriteOnly() : boolean

Property Value

System.Boolean . Value that is true if Usage.WriteOnly should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.WriteOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

MeshOptions.WriteOnly Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether Usage.WriteOnly should be used for vertex and index buffers.

Definition

Visual Basic .NET | Public ReadOnly Property WriteOnly As Boolean
C# | public bool WriteOnly { get; }
Managed C++ | public: __property bool get_WriteOnly();
JScript .NET | public function get WriteOnly() : boolean

Property Value

System.Boolean . Value that is true if Usage.WriteOnly should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferWriteOnly and MeshOptions.VertexBufferWriteOnly.


MiscCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains miscellaneous driver primitive capabilities.

Definition

Visual Basic .NET | Public Structure MiscCaps
C# | public struct MiscCaps
Managed C++ | public __value struct MiscCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
HasFogVertexClamped | Specifies whether the device clamps the fog blend factor per vertex.
IsNullReference | Specifies whether the device is a reference device that does not render.
SupportsBlendOperation | Specifies whether the device supports alpha blend operations other than BlendOperation.Add.
SupportsClipPlaneScaledPoints | Specifies whether the device correctly clips scaled points (that is, those whose size is greater than 1.0) to user-defined clipping planes.
SupportsClipTransformedVertices | Specifies whether the device clips post-transformed vertex primitives.
SupportsColorWrite | Specifies whether the device supports per-channel writes for the render target color buffer.
SupportsCullClockwise | Specifies whether the driver supports clockwise triangle culling through RenderStateManager.CullMode.
SupportsCullCounterClockwise | Specifies whether the driver supports counterclockwise triangle culling through RenderStateManager.CullMode.
SupportsCullNone | Specifies whether the driver does not perform triangle culling.
SupportsFogAndSpecularAlpha | Specifies whether the device supports separate fog and specular alpha.
SupportsIndependentWriteMasks | Specifies whether the device supports independent write masks for multiple element textures or multiple render targets.
SupportsMaskZ | Specifies whether the device can enable and disable modification of the depth buffer on pixel operations.
SupportsMultipleRenderTargetsIndependentBitDepths | Specifies whether the device supports independent bit depths for multiple render targets.
SupportsMultipleRenderTargetsPostPixelShaderBlending | Specifies whether the device supports multiple render targets after pixel shader blending.
SupportsPerStageConstant | Specifies whether the device supports per-stage constants.
SupportsSeparateAlphaBlend | Specifies whether the device supports separate alpha blending.
SupportsTextureStageStateArgumentTemp | Specifies whether the device supports TextureArgument for temporary registers.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MiscCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


MiscCaps.HasFogVertexClamped

MiscCaps.HasFogVertexClamped Property

Note: This documentation is preliminary and is subject to change.

Specifies whether the device clamps the fog blend factor per vertex.

Definition

Visual Basic .NET | Public ReadOnly Property HasFogVertexClamped As Boolean
C# | public bool HasFogVertexClamped { get; }
Managed C++ | public: __property bool get_HasFogVertexClamped();
JScript .NET | public function get HasFogVertexClamped() : boolean

Property Value

System.Boolean . Value that is true if the device clamps vertex fog, or false if it does not.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


MiscCaps.IsNullReference

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.IsNullReference Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device is a reference device that does not render.

Definition

Visual Basic .NET | Public ReadOnly Property IsNullReference As Boolean
C# | public bool IsNullReference { get; }
Managed C++ | public: __property bool get_IsNullReference();
JScript .NET | public function get IsNullReference() : boolean

Property Value

System.Boolean . Value that is true if the device is a reference device that does not render, or false otherwise.

This property is read-only.


MiscCaps.SupportsBlendOperation

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsBlendOperation Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports alpha blend operations other than BlendOperation.Add.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlendOperation As Boolean
C# | public bool SupportsBlendOperation { get; }
Managed C++ | public: __property bool get_SupportsBlendOperation();
JScript .NET | public function get SupportsBlendOperation() : boolean

Property Value

System.Boolean . Value that is true if the device supports other alpha blending operations, or false if it does not.

This property is read-only.


MiscCaps.SupportsClipPlaneScaledPoints

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsClipPlaneScaledPoints Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device correctly clips scaled points (that is, those whose size is greater than 1.0) to user-defined clipping planes.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsClipPlaneScaledPoints As Boolean
C# | public bool SupportsClipPlaneScaledPoints { get; }
Managed C++ | public: __property bool get_SupportsClipPlaneScaledPoints();
JScript .NET | public function get SupportsClipPlaneScaledPoints() : boolean

Property Value

System.Boolean . Value that is true if the device correctly clips scaled points, or false if it does not.

This property is read-only.


MiscCaps.SupportsClipTransformedVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsClipTransformedVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device clips post-transformed vertex primitives.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsClipTransformedVertices As Boolean
C# | public bool SupportsClipTransformedVertices { get; }
Managed C++ | public: __property bool get_SupportsClipTransformedVertices();
JScript .NET | public function get SupportsClipTransformedVertices() : boolean

Property Value

System.Boolean . Value that is true if the device clips post-transformed vertex primitives, or false if it does not.

This property is read-only.


MiscCaps.SupportsColorWrite

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsColorWrite Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports per-channel writes for the render target color buffer.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsColorWrite As Boolean
C# | public bool SupportsColorWrite { get; }
Managed C++ | public: __property bool get_SupportsColorWrite();
JScript .NET | public function get SupportsColorWrite() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-channel writes for the render-target color buffer, or false if it does not.

This property is read-only.


MiscCaps.SupportsCullClockwise

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsCullClockwise Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the driver supports clockwise triangle culling through RenderStateManager.CullMode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsCullClockwise As Boolean
C# | public bool SupportsCullClockwise { get; }
Managed C++ | public: __property bool get_SupportsCullClockwise();
JScript .NET | public function get SupportsCullClockwise() : boolean

Property Value

System.Boolean . Value that is true if the driver supports clockwise triangle culling, or false if it does not.

This property is read-only.


MiscCaps.SupportsCullCounterClockwise

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsCullCounterClockwise Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the driver supports counterclockwise triangle culling through RenderStateManager.CullMode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsCullCounterClockwise As Boolean
C# | public bool SupportsCullCounterClockwise { get; }
Managed C++ | public: __property bool get_SupportsCullCounterClockwise();
JScript .NET | public function get SupportsCullCounterClockwise() : boolean

Property Value

System.Boolean . Value that is true if the driver supports counterclockwise triangle culling, or false if it does not.

This property is read-only.


MiscCaps.SupportsCullNone

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsCullNone Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the driver does not perform triangle culling.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsCullNone As Boolean
C# | public bool SupportsCullNone { get; }
Managed C++ | public: __property bool get_SupportsCullNone();
JScript .NET | public function get SupportsCullNone() : boolean

Property Value

System.Boolean . Value that is true if the driver does not perform triangle culling, or false if it does.

This property is read-only.


MiscCaps.SupportsFogAndSpecularAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsFogAndSpecularAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports separate fog and specular alpha.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFogAndSpecularAlpha As Boolean
C# | public bool SupportsFogAndSpecularAlpha { get; }
Managed C++ | public: __property bool get_SupportsFogAndSpecularAlpha();
JScript .NET | public function get SupportsFogAndSpecularAlpha() : boolean

Property Value

System.Boolean . Value that is true if the device supports separate fog and specular alpha, or false if it does not.

This property is read-only.

Remarks

Many devices use the specular alpha channel to store the fog factor.


MiscCaps.SupportsIndependentWriteMasks

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsIndependentWriteMasks Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports independent write masks for multiple element textures or multiple render targets.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsIndependentWriteMasks As Boolean
C# | public bool SupportsIndependentWriteMasks { get; }
Managed C++ | public: __property bool get_SupportsIndependentWriteMasks();
JScript .NET | public function get SupportsIndependentWriteMasks() : boolean

Property Value

System.Boolean . Value that is true if the device supports independent write masks, or false if it does not.

This property is read-only.


MiscCaps.SupportsMaskZ

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsMaskZ Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device can enable and disable modification of the depth buffer on pixel operations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMaskZ As Boolean
C# | public bool SupportsMaskZ { get; }
Managed C++ | public: __property bool get_SupportsMaskZ();
JScript .NET | public function get SupportsMaskZ() : boolean

Property Value

System.Boolean . Value that is true if the device can enable and disable modification of the depth buffer, or false if it cannot.

This property is read-only.


MiscCaps.SupportsMultipleRenderTargetsIndependentBitDepths

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsMultipleRenderTargetsIndependentBitDepths Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports independent bit depths for multiple render targets.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMultipleRenderTargetsIndependentBitDepths As Boolean
C# | public bool SupportsMultipleRenderTargetsIndependentBitDepths { get; }
Managed C++ | public: __property bool get_SupportsMultipleRenderTargetsIndependentBitDepths();
JScript .NET | public function get SupportsMultipleRenderTargetsIndependentBitDepths() : boolean

Property Value

System.Boolean . Value that is true if the device supports independent bit depths, or false if it does not.

This property is read-only.


MiscCaps.SupportsMultipleRenderTargetsPostPixelShaderBlending

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsMultipleRenderTargetsPostPixelShaderBlending Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports multiple render targets after pixel shader blending.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMultipleRenderTargetsPostPixelShaderBlending As Boolean
C# | public bool SupportsMultipleRenderTargetsPostPixelShaderBlending { get; }
Managed C++ | public: __property bool get_SupportsMultipleRenderTargetsPostPixelShaderBlending();
JScript .NET | public function get SupportsMultipleRenderTargetsPostPixelShaderBlending() : boolean

Property Value

System.Boolean . Value that is true if the device supports multiple render targets after pixel shader blending, or false if it does not.

This property is read-only.


MiscCaps.SupportsPerStageConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsPerStageConstant Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports per-stage constants.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPerStageConstant As Boolean
C# | public bool SupportsPerStageConstant { get; }
Managed C++ | public: __property bool get_SupportsPerStageConstant();
JScript .NET | public function get SupportsPerStageConstant() : boolean

Property Value

System.Boolean . Value that is true if the device supports per-stage constants, or false if it does not.

This property is read-only.


MiscCaps.SupportsSeparateAlphaBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsSeparateAlphaBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports separate alpha blending.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSeparateAlphaBlend As Boolean
C# | public bool SupportsSeparateAlphaBlend { get; }
Managed C++ | public: __property bool get_SupportsSeparateAlphaBlend();
JScript .NET | public function get SupportsSeparateAlphaBlend() : boolean

Property Value

System.Boolean . Value that is true if the device supports separate alpha blending, or false if it does not.

This property is read-only.


MiscCaps.SupportsTextureStageStateArgumentTemp

Microsoft DirectX 9.0 SDK Update (October 2004)

MiscCaps.SupportsTextureStageStateArgumentTemp Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports TextureArgument for temporary registers.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureStageStateArgumentTemp As Boolean
C# | public bool SupportsTextureStageStateArgumentTemp { get; }
Managed C++ | public: __property bool get_SupportsTextureStageStateArgumentTemp();
JScript .NET | public function get SupportsTextureStageStateArgumentTemp() : boolean

Property Value

System.Boolean . Value that is true if the device supports TextureArgument for temporary registers, or false if it does not.

This property is read-only.


MyD3DXAllocateHierarchy

Microsoft DirectX 9.0 SDK Update (October 2004)

MyD3DXAllocateHierarchy Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Not supported.

Definition

Visual Basic .NET | Public Structure MyD3DXAllocateHierarchy
C# | public struct MyD3DXAllocateHierarchy
Managed C++ | public __value struct MyD3DXAllocateHierarchy
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MyD3DXAnimationCallback

Microsoft DirectX 9.0 SDK Update (October 2004)

MyD3DXAnimationCallback Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Not supported.

Definition

Visual Basic .NET | Public Structure MyD3DXAnimationCallback
C# | public struct MyD3DXAnimationCallback
Managed C++ | public __value struct MyD3DXAnimationCallback
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MyD3DXFrame

Microsoft DirectX 9.0 SDK Update (October 2004)

MyD3DXFrame Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Not supported.

Definition

Visual Basic .NET | Public Structure MyD3DXFrame
C# | public struct MyD3DXFrame
Managed C++ | public __value struct MyD3DXFrame
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MyD3DXIncludeClass

Microsoft DirectX 9.0 SDK Update (October 2004)

MyD3DXIncludeClass Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Not supported.

Definition

Visual Basic .NET | Public Structure MyD3DXIncludeClass
C# | public struct MyD3DXIncludeClass
Managed C++ | public __value struct MyD3DXIncludeClass
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MyD3DXLoadUserData

Microsoft DirectX 9.0 SDK Update (October 2004)

MyD3DXLoadUserData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Not supported.

Definition

Visual Basic .NET | Public Structure MyD3DXLoadUserData
C# | public struct MyD3DXLoadUserData
Managed C++ | public __value struct MyD3DXLoadUserData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MyD3DXMeshContainer

Microsoft DirectX 9.0 SDK Update (October 2004)

MyD3DXMeshContainer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Not supported.

Definition

Visual Basic .NET | Public Structure MyD3DXMeshContainer
C# | public struct MyD3DXMeshContainer
Managed C++ | public __value struct MyD3DXMeshContainer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MyD3DXSaveUserData

Microsoft DirectX 9.0 SDK Update (October 2004)

MyD3DXSaveUserData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Not supported.

Definition

Visual Basic .NET | Public Structure MyD3DXSaveUserData
C# | public struct MyD3DXSaveUserData
Managed C++ | public __value struct MyD3DXSaveUserData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PaletteEntry

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the color and usage of an entry in a logical palette.

Definition

Visual Basic .NET | Public Structure PaletteEntry
C# | public struct PaletteEntry
Managed C++ | public __value struct PaletteEntry
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PaletteEntry | Initializes a new instance of the PaletteEntry class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Blue | Retrieves or sets the blue intensity value for the palette entry.
Flags | Retrieves or sets the alpha intensity value for the palette entry.
Green | Retrieves or sets the green intensity value for the palette entry.
Red | Retrieves or sets the red intensity value for the palette entry.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PaletteEntry.PaletteEntry

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.PaletteEntry Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PaletteEntry class.

Overload List

public PaletteEntry();
public PaletteEntry(byte, byte, byte, byte);


PaletteEntry.PaletteEntry()

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.PaletteEntry Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PaletteEntry class.

Definition

Visual Basic .NET | Public Sub New()
C# | public PaletteEntry();
Managed C++ | public: PaletteEntry();
JScript .NET | public function PaletteEntry();


PaletteEntry.PaletteEntry(Byte,Byte,Byte,Byte)

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.PaletteEntry Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PaletteEntry class.

Definition

Visual Basic .NET Public Sub New( _
ByVal red As Byte, _
ByVal green As Byte, _
ByVal blue As Byte, _
ByVal flags As Byte _
)
C# public PaletteEntry(
byte red,
byte green,
byte blue,
byte flags
);
Managed C++ public: PaletteEntry(
Byte red,
Byte green,
Byte blue,
Byte flags
);
JScript .NET public function PaletteEntry(
red : byte,
green : byte,
blue : byte,
flags : byte
);

Parameters

red | System.Byte. Red intensity value for the palette entry.
green | System.Byte. Green intensity value for the palette entry.
blue | System.Byte. Blue intensity value for the palette entry.
flags | System.Byte. Alpha intensity value for the palette entry.


PaletteEntry.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PaletteEntry.Blue

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Blue Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the blue intensity value for the palette entry.

Definition

Visual Basic .NET | Public Property Blue As Byte
C# | public byte Blue { get; set; }
Managed C++ public: __property Byte get_Blue();
public: __property void set_Blue(Byte);
JScript .NET public function get Blue() : byte
public function set Blue(byte);

Property Value

System.Byte . A Byte Leave Site value that represents the blue intensity for the palette entry.

This property is read/write.


PaletteEntry.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the alpha intensity value for the palette entry.

Definition

Visual Basic .NET | Public Property Flags As Byte
C# | public byte Flags { get; set; }
Managed C++ public: __property Byte get_Flags();
public: __property void set_Flags(Byte);
JScript .NET public function get Flags() : byte
public function set Flags(byte);

Property Value

System.Byte . A Byte Leave Site value that represents the alpha intensity for the palette entry.

This property is read/write.


PaletteEntry.Green

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Green Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the green intensity value for the palette entry.

Definition

Visual Basic .NET | Public Property Green As Byte
C# | public byte Green { get; set; }
Managed C++ public: __property Byte get_Green();
public: __property void set_Green(Byte);
JScript .NET public function get Green() : byte
public function set Green(byte);

Property Value

System.Byte . A Byte Leave Site value that represents the green intensity for the palette entry.

This property is read/write.


PaletteEntry.Red

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Red Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the red intensity value for the palette entry.

Definition

Visual Basic .NET | Public Property Red As Byte
C# | public byte Red { get; set; }
Managed C++ public: __property Byte get_Red();
public: __property void set_Red(Byte);
JScript .NET public function get Red() : byte
public function set Red(byte);

Property Value

System.Byte . A Byte Leave Site value that represents the red intensity for the palette entry.

This property is read/write.


ParameterDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a parameter that is used for an effect object.

Definition

Visual Basic .NET | Public Structure ParameterDescription
C# | public struct ParameterDescription
Managed C++ | public __value struct ParameterDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ParameterDescription | Initializes a new instance of the ParameterDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Retrieves the number of annotations for the parameter description.
Bytes | Contains the size of the parameter in bytes.
Class | Retrieves the parameter class, which is one of the values in the ParameterClass enumeration.
Columns | Retrieves the number of columns in the array.
Elements | Retrieves the number of elements in the array.
Flags | Retrieves the parameter attributes.
Name | Retrieves the name of the parameter.
Rows | Retrieves the number of rows in the array.
Semantic | Retrieves the semantic meaning, also called the usage.
StructMembers | Retrieves the number of structure members.
Type | Retrieves the parameter type, which is one of the values in the ParameterType enumeration.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ParameterDescription.ParameterDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.ParameterDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ParameterDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ParameterDescription();
Managed C++ | public: ParameterDescription();
JScript .NET | public function ParameterDescription();


ParameterDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ParameterDescription.Annotations

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Annotations Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of annotations for the parameter description.

Definition

Visual Basic .NET | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
Managed C++ | public: __property int get_Annotations();
JScript .NET | public function get Annotations() : int

Property Value

System.Int32 . Integer that represents the number of annotations.

This property is read-only.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


ParameterDescription.Bytes

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Bytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Contains the size of the parameter in bytes.

Definition

Visual Basic .NET | Public ReadOnly Property Bytes As Integer
C# | public int Bytes { get; }
Managed C++ | public: __property int get_Bytes();
JScript .NET | public function get Bytes() : int

Property Value

System.Int32 . Integer that represents the size of the parameter in bytes.

This property is read-only.


ParameterDescription.Class

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Class Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the parameter class, which is one of the values in the ParameterClass enumeration.

Definition

Visual Basic .NET | Public ReadOnly Property Class As ParameterClass
C# | public ParameterClass Class { get; }
Managed C++ | public: __property ParameterClass get_Class();
JScript .NET | public function get Class() : ParameterClass

Property Value

Microsoft.DirectX.Direct3D.ParameterClass . Value of the ParameterClass enumeration to retrieve.

This property is read-only.


ParameterDescription.Columns

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Columns Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of columns in the array.

Definition

Visual Basic .NET | Public ReadOnly Property Columns As Integer
C# | public int Columns { get; }
Managed C++ | public: __property int get_Columns();
JScript .NET | public function get Columns() : int

Property Value

System.Int32 . Integer that represents the number of columns in the array.

This property is read-only.


ParameterDescription.Elements

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Elements Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of elements in the array.

Definition

Visual Basic .NET | Public ReadOnly Property Elements As Integer
C# | public int Elements { get; }
Managed C++ | public: __property int get_Elements();
JScript .NET | public function get Elements() : int

Property Value

System.Int32 . Integer that represents the number of elements in the array.

This property is read-only.


ParameterDescription.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the parameter attributes.

Definition

Visual Basic .NET | Public ReadOnly Property Flags As ParameterFlags
C# | public ParameterFlags Flags { get; }
Managed C++ | public: __property ParameterFlags get_Flags();
JScript .NET | public function get Flags() : ParameterFlags

Property Value

Microsoft.DirectX.Direct3D.ParameterFlags .

This property is read-only.


ParameterDescription.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the name of the parameter.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . String that contains the parameter name.

This property is read-only.


ParameterDescription.Rows

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Rows Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of rows in the array.

Definition

Visual Basic .NET | Public ReadOnly Property Rows As Integer
C# | public int Rows { get; }
Managed C++ | public: __property int get_Rows();
JScript .NET | public function get Rows() : int

Property Value

System.Int32 . Integer that represents the number of rows in the array.

This property is read-only.


ParameterDescription.Semantic

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Semantic Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the semantic meaning, also called the usage.

Definition

Visual Basic .NET | Public ReadOnly Property Semantic As String
C# | public string Semantic { get; }
Managed C++ | public: __property String* get_Semantic();
JScript .NET | public function get Semantic() : String

Property Value

System.String . String that contains the semantic meaning.

This property is read-only.


ParameterDescription.StructMembers

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.StructMembers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of structure members.

Definition

Visual Basic .NET | Public ReadOnly Property StructMembers As Integer
C# | public int StructMembers { get; }
Managed C++ | public: __property int get_StructMembers();
JScript .NET | public function get StructMembers() : int

Property Value

System.Int32 . Integer that represents the number of structure members.

This property is read-only.


ParameterDescription.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterDescription.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the parameter type, which is one of the values in the ParameterType enumeration.

Definition

Visual Basic .NET | Public ReadOnly Property Type As ParameterType
C# | public ParameterType Type { get; }
Managed C++ | public: __property ParameterType get_Type();
JScript .NET | public function get Type() : ParameterType

Property Value

Microsoft.DirectX.Direct3D.ParameterType . Value of the ParameterType enumeration to retrieve.

This property is read-only.


PassDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

PassDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a pass for an effect object.

Definition

Visual Basic .NET | Public Structure PassDescription
C# | public struct PassDescription
Managed C++ | public __value struct PassDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PassDescription | Initializes a new instance of the PassDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Retrieves the number of annotations for the current pass description.
Name | Retrieves the name used for the pass.
PixelShaderFunction | Retrieves a GraphicsStream object that contains the pixel shader function.
VertexShaderFunction | Retrieves a GraphicsStream object that contains the vertex shader function.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PassDescription.PassDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

PassDescription.PassDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PassDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public PassDescription();
Managed C++ | public: PassDescription();
JScript .NET | public function PassDescription();


PassDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PassDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PassDescription.Annotations

Microsoft DirectX 9.0 SDK Update (October 2004)

PassDescription.Annotations Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of annotations for the current pass description.

Definition

Visual Basic .NET | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
Managed C++ | public: __property int get_Annotations();
JScript .NET | public function get Annotations() : int

Property Value

System.Int32 . Integer that represents the number of annotations to retrieve.

This property is read-only.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


PassDescription.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

PassDescription.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the name used for the pass.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . String that represents the pass name.

This property is read-only.


PassDescription.PixelShaderFunction

Microsoft DirectX 9.0 SDK Update (October 2004)

PassDescription.PixelShaderFunction Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a GraphicsStream object that contains the pixel shader function.

Definition

Visual Basic .NET | Public ReadOnly Property PixelShaderFunction As GraphicsStream
C# | public GraphicsStream PixelShaderFunction { get; }
Managed C++ | public: __property GraphicsStream* get_PixelShaderFunction();
JScript .NET | public function get PixelShaderFunction() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the pixel shader function to retrieve.

This property is read-only.


PassDescription.VertexShaderFunction

Microsoft DirectX 9.0 SDK Update (October 2004)

PassDescription.VertexShaderFunction Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a GraphicsStream object that contains the vertex shader function.

Definition

Visual Basic .NET | Public ReadOnly Property VertexShaderFunction As GraphicsStream
C# | public GraphicsStream VertexShaderFunction { get; }
Managed C++ | public: __property GraphicsStream* get_VertexShaderFunction();
JScript .NET | public function get VertexShaderFunction() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream . A GraphicsStream object that contains the vertex shader function to retrieve.

This property is read-only.


PatchInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains the attributes of a patch mesh.

Definition

Visual Basic .NET | Public Structure PatchInformation
C# | public struct PatchInformation
Managed C++ | public __value struct PatchInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PatchInformation | Initializes a new instance of the PatchInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BasisType | Retrieves or sets the type of curve used to construct the patch.
Degree | Retrieves or sets the degree of the curves used to construct the patch.
PatchType | Retrieves or sets the patch type.
TessellateLevel | Retrieves or sets the tessellation level.

Remarks

A mesh is a set of faces, each of which is described by a simple polygon. Objects can be created by connecting several meshes together. A patch mesh is made up of patches, which are four-sided pieces of geometry that are constructed from curves. The type of curve used and the curve's order can be varied so that the patch surface fits almost any surface shape.

The following types of patch combinations are supported.

Patch Type | Basis | Degree
Rectangle | Bezier | 2,3,5
Rectangle | B-spline | 2,3,5
Rectangle | Catmull-Rom | 3
Triangle | Bezier | 2,3,5
N-patch | N/A | 3

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PatchInformation.PatchInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchInformation.PatchInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PatchInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public PatchInformation();
Managed C++ | public: PatchInformation();
JScript .NET | public function PatchInformation();


PatchInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PatchInformation.BasisType

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchInformation.BasisType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the type of curve used to construct the patch.

Definition

Visual Basic .NET | Public Property BasisType As BasisType
C# | public BasisType BasisType { get; set; }
Managed C++ public: __property BasisType get_BasisType();
public: __property void set_BasisType(BasisType);
JScript .NET public function get BasisType() : BasisType
public function set BasisType(BasisType);

Property Value

Microsoft.DirectX.Direct3D.BasisType . Value of the BasisType enumeration to set or retrieve.

This property is read/write.


PatchInformation.Degree

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchInformation.Degree Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the degree of the curves used to construct the patch.

Definition

Visual Basic .NET | Public Property Degree As DegreeType
C# | public DegreeType Degree { get; set; }
Managed C++ public: __property DegreeType get_Degree();
public: __property void set_Degree(DegreeType);
JScript .NET public function get Degree() : DegreeType
public function set Degree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType . Value of the DegreeType enumeration to set or retrieve.

This property is read/write.


PatchInformation.PatchType

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchInformation.PatchType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the patch type.

Definition

Visual Basic .NET | Public Property PatchType As PatchType
C# | public PatchType PatchType { get; set; }
Managed C++ public: __property PatchType get_PatchType();
public: __property void set_PatchType(PatchType);
JScript .NET public function get PatchType() : PatchType
public function set PatchType(PatchType);

Property Value

Microsoft.DirectX.Direct3D.PatchType . Value of the PatchType enumeration to set or retrieve.

This property is read/write.


PatchInformation.TessellateLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

PatchInformation.TessellateLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the tessellation level.

Definition

Visual Basic .NET | Public Property TessellateLevel As Single()
C# | public float[] TessellateLevel { get; set; }
Managed C++ public: __property float get_TessellateLevel();
public: __property void set_TessellateLevel(float);
JScript .NET public function get TessellateLevel() : float[]
public function set TessellateLevel(float[]);

Property Value

System.Single[] . Array of four floating-point values that represent the tessellation level to set or retrieve.

This property is read/write.


PipelineTimings

Microsoft DirectX 9.0 SDK Update (October 2004)

PipelineTimings Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Provides percentage of time spent processing data in the pipeline.

Definition

Visual Basic .NET | Public Structure PipelineTimings
C# | public struct PipelineTimings
Managed C++ | public __value struct PipelineTimings
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PipelineTimings | Creates a new instance of the PipelineTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
GpuIdleTimePercent | Retrieves the percentage of time not processing anything.
OtherGpuProcessingTimePercent | Retrieves the percentage of time spent doing other processing.
PixelProcessingTimePercent | Retrieves the percentage of time spent running pixel shaders.
VertexProcessingTimePercent | Retrieves the percentage of time spent running vertex shaders.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PipelineTimings.PipelineTimings()

Microsoft DirectX 9.0 SDK Update (October 2004)

PipelineTimings.PipelineTimings Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the PipelineTimings structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public PipelineTimings();
Managed C++ | public: PipelineTimings();
JScript .NET | public function PipelineTimings();


PipelineTimings.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PipelineTimings.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PipelineTimings.GpuIdleTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

PipelineTimings.GpuIdleTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time not processing anything.

Definition

Visual Basic .NET | Public ReadOnly Property GpuIdleTimePercent As Single
C# | public float GpuIdleTimePercent { get; }
Managed C++ | public: __property float get_GpuIdleTimePercent();
JScript .NET | public function get GpuIdleTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time not processing anything.

This property is read-only.


PipelineTimings.OtherGpuProcessingTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

PipelineTimings.OtherGpuProcessingTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time spent doing other processing.

Definition

Visual Basic .NET | Public ReadOnly Property OtherGpuProcessingTimePercent As Single
C# | public float OtherGpuProcessingTimePercent { get; }
Managed C++ | public: __property float get_OtherGpuProcessingTimePercent();
JScript .NET | public function get OtherGpuProcessingTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time spent doing other processing.

This property is read-only.


PipelineTimings.PixelProcessingTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

PipelineTimings.PixelProcessingTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time spent running pixel shaders.

Definition

Visual Basic .NET | Public ReadOnly Property PixelProcessingTimePercent As Single
C# | public float PixelProcessingTimePercent { get; }
Managed C++ | public: __property float get_PixelProcessingTimePercent();
JScript .NET | public function get PixelProcessingTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time spent running pixel shaders.

This property is read-only.


PipelineTimings.VertexProcessingTimePercent

Microsoft DirectX 9.0 SDK Update (October 2004)

PipelineTimings.VertexProcessingTimePercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time spent running vertex shaders.

Definition

Visual Basic .NET | Public ReadOnly Property VertexProcessingTimePercent As Single
C# | public float VertexProcessingTimePercent { get; }
Managed C++ | public: __property float get_VertexProcessingTimePercent();
JScript .NET | public function get VertexProcessingTimePercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time spent running vertex shaders.

This property is read-only.


PixelShaderCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains pixel shader capabilities.

Definition

Visual Basic .NET | Public Structure PixelShaderCaps
C# | public struct PixelShaderCaps
Managed C++ | public __value struct PixelShaderCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) MaxDynamicFlowControlDepth | Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, and ifc).
static (Shared in Visual Basic .NET) MaxNumberInstructionSlots | Specifies the maximum number of instruction slots the driver supports.
static (Shared in Visual Basic .NET) MaxNumberTemps | Specifies the maximum number of temporary registers the driver supports.
static (Shared in Visual Basic .NET) MaxStaticFlowControlDepth | Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.
static (Shared in Visual Basic .NET) MinDynamicFlowControlDepth | Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, and ifc).
static (Shared in Visual Basic .NET) MinNumberInstructionSlots | Specifies the minimum number of instruction slots the driver supports.
static (Shared in Visual Basic .NET) MinNumberTemps | Specifies the minimum number of temporary registers supported.
static (Shared in Visual Basic .NET) MinStaticFlowControlDepth | Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DynamicFlowControlDepth | Retrieves a value that represents the depth of the dynamic flow-control instruction nesting.
NumberInstructionSlots | Retrieves the number of instruction slots the device supports.
NumberTemps | Retrieves the number of temporary registers the device supports.
StaticFlowControlDepth | Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.
SupportsArbitrarySwizzle | Determines whether arbitrary swizzle is supported.
SupportsGradientInstructions | Determines whether gradient instructions are supported.
SupportsNoDependentReadLimit | Determines whether there are no dependent read limits.
SupportsNoTextureInstructionLimit | Determines whether there are no limits on texture instructions.
SupportsPredication | Determines whether instruction predication as defined in the predication section is supported.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PixelShaderCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PixelShaderCaps.DynamicFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.DynamicFlowControlDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that represents the depth of the dynamic flow-control instruction nesting.

Definition

Visual Basic .NET | Public ReadOnly Property DynamicFlowControlDepth As Integer
C# | public int DynamicFlowControlDepth { get; }
Managed C++ | public: __property int get_DynamicFlowControlDepth();
JScript .NET | public function get DynamicFlowControlDepth() : int

Property Value

System.Int32 . Integer that represents the level of instruction nesting allowed. The acceptable range of values is 0 to 24.

This property is read-only.

Remarks

If this value is 0, the device does not support dynamic flow control. If it is non-zero, the device supports dynamic flow control (instructions if, break, and breakc).


PixelShaderCaps.NumberInstructionSlots

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.NumberInstructionSlots Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of instruction slots the device supports.

Definition

Visual Basic .NET | Public ReadOnly Property NumberInstructionSlots As Integer
C# | public int NumberInstructionSlots { get; }
Managed C++ | public: __property int get_NumberInstructionSlots();
JScript .NET | public function get NumberInstructionSlots() : int

Property Value

System.Int32 . Integer that represents the number of instruction slots supported. The acceptable range of values is 96 to 512.

This property is read-only.


PixelShaderCaps.NumberTemps

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.NumberTemps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of temporary registers the device supports.

Definition

Visual Basic .NET | Public ReadOnly Property NumberTemps As Integer
C# | public int NumberTemps { get; }
Managed C++ | public: __property int get_NumberTemps();
JScript .NET | public function get NumberTemps() : int

Property Value

System.Int32 . Integer that represents the number of temporary registers supported. The acceptable range of values is 12 to 32.

This property is read-only.


PixelShaderCaps.StaticFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.StaticFlowControlDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.

Definition

Visual Basic .NET | Public ReadOnly Property StaticFlowControlDepth As Integer
C# | public int StaticFlowControlDepth { get; }
Managed C++ | public: __property int get_StaticFlowControlDepth();
JScript .NET | public function get StaticFlowControlDepth() : int

Property Value

System.Int32 . Integer that represents instruction nesting depth. The acceptable range of values is 0 to 4.

This property is read-only.

Remarks

If this value is 0, the device does not support static flow control.


PixelShaderCaps.SupportsArbitrarySwizzle

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.SupportsArbitrarySwizzle Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether arbitrary swizzle is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsArbitrarySwizzle As Boolean
C# | public bool SupportsArbitrarySwizzle { get; }
Managed C++ | public: __property bool get_SupportsArbitrarySwizzle();
JScript .NET | public function get SupportsArbitrarySwizzle() : boolean

Property Value

System.Boolean . Value that is true if arbitrary swizzle is supported, or false if it is not.

This property is read-only.


PixelShaderCaps.SupportsGradientInstructions

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.SupportsGradientInstructions Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether gradient instructions are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsGradientInstructions As Boolean
C# | public bool SupportsGradientInstructions { get; }
Managed C++ | public: __property bool get_SupportsGradientInstructions();
JScript .NET | public function get SupportsGradientInstructions() : boolean

Property Value

System.Boolean . Value that is true if gradient instructions are supported, or false if they are not.

This property is read-only.


PixelShaderCaps.SupportsNoDependentReadLimit

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.SupportsNoDependentReadLimit Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether there are no dependent read limits.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNoDependentReadLimit As Boolean
C# | public bool SupportsNoDependentReadLimit { get; }
Managed C++ | public: __property bool get_SupportsNoDependentReadLimit();
JScript .NET | public function get SupportsNoDependentReadLimit() : boolean

Property Value

System.Boolean . Value that is true if there are no dependent read limits, or false if there are dependent read limits.

This property is read-only.


PixelShaderCaps.SupportsNoTextureInstructionLimit

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.SupportsNoTextureInstructionLimit Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether there are no limits on texture instructions.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNoTextureInstructionLimit As Boolean
C# | public bool SupportsNoTextureInstructionLimit { get; }
Managed C++ | public: __property bool get_SupportsNoTextureInstructionLimit();
JScript .NET | public function get SupportsNoTextureInstructionLimit() : boolean

Property Value

System.Boolean . Value that is true if there are no limits on texture instructions, or false if there are limits on texture instructions.

This property is read-only.


PixelShaderCaps.SupportsPredication

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.SupportsPredication Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether instruction predication as defined in the predication section is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPredication As Boolean
C# | public bool SupportsPredication { get; }
Managed C++ | public: __property bool get_SupportsPredication();
JScript .NET | public function get SupportsPredication() : boolean

Property Value

System.Boolean . Value that is true if instruction predication is supported, or false if it is not.

This property is read-only.


PixelShaderCaps.MaxDynamicFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MaxDynamicFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, and ifc).

Definition

Visual Basic .NET | Public Shared MaxDynamicFlowControlDepth As Int32
C# | public static Int32 MaxDynamicFlowControlDepth;
Managed C++ | public: static Int32 MaxDynamicFlowControlDepth;
JScript .NET | public static var MaxDynamicFlowControlDepth : Int32

Field Value

System.Int32 . Value of 24.

This field is read-only.


PixelShaderCaps.MaxNumberInstructionSlots

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MaxNumberInstructionSlots Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the maximum number of instruction slots the driver supports.

Definition

Visual Basic .NET | Public Shared MaxNumberInstructionSlots As Int32
C# | public static Int32 MaxNumberInstructionSlots;
Managed C++ | public: static Int32 MaxNumberInstructionSlots;
JScript .NET | public static var MaxNumberInstructionSlots : Int32

Field Value

System.Int32 . Value of 512.

This field is read-only.


PixelShaderCaps.MaxNumberTemps

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MaxNumberTemps Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the maximum number of temporary registers the driver supports.

Definition

Visual Basic .NET | Public Shared MaxNumberTemps As Int32
C# | public static Int32 MaxNumberTemps;
Managed C++ | public: static Int32 MaxNumberTemps;
JScript .NET | public static var MaxNumberTemps : Int32

Field Value

System.Int32 . Value of 512.

This field is read-only.


PixelShaderCaps.MaxStaticFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MaxStaticFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic .NET | Public Shared MaxStaticFlowControlDepth As Int32
C# | public static Int32 MaxStaticFlowControlDepth;
Managed C++ | public: static Int32 MaxStaticFlowControlDepth;
JScript .NET | public static var MaxStaticFlowControlDepth : Int32

Field Value

System.Int32 . Value of 4.

This field is read-only.


PixelShaderCaps.MinDynamicFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MinDynamicFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, and ifc).

Definition

Visual Basic .NET | Public Shared MinDynamicFlowControlDepth As Int32
C# | public static Int32 MinDynamicFlowControlDepth;
Managed C++ | public: static Int32 MinDynamicFlowControlDepth;
JScript .NET | public static var MinDynamicFlowControlDepth : Int32

Field Value

System.Int32 . Value of 0.

This field is read-only.


PixelShaderCaps.MinNumberInstructionSlots

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MinNumberInstructionSlots Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the minimum number of instruction slots the driver supports.

Definition

Visual Basic .NET | Public Shared MinNumberInstructionSlots As Int32
C# | public static Int32 MinNumberInstructionSlots;
Managed C++ | public: static Int32 MinNumberInstructionSlots;
JScript .NET | public static var MinNumberInstructionSlots : Int32

Field Value

System.Int32 . Value of 96.

This field is read-only.


PixelShaderCaps.MinNumberTemps

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MinNumberTemps Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the minimum number of temporary registers supported.

Definition

Visual Basic .NET | Public Shared MinNumberTemps As Int32
C# | public static Int32 MinNumberTemps;
Managed C++ | public: static Int32 MinNumberTemps;
JScript .NET | public static var MinNumberTemps : Int32

Field Value

System.Int32 . Value of 12.

This field is read-only.


PixelShaderCaps.MinStaticFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelShaderCaps.MinStaticFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic .NET | Public Shared MinStaticFlowControlDepth As Int32
C# | public static Int32 MinStaticFlowControlDepth;
Managed C++ | public: static Int32 MinStaticFlowControlDepth;
JScript .NET | public static var MinStaticFlowControlDepth : Int32

Field Value

System.Int32 . Value of 1.

This field is read-only.


CustomVertex.PositionColored

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains position and color information.

Definition

Visual Basic .NET | Public Structure PositionColored
C# | public struct PositionColored
Managed C++ | public __value struct PositionColored
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionColored | Initializes a new instance of the CustomVertex.PositionColored class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.PositionColored structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.PositionColored.PositionColored

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.PositionColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionColored class.

Overload List

public PositionColored(float, float, float, int);
public PositionColored(Vector3, int);


CustomVertex.PositionColored.PositionColored(Vector3,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.PositionColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionColored class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Vector3, _
ByVal c As Integer _
)
C# public PositionColored(
Vector3 value,
int c
);
Managed C++ public: PositionColored(
Vector3 value,
int c
);
JScript .NET public function PositionColored(
value : Vector3,
c : int
);

Parameters

value | Microsoft.DirectX.Vector3. A Vector3 object that contains the position.
c | System.Int32. Integer that represents the diffuse color value.


CustomVertex.PositionColored.PositionColored(Single,Single,Single,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.PositionColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionColored class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal c As Integer _
)
C# public PositionColored(
float xvalue,
float yvalue,
float zvalue,
int c
);
Managed C++ public: PositionColored(
float xvalue,
float yvalue,
float zvalue,
int c
);
JScript .NET public function PositionColored(
xvalue : float,
yvalue : float,
zvalue : float,
c : int
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
c | System.Int32. Integer that represents the diffuse color value.


CustomVertex.PositionColored.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.PositionColored.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionColored.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.PositionColored structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure in bytes.

This property is read-only.


CustomVertex.PositionColored.Color

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.Color Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex color.

Definition

Visual Basic .NET | Public Color As Int32
C# | public Int32 Color;
Managed C++ | public: Int32 Color;
JScript .NET | public var Color : Int32

Field Value

System.Int32 . Integer that represents the vertex color.

This field is read/write.


CustomVertex.PositionColored.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionColored.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionColored.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionColored.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColored.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionColoredTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains position, color, and one set of texture coordinates.

Definition

Visual Basic .NET | Public Structure PositionColoredTextured
C# | public struct PositionColoredTextured
Managed C++ | public __value struct PositionColoredTextured
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionColoredTextured | Initializes a new instance of the CustomVertex.PositionColoredTextured class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.PositionColoredTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.PositionColoredTextured.PositionColoredTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.PositionColoredTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionColoredTextured class.

Overload List

public PositionColoredTextured(float, float, float, int, float, float);
public PositionColoredTextured(Vector3, int, float, float);


CustomVertex.PositionColoredTextured.PositionColoredTextured(Vector3,Int32,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.PositionColoredTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionColoredTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Vector3, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionColoredTextured(
Vector3 value,
int c,
float u,
float v
);
Managed C++ public: PositionColoredTextured(
Vector3 value,
int c,
float u,
float v
);
JScript .NET public function PositionColoredTextured(
value : Vector3,
c : int,
u : float,
v : float
);

Parameters

value | Microsoft.DirectX.Vector3. A Vector3 object that contains the position.
c | System.Int32. Integer that represents the vertex color value.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionColoredTextured.PositionColoredTextured(Single,Single,Single,Int32,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.PositionColoredTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionColoredTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionColoredTextured(
float xvalue,
float yvalue,
float zvalue,
int c,
float u,
float v
);
Managed C++ public: PositionColoredTextured(
float xvalue,
float yvalue,
float zvalue,
int c,
float u,
float v
);
JScript .NET public function PositionColoredTextured(
xvalue : float,
yvalue : float,
zvalue : float,
c : int,
u : float,
v : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
c | System.Int32. Integer that represents the vertex color value.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionColoredTextured.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.PositionColoredTextured.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionColoredTextured.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.PositionColoredTextured structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure in bytes.

This property is read-only.


CustomVertex.PositionColoredTextured.Color

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.Color Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex color.

Definition

Visual Basic .NET | Public Color As Int32
C# | public Int32 Color;
Managed C++ | public: Int32 Color;
JScript .NET | public var Color : Int32

Field Value

System.Int32 . Integer that represents the vertex color.

This field is read/write.


CustomVertex.PositionColoredTextured.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionColoredTextured.Tu

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.Tu Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic .NET | Public Tu As Single
C# | public Single Tu;
Managed C++ | public: Single Tu;
JScript .NET | public var Tu : Single

Field Value

System.Single . Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.PositionColoredTextured.Tv

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.Tv Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic .NET | Public Tv As Single
C# | public Single Tv;
Managed C++ | public: Single Tv;
JScript .NET | public var Tv : Single

Field Value

System.Single . Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.PositionColoredTextured.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionColoredTextured.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionColoredTextured.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionColoredTextured.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionNormal

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains position and normal data.

Definition

Visual Basic .NET | Public Structure PositionNormal
C# | public struct PositionNormal
Managed C++ | public __value struct PositionNormal
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Nx | Retrieves or sets the nx component of the vertex normal.
Ny | Retrieves or sets the ny component of the vertex normal.
Nz | Retrieves or sets the nz component of the vertex normal.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionNormal | Initializes a new instance of the CustomVertex.PositionNormal class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Normal | Retrieves or sets the vertex normal data.
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.PositionNormal structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.PositionNormal.PositionNormal

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.PositionNormal Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormal class.

Overload List

public PositionNormal(float, float, float, float, float, float);
public PositionNormal(Vector3, Vector3);


CustomVertex.PositionNormal.PositionNormal(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.PositionNormal Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormal class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pos As Vector3, _
ByVal nor As Vector3 _
)
C# public PositionNormal(
Vector3 pos,
Vector3 nor
);
Managed C++ public: PositionNormal(
Vector3 pos,
Vector3 nor
);
JScript .NET public function PositionNormal(
pos : Vector3,
nor : Vector3
);

Parameters

pos | Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex position.
nor | Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex normal data.


CustomVertex.PositionNormal.PositionNormal(Single,Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.PositionNormal Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormal class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal nxvalue As Single, _
ByVal nyvalue As Single, _
ByVal nzvalue As Single _
)
C# public PositionNormal(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue
);
Managed C++ public: PositionNormal(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue
);
JScript .NET public function PositionNormal(
xvalue : float,
yvalue : float,
zvalue : float,
nxvalue : float,
nyvalue : float,
nzvalue : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
nxvalue | System.Single. Floating-point value that represents the nx coordinate of the vertex normal.
nyvalue | System.Single. Floating-point value that represents the ny coordinate of the vertex normal.
nzvalue | System.Single. Floating-point value that represents the nz coordinate of the vertex normal.


CustomVertex.PositionNormal.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.PositionNormal.Normal

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Normal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex normal data.

Definition

Visual Basic .NET | Public Property Normal As Vector3
C# | public Vector3 Normal { get; set; }
Managed C++ public: __property Vector3 get_Normal();
public: __property void set_Normal(Vector3);
JScript .NET public function get Normal() : Vector3
public function set Normal(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex normal data.

This property is read/write.


CustomVertex.PositionNormal.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionNormal.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.PositionNormal structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionNormal.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionNormal.Nx

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Nx Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the nx component of the vertex normal.

Definition

Visual Basic .NET | Public Nx As Single
C# | public Single Nx;
Managed C++ | public: Single Nx;
JScript .NET | public var Nx : Single

Field Value

System.Single . Floating-point value that represents the nx component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormal.Ny

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Ny Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ny component of the vertex normal.

Definition

Visual Basic .NET | Public Ny As Single
C# | public Single Ny;
Managed C++ | public: Single Ny;
JScript .NET | public var Ny : Single

Field Value

System.Single . Floating-point value that represents the ny component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormal.Nz

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Nz Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the nz component of the vertex normal.

Definition

Visual Basic .NET | Public Nz As Single
C# | public Single Nz;
Managed C++ | public: Single Nz;
JScript .NET | public var Nz : Single

Field Value

System.Single . Floating-point value that represents the nz component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormal.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionNormal.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionNormal.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormal.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionNormalColored

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains position, color, and normal data.

Definition

Visual Basic .NET | Public Structure PositionNormalColored
C# | public struct PositionNormalColored
Managed C++ | public __value struct PositionNormalColored
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Nx | Retrieves or sets the nx component of the vertex normal.
Ny | Retrieves or sets the ny component of the vertex normal.
Nz | Retrieves or sets the nz component of the vertex normal.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionNormalColored | Initializes a new instance of the CustomVertex.PositionNormalColored class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Normal | Retrieves or sets the vertex normal data.
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.PositionNormalColored structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.PositionNormalColored.PositionNormalColored

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.PositionNormalColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormalColored class.

Overload List

public PositionNormalColored(float, float, float, float, float, float, int);
public PositionNormalColored(Vector3, Vector3, int);


CustomVertex.PositionNormalColored.PositionNormalColored(Vector3,Vector3,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.PositionNormalColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormalColored class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pos As Vector3, _
ByVal nor As Vector3, _
ByVal c As Integer _
)
C# public PositionNormalColored(
Vector3 pos,
Vector3 nor,
int c
);
Managed C++ public: PositionNormalColored(
Vector3 pos,
Vector3 nor,
int c
);
JScript .NET public function PositionNormalColored(
pos : Vector3,
nor : Vector3,
c : int
);

Parameters

pos | Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex position.
nor | Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex normal data.
c | System.Int32. Integer that represents the vertex color value.


CustomVertex.PositionNormalColored.PositionNormalColored(Single,Single,Single,Single,Single,Single,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.PositionNormalColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormalColored class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal nxvalue As Single, _
ByVal nyvalue As Single, _
ByVal nzvalue As Single, _
ByVal c As Integer _
)
C# public PositionNormalColored(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
int c
);
Managed C++ public: PositionNormalColored(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
int c
);
JScript .NET public function PositionNormalColored(
xvalue : float,
yvalue : float,
zvalue : float,
nxvalue : float,
nyvalue : float,
nzvalue : float,
c : int
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
nxvalue | System.Single. Floating-point value that represents the nx coordinate of the vertex normal.
nyvalue | System.Single. Floating-point value that represents the ny coordinate of the vertex normal.
nzvalue | System.Single. Floating-point value that represents the nz coordinate of the vertex normal.
c | System.Int32. Integer that represents the vertex color value.


CustomVertex.PositionNormalColored.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.PositionNormalColored.Normal

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Normal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex normal data.

Definition

Visual Basic .NET | Public Property Normal As Vector3
C# | public Vector3 Normal { get; set; }
Managed C++ public: __property Vector3 get_Normal();
public: __property void set_Normal(Vector3);
JScript .NET public function get Normal() : Vector3
public function set Normal(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex normal data.

This property is read/write.


CustomVertex.PositionNormalColored.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionNormalColored.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.PositionNormalColored structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionNormalColored.Color

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Color Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex color.

Definition

Visual Basic .NET | Public Color As Int32
C# | public Int32 Color;
Managed C++ | public: Int32 Color;
JScript .NET | public var Color : Int32

Field Value

System.Int32 . Integer that represents the vertex color.

This field is read/write.


CustomVertex.PositionNormalColored.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionNormalColored.Nx

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Nx Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the nx component of the vertex normal.

Definition

Visual Basic .NET | Public Nx As Single
C# | public Single Nx;
Managed C++ | public: Single Nx;
JScript .NET | public var Nx : Single

Field Value

System.Single . Floating-point value that represents the nx component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormalColored.Ny

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Ny Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the ny component of the vertex normal.

Definition

Visual Basic .NET | Public Ny As Single
C# | public Single Ny;
Managed C++ | public: Single Ny;
JScript .NET | public var Ny : Single

Field Value

System.Single . Floating-point value that represents the ny component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormalColored.Nz

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Nz Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the nz component of the vertex normal.

Definition

Visual Basic .NET | Public Nz As Single
C# | public Single Nz;
Managed C++ | public: Single Nz;
JScript .NET | public var Nz : Single

Field Value

System.Single . Floating-point value that represents the nz component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormalColored.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionNormalColored.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionNormalColored.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalColored.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionNormalTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Describes a custom vertex format structure that contains position, normal data, and one set of texture coordinates.

Definition

Visual Basic .NET | Public Structure PositionNormalTextured
C# | public struct PositionNormalTextured
Managed C++ | public __value struct PositionNormalTextured
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Nx | Retrieves or sets the nx component of the vertex normal.
Ny | Retrieves or sets the ny component of the vertex normal.
Nz | Retrieves or sets the nz component of the vertex normal.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionNormalTextured | Initializes a new instance of the CustomVertex.PositionNormalTextured class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Normal | Retrieves or sets the vertex normal data.
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.PositionNormalTextured structure.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.PositionNormalTextured.PositionNormalTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.PositionNormalTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormalTextured class.

Overload List

public PositionNormalTextured(float, float, float, float, float, float, float, float);
public PositionNormalTextured(Vector3, Vector3, float, float);


CustomVertex.PositionNormalTextured.PositionNormalTextured(Vector3,Vector3,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.PositionNormalTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormalTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pos As Vector3, _
ByVal nor As Vector3, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionNormalTextured(
Vector3 pos,
Vector3 nor,
float u,
float v
);
Managed C++ public: PositionNormalTextured(
Vector3 pos,
Vector3 nor,
float u,
float v
);
JScript .NET public function PositionNormalTextured(
pos : Vector3,
nor : Vector3,
u : float,
v : float
);

Parameters

pos | Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex position.
nor | Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex normal data.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionNormalTextured.PositionNormalTextured(Single,Single,Single,Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.PositionNormalTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionNormalTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal nxvalue As Single, _
ByVal nyvalue As Single, _
ByVal nzvalue As Single, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionNormalTextured(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
float u,
float v
);
Managed C++ public: PositionNormalTextured(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
float u,
float v
);
JScript .NET public function PositionNormalTextured(
xvalue : float,
yvalue : float,
zvalue : float,
nxvalue : float,
nyvalue : float,
nzvalue : float,
u : float,
v : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
nxvalue | System.Single. Floating-point value that represents the nx coordinate of the vertex normal.
nyvalue | System.Single. Floating-point value that represents the ny coordinate of the vertex normal.
nzvalue | System.Single. Floating-point value that represents the nz coordinate of the vertex normal.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionNormalTextured.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.PositionNormalTextured.Normal

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Normal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex normal data.

Definition

Visual Basic .NET | Public Property Normal As Vector3
C# | public Vector3 Normal { get; set; }
Managed C++ public: __property Vector3 get_Normal();
public: __property void set_Normal(Vector3);
JScript .NET public function get Normal() : Vector3
public function set Normal(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex normal data.

This property is read/write.


CustomVertex.PositionNormalTextured.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionNormalTextured.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.PositionNormalTextured structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionNormalTextured.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionNormalTextured.Nx

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Nx Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Retrieves or sets the nx component of the vertex normal.

Definition

Visual Basic .NET | Public Nx As Single
C# | public Single Nx;
Managed C++ | public: Single Nx;
JScript .NET | public var Nx : Single

Field Value

System.Single . Floating-point value that represents the nx component of the vertex normal.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Ny

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Ny Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Retrieves or sets the ny component of the vertex normal.

Definition

Visual Basic .NET | Public Ny As Single
C# | public Single Ny;
Managed C++ | public: Single Ny;
JScript .NET | public var Ny : Single

Field Value

System.Single . Floating-point value that represents the ny component of the vertex normal.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Nz

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Nz Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Retrieves or sets the nz component of the vertex normal.

Definition

Visual Basic .NET | Public Nz As Single
C# | public Single Nz;
Managed C++ | public: Single Nz;
JScript .NET | public var Nz : Single

Field Value

System.Single . Floating-point value that represents the nz component of the vertex normal.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Tu

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Tu Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic .NET | Public Tu As Single
C# | public Single Tu;
Managed C++ | public: Single Tu;
JScript .NET | public var Tu : Single

Field Value

System.Single . Floating-point value that represents the u component of the texture coordinate.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Tv

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Tv Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Mesh Object

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic .NET | Public Tv As Single
C# | public Single Tv;
Managed C++ | public: Single Tv;
JScript .NET | public var Tv : Single

Field Value

System.Single . Floating-point value that represents the v component of the texture coordinate.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionNormalTextured.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionNormalTextured.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionNormalTextured.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains only position data.

Definition

Visual Basic .NET | Public Structure PositionOnly
C# | public struct PositionOnly
Managed C++ | public __value struct PositionOnly
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionOnly | Initializes a new instance of the CustomVertex.PositionOnly class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.PositionOnly structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.PositionOnly.PositionOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.PositionOnly Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionOnly class.

Overload List

public PositionOnly(float, float, float);
public PositionOnly(Vector3);


CustomVertex.PositionOnly.PositionOnly(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.PositionOnly Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionOnly class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Vector3 _
)
C# public PositionOnly(
Vector3 value
);
Managed C++ public: PositionOnly(
Vector3 value
);
JScript .NET public function PositionOnly(
value : Vector3
);

Parameters

value Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex position.


CustomVertex.PositionOnly.PositionOnly(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.PositionOnly Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionOnly class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single _
)
C# public PositionOnly(
float xvalue,
float yvalue,
float zvalue
);
Managed C++ public: PositionOnly(
float xvalue,
float yvalue,
float zvalue
);
JScript .NET public function PositionOnly(
xvalue : float,
yvalue : float,
zvalue : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.


CustomVertex.PositionOnly.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.PositionOnly.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionOnly.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.PositionOnly structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionOnly.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionOnly.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionOnly.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionOnly.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionOnly.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains position and one set of texture coordinates.

Definition

Visual Basic .NET | Public Structure PositionTextured
C# | public struct PositionTextured
Managed C++ | public __value struct PositionTextured
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionTextured | Initializes a new instance of the CustomVertex.PositionTextured class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.PositionTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.PositionTextured.PositionTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.PositionTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionTextured class.

Overload List

public PositionTextured(float, float, float, float, float);
public PositionTextured(Vector3, float, float);


CustomVertex.PositionTextured.PositionTextured(Vector3,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.PositionTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pos As Vector3, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionTextured(
Vector3 pos,
float u,
float v
);
Managed C++ public: PositionTextured(
Vector3 pos,
float u,
float v
);
JScript .NET public function PositionTextured(
pos : Vector3,
u : float,
v : float
);

Parameters

pos | Microsoft.DirectX.Vector3. A Vector3 object that contains the vertex position.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionTextured.PositionTextured(Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.PositionTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.PositionTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionTextured(
float xvalue,
float yvalue,
float zvalue,
float u,
float v
);
Managed C++ public: PositionTextured(
float xvalue,
float yvalue,
float zvalue,
float u,
float v
);
JScript .NET public function PositionTextured(
xvalue : float,
yvalue : float,
zvalue : float,
u : float,
v : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionTextured.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.PositionTextured.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionTextured.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.PositionTextured structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionTextured.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionTextured.Tu

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.Tu Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic .NET | Public Tu As Single
C# | public Single Tu;
Managed C++ | public: Single Tu;
JScript .NET | public var Tu : Single

Field Value

System.Single . Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.PositionTextured.Tv

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.Tv Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic .NET | Public Tv As Single
C# | public Single Tv;
Managed C++ | public: Single Tv;
JScript .NET | public var Tv : Single

Field Value

System.Single . Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.PositionTextured.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionTextured.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionTextured.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.PositionTextured.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


PropertyDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a property used for an effect object.

Definition

Visual Basic .NET | Public Structure PropertyDescription
C# | public struct PropertyDescription
Managed C++ | public __value struct PropertyDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PropertyDescription | Initializes a new instance of the PropertyDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Bytes | Retrieves or sets the size of the property, in bytes.
Dimension | Retrieves or sets the dimension of the property.
Index | Retrieves or sets the index of the property.
Name | Retrieves or sets the name of the property.
Type | Retrieves or sets the property type.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PropertyDescription.PropertyDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription.PropertyDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PropertyDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public PropertyDescription();
Managed C++ | public: PropertyDescription();
JScript .NET | public function PropertyDescription();


PropertyDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PropertyDescription.Bytes

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription.Bytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the size of the property, in bytes.

Definition

Visual Basic .NET | Public Property Bytes As Integer
C# | public int Bytes { get; set; }
Managed C++ public: __property int get_Bytes();
public: __property void set_Bytes(int);
JScript .NET public function get Bytes() : int
public function set Bytes(int);

Property Value

System.Int32 . Integer that represents the property size to set or retrieve.

This property is read/write.


PropertyDescription.Dimension

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription.Dimension Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the dimension of the property.

Definition

Visual Basic .NET | Public Property Dimension As Integer
C# | public int Dimension { get; set; }
Managed C++ public: __property int get_Dimension();
public: __property void set_Dimension(int);
JScript .NET public function get Dimension() : int
public function set Dimension(int);

Property Value

System.Int32 . Integer that represents the property dimension to set or retrieve.

This property is read/write.


PropertyDescription.Index

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription.Index Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the index of the property.

Definition

Visual Basic .NET | Public Property Index As String
C# | public string Index { get; set; }
Managed C++ public: __property String* get_Index();
public: __property void set_Index(String*);
JScript .NET public function get Index() : String
public function set Index(String);

Property Value

System.String . String that represents the index of the property to set or retrieve.

This property is read/write.


PropertyDescription.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the name of the property.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String . String that contains the property name to set or retrieve.

This property is read/write.


PropertyDescription.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyDescription.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the property type.

Definition

Visual Basic .NET | Public Property Type As ParameterType
C# | public ParameterType Type { get; set; }
Managed C++ public: __property ParameterType get_Type();
public: __property void set_Type(ParameterType);
JScript .NET public function get Type() : ParameterType
public function set Type(ParameterType);

Property Value

Microsoft.DirectX.Direct3D.ParameterType . A ParameterType enumeration value that represents the property type to set or retrieve.

This property is read/write.


PrtSplitMeshClusterData

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains precomputed radiance transfer (PRT) split mesh cluster data.

Definition

Visual Basic .NET | Public Structure PrtSplitMeshClusterData
C# | public struct PrtSplitMeshClusterData
Managed C++ | public __value struct PrtSplitMeshClusterData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PrtSplitMeshClusterData | Initializes a new instance of the PrtSplitMeshClusterData structure.

Properties

Property | Description
ClusterLength | Retrieves or sets the number of clusters in this supercluster.
ClusterStart | Retrieves or sets the initial index into cluster array.
FaceLength | Retrieves or sets the number of faces in this supercluster.
FaceStart | Retrieves or sets the initial index into face array.
VertexLength | Retrieves or sets the number of vertices in this supercluster.
VertexStart | Retrieves or sets the initial vertex into remapped vertex array.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrtSplitMeshClusterData.PrtSplitMeshClusterData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData.PrtSplitMeshClusterData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtSplitMeshClusterData structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public PrtSplitMeshClusterData();
Managed C++ | public: PrtSplitMeshClusterData();
JScript .NET | public function PrtSplitMeshClusterData();


PrtSplitMeshClusterData.ClusterLength

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData.ClusterLength Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of clusters in this supercluster.

Definition

Visual Basic .NET | Public Property ClusterLength As Integer
C# | public int ClusterLength { get; set; }
Managed C++ public: __property int get_ClusterLength();
public: __property void set_ClusterLength(int);
JScript .NET public function get ClusterLength() : int
public function set ClusterLength(int);

Property Value

System.Int32 . Number of clusters in this supercluster.

This property is read/write.


PrtSplitMeshClusterData.ClusterStart

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData.ClusterStart Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the initial index into cluster array.

Definition

Visual Basic .NET | Public Property ClusterStart As Integer
C# | public int ClusterStart { get; set; }
Managed C++ public: __property int get_ClusterStart();
public: __property void set_ClusterStart(int);
JScript .NET public function get ClusterStart() : int
public function set ClusterStart(int);

Property Value

System.Int32 . Initial index into cluster array.

This property is read/write.


PrtSplitMeshClusterData.FaceLength

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData.FaceLength Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of faces in this supercluster.

Definition

Visual Basic .NET | Public Property FaceLength As Integer
C# | public int FaceLength { get; set; }
Managed C++ public: __property int get_FaceLength();
public: __property void set_FaceLength(int);
JScript .NET public function get FaceLength() : int
public function set FaceLength(int);

Property Value

System.Int32 . Number of faces in this supercluster.

This property is read/write.


PrtSplitMeshClusterData.FaceStart

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData.FaceStart Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the initial index into face array.

Definition

Visual Basic .NET | Public Property FaceStart As Integer
C# | public int FaceStart { get; set; }
Managed C++ public: __property int get_FaceStart();
public: __property void set_FaceStart(int);
JScript .NET public function get FaceStart() : int
public function set FaceStart(int);

Property Value

System.Int32 . Initial index into face array.

This property is read/write.


PrtSplitMeshClusterData.VertexLength

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData.VertexLength Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of vertices in this supercluster.

Definition

Visual Basic .NET | Public Property VertexLength As Integer
C# | public int VertexLength { get; set; }
Managed C++ public: __property int get_VertexLength();
public: __property void set_VertexLength(int);
JScript .NET public function get VertexLength() : int
public function set VertexLength(int);

Property Value

System.Int32 . Number of vertices in this supercluster.

This property is read/write.


PrtSplitMeshClusterData.VertexStart

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshClusterData.VertexStart Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the initial vertex into remapped vertex array.

Definition

Visual Basic .NET | Public Property VertexStart As Integer
C# | public int VertexStart { get; set; }
Managed C++ public: __property int get_VertexStart();
public: __property void set_VertexStart(int);
JScript .NET public function get VertexStart() : int
public function set VertexStart(int);

Property Value

System.Int32 . Initial vertex into remapped vertex array.

This property is read/write.


PrtSplitMeshVertexData

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshVertexData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains precomputed radiance transfer (PRT) split mesh vertex data.

Definition

Visual Basic .NET | Public Structure PrtSplitMeshVertexData
C# | public struct PrtSplitMeshVertexData
Managed C++ | public __value struct PrtSplitMeshVertexData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PrtSplitMeshVertexData | Initializes a new instance of the PrtSplitMeshVertexData structure.

Properties

Property | Description
SubCluster | Retrieves or sets the cluster index, relative to the supercluster.
VertexRemap | Retrieves or sets the vertex in the original mesh to which this split mesh vertex corresponds.
VertexStatus | Retrieves or sets the vertex status.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrtSplitMeshVertexData.PrtSplitMeshVertexData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshVertexData.PrtSplitMeshVertexData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PrtSplitMeshVertexData structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public PrtSplitMeshVertexData();
Managed C++ | public: PrtSplitMeshVertexData();
JScript .NET | public function PrtSplitMeshVertexData();


PrtSplitMeshVertexData.SubCluster

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshVertexData.SubCluster Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the cluster index, relative to the supercluster.

Definition

Visual Basic .NET | Public Property SubCluster As Integer
C# | public int SubCluster { get; set; }
Managed C++ public: __property int get_SubCluster();
public: __property void set_SubCluster(int);
JScript .NET public function get SubCluster() : int
public function set SubCluster(int);

Property Value

System.Int32 . Cluster index, relative to the supercluster.

This property is read/write.


PrtSplitMeshVertexData.VertexRemap

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshVertexData.VertexRemap Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex in the original mesh to which this split mesh vertex corresponds.

Definition

Visual Basic .NET | Public Property VertexRemap As Integer
C# | public int VertexRemap { get; set; }
Managed C++ public: __property int get_VertexRemap();
public: __property void set_VertexRemap(int);
JScript .NET public function get VertexRemap() : int
public function set VertexRemap(int);

Property Value

System.Int32 . Vertex in the original mesh to which this split mesh vertex corresponds.

This property is read/write.


PrtSplitMeshVertexData.VertexStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtSplitMeshVertexData.VertexStatus Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex status.

Definition

Visual Basic .NET | Public Property VertexStatus As Byte
C# | public byte VertexStatus { get; set; }
Managed C++ public: __property Byte get_VertexStatus();
public: __property void set_VertexStatus(Byte);
JScript .NET public function get VertexStatus() : byte
public function set VertexStatus(byte);

Property Value

System.Byte . Vertex status. A value of 1 if the vertex has valid data, 0 if it is "full".

This property is read/write.


RasterCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains information about raster drawing capabilities.

Definition

Visual Basic .NET | Public Structure RasterCaps
C# | public struct RasterCaps
Managed C++ | public __value struct RasterCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAnisotropy | Determines whether the device supports anisotropic filtering.
SupportsColorPerspective | Determines whether the device iterates color perspective correctly.
SupportsDepthBias | Determines whether the device supports legacy depth bias.
SupportsDither | Determines whether the device supports dithering to improve color resolution.
SupportsFogRange | Determines whether the device supports supports range-based fog.
SupportsFogTable | Determines whether the device supports using a fog table.
SupportsFogVertex | Determines whether the device supports vertex fog.
SupportsMipMapLevelOfDetailBias | Determines whether the device supports level of detail (LOD) bias adjustments.
SupportsMultisampleToggle | Determines whether the device supports toggling multisampling on and off between Device.BeginScene and Device.EndScene.
SupportsScissorTest | Determines whether the device supports scissor testing.
SupportsSlopeScaleDepthBias | Determines whether the device supports performing true slope scale-based depth bias.
SupportsWBuffer | Determines whether the device supports depth buffering using the w-buffer (w-buffering).
SupportsWFog | Determines whether the device supports w-based fog.
SupportsZBufferLessHsr | Determines whether a device can perform hidden-surface removal (HSR) without requiring the application to sort polygons and without requiring a depth buffer to be allocated.
SupportsZBufferTest | Determines whether the device can perform z-test operations.
SupportsZFog | Determines whether the device supports z-based fog.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RasterCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RasterCaps.SupportsAnisotropy

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsAnisotropy Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports anisotropic filtering.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAnisotropy As Boolean
C# | public bool SupportsAnisotropy { get; }
Managed C++ | public: __property bool get_SupportsAnisotropy();
JScript .NET | public function get SupportsAnisotropy() : boolean

Property Value

System.Boolean . Value that is true if the device supports anisotropic filtering, or false if it does not.

This property is read-only.


RasterCaps.SupportsColorPerspective

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsColorPerspective Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device iterates color perspective correctly.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsColorPerspective As Boolean
C# | public bool SupportsColorPerspective { get; }
Managed C++ | public: __property bool get_SupportsColorPerspective();
JScript .NET | public function get SupportsColorPerspective() : boolean

Property Value

System.Boolean . Value that is true if the device supports iterating color perspective correctly, or false if it does not.

This property is read-only.


RasterCaps.SupportsDepthBias

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsDepthBias Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports legacy depth bias.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDepthBias As Boolean
C# | public bool SupportsDepthBias { get; }
Managed C++ | public: __property bool get_SupportsDepthBias();
JScript .NET | public function get SupportsDepthBias() : boolean

Property Value

System.Boolean . Value that is true if the device supports legacy depth bias, or false if it does not.

This property is read-only.


RasterCaps.SupportsDither

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsDither Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports dithering to improve color resolution.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDither As Boolean
C# | public bool SupportsDither { get; }
Managed C++ | public: __property bool get_SupportsDither();
JScript .NET | public function get SupportsDither() : boolean

Property Value

System.Boolean . Value that is true if the device supports dithering, or false if it does not.

This property is read-only.


RasterCaps.SupportsFogRange

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsFogRange Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports supports range-based fog.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFogRange As Boolean
C# | public bool SupportsFogRange { get; }
Managed C++ | public: __property bool get_SupportsFogRange();
JScript .NET | public function get SupportsFogRange() : boolean

Property Value

System.Boolean . Value that is true if the device supports range-based fog, or false if it does not.

This property is read-only.

Remarks

In range-based fog, the distance of an object from the viewer, not the depth of the object (that is, the z-coordinate) is used to compute fog effects in the scene.


RasterCaps.SupportsFogTable

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsFogTable Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports using a fog table.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFogTable As Boolean
C# | public bool SupportsFogTable { get; }
Managed C++ | public: __property bool get_SupportsFogTable();
JScript .NET | public function get SupportsFogTable() : boolean

Property Value

System.Boolean . Value that is true if the device supports using a fog table, or false if it does not.

This property is read-only.

Remarks

The device calculates the fog value by referring to a lookup table containing fog values that are indexed to the depth of a given pixel.


RasterCaps.SupportsFogVertex

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsFogVertex Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports vertex fog.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFogVertex As Boolean
C# | public bool SupportsFogVertex { get; }
Managed C++ | public: __property bool get_SupportsFogVertex();
JScript .NET | public function get SupportsFogVertex() : boolean

Property Value

System.Boolean . Value that is true if the device supports vertex fog, or false if it does not.

This property is read-only.

Remarks

The device calculates the fog value during the lighting operation and interpolates it during rasterization.


RasterCaps.SupportsMipMapLevelOfDetailBias

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsMipMapLevelOfDetailBias Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports level of detail (LOD) bias adjustments.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMipMapLevelOfDetailBias As Boolean
C# | public bool SupportsMipMapLevelOfDetailBias { get; }
Managed C++ | public: __property bool get_SupportsMipMapLevelOfDetailBias();
JScript .NET | public function get SupportsMipMapLevelOfDetailBias() : boolean

Property Value

System.Boolean . Value that is true if the device supports LOD bias adjustments, or false if it does not.

This property is read-only.

Remarks

LOD bias adjustments enable an application to make a mipmap appear crisper or less sharp than it normally would.

See Also

  • SamplerStateManager.MipMapLevelOfDetailBias


RasterCaps.SupportsMultisampleToggle

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsMultisampleToggle Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports toggling multisampling on and off between Device.BeginScene and Device.EndScene.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMultisampleToggle As Boolean
C# | public bool SupportsMultisampleToggle { get; }
Managed C++ | public: __property bool get_SupportsMultisampleToggle();
JScript .NET | public function get SupportsMultisampleToggle() : boolean

Property Value

System.Boolean . Value that is true if the device supports toggling multisampling on and off, or false if it does not.

This property is read-only.


RasterCaps.SupportsScissorTest

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsScissorTest Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports scissor testing.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsScissorTest As Boolean
C# | public bool SupportsScissorTest { get; }
Managed C++ | public: __property bool get_SupportsScissorTest();
JScript .NET | public function get SupportsScissorTest() : boolean

Property Value

System.Boolean . Value that is true if the device supports scissor testing, or false if it does not.

This property is read-only.


RasterCaps.SupportsSlopeScaleDepthBias

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsSlopeScaleDepthBias Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports performing true slope scale-based depth bias.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSlopeScaleDepthBias As Boolean
C# | public bool SupportsSlopeScaleDepthBias { get; }
Managed C++ | public: __property bool get_SupportsSlopeScaleDepthBias();
JScript .NET | public function get SupportsSlopeScaleDepthBias() : boolean

Property Value

System.Boolean . Value that is true if the device supports true slope scale-based depth bias, or false if it does not.

This property is read-only.


RasterCaps.SupportsWBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsWBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports depth buffering using the w-buffer (w-buffering).

Definition

Visual Basic .NET | Public ReadOnly Property SupportsWBuffer As Boolean
C# | public bool SupportsWBuffer { get; }
Managed C++ | public: __property bool get_SupportsWBuffer();
JScript .NET | public function get SupportsWBuffer() : boolean

Property Value

System.Boolean . Value that is true if the device supports depth buffering using the w-buffer, or false if it does not.

This property is read-only.

See Also

  • Depth Buffers


RasterCaps.SupportsWFog

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsWFog Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports w-based fog.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsWFog As Boolean
C# | public bool SupportsWFog { get; }
Managed C++ | public: __property bool get_SupportsWFog();
JScript .NET | public function get SupportsWFog() : boolean

Property Value

System.Boolean . Value that is true if the device supports w-based fog, or false if it does not.

This property is read-only.

Remarks

W-based fog is used when a perspective projection matrix is specified, but affine projections still use z-based fog. The system considers a projection matrix that contains a nonzero value in the [3][4] element to be a perspective projection matrix.


RasterCaps.SupportsZBufferLessHsr

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsZBufferLessHsr Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether a device can perform hidden-surface removal (HSR) without requiring the application to sort polygons and without requiring a depth buffer to be allocated.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsZBufferLessHsr As Boolean
C# | public bool SupportsZBufferLessHsr { get; }
Managed C++ | public: __property bool get_SupportsZBufferLessHsr();
JScript .NET | public function get SupportsZBufferLessHsr() : boolean

Property Value

System.Boolean . Value that is true if the device supports bufferless HSR, or false if it does not.

This property is read-only.

Remarks

Z-bufferless HSR leaves more video memory for textures. The method used to perform HSR is hardware-dependent and transparent to the application.

Z-bufferless HSR is performed if no depth-buffer surface is associated with the render target surface and the depth-buffer comparison test is enabled (that is, when the state value associated with RenderStateManager.ZBufferEnable is set to true).


RasterCaps.SupportsZBufferTest

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsZBufferTest Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device can perform z-test operations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsZBufferTest As Boolean
C# | public bool SupportsZBufferTest { get; }
Managed C++ | public: __property bool get_SupportsZBufferTest();
JScript .NET | public function get SupportsZBufferTest() : boolean

Property Value

System.Boolean . Value that is true if the device can perform z-test operations, or false if it cannot.

This property is read-only.

Remarks

This property effectively renders a primitive and indicates whether any z pixels have been rendered.


RasterCaps.SupportsZFog

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterCaps.SupportsZFog Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the device supports z-based fog.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsZFog As Boolean
C# | public bool SupportsZFog { get; }
Managed C++ | public: __property bool get_SupportsZFog();
JScript .NET | public function get SupportsZFog() : boolean

Property Value

System.Boolean . Value that is true if the device supports z-based fog, or false if it does not.

This property is read-only.


RasterStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterStatus Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the raster status.

Definition

Visual Basic .NET | Public Structure RasterStatus
C# | public struct RasterStatus
Managed C++ | public __value struct RasterStatus
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RasterStatus | Initializes a new instance of the RasterStatus class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
InVBlank | Retrieves or sets the status of the vertical blank period.
ScanLine | Retrieves or sets a value that roughly corresponds to the current scan line painted by the raster.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RasterStatus.RasterStatus()

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterStatus.RasterStatus Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RasterStatus class.

Definition

Visual Basic .NET | Public Sub New()
C# | public RasterStatus();
Managed C++ | public: RasterStatus();
JScript .NET | public function RasterStatus();


RasterStatus.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterStatus.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RasterStatus.InVBlank

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterStatus.InVBlank Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the status of the vertical blank period.

Definition

Visual Basic .NET | Public Property InVBlank As Boolean
C# | public bool InVBlank { get; set; }
Managed C++ public: __property bool get_InVBlank();
public: __property void set_InVBlank(bool);
JScript .NET public function get InVBlank() : boolean
public function set InVBlank(boolean);

Property Value

System.Boolean . Value that is true if the raster is in the vertical blank period, or false if it is not.

This property is read/write.


RasterStatus.ScanLine

Microsoft DirectX 9.0 SDK Update (October 2004)

RasterStatus.ScanLine Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that roughly corresponds to the current scan line painted by the raster.

Definition

Visual Basic .NET | Public Property ScanLine As Integer
C# | public int ScanLine { get; set; }
Managed C++ public: __property int get_ScanLine();
public: __property void set_ScanLine(int);
JScript .NET public function get ScanLine() : int
public function set ScanLine(int);

Property Value

System.Int32 . Integer that roughly corresponds to the current scan line to set or retrieve.

This property is read/write.

Remarks

If InVBlank is false, this property's value is an integer that roughly corresponds to the current scan line painted by the raster. Scan lines are numbered in the same way as Microsoft® Direct3D® surface coordinates: 0 is the top of the primary surface, extending to the value (height of the surface - 1) at the bottom of the display.

If InVBlank is true, this value is set to 0 and can be ignored.


RectanglePatchInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a rectangular high-order patch.

Definition

Visual Basic .NET | Public Structure RectanglePatchInformation
C# | public struct RectanglePatchInformation
Managed C++ | public __value struct RectanglePatchInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RectanglePatchInformation | Initializes a new instance of the RectanglePatchInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BasisType | Retrieves or sets a value of the BasisType enumeration that defines the basis type for the rectangular high-order patch.
Degree | Retrieves or sets a value of the DegreeType enumeration that defines the degree for the rectangular patch.
Height | Retrieves or sets the height of each vertex, in number of vertices.
StartVertexOffsetHeight | Retrieves or sets the starting vertex offset height, in number of vertices.
StartVertexOffsetWidth | Retrieves or sets the starting vertex offset width, in number of vertices.
Stride | Retrieves or sets the width of the imaginary two-dimensional vertex array, which occupies the same space as the vertex buffer.
Width | Retrieves or sets the width of each vertex, in number of vertices.

Remarks

The following diagram identifies the parameters that specify a rectangle patch.

Rectangle Patch Info

Each of the vertices in the vertex buffer is shown as a black dot. In this case, the vertex buffer has 20 vertices in it, 16 of which are in the rectangle patch. The stride (also called the pitch) is the number of vertices in the width of the vertex buffer (five in this case). The x offset to the first vertex is called the StartIndexVertexWidth and has a value of 1; the y offset is called the StartIndexVertexHeight and has a value of 0.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RectanglePatchInformation.RectanglePatchInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.RectanglePatchInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RectanglePatchInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public RectanglePatchInformation();
Managed C++ | public: RectanglePatchInformation();
JScript .NET | public function RectanglePatchInformation();


RectanglePatchInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RectanglePatchInformation.BasisType

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.BasisType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value of the BasisType enumeration that defines the basis type for the rectangular high-order patch.

Definition

Visual Basic .NET | Public Property BasisType As BasisType
C# | public BasisType BasisType { get; set; }
Managed C++ public: __property BasisType get_BasisType();
public: __property void set_BasisType(BasisType);
JScript .NET public function get BasisType() : BasisType
public function set BasisType(BasisType);

Property Value

Microsoft.DirectX.Direct3D.BasisType . Value of the BasisType enumeration to set or retrieve.

This property is read/write.

Remarks

Value | Order supported | Width and height
Bezier | Linear, cubic, and quintic | Width = height = order + 1
BSpline | Linear, cubic, and quintic | Width = height > order
CatMullRom | Cubic | Width = height > order


RectanglePatchInformation.Degree

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.Degree Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value of the DegreeType enumeration that defines the degree for the rectangular patch.

Definition

Visual Basic .NET | Public Property Degree As DegreeType
C# | public DegreeType Degree { get; set; }
Managed C++ public: __property DegreeType get_Degree();
public: __property void set_Degree(DegreeType);
JScript .NET public function get Degree() : DegreeType
public function set Degree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType . Value of the DegreeType enumeration to set or retrieve.

This property is read/write.


RectanglePatchInformation.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height of each vertex, in number of vertices.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height, in number of vertices, of each vertex to set or retrieve.

This property is read/write.


RectanglePatchInformation.StartVertexOffsetHeight

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.StartVertexOffsetHeight Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the starting vertex offset height, in number of vertices.

Definition

Visual Basic .NET | Public Property StartVertexOffsetHeight As Integer
C# | public int StartVertexOffsetHeight { get; set; }
Managed C++ public: __property int get_StartVertexOffsetHeight();
public: __property void set_StartVertexOffsetHeight(int);
JScript .NET public function get StartVertexOffsetHeight() : int
public function set StartVertexOffsetHeight(int);

Property Value

System.Int32 . Integer that represents the starting vertex offset height, in number of vertices, to set or retrieve.

This property is read/write.


RectanglePatchInformation.StartVertexOffsetWidth

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.StartVertexOffsetWidth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the starting vertex offset width, in number of vertices.

Definition

Visual Basic .NET | Public Property StartVertexOffsetWidth As Integer
C# | public int StartVertexOffsetWidth { get; set; }
Managed C++ public: __property int get_StartVertexOffsetWidth();
public: __property void set_StartVertexOffsetWidth(int);
JScript .NET public function get StartVertexOffsetWidth() : int
public function set StartVertexOffsetWidth(int);

Property Value

System.Int32 . Integer that represents the starting vertex offset width, in number of vertices, to set or retrieve.

This property is read/write.


RectanglePatchInformation.Stride

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.Stride Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of the imaginary two-dimensional vertex array, which occupies the same space as the vertex buffer.

Definition

Visual Basic .NET | Public Property Stride As Integer
C# | public int Stride { get; set; }
Managed C++ public: __property int get_Stride();
public: __property void set_Stride(int);
JScript .NET public function get Stride() : int
public function set Stride(int);

Property Value

System.Int32 . Integer that represents the width of the imaginary two-dimensional vertex array to set or retrieve.

This property is read/write.


RectanglePatchInformation.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

RectanglePatchInformation.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of each vertex, in number of vertices.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width, in number of vertices, of each vertex to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes an off-screen render target.

Definition

Visual Basic .NET | Public Structure RenderToEnvironmentDescription
C# | public struct RenderToEnvironmentDescription
Managed C++ | public __value struct RenderToEnvironmentDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RenderToEnvironmentDescription | Initializes a new instance of the RenderToEnvironmentDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DepthStencil | Retrieves or sets a value that indicates whether the z-buffer is needed.
DepthStencilFormat | Retrieves or sets the depth stencil format.
Format | Retrieves or sets the color buffer format.
MipLevels | Retrieves or sets the maximum level of detail (LOD) number.
Size | Retrieves or sets the size of the render target.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RenderToEnvironmentDescription.RenderToEnvironmentDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription.RenderToEnvironmentDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToEnvironmentDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public RenderToEnvironmentDescription();
Managed C++ | public: RenderToEnvironmentDescription();
JScript .NET | public function RenderToEnvironmentDescription();


RenderToEnvironmentDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RenderToEnvironmentDescription.DepthStencil

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription.DepthStencil Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that indicates whether the z-buffer is needed.

Definition

Visual Basic .NET | Public Property DepthStencil As Boolean
C# | public bool DepthStencil { get; set; }
Managed C++ public: __property bool get_DepthStencil();
public: __property void set_DepthStencil(bool);
JScript .NET public function get DepthStencil() : boolean
public function set DepthStencil(boolean);

Property Value

System.Boolean . Value that is true if the z-buffer is needed, or false if it is not.

This property is read/write.


RenderToEnvironmentDescription.DepthStencilFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription.DepthStencilFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the depth stencil format.

Definition

Visual Basic .NET | Public Property DepthStencilFormat As DepthFormat
C# | public DepthFormat DepthStencilFormat { get; set; }
Managed C++ public: __property DepthFormat get_DepthStencilFormat();
public: __property void set_DepthStencilFormat(DepthFormat);
JScript .NET public function get DepthStencilFormat() : DepthFormat
public function set DepthStencilFormat(DepthFormat);

Property Value

Microsoft.DirectX.Direct3D.DepthFormat . Value of the DepthFormat enumeration that describes the depth stencil format to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the color buffer format.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . Value of the Format enumeration that describes the format of the color buffer to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription.MipLevels

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription.MipLevels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the maximum level of detail (LOD) number.

Definition

Visual Basic .NET | Public Property MipLevels As Integer
C# | public int MipLevels { get; set; }
Managed C++ public: __property int get_MipLevels();
public: __property void set_MipLevels(int);
JScript .NET public function get MipLevels() : int
public function set MipLevels(int);

Property Value

System.Int32 . Integer that represents the maximum mipmap level to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription.Size

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToEnvironmentDescription.Size Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the size of the render target.

Definition

Visual Basic .NET | Public Property Size As Integer
C# | public int Size { get; set; }
Managed C++ public: __property int get_Size();
public: __property void set_Size(int);
JScript .NET public function get Size() : int
public function set Size(int);

Property Value

System.Int32 . Integer that represents the width and height, in pixels, of the render target to set or retrieve.

This property is read/write.


RenderToSurfaceDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a render surface.

Definition

Visual Basic .NET | Public Structure RenderToSurfaceDescription
C# | public struct RenderToSurfaceDescription
Managed C++ | public __value struct RenderToSurfaceDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RenderToSurfaceDescription | Initializes a new instance of the RenderToSurfaceDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DepthStencil | Retrieves or sets a value that specifies whether the render surface supports a depth stencil surface.
DepthStencilFormat | Retrieves or sets the depth stencil format of the render surface.
Format | Retrieves or sets the format of the render surface.
Height | Retrieves or sets the height of the render surface.
Width | Retrieves or sets the width of the render surface.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RenderToSurfaceDescription.RenderToSurfaceDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription.RenderToSurfaceDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the RenderToSurfaceDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public RenderToSurfaceDescription();
Managed C++ | public: RenderToSurfaceDescription();
JScript .NET | public function RenderToSurfaceDescription();


RenderToSurfaceDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RenderToSurfaceDescription.DepthStencil

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription.DepthStencil Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies whether the render surface supports a depth stencil surface.

Definition

Visual Basic .NET | Public Property DepthStencil As Boolean
C# | public bool DepthStencil { get; set; }
Managed C++ public: __property bool get_DepthStencil();
public: __property void set_DepthStencil(bool);
JScript .NET public function get DepthStencil() : boolean
public function set DepthStencil(boolean);

Property Value

System.Boolean . Value that is true if the render surface supports a depth stencil surface, or false if it does not.

This property is read/write.


RenderToSurfaceDescription.DepthStencilFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription.DepthStencilFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the depth stencil format of the render surface.

Definition

Visual Basic .NET | Public Property DepthStencilFormat As DepthFormat
C# | public DepthFormat DepthStencilFormat { get; set; }
Managed C++ public: __property DepthFormat get_DepthStencilFormat();
public: __property void set_DepthStencilFormat(DepthFormat);
JScript .NET public function get DepthStencilFormat() : DepthFormat
public function set DepthStencilFormat(DepthFormat);

Property Value

Microsoft.DirectX.Direct3D.DepthFormat . Value of the DepthFormat enumeration that describes the depth stencil format of the render surface to set or retrieve.

This property is read/write.


RenderToSurfaceDescription.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the format of the render surface.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . Value of the Format enumeration that describes the format of the render surface to set or retrieve.

This property is read/write.


RenderToSurfaceDescription.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height of the render surface.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height of the render surface in pixels.

This property is read/write.


RenderToSurfaceDescription.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

RenderToSurfaceDescription.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of the render surface.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width of the render surface in pixels.

This property is read/write.


ResourceManager

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceManager Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains resource manager usage statistics.

Definition

Visual Basic .NET | Public Structure ResourceManager
C# | public struct ResourceManager
Managed C++ | public __value struct ResourceManager
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetStatistics | Retrieves an array of resource usage statistics.
ResourceManager | Initializes a new instance of the ResourceManager class.
ToString | Obtains a string representation of the current instance.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ResourceManager.GetStatistics()

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceManager.GetStatistics Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an array of resource usage statistics.

Definition

Visual Basic .NET | Public Function GetStatistics() As ResourceStats()
C# | public ResourceStats[] GetStatistics();
Managed C++ | public: ResourceStats GetStatistics() __gc[];
JScript .NET | public function GetStatistics() : ResourceStats[];

Return Value

Microsoft.DirectX.Direct3D.ResourceStats[]. Array of ResourceStats structures that contain the usage statistics of the resource manager.


ResourceManager.ResourceManager()

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceManager.ResourceManager Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ResourceManager class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ResourceManager();
Managed C++ | public: ResourceManager();
JScript .NET | public function ResourceManager();


ResourceManager.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceManager.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ResourceStats

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains information about the resource manager.

Definition

Visual Basic .NET | Public Structure ResourceStats
C# | public struct ResourceStats
Managed C++ | public __value struct ResourceStats
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ResourceStats | Initializes a new instance of the ResourceStats class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ApproximateBytesDownloaded | Retrieves the approximate number of bytes downloaded by the resource manager.
LastObjectPriority | Retrieves the priority value of the last object evicted.
NumberEvicts | Retrieves the number of objects evicted.
NumberObjectsCreatedInVideoMemory | Retrieves the number of objects created in video memory.
NumberObjectsUsed | Retrieves the number of objects set to the device.
NumberObjectsUsedInVideoMemory | Retrieves the number of objects set to the device that are already in video memory.
Thrashing | Retrieves a value that indicates whether thrashing is occurring.
TotalManaged | Retrieves the total number of managed objects.
TotalManagedBytes | Retrieves the total number of bytes used by the managed objects.
WorkingSet | Retrieves the number of objects in video memory.
WorkingSetBytes | Retrieves the number of bytes in video memory.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ResourceStats.ResourceStats()

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.ResourceStats Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ResourceStats class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ResourceStats();
Managed C++ | public: ResourceStats();
JScript .NET | public function ResourceStats();


ResourceStats.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ResourceStats.ApproximateBytesDownloaded

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.ApproximateBytesDownloaded Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the approximate number of bytes downloaded by the resource manager.

Definition

Visual Basic .NET | Public ReadOnly Property ApproximateBytesDownloaded As Integer
C# | public int ApproximateBytesDownloaded { get; }
Managed C++ | public: __property int get_ApproximateBytesDownloaded();
JScript .NET | public function get ApproximateBytesDownloaded() : int

Property Value

System.Int32 . Integer that represents the approximate number of bytes downloaded.

This property is read-only.


ResourceStats.LastObjectPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.LastObjectPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the priority value of the last object evicted.

Definition

Visual Basic .NET | Public ReadOnly Property LastObjectPriority As Integer
C# | public int LastObjectPriority { get; }
Managed C++ | public: __property int get_LastObjectPriority();
JScript .NET | public function get LastObjectPriority() : int

Property Value

System.Int32 . Integer that represents the priority of the last object.

This property is read-only.


ResourceStats.NumberEvicts

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.NumberEvicts Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of objects evicted.

Definition

Visual Basic .NET | Public ReadOnly Property NumberEvicts As Integer
C# | public int NumberEvicts { get; }
Managed C++ | public: __property int get_NumberEvicts();
JScript .NET | public function get NumberEvicts() : int

Property Value

System.Int32 . Integer that represents the number of evicted objects.

This property is read-only.


ResourceStats.NumberObjectsCreatedInVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.NumberObjectsCreatedInVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of objects created in video memory.

Definition

Visual Basic .NET | Public ReadOnly Property NumberObjectsCreatedInVideoMemory As Integer
C# | public int NumberObjectsCreatedInVideoMemory { get; }
Managed C++ | public: __property int get_NumberObjectsCreatedInVideoMemory();
JScript .NET | public function get NumberObjectsCreatedInVideoMemory() : int

Property Value

System.Int32 . Integer that represents the number of objects created in video memory.

This property is read-only.


ResourceStats.NumberObjectsUsed

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.NumberObjectsUsed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of objects set to the device.

Definition

Visual Basic .NET | Public ReadOnly Property NumberObjectsUsed As Integer
C# | public int NumberObjectsUsed { get; }
Managed C++ | public: __property int get_NumberObjectsUsed();
JScript .NET | public function get NumberObjectsUsed() : int

Property Value

System.Int32 . Integer that represents the number of objects set to the device.

This property is read-only.


ResourceStats.NumberObjectsUsedInVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.NumberObjectsUsedInVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of objects set to the device that are already in video memory.

Definition

Visual Basic .NET | Public ReadOnly Property NumberObjectsUsedInVideoMemory As Integer
C# | public int NumberObjectsUsedInVideoMemory { get; }
Managed C++ | public: __property int get_NumberObjectsUsedInVideoMemory();
JScript .NET | public function get NumberObjectsUsedInVideoMemory() : int

Property Value

System.Int32 . Integer that represents the number of objects already in video memory.

This property is read-only.


ResourceStats.Thrashing

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.Thrashing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether thrashing is occurring.

Definition

Visual Basic .NET | Public ReadOnly Property Thrashing As Boolean
C# | public bool Thrashing { get; }
Managed C++ | public: __property bool get_Thrashing();
JScript .NET | public function get Thrashing() : boolean

Property Value

System.Boolean . Value that is true if thrashing is occurring, or false if it is not.

This property is read-only.


ResourceStats.TotalManaged

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.TotalManaged Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the total number of managed objects.

Definition

Visual Basic .NET | Public ReadOnly Property TotalManaged As Integer
C# | public int TotalManaged { get; }
Managed C++ | public: __property int get_TotalManaged();
JScript .NET | public function get TotalManaged() : int

Property Value

System.Int32 . Integer that represents the total number of managed objects.

This property is read-only.


ResourceStats.TotalManagedBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.TotalManagedBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the total number of bytes used by the managed objects.

Definition

Visual Basic .NET | Public ReadOnly Property TotalManagedBytes As Integer
C# | public int TotalManagedBytes { get; }
Managed C++ | public: __property int get_TotalManagedBytes();
JScript .NET | public function get TotalManagedBytes() : int

Property Value

System.Int32 . Integer that represents the total number of bytes of managed objects.

This property is read-only.


ResourceStats.WorkingSet

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.WorkingSet Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of objects in video memory.

Definition

Visual Basic .NET | Public ReadOnly Property WorkingSet As Integer
C# | public int WorkingSet { get; }
Managed C++ | public: __property int get_WorkingSet();
JScript .NET | public function get WorkingSet() : int

Property Value

System.Int32 . Integer that represents the number of objects in video memory.

This property is read-only.


ResourceStats.WorkingSetBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

ResourceStats.WorkingSetBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of bytes in video memory.

Definition

Visual Basic .NET | Public ReadOnly Property WorkingSetBytes As Integer
C# | public int WorkingSetBytes { get; }
Managed C++ | public: __property int get_WorkingSetBytes();
JScript .NET | public function get WorkingSetBytes() : int

Property Value

System.Int32 . Integer that represents the number of bytes in video memory.

This property is read-only.


ScaleRotateTranslate

Microsoft DirectX 9.0 SDK Update (October 2004)

ScaleRotateTranslate Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Encapsulates scale, rotate and translate structures.

Definition

Visual Basic .NET | Public Structure ScaleRotateTranslate
C# | public struct ScaleRotateTranslate
Managed C++ | public __value struct ScaleRotateTranslate
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ScaleRotateTranslate | Initializes a new instance of the ScaleRotateTranslate class.

Properties

Property | Description
Rotation | Retrieves or sets a Quaternion structure.
Scaling | Retrieves or sets a Vector3 structure.
Translation | Retrieves or sets a Vector3 structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ScaleRotateTranslate.ScaleRotateTranslate()

Microsoft DirectX 9.0 SDK Update (October 2004)

ScaleRotateTranslate.ScaleRotateTranslate Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ScaleRotateTranslate class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ScaleRotateTranslate();
Managed C++ | public: ScaleRotateTranslate();
JScript .NET | public function ScaleRotateTranslate();


ScaleRotateTranslate.Rotation

ScaleRotateTranslate.Rotation Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Quaternion structure.

Definition

Visual Basic .NET | Public Property Rotation As Quaternion
C# | public Quaternion Rotation { get; set; }
Managed C++ public: __property Quaternion get_Rotation();
public: __property void set_Rotation(Quaternion);
JScript .NET public function get Rotation() : Quaternion
public function set Rotation(Quaternion);

Property Value

Microsoft.DirectX.Quaternion . A Quaternion structure that contains values used for rotation operations.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


ScaleRotateTranslate.Scaling

Microsoft DirectX 9.0 SDK Update (October 2004)

ScaleRotateTranslate.Scaling Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Vector3 structure.

Definition

Visual Basic .NET | Public Property Scaling As Vector3
C# | public Vector3 Scaling { get; set; }
Managed C++ public: __property Vector3 get_Scaling();
public: __property void set_Scaling(Vector3);
JScript .NET public function get Scaling() : Vector3
public function set Scaling(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 structure that contains values used for scaling operations.

This property is read/write.


ScaleRotateTranslate.Translation

ScaleRotateTranslate.Translation Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Vector3 structure.

Definition

Visual Basic .NET | Public Property Translation As Vector3
C# | public Vector3 Translation { get; set; }
Managed C++ public: __property Vector3 get_Translation();
public: __property void set_Translation(Vector3);
JScript .NET public function get Translation() : Vector3
public function set Translation(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 structure that contains values used for translation operations.

This property is read/write.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Semantic

Microsoft DirectX 9.0 SDK Update (October 2004)

Semantic Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Maps a parameter to vertex or pixel shader registers.

Definition

Visual Basic .NET | Public Structure Semantic
C# | public struct Semantic
Managed C++ | public __value struct Semantic
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Semantic | Initializes a new instance of the Semantic class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Usage | Retrieves or sets options that identify how resources are used.
UsageIndex | Retrieves or sets options that modify how usage is interpreted.

Remarks

Semantics also can be used as optional descriptive strings attached to non-register parameters.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Semantic.Semantic()

Microsoft DirectX 9.0 SDK Update (October 2004)

Semantic.Semantic Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Semantic class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Semantic();
Managed C++ | public: Semantic();
JScript .NET | public function Semantic();


Semantic.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Semantic.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Semantic.Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

Semantic.Usage Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets options that identify how resources are used.

Definition

Visual Basic .NET | Public Property Usage As Integer
C# | public int Usage { get; set; }
Managed C++ public: __property int get_Usage();
public: __property void set_Usage(int);
JScript .NET public function get Usage() : int
public function set Usage(int);

Property Value

System.Int32 . Integer that represents a value from the Usage enumeration that specifies how resources are used.

This property is read/write.


Semantic.UsageIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

Semantic.UsageIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets options that modify how usage is interpreted.

Definition

Visual Basic .NET | Public Property UsageIndex As Integer
C# | public int UsageIndex { get; set; }
Managed C++ public: __property int get_UsageIndex();
public: __property void set_UsageIndex(int);
JScript .NET public function get UsageIndex() : int
public function set UsageIndex(int);

Property Value

System.Int32 . Integer that represents the usage index value to set or retrieve.

This property is read/write.


ShadeCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

ShadeCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Defines shading operation capabilities.

Definition

Visual Basic .NET | Public Structure ShadeCaps
C# | public struct ShadeCaps
Managed C++ | public __value struct ShadeCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlphaGouraudBlend | Specifies whether the device supports an alpha component for Gouraud-blended transparency.
SupportsColorGouraudRgb | Specifies whether the device supports colored Gouraud shading in the RGB color model.
SupportsFogGouraud | Specifies whether the device supports fog in the Gouraud shading mode.
SupportsSpecularGouraudRgb | Specifies whether the device supports Gouraud shading of specular highlights.

Remarks

It is generally assumed that if a device supports a shading operation at all, it at least supports flat shading.

When alpha components are not supported, the alpha value of generated colors is implicitly 255. This is the maximum possible alpha (that is, the alpha component is at full intensity).

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShadeCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShadeCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShadeCaps.SupportsAlphaGouraudBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

ShadeCaps.SupportsAlphaGouraudBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports an alpha component for Gouraud-blended transparency.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAlphaGouraudBlend As Boolean
C# | public bool SupportsAlphaGouraudBlend { get; }
Managed C++ | public: __property bool get_SupportsAlphaGouraudBlend();
JScript .NET | public function get SupportsAlphaGouraudBlend() : boolean

Property Value

System.Boolean . Value that is true if the device supports an alpha component for Gouraud-blended transparency, or false if it does not.

This property is read-only.

Remarks

In this mode, the alpha color component of a primitive is provided at vertices and interpolated across a face along with the other color components.


ShadeCaps.SupportsColorGouraudRgb

Microsoft DirectX 9.0 SDK Update (October 2004)

ShadeCaps.SupportsColorGouraudRgb Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports colored Gouraud shading in the RGB color model.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsColorGouraudRgb As Boolean
C# | public bool SupportsColorGouraudRgb { get; }
Managed C++ | public: __property bool get_SupportsColorGouraudRgb();
JScript .NET | public function get SupportsColorGouraudRgb() : boolean

Property Value

System.Boolean . Value that is true if the device supports colored Gouraud shading in the RGB color model, or false if it does not.

This property is read-only.

Remarks

In this mode, the color component for a primitive is provided at vertices and interpolated across a face along with the other color components. In the RGB lighting model, the red, green, and blue components are interpolated.


ShadeCaps.SupportsFogGouraud

Microsoft DirectX 9.0 SDK Update (October 2004)

ShadeCaps.SupportsFogGouraud Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports fog in the Gouraud shading mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsFogGouraud As Boolean
C# | public bool SupportsFogGouraud { get; }
Managed C++ | public: __property bool get_SupportsFogGouraud();
JScript .NET | public function get SupportsFogGouraud() : boolean

Property Value

System.Boolean . Value that is true if the device supports fog in the Gouraud shading mode, or false if it does not.

This property is read-only.


ShadeCaps.SupportsSpecularGouraudRgb

Microsoft DirectX 9.0 SDK Update (October 2004)

ShadeCaps.SupportsSpecularGouraudRgb Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports Gouraud shading of specular highlights.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSpecularGouraudRgb As Boolean
C# | public bool SupportsSpecularGouraudRgb { get; }
Managed C++ | public: __property bool get_SupportsSpecularGouraudRgb();
JScript .NET | public function get SupportsSpecularGouraudRgb() : boolean

Property Value

System.Boolean . Value that is true if the device supports Gouraud shading of specular highlights, or false if it does not.

This property is read-only.


ShaderConstantInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains shader constant information.

Definition

Visual Basic .NET | Public Structure ShaderConstantInformation
C# | public struct ShaderConstantInformation
Managed C++ | public __value struct ShaderConstantInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderConstantInformation | Initializes a new instance of the ShaderConstantInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DefaultValue | Retrieves or sets the offset, in bytes, to the string that contains the default value of the shader constant.
Name | Retrieves or sets the offset, in bytes, to the name of the shader constant.
RegisterCount | Retrieves or sets the number of registers.
RegisterIndex | Retrieves or sets the register index.
RegisterSet | Retrieves or sets a value from the RegisterSet enumeration that specifies the shader register data type.
TypeInformation | Retrieves or sets the offset, in bytes, to the type information of a shader constant.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderConstantInformation.ShaderConstantInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.ShaderConstantInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderConstantInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderConstantInformation();
Managed C++ | public: ShaderConstantInformation();
JScript .NET | public function ShaderConstantInformation();


ShaderConstantInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderConstantInformation.DefaultValue

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.DefaultValue Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, to the string that contains the default value of the shader constant.

Definition

Visual Basic .NET | Public Property DefaultValue As Integer
C# | public int DefaultValue { get; set; }
Managed C++ public: __property int get_DefaultValue();
public: __property void set_DefaultValue(int);
JScript .NET public function get DefaultValue() : int
public function set DefaultValue(int);

Property Value

System.Int32 . Integer that represents the string offset of the shader constant default value.

This property is read/write.


ShaderConstantInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, to the name of the shader constant.

Definition

Visual Basic .NET | Public Property Name As Integer
C# | public int Name { get; set; }
Managed C++ public: __property int get_Name();
public: __property void set_Name(int);
JScript .NET public function get Name() : int
public function set Name(int);

Property Value

System.Int32 . Integer that represents the shader constant name offset.

This property is read/write.


ShaderConstantInformation.RegisterCount

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.RegisterCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of registers.

Definition

Visual Basic .NET | Public Property RegisterCount As Short
C# | public short RegisterCount { get; set; }
Managed C++ public: __property short get_RegisterCount();
public: __property void set_RegisterCount(short);
JScript .NET public function get RegisterCount() : short
public function set RegisterCount(short);

Property Value

System.Int16 . Integer that represents the number of registers to set or retrieve.

This property is read/write.


ShaderConstantInformation.RegisterIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.RegisterIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the register index.

Definition

Visual Basic .NET | Public Property RegisterIndex As Short
C# | public short RegisterIndex { get; set; }
Managed C++ public: __property short get_RegisterIndex();
public: __property void set_RegisterIndex(short);
JScript .NET public function get RegisterIndex() : short
public function set RegisterIndex(short);

Property Value

System.Int16 . Integer that represents the register index to set or retrieve.

This property is read/write.


ShaderConstantInformation.RegisterSet

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.RegisterSet Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value from the RegisterSet enumeration that specifies the shader register data type.

Definition

Visual Basic .NET | Public Property RegisterSet As Short
C# | public short RegisterSet { get; set; }
Managed C++ public: __property short get_RegisterSet();
public: __property void set_RegisterSet(short);
JScript .NET public function get RegisterSet() : short
public function set RegisterSet(short);

Property Value

System.Int16 . Value from the RegisterSet enumeration to set or retrieve.

This property is read/write.


ShaderConstantInformation.TypeInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantInformation.TypeInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, to the type information of a shader constant.

Definition

Visual Basic .NET | Public Property TypeInformation As Integer
C# | public int TypeInformation { get; set; }
Managed C++ public: __property int get_TypeInformation();
public: __property void set_TypeInformation(int);
JScript .NET public function get TypeInformation() : int
public function set TypeInformation(int);

Property Value

System.Int32 . Integer that represents the offset to the type information.

This property is read/write.


ShaderConstantTable

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains the shader constant table that is embedded inside the shader.

Definition

Visual Basic .NET | Public Structure ShaderConstantTable
C# | public struct ShaderConstantTable
Managed C++ | public __value struct ShaderConstantTable
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderConstantTable | Initializes a new instance of the ShaderConstantTable class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BuildInfo | Retrieves or sets the offset, in bytes, to the build information.
ConstantInformation | Retrieves or sets the offset, in bytes, to the constant information.
Constants | Retrieves or sets the number of constants.
Creator | Retrieves or sets the offset, in bytes, to the name of the effect creator.
Flags | Retrieves or sets one or more values from the ShaderFlags enumeration that specify the compiler flags used to build the shader.
Size | Retrieves or sets the size of a constant.
Target | Retrieves or sets the offset, in bytes, into the string that contains the target.
Version | Retrieves or sets the shader version.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderConstantTable.ShaderConstantTable()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.ShaderConstantTable Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderConstantTable class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderConstantTable();
Managed C++ | public: ShaderConstantTable();
JScript .NET | public function ShaderConstantTable();


ShaderConstantTable.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderConstantTable.BuildInfo

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.BuildInfo Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, to the build information.

Definition

Visual Basic .NET | Public Property BuildInfo As Integer
C# | public int BuildInfo { get; set; }
Managed C++ public: __property int get_BuildInfo();
public: __property void set_BuildInfo(int);
JScript .NET public function get BuildInfo() : int
public function set BuildInfo(int);

Property Value

System.Int32 . Integer that represents the offset to the build information.

This property is read/write.


ShaderConstantTable.ConstantInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.ConstantInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, to the constant information.

Definition

Visual Basic .NET | Public Property ConstantInformation As Integer
C# | public int ConstantInformation { get; set; }
Managed C++ public: __property int get_ConstantInformation();
public: __property void set_ConstantInformation(int);
JScript .NET public function get ConstantInformation() : int
public function set ConstantInformation(int);

Property Value

System.Int32 . Integer that represents the offset to the constant information.

This property is read/write.


ShaderConstantTable.Constants

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.Constants Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of constants.

Definition

Visual Basic .NET | Public Property Constants As Integer
C# | public int Constants { get; set; }
Managed C++ public: __property int get_Constants();
public: __property void set_Constants(int);
JScript .NET public function get Constants() : int
public function set Constants(int);

Property Value

System.Int32 . Integer that represents the number of constants to set or retrieve.

This property is read/write.


ShaderConstantTable.Creator

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.Creator Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, to the name of the effect creator.

Definition

Visual Basic .NET | Public Property Creator As Integer
C# | public int Creator { get; set; }
Managed C++ public: __property int get_Creator();
public: __property void set_Creator(int);
JScript .NET public function get Creator() : int
public function set Creator(int);

Property Value

System.Int32 . Integer that represents the offset to the effect creator name.

This property is read/write.


ShaderConstantTable.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets one or more values from the ShaderFlags enumeration that specify the compiler flags used to build the shader.

Definition

Visual Basic .NET | Public Property Flags As ShaderFlags
C# | public ShaderFlags Flags { get; set; }
Managed C++ public: __property ShaderFlags get_Flags();
public: __property void set_Flags(ShaderFlags);
JScript .NET public function get Flags() : ShaderFlags
public function set Flags(ShaderFlags);

Property Value

Microsoft.DirectX.Direct3D.ShaderFlags . One or more values of the ShaderFlags enumeration to set or retrieve.

This property is read/write.


ShaderConstantTable.Size

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.Size Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the size of a constant.

Definition

Visual Basic .NET | Public Property Size As Integer
C# | public int Size { get; set; }
Managed C++ public: __property int get_Size();
public: __property void set_Size(int);
JScript .NET public function get Size() : int
public function set Size(int);

Property Value

System.Int32 . Integer that represents the size of the constant.

This property is read/write.

Remarks

Shader constant information is included in a tab-delimited table of comments. All offsets are measured in bytes from the beginning of the structure. Entries in the constant table are sorted by Creator in ascending order.


ShaderConstantTable.Target

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.Target Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, into the string that contains the target.

Definition

Visual Basic .NET | Public Property Target As Integer
C# | public int Target { get; set; }
Managed C++ public: __property int get_Target();
public: __property void set_Target(int);
JScript .NET public function get Target() : int
public function set Target(int);

Property Value

System.Int32 . Integer that represents the string offset of the target.

This property is read/write.


ShaderConstantTable.Version

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderConstantTable.Version Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the shader version.

Definition

Visual Basic .NET | Public Property Version As Integer
C# | public int Version { get; set; }
Managed C++ public: __property int get_Version();
public: __property void set_Version(int);
JScript .NET public function get Version() : int
public function set Version(int);

Property Value

System.Int32 . Integer that represents the shader version.

This property is read/write.


ShaderDebugInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains shader debug information.

Definition

Visual Basic .NET | Public Structure ShaderDebugInformation
C# | public struct ShaderDebugInformation
Managed C++ | public __value struct ShaderDebugInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderDebugInformation | Initializes a new instance of the ShaderDebugInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Creator | Retrieves or sets the offset to the shader creator information.
EntryPointName | Retrieves or sets the offset to the entry-point name.
FileInformation | Retrieves or sets the offset to the shader file information.
Files | Retrieves or sets the number of source files.
InstructionInformation | Retrieves or sets the offset, in bytes, from the start of the structure to the instructions.
Instructions | Retrieves or sets the number of instructions.
Size | Retrieves or sets the size, in bytes, of the debug information structure.
SourceCode | Retrieves or sets the offset, in bytes, from the start of the structure to the source code.
VariableInformation | Retrieves or sets the offset, in bytes, from the start of the structure to the variable information.
Variables | Retrieves or sets the number of variables.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderDebugInformation.ShaderDebugInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.ShaderDebugInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderDebugInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderDebugInformation();
Managed C++ | public: ShaderDebugInformation();
JScript .NET | public function ShaderDebugInformation();


ShaderDebugInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderDebugInformation.Creator

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.Creator Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset to the shader creator information.

Definition

Visual Basic .NET | Public Property Creator As Integer
C# | public int Creator { get; set; }
Managed C++ public: __property int get_Creator();
public: __property void set_Creator(int);
JScript .NET public function get Creator() : int
public function set Creator(int);

Property Value

System.Int32 . Integer that represents the offset to the shader creator information.

This property is read/write.


ShaderDebugInformation.EntryPointName

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.EntryPointName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset to the entry-point name.

Definition

Visual Basic .NET | Public Property EntryPointName As Integer
C# | public int EntryPointName { get; set; }
Managed C++ public: __property int get_EntryPointName();
public: __property void set_EntryPointName(int);
JScript .NET public function get EntryPointName() : int
public function set EntryPointName(int);

Property Value

System.Int32 . Integer that represents the offset to the entry-point name.

This property is read/write.


ShaderDebugInformation.FileInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.FileInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset to the shader file information.

Definition

Visual Basic .NET | Public Property FileInformation As Integer
C# | public int FileInformation { get; set; }
Managed C++ public: __property int get_FileInformation();
public: __property void set_FileInformation(int);
JScript .NET public function get FileInformation() : int
public function set FileInformation(int);

Property Value

System.Int32 . Integer that represents the offset to the shader file information.

This property is read/write.


ShaderDebugInformation.Files

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.Files Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of source files.

Definition

Visual Basic .NET | Public Property Files As Integer
C# | public int Files { get; set; }
Managed C++ public: __property int get_Files();
public: __property void set_Files(int);
JScript .NET public function get Files() : int
public function set Files(int);

Property Value

System.Int32 . Integer that represents the number of source files to set or retrieve.

This property is read/write.


ShaderDebugInformation.InstructionInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.InstructionInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, from the start of the structure to the instructions.

Definition

Visual Basic .NET | Public Property InstructionInformation As Integer
C# | public int InstructionInformation { get; set; }
Managed C++ public: __property int get_InstructionInformation();
public: __property void set_InstructionInformation(int);
JScript .NET public function get InstructionInformation() : int
public function set InstructionInformation(int);

Property Value

System.Int32 . Integer that represents the offset to the instructions to set or retrieve.

This property is read/write.


ShaderDebugInformation.Instructions

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.Instructions Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of instructions.

Definition

Visual Basic .NET | Public Property Instructions As Integer
C# | public int Instructions { get; set; }
Managed C++ public: __property int get_Instructions();
public: __property void set_Instructions(int);
JScript .NET public function get Instructions() : int
public function set Instructions(int);

Property Value

System.Int32 . Integer that represents the number of instructions to set or retrieve.

This property is read/write.


ShaderDebugInformation.Size

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.Size Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the size, in bytes, of the debug information structure.

Definition

Visual Basic .NET | Public Property Size As Integer
C# | public int Size { get; set; }
Managed C++ public: __property int get_Size();
public: __property void set_Size(int);
JScript .NET public function get Size() : int
public function set Size(int);

Property Value

System.Int32 . Integer that represents the size of the debug information structure.

This property is read/write.


ShaderDebugInformation.SourceCode

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.SourceCode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, from the start of the structure to the source code.

Definition

Visual Basic .NET | Public Property SourceCode As Integer
C# | public int SourceCode { get; set; }
Managed C++ public: __property int get_SourceCode();
public: __property void set_SourceCode(int);
JScript .NET public function get SourceCode() : int
public function set SourceCode(int);

Property Value

System.Int32 . Integer that represents the offset to the source code.

This property is read/write.


ShaderDebugInformation.VariableInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.VariableInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, from the start of the structure to the variable information.

Definition

Visual Basic .NET | Public Property VariableInformation As Integer
C# | public int VariableInformation { get; set; }
Managed C++ public: __property int get_VariableInformation();
public: __property void set_VariableInformation(int);
JScript .NET public function get VariableInformation() : int
public function set VariableInformation(int);

Property Value

System.Int32 . Integer that represents the offset to the variable information.

This property is read/write.


ShaderDebugInformation.Variables

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderDebugInformation.Variables Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of variables.

Definition

Visual Basic .NET | Public Property Variables As Integer
C# | public int Variables { get; set; }
Managed C++ public: __property int get_Variables();
public: __property void set_Variables(int);
JScript .NET public function get Variables() : int
public function set Variables(int);

Property Value

System.Int32 . Integer that represents the number of variables to set or retrieve.

This property is read/write.


ShaderFileInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderFileInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains information about the shader file.

Definition

Visual Basic .NET | Public Structure ShaderFileInformation
C# | public struct ShaderFileInformation
Managed C++ | public __value struct ShaderFileInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderFileInformation | Initializes a new instance of the ShaderFileInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets the offset, in bytes, to the shader name.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderFileInformation.ShaderFileInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderFileInformation.ShaderFileInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderFileInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderFileInformation();
Managed C++ | public: ShaderFileInformation();
JScript .NET | public function ShaderFileInformation();


ShaderFileInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderFileInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderFileInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderFileInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, to the shader name.

Definition

Visual Basic .NET | Public Property Name As Integer
C# | public int Name { get; set; }
Managed C++ public: __property int get_Name();
public: __property void set_Name(int);
JScript .NET public function get Name() : int
public function set Name(int);

Property Value

System.Int32 . Integer that represents the shader name offset.

This property is read/write.


ShaderInstructionInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderInstructionInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains data for retrieving shader instruction information.

Definition

Visual Basic .NET | Public Structure ShaderInstructionInformation
C# | public struct ShaderInstructionInformation
Managed C++ | public __value struct ShaderInstructionInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderInstructionInformation | Initializes a new instance of the ShaderInstructionInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
File | Retrieves or sets the offset, in bytes, from the beginning of the debug information to the file-name string.
Line | Retrieves or sets the shader line number that contains the instruction.
Offset | Retrieves or sets the offset for the shader instruction.

Remarks

This structure is used to maintain information about a shader instruction, such as the offset of the file name string or the offset of the point at which the instruction begins.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderInstructionInformation.ShaderInstructionInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderInstructionInformation.ShaderInstructionInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderInstructionInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderInstructionInformation();
Managed C++ | public: ShaderInstructionInformation();
JScript .NET | public function ShaderInstructionInformation();


ShaderInstructionInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderInstructionInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderInstructionInformation.File

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderInstructionInformation.File Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset, in bytes, from the beginning of the debug information to the file-name string.

Definition

Visual Basic .NET | Public Property File As Short
C# | public short File { get; set; }
Managed C++ public: __property short get_File();
public: __property void set_File(short);
JScript .NET public function get File() : short
public function set File(short);

Property Value

System.Int16 . Integer that represents the file-name string offset in bytes.

This property is read/write.


ShaderInstructionInformation.Line

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderInstructionInformation.Line Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the shader line number that contains the instruction.

Definition

Visual Basic .NET | Public Property Line As Short
C# | public short Line { get; set; }
Managed C++ public: __property short get_Line();
public: __property void set_Line(short);
JScript .NET public function get Line() : short
public function set Line(short);

Property Value

System.Int16 . Integer that represents the shader instruction line number to set or retrieve.

This property is read/write.


ShaderInstructionInformation.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderInstructionInformation.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset for the shader instruction.

Definition

Visual Basic .NET | Public Property Offset As Integer
C# | public int Offset { get; set; }
Managed C++ public: __property int get_Offset();
public: __property void set_Offset(int);
JScript .NET public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32 . Integer that represents the shader instruction offset.

This property is read/write.


ShaderStructMemberInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderStructMemberInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains the shader structure member information.

Definition

Visual Basic .NET | Public Structure ShaderStructMemberInformation
C# | public struct ShaderStructMemberInformation
Managed C++ | public __value struct ShaderStructMemberInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderStructMemberInformation | Initializes a new instance of the ShaderStructMemberInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets the shader structure member name.
TypeInformation | Retrieves or sets the offset of the string that contains the type information.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderStructMemberInformation.ShaderStructMemberInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderStructMemberInformation.ShaderStructMemberInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderStructMemberInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderStructMemberInformation();
Managed C++ | public: ShaderStructMemberInformation();
JScript .NET | public function ShaderStructMemberInformation();


ShaderStructMemberInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderStructMemberInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderStructMemberInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderStructMemberInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the shader structure member name.

Definition

Visual Basic .NET | Public Property Name As Integer
C# | public int Name { get; set; }
Managed C++ public: __property int get_Name();
public: __property void set_Name(int);
JScript .NET public function get Name() : int
public function set Name(int);

Property Value

System.Int32 . Integer that represents the offset of the structure member name.

This property is read/write.


ShaderStructMemberInformation.TypeInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderStructMemberInformation.TypeInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset of the string that contains the type information.

Definition

Visual Basic .NET | Public Property TypeInformation As Integer
C# | public int TypeInformation { get; set; }
Managed C++ public: __property int get_TypeInformation();
public: __property void set_TypeInformation(int);
JScript .NET public function get TypeInformation() : int
public function set TypeInformation(int);

Property Value

System.Int32 . Integer that represents the offset of the type information string.

This property is read/write.


ShaderTypeInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains shader type information.

Definition

Visual Basic .NET | Public Structure ShaderTypeInformation
C# | public struct ShaderTypeInformation
Managed C++ | public __value struct ShaderTypeInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderTypeInformation | Initializes a new instance of the ShaderTypeInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Class | Retrieves or sets the class for shader type information.
Columns | Retrieves or sets the number of columns for vectors and matrices.
Elements | Retrieves or sets the number of elements, or the array dimensions, for the shader type information.
StructMemberInformation | Retrieves or sets the offset of the structure member information.
StructMembers | Retrieves or sets the number of structure members.
Type | Retrieves or sets the type for shader type information.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderTypeInformation.ShaderTypeInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.ShaderTypeInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderTypeInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderTypeInformation();
Managed C++ | public: ShaderTypeInformation();
JScript .NET | public function ShaderTypeInformation();


ShaderTypeInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderTypeInformation.Class

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.Class Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the class for shader type information.

Definition

Visual Basic .NET | Public Property Class As Short
C# | public short Class { get; set; }
Managed C++ public: __property short get_Class();
public: __property void set_Class(short);
JScript .NET public function get Class() : short
public function set Class(short);

Property Value

System.Int16 . Member of the ParameterClass enumeration that represents the class of the object.

This property is read/write.


ShaderTypeInformation.Columns

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.Columns Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of columns for vectors and matrices.

Definition

Visual Basic .NET | Public Property Columns As Short
C# | public short Columns { get; set; }
Managed C++ public: __property short get_Columns();
public: __property void set_Columns(short);
JScript .NET public function get Columns() : short
public function set Columns(short);

Property Value

System.Int16 . Integer that represents the number of columns.

This property is read/write.


ShaderTypeInformation.Elements

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.Elements Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of elements, or the array dimensions, for the shader type information.

Definition

Visual Basic .NET | Public Property Elements As Short
C# | public short Elements { get; set; }
Managed C++ public: __property short get_Elements();
public: __property void set_Elements(short);
JScript .NET public function get Elements() : short
public function set Elements(short);

Property Value

System.Int16 . Integer that represents the number of elements in the array.

This property is read/write.


ShaderTypeInformation.StructMemberInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.StructMemberInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset of the structure member information.

Definition

Visual Basic .NET | Public Property StructMemberInformation As Integer
C# | public int StructMemberInformation { get; set; }
Managed C++ public: __property int get_StructMemberInformation();
public: __property void set_StructMemberInformation(int);
JScript .NET public function get StructMemberInformation() : int
public function set StructMemberInformation(int);

Property Value

System.Int32 . Integer that represents the offset.

This property is read/write.


ShaderTypeInformation.StructMembers

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.StructMembers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of structure members.

Definition

Visual Basic .NET | Public Property StructMembers As Short
C# | public short StructMembers { get; set; }
Managed C++ public: __property short get_StructMembers();
public: __property void set_StructMembers(short);
JScript .NET public function get StructMembers() : short
public function set StructMembers(short);

Property Value

System.Int16 . Integer that represents the number of structure members.

This property is read/write.


ShaderTypeInformation.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderTypeInformation.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the type for shader type information.

Definition

Visual Basic .NET | Public Property Type As Short
C# | public short Type { get; set; }
Managed C++ public: __property short get_Type();
public: __property void set_Type(short);
JScript .NET public function get Type() : short
public function set Type(short);

Property Value

System.Int16 . Member of the ParameterType enumeration that represents the type of the object.

This property is read/write.


ShaderVariableInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains shader variable information.

Definition

Visual Basic .NET | Public Structure ShaderVariableInformation
C# | public struct ShaderVariableInformation
Managed C++ | public __value struct ShaderVariableInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderVariableInformation | Initializes a new instance of the ShaderVariableInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets the shader variable name.
Scope | Retrieves or sets the scope of the shader variable.
TypeInformation | Retrieves or sets the type of the shader variable.
WriteInformation | Retrieves or sets the write information for the variable.
Writes | Retrieves or sets the number of writes.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderVariableInformation.ShaderVariableInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation.ShaderVariableInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderVariableInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderVariableInformation();
Managed C++ | public: ShaderVariableInformation();
JScript .NET | public function ShaderVariableInformation();


ShaderVariableInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderVariableInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the shader variable name.

Definition

Visual Basic .NET | Public Property Name As Integer
C# | public int Name { get; set; }
Managed C++ public: __property int get_Name();
public: __property void set_Name(int);
JScript .NET public function get Name() : int
public function set Name(int);

Property Value

System.Int32 . Integer that represents the offset of the shader variable name.

This property is read/write.


ShaderVariableInformation.Scope

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation.Scope Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the scope of the shader variable.

Definition

Visual Basic .NET | Public Property Scope As Integer
C# | public int Scope { get; set; }
Managed C++ public: __property int get_Scope();
public: __property void set_Scope(int);
JScript .NET public function get Scope() : int
public function set Scope(int);

Property Value

System.Int32 . Integer that represents the scope identifier.

This property is read/write.


ShaderVariableInformation.TypeInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation.TypeInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the type of the shader variable.

Definition

Visual Basic .NET | Public Property TypeInformation As Integer
C# | public int TypeInformation { get; set; }
Managed C++ public: __property int get_TypeInformation();
public: __property void set_TypeInformation(int);
JScript .NET public function get TypeInformation() : int
public function set TypeInformation(int);

Property Value

System.Int32 . Integer that represents the offset of the shader-variable type information.

This property is read/write.


ShaderVariableInformation.WriteInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation.WriteInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the write information for the variable.

Definition

Visual Basic .NET | Public Property WriteInformation As Integer
C# | public int WriteInformation { get; set; }
Managed C++ public: __property int get_WriteInformation();
public: __property void set_WriteInformation(int);
JScript .NET public function get WriteInformation() : int
public function set WriteInformation(int);

Property Value

System.Int32 . Integer that represents the offset of the write information.

This property is read/write.


ShaderVariableInformation.Writes

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderVariableInformation.Writes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of writes.

Definition

Visual Basic .NET | Public Property Writes As Integer
C# | public int Writes { get; set; }
Managed C++ public: __property int get_Writes();
public: __property void set_Writes(int);
JScript .NET public function get Writes() : int
public function set Writes(int);

Property Value

System.Int32 . Integer that represents the number of writes.

This property is read/write.


ShaderWriteInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderWriteInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains the shader write information.

Definition

Visual Basic .NET | Public Structure ShaderWriteInformation
C# | public struct ShaderWriteInformation
Managed C++ | public __value struct ShaderWriteInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderWriteInformation | Initializes a new instance of the ShaderWriteInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Instruction | Retrieves or sets the shader instruction to write.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ShaderWriteInformation.ShaderWriteInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderWriteInformation.ShaderWriteInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ShaderWriteInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ShaderWriteInformation();
Managed C++ | public: ShaderWriteInformation();
JScript .NET | public function ShaderWriteInformation();


ShaderWriteInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderWriteInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ShaderWriteInformation.Instruction

Microsoft DirectX 9.0 SDK Update (October 2004)

ShaderWriteInformation.Instruction Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the shader instruction to write.

Definition

Visual Basic .NET | Public Property Instruction As Integer
C# | public int Instruction { get; set; }
Managed C++ public: __property int get_Instruction();
public: __property void set_Instruction(int);
JScript .NET public function get Instruction() : int
public function set Instruction(int);

Property Value

System.Int32 . Integer that represents the shader instruction to set or retrieve.

This property is read/write.


SkinMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains skin information and mesh data.

Definition

Visual Basic .NET | Public Structure SkinMesh
C# | public struct SkinMesh
Managed C++ | public __value struct SkinMesh
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) FromX | Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.
SkinMesh | Initializes a new instance of the SkinMesh class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Mesh | Retrieves or sets the Mesh object associated with the current skin information.
SkinInformation | Retrieves or sets the SkinInformation object used for skinning.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SkinMesh.FromX

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.

Overload List

public static SkinMesh FromX(XFileData, MeshFlags, Device);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static SkinMesh FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : SkinMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the Microsoft® DirectX® file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags enumeration that specifies creation options for the mesh.
device | Microsoft.DirectX.Direct3D.Device. A Device object associated with the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial objects loaded from the .x file data object.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh . A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
Managed C++ public: static SkinMesh FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : SkinMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the Microsoft® DirectX® file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags enumeration that specifies creation options for the mesh.
device | Microsoft.DirectX.Direct3D.Device. A Device object associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh . A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,ExtendedMaterial)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
Managed C++ public: static SkinMesh FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : SkinMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the Microsoft® DirectX® file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags enumeration that specifies creation options for the mesh.
device | Microsoft.DirectX.Direct3D.Device. A Device object associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial objects loaded from the .x file data object.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh . A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
Managed C++ public: static SkinMesh FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
GraphicsStream **adjacency
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : SkinMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the Microsoft® DirectX® file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags enumeration that specifies creation options for the mesh.
device | Microsoft.DirectX.Direct3D.Device. A Device object associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh . A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device
);
Managed C++ public: static SkinMesh FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device
) : SkinMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the Microsoft® DirectX® file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags enumeration that specifies creation options for the mesh.
device | Microsoft.DirectX.Direct3D.Device. A Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh . A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance)

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.FromX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads skin information and mesh data from a Microsoft® Direct3D® .x file data object.

Definition

Visual Basic .NET Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
Managed C++ public: static SkinMesh FromX(
XFileData *xofObjMesh,
MeshFlags options,
Device *device,
GraphicsStream **adjacency,
ExtendedMaterial *materials,
EffectInstance *effects
);
JScript .NET public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : SkinMesh;

Parameters

xofObjMesh | Microsoft.DirectX.Direct3D.XFileData. An XFileData object that represents the Microsoft® DirectX® file data object to load.
options | Microsoft.DirectX.Direct3D.MeshFlags. A MeshFlags enumeration that specifies creation options for the mesh.
device | Microsoft.DirectX.Direct3D.Device. A Device object associated with the mesh.
adjacency | Microsoft.DirectX.GraphicsStream. A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials | Microsoft.DirectX.Direct3D.ExtendedMaterial[]. Array of ExtendedMaterial objects loaded from the .x file data object.
effects | Microsoft.DirectX.Direct3D.EffectInstance[]. An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh . A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft® Direct3D® could not allocate sufficient memory to complete the call.


SkinMesh.SkinMesh()

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.SkinMesh Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SkinMesh class.

Definition

Visual Basic .NET | Public Sub New()
C# | public SkinMesh();
Managed C++ | public: SkinMesh();
JScript .NET | public function SkinMesh();


SkinMesh.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SkinMesh.Mesh

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.Mesh Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the Mesh object associated with the current skin information.

Definition

Visual Basic .NET | Public Property Mesh As Mesh
C# | public Mesh Mesh { get; set; }
Managed C++ public: __property Mesh* get_Mesh();
public: __property void set_Mesh(Mesh*);
JScript .NET public function get Mesh() : Mesh
public function set Mesh(Mesh);

Property Value

Microsoft.DirectX.Direct3D.Mesh . A Mesh object to set or retrieve.

This property is read/write.


SkinMesh.SkinInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

SkinMesh.SkinInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the SkinInformation object used for skinning.

Definition

Visual Basic .NET | Public Property SkinInformation As SkinInformation
C# | public SkinInformation SkinInformation { get; set; }
Managed C++ public: __property SkinInformation* get_SkinInformation();
public: __property void set_SkinInformation(SkinInformation*);
JScript .NET public function get SkinInformation() : SkinInformation
public function set SkinInformation(SkinInformation);

Property Value

Microsoft.DirectX.Direct3D.SkinInformation . A SkinInformation object to set or retrieve.

This property is read/write.


SphericalHarmonicMaterial

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains spherical harmonic (SH) precomputed radiance transfer (PRT) material characteristics.

Definition

Visual Basic .NET | Public Structure SphericalHarmonicMaterial
C# | public struct SphericalHarmonicMaterial
Managed C++ | public __value struct SphericalHarmonicMaterial
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
SphericalHarmonicMaterial | Initializes a new instance of the SphericalHarmonicMaterial structure.

Properties

Property | Description
Absorption | Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.
AbsorptionColor | Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.
Diffuse | Retrieves or sets the diffuse albedo of the surface.
DiffuseColor | Retrieves or sets the diffuse albedo of the surface.
IsMirror | Determines whether the material is a mirror.
IsSubsurfaceScattering | Enables or disables subsurface scattering.
ReducedScattering | Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.
ReducedScatteringColor | Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.
RelativeIndexOfRefraction | Retrieves or sets the relative index of refraction as the ratio between two absolute indices of refraction.

Remarks

Non-spectral scenes use the red channel from the materials instead of the luminance value.

For more information about precomputed radiance transfer (PRT) see:

  • Jensen et al., Siggraph Proceedings: A Practical Model for Subsurface Light Transport, 2001.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • PrtEngine.SetMeshMaterials


SphericalHarmonicMaterial.SphericalHarmonicMaterial()

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.SphericalHarmonicMaterial Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SphericalHarmonicMaterial structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public SphericalHarmonicMaterial();
Managed C++ | public: SphericalHarmonicMaterial();
JScript .NET | public function SphericalHarmonicMaterial();


SphericalHarmonicMaterial.Absorption

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.Absorption Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.

Definition

Visual Basic .NET | Public Property Absorption As Color
C# | public Color Absorption { get; set; }
Managed C++ public: __property Color get_Absorption();
public: __property void set_Absorption(Color);
JScript .NET public function get Absorption() : Color
public function set Absorption(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the absorption coefficient.

This property is read/write.

Remarks

The absorption coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.AbsorptionColor

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.AbsorptionColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.

Definition

Visual Basic .NET | Public Property AbsorptionColor As ColorValue
C# | public ColorValue AbsorptionColor { get; set; }
Managed C++ public: __property ColorValue get_AbsorptionColor();
public: __property void set_AbsorptionColor(ColorValue);
JScript .NET public function get AbsorptionColor() : ColorValue
public function set AbsorptionColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the absorption coefficient.

This property is read/write.

Remarks

The absorption coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.Diffuse

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.Diffuse Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the diffuse albedo of the surface.

Definition

Visual Basic .NET | Public Property Diffuse As Color
C# | public Color Diffuse { get; set; }
Managed C++ public: __property Color get_Diffuse();
public: __property void set_Diffuse(Color);
JScript .NET public function get Diffuse() : Color
public function set Diffuse(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the diffuse albedo of the surface.

This property is read/write.

Remarks

This value is ignored if the object is a mirror.


SphericalHarmonicMaterial.DiffuseColor

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.DiffuseColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the diffuse albedo of the surface.

Definition

Visual Basic .NET | Public Property DiffuseColor As ColorValue
C# | public ColorValue DiffuseColor { get; set; }
Managed C++ public: __property ColorValue get_DiffuseColor();
public: __property void set_DiffuseColor(ColorValue);
JScript .NET public function get DiffuseColor() : ColorValue
public function set DiffuseColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the diffuse albedo of the surface.

This property is read/write.

Remarks

This value is ignored if the object is a mirror.


SphericalHarmonicMaterial.IsMirror

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.IsMirror Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the material is a mirror.

Definition

Visual Basic .NET | Public Property IsMirror As Boolean
C# | public bool IsMirror { get; set; }
Managed C++ public: __property bool get_IsMirror();
public: __property void set_IsMirror(bool);
JScript .NET public function get IsMirror() : boolean
public function set IsMirror(boolean);

Property Value

System.Boolean . Must be set to false. A setting of true is not currently supported.

This property is read/write.


SphericalHarmonicMaterial.IsSubsurfaceScattering

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.IsSubsurfaceScattering Property

Language:
Note: This documentation is preliminary and is subject to change.

Enables or disables subsurface scattering.

Definition

Visual Basic .NET | Public Property IsSubsurfaceScattering As Boolean
C# | public bool IsSubsurfaceScattering { get; set; }
Managed C++ public: __property bool get_IsSubsurfaceScattering();
public: __property void set_IsSubsurfaceScattering(bool);
JScript .NET public function get IsSubsurfaceScattering() : boolean
public function set IsSubsurfaceScattering(boolean);

Property Value

System.Boolean . Set to true to enable subsurface scattering, or false to disable it.

This property is read/write.

Remarks

Any object that does subsurface scattering cannot be a mirror.


SphericalHarmonicMaterial.ReducedScattering

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.ReducedScattering Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.

Definition

Visual Basic .NET | Public Property ReducedScattering As Color
C# | public Color ReducedScattering { get; set; }
Managed C++ public: __property Color get_ReducedScattering();
public: __property void set_ReducedScattering(Color);
JScript .NET public function get ReducedScattering() : Color
public function set ReducedScattering(Color);

Property Value

System.Drawing.Color . A Color Leave Site object that represents the reduced scattering coefficient.

This property is read/write.

Remarks

The reduced scattering coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.ReducedScatteringColor

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.ReducedScatteringColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.

Definition

Visual Basic .NET | Public Property ReducedScatteringColor As ColorValue
C# | public ColorValue ReducedScatteringColor { get; set; }
Managed C++ public: __property ColorValue get_ReducedScatteringColor();
public: __property void set_ReducedScatteringColor(ColorValue);
JScript .NET public function get ReducedScatteringColor() : ColorValue
public function set ReducedScatteringColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue . A ColorValue object that represents the reduced scattering coefficient.

This property is read/write.

Remarks

The reduced scattering coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.RelativeIndexOfRefraction

Microsoft DirectX 9.0 SDK Update (October 2004)

SphericalHarmonicMaterial.RelativeIndexOfRefraction Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the relative index of refraction as the ratio between two absolute indices of refraction.

Definition

Visual Basic .NET | Public Property RelativeIndexOfRefraction As Single
C# | public float RelativeIndexOfRefraction { get; set; }
Managed C++ public: __property float get_RelativeIndexOfRefraction();
public: __property void set_RelativeIndexOfRefraction(float);
JScript .NET public function get RelativeIndexOfRefraction() : float
public function set RelativeIndexOfRefraction(float);

Property Value

System.Single . A floating-point value that represents the relative index of refraction.

This property is read/write.

Remarks

The relative index of refraction is the ratio between two absolute indices of refraction. An index of refraction is the ratio of the sine of the angle of incidence to the sine of the angle of refraction.


StageTimings

Microsoft DirectX 9.0 SDK Update (October 2004)

StageTimings Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Provides percentage of time spent processing shader data.

Definition

Visual Basic .NET | Public Structure StageTimings
C# | public struct StageTimings
Managed C++ | public __value struct StageTimings
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
StageTimings | Creates a new instance of the StageTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ComputationProcessingPercent | Retrieves the percentage of time processing (moving data around in registers or doing mathematical operations).
MemoryProcessingPercent | Retrieves the percentage of time in the shader spent on memory accesses.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StageTimings.StageTimings()

Microsoft DirectX 9.0 SDK Update (October 2004)

StageTimings.StageTimings Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new instance of the StageTimings structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public StageTimings();
Managed C++ | public: StageTimings();
JScript .NET | public function StageTimings();


StageTimings.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

StageTimings.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


StageTimings.ComputationProcessingPercent

Microsoft DirectX 9.0 SDK Update (October 2004)

StageTimings.ComputationProcessingPercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time processing (moving data around in registers or doing mathematical operations).

Definition

Visual Basic .NET | Public ReadOnly Property ComputationProcessingPercent As Single
C# | public float ComputationProcessingPercent { get; }
Managed C++ | public: __property float get_ComputationProcessingPercent();
JScript .NET | public function get ComputationProcessingPercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time processing.

This property is read-only.


StageTimings.MemoryProcessingPercent

Microsoft DirectX 9.0 SDK Update (October 2004)

StageTimings.MemoryProcessingPercent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the percentage of time in the shader spent on memory accesses.

Definition

Visual Basic .NET | Public ReadOnly Property MemoryProcessingPercent As Single
C# | public float MemoryProcessingPercent { get; }
Managed C++ | public: __property float get_MemoryProcessingPercent();
JScript .NET | public function get MemoryProcessingPercent() : float

Property Value

System.Single . A Single Leave Site that represents the percentage of time in the shader spent on memory accesses.

This property is read-only.


StencilCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains flags that specify supported stencil-buffer operations.

Definition

Visual Basic .NET | Public Structure StencilCaps
C# | public struct StencilCaps
Managed C++ | public __value struct StencilCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDecrement | Specifies whether the stencil buffer entry can be decremented, wrapping to the maximum value if the new value is less than zero.
SupportsDecrementSaturation | Specifies whether the stencil buffer entry can be decremented, clamping to zero.
SupportsIncrement | Specifies whether the stencil buffer entry can be incremented, wrapping to zero if the new value exceeds the maximum value.
SupportsIncrementSaturation | Specifies whether the stencil buffer entry can be incremented, clamping to the maximum value.
SupportsInvert | Specifies whether the bits in the stencil buffer entry can be inverted.
SupportsKeep | Specifies whether to keep the stencil buffer entry unmodified or allow it to be updated.
SupportsReplace | Specifies whether to replace the stencil buffer entry with a reference value.
SupportsTwoSided | Specifies whether the device supports two-sided stenciling.
SupportsZero | Specifies whether the device supports setting the stencil buffer entry to 0.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StencilCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


StencilCaps.SupportsDecrement

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsDecrement Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the stencil buffer entry can be decremented, wrapping to the maximum value if the new value is less than zero.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDecrement As Boolean
C# | public bool SupportsDecrement { get; }
Managed C++ | public: __property bool get_SupportsDecrement();
JScript .NET | public function get SupportsDecrement() : boolean

Property Value

System.Boolean . Value that is true if the stencil-buffer entry can be decremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsDecrementSaturation

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsDecrementSaturation Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the stencil buffer entry can be decremented, clamping to zero.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDecrementSaturation As Boolean
C# | public bool SupportsDecrementSaturation { get; }
Managed C++ | public: __property bool get_SupportsDecrementSaturation();
JScript .NET | public function get SupportsDecrementSaturation() : boolean

Property Value

System.Boolean . Value that is true if the stencil-buffer entry can be decremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsIncrement

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsIncrement Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the stencil buffer entry can be incremented, wrapping to zero if the new value exceeds the maximum value.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsIncrement As Boolean
C# | public bool SupportsIncrement { get; }
Managed C++ | public: __property bool get_SupportsIncrement();
JScript .NET | public function get SupportsIncrement() : boolean

Property Value

System.Boolean . Value that is true if the stencil-buffer entry can be incremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsIncrementSaturation

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsIncrementSaturation Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the stencil buffer entry can be incremented, clamping to the maximum value.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsIncrementSaturation As Boolean
C# | public bool SupportsIncrementSaturation { get; }
Managed C++ | public: __property bool get_SupportsIncrementSaturation();
JScript .NET | public function get SupportsIncrementSaturation() : boolean

Property Value

System.Boolean . Value that is true if the stencil-buffer entry can be incremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsInvert

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsInvert Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the bits in the stencil buffer entry can be inverted.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsInvert As Boolean
C# | public bool SupportsInvert { get; }
Managed C++ | public: __property bool get_SupportsInvert();
JScript .NET | public function get SupportsInvert() : boolean

Property Value

System.Boolean . Value that is true if the stencil-buffer bits can be inverted, or false if they cannot.

This property is read-only.


StencilCaps.SupportsKeep

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsKeep Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether to keep the stencil buffer entry unmodified or allow it to be updated.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsKeep As Boolean
C# | public bool SupportsKeep { get; }
Managed C++ | public: __property bool get_SupportsKeep();
JScript .NET | public function get SupportsKeep() : boolean

Property Value

System.Boolean . Value that is true to keep the stencil-buffer entry unmodified, or false to allow it to be updated.

This property is read-only.


StencilCaps.SupportsReplace

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsReplace Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether to replace the stencil buffer entry with a reference value.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsReplace As Boolean
C# | public bool SupportsReplace { get; }
Managed C++ | public: __property bool get_SupportsReplace();
JScript .NET | public function get SupportsReplace() : boolean

Property Value

System.Boolean . Value that is true to replace the stencil-buffer entry with a reference value, or false otherwise.

This property is read-only.


StencilCaps.SupportsTwoSided

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsTwoSided Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports two-sided stenciling.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTwoSided As Boolean
C# | public bool SupportsTwoSided { get; }
Managed C++ | public: __property bool get_SupportsTwoSided();
JScript .NET | public function get SupportsTwoSided() : boolean

Property Value

System.Boolean . Value that is true if two-sided stenciling is supported, or false if it is not.

This property is read-only.


StencilCaps.SupportsZero

Microsoft DirectX 9.0 SDK Update (October 2004)

StencilCaps.SupportsZero Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports setting the stencil buffer entry to 0.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsZero As Boolean
C# | public bool SupportsZero { get; }
Managed C++ | public: __property bool get_SupportsZero();
JScript .NET | public function get SupportsZero() : boolean

Property Value

System.Boolean . Value that is true if setting the stencil-buffer entry to 0 is supported, or false if it is not.

This property is read-only.


SurfaceDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a surface.

Definition

Visual Basic .NET | Public Structure SurfaceDescription
C# | public struct SurfaceDescription
Managed C++ | public __value struct SurfaceDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
SurfaceDescription | Initializes a new instance of the SurfaceDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets a value of the Format enumeration that describes the surface format.
Height | Retrieves or sets the height of the surface.
MultiSampleQuality | Retrieves or sets the multisample quality level.
MultiSampleType | Retrieves or sets a member of the MultiSampleType enumeration that specifies the levels of full-scene multisampling supported by the surface.
Pool | Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current surface.
Type | Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a surface.
Usage | Retrieves or sets a member of the Usage enumeration that specifies the usage type of the surface.
Width | Retrieves or sets the width of the surface.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceDescription.SurfaceDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.SurfaceDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SurfaceDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public SurfaceDescription();
Managed C++ | public: SurfaceDescription();
JScript .NET | public function SurfaceDescription();


SurfaceDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SurfaceDescription.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value of the Format enumeration that describes the surface format.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . Member of the Format enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height of the surface.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height of the surface, in pixels.

This property is read/write.


SurfaceDescription.MultiSampleQuality

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.MultiSampleQuality Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the multisample quality level.

Definition

Visual Basic .NET | Public Property MultiSampleQuality As Integer
C# | public int MultiSampleQuality { get; set; }
Managed C++ public: __property int get_MultiSampleQuality();
public: __property void set_MultiSampleQuality(int);
JScript .NET public function get MultiSampleQuality() : int
public function set MultiSampleQuality(int);

Property Value

System.Int32 . Integer that represents the quality level.

This property is read/write.

Remarks

The valid quality level range is between zero and one less than the level returned by the qualityLevels parameter of Manager.CheckDeviceMultiSampleType.


SurfaceDescription.MultiSampleType

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.MultiSampleType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a member of the MultiSampleType enumeration that specifies the levels of full-scene multisampling supported by the surface.

Definition

Visual Basic .NET | Public Property MultiSampleType As MultiSampleType
C# | public MultiSampleType MultiSampleType { get; set; }
Managed C++ public: __property MultiSampleType get_MultiSampleType();
public: __property void set_MultiSampleType(MultiSampleType);
JScript .NET public function get MultiSampleType() : MultiSampleType
public function set MultiSampleType(MultiSampleType);

Property Value

Microsoft.DirectX.Direct3D.MultiSampleType . Member of the MultiSampleType enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Pool

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Pool Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current surface.

Definition

Visual Basic .NET | Public Property Pool As Pool
C# | public Pool Pool { get; set; }
Managed C++ public: __property Pool get_Pool();
public: __property void set_Pool(Pool);
JScript .NET public function get Pool() : Pool
public function set Pool(Pool);

Property Value

Microsoft.DirectX.Direct3D.Pool . Member of the Pool enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a surface.

Definition

Visual Basic .NET | Public Property Type As ResourceType
C# | public ResourceType Type { get; set; }
Managed C++ public: __property ResourceType get_Type();
public: __property void set_Type(ResourceType);
JScript .NET public function get Type() : ResourceType
public function set Type(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType . Member of the ResourceType enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Usage Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a member of the Usage enumeration that specifies the usage type of the surface.

Definition

Visual Basic .NET | Public Property Usage As Usage
C# | public Usage Usage { get; set; }
Managed C++ public: __property Usage get_Usage();
public: __property void set_Usage(Usage);
JScript .NET public function get Usage() : Usage
public function set Usage(Usage);

Property Value

Microsoft.DirectX.Direct3D.Usage . Member of the Usage enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of the surface.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width of the surface, in pixels.

This property is read/write.


TechniqueDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

TechniqueDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a technique used by an effect.

Definition

Visual Basic .NET | Public Structure TechniqueDescription
C# | public struct TechniqueDescription
Managed C++ | public __value struct TechniqueDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
TechniqueDescription | Initializes a new instance of the TechniqueDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Retrieves the number of annotations for the current technique.
Name | Retrieves the technique name.
Passes | Retrieves the number of rendering passes the technique requires.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TechniqueDescription.TechniqueDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

TechniqueDescription.TechniqueDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TechniqueDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public TechniqueDescription();
Managed C++ | public: TechniqueDescription();
JScript .NET | public function TechniqueDescription();


TechniqueDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

TechniqueDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


TechniqueDescription.Annotations

Microsoft DirectX 9.0 SDK Update (October 2004)

TechniqueDescription.Annotations Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of annotations for the current technique.

Definition

Visual Basic .NET | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
Managed C++ | public: __property int get_Annotations();
JScript .NET | public function get Annotations() : int

Property Value

System.Int32 . Integer that represents the number of annotations.

This property is read-only.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


TechniqueDescription.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

TechniqueDescription.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the technique name.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String . String that contains the technique name.

This property is read-only.


TechniqueDescription.Passes

Microsoft DirectX 9.0 SDK Update (October 2004)

TechniqueDescription.Passes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of rendering passes the technique requires.

Definition

Visual Basic .NET | Public ReadOnly Property Passes As Integer
C# | public int Passes { get; }
Managed C++ | public: __property int get_Passes();
JScript .NET | public function get Passes() : int

Property Value

System.Int32 . Integer that represents the number of rendering passes required.

This property is read-only.

Remarks

Some video cards can render two textures in a single pass. However, if a card does not have this capability, it is often possible to render the same effect in two passes, using one texture for each pass.


TextureCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains miscellaneous texture-mapping capabilities.

Definition

Visual Basic .NET | Public Structure TextureCaps
C# | public struct TextureCaps
Managed C++ | public __value struct TextureCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlpha | Specifies whether alpha in texture pixels is supported.
SupportsAlphaPalette | Specifies whether the device can draw alpha from texture palettes.
SupportsCubeMap | Specifies whether cube textures are supported.
SupportsCubeMapPower2 | Specifies whether the device requires that cube texture maps have dimensions specified as powers of two.
SupportsMipCubeMap | Specifies whether the device supports mipmapped cube textures.
SupportsMipMap | Specifies whether the device supports mipmapped textures.
SupportsMipVolumeMap | Specifies whether the device supports mipmapped volume textures.
SupportsNonPower2Conditional | Specifies whether the device conditionally supports the use of 2-D textures with dimensions that are not powers of two.
SupportsNoProjectedBumpEnvironment | Specifies whether the device does not support a projected bump-environment lookup operation in programmable and fixed-function shaders.
SupportsPerspective | Specifies whether perspective correction texturing is supported.
SupportsPower2 | Specifies whether the device supports all textures having widths and heights that are specified as powers of two.
SupportsProjected | Specifies whether TextureTransform.Projected is supported.
SupportsSquareOnly | Specifies whether all textures must be square.
SupportsTextureRepeatNotScaledBySize | Specifies whether texture indices are not scaled by the texture size prior to interpolation.
SupportsVolumeMap | Specifies whether the device supports volume textures.
SupportsVolumeMapPower2 | Specifies whether the device requires that volume texture maps have dimensions that are specified as powers of two.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


TextureCaps.SupportsAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether alpha in texture pixels is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAlpha As Boolean
C# | public bool SupportsAlpha { get; }
Managed C++ | public: __property bool get_SupportsAlpha();
JScript .NET | public function get SupportsAlpha() : boolean

Property Value

System.Boolean . Value that is true if alpha in texture pixels is supported, or false if it is not.

This property is read-only.


TextureCaps.SupportsAlphaPalette

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsAlphaPalette Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device can draw alpha from texture palettes.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAlphaPalette As Boolean
C# | public bool SupportsAlphaPalette { get; }
Managed C++ | public: __property bool get_SupportsAlphaPalette();
JScript .NET | public function get SupportsAlphaPalette() : boolean

Property Value

System.Boolean . Value that is true if the device can draw alpha from texture palettes, or false if it cannot.

This property is read-only.


TextureCaps.SupportsCubeMap

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsCubeMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether cube textures are supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsCubeMap As Boolean
C# | public bool SupportsCubeMap { get; }
Managed C++ | public: __property bool get_SupportsCubeMap();
JScript .NET | public function get SupportsCubeMap() : boolean

Property Value

System.Boolean . Value that is true if cube textures are supported, or false if they are not.

This property is read-only.


TextureCaps.SupportsCubeMapPower2

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsCubeMapPower2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device requires that cube texture maps have dimensions specified as powers of two.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsCubeMapPower2 As Boolean
C# | public bool SupportsCubeMapPower2 { get; }
Managed C++ | public: __property bool get_SupportsCubeMapPower2();
JScript .NET | public function get SupportsCubeMapPower2() : boolean

Property Value

System.Boolean . Value that is true if the device requires cube map dimensions to be a power of two, or false if it does not.

This property is read-only.


TextureCaps.SupportsMipCubeMap

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsMipCubeMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports mipmapped cube textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMipCubeMap As Boolean
C# | public bool SupportsMipCubeMap { get; }
Managed C++ | public: __property bool get_SupportsMipCubeMap();
JScript .NET | public function get SupportsMipCubeMap() : boolean

Property Value

System.Boolean . Value that is true if mipmapped cube textures are supported, or false if they are not.

This property is read-only.


TextureCaps.SupportsMipMap

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsMipMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports mipmapped textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMipMap As Boolean
C# | public bool SupportsMipMap { get; }
Managed C++ | public: __property bool get_SupportsMipMap();
JScript .NET | public function get SupportsMipMap() : boolean

Property Value

System.Boolean . Value that is true if the device supports mipmapped textures, or false if it does not.

This property is read-only.


TextureCaps.SupportsMipVolumeMap

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsMipVolumeMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports mipmapped volume textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMipVolumeMap As Boolean
C# | public bool SupportsMipVolumeMap { get; }
Managed C++ | public: __property bool get_SupportsMipVolumeMap();
JScript .NET | public function get SupportsMipVolumeMap() : boolean

Property Value

System.Boolean . Value that is true if the device supports mipmapped volume textures, or false if it does not.

This property is read-only.


TextureCaps.SupportsNonPower2Conditional

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsNonPower2Conditional Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device conditionally supports the use of 2-D textures with dimensions that are not powers of two.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNonPower2Conditional As Boolean
C# | public bool SupportsNonPower2Conditional { get; }
Managed C++ | public: __property bool get_SupportsNonPower2Conditional();
JScript .NET | public function get SupportsNonPower2Conditional() : boolean

Property Value

System.Boolean . Value that is true if the device conditionally supports dimensions that are not powers of two, or false if it does not.

This property is read-only.

Remarks

A device that exposes this capability can use a texture whose dimensions are not powers of two, provided all of the following requirements are met.

  • The texture-addressing mode for the texture stage is set to TextureAddress.Clamp.
  • Texture wrapping for the texture stage is disabled (that is, RenderStateManager.Wrap0 is set to 0).
  • Mipmapping is not in use (that is, only the magnification filter is in use).
  • Texture formats are not DXT1-5.

A texture that is not a power of two cannot be set at a stage that will be read based on a shader computation (such as the bem, beml, or texm3x3 instructions in pixel shaders versions 1_0 to 1_3). For example, these textures can be used to store bumps that are fed into texture reads, but not the environment maps that are used in texbem, texbeml, or texm3x3spec. This means that a texture with dimensions that are not powers of two cannot be addressed or sampled using texture coordinates computed within the shader. This type of operation is known as a dependent read, and cannot be performed on these types of textures.


TextureCaps.SupportsNoProjectedBumpEnvironment

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsNoProjectedBumpEnvironment Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device does not support a projected bump-environment lookup operation in programmable and fixed-function shaders.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNoProjectedBumpEnvironment As Boolean
C# | public bool SupportsNoProjectedBumpEnvironment { get; }
Managed C++ | public: __property bool get_SupportsNoProjectedBumpEnvironment();
JScript .NET | public function get SupportsNoProjectedBumpEnvironment() : boolean

Property Value

System.Boolean . Value that is true if the device does not support a projected bump-environment lookup operation, or false if it does.

This property is read-only.


TextureCaps.SupportsPerspective

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsPerspective Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether perspective correction texturing is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPerspective As Boolean
C# | public bool SupportsPerspective { get; }
Managed C++ | public: __property bool get_SupportsPerspective();
JScript .NET | public function get SupportsPerspective() : boolean

Property Value

System.Boolean . Value that is true if perspective correction texturing is supported, or false if it is not.

This property is read-only.


TextureCaps.SupportsPower2

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsPower2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports all textures having widths and heights that are specified as powers of two.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPower2 As Boolean
C# | public bool SupportsPower2 { get; }
Managed C++ | public: __property bool get_SupportsPower2();
JScript .NET | public function get SupportsPower2() : boolean

Property Value

System.Boolean . Value that is true if the device supports texture dimensions as powers of two, or false if it does not.

This property is read-only.

Remarks

This requirement does not apply to cube textures or volume textures.


TextureCaps.SupportsProjected

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsProjected Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether TextureTransform.Projected is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsProjected As Boolean
C# | public bool SupportsProjected { get; }
Managed C++ | public: __property bool get_SupportsProjected();
JScript .NET | public function get SupportsProjected() : boolean

Property Value

System.Boolean . Value that is true if TextureTransform.Projected is supported, or false if it is not.

This property is read-only.

Remarks

When applied, the device divides transformed texture coordinates by the last texture coordinate. If this property's capability is present, the projective divide occurs on a per-pixel basis. If the capability is not present but the projective divide needs to occur anyway, the Microsoft® Direct3D® runtime performs it on a per-vertex basis.


TextureCaps.SupportsSquareOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsSquareOnly Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether all textures must be square.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSquareOnly As Boolean
C# | public bool SupportsSquareOnly { get; }
Managed C++ | public: __property bool get_SupportsSquareOnly();
JScript .NET | public function get SupportsSquareOnly() : boolean

Property Value

System.Boolean . Value that is true if all textures are required to be square, or false if they are not.

This property is read-only.


TextureCaps.SupportsTextureRepeatNotScaledBySize

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsTextureRepeatNotScaledBySize Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether texture indices are not scaled by the texture size prior to interpolation.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureRepeatNotScaledBySize As Boolean
C# | public bool SupportsTextureRepeatNotScaledBySize { get; }
Managed C++ | public: __property bool get_SupportsTextureRepeatNotScaledBySize();
JScript .NET | public function get SupportsTextureRepeatNotScaledBySize() : boolean

Property Value

System.Boolean . Value that is true if texture indices are not scaled prior to interpolation, or false if they are.

This property is read-only.


TextureCaps.SupportsVolumeMap

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsVolumeMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports volume textures.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsVolumeMap As Boolean
C# | public bool SupportsVolumeMap { get; }
Managed C++ | public: __property bool get_SupportsVolumeMap();
JScript .NET | public function get SupportsVolumeMap() : boolean

Property Value

System.Boolean . Value that is true if volume textures are supported, or false if they are not.

This property is read-only.


TextureCaps.SupportsVolumeMapPower2

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureCaps.SupportsVolumeMapPower2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device requires that volume texture maps have dimensions that are specified as powers of two.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsVolumeMapPower2 As Boolean
C# | public bool SupportsVolumeMapPower2 { get; }
Managed C++ | public: __property bool get_SupportsVolumeMapPower2();
JScript .NET | public function get SupportsVolumeMapPower2() : boolean

Property Value

System.Boolean . Value that is true if the device requires volume map dimensions to be a power of two, or false if it does not.

This property is read-only.


TextureOperationCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains values that describe the texture operations that the current device supports.

Definition

Visual Basic .NET | Public Structure TextureOperationCaps
C# | public struct TextureOperationCaps
Managed C++ | public __value struct TextureOperationCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAdd | Specifies whether the TextureOperation.Add texture blending operation is supported.
SupportsAddSigned | Specifies whether the TextureOperation.AddSigned texture blending operation is supported.
SupportsAddSigned2X | Specifies whether the TextureOperation.AddSigned2X texture blending operation is supported.
SupportsAddSmooth | Specifies whether the TextureOperation.AddSmooth texture blending operation is supported.
SupportsBlendCurrentAlpha | Specifies whether the TextureOperation.BlendCurrentAlpha texture blending operation is supported.
SupportsBlendDiffuseAlpha | Specifies whether the TextureOperation.BlendDiffuseAlpha texture blending operation is supported.
SupportsBlendFactorAlpha | Specifies whether the TextureOperation.BlendFactorAlpha texture blending operation is supported.
SupportsBlendTextureAlpha | Specifies whether the TextureOperation.BlendTextureAlpha texture blending operation is supported.
SupportsBlendTextureAlphaPM | Specifies whether the TextureOperation.BlendTextureAlphaPM texture blending operation is supported.
SupportsBumpEnvironmentMap | Specifies whether the TextureOperation.BumpEnvironmentMap texture blending operation is supported.
SupportsBumpEnvironmentMapLuminance | Specifies whether the TextureOperation.BumpEnvironmentMapLuminance texture blending operation is supported.
SupportsDisable | Specifies whether the TextureOperation.Disable texture blending operation is supported.
SupportsDotProduct3 | Specifies whether the TextureOperation.DotProduct3 texture blending operation is supported.
SupportsLerp | Specifies whether the TextureOperation.Lerp texture blending operation is supported.
SupportsModulate | Specifies whether the TextureOperation.Modulate texture blending operation is supported.
SupportsModulate2X | Specifies whether the TextureOperation.Modulate2X texture blending operation is supported.
SupportsModulate4X | Specifies whether the TextureOperation.Modulate4X texture blending operation is supported.
SupportsModulateAlphaAddColor | Specifies whether the TextureOperation.ModulateAddColor texture blending operation is supported.
SupportsModulateColorAddAlpha | Specifies whether the TextureOperation.ModulateColorAddAlpha texture blending operation is supported.
SupportsModulateInvAlphaAddColor | Specifies whether the TextureOperation.ModulateInvAlphaAddColor texture blending operation is supported.
SupportsModulateInvColorAddAlpha | Specifies whether the TextureOperation.ModulateInvColorAddAlpha texture blending operation is supported.
SupportsMultiplyAdd | Specifies whether the TextureOperation.MultiplyAdd texture blending operation is supported.
SupportsPreModulate | Specifies whether the TextureOperation.PreModulate texture blending operation is supported.
SupportsSelectArgument1 | Specifies whether the TextureOperation.SelectArgument1 texture blending operation is supported.
SupportsSelectArgument2 | Specifies whether the TextureOperation.SelectArgument2 texture blending operation is supported.
SupportsSubtract | Specifies whether the TextureOperation.Subtract texture blending operation is supported.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureOperationCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


TextureOperationCaps.SupportsAdd

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsAdd Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.Add texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAdd As Boolean
C# | public bool SupportsAdd { get; }
Managed C++ | public: __property bool get_SupportsAdd();
JScript .NET | public function get SupportsAdd() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.Add is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsAddSigned

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsAddSigned Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.AddSigned texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAddSigned As Boolean
C# | public bool SupportsAddSigned { get; }
Managed C++ | public: __property bool get_SupportsAddSigned();
JScript .NET | public function get SupportsAddSigned() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.AddSigned is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsAddSigned2X

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsAddSigned2X Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.AddSigned2X texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAddSigned2X As Boolean
C# | public bool SupportsAddSigned2X { get; }
Managed C++ | public: __property bool get_SupportsAddSigned2X();
JScript .NET | public function get SupportsAddSigned2X() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.AddSigned2X is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsAddSmooth

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsAddSmooth Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.AddSmooth texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsAddSmooth As Boolean
C# | public bool SupportsAddSmooth { get; }
Managed C++ | public: __property bool get_SupportsAddSmooth();
JScript .NET | public function get SupportsAddSmooth() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.AddSmooth is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendCurrentAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsBlendCurrentAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.BlendCurrentAlpha texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlendCurrentAlpha As Boolean
C# | public bool SupportsBlendCurrentAlpha { get; }
Managed C++ | public: __property bool get_SupportsBlendCurrentAlpha();
JScript .NET | public function get SupportsBlendCurrentAlpha() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.BlendCurrentAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendDiffuseAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsBlendDiffuseAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.BlendDiffuseAlpha texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlendDiffuseAlpha As Boolean
C# | public bool SupportsBlendDiffuseAlpha { get; }
Managed C++ | public: __property bool get_SupportsBlendDiffuseAlpha();
JScript .NET | public function get SupportsBlendDiffuseAlpha() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.BlendDiffuseAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendFactorAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsBlendFactorAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.BlendFactorAlpha texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlendFactorAlpha As Boolean
C# | public bool SupportsBlendFactorAlpha { get; }
Managed C++ | public: __property bool get_SupportsBlendFactorAlpha();
JScript .NET | public function get SupportsBlendFactorAlpha() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.BlendFactorAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendTextureAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsBlendTextureAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.BlendTextureAlpha texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlendTextureAlpha As Boolean
C# | public bool SupportsBlendTextureAlpha { get; }
Managed C++ | public: __property bool get_SupportsBlendTextureAlpha();
JScript .NET | public function get SupportsBlendTextureAlpha() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.BlendTextureAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendTextureAlphaPM

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsBlendTextureAlphaPM Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.BlendTextureAlphaPM texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBlendTextureAlphaPM As Boolean
C# | public bool SupportsBlendTextureAlphaPM { get; }
Managed C++ | public: __property bool get_SupportsBlendTextureAlphaPM();
JScript .NET | public function get SupportsBlendTextureAlphaPM() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.BlendTextureAlphaPM is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBumpEnvironmentMap

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsBumpEnvironmentMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.BumpEnvironmentMap texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBumpEnvironmentMap As Boolean
C# | public bool SupportsBumpEnvironmentMap { get; }
Managed C++ | public: __property bool get_SupportsBumpEnvironmentMap();
JScript .NET | public function get SupportsBumpEnvironmentMap() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.BumpEnvironmentMap is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBumpEnvironmentMapLuminance

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsBumpEnvironmentMapLuminance Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.BumpEnvironmentMapLuminance texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsBumpEnvironmentMapLuminance As Boolean
C# | public bool SupportsBumpEnvironmentMapLuminance { get; }
Managed C++ | public: __property bool get_SupportsBumpEnvironmentMapLuminance();
JScript .NET | public function get SupportsBumpEnvironmentMapLuminance() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.BumpEnvironmentMapLuminance is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsDisable

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsDisable Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.Disable texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDisable As Boolean
C# | public bool SupportsDisable { get; }
Managed C++ | public: __property bool get_SupportsDisable();
JScript .NET | public function get SupportsDisable() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.Disable is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsDotProduct3

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsDotProduct3 Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.DotProduct3 texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDotProduct3 As Boolean
C# | public bool SupportsDotProduct3 { get; }
Managed C++ | public: __property bool get_SupportsDotProduct3();
JScript .NET | public function get SupportsDotProduct3() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.DotProduct3 is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsLerp

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsLerp Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.Lerp texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsLerp As Boolean
C# | public bool SupportsLerp { get; }
Managed C++ | public: __property bool get_SupportsLerp();
JScript .NET | public function get SupportsLerp() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.Lerp is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulate

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsModulate Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.Modulate texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsModulate As Boolean
C# | public bool SupportsModulate { get; }
Managed C++ | public: __property bool get_SupportsModulate();
JScript .NET | public function get SupportsModulate() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.Modulate is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulate2X

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsModulate2X Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.Modulate2X texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsModulate2X As Boolean
C# | public bool SupportsModulate2X { get; }
Managed C++ | public: __property bool get_SupportsModulate2X();
JScript .NET | public function get SupportsModulate2X() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.Modulate2X is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulate4X

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsModulate4X Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.Modulate4X texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsModulate4X As Boolean
C# | public bool SupportsModulate4X { get; }
Managed C++ | public: __property bool get_SupportsModulate4X();
JScript .NET | public function get SupportsModulate4X() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.Modulate4X is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateAlphaAddColor

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsModulateAlphaAddColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.ModulateAddColor texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsModulateAlphaAddColor As Boolean
C# | public bool SupportsModulateAlphaAddColor { get; }
Managed C++ | public: __property bool get_SupportsModulateAlphaAddColor();
JScript .NET | public function get SupportsModulateAlphaAddColor() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.ModulateAddColor is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateColorAddAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsModulateColorAddAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.ModulateColorAddAlpha texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsModulateColorAddAlpha As Boolean
C# | public bool SupportsModulateColorAddAlpha { get; }
Managed C++ | public: __property bool get_SupportsModulateColorAddAlpha();
JScript .NET | public function get SupportsModulateColorAddAlpha() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.ModulateColorAddAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateInvAlphaAddColor

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsModulateInvAlphaAddColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.ModulateInvAlphaAddColor texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsModulateInvAlphaAddColor As Boolean
C# | public bool SupportsModulateInvAlphaAddColor { get; }
Managed C++ | public: __property bool get_SupportsModulateInvAlphaAddColor();
JScript .NET | public function get SupportsModulateInvAlphaAddColor() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.ModulateInvAlphaAddColor is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateInvColorAddAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsModulateInvColorAddAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.ModulateInvColorAddAlpha texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsModulateInvColorAddAlpha As Boolean
C# | public bool SupportsModulateInvColorAddAlpha { get; }
Managed C++ | public: __property bool get_SupportsModulateInvColorAddAlpha();
JScript .NET | public function get SupportsModulateInvColorAddAlpha() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.ModulateInvColorAddAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsMultiplyAdd

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsMultiplyAdd Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.MultiplyAdd texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMultiplyAdd As Boolean
C# | public bool SupportsMultiplyAdd { get; }
Managed C++ | public: __property bool get_SupportsMultiplyAdd();
JScript .NET | public function get SupportsMultiplyAdd() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.MultiplyAdd is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsPreModulate

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsPreModulate Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.PreModulate texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPreModulate As Boolean
C# | public bool SupportsPreModulate { get; }
Managed C++ | public: __property bool get_SupportsPreModulate();
JScript .NET | public function get SupportsPreModulate() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.PreModulate is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsSelectArgument1

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsSelectArgument1 Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.SelectArgument1 texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSelectArgument1 As Boolean
C# | public bool SupportsSelectArgument1 { get; }
Managed C++ | public: __property bool get_SupportsSelectArgument1();
JScript .NET | public function get SupportsSelectArgument1() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.SelectArgument1 is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsSelectArgument2

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsSelectArgument2 Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.SelectArgument2 texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSelectArgument2 As Boolean
C# | public bool SupportsSelectArgument2 { get; }
Managed C++ | public: __property bool get_SupportsSelectArgument2();
JScript .NET | public function get SupportsSelectArgument2() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.SelectArgument2 is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsSubtract

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureOperationCaps.SupportsSubtract Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the TextureOperation.Subtract texture blending operation is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsSubtract As Boolean
C# | public bool SupportsSubtract { get; }
Managed C++ | public: __property bool get_SupportsSubtract();
JScript .NET | public function get SupportsSubtract() : boolean

Property Value

System.Boolean . Value that is true if TextureOperation.Subtract is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureRequirements

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRequirements Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains texture creation parameters.

Definition

Visual Basic .NET | Public Structure TextureRequirements
C# | public struct TextureRequirements
Managed C++ | public __value struct TextureRequirements
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
TextureRequirements | Initializes a new instance of the TextureRequirements class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets the desired pixel format.
Height | Retrieves or sets the height for a texture.
NumberMipLevels | Retrieves or sets the number of mipmap levels for a texture.
Width | Retrieves or sets the width for a texture.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextureRequirements.TextureRequirements()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRequirements.TextureRequirements Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TextureRequirements class.

Definition

Visual Basic .NET | Public Sub New()
C# | public TextureRequirements();
Managed C++ | public: TextureRequirements();
JScript .NET | public function TextureRequirements();


TextureRequirements.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRequirements.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


TextureRequirements.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRequirements.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the desired pixel format.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . Value of the Format class that specifies the pixel format to set or retrieve.

This property is read/write.


TextureRequirements.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRequirements.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height for a texture.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer value that represents the height of the texture, in pixels.

This property is read/write.


TextureRequirements.NumberMipLevels

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRequirements.NumberMipLevels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of mipmap levels for a texture.

Definition

Visual Basic .NET | Public Property NumberMipLevels As Integer
C# | public int NumberMipLevels { get; set; }
Managed C++ public: __property int get_NumberMipLevels();
public: __property void set_NumberMipLevels(int);
JScript .NET public function get NumberMipLevels() : int
public function set NumberMipLevels(int);

Property Value

System.Int32 . Integer value that represents the mipmap levels to set or retrieve.

This property is read/write.


TextureRequirements.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

TextureRequirements.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width for a texture.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer value that represents the width of the texture in pixels.

This property is read/write.


TrackDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes an animation track and specifies its weight and speed at a given time.

Definition

Visual Basic .NET | Public Structure TrackDescription
C# | public struct TrackDescription
Managed C++ | public __value struct TrackDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TrackDescription | Initializes a new instance of the TrackDescription class.

Properties

Property | Description
Enable | Retrieves or sets a track's enable/disable parameter.
Position | Retrieves or sets a track's time position in the local time frame of its current animation set.
Priority | Retrieves or sets a track's priority type as defined in PriorityType.
Speed | Retrieves or sets the speed value.
Weight | Retrieves or sets the weight value.

Remarks

The data that this method returns is used to scale and translate animation key frames.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TrackDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


TrackDescription.TrackDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription.TrackDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TrackDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public TrackDescription();
Managed C++ | public: TrackDescription();
JScript .NET | public function TrackDescription();


TrackDescription.Enable

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription.Enable Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a track's enable/disable parameter.

Definition

Visual Basic .NET | Public Property Enable As Boolean
C# | public bool Enable { get; set; }
Managed C++ public: __property bool get_Enable();
public: __property void set_Enable(bool);
JScript .NET public function get Enable() : boolean
public function set Enable(boolean);

Property Value

System.Boolean . Value that is true to enable the track, or false to disable it.

This property is read/write.


TrackDescription.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a track's time position in the local time frame of its current animation set.

Definition

Visual Basic .NET | Public Property Position As Double
C# | public double Position { get; set; }
Managed C++ public: __property double get_Position();
public: __property void set_Position(double);
JScript .NET public function get Position() : double
public function set Position(double);

Property Value

System.Double . Time position of the track.

This property is read/write.


TrackDescription.Priority

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription.Priority Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a track's priority type as defined in PriorityType.

Definition

Visual Basic .NET | Public Property Priority As PriorityType
C# | public PriorityType Priority { get; set; }
Managed C++ public: __property PriorityType get_Priority();
public: __property void set_Priority(PriorityType);
JScript .NET public function get Priority() : PriorityType
public function set Priority(PriorityType);

Property Value

Microsoft.DirectX.Direct3D.PriorityType . Priority type of the track.

This property is read/write.


TrackDescription.Speed

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription.Speed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the speed value.

Definition

Visual Basic .NET | Public Property Speed As Single
C# | public float Speed { get; set; }
Managed C++ public: __property float get_Speed();
public: __property void set_Speed(float);
JScript .NET public function get Speed() : float
public function set Speed(float);

Property Value

System.Single . Speed value.

This property is read/write.

Remarks

This value is used as a multiplier to scale a track's period.


TrackDescription.Weight

Microsoft DirectX 9.0 SDK Update (October 2004)

TrackDescription.Weight Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the weight value.

Definition

Visual Basic .NET | Public Property Weight As Single
C# | public float Weight { get; set; }
Managed C++ public: __property float get_Weight();
public: __property void set_Weight(float);
JScript .NET public function get Weight() : float
public function set Weight(float);

Property Value

System.Single . Weight value.

This property is read/write.

Remarks

The weight determines how much of a track to blend with other tracks in the mixer.


CustomVertex.Transformed

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains transformed vertices.

Definition

Visual Basic .NET | Public Structure Transformed
C# | public struct Transformed
Managed C++ | public __value struct Transformed
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
Transformed | Initializes a new instance of the CustomVertex.Transformed class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.Transformed structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.Transformed.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.Transformed.Transformed

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Transformed Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.Transformed class.

Overload List

public Transformed(float, float, float, float);
public Transformed(Vector4);


CustomVertex.Transformed.Transformed(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Transformed Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.Transformed class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Vector4 _
)
C# public Transformed(
Vector4 value
);
Managed C++ public: Transformed(
Vector4 value
);
JScript .NET public function Transformed(
value : Vector4
);

Parameters

value Microsoft.DirectX.Vector4. A Vector4 object that contains the position.


CustomVertex.Transformed.Transformed(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Transformed Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.Transformed class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single _
)
C# public Transformed(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue
);
Managed C++ public: Transformed(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue
);
JScript .NET public function Transformed(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
rhwvalue | System.Single. Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.


CustomVertex.Transformed.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the transformed position.

Definition

Visual Basic .NET | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
Managed C++ public: __property Vector4 get_Position();
public: __property void set_Position(Vector4);
JScript .NET public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4 . A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.Transformed.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.Transformed structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.Transformed.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.Transformed.Rhw

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Rhw Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic .NET | Public Rhw As Single
C# | public Single Rhw;
Managed C++ | public: Single Rhw;
JScript .NET | public var Rhw : Single

Field Value

System.Single . Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.Transformed.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.Transformed.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.Transformed.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.Transformed.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.TransformedColored

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains transformed vertices and color information.

Definition

Visual Basic .NET | Public Structure TransformedColored
C# | public struct TransformedColored
Managed C++ | public __value struct TransformedColored
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TransformedColored | Initializes a new instance of the CustomVertex.TransformedColored class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.TransformedColored structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.TransformedColored.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.TransformedColored.TransformedColored

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.TransformedColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedColored class.

Overload List

public TransformedColored(float, float, float, float, int);
public TransformedColored(Vector4, int);


CustomVertex.TransformedColored.TransformedColored(Vector4,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.TransformedColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedColored class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Vector4, _
ByVal c As Integer _
)
C# public TransformedColored(
Vector4 value,
int c
);
Managed C++ public: TransformedColored(
Vector4 value,
int c
);
JScript .NET public function TransformedColored(
value : Vector4,
c : int
);

Parameters

value | Microsoft.DirectX.Vector4. A Vector4 object that contains the position.
c | System.Int32. Integer that represents the vertex color value.


CustomVertex.TransformedColored.TransformedColored(Single,Single,Single,Single,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.TransformedColored Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedColored class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single, _
ByVal c As Integer _
)
C# public TransformedColored(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c
);
Managed C++ public: TransformedColored(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c
);
JScript .NET public function TransformedColored(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float,
c : int
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
rhwvalue | System.Single. Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.
c | System.Int32. Integer that represents the vertex color value.


CustomVertex.TransformedColored.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the transformed position.

Definition

Visual Basic .NET | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
Managed C++ public: __property Vector4 get_Position();
public: __property void set_Position(Vector4);
JScript .NET public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4 . A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.TransformedColored.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.TransformedColored structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.TransformedColored.Color

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.Color Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex color.

Definition

Visual Basic .NET | Public Color As Int32
C# | public Int32 Color;
Managed C++ | public: Int32 Color;
JScript .NET | public var Color : Int32

Field Value

System.Int32 . Integer that represents the vertex color.

This field is read/write.


CustomVertex.TransformedColored.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.TransformedColored.Rhw

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.Rhw Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic .NET | Public Rhw As Single
C# | public Single Rhw;
Managed C++ | public: Single Rhw;
JScript .NET | public var Rhw : Single

Field Value

System.Single . Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.TransformedColored.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.TransformedColored.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.TransformedColored.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColored.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains transformed vertices, color, and one set of texture coordinates.

Definition

Visual Basic .NET | Public Structure TransformedColoredTextured
C# | public struct TransformedColoredTextured
Managed C++ | public __value struct TransformedColoredTextured
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TransformedColoredTextured | Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.TransformedColoredTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.TransformedColoredTextured.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.TransformedColoredTextured.TransformedColoredTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.TransformedColoredTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Overload List

public TransformedColoredTextured(float, float, float, float, int, float, float);
public TransformedColoredTextured(Vector4, int, float, float);


CustomVertex.TransformedColoredTextured.TransformedColoredTextured(Vector4,Int32,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.TransformedColoredTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Vector4, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedColoredTextured(
Vector4 value,
int c,
float u,
float v
);
Managed C++ public: TransformedColoredTextured(
Vector4 value,
int c,
float u,
float v
);
JScript .NET public function TransformedColoredTextured(
value : Vector4,
c : int,
u : float,
v : float
);

Parameters

value | Microsoft.DirectX.Vector4. A Vector4 object that contains the position.
c | System.Int32. Integer that represents the vertex color value.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedColoredTextured.TransformedColoredTextured(Single,Single,Single,Single,Int32,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.TransformedColoredTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedColoredTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c,
float u,
float v
);
Managed C++ public: TransformedColoredTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c,
float u,
float v
);
JScript .NET public function TransformedColoredTextured(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float,
c : int,
u : float,
v : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
rhwvalue | System.Single. Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.
c | System.Int32. Integer that represents the vertex color value.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedColoredTextured.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the transformed position.

Definition

Visual Basic .NET | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
Managed C++ public: __property Vector4 get_Position();
public: __property void set_Position(Vector4);
JScript .NET public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4 . A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.TransformedColoredTextured.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.TransformedColoredTextured structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.TransformedColoredTextured.Color

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Color Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the vertex color.

Definition

Visual Basic .NET | Public Color As Int32
C# | public Int32 Color;
Managed C++ | public: Int32 Color;
JScript .NET | public var Color : Int32

Field Value

System.Int32 . Integer that represents the vertex color.

This field is read/write.


CustomVertex.TransformedColoredTextured.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.TransformedColoredTextured.Rhw

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Rhw Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic .NET | Public Rhw As Single
C# | public Single Rhw;
Managed C++ | public: Single Rhw;
JScript .NET | public var Rhw : Single

Field Value

System.Single . Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured.Tu

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Tu Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic .NET | Public Tu As Single
C# | public Single Tu;
Managed C++ | public: Single Tu;
JScript .NET | public var Tu : Single

Field Value

System.Single . Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedColoredTextured.Tv

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Tv Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic .NET | Public Tv As Single
C# | public Single Tv;
Managed C++ | public: Single Tv;
JScript .NET | public var Tv : Single

Field Value

System.Single . Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedColoredTextured.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedColoredTextured.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.TransformedTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a custom vertex format structure that contains transformed vertices and one set of texture coordinates.

Definition

Visual Basic .NET | Public Structure TransformedTextured
C# | public struct TransformedTextured
Managed C++ | public __value struct TransformedTextured
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TransformedTextured | Initializes a new instance of the CustomVertex.TransformedTextured class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic .NET) StrideSize | Retrieves the size of the CustomVertex.TransformedTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CustomVertex Class


CustomVertex.TransformedTextured.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomVertex.TransformedTextured.TransformedTextured

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.TransformedTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedTextured class.

Overload List

public TransformedTextured(float, float, float, float, float, float);
public TransformedTextured(Vector4, float, float);


CustomVertex.TransformedTextured.TransformedTextured(Vector4,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.TransformedTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Vector4, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedTextured(
Vector4 value,
float u,
float v
);
Managed C++ public: TransformedTextured(
Vector4 value,
float u,
float v
);
JScript .NET public function TransformedTextured(
value : Vector4,
u : float,
v : float
);

Parameters

value | Microsoft.DirectX.Vector4. A Vector4 object that contains the position.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedTextured.TransformedTextured(Single,Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.TransformedTextured Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CustomVertex.TransformedTextured class.

Definition

Visual Basic .NET Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
float u,
float v
);
Managed C++ public: TransformedTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
float u,
float v
);
JScript .NET public function TransformedTextured(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float,
u : float,
v : float
);

Parameters

xvalue | System.Single. Floating-point value that represents the x coordinate of the position.
yvalue | System.Single. Floating-point value that represents the y coordinate of the position.
zvalue | System.Single. Floating-point value that represents the z coordinate of the position.
rhwvalue | System.Single. Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.
u | System.Single. Floating-point value that represents the u component of the texture coordinate.
v | System.Single. Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedTextured.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the transformed position.

Definition

Visual Basic .NET | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
Managed C++ public: __property Vector4 get_Position();
public: __property void set_Position(Vector4);
JScript .NET public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4 . A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.TransformedTextured.StrideSize

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.StrideSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the CustomVertex.TransformedTextured structure.

Definition

Visual Basic .NET | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
Managed C++ | public: __property static int get_StrideSize();
JScript .NET | public static function get StrideSize() : int

Property Value

System.Int32 . Size of the structure, in bytes.

This property is read-only.


CustomVertex.TransformedTextured.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.Format Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic .NET | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
Managed C++ | public: static VertexFormats Format;
JScript .NET | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats . A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.TransformedTextured.Rhw

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.Rhw Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic .NET | Public Rhw As Single
C# | public Single Rhw;
Managed C++ | public: Single Rhw;
JScript .NET | public var Rhw : Single

Field Value

System.Single . Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.TransformedTextured.Tu

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.Tu Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic .NET | Public Tu As Single
C# | public Single Tu;
Managed C++ | public: Single Tu;
JScript .NET | public var Tu : Single

Field Value

System.Single . Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedTextured.Tv

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.Tv Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic .NET | Public Tv As Single
C# | public Single Tv;
Managed C++ | public: Single Tv;
JScript .NET | public var Tv : Single

Field Value

System.Single . Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedTextured.X

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the position.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.TransformedTextured.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the position.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.TransformedTextured.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomVertex.TransformedTextured.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the position.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . Floating-point value that represents the z component of the position.

This field is read/write.


TrianglePatchInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

TrianglePatchInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a triangular high-order patch.

Definition

Visual Basic .NET | Public Structure TrianglePatchInformation
C# | public struct TrianglePatchInformation
Managed C++ | public __value struct TrianglePatchInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TrianglePatchInformation | Initializes a new instance of the TrianglePatchInformation class.

Properties

Property | Description
BasisType | Retrieves or sets a value that defines the basis type for the triangular high-order patch.
Degree | Retrieves or sets a value that defines the degree type for the triangular high-order patch.
NumberVertices | Retrieves or sets the number of vertices for the triangular high-order patch.
StartVertexOffset | Retrieves or sets the starting vertex offset, in number of vertices.

Remarks

The following diagram identifies the vertex order and segment numbers for a cubic Bezier triangle patch. The vertex order determines the segment numbers used by Device.DrawTrianglePatch. The offset is the number of bytes to the first triangle patch vertex in the vertex buffer.

Triangle Patch Info

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TrianglePatchInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

TrianglePatchInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


TrianglePatchInformation.TrianglePatchInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

TrianglePatchInformation.TrianglePatchInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the TrianglePatchInformation class.

Definition

Visual Basic .NET | Public Sub New()
C# | public TrianglePatchInformation();
Managed C++ | public: TrianglePatchInformation();
JScript .NET | public function TrianglePatchInformation();


TrianglePatchInformation.BasisType

Microsoft DirectX 9.0 SDK Update (October 2004)

TrianglePatchInformation.BasisType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that defines the basis type for the triangular high-order patch.

Definition

Visual Basic .NET | Public Property BasisType As BasisType
C# | public BasisType BasisType { get; set; }
Managed C++ public: __property BasisType get_BasisType();
public: __property void set_BasisType(BasisType);
JScript .NET public function get BasisType() : BasisType
public function set BasisType(BasisType);

Property Value

Microsoft.DirectX.Direct3D.BasisType . Value from the BasisType enumeration to set or retrieve.

This property is read/write.

Remarks

The only valid value for this member is Basis.Bezier.


TrianglePatchInformation.Degree

Microsoft DirectX 9.0 SDK Update (October 2004)

TrianglePatchInformation.Degree Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that defines the degree type for the triangular high-order patch.

Definition

Visual Basic .NET | Public Property Degree As DegreeType
C# | public DegreeType Degree { get; set; }
Managed C++ public: __property DegreeType get_Degree();
public: __property void set_Degree(DegreeType);
JScript .NET public function get Degree() : DegreeType
public function set Degree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType . Value from the DegreeType enumeration to set or retrieve.

This property is read/write.

Remarks

The following values define the degree type for the triangular high-order patch.

Value | Number of vertices
Cubic | 10
Linear | 3
Quadratic | Not supported.
Quintic | 21


TrianglePatchInformation.NumberVertices

Microsoft DirectX 9.0 SDK Update (October 2004)

TrianglePatchInformation.NumberVertices Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of vertices for the triangular high-order patch.

Definition

Visual Basic .NET | Public Property NumberVertices As Integer
C# | public int NumberVertices { get; set; }
Managed C++ public: __property int get_NumberVertices();
public: __property void set_NumberVertices(int);
JScript .NET public function get NumberVertices() : int
public function set NumberVertices(int);

Property Value

System.Int32 . Integer value that represents the number of vertices to set or retrieve.

This property is read/write.


TrianglePatchInformation.StartVertexOffset

Microsoft DirectX 9.0 SDK Update (October 2004)

TrianglePatchInformation.StartVertexOffset Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the starting vertex offset, in number of vertices.

Definition

Visual Basic .NET | Public Property StartVertexOffset As Integer
C# | public int StartVertexOffset { get; set; }
Managed C++ public: __property int get_StartVertexOffset();
public: __property void set_StartVertexOffset(int);
JScript .NET public function get StartVertexOffset() : int
public function set StartVertexOffset(int);

Property Value

System.Int32 . Integer value that represents the number of vertices that specify the starting vertex offset.

This property is read/write.


ValidateDeviceParams

Microsoft DirectX 9.0 SDK Update (October 2004)

ValidateDeviceParams Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the number of passes and the result code returned from a ValidateDevice call.

Definition

Visual Basic .NET | Public Structure ValidateDeviceParams
C# | public struct ValidateDeviceParams
Managed C++ | public __value struct ValidateDeviceParams
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
ValidateDeviceParams | Initializes a new instance of the ValidateDeviceParams class.

Properties

Property | Description
Passes | Retrieves the number of rendering passes needed to complete the desired effect through multipass rendering.
Result | Retrieves the result code of a validation.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ValidateDeviceParams.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ValidateDeviceParams.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ValidateDeviceParams.ValidateDeviceParams()

Microsoft DirectX 9.0 SDK Update (October 2004)

ValidateDeviceParams.ValidateDeviceParams Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ValidateDeviceParams class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ValidateDeviceParams();
Managed C++ | public: ValidateDeviceParams();
JScript .NET | public function ValidateDeviceParams();


ValidateDeviceParams.Passes

Microsoft DirectX 9.0 SDK Update (October 2004)

ValidateDeviceParams.Passes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of rendering passes needed to complete the desired effect through multipass rendering.

Definition

Visual Basic .NET | Public ReadOnly Property Passes As Integer
C# | public int Passes { get; }
Managed C++ | public: __property int get_Passes();
JScript .NET | public function get Passes() : int

Property Value

System.Int32 . Integer that represents the number of rendering passes to retrieve.

This property is read-only.


ValidateDeviceParams.Result

Microsoft DirectX 9.0 SDK Update (October 2004)

ValidateDeviceParams.Result Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the result code of a validation.

Definition

Visual Basic .NET | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
Managed C++ | public: __property ResultCode get_Result();
JScript .NET | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.Direct3D.ResultCode . Value of the ResultCode enumeration to retrieve.

This property is read-only.


VertexBufferDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a vertex buffer.

Definition

Visual Basic .NET | Public Structure VertexBufferDescription
C# | public struct VertexBufferDescription
Managed C++ | public __value struct VertexBufferDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexBufferDescription | Initializes a new instance of the VertexBufferDescription class.

Properties

Property | Description
Format | Retrieves or sets a member of the Format enumeration that describes the surface format of the vertex buffer data.
Pool | Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current vertex buffer.
Size | Retrieves or sets the size of the vertex buffer.
Type | Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a vertex buffer.
Usage | Retrieves or sets a combination of Usage enumeration values.
VertexFormat | Retrieves or sets a combination of VertexFormats enumeration values that describe the vertex format of the vertices in the current buffer.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexBufferDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VertexBufferDescription.VertexBufferDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.VertexBufferDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexBufferDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public VertexBufferDescription();
Managed C++ | public: VertexBufferDescription();
JScript .NET | public function VertexBufferDescription();


VertexBufferDescription.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a member of the Format enumeration that describes the surface format of the vertex buffer data.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . Value of the Format enumeration to set or retrieve.

This property is read/write.


VertexBufferDescription.Pool

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.Pool Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current vertex buffer.

Definition

Visual Basic .NET | Public Property Pool As Pool
C# | public Pool Pool { get; set; }
Managed C++ public: __property Pool get_Pool();
public: __property void set_Pool(Pool);
JScript .NET public function get Pool() : Pool
public function set Pool(Pool);

Property Value

Microsoft.DirectX.Direct3D.Pool . Value of the Pool enumeration to set or retrieve.

This property is read/write.


VertexBufferDescription.Size

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.Size Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the size of the vertex buffer.

Definition

Visual Basic .NET | Public Property Size As Integer
C# | public int Size { get; set; }
Managed C++ public: __property int get_Size();
public: __property void set_Size(int);
JScript .NET public function get Size() : int
public function set Size(int);

Property Value

System.Int32 . Integer value that specifies the number of bytes in the vertex buffer.

This property is read/write.


VertexBufferDescription.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a vertex buffer.

Definition

Visual Basic .NET | Public Property Type As ResourceType
C# | public ResourceType Type { get; set; }
Managed C++ public: __property ResourceType get_Type();
public: __property void set_Type(ResourceType);
JScript .NET public function get Type() : ResourceType
public function set Type(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType . Value of the ResourceType enumeration to set or retrieve.

This property is read/write.


VertexBufferDescription.Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.Usage Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a combination of Usage enumeration values.

Definition

Visual Basic .NET | Public Property Usage As Usage
C# | public Usage Usage { get; set; }
Managed C++ public: __property Usage get_Usage();
public: __property void set_Usage(Usage);
JScript .NET public function get Usage() : Usage
public function set Usage(Usage);

Property Value

Microsoft.DirectX.Direct3D.Usage . Values of the Usage enumeration to set or retrieve.

This property is read/write.


VertexBufferDescription.VertexFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexBufferDescription.VertexFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a combination of VertexFormats enumeration values that describe the vertex format of the vertices in the current buffer.

Definition

Visual Basic .NET | Public Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; set; }
Managed C++ public: __property VertexFormats get_VertexFormat();
public: __property void set_VertexFormat(VertexFormats);
JScript .NET public function get VertexFormat() : VertexFormats
public function set VertexFormat(VertexFormats);

Property Value

Microsoft.DirectX.Direct3D.VertexFormats . Values of the VertexFormats enumeration to set or retrieve.

This property is read/write.


VertexCache

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexCache Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Defines vertex cache optimization hints.

Definition

Visual Basic .NET | Public Structure VertexCache
C# | public struct VertexCache
Managed C++ | public __value struct VertexCache
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexCache | Initializes a new instance of the VertexCache class.

Properties

Property | Description
CacheSize | Retrieves the cache size, which is used as a target for optimization.
MagicNumber | Retrieves a value that is used by internal optimization methods to determine when to restart strips.
OptimizationMethod | Retrieves the optimization method.
Pattern | Retrieves the bit pattern of the vertex cache.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexCache.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexCache.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VertexCache.VertexCache()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexCache.VertexCache Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexCache class.

Definition

Visual Basic .NET | Public Sub New()
C# | public VertexCache();
Managed C++ | public: VertexCache();
JScript .NET | public function VertexCache();


VertexCache.CacheSize

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexCache.CacheSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the cache size, which is used as a target for optimization.

Definition

Visual Basic .NET | Public ReadOnly Property CacheSize As Integer
C# | public int CacheSize { get; }
Managed C++ | public: __property int get_CacheSize();
JScript .NET | public function get CacheSize() : int

Property Value

System.Int32 . Cache size for which to optimize.

This property is read-only.

Remarks

The cache size is required only if OptimizationMethod is set to 1.


VertexCache.MagicNumber

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexCache.MagicNumber Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that is used by internal optimization methods to determine when to restart strips.

Definition

Visual Basic .NET | Public ReadOnly Property MagicNumber As Integer
C# | public int MagicNumber { get; }
Managed C++ | public: __property int get_MagicNumber();
JScript .NET | public function get MagicNumber() : int

Property Value

System.Int32 . Value that determines when to restart strips.

This property is read-only.

Remarks

This value cannot be set or modified by a user. It is required only if OptimizationMethod is set to 1.


VertexCache.OptimizationMethod

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexCache.OptimizationMethod Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the optimization method.

Definition

Visual Basic .NET | Public ReadOnly Property OptimizationMethod As Integer
C# | public int OptimizationMethod { get; }
Managed C++ | public: __property int get_OptimizationMethod();
JScript .NET | public function get OptimizationMethod() : int

Property Value

System.Int32 . Value that is 0 to get the longest strips, or 1 to optimize the vertex cache.

This property is read-only.


VertexCache.Pattern

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexCache.Pattern Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the bit pattern of the vertex cache.

Definition

Visual Basic .NET | Public ReadOnly Property Pattern As Integer
C# | public int Pattern { get; }
Managed C++ | public: __property int get_Pattern();
JScript .NET | public function get Pattern() : int

Property Value

System.Int32 . Value in the four-character code (FOURCC) ('C', 'A', 'C', 'H') format that specifies the bit pattern.

This property is read-only.


VertexElement

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Vertex Declaration

Defines input vertex data to the pipeline.

Definition

Visual Basic .NET | Public Structure VertexElement
C# | public struct VertexElement
Managed C++ | public __value struct VertexElement
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) VertexDeclarationEnd | Retrieves a VertexElement structure that is considered to be the end of vertex shader declaration.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexElement | Initializes a new instance of the VertexElement class.

Properties

Property | Description
DeclarationMethod | Retrieves or sets the tessellator processing method.
DeclarationType | Retrieves or sets the data type that defines the data size for the vertex element.
DeclarationUsage | Retrieves or sets one or more usage values that define the intended use of the vertex data.
Offset | Retrieves or sets the offset (if any) from the beginning of the stream to the beginning of the vertex data.
Stream | Retrieves or sets the stream number (or index) to use.
UsageIndex | Modifies the usage data to allow the user to specify multiple usage types.

How Do I...?

Create a Vertex Declaration

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexElement.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VertexElement.VertexElement(Int16,Int16,DeclarationType,DeclarationMethod,DeclarationUsage,Byte)

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.VertexElement Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexElement class.

Definition

Visual Basic .NET Public Sub New( _
ByVal stream As Short, _
ByVal offset As Short, _
ByVal declType As DeclarationType, _
ByVal declMethod As DeclarationMethod, _
ByVal declUsage As DeclarationUsage, _
ByVal usageIndex As Byte _
)
C# public VertexElement(
short stream,
short offset,
DeclarationType declType,
DeclarationMethod declMethod,
DeclarationUsage declUsage,
byte usageIndex
);
Managed C++ public: VertexElement(
short stream,
short offset,
DeclarationType declType,
DeclarationMethod declMethod,
DeclarationUsage declUsage,
Byte usageIndex
);
JScript .NET public function VertexElement(
stream : short,
offset : short,
declType : DeclarationType,
declMethod : DeclarationMethod,
declUsage : DeclarationUsage,
usageIndex : byte
);

Parameters

stream | System.Int16. Stream number (or index) to use.
offset | System.Int16. Offset (if any) from the beginning of the stream to the beginning of the vertex data.
declType | Microsoft.DirectX.Direct3D.DeclarationType. A DeclarationType enumeration value specifying one of several predefined types that define the vertex data size.
declMethod | Microsoft.DirectX.Direct3D.DeclarationMethod. A DeclarationMethod enumeration value that specifies the tessellator processing method. These methods determine how the tessellator interprets/operates on the vertex data.
declUsage | Microsoft.DirectX.Direct3D.DeclarationUsage. A DeclarationUsage enumeration value that defines the intended use of the vertex data.
usageIndex | System.Byte. Modifies the usage data to allow the user to specify multiple usage types.

Remarks

Vertex data is defined using an array of VertexElement structures. The size of the array includes the VertexDeclarationEnd field, which ends the declaration. The inclusion of this field means that the array count is actually higher than the number of valid vertex elements by one.


VertexElement.DeclarationMethod

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.DeclarationMethod Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the tessellator processing method.

Definition

Visual Basic .NET | Public Property DeclarationMethod As DeclarationMethod
C# | public DeclarationMethod DeclarationMethod { get; set; }
Managed C++ public: __property DeclarationMethod get_DeclarationMethod();
public: __property void set_DeclarationMethod(DeclarationMethod);
JScript .NET public function get DeclarationMethod() : DeclarationMethod
public function set DeclarationMethod(DeclarationMethod);

Property Value

Microsoft.DirectX.Direct3D.DeclarationMethod . Value of the DeclarationMethod enumeration that specifies the tessellator processing method to set or retrieve.

This property is read/write.


VertexElement.DeclarationType

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.DeclarationType Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the data type that defines the data size for the vertex element.

Definition

Visual Basic .NET | Public Property DeclarationType As DeclarationType
C# | public DeclarationType DeclarationType { get; set; }
Managed C++ public: __property DeclarationType get_DeclarationType();
public: __property void set_DeclarationType(DeclarationType);
JScript .NET public function get DeclarationType() : DeclarationType
public function set DeclarationType(DeclarationType);

Property Value

Microsoft.DirectX.Direct3D.DeclarationType . Value of the DeclarationType enumeration to set or retrieve.

This property is read/write.


VertexElement.DeclarationUsage

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.DeclarationUsage Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets one or more usage values that define the intended use of the vertex data.

Definition

Visual Basic .NET | Public Property DeclarationUsage As DeclarationUsage
C# | public DeclarationUsage DeclarationUsage { get; set; }
Managed C++ public: __property DeclarationUsage get_DeclarationUsage();
public: __property void set_DeclarationUsage(DeclarationUsage);
JScript .NET public function get DeclarationUsage() : DeclarationUsage
public function set DeclarationUsage(DeclarationUsage);

Property Value

Microsoft.DirectX.Direct3D.DeclarationUsage . Value of the DeclarationUsage enumeration to set or retrieve.

This property is read/write.


VertexElement.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the offset (if any) from the beginning of the stream to the beginning of the vertex data.

Definition

Visual Basic .NET | Public Property Offset As Short
C# | public short Offset { get; set; }
Managed C++ public: __property short get_Offset();
public: __property void set_Offset(short);
JScript .NET public function get Offset() : short
public function set Offset(short);

Property Value

System.Int16 . Offset, in bytes, to the start of the vertex data.

This property is read/write.


VertexElement.Stream

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.Stream Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the stream number (or index) to use.

Definition

Visual Basic .NET | Public Property Stream As Short
C# | public short Stream { get; set; }
Managed C++ public: __property short get_Stream();
public: __property void set_Stream(short);
JScript .NET public function get Stream() : short
public function set Stream(short);

Property Value

System.Int16 . Stream number (or index) to use.

This property is read/write.


VertexElement.UsageIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.UsageIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

Modifies the usage data to allow the user to specify multiple usage types.

Definition

Visual Basic .NET | Public Property UsageIndex As Byte
C# | public byte UsageIndex { get; set; }
Managed C++ public: __property Byte get_UsageIndex();
public: __property void set_UsageIndex(Byte);
JScript .NET public function get UsageIndex() : byte
public function set UsageIndex(byte);

Property Value

System.Byte . Byte that represents the usage index.

This property is read/write.

Remarks

The UsageIndex structure is used in conjunction with VertexElement.DeclarationUsage to specify the semantic of a vertex element.


VertexElement.VertexDeclarationEnd

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexElement.VertexDeclarationEnd Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Create a Vertex Declaration

Retrieves a VertexElement structure that is considered to be the end of vertex shader declaration.

Definition

Visual Basic .NET | Public Shared VertexDeclarationEnd As VertexElement
C# | public static VertexElement VertexDeclarationEnd;
Managed C++ | public: static VertexElement VertexDeclarationEnd;
JScript .NET | public static var VertexDeclarationEnd : VertexElement

Field Value

Microsoft.DirectX.Direct3D.VertexElement . A VertexElement structure that marks the end of vertex shader declaration.

This field is read-only.

Remarks

Vertex data is defined using an array of VertexElement structures. The size of the array includes the VertexDeclarationEnd field, which ends the declaration. The inclusion of this field means that the array count is actually higher than the number of valid vertex elements by one.

How Do I...?

Create a Vertex Declaration

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);


VertexFormatCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexFormatCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the flexible vertex format (FVF) capabilities supported by a device.

Definition

Visual Basic .NET | Public Structure VertexFormatCaps
C# | public struct VertexFormatCaps
Managed C++ | public __value struct VertexFormatCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDoNotStripElements | Specifies whether a device supports keeping vertex elements or stripping them if they are not needed for rendering.
SupportsPointSize | Specifies whether the vertex point size is determined by RenderStateManager.PointSize or the vertex data.
SupportsTextureCoordinateCountMask | Specifies whether the device supports the texture coordinate count mask.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexFormatCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexFormatCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VertexFormatCaps.SupportsDoNotStripElements

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexFormatCaps.SupportsDoNotStripElements Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a device supports keeping vertex elements or stripping them if they are not needed for rendering.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDoNotStripElements As Boolean
C# | public bool SupportsDoNotStripElements { get; }
Managed C++ | public: __property bool get_SupportsDoNotStripElements();
JScript .NET | public function get SupportsDoNotStripElements() : boolean

Property Value

System.Boolean . Value that is true if the device supports keeping vertex elements, or false if it supports stripping vertex elements.

This property is read-only.

Remarks

It is preferable that vertex elements not be stripped. That is, if the vertex format contains elements that are not used with the current render states, there is no need to regenerate the vertices. If this capability flag is not present, stripping extraneous elements from the vertex format results in better performance.


VertexFormatCaps.SupportsPointSize

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexFormatCaps.SupportsPointSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the vertex point size is determined by RenderStateManager.PointSize or the vertex data.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPointSize As Boolean
C# | public bool SupportsPointSize { get; }
Managed C++ | public: __property bool get_SupportsPointSize();
JScript .NET | public function get SupportsPointSize() : boolean

Property Value

System.Boolean . Value that is true if the point size is determined by the vertex data, or false if it is determined by RenderStateManager.PointSize.

This property is read-only.

Remarks

If the application provides point size in both the render state and the flexible vertex format (FVF) data, the vertex data overrides the render-state data.


VertexFormatCaps.SupportsTextureCoordinateCountMask

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexFormatCaps.SupportsTextureCoordinateCountMask Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the device supports the texture coordinate count mask.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureCoordinateCountMask As Boolean
C# | public bool SupportsTextureCoordinateCountMask { get; }
Managed C++ | public: __property bool get_SupportsTextureCoordinateCountMask();
JScript .NET | public function get SupportsTextureCoordinateCountMask() : boolean

Property Value

System.Boolean . Value that is true if the device supports the texture coordinate count mask, or false if it does not.

This property is read-only.


VertexProcessingCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes vertex processing capabilities.

Definition

Visual Basic .NET | Public Structure VertexProcessingCaps
C# | public struct VertexProcessingCaps
Managed C++ | public __value struct VertexProcessingCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDirectionalLights | Specifies whether directional lights are supported on a device.
SupportsLocalViewer | Specifies whether a device supports the local viewer mode.
SupportsMaterialSource | Specifies whether a device can perform Microsoft® DirectX® 7.0 colormaterialsource operations.
SupportsNoTextureGenerationNonLocalViewer | Specifies whether a device supports texture generation in non-local viewer mode.
SupportsPositionalLights | Specifies whether positional lights, including point and spot, are supported on a device.
SupportsTextureGeneration | Specifies whether a device supports texture generation.
SupportsTextureGenerationSphereMap | Specifies whether a device supports texture generation for sphere maps.
SupportsTweening | Specifies whether a device supports vertex tweening.

Remarks

For a given physical device, these capabilities might vary across Device objects, depending on the parameters supplied to the Device constructor.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexProcessingCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VertexProcessingCaps.SupportsDirectionalLights

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsDirectionalLights Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether directional lights are supported on a device.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsDirectionalLights As Boolean
C# | public bool SupportsDirectionalLights { get; }
Managed C++ | public: __property bool get_SupportsDirectionalLights();
JScript .NET | public function get SupportsDirectionalLights() : boolean

Property Value

System.Boolean . Value that is true if directional lights are supported, or false if they are not.

This property is read-only.


VertexProcessingCaps.SupportsLocalViewer

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsLocalViewer Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a device supports the local viewer mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsLocalViewer As Boolean
C# | public bool SupportsLocalViewer { get; }
Managed C++ | public: __property bool get_SupportsLocalViewer();
JScript .NET | public function get SupportsLocalViewer() : boolean

Property Value

System.Boolean . Value that is true if local viewer is supported, or false if it is not.

This property is read-only.


VertexProcessingCaps.SupportsMaterialSource

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsMaterialSource Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a device can perform Microsoft® DirectX® 7.0 colormaterialsource operations.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsMaterialSource As Boolean
C# | public bool SupportsMaterialSource { get; }
Managed C++ | public: __property bool get_SupportsMaterialSource();
JScript .NET | public function get SupportsMaterialSource() : boolean

Property Value

System.Boolean . Value that is true if colormaterialsource operations are supported, or false if they are not.

This property is read-only.


VertexProcessingCaps.SupportsNoTextureGenerationNonLocalViewer

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsNoTextureGenerationNonLocalViewer Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a device supports texture generation in non-local viewer mode.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsNoTextureGenerationNonLocalViewer As Boolean
C# | public bool SupportsNoTextureGenerationNonLocalViewer { get; }
Managed C++ | public: __property bool get_SupportsNoTextureGenerationNonLocalViewer();
JScript .NET | public function get SupportsNoTextureGenerationNonLocalViewer() : boolean

Property Value

System.Boolean . Value that is true if the device does not support texture generation in non-local viewer mode, or false if it does.

This property is read-only.


VertexProcessingCaps.SupportsPositionalLights

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsPositionalLights Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether positional lights, including point and spot, are supported on a device.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPositionalLights As Boolean
C# | public bool SupportsPositionalLights { get; }
Managed C++ | public: __property bool get_SupportsPositionalLights();
JScript .NET | public function get SupportsPositionalLights() : boolean

Property Value

System.Boolean . Value that is true if positional lights are supported, or false if they are not.

This property is read-only.


VertexProcessingCaps.SupportsTextureGeneration

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsTextureGeneration Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a device supports texture generation.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureGeneration As Boolean
C# | public bool SupportsTextureGeneration { get; }
Managed C++ | public: __property bool get_SupportsTextureGeneration();
JScript .NET | public function get SupportsTextureGeneration() : boolean

Property Value

System.Boolean . Value that is true if texture generation is supported, or false if it is not.

This property is read-only.


VertexProcessingCaps.SupportsTextureGenerationSphereMap

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsTextureGenerationSphereMap Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a device supports texture generation for sphere maps.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTextureGenerationSphereMap As Boolean
C# | public bool SupportsTextureGenerationSphereMap { get; }
Managed C++ | public: __property bool get_SupportsTextureGenerationSphereMap();
JScript .NET | public function get SupportsTextureGenerationSphereMap() : boolean

Property Value

System.Boolean . Value that is true if texture generation for sphere maps is supported, or false if it is not.

This property is read-only.


VertexProcessingCaps.SupportsTweening

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexProcessingCaps.SupportsTweening Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether a device supports vertex tweening.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsTweening As Boolean
C# | public bool SupportsTweening { get; }
Managed C++ | public: __property bool get_SupportsTweening();
JScript .NET | public function get SupportsTweening() : boolean

Property Value

System.Boolean . Value that is true if vertex tweening is supported, or false if it is not.

This property is read-only.


VertexShaderCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes vertex shader capabilities.

Definition

Visual Basic .NET | Public Structure VertexShaderCaps
C# | public struct VertexShaderCaps
Managed C++ | public __value struct VertexShaderCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) MaxDynamicFlowControlDepth | Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, ifc).
static (Shared in Visual Basic .NET) MaxNumberTemps | Specifies the maximum number of temporary registers supported.
static (Shared in Visual Basic .NET) MaxStaticFlowControlDepth | Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.
static (Shared in Visual Basic .NET) MinDynamicFlowControlDepth | Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, ifc).
static (Shared in Visual Basic .NET) MinNumberTemps | Specifies the minimum number of temporary registers supported.
static (Shared in Visual Basic .NET) MinStaticFlowControlDepth | Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DynamicFlowControlDepth | Retrieves a value that represents the depth of the dynamic flow control instruction nesting.
NumberTemps | Retrieves the number of temporary registers supported by the device.
StaticFlowControlDepth | Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.
SupportsPredication | Determines whether instruction predication as defined in the predication section is supported.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexShaderCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VertexShaderCaps.DynamicFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.DynamicFlowControlDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that represents the depth of the dynamic flow control instruction nesting.

Definition

Visual Basic .NET | Public ReadOnly Property DynamicFlowControlDepth As Integer
C# | public int DynamicFlowControlDepth { get; }
Managed C++ | public: __property int get_DynamicFlowControlDepth();
JScript .NET | public function get DynamicFlowControlDepth() : int

Property Value

System.Int32 . Integer that represents the level of instruction nesting allowed. The acceptable range of values is 0 to 24.

This property is read-only.

Remarks

If this value is zero, the device does not support dynamic flow control. If it is non-zero, the device supports dynamic flow control (instructions if, break, and breakc).


VertexShaderCaps.NumberTemps

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.NumberTemps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of temporary registers supported by the device.

Definition

Visual Basic .NET | Public ReadOnly Property NumberTemps As Integer
C# | public int NumberTemps { get; }
Managed C++ | public: __property int get_NumberTemps();
JScript .NET | public function get NumberTemps() : int

Property Value

System.Int32 . Integer that represents the number of temporary registers supported. The acceptable range of values is 12 to 32.

This property is read-only.


VertexShaderCaps.StaticFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.StaticFlowControlDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.

Definition

Visual Basic .NET | Public ReadOnly Property StaticFlowControlDepth As Integer
C# | public int StaticFlowControlDepth { get; }
Managed C++ | public: __property int get_StaticFlowControlDepth();
JScript .NET | public function get StaticFlowControlDepth() : int

Property Value

System.Int32 . Integer that represents instruction nesting depth. The acceptable range of values is 0 to 4.

This property is read-only.

Remarks

If this value is zero, the device does not support static flow control.


VertexShaderCaps.SupportsPredication

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.SupportsPredication Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether instruction predication as defined in the predication section is supported.

Definition

Visual Basic .NET | Public ReadOnly Property SupportsPredication As Boolean
C# | public bool SupportsPredication { get; }
Managed C++ | public: __property bool get_SupportsPredication();
JScript .NET | public function get SupportsPredication() : boolean

Property Value

System.Boolean . Value that is true if instruction predication is supported, or false if it is not.

This property is read-only.


VertexShaderCaps.MaxDynamicFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.MaxDynamicFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, ifc).

Definition

Visual Basic .NET | Public Shared MaxDynamicFlowControlDepth As Int32
C# | public static Int32 MaxDynamicFlowControlDepth;
Managed C++ | public: static Int32 MaxDynamicFlowControlDepth;
JScript .NET | public static var MaxDynamicFlowControlDepth : Int32

Field Value

System.Int32 . Value of 24.

This field is read-only.


VertexShaderCaps.MaxNumberTemps

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.MaxNumberTemps Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the maximum number of temporary registers supported.

Definition

Visual Basic .NET | Public Shared MaxNumberTemps As Int32
C# | public static Int32 MaxNumberTemps;
Managed C++ | public: static Int32 MaxNumberTemps;
JScript .NET | public static var MaxNumberTemps : Int32

Field Value

System.Int32 . Value of 32.

This field is read-only.


VertexShaderCaps.MaxStaticFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.MaxStaticFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic .NET | Public Shared MaxStaticFlowControlDepth As Int32
C# | public static Int32 MaxStaticFlowControlDepth;
Managed C++ | public: static Int32 MaxStaticFlowControlDepth;
JScript .NET | public static var MaxStaticFlowControlDepth : Int32

Field Value

System.Int32 . Value of 4.

This field is read-only.


VertexShaderCaps.MinDynamicFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.MinDynamicFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, ifc).

Definition

Visual Basic .NET | Public Shared MinDynamicFlowControlDepth As Int32
C# | public static Int32 MinDynamicFlowControlDepth;
Managed C++ | public: static Int32 MinDynamicFlowControlDepth;
JScript .NET | public static var MinDynamicFlowControlDepth : Int32

Field Value

System.Int32 . Value of 0.

This field is read-only.


VertexShaderCaps.MinNumberTemps

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.MinNumberTemps Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the minimum number of temporary registers supported.

Definition

Visual Basic .NET | Public Shared MinNumberTemps As Int32
C# | public static Int32 MinNumberTemps;
Managed C++ | public: static Int32 MinNumberTemps;
JScript .NET | public static var MinNumberTemps : Int32

Field Value

System.Int32 . Value of 12.

This field is read-only.


VertexShaderCaps.MinStaticFlowControlDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexShaderCaps.MinStaticFlowControlDepth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic .NET | Public Shared MinStaticFlowControlDepth As Int32
C# | public static Int32 MinStaticFlowControlDepth;
Managed C++ | public: static Int32 MinStaticFlowControlDepth;
JScript .NET | public static var MinStaticFlowControlDepth : Int32

Field Value

System.Int32 . Value of 1.

This field is read-only.


VertexStats

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexStats Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Reports the number of triangles that have been processed and clipped by the runtime's software vertex processing.

Definition

Visual Basic .NET | Public Structure VertexStats
C# | public struct VertexStats
Managed C++ | public __value struct VertexStats
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexStats | Initializes a new instance of the VertexStats class.

Properties

Property | Description
NumberExtraClippingTriangles | Retrieves the number of new triangles generated by clipping.
NumberRenderedTriangles | Retrieves the total number of triangles that are not clipped in the current frame.

Remarks

Use the debug runtime and software vertex processing to get the number of non-clipped and clipped primitives for a particular scene. Primitives typically are clipped based on a guard band, if one is present. The clipping guard band is set with parameters such as Caps.GuardBandLeft.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VertexStats.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexStats.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VertexStats.VertexStats()

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexStats.VertexStats Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VertexStats class.

Definition

Visual Basic .NET | Public Sub New()
C# | public VertexStats();
Managed C++ | public: VertexStats();
JScript .NET | public function VertexStats();


VertexStats.NumberExtraClippingTriangles

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexStats.NumberExtraClippingTriangles Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of new triangles generated by clipping.

Definition

Visual Basic .NET | Public ReadOnly Property NumberExtraClippingTriangles As Integer
C# | public int NumberExtraClippingTriangles { get; }
Managed C++ | public: __property int get_NumberExtraClippingTriangles();
JScript .NET | public function get NumberExtraClippingTriangles() : int

Property Value

System.Int32 . Integer that represents the number of new triangles generated by clipping.

This property is read-only.


VertexStats.NumberRenderedTriangles

Microsoft DirectX 9.0 SDK Update (October 2004)

VertexStats.NumberRenderedTriangles Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the total number of triangles that are not clipped in the current frame.

Definition

Visual Basic .NET | Public ReadOnly Property NumberRenderedTriangles As Integer
C# | public int NumberRenderedTriangles { get; }
Managed C++ | public: __property int get_NumberRenderedTriangles();
JScript .NET | public function get NumberRenderedTriangles() : int

Property Value

System.Int32 . Integer that represents the number of triangles rendered.

This property is read-only.


Viewport

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Defines the window dimensions of a render target surface onto which a 3-D volume projects.

Definition

Visual Basic .NET | Public Structure Viewport
C# | public struct Viewport
Managed C++ | public __value struct Viewport
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
Viewport | Initializes a new instance of the Viewport class.

Properties

Property | Description
Height | Retrieves or sets the height dimension of the viewport on the render target surface, in pixels.
MaxZ | Retrieves or sets the maximum value of the clip volume.
MinZ | Retrieves or sets the minimum value of the clip volume.
Width | Retrieves or sets the width dimension of the viewport on the render target surface, in pixels.
X | Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.
Y | Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.

Remarks

The X, Y, Width, and Height members describe the position and dimensions of the viewport on the render-target surface. Usually, applications render to the entire target surface; when rendering on a 640x480 surface, these members should be 0, 0, 640, and 480, respectively. The MinZ and MaxZ properties typically are set to 0.0 and 1.0, but can be set to other values to achieve specific effects. For example, setting them both to 0.0 can force the system to render objects to the foreground of a scene, while setting both to 1.0 can force the objects into the background.

When the viewport parameters for a device change (due to the use of the Device.Viewport property), the driver builds a new transformation matrix.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Viewport.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Viewport.Viewport()

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.Viewport Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Viewport class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Viewport();
Managed C++ | public: Viewport();
JScript .NET | public function Viewport();


Viewport.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height dimension of the viewport on the render target surface, in pixels.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member should be set to the height dimension of the render target surface.


Viewport.MaxZ

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.MaxZ Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the maximum value of the clip volume.

Definition

Visual Basic .NET | Public Property MaxZ As Single
C# | public float MaxZ { get; set; }
Managed C++ public: __property float get_MaxZ();
public: __property void set_MaxZ(float);
JScript .NET public function get MaxZ() : float
public function set MaxZ(float);

Property Value

System.Single . Integer that represents the maximum z-value of the clipping volume.

This property is read/write.

Remarks

MaxZ, together with MinZ, specifies the range of depth values into which a scene is rendered. Most applications set this value to 1.0. Clipping is performed after the projection matrix is applied.


Viewport.MinZ

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.MinZ Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the minimum value of the clip volume.

Definition

Visual Basic .NET | Public Property MinZ As Single
C# | public float MinZ { get; set; }
Managed C++ public: __property float get_MinZ();
public: __property void set_MinZ(float);
JScript .NET public function get MinZ() : float
public function set MinZ(float);

Property Value

System.Single . Integer that represents the minimum z-value of the clipping volume.

This property is read/write.

Remarks

MinZ, together with MaxZ, specifies the range of depth values into which a scene is rendered. Most applications set this value to 0.0. Clipping is performed after the projection matrix is applied.


Viewport.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width dimension of the viewport on the render target surface, in pixels.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member should be set to the width dimension of the render target surface.


Viewport.X

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.X Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.

Definition

Visual Basic .NET | Public Property X As Integer
C# | public int X { get; set; }
Managed C++ public: __property int get_X();
public: __property void set_X(int);
JScript .NET public function get X() : int
public function set X(int);

Property Value

System.Int32 . Integer that represents the upper-left corner of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member can be set to 0.


Viewport.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

Viewport.Y Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.

Definition

Visual Basic .NET | Public Property Y As Integer
C# | public int Y { get; set; }
Managed C++ public: __property int get_Y();
public: __property void set_Y(int);
JScript .NET public function get Y() : int
public function set Y(int);

Property Value

System.Int32 . Integer that represents the upper-left corner of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member can be set to 0.


VolumeDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a volume.

Definition

Visual Basic .NET | Public Structure VolumeDescription
C# | public struct VolumeDescription
Managed C++ | public __value struct VolumeDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VolumeDescription | Initializes a new instance of the VolumeDescription class.

Properties

Property | Description
Depth | Retrieves or sets the depth of the volume, in pixels.
Format | Retrieves or sets the desired surface format of a volume.
Height | Retrieves or sets the height of the volume in pixels.
Pool | Retrieves or sets a Pool value that specifies the class of memory allocated for the current volume.
Type | Retrieves or sets a ResourceType value that identifies the current resource as a volume.
Usage | Not used at this time. This member's value should always be 0.
Width | Retrieves or sets the width of a volume in pixels.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VolumeDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VolumeDescription.VolumeDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.VolumeDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VolumeDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public VolumeDescription();
Managed C++ | public: VolumeDescription();
JScript .NET | public function VolumeDescription();


VolumeDescription.Depth

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.Depth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the depth of the volume, in pixels.

Definition

Visual Basic .NET | Public Property Depth As Integer
C# | public int Depth { get; set; }
Managed C++ public: __property int get_Depth();
public: __property void set_Depth(int);
JScript .NET public function get Depth() : int
public function set Depth(int);

Property Value

System.Int32 . Integer that represents the depth of the volume to set or retrieve.

This property is read/write.


VolumeDescription.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the desired surface format of a volume.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . A Format object that specifies the surface format to set or retrieve.

This property is read/write.


VolumeDescription.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the height of the volume in pixels.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height of the volume to set or retrieve.

This property is read/write.


VolumeDescription.Pool

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.Pool Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a Pool value that specifies the class of memory allocated for the current volume.

Definition

Visual Basic .NET | Public Property Pool As Pool
C# | public Pool Pool { get; set; }
Managed C++ public: __property Pool get_Pool();
public: __property void set_Pool(Pool);
JScript .NET public function get Pool() : Pool
public function set Pool(Pool);

Property Value

Microsoft.DirectX.Direct3D.Pool . Value of the Pool enumeration to set or retrieve.

This property is read/write.


VolumeDescription.Type

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.Type Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a ResourceType value that identifies the current resource as a volume.

Definition

Visual Basic .NET | Public Property Type As ResourceType
C# | public ResourceType Type { get; set; }
Managed C++ public: __property ResourceType get_Type();
public: __property void set_Type(ResourceType);
JScript .NET public function get Type() : ResourceType
public function set Type(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType . Value of the ResourceType enumeration to set or retrieve.

This property is read/write.


VolumeDescription.Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.Usage Property

Language:
Note: This documentation is preliminary and is subject to change.

Not used at this time. This member's value should always be 0.

Definition

Visual Basic .NET | Public Property Usage As Usage
C# | public Usage Usage { get; set; }
Managed C++ public: __property Usage get_Usage();
public: __property void set_Usage(Usage);
JScript .NET public function get Usage() : Usage
public function set Usage(Usage);

Property Value

Microsoft.DirectX.Direct3D.Usage .

This property is read/write.


VolumeDescription.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeDescription.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the width of a volume in pixels.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width of the volume to set or retrieve.

This property is read/write.


VolumeTextureRequirements

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains volume texture creation parameters.

Definition

Visual Basic .NET | Public Structure VolumeTextureRequirements
C# | public struct VolumeTextureRequirements
Managed C++ | public __value struct VolumeTextureRequirements
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VolumeTextureRequirements | Initializes a new instance of the VolumeTextureRequirements class.

Properties

Property | Description
Depth | Retrieves or sets the volume texture depth, in pixels.
Format | Retrieves or sets the desired pixel format.
Height | Retrieves or sets the volume texture height, in pixels.
NumberMipLevels | Retrieves or sets the number of mipmap levels of a volume texture.
Width | Retrieves or sets the volume texture width, in pixels.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VolumeTextureRequirements.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


VolumeTextureRequirements.VolumeTextureRequirements()

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements.VolumeTextureRequirements Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the VolumeTextureRequirements class.

Definition

Visual Basic .NET | Public Sub New()
C# | public VolumeTextureRequirements();
Managed C++ | public: VolumeTextureRequirements();
JScript .NET | public function VolumeTextureRequirements();


VolumeTextureRequirements.Depth

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements.Depth Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the volume texture depth, in pixels.

Definition

Visual Basic .NET | Public Property Depth As Integer
C# | public int Depth { get; set; }
Managed C++ public: __property int get_Depth();
public: __property void set_Depth(int);
JScript .NET public function get Depth() : int
public function set Depth(int);

Property Value

System.Int32 . Integer that represents the depth to set or retrieve.

This property is read/write.


VolumeTextureRequirements.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the desired pixel format.

Definition

Visual Basic .NET | Public Property Format As Format
C# | public Format Format { get; set; }
Managed C++ public: __property Format get_Format();
public: __property void set_Format(Format);
JScript .NET public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format . A Format object that specifies the pixel format to set or retrieve.

This property is read/write.


VolumeTextureRequirements.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the volume texture height, in pixels.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 . Integer that represents the height to set or retrieve.

This property is read/write.


VolumeTextureRequirements.NumberMipLevels

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements.NumberMipLevels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the number of mipmap levels of a volume texture.

Definition

Visual Basic .NET | Public Property NumberMipLevels As Integer
C# | public int NumberMipLevels { get; set; }
Managed C++ public: __property int get_NumberMipLevels();
public: __property void set_NumberMipLevels(int);
JScript .NET public function get NumberMipLevels() : int
public function set NumberMipLevels(int);

Property Value

System.Int32 . Integer that represents the number of mipmap levels to set or retrieve.

This property is read/write.


VolumeTextureRequirements.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

VolumeTextureRequirements.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the volume texture width, in pixels.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 . Integer that represents the width to set or retrieve.

This property is read/write.


WeldEpsilons

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies a per-vertex value that is used to weld similar vertices together.

Definition

Visual Basic .NET | Public Structure WeldEpsilons
C# | public struct WeldEpsilons
Managed C++ | public __value struct WeldEpsilons
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
WeldEpsilons | Initializes a new instance of the WeldEpsilons class.

Properties

Property | Description
Binormal | Retrieves or sets the allowable tolerance value of a binormal, or the cross product of the tangent and normal vectors, to compare between vertices.
BlendWeights | Retrieves or sets the allowable tolerance value of the blend weights to compare between vertices.
Diffuse | Retrieves or sets the allowable tolerance value of the diffuse lighting to compare between vertices.
Normal | Retrieves or sets the allowable tolerance value of a normal to compare between vertices.
PointSize | Retrieves or sets the allowable tolerance value of a point size to compare between vertices.
Position | Retrieves or sets the allowable tolerance value of a position to compare between vertices.
Specular | Retrieves or sets the allowable tolerance value of specular lighting to compare between vertices.
Tangent | Retrieves or sets the allowable tolerance value of a tangent to compare between vertices.
TessellateFactor | Retrieves or sets the allowable tolerance value of a tessellation factor to compare between vertices.
TextureCoordinate | Retrieves or sets the allowable tolerance value of texture coordinates to compare between vertices.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WeldEpsilons.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


WeldEpsilons.WeldEpsilons()

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.WeldEpsilons Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WeldEpsilons class.

Definition

Visual Basic .NET | Public Sub New()
C# | public WeldEpsilons();
Managed C++ | public: WeldEpsilons();
JScript .NET | public function WeldEpsilons();


WeldEpsilons.Binormal

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.Binormal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of a binormal, or the cross product of the tangent and normal vectors, to compare between vertices.

Definition

Visual Basic .NET | Public Property Binormal As Single
C# | public float Binormal { get; set; }
Managed C++ public: __property float get_Binormal();
public: __property void set_Binormal(float);
JScript .NET public function get Binormal() : float
public function set Binormal(float);

Property Value

System.Single . Floating-point value that represents the binormal epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.BlendWeights

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.BlendWeights Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of the blend weights to compare between vertices.

Definition

Visual Basic .NET | Public Property BlendWeights As Single
C# | public float BlendWeights { get; set; }
Managed C++ public: __property float get_BlendWeights();
public: __property void set_BlendWeights(float);
JScript .NET public function get BlendWeights() : float
public function set BlendWeights(float);

Property Value

System.Single . Floating-point value that represents the blend weight epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Diffuse

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.Diffuse Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of the diffuse lighting to compare between vertices.

Definition

Visual Basic .NET | Public Property Diffuse As Single
C# | public float Diffuse { get; set; }
Managed C++ public: __property float get_Diffuse();
public: __property void set_Diffuse(float);
JScript .NET public function get Diffuse() : float
public function set Diffuse(float);

Property Value

System.Single . Floating-point value that represents the diffuse lighting epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Normal

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.Normal Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of a normal to compare between vertices.

Definition

Visual Basic .NET | Public Property Normal As Single
C# | public float Normal { get; set; }
Managed C++ public: __property float get_Normal();
public: __property void set_Normal(float);
JScript .NET public function get Normal() : float
public function set Normal(float);

Property Value

System.Single . Floating-point value that represents the normal epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.PointSize

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.PointSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of a point size to compare between vertices.

Definition

Visual Basic .NET | Public Property PointSize As Single
C# | public float PointSize { get; set; }
Managed C++ public: __property float get_PointSize();
public: __property void set_PointSize(float);
JScript .NET public function get PointSize() : float
public function set PointSize(float);

Property Value

System.Single . Floating-point value that represents the point size epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of a position to compare between vertices.

Definition

Visual Basic .NET | Public Property Position As Single
C# | public float Position { get; set; }
Managed C++ public: __property float get_Position();
public: __property void set_Position(float);
JScript .NET public function get Position() : float
public function set Position(float);

Property Value

System.Single . Floating-point value that represents the position epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Specular

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.Specular Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of specular lighting to compare between vertices.

Definition

Visual Basic .NET | Public Property Specular As Single
C# | public float Specular { get; set; }
Managed C++ public: __property float get_Specular();
public: __property void set_Specular(float);
JScript .NET public function get Specular() : float
public function set Specular(float);

Property Value

System.Single . Floating-point value that represents the specular lighting epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Tangent

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.Tangent Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of a tangent to compare between vertices.

Definition

Visual Basic .NET | Public Property Tangent As Single
C# | public float Tangent { get; set; }
Managed C++ public: __property float get_Tangent();
public: __property void set_Tangent(float);
JScript .NET public function get Tangent() : float
public function set Tangent(float);

Property Value

System.Single . Floating-point value that represents the tangent epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.TessellateFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.TessellateFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of a tessellation factor to compare between vertices.

Definition

Visual Basic .NET | Public Property TessellateFactor As Single
C# | public float TessellateFactor { get; set; }
Managed C++ public: __property float get_TessellateFactor();
public: __property void set_TessellateFactor(float);
JScript .NET public function get TessellateFactor() : float
public function set TessellateFactor(float);

Property Value

System.Single . Floating-point value that represents the tessellation factor epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.TextureCoordinate

Microsoft DirectX 9.0 SDK Update (October 2004)

WeldEpsilons.TextureCoordinate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the allowable tolerance value of texture coordinates to compare between vertices.

Definition

Visual Basic .NET | Public Property TextureCoordinate As Single()
C# | public float[] TextureCoordinate { get; set; }
Managed C++ public: __property float get_TextureCoordinate();
public: __property void set_TextureCoordinate(float);
JScript .NET public function get TextureCoordinate() : float[]
public function set TextureCoordinate(float[]);

Property Value

System.Single[] . Array of eight floating-point values that represent the texture coordinate epsilons to set or retrieve.

This property is read/write.


Fill2DTextureCallback(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Fill2DTextureCallback Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Represents the method that handles the FillTexture(Texture,Fill2DTextureCallback) call.

Definition

Visual Basic .NET Public Delegate Sub Fill2DTextureCallback( _
ByVal texCoord As Vector2, _
ByVal texelSize As Vector2 _
)
C# public sealed delegate void Fill2DTextureCallback(
Vector2 texCoord,
Vector2 texelSize
);
Managed C++ public: __gc __delegate void Fill2DTextureCallback(
Vector2 texCoord,
Vector2 texelSize
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

texCoord | Microsoft.DirectX.Vector2. A Vector2 object that contains the coordinates of the texel currently being evaluated. See Remarks.
texelSize | Microsoft.DirectX.Vector2. A Vector2 object that contains the dimensions of the current texel.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

Remarks

Texture coordinate components range from 0 to 1 for textures and volume textures, and from -1 to 1 for cube textures.

See Also

  • Fill3DTextureCallback


Fill3DTextureCallback(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Fill3DTextureCallback Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Represents the method that handles the FillTexture(VolumeTexture,Fill3DTextureCallback) or FillTexture(CubeTexture,Fill3DTextureCallback) call.

Definition

Visual Basic .NET Public Delegate Sub Fill3DTextureCallback( _
ByVal texCoord As Vector3, _
ByVal texelSize As Vector3 _
)
C# public sealed delegate void Fill3DTextureCallback(
Vector3 texCoord,
Vector3 texelSize
);
Managed C++ public: __gc __delegate void Fill3DTextureCallback(
Vector3 texCoord,
Vector3 texelSize
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

texCoord | Microsoft.DirectX.Vector3. A Vector3 object that contains the coordinates of the texel currently being evaluated. See Remarks.
texelSize | Microsoft.DirectX.Vector3. A Vector3 object that contains the dimensions of the current texel.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

Remarks

Texture coordinate components range from 0 to 1 for textures and volume textures, and from -1 to 1 for cube textures.

See Also

  • Fill2DTextureCallback


HandleAnimationCallback(Int32,IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

HandleAnimationCallback Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

This delegate is used to handle callbacks triggered by KeyCallbacks in an animation track.

Definition

Visual Basic .NET Public Delegate Sub HandleAnimationCallback( _
ByVal track As Integer, _
ByVal callbackData As IntPtr _
)
C# public sealed delegate void HandleAnimationCallback(
int track,
IntPtr callbackData
);
Managed C++ public: __gc __delegate void HandleAnimationCallback(
int track,
IntPtr callbackData
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

track | System.Int32. Identifier of the track on which the callback occurs.
callbackData | System.IntPtr. Callback data specified in the KeyCallback.CallBackData field.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrtEngineCallback(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrtEngineCallback Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Represents an optional callback method that computes the percentage of spherical harmonic (SH) computations completed and gives the caller the option of aborting the simulator.

Definition

Visual Basic .NET Public Delegate Sub PrtEngineCallback( _
ByVal percentComplete As Single _
)
C# public sealed delegate void PrtEngineCallback(
float percentComplete
);
Managed C++ public: __gc __delegate void PrtEngineCallback(
float percentComplete
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

percentComplete System.Single. A floating-point value that contains the percentage of spherical harmonic (SH) computations completed.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • PrtEngine.SetCallback


Microsoft.DirectX.DirectDraw

Note: This documentation is preliminary and is subject to change.

Warning: Microsoft® DirectDraw® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw enables you to directly manipulate display memory, the hardware blitter, hardware overlay support, and flipping surface support. The following tables list the members exposed by the Microsoft.DirectX.DirectDraw namespace.

Classes

CannotCloneException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Primary surfaces, or surfaces that are implicitly created, cannot be duplicated. Deprecated.
CannotCreateDeviceContextException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Windows cannot create any more device contexts (DCs), or a DC has requested a palette-indexed surface when the surface had no palette and the display mode was not palette-indexed (in this case DirectDraw cannot select a proper palette into the DC). Deprecated.
CannotLockSurfaceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this surface is refused because an attempt was made to lock the primary surface without DCI support. Deprecated.
CannotPageLockException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-lock a surface failed. Page lock does not work on a display-memory surface or an emulated primary surface. Deprecated.
CannotPageUnlockException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-unlock a surface failed. Page unlock does not work on a display-memory surface or an emulated primary surface. Deprecated.
CapsComplexRequiredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface requires the Complex flag. Deprecated.
Clipper
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Clipper object to manage clip lists. Deprecated.
ClipperIsUsingWindowException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set a clip list for a DirectDrawClipper object that is already monitoring a window handle. Deprecated.
ColorControl
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorControl object allows you to get and set color controls. Deprecated.
ColorKeyNotSetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No source color key is specified for this operation. Deprecated.
CurrentlyNotAvailableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No support is currently available. Deprecated.
DDrawHelper
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Utility class Deprecated.
Device
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Device object to create DirectDraw objects and work with system-level variables. Deprecated.
DeviceDoesNotOwnSurfaceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Surfaces created by one DirectDraw device cannot be used directly by another DirectDraw device. Deprecated.
DevicesCollection
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of devices. Deprecated.
DisplayModesCollection
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of display modes. Deprecated.
DrawFastCannotClipException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A DirectDrawClipper object is attached to a source surface that has passed into a call to the DrawFast method. Deprecated.
ExclusiveModeAlreadySetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set the cooperative level when it was already set to exclusive. Deprecated.
ExpiredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data has expired and is therefore no longer valid. Deprecated.
GammaControl
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the GammaControl object to adjust the red, green, and blue gamma ramp levels of the primary surface. Deprecated.
GraphicsAlreadyCreatedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A device context (DC) has already been returned for this surface. Only one DC can be retrieved for each surface. Deprecated.
GraphicsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception class for all DirectDraw exceptions. Derives from DirectXException. Deprecated.
HeightAlignException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height of the provided rectangle is not a multiple of the required alignment. Deprecated.
ImplicitlyCreatedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface cannot be restored because it is an implicitly created surface. Deprecated.
IncompatiblePrimaryException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface creation request does not match the existing primary surface. Deprecated.
InvalidCapsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more of the capability bits passed to the callback function are incorrect. Deprecated.
InvalidClipListException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the provided clip list. Deprecated.
InvalidDirectDrawGuidException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The globally unique identifier (Guid) passed to the constructor is not a valid DirectDraw driver identifier. Deprecated.
InvalidModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the requested mode. Deprecated.
InvalidObjectException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw received a reference that was an invalid DirectDraw object. Deprecated.
InvalidPixelFormatException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format was invalid as specified. Deprecated.
InvalidPositionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The position of the overlay on the destination is no longer legal. Deprecated.
InvalidRectangleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was invalid. Deprecated.
InvalidStreamException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified stream contains invalid data. Deprecated.
InvalidSurfaceTypeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface was of the wrong type. Deprecated.
LockedSurfacesException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more surfaces are locked, causing the failure of the requested operation. Deprecated.
MoreDataException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is more data available than the specified buffer size can hold. Deprecated.
NewModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When StartModeTest is called with the IsTestRequired flag, it may throw this exception to denote that some or all of the resolutions can and should be tested. EvaluateMode throws this exception to indicate that the test has switched to a new display mode. Deprecated.
NoAlphaHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No alpha-acceleration hardware is present or available, causing the failure of the requested operation. Deprecated.
NoClipListException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No clip list is available. Deprecated.
NoClipperAttachedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No DirectDrawClipper object is attached to the surface object. Deprecated.
NoColorConversionHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No color-conversion hardware is present or available. Deprecated.
NoColorKeyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface does not currently have a color key. Deprecated.
NoColorKeyHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for the destination color key. Deprecated.
NoCooperativeLevelSetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A create function was called without the SetCooperativeLevel method. Deprecated.
NoDeviceContextException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No device context (DC) has ever been created for this surface. Deprecated.
NoDirectDrawHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware-only DirectDraw object creation is not possible; the driver does not support any hardware. Deprecated.
NoDirectDrawSupportException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw support is not possible with the current display driver. Deprecated.
NoDrawHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No blitter hardware is present. Deprecated.
NoDriverSupportException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the display adapter driver does not enumerate refresh rates. Deprecated.
NoEmulationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Software emulation is not available. Deprecated.
NoExclusiveModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation requires the application to have exclusive mode, but the application does not have exclusive mode. Deprecated.
NoFlipHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flipping visible surfaces is not supported. Deprecated.
NoFocusWindowException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to create or set a device window without first setting the focus window. Deprecated.
NoGdiException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No GDI is present. Deprecated.
NoMirrorHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No mirroring hardware is present or available. Deprecated.
NoMonitorInformationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the monitor has no associated EDID data. Deprecated.
NoNonLocalVideoMemoryException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to allocate nonlocal video memory from a device that does not support nonlocal video memory. Deprecated.
NoOptimizeHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The device does not support optimized surfaces. Deprecated.
NoOverlayDestinationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method is called on an overlay that the UpdateOverlay method has not been called on to establish as a destination. Deprecated.
NoOverlayHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No overlay hardware is present or available. Deprecated.
NoPaletteAttachedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No palette object is attached to this surface. Deprecated.
NoPaletteHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for 16- or 256-color palettes. Deprecated.
NoRasterOperationHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No appropriate raster-operation hardware is present or available. Deprecated.
NoRotationHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No rotation hardware is present or available. Deprecated.
NoStereoHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no stereo hardware present or available. Deprecated.
NoStretchHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for stretching. Deprecated.
NoSurfaceLeftException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware present that supports stereo surfaces. Deprecated.
Not4BitColorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color palette, and the requested operation requires a 4-bit color palette. Deprecated.
Not4BitColorIndexException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color index palette, and the requested operation requires a 4-bit color index palette. Deprecated.
Not8BitColorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using an 8-bit color palette, and the requested operation requires an 8-bit color palette. Deprecated.
NotAnOverlaySurfaceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An overlay component is called for a nonoverlay surface. Deprecated.
NotFlippableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to flip a surface that cannot be flipped. Deprecated.
NotFoundException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested item was not found. Deprecated.
NotLoadedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is an optimized surface, but it has not yet been allocated any memory. Deprecated.
NotLockedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to unlock a surface that was not locked. Deprecated.
NotPageLockedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to page-unlock a surface with no outstanding page locks. Deprecated.
NotPalettizedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface being used is not a palette-based surface. Deprecated.
NoVideoSyncHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for vertical blank-synchronized operations. Deprecated.
NoWindowException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Clipper notification requires a window, or no window has been previously set as the cooperative level window Deprecated.
OutOfCapsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware needed for the requested operation has already been allocated. Deprecated.
OutOfVideoMemoryException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not have enough display memory to perform the operation. Deprecated.
OverlappingRectanglesException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The source and destination rectangles are on the same surface and overlap each other. Deprecated.
OverlayCantClipException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware does not support clipped overlays. Deprecated.
OverlayColorKeyOnlyOneActiveException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to have more than one color key active on an overlay. Deprecated.
OverlayNotVisibleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method was called on a hidden overlay. Deprecated.
Palette
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Palette object to create DirectDrawPalette objects Deprecated.
PaletteBusyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this palette is refused because the palette is locked by another thread. Deprecated.
PrimarySurfaceAlreadyExistsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This process has already created a primary surface. Deprecated.
RegionTooSmallException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The region passed to the Clipper.ClipList property is too small. Deprecated.
Surface
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A surface represents a linear area of display memory. A surface usually resides in the display memory of the display card, although surfaces can exist in system memory. Unless specifically instructed otherwise during the creation of the Surface object, DirectDraw will put the Surface object wherever the best performance can be achieved given the requested capabilities. Surface objects can take advantage of specialized processors on display cards, not only to perform certain tasks faster, but to perform some tasks in parallel with the system CPU. Deprecated.
SurfaceBusyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is locked by another thread. Deprecated.
SurfaceCaps
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the capabilities of a DirectDrawSurface object. Deprecated.
SurfaceDescription
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A description of a surface. Deprecated.
SurfaceIsObscuredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is obscured. Deprecated.
SurfaceLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface memory is gone. Call the Surface.Restore method on this surface to restore the memory associated Deprecated.
SurfaceNotAttachedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested surface is not attached. Deprecated.
SurfacesCollection
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of surfaces. Deprecated.
TestFinishedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When thrown by StartModeTest method, this value means that no test could be initiated because all the resolutions chosen for testing already have refresh rate information in the registry. Deprecated.
TooBigHeightException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height requested by DirectDraw is too large. Deprecated.
TooBigSizeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size requested by DirectDraw is too large. However, the individual height and width are valid sizes. Deprecated.
TooBigWidthException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The width requested by DirectDraw is too large. Deprecated.
UnsupportedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.
UnsupportedFormatException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format requested is not supported by DirectDraw. Deprecated.
UnsupportedMaskException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The bitmask in the pixel format requested is not supported by DirectDraw. Deprecated.
UnsupportedModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display is currently in an unsupported mode. Deprecated.
VerticalBlankInProgressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A vertical blank is in progress. Deprecated.
VideoNotActiveException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The video port is not active. Deprecated.
WasStillDrawingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The previous blit operation that is transferring information to or from this surface is incomplete. Deprecated.
WindowAlreadySetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDraw cooperative-level window has already been set. It cannot be reset while the process has surfaces or palettes created. Deprecated.
WindowSubclassedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is prevented from restoring state because the DirectDraw cooperative-level window handle has been subclassed. Deprecated.
WrongModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface cannot be restored because it was created in a different mode. Deprecated.
XAlignException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was not horizontally aligned on a required boundary. Deprecated.

Enumerations

ColorKeyFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines which color key is requested. Deprecated.
CooperativeLevelFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.
CreateFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creation flags. Deprecated.
DrawFastFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of transfer. Deprecated.
DrawFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of flags that determine the valid members of the associated DrawEffects structure, specify color-key information, or request special behavior from the method. Deprecated.
FlipFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags specifying flip options. Deprecated.
FourCc
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCc codes Deprecated.
GetDeviceFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDeviceFlags Deprecated.
GetDevicesFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDevicesFlags Deprecated.
GetDisplayModeFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Getting displaymode flags, can be used to enumerate Standard VGA Modes, or RefreshRates. Deprecated.
GetSurfacesFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The search type flag determines how the method searches for matching surfaces; The matching flag determines whether the method enumerates all surfaces, only those that match, or only those that do not match the description. Deprecated.
LockFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags describing locking. Deprecated.
OverlayEffectsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for overlay effects. Deprecated.
OverlayFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.
OverlayZFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.
OverlayZOrdersFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.
StartModeTestFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for the StartModeTest call. Deprecated.
StereoViewCapsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for Stereo View caps... Deprecated.
WaitVbFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines how long to wait for the vertical blank. Deprecated.

Structures

Caps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the capabilities of the hardware exposed through the DirectDraw object. Deprecated.
ColorControlObject
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the color controls associated with an overlay surface, or a primary surface. Deprecated.
ColorKey
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a source color key, destination color key, or color space. Deprecated.
ColorKeyCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key capabilities Deprecated.
DeviceIdentifier
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.
DeviceInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.
DrawEffects
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations (ROPs), effects, and override information. Deprecated.
FXAlphaCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific alpha capabilities Deprecated.
FXCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.
GammaRamps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.
GetCapsStruct
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware and Hardware Emulation Layer (HEL) capabilities Deprecated.
LockedData
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
OverlayEffects
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Override information to the UpdateOverlay method. Deprecated.
PaletteCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities Deprecated.
PaletteEntry
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the color and usage of an entry in a logical color palette. Deprecated.
PixelFormat
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of a DirectDrawSurface. Deprecated.


Microsoft.DirectX.DirectDraw.CannotCloneException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCloneException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Primary surfaces, or surfaces that are implicitly created, cannot be duplicated. Deprecated.

Definition

Visual Basic .NET Public Class CannotCloneException
Inherits GraphicsException
C# | public class CannotCloneException : GraphicsException
Managed C++ | public __gc class CannotCloneException : public GraphicsException
JScript .NET | public class CannotCloneException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCloneException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotCloneException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotCloneException.CannotCloneException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCloneException.CannotCloneException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCloneException();
protected CannotCloneException(SerializationInfo, StreamingContext);
public CannotCloneException(string);
public CannotCloneException(string, Exception);


CannotCloneException.CannotCloneException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCloneException.CannotCloneException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCloneException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotCloneException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotCloneException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotCloneException.CannotCloneException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCloneException.CannotCloneException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCloneException(
string message,
Exception inner
);
Managed C++ public: CannotCloneException(
String *message,
Exception *inner
);
JScript .NET public function CannotCloneException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotCloneException.CannotCloneException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCloneException.CannotCloneException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotCloneException(
string message
);
Managed C++ public: CannotCloneException(
String *message
);
JScript .NET public function CannotCloneException(
message : String
);

Parameters

message System.String.


CannotCloneException.CannotCloneException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCloneException.CannotCloneException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotCloneException();
Managed C++ | public: CannotCloneException();
JScript .NET | public function CannotCloneException();


Microsoft.DirectX.DirectDraw.CannotCreateDeviceContextException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateDeviceContextException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Windows cannot create any more device contexts (DCs), or a DC has requested a palette-indexed surface when the surface had no palette and the display mode was not palette-indexed (in this case DirectDraw cannot select a proper palette into the DC). Deprecated.

Definition

Visual Basic .NET Public Class CannotCreateDeviceContextException
Inherits GraphicsException
C# | public class CannotCreateDeviceContextException : GraphicsException
Managed C++ | public __gc class CannotCreateDeviceContextException : public GraphicsException
JScript .NET | public class CannotCreateDeviceContextException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCreateDeviceContextException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotCreateDeviceContextException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotCreateDeviceContextException.CannotCreateDeviceContextException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCreateDeviceContextException();
protected CannotCreateDeviceContextException(SerializationInfo, StreamingContext);
public CannotCreateDeviceContextException(string);
public CannotCreateDeviceContextException(string, Exception);


CannotCreateDeviceContextException.CannotCreateDeviceContextException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCreateDeviceContextException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotCreateDeviceContextException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotCreateDeviceContextException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotCreateDeviceContextException.CannotCreateDeviceContextException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCreateDeviceContextException(
string message,
Exception inner
);
Managed C++ public: CannotCreateDeviceContextException(
String *message,
Exception *inner
);
JScript .NET public function CannotCreateDeviceContextException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotCreateDeviceContextException.CannotCreateDeviceContextException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotCreateDeviceContextException(
string message
);
Managed C++ public: CannotCreateDeviceContextException(
String *message
);
JScript .NET public function CannotCreateDeviceContextException(
message : String
);

Parameters

message System.String.


CannotCreateDeviceContextException.CannotCreateDeviceContextException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotCreateDeviceContextException();
Managed C++ | public: CannotCreateDeviceContextException();
JScript .NET | public function CannotCreateDeviceContextException();


Microsoft.DirectX.DirectDraw.CannotLockSurfaceException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLockSurfaceException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this surface is refused because an attempt was made to lock the primary surface without DCI support. Deprecated.

Definition

Visual Basic .NET Public Class CannotLockSurfaceException
Inherits GraphicsException
C# | public class CannotLockSurfaceException : GraphicsException
Managed C++ | public __gc class CannotLockSurfaceException : public GraphicsException
JScript .NET | public class CannotLockSurfaceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotLockSurfaceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotLockSurfaceException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotLockSurfaceException.CannotLockSurfaceException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotLockSurfaceException();
protected CannotLockSurfaceException(SerializationInfo, StreamingContext);
public CannotLockSurfaceException(string);
public CannotLockSurfaceException(string, Exception);


CannotLockSurfaceException.CannotLockSurfaceException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotLockSurfaceException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotLockSurfaceException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotLockSurfaceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotLockSurfaceException.CannotLockSurfaceException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotLockSurfaceException(
string message,
Exception inner
);
Managed C++ public: CannotLockSurfaceException(
String *message,
Exception *inner
);
JScript .NET public function CannotLockSurfaceException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotLockSurfaceException.CannotLockSurfaceException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotLockSurfaceException(
string message
);
Managed C++ public: CannotLockSurfaceException(
String *message
);
JScript .NET public function CannotLockSurfaceException(
message : String
);

Parameters

message System.String.


CannotLockSurfaceException.CannotLockSurfaceException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotLockSurfaceException();
Managed C++ | public: CannotLockSurfaceException();
JScript .NET | public function CannotLockSurfaceException();


Microsoft.DirectX.DirectDraw.CannotPageLockException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageLockException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-lock a surface failed. Page lock does not work on a display-memory surface or an emulated primary surface. Deprecated.

Definition

Visual Basic .NET Public Class CannotPageLockException
Inherits GraphicsException
C# | public class CannotPageLockException : GraphicsException
Managed C++ | public __gc class CannotPageLockException : public GraphicsException
JScript .NET | public class CannotPageLockException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotPageLockException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotPageLockException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotPageLockException.CannotPageLockException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageLockException.CannotPageLockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotPageLockException();
protected CannotPageLockException(SerializationInfo, StreamingContext);
public CannotPageLockException(string);
public CannotPageLockException(string, Exception);


CannotPageLockException.CannotPageLockException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageLockException.CannotPageLockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotPageLockException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotPageLockException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotPageLockException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotPageLockException.CannotPageLockException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageLockException.CannotPageLockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotPageLockException(
string message,
Exception inner
);
Managed C++ public: CannotPageLockException(
String *message,
Exception *inner
);
JScript .NET public function CannotPageLockException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotPageLockException.CannotPageLockException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageLockException.CannotPageLockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotPageLockException(
string message
);
Managed C++ public: CannotPageLockException(
String *message
);
JScript .NET public function CannotPageLockException(
message : String
);

Parameters

message System.String.


CannotPageLockException.CannotPageLockException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageLockException.CannotPageLockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotPageLockException();
Managed C++ | public: CannotPageLockException();
JScript .NET | public function CannotPageLockException();


Microsoft.DirectX.DirectDraw.CannotPageUnlockException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageUnlockException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-unlock a surface failed. Page unlock does not work on a display-memory surface or an emulated primary surface. Deprecated.

Definition

Visual Basic .NET Public Class CannotPageUnlockException
Inherits GraphicsException
C# | public class CannotPageUnlockException : GraphicsException
Managed C++ | public __gc class CannotPageUnlockException : public GraphicsException
JScript .NET | public class CannotPageUnlockException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotPageUnlockException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotPageUnlockException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotPageUnlockException.CannotPageUnlockException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotPageUnlockException();
protected CannotPageUnlockException(SerializationInfo, StreamingContext);
public CannotPageUnlockException(string);
public CannotPageUnlockException(string, Exception);


CannotPageUnlockException.CannotPageUnlockException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotPageUnlockException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotPageUnlockException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotPageUnlockException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotPageUnlockException.CannotPageUnlockException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotPageUnlockException(
string message,
Exception inner
);
Managed C++ public: CannotPageUnlockException(
String *message,
Exception *inner
);
JScript .NET public function CannotPageUnlockException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotPageUnlockException.CannotPageUnlockException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotPageUnlockException(
string message
);
Managed C++ public: CannotPageUnlockException(
String *message
);
JScript .NET public function CannotPageUnlockException(
message : String
);

Parameters

message System.String.


CannotPageUnlockException.CannotPageUnlockException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotPageUnlockException();
Managed C++ | public: CannotPageUnlockException();
JScript .NET | public function CannotPageUnlockException();


Microsoft.DirectX.DirectDraw.CapsComplexRequiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

CapsComplexRequiredException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface requires the Complex flag. Deprecated.

Definition

Visual Basic .NET Public Class CapsComplexRequiredException
Inherits GraphicsException
C# | public class CapsComplexRequiredException : GraphicsException
Managed C++ | public __gc class CapsComplexRequiredException : public GraphicsException
JScript .NET | public class CapsComplexRequiredException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CapsComplexRequiredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CapsComplexRequiredException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CapsComplexRequiredException.CapsComplexRequiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CapsComplexRequiredException();
protected CapsComplexRequiredException(SerializationInfo, StreamingContext);
public CapsComplexRequiredException(string);
public CapsComplexRequiredException(string, Exception);


CapsComplexRequiredException.CapsComplexRequiredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CapsComplexRequiredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CapsComplexRequiredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CapsComplexRequiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CapsComplexRequiredException.CapsComplexRequiredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CapsComplexRequiredException(
string message,
Exception inner
);
Managed C++ public: CapsComplexRequiredException(
String *message,
Exception *inner
);
JScript .NET public function CapsComplexRequiredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CapsComplexRequiredException.CapsComplexRequiredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CapsComplexRequiredException(
string message
);
Managed C++ public: CapsComplexRequiredException(
String *message
);
JScript .NET public function CapsComplexRequiredException(
message : String
);

Parameters

message System.String.


CapsComplexRequiredException.CapsComplexRequiredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CapsComplexRequiredException();
Managed C++ | public: CapsComplexRequiredException();
JScript .NET | public function CapsComplexRequiredException();


Microsoft.DirectX.DirectDraw.Clipper

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Clipper object to manage clip lists. Deprecated.

Definition

Visual Basic .NET Public Class Clipper
Inherits MarshalByRefObject
Implements IDisposable
C# public class Clipper : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Clipper : public MarshalByRefObject,
IDisposable
JScript .NET public class Clipper extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Clipper
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ClipList
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets a copy of the clip list associated with a Clipper object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
Window
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the window previously associated with this Clipper object. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Clipper

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Clipper.Clipper

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Clipper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Clipper();
public Clipper(Device);


Clipper.Clipper(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Clipper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dev As Device _
)
C# public Clipper(
Device dev
);
Managed C++ public: Clipper(
Device *dev
);
JScript .NET public function Clipper(
dev : Device
);

Parameters

dev Microsoft.DirectX.DirectDraw.Device.


Clipper.Clipper()

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Clipper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Clipper();
Managed C++ | public: Clipper();
JScript .NET | public function Clipper();


Clipper.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Clipper.Disposed
  • Clipper.Disposing


Clipper.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Clipper.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Clipper();
Managed C++ | ~Clipper();
JScript .NET | protected override function Finalize();


Clipper.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Clipper.op_Equality(Clipper,Clipper)

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Clipper, _
ByVal right As Clipper _
) As Boolean
C# public static bool op_Equality(
Clipper left,
Clipper right
);
Managed C++ public: static bool op_Equality(
Clipper *left,
Clipper *right
);
JScript .NET public static function op_Equality(
left : Clipper,
right : Clipper
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Clipper. The Clipper structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.Clipper. The Clipper structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Clipper.op_Inequality(Clipper,Clipper)

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Clipper, _
ByVal right As Clipper _
) As Boolean
C# public static bool op_Inequality(
Clipper left,
Clipper right
);
Managed C++ public: static bool op_Inequality(
Clipper *left,
Clipper *right
);
JScript .NET public static function op_Inequality(
left : Clipper,
right : Clipper
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Clipper. The Clipper structure to the left of the inequality operator.
right | Microsoft.DirectX.DirectDraw.Clipper. The Clipper structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Clipper.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Clipper.ClipList

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.ClipList Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets a copy of the clip list associated with a Clipper object. Deprecated.

Definition

Visual Basic .NET | Public Property ClipList As Rectangle()
C# | public Rectangle[] ClipList { get; set; }
Managed C++ public: __property Rectangle get_ClipList();
public: __property void set_ClipList(Rectangle);
JScript .NET public function get ClipList() : Rectangle[]
public function set ClipList(Rectangle[]);

Property Value

System.Drawing.Rectangle[] .

This property is read/write.


Clipper.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Clipper.Window

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Window Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the window previously associated with this Clipper object. Deprecated.

Definition

Visual Basic .NET | Public Property Window As Control
C# | public Control Window { get; set; }
Managed C++ public: __property Control* get_Window();
public: __property void set_Window(Control*);
JScript .NET public function get Window() : Control
public function set Window(Control);

Property Value

System.Windows.Forms.Control .

This property is read/write.


Clipper.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Clipper.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Clipper.Disposing event, use the following code.

clipper.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectDraw.ClipperIsUsingWindowException

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipperIsUsingWindowException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set a clip list for a DirectDrawClipper object that is already monitoring a window handle. Deprecated.

Definition

Visual Basic .NET Public Class ClipperIsUsingWindowException
Inherits GraphicsException
C# | public class ClipperIsUsingWindowException : GraphicsException
Managed C++ | public __gc class ClipperIsUsingWindowException : public GraphicsException
JScript .NET | public class ClipperIsUsingWindowException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ClipperIsUsingWindowException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ClipperIsUsingWindowException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClipperIsUsingWindowException.ClipperIsUsingWindowException

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ClipperIsUsingWindowException();
protected ClipperIsUsingWindowException(SerializationInfo, StreamingContext);
public ClipperIsUsingWindowException(string);
public ClipperIsUsingWindowException(string, Exception);


ClipperIsUsingWindowException.ClipperIsUsingWindowException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ClipperIsUsingWindowException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ClipperIsUsingWindowException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ClipperIsUsingWindowException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ClipperIsUsingWindowException.ClipperIsUsingWindowException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ClipperIsUsingWindowException(
string message,
Exception inner
);
Managed C++ public: ClipperIsUsingWindowException(
String *message,
Exception *inner
);
JScript .NET public function ClipperIsUsingWindowException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ClipperIsUsingWindowException.ClipperIsUsingWindowException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ClipperIsUsingWindowException(
string message
);
Managed C++ public: ClipperIsUsingWindowException(
String *message
);
JScript .NET public function ClipperIsUsingWindowException(
message : String
);

Parameters

message System.String.


ClipperIsUsingWindowException.ClipperIsUsingWindowException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ClipperIsUsingWindowException();
Managed C++ | public: ClipperIsUsingWindowException();
JScript .NET | public function ClipperIsUsingWindowException();


Microsoft.DirectX.DirectDraw.ColorControl

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorControl object allows you to get and set color controls. Deprecated.

Definition

Visual Basic .NET Public Class ColorControl
Inherits MarshalByRefObject
Implements IDisposable
C# public class ColorControl : MarshalByRefObject,
IDisposable
Managed C++ public __gc class ColorControl : public MarshalByRefObject,
IDisposable
JScript .NET public class ColorControl extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
ColorControl
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ColorControls
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Values to be applied to the specified surface. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ColorControl

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorControl.ColorControl(Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.ColorControl Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal surf As Surface _
)
C# public ColorControl(
Surface surf
);
Managed C++ public: ColorControl(
Surface *surf
);
JScript .NET public function ColorControl(
surf : Surface
);

Parameters

surf Microsoft.DirectX.DirectDraw.Surface.


ColorControl.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • ColorControl.Disposed
  • ColorControl.Disposing


ColorControl.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


ColorControl.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ColorControl();
Managed C++ | ~ColorControl();
JScript .NET | protected override function Finalize();


ColorControl.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


ColorControl.op_Equality(ColorControl,ColorControl)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As ColorControl, _
ByVal right As ColorControl _
) As Boolean
C# public static bool op_Equality(
ColorControl left,
ColorControl right
);
Managed C++ public: static bool op_Equality(
ColorControl *left,
ColorControl *right
);
JScript .NET public static function op_Equality(
left : ColorControl,
right : ColorControl
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.ColorControl. The ColorControl structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.ColorControl. The ColorControl structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


ColorControl.op_Inequality(ColorControl,ColorControl)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As ColorControl, _
ByVal right As ColorControl _
) As Boolean
C# public static bool op_Inequality(
ColorControl left,
ColorControl right
);
Managed C++ public: static bool op_Inequality(
ColorControl *left,
ColorControl *right
);
JScript .NET public static function op_Inequality(
left : ColorControl,
right : ColorControl
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.ColorControl. The ColorControl structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.ColorControl. The ColorControl structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


ColorControl.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


ColorControl.ColorControls

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.ColorControls Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Values to be applied to the specified surface. Deprecated.

Definition

Visual Basic .NET | Public Property ColorControls As ColorControlObject
C# | public ColorControlObject ColorControls { get; set; }
Managed C++ public: __property ColorControlObject get_ColorControls();
public: __property void set_ColorControls(ColorControlObject);
JScript .NET public function get ColorControls() : ColorControlObject
public function set ColorControls(ColorControlObject);

Property Value

Microsoft.DirectX.DirectDraw.ColorControlObject .

This property is read/write.


ColorControl.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


ColorControl.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControl.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a ColorControl.Disposing event, use the following code.

colorControl.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectDraw.ColorKeyNotSetException

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyNotSetException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No source color key is specified for this operation. Deprecated.

Definition

Visual Basic .NET Public Class ColorKeyNotSetException
Inherits GraphicsException
C# | public class ColorKeyNotSetException : GraphicsException
Managed C++ | public __gc class ColorKeyNotSetException : public GraphicsException
JScript .NET | public class ColorKeyNotSetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ColorKeyNotSetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ColorKeyNotSetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorKeyNotSetException.ColorKeyNotSetException

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ColorKeyNotSetException();
protected ColorKeyNotSetException(SerializationInfo, StreamingContext);
public ColorKeyNotSetException(string);
public ColorKeyNotSetException(string, Exception);


ColorKeyNotSetException.ColorKeyNotSetException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ColorKeyNotSetException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ColorKeyNotSetException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ColorKeyNotSetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ColorKeyNotSetException.ColorKeyNotSetException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ColorKeyNotSetException(
string message,
Exception inner
);
Managed C++ public: ColorKeyNotSetException(
String *message,
Exception *inner
);
JScript .NET public function ColorKeyNotSetException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ColorKeyNotSetException.ColorKeyNotSetException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ColorKeyNotSetException(
string message
);
Managed C++ public: ColorKeyNotSetException(
String *message
);
JScript .NET public function ColorKeyNotSetException(
message : String
);

Parameters

message System.String.


ColorKeyNotSetException.ColorKeyNotSetException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ColorKeyNotSetException();
Managed C++ | public: ColorKeyNotSetException();
JScript .NET | public function ColorKeyNotSetException();


Microsoft.DirectX.DirectDraw.CurrentlyNotAvailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

CurrentlyNotAvailableException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No support is currently available. Deprecated.

Definition

Visual Basic .NET Public Class CurrentlyNotAvailableException
Inherits GraphicsException
C# | public class CurrentlyNotAvailableException : GraphicsException
Managed C++ | public __gc class CurrentlyNotAvailableException : public GraphicsException
JScript .NET | public class CurrentlyNotAvailableException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CurrentlyNotAvailableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CurrentlyNotAvailableException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CurrentlyNotAvailableException.CurrentlyNotAvailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CurrentlyNotAvailableException();
protected CurrentlyNotAvailableException(SerializationInfo, StreamingContext);
public CurrentlyNotAvailableException(string);
public CurrentlyNotAvailableException(string, Exception);


CurrentlyNotAvailableException.CurrentlyNotAvailableException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CurrentlyNotAvailableException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CurrentlyNotAvailableException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CurrentlyNotAvailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CurrentlyNotAvailableException.CurrentlyNotAvailableException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CurrentlyNotAvailableException(
string message,
Exception inner
);
Managed C++ public: CurrentlyNotAvailableException(
String *message,
Exception *inner
);
JScript .NET public function CurrentlyNotAvailableException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CurrentlyNotAvailableException.CurrentlyNotAvailableException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CurrentlyNotAvailableException(
string message
);
Managed C++ public: CurrentlyNotAvailableException(
String *message
);
JScript .NET public function CurrentlyNotAvailableException(
message : String
);

Parameters

message System.String.


CurrentlyNotAvailableException.CurrentlyNotAvailableException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CurrentlyNotAvailableException();
Managed C++ | public: CurrentlyNotAvailableException();
JScript .NET | public function CurrentlyNotAvailableException();


Microsoft.DirectX.DirectDraw.DDrawHelper

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Utility class Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class DDrawHelper
Inherits Object
C# | public sealed class DDrawHelper : Object
Managed C++ | public __gc __sealed class DDrawHelper : public Object
JScript .NET | public class DDrawHelper extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic .NET) KeyHardwareDescription
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyHardwareDriverName
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) PathHardware
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
DDrawHelper
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) GetWhqlDay
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Day. Deprecated.
static (Shared in Visual Basic .NET) GetWhqlMonth
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Month. Deprecated.
static (Shared in Visual Basic .NET) GetWhqlYear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Year. Deprecated.

Inheritance Hierarchy

Object Leave Site
DDrawHelper

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DDrawHelper.DDrawHelper()

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper.DDrawHelper Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DDrawHelper();
Managed C++ | public: DDrawHelper();
JScript .NET | public function DDrawHelper();


DDrawHelper.GetWhqlDay(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper.GetWhqlDay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Day. Deprecated.

Definition

Visual Basic .NET Public Shared Function GetWhqlDay( _
ByVal whqlLevel As Integer _
) As Integer
C# public static int GetWhqlDay(
int whqlLevel
);
Managed C++ public: static int GetWhqlDay(
int whqlLevel
);
JScript .NET public static function GetWhqlDay(
whqlLevel : int
) : int;

Parameters

whqlLevel System.Int32.

Return Value

System.Int32 .


DDrawHelper.GetWhqlMonth(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper.GetWhqlMonth Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Month. Deprecated.

Definition

Visual Basic .NET Public Shared Function GetWhqlMonth( _
ByVal whqlLevel As Integer _
) As Integer
C# public static int GetWhqlMonth(
int whqlLevel
);
Managed C++ public: static int GetWhqlMonth(
int whqlLevel
);
JScript .NET public static function GetWhqlMonth(
whqlLevel : int
) : int;

Parameters

whqlLevel System.Int32.

Return Value

System.Int32 .


DDrawHelper.GetWhqlYear(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper.GetWhqlYear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Year. Deprecated.

Definition

Visual Basic .NET Public Shared Function GetWhqlYear( _
ByVal whqlLevel As Integer _
) As Integer
C# public static int GetWhqlYear(
int whqlLevel
);
Managed C++ public: static int GetWhqlYear(
int whqlLevel
);
JScript .NET public static function GetWhqlYear(
whqlLevel : int
) : int;

Parameters

whqlLevel System.Int32.

Return Value

System.Int32 .


DDrawHelper.KeyHardwareDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper.KeyHardwareDescription Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyHardwareDescription As String
C# | public static String KeyHardwareDescription;
Managed C++ | public: static String KeyHardwareDescription;
JScript .NET | public static var KeyHardwareDescription : String

Field Value

System.String .

This field is read/write.


DDrawHelper.KeyHardwareDriverName

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper.KeyHardwareDriverName Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyHardwareDriverName As String
C# | public static String KeyHardwareDriverName;
Managed C++ | public: static String KeyHardwareDriverName;
JScript .NET | public static var KeyHardwareDriverName : String

Field Value

System.String .

This field is read/write.


DDrawHelper.PathHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

DDrawHelper.PathHardware Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared PathHardware As String
C# | public static String PathHardware;
Managed C++ | public: static String PathHardware;
JScript .NET | public static var PathHardware : String

Field Value

System.String .

This field is read/write.


Microsoft.DirectX.DirectDraw.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Device Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Device object to create DirectDraw objects and work with system-level variables. Deprecated.

Definition

Visual Basic .NET Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# public class Device : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Device : public MarshalByRefObject,
IDisposable
JScript .NET public class Device extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Device
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
FlipToGdiSurface
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface that the GDI writes to the primary surface. Deprecated.
GetAvailableVideoMemory
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the total amount of display memory available and the amount of display memory currently free for a given type of surface. Deprecated.
GetCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills in the capabilities of the device driver for the hardware and the hardware emulation layer (HEL). Deprecated.
GetDeviceInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains information about the driver. This method can be used, with caution, to recognize specific hardware installations to implement workarounds for poor driver or chipset behavior. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetSurfaceFromDC
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Surface object for a surface, based on its GDI device context handle. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RestoreAllSurfaces
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores all the surfaces created for the DirectDraw object, in the order that they were created. Deprecated.
RestoreDisplayMode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the mode of the display device hardware for the primary surface to what it was before the SetDisplayMode method was called. Exclusive-level access is required to use this method. Deprecated.
SetCooperativeLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.
SetDisplayMode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the mode of the display-device hardware. Deprecated.
TestCooperativeLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reports the current cooperative-level status of the device for a windowed or full-screen application. Deprecated.
WaitForVerticalBlank
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Helps the application synchronize itself with the vertical-blank interval. Deprecated.

Properties

Property Description
DeviceInformation
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.
DisplayMode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current display mode. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
FourCCCodes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the FOURCC codes supported by the DirectDraw object. Deprecated.
GdiSurface
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DirectDrawSurface object that currently represents the surface memory that GDI is treating as the primary surface. Deprecated.
HardwareCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware. Deprecated.
HardwareEmulationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware emulation layer (HEL). Deprecated.
MonitorFrequency
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the frequency of the monitor being driven by the DirectDraw object. Deprecated.
ScanLine
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the scan line that is currently being drawn on the monitor. Deprecated.
VerticalBlankStatus
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the status of the vertical blank. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Device.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Device();
public Device(CreateFlags);
public Device(Guid);


Device.Device(CreateFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As CreateFlags _
)
C# public Device(
CreateFlags flags
);
Managed C++ public: Device(
CreateFlags flags
);
JScript .NET public function Device(
flags : CreateFlags
);

Parameters

flags Microsoft.DirectX.DirectDraw.CreateFlags.


Device.Device(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal guidDevice As Guid _
)
C# public Device(
Guid guidDevice
);
Managed C++ public: Device(
Guid guidDevice
);
JScript .NET public function Device(
guidDevice : Guid
);

Parameters

guidDevice System.Guid.


Device.Device()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Device();
Managed C++ | public: Device();
JScript .NET | public function Device();


Device.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Device.Disposed
  • Device.Disposing


Device.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Device.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Device();
Managed C++ | ~Device();
JScript .NET | protected override function Finalize();


Device.FlipToGdiSurface()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.FlipToGdiSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface that the GDI writes to the primary surface. Deprecated.

Definition

Visual Basic .NET | Public Sub FlipToGdiSurface()
C# | public void FlipToGdiSurface();
Managed C++ | public: void FlipToGdiSurface();
JScript .NET | public function FlipToGdiSurface();


Device.GetAvailableVideoMemory(SurfaceCaps,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetAvailableVideoMemory Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the total amount of display memory available and the amount of display memory currently free for a given type of surface. Deprecated.

Definition

Visual Basic .NET Public Sub GetAvailableVideoMemory( _
ByVal caps As SurfaceCaps, _
ByRef totalMem As Integer, _
ByRef freeMem As Integer _
)
C# public void GetAvailableVideoMemory(
SurfaceCaps caps,
out int totalMem,
out int freeMem
);
Managed C++ public: void GetAvailableVideoMemory(
SurfaceCaps *caps,
int *totalMem,
int *freeMem
);
JScript .NET public function GetAvailableVideoMemory(
caps : SurfaceCaps,
totalMem : int,
freeMem : int
);

Parameters

caps | Microsoft.DirectX.DirectDraw.SurfaceCaps.
totalMem | System.Int32.
freeMem | System.Int32.


Device.GetCaps()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills in the capabilities of the device driver for the hardware and the hardware emulation layer (HEL). Deprecated.

Definition

Visual Basic .NET | Public Function GetCaps() As GetCapsStruct
C# | public GetCapsStruct GetCaps();
Managed C++ | public: GetCapsStruct GetCaps();
JScript .NET | public function GetCaps() : GetCapsStruct;

Return Value

Microsoft.DirectX.DirectDraw.GetCapsStruct .


Device.GetDeviceInformation(GetDeviceFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetDeviceInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains information about the driver. This method can be used, with caution, to recognize specific hardware installations to implement workarounds for poor driver or chipset behavior. Deprecated.

Definition

Visual Basic .NET Public Function GetDeviceInformation( _
ByVal flags As GetDeviceFlags _
) As DeviceIdentifier
C# public DeviceIdentifier GetDeviceInformation(
GetDeviceFlags flags
);
Managed C++ public: DeviceIdentifier GetDeviceInformation(
GetDeviceFlags flags
);
JScript .NET public function GetDeviceInformation(
flags : GetDeviceFlags
) : DeviceIdentifier;

Parameters

flags Microsoft.DirectX.DirectDraw.GetDeviceFlags.

Return Value

Microsoft.DirectX.DirectDraw.DeviceIdentifier .


Device.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Device.GetSurfaceFromDC(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetSurfaceFromDC Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Surface object for a surface, based on its GDI device context handle. Deprecated.

Definition

Visual Basic .NET Public Function GetSurfaceFromDC( _
ByVal dcHandle As IntPtr _
) As Surface
C# public Surface GetSurfaceFromDC(
IntPtr dcHandle
);
Managed C++ public: Surface* GetSurfaceFromDC(
IntPtr dcHandle
);
JScript .NET public function GetSurfaceFromDC(
dcHandle : IntPtr
) : Surface;

Parameters

dcHandle System.IntPtr.

Return Value

Microsoft.DirectX.DirectDraw.Surface .


Device.op_Equality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
Managed C++ public: static bool op_Equality(
Device *left,
Device *right
);
JScript .NET public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Device. The Device structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.Device. The Device structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Device.op_Inequality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
Managed C++ public: static bool op_Inequality(
Device *left,
Device *right
);
JScript .NET public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Device. The Device structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.Device. The Device structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Device.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Device.RestoreAllSurfaces()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.RestoreAllSurfaces Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores all the surfaces created for the DirectDraw object, in the order that they were created. Deprecated.

Definition

Visual Basic .NET | Public Sub RestoreAllSurfaces()
C# | public void RestoreAllSurfaces();
Managed C++ | public: void RestoreAllSurfaces();
JScript .NET | public function RestoreAllSurfaces();


Device.RestoreDisplayMode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.RestoreDisplayMode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the mode of the display device hardware for the primary surface to what it was before the SetDisplayMode method was called. Exclusive-level access is required to use this method. Deprecated.

Definition

Visual Basic .NET | Public Sub RestoreDisplayMode()
C# | public void RestoreDisplayMode();
Managed C++ | public: void RestoreDisplayMode();
JScript .NET | public function RestoreDisplayMode();


Device.SetCooperativeLevel(Control,CooperativeLevelFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.

Definition

Visual Basic .NET Public Sub SetCooperativeLevel( _
ByVal parent As Control, _
ByVal flags As CooperativeLevelFlags _
)
C# public void SetCooperativeLevel(
Control parent,
CooperativeLevelFlags flags
);
Managed C++ public: void SetCooperativeLevel(
Control *parent,
CooperativeLevelFlags flags
);
JScript .NET public function SetCooperativeLevel(
parent : Control,
flags : CooperativeLevelFlags
);

Parameters

parent | System.Windows.Forms.Control.
flags | Microsoft.DirectX.DirectDraw.CooperativeLevelFlags.


Device.SetDisplayMode(Int32,Int32,Int32,Int32,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetDisplayMode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the mode of the display-device hardware. Deprecated.

Definition

Visual Basic .NET Public Sub SetDisplayMode( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal bitPerPixel As Integer, _
ByVal refreshRate As Integer, _
ByVal standardVgaMode As Boolean _
)
C# public void SetDisplayMode(
int width,
int height,
int bitPerPixel,
int refreshRate,
bool standardVgaMode
);
Managed C++ public: void SetDisplayMode(
int width,
int height,
int bitPerPixel,
int refreshRate,
bool standardVgaMode
);
JScript .NET public function SetDisplayMode(
width : int,
height : int,
bitPerPixel : int,
refreshRate : int,
standardVgaMode : boolean
);

Parameters

width | System.Int32.
height | System.Int32.
bitPerPixel | System.Int32.
refreshRate | System.Int32.
standardVgaMode | System.Boolean.


Device.TestCooperativeLevel()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.TestCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reports the current cooperative-level status of the device for a windowed or full-screen application. Deprecated.

Definition

Visual Basic .NET | Public Function TestCooperativeLevel() As Boolean
C# | public bool TestCooperativeLevel();
Managed C++ | public: bool TestCooperativeLevel();
JScript .NET | public function TestCooperativeLevel() : boolean;

Return Value

System.Boolean .


Device.WaitForVerticalBlank(WaitVbFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.WaitForVerticalBlank Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Helps the application synchronize itself with the vertical-blank interval. Deprecated.

Definition

Visual Basic .NET Public Sub WaitForVerticalBlank( _
ByVal flags As WaitVbFlags _
)
C# public void WaitForVerticalBlank(
WaitVbFlags flags
);
Managed C++ public: void WaitForVerticalBlank(
WaitVbFlags flags
);
JScript .NET public function WaitForVerticalBlank(
flags : WaitVbFlags
);

Parameters

flags Microsoft.DirectX.DirectDraw.WaitVbFlags.


Device.DeviceInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DeviceInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceInformation As DeviceIdentifier
C# | public DeviceIdentifier DeviceInformation { get; }
Managed C++ | public: __property DeviceIdentifier get_DeviceInformation();
JScript .NET | public function get DeviceInformation() : DeviceIdentifier

Property Value

Microsoft.DirectX.DirectDraw.DeviceIdentifier .

This property is read-only.


Device.DisplayMode

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DisplayMode Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current display mode. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DisplayMode As SurfaceDescription
C# | public SurfaceDescription DisplayMode { get; }
Managed C++ | public: __property SurfaceDescription* get_DisplayMode();
JScript .NET | public function get DisplayMode() : SurfaceDescription

Property Value

Microsoft.DirectX.DirectDraw.SurfaceDescription .

This property is read-only.


Device.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Device.FourCCCodes

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.FourCCCodes Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the FOURCC codes supported by the DirectDraw object. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property FourCCCodes As Integer()
C# | public int[] FourCCCodes { get; }
Managed C++ | public: __property int get_FourCCCodes();
JScript .NET | public function get FourCCCodes() : int[]

Property Value

System.Int32[] .

This property is read-only.


Device.GdiSurface

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GdiSurface Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DirectDrawSurface object that currently represents the surface memory that GDI is treating as the primary surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GdiSurface As Surface
C# | public Surface GdiSurface { get; }
Managed C++ | public: __property Surface* get_GdiSurface();
JScript .NET | public function get GdiSurface() : Surface

Property Value

Microsoft.DirectX.DirectDraw.Surface .

This property is read-only.


Device.HardwareCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.HardwareCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property HardwareCaps As Caps
C# | public Caps HardwareCaps { get; }
Managed C++ | public: __property Caps get_HardwareCaps();
JScript .NET | public function get HardwareCaps() : Caps

Property Value

Microsoft.DirectX.DirectDraw.Caps .

This property is read-only.


Device.HardwareEmulationCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.HardwareEmulationCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware emulation layer (HEL). Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property HardwareEmulationCaps As Caps
C# | public Caps HardwareEmulationCaps { get; }
Managed C++ | public: __property Caps get_HardwareEmulationCaps();
JScript .NET | public function get HardwareEmulationCaps() : Caps

Property Value

Microsoft.DirectX.DirectDraw.Caps .

This property is read-only.


Device.MonitorFrequency

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.MonitorFrequency Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the frequency of the monitor being driven by the DirectDraw object. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MonitorFrequency As Integer
C# | public int MonitorFrequency { get; }
Managed C++ | public: __property int get_MonitorFrequency();
JScript .NET | public function get MonitorFrequency() : int

Property Value

System.Int32 .

This property is read-only.


Device.ScanLine

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ScanLine Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the scan line that is currently being drawn on the monitor. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ScanLine As Integer
C# | public int ScanLine { get; }
Managed C++ | public: __property int get_ScanLine();
JScript .NET | public function get ScanLine() : int

Property Value

System.Int32 .

This property is read-only.


Device.VerticalBlankStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.VerticalBlankStatus Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the status of the vertical blank. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VerticalBlankStatus As Boolean
C# | public bool VerticalBlankStatus { get; }
Managed C++ | public: __property bool get_VerticalBlankStatus();
JScript .NET | public function get VerticalBlankStatus() : boolean

Property Value

System.Boolean .

This property is read-only.


Device.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.Disposing event, use the following code.

device.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectDraw.DeviceDoesNotOwnSurfaceException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceDoesNotOwnSurfaceException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Surfaces created by one DirectDraw device cannot be used directly by another DirectDraw device. Deprecated.

Definition

Visual Basic .NET Public Class DeviceDoesNotOwnSurfaceException
Inherits GraphicsException
C# | public class DeviceDoesNotOwnSurfaceException : GraphicsException
Managed C++ | public __gc class DeviceDoesNotOwnSurfaceException : public GraphicsException
JScript .NET | public class DeviceDoesNotOwnSurfaceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceDoesNotOwnSurfaceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DeviceDoesNotOwnSurfaceException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DeviceDoesNotOwnSurfaceException();
protected DeviceDoesNotOwnSurfaceException(SerializationInfo, StreamingContext);
public DeviceDoesNotOwnSurfaceException(string);
public DeviceDoesNotOwnSurfaceException(string, Exception);


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceDoesNotOwnSurfaceException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DeviceDoesNotOwnSurfaceException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DeviceDoesNotOwnSurfaceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceDoesNotOwnSurfaceException(
string message,
Exception inner
);
Managed C++ public: DeviceDoesNotOwnSurfaceException(
String *message,
Exception *inner
);
JScript .NET public function DeviceDoesNotOwnSurfaceException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DeviceDoesNotOwnSurfaceException(
string message
);
Managed C++ public: DeviceDoesNotOwnSurfaceException(
String *message
);
JScript .NET public function DeviceDoesNotOwnSurfaceException(
message : String
);

Parameters

message System.String.


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceDoesNotOwnSurfaceException();
Managed C++ | public: DeviceDoesNotOwnSurfaceException();
JScript .NET | public function DeviceDoesNotOwnSurfaceException();


Microsoft.DirectX.DirectDraw.DevicesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of devices. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class DevicesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class DevicesCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class DevicesCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class DevicesCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DevicesCollection
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Inheritance Hierarchy

Object Leave Site
DevicesCollection

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DevicesCollection.DevicesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.DevicesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DevicesCollection();
public DevicesCollection(GetDevicesFlags);


DevicesCollection.DevicesCollection(GetDevicesFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.DevicesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As GetDevicesFlags _
)
C# public DevicesCollection(
GetDevicesFlags flags
);
Managed C++ public: DevicesCollection(
GetDevicesFlags flags
);
JScript .NET public function DevicesCollection(
flags : GetDevicesFlags
);

Parameters

flags Microsoft.DirectX.DirectDraw.GetDevicesFlags.


DevicesCollection.DevicesCollection()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.DevicesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DevicesCollection();
Managed C++ | public: DevicesCollection();
JScript .NET | public function DevicesCollection();


DevicesCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


DevicesCollection.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean .


DevicesCollection.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();


DevicesCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


DevicesCollection.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object .

This property is read-only.


Microsoft.DirectX.DirectDraw.DisplayModesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of display modes. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class DisplayModesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class DisplayModesCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class DisplayModesCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class DisplayModesCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DisplayModesCollection
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Inheritance Hierarchy

Object Leave Site
DisplayModesCollection

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisplayModesCollection.DisplayModesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.DisplayModesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DisplayModesCollection(Device);
public DisplayModesCollection(GetDisplayModeFlags, SurfaceDescription, Device);
public DisplayModesCollection(SurfaceDescription, Device);


DisplayModesCollection.DisplayModesCollection(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.DisplayModesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dev As Device _
)
C# public DisplayModesCollection(
Device dev
);
Managed C++ public: DisplayModesCollection(
Device *dev
);
JScript .NET public function DisplayModesCollection(
dev : Device
);

Parameters

dev Microsoft.DirectX.DirectDraw.Device.


DisplayModesCollection.DisplayModesCollection(SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.DisplayModesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public DisplayModesCollection(
SurfaceDescription desc,
Device dev
);
Managed C++ public: DisplayModesCollection(
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function DisplayModesCollection(
desc : SurfaceDescription,
dev : Device
);

Parameters

desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


DisplayModesCollection.DisplayModesCollection(GetDisplayModeFlags,SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.DisplayModesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As GetDisplayModeFlags, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public DisplayModesCollection(
GetDisplayModeFlags flags,
SurfaceDescription desc,
Device dev
);
Managed C++ public: DisplayModesCollection(
GetDisplayModeFlags flags,
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function DisplayModesCollection(
flags : GetDisplayModeFlags,
desc : SurfaceDescription,
dev : Device
);

Parameters

flags | Microsoft.DirectX.DirectDraw.GetDisplayModeFlags.
desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


DisplayModesCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


DisplayModesCollection.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean .


DisplayModesCollection.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();


DisplayModesCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


DisplayModesCollection.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

DisplayModesCollection.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object .

This property is read-only.


Microsoft.DirectX.DirectDraw.DrawFastCannotClipException

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFastCannotClipException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A DirectDrawClipper object is attached to a source surface that has passed into a call to the DrawFast method. Deprecated.

Definition

Visual Basic .NET Public Class DrawFastCannotClipException
Inherits GraphicsException
C# | public class DrawFastCannotClipException : GraphicsException
Managed C++ | public __gc class DrawFastCannotClipException : public GraphicsException
JScript .NET | public class DrawFastCannotClipException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DrawFastCannotClipException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DrawFastCannotClipException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrawFastCannotClipException.DrawFastCannotClipException

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DrawFastCannotClipException();
protected DrawFastCannotClipException(SerializationInfo, StreamingContext);
public DrawFastCannotClipException(string);
public DrawFastCannotClipException(string, Exception);


DrawFastCannotClipException.DrawFastCannotClipException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DrawFastCannotClipException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DrawFastCannotClipException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DrawFastCannotClipException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DrawFastCannotClipException.DrawFastCannotClipException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DrawFastCannotClipException(
string message,
Exception inner
);
Managed C++ public: DrawFastCannotClipException(
String *message,
Exception *inner
);
JScript .NET public function DrawFastCannotClipException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DrawFastCannotClipException.DrawFastCannotClipException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DrawFastCannotClipException(
string message
);
Managed C++ public: DrawFastCannotClipException(
String *message
);
JScript .NET public function DrawFastCannotClipException(
message : String
);

Parameters

message System.String.


DrawFastCannotClipException.DrawFastCannotClipException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DrawFastCannotClipException();
Managed C++ | public: DrawFastCannotClipException();
JScript .NET | public function DrawFastCannotClipException();


Microsoft.DirectX.DirectDraw.ExclusiveModeAlreadySetException

Microsoft DirectX 9.0 SDK Update (October 2004)

ExclusiveModeAlreadySetException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set the cooperative level when it was already set to exclusive. Deprecated.

Definition

Visual Basic .NET Public Class ExclusiveModeAlreadySetException
Inherits GraphicsException
C# | public class ExclusiveModeAlreadySetException : GraphicsException
Managed C++ | public __gc class ExclusiveModeAlreadySetException : public GraphicsException
JScript .NET | public class ExclusiveModeAlreadySetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ExclusiveModeAlreadySetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ExclusiveModeAlreadySetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException

Microsoft DirectX 9.0 SDK Update (October 2004)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ExclusiveModeAlreadySetException();
protected ExclusiveModeAlreadySetException(SerializationInfo, StreamingContext);
public ExclusiveModeAlreadySetException(string);
public ExclusiveModeAlreadySetException(string, Exception);


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ExclusiveModeAlreadySetException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ExclusiveModeAlreadySetException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ExclusiveModeAlreadySetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ExclusiveModeAlreadySetException(
string message,
Exception inner
);
Managed C++ public: ExclusiveModeAlreadySetException(
String *message,
Exception *inner
);
JScript .NET public function ExclusiveModeAlreadySetException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ExclusiveModeAlreadySetException(
string message
);
Managed C++ public: ExclusiveModeAlreadySetException(
String *message
);
JScript .NET public function ExclusiveModeAlreadySetException(
message : String
);

Parameters

message System.String.


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ExclusiveModeAlreadySetException();
Managed C++ | public: ExclusiveModeAlreadySetException();
JScript .NET | public function ExclusiveModeAlreadySetException();


Microsoft.DirectX.DirectDraw.ExpiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

ExpiredException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data has expired and is therefore no longer valid. Deprecated.

Definition

Visual Basic .NET Public Class ExpiredException
Inherits GraphicsException
C# | public class ExpiredException : GraphicsException
Managed C++ | public __gc class ExpiredException : public GraphicsException
JScript .NET | public class ExpiredException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ExpiredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ExpiredException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ExpiredException.ExpiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

ExpiredException.ExpiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ExpiredException();
protected ExpiredException(SerializationInfo, StreamingContext);
public ExpiredException(string);
public ExpiredException(string, Exception);


ExpiredException.ExpiredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ExpiredException.ExpiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ExpiredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ExpiredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ExpiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ExpiredException.ExpiredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ExpiredException.ExpiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ExpiredException(
string message,
Exception inner
);
Managed C++ public: ExpiredException(
String *message,
Exception *inner
);
JScript .NET public function ExpiredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ExpiredException.ExpiredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ExpiredException.ExpiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ExpiredException(
string message
);
Managed C++ public: ExpiredException(
String *message
);
JScript .NET public function ExpiredException(
message : String
);

Parameters

message System.String.


ExpiredException.ExpiredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ExpiredException.ExpiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ExpiredException();
Managed C++ | public: ExpiredException();
JScript .NET | public function ExpiredException();


Microsoft.DirectX.DirectDraw.GammaControl

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the GammaControl object to adjust the red, green, and blue gamma ramp levels of the primary surface. Deprecated.

Definition

Visual Basic .NET Public Class GammaControl
Inherits MarshalByRefObject
Implements IDisposable
C# public class GammaControl : MarshalByRefObject,
IDisposable
Managed C++ public __gc class GammaControl : public MarshalByRefObject,
IDisposable
JScript .NET public class GammaControl extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GammaControl
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetGammaRamp
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
GammaRamp
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
GammaControl

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GammaControl.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • GammaControl.Disposed
  • GammaControl.Disposing


GammaControl.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


GammaControl.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~GammaControl();
Managed C++ | ~GammaControl();
JScript .NET | protected override function Finalize();


GammaControl.GammaControl(Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.GammaControl Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal surf As Surface _
)
C# public GammaControl(
Surface surf
);
Managed C++ public: GammaControl(
Surface *surf
);
JScript .NET public function GammaControl(
surf : Surface
);

Parameters

surf Microsoft.DirectX.DirectDraw.Surface.


GammaControl.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


GammaControl.op_Equality(GammaControl,GammaControl)

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As GammaControl, _
ByVal right As GammaControl _
) As Boolean
C# public static bool op_Equality(
GammaControl left,
GammaControl right
);
Managed C++ public: static bool op_Equality(
GammaControl *left,
GammaControl *right
);
JScript .NET public static function op_Equality(
left : GammaControl,
right : GammaControl
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.GammaControl. The GammaControl structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.GammaControl. The GammaControl structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


GammaControl.op_Inequality(GammaControl,GammaControl)

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As GammaControl, _
ByVal right As GammaControl _
) As Boolean
C# public static bool op_Inequality(
GammaControl left,
GammaControl right
);
Managed C++ public: static bool op_Inequality(
GammaControl *left,
GammaControl *right
);
JScript .NET public static function op_Inequality(
left : GammaControl,
right : GammaControl
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.GammaControl. The GammaControl structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.GammaControl. The GammaControl structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


GammaControl.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


GammaControl.SetGammaRamp(Boolean,GammaRamps)

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.SetGammaRamp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Definition

Visual Basic .NET Public Sub SetGammaRamp( _
ByVal calibrate As Boolean, _
ByVal ramps As GammaRamps _
)
C# public void SetGammaRamp(
bool calibrate,
GammaRamps ramps
);
Managed C++ public: void SetGammaRamp(
bool calibrate,
GammaRamps ramps
);
JScript .NET public function SetGammaRamp(
calibrate : boolean,
ramps : GammaRamps
);

Parameters

calibrate | System.Boolean.
ramps | Microsoft.DirectX.DirectDraw.GammaRamps.


GammaControl.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


GammaControl.GammaRamp

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.GammaRamp Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Definition

Visual Basic .NET | Public Property GammaRamp As GammaRamps
C# | public GammaRamps GammaRamp { get; set; }
Managed C++ public: __property GammaRamps get_GammaRamp();
public: __property void set_GammaRamp(GammaRamps);
JScript .NET public function get GammaRamp() : GammaRamps
public function set GammaRamp(GammaRamps);

Property Value

Microsoft.DirectX.DirectDraw.GammaRamps .

This property is read/write.


GammaControl.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaControl.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a GammaControl.Disposing event, use the following code.

gammaControl.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectDraw.GraphicsAlreadyCreatedException

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsAlreadyCreatedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A device context (DC) has already been returned for this surface. Only one DC can be retrieved for each surface. Deprecated.

Definition

Visual Basic .NET Public Class GraphicsAlreadyCreatedException
Inherits GraphicsException
C# | public class GraphicsAlreadyCreatedException : GraphicsException
Managed C++ | public __gc class GraphicsAlreadyCreatedException : public GraphicsException
JScript .NET | public class GraphicsAlreadyCreatedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
GraphicsAlreadyCreatedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
GraphicsAlreadyCreatedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public GraphicsAlreadyCreatedException();
protected GraphicsAlreadyCreatedException(SerializationInfo, StreamingContext);
public GraphicsAlreadyCreatedException(string);
public GraphicsAlreadyCreatedException(string, Exception);


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GraphicsAlreadyCreatedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: GraphicsAlreadyCreatedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function GraphicsAlreadyCreatedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GraphicsAlreadyCreatedException(
string message,
Exception inner
);
Managed C++ public: GraphicsAlreadyCreatedException(
String *message,
Exception *inner
);
JScript .NET public function GraphicsAlreadyCreatedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public GraphicsAlreadyCreatedException(
string message
);
Managed C++ public: GraphicsAlreadyCreatedException(
String *message
);
JScript .NET public function GraphicsAlreadyCreatedException(
message : String
);

Parameters

message System.String.


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public GraphicsAlreadyCreatedException();
Managed C++ | public: GraphicsAlreadyCreatedException();
JScript .NET | public function GraphicsAlreadyCreatedException();


Microsoft.DirectX.DirectDraw.GraphicsException

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception class for all DirectDraw exceptions. Derives from DirectXException. Deprecated.

Definition

Visual Basic .NET Public Class GraphicsException
Inherits DirectXException
C# | public class GraphicsException : DirectXException
Managed C++ | public __gc class GraphicsException : public DirectXException
JScript .NET | public class GraphicsException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
GraphicsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotCloneException
CannotCreateDeviceContextException
CannotLockSurfaceException
CannotPageLockException
CannotPageUnlockException
CapsComplexRequiredException
ClipperIsUsingWindowException
ColorKeyNotSetException
CurrentlyNotAvailableException
DeviceDoesNotOwnSurfaceException
DrawFastCannotClipException
ExclusiveModeAlreadySetException
ExpiredException
GraphicsAlreadyCreatedException
HeightAlignException
ImplicitlyCreatedException
IncompatiblePrimaryException
InvalidCapsException
InvalidClipListException
InvalidDirectDrawGuidException
InvalidModeException
InvalidObjectException
InvalidPixelFormatException
InvalidPositionException
InvalidRectangleException
InvalidStreamException
InvalidSurfaceTypeException
LockedSurfacesException
MoreDataException
NewModeException
NoAlphaHardwareException
NoClipListException
NoClipperAttachedException
NoColorConversionHardwareException
NoColorKeyException
NoColorKeyHardwareException
NoCooperativeLevelSetException
NoDeviceContextException
NoDirectDrawHardwareException
NoDirectDrawSupportException
NoDrawHardwareException
NoDriverSupportException
NoEmulationException
NoExclusiveModeException
NoFlipHardwareException
NoFocusWindowException
NoGdiException
NoMirrorHardwareException
NoMonitorInformationException
NoNonLocalVideoMemoryException
NoOptimizeHardwareException
NoOverlayDestinationException
NoOverlayHardwareException
NoPaletteAttachedException
NoPaletteHardwareException
NoRasterOperationHardwareException
NoRotationHardwareException
NoStereoHardwareException
NoStretchHardwareException
NoSurfaceLeftException
Not4BitColorException
Not4BitColorIndexException
Not8BitColorException
NotAnOverlaySurfaceException
NotFlippableException
NotFoundException
NotLoadedException
NotLockedException
NotPageLockedException
NotPalettizedException
NoVideoSyncHardwareException
NoWindowException
OutOfCapsException
OutOfVideoMemoryException
OverlappingRectanglesException
OverlayCantClipException
OverlayColorKeyOnlyOneActiveException
OverlayNotVisibleException
PaletteBusyException
PrimarySurfaceAlreadyExistsException
RegionTooSmallException
SurfaceBusyException
SurfaceIsObscuredException
SurfaceLostException
SurfaceNotAttachedException
TestFinishedException
TooBigHeightException
TooBigSizeException
TooBigWidthException
UnsupportedException
UnsupportedFormatException
UnsupportedMaskException
UnsupportedModeException
VerticalBlankInProgressException
VideoNotActiveException
WasStillDrawingException
WindowAlreadySetException
WindowSubclassedException
WrongModeException
XAlignException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GraphicsException.GetExceptionFromResultInternal(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GetExceptionFromResultInternal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32.

Return Value

System.Exception .

Applies To

This object applies to a large number of classes.


GraphicsException.GraphicsException

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public GraphicsException();
protected GraphicsException(SerializationInfo, StreamingContext);
public GraphicsException(string);
public GraphicsException(string, Exception);


GraphicsException.GraphicsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GraphicsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: GraphicsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function GraphicsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


GraphicsException.GraphicsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GraphicsException(
string message,
Exception inner
);
Managed C++ public: GraphicsException(
String *message,
Exception *inner
);
JScript .NET public function GraphicsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


GraphicsException.GraphicsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public GraphicsException(
string message
);
Managed C++ public: GraphicsException(
String *message
);
JScript .NET public function GraphicsException(
message : String
);

Parameters

message System.String.


GraphicsException.GraphicsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsException.GraphicsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public GraphicsException();
Managed C++ | public: GraphicsException();
JScript .NET | public function GraphicsException();


Microsoft.DirectX.DirectDraw.HeightAlignException

Microsoft DirectX 9.0 SDK Update (October 2004)

HeightAlignException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height of the provided rectangle is not a multiple of the required alignment. Deprecated.

Definition

Visual Basic .NET Public Class HeightAlignException
Inherits GraphicsException
C# | public class HeightAlignException : GraphicsException
Managed C++ | public __gc class HeightAlignException : public GraphicsException
JScript .NET | public class HeightAlignException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
HeightAlignException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
HeightAlignException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HeightAlignException.HeightAlignException

Microsoft DirectX 9.0 SDK Update (October 2004)

HeightAlignException.HeightAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public HeightAlignException();
protected HeightAlignException(SerializationInfo, StreamingContext);
public HeightAlignException(string);
public HeightAlignException(string, Exception);


HeightAlignException.HeightAlignException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

HeightAlignException.HeightAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected HeightAlignException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: HeightAlignException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function HeightAlignException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


HeightAlignException.HeightAlignException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

HeightAlignException.HeightAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public HeightAlignException(
string message,
Exception inner
);
Managed C++ public: HeightAlignException(
String *message,
Exception *inner
);
JScript .NET public function HeightAlignException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


HeightAlignException.HeightAlignException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

HeightAlignException.HeightAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public HeightAlignException(
string message
);
Managed C++ public: HeightAlignException(
String *message
);
JScript .NET public function HeightAlignException(
message : String
);

Parameters

message System.String.


HeightAlignException.HeightAlignException()

Microsoft DirectX 9.0 SDK Update (October 2004)

HeightAlignException.HeightAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public HeightAlignException();
Managed C++ | public: HeightAlignException();
JScript .NET | public function HeightAlignException();


Microsoft.DirectX.DirectDraw.ImplicitlyCreatedException

Microsoft DirectX 9.0 SDK Update (October 2004)

ImplicitlyCreatedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface cannot be restored because it is an implicitly created surface. Deprecated.

Definition

Visual Basic .NET Public Class ImplicitlyCreatedException
Inherits GraphicsException
C# | public class ImplicitlyCreatedException : GraphicsException
Managed C++ | public __gc class ImplicitlyCreatedException : public GraphicsException
JScript .NET | public class ImplicitlyCreatedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ImplicitlyCreatedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ImplicitlyCreatedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ImplicitlyCreatedException.ImplicitlyCreatedException

Microsoft DirectX 9.0 SDK Update (October 2004)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ImplicitlyCreatedException();
protected ImplicitlyCreatedException(SerializationInfo, StreamingContext);
public ImplicitlyCreatedException(string);
public ImplicitlyCreatedException(string, Exception);


ImplicitlyCreatedException.ImplicitlyCreatedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ImplicitlyCreatedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ImplicitlyCreatedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ImplicitlyCreatedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ImplicitlyCreatedException.ImplicitlyCreatedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ImplicitlyCreatedException(
string message,
Exception inner
);
Managed C++ public: ImplicitlyCreatedException(
String *message,
Exception *inner
);
JScript .NET public function ImplicitlyCreatedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ImplicitlyCreatedException.ImplicitlyCreatedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ImplicitlyCreatedException(
string message
);
Managed C++ public: ImplicitlyCreatedException(
String *message
);
JScript .NET public function ImplicitlyCreatedException(
message : String
);

Parameters

message System.String.


ImplicitlyCreatedException.ImplicitlyCreatedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ImplicitlyCreatedException();
Managed C++ | public: ImplicitlyCreatedException();
JScript .NET | public function ImplicitlyCreatedException();


Microsoft.DirectX.DirectDraw.IncompatiblePrimaryException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatiblePrimaryException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface creation request does not match the existing primary surface. Deprecated.

Definition

Visual Basic .NET Public Class IncompatiblePrimaryException
Inherits GraphicsException
C# | public class IncompatiblePrimaryException : GraphicsException
Managed C++ | public __gc class IncompatiblePrimaryException : public GraphicsException
JScript .NET | public class IncompatiblePrimaryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompatiblePrimaryException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
IncompatiblePrimaryException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IncompatiblePrimaryException.IncompatiblePrimaryException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public IncompatiblePrimaryException();
protected IncompatiblePrimaryException(SerializationInfo, StreamingContext);
public IncompatiblePrimaryException(string);
public IncompatiblePrimaryException(string, Exception);


IncompatiblePrimaryException.IncompatiblePrimaryException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompatiblePrimaryException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: IncompatiblePrimaryException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function IncompatiblePrimaryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


IncompatiblePrimaryException.IncompatiblePrimaryException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompatiblePrimaryException(
string message,
Exception inner
);
Managed C++ public: IncompatiblePrimaryException(
String *message,
Exception *inner
);
JScript .NET public function IncompatiblePrimaryException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


IncompatiblePrimaryException.IncompatiblePrimaryException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public IncompatiblePrimaryException(
string message
);
Managed C++ public: IncompatiblePrimaryException(
String *message
);
JScript .NET public function IncompatiblePrimaryException(
message : String
);

Parameters

message System.String.


IncompatiblePrimaryException.IncompatiblePrimaryException()

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public IncompatiblePrimaryException();
Managed C++ | public: IncompatiblePrimaryException();
JScript .NET | public function IncompatiblePrimaryException();


Microsoft.DirectX.DirectDraw.InvalidCapsException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCapsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more of the capability bits passed to the callback function are incorrect. Deprecated.

Definition

Visual Basic .NET Public Class InvalidCapsException
Inherits GraphicsException
C# | public class InvalidCapsException : GraphicsException
Managed C++ | public __gc class InvalidCapsException : public GraphicsException
JScript .NET | public class InvalidCapsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCapsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidCapsException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidCapsException.InvalidCapsException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCapsException.InvalidCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidCapsException();
protected InvalidCapsException(SerializationInfo, StreamingContext);
public InvalidCapsException(string);
public InvalidCapsException(string, Exception);


InvalidCapsException.InvalidCapsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCapsException.InvalidCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidCapsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidCapsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidCapsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidCapsException.InvalidCapsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCapsException.InvalidCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidCapsException(
string message,
Exception inner
);
Managed C++ public: InvalidCapsException(
String *message,
Exception *inner
);
JScript .NET public function InvalidCapsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidCapsException.InvalidCapsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCapsException.InvalidCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidCapsException(
string message
);
Managed C++ public: InvalidCapsException(
String *message
);
JScript .NET public function InvalidCapsException(
message : String
);

Parameters

message System.String.


InvalidCapsException.InvalidCapsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCapsException.InvalidCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidCapsException();
Managed C++ | public: InvalidCapsException();
JScript .NET | public function InvalidCapsException();


Microsoft.DirectX.DirectDraw.InvalidClipListException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidClipListException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the provided clip list. Deprecated.

Definition

Visual Basic .NET Public Class InvalidClipListException
Inherits GraphicsException
C# | public class InvalidClipListException : GraphicsException
Managed C++ | public __gc class InvalidClipListException : public GraphicsException
JScript .NET | public class InvalidClipListException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidClipListException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidClipListException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidClipListException.InvalidClipListException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidClipListException.InvalidClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidClipListException();
protected InvalidClipListException(SerializationInfo, StreamingContext);
public InvalidClipListException(string);
public InvalidClipListException(string, Exception);


InvalidClipListException.InvalidClipListException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidClipListException.InvalidClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidClipListException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidClipListException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidClipListException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidClipListException.InvalidClipListException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidClipListException.InvalidClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidClipListException(
string message,
Exception inner
);
Managed C++ public: InvalidClipListException(
String *message,
Exception *inner
);
JScript .NET public function InvalidClipListException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidClipListException.InvalidClipListException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidClipListException.InvalidClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidClipListException(
string message
);
Managed C++ public: InvalidClipListException(
String *message
);
JScript .NET public function InvalidClipListException(
message : String
);

Parameters

message System.String.


InvalidClipListException.InvalidClipListException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidClipListException.InvalidClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidClipListException();
Managed C++ | public: InvalidClipListException();
JScript .NET | public function InvalidClipListException();


Microsoft.DirectX.DirectDraw.InvalidDirectDrawGuidException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDirectDrawGuidException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The globally unique identifier (Guid) passed to the constructor is not a valid DirectDraw driver identifier. Deprecated.

Definition

Visual Basic .NET Public Class InvalidDirectDrawGuidException
Inherits GraphicsException
C# | public class InvalidDirectDrawGuidException : GraphicsException
Managed C++ | public __gc class InvalidDirectDrawGuidException : public GraphicsException
JScript .NET | public class InvalidDirectDrawGuidException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDirectDrawGuidException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidDirectDrawGuidException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidDirectDrawGuidException();
protected InvalidDirectDrawGuidException(SerializationInfo, StreamingContext);
public InvalidDirectDrawGuidException(string);
public InvalidDirectDrawGuidException(string, Exception);


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDirectDrawGuidException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidDirectDrawGuidException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidDirectDrawGuidException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDirectDrawGuidException(
string message,
Exception inner
);
Managed C++ public: InvalidDirectDrawGuidException(
String *message,
Exception *inner
);
JScript .NET public function InvalidDirectDrawGuidException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidDirectDrawGuidException(
string message
);
Managed C++ public: InvalidDirectDrawGuidException(
String *message
);
JScript .NET public function InvalidDirectDrawGuidException(
message : String
);

Parameters

message System.String.


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidDirectDrawGuidException();
Managed C++ | public: InvalidDirectDrawGuidException();
JScript .NET | public function InvalidDirectDrawGuidException();


Microsoft.DirectX.DirectDraw.InvalidModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidModeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the requested mode. Deprecated.

Definition

Visual Basic .NET Public Class InvalidModeException
Inherits GraphicsException
C# | public class InvalidModeException : GraphicsException
Managed C++ | public __gc class InvalidModeException : public GraphicsException
JScript .NET | public class InvalidModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidModeException.InvalidModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidModeException.InvalidModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidModeException();
protected InvalidModeException(SerializationInfo, StreamingContext);
public InvalidModeException(string);
public InvalidModeException(string, Exception);


InvalidModeException.InvalidModeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidModeException.InvalidModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidModeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidModeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidModeException.InvalidModeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidModeException.InvalidModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidModeException(
string message,
Exception inner
);
Managed C++ public: InvalidModeException(
String *message,
Exception *inner
);
JScript .NET public function InvalidModeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidModeException.InvalidModeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidModeException.InvalidModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidModeException(
string message
);
Managed C++ public: InvalidModeException(
String *message
);
JScript .NET public function InvalidModeException(
message : String
);

Parameters

message System.String.


InvalidModeException.InvalidModeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidModeException.InvalidModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidModeException();
Managed C++ | public: InvalidModeException();
JScript .NET | public function InvalidModeException();


Microsoft.DirectX.DirectDraw.InvalidObjectException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw received a reference that was an invalid DirectDraw object. Deprecated.

Definition

Visual Basic .NET Public Class InvalidObjectException
Inherits GraphicsException
C# | public class InvalidObjectException : GraphicsException
Managed C++ | public __gc class InvalidObjectException : public GraphicsException
JScript .NET | public class InvalidObjectException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidObjectException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidObjectException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidObjectException.InvalidObjectException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException.InvalidObjectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidObjectException();
protected InvalidObjectException(SerializationInfo, StreamingContext);
public InvalidObjectException(string);
public InvalidObjectException(string, Exception);


InvalidObjectException.InvalidObjectException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException.InvalidObjectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidObjectException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidObjectException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidObjectException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidObjectException.InvalidObjectException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException.InvalidObjectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidObjectException(
string message,
Exception inner
);
Managed C++ public: InvalidObjectException(
String *message,
Exception *inner
);
JScript .NET public function InvalidObjectException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidObjectException.InvalidObjectException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException.InvalidObjectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidObjectException(
string message
);
Managed C++ public: InvalidObjectException(
String *message
);
JScript .NET public function InvalidObjectException(
message : String
);

Parameters

message System.String.


InvalidObjectException.InvalidObjectException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException.InvalidObjectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidObjectException();
Managed C++ | public: InvalidObjectException();
JScript .NET | public function InvalidObjectException();


Microsoft.DirectX.DirectDraw.InvalidPixelFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPixelFormatException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format was invalid as specified. Deprecated.

Definition

Visual Basic .NET Public Class InvalidPixelFormatException
Inherits GraphicsException
C# | public class InvalidPixelFormatException : GraphicsException
Managed C++ | public __gc class InvalidPixelFormatException : public GraphicsException
JScript .NET | public class InvalidPixelFormatException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPixelFormatException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidPixelFormatException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidPixelFormatException.InvalidPixelFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPixelFormatException();
protected InvalidPixelFormatException(SerializationInfo, StreamingContext);
public InvalidPixelFormatException(string);
public InvalidPixelFormatException(string, Exception);


InvalidPixelFormatException.InvalidPixelFormatException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPixelFormatException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidPixelFormatException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidPixelFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidPixelFormatException.InvalidPixelFormatException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPixelFormatException(
string message,
Exception inner
);
Managed C++ public: InvalidPixelFormatException(
String *message,
Exception *inner
);
JScript .NET public function InvalidPixelFormatException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidPixelFormatException.InvalidPixelFormatException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidPixelFormatException(
string message
);
Managed C++ public: InvalidPixelFormatException(
String *message
);
JScript .NET public function InvalidPixelFormatException(
message : String
);

Parameters

message System.String.


InvalidPixelFormatException.InvalidPixelFormatException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidPixelFormatException();
Managed C++ | public: InvalidPixelFormatException();
JScript .NET | public function InvalidPixelFormatException();


Microsoft.DirectX.DirectDraw.InvalidPositionException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPositionException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The position of the overlay on the destination is no longer legal. Deprecated.

Definition

Visual Basic .NET Public Class InvalidPositionException
Inherits GraphicsException
C# | public class InvalidPositionException : GraphicsException
Managed C++ | public __gc class InvalidPositionException : public GraphicsException
JScript .NET | public class InvalidPositionException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPositionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidPositionException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidPositionException.InvalidPositionException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPositionException.InvalidPositionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPositionException();
protected InvalidPositionException(SerializationInfo, StreamingContext);
public InvalidPositionException(string);
public InvalidPositionException(string, Exception);


InvalidPositionException.InvalidPositionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPositionException.InvalidPositionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPositionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidPositionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidPositionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidPositionException.InvalidPositionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPositionException.InvalidPositionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPositionException(
string message,
Exception inner
);
Managed C++ public: InvalidPositionException(
String *message,
Exception *inner
);
JScript .NET public function InvalidPositionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidPositionException.InvalidPositionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPositionException.InvalidPositionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidPositionException(
string message
);
Managed C++ public: InvalidPositionException(
String *message
);
JScript .NET public function InvalidPositionException(
message : String
);

Parameters

message System.String.


InvalidPositionException.InvalidPositionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPositionException.InvalidPositionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidPositionException();
Managed C++ | public: InvalidPositionException();
JScript .NET | public function InvalidPositionException();


Microsoft.DirectX.DirectDraw.InvalidRectangleException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidRectangleException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidRectangleException
Inherits GraphicsException
C# | public class InvalidRectangleException : GraphicsException
Managed C++ | public __gc class InvalidRectangleException : public GraphicsException
JScript .NET | public class InvalidRectangleException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidRectangleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidRectangleException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidRectangleException.InvalidRectangleException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidRectangleException();
protected InvalidRectangleException(SerializationInfo, StreamingContext);
public InvalidRectangleException(string);
public InvalidRectangleException(string, Exception);


InvalidRectangleException.InvalidRectangleException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidRectangleException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidRectangleException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidRectangleException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidRectangleException.InvalidRectangleException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidRectangleException(
string message,
Exception inner
);
Managed C++ public: InvalidRectangleException(
String *message,
Exception *inner
);
JScript .NET public function InvalidRectangleException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidRectangleException.InvalidRectangleException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidRectangleException(
string message
);
Managed C++ public: InvalidRectangleException(
String *message
);
JScript .NET public function InvalidRectangleException(
message : String
);

Parameters

message System.String.


InvalidRectangleException.InvalidRectangleException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidRectangleException();
Managed C++ | public: InvalidRectangleException();
JScript .NET | public function InvalidRectangleException();


Microsoft.DirectX.DirectDraw.InvalidStreamException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStreamException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified stream contains invalid data. Deprecated.

Definition

Visual Basic .NET Public Class InvalidStreamException
Inherits GraphicsException
C# | public class InvalidStreamException : GraphicsException
Managed C++ | public __gc class InvalidStreamException : public GraphicsException
JScript .NET | public class InvalidStreamException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidStreamException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidStreamException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidStreamException.InvalidStreamException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStreamException.InvalidStreamException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidStreamException();
protected InvalidStreamException(SerializationInfo, StreamingContext);
public InvalidStreamException(string);
public InvalidStreamException(string, Exception);


InvalidStreamException.InvalidStreamException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStreamException.InvalidStreamException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidStreamException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidStreamException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidStreamException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidStreamException.InvalidStreamException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStreamException.InvalidStreamException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidStreamException(
string message,
Exception inner
);
Managed C++ public: InvalidStreamException(
String *message,
Exception *inner
);
JScript .NET public function InvalidStreamException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidStreamException.InvalidStreamException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStreamException.InvalidStreamException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidStreamException(
string message
);
Managed C++ public: InvalidStreamException(
String *message
);
JScript .NET public function InvalidStreamException(
message : String
);

Parameters

message System.String.


InvalidStreamException.InvalidStreamException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStreamException.InvalidStreamException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidStreamException();
Managed C++ | public: InvalidStreamException();
JScript .NET | public function InvalidStreamException();


Microsoft.DirectX.DirectDraw.InvalidSurfaceTypeException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidSurfaceTypeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface was of the wrong type. Deprecated.

Definition

Visual Basic .NET Public Class InvalidSurfaceTypeException
Inherits GraphicsException
C# | public class InvalidSurfaceTypeException : GraphicsException
Managed C++ | public __gc class InvalidSurfaceTypeException : public GraphicsException
JScript .NET | public class InvalidSurfaceTypeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidSurfaceTypeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidSurfaceTypeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidSurfaceTypeException.InvalidSurfaceTypeException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidSurfaceTypeException();
protected InvalidSurfaceTypeException(SerializationInfo, StreamingContext);
public InvalidSurfaceTypeException(string);
public InvalidSurfaceTypeException(string, Exception);


InvalidSurfaceTypeException.InvalidSurfaceTypeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidSurfaceTypeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidSurfaceTypeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidSurfaceTypeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidSurfaceTypeException.InvalidSurfaceTypeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidSurfaceTypeException(
string message,
Exception inner
);
Managed C++ public: InvalidSurfaceTypeException(
String *message,
Exception *inner
);
JScript .NET public function InvalidSurfaceTypeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidSurfaceTypeException.InvalidSurfaceTypeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidSurfaceTypeException(
string message
);
Managed C++ public: InvalidSurfaceTypeException(
String *message
);
JScript .NET public function InvalidSurfaceTypeException(
message : String
);

Parameters

message System.String.


InvalidSurfaceTypeException.InvalidSurfaceTypeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidSurfaceTypeException();
Managed C++ | public: InvalidSurfaceTypeException();
JScript .NET | public function InvalidSurfaceTypeException();


Microsoft.DirectX.DirectDraw.LockedSurfacesException

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedSurfacesException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more surfaces are locked, causing the failure of the requested operation. Deprecated.

Definition

Visual Basic .NET Public Class LockedSurfacesException
Inherits GraphicsException
C# | public class LockedSurfacesException : GraphicsException
Managed C++ | public __gc class LockedSurfacesException : public GraphicsException
JScript .NET | public class LockedSurfacesException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
LockedSurfacesException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
LockedSurfacesException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LockedSurfacesException.LockedSurfacesException

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedSurfacesException.LockedSurfacesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public LockedSurfacesException();
protected LockedSurfacesException(SerializationInfo, StreamingContext);
public LockedSurfacesException(string);
public LockedSurfacesException(string, Exception);


LockedSurfacesException.LockedSurfacesException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedSurfacesException.LockedSurfacesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected LockedSurfacesException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: LockedSurfacesException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function LockedSurfacesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


LockedSurfacesException.LockedSurfacesException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedSurfacesException.LockedSurfacesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public LockedSurfacesException(
string message,
Exception inner
);
Managed C++ public: LockedSurfacesException(
String *message,
Exception *inner
);
JScript .NET public function LockedSurfacesException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


LockedSurfacesException.LockedSurfacesException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedSurfacesException.LockedSurfacesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public LockedSurfacesException(
string message
);
Managed C++ public: LockedSurfacesException(
String *message
);
JScript .NET public function LockedSurfacesException(
message : String
);

Parameters

message System.String.


LockedSurfacesException.LockedSurfacesException()

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedSurfacesException.LockedSurfacesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public LockedSurfacesException();
Managed C++ | public: LockedSurfacesException();
JScript .NET | public function LockedSurfacesException();


Microsoft.DirectX.DirectDraw.MoreDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is more data available than the specified buffer size can hold. Deprecated.

Definition

Visual Basic .NET Public Class MoreDataException
Inherits GraphicsException
C# | public class MoreDataException : GraphicsException
Managed C++ | public __gc class MoreDataException : public GraphicsException
JScript .NET | public class MoreDataException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MoreDataException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
MoreDataException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MoreDataException.MoreDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public MoreDataException();
protected MoreDataException(SerializationInfo, StreamingContext);
public MoreDataException(string);
public MoreDataException(string, Exception);


MoreDataException.MoreDataException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MoreDataException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: MoreDataException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function MoreDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


MoreDataException.MoreDataException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MoreDataException(
string message,
Exception inner
);
Managed C++ public: MoreDataException(
String *message,
Exception *inner
);
JScript .NET public function MoreDataException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


MoreDataException.MoreDataException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public MoreDataException(
string message
);
Managed C++ public: MoreDataException(
String *message
);
JScript .NET public function MoreDataException(
message : String
);

Parameters

message System.String.


MoreDataException.MoreDataException()

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public MoreDataException();
Managed C++ | public: MoreDataException();
JScript .NET | public function MoreDataException();


Microsoft.DirectX.DirectDraw.NewModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

NewModeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When StartModeTest is called with the IsTestRequired flag, it may throw this exception to denote that some or all of the resolutions can and should be tested. EvaluateMode throws this exception to indicate that the test has switched to a new display mode. Deprecated.

Definition

Visual Basic .NET Public Class NewModeException
Inherits GraphicsException
C# | public class NewModeException : GraphicsException
Managed C++ | public __gc class NewModeException : public GraphicsException
JScript .NET | public class NewModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NewModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NewModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NewModeException.NewModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

NewModeException.NewModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NewModeException();
protected NewModeException(SerializationInfo, StreamingContext);
public NewModeException(string);
public NewModeException(string, Exception);


NewModeException.NewModeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NewModeException.NewModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NewModeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NewModeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NewModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NewModeException.NewModeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NewModeException.NewModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NewModeException(
string message,
Exception inner
);
Managed C++ public: NewModeException(
String *message,
Exception *inner
);
JScript .NET public function NewModeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NewModeException.NewModeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NewModeException.NewModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NewModeException(
string message
);
Managed C++ public: NewModeException(
String *message
);
JScript .NET public function NewModeException(
message : String
);

Parameters

message System.String.


NewModeException.NewModeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NewModeException.NewModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NewModeException();
Managed C++ | public: NewModeException();
JScript .NET | public function NewModeException();


Microsoft.DirectX.DirectDraw.NoAlphaHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAlphaHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No alpha-acceleration hardware is present or available, causing the failure of the requested operation. Deprecated.

Definition

Visual Basic .NET Public Class NoAlphaHardwareException
Inherits GraphicsException
C# | public class NoAlphaHardwareException : GraphicsException
Managed C++ | public __gc class NoAlphaHardwareException : public GraphicsException
JScript .NET | public class NoAlphaHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoAlphaHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoAlphaHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoAlphaHardwareException.NoAlphaHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoAlphaHardwareException();
protected NoAlphaHardwareException(SerializationInfo, StreamingContext);
public NoAlphaHardwareException(string);
public NoAlphaHardwareException(string, Exception);


NoAlphaHardwareException.NoAlphaHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoAlphaHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoAlphaHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoAlphaHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoAlphaHardwareException.NoAlphaHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoAlphaHardwareException(
string message,
Exception inner
);
Managed C++ public: NoAlphaHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoAlphaHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoAlphaHardwareException.NoAlphaHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoAlphaHardwareException(
string message
);
Managed C++ public: NoAlphaHardwareException(
String *message
);
JScript .NET public function NoAlphaHardwareException(
message : String
);

Parameters

message System.String.


NoAlphaHardwareException.NoAlphaHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoAlphaHardwareException();
Managed C++ | public: NoAlphaHardwareException();
JScript .NET | public function NoAlphaHardwareException();


Microsoft.DirectX.DirectDraw.NoClipListException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipListException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No clip list is available. Deprecated.

Definition

Visual Basic .NET Public Class NoClipListException
Inherits GraphicsException
C# | public class NoClipListException : GraphicsException
Managed C++ | public __gc class NoClipListException : public GraphicsException
JScript .NET | public class NoClipListException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoClipListException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoClipListException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoClipListException.NoClipListException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipListException.NoClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoClipListException();
protected NoClipListException(SerializationInfo, StreamingContext);
public NoClipListException(string);
public NoClipListException(string, Exception);


NoClipListException.NoClipListException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipListException.NoClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoClipListException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoClipListException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoClipListException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoClipListException.NoClipListException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipListException.NoClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoClipListException(
string message,
Exception inner
);
Managed C++ public: NoClipListException(
String *message,
Exception *inner
);
JScript .NET public function NoClipListException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoClipListException.NoClipListException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipListException.NoClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoClipListException(
string message
);
Managed C++ public: NoClipListException(
String *message
);
JScript .NET public function NoClipListException(
message : String
);

Parameters

message System.String.


NoClipListException.NoClipListException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipListException.NoClipListException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoClipListException();
Managed C++ | public: NoClipListException();
JScript .NET | public function NoClipListException();


Microsoft.DirectX.DirectDraw.NoClipperAttachedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipperAttachedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No DirectDrawClipper object is attached to the surface object. Deprecated.

Definition

Visual Basic .NET Public Class NoClipperAttachedException
Inherits GraphicsException
C# | public class NoClipperAttachedException : GraphicsException
Managed C++ | public __gc class NoClipperAttachedException : public GraphicsException
JScript .NET | public class NoClipperAttachedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoClipperAttachedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoClipperAttachedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoClipperAttachedException.NoClipperAttachedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoClipperAttachedException();
protected NoClipperAttachedException(SerializationInfo, StreamingContext);
public NoClipperAttachedException(string);
public NoClipperAttachedException(string, Exception);


NoClipperAttachedException.NoClipperAttachedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoClipperAttachedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoClipperAttachedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoClipperAttachedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoClipperAttachedException.NoClipperAttachedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoClipperAttachedException(
string message,
Exception inner
);
Managed C++ public: NoClipperAttachedException(
String *message,
Exception *inner
);
JScript .NET public function NoClipperAttachedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoClipperAttachedException.NoClipperAttachedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoClipperAttachedException(
string message
);
Managed C++ public: NoClipperAttachedException(
String *message
);
JScript .NET public function NoClipperAttachedException(
message : String
);

Parameters

message System.String.


NoClipperAttachedException.NoClipperAttachedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoClipperAttachedException();
Managed C++ | public: NoClipperAttachedException();
JScript .NET | public function NoClipperAttachedException();


Microsoft.DirectX.DirectDraw.NoColorConversionHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorConversionHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No color-conversion hardware is present or available. Deprecated.

Definition

Visual Basic .NET Public Class NoColorConversionHardwareException
Inherits GraphicsException
C# | public class NoColorConversionHardwareException : GraphicsException
Managed C++ | public __gc class NoColorConversionHardwareException : public GraphicsException
JScript .NET | public class NoColorConversionHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoColorConversionHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoColorConversionHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoColorConversionHardwareException.NoColorConversionHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoColorConversionHardwareException();
protected NoColorConversionHardwareException(SerializationInfo, StreamingContext);
public NoColorConversionHardwareException(string);
public NoColorConversionHardwareException(string, Exception);


NoColorConversionHardwareException.NoColorConversionHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoColorConversionHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoColorConversionHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoColorConversionHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoColorConversionHardwareException.NoColorConversionHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoColorConversionHardwareException(
string message,
Exception inner
);
Managed C++ public: NoColorConversionHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoColorConversionHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoColorConversionHardwareException.NoColorConversionHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoColorConversionHardwareException(
string message
);
Managed C++ public: NoColorConversionHardwareException(
String *message
);
JScript .NET public function NoColorConversionHardwareException(
message : String
);

Parameters

message System.String.


NoColorConversionHardwareException.NoColorConversionHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoColorConversionHardwareException();
Managed C++ | public: NoColorConversionHardwareException();
JScript .NET | public function NoColorConversionHardwareException();


Microsoft.DirectX.DirectDraw.NoColorKeyException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface does not currently have a color key. Deprecated.

Definition

Visual Basic .NET Public Class NoColorKeyException
Inherits GraphicsException
C# | public class NoColorKeyException : GraphicsException
Managed C++ | public __gc class NoColorKeyException : public GraphicsException
JScript .NET | public class NoColorKeyException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoColorKeyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoColorKeyException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoColorKeyException.NoColorKeyException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyException.NoColorKeyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoColorKeyException();
protected NoColorKeyException(SerializationInfo, StreamingContext);
public NoColorKeyException(string);
public NoColorKeyException(string, Exception);


NoColorKeyException.NoColorKeyException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyException.NoColorKeyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoColorKeyException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoColorKeyException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoColorKeyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoColorKeyException.NoColorKeyException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyException.NoColorKeyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoColorKeyException(
string message,
Exception inner
);
Managed C++ public: NoColorKeyException(
String *message,
Exception *inner
);
JScript .NET public function NoColorKeyException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoColorKeyException.NoColorKeyException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyException.NoColorKeyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoColorKeyException(
string message
);
Managed C++ public: NoColorKeyException(
String *message
);
JScript .NET public function NoColorKeyException(
message : String
);

Parameters

message System.String.


NoColorKeyException.NoColorKeyException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyException.NoColorKeyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoColorKeyException();
Managed C++ | public: NoColorKeyException();
JScript .NET | public function NoColorKeyException();


Microsoft.DirectX.DirectDraw.NoColorKeyHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for the destination color key. Deprecated.

Definition

Visual Basic .NET Public Class NoColorKeyHardwareException
Inherits GraphicsException
C# | public class NoColorKeyHardwareException : GraphicsException
Managed C++ | public __gc class NoColorKeyHardwareException : public GraphicsException
JScript .NET | public class NoColorKeyHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoColorKeyHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoColorKeyHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoColorKeyHardwareException.NoColorKeyHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoColorKeyHardwareException();
protected NoColorKeyHardwareException(SerializationInfo, StreamingContext);
public NoColorKeyHardwareException(string);
public NoColorKeyHardwareException(string, Exception);


NoColorKeyHardwareException.NoColorKeyHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoColorKeyHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoColorKeyHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoColorKeyHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoColorKeyHardwareException.NoColorKeyHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoColorKeyHardwareException(
string message,
Exception inner
);
Managed C++ public: NoColorKeyHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoColorKeyHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoColorKeyHardwareException.NoColorKeyHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoColorKeyHardwareException(
string message
);
Managed C++ public: NoColorKeyHardwareException(
String *message
);
JScript .NET public function NoColorKeyHardwareException(
message : String
);

Parameters

message System.String.


NoColorKeyHardwareException.NoColorKeyHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoColorKeyHardwareException();
Managed C++ | public: NoColorKeyHardwareException();
JScript .NET | public function NoColorKeyHardwareException();


Microsoft.DirectX.DirectDraw.NoCooperativeLevelSetException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCooperativeLevelSetException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A create function was called without the SetCooperativeLevel method. Deprecated.

Definition

Visual Basic .NET Public Class NoCooperativeLevelSetException
Inherits GraphicsException
C# | public class NoCooperativeLevelSetException : GraphicsException
Managed C++ | public __gc class NoCooperativeLevelSetException : public GraphicsException
JScript .NET | public class NoCooperativeLevelSetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoCooperativeLevelSetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoCooperativeLevelSetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoCooperativeLevelSetException.NoCooperativeLevelSetException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoCooperativeLevelSetException();
protected NoCooperativeLevelSetException(SerializationInfo, StreamingContext);
public NoCooperativeLevelSetException(string);
public NoCooperativeLevelSetException(string, Exception);


NoCooperativeLevelSetException.NoCooperativeLevelSetException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoCooperativeLevelSetException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoCooperativeLevelSetException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoCooperativeLevelSetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoCooperativeLevelSetException.NoCooperativeLevelSetException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoCooperativeLevelSetException(
string message,
Exception inner
);
Managed C++ public: NoCooperativeLevelSetException(
String *message,
Exception *inner
);
JScript .NET public function NoCooperativeLevelSetException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoCooperativeLevelSetException.NoCooperativeLevelSetException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoCooperativeLevelSetException(
string message
);
Managed C++ public: NoCooperativeLevelSetException(
String *message
);
JScript .NET public function NoCooperativeLevelSetException(
message : String
);

Parameters

message System.String.


NoCooperativeLevelSetException.NoCooperativeLevelSetException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoCooperativeLevelSetException();
Managed C++ | public: NoCooperativeLevelSetException();
JScript .NET | public function NoCooperativeLevelSetException();


Microsoft.DirectX.DirectDraw.NoDeviceContextException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDeviceContextException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No device context (DC) has ever been created for this surface. Deprecated.

Definition

Visual Basic .NET Public Class NoDeviceContextException
Inherits GraphicsException
C# | public class NoDeviceContextException : GraphicsException
Managed C++ | public __gc class NoDeviceContextException : public GraphicsException
JScript .NET | public class NoDeviceContextException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDeviceContextException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDeviceContextException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoDeviceContextException.NoDeviceContextException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDeviceContextException();
protected NoDeviceContextException(SerializationInfo, StreamingContext);
public NoDeviceContextException(string);
public NoDeviceContextException(string, Exception);


NoDeviceContextException.NoDeviceContextException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDeviceContextException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoDeviceContextException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoDeviceContextException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoDeviceContextException.NoDeviceContextException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDeviceContextException(
string message,
Exception inner
);
Managed C++ public: NoDeviceContextException(
String *message,
Exception *inner
);
JScript .NET public function NoDeviceContextException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoDeviceContextException.NoDeviceContextException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoDeviceContextException(
string message
);
Managed C++ public: NoDeviceContextException(
String *message
);
JScript .NET public function NoDeviceContextException(
message : String
);

Parameters

message System.String.


NoDeviceContextException.NoDeviceContextException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoDeviceContextException();
Managed C++ | public: NoDeviceContextException();
JScript .NET | public function NoDeviceContextException();


Microsoft.DirectX.DirectDraw.NoDirectDrawHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware-only DirectDraw object creation is not possible; the driver does not support any hardware. Deprecated.

Definition

Visual Basic .NET Public Class NoDirectDrawHardwareException
Inherits GraphicsException
C# | public class NoDirectDrawHardwareException : GraphicsException
Managed C++ | public __gc class NoDirectDrawHardwareException : public GraphicsException
JScript .NET | public class NoDirectDrawHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDirectDrawHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDirectDrawHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoDirectDrawHardwareException.NoDirectDrawHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDirectDrawHardwareException();
protected NoDirectDrawHardwareException(SerializationInfo, StreamingContext);
public NoDirectDrawHardwareException(string);
public NoDirectDrawHardwareException(string, Exception);


NoDirectDrawHardwareException.NoDirectDrawHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDirectDrawHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoDirectDrawHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoDirectDrawHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoDirectDrawHardwareException.NoDirectDrawHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDirectDrawHardwareException(
string message,
Exception inner
);
Managed C++ public: NoDirectDrawHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoDirectDrawHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoDirectDrawHardwareException.NoDirectDrawHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoDirectDrawHardwareException(
string message
);
Managed C++ public: NoDirectDrawHardwareException(
String *message
);
JScript .NET public function NoDirectDrawHardwareException(
message : String
);

Parameters

message System.String.


NoDirectDrawHardwareException.NoDirectDrawHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoDirectDrawHardwareException();
Managed C++ | public: NoDirectDrawHardwareException();
JScript .NET | public function NoDirectDrawHardwareException();


Microsoft.DirectX.DirectDraw.NoDirectDrawSupportException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawSupportException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw support is not possible with the current display driver. Deprecated.

Definition

Visual Basic .NET Public Class NoDirectDrawSupportException
Inherits GraphicsException
C# | public class NoDirectDrawSupportException : GraphicsException
Managed C++ | public __gc class NoDirectDrawSupportException : public GraphicsException
JScript .NET | public class NoDirectDrawSupportException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDirectDrawSupportException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDirectDrawSupportException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoDirectDrawSupportException.NoDirectDrawSupportException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDirectDrawSupportException();
protected NoDirectDrawSupportException(SerializationInfo, StreamingContext);
public NoDirectDrawSupportException(string);
public NoDirectDrawSupportException(string, Exception);


NoDirectDrawSupportException.NoDirectDrawSupportException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDirectDrawSupportException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoDirectDrawSupportException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoDirectDrawSupportException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoDirectDrawSupportException.NoDirectDrawSupportException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDirectDrawSupportException(
string message,
Exception inner
);
Managed C++ public: NoDirectDrawSupportException(
String *message,
Exception *inner
);
JScript .NET public function NoDirectDrawSupportException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoDirectDrawSupportException.NoDirectDrawSupportException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoDirectDrawSupportException(
string message
);
Managed C++ public: NoDirectDrawSupportException(
String *message
);
JScript .NET public function NoDirectDrawSupportException(
message : String
);

Parameters

message System.String.


NoDirectDrawSupportException.NoDirectDrawSupportException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoDirectDrawSupportException();
Managed C++ | public: NoDirectDrawSupportException();
JScript .NET | public function NoDirectDrawSupportException();


Microsoft.DirectX.DirectDraw.NoDrawHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDrawHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No blitter hardware is present. Deprecated.

Definition

Visual Basic .NET Public Class NoDrawHardwareException
Inherits GraphicsException
C# | public class NoDrawHardwareException : GraphicsException
Managed C++ | public __gc class NoDrawHardwareException : public GraphicsException
JScript .NET | public class NoDrawHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDrawHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDrawHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoDrawHardwareException.NoDrawHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDrawHardwareException.NoDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDrawHardwareException();
protected NoDrawHardwareException(SerializationInfo, StreamingContext);
public NoDrawHardwareException(string);
public NoDrawHardwareException(string, Exception);


NoDrawHardwareException.NoDrawHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDrawHardwareException.NoDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDrawHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoDrawHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoDrawHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoDrawHardwareException.NoDrawHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDrawHardwareException.NoDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDrawHardwareException(
string message,
Exception inner
);
Managed C++ public: NoDrawHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoDrawHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoDrawHardwareException.NoDrawHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDrawHardwareException.NoDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoDrawHardwareException(
string message
);
Managed C++ public: NoDrawHardwareException(
String *message
);
JScript .NET public function NoDrawHardwareException(
message : String
);

Parameters

message System.String.


NoDrawHardwareException.NoDrawHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDrawHardwareException.NoDrawHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoDrawHardwareException();
Managed C++ | public: NoDrawHardwareException();
JScript .NET | public function NoDrawHardwareException();


Microsoft.DirectX.DirectDraw.NoDriverSupportException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverSupportException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the display adapter driver does not enumerate refresh rates. Deprecated.

Definition

Visual Basic .NET Public Class NoDriverSupportException
Inherits GraphicsException
C# | public class NoDriverSupportException : GraphicsException
Managed C++ | public __gc class NoDriverSupportException : public GraphicsException
JScript .NET | public class NoDriverSupportException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDriverSupportException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDriverSupportException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoDriverSupportException.NoDriverSupportException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDriverSupportException();
protected NoDriverSupportException(SerializationInfo, StreamingContext);
public NoDriverSupportException(string);
public NoDriverSupportException(string, Exception);


NoDriverSupportException.NoDriverSupportException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDriverSupportException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoDriverSupportException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoDriverSupportException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoDriverSupportException.NoDriverSupportException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDriverSupportException(
string message,
Exception inner
);
Managed C++ public: NoDriverSupportException(
String *message,
Exception *inner
);
JScript .NET public function NoDriverSupportException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoDriverSupportException.NoDriverSupportException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoDriverSupportException(
string message
);
Managed C++ public: NoDriverSupportException(
String *message
);
JScript .NET public function NoDriverSupportException(
message : String
);

Parameters

message System.String.


NoDriverSupportException.NoDriverSupportException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoDriverSupportException();
Managed C++ | public: NoDriverSupportException();
JScript .NET | public function NoDriverSupportException();


Microsoft.DirectX.DirectDraw.NoEmulationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoEmulationException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Software emulation is not available. Deprecated.

Definition

Visual Basic .NET Public Class NoEmulationException
Inherits GraphicsException
C# | public class NoEmulationException : GraphicsException
Managed C++ | public __gc class NoEmulationException : public GraphicsException
JScript .NET | public class NoEmulationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoEmulationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoEmulationException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoEmulationException.NoEmulationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoEmulationException.NoEmulationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoEmulationException();
protected NoEmulationException(SerializationInfo, StreamingContext);
public NoEmulationException(string);
public NoEmulationException(string, Exception);


NoEmulationException.NoEmulationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoEmulationException.NoEmulationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoEmulationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoEmulationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoEmulationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoEmulationException.NoEmulationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoEmulationException.NoEmulationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoEmulationException(
string message,
Exception inner
);
Managed C++ public: NoEmulationException(
String *message,
Exception *inner
);
JScript .NET public function NoEmulationException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoEmulationException.NoEmulationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoEmulationException.NoEmulationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoEmulationException(
string message
);
Managed C++ public: NoEmulationException(
String *message
);
JScript .NET public function NoEmulationException(
message : String
);

Parameters

message System.String.


NoEmulationException.NoEmulationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoEmulationException.NoEmulationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoEmulationException();
Managed C++ | public: NoEmulationException();
JScript .NET | public function NoEmulationException();


Microsoft.DirectX.DirectDraw.NoExclusiveModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoExclusiveModeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation requires the application to have exclusive mode, but the application does not have exclusive mode. Deprecated.

Definition

Visual Basic .NET Public Class NoExclusiveModeException
Inherits GraphicsException
C# | public class NoExclusiveModeException : GraphicsException
Managed C++ | public __gc class NoExclusiveModeException : public GraphicsException
JScript .NET | public class NoExclusiveModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoExclusiveModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoExclusiveModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoExclusiveModeException.NoExclusiveModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoExclusiveModeException();
protected NoExclusiveModeException(SerializationInfo, StreamingContext);
public NoExclusiveModeException(string);
public NoExclusiveModeException(string, Exception);


NoExclusiveModeException.NoExclusiveModeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoExclusiveModeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoExclusiveModeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoExclusiveModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoExclusiveModeException.NoExclusiveModeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoExclusiveModeException(
string message,
Exception inner
);
Managed C++ public: NoExclusiveModeException(
String *message,
Exception *inner
);
JScript .NET public function NoExclusiveModeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoExclusiveModeException.NoExclusiveModeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoExclusiveModeException(
string message
);
Managed C++ public: NoExclusiveModeException(
String *message
);
JScript .NET public function NoExclusiveModeException(
message : String
);

Parameters

message System.String.


NoExclusiveModeException.NoExclusiveModeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoExclusiveModeException();
Managed C++ | public: NoExclusiveModeException();
JScript .NET | public function NoExclusiveModeException();


Microsoft.DirectX.DirectDraw.NoFlipHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFlipHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flipping visible surfaces is not supported. Deprecated.

Definition

Visual Basic .NET Public Class NoFlipHardwareException
Inherits GraphicsException
C# | public class NoFlipHardwareException : GraphicsException
Managed C++ | public __gc class NoFlipHardwareException : public GraphicsException
JScript .NET | public class NoFlipHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoFlipHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoFlipHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoFlipHardwareException.NoFlipHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFlipHardwareException.NoFlipHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoFlipHardwareException();
protected NoFlipHardwareException(SerializationInfo, StreamingContext);
public NoFlipHardwareException(string);
public NoFlipHardwareException(string, Exception);


NoFlipHardwareException.NoFlipHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFlipHardwareException.NoFlipHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoFlipHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoFlipHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoFlipHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoFlipHardwareException.NoFlipHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFlipHardwareException.NoFlipHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoFlipHardwareException(
string message,
Exception inner
);
Managed C++ public: NoFlipHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoFlipHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoFlipHardwareException.NoFlipHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFlipHardwareException.NoFlipHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoFlipHardwareException(
string message
);
Managed C++ public: NoFlipHardwareException(
String *message
);
JScript .NET public function NoFlipHardwareException(
message : String
);

Parameters

message System.String.


NoFlipHardwareException.NoFlipHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFlipHardwareException.NoFlipHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoFlipHardwareException();
Managed C++ | public: NoFlipHardwareException();
JScript .NET | public function NoFlipHardwareException();


Microsoft.DirectX.DirectDraw.NoFocusWindowException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFocusWindowException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to create or set a device window without first setting the focus window. Deprecated.

Definition

Visual Basic .NET Public Class NoFocusWindowException
Inherits GraphicsException
C# | public class NoFocusWindowException : GraphicsException
Managed C++ | public __gc class NoFocusWindowException : public GraphicsException
JScript .NET | public class NoFocusWindowException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoFocusWindowException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoFocusWindowException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoFocusWindowException.NoFocusWindowException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFocusWindowException.NoFocusWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoFocusWindowException();
protected NoFocusWindowException(SerializationInfo, StreamingContext);
public NoFocusWindowException(string);
public NoFocusWindowException(string, Exception);


NoFocusWindowException.NoFocusWindowException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFocusWindowException.NoFocusWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoFocusWindowException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoFocusWindowException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoFocusWindowException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoFocusWindowException.NoFocusWindowException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFocusWindowException.NoFocusWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoFocusWindowException(
string message,
Exception inner
);
Managed C++ public: NoFocusWindowException(
String *message,
Exception *inner
);
JScript .NET public function NoFocusWindowException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoFocusWindowException.NoFocusWindowException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFocusWindowException.NoFocusWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoFocusWindowException(
string message
);
Managed C++ public: NoFocusWindowException(
String *message
);
JScript .NET public function NoFocusWindowException(
message : String
);

Parameters

message System.String.


NoFocusWindowException.NoFocusWindowException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoFocusWindowException.NoFocusWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoFocusWindowException();
Managed C++ | public: NoFocusWindowException();
JScript .NET | public function NoFocusWindowException();


Microsoft.DirectX.DirectDraw.NoGdiException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoGdiException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No GDI is present. Deprecated.

Definition

Visual Basic .NET Public Class NoGdiException
Inherits GraphicsException
C# | public class NoGdiException : GraphicsException
Managed C++ | public __gc class NoGdiException : public GraphicsException
JScript .NET | public class NoGdiException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoGdiException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoGdiException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoGdiException.NoGdiException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoGdiException.NoGdiException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoGdiException();
protected NoGdiException(SerializationInfo, StreamingContext);
public NoGdiException(string);
public NoGdiException(string, Exception);


NoGdiException.NoGdiException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoGdiException.NoGdiException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoGdiException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoGdiException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoGdiException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoGdiException.NoGdiException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoGdiException.NoGdiException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoGdiException(
string message,
Exception inner
);
Managed C++ public: NoGdiException(
String *message,
Exception *inner
);
JScript .NET public function NoGdiException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoGdiException.NoGdiException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoGdiException.NoGdiException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoGdiException(
string message
);
Managed C++ public: NoGdiException(
String *message
);
JScript .NET public function NoGdiException(
message : String
);

Parameters

message System.String.


NoGdiException.NoGdiException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoGdiException.NoGdiException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoGdiException();
Managed C++ | public: NoGdiException();
JScript .NET | public function NoGdiException();


Microsoft.DirectX.DirectDraw.NoMirrorHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMirrorHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No mirroring hardware is present or available. Deprecated.

Definition

Visual Basic .NET Public Class NoMirrorHardwareException
Inherits GraphicsException
C# | public class NoMirrorHardwareException : GraphicsException
Managed C++ | public __gc class NoMirrorHardwareException : public GraphicsException
JScript .NET | public class NoMirrorHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoMirrorHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoMirrorHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoMirrorHardwareException.NoMirrorHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoMirrorHardwareException();
protected NoMirrorHardwareException(SerializationInfo, StreamingContext);
public NoMirrorHardwareException(string);
public NoMirrorHardwareException(string, Exception);


NoMirrorHardwareException.NoMirrorHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoMirrorHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoMirrorHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoMirrorHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoMirrorHardwareException.NoMirrorHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoMirrorHardwareException(
string message,
Exception inner
);
Managed C++ public: NoMirrorHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoMirrorHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoMirrorHardwareException.NoMirrorHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoMirrorHardwareException(
string message
);
Managed C++ public: NoMirrorHardwareException(
String *message
);
JScript .NET public function NoMirrorHardwareException(
message : String
);

Parameters

message System.String.


NoMirrorHardwareException.NoMirrorHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoMirrorHardwareException();
Managed C++ | public: NoMirrorHardwareException();
JScript .NET | public function NoMirrorHardwareException();


Microsoft.DirectX.DirectDraw.NoMonitorInformationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMonitorInformationException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the monitor has no associated EDID data. Deprecated.

Definition

Visual Basic .NET Public Class NoMonitorInformationException
Inherits GraphicsException
C# | public class NoMonitorInformationException : GraphicsException
Managed C++ | public __gc class NoMonitorInformationException : public GraphicsException
JScript .NET | public class NoMonitorInformationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoMonitorInformationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoMonitorInformationException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoMonitorInformationException.NoMonitorInformationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoMonitorInformationException();
protected NoMonitorInformationException(SerializationInfo, StreamingContext);
public NoMonitorInformationException(string);
public NoMonitorInformationException(string, Exception);


NoMonitorInformationException.NoMonitorInformationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoMonitorInformationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoMonitorInformationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoMonitorInformationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoMonitorInformationException.NoMonitorInformationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoMonitorInformationException(
string message,
Exception inner
);
Managed C++ public: NoMonitorInformationException(
String *message,
Exception *inner
);
JScript .NET public function NoMonitorInformationException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoMonitorInformationException.NoMonitorInformationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoMonitorInformationException(
string message
);
Managed C++ public: NoMonitorInformationException(
String *message
);
JScript .NET public function NoMonitorInformationException(
message : String
);

Parameters

message System.String.


NoMonitorInformationException.NoMonitorInformationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoMonitorInformationException();
Managed C++ | public: NoMonitorInformationException();
JScript .NET | public function NoMonitorInformationException();


Microsoft.DirectX.DirectDraw.NoNonLocalVideoMemoryException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoNonLocalVideoMemoryException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to allocate nonlocal video memory from a device that does not support nonlocal video memory. Deprecated.

Definition

Visual Basic .NET Public Class NoNonLocalVideoMemoryException
Inherits GraphicsException
C# | public class NoNonLocalVideoMemoryException : GraphicsException
Managed C++ | public __gc class NoNonLocalVideoMemoryException : public GraphicsException
JScript .NET | public class NoNonLocalVideoMemoryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoNonLocalVideoMemoryException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoNonLocalVideoMemoryException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoNonLocalVideoMemoryException();
protected NoNonLocalVideoMemoryException(SerializationInfo, StreamingContext);
public NoNonLocalVideoMemoryException(string);
public NoNonLocalVideoMemoryException(string, Exception);


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoNonLocalVideoMemoryException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoNonLocalVideoMemoryException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoNonLocalVideoMemoryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoNonLocalVideoMemoryException(
string message,
Exception inner
);
Managed C++ public: NoNonLocalVideoMemoryException(
String *message,
Exception *inner
);
JScript .NET public function NoNonLocalVideoMemoryException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoNonLocalVideoMemoryException(
string message
);
Managed C++ public: NoNonLocalVideoMemoryException(
String *message
);
JScript .NET public function NoNonLocalVideoMemoryException(
message : String
);

Parameters

message System.String.


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoNonLocalVideoMemoryException();
Managed C++ | public: NoNonLocalVideoMemoryException();
JScript .NET | public function NoNonLocalVideoMemoryException();


Microsoft.DirectX.DirectDraw.NoOptimizeHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOptimizeHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The device does not support optimized surfaces. Deprecated.

Definition

Visual Basic .NET Public Class NoOptimizeHardwareException
Inherits GraphicsException
C# | public class NoOptimizeHardwareException : GraphicsException
Managed C++ | public __gc class NoOptimizeHardwareException : public GraphicsException
JScript .NET | public class NoOptimizeHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoOptimizeHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoOptimizeHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoOptimizeHardwareException.NoOptimizeHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoOptimizeHardwareException();
protected NoOptimizeHardwareException(SerializationInfo, StreamingContext);
public NoOptimizeHardwareException(string);
public NoOptimizeHardwareException(string, Exception);


NoOptimizeHardwareException.NoOptimizeHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoOptimizeHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoOptimizeHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoOptimizeHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoOptimizeHardwareException.NoOptimizeHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoOptimizeHardwareException(
string message,
Exception inner
);
Managed C++ public: NoOptimizeHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoOptimizeHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoOptimizeHardwareException.NoOptimizeHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoOptimizeHardwareException(
string message
);
Managed C++ public: NoOptimizeHardwareException(
String *message
);
JScript .NET public function NoOptimizeHardwareException(
message : String
);

Parameters

message System.String.


NoOptimizeHardwareException.NoOptimizeHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoOptimizeHardwareException();
Managed C++ | public: NoOptimizeHardwareException();
JScript .NET | public function NoOptimizeHardwareException();


Microsoft.DirectX.DirectDraw.NoOverlayDestinationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayDestinationException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method is called on an overlay that the UpdateOverlay method has not been called on to establish as a destination. Deprecated.

Definition

Visual Basic .NET Public Class NoOverlayDestinationException
Inherits GraphicsException
C# | public class NoOverlayDestinationException : GraphicsException
Managed C++ | public __gc class NoOverlayDestinationException : public GraphicsException
JScript .NET | public class NoOverlayDestinationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoOverlayDestinationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoOverlayDestinationException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoOverlayDestinationException.NoOverlayDestinationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoOverlayDestinationException();
protected NoOverlayDestinationException(SerializationInfo, StreamingContext);
public NoOverlayDestinationException(string);
public NoOverlayDestinationException(string, Exception);


NoOverlayDestinationException.NoOverlayDestinationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoOverlayDestinationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoOverlayDestinationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoOverlayDestinationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoOverlayDestinationException.NoOverlayDestinationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoOverlayDestinationException(
string message,
Exception inner
);
Managed C++ public: NoOverlayDestinationException(
String *message,
Exception *inner
);
JScript .NET public function NoOverlayDestinationException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoOverlayDestinationException.NoOverlayDestinationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoOverlayDestinationException(
string message
);
Managed C++ public: NoOverlayDestinationException(
String *message
);
JScript .NET public function NoOverlayDestinationException(
message : String
);

Parameters

message System.String.


NoOverlayDestinationException.NoOverlayDestinationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoOverlayDestinationException();
Managed C++ | public: NoOverlayDestinationException();
JScript .NET | public function NoOverlayDestinationException();


Microsoft.DirectX.DirectDraw.NoOverlayHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No overlay hardware is present or available. Deprecated.

Definition

Visual Basic .NET Public Class NoOverlayHardwareException
Inherits GraphicsException
C# | public class NoOverlayHardwareException : GraphicsException
Managed C++ | public __gc class NoOverlayHardwareException : public GraphicsException
JScript .NET | public class NoOverlayHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoOverlayHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoOverlayHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoOverlayHardwareException.NoOverlayHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoOverlayHardwareException();
protected NoOverlayHardwareException(SerializationInfo, StreamingContext);
public NoOverlayHardwareException(string);
public NoOverlayHardwareException(string, Exception);


NoOverlayHardwareException.NoOverlayHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoOverlayHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoOverlayHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoOverlayHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoOverlayHardwareException.NoOverlayHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoOverlayHardwareException(
string message,
Exception inner
);
Managed C++ public: NoOverlayHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoOverlayHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoOverlayHardwareException.NoOverlayHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoOverlayHardwareException(
string message
);
Managed C++ public: NoOverlayHardwareException(
String *message
);
JScript .NET public function NoOverlayHardwareException(
message : String
);

Parameters

message System.String.


NoOverlayHardwareException.NoOverlayHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoOverlayHardwareException();
Managed C++ | public: NoOverlayHardwareException();
JScript .NET | public function NoOverlayHardwareException();


Microsoft.DirectX.DirectDraw.NoPaletteAttachedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteAttachedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No palette object is attached to this surface. Deprecated.

Definition

Visual Basic .NET Public Class NoPaletteAttachedException
Inherits GraphicsException
C# | public class NoPaletteAttachedException : GraphicsException
Managed C++ | public __gc class NoPaletteAttachedException : public GraphicsException
JScript .NET | public class NoPaletteAttachedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoPaletteAttachedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoPaletteAttachedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoPaletteAttachedException.NoPaletteAttachedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoPaletteAttachedException();
protected NoPaletteAttachedException(SerializationInfo, StreamingContext);
public NoPaletteAttachedException(string);
public NoPaletteAttachedException(string, Exception);


NoPaletteAttachedException.NoPaletteAttachedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoPaletteAttachedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoPaletteAttachedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoPaletteAttachedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoPaletteAttachedException.NoPaletteAttachedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoPaletteAttachedException(
string message,
Exception inner
);
Managed C++ public: NoPaletteAttachedException(
String *message,
Exception *inner
);
JScript .NET public function NoPaletteAttachedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoPaletteAttachedException.NoPaletteAttachedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoPaletteAttachedException(
string message
);
Managed C++ public: NoPaletteAttachedException(
String *message
);
JScript .NET public function NoPaletteAttachedException(
message : String
);

Parameters

message System.String.


NoPaletteAttachedException.NoPaletteAttachedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoPaletteAttachedException();
Managed C++ | public: NoPaletteAttachedException();
JScript .NET | public function NoPaletteAttachedException();


Microsoft.DirectX.DirectDraw.NoPaletteHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for 16- or 256-color palettes. Deprecated.

Definition

Visual Basic .NET Public Class NoPaletteHardwareException
Inherits GraphicsException
C# | public class NoPaletteHardwareException : GraphicsException
Managed C++ | public __gc class NoPaletteHardwareException : public GraphicsException
JScript .NET | public class NoPaletteHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoPaletteHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoPaletteHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoPaletteHardwareException.NoPaletteHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoPaletteHardwareException();
protected NoPaletteHardwareException(SerializationInfo, StreamingContext);
public NoPaletteHardwareException(string);
public NoPaletteHardwareException(string, Exception);


NoPaletteHardwareException.NoPaletteHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoPaletteHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoPaletteHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoPaletteHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoPaletteHardwareException.NoPaletteHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoPaletteHardwareException(
string message,
Exception inner
);
Managed C++ public: NoPaletteHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoPaletteHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoPaletteHardwareException.NoPaletteHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoPaletteHardwareException(
string message
);
Managed C++ public: NoPaletteHardwareException(
String *message
);
JScript .NET public function NoPaletteHardwareException(
message : String
);

Parameters

message System.String.


NoPaletteHardwareException.NoPaletteHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoPaletteHardwareException();
Managed C++ | public: NoPaletteHardwareException();
JScript .NET | public function NoPaletteHardwareException();


Microsoft.DirectX.DirectDraw.NoRasterOperationHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRasterOperationHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No appropriate raster-operation hardware is present or available. Deprecated.

Definition

Visual Basic .NET Public Class NoRasterOperationHardwareException
Inherits GraphicsException
C# | public class NoRasterOperationHardwareException : GraphicsException
Managed C++ | public __gc class NoRasterOperationHardwareException : public GraphicsException
JScript .NET | public class NoRasterOperationHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoRasterOperationHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoRasterOperationHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoRasterOperationHardwareException.NoRasterOperationHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoRasterOperationHardwareException();
protected NoRasterOperationHardwareException(SerializationInfo, StreamingContext);
public NoRasterOperationHardwareException(string);
public NoRasterOperationHardwareException(string, Exception);


NoRasterOperationHardwareException.NoRasterOperationHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoRasterOperationHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoRasterOperationHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoRasterOperationHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoRasterOperationHardwareException.NoRasterOperationHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoRasterOperationHardwareException(
string message,
Exception inner
);
Managed C++ public: NoRasterOperationHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoRasterOperationHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoRasterOperationHardwareException.NoRasterOperationHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoRasterOperationHardwareException(
string message
);
Managed C++ public: NoRasterOperationHardwareException(
String *message
);
JScript .NET public function NoRasterOperationHardwareException(
message : String
);

Parameters

message System.String.


NoRasterOperationHardwareException.NoRasterOperationHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoRasterOperationHardwareException();
Managed C++ | public: NoRasterOperationHardwareException();
JScript .NET | public function NoRasterOperationHardwareException();


Microsoft.DirectX.DirectDraw.NoRotationHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRotationHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No rotation hardware is present or available. Deprecated.

Definition

Visual Basic .NET Public Class NoRotationHardwareException
Inherits GraphicsException
C# | public class NoRotationHardwareException : GraphicsException
Managed C++ | public __gc class NoRotationHardwareException : public GraphicsException
JScript .NET | public class NoRotationHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoRotationHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoRotationHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoRotationHardwareException.NoRotationHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoRotationHardwareException();
protected NoRotationHardwareException(SerializationInfo, StreamingContext);
public NoRotationHardwareException(string);
public NoRotationHardwareException(string, Exception);


NoRotationHardwareException.NoRotationHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoRotationHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoRotationHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoRotationHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoRotationHardwareException.NoRotationHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoRotationHardwareException(
string message,
Exception inner
);
Managed C++ public: NoRotationHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoRotationHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoRotationHardwareException.NoRotationHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoRotationHardwareException(
string message
);
Managed C++ public: NoRotationHardwareException(
String *message
);
JScript .NET public function NoRotationHardwareException(
message : String
);

Parameters

message System.String.


NoRotationHardwareException.NoRotationHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoRotationHardwareException();
Managed C++ | public: NoRotationHardwareException();
JScript .NET | public function NoRotationHardwareException();


Microsoft.DirectX.DirectDraw.NoStereoHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStereoHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no stereo hardware present or available. Deprecated.

Definition

Visual Basic .NET Public Class NoStereoHardwareException
Inherits GraphicsException
C# | public class NoStereoHardwareException : GraphicsException
Managed C++ | public __gc class NoStereoHardwareException : public GraphicsException
JScript .NET | public class NoStereoHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoStereoHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoStereoHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoStereoHardwareException.NoStereoHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoStereoHardwareException();
protected NoStereoHardwareException(SerializationInfo, StreamingContext);
public NoStereoHardwareException(string);
public NoStereoHardwareException(string, Exception);


NoStereoHardwareException.NoStereoHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoStereoHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoStereoHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoStereoHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoStereoHardwareException.NoStereoHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoStereoHardwareException(
string message,
Exception inner
);
Managed C++ public: NoStereoHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoStereoHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoStereoHardwareException.NoStereoHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoStereoHardwareException(
string message
);
Managed C++ public: NoStereoHardwareException(
String *message
);
JScript .NET public function NoStereoHardwareException(
message : String
);

Parameters

message System.String.


NoStereoHardwareException.NoStereoHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoStereoHardwareException();
Managed C++ | public: NoStereoHardwareException();
JScript .NET | public function NoStereoHardwareException();


Microsoft.DirectX.DirectDraw.NoStretchHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStretchHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for stretching. Deprecated.

Definition

Visual Basic .NET Public Class NoStretchHardwareException
Inherits GraphicsException
C# | public class NoStretchHardwareException : GraphicsException
Managed C++ | public __gc class NoStretchHardwareException : public GraphicsException
JScript .NET | public class NoStretchHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoStretchHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoStretchHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoStretchHardwareException.NoStretchHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoStretchHardwareException();
protected NoStretchHardwareException(SerializationInfo, StreamingContext);
public NoStretchHardwareException(string);
public NoStretchHardwareException(string, Exception);


NoStretchHardwareException.NoStretchHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoStretchHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoStretchHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoStretchHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoStretchHardwareException.NoStretchHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoStretchHardwareException(
string message,
Exception inner
);
Managed C++ public: NoStretchHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoStretchHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoStretchHardwareException.NoStretchHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoStretchHardwareException(
string message
);
Managed C++ public: NoStretchHardwareException(
String *message
);
JScript .NET public function NoStretchHardwareException(
message : String
);

Parameters

message System.String.


NoStretchHardwareException.NoStretchHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoStretchHardwareException();
Managed C++ | public: NoStretchHardwareException();
JScript .NET | public function NoStretchHardwareException();


Microsoft.DirectX.DirectDraw.NoSurfaceLeftException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoSurfaceLeftException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware present that supports stereo surfaces. Deprecated.

Definition

Visual Basic .NET Public Class NoSurfaceLeftException
Inherits GraphicsException
C# | public class NoSurfaceLeftException : GraphicsException
Managed C++ | public __gc class NoSurfaceLeftException : public GraphicsException
JScript .NET | public class NoSurfaceLeftException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoSurfaceLeftException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoSurfaceLeftException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoSurfaceLeftException.NoSurfaceLeftException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoSurfaceLeftException();
protected NoSurfaceLeftException(SerializationInfo, StreamingContext);
public NoSurfaceLeftException(string);
public NoSurfaceLeftException(string, Exception);


NoSurfaceLeftException.NoSurfaceLeftException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoSurfaceLeftException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoSurfaceLeftException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoSurfaceLeftException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoSurfaceLeftException.NoSurfaceLeftException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoSurfaceLeftException(
string message,
Exception inner
);
Managed C++ public: NoSurfaceLeftException(
String *message,
Exception *inner
);
JScript .NET public function NoSurfaceLeftException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoSurfaceLeftException.NoSurfaceLeftException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoSurfaceLeftException(
string message
);
Managed C++ public: NoSurfaceLeftException(
String *message
);
JScript .NET public function NoSurfaceLeftException(
message : String
);

Parameters

message System.String.


NoSurfaceLeftException.NoSurfaceLeftException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoSurfaceLeftException();
Managed C++ | public: NoSurfaceLeftException();
JScript .NET | public function NoSurfaceLeftException();


Microsoft.DirectX.DirectDraw.Not4BitColorException

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color palette, and the requested operation requires a 4-bit color palette. Deprecated.

Definition

Visual Basic .NET Public Class Not4BitColorException
Inherits GraphicsException
C# | public class Not4BitColorException : GraphicsException
Managed C++ | public __gc class Not4BitColorException : public GraphicsException
JScript .NET | public class Not4BitColorException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
Not4BitColorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
Not4BitColorException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Not4BitColorException.Not4BitColorException

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorException.Not4BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Not4BitColorException();
protected Not4BitColorException(SerializationInfo, StreamingContext);
public Not4BitColorException(string);
public Not4BitColorException(string, Exception);


Not4BitColorException.Not4BitColorException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorException.Not4BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Not4BitColorException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: Not4BitColorException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function Not4BitColorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


Not4BitColorException.Not4BitColorException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorException.Not4BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Not4BitColorException(
string message,
Exception inner
);
Managed C++ public: Not4BitColorException(
String *message,
Exception *inner
);
JScript .NET public function Not4BitColorException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


Not4BitColorException.Not4BitColorException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorException.Not4BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public Not4BitColorException(
string message
);
Managed C++ public: Not4BitColorException(
String *message
);
JScript .NET public function Not4BitColorException(
message : String
);

Parameters

message System.String.


Not4BitColorException.Not4BitColorException()

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorException.Not4BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Not4BitColorException();
Managed C++ | public: Not4BitColorException();
JScript .NET | public function Not4BitColorException();


Microsoft.DirectX.DirectDraw.Not4BitColorIndexException

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorIndexException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color index palette, and the requested operation requires a 4-bit color index palette. Deprecated.

Definition

Visual Basic .NET Public Class Not4BitColorIndexException
Inherits GraphicsException
C# | public class Not4BitColorIndexException : GraphicsException
Managed C++ | public __gc class Not4BitColorIndexException : public GraphicsException
JScript .NET | public class Not4BitColorIndexException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
Not4BitColorIndexException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
Not4BitColorIndexException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Not4BitColorIndexException.Not4BitColorIndexException

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Not4BitColorIndexException();
protected Not4BitColorIndexException(SerializationInfo, StreamingContext);
public Not4BitColorIndexException(string);
public Not4BitColorIndexException(string, Exception);


Not4BitColorIndexException.Not4BitColorIndexException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Not4BitColorIndexException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: Not4BitColorIndexException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function Not4BitColorIndexException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


Not4BitColorIndexException.Not4BitColorIndexException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Not4BitColorIndexException(
string message,
Exception inner
);
Managed C++ public: Not4BitColorIndexException(
String *message,
Exception *inner
);
JScript .NET public function Not4BitColorIndexException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


Not4BitColorIndexException.Not4BitColorIndexException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public Not4BitColorIndexException(
string message
);
Managed C++ public: Not4BitColorIndexException(
String *message
);
JScript .NET public function Not4BitColorIndexException(
message : String
);

Parameters

message System.String.


Not4BitColorIndexException.Not4BitColorIndexException()

Microsoft DirectX 9.0 SDK Update (October 2004)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Not4BitColorIndexException();
Managed C++ | public: Not4BitColorIndexException();
JScript .NET | public function Not4BitColorIndexException();


Microsoft.DirectX.DirectDraw.Not8BitColorException

Microsoft DirectX 9.0 SDK Update (October 2004)

Not8BitColorException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using an 8-bit color palette, and the requested operation requires an 8-bit color palette. Deprecated.

Definition

Visual Basic .NET Public Class Not8BitColorException
Inherits GraphicsException
C# | public class Not8BitColorException : GraphicsException
Managed C++ | public __gc class Not8BitColorException : public GraphicsException
JScript .NET | public class Not8BitColorException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
Not8BitColorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
Not8BitColorException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Not8BitColorException.Not8BitColorException

Microsoft DirectX 9.0 SDK Update (October 2004)

Not8BitColorException.Not8BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Not8BitColorException();
protected Not8BitColorException(SerializationInfo, StreamingContext);
public Not8BitColorException(string);
public Not8BitColorException(string, Exception);


Not8BitColorException.Not8BitColorException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not8BitColorException.Not8BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Not8BitColorException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: Not8BitColorException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function Not8BitColorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


Not8BitColorException.Not8BitColorException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not8BitColorException.Not8BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Not8BitColorException(
string message,
Exception inner
);
Managed C++ public: Not8BitColorException(
String *message,
Exception *inner
);
JScript .NET public function Not8BitColorException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


Not8BitColorException.Not8BitColorException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Not8BitColorException.Not8BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public Not8BitColorException(
string message
);
Managed C++ public: Not8BitColorException(
String *message
);
JScript .NET public function Not8BitColorException(
message : String
);

Parameters

message System.String.


Not8BitColorException.Not8BitColorException()

Microsoft DirectX 9.0 SDK Update (October 2004)

Not8BitColorException.Not8BitColorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Not8BitColorException();
Managed C++ | public: Not8BitColorException();
JScript .NET | public function Not8BitColorException();


Microsoft.DirectX.DirectDraw.NotAnOverlaySurfaceException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAnOverlaySurfaceException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An overlay component is called for a nonoverlay surface. Deprecated.

Definition

Visual Basic .NET Public Class NotAnOverlaySurfaceException
Inherits GraphicsException
C# | public class NotAnOverlaySurfaceException : GraphicsException
Managed C++ | public __gc class NotAnOverlaySurfaceException : public GraphicsException
JScript .NET | public class NotAnOverlaySurfaceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAnOverlaySurfaceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotAnOverlaySurfaceException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotAnOverlaySurfaceException();
protected NotAnOverlaySurfaceException(SerializationInfo, StreamingContext);
public NotAnOverlaySurfaceException(string);
public NotAnOverlaySurfaceException(string, Exception);


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAnOverlaySurfaceException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotAnOverlaySurfaceException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotAnOverlaySurfaceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAnOverlaySurfaceException(
string message,
Exception inner
);
Managed C++ public: NotAnOverlaySurfaceException(
String *message,
Exception *inner
);
JScript .NET public function NotAnOverlaySurfaceException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotAnOverlaySurfaceException(
string message
);
Managed C++ public: NotAnOverlaySurfaceException(
String *message
);
JScript .NET public function NotAnOverlaySurfaceException(
message : String
);

Parameters

message System.String.


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotAnOverlaySurfaceException();
Managed C++ | public: NotAnOverlaySurfaceException();
JScript .NET | public function NotAnOverlaySurfaceException();


Microsoft.DirectX.DirectDraw.NotFlippableException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFlippableException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to flip a surface that cannot be flipped. Deprecated.

Definition

Visual Basic .NET Public Class NotFlippableException
Inherits GraphicsException
C# | public class NotFlippableException : GraphicsException
Managed C++ | public __gc class NotFlippableException : public GraphicsException
JScript .NET | public class NotFlippableException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFlippableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotFlippableException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotFlippableException.NotFlippableException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFlippableException.NotFlippableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotFlippableException();
protected NotFlippableException(SerializationInfo, StreamingContext);
public NotFlippableException(string);
public NotFlippableException(string, Exception);


NotFlippableException.NotFlippableException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFlippableException.NotFlippableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFlippableException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotFlippableException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotFlippableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotFlippableException.NotFlippableException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFlippableException.NotFlippableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFlippableException(
string message,
Exception inner
);
Managed C++ public: NotFlippableException(
String *message,
Exception *inner
);
JScript .NET public function NotFlippableException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotFlippableException.NotFlippableException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFlippableException.NotFlippableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotFlippableException(
string message
);
Managed C++ public: NotFlippableException(
String *message
);
JScript .NET public function NotFlippableException(
message : String
);

Parameters

message System.String.


NotFlippableException.NotFlippableException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFlippableException.NotFlippableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotFlippableException();
Managed C++ | public: NotFlippableException();
JScript .NET | public function NotFlippableException();


Microsoft.DirectX.DirectDraw.NotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested item was not found. Deprecated.

Definition

Visual Basic .NET Public Class NotFoundException
Inherits GraphicsException
C# | public class NotFoundException : GraphicsException
Managed C++ | public __gc class NotFoundException : public GraphicsException
JScript .NET | public class NotFoundException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFoundException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotFoundException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotFoundException.NotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotFoundException();
protected NotFoundException(SerializationInfo, StreamingContext);
public NotFoundException(string);
public NotFoundException(string, Exception);


NotFoundException.NotFoundException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFoundException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotFoundException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotFoundException.NotFoundException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFoundException(
string message,
Exception inner
);
Managed C++ public: NotFoundException(
String *message,
Exception *inner
);
JScript .NET public function NotFoundException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotFoundException.NotFoundException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotFoundException(
string message
);
Managed C++ public: NotFoundException(
String *message
);
JScript .NET public function NotFoundException(
message : String
);

Parameters

message System.String.


NotFoundException.NotFoundException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotFoundException();
Managed C++ | public: NotFoundException();
JScript .NET | public function NotFoundException();


Microsoft.DirectX.DirectDraw.NotLoadedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLoadedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is an optimized surface, but it has not yet been allocated any memory. Deprecated.

Definition

Visual Basic .NET Public Class NotLoadedException
Inherits GraphicsException
C# | public class NotLoadedException : GraphicsException
Managed C++ | public __gc class NotLoadedException : public GraphicsException
JScript .NET | public class NotLoadedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotLoadedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotLoadedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotLoadedException.NotLoadedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLoadedException.NotLoadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotLoadedException();
protected NotLoadedException(SerializationInfo, StreamingContext);
public NotLoadedException(string);
public NotLoadedException(string, Exception);


NotLoadedException.NotLoadedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLoadedException.NotLoadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotLoadedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotLoadedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotLoadedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotLoadedException.NotLoadedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLoadedException.NotLoadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotLoadedException(
string message,
Exception inner
);
Managed C++ public: NotLoadedException(
String *message,
Exception *inner
);
JScript .NET public function NotLoadedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotLoadedException.NotLoadedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLoadedException.NotLoadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotLoadedException(
string message
);
Managed C++ public: NotLoadedException(
String *message
);
JScript .NET public function NotLoadedException(
message : String
);

Parameters

message System.String.


NotLoadedException.NotLoadedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLoadedException.NotLoadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotLoadedException();
Managed C++ | public: NotLoadedException();
JScript .NET | public function NotLoadedException();


Microsoft.DirectX.DirectDraw.NotLockedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLockedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to unlock a surface that was not locked. Deprecated.

Definition

Visual Basic .NET Public Class NotLockedException
Inherits GraphicsException
C# | public class NotLockedException : GraphicsException
Managed C++ | public __gc class NotLockedException : public GraphicsException
JScript .NET | public class NotLockedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotLockedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotLockedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotLockedException.NotLockedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLockedException.NotLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotLockedException();
protected NotLockedException(SerializationInfo, StreamingContext);
public NotLockedException(string);
public NotLockedException(string, Exception);


NotLockedException.NotLockedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLockedException.NotLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotLockedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotLockedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotLockedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotLockedException.NotLockedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLockedException.NotLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotLockedException(
string message,
Exception inner
);
Managed C++ public: NotLockedException(
String *message,
Exception *inner
);
JScript .NET public function NotLockedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotLockedException.NotLockedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLockedException.NotLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotLockedException(
string message
);
Managed C++ public: NotLockedException(
String *message
);
JScript .NET public function NotLockedException(
message : String
);

Parameters

message System.String.


NotLockedException.NotLockedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotLockedException.NotLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotLockedException();
Managed C++ | public: NotLockedException();
JScript .NET | public function NotLockedException();


Microsoft.DirectX.DirectDraw.NotPageLockedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPageLockedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to page-unlock a surface with no outstanding page locks. Deprecated.

Definition

Visual Basic .NET Public Class NotPageLockedException
Inherits GraphicsException
C# | public class NotPageLockedException : GraphicsException
Managed C++ | public __gc class NotPageLockedException : public GraphicsException
JScript .NET | public class NotPageLockedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotPageLockedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotPageLockedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotPageLockedException.NotPageLockedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPageLockedException.NotPageLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotPageLockedException();
protected NotPageLockedException(SerializationInfo, StreamingContext);
public NotPageLockedException(string);
public NotPageLockedException(string, Exception);


NotPageLockedException.NotPageLockedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPageLockedException.NotPageLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotPageLockedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotPageLockedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotPageLockedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotPageLockedException.NotPageLockedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPageLockedException.NotPageLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotPageLockedException(
string message,
Exception inner
);
Managed C++ public: NotPageLockedException(
String *message,
Exception *inner
);
JScript .NET public function NotPageLockedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotPageLockedException.NotPageLockedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPageLockedException.NotPageLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotPageLockedException(
string message
);
Managed C++ public: NotPageLockedException(
String *message
);
JScript .NET public function NotPageLockedException(
message : String
);

Parameters

message System.String.


NotPageLockedException.NotPageLockedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPageLockedException.NotPageLockedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotPageLockedException();
Managed C++ | public: NotPageLockedException();
JScript .NET | public function NotPageLockedException();


Microsoft.DirectX.DirectDraw.NotPalettizedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPalettizedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface being used is not a palette-based surface. Deprecated.

Definition

Visual Basic .NET Public Class NotPalettizedException
Inherits GraphicsException
C# | public class NotPalettizedException : GraphicsException
Managed C++ | public __gc class NotPalettizedException : public GraphicsException
JScript .NET | public class NotPalettizedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotPalettizedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotPalettizedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotPalettizedException.NotPalettizedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPalettizedException.NotPalettizedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotPalettizedException();
protected NotPalettizedException(SerializationInfo, StreamingContext);
public NotPalettizedException(string);
public NotPalettizedException(string, Exception);


NotPalettizedException.NotPalettizedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPalettizedException.NotPalettizedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotPalettizedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotPalettizedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotPalettizedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotPalettizedException.NotPalettizedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPalettizedException.NotPalettizedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotPalettizedException(
string message,
Exception inner
);
Managed C++ public: NotPalettizedException(
String *message,
Exception *inner
);
JScript .NET public function NotPalettizedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotPalettizedException.NotPalettizedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPalettizedException.NotPalettizedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotPalettizedException(
string message
);
Managed C++ public: NotPalettizedException(
String *message
);
JScript .NET public function NotPalettizedException(
message : String
);

Parameters

message System.String.


NotPalettizedException.NotPalettizedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotPalettizedException.NotPalettizedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotPalettizedException();
Managed C++ | public: NotPalettizedException();
JScript .NET | public function NotPalettizedException();


Microsoft.DirectX.DirectDraw.NoVideoSyncHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVideoSyncHardwareException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for vertical blank-synchronized operations. Deprecated.

Definition

Visual Basic .NET Public Class NoVideoSyncHardwareException
Inherits GraphicsException
C# | public class NoVideoSyncHardwareException : GraphicsException
Managed C++ | public __gc class NoVideoSyncHardwareException : public GraphicsException
JScript .NET | public class NoVideoSyncHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoVideoSyncHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoVideoSyncHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoVideoSyncHardwareException.NoVideoSyncHardwareException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoVideoSyncHardwareException();
protected NoVideoSyncHardwareException(SerializationInfo, StreamingContext);
public NoVideoSyncHardwareException(string);
public NoVideoSyncHardwareException(string, Exception);


NoVideoSyncHardwareException.NoVideoSyncHardwareException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoVideoSyncHardwareException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoVideoSyncHardwareException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoVideoSyncHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoVideoSyncHardwareException.NoVideoSyncHardwareException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoVideoSyncHardwareException(
string message,
Exception inner
);
Managed C++ public: NoVideoSyncHardwareException(
String *message,
Exception *inner
);
JScript .NET public function NoVideoSyncHardwareException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoVideoSyncHardwareException.NoVideoSyncHardwareException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoVideoSyncHardwareException(
string message
);
Managed C++ public: NoVideoSyncHardwareException(
String *message
);
JScript .NET public function NoVideoSyncHardwareException(
message : String
);

Parameters

message System.String.


NoVideoSyncHardwareException.NoVideoSyncHardwareException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoVideoSyncHardwareException();
Managed C++ | public: NoVideoSyncHardwareException();
JScript .NET | public function NoVideoSyncHardwareException();


Microsoft.DirectX.DirectDraw.NoWindowException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoWindowException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Clipper notification requires a window, or no window has been previously set as the cooperative level window Deprecated.

Definition

Visual Basic .NET Public Class NoWindowException
Inherits GraphicsException
C# | public class NoWindowException : GraphicsException
Managed C++ | public __gc class NoWindowException : public GraphicsException
JScript .NET | public class NoWindowException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoWindowException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoWindowException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoWindowException.NoWindowException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoWindowException.NoWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoWindowException();
protected NoWindowException(SerializationInfo, StreamingContext);
public NoWindowException(string);
public NoWindowException(string, Exception);


NoWindowException.NoWindowException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoWindowException.NoWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoWindowException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoWindowException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoWindowException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoWindowException.NoWindowException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoWindowException.NoWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoWindowException(
string message,
Exception inner
);
Managed C++ public: NoWindowException(
String *message,
Exception *inner
);
JScript .NET public function NoWindowException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoWindowException.NoWindowException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoWindowException.NoWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoWindowException(
string message
);
Managed C++ public: NoWindowException(
String *message
);
JScript .NET public function NoWindowException(
message : String
);

Parameters

message System.String.


NoWindowException.NoWindowException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoWindowException.NoWindowException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoWindowException();
Managed C++ | public: NoWindowException();
JScript .NET | public function NoWindowException();


Microsoft.DirectX.DirectDraw.OutOfCapsException

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfCapsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware needed for the requested operation has already been allocated. Deprecated.

Definition

Visual Basic .NET Public Class OutOfCapsException
Inherits GraphicsException
C# | public class OutOfCapsException : GraphicsException
Managed C++ | public __gc class OutOfCapsException : public GraphicsException
JScript .NET | public class OutOfCapsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OutOfCapsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OutOfCapsException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OutOfCapsException.OutOfCapsException

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfCapsException.OutOfCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OutOfCapsException();
protected OutOfCapsException(SerializationInfo, StreamingContext);
public OutOfCapsException(string);
public OutOfCapsException(string, Exception);


OutOfCapsException.OutOfCapsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfCapsException.OutOfCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OutOfCapsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OutOfCapsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OutOfCapsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


OutOfCapsException.OutOfCapsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfCapsException.OutOfCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OutOfCapsException(
string message,
Exception inner
);
Managed C++ public: OutOfCapsException(
String *message,
Exception *inner
);
JScript .NET public function OutOfCapsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


OutOfCapsException.OutOfCapsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfCapsException.OutOfCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OutOfCapsException(
string message
);
Managed C++ public: OutOfCapsException(
String *message
);
JScript .NET public function OutOfCapsException(
message : String
);

Parameters

message System.String.


OutOfCapsException.OutOfCapsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfCapsException.OutOfCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OutOfCapsException();
Managed C++ | public: OutOfCapsException();
JScript .NET | public function OutOfCapsException();


Microsoft.DirectX.DirectDraw.OutOfVideoMemoryException

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not have enough display memory to perform the operation. Deprecated.

Definition

Visual Basic .NET Public Class OutOfVideoMemoryException
Inherits GraphicsException
C# | public class OutOfVideoMemoryException : GraphicsException
Managed C++ | public __gc class OutOfVideoMemoryException : public GraphicsException
JScript .NET | public class OutOfVideoMemoryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OutOfVideoMemoryException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OutOfVideoMemoryException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OutOfVideoMemoryException.OutOfVideoMemoryException

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OutOfVideoMemoryException();
protected OutOfVideoMemoryException(SerializationInfo, StreamingContext);
public OutOfVideoMemoryException(string);
public OutOfVideoMemoryException(string, Exception);


OutOfVideoMemoryException.OutOfVideoMemoryException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OutOfVideoMemoryException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OutOfVideoMemoryException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OutOfVideoMemoryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


OutOfVideoMemoryException.OutOfVideoMemoryException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OutOfVideoMemoryException(
string message,
Exception inner
);
Managed C++ public: OutOfVideoMemoryException(
String *message,
Exception *inner
);
JScript .NET public function OutOfVideoMemoryException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


OutOfVideoMemoryException.OutOfVideoMemoryException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OutOfVideoMemoryException(
string message
);
Managed C++ public: OutOfVideoMemoryException(
String *message
);
JScript .NET public function OutOfVideoMemoryException(
message : String
);

Parameters

message System.String.


OutOfVideoMemoryException.OutOfVideoMemoryException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OutOfVideoMemoryException();
Managed C++ | public: OutOfVideoMemoryException();
JScript .NET | public function OutOfVideoMemoryException();


Microsoft.DirectX.DirectDraw.OverlappingRectanglesException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlappingRectanglesException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The source and destination rectangles are on the same surface and overlap each other. Deprecated.

Definition

Visual Basic .NET Public Class OverlappingRectanglesException
Inherits GraphicsException
C# | public class OverlappingRectanglesException : GraphicsException
Managed C++ | public __gc class OverlappingRectanglesException : public GraphicsException
JScript .NET | public class OverlappingRectanglesException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlappingRectanglesException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlappingRectanglesException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlappingRectanglesException.OverlappingRectanglesException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlappingRectanglesException();
protected OverlappingRectanglesException(SerializationInfo, StreamingContext);
public OverlappingRectanglesException(string);
public OverlappingRectanglesException(string, Exception);


OverlappingRectanglesException.OverlappingRectanglesException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlappingRectanglesException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OverlappingRectanglesException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OverlappingRectanglesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


OverlappingRectanglesException.OverlappingRectanglesException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlappingRectanglesException(
string message,
Exception inner
);
Managed C++ public: OverlappingRectanglesException(
String *message,
Exception *inner
);
JScript .NET public function OverlappingRectanglesException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


OverlappingRectanglesException.OverlappingRectanglesException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OverlappingRectanglesException(
string message
);
Managed C++ public: OverlappingRectanglesException(
String *message
);
JScript .NET public function OverlappingRectanglesException(
message : String
);

Parameters

message System.String.


OverlappingRectanglesException.OverlappingRectanglesException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OverlappingRectanglesException();
Managed C++ | public: OverlappingRectanglesException();
JScript .NET | public function OverlappingRectanglesException();


Microsoft.DirectX.DirectDraw.OverlayCantClipException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayCantClipException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware does not support clipped overlays. Deprecated.

Definition

Visual Basic .NET Public Class OverlayCantClipException
Inherits GraphicsException
C# | public class OverlayCantClipException : GraphicsException
Managed C++ | public __gc class OverlayCantClipException : public GraphicsException
JScript .NET | public class OverlayCantClipException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlayCantClipException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlayCantClipException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayCantClipException.OverlayCantClipException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlayCantClipException();
protected OverlayCantClipException(SerializationInfo, StreamingContext);
public OverlayCantClipException(string);
public OverlayCantClipException(string, Exception);


OverlayCantClipException.OverlayCantClipException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlayCantClipException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OverlayCantClipException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OverlayCantClipException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


OverlayCantClipException.OverlayCantClipException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlayCantClipException(
string message,
Exception inner
);
Managed C++ public: OverlayCantClipException(
String *message,
Exception *inner
);
JScript .NET public function OverlayCantClipException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


OverlayCantClipException.OverlayCantClipException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OverlayCantClipException(
string message
);
Managed C++ public: OverlayCantClipException(
String *message
);
JScript .NET public function OverlayCantClipException(
message : String
);

Parameters

message System.String.


OverlayCantClipException.OverlayCantClipException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OverlayCantClipException();
Managed C++ | public: OverlayCantClipException();
JScript .NET | public function OverlayCantClipException();


Microsoft.DirectX.DirectDraw.OverlayColorKeyOnlyOneActiveException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayColorKeyOnlyOneActiveException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to have more than one color key active on an overlay. Deprecated.

Definition

Visual Basic .NET Public Class OverlayColorKeyOnlyOneActiveException
Inherits GraphicsException
C# | public class OverlayColorKeyOnlyOneActiveException : GraphicsException
Managed C++ | public __gc class OverlayColorKeyOnlyOneActiveException : public GraphicsException
JScript .NET | public class OverlayColorKeyOnlyOneActiveException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlayColorKeyOnlyOneActiveException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlayColorKeyOnlyOneActiveException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlayColorKeyOnlyOneActiveException();
protected OverlayColorKeyOnlyOneActiveException(SerializationInfo, StreamingContext);
public OverlayColorKeyOnlyOneActiveException(string);
public OverlayColorKeyOnlyOneActiveException(string, Exception);


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlayColorKeyOnlyOneActiveException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OverlayColorKeyOnlyOneActiveException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OverlayColorKeyOnlyOneActiveException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlayColorKeyOnlyOneActiveException(
string message,
Exception inner
);
Managed C++ public: OverlayColorKeyOnlyOneActiveException(
String *message,
Exception *inner
);
JScript .NET public function OverlayColorKeyOnlyOneActiveException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OverlayColorKeyOnlyOneActiveException(
string message
);
Managed C++ public: OverlayColorKeyOnlyOneActiveException(
String *message
);
JScript .NET public function OverlayColorKeyOnlyOneActiveException(
message : String
);

Parameters

message System.String.


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OverlayColorKeyOnlyOneActiveException();
Managed C++ | public: OverlayColorKeyOnlyOneActiveException();
JScript .NET | public function OverlayColorKeyOnlyOneActiveException();


Microsoft.DirectX.DirectDraw.OverlayNotVisibleException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayNotVisibleException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method was called on a hidden overlay. Deprecated.

Definition

Visual Basic .NET Public Class OverlayNotVisibleException
Inherits GraphicsException
C# | public class OverlayNotVisibleException : GraphicsException
Managed C++ | public __gc class OverlayNotVisibleException : public GraphicsException
JScript .NET | public class OverlayNotVisibleException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlayNotVisibleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlayNotVisibleException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayNotVisibleException.OverlayNotVisibleException

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlayNotVisibleException();
protected OverlayNotVisibleException(SerializationInfo, StreamingContext);
public OverlayNotVisibleException(string);
public OverlayNotVisibleException(string, Exception);


OverlayNotVisibleException.OverlayNotVisibleException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlayNotVisibleException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OverlayNotVisibleException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OverlayNotVisibleException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


OverlayNotVisibleException.OverlayNotVisibleException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlayNotVisibleException(
string message,
Exception inner
);
Managed C++ public: OverlayNotVisibleException(
String *message,
Exception *inner
);
JScript .NET public function OverlayNotVisibleException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


OverlayNotVisibleException.OverlayNotVisibleException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OverlayNotVisibleException(
string message
);
Managed C++ public: OverlayNotVisibleException(
String *message
);
JScript .NET public function OverlayNotVisibleException(
message : String
);

Parameters

message System.String.


OverlayNotVisibleException.OverlayNotVisibleException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OverlayNotVisibleException();
Managed C++ | public: OverlayNotVisibleException();
JScript .NET | public function OverlayNotVisibleException();


Microsoft.DirectX.DirectDraw.Palette

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Palette object to create DirectDrawPalette objects Deprecated.

Definition

Visual Basic .NET Public Class Palette
Inherits MarshalByRefObject
Implements IDisposable
C# public class Palette : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Palette : public MarshalByRefObject,
IDisposable
JScript .NET public class Palette extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetEntries
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Queries palette values from a DirectDrawPalette object. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
Palette
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetEntries
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes entries in a DirectDrawPalette object immediately. Deprecated.

Properties

Property Description
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of this palette object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Palette

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Palette.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Palette.Disposed
  • Palette.Disposing


Palette.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Palette.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Palette();
Managed C++ | ~Palette();
JScript .NET | protected override function Finalize();


Palette.GetEntries(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.GetEntries Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Queries palette values from a DirectDrawPalette object. Deprecated.

Definition

Visual Basic .NET Public Function GetEntries( _
ByVal base As Integer, _
ByVal numEntries As Integer _
) As PaletteEntry()
C# public PaletteEntry[] GetEntries(
int base,
int numEntries
);
Managed C++ public: PaletteEntry GetEntries(
int base,
int numEntries
) __gc[];
JScript .NET public function GetEntries(
base : int,
numEntries : int
) : PaletteEntry[];

Parameters

base | System.Int32.
numEntries | System.Int32.

Return Value

Microsoft.DirectX.DirectDraw.PaletteEntry[].


Palette.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Palette.op_Equality(Palette,Palette)

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Palette, _
ByVal right As Palette _
) As Boolean
C# public static bool op_Equality(
Palette left,
Palette right
);
Managed C++ public: static bool op_Equality(
Palette *left,
Palette *right
);
JScript .NET public static function op_Equality(
left : Palette,
right : Palette
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Palette. The Palette structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.Palette. The Palette structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Palette.op_Inequality(Palette,Palette)

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Palette, _
ByVal right As Palette _
) As Boolean
C# public static bool op_Inequality(
Palette left,
Palette right
);
Managed C++ public: static bool op_Inequality(
Palette *left,
Palette *right
);
JScript .NET public static function op_Inequality(
left : Palette,
right : Palette
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Palette. The Palette structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.Palette. The Palette structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Palette.Palette

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Palette Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Palette(Device, PaletteCaps, PaletteEntry[]);
public Palette(Device, string);
public Palette(Surface);


Palette.Palette(Device,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Palette Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal file As String _
)
C# public Palette(
Device device,
string file
);
Managed C++ public: Palette(
Device *device,
String *file
);
JScript .NET public function Palette(
device : Device,
file : String
);

Parameters

device | Microsoft.DirectX.DirectDraw.Device.
file | System.String.


Palette.Palette(Device,PaletteCaps,PaletteEntry[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Palette Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal device As Device, _
ByVal flags As PaletteCaps, _
ByVal palette() As PaletteEntry _
)
C# public Palette(
Device device,
PaletteCaps flags,
PaletteEntry[] palette
);
Managed C++ public: Palette(
Device *device,
PaletteCaps flags,
PaletteEntry palette __gc[]
);
JScript .NET public function Palette(
device : Device,
flags : PaletteCaps,
palette : PaletteEntry[]
);

Parameters

device | Microsoft.DirectX.DirectDraw.Device.
flags | Microsoft.DirectX.DirectDraw.PaletteCaps.
palette | Microsoft.DirectX.DirectDraw.PaletteEntry[].


Palette.Palette(Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Palette Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal surf As Surface _
)
C# public Palette(
Surface surf
);
Managed C++ public: Palette(
Surface *surf
);
JScript .NET public function Palette(
surf : Surface
);

Parameters

surf Microsoft.DirectX.DirectDraw.Surface.


Palette.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Palette.SetEntries(Int32,PaletteEntry[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.SetEntries Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes entries in a DirectDrawPalette object immediately. Deprecated.

Definition

Visual Basic .NET Public Sub SetEntries( _
ByVal base As Integer, _
ByVal entries() As PaletteEntry _
)
C# public void SetEntries(
int base,
PaletteEntry[] entries
);
Managed C++ public: void SetEntries(
int base,
PaletteEntry entries __gc[]
);
JScript .NET public function SetEntries(
base : int,
entries : PaletteEntry[]
);

Parameters

base | System.Int32.
entries | Microsoft.DirectX.DirectDraw.PaletteEntry[].


Palette.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of this palette object. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Caps As PaletteCaps
C# | public PaletteCaps Caps { get; }
Managed C++ | public: __property PaletteCaps get_Caps();
JScript .NET | public function get Caps() : PaletteCaps

Property Value

Microsoft.DirectX.DirectDraw.PaletteCaps .

This property is read-only.


Palette.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Palette.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Palette.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Palette.Disposing event, use the following code.

palette.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectDraw.PaletteBusyException

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteBusyException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this palette is refused because the palette is locked by another thread. Deprecated.

Definition

Visual Basic .NET Public Class PaletteBusyException
Inherits GraphicsException
C# | public class PaletteBusyException : GraphicsException
Managed C++ | public __gc class PaletteBusyException : public GraphicsException
JScript .NET | public class PaletteBusyException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PaletteBusyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
PaletteBusyException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PaletteBusyException.PaletteBusyException

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteBusyException.PaletteBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PaletteBusyException();
protected PaletteBusyException(SerializationInfo, StreamingContext);
public PaletteBusyException(string);
public PaletteBusyException(string, Exception);


PaletteBusyException.PaletteBusyException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteBusyException.PaletteBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PaletteBusyException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PaletteBusyException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PaletteBusyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PaletteBusyException.PaletteBusyException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteBusyException.PaletteBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PaletteBusyException(
string message,
Exception inner
);
Managed C++ public: PaletteBusyException(
String *message,
Exception *inner
);
JScript .NET public function PaletteBusyException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PaletteBusyException.PaletteBusyException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteBusyException.PaletteBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PaletteBusyException(
string message
);
Managed C++ public: PaletteBusyException(
String *message
);
JScript .NET public function PaletteBusyException(
message : String
);

Parameters

message System.String.


PaletteBusyException.PaletteBusyException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteBusyException.PaletteBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PaletteBusyException();
Managed C++ | public: PaletteBusyException();
JScript .NET | public function PaletteBusyException();


Microsoft.DirectX.DirectDraw.PrimarySurfaceAlreadyExistsException

Microsoft DirectX 9.0 SDK Update (October 2004)

PrimarySurfaceAlreadyExistsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This process has already created a primary surface. Deprecated.

Definition

Visual Basic .NET Public Class PrimarySurfaceAlreadyExistsException
Inherits GraphicsException
C# | public class PrimarySurfaceAlreadyExistsException : GraphicsException
Managed C++ | public __gc class PrimarySurfaceAlreadyExistsException : public GraphicsException
JScript .NET | public class PrimarySurfaceAlreadyExistsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PrimarySurfaceAlreadyExistsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
PrimarySurfaceAlreadyExistsException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException

Microsoft DirectX 9.0 SDK Update (October 2004)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PrimarySurfaceAlreadyExistsException();
protected PrimarySurfaceAlreadyExistsException(SerializationInfo, StreamingContext);
public PrimarySurfaceAlreadyExistsException(string);
public PrimarySurfaceAlreadyExistsException(string, Exception);


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PrimarySurfaceAlreadyExistsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PrimarySurfaceAlreadyExistsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PrimarySurfaceAlreadyExistsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PrimarySurfaceAlreadyExistsException(
string message,
Exception inner
);
Managed C++ public: PrimarySurfaceAlreadyExistsException(
String *message,
Exception *inner
);
JScript .NET public function PrimarySurfaceAlreadyExistsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PrimarySurfaceAlreadyExistsException(
string message
);
Managed C++ public: PrimarySurfaceAlreadyExistsException(
String *message
);
JScript .NET public function PrimarySurfaceAlreadyExistsException(
message : String
);

Parameters

message System.String.


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PrimarySurfaceAlreadyExistsException();
Managed C++ | public: PrimarySurfaceAlreadyExistsException();
JScript .NET | public function PrimarySurfaceAlreadyExistsException();


Microsoft.DirectX.DirectDraw.RegionTooSmallException

Microsoft DirectX 9.0 SDK Update (October 2004)

RegionTooSmallException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The region passed to the Clipper.ClipList property is too small. Deprecated.

Definition

Visual Basic .NET Public Class RegionTooSmallException
Inherits GraphicsException
C# | public class RegionTooSmallException : GraphicsException
Managed C++ | public __gc class RegionTooSmallException : public GraphicsException
JScript .NET | public class RegionTooSmallException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
RegionTooSmallException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
RegionTooSmallException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RegionTooSmallException.RegionTooSmallException

Microsoft DirectX 9.0 SDK Update (October 2004)

RegionTooSmallException.RegionTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public RegionTooSmallException();
protected RegionTooSmallException(SerializationInfo, StreamingContext);
public RegionTooSmallException(string);
public RegionTooSmallException(string, Exception);


RegionTooSmallException.RegionTooSmallException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

RegionTooSmallException.RegionTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected RegionTooSmallException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: RegionTooSmallException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function RegionTooSmallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


RegionTooSmallException.RegionTooSmallException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

RegionTooSmallException.RegionTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public RegionTooSmallException(
string message,
Exception inner
);
Managed C++ public: RegionTooSmallException(
String *message,
Exception *inner
);
JScript .NET public function RegionTooSmallException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


RegionTooSmallException.RegionTooSmallException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

RegionTooSmallException.RegionTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public RegionTooSmallException(
string message
);
Managed C++ public: RegionTooSmallException(
String *message
);
JScript .NET public function RegionTooSmallException(
message : String
);

Parameters

message System.String.


RegionTooSmallException.RegionTooSmallException()

Microsoft DirectX 9.0 SDK Update (October 2004)

RegionTooSmallException.RegionTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public RegionTooSmallException();
Managed C++ | public: RegionTooSmallException();
JScript .NET | public function RegionTooSmallException();


Microsoft.DirectX.DirectDraw.Surface

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A surface represents a linear area of display memory. A surface usually resides in the display memory of the display card, although surfaces can exist in system memory. Unless specifically instructed otherwise during the creation of the Surface object, DirectDraw will put the Surface object wherever the best performance can be achieved given the requested capabilities. Surface objects can take advantage of specialized processors on display cards, not only to perform certain tasks faster, but to perform some tasks in parallel with the system CPU. Deprecated.

Definition

Visual Basic .NET Public Class Surface
Inherits MarshalByRefObject
Implements ICloneable, IDisposable
C# public class Surface : MarshalByRefObject,
ICloneable, IDisposable
Managed C++ public __gc class Surface : public MarshalByRefObject,
ICloneable, IDisposable
JScript .NET public class Surface extends MarshalByRefObject
implements IDisposable, ICloneable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method | Description
ChangeUniquenessValue
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Manually updates the uniqueness value for this surface. Deprecated.
Clone
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.
ColorFill
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Draw
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.
DrawBox
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawCircle
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawEllipse
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawFast
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.
DrawLine
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawRoundedBox
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawText
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawToDc
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
Flip
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface memory associated with the BackBuffer surface become associated with the front-buffer surface. Deprecated.
GetAttachedSurface
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains the attached surface that has the specified capabilities. Deprecated.
GetColorKey
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color key value for the DirectDrawSurface object. Deprecated.
GetDc
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetOverlayPosition
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Given a visible, active overlay surface, the GetOverlayPosition method returns the display coordinates of the surface Deprecated.
Lock | Allows manipulation of surface memory.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
PageLock
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Prevents a system-memory surface from being paged out while a blit operation that uses direct memory access (DMA) transfers to or from system memory is in progress. Deprecated.
PageUnlock
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unlocks a system-memory surface, allowing it to be paged out. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
ReleaseDc
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Release a device context handle. Deprecated.
Restore
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores a surface that has been lost. This occurs when the surface memory associated with the DirectDrawSurface object has been freed. Deprecated.
SetColorKey
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the color key value for the DirectDrawSurface object if the hardware supports color keys on a per-surface basis. Deprecated.
SetOverlayPosition
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the display coordinates of an overlay surface. Deprecated.
Surface
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Unlock
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
UpdateOverlay
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.
UpdateOverlayZOrder
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the z-order of an overlay. Deprecated.

Properties

Property Description
CanDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether a blit involving this surface can occur immediately. Deprecated.
CanFlip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether this surface can be flipped immediately. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of the surface. These capabilities are not necessarily related to the capabilities of the display device. Deprecated.
Clipper
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Clipper object associated with this surface. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
DrawDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrives the device that was used to create the surface. Deprecated.
DrawStyle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current drawing style. Deprecated.
DrawWidth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current draw width Deprecated.
FillColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill color. Deprecated.
FillStyle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill style. Deprecated.
FontBackColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font back color. Deprecated.
FontHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font handle. Deprecated.
FontTransparency
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font transparency. Deprecated.
ForeColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font foreground color. Deprecated.
IsDrawDone
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the blit is done, and returns true if the last blit on this surface has completed. Deprecated.
IsFlipDone
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the flip has finished, and returns true if the last flip on this surface has completed. Deprecated.
IsLost
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the surface memory associated with a DirectDrawSurface object has been freed. Deprecated.
Palette
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Palette object associated with this surface. Deprecated.
PixelFormat
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color and pixel format of the surface. Deprecated.
SurfaceDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a description of the surface in its current condition. Deprecated.
UniquenessValue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current uniqueness value for this surface. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Surface

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Surface.ChangeUniquenessValue()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ChangeUniquenessValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Manually updates the uniqueness value for this surface. Deprecated.

Definition

Visual Basic .NET | Public Sub ChangeUniquenessValue()
C# | public void ChangeUniquenessValue();
Managed C++ | public: void ChangeUniquenessValue();
JScript .NET | public function ChangeUniquenessValue();


Surface.Clone()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function Clone() As Object
C# | public override object Clone();
Managed C++ | public: Object* Clone();
JScript .NET | public override function Clone() : Object;

Return Value

System.Object .


Surface.ColorFill

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Overload List

public void ColorFill(Color);
public void ColorFill(int);
public void ColorFill(Rectangle, Color);
public void ColorFill(Rectangle, int);


Surface.ColorFill(Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic .NET Public Sub ColorFill( _
ByVal fillValue As Color _
)
C# public void ColorFill(
Color fillValue
);
Managed C++ public: void ColorFill(
Color fillValue
);
JScript .NET public function ColorFill(
fillValue : Color
);

Parameters

fillValue System.Drawing.Color.


Surface.ColorFill(Rectangle,Color)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic .NET Public Sub ColorFill( _
ByVal destRectangle As Rectangle, _
ByVal fillValue As Color _
)
C# public void ColorFill(
Rectangle destRectangle,
Color fillValue
);
Managed C++ public: void ColorFill(
Rectangle destRectangle,
Color fillValue
);
JScript .NET public function ColorFill(
destRectangle : Rectangle,
fillValue : Color
);

Parameters

destRectangle | System.Drawing.Rectangle.
fillValue | System.Drawing.Color.


Surface.ColorFill(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic .NET Public Sub ColorFill( _
ByVal fillValue As Integer _
)
C# public void ColorFill(
int fillValue
);
Managed C++ public: void ColorFill(
int fillValue
);
JScript .NET public function ColorFill(
fillValue : int
);

Parameters

fillValue System.Int32.


Surface.ColorFill(Rectangle,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ColorFill Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic .NET Public Sub ColorFill( _
ByVal destRectangle As Rectangle, _
ByVal fillValue As Integer _
)
C# public void ColorFill(
Rectangle destRectangle,
int fillValue
);
Managed C++ public: void ColorFill(
Rectangle destRectangle,
int fillValue
);
JScript .NET public function ColorFill(
destRectangle : Rectangle,
fillValue : int
);

Parameters

destRectangle | System.Drawing.Rectangle.
fillValue | System.Int32.


Surface.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


Surface.Draw

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Overload List

public void Draw(Rectangle, Surface, DrawFlags);
public void Draw(Rectangle, Surface, DrawFlags, DrawEffects);
public void Draw(Rectangle, Surface, Rectangle, DrawFlags);
public void Draw(Rectangle, Surface, Rectangle, DrawFlags, DrawEffects);
public void Draw(Surface, DrawFlags);
public void Draw(Surface, DrawFlags, DrawEffects);
public void Draw(Surface, Rectangle, DrawFlags);
public void Draw(Surface, Rectangle, DrawFlags, DrawEffects);


Surface.Draw(Surface,DrawFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Surface sourceSurface,
DrawFlags flags
);
Managed C++ public: void Draw(
Surface *sourceSurface,
DrawFlags flags
);
JScript .NET public function Draw(
sourceSurface : Surface,
flags : DrawFlags
);

Parameters

sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.


Surface.Draw(Rectangle,Surface,DrawFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
DrawFlags flags
);
Managed C++ public: void Draw(
Rectangle destRectangle,
Surface *sourceSurface,
DrawFlags flags
);
JScript .NET public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
flags : DrawFlags
);

Parameters

destRectangle | System.Drawing.Rectangle.
sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.


Surface.Draw(Surface,Rectangle,DrawFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
Managed C++ public: void Draw(
Surface *sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
JScript .NET public function Draw(
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags
);

Parameters

sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
srcRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.


Surface.Draw(Rectangle,Surface,Rectangle,DrawFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
Managed C++ public: void Draw(
Rectangle destRectangle,
Surface *sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
JScript .NET public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags
);

Parameters

destRectangle | System.Drawing.Rectangle.
sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
srcRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.


Surface.Draw(Surface,DrawFlags,DrawEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Surface sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
Managed C++ public: void Draw(
Surface *sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
JScript .NET public function Draw(
sourceSurface : Surface,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.
bltEffects | Microsoft.DirectX.DirectDraw.DrawEffects.


Surface.Draw(Rectangle,Surface,DrawFlags,DrawEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
Managed C++ public: void Draw(
Rectangle destRectangle,
Surface *sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
JScript .NET public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

destRectangle | System.Drawing.Rectangle.
sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.
bltEffects | Microsoft.DirectX.DirectDraw.DrawEffects.


Surface.Draw(Surface,Rectangle,DrawFlags,DrawEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
Managed C++ public: void Draw(
Surface *sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
JScript .NET public function Draw(
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
srcRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.
bltEffects | Microsoft.DirectX.DirectDraw.DrawEffects.


Surface.Draw(Rectangle,Surface,Rectangle,DrawFlags,DrawEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Draw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic .NET Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
Managed C++ public: void Draw(
Rectangle destRectangle,
Surface *sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
JScript .NET public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

destRectangle | System.Drawing.Rectangle.
sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
srcRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.DrawFlags.
bltEffects | Microsoft.DirectX.DirectDraw.DrawEffects.


Surface.DrawBox(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET Public Sub DrawBox( _
ByVal left As Integer, _
ByVal top As Integer, _
ByVal right As Integer, _
ByVal bottom As Integer _
)
C# public void DrawBox(
int left,
int top,
int right,
int bottom
);
Managed C++ public: void DrawBox(
int left,
int top,
int right,
int bottom
);
JScript .NET public function DrawBox(
left : int,
top : int,
right : int,
bottom : int
);

Parameters

left | System.Int32.
top | System.Int32.
right | System.Int32.
bottom | System.Int32.


Surface.DrawCircle(Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawCircle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET Public Sub DrawCircle( _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal radius As Integer _
)
C# public void DrawCircle(
int x,
int y,
int radius
);
Managed C++ public: void DrawCircle(
int x,
int y,
int radius
);
JScript .NET public function DrawCircle(
x : int,
y : int,
radius : int
);

Parameters

x | System.Int32.
y | System.Int32.
radius | System.Int32.


Surface.DrawEllipse(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawEllipse Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET Public Sub DrawEllipse( _
ByVal x1 As Integer, _
ByVal y1 As Integer, _
ByVal x2 As Integer, _
ByVal y2 As Integer _
)
C# public void DrawEllipse(
int x1,
int y1,
int x2,
int y2
);
Managed C++ public: void DrawEllipse(
int x1,
int y1,
int x2,
int y2
);
JScript .NET public function DrawEllipse(
x1 : int,
y1 : int,
x2 : int,
y2 : int
);

Parameters

x1 | System.Int32.
y1 | System.Int32.
x2 | System.Int32.
y2 | System.Int32.


Surface.DrawFast

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawFast Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.

Overload List

public void DrawFast(int, int, Surface, DrawFastFlags);
public void DrawFast(int, int, Surface, Rectangle, DrawFastFlags);


Surface.DrawFast(Int32,Int32,Surface,DrawFastFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawFast Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.

Definition

Visual Basic .NET Public Sub DrawFast( _
ByVal xcoord As Integer, _
ByVal ycoord As Integer, _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFastFlags _
)
C# public void DrawFast(
int xcoord,
int ycoord,
Surface sourceSurface,
DrawFastFlags flags
);
Managed C++ public: void DrawFast(
int xcoord,
int ycoord,
Surface *sourceSurface,
DrawFastFlags flags
);
JScript .NET public function DrawFast(
xcoord : int,
ycoord : int,
sourceSurface : Surface,
flags : DrawFastFlags
);

Parameters

xcoord | System.Int32.
ycoord | System.Int32.
sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.DrawFastFlags.


Surface.DrawFast(Int32,Int32,Surface,Rectangle,DrawFastFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawFast Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.

Definition

Visual Basic .NET Public Sub DrawFast( _
ByVal xcoord As Integer, _
ByVal ycoord As Integer, _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFastFlags _
)
C# public void DrawFast(
int xcoord,
int ycoord,
Surface sourceSurface,
Rectangle srcRectangle,
DrawFastFlags flags
);
Managed C++ public: void DrawFast(
int xcoord,
int ycoord,
Surface *sourceSurface,
Rectangle srcRectangle,
DrawFastFlags flags
);
JScript .NET public function DrawFast(
xcoord : int,
ycoord : int,
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFastFlags
);

Parameters

xcoord | System.Int32.
ycoord | System.Int32.
sourceSurface | Microsoft.DirectX.DirectDraw.Surface.
srcRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.DrawFastFlags.


Surface.DrawLine(Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawLine Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET Public Sub DrawLine( _
ByVal x1 As Integer, _
ByVal y1 As Integer, _
ByVal x2 As Integer, _
ByVal y2 As Integer _
)
C# public void DrawLine(
int x1,
int y1,
int x2,
int y2
);
Managed C++ public: void DrawLine(
int x1,
int y1,
int x2,
int y2
);
JScript .NET public function DrawLine(
x1 : int,
y1 : int,
x2 : int,
y2 : int
);

Parameters

x1 | System.Int32.
y1 | System.Int32.
x2 | System.Int32.
y2 | System.Int32.


Surface.DrawRoundedBox(Int32,Int32,Int32,Int32,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawRoundedBox Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET Public Sub DrawRoundedBox( _
ByVal left As Integer, _
ByVal top As Integer, _
ByVal right As Integer, _
ByVal bottom As Integer, _
ByVal rw As Integer, _
ByVal rh As Integer _
)
C# public void DrawRoundedBox(
int left,
int top,
int right,
int bottom,
int rw,
int rh
);
Managed C++ public: void DrawRoundedBox(
int left,
int top,
int right,
int bottom,
int rw,
int rh
);
JScript .NET public function DrawRoundedBox(
left : int,
top : int,
right : int,
bottom : int,
rw : int,
rh : int
);

Parameters

left | System.Int32.
top | System.Int32.
right | System.Int32.
bottom | System.Int32.
rw | System.Int32.
rh | System.Int32.


Surface.DrawText(Int32,Int32,String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawText Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET Public Sub DrawText( _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal text As String, _
ByVal drawAtLastPosition As Boolean _
)
C# public void DrawText(
int x,
int y,
string text,
bool drawAtLastPosition
);
Managed C++ public: void DrawText(
int x,
int y,
String *text,
bool drawAtLastPosition
);
JScript .NET public function DrawText(
x : int,
y : int,
text : String,
drawAtLastPosition : boolean
);

Parameters

x | System.Int32.
y | System.Int32.
text | System.String.
drawAtLastPosition | System.Boolean.


Surface.DrawToDc(IntPtr,Rectangle,Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawToDc Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET Public Sub DrawToDc( _
ByVal hdc As IntPtr, _
ByVal destRect As Rectangle, _
ByVal srcRect As Rectangle _
)
C# public void DrawToDc(
IntPtr hdc,
Rectangle destRect,
Rectangle srcRect
);
Managed C++ public: void DrawToDc(
IntPtr hdc,
Rectangle destRect,
Rectangle srcRect
);
JScript .NET public function DrawToDc(
hdc : IntPtr,
destRect : Rectangle,
srcRect : Rectangle
);

Parameters

hdc | System.IntPtr.
destRect | System.Drawing.Rectangle.
srcRect | System.Drawing.Rectangle.


Surface.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Surface.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Surface();
Managed C++ | ~Surface();
JScript .NET | protected override function Finalize();


Surface.Flip(Surface,FlipFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Flip Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface memory associated with the BackBuffer surface become associated with the front-buffer surface. Deprecated.

Definition

Visual Basic .NET Public Sub Flip( _
ByVal surface As Surface, _
ByVal flags As FlipFlags _
)
C# public void Flip(
Surface surface,
FlipFlags flags
);
Managed C++ public: void Flip(
Surface *surface,
FlipFlags flags
);
JScript .NET public function Flip(
surface : Surface,
flags : FlipFlags
);

Parameters

surface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.FlipFlags.


Surface.GetAttachedSurface(SurfaceCaps)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetAttachedSurface Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains the attached surface that has the specified capabilities. Deprecated.

Definition

Visual Basic .NET Public Function GetAttachedSurface( _
ByVal caps As SurfaceCaps _
) As Surface
C# public Surface GetAttachedSurface(
SurfaceCaps caps
);
Managed C++ public: Surface* GetAttachedSurface(
SurfaceCaps *caps
);
JScript .NET public function GetAttachedSurface(
caps : SurfaceCaps
) : Surface;

Parameters

caps Microsoft.DirectX.DirectDraw.SurfaceCaps.

Return Value

Microsoft.DirectX.DirectDraw.Surface .


Surface.GetColorKey(ColorKeyFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetColorKey Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color key value for the DirectDrawSurface object. Deprecated.

Definition

Visual Basic .NET Public Function GetColorKey( _
ByVal flags As ColorKeyFlags _
) As ColorKey
C# public ColorKey GetColorKey(
ColorKeyFlags flags
);
Managed C++ public: ColorKey GetColorKey(
ColorKeyFlags flags
);
JScript .NET public function GetColorKey(
flags : ColorKeyFlags
) : ColorKey;

Parameters

flags Microsoft.DirectX.DirectDraw.ColorKeyFlags.

Return Value

Microsoft.DirectX.DirectDraw.ColorKey .


Surface.GetDc()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetDc Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic .NET | Public Function GetDc() As IntPtr
C# | public IntPtr GetDc();
Managed C++ | public: IntPtr GetDc();
JScript .NET | public function GetDc() : IntPtr;

Return Value

System.IntPtr .


Surface.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Surface.GetOverlayPosition()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.GetOverlayPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Given a visible, active overlay surface, the GetOverlayPosition method returns the display coordinates of the surface Deprecated.

Definition

Visual Basic .NET | Public Function GetOverlayPosition() As Point
C# | public Point GetOverlayPosition();
Managed C++ | public: Point GetOverlayPosition();
JScript .NET | public function GetOverlayPosition() : Point;

Return Value

System.Drawing.Point .


Surface.Lock

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows manipulation of surface memory.

Overload List

public LockedData Lock(LockFlags);
public LockedData Lock(Rectangle, LockFlags);


Surface.Lock(LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Allows manipulation of surface memory. Deprecated.

Definition

Visual Basic .NET Public Function Lock( _
ByVal flags As LockFlags _
) As LockedData
C# public LockedData Lock(
LockFlags flags
);
Managed C++ public: LockedData Lock(
LockFlags flags
);
JScript .NET public function Lock(
flags : LockFlags
) : LockedData;

Parameters

flags Microsoft.DirectX.DirectDraw.LockFlags.

Return Value

Microsoft.DirectX.DirectDraw.LockedData .


Surface.Lock(Rectangle,LockFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Lock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows manipulation of surface memory.

Definition

Visual Basic .NET Public Function Lock( _
ByVal destRectangle As Rectangle, _
ByVal flags As LockFlags _
) As LockedData
C# public LockedData Lock(
Rectangle destRectangle,
LockFlags flags
);
Managed C++ public: LockedData Lock(
Rectangle destRectangle,
LockFlags flags
);
JScript .NET public function Lock(
destRectangle : Rectangle,
flags : LockFlags
) : LockedData;

Parameters

destRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.LockFlags.

Return Value

Microsoft.DirectX.DirectDraw.LockedData .


Surface.op_Equality(Surface,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Surface, _
ByVal right As Surface _
) As Boolean
C# public static bool op_Equality(
Surface left,
Surface right
);
Managed C++ public: static bool op_Equality(
Surface *left,
Surface *right
);
JScript .NET public static function op_Equality(
left : Surface,
right : Surface
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Surface. The Surface structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.Surface. The Surface structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Surface.op_Inequality(Surface,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Surface, _
ByVal right As Surface _
) As Boolean
C# public static bool op_Inequality(
Surface left,
Surface right
);
Managed C++ public: static bool op_Inequality(
Surface *left,
Surface *right
);
JScript .NET public static function op_Inequality(
left : Surface,
right : Surface
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.Surface. The Surface structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.Surface. The Surface structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Surface.PageLock()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.PageLock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Prevents a system-memory surface from being paged out while a blit operation that uses direct memory access (DMA) transfers to or from system memory is in progress. Deprecated.

Definition

Visual Basic .NET | Public Sub PageLock()
C# | public void PageLock();
Managed C++ | public: void PageLock();
JScript .NET | public function PageLock();


Surface.PageUnlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.PageUnlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unlocks a system-memory surface, allowing it to be paged out. Deprecated.

Definition

Visual Basic .NET | Public Sub PageUnlock()
C# | public void PageUnlock();
Managed C++ | public: void PageUnlock();
JScript .NET | public function PageUnlock();


Surface.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Surface.ReleaseDc(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ReleaseDc Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Release a device context handle. Deprecated.

Definition

Visual Basic .NET Public Sub ReleaseDc( _
ByVal hdc As IntPtr _
)
C# public void ReleaseDc(
IntPtr hdc
);
Managed C++ public: void ReleaseDc(
IntPtr hdc
);
JScript .NET public function ReleaseDc(
hdc : IntPtr
);

Parameters

hdc System.IntPtr.


Surface.Restore()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Restore Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores a surface that has been lost. This occurs when the surface memory associated with the DirectDrawSurface object has been freed. Deprecated.

Definition

Visual Basic .NET | Public Sub Restore()
C# | public void Restore();
Managed C++ | public: void Restore();
JScript .NET | public function Restore();


Surface.SetColorKey(ColorKeyFlags,ColorKey)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.SetColorKey Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the color key value for the DirectDrawSurface object if the hardware supports color keys on a per-surface basis. Deprecated.

Definition

Visual Basic .NET Public Sub SetColorKey( _
ByVal flags As ColorKeyFlags, _
ByVal value As ColorKey _
)
C# public void SetColorKey(
ColorKeyFlags flags,
ColorKey value
);
Managed C++ public: void SetColorKey(
ColorKeyFlags flags,
ColorKey value
);
JScript .NET public function SetColorKey(
flags : ColorKeyFlags,
value : ColorKey
);

Parameters

flags | Microsoft.DirectX.DirectDraw.ColorKeyFlags.
value | Microsoft.DirectX.DirectDraw.ColorKey.


Surface.SetOverlayPosition(Point)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.SetOverlayPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the display coordinates of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub SetOverlayPosition( _
ByVal position As Point _
)
C# public void SetOverlayPosition(
Point position
);
Managed C++ public: void SetOverlayPosition(
Point position
);
JScript .NET public function SetOverlayPosition(
position : Point
);

Parameters

position System.Drawing.Point.


Surface.Surface

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Surface(Bitmap, SurfaceDescription, Device);
public Surface(Stream, SurfaceDescription, Device);
public Surface(string, SurfaceDescription, Device);
public Surface(SurfaceDescription, Device);


Surface.Surface(Stream,SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
Stream source,
SurfaceDescription desc,
Device dev
);
Managed C++ public: Surface(
Stream *source,
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function Surface(
source : Stream,
desc : SurfaceDescription,
dev : Device
);

Parameters

source | System.IO.Stream.
desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


Surface.Surface(Bitmap,SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Bitmap, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
Bitmap source,
SurfaceDescription desc,
Device dev
);
Managed C++ public: Surface(
Bitmap *source,
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function Surface(
source : Bitmap,
desc : SurfaceDescription,
dev : Device
);

Parameters

source | System.Drawing.Bitmap.
desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


Surface.Surface(String,SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal filename As String, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
string filename,
SurfaceDescription desc,
Device dev
);
Managed C++ public: Surface(
String *filename,
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function Surface(
filename : String,
desc : SurfaceDescription,
dev : Device
);

Parameters

filename | System.String.
desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


Surface.Surface(SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Surface Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
SurfaceDescription desc,
Device dev
);
Managed C++ public: Surface(
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function Surface(
desc : SurfaceDescription,
dev : Device
);

Parameters

desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


Surface.Unlock

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Unlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Overload List

public void Unlock();
public void Unlock(Rectangle);


Surface.Unlock()

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Unlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Sub Unlock()
C# | public void Unlock();
Managed C++ | public: void Unlock();
JScript .NET | public function Unlock();


Surface.Unlock(Rectangle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Unlock Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub Unlock( _
ByVal destRectangle As Rectangle _
)
C# public void Unlock(
Rectangle destRectangle
);
Managed C++ public: void Unlock(
Rectangle destRectangle
);
JScript .NET public function Unlock(
destRectangle : Rectangle
);

Parameters

destRectangle System.Drawing.Rectangle.


Surface.UpdateOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Overload List

public void UpdateOverlay(Rectangle, Surface, OverlayFlags);
public void UpdateOverlay(Rectangle, Surface, OverlayFlags, OverlayEffects);
public void UpdateOverlay(Rectangle, Surface, Rectangle, OverlayFlags);
public void UpdateOverlay(Rectangle, Surface, Rectangle, OverlayFlags, OverlayEffects);
public void UpdateOverlay(Surface, OverlayFlags);
public void UpdateOverlay(Surface, OverlayFlags, OverlayEffects);
public void UpdateOverlay(Surface, Rectangle, OverlayFlags);
public void UpdateOverlay(Surface, Rectangle, OverlayFlags, OverlayEffects);


Surface.UpdateOverlay(Surface,OverlayFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Surface destSurface,
OverlayFlags flags
);
Managed C++ public: void UpdateOverlay(
Surface *destSurface,
OverlayFlags flags
);
JScript .NET public function UpdateOverlay(
destSurface : Surface,
flags : OverlayFlags
);

Parameters

destSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.


Surface.UpdateOverlay(Rectangle,Surface,OverlayFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
OverlayFlags flags
);
Managed C++ public: void UpdateOverlay(
Rectangle srcRectangle,
Surface *destSurface,
OverlayFlags flags
);
JScript .NET public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
flags : OverlayFlags
);

Parameters

srcRectangle | System.Drawing.Rectangle.
destSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.


Surface.UpdateOverlay(Surface,Rectangle,OverlayFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
Managed C++ public: void UpdateOverlay(
Surface *destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
JScript .NET public function UpdateOverlay(
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags
);

Parameters

destSurface | Microsoft.DirectX.DirectDraw.Surface.
destRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.


Surface.UpdateOverlay(Rectangle,Surface,Rectangle,OverlayFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
Managed C++ public: void UpdateOverlay(
Rectangle srcRectangle,
Surface *destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
JScript .NET public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags
);

Parameters

srcRectangle | System.Drawing.Rectangle.
destSurface | Microsoft.DirectX.DirectDraw.Surface.
destRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.


Surface.UpdateOverlay(Surface,OverlayFlags,OverlayEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Surface destSurface,
OverlayFlags flags,
OverlayEffects effects
);
Managed C++ public: void UpdateOverlay(
Surface *destSurface,
OverlayFlags flags,
OverlayEffects effects
);
JScript .NET public function UpdateOverlay(
destSurface : Surface,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

destSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.
effects | Microsoft.DirectX.DirectDraw.OverlayEffects.


Surface.UpdateOverlay(Rectangle,Surface,OverlayFlags,OverlayEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
OverlayFlags flags,
OverlayEffects effects
);
Managed C++ public: void UpdateOverlay(
Rectangle srcRectangle,
Surface *destSurface,
OverlayFlags flags,
OverlayEffects effects
);
JScript .NET public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

srcRectangle | System.Drawing.Rectangle.
destSurface | Microsoft.DirectX.DirectDraw.Surface.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.
effects | Microsoft.DirectX.DirectDraw.OverlayEffects.


Surface.UpdateOverlay(Surface,Rectangle,OverlayFlags,OverlayEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
Managed C++ public: void UpdateOverlay(
Surface *destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
JScript .NET public function UpdateOverlay(
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

destSurface | Microsoft.DirectX.DirectDraw.Surface.
destRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.
effects | Microsoft.DirectX.DirectDraw.OverlayEffects.


Surface.UpdateOverlay(Rectangle,Surface,Rectangle,OverlayFlags,OverlayEffects)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlay Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
Managed C++ public: void UpdateOverlay(
Rectangle srcRectangle,
Surface *destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
JScript .NET public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

srcRectangle | System.Drawing.Rectangle.
destSurface | Microsoft.DirectX.DirectDraw.Surface.
destRectangle | System.Drawing.Rectangle.
flags | Microsoft.DirectX.DirectDraw.OverlayFlags.
effects | Microsoft.DirectX.DirectDraw.OverlayEffects.


Surface.UpdateOverlayZOrder(OverlayZFlags,Surface)

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UpdateOverlayZOrder Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the z-order of an overlay. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateOverlayZOrder( _
ByVal flags As OverlayZFlags, _
ByVal surface As Surface _
)
C# public void UpdateOverlayZOrder(
OverlayZFlags flags,
Surface surface
);
Managed C++ public: void UpdateOverlayZOrder(
OverlayZFlags flags,
Surface *surface
);
JScript .NET public function UpdateOverlayZOrder(
flags : OverlayZFlags,
surface : Surface
);

Parameters

flags | Microsoft.DirectX.DirectDraw.OverlayZFlags.
surface | Microsoft.DirectX.DirectDraw.Surface.


Surface.CanDraw

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.CanDraw Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether a blit involving this surface can occur immediately. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CanDraw As Boolean
C# | public bool CanDraw { get; }
Managed C++ | public: __property bool get_CanDraw();
JScript .NET | public function get CanDraw() : boolean

Property Value

System.Boolean .

This property is read-only.


Surface.CanFlip

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.CanFlip Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether this surface can be flipped immediately. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CanFlip As Boolean
C# | public bool CanFlip { get; }
Managed C++ | public: __property bool get_CanFlip();
JScript .NET | public function get CanFlip() : boolean

Property Value

System.Boolean .

This property is read-only.


Surface.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of the surface. These capabilities are not necessarily related to the capabilities of the display device. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Caps As SurfaceCaps
C# | public SurfaceCaps Caps { get; }
Managed C++ | public: __property SurfaceCaps* get_Caps();
JScript .NET | public function get Caps() : SurfaceCaps

Property Value

Microsoft.DirectX.DirectDraw.SurfaceCaps .

This property is read-only.


Surface.Clipper

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Clipper Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Clipper object associated with this surface. Deprecated.

Definition

Visual Basic .NET | Public Property Clipper As Clipper
C# | public Clipper Clipper { get; set; }
Managed C++ public: __property Clipper* get_Clipper();
public: __property void set_Clipper(Clipper*);
JScript .NET public function get Clipper() : Clipper
public function set Clipper(Clipper);

Property Value

Microsoft.DirectX.DirectDraw.Clipper .

This property is read/write.


Surface.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Surface.DrawDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrives the device that was used to create the surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawDevice As Device
C# | public Device DrawDevice { get; }
Managed C++ | public: __property Device* get_DrawDevice();
JScript .NET | public function get DrawDevice() : Device

Property Value

Microsoft.DirectX.DirectDraw.Device .

This property is read-only.


Surface.DrawStyle

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawStyle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current drawing style. Deprecated.

Definition

Visual Basic .NET | Public Property DrawStyle As Integer
C# | public int DrawStyle { get; set; }
Managed C++ public: __property int get_DrawStyle();
public: __property void set_DrawStyle(int);
JScript .NET public function get DrawStyle() : int
public function set DrawStyle(int);

Property Value

System.Int32 .

This property is read/write.


Surface.DrawWidth

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.DrawWidth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current draw width Deprecated.

Definition

Visual Basic .NET | Public Property DrawWidth As Integer
C# | public int DrawWidth { get; set; }
Managed C++ public: __property int get_DrawWidth();
public: __property void set_DrawWidth(int);
JScript .NET public function get DrawWidth() : int
public function set DrawWidth(int);

Property Value

System.Int32 .

This property is read/write.


Surface.FillColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.FillColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill color. Deprecated.

Definition

Visual Basic .NET | Public Property FillColor As Color
C# | public Color FillColor { get; set; }
Managed C++ public: __property Color get_FillColor();
public: __property void set_FillColor(Color);
JScript .NET public function get FillColor() : Color
public function set FillColor(Color);

Property Value

System.Drawing.Color .

This property is read/write.


Surface.FillStyle

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.FillStyle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill style. Deprecated.

Definition

Visual Basic .NET | Public Property FillStyle As Integer
C# | public int FillStyle { get; set; }
Managed C++ public: __property int get_FillStyle();
public: __property void set_FillStyle(int);
JScript .NET public function get FillStyle() : int
public function set FillStyle(int);

Property Value

System.Int32 .

This property is read/write.


Surface.FontBackColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.FontBackColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font back color. Deprecated.

Definition

Visual Basic .NET | Public Property FontBackColor As Color
C# | public Color FontBackColor { get; set; }
Managed C++ public: __property Color get_FontBackColor();
public: __property void set_FontBackColor(Color);
JScript .NET public function get FontBackColor() : Color
public function set FontBackColor(Color);

Property Value

System.Drawing.Color .

This property is read/write.


Surface.FontHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.FontHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font handle. Deprecated.

Definition

Visual Basic .NET Public Property FontHandle( _
ByVal value As IntPtr _
) As IntPtr
C# public IntPtr this[
IntPtr value
] { set; }
Managed C++ public: __property void set_FontHandle(
IntPtr value,
IntPtr
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

System.IntPtr .

This property is write-only.

Parameters

value System.IntPtr.


Surface.FontTransparency

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.FontTransparency Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font transparency. Deprecated.

Definition

Visual Basic .NET | Public Property FontTransparency As Boolean
C# | public bool FontTransparency { get; set; }
Managed C++ public: __property bool get_FontTransparency();
public: __property void set_FontTransparency(bool);
JScript .NET public function get FontTransparency() : boolean
public function set FontTransparency(boolean);

Property Value

System.Boolean .

This property is read/write.


Surface.ForeColor

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.ForeColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font foreground color. Deprecated.

Definition

Visual Basic .NET | Public Property ForeColor As Color
C# | public Color ForeColor { get; set; }
Managed C++ public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color);
JScript .NET public function get ForeColor() : Color
public function set ForeColor(Color);

Property Value

System.Drawing.Color .

This property is read/write.


Surface.IsDrawDone

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.IsDrawDone Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the blit is done, and returns true if the last blit on this surface has completed. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsDrawDone As Boolean
C# | public bool IsDrawDone { get; }
Managed C++ | public: __property bool get_IsDrawDone();
JScript .NET | public function get IsDrawDone() : boolean

Property Value

System.Boolean .

This property is read-only.


Surface.IsFlipDone

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.IsFlipDone Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the flip has finished, and returns true if the last flip on this surface has completed. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsFlipDone As Boolean
C# | public bool IsFlipDone { get; }
Managed C++ | public: __property bool get_IsFlipDone();
JScript .NET | public function get IsFlipDone() : boolean

Property Value

System.Boolean .

This property is read-only.


Surface.IsLost

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.IsLost Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the surface memory associated with a DirectDrawSurface object has been freed. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsLost As Boolean
C# | public bool IsLost { get; }
Managed C++ | public: __property bool get_IsLost();
JScript .NET | public function get IsLost() : boolean

Property Value

System.Boolean .

This property is read-only.


Surface.Palette

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Palette Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Palette object associated with this surface. Deprecated.

Definition

Visual Basic .NET | Public Property Palette As Palette
C# | public Palette Palette { get; set; }
Managed C++ public: __property Palette* get_Palette();
public: __property void set_Palette(Palette*);
JScript .NET public function get Palette() : Palette
public function set Palette(Palette);

Property Value

Microsoft.DirectX.DirectDraw.Palette .

This property is read/write.


Surface.PixelFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.PixelFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color and pixel format of the surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PixelFormat As PixelFormat
C# | public PixelFormat PixelFormat { get; }
Managed C++ | public: __property PixelFormat get_PixelFormat();
JScript .NET | public function get PixelFormat() : PixelFormat

Property Value

Microsoft.DirectX.DirectDraw.PixelFormat .

This property is read-only.


Surface.SurfaceDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.SurfaceDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a description of the surface in its current condition. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SurfaceDescription As SurfaceDescription
C# | public SurfaceDescription SurfaceDescription { get; }
Managed C++ | public: __property SurfaceDescription* get_SurfaceDescription();
JScript .NET | public function get SurfaceDescription() : SurfaceDescription

Property Value

Microsoft.DirectX.DirectDraw.SurfaceDescription .

This property is read-only.


Surface.UniquenessValue

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.UniquenessValue Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current uniqueness value for this surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property UniquenessValue As Integer
C# | public int UniquenessValue { get; }
Managed C++ | public: __property int get_UniquenessValue();
JScript .NET | public function get UniquenessValue() : int

Property Value

System.Int32 .

This property is read-only.


Surface.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Surface.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Surface.Disposing event, use the following code.

surface.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectDraw.SurfaceBusyException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceBusyException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is locked by another thread. Deprecated.

Definition

Visual Basic .NET Public Class SurfaceBusyException
Inherits GraphicsException
C# | public class SurfaceBusyException : GraphicsException
Managed C++ | public __gc class SurfaceBusyException : public GraphicsException
JScript .NET | public class SurfaceBusyException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceBusyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceBusyException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceBusyException.SurfaceBusyException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceBusyException.SurfaceBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceBusyException();
protected SurfaceBusyException(SerializationInfo, StreamingContext);
public SurfaceBusyException(string);
public SurfaceBusyException(string, Exception);


SurfaceBusyException.SurfaceBusyException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceBusyException.SurfaceBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceBusyException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SurfaceBusyException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SurfaceBusyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SurfaceBusyException.SurfaceBusyException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceBusyException.SurfaceBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceBusyException(
string message,
Exception inner
);
Managed C++ public: SurfaceBusyException(
String *message,
Exception *inner
);
JScript .NET public function SurfaceBusyException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SurfaceBusyException.SurfaceBusyException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceBusyException.SurfaceBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SurfaceBusyException(
string message
);
Managed C++ public: SurfaceBusyException(
String *message
);
JScript .NET public function SurfaceBusyException(
message : String
);

Parameters

message System.String.


SurfaceBusyException.SurfaceBusyException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceBusyException.SurfaceBusyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SurfaceBusyException();
Managed C++ | public: SurfaceBusyException();
JScript .NET | public function SurfaceBusyException();


Microsoft.DirectX.DirectDraw.SurfaceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the capabilities of a DirectDrawSurface object. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SurfaceCaps
Inherits Object
C# | public sealed class SurfaceCaps : Object
Managed C++ | public __gc __sealed class SurfaceCaps : public Object
JScript .NET | public class SurfaceCaps extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Clear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Remove all set capabilities. Deprecated.
SurfaceCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface contains alpha-only information. Deprecated.
BackBuffer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the back buffer of a surface flipping structure. Deprecated.
Complex
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A complex surface is being described. A complex surface results in the creation of more than one surface. The additional surfaces are attached to the root surface. The complex surface can be destroyed only by destroying the root. Deprecated.
Flip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a part of a surface-flipping structure. Deprecated.
FrontBuffer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the front buffer of a surface-flipping structure. Deprecated.
HardwareCodec
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can have a stream decompressed to it by the hardware. Deprecated.
LiveVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive live video. Deprecated.
LocalVideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in true, local video memory, rather than nonlocal video memory. If this flag is specified, VideoMemory must be specified, as well. This flag cannot be used with the NonLocalVideoMemory flag. Deprecated.
ModeX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a 320×200 or 320×240 Mode X surface. Deprecated.
NonLocalVideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in nonlocal video memory, rather than true, local video memory. If this flag is specified, VideoMemory flag must be specified, as well. This cannot be used with the LocalVideoMemory flag. Deprecated.
OffScreenPlain
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is any off-screen surface that is not an overlay, front-buffer, back-buffer, or alpha surface. It is used to identify plain surfaces. Deprecated.
Overlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is an overlay. It might or might not be directly visible, depending on whether it is currently being overlaid onto the primary surface. Deprecated.
OwnGraphics
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface has a device context (DC) association for a long period of time. Deprecated.
Palette
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This device driver allows unique DirectDrawPalette objects to be created and attached to this surface. Deprecated.
PrimarySurface
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is the primary surface. It represents what is currently visible. Deprecated.
StandardVgaMode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a standard VGA mode surface, and not a Mode X surface. This flag cannot be used in combination with the ModeX flag. Deprecated.
StereoSurfaceLeft
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is part of a stereo flipping chain. Deprecated.
SystemMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface memory was allocated in system memory. Deprecated.
VideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in display memory. Deprecated.
VideoPort
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive data from a video port. Deprecated.
Visible
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes made to this surface are immediately visible. It is always set for the primary surface, as well as for overlays while they are being overlaid and texture maps while they are being textured. Deprecated.
WriteAccessOnly
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Only write access is permitted to the surface. Read access from the surface can cause a general protection (GP) fault, and the read results from this surface would not be meaningful. Deprecated.

Inheritance Hierarchy

Object Leave Site
SurfaceCaps

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceCaps.Clear()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Remove all set capabilities. Deprecated.

Definition

Visual Basic .NET | Public Sub Clear()
C# | public void Clear();
Managed C++ | public: void Clear();
JScript .NET | public function Clear();


SurfaceCaps.SurfaceCaps()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.SurfaceCaps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SurfaceCaps();
Managed C++ | public: SurfaceCaps();
JScript .NET | public function SurfaceCaps();


SurfaceCaps.Alpha

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.Alpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface contains alpha-only information. Deprecated.

Definition

Visual Basic .NET | Public Property Alpha As Boolean
C# | public bool Alpha { get; set; }
Managed C++ public: __property bool get_Alpha();
public: __property void set_Alpha(bool);
JScript .NET public function get Alpha() : boolean
public function set Alpha(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.BackBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.BackBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the back buffer of a surface flipping structure. Deprecated.

Definition

Visual Basic .NET | Public Property BackBuffer As Boolean
C# | public bool BackBuffer { get; set; }
Managed C++ public: __property bool get_BackBuffer();
public: __property void set_BackBuffer(bool);
JScript .NET public function get BackBuffer() : boolean
public function set BackBuffer(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.Complex

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.Complex Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A complex surface is being described. A complex surface results in the creation of more than one surface. The additional surfaces are attached to the root surface. The complex surface can be destroyed only by destroying the root. Deprecated.

Definition

Visual Basic .NET | Public Property Complex As Boolean
C# | public bool Complex { get; set; }
Managed C++ public: __property bool get_Complex();
public: __property void set_Complex(bool);
JScript .NET public function get Complex() : boolean
public function set Complex(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.Flip

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.Flip Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a part of a surface-flipping structure. Deprecated.

Definition

Visual Basic .NET | Public Property Flip As Boolean
C# | public bool Flip { get; set; }
Managed C++ public: __property bool get_Flip();
public: __property void set_Flip(bool);
JScript .NET public function get Flip() : boolean
public function set Flip(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.FrontBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.FrontBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the front buffer of a surface-flipping structure. Deprecated.

Definition

Visual Basic .NET | Public Property FrontBuffer As Boolean
C# | public bool FrontBuffer { get; set; }
Managed C++ public: __property bool get_FrontBuffer();
public: __property void set_FrontBuffer(bool);
JScript .NET public function get FrontBuffer() : boolean
public function set FrontBuffer(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.HardwareCodec

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.HardwareCodec Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can have a stream decompressed to it by the hardware. Deprecated.

Definition

Visual Basic .NET | Public Property HardwareCodec As Boolean
C# | public bool HardwareCodec { get; set; }
Managed C++ public: __property bool get_HardwareCodec();
public: __property void set_HardwareCodec(bool);
JScript .NET public function get HardwareCodec() : boolean
public function set HardwareCodec(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.LiveVideo

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.LiveVideo Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive live video. Deprecated.

Definition

Visual Basic .NET | Public Property LiveVideo As Boolean
C# | public bool LiveVideo { get; set; }
Managed C++ public: __property bool get_LiveVideo();
public: __property void set_LiveVideo(bool);
JScript .NET public function get LiveVideo() : boolean
public function set LiveVideo(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.LocalVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.LocalVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in true, local video memory, rather than nonlocal video memory. If this flag is specified, VideoMemory must be specified, as well. This flag cannot be used with the NonLocalVideoMemory flag. Deprecated.

Definition

Visual Basic .NET | Public Property LocalVideoMemory As Boolean
C# | public bool LocalVideoMemory { get; set; }
Managed C++ public: __property bool get_LocalVideoMemory();
public: __property void set_LocalVideoMemory(bool);
JScript .NET public function get LocalVideoMemory() : boolean
public function set LocalVideoMemory(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.ModeX

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.ModeX Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a 320×200 or 320×240 Mode X surface. Deprecated.

Definition

Visual Basic .NET | Public Property ModeX As Boolean
C# | public bool ModeX { get; set; }
Managed C++ public: __property bool get_ModeX();
public: __property void set_ModeX(bool);
JScript .NET public function get ModeX() : boolean
public function set ModeX(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.NonLocalVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.NonLocalVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in nonlocal video memory, rather than true, local video memory. If this flag is specified, VideoMemory flag must be specified, as well. This cannot be used with the LocalVideoMemory flag. Deprecated.

Definition

Visual Basic .NET | Public Property NonLocalVideoMemory As Boolean
C# | public bool NonLocalVideoMemory { get; set; }
Managed C++ public: __property bool get_NonLocalVideoMemory();
public: __property void set_NonLocalVideoMemory(bool);
JScript .NET public function get NonLocalVideoMemory() : boolean
public function set NonLocalVideoMemory(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.OffScreenPlain

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.OffScreenPlain Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is any off-screen surface that is not an overlay, front-buffer, back-buffer, or alpha surface. It is used to identify plain surfaces. Deprecated.

Definition

Visual Basic .NET | Public Property OffScreenPlain As Boolean
C# | public bool OffScreenPlain { get; set; }
Managed C++ public: __property bool get_OffScreenPlain();
public: __property void set_OffScreenPlain(bool);
JScript .NET public function get OffScreenPlain() : boolean
public function set OffScreenPlain(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.Overlay

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.Overlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is an overlay. It might or might not be directly visible, depending on whether it is currently being overlaid onto the primary surface. Deprecated.

Definition

Visual Basic .NET | Public Property Overlay As Boolean
C# | public bool Overlay { get; set; }
Managed C++ public: __property bool get_Overlay();
public: __property void set_Overlay(bool);
JScript .NET public function get Overlay() : boolean
public function set Overlay(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.OwnGraphics

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.OwnGraphics Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface has a device context (DC) association for a long period of time. Deprecated.

Definition

Visual Basic .NET | Public Property OwnGraphics As Boolean
C# | public bool OwnGraphics { get; set; }
Managed C++ public: __property bool get_OwnGraphics();
public: __property void set_OwnGraphics(bool);
JScript .NET public function get OwnGraphics() : boolean
public function set OwnGraphics(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.Palette

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.Palette Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This device driver allows unique DirectDrawPalette objects to be created and attached to this surface. Deprecated.

Definition

Visual Basic .NET | Public Property Palette As Boolean
C# | public bool Palette { get; set; }
Managed C++ public: __property bool get_Palette();
public: __property void set_Palette(bool);
JScript .NET public function get Palette() : boolean
public function set Palette(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.PrimarySurface

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.PrimarySurface Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is the primary surface. It represents what is currently visible. Deprecated.

Definition

Visual Basic .NET | Public Property PrimarySurface As Boolean
C# | public bool PrimarySurface { get; set; }
Managed C++ public: __property bool get_PrimarySurface();
public: __property void set_PrimarySurface(bool);
JScript .NET public function get PrimarySurface() : boolean
public function set PrimarySurface(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.StandardVgaMode

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.StandardVgaMode Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a standard VGA mode surface, and not a Mode X surface. This flag cannot be used in combination with the ModeX flag. Deprecated.

Definition

Visual Basic .NET | Public Property StandardVgaMode As Boolean
C# | public bool StandardVgaMode { get; set; }
Managed C++ public: __property bool get_StandardVgaMode();
public: __property void set_StandardVgaMode(bool);
JScript .NET public function get StandardVgaMode() : boolean
public function set StandardVgaMode(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.StereoSurfaceLeft

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.StereoSurfaceLeft Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is part of a stereo flipping chain. Deprecated.

Definition

Visual Basic .NET | Public Property StereoSurfaceLeft As Boolean
C# | public bool StereoSurfaceLeft { get; set; }
Managed C++ public: __property bool get_StereoSurfaceLeft();
public: __property void set_StereoSurfaceLeft(bool);
JScript .NET public function get StereoSurfaceLeft() : boolean
public function set StereoSurfaceLeft(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.SystemMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.SystemMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface memory was allocated in system memory. Deprecated.

Definition

Visual Basic .NET | Public Property SystemMemory As Boolean
C# | public bool SystemMemory { get; set; }
Managed C++ public: __property bool get_SystemMemory();
public: __property void set_SystemMemory(bool);
JScript .NET public function get SystemMemory() : boolean
public function set SystemMemory(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.VideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.VideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in display memory. Deprecated.

Definition

Visual Basic .NET | Public Property VideoMemory As Boolean
C# | public bool VideoMemory { get; set; }
Managed C++ public: __property bool get_VideoMemory();
public: __property void set_VideoMemory(bool);
JScript .NET public function get VideoMemory() : boolean
public function set VideoMemory(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.VideoPort

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.VideoPort Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive data from a video port. Deprecated.

Definition

Visual Basic .NET | Public Property VideoPort As Boolean
C# | public bool VideoPort { get; set; }
Managed C++ public: __property bool get_VideoPort();
public: __property void set_VideoPort(bool);
JScript .NET public function get VideoPort() : boolean
public function set VideoPort(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.Visible

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.Visible Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes made to this surface are immediately visible. It is always set for the primary surface, as well as for overlays while they are being overlaid and texture maps while they are being textured. Deprecated.

Definition

Visual Basic .NET | Public Property Visible As Boolean
C# | public bool Visible { get; set; }
Managed C++ public: __property bool get_Visible();
public: __property void set_Visible(bool);
JScript .NET public function get Visible() : boolean
public function set Visible(boolean);

Property Value

System.Boolean .

This property is read/write.


SurfaceCaps.WriteAccessOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceCaps.WriteAccessOnly Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Only write access is permitted to the surface. Read access from the surface can cause a general protection (GP) fault, and the read results from this surface would not be meaningful. Deprecated.

Definition

Visual Basic .NET | Public Property WriteAccessOnly As Boolean
C# | public bool WriteAccessOnly { get; set; }
Managed C++ public: __property bool get_WriteAccessOnly();
public: __property void set_WriteAccessOnly(bool);
JScript .NET public function get WriteAccessOnly() : boolean
public function set WriteAccessOnly(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.DirectDraw.SurfaceDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A description of a surface. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SurfaceDescription
Inherits Object
C# | public sealed class SurfaceDescription : Object
Managed C++ | public __gc __sealed class SurfaceDescription : public Object
JScript .NET | public class SurfaceDescription extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Clear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reset the object back to defaults. Deprecated.
SurfaceDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
AlphaBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The AlphaBitDepth member is valid. Deprecated.
BackBufferCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The BackBufferCount member is valid. Deprecated.
DestinationDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the destination color key for blit operations. Deprecated.
DestinationOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.
EmptyFaceColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Empty face color Deprecated.
Height
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.
LinearSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Size of the buffer. Currently returned only for compressed texture surfaces. Deprecated.
Pitch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Distance, in bytes, to the start of next line. Deprecated.
PixelFormatStructure
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of the surface. Deprecated.
RefreshRate
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Refresh rate (used when the display mode is described). The value of 0 indicates an adapter default. Deprecated.
SourceDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for blit operations. Deprecated.
SourceOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.
SurfaceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The capabilities of the surface. Deprecated.
Width
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.

Inheritance Hierarchy

Object Leave Site
SurfaceDescription

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceDescription.Clear()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reset the object back to defaults. Deprecated.

Definition

Visual Basic .NET | Public Sub Clear()
C# | public void Clear();
Managed C++ | public: void Clear();
JScript .NET | public function Clear();


SurfaceDescription.SurfaceDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.SurfaceDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceDescription();
public SurfaceDescription(SurfaceCaps);


SurfaceDescription.SurfaceDescription(SurfaceCaps)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.SurfaceDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal caps As SurfaceCaps _
)
C# public SurfaceDescription(
SurfaceCaps caps
);
Managed C++ public: SurfaceDescription(
SurfaceCaps *caps
);
JScript .NET public function SurfaceDescription(
caps : SurfaceCaps
);

Parameters

caps Microsoft.DirectX.DirectDraw.SurfaceCaps.


SurfaceDescription.SurfaceDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.SurfaceDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SurfaceDescription();
Managed C++ | public: SurfaceDescription();
JScript .NET | public function SurfaceDescription();


SurfaceDescription.AlphaBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.AlphaBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The AlphaBitDepth member is valid. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaBitDepth As Integer
C# | public int AlphaBitDepth { get; set; }
Managed C++ public: __property int get_AlphaBitDepth();
public: __property void set_AlphaBitDepth(int);
JScript .NET public function get AlphaBitDepth() : int
public function set AlphaBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


SurfaceDescription.BackBufferCount

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.BackBufferCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The BackBufferCount member is valid. Deprecated.

Definition

Visual Basic .NET | Public Property BackBufferCount As Integer
C# | public int BackBufferCount { get; set; }
Managed C++ public: __property int get_BackBufferCount();
public: __property void set_BackBufferCount(int);
JScript .NET public function get BackBufferCount() : int
public function set BackBufferCount(int);

Property Value

System.Int32 .

This property is read/write.


SurfaceDescription.DestinationDraw

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.DestinationDraw Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the destination color key for blit operations. Deprecated.

Definition

Visual Basic .NET | Public Property DestinationDraw As ColorKey
C# | public ColorKey DestinationDraw { get; set; }
Managed C++ public: __property ColorKey get_DestinationDraw();
public: __property void set_DestinationDraw(ColorKey);
JScript .NET public function get DestinationDraw() : ColorKey
public function set DestinationDraw(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


SurfaceDescription.DestinationOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.DestinationOverlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.

Definition

Visual Basic .NET | Public Property DestinationOverlay As ColorKey
C# | public ColorKey DestinationOverlay { get; set; }
Managed C++ public: __property ColorKey get_DestinationOverlay();
public: __property void set_DestinationOverlay(ColorKey);
JScript .NET public function get DestinationOverlay() : ColorKey
public function set DestinationOverlay(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


SurfaceDescription.EmptyFaceColor

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.EmptyFaceColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Empty face color Deprecated.

Definition

Visual Basic .NET | Public Property EmptyFaceColor As Integer
C# | public int EmptyFaceColor { get; set; }
Managed C++ public: __property int get_EmptyFaceColor();
public: __property void set_EmptyFaceColor(int);
JScript .NET public function get EmptyFaceColor() : int
public function set EmptyFaceColor(int);

Property Value

System.Int32 .

This property is read/write.


SurfaceDescription.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 .

This property is read/write.


SurfaceDescription.LinearSize

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.LinearSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Size of the buffer. Currently returned only for compressed texture surfaces. Deprecated.

Definition

Visual Basic .NET | Public Property LinearSize As Integer
C# | public int LinearSize { get; set; }
Managed C++ public: __property int get_LinearSize();
public: __property void set_LinearSize(int);
JScript .NET public function get LinearSize() : int
public function set LinearSize(int);

Property Value

System.Int32 .

This property is read/write.


SurfaceDescription.Pitch

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Pitch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Distance, in bytes, to the start of next line. Deprecated.

Definition

Visual Basic .NET | Public Property Pitch As Integer
C# | public int Pitch { get; set; }
Managed C++ public: __property int get_Pitch();
public: __property void set_Pitch(int);
JScript .NET public function get Pitch() : int
public function set Pitch(int);

Property Value

System.Int32 .

This property is read/write.


SurfaceDescription.PixelFormatStructure

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.PixelFormatStructure Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of the surface. Deprecated.

Definition

Visual Basic .NET | Public Property PixelFormatStructure As PixelFormat
C# | public PixelFormat PixelFormatStructure { get; set; }
Managed C++ public: __property PixelFormat get_PixelFormatStructure();
public: __property void set_PixelFormatStructure(PixelFormat);
JScript .NET public function get PixelFormatStructure() : PixelFormat
public function set PixelFormatStructure(PixelFormat);

Property Value

Microsoft.DirectX.DirectDraw.PixelFormat .

This property is read/write.


SurfaceDescription.RefreshRate

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.RefreshRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Refresh rate (used when the display mode is described). The value of 0 indicates an adapter default. Deprecated.

Definition

Visual Basic .NET | Public Property RefreshRate As Integer
C# | public int RefreshRate { get; set; }
Managed C++ public: __property int get_RefreshRate();
public: __property void set_RefreshRate(int);
JScript .NET public function get RefreshRate() : int
public function set RefreshRate(int);

Property Value

System.Int32 .

This property is read/write.


SurfaceDescription.SourceDraw

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.SourceDraw Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for blit operations. Deprecated.

Definition

Visual Basic .NET | Public Property SourceDraw As ColorKey
C# | public ColorKey SourceDraw { get; set; }
Managed C++ public: __property ColorKey get_SourceDraw();
public: __property void set_SourceDraw(ColorKey);
JScript .NET public function get SourceDraw() : ColorKey
public function set SourceDraw(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


SurfaceDescription.SourceOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.SourceOverlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.

Definition

Visual Basic .NET | Public Property SourceOverlay As ColorKey
C# | public ColorKey SourceOverlay { get; set; }
Managed C++ public: __property ColorKey get_SourceOverlay();
public: __property void set_SourceOverlay(ColorKey);
JScript .NET public function get SourceOverlay() : ColorKey
public function set SourceOverlay(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


SurfaceDescription.SurfaceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.SurfaceCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The capabilities of the surface. Deprecated.

Definition

Visual Basic .NET | Public Property SurfaceCaps As SurfaceCaps
C# | public SurfaceCaps SurfaceCaps { get; set; }
Managed C++ public: __property SurfaceCaps* get_SurfaceCaps();
public: __property void set_SurfaceCaps(SurfaceCaps*);
JScript .NET public function get SurfaceCaps() : SurfaceCaps
public function set SurfaceCaps(SurfaceCaps);

Property Value

Microsoft.DirectX.DirectDraw.SurfaceCaps .

This property is read/write.


SurfaceDescription.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceDescription.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 .

This property is read/write.


Microsoft.DirectX.DirectDraw.SurfaceIsObscuredException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceIsObscuredException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is obscured. Deprecated.

Definition

Visual Basic .NET Public Class SurfaceIsObscuredException
Inherits GraphicsException
C# | public class SurfaceIsObscuredException : GraphicsException
Managed C++ | public __gc class SurfaceIsObscuredException : public GraphicsException
JScript .NET | public class SurfaceIsObscuredException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceIsObscuredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceIsObscuredException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceIsObscuredException.SurfaceIsObscuredException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceIsObscuredException();
protected SurfaceIsObscuredException(SerializationInfo, StreamingContext);
public SurfaceIsObscuredException(string);
public SurfaceIsObscuredException(string, Exception);


SurfaceIsObscuredException.SurfaceIsObscuredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceIsObscuredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SurfaceIsObscuredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SurfaceIsObscuredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SurfaceIsObscuredException.SurfaceIsObscuredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceIsObscuredException(
string message,
Exception inner
);
Managed C++ public: SurfaceIsObscuredException(
String *message,
Exception *inner
);
JScript .NET public function SurfaceIsObscuredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SurfaceIsObscuredException.SurfaceIsObscuredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SurfaceIsObscuredException(
string message
);
Managed C++ public: SurfaceIsObscuredException(
String *message
);
JScript .NET public function SurfaceIsObscuredException(
message : String
);

Parameters

message System.String.


SurfaceIsObscuredException.SurfaceIsObscuredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SurfaceIsObscuredException();
Managed C++ | public: SurfaceIsObscuredException();
JScript .NET | public function SurfaceIsObscuredException();


Microsoft.DirectX.DirectDraw.SurfaceLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface memory is gone. Call the Surface.Restore method on this surface to restore the memory associated Deprecated.

Definition

Visual Basic .NET Public Class SurfaceLostException
Inherits GraphicsException
C# | public class SurfaceLostException : GraphicsException
Managed C++ | public __gc class SurfaceLostException : public GraphicsException
JScript .NET | public class SurfaceLostException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceLostException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceLostException.SurfaceLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLostException.SurfaceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceLostException();
protected SurfaceLostException(SerializationInfo, StreamingContext);
public SurfaceLostException(string);
public SurfaceLostException(string, Exception);


SurfaceLostException.SurfaceLostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLostException.SurfaceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceLostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SurfaceLostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SurfaceLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SurfaceLostException.SurfaceLostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLostException.SurfaceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceLostException(
string message,
Exception inner
);
Managed C++ public: SurfaceLostException(
String *message,
Exception *inner
);
JScript .NET public function SurfaceLostException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SurfaceLostException.SurfaceLostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLostException.SurfaceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SurfaceLostException(
string message
);
Managed C++ public: SurfaceLostException(
String *message
);
JScript .NET public function SurfaceLostException(
message : String
);

Parameters

message System.String.


SurfaceLostException.SurfaceLostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceLostException.SurfaceLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SurfaceLostException();
Managed C++ | public: SurfaceLostException();
JScript .NET | public function SurfaceLostException();


Microsoft.DirectX.DirectDraw.SurfaceNotAttachedException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceNotAttachedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested surface is not attached. Deprecated.

Definition

Visual Basic .NET Public Class SurfaceNotAttachedException
Inherits GraphicsException
C# | public class SurfaceNotAttachedException : GraphicsException
Managed C++ | public __gc class SurfaceNotAttachedException : public GraphicsException
JScript .NET | public class SurfaceNotAttachedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceNotAttachedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceNotAttachedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfaceNotAttachedException.SurfaceNotAttachedException

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceNotAttachedException();
protected SurfaceNotAttachedException(SerializationInfo, StreamingContext);
public SurfaceNotAttachedException(string);
public SurfaceNotAttachedException(string, Exception);


SurfaceNotAttachedException.SurfaceNotAttachedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceNotAttachedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SurfaceNotAttachedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SurfaceNotAttachedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SurfaceNotAttachedException.SurfaceNotAttachedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceNotAttachedException(
string message,
Exception inner
);
Managed C++ public: SurfaceNotAttachedException(
String *message,
Exception *inner
);
JScript .NET public function SurfaceNotAttachedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SurfaceNotAttachedException.SurfaceNotAttachedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SurfaceNotAttachedException(
string message
);
Managed C++ public: SurfaceNotAttachedException(
String *message
);
JScript .NET public function SurfaceNotAttachedException(
message : String
);

Parameters

message System.String.


SurfaceNotAttachedException.SurfaceNotAttachedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SurfaceNotAttachedException();
Managed C++ | public: SurfaceNotAttachedException();
JScript .NET | public function SurfaceNotAttachedException();


Microsoft.DirectX.DirectDraw.SurfacesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of surfaces. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SurfacesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class SurfacesCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class SurfacesCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class SurfacesCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.
SurfacesCollection
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Inheritance Hierarchy

Object Leave Site
SurfacesCollection

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SurfacesCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


SurfacesCollection.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean .


SurfacesCollection.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();


SurfacesCollection.SurfacesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.SurfacesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfacesCollection(Device);
public SurfacesCollection(GetSurfacesFlags, SurfaceDescription, Device);
public SurfacesCollection(OverlayZOrdersFlags, Surface, Device);
public SurfacesCollection(Surface, Device);
public SurfacesCollection(SurfaceDescription, Device);


SurfacesCollection.SurfacesCollection(OverlayZOrdersFlags,Surface,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.SurfacesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As OverlayZOrdersFlags, _
ByVal surf As Surface, _
ByVal dev As Device _
)
C# public SurfacesCollection(
OverlayZOrdersFlags flags,
Surface surf,
Device dev
);
Managed C++ public: SurfacesCollection(
OverlayZOrdersFlags flags,
Surface *surf,
Device *dev
);
JScript .NET public function SurfacesCollection(
flags : OverlayZOrdersFlags,
surf : Surface,
dev : Device
);

Parameters

flags | Microsoft.DirectX.DirectDraw.OverlayZOrdersFlags.
surf | Microsoft.DirectX.DirectDraw.Surface.
dev | Microsoft.DirectX.DirectDraw.Device.


SurfacesCollection.SurfacesCollection(Surface,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.SurfacesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal surf As Surface, _
ByVal dev As Device _
)
C# public SurfacesCollection(
Surface surf,
Device dev
);
Managed C++ public: SurfacesCollection(
Surface *surf,
Device *dev
);
JScript .NET public function SurfacesCollection(
surf : Surface,
dev : Device
);

Parameters

surf | Microsoft.DirectX.DirectDraw.Surface.
dev | Microsoft.DirectX.DirectDraw.Device.


SurfacesCollection.SurfacesCollection(GetSurfacesFlags,SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.SurfacesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As GetSurfacesFlags, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public SurfacesCollection(
GetSurfacesFlags flags,
SurfaceDescription desc,
Device dev
);
Managed C++ public: SurfacesCollection(
GetSurfacesFlags flags,
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function SurfacesCollection(
flags : GetSurfacesFlags,
desc : SurfaceDescription,
dev : Device
);

Parameters

flags | Microsoft.DirectX.DirectDraw.GetSurfacesFlags.
desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


SurfacesCollection.SurfacesCollection(SurfaceDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.SurfacesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public SurfacesCollection(
SurfaceDescription desc,
Device dev
);
Managed C++ public: SurfacesCollection(
SurfaceDescription *desc,
Device *dev
);
JScript .NET public function SurfacesCollection(
desc : SurfaceDescription,
dev : Device
);

Parameters

desc | Microsoft.DirectX.DirectDraw.SurfaceDescription.
dev | Microsoft.DirectX.DirectDraw.Device.


SurfacesCollection.SurfacesCollection(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.SurfacesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dev As Device _
)
C# public SurfacesCollection(
Device dev
);
Managed C++ public: SurfacesCollection(
Device *dev
);
JScript .NET public function SurfacesCollection(
dev : Device
);

Parameters

dev Microsoft.DirectX.DirectDraw.Device.


SurfacesCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


SurfacesCollection.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

SurfacesCollection.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object .

This property is read-only.


Microsoft.DirectX.DirectDraw.TestFinishedException

Microsoft DirectX 9.0 SDK Update (October 2004)

TestFinishedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When thrown by StartModeTest method, this value means that no test could be initiated because all the resolutions chosen for testing already have refresh rate information in the registry. Deprecated.

Definition

Visual Basic .NET Public Class TestFinishedException
Inherits GraphicsException
C# | public class TestFinishedException : GraphicsException
Managed C++ | public __gc class TestFinishedException : public GraphicsException
JScript .NET | public class TestFinishedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TestFinishedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TestFinishedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TestFinishedException.TestFinishedException

Microsoft DirectX 9.0 SDK Update (October 2004)

TestFinishedException.TestFinishedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TestFinishedException();
protected TestFinishedException(SerializationInfo, StreamingContext);
public TestFinishedException(string);
public TestFinishedException(string, Exception);


TestFinishedException.TestFinishedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TestFinishedException.TestFinishedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TestFinishedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TestFinishedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TestFinishedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TestFinishedException.TestFinishedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TestFinishedException.TestFinishedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TestFinishedException(
string message,
Exception inner
);
Managed C++ public: TestFinishedException(
String *message,
Exception *inner
);
JScript .NET public function TestFinishedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TestFinishedException.TestFinishedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TestFinishedException.TestFinishedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TestFinishedException(
string message
);
Managed C++ public: TestFinishedException(
String *message
);
JScript .NET public function TestFinishedException(
message : String
);

Parameters

message System.String.


TestFinishedException.TestFinishedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TestFinishedException.TestFinishedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TestFinishedException();
Managed C++ | public: TestFinishedException();
JScript .NET | public function TestFinishedException();


Microsoft.DirectX.DirectDraw.TooBigHeightException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigHeightException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height requested by DirectDraw is too large. Deprecated.

Definition

Visual Basic .NET Public Class TooBigHeightException
Inherits GraphicsException
C# | public class TooBigHeightException : GraphicsException
Managed C++ | public __gc class TooBigHeightException : public GraphicsException
JScript .NET | public class TooBigHeightException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooBigHeightException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooBigHeightException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TooBigHeightException.TooBigHeightException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigHeightException.TooBigHeightException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TooBigHeightException();
protected TooBigHeightException(SerializationInfo, StreamingContext);
public TooBigHeightException(string);
public TooBigHeightException(string, Exception);


TooBigHeightException.TooBigHeightException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigHeightException.TooBigHeightException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooBigHeightException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TooBigHeightException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TooBigHeightException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TooBigHeightException.TooBigHeightException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigHeightException.TooBigHeightException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooBigHeightException(
string message,
Exception inner
);
Managed C++ public: TooBigHeightException(
String *message,
Exception *inner
);
JScript .NET public function TooBigHeightException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TooBigHeightException.TooBigHeightException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigHeightException.TooBigHeightException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TooBigHeightException(
string message
);
Managed C++ public: TooBigHeightException(
String *message
);
JScript .NET public function TooBigHeightException(
message : String
);

Parameters

message System.String.


TooBigHeightException.TooBigHeightException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigHeightException.TooBigHeightException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TooBigHeightException();
Managed C++ | public: TooBigHeightException();
JScript .NET | public function TooBigHeightException();


Microsoft.DirectX.DirectDraw.TooBigSizeException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigSizeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size requested by DirectDraw is too large. However, the individual height and width are valid sizes. Deprecated.

Definition

Visual Basic .NET Public Class TooBigSizeException
Inherits GraphicsException
C# | public class TooBigSizeException : GraphicsException
Managed C++ | public __gc class TooBigSizeException : public GraphicsException
JScript .NET | public class TooBigSizeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooBigSizeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooBigSizeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TooBigSizeException.TooBigSizeException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigSizeException.TooBigSizeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TooBigSizeException();
protected TooBigSizeException(SerializationInfo, StreamingContext);
public TooBigSizeException(string);
public TooBigSizeException(string, Exception);


TooBigSizeException.TooBigSizeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigSizeException.TooBigSizeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooBigSizeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TooBigSizeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TooBigSizeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TooBigSizeException.TooBigSizeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigSizeException.TooBigSizeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooBigSizeException(
string message,
Exception inner
);
Managed C++ public: TooBigSizeException(
String *message,
Exception *inner
);
JScript .NET public function TooBigSizeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TooBigSizeException.TooBigSizeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigSizeException.TooBigSizeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TooBigSizeException(
string message
);
Managed C++ public: TooBigSizeException(
String *message
);
JScript .NET public function TooBigSizeException(
message : String
);

Parameters

message System.String.


TooBigSizeException.TooBigSizeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigSizeException.TooBigSizeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TooBigSizeException();
Managed C++ | public: TooBigSizeException();
JScript .NET | public function TooBigSizeException();


Microsoft.DirectX.DirectDraw.TooBigWidthException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigWidthException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The width requested by DirectDraw is too large. Deprecated.

Definition

Visual Basic .NET Public Class TooBigWidthException
Inherits GraphicsException
C# | public class TooBigWidthException : GraphicsException
Managed C++ | public __gc class TooBigWidthException : public GraphicsException
JScript .NET | public class TooBigWidthException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooBigWidthException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooBigWidthException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TooBigWidthException.TooBigWidthException

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigWidthException.TooBigWidthException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TooBigWidthException();
protected TooBigWidthException(SerializationInfo, StreamingContext);
public TooBigWidthException(string);
public TooBigWidthException(string, Exception);


TooBigWidthException.TooBigWidthException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigWidthException.TooBigWidthException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooBigWidthException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TooBigWidthException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TooBigWidthException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TooBigWidthException.TooBigWidthException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigWidthException.TooBigWidthException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooBigWidthException(
string message,
Exception inner
);
Managed C++ public: TooBigWidthException(
String *message,
Exception *inner
);
JScript .NET public function TooBigWidthException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TooBigWidthException.TooBigWidthException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigWidthException.TooBigWidthException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TooBigWidthException(
string message
);
Managed C++ public: TooBigWidthException(
String *message
);
JScript .NET public function TooBigWidthException(
message : String
);

Parameters

message System.String.


TooBigWidthException.TooBigWidthException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TooBigWidthException.TooBigWidthException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TooBigWidthException();
Managed C++ | public: TooBigWidthException();
JScript .NET | public function TooBigWidthException();


Microsoft.DirectX.DirectDraw.UnsupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.

Definition

Visual Basic .NET Public Class UnsupportedException
Inherits GraphicsException
C# | public class UnsupportedException : GraphicsException
Managed C++ | public __gc class UnsupportedException : public GraphicsException
JScript .NET | public class UnsupportedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedException.UnsupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedException();
protected UnsupportedException(SerializationInfo, StreamingContext);
public UnsupportedException(string);
public UnsupportedException(string, Exception);


UnsupportedException.UnsupportedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UnsupportedException.UnsupportedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedException(
string message,
Exception inner
);
Managed C++ public: UnsupportedException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UnsupportedException.UnsupportedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedException(
string message
);
Managed C++ public: UnsupportedException(
String *message
);
JScript .NET public function UnsupportedException(
message : String
);

Parameters

message System.String.


UnsupportedException.UnsupportedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedException();
Managed C++ | public: UnsupportedException();
JScript .NET | public function UnsupportedException();


Microsoft.DirectX.DirectDraw.UnsupportedFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFormatException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format requested is not supported by DirectDraw. Deprecated.

Definition

Visual Basic .NET Public Class UnsupportedFormatException
Inherits GraphicsException
C# | public class UnsupportedFormatException : GraphicsException
Managed C++ | public __gc class UnsupportedFormatException : public GraphicsException
JScript .NET | public class UnsupportedFormatException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedFormatException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedFormatException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedFormatException.UnsupportedFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedFormatException();
protected UnsupportedFormatException(SerializationInfo, StreamingContext);
public UnsupportedFormatException(string);
public UnsupportedFormatException(string, Exception);


UnsupportedFormatException.UnsupportedFormatException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedFormatException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedFormatException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UnsupportedFormatException.UnsupportedFormatException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedFormatException(
string message,
Exception inner
);
Managed C++ public: UnsupportedFormatException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedFormatException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UnsupportedFormatException.UnsupportedFormatException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedFormatException(
string message
);
Managed C++ public: UnsupportedFormatException(
String *message
);
JScript .NET public function UnsupportedFormatException(
message : String
);

Parameters

message System.String.


UnsupportedFormatException.UnsupportedFormatException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedFormatException();
Managed C++ | public: UnsupportedFormatException();
JScript .NET | public function UnsupportedFormatException();


Microsoft.DirectX.DirectDraw.UnsupportedMaskException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedMaskException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The bitmask in the pixel format requested is not supported by DirectDraw. Deprecated.

Definition

Visual Basic .NET Public Class UnsupportedMaskException
Inherits GraphicsException
C# | public class UnsupportedMaskException : GraphicsException
Managed C++ | public __gc class UnsupportedMaskException : public GraphicsException
JScript .NET | public class UnsupportedMaskException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedMaskException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedMaskException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedMaskException.UnsupportedMaskException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedMaskException();
protected UnsupportedMaskException(SerializationInfo, StreamingContext);
public UnsupportedMaskException(string);
public UnsupportedMaskException(string, Exception);


UnsupportedMaskException.UnsupportedMaskException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedMaskException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedMaskException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedMaskException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UnsupportedMaskException.UnsupportedMaskException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedMaskException(
string message,
Exception inner
);
Managed C++ public: UnsupportedMaskException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedMaskException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UnsupportedMaskException.UnsupportedMaskException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedMaskException(
string message
);
Managed C++ public: UnsupportedMaskException(
String *message
);
JScript .NET public function UnsupportedMaskException(
message : String
);

Parameters

message System.String.


UnsupportedMaskException.UnsupportedMaskException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedMaskException();
Managed C++ | public: UnsupportedMaskException();
JScript .NET | public function UnsupportedMaskException();


Microsoft.DirectX.DirectDraw.UnsupportedModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedModeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display is currently in an unsupported mode. Deprecated.

Definition

Visual Basic .NET Public Class UnsupportedModeException
Inherits GraphicsException
C# | public class UnsupportedModeException : GraphicsException
Managed C++ | public __gc class UnsupportedModeException : public GraphicsException
JScript .NET | public class UnsupportedModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedModeException.UnsupportedModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedModeException();
protected UnsupportedModeException(SerializationInfo, StreamingContext);
public UnsupportedModeException(string);
public UnsupportedModeException(string, Exception);


UnsupportedModeException.UnsupportedModeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedModeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedModeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UnsupportedModeException.UnsupportedModeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedModeException(
string message,
Exception inner
);
Managed C++ public: UnsupportedModeException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedModeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UnsupportedModeException.UnsupportedModeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedModeException(
string message
);
Managed C++ public: UnsupportedModeException(
String *message
);
JScript .NET public function UnsupportedModeException(
message : String
);

Parameters

message System.String.


UnsupportedModeException.UnsupportedModeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedModeException();
Managed C++ | public: UnsupportedModeException();
JScript .NET | public function UnsupportedModeException();


Microsoft.DirectX.DirectDraw.VerticalBlankInProgressException

Microsoft DirectX 9.0 SDK Update (October 2004)

VerticalBlankInProgressException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A vertical blank is in progress. Deprecated.

Definition

Visual Basic .NET Public Class VerticalBlankInProgressException
Inherits GraphicsException
C# | public class VerticalBlankInProgressException : GraphicsException
Managed C++ | public __gc class VerticalBlankInProgressException : public GraphicsException
JScript .NET | public class VerticalBlankInProgressException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
VerticalBlankInProgressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
VerticalBlankInProgressException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VerticalBlankInProgressException.VerticalBlankInProgressException

Microsoft DirectX 9.0 SDK Update (October 2004)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public VerticalBlankInProgressException();
protected VerticalBlankInProgressException(SerializationInfo, StreamingContext);
public VerticalBlankInProgressException(string);
public VerticalBlankInProgressException(string, Exception);


VerticalBlankInProgressException.VerticalBlankInProgressException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected VerticalBlankInProgressException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: VerticalBlankInProgressException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function VerticalBlankInProgressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


VerticalBlankInProgressException.VerticalBlankInProgressException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public VerticalBlankInProgressException(
string message,
Exception inner
);
Managed C++ public: VerticalBlankInProgressException(
String *message,
Exception *inner
);
JScript .NET public function VerticalBlankInProgressException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


VerticalBlankInProgressException.VerticalBlankInProgressException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public VerticalBlankInProgressException(
string message
);
Managed C++ public: VerticalBlankInProgressException(
String *message
);
JScript .NET public function VerticalBlankInProgressException(
message : String
);

Parameters

message System.String.


VerticalBlankInProgressException.VerticalBlankInProgressException()

Microsoft DirectX 9.0 SDK Update (October 2004)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public VerticalBlankInProgressException();
Managed C++ | public: VerticalBlankInProgressException();
JScript .NET | public function VerticalBlankInProgressException();


Microsoft.DirectX.DirectDraw.VideoNotActiveException

Microsoft DirectX 9.0 SDK Update (October 2004)

VideoNotActiveException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The video port is not active. Deprecated.

Definition

Visual Basic .NET Public Class VideoNotActiveException
Inherits GraphicsException
C# | public class VideoNotActiveException : GraphicsException
Managed C++ | public __gc class VideoNotActiveException : public GraphicsException
JScript .NET | public class VideoNotActiveException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
VideoNotActiveException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
VideoNotActiveException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VideoNotActiveException.VideoNotActiveException

Microsoft DirectX 9.0 SDK Update (October 2004)

VideoNotActiveException.VideoNotActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public VideoNotActiveException();
protected VideoNotActiveException(SerializationInfo, StreamingContext);
public VideoNotActiveException(string);
public VideoNotActiveException(string, Exception);


VideoNotActiveException.VideoNotActiveException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

VideoNotActiveException.VideoNotActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected VideoNotActiveException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: VideoNotActiveException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function VideoNotActiveException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


VideoNotActiveException.VideoNotActiveException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

VideoNotActiveException.VideoNotActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public VideoNotActiveException(
string message,
Exception inner
);
Managed C++ public: VideoNotActiveException(
String *message,
Exception *inner
);
JScript .NET public function VideoNotActiveException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


VideoNotActiveException.VideoNotActiveException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

VideoNotActiveException.VideoNotActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public VideoNotActiveException(
string message
);
Managed C++ public: VideoNotActiveException(
String *message
);
JScript .NET public function VideoNotActiveException(
message : String
);

Parameters

message System.String.


VideoNotActiveException.VideoNotActiveException()

Microsoft DirectX 9.0 SDK Update (October 2004)

VideoNotActiveException.VideoNotActiveException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public VideoNotActiveException();
Managed C++ | public: VideoNotActiveException();
JScript .NET | public function VideoNotActiveException();


Microsoft.DirectX.DirectDraw.WasStillDrawingException

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The previous blit operation that is transferring information to or from this surface is incomplete. Deprecated.

Definition

Visual Basic .NET Public Class WasStillDrawingException
Inherits GraphicsException
C# | public class WasStillDrawingException : GraphicsException
Managed C++ | public __gc class WasStillDrawingException : public GraphicsException
JScript .NET | public class WasStillDrawingException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WasStillDrawingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WasStillDrawingException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WasStillDrawingException.WasStillDrawingException

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WasStillDrawingException();
protected WasStillDrawingException(SerializationInfo, StreamingContext);
public WasStillDrawingException(string);
public WasStillDrawingException(string, Exception);


WasStillDrawingException.WasStillDrawingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WasStillDrawingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: WasStillDrawingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function WasStillDrawingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


WasStillDrawingException.WasStillDrawingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WasStillDrawingException(
string message,
Exception inner
);
Managed C++ public: WasStillDrawingException(
String *message,
Exception *inner
);
JScript .NET public function WasStillDrawingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


WasStillDrawingException.WasStillDrawingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public WasStillDrawingException(
string message
);
Managed C++ public: WasStillDrawingException(
String *message
);
JScript .NET public function WasStillDrawingException(
message : String
);

Parameters

message System.String.


WasStillDrawingException.WasStillDrawingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public WasStillDrawingException();
Managed C++ | public: WasStillDrawingException();
JScript .NET | public function WasStillDrawingException();


Microsoft.DirectX.DirectDraw.WindowAlreadySetException

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowAlreadySetException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDraw cooperative-level window has already been set. It cannot be reset while the process has surfaces or palettes created. Deprecated.

Definition

Visual Basic .NET Public Class WindowAlreadySetException
Inherits GraphicsException
C# | public class WindowAlreadySetException : GraphicsException
Managed C++ | public __gc class WindowAlreadySetException : public GraphicsException
JScript .NET | public class WindowAlreadySetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WindowAlreadySetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WindowAlreadySetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WindowAlreadySetException.WindowAlreadySetException

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WindowAlreadySetException();
protected WindowAlreadySetException(SerializationInfo, StreamingContext);
public WindowAlreadySetException(string);
public WindowAlreadySetException(string, Exception);


WindowAlreadySetException.WindowAlreadySetException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WindowAlreadySetException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: WindowAlreadySetException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function WindowAlreadySetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


WindowAlreadySetException.WindowAlreadySetException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WindowAlreadySetException(
string message,
Exception inner
);
Managed C++ public: WindowAlreadySetException(
String *message,
Exception *inner
);
JScript .NET public function WindowAlreadySetException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


WindowAlreadySetException.WindowAlreadySetException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public WindowAlreadySetException(
string message
);
Managed C++ public: WindowAlreadySetException(
String *message
);
JScript .NET public function WindowAlreadySetException(
message : String
);

Parameters

message System.String.


WindowAlreadySetException.WindowAlreadySetException()

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public WindowAlreadySetException();
Managed C++ | public: WindowAlreadySetException();
JScript .NET | public function WindowAlreadySetException();


Microsoft.DirectX.DirectDraw.WindowSubclassedException

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowSubclassedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is prevented from restoring state because the DirectDraw cooperative-level window handle has been subclassed. Deprecated.

Definition

Visual Basic .NET Public Class WindowSubclassedException
Inherits GraphicsException
C# | public class WindowSubclassedException : GraphicsException
Managed C++ | public __gc class WindowSubclassedException : public GraphicsException
JScript .NET | public class WindowSubclassedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WindowSubclassedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WindowSubclassedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WindowSubclassedException.WindowSubclassedException

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WindowSubclassedException();
protected WindowSubclassedException(SerializationInfo, StreamingContext);
public WindowSubclassedException(string);
public WindowSubclassedException(string, Exception);


WindowSubclassedException.WindowSubclassedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WindowSubclassedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: WindowSubclassedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function WindowSubclassedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


WindowSubclassedException.WindowSubclassedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WindowSubclassedException(
string message,
Exception inner
);
Managed C++ public: WindowSubclassedException(
String *message,
Exception *inner
);
JScript .NET public function WindowSubclassedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


WindowSubclassedException.WindowSubclassedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public WindowSubclassedException(
string message
);
Managed C++ public: WindowSubclassedException(
String *message
);
JScript .NET public function WindowSubclassedException(
message : String
);

Parameters

message System.String.


WindowSubclassedException.WindowSubclassedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public WindowSubclassedException();
Managed C++ | public: WindowSubclassedException();
JScript .NET | public function WindowSubclassedException();


Microsoft.DirectX.DirectDraw.WrongModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongModeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface cannot be restored because it was created in a different mode. Deprecated.

Definition

Visual Basic .NET Public Class WrongModeException
Inherits GraphicsException
C# | public class WrongModeException : GraphicsException
Managed C++ | public __gc class WrongModeException : public GraphicsException
JScript .NET | public class WrongModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WrongModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WrongModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WrongModeException.WrongModeException

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongModeException.WrongModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WrongModeException();
protected WrongModeException(SerializationInfo, StreamingContext);
public WrongModeException(string);
public WrongModeException(string, Exception);


WrongModeException.WrongModeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongModeException.WrongModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WrongModeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: WrongModeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function WrongModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


WrongModeException.WrongModeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongModeException.WrongModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WrongModeException(
string message,
Exception inner
);
Managed C++ public: WrongModeException(
String *message,
Exception *inner
);
JScript .NET public function WrongModeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


WrongModeException.WrongModeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongModeException.WrongModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public WrongModeException(
string message
);
Managed C++ public: WrongModeException(
String *message
);
JScript .NET public function WrongModeException(
message : String
);

Parameters

message System.String.


WrongModeException.WrongModeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

WrongModeException.WrongModeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public WrongModeException();
Managed C++ | public: WrongModeException();
JScript .NET | public function WrongModeException();


Microsoft.DirectX.DirectDraw.XAlignException

Microsoft DirectX 9.0 SDK Update (October 2004)

XAlignException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was not horizontally aligned on a required boundary. Deprecated.

Definition

Visual Basic .NET Public Class XAlignException
Inherits GraphicsException
C# | public class XAlignException : GraphicsException
Managed C++ | public __gc class XAlignException : public GraphicsException
JScript .NET | public class XAlignException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
XAlignException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
XAlignException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


XAlignException.XAlignException

Microsoft DirectX 9.0 SDK Update (October 2004)

XAlignException.XAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public XAlignException();
protected XAlignException(SerializationInfo, StreamingContext);
public XAlignException(string);
public XAlignException(string, Exception);


XAlignException.XAlignException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

XAlignException.XAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected XAlignException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: XAlignException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function XAlignException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


XAlignException.XAlignException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

XAlignException.XAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public XAlignException(
string message,
Exception inner
);
Managed C++ public: XAlignException(
String *message,
Exception *inner
);
JScript .NET public function XAlignException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


XAlignException.XAlignException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

XAlignException.XAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public XAlignException(
string message
);
Managed C++ public: XAlignException(
String *message
);
JScript .NET public function XAlignException(
message : String
);

Parameters

message System.String.


XAlignException.XAlignException()

Microsoft DirectX 9.0 SDK Update (October 2004)

XAlignException.XAlignException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public XAlignException();
Managed C++ | public: XAlignException();
JScript .NET | public function XAlignException();


ColorKeyFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines which color key is requested. Deprecated.

Definition

Visual Basic .NET | Public Enum ColorKeyFlags
C# | public enum ColorKeyFlags
Managed C++ | __value public enum ColorKeyFlags
JScript .NET | public enum ColorKeyFlags

Members

Member | Value | Description
SourceOverlay | 16
SourceDraw | 8
DestinationOverlay | 4
DestinationDraw | 2
ColorSpace | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CooperativeLevelFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

CooperativeLevelFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.

Definition

Visual Basic .NET | Public Enum CooperativeLevelFlags
C# | public enum CooperativeLevelFlags
Managed C++ | __value public enum CooperativeLevelFlags
JScript .NET | public enum CooperativeLevelFlags

Members

Member | Value | Description
FullscreenExclusiveAllowModex | 81
FullscreenExclusive | 17
CreateDeviceWindow | 512
SetDeviceWindow | 256
SetFocusWindow | 128
AllowModeX | 64
Exclusive | 16
Normal | 8
NoWindowChanges | 4
AllowReboot | 2
Fullscreen | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CreateFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creation flags. Deprecated.

Definition

Visual Basic .NET | Public Enum CreateFlags
C# | public enum CreateFlags
Managed C++ | __value public enum CreateFlags
JScript .NET | public enum CreateFlags

Members

Member | Value | Description
Default | 0
EmulationOnly | 2
HardwareOnly | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrawFastFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFastFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of transfer. Deprecated.

Definition

Visual Basic .NET | Public Enum DrawFastFlags
C# | public enum DrawFastFlags
Managed C++ | __value public enum DrawFastFlags
JScript .NET | public enum DrawFastFlags

Members

Member | Value | Description
DoNotWait | 32
Wait | 16
DestinationColorKey | 2
SourceColorKey | 1
NoColorKey | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrawFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of flags that determine the valid members of the associated DrawEffects structure, specify color-key information, or request special behavior from the method. Deprecated.

Definition

Visual Basic .NET | Public Enum DrawFlags
C# | public enum DrawFlags
Managed C++ | __value public enum DrawFlags
JScript .NET | public enum DrawFlags

Members

Member | Value | Description
DoNotWait | 134217728
DepthFill | 33554432
Wait | 16777216
RotationAngle | 262144
RasterOperation | 131072
KeySourceOverride | 65536
KeySource | 32768
KeyDestinationOverride | 16384
KeyDestination | 8192
RasterOperations | 4096
Effects | 2048
ColorFix | 1024
Async | 512
AlphaSourceSurfaceOverride | 256
AlphaSourceNegative | 128
AlphaSourceConstOverride | 64
AlphaSource | 32
AlphaEdgeBlend | 16
AlphaDestinationSurfaceOverride | 8
AlphaDestinationNegative | 4
AlphaDestinationConstOverride | 2
AlphaDestination | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FlipFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

FlipFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags specifying flip options. Deprecated.

Definition

Visual Basic .NET | Public Enum FlipFlags
C# | public enum FlipFlags
Managed C++ | __value public enum FlipFlags
JScript .NET | public enum FlipFlags

Members

Member | Value | Description
DoNotWait | 32
Stereo | 16
Interval4 | 67108864
Interval3 | 50331648
Interval2 | 33554432
NoVSync | 8
Odd | 4
Even | 2
Wait | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FourCc

Microsoft DirectX 9.0 SDK Update (October 2004)

FourCc Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCc codes Deprecated.

Definition

Visual Basic .NET | Public Enum FourCc
C# | public enum FourCc
Managed C++ | __value public enum FourCc
JScript .NET | public enum FourCc

Members

Member | Value | Description
Dxt5 | 894720068
Dxt4 | 877942852
Dxt3 | 861165636
Dxt2 | 844388420
Dxt1 | 827611204

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GetDeviceFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

GetDeviceFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDeviceFlags Deprecated.

Definition

Visual Basic .NET | Public Enum GetDeviceFlags
C# | public enum GetDeviceFlags
Managed C++ | __value public enum GetDeviceFlags
JScript .NET | public enum GetDeviceFlags

Members

Member | Value | Description
Default | 0
GetHostIdentifier | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GetDevicesFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

GetDevicesFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDevicesFlags Deprecated.

Definition

Visual Basic .NET | Public Enum GetDevicesFlags
C# | public enum GetDevicesFlags
Managed C++ | __value public enum GetDevicesFlags
JScript .NET | public enum GetDevicesFlags

Members

Member | Value | Description
All | 7
NonDisplayDevices | 4
DetachedSecondaryDevice | 2
AttachedSecondaryDevice | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GetDisplayModeFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

GetDisplayModeFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Getting displaymode flags, can be used to enumerate Standard VGA Modes, or RefreshRates. Deprecated.

Definition

Visual Basic .NET | Public Enum GetDisplayModeFlags
C# | public enum GetDisplayModeFlags
Managed C++ | __value public enum GetDisplayModeFlags
JScript .NET | public enum GetDisplayModeFlags

Members

Member | Value | Description
StandardVgaModes | 2
RefreshRates | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GetSurfacesFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

GetSurfacesFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The search type flag determines how the method searches for matching surfaces; The matching flag determines whether the method enumerates all surfaces, only those that match, or only those that do not match the description. Deprecated.

Definition

Visual Basic .NET | Public Enum GetSurfacesFlags
C# | public enum GetSurfacesFlags
Managed C++ | __value public enum GetSurfacesFlags
JScript .NET | public enum GetSurfacesFlags

Members

Member | Value | Description
AllMatched | 3
DoesExist | 16
CanBeCreated | 8
NoMatch | 4
All | 1
Match | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LockFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

LockFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags describing locking. Deprecated.

Definition

Visual Basic .NET | Public Enum LockFlags
C# | public enum LockFlags
Managed C++ | __value public enum LockFlags
JScript .NET | public enum LockFlags

Members

Member | Value | Description
DoNotWait | 16384
NoSystemLock | 2048
WriteOnly | 32
ReadOnly | 16
Wait | 1
SurfaceMemoryPointer | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayEffectsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffectsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for overlay effects. Deprecated.

Definition

Visual Basic .NET | Public Enum OverlayEffectsFlags
C# | public enum OverlayEffectsFlags
Managed C++ | __value public enum OverlayEffectsFlags
JScript .NET | public enum OverlayEffectsFlags

Members

Member | Value | Description
Deinterlace | 8
MirrorUpDown | 4
MirrorLeftRight | 2
ArithmeticStretchY | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.

Definition

Visual Basic .NET | Public Enum OverlayFlags
C# | public enum OverlayFlags
Managed C++ | __value public enum OverlayFlags
JScript .NET | public enum OverlayFlags

Members

Member | Value | Description
DegradeArgbScaling | 67108864
ArgbScaleFactors | 33554432
BobHardware | 16777216
Interleaved | 8388608
OverrideBobWeave | 4194304
Bob | 2097152
AutoFlip | 1048576
Effects | 524288
RefreshAll | 131072
RefreshDirtyRectangles | 65536
AddDirtyRectangle | 32768
Show | 16384
KeySourceOverride | 8192
KeySource | 4096
KeyDestinationOverride | 2048
KeyDestination | 1024
Hide | 512
AlphaSurfaceOverride | 256
AlphaSourceNegative | 128
AlphaSourceConstOverride | 64
AlphaSource | 32
AlphaEdgeBlend | 16
AlphaDestinationSurfaceOverride | 8
AlphaDestinationNegative | 4
AlphaDestinationOverride | 2
AlphaDestination | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayZFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayZFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.

Definition

Visual Basic .NET | Public Enum OverlayZFlags
C# | public enum OverlayZFlags
Managed C++ | __value public enum OverlayZFlags
JScript .NET | public enum OverlayZFlags

Members

Member | Value | Description
InsertInBackOf | 5
InsertInFrontOf | 4
MoveBackward | 3
MoveForward | 2
SendToBack | 1
SendToFront | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayZOrdersFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayZOrdersFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.

Definition

Visual Basic .NET | Public Enum OverlayZOrdersFlags
C# | public enum OverlayZOrdersFlags
Managed C++ | __value public enum OverlayZOrdersFlags
JScript .NET | public enum OverlayZOrdersFlags

Members

Member | Value | Description
FrontToBack | 1
BackToFront | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StartModeTestFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

StartModeTestFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for the StartModeTest call. Deprecated.

Definition

Visual Basic .NET | Public Enum StartModeTestFlags
C# | public enum StartModeTestFlags
Managed C++ | __value public enum StartModeTestFlags
JScript .NET | public enum StartModeTestFlags

Members

Member | Value | Description
IsTestRequired | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StereoViewCapsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

StereoViewCapsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for Stereo View caps... Deprecated.

Definition

Visual Basic .NET | Public Enum StereoViewCapsFlags
C# | public enum StereoViewCapsFlags
Managed C++ | __value public enum StereoViewCapsFlags
JScript .NET | public enum StereoViewCapsFlags

Members

Member | Value | Description
StereoSequential | 16

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


WaitVbFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

WaitVbFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines how long to wait for the vertical blank. Deprecated.

Definition

Visual Basic .NET | Public Enum WaitVbFlags
C# | public enum WaitVbFlags
Managed C++ | __value public enum WaitVbFlags
JScript .NET | public enum WaitVbFlags

Members

Member | Value | Description
BlockEnd | 4
BlockBeginEvent | 2
BlockBegin | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the capabilities of the hardware exposed through the DirectDraw object. Deprecated.

Definition

Visual Basic .NET | Public Structure Caps
C# | public struct Caps
Managed C++ | public __value struct Caps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Caps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AlignBoundaryDestination
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle alignment for an overlay surface, in pixels. Deprecated.
AlignBoundaryDestinationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles with the x-axis aligned to the AlignBoundaryDest boundaries of the surface. Deprecated.
AlignBoundarySource
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle alignment for an overlay surface, in pixels. Deprecated.
AlignBoundarySourceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles with the x-axis aligned to the AlignBoundarySource boundaries of the surface. Deprecated.
AlignSizeDestination
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle size alignment for an overlay surface, in pixels. Overlay destination rectangles must have a pixel width that is a multiple of this value. Deprecated.
AlignSizeDestinationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles whose x-axis sizes, in pixels, are AlignSizeDest multiples. Deprecated.
AlignSizeSource
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle size alignment for an overlay surface, in pixels. Overlay source rectangles must have a pixel width that is a multiple of this value. Deprecated.
AlignSizeSourceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles whose x-axis sizes, in pixels, are AlignSizeSource multiples. Deprecated.
AlignStride
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.
AlignStrideAlign
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware supports alpha-only surfaces. Deprecated.
AlphaDrawConstBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 2, 4, or 8 bits per pixel. Deprecated.
AlphaDrawPixelBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AlphaDrawSurfaceBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel.) Deprecated.
AlphaOverlayConstBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AlphaOverlayPixelBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AlphaOverlaySurfaceBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AutoFlipOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay can be automatically flipped to the next surface in the flipping chain each time that a video port VSYNC occurs, allowing the video port and the overlay to double-buffer the video without CPU overhead. This option is only valid when the surface is receiving data from a video port. If the video port data is noninterlaced or noninterleaved, it flips on every VSYNC. If the data is being interleaved in memory, it flips on every other VSYNC. Deprecated.
BankSwitched
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware is bank-switched and is potentially very slow at random access to display memory. Deprecated.
CanClip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping with blitting. Deprecated.
CanClipStretched
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping while stretch blitting. Deprecated.
CanDrawSystemMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blitting to or from system memory. Deprecated.
CanFlipOddEven
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver is capable of performing odd and even flip operations. Deprecated.
CertifiedHardware
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is certified. Deprecated.
ColorControlOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay surface contains color controls (such as brightness and sharpness) Deprecated.
ColorControlPrimary
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface contains color controls (for instance, gamma) Deprecated.
ColorFill
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color filling with a blitter. Deprecated.
ColorKeyCapable
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports some form of color key in either overlay or blit operations. Deprecated.
ColorKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key cababilities Deprecated.
ColorKeyHardwareAssisted
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The color key is partially hardware-assisted. This means that other resources (CPU or video memory) might be used. If this bit is not set, full hardware support is in place. Deprecated.
CopyFourCc
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver supports blitting any FOURCC surface to another surface of the same FOURCC. Deprecated.
CurrentVideoPorts
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of live video ports. Deprecated.
CurrentVisibleOverlays
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of visible overlays or overlay sprites. Deprecated.
Draw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blit operations. Deprecated.
DrawFourCc
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color-space conversions during blit operations. Deprecated.
DrawQueue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of asynchronous blit operations. Deprecated.
DrawStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of stretching during blit operations. Deprecated.
FlipInterval
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the FileInterval flags Deprecated.
FlipNoVSync
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the NoVsync flag. Deprecated.
FXAlphaCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.
FXCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.
GammaCalibration
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator. Deprecated.
GdiShared
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is shared with GDI Deprecated.
MaxHardwareCodecStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.
MaxOverlayStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
maximum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.
MaxVideoPorts
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum video ports. Deprecated.
MaxVisibleOverlays
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of visible overlays Deprecated.
MinHardwareCodecStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.
MinOverlayStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Minimum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.
NlVbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from nonlocal to local video memory. Deprecated.
NlVbCKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits form nonlocal to local video memory. Deprecated.
NlVbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from nonlocal to local video memory. Deprecated.
NlVbExtendedCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from nonlocal to local video memory. Deprecated.
NlVbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from nonlocal to local video memory. Deprecated.
NoHardware
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support. Deprecated.
NonLocalVideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display driver supports surfaces in nonlocal video memory. Deprecated.
NoPageLockRequired
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DMA blit operations are supported on system-memory surfaces that are not page-locked. Deprecated.
NumberFourCcCodes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of FourCC codes. Deprecated.
Overlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays. Deprecated.
OverlayCannotClip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays but cannot clip them. Deprecated.
OverlayFourCc
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of color-space conversions during overlay operations. Deprecated.
OverlayHardwareDisplaysInterlacedVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually. Deprecated.
OverlayHardwareDisplaysInterleavedVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.
OverlayHardwareDisplaysNonInterleavedVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is not interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.
OverlayStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of stretching. Deprecated.
Palette
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of creating and supporting DirectDrawPalette objects for surfaces other than the primary surface. Deprecated.
PaletteCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities. Deprecated.
PaletteVerticalSync
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of updating a palette synchronized with the vertical refresh. Deprecated.
PrimaryGamma
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports dynamic gamma ramps for the primary surface. Deprecated.
RasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported. Deprecated.
ReadScanLine
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of returning the current scan line. Deprecated.
SsbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to system memory. Deprecated.
SsbCKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to system memory. Deprecated.
SsbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to system memory. Deprecated.
SsbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to system memory. Deprecated.
Stereo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns on the bit to support stereo mode. The driver can do stereo in at least one mode other than the current mode. Deprecated.
StereoVisionSequential
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver can do stereo in at least one mode other than the current mode. Deprecated.
SurfaceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
General surface capabilities. Deprecated.
SvbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to display memory. Deprecated.
SvbcKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to display memory. Deprecated.
SvbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to display memory. Deprecated.
SvbExtendedCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from system memory to display memory. Deprecated.
SvbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to display memory. Deprecated.
SvCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stereo-vision capabilities Deprecated.
VerticalBlankInterrupt
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of generating a vertical-blank interrupt. Deprecated.
VideoMemoryFree
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Free display memory. Deprecated.
VideoMemoryTotal
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total amount of display memory on the device, in bytes, minus memory reserved for the primary surface and any private data structures reserved by the driver. Deprecated.
VideoPort
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports live video. Deprecated.
VsbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from display memory to system memory. Deprecated.
VsbCKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from display memory to system memory. Deprecated.
VsbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from display memory to system memory. Deprecated.
VsbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from display memory to system memory. Deprecated.
WideSurfaces
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display surface supports surfaces wider than the primary surface. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Caps.Caps()

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Caps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Caps();
Managed C++ | public: Caps();
JScript .NET | public function Caps();


Caps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Caps.AlignBoundaryDestination

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignBoundaryDestination Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle alignment for an overlay surface, in pixels. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignBoundaryDestination As Integer
C# | public int AlignBoundaryDestination { get; }
Managed C++ | public: __property int get_AlignBoundaryDestination();
JScript .NET | public function get AlignBoundaryDestination() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlignBoundaryDestinationCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignBoundaryDestinationCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles with the x-axis aligned to the AlignBoundaryDest boundaries of the surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignBoundaryDestinationCaps As Boolean
C# | public bool AlignBoundaryDestinationCaps { get; }
Managed C++ | public: __property bool get_AlignBoundaryDestinationCaps();
JScript .NET | public function get AlignBoundaryDestinationCaps() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.AlignBoundarySource

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignBoundarySource Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle alignment for an overlay surface, in pixels. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignBoundarySource As Integer
C# | public int AlignBoundarySource { get; }
Managed C++ | public: __property int get_AlignBoundarySource();
JScript .NET | public function get AlignBoundarySource() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlignBoundarySourceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignBoundarySourceCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles with the x-axis aligned to the AlignBoundarySource boundaries of the surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignBoundarySourceCaps As Boolean
C# | public bool AlignBoundarySourceCaps { get; }
Managed C++ | public: __property bool get_AlignBoundarySourceCaps();
JScript .NET | public function get AlignBoundarySourceCaps() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.AlignSizeDestination

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignSizeDestination Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle size alignment for an overlay surface, in pixels. Overlay destination rectangles must have a pixel width that is a multiple of this value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignSizeDestination As Integer
C# | public int AlignSizeDestination { get; }
Managed C++ | public: __property int get_AlignSizeDestination();
JScript .NET | public function get AlignSizeDestination() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlignSizeDestinationCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignSizeDestinationCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles whose x-axis sizes, in pixels, are AlignSizeDest multiples. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignSizeDestinationCaps As Boolean
C# | public bool AlignSizeDestinationCaps { get; }
Managed C++ | public: __property bool get_AlignSizeDestinationCaps();
JScript .NET | public function get AlignSizeDestinationCaps() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.AlignSizeSource

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignSizeSource Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle size alignment for an overlay surface, in pixels. Overlay source rectangles must have a pixel width that is a multiple of this value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignSizeSource As Integer
C# | public int AlignSizeSource { get; }
Managed C++ | public: __property int get_AlignSizeSource();
JScript .NET | public function get AlignSizeSource() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlignSizeSourceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignSizeSourceCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles whose x-axis sizes, in pixels, are AlignSizeSource multiples. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignSizeSourceCaps As Boolean
C# | public bool AlignSizeSourceCaps { get; }
Managed C++ | public: __property bool get_AlignSizeSourceCaps();
JScript .NET | public function get AlignSizeSourceCaps() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.AlignStride

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignStride Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignStride As Boolean
C# | public bool AlignStride { get; }
Managed C++ | public: __property bool get_AlignStride();
JScript .NET | public function get AlignStride() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.AlignStrideAlign

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlignStrideAlign Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlignStrideAlign As Integer
C# | public int AlignStrideAlign { get; }
Managed C++ | public: __property int get_AlignStrideAlign();
JScript .NET | public function get AlignStrideAlign() : int

Property Value

System.Int32 .

This property is read-only.


Caps.Alpha

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Alpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware supports alpha-only surfaces. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Alpha As Boolean
C# | public bool Alpha { get; }
Managed C++ | public: __property bool get_Alpha();
JScript .NET | public function get Alpha() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.AlphaDrawConstBitDepths

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlphaDrawConstBitDepths Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlphaDrawConstBitDepths As Integer
C# | public int AlphaDrawConstBitDepths { get; }
Managed C++ | public: __property int get_AlphaDrawConstBitDepths();
JScript .NET | public function get AlphaDrawConstBitDepths() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlphaDrawPixelBitDepths

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlphaDrawPixelBitDepths Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlphaDrawPixelBitDepths As Integer
C# | public int AlphaDrawPixelBitDepths { get; }
Managed C++ | public: __property int get_AlphaDrawPixelBitDepths();
JScript .NET | public function get AlphaDrawPixelBitDepths() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlphaDrawSurfaceBitDepths

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlphaDrawSurfaceBitDepths Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel.) Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlphaDrawSurfaceBitDepths As Integer
C# | public int AlphaDrawSurfaceBitDepths { get; }
Managed C++ | public: __property int get_AlphaDrawSurfaceBitDepths();
JScript .NET | public function get AlphaDrawSurfaceBitDepths() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlphaOverlayConstBitDepths

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlphaOverlayConstBitDepths Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlphaOverlayConstBitDepths As Integer
C# | public int AlphaOverlayConstBitDepths { get; }
Managed C++ | public: __property int get_AlphaOverlayConstBitDepths();
JScript .NET | public function get AlphaOverlayConstBitDepths() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlphaOverlayPixelBitDepths

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlphaOverlayPixelBitDepths Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlphaOverlayPixelBitDepths As Integer
C# | public int AlphaOverlayPixelBitDepths { get; }
Managed C++ | public: __property int get_AlphaOverlayPixelBitDepths();
JScript .NET | public function get AlphaOverlayPixelBitDepths() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AlphaOverlaySurfaceBitDepths

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AlphaOverlaySurfaceBitDepths Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AlphaOverlaySurfaceBitDepths As Integer
C# | public int AlphaOverlaySurfaceBitDepths { get; }
Managed C++ | public: __property int get_AlphaOverlaySurfaceBitDepths();
JScript .NET | public function get AlphaOverlaySurfaceBitDepths() : int

Property Value

System.Int32 .

This property is read-only.


Caps.AutoFlipOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.AutoFlipOverlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay can be automatically flipped to the next surface in the flipping chain each time that a video port VSYNC occurs, allowing the video port and the overlay to double-buffer the video without CPU overhead. This option is only valid when the surface is receiving data from a video port. If the video port data is noninterlaced or noninterleaved, it flips on every VSYNC. If the data is being interleaved in memory, it flips on every other VSYNC. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AutoFlipOverlay As Boolean
C# | public bool AutoFlipOverlay { get; }
Managed C++ | public: __property bool get_AutoFlipOverlay();
JScript .NET | public function get AutoFlipOverlay() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.BankSwitched

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.BankSwitched Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware is bank-switched and is potentially very slow at random access to display memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property BankSwitched As Boolean
C# | public bool BankSwitched { get; }
Managed C++ | public: __property bool get_BankSwitched();
JScript .NET | public function get BankSwitched() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.CanClip

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CanClip Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping with blitting. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CanClip As Boolean
C# | public bool CanClip { get; }
Managed C++ | public: __property bool get_CanClip();
JScript .NET | public function get CanClip() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.CanClipStretched

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CanClipStretched Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping while stretch blitting. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CanClipStretched As Boolean
C# | public bool CanClipStretched { get; }
Managed C++ | public: __property bool get_CanClipStretched();
JScript .NET | public function get CanClipStretched() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.CanDrawSystemMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CanDrawSystemMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blitting to or from system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CanDrawSystemMemory As Boolean
C# | public bool CanDrawSystemMemory { get; }
Managed C++ | public: __property bool get_CanDrawSystemMemory();
JScript .NET | public function get CanDrawSystemMemory() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.CanFlipOddEven

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CanFlipOddEven Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver is capable of performing odd and even flip operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CanFlipOddEven As Boolean
C# | public bool CanFlipOddEven { get; }
Managed C++ | public: __property bool get_CanFlipOddEven();
JScript .NET | public function get CanFlipOddEven() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.CertifiedHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CertifiedHardware Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is certified. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CertifiedHardware As Boolean
C# | public bool CertifiedHardware { get; }
Managed C++ | public: __property bool get_CertifiedHardware();
JScript .NET | public function get CertifiedHardware() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.ColorControlOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ColorControlOverlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay surface contains color controls (such as brightness and sharpness) Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ColorControlOverlay As Boolean
C# | public bool ColorControlOverlay { get; }
Managed C++ | public: __property bool get_ColorControlOverlay();
JScript .NET | public function get ColorControlOverlay() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.ColorControlPrimary

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ColorControlPrimary Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface contains color controls (for instance, gamma) Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ColorControlPrimary As Boolean
C# | public bool ColorControlPrimary { get; }
Managed C++ | public: __property bool get_ColorControlPrimary();
JScript .NET | public function get ColorControlPrimary() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.ColorFill

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ColorFill Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color filling with a blitter. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ColorFill As Boolean
C# | public bool ColorFill { get; }
Managed C++ | public: __property bool get_ColorFill();
JScript .NET | public function get ColorFill() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.ColorKeyCapable

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ColorKeyCapable Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports some form of color key in either overlay or blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ColorKeyCapable As Boolean
C# | public bool ColorKeyCapable { get; }
Managed C++ | public: __property bool get_ColorKeyCapable();
JScript .NET | public function get ColorKeyCapable() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.ColorKeyCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ColorKeyCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key cababilities Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ColorKeyCaps As ColorKeyCaps
C# | public ColorKeyCaps ColorKeyCaps { get; }
Managed C++ | public: __property ColorKeyCaps get_ColorKeyCaps();
JScript .NET | public function get ColorKeyCaps() : ColorKeyCaps

Property Value

Microsoft.DirectX.DirectDraw.ColorKeyCaps .

This property is read-only.


Caps.ColorKeyHardwareAssisted

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ColorKeyHardwareAssisted Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The color key is partially hardware-assisted. This means that other resources (CPU or video memory) might be used. If this bit is not set, full hardware support is in place. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ColorKeyHardwareAssisted As Boolean
C# | public bool ColorKeyHardwareAssisted { get; }
Managed C++ | public: __property bool get_ColorKeyHardwareAssisted();
JScript .NET | public function get ColorKeyHardwareAssisted() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.CopyFourCc

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CopyFourCc Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver supports blitting any FOURCC surface to another surface of the same FOURCC. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CopyFourCc As Boolean
C# | public bool CopyFourCc { get; }
Managed C++ | public: __property bool get_CopyFourCc();
JScript .NET | public function get CopyFourCc() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.CurrentVideoPorts

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CurrentVideoPorts Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of live video ports. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CurrentVideoPorts As Integer
C# | public int CurrentVideoPorts { get; }
Managed C++ | public: __property int get_CurrentVideoPorts();
JScript .NET | public function get CurrentVideoPorts() : int

Property Value

System.Int32 .

This property is read-only.


Caps.CurrentVisibleOverlays

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.CurrentVisibleOverlays Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of visible overlays or overlay sprites. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CurrentVisibleOverlays As Integer
C# | public int CurrentVisibleOverlays { get; }
Managed C++ | public: __property int get_CurrentVisibleOverlays();
JScript .NET | public function get CurrentVisibleOverlays() : int

Property Value

System.Int32 .

This property is read-only.


Caps.Draw

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Draw Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Draw As Boolean
C# | public bool Draw { get; }
Managed C++ | public: __property bool get_Draw();
JScript .NET | public function get Draw() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.DrawFourCc

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DrawFourCc Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color-space conversions during blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawFourCc As Boolean
C# | public bool DrawFourCc { get; }
Managed C++ | public: __property bool get_DrawFourCc();
JScript .NET | public function get DrawFourCc() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.DrawQueue

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DrawQueue Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of asynchronous blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawQueue As Boolean
C# | public bool DrawQueue { get; }
Managed C++ | public: __property bool get_DrawQueue();
JScript .NET | public function get DrawQueue() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.DrawStretch

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DrawStretch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of stretching during blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawStretch As Boolean
C# | public bool DrawStretch { get; }
Managed C++ | public: __property bool get_DrawStretch();
JScript .NET | public function get DrawStretch() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.FlipInterval

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FlipInterval Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the FileInterval flags Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property FlipInterval As Boolean
C# | public bool FlipInterval { get; }
Managed C++ | public: __property bool get_FlipInterval();
JScript .NET | public function get FlipInterval() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.FlipNoVSync

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FlipNoVSync Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the NoVsync flag. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property FlipNoVSync As Boolean
C# | public bool FlipNoVSync { get; }
Managed C++ | public: __property bool get_FlipNoVSync();
JScript .NET | public function get FlipNoVSync() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.FXAlphaCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FXAlphaCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property FXAlphaCaps As FXAlphaCaps
C# | public FXAlphaCaps FXAlphaCaps { get; }
Managed C++ | public: __property FXAlphaCaps get_FXAlphaCaps();
JScript .NET | public function get FXAlphaCaps() : FXAlphaCaps

Property Value

Microsoft.DirectX.DirectDraw.FXAlphaCaps .

This property is read-only.


Caps.FXCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FXCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property FXCaps As FXCaps
C# | public FXCaps FXCaps { get; }
Managed C++ | public: __property FXCaps get_FXCaps();
JScript .NET | public function get FXCaps() : FXCaps

Property Value

Microsoft.DirectX.DirectDraw.FXCaps .

This property is read-only.


Caps.GammaCalibration

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.GammaCalibration Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GammaCalibration As Boolean
C# | public bool GammaCalibration { get; }
Managed C++ | public: __property bool get_GammaCalibration();
JScript .NET | public function get GammaCalibration() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.GdiShared

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.GdiShared Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is shared with GDI Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GdiShared As Boolean
C# | public bool GdiShared { get; }
Managed C++ | public: __property bool get_GdiShared();
JScript .NET | public function get GdiShared() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.MaxHardwareCodecStretch

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardwareCodecStretch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MaxHardwareCodecStretch As Integer
C# | public int MaxHardwareCodecStretch { get; }
Managed C++ | public: __property int get_MaxHardwareCodecStretch();
JScript .NET | public function get MaxHardwareCodecStretch() : int

Property Value

System.Int32 .

This property is read-only.


Caps.MaxOverlayStretch

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxOverlayStretch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
maximum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MaxOverlayStretch As Integer
C# | public int MaxOverlayStretch { get; }
Managed C++ | public: __property int get_MaxOverlayStretch();
JScript .NET | public function get MaxOverlayStretch() : int

Property Value

System.Int32 .

This property is read-only.


Caps.MaxVideoPorts

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVideoPorts Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum video ports. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVideoPorts As Integer
C# | public int MaxVideoPorts { get; }
Managed C++ | public: __property int get_MaxVideoPorts();
JScript .NET | public function get MaxVideoPorts() : int

Property Value

System.Int32 .

This property is read-only.


Caps.MaxVisibleOverlays

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxVisibleOverlays Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of visible overlays Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MaxVisibleOverlays As Integer
C# | public int MaxVisibleOverlays { get; }
Managed C++ | public: __property int get_MaxVisibleOverlays();
JScript .NET | public function get MaxVisibleOverlays() : int

Property Value

System.Int32 .

This property is read-only.


Caps.MinHardwareCodecStretch

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MinHardwareCodecStretch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MinHardwareCodecStretch As Integer
C# | public int MinHardwareCodecStretch { get; }
Managed C++ | public: __property int get_MinHardwareCodecStretch();
JScript .NET | public function get MinHardwareCodecStretch() : int

Property Value

System.Int32 .

This property is read-only.


Caps.MinOverlayStretch

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MinOverlayStretch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Minimum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MinOverlayStretch As Integer
C# | public int MinOverlayStretch { get; }
Managed C++ | public: __property int get_MinOverlayStretch();
JScript .NET | public function get MinOverlayStretch() : int

Property Value

System.Int32 .

This property is read-only.


Caps.NlVbCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NlVbCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NlVbCaps As Integer
C# | public int NlVbCaps { get; }
Managed C++ | public: __property int get_NlVbCaps();
JScript .NET | public function get NlVbCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.NlVbCKeyCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NlVbCKeyCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits form nonlocal to local video memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NlVbCKeyCaps As Integer
C# | public int NlVbCKeyCaps { get; }
Managed C++ | public: __property int get_NlVbCKeyCaps();
JScript .NET | public function get NlVbCKeyCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.NlVbEffectsCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NlVbEffectsCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NlVbEffectsCaps As Integer
C# | public int NlVbEffectsCaps { get; }
Managed C++ | public: __property int get_NlVbEffectsCaps();
JScript .NET | public function get NlVbEffectsCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.NlVbExtendedCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NlVbExtendedCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NlVbExtendedCaps As Integer
C# | public int NlVbExtendedCaps { get; }
Managed C++ | public: __property int get_NlVbExtendedCaps();
JScript .NET | public function get NlVbExtendedCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.NlVbRasterOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NlVbRasterOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NlVbRasterOperations As Integer()
C# | public int[] NlVbRasterOperations { get; }
Managed C++ | public: __property int get_NlVbRasterOperations();
JScript .NET | public function get NlVbRasterOperations() : int[]

Property Value

System.Int32[] .

This property is read-only.


Caps.NoHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NoHardware Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NoHardware As Boolean
C# | public bool NoHardware { get; }
Managed C++ | public: __property bool get_NoHardware();
JScript .NET | public function get NoHardware() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.NonLocalVideoMemory

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NonLocalVideoMemory Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display driver supports surfaces in nonlocal video memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NonLocalVideoMemory As Boolean
C# | public bool NonLocalVideoMemory { get; }
Managed C++ | public: __property bool get_NonLocalVideoMemory();
JScript .NET | public function get NonLocalVideoMemory() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.NoPageLockRequired

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NoPageLockRequired Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DMA blit operations are supported on system-memory surfaces that are not page-locked. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NoPageLockRequired As Boolean
C# | public bool NoPageLockRequired { get; }
Managed C++ | public: __property bool get_NoPageLockRequired();
JScript .NET | public function get NoPageLockRequired() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.NumberFourCcCodes

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NumberFourCcCodes Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of FourCC codes. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NumberFourCcCodes As Integer
C# | public int NumberFourCcCodes { get; }
Managed C++ | public: __property int get_NumberFourCcCodes();
JScript .NET | public function get NumberFourCcCodes() : int

Property Value

System.Int32 .

This property is read-only.


Caps.Overlay

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Overlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Overlay As Boolean
C# | public bool Overlay { get; }
Managed C++ | public: __property bool get_Overlay();
JScript .NET | public function get Overlay() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.OverlayCannotClip

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.OverlayCannotClip Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays but cannot clip them. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayCannotClip As Boolean
C# | public bool OverlayCannotClip { get; }
Managed C++ | public: __property bool get_OverlayCannotClip();
JScript .NET | public function get OverlayCannotClip() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.OverlayFourCc

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.OverlayFourCc Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of color-space conversions during overlay operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayFourCc As Boolean
C# | public bool OverlayFourCc { get; }
Managed C++ | public: __property bool get_OverlayFourCc();
JScript .NET | public function get OverlayFourCc() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.OverlayHardwareDisplaysInterlacedVideo

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.OverlayHardwareDisplaysInterlacedVideo Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayHardwareDisplaysInterlacedVideo As Boolean
C# | public bool OverlayHardwareDisplaysInterlacedVideo { get; }
Managed C++ | public: __property bool get_OverlayHardwareDisplaysInterlacedVideo();
JScript .NET | public function get OverlayHardwareDisplaysInterlacedVideo() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.OverlayHardwareDisplaysInterleavedVideo

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.OverlayHardwareDisplaysInterleavedVideo Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayHardwareDisplaysInterleavedVideo As Boolean
C# | public bool OverlayHardwareDisplaysInterleavedVideo { get; }
Managed C++ | public: __property bool get_OverlayHardwareDisplaysInterleavedVideo();
JScript .NET | public function get OverlayHardwareDisplaysInterleavedVideo() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.OverlayHardwareDisplaysNonInterleavedVideo

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.OverlayHardwareDisplaysNonInterleavedVideo Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is not interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayHardwareDisplaysNonInterleavedVideo As Boolean
C# | public bool OverlayHardwareDisplaysNonInterleavedVideo { get; }
Managed C++ | public: __property bool get_OverlayHardwareDisplaysNonInterleavedVideo();
JScript .NET | public function get OverlayHardwareDisplaysNonInterleavedVideo() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.OverlayStretch

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.OverlayStretch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of stretching. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayStretch As Boolean
C# | public bool OverlayStretch { get; }
Managed C++ | public: __property bool get_OverlayStretch();
JScript .NET | public function get OverlayStretch() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.Palette

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Palette Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of creating and supporting DirectDrawPalette objects for surfaces other than the primary surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Palette As Boolean
C# | public bool Palette { get; }
Managed C++ | public: __property bool get_Palette();
JScript .NET | public function get Palette() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.PaletteCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PaletteCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PaletteCaps As PaletteCaps
C# | public PaletteCaps PaletteCaps { get; }
Managed C++ | public: __property PaletteCaps get_PaletteCaps();
JScript .NET | public function get PaletteCaps() : PaletteCaps

Property Value

Microsoft.DirectX.DirectDraw.PaletteCaps .

This property is read-only.


Caps.PaletteVerticalSync

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PaletteVerticalSync Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of updating a palette synchronized with the vertical refresh. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PaletteVerticalSync As Boolean
C# | public bool PaletteVerticalSync { get; }
Managed C++ | public: __property bool get_PaletteVerticalSync();
JScript .NET | public function get PaletteVerticalSync() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.PrimaryGamma

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PrimaryGamma Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports dynamic gamma ramps for the primary surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PrimaryGamma As Boolean
C# | public bool PrimaryGamma { get; }
Managed C++ | public: __property bool get_PrimaryGamma();
JScript .NET | public function get PrimaryGamma() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.RasterOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.RasterOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property RasterOperations As Integer()
C# | public int[] RasterOperations { get; }
Managed C++ | public: __property int get_RasterOperations();
JScript .NET | public function get RasterOperations() : int[]

Property Value

System.Int32[] .

This property is read-only.


Caps.ReadScanLine

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ReadScanLine Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of returning the current scan line. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ReadScanLine As Boolean
C# | public bool ReadScanLine { get; }
Managed C++ | public: __property bool get_ReadScanLine();
JScript .NET | public function get ReadScanLine() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.SsbCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SsbCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SsbCaps As Integer
C# | public int SsbCaps { get; }
Managed C++ | public: __property int get_SsbCaps();
JScript .NET | public function get SsbCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.SsbCKeyCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SsbCKeyCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SsbCKeyCaps As Integer
C# | public int SsbCKeyCaps { get; }
Managed C++ | public: __property int get_SsbCKeyCaps();
JScript .NET | public function get SsbCKeyCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.SsbEffectsCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SsbEffectsCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SsbEffectsCaps As Integer
C# | public int SsbEffectsCaps { get; }
Managed C++ | public: __property int get_SsbEffectsCaps();
JScript .NET | public function get SsbEffectsCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.SsbRasterOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SsbRasterOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SsbRasterOperations As Integer()
C# | public int[] SsbRasterOperations { get; }
Managed C++ | public: __property int get_SsbRasterOperations();
JScript .NET | public function get SsbRasterOperations() : int[]

Property Value

System.Int32[] .

This property is read-only.


Caps.Stereo

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Stereo Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns on the bit to support stereo mode. The driver can do stereo in at least one mode other than the current mode. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Stereo As Boolean
C# | public bool Stereo { get; }
Managed C++ | public: __property bool get_Stereo();
JScript .NET | public function get Stereo() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.StereoVisionSequential

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.StereoVisionSequential Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver can do stereo in at least one mode other than the current mode. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property StereoVisionSequential As Boolean
C# | public bool StereoVisionSequential { get; }
Managed C++ | public: __property bool get_StereoVisionSequential();
JScript .NET | public function get StereoVisionSequential() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.SurfaceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SurfaceCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
General surface capabilities. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SurfaceCaps As SurfaceCaps
C# | public SurfaceCaps SurfaceCaps { get; }
Managed C++ | public: __property SurfaceCaps* get_SurfaceCaps();
JScript .NET | public function get SurfaceCaps() : SurfaceCaps

Property Value

Microsoft.DirectX.DirectDraw.SurfaceCaps .

This property is read-only.


Caps.SvbCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SvbCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SvbCaps As Integer
C# | public int SvbCaps { get; }
Managed C++ | public: __property int get_SvbCaps();
JScript .NET | public function get SvbCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.SvbcKeyCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SvbcKeyCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SvbcKeyCaps As Integer
C# | public int SvbcKeyCaps { get; }
Managed C++ | public: __property int get_SvbcKeyCaps();
JScript .NET | public function get SvbcKeyCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.SvbEffectsCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SvbEffectsCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SvbEffectsCaps As Integer
C# | public int SvbEffectsCaps { get; }
Managed C++ | public: __property int get_SvbEffectsCaps();
JScript .NET | public function get SvbEffectsCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.SvbExtendedCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SvbExtendedCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SvbExtendedCaps As Integer
C# | public int SvbExtendedCaps { get; }
Managed C++ | public: __property int get_SvbExtendedCaps();
JScript .NET | public function get SvbExtendedCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.SvbRasterOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SvbRasterOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to display memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SvbRasterOperations As Integer()
C# | public int[] SvbRasterOperations { get; }
Managed C++ | public: __property int get_SvbRasterOperations();
JScript .NET | public function get SvbRasterOperations() : int[]

Property Value

System.Int32[] .

This property is read-only.


Caps.SvCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SvCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stereo-vision capabilities Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SvCaps As Integer
C# | public int SvCaps { get; }
Managed C++ | public: __property int get_SvCaps();
JScript .NET | public function get SvCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.VerticalBlankInterrupt

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VerticalBlankInterrupt Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of generating a vertical-blank interrupt. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VerticalBlankInterrupt As Boolean
C# | public bool VerticalBlankInterrupt { get; }
Managed C++ | public: __property bool get_VerticalBlankInterrupt();
JScript .NET | public function get VerticalBlankInterrupt() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.VideoMemoryFree

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VideoMemoryFree Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Free display memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VideoMemoryFree As Integer
C# | public int VideoMemoryFree { get; }
Managed C++ | public: __property int get_VideoMemoryFree();
JScript .NET | public function get VideoMemoryFree() : int

Property Value

System.Int32 .

This property is read-only.


Caps.VideoMemoryTotal

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VideoMemoryTotal Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total amount of display memory on the device, in bytes, minus memory reserved for the primary surface and any private data structures reserved by the driver. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VideoMemoryTotal As Integer
C# | public int VideoMemoryTotal { get; }
Managed C++ | public: __property int get_VideoMemoryTotal();
JScript .NET | public function get VideoMemoryTotal() : int

Property Value

System.Int32 .

This property is read-only.


Caps.VideoPort

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VideoPort Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports live video. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VideoPort As Boolean
C# | public bool VideoPort { get; }
Managed C++ | public: __property bool get_VideoPort();
JScript .NET | public function get VideoPort() : boolean

Property Value

System.Boolean .

This property is read-only.


Caps.VsbCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VsbCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from display memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VsbCaps As Integer
C# | public int VsbCaps { get; }
Managed C++ | public: __property int get_VsbCaps();
JScript .NET | public function get VsbCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.VsbCKeyCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VsbCKeyCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from display memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VsbCKeyCaps As Integer
C# | public int VsbCKeyCaps { get; }
Managed C++ | public: __property int get_VsbCKeyCaps();
JScript .NET | public function get VsbCKeyCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.VsbEffectsCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VsbEffectsCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from display memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VsbEffectsCaps As Integer
C# | public int VsbEffectsCaps { get; }
Managed C++ | public: __property int get_VsbEffectsCaps();
JScript .NET | public function get VsbEffectsCaps() : int

Property Value

System.Int32 .

This property is read-only.


Caps.VsbRasterOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.VsbRasterOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from display memory to system memory. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VsbRasterOperations As Integer()
C# | public int[] VsbRasterOperations { get; }
Managed C++ | public: __property int get_VsbRasterOperations();
JScript .NET | public function get VsbRasterOperations() : int[]

Property Value

System.Int32[] .

This property is read-only.


Caps.WideSurfaces

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.WideSurfaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display surface supports surfaces wider than the primary surface. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property WideSurfaces As Boolean
C# | public bool WideSurfaces { get; }
Managed C++ | public: __property bool get_WideSurfaces();
JScript .NET | public function get WideSurfaces() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the color controls associated with an overlay surface, or a primary surface. Deprecated.

Definition

Visual Basic .NET | Public Structure ColorControlObject
C# | public struct ColorControlObject
Managed C++ | public __value struct ColorControlObject
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ColorControlObject
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Brightness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Luminance intensity, in IRE units times 100. The valid range is from 0 through 10,000. The default is 750, which translates to 7.5 IRE. Deprecated.
ColorEnable
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag indicating whether color is used. Deprecated.
Contrast
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Relative difference between higher and lower intensity luminance values in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000 (100 IRE). Higher values of contrast cause darker luminance values to tend toward black and lighter luminance values to tend toward white. Lower values of contrast cause all luminance values to move toward the middle of the scale. Deprecated.
Gamma
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the amount of gamma correction applied to the luminance values. The valid range is from 1 through 500 gamma units, with a default of 1. Deprecated.
Hue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Phase relationship of the chrominance components. Hue is specified in degrees, and the valid range is from -180 through 180, with a default of 0. Deprecated.
IsBrightnessValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Brightness member contains valid data. Deprecated.
IsColorEnableValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorEnable member contains valid data. Deprecated.
IsContrastValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Contrast member contains valid data. Deprecated.
IsGammaValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Gamma member contains valid data. Deprecated.
IsHueValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Hue member contains valid data. Deprecated.
IsSaturationValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Saturation member contains valid data. Deprecated.
IsSharpnessValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Sharpness member contains valid data. Deprecated.
Saturation
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color intensity, in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000, which translates to 100 IRE. Deprecated.
Sharpness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sharpness, in arbitrary units. The valid range is from 0 through 10, with a default of 5. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorControlObject.ColorControlObject()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.ColorControlObject Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ColorControlObject();
Managed C++ | public: ColorControlObject();
JScript .NET | public function ColorControlObject();


ColorControlObject.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ColorControlObject.Brightness

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.Brightness Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Luminance intensity, in IRE units times 100. The valid range is from 0 through 10,000. The default is 750, which translates to 7.5 IRE. Deprecated.

Definition

Visual Basic .NET | Public Property Brightness As Integer
C# | public int Brightness { get; set; }
Managed C++ public: __property int get_Brightness();
public: __property void set_Brightness(int);
JScript .NET public function get Brightness() : int
public function set Brightness(int);

Property Value

System.Int32 .

This property is read/write.


ColorControlObject.ColorEnable

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.ColorEnable Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag indicating whether color is used. Deprecated.

Definition

Visual Basic .NET | Public Property ColorEnable As Integer
C# | public int ColorEnable { get; set; }
Managed C++ public: __property int get_ColorEnable();
public: __property void set_ColorEnable(int);
JScript .NET public function get ColorEnable() : int
public function set ColorEnable(int);

Property Value

System.Int32 .

This property is read/write.


ColorControlObject.Contrast

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.Contrast Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Relative difference between higher and lower intensity luminance values in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000 (100 IRE). Higher values of contrast cause darker luminance values to tend toward black and lighter luminance values to tend toward white. Lower values of contrast cause all luminance values to move toward the middle of the scale. Deprecated.

Definition

Visual Basic .NET | Public Property Contrast As Integer
C# | public int Contrast { get; set; }
Managed C++ public: __property int get_Contrast();
public: __property void set_Contrast(int);
JScript .NET public function get Contrast() : int
public function set Contrast(int);

Property Value

System.Int32 .

This property is read/write.


ColorControlObject.Gamma

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.Gamma Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the amount of gamma correction applied to the luminance values. The valid range is from 1 through 500 gamma units, with a default of 1. Deprecated.

Definition

Visual Basic .NET | Public Property Gamma As Integer
C# | public int Gamma { get; set; }
Managed C++ public: __property int get_Gamma();
public: __property void set_Gamma(int);
JScript .NET public function get Gamma() : int
public function set Gamma(int);

Property Value

System.Int32 .

This property is read/write.


ColorControlObject.Hue

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.Hue Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Phase relationship of the chrominance components. Hue is specified in degrees, and the valid range is from -180 through 180, with a default of 0. Deprecated.

Definition

Visual Basic .NET | Public Property Hue As Integer
C# | public int Hue { get; set; }
Managed C++ public: __property int get_Hue();
public: __property void set_Hue(int);
JScript .NET public function get Hue() : int
public function set Hue(int);

Property Value

System.Int32 .

This property is read/write.


ColorControlObject.IsBrightnessValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.IsBrightnessValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Brightness member contains valid data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsBrightnessValid As Boolean
C# | public bool IsBrightnessValid { get; }
Managed C++ | public: __property bool get_IsBrightnessValid();
JScript .NET | public function get IsBrightnessValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject.IsColorEnableValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.IsColorEnableValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorEnable member contains valid data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsColorEnableValid As Boolean
C# | public bool IsColorEnableValid { get; }
Managed C++ | public: __property bool get_IsColorEnableValid();
JScript .NET | public function get IsColorEnableValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject.IsContrastValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.IsContrastValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Contrast member contains valid data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsContrastValid As Boolean
C# | public bool IsContrastValid { get; }
Managed C++ | public: __property bool get_IsContrastValid();
JScript .NET | public function get IsContrastValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject.IsGammaValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.IsGammaValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Gamma member contains valid data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsGammaValid As Boolean
C# | public bool IsGammaValid { get; }
Managed C++ | public: __property bool get_IsGammaValid();
JScript .NET | public function get IsGammaValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject.IsHueValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.IsHueValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Hue member contains valid data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsHueValid As Boolean
C# | public bool IsHueValid { get; }
Managed C++ | public: __property bool get_IsHueValid();
JScript .NET | public function get IsHueValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject.IsSaturationValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.IsSaturationValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Saturation member contains valid data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsSaturationValid As Boolean
C# | public bool IsSaturationValid { get; }
Managed C++ | public: __property bool get_IsSaturationValid();
JScript .NET | public function get IsSaturationValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject.IsSharpnessValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.IsSharpnessValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Sharpness member contains valid data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property IsSharpnessValid As Boolean
C# | public bool IsSharpnessValid { get; }
Managed C++ | public: __property bool get_IsSharpnessValid();
JScript .NET | public function get IsSharpnessValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorControlObject.Saturation

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.Saturation Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color intensity, in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000, which translates to 100 IRE. Deprecated.

Definition

Visual Basic .NET | Public Property Saturation As Integer
C# | public int Saturation { get; set; }
Managed C++ public: __property int get_Saturation();
public: __property void set_Saturation(int);
JScript .NET public function get Saturation() : int
public function set Saturation(int);

Property Value

System.Int32 .

This property is read/write.


ColorControlObject.Sharpness

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorControlObject.Sharpness Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sharpness, in arbitrary units. The valid range is from 0 through 10, with a default of 5. Deprecated.

Definition

Visual Basic .NET | Public Property Sharpness As Integer
C# | public int Sharpness { get; set; }
Managed C++ public: __property int get_Sharpness();
public: __property void set_Sharpness(int);
JScript .NET public function get Sharpness() : int
public function set Sharpness(int);

Property Value

System.Int32 .

This property is read/write.


ColorKey

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a source color key, destination color key, or color space. Deprecated.

Definition

Visual Basic .NET | Public Structure ColorKey
C# | public struct ColorKey
Managed C++ | public __value struct ColorKey
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ColorKey
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ColorSpaceHighValue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
High value of the color range that is to be used as the color key. Deprecated.
ColorSpaceLowValue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Low value of the color range that is to be used as the color key. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorKey.ColorKey()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.ColorKey Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ColorKey();
Managed C++ | public: ColorKey();
JScript .NET | public function ColorKey();


ColorKey.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


ColorKey.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


ColorKey.op_Equality(ColorKey,ColorKey)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As ColorKey, _
ByVal right As ColorKey _
) As Boolean
C# public static bool op_Equality(
ColorKey left,
ColorKey right
);
Managed C++ public: static bool op_Equality(
ColorKey left,
ColorKey right
);
JScript .NET public static function op_Equality(
left : ColorKey,
right : ColorKey
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.ColorKey. The ColorKey structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.ColorKey. The ColorKey structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


ColorKey.op_Inequality(ColorKey,ColorKey)

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As ColorKey, _
ByVal right As ColorKey _
) As Boolean
C# public static bool op_Inequality(
ColorKey left,
ColorKey right
);
Managed C++ public: static bool op_Inequality(
ColorKey left,
ColorKey right
);
JScript .NET public static function op_Inequality(
left : ColorKey,
right : ColorKey
) : boolean;

Parameters

left | Microsoft.DirectX.DirectDraw.ColorKey. The ColorKey structure to the left of the equality operator.
right | Microsoft.DirectX.DirectDraw.ColorKey. The ColorKey structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


ColorKey.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ColorKey.ColorSpaceHighValue

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.ColorSpaceHighValue Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
High value of the color range that is to be used as the color key. Deprecated.

Definition

Visual Basic .NET | Public Property ColorSpaceHighValue As Integer
C# | public int ColorSpaceHighValue { get; set; }
Managed C++ public: __property int get_ColorSpaceHighValue();
public: __property void set_ColorSpaceHighValue(int);
JScript .NET public function get ColorSpaceHighValue() : int
public function set ColorSpaceHighValue(int);

Property Value

System.Int32 .

This property is read/write.


ColorKey.ColorSpaceLowValue

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKey.ColorSpaceLowValue Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Low value of the color range that is to be used as the color key. Deprecated.

Definition

Visual Basic .NET | Public Property ColorSpaceLowValue As Integer
C# | public int ColorSpaceLowValue { get; set; }
Managed C++ public: __property int get_ColorSpaceLowValue();
public: __property void set_ColorSpaceLowValue(int);
JScript .NET public function get ColorSpaceLowValue() : int
public function set ColorSpaceLowValue(int);

Property Value

System.Int32 .

This property is read/write.


ColorKeyCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key capabilities Deprecated.

Definition

Visual Basic .NET | Public Structure ColorKeyCaps
C# | public struct ColorKeyCaps
Managed C++ | public __value struct ColorKeyCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
DestinationDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.
DestinationDrawColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color space that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.
DestinationDrawColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.
DestinationDrawYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.
DestinationOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying with color keying of the replaceable bits of the destination surface to be overlaid for RGB colors. Deprecated.
DestinationOverlayColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of RGB colors. Deprecated.
DestinationOverlayColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of YUV colors. Deprecated.
DestinationOverlayOneActive
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active destination color key value for visible overlay surfaces Deprecated.
DestinationOverlayYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using color keying of the replaceable bits of the destination surface to be overlaid for YUV colors. Deprecated.
NoCostOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that there are no bandwidth trade-offs for using the color key with an overlay. Deprecated.
SourceDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for RGB colors. Deprecated.
SourceDrawColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for RGB colors. Deprecated.
SourceDrawColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for YUV colors. Deprecated.
SourceDrawYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for YUV colors. Deprecated.
SourceOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for RGB colors. Deprecated.
SourceOverlayColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for RGB colors. Deprecated.
SourceOverlayColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for YUV colors. Deprecated.
SourceOverlayOneActive
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active source color key value for visible overlay surfaces. Deprecated.
SourceOverlayYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for YUV colors. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorKeyCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ColorKeyCaps.DestinationDraw

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationDraw Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationDraw As Boolean
C# | public bool DestinationDraw { get; }
Managed C++ | public: __property bool get_DestinationDraw();
JScript .NET | public function get DestinationDraw() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationDrawColorSpace

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationDrawColorSpace Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color space that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationDrawColorSpace As Boolean
C# | public bool DestinationDrawColorSpace { get; }
Managed C++ | public: __property bool get_DestinationDrawColorSpace();
JScript .NET | public function get DestinationDrawColorSpace() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationDrawColorSpaceYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationDrawColorSpaceYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationDrawColorSpaceYuv As Boolean
C# | public bool DestinationDrawColorSpaceYuv { get; }
Managed C++ | public: __property bool get_DestinationDrawColorSpaceYuv();
JScript .NET | public function get DestinationDrawColorSpaceYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationDrawYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationDrawYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationDrawYuv As Boolean
C# | public bool DestinationDrawYuv { get; }
Managed C++ | public: __property bool get_DestinationDrawYuv();
JScript .NET | public function get DestinationDrawYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationOverlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying with color keying of the replaceable bits of the destination surface to be overlaid for RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationOverlay As Boolean
C# | public bool DestinationOverlay { get; }
Managed C++ | public: __property bool get_DestinationOverlay();
JScript .NET | public function get DestinationOverlay() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationOverlayColorSpace

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationOverlayColorSpace Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationOverlayColorSpace As Boolean
C# | public bool DestinationOverlayColorSpace { get; }
Managed C++ | public: __property bool get_DestinationOverlayColorSpace();
JScript .NET | public function get DestinationOverlayColorSpace() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationOverlayColorSpaceYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationOverlayColorSpaceYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationOverlayColorSpaceYuv As Boolean
C# | public bool DestinationOverlayColorSpaceYuv { get; }
Managed C++ | public: __property bool get_DestinationOverlayColorSpaceYuv();
JScript .NET | public function get DestinationOverlayColorSpaceYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationOverlayOneActive

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationOverlayOneActive Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active destination color key value for visible overlay surfaces Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationOverlayOneActive As Boolean
C# | public bool DestinationOverlayOneActive { get; }
Managed C++ | public: __property bool get_DestinationOverlayOneActive();
JScript .NET | public function get DestinationOverlayOneActive() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.DestinationOverlayYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.DestinationOverlayYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using color keying of the replaceable bits of the destination surface to be overlaid for YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DestinationOverlayYuv As Boolean
C# | public bool DestinationOverlayYuv { get; }
Managed C++ | public: __property bool get_DestinationOverlayYuv();
JScript .NET | public function get DestinationOverlayYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.NoCostOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.NoCostOverlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that there are no bandwidth trade-offs for using the color key with an overlay. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NoCostOverlay As Boolean
C# | public bool NoCostOverlay { get; }
Managed C++ | public: __property bool get_NoCostOverlay();
JScript .NET | public function get NoCostOverlay() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceDraw

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceDraw Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceDraw As Boolean
C# | public bool SourceDraw { get; }
Managed C++ | public: __property bool get_SourceDraw();
JScript .NET | public function get SourceDraw() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceDrawColorSpace

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceDrawColorSpace Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceDrawColorSpace As Boolean
C# | public bool SourceDrawColorSpace { get; }
Managed C++ | public: __property bool get_SourceDrawColorSpace();
JScript .NET | public function get SourceDrawColorSpace() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceDrawColorSpaceYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceDrawColorSpaceYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceDrawColorSpaceYuv As Boolean
C# | public bool SourceDrawColorSpaceYuv { get; }
Managed C++ | public: __property bool get_SourceDrawColorSpaceYuv();
JScript .NET | public function get SourceDrawColorSpaceYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceDrawYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceDrawYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceDrawYuv As Boolean
C# | public bool SourceDrawYuv { get; }
Managed C++ | public: __property bool get_SourceDrawYuv();
JScript .NET | public function get SourceDrawYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceOverlay

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceOverlay Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceOverlay As Boolean
C# | public bool SourceOverlay { get; }
Managed C++ | public: __property bool get_SourceOverlay();
JScript .NET | public function get SourceOverlay() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceOverlayColorSpace

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceOverlayColorSpace Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for RGB colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceOverlayColorSpace As Boolean
C# | public bool SourceOverlayColorSpace { get; }
Managed C++ | public: __property bool get_SourceOverlayColorSpace();
JScript .NET | public function get SourceOverlayColorSpace() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceOverlayColorSpaceYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceOverlayColorSpaceYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceOverlayColorSpaceYuv As Boolean
C# | public bool SourceOverlayColorSpaceYuv { get; }
Managed C++ | public: __property bool get_SourceOverlayColorSpaceYuv();
JScript .NET | public function get SourceOverlayColorSpaceYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceOverlayOneActive

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceOverlayOneActive Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active source color key value for visible overlay surfaces. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceOverlayOneActive As Boolean
C# | public bool SourceOverlayOneActive { get; }
Managed C++ | public: __property bool get_SourceOverlayOneActive();
JScript .NET | public function get SourceOverlayOneActive() : boolean

Property Value

System.Boolean .

This property is read-only.


ColorKeyCaps.SourceOverlayYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorKeyCaps.SourceOverlayYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for YUV colors. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourceOverlayYuv As Boolean
C# | public bool SourceOverlayYuv { get; }
Managed C++ | public: __property bool get_SourceOverlayYuv();
JScript .NET | public function get SourceOverlayYuv() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceIdentifier

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.

Definition

Visual Basic .NET | Public Structure DeviceIdentifier
C# | public struct DeviceIdentifier
Managed C++ | public __value struct DeviceIdentifier
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DeviceIdentifier
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.
DeviceGuid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unique identifier for the driver/chipset pair. Use this value if you want to track changes to the driver or chipset to reprofile the graphics subsystem. It can also be used to identify particular problematic drivers. Deprecated.
DeviceId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the type of chipset. Can be 0 if unknown. Deprecated.
Driver
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.
DriverVersion
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Version of the driver. Deprecated.
Revision
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the revision level of the chipset. Can be 0 if unknown. Deprecated.
SubSystemId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the subsystem. Typically, this means the particular board. Can be 0 if unknown. Deprecated.
VendorId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the manufacturer. Can be 0 if unknown. Deprecated.
WhqlLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Windows Hardware Quality Lab (WHQL) certification level for the device/driver pair. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceIdentifier.DeviceIdentifier()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.DeviceIdentifier Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceIdentifier();
Managed C++ | public: DeviceIdentifier();
JScript .NET | public function DeviceIdentifier();


DeviceIdentifier.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceIdentifier.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Description As String
C# | public string Description { get; }
Managed C++ | public: __property String* get_Description();
JScript .NET | public function get Description() : String

Property Value

System.String .

This property is read-only.


DeviceIdentifier.DeviceGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.DeviceGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unique identifier for the driver/chipset pair. Use this value if you want to track changes to the driver or chipset to reprofile the graphics subsystem. It can also be used to identify particular problematic drivers. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceGuid As Guid
C# | public Guid DeviceGuid { get; }
Managed C++ | public: __property Guid get_DeviceGuid();
JScript .NET | public function get DeviceGuid() : Guid

Property Value

System.Guid .

This property is read-only.


DeviceIdentifier.DeviceId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.DeviceId Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the type of chipset. Can be 0 if unknown. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceId As Integer
C# | public int DeviceId { get; }
Managed C++ | public: __property int get_DeviceId();
JScript .NET | public function get DeviceId() : int

Property Value

System.Int32 .

This property is read-only.


DeviceIdentifier.Driver

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.Driver Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Driver As String
C# | public string Driver { get; }
Managed C++ | public: __property String* get_Driver();
JScript .NET | public function get Driver() : String

Property Value

System.String .

This property is read-only.


DeviceIdentifier.DriverVersion

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.DriverVersion Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Version of the driver. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DriverVersion As Long
C# | public long DriverVersion { get; }
Managed C++ | public: __property long get_DriverVersion();
JScript .NET | public function get DriverVersion() : long

Property Value

System.Int64 .

This property is read-only.


DeviceIdentifier.Revision

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.Revision Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the revision level of the chipset. Can be 0 if unknown. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Revision As Integer
C# | public int Revision { get; }
Managed C++ | public: __property int get_Revision();
JScript .NET | public function get Revision() : int

Property Value

System.Int32 .

This property is read-only.


DeviceIdentifier.SubSystemId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.SubSystemId Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the subsystem. Typically, this means the particular board. Can be 0 if unknown. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SubSystemId As Integer
C# | public int SubSystemId { get; }
Managed C++ | public: __property int get_SubSystemId();
JScript .NET | public function get SubSystemId() : int

Property Value

System.Int32 .

This property is read-only.


DeviceIdentifier.VendorId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.VendorId Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the manufacturer. Can be 0 if unknown. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property VendorId As Integer
C# | public int VendorId { get; }
Managed C++ | public: __property int get_VendorId();
JScript .NET | public function get VendorId() : int

Property Value

System.Int32 .

This property is read-only.


DeviceIdentifier.WhqlLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceIdentifier.WhqlLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Windows Hardware Quality Lab (WHQL) certification level for the device/driver pair. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property WhqlLevel As Integer
C# | public int WhqlLevel { get; }
Managed C++ | public: __property int get_WhqlLevel();
JScript .NET | public function get WhqlLevel() : int

Property Value

System.Int32 .

This property is read-only.


DeviceInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.

Definition

Visual Basic .NET | Public Structure DeviceInformation
C# | public struct DeviceInformation
Managed C++ | public __value struct DeviceInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DeviceInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.
Driver
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceInformation.DeviceInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.DeviceInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceInformation();
Managed C++ | public: DeviceInformation();
JScript .NET | public function DeviceInformation();


DeviceInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceInformation.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Description As String
C# | public string Description { get; }
Managed C++ | public: __property String* get_Description();
JScript .NET | public function get Description() : String

Property Value

System.String .

This property is read-only.


DeviceInformation.Driver

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.Driver Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Driver As Guid
C# | public Guid Driver { get; }
Managed C++ | public: __property Guid get_Driver();
JScript .NET | public function get Driver() : Guid

Property Value

System.Guid .

This property is read-only.


DeviceInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String .

This property is read-only.


DrawEffects

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations (ROPs), effects, and override information. Deprecated.

Definition

Visual Basic .NET | Public Structure DrawEffects
C# | public struct DrawEffects
Managed C++ | public __value struct DrawEffects
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DrawEffects
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AlphaDestinationConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel destination. Deprecated.
AlphaDestinationConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the destination alpha constant. Deprecated.
AlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha constant used for edge blending. Deprecated.
AlphaEdgeBlendBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the constant for an alpha edge blend. Deprecated.
AlphaSourceConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel source. Deprecated.
AlphaSourceConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the source alpha constant. Deprecated.
DestinationColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.
DrawRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw raster operations. Deprecated.
EffectOperationArithmeticStretchy
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic stretching along the y-axis for this blit. Deprecated.
EffectOperationMirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its y-axis. This blit mirrors the surface from left to right. Deprecated.
EffectOperationMirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its x-axis. This blit mirrors the surface from top to bottom. Deprecated.
EffectOperationNoTearing
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Schedules this blit to avoid tearing. Deprecated.
EffectOperationRotate180
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 180 degrees clockwise during this blit. Deprecated.
EffectOperationRotate270
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 270 degrees clockwise during this blit. Deprecated.
EffectOperationRotate90
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 90 degrees clockwise during this blit. Deprecated.
FillColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color used to fill a surface. Deprecated.
FillDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Depth value for the z-buffer. Deprecated.
FillPixel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pixel value for RGBA or RGBZ fills. Applications that use RGBZ fills should use this member. Deprecated.
FXOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of FX operations. Deprecated.
RasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Win32 raster operations. Deprecated.
RotationAngle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotation angle for the blit. Deprecated.
SourceColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrawEffects.DrawEffects()

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.DrawEffects Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DrawEffects();
Managed C++ | public: DrawEffects();
JScript .NET | public function DrawEffects();


DrawEffects.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DrawEffects.AlphaDestinationConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.AlphaDestinationConstant Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel destination. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaDestinationConstant As Integer
C# | public int AlphaDestinationConstant { get; set; }
Managed C++ public: __property int get_AlphaDestinationConstant();
public: __property void set_AlphaDestinationConstant(int);
JScript .NET public function get AlphaDestinationConstant() : int
public function set AlphaDestinationConstant(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.AlphaDestinationConstantBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.AlphaDestinationConstantBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the destination alpha constant. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaDestinationConstantBitDepth As Integer
C# | public int AlphaDestinationConstantBitDepth { get; set; }
Managed C++ public: __property int get_AlphaDestinationConstantBitDepth();
public: __property void set_AlphaDestinationConstantBitDepth(int);
JScript .NET public function get AlphaDestinationConstantBitDepth() : int
public function set AlphaDestinationConstantBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.AlphaEdgeBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.AlphaEdgeBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha constant used for edge blending. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaEdgeBlend As Integer
C# | public int AlphaEdgeBlend { get; set; }
Managed C++ public: __property int get_AlphaEdgeBlend();
public: __property void set_AlphaEdgeBlend(int);
JScript .NET public function get AlphaEdgeBlend() : int
public function set AlphaEdgeBlend(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.AlphaEdgeBlendBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.AlphaEdgeBlendBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the constant for an alpha edge blend. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaEdgeBlendBitDepth As Integer
C# | public int AlphaEdgeBlendBitDepth { get; set; }
Managed C++ public: __property int get_AlphaEdgeBlendBitDepth();
public: __property void set_AlphaEdgeBlendBitDepth(int);
JScript .NET public function get AlphaEdgeBlendBitDepth() : int
public function set AlphaEdgeBlendBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.AlphaSourceConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.AlphaSourceConstant Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel source. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaSourceConstant As Integer
C# | public int AlphaSourceConstant { get; set; }
Managed C++ public: __property int get_AlphaSourceConstant();
public: __property void set_AlphaSourceConstant(int);
JScript .NET public function get AlphaSourceConstant() : int
public function set AlphaSourceConstant(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.AlphaSourceConstantBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.AlphaSourceConstantBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the source alpha constant. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaSourceConstantBitDepth As Integer
C# | public int AlphaSourceConstantBitDepth { get; set; }
Managed C++ public: __property int get_AlphaSourceConstantBitDepth();
public: __property void set_AlphaSourceConstantBitDepth(int);
JScript .NET public function get AlphaSourceConstantBitDepth() : int
public function set AlphaSourceConstantBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.DestinationColorKey

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.DestinationColorKey Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.

Definition

Visual Basic .NET | Public Property DestinationColorKey As ColorKey
C# | public ColorKey DestinationColorKey { get; set; }
Managed C++ public: __property ColorKey get_DestinationColorKey();
public: __property void set_DestinationColorKey(ColorKey);
JScript .NET public function get DestinationColorKey() : ColorKey
public function set DestinationColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


DrawEffects.DrawRasterOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.DrawRasterOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw raster operations. Deprecated.

Definition

Visual Basic .NET | Public Property DrawRasterOperations As Integer
C# | public int DrawRasterOperations { get; set; }
Managed C++ public: __property int get_DrawRasterOperations();
public: __property void set_DrawRasterOperations(int);
JScript .NET public function get DrawRasterOperations() : int
public function set DrawRasterOperations(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.EffectOperationArithmeticStretchy

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.EffectOperationArithmeticStretchy Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic stretching along the y-axis for this blit. Deprecated.

Definition

Visual Basic .NET | Public Property EffectOperationArithmeticStretchy As Boolean
C# | public bool EffectOperationArithmeticStretchy { get; set; }
Managed C++ public: __property bool get_EffectOperationArithmeticStretchy();
public: __property void set_EffectOperationArithmeticStretchy(bool);
JScript .NET public function get EffectOperationArithmeticStretchy() : boolean
public function set EffectOperationArithmeticStretchy(boolean);

Property Value

System.Boolean .

This property is read/write.


DrawEffects.EffectOperationMirrorLeftRight

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.EffectOperationMirrorLeftRight Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its y-axis. This blit mirrors the surface from left to right. Deprecated.

Definition

Visual Basic .NET | Public Property EffectOperationMirrorLeftRight As Boolean
C# | public bool EffectOperationMirrorLeftRight { get; set; }
Managed C++ public: __property bool get_EffectOperationMirrorLeftRight();
public: __property void set_EffectOperationMirrorLeftRight(bool);
JScript .NET public function get EffectOperationMirrorLeftRight() : boolean
public function set EffectOperationMirrorLeftRight(boolean);

Property Value

System.Boolean .

This property is read/write.


DrawEffects.EffectOperationMirrorUpDown

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.EffectOperationMirrorUpDown Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its x-axis. This blit mirrors the surface from top to bottom. Deprecated.

Definition

Visual Basic .NET | Public Property EffectOperationMirrorUpDown As Boolean
C# | public bool EffectOperationMirrorUpDown { get; set; }
Managed C++ public: __property bool get_EffectOperationMirrorUpDown();
public: __property void set_EffectOperationMirrorUpDown(bool);
JScript .NET public function get EffectOperationMirrorUpDown() : boolean
public function set EffectOperationMirrorUpDown(boolean);

Property Value

System.Boolean .

This property is read/write.


DrawEffects.EffectOperationNoTearing

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.EffectOperationNoTearing Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Schedules this blit to avoid tearing. Deprecated.

Definition

Visual Basic .NET | Public Property EffectOperationNoTearing As Boolean
C# | public bool EffectOperationNoTearing { get; set; }
Managed C++ public: __property bool get_EffectOperationNoTearing();
public: __property void set_EffectOperationNoTearing(bool);
JScript .NET public function get EffectOperationNoTearing() : boolean
public function set EffectOperationNoTearing(boolean);

Property Value

System.Boolean .

This property is read/write.


DrawEffects.EffectOperationRotate180

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.EffectOperationRotate180 Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 180 degrees clockwise during this blit. Deprecated.

Definition

Visual Basic .NET | Public Property EffectOperationRotate180 As Boolean
C# | public bool EffectOperationRotate180 { get; set; }
Managed C++ public: __property bool get_EffectOperationRotate180();
public: __property void set_EffectOperationRotate180(bool);
JScript .NET public function get EffectOperationRotate180() : boolean
public function set EffectOperationRotate180(boolean);

Property Value

System.Boolean .

This property is read/write.


DrawEffects.EffectOperationRotate270

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.EffectOperationRotate270 Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 270 degrees clockwise during this blit. Deprecated.

Definition

Visual Basic .NET | Public Property EffectOperationRotate270 As Boolean
C# | public bool EffectOperationRotate270 { get; set; }
Managed C++ public: __property bool get_EffectOperationRotate270();
public: __property void set_EffectOperationRotate270(bool);
JScript .NET public function get EffectOperationRotate270() : boolean
public function set EffectOperationRotate270(boolean);

Property Value

System.Boolean .

This property is read/write.


DrawEffects.EffectOperationRotate90

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.EffectOperationRotate90 Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 90 degrees clockwise during this blit. Deprecated.

Definition

Visual Basic .NET | Public Property EffectOperationRotate90 As Boolean
C# | public bool EffectOperationRotate90 { get; set; }
Managed C++ public: __property bool get_EffectOperationRotate90();
public: __property void set_EffectOperationRotate90(bool);
JScript .NET public function get EffectOperationRotate90() : boolean
public function set EffectOperationRotate90(boolean);

Property Value

System.Boolean .

This property is read/write.


DrawEffects.FillColor

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.FillColor Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color used to fill a surface. Deprecated.

Definition

Visual Basic .NET | Public Property FillColor As Integer
C# | public int FillColor { get; set; }
Managed C++ public: __property int get_FillColor();
public: __property void set_FillColor(int);
JScript .NET public function get FillColor() : int
public function set FillColor(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.FillDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.FillDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Depth value for the z-buffer. Deprecated.

Definition

Visual Basic .NET | Public Property FillDepth As Integer
C# | public int FillDepth { get; set; }
Managed C++ public: __property int get_FillDepth();
public: __property void set_FillDepth(int);
JScript .NET public function get FillDepth() : int
public function set FillDepth(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.FillPixel

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.FillPixel Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pixel value for RGBA or RGBZ fills. Applications that use RGBZ fills should use this member. Deprecated.

Definition

Visual Basic .NET | Public Property FillPixel As Integer
C# | public int FillPixel { get; set; }
Managed C++ public: __property int get_FillPixel();
public: __property void set_FillPixel(int);
JScript .NET public function get FillPixel() : int
public function set FillPixel(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.FXOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.FXOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of FX operations. Deprecated.

Definition

Visual Basic .NET | Public Property FXOperations As Integer
C# | public int FXOperations { get; set; }
Managed C++ public: __property int get_FXOperations();
public: __property void set_FXOperations(int);
JScript .NET public function get FXOperations() : int
public function set FXOperations(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.RasterOperations

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.RasterOperations Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Win32 raster operations. Deprecated.

Definition

Visual Basic .NET | Public Property RasterOperations As Integer
C# | public int RasterOperations { get; set; }
Managed C++ public: __property int get_RasterOperations();
public: __property void set_RasterOperations(int);
JScript .NET public function get RasterOperations() : int
public function set RasterOperations(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.RotationAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.RotationAngle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotation angle for the blit. Deprecated.

Definition

Visual Basic .NET | Public Property RotationAngle As Integer
C# | public int RotationAngle { get; set; }
Managed C++ public: __property int get_RotationAngle();
public: __property void set_RotationAngle(int);
JScript .NET public function get RotationAngle() : int
public function set RotationAngle(int);

Property Value

System.Int32 .

This property is read/write.


DrawEffects.SourceColorKey

Microsoft DirectX 9.0 SDK Update (October 2004)

DrawEffects.SourceColorKey Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Definition

Visual Basic .NET | Public Property SourceColorKey As ColorKey
C# | public ColorKey SourceColorKey { get; set; }
Managed C++ public: __property ColorKey get_SourceColorKey();
public: __property void set_SourceColorKey(ColorKey);
JScript .NET public function get SourceColorKey() : ColorKey
public function set SourceColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


FXAlphaCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific alpha capabilities Deprecated.

Definition

Visual Basic .NET | Public Structure FXAlphaCaps
C# | public struct FXAlphaCaps
Managed C++ | public __value struct FXAlphaCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
DrawAlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for draw operations. Deprecated.
DrawAlphaPixels
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.
DrawAlphaPixelsNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha is set. Used for draw operations. Deprecated.
DrawAlphaSurfaces
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.
DrawAlphaSurfacesNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha channel-data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be set only if Alpha has been set. Used for blit operations. Deprecated.
OverlayAlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for overlays. Deprecated.
OverlayAlphaPixels
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.
OverlayAlphaPixelsNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.
OverlayAlphaSurfaces
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.
OverlayAlphaSurfacesNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha-channel data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FXAlphaCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FXAlphaCaps.DrawAlphaEdgeBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.DrawAlphaEdgeBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for draw operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawAlphaEdgeBlend As Boolean
C# | public bool DrawAlphaEdgeBlend { get; }
Managed C++ | public: __property bool get_DrawAlphaEdgeBlend();
JScript .NET | public function get DrawAlphaEdgeBlend() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.DrawAlphaPixels

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.DrawAlphaPixels Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawAlphaPixels As Boolean
C# | public bool DrawAlphaPixels { get; }
Managed C++ | public: __property bool get_DrawAlphaPixels();
JScript .NET | public function get DrawAlphaPixels() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.DrawAlphaPixelsNegative

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.DrawAlphaPixelsNegative Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha is set. Used for draw operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawAlphaPixelsNegative As Boolean
C# | public bool DrawAlphaPixelsNegative { get; }
Managed C++ | public: __property bool get_DrawAlphaPixelsNegative();
JScript .NET | public function get DrawAlphaPixelsNegative() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.DrawAlphaSurfaces

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.DrawAlphaSurfaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawAlphaSurfaces As Boolean
C# | public bool DrawAlphaSurfaces { get; }
Managed C++ | public: __property bool get_DrawAlphaSurfaces();
JScript .NET | public function get DrawAlphaSurfaces() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.DrawAlphaSurfacesNegative

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.DrawAlphaSurfacesNegative Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha channel-data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be set only if Alpha has been set. Used for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawAlphaSurfacesNegative As Boolean
C# | public bool DrawAlphaSurfacesNegative { get; }
Managed C++ | public: __property bool get_DrawAlphaSurfacesNegative();
JScript .NET | public function get DrawAlphaSurfacesNegative() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.OverlayAlphaEdgeBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.OverlayAlphaEdgeBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for overlays. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayAlphaEdgeBlend As Boolean
C# | public bool OverlayAlphaEdgeBlend { get; }
Managed C++ | public: __property bool get_OverlayAlphaEdgeBlend();
JScript .NET | public function get OverlayAlphaEdgeBlend() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.OverlayAlphaPixels

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.OverlayAlphaPixels Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayAlphaPixels As Boolean
C# | public bool OverlayAlphaPixels { get; }
Managed C++ | public: __property bool get_OverlayAlphaPixels();
JScript .NET | public function get OverlayAlphaPixels() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.OverlayAlphaPixelsNegative

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.OverlayAlphaPixelsNegative Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayAlphaPixelsNegative As Boolean
C# | public bool OverlayAlphaPixelsNegative { get; }
Managed C++ | public: __property bool get_OverlayAlphaPixelsNegative();
JScript .NET | public function get OverlayAlphaPixelsNegative() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.OverlayAlphaSurfaces

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.OverlayAlphaSurfaces Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayAlphaSurfaces As Boolean
C# | public bool OverlayAlphaSurfaces { get; }
Managed C++ | public: __property bool get_OverlayAlphaSurfaces();
JScript .NET | public function get OverlayAlphaSurfaces() : boolean

Property Value

System.Boolean .

This property is read-only.


FXAlphaCaps.OverlayAlphaSurfacesNegative

Microsoft DirectX 9.0 SDK Update (October 2004)

FXAlphaCaps.OverlayAlphaSurfacesNegative Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha-channel data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayAlphaSurfacesNegative As Boolean
C# | public bool OverlayAlphaSurfacesNegative { get; }
Managed C++ | public: __property bool get_OverlayAlphaSurfacesNegative();
JScript .NET | public function get OverlayAlphaSurfacesNegative() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.

Definition

Visual Basic .NET | Public Structure FXCaps
C# | public struct FXCaps
Managed C++ | public __value struct FXCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
DrawAlpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-blended blit operations. Deprecated.
DrawArithmeticStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically). Deprecated.
DrawArithmeticStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.
DrawFilter
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver can do surface-reconstruction filtering for warped blits. Deprecated.
DrawMirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring left to right in a blit operation. Deprecated.
DrawMirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring top to bottom in a blit operation. Deprecated.
DrawRotation
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary rotation in a blit operation. Deprecated.
DrawRotation90Degrees
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports 90-degree rotations in a blit operation. Deprecated.
DrawShrinkX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawShrinkXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawShrinkY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
DrawShrinkYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
DrawStretchX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawStretchXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
DrawStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
OverlayAlpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports geometric transformations (or warps) for blitted sprites. Transformations are not currently supported for explicit blit operations. Deprecated.
OverlayArithmeticStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically). Deprecated.
OverlayArithmeticStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.
OverlayFilter
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports surface-reconstruction filtering for warped overlay sprites. Deprecated.
OverlayMirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the vertical axis. Deprecated.
OverlayMirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the horizontal axis. Deprecated.
OverlayShrinkX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayShrinkXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayShrinkY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayShrinkYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayStretchX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.
OverlayStretchXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available Deprecated.
OverlayStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FXCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FXCaps.DrawAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-blended blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawAlpha As Boolean
C# | public bool DrawAlpha { get; }
Managed C++ | public: __property bool get_DrawAlpha();
JScript .NET | public function get DrawAlpha() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawArithmeticStretchY

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawArithmeticStretchY Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically). Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawArithmeticStretchY As Boolean
C# | public bool DrawArithmeticStretchY { get; }
Managed C++ | public: __property bool get_DrawArithmeticStretchY();
JScript .NET | public function get DrawArithmeticStretchY() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawArithmeticStretchYn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawArithmeticStretchYn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawArithmeticStretchYn As Boolean
C# | public bool DrawArithmeticStretchYn { get; }
Managed C++ | public: __property bool get_DrawArithmeticStretchYn();
JScript .NET | public function get DrawArithmeticStretchYn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawFilter

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawFilter Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver can do surface-reconstruction filtering for warped blits. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawFilter As Boolean
C# | public bool DrawFilter { get; }
Managed C++ | public: __property bool get_DrawFilter();
JScript .NET | public function get DrawFilter() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawMirrorLeftRight

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawMirrorLeftRight Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring left to right in a blit operation. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawMirrorLeftRight As Boolean
C# | public bool DrawMirrorLeftRight { get; }
Managed C++ | public: __property bool get_DrawMirrorLeftRight();
JScript .NET | public function get DrawMirrorLeftRight() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawMirrorUpDown

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawMirrorUpDown Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring top to bottom in a blit operation. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawMirrorUpDown As Boolean
C# | public bool DrawMirrorUpDown { get; }
Managed C++ | public: __property bool get_DrawMirrorUpDown();
JScript .NET | public function get DrawMirrorUpDown() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawRotation

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawRotation Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary rotation in a blit operation. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawRotation As Boolean
C# | public bool DrawRotation { get; }
Managed C++ | public: __property bool get_DrawRotation();
JScript .NET | public function get DrawRotation() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawRotation90Degrees

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawRotation90Degrees Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports 90-degree rotations in a blit operation. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawRotation90Degrees As Boolean
C# | public bool DrawRotation90Degrees { get; }
Managed C++ | public: __property bool get_DrawRotation90Degrees();
JScript .NET | public function get DrawRotation90Degrees() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawShrinkX

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawShrinkX Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawShrinkX As Boolean
C# | public bool DrawShrinkX { get; }
Managed C++ | public: __property bool get_DrawShrinkX();
JScript .NET | public function get DrawShrinkX() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawShrinkXn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawShrinkXn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawShrinkXn As Boolean
C# | public bool DrawShrinkXn { get; }
Managed C++ | public: __property bool get_DrawShrinkXn();
JScript .NET | public function get DrawShrinkXn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawShrinkY

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawShrinkY Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawShrinkY As Boolean
C# | public bool DrawShrinkY { get; }
Managed C++ | public: __property bool get_DrawShrinkY();
JScript .NET | public function get DrawShrinkY() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawShrinkYn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawShrinkYn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawShrinkYn As Boolean
C# | public bool DrawShrinkYn { get; }
Managed C++ | public: __property bool get_DrawShrinkYn();
JScript .NET | public function get DrawShrinkYn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawStretchX

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawStretchX Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawStretchX As Boolean
C# | public bool DrawStretchX { get; }
Managed C++ | public: __property bool get_DrawStretchX();
JScript .NET | public function get DrawStretchX() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawStretchXn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawStretchXn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawStretchXn As Boolean
C# | public bool DrawStretchXn { get; }
Managed C++ | public: __property bool get_DrawStretchXn();
JScript .NET | public function get DrawStretchXn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawStretchY

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawStretchY Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawStretchY As Boolean
C# | public bool DrawStretchY { get; }
Managed C++ | public: __property bool get_DrawStretchY();
JScript .NET | public function get DrawStretchY() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.DrawStretchYn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.DrawStretchYn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DrawStretchYn As Boolean
C# | public bool DrawStretchYn { get; }
Managed C++ | public: __property bool get_DrawStretchYn();
JScript .NET | public function get DrawStretchYn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayAlpha

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayAlpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports geometric transformations (or warps) for blitted sprites. Transformations are not currently supported for explicit blit operations. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayAlpha As Boolean
C# | public bool OverlayAlpha { get; }
Managed C++ | public: __property bool get_OverlayAlpha();
JScript .NET | public function get OverlayAlpha() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayArithmeticStretchY

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayArithmeticStretchY Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically). Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayArithmeticStretchY As Boolean
C# | public bool OverlayArithmeticStretchY { get; }
Managed C++ | public: __property bool get_OverlayArithmeticStretchY();
JScript .NET | public function get OverlayArithmeticStretchY() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayArithmeticStretchYn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayArithmeticStretchYn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayArithmeticStretchYn As Boolean
C# | public bool OverlayArithmeticStretchYn { get; }
Managed C++ | public: __property bool get_OverlayArithmeticStretchYn();
JScript .NET | public function get OverlayArithmeticStretchYn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayFilter

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayFilter Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports surface-reconstruction filtering for warped overlay sprites. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayFilter As Boolean
C# | public bool OverlayFilter { get; }
Managed C++ | public: __property bool get_OverlayFilter();
JScript .NET | public function get OverlayFilter() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayMirrorLeftRight

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayMirrorLeftRight Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the vertical axis. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayMirrorLeftRight As Boolean
C# | public bool OverlayMirrorLeftRight { get; }
Managed C++ | public: __property bool get_OverlayMirrorLeftRight();
JScript .NET | public function get OverlayMirrorLeftRight() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayMirrorUpDown

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayMirrorUpDown Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the horizontal axis. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayMirrorUpDown As Boolean
C# | public bool OverlayMirrorUpDown { get; }
Managed C++ | public: __property bool get_OverlayMirrorUpDown();
JScript .NET | public function get OverlayMirrorUpDown() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayShrinkX

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayShrinkX Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayShrinkX As Boolean
C# | public bool OverlayShrinkX { get; }
Managed C++ | public: __property bool get_OverlayShrinkX();
JScript .NET | public function get OverlayShrinkX() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayShrinkXn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayShrinkXn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayShrinkXn As Boolean
C# | public bool OverlayShrinkXn { get; }
Managed C++ | public: __property bool get_OverlayShrinkXn();
JScript .NET | public function get OverlayShrinkXn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayShrinkY

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayShrinkY Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayShrinkY As Boolean
C# | public bool OverlayShrinkY { get; }
Managed C++ | public: __property bool get_OverlayShrinkY();
JScript .NET | public function get OverlayShrinkY() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayShrinkYn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayShrinkYn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayShrinkYn As Boolean
C# | public bool OverlayShrinkYn { get; }
Managed C++ | public: __property bool get_OverlayShrinkYn();
JScript .NET | public function get OverlayShrinkYn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayStretchX

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayStretchX Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayStretchX As Boolean
C# | public bool OverlayStretchX { get; }
Managed C++ | public: __property bool get_OverlayStretchX();
JScript .NET | public function get OverlayStretchX() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayStretchXn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayStretchXn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayStretchXn As Boolean
C# | public bool OverlayStretchXn { get; }
Managed C++ | public: __property bool get_OverlayStretchXn();
JScript .NET | public function get OverlayStretchXn() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayStretchY

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayStretchY Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayStretchY As Boolean
C# | public bool OverlayStretchY { get; }
Managed C++ | public: __property bool get_OverlayStretchY();
JScript .NET | public function get OverlayStretchY() : boolean

Property Value

System.Boolean .

This property is read-only.


FXCaps.OverlayStretchYn

Microsoft DirectX 9.0 SDK Update (October 2004)

FXCaps.OverlayStretchYn Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OverlayStretchYn As Boolean
C# | public bool OverlayStretchYn { get; }
Managed C++ | public: __property bool get_OverlayStretchYn();
JScript .NET | public function get OverlayStretchYn() : boolean

Property Value

System.Boolean .

This property is read-only.


GammaRamps

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.

Definition

Visual Basic .NET | Public Structure GammaRamps
C# | public struct GammaRamps
Managed C++ | public __value struct GammaRamps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GammaRamps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetBlue
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the blue gamma ramps. Deprecated.
GetGreen
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the green gamma ramps. Deprecated.
GetRed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the red gamma ramps. Deprecated.
SetBlue
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the blue gamma ramps. Deprecated.
SetGreen
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the green gamma ramps. Deprecated.
SetRed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the red gamma ramps. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GammaRamps.GammaRamps()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps.GammaRamps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public GammaRamps();
Managed C++ | public: GammaRamps();
JScript .NET | public function GammaRamps();


GammaRamps.GetBlue()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps.GetBlue Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the blue gamma ramps. Deprecated.

Definition

Visual Basic .NET | Public Function GetBlue() As Short()
C# | public short[] GetBlue();
Managed C++ | public: short GetBlue() __gc[];
JScript .NET | public function GetBlue() : short[];

Return Value

System.Int16[].


GammaRamps.GetGreen()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps.GetGreen Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the green gamma ramps. Deprecated.

Definition

Visual Basic .NET | Public Function GetGreen() As Short()
C# | public short[] GetGreen();
Managed C++ | public: short GetGreen() __gc[];
JScript .NET | public function GetGreen() : short[];

Return Value

System.Int16[].


GammaRamps.GetRed()

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps.GetRed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the red gamma ramps. Deprecated.

Definition

Visual Basic .NET | Public Function GetRed() As Short()
C# | public short[] GetRed();
Managed C++ | public: short GetRed() __gc[];
JScript .NET | public function GetRed() : short[];

Return Value

System.Int16[].


GammaRamps.SetBlue(Int16[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps.SetBlue Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the blue gamma ramps. Deprecated.

Definition

Visual Basic .NET Public Sub SetBlue( _
ByVal value() As Short _
)
C# public void SetBlue(
short[] value
);
Managed C++ public: void SetBlue(
short value __gc[]
);
JScript .NET public function SetBlue(
value : short[]
);

Parameters

value System.Int16[].


GammaRamps.SetGreen(Int16[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps.SetGreen Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the green gamma ramps. Deprecated.

Definition

Visual Basic .NET Public Sub SetGreen( _
ByVal value() As Short _
)
C# public void SetGreen(
short[] value
);
Managed C++ public: void SetGreen(
short value __gc[]
);
JScript .NET public function SetGreen(
value : short[]
);

Parameters

value System.Int16[].


GammaRamps.SetRed(Int16[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GammaRamps.SetRed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the red gamma ramps. Deprecated.

Definition

Visual Basic .NET Public Sub SetRed( _
ByVal value() As Short _
)
C# public void SetRed(
short[] value
);
Managed C++ public: void SetRed(
short value __gc[]
);
JScript .NET public function SetRed(
value : short[]
);

Parameters

value System.Int16[].


GetCapsStruct

Microsoft DirectX 9.0 SDK Update (October 2004)

GetCapsStruct Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware and Hardware Emulation Layer (HEL) capabilities Deprecated.

Definition

Visual Basic .NET | Public Structure GetCapsStruct
C# | public struct GetCapsStruct
Managed C++ | public __value struct GetCapsStruct
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetCapsStruct
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
HardwareCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware capabilities Deprecated.
HardwareEmulationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware emulation layer (HEL) capabilities Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GetCapsStruct.GetCapsStruct()

Microsoft DirectX 9.0 SDK Update (October 2004)

GetCapsStruct.GetCapsStruct Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public GetCapsStruct();
Managed C++ | public: GetCapsStruct();
JScript .NET | public function GetCapsStruct();


GetCapsStruct.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

GetCapsStruct.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


GetCapsStruct.HardwareCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

GetCapsStruct.HardwareCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware capabilities Deprecated.

Definition

Visual Basic .NET | Public Property HardwareCaps As Caps
C# | public Caps HardwareCaps { get; set; }
Managed C++ public: __property Caps get_HardwareCaps();
public: __property void set_HardwareCaps(Caps);
JScript .NET public function get HardwareCaps() : Caps
public function set HardwareCaps(Caps);

Property Value

Microsoft.DirectX.DirectDraw.Caps .

This property is read/write.


GetCapsStruct.HardwareEmulationCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

GetCapsStruct.HardwareEmulationCaps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware emulation layer (HEL) capabilities Deprecated.

Definition

Visual Basic .NET | Public Property HardwareEmulationCaps As Caps
C# | public Caps HardwareEmulationCaps { get; set; }
Managed C++ public: __property Caps get_HardwareEmulationCaps();
public: __property void set_HardwareEmulationCaps(Caps);
JScript .NET public function get HardwareEmulationCaps() : Caps
public function set HardwareEmulationCaps(Caps);

Property Value

Microsoft.DirectX.DirectDraw.Caps .

This property is read/write.


LockedData

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Structure LockedData
C# | public struct LockedData
Managed C++ | public __value struct LockedData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
LockedData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
Data
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Height
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Pitch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RGBBitCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Width
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LockedData.LockedData()

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedData.LockedData Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public LockedData();
Managed C++ | public: LockedData();
JScript .NET | public function LockedData();


LockedData.Data

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedData.Data Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Property Data As GraphicsStream
C# | public GraphicsStream Data { get; set; }
Managed C++ public: __property GraphicsStream* get_Data();
public: __property void set_Data(GraphicsStream*);
JScript .NET public function get Data() : GraphicsStream
public function set Data(GraphicsStream);

Property Value

Microsoft.DirectX.GraphicsStream .

This property is read/write.


LockedData.Height

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedData.Height Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Property Height As Integer
C# | public int Height { get; set; }
Managed C++ public: __property int get_Height();
public: __property void set_Height(int);
JScript .NET public function get Height() : int
public function set Height(int);

Property Value

System.Int32 .

This property is read/write.


LockedData.Pitch

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedData.Pitch Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Property Pitch As Integer
C# | public int Pitch { get; set; }
Managed C++ public: __property int get_Pitch();
public: __property void set_Pitch(int);
JScript .NET public function get Pitch() : int
public function set Pitch(int);

Property Value

System.Int32 .

This property is read/write.


LockedData.RGBBitCount

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedData.RGBBitCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Property RGBBitCount As Integer
C# | public int RGBBitCount { get; set; }
Managed C++ public: __property int get_RGBBitCount();
public: __property void set_RGBBitCount(int);
JScript .NET public function get RGBBitCount() : int
public function set RGBBitCount(int);

Property Value

System.Int32 .

This property is read/write.


LockedData.Width

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedData.Width Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Property Width As Integer
C# | public int Width { get; set; }
Managed C++ public: __property int get_Width();
public: __property void set_Width(int);
JScript .NET public function get Width() : int
public function set Width(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Override information to the UpdateOverlay method. Deprecated.

Definition

Visual Basic .NET | Public Structure OverlayEffects
C# | public struct OverlayEffects
Managed C++ | public __value struct OverlayEffects
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
OverlayEffects
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AlphaDestinationConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a destination. Deprecated.
AlphaDestinationConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a destination. Deprecated.
AlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha for an edge blend. Deprecated.
AlphaEdgeBlendBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the constant for an alpha edge blend. Deprecated.
AlphaSourceConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a source. Deprecated.
AlphaSourceConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a source. Deprecated.
ArithmeticStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If stretching, use arithmetic stretching along the y-axis for this overlay. Deprecated.
DestinationColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.
Effects
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay FX flags. Deprecated.
MirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the vertical axis. Deprecated.
MirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the horizontal axis. Deprecated.
SourceColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OverlayEffects.OverlayEffects()

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.OverlayEffects Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OverlayEffects();
Managed C++ | public: OverlayEffects();
JScript .NET | public function OverlayEffects();


OverlayEffects.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


OverlayEffects.AlphaDestinationConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.AlphaDestinationConstant Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a destination. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaDestinationConstant As Integer
C# | public int AlphaDestinationConstant { get; set; }
Managed C++ public: __property int get_AlphaDestinationConstant();
public: __property void set_AlphaDestinationConstant(int);
JScript .NET public function get AlphaDestinationConstant() : int
public function set AlphaDestinationConstant(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects.AlphaDestinationConstantBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.AlphaDestinationConstantBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a destination. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaDestinationConstantBitDepth As Integer
C# | public int AlphaDestinationConstantBitDepth { get; set; }
Managed C++ public: __property int get_AlphaDestinationConstantBitDepth();
public: __property void set_AlphaDestinationConstantBitDepth(int);
JScript .NET public function get AlphaDestinationConstantBitDepth() : int
public function set AlphaDestinationConstantBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects.AlphaEdgeBlend

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.AlphaEdgeBlend Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha for an edge blend. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaEdgeBlend As Integer
C# | public int AlphaEdgeBlend { get; set; }
Managed C++ public: __property int get_AlphaEdgeBlend();
public: __property void set_AlphaEdgeBlend(int);
JScript .NET public function get AlphaEdgeBlend() : int
public function set AlphaEdgeBlend(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects.AlphaEdgeBlendBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.AlphaEdgeBlendBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the constant for an alpha edge blend. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaEdgeBlendBitDepth As Integer
C# | public int AlphaEdgeBlendBitDepth { get; set; }
Managed C++ public: __property int get_AlphaEdgeBlendBitDepth();
public: __property void set_AlphaEdgeBlendBitDepth(int);
JScript .NET public function get AlphaEdgeBlendBitDepth() : int
public function set AlphaEdgeBlendBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects.AlphaSourceConstant

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.AlphaSourceConstant Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a source. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaSourceConstant As Integer
C# | public int AlphaSourceConstant { get; set; }
Managed C++ public: __property int get_AlphaSourceConstant();
public: __property void set_AlphaSourceConstant(int);
JScript .NET public function get AlphaSourceConstant() : int
public function set AlphaSourceConstant(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects.AlphaSourceConstantBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.AlphaSourceConstantBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a source. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaSourceConstantBitDepth As Integer
C# | public int AlphaSourceConstantBitDepth { get; set; }
Managed C++ public: __property int get_AlphaSourceConstantBitDepth();
public: __property void set_AlphaSourceConstantBitDepth(int);
JScript .NET public function get AlphaSourceConstantBitDepth() : int
public function set AlphaSourceConstantBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects.ArithmeticStretchY

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.ArithmeticStretchY Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If stretching, use arithmetic stretching along the y-axis for this overlay. Deprecated.

Definition

Visual Basic .NET | Public Property ArithmeticStretchY As Boolean
C# | public bool ArithmeticStretchY { get; set; }
Managed C++ public: __property bool get_ArithmeticStretchY();
public: __property void set_ArithmeticStretchY(bool);
JScript .NET public function get ArithmeticStretchY() : boolean
public function set ArithmeticStretchY(boolean);

Property Value

System.Boolean .

This property is read/write.


OverlayEffects.DestinationColorKey

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.DestinationColorKey Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.

Definition

Visual Basic .NET | Public Property DestinationColorKey As ColorKey
C# | public ColorKey DestinationColorKey { get; set; }
Managed C++ public: __property ColorKey get_DestinationColorKey();
public: __property void set_DestinationColorKey(ColorKey);
JScript .NET public function get DestinationColorKey() : ColorKey
public function set DestinationColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


OverlayEffects.Effects

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.Effects Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay FX flags. Deprecated.

Definition

Visual Basic .NET | Public Property Effects As Integer
C# | public int Effects { get; set; }
Managed C++ public: __property int get_Effects();
public: __property void set_Effects(int);
JScript .NET public function get Effects() : int
public function set Effects(int);

Property Value

System.Int32 .

This property is read/write.


OverlayEffects.MirrorLeftRight

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.MirrorLeftRight Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the vertical axis. Deprecated.

Definition

Visual Basic .NET | Public Property MirrorLeftRight As Boolean
C# | public bool MirrorLeftRight { get; set; }
Managed C++ public: __property bool get_MirrorLeftRight();
public: __property void set_MirrorLeftRight(bool);
JScript .NET public function get MirrorLeftRight() : boolean
public function set MirrorLeftRight(boolean);

Property Value

System.Boolean .

This property is read/write.


OverlayEffects.MirrorUpDown

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.MirrorUpDown Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the horizontal axis. Deprecated.

Definition

Visual Basic .NET | Public Property MirrorUpDown As Boolean
C# | public bool MirrorUpDown { get; set; }
Managed C++ public: __property bool get_MirrorUpDown();
public: __property void set_MirrorUpDown(bool);
JScript .NET public function get MirrorUpDown() : boolean
public function set MirrorUpDown(boolean);

Property Value

System.Boolean .

This property is read/write.


OverlayEffects.SourceColorKey

Microsoft DirectX 9.0 SDK Update (October 2004)

OverlayEffects.SourceColorKey Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Definition

Visual Basic .NET | Public Property SourceColorKey As ColorKey
C# | public ColorKey SourceColorKey { get; set; }
Managed C++ public: __property ColorKey get_SourceColorKey();
public: __property void set_SourceColorKey(ColorKey);
JScript .NET public function get SourceColorKey() : ColorKey
public function set SourceColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey .

This property is read/write.


PaletteCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities Deprecated.

Definition

Visual Basic .NET | Public Structure PaletteCaps
C# | public struct PaletteCaps
Managed C++ | public __value struct PaletteCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Allow256
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that can have all 256 entries defined. Deprecated.
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that include an alpha component. Deprecated.
EightBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 8-bit color entries (256 colors). Deprecated.
EightBitEntries
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies an index to an 8-bit color index. Deprecated.
FourBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 4-bit color entries (16 colors). Deprecated.
OneBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 1-bit color entries (two colors). Deprecated.
PrimarySurface
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported. Deprecated.
PrimarySurfaceLeft
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface on the left. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported Deprecated.
TwoBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 2-bit color entries (four colors). Deprecated.
VerticalSync
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette can be modified synchronously with the monitor's refresh rate. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PaletteCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PaletteCaps.Allow256

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.Allow256 Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that can have all 256 entries defined. Deprecated.

Definition

Visual Basic .NET | Public Property Allow256 As Boolean
C# | public bool Allow256 { get; set; }
Managed C++ public: __property bool get_Allow256();
public: __property void set_Allow256(bool);
JScript .NET public function get Allow256() : boolean
public function set Allow256(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.Alpha

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.Alpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that include an alpha component. Deprecated.

Definition

Visual Basic .NET | Public Property Alpha As Boolean
C# | public bool Alpha { get; set; }
Managed C++ public: __property bool get_Alpha();
public: __property void set_Alpha(bool);
JScript .NET public function get Alpha() : boolean
public function set Alpha(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.EightBit

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.EightBit Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 8-bit color entries (256 colors). Deprecated.

Definition

Visual Basic .NET | Public Property EightBit As Boolean
C# | public bool EightBit { get; set; }
Managed C++ public: __property bool get_EightBit();
public: __property void set_EightBit(bool);
JScript .NET public function get EightBit() : boolean
public function set EightBit(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.EightBitEntries

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.EightBitEntries Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies an index to an 8-bit color index. Deprecated.

Definition

Visual Basic .NET | Public Property EightBitEntries As Boolean
C# | public bool EightBitEntries { get; set; }
Managed C++ public: __property bool get_EightBitEntries();
public: __property void set_EightBitEntries(bool);
JScript .NET public function get EightBitEntries() : boolean
public function set EightBitEntries(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.FourBit

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.FourBit Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 4-bit color entries (16 colors). Deprecated.

Definition

Visual Basic .NET | Public Property FourBit As Boolean
C# | public bool FourBit { get; set; }
Managed C++ public: __property bool get_FourBit();
public: __property void set_FourBit(bool);
JScript .NET public function get FourBit() : boolean
public function set FourBit(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.OneBit

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.OneBit Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 1-bit color entries (two colors). Deprecated.

Definition

Visual Basic .NET | Public Property OneBit As Boolean
C# | public bool OneBit { get; set; }
Managed C++ public: __property bool get_OneBit();
public: __property void set_OneBit(bool);
JScript .NET public function get OneBit() : boolean
public function set OneBit(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.PrimarySurface

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.PrimarySurface Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported. Deprecated.

Definition

Visual Basic .NET | Public Property PrimarySurface As Boolean
C# | public bool PrimarySurface { get; set; }
Managed C++ public: __property bool get_PrimarySurface();
public: __property void set_PrimarySurface(bool);
JScript .NET public function get PrimarySurface() : boolean
public function set PrimarySurface(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.PrimarySurfaceLeft

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.PrimarySurfaceLeft Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface on the left. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported Deprecated.

Definition

Visual Basic .NET | Public Property PrimarySurfaceLeft As Boolean
C# | public bool PrimarySurfaceLeft { get; set; }
Managed C++ public: __property bool get_PrimarySurfaceLeft();
public: __property void set_PrimarySurfaceLeft(bool);
JScript .NET public function get PrimarySurfaceLeft() : boolean
public function set PrimarySurfaceLeft(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.TwoBit

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.TwoBit Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 2-bit color entries (four colors). Deprecated.

Definition

Visual Basic .NET | Public Property TwoBit As Boolean
C# | public bool TwoBit { get; set; }
Managed C++ public: __property bool get_TwoBit();
public: __property void set_TwoBit(bool);
JScript .NET public function get TwoBit() : boolean
public function set TwoBit(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteCaps.VerticalSync

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteCaps.VerticalSync Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette can be modified synchronously with the monitor's refresh rate. Deprecated.

Definition

Visual Basic .NET | Public Property VerticalSync As Boolean
C# | public bool VerticalSync { get; set; }
Managed C++ public: __property bool get_VerticalSync();
public: __property void set_VerticalSync(bool);
JScript .NET public function get VerticalSync() : boolean
public function set VerticalSync(boolean);

Property Value

System.Boolean .

This property is read/write.


PaletteEntry

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the color and usage of an entry in a logical color palette. Deprecated.

Definition

Visual Basic .NET | Public Structure PaletteEntry
C# | public struct PaletteEntry
Managed C++ | public __value struct PaletteEntry
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PaletteEntry
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Blue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a blue intensity value for the palette entry. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the palette entry is to be used. Deprecated.
Green
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a green intensity value for the palette entry. Deprecated.
Red
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a red intensity value for the palette entry. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PaletteEntry.PaletteEntry()

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.PaletteEntry Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PaletteEntry();
Managed C++ | public: PaletteEntry();
JScript .NET | public function PaletteEntry();


PaletteEntry.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PaletteEntry.Blue

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Blue Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a blue intensity value for the palette entry. Deprecated.

Definition

Visual Basic .NET | Public Property Blue As Byte
C# | public byte Blue { get; set; }
Managed C++ public: __property Byte get_Blue();
public: __property void set_Blue(Byte);
JScript .NET public function get Blue() : byte
public function set Blue(byte);

Property Value

System.Byte .

This property is read/write.


PaletteEntry.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the palette entry is to be used. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As Byte
C# | public byte Flags { get; set; }
Managed C++ public: __property Byte get_Flags();
public: __property void set_Flags(Byte);
JScript .NET public function get Flags() : byte
public function set Flags(byte);

Property Value

System.Byte .

This property is read/write.


PaletteEntry.Green

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Green Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a green intensity value for the palette entry. Deprecated.

Definition

Visual Basic .NET | Public Property Green As Byte
C# | public byte Green { get; set; }
Managed C++ public: __property Byte get_Green();
public: __property void set_Green(Byte);
JScript .NET public function get Green() : byte
public function set Green(byte);

Property Value

System.Byte .

This property is read/write.


PaletteEntry.Red

Microsoft DirectX 9.0 SDK Update (October 2004)

PaletteEntry.Red Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a red intensity value for the palette entry. Deprecated.

Definition

Visual Basic .NET | Public Property Red As Byte
C# | public byte Red { get; set; }
Managed C++ public: __property Byte get_Red();
public: __property void set_Red(Byte);
JScript .NET public function get Red() : byte
public function set Red(byte);

Property Value

System.Byte .

This property is read/write.


PixelFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of a DirectDrawSurface. Deprecated.

Definition

Visual Basic .NET | Public Structure PixelFormat
C# | public struct PixelFormat
Managed C++ | public __value struct PixelFormat
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PixelFormat
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format describes an alpha-only surface. Deprecated.
AlphaBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha channel bit depth (1, 2, 4, or 8) for an alpha-only surface. Deprecated.
AlphaPixels
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface has alpha channel information in the pixel format. Deprecated.
AlphaPremultiplied
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface uses the premultiplied alpha format. That is, the color components in each pixel are premultiplied by the alpha component. Deprecated.
BBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for blue bits. Deprecated.
Compressed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts pixel data in the specified format and compress it during the write operation. Deprecated.
DrawMsTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample draws. Deprecated.
FlipMsTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample flips. Deprecated.
FourCC
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCC code. Deprecated.
FourCcIsValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The FourCC member is valid and contains a FOURCC code describing a non-RGB pixel format. Deprecated.
GBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for green bits. Deprecated.
PaletteIndexed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, 4-, or 8-bit color-indexed. Deprecated.
PaletteIndexedTo8
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, or 4-bit color-indexed to an 8-bit palette. Deprecated.
RBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for red bits. Deprecated.
Rgb
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The RGB data in the pixel format structure is valid. Deprecated.
RgbAlphaBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.
RgbBitCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
RGB bits per pixel (4, 8, 16, 24, or 32). Deprecated.
RgbToYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts RGB data and translates it during the write operation to YUV data. The format of the data to be written is contained in the pixel format structure. The Rgb flag is set. Deprecated.
YBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for Y bits. Deprecated.
Yuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The YUV data in the pixel format structure is valid. Deprecated.
YuvAlphaBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.
YuvBitCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
YUV bits per pixel (4, 8, 16, 24, or 32). Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PixelFormat.PixelFormat()

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.PixelFormat Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PixelFormat();
Managed C++ | public: PixelFormat();
JScript .NET | public function PixelFormat();


PixelFormat.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PixelFormat.Alpha

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.Alpha Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format describes an alpha-only surface. Deprecated.

Definition

Visual Basic .NET | Public Property Alpha As Boolean
C# | public bool Alpha { get; set; }
Managed C++ public: __property bool get_Alpha();
public: __property void set_Alpha(bool);
JScript .NET public function get Alpha() : boolean
public function set Alpha(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.AlphaBitDepth

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.AlphaBitDepth Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha channel bit depth (1, 2, 4, or 8) for an alpha-only surface. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaBitDepth As Integer
C# | public int AlphaBitDepth { get; set; }
Managed C++ public: __property int get_AlphaBitDepth();
public: __property void set_AlphaBitDepth(int);
JScript .NET public function get AlphaBitDepth() : int
public function set AlphaBitDepth(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.AlphaPixels

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.AlphaPixels Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface has alpha channel information in the pixel format. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaPixels As Boolean
C# | public bool AlphaPixels { get; set; }
Managed C++ public: __property bool get_AlphaPixels();
public: __property void set_AlphaPixels(bool);
JScript .NET public function get AlphaPixels() : boolean
public function set AlphaPixels(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.AlphaPremultiplied

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.AlphaPremultiplied Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface uses the premultiplied alpha format. That is, the color components in each pixel are premultiplied by the alpha component. Deprecated.

Definition

Visual Basic .NET | Public Property AlphaPremultiplied As Boolean
C# | public bool AlphaPremultiplied { get; set; }
Managed C++ public: __property bool get_AlphaPremultiplied();
public: __property void set_AlphaPremultiplied(bool);
JScript .NET public function get AlphaPremultiplied() : boolean
public function set AlphaPremultiplied(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.BBitMask

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.BBitMask Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for blue bits. Deprecated.

Definition

Visual Basic .NET | Public Property BBitMask As Integer
C# | public int BBitMask { get; set; }
Managed C++ public: __property int get_BBitMask();
public: __property void set_BBitMask(int);
JScript .NET public function get BBitMask() : int
public function set BBitMask(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.Compressed

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.Compressed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts pixel data in the specified format and compress it during the write operation. Deprecated.

Definition

Visual Basic .NET | Public Property Compressed As Boolean
C# | public bool Compressed { get; set; }
Managed C++ public: __property bool get_Compressed();
public: __property void set_Compressed(bool);
JScript .NET public function get Compressed() : boolean
public function set Compressed(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.DrawMsTypes

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.DrawMsTypes Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample draws. Deprecated.

Definition

Visual Basic .NET | Public Property DrawMsTypes As Short
C# | public short DrawMsTypes { get; set; }
Managed C++ public: __property short get_DrawMsTypes();
public: __property void set_DrawMsTypes(short);
JScript .NET public function get DrawMsTypes() : short
public function set DrawMsTypes(short);

Property Value

System.Int16 .

This property is read/write.


PixelFormat.FlipMsTypes

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.FlipMsTypes Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample flips. Deprecated.

Definition

Visual Basic .NET | Public Property FlipMsTypes As Short
C# | public short FlipMsTypes { get; set; }
Managed C++ public: __property short get_FlipMsTypes();
public: __property void set_FlipMsTypes(short);
JScript .NET public function get FlipMsTypes() : short
public function set FlipMsTypes(short);

Property Value

System.Int16 .

This property is read/write.


PixelFormat.FourCC

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.FourCC Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCC code. Deprecated.

Definition

Visual Basic .NET | Public Property FourCC As Integer
C# | public int FourCC { get; set; }
Managed C++ public: __property int get_FourCC();
public: __property void set_FourCC(int);
JScript .NET public function get FourCC() : int
public function set FourCC(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.FourCcIsValid

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.FourCcIsValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The FourCC member is valid and contains a FOURCC code describing a non-RGB pixel format. Deprecated.

Definition

Visual Basic .NET | Public Property FourCcIsValid As Boolean
C# | public bool FourCcIsValid { get; set; }
Managed C++ public: __property bool get_FourCcIsValid();
public: __property void set_FourCcIsValid(bool);
JScript .NET public function get FourCcIsValid() : boolean
public function set FourCcIsValid(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.GBitMask

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.GBitMask Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for green bits. Deprecated.

Definition

Visual Basic .NET | Public Property GBitMask As Integer
C# | public int GBitMask { get; set; }
Managed C++ public: __property int get_GBitMask();
public: __property void set_GBitMask(int);
JScript .NET public function get GBitMask() : int
public function set GBitMask(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.PaletteIndexed

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.PaletteIndexed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, 4-, or 8-bit color-indexed. Deprecated.

Definition

Visual Basic .NET | Public Property PaletteIndexed As Integer
C# | public int PaletteIndexed { get; set; }
Managed C++ public: __property int get_PaletteIndexed();
public: __property void set_PaletteIndexed(int);
JScript .NET public function get PaletteIndexed() : int
public function set PaletteIndexed(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.PaletteIndexedTo8

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.PaletteIndexedTo8 Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, or 4-bit color-indexed to an 8-bit palette. Deprecated.

Definition

Visual Basic .NET | Public Property PaletteIndexedTo8 As Boolean
C# | public bool PaletteIndexedTo8 { get; set; }
Managed C++ public: __property bool get_PaletteIndexedTo8();
public: __property void set_PaletteIndexedTo8(bool);
JScript .NET public function get PaletteIndexedTo8() : boolean
public function set PaletteIndexedTo8(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.RBitMask

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.RBitMask Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for red bits. Deprecated.

Definition

Visual Basic .NET | Public Property RBitMask As Integer
C# | public int RBitMask { get; set; }
Managed C++ public: __property int get_RBitMask();
public: __property void set_RBitMask(int);
JScript .NET public function get RBitMask() : int
public function set RBitMask(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.Rgb

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.Rgb Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The RGB data in the pixel format structure is valid. Deprecated.

Definition

Visual Basic .NET | Public Property Rgb As Boolean
C# | public bool Rgb { get; set; }
Managed C++ public: __property bool get_Rgb();
public: __property void set_Rgb(bool);
JScript .NET public function get Rgb() : boolean
public function set Rgb(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.RgbAlphaBitMask

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.RgbAlphaBitMask Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.

Definition

Visual Basic .NET | Public Property RgbAlphaBitMask As Integer
C# | public int RgbAlphaBitMask { get; set; }
Managed C++ public: __property int get_RgbAlphaBitMask();
public: __property void set_RgbAlphaBitMask(int);
JScript .NET public function get RgbAlphaBitMask() : int
public function set RgbAlphaBitMask(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.RgbBitCount

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.RgbBitCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
RGB bits per pixel (4, 8, 16, 24, or 32). Deprecated.

Definition

Visual Basic .NET | Public Property RgbBitCount As Integer
C# | public int RgbBitCount { get; set; }
Managed C++ public: __property int get_RgbBitCount();
public: __property void set_RgbBitCount(int);
JScript .NET public function get RgbBitCount() : int
public function set RgbBitCount(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.RgbToYuv

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.RgbToYuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts RGB data and translates it during the write operation to YUV data. The format of the data to be written is contained in the pixel format structure. The Rgb flag is set. Deprecated.

Definition

Visual Basic .NET | Public Property RgbToYuv As Boolean
C# | public bool RgbToYuv { get; set; }
Managed C++ public: __property bool get_RgbToYuv();
public: __property void set_RgbToYuv(bool);
JScript .NET public function get RgbToYuv() : boolean
public function set RgbToYuv(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.YBitMask

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.YBitMask Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for Y bits. Deprecated.

Definition

Visual Basic .NET | Public Property YBitMask As Integer
C# | public int YBitMask { get; set; }
Managed C++ public: __property int get_YBitMask();
public: __property void set_YBitMask(int);
JScript .NET public function get YBitMask() : int
public function set YBitMask(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.Yuv

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.Yuv Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The YUV data in the pixel format structure is valid. Deprecated.

Definition

Visual Basic .NET | Public Property Yuv As Boolean
C# | public bool Yuv { get; set; }
Managed C++ public: __property bool get_Yuv();
public: __property void set_Yuv(bool);
JScript .NET public function get Yuv() : boolean
public function set Yuv(boolean);

Property Value

System.Boolean .

This property is read/write.


PixelFormat.YuvAlphaBitMask

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.YuvAlphaBitMask Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.

Definition

Visual Basic .NET | Public Property YuvAlphaBitMask As Integer
C# | public int YuvAlphaBitMask { get; set; }
Managed C++ public: __property int get_YuvAlphaBitMask();
public: __property void set_YuvAlphaBitMask(int);
JScript .NET public function get YuvAlphaBitMask() : int
public function set YuvAlphaBitMask(int);

Property Value

System.Int32 .

This property is read/write.


PixelFormat.YuvBitCount

Microsoft DirectX 9.0 SDK Update (October 2004)

PixelFormat.YuvBitCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
YUV bits per pixel (4, 8, 16, 24, or 32). Deprecated.

Definition

Visual Basic .NET | Public Property YuvBitCount As Integer
C# | public int YuvBitCount { get; set; }
Managed C++ public: __property int get_YuvBitCount();
public: __property void set_YuvBitCount(int);
JScript .NET public function get YuvBitCount() : int
public function set YuvBitCount(int);

Property Value

System.Int32 .

This property is read/write.


Microsoft.DirectX.DirectInput

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectInput® is used to process data from a keyboard, mouse, joystick, or other game controller. The following tables list the members exposed by the Microsoft.DirectX.DirectInput namespace.

Classes

AcquiredException | The operation cannot be performed while the device is acquired.
Action | Describes a mapping of one game action to one device semantic. An array of Diaction structures is contained by a Diactionformat structure.
ActionCollection | A collection of actions.
ActionFormat | Contains information about the calling application and acts as a container for an array of Diaction structures that define action-to-control mappings for a genre.
BadDriverVersionException | The object could not be created due to an incompatible driver version or mismatched or incomplete driver components.
BufferedData | Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.
BufferedDataCollection | Collection of buffered data.
ConfigureDevicesParameters
Device | Applications use the methods of the Device object to gain and release access to Microsoft® DirectInput® devices, manage device properties and information, set behavior, perform initialization, create and play force-feedback effects, and invoke a device's control panel.
DeviceFullException | The device is full.
DeviceList | Collection of devices.
DeviceNotRegisteredException | The device or device instance is not registered with DirectInput.
DeviceObjectList | A collection of device objects.
DeviceProperties | Various properties you can get or set on a device.
DInputHelper | Utility class for DirectInput
EffectList | A collection of effects.
EffectObject | Applications use the methods of the EffectObject to manage effects of force-feedback devices.
EffectPlayingException | The parameters were updated in memory but were not downloaded to the device because the device does not support updating an effect while it is still playing.
ForceFeedbackGuid | Force feedback guid.
HasEffectsException | The device cannot be reinitialized because effects are attached to it.
IncompleteEffectException | The effect could not be downloaded because essential information is missing. For example, no axes have been associated with the effect, or no type-specific information has been supplied.
InputException | Base exception type for all DirectInput exceptions. Derives from DirectXException.
InputLostException | Access to the input device has been lost. It must be reacquired.
InsufficientPriveledgesException | Insufficient priveledges for this call.
KeyboardState | Contains the keyboard state.
Manager | Applications use the methods of the Manager object to enumerate, create, and retrieve the status of DirectInput devices.
MapFileFailException | An error has occurred either reading the vendor-supplied action-mapping file for the device or reading or writing the user configuration mapping file for the device.
MoreDataException | Not all the requested information fit into the buffer.
NotAcquiredException | The operation cannot be performed unless the device is acquired.
NotBufferedException | The device is not buffered. Set the BufferSize property to enable buffering.
NotDownloadedException | The effect is not downloaded.
NotExclusivelyAcquiredException | The operation cannot be performed unless the device is acquired in Exclusive mode.
NotFoundException | The requested object does not exist.
ObjectTypeGuid | Object type guid.
OtherApplicationHasPriorityException | Another application has a higher priority level, preventing this call from succeeding.
PendingException | Data is not yet available.
ReportFullException | More information was requested to be sent than can be sent to the device.
SystemGuid | Contains system guids for common device types.
UnpluggedException | The operation could not be completed because the device is not plugged in.
UnsupportedException | The function called is not supported at this time.

Enumerations

ActionAttributeFlags | Flags used to request specific attributes or processing.
ActionMapControl | Flags to control the mapping.
ActionMechanism | Mapping mechanism used by DirectInput to configure the action.
Any | The following constants are used in the dwSemantic member of the Diaction structure to map an action to any matching control on the device.
ApplyActionMap | Value that specifies how the action map is applied.
ArcadePlatform | The genre contains controls for an arcade-style game.
ArcadeSideToSide | The genre contains controls for an arcade-style game.
AxesDataFormat | Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.
BrowserControl | The genre contains controls for browser control.
Button | A button.
Cad2DControl | The genre contains controls for a 2D CAD control
Cad3DControl | The genre contains controls for a 3-D CAD control
CadFlyBy | The genre contains controls for a CAD Fly By.
CadModel | The genre contains controls for a CAD model.
ConfigureDevicesFlags | Flags for configuring devices.
CooperativeLevelFlags | The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.
DataFormatFlags | Data format flags.
DeviceClass | Used when enumerating a class of devices.
DeviceData | Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.
DeviceDataFormat | Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.
DeviceObjectTypeFlags
DeviceType
DeviceTypeControl
DeviceTypeDriving
DeviceTypeFirstPerson
DeviceTypeFlight
DeviceTypeGamePad
DeviceTypeJoystick
DeviceTypeKeyboard | All keyboards. Equivalent to DI8DEVTYPE_KEYBOARD.
DeviceTypeMouse
DeviceTypeRemote
DeviceTypeScreenPtr
DeviceTypeSupplemental
DI
DrivingCombat
DrivingMecha
DrivingRace
DrivingTank
EffectFlags
EffectParameterFlags
EffectStartFlags
EffectType
EnumBySemanticsReason
EnumDevicesBySemanticsFlags
EnumDevicesFlags
FightingFps
FightingHandToHand
FightingThirdPerson
FileEffectsFlags
FlyingCivilian
FlyingHelicopter
FlyingMilitary
ForceFeedbackCommand
ForceFeedbackStates
ImageFileType
JoystickOffset
Key
Keyboard | The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical key.
MaxPoints
Mouse | The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical axis or button on a mouse.
MouseOffset | Mouse device constants, defined in Dinput.h, represent offsets within a mouse device's data packet, the Dimousestate or Dimousestate2 structure.
ObjectInstanceFlags
ParameterHow
PropertyType
PropRangeFlags | Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.
RemoteControl
ReturnCode
SetActionMapReturnCodes
SpaceSim
SportsBaseballBatting
SportsBaseBallField
SportsBaseballPitch
SportsBasketballDefense
SportsBasketballOffense
SportsBikingMountain
SportsFishing
SportsFootballDefense
SportsFootballField
SportsFootballOffense
SportsFootballQuarterback
SportsGolf
SportsHockeyDefense
SportsHockeyGoalie
SportsHockeyOffense
SportsHunting
SportsRaquet
SportsSkiing
SportsSoccerDefense
SportsSoccerOffense
StandardEffect
StrategyRolePlaying
StrategyTurn
TextAlign
TimeStamp
Voice

Structures

CalibrationPoint | Describes a calibration point. An array of Cpoint structures is contained by a Dipropcpoints structure.
ColorSet | Describes a set of colors used to draw the device configuration user object. It is part of the Diconfiguredevicesparams structure.
Condition | Contains type-specific information for effects that are marked as DIEFT_CONDITION.A reference to an array of Dicondition structures for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure. The number of elements in the array must be either one, or equal to the number of axes associated with the effect.
ConstantForce | Contains type-specific information for effects that are marked as DIEFT_CONSTANTFORCE.The structure describes a constant force effect.A reference to a single Diconstantforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
CustomForce | Contains type-specific information for effects that are marked as DIEFT_CUSTOMFORCE.The structure describes a custom or user-defined force.A reference to a Dicustomforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
DataFormat | Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.
DeviceArrival
DeviceCaps | Describes a Microsoft® DirectInput® device's capabilities. This structure is used with the Inputdevice9Getcapabilities method.
DeviceImageInformation | Carries information required to display a device image or an overlay image with a callout. This structure is passed to the Inputdevice9Getimageinfo method as an array within a Dideviceimageinfoheader structure.
DeviceImageInformationHeader | Contains information about device images. Used in the Inputdevice9Getimageinfo method.
DeviceInstance | Describes an instance of a Microsoft® DirectInput® device. This structure is used with the Input9Enumdevices, Input9Enumdevicesbysemantics, and Inputdevice9Getdeviceinfo methods.
DeviceObjectInstance | Describes a device object instance. This structure is used with the Inputdevice9Enumobjects method to provide the Dienumdeviceobjectscallback callback function with information about a particular object associated with a device, such as an axis or button. It is also used with the Inputdevice9Getobjectinfo method to retrieve information about a device object.
Effect | Used by the Inputdevice9Createeffect method to initialize a new Inputeffect object. It is also used by the InputeffectSetparameters and InputeffectGetparameters methods.
EffectInformation | Used by the Inputdevice9Enumeffects and Inputdevice9Geteffectinfo methods to return information about a particular effect supported by a device.
EffectStatus
Envelope | Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.
FileEffect | Describes data for a force-feedback effect stored in a file. It is used in conjunction with the Inputdevice9Enumeffectsinfile and Inputdevice9Writeeffecttofile methods.
InputRange
JoystickState | Describes the state of a joystick device. This structure is used with the Inputdevice9Getdevicestate method.
MouseState | Describes the state of a mouse device that has up to four buttons, or another device that is being accessed as if it were a mouse device. This structure is used with the Inputdevice9Getdevicestate method.
ObjectDataFormat | Describes a device object's data format for use with the Inputdevice9Setdataformat method.
Periodic | Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
RampForce | Contains type-specific information for effects that are marked as DIEFT_RAMPFORCE. The structure describes a ramp force effect.A reference to a single Dirampforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
SemanticsInstance


Microsoft.DirectX.DirectInput.AcquiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

AcquiredException Class

Language:
Note: This documentation is preliminary and is subject to change.

The operation cannot be performed while the device is acquired.

Definition

Visual Basic .NET Public Class AcquiredException
Inherits InputException
C# | public class AcquiredException : InputException
Managed C++ | public __gc class AcquiredException : public InputException
JScript .NET | public class AcquiredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AcquiredException | Initializes a new instance of the object.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
AcquiredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AcquiredException.AcquiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

AcquiredException.AcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public AcquiredException();
protected AcquiredException(SerializationInfo, StreamingContext);
public AcquiredException(string);
public AcquiredException(string, Exception);


AcquiredException.AcquiredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AcquiredException.AcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AcquiredException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AcquiredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AcquiredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AcquiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AcquiredException.AcquiredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AcquiredException.AcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AcquiredException(
string message,
Exception inner
);
Managed C++ public: AcquiredException(
String *message,
Exception *inner
);
JScript .NET public function AcquiredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AcquiredException.AcquiredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AcquiredException.AcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AcquiredException(
string message
);
Managed C++ public: AcquiredException(
String *message
);
JScript .NET public function AcquiredException(
message : String
);

Parameters

message System.String.


AcquiredException.AcquiredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AcquiredException.AcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public AcquiredException();
Managed C++ | public: AcquiredException();
JScript .NET | public function AcquiredException();


Microsoft.DirectX.DirectInput.Action

Microsoft DirectX 9.0 SDK Update (October 2004)

Action Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes a mapping of one game action to one device semantic. An array of Diaction structures is contained by a Diactionformat structure.

Definition

Visual Basic .NET Public Class Action
Inherits Object
C# | public class Action : Object
Managed C++ | public __gc class Action : public Object
JScript .NET | public class Action extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Action | Initializes a new instance of the object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
ActionName | Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.
ApplicationData | Retrieves or sets an identifier, or a function reference, for the application-specific action associated with the device object.
Flags | Flags used to request specific attributes or processing. Can be zero or one or more of the following values.
guidInstance | Device instance GUID if a specific device is requested. Otherwise GUID_NULL.
How | When the structure is returned by Inputdevice9Buildactionmap, this member receives a value to indicate the mapping mechanism used by Microsoft® DirectInput® to configure the action. This memeber is ignored when the action map is passed to Inputdevice9Setactionmap. The following values are defined.
ObjectId | Gets or retrieves a control identifier.
Semantic | For a joystick, a predefined action mapping constant for this application genre representing a virtual control or a constant for a control not defined in the genre. For a keyboard, mouse, or Microsoft® DirectPlay® voice device, a constant that represents a particular device object. See ActionMappingConstants.

Inheritance Hierarchy

Object Leave Site
Action

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Action.Action()

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.Action Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public Action();
Managed C++ | public: Action();
JScript .NET | public function Action();


Action.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Action();
Managed C++ | ~Action();
JScript .NET | protected override function Finalize();


Action.ActionName

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.ActionName Property

Language:
Note: This documentation is preliminary and is subject to change.

Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.

Definition

Visual Basic .NET | Public Property ActionName As String
C# | public string ActionName { get; set; }
Managed C++ public: __property String* get_ActionName();
public: __property void set_ActionName(String*);
JScript .NET public function get ActionName() : String
public function set ActionName(String);

Property Value

System.String .

This property is read/write.


Action.ApplicationData

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.ApplicationData Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets an identifier, or a function reference, for the application-specific action associated with the device object.

Definition

Visual Basic .NET | Public Property ApplicationData As Object
C# | public object ApplicationData { get; set; }
Managed C++ public: __property Object* get_ApplicationData();
public: __property void set_ApplicationData(Object*);
JScript .NET public function get ApplicationData() : Object
public function set ApplicationData(Object);

Property Value

System.Object .

This property is read/write.


Action.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Flags used to request specific attributes or processing. Can be zero or one or more of the following values.

Definition

Visual Basic .NET | Public Property Flags As ActionAttributeFlags
C# | public ActionAttributeFlags Flags { get; set; }
Managed C++ public: __property ActionAttributeFlags get_Flags();
public: __property void set_Flags(ActionAttributeFlags);
JScript .NET public function get Flags() : ActionAttributeFlags
public function set Flags(ActionAttributeFlags);

Property Value

Microsoft.DirectX.DirectInput.ActionAttributeFlags .

This property is read/write.


Action.guidInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.guidInstance Property

Language:
Note: This documentation is preliminary and is subject to change.

Device instance GUID if a specific device is requested. Otherwise GUID_NULL.

Definition

Visual Basic .NET | Public Property guidInstance As Guid
C# | public Guid guidInstance { get; set; }
Managed C++ public: __property Guid get_guidInstance();
public: __property void set_guidInstance(Guid);
JScript .NET public function get guidInstance() : Guid
public function set guidInstance(Guid);

Property Value

System.Guid .

This property is read/write.


Action.How

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.How Property

Language:
Note: This documentation is preliminary and is subject to change.

When the structure is returned by Inputdevice9Buildactionmap, this member receives a value to indicate the mapping mechanism used by Microsoft® DirectInput® to configure the action. This memeber is ignored when the action map is passed to Inputdevice9Setactionmap. The following values are defined.

Definition

Visual Basic .NET | Public Property How As ActionMechanism
C# | public ActionMechanism How { get; set; }
Managed C++ public: __property ActionMechanism get_How();
public: __property void set_How(ActionMechanism);
JScript .NET public function get How() : ActionMechanism
public function set How(ActionMechanism);

Property Value

Microsoft.DirectX.DirectInput.ActionMechanism .

This property is read/write.


Action.ObjectId

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.ObjectId Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or retrieves a control identifier.

Definition

Visual Basic .NET | Public Property ObjectId As Integer
C# | public int ObjectId { get; set; }
Managed C++ public: __property int get_ObjectId();
public: __property void set_ObjectId(int);
JScript .NET public function get ObjectId() : int
public function set ObjectId(int);

Property Value

System.Int32 .

This property is read/write.


Action.Semantic

Microsoft DirectX 9.0 SDK Update (October 2004)

Action.Semantic Property

Language:
Note: This documentation is preliminary and is subject to change.

For a joystick, a predefined action mapping constant for this application genre representing a virtual control or a constant for a control not defined in the genre. For a keyboard, mouse, or Microsoft® DirectPlay® voice device, a constant that represents a particular device object. See ActionMappingConstants.

Definition

Visual Basic .NET | Public Property Semantic As Integer
C# | public int Semantic { get; set; }
Managed C++ public: __property int get_Semantic();
public: __property void set_Semantic(int);
JScript .NET public function get Semantic() : int
public function set Semantic(int);

Property Value

System.Int32 .

This property is read/write.


Microsoft.DirectX.DirectInput.ActionCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

A collection of actions.

Definition

Visual Basic .NET Public Class ActionCollection
Inherits Object
Implements ICloneable, IEnumerable
C# public class ActionCollection : Object,
ICloneable, IEnumerable
Managed C++ public __gc class ActionCollection : public Object,
ICloneable, IEnumerable
JScript .NET public class ActionCollection extends Object
implements IEnumerable, ICloneable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ActionCollection | Initializes a new instance of the object.
Add | Add an element to the collection.
Clear | Clear all of the elements from the collection.
Clone | Duplicates the object.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the collection or a portion of it to a one-dimensional array.
GetEnumerator | Gets an enumerator for this collection.
IndexOf | Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.

Properties

Property | Description
Count | Gets the number of elements.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection is read only.
Item

Inheritance Hierarchy

Object Leave Site
ActionCollection

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ActionCollection.ActionCollection()

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.ActionCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public ActionCollection();
Managed C++ | public: ActionCollection();
JScript .NET | public function ActionCollection();


ActionCollection.Add(Action)

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Add an element to the collection.

Definition

Visual Basic .NET Public Function Add( _
ByVal value As Action _
) As Integer
C# public int Add(
Action value
);
Managed C++ public: int Add(
Action *value
);
JScript .NET public function Add(
value : Action
) : int;

Parameters

value Microsoft.DirectX.DirectInput.Action.

Return Value

System.Int32 .


ActionCollection.Clear()

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clear all of the elements from the collection.

Definition

Visual Basic .NET | Public Sub Clear()
C# | public void Clear();
Managed C++ | public: void Clear();
JScript .NET | public function Clear();


ActionCollection.Clone()

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Duplicates the object.

Definition

Visual Basic .NET | Overrides Public Function Clone() As Object
C# | public override object Clone();
Managed C++ | public: Object* Clone();
JScript .NET | public override function Clone() : Object;

Return Value

System.Object .


ActionCollection.Contains(Action)

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Contains Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether an element is in the collection.

Definition

Visual Basic .NET Public Function Contains( _
ByVal value As Action _
) As Boolean
C# public bool Contains(
Action value
);
Managed C++ public: bool Contains(
Action *value
);
JScript .NET public function Contains(
value : Action
) : boolean;

Parameters

value Microsoft.DirectX.DirectInput.Action.

Return Value

System.Boolean .


ActionCollection.CopyTo(Array,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.CopyTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies the collection or a portion of it to a one-dimensional array.

Definition

Visual Basic .NET Public Sub CopyTo( _
ByVal data As Array, _
ByVal index As Integer _
)
C# public void CopyTo(
Array data,
int index
);
Managed C++ public: void CopyTo(
Array *data,
int index
);
JScript .NET public function CopyTo(
data : Array,
index : int
);

Parameters

data | System.Array.
index | System.Int32.


ActionCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets an enumerator for this collection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


ActionCollection.IndexOf(Action)

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.IndexOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Definition

Visual Basic .NET Public Function IndexOf( _
ByVal value As Action _
) As Integer
C# public int IndexOf(
Action value
);
Managed C++ public: int IndexOf(
Action *value
);
JScript .NET public function IndexOf(
value : Action
) : int;

Parameters

value Microsoft.DirectX.DirectInput.Action.

Return Value

System.Int32 .


ActionCollection.Insert(Int32,Action)

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Insert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Inserts an element into the collection at the specified index.

Definition

Visual Basic .NET Public Sub Insert( _
ByVal index As Integer, _
ByVal value As Action _
)
C# public void Insert(
int index,
Action value
);
Managed C++ public: void Insert(
int index,
Action *value
);
JScript .NET public function Insert(
index : int,
value : Action
);

Parameters

index | System.Int32.
value | Microsoft.DirectX.DirectInput.Action.


ActionCollection.Remove(Action)

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Remove Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the first occurrence of a specific object from the collection.

Definition

Visual Basic .NET Public Sub Remove( _
ByVal value As Action _
)
C# public void Remove(
Action value
);
Managed C++ public: void Remove(
Action *value
);
JScript .NET public function Remove(
value : Action
);

Parameters

value Microsoft.DirectX.DirectInput.Action.


ActionCollection.RemoveAt(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.RemoveAt Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the element at the specified index of the collection.

Definition

Visual Basic .NET Public Sub RemoveAt( _
ByVal index As Integer _
)
C# public void RemoveAt(
int index
);
Managed C++ public: void RemoveAt(
int index
);
JScript .NET public function RemoveAt(
index : int
);

Parameters

index System.Int32.


ActionCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the number of elements.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


ActionCollection.IsFixedSize

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.IsFixedSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value indicating whether the collection has a fixed size.

Definition

Visual Basic .NET | Public ReadOnly Property IsFixedSize As Boolean
C# | public bool IsFixedSize { get; }
Managed C++ | public: __property bool get_IsFixedSize();
JScript .NET | public function get IsFixedSize() : boolean

Property Value

System.Boolean .

This property is read-only.


ActionCollection.IsReadOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.IsReadOnly Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value indicating whether the collection is read only.

Definition

Visual Basic .NET | Public ReadOnly Property IsReadOnly As Boolean
C# | public bool IsReadOnly { get; }
Managed C++ | public: __property bool get_IsReadOnly();
JScript .NET | public function get IsReadOnly() : boolean

Property Value

System.Boolean .

This property is read-only.


ActionCollection.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionCollection.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Property Item( _
ByVal index As Integer _
) As Action
C# public Action this[
int index
] { get; set; }
Managed C++ public: __property Action* get_Item(
int index
);
public: __property void set_Item(
int index,
Action*
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.DirectInput.Action .

This property is read/write.

Parameters

index System.Int32.


Microsoft.DirectX.DirectInput.ActionFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains information about the calling application and acts as a container for an array of Diaction structures that define action-to-control mappings for a genre.

Definition

Visual Basic .NET Public Class ActionFormat
Inherits Object
C# | public class ActionFormat : Object
Managed C++ | public __gc class ActionFormat : public Object
JScript .NET | public class ActionFormat extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ActionFormat | Initializes a new instance of the object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
ActionMap | GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.
ActionMapGuid | GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.
Actions | Collection of actions.
AxisMax | Maximum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMax value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.
AxisMin | Minimum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMin value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.
BufferSize | Retrieves or sets a value that specifies the number of input data packets in the buffer for each device to which this action-to-control mapping is to be applied.
Genre | DWORD value that specifies the genre of the application. For possible values, see ActionMappingConstants.
Instance | Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.
InstanceHandle | Handle of the module containing string resources for action names.
TimeStamp | FILETIME structure that receives the time at which this action map was last written to disk. See Remarks.

Inheritance Hierarchy

Object Leave Site
ActionFormat

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ActionFormat.ActionFormat()

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.ActionFormat Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public ActionFormat();
Managed C++ | public: ActionFormat();
JScript .NET | public function ActionFormat();


ActionFormat.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ActionFormat();
Managed C++ | ~ActionFormat();
JScript .NET | protected override function Finalize();


ActionFormat.ActionMap

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.ActionMap Property

Language:
Note: This documentation is preliminary and is subject to change.

GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.

Definition

Visual Basic .NET | Public Property ActionMap As String
C# | public string ActionMap { get; set; }
Managed C++ public: __property String* get_ActionMap();
public: __property void set_ActionMap(String*);
JScript .NET public function get ActionMap() : String
public function set ActionMap(String);

Property Value

System.String .

This property is read/write.


ActionFormat.ActionMapGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.ActionMapGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.

Definition

Visual Basic .NET | Public Property ActionMapGuid As Guid
C# | public Guid ActionMapGuid { get; set; }
Managed C++ public: __property Guid get_ActionMapGuid();
public: __property void set_ActionMapGuid(Guid);
JScript .NET public function get ActionMapGuid() : Guid
public function set ActionMapGuid(Guid);

Property Value

System.Guid .

This property is read/write.


ActionFormat.Actions

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.Actions Property

Language:
Note: This documentation is preliminary and is subject to change.

Collection of actions.

Definition

Visual Basic .NET | Public ReadOnly Property Actions As ActionCollection
C# | public ActionCollection Actions { get; }
Managed C++ | public: __property ActionCollection* get_Actions();
JScript .NET | public function get Actions() : ActionCollection

Property Value

Microsoft.DirectX.DirectInput.ActionCollection .

This property is read-only.


ActionFormat.AxisMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.AxisMax Property

Language:
Note: This documentation is preliminary and is subject to change.

Maximum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMax value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.

Definition

Visual Basic .NET | Public Property AxisMax As Integer
C# | public int AxisMax { get; set; }
Managed C++ public: __property int get_AxisMax();
public: __property void set_AxisMax(int);
JScript .NET public function get AxisMax() : int
public function set AxisMax(int);

Property Value

System.Int32 .

This property is read/write.


ActionFormat.AxisMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.AxisMin Property

Language:
Note: This documentation is preliminary and is subject to change.

Minimum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMin value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.

Definition

Visual Basic .NET | Public Property AxisMin As Integer
C# | public int AxisMin { get; set; }
Managed C++ public: __property int get_AxisMin();
public: __property void set_AxisMin(int);
JScript .NET public function get AxisMin() : int
public function set AxisMin(int);

Property Value

System.Int32 .

This property is read/write.


ActionFormat.BufferSize

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.BufferSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a value that specifies the number of input data packets in the buffer for each device to which this action-to-control mapping is to be applied.

Definition

Visual Basic .NET | Public Property BufferSize As Integer
C# | public int BufferSize { get; set; }
Managed C++ public: __property int get_BufferSize();
public: __property void set_BufferSize(int);
JScript .NET public function get BufferSize() : int
public function set BufferSize(int);

Property Value

System.Int32 .

This property is read/write.


ActionFormat.Genre

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.Genre Property

Language:
Note: This documentation is preliminary and is subject to change.

DWORD value that specifies the genre of the application. For possible values, see ActionMappingConstants.

Definition

Visual Basic .NET | Public Property Genre As Integer
C# | public int Genre { get; set; }
Managed C++ public: __property int get_Genre();
public: __property void set_Genre(int);
JScript .NET public function get Genre() : int
public function set Genre(int);

Property Value

System.Int32 .

This property is read/write.


ActionFormat.Instance

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.Instance Property

Language:
Note: This documentation is preliminary and is subject to change.

Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.

Definition

Visual Basic .NET Public Property Instance( _
ByVal value As IntPtr _
) As IntPtr
C# public IntPtr this[
IntPtr value
] { set; }
Managed C++ public: __property void set_Instance(
IntPtr value,
IntPtr
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

System.IntPtr .

This property is write-only.

Parameters

value System.IntPtr.


ActionFormat.InstanceHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.InstanceHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Handle of the module containing string resources for action names.

Definition

Visual Basic .NET | Public ReadOnly Property InstanceHandle As IntPtr
C# | public IntPtr InstanceHandle { get; }
Managed C++ | public: __property IntPtr get_InstanceHandle();
JScript .NET | public function get InstanceHandle() : IntPtr

Property Value

System.IntPtr .

This property is read-only.


ActionFormat.TimeStamp

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionFormat.TimeStamp Property

Language:
Note: This documentation is preliminary and is subject to change.

FILETIME structure that receives the time at which this action map was last written to disk. See Remarks.

Definition

Visual Basic .NET | Public Property TimeStamp As FILETIME
C# | public FILETIME TimeStamp { get; set; }
Managed C++ public: __property FILETIME get_TimeStamp();
public: __property void set_TimeStamp(FILETIME);
JScript .NET public function get TimeStamp() : FILETIME
public function set TimeStamp(FILETIME);

Property Value

System.Runtime.InteropServices.FILETIME .

This property is read/write.


Microsoft.DirectX.DirectInput.BadDriverVersionException

Microsoft DirectX 9.0 SDK Update (October 2004)

BadDriverVersionException Class

Language:
Note: This documentation is preliminary and is subject to change.

The object could not be created due to an incompatible driver version or mismatched or incomplete driver components.

Definition

Visual Basic .NET Public Class BadDriverVersionException
Inherits InputException
C# | public class BadDriverVersionException : InputException
Managed C++ | public __gc class BadDriverVersionException : public InputException
JScript .NET | public class BadDriverVersionException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BadDriverVersionException | Initializes a new instance of the object.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
BadDriverVersionException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BadDriverVersionException.BadDriverVersionException

Microsoft DirectX 9.0 SDK Update (October 2004)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public BadDriverVersionException();
protected BadDriverVersionException(SerializationInfo, StreamingContext);
public BadDriverVersionException(string);
public BadDriverVersionException(string, Exception);


BadDriverVersionException.BadDriverVersionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadDriverVersionException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BadDriverVersionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: BadDriverVersionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function BadDriverVersionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


BadDriverVersionException.BadDriverVersionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BadDriverVersionException(
string message,
Exception inner
);
Managed C++ public: BadDriverVersionException(
String *message,
Exception *inner
);
JScript .NET public function BadDriverVersionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


BadDriverVersionException.BadDriverVersionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public BadDriverVersionException(
string message
);
Managed C++ public: BadDriverVersionException(
String *message
);
JScript .NET public function BadDriverVersionException(
message : String
);

Parameters

message System.String.


BadDriverVersionException.BadDriverVersionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public BadDriverVersionException();
Managed C++ | public: BadDriverVersionException();
JScript .NET | public function BadDriverVersionException();


Microsoft.DirectX.DirectInput.BufferedData

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.

Definition

Visual Basic .NET Public Class BufferedData
Inherits Object
C# | public class BufferedData : Object
Managed C++ | public __gc class BufferedData : public Object
JScript .NET | public class BufferedData extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_GreaterThan
static (Shared in Visual Basic .NET) op_GreaterThanOrEqual
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_LessThan
static (Shared in Visual Basic .NET) op_LessThanOrEqual
static (Shared in Visual Basic .NET) op_LogicalAnd
static (Shared in Visual Basic .NET) op_LogicalOr

Properties

Property | Description
ApplicationData | Application-defined action value assigned to this object in the last call to Inputdevice9Setactionmap. This is the value in the uAppData member of the Diaction structure associated with the object. Ignore this value if you are not using action mapping. When the structure is used with the Inputdevice9Senddevicedata method, this member must be zero.
ButtonPressedData
Data | Data obtained from or sent to the device. For axis input, if the device is in relative axis mode, the relative axis motion is reported. If the device is in absolute axis mode, the absolute axis coordinate is reported.For button input, only the low byte of DwData is significant. The high bit of the low byte is set if the button was pressed; it is clear if the button was released.
Offset | The offset into the current data format of the object whose data is being reported.
Sequence | Microsoft® DirectInput® sequence number for this event. All input events are assigned an increasing sequence number. This enables events from different devices to be sorted chronologically.
TimeStamp | System time at which the input event was generated, in milliseconds. This value wraps around approximately every 50 days. See Remarks. When the structure is used with the Inputdevice9Senddevicedata method, this member must be 0.

Inheritance Hierarchy

Object Leave Site
BufferedData

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BufferedData.op_Equality(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_Equality(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_Equality(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_Equality(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


BufferedData.op_GreaterThan(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_GreaterThan Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function op_GreaterThan( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_GreaterThan(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_GreaterThan(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_GreaterThan(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean .


BufferedData.op_GreaterThanOrEqual(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_GreaterThanOrEqual Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function op_GreaterThanOrEqual( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_GreaterThanOrEqual(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_GreaterThanOrEqual(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_GreaterThanOrEqual(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean .


BufferedData.op_Inequality(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_Inequality(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_Inequality(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_Inequality(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


BufferedData.op_LessThan(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_LessThan Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function op_LessThan( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LessThan(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_LessThan(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_LessThan(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean .


BufferedData.op_LessThanOrEqual(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_LessThanOrEqual Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function op_LessThanOrEqual( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LessThanOrEqual(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_LessThanOrEqual(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_LessThanOrEqual(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean .


BufferedData.op_LogicalAnd(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_LogicalAnd Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function op_LogicalAnd( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LogicalAnd(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_LogicalAnd(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_LogicalAnd(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean .


BufferedData.op_LogicalOr(BufferedData,BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.op_LogicalOr Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function op_LogicalOr( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LogicalOr(
BufferedData a,
BufferedData b
);
Managed C++ public: static bool op_LogicalOr(
BufferedData *a,
BufferedData *b
);
JScript .NET public static function op_LogicalOr(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a | Microsoft.DirectX.DirectInput.BufferedData.
b | Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean .


BufferedData.ApplicationData

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.ApplicationData Property

Language:
Note: This documentation is preliminary and is subject to change.

Application-defined action value assigned to this object in the last call to Inputdevice9Setactionmap. This is the value in the uAppData member of the Diaction structure associated with the object. Ignore this value if you are not using action mapping. When the structure is used with the Inputdevice9Senddevicedata method, this member must be zero.

Definition

Visual Basic .NET | Public ReadOnly Property ApplicationData As Object
C# | public object ApplicationData { get; }
Managed C++ | public: __property Object* get_ApplicationData();
JScript .NET | public function get ApplicationData() : Object

Property Value

System.Object .

This property is read-only.


BufferedData.ButtonPressedData

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.ButtonPressedData Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property ButtonPressedData As Integer
C# | public int ButtonPressedData { get; }
Managed C++ | public: __property int get_ButtonPressedData();
JScript .NET | public function get ButtonPressedData() : int

Property Value

System.Int32 .

This property is read-only.


BufferedData.Data

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.Data Property

Language:
Note: This documentation is preliminary and is subject to change.

Data obtained from or sent to the device. For axis input, if the device is in relative axis mode, the relative axis motion is reported. If the device is in absolute axis mode, the absolute axis coordinate is reported.For button input, only the low byte of DwData is significant. The high bit of the low byte is set if the button was pressed; it is clear if the button was released.

Definition

Visual Basic .NET | Public ReadOnly Property Data As Integer
C# | public int Data { get; }
Managed C++ | public: __property int get_Data();
JScript .NET | public function get Data() : int

Property Value

System.Int32 .

This property is read-only.


BufferedData.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

The offset into the current data format of the object whose data is being reported.

Definition

Visual Basic .NET | Public ReadOnly Property Offset As Integer
C# | public int Offset { get; }
Managed C++ | public: __property int get_Offset();
JScript .NET | public function get Offset() : int

Property Value

System.Int32 .

This property is read-only.


BufferedData.Sequence

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.Sequence Property

Language:
Note: This documentation is preliminary and is subject to change.

Microsoft® DirectInput® sequence number for this event. All input events are assigned an increasing sequence number. This enables events from different devices to be sorted chronologically.

Definition

Visual Basic .NET | Public ReadOnly Property Sequence As Integer
C# | public int Sequence { get; }
Managed C++ | public: __property int get_Sequence();
JScript .NET | public function get Sequence() : int

Property Value

System.Int32 .

This property is read-only.


BufferedData.TimeStamp

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedData.TimeStamp Property

Language:
Note: This documentation is preliminary and is subject to change.

System time at which the input event was generated, in milliseconds. This value wraps around approximately every 50 days. See Remarks. When the structure is used with the Inputdevice9Senddevicedata method, this member must be 0.

Definition

Visual Basic .NET | Public ReadOnly Property TimeStamp As Integer
C# | public int TimeStamp { get; }
Managed C++ | public: __property int get_TimeStamp();
JScript .NET | public function get TimeStamp() : int

Property Value

System.Int32 .

This property is read-only.


Microsoft.DirectX.DirectInput.BufferedDataCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Collection of buffered data.

Definition

Visual Basic .NET Public Class BufferedDataCollection
Inherits Object
Implements ICloneable, IEnumerable
C# public class BufferedDataCollection : Object,
ICloneable, IEnumerable
Managed C++ public __gc class BufferedDataCollection : public Object,
ICloneable, IEnumerable
JScript .NET public class BufferedDataCollection extends Object
implements IEnumerable, ICloneable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Add | Adds a new element to the collection.
BufferedDataCollection | Initializes a new instance of the object.
Clear | Clears all elements from the collection.
Clone | Duplicates the object.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the collection or a portion of it to a one-dimensional array.
DeviceDataAverage | Return the average of all data in the collection.
DeviceDataInstanceCount | Return the count of all the data in the collection.
DeviceDataSum | Return the sum of all the data in the collection.
GetEnumerator | Gets an enumerator for this collection.
IndexOf | Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
SortBySequence | Sort the collection by sequence.

Properties

Property | Description
Count | Gets the number of elements.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection is read only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Inheritance Hierarchy

Object Leave Site
BufferedDataCollection

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BufferedDataCollection.Add(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a new element to the collection.

Definition

Visual Basic .NET Public Function Add( _
ByVal value As Object _
) As Integer
C# public int Add(
object value
);
Managed C++ public: int Add(
Object *value
);
JScript .NET public function Add(
value : Object
) : int;

Parameters

value System.Object.

Return Value

System.Int32 .


BufferedDataCollection.BufferedDataCollection()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.BufferedDataCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public BufferedDataCollection();
Managed C++ | public: BufferedDataCollection();
JScript .NET | public function BufferedDataCollection();


BufferedDataCollection.Clear()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Clears all elements from the collection.

Definition

Visual Basic .NET | Public Sub Clear()
C# | public void Clear();
Managed C++ | public: void Clear();
JScript .NET | public function Clear();


BufferedDataCollection.Clone()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Duplicates the object.

Definition

Visual Basic .NET | Overrides Public Function Clone() As Object
C# | public override object Clone();
Managed C++ | public: Object* Clone();
JScript .NET | public override function Clone() : Object;

Return Value

System.Object .


BufferedDataCollection.Contains

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Contains Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether an element is in the collection.

Overload List

public bool Contains(BufferedData);
public bool Contains(object);


BufferedDataCollection.Contains(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Contains Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether an element is in the collection.

Definition

Visual Basic .NET Public Function Contains( _
ByVal obj As Object _
) As Boolean
C# public bool Contains(
object obj
);
Managed C++ public: bool Contains(
Object *obj
);
JScript .NET public function Contains(
obj : Object
) : boolean;

Parameters

obj System.Object.

Return Value

System.Boolean .


BufferedDataCollection.Contains(BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Contains Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether an element is in the collection.

Definition

Visual Basic .NET Public Function Contains( _
ByVal value As BufferedData _
) As Boolean
C# public bool Contains(
BufferedData value
);
Managed C++ public: bool Contains(
BufferedData *value
);
JScript .NET public function Contains(
value : BufferedData
) : boolean;

Parameters

value Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Boolean .


BufferedDataCollection.CopyTo(Array,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.CopyTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies the collection or a portion of it to a one-dimensional array.

Definition

Visual Basic .NET Public Sub CopyTo( _
ByVal data As Array, _
ByVal index As Integer _
)
C# public void CopyTo(
Array data,
int index
);
Managed C++ public: void CopyTo(
Array *data,
int index
);
JScript .NET public function CopyTo(
data : Array,
index : int
);

Parameters

data | System.Array.
index | System.Int32.


BufferedDataCollection.DeviceDataAverage

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataAverage Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the average of all data in the collection.

Overload List

public int DeviceDataAverage(int);
public int DeviceDataAverage(object);


BufferedDataCollection.DeviceDataAverage(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataAverage Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the average of all data in the collection.

Definition

Visual Basic .NET Public Function DeviceDataAverage( _
ByVal offset As Integer _
) As Integer
C# public int DeviceDataAverage(
int offset
);
Managed C++ public: int DeviceDataAverage(
int offset
);
JScript .NET public function DeviceDataAverage(
offset : int
) : int;

Parameters

offset System.Int32.

Return Value

System.Int32 .


BufferedDataCollection.DeviceDataAverage(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataAverage Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the average of all data in the collection.

Definition

Visual Basic .NET Public Function DeviceDataAverage( _
ByVal applicationData As Object _
) As Integer
C# public int DeviceDataAverage(
object applicationData
);
Managed C++ public: int DeviceDataAverage(
Object *applicationData
);
JScript .NET public function DeviceDataAverage(
applicationData : Object
) : int;

Parameters

applicationData System.Object.

Return Value

System.Int32 .


BufferedDataCollection.DeviceDataInstanceCount

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataInstanceCount Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the count of all the data in the collection.

Overload List

public int DeviceDataInstanceCount(int);
public int DeviceDataInstanceCount(object);


BufferedDataCollection.DeviceDataInstanceCount(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataInstanceCount Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the count of all the data in the collection.

Definition

Visual Basic .NET Public Function DeviceDataInstanceCount( _
ByVal offset As Integer _
) As Integer
C# public int DeviceDataInstanceCount(
int offset
);
Managed C++ public: int DeviceDataInstanceCount(
int offset
);
JScript .NET public function DeviceDataInstanceCount(
offset : int
) : int;

Parameters

offset System.Int32.

Return Value

System.Int32 .


BufferedDataCollection.DeviceDataInstanceCount(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataInstanceCount Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the count of all the data in the collection.

Definition

Visual Basic .NET Public Function DeviceDataInstanceCount( _
ByVal applicationData As Object _
) As Integer
C# public int DeviceDataInstanceCount(
object applicationData
);
Managed C++ public: int DeviceDataInstanceCount(
Object *applicationData
);
JScript .NET public function DeviceDataInstanceCount(
applicationData : Object
) : int;

Parameters

applicationData System.Object.

Return Value

System.Int32 .


BufferedDataCollection.DeviceDataSum

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataSum Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the sum of all the data in the collection.

Overload List

public int DeviceDataSum(int);
public int DeviceDataSum(object);


BufferedDataCollection.DeviceDataSum(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataSum Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the sum of all the data in the collection.

Definition

Visual Basic .NET Public Function DeviceDataSum( _
ByVal offset As Integer _
) As Integer
C# public int DeviceDataSum(
int offset
);
Managed C++ public: int DeviceDataSum(
int offset
);
JScript .NET public function DeviceDataSum(
offset : int
) : int;

Parameters

offset System.Int32.

Return Value

System.Int32 .


BufferedDataCollection.DeviceDataSum(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.DeviceDataSum Method

 Language:
Note: This documentation is preliminary and is subject to change.

Return the sum of all the data in the collection.

Definition

Visual Basic .NET Public Function DeviceDataSum( _
ByVal applicationData As Object _
) As Integer
C# public int DeviceDataSum(
object applicationData
);
Managed C++ public: int DeviceDataSum(
Object *applicationData
);
JScript .NET public function DeviceDataSum(
applicationData : Object
) : int;

Parameters

applicationData System.Object.

Return Value

System.Int32 .


BufferedDataCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets an enumerator for this collection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


BufferedDataCollection.IndexOf

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.IndexOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Overload List

public int IndexOf(BufferedData);
public int IndexOf(object);


BufferedDataCollection.IndexOf(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.IndexOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Definition

Visual Basic .NET Public Function IndexOf( _
ByVal obj As Object _
) As Integer
C# public int IndexOf(
object obj
);
Managed C++ public: int IndexOf(
Object *obj
);
JScript .NET public function IndexOf(
obj : Object
) : int;

Parameters

obj System.Object.

Return Value

System.Int32 .


BufferedDataCollection.IndexOf(BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.IndexOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Definition

Visual Basic .NET Public Function IndexOf( _
ByVal value As BufferedData _
) As Integer
C# public int IndexOf(
BufferedData value
);
Managed C++ public: int IndexOf(
BufferedData *value
);
JScript .NET public function IndexOf(
value : BufferedData
) : int;

Parameters

value Microsoft.DirectX.DirectInput.BufferedData.

Return Value

System.Int32 .


BufferedDataCollection.Insert(Int32,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Insert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Inserts an element into the collection at the specified index.

Definition

Visual Basic .NET Public Sub Insert( _
ByVal __unnamed000 As Integer, _
ByVal __unnamed001 As Object _
)
C# public void Insert(
int __unnamed000,
object __unnamed001
);
Managed C++ public: void Insert(
int __unnamed000,
Object *__unnamed001
);
JScript .NET public function Insert(
__unnamed000 : int,
__unnamed001 : Object
);

Parameters

__unnamed000 | System.Int32.
__unnamed001 | System.Object.


BufferedDataCollection.Remove

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Remove Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the first occurrence of a specific object from the collection.

Overload List

public void Remove(BufferedData);
public void Remove(object);


BufferedDataCollection.Remove(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Remove Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the first occurrence of a specific object from the collection.

Definition

Visual Basic .NET Public Sub Remove( _
ByVal __unnamed000 As Object _
)
C# public void Remove(
object __unnamed000
);
Managed C++ public: void Remove(
Object *__unnamed000
);
JScript .NET public function Remove(
__unnamed000 : Object
);

Parameters

__unnamed000 System.Object.


BufferedDataCollection.Remove(BufferedData)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Remove Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the first occurrence of a specific object from the collection.

Definition

Visual Basic .NET Public Sub Remove( _
ByVal value As BufferedData _
)
C# public void Remove(
BufferedData value
);
Managed C++ public: void Remove(
BufferedData *value
);
JScript .NET public function Remove(
value : BufferedData
);

Parameters

value Microsoft.DirectX.DirectInput.BufferedData.


BufferedDataCollection.RemoveAt(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.RemoveAt Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the element at the specified index of the collection.

Definition

Visual Basic .NET Public Sub RemoveAt( _
ByVal index As Integer _
)
C# public void RemoveAt(
int index
);
Managed C++ public: void RemoveAt(
int index
);
JScript .NET public function RemoveAt(
index : int
);

Parameters

index System.Int32.


BufferedDataCollection.SortBySequence

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.SortBySequence Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sort the collection by sequence.

Overload List

public void SortBySequence();
public void SortBySequence(bool);


BufferedDataCollection.SortBySequence(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.SortBySequence Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sort the collection by sequence.

Definition

Visual Basic .NET Public Sub SortBySequence( _
ByVal Descending As Boolean _
)
C# public void SortBySequence(
bool Descending
);
Managed C++ public: void SortBySequence(
bool Descending
);
JScript .NET public function SortBySequence(
Descending : boolean
);

Parameters

Descending System.Boolean.


BufferedDataCollection.SortBySequence()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.SortBySequence Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sort the collection by sequence.

Definition

Visual Basic .NET | Public Sub SortBySequence()
C# | public void SortBySequence();
Managed C++ | public: void SortBySequence();
JScript .NET | public function SortBySequence();


BufferedDataCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the number of elements.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


BufferedDataCollection.IsFixedSize

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.IsFixedSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value indicating whether the collection has a fixed size.

Definition

Visual Basic .NET | Public ReadOnly Property IsFixedSize As Boolean
C# | public bool IsFixedSize { get; }
Managed C++ | public: __property bool get_IsFixedSize();
JScript .NET | public function get IsFixedSize() : boolean

Property Value

System.Boolean .

This property is read-only.


BufferedDataCollection.IsReadOnly

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.IsReadOnly Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value indicating whether the collection is read only.

Definition

Visual Basic .NET | Public ReadOnly Property IsReadOnly As Boolean
C# | public bool IsReadOnly { get; }
Managed C++ | public: __property bool get_IsReadOnly();
JScript .NET | public function get IsReadOnly() : boolean

Property Value

System.Boolean .

This property is read-only.


BufferedDataCollection.IsSynchronized

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.IsSynchronized Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value indicating whether access to the collection is synchronized (thread-safe).

Definition

Visual Basic .NET | Public ReadOnly Property IsSynchronized As Boolean
C# | public bool IsSynchronized { get; }
Managed C++ | public: __property bool get_IsSynchronized();
JScript .NET | public function get IsSynchronized() : boolean

Property Value

System.Boolean .

This property is read-only.


BufferedDataCollection.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Property Item( _
ByVal index As Integer _
) As BufferedData
C# public BufferedData this[
int index
] { get; set; }
Managed C++ public: __property BufferedData* get_Item(
int index
);
public: __property void set_Item(
int index,
BufferedData*
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.DirectInput.BufferedData .

This property is read/write.

Parameters

index System.Int32.


BufferedDataCollection.SyncRoot

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferedDataCollection.SyncRoot Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets an object that can be used to synchronize access to the collection.

Definition

Visual Basic .NET | Public ReadOnly Property SyncRoot As Object
C# | public object SyncRoot { get; }
Managed C++ | public: __property Object* get_SyncRoot();
JScript .NET | public function get SyncRoot() : Object

Property Value

System.Object .

This property is read-only.


Microsoft.DirectX.DirectInput.ConfigureDevicesParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters Class

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Class ConfigureDevicesParameters
Inherits Object
C# | public class ConfigureDevicesParameters : Object
Managed C++ | public __gc class ConfigureDevicesParameters : public Object
JScript .NET | public class ConfigureDevicesParameters extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConfigureDevicesParameters | Initializes a new instance of the object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetActionFormats
GetUserNames
SetActionFormats
SetUserNames
ToString | Obtains a string representation of the current instance.

Properties

Property Description
ColorSetStruct
Window

Inheritance Hierarchy

Object Leave Site
ConfigureDevicesParameters

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConfigureDevicesParameters.ConfigureDevicesParameters()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.ConfigureDevicesParameters Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConfigureDevicesParameters();
Managed C++ | public: ConfigureDevicesParameters();
JScript .NET | public function ConfigureDevicesParameters();


ConfigureDevicesParameters.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ConfigureDevicesParameters();
Managed C++ | ~ConfigureDevicesParameters();
JScript .NET | protected override function Finalize();


ConfigureDevicesParameters.GetActionFormats()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.GetActionFormats Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Function GetActionFormats() As ActionFormat()
C# | public ActionFormat[] GetActionFormats();
Managed C++ | public: ActionFormat* GetActionFormats() __gc[];
JScript .NET | public function GetActionFormats() : ActionFormat[];

Return Value

Microsoft.DirectX.DirectInput.ActionFormat[].


ConfigureDevicesParameters.GetUserNames()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.GetUserNames Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Function GetUserNames() As String()
C# | public string[] GetUserNames();
Managed C++ | public: String* GetUserNames() __gc[];
JScript .NET | public function GetUserNames() : String[];

Return Value

System.String[].


ConfigureDevicesParameters.SetActionFormats(ActionFormat[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.SetActionFormats Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Sub SetActionFormats( _
ByVal value() As ActionFormat _
)
C# public void SetActionFormats(
ActionFormat[] value
);
Managed C++ public: void SetActionFormats(
ActionFormat *value __gc[]
);
JScript .NET public function SetActionFormats(
value : ActionFormat[]
);

Parameters

value Microsoft.DirectX.DirectInput.ActionFormat[].


ConfigureDevicesParameters.SetUserNames(String[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.SetUserNames Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Sub SetUserNames( _
ByVal value() As String _
)
C# public void SetUserNames(
string[] value
);
Managed C++ public: void SetUserNames(
String *value __gc[]
);
JScript .NET public function SetUserNames(
value : String[]
);

Parameters

value System.String[].


ConfigureDevicesParameters.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConfigureDevicesParameters.ColorSetStruct

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.ColorSetStruct Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property ColorSetStruct As ColorSet
C# | public ColorSet ColorSetStruct { get; set; }
Managed C++ public: __property ColorSet get_ColorSetStruct();
public: __property void set_ColorSetStruct(ColorSet);
JScript .NET public function get ColorSetStruct() : ColorSet
public function set ColorSetStruct(ColorSet);

Property Value

Microsoft.DirectX.DirectInput.ColorSet .

This property is read/write.


ConfigureDevicesParameters.Window

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesParameters.Window Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Window As Control
C# | public Control Window { get; set; }
Managed C++ public: __property Control* get_Window();
public: __property void set_Window(Control*);
JScript .NET public function get Window() : Control
public function set Window(Control);

Property Value

System.Windows.Forms.Control .

This property is read/write.


Microsoft.DirectX.DirectInput.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Device Class

Language:
Note: This documentation is preliminary and is subject to change.

Applications use the methods of the Device object to gain and release access to Microsoft® DirectInput® devices, manage device properties and information, set behavior, perform initialization, create and play force-feedback effects, and invoke a device's control panel.

Definition

Visual Basic .NET NotInheritable Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# public sealed class Device : MarshalByRefObject,
IDisposable
Managed C++ public __gc __sealed class Device : public MarshalByRefObject,
IDisposable
JScript .NET public class Device extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Acquire | Obtains access to the input device.
BuildActionMap | Builds an action map for the device and retrieves information about it.
Device | Initializes a new instance of the object.
Dispose | Immediately releases the unmanaged resources used by an object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetBufferedData | Retrieves buffered data from the device.
GetCurrentKeyboardState | Retrieves immediate data from the device.
GetDeviceState
GetEffectInformation
GetEffects | Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.
GetHashCode | Returns the hash code for the current instance.
GetObjectInformation | Retrieves information about a device object, such as a button or axis.
GetObjects | Enumerates the input and output objects available on a device.
GetPressedKeys | Retrieves the currently pressed keys on a keyboard device.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Poll | Retrieves data from polled objects on a Microsoft® DirectInput® device. If the device does not require polling, calling this method has no effect. If a device that requires polling is not polled periodically, no new data is received from the device. Calling this method causes Microsoft® DirectInput® to update the device state, generate input events (if buffered data is enabled), and set notification events (if notification is enabled).
RunControlPanel | Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.
SendForceFeedbackCommand | Sends a command to the device's force-feedback system.
SendHardwareCommand | Sends a hardware-specific command to the force-feedback driver.
SetActionMap | Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.
SetCooperativeLevel | Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.
SetDataFormat | Sets the data format for the Microsoft® DirectInput® device.
SetEventNotification | Specifies an event that is to be set when the device state changes. It is also used to turn off event notification.
Unacquire | Releases access to the device.
WriteEffect | Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Properties

Property | Description
Caps | Obtains the capabilities of the DirectInputDevice object.
CreatedEffects | Enumerates all the currently created effects for this device. Effects created by Inputdevice9Createeffect are enumerated.
CurrentJoystickState | Retrieves immediate data from the joystick device.
CurrentMouseState | Retrieves immediate data from the mouse device.
DeviceInformation | Obtains information about the device's identity.
ForceFeedbackState | Retrieves the state of the device's force-feedback system.
ImageInformation | Retrieves information about a device image for use in a configuration property sheet.
Objects | Enumerates the input and output objects available on a device.
Properties | Retrieves information about the input device.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Device.Acquire()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Acquire Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains access to the input device.

Definition

Visual Basic .NET | Public Sub Acquire()
C# | public void Acquire();
Managed C++ | public: void Acquire();
JScript .NET | public function Acquire();


Device.BuildActionMap

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.BuildActionMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds an action map for the device and retrieves information about it.

Overload List

public void BuildActionMap(ActionFormat, ActionMapControl);
public void BuildActionMap(ActionFormat, string, ActionMapControl);


Device.BuildActionMap(ActionFormat,ActionMapControl)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.BuildActionMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds an action map for the device and retrieves information about it.

Definition

Visual Basic .NET Public Sub BuildActionMap( _
ByVal af As ActionFormat, _
ByVal flags As ActionMapControl _
)
C# public void BuildActionMap(
ActionFormat af,
ActionMapControl flags
);
Managed C++ public: void BuildActionMap(
ActionFormat *af,
ActionMapControl flags
);
JScript .NET public function BuildActionMap(
af : ActionFormat,
flags : ActionMapControl
);

Parameters

af | Microsoft.DirectX.DirectInput.ActionFormat.
flags | Microsoft.DirectX.DirectInput.ActionMapControl.


Device.BuildActionMap(ActionFormat,String,ActionMapControl)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.BuildActionMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds an action map for the device and retrieves information about it.

Definition

Visual Basic .NET Public Sub BuildActionMap( _
ByVal af As ActionFormat, _
ByVal userName As String, _
ByVal flags As ActionMapControl _
)
C# public void BuildActionMap(
ActionFormat af,
string userName,
ActionMapControl flags
);
Managed C++ public: void BuildActionMap(
ActionFormat *af,
String *userName,
ActionMapControl flags
);
JScript .NET public function BuildActionMap(
af : ActionFormat,
userName : String,
flags : ActionMapControl
);

Parameters

af | Microsoft.DirectX.DirectInput.ActionFormat.
userName | System.String.
flags | Microsoft.DirectX.DirectInput.ActionMapControl.


Device.Device(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal deviceGuid As Guid _
)
C# public Device(
Guid deviceGuid
);
Managed C++ public: Device(
Guid deviceGuid
);
JScript .NET public function Device(
deviceGuid : Guid
);

Parameters

deviceGuid System.Guid.


Device.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


Device.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Device.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Device();
Managed C++ | ~Device();
JScript .NET | protected override function Finalize();


Device.GetBufferedData()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetBufferedData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves buffered data from the device.

Definition

Visual Basic .NET | Public Function GetBufferedData() As BufferedDataCollection
C# | public BufferedDataCollection GetBufferedData();
Managed C++ | public: BufferedDataCollection* GetBufferedData();
JScript .NET | public function GetBufferedData() : BufferedDataCollection;

Return Value

Microsoft.DirectX.DirectInput.BufferedDataCollection .


Device.GetCurrentKeyboardState()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetCurrentKeyboardState Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves immediate data from the device.

Definition

Visual Basic .NET | Public Function GetCurrentKeyboardState() As KeyboardState
C# | public KeyboardState GetCurrentKeyboardState();
Managed C++ | public: KeyboardState* GetCurrentKeyboardState();
JScript .NET | public function GetCurrentKeyboardState() : KeyboardState;

Return Value

Microsoft.DirectX.DirectInput.KeyboardState .


Device.GetDeviceState(Type)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetDeviceState Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Function GetDeviceState( _
ByVal customFormatType As Type _
) As Object
C# public object GetDeviceState(
Type customFormatType
);
Managed C++ public: Object* GetDeviceState(
Type *customFormatType
);
JScript .NET public function GetDeviceState(
customFormatType : Type
) : Object;

Parameters

customFormatType System.Type.

Return Value

System.Object .


Device.GetEffectInformation(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetEffectInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Function GetEffectInformation( _
ByVal rguid As Guid _
) As EffectInformation
C# public EffectInformation GetEffectInformation(
Guid rguid
);
Managed C++ public: EffectInformation GetEffectInformation(
Guid rguid
);
JScript .NET public function GetEffectInformation(
rguid : Guid
) : EffectInformation;

Parameters

rguid System.Guid.

Return Value

Microsoft.DirectX.DirectInput.EffectInformation .


Device.GetEffects

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetEffects Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.

Overload List

public EffectList GetEffects(EffectType);
public EffectList GetEffects(string, FileEffectsFlags);


Device.GetEffects(String,FileEffectsFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetEffects Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.

Definition

Visual Basic .NET Public Function GetEffects( _
ByVal fileName As String, _
ByVal flags As FileEffectsFlags _
) As EffectList
C# public EffectList GetEffects(
string fileName,
FileEffectsFlags flags
);
Managed C++ public: EffectList* GetEffects(
String *fileName,
FileEffectsFlags flags
);
JScript .NET public function GetEffects(
fileName : String,
flags : FileEffectsFlags
) : EffectList;

Parameters

fileName | System.String.
flags | Microsoft.DirectX.DirectInput.FileEffectsFlags.

Return Value

Microsoft.DirectX.DirectInput.EffectList .


Device.GetEffects(EffectType)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetEffects Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.

Definition

Visual Basic .NET Public Function GetEffects( _
ByVal effType As EffectType _
) As EffectList
C# public EffectList GetEffects(
EffectType effType
);
Managed C++ public: EffectList* GetEffects(
EffectType effType
);
JScript .NET public function GetEffects(
effType : EffectType
) : EffectList;

Parameters

effType Microsoft.DirectX.DirectInput.EffectType.

Return Value

Microsoft.DirectX.DirectInput.EffectList .


Device.GetObjectInformation(Int32,ParameterHow)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetObjectInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about a device object, such as a button or axis.

Definition

Visual Basic .NET Public Function GetObjectInformation( _
ByVal obj As Integer, _
ByVal how As ParameterHow _
) As DeviceObjectInstance
C# public DeviceObjectInstance GetObjectInformation(
int obj,
ParameterHow how
);
Managed C++ public: DeviceObjectInstance GetObjectInformation(
int obj,
ParameterHow how
);
JScript .NET public function GetObjectInformation(
obj : int,
how : ParameterHow
) : DeviceObjectInstance;

Parameters

obj | System.Int32.
how | Microsoft.DirectX.DirectInput.ParameterHow.

Return Value

Microsoft.DirectX.DirectInput.DeviceObjectInstance .


Device.GetObjects(DeviceObjectTypeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetObjects Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates the input and output objects available on a device.

Definition

Visual Basic .NET Public Function GetObjects( _
ByVal flags As DeviceObjectTypeFlags _
) As DeviceObjectList
C# public DeviceObjectList GetObjects(
DeviceObjectTypeFlags flags
);
Managed C++ public: DeviceObjectList* GetObjects(
DeviceObjectTypeFlags flags
);
JScript .NET public function GetObjects(
flags : DeviceObjectTypeFlags
) : DeviceObjectList;

Parameters

flags Microsoft.DirectX.DirectInput.DeviceObjectTypeFlags.

Return Value

Microsoft.DirectX.DirectInput.DeviceObjectList .


Device.GetPressedKeys()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetPressedKeys Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the currently pressed keys on a keyboard device.

Definition

Visual Basic .NET | Public Function GetPressedKeys() As Key()
C# | public Key[] GetPressedKeys();
Managed C++ | public: Key GetPressedKeys() __gc[];
JScript .NET | public function GetPressedKeys() : Key[];

Return Value

Microsoft.DirectX.DirectInput.Key[].


Device.op_Equality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
Managed C++ public: static bool op_Equality(
Device *left,
Device *right
);
JScript .NET public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.DirectInput.Device. The Device structure to the left of the equality operator.
right | Microsoft.DirectX.DirectInput.Device. The Device structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Device.op_Inequality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
Managed C++ public: static bool op_Inequality(
Device *left,
Device *right
);
JScript .NET public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.DirectInput.Device. The Device structure to the left of the equality operator.
right | Microsoft.DirectX.DirectInput.Device. The Device structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Device.Poll()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Poll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves data from polled objects on a Microsoft® DirectInput® device. If the device does not require polling, calling this method has no effect. If a device that requires polling is not polled periodically, no new data is received from the device. Calling this method causes Microsoft® DirectInput® to update the device state, generate input events (if buffered data is enabled), and set notification events (if notification is enabled).

Definition

Visual Basic .NET | Public Sub Poll()
C# | public void Poll();
Managed C++ | public: void Poll();
JScript .NET | public function Poll();


Device.RunControlPanel

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.RunControlPanel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.

Overload List

public void RunControlPanel();
public void RunControlPanel(Control);


Device.RunControlPanel()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.RunControlPanel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.

Definition

Visual Basic .NET | Public Sub RunControlPanel()
C# | public void RunControlPanel();
Managed C++ | public: void RunControlPanel();
JScript .NET | public function RunControlPanel();


Device.RunControlPanel(Control)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.RunControlPanel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.

Definition

Visual Basic .NET Public Sub RunControlPanel( _
ByVal owner As Control _
)
C# public void RunControlPanel(
Control owner
);
Managed C++ public: void RunControlPanel(
Control *owner
);
JScript .NET public function RunControlPanel(
owner : Control
);

Parameters

owner System.Windows.Forms.Control.


Device.SendForceFeedbackCommand(ForceFeedbackCommand)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SendForceFeedbackCommand Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sends a command to the device's force-feedback system.

Definition

Visual Basic .NET Public Sub SendForceFeedbackCommand( _
ByVal command As ForceFeedbackCommand _
)
C# public void SendForceFeedbackCommand(
ForceFeedbackCommand command
);
Managed C++ public: void SendForceFeedbackCommand(
ForceFeedbackCommand command
);
JScript .NET public function SendForceFeedbackCommand(
command : ForceFeedbackCommand
);

Parameters

command Microsoft.DirectX.DirectInput.ForceFeedbackCommand.


Device.SendHardwareCommand(Int32,Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SendHardwareCommand Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sends a hardware-specific command to the force-feedback driver.

Definition

Visual Basic .NET Public Function SendHardwareCommand( _
ByVal command As Integer, _
ByVal data() As Byte _
) As Byte()
C# public byte[] SendHardwareCommand(
int command,
byte[] data
);
Managed C++ public: Byte SendHardwareCommand(
int command,
Byte data __gc[]
) __gc[];
JScript .NET public function SendHardwareCommand(
command : int,
data : byte[]
) : byte[];

Parameters

command | System.Int32.
data | System.Byte[].

Return Value

System.Byte[].


Device.SetActionMap

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetActionMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.

Overload List

public SetActionMapReturnCodes SetActionMap(ActionFormat, ApplyActionMap);
public SetActionMapReturnCodes SetActionMap(ActionFormat, string, ApplyActionMap);


Device.SetActionMap(ActionFormat,ApplyActionMap)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetActionMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.

Definition

Visual Basic .NET Public Function SetActionMap( _
ByVal af As ActionFormat, _
ByVal flags As ApplyActionMap _
) As SetActionMapReturnCodes
C# public SetActionMapReturnCodes SetActionMap(
ActionFormat af,
ApplyActionMap flags
);
Managed C++ public: SetActionMapReturnCodes SetActionMap(
ActionFormat *af,
ApplyActionMap flags
);
JScript .NET public function SetActionMap(
af : ActionFormat,
flags : ApplyActionMap
) : SetActionMapReturnCodes;

Parameters

af | Microsoft.DirectX.DirectInput.ActionFormat.
flags | Microsoft.DirectX.DirectInput.ApplyActionMap.

Return Value

Microsoft.DirectX.DirectInput.SetActionMapReturnCodes .


Device.SetActionMap(ActionFormat,String,ApplyActionMap)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetActionMap Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.

Definition

Visual Basic .NET Public Function SetActionMap( _
ByVal af As ActionFormat, _
ByVal userName As String, _
ByVal flags As ApplyActionMap _
) As SetActionMapReturnCodes
C# public SetActionMapReturnCodes SetActionMap(
ActionFormat af,
string userName,
ApplyActionMap flags
);
Managed C++ public: SetActionMapReturnCodes SetActionMap(
ActionFormat *af,
String *userName,
ApplyActionMap flags
);
JScript .NET public function SetActionMap(
af : ActionFormat,
userName : String,
flags : ApplyActionMap
) : SetActionMapReturnCodes;

Parameters

af | Microsoft.DirectX.DirectInput.ActionFormat.
userName | System.String.
flags | Microsoft.DirectX.DirectInput.ApplyActionMap.

Return Value

Microsoft.DirectX.DirectInput.SetActionMapReturnCodes .


Device.SetCooperativeLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Overload List

public void SetCooperativeLevel(Control, CooperativeLevelFlags);
public void SetCooperativeLevel(IntPtr, CooperativeLevelFlags);


Device.SetCooperativeLevel(Control,CooperativeLevelFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Definition

Visual Basic .NET Public Sub SetCooperativeLevel( _
ByVal parent As Control, _
ByVal flags As CooperativeLevelFlags _
)
C# public void SetCooperativeLevel(
Control parent,
CooperativeLevelFlags flags
);
Managed C++ public: void SetCooperativeLevel(
Control *parent,
CooperativeLevelFlags flags
);
JScript .NET public function SetCooperativeLevel(
parent : Control,
flags : CooperativeLevelFlags
);

Parameters

parent | System.Windows.Forms.Control.
flags | Microsoft.DirectX.DirectInput.CooperativeLevelFlags.


Device.SetCooperativeLevel(IntPtr,CooperativeLevelFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetCooperativeLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Definition

Visual Basic .NET Public Sub SetCooperativeLevel( _
ByVal hwnd As IntPtr, _
ByVal flags As CooperativeLevelFlags _
)
C# public void SetCooperativeLevel(
IntPtr hwnd,
CooperativeLevelFlags flags
);
Managed C++ public: void SetCooperativeLevel(
IntPtr hwnd,
CooperativeLevelFlags flags
);
JScript .NET public function SetCooperativeLevel(
hwnd : IntPtr,
flags : CooperativeLevelFlags
);

Parameters

hwnd | System.IntPtr.
flags | Microsoft.DirectX.DirectInput.CooperativeLevelFlags.


Device.SetDataFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetDataFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the data format for the Microsoft® DirectInput® device.

Overload List

public void SetDataFormat(DataFormat);
public void SetDataFormat(DeviceDataFormat);


Device.SetDataFormat(DeviceDataFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetDataFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the data format for the Microsoft® DirectInput® device.

Definition

Visual Basic .NET Public Sub SetDataFormat( _
ByVal df As DeviceDataFormat _
)
C# public void SetDataFormat(
DeviceDataFormat df
);
Managed C++ public: void SetDataFormat(
DeviceDataFormat df
);
JScript .NET public function SetDataFormat(
df : DeviceDataFormat
);

Parameters

df Microsoft.DirectX.DirectInput.DeviceDataFormat.


Device.SetDataFormat(DataFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetDataFormat Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the data format for the Microsoft® DirectInput® device.

Definition

Visual Basic .NET Public Sub SetDataFormat( _
ByVal df As DataFormat _
)
C# public void SetDataFormat(
DataFormat df
);
Managed C++ public: void SetDataFormat(
DataFormat df
);
JScript .NET public function SetDataFormat(
df : DataFormat
);

Parameters

df Microsoft.DirectX.DirectInput.DataFormat.


Device.SetEventNotification(WaitHandle)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SetEventNotification Method

 Language:
Note: This documentation is preliminary and is subject to change.

Specifies an event that is to be set when the device state changes. It is also used to turn off event notification.

Definition

Visual Basic .NET Public Sub SetEventNotification( _
ByVal deviceEvent As WaitHandle _
)
C# public void SetEventNotification(
WaitHandle deviceEvent
);
Managed C++ public: void SetEventNotification(
WaitHandle *deviceEvent
);
JScript .NET public function SetEventNotification(
deviceEvent : WaitHandle
);

Parameters

deviceEvent System.Threading.WaitHandle.


Device.Unacquire()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Unacquire Method

 Language:
Note: This documentation is preliminary and is subject to change.

Releases access to the device.

Definition

Visual Basic .NET | Public Sub Unacquire()
C# | public void Unacquire();
Managed C++ | public: void Unacquire();
JScript .NET | public function Unacquire();


Device.WriteEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.WriteEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Overload List

public void WriteEffect(Stream, FileEffect[]);
public void WriteEffect(Stream, FileEffect[], FileEffectsFlags);
public void WriteEffect(string, FileEffect[]);
public void WriteEffect(string, FileEffect[], FileEffectsFlags);


Device.WriteEffect(Stream,FileEffect[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.WriteEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic .NET Public Sub WriteEffect( _
ByVal stream As Stream, _
ByVal fileEffect() As FileEffect _
)
C# public void WriteEffect(
Stream stream,
FileEffect[] fileEffect
);
Managed C++ public: void WriteEffect(
Stream *stream,
FileEffect fileEffect __gc[]
);
JScript .NET public function WriteEffect(
stream : Stream,
fileEffect : FileEffect[]
);

Parameters

stream | System.IO.Stream.
fileEffect | Microsoft.DirectX.DirectInput.FileEffect[].


Device.WriteEffect(Stream,FileEffect[],FileEffectsFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.WriteEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic .NET Public Sub WriteEffect( _
ByVal stream As Stream, _
ByVal fileEffect() As FileEffect, _
ByVal flags As FileEffectsFlags _
)
C# public void WriteEffect(
Stream stream,
FileEffect[] fileEffect,
FileEffectsFlags flags
);
Managed C++ public: void WriteEffect(
Stream *stream,
FileEffect fileEffect __gc[],
FileEffectsFlags flags
);
JScript .NET public function WriteEffect(
stream : Stream,
fileEffect : FileEffect[],
flags : FileEffectsFlags
);

Parameters

stream | System.IO.Stream.
fileEffect | Microsoft.DirectX.DirectInput.FileEffect[].
flags | Microsoft.DirectX.DirectInput.FileEffectsFlags.


Device.WriteEffect(String,FileEffect[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.WriteEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic .NET Public Sub WriteEffect( _
ByVal fileName As String, _
ByVal fileEffect() As FileEffect _
)
C# public void WriteEffect(
string fileName,
FileEffect[] fileEffect
);
Managed C++ public: void WriteEffect(
String *fileName,
FileEffect fileEffect __gc[]
);
JScript .NET public function WriteEffect(
fileName : String,
fileEffect : FileEffect[]
);

Parameters

fileName | System.String.
fileEffect | Microsoft.DirectX.DirectInput.FileEffect[].


Device.WriteEffect(String,FileEffect[],FileEffectsFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.WriteEffect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic .NET Public Sub WriteEffect( _
ByVal fileName As String, _
ByVal fileEffect() As FileEffect, _
ByVal flags As FileEffectsFlags _
)
C# public void WriteEffect(
string fileName,
FileEffect[] fileEffect,
FileEffectsFlags flags
);
Managed C++ public: void WriteEffect(
String *fileName,
FileEffect fileEffect __gc[],
FileEffectsFlags flags
);
JScript .NET public function WriteEffect(
fileName : String,
fileEffect : FileEffect[],
flags : FileEffectsFlags
);

Parameters

fileName | System.String.
fileEffect | Microsoft.DirectX.DirectInput.FileEffect[].
flags | Microsoft.DirectX.DirectInput.FileEffectsFlags.


Device.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Obtains the capabilities of the DirectInputDevice object.

Definition

Visual Basic .NET | Public ReadOnly Property Caps As DeviceCaps
C# | public DeviceCaps Caps { get; }
Managed C++ | public: __property DeviceCaps get_Caps();
JScript .NET | public function get Caps() : DeviceCaps

Property Value

Microsoft.DirectX.DirectInput.DeviceCaps .

This property is read-only.


Device.CreatedEffects

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CreatedEffects Property

Language:
Note: This documentation is preliminary and is subject to change.

Enumerates all the currently created effects for this device. Effects created by Inputdevice9Createeffect are enumerated.

Definition

Visual Basic .NET | Public ReadOnly Property CreatedEffects As EffectList
C# | public EffectList CreatedEffects { get; }
Managed C++ | public: __property EffectList* get_CreatedEffects();
JScript .NET | public function get CreatedEffects() : EffectList

Property Value

Microsoft.DirectX.DirectInput.EffectList .

This property is read-only.


Device.CurrentJoystickState

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CurrentJoystickState Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves immediate data from the joystick device.

Definition

Visual Basic .NET | Public ReadOnly Property CurrentJoystickState As JoystickState
C# | public JoystickState CurrentJoystickState { get; }
Managed C++ | public: __property JoystickState get_CurrentJoystickState();
JScript .NET | public function get CurrentJoystickState() : JoystickState

Property Value

Microsoft.DirectX.DirectInput.JoystickState .

This property is read-only.


Device.CurrentMouseState

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.CurrentMouseState Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves immediate data from the mouse device.

Definition

Visual Basic .NET | Public ReadOnly Property CurrentMouseState As MouseState
C# | public MouseState CurrentMouseState { get; }
Managed C++ | public: __property MouseState get_CurrentMouseState();
JScript .NET | public function get CurrentMouseState() : MouseState

Property Value

Microsoft.DirectX.DirectInput.MouseState .

This property is read-only.


Device.DeviceInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.DeviceInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Obtains information about the device's identity.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceInformation As DeviceInstance
C# | public DeviceInstance DeviceInformation { get; }
Managed C++ | public: __property DeviceInstance get_DeviceInformation();
JScript .NET | public function get DeviceInformation() : DeviceInstance

Property Value

Microsoft.DirectX.DirectInput.DeviceInstance .

This property is read-only.


Device.ForceFeedbackState

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ForceFeedbackState Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the state of the device's force-feedback system.

Definition

Visual Basic .NET | Public ReadOnly Property ForceFeedbackState As ForceFeedbackStates
C# | public ForceFeedbackStates ForceFeedbackState { get; }
Managed C++ | public: __property ForceFeedbackStates get_ForceFeedbackState();
JScript .NET | public function get ForceFeedbackState() : ForceFeedbackStates

Property Value

Microsoft.DirectX.DirectInput.ForceFeedbackStates .

This property is read-only.


Device.ImageInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.ImageInformation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about a device image for use in a configuration property sheet.

Definition

Visual Basic .NET | Public ReadOnly Property ImageInformation As DeviceImageInformationHeader
C# | public DeviceImageInformationHeader ImageInformation { get; }
Managed C++ | public: __property DeviceImageInformationHeader get_ImageInformation();
JScript .NET | public function get ImageInformation() : DeviceImageInformationHeader

Property Value

Microsoft.DirectX.DirectInput.DeviceImageInformationHeader .

This property is read-only.


Device.Objects

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Objects Property

Language:
Note: This documentation is preliminary and is subject to change.

Enumerates the input and output objects available on a device.

Definition

Visual Basic .NET | Public ReadOnly Property Objects As DeviceObjectList
C# | public DeviceObjectList Objects { get; }
Managed C++ | public: __property DeviceObjectList* get_Objects();
JScript .NET | public function get Objects() : DeviceObjectList

Property Value

Microsoft.DirectX.DirectInput.DeviceObjectList .

This property is read-only.


Device.Properties

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Properties Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about the input device.

Definition

Visual Basic .NET | Public ReadOnly Property Properties As DeviceProperties
C# | public DeviceProperties Properties { get; }
Managed C++ | public: __property DeviceProperties* get_Properties();
JScript .NET | public function get Properties() : DeviceProperties

Property Value

Microsoft.DirectX.DirectInput.DeviceProperties .

This property is read-only.


Microsoft.DirectX.DirectInput.DeviceFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceFullException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device is full.

Definition

Visual Basic .NET Public Class DeviceFullException
Inherits InputException
C# | public class DeviceFullException : InputException
Managed C++ | public __gc class DeviceFullException : public InputException
JScript .NET | public class DeviceFullException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceFullException | Initializes a new instance of the object.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
DeviceFullException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceFullException.DeviceFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceFullException.DeviceFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public DeviceFullException();
protected DeviceFullException(SerializationInfo, StreamingContext);
public DeviceFullException(string);
public DeviceFullException(string, Exception);


DeviceFullException.DeviceFullException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceFullException.DeviceFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceFullException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceFullException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DeviceFullException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DeviceFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DeviceFullException.DeviceFullException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceFullException.DeviceFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceFullException(
string message,
Exception inner
);
Managed C++ public: DeviceFullException(
String *message,
Exception *inner
);
JScript .NET public function DeviceFullException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DeviceFullException.DeviceFullException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceFullException.DeviceFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DeviceFullException(
string message
);
Managed C++ public: DeviceFullException(
String *message
);
JScript .NET public function DeviceFullException(
message : String
);

Parameters

message System.String.


DeviceFullException.DeviceFullException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceFullException.DeviceFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceFullException();
Managed C++ | public: DeviceFullException();
JScript .NET | public function DeviceFullException();


Microsoft.DirectX.DirectInput.DeviceList

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceList Class

Language:
Note: This documentation is preliminary and is subject to change.

Collection of devices.

Definition

Visual Basic .NET NotInheritable Public Class DeviceList
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class DeviceList : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class DeviceList : public Object,
IEnumerable, IEnumerator
JScript .NET public class DeviceList extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Gets an enumerator for this collection.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

Property | Description
Count | Gets the number of elements.
Current | Gets the current element in the collection.

Inheritance Hierarchy

Object Leave Site
DeviceList

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceList.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceList.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets an enumerator for this collection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


DeviceList.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceList.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next element of the collection.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean .


DeviceList.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceList.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the enumerator to its initial position, which is before the first element in the collection.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();


DeviceList.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceList.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the number of elements.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


DeviceList.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceList.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the current element in the collection.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object .

This property is read-only.


Microsoft.DirectX.DirectInput.DeviceNotRegisteredException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotRegisteredException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device or device instance is not registered with DirectInput.

Definition

Visual Basic .NET Public Class DeviceNotRegisteredException
Inherits InputException
C# | public class DeviceNotRegisteredException : InputException
Managed C++ | public __gc class DeviceNotRegisteredException : public InputException
JScript .NET | public class DeviceNotRegisteredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceNotRegisteredException | Initializes a new instance of the object.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
DeviceNotRegisteredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceNotRegisteredException.DeviceNotRegisteredException

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public DeviceNotRegisteredException();
protected DeviceNotRegisteredException(SerializationInfo, StreamingContext);
public DeviceNotRegisteredException(string);
public DeviceNotRegisteredException(string, Exception);


DeviceNotRegisteredException.DeviceNotRegisteredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceNotRegisteredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DeviceNotRegisteredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DeviceNotRegisteredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DeviceNotRegisteredException.DeviceNotRegisteredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceNotRegisteredException(
string message,
Exception inner
);
Managed C++ public: DeviceNotRegisteredException(
String *message,
Exception *inner
);
JScript .NET public function DeviceNotRegisteredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DeviceNotRegisteredException.DeviceNotRegisteredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DeviceNotRegisteredException(
string message
);
Managed C++ public: DeviceNotRegisteredException(
String *message
);
JScript .NET public function DeviceNotRegisteredException(
message : String
);

Parameters

message System.String.


DeviceNotRegisteredException.DeviceNotRegisteredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceNotRegisteredException();
Managed C++ | public: DeviceNotRegisteredException();
JScript .NET | public function DeviceNotRegisteredException();


Microsoft.DirectX.DirectInput.DeviceObjectList

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectList Class

Language:
Note: This documentation is preliminary and is subject to change.

A collection of device objects.

Definition

Visual Basic .NET NotInheritable Public Class DeviceObjectList
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class DeviceObjectList : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class DeviceObjectList : public Object,
IEnumerable, IEnumerator
JScript .NET public class DeviceObjectList extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Gets an enumerator for this collection.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

Property | Description
Count | Gets the number of elements.
Current | Gets the current element in the collection.

Inheritance Hierarchy

Object Leave Site
DeviceObjectList

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceObjectList.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectList.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets an enumerator for this collection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


DeviceObjectList.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectList.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next element of the collection.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean .


DeviceObjectList.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectList.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the enumerator to its initial position, which is before the first element in the collection.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();


DeviceObjectList.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectList.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the number of elements.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


DeviceObjectList.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectList.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the current element in the collection.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object .

This property is read-only.


Microsoft.DirectX.DirectInput.DeviceProperties

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties Class

Language:
Note: This documentation is preliminary and is subject to change.

Various properties you can get or set on a device.

Definition

Visual Basic .NET Public Class DeviceProperties
Inherits Object
C# | public class DeviceProperties : Object
Managed C++ | public __gc class DeviceProperties : public Object
JScript .NET | public class DeviceProperties extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetApplicationData | Retrieves the application-defined value associated with an in-game action.
GetCalibrationPoints | Retrieves calibration points used for the adjustment of incoming raw data.
GetDeadZone | Retrieves a value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range.
GetGranularity | Retrieves the input granularity. Granularity represents the smallest distance over which the object reports movement. Most axis objects have a granularity of one; that is, all values are possible. Some axes have a larger granularity. For example, the wheel axis on a mouse can have a granularity of 20; that is, all reported changes in position are multiples of 20. In other words, when the user turns the wheel slowly, the device reports a position of 0, then 20, then 40, and so on. This is a read-only property.
GetKeyName | Retrieves the localized key name for a keyboard key
GetLogicalRange | Retrieves the range of the raw data returned for axes on a HID. Devices can return negative values.
GetPhysicalRange | Retrieves the range of data for axes as suggested by the manufacturer of a HID. Values can be negative. Normally DirectInput returns values from 0 through 0×FFFF, but the range can be made to conform to the manufacturer's suggested range by using the Range property.
GetRange | Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.
GetSaturation | Retrieves a value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone).
GetScanCode | Retrieves the scan code for a keyboard key.
SetApplicationData | Sets the application-defined value associated with an in-game action.
SetCalibrationPoints | Sets calibration points used for the adjustment of incoming raw data.
SetDeadZone | Sets the value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range. This setting can be applied to either the entire device or to a specific axis.
SetRange | Sets the range of values an object can possibly report.
SetSaturation | Sets the value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone). This setting can be applied to either the entire device or a specific axis.

Properties

Property | Description
AutoCenter | Specifies whether device objects are self centering. This setting applies to the entire device, rather than to any particular object.
AxisModeAbsolute | Gets or sets a value showing the the axis mode as absolute.
BufferSize | Sets the input buffer size.
ForceFeedbackGain | Sets the gain for the device.
ForceFeedbackLoad | Retrieves the memory load for a device.
JoystickId | Returns the instance number of a joystick.
PortDisplayName | Retrieves the human-readable display name of the port to which this device is connected. Not generally used by applications.
ProductName | Retrieves the friendly product name of the device.
TypeName | Predefined property that retrieves the type name of a device. For most game controllers, this is the registry key name under REGSTR_PATH_JOYOEM from which static device settings can be retrieved, but predefined joystick types have special names consisting of a number sign (#) followed by a character dependent on the type. This value might not be available for all devices.
UserName | Retrieves the user name for a user currently assigned to a device
VendorIdentityProductId | Read-only device property that retrieves the vendor identity (ID) and product ID of a HID device.

Inheritance Hierarchy

Object Leave Site
DeviceProperties

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceProperties.GetApplicationData(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetApplicationData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the application-defined value associated with an in-game action.

Definition

Visual Basic .NET Public Function GetApplicationData( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Object
C# public object GetApplicationData(
ParameterHow how,
int objectId
);
Managed C++ public: Object* GetApplicationData(
ParameterHow how,
int objectId
);
JScript .NET public function GetApplicationData(
how : ParameterHow,
objectId : int
) : Object;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

System.Object .


DeviceProperties.GetCalibrationPoints(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetCalibrationPoints Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves calibration points used for the adjustment of incoming raw data.

Definition

Visual Basic .NET Public Function GetCalibrationPoints( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As CalibrationPoint()
C# public CalibrationPoint[] GetCalibrationPoints(
ParameterHow how,
int objectId
);
Managed C++ public: CalibrationPoint GetCalibrationPoints(
ParameterHow how,
int objectId
) __gc[];
JScript .NET public function GetCalibrationPoints(
how : ParameterHow,
objectId : int
) : CalibrationPoint[];

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

Microsoft.DirectX.DirectInput.CalibrationPoint[].


DeviceProperties.GetDeadZone(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetDeadZone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range.

Definition

Visual Basic .NET Public Function GetDeadZone( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetDeadZone(
ParameterHow how,
int objectId
);
Managed C++ public: int GetDeadZone(
ParameterHow how,
int objectId
);
JScript .NET public function GetDeadZone(
how : ParameterHow,
objectId : int
) : int;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

System.Int32 .


DeviceProperties.GetGranularity(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetGranularity Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the input granularity. Granularity represents the smallest distance over which the object reports movement. Most axis objects have a granularity of one; that is, all values are possible. Some axes have a larger granularity. For example, the wheel axis on a mouse can have a granularity of 20; that is, all reported changes in position are multiples of 20. In other words, when the user turns the wheel slowly, the device reports a position of 0, then 20, then 40, and so on. This is a read-only property.

Definition

Visual Basic .NET Public Function GetGranularity( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetGranularity(
ParameterHow how,
int objectId
);
Managed C++ public: int GetGranularity(
ParameterHow how,
int objectId
);
JScript .NET public function GetGranularity(
how : ParameterHow,
objectId : int
) : int;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

System.Int32 .


DeviceProperties.GetKeyName(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetKeyName Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the localized key name for a keyboard key

Definition

Visual Basic .NET Public Function GetKeyName( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As String
C# public string GetKeyName(
ParameterHow how,
int objectId
);
Managed C++ public: String* GetKeyName(
ParameterHow how,
int objectId
);
JScript .NET public function GetKeyName(
how : ParameterHow,
objectId : int
) : String;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

System.String .


DeviceProperties.GetLogicalRange(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetLogicalRange Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the range of the raw data returned for axes on a HID. Devices can return negative values.

Definition

Visual Basic .NET Public Function GetLogicalRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As InputRange
C# public InputRange GetLogicalRange(
ParameterHow how,
int objectId
);
Managed C++ public: InputRange GetLogicalRange(
ParameterHow how,
int objectId
);
JScript .NET public function GetLogicalRange(
how : ParameterHow,
objectId : int
) : InputRange;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

Microsoft.DirectX.DirectInput.InputRange .


DeviceProperties.GetPhysicalRange(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetPhysicalRange Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the range of data for axes as suggested by the manufacturer of a HID. Values can be negative. Normally DirectInput returns values from 0 through 0×FFFF, but the range can be made to conform to the manufacturer's suggested range by using the Range property.

Definition

Visual Basic .NET Public Function GetPhysicalRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As InputRange
C# public InputRange GetPhysicalRange(
ParameterHow how,
int objectId
);
Managed C++ public: InputRange GetPhysicalRange(
ParameterHow how,
int objectId
);
JScript .NET public function GetPhysicalRange(
how : ParameterHow,
objectId : int
) : InputRange;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

Microsoft.DirectX.DirectInput.InputRange .


DeviceProperties.GetRange(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetRange Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.

Definition

Visual Basic .NET Public Function GetRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As InputRange
C# public InputRange GetRange(
ParameterHow how,
int objectId
);
Managed C++ public: InputRange GetRange(
ParameterHow how,
int objectId
);
JScript .NET public function GetRange(
how : ParameterHow,
objectId : int
) : InputRange;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

Microsoft.DirectX.DirectInput.InputRange .


DeviceProperties.GetSaturation(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetSaturation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone).

Definition

Visual Basic .NET Public Function GetSaturation( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetSaturation(
ParameterHow how,
int objectId
);
Managed C++ public: int GetSaturation(
ParameterHow how,
int objectId
);
JScript .NET public function GetSaturation(
how : ParameterHow,
objectId : int
) : int;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

System.Int32 .


DeviceProperties.GetScanCode(ParameterHow,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.GetScanCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the scan code for a keyboard key.

Definition

Visual Basic .NET Public Function GetScanCode( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetScanCode(
ParameterHow how,
int objectId
);
Managed C++ public: int GetScanCode(
ParameterHow how,
int objectId
);
JScript .NET public function GetScanCode(
how : ParameterHow,
objectId : int
) : int;

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.

Return Value

System.Int32 .


DeviceProperties.SetApplicationData(ParameterHow,Int32,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.SetApplicationData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the application-defined value associated with an in-game action.

Definition

Visual Basic .NET Public Sub SetApplicationData( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As Object _
)
C# public void SetApplicationData(
ParameterHow how,
int objectId,
object value
);
Managed C++ public: void SetApplicationData(
ParameterHow how,
int objectId,
Object *value
);
JScript .NET public function SetApplicationData(
how : ParameterHow,
objectId : int,
value : Object
);

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.
value | System.Object.


DeviceProperties.SetCalibrationPoints(ParameterHow,Int32,CalibrationPoint[])

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.SetCalibrationPoints Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets calibration points used for the adjustment of incoming raw data.

Definition

Visual Basic .NET Public Sub SetCalibrationPoints( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value() As CalibrationPoint _
)
C# public void SetCalibrationPoints(
ParameterHow how,
int objectId,
CalibrationPoint[] value
);
Managed C++ public: void SetCalibrationPoints(
ParameterHow how,
int objectId,
CalibrationPoint value __gc[]
);
JScript .NET public function SetCalibrationPoints(
how : ParameterHow,
objectId : int,
value : CalibrationPoint[]
);

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.
value | Microsoft.DirectX.DirectInput.CalibrationPoint[].


DeviceProperties.SetDeadZone(ParameterHow,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.SetDeadZone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range. This setting can be applied to either the entire device or to a specific axis.

Definition

Visual Basic .NET Public Sub SetDeadZone( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As Integer _
)
C# public void SetDeadZone(
ParameterHow how,
int objectId,
int value
);
Managed C++ public: void SetDeadZone(
ParameterHow how,
int objectId,
int value
);
JScript .NET public function SetDeadZone(
how : ParameterHow,
objectId : int,
value : int
);

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.
value | System.Int32.


DeviceProperties.SetRange(ParameterHow,Int32,InputRange)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.SetRange Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the range of values an object can possibly report.

Definition

Visual Basic .NET Public Sub SetRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As InputRange _
)
C# public void SetRange(
ParameterHow how,
int objectId,
InputRange value
);
Managed C++ public: void SetRange(
ParameterHow how,
int objectId,
InputRange value
);
JScript .NET public function SetRange(
how : ParameterHow,
objectId : int,
value : InputRange
);

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.
value | Microsoft.DirectX.DirectInput.InputRange.


DeviceProperties.SetSaturation(ParameterHow,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.SetSaturation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone). This setting can be applied to either the entire device or a specific axis.

Definition

Visual Basic .NET Public Sub SetSaturation( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As Integer _
)
C# public void SetSaturation(
ParameterHow how,
int objectId,
int value
);
Managed C++ public: void SetSaturation(
ParameterHow how,
int objectId,
int value
);
JScript .NET public function SetSaturation(
how : ParameterHow,
objectId : int,
value : int
);

Parameters

how | Microsoft.DirectX.DirectInput.ParameterHow.
objectId | System.Int32.
value | System.Int32.


DeviceProperties.AutoCenter

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.AutoCenter Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether device objects are self centering. This setting applies to the entire device, rather than to any particular object.

Definition

Visual Basic .NET | Public Property AutoCenter As Boolean
C# | public bool AutoCenter { get; set; }
Managed C++ public: __property bool get_AutoCenter();
public: __property void set_AutoCenter(bool);
JScript .NET public function get AutoCenter() : boolean
public function set AutoCenter(boolean);

Property Value

System.Boolean .

This property is read/write.


DeviceProperties.AxisModeAbsolute

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.AxisModeAbsolute Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets a value showing the the axis mode as absolute.

Definition

Visual Basic .NET | Public Property AxisModeAbsolute As Boolean
C# | public bool AxisModeAbsolute { get; set; }
Managed C++ public: __property bool get_AxisModeAbsolute();
public: __property void set_AxisModeAbsolute(bool);
JScript .NET public function get AxisModeAbsolute() : boolean
public function set AxisModeAbsolute(boolean);

Property Value

System.Boolean .

This property is read/write.


DeviceProperties.BufferSize

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.BufferSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Sets the input buffer size.

Definition

Visual Basic .NET | Public Property BufferSize As Integer
C# | public int BufferSize { get; set; }
Managed C++ public: __property int get_BufferSize();
public: __property void set_BufferSize(int);
JScript .NET public function get BufferSize() : int
public function set BufferSize(int);

Property Value

System.Int32 .

This property is read/write.


DeviceProperties.ForceFeedbackGain

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.ForceFeedbackGain Property

Language:
Note: This documentation is preliminary and is subject to change.

Sets the gain for the device.

Definition

Visual Basic .NET | Public Property ForceFeedbackGain As Integer
C# | public int ForceFeedbackGain { get; set; }
Managed C++ public: __property int get_ForceFeedbackGain();
public: __property void set_ForceFeedbackGain(int);
JScript .NET public function get ForceFeedbackGain() : int
public function set ForceFeedbackGain(int);

Property Value

System.Int32 .

This property is read/write.


DeviceProperties.ForceFeedbackLoad

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.ForceFeedbackLoad Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the memory load for a device.

Definition

Visual Basic .NET | Public ReadOnly Property ForceFeedbackLoad As Integer
C# | public int ForceFeedbackLoad { get; }
Managed C++ | public: __property int get_ForceFeedbackLoad();
JScript .NET | public function get ForceFeedbackLoad() : int

Property Value

System.Int32 .

This property is read-only.


DeviceProperties.JoystickId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.JoystickId Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns the instance number of a joystick.

Definition

Visual Basic .NET | Public ReadOnly Property JoystickId As Integer
C# | public int JoystickId { get; }
Managed C++ | public: __property int get_JoystickId();
JScript .NET | public function get JoystickId() : int

Property Value

System.Int32 .

This property is read-only.


DeviceProperties.PortDisplayName

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.PortDisplayName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the human-readable display name of the port to which this device is connected. Not generally used by applications.

Definition

Visual Basic .NET | Public ReadOnly Property PortDisplayName As String
C# | public string PortDisplayName { get; }
Managed C++ | public: __property String* get_PortDisplayName();
JScript .NET | public function get PortDisplayName() : String

Property Value

System.String .

This property is read-only.


DeviceProperties.ProductName

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.ProductName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the friendly product name of the device.

Definition

Visual Basic .NET | Public ReadOnly Property ProductName As String
C# | public string ProductName { get; }
Managed C++ | public: __property String* get_ProductName();
JScript .NET | public function get ProductName() : String

Property Value

System.String .

This property is read-only.


DeviceProperties.TypeName

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.TypeName Property

Language:
Note: This documentation is preliminary and is subject to change.

Predefined property that retrieves the type name of a device. For most game controllers, this is the registry key name under REGSTR_PATH_JOYOEM from which static device settings can be retrieved, but predefined joystick types have special names consisting of a number sign (#) followed by a character dependent on the type. This value might not be available for all devices.

Definition

Visual Basic .NET | Public ReadOnly Property TypeName As String
C# | public string TypeName { get; }
Managed C++ | public: __property String* get_TypeName();
JScript .NET | public function get TypeName() : String

Property Value

System.String .

This property is read-only.


DeviceProperties.UserName

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.UserName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the user name for a user currently assigned to a device

Definition

Visual Basic .NET | Public ReadOnly Property UserName As String
C# | public string UserName { get; }
Managed C++ | public: __property String* get_UserName();
JScript .NET | public function get UserName() : String

Property Value

System.String .

This property is read-only.


DeviceProperties.VendorIdentityProductId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceProperties.VendorIdentityProductId Property

Language:
Note: This documentation is preliminary and is subject to change.

Read-only device property that retrieves the vendor identity (ID) and product ID of a HID device.

Definition

Visual Basic .NET | Public ReadOnly Property VendorIdentityProductId As Integer
C# | public int VendorIdentityProductId { get; }
Managed C++ | public: __property int get_VendorIdentityProductId();
JScript .NET | public function get VendorIdentityProductId() : int

Property Value

System.Int32 .

This property is read-only.


Microsoft.DirectX.DirectInput.DInputHelper

Microsoft DirectX 9.0 SDK Update (October 2004)

DInputHelper Class

Language:
Note: This documentation is preliminary and is subject to change.

Utility class for DirectInput

Definition

Visual Basic .NET NotInheritable Public Class DInputHelper
Inherits Object
C# | public sealed class DInputHelper : Object
Managed C++ | public __gc __sealed class DInputHelper : public Object
JScript .NET | public class DInputHelper extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) ButtonAny | Any button. This is a function that takes a button number as its argument.
static (Shared in Visual Basic .NET) EnumCollection | An object that belongs to HID link collection number n.
static (Shared in Visual Basic .NET) GetInstance | Extracts the object instance number code from a data format type.
static (Shared in Visual Basic .NET) GetTypeCode
static (Shared in Visual Basic .NET) MakeInstance | Creates an instance identifier of a device object.
static (Shared in Visual Basic .NET) MarshalDeviceArrival | Marshal a device arrival during enumeration.

Inheritance Hierarchy

Object Leave Site
DInputHelper

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DInputHelper.ButtonAny(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DInputHelper.ButtonAny Method

 Language:
Note: This documentation is preliminary and is subject to change.

Any button. This is a function that takes a button number as its argument.

Definition

Visual Basic .NET Public Shared Function ButtonAny( _
ByVal instance As Integer _
) As Integer
C# public static int ButtonAny(
int instance
);
Managed C++ public: static int ButtonAny(
int instance
);
JScript .NET public static function ButtonAny(
instance : int
) : int;

Parameters

instance System.Int32.

Return Value

System.Int32 .


DInputHelper.EnumCollection(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DInputHelper.EnumCollection Method

 Language:
Note: This documentation is preliminary and is subject to change.

An object that belongs to HID link collection number n.

Definition

Visual Basic .NET Public Shared Function EnumCollection( _
ByVal n As Integer _
) As Integer
C# public static int EnumCollection(
int n
);
Managed C++ public: static int EnumCollection(
int n
);
JScript .NET public static function EnumCollection(
n : int
) : int;

Parameters

n System.Int32.

Return Value

System.Int32 .


DInputHelper.GetInstance(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DInputHelper.GetInstance Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extracts the object instance number code from a data format type.

Definition

Visual Basic .NET Public Shared Function GetInstance( _
ByVal n As Integer _
) As Integer
C# public static int GetInstance(
int n
);
Managed C++ public: static int GetInstance(
int n
);
JScript .NET public static function GetInstance(
n : int
) : int;

Parameters

n System.Int32.

Return Value

System.Int32 .


DInputHelper.GetTypeCode(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DInputHelper.GetTypeCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function GetTypeCode( _
ByVal n As Integer _
) As Integer
C# public static int GetTypeCode(
int n
);
Managed C++ public: static int GetTypeCode(
int n
);
JScript .NET public static function GetTypeCode(
n : int
) : int;

Parameters

n System.Int32.

Return Value

System.Int32 .


DInputHelper.MakeInstance(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DInputHelper.MakeInstance Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an instance identifier of a device object.

Definition

Visual Basic .NET Public Shared Function MakeInstance( _
ByVal n As Integer _
) As Integer
C# public static int MakeInstance(
int n
);
Managed C++ public: static int MakeInstance(
int n
);
JScript .NET public static function MakeInstance(
n : int
) : int;

Parameters

n System.Int32.

Return Value

System.Int32 .


DInputHelper.MarshalDeviceArrival(IntPtr,DeviceArrival)

Microsoft DirectX 9.0 SDK Update (October 2004)

DInputHelper.MarshalDeviceArrival Method

 Language:
Note: This documentation is preliminary and is subject to change.

Marshal a device arrival during enumeration.

Definition

Visual Basic .NET Public Shared Function MarshalDeviceArrival( _
ByVal arrival As IntPtr, _
ByRef da As DeviceArrival _
) As Boolean
C# public static bool MarshalDeviceArrival(
IntPtr arrival,
ref DeviceArrival da
);
Managed C++ public: static bool MarshalDeviceArrival(
IntPtr arrival,
DeviceArrival *da
);
JScript .NET public static function MarshalDeviceArrival(
arrival : IntPtr,
da : DeviceArrival
) : boolean;

Parameters

arrival | System.IntPtr.
da | Microsoft.DirectX.DirectInput.DeviceArrival.

Return Value

System.Boolean .


Microsoft.DirectX.DirectInput.EffectList

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectList Class

Language:
Note: This documentation is preliminary and is subject to change.

A collection of effects.

Definition

Visual Basic .NET NotInheritable Public Class EffectList
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class EffectList : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class EffectList : public Object,
IEnumerable, IEnumerator
JScript .NET public class EffectList extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Gets an enumerator for this collection.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

Property | Description
Count | Gets the number of elements.
Current | Gets the current element in the collection.

Inheritance Hierarchy

Object Leave Site
EffectList

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectList.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectList.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Gets an enumerator for this collection.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


EffectList.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectList.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances the enumerator to the next element of the collection.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean .


EffectList.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectList.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the enumerator to its initial position, which is before the first element in the collection.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();


EffectList.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectList.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the number of elements.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


EffectList.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectList.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the current element in the collection.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object .

This property is read-only.


Microsoft.DirectX.DirectInput.EffectObject

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject Class

Language:
Note: This documentation is preliminary and is subject to change.

Applications use the methods of the EffectObject to manage effects of force-feedback devices.

Definition

Visual Basic .NET Public Class EffectObject
Inherits MarshalByRefObject
Implements IDisposable
C# public class EffectObject : MarshalByRefObject,
IDisposable
Managed C++ public __gc class EffectObject : public MarshalByRefObject,
IDisposable
JScript .NET public class EffectObject extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by an object.
Download | Places the effect on the device. If the effect is already on the device, the existing effect is updated to match the values set by the method.
EffectObject | Initializes a new instance of the object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetParameters | Retrieves information about an effect.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
SendHardwareCommand | Sends a hardware-specific command to the driver.
SetParameters | Sets the characteristics of an effect.
Start | Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.
Stop | Stops playing an effect.
Unload | Removes the effect from the device. If the effect is playing, it is automatically stopped before it is unloaded.

Properties

Property | Description
EffectGuid | Retrieves the GUID for the effect represented by the Inputeffect object.
EffectStatus | Retrieves the status of an effect.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
EffectObject

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectObject.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


EffectObject.Download()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Download Method

 Language:
Note: This documentation is preliminary and is subject to change.

Places the effect on the device. If the effect is already on the device, the existing effect is updated to match the values set by the method.

Definition

Visual Basic .NET | Public Sub Download()
C# | public void Download();
Managed C++ | public: void Download();
JScript .NET | public function Download();


EffectObject.EffectObject

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.EffectObject Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public EffectObject(Guid, Device);
public EffectObject(Guid, Effect, Device);


EffectObject.EffectObject(Guid,Effect,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.EffectObject Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal eff As Guid, _
ByVal die As Effect, _
ByVal dev As Device _
)
C# public EffectObject(
Guid eff,
Effect die,
Device dev
);
Managed C++ public: EffectObject(
Guid eff,
Effect die,
Device *dev
);
JScript .NET public function EffectObject(
eff : Guid,
die : Effect,
dev : Device
);

Parameters

eff | System.Guid.
die | Microsoft.DirectX.DirectInput.Effect.
dev | Microsoft.DirectX.DirectInput.Device.


EffectObject.EffectObject(Guid,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.EffectObject Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal eff As Guid, _
ByVal dev As Device _
)
C# public EffectObject(
Guid eff,
Device dev
);
Managed C++ public: EffectObject(
Guid eff,
Device *dev
);
JScript .NET public function EffectObject(
eff : Guid,
dev : Device
);

Parameters

eff | System.Guid.
dev | Microsoft.DirectX.DirectInput.Device.


EffectObject.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


EffectObject.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~EffectObject();
Managed C++ | ~EffectObject();
JScript .NET | protected override function Finalize();


EffectObject.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


EffectObject.GetParameters(Effect,EffectParameterFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.GetParameters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves information about an effect.

Definition

Visual Basic .NET Public Sub GetParameters( _
ByRef eff As Effect, _
ByVal flags As EffectParameterFlags _
)
C# public void GetParameters(
ref Effect eff,
EffectParameterFlags flags
);
Managed C++ public: void GetParameters(
Effect *eff,
EffectParameterFlags flags
);
JScript .NET public function GetParameters(
eff : Effect,
flags : EffectParameterFlags
);

Parameters

eff | Microsoft.DirectX.DirectInput.Effect.
flags | Microsoft.DirectX.DirectInput.EffectParameterFlags.


EffectObject.op_Equality(EffectObject,EffectObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As EffectObject, _
ByVal right As EffectObject _
) As Boolean
C# public static bool op_Equality(
EffectObject left,
EffectObject right
);
Managed C++ public: static bool op_Equality(
EffectObject *left,
EffectObject *right
);
JScript .NET public static function op_Equality(
left : EffectObject,
right : EffectObject
) : boolean;

Parameters

left | Microsoft.DirectX.DirectInput.EffectObject. The EffectObject structure to the left of the equality operator.
right | Microsoft.DirectX.DirectInput.EffectObject. The EffectObject structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


EffectObject.op_Inequality(EffectObject,EffectObject)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As EffectObject, _
ByVal right As EffectObject _
) As Boolean
C# public static bool op_Inequality(
EffectObject left,
EffectObject right
);
Managed C++ public: static bool op_Inequality(
EffectObject *left,
EffectObject *right
);
JScript .NET public static function op_Inequality(
left : EffectObject,
right : EffectObject
) : boolean;

Parameters

left | Microsoft.DirectX.DirectInput.EffectObject. The EffectObject structure to the left of the equality operator.
right | Microsoft.DirectX.DirectInput.EffectObject. The EffectObject structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


EffectObject.SendHardwareCommand(Int32,Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.SendHardwareCommand Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sends a hardware-specific command to the driver.

Definition

Visual Basic .NET Public Function SendHardwareCommand( _
ByVal command As Integer, _
ByVal data() As Byte _
) As Byte()
C# public byte[] SendHardwareCommand(
int command,
byte[] data
);
Managed C++ public: Byte SendHardwareCommand(
int command,
Byte data __gc[]
) __gc[];
JScript .NET public function SendHardwareCommand(
command : int,
data : byte[]
) : byte[];

Parameters

command | System.Int32.
data | System.Byte[].

Return Value

System.Byte[].


EffectObject.SetParameters(Effect,EffectParameterFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.SetParameters Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the characteristics of an effect.

Definition

Visual Basic .NET Public Sub SetParameters( _
ByVal eff As Effect, _
ByVal flags As EffectParameterFlags _
)
C# public void SetParameters(
Effect eff,
EffectParameterFlags flags
);
Managed C++ public: void SetParameters(
Effect eff,
EffectParameterFlags flags
);
JScript .NET public function SetParameters(
eff : Effect,
flags : EffectParameterFlags
);

Parameters

eff | Microsoft.DirectX.DirectInput.Effect.
flags | Microsoft.DirectX.DirectInput.EffectParameterFlags.


EffectObject.Start

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Start Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.

Overload List

public void Start(int);
public void Start(int, EffectStartFlags);


EffectObject.Start(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Start Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.

Definition

Visual Basic .NET Public Sub Start( _
ByVal iterations As Integer _
)
C# public void Start(
int iterations
);
Managed C++ public: void Start(
int iterations
);
JScript .NET public function Start(
iterations : int
);

Parameters

iterations System.Int32.


EffectObject.Start(Int32,EffectStartFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Start Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.

Definition

Visual Basic .NET Public Sub Start( _
ByVal iterations As Integer, _
ByVal flags As EffectStartFlags _
)
C# public void Start(
int iterations,
EffectStartFlags flags
);
Managed C++ public: void Start(
int iterations,
EffectStartFlags flags
);
JScript .NET public function Start(
iterations : int,
flags : EffectStartFlags
);

Parameters

iterations | System.Int32.
flags | Microsoft.DirectX.DirectInput.EffectStartFlags.


EffectObject.Stop()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Stop Method

 Language:
Note: This documentation is preliminary and is subject to change.

Stops playing an effect.

Definition

Visual Basic .NET | Public Sub Stop()
C# | public void Stop();
Managed C++ | public: void Stop();
JScript .NET | public function Stop();


EffectObject.Unload()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.Unload Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the effect from the device. If the effect is playing, it is automatically stopped before it is unloaded.

Definition

Visual Basic .NET | Public Sub Unload()
C# | public void Unload();
Managed C++ | public: void Unload();
JScript .NET | public function Unload();


EffectObject.EffectGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.EffectGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the GUID for the effect represented by the Inputeffect object.

Definition

Visual Basic .NET | Public ReadOnly Property EffectGuid As Guid
C# | public Guid EffectGuid { get; }
Managed C++ | public: __property Guid get_EffectGuid();
JScript .NET | public function get EffectGuid() : Guid

Property Value

System.Guid .

This property is read-only.


EffectObject.EffectStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectObject.EffectStatus Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the status of an effect.

Definition

Visual Basic .NET | Public ReadOnly Property EffectStatus As EffectStatus
C# | public EffectStatus EffectStatus { get; }
Managed C++ | public: __property EffectStatus get_EffectStatus();
JScript .NET | public function get EffectStatus() : EffectStatus

Property Value

Microsoft.DirectX.DirectInput.EffectStatus .

This property is read-only.


Microsoft.DirectX.DirectInput.EffectPlayingException

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPlayingException Class

Language:
Note: This documentation is preliminary and is subject to change.

The parameters were updated in memory but were not downloaded to the device because the device does not support updating an effect while it is still playing.

Definition

Visual Basic .NET Public Class EffectPlayingException
Inherits InputException
C# | public class EffectPlayingException : InputException
Managed C++ | public __gc class EffectPlayingException : public InputException
JScript .NET | public class EffectPlayingException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
EffectPlayingException | Initializes a new instance of the object.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
EffectPlayingException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectPlayingException.EffectPlayingException

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPlayingException.EffectPlayingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public EffectPlayingException();
protected EffectPlayingException(SerializationInfo, StreamingContext);
public EffectPlayingException(string);
public EffectPlayingException(string, Exception);


EffectPlayingException.EffectPlayingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPlayingException.EffectPlayingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectPlayingException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected EffectPlayingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: EffectPlayingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function EffectPlayingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


EffectPlayingException.EffectPlayingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPlayingException.EffectPlayingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public EffectPlayingException(
string message,
Exception inner
);
Managed C++ public: EffectPlayingException(
String *message,
Exception *inner
);
JScript .NET public function EffectPlayingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


EffectPlayingException.EffectPlayingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPlayingException.EffectPlayingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public EffectPlayingException(
string message
);
Managed C++ public: EffectPlayingException(
String *message
);
JScript .NET public function EffectPlayingException(
message : String
);

Parameters

message System.String.


EffectPlayingException.EffectPlayingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectPlayingException.EffectPlayingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectPlayingException();
Managed C++ | public: EffectPlayingException();
JScript .NET | public function EffectPlayingException();


Microsoft.DirectX.DirectInput.ForceFeedbackGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid Class

Language:
Note: This documentation is preliminary and is subject to change.

Force feedback guid.

Definition

Visual Basic .NET NotInheritable Public Class ForceFeedbackGuid
Inherits Object
C# | public sealed class ForceFeedbackGuid : Object
Managed C++ | public __gc __sealed class ForceFeedbackGuid : public Object
JScript .NET | public class ForceFeedbackGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic .NET) ConstantForce
static (Shared in Visual Basic .NET) CustomForce
static (Shared in Visual Basic .NET) Damper
static (Shared in Visual Basic .NET) Friction
static (Shared in Visual Basic .NET) Inertia
static (Shared in Visual Basic .NET) RampForce
static (Shared in Visual Basic .NET) SawtoothDown
static (Shared in Visual Basic .NET) SawtoothUp
static (Shared in Visual Basic .NET) Sine
static (Shared in Visual Basic .NET) Spring
static (Shared in Visual Basic .NET) Square
static (Shared in Visual Basic .NET) Triangle

Inheritance Hierarchy

Object Leave Site
ForceFeedbackGuid

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ForceFeedbackGuid.ConstantForce

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.ConstantForce Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared ConstantForce As Guid
C# | public static Guid ConstantForce;
Managed C++ | public: static Guid ConstantForce;
JScript .NET | public static var ConstantForce : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.CustomForce

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.CustomForce Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared CustomForce As Guid
C# | public static Guid CustomForce;
Managed C++ | public: static Guid CustomForce;
JScript .NET | public static var CustomForce : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.Damper

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.Damper Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Damper As Guid
C# | public static Guid Damper;
Managed C++ | public: static Guid Damper;
JScript .NET | public static var Damper : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.Friction

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.Friction Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Friction As Guid
C# | public static Guid Friction;
Managed C++ | public: static Guid Friction;
JScript .NET | public static var Friction : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.Inertia

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.Inertia Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Inertia As Guid
C# | public static Guid Inertia;
Managed C++ | public: static Guid Inertia;
JScript .NET | public static var Inertia : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.RampForce

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.RampForce Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared RampForce As Guid
C# | public static Guid RampForce;
Managed C++ | public: static Guid RampForce;
JScript .NET | public static var RampForce : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.SawtoothDown

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.SawtoothDown Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared SawtoothDown As Guid
C# | public static Guid SawtoothDown;
Managed C++ | public: static Guid SawtoothDown;
JScript .NET | public static var SawtoothDown : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.SawtoothUp

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.SawtoothUp Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared SawtoothUp As Guid
C# | public static Guid SawtoothUp;
Managed C++ | public: static Guid SawtoothUp;
JScript .NET | public static var SawtoothUp : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.Sine

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.Sine Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Sine As Guid
C# | public static Guid Sine;
Managed C++ | public: static Guid Sine;
JScript .NET | public static var Sine : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.Spring

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.Spring Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Spring As Guid
C# | public static Guid Spring;
Managed C++ | public: static Guid Spring;
JScript .NET | public static var Spring : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.Square

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.Square Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Square As Guid
C# | public static Guid Square;
Managed C++ | public: static Guid Square;
JScript .NET | public static var Square : Guid

Field Value

System.Guid .

This field is read-only.


ForceFeedbackGuid.Triangle

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackGuid.Triangle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Triangle As Guid
C# | public static Guid Triangle;
Managed C++ | public: static Guid Triangle;
JScript .NET | public static var Triangle : Guid

Field Value

System.Guid .

This field is read-only.


Microsoft.DirectX.DirectInput.HasEffectsException

Microsoft DirectX 9.0 SDK Update (October 2004)

HasEffectsException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device cannot be reinitialized because effects are attached to it.

Definition

Visual Basic .NET Public Class HasEffectsException
Inherits InputException
C# | public class HasEffectsException : InputException
Managed C++ | public __gc class HasEffectsException : public InputException
JScript .NET | public class HasEffectsException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
HasEffectsException | Initializes a new instance of the object.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
HasEffectsException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HasEffectsException.HasEffectsException

Microsoft DirectX 9.0 SDK Update (October 2004)

HasEffectsException.HasEffectsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public HasEffectsException();
protected HasEffectsException(SerializationInfo, StreamingContext);
public HasEffectsException(string);
public HasEffectsException(string, Exception);


HasEffectsException.HasEffectsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

HasEffectsException.HasEffectsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the HasEffectsException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected HasEffectsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: HasEffectsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function HasEffectsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


HasEffectsException.HasEffectsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

HasEffectsException.HasEffectsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public HasEffectsException(
string message,
Exception inner
);
Managed C++ public: HasEffectsException(
String *message,
Exception *inner
);
JScript .NET public function HasEffectsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


HasEffectsException.HasEffectsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

HasEffectsException.HasEffectsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public HasEffectsException(
string message
);
Managed C++ public: HasEffectsException(
String *message
);
JScript .NET public function HasEffectsException(
message : String
);

Parameters

message System.String.


HasEffectsException.HasEffectsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

HasEffectsException.HasEffectsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public HasEffectsException();
Managed C++ | public: HasEffectsException();
JScript .NET | public function HasEffectsException();


Microsoft.DirectX.DirectInput.IncompleteEffectException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteEffectException Class

Language:
Note: This documentation is preliminary and is subject to change.

The effect could not be downloaded because essential information is missing. For example, no axes have been associated with the effect, or no type-specific information has been supplied.

Definition

Visual Basic .NET Public Class IncompleteEffectException
Inherits InputException
C# | public class IncompleteEffectException : InputException
Managed C++ | public __gc class IncompleteEffectException : public InputException
JScript .NET | public class IncompleteEffectException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompleteEffectException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
IncompleteEffectException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IncompleteEffectException.IncompleteEffectException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public IncompleteEffectException();
protected IncompleteEffectException(SerializationInfo, StreamingContext);
public IncompleteEffectException(string);
public IncompleteEffectException(string, Exception);


IncompleteEffectException.IncompleteEffectException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the IncompleteEffectException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompleteEffectException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: IncompleteEffectException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function IncompleteEffectException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


IncompleteEffectException.IncompleteEffectException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompleteEffectException(
string message,
Exception inner
);
Managed C++ public: IncompleteEffectException(
String *message,
Exception *inner
);
JScript .NET public function IncompleteEffectException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


IncompleteEffectException.IncompleteEffectException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public IncompleteEffectException(
string message
);
Managed C++ public: IncompleteEffectException(
String *message
);
JScript .NET public function IncompleteEffectException(
message : String
);

Parameters

message System.String.


IncompleteEffectException.IncompleteEffectException()

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public IncompleteEffectException();
Managed C++ | public: IncompleteEffectException();
JScript .NET | public function IncompleteEffectException();


Microsoft.DirectX.DirectInput.InputException

Microsoft DirectX 9.0 SDK Update (October 2004)

InputException Class

Language:
Note: This documentation is preliminary and is subject to change.

Base exception type for all DirectInput exceptions. Derives from DirectXException.

Definition

Visual Basic .NET Public Class InputException
Inherits DirectXException
C# | public class InputException : DirectXException
Managed C++ | public __gc class InputException : public DirectXException
JScript .NET | public class InputException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InputException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
AcquiredException
BadDriverVersionException
DeviceFullException
DeviceNotRegisteredException
EffectPlayingException
HasEffectsException
IncompleteEffectException
InputLostException
InsufficientPriveledgesException
MapFileFailException
MoreDataException
NotAcquiredException
NotBufferedException
NotDownloadedException
NotExclusivelyAcquiredException
NotFoundException
OtherApplicationHasPriorityException
PendingException
ReportFullException
UnpluggedException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputException.GetExceptionFromResultInternal(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputException.GetExceptionFromResultInternal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32.

Return Value

System.Exception .

Applies To

AcquiredException, BadDriverVersionException, DeviceFullException, DeviceNotRegisteredException, EffectPlayingException, HasEffectsException, IncompleteEffectException, InputLostException, InsufficientPriveledgesException, MapFileFailException, MoreDataException, NotAcquiredException, NotBufferedException, NotDownloadedException, NotExclusivelyAcquiredException, NotFoundException, OtherApplicationHasPriorityException, PendingException, ReportFullException, UnpluggedException, UnsupportedException


InputException.InputException

Microsoft DirectX 9.0 SDK Update (October 2004)

InputException.InputException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public InputException();
protected InputException(SerializationInfo, StreamingContext);
public InputException(string);
public InputException(string, Exception);


InputException.InputException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputException.InputException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InputException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InputException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InputException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InputException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InputException.InputException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputException.InputException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InputException(
string message,
Exception inner
);
Managed C++ public: InputException(
String *message,
Exception *inner
);
JScript .NET public function InputException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InputException.InputException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputException.InputException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InputException(
string message
);
Managed C++ public: InputException(
String *message
);
JScript .NET public function InputException(
message : String
);

Parameters

message System.String.


InputException.InputException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputException.InputException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public InputException();
Managed C++ | public: InputException();
JScript .NET | public function InputException();


Microsoft.DirectX.DirectInput.InputLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Access to the input device has been lost. It must be reacquired.

Definition

Visual Basic .NET Public Class InputLostException
Inherits InputException
C# | public class InputLostException : InputException
Managed C++ | public __gc class InputLostException : public InputException
JScript .NET | public class InputLostException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InputLostException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
InputLostException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputLostException.InputLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLostException.InputLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public InputLostException();
protected InputLostException(SerializationInfo, StreamingContext);
public InputLostException(string);
public InputLostException(string, Exception);


InputLostException.InputLostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLostException.InputLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InputLostException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InputLostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InputLostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InputLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InputLostException.InputLostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLostException.InputLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InputLostException(
string message,
Exception inner
);
Managed C++ public: InputLostException(
String *message,
Exception *inner
);
JScript .NET public function InputLostException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InputLostException.InputLostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLostException.InputLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InputLostException(
string message
);
Managed C++ public: InputLostException(
String *message
);
JScript .NET public function InputLostException(
message : String
);

Parameters

message System.String.


InputLostException.InputLostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLostException.InputLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public InputLostException();
Managed C++ | public: InputLostException();
JScript .NET | public function InputLostException();


Microsoft.DirectX.DirectInput.InsufficientPriveledgesException

Microsoft DirectX 9.0 SDK Update (October 2004)

InsufficientPriveledgesException Class

Language:
Note: This documentation is preliminary and is subject to change.

Insufficient priveledges for this call.

Definition

Visual Basic .NET Public Class InsufficientPriveledgesException
Inherits InputException
C# | public class InsufficientPriveledgesException : InputException
Managed C++ | public __gc class InsufficientPriveledgesException : public InputException
JScript .NET | public class InsufficientPriveledgesException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InsufficientPriveledgesException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
InsufficientPriveledgesException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InsufficientPriveledgesException.InsufficientPriveledgesException

Microsoft DirectX 9.0 SDK Update (October 2004)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public InsufficientPriveledgesException();
protected InsufficientPriveledgesException(SerializationInfo, StreamingContext);
public InsufficientPriveledgesException(string);
public InsufficientPriveledgesException(string, Exception);


InsufficientPriveledgesException.InsufficientPriveledgesException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the InsufficientPriveledgesException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InsufficientPriveledgesException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InsufficientPriveledgesException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InsufficientPriveledgesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InsufficientPriveledgesException.InsufficientPriveledgesException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InsufficientPriveledgesException(
string message,
Exception inner
);
Managed C++ public: InsufficientPriveledgesException(
String *message,
Exception *inner
);
JScript .NET public function InsufficientPriveledgesException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InsufficientPriveledgesException.InsufficientPriveledgesException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InsufficientPriveledgesException(
string message
);
Managed C++ public: InsufficientPriveledgesException(
String *message
);
JScript .NET public function InsufficientPriveledgesException(
message : String
);

Parameters

message System.String.


InsufficientPriveledgesException.InsufficientPriveledgesException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public InsufficientPriveledgesException();
Managed C++ | public: InsufficientPriveledgesException();
JScript .NET | public function InsufficientPriveledgesException();


Microsoft.DirectX.DirectInput.KeyboardState

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyboardState Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains the keyboard state.

Definition

Visual Basic .NET Public Class KeyboardState
Inherits Object
C# | public class KeyboardState : Object
Managed C++ | public __gc class KeyboardState : public Object
JScript .NET | public class KeyboardState extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property Description
Item

Inheritance Hierarchy

Object Leave Site
KeyboardState

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


KeyboardState.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

KeyboardState.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal index As Key _
) As Boolean
C# public bool this[
Key index
] { get; }
Managed C++ public: __property bool get_Item(
Key index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

System.Boolean .

This property is read-only.

Parameters

index Microsoft.DirectX.DirectInput.Key.


Microsoft.DirectX.DirectInput.Manager

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager Class

Language:
Note: This documentation is preliminary and is subject to change.

Applications use the methods of the Manager object to enumerate, create, and retrieve the status of Microsoft® DirectInput® devices.

Definition

Visual Basic .NET Public Class Manager
Inherits MarshalByRefObject
C# | public class Manager : MarshalByRefObject
Managed C++ | public __gc class Manager : public MarshalByRefObject
JScript .NET | public class Manager extends MarshalByRefObject

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) ConfigureDevices
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic .NET) FindDevice
static (Shared in Visual Basic .NET) GetDeviceAttached
static (Shared in Visual Basic .NET) GetDevices | Enumerates available devices.
static (Shared in Visual Basic .NET) RunControlPanel | Runs Control Panel to enable the user to install a new input device or modify configurations.

Properties

Property | Description
static (Shared in Visual Basic .NET) Devices | Enumerates available devices.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Manager

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Manager.ConfigureDevices(ConfigureDevicesParameters,ConfigureDevicesFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.ConfigureDevices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Sub ConfigureDevices( _
ByVal params As ConfigureDevicesParameters, _
ByVal flags As ConfigureDevicesFlags _
)
C# public static void ConfigureDevices(
ConfigureDevicesParameters params,
ConfigureDevicesFlags flags
);
Managed C++ public: static void ConfigureDevices(
ConfigureDevicesParameters *params,
ConfigureDevicesFlags flags
);
JScript .NET public static function ConfigureDevices(
params : ConfigureDevicesParameters,
flags : ConfigureDevicesFlags
);

Parameters

params | Microsoft.DirectX.DirectInput.ConfigureDevicesParameters.
flags | Microsoft.DirectX.DirectInput.ConfigureDevicesFlags.


Manager.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Manager();
Managed C++ | ~Manager();
JScript .NET | protected override function Finalize();


Manager.FindDevice(Guid,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.FindDevice Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function FindDevice( _
ByVal guidClass As Guid, _
ByVal name As String _
) As Guid
C# public static Guid FindDevice(
Guid guidClass,
string name
);
Managed C++ public: static Guid FindDevice(
Guid guidClass,
String *name
);
JScript .NET public static function FindDevice(
guidClass : Guid,
name : String
) : Guid;

Parameters

guidClass | System.Guid.
name | System.String.

Return Value

System.Guid .


Manager.GetDeviceAttached(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetDeviceAttached Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Shared Function GetDeviceAttached( _
ByVal rguid As Guid _
) As Boolean
C# public static bool GetDeviceAttached(
Guid rguid
);
Managed C++ public: static bool GetDeviceAttached(
Guid rguid
);
JScript .NET public static function GetDeviceAttached(
rguid : Guid
) : boolean;

Parameters

rguid System.Guid.

Return Value

System.Boolean .


Manager.GetDevices

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetDevices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates available devices.

Overload List

public static DeviceList GetDevices(ActionFormat, EnumDevicesBySemanticsFlags);
public static DeviceList GetDevices(DeviceClass, EnumDevicesFlags);
public static DeviceList GetDevices(DeviceType, EnumDevicesFlags);
public static DeviceList GetDevices(string, ActionFormat, EnumDevicesBySemanticsFlags);


Manager.GetDevices(ActionFormat,EnumDevicesBySemanticsFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetDevices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates available devices.

Definition

Visual Basic .NET Public Shared Function GetDevices( _
ByVal actionFormat As ActionFormat, _
ByVal flags As EnumDevicesBySemanticsFlags _
) As DeviceList
C# public static DeviceList GetDevices(
ActionFormat actionFormat,
EnumDevicesBySemanticsFlags flags
);
Managed C++ public: static DeviceList* GetDevices(
ActionFormat *actionFormat,
EnumDevicesBySemanticsFlags flags
);
JScript .NET public static function GetDevices(
actionFormat : ActionFormat,
flags : EnumDevicesBySemanticsFlags
) : DeviceList;

Parameters

actionFormat | Microsoft.DirectX.DirectInput.ActionFormat.
flags | Microsoft.DirectX.DirectInput.EnumDevicesBySemanticsFlags.

Return Value

Microsoft.DirectX.DirectInput.DeviceList .


Manager.GetDevices(String,ActionFormat,EnumDevicesBySemanticsFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetDevices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates available devices.

Definition

Visual Basic .NET Public Shared Function GetDevices( _
ByVal name As String, _
ByVal actionFormat As ActionFormat, _
ByVal flags As EnumDevicesBySemanticsFlags _
) As DeviceList
C# public static DeviceList GetDevices(
string name,
ActionFormat actionFormat,
EnumDevicesBySemanticsFlags flags
);
Managed C++ public: static DeviceList* GetDevices(
String *name,
ActionFormat *actionFormat,
EnumDevicesBySemanticsFlags flags
);
JScript .NET public static function GetDevices(
name : String,
actionFormat : ActionFormat,
flags : EnumDevicesBySemanticsFlags
) : DeviceList;

Parameters

name | System.String.
actionFormat | Microsoft.DirectX.DirectInput.ActionFormat.
flags | Microsoft.DirectX.DirectInput.EnumDevicesBySemanticsFlags.

Return Value

Microsoft.DirectX.DirectInput.DeviceList .


Manager.GetDevices(DeviceType,EnumDevicesFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetDevices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates available devices.

Definition

Visual Basic .NET Public Shared Function GetDevices( _
ByVal deviceType As DeviceType, _
ByVal flags As EnumDevicesFlags _
) As DeviceList
C# public static DeviceList GetDevices(
DeviceType deviceType,
EnumDevicesFlags flags
);
Managed C++ public: static DeviceList* GetDevices(
DeviceType deviceType,
EnumDevicesFlags flags
);
JScript .NET public static function GetDevices(
deviceType : DeviceType,
flags : EnumDevicesFlags
) : DeviceList;

Parameters

deviceType | Microsoft.DirectX.DirectInput.DeviceType.
flags | Microsoft.DirectX.DirectInput.EnumDevicesFlags.

Return Value

Microsoft.DirectX.DirectInput.DeviceList .


Manager.GetDevices(DeviceClass,EnumDevicesFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.GetDevices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Enumerates available devices.

Definition

Visual Basic .NET Public Shared Function GetDevices( _
ByVal deviceType As DeviceClass, _
ByVal flags As EnumDevicesFlags _
) As DeviceList
C# public static DeviceList GetDevices(
DeviceClass deviceType,
EnumDevicesFlags flags
);
Managed C++ public: static DeviceList* GetDevices(
DeviceClass deviceType,
EnumDevicesFlags flags
);
JScript .NET public static function GetDevices(
deviceType : DeviceClass,
flags : EnumDevicesFlags
) : DeviceList;

Parameters

deviceType | Microsoft.DirectX.DirectInput.DeviceClass.
flags | Microsoft.DirectX.DirectInput.EnumDevicesFlags.

Return Value

Microsoft.DirectX.DirectInput.DeviceList .


Manager.RunControlPanel

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.RunControlPanel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Runs Control Panel to enable the user to install a new input device or modify configurations.

Overload List

public static void RunControlPanel();
public static void RunControlPanel(Control);


Manager.RunControlPanel()

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.RunControlPanel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Runs Control Panel to enable the user to install a new input device or modify configurations.

Definition

Visual Basic .NET | Public Shared Sub RunControlPanel()
C# | public static void RunControlPanel();
Managed C++ | public: static void RunControlPanel();
JScript .NET | public static function RunControlPanel();


Manager.RunControlPanel(Control)

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.RunControlPanel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Runs Control Panel to enable the user to install a new input device or modify configurations.

Definition

Visual Basic .NET Public Shared Sub RunControlPanel( _
ByVal owner As Control _
)
C# public static void RunControlPanel(
Control owner
);
Managed C++ public: static void RunControlPanel(
Control *owner
);
JScript .NET public static function RunControlPanel(
owner : Control
);

Parameters

owner System.Windows.Forms.Control.


Manager.Devices

Microsoft DirectX 9.0 SDK Update (October 2004)

Manager.Devices Property

Language:
Note: This documentation is preliminary and is subject to change.

Enumerates available devices.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Devices As DeviceList
C# | public static DeviceList Devices { get; }
Managed C++ | public: __property static DeviceList* get_Devices();
JScript .NET | public static function get Devices() : DeviceList

Property Value

Microsoft.DirectX.DirectInput.DeviceList .

This property is read-only.


Microsoft.DirectX.DirectInput.MapFileFailException

Microsoft DirectX 9.0 SDK Update (October 2004)

MapFileFailException Class

Language:
Note: This documentation is preliminary and is subject to change.

An error has occurred either reading the vendor-supplied action-mapping file for the device or reading or writing the user configuration mapping file for the device.

Definition

Visual Basic .NET Public Class MapFileFailException
Inherits InputException
C# | public class MapFileFailException : InputException
Managed C++ | public __gc class MapFileFailException : public InputException
JScript .NET | public class MapFileFailException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MapFileFailException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
MapFileFailException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MapFileFailException.MapFileFailException

Microsoft DirectX 9.0 SDK Update (October 2004)

MapFileFailException.MapFileFailException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public MapFileFailException();
protected MapFileFailException(SerializationInfo, StreamingContext);
public MapFileFailException(string);
public MapFileFailException(string, Exception);


MapFileFailException.MapFileFailException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

MapFileFailException.MapFileFailException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MapFileFailException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MapFileFailException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: MapFileFailException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function MapFileFailException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


MapFileFailException.MapFileFailException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

MapFileFailException.MapFileFailException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MapFileFailException(
string message,
Exception inner
);
Managed C++ public: MapFileFailException(
String *message,
Exception *inner
);
JScript .NET public function MapFileFailException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


MapFileFailException.MapFileFailException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

MapFileFailException.MapFileFailException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public MapFileFailException(
string message
);
Managed C++ public: MapFileFailException(
String *message
);
JScript .NET public function MapFileFailException(
message : String
);

Parameters

message System.String.


MapFileFailException.MapFileFailException()

Microsoft DirectX 9.0 SDK Update (October 2004)

MapFileFailException.MapFileFailException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public MapFileFailException();
Managed C++ | public: MapFileFailException();
JScript .NET | public function MapFileFailException();


Microsoft.DirectX.DirectInput.MoreDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException Class

Language:
Note: This documentation is preliminary and is subject to change.

Not all the requested information fit into the buffer.

Definition

Visual Basic .NET Public Class MoreDataException
Inherits InputException
C# | public class MoreDataException : InputException
Managed C++ | public __gc class MoreDataException : public InputException
JScript .NET | public class MoreDataException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MoreDataException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
MoreDataException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MoreDataException.MoreDataException

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public MoreDataException();
protected MoreDataException(SerializationInfo, StreamingContext);
public MoreDataException(string);
public MoreDataException(string, Exception);


MoreDataException.MoreDataException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MoreDataException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: MoreDataException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function MoreDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


MoreDataException.MoreDataException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MoreDataException(
string message,
Exception inner
);
Managed C++ public: MoreDataException(
String *message,
Exception *inner
);
JScript .NET public function MoreDataException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


MoreDataException.MoreDataException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public MoreDataException(
string message
);
Managed C++ public: MoreDataException(
String *message
);
JScript .NET public function MoreDataException(
message : String
);

Parameters

message System.String.


MoreDataException.MoreDataException()

Microsoft DirectX 9.0 SDK Update (October 2004)

MoreDataException.MoreDataException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public MoreDataException();
Managed C++ | public: MoreDataException();
JScript .NET | public function MoreDataException();


Microsoft.DirectX.DirectInput.NotAcquiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAcquiredException Class

Language:
Note: This documentation is preliminary and is subject to change.

The operation cannot be performed unless the device is acquired.

Definition

Visual Basic .NET Public Class NotAcquiredException
Inherits InputException
C# | public class NotAcquiredException : InputException
Managed C++ | public __gc class NotAcquiredException : public InputException
JScript .NET | public class NotAcquiredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAcquiredException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotAcquiredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotAcquiredException.NotAcquiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAcquiredException.NotAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public NotAcquiredException();
protected NotAcquiredException(SerializationInfo, StreamingContext);
public NotAcquiredException(string);
public NotAcquiredException(string, Exception);


NotAcquiredException.NotAcquiredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAcquiredException.NotAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotAcquiredException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAcquiredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotAcquiredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotAcquiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotAcquiredException.NotAcquiredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAcquiredException.NotAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAcquiredException(
string message,
Exception inner
);
Managed C++ public: NotAcquiredException(
String *message,
Exception *inner
);
JScript .NET public function NotAcquiredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotAcquiredException.NotAcquiredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAcquiredException.NotAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotAcquiredException(
string message
);
Managed C++ public: NotAcquiredException(
String *message
);
JScript .NET public function NotAcquiredException(
message : String
);

Parameters

message System.String.


NotAcquiredException.NotAcquiredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAcquiredException.NotAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotAcquiredException();
Managed C++ | public: NotAcquiredException();
JScript .NET | public function NotAcquiredException();


Microsoft.DirectX.DirectInput.NotBufferedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException Class

Language:
Note: This documentation is preliminary and is subject to change.

The device is not buffered. Set the BufferSize property to enable buffering.

Definition

Visual Basic .NET Public Class NotBufferedException
Inherits InputException
C# | public class NotBufferedException : InputException
Managed C++ | public __gc class NotBufferedException : public InputException
JScript .NET | public class NotBufferedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotBufferedException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotBufferedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotBufferedException.NotBufferedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public NotBufferedException();
protected NotBufferedException(SerializationInfo, StreamingContext);
public NotBufferedException(string);
public NotBufferedException(string, Exception);


NotBufferedException.NotBufferedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotBufferedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotBufferedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotBufferedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotBufferedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotBufferedException.NotBufferedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotBufferedException(
string message,
Exception inner
);
Managed C++ public: NotBufferedException(
String *message,
Exception *inner
);
JScript .NET public function NotBufferedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotBufferedException.NotBufferedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotBufferedException(
string message
);
Managed C++ public: NotBufferedException(
String *message
);
JScript .NET public function NotBufferedException(
message : String
);

Parameters

message System.String.


NotBufferedException.NotBufferedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotBufferedException();
Managed C++ | public: NotBufferedException();
JScript .NET | public function NotBufferedException();


Microsoft.DirectX.DirectInput.NotDownloadedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotDownloadedException Class

Language:
Note: This documentation is preliminary and is subject to change.

The effect is not downloaded.

Definition

Visual Basic .NET Public Class NotDownloadedException
Inherits InputException
C# | public class NotDownloadedException : InputException
Managed C++ | public __gc class NotDownloadedException : public InputException
JScript .NET | public class NotDownloadedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotDownloadedException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotDownloadedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotDownloadedException.NotDownloadedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotDownloadedException.NotDownloadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public NotDownloadedException();
protected NotDownloadedException(SerializationInfo, StreamingContext);
public NotDownloadedException(string);
public NotDownloadedException(string, Exception);


NotDownloadedException.NotDownloadedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotDownloadedException.NotDownloadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotDownloadedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotDownloadedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotDownloadedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotDownloadedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotDownloadedException.NotDownloadedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotDownloadedException.NotDownloadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotDownloadedException(
string message,
Exception inner
);
Managed C++ public: NotDownloadedException(
String *message,
Exception *inner
);
JScript .NET public function NotDownloadedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotDownloadedException.NotDownloadedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotDownloadedException.NotDownloadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotDownloadedException(
string message
);
Managed C++ public: NotDownloadedException(
String *message
);
JScript .NET public function NotDownloadedException(
message : String
);

Parameters

message System.String.


NotDownloadedException.NotDownloadedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotDownloadedException.NotDownloadedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotDownloadedException();
Managed C++ | public: NotDownloadedException();
JScript .NET | public function NotDownloadedException();


Microsoft.DirectX.DirectInput.NotExclusivelyAcquiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotExclusivelyAcquiredException Class

Language:
Note: This documentation is preliminary and is subject to change.

The operation cannot be performed unless the device is acquired in Exclusive mode.

Definition

Visual Basic .NET Public Class NotExclusivelyAcquiredException
Inherits InputException
C# | public class NotExclusivelyAcquiredException : InputException
Managed C++ | public __gc class NotExclusivelyAcquiredException : public InputException
JScript .NET | public class NotExclusivelyAcquiredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotExclusivelyAcquiredException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotExclusivelyAcquiredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public NotExclusivelyAcquiredException();
protected NotExclusivelyAcquiredException(SerializationInfo, StreamingContext);
public NotExclusivelyAcquiredException(string);
public NotExclusivelyAcquiredException(string, Exception);


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotExclusivelyAcquiredException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotExclusivelyAcquiredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotExclusivelyAcquiredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotExclusivelyAcquiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotExclusivelyAcquiredException(
string message,
Exception inner
);
Managed C++ public: NotExclusivelyAcquiredException(
String *message,
Exception *inner
);
JScript .NET public function NotExclusivelyAcquiredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotExclusivelyAcquiredException(
string message
);
Managed C++ public: NotExclusivelyAcquiredException(
String *message
);
JScript .NET public function NotExclusivelyAcquiredException(
message : String
);

Parameters

message System.String.


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotExclusivelyAcquiredException();
Managed C++ | public: NotExclusivelyAcquiredException();
JScript .NET | public function NotExclusivelyAcquiredException();


Microsoft.DirectX.DirectInput.NotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException Class

Language:
Note: This documentation is preliminary and is subject to change.

The requested object does not exist.

Definition

Visual Basic .NET Public Class NotFoundException
Inherits InputException
C# | public class NotFoundException : InputException
Managed C++ | public __gc class NotFoundException : public InputException
JScript .NET | public class NotFoundException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFoundException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotFoundException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotFoundException.NotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public NotFoundException();
protected NotFoundException(SerializationInfo, StreamingContext);
public NotFoundException(string);
public NotFoundException(string, Exception);


NotFoundException.NotFoundException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFoundException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotFoundException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotFoundException.NotFoundException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFoundException(
string message,
Exception inner
);
Managed C++ public: NotFoundException(
String *message,
Exception *inner
);
JScript .NET public function NotFoundException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotFoundException.NotFoundException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotFoundException(
string message
);
Managed C++ public: NotFoundException(
String *message
);
JScript .NET public function NotFoundException(
message : String
);

Parameters

message System.String.


NotFoundException.NotFoundException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotFoundException.NotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotFoundException();
Managed C++ | public: NotFoundException();
JScript .NET | public function NotFoundException();


Microsoft.DirectX.DirectInput.ObjectTypeGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid Class

Language:
Note: This documentation is preliminary and is subject to change.

Object type guid.

Definition

Visual Basic .NET NotInheritable Public Class ObjectTypeGuid
Inherits Object
C# | public sealed class ObjectTypeGuid : Object
Managed C++ | public __gc __sealed class ObjectTypeGuid : public Object
JScript .NET | public class ObjectTypeGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic .NET) Button
static (Shared in Visual Basic .NET) Key
static (Shared in Visual Basic .NET) PointOfView
static (Shared in Visual Basic .NET) RxAxis
static (Shared in Visual Basic .NET) RyAxis
static (Shared in Visual Basic .NET) RzAxis
static (Shared in Visual Basic .NET) Slider
static (Shared in Visual Basic .NET) Unknown
static (Shared in Visual Basic .NET) XAxis
static (Shared in Visual Basic .NET) YAxis
static (Shared in Visual Basic .NET) ZAxis

Inheritance Hierarchy

Object Leave Site
ObjectTypeGuid

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ObjectTypeGuid.Button

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.Button Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Button As Guid
C# | public static Guid Button;
Managed C++ | public: static Guid Button;
JScript .NET | public static var Button : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.Key

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.Key Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Key As Guid
C# | public static Guid Key;
Managed C++ | public: static Guid Key;
JScript .NET | public static var Key : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.PointOfView

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.PointOfView Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared PointOfView As Guid
C# | public static Guid PointOfView;
Managed C++ | public: static Guid PointOfView;
JScript .NET | public static var PointOfView : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.RxAxis

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.RxAxis Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared RxAxis As Guid
C# | public static Guid RxAxis;
Managed C++ | public: static Guid RxAxis;
JScript .NET | public static var RxAxis : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.RyAxis

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.RyAxis Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared RyAxis As Guid
C# | public static Guid RyAxis;
Managed C++ | public: static Guid RyAxis;
JScript .NET | public static var RyAxis : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.RzAxis

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.RzAxis Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared RzAxis As Guid
C# | public static Guid RzAxis;
Managed C++ | public: static Guid RzAxis;
JScript .NET | public static var RzAxis : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.Slider

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.Slider Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Slider As Guid
C# | public static Guid Slider;
Managed C++ | public: static Guid Slider;
JScript .NET | public static var Slider : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.Unknown

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.Unknown Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Unknown As Guid
C# | public static Guid Unknown;
Managed C++ | public: static Guid Unknown;
JScript .NET | public static var Unknown : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.XAxis

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.XAxis Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared XAxis As Guid
C# | public static Guid XAxis;
Managed C++ | public: static Guid XAxis;
JScript .NET | public static var XAxis : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.YAxis

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.YAxis Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared YAxis As Guid
C# | public static Guid YAxis;
Managed C++ | public: static Guid YAxis;
JScript .NET | public static var YAxis : Guid

Field Value

System.Guid .

This field is read-only.


ObjectTypeGuid.ZAxis

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectTypeGuid.ZAxis Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared ZAxis As Guid
C# | public static Guid ZAxis;
Managed C++ | public: static Guid ZAxis;
JScript .NET | public static var ZAxis : Guid

Field Value

System.Guid .

This field is read-only.


Microsoft.DirectX.DirectInput.OtherApplicationHasPriorityException

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException Class

Language:
Note: This documentation is preliminary and is subject to change.

Another application has a higher priority level, preventing this call from succeeding.

Definition

Visual Basic .NET Public Class OtherApplicationHasPriorityException
Inherits InputException
C# | public class OtherApplicationHasPriorityException : InputException
Managed C++ | public __gc class OtherApplicationHasPriorityException : public InputException
JScript .NET | public class OtherApplicationHasPriorityException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OtherApplicationHasPriorityException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
OtherApplicationHasPriorityException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public OtherApplicationHasPriorityException();
protected OtherApplicationHasPriorityException(SerializationInfo, StreamingContext);
public OtherApplicationHasPriorityException(string);
public OtherApplicationHasPriorityException(string, Exception);


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OtherApplicationHasPriorityException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OtherApplicationHasPriorityException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OtherApplicationHasPriorityException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OtherApplicationHasPriorityException(
string message,
Exception inner
);
Managed C++ public: OtherApplicationHasPriorityException(
String *message,
Exception *inner
);
JScript .NET public function OtherApplicationHasPriorityException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OtherApplicationHasPriorityException(
string message
);
Managed C++ public: OtherApplicationHasPriorityException(
String *message
);
JScript .NET public function OtherApplicationHasPriorityException(
message : String
);

Parameters

message System.String.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public OtherApplicationHasPriorityException();
Managed C++ | public: OtherApplicationHasPriorityException();
JScript .NET | public function OtherApplicationHasPriorityException();


Microsoft.DirectX.DirectInput.PendingException

Microsoft DirectX 9.0 SDK Update (October 2004)

PendingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Data is not yet available.

Definition

Visual Basic .NET Public Class PendingException
Inherits InputException
C# | public class PendingException : InputException
Managed C++ | public __gc class PendingException : public InputException
JScript .NET | public class PendingException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PendingException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
PendingException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PendingException.PendingException

Microsoft DirectX 9.0 SDK Update (October 2004)

PendingException.PendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public PendingException();
protected PendingException(SerializationInfo, StreamingContext);
public PendingException(string);
public PendingException(string, Exception);


PendingException.PendingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PendingException.PendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PendingException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PendingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PendingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PendingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PendingException.PendingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PendingException.PendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PendingException(
string message,
Exception inner
);
Managed C++ public: PendingException(
String *message,
Exception *inner
);
JScript .NET public function PendingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PendingException.PendingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PendingException.PendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PendingException(
string message
);
Managed C++ public: PendingException(
String *message
);
JScript .NET public function PendingException(
message : String
);

Parameters

message System.String.


PendingException.PendingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PendingException.PendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public PendingException();
Managed C++ | public: PendingException();
JScript .NET | public function PendingException();


Microsoft.DirectX.DirectInput.ReportFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

ReportFullException Class

Language:
Note: This documentation is preliminary and is subject to change.

More information was requested to be sent than can be sent to the device.

Definition

Visual Basic .NET Public Class ReportFullException
Inherits InputException
C# | public class ReportFullException : InputException
Managed C++ | public __gc class ReportFullException : public InputException
JScript .NET | public class ReportFullException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ReportFullException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
ReportFullException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReportFullException.ReportFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

ReportFullException.ReportFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public ReportFullException();
protected ReportFullException(SerializationInfo, StreamingContext);
public ReportFullException(string);
public ReportFullException(string, Exception);


ReportFullException.ReportFullException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ReportFullException.ReportFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ReportFullException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ReportFullException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ReportFullException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ReportFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ReportFullException.ReportFullException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ReportFullException.ReportFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ReportFullException(
string message,
Exception inner
);
Managed C++ public: ReportFullException(
String *message,
Exception *inner
);
JScript .NET public function ReportFullException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ReportFullException.ReportFullException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ReportFullException.ReportFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ReportFullException(
string message
);
Managed C++ public: ReportFullException(
String *message
);
JScript .NET public function ReportFullException(
message : String
);

Parameters

message System.String.


ReportFullException.ReportFullException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ReportFullException.ReportFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public ReportFullException();
Managed C++ | public: ReportFullException();
JScript .NET | public function ReportFullException();


Microsoft.DirectX.DirectInput.SystemGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

SystemGuid Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains system guids for common device types.

Definition

Visual Basic .NET NotInheritable Public Class SystemGuid
Inherits Object
C# | public sealed class SystemGuid : Object
Managed C++ | public __gc __sealed class SystemGuid : public Object
JScript .NET | public class SystemGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic .NET) Keyboard
static (Shared in Visual Basic .NET) Mouse

Inheritance Hierarchy

Object Leave Site
SystemGuid

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SystemGuid.Keyboard

Microsoft DirectX 9.0 SDK Update (October 2004)

SystemGuid.Keyboard Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Keyboard As Guid
C# | public static Guid Keyboard;
Managed C++ | public: static Guid Keyboard;
JScript .NET | public static var Keyboard : Guid

Field Value

System.Guid .

This field is read-only.


SystemGuid.Mouse

Microsoft DirectX 9.0 SDK Update (October 2004)

SystemGuid.Mouse Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Shared Mouse As Guid
C# | public static Guid Mouse;
Managed C++ | public: static Guid Mouse;
JScript .NET | public static var Mouse : Guid

Field Value

System.Guid .

This field is read-only.


Microsoft.DirectX.DirectInput.UnpluggedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnpluggedException Class

Language:
Note: This documentation is preliminary and is subject to change.

The operation could not be completed because the device is not plugged in.

Definition

Visual Basic .NET Public Class UnpluggedException
Inherits InputException
C# | public class UnpluggedException : InputException
Managed C++ | public __gc class UnpluggedException : public InputException
JScript .NET | public class UnpluggedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnpluggedException | Initializes a new instance of the object.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
UnpluggedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnpluggedException.UnpluggedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnpluggedException.UnpluggedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public UnpluggedException();
protected UnpluggedException(SerializationInfo, StreamingContext);
public UnpluggedException(string);
public UnpluggedException(string, Exception);


UnpluggedException.UnpluggedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnpluggedException.UnpluggedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnpluggedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnpluggedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnpluggedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnpluggedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UnpluggedException.UnpluggedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnpluggedException.UnpluggedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnpluggedException(
string message,
Exception inner
);
Managed C++ public: UnpluggedException(
String *message,
Exception *inner
);
JScript .NET public function UnpluggedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UnpluggedException.UnpluggedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnpluggedException.UnpluggedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnpluggedException(
string message
);
Managed C++ public: UnpluggedException(
String *message
);
JScript .NET public function UnpluggedException(
message : String
);

Parameters

message System.String.


UnpluggedException.UnpluggedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnpluggedException.UnpluggedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnpluggedException();
Managed C++ | public: UnpluggedException();
JScript .NET | public function UnpluggedException();


Microsoft.DirectX.DirectInput.UnsupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException Class

Language:
Note: This documentation is preliminary and is subject to change.

The function called is not supported at this time.

Definition

Visual Basic .NET Public Class UnsupportedException
Inherits InputException
C# | public class UnsupportedException : InputException
Managed C++ | public __gc class UnsupportedException : public InputException
JScript .NET | public class UnsupportedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedException | Initializes a new instance of the object.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedException.UnsupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public UnsupportedException();
protected UnsupportedException(SerializationInfo, StreamingContext);
public UnsupportedException(string);
public UnsupportedException(string, Exception);


UnsupportedException.UnsupportedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UnsupportedException.UnsupportedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedException(
string message,
Exception inner
);
Managed C++ public: UnsupportedException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UnsupportedException.UnsupportedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedException(
string message
);
Managed C++ public: UnsupportedException(
String *message
);
JScript .NET public function UnsupportedException(
message : String
);

Parameters

message System.String.


UnsupportedException.UnsupportedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedException();
Managed C++ | public: UnsupportedException();
JScript .NET | public function UnsupportedException();


ActionAttributeFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionAttributeFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Flags used to request specific attributes or processing.

Definition

Visual Basic .NET | Public Enum ActionAttributeFlags
C# | public enum ActionAttributeFlags
Managed C++ | __value public enum ActionAttributeFlags
JScript .NET | public enum ActionAttributeFlags

Members

Member | Value | Description
NoAttribute | 0
AppFixed | 16
NoRange | 8
AppNoMap | 4
AppMapped | 2
ForceFeedback | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ActionMapControl

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionMapControl Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Flags to control the mapping.

Definition

Visual Basic .NET | Public Enum ActionMapControl
C# | public enum ActionMapControl
Managed C++ | __value public enum ActionMapControl
JScript .NET | public enum ActionMapControl

Members

Member | Value | Description
Initialize | 2
HardwareDefaults | 4
Preserve | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ActionMechanism

Microsoft DirectX 9.0 SDK Update (October 2004)

ActionMechanism Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Mapping mechanism used by DirectInput to configure the action.

Definition

Visual Basic .NET | Public Enum ActionMechanism
C# | public enum ActionMechanism
Managed C++ | __value public enum ActionMechanism
JScript .NET | public enum ActionMechanism

Members

Member | Value | Description
Error | -2147483648
HardwareDefault | 8
HardwareApp | 4
AppRequested | 2
UserConfig | 1
Unmapped | 0
Default | 32

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Any

Microsoft DirectX 9.0 SDK Update (October 2004)

Any Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The following constants are used in the dwSemantic member of the Diaction structure to map an action to any matching control on the device.

Definition

Visual Basic .NET | Public Enum Any
C# | public enum Any
Managed C++ | __value public enum Any
JScript .NET | public enum Any

Members

Member | Value | Description
PointOfView3 | -16759293
PointOfView2 | -16759294
PointOfView1 | -16759295
PointOfView4 | -16759292
Axis4 | -16760316
Axis3 | -16760317 | Any axis
Axis2 | -16760318 | Any axis
Axis1 | -16760319 | Any axis
AxisS2 | -16432638 | Any s-axis
AxisS1 | -16432639 | Any s-axis
AxisC2 | -16465406 | Any clutch
AxisC1 | -16465407 | Any clutch
AxisB2 | -16498174 | Any brake
AxisB1 | -16498175 | Any brake
AxisA2 | -16530942 | Any axis
AxisA1 | -16530943 | Any accelerator
AxisV2 | -16563710 | Any v-axis
AxisV1 | -16563711 | Any v-axis
AxisU2 | -16596478 | Any u-axis
AxisU1 | -16596479 | Any u-axis
AxisR2 | -16629246 | Any r-axis
AxisR1 | -16629247 | Any r-axis
AxisZ2 | -16662014 | Any z-axis
AxisZ1 | -16662015 | Any z-axis
AxisY2 | -16694782 | Any axis
AxisY1 | -16694783 | Any axis
AxisX2 | -16727550 | Any x-axis
AxisX1 | -16727551 | Any x-axis

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ApplyActionMap

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplyActionMap Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Value that specifies how the action map is applied.

Definition

Visual Basic .NET | Public Enum ApplyActionMap
C# | public enum ApplyActionMap
Managed C++ | __value public enum ApplyActionMap
JScript .NET | public enum ApplyActionMap

Members

Member | Value | Description
ForceSave | 2
NoUser | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ArcadePlatform

Microsoft DirectX 9.0 SDK Update (October 2004)

ArcadePlatform Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The genre contains controls for an arcade-style game.

Definition

Visual Basic .NET | Public Enum ArcadePlatform
C# | public enum ArcadePlatform
Managed C++ | __value public enum ArcadePlatform
JScript .NET | public enum ArcadePlatform

Members

Member | Value | Description
ButtonPause | 570443004
ButtonDevice | 570443006
ButtonViewRightLink | 570934508
ButtonViewLeftLink | 570934500
ButtonViewDownLink | 570934504
ButtonViewUpLink | 570934496
ButtonBackLink | 570508520
ButtonForwardLink | 570508512
ButtonRightLink | 570475756
ButtonLeftLink | 570475748
ButtonFireSecondary | 570442758
HatSwitchView | 570443265
ButtonMenu | 570426621
ButtonSelect | 570426373
ButtonSpecial | 570426372
ButtonCrouch | 570426371
ButtonFire | 570426370
ButtonJump | 570426369
AxisMove | 570491394
AxisLateral | 570458625
ArcadePlatform | 570425344

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ArcadeSideToSide

Microsoft DirectX 9.0 SDK Update (October 2004)

ArcadeSideToSide Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The genre contains controls for an arcade-style game.

Definition

Visual Basic .NET | Public Enum ArcadeSideToSide
C# | public enum ArcadeSideToSide
Managed C++ | __value public enum ArcadeSideToSide
JScript .NET | public enum ArcadeSideToSide

Members

Member | Value | Description
ButtonPause | 553665788
ButtonDevice | 553665790
ButtonViewRightLink | 554157292
ButtonViewLeftLink | 554157284
ButtonViewDownLink | 554157288
ButtonViewUpLink | 554157280
ButtonBackLink | 553731304
ButtonForwardLink | 553731296
ButtonRightLink | 553698540
ButtonLeftLink | 553698532
HatSwitchView | 553666049
ButtonMenu | 553649405
ButtonSelect | 553649157
ButtonSpecial | 553649156
ButtonAttack | 553649155
ButtonCarry | 553649154
ButtonThrow | 553649153
AxisMove | 553714178
AxisLateral | 553681409
ArcadeSideToSide | 553648128

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AxesDataFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

AxesDataFormat Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.

Definition

Visual Basic .NET | Public Enum AxesDataFormat
C# | public enum AxesDataFormat
Managed C++ | __value public enum AxesDataFormat
JScript .NET | public enum AxesDataFormat

Members

Member | Value | Description
Axis | 3
RelativeAxis | 1
AbsoluteAxis | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BrowserControl

Microsoft DirectX 9.0 SDK Update (October 2004)

BrowserControl Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The genre contains controls for browser control.

Definition

Visual Basic .NET | Public Enum BrowserControl
C# | public enum BrowserControl
Managed C++ | __value public enum BrowserControl
JScript .NET | public enum BrowserControl

Members

Member | Value | Description
ButtonPause | 671106300
ButtonDevice | 671106302
ButtonMenu | 671089917
ButtonSelect | 671089665
AxisMove | 671154690
AxisLateral | 671121921
ButtonPrint | 671106058
ButtonHistory | 671106057
ButtonPrevious | 671106056
ButtonNext | 671106055
ButtonFavorites | 671106054
ButtonHome | 671106053
ButtonStop | 671106052
ButtonSearch | 671106051
ButtonRefresh | 671089666
AxisView | 671187459
BrowserControl | 671088640

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Button

Microsoft DirectX 9.0 SDK Update (October 2004)

Button Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

A button.

Definition

Visual Basic .NET | Public Enum Button
C# | public enum Button
Managed C++ | __value public enum Button
JScript .NET | public enum Button

Members

Member | Value | Description
NoTrigger | -1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Cad2DControl

Microsoft DirectX 9.0 SDK Update (October 2004)

Cad2DControl Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The genre contains controls for a 2D CAD control

Definition

Visual Basic .NET | Public Enum Cad2DControl
C# | public enum Cad2DControl
Managed C++ | __value public enum Cad2DControl
JScript .NET | public enum Cad2DControl

Members

Member | Value | Description
ButtonPause | 587220220
ButtonDevice | 587220222
ButtonDisplay | 587219973
AxisRotateZ | 587350532
HatSwitch | 587220481
ButtonMenu | 587203837
ButtonSpecial2 | 587203588
ButtonSpecial | 587203587
ButtonSpecial1 | 587203586
ButtonSelect | 587203585
AxisInOut | 587301379
AxisMove | 587268610
AxisLateral | 587235841
Cad2DControl | 587202560

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Cad3DControl

Microsoft DirectX 9.0 SDK Update (October 2004)

Cad3DControl Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The genre contains controls for a 3-D CAD control

Definition

Visual Basic .NET | Public Enum Cad3DControl
C# | public enum Cad3DControl
Managed C++ | __value public enum Cad3DControl
JScript .NET | public enum Cad3DControl

Members

Member | Value | Description
ButtonPause | 603997436
ButtonDevice | 603997438
ButtonDisplay | 603997189
AxisRotateZ | 604127750
AxisRotateY | 604160517
AxisRotateX | 604193284
HatSwitch | 603997697
ButtonMenu | 603981053
ButtonSpecial2 | 603980804
ButtonSpecial | 603980803
ButtonSpecial1 | 603980802
ButtonSelect | 603980801
AxisInOut | 604078595
AxisMove | 604045826
AxisLateral | 604013057
Cad3DControl | 603979776

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CadFlyBy

Microsoft DirectX 9.0 SDK Update (October 2004)

CadFlyBy Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The genre contains controls for a CAD Fly By.

Definition

Visual Basic .NET | Public Enum CadFlyBy
C# | public enum CadFlyBy
Managed C++ | __value public enum CadFlyBy
JScript .NET | public enum CadFlyBy

Members

Member | Value | Description
ButtonPause | 620774652
ButtonDevice | 620774654
ButtonDisplay | 620774405
AxisRotateZ | 620904966
AxisRotateY | 620937733
AxisRotateX | 620970500
HatSwitch | 620774913
ButtonMenu | 620758269
ButtonSpecial2 | 620758020
ButtonSpecial | 620758019
ButtonSpecial1 | 620758018
ButtonSelect | 620758017
AxisInOut | 620855811
AxisMove | 620823042
AxisLateral | 620790273
CadFlyBy | 620756992

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CadModel

Microsoft DirectX 9.0 SDK Update (October 2004)

CadModel Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The genre contains controls for a CAD model.

Definition

Visual Basic .NET | Public Enum CadModel
C# | public enum CadModel
Managed C++ | __value public enum CadModel
JScript .NET | public enum CadModel

Members

Member | Value | Description
ButtonPause | 637551868
ButtonDevice | 637551870
ButtonDisplay | 637551621
AxisRotateZ | 637682182
AxisRotateY | 637714949
AxisRotateX | 637747716
HatSwitch | 637552129
ButtonMenu | 637535485
ButtonSpecial2 | 637535236
ButtonSpecial | 637535235
ButtonSpecial1 | 637535234
ButtonSelect | 637535233
AxisInOut | 637633027
AxisMove | 637600258
AxisLateral | 637567489
CadModel | 637534208

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConfigureDevicesFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ConfigureDevicesFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Flags for configuring devices.

Definition

Visual Basic .NET | Public Enum ConfigureDevicesFlags
C# | public enum ConfigureDevicesFlags
Managed C++ | __value public enum ConfigureDevicesFlags
JScript .NET | public enum ConfigureDevicesFlags

Members

Member | Value | Description
Edit | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CooperativeLevelFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

CooperativeLevelFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Definition

Visual Basic .NET | Public Enum CooperativeLevelFlags
C# | public enum CooperativeLevelFlags
Managed C++ | __value public enum CooperativeLevelFlags
JScript .NET | public enum CooperativeLevelFlags

Members

Member | Value | Description
NoWindowsKey | 16
Background | 8
Foreground | 4
NonExclusive | 2
Exclusive | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DataFormatFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

DataFormatFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Data format flags.

Definition

Visual Basic .NET | Public Enum DataFormatFlags
C# | public enum DataFormatFlags
Managed C++ | __value public enum DataFormatFlags
JScript .NET | public enum DataFormatFlags

Members

Member | Value | Description
RelativeAxis | 2
AbsoluteAxis | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceClass

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceClass Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Used when enumerating a class of devices.

Definition

Visual Basic .NET | Public Enum DeviceClass
C# | public enum DeviceClass
Managed C++ | __value public enum DeviceClass
JScript .NET | public enum DeviceClass

Members

Member | Value | Description
Pointer | 2 | All devices of type DI8DEVTYPE_MOUSE and DI8DEVTYPE_SCREENPOINTER.
Keyboard | 3 | All keyboards. Equivalent to DI8DEVTYPE_KEYBOARD.
GameControl | 4 | All game controllers.
Other | 1
All | 0 | All devices.

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceData

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceData Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.

Definition

Visual Basic .NET | Public Enum DeviceData
C# | public enum DeviceData
Managed C++ | __value public enum DeviceData
JScript .NET | public enum DeviceData

Members

Member | Value | Description
Continue | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceDataFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceDataFormat Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.

Definition

Visual Basic .NET | Public Enum DeviceDataFormat
C# | public enum DeviceDataFormat
Managed C++ | __value public enum DeviceDataFormat
JScript .NET | public enum DeviceDataFormat

Members

Member | Value | Description
Mouse | 1
Keyboard | 0
Joystick | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceObjectTypeFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectTypeFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceObjectTypeFlags
C# | public enum DeviceObjectTypeFlags
Managed C++ | __value public enum DeviceObjectTypeFlags
JScript .NET | public enum DeviceObjectTypeFlags

Members

Member | Value | Description
Button | 12
NoCollection | 16776960
Alias | 134217728 | Flags describing other attributes of the data format. This value can be one of the following:
VendorDefined | 67108864
Output | 268435456
ForceFeedbackEffectTrigger | 33554432
ForceFeedbackActuator | 16777216
InstanceMask | 16776960
AnyInstance | 16776960
NoData | 128
Collection | 64
Pov | 16
ToggleButton | 8
PushButton | 4
Axis | 3
AbsoluteAxis | 2
RelativeAxis | 1
All | 0 | Flags describing other attributes of the data format. This value can be one of the following:

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceType
C# | public enum DeviceType
Managed C++ | __value public enum DeviceType
JScript .NET | public enum DeviceType

Members

Member | Value | Description
Keyboard | 19
Mouse | 18
Supplemental | 28
Remote | 27
ScreenPointer | 26
DeviceControl | 25
FirstPerson | 24
Flight | 23
Driving | 22
Gamepad | 21
Joystick | 20
Device | 17 | All devices that do not fall into another class.
LimitedGameSubtype | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeControl

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeControl Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeControl
C# | public enum DeviceTypeControl
Managed C++ | __value public enum DeviceTypeControl
JScript .NET | public enum DeviceTypeControl

Members

Member | Value | Description
CommsSelectionHardwired | 4
CommsSelection | 3
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeDriving

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeDriving Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeDriving
C# | public enum DeviceTypeDriving
Managed C++ | __value public enum DeviceTypeDriving
JScript .NET | public enum DeviceTypeDriving

Members

Member | Value | Description
HandHeld | 5
ThreePedals | 4
DualPedals | 3
CombinedPedals | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeFirstPerson

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeFirstPerson Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeFirstPerson
C# | public enum DeviceTypeFirstPerson
Managed C++ | __value public enum DeviceTypeFirstPerson
JScript .NET | public enum DeviceTypeFirstPerson

Members

Member | Value | Description
Shooter | 4
SixDegreesOfFreedom | 3
Unknown | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeFlight

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeFlight Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeFlight
C# | public enum DeviceTypeFlight
Managed C++ | __value public enum DeviceTypeFlight
JScript .NET | public enum DeviceTypeFlight

Members

Member | Value | Description
RemoteControl | 4
Yoke | 3
Stick | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeGamePad

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeGamePad Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeGamePad
C# | public enum DeviceTypeGamePad
Managed C++ | __value public enum DeviceTypeGamePad
JScript .NET | public enum DeviceTypeGamePad

Members

Member | Value | Description
Tilt | 3
Standard | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeJoystick

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeJoystick Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeJoystick
C# | public enum DeviceTypeJoystick
Managed C++ | __value public enum DeviceTypeJoystick
JScript .NET | public enum DeviceTypeJoystick

Members

Member | Value | Description
Standard | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeKeyboard

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeKeyboard Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

All keyboards. Equivalent to DI8DEVTYPE_KEYBOARD.

Definition

Visual Basic .NET | Public Enum DeviceTypeKeyboard
C# | public enum DeviceTypeKeyboard
Managed C++ | __value public enum DeviceTypeKeyboard
JScript .NET | public enum DeviceTypeKeyboard

Members

Member | Value | Description
J3100 | 12
JapanAX | 11
Japan106 | 10
Nec98106 | 9
Nec98Laptop | 8
Nec98 | 7
Nokia9140 | 6
Nokia1050 | 5
PcEnh | 4
PcAt | 3
Olivetti | 2
PcXt | 1
Unknown | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeMouse

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeMouse Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeMouse
C# | public enum DeviceTypeMouse
Managed C++ | __value public enum DeviceTypeMouse
JScript .NET | public enum DeviceTypeMouse

Members

Member | Value | Description
Absolute | 6
Trackball | 5
Touchpad | 4
Fingerstick | 3
Traditional | 2
Unknown | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeRemote

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeRemote Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeRemote
C# | public enum DeviceTypeRemote
Managed C++ | __value public enum DeviceTypeRemote
JScript .NET | public enum DeviceTypeRemote

Members

Member | Value | Description
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeScreenPtr

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeScreenPtr Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeScreenPtr
C# | public enum DeviceTypeScreenPtr
Managed C++ | __value public enum DeviceTypeScreenPtr
JScript .NET | public enum DeviceTypeScreenPtr

Members

Member | Value | Description
Touch | 5
LightPen | 4
LightGun | 3
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceTypeSupplemental

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceTypeSupplemental Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DeviceTypeSupplemental
C# | public enum DeviceTypeSupplemental
Managed C++ | __value public enum DeviceTypeSupplemental
JScript .NET | public enum DeviceTypeSupplemental

Members

Member | Value | Description
RudderPedals | 13
ThreePedals | 12
DualPedals | 11
CombinedPedals | 10
SplitThrottle | 9
Throttle | 8
Shifter | 7
ShiftStickGate | 6
HandTracker | 5
HeadTracker | 4
SecondHandController | 3
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DI

Microsoft DirectX 9.0 SDK Update (October 2004)

DI Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DI
C# | public enum DI
Managed C++ | __value public enum DI
JScript .NET | public enum DI

Members

Member | Value | Description
Infinite | -1
Seconds | 1000000
NominalMax | 10000
Degrees | 100

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrivingCombat

Microsoft DirectX 9.0 SDK Update (October 2004)

DrivingCombat Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DrivingCombat
C# | public enum DrivingCombat
Managed C++ | __value public enum DrivingCombat
JScript .NET | public enum DrivingCombat

Members

Member | Value | Description
ButtonPause | 33572092
ButtonDevice | 33572094
ButtonGlanceRightLink | 34063596
ButtonGlanceLeftLink | 34063588
ButtonSteerRightLink | 33606892
ButtonSteerLeftLink | 33606884
ButtonAccelerateLink | 33805536
ButtonFireSecondary | 33573897
ButtonBrake | 33573896
ButtonAids | 33571847
ButtonDashboard | 33571846
ButtonShiftDown | 33573893
ButtonShiftUp | 33573892
HatSwitchGlance | 33572353
AxisAccelAndBrake | 33638916
ButtonMenu | 33555709
ButtonTarget | 33557507
ButtonWeapons | 33557506
ButtonFire | 33557505
AxisBrake | 33821187
AxisAccelerate | 33788418
AxisSteer | 33589761
Combat | 33554432

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrivingMecha

Microsoft DirectX 9.0 SDK Update (October 2004)

DrivingMecha Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DrivingMecha
C# | public enum DrivingMecha
Managed C++ | __value public enum DrivingMecha
JScript .NET | public enum DrivingMecha

Members

Member | Value | Description
ButtonPause | 687883516
ButtonDevice | 687883518
ButtonSlowerLink | 688112872
ButtonFasterLink | 688112864
ButtonRotateRightLink | 688014572
ButtonRotateLeftLink | 688014564
ButtonBackLink | 687949032
ButtonForwardLink | 687949024
ButtonRightLink | 687916268
ButtonLeftLink | 687916260
ButtonFireSecondary | 687883273
ButtonView | 687883272
HatSwitchGlance | 687883777
ButtonMenu | 687867133
ButtonJump | 687866886
ButtonZoom | 687866885
ButtonTarget | 687866883
ButtonWeapons | 687866882
ButtonFire | 687866881
AxisThrottle | 688095748
AxisRotate | 687997443
AxisSteer | 687899137
ButtonCenter | 687883271
ButtonReverse | 687866884
AxisTorso | 687931906
DrivingMecha | 687865856

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrivingRace

Microsoft DirectX 9.0 SDK Update (October 2004)

DrivingRace Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DrivingRace
C# | public enum DrivingRace
Managed C++ | __value public enum DrivingRace
JScript .NET | public enum DrivingRace

Members

Member | Value | Description
ButtonPause | 16794876
ButtonDevice | 16794878
ButtonGlanceRightLink | 17286380
ButtonGlanceLeftLink | 17286372
ButtonSteerRightLink | 16829676
ButtonSteerLeftLink | 16829668
ButtonAccelerateLink | 17028320
ButtonPit | 16794633
ButtonBoost | 16794632
ButtonMap | 16794631
ButtonAids | 16794630
ButtonDashboard | 16794629
ButtonBrake | 16796676
HatSwitchGlance | 16795137
AxisAccelAndBrake | 16861700
ButtonMenu | 16778493
ButtonView | 16784387
ButtonShiftDown | 16780290
ButtonShiftUp | 16780289
AxisBrake | 17043971
AxisAccelerate | 17011202
AxisSteer | 16812545
Race | 16777216

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DrivingTank

Microsoft DirectX 9.0 SDK Update (October 2004)

DrivingTank Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum DrivingTank
C# | public enum DrivingTank
Managed C++ | __value public enum DrivingTank
JScript .NET | public enum DrivingTank

Members

Member | Value | Description
ButtonPause | 50349308
ButtonDevice | 50349310
ButtonGlanceRightLink | 50840812
ButtonGlanceLeftLink | 50840804
ButtonRotateRightLink | 50480364
ButtonRotateLeftLink | 50480356
ButtonBarrelDownLink | 50414824
ButtonBarrelUpLink | 50414816
ButtonSteerRightLink | 50384108
ButtonSteerLeftLink | 50384100
ButtonAccelerateLink | 50582752
ButtonFireSecondary | 50351111
ButtonBrake | 50351110
ButtonDashboard | 50355205
ButtonView | 50355204
AxisAccelAndBrake | 50416134
AxisBrake | 50614789
HatSwitchGlance | 50349569
ButtonMenu | 50332925
ButtonTarget | 50334723
ButtonWeapons | 50334722
ButtonFire | 50334721
AxisRotate | 50463236
AxisAccelerate | 50565635
AxisBarrel | 50397698
AxisSteer | 50366977
Tank | 50331648

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum EffectFlags
C# | public enum EffectFlags
Managed C++ | __value public enum EffectFlags
JScript .NET | public enum EffectFlags

Members

Member | Value | Description
Spherical | 64
Polar | 32
Cartesian | 16
ObjectOffsets | 2
ObjectIds | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectParameterFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectParameterFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum EffectParameterFlags
C# | public enum EffectParameterFlags
Managed C++ | __value public enum EffectParameterFlags
JScript .NET | public enum EffectParameterFlags

Members

Member | Value | Description
NoDownload | -2147483648
NoRestart | 1073741824
AllParams | 1023
TypeSpecificParams | 256
Envelope | 128
Direction | 64
Axes | 32
TriggerRepeatInterval | 16
TriggerButton | 8
Gain | 4
SamplePeriod | 2
Duration | 1
Start | 536870912
StartDelay | 512

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectStartFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectStartFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum EffectStartFlags
C# | public enum EffectStartFlags
Managed C++ | __value public enum EffectStartFlags
JScript .NET | public enum EffectStartFlags

Members

Member | Value | Description
NoDownload | -2147483648
Solo | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectType

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum EffectType
C# | public enum EffectType
Managed C++ | __value public enum EffectType
JScript .NET | public enum EffectType

Members

Member | Value | Description
CustomForce | 5
Condition | 4 | Contains type-specific information for effects that are marked as DIEFT_CONDITION.A reference to an array of Dicondition structures for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure. The number of elements in the array must be either one, or equal to the number of axes associated with the effect.
RampForce | 2
ConstantForce | 1
StartDelay | 32768
DeadBand | 16384
PosNegSaturation | 8192
PosNegCoeffecients | 4096
Saturation | 2048 | Retrieves a value for the
ForceFeedbackFade | 1024
ForceFeedbackAttack | 512
Hardware | 255
Periodic | 3 | Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
All | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EnumBySemanticsReason

Microsoft DirectX 9.0 SDK Update (October 2004)

EnumBySemanticsReason Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum EnumBySemanticsReason
C# | public enum EnumBySemanticsReason
Managed C++ | __value public enum EnumBySemanticsReason
JScript .NET | public enum EnumBySemanticsReason

Members

Member | Value | Description
NewDevice | 32
RecentDevice | 16
MappedPriorityTwo | 2
MappedPriorityOne | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EnumDevicesBySemanticsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

EnumDevicesBySemanticsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum EnumDevicesBySemanticsFlags
C# | public enum EnumDevicesBySemanticsFlags
Managed C++ | __value public enum EnumDevicesBySemanticsFlags
JScript .NET | public enum EnumDevicesBySemanticsFlags

Members

Member | Value | Description
Valid | 28944
NonGamingDevices | 16384
MultiMiceKeyboards | 8192
AvailableDevices | 4096
ForceFeedback | 256
ThisUser | 16
AttachedOnly | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EnumDevicesFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

EnumDevicesFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum EnumDevicesFlags
C# | public enum EnumDevicesFlags
Managed C++ | __value public enum EnumDevicesFlags
JScript .NET | public enum EnumDevicesFlags

Members

Member | Value | Description
IncludeHidden | 262144
IncludePhantoms | 131072
IncludeAliases | 65536
ForceFeeback | 256
AttachedOnly | 1
AllDevices | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FightingFps

Microsoft DirectX 9.0 SDK Update (October 2004)

FightingFps Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum FightingFps
C# | public enum FightingFps
Managed C++ | __value public enum FightingFps
JScript .NET | public enum FightingFps

Members

Member | Value | Description
ButtonPause | 151012604
ButtonDevice | 151012606
ButtonStepRightLink | 151143660
ButtonStepLeftLink | 151143652
ButtonGlanceDownLink | 151110888
ButtonGlanceUpLink | 151110880
ButtonBackwardLink | 151078120
ButtonForwardLink | 151078112
ButtonRotateRightLink | 151045356
ButtonRotateLeftLink | 151045348
ButtonFireSecondary | 151012364
ButtonGlanceR | 151012363
ButtonGlanceL | 151012362
ButtonDodge | 151012361
AxisSideStep | 151142916
ButtonDisplay | 151012360
HatSwitchGlance | 151012865
ButtonMenu | 150996221
ButtonStrafe | 150995975
AxisLookUpDown | 151093763
ButtonJump | 150995974
ButtonCrouch | 150995973
ButtonSelect | 150995972
ButtonApply | 150995971
ButtonWeapons | 150995970
ButtonFire | 150995969
AxisMove | 151060994
AxisRotate | 151028225
FightingFps | 150994944

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FightingHandToHand

Microsoft DirectX 9.0 SDK Update (October 2004)

FightingHandToHand Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum FightingHandToHand
C# | public enum FightingHandToHand
Managed C++ | __value public enum FightingHandToHand
JScript .NET | public enum FightingHandToHand

Members

Member | Value | Description
ButtonPause | 134235388
ButtonDevice | 134235390
ButtonBackwardLink | 134300904
ButtonForwardLink | 134300896
ButtonRightLink | 134268140
ButtonLeftLink | 134268132
ButtonDodge | 134235146
AxisRotate | 134365699
ButtonDisplay | 134235145
HatSwitchSlide | 134235649
ButtonSelect | 134235144
ButtonMenu | 134219005
ButtonSpecial2 | 134218759
ButtonSpecial1 | 134218758
ButtonJump | 134218757
ButtonCrouch | 134218756
ButtonBlock | 134218755
ButtonKick | 134218754
ButtonPunch | 134218753
AxisMove | 134283778
AxisLateral | 134251009
FightingHandToHand | 134217728

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FightingThirdPerson

Microsoft DirectX 9.0 SDK Update (October 2004)

FightingThirdPerson Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum FightingThirdPerson
C# | public enum FightingThirdPerson
Managed C++ | __value public enum FightingThirdPerson
JScript .NET | public enum FightingThirdPerson

Members

Member | Value | Description
ButtonPause | 167789820
ButtonDevice | 167789822
ButtonGlanceRightLink | 168281324
ButtonGlanceLeftLink | 168281316
ButtonGlanceDownLink | 168281320
ButtonGlanceUpLink | 168281312
ButtonBackwardLink | 167855336
ButtonForwardLink | 167855328
ButtonTurnRightLink | 167920876
ButtonTurnLeftLink | 167920868
ButtonInventory | 167789578
ButtonDodge | 167789577
AxisStep | 167821827
ButtonStepRight | 167789576
ButtonStepLeft | 167789575
ButtonView | 167789574
HatSwitchGlance | 167790081
ButtonMenu | 167773437
ButtonJump | 167773189
ButtonUse | 167773188
ButtonSelect | 167773187
ButtonAction | 167773186
ButtonRun | 167773185
AxisMove | 167838210
AxisTurn | 167903745
FightingThirdPerson | 167772160

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FileEffectsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

FileEffectsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum FileEffectsFlags
C# | public enum FileEffectsFlags
Managed C++ | __value public enum FileEffectsFlags
JScript .NET | public enum FileEffectsFlags

Members

Member | Value | Description
ModifyIfNeeded | 16
IncludeNonStandard | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FlyingCivilian

Microsoft DirectX 9.0 SDK Update (October 2004)

FlyingCivilian Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum FlyingCivilian
C# | public enum FlyingCivilian
Managed C++ | __value public enum FlyingCivilian
JScript .NET | public enum FlyingCivilian

Members

Member | Value | Description
ButtonPause | 67126524
ButtonDevice | 67126526
ButtonGlanceDownLink | 67618024
ButtonGlanceUpLink | 67618016
ButtonGlanceRightLink | 67618028
ButtonGlanceLeftLink | 67618020
ButtonSlowerLink | 67359976
ButtonFasterLink | 67359968
ButtonBrakeLink | 67398880
ButtonFlapsDown | 67134469
ButtonFlapsUp | 67134468
AxisFlaps | 67459590
AxisRudder | 67260933
AxisBrake | 67398148
HatSwitchGlance | 67126785
ButtonMenu | 67110141
ButtonGear | 67120131
ButtonDisplay | 67118082
ButtonView | 67118081
AxisThrottle | 67342851
AxisPitch | 67176962
AxisBank | 67144193
Civilian | 67108864

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FlyingHelicopter

Microsoft DirectX 9.0 SDK Update (October 2004)

FlyingHelicopter Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum FlyingHelicopter
C# | public enum FlyingHelicopter
Managed C++ | __value public enum FlyingHelicopter
JScript .NET | public enum FlyingHelicopter

Members

Member | Value | Description
ButtonPause | 100680956
ButtonDevice | 100680958
ButtonGlanceDownLink | 101172456
ButtonGlanceUpLink | 101172448
ButtonGlanceRightLink | 101172460
ButtonGlanceLeftLink | 101172452
ButtonSlowerLink | 100916456
ButtonFasterLink | 100916448
ButtonFireSecondary | 100682759
ButtonGear | 100688902
ButtonView | 100688901
ButtonCounter | 100684804
AxisThrottle | 100915717
AxisTorque | 100817412
HatSwitchGlance | 100681217
ButtonMenu | 100664573
ButtonTarget | 100668419
ButtonWeapons | 100668418
ButtonFire | 100668417
AxisCollective | 100764163
AxisPitch | 100731394
AxisBank | 100698625
Helicopter | 100663296

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FlyingMilitary

Microsoft DirectX 9.0 SDK Update (October 2004)

FlyingMilitary Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum FlyingMilitary
C# | public enum FlyingMilitary
Managed C++ | __value public enum FlyingMilitary
JScript .NET | public enum FlyingMilitary

Members

Member | Value | Description
ButtonPause | 83903740
ButtonDevice | 83903742
ButtonGlanceDownLink | 84395240
ButtonGlanceUpLink | 84395232
ButtonGlanceRightLink | 84395244
ButtonGlanceLeftLink | 84395236
ButtonSlowerLink | 84137192
ButtonFasterLink | 84137184
ButtonBrakeLink | 84174048
ButtonGear | 83911690
ButtonFireSecondary | 83905545
ButtonFlapsDown | 83907592
ButtonFlapsUp | 83907591
AxisFlaps | 84234758
ButtonDisplay | 83911686
ButtonView | 83911685
AxisBrake | 84173317
AxisRudder | 84036100
ButtonCounter | 83909636
HatSwitchGlance | 83904001
ButtonMenu | 83887357
ButtonTarget | 83889155
ButtonWeapons | 83889154
ButtonFire | 83889153
AxisThrottle | 84120067
AxisPitch | 83954178
AxisBank | 83921409
Military | 83886080

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ForceFeedbackCommand

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackCommand Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum ForceFeedbackCommand
C# | public enum ForceFeedbackCommand
Managed C++ | __value public enum ForceFeedbackCommand
JScript .NET | public enum ForceFeedbackCommand

Members

Member | Value | Description
Reset | 1 | Sets the enumerator to its initial position, which is before the first element in the collection.
SetActuatorsOff | 32
SetActuatorsOn | 16
Continue | 8
Pause | 4 | Sends a command to the device's force-feedback system.
StopAll | 2 | Sends a command to the device's force-feedback system.

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ForceFeedbackStates

Microsoft DirectX 9.0 SDK Update (October 2004)

ForceFeedbackStates Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum ForceFeedbackStates
C# | public enum ForceFeedbackStates
Managed C++ | __value public enum ForceFeedbackStates
JScript .NET | public enum ForceFeedbackStates

Members

Member | Value | Description
Empty | 1 | Retrieves the state of the device's force-feedback system.
DeviceLost | -2147483648
UserForceFeedbackSwitchOff | 2048
UserForceFeedbackSwitchOn | 1024
SafterSwitchOff | 512
SafetySwitchOn | 256
PowerOff | 128
PowerOn | 64 | Retrieves the state of the device's force-feedback system.
ActuatorsOff | 32
ActuatorsOn | 16
Paused | 4 | Retrieves the state of the device's force-feedback system.
Stopped | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ImageFileType

Microsoft DirectX 9.0 SDK Update (October 2004)

ImageFileType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum ImageFileType
C# | public enum ImageFileType
Managed C++ | __value public enum ImageFileType
JScript .NET | public enum ImageFileType

Members

Member | Value | Description
Overlay | 2
Configuration | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


JoystickOffset

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickOffset Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum JoystickOffset
C# | public enum JoystickOffset
Managed C++ | __value public enum JoystickOffset
JScript .NET | public enum JoystickOffset

Members

Member | Value | Description
Y | 4
X | 0
Button62 | 110
Button61 | 109
Button60 | 108
Button59 | 107
Button58 | 106
Button57 | 105
Button56 | 104
Button55 | 103
Button54 | 102
Button53 | 101
Button52 | 100
Button51 | 99
Button50 | 98
Button49 | 97
Button48 | 96
Button47 | 95
Button46 | 94
Button45 | 93
Button44 | 92
Button43 | 91
Button42 | 90
Button41 | 89
Button40 | 88
Button39 | 87
Button38 | 86
Button37 | 85
Button36 | 84
Button35 | 83
Button34 | 82
Button33 | 81
Button32 | 80
Button31 | 79
Button30 | 78
Button29 | 77
Button28 | 76
Button27 | 75
Button26 | 74
Button25 | 73
Button24 | 72
Button23 | 71
Button22 | 70
Button21 | 69
Button20 | 68
Button19 | 67
Button18 | 66
Button17 | 65
Button16 | 64
Button15 | 63
Button14 | 62
Button13 | 61
Button12 | 60
Button11 | 59
Button10 | 58
Button9 | 57
Button8 | 56
Button7 | 55
Button6 | 54
Button5 | 53
Button4 | 52
Button3 | 51
Button2 | 50
Button1 | 49
Button0 | 48
PointOfView3 | 44
PointOfView2 | 40
PointOfView1 | 36
PointOfView0 | 32
Slider1 | 28 | Two additional axis values (formerly called the u-axis and v-axis) whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.
Slider0 | 24 | Two additional axis values (formerly called the u-axis and v-axis) whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.
RZ | 20 | Z-axis rotation (often called the rudder). If the joystick does not have this axis, the value is 0.
RY | 16 | Y-axis rotation. If the joystick does not have this axis, the value is 0.
RX | 12 | X-axis rotation. If the joystick does not have this axis, the value is 0.
Z | 8
Button128 | 176
Button127 | 175
Button126 | 174
Button125 | 173
Button124 | 172
Button123 | 171
Button122 | 170
Button121 | 169
Button120 | 168
Button119 | 167
Button118 | 166
Button117 | 165
Button116 | 164
Button115 | 163
Button114 | 162
Button113 | 161
Button112 | 160
Button111 | 159
Button110 | 158
Button109 | 157
Button108 | 156
Button107 | 155
Button106 | 154
Button105 | 153
Button104 | 152
Button103 | 151
Button102 | 150
Button101 | 149
Button100 | 148
Button99 | 147
Button98 | 146
Button97 | 145
Button96 | 144
Button95 | 143
Button94 | 142
Button93 | 141
Button92 | 140
Button91 | 139
Button90 | 138
Button89 | 137
Button88 | 136
Button87 | 135
Button86 | 134
Button85 | 133
Button84 | 132
Button83 | 131
Button82 | 130
Button81 | 129
Button80 | 128
Button79 | 127
Button78 | 126
Button77 | 125
Button76 | 124
Button75 | 123
Button74 | 122
Button73 | 121
Button72 | 120
Button71 | 119
Button70 | 118
Button69 | 117
Button68 | 116
Button67 | 115
Button66 | 114
Button65 | 113
Button64 | 112
Button63 | 111

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Key

Microsoft DirectX 9.0 SDK Update (October 2004)

Key Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum Key
C# | public enum Key
Managed C++ | __value public enum Key
JScript .NET | public enum Key

Members

Member | Value | Description
Sleep | 223
Next | 209
Stop | 149
Convert | 121
Decimal | 83
X | 45
Y | 21
Escape | 1
Circumflex | 144
PageDown | 209
DownArrow | 208
RightArrow | 205
LeftArrow | 203
PageUp | 201
UpArrow | 200
RightAlt | 184
NumPadSlash | 181
NumPadPeriod | 83
NumPadPlus | 78
NumPadMinus | 74
CapsLock | 58
LeftAlt | 56
NumPadStar | 55
BackSpace | 14
MediaSelect | 237
Mail | 236
MyComputer | 235
WebBack | 234
WebForward | 233
WebStop | 232
WebRefresh | 231
WebFavorites | 230
WebSearch | 229
Wake | 227
Power | 222
Apps | 221
RightWindows | 220
LeftWindows | 219
Down | 208
End | 207
Prior | 201
Up | 200
Home | 199
RightMenu | 184
SysRq | 183
Divide | 181
NumPadComma | 179
WebHome | 178
VolumeUp | 176
VolumeDown | 174
MediaStop | 164
PlayPause | 162
Calculator | 161
Mute | 160
RightControl | 157
NumPadEnter | 156
NextTrack | 153
Unlabeled | 151
AX | 150
Kanji | 148
Underline | 147
Colon | 146
At | 145
PrevTrack | 144
NumPadEquals | 141
AbntC2 | 126
Yen | 125
NoConvert | 123
AbntC1 | 115
Kana | 112
F15 | 102
F14 | 101
F13 | 100
F12 | 88
F11 | 87
OEM102 | 86
NumPad0 | 82
NumPad3 | 81
NumPad2 | 80
NumPad1 | 79
NumPad6 | 77
NumPad5 | 76
NumPad4 | 75
Subtract | 74
NumPad9 | 73
NumPad8 | 72
NumPad7 | 71
Scroll | 70
Numlock | 69
F10 | 68
F9 | 67
F8 | 66
F7 | 65
F6 | 64
F5 | 63
F4 | 62
F3 | 61
F2 | 60
F1 | 59
Capital | 58
Space | 57
LeftMenu | 56
Multiply | 55
RightShift | 54
Slash | 53
Period | 52
Comma | 51
M | 50
N | 49
B | 48
V | 47
C | 46
Z | 44
BackSlash | 43
LeftShift | 42
Grave | 41
Apostrophe | 40
SemiColon | 39
L | 38
K | 37
J | 36
H | 35
G | 34
F | 33
D | 32
S | 31
A | 30
LeftControl | 29
Return | 28
RightBracket | 27
LeftBracket | 26
P | 25
O | 24
I | 23
U | 22
T | 20
R | 19
E | 18
W | 17
Tab | 15
Back | 14
Equals | 13 | Returns a value indicating whether this instance is equal to a specified object.
Minus | 12
D0 | 11
D9 | 10
D8 | 9
D7 | 8
D6 | 7
D5 | 6
D4 | 5
D3 | 4
D2 | 3
D1 | 2
Insert | 210 | Inserts an element into the collection at the specified index.
Right | 205
Left | 203
Pause | 197
Add | 78
Delete | 211
Q | 16

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Keyboard

Microsoft DirectX 9.0 SDK Update (October 2004)

Keyboard Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical key.

Definition

Visual Basic .NET | Public Enum Keyboard
C# | public enum Keyboard
Managed C++ | __value public enum Keyboard
JScript .NET | public enum Keyboard

Members

Member | Value | Description
Sleep | -2130705185
Next | -2130705199 | PAGE DOWN
Stop | -2130705259 | On NEC PC-98 Japanese keyboard
Convert | -2130705287 | On Japanese keyboard
Decimal | -2130705325 | PERIOD (decimal point) on numeric keypad
X | -2130705363
Y | -2130705387
Escape | -2130705407
MediaSelect | -2130705171 | MEDIA SELECT key, which displays a selection of supported media players on the system
Mail | -2130705172
MyComputer | -2130705173
WebBack | -2130705174
WebForward | -2130705175
WebStop | -2130705176
WebRefresh | -2130705177
WebFavorites | -2130705178 | Displays the Microsoft Internet Explorer Favorites list, the Microsoft Windows® Favorites folder, or the Netscape Bookmarks list
WebSearch | -2130705179
Wake | -2130705181
Power | -2130705186
Apps | -2130705187 | Application key
RightWindows | -2130705188
LeftWindows | -2130705189
Down | -2130705200 | DOWN ARROW
End | -2130705201
Prior | -2130705207 | PAGE UP
Up | -2130705208 | UP ARROW
Home | -2130705209
RightMenu | -2130705224 | Right ALT
SysRq | -2130705225
Divide | -2130705227 | FORWARD SLASH (/) on numeric keypad
NumPadComma | -2130705229 | On numeric keypad of NEC PC-98 Japanese keyboard
WebHome | -2130705230
VolumeUp | -2130705232
VolumeDown | -2130705234
MediaStop | -2130705244
PlayPause | -2130705246
Calculator | -2130705247
Mute | -2130705248
RightControl | -2130705251
NumPadEnter | -2130705252
NextTrack | -2130705255 | NEXT TRACK
Unlabeled | -2130705257 | On Japanese keyboard
AX | -2130705258 | On Japanese keyboard
Kanji | -2130705260 | On Japanese keyboard
Underline | -2130705261 | On NEC PC-98 Japanese keyboard
Colon | -2130705262 | On Japanese keyboard
At | -2130705263 | On Japanese keyboard
PrevTrack | -2130705264 | PREVIOUS TRACK; CIRCUMFLEX (^) on Japanese keyboard
NumPadEquals | -2130705267
AbntC2 | -2130705282 | On numeric pad of Brazilian keyboards
Yen | -2130705283 | On Japanese keyboard
NoConvert | -2130705285 | On Japanese keyboard
AbntC1 | -2130705293 | On numeric pad of Brazilian keyboards
Kana | -2130705296 | On Japanese keyboard
F15 | -2130705306 | On NEC PC-98 Japanese keyboard
F14 | -2130705307 | On NEC PC-98 Japanese keyboard
F13 | -2130705308 | On NEC PC-98 Japanese keyboard
F12 | -2130705320
F11 | -2130705321
OEM102 | -2130705322 | On British and German keyboards
NumPad0 | -2130705326
NumPad3 | -2130705327
NumPad2 | -2130705328
NumPad1 | -2130705329
NumPad6 | -2130705331
NumPad5 | -2130705332
NumPad4 | -2130705333
Subtract | -2130705334 | MINUS SIGN (-) on numeric keypad
NumPad9 | -2130705335
NumPad8 | -2130705336
NumPad7 | -2130705337
Scroll | -2130705338 | SCROLL LOCK
Numlock | -2130705339
F10 | -2130705340
F9 | -2130705341
F8 | -2130705342
F7 | -2130705343
F6 | -2130705344
F5 | -2130705345
F4 | -2130705346
F3 | -2130705347
F2 | -2130705348
F1 | -2130705349
Capital | -2130705350 | CAPS LOCK
Space | -2130705351 | SPACEBAR
LeftMenu | -2130705352 | Left ALT
Multiply | -2130705353 | ASTERISK (*) on numeric keypad
RightShift | -2130705354 | RIGHT ARROW
Slash | -2130705355 | FORWARD SLASH (/) on main keyboard
Period | -2130705356 | On main keyboard
Comma | -2130705357
M | -2130705358
N | -2130705359
B | -2130705360
V | -2130705361
C | -2130705362
Z | -2130705364
BackSlash | -2130705365
LeftShift | -2130705366 | LEFT ARROW
Grave | -2130705367 | GRAVE ACCENT (`)
Apostrophe | -2130705368
SemiColon | -2130705369
L | -2130705370
K | -2130705371
J | -2130705372
H | -2130705373
G | -2130705374
F | -2130705375
D | -2130705376
S | -2130705377
A | -2130705378
LeftControl | -2130705379
Return | -2130705380 | ENTER on main keyboard
RightBracket | -2130705381
LeftBracket | -2130705382
P | -2130705383
O | -2130705384
I | -2130705385
U | -2130705386
T | -2130705388
R | -2130705389
E | -2130705390
W | -2130705391
Tab | -2130705393
Back | -2130705394 | BACKSPACE
Equals | -2130705395 | Returns a value indicating whether this instance is equal to a specified object.
Minus | -2130705396 | On main keyboard
D0 | -2130705397 | On main keyboard
D9 | -2130705398 | On main keyboard
D8 | -2130705399 | On main keyboard
D7 | -2130705400 | On main keyboard
D6 | -2130705401 | On main keyboard
D5 | -2130705402 | On main keyboard
D4 | -2130705403 | On main keyboard
D3 | -2130705404 | On main keyboard
D2 | -2130705405 | On main keyboard
D1 | -2130705406 | On main keyboard
Insert | -2130705198 | Inserts an element into the collection at the specified index.
Right | -2130705203 | RIGHT ARROW
Left | -2130705205 | LEFT ARROW
Pause | -2130705211
Add | -2130705330 | PLUS SIGN (+) on numeric keypad
Delete | -2130705197
Q | -2130705392

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MaxPoints

Microsoft DirectX 9.0 SDK Update (October 2004)

MaxPoints Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum MaxPoints
C# | public enum MaxPoints
Managed C++ | __value public enum MaxPoints
JScript .NET | public enum MaxPoints

Members

Member | Value | Description
Value | 8

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Mouse

Microsoft DirectX 9.0 SDK Update (October 2004)

Mouse Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical axis or button on a mouse.

Definition

Visual Basic .NET | Public Enum Mouse
C# | public enum Mouse
Managed C++ | __value public enum Mouse
JScript .NET | public enum Mouse

Members

Member | Value | Description
Button7 | -2113928173
Button6 | -2113928174
Button5 | -2113928175
Button4 | -2113928176
Button3 | -2113928177
Button2 | -2113928178
Button1 | -2113928179
Button0 | -2113928180
Wheel | -2113928440
YAxis | -2113928444
XAxis | -2113928448
YAxisAB | -2113928700
XAxisAB | -2113928704

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MouseOffset

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseOffset Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Mouse device constants, defined in Dinput.h, represent offsets within a mouse device's data packet, the Dimousestate or Dimousestate2 structure.

Definition

Visual Basic .NET | Public Enum MouseOffset
C# | public enum MouseOffset
Managed C++ | __value public enum MouseOffset
JScript .NET | public enum MouseOffset

Members

Member | Value | Description
Y | 4
X | 0
Button7 | 19 | Dimousestate2 only
Button6 | 18 | Dimousestate2 only
Button5 | 17 | Dimousestate2 only
Button4 | 16 | Dimousestate2 only
Button3 | 15
Button2 | 14
Button1 | 13
Button0 | 12
Z | 8

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ObjectInstanceFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectInstanceFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum ObjectInstanceFlags
C# | public enum ObjectInstanceFlags
Managed C++ | __value public enum ObjectInstanceFlags
JScript .NET | public enum ObjectInstanceFlags

Members

Member | Value | Description
Mask | 3840 | Flags describing other attributes of the data format. This value can be one of the following:
GuidUsage | 65536
Force | 1024 | The magnitude of the maximum force that can be created by the actuator associated with this object. Force is expressed in newtons and measured in relation to where the hand would be during normal operation of the device.
Acceleration | 768
Velocity | 512
Position | 256
Polled | 32768
EffectTrigger | 2
Actuator | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ParameterHow

Microsoft DirectX 9.0 SDK Update (October 2004)

ParameterHow Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum ParameterHow
C# | public enum ParameterHow
Managed C++ | __value public enum ParameterHow
JScript .NET | public enum ParameterHow

Members

Member | Value | Description
ByUsage | 3
ById | 2
ByOffset | 1
ByDevice | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PropertyType

Microsoft DirectX 9.0 SDK Update (October 2004)

PropertyType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum PropertyType
C# | public enum PropertyType
Managed C++ | __value public enum PropertyType
JScript .NET | public enum PropertyType

Members

Member | Value | Description
UserName | 25
Granularity | 3
BufferSize | 1
TypeName | 26
VendorIdentityProductId | 24
ScanCode | 23
AppData | 22
CalibrationPoints | 21
KeyName | 20
LogicalRange | 19
PhysicalRange | 18
GetPortDisplayName | 16
JoystickId | 15
ProductName | 14
InstanceName | 13
GuidAndPath | 12
Calibration | 11
CalibrationMode | 10
AutoCenter | 9
ForceFeedbackLoad | 8
ForceFeedbackGain | 7
Saturation | 6
DeadZone | 5
Range | 4
AxisMode | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PropRangeFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

PropRangeFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.

Definition

Visual Basic .NET | Public Enum PropRangeFlags
C# | public enum PropRangeFlags
Managed C++ | __value public enum PropRangeFlags
JScript .NET | public enum PropRangeFlags

Members

Member | Value | Description
NoMax | 2147483647
NoMin | -2147483648

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RemoteControl

Microsoft DirectX 9.0 SDK Update (October 2004)

RemoteControl Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum RemoteControl
C# | public enum RemoteControl
Managed C++ | __value public enum RemoteControl
JScript .NET | public enum RemoteControl

Members

Member | Value | Description
ButtonPause | 654329084
ButtonDevice | 654329086
ButtonMenu | 654312701
ButtonPlay | 654320643
ButtonSelect | 654312450
RemoteControl | 654311424
ButtonDigit9 | 654332952
ButtonDigit8 | 654332951
ButtonDigit7 | 654332950
ButtonDigit6 | 654332949
ButtonDigit5 | 654332948
ButtonDigit4 | 654332947
ButtonDigit3 | 654332946
ButtonDigit2 | 654332945
ButtonDigit1 | 654332944
ButtonDigit0 | 654332943
ButtonAdjust | 654334990
ButtonDvd | 654334989
ButtonTuner | 654334988
ButtonVcr | 654334987
ButtonCD | 654334986
ButtonCable | 654334985
ButtonTV | 654334984
AxisSlider2 | 654656002
ButtonRecord | 654320647
ButtonChange | 654320646
ButtonReview | 654320645
ButtonCue | 654320644
ButtonMute | 654312449
AxisSlider | 654639617

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReturnCode

Microsoft DirectX 9.0 SDK Update (October 2004)

ReturnCode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum ReturnCode
C# | public enum ReturnCode
Managed C++ | __value public enum ReturnCode
JScript .NET | public enum ReturnCode

Members

Member | Value | Description
WriteProtect | 19
TruncatedAndRestarted | 12
SettingsNotSaved | 11
Truncated | 8
EffectRestarted | 4
DownloadSkipped | 3
PolledDevice | 2
NoEffect | 1
PropNoEffect | 1
BufferOverflow | 1
NotAttached | 1
Ok | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SetActionMapReturnCodes

Microsoft DirectX 9.0 SDK Update (October 2004)

SetActionMapReturnCodes Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SetActionMapReturnCodes
C# | public enum SetActionMapReturnCodes
Managed C++ | __value public enum SetActionMapReturnCodes
JScript .NET | public enum SetActionMapReturnCodes

Members

Member | Value | Description
WriteProtected | 19
SettingsNotSaved | 11
Success | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SpaceSim

Microsoft DirectX 9.0 SDK Update (October 2004)

SpaceSim Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SpaceSim
C# | public enum SpaceSim
Managed C++ | __value public enum SpaceSim
JScript .NET | public enum SpaceSim

Members

Member | Value | Description
ButtonPause | 117458172
ButtonDevice | 117458174
ButtonGlanceDownLink | 117949672
ButtonGlanceUpLink | 117949664
ButtonGlanceRightLink | 117949676
ButtonGlanceLeftLink | 117949668
ButtonTurnRightLink | 117589228
ButtonTurnLeftLink | 117589220
ButtonSlowerLink | 117687528
ButtonFasterLink | 117687520
ButtonBackwardLink | 117523688
ButtonForwardLink | 117523680
ButtonRightLink | 117490924
ButtonLeftLink | 117490916
ButtonFireSecondary | 117457929
ButtonGear | 117457928
ButtonLower | 117457927
ButtonRaise | 117457926
ButtonDisplay | 117457925
ButtonView | 117457924
AxisRotate | 117588485
AxisClimb | 117555716
HatSwitchGlance | 117458433
ButtonMenu | 117441789
ButtonTarget | 117441539
ButtonWeapons | 117441538
ButtonFire | 117441537
AxisThrottle | 117670403
AxisMove | 117506562
AxisLateral | 117473793
SpaceSim | 117440512

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsBaseballBatting

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsBaseballBatting Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsBaseballBatting
C# | public enum SportsBaseballBatting
Managed C++ | __value public enum SportsBaseballBatting
JScript .NET | public enum SportsBaseballBatting

Members

Member | Value | Description
ButtonPause | 251675900
ButtonDevice | 251675902
ButtonBackLink | 251741416
ButtonForwardLink | 251741408
ButtonRightLink | 251708652
ButtonLeftLink | 251708644
ButtonBox | 251675658
ButtonNoSteal | 251675657
ButtonMenu | 251659517
ButtonContact | 251659272
ButtonSlide | 251659271
ButtonBurst | 251659270
ButtonSteal | 251659269
ButtonBunt | 251659268
ButtonPower | 251659267
ButtonNormal | 251659266
ButtonSelect | 251659265
AxisMove | 251724290
AxisLateral | 251691521
SportsBaseballBatting | 251658240

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsBaseBallField

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsBaseBallField Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsBaseBallField
C# | public enum SportsBaseBallField
Managed C++ | __value public enum SportsBaseBallField
JScript .NET | public enum SportsBaseBallField

Members

Member | Value | Description
ButtonPause | 285230332
ButtonDevice | 285230334
ButtonBackLink | 285295848
ButtonForwardLink | 285295840
ButtonAimRightLink | 285263084
ButtonAimLeftLink | 285263076
ButtonShiftOut | 285230088
ButtonShiftIn | 285230087
ButtonMenu | 285213949
ButtonDive | 285213702
ButtonJump | 285213701
ButtonBurst | 285213700
ButtonThrow2 | 285213699
ButtonThrow1 | 285213698
ButtonNearest | 285213697
AxisMove | 285278722
AxisLateral | 285245953
SportsBaseBallField | 285212672

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsBaseballPitch

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsBaseballPitch Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsBaseballPitch
C# | public enum SportsBaseballPitch
Managed C++ | __value public enum SportsBaseballPitch
JScript .NET | public enum SportsBaseballPitch

Members

Member | Value | Description
ButtonBase | 268436483
ButtonPause | 268453116
ButtonDevice | 268453118
ButtonBackLink | 268518632
ButtonForwardLink | 268518624
ButtonRightLink | 268485868
ButtonLeftLink | 268485860
ButtonLook | 268452871
ButtonWalk | 268452870
ButtonMenu | 268436733
ButtonFake | 268436485
ButtonThrow | 268436484
ButtonPitch | 268436482
ButtonSelect | 268436481
AxisMove | 268501506
AxisLateral | 268468737
SportsBaseballPitch | 268435456

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsBasketballDefense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsBasketballDefense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsBasketballDefense
C# | public enum SportsBasketballDefense
Managed C++ | __value public enum SportsBasketballDefense
JScript .NET | public enum SportsBasketballDefense

Members

Member | Value | Description
ButtonPause | 318784764
ButtonDevice | 318784766
ButtonBackLink | 318850280
ButtonForwardLink | 318850272
ButtonRightLink | 318817516
ButtonLeftLink | 318817508
ButtonSubstitute | 318784521
ButtonTimeout | 318784520
HatSwitchGlance | 318785025
ButtonMenu | 318768381
ButtonPlay | 318768135
ButtonBurst | 318768134
ButtonPlayer | 318768133
ButtonSpecial | 318768132
ButtonFake | 318768131
ButtonSteal | 318768130
ButtonJump | 318768129
AxisMove | 318833154
AxisLateral | 318800385
SportsBasketballDefense | 318767104

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsBasketballOffense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsBasketballOffense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsBasketballOffense
C# | public enum SportsBasketballOffense
Managed C++ | __value public enum SportsBasketballOffense
JScript .NET | public enum SportsBasketballOffense

Members

Member | Value | Description
ButtonPause | 302007548
ButtonDevice | 302007550
ButtonBackLink | 302073064
ButtonForwardLink | 302073056
ButtonRightLink | 302040300
ButtonLeftLink | 302040292
ButtonSubstitute | 302007310
ButtonTimeout | 302007309
ButtonPost | 302007308
ButtonJab | 302007307
ButtonPlay | 302007306
ButtonScreen | 302007305
HatSwitchGlance | 302007809
ButtonMenu | 301991165
ButtonCall | 301990920
ButtonBurst | 301990919
ButtonPlayer | 301990918
ButtonSpecial | 301990917
ButtonFake | 301990916
ButtonPass | 301990915
ButtonDunk | 301990914
ButtonShoot | 301990913
AxisMove | 302055938
AxisLateral | 302023169
SportsBasketballOffense | 301989888

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsBikingMountain

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsBikingMountain Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsBikingMountain
C# | public enum SportsBikingMountain
Managed C++ | __value public enum SportsBikingMountain
JScript .NET | public enum SportsBikingMountain

Members

Member | Value | Description
ButtonPause | 469779708
ButtonDevice | 469779710
ButtonBrakeLink | 470041832
ButtonSlowerLink | 469845224
ButtonFasterLink | 469845216
ButtonRightLink | 469812460
ButtonLeftLink | 469812452
AxisBrake | 470041091
ButtonZoom | 469779462
HatSwitchScroll | 469779969
ButtonMenu | 469763325
ButtonSpecial2 | 469763077
ButtonSelect | 469763076
ButtonSpecial1 | 469763075
ButtonCamera | 469763074
ButtonJump | 469763073
AxisPedal | 469828098
AxisTurn | 469795329
SportsBikingMountain | 469762048

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsFishing

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsFishing Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsFishing
C# | public enum SportsFishing
Managed C++ | __value public enum SportsFishing
JScript .NET | public enum SportsFishing

Members

Member | Value | Description
ButtonPause | 234898684
ButtonDevice | 234898686
ButtonRotateRightLink | 235029740
ButtonRotateLeftLink | 235029732
ButtonBackLink | 234964200
ButtonForwardLink | 234964192
ButtonRightLink | 234931436
ButtonLeftLink | 234931428
ButtonJump | 234898440
ButtonCrouch | 234898439
AxisRotate | 235028995
ButtonDisplay | 234898438
HatSwitchGlance | 234898945
ButtonMenu | 234882301
ButtonMap | 234882053
ButtonBait | 234882052
ButtonBinocular | 234882051
ButtonType | 234882050
ButtonCast | 234882049
AxisMove | 234947074
AxisLateral | 234914305
SportsFishing | 234881024

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsFootballDefense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsFootballDefense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsFootballDefense
C# | public enum SportsFootballDefense
Managed C++ | __value public enum SportsFootballDefense
JScript .NET | public enum SportsFootballDefense

Members

Member | Value | Description
ButtonPause | 385893628
ButtonDevice | 385893630
ButtonBackLink | 385959144
ButtonForwardLink | 385959136
ButtonRightLink | 385926380
ButtonLeftLink | 385926372
ButtonSubstitute | 385893389
ButtonZoom | 385893388
ButtonAudible | 385893387
ButtonRip | 385893386
ButtonBullRush | 385893385
ButtonSwim | 385893384
ButtonSpin | 385893383
ButtonMenu | 385877245
ButtonSuperTackle | 385876998
ButtonFake | 385876997
ButtonTackle | 385876996
ButtonJump | 385876995
ButtonSelect | 385876994
ButtonPlay | 385876993
AxisMove | 385942018
AxisLateral | 385909249
SportsFootballDefense | 385875968

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsFootballField

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsFootballField Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsFootballField
C# | public enum SportsFootballField
Managed C++ | __value public enum SportsFootballField
JScript .NET | public enum SportsFootballField

Members

Member | Value | Description
ButtonPause | 335561980
ButtonDevice | 335561982
ButtonMenu | 335545597
ButtonHelp | 335545347
ButtonSelect | 335545346
ButtonPlay | 335545345
SportsFootballField | 335544320

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsFootballOffense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsFootballOffense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsFootballOffense
C# | public enum SportsFootballOffense
Managed C++ | __value public enum SportsFootballOffense
JScript .NET | public enum SportsFootballOffense

Members

Member | Value | Description
ButtonPause | 369116412
ButtonDevice | 369116414
ButtonBackLink | 369181928
ButtonForwardLink | 369181920
ButtonRightLink | 369149164
ButtonLeftLink | 369149156
ButtonSubstitute | 369116171
ButtonZoom | 369116170
ButtonDive | 369116169
ButtonTurbo | 369116168
ButtonShoulder | 369116167
ButtonJuke | 369116166
ButtonMenu | 369100029
ButtonSpin | 369099781
ButtonThrow | 369099780
ButtonRightArm | 369099779
ButtonLeftArm | 369099778
ButtonJump | 369099777
AxisMove | 369164802
AxisLateral | 369132033
SportsFootballOffense | 369098752

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsFootballQuarterback

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsFootballQuarterback Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsFootballQuarterback
C# | public enum SportsFootballQuarterback
Managed C++ | __value public enum SportsFootballQuarterback
JScript .NET | public enum SportsFootballQuarterback

Members

Member | Value | Description
ButtonPause | 352339196
ButtonDevice | 352339198
ButtonBackLink | 352404712
ButtonForwardLink | 352404704
ButtonRightLink | 352371948
ButtonLeftLink | 352371940
ButtonAudible | 352338953
ButtonMotion | 352338952
ButtonFakeSnap | 352338951
ButtonMenu | 352322813
ButtonFake | 352322566
ButtonPass | 352322565
ButtonSlide | 352322564
ButtonJump | 352322563
ButtonSnap | 352322562
ButtonSelect | 352322561
AxisMove | 352387586
AxisLateral | 352354817
SportsFootballQuarterback | 352321536

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsGolf

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsGolf Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsGolf
C# | public enum SportsGolf
Managed C++ | __value public enum SportsGolf
JScript .NET | public enum SportsGolf

Members

Member | Value | Description
ButtonPause | 402670844
ButtonDevice | 402670846
ButtonBackLink | 402736360
ButtonForwardLink | 402736352
ButtonRightLink | 402703596
ButtonLeftLink | 402703588
ButtonSubstitute | 402670601
ButtonTimeout | 402670600
ButtonZoom | 402670599
HatSwitchScroll | 402671105
ButtonMenu | 402654461
ButtonFlyBy | 402654214
ButtonTerrain | 402654213
ButtonDown | 402654212
ButtonUp | 402654211
ButtonSelect | 402654210
ButtonSwing | 402654209
AxisMove | 402719234
AxisLateral | 402686465
SportsGolf | 402653184

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsHockeyDefense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsHockeyDefense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsHockeyDefense
C# | public enum SportsHockeyDefense
Managed C++ | __value public enum SportsHockeyDefense
JScript .NET | public enum SportsHockeyDefense

Members

Member | Value | Description
ButtonPause | 436225276
ButtonDevice | 436225278
ButtonBackLink | 436290792
ButtonForwardLink | 436290784
ButtonRightLink | 436258028
ButtonLeftLink | 436258020
ButtonSubstitute | 436225033
ButtonTimeout | 436225032
ButtonStrategy | 436225031
ButtonZoom | 436225030
HatSwitchScroll | 436225537
ButtonMenu | 436208893
ButtonFake | 436208645
ButtonBlock | 436208644
ButtonBurst | 436208643
ButtonSteal | 436208642
ButtonPlayer | 436208641
AxisMove | 436273666
AxisLateral | 436240897
SportsHockeyDefense | 436207616

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsHockeyGoalie

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsHockeyGoalie Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsHockeyGoalie
C# | public enum SportsHockeyGoalie
Managed C++ | __value public enum SportsHockeyGoalie
JScript .NET | public enum SportsHockeyGoalie

Members

Member | Value | Description
ButtonPause | 453002492
ButtonDevice | 453002494
ButtonBackLink | 453068008
ButtonForwardLink | 453068000
ButtonRightLink | 453035244
ButtonLeftLink | 453035236
ButtonSubstitute | 453002248
ButtonTimeout | 453002247
ButtonStrategy | 453002246
ButtonZoom | 453002245
HatSwitchScroll | 453002753
ButtonMenu | 452986109
ButtonBlock | 452985860
ButtonSteal | 452985859
ButtonPoke | 452985858
ButtonPass | 452985857
AxisMove | 453050882
AxisLateral | 453018113
SportsHockeyGoalie | 452984832

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsHockeyOffense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsHockeyOffense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsHockeyOffense
C# | public enum SportsHockeyOffense
Managed C++ | __value public enum SportsHockeyOffense
JScript .NET | public enum SportsHockeyOffense

Members

Member | Value | Description
ButtonPause | 419448060
ButtonDevice | 419448062
ButtonBackLink | 419513576
ButtonForwardLink | 419513568
ButtonRightLink | 419480812
ButtonLeftLink | 419480804
ButtonSubstitute | 419447817
ButtonTimeout | 419447816
ButtonStrategy | 419447815
ButtonZoom | 419447814
HatSwitchScroll | 419448321
ButtonMenu | 419431677
ButtonFake | 419431429
ButtonSpecial | 419431428
ButtonBurst | 419431427
ButtonPass | 419431426
ButtonShoot | 419431425
AxisMove | 419496450
AxisLateral | 419463681
SportsHockeyOffense | 419430400

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsHunting

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsHunting Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsHunting
C# | public enum SportsHunting
Managed C++ | __value public enum SportsHunting
JScript .NET | public enum SportsHunting

Members

Member | Value | Description
ButtonPause | 218121468
ButtonDevice | 218121470
ButtonRotateRightLink | 218252524
ButtonRotateLeftLink | 218252516
ButtonBackLink | 218186984
ButtonForwardLink | 218186976
ButtonRightLink | 218154220
ButtonLeftLink | 218154212
ButtonFireSecondary | 218121227
ButtonJump | 218121226
ButtonCrouch | 218121225
AxisRotate | 218251779
ButtonDisplay | 218121224
HatSwitchGlance | 218121729
ButtonMenu | 218105085
ButtonSpecial | 218104839
ButtonMap | 218104838
ButtonCall | 218104837
ButtonBinocular | 218104836
ButtonWeapon | 218104835
ButtonAim | 218104834
ButtonFire | 218104833
AxisMove | 218169858
AxisLateral | 218137089
SportsHunting | 218103808

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsRaquet

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsRaquet Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsRaquet
C# | public enum SportsRaquet
Managed C++ | __value public enum SportsRaquet
JScript .NET | public enum SportsRaquet

Members

Member | Value | Description
ButtonPause | 536888572
ButtonDevice | 536888574
ButtonBackLink | 536954088
ButtonForwardLink | 536954080
ButtonRightLink | 536921324
ButtonLeftLink | 536921316
ButtonSubstitute | 536888327
ButtonTimeout | 536888326
HatSwitchGlance | 536888833
ButtonMenu | 536872189
ButtonSelect | 536871941
ButtonSpecial | 536871940
ButtonSmash | 536871939
ButtonBackswing | 536871938
ButtonSwing | 536871937
AxisMove | 536936962
AxisLateral | 536904193
SportsRaquet | 536870912

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsSkiing

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsSkiing Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsSkiing
C# | public enum SportsSkiing
Managed C++ | __value public enum SportsSkiing
JScript .NET | public enum SportsSkiing

Members

Member | Value | Description
ButtonPause | 486556924
ButtonDevice | 486556926
ButtonSlowerLink | 486622440
ButtonFasterLink | 486622432
ButtonRightLink | 486589676
ButtonLeftLink | 486589668
ButtonZoom | 486556679
HatSwitchGlance | 486557185
ButtonMenu | 486540541
ButtonSpecial2 | 486540294
ButtonSelect | 486540293
ButtonSpecial1 | 486540292
ButtonCamera | 486540291
ButtonCrouch | 486540290
ButtonJump | 486540289
AxisSpeed | 486605314
AxisTurn | 486572545
SportsSkiing | 486539264

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsSoccerDefense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsSoccerDefense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsSoccerDefense
C# | public enum SportsSoccerDefense
Managed C++ | __value public enum SportsSoccerDefense
JScript .NET | public enum SportsSoccerDefense

Members

Member | Value | Description
ButtonPause | 520111356
ButtonDevice | 520111358
ButtonBackLink | 520176872
ButtonForwardLink | 520176864
ButtonRightLink | 520144108
ButtonLeftLink | 520144100
ButtonSubstitute | 520111116
ButtonGoalieCharge | 520111115
ButtonClear | 520111114
ButtonHead | 520111113
ButtonFoul | 520111112
HatSwitchGlance | 520111617
ButtonMenu | 520094973
ButtonSlide | 520094727
ButtonSelect | 520094726
ButtonSpecial | 520094725
ButtonPlayer | 520094724
ButtonFake | 520094723
ButtonSteal | 520094722
ButtonBlock | 520094721
AxisMove | 520159746
AxisLateral | 520126977
SportsSoccerDefense | 520093696

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SportsSoccerOffense

Microsoft DirectX 9.0 SDK Update (October 2004)

SportsSoccerOffense Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum SportsSoccerOffense
C# | public enum SportsSoccerOffense
Managed C++ | __value public enum SportsSoccerOffense
JScript .NET | public enum SportsSoccerOffense

Members

Member | Value | Description
ButtonPause | 503334140
ButtonDevice | 503334142
ButtonBackLink | 503399656
ButtonForwardLink | 503399648
ButtonRightLink | 503366892
ButtonLeftLink | 503366884
ButtonHead | 503333901
ButtonControl | 503333900
ButtonSprint | 503333899
ButtonPassThru | 503333898
ButtonShootHigh | 503333897
ButtonShootLow | 503333896
ButtonSubstitute | 503333895
HatSwitchGlance | 503334401
ButtonMenu | 503317757
ButtonSelect | 503317510
ButtonSpecial1 | 503317509
ButtonPlayer | 503317508
ButtonFake | 503317507
ButtonPass | 503317506
ButtonShoot | 503317505
AxisBend | 503415299
AxisMove | 503382530
AxisLateral | 503349761
SportsSoccerOffense | 503316480

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StandardEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

StandardEffect Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum StandardEffect
C# | public enum StandardEffect
Managed C++ | __value public enum StandardEffect
JScript .NET | public enum StandardEffect

Members

Member | Value | Description
ConditionEffect | 13
PeriodicEffect | 12
CustomForceEffect | 11
FrictionEffect | 10
InertiaEffect | 9
DamperEffect | 8
SpringEffect | 7
SawtoothDownEffect | 6
SawtoothUpEffect | 5
TriangleEffect | 4
SineEffect | 3
SquareEffect | 2
RampForceEffect | 1
ConstantForceEffect | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StrategyRolePlaying

Microsoft DirectX 9.0 SDK Update (October 2004)

StrategyRolePlaying Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum StrategyRolePlaying
C# | public enum StrategyRolePlaying
Managed C++ | __value public enum StrategyRolePlaying
JScript .NET | public enum StrategyRolePlaying

Members

Member | Value | Description
ButtonPause | 184567036
ButtonDevice | 184567038
ButtonRotateRightLink | 184698092
ButtonRotateLeftLink | 184698084
ButtonBackLink | 184632552
ButtonForwardLink | 184632544
ButtonRightLink | 184599788
ButtonLeftLink | 184599780
AxisRotate | 184697347
ButtonDisplay | 184566793
ButtonMap | 184566792
HatSwitchGlance | 184567297
ButtonMenu | 184550653
ButtonJump | 184550407
ButtonCrouch | 184550406
ButtonCast | 184550405
ButtonAttack | 184550404
ButtonSelect | 184550403
ButtonApply | 184550402
ButtonGet | 184550401
AxisMove | 184615426
AxisLateral | 184582657
StrategyRolePlaying | 184549376

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StrategyTurn

Microsoft DirectX 9.0 SDK Update (October 2004)

StrategyTurn Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum StrategyTurn
C# | public enum StrategyTurn
Managed C++ | __value public enum StrategyTurn
JScript .NET | public enum StrategyTurn

Members

Member | Value | Description
ButtonPause | 201344252
ButtonDevice | 201344254
ButtonBackLink | 201409768
ButtonForwardLink | 201409760
ButtonRightLink | 201377004
ButtonLeftLink | 201376996
ButtonDisplay | 201344008
ButtonMap | 201344007
ButtonZoom | 201344006
ButtonMenu | 201327869
ButtonTurn | 201327621
ButtonTeam | 201327620
ButtonApply | 201327619
ButtonInstruct | 201327618
ButtonSelect | 201327617
AxisMove | 201392642
AxisLateral | 201359873
StrategyTurn | 201326592

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TextAlign

Microsoft DirectX 9.0 SDK Update (October 2004)

TextAlign Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum TextAlign
C# | public enum TextAlign
Managed C++ | __value public enum TextAlign
JScript .NET | public enum TextAlign

Members

Member | Value | Description
BottomAligned | 8
TopAligned | 4
Middle | 0
RightAligned | 2
LeftAlign | 1
Centered | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TimeStamp

Microsoft DirectX 9.0 SDK Update (October 2004)

TimeStamp Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum TimeStamp
C# | public enum TimeStamp
Managed C++ | __value public enum TimeStamp
JScript .NET | public enum TimeStamp

Members

Member | Value | Description
UnusedDeviceHigh | 0
UnusedDeviceLow | 0
NewDeviceHigh | -1
NewDeviceLow | -1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Voice

Microsoft DirectX 9.0 SDK Update (October 2004)

Voice Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Enum Voice
C# | public enum Voice
Managed C++ | __value public enum Voice
JScript .NET | public enum Voice

Members

Member | Value | Description
VoiceCommand | -2097150960
Transmit | -2097150963
PlaybackMute | -2097150964
RecordMute | -2097150965
Team | -2097150967
Channel8 | -2097150968
Channel7 | -2097150969
Channel6 | -2097150970
Channel5 | -2097150971
Channel4 | -2097150972
Channel3 | -2097150973
Channel2 | -2097150974
Channel1 | -2097150975
All | -2097150966

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CalibrationPoint

Microsoft DirectX 9.0 SDK Update (October 2004)

CalibrationPoint Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a calibration point. An array of Cpoint structures is contained by a Dipropcpoints structure.

Definition

Visual Basic .NET | Public Structure CalibrationPoint
C# | public struct CalibrationPoint
Managed C++ | public __value struct CalibrationPoint
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CalibrationPoint | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
RawData
ScalingValue | Scaling value to be associated with the LP number. The percentage of the maximum value multiplied by 10000.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CalibrationPoint.CalibrationPoint()

Microsoft DirectX 9.0 SDK Update (October 2004)

CalibrationPoint.CalibrationPoint Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public CalibrationPoint();
Managed C++ | public: CalibrationPoint();
JScript .NET | public function CalibrationPoint();


CalibrationPoint.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CalibrationPoint.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CalibrationPoint.RawData

Microsoft DirectX 9.0 SDK Update (October 2004)

CalibrationPoint.RawData Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property RawData As Integer
C# | public int RawData { get; set; }
Managed C++ public: __property int get_RawData();
public: __property void set_RawData(int);
JScript .NET public function get RawData() : int
public function set RawData(int);

Property Value

System.Int32 .

This property is read/write.


CalibrationPoint.ScalingValue

Microsoft DirectX 9.0 SDK Update (October 2004)

CalibrationPoint.ScalingValue Property

Language:
Note: This documentation is preliminary and is subject to change.

Scaling value to be associated with the LP number. The percentage of the maximum value multiplied by 10000.

Definition

Visual Basic .NET | Public Property ScalingValue As Integer
C# | public int ScalingValue { get; set; }
Managed C++ public: __property int get_ScalingValue();
public: __property void set_ScalingValue(int);
JScript .NET public function get ScalingValue() : int
public function set ScalingValue(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a set of colors used to draw the device configuration user object. It is part of the Diconfiguredevicesparams structure.

Definition

Visual Basic .NET | Public Structure ColorSet
C# | public struct ColorSet
Managed C++ | public __value struct ColorSet
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ColorSet | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AreaFill | Fill color for areas outside controls such as tabs and buttons.
Border | Border color, used to display lines around controls such as tabs and buttons.
CalloutHighlight | Color used to display callout lines.
CalloutLine | Color used to display callout lines.
ControlFill | Fill color for controls such as tabs and buttons.
HighlightFill | Fill color for highlighted controls.
TextFore | Foreground text color.
TextHighlight | Foreground color for highlighted text.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ColorSet.ColorSet()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.ColorSet Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public ColorSet();
Managed C++ | public: ColorSet();
JScript .NET | public function ColorSet();


ColorSet.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ColorSet.AreaFill

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.AreaFill Property

Language:
Note: This documentation is preliminary and is subject to change.

Fill color for areas outside controls such as tabs and buttons.

Definition

Visual Basic .NET | Public Property AreaFill As Integer
C# | public int AreaFill { get; set; }
Managed C++ public: __property int get_AreaFill();
public: __property void set_AreaFill(int);
JScript .NET public function get AreaFill() : int
public function set AreaFill(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet.Border

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.Border Property

Language:
Note: This documentation is preliminary and is subject to change.

Border color, used to display lines around controls such as tabs and buttons.

Definition

Visual Basic .NET | Public Property Border As Integer
C# | public int Border { get; set; }
Managed C++ public: __property int get_Border();
public: __property void set_Border(int);
JScript .NET public function get Border() : int
public function set Border(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet.CalloutHighlight

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.CalloutHighlight Property

Language:
Note: This documentation is preliminary and is subject to change.

Color used to display callout lines.

Definition

Visual Basic .NET | Public Property CalloutHighlight As Integer
C# | public int CalloutHighlight { get; set; }
Managed C++ public: __property int get_CalloutHighlight();
public: __property void set_CalloutHighlight(int);
JScript .NET public function get CalloutHighlight() : int
public function set CalloutHighlight(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet.CalloutLine

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.CalloutLine Property

Language:
Note: This documentation is preliminary and is subject to change.

Color used to display callout lines.

Definition

Visual Basic .NET | Public Property CalloutLine As Integer
C# | public int CalloutLine { get; set; }
Managed C++ public: __property int get_CalloutLine();
public: __property void set_CalloutLine(int);
JScript .NET public function get CalloutLine() : int
public function set CalloutLine(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet.ControlFill

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.ControlFill Property

Language:
Note: This documentation is preliminary and is subject to change.

Fill color for controls such as tabs and buttons.

Definition

Visual Basic .NET | Public Property ControlFill As Integer
C# | public int ControlFill { get; set; }
Managed C++ public: __property int get_ControlFill();
public: __property void set_ControlFill(int);
JScript .NET public function get ControlFill() : int
public function set ControlFill(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet.HighlightFill

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.HighlightFill Property

Language:
Note: This documentation is preliminary and is subject to change.

Fill color for highlighted controls.

Definition

Visual Basic .NET | Public Property HighlightFill As Integer
C# | public int HighlightFill { get; set; }
Managed C++ public: __property int get_HighlightFill();
public: __property void set_HighlightFill(int);
JScript .NET public function get HighlightFill() : int
public function set HighlightFill(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet.TextFore

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.TextFore Property

Language:
Note: This documentation is preliminary and is subject to change.

Foreground text color.

Definition

Visual Basic .NET | Public Property TextFore As Integer
C# | public int TextFore { get; set; }
Managed C++ public: __property int get_TextFore();
public: __property void set_TextFore(int);
JScript .NET public function get TextFore() : int
public function set TextFore(int);

Property Value

System.Int32 .

This property is read/write.


ColorSet.TextHighlight

Microsoft DirectX 9.0 SDK Update (October 2004)

ColorSet.TextHighlight Property

Language:
Note: This documentation is preliminary and is subject to change.

Foreground color for highlighted text.

Definition

Visual Basic .NET | Public Property TextHighlight As Integer
C# | public int TextHighlight { get; set; }
Managed C++ public: __property int get_TextHighlight();
public: __property void set_TextHighlight(int);
JScript .NET public function get TextHighlight() : int
public function set TextHighlight(int);

Property Value

System.Int32 .

This property is read/write.


Condition

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains type-specific information for effects that are marked as DIEFT_CONDITION.A reference to an array of Dicondition structures for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure. The number of elements in the array must be either one, or equal to the number of axes associated with the effect.

Definition

Visual Basic .NET | Public Structure Condition
C# | public struct Condition
Managed C++ | public __value struct Condition
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Condition | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DeadBand | Region around LOffset in which the condition is not active, in the range from 0 through 10,000. In other words, the condition is not active between LOffset minus LDeadBand and LOffset plus LDeadBand.
NegativeCoefficient | Coefficient constant on the negative side of the offset, in the range from -10,000 through 10,000. If the device does not support separate positive and negative coefficients, the value of LNegative
NegativeSaturation | Maximum force output on the negative side of the offset, in the range from 0 through 10,000.If the device does not support force saturation, the value of this member is ignored.If the device does not support separate positive and negative saturation, the value of DwNegativeSaturation is ignored, and the value of DwPositiveSaturation is used as both the positive and negative saturation.
Offset | Offset for the condition, in the range from -10,000 through 10,000.
PositiveCoefficient | Coefficient constant on the positive side of the offset, in the range from -10,000 through 10,000.
PositiveSaturation | Maximum force output on the positive side of the offset, in the range from 0 through 10,000.If the device does not support force TermSaturation, the value of this member is ignored.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Condition.Condition()

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.Condition Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public Condition();
Managed C++ | public: Condition();
JScript .NET | public function Condition();


Condition.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Condition.DeadBand

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.DeadBand Property

Language:
Note: This documentation is preliminary and is subject to change.

Region around LOffset in which the condition is not active, in the range from 0 through 10,000. In other words, the condition is not active between LOffset minus LDeadBand and LOffset plus LDeadBand.

Definition

Visual Basic .NET | Public Property DeadBand As Integer
C# | public int DeadBand { get; set; }
Managed C++ public: __property int get_DeadBand();
public: __property void set_DeadBand(int);
JScript .NET public function get DeadBand() : int
public function set DeadBand(int);

Property Value

System.Int32 .

This property is read/write.


Condition.NegativeCoefficient

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.NegativeCoefficient Property

Language:
Note: This documentation is preliminary and is subject to change.

Coefficient constant on the negative side of the offset, in the range from -10,000 through 10,000. If the device does not support separate positive and negative coefficients, the value of LNegative

Definition

Visual Basic .NET | Public Property NegativeCoefficient As Integer
C# | public int NegativeCoefficient { get; set; }
Managed C++ public: __property int get_NegativeCoefficient();
public: __property void set_NegativeCoefficient(int);
JScript .NET public function get NegativeCoefficient() : int
public function set NegativeCoefficient(int);

Property Value

System.Int32 .

This property is read/write.


Condition.NegativeSaturation

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.NegativeSaturation Property

Language:
Note: This documentation is preliminary and is subject to change.

Maximum force output on the negative side of the offset, in the range from 0 through 10,000.If the device does not support force saturation, the value of this member is ignored.If the device does not support separate positive and negative saturation, the value of DwNegativeSaturation is ignored, and the value of DwPositiveSaturation is used as both the positive and negative saturation.

Definition

Visual Basic .NET | Public Property NegativeSaturation As Integer
C# | public int NegativeSaturation { get; set; }
Managed C++ public: __property int get_NegativeSaturation();
public: __property void set_NegativeSaturation(int);
JScript .NET public function get NegativeSaturation() : int
public function set NegativeSaturation(int);

Property Value

System.Int32 .

This property is read/write.


Condition.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

Offset for the condition, in the range from -10,000 through 10,000.

Definition

Visual Basic .NET | Public Property Offset As Integer
C# | public int Offset { get; set; }
Managed C++ public: __property int get_Offset();
public: __property void set_Offset(int);
JScript .NET public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32 .

This property is read/write.


Condition.PositiveCoefficient

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.PositiveCoefficient Property

Language:
Note: This documentation is preliminary and is subject to change.

Coefficient constant on the positive side of the offset, in the range from -10,000 through 10,000.

Definition

Visual Basic .NET | Public Property PositiveCoefficient As Integer
C# | public int PositiveCoefficient { get; set; }
Managed C++ public: __property int get_PositiveCoefficient();
public: __property void set_PositiveCoefficient(int);
JScript .NET public function get PositiveCoefficient() : int
public function set PositiveCoefficient(int);

Property Value

System.Int32 .

This property is read/write.


Condition.PositiveSaturation

Microsoft DirectX 9.0 SDK Update (October 2004)

Condition.PositiveSaturation Property

Language:
Note: This documentation is preliminary and is subject to change.

Maximum force output on the positive side of the offset, in the range from 0 through 10,000.If the device does not support force TermSaturation, the value of this member is ignored.

Definition

Visual Basic .NET | Public Property PositiveSaturation As Integer
C# | public int PositiveSaturation { get; set; }
Managed C++ public: __property int get_PositiveSaturation();
public: __property void set_PositiveSaturation(int);
JScript .NET public function get PositiveSaturation() : int
public function set PositiveSaturation(int);

Property Value

System.Int32 .

This property is read/write.


ConstantForce

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantForce Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains type-specific information for effects that are marked as DIEFT_CONSTANTFORCE.The structure describes a constant force effect.A reference to a single Diconstantforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic .NET | Public Structure ConstantForce
C# | public struct ConstantForce
Managed C++ | public __value struct ConstantForce
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConstantForce | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Magnitude | The magnitude of the effect, in the range from -10,000 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConstantForce.ConstantForce()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantForce.ConstantForce Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConstantForce();
Managed C++ | public: ConstantForce();
JScript .NET | public function ConstantForce();


ConstantForce.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantForce.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConstantForce.Magnitude

Microsoft DirectX 9.0 SDK Update (October 2004)

ConstantForce.Magnitude Property

Language:
Note: This documentation is preliminary and is subject to change.

The magnitude of the effect, in the range from -10,000 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.

Definition

Visual Basic .NET | Public Property Magnitude As Integer
C# | public int Magnitude { get; set; }
Managed C++ public: __property int get_Magnitude();
public: __property void set_Magnitude(int);
JScript .NET public function get Magnitude() : int
public function set Magnitude(int);

Property Value

System.Int32 .

This property is read/write.


CustomForce

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains type-specific information for effects that are marked as DIEFT_CUSTOMFORCE.The structure describes a custom or user-defined force.A reference to a Dicustomforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic .NET | Public Structure CustomForce
C# | public struct CustomForce
Managed C++ | public __value struct CustomForce
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CustomForce | Initializes a new instance of the object.
GetForceData
SetForceData
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Channels | Number of channels (axes) affected by this force. The first channel is applied to the first axis associated with the effect, the second to the second, and so on. If there are fewer channels than axes, nothing is associated with the extra axes.If there is only a single channel, the effect is rotated in the direction specified by the rglDirection member of the Dieffect structure. If there is more than one channel, rotation is not allowed.Not all devices support rotation of custom effects.
SamplePeriod | Sample period, in microseconds.
Samples | Total number of samples in the RglForceData. It must be an integral multiple of the CChannels.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CustomForce.CustomForce()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce.CustomForce Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public CustomForce();
Managed C++ | public: CustomForce();
JScript .NET | public function CustomForce();


CustomForce.GetForceData()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce.GetForceData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Function GetForceData() As Integer()
C# | public int[] GetForceData();
Managed C++ | public: int GetForceData() __gc[];
JScript .NET | public function GetForceData() : int[];

Return Value

System.Int32[].


CustomForce.SetForceData(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce.SetForceData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Sub SetForceData( _
ByVal value() As Integer _
)
C# public void SetForceData(
int[] value
);
Managed C++ public: void SetForceData(
int value __gc[]
);
JScript .NET public function SetForceData(
value : int[]
);

Parameters

value System.Int32[].


CustomForce.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CustomForce.Channels

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce.Channels Property

Language:
Note: This documentation is preliminary and is subject to change.

Number of channels (axes) affected by this force. The first channel is applied to the first axis associated with the effect, the second to the second, and so on. If there are fewer channels than axes, nothing is associated with the extra axes.If there is only a single channel, the effect is rotated in the direction specified by the rglDirection member of the Dieffect structure. If there is more than one channel, rotation is not allowed.Not all devices support rotation of custom effects.

Definition

Visual Basic .NET | Public Property Channels As Integer
C# | public int Channels { get; set; }
Managed C++ public: __property int get_Channels();
public: __property void set_Channels(int);
JScript .NET public function get Channels() : int
public function set Channels(int);

Property Value

System.Int32 .

This property is read/write.


CustomForce.SamplePeriod

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce.SamplePeriod Property

Language:
Note: This documentation is preliminary and is subject to change.

Sample period, in microseconds.

Definition

Visual Basic .NET | Public Property SamplePeriod As Integer
C# | public int SamplePeriod { get; set; }
Managed C++ public: __property int get_SamplePeriod();
public: __property void set_SamplePeriod(int);
JScript .NET public function get SamplePeriod() : int
public function set SamplePeriod(int);

Property Value

System.Int32 .

This property is read/write.


CustomForce.Samples

Microsoft DirectX 9.0 SDK Update (October 2004)

CustomForce.Samples Property

Language:
Note: This documentation is preliminary and is subject to change.

Total number of samples in the RglForceData. It must be an integral multiple of the CChannels.

Definition

Visual Basic .NET | Public Property Samples As Integer
C# | public int Samples { get; set; }
Managed C++ public: __property int get_Samples();
public: __property void set_Samples(int);
JScript .NET public function get Samples() : int
public function set Samples(int);

Property Value

System.Int32 .

This property is read/write.


DataFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

DataFormat Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.

Definition

Visual Basic .NET | Public Structure DataFormat
C# | public struct DataFormat
Managed C++ | public __value struct DataFormat
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ObjectDataFormat

Methods

Method | Description
DataFormat | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DataSize | Size of a data packet returned by the device, in bytes. This value must be a multiple of 4 and must exceed the largest offset value for an object's data within the data packet.
Flags | Flags describing other attributes of the data format. This value can be one of the following:

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DataFormat.DataFormat()

Microsoft DirectX 9.0 SDK Update (October 2004)

DataFormat.DataFormat Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DataFormat();
Managed C++ | public: DataFormat();
JScript .NET | public function DataFormat();


DataFormat.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DataFormat.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DataFormat.DataSize

Microsoft DirectX 9.0 SDK Update (October 2004)

DataFormat.DataSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Size of a data packet returned by the device, in bytes. This value must be a multiple of 4 and must exceed the largest offset value for an object's data within the data packet.

Definition

Visual Basic .NET | Public Property DataSize As Integer
C# | public int DataSize { get; set; }
Managed C++ public: __property int get_DataSize();
public: __property void set_DataSize(int);
JScript .NET public function get DataSize() : int
public function set DataSize(int);

Property Value

System.Int32 .

This property is read/write.


DataFormat.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

DataFormat.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Flags describing other attributes of the data format. This value can be one of the following:

Definition

Visual Basic .NET | Public Property Flags As DataFormatFlags
C# | public DataFormatFlags Flags { get; set; }
Managed C++ public: __property DataFormatFlags get_Flags();
public: __property void set_Flags(DataFormatFlags);
JScript .NET public function get Flags() : DataFormatFlags
public function set Flags(DataFormatFlags);

Property Value

Microsoft.DirectX.DirectInput.DataFormatFlags .

This property is read/write.


DataFormat.ObjectDataFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

DataFormat.ObjectDataFormat Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ObjectDataFormat As ObjectDataFormat
C# | public ObjectDataFormat ObjectDataFormat;
Managed C++ | public: ObjectDataFormat ObjectDataFormat;
JScript .NET | public var ObjectDataFormat : ObjectDataFormat

Field Value

Microsoft.DirectX.DirectInput.ObjectDataFormat[] .

This field is read/write.


DeviceArrival

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceArrival Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Structure DeviceArrival
C# | public struct DeviceArrival
Managed C++ | public __value struct DeviceArrival
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceArrival | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property Description
Class
Name

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceArrival.DeviceArrival()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceArrival.DeviceArrival Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceArrival();
Managed C++ | public: DeviceArrival();
JScript .NET | public function DeviceArrival();


DeviceArrival.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceArrival.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceArrival.Class

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceArrival.Class Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Class As Guid
C# | public Guid Class { get; set; }
Managed C++ public: __property Guid get_Class();
public: __property void set_Class(Guid);
JScript .NET public function get Class() : Guid
public function set Class(Guid);

Property Value

System.Guid .

This property is read/write.


DeviceArrival.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceArrival.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


DeviceCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a Microsoft® DirectInput® device's capabilities. This structure is used with the Inputdevice9Getcapabilities method.

Definition

Visual Basic .NET | Public Structure DeviceCaps
C# | public struct DeviceCaps
Managed C++ | public __value struct DeviceCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceCaps | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Alias
Attack
Attatched
DeadBand
DeviceSubType | Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.
DeviceType | Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.
Emulated
Fade
FFDriverVersion | Version number of the device driver.
FFMinTimeResolution | Minimum time, in microseconds, that the device can resolve. The device rounds any times to the nearest supported increment. For example, if the value of DwFFMinTimeResolution is 1000, the device would round any times to the nearest millisecond.
FFSamplePeriod | Minimum time between playback of consecutive raw force commands, in microseconds.
FirmwareRevision | Firmware revision of the device.
ForceFeedback
HardwareRevision | Hardware revision of the device.
Hidden
NumberAxes | Number of axes available on the device.
NumberButtons | Number of buttons available on the device.
NumberPointOfViews | Number of point-of-view controllers available on the device.
Phantom
PolledDataFormat
PolledDevice
PosNegCoefficients
PosNegSaturation
Saturation
StartDelay

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceCaps.DeviceCaps()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.DeviceCaps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceCaps();
Managed C++ | public: DeviceCaps();
JScript .NET | public function DeviceCaps();


DeviceCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceCaps.Alias

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Alias Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Alias As Boolean
C# | public bool Alias { get; }
Managed C++ | public: __property bool get_Alias();
JScript .NET | public function get Alias() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.Attack

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Attack Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Attack As Boolean
C# | public bool Attack { get; }
Managed C++ | public: __property bool get_Attack();
JScript .NET | public function get Attack() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.Attatched

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Attatched Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Attatched As Boolean
C# | public bool Attatched { get; }
Managed C++ | public: __property bool get_Attatched();
JScript .NET | public function get Attatched() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.DeadBand

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.DeadBand Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property DeadBand As Boolean
C# | public bool DeadBand { get; }
Managed C++ | public: __property bool get_DeadBand();
JScript .NET | public function get DeadBand() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.DeviceSubType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.DeviceSubType Property

Language:
Note: This documentation is preliminary and is subject to change.

Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceSubType As Integer
C# | public int DeviceSubType { get; }
Managed C++ | public: __property int get_DeviceSubType();
JScript .NET | public function get DeviceSubType() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.DeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.DeviceType Property

Language:
Note: This documentation is preliminary and is subject to change.

Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.

Definition

Visual Basic .NET | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
Managed C++ | public: __property DeviceType get_DeviceType();
JScript .NET | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.DirectInput.DeviceType .

This property is read-only.


DeviceCaps.Emulated

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Emulated Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Emulated As Boolean
C# | public bool Emulated { get; }
Managed C++ | public: __property bool get_Emulated();
JScript .NET | public function get Emulated() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.Fade

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Fade Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Fade As Boolean
C# | public bool Fade { get; }
Managed C++ | public: __property bool get_Fade();
JScript .NET | public function get Fade() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.FFDriverVersion

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.FFDriverVersion Property

Language:
Note: This documentation is preliminary and is subject to change.

Version number of the device driver.

Definition

Visual Basic .NET | Public ReadOnly Property FFDriverVersion As Integer
C# | public int FFDriverVersion { get; }
Managed C++ | public: __property int get_FFDriverVersion();
JScript .NET | public function get FFDriverVersion() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.FFMinTimeResolution

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.FFMinTimeResolution Property

Language:
Note: This documentation is preliminary and is subject to change.

Minimum time, in microseconds, that the device can resolve. The device rounds any times to the nearest supported increment. For example, if the value of DwFFMinTimeResolution is 1000, the device would round any times to the nearest millisecond.

Definition

Visual Basic .NET | Public ReadOnly Property FFMinTimeResolution As Integer
C# | public int FFMinTimeResolution { get; }
Managed C++ | public: __property int get_FFMinTimeResolution();
JScript .NET | public function get FFMinTimeResolution() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.FFSamplePeriod

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.FFSamplePeriod Property

Language:
Note: This documentation is preliminary and is subject to change.

Minimum time between playback of consecutive raw force commands, in microseconds.

Definition

Visual Basic .NET | Public ReadOnly Property FFSamplePeriod As Integer
C# | public int FFSamplePeriod { get; }
Managed C++ | public: __property int get_FFSamplePeriod();
JScript .NET | public function get FFSamplePeriod() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.FirmwareRevision

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.FirmwareRevision Property

Language:
Note: This documentation is preliminary and is subject to change.

Firmware revision of the device.

Definition

Visual Basic .NET | Public ReadOnly Property FirmwareRevision As Integer
C# | public int FirmwareRevision { get; }
Managed C++ | public: __property int get_FirmwareRevision();
JScript .NET | public function get FirmwareRevision() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.ForceFeedback

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.ForceFeedback Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property ForceFeedback As Boolean
C# | public bool ForceFeedback { get; }
Managed C++ | public: __property bool get_ForceFeedback();
JScript .NET | public function get ForceFeedback() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.HardwareRevision

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.HardwareRevision Property

Language:
Note: This documentation is preliminary and is subject to change.

Hardware revision of the device.

Definition

Visual Basic .NET | Public ReadOnly Property HardwareRevision As Integer
C# | public int HardwareRevision { get; }
Managed C++ | public: __property int get_HardwareRevision();
JScript .NET | public function get HardwareRevision() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.Hidden

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Hidden Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Hidden As Boolean
C# | public bool Hidden { get; }
Managed C++ | public: __property bool get_Hidden();
JScript .NET | public function get Hidden() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.NumberAxes

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.NumberAxes Property

Language:
Note: This documentation is preliminary and is subject to change.

Number of axes available on the device.

Definition

Visual Basic .NET | Public ReadOnly Property NumberAxes As Integer
C# | public int NumberAxes { get; }
Managed C++ | public: __property int get_NumberAxes();
JScript .NET | public function get NumberAxes() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.NumberButtons

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.NumberButtons Property

Language:
Note: This documentation is preliminary and is subject to change.

Number of buttons available on the device.

Definition

Visual Basic .NET | Public ReadOnly Property NumberButtons As Integer
C# | public int NumberButtons { get; }
Managed C++ | public: __property int get_NumberButtons();
JScript .NET | public function get NumberButtons() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.NumberPointOfViews

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.NumberPointOfViews Property

Language:
Note: This documentation is preliminary and is subject to change.

Number of point-of-view controllers available on the device.

Definition

Visual Basic .NET | Public ReadOnly Property NumberPointOfViews As Integer
C# | public int NumberPointOfViews { get; }
Managed C++ | public: __property int get_NumberPointOfViews();
JScript .NET | public function get NumberPointOfViews() : int

Property Value

System.Int32 .

This property is read-only.


DeviceCaps.Phantom

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Phantom Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Phantom As Boolean
C# | public bool Phantom { get; }
Managed C++ | public: __property bool get_Phantom();
JScript .NET | public function get Phantom() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.PolledDataFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.PolledDataFormat Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property PolledDataFormat As Boolean
C# | public bool PolledDataFormat { get; }
Managed C++ | public: __property bool get_PolledDataFormat();
JScript .NET | public function get PolledDataFormat() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.PolledDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.PolledDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property PolledDevice As Boolean
C# | public bool PolledDevice { get; }
Managed C++ | public: __property bool get_PolledDevice();
JScript .NET | public function get PolledDevice() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.PosNegCoefficients

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.PosNegCoefficients Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property PosNegCoefficients As Boolean
C# | public bool PosNegCoefficients { get; }
Managed C++ | public: __property bool get_PosNegCoefficients();
JScript .NET | public function get PosNegCoefficients() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.PosNegSaturation

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.PosNegSaturation Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property PosNegSaturation As Boolean
C# | public bool PosNegSaturation { get; }
Managed C++ | public: __property bool get_PosNegSaturation();
JScript .NET | public function get PosNegSaturation() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.Saturation

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.Saturation Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Saturation As Boolean
C# | public bool Saturation { get; }
Managed C++ | public: __property bool get_Saturation();
JScript .NET | public function get Saturation() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceCaps.StartDelay

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceCaps.StartDelay Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property StartDelay As Boolean
C# | public bool StartDelay { get; }
Managed C++ | public: __property bool get_StartDelay();
JScript .NET | public function get StartDelay() : boolean

Property Value

System.Boolean .

This property is read-only.


DeviceImageInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Carries information required to display a device image or an overlay image with a callout. This structure is passed to the Inputdevice9Getimageinfo method as an array within a Dideviceimageinfoheader structure.

Definition

Visual Basic .NET | Public Structure DeviceImageInformation
C# | public struct DeviceImageInformation
Managed C++ | public __value struct DeviceImageInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
CalloutLine | Array of POINT structures that specify coordinates of the points describing a callout line. A callout line connects a device control to a caption for the game action. Each line can have from one to four segments. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
CalloutRectangle | RECT structure that describes the rectangle in which the game action string is displayed. If the string cannot fit within the rectangle, the application is responsible for handling clipping. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
Overlay | Rectangle, using coordinates relative to the top-left pixel of the device configuration image, in which the overlay image should be painted. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Methods

Method | Description
DeviceImageInformation | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Flags | Flag that describes the intended use of the image.
ImagePath | Fully qualified path to the file that contains an image of the device. The file format is given in DwFlags. If no image is available for the device, this member will be set to NULL. If so, the application is responsible for enumerating controls on the device and displaying a default listing of actions to device controls (similar to the method used by most applications before Microsoft® DirectX® 8.0).
ObjectId | Control identifier, as a combination of DIDFT_* flags and an instance value, to which an overlay image corresponds for this device. Applications use the DIDFT_GETINSTANCE and DIDFT_GETTYPE macros to decode this value to its constituent parts. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
TextAlign | DWORD value that specifies the alignment of the text in the rectangle described by the RcCalloutRect member. Must be one horizontal alignment flag combined with one vertical alignment flag. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
ViewId | For device view images (DIDIFT_CONFIGURATION), this is the identifier of the device view.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceImageInformation.DeviceImageInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.DeviceImageInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceImageInformation();
Managed C++ | public: DeviceImageInformation();
JScript .NET | public function DeviceImageInformation();


DeviceImageInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceImageInformation.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Flag that describes the intended use of the image.

Definition

Visual Basic .NET | Public Property Flags As ImageFileType
C# | public ImageFileType Flags { get; set; }
Managed C++ public: __property ImageFileType get_Flags();
public: __property void set_Flags(ImageFileType);
JScript .NET public function get Flags() : ImageFileType
public function set Flags(ImageFileType);

Property Value

Microsoft.DirectX.DirectInput.ImageFileType .

This property is read/write.


DeviceImageInformation.ImagePath

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.ImagePath Property

Language:
Note: This documentation is preliminary and is subject to change.

Fully qualified path to the file that contains an image of the device. The file format is given in DwFlags. If no image is available for the device, this member will be set to NULL. If so, the application is responsible for enumerating controls on the device and displaying a default listing of actions to device controls (similar to the method used by most applications before Microsoft® DirectX® 8.0).

Definition

Visual Basic .NET | Public Property ImagePath As String
C# | public string ImagePath { get; set; }
Managed C++ public: __property String* get_ImagePath();
public: __property void set_ImagePath(String*);
JScript .NET public function get ImagePath() : String
public function set ImagePath(String);

Property Value

System.String .

This property is read/write.


DeviceImageInformation.ObjectId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.ObjectId Property

Language:
Note: This documentation is preliminary and is subject to change.

Control identifier, as a combination of DIDFT_* flags and an instance value, to which an overlay image corresponds for this device. Applications use the DIDFT_GETINSTANCE and DIDFT_GETTYPE macros to decode this value to its constituent parts. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic .NET | Public Property ObjectId As Integer
C# | public int ObjectId { get; set; }
Managed C++ public: __property int get_ObjectId();
public: __property void set_ObjectId(int);
JScript .NET public function get ObjectId() : int
public function set ObjectId(int);

Property Value

System.Int32 .

This property is read/write.


DeviceImageInformation.TextAlign

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.TextAlign Property

Language:
Note: This documentation is preliminary and is subject to change.

DWORD value that specifies the alignment of the text in the rectangle described by the RcCalloutRect member. Must be one horizontal alignment flag combined with one vertical alignment flag. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic .NET | Public Property TextAlign As Integer
C# | public int TextAlign { get; set; }
Managed C++ public: __property int get_TextAlign();
public: __property void set_TextAlign(int);
JScript .NET public function get TextAlign() : int
public function set TextAlign(int);

Property Value

System.Int32 .

This property is read/write.


DeviceImageInformation.ViewId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.ViewId Property

Language:
Note: This documentation is preliminary and is subject to change.

For device view images (DIDIFT_CONFIGURATION), this is the identifier of the device view.

Definition

Visual Basic .NET | Public Property ViewId As Integer
C# | public int ViewId { get; set; }
Managed C++ public: __property int get_ViewId();
public: __property void set_ViewId(int);
JScript .NET public function get ViewId() : int
public function set ViewId(int);

Property Value

System.Int32 .

This property is read/write.


DeviceImageInformation.CalloutLine

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.CalloutLine Field

 Language:
Note: This documentation is preliminary and is subject to change.

Array of POINT structures that specify coordinates of the points describing a callout line. A callout line connects a device control to a caption for the game action. Each line can have from one to four segments. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic .NET | Public CalloutLine As Point
C# | public Point CalloutLine;
Managed C++ | public: Point CalloutLine;
JScript .NET | public var CalloutLine : Point

Field Value

System.Drawing.Point[] .

This field is read/write.


DeviceImageInformation.CalloutRectangle

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.CalloutRectangle Field

 Language:
Note: This documentation is preliminary and is subject to change.

RECT structure that describes the rectangle in which the game action string is displayed. If the string cannot fit within the rectangle, the application is responsible for handling clipping. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic .NET | Public CalloutRectangle As Rectangle
C# | public Rectangle CalloutRectangle;
Managed C++ | public: Rectangle CalloutRectangle;
JScript .NET | public var CalloutRectangle : Rectangle

Field Value

System.Drawing.Rectangle .

This field is read/write.


DeviceImageInformation.Overlay

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformation.Overlay Field

 Language:
Note: This documentation is preliminary and is subject to change.

Rectangle, using coordinates relative to the top-left pixel of the device configuration image, in which the overlay image should be painted. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic .NET | Public Overlay As Rectangle
C# | public Rectangle Overlay;
Managed C++ | public: Rectangle Overlay;
JScript .NET | public var Overlay : Rectangle

Field Value

System.Drawing.Rectangle .

This field is read/write.


DeviceImageInformationHeader

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains information about device images. Used in the Inputdevice9Getimageinfo method.

Definition

Visual Basic .NET | Public Structure DeviceImageInformationHeader
C# | public struct DeviceImageInformationHeader
Managed C++ | public __value struct DeviceImageInformationHeader
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
ImageInformationArray | Pointer to a buffer that receives an array of Dideviceimageinfo structures describing all the device images and views, overlay images, and callout-string coordinates.

Methods

Method | Description
DeviceImageInformationHeader | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Buttons | DWORD variable that receives the number of buttons on the device.
NumberAxes | DWORD variable that receives the number of axes on the device.
POVs | DWORD variable that receives the number of point-of-view controllers on the device.
Views | DWORD variable that receives the number of views of this device.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceImageInformationHeader.DeviceImageInformationHeader()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader.DeviceImageInformationHeader Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceImageInformationHeader();
Managed C++ | public: DeviceImageInformationHeader();
JScript .NET | public function DeviceImageInformationHeader();


DeviceImageInformationHeader.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceImageInformationHeader.Buttons

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader.Buttons Property

Language:
Note: This documentation is preliminary and is subject to change.

DWORD variable that receives the number of buttons on the device.

Definition

Visual Basic .NET | Public ReadOnly Property Buttons As Integer
C# | public int Buttons { get; }
Managed C++ | public: __property int get_Buttons();
JScript .NET | public function get Buttons() : int

Property Value

System.Int32 .

This property is read-only.


DeviceImageInformationHeader.NumberAxes

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader.NumberAxes Property

Language:
Note: This documentation is preliminary and is subject to change.

DWORD variable that receives the number of axes on the device.

Definition

Visual Basic .NET | Public ReadOnly Property NumberAxes As Integer
C# | public int NumberAxes { get; }
Managed C++ | public: __property int get_NumberAxes();
JScript .NET | public function get NumberAxes() : int

Property Value

System.Int32 .

This property is read-only.


DeviceImageInformationHeader.POVs

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader.POVs Property

Language:
Note: This documentation is preliminary and is subject to change.

DWORD variable that receives the number of point-of-view controllers on the device.

Definition

Visual Basic .NET | Public ReadOnly Property POVs As Integer
C# | public int POVs { get; }
Managed C++ | public: __property int get_POVs();
JScript .NET | public function get POVs() : int

Property Value

System.Int32 .

This property is read-only.


DeviceImageInformationHeader.Views

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader.Views Property

Language:
Note: This documentation is preliminary and is subject to change.

DWORD variable that receives the number of views of this device.

Definition

Visual Basic .NET | Public ReadOnly Property Views As Integer
C# | public int Views { get; }
Managed C++ | public: __property int get_Views();
JScript .NET | public function get Views() : int

Property Value

System.Int32 .

This property is read-only.


DeviceImageInformationHeader.ImageInformationArray

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceImageInformationHeader.ImageInformationArray Field

 Language:
Note: This documentation is preliminary and is subject to change.

Pointer to a buffer that receives an array of Dideviceimageinfo structures describing all the device images and views, overlay images, and callout-string coordinates.

Definition

Visual Basic .NET | Public ImageInformationArray As DeviceImageInformation
C# | public DeviceImageInformation ImageInformationArray;
Managed C++ | public: DeviceImageInformation ImageInformationArray;
JScript .NET | public var ImageInformationArray : DeviceImageInformation

Field Value

Microsoft.DirectX.DirectInput.DeviceImageInformation[] .

This field is read/write.


DeviceInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes an instance of a Microsoft® DirectInput® device. This structure is used with the Input9Enumdevices, Input9Enumdevicesbysemantics, and Inputdevice9Getdeviceinfo methods.

Definition

Visual Basic .NET | Public Structure DeviceInstance
C# | public struct DeviceInstance
Managed C++ | public __value struct DeviceInstance
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceInstance | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DeviceSubType | Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).
DeviceType | Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).
FFDriverGuid | Unique identifier for the driver being used for force feedback. The driver's manufacturer establishes this identifier.
InstanceGuid | Unique identifier for the instance of the device. An application can save the instance GUID into a configuration file and use it at a later time. Instance GUIDs are specific to a particular computer. An instance GUID obtained from one computer is unrelated to instance GUIDs on another.
InstanceName | Friendly name for the instance, for example, 'Joystick 1.'
ProductGuid | Unique identifier for the product. This identifier is established by the manufacturer of the device.
ProductName | Friendly name for the product.
Usage | If the device is a Human Interface Device (HID), this member contains the HID usage code.
UsagePage | If the device is a Human Interface Device (HID), this member contains the HID usage page code.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceInstance.DeviceInstance()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.DeviceInstance Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceInstance();
Managed C++ | public: DeviceInstance();
JScript .NET | public function DeviceInstance();


DeviceInstance.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceInstance.DeviceSubType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.DeviceSubType Property

Language:
Note: This documentation is preliminary and is subject to change.

Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).

Definition

Visual Basic .NET | Public ReadOnly Property DeviceSubType As Integer
C# | public int DeviceSubType { get; }
Managed C++ | public: __property int get_DeviceSubType();
JScript .NET | public function get DeviceSubType() : int

Property Value

System.Int32 .

This property is read-only.


DeviceInstance.DeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.DeviceType Property

Language:
Note: This documentation is preliminary and is subject to change.

Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).

Definition

Visual Basic .NET | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
Managed C++ | public: __property DeviceType get_DeviceType();
JScript .NET | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.DirectInput.DeviceType .

This property is read-only.


DeviceInstance.FFDriverGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.FFDriverGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Unique identifier for the driver being used for force feedback. The driver's manufacturer establishes this identifier.

Definition

Visual Basic .NET | Public ReadOnly Property FFDriverGuid As Guid
C# | public Guid FFDriverGuid { get; }
Managed C++ | public: __property Guid get_FFDriverGuid();
JScript .NET | public function get FFDriverGuid() : Guid

Property Value

System.Guid .

This property is read-only.


DeviceInstance.InstanceGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.InstanceGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Unique identifier for the instance of the device. An application can save the instance GUID into a configuration file and use it at a later time. Instance GUIDs are specific to a particular computer. An instance GUID obtained from one computer is unrelated to instance GUIDs on another.

Definition

Visual Basic .NET | Public ReadOnly Property InstanceGuid As Guid
C# | public Guid InstanceGuid { get; }
Managed C++ | public: __property Guid get_InstanceGuid();
JScript .NET | public function get InstanceGuid() : Guid

Property Value

System.Guid .

This property is read-only.


DeviceInstance.InstanceName

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.InstanceName Property

Language:
Note: This documentation is preliminary and is subject to change.

Friendly name for the instance, for example, 'Joystick 1.'

Definition

Visual Basic .NET | Public ReadOnly Property InstanceName As String
C# | public string InstanceName { get; }
Managed C++ | public: __property String* get_InstanceName();
JScript .NET | public function get InstanceName() : String

Property Value

System.String .

This property is read-only.


DeviceInstance.ProductGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.ProductGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Unique identifier for the product. This identifier is established by the manufacturer of the device.

Definition

Visual Basic .NET | Public ReadOnly Property ProductGuid As Guid
C# | public Guid ProductGuid { get; }
Managed C++ | public: __property Guid get_ProductGuid();
JScript .NET | public function get ProductGuid() : Guid

Property Value

System.Guid .

This property is read-only.


DeviceInstance.ProductName

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.ProductName Property

Language:
Note: This documentation is preliminary and is subject to change.

Friendly name for the product.

Definition

Visual Basic .NET | Public ReadOnly Property ProductName As String
C# | public string ProductName { get; }
Managed C++ | public: __property String* get_ProductName();
JScript .NET | public function get ProductName() : String

Property Value

System.String .

This property is read-only.


DeviceInstance.Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.Usage Property

Language:
Note: This documentation is preliminary and is subject to change.

If the device is a Human Interface Device (HID), this member contains the HID usage code.

Definition

Visual Basic .NET | Public ReadOnly Property Usage As Short
C# | public short Usage { get; }
Managed C++ | public: __property short get_Usage();
JScript .NET | public function get Usage() : short

Property Value

System.Int16 .

This property is read-only.


DeviceInstance.UsagePage

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInstance.UsagePage Property

Language:
Note: This documentation is preliminary and is subject to change.

If the device is a Human Interface Device (HID), this member contains the HID usage page code.

Definition

Visual Basic .NET | Public ReadOnly Property UsagePage As Short
C# | public short UsagePage { get; }
Managed C++ | public: __property short get_UsagePage();
JScript .NET | public function get UsagePage() : short

Property Value

System.Int16 .

This property is read-only.


DeviceObjectInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a device object instance. This structure is used with the Inputdevice9Enumobjects method to provide the Dienumdeviceobjectscallback callback function with information about a particular object associated with a device, such as an axis or button. It is also used with the Inputdevice9Getobjectinfo method to retrieve information about a device object.

Definition

Visual Basic .NET | Public Structure DeviceObjectInstance
C# | public struct DeviceObjectInstance
Managed C++ | public __value struct DeviceObjectInstance
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceObjectInstance | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CollectionNumber | The Human Interface Device (TermHid) link collection to which the object belongs.
DesignatorIndex | An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.
Dimension | A Human Interface Device (HID) code for the dimensional units in which the object's value is reported, if known, or 0 if not known.
Exponent | The exponent to associate with the dimension, if known. Dimensional units are always integral, so an exponent might be needed to convert them to nonintegral types.
Flags | Flags describing other attributes of the data format. This value can be one of the following:
ForceResolution | The force resolution of the actuator associated with this object. The returned value represents the number of gradations, or subdivisions, of the maximum force that can be expressed by the force-feedback system from 0 (no force) to maximum force.
MaxForce | The magnitude of the maximum force that can be created by the actuator associated with this object. Force is expressed in newtons and measured in relation to where the hand would be during normal operation of the device.
Name | Name of the object, for example, 'X-Axis' or 'Right Shift.'
ObjectId | An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.
ObjectType | Unique identifier that indicates the object type. This member is optional. If present, it can be one of the following values:
Offset | Offset in the native data format of the device. The native data format corresponds to the raw device data. The DwOfs member does not correspond to the device constant, such as DIJOFS_BUTTON0, for this object.
ReportId | Reserved.
Usage | The HID usage associated with the object, if known. HIDs always report a usage. Non-HIDs can optionally report a usage; if they do not, the value of this member is 0.
UsagePage | The Human Interface Device (HID) usage page associated with the object, if known. HIDs always report a usage page. Non-HID devices can optionally report a usage page; if they do not, the value of this member is 0.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeviceObjectInstance.DeviceObjectInstance()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.DeviceObjectInstance Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceObjectInstance();
Managed C++ | public: DeviceObjectInstance();
JScript .NET | public function DeviceObjectInstance();


DeviceObjectInstance.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceObjectInstance.CollectionNumber

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.CollectionNumber Property

Language:
Note: This documentation is preliminary and is subject to change.

The Human Interface Device (TermHid) link collection to which the object belongs.

Definition

Visual Basic .NET | Public Property CollectionNumber As Short
C# | public short CollectionNumber { get; set; }
Managed C++ public: __property short get_CollectionNumber();
public: __property void set_CollectionNumber(short);
JScript .NET public function get CollectionNumber() : short
public function set CollectionNumber(short);

Property Value

System.Int16 .

This property is read/write.


DeviceObjectInstance.DesignatorIndex

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.DesignatorIndex Property

Language:
Note: This documentation is preliminary and is subject to change.

An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.

Definition

Visual Basic .NET | Public Property DesignatorIndex As Short
C# | public short DesignatorIndex { get; set; }
Managed C++ public: __property short get_DesignatorIndex();
public: __property void set_DesignatorIndex(short);
JScript .NET public function get DesignatorIndex() : short
public function set DesignatorIndex(short);

Property Value

System.Int16 .

This property is read/write.


DeviceObjectInstance.Dimension

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.Dimension Property

Language:
Note: This documentation is preliminary and is subject to change.

A Human Interface Device (HID) code for the dimensional units in which the object's value is reported, if known, or 0 if not known.

Definition

Visual Basic .NET | Public Property Dimension As Integer
C# | public int Dimension { get; set; }
Managed C++ public: __property int get_Dimension();
public: __property void set_Dimension(int);
JScript .NET public function get Dimension() : int
public function set Dimension(int);

Property Value

System.Int32 .

This property is read/write.


DeviceObjectInstance.Exponent

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.Exponent Property

Language:
Note: This documentation is preliminary and is subject to change.

The exponent to associate with the dimension, if known. Dimensional units are always integral, so an exponent might be needed to convert them to nonintegral types.

Definition

Visual Basic .NET | Public Property Exponent As Short
C# | public short Exponent { get; set; }
Managed C++ public: __property short get_Exponent();
public: __property void set_Exponent(short);
JScript .NET public function get Exponent() : short
public function set Exponent(short);

Property Value

System.Int16 .

This property is read/write.


DeviceObjectInstance.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Flags describing other attributes of the data format. This value can be one of the following:

Definition

Visual Basic .NET | Public Property Flags As Integer
C# | public int Flags { get; set; }
Managed C++ public: __property int get_Flags();
public: __property void set_Flags(int);
JScript .NET public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32 .

This property is read/write.


DeviceObjectInstance.ForceResolution

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.ForceResolution Property

Language:
Note: This documentation is preliminary and is subject to change.

The force resolution of the actuator associated with this object. The returned value represents the number of gradations, or subdivisions, of the maximum force that can be expressed by the force-feedback system from 0 (no force) to maximum force.

Definition

Visual Basic .NET | Public Property ForceResolution As Integer
C# | public int ForceResolution { get; set; }
Managed C++ public: __property int get_ForceResolution();
public: __property void set_ForceResolution(int);
JScript .NET public function get ForceResolution() : int
public function set ForceResolution(int);

Property Value

System.Int32 .

This property is read/write.


DeviceObjectInstance.MaxForce

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.MaxForce Property

Language:
Note: This documentation is preliminary and is subject to change.

The magnitude of the maximum force that can be created by the actuator associated with this object. Force is expressed in newtons and measured in relation to where the hand would be during normal operation of the device.

Definition

Visual Basic .NET | Public Property MaxForce As Integer
C# | public int MaxForce { get; set; }
Managed C++ public: __property int get_MaxForce();
public: __property void set_MaxForce(int);
JScript .NET public function get MaxForce() : int
public function set MaxForce(int);

Property Value

System.Int32 .

This property is read/write.


DeviceObjectInstance.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Name of the object, for example, 'X-Axis' or 'Right Shift.'

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


DeviceObjectInstance.ObjectId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.ObjectId Property

Language:
Note: This documentation is preliminary and is subject to change.

An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.

Definition

Visual Basic .NET | Public Property ObjectId As Integer
C# | public int ObjectId { get; set; }
Managed C++ public: __property int get_ObjectId();
public: __property void set_ObjectId(int);
JScript .NET public function get ObjectId() : int
public function set ObjectId(int);

Property Value

System.Int32 .

This property is read/write.


DeviceObjectInstance.ObjectType

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.ObjectType Property

Language:
Note: This documentation is preliminary and is subject to change.

Unique identifier that indicates the object type. This member is optional. If present, it can be one of the following values:

Definition

Visual Basic .NET | Public Property ObjectType As Guid
C# | public Guid ObjectType { get; set; }
Managed C++ public: __property Guid get_ObjectType();
public: __property void set_ObjectType(Guid);
JScript .NET public function get ObjectType() : Guid
public function set ObjectType(Guid);

Property Value

System.Guid .

This property is read/write.


DeviceObjectInstance.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

Offset in the native data format of the device. The native data format corresponds to the raw device data. The DwOfs member does not correspond to the device constant, such as DIJOFS_BUTTON0, for this object.

Definition

Visual Basic .NET | Public Property Offset As Integer
C# | public int Offset { get; set; }
Managed C++ public: __property int get_Offset();
public: __property void set_Offset(int);
JScript .NET public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32 .

This property is read/write.


DeviceObjectInstance.ReportId

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.ReportId Property

Language:
Note: This documentation is preliminary and is subject to change.

Reserved.

Definition

Visual Basic .NET | Public Property ReportId As Short
C# | public short ReportId { get; set; }
Managed C++ public: __property short get_ReportId();
public: __property void set_ReportId(short);
JScript .NET public function get ReportId() : short
public function set ReportId(short);

Property Value

System.Int16 .

This property is read/write.


DeviceObjectInstance.Usage

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.Usage Property

Language:
Note: This documentation is preliminary and is subject to change.

The HID usage associated with the object, if known. HIDs always report a usage. Non-HIDs can optionally report a usage; if they do not, the value of this member is 0.

Definition

Visual Basic .NET | Public Property Usage As Short
C# | public short Usage { get; set; }
Managed C++ public: __property short get_Usage();
public: __property void set_Usage(short);
JScript .NET public function get Usage() : short
public function set Usage(short);

Property Value

System.Int16 .

This property is read/write.


DeviceObjectInstance.UsagePage

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceObjectInstance.UsagePage Property

Language:
Note: This documentation is preliminary and is subject to change.

The Human Interface Device (HID) usage page associated with the object, if known. HIDs always report a usage page. Non-HID devices can optionally report a usage page; if they do not, the value of this member is 0.

Definition

Visual Basic .NET | Public Property UsagePage As Short
C# | public short UsagePage { get; set; }
Managed C++ public: __property short get_UsagePage();
public: __property void set_UsagePage(short);
JScript .NET public function get UsagePage() : short
public function set UsagePage(short);

Property Value

System.Int16 .

This property is read/write.


Effect

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Used by the Inputdevice9Createeffect method to initialize a new Inputeffect object. It is also used by the InputeffectSetparameters and InputeffectGetparameters methods.

Definition

Visual Basic .NET | Public Structure Effect
C# | public struct Effect
Managed C++ | public __value struct Effect
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
ConditionStruct
Constant
CustomStruct
EnvelopeStruct
Periodic | Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
RampStruct

Methods

Method | Description
Effect | Initializes a new instance of the object.
GetAxes
GetDirection
SetAxes
SetDirection
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Duration | The total duration of the effect, in microseconds. If this value is INFINITE, the effect has infinite duration. If an TermEnvelope has been applied to the effect, the TermAttack is applied, followed by an infinite TermSustain.
EffectType
Flags | Flags associated with the effect. This value can be a combination of one or more of the following values:
Gain | The gain to be applied to the effect, in the range from 0 through 10,000. The gain is a scaling factor applied to all magnitudes of the effect and its envelope.
SamplePeriod | The period at which the device should play back the effect, in microseconds. A value of 0 indicates that the default playback sample rate should be used. If the device is not capable of playing back the effect at the specified rate, it chooses the supported rate that is closest to the requested value.Setting a custom DwSamplePeriod can be used for special effects. For example, playing a sine wave at an artificially large sample period results in a rougher texture.
StartDelay | Time (in microseconds) that the device should wait after a InputeffectStart call before playing the effect. If this value is 0, effect playback begins immediately. This member is not present in versions prior to Microsoft® DirectX® 7.0.
TriggerButton | The identifier or offset of the button to be used to trigger playback of the effect. The flags DIEFF_OBJECTIDS and DIEFF_OBJECTOFFSETS determine the semantics of the value. If this member is set to DIEB_NOTRIGGER, no trigger button is associated with the effect.
TriggerRepeatInterval | The interval, in microseconds, between the end of one playback and the start of the next when the effect is triggered by a button press and the button is held down. Setting this value to INFINITE suppresses repetition. Support for trigger repeat for an effect is indicated by the presence of the DIEP_TRIGGERREPEATINTERVAL flag in the dwStaticParams member of the Dieffectinfo structure.
UsesEnvelope | Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Effect.Effect()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Effect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public Effect();
Managed C++ | public: Effect();
JScript .NET | public function Effect();


Effect.GetAxes()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.GetAxes Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Function GetAxes() As Integer()
C# | public int[] GetAxes();
Managed C++ | public: int GetAxes() __gc[];
JScript .NET | public function GetAxes() : int[];

Return Value

System.Int32[].


Effect.GetDirection()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.GetDirection Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Function GetDirection() As Integer()
C# | public int[] GetDirection();
Managed C++ | public: int GetDirection() __gc[];
JScript .NET | public function GetDirection() : int[];

Return Value

System.Int32[].


Effect.SetAxes(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.SetAxes Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Sub SetAxes( _
ByVal value() As Integer _
)
C# public void SetAxes(
int[] value
);
Managed C++ public: void SetAxes(
int value __gc[]
);
JScript .NET public function SetAxes(
value : int[]
);

Parameters

value System.Int32[].


Effect.SetDirection(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.SetDirection Method

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET Public Sub SetDirection( _
ByVal value() As Integer _
)
C# public void SetDirection(
int[] value
);
Managed C++ public: void SetDirection(
int value __gc[]
);
JScript .NET public function SetDirection(
value : int[]
);

Parameters

value System.Int32[].


Effect.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Effect.Duration

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Duration Property

Language:
Note: This documentation is preliminary and is subject to change.

The total duration of the effect, in microseconds. If this value is INFINITE, the effect has infinite duration. If an TermEnvelope has been applied to the effect, the TermAttack is applied, followed by an infinite TermSustain.

Definition

Visual Basic .NET | Public Property Duration As Integer
C# | public int Duration { get; set; }
Managed C++ public: __property int get_Duration();
public: __property void set_Duration(int);
JScript .NET public function get Duration() : int
public function set Duration(int);

Property Value

System.Int32 .

This property is read/write.


Effect.EffectType

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.EffectType Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property EffectType As EffectType
C# | public EffectType EffectType { get; set; }
Managed C++ public: __property EffectType get_EffectType();
public: __property void set_EffectType(EffectType);
JScript .NET public function get EffectType() : EffectType
public function set EffectType(EffectType);

Property Value

Microsoft.DirectX.DirectInput.EffectType .

This property is read/write.


Effect.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Flags associated with the effect. This value can be a combination of one or more of the following values:

Definition

Visual Basic .NET | Public Property Flags As EffectFlags
C# | public EffectFlags Flags { get; set; }
Managed C++ public: __property EffectFlags get_Flags();
public: __property void set_Flags(EffectFlags);
JScript .NET public function get Flags() : EffectFlags
public function set Flags(EffectFlags);

Property Value

Microsoft.DirectX.DirectInput.EffectFlags .

This property is read/write.


Effect.Gain

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Gain Property

Language:
Note: This documentation is preliminary and is subject to change.

The gain to be applied to the effect, in the range from 0 through 10,000. The gain is a scaling factor applied to all magnitudes of the effect and its envelope.

Definition

Visual Basic .NET | Public Property Gain As Integer
C# | public int Gain { get; set; }
Managed C++ public: __property int get_Gain();
public: __property void set_Gain(int);
JScript .NET public function get Gain() : int
public function set Gain(int);

Property Value

System.Int32 .

This property is read/write.


Effect.SamplePeriod

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.SamplePeriod Property

Language:
Note: This documentation is preliminary and is subject to change.

The period at which the device should play back the effect, in microseconds. A value of 0 indicates that the default playback sample rate should be used. If the device is not capable of playing back the effect at the specified rate, it chooses the supported rate that is closest to the requested value.Setting a custom DwSamplePeriod can be used for special effects. For example, playing a sine wave at an artificially large sample period results in a rougher texture.

Definition

Visual Basic .NET | Public Property SamplePeriod As Integer
C# | public int SamplePeriod { get; set; }
Managed C++ public: __property int get_SamplePeriod();
public: __property void set_SamplePeriod(int);
JScript .NET public function get SamplePeriod() : int
public function set SamplePeriod(int);

Property Value

System.Int32 .

This property is read/write.


Effect.StartDelay

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.StartDelay Property

Language:
Note: This documentation is preliminary and is subject to change.

Time (in microseconds) that the device should wait after a InputeffectStart call before playing the effect. If this value is 0, effect playback begins immediately. This member is not present in versions prior to Microsoft® DirectX® 7.0.

Definition

Visual Basic .NET | Public Property StartDelay As Integer
C# | public int StartDelay { get; set; }
Managed C++ public: __property int get_StartDelay();
public: __property void set_StartDelay(int);
JScript .NET public function get StartDelay() : int
public function set StartDelay(int);

Property Value

System.Int32 .

This property is read/write.


Effect.TriggerButton

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.TriggerButton Property

Language:
Note: This documentation is preliminary and is subject to change.

The identifier or offset of the button to be used to trigger playback of the effect. The flags DIEFF_OBJECTIDS and DIEFF_OBJECTOFFSETS determine the semantics of the value. If this member is set to DIEB_NOTRIGGER, no trigger button is associated with the effect.

Definition

Visual Basic .NET | Public Property TriggerButton As Integer
C# | public int TriggerButton { get; set; }
Managed C++ public: __property int get_TriggerButton();
public: __property void set_TriggerButton(int);
JScript .NET public function get TriggerButton() : int
public function set TriggerButton(int);

Property Value

System.Int32 .

This property is read/write.


Effect.TriggerRepeatInterval

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.TriggerRepeatInterval Property

Language:
Note: This documentation is preliminary and is subject to change.

The interval, in microseconds, between the end of one playback and the start of the next when the effect is triggered by a button press and the button is held down. Setting this value to INFINITE suppresses repetition. Support for trigger repeat for an effect is indicated by the presence of the DIEP_TRIGGERREPEATINTERVAL flag in the dwStaticParams member of the Dieffectinfo structure.

Definition

Visual Basic .NET | Public Property TriggerRepeatInterval As Integer
C# | public int TriggerRepeatInterval { get; set; }
Managed C++ public: __property int get_TriggerRepeatInterval();
public: __property void set_TriggerRepeatInterval(int);
JScript .NET public function get TriggerRepeatInterval() : int
public function set TriggerRepeatInterval(int);

Property Value

System.Int32 .

This property is read/write.


Effect.UsesEnvelope

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.UsesEnvelope Property

Language:
Note: This documentation is preliminary and is subject to change.

Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.

Definition

Visual Basic .NET | Public Property UsesEnvelope As Boolean
C# | public bool UsesEnvelope { get; set; }
Managed C++ public: __property bool get_UsesEnvelope();
public: __property void set_UsesEnvelope(bool);
JScript .NET public function get UsesEnvelope() : boolean
public function set UsesEnvelope(boolean);

Property Value

System.Boolean .

This property is read/write.


Effect.ConditionStruct

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.ConditionStruct Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ConditionStruct As Condition
C# | public Condition ConditionStruct;
Managed C++ | public: Condition ConditionStruct;
JScript .NET | public var ConditionStruct : Condition

Field Value

Microsoft.DirectX.DirectInput.Condition[] .

This field is read/write.


Effect.Constant

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Constant Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Constant As ConstantForce
C# | public ConstantForce Constant;
Managed C++ | public: ConstantForce Constant;
JScript .NET | public var Constant : ConstantForce

Field Value

Microsoft.DirectX.DirectInput.ConstantForce .

This field is read/write.


Effect.CustomStruct

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.CustomStruct Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public CustomStruct As CustomForce
C# | public CustomForce CustomStruct;
Managed C++ | public: CustomForce CustomStruct;
JScript .NET | public var CustomStruct : CustomForce

Field Value

Microsoft.DirectX.DirectInput.CustomForce .

This field is read/write.


Effect.EnvelopeStruct

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.EnvelopeStruct Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public EnvelopeStruct As Envelope
C# | public Envelope EnvelopeStruct;
Managed C++ | public: Envelope EnvelopeStruct;
JScript .NET | public var EnvelopeStruct : Envelope

Field Value

Microsoft.DirectX.DirectInput.Envelope .

This field is read/write.


Effect.Periodic

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.Periodic Field

 Language:
Note: This documentation is preliminary and is subject to change.

Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic .NET | Public Periodic As Periodic
C# | public Periodic Periodic;
Managed C++ | public: Periodic Periodic;
JScript .NET | public var Periodic : Periodic

Field Value

Microsoft.DirectX.DirectInput.Periodic .

This field is read/write.


Effect.RampStruct

Microsoft DirectX 9.0 SDK Update (October 2004)

Effect.RampStruct Field

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public RampStruct As RampForce
C# | public RampForce RampStruct;
Managed C++ | public: RampForce RampStruct;
JScript .NET | public var RampStruct : RampForce

Field Value

Microsoft.DirectX.DirectInput.RampForce .

This field is read/write.


EffectInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Used by the Inputdevice9Enumeffects and Inputdevice9Geteffectinfo methods to return information about a particular effect supported by a device.

Definition

Visual Basic .NET | Public Structure EffectInformation
C# | public struct EffectInformation
Managed C++ | public __value struct EffectInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectInformation | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DynamicParams | Zero or more DIEP_* values denoting parameters of the effect that can be modified while the effect is playing. For a list of possible values, see InputeffectGetparameters. If an application attempts to change a parameter while the effect is playing and the driver does not support modifying that effect dynamically, the driver is permitted to stop the effect, update the parameters, then restart it. For more information, see InputeffectSetparameters.
EffectGuid | Identifier of the effect.
EffectType | Zero or more of the following values:
Name | Name of the effect, for example, 'Sawtooth up' or 'Constant force'.
StaticParams | Zero or more DIEP_* values describing the parameters supported by the effect. For example, if DIEP_ENVELOPE is set, the effect supports an envelope. For a list of possible values, see InputeffectGetparameters. It is not an error for an application to attempt to use effect parameters that are not supported by the device. The unsupported parameters are ignored.This information is provided to enable the application to tailor its use of force feedback to the capabilities of the specific device.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectInformation.EffectInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation.EffectInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectInformation();
Managed C++ | public: EffectInformation();
JScript .NET | public function EffectInformation();


EffectInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectInformation.DynamicParams

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation.DynamicParams Property

Language:
Note: This documentation is preliminary and is subject to change.

Zero or more DIEP_* values denoting parameters of the effect that can be modified while the effect is playing. For a list of possible values, see InputeffectGetparameters. If an application attempts to change a parameter while the effect is playing and the driver does not support modifying that effect dynamically, the driver is permitted to stop the effect, update the parameters, then restart it. For more information, see InputeffectSetparameters.

Definition

Visual Basic .NET | Public Property DynamicParams As Integer
C# | public int DynamicParams { get; set; }
Managed C++ public: __property int get_DynamicParams();
public: __property void set_DynamicParams(int);
JScript .NET public function get DynamicParams() : int
public function set DynamicParams(int);

Property Value

System.Int32 .

This property is read/write.


EffectInformation.EffectGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation.EffectGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Identifier of the effect.

Definition

Visual Basic .NET | Public Property EffectGuid As Guid
C# | public Guid EffectGuid { get; set; }
Managed C++ public: __property Guid get_EffectGuid();
public: __property void set_EffectGuid(Guid);
JScript .NET public function get EffectGuid() : Guid
public function set EffectGuid(Guid);

Property Value

System.Guid .

This property is read/write.


EffectInformation.EffectType

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation.EffectType Property

Language:
Note: This documentation is preliminary and is subject to change.

Zero or more of the following values:

Definition

Visual Basic .NET | Public Property EffectType As Integer
C# | public int EffectType { get; set; }
Managed C++ public: __property int get_EffectType();
public: __property void set_EffectType(int);
JScript .NET public function get EffectType() : int
public function set EffectType(int);

Property Value

System.Int32 .

This property is read/write.


EffectInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Name of the effect, for example, 'Sawtooth up' or 'Constant force'.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


EffectInformation.StaticParams

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectInformation.StaticParams Property

Language:
Note: This documentation is preliminary and is subject to change.

Zero or more DIEP_* values describing the parameters supported by the effect. For example, if DIEP_ENVELOPE is set, the effect supports an envelope. For a list of possible values, see InputeffectGetparameters. It is not an error for an application to attempt to use effect parameters that are not supported by the device. The unsupported parameters are ignored.This information is provided to enable the application to tailor its use of force feedback to the capabilities of the specific device.

Definition

Visual Basic .NET | Public Property StaticParams As Integer
C# | public int StaticParams { get; set; }
Managed C++ public: __property int get_StaticParams();
public: __property void set_StaticParams(int);
JScript .NET public function get StaticParams() : int
public function set StaticParams(int);

Property Value

System.Int32 .

This property is read/write.


EffectStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectStatus Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Structure EffectStatus
C# | public struct EffectStatus
Managed C++ | public __value struct EffectStatus
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectStatus | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Emulated
Playing | The effect is playing.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectStatus.EffectStatus()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectStatus.EffectStatus Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectStatus();
Managed C++ | public: EffectStatus();
JScript .NET | public function EffectStatus();


EffectStatus.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectStatus.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectStatus.Emulated

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectStatus.Emulated Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public ReadOnly Property Emulated As Boolean
C# | public bool Emulated { get; }
Managed C++ | public: __property bool get_Emulated();
JScript .NET | public function get Emulated() : boolean

Property Value

System.Boolean .

This property is read-only.


EffectStatus.Playing

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectStatus.Playing Property

Language:
Note: This documentation is preliminary and is subject to change.

The effect is playing.

Definition

Visual Basic .NET | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
Managed C++ | public: __property bool get_Playing();
JScript .NET | public function get Playing() : boolean

Property Value

System.Boolean .

This property is read-only.


Envelope

Microsoft DirectX 9.0 SDK Update (October 2004)

Envelope Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.

Definition

Visual Basic .NET | Public Structure Envelope
C# | public struct Envelope
Managed C++ | public __value struct Envelope
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Envelope | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AttackLevel | Amplitude for the start of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.
AttackTime | The time, in microseconds, to reach the TermSustain level.
FadeLevel | Amplitude for the end of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.
FadeTime | The time, in microseconds, to reach the fade level.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Envelope.Envelope()

Microsoft DirectX 9.0 SDK Update (October 2004)

Envelope.Envelope Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public Envelope();
Managed C++ | public: Envelope();
JScript .NET | public function Envelope();


Envelope.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Envelope.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Envelope.AttackLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Envelope.AttackLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Amplitude for the start of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.

Definition

Visual Basic .NET | Public Property AttackLevel As Integer
C# | public int AttackLevel { get; set; }
Managed C++ public: __property int get_AttackLevel();
public: __property void set_AttackLevel(int);
JScript .NET public function get AttackLevel() : int
public function set AttackLevel(int);

Property Value

System.Int32 .

This property is read/write.


Envelope.AttackTime

Microsoft DirectX 9.0 SDK Update (October 2004)

Envelope.AttackTime Property

Language:
Note: This documentation is preliminary and is subject to change.

The time, in microseconds, to reach the TermSustain level.

Definition

Visual Basic .NET | Public Property AttackTime As Integer
C# | public int AttackTime { get; set; }
Managed C++ public: __property int get_AttackTime();
public: __property void set_AttackTime(int);
JScript .NET public function get AttackTime() : int
public function set AttackTime(int);

Property Value

System.Int32 .

This property is read/write.


Envelope.FadeLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Envelope.FadeLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Amplitude for the end of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.

Definition

Visual Basic .NET | Public Property FadeLevel As Integer
C# | public int FadeLevel { get; set; }
Managed C++ public: __property int get_FadeLevel();
public: __property void set_FadeLevel(int);
JScript .NET public function get FadeLevel() : int
public function set FadeLevel(int);

Property Value

System.Int32 .

This property is read/write.


Envelope.FadeTime

Microsoft DirectX 9.0 SDK Update (October 2004)

Envelope.FadeTime Property

Language:
Note: This documentation is preliminary and is subject to change.

The time, in microseconds, to reach the fade level.

Definition

Visual Basic .NET | Public Property FadeTime As Integer
C# | public int FadeTime { get; set; }
Managed C++ public: __property int get_FadeTime();
public: __property void set_FadeTime(int);
JScript .NET public function get FadeTime() : int
public function set FadeTime(int);

Property Value

System.Int32 .

This property is read/write.


FileEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

FileEffect Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes data for a force-feedback effect stored in a file. It is used in conjunction with the Inputdevice9Enumeffectsinfile and Inputdevice9Writeeffecttofile methods.

Definition

Visual Basic .NET | Public Structure FileEffect
C# | public struct FileEffect
Managed C++ | public __value struct FileEffect
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
EffectStruct | Pointer to a Dieffect structure containing information about the effect.

Methods

Method | Description
FileEffect | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
EffectGuid | Unique identifier of the effect type. This can be one of the standard GUIDs defined in Dinput.h, such as GUID_ConstantForce, or one created by the designer.
Name | Name of the effect.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FileEffect.FileEffect()

Microsoft DirectX 9.0 SDK Update (October 2004)

FileEffect.FileEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public FileEffect();
Managed C++ | public: FileEffect();
JScript .NET | public function FileEffect();


FileEffect.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FileEffect.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FileEffect.EffectGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

FileEffect.EffectGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Unique identifier of the effect type. This can be one of the standard GUIDs defined in Dinput.h, such as GUID_ConstantForce, or one created by the designer.

Definition

Visual Basic .NET | Public Property EffectGuid As Guid
C# | public Guid EffectGuid { get; set; }
Managed C++ public: __property Guid get_EffectGuid();
public: __property void set_EffectGuid(Guid);
JScript .NET public function get EffectGuid() : Guid
public function set EffectGuid(Guid);

Property Value

System.Guid .

This property is read/write.


FileEffect.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

FileEffect.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Name of the effect.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


FileEffect.EffectStruct

Microsoft DirectX 9.0 SDK Update (October 2004)

FileEffect.EffectStruct Field

 Language:
Note: This documentation is preliminary and is subject to change.

Pointer to a Dieffect structure containing information about the effect.

Definition

Visual Basic .NET | Public EffectStruct As Effect
C# | public Effect EffectStruct;
Managed C++ | public: Effect EffectStruct;
JScript .NET | public var EffectStruct : Effect

Field Value

Microsoft.DirectX.DirectInput.Effect .

This field is read/write.


InputRange

Microsoft DirectX 9.0 SDK Update (October 2004)

InputRange Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Structure InputRange
C# | public struct InputRange
Managed C++ | public __value struct InputRange
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
InputRange | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property Description
Max
Min

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputRange.InputRange(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputRange.InputRange Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal minimumRange As Integer, _
ByVal maximumRange As Integer _
)
C# public InputRange(
int minimumRange,
int maximumRange
);
Managed C++ public: InputRange(
int minimumRange,
int maximumRange
);
JScript .NET public function InputRange(
minimumRange : int,
maximumRange : int
);

Parameters

minimumRange | System.Int32.
maximumRange | System.Int32.


InputRange.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputRange.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


InputRange.Max

Microsoft DirectX 9.0 SDK Update (October 2004)

InputRange.Max Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Max As Integer
C# | public int Max { get; set; }
Managed C++ public: __property int get_Max();
public: __property void set_Max(int);
JScript .NET public function get Max() : int
public function set Max(int);

Property Value

System.Int32 .

This property is read/write.


InputRange.Min

Microsoft DirectX 9.0 SDK Update (October 2004)

InputRange.Min Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Min As Integer
C# | public int Min { get; set; }
Managed C++ public: __property int get_Min();
public: __property void set_Min(int);
JScript .NET public function get Min() : int
public function set Min(int);

Property Value

System.Int32 .

This property is read/write.


JoystickState

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the state of a joystick device. This structure is used with the Inputdevice9Getdevicestate method.

Definition

Visual Basic .NET | Public Structure JoystickState
C# | public struct JoystickState
Managed C++ | public __value struct JoystickState
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetASlider | Extra axis accelerations.
GetButtons | Array of buttons. The high-order bit of the byte is set if the corresponding button is down, and clear if the button is up or does not exist.
GetFSlider | Extra axis forces.
GetPointOfView | Direction controllers, such as point-of-view hats. The position is indicated in hundredths of a degree clockwise from north (away from the user). The center position is normally reported as -1; but see Remarks. For indicators that have only five positions, the value for a controller is -1, 0, 9,000, 18,000, or 27,000.
GetSlider | Two additional axes, formerly called the u-axis and v-axis, whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.
GetVSlider | Extra axis velocities.
JoystickState | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ARx | X-axis angular acceleration.
ARy | Y-axis angular acceleration.
ARz | Z-axis angular acceleration.
AX | X-axis acceleration.
AY | Y-axis acceleration.
AZ | Z-axis acceleration.
FRx | X-axis torque.
FRy | Y-axis torque.
FRz | Z-axis torque.
FX | X-axis force.
FY | Y-axis force.
FZ | Z-axis force.
Rx | X-axis rotation. If the joystick does not have this axis, the value is 0.
Ry | Y-axis rotation. If the joystick does not have this axis, the value is 0.
Rz | Z-axis rotation (often called the rudder). If the joystick does not have this axis, the value is 0.
VRx | X-axis angular velocity.
VRy | Y-axis angular velocity.
VRz | Z-axis angular velocity.
VX | X-axis velocity.
VY | Y-axis velocity.
VZ | Z-axis velocity.
X | X-axis, usually the left-right movement of a stick.
Y | Y-axis, usually the forward-backward movement of a stick.
Z | Z-axis, often the throttle control. If the joystick does not have this axis, the value is 0.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


JoystickState.GetASlider()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.GetASlider Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extra axis accelerations.

Definition

Visual Basic .NET | Public Function GetASlider() As Integer()
C# | public int[] GetASlider();
Managed C++ | public: int GetASlider() __gc[];
JScript .NET | public function GetASlider() : int[];

Return Value

System.Int32[].


JoystickState.GetButtons()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.GetButtons Method

 Language:
Note: This documentation is preliminary and is subject to change.

Array of buttons. The high-order bit of the byte is set if the corresponding button is down, and clear if the button is up or does not exist.

Definition

Visual Basic .NET | Public Function GetButtons() As Byte()
C# | public byte[] GetButtons();
Managed C++ | public: Byte GetButtons() __gc[];
JScript .NET | public function GetButtons() : byte[];

Return Value

System.Byte[].


JoystickState.GetFSlider()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.GetFSlider Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extra axis forces.

Definition

Visual Basic .NET | Public Function GetFSlider() As Integer()
C# | public int[] GetFSlider();
Managed C++ | public: int GetFSlider() __gc[];
JScript .NET | public function GetFSlider() : int[];

Return Value

System.Int32[].


JoystickState.GetPointOfView()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.GetPointOfView Method

 Language:
Note: This documentation is preliminary and is subject to change.

Direction controllers, such as point-of-view hats. The position is indicated in hundredths of a degree clockwise from north (away from the user). The center position is normally reported as -1; but see Remarks. For indicators that have only five positions, the value for a controller is -1, 0, 9,000, 18,000, or 27,000.

Definition

Visual Basic .NET | Public Function GetPointOfView() As Integer()
C# | public int[] GetPointOfView();
Managed C++ | public: int GetPointOfView() __gc[];
JScript .NET | public function GetPointOfView() : int[];

Return Value

System.Int32[].


JoystickState.GetSlider()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.GetSlider Method

 Language:
Note: This documentation is preliminary and is subject to change.

Two additional axes, formerly called the u-axis and v-axis, whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.

Definition

Visual Basic .NET | Public Function GetSlider() As Integer()
C# | public int[] GetSlider();
Managed C++ | public: int GetSlider() __gc[];
JScript .NET | public function GetSlider() : int[];

Return Value

System.Int32[].


JoystickState.GetVSlider()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.GetVSlider Method

 Language:
Note: This documentation is preliminary and is subject to change.

Extra axis velocities.

Definition

Visual Basic .NET | Public Function GetVSlider() As Integer()
C# | public int[] GetVSlider();
Managed C++ | public: int GetVSlider() __gc[];
JScript .NET | public function GetVSlider() : int[];

Return Value

System.Int32[].


JoystickState.JoystickState()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.JoystickState Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public JoystickState();
Managed C++ | public: JoystickState();
JScript .NET | public function JoystickState();


JoystickState.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


JoystickState.ARx

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.ARx Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis angular acceleration.

Definition

Visual Basic .NET | Public ReadOnly Property ARx As Integer
C# | public int ARx { get; }
Managed C++ | public: __property int get_ARx();
JScript .NET | public function get ARx() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.ARy

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.ARy Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis angular acceleration.

Definition

Visual Basic .NET | Public ReadOnly Property ARy As Integer
C# | public int ARy { get; }
Managed C++ | public: __property int get_ARy();
JScript .NET | public function get ARy() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.ARz

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.ARz Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis angular acceleration.

Definition

Visual Basic .NET | Public ReadOnly Property ARz As Integer
C# | public int ARz { get; }
Managed C++ | public: __property int get_ARz();
JScript .NET | public function get ARz() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.AX

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.AX Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis acceleration.

Definition

Visual Basic .NET | Public ReadOnly Property AX As Integer
C# | public int AX { get; }
Managed C++ | public: __property int get_AX();
JScript .NET | public function get AX() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.AY

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.AY Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis acceleration.

Definition

Visual Basic .NET | Public ReadOnly Property AY As Integer
C# | public int AY { get; }
Managed C++ | public: __property int get_AY();
JScript .NET | public function get AY() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.AZ

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.AZ Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis acceleration.

Definition

Visual Basic .NET | Public ReadOnly Property AZ As Integer
C# | public int AZ { get; }
Managed C++ | public: __property int get_AZ();
JScript .NET | public function get AZ() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.FRx

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.FRx Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis torque.

Definition

Visual Basic .NET | Public ReadOnly Property FRx As Integer
C# | public int FRx { get; }
Managed C++ | public: __property int get_FRx();
JScript .NET | public function get FRx() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.FRy

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.FRy Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis torque.

Definition

Visual Basic .NET | Public ReadOnly Property FRy As Integer
C# | public int FRy { get; }
Managed C++ | public: __property int get_FRy();
JScript .NET | public function get FRy() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.FRz

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.FRz Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis torque.

Definition

Visual Basic .NET | Public ReadOnly Property FRz As Integer
C# | public int FRz { get; }
Managed C++ | public: __property int get_FRz();
JScript .NET | public function get FRz() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.FX

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.FX Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis force.

Definition

Visual Basic .NET | Public ReadOnly Property FX As Integer
C# | public int FX { get; }
Managed C++ | public: __property int get_FX();
JScript .NET | public function get FX() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.FY

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.FY Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis force.

Definition

Visual Basic .NET | Public ReadOnly Property FY As Integer
C# | public int FY { get; }
Managed C++ | public: __property int get_FY();
JScript .NET | public function get FY() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.FZ

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.FZ Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis force.

Definition

Visual Basic .NET | Public ReadOnly Property FZ As Integer
C# | public int FZ { get; }
Managed C++ | public: __property int get_FZ();
JScript .NET | public function get FZ() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.Rx

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.Rx Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis rotation. If the joystick does not have this axis, the value is 0.

Definition

Visual Basic .NET | Public ReadOnly Property Rx As Integer
C# | public int Rx { get; }
Managed C++ | public: __property int get_Rx();
JScript .NET | public function get Rx() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.Ry

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.Ry Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis rotation. If the joystick does not have this axis, the value is 0.

Definition

Visual Basic .NET | Public ReadOnly Property Ry As Integer
C# | public int Ry { get; }
Managed C++ | public: __property int get_Ry();
JScript .NET | public function get Ry() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.Rz

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.Rz Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis rotation (often called the rudder). If the joystick does not have this axis, the value is 0.

Definition

Visual Basic .NET | Public ReadOnly Property Rz As Integer
C# | public int Rz { get; }
Managed C++ | public: __property int get_Rz();
JScript .NET | public function get Rz() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.VRx

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.VRx Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis angular velocity.

Definition

Visual Basic .NET | Public ReadOnly Property VRx As Integer
C# | public int VRx { get; }
Managed C++ | public: __property int get_VRx();
JScript .NET | public function get VRx() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.VRy

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.VRy Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis angular velocity.

Definition

Visual Basic .NET | Public ReadOnly Property VRy As Integer
C# | public int VRy { get; }
Managed C++ | public: __property int get_VRy();
JScript .NET | public function get VRy() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.VRz

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.VRz Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis angular velocity.

Definition

Visual Basic .NET | Public ReadOnly Property VRz As Integer
C# | public int VRz { get; }
Managed C++ | public: __property int get_VRz();
JScript .NET | public function get VRz() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.VX

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.VX Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis velocity.

Definition

Visual Basic .NET | Public ReadOnly Property VX As Integer
C# | public int VX { get; }
Managed C++ | public: __property int get_VX();
JScript .NET | public function get VX() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.VY

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.VY Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis velocity.

Definition

Visual Basic .NET | Public ReadOnly Property VY As Integer
C# | public int VY { get; }
Managed C++ | public: __property int get_VY();
JScript .NET | public function get VY() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.VZ

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.VZ Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis velocity.

Definition

Visual Basic .NET | Public ReadOnly Property VZ As Integer
C# | public int VZ { get; }
Managed C++ | public: __property int get_VZ();
JScript .NET | public function get VZ() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.X

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.X Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis, usually the left-right movement of a stick.

Definition

Visual Basic .NET | Public ReadOnly Property X As Integer
C# | public int X { get; }
Managed C++ | public: __property int get_X();
JScript .NET | public function get X() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.Y Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis, usually the forward-backward movement of a stick.

Definition

Visual Basic .NET | Public ReadOnly Property Y As Integer
C# | public int Y { get; }
Managed C++ | public: __property int get_Y();
JScript .NET | public function get Y() : int

Property Value

System.Int32 .

This property is read-only.


JoystickState.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

JoystickState.Z Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis, often the throttle control. If the joystick does not have this axis, the value is 0.

Definition

Visual Basic .NET | Public ReadOnly Property Z As Integer
C# | public int Z { get; }
Managed C++ | public: __property int get_Z();
JScript .NET | public function get Z() : int

Property Value

System.Int32 .

This property is read-only.


MouseState

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseState Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes the state of a mouse device that has up to four buttons, or another device that is being accessed as if it were a mouse device. This structure is used with the Inputdevice9Getdevicestate method.

Definition

Visual Basic .NET | Public Structure MouseState
C# | public struct MouseState
Managed C++ | public __value struct MouseState
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetMouseButtons | Array of buttons. The high-order bit of the byte is set if the corresponding button is down.
MouseState | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
X | X-axis.
Y | Y-axis.
Z | Z-axis, typically a wheel. If the mouse does not have a z-axis, the value is 0.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MouseState.GetMouseButtons()

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseState.GetMouseButtons Method

 Language:
Note: This documentation is preliminary and is subject to change.

Array of buttons. The high-order bit of the byte is set if the corresponding button is down.

Definition

Visual Basic .NET | Public Function GetMouseButtons() As Byte()
C# | public byte[] GetMouseButtons();
Managed C++ | public: Byte GetMouseButtons() __gc[];
JScript .NET | public function GetMouseButtons() : byte[];

Return Value

System.Byte[].


MouseState.MouseState()

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseState.MouseState Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public MouseState();
Managed C++ | public: MouseState();
JScript .NET | public function MouseState();


MouseState.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseState.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


MouseState.X

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseState.X Property

Language:
Note: This documentation is preliminary and is subject to change.

X-axis.

Definition

Visual Basic .NET | Public ReadOnly Property X As Integer
C# | public int X { get; }
Managed C++ | public: __property int get_X();
JScript .NET | public function get X() : int

Property Value

System.Int32 .

This property is read-only.


MouseState.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseState.Y Property

Language:
Note: This documentation is preliminary and is subject to change.

Y-axis.

Definition

Visual Basic .NET | Public ReadOnly Property Y As Integer
C# | public int Y { get; }
Managed C++ | public: __property int get_Y();
JScript .NET | public function get Y() : int

Property Value

System.Int32 .

This property is read-only.


MouseState.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

MouseState.Z Property

Language:
Note: This documentation is preliminary and is subject to change.

Z-axis, typically a wheel. If the mouse does not have a z-axis, the value is 0.

Definition

Visual Basic .NET | Public ReadOnly Property Z As Integer
C# | public int Z { get; }
Managed C++ | public: __property int get_Z();
JScript .NET | public function get Z() : int

Property Value

System.Int32 .

This property is read-only.


ObjectDataFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectDataFormat Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a device object's data format for use with the Inputdevice9Setdataformat method.

Definition

Visual Basic .NET | Public Structure ObjectDataFormat
C# | public struct ObjectDataFormat
Managed C++ | public __value struct ObjectDataFormat
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ObjectDataFormat | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DeviceType | Device type that describes the object. It is a combination of the following flags describing the object type (axis, button, and so forth) and containing the object-instance number in the middle 16 bits. When requesting a data format, the instance portion must be set to DIDFT_ANYINSTANCE to indicate that any instance is permissible, or to DidftMakeinstance(n) to restrict the request to instance n. See the examples under Remarks.
Flags | Zero or more of the following values:
Offset | Offset within the data packet where the data for the input source is stored. This value must be a multiple of 4 for DWORD size data, such as axes. It can be byte-aligned for buttons.
SourceGuid | Unique identifier for the axis, button, or other input source. When requesting a data format, making this member NULL indicates that any type of object is permissible.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ObjectDataFormat.ObjectDataFormat()

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectDataFormat.ObjectDataFormat Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public ObjectDataFormat();
Managed C++ | public: ObjectDataFormat();
JScript .NET | public function ObjectDataFormat();


ObjectDataFormat.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectDataFormat.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ObjectDataFormat.DeviceType

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectDataFormat.DeviceType Property

Language:
Note: This documentation is preliminary and is subject to change.

Device type that describes the object. It is a combination of the following flags describing the object type (axis, button, and so forth) and containing the object-instance number in the middle 16 bits. When requesting a data format, the instance portion must be set to DIDFT_ANYINSTANCE to indicate that any instance is permissible, or to DidftMakeinstance(n) to restrict the request to instance n. See the examples under Remarks.

Definition

Visual Basic .NET | Public Property DeviceType As Integer
C# | public int DeviceType { get; set; }
Managed C++ public: __property int get_DeviceType();
public: __property void set_DeviceType(int);
JScript .NET public function get DeviceType() : int
public function set DeviceType(int);

Property Value

System.Int32 .

This property is read/write.


ObjectDataFormat.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectDataFormat.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Zero or more of the following values:

Definition

Visual Basic .NET | Public Property Flags As Integer
C# | public int Flags { get; set; }
Managed C++ public: __property int get_Flags();
public: __property void set_Flags(int);
JScript .NET public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32 .

This property is read/write.


ObjectDataFormat.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectDataFormat.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

Offset within the data packet where the data for the input source is stored. This value must be a multiple of 4 for DWORD size data, such as axes. It can be byte-aligned for buttons.

Definition

Visual Basic .NET | Public Property Offset As Integer
C# | public int Offset { get; set; }
Managed C++ public: __property int get_Offset();
public: __property void set_Offset(int);
JScript .NET public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32 .

This property is read/write.


ObjectDataFormat.SourceGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectDataFormat.SourceGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Unique identifier for the axis, button, or other input source. When requesting a data format, making this member NULL indicates that any type of object is permissible.

Definition

Visual Basic .NET | Public Property SourceGuid As Guid
C# | public Guid SourceGuid { get; set; }
Managed C++ public: __property Guid get_SourceGuid();
public: __property void set_SourceGuid(Guid);
JScript .NET public function get SourceGuid() : Guid
public function set SourceGuid(Guid);

Property Value

System.Guid .

This property is read/write.


Periodic

Microsoft DirectX 9.0 SDK Update (October 2004)

Periodic Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic .NET | Public Structure Periodic
C# | public struct Periodic
Managed C++ | public __value struct Periodic
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Periodic | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Magnitude | Magnitude of the effect, in the range from 0 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.
Offset | Offset of the effect. The range of forces generated by the effect is LOffset minus DwMagnitude to LOffset plus DwMagnitude. The value of the LOffset member is also the baseline for any envelope that is applied to the effect.
Period | Period of the effect, in microseconds.
Phase | Position in the cycle of the periodic effect at which playback begins, in the range from 0 through 35,999. See Remarks.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Periodic.Periodic()

Microsoft DirectX 9.0 SDK Update (October 2004)

Periodic.Periodic Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public Periodic();
Managed C++ | public: Periodic();
JScript .NET | public function Periodic();


Periodic.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Periodic.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Periodic.Magnitude

Microsoft DirectX 9.0 SDK Update (October 2004)

Periodic.Magnitude Property

Language:
Note: This documentation is preliminary and is subject to change.

Magnitude of the effect, in the range from 0 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.

Definition

Visual Basic .NET | Public Property Magnitude As Integer
C# | public int Magnitude { get; set; }
Managed C++ public: __property int get_Magnitude();
public: __property void set_Magnitude(int);
JScript .NET public function get Magnitude() : int
public function set Magnitude(int);

Property Value

System.Int32 .

This property is read/write.


Periodic.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

Periodic.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

Offset of the effect. The range of forces generated by the effect is LOffset minus DwMagnitude to LOffset plus DwMagnitude. The value of the LOffset member is also the baseline for any envelope that is applied to the effect.

Definition

Visual Basic .NET | Public Property Offset As Integer
C# | public int Offset { get; set; }
Managed C++ public: __property int get_Offset();
public: __property void set_Offset(int);
JScript .NET public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32 .

This property is read/write.


Periodic.Period

Microsoft DirectX 9.0 SDK Update (October 2004)

Periodic.Period Property

Language:
Note: This documentation is preliminary and is subject to change.

Period of the effect, in microseconds.

Definition

Visual Basic .NET | Public Property Period As Integer
C# | public int Period { get; set; }
Managed C++ public: __property int get_Period();
public: __property void set_Period(int);
JScript .NET public function get Period() : int
public function set Period(int);

Property Value

System.Int32 .

This property is read/write.


Periodic.Phase

Microsoft DirectX 9.0 SDK Update (October 2004)

Periodic.Phase Property

Language:
Note: This documentation is preliminary and is subject to change.

Position in the cycle of the periodic effect at which playback begins, in the range from 0 through 35,999. See Remarks.

Definition

Visual Basic .NET | Public Property Phase As Integer
C# | public int Phase { get; set; }
Managed C++ public: __property int get_Phase();
public: __property void set_Phase(int);
JScript .NET public function get Phase() : int
public function set Phase(int);

Property Value

System.Int32 .

This property is read/write.


RampForce

Microsoft DirectX 9.0 SDK Update (October 2004)

RampForce Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains type-specific information for effects that are marked as DIEFT_RAMPFORCE. The structure describes a ramp force effect.A reference to a single Dirampforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic .NET | Public Structure RampForce
C# | public struct RampForce
Managed C++ | public __value struct RampForce
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RampForce | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
End | Magnitude at the end of the effect, in the range from -10,000 through 10,000.
Start | Magnitude at the start of the effect, in the range from -10,000 through 10,000.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RampForce.RampForce()

Microsoft DirectX 9.0 SDK Update (October 2004)

RampForce.RampForce Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public RampForce();
Managed C++ | public: RampForce();
JScript .NET | public function RampForce();


RampForce.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RampForce.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RampForce.End

Microsoft DirectX 9.0 SDK Update (October 2004)

RampForce.End Property

Language:
Note: This documentation is preliminary and is subject to change.

Magnitude at the end of the effect, in the range from -10,000 through 10,000.

Definition

Visual Basic .NET | Public Property End As Integer
C# | public int End { get; set; }
Managed C++ public: __property int get_End();
public: __property void set_End(int);
JScript .NET public function get End() : int
public function set End(int);

Property Value

System.Int32 .

This property is read/write.


RampForce.Start

Microsoft DirectX 9.0 SDK Update (October 2004)

RampForce.Start Property

Language:
Note: This documentation is preliminary and is subject to change.

Magnitude at the start of the effect, in the range from -10,000 through 10,000.

Definition

Visual Basic .NET | Public Property Start As Integer
C# | public int Start { get; set; }
Managed C++ public: __property int get_Start();
public: __property void set_Start(int);
JScript .NET public function get Start() : int
public function set Start(int);

Property Value

System.Int32 .

This property is read/write.


SemanticsInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

SemanticsInstance Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Structure SemanticsInstance
C# | public struct SemanticsInstance
Managed C++ | public __value struct SemanticsInstance
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
SemanticsInstance | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property Description
Device
DeviceInstance
Flags
Remaining

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SemanticsInstance.SemanticsInstance()

Microsoft DirectX 9.0 SDK Update (October 2004)

SemanticsInstance.SemanticsInstance Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET | Public Sub New()
C# | public SemanticsInstance();
Managed C++ | public: SemanticsInstance();
JScript .NET | public function SemanticsInstance();


SemanticsInstance.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SemanticsInstance.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SemanticsInstance.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

SemanticsInstance.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Device As Device
C# | public Device Device { get; set; }
Managed C++ public: __property Device* get_Device();
public: __property void set_Device(Device*);
JScript .NET public function get Device() : Device
public function set Device(Device);

Property Value

Microsoft.DirectX.DirectInput.Device .

This property is read/write.


SemanticsInstance.DeviceInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

SemanticsInstance.DeviceInstance Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property DeviceInstance As DeviceInstance
C# | public DeviceInstance DeviceInstance { get; set; }
Managed C++ public: __property DeviceInstance get_DeviceInstance();
public: __property void set_DeviceInstance(DeviceInstance);
JScript .NET public function get DeviceInstance() : DeviceInstance
public function set DeviceInstance(DeviceInstance);

Property Value

Microsoft.DirectX.DirectInput.DeviceInstance .

This property is read/write.


SemanticsInstance.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

SemanticsInstance.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Flags As Integer
C# | public int Flags { get; set; }
Managed C++ public: __property int get_Flags();
public: __property void set_Flags(int);
JScript .NET public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32 .

This property is read/write.


SemanticsInstance.Remaining

Microsoft DirectX 9.0 SDK Update (October 2004)

SemanticsInstance.Remaining Property

Language:
Note: This documentation is preliminary and is subject to change.

Definition

Visual Basic .NET | Public Property Remaining As Integer
C# | public int Remaining { get; set; }
Managed C++ public: __property int get_Remaining();
public: __property void set_Remaining(int);
JScript .NET public function get Remaining() : int
public function set Remaining(int);

Property Value

System.Int32 .

This property is read/write.


Microsoft.DirectX.DirectPlay.Lobby

Note: This documentation is preliminary and is subject to change.

Warning: Microsoft® DirectPlay® Lobby has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Lobby enables a DirectX application to interact with an application hosted on a remote server. The following tables list the members exposed by the Microsoft.DirectX.DirectPlay.Lobby namespace.

Classes

Application
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Application object is used by an application that supports lobbying. This object allows the application to register with the system so that it can be lobby launched. Additionally, it also lets the application get the connection information necessary to launch a game without querying the user. Lastly, this object allows the lobbied application to send messages and notifications to the lobby client that launched the application. Deprecated.
Client
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Client object is used by a lobby client application and is responsible for enumerating and launching lobby-enabled game applications on the local computer, and communicating with them once they are running. Deprecated.
ConnectEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.
ConnectionSettingsEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.
DisconnectEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.
ReceiveEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
SessionStatusEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Enumerations

AvailableFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The default behavior for this method is to automatically mark the object as Unavailable when the first connection is established. By specifying this flag, the object is not automatically marked unavailable after the first connection is established, thereby allowing multiple connections. Deprecated.
ConnectFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.
ConnectionSettingsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flgas for connection settings. Deprecated.
Handle
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to represent system handles. Deprecated.
InitializeFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.
SessionStatusFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for SessionStatus Deprecated.

Structures

ApplicationInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used in the pEnumData parameter of the Play8lobbyclientEnumlocalprogramsDplay method to describe the lobbied application. Deprecated.
ConnectInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify connection information for a lobby client when connecting to the lobby application in the Play8lobbyclientConnectapplicationDplay method. Deprecated.
ConnectionSettings
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify the settings you want to associate with a connection. These settings contain all the information required to create, initialize and connect/host a Microsoft® DirectPlay® object. Deprecated.
ConnectionSettingsMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.
ConnectMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.
DisconnectMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.
ProgramDescription
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a Microsoft® DirectPlay® lobby-aware application. Deprecated.
ReceiveMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
SessionStatusMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Delegates

ConnectEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Connect event. Deprecated.
ConnectionSettingsEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.
DisconnectEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
ReceiveLobbyEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.
SessionStatusEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionStatus event. Deprecated.


Microsoft.DirectX.DirectPlay.Lobby.Application

Microsoft DirectX 9.0 SDK Update (October 2004)

Application Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Application object is used by an application that supports lobbying. This object allows the application to register with the system so that it can be lobby launched. Additionally, it also lets the application get the connection information necessary to launch a game without querying the user. Lastly, this object allows the lobbied application to send messages and notifications to the lobby client that launched the application. Deprecated.

Definition

Visual Basic .NET Public Class Application
Inherits MarshalByRefObject
Implements IDisposable
C# public class Application : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Application : public MarshalByRefObject,
IDisposable
JScript .NET public class Application extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Connect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.
ConnectionSettings
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.
Disconnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application receives data. Deprecated.
SessionStatus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Methods

Method Description
Application
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disconnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionStatus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterProgram
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Registers a lobby-aware application with . Applications must be registered to enable lobby launching. Deprecated.
Send
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message from the lobbied application to the lobby client. Deprecated.
SetApplicationAvailable
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes an application available or unavailable for a lobby client to connect to. This method is typically called if a lobbied application is independently launched, that is, not launched by a lobby client. Additionally, this method should be called if a game has ended and the lobbied application needs to be available to connect to a lobby client at the start of another game. Deprecated.
SetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method generates a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.
UnregisterProgram
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unregisters a lobby-aware application that was registered through the method. Deprecated.
UpdateStatus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updates the status of a connected lobby client. Deprecated.

Properties

Property Description
ConnectionHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection handle to the lobby client. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Application

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Application.Application

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Application Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Overload List

public Application();
public Application(InitializeFlags);
public Application(out int, ConnectEventHandler);
public Application(out int, InitializeFlags, ConnectEventHandler);


Application.Application(Int32,InitializeFlags,ConnectEventHandler)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Application Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByRef connectionHandle As Integer, _
ByVal flags As InitializeFlags, _
ByVal connectEventHandler As ConnectEventHandler _
)
C# public Application(
out int connectionHandle,
InitializeFlags flags,
ConnectEventHandler connectEventHandler
);
Managed C++ public: Application(
int *connectionHandle,
InitializeFlags flags,
ConnectEventHandler *connectEventHandler
);
JScript .NET public function Application(
connectionHandle : int,
flags : InitializeFlags,
connectEventHandler : ConnectEventHandler
);

Parameters

connectionHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.Lobby.InitializeFlags.
connectEventHandler | Microsoft.DirectX.DirectPlay.Lobby.ConnectEventHandler.


Application.Application(Int32,ConnectEventHandler)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Application Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByRef connectionHandle As Integer, _
ByVal connectEventHandler As ConnectEventHandler _
)
C# public Application(
out int connectionHandle,
ConnectEventHandler connectEventHandler
);
Managed C++ public: Application(
int *connectionHandle,
ConnectEventHandler *connectEventHandler
);
JScript .NET public function Application(
connectionHandle : int,
connectEventHandler : ConnectEventHandler
);

Parameters

connectionHandle | System.Int32.
connectEventHandler | Microsoft.DirectX.DirectPlay.Lobby.ConnectEventHandler.


Application.Application(InitializeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Application Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Application(
InitializeFlags flags
);
Managed C++ public: Application(
InitializeFlags flags
);
JScript .NET public function Application(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Lobby.InitializeFlags.


Application.Application()

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Application Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Application();
Managed C++ | public: Application();
JScript .NET | public function Application();


Application.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Application.Disposed
  • Application.Disposing


Application.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Application.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Application();
Managed C++ | ~Application();
JScript .NET | protected override function Finalize();


Application.GetConnectionSettings(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.GetConnectionSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.

Definition

Visual Basic .NET Public Function GetConnectionSettings( _
ByVal lobbyClient As Integer _
) As ConnectionSettings
C# public ConnectionSettings GetConnectionSettings(
int lobbyClient
);
Managed C++ public: ConnectionSettings GetConnectionSettings(
int lobbyClient
);
JScript .NET public function GetConnectionSettings(
lobbyClient : int
) : ConnectionSettings;

Parameters

lobbyClient System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings .


Application.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Application.op_Equality(Application,Application)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Application, _
ByVal right As Application _
) As Boolean
C# public static bool op_Equality(
Application left,
Application right
);
Managed C++ public: static bool op_Equality(
Application *left,
Application *right
);
JScript .NET public static function op_Equality(
left : Application,
right : Application
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Lobby.Application. The Application structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Lobby.Application. The Application structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Application.op_Inequality(Application,Application)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Application, _
ByVal right As Application _
) As Boolean
C# public static bool op_Inequality(
Application left,
Application right
);
Managed C++ public: static bool op_Inequality(
Application *left,
Application *right
);
JScript .NET public static function op_Inequality(
left : Application,
right : Application
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Lobby.Application. The Application structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Lobby.Application. The Application structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Application.raise_Connect(Object,ConnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.raise_Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Connect( _
ByVal i1 As Object, _
ByVal i2 As ConnectEventArgs _
)
C# protected void raise_Connect(
object i1,
ConnectEventArgs i2
);
Managed C++ protected: void raise_Connect(
Object *i1,
ConnectEventArgs *i2
);
JScript .NET protected function raise_Connect(
i1 : Object,
i2 : ConnectEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.ConnectEventArgs.


Application.raise_ConnectionSettings(Object,ConnectionSettingsEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.raise_ConnectionSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ConnectionSettings( _
ByVal i1 As Object, _
ByVal i2 As ConnectionSettingsEventArgs _
)
C# protected void raise_ConnectionSettings(
object i1,
ConnectionSettingsEventArgs i2
);
Managed C++ protected: void raise_ConnectionSettings(
Object *i1,
ConnectionSettingsEventArgs *i2
);
JScript .NET protected function raise_ConnectionSettings(
i1 : Object,
i2 : ConnectionSettingsEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsEventArgs.


Application.raise_Disconnect(Object,DisconnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.raise_Disconnect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disconnect( _
ByVal i1 As Object, _
ByVal i2 As DisconnectEventArgs _
)
C# protected void raise_Disconnect(
object i1,
DisconnectEventArgs i2
);
Managed C++ protected: void raise_Disconnect(
Object *i1,
DisconnectEventArgs *i2
);
JScript .NET protected function raise_Disconnect(
i1 : Object,
i2 : DisconnectEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.DisconnectEventArgs.


Application.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Application.raise_Receive(Object,ReceiveEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.raise_Receive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
Managed C++ protected: void raise_Receive(
Object *i1,
ReceiveEventArgs *i2
);
JScript .NET protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.ReceiveEventArgs.


Application.raise_SessionStatus(Object,SessionStatusEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.raise_SessionStatus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SessionStatus( _
ByVal i1 As Object, _
ByVal i2 As SessionStatusEventArgs _
)
C# protected void raise_SessionStatus(
object i1,
SessionStatusEventArgs i2
);
Managed C++ protected: void raise_SessionStatus(
Object *i1,
SessionStatusEventArgs *i2
);
JScript .NET protected function raise_SessionStatus(
i1 : Object,
i2 : SessionStatusEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.SessionStatusEventArgs.


Application.RegisterProgram(ProgramDescription)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.RegisterProgram Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Registers a lobby-aware application with . Applications must be registered to enable lobby launching. Deprecated.

Definition

Visual Basic .NET Public Sub RegisterProgram( _
ByVal programDescription As ProgramDescription _
)
C# public void RegisterProgram(
ProgramDescription programDescription
);
Managed C++ public: void RegisterProgram(
ProgramDescription programDescription
);
JScript .NET public function RegisterProgram(
programDescription : ProgramDescription
);

Parameters

programDescription Microsoft.DirectX.DirectPlay.Lobby.ProgramDescription.


Application.Send(Int32,NetworkPacket)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message from the lobbied application to the lobby client. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal connectionHandle As Integer, _
ByVal data As NetworkPacket _
)
C# public void Send(
int connectionHandle,
NetworkPacket data
);
Managed C++ public: void Send(
int connectionHandle,
NetworkPacket *data
);
JScript .NET public function Send(
connectionHandle : int,
data : NetworkPacket
);

Parameters

connectionHandle | System.Int32.
data | Microsoft.DirectX.DirectPlay.NetworkPacket.


Application.SetApplicationAvailable(Boolean,AvailableFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.SetApplicationAvailable Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes an application available or unavailable for a lobby client to connect to. This method is typically called if a lobbied application is independently launched, that is, not launched by a lobby client. Additionally, this method should be called if a game has ended and the lobbied application needs to be available to connect to a lobby client at the start of another game. Deprecated.

Definition

Visual Basic .NET Public Sub SetApplicationAvailable( _
ByVal available As Boolean, _
ByVal flags As AvailableFlags _
)
C# public void SetApplicationAvailable(
bool available,
AvailableFlags flags
);
Managed C++ public: void SetApplicationAvailable(
bool available,
AvailableFlags flags
);
JScript .NET public function SetApplicationAvailable(
available : boolean,
flags : AvailableFlags
);

Parameters

available | System.Boolean.
flags | Microsoft.DirectX.DirectPlay.Lobby.AvailableFlags.


Application.SetConnectionSettings(Int32,ConnectionSettings)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.SetConnectionSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method generates a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.

Definition

Visual Basic .NET Public Sub SetConnectionSettings( _
ByVal lobbyClient As Integer, _
ByVal connectionSettings As ConnectionSettings _
)
C# public void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
Managed C++ public: void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
JScript .NET public function SetConnectionSettings(
lobbyClient : int,
connectionSettings : ConnectionSettings
);

Parameters

lobbyClient | System.Int32.
connectionSettings | Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings.


Application.UnregisterProgram(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.UnregisterProgram Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unregisters a lobby-aware application that was registered through the method. Deprecated.

Definition

Visual Basic .NET Public Sub UnregisterProgram( _
ByVal guidApplication As Guid _
)
C# public void UnregisterProgram(
Guid guidApplication
);
Managed C++ public: void UnregisterProgram(
Guid guidApplication
);
JScript .NET public function UnregisterProgram(
guidApplication : Guid
);

Parameters

guidApplication System.Guid.


Application.UpdateStatus(Int32,SessionStatusFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.UpdateStatus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updates the status of a connected lobby client. Deprecated.

Definition

Visual Basic .NET Public Sub UpdateStatus( _
ByVal connectionHandle As Integer, _
ByVal flags As SessionStatusFlags _
)
C# public void UpdateStatus(
int connectionHandle,
SessionStatusFlags flags
);
Managed C++ public: void UpdateStatus(
int connectionHandle,
SessionStatusFlags flags
);
JScript .NET public function UpdateStatus(
connectionHandle : int,
flags : SessionStatusFlags
);

Parameters

connectionHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.Lobby.SessionStatusFlags.


Application.ConnectionHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.ConnectionHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection handle to the lobby client. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionHandle As Integer
C# | public int ConnectionHandle { get; }
Managed C++ | public: __property int get_ConnectionHandle();
JScript .NET | public function get ConnectionHandle() : int

Property Value

System.Int32 .

This property is read-only.


Application.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Application.Connect

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Connect Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.

Definition

Visual Basic .NET | Public Event Connect As ConnectEventHandler
C# | public event ConnectEventHandler Connect;
Managed C++ | public: __event ConnectEventHandler Connect;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Application.ConnectionSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.ConnectionSettings Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.

Definition

Visual Basic .NET | Public Event ConnectionSettings As ConnectionSettingsEventHandler
C# | public event ConnectionSettingsEventHandler ConnectionSettings;
Managed C++ | public: __event ConnectionSettingsEventHandler ConnectionSettings;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Application.Disconnect

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Disconnect Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has completed. Deprecated.

Definition

Visual Basic .NET | Public Event Disconnect As DisconnectEventHandler
C# | public event DisconnectEventHandler Disconnect;
Managed C++ | public: __event DisconnectEventHandler Disconnect;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Application.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Application.Disposing event, use the following code.

application.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Application.Receive

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.Receive Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application receives data. Deprecated.

Definition

Visual Basic .NET | Public Event Receive As ReceiveLobbyEventHandler
C# | public event ReceiveLobbyEventHandler Receive;
Managed C++ | public: __event ReceiveLobbyEventHandler Receive;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Application.SessionStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

Application.SessionStatus Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Definition

Visual Basic .NET | Public Event SessionStatus As SessionStatusEventHandler
C# | public event SessionStatusEventHandler SessionStatus;
Managed C++ | public: __event SessionStatusEventHandler SessionStatus;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.Lobby.Client

Microsoft DirectX 9.0 SDK Update (October 2004)

Client Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Client object is used by a lobby client application and is responsible for enumerating and launching lobby-enabled game applications on the local computer, and communicating with them once they are running. Deprecated.

Definition

Visual Basic .NET Public Class Client
Inherits MarshalByRefObject
Implements IDisposable
C# public class Client : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Client : public MarshalByRefObject,
IDisposable
JScript .NET public class Client extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Connect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.
ConnectionSettings
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.
Disconnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when data has been received. Deprecated.
SessionStatus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Methods

Method Description
Client
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ConnectApplication
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connects a lobby-enabled application to the session specified in the structure. If the application is not running, this method can be used to launch the application.When the connection is successfully established, the lobbied application generates a system message to the message handler. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetLocalPrograms
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disconnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionStatus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
ReleaseApplication
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Releases a lobbied application and closes the connection between the lobby client and the application. This method should be called whenever a lobby client has finished its session with an application. Deprecated.
Send
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message to a lobbied application that was launched by this lobby client or was connected by this lobby client. Deprecated.
SetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method will generate a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Client

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Client.Client

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Client Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Client();
public Client(InitializeFlags);


Client.Client(InitializeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Client Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Client(
InitializeFlags flags
);
Managed C++ public: Client(
InitializeFlags flags
);
JScript .NET public function Client(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Lobby.InitializeFlags.


Client.Client()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Client Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Client();
Managed C++ | public: Client();
JScript .NET | public function Client();


Client.ConnectApplication(ConnectInformation,Int32,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ConnectApplication Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connects a lobby-enabled application to the session specified in the structure. If the application is not running, this method can be used to launch the application.When the connection is successfully established, the lobbied application generates a system message to the message handler. Deprecated.

Definition

Visual Basic .NET Public Function ConnectApplication( _
ByVal connectInformation As ConnectInformation, _
ByVal timeOut As Integer, _
ByVal applicationContext As Object _
) As Integer
C# public int ConnectApplication(
ConnectInformation connectInformation,
int timeOut,
object applicationContext
);
Managed C++ public: int ConnectApplication(
ConnectInformation connectInformation,
int timeOut,
Object *applicationContext
);
JScript .NET public function ConnectApplication(
connectInformation : ConnectInformation,
timeOut : int,
applicationContext : Object
) : int;

Parameters

connectInformation | Microsoft.DirectX.DirectPlay.Lobby.ConnectInformation.
timeOut | System.Int32.
applicationContext | System.Object.

Return Value

System.Int32 .


Client.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


Client.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Client.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Client();
Managed C++ | ~Client();
JScript .NET | protected override function Finalize();


Client.GetConnectionSettings(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetConnectionSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.

Definition

Visual Basic .NET Public Function GetConnectionSettings( _
ByVal lobbyClient As Integer _
) As ConnectionSettings
C# public ConnectionSettings GetConnectionSettings(
int lobbyClient
);
Managed C++ public: ConnectionSettings GetConnectionSettings(
int lobbyClient
);
JScript .NET public function GetConnectionSettings(
lobbyClient : int
) : ConnectionSettings;

Parameters

lobbyClient System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings .


Client.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Client.GetLocalPrograms

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetLocalPrograms Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.

Overload List

public ApplicationInformation[] GetLocalPrograms();
public ApplicationInformation[] GetLocalPrograms(Guid);


Client.GetLocalPrograms()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetLocalPrograms Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.

Definition

Visual Basic .NET | Public Function GetLocalPrograms() As ApplicationInformation()
C# | public ApplicationInformation[] GetLocalPrograms();
Managed C++ | public: ApplicationInformation GetLocalPrograms() __gc[];
JScript .NET | public function GetLocalPrograms() : ApplicationInformation[];

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ApplicationInformation[].


Client.GetLocalPrograms(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetLocalPrograms Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.

Definition

Visual Basic .NET Public Function GetLocalPrograms( _
ByVal guidApplication As Guid _
) As ApplicationInformation()
C# public ApplicationInformation[] GetLocalPrograms(
Guid guidApplication
);
Managed C++ public: ApplicationInformation GetLocalPrograms(
Guid guidApplication
) __gc[];
JScript .NET public function GetLocalPrograms(
guidApplication : Guid
) : ApplicationInformation[];

Parameters

guidApplication System.Guid.

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ApplicationInformation[].


Client.op_Equality(Client,Client)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Equality(
Client left,
Client right
);
Managed C++ public: static bool op_Equality(
Client *left,
Client *right
);
JScript .NET public static function op_Equality(
left : Client,
right : Client
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Lobby.Client. The Client structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Lobby.Client. The Client structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Client.op_Inequality(Client,Client)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Inequality(
Client left,
Client right
);
Managed C++ public: static bool op_Inequality(
Client *left,
Client *right
);
JScript .NET public static function op_Inequality(
left : Client,
right : Client
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Lobby.Client. The Client structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Lobby.Client. The Client structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Client.raise_Connect(Object,ConnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Connect( _
ByVal i1 As Object, _
ByVal i2 As ConnectEventArgs _
)
C# protected void raise_Connect(
object i1,
ConnectEventArgs i2
);
Managed C++ protected: void raise_Connect(
Object *i1,
ConnectEventArgs *i2
);
JScript .NET protected function raise_Connect(
i1 : Object,
i2 : ConnectEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.ConnectEventArgs.


Client.raise_ConnectionSettings(Object,ConnectionSettingsEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_ConnectionSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ConnectionSettings( _
ByVal i1 As Object, _
ByVal i2 As ConnectionSettingsEventArgs _
)
C# protected void raise_ConnectionSettings(
object i1,
ConnectionSettingsEventArgs i2
);
Managed C++ protected: void raise_ConnectionSettings(
Object *i1,
ConnectionSettingsEventArgs *i2
);
JScript .NET protected function raise_ConnectionSettings(
i1 : Object,
i2 : ConnectionSettingsEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsEventArgs.


Client.raise_Disconnect(Object,DisconnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_Disconnect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disconnect( _
ByVal i1 As Object, _
ByVal i2 As DisconnectEventArgs _
)
C# protected void raise_Disconnect(
object i1,
DisconnectEventArgs i2
);
Managed C++ protected: void raise_Disconnect(
Object *i1,
DisconnectEventArgs *i2
);
JScript .NET protected function raise_Disconnect(
i1 : Object,
i2 : DisconnectEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.DisconnectEventArgs.


Client.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Client.raise_Receive(Object,ReceiveEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_Receive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
Managed C++ protected: void raise_Receive(
Object *i1,
ReceiveEventArgs *i2
);
JScript .NET protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.ReceiveEventArgs.


Client.raise_SessionStatus(Object,SessionStatusEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_SessionStatus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SessionStatus( _
ByVal i1 As Object, _
ByVal i2 As SessionStatusEventArgs _
)
C# protected void raise_SessionStatus(
object i1,
SessionStatusEventArgs i2
);
Managed C++ protected: void raise_SessionStatus(
Object *i1,
SessionStatusEventArgs *i2
);
JScript .NET protected function raise_SessionStatus(
i1 : Object,
i2 : SessionStatusEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Lobby.SessionStatusEventArgs.


Client.ReleaseApplication(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ReleaseApplication Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Releases a lobbied application and closes the connection between the lobby client and the application. This method should be called whenever a lobby client has finished its session with an application. Deprecated.

Definition

Visual Basic .NET Public Sub ReleaseApplication( _
ByVal connectionHandle As Integer _
)
C# public void ReleaseApplication(
int connectionHandle
);
Managed C++ public: void ReleaseApplication(
int connectionHandle
);
JScript .NET public function ReleaseApplication(
connectionHandle : int
);

Parameters

connectionHandle System.Int32.


Client.Send(Int32,NetworkPacket)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message to a lobbied application that was launched by this lobby client or was connected by this lobby client. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal connectionHandle As Integer, _
ByVal data As NetworkPacket _
)
C# public void Send(
int connectionHandle,
NetworkPacket data
);
Managed C++ public: void Send(
int connectionHandle,
NetworkPacket *data
);
JScript .NET public function Send(
connectionHandle : int,
data : NetworkPacket
);

Parameters

connectionHandle | System.Int32.
data | Microsoft.DirectX.DirectPlay.NetworkPacket.


Client.SetConnectionSettings(Int32,ConnectionSettings)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetConnectionSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method will generate a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.

Definition

Visual Basic .NET Public Sub SetConnectionSettings( _
ByVal lobbyClient As Integer, _
ByVal connectionSettings As ConnectionSettings _
)
C# public void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
Managed C++ public: void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
JScript .NET public function SetConnectionSettings(
lobbyClient : int,
connectionSettings : ConnectionSettings
);

Parameters

lobbyClient | System.Int32.
connectionSettings | Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings.


Client.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Client.Connect

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Connect Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic .NET | Public Event Connect As ConnectEventHandler
C# | public event ConnectEventHandler Connect;
Managed C++ | public: __event ConnectEventHandler Connect;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.ConnectionSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ConnectionSettings Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.

Definition

Visual Basic .NET | Public Event ConnectionSettings As ConnectionSettingsEventHandler
C# | public event ConnectionSettingsEventHandler ConnectionSettings;
Managed C++ | public: __event ConnectionSettingsEventHandler ConnectionSettings;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.Disconnect

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Disconnect Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic .NET | Public Event Disconnect As DisconnectEventHandler
C# | public event DisconnectEventHandler Disconnect;
Managed C++ | public: __event DisconnectEventHandler Disconnect;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Client.Disposing event, use the following code.

client.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Client.Receive

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Receive Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when data has been received. Deprecated.

Definition

Visual Basic .NET | Public Event Receive As ReceiveLobbyEventHandler
C# | public event ReceiveLobbyEventHandler Receive;
Managed C++ | public: __event ReceiveLobbyEventHandler Receive;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.SessionStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SessionStatus Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Definition

Visual Basic .NET | Public Event SessionStatus As SessionStatusEventHandler
C# | public event SessionStatusEventHandler SessionStatus;
Managed C++ | public: __event SessionStatusEventHandler SessionStatus;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.Lobby.ConnectEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ConnectEventArgs
Inherits EventArgs
C# | public sealed class ConnectEventArgs : EventArgs
Managed C++ | public __gc __sealed class ConnectEventArgs : public EventArgs
JScript .NET | public class ConnectEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectEventArgs.ConnectEventArgs(ConnectMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectEventArgs.ConnectEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ConnectMessage _
)
C# public ConnectEventArgs(
ConnectMessage dpMessage
);
Managed C++ public: ConnectEventArgs(
ConnectMessage dpMessage
);
JScript .NET public function ConnectEventArgs(
dpMessage : ConnectMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.ConnectMessage.


ConnectEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ConnectMessage
C# | public ConnectMessage Message;
Managed C++ | public: ConnectMessage Message;
JScript .NET | public var Message : ConnectMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ConnectionSettingsEventArgs
Inherits EventArgs
C# | public sealed class ConnectionSettingsEventArgs : EventArgs
Managed C++ | public __gc __sealed class ConnectionSettingsEventArgs : public EventArgs
JScript .NET | public class ConnectionSettingsEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectionSettingsEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectionSettingsEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectionSettingsEventArgs.ConnectionSettingsEventArgs(ConnectionSettingsMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsEventArgs.ConnectionSettingsEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ConnectionSettingsMessage _
)
C# public ConnectionSettingsEventArgs(
ConnectionSettingsMessage dpMessage
);
Managed C++ public: ConnectionSettingsEventArgs(
ConnectionSettingsMessage dpMessage
);
JScript .NET public function ConnectionSettingsEventArgs(
dpMessage : ConnectionSettingsMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsMessage.


ConnectionSettingsEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ConnectionSettingsMessage
C# | public ConnectionSettingsMessage Message;
Managed C++ | public: ConnectionSettingsMessage Message;
JScript .NET | public var Message : ConnectionSettingsMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Lobby.DisconnectEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class DisconnectEventArgs
Inherits EventArgs
C# | public sealed class DisconnectEventArgs : EventArgs
Managed C++ | public __gc __sealed class DisconnectEventArgs : public EventArgs
JScript .NET | public class DisconnectEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
DisconnectEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
DisconnectEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisconnectEventArgs.DisconnectEventArgs(DisconnectMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectEventArgs.DisconnectEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As DisconnectMessage _
)
C# public DisconnectEventArgs(
DisconnectMessage dpMessage
);
Managed C++ public: DisconnectEventArgs(
DisconnectMessage dpMessage
);
JScript .NET public function DisconnectEventArgs(
dpMessage : DisconnectMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.DisconnectMessage.


DisconnectEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As DisconnectMessage
C# | public DisconnectMessage Message;
Managed C++ | public: DisconnectMessage Message;
JScript .NET | public var Message : DisconnectMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.DisconnectMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Lobby.ReceiveEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ReceiveEventArgs
Inherits EventArgs
C# | public sealed class ReceiveEventArgs : EventArgs
Managed C++ | public __gc __sealed class ReceiveEventArgs : public EventArgs
JScript .NET | public class ReceiveEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ReceiveEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ReceiveEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReceiveEventArgs.ReceiveEventArgs(ReceiveMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveEventArgs.ReceiveEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ReceiveMessage _
)
C# public ReceiveEventArgs(
ReceiveMessage dpMessage
);
Managed C++ public: ReceiveEventArgs(
ReceiveMessage dpMessage
);
JScript .NET public function ReceiveEventArgs(
dpMessage : ReceiveMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.ReceiveMessage.


ReceiveEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ReceiveMessage
C# | public ReceiveMessage Message;
Managed C++ | public: ReceiveMessage Message;
JScript .NET | public var Message : ReceiveMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ReceiveMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Lobby.SessionStatusEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SessionStatusEventArgs
Inherits EventArgs
C# | public sealed class SessionStatusEventArgs : EventArgs
Managed C++ | public __gc __sealed class SessionStatusEventArgs : public EventArgs
JScript .NET | public class SessionStatusEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SessionStatusEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SessionStatusEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionStatusEventArgs.SessionStatusEventArgs(SessionStatusMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusEventArgs.SessionStatusEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As SessionStatusMessage _
)
C# public SessionStatusEventArgs(
SessionStatusMessage dpMessage
);
Managed C++ public: SessionStatusEventArgs(
SessionStatusMessage dpMessage
);
JScript .NET public function SessionStatusEventArgs(
dpMessage : SessionStatusMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.SessionStatusMessage.


SessionStatusEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As SessionStatusMessage
C# | public SessionStatusMessage Message;
Managed C++ | public: SessionStatusMessage Message;
JScript .NET | public var Message : SessionStatusMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.SessionStatusMessage .

This field is read/write.


AvailableFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

AvailableFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The default behavior for this method is to automatically mark the object as Unavailable when the first connection is established. By specifying this flag, the object is not automatically marked unavailable after the first connection is established, thereby allowing multiple connections. Deprecated.

Definition

Visual Basic .NET | Public Enum AvailableFlags
C# | public enum AvailableFlags
Managed C++ | __value public enum AvailableFlags
JScript .NET | public enum AvailableFlags

Members

Member | Value | Description
AllowMultipleConnect | 1 | The default behavior for this method is to automatically mark the object as Unavailable when the first connection is established. By specifying this flag, the object is not automatically marked unavailable after the first connection is established, thereby allowing multiple connections.

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.

Definition

Visual Basic .NET | Public Enum ConnectFlags
C# | public enum ConnectFlags
Managed C++ | __value public enum ConnectFlags
JScript .NET | public enum ConnectFlags

Members

Member | Value | Description
LaunchNotFound | 2
LaunchNew | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectionSettingsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flgas for connection settings. Deprecated.

Definition

Visual Basic .NET | Public Enum ConnectionSettingsFlags
C# | public enum ConnectionSettingsFlags
Managed C++ | __value public enum ConnectionSettingsFlags
JScript .NET | public enum ConnectionSettingsFlags

Members

Member | Value | Description
Host | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Handle

Microsoft DirectX 9.0 SDK Update (October 2004)

Handle Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to represent system handles. Deprecated.

Definition

Visual Basic .NET | Public Enum Handle
C# | public enum Handle
Managed C++ | __value public enum Handle
JScript .NET | public enum Handle

Members

Member | Value | Description
AllConnections | -1 | The message you have specified will be sent to all lobby clients to which you are connected.

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InitializeFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

InitializeFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.

Definition

Visual Basic .NET | Public Enum InitializeFlags
C# | public enum InitializeFlags
Managed C++ | __value public enum InitializeFlags
JScript .NET | public enum InitializeFlags

Members

Member | Value | Description
DisableParameterValidation | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionStatusFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for SessionStatus Deprecated.

Definition

Visual Basic .NET | Public Enum SessionStatusFlags
C# | public enum SessionStatusFlags
Managed C++ | __value public enum SessionStatusFlags
JScript .NET | public enum SessionStatusFlags

Members

Member | Value | Description
HostMigratedHere | 6
HostMigrated | 5
Terminated | 4
Disconnected | 3
CouldNotConnect | 2
Connected | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ApplicationInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used in the pEnumData parameter of the Play8lobbyclientEnumlocalprogramsDplay method to describe the lobbied application. Deprecated.

Definition

Visual Basic .NET | Public Structure ApplicationInformation
C# | public struct ApplicationInformation
Managed C++ | public __value struct ApplicationInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ApplicationInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ApplicationName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WSTR containing the name of the lobbied application. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the lobbied application. Deprecated.
NumberRunning
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of instances of the application. Deprecated.
NumberWaiting
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of clients waiting to connect to the lobbied application. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ApplicationInformation.ApplicationInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation.ApplicationInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ApplicationInformation();
Managed C++ | public: ApplicationInformation();
JScript .NET | public function ApplicationInformation();


ApplicationInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ApplicationInformation.ApplicationName

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation.ApplicationName Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WSTR containing the name of the lobbied application. Deprecated.

Definition

Visual Basic .NET | Public Property ApplicationName As String
C# | public string ApplicationName { get; set; }
Managed C++ public: __property String* get_ApplicationName();
public: __property void set_ApplicationName(String*);
JScript .NET public function get ApplicationName() : String
public function set ApplicationName(String);

Property Value

System.String .

This property is read/write.


ApplicationInformation.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As Integer
C# | public int Flags { get; set; }
Managed C++ public: __property int get_Flags();
public: __property void set_Flags(int);
JScript .NET public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32 .

This property is read/write.


ApplicationInformation.GuidApplication

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation.GuidApplication Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the lobbied application. Deprecated.

Definition

Visual Basic .NET | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
Managed C++ public: __property Guid get_GuidApplication();
public: __property void set_GuidApplication(Guid);
JScript .NET public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid .

This property is read/write.


ApplicationInformation.NumberRunning

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation.NumberRunning Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of instances of the application. Deprecated.

Definition

Visual Basic .NET | Public Property NumberRunning As Integer
C# | public int NumberRunning { get; set; }
Managed C++ public: __property int get_NumberRunning();
public: __property void set_NumberRunning(int);
JScript .NET public function get NumberRunning() : int
public function set NumberRunning(int);

Property Value

System.Int32 .

This property is read/write.


ApplicationInformation.NumberWaiting

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationInformation.NumberWaiting Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of clients waiting to connect to the lobbied application. Deprecated.

Definition

Visual Basic .NET | Public Property NumberWaiting As Integer
C# | public int NumberWaiting { get; set; }
Managed C++ public: __property int get_NumberWaiting();
public: __property void set_NumberWaiting(int);
JScript .NET public function get NumberWaiting() : int
public function set NumberWaiting(int);

Property Value

System.Int32 .

This property is read/write.


ConnectInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify connection information for a lobby client when connecting to the lobby application in the Play8lobbyclientConnectapplicationDplay method. Deprecated.

Definition

Visual Basic .NET | Public Structure ConnectInformation
C# | public struct ConnectInformation
Managed C++ | public __value struct ConnectInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ConnectionSettings
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the connection settings you want to associate with the connection when it is established. Deprecated.

Methods

Method Description
ConnectInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags, which determine connection behavior. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.
LobbyConnectData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to connection data passed to the lobbied application. Deprecated.
UseConnectionSettings
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets or sets a value that specifies whether or not the connection settings should be used. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectInformation.ConnectInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation.ConnectInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectInformation();
Managed C++ | public: ConnectInformation();
JScript .NET | public function ConnectInformation();


ConnectInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConnectInformation.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags, which determine connection behavior. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As ConnectFlags
C# | public ConnectFlags Flags { get; set; }
Managed C++ public: __property ConnectFlags get_Flags();
public: __property void set_Flags(ConnectFlags);
JScript .NET public function get Flags() : ConnectFlags
public function set Flags(ConnectFlags);

Property Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectFlags .

This property is read/write.


ConnectInformation.GuidApplication

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation.GuidApplication Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.

Definition

Visual Basic .NET | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
Managed C++ public: __property Guid get_GuidApplication();
public: __property void set_GuidApplication(Guid);
JScript .NET public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid .

This property is read/write.


ConnectInformation.LobbyConnectData

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation.LobbyConnectData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to connection data passed to the lobbied application. Deprecated.

Definition

Visual Basic .NET | Public Property LobbyConnectData As NetworkPacket
C# | public NetworkPacket LobbyConnectData { get; set; }
Managed C++ public: __property NetworkPacket* get_LobbyConnectData();
public: __property void set_LobbyConnectData(NetworkPacket*);
JScript .NET public function get LobbyConnectData() : NetworkPacket
public function set LobbyConnectData(NetworkPacket);

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read/write.


ConnectInformation.UseConnectionSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation.UseConnectionSettings Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets or sets a value that specifies whether or not the connection settings should be used. Deprecated.

Definition

Visual Basic .NET | Public Property UseConnectionSettings As Boolean
C# | public bool UseConnectionSettings { get; set; }
Managed C++ public: __property bool get_UseConnectionSettings();
public: __property void set_UseConnectionSettings(bool);
JScript .NET public function get UseConnectionSettings() : boolean
public function set UseConnectionSettings(boolean);

Property Value

System.Boolean .

This property is read/write.


ConnectInformation.ConnectionSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectInformation.ConnectionSettings Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the connection settings you want to associate with the connection when it is established. Deprecated.

Definition

Visual Basic .NET | Public ConnectionSettings As ConnectionSettings
C# | public ConnectionSettings ConnectionSettings;
Managed C++ | public: ConnectionSettings ConnectionSettings;
JScript .NET | public var ConnectionSettings : ConnectionSettings

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings .

This field is read/write.


ConnectionSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify the settings you want to associate with a connection. These settings contain all the information required to create, initialize and connect/host a Microsoft® DirectPlay® object. Deprecated.

Definition

Visual Basic .NET | Public Structure ConnectionSettings
C# | public struct ConnectionSettings
Managed C++ | public __value struct ConnectionSettings
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ApplicationDescriptionChanged
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetDeviceAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the array of device addresses. Deprecated.
SetDeviceAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be specified. Deprecated.
HostAddress
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If DPLCONNECTSETTINGS_HOST is not specified, this is the address of the session the client should connect to. Deprecated.
PlayerName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Can be used to pass the player name you want the DirectPlay object to use when launching. This member can be NULL. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectionSettings.ConnectionSettings()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.ConnectionSettings Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectionSettings();
Managed C++ | public: ConnectionSettings();
JScript .NET | public function ConnectionSettings();


ConnectionSettings.GetDeviceAddresses()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.GetDeviceAddresses Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the array of device addresses. Deprecated.

Definition

Visual Basic .NET | Public Function GetDeviceAddresses() As Address()
C# | public Address[] GetDeviceAddresses();
Managed C++ | public: Address* GetDeviceAddresses() __gc[];
JScript .NET | public function GetDeviceAddresses() : Address[];

Return Value

Microsoft.DirectX.DirectPlay.Address[].


ConnectionSettings.SetDeviceAddresses(Address[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.SetDeviceAddresses Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub SetDeviceAddresses( _
ByVal value() As Address _
)
C# public void SetDeviceAddresses(
Address[] value
);
Managed C++ public: void SetDeviceAddresses(
Address *value __gc[]
);
JScript .NET public function SetDeviceAddresses(
value : Address[]
);

Parameters

value Microsoft.DirectX.DirectPlay.Address[].


ConnectionSettings.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConnectionSettings.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be specified. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As ConnectionSettingsFlags
C# | public ConnectionSettingsFlags Flags { get; set; }
Managed C++ public: __property ConnectionSettingsFlags get_Flags();
public: __property void set_Flags(ConnectionSettingsFlags);
JScript .NET public function get Flags() : ConnectionSettingsFlags
public function set Flags(ConnectionSettingsFlags);

Property Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsFlags .

This property is read/write.


ConnectionSettings.HostAddress

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.HostAddress Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If DPLCONNECTSETTINGS_HOST is not specified, this is the address of the session the client should connect to. Deprecated.

Definition

Visual Basic .NET | Public Property HostAddress As Address
C# | public Address HostAddress { get; set; }
Managed C++ public: __property Address* get_HostAddress();
public: __property void set_HostAddress(Address*);
JScript .NET public function get HostAddress() : Address
public function set HostAddress(Address);

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read/write.


ConnectionSettings.PlayerName

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.PlayerName Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Can be used to pass the player name you want the DirectPlay object to use when launching. This member can be NULL. Deprecated.

Definition

Visual Basic .NET | Public Property PlayerName As String
C# | public string PlayerName { get; set; }
Managed C++ public: __property String* get_PlayerName();
public: __property void set_PlayerName(String*);
JScript .NET public function get PlayerName() : String
public function set PlayerName(String);

Property Value

System.String .

This property is read/write.


ConnectionSettings.ApplicationDescriptionChanged

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettings.ApplicationDescriptionChanged Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public ApplicationDescriptionChanged As ApplicationDescription
C# | public ApplicationDescription ApplicationDescriptionChanged;
Managed C++ | public: ApplicationDescription ApplicationDescriptionChanged;
JScript .NET | public var ApplicationDescriptionChanged : ApplicationDescription

Field Value

Microsoft.DirectX.DirectPlay.ApplicationDescription .

This field is read/write.


ConnectionSettingsMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.

Definition

Visual Basic .NET | Public Structure ConnectionSettingsMessage
C# | public struct ConnectionSettingsMessage
Managed C++ | public __value struct ConnectionSettingsMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ConnectionSettings
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains a reference to a DplConnectionSettingsDplay structure describing the connection settings for the specified connection. Deprecated.

Methods

Method Description
ConnectionSettingsMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a context value that has been set for the connection. Deprecated.
Sender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the handle to the connection that sent this message. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectionSettingsMessage.ConnectionSettingsMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsMessage.ConnectionSettingsMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectionSettingsMessage();
Managed C++ | public: ConnectionSettingsMessage();
JScript .NET | public function ConnectionSettingsMessage();


ConnectionSettingsMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConnectionSettingsMessage.ConnectionContext

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsMessage.ConnectionContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a context value that has been set for the connection. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
Managed C++ | public: __property Object* get_ConnectionContext();
JScript .NET | public function get ConnectionContext() : Object

Property Value

System.Object .

This property is read-only.


ConnectionSettingsMessage.Sender

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsMessage.Sender Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the handle to the connection that sent this message. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Sender As Integer
C# | public int Sender { get; }
Managed C++ | public: __property int get_Sender();
JScript .NET | public function get Sender() : int

Property Value

System.Int32 .

This property is read-only.


ConnectionSettingsMessage.ConnectionSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsMessage.ConnectionSettings Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains a reference to a DplConnectionSettingsDplay structure describing the connection settings for the specified connection. Deprecated.

Definition

Visual Basic .NET | Public ConnectionSettings As ConnectionSettings
C# | public ConnectionSettings ConnectionSettings;
Managed C++ | public: ConnectionSettings ConnectionSettings;
JScript .NET | public var ConnectionSettings : ConnectionSettings

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings .

This field is read/write.


ConnectMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.

Definition

Visual Basic .NET | Public Structure ConnectMessage
C# | public struct ConnectMessage
Managed C++ | public __value struct ConnectMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value associated with this connection. For lobbied applications, set this parameter when this message is received in your message handler to associate the context value with the connection. This may be set to NULL to disable context values. Deprecated.
ConnectionHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle used to identify the connection. This handle is used in subsequent calls to Play8lobbyclientSendDplay and Play8lobbyclientReleaseapplicationDplay. Deprecated.
ConnectionSettings
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.
ConnectionSettingsValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.
LobbyConnectData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to lobby connection data. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectMessage.ConnectMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage.ConnectMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectMessage();
Managed C++ | public: ConnectMessage();
JScript .NET | public function ConnectMessage();


ConnectMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConnectMessage.ConnectionContext

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage.ConnectionContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value associated with this connection. For lobbied applications, set this parameter when this message is received in your message handler to associate the context value with the connection. This may be set to NULL to disable context values. Deprecated.

Definition

Visual Basic .NET | Public Property ConnectionContext As Object
C# | public object ConnectionContext { get; set; }
Managed C++ public: __property Object* get_ConnectionContext();
public: __property void set_ConnectionContext(Object*);
JScript .NET public function get ConnectionContext() : Object
public function set ConnectionContext(Object);

Property Value

System.Object .

This property is read/write.


ConnectMessage.ConnectionHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage.ConnectionHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle used to identify the connection. This handle is used in subsequent calls to Play8lobbyclientSendDplay and Play8lobbyclientReleaseapplicationDplay. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionHandle As Integer
C# | public int ConnectionHandle { get; }
Managed C++ | public: __property int get_ConnectionHandle();
JScript .NET | public function get ConnectionHandle() : int

Property Value

System.Int32 .

This property is read-only.


ConnectMessage.ConnectionSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage.ConnectionSettings Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionSettings As ConnectionSettings
C# | public ConnectionSettings ConnectionSettings { get; }
Managed C++ | public: __property ConnectionSettings get_ConnectionSettings();
JScript .NET | public function get ConnectionSettings() : ConnectionSettings

Property Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings .

This property is read-only.


ConnectMessage.ConnectionSettingsValid

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage.ConnectionSettingsValid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionSettingsValid As Boolean
C# | public bool ConnectionSettingsValid { get; }
Managed C++ | public: __property bool get_ConnectionSettingsValid();
JScript .NET | public function get ConnectionSettingsValid() : boolean

Property Value

System.Boolean .

This property is read-only.


ConnectMessage.LobbyConnectData

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectMessage.LobbyConnectData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to lobby connection data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property LobbyConnectData As NetworkPacket
C# | public NetworkPacket LobbyConnectData { get; }
Managed C++ | public: __property NetworkPacket* get_LobbyConnectData();
JScript .NET | public function get LobbyConnectData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read-only.


DisconnectMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure DisconnectMessage
C# | public struct DisconnectMessage
Managed C++ | public __value struct DisconnectMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DisconnectMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.
DisconnectId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle specifying the disconnection identifier. Deprecated.
Reason
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reason for the disconnection. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisconnectMessage.DisconnectMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectMessage.DisconnectMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DisconnectMessage();
Managed C++ | public: DisconnectMessage();
JScript .NET | public function DisconnectMessage();


DisconnectMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DisconnectMessage.ConnectionContext

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectMessage.ConnectionContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
Managed C++ | public: __property Object* get_ConnectionContext();
JScript .NET | public function get ConnectionContext() : Object

Property Value

System.Object .

This property is read-only.


DisconnectMessage.DisconnectId

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectMessage.DisconnectId Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle specifying the disconnection identifier. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property DisconnectId As Integer
C# | public int DisconnectId { get; }
Managed C++ | public: __property int get_DisconnectId();
JScript .NET | public function get DisconnectId() : int

Property Value

System.Int32 .

This property is read-only.


DisconnectMessage.Reason

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectMessage.Reason Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reason for the disconnection. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Reason As ResultCode
C# | public ResultCode Reason { get; }
Managed C++ | public: __property ResultCode get_Reason();
JScript .NET | public function get Reason() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode .

This property is read-only.


ProgramDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a Microsoft® DirectPlay® lobby-aware application. Deprecated.

Definition

Visual Basic .NET | Public Structure ProgramDescription
C# | public struct ProgramDescription
Managed C++ | public __value struct ProgramDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ProgramDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ApplicationName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application name. Deprecated.
CommandLine
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the command-line arguments. Deprecated.
CurrentDirectory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the directory that should be set as the application's working directory.. Deprecated.
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application description. Deprecated.
ExecutableFilename
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the application executable. Deprecated.
ExecutablePath
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the application executable. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.
LauncherFilename
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the launcher executable. Deprecated.
LauncherPath
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the launcher executable. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ProgramDescription.ProgramDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.ProgramDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ProgramDescription();
Managed C++ | public: ProgramDescription();
JScript .NET | public function ProgramDescription();


ProgramDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ProgramDescription.ApplicationName

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.ApplicationName Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application name. Deprecated.

Definition

Visual Basic .NET | Public Property ApplicationName As String
C# | public string ApplicationName { get; set; }
Managed C++ public: __property String* get_ApplicationName();
public: __property void set_ApplicationName(String*);
JScript .NET public function get ApplicationName() : String
public function set ApplicationName(String);

Property Value

System.String .

This property is read/write.


ProgramDescription.CommandLine

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.CommandLine Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the command-line arguments. Deprecated.

Definition

Visual Basic .NET | Public Property CommandLine As String
C# | public string CommandLine { get; set; }
Managed C++ public: __property String* get_CommandLine();
public: __property void set_CommandLine(String*);
JScript .NET public function get CommandLine() : String
public function set CommandLine(String);

Property Value

System.String .

This property is read/write.


ProgramDescription.CurrentDirectory

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.CurrentDirectory Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the directory that should be set as the application's working directory.. Deprecated.

Definition

Visual Basic .NET | Public Property CurrentDirectory As String
C# | public string CurrentDirectory { get; set; }
Managed C++ public: __property String* get_CurrentDirectory();
public: __property void set_CurrentDirectory(String*);
JScript .NET public function get CurrentDirectory() : String
public function set CurrentDirectory(String);

Property Value

System.String .

This property is read/write.


ProgramDescription.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application description. Deprecated.

Definition

Visual Basic .NET | Public Property Description As String
C# | public string Description { get; set; }
Managed C++ public: __property String* get_Description();
public: __property void set_Description(String*);
JScript .NET public function get Description() : String
public function set Description(String);

Property Value

System.String .

This property is read/write.


ProgramDescription.ExecutableFilename

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.ExecutableFilename Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the application executable. Deprecated.

Definition

Visual Basic .NET | Public Property ExecutableFilename As String
C# | public string ExecutableFilename { get; set; }
Managed C++ public: __property String* get_ExecutableFilename();
public: __property void set_ExecutableFilename(String*);
JScript .NET public function get ExecutableFilename() : String
public function set ExecutableFilename(String);

Property Value

System.String .

This property is read/write.


ProgramDescription.ExecutablePath

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.ExecutablePath Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the application executable. Deprecated.

Definition

Visual Basic .NET | Public Property ExecutablePath As String
C# | public string ExecutablePath { get; set; }
Managed C++ public: __property String* get_ExecutablePath();
public: __property void set_ExecutablePath(String*);
JScript .NET public function get ExecutablePath() : String
public function set ExecutablePath(String);

Property Value

System.String .

This property is read/write.


ProgramDescription.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As Integer
C# | public int Flags { get; set; }
Managed C++ public: __property int get_Flags();
public: __property void set_Flags(int);
JScript .NET public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32 .

This property is read/write.


ProgramDescription.GuidApplication

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.GuidApplication Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.

Definition

Visual Basic .NET | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
Managed C++ public: __property Guid get_GuidApplication();
public: __property void set_GuidApplication(Guid);
JScript .NET public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid .

This property is read/write.


ProgramDescription.LauncherFilename

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.LauncherFilename Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the launcher executable. Deprecated.

Definition

Visual Basic .NET | Public Property LauncherFilename As String
C# | public string LauncherFilename { get; set; }
Managed C++ public: __property String* get_LauncherFilename();
public: __property void set_LauncherFilename(String*);
JScript .NET public function get LauncherFilename() : String
public function set LauncherFilename(String);

Property Value

System.String .

This property is read/write.


ProgramDescription.LauncherPath

Microsoft DirectX 9.0 SDK Update (October 2004)

ProgramDescription.LauncherPath Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the launcher executable. Deprecated.

Definition

Visual Basic .NET | Public Property LauncherPath As String
C# | public string LauncherPath { get; set; }
Managed C++ public: __property String* get_LauncherPath();
public: __property void set_LauncherPath(String*);
JScript .NET public function get LauncherPath() : String
public function set LauncherPath(String);

Property Value

System.String .

This property is read/write.


ReceiveMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic .NET | Public Structure ReceiveMessage
C# | public struct ReceiveMessage
Managed C++ | public __value struct ReceiveMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ReceiveMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.
ReceiveData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the message data buffer. This buffer is normally only valid while the DpnMsgidReceiveDplay message is being processed by the callback message handler. Deprecated.
Sender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReceiveMessage.ReceiveMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.ReceiveMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ReceiveMessage();
Managed C++ | public: ReceiveMessage();
JScript .NET | public function ReceiveMessage();


ReceiveMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ReceiveMessage.ConnectionContext

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.ConnectionContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
Managed C++ | public: __property Object* get_ConnectionContext();
JScript .NET | public function get ConnectionContext() : Object

Property Value

System.Object .

This property is read-only.


ReceiveMessage.ReceiveData

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.ReceiveData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the message data buffer. This buffer is normally only valid while the DpnMsgidReceiveDplay message is being processed by the callback message handler. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ReceiveData As NetworkPacket
C# | public NetworkPacket ReceiveData { get; }
Managed C++ | public: __property NetworkPacket* get_ReceiveData();
JScript .NET | public function get ReceiveData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read-only.


ReceiveMessage.Sender

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.Sender Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Sender As Integer
C# | public int Sender { get; }
Managed C++ | public: __property int get_Sender();
JScript .NET | public function get Sender() : int

Property Value

System.Int32 .

This property is read-only.


SessionStatusMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure SessionStatusMessage
C# | public struct SessionStatusMessage
Managed C++ | public __value struct SessionStatusMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SessionStatusMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.
Sender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle of the application that sent the status update message. Deprecated.
Status
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updated status of the session. This member can be set to one of the following values. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionStatusMessage.SessionStatusMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusMessage.SessionStatusMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SessionStatusMessage();
Managed C++ | public: SessionStatusMessage();
JScript .NET | public function SessionStatusMessage();


SessionStatusMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SessionStatusMessage.ConnectionContext

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusMessage.ConnectionContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
Managed C++ | public: __property Object* get_ConnectionContext();
JScript .NET | public function get ConnectionContext() : Object

Property Value

System.Object .

This property is read-only.


SessionStatusMessage.Sender

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusMessage.Sender Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle of the application that sent the status update message. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Sender As Integer
C# | public int Sender { get; }
Managed C++ | public: __property int get_Sender();
JScript .NET | public function get Sender() : int

Property Value

System.Int32 .

This property is read-only.


SessionStatusMessage.Status

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusMessage.Status Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updated status of the session. This member can be set to one of the following values. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Status As SessionStatusFlags
C# | public SessionStatusFlags Status { get; }
Managed C++ | public: __property SessionStatusFlags get_Status();
JScript .NET | public function get Status() : SessionStatusFlags

Property Value

Microsoft.DirectX.DirectPlay.Lobby.SessionStatusFlags .

This property is read-only.


ConnectEventHandler(Object,ConnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Connect event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ConnectEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectEventArgs _
)
C# public sealed delegate void ConnectEventHandler(
object sender,
ConnectEventArgs e
);
Managed C++ public: __gc __delegate void ConnectEventHandler(
Object *sender,
ConnectEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Lobby.ConnectEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectionSettingsEventHandler(Object,ConnectionSettingsEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionSettingsEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ConnectionSettingsEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectionSettingsEventArgs _
)
C# public sealed delegate void ConnectionSettingsEventHandler(
object sender,
ConnectionSettingsEventArgs e
);
Managed C++ public: __gc __delegate void ConnectionSettingsEventHandler(
Object *sender,
ConnectionSettingsEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisconnectEventHandler(Object,DisconnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub DisconnectEventHandler( _
ByVal sender As Object, _
ByVal e As DisconnectEventArgs _
)
C# public sealed delegate void DisconnectEventHandler(
object sender,
DisconnectEventArgs e
);
Managed C++ public: __gc __delegate void DisconnectEventHandler(
Object *sender,
DisconnectEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Lobby.DisconnectEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReceiveLobbyEventHandler(Object,ReceiveEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveLobbyEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ReceiveLobbyEventHandler( _
ByVal sender As Object, _
ByVal e As ReceiveEventArgs _
)
C# public sealed delegate void ReceiveLobbyEventHandler(
object sender,
ReceiveEventArgs e
);
Managed C++ public: __gc __delegate void ReceiveLobbyEventHandler(
Object *sender,
ReceiveEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Lobby.ReceiveEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionStatusEventHandler(Object,SessionStatusEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionStatusEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionStatus event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub SessionStatusEventHandler( _
ByVal sender As Object, _
ByVal e As SessionStatusEventArgs _
)
C# public sealed delegate void SessionStatusEventHandler(
object sender,
SessionStatusEventArgs e
);
Managed C++ public: __gc __delegate void SessionStatusEventHandler(
Object *sender,
SessionStatusEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Lobby.SessionStatusEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.Voice

Note: This documentation is preliminary and is subject to change.

Warning: Microsoft® DirectPlay® Voice has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Voice provides media-independent network transport and client management, but it does not duplicate DirectPlay session control features. The following tables list the members exposed by the Microsoft.DirectX.DirectPlay.Voice namespace.

Classes

AlreadyBufferedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data was already buffered. Deprecated.
AlreadyPendingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is already pending. Deprecated.
Client
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Client object to manage clients in a voice session. Deprecated.
CompressionGuid
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various compression codecs that can be used. Deprecated.
CompressionNotSupportedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified compression type is not supported on the local computer. Deprecated.
ConnectAbortedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connect operation was canceled before it could be completed. Deprecated.
ConnectAbortingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection is being disconnected. Deprecated.
ConnectedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is connected. Deprecated.
ConnectionLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection to the voice session has been lost. Deprecated.
ConnectResultEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.
DisconnectResultEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
HostingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is the host of the session. Deprecated.
HostMigratedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
IncompatibleVersionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client connected to a voice session that is incompatible with the host. Deprecated.
InputLevelEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.
InvalidBufferException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A buffer specified as a parameter is invalid. Deprecated.
InvalidDeviceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified device is invalid. Deprecated.
InvalidFlagsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.
InvalidGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group ID is not recognized as a valid group ID for this game session. Deprecated.
InvalidHandleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.
InvalidObjectException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay object is invalid. Deprecated.
InvalidPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.
InvalidTargetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified target is not a valid player ID or group ID for this voice session. Deprecated.
LockedBufferException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer is already locked. Deprecated.
No3DSoundException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support 3-D sound. Deprecated.
NoRecordVolumeAvailableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support record volume. Deprecated.
NotAllowedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object does not have the permission to perform this operation. Deprecated.
NotBufferedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no user buffer for the specified ID. Deprecated.
NotConnectedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is not connected. Deprecated.
NotHostingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the session. Deprecated.
NoTransportException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified object is not a valid transport. Deprecated.
NotSupportedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.
NoVoiceSessionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session specified is not a voice session. Deprecated.
OutputLevelEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.
PlaybackSystemErrorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the playback system occurred. Deprecated.
PlayerOutputLevelEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.
PlayerStartedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStarted event. Deprecated.
PlayerStoppedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStopped event. Deprecated.
RecordStartedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStarted event. Deprecated.
RecordStoppedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStopped event. Deprecated.
RecordSystemErrorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the recording system occurred. Deprecated.
RunSetupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified audio configuration has not been tested. Call the Test.CheckAudioSetup method. Deprecated.
SendErrorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error occurred while sending data. Deprecated.
Server
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to manage the host of the voice session. Deprecated.
SessionLostEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.
SessionLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The transport has lost the connection to the session. Deprecated.
SetTargetsEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SetTargets event. Deprecated.
SoundInitializeFailureException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A failure was encountered initializing the sound card. Deprecated.
Test
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the Test.CheckAudioSetup method of the Test object to test the Microsoft® DirectPlay® Voice audio configuration. Deprecated.
TimedOutException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.
TransportNoPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is connected/hosting but no local player exists. Deprecated.
TransportNoSessionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is valid but is not connected/hosting. Deprecated.
TransportNotHostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the voice session. Deprecated.
UserBackException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user has pressed back on the first page of the CheckAudioSetup wizard. Deprecated.
UserCancelException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.
VoiceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for DirectPlay Voice exceptions. Derives from DirectXException. Deprecated.
VoicePlayerCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.
VoicePlayerDeletedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDeleted event. Deprecated.

Enumerations

BufferAggressiveness
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferAggressiveness. Deprecated.
BufferQuality
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferQuality. Deprecated.
ClientConfigFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for client configuration. Deprecated.
InputLevelFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for input level. Deprecated.
NotifyPeriod
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for NotifyPeriod. Deprecated.
PlaybackVolume
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for PlaybackVolume. Deprecated.
PlayerCapsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player capability flags. Deprecated.
PlayerId
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
System wide player id's. Deprecated.
RecordVolume
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for RecordVolume. Deprecated.
ResultCode
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various codes that can be returned by events. Deprecated.
SessionFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for controlling sessions. Deprecated.
SessionType
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of DirectPlay Voice session to run. Deprecated.
SoundConfigFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags to control how the sound device is configured. Deprecated.
StopSessionFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for stopping a session. Deprecated.
TestFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the user can press the Back button and whether the setup should be queried. Deprecated.
Threshold
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for Threshold. Deprecated.
VoiceFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various flags for DirectPlay Voice. Deprecated.

Structures

ClientConfig
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the run-time parameters for the client. Deprecated.
CompressionInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the attributes of a specific Microsoft® DirectPlay® Voice compression type. Deprecated.
ConnectResultMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.
CreateVoicePlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidCreatevoiceplayerDplay message when a new player joins the voice session.The structure contains information for the DvmsgidCreatevoiceplayerDplay message. Deprecated.
DeleteVoicePlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
For clients, Microsoft® DirectPlay® Voice generates the DvmsgidDeletevoiceplayerDplay message when a player quits the voice session. This message is available only to clients in peer-to-peer voice sessions.For the host, Microsoft® DirectPlay® Voice generates the message when a player quits the voice session.The structure contains information for the DvmsgidDeletevoiceplayerDplay system message. Deprecated.
DisconnectResultMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
HostMigratedMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
InputLevelMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.
OutputLevelMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.
PlayerOutputLevelMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.
PlayerVoiceStartMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestartDplay message when an incoming audio stream begins playing back.The structure contains information for the DvmsgidPlayervoicestartDplay system message. Deprecated.
PlayerVoiceStopMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestopDplay message when an incoming audio stream stops.The DvmsgidPlayervoicestopDplay structure contains information for the DvmsgidPlayervoicestopDplay system message. Deprecated.
RecordStartMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstartDplay message when audio input on the local client begins.The structure contains information for the DvmsgidRecordstartDplay system message. Deprecated.
RecordStopMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstopDplay message when audio input on the local client stops.The structure contains information for the DvmsgidRecordstopDplay system message. Deprecated.
SessionDescription
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the desired or current session settings for the Microsoft® DirectPlay® Voice server. This structure is used by the voice session host to configure the session, and by the session host and clients to retrieve information about the current session. Deprecated.
SessionLostMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.
SetTargetsMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
PdvmessagehandlerDplay is an application-defined callback function used by the PlayvoiceclientDplay and PlayvoiceserverDplay objects to send messages to the user. Deprecated.
SoundDeviceConfig
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve information about the sound device configuration and cannot be changed once a connection has been made. After a connection is made, you can retrieve the current sound device configuration by calling PlayvoiceclientGetsounddeviceconfigDplay. Deprecated.

Delegates

ConnectResultEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ConnectResult event. Deprecated.
DisconnectResultEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
InputLevelEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the InputLevel event. Deprecated.
OutputLevelEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the OutputLevel event. Deprecated.
PlayerOutputLevelEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.
PlayerStartedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStarted event. Deprecated.
PlayerStoppedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStopped event. Deprecated.
RecordStartedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStarted event. Deprecated.
RecordStoppedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStopped event. Deprecated.
SessionLostEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionLost event. Deprecated.
SetTargetsEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SetTargets event. Deprecated.
VoiceHostMigratedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.
VoicePlayerCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.
VoicePlayerDeletedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDeleted event. Deprecated.


Microsoft.DirectX.DirectPlay.Voice.AlreadyBufferedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyBufferedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data was already buffered. Deprecated.

Definition

Visual Basic .NET Public Class AlreadyBufferedException
Inherits VoiceException
C# | public class AlreadyBufferedException : VoiceException
Managed C++ | public __gc class AlreadyBufferedException : public VoiceException
JScript .NET | public class AlreadyBufferedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyBufferedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
AlreadyBufferedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AlreadyBufferedException.AlreadyBufferedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyBufferedException();
protected AlreadyBufferedException(SerializationInfo, StreamingContext);
public AlreadyBufferedException(string);
public AlreadyBufferedException(string, Exception);


AlreadyBufferedException.AlreadyBufferedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyBufferedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AlreadyBufferedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AlreadyBufferedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AlreadyBufferedException.AlreadyBufferedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyBufferedException(
string message,
Exception inner
);
Managed C++ public: AlreadyBufferedException(
String *message,
Exception *inner
);
JScript .NET public function AlreadyBufferedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AlreadyBufferedException.AlreadyBufferedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AlreadyBufferedException(
string message
);
Managed C++ public: AlreadyBufferedException(
String *message
);
JScript .NET public function AlreadyBufferedException(
message : String
);

Parameters

message System.String.


AlreadyBufferedException.AlreadyBufferedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AlreadyBufferedException();
Managed C++ | public: AlreadyBufferedException();
JScript .NET | public function AlreadyBufferedException();


Microsoft.DirectX.DirectPlay.Voice.AlreadyPendingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyPendingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is already pending. Deprecated.

Definition

Visual Basic .NET Public Class AlreadyPendingException
Inherits VoiceException
C# | public class AlreadyPendingException : VoiceException
Managed C++ | public __gc class AlreadyPendingException : public VoiceException
JScript .NET | public class AlreadyPendingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyPendingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
AlreadyPendingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AlreadyPendingException.AlreadyPendingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyPendingException.AlreadyPendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyPendingException();
protected AlreadyPendingException(SerializationInfo, StreamingContext);
public AlreadyPendingException(string);
public AlreadyPendingException(string, Exception);


AlreadyPendingException.AlreadyPendingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyPendingException.AlreadyPendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyPendingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AlreadyPendingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AlreadyPendingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AlreadyPendingException.AlreadyPendingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyPendingException.AlreadyPendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyPendingException(
string message,
Exception inner
);
Managed C++ public: AlreadyPendingException(
String *message,
Exception *inner
);
JScript .NET public function AlreadyPendingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AlreadyPendingException.AlreadyPendingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyPendingException.AlreadyPendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AlreadyPendingException(
string message
);
Managed C++ public: AlreadyPendingException(
String *message
);
JScript .NET public function AlreadyPendingException(
message : String
);

Parameters

message System.String.


AlreadyPendingException.AlreadyPendingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyPendingException.AlreadyPendingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AlreadyPendingException();
Managed C++ | public: AlreadyPendingException();
JScript .NET | public function AlreadyPendingException();


Microsoft.DirectX.DirectPlay.Voice.Client

Microsoft DirectX 9.0 SDK Update (October 2004)

Client Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Client object to manage clients in a voice session. Deprecated.

Definition

Visual Basic .NET Public Class Client
Inherits MarshalByRefObject
Implements IDisposable
C# public class Client : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Client : public MarshalByRefObject,
IDisposable
JScript .NET public class Client extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ConnectResult
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.
DisconnectResult
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has been completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
GainFocus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application gains focus. Deprecated.
HostMigrated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has migrated. Deprecated.
InputLevel
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the input level has changed. Deprecated.
LostFocus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application has lost focus. Deprecated.
OutputLevel
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the output level changes. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDeleted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
PlayerOutputLevel
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a players output level has changed. Deprecated.
PlayerStarted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player starts talking. Deprecated.
PlayerStopped
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has stopped talking. Deprecated.
RecordStarted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has started talking. Deprecated.
RecordStopped
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has stopped talking. Deprecated.
SessionLost
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been lost. Deprecated.
SetTargets
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Methods

Method Description
Client
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.
Create3DSoundBuffer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.
Delete3DSoundBuffer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns exclusive control of the 3-D sound buffer object to the Microsoft® DirectPlay® voice client object. Deprecated.
Disconnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_ConnectResult
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_DisconnectResult
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GainFocus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_HostMigrated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_InputLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_LostFocus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_OutputLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDeleted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerOutputLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerStarted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerStopped
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_RecordStarted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_RecordStopped
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionLost
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SetTargets
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ClientConfig
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the client configuration. Deprecated.
CompressionTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the available compression types on the system. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
SessionDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the session properties. Deprecated.
SoundDeviceConfig
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the sound device configuration of the session. Deprecated.
TransmitTargets
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the transmit targets, if any, of the voice stream from this client. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Client

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Client.Client

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Client Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Client(object);
public Client(object, int[]);


Client.Client(Object,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Client Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dplayObject As Object, _
ByVal msgMask() As Integer _
)
C# public Client(
object dplayObject,
int[] msgMask
);
Managed C++ public: Client(
Object *dplayObject,
int msgMask __gc[]
);
JScript .NET public function Client(
dplayObject : Object,
msgMask : int[]
);

Parameters

dplayObject | System.Object.
msgMask | System.Int32[].


Client.Client(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Client Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dplayObject As Object _
)
C# public Client(
object dplayObject
);
Managed C++ public: Client(
Object *dplayObject
);
JScript .NET public function Client(
dplayObject : Object
);

Parameters

dplayObject System.Object.


Client.Connect(SoundDeviceConfig,ClientConfig,VoiceFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal soundConfig As SoundDeviceConfig, _
ByVal clientConfig As ClientConfig, _
ByVal flags As VoiceFlags _
)
C# public void Connect(
SoundDeviceConfig soundConfig,
ClientConfig clientConfig,
VoiceFlags flags
);
Managed C++ public: void Connect(
SoundDeviceConfig soundConfig,
ClientConfig clientConfig,
VoiceFlags flags
);
JScript .NET public function Connect(
soundConfig : SoundDeviceConfig,
clientConfig : ClientConfig,
flags : VoiceFlags
);

Parameters

soundConfig | Microsoft.DirectX.DirectPlay.Voice.SoundDeviceConfig.
clientConfig | Microsoft.DirectX.DirectPlay.Voice.ClientConfig.
flags | Microsoft.DirectX.DirectPlay.Voice.VoiceFlags.


Client.Create3DSoundBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Create3DSoundBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.

Overload List

public Buffer3D Create3DSoundBuffer(int);
public Buffer3D Create3DSoundBuffer(int, Buffer, int, int);


Client.Create3DSoundBuffer(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Create3DSoundBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.

Definition

Visual Basic .NET Public Function Create3DSoundBuffer( _
ByVal sourcePlayerID As Integer _
) As Buffer3D
C# public Buffer3D Create3DSoundBuffer(
int sourcePlayerID
);
Managed C++ public: Buffer3D* Create3DSoundBuffer(
int sourcePlayerID
);
JScript .NET public function Create3DSoundBuffer(
sourcePlayerID : int
) : Buffer3D;

Parameters

sourcePlayerID System.Int32.

Return Value

Microsoft.DirectX.DirectSound.Buffer3D .


Client.Create3DSoundBuffer(Int32,Buffer,Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Create3DSoundBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.

Definition

Visual Basic .NET Public Function Create3DSoundBuffer( _
ByVal sourcePlayerID As Integer, _
ByVal sourceBuffer As Buffer, _
ByVal priority As Integer, _
ByVal flags As Integer _
) As Buffer3D
C# public Buffer3D Create3DSoundBuffer(
int sourcePlayerID,
Buffer sourceBuffer,
int priority,
int flags
);
Managed C++ public: Buffer3D* Create3DSoundBuffer(
int sourcePlayerID,
Buffer *sourceBuffer,
int priority,
int flags
);
JScript .NET public function Create3DSoundBuffer(
sourcePlayerID : int,
sourceBuffer : Buffer,
priority : int,
flags : int
) : Buffer3D;

Parameters

sourcePlayerID | System.Int32.
sourceBuffer | Microsoft.DirectX.DirectSound.Buffer.
priority | System.Int32.
flags | System.Int32.

Return Value

Microsoft.DirectX.DirectSound.Buffer3D .


Client.Delete3DSoundBuffer(Int32,Buffer3D)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Delete3DSoundBuffer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns exclusive control of the 3-D sound buffer object to the Microsoft® DirectPlay® voice client object. Deprecated.

Definition

Visual Basic .NET Public Sub Delete3DSoundBuffer( _
ByVal sourcePlayerID As Integer, _
ByVal userBuffer As Buffer3D _
)
C# public void Delete3DSoundBuffer(
int sourcePlayerID,
Buffer3D userBuffer
);
Managed C++ public: void Delete3DSoundBuffer(
int sourcePlayerID,
Buffer3D *userBuffer
);
JScript .NET public function Delete3DSoundBuffer(
sourcePlayerID : int,
userBuffer : Buffer3D
);

Parameters

sourcePlayerID | System.Int32.
userBuffer | Microsoft.DirectX.DirectSound.Buffer3D.


Client.Disconnect(VoiceFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Disconnect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic .NET Public Sub Disconnect( _
ByVal flags As VoiceFlags _
)
C# public void Disconnect(
VoiceFlags flags
);
Managed C++ public: void Disconnect(
VoiceFlags flags
);
JScript .NET public function Disconnect(
flags : VoiceFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Voice.VoiceFlags.


Client.op_Equality(Client,Client)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Equality(
Client left,
Client right
);
Managed C++ public: static bool op_Equality(
Client *left,
Client *right
);
JScript .NET public static function op_Equality(
left : Client,
right : Client
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Voice.Client. The Client structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Voice.Client. The Client structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Client.op_Inequality(Client,Client)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Inequality(
Client left,
Client right
);
Managed C++ public: static bool op_Inequality(
Client *left,
Client *right
);
JScript .NET public static function op_Inequality(
left : Client,
right : Client
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Voice.Client. The Client structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Voice.Client. The Client structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Client.raise_ConnectResult(Object,ConnectResultEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_ConnectResult Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ConnectResult( _
ByVal i1 As Object, _
ByVal i2 As ConnectResultEventArgs _
)
C# protected void raise_ConnectResult(
object i1,
ConnectResultEventArgs i2
);
Managed C++ protected: void raise_ConnectResult(
Object *i1,
ConnectResultEventArgs *i2
);
JScript .NET protected function raise_ConnectResult(
i1 : Object,
i2 : ConnectResultEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.ConnectResultEventArgs.


Client.raise_DisconnectResult(Object,DisconnectResultEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_DisconnectResult Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_DisconnectResult( _
ByVal i1 As Object, _
ByVal i2 As DisconnectResultEventArgs _
)
C# protected void raise_DisconnectResult(
object i1,
DisconnectResultEventArgs i2
);
Managed C++ protected: void raise_DisconnectResult(
Object *i1,
DisconnectResultEventArgs *i2
);
JScript .NET protected function raise_DisconnectResult(
i1 : Object,
i2 : DisconnectResultEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.DisconnectResultEventArgs.


Client.raise_GainFocus(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_GainFocus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_GainFocus( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_GainFocus(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_GainFocus(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_GainFocus(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Client.raise_HostMigrated(Object,HostMigratedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_HostMigrated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_HostMigrated( _
ByVal i1 As Object, _
ByVal i2 As HostMigratedEventArgs _
)
C# protected void raise_HostMigrated(
object i1,
HostMigratedEventArgs i2
);
Managed C++ protected: void raise_HostMigrated(
Object *i1,
HostMigratedEventArgs *i2
);
JScript .NET protected function raise_HostMigrated(
i1 : Object,
i2 : HostMigratedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.HostMigratedEventArgs.


Client.raise_InputLevel(Object,InputLevelEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_InputLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_InputLevel( _
ByVal i1 As Object, _
ByVal i2 As InputLevelEventArgs _
)
C# protected void raise_InputLevel(
object i1,
InputLevelEventArgs i2
);
Managed C++ protected: void raise_InputLevel(
Object *i1,
InputLevelEventArgs *i2
);
JScript .NET protected function raise_InputLevel(
i1 : Object,
i2 : InputLevelEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.InputLevelEventArgs.


Client.raise_LostFocus(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_LostFocus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_LostFocus( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_LostFocus(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_LostFocus(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_LostFocus(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Client.raise_OutputLevel(Object,OutputLevelEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_OutputLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_OutputLevel( _
ByVal i1 As Object, _
ByVal i2 As OutputLevelEventArgs _
)
C# protected void raise_OutputLevel(
object i1,
OutputLevelEventArgs i2
);
Managed C++ protected: void raise_OutputLevel(
Object *i1,
OutputLevelEventArgs *i2
);
JScript .NET protected function raise_OutputLevel(
i1 : Object,
i2 : OutputLevelEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.OutputLevelEventArgs.


Client.raise_PlayerCreated(Object,VoicePlayerCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_PlayerCreated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
VoicePlayerCreatedEventArgs i2
);
Managed C++ protected: void raise_PlayerCreated(
Object *i1,
VoicePlayerCreatedEventArgs *i2
);
JScript .NET protected function raise_PlayerCreated(
i1 : Object,
i2 : VoicePlayerCreatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.VoicePlayerCreatedEventArgs.


Client.raise_PlayerDeleted(Object,VoicePlayerDeletedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_PlayerDeleted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerDeleted( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerDeletedEventArgs _
)
C# protected void raise_PlayerDeleted(
object i1,
VoicePlayerDeletedEventArgs i2
);
Managed C++ protected: void raise_PlayerDeleted(
Object *i1,
VoicePlayerDeletedEventArgs *i2
);
JScript .NET protected function raise_PlayerDeleted(
i1 : Object,
i2 : VoicePlayerDeletedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.VoicePlayerDeletedEventArgs.


Client.raise_PlayerOutputLevel(Object,PlayerOutputLevelEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_PlayerOutputLevel Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerOutputLevel( _
ByVal i1 As Object, _
ByVal i2 As PlayerOutputLevelEventArgs _
)
C# protected void raise_PlayerOutputLevel(
object i1,
PlayerOutputLevelEventArgs i2
);
Managed C++ protected: void raise_PlayerOutputLevel(
Object *i1,
PlayerOutputLevelEventArgs *i2
);
JScript .NET protected function raise_PlayerOutputLevel(
i1 : Object,
i2 : PlayerOutputLevelEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelEventArgs.


Client.raise_PlayerStarted(Object,PlayerStartedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_PlayerStarted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerStarted( _
ByVal i1 As Object, _
ByVal i2 As PlayerStartedEventArgs _
)
C# protected void raise_PlayerStarted(
object i1,
PlayerStartedEventArgs i2
);
Managed C++ protected: void raise_PlayerStarted(
Object *i1,
PlayerStartedEventArgs *i2
);
JScript .NET protected function raise_PlayerStarted(
i1 : Object,
i2 : PlayerStartedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.PlayerStartedEventArgs.


Client.raise_PlayerStopped(Object,PlayerStoppedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_PlayerStopped Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerStopped( _
ByVal i1 As Object, _
ByVal i2 As PlayerStoppedEventArgs _
)
C# protected void raise_PlayerStopped(
object i1,
PlayerStoppedEventArgs i2
);
Managed C++ protected: void raise_PlayerStopped(
Object *i1,
PlayerStoppedEventArgs *i2
);
JScript .NET protected function raise_PlayerStopped(
i1 : Object,
i2 : PlayerStoppedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.PlayerStoppedEventArgs.


Client.raise_RecordStarted(Object,RecordStartedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_RecordStarted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_RecordStarted( _
ByVal i1 As Object, _
ByVal i2 As RecordStartedEventArgs _
)
C# protected void raise_RecordStarted(
object i1,
RecordStartedEventArgs i2
);
Managed C++ protected: void raise_RecordStarted(
Object *i1,
RecordStartedEventArgs *i2
);
JScript .NET protected function raise_RecordStarted(
i1 : Object,
i2 : RecordStartedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.RecordStartedEventArgs.


Client.raise_RecordStopped(Object,RecordStoppedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_RecordStopped Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_RecordStopped( _
ByVal i1 As Object, _
ByVal i2 As RecordStoppedEventArgs _
)
C# protected void raise_RecordStopped(
object i1,
RecordStoppedEventArgs i2
);
Managed C++ protected: void raise_RecordStopped(
Object *i1,
RecordStoppedEventArgs *i2
);
JScript .NET protected function raise_RecordStopped(
i1 : Object,
i2 : RecordStoppedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.RecordStoppedEventArgs.


Client.raise_SessionLost(Object,SessionLostEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_SessionLost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SessionLost( _
ByVal i1 As Object, _
ByVal i2 As SessionLostEventArgs _
)
C# protected void raise_SessionLost(
object i1,
SessionLostEventArgs i2
);
Managed C++ protected: void raise_SessionLost(
Object *i1,
SessionLostEventArgs *i2
);
JScript .NET protected function raise_SessionLost(
i1 : Object,
i2 : SessionLostEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.SessionLostEventArgs.


Client.raise_SetTargets(Object,SetTargetsEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_SetTargets Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SetTargets( _
ByVal i1 As Object, _
ByVal i2 As SetTargetsEventArgs _
)
C# protected void raise_SetTargets(
object i1,
SetTargetsEventArgs i2
);
Managed C++ protected: void raise_SetTargets(
Object *i1,
SetTargetsEventArgs *i2
);
JScript .NET protected function raise_SetTargets(
i1 : Object,
i2 : SetTargetsEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.SetTargetsEventArgs.


Client.ClientConfig

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ClientConfig Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the client configuration. Deprecated.

Definition

Visual Basic .NET | Public Property ClientConfig As ClientConfig
C# | public ClientConfig ClientConfig { get; set; }
Managed C++ public: __property ClientConfig get_ClientConfig();
public: __property void set_ClientConfig(ClientConfig);
JScript .NET public function get ClientConfig() : ClientConfig
public function set ClientConfig(ClientConfig);

Property Value

Microsoft.DirectX.DirectPlay.Voice.ClientConfig .

This property is read/write.


Client.CompressionTypes

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.CompressionTypes Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the available compression types on the system. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CompressionTypes As CompressionInformation()
C# | public CompressionInformation[] CompressionTypes { get; }
Managed C++ | public: __property CompressionInformation get_CompressionTypes();
JScript .NET | public function get CompressionTypes() : CompressionInformation[]

Property Value

Microsoft.DirectX.DirectPlay.Voice.CompressionInformation[] .

This property is read-only.


Client.SessionDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SessionDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the session properties. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SessionDescription As SessionDescription
C# | public SessionDescription SessionDescription { get; }
Managed C++ | public: __property SessionDescription get_SessionDescription();
JScript .NET | public function get SessionDescription() : SessionDescription

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionDescription .

This property is read-only.


Client.SoundDeviceConfig

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SoundDeviceConfig Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the sound device configuration of the session. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SoundDeviceConfig As SoundDeviceConfig
C# | public SoundDeviceConfig SoundDeviceConfig { get; }
Managed C++ | public: __property SoundDeviceConfig get_SoundDeviceConfig();
JScript .NET | public function get SoundDeviceConfig() : SoundDeviceConfig

Property Value

Microsoft.DirectX.DirectPlay.Voice.SoundDeviceConfig .

This property is read-only.


Client.TransmitTargets

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.TransmitTargets Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the transmit targets, if any, of the voice stream from this client. Deprecated.

Definition

Visual Basic .NET | Public Property TransmitTargets As Integer()
C# | public int[] TransmitTargets { get; set; }
Managed C++ public: __property int get_TransmitTargets();
public: __property void set_TransmitTargets(int);
JScript .NET public function get TransmitTargets() : int[]
public function set TransmitTargets(int[]);

Property Value

System.Int32[] .

This property is read/write.


Client.ConnectResult

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ConnectResult Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.

Definition

Visual Basic .NET | Public Event ConnectResult As ConnectResultEventHandler
C# | public event ConnectResultEventHandler ConnectResult;
Managed C++ | public: __event ConnectResultEventHandler ConnectResult;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.DisconnectResult

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.DisconnectResult Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has been completed. Deprecated.

Definition

Visual Basic .NET | Public Event DisconnectResult As DisconnectResultEventHandler
C# | public event DisconnectResultEventHandler DisconnectResult;
Managed C++ | public: __event DisconnectResultEventHandler DisconnectResult;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.GainFocus

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GainFocus Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application gains focus. Deprecated.

Definition

Visual Basic .NET | Public Event GainFocus As EventHandler
C# | public event EventHandler GainFocus;
Managed C++ | public: __event EventHandler GainFocus;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.HostMigrated

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.HostMigrated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has migrated. Deprecated.

Definition

Visual Basic .NET | Public Event HostMigrated As VoiceHostMigratedEventHandler
C# | public event VoiceHostMigratedEventHandler HostMigrated;
Managed C++ | public: __event VoiceHostMigratedEventHandler HostMigrated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.InputLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.InputLevel Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the input level has changed. Deprecated.

Definition

Visual Basic .NET | Public Event InputLevel As InputLevelEventHandler
C# | public event InputLevelEventHandler InputLevel;
Managed C++ | public: __event InputLevelEventHandler InputLevel;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.LostFocus

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.LostFocus Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application has lost focus. Deprecated.

Definition

Visual Basic .NET | Public Event LostFocus As EventHandler
C# | public event EventHandler LostFocus;
Managed C++ | public: __event EventHandler LostFocus;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.OutputLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.OutputLevel Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the output level changes. Deprecated.

Definition

Visual Basic .NET | Public Event OutputLevel As OutputLevelEventHandler
C# | public event OutputLevelEventHandler OutputLevel;
Managed C++ | public: __event OutputLevelEventHandler OutputLevel;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.PlayerCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.PlayerCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerCreated As VoicePlayerCreatedEventHandler
C# | public event VoicePlayerCreatedEventHandler PlayerCreated;
Managed C++ | public: __event VoicePlayerCreatedEventHandler PlayerCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.PlayerDeleted

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.PlayerDeleted Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerDeleted As VoicePlayerDeletedEventHandler
C# | public event VoicePlayerDeletedEventHandler PlayerDeleted;
Managed C++ | public: __event VoicePlayerDeletedEventHandler PlayerDeleted;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.PlayerOutputLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.PlayerOutputLevel Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a players output level has changed. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerOutputLevel As PlayerOutputLevelEventHandler
C# | public event PlayerOutputLevelEventHandler PlayerOutputLevel;
Managed C++ | public: __event PlayerOutputLevelEventHandler PlayerOutputLevel;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.PlayerStarted

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.PlayerStarted Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player starts talking. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerStarted As PlayerStartedEventHandler
C# | public event PlayerStartedEventHandler PlayerStarted;
Managed C++ | public: __event PlayerStartedEventHandler PlayerStarted;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.PlayerStopped

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.PlayerStopped Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has stopped talking. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerStopped As PlayerStoppedEventHandler
C# | public event PlayerStoppedEventHandler PlayerStopped;
Managed C++ | public: __event PlayerStoppedEventHandler PlayerStopped;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.RecordStarted

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.RecordStarted Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has started talking. Deprecated.

Definition

Visual Basic .NET | Public Event RecordStarted As RecordStartedEventHandler
C# | public event RecordStartedEventHandler RecordStarted;
Managed C++ | public: __event RecordStartedEventHandler RecordStarted;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.RecordStopped

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.RecordStopped Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has stopped talking. Deprecated.

Definition

Visual Basic .NET | Public Event RecordStopped As RecordStoppedEventHandler
C# | public event RecordStoppedEventHandler RecordStopped;
Managed C++ | public: __event RecordStoppedEventHandler RecordStopped;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.SessionLost

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SessionLost Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been lost. Deprecated.

Definition

Visual Basic .NET | Public Event SessionLost As SessionLostEventHandler
C# | public event SessionLostEventHandler SessionLost;
Managed C++ | public: __event SessionLostEventHandler SessionLost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.SetTargets

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetTargets Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Definition

Visual Basic .NET | Public Event SetTargets As SetTargetsEventHandler
C# | public event SetTargetsEventHandler SetTargets;
Managed C++ | public: __event SetTargetsEventHandler SetTargets;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.Voice.CompressionGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various compression codecs that can be used. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class CompressionGuid
Inherits Object
C# | public sealed class CompressionGuid : Object
Managed C++ | public __gc __sealed class CompressionGuid : public Object
JScript .NET | public class CompressionGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic .NET) AdPcm
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) Default
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) Gsm
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) None
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) Sc03
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) Sc06
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) TrueSpeech
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) Vr12
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Inheritance Hierarchy

Object Leave Site
CompressionGuid

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CompressionGuid.AdPcm

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.AdPcm Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared AdPcm As Guid
C# | public static Guid AdPcm;
Managed C++ | public: static Guid AdPcm;
JScript .NET | public static var AdPcm : Guid

Field Value

System.Guid .

This field is read-only.


CompressionGuid.Default

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.Default Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared Default As Guid
C# | public static Guid Default;
Managed C++ | public: static Guid Default;
JScript .NET | public static var Default : Guid

Field Value

System.Guid .

This field is read-only.


CompressionGuid.Gsm

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.Gsm Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared Gsm As Guid
C# | public static Guid Gsm;
Managed C++ | public: static Guid Gsm;
JScript .NET | public static var Gsm : Guid

Field Value

System.Guid .

This field is read-only.


CompressionGuid.None

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.None Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared None As Guid
C# | public static Guid None;
Managed C++ | public: static Guid None;
JScript .NET | public static var None : Guid

Field Value

System.Guid .

This field is read-only.


CompressionGuid.Sc03

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.Sc03 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared Sc03 As Guid
C# | public static Guid Sc03;
Managed C++ | public: static Guid Sc03;
JScript .NET | public static var Sc03 : Guid

Field Value

System.Guid .

This field is read-only.


CompressionGuid.Sc06

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.Sc06 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared Sc06 As Guid
C# | public static Guid Sc06;
Managed C++ | public: static Guid Sc06;
JScript .NET | public static var Sc06 : Guid

Field Value

System.Guid .

This field is read-only.


CompressionGuid.TrueSpeech

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.TrueSpeech Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared TrueSpeech As Guid
C# | public static Guid TrueSpeech;
Managed C++ | public: static Guid TrueSpeech;
JScript .NET | public static var TrueSpeech : Guid

Field Value

System.Guid .

This field is read-only.


CompressionGuid.Vr12

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionGuid.Vr12 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared Vr12 As Guid
C# | public static Guid Vr12;
Managed C++ | public: static Guid Vr12;
JScript .NET | public static var Vr12 : Guid

Field Value

System.Guid .

This field is read-only.


Microsoft.DirectX.DirectPlay.Voice.CompressionNotSupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionNotSupportedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified compression type is not supported on the local computer. Deprecated.

Definition

Visual Basic .NET Public Class CompressionNotSupportedException
Inherits VoiceException
C# | public class CompressionNotSupportedException : VoiceException
Managed C++ | public __gc class CompressionNotSupportedException : public VoiceException
JScript .NET | public class CompressionNotSupportedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CompressionNotSupportedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
CompressionNotSupportedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CompressionNotSupportedException.CompressionNotSupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CompressionNotSupportedException();
protected CompressionNotSupportedException(SerializationInfo, StreamingContext);
public CompressionNotSupportedException(string);
public CompressionNotSupportedException(string, Exception);


CompressionNotSupportedException.CompressionNotSupportedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CompressionNotSupportedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CompressionNotSupportedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CompressionNotSupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CompressionNotSupportedException.CompressionNotSupportedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CompressionNotSupportedException(
string message,
Exception inner
);
Managed C++ public: CompressionNotSupportedException(
String *message,
Exception *inner
);
JScript .NET public function CompressionNotSupportedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CompressionNotSupportedException.CompressionNotSupportedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CompressionNotSupportedException(
string message
);
Managed C++ public: CompressionNotSupportedException(
String *message
);
JScript .NET public function CompressionNotSupportedException(
message : String
);

Parameters

message System.String.


CompressionNotSupportedException.CompressionNotSupportedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CompressionNotSupportedException();
Managed C++ | public: CompressionNotSupportedException();
JScript .NET | public function CompressionNotSupportedException();


Microsoft.DirectX.DirectPlay.Voice.ConnectAbortedException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connect operation was canceled before it could be completed. Deprecated.

Definition

Visual Basic .NET Public Class ConnectAbortedException
Inherits VoiceException
C# | public class ConnectAbortedException : VoiceException
Managed C++ | public __gc class ConnectAbortedException : public VoiceException
JScript .NET | public class ConnectAbortedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectAbortedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectAbortedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectAbortedException.ConnectAbortedException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortedException.ConnectAbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectAbortedException();
protected ConnectAbortedException(SerializationInfo, StreamingContext);
public ConnectAbortedException(string);
public ConnectAbortedException(string, Exception);


ConnectAbortedException.ConnectAbortedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortedException.ConnectAbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectAbortedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConnectAbortedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConnectAbortedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ConnectAbortedException.ConnectAbortedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortedException.ConnectAbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectAbortedException(
string message,
Exception inner
);
Managed C++ public: ConnectAbortedException(
String *message,
Exception *inner
);
JScript .NET public function ConnectAbortedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ConnectAbortedException.ConnectAbortedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortedException.ConnectAbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConnectAbortedException(
string message
);
Managed C++ public: ConnectAbortedException(
String *message
);
JScript .NET public function ConnectAbortedException(
message : String
);

Parameters

message System.String.


ConnectAbortedException.ConnectAbortedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortedException.ConnectAbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectAbortedException();
Managed C++ | public: ConnectAbortedException();
JScript .NET | public function ConnectAbortedException();


Microsoft.DirectX.DirectPlay.Voice.ConnectAbortingException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection is being disconnected. Deprecated.

Definition

Visual Basic .NET Public Class ConnectAbortingException
Inherits VoiceException
C# | public class ConnectAbortingException : VoiceException
Managed C++ | public __gc class ConnectAbortingException : public VoiceException
JScript .NET | public class ConnectAbortingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectAbortingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectAbortingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectAbortingException.ConnectAbortingException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectAbortingException();
protected ConnectAbortingException(SerializationInfo, StreamingContext);
public ConnectAbortingException(string);
public ConnectAbortingException(string, Exception);


ConnectAbortingException.ConnectAbortingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectAbortingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConnectAbortingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConnectAbortingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ConnectAbortingException.ConnectAbortingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectAbortingException(
string message,
Exception inner
);
Managed C++ public: ConnectAbortingException(
String *message,
Exception *inner
);
JScript .NET public function ConnectAbortingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ConnectAbortingException.ConnectAbortingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConnectAbortingException(
string message
);
Managed C++ public: ConnectAbortingException(
String *message
);
JScript .NET public function ConnectAbortingException(
message : String
);

Parameters

message System.String.


ConnectAbortingException.ConnectAbortingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectAbortingException();
Managed C++ | public: ConnectAbortingException();
JScript .NET | public function ConnectAbortingException();


Microsoft.DirectX.DirectPlay.Voice.ConnectedException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is connected. Deprecated.

Definition

Visual Basic .NET Public Class ConnectedException
Inherits VoiceException
C# | public class ConnectedException : VoiceException
Managed C++ | public __gc class ConnectedException : public VoiceException
JScript .NET | public class ConnectedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectedException.ConnectedException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectedException.ConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectedException();
protected ConnectedException(SerializationInfo, StreamingContext);
public ConnectedException(string);
public ConnectedException(string, Exception);


ConnectedException.ConnectedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectedException.ConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConnectedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConnectedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ConnectedException.ConnectedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectedException.ConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectedException(
string message,
Exception inner
);
Managed C++ public: ConnectedException(
String *message,
Exception *inner
);
JScript .NET public function ConnectedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ConnectedException.ConnectedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectedException.ConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConnectedException(
string message
);
Managed C++ public: ConnectedException(
String *message
);
JScript .NET public function ConnectedException(
message : String
);

Parameters

message System.String.


ConnectedException.ConnectedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectedException.ConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectedException();
Managed C++ | public: ConnectedException();
JScript .NET | public function ConnectedException();


Microsoft.DirectX.DirectPlay.Voice.ConnectionLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection to the voice session has been lost. Deprecated.

Definition

Visual Basic .NET Public Class ConnectionLostException
Inherits VoiceException
C# | public class ConnectionLostException : VoiceException
Managed C++ | public __gc class ConnectionLostException : public VoiceException
JScript .NET | public class ConnectionLostException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectionLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectionLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectionLostException.ConnectionLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionLostException.ConnectionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectionLostException();
protected ConnectionLostException(SerializationInfo, StreamingContext);
public ConnectionLostException(string);
public ConnectionLostException(string, Exception);


ConnectionLostException.ConnectionLostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionLostException.ConnectionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectionLostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConnectionLostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConnectionLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ConnectionLostException.ConnectionLostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionLostException.ConnectionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectionLostException(
string message,
Exception inner
);
Managed C++ public: ConnectionLostException(
String *message,
Exception *inner
);
JScript .NET public function ConnectionLostException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ConnectionLostException.ConnectionLostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionLostException.ConnectionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConnectionLostException(
string message
);
Managed C++ public: ConnectionLostException(
String *message
);
JScript .NET public function ConnectionLostException(
message : String
);

Parameters

message System.String.


ConnectionLostException.ConnectionLostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionLostException.ConnectionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectionLostException();
Managed C++ | public: ConnectionLostException();
JScript .NET | public function ConnectionLostException();


Microsoft.DirectX.DirectPlay.Voice.ConnectResultEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ConnectResultEventArgs
Inherits EventArgs
C# | public sealed class ConnectResultEventArgs : EventArgs
Managed C++ | public __gc __sealed class ConnectResultEventArgs : public EventArgs
JScript .NET | public class ConnectResultEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectResultEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectResultEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectResultEventArgs.ConnectResultEventArgs(ConnectResultMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultEventArgs.ConnectResultEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ConnectResultMessage _
)
C# public ConnectResultEventArgs(
ConnectResultMessage dpMessage
);
Managed C++ public: ConnectResultEventArgs(
ConnectResultMessage dpMessage
);
JScript .NET public function ConnectResultEventArgs(
dpMessage : ConnectResultMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.ConnectResultMessage.


ConnectResultEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ConnectResultMessage
C# | public ConnectResultMessage Message;
Managed C++ | public: ConnectResultMessage Message;
JScript .NET | public var Message : ConnectResultMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.ConnectResultMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.DisconnectResultEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class DisconnectResultEventArgs
Inherits EventArgs
C# | public sealed class DisconnectResultEventArgs : EventArgs
Managed C++ | public __gc __sealed class DisconnectResultEventArgs : public EventArgs
JScript .NET | public class DisconnectResultEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
DisconnectResultEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
DisconnectResultEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisconnectResultEventArgs.DisconnectResultEventArgs(DisconnectResultMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultEventArgs.DisconnectResultEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As DisconnectResultMessage _
)
C# public DisconnectResultEventArgs(
DisconnectResultMessage dpMessage
);
Managed C++ public: DisconnectResultEventArgs(
DisconnectResultMessage dpMessage
);
JScript .NET public function DisconnectResultEventArgs(
dpMessage : DisconnectResultMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.DisconnectResultMessage.


DisconnectResultEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As DisconnectResultMessage
C# | public DisconnectResultMessage Message;
Managed C++ | public: DisconnectResultMessage Message;
JScript .NET | public var Message : DisconnectResultMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.DisconnectResultMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.HostingException

Microsoft DirectX 9.0 SDK Update (October 2004)

HostingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is the host of the session. Deprecated.

Definition

Visual Basic .NET Public Class HostingException
Inherits VoiceException
C# | public class HostingException : VoiceException
Managed C++ | public __gc class HostingException : public VoiceException
JScript .NET | public class HostingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
HostingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
HostingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HostingException.HostingException

Microsoft DirectX 9.0 SDK Update (October 2004)

HostingException.HostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public HostingException();
protected HostingException(SerializationInfo, StreamingContext);
public HostingException(string);
public HostingException(string, Exception);


HostingException.HostingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

HostingException.HostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected HostingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: HostingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function HostingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


HostingException.HostingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

HostingException.HostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public HostingException(
string message,
Exception inner
);
Managed C++ public: HostingException(
String *message,
Exception *inner
);
JScript .NET public function HostingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


HostingException.HostingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

HostingException.HostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public HostingException(
string message
);
Managed C++ public: HostingException(
String *message
);
JScript .NET public function HostingException(
message : String
);

Parameters

message System.String.


HostingException.HostingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

HostingException.HostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public HostingException();
Managed C++ | public: HostingException();
JScript .NET | public function HostingException();


Microsoft.DirectX.DirectPlay.Voice.HostMigratedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class HostMigratedEventArgs
Inherits EventArgs
C# | public sealed class HostMigratedEventArgs : EventArgs
Managed C++ | public __gc __sealed class HostMigratedEventArgs : public EventArgs
JScript .NET | public class HostMigratedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
HostMigratedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
HostMigratedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HostMigratedEventArgs.HostMigratedEventArgs(HostMigratedMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedEventArgs.HostMigratedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As HostMigratedMessage _
)
C# public HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
Managed C++ public: HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
JScript .NET public function HostMigratedEventArgs(
dpMessage : HostMigratedMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.HostMigratedMessage.


HostMigratedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As HostMigratedMessage
C# | public HostMigratedMessage Message;
Managed C++ | public: HostMigratedMessage Message;
JScript .NET | public var Message : HostMigratedMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.HostMigratedMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.IncompatibleVersionException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatibleVersionException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client connected to a voice session that is incompatible with the host. Deprecated.

Definition

Visual Basic .NET Public Class IncompatibleVersionException
Inherits VoiceException
C# | public class IncompatibleVersionException : VoiceException
Managed C++ | public __gc class IncompatibleVersionException : public VoiceException
JScript .NET | public class IncompatibleVersionException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompatibleVersionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
IncompatibleVersionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IncompatibleVersionException.IncompatibleVersionException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public IncompatibleVersionException();
protected IncompatibleVersionException(SerializationInfo, StreamingContext);
public IncompatibleVersionException(string);
public IncompatibleVersionException(string, Exception);


IncompatibleVersionException.IncompatibleVersionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompatibleVersionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: IncompatibleVersionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function IncompatibleVersionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


IncompatibleVersionException.IncompatibleVersionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompatibleVersionException(
string message,
Exception inner
);
Managed C++ public: IncompatibleVersionException(
String *message,
Exception *inner
);
JScript .NET public function IncompatibleVersionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


IncompatibleVersionException.IncompatibleVersionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public IncompatibleVersionException(
string message
);
Managed C++ public: IncompatibleVersionException(
String *message
);
JScript .NET public function IncompatibleVersionException(
message : String
);

Parameters

message System.String.


IncompatibleVersionException.IncompatibleVersionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public IncompatibleVersionException();
Managed C++ | public: IncompatibleVersionException();
JScript .NET | public function IncompatibleVersionException();


Microsoft.DirectX.DirectPlay.Voice.InputLevelEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class InputLevelEventArgs
Inherits EventArgs
C# | public sealed class InputLevelEventArgs : EventArgs
Managed C++ | public __gc __sealed class InputLevelEventArgs : public EventArgs
JScript .NET | public class InputLevelEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
InputLevelEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
InputLevelEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputLevelEventArgs.InputLevelEventArgs(InputLevelMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelEventArgs.InputLevelEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As InputLevelMessage _
)
C# public InputLevelEventArgs(
InputLevelMessage dpMessage
);
Managed C++ public: InputLevelEventArgs(
InputLevelMessage dpMessage
);
JScript .NET public function InputLevelEventArgs(
dpMessage : InputLevelMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.InputLevelMessage.


InputLevelEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As InputLevelMessage
C# | public InputLevelMessage Message;
Managed C++ | public: InputLevelMessage Message;
JScript .NET | public var Message : InputLevelMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.InputLevelMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.InvalidBufferException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidBufferException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A buffer specified as a parameter is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidBufferException
Inherits VoiceException
C# | public class InvalidBufferException : VoiceException
Managed C++ | public __gc class InvalidBufferException : public VoiceException
JScript .NET | public class InvalidBufferException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidBufferException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidBufferException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidBufferException.InvalidBufferException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidBufferException.InvalidBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidBufferException();
protected InvalidBufferException(SerializationInfo, StreamingContext);
public InvalidBufferException(string);
public InvalidBufferException(string, Exception);


InvalidBufferException.InvalidBufferException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidBufferException.InvalidBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidBufferException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidBufferException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidBufferException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidBufferException.InvalidBufferException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidBufferException.InvalidBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidBufferException(
string message,
Exception inner
);
Managed C++ public: InvalidBufferException(
String *message,
Exception *inner
);
JScript .NET public function InvalidBufferException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidBufferException.InvalidBufferException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidBufferException.InvalidBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidBufferException(
string message
);
Managed C++ public: InvalidBufferException(
String *message
);
JScript .NET public function InvalidBufferException(
message : String
);

Parameters

message System.String.


InvalidBufferException.InvalidBufferException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidBufferException.InvalidBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidBufferException();
Managed C++ | public: InvalidBufferException();
JScript .NET | public function InvalidBufferException();


Microsoft.DirectX.DirectPlay.Voice.InvalidDeviceException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified device is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidDeviceException
Inherits VoiceException
C# | public class InvalidDeviceException : VoiceException
Managed C++ | public __gc class InvalidDeviceException : public VoiceException
JScript .NET | public class InvalidDeviceException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDeviceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidDeviceException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidDeviceException.InvalidDeviceException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidDeviceException();
protected InvalidDeviceException(SerializationInfo, StreamingContext);
public InvalidDeviceException(string);
public InvalidDeviceException(string, Exception);


InvalidDeviceException.InvalidDeviceException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDeviceException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidDeviceException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidDeviceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidDeviceException.InvalidDeviceException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDeviceException(
string message,
Exception inner
);
Managed C++ public: InvalidDeviceException(
String *message,
Exception *inner
);
JScript .NET public function InvalidDeviceException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidDeviceException.InvalidDeviceException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidDeviceException(
string message
);
Managed C++ public: InvalidDeviceException(
String *message
);
JScript .NET public function InvalidDeviceException(
message : String
);

Parameters

message System.String.


InvalidDeviceException.InvalidDeviceException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceException.InvalidDeviceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidDeviceException();
Managed C++ | public: InvalidDeviceException();
JScript .NET | public function InvalidDeviceException();


Microsoft.DirectX.DirectPlay.Voice.InvalidFlagsException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidFlagsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidFlagsException
Inherits VoiceException
C# | public class InvalidFlagsException : VoiceException
Managed C++ | public __gc class InvalidFlagsException : public VoiceException
JScript .NET | public class InvalidFlagsException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidFlagsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidFlagsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidFlagsException.InvalidFlagsException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidFlagsException.InvalidFlagsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidFlagsException();
protected InvalidFlagsException(SerializationInfo, StreamingContext);
public InvalidFlagsException(string);
public InvalidFlagsException(string, Exception);


InvalidFlagsException.InvalidFlagsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidFlagsException.InvalidFlagsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidFlagsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidFlagsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidFlagsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidFlagsException.InvalidFlagsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidFlagsException.InvalidFlagsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidFlagsException(
string message,
Exception inner
);
Managed C++ public: InvalidFlagsException(
String *message,
Exception *inner
);
JScript .NET public function InvalidFlagsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidFlagsException.InvalidFlagsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidFlagsException.InvalidFlagsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidFlagsException(
string message
);
Managed C++ public: InvalidFlagsException(
String *message
);
JScript .NET public function InvalidFlagsException(
message : String
);

Parameters

message System.String.


InvalidFlagsException.InvalidFlagsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidFlagsException.InvalidFlagsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidFlagsException();
Managed C++ | public: InvalidFlagsException();
JScript .NET | public function InvalidFlagsException();


Microsoft.DirectX.DirectPlay.Voice.InvalidGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidGroupException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group ID is not recognized as a valid group ID for this game session. Deprecated.

Definition

Visual Basic .NET Public Class InvalidGroupException
Inherits VoiceException
C# | public class InvalidGroupException : VoiceException
Managed C++ | public __gc class InvalidGroupException : public VoiceException
JScript .NET | public class InvalidGroupException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidGroupException.InvalidGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidGroupException.InvalidGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidGroupException();
protected InvalidGroupException(SerializationInfo, StreamingContext);
public InvalidGroupException(string);
public InvalidGroupException(string, Exception);


InvalidGroupException.InvalidGroupException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidGroupException.InvalidGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidGroupException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidGroupException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidGroupException.InvalidGroupException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidGroupException.InvalidGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidGroupException(
string message,
Exception inner
);
Managed C++ public: InvalidGroupException(
String *message,
Exception *inner
);
JScript .NET public function InvalidGroupException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidGroupException.InvalidGroupException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidGroupException.InvalidGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidGroupException(
string message
);
Managed C++ public: InvalidGroupException(
String *message
);
JScript .NET public function InvalidGroupException(
message : String
);

Parameters

message System.String.


InvalidGroupException.InvalidGroupException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidGroupException.InvalidGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidGroupException();
Managed C++ | public: InvalidGroupException();
JScript .NET | public function InvalidGroupException();


Microsoft.DirectX.DirectPlay.Voice.InvalidHandleException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHandleException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidHandleException
Inherits VoiceException
C# | public class InvalidHandleException : VoiceException
Managed C++ | public __gc class InvalidHandleException : public VoiceException
JScript .NET | public class InvalidHandleException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidHandleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidHandleException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidHandleException.InvalidHandleException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHandleException.InvalidHandleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidHandleException();
protected InvalidHandleException(SerializationInfo, StreamingContext);
public InvalidHandleException(string);
public InvalidHandleException(string, Exception);


InvalidHandleException.InvalidHandleException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHandleException.InvalidHandleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidHandleException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidHandleException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidHandleException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidHandleException.InvalidHandleException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHandleException.InvalidHandleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidHandleException(
string message,
Exception inner
);
Managed C++ public: InvalidHandleException(
String *message,
Exception *inner
);
JScript .NET public function InvalidHandleException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidHandleException.InvalidHandleException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHandleException.InvalidHandleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidHandleException(
string message
);
Managed C++ public: InvalidHandleException(
String *message
);
JScript .NET public function InvalidHandleException(
message : String
);

Parameters

message System.String.


InvalidHandleException.InvalidHandleException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHandleException.InvalidHandleException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidHandleException();
Managed C++ | public: InvalidHandleException();
JScript .NET | public function InvalidHandleException();


Microsoft.DirectX.DirectPlay.Voice.InvalidObjectException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay object is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidObjectException
Inherits VoiceException
C# | public class InvalidObjectException : VoiceException
Managed C++ | public __gc class InvalidObjectException : public VoiceException
JScript .NET | public class InvalidObjectException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidObjectException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidObjectException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.Voice.InvalidPlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPlayerException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.

Definition

Visual Basic .NET Public Class InvalidPlayerException
Inherits VoiceException
C# | public class InvalidPlayerException : VoiceException
Managed C++ | public __gc class InvalidPlayerException : public VoiceException
JScript .NET | public class InvalidPlayerException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidPlayerException.InvalidPlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPlayerException.InvalidPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPlayerException();
protected InvalidPlayerException(SerializationInfo, StreamingContext);
public InvalidPlayerException(string);
public InvalidPlayerException(string, Exception);


InvalidPlayerException.InvalidPlayerException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPlayerException.InvalidPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPlayerException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidPlayerException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidPlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidPlayerException.InvalidPlayerException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPlayerException.InvalidPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPlayerException(
string message,
Exception inner
);
Managed C++ public: InvalidPlayerException(
String *message,
Exception *inner
);
JScript .NET public function InvalidPlayerException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidPlayerException.InvalidPlayerException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPlayerException.InvalidPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidPlayerException(
string message
);
Managed C++ public: InvalidPlayerException(
String *message
);
JScript .NET public function InvalidPlayerException(
message : String
);

Parameters

message System.String.


InvalidPlayerException.InvalidPlayerException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPlayerException.InvalidPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidPlayerException();
Managed C++ | public: InvalidPlayerException();
JScript .NET | public function InvalidPlayerException();


Microsoft.DirectX.DirectPlay.Voice.InvalidTargetException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidTargetException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified target is not a valid player ID or group ID for this voice session. Deprecated.

Definition

Visual Basic .NET Public Class InvalidTargetException
Inherits VoiceException
C# | public class InvalidTargetException : VoiceException
Managed C++ | public __gc class InvalidTargetException : public VoiceException
JScript .NET | public class InvalidTargetException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidTargetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidTargetException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidTargetException.InvalidTargetException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidTargetException.InvalidTargetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidTargetException();
protected InvalidTargetException(SerializationInfo, StreamingContext);
public InvalidTargetException(string);
public InvalidTargetException(string, Exception);


InvalidTargetException.InvalidTargetException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidTargetException.InvalidTargetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidTargetException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidTargetException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidTargetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidTargetException.InvalidTargetException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidTargetException.InvalidTargetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidTargetException(
string message,
Exception inner
);
Managed C++ public: InvalidTargetException(
String *message,
Exception *inner
);
JScript .NET public function InvalidTargetException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidTargetException.InvalidTargetException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidTargetException.InvalidTargetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidTargetException(
string message
);
Managed C++ public: InvalidTargetException(
String *message
);
JScript .NET public function InvalidTargetException(
message : String
);

Parameters

message System.String.


InvalidTargetException.InvalidTargetException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidTargetException.InvalidTargetException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidTargetException();
Managed C++ | public: InvalidTargetException();
JScript .NET | public function InvalidTargetException();


Microsoft.DirectX.DirectPlay.Voice.LockedBufferException

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBufferException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer is already locked. Deprecated.

Definition

Visual Basic .NET Public Class LockedBufferException
Inherits VoiceException
C# | public class LockedBufferException : VoiceException
Managed C++ | public __gc class LockedBufferException : public VoiceException
JScript .NET | public class LockedBufferException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
LockedBufferException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
LockedBufferException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LockedBufferException.LockedBufferException

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBufferException.LockedBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public LockedBufferException();
protected LockedBufferException(SerializationInfo, StreamingContext);
public LockedBufferException(string);
public LockedBufferException(string, Exception);


LockedBufferException.LockedBufferException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBufferException.LockedBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected LockedBufferException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: LockedBufferException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function LockedBufferException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


LockedBufferException.LockedBufferException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBufferException.LockedBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public LockedBufferException(
string message,
Exception inner
);
Managed C++ public: LockedBufferException(
String *message,
Exception *inner
);
JScript .NET public function LockedBufferException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


LockedBufferException.LockedBufferException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBufferException.LockedBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public LockedBufferException(
string message
);
Managed C++ public: LockedBufferException(
String *message
);
JScript .NET public function LockedBufferException(
message : String
);

Parameters

message System.String.


LockedBufferException.LockedBufferException()

Microsoft DirectX 9.0 SDK Update (October 2004)

LockedBufferException.LockedBufferException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public LockedBufferException();
Managed C++ | public: LockedBufferException();
JScript .NET | public function LockedBufferException();


Microsoft.DirectX.DirectPlay.Voice.No3DSoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

No3DSoundException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support 3-D sound. Deprecated.

Definition

Visual Basic .NET Public Class No3DSoundException
Inherits VoiceException
C# | public class No3DSoundException : VoiceException
Managed C++ | public __gc class No3DSoundException : public VoiceException
JScript .NET | public class No3DSoundException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
No3DSoundException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
No3DSoundException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


No3DSoundException.No3DSoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

No3DSoundException.No3DSoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public No3DSoundException();
protected No3DSoundException(SerializationInfo, StreamingContext);
public No3DSoundException(string);
public No3DSoundException(string, Exception);


No3DSoundException.No3DSoundException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

No3DSoundException.No3DSoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected No3DSoundException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: No3DSoundException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function No3DSoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


No3DSoundException.No3DSoundException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

No3DSoundException.No3DSoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public No3DSoundException(
string message,
Exception inner
);
Managed C++ public: No3DSoundException(
String *message,
Exception *inner
);
JScript .NET public function No3DSoundException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


No3DSoundException.No3DSoundException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

No3DSoundException.No3DSoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public No3DSoundException(
string message
);
Managed C++ public: No3DSoundException(
String *message
);
JScript .NET public function No3DSoundException(
message : String
);

Parameters

message System.String.


No3DSoundException.No3DSoundException()

Microsoft DirectX 9.0 SDK Update (October 2004)

No3DSoundException.No3DSoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public No3DSoundException();
Managed C++ | public: No3DSoundException();
JScript .NET | public function No3DSoundException();


Microsoft.DirectX.DirectPlay.Voice.NoRecordVolumeAvailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRecordVolumeAvailableException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support record volume. Deprecated.

Definition

Visual Basic .NET Public Class NoRecordVolumeAvailableException
Inherits VoiceException
C# | public class NoRecordVolumeAvailableException : VoiceException
Managed C++ | public __gc class NoRecordVolumeAvailableException : public VoiceException
JScript .NET | public class NoRecordVolumeAvailableException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoRecordVolumeAvailableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NoRecordVolumeAvailableException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoRecordVolumeAvailableException();
protected NoRecordVolumeAvailableException(SerializationInfo, StreamingContext);
public NoRecordVolumeAvailableException(string);
public NoRecordVolumeAvailableException(string, Exception);


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoRecordVolumeAvailableException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoRecordVolumeAvailableException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoRecordVolumeAvailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoRecordVolumeAvailableException(
string message,
Exception inner
);
Managed C++ public: NoRecordVolumeAvailableException(
String *message,
Exception *inner
);
JScript .NET public function NoRecordVolumeAvailableException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoRecordVolumeAvailableException(
string message
);
Managed C++ public: NoRecordVolumeAvailableException(
String *message
);
JScript .NET public function NoRecordVolumeAvailableException(
message : String
);

Parameters

message System.String.


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoRecordVolumeAvailableException();
Managed C++ | public: NoRecordVolumeAvailableException();
JScript .NET | public function NoRecordVolumeAvailableException();


Microsoft.DirectX.DirectPlay.Voice.NotAllowedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAllowedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object does not have the permission to perform this operation. Deprecated.

Definition

Visual Basic .NET Public Class NotAllowedException
Inherits VoiceException
C# | public class NotAllowedException : VoiceException
Managed C++ | public __gc class NotAllowedException : public VoiceException
JScript .NET | public class NotAllowedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAllowedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotAllowedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotAllowedException.NotAllowedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAllowedException.NotAllowedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotAllowedException();
protected NotAllowedException(SerializationInfo, StreamingContext);
public NotAllowedException(string);
public NotAllowedException(string, Exception);


NotAllowedException.NotAllowedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAllowedException.NotAllowedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAllowedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotAllowedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotAllowedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotAllowedException.NotAllowedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAllowedException.NotAllowedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAllowedException(
string message,
Exception inner
);
Managed C++ public: NotAllowedException(
String *message,
Exception *inner
);
JScript .NET public function NotAllowedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotAllowedException.NotAllowedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAllowedException.NotAllowedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotAllowedException(
string message
);
Managed C++ public: NotAllowedException(
String *message
);
JScript .NET public function NotAllowedException(
message : String
);

Parameters

message System.String.


NotAllowedException.NotAllowedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAllowedException.NotAllowedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotAllowedException();
Managed C++ | public: NotAllowedException();
JScript .NET | public function NotAllowedException();


Microsoft.DirectX.DirectPlay.Voice.NotBufferedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no user buffer for the specified ID. Deprecated.

Definition

Visual Basic .NET Public Class NotBufferedException
Inherits VoiceException
C# | public class NotBufferedException : VoiceException
Managed C++ | public __gc class NotBufferedException : public VoiceException
JScript .NET | public class NotBufferedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotBufferedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotBufferedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotBufferedException.NotBufferedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotBufferedException();
protected NotBufferedException(SerializationInfo, StreamingContext);
public NotBufferedException(string);
public NotBufferedException(string, Exception);


NotBufferedException.NotBufferedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotBufferedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotBufferedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotBufferedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotBufferedException.NotBufferedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotBufferedException(
string message,
Exception inner
);
Managed C++ public: NotBufferedException(
String *message,
Exception *inner
);
JScript .NET public function NotBufferedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotBufferedException.NotBufferedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotBufferedException(
string message
);
Managed C++ public: NotBufferedException(
String *message
);
JScript .NET public function NotBufferedException(
message : String
);

Parameters

message System.String.


NotBufferedException.NotBufferedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotBufferedException.NotBufferedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotBufferedException();
Managed C++ | public: NotBufferedException();
JScript .NET | public function NotBufferedException();


Microsoft.DirectX.DirectPlay.Voice.NotConnectedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotConnectedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is not connected. Deprecated.

Definition

Visual Basic .NET Public Class NotConnectedException
Inherits VoiceException
C# | public class NotConnectedException : VoiceException
Managed C++ | public __gc class NotConnectedException : public VoiceException
JScript .NET | public class NotConnectedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotConnectedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotConnectedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotConnectedException.NotConnectedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotConnectedException.NotConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotConnectedException();
protected NotConnectedException(SerializationInfo, StreamingContext);
public NotConnectedException(string);
public NotConnectedException(string, Exception);


NotConnectedException.NotConnectedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotConnectedException.NotConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotConnectedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotConnectedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotConnectedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotConnectedException.NotConnectedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotConnectedException.NotConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotConnectedException(
string message,
Exception inner
);
Managed C++ public: NotConnectedException(
String *message,
Exception *inner
);
JScript .NET public function NotConnectedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotConnectedException.NotConnectedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotConnectedException.NotConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotConnectedException(
string message
);
Managed C++ public: NotConnectedException(
String *message
);
JScript .NET public function NotConnectedException(
message : String
);

Parameters

message System.String.


NotConnectedException.NotConnectedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotConnectedException.NotConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotConnectedException();
Managed C++ | public: NotConnectedException();
JScript .NET | public function NotConnectedException();


Microsoft.DirectX.DirectPlay.Voice.NotHostingException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the session. Deprecated.

Definition

Visual Basic .NET Public Class NotHostingException
Inherits VoiceException
C# | public class NotHostingException : VoiceException
Managed C++ | public __gc class NotHostingException : public VoiceException
JScript .NET | public class NotHostingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotHostingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotHostingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotHostingException.NotHostingException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostingException.NotHostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotHostingException();
protected NotHostingException(SerializationInfo, StreamingContext);
public NotHostingException(string);
public NotHostingException(string, Exception);


NotHostingException.NotHostingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostingException.NotHostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotHostingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotHostingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotHostingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotHostingException.NotHostingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostingException.NotHostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotHostingException(
string message,
Exception inner
);
Managed C++ public: NotHostingException(
String *message,
Exception *inner
);
JScript .NET public function NotHostingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotHostingException.NotHostingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostingException.NotHostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotHostingException(
string message
);
Managed C++ public: NotHostingException(
String *message
);
JScript .NET public function NotHostingException(
message : String
);

Parameters

message System.String.


NotHostingException.NotHostingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostingException.NotHostingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotHostingException();
Managed C++ | public: NotHostingException();
JScript .NET | public function NotHostingException();


Microsoft.DirectX.DirectPlay.Voice.NoTransportException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoTransportException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified object is not a valid transport. Deprecated.

Definition

Visual Basic .NET Public Class NoTransportException
Inherits VoiceException
C# | public class NoTransportException : VoiceException
Managed C++ | public __gc class NoTransportException : public VoiceException
JScript .NET | public class NoTransportException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoTransportException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NoTransportException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoTransportException.NoTransportException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoTransportException.NoTransportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoTransportException();
protected NoTransportException(SerializationInfo, StreamingContext);
public NoTransportException(string);
public NoTransportException(string, Exception);


NoTransportException.NoTransportException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoTransportException.NoTransportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoTransportException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoTransportException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoTransportException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoTransportException.NoTransportException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoTransportException.NoTransportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoTransportException(
string message,
Exception inner
);
Managed C++ public: NoTransportException(
String *message,
Exception *inner
);
JScript .NET public function NoTransportException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoTransportException.NoTransportException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoTransportException.NoTransportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoTransportException(
string message
);
Managed C++ public: NoTransportException(
String *message
);
JScript .NET public function NoTransportException(
message : String
);

Parameters

message System.String.


NoTransportException.NoTransportException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoTransportException.NoTransportException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoTransportException();
Managed C++ | public: NoTransportException();
JScript .NET | public function NoTransportException();


Microsoft.DirectX.DirectPlay.Voice.NotSupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotSupportedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.

Definition

Visual Basic .NET Public Class NotSupportedException
Inherits VoiceException
C# | public class NotSupportedException : VoiceException
Managed C++ | public __gc class NotSupportedException : public VoiceException
JScript .NET | public class NotSupportedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotSupportedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotSupportedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotSupportedException.NotSupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotSupportedException.NotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotSupportedException();
protected NotSupportedException(SerializationInfo, StreamingContext);
public NotSupportedException(string);
public NotSupportedException(string, Exception);


NotSupportedException.NotSupportedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotSupportedException.NotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotSupportedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotSupportedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotSupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotSupportedException.NotSupportedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotSupportedException.NotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotSupportedException(
string message,
Exception inner
);
Managed C++ public: NotSupportedException(
String *message,
Exception *inner
);
JScript .NET public function NotSupportedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotSupportedException.NotSupportedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotSupportedException.NotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotSupportedException(
string message
);
Managed C++ public: NotSupportedException(
String *message
);
JScript .NET public function NotSupportedException(
message : String
);

Parameters

message System.String.


NotSupportedException.NotSupportedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotSupportedException.NotSupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotSupportedException();
Managed C++ | public: NotSupportedException();
JScript .NET | public function NotSupportedException();


Microsoft.DirectX.DirectPlay.Voice.NoVoiceSessionException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVoiceSessionException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session specified is not a voice session. Deprecated.

Definition

Visual Basic .NET Public Class NoVoiceSessionException
Inherits VoiceException
C# | public class NoVoiceSessionException : VoiceException
Managed C++ | public __gc class NoVoiceSessionException : public VoiceException
JScript .NET | public class NoVoiceSessionException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoVoiceSessionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NoVoiceSessionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoVoiceSessionException.NoVoiceSessionException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVoiceSessionException.NoVoiceSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoVoiceSessionException();
protected NoVoiceSessionException(SerializationInfo, StreamingContext);
public NoVoiceSessionException(string);
public NoVoiceSessionException(string, Exception);


NoVoiceSessionException.NoVoiceSessionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVoiceSessionException.NoVoiceSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoVoiceSessionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoVoiceSessionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoVoiceSessionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoVoiceSessionException.NoVoiceSessionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVoiceSessionException.NoVoiceSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoVoiceSessionException(
string message,
Exception inner
);
Managed C++ public: NoVoiceSessionException(
String *message,
Exception *inner
);
JScript .NET public function NoVoiceSessionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoVoiceSessionException.NoVoiceSessionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVoiceSessionException.NoVoiceSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoVoiceSessionException(
string message
);
Managed C++ public: NoVoiceSessionException(
String *message
);
JScript .NET public function NoVoiceSessionException(
message : String
);

Parameters

message System.String.


NoVoiceSessionException.NoVoiceSessionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoVoiceSessionException.NoVoiceSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoVoiceSessionException();
Managed C++ | public: NoVoiceSessionException();
JScript .NET | public function NoVoiceSessionException();


Microsoft.DirectX.DirectPlay.Voice.OutputLevelEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class OutputLevelEventArgs
Inherits EventArgs
C# | public sealed class OutputLevelEventArgs : EventArgs
Managed C++ | public __gc __sealed class OutputLevelEventArgs : public EventArgs
JScript .NET | public class OutputLevelEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
OutputLevelEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
OutputLevelEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OutputLevelEventArgs.OutputLevelEventArgs(OutputLevelMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelEventArgs.OutputLevelEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As OutputLevelMessage _
)
C# public OutputLevelEventArgs(
OutputLevelMessage dpMessage
);
Managed C++ public: OutputLevelEventArgs(
OutputLevelMessage dpMessage
);
JScript .NET public function OutputLevelEventArgs(
dpMessage : OutputLevelMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.OutputLevelMessage.


OutputLevelEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As OutputLevelMessage
C# | public OutputLevelMessage Message;
Managed C++ | public: OutputLevelMessage Message;
JScript .NET | public var Message : OutputLevelMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.OutputLevelMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.PlaybackSystemErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackSystemErrorException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the playback system occurred. Deprecated.

Definition

Visual Basic .NET Public Class PlaybackSystemErrorException
Inherits VoiceException
C# | public class PlaybackSystemErrorException : VoiceException
Managed C++ | public __gc class PlaybackSystemErrorException : public VoiceException
JScript .NET | public class PlaybackSystemErrorException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlaybackSystemErrorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
PlaybackSystemErrorException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlaybackSystemErrorException.PlaybackSystemErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlaybackSystemErrorException();
protected PlaybackSystemErrorException(SerializationInfo, StreamingContext);
public PlaybackSystemErrorException(string);
public PlaybackSystemErrorException(string, Exception);


PlaybackSystemErrorException.PlaybackSystemErrorException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlaybackSystemErrorException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PlaybackSystemErrorException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PlaybackSystemErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PlaybackSystemErrorException.PlaybackSystemErrorException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlaybackSystemErrorException(
string message,
Exception inner
);
Managed C++ public: PlaybackSystemErrorException(
String *message,
Exception *inner
);
JScript .NET public function PlaybackSystemErrorException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PlaybackSystemErrorException.PlaybackSystemErrorException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PlaybackSystemErrorException(
string message
);
Managed C++ public: PlaybackSystemErrorException(
String *message
);
JScript .NET public function PlaybackSystemErrorException(
message : String
);

Parameters

message System.String.


PlaybackSystemErrorException.PlaybackSystemErrorException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlaybackSystemErrorException();
Managed C++ | public: PlaybackSystemErrorException();
JScript .NET | public function PlaybackSystemErrorException();


Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayerOutputLevelEventArgs
Inherits EventArgs
C# | public sealed class PlayerOutputLevelEventArgs : EventArgs
Managed C++ | public __gc __sealed class PlayerOutputLevelEventArgs : public EventArgs
JScript .NET | public class PlayerOutputLevelEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerOutputLevelEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerOutputLevelEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerOutputLevelEventArgs.PlayerOutputLevelEventArgs(PlayerOutputLevelMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelEventArgs.PlayerOutputLevelEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As PlayerOutputLevelMessage _
)
C# public PlayerOutputLevelEventArgs(
PlayerOutputLevelMessage dpMessage
);
Managed C++ public: PlayerOutputLevelEventArgs(
PlayerOutputLevelMessage dpMessage
);
JScript .NET public function PlayerOutputLevelEventArgs(
dpMessage : PlayerOutputLevelMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelMessage.


PlayerOutputLevelEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As PlayerOutputLevelMessage
C# | public PlayerOutputLevelMessage Message;
Managed C++ | public: PlayerOutputLevelMessage Message;
JScript .NET | public var Message : PlayerOutputLevelMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.PlayerStartedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStartedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStarted event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayerStartedEventArgs
Inherits EventArgs
C# | public sealed class PlayerStartedEventArgs : EventArgs
Managed C++ | public __gc __sealed class PlayerStartedEventArgs : public EventArgs
JScript .NET | public class PlayerStartedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerStartedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerStartedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerStartedEventArgs.PlayerStartedEventArgs(PlayerVoiceStartMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStartedEventArgs.PlayerStartedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As PlayerVoiceStartMessage _
)
C# public PlayerStartedEventArgs(
PlayerVoiceStartMessage dpMessage
);
Managed C++ public: PlayerStartedEventArgs(
PlayerVoiceStartMessage dpMessage
);
JScript .NET public function PlayerStartedEventArgs(
dpMessage : PlayerVoiceStartMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStartMessage.


PlayerStartedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStartedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As PlayerVoiceStartMessage
C# | public PlayerVoiceStartMessage Message;
Managed C++ | public: PlayerVoiceStartMessage Message;
JScript .NET | public var Message : PlayerVoiceStartMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStartMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.PlayerStoppedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStoppedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStopped event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayerStoppedEventArgs
Inherits EventArgs
C# | public sealed class PlayerStoppedEventArgs : EventArgs
Managed C++ | public __gc __sealed class PlayerStoppedEventArgs : public EventArgs
JScript .NET | public class PlayerStoppedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerStoppedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerStoppedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerStoppedEventArgs.PlayerStoppedEventArgs(PlayerVoiceStopMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStoppedEventArgs.PlayerStoppedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As PlayerVoiceStopMessage _
)
C# public PlayerStoppedEventArgs(
PlayerVoiceStopMessage dpMessage
);
Managed C++ public: PlayerStoppedEventArgs(
PlayerVoiceStopMessage dpMessage
);
JScript .NET public function PlayerStoppedEventArgs(
dpMessage : PlayerVoiceStopMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStopMessage.


PlayerStoppedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStoppedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As PlayerVoiceStopMessage
C# | public PlayerVoiceStopMessage Message;
Managed C++ | public: PlayerVoiceStopMessage Message;
JScript .NET | public var Message : PlayerVoiceStopMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStopMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.RecordStartedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStarted event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class RecordStartedEventArgs
Inherits EventArgs
C# | public sealed class RecordStartedEventArgs : EventArgs
Managed C++ | public __gc __sealed class RecordStartedEventArgs : public EventArgs
JScript .NET | public class RecordStartedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
RecordStartedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
RecordStartedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordStartedEventArgs.RecordStartedEventArgs(RecordStartMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartedEventArgs.RecordStartedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As RecordStartMessage _
)
C# public RecordStartedEventArgs(
RecordStartMessage dpMessage
);
Managed C++ public: RecordStartedEventArgs(
RecordStartMessage dpMessage
);
JScript .NET public function RecordStartedEventArgs(
dpMessage : RecordStartMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.RecordStartMessage.


RecordStartedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As RecordStartMessage
C# | public RecordStartMessage Message;
Managed C++ | public: RecordStartMessage Message;
JScript .NET | public var Message : RecordStartMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.RecordStartMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.RecordStoppedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStoppedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStopped event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class RecordStoppedEventArgs
Inherits EventArgs
C# | public sealed class RecordStoppedEventArgs : EventArgs
Managed C++ | public __gc __sealed class RecordStoppedEventArgs : public EventArgs
JScript .NET | public class RecordStoppedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
RecordStoppedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
RecordStoppedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordStoppedEventArgs.RecordStoppedEventArgs(RecordStopMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStoppedEventArgs.RecordStoppedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As RecordStopMessage _
)
C# public RecordStoppedEventArgs(
RecordStopMessage dpMessage
);
Managed C++ public: RecordStoppedEventArgs(
RecordStopMessage dpMessage
);
JScript .NET public function RecordStoppedEventArgs(
dpMessage : RecordStopMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.RecordStopMessage.


RecordStoppedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStoppedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As RecordStopMessage
C# | public RecordStopMessage Message;
Managed C++ | public: RecordStopMessage Message;
JScript .NET | public var Message : RecordStopMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.RecordStopMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.RecordSystemErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordSystemErrorException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the recording system occurred. Deprecated.

Definition

Visual Basic .NET Public Class RecordSystemErrorException
Inherits VoiceException
C# | public class RecordSystemErrorException : VoiceException
Managed C++ | public __gc class RecordSystemErrorException : public VoiceException
JScript .NET | public class RecordSystemErrorException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
RecordSystemErrorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
RecordSystemErrorException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordSystemErrorException.RecordSystemErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public RecordSystemErrorException();
protected RecordSystemErrorException(SerializationInfo, StreamingContext);
public RecordSystemErrorException(string);
public RecordSystemErrorException(string, Exception);


RecordSystemErrorException.RecordSystemErrorException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected RecordSystemErrorException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: RecordSystemErrorException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function RecordSystemErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


RecordSystemErrorException.RecordSystemErrorException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public RecordSystemErrorException(
string message,
Exception inner
);
Managed C++ public: RecordSystemErrorException(
String *message,
Exception *inner
);
JScript .NET public function RecordSystemErrorException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


RecordSystemErrorException.RecordSystemErrorException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public RecordSystemErrorException(
string message
);
Managed C++ public: RecordSystemErrorException(
String *message
);
JScript .NET public function RecordSystemErrorException(
message : String
);

Parameters

message System.String.


RecordSystemErrorException.RecordSystemErrorException()

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public RecordSystemErrorException();
Managed C++ | public: RecordSystemErrorException();
JScript .NET | public function RecordSystemErrorException();


Microsoft.DirectX.DirectPlay.Voice.RunSetupException

Microsoft DirectX 9.0 SDK Update (October 2004)

RunSetupException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified audio configuration has not been tested. Call the Test.CheckAudioSetup method. Deprecated.

Definition

Visual Basic .NET Public Class RunSetupException
Inherits VoiceException
C# | public class RunSetupException : VoiceException
Managed C++ | public __gc class RunSetupException : public VoiceException
JScript .NET | public class RunSetupException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
RunSetupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
RunSetupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RunSetupException.RunSetupException

Microsoft DirectX 9.0 SDK Update (October 2004)

RunSetupException.RunSetupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public RunSetupException();
protected RunSetupException(SerializationInfo, StreamingContext);
public RunSetupException(string);
public RunSetupException(string, Exception);


RunSetupException.RunSetupException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

RunSetupException.RunSetupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected RunSetupException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: RunSetupException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function RunSetupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


RunSetupException.RunSetupException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

RunSetupException.RunSetupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public RunSetupException(
string message,
Exception inner
);
Managed C++ public: RunSetupException(
String *message,
Exception *inner
);
JScript .NET public function RunSetupException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


RunSetupException.RunSetupException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

RunSetupException.RunSetupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public RunSetupException(
string message
);
Managed C++ public: RunSetupException(
String *message
);
JScript .NET public function RunSetupException(
message : String
);

Parameters

message System.String.


RunSetupException.RunSetupException()

Microsoft DirectX 9.0 SDK Update (October 2004)

RunSetupException.RunSetupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public RunSetupException();
Managed C++ | public: RunSetupException();
JScript .NET | public function RunSetupException();


Microsoft.DirectX.DirectPlay.Voice.SendErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

SendErrorException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error occurred while sending data. Deprecated.

Definition

Visual Basic .NET Public Class SendErrorException
Inherits VoiceException
C# | public class SendErrorException : VoiceException
Managed C++ | public __gc class SendErrorException : public VoiceException
JScript .NET | public class SendErrorException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SendErrorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
SendErrorException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SendErrorException.SendErrorException

Microsoft DirectX 9.0 SDK Update (October 2004)

SendErrorException.SendErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SendErrorException();
protected SendErrorException(SerializationInfo, StreamingContext);
public SendErrorException(string);
public SendErrorException(string, Exception);


SendErrorException.SendErrorException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendErrorException.SendErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SendErrorException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SendErrorException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SendErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SendErrorException.SendErrorException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendErrorException.SendErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SendErrorException(
string message,
Exception inner
);
Managed C++ public: SendErrorException(
String *message,
Exception *inner
);
JScript .NET public function SendErrorException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SendErrorException.SendErrorException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendErrorException.SendErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SendErrorException(
string message
);
Managed C++ public: SendErrorException(
String *message
);
JScript .NET public function SendErrorException(
message : String
);

Parameters

message System.String.


SendErrorException.SendErrorException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SendErrorException.SendErrorException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SendErrorException();
Managed C++ | public: SendErrorException();
JScript .NET | public function SendErrorException();


Microsoft.DirectX.DirectPlay.Voice.Server

Microsoft DirectX 9.0 SDK Update (October 2004)

Server Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to manage the host of the voice session. Deprecated.

Definition

Visual Basic .NET Public Class Server
Inherits MarshalByRefObject
Implements IDisposable
C# public class Server : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Server : public MarshalByRefObject,
IDisposable
JScript .NET public class Server extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDeleted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
SessionLost
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a session is lost. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetTransmitTargets
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the transmit targets, if any, of the voice stream for a player in a session. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDeleted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionLost
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Server
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetTransmitTargets
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the transmission of audio from the client to the specified members of the session. Deprecated.
StartSession
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Starts an initialized Microsoft® DirectPlay® Voice session within a running Microsoft® DirectPlay® transport session. This method must be successfully called before the clients can complete a connection to the voice session. Deprecated.
StopSession
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Properties

Property Description
CompressionTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves available compression types for the system. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
SessionDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Microsoft DirectPlay® Voice session settings. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Server

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Server.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


Server.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Server.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Server();
Managed C++ | ~Server();
JScript .NET | protected override function Finalize();


Server.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Server.GetTransmitTargets(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetTransmitTargets Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the transmit targets, if any, of the voice stream for a player in a session. Deprecated.

Definition

Visual Basic .NET Public Function GetTransmitTargets( _
ByVal sourceID As Integer _
) As Integer()
C# public int[] GetTransmitTargets(
int sourceID
);
Managed C++ public: int GetTransmitTargets(
int sourceID
) __gc[];
JScript .NET public function GetTransmitTargets(
sourceID : int
) : int[];

Parameters

sourceID System.Int32.

Return Value

System.Int32[].


Server.op_Equality(Server,Server)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Equality(
Server left,
Server right
);
Managed C++ public: static bool op_Equality(
Server *left,
Server *right
);
JScript .NET public static function op_Equality(
left : Server,
right : Server
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Voice.Server. The Server structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Voice.Server. The Server structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Server.op_Inequality(Server,Server)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Inequality(
Server left,
Server right
);
Managed C++ public: static bool op_Inequality(
Server *left,
Server *right
);
JScript .NET public static function op_Inequality(
left : Server,
right : Server
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Voice.Server. The Server structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Voice.Server. The Server structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Server.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Server.raise_PlayerCreated(Object,VoicePlayerCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_PlayerCreated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
VoicePlayerCreatedEventArgs i2
);
Managed C++ protected: void raise_PlayerCreated(
Object *i1,
VoicePlayerCreatedEventArgs *i2
);
JScript .NET protected function raise_PlayerCreated(
i1 : Object,
i2 : VoicePlayerCreatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.VoicePlayerCreatedEventArgs.


Server.raise_PlayerDeleted(Object,VoicePlayerDeletedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_PlayerDeleted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerDeleted( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerDeletedEventArgs _
)
C# protected void raise_PlayerDeleted(
object i1,
VoicePlayerDeletedEventArgs i2
);
Managed C++ protected: void raise_PlayerDeleted(
Object *i1,
VoicePlayerDeletedEventArgs *i2
);
JScript .NET protected function raise_PlayerDeleted(
i1 : Object,
i2 : VoicePlayerDeletedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.VoicePlayerDeletedEventArgs.


Server.raise_SessionLost(Object,SessionLostEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_SessionLost Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SessionLost( _
ByVal i1 As Object, _
ByVal i2 As SessionLostEventArgs _
)
C# protected void raise_SessionLost(
object i1,
SessionLostEventArgs i2
);
Managed C++ protected: void raise_SessionLost(
Object *i1,
SessionLostEventArgs *i2
);
JScript .NET protected function raise_SessionLost(
i1 : Object,
i2 : SessionLostEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.Voice.SessionLostEventArgs.


Server.Server

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Server Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Server(object);
public Server(object, int[]);


Server.Server(Object,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Server Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dplayObject As Object, _
ByVal msgMask() As Integer _
)
C# public Server(
object dplayObject,
int[] msgMask
);
Managed C++ public: Server(
Object *dplayObject,
int msgMask __gc[]
);
JScript .NET public function Server(
dplayObject : Object,
msgMask : int[]
);

Parameters

dplayObject | System.Object.
msgMask | System.Int32[].


Server.Server(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Server Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dplayObject As Object _
)
C# public Server(
object dplayObject
);
Managed C++ public: Server(
Object *dplayObject
);
JScript .NET public function Server(
dplayObject : Object
);

Parameters

dplayObject System.Object.


Server.SetTransmitTargets(Int32,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetTransmitTargets Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the transmission of audio from the client to the specified members of the session. Deprecated.

Definition

Visual Basic .NET Public Sub SetTransmitTargets( _
ByVal sourceID As Integer, _
ByVal targets() As Integer _
)
C# public void SetTransmitTargets(
int sourceID,
int[] targets
);
Managed C++ public: void SetTransmitTargets(
int sourceID,
int targets __gc[]
);
JScript .NET public function SetTransmitTargets(
sourceID : int,
targets : int[]
);

Parameters

sourceID | System.Int32.
targets | System.Int32[].


Server.StartSession(SessionDescription)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.StartSession Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Starts an initialized Microsoft® DirectPlay® Voice session within a running Microsoft® DirectPlay® transport session. This method must be successfully called before the clients can complete a connection to the voice session. Deprecated.

Definition

Visual Basic .NET Public Sub StartSession( _
ByVal sessionDescription As SessionDescription _
)
C# public void StartSession(
SessionDescription sessionDescription
);
Managed C++ public: void StartSession(
SessionDescription sessionDescription
);
JScript .NET public function StartSession(
sessionDescription : SessionDescription
);

Parameters

sessionDescription Microsoft.DirectX.DirectPlay.Voice.SessionDescription.


Server.StopSession

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.StopSession Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Overload List

public void StopSession();
public void StopSession(StopSessionFlags);


Server.StopSession()

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.StopSession Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic .NET | Public Sub StopSession()
C# | public void StopSession();
Managed C++ | public: void StopSession();
JScript .NET | public function StopSession();


Server.StopSession(StopSessionFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.StopSession Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic .NET Public Sub StopSession( _
ByVal flags As StopSessionFlags _
)
C# public void StopSession(
StopSessionFlags flags
);
Managed C++ public: void StopSession(
StopSessionFlags flags
);
JScript .NET public function StopSession(
flags : StopSessionFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Voice.StopSessionFlags.


Server.CompressionTypes

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CompressionTypes Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves available compression types for the system. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property CompressionTypes As CompressionInformation()
C# | public CompressionInformation[] CompressionTypes { get; }
Managed C++ | public: __property CompressionInformation get_CompressionTypes();
JScript .NET | public function get CompressionTypes() : CompressionInformation[]

Property Value

Microsoft.DirectX.DirectPlay.Voice.CompressionInformation[] .

This property is read-only.


Server.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Server.SessionDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SessionDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Microsoft® DirectPlay® Voice session settings. Deprecated.

Definition

Visual Basic .NET | Public Property SessionDescription As SessionDescription
C# | public SessionDescription SessionDescription { get; set; }
Managed C++ public: __property SessionDescription get_SessionDescription();
public: __property void set_SessionDescription(SessionDescription);
JScript .NET public function get SessionDescription() : SessionDescription
public function set SessionDescription(SessionDescription);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionDescription .

This property is read/write.


Server.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Server.Disposing event, use the following code.

server.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Server.PlayerCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.PlayerCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerCreated As VoicePlayerCreatedEventHandler
C# | public event VoicePlayerCreatedEventHandler PlayerCreated;
Managed C++ | public: __event VoicePlayerCreatedEventHandler PlayerCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.PlayerDeleted

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.PlayerDeleted Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerDeleted As VoicePlayerDeletedEventHandler
C# | public event VoicePlayerDeletedEventHandler PlayerDeleted;
Managed C++ | public: __event VoicePlayerDeletedEventHandler PlayerDeleted;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.SessionLost

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SessionLost Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a session is lost. Deprecated.

Definition

Visual Basic .NET | Public Event SessionLost As SessionLostEventHandler
C# | public event SessionLostEventHandler SessionLost;
Managed C++ | public: __event SessionLostEventHandler SessionLost;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.Voice.SessionLostEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SessionLostEventArgs
Inherits EventArgs
C# | public sealed class SessionLostEventArgs : EventArgs
Managed C++ | public __gc __sealed class SessionLostEventArgs : public EventArgs
JScript .NET | public class SessionLostEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SessionLostEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SessionLostEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionLostEventArgs.SessionLostEventArgs(SessionLostMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostEventArgs.SessionLostEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As SessionLostMessage _
)
C# public SessionLostEventArgs(
SessionLostMessage dpMessage
);
Managed C++ public: SessionLostEventArgs(
SessionLostMessage dpMessage
);
JScript .NET public function SessionLostEventArgs(
dpMessage : SessionLostMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.SessionLostMessage.


SessionLostEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As SessionLostMessage
C# | public SessionLostMessage Message;
Managed C++ | public: SessionLostMessage Message;
JScript .NET | public var Message : SessionLostMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.SessionLostMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.SessionLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The transport has lost the connection to the session. Deprecated.

Definition

Visual Basic .NET Public Class SessionLostException
Inherits VoiceException
C# | public class SessionLostException : VoiceException
Managed C++ | public __gc class SessionLostException : public VoiceException
JScript .NET | public class SessionLostException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SessionLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
SessionLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionLostException.SessionLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostException.SessionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SessionLostException();
protected SessionLostException(SerializationInfo, StreamingContext);
public SessionLostException(string);
public SessionLostException(string, Exception);


SessionLostException.SessionLostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostException.SessionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SessionLostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SessionLostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SessionLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SessionLostException.SessionLostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostException.SessionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SessionLostException(
string message,
Exception inner
);
Managed C++ public: SessionLostException(
String *message,
Exception *inner
);
JScript .NET public function SessionLostException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SessionLostException.SessionLostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostException.SessionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SessionLostException(
string message
);
Managed C++ public: SessionLostException(
String *message
);
JScript .NET public function SessionLostException(
message : String
);

Parameters

message System.String.


SessionLostException.SessionLostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostException.SessionLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SessionLostException();
Managed C++ | public: SessionLostException();
JScript .NET | public function SessionLostException();


Microsoft.DirectX.DirectPlay.Voice.SetTargetsEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

SetTargetsEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SetTargets event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SetTargetsEventArgs
Inherits EventArgs
C# | public sealed class SetTargetsEventArgs : EventArgs
Managed C++ | public __gc __sealed class SetTargetsEventArgs : public EventArgs
JScript .NET | public class SetTargetsEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SetTargetsEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SetTargetsEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SetTargetsEventArgs.SetTargetsEventArgs(SetTargetsMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

SetTargetsEventArgs.SetTargetsEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As SetTargetsMessage _
)
C# public SetTargetsEventArgs(
SetTargetsMessage dpMessage
);
Managed C++ public: SetTargetsEventArgs(
SetTargetsMessage dpMessage
);
JScript .NET public function SetTargetsEventArgs(
dpMessage : SetTargetsMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.SetTargetsMessage.


SetTargetsEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

SetTargetsEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As SetTargetsMessage
C# | public SetTargetsMessage Message;
Managed C++ | public: SetTargetsMessage Message;
JScript .NET | public var Message : SetTargetsMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.SetTargetsMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.SoundInitializeFailureException

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundInitializeFailureException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A failure was encountered initializing the sound card. Deprecated.

Definition

Visual Basic .NET Public Class SoundInitializeFailureException
Inherits VoiceException
C# | public class SoundInitializeFailureException : VoiceException
Managed C++ | public __gc class SoundInitializeFailureException : public VoiceException
JScript .NET | public class SoundInitializeFailureException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SoundInitializeFailureException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
SoundInitializeFailureException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SoundInitializeFailureException.SoundInitializeFailureException

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SoundInitializeFailureException();
protected SoundInitializeFailureException(SerializationInfo, StreamingContext);
public SoundInitializeFailureException(string);
public SoundInitializeFailureException(string, Exception);


SoundInitializeFailureException.SoundInitializeFailureException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SoundInitializeFailureException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SoundInitializeFailureException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SoundInitializeFailureException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SoundInitializeFailureException.SoundInitializeFailureException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SoundInitializeFailureException(
string message,
Exception inner
);
Managed C++ public: SoundInitializeFailureException(
String *message,
Exception *inner
);
JScript .NET public function SoundInitializeFailureException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SoundInitializeFailureException.SoundInitializeFailureException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SoundInitializeFailureException(
string message
);
Managed C++ public: SoundInitializeFailureException(
String *message
);
JScript .NET public function SoundInitializeFailureException(
message : String
);

Parameters

message System.String.


SoundInitializeFailureException.SoundInitializeFailureException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SoundInitializeFailureException();
Managed C++ | public: SoundInitializeFailureException();
JScript .NET | public function SoundInitializeFailureException();


Microsoft.DirectX.DirectPlay.Voice.Test

Microsoft DirectX 9.0 SDK Update (October 2004)

Test Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the Test.CheckAudioSetup method of the Test object to test the Microsoft® DirectPlay® Voice audio configuration. Deprecated.

Definition

Visual Basic .NET Public Class Test
Inherits MarshalByRefObject
Implements IDisposable
C# public class Test : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Test : public MarshalByRefObject,
IDisposable
JScript .NET public class Test extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
CheckAudioSetup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Test
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Test

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Test.CheckAudioSetup

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.CheckAudioSetup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Overload List

public void CheckAudioSetup();
public void CheckAudioSetup(Guid, Guid);
public void CheckAudioSetup(Guid, Guid, Control, TestFlags);
public void CheckAudioSetup(Guid, Guid, TestFlags);


Test.CheckAudioSetup()

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.CheckAudioSetup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic .NET | Public Sub CheckAudioSetup()
C# | public void CheckAudioSetup();
Managed C++ | public: void CheckAudioSetup();
JScript .NET | public function CheckAudioSetup();


Test.CheckAudioSetup(Guid,Guid,TestFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.CheckAudioSetup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic .NET Public Sub CheckAudioSetup( _
ByVal guidPlayback As Guid, _
ByVal guidCapture As Guid, _
ByVal flags As TestFlags _
)
C# public void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
TestFlags flags
);
Managed C++ public: void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
TestFlags flags
);
JScript .NET public function CheckAudioSetup(
guidPlayback : Guid,
guidCapture : Guid,
flags : TestFlags
);

Parameters

guidPlayback | System.Guid.
guidCapture | System.Guid.
flags | Microsoft.DirectX.DirectPlay.Voice.TestFlags.


Test.CheckAudioSetup(Guid,Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.CheckAudioSetup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic .NET Public Sub CheckAudioSetup( _
ByVal guidPlayback As Guid, _
ByVal guidCapture As Guid _
)
C# public void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture
);
Managed C++ public: void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture
);
JScript .NET public function CheckAudioSetup(
guidPlayback : Guid,
guidCapture : Guid
);

Parameters

guidPlayback | System.Guid.
guidCapture | System.Guid.


Test.CheckAudioSetup(Guid,Guid,Control,TestFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.CheckAudioSetup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic .NET Public Sub CheckAudioSetup( _
ByVal guidPlayback As Guid, _
ByVal guidCapture As Guid, _
ByVal window As Control, _
ByVal flags As TestFlags _
)
C# public void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
Control window,
TestFlags flags
);
Managed C++ public: void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
Control *window,
TestFlags flags
);
JScript .NET public function CheckAudioSetup(
guidPlayback : Guid,
guidCapture : Guid,
window : Control,
flags : TestFlags
);

Parameters

guidPlayback | System.Guid.
guidCapture | System.Guid.
window | System.Windows.Forms.Control.
flags | Microsoft.DirectX.DirectPlay.Voice.TestFlags.


Test.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Test.Dispose
  • Test.Disposing


Test.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Test();
Managed C++ | ~Test();
JScript .NET | protected override function Finalize();


Test.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Test.Test()

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.Test Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Test();
Managed C++ | public: Test();
JScript .NET | public function Test();


Test.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Test.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Test.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Test.Disposing event, use the following code.

test.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectPlay.Voice.TimedOutException

Microsoft DirectX 9.0 SDK Update (October 2004)

TimedOutException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.

Definition

Visual Basic .NET Public Class TimedOutException
Inherits VoiceException
C# | public class TimedOutException : VoiceException
Managed C++ | public __gc class TimedOutException : public VoiceException
JScript .NET | public class TimedOutException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TimedOutException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TimedOutException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TimedOutException.TimedOutException

Microsoft DirectX 9.0 SDK Update (October 2004)

TimedOutException.TimedOutException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TimedOutException();
protected TimedOutException(SerializationInfo, StreamingContext);
public TimedOutException(string);
public TimedOutException(string, Exception);


TimedOutException.TimedOutException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TimedOutException.TimedOutException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TimedOutException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TimedOutException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TimedOutException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TimedOutException.TimedOutException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TimedOutException.TimedOutException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TimedOutException(
string message,
Exception inner
);
Managed C++ public: TimedOutException(
String *message,
Exception *inner
);
JScript .NET public function TimedOutException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TimedOutException.TimedOutException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TimedOutException.TimedOutException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TimedOutException(
string message
);
Managed C++ public: TimedOutException(
String *message
);
JScript .NET public function TimedOutException(
message : String
);

Parameters

message System.String.


TimedOutException.TimedOutException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TimedOutException.TimedOutException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TimedOutException();
Managed C++ | public: TimedOutException();
JScript .NET | public function TimedOutException();


Microsoft.DirectX.DirectPlay.Voice.TransportNoPlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoPlayerException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is connected/hosting but no local player exists. Deprecated.

Definition

Visual Basic .NET Public Class TransportNoPlayerException
Inherits VoiceException
C# | public class TransportNoPlayerException : VoiceException
Managed C++ | public __gc class TransportNoPlayerException : public VoiceException
JScript .NET | public class TransportNoPlayerException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
TransportNoPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TransportNoPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TransportNoPlayerException.TransportNoPlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TransportNoPlayerException();
protected TransportNoPlayerException(SerializationInfo, StreamingContext);
public TransportNoPlayerException(string);
public TransportNoPlayerException(string, Exception);


TransportNoPlayerException.TransportNoPlayerException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TransportNoPlayerException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TransportNoPlayerException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TransportNoPlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TransportNoPlayerException.TransportNoPlayerException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TransportNoPlayerException(
string message,
Exception inner
);
Managed C++ public: TransportNoPlayerException(
String *message,
Exception *inner
);
JScript .NET public function TransportNoPlayerException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TransportNoPlayerException.TransportNoPlayerException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TransportNoPlayerException(
string message
);
Managed C++ public: TransportNoPlayerException(
String *message
);
JScript .NET public function TransportNoPlayerException(
message : String
);

Parameters

message System.String.


TransportNoPlayerException.TransportNoPlayerException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TransportNoPlayerException();
Managed C++ | public: TransportNoPlayerException();
JScript .NET | public function TransportNoPlayerException();


Microsoft.DirectX.DirectPlay.Voice.TransportNoSessionException

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoSessionException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is valid but is not connected/hosting. Deprecated.

Definition

Visual Basic .NET Public Class TransportNoSessionException
Inherits VoiceException
C# | public class TransportNoSessionException : VoiceException
Managed C++ | public __gc class TransportNoSessionException : public VoiceException
JScript .NET | public class TransportNoSessionException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
TransportNoSessionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TransportNoSessionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TransportNoSessionException.TransportNoSessionException

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TransportNoSessionException();
protected TransportNoSessionException(SerializationInfo, StreamingContext);
public TransportNoSessionException(string);
public TransportNoSessionException(string, Exception);


TransportNoSessionException.TransportNoSessionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TransportNoSessionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TransportNoSessionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TransportNoSessionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TransportNoSessionException.TransportNoSessionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TransportNoSessionException(
string message,
Exception inner
);
Managed C++ public: TransportNoSessionException(
String *message,
Exception *inner
);
JScript .NET public function TransportNoSessionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TransportNoSessionException.TransportNoSessionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TransportNoSessionException(
string message
);
Managed C++ public: TransportNoSessionException(
String *message
);
JScript .NET public function TransportNoSessionException(
message : String
);

Parameters

message System.String.


TransportNoSessionException.TransportNoSessionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TransportNoSessionException();
Managed C++ | public: TransportNoSessionException();
JScript .NET | public function TransportNoSessionException();


Microsoft.DirectX.DirectPlay.Voice.TransportNotHostException

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNotHostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the voice session. Deprecated.

Definition

Visual Basic .NET Public Class TransportNotHostException
Inherits VoiceException
C# | public class TransportNotHostException : VoiceException
Managed C++ | public __gc class TransportNotHostException : public VoiceException
JScript .NET | public class TransportNotHostException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
TransportNotHostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TransportNotHostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TransportNotHostException.TransportNotHostException

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNotHostException.TransportNotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TransportNotHostException();
protected TransportNotHostException(SerializationInfo, StreamingContext);
public TransportNotHostException(string);
public TransportNotHostException(string, Exception);


TransportNotHostException.TransportNotHostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNotHostException.TransportNotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TransportNotHostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TransportNotHostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TransportNotHostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TransportNotHostException.TransportNotHostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNotHostException.TransportNotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TransportNotHostException(
string message,
Exception inner
);
Managed C++ public: TransportNotHostException(
String *message,
Exception *inner
);
JScript .NET public function TransportNotHostException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TransportNotHostException.TransportNotHostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNotHostException.TransportNotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TransportNotHostException(
string message
);
Managed C++ public: TransportNotHostException(
String *message
);
JScript .NET public function TransportNotHostException(
message : String
);

Parameters

message System.String.


TransportNotHostException.TransportNotHostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TransportNotHostException.TransportNotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TransportNotHostException();
Managed C++ | public: TransportNotHostException();
JScript .NET | public function TransportNotHostException();


Microsoft.DirectX.DirectPlay.Voice.UserBackException

Microsoft DirectX 9.0 SDK Update (October 2004)

UserBackException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user has pressed back on the first page of the CheckAudioSetup wizard. Deprecated.

Definition

Visual Basic .NET Public Class UserBackException
Inherits VoiceException
C# | public class UserBackException : VoiceException
Managed C++ | public __gc class UserBackException : public VoiceException
JScript .NET | public class UserBackException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UserBackException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
UserBackException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UserBackException.UserBackException

Microsoft DirectX 9.0 SDK Update (October 2004)

UserBackException.UserBackException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UserBackException();
protected UserBackException(SerializationInfo, StreamingContext);
public UserBackException(string);
public UserBackException(string, Exception);


UserBackException.UserBackException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UserBackException.UserBackException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UserBackException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UserBackException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UserBackException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UserBackException.UserBackException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UserBackException.UserBackException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UserBackException(
string message,
Exception inner
);
Managed C++ public: UserBackException(
String *message,
Exception *inner
);
JScript .NET public function UserBackException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UserBackException.UserBackException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UserBackException.UserBackException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UserBackException(
string message
);
Managed C++ public: UserBackException(
String *message
);
JScript .NET public function UserBackException(
message : String
);

Parameters

message System.String.


UserBackException.UserBackException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UserBackException.UserBackException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public UserBackException();
Managed C++ | public: UserBackException();
JScript .NET | public function UserBackException();


Microsoft.DirectX.DirectPlay.Voice.UserCancelException

Microsoft DirectX 9.0 SDK Update (October 2004)

UserCancelException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.

Definition

Visual Basic .NET Public Class UserCancelException
Inherits VoiceException
C# | public class UserCancelException : VoiceException
Managed C++ | public __gc class UserCancelException : public VoiceException
JScript .NET | public class UserCancelException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UserCancelException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
UserCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UserCancelException.UserCancelException

Microsoft DirectX 9.0 SDK Update (October 2004)

UserCancelException.UserCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UserCancelException();
protected UserCancelException(SerializationInfo, StreamingContext);
public UserCancelException(string);
public UserCancelException(string, Exception);


UserCancelException.UserCancelException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UserCancelException.UserCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UserCancelException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UserCancelException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UserCancelException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


UserCancelException.UserCancelException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UserCancelException.UserCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UserCancelException(
string message,
Exception inner
);
Managed C++ public: UserCancelException(
String *message,
Exception *inner
);
JScript .NET public function UserCancelException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


UserCancelException.UserCancelException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UserCancelException.UserCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UserCancelException(
string message
);
Managed C++ public: UserCancelException(
String *message
);
JScript .NET public function UserCancelException(
message : String
);

Parameters

message System.String.


UserCancelException.UserCancelException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UserCancelException.UserCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public UserCancelException();
Managed C++ | public: UserCancelException();
JScript .NET | public function UserCancelException();


Microsoft.DirectX.DirectPlay.Voice.VoiceException

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for DirectPlay Voice exceptions. Derives from DirectXException. Deprecated.

Definition

Visual Basic .NET Public Class VoiceException
Inherits DirectPlayException
C# | public class VoiceException : DirectPlayException
Managed C++ | public __gc class VoiceException : public DirectPlayException
JScript .NET | public class VoiceException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
VoiceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
AlreadyBufferedException
AlreadyPendingException
CompressionNotSupportedException
ConnectAbortedException
ConnectAbortingException
ConnectedException
ConnectionLostException
HostingException
IncompatibleVersionException
InvalidBufferException
InvalidDeviceException
InvalidFlagsException
InvalidGroupException
InvalidHandleException
InvalidObjectException
InvalidPlayerException
InvalidTargetException
LockedBufferException
No3DSoundException
NoRecordVolumeAvailableException
NotAllowedException
NotBufferedException
NotConnectedException
NotHostingException
NoTransportException
NotSupportedException
NoVoiceSessionException
PlaybackSystemErrorException
RecordSystemErrorException
RunSetupException
SendErrorException
SessionLostException
SoundInitializeFailureException
TimedOutException
TransportNoPlayerException
TransportNoSessionException
TransportNotHostException
UserBackException
UserCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VoiceException.GetExceptionFromResultInternal(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceException.GetExceptionFromResultInternal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32.

Return Value

System.Exception .

Applies To

This object applies to a large number of classes.


VoiceException.VoiceException

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceException.VoiceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public VoiceException();
protected VoiceException(SerializationInfo, StreamingContext);
public VoiceException(string);
public VoiceException(string, Exception);


VoiceException.VoiceException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceException.VoiceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected VoiceException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: VoiceException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function VoiceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


VoiceException.VoiceException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceException.VoiceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public VoiceException(
string message,
Exception inner
);
Managed C++ public: VoiceException(
String *message,
Exception *inner
);
JScript .NET public function VoiceException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


VoiceException.VoiceException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceException.VoiceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public VoiceException(
string message
);
Managed C++ public: VoiceException(
String *message
);
JScript .NET public function VoiceException(
message : String
);

Parameters

message System.String.


VoiceException.VoiceException()

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceException.VoiceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public VoiceException();
Managed C++ | public: VoiceException();
JScript .NET | public function VoiceException();


Microsoft.DirectX.DirectPlay.Voice.VoicePlayerCreatedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerCreatedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class VoicePlayerCreatedEventArgs
Inherits EventArgs
C# | public sealed class VoicePlayerCreatedEventArgs : EventArgs
Managed C++ | public __gc __sealed class VoicePlayerCreatedEventArgs : public EventArgs
JScript .NET | public class VoicePlayerCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
VoicePlayerCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
VoicePlayerCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VoicePlayerCreatedEventArgs.VoicePlayerCreatedEventArgs(CreateVoicePlayerMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerCreatedEventArgs.VoicePlayerCreatedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As CreateVoicePlayerMessage _
)
C# public VoicePlayerCreatedEventArgs(
CreateVoicePlayerMessage dpMessage
);
Managed C++ public: VoicePlayerCreatedEventArgs(
CreateVoicePlayerMessage dpMessage
);
JScript .NET public function VoicePlayerCreatedEventArgs(
dpMessage : CreateVoicePlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.CreateVoicePlayerMessage.


VoicePlayerCreatedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerCreatedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As CreateVoicePlayerMessage
C# | public CreateVoicePlayerMessage Message;
Managed C++ | public: CreateVoicePlayerMessage Message;
JScript .NET | public var Message : CreateVoicePlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.CreateVoicePlayerMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.Voice.VoicePlayerDeletedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerDeletedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDeleted event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class VoicePlayerDeletedEventArgs
Inherits EventArgs
C# | public sealed class VoicePlayerDeletedEventArgs : EventArgs
Managed C++ | public __gc __sealed class VoicePlayerDeletedEventArgs : public EventArgs
JScript .NET | public class VoicePlayerDeletedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
VoicePlayerDeletedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
VoicePlayerDeletedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VoicePlayerDeletedEventArgs.VoicePlayerDeletedEventArgs(DeleteVoicePlayerMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerDeletedEventArgs.VoicePlayerDeletedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As DeleteVoicePlayerMessage _
)
C# public VoicePlayerDeletedEventArgs(
DeleteVoicePlayerMessage dpMessage
);
Managed C++ public: VoicePlayerDeletedEventArgs(
DeleteVoicePlayerMessage dpMessage
);
JScript .NET public function VoicePlayerDeletedEventArgs(
dpMessage : DeleteVoicePlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.DeleteVoicePlayerMessage.


VoicePlayerDeletedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerDeletedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As DeleteVoicePlayerMessage
C# | public DeleteVoicePlayerMessage Message;
Managed C++ | public: DeleteVoicePlayerMessage Message;
JScript .NET | public var Message : DeleteVoicePlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.DeleteVoicePlayerMessage .

This field is read/write.


BufferAggressiveness

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferAggressiveness Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferAggressiveness. Deprecated.

Definition

Visual Basic .NET | Public Enum BufferAggressiveness
C# | public enum BufferAggressiveness
Managed C++ | __value public enum BufferAggressiveness
JScript .NET | public enum BufferAggressiveness

Members

Member | Value | Description
Default | 0
Max | 100
Min | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BufferQuality

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferQuality Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferQuality. Deprecated.

Definition

Visual Basic .NET | Public Enum BufferQuality
C# | public enum BufferQuality
Managed C++ | __value public enum BufferQuality
JScript .NET | public enum BufferQuality

Members

Member | Value | Description
Default | 0
Max | 100
Min | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClientConfigFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfigFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for client configuration. Deprecated.

Definition

Visual Basic .NET | Public Enum ClientConfigFlags
C# | public enum ClientConfigFlags
Managed C++ | __value public enum ClientConfigFlags
JScript .NET | public enum ClientConfigFlags

Members

Member | Value | Description
EchoSuppression | 134217728
AutoVoiceActivated | 32
MuteGlobal | 16
AutoRecordVolume | 8
ManualVoiceActivated | 4
PlaybackMute | 2
RecordMute | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputLevelFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for input level. Deprecated.

Definition

Visual Basic .NET | Public Enum InputLevelFlags
C# | public enum InputLevelFlags
Managed C++ | __value public enum InputLevelFlags
JScript .NET | public enum InputLevelFlags

Members

Member | Value | Description
Max | 99
Min | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotifyPeriod

Microsoft DirectX 9.0 SDK Update (October 2004)

NotifyPeriod Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for NotifyPeriod. Deprecated.

Definition

Visual Basic .NET | Public Enum NotifyPeriod
C# | public enum NotifyPeriod
Managed C++ | __value public enum NotifyPeriod
JScript .NET | public enum NotifyPeriod

Members

Member | Value | Description
Minimum | 20

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlaybackVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

PlaybackVolume Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for PlaybackVolume. Deprecated.

Definition

Visual Basic .NET | Public Enum PlaybackVolume
C# | public enum PlaybackVolume
Managed C++ | __value public enum PlaybackVolume
JScript .NET | public enum PlaybackVolume

Members

Member | Value | Description
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerCapsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerCapsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player capability flags. Deprecated.

Definition

Visual Basic .NET | Public Enum PlayerCapsFlags
C# | public enum PlayerCapsFlags
Managed C++ | __value public enum PlayerCapsFlags
JScript .NET | public enum PlayerCapsFlags

Members

Member | Value | Description
Local | 2
HalfDuplex | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerId

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerId Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
System wide player id's. Deprecated.

Definition

Visual Basic .NET | Public Enum PlayerId
C# | public enum PlayerId
Managed C++ | __value public enum PlayerId
JScript .NET | public enum PlayerId

Members

Member | Value | Description
System | 0
Remaining | -1
AllPlayers | 0
ServerPlayer | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordVolume Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for RecordVolume. Deprecated.

Definition

Visual Basic .NET | Public Enum RecordVolume
C# | public enum RecordVolume
Managed C++ | __value public enum RecordVolume
JScript .NET | public enum RecordVolume

Members

Member | Value | Description
Last | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ResultCode

Microsoft DirectX 9.0 SDK Update (October 2004)

ResultCode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various codes that can be returned by events. Deprecated.

Definition

Visual Basic .NET | Public Enum ResultCode
C# | public enum ResultCode
Managed C++ | __value public enum ResultCode
JScript .NET | public enum ResultCode

Members

Member | Value | Description
Connected | -2146107030
FullDuplex | 1376261
LockedBuffer | -2146106992
InvalidBuffer | -2146106993
NoRecVolAvailable | -2146106994
UserBack | -2146106995
TransportNoPlayer | -2146106996
TransportNoSession | -2146106997
TransportNotInit | -2146106998
NoCallback | -2146106999
NoTransport | -2146107000
InvalidPointer | -2147467261
Initialized | -2146107001
IncompatibleVersion | -2146107004
RunSetup | -2146107005
UserCancel | -2146107008
SendError | -2146107009
PlaybackSystemError | -2146107010
RecordSystemError | -2146107011
InvalidDevice | -2146107012
NotHosting | -2146107013
Hosting | -2146107014
NotBuffered | -2146107015
AlreadyBuffered | -2146107016
No3DSound | -2146107017
ConnectAborted | -2146107018
TimeOut | -2146107019
SoundInitFailure | -2146107020
AlreadyPending | -2146107021
CompressionNotSupported | -2146107022
TransportNotHost | -2146107023
InvalidTarget | -2146107024
NotAllowed | -2146107025
ConnectAborting | -2146107026
NotConnected | -2146107029
ConnectionLost | -2146107032
NoVoiceSession | -2146107090
SessionLost | -2146107092
NotSupported | -2147467263
HalfDuplex | 1376266

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for controlling sessions. Deprecated.

Definition

Visual Basic .NET | Public Enum SessionFlags
C# | public enum SessionFlags
Managed C++ | __value public enum SessionFlags
JScript .NET | public enum SessionFlags

Members

Member | Value | Description
ServerControlTarget | 2
NoHostMigration | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionType

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionType Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of DirectPlay Voice session to run. Deprecated.

Definition

Visual Basic .NET | Public Enum SessionType
C# | public enum SessionType
Managed C++ | __value public enum SessionType
JScript .NET | public enum SessionType

Members

Member | Value | Description
Peer | 1
Echo | 4
Fowarding | 3
Mixing | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SoundConfigFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundConfigFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags to control how the sound device is configured. Deprecated.

Definition

Visual Basic .NET | Public Enum SoundConfigFlags
C# | public enum SoundConfigFlags
Managed C++ | __value public enum SoundConfigFlags
JScript .NET | public enum SoundConfigFlags

Members

Member | Value | Description
StrictFocus | 1073741824
NoFocus | 536870912
NoRecordVolumeAvailable | 16
SetConversionQuality | 8
HalfDuplex | 4
AutoSelect | 2
NormalMode | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


StopSessionFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

StopSessionFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for stopping a session. Deprecated.

Definition

Visual Basic .NET | Public Enum StopSessionFlags
C# | public enum StopSessionFlags
Managed C++ | __value public enum StopSessionFlags
JScript .NET | public enum StopSessionFlags

Members

Member | Value | Description
NoHostMigrate | 8

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TestFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

TestFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the user can press the Back button and whether the setup should be queried. Deprecated.

Definition

Visual Basic .NET | Public Enum TestFlags
C# | public enum TestFlags
Managed C++ | __value public enum TestFlags
JScript .NET | public enum TestFlags

Members

Member | Value | Description
AllowBack | 16
QueryOnly | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Threshold

Microsoft DirectX 9.0 SDK Update (October 2004)

Threshold Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for Threshold. Deprecated.

Definition

Visual Basic .NET | Public Enum Threshold
C# | public enum Threshold
Managed C++ | __value public enum Threshold
JScript .NET | public enum Threshold

Members

Member | Value | Description
Unused | -2
Default | -1
Max | 99
Min | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VoiceFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various flags for DirectPlay Voice. Deprecated.

Definition

Visual Basic .NET | Public Enum VoiceFlags
C# | public enum VoiceFlags
Managed C++ | __value public enum VoiceFlags
JScript .NET | public enum VoiceFlags

Members

Member | Value | Description
Sync | 1 | The method does not return until the operation is completed.

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClientConfig

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the run-time parameters for the client. Deprecated.

Definition

Visual Basic .NET | Public Structure ClientConfig
C# | public struct ClientConfig
Managed C++ | public __value struct ClientConfig
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ClientConfig
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BufferAggressiveness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting for the adaptive buffer algorithm. For most applications, this can be set to DVBUFFERAGGRESSIVENESS_DEFAULT. It can also be set to anything in the range of DVBUFFERAGGRESSIVENESS_MIN and DVBUFFERAGGRESSIVENESS_MAX. In general, the higher the value, the quicker the adaptive buffering adjusts to changing conditions. The lower the value, the slower the adaptive buffering adjusts to changing conditions. Deprecated.
BufferQuality
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer quality setting for the adaptive buffering algorithm. For most applications, this should be set to DVBUFFERQUALITY_DEFAULT. It can be set to anything in the range of DVBUFFERQUALITY_MIN to DVBUFFERQUALITY_MAX. In general, the higher the value, the higher the quality of the voice but the higher the latency. The lower the value, the lower the latency but the lower the quality. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Client configuration flags. Deprecated.
NotifyPeriod
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating how often you want to receive DVMSGID_OUTPUTLEVEL and DVMSGID_INPUTLEVEL (if session is full duplex) messages. If this value is set to 0, these messages are disabled. The value specifies the number of milliseconds between these messages. DVNOTIFYPERIOD_MINPERIOD specifies the minimum period between messages that is allowed. Deprecated.
PlaybackVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating what the playback volume should be set to. Adjusting this volume adjusts both the main buffer and all 3-D sound buffers. See the IDirectSoundBuffer8.SetVolume method for valid values. You can specify DVPLAYBACKVOLUME_DEFAULT to use a default value that is appropriate for most situations (full volume). Deprecated.
RecordVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
LONG value that specifies what the volume of the recording should be set to. See the IDirectSoundBuffer8.SetVolume method for valid values.If automatic gain control is enabled, this value can be set to DVRECORDVOLUME_LAST, which tells the system to use the current volume as determined by the automatic gain control algorithm. If a value other than DVRECORDVOLUME_LAST is specified in combination with automatic gain control, this value will be used to restart the algorithm at the specified value.On return from a call to PlayvoiceclientGetclientconfigDplay, this value will contain the current recording volume. When adjusting the recording volume, Microsoft® DirectPlay® Voice will adjust the volume for the microphone (if a microphone volume is present for the card) and the master recording volume (if one is present on the card). If neither a microphone volume nor a master record volume is present, Microsoft® DirectPlay® Voice will be unable to adjust the recording volume. Deprecated.
Threshold
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Input level used to trigger voice transmission if the DVCLIENTCONFIG_MANUALVOICEACTIVATED flag is specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range of DVTHRESHOLD_MIN to DVTHRESHOLD_MAX. Additionally, DVTHRESHOLD_DEFAULT can be set to use a default value. If DVCLIENTCONFIG_MANUALVOICEACTIVATED or DVCLIENTCONFIG_AUTOVOICEACTIVATED is not specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range member of this structure (indicating push-to-talk mode) this value must be set to DVTHRESHOLD_UNUSED. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClientConfig.ClientConfig()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.ClientConfig Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ClientConfig();
Managed C++ | public: ClientConfig();
JScript .NET | public function ClientConfig();


ClientConfig.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ClientConfig.BufferAggressiveness

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.BufferAggressiveness Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting for the adaptive buffer algorithm. For most applications, this can be set to DVBUFFERAGGRESSIVENESS_DEFAULT. It can also be set to anything in the range of DVBUFFERAGGRESSIVENESS_MIN and DVBUFFERAGGRESSIVENESS_MAX. In general, the higher the value, the quicker the adaptive buffering adjusts to changing conditions. The lower the value, the slower the adaptive buffering adjusts to changing conditions. Deprecated.

Definition

Visual Basic .NET | Public Property BufferAggressiveness As BufferAggressiveness
C# | public BufferAggressiveness BufferAggressiveness { get; set; }
Managed C++ public: __property BufferAggressiveness get_BufferAggressiveness();
public: __property void set_BufferAggressiveness(BufferAggressiveness);
JScript .NET public function get BufferAggressiveness() : BufferAggressiveness
public function set BufferAggressiveness(BufferAggressiveness);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferAggressiveness .

This property is read/write.


ClientConfig.BufferQuality

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.BufferQuality Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer quality setting for the adaptive buffering algorithm. For most applications, this should be set to DVBUFFERQUALITY_DEFAULT. It can be set to anything in the range of DVBUFFERQUALITY_MIN to DVBUFFERQUALITY_MAX. In general, the higher the value, the higher the quality of the voice but the higher the latency. The lower the value, the lower the latency but the lower the quality. Deprecated.

Definition

Visual Basic .NET | Public Property BufferQuality As BufferQuality
C# | public BufferQuality BufferQuality { get; set; }
Managed C++ public: __property BufferQuality get_BufferQuality();
public: __property void set_BufferQuality(BufferQuality);
JScript .NET public function get BufferQuality() : BufferQuality
public function set BufferQuality(BufferQuality);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferQuality .

This property is read/write.


ClientConfig.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Client configuration flags. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As ClientConfigFlags
C# | public ClientConfigFlags Flags { get; set; }
Managed C++ public: __property ClientConfigFlags get_Flags();
public: __property void set_Flags(ClientConfigFlags);
JScript .NET public function get Flags() : ClientConfigFlags
public function set Flags(ClientConfigFlags);

Property Value

Microsoft.DirectX.DirectPlay.Voice.ClientConfigFlags .

This property is read/write.


ClientConfig.NotifyPeriod

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.NotifyPeriod Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating how often you want to receive DVMSGID_OUTPUTLEVEL and DVMSGID_INPUTLEVEL (if session is full duplex) messages. If this value is set to 0, these messages are disabled. The value specifies the number of milliseconds between these messages. DVNOTIFYPERIOD_MINPERIOD specifies the minimum period between messages that is allowed. Deprecated.

Definition

Visual Basic .NET | Public Property NotifyPeriod As Integer
C# | public int NotifyPeriod { get; set; }
Managed C++ public: __property int get_NotifyPeriod();
public: __property void set_NotifyPeriod(int);
JScript .NET public function get NotifyPeriod() : int
public function set NotifyPeriod(int);

Property Value

System.Int32 .

This property is read/write.


ClientConfig.PlaybackVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.PlaybackVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating what the playback volume should be set to. Adjusting this volume adjusts both the main buffer and all 3-D sound buffers. See the IDirectSoundBuffer8.SetVolume method for valid values. You can specify DVPLAYBACKVOLUME_DEFAULT to use a default value that is appropriate for most situations (full volume). Deprecated.

Definition

Visual Basic .NET | Public Property PlaybackVolume As Integer
C# | public int PlaybackVolume { get; set; }
Managed C++ public: __property int get_PlaybackVolume();
public: __property void set_PlaybackVolume(int);
JScript .NET public function get PlaybackVolume() : int
public function set PlaybackVolume(int);

Property Value

System.Int32 .

This property is read/write.


ClientConfig.RecordVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.RecordVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
LONG value that specifies what the volume of the recording should be set to. See the IDirectSoundBuffer8.SetVolume method for valid values.If automatic gain control is enabled, this value can be set to DVRECORDVOLUME_LAST, which tells the system to use the current volume as determined by the automatic gain control algorithm. If a value other than DVRECORDVOLUME_LAST is specified in combination with automatic gain control, this value will be used to restart the algorithm at the specified value.On return from a call to PlayvoiceclientGetclientconfigDplay, this value will contain the current recording volume. When adjusting the recording volume, Microsoft® DirectPlay® Voice will adjust the volume for the microphone (if a microphone volume is present for the card) and the master recording volume (if one is present on the card). If neither a microphone volume nor a master record volume is present, Microsoft® DirectPlay® Voice will be unable to adjust the recording volume. Deprecated.

Definition

Visual Basic .NET | Public Property RecordVolume As Integer
C# | public int RecordVolume { get; set; }
Managed C++ public: __property int get_RecordVolume();
public: __property void set_RecordVolume(int);
JScript .NET public function get RecordVolume() : int
public function set RecordVolume(int);

Property Value

System.Int32 .

This property is read/write.


ClientConfig.Threshold

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientConfig.Threshold Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Input level used to trigger voice transmission if the DVCLIENTCONFIG_MANUALVOICEACTIVATED flag is specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range of DVTHRESHOLD_MIN to DVTHRESHOLD_MAX. Additionally, DVTHRESHOLD_DEFAULT can be set to use a default value. If DVCLIENTCONFIG_MANUALVOICEACTIVATED or DVCLIENTCONFIG_AUTOVOICEACTIVATED is not specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range member of this structure (indicating push-to-talk mode) this value must be set to DVTHRESHOLD_UNUSED. Deprecated.

Definition

Visual Basic .NET | Public Property Threshold As Threshold
C# | public Threshold Threshold { get; set; }
Managed C++ public: __property Threshold get_Threshold();
public: __property void set_Threshold(Threshold);
JScript .NET public function get Threshold() : Threshold
public function set Threshold(Threshold);

Property Value

Microsoft.DirectX.DirectPlay.Voice.Threshold .

This property is read/write.


CompressionInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the attributes of a specific Microsoft® DirectPlay® Voice compression type. Deprecated.

Definition

Visual Basic .NET | Public Structure CompressionInformation
C# | public struct CompressionInformation
Managed C++ | public __value struct CompressionInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CompressionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a longer name of the codec. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved; must be 0. Deprecated.
GuidType
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID used to identify this compression type by Microsoft® DirectPlay® Voice. Deprecated.
MaxBitsPerSecond
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of bits per second claimed by the codec. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a name describing the codec. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CompressionInformation.CompressionInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation.CompressionInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CompressionInformation();
Managed C++ | public: CompressionInformation();
JScript .NET | public function CompressionInformation();


CompressionInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CompressionInformation.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a longer name of the codec. Deprecated.

Definition

Visual Basic .NET | Public Property Description As String
C# | public string Description { get; set; }
Managed C++ public: __property String* get_Description();
public: __property void set_Description(String*);
JScript .NET public function get Description() : String
public function set Description(String);

Property Value

System.String .

This property is read/write.


CompressionInformation.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved; must be 0. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As Integer
C# | public int Flags { get; set; }
Managed C++ public: __property int get_Flags();
public: __property void set_Flags(int);
JScript .NET public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32 .

This property is read/write.


CompressionInformation.GuidType

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation.GuidType Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID used to identify this compression type by Microsoft® DirectPlay® Voice. Deprecated.

Definition

Visual Basic .NET | Public Property GuidType As Guid
C# | public Guid GuidType { get; set; }
Managed C++ public: __property Guid get_GuidType();
public: __property void set_GuidType(Guid);
JScript .NET public function get GuidType() : Guid
public function set GuidType(Guid);

Property Value

System.Guid .

This property is read/write.


CompressionInformation.MaxBitsPerSecond

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation.MaxBitsPerSecond Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of bits per second claimed by the codec. Deprecated.

Definition

Visual Basic .NET | Public Property MaxBitsPerSecond As Integer
C# | public int MaxBitsPerSecond { get; set; }
Managed C++ public: __property int get_MaxBitsPerSecond();
public: __property void set_MaxBitsPerSecond(int);
JScript .NET public function get MaxBitsPerSecond() : int
public function set MaxBitsPerSecond(int);

Property Value

System.Int32 .

This property is read/write.


CompressionInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressionInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a name describing the codec. Deprecated.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


ConnectResultMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.

Definition

Visual Basic .NET | Public Structure ConnectResultMessage
C# | public struct ConnectResultMessage
Managed C++ | public __value struct ConnectResultMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectResultMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Result
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT that specifies the outcome of the connection attempt. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectResultMessage.ConnectResultMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultMessage.ConnectResultMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectResultMessage();
Managed C++ | public: ConnectResultMessage();
JScript .NET | public function ConnectResultMessage();


ConnectResultMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConnectResultMessage.Result

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultMessage.Result Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT that specifies the outcome of the connection attempt. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
Managed C++ | public: __property ResultCode get_Result();
JScript .NET | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.Voice.ResultCode .

This property is read-only.


CreateVoicePlayerMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateVoicePlayerMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidCreatevoiceplayerDplay message when a new player joins the voice session.The structure contains information for the DvmsgidCreatevoiceplayerDplay message. Deprecated.

Definition

Visual Basic .NET | Public Structure CreateVoicePlayerMessage
C# | public struct CreateVoicePlayerMessage
Managed C++ | public __value struct CreateVoicePlayerMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreateVoicePlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag specifying information about the player: Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value for the player in the voice session. This value is set through this parameter when this message is received. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player who connected. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CreateVoicePlayerMessage.CreateVoicePlayerMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateVoicePlayerMessage.CreateVoicePlayerMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CreateVoicePlayerMessage();
Managed C++ | public: CreateVoicePlayerMessage();
JScript .NET | public function CreateVoicePlayerMessage();


CreateVoicePlayerMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateVoicePlayerMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CreateVoicePlayerMessage.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateVoicePlayerMessage.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag specifying information about the player: Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Flags As PlayerCapsFlags
C# | public PlayerCapsFlags Flags { get; }
Managed C++ | public: __property PlayerCapsFlags get_Flags();
JScript .NET | public function get Flags() : PlayerCapsFlags

Property Value

Microsoft.DirectX.DirectPlay.Voice.PlayerCapsFlags .

This property is read-only.


CreateVoicePlayerMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateVoicePlayerMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value for the player in the voice session. This value is set through this parameter when this message is received. Deprecated.

Definition

Visual Basic .NET | Public Property PlayerContext As Object
C# | public object PlayerContext { get; set; }
Managed C++ public: __property Object* get_PlayerContext();
public: __property void set_PlayerContext(Object*);
JScript .NET public function get PlayerContext() : Object
public function set PlayerContext(Object);

Property Value

System.Object .

This property is read/write.


CreateVoicePlayerMessage.PlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateVoicePlayerMessage.PlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player who connected. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
Managed C++ | public: __property int get_PlayerID();
JScript .NET | public function get PlayerID() : int

Property Value

System.Int32 .

This property is read-only.


DeleteVoicePlayerMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

DeleteVoicePlayerMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
For clients, Microsoft® DirectPlay® Voice generates the DvmsgidDeletevoiceplayerDplay message when a player quits the voice session. This message is available only to clients in peer-to-peer voice sessions.For the host, Microsoft® DirectPlay® Voice generates the message when a player quits the voice session.The structure contains information for the DvmsgidDeletevoiceplayerDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure DeleteVoicePlayerMessage
C# | public struct DeleteVoicePlayerMessage
Managed C++ | public __value struct DeleteVoicePlayerMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DeleteVoicePlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of player who disconnected. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DeleteVoicePlayerMessage.DeleteVoicePlayerMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeleteVoicePlayerMessage.DeleteVoicePlayerMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeleteVoicePlayerMessage();
Managed C++ | public: DeleteVoicePlayerMessage();
JScript .NET | public function DeleteVoicePlayerMessage();


DeleteVoicePlayerMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeleteVoicePlayerMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeleteVoicePlayerMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

DeleteVoicePlayerMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


DeleteVoicePlayerMessage.PlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

DeleteVoicePlayerMessage.PlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of player who disconnected. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
Managed C++ | public: __property int get_PlayerID();
JScript .NET | public function get PlayerID() : int

Property Value

System.Int32 .

This property is read-only.


DisconnectResultMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure DisconnectResultMessage
C# | public struct DisconnectResultMessage
Managed C++ | public __value struct DisconnectResultMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DisconnectResultMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Result
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the disconnect request. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisconnectResultMessage.DisconnectResultMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultMessage.DisconnectResultMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DisconnectResultMessage();
Managed C++ | public: DisconnectResultMessage();
JScript .NET | public function DisconnectResultMessage();


DisconnectResultMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DisconnectResultMessage.Result

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultMessage.Result Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the disconnect request. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
Managed C++ | public: __property ResultCode get_Result();
JScript .NET | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.Voice.ResultCode .

This property is read-only.


HostMigratedMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure HostMigratedMessage
C# | public struct HostMigratedMessage
Managed C++ | public __value struct HostMigratedMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
HostMigratedMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NewHostID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the new host. Deprecated.
ServerObject
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If the local client has become the new voice session host, this member will point to a newly created PlayvoiceserverDplay object that can be used by the local client for providing host services. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HostMigratedMessage.HostMigratedMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedMessage.HostMigratedMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public HostMigratedMessage();
Managed C++ | public: HostMigratedMessage();
JScript .NET | public function HostMigratedMessage();


HostMigratedMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


HostMigratedMessage.NewHostID

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedMessage.NewHostID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the new host. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NewHostID As Integer
C# | public int NewHostID { get; }
Managed C++ | public: __property int get_NewHostID();
JScript .NET | public function get NewHostID() : int

Property Value

System.Int32 .

This property is read-only.


HostMigratedMessage.ServerObject

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedMessage.ServerObject Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If the local client has become the new voice session host, this member will point to a newly created PlayvoiceserverDplay object that can be used by the local client for providing host services. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ServerObject As Server
C# | public Server ServerObject { get; }
Managed C++ | public: __property Server* get_ServerObject();
JScript .NET | public function get ServerObject() : Server

Property Value

Microsoft.DirectX.DirectPlay.Voice.Server .

This property is read-only.


InputLevelMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure InputLevelMessage
C# | public struct InputLevelMessage
Managed C++ | public __value struct InputLevelMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
InputLevelMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer value representing peak level across the current frame, which corresponds to approximately 1/10 second of audio stream. The current frame typically lags 50-200 ms behind real-time. This value can range from 0 through 99, with 0 being completely silent and 99 being the highest possible input level. Deprecated.
RecordVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current recording volume for the client. The value can range from -10,000 to 0. This member is available even when automatic gain control is active. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputLevelMessage.InputLevelMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelMessage.InputLevelMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InputLevelMessage();
Managed C++ | public: InputLevelMessage();
JScript .NET | public function InputLevelMessage();


InputLevelMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


InputLevelMessage.LocalPlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelMessage.LocalPlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
Managed C++ | public: __property Object* get_LocalPlayerContext();
JScript .NET | public function get LocalPlayerContext() : Object

Property Value

System.Object .

This property is read-only.


InputLevelMessage.PeakLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelMessage.PeakLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer value representing peak level across the current frame, which corresponds to approximately 1/10 second of audio stream. The current frame typically lags 50-200 ms behind real-time. This value can range from 0 through 99, with 0 being completely silent and 99 being the highest possible input level. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
Managed C++ | public: __property int get_PeakLevel();
JScript .NET | public function get PeakLevel() : int

Property Value

System.Int32 .

This property is read-only.


InputLevelMessage.RecordVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelMessage.RecordVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current recording volume for the client. The value can range from -10,000 to 0. This member is available even when automatic gain control is active. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property RecordVolume As Integer
C# | public int RecordVolume { get; }
Managed C++ | public: __property int get_RecordVolume();
JScript .NET | public function get RecordVolume() : int

Property Value

System.Int32 .

This property is read-only.


OutputLevelMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure OutputLevelMessage
C# | public struct OutputLevelMessage
Managed C++ | public __value struct OutputLevelMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
OutputLevelMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
OutputVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current playback volume for the client. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of playback. This value must be in the range from 0 through 99. 0 indicates complete silence and 99 indicates the highest possible output level. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OutputLevelMessage.OutputLevelMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelMessage.OutputLevelMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public OutputLevelMessage();
Managed C++ | public: OutputLevelMessage();
JScript .NET | public function OutputLevelMessage();


OutputLevelMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


OutputLevelMessage.LocalPlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelMessage.LocalPlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
Managed C++ | public: __property Object* get_LocalPlayerContext();
JScript .NET | public function get LocalPlayerContext() : Object

Property Value

System.Object .

This property is read-only.


OutputLevelMessage.OutputVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelMessage.OutputVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current playback volume for the client. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OutputVolume As Integer
C# | public int OutputVolume { get; }
Managed C++ | public: __property int get_OutputVolume();
JScript .NET | public function get OutputVolume() : int

Property Value

System.Int32 .

This property is read-only.


OutputLevelMessage.PeakLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelMessage.PeakLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of playback. This value must be in the range from 0 through 99. 0 indicates complete silence and 99 indicates the highest possible output level. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
Managed C++ | public: __property int get_PeakLevel();
JScript .NET | public function get PeakLevel() : int

Property Value

System.Int32 .

This property is read-only.


PlayerOutputLevelMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure PlayerOutputLevelMessage
C# | public struct PlayerOutputLevelMessage
Managed C++ | public __value struct PlayerOutputLevelMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PlayerOutputLevelMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of the player's voice stream. This value must be in the range from 0 through 99, with 0 being completely silent and 99 being the highest possible output level. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
SourcePlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player whose voice is being played back. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerOutputLevelMessage.PlayerOutputLevelMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelMessage.PlayerOutputLevelMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerOutputLevelMessage();
Managed C++ | public: PlayerOutputLevelMessage();
JScript .NET | public function PlayerOutputLevelMessage();


PlayerOutputLevelMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PlayerOutputLevelMessage.PeakLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelMessage.PeakLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of the player's voice stream. This value must be in the range from 0 through 99, with 0 being completely silent and 99 being the highest possible output level. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
Managed C++ | public: __property int get_PeakLevel();
JScript .NET | public function get PeakLevel() : int

Property Value

System.Int32 .

This property is read-only.


PlayerOutputLevelMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


PlayerOutputLevelMessage.SourcePlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelMessage.SourcePlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player whose voice is being played back. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourcePlayerID As Integer
C# | public int SourcePlayerID { get; }
Managed C++ | public: __property int get_SourcePlayerID();
JScript .NET | public function get SourcePlayerID() : int

Property Value

System.Int32 .

This property is read-only.


PlayerVoiceStartMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStartMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestartDplay message when an incoming audio stream begins playing back.The structure contains information for the DvmsgidPlayervoicestartDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure PlayerVoiceStartMessage
C# | public struct PlayerVoiceStartMessage
Managed C++ | public __value struct PlayerVoiceStartMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PlayerVoiceStartMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
SourcePlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerVoiceStartMessage.PlayerVoiceStartMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStartMessage.PlayerVoiceStartMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerVoiceStartMessage();
Managed C++ | public: PlayerVoiceStartMessage();
JScript .NET | public function PlayerVoiceStartMessage();


PlayerVoiceStartMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStartMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PlayerVoiceStartMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStartMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


PlayerVoiceStartMessage.SourcePlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStartMessage.SourcePlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourcePlayerID As Integer
C# | public int SourcePlayerID { get; }
Managed C++ | public: __property int get_SourcePlayerID();
JScript .NET | public function get SourcePlayerID() : int

Property Value

System.Int32 .

This property is read-only.


PlayerVoiceStopMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStopMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestopDplay message when an incoming audio stream stops.The DvmsgidPlayervoicestopDplay structure contains information for the DvmsgidPlayervoicestopDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure PlayerVoiceStopMessage
C# | public struct PlayerVoiceStopMessage
Managed C++ | public __value struct PlayerVoiceStopMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PlayerVoiceStopMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
SourcePlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerVoiceStopMessage.PlayerVoiceStopMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStopMessage.PlayerVoiceStopMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerVoiceStopMessage();
Managed C++ | public: PlayerVoiceStopMessage();
JScript .NET | public function PlayerVoiceStopMessage();


PlayerVoiceStopMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStopMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PlayerVoiceStopMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStopMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


PlayerVoiceStopMessage.SourcePlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerVoiceStopMessage.SourcePlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SourcePlayerID As Integer
C# | public int SourcePlayerID { get; }
Managed C++ | public: __property int get_SourcePlayerID();
JScript .NET | public function get SourcePlayerID() : int

Property Value

System.Int32 .

This property is read-only.


RecordStartMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstartDplay message when audio input on the local client begins.The structure contains information for the DvmsgidRecordstartDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure RecordStartMessage
C# | public struct RecordStartMessage
Managed C++ | public __value struct RecordStartMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
RecordStartMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to begin. In push-to-talk mode, this value is 0. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordStartMessage.RecordStartMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartMessage.RecordStartMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public RecordStartMessage();
Managed C++ | public: RecordStartMessage();
JScript .NET | public function RecordStartMessage();


RecordStartMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RecordStartMessage.LocalPlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartMessage.LocalPlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
Managed C++ | public: __property Object* get_LocalPlayerContext();
JScript .NET | public function get LocalPlayerContext() : Object

Property Value

System.Object .

This property is read-only.


RecordStartMessage.PeakLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartMessage.PeakLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to begin. In push-to-talk mode, this value is 0. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
Managed C++ | public: __property int get_PeakLevel();
JScript .NET | public function get PeakLevel() : int

Property Value

System.Int32 .

This property is read-only.


RecordStopMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStopMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstopDplay message when audio input on the local client stops.The structure contains information for the DvmsgidRecordstopDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure RecordStopMessage
C# | public struct RecordStopMessage
Managed C++ | public __value struct RecordStopMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
RecordStopMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to stop. In push-to-talk mode, this value is 0. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordStopMessage.RecordStopMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStopMessage.RecordStopMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public RecordStopMessage();
Managed C++ | public: RecordStopMessage();
JScript .NET | public function RecordStopMessage();


RecordStopMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStopMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RecordStopMessage.LocalPlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStopMessage.LocalPlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
Managed C++ | public: __property Object* get_LocalPlayerContext();
JScript .NET | public function get LocalPlayerContext() : Object

Property Value

System.Object .

This property is read-only.


RecordStopMessage.PeakLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStopMessage.PeakLevel Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to stop. In push-to-talk mode, this value is 0. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
Managed C++ | public: __property int get_PeakLevel();
JScript .NET | public function get PeakLevel() : int

Property Value

System.Int32 .

This property is read-only.


SessionDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the desired or current session settings for the Microsoft® DirectPlay® Voice server. This structure is used by the voice session host to configure the session, and by the session host and clients to retrieve information about the current session. Deprecated.

Definition

Visual Basic .NET | Public Structure SessionDescription
C# | public struct SessionDescription
Managed C++ | public __value struct SessionDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SessionDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BufferAggressiveness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERAGGRESSIVENESS_DEFAULT. Allowable values are between DVBUFFERAGGRESSIVENESS _MIN and DVBUFFERAGGRESSIVENESS _MAX. Additionally, this member can be set to the following value. Deprecated.
BufferQuality
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer quality setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERQUALITY_DEFAULT. Allowable values are between DVBUFFERQUALITY_MIN and DVBUFFERQUALITY_MAX. Additionally, this member can be set to the following value. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Combination of the following flags. Deprecated.
GuidCompressionType
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID specifying the compression type of the session. To select the default compression codec, set this member to DPVCTGUID_DEFAULT. Deprecated.
SessionType
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of Microsoft® DirectPlay® Voice session to run. The DVSESSIONTYPE_PEER flag is not available in client/server sessions; all other flags are valid for all session types. This member can be one of the following values. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionDescription.SessionDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription.SessionDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SessionDescription();
Managed C++ | public: SessionDescription();
JScript .NET | public function SessionDescription();


SessionDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SessionDescription.BufferAggressiveness

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription.BufferAggressiveness Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERAGGRESSIVENESS_DEFAULT. Allowable values are between DVBUFFERAGGRESSIVENESS _MIN and DVBUFFERAGGRESSIVENESS _MAX. Additionally, this member can be set to the following value. Deprecated.

Definition

Visual Basic .NET | Public Property BufferAggressiveness As BufferAggressiveness
C# | public BufferAggressiveness BufferAggressiveness { get; set; }
Managed C++ public: __property BufferAggressiveness get_BufferAggressiveness();
public: __property void set_BufferAggressiveness(BufferAggressiveness);
JScript .NET public function get BufferAggressiveness() : BufferAggressiveness
public function set BufferAggressiveness(BufferAggressiveness);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferAggressiveness .

This property is read/write.


SessionDescription.BufferQuality

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription.BufferQuality Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer quality setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERQUALITY_DEFAULT. Allowable values are between DVBUFFERQUALITY_MIN and DVBUFFERQUALITY_MAX. Additionally, this member can be set to the following value. Deprecated.

Definition

Visual Basic .NET | Public Property BufferQuality As BufferQuality
C# | public BufferQuality BufferQuality { get; set; }
Managed C++ public: __property BufferQuality get_BufferQuality();
public: __property void set_BufferQuality(BufferQuality);
JScript .NET public function get BufferQuality() : BufferQuality
public function set BufferQuality(BufferQuality);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferQuality .

This property is read/write.


SessionDescription.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Combination of the following flags. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As SessionFlags
C# | public SessionFlags Flags { get; set; }
Managed C++ public: __property SessionFlags get_Flags();
public: __property void set_Flags(SessionFlags);
JScript .NET public function get Flags() : SessionFlags
public function set Flags(SessionFlags);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionFlags .

This property is read/write.


SessionDescription.GuidCompressionType

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription.GuidCompressionType Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID specifying the compression type of the session. To select the default compression codec, set this member to DPVCTGUID_DEFAULT. Deprecated.

Definition

Visual Basic .NET | Public Property GuidCompressionType As Guid
C# | public Guid GuidCompressionType { get; set; }
Managed C++ public: __property Guid get_GuidCompressionType();
public: __property void set_GuidCompressionType(Guid);
JScript .NET public function get GuidCompressionType() : Guid
public function set GuidCompressionType(Guid);

Property Value

System.Guid .

This property is read/write.


SessionDescription.SessionType

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionDescription.SessionType Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of Microsoft® DirectPlay® Voice session to run. The DVSESSIONTYPE_PEER flag is not available in client/server sessions; all other flags are valid for all session types. This member can be one of the following values. Deprecated.

Definition

Visual Basic .NET | Public Property SessionType As SessionType
C# | public SessionType SessionType { get; set; }
Managed C++ public: __property SessionType get_SessionType();
public: __property void set_SessionType(SessionType);
JScript .NET public function get SessionType() : SessionType
public function set SessionType(SessionType);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionType .

This property is read/write.


SessionLostMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure SessionLostMessage
C# | public struct SessionLostMessage
Managed C++ | public __value struct SessionLostMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SessionLostMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Result
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT value indicating why the session was terminated. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionLostMessage.SessionLostMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostMessage.SessionLostMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SessionLostMessage();
Managed C++ | public: SessionLostMessage();
JScript .NET | public function SessionLostMessage();


SessionLostMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SessionLostMessage.Result

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostMessage.Result Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT value indicating why the session was terminated. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
Managed C++ | public: __property ResultCode get_Result();
JScript .NET | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.Voice.ResultCode .

This property is read-only.


SetTargetsMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

SetTargetsMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
PdvmessagehandlerDplay is an application-defined callback function used by the PlayvoiceclientDplay and PlayvoiceserverDplay objects to send messages to the user. Deprecated.

Definition

Visual Basic .NET | Public Structure SetTargetsMessage
C# | public struct SetTargetsMessage
Managed C++ | public __value struct SetTargetsMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Targets
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Methods

Method Description
SetTargetsMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SetTargetsMessage.SetTargetsMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

SetTargetsMessage.SetTargetsMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SetTargetsMessage();
Managed C++ | public: SetTargetsMessage();
JScript .NET | public function SetTargetsMessage();


SetTargetsMessage.Targets

Microsoft DirectX 9.0 SDK Update (October 2004)

SetTargetsMessage.Targets Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Definition

Visual Basic .NET | Public Targets As Int32
C# | public Int32 Targets;
Managed C++ | public: Int32 Targets;
JScript .NET | public var Targets : Int32

Field Value

System.Int32[] .

This field is read/write.


SoundDeviceConfig

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve information about the sound device configuration and cannot be changed once a connection has been made. After a connection is made, you can retrieve the current sound device configuration by calling PlayvoiceclientGetsounddeviceconfigDplay. Deprecated.

Definition

Visual Basic .NET | Public Structure SoundDeviceConfig
C# | public struct SoundDeviceConfig
Managed C++ | public __value struct SoundDeviceConfig
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SoundDeviceConfig
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
CaptureDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of the following flags. Deprecated.
GuidCaptureDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.
GuidPlaybackDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the globally unique identifier (GUID) of the device used for playback. Deprecated.
MainBuffer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an IDirectSoundBuffer8 object, which is used to create the Microsoft® DirectPlay® Voice main buffer. This can be either NULL or a user-created Microsoft DirectSound® buffer. If this member is set to NULL, Microsoft® DirectPlay® Voice will create a buffer for the main voice buffer. If users specify a buffer here, Microsoft® DirectPlay® Voice will use their buffer for the main voice buffer. User-created buffers have the following restrictions. Deprecated.
MainBufferFlags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwFlags parameter of the IDirectSoundBuffer8.Play method when Play is called for the main buffer. The DSBPLAY_LOOPING flag is automatically added to this field. See the documentation on IDirectSoundBuffer8.Play for details. This parameter must be 0 if the LpdsMainBuffer member of this structure is NULL. Deprecated.
MainBufferPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwPriority parameter of the IDirectSoundBuffer8.Play method when Play is called on the main buffer. See documentation for IDirectSoundBuffer8.Play for more information. This member must be set to 0 if lpdsMainBufferDesc is NULL. Deprecated.
PlaybackDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the playback device. Deprecated.
Window
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Must be set to the window that will be used to determine focus for sound playback. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SoundDeviceConfig.SoundDeviceConfig()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.SoundDeviceConfig Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SoundDeviceConfig();
Managed C++ | public: SoundDeviceConfig();
JScript .NET | public function SoundDeviceConfig();


SoundDeviceConfig.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SoundDeviceConfig.CaptureDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.CaptureDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.

Definition

Visual Basic .NET | Public Property CaptureDevice As Capture
C# | public Capture CaptureDevice { get; set; }
Managed C++ public: __property Capture* get_CaptureDevice();
public: __property void set_CaptureDevice(Capture*);
JScript .NET public function get CaptureDevice() : Capture
public function set CaptureDevice(Capture);

Property Value

Microsoft.DirectX.DirectSound.Capture .

This property is read/write.


SoundDeviceConfig.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of the following flags. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As SoundConfigFlags
C# | public SoundConfigFlags Flags { get; set; }
Managed C++ public: __property SoundConfigFlags get_Flags();
public: __property void set_Flags(SoundConfigFlags);
JScript .NET public function get Flags() : SoundConfigFlags
public function set Flags(SoundConfigFlags);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SoundConfigFlags .

This property is read/write.


SoundDeviceConfig.GuidCaptureDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.GuidCaptureDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.

Definition

Visual Basic .NET | Public Property GuidCaptureDevice As Guid
C# | public Guid GuidCaptureDevice { get; set; }
Managed C++ public: __property Guid get_GuidCaptureDevice();
public: __property void set_GuidCaptureDevice(Guid);
JScript .NET public function get GuidCaptureDevice() : Guid
public function set GuidCaptureDevice(Guid);

Property Value

System.Guid .

This property is read/write.


SoundDeviceConfig.GuidPlaybackDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.GuidPlaybackDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the globally unique identifier (GUID) of the device used for playback. Deprecated.

Definition

Visual Basic .NET | Public Property GuidPlaybackDevice As Guid
C# | public Guid GuidPlaybackDevice { get; set; }
Managed C++ public: __property Guid get_GuidPlaybackDevice();
public: __property void set_GuidPlaybackDevice(Guid);
JScript .NET public function get GuidPlaybackDevice() : Guid
public function set GuidPlaybackDevice(Guid);

Property Value

System.Guid .

This property is read/write.


SoundDeviceConfig.MainBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.MainBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an IDirectSoundBuffer8 object, which is used to create the Microsoft® DirectPlay® Voice main buffer. This can be either NULL or a user-created Microsoft DirectSound® buffer. If this member is set to NULL, Microsoft® DirectPlay® Voice will create a buffer for the main voice buffer. If users specify a buffer here, Microsoft® DirectPlay® Voice will use their buffer for the main voice buffer. User-created buffers have the following restrictions. Deprecated.

Definition

Visual Basic .NET | Public Property MainBuffer As Buffer
C# | public Buffer MainBuffer { get; set; }
Managed C++ public: __property Buffer* get_MainBuffer();
public: __property void set_MainBuffer(Buffer*);
JScript .NET public function get MainBuffer() : Buffer
public function set MainBuffer(Buffer);

Property Value

Microsoft.DirectX.DirectSound.Buffer .

This property is read/write.


SoundDeviceConfig.MainBufferFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.MainBufferFlags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwFlags parameter of the IDirectSoundBuffer8.Play method when Play is called for the main buffer. The DSBPLAY_LOOPING flag is automatically added to this field. See the documentation on IDirectSoundBuffer8.Play for details. This parameter must be 0 if the LpdsMainBuffer member of this structure is NULL. Deprecated.

Definition

Visual Basic .NET | Public Property MainBufferFlags As Integer
C# | public int MainBufferFlags { get; set; }
Managed C++ public: __property int get_MainBufferFlags();
public: __property void set_MainBufferFlags(int);
JScript .NET public function get MainBufferFlags() : int
public function set MainBufferFlags(int);

Property Value

System.Int32 .

This property is read/write.


SoundDeviceConfig.MainBufferPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.MainBufferPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwPriority parameter of the IDirectSoundBuffer8.Play method when Play is called on the main buffer. See documentation for IDirectSoundBuffer8.Play for more information. This member must be set to 0 if lpdsMainBufferDesc is NULL. Deprecated.

Definition

Visual Basic .NET | Public Property MainBufferPriority As Integer
C# | public int MainBufferPriority { get; set; }
Managed C++ public: __property int get_MainBufferPriority();
public: __property void set_MainBufferPriority(int);
JScript .NET public function get MainBufferPriority() : int
public function set MainBufferPriority(int);

Property Value

System.Int32 .

This property is read/write.


SoundDeviceConfig.PlaybackDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.PlaybackDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the playback device. Deprecated.

Definition

Visual Basic .NET | Public Property PlaybackDevice As Device
C# | public Device PlaybackDevice { get; set; }
Managed C++ public: __property Device* get_PlaybackDevice();
public: __property void set_PlaybackDevice(Device*);
JScript .NET public function get PlaybackDevice() : Device
public function set PlaybackDevice(Device);

Property Value

Microsoft.DirectX.DirectSound.Device .

This property is read/write.


SoundDeviceConfig.Window

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundDeviceConfig.Window Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Must be set to the window that will be used to determine focus for sound playback. Deprecated.

Definition

Visual Basic .NET | Public Property Window As Control
C# | public Control Window { get; set; }
Managed C++ public: __property Control* get_Window();
public: __property void set_Window(Control*);
JScript .NET public function get Window() : Control
public function set Window(Control);

Property Value

System.Windows.Forms.Control .

This property is read/write.


ConnectResultEventHandler(Object,ConnectResultEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectResultEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ConnectResult event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ConnectResultEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectResultEventArgs _
)
C# public sealed delegate void ConnectResultEventHandler(
object sender,
ConnectResultEventArgs e
);
Managed C++ public: __gc __delegate void ConnectResultEventHandler(
Object *sender,
ConnectResultEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.ConnectResultEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DisconnectResultEventHandler(Object,DisconnectResultEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

DisconnectResultEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub DisconnectResultEventHandler( _
ByVal sender As Object, _
ByVal e As DisconnectResultEventArgs _
)
C# public sealed delegate void DisconnectResultEventHandler(
object sender,
DisconnectResultEventArgs e
);
Managed C++ public: __gc __delegate void DisconnectResultEventHandler(
Object *sender,
DisconnectResultEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.DisconnectResultEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputLevelEventHandler(Object,InputLevelEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputLevelEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the InputLevel event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub InputLevelEventHandler( _
ByVal sender As Object, _
ByVal e As InputLevelEventArgs _
)
C# public sealed delegate void InputLevelEventHandler(
object sender,
InputLevelEventArgs e
);
Managed C++ public: __gc __delegate void InputLevelEventHandler(
Object *sender,
InputLevelEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.InputLevelEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OutputLevelEventHandler(Object,OutputLevelEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

OutputLevelEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the OutputLevel event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub OutputLevelEventHandler( _
ByVal sender As Object, _
ByVal e As OutputLevelEventArgs _
)
C# public sealed delegate void OutputLevelEventHandler(
object sender,
OutputLevelEventArgs e
);
Managed C++ public: __gc __delegate void OutputLevelEventHandler(
Object *sender,
OutputLevelEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.OutputLevelEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerOutputLevelEventHandler(Object,PlayerOutputLevelEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerOutputLevelEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PlayerOutputLevelEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerOutputLevelEventArgs _
)
C# public sealed delegate void PlayerOutputLevelEventHandler(
object sender,
PlayerOutputLevelEventArgs e
);
Managed C++ public: __gc __delegate void PlayerOutputLevelEventHandler(
Object *sender,
PlayerOutputLevelEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerStartedEventHandler(Object,PlayerStartedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStartedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStarted event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PlayerStartedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerStartedEventArgs _
)
C# public sealed delegate void PlayerStartedEventHandler(
object sender,
PlayerStartedEventArgs e
);
Managed C++ public: __gc __delegate void PlayerStartedEventHandler(
Object *sender,
PlayerStartedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.PlayerStartedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerStoppedEventHandler(Object,PlayerStoppedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerStoppedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStopped event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PlayerStoppedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerStoppedEventArgs _
)
C# public sealed delegate void PlayerStoppedEventHandler(
object sender,
PlayerStoppedEventArgs e
);
Managed C++ public: __gc __delegate void PlayerStoppedEventHandler(
Object *sender,
PlayerStoppedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.PlayerStoppedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordStartedEventHandler(Object,RecordStartedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStartedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStarted event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub RecordStartedEventHandler( _
ByVal sender As Object, _
ByVal e As RecordStartedEventArgs _
)
C# public sealed delegate void RecordStartedEventHandler(
object sender,
RecordStartedEventArgs e
);
Managed C++ public: __gc __delegate void RecordStartedEventHandler(
Object *sender,
RecordStartedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.RecordStartedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RecordStoppedEventHandler(Object,RecordStoppedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

RecordStoppedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStopped event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub RecordStoppedEventHandler( _
ByVal sender As Object, _
ByVal e As RecordStoppedEventArgs _
)
C# public sealed delegate void RecordStoppedEventHandler(
object sender,
RecordStoppedEventArgs e
);
Managed C++ public: __gc __delegate void RecordStoppedEventHandler(
Object *sender,
RecordStoppedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.RecordStoppedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionLostEventHandler(Object,SessionLostEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionLostEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionLost event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub SessionLostEventHandler( _
ByVal sender As Object, _
ByVal e As SessionLostEventArgs _
)
C# public sealed delegate void SessionLostEventHandler(
object sender,
SessionLostEventArgs e
);
Managed C++ public: __gc __delegate void SessionLostEventHandler(
Object *sender,
SessionLostEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.SessionLostEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SetTargetsEventHandler(Object,SetTargetsEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SetTargetsEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SetTargets event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub SetTargetsEventHandler( _
ByVal sender As Object, _
ByVal e As SetTargetsEventArgs _
)
C# public sealed delegate void SetTargetsEventHandler(
object sender,
SetTargetsEventArgs e
);
Managed C++ public: __gc __delegate void SetTargetsEventHandler(
Object *sender,
SetTargetsEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.SetTargetsEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VoiceHostMigratedEventHandler(Object,HostMigratedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoiceHostMigratedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub VoiceHostMigratedEventHandler( _
ByVal sender As Object, _
ByVal e As HostMigratedEventArgs _
)
C# public sealed delegate void VoiceHostMigratedEventHandler(
object sender,
HostMigratedEventArgs e
);
Managed C++ public: __gc __delegate void VoiceHostMigratedEventHandler(
Object *sender,
HostMigratedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.HostMigratedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VoicePlayerCreatedEventHandler(Object,VoicePlayerCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerCreatedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub VoicePlayerCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As VoicePlayerCreatedEventArgs _
)
C# public sealed delegate void VoicePlayerCreatedEventHandler(
object sender,
VoicePlayerCreatedEventArgs e
);
Managed C++ public: __gc __delegate void VoicePlayerCreatedEventHandler(
Object *sender,
VoicePlayerCreatedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.VoicePlayerCreatedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


VoicePlayerDeletedEventHandler(Object,VoicePlayerDeletedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

VoicePlayerDeletedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDeleted event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub VoicePlayerDeletedEventHandler( _
ByVal sender As Object, _
ByVal e As VoicePlayerDeletedEventArgs _
)
C# public sealed delegate void VoicePlayerDeletedEventHandler(
object sender,
VoicePlayerDeletedEventArgs e
);
Managed C++ public: __gc __delegate void VoicePlayerDeletedEventHandler(
Object *sender,
VoicePlayerDeletedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.Voice.VoicePlayerDeletedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay

Note: This documentation is preliminary and is subject to change.

Warning: Microsoft® DirectPlay® has been deprecated. Deprecated components of Microsoft DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay enables you to write network applications such as multiplayer games. The following tables list the members exposed by the Microsoft.DirectX.DirectPlay namespace.

Classes

AbortedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation was canceled before it could be completed. Deprecated.
Address
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Address object contains generic addressing methods used to create and manipulate addresses for Microsoft® DirectPlay®. Deprecated.
AddressingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is invalid. Deprecated.
AlreadyClosingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to call the Close method on a session has been made more than once. Deprecated.
AlreadyConnectedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is already connected to the session. Deprecated.
AlreadyDisconnectingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client is already disconnecting from the session. Deprecated.
AlreadyRegisteredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object has already been registered. Deprecated.
AsyncOperationCompleteEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the AsyncOperationComplete event. Deprecated.
CannotCancelException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not be canceled. Deprecated.
CannotCreateGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new group cannot be created. Deprecated.
CannotCreatePlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new player cannot be created. Deprecated.
CannotLaunchApplicationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The lobby cannot launch the specified application. Deprecated.
Client
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Warning: This interface has been deprecated.
Applications use the methods of the Client object to create and manage client applications for client/server sessions. Deprecated.
ClientInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.
ConnectCompleteEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.
ConnectingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The method is in the process of connecting to the network. Deprecated.
ConnectionLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider connection was reset while data was being sent. Deprecated.
ConversionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data could not be converted. Deprecated.
DataTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application data is too large for the service provider's Maximum Transmission Unit. Deprecated.
DirectPlayException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for all DirectPlay exceptions. Derives from DirectXException. Deprecated.
DoesNotExistException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Requested element is not part of the address or the requested application globally unique identifier (Guid) is not registered. Deprecated.
DuplicateCommandException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A duplicate command has been issued. Deprecated.
EndPointNotReceivingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An end point is not receiving data. Deprecated.
FindHostQueryEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the FindHostQuery event. Deprecated.
FindHostQueryTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The query data specified is too large. Deprecated.
FindHostResponseEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.
FindHostResponseTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.
GroupCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the GroupCreated event. Deprecated.
GroupDestroyedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the Group Destroyed event. Deprecated.
GroupInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.
GroupMembersList
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of group members. Deprecated.
GroupNotEmptyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified group is not empty. Deprecated.
HostingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session is already hosting. Deprecated.
HostMigratedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
IncompleteAddressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is not complete. Deprecated.
IndicateConnectEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.
IndicatedConnectAbortedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.
InvalidAddressFormatException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address format is invalid. Deprecated.
InvalidApplicationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid supplied for the application is invalid. Deprecated.
InvalidCommandException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The command specified is invalid. Deprecated.
InvalidDeviceAddressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address for the local computer or adapter is invalid. Deprecated.
InvalidEndPointException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The endpoint was invalid Deprecated.
InvalidFlagsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.
InvalidGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group identifier (ID) is not recognized as a valid group ID for this game session. Deprecated.
InvalidHandleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.
InvalidHostAddressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified remote address is invalid. Deprecated.
InvalidInstanceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid for the application instance is invalid. Deprecated.
InvalidObjectException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object parameter is invalid. This value will be returned in a connect request if the connecting player was not a client in a client/server game or a peer in a peer-to-peer game. Deprecated.
InvalidPasswordException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An invalid password was supplied when attempting to join a session that requires a password. Deprecated.
InvalidPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.
InvalidPriorityException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified priority is not within the range of allowed priorities, which is inclusively from 0 through 65535. Deprecated.
InvalidStringException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
String specified as a parameter is invalid. Deprecated.
InvalidUrlException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specified string is not a valid DirectPlay URL. Deprecated.
InvalidVersionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was an attempt to connect to an invalid version of DirectPlay. Deprecated.
NatResolver
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the NatResolver object to simplify traversal through the Internet Connection Sharing features available in Microsoft® Windows® Millennium Edition (Windows Me) and Windows XP, as well as other Network Address Translators. Deprecated.
NatResolverQueryEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the NatResolver Query event. Deprecated.
NetworkPacket
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A network packet that can be sent to other members of this session. Deprecated.
NoCapsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The communication link that DirectPlay is attempting to use is not capable of this function. Deprecated.
NoConnectionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No communication link was established. Deprecated.
NoHostPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is currently no player acting as the host of the session. Deprecated.
NoMoreAddressComponentsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No more address components can be added to this address. Deprecated.
NoResponseException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was no response from the specified target. Deprecated.
NotAllowedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This function is not allowed on this object. Deprecated.
NotHostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt by the client to connect to a nonhost computer. Additionally, this error value can be returned by a nonhost that tries to set the application description. Deprecated.
NotReadyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not ready for use. Deprecated.
NotRegisteredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This object is not registered. Deprecated.
Peer
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Peer object to create a peer-to-peer Microsoft® DirectPlay® session. Deprecated.
PeerInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.
PlayerAddedToGroupEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerAddedToGroup event. Deprecated.
PlayerAlreadyInGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is already included in the group. Deprecated.
PlayerCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.
PlayerDestroyedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDestroyed event. Deprecated.
PlayerLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has lost the connection to the session. Deprecated.
PlayerNotInGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not included in the group. Deprecated.
PlayerNotReachableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has tried to join a peer-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.
PlayerRemovedFromGroupEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerRemovedFromGroup event. Deprecated.
PlayersGroupsEnumerator
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides an enumerator for player and group lists. Deprecated.
ReceiveEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
SendCompleteEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.
SendTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The send was too large. Deprecated.
Server
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to create and manage the server for a Microsoft® DirectPlay® client/server transport session. Deprecated.
ServerInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.
SessionFullException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The request to connect to the host or server failed because the maximum number of players allotted for the session has been reached. Deprecated.
SessionTerminatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SessionTerminated event. Deprecated.
TableFullException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The table is full. Deprecated.
ThreadCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadCreated event. Deprecated.
ThreadDestroyedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadDestroyed event. Deprecated.
ThreadPool
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the ThreadPool object to manage threads in a Microsoft® DirectPlay® application Deprecated.
TimedOutException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.
UserCancelException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.

Enumerations

CancelFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancel all asynchronous requests. Deprecated.
ConnectFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.
DestroyGroupFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
DestroyPlayerFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
FindHostsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
GetSendQueueInformationFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
GroupFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
HostFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.
InitializeFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.
LocalAddressFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
PlayerID
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default system player id's. Deprecated.
ResultCode
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result codes that can be returned via events. Deprecated.
SendFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
SessionFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
SyncFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Structures

AddPlayerToGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidAddPlayerToGroupDplay message when a player has been added to a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidAddPlayerToGroupDplay system message. Deprecated.
ApplicationDescription
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the settings for a Microsoft® DirectPlay® application. Deprecated.
AsyncOperationCompleteMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the AsyncOperationComplete event. Deprecated.
Caps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when setting and retrieving general parameters for Microsoft® DirectPlay®. Deprecated.
ClientInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.
ConnectCompleteMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.
ConnectionInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to retrieve statistics for the connection between you and a remote computer that you are connected to. Deprecated.
CreateGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateGroupDplay message when a group is created.The structure contains information for the DpnMsgidCreateGroupDplay system message. Deprecated.
CreatePlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreatePlayerDplay message when a player is added to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidCreatePlayerDplay system message. Deprecated.
CreateThreadMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateThreadDplay message when a new thread is created.The structure contains information for the DpnMsgidCreateThreadDplay system message. Deprecated.
DestroyGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyGroupDplay message when a group is destroyed from a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyGroupDplay system message. Deprecated.
DestroyPlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyPlayerDplay message when a player leaves a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyPlayerDplay system message. Deprecated.
DestroyThreadMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyThreadDplay message when a thread is shut down.The structure contains information for the DpnMsgidDestroyThreadDplay system message. Deprecated.
FindHostsQueryMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the FindHostQuery event. Deprecated.
FindHostsResponseMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® sends the DpnMsgidEnumHostsResponseDplay message to a peer or client's message handler to convey the host's response to an enumeration request.The structure contains information for the DpnMsgidEnumHostsResponseDplay system message. Deprecated.
GroupInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static group information. Deprecated.
GroupInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.
HostMigratedMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
IndicateConnectMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.
IndicatedConnectAbortedMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.
NatResolverQueryMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the NatResolverQuery event. Deprecated.
PeerInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.
PlayerInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static player information. Deprecated.
ReceiveMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
RemovePlayerFromGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidRemovePlayerFromGroupDplay message when a player has been deleted from a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidRemovePlayerFromGroupDplay system message. Deprecated.
SendCompleteMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.
ServerInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.
ServiceProviderCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve parameters for service providers. Deprecated.
ServiceProviderCapsFlags
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers for the system, including those that are not available to the application or do not have devices installed. Deprecated.
ServiceProviderInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when enumerating information for a specific service provider. Deprecated.
ServiceProviderInformationFlags
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the service provider. Deprecated.
TerminateSessionMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidTerminateSessionDplay message when a session is terminated by the host.The structure contains information for the DpnMsgidTerminateSessionDplay system message. Deprecated.

Delegates

ApplicationDescriptionEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This message indicates that the application description has been changed. There is no accompanying structure. Deprecated.
AsyncOperationCompleteEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the AsyncOperationComplete event. Deprecated.
ClientInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.
ConnectCompleteEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.
FindHostQueryEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostQuery event. Deprecated.
FindHostResponseEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostResponse event. Deprecated.
GroupCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupCreated event. Deprecated.
GroupDestroyedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupDestroyed event. Deprecated.
GroupInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.
HostMigratedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.
IndicateConnectEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.
IndicatedConnectAbortedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.
NatResolverQueryEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the NatResolverQuery event. Deprecated.
PeerInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.
PlayerAddedToGroupEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerAddedToGroup event. Deprecated.
PlayerCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.
PlayerDestroyedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDestroyed event. Deprecated.
PlayerRemovedFromGroupEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerRemovedFromGroup event. Deprecated.
ReceiveEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.
SendCompleteEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SendComplete event. Deprecated.
ServerInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.
SessionTerminatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionTerminated event. Deprecated.
ThreadCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadCreated event. Deprecated.
ThreadDestroyedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadDestroyed event. Deprecated.


Microsoft.DirectX.DirectPlay.AbortedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AbortedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation was canceled before it could be completed. Deprecated.

Definition

Visual Basic .NET Public Class AbortedException
Inherits DirectPlayException
C# | public class AbortedException : DirectPlayException
Managed C++ | public __gc class AbortedException : public DirectPlayException
JScript .NET | public class AbortedException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AbortedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AbortedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AbortedException.AbortedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AbortedException.AbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AbortedException();
protected AbortedException(SerializationInfo, StreamingContext);
public AbortedException(string);
public AbortedException(string, Exception);


AbortedException.AbortedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AbortedException.AbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AbortedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AbortedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AbortedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AbortedException.AbortedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AbortedException.AbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AbortedException(
string message,
Exception inner
);
Managed C++ public: AbortedException(
String *message,
Exception *inner
);
JScript .NET public function AbortedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AbortedException.AbortedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AbortedException.AbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AbortedException(
string message
);
Managed C++ public: AbortedException(
String *message
);
JScript .NET public function AbortedException(
message : String
);

Parameters

message System.String.


AbortedException.AbortedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AbortedException.AbortedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AbortedException();
Managed C++ | public: AbortedException();
JScript .NET | public function AbortedException();


Microsoft.DirectX.DirectPlay.Address

Microsoft DirectX 9.0 SDK Update (October 2004)

Address Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Address object contains generic addressing methods used to create and manipulate addresses for Microsoft® DirectPlay®. Deprecated.

Definition

Visual Basic .NET Public Class Address
Inherits MarshalByRefObject
Implements ICloneable, IDisposable
C# public class Address : MarshalByRefObject,
ICloneable, IDisposable
Managed C++ public __gc class Address : public MarshalByRefObject,
ICloneable, IDisposable
JScript .NET public class Address extends MarshalByRefObject
implements IDisposable, ICloneable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Fields

Field Description
static (Shared in Visual Basic .NET) BaudRate115200
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) BaudRate14400
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) BaudRate19200
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) BaudRate38400
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) BaudRate56000
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) BaudRate57600
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) BaudRate9600
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) DpnServerPort
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) EscapeChar
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) FlowControlControlRts
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) FlowControlDtr
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) FlowControlNone
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) FlowControlRtsDtr
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) FlowControlXonXoff
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) Header
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) IndexInvalid
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) IpxProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyApplicationInstance
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyBaud
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyDevice
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyFlowControl
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyHostname
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyNatResolver
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyNatResolverUserString
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyParity
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyPhoneNumber
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyPort
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyProcessor
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyProgram
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyScope
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyStopBits
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) KeyTraversalMode
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ModemProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ParityEven
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ParityMark
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ParityNone
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ParityOdd
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ParitySpace
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) SeparatorComponent
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) SeparatorKeyValue
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) SeparatorUserdata
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) SerialProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ServiceProviderBlueTooth
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ServiceProviderIpx
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ServiceProviderModem
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ServiceProviderSerial
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) ServiceProviderTcpIp
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) StopBitsOne
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) StopBitsOneFive
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) StopBitsTwo
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) TcpIpProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) TraversalModeNone
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) TraversalModePortRecommended
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) TraversalModePortRequired
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
AddComponent
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.
Address
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Clear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the address object to an empty address. Deprecated.
Clone
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetComponentBinary
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetComponentGuid
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetComponentInteger
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetComponentString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetEqual
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the contents of the object it is called on to match the contents of the address object passed to the method. Deprecated.

Properties

Property Description
Device
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the local device GUID in the Address object.Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
NumberComponents
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of components in the Address object. Deprecated.
ServiceProvider
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the service provider globally unique identifier (GUID) in the Address object.Deprecated.
Url
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Microsoft DirectPlay® address URL string represented by this Address object. Deprecated.
UserData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the user data in the Address object.Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Address

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Address.AddComponent

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.AddComponent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Overload List

public void AddComponent(string, byte[]);
public void AddComponent(string, Guid);
public void AddComponent(string, int);
public void AddComponent(string, string);


Address.AddComponent(String,Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.AddComponent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic .NET Public Sub AddComponent( _
ByVal keyName As String, _
ByVal value() As Byte _
)
C# public void AddComponent(
string keyName,
byte[] value
);
Managed C++ public: void AddComponent(
String *keyName,
Byte value __gc[]
);
JScript .NET public function AddComponent(
keyName : String,
value : byte[]
);

Parameters

keyName | System.String.
value | System.Byte[].


Address.AddComponent(String,Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.AddComponent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic .NET Public Sub AddComponent( _
ByVal keyName As String, _
ByVal value As Guid _
)
C# public void AddComponent(
string keyName,
Guid value
);
Managed C++ public: void AddComponent(
String *keyName,
Guid value
);
JScript .NET public function AddComponent(
keyName : String,
value : Guid
);

Parameters

keyName | System.String.
value | System.Guid.


Address.AddComponent(String,String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.AddComponent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic .NET Public Sub AddComponent( _
ByVal keyName As String, _
ByVal value As String _
)
C# public void AddComponent(
string keyName,
string value
);
Managed C++ public: void AddComponent(
String *keyName,
String *value
);
JScript .NET public function AddComponent(
keyName : String,
value : String
);

Parameters

keyName | System.String.
value | System.String.


Address.AddComponent(String,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.AddComponent Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic .NET Public Sub AddComponent( _
ByVal keyName As String, _
ByVal iValue As Integer _
)
C# public void AddComponent(
string keyName,
int iValue
);
Managed C++ public: void AddComponent(
String *keyName,
int iValue
);
JScript .NET public function AddComponent(
keyName : String,
iValue : int
);

Parameters

keyName | System.String.
iValue | System.Int32.


Address.Address

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Address Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Address();
public Address(IPAddress);
public Address(IPEndPoint);
public Address(string, int);


Address.Address(IPEndPoint)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Address Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal address As IPEndPoint _
)
C# public Address(
IPEndPoint address
);
Managed C++ public: Address(
IPEndPoint *address
);
JScript .NET public function Address(
address : IPEndPoint
);

Parameters

address System.Net.IPEndPoint.


Address.Address(IPAddress)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Address Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal address As IPAddress _
)
C# public Address(
IPAddress address
);
Managed C++ public: Address(
IPAddress *address
);
JScript .NET public function Address(
address : IPAddress
);

Parameters

address System.Net.IPAddress.


Address.Address(String,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Address Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal hostname As String, _
ByVal port As Integer _
)
C# public Address(
string hostname,
int port
);
Managed C++ public: Address(
String *hostname,
int port
);
JScript .NET public function Address(
hostname : String,
port : int
);

Parameters

hostname | System.String.
port | System.Int32.


Address.Address()

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Address Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Address();
Managed C++ | public: Address();
JScript .NET | public function Address();


Address.Clear()

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Clear Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the address object to an empty address. Deprecated.

Definition

Visual Basic .NET | Public Sub Clear()
C# | public void Clear();
Managed C++ | public: void Clear();
JScript .NET | public function Clear();


Address.Clone()

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function Clone() As Object
C# | public override object Clone();
Managed C++ | public: Object* Clone();
JScript .NET | public override function Clone() : Object;

Return Value

System.Object .


Address.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Address.Disposed
  • Address.Disposing


Address.Equals

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Overload List

public bool Equals(Address);
public override bool Equals(object);


Address.Equals(Address)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Public Function Equals( _
ByVal address As Address _
) As Boolean
C# public bool Equals(
Address address
);
Managed C++ public: bool Equals(
Address *address
);
JScript .NET public function Equals(
address : Address
) : boolean;

Parameters

address Microsoft.DirectX.DirectPlay.Address. An Address object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Address.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Address.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Address();
Managed C++ | ~Address();
JScript .NET | protected override function Finalize();


Address.GetComponentBinary(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.GetComponentBinary Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic .NET Public Function GetComponentBinary( _
ByVal keyName As String _
) As Byte()
C# public byte[] GetComponentBinary(
string keyName
);
Managed C++ public: Byte GetComponentBinary(
String *keyName
) __gc[];
JScript .NET public function GetComponentBinary(
keyName : String
) : byte[];

Parameters

keyName System.String.

Return Value

System.Byte[].


Address.GetComponentGuid(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.GetComponentGuid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic .NET Public Function GetComponentGuid( _
ByVal keyName As String _
) As Guid
C# public Guid GetComponentGuid(
string keyName
);
Managed C++ public: Guid GetComponentGuid(
String *keyName
);
JScript .NET public function GetComponentGuid(
keyName : String
) : Guid;

Parameters

keyName System.String.

Return Value

System.Guid .


Address.GetComponentInteger(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.GetComponentInteger Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic .NET Public Function GetComponentInteger( _
ByVal keyName As String _
) As Integer
C# public int GetComponentInteger(
string keyName
);
Managed C++ public: int GetComponentInteger(
String *keyName
);
JScript .NET public function GetComponentInteger(
keyName : String
) : int;

Parameters

keyName System.String.

Return Value

System.Int32 .


Address.GetComponentString(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.GetComponentString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic .NET Public Function GetComponentString( _
ByVal keyName As String _
) As String
C# public string GetComponentString(
string keyName
);
Managed C++ public: String* GetComponentString(
String *keyName
);
JScript .NET public function GetComponentString(
keyName : String
) : String;

Parameters

keyName System.String.

Return Value

System.String .


Address.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Address.op_Equality(Address,Address)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Address, _
ByVal right As Address _
) As Boolean
C# public static bool op_Equality(
Address left,
Address right
);
Managed C++ public: static bool op_Equality(
Address *left,
Address *right
);
JScript .NET public static function op_Equality(
left : Address,
right : Address
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Address. The Address structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Address. The Address structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Address.op_Inequality(Address,Address)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Address, _
ByVal right As Address _
) As Boolean
C# public static bool op_Inequality(
Address left,
Address right
);
Managed C++ public: static bool op_Inequality(
Address *left,
Address *right
);
JScript .NET public static function op_Inequality(
left : Address,
right : Address
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Address. The Address structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Address. The Address structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Address.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Address.SetEqual(Address)

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.SetEqual Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the contents of the object it is called on to match the contents of the address object passed to the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetEqual( _
ByVal address As Address _
)
C# public void SetEqual(
Address address
);
Managed C++ public: void SetEqual(
Address *address
);
JScript .NET public function SetEqual(
address : Address
);

Parameters

address Microsoft.DirectX.DirectPlay.Address.


Address.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Device Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the local device globally unique identifier (GUID) in the Address object.Deprecated.

Definition

Visual Basic .NET | Public Property Device As Guid
C# | public Guid Device { get; set; }
Managed C++ public: __property Guid get_Device();
public: __property void set_Device(Guid);
JScript .NET public function get Device() : Guid
public function set Device(Guid);

Property Value

System.Guid .

This property is read/write.


Address.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Address.NumberComponents

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.NumberComponents Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of components in the Address object. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property NumberComponents As Integer
C# | public int NumberComponents { get; }
Managed C++ | public: __property int get_NumberComponents();
JScript .NET | public function get NumberComponents() : int

Property Value

System.Int32 .

This property is read-only.


Address.ServiceProvider

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ServiceProvider Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the service provider globally unique identifier (GUID) in the Address object.Deprecated.

Definition

Visual Basic .NET | Public Property ServiceProvider As Guid
C# | public Guid ServiceProvider { get; set; }
Managed C++ public: __property Guid get_ServiceProvider();
public: __property void set_ServiceProvider(Guid);
JScript .NET public function get ServiceProvider() : Guid
public function set ServiceProvider(Guid);

Property Value

System.Guid .

This property is read/write.


Address.Url

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Url Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Microsoft® DirectPlay® address URL string represented by this Address object. Deprecated.

Definition

Visual Basic .NET | Public Property Url As String
C# | public string Url { get; set; }
Managed C++ public: __property String* get_Url();
public: __property void set_Url(String*);
JScript .NET public function get Url() : String
public function set Url(String);

Property Value

System.String .

This property is read/write.


Address.UserData

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.UserData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the user data in the Address object.Deprecated.

Definition

Visual Basic .NET | Public Property UserData As IntPtr
C# | public IntPtr UserData { get; set; }
Managed C++ public: __property IntPtr get_UserData();
public: __property void set_UserData(IntPtr);
JScript .NET public function get UserData() : IntPtr
public function set UserData(IntPtr);

Property Value

System.IntPtr .

This property is read/write.


Address.BaudRate115200

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.BaudRate115200 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared BaudRate115200 As Int32
C# | public static Int32 BaudRate115200;
Managed C++ | public: static Int32 BaudRate115200;
JScript .NET | public static var BaudRate115200 : Int32

Field Value

System.Int32 .

This field is read-only.


Address.BaudRate14400

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.BaudRate14400 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared BaudRate14400 As Int32
C# | public static Int32 BaudRate14400;
Managed C++ | public: static Int32 BaudRate14400;
JScript .NET | public static var BaudRate14400 : Int32

Field Value

System.Int32 .

This field is read-only.


Address.BaudRate19200

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.BaudRate19200 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared BaudRate19200 As Int32
C# | public static Int32 BaudRate19200;
Managed C++ | public: static Int32 BaudRate19200;
JScript .NET | public static var BaudRate19200 : Int32

Field Value

System.Int32 .

This field is read-only.


Address.BaudRate38400

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.BaudRate38400 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared BaudRate38400 As Int32
C# | public static Int32 BaudRate38400;
Managed C++ | public: static Int32 BaudRate38400;
JScript .NET | public static var BaudRate38400 : Int32

Field Value

System.Int32 .

This field is read-only.


Address.BaudRate56000

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.BaudRate56000 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared BaudRate56000 As Int32
C# | public static Int32 BaudRate56000;
Managed C++ | public: static Int32 BaudRate56000;
JScript .NET | public static var BaudRate56000 : Int32

Field Value

System.Int32 .

This field is read-only.


Address.BaudRate57600

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.BaudRate57600 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared BaudRate57600 As Int32
C# | public static Int32 BaudRate57600;
Managed C++ | public: static Int32 BaudRate57600;
JScript .NET | public static var BaudRate57600 : Int32

Field Value

System.Int32 .

This field is read-only.


Address.BaudRate9600

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.BaudRate9600 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared BaudRate9600 As Int32
C# | public static Int32 BaudRate9600;
Managed C++ | public: static Int32 BaudRate9600;
JScript .NET | public static var BaudRate9600 : Int32

Field Value

System.Int32 .

This field is read-only.


Address.DpnServerPort

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.DpnServerPort Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared DpnServerPort As Int32
C# | public static Int32 DpnServerPort;
Managed C++ | public: static Int32 DpnServerPort;
JScript .NET | public static var DpnServerPort : Int32

Field Value

System.Int32 .

This field is read-only.


Address.EscapeChar

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.EscapeChar Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared EscapeChar As String
C# | public static String EscapeChar;
Managed C++ | public: static String EscapeChar;
JScript .NET | public static var EscapeChar : String

Field Value

System.String .

This field is read/write.


Address.FlowControlControlRts

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.FlowControlControlRts Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared FlowControlControlRts As String
C# | public static String FlowControlControlRts;
Managed C++ | public: static String FlowControlControlRts;
JScript .NET | public static var FlowControlControlRts : String

Field Value

System.String .

This field is read/write.


Address.FlowControlDtr

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.FlowControlDtr Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared FlowControlDtr As String
C# | public static String FlowControlDtr;
Managed C++ | public: static String FlowControlDtr;
JScript .NET | public static var FlowControlDtr : String

Field Value

System.String .

This field is read/write.


Address.FlowControlNone

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.FlowControlNone Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared FlowControlNone As String
C# | public static String FlowControlNone;
Managed C++ | public: static String FlowControlNone;
JScript .NET | public static var FlowControlNone : String

Field Value

System.String .

This field is read/write.


Address.FlowControlRtsDtr

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.FlowControlRtsDtr Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared FlowControlRtsDtr As String
C# | public static String FlowControlRtsDtr;
Managed C++ | public: static String FlowControlRtsDtr;
JScript .NET | public static var FlowControlRtsDtr : String

Field Value

System.String .

This field is read/write.


Address.FlowControlXonXoff

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.FlowControlXonXoff Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared FlowControlXonXoff As String
C# | public static String FlowControlXonXoff;
Managed C++ | public: static String FlowControlXonXoff;
JScript .NET | public static var FlowControlXonXoff : String

Field Value

System.String .

This field is read/write.


Address.Header

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Header Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared Header As String
C# | public static String Header;
Managed C++ | public: static String Header;
JScript .NET | public static var Header : String

Field Value

System.String .

This field is read/write.


Address.IndexInvalid

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.IndexInvalid Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared IndexInvalid As Int32
C# | public static Int32 IndexInvalid;
Managed C++ | public: static Int32 IndexInvalid;
JScript .NET | public static var IndexInvalid : Int32

Field Value

System.Int32 .

This field is read-only.


Address.IpxProvider

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.IpxProvider Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared IpxProvider As String
C# | public static String IpxProvider;
Managed C++ | public: static String IpxProvider;
JScript .NET | public static var IpxProvider : String

Field Value

System.String .

This field is read/write.


Address.KeyApplicationInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyApplicationInstance Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyApplicationInstance As String
C# | public static String KeyApplicationInstance;
Managed C++ | public: static String KeyApplicationInstance;
JScript .NET | public static var KeyApplicationInstance : String

Field Value

System.String .

This field is read/write.


Address.KeyBaud

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyBaud Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyBaud As String
C# | public static String KeyBaud;
Managed C++ | public: static String KeyBaud;
JScript .NET | public static var KeyBaud : String

Field Value

System.String .

This field is read/write.


Address.KeyDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyDevice Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyDevice As String
C# | public static String KeyDevice;
Managed C++ | public: static String KeyDevice;
JScript .NET | public static var KeyDevice : String

Field Value

System.String .

This field is read/write.


Address.KeyFlowControl

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyFlowControl Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyFlowControl As String
C# | public static String KeyFlowControl;
Managed C++ | public: static String KeyFlowControl;
JScript .NET | public static var KeyFlowControl : String

Field Value

System.String .

This field is read/write.


Address.KeyHostname

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyHostname Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyHostname As String
C# | public static String KeyHostname;
Managed C++ | public: static String KeyHostname;
JScript .NET | public static var KeyHostname : String

Field Value

System.String .

This field is read/write.


Address.KeyNatResolver

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyNatResolver Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyNatResolver As String
C# | public static String KeyNatResolver;
Managed C++ | public: static String KeyNatResolver;
JScript .NET | public static var KeyNatResolver : String

Field Value

System.String .

This field is read/write.


Address.KeyNatResolverUserString

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyNatResolverUserString Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyNatResolverUserString As String
C# | public static String KeyNatResolverUserString;
Managed C++ | public: static String KeyNatResolverUserString;
JScript .NET | public static var KeyNatResolverUserString : String

Field Value

System.String .

This field is read/write.


Address.KeyParity

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyParity Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyParity As String
C# | public static String KeyParity;
Managed C++ | public: static String KeyParity;
JScript .NET | public static var KeyParity : String

Field Value

System.String .

This field is read/write.


Address.KeyPhoneNumber

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyPhoneNumber Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyPhoneNumber As String
C# | public static String KeyPhoneNumber;
Managed C++ | public: static String KeyPhoneNumber;
JScript .NET | public static var KeyPhoneNumber : String

Field Value

System.String .

This field is read/write.


Address.KeyPort

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyPort Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyPort As String
C# | public static String KeyPort;
Managed C++ | public: static String KeyPort;
JScript .NET | public static var KeyPort : String

Field Value

System.String .

This field is read/write.


Address.KeyProcessor

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyProcessor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyProcessor As String
C# | public static String KeyProcessor;
Managed C++ | public: static String KeyProcessor;
JScript .NET | public static var KeyProcessor : String

Field Value

System.String .

This field is read/write.


Address.KeyProgram

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyProgram Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyProgram As String
C# | public static String KeyProgram;
Managed C++ | public: static String KeyProgram;
JScript .NET | public static var KeyProgram : String

Field Value

System.String .

This field is read/write.


Address.KeyProvider

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyProvider Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyProvider As String
C# | public static String KeyProvider;
Managed C++ | public: static String KeyProvider;
JScript .NET | public static var KeyProvider : String

Field Value

System.String .

This field is read/write.


Address.KeyScope

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyScope Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyScope As String
C# | public static String KeyScope;
Managed C++ | public: static String KeyScope;
JScript .NET | public static var KeyScope : String

Field Value

System.String .

This field is read/write.


Address.KeyStopBits

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyStopBits Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyStopBits As String
C# | public static String KeyStopBits;
Managed C++ | public: static String KeyStopBits;
JScript .NET | public static var KeyStopBits : String

Field Value

System.String .

This field is read/write.


Address.KeyTraversalMode

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.KeyTraversalMode Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared KeyTraversalMode As String
C# | public static String KeyTraversalMode;
Managed C++ | public: static String KeyTraversalMode;
JScript .NET | public static var KeyTraversalMode : String

Field Value

System.String .

This field is read/write.


Address.ModemProvider

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ModemProvider Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ModemProvider As String
C# | public static String ModemProvider;
Managed C++ | public: static String ModemProvider;
JScript .NET | public static var ModemProvider : String

Field Value

System.String .

This field is read/write.


Address.ParityEven

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ParityEven Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ParityEven As String
C# | public static String ParityEven;
Managed C++ | public: static String ParityEven;
JScript .NET | public static var ParityEven : String

Field Value

System.String .

This field is read/write.


Address.ParityMark

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ParityMark Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ParityMark As String
C# | public static String ParityMark;
Managed C++ | public: static String ParityMark;
JScript .NET | public static var ParityMark : String

Field Value

System.String .

This field is read/write.


Address.ParityNone

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ParityNone Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ParityNone As String
C# | public static String ParityNone;
Managed C++ | public: static String ParityNone;
JScript .NET | public static var ParityNone : String

Field Value

System.String .

This field is read/write.


Address.ParityOdd

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ParityOdd Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ParityOdd As String
C# | public static String ParityOdd;
Managed C++ | public: static String ParityOdd;
JScript .NET | public static var ParityOdd : String

Field Value

System.String .

This field is read/write.


Address.ParitySpace

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ParitySpace Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ParitySpace As String
C# | public static String ParitySpace;
Managed C++ | public: static String ParitySpace;
JScript .NET | public static var ParitySpace : String

Field Value

System.String .

This field is read/write.


Address.SeparatorComponent

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.SeparatorComponent Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared SeparatorComponent As String
C# | public static String SeparatorComponent;
Managed C++ | public: static String SeparatorComponent;
JScript .NET | public static var SeparatorComponent : String

Field Value

System.String .

This field is read/write.


Address.SeparatorKeyValue

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.SeparatorKeyValue Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared SeparatorKeyValue As String
C# | public static String SeparatorKeyValue;
Managed C++ | public: static String SeparatorKeyValue;
JScript .NET | public static var SeparatorKeyValue : String

Field Value

System.String .

This field is read/write.


Address.SeparatorUserdata

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.SeparatorUserdata Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared SeparatorUserdata As String
C# | public static String SeparatorUserdata;
Managed C++ | public: static String SeparatorUserdata;
JScript .NET | public static var SeparatorUserdata : String

Field Value

System.String .

This field is read/write.


Address.SerialProvider

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.SerialProvider Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared SerialProvider As String
C# | public static String SerialProvider;
Managed C++ | public: static String SerialProvider;
JScript .NET | public static var SerialProvider : String

Field Value

System.String .

This field is read/write.


Address.ServiceProviderBlueTooth

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ServiceProviderBlueTooth Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ServiceProviderBlueTooth As Guid
C# | public static Guid ServiceProviderBlueTooth;
Managed C++ | public: static Guid ServiceProviderBlueTooth;
JScript .NET | public static var ServiceProviderBlueTooth : Guid

Field Value

System.Guid .

This field is read-only.


Address.ServiceProviderIpx

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ServiceProviderIpx Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ServiceProviderIpx As Guid
C# | public static Guid ServiceProviderIpx;
Managed C++ | public: static Guid ServiceProviderIpx;
JScript .NET | public static var ServiceProviderIpx : Guid

Field Value

System.Guid .

This field is read-only.


Address.ServiceProviderModem

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ServiceProviderModem Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ServiceProviderModem As Guid
C# | public static Guid ServiceProviderModem;
Managed C++ | public: static Guid ServiceProviderModem;
JScript .NET | public static var ServiceProviderModem : Guid

Field Value

System.Guid .

This field is read-only.


Address.ServiceProviderSerial

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ServiceProviderSerial Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ServiceProviderSerial As Guid
C# | public static Guid ServiceProviderSerial;
Managed C++ | public: static Guid ServiceProviderSerial;
JScript .NET | public static var ServiceProviderSerial : Guid

Field Value

System.Guid .

This field is read-only.


Address.ServiceProviderTcpIp

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.ServiceProviderTcpIp Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared ServiceProviderTcpIp As Guid
C# | public static Guid ServiceProviderTcpIp;
Managed C++ | public: static Guid ServiceProviderTcpIp;
JScript .NET | public static var ServiceProviderTcpIp : Guid

Field Value

System.Guid .

This field is read-only.


Address.StopBitsOne

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.StopBitsOne Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared StopBitsOne As String
C# | public static String StopBitsOne;
Managed C++ | public: static String StopBitsOne;
JScript .NET | public static var StopBitsOne : String

Field Value

System.String .

This field is read/write.


Address.StopBitsOneFive

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.StopBitsOneFive Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared StopBitsOneFive As String
C# | public static String StopBitsOneFive;
Managed C++ | public: static String StopBitsOneFive;
JScript .NET | public static var StopBitsOneFive : String

Field Value

System.String .

This field is read/write.


Address.StopBitsTwo

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.StopBitsTwo Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared StopBitsTwo As String
C# | public static String StopBitsTwo;
Managed C++ | public: static String StopBitsTwo;
JScript .NET | public static var StopBitsTwo : String

Field Value

System.String .

This field is read/write.


Address.TcpIpProvider

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.TcpIpProvider Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared TcpIpProvider As String
C# | public static String TcpIpProvider;
Managed C++ | public: static String TcpIpProvider;
JScript .NET | public static var TcpIpProvider : String

Field Value

System.String .

This field is read/write.


Address.TraversalModeNone

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.TraversalModeNone Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared TraversalModeNone As Int32
C# | public static Int32 TraversalModeNone;
Managed C++ | public: static Int32 TraversalModeNone;
JScript .NET | public static var TraversalModeNone : Int32

Field Value

System.Int32 .

This field is read-only.


Address.TraversalModePortRecommended

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.TraversalModePortRecommended Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared TraversalModePortRecommended As Int32
C# | public static Int32 TraversalModePortRecommended;
Managed C++ | public: static Int32 TraversalModePortRecommended;
JScript .NET | public static var TraversalModePortRecommended : Int32

Field Value

System.Int32 .

This field is read-only.


Address.TraversalModePortRequired

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.TraversalModePortRequired Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Shared TraversalModePortRequired As Int32
C# | public static Int32 TraversalModePortRequired;
Managed C++ | public: static Int32 TraversalModePortRequired;
JScript .NET | public static var TraversalModePortRequired : Int32

Field Value

System.Int32 .

This field is read-only.


Address.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Address.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Address.Disposing event, use the following code.

address.Disposing += new System.EventHandler(this.OnDisposing);

The Dispose property of an object indicates whether that object has been disposed.


Microsoft.DirectX.DirectPlay.AddressingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is invalid. Deprecated.

Definition

Visual Basic .NET Public Class AddressingException
Inherits DirectPlayException
C# | public class AddressingException : DirectPlayException
Managed C++ | public __gc class AddressingException : public DirectPlayException
JScript .NET | public class AddressingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AddressingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AddressingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AddressingException.AddressingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressingException.AddressingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AddressingException();
protected AddressingException(SerializationInfo, StreamingContext);
public AddressingException(string);
public AddressingException(string, Exception);


AddressingException.AddressingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressingException.AddressingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AddressingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AddressingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AddressingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AddressingException.AddressingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressingException.AddressingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AddressingException(
string message,
Exception inner
);
Managed C++ public: AddressingException(
String *message,
Exception *inner
);
JScript .NET public function AddressingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AddressingException.AddressingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressingException.AddressingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AddressingException(
string message
);
Managed C++ public: AddressingException(
String *message
);
JScript .NET public function AddressingException(
message : String
);

Parameters

message System.String.


AddressingException.AddressingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AddressingException.AddressingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AddressingException();
Managed C++ | public: AddressingException();
JScript .NET | public function AddressingException();


Microsoft.DirectX.DirectPlay.AlreadyClosingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyClosingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to call the Close method on a session has been made more than once. Deprecated.

Definition

Visual Basic .NET Public Class AlreadyClosingException
Inherits DirectPlayException
C# | public class AlreadyClosingException : DirectPlayException
Managed C++ | public __gc class AlreadyClosingException : public DirectPlayException
JScript .NET | public class AlreadyClosingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyClosingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyClosingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AlreadyClosingException.AlreadyClosingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyClosingException.AlreadyClosingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyClosingException();
protected AlreadyClosingException(SerializationInfo, StreamingContext);
public AlreadyClosingException(string);
public AlreadyClosingException(string, Exception);


AlreadyClosingException.AlreadyClosingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyClosingException.AlreadyClosingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyClosingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AlreadyClosingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AlreadyClosingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AlreadyClosingException.AlreadyClosingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyClosingException.AlreadyClosingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyClosingException(
string message,
Exception inner
);
Managed C++ public: AlreadyClosingException(
String *message,
Exception *inner
);
JScript .NET public function AlreadyClosingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AlreadyClosingException.AlreadyClosingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyClosingException.AlreadyClosingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AlreadyClosingException(
string message
);
Managed C++ public: AlreadyClosingException(
String *message
);
JScript .NET public function AlreadyClosingException(
message : String
);

Parameters

message System.String.


AlreadyClosingException.AlreadyClosingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyClosingException.AlreadyClosingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AlreadyClosingException();
Managed C++ | public: AlreadyClosingException();
JScript .NET | public function AlreadyClosingException();


Microsoft.DirectX.DirectPlay.AlreadyConnectedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyConnectedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is already connected to the session. Deprecated.

Definition

Visual Basic .NET Public Class AlreadyConnectedException
Inherits DirectPlayException
C# | public class AlreadyConnectedException : DirectPlayException
Managed C++ | public __gc class AlreadyConnectedException : public DirectPlayException
JScript .NET | public class AlreadyConnectedException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyConnectedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyConnectedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AlreadyConnectedException.AlreadyConnectedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyConnectedException();
protected AlreadyConnectedException(SerializationInfo, StreamingContext);
public AlreadyConnectedException(string);
public AlreadyConnectedException(string, Exception);


AlreadyConnectedException.AlreadyConnectedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyConnectedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AlreadyConnectedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AlreadyConnectedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AlreadyConnectedException.AlreadyConnectedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyConnectedException(
string message,
Exception inner
);
Managed C++ public: AlreadyConnectedException(
String *message,
Exception *inner
);
JScript .NET public function AlreadyConnectedException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AlreadyConnectedException.AlreadyConnectedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AlreadyConnectedException(
string message
);
Managed C++ public: AlreadyConnectedException(
String *message
);
JScript .NET public function AlreadyConnectedException(
message : String
);

Parameters

message System.String.


AlreadyConnectedException.AlreadyConnectedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AlreadyConnectedException();
Managed C++ | public: AlreadyConnectedException();
JScript .NET | public function AlreadyConnectedException();


Microsoft.DirectX.DirectPlay.AlreadyDisconnectingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyDisconnectingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client is already disconnecting from the session. Deprecated.

Definition

Visual Basic .NET Public Class AlreadyDisconnectingException
Inherits DirectPlayException
C# | public class AlreadyDisconnectingException : DirectPlayException
Managed C++ | public __gc class AlreadyDisconnectingException : public DirectPlayException
JScript .NET | public class AlreadyDisconnectingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyDisconnectingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyDisconnectingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AlreadyDisconnectingException.AlreadyDisconnectingException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyDisconnectingException();
protected AlreadyDisconnectingException(SerializationInfo, StreamingContext);
public AlreadyDisconnectingException(string);
public AlreadyDisconnectingException(string, Exception);


AlreadyDisconnectingException.AlreadyDisconnectingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyDisconnectingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AlreadyDisconnectingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AlreadyDisconnectingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AlreadyDisconnectingException.AlreadyDisconnectingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyDisconnectingException(
string message,
Exception inner
);
Managed C++ public: AlreadyDisconnectingException(
String *message,
Exception *inner
);
JScript .NET public function AlreadyDisconnectingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AlreadyDisconnectingException.AlreadyDisconnectingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AlreadyDisconnectingException(
string message
);
Managed C++ public: AlreadyDisconnectingException(
String *message
);
JScript .NET public function AlreadyDisconnectingException(
message : String
);

Parameters

message System.String.


AlreadyDisconnectingException.AlreadyDisconnectingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AlreadyDisconnectingException();
Managed C++ | public: AlreadyDisconnectingException();
JScript .NET | public function AlreadyDisconnectingException();


Microsoft.DirectX.DirectPlay.AlreadyRegisteredException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyRegisteredException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object has already been registered. Deprecated.

Definition

Visual Basic .NET Public Class AlreadyRegisteredException
Inherits DirectPlayException
C# | public class AlreadyRegisteredException : DirectPlayException
Managed C++ | public __gc class AlreadyRegisteredException : public DirectPlayException
JScript .NET | public class AlreadyRegisteredException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyRegisteredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyRegisteredException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AlreadyRegisteredException.AlreadyRegisteredException

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyRegisteredException();
protected AlreadyRegisteredException(SerializationInfo, StreamingContext);
public AlreadyRegisteredException(string);
public AlreadyRegisteredException(string, Exception);


AlreadyRegisteredException.AlreadyRegisteredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyRegisteredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AlreadyRegisteredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AlreadyRegisteredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


AlreadyRegisteredException.AlreadyRegisteredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyRegisteredException(
string message,
Exception inner
);
Managed C++ public: AlreadyRegisteredException(
String *message,
Exception *inner
);
JScript .NET public function AlreadyRegisteredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


AlreadyRegisteredException.AlreadyRegisteredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AlreadyRegisteredException(
string message
);
Managed C++ public: AlreadyRegisteredException(
String *message
);
JScript .NET public function AlreadyRegisteredException(
message : String
);

Parameters

message System.String.


AlreadyRegisteredException.AlreadyRegisteredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AlreadyRegisteredException();
Managed C++ | public: AlreadyRegisteredException();
JScript .NET | public function AlreadyRegisteredException();


Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the AsyncOperationComplete event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class AsyncOperationCompleteEventArgs
Inherits EventArgs
C# | public sealed class AsyncOperationCompleteEventArgs : EventArgs
Managed C++ | public __gc __sealed class AsyncOperationCompleteEventArgs : public EventArgs
JScript .NET | public class AsyncOperationCompleteEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
AsyncOperationCompleteEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
AsyncOperationCompleteEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AsyncOperationCompleteEventArgs.AsyncOperationCompleteEventArgs(AsyncOperationCompleteMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteEventArgs.AsyncOperationCompleteEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As AsyncOperationCompleteMessage _
)
C# public AsyncOperationCompleteEventArgs(
AsyncOperationCompleteMessage dpMessage
);
Managed C++ public: AsyncOperationCompleteEventArgs(
AsyncOperationCompleteMessage dpMessage
);
JScript .NET public function AsyncOperationCompleteEventArgs(
dpMessage : AsyncOperationCompleteMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.AsyncOperationCompleteMessage.


AsyncOperationCompleteEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As AsyncOperationCompleteMessage
C# | public AsyncOperationCompleteMessage Message;
Managed C++ | public: AsyncOperationCompleteMessage Message;
JScript .NET | public var Message : AsyncOperationCompleteMessage

Field Value

Microsoft.DirectX.DirectPlay.AsyncOperationCompleteMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.CannotCancelException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCancelException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not be canceled. Deprecated.

Definition

Visual Basic .NET Public Class CannotCancelException
Inherits DirectPlayException
C# | public class CannotCancelException : DirectPlayException
Managed C++ | public __gc class CannotCancelException : public DirectPlayException
JScript .NET | public class CannotCancelException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCancelException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotCancelException.CannotCancelException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCancelException.CannotCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCancelException();
protected CannotCancelException(SerializationInfo, StreamingContext);
public CannotCancelException(string);
public CannotCancelException(string, Exception);


CannotCancelException.CannotCancelException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCancelException.CannotCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCancelException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotCancelException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotCancelException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotCancelException.CannotCancelException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCancelException.CannotCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCancelException(
string message,
Exception inner
);
Managed C++ public: CannotCancelException(
String *message,
Exception *inner
);
JScript .NET public function CannotCancelException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotCancelException.CannotCancelException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCancelException.CannotCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotCancelException(
string message
);
Managed C++ public: CannotCancelException(
String *message
);
JScript .NET public function CannotCancelException(
message : String
);

Parameters

message System.String.


CannotCancelException.CannotCancelException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCancelException.CannotCancelException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotCancelException();
Managed C++ | public: CannotCancelException();
JScript .NET | public function CannotCancelException();


Microsoft.DirectX.DirectPlay.CannotCreateGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateGroupException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new group cannot be created. Deprecated.

Definition

Visual Basic .NET Public Class CannotCreateGroupException
Inherits DirectPlayException
C# | public class CannotCreateGroupException : DirectPlayException
Managed C++ | public __gc class CannotCreateGroupException : public DirectPlayException
JScript .NET | public class CannotCreateGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCreateGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotCreateGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotCreateGroupException.CannotCreateGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCreateGroupException();
protected CannotCreateGroupException(SerializationInfo, StreamingContext);
public CannotCreateGroupException(string);
public CannotCreateGroupException(string, Exception);


CannotCreateGroupException.CannotCreateGroupException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCreateGroupException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotCreateGroupException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotCreateGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotCreateGroupException.CannotCreateGroupException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCreateGroupException(
string message,
Exception inner
);
Managed C++ public: CannotCreateGroupException(
String *message,
Exception *inner
);
JScript .NET public function CannotCreateGroupException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotCreateGroupException.CannotCreateGroupException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotCreateGroupException(
string message
);
Managed C++ public: CannotCreateGroupException(
String *message
);
JScript .NET public function CannotCreateGroupException(
message : String
);

Parameters

message System.String.


CannotCreateGroupException.CannotCreateGroupException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotCreateGroupException();
Managed C++ | public: CannotCreateGroupException();
JScript .NET | public function CannotCreateGroupException();


Microsoft.DirectX.DirectPlay.CannotCreatePlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreatePlayerException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new player cannot be created. Deprecated.

Definition

Visual Basic .NET Public Class CannotCreatePlayerException
Inherits DirectPlayException
C# | public class CannotCreatePlayerException : DirectPlayException
Managed C++ | public __gc class CannotCreatePlayerException : public DirectPlayException
JScript .NET | public class CannotCreatePlayerException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCreatePlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotCreatePlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotCreatePlayerException.CannotCreatePlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCreatePlayerException();
protected CannotCreatePlayerException(SerializationInfo, StreamingContext);
public CannotCreatePlayerException(string);
public CannotCreatePlayerException(string, Exception);


CannotCreatePlayerException.CannotCreatePlayerException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCreatePlayerException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotCreatePlayerException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotCreatePlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotCreatePlayerException.CannotCreatePlayerException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCreatePlayerException(
string message,
Exception inner
);
Managed C++ public: CannotCreatePlayerException(
String *message,
Exception *inner
);
JScript .NET public function CannotCreatePlayerException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotCreatePlayerException.CannotCreatePlayerException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotCreatePlayerException(
string message
);
Managed C++ public: CannotCreatePlayerException(
String *message
);
JScript .NET public function CannotCreatePlayerException(
message : String
);

Parameters

message System.String.


CannotCreatePlayerException.CannotCreatePlayerException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotCreatePlayerException();
Managed C++ | public: CannotCreatePlayerException();
JScript .NET | public function CannotCreatePlayerException();


Microsoft.DirectX.DirectPlay.CannotLaunchApplicationException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLaunchApplicationException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The lobby cannot launch the specified application. Deprecated.

Definition

Visual Basic .NET Public Class CannotLaunchApplicationException
Inherits DirectPlayException
C# | public class CannotLaunchApplicationException : DirectPlayException
Managed C++ | public __gc class CannotLaunchApplicationException : public DirectPlayException
JScript .NET | public class CannotLaunchApplicationException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotLaunchApplicationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotLaunchApplicationException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CannotLaunchApplicationException.CannotLaunchApplicationException

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotLaunchApplicationException();
protected CannotLaunchApplicationException(SerializationInfo, StreamingContext);
public CannotLaunchApplicationException(string);
public CannotLaunchApplicationException(string, Exception);


CannotLaunchApplicationException.CannotLaunchApplicationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotLaunchApplicationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: CannotLaunchApplicationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function CannotLaunchApplicationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


CannotLaunchApplicationException.CannotLaunchApplicationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotLaunchApplicationException(
string message,
Exception inner
);
Managed C++ public: CannotLaunchApplicationException(
String *message,
Exception *inner
);
JScript .NET public function CannotLaunchApplicationException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


CannotLaunchApplicationException.CannotLaunchApplicationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public CannotLaunchApplicationException(
string message
);
Managed C++ public: CannotLaunchApplicationException(
String *message
);
JScript .NET public function CannotLaunchApplicationException(
message : String
);

Parameters

message System.String.


CannotLaunchApplicationException.CannotLaunchApplicationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CannotLaunchApplicationException();
Managed C++ | public: CannotLaunchApplicationException();
JScript .NET | public function CannotLaunchApplicationException();


Microsoft.DirectX.DirectPlay.Client

Microsoft DirectX 9.0 SDK Update (October 2004)

Client Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Warning: This interface has been deprecated.
Applications use the methods of the Client object to create and manage client applications for client/server sessions. Deprecated.

Definition

Visual Basic .NET Public Class Client
Inherits MarshalByRefObject
Implements IDisposable
C# public class Client : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Client : public MarshalByRefObject,
IDisposable
JScript .NET public class Client extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ApplicationDescriptionChanged
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.
AsyncOperationComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.
ClientInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.
ConnectComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
FindHostResponse
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the client receives data. Deprecated.
SendComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.
ServerInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.
SessionTerminated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Methods

Method Description
CancelAsyncOperation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.
Client
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
FindHosts
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.
GetConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local client and the server. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetSendQueueInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should decrease the rate that messages are sent. Deprecated.
GetServerAddress
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address of the server for the session. Deprecated.
GetServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.
GetServiceProviders
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.
GetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DpnSpCapsDplay structure for the specified service provider. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_ApplicationDescriptionChanged
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_AsyncOperationComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostResponse
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SendComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionTerminated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Send
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.
SetClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.
SetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.
UnregisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the full application description for the connected application. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Client object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Client

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Client.CancelAsyncOperation

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Overload List

public void CancelAsyncOperation(CancelFlags);
public void CancelAsyncOperation(int);


Client.CancelAsyncOperation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic .NET Public Sub CancelAsyncOperation( _
ByVal asyncHandle As Integer _
)
C# public void CancelAsyncOperation(
int asyncHandle
);
Managed C++ public: void CancelAsyncOperation(
int asyncHandle
);
JScript .NET public function CancelAsyncOperation(
asyncHandle : int
);

Parameters

asyncHandle System.Int32.


Client.CancelAsyncOperation(CancelFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic .NET Public Sub CancelAsyncOperation( _
ByVal flags As CancelFlags _
)
C# public void CancelAsyncOperation(
CancelFlags flags
);
Managed C++ public: void CancelAsyncOperation(
CancelFlags flags
);
JScript .NET public function CancelAsyncOperation(
flags : CancelFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.CancelFlags.


Client.Client(InitializeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Client Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Client(
InitializeFlags flags
);
Managed C++ public: Client(
InitializeFlags flags
);
JScript .NET public function Client(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags.


Client.Connect

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Overload List

public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags, object);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags, object);


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags,
object userContext
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
ConnectFlags flags,
Object *userContext
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.
userContext | System.Object.


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags,
object userContext
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
int *asyncHandle,
ConnectFlags flags,
Object *userContext
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.
userContext | System.Object.


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
ConnectFlags flags
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
int *asyncHandle,
ConnectFlags flags
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.


Client.Dispose

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Overload List

public override void Dispose();
public void Dispose(bool);

See Also

  • Client.Disposed
  • Client.Disposing


Client.Dispose(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET Public Sub Dispose( _
ByVal closeImmediate As Boolean _
)
C# public void Dispose(
bool closeImmediate
);
Managed C++ public: void Dispose(
bool closeImmediate
);
JScript .NET public function Dispose(
closeImmediate : boolean
);

Parameters

closeImmediate System.Boolean.

See Also

  • Client.Disposed
  • Client.Disposing


Client.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Client.Disposed
  • Client.Disposing


Client.FindHosts

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Overload List

public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int, object);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, object);


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
object userContext
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
Object *userContext
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.
userContext | System.Object.


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle,
object userContext
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
int *asyncHandle,
Object *userContext
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.
asyncHandle | System.Int32.
userContext | System.Object.


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
int *asyncHandle
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.
asyncHandle | System.Int32.


Client.GetConnectionInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetConnectionInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local client and the server. Deprecated.

Definition

Visual Basic .NET | Public Function GetConnectionInformation() As ConnectionInformation
C# | public ConnectionInformation GetConnectionInformation();
Managed C++ | public: ConnectionInformation GetConnectionInformation();
JScript .NET | public function GetConnectionInformation() : ConnectionInformation;

Return Value

Microsoft.DirectX.DirectPlay.ConnectionInformation .


Client.GetSendQueueInformation(Int32,Int32,GetSendQueueInformationFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetSendQueueInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should decrease the rate that messages are sent. Deprecated.

Definition

Visual Basic .NET Public Sub GetSendQueueInformation( _
ByRef numberMessages As Integer, _
ByRef numberBytes As Integer, _
ByVal flags As GetSendQueueInformationFlags _
)
C# public void GetSendQueueInformation(
out int numberMessages,
out int numberBytes,
GetSendQueueInformationFlags flags
);
Managed C++ public: void GetSendQueueInformation(
int *numberMessages,
int *numberBytes,
GetSendQueueInformationFlags flags
);
JScript .NET public function GetSendQueueInformation(
numberMessages : int,
numberBytes : int,
flags : GetSendQueueInformationFlags
);

Parameters

numberMessages | System.Int32.
numberBytes | System.Int32.
flags | Microsoft.DirectX.DirectPlay.GetSendQueueInformationFlags.


Client.GetServerAddress()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetServerAddress Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address of the server for the session. Deprecated.

Definition

Visual Basic .NET | Public Function GetServerAddress() As Address
C# | public Address GetServerAddress();
Managed C++ | public: Address* GetServerAddress();
JScript .NET | public function GetServerAddress() : Address;

Return Value

Microsoft.DirectX.DirectPlay.Address .


Client.GetServerInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.

Definition

Visual Basic .NET | Public Function GetServerInformation() As PlayerInformation
C# | public PlayerInformation GetServerInformation();
Managed C++ | public: PlayerInformation GetServerInformation();
JScript .NET | public function GetServerInformation() : PlayerInformation;

Return Value

Microsoft.DirectX.DirectPlay.PlayerInformation .


Client.GetServiceProviders

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Overload List

public ServiceProviderInformation[] GetServiceProviders(bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, Guid, bool);


Client.GetServiceProviders(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
getAll : boolean
) : ServiceProviderInformation[];

Parameters

getAll System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Client.GetServiceProviders(Guid,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
Guid guidServiceProvider,
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
guidServiceProvider : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider | System.Guid.
getAll | System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Client.GetServiceProviders(Guid,Guid,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal guidApplication As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
guidServiceProvider : Guid,
guidApplication : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider | System.Guid.
guidApplication | System.Guid.
getAll | System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Client.GetSPCaps(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.GetSPCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DpnSpCapsDplay structure for the specified service provider. Deprecated.

Definition

Visual Basic .NET Public Function GetSPCaps( _
ByVal guidServiceProvider As Guid _
) As ServiceProviderCaps
C# public ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
Managed C++ public: ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
JScript .NET public function GetSPCaps(
guidServiceProvider : Guid
) : ServiceProviderCaps;

Parameters

guidServiceProvider System.Guid.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderCaps .


Client.op_Equality(Client,Client)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Equality(
Client left,
Client right
);
Managed C++ public: static bool op_Equality(
Client *left,
Client *right
);
JScript .NET public static function op_Equality(
left : Client,
right : Client
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Client. The Client structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Client. The Client structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Client.op_Inequality(Client,Client)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Inequality(
Client left,
Client right
);
Managed C++ public: static bool op_Inequality(
Client *left,
Client *right
);
JScript .NET public static function op_Inequality(
left : Client,
right : Client
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Client. The Client structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Client. The Client structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Client.raise_ApplicationDescriptionChanged(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_ApplicationDescriptionChanged Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ApplicationDescriptionChanged( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_ApplicationDescriptionChanged(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_ApplicationDescriptionChanged(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_ApplicationDescriptionChanged(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Client.raise_AsyncOperationComplete(Object,AsyncOperationCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_AsyncOperationComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_AsyncOperationComplete( _
ByVal i1 As Object, _
ByVal i2 As AsyncOperationCompleteEventArgs _
)
C# protected void raise_AsyncOperationComplete(
object i1,
AsyncOperationCompleteEventArgs i2
);
Managed C++ protected: void raise_AsyncOperationComplete(
Object *i1,
AsyncOperationCompleteEventArgs *i2
);
JScript .NET protected function raise_AsyncOperationComplete(
i1 : Object,
i2 : AsyncOperationCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs.


Client.raise_ClientInformation(Object,ClientInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_ClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ClientInformation( _
ByVal i1 As Object, _
ByVal i2 As ClientInformationEventArgs _
)
C# protected void raise_ClientInformation(
object i1,
ClientInformationEventArgs i2
);
Managed C++ protected: void raise_ClientInformation(
Object *i1,
ClientInformationEventArgs *i2
);
JScript .NET protected function raise_ClientInformation(
i1 : Object,
i2 : ClientInformationEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ClientInformationEventArgs.


Client.raise_ConnectComplete(Object,ConnectCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_ConnectComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ConnectComplete( _
ByVal i1 As Object, _
ByVal i2 As ConnectCompleteEventArgs _
)
C# protected void raise_ConnectComplete(
object i1,
ConnectCompleteEventArgs i2
);
Managed C++ protected: void raise_ConnectComplete(
Object *i1,
ConnectCompleteEventArgs *i2
);
JScript .NET protected function raise_ConnectComplete(
i1 : Object,
i2 : ConnectCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ConnectCompleteEventArgs.


Client.raise_FindHostResponse(Object,FindHostResponseEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_FindHostResponse Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_FindHostResponse( _
ByVal i1 As Object, _
ByVal i2 As FindHostResponseEventArgs _
)
C# protected void raise_FindHostResponse(
object i1,
FindHostResponseEventArgs i2
);
Managed C++ protected: void raise_FindHostResponse(
Object *i1,
FindHostResponseEventArgs *i2
);
JScript .NET protected function raise_FindHostResponse(
i1 : Object,
i2 : FindHostResponseEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.FindHostResponseEventArgs.


Client.raise_Receive(Object,ReceiveEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_Receive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
Managed C++ protected: void raise_Receive(
Object *i1,
ReceiveEventArgs *i2
);
JScript .NET protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ReceiveEventArgs.


Client.raise_SendComplete(Object,SendCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_SendComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SendComplete( _
ByVal i1 As Object, _
ByVal i2 As SendCompleteEventArgs _
)
C# protected void raise_SendComplete(
object i1,
SendCompleteEventArgs i2
);
Managed C++ protected: void raise_SendComplete(
Object *i1,
SendCompleteEventArgs *i2
);
JScript .NET protected function raise_SendComplete(
i1 : Object,
i2 : SendCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.SendCompleteEventArgs.


Client.raise_ServerInformation(Object,ServerInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_ServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ServerInformation( _
ByVal i1 As Object, _
ByVal i2 As ServerInformationEventArgs _
)
C# protected void raise_ServerInformation(
object i1,
ServerInformationEventArgs i2
);
Managed C++ protected: void raise_ServerInformation(
Object *i1,
ServerInformationEventArgs *i2
);
JScript .NET protected function raise_ServerInformation(
i1 : Object,
i2 : ServerInformationEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ServerInformationEventArgs.


Client.raise_SessionTerminated(Object,SessionTerminatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.raise_SessionTerminated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SessionTerminated( _
ByVal i1 As Object, _
ByVal i2 As SessionTerminatedEventArgs _
)
C# protected void raise_SessionTerminated(
object i1,
SessionTerminatedEventArgs i2
);
Managed C++ protected: void raise_SessionTerminated(
Object *i1,
SessionTerminatedEventArgs *i2
);
JScript .NET protected function raise_SessionTerminated(
i1 : Object,
i2 : SessionTerminatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.SessionTerminatedEventArgs.


Client.RegisterLobby(Int32,Application)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.RegisterLobby Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub RegisterLobby( _
ByVal handle As Integer, _
ByVal lobbiedApplication As Application _
)
C# public void RegisterLobby(
int handle,
Application lobbiedApplication
);
Managed C++ public: void RegisterLobby(
int handle,
Application *lobbiedApplication
);
JScript .NET public function RegisterLobby(
handle : int,
lobbiedApplication : Application
);

Parameters

handle | System.Int32.
lobbiedApplication | Microsoft.DirectX.DirectPlay.Lobby.Application.


Client.Send

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Overload List

public void Send(GCHandle, int, int, out int, SendFlags);
public void Send(GCHandle, int, int, out int, SendFlags, object);
public void Send(GCHandle, int, int, SendFlags);
public void Send(GCHandle, int, int, SendFlags, object);
public void Send(NetworkPacket, int, out int, SendFlags);
public void Send(NetworkPacket, int, out int, SendFlags, object);
public void Send(NetworkPacket, int, SendFlags);
public void Send(NetworkPacket, int, SendFlags, object);


Client.Send(GCHandle,Int32,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
Managed C++ public: void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
int *asyncHandle,
SendFlags flags,
Object *context
);
JScript .NET public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Client.Send(GCHandle,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
object context
);
Managed C++ public: void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
Object *context
);
JScript .NET public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Client.Send(GCHandle,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
Managed C++ public: void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
JScript .NET public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags
);

Parameters

gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Client.Send(GCHandle,Int32,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags
);
Managed C++ public: void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
int *asyncHandle,
SendFlags flags
);
JScript .NET public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Client.Send(NetworkPacket,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
Managed C++ public: void Send(
NetworkPacket *sendData,
int timeOut,
int *asyncHandle,
SendFlags flags,
Object *context
);
JScript .NET public function Send(
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Client.Send(NetworkPacket,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
SendFlags flags,
object context
);
Managed C++ public: void Send(
NetworkPacket *sendData,
int timeOut,
SendFlags flags,
Object *context
);
JScript .NET public function Send(
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Client.Send(NetworkPacket,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
SendFlags flags
);
Managed C++ public: void Send(
NetworkPacket *sendData,
int timeOut,
SendFlags flags
);
JScript .NET public function Send(
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags
);

Parameters

sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Client.Send(NetworkPacket,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Send Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags
);
Managed C++ public: void Send(
NetworkPacket *sendData,
int timeOut,
int *asyncHandle,
SendFlags flags
);
JScript .NET public function Send(
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Client.SetClientInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Overload List

public void SetClientInformation(PlayerInformation, out int, SyncFlags);
public void SetClientInformation(PlayerInformation, out int, SyncFlags, object);
public void SetClientInformation(PlayerInformation, SyncFlags);
public void SetClientInformation(PlayerInformation, SyncFlags, object);


Client.SetClientInformation(PlayerInformation,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
Managed C++ public: void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
JScript .NET public function SetClientInformation(
playerInformation : PlayerInformation,
flags : SyncFlags
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Client.SetClientInformation(PlayerInformation,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void SetClientInformation(
PlayerInformation playerInformation,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function SetClientInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Client.SetClientInformation(PlayerInformation,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetClientInformation(
playerInformation : PlayerInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Client.SetClientInformation(PlayerInformation,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetClientInformation(
PlayerInformation playerInformation,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetClientInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Client.SetSPCaps(Guid,ServiceProviderCaps)

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SetSPCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.

Definition

Visual Basic .NET Public Sub SetSPCaps( _
ByVal guidServiceProvider As Guid, _
ByVal value As ServiceProviderCaps _
)
C# public void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
Managed C++ public: void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
JScript .NET public function SetSPCaps(
guidServiceProvider : Guid,
value : ServiceProviderCaps
);

Parameters

guidServiceProvider | System.Guid.
value | Microsoft.DirectX.DirectPlay.ServiceProviderCaps.


Client.UnregisterLobby()

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.UnregisterLobby Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Sub UnregisterLobby()
C# | public void UnregisterLobby();
Managed C++ | public: void UnregisterLobby();
JScript .NET | public function UnregisterLobby();


Client.ApplicationDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ApplicationDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the full application description for the connected application. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; }
Managed C++ | public: __property ApplicationDescription get_ApplicationDescription();
JScript .NET | public function get ApplicationDescription() : ApplicationDescription

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription .

This property is read-only.


Client.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Client object. Deprecated.

Definition

Visual Basic .NET | Public Property Caps As Caps
C# | public Caps Caps { get; set; }
Managed C++ public: __property Caps get_Caps();
public: __property void set_Caps(Caps);
JScript .NET public function get Caps() : Caps
public function set Caps(Caps);

Property Value

Microsoft.DirectX.DirectPlay.Caps .

This property is read/write.


Client.ApplicationDescriptionChanged

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ApplicationDescriptionChanged Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.

Definition

Visual Basic .NET | Public Event ApplicationDescriptionChanged As ApplicationDescriptionEventHandler
C# | public event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
Managed C++ | public: __event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.AsyncOperationComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.AsyncOperationComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.

Definition

Visual Basic .NET | Public Event AsyncOperationComplete As AsyncOperationCompleteEventHandler
C# | public event AsyncOperationCompleteEventHandler AsyncOperationComplete;
Managed C++ | public: __event AsyncOperationCompleteEventHandler AsyncOperationComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.ClientInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ClientInformation Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic .NET | Public Event ClientInformation As ClientInformationEventHandler
C# | public event ClientInformationEventHandler ClientInformation;
Managed C++ | public: __event ClientInformationEventHandler ClientInformation;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.ConnectComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ConnectComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has completed. Deprecated.

Definition

Visual Basic .NET | Public Event ConnectComplete As ConnectCompleteEventHandler
C# | public event ConnectCompleteEventHandler ConnectComplete;
Managed C++ | public: __event ConnectCompleteEventHandler ConnectComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.FindHostResponse

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.FindHostResponse Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.

Definition

Visual Basic .NET | Public Event FindHostResponse As FindHostResponseEventHandler
C# | public event FindHostResponseEventHandler FindHostResponse;
Managed C++ | public: __event FindHostResponseEventHandler FindHostResponse;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.Receive

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.Receive Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the client receives data. Deprecated.

Definition

Visual Basic .NET | Public Event Receive As ReceiveEventHandler
C# | public event ReceiveEventHandler Receive;
Managed C++ | public: __event ReceiveEventHandler Receive;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.SendComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SendComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.

Definition

Visual Basic .NET | Public Event SendComplete As SendCompleteEventHandler
C# | public event SendCompleteEventHandler SendComplete;
Managed C++ | public: __event SendCompleteEventHandler SendComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.ServerInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.ServerInformation Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.

Definition

Visual Basic .NET | Public Event ServerInformation As ServerInformationEventHandler
C# | public event ServerInformationEventHandler ServerInformation;
Managed C++ | public: __event ServerInformationEventHandler ServerInformation;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Client.SessionTerminated

Microsoft DirectX 9.0 SDK Update (October 2004)

Client.SessionTerminated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Definition

Visual Basic .NET | Public Event SessionTerminated As SessionTerminatedEventHandler
C# | public event SessionTerminatedEventHandler SessionTerminated;
Managed C++ | public: __event SessionTerminatedEventHandler SessionTerminated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.ClientInformationEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ClientInformationEventArgs
Inherits EventArgs
C# | public sealed class ClientInformationEventArgs : EventArgs
Managed C++ | public __gc __sealed class ClientInformationEventArgs : public EventArgs
JScript .NET | public class ClientInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ClientInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ClientInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClientInformationEventArgs.ClientInformationEventArgs(ClientInformationMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationEventArgs.ClientInformationEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ClientInformationMessage _
)
C# public ClientInformationEventArgs(
ClientInformationMessage dpMessage
);
Managed C++ public: ClientInformationEventArgs(
ClientInformationMessage dpMessage
);
JScript .NET public function ClientInformationEventArgs(
dpMessage : ClientInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ClientInformationMessage.


ClientInformationEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ClientInformationMessage
C# | public ClientInformationMessage Message;
Managed C++ | public: ClientInformationMessage Message;
JScript .NET | public var Message : ClientInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.ClientInformationMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.ConnectCompleteEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ConnectCompleteEventArgs
Inherits EventArgs
C# | public sealed class ConnectCompleteEventArgs : EventArgs
Managed C++ | public __gc __sealed class ConnectCompleteEventArgs : public EventArgs
JScript .NET | public class ConnectCompleteEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectCompleteEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectCompleteEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectCompleteEventArgs.ConnectCompleteEventArgs(ConnectCompleteMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteEventArgs.ConnectCompleteEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ConnectCompleteMessage _
)
C# public ConnectCompleteEventArgs(
ConnectCompleteMessage dpMessage
);
Managed C++ public: ConnectCompleteEventArgs(
ConnectCompleteMessage dpMessage
);
JScript .NET public function ConnectCompleteEventArgs(
dpMessage : ConnectCompleteMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ConnectCompleteMessage.


ConnectCompleteEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ConnectCompleteMessage
C# | public ConnectCompleteMessage Message;
Managed C++ | public: ConnectCompleteMessage Message;
JScript .NET | public var Message : ConnectCompleteMessage

Field Value

Microsoft.DirectX.DirectPlay.ConnectCompleteMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.ConnectingException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The method is in the process of connecting to the network. Deprecated.

Definition

Visual Basic .NET Public Class ConnectingException
Inherits DirectPlayException
C# | public class ConnectingException : DirectPlayException
Managed C++ | public __gc class ConnectingException : public DirectPlayException
JScript .NET | public class ConnectingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
ConnectingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectingException.ConnectingException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectingException.ConnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectingException();
protected ConnectingException(SerializationInfo, StreamingContext);
public ConnectingException(string);
public ConnectingException(string, Exception);


ConnectingException.ConnectingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectingException.ConnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConnectingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConnectingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ConnectingException.ConnectingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectingException.ConnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectingException(
string message,
Exception inner
);
Managed C++ public: ConnectingException(
String *message,
Exception *inner
);
JScript .NET public function ConnectingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ConnectingException.ConnectingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectingException.ConnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConnectingException(
string message
);
Managed C++ public: ConnectingException(
String *message
);
JScript .NET public function ConnectingException(
message : String
);

Parameters

message System.String.


ConnectingException.ConnectingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectingException.ConnectingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectingException();
Managed C++ | public: ConnectingException();
JScript .NET | public function ConnectingException();


Microsoft.DirectX.DirectPlay.ConnectionLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider connection was reset while data was being sent. Deprecated.

Definition

Visual Basic .NET Public Class ConnectionLostException
Inherits DirectPlayException
C# | public class ConnectionLostException : DirectPlayException
Managed C++ | public __gc class ConnectionLostException : public DirectPlayException
JScript .NET | public class ConnectionLostException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectionLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
ConnectionLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.ConversionException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConversionException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data could not be converted. Deprecated.

Definition

Visual Basic .NET Public Class ConversionException
Inherits DirectPlayException
C# | public class ConversionException : DirectPlayException
Managed C++ | public __gc class ConversionException : public DirectPlayException
JScript .NET | public class ConversionException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConversionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
ConversionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConversionException.ConversionException

Microsoft DirectX 9.0 SDK Update (October 2004)

ConversionException.ConversionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConversionException();
protected ConversionException(SerializationInfo, StreamingContext);
public ConversionException(string);
public ConversionException(string, Exception);


ConversionException.ConversionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConversionException.ConversionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConversionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ConversionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ConversionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


ConversionException.ConversionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConversionException.ConversionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConversionException(
string message,
Exception inner
);
Managed C++ public: ConversionException(
String *message,
Exception *inner
);
JScript .NET public function ConversionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


ConversionException.ConversionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConversionException.ConversionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ConversionException(
string message
);
Managed C++ public: ConversionException(
String *message
);
JScript .NET public function ConversionException(
message : String
);

Parameters

message System.String.


ConversionException.ConversionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConversionException.ConversionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConversionException();
Managed C++ | public: ConversionException();
JScript .NET | public function ConversionException();


Microsoft.DirectX.DirectPlay.DataTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

DataTooLargeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application data is too large for the service provider's Maximum Transmission Unit. Deprecated.

Definition

Visual Basic .NET Public Class DataTooLargeException
Inherits DirectPlayException
C# | public class DataTooLargeException : DirectPlayException
Managed C++ | public __gc class DataTooLargeException : public DirectPlayException
JScript .NET | public class DataTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DataTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
DataTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DataTooLargeException.DataTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

DataTooLargeException.DataTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DataTooLargeException();
protected DataTooLargeException(SerializationInfo, StreamingContext);
public DataTooLargeException(string);
public DataTooLargeException(string, Exception);


DataTooLargeException.DataTooLargeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DataTooLargeException.DataTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DataTooLargeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DataTooLargeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DataTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DataTooLargeException.DataTooLargeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DataTooLargeException.DataTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DataTooLargeException(
string message,
Exception inner
);
Managed C++ public: DataTooLargeException(
String *message,
Exception *inner
);
JScript .NET public function DataTooLargeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DataTooLargeException.DataTooLargeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DataTooLargeException.DataTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DataTooLargeException(
string message
);
Managed C++ public: DataTooLargeException(
String *message
);
JScript .NET public function DataTooLargeException(
message : String
);

Parameters

message System.String.


DataTooLargeException.DataTooLargeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DataTooLargeException.DataTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DataTooLargeException();
Managed C++ | public: DataTooLargeException();
JScript .NET | public function DataTooLargeException();


Microsoft.DirectX.DirectPlay.DirectPlayException

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectPlayException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for all DirectPlay exceptions. Derives from DirectXException. Deprecated.

Definition

Visual Basic .NET Public Class DirectPlayException
Inherits DirectXException
C# | public class DirectPlayException : DirectXException
Managed C++ | public __gc class DirectPlayException : public DirectXException
JScript .NET | public class DirectPlayException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DirectPlayException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AbortedException
AddressingException
AlreadyClosingException
AlreadyConnectedException
AlreadyDisconnectingException
AlreadyRegisteredException
CannotCancelException
CannotCreateGroupException
CannotCreatePlayerException
CannotLaunchApplicationException
ConnectingException
ConnectionLostException
ConversionException
DataTooLargeException
DoesNotExistException
DuplicateCommandException
EndPointNotReceivingException
FindHostQueryTooLargeException
FindHostResponseTooLargeException
GroupNotEmptyException
HostingException
IncompleteAddressException
InvalidAddressFormatException
InvalidApplicationException
InvalidCommandException
InvalidDeviceAddressException
InvalidEndPointException
InvalidFlagsException
InvalidGroupException
InvalidHandleException
InvalidHostAddressException
InvalidInstanceException
InvalidObjectException
InvalidPasswordException
InvalidPlayerException
InvalidPriorityException
InvalidStringException
InvalidUrlException
InvalidVersionException
NoCapsException
NoConnectionException
NoHostPlayerException
NoMoreAddressComponentsException
NoResponseException
NotAllowedException
NotHostException
NotReadyException
NotRegisteredException
PlayerAlreadyInGroupException
PlayerLostException
PlayerNotInGroupException
PlayerNotReachableException
SendTooLargeException
SessionFullException
TableFullException
TimedOutException
UserCancelException
VoiceException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DirectPlayException.DirectPlayException

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectPlayException.DirectPlayException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DirectPlayException();
protected DirectPlayException(SerializationInfo, StreamingContext);
public DirectPlayException(string);
public DirectPlayException(string, Exception);


DirectPlayException.DirectPlayException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectPlayException.DirectPlayException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DirectPlayException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DirectPlayException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DirectPlayException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DirectPlayException.DirectPlayException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectPlayException.DirectPlayException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DirectPlayException(
string message,
Exception inner
);
Managed C++ public: DirectPlayException(
String *message,
Exception *inner
);
JScript .NET public function DirectPlayException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DirectPlayException.DirectPlayException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectPlayException.DirectPlayException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DirectPlayException(
string message
);
Managed C++ public: DirectPlayException(
String *message
);
JScript .NET public function DirectPlayException(
message : String
);

Parameters

message System.String.


DirectPlayException.DirectPlayException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectPlayException.DirectPlayException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DirectPlayException();
Managed C++ | public: DirectPlayException();
JScript .NET | public function DirectPlayException();


DirectPlayException.GetExceptionFromResultInternal(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectPlayException.GetExceptionFromResultInternal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32.

Return Value

System.Exception .

Applies To

This object applies to a large number of classes.


Microsoft.DirectX.DirectPlay.DoesNotExistException

Microsoft DirectX 9.0 SDK Update (October 2004)

DoesNotExistException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Requested element is not part of the address or the requested application globally unique identifier (Guid) is not registered. Deprecated.

Definition

Visual Basic .NET Public Class DoesNotExistException
Inherits DirectPlayException
C# | public class DoesNotExistException : DirectPlayException
Managed C++ | public __gc class DoesNotExistException : public DirectPlayException
JScript .NET | public class DoesNotExistException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DoesNotExistException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
DoesNotExistException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DoesNotExistException.DoesNotExistException

Microsoft DirectX 9.0 SDK Update (October 2004)

DoesNotExistException.DoesNotExistException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DoesNotExistException();
protected DoesNotExistException(SerializationInfo, StreamingContext);
public DoesNotExistException(string);
public DoesNotExistException(string, Exception);


DoesNotExistException.DoesNotExistException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DoesNotExistException.DoesNotExistException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DoesNotExistException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DoesNotExistException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DoesNotExistException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DoesNotExistException.DoesNotExistException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DoesNotExistException.DoesNotExistException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DoesNotExistException(
string message,
Exception inner
);
Managed C++ public: DoesNotExistException(
String *message,
Exception *inner
);
JScript .NET public function DoesNotExistException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DoesNotExistException.DoesNotExistException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DoesNotExistException.DoesNotExistException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DoesNotExistException(
string message
);
Managed C++ public: DoesNotExistException(
String *message
);
JScript .NET public function DoesNotExistException(
message : String
);

Parameters

message System.String.


DoesNotExistException.DoesNotExistException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DoesNotExistException.DoesNotExistException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DoesNotExistException();
Managed C++ | public: DoesNotExistException();
JScript .NET | public function DoesNotExistException();


Microsoft.DirectX.DirectPlay.DuplicateCommandException

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateCommandException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A duplicate command has been issued. Deprecated.

Definition

Visual Basic .NET Public Class DuplicateCommandException
Inherits DirectPlayException
C# | public class DuplicateCommandException : DirectPlayException
Managed C++ | public __gc class DuplicateCommandException : public DirectPlayException
JScript .NET | public class DuplicateCommandException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DuplicateCommandException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
DuplicateCommandException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DuplicateCommandException.DuplicateCommandException

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DuplicateCommandException();
protected DuplicateCommandException(SerializationInfo, StreamingContext);
public DuplicateCommandException(string);
public DuplicateCommandException(string, Exception);


DuplicateCommandException.DuplicateCommandException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DuplicateCommandException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DuplicateCommandException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DuplicateCommandException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


DuplicateCommandException.DuplicateCommandException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DuplicateCommandException(
string message,
Exception inner
);
Managed C++ public: DuplicateCommandException(
String *message,
Exception *inner
);
JScript .NET public function DuplicateCommandException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


DuplicateCommandException.DuplicateCommandException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DuplicateCommandException(
string message
);
Managed C++ public: DuplicateCommandException(
String *message
);
JScript .NET public function DuplicateCommandException(
message : String
);

Parameters

message System.String.


DuplicateCommandException.DuplicateCommandException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DuplicateCommandException();
Managed C++ | public: DuplicateCommandException();
JScript .NET | public function DuplicateCommandException();


Microsoft.DirectX.DirectPlay.EndPointNotReceivingException

Microsoft DirectX 9.0 SDK Update (October 2004)

EndPointNotReceivingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An end point is not receiving data. Deprecated.

Definition

Visual Basic .NET Public Class EndPointNotReceivingException
Inherits DirectPlayException
C# | public class EndPointNotReceivingException : DirectPlayException
Managed C++ | public __gc class EndPointNotReceivingException : public DirectPlayException
JScript .NET | public class EndPointNotReceivingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
EndPointNotReceivingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
EndPointNotReceivingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EndPointNotReceivingException.EndPointNotReceivingException

Microsoft DirectX 9.0 SDK Update (October 2004)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public EndPointNotReceivingException();
protected EndPointNotReceivingException(SerializationInfo, StreamingContext);
public EndPointNotReceivingException(string);
public EndPointNotReceivingException(string, Exception);


EndPointNotReceivingException.EndPointNotReceivingException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected EndPointNotReceivingException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: EndPointNotReceivingException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function EndPointNotReceivingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


EndPointNotReceivingException.EndPointNotReceivingException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public EndPointNotReceivingException(
string message,
Exception inner
);
Managed C++ public: EndPointNotReceivingException(
String *message,
Exception *inner
);
JScript .NET public function EndPointNotReceivingException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


EndPointNotReceivingException.EndPointNotReceivingException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public EndPointNotReceivingException(
string message
);
Managed C++ public: EndPointNotReceivingException(
String *message
);
JScript .NET public function EndPointNotReceivingException(
message : String
);

Parameters

message System.String.


EndPointNotReceivingException.EndPointNotReceivingException()

Microsoft DirectX 9.0 SDK Update (October 2004)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public EndPointNotReceivingException();
Managed C++ | public: EndPointNotReceivingException();
JScript .NET | public function EndPointNotReceivingException();


Microsoft.DirectX.DirectPlay.FindHostQueryEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the FindHostQuery event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class FindHostQueryEventArgs
Inherits EventArgs
C# | public sealed class FindHostQueryEventArgs : EventArgs
Managed C++ | public __gc __sealed class FindHostQueryEventArgs : public EventArgs
JScript .NET | public class FindHostQueryEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
FindHostQueryEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
RejectMessage
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
FindHostQueryEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostQueryEventArgs.FindHostQueryEventArgs(FindHostsQueryMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryEventArgs.FindHostQueryEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As FindHostsQueryMessage _
)
C# public FindHostQueryEventArgs(
FindHostsQueryMessage dpMessage
);
Managed C++ public: FindHostQueryEventArgs(
FindHostsQueryMessage dpMessage
);
JScript .NET public function FindHostQueryEventArgs(
dpMessage : FindHostsQueryMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.FindHostsQueryMessage.


FindHostQueryEventArgs.RejectMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryEventArgs.RejectMessage Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Definition

Visual Basic .NET | Public Property RejectMessage As Boolean
C# | public bool RejectMessage { get; set; }
Managed C++ public: __property bool get_RejectMessage();
public: __property void set_RejectMessage(bool);
JScript .NET public function get RejectMessage() : boolean
public function set RejectMessage(boolean);

Property Value

System.Boolean .

This property is read/write.


FindHostQueryEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As FindHostsQueryMessage
C# | public FindHostsQueryMessage Message;
Managed C++ | public: FindHostsQueryMessage Message;
JScript .NET | public var Message : FindHostsQueryMessage

Field Value

Microsoft.DirectX.DirectPlay.FindHostsQueryMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.FindHostQueryTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryTooLargeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The query data specified is too large. Deprecated.

Definition

Visual Basic .NET Public Class FindHostQueryTooLargeException
Inherits DirectPlayException
C# | public class FindHostQueryTooLargeException : DirectPlayException
Managed C++ | public __gc class FindHostQueryTooLargeException : public DirectPlayException
JScript .NET | public class FindHostQueryTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
FindHostQueryTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
FindHostQueryTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostQueryTooLargeException.FindHostQueryTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public FindHostQueryTooLargeException();
protected FindHostQueryTooLargeException(SerializationInfo, StreamingContext);
public FindHostQueryTooLargeException(string);
public FindHostQueryTooLargeException(string, Exception);


FindHostQueryTooLargeException.FindHostQueryTooLargeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected FindHostQueryTooLargeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: FindHostQueryTooLargeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function FindHostQueryTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


FindHostQueryTooLargeException.FindHostQueryTooLargeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public FindHostQueryTooLargeException(
string message,
Exception inner
);
Managed C++ public: FindHostQueryTooLargeException(
String *message,
Exception *inner
);
JScript .NET public function FindHostQueryTooLargeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


FindHostQueryTooLargeException.FindHostQueryTooLargeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public FindHostQueryTooLargeException(
string message
);
Managed C++ public: FindHostQueryTooLargeException(
String *message
);
JScript .NET public function FindHostQueryTooLargeException(
message : String
);

Parameters

message System.String.


FindHostQueryTooLargeException.FindHostQueryTooLargeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public FindHostQueryTooLargeException();
Managed C++ | public: FindHostQueryTooLargeException();
JScript .NET | public function FindHostQueryTooLargeException();


Microsoft.DirectX.DirectPlay.FindHostResponseEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class FindHostResponseEventArgs
Inherits EventArgs
C# | public sealed class FindHostResponseEventArgs : EventArgs
Managed C++ | public __gc __sealed class FindHostResponseEventArgs : public EventArgs
JScript .NET | public class FindHostResponseEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
FindHostResponseEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
FindHostResponseEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostResponseEventArgs.FindHostResponseEventArgs(FindHostsResponseMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseEventArgs.FindHostResponseEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As FindHostsResponseMessage _
)
C# public FindHostResponseEventArgs(
FindHostsResponseMessage dpMessage
);
Managed C++ public: FindHostResponseEventArgs(
FindHostsResponseMessage dpMessage
);
JScript .NET public function FindHostResponseEventArgs(
dpMessage : FindHostsResponseMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.FindHostsResponseMessage.


FindHostResponseEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As FindHostsResponseMessage
C# | public FindHostsResponseMessage Message;
Managed C++ | public: FindHostsResponseMessage Message;
JScript .NET | public var Message : FindHostsResponseMessage

Field Value

Microsoft.DirectX.DirectPlay.FindHostsResponseMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.FindHostResponseTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseTooLargeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.

Definition

Visual Basic .NET Public Class FindHostResponseTooLargeException
Inherits DirectPlayException
C# | public class FindHostResponseTooLargeException : DirectPlayException
Managed C++ | public __gc class FindHostResponseTooLargeException : public DirectPlayException
JScript .NET | public class FindHostResponseTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
FindHostResponseTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
FindHostResponseTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostResponseTooLargeException.FindHostResponseTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public FindHostResponseTooLargeException();
protected FindHostResponseTooLargeException(SerializationInfo, StreamingContext);
public FindHostResponseTooLargeException(string);
public FindHostResponseTooLargeException(string, Exception);


FindHostResponseTooLargeException.FindHostResponseTooLargeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected FindHostResponseTooLargeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: FindHostResponseTooLargeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function FindHostResponseTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


FindHostResponseTooLargeException.FindHostResponseTooLargeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public FindHostResponseTooLargeException(
string message,
Exception inner
);
Managed C++ public: FindHostResponseTooLargeException(
String *message,
Exception *inner
);
JScript .NET public function FindHostResponseTooLargeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


FindHostResponseTooLargeException.FindHostResponseTooLargeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public FindHostResponseTooLargeException(
string message
);
Managed C++ public: FindHostResponseTooLargeException(
String *message
);
JScript .NET public function FindHostResponseTooLargeException(
message : String
);

Parameters

message System.String.


FindHostResponseTooLargeException.FindHostResponseTooLargeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public FindHostResponseTooLargeException();
Managed C++ | public: FindHostResponseTooLargeException();
JScript .NET | public function FindHostResponseTooLargeException();


Microsoft.DirectX.DirectPlay.GroupCreatedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupCreatedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the GroupCreated event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class GroupCreatedEventArgs
Inherits EventArgs
C# | public sealed class GroupCreatedEventArgs : EventArgs
Managed C++ | public __gc __sealed class GroupCreatedEventArgs : public EventArgs
JScript .NET | public class GroupCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
GroupCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
GroupCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupCreatedEventArgs.GroupCreatedEventArgs(CreateGroupMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupCreatedEventArgs.GroupCreatedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As CreateGroupMessage _
)
C# public GroupCreatedEventArgs(
CreateGroupMessage dpMessage
);
Managed C++ public: GroupCreatedEventArgs(
CreateGroupMessage dpMessage
);
JScript .NET public function GroupCreatedEventArgs(
dpMessage : CreateGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.CreateGroupMessage.


GroupCreatedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupCreatedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As CreateGroupMessage
C# | public CreateGroupMessage Message;
Managed C++ | public: CreateGroupMessage Message;
JScript .NET | public var Message : CreateGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.CreateGroupMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.GroupDestroyedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupDestroyedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the Group Destroyed event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class GroupDestroyedEventArgs
Inherits EventArgs
C# | public sealed class GroupDestroyedEventArgs : EventArgs
Managed C++ | public __gc __sealed class GroupDestroyedEventArgs : public EventArgs
JScript .NET | public class GroupDestroyedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
GroupDestroyedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
GroupDestroyedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupDestroyedEventArgs.GroupDestroyedEventArgs(DestroyGroupMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupDestroyedEventArgs.GroupDestroyedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As DestroyGroupMessage _
)
C# public GroupDestroyedEventArgs(
DestroyGroupMessage dpMessage
);
Managed C++ public: GroupDestroyedEventArgs(
DestroyGroupMessage dpMessage
);
JScript .NET public function GroupDestroyedEventArgs(
dpMessage : DestroyGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.DestroyGroupMessage.


GroupDestroyedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupDestroyedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As DestroyGroupMessage
C# | public DestroyGroupMessage Message;
Managed C++ | public: DestroyGroupMessage Message;
JScript .NET | public var Message : DestroyGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.DestroyGroupMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.GroupInformationEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class GroupInformationEventArgs
Inherits EventArgs
C# | public sealed class GroupInformationEventArgs : EventArgs
Managed C++ | public __gc __sealed class GroupInformationEventArgs : public EventArgs
JScript .NET | public class GroupInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
GroupInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
GroupInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupInformationEventArgs.GroupInformationEventArgs(GroupInformationMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationEventArgs.GroupInformationEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As GroupInformationMessage _
)
C# public GroupInformationEventArgs(
GroupInformationMessage dpMessage
);
Managed C++ public: GroupInformationEventArgs(
GroupInformationMessage dpMessage
);
JScript .NET public function GroupInformationEventArgs(
dpMessage : GroupInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.GroupInformationMessage.


GroupInformationEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As GroupInformationMessage
C# | public GroupInformationMessage Message;
Managed C++ | public: GroupInformationMessage Message;
JScript .NET | public var Message : GroupInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.GroupInformationMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.GroupMembersList

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupMembersList Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of group members. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class GroupMembersList
Inherits Object
C# | public sealed class GroupMembersList : Object
Managed C++ | public __gc __sealed class GroupMembersList : public Object
JScript .NET | public class GroupMembersList extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property Description
Item
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Inheritance Hierarchy

Object Leave Site
GroupMembersList

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupMembersList.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupMembersList.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal groupId As Integer _
) As PlayersGroupsEnumerator
C# public PlayersGroupsEnumerator this[
int groupId
] { get; }
Managed C++ public: __property PlayersGroupsEnumerator* get_Item(
int groupId
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator .

This property is read-only.

Parameters

groupId System.Int32.


Microsoft.DirectX.DirectPlay.GroupNotEmptyException

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupNotEmptyException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified group is not empty. Deprecated.

Definition

Visual Basic .NET Public Class GroupNotEmptyException
Inherits DirectPlayException
C# | public class GroupNotEmptyException : DirectPlayException
Managed C++ | public __gc class GroupNotEmptyException : public DirectPlayException
JScript .NET | public class GroupNotEmptyException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
GroupNotEmptyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
GroupNotEmptyException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupNotEmptyException.GroupNotEmptyException

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupNotEmptyException.GroupNotEmptyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public GroupNotEmptyException();
protected GroupNotEmptyException(SerializationInfo, StreamingContext);
public GroupNotEmptyException(string);
public GroupNotEmptyException(string, Exception);


GroupNotEmptyException.GroupNotEmptyException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupNotEmptyException.GroupNotEmptyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GroupNotEmptyException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: GroupNotEmptyException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function GroupNotEmptyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


GroupNotEmptyException.GroupNotEmptyException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupNotEmptyException.GroupNotEmptyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GroupNotEmptyException(
string message,
Exception inner
);
Managed C++ public: GroupNotEmptyException(
String *message,
Exception *inner
);
JScript .NET public function GroupNotEmptyException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


GroupNotEmptyException.GroupNotEmptyException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupNotEmptyException.GroupNotEmptyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public GroupNotEmptyException(
string message
);
Managed C++ public: GroupNotEmptyException(
String *message
);
JScript .NET public function GroupNotEmptyException(
message : String
);

Parameters

message System.String.


GroupNotEmptyException.GroupNotEmptyException()

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupNotEmptyException.GroupNotEmptyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public GroupNotEmptyException();
Managed C++ | public: GroupNotEmptyException();
JScript .NET | public function GroupNotEmptyException();


Microsoft.DirectX.DirectPlay.HostingException

Microsoft DirectX 9.0 SDK Update (October 2004)

HostingException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session is already hosting. Deprecated.

Definition

Visual Basic .NET Public Class HostingException
Inherits DirectPlayException
C# | public class HostingException : DirectPlayException
Managed C++ | public __gc class HostingException : public DirectPlayException
JScript .NET | public class HostingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
HostingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
HostingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.HostMigratedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class HostMigratedEventArgs
Inherits EventArgs
C# | public sealed class HostMigratedEventArgs : EventArgs
Managed C++ | public __gc __sealed class HostMigratedEventArgs : public EventArgs
JScript .NET | public class HostMigratedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
HostMigratedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
HostMigratedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HostMigratedEventArgs.HostMigratedEventArgs(HostMigratedMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedEventArgs.HostMigratedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As HostMigratedMessage _
)
C# public HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
Managed C++ public: HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
JScript .NET public function HostMigratedEventArgs(
dpMessage : HostMigratedMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.HostMigratedMessage.


HostMigratedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As HostMigratedMessage
C# | public HostMigratedMessage Message;
Managed C++ | public: HostMigratedMessage Message;
JScript .NET | public var Message : HostMigratedMessage

Field Value

Microsoft.DirectX.DirectPlay.HostMigratedMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.IncompleteAddressException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteAddressException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is not complete. Deprecated.

Definition

Visual Basic .NET Public Class IncompleteAddressException
Inherits DirectPlayException
C# | public class IncompleteAddressException : DirectPlayException
Managed C++ | public __gc class IncompleteAddressException : public DirectPlayException
JScript .NET | public class IncompleteAddressException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompleteAddressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
IncompleteAddressException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IncompleteAddressException.IncompleteAddressException

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public IncompleteAddressException();
protected IncompleteAddressException(SerializationInfo, StreamingContext);
public IncompleteAddressException(string);
public IncompleteAddressException(string, Exception);


IncompleteAddressException.IncompleteAddressException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompleteAddressException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: IncompleteAddressException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function IncompleteAddressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


IncompleteAddressException.IncompleteAddressException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompleteAddressException(
string message,
Exception inner
);
Managed C++ public: IncompleteAddressException(
String *message,
Exception *inner
);
JScript .NET public function IncompleteAddressException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


IncompleteAddressException.IncompleteAddressException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public IncompleteAddressException(
string message
);
Managed C++ public: IncompleteAddressException(
String *message
);
JScript .NET public function IncompleteAddressException(
message : String
);

Parameters

message System.String.


IncompleteAddressException.IncompleteAddressException()

Microsoft DirectX 9.0 SDK Update (October 2004)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public IncompleteAddressException();
Managed C++ | public: IncompleteAddressException();
JScript .NET | public function IncompleteAddressException();


Microsoft.DirectX.DirectPlay.IndicateConnectEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class IndicateConnectEventArgs
Inherits EventArgs
C# | public sealed class IndicateConnectEventArgs : EventArgs
Managed C++ | public __gc __sealed class IndicateConnectEventArgs : public EventArgs
JScript .NET | public class IndicateConnectEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
IndicateConnectEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
RejectMessage
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
IndicateConnectEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IndicateConnectEventArgs.IndicateConnectEventArgs(IndicateConnectMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectEventArgs.IndicateConnectEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As IndicateConnectMessage _
)
C# public IndicateConnectEventArgs(
IndicateConnectMessage dpMessage
);
Managed C++ public: IndicateConnectEventArgs(
IndicateConnectMessage dpMessage
);
JScript .NET public function IndicateConnectEventArgs(
dpMessage : IndicateConnectMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.IndicateConnectMessage.


IndicateConnectEventArgs.RejectMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectEventArgs.RejectMessage Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Definition

Visual Basic .NET | Public Property RejectMessage As Boolean
C# | public bool RejectMessage { get; set; }
Managed C++ public: __property bool get_RejectMessage();
public: __property void set_RejectMessage(bool);
JScript .NET public function get RejectMessage() : boolean
public function set RejectMessage(boolean);

Property Value

System.Boolean .

This property is read/write.


IndicateConnectEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As IndicateConnectMessage
C# | public IndicateConnectMessage Message;
Managed C++ | public: IndicateConnectMessage Message;
JScript .NET | public var Message : IndicateConnectMessage

Field Value

Microsoft.DirectX.DirectPlay.IndicateConnectMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class IndicatedConnectAbortedEventArgs
Inherits EventArgs
C# | public sealed class IndicatedConnectAbortedEventArgs : EventArgs
Managed C++ | public __gc __sealed class IndicatedConnectAbortedEventArgs : public EventArgs
JScript .NET | public class IndicatedConnectAbortedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Methods

Method Description
IndicatedConnectAbortedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
IndicatedConnectAbortedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IndicatedConnectAbortedEventArgs.IndicatedConnectAbortedEventArgs(IndicatedConnectAbortedMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedEventArgs.IndicatedConnectAbortedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As IndicatedConnectAbortedMessage _
)
C# public IndicatedConnectAbortedEventArgs(
IndicatedConnectAbortedMessage dpMessage
);
Managed C++ public: IndicatedConnectAbortedEventArgs(
IndicatedConnectAbortedMessage dpMessage
);
JScript .NET public function IndicatedConnectAbortedEventArgs(
dpMessage : IndicatedConnectAbortedMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedMessage.


IndicatedConnectAbortedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Message As IndicatedConnectAbortedMessage
C# | public IndicatedConnectAbortedMessage Message;
Managed C++ | public: IndicatedConnectAbortedMessage Message;
JScript .NET | public var Message : IndicatedConnectAbortedMessage

Field Value

Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.InvalidAddressFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidAddressFormatException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address format is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidAddressFormatException
Inherits DirectPlayException
C# | public class InvalidAddressFormatException : DirectPlayException
Managed C++ | public __gc class InvalidAddressFormatException : public DirectPlayException
JScript .NET | public class InvalidAddressFormatException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidAddressFormatException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidAddressFormatException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidAddressFormatException.InvalidAddressFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidAddressFormatException();
protected InvalidAddressFormatException(SerializationInfo, StreamingContext);
public InvalidAddressFormatException(string);
public InvalidAddressFormatException(string, Exception);


InvalidAddressFormatException.InvalidAddressFormatException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidAddressFormatException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidAddressFormatException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidAddressFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidAddressFormatException.InvalidAddressFormatException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidAddressFormatException(
string message,
Exception inner
);
Managed C++ public: InvalidAddressFormatException(
String *message,
Exception *inner
);
JScript .NET public function InvalidAddressFormatException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidAddressFormatException.InvalidAddressFormatException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidAddressFormatException(
string message
);
Managed C++ public: InvalidAddressFormatException(
String *message
);
JScript .NET public function InvalidAddressFormatException(
message : String
);

Parameters

message System.String.


InvalidAddressFormatException.InvalidAddressFormatException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidAddressFormatException();
Managed C++ | public: InvalidAddressFormatException();
JScript .NET | public function InvalidAddressFormatException();


Microsoft.DirectX.DirectPlay.InvalidApplicationException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidApplicationException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid supplied for the application is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidApplicationException
Inherits DirectPlayException
C# | public class InvalidApplicationException : DirectPlayException
Managed C++ | public __gc class InvalidApplicationException : public DirectPlayException
JScript .NET | public class InvalidApplicationException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidApplicationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidApplicationException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidApplicationException.InvalidApplicationException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidApplicationException();
protected InvalidApplicationException(SerializationInfo, StreamingContext);
public InvalidApplicationException(string);
public InvalidApplicationException(string, Exception);


InvalidApplicationException.InvalidApplicationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidApplicationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidApplicationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidApplicationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidApplicationException.InvalidApplicationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidApplicationException(
string message,
Exception inner
);
Managed C++ public: InvalidApplicationException(
String *message,
Exception *inner
);
JScript .NET public function InvalidApplicationException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidApplicationException.InvalidApplicationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidApplicationException(
string message
);
Managed C++ public: InvalidApplicationException(
String *message
);
JScript .NET public function InvalidApplicationException(
message : String
);

Parameters

message System.String.


InvalidApplicationException.InvalidApplicationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidApplicationException();
Managed C++ | public: InvalidApplicationException();
JScript .NET | public function InvalidApplicationException();


Microsoft.DirectX.DirectPlay.InvalidCommandException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCommandException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The command specified is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidCommandException
Inherits DirectPlayException
C# | public class InvalidCommandException : DirectPlayException
Managed C++ | public __gc class InvalidCommandException : public DirectPlayException
JScript .NET | public class InvalidCommandException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCommandException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidCommandException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidCommandException.InvalidCommandException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCommandException.InvalidCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidCommandException();
protected InvalidCommandException(SerializationInfo, StreamingContext);
public InvalidCommandException(string);
public InvalidCommandException(string, Exception);


InvalidCommandException.InvalidCommandException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCommandException.InvalidCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidCommandException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidCommandException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidCommandException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidCommandException.InvalidCommandException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCommandException.InvalidCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidCommandException(
string message,
Exception inner
);
Managed C++ public: InvalidCommandException(
String *message,
Exception *inner
);
JScript .NET public function InvalidCommandException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidCommandException.InvalidCommandException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCommandException.InvalidCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidCommandException(
string message
);
Managed C++ public: InvalidCommandException(
String *message
);
JScript .NET public function InvalidCommandException(
message : String
);

Parameters

message System.String.


InvalidCommandException.InvalidCommandException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCommandException.InvalidCommandException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidCommandException();
Managed C++ | public: InvalidCommandException();
JScript .NET | public function InvalidCommandException();


Microsoft.DirectX.DirectPlay.InvalidDeviceAddressException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceAddressException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address for the local computer or adapter is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidDeviceAddressException
Inherits DirectPlayException
C# | public class InvalidDeviceAddressException : DirectPlayException
Managed C++ | public __gc class InvalidDeviceAddressException : public DirectPlayException
JScript .NET | public class InvalidDeviceAddressException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDeviceAddressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidDeviceAddressException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidDeviceAddressException.InvalidDeviceAddressException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidDeviceAddressException();
protected InvalidDeviceAddressException(SerializationInfo, StreamingContext);
public InvalidDeviceAddressException(string);
public InvalidDeviceAddressException(string, Exception);


InvalidDeviceAddressException.InvalidDeviceAddressException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDeviceAddressException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidDeviceAddressException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidDeviceAddressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidDeviceAddressException.InvalidDeviceAddressException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDeviceAddressException(
string message,
Exception inner
);
Managed C++ public: InvalidDeviceAddressException(
String *message,
Exception *inner
);
JScript .NET public function InvalidDeviceAddressException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidDeviceAddressException.InvalidDeviceAddressException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidDeviceAddressException(
string message
);
Managed C++ public: InvalidDeviceAddressException(
String *message
);
JScript .NET public function InvalidDeviceAddressException(
message : String
);

Parameters

message System.String.


InvalidDeviceAddressException.InvalidDeviceAddressException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidDeviceAddressException();
Managed C++ | public: InvalidDeviceAddressException();
JScript .NET | public function InvalidDeviceAddressException();


Microsoft.DirectX.DirectPlay.InvalidEndPointException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidEndPointException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The endpoint was invalid Deprecated.

Definition

Visual Basic .NET Public Class InvalidEndPointException
Inherits DirectPlayException
C# | public class InvalidEndPointException : DirectPlayException
Managed C++ | public __gc class InvalidEndPointException : public DirectPlayException
JScript .NET | public class InvalidEndPointException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidEndPointException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidEndPointException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidEndPointException.InvalidEndPointException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidEndPointException();
protected InvalidEndPointException(SerializationInfo, StreamingContext);
public InvalidEndPointException(string);
public InvalidEndPointException(string, Exception);


InvalidEndPointException.InvalidEndPointException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidEndPointException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidEndPointException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidEndPointException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidEndPointException.InvalidEndPointException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidEndPointException(
string message,
Exception inner
);
Managed C++ public: InvalidEndPointException(
String *message,
Exception *inner
);
JScript .NET public function InvalidEndPointException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidEndPointException.InvalidEndPointException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidEndPointException(
string message
);
Managed C++ public: InvalidEndPointException(
String *message
);
JScript .NET public function InvalidEndPointException(
message : String
);

Parameters

message System.String.


InvalidEndPointException.InvalidEndPointException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidEndPointException();
Managed C++ | public: InvalidEndPointException();
JScript .NET | public function InvalidEndPointException();


Microsoft.DirectX.DirectPlay.InvalidFlagsException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidFlagsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidFlagsException
Inherits DirectPlayException
C# | public class InvalidFlagsException : DirectPlayException
Managed C++ | public __gc class InvalidFlagsException : public DirectPlayException
JScript .NET | public class InvalidFlagsException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidFlagsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidFlagsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.InvalidGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidGroupException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group identifier (ID) is not recognized as a valid group ID for this game session. Deprecated.

Definition

Visual Basic .NET Public Class InvalidGroupException
Inherits DirectPlayException
C# | public class InvalidGroupException : DirectPlayException
Managed C++ | public __gc class InvalidGroupException : public DirectPlayException
JScript .NET | public class InvalidGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.InvalidHandleException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHandleException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidHandleException
Inherits DirectPlayException
C# | public class InvalidHandleException : DirectPlayException
Managed C++ | public __gc class InvalidHandleException : public DirectPlayException
JScript .NET | public class InvalidHandleException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidHandleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidHandleException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.InvalidHostAddressException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHostAddressException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified remote address is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidHostAddressException
Inherits DirectPlayException
C# | public class InvalidHostAddressException : DirectPlayException
Managed C++ | public __gc class InvalidHostAddressException : public DirectPlayException
JScript .NET | public class InvalidHostAddressException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidHostAddressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidHostAddressException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidHostAddressException.InvalidHostAddressException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidHostAddressException();
protected InvalidHostAddressException(SerializationInfo, StreamingContext);
public InvalidHostAddressException(string);
public InvalidHostAddressException(string, Exception);


InvalidHostAddressException.InvalidHostAddressException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidHostAddressException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidHostAddressException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidHostAddressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidHostAddressException.InvalidHostAddressException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidHostAddressException(
string message,
Exception inner
);
Managed C++ public: InvalidHostAddressException(
String *message,
Exception *inner
);
JScript .NET public function InvalidHostAddressException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidHostAddressException.InvalidHostAddressException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidHostAddressException(
string message
);
Managed C++ public: InvalidHostAddressException(
String *message
);
JScript .NET public function InvalidHostAddressException(
message : String
);

Parameters

message System.String.


InvalidHostAddressException.InvalidHostAddressException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidHostAddressException();
Managed C++ | public: InvalidHostAddressException();
JScript .NET | public function InvalidHostAddressException();


Microsoft.DirectX.DirectPlay.InvalidInstanceException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidInstanceException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid for the application instance is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidInstanceException
Inherits DirectPlayException
C# | public class InvalidInstanceException : DirectPlayException
Managed C++ | public __gc class InvalidInstanceException : public DirectPlayException
JScript .NET | public class InvalidInstanceException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidInstanceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidInstanceException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidInstanceException.InvalidInstanceException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidInstanceException();
protected InvalidInstanceException(SerializationInfo, StreamingContext);
public InvalidInstanceException(string);
public InvalidInstanceException(string, Exception);


InvalidInstanceException.InvalidInstanceException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidInstanceException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidInstanceException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidInstanceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidInstanceException.InvalidInstanceException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidInstanceException(
string message,
Exception inner
);
Managed C++ public: InvalidInstanceException(
String *message,
Exception *inner
);
JScript .NET public function InvalidInstanceException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidInstanceException.InvalidInstanceException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidInstanceException(
string message
);
Managed C++ public: InvalidInstanceException(
String *message
);
JScript .NET public function InvalidInstanceException(
message : String
);

Parameters

message System.String.


InvalidInstanceException.InvalidInstanceException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidInstanceException();
Managed C++ | public: InvalidInstanceException();
JScript .NET | public function InvalidInstanceException();


Microsoft.DirectX.DirectPlay.InvalidObjectException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidObjectException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object parameter is invalid. This value will be returned in a connect request if the connecting player was not a client in a client/server game or a peer in a peer-to-peer game. Deprecated.

Definition

Visual Basic .NET Public Class InvalidObjectException
Inherits DirectPlayException
C# | public class InvalidObjectException : DirectPlayException
Managed C++ | public __gc class InvalidObjectException : public DirectPlayException
JScript .NET | public class InvalidObjectException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidObjectException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidObjectException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.InvalidPasswordException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPasswordException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An invalid password was supplied when attempting to join a session that requires a password. Deprecated.

Definition

Visual Basic .NET Public Class InvalidPasswordException
Inherits DirectPlayException
C# | public class InvalidPasswordException : DirectPlayException
Managed C++ | public __gc class InvalidPasswordException : public DirectPlayException
JScript .NET | public class InvalidPasswordException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPasswordException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidPasswordException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidPasswordException.InvalidPasswordException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPasswordException();
protected InvalidPasswordException(SerializationInfo, StreamingContext);
public InvalidPasswordException(string);
public InvalidPasswordException(string, Exception);


InvalidPasswordException.InvalidPasswordException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPasswordException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidPasswordException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidPasswordException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidPasswordException.InvalidPasswordException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPasswordException(
string message,
Exception inner
);
Managed C++ public: InvalidPasswordException(
String *message,
Exception *inner
);
JScript .NET public function InvalidPasswordException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidPasswordException.InvalidPasswordException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidPasswordException(
string message
);
Managed C++ public: InvalidPasswordException(
String *message
);
JScript .NET public function InvalidPasswordException(
message : String
);

Parameters

message System.String.


InvalidPasswordException.InvalidPasswordException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidPasswordException();
Managed C++ | public: InvalidPasswordException();
JScript .NET | public function InvalidPasswordException();


Microsoft.DirectX.DirectPlay.InvalidPlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPlayerException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.

Definition

Visual Basic .NET Public Class InvalidPlayerException
Inherits DirectPlayException
C# | public class InvalidPlayerException : DirectPlayException
Managed C++ | public __gc class InvalidPlayerException : public DirectPlayException
JScript .NET | public class InvalidPlayerException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.InvalidPriorityException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPriorityException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified priority is not within the range of allowed priorities, which is inclusively from 0 through 65535. Deprecated.

Definition

Visual Basic .NET Public Class InvalidPriorityException
Inherits DirectPlayException
C# | public class InvalidPriorityException : DirectPlayException
Managed C++ | public __gc class InvalidPriorityException : public DirectPlayException
JScript .NET | public class InvalidPriorityException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPriorityException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidPriorityException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidPriorityException.InvalidPriorityException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPriorityException();
protected InvalidPriorityException(SerializationInfo, StreamingContext);
public InvalidPriorityException(string);
public InvalidPriorityException(string, Exception);


InvalidPriorityException.InvalidPriorityException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPriorityException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidPriorityException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidPriorityException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidPriorityException.InvalidPriorityException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPriorityException(
string message,
Exception inner
);
Managed C++ public: InvalidPriorityException(
String *message,
Exception *inner
);
JScript .NET public function InvalidPriorityException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidPriorityException.InvalidPriorityException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidPriorityException(
string message
);
Managed C++ public: InvalidPriorityException(
String *message
);
JScript .NET public function InvalidPriorityException(
message : String
);

Parameters

message System.String.


InvalidPriorityException.InvalidPriorityException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidPriorityException();
Managed C++ | public: InvalidPriorityException();
JScript .NET | public function InvalidPriorityException();


Microsoft.DirectX.DirectPlay.InvalidStringException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStringException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
String specified as a parameter is invalid. Deprecated.

Definition

Visual Basic .NET Public Class InvalidStringException
Inherits DirectPlayException
C# | public class InvalidStringException : DirectPlayException
Managed C++ | public __gc class InvalidStringException : public DirectPlayException
JScript .NET | public class InvalidStringException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidStringException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidStringException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidStringException.InvalidStringException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStringException.InvalidStringException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidStringException();
protected InvalidStringException(SerializationInfo, StreamingContext);
public InvalidStringException(string);
public InvalidStringException(string, Exception);


InvalidStringException.InvalidStringException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStringException.InvalidStringException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidStringException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidStringException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidStringException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidStringException.InvalidStringException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStringException.InvalidStringException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidStringException(
string message,
Exception inner
);
Managed C++ public: InvalidStringException(
String *message,
Exception *inner
);
JScript .NET public function InvalidStringException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidStringException.InvalidStringException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStringException.InvalidStringException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidStringException(
string message
);
Managed C++ public: InvalidStringException(
String *message
);
JScript .NET public function InvalidStringException(
message : String
);

Parameters

message System.String.


InvalidStringException.InvalidStringException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidStringException.InvalidStringException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidStringException();
Managed C++ | public: InvalidStringException();
JScript .NET | public function InvalidStringException();


Microsoft.DirectX.DirectPlay.InvalidUrlException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidUrlException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specified string is not a valid DirectPlay URL. Deprecated.

Definition

Visual Basic .NET Public Class InvalidUrlException
Inherits DirectPlayException
C# | public class InvalidUrlException : DirectPlayException
Managed C++ | public __gc class InvalidUrlException : public DirectPlayException
JScript .NET | public class InvalidUrlException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidUrlException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidUrlException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidUrlException.InvalidUrlException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidUrlException.InvalidUrlException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidUrlException();
protected InvalidUrlException(SerializationInfo, StreamingContext);
public InvalidUrlException(string);
public InvalidUrlException(string, Exception);


InvalidUrlException.InvalidUrlException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidUrlException.InvalidUrlException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidUrlException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidUrlException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidUrlException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidUrlException.InvalidUrlException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidUrlException.InvalidUrlException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidUrlException(
string message,
Exception inner
);
Managed C++ public: InvalidUrlException(
String *message,
Exception *inner
);
JScript .NET public function InvalidUrlException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidUrlException.InvalidUrlException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidUrlException.InvalidUrlException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidUrlException(
string message
);
Managed C++ public: InvalidUrlException(
String *message
);
JScript .NET public function InvalidUrlException(
message : String
);

Parameters

message System.String.


InvalidUrlException.InvalidUrlException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidUrlException.InvalidUrlException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidUrlException();
Managed C++ | public: InvalidUrlException();
JScript .NET | public function InvalidUrlException();


Microsoft.DirectX.DirectPlay.InvalidVersionException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidVersionException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was an attempt to connect to an invalid version of DirectPlay. Deprecated.

Definition

Visual Basic .NET Public Class InvalidVersionException
Inherits DirectPlayException
C# | public class InvalidVersionException : DirectPlayException
Managed C++ | public __gc class InvalidVersionException : public DirectPlayException
JScript .NET | public class InvalidVersionException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidVersionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidVersionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InvalidVersionException.InvalidVersionException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidVersionException.InvalidVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidVersionException();
protected InvalidVersionException(SerializationInfo, StreamingContext);
public InvalidVersionException(string);
public InvalidVersionException(string, Exception);


InvalidVersionException.InvalidVersionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidVersionException.InvalidVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidVersionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: InvalidVersionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function InvalidVersionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


InvalidVersionException.InvalidVersionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidVersionException.InvalidVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidVersionException(
string message,
Exception inner
);
Managed C++ public: InvalidVersionException(
String *message,
Exception *inner
);
JScript .NET public function InvalidVersionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


InvalidVersionException.InvalidVersionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidVersionException.InvalidVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public InvalidVersionException(
string message
);
Managed C++ public: InvalidVersionException(
String *message
);
JScript .NET public function InvalidVersionException(
message : String
);

Parameters

message System.String.


InvalidVersionException.InvalidVersionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidVersionException.InvalidVersionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public InvalidVersionException();
Managed C++ | public: InvalidVersionException();
JScript .NET | public function InvalidVersionException();


Microsoft.DirectX.DirectPlay.NatResolver

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the NatResolver object to simplify traversal through the Internet Connection Sharing features available in Microsoft® Windows® Millennium Edition (Windows Me) and Windows XP, as well as other Network Address Translators. Deprecated.

Definition

Visual Basic .NET Public Class NatResolver
Inherits MarshalByRefObject
Implements IDisposable
C# public class NatResolver : MarshalByRefObject,
IDisposable
Managed C++ public __gc class NatResolver : public MarshalByRefObject,
IDisposable
JScript .NET public class NatResolver extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
Query
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a query for a Nat Resolver has been received. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the list of objects on which the NAT Resolver has been started. Deprecated.
GetDevices
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the list of available devices on which the NAT Resolver can be started. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
NatResolver
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Query
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Start
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
NatResolver

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NatResolver.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • NatResolver.Disposed
  • NatResolver.Disposing


NatResolver.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


NatResolver.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~NatResolver();
Managed C++ | ~NatResolver();
JScript .NET | protected override function Finalize();


NatResolver.GetAddresses()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.GetAddresses Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the list of objects on which the NAT Resolver has been started. Deprecated.

Definition

Visual Basic .NET | Public Function GetAddresses() As Address()
C# | public Address[] GetAddresses();
Managed C++ | public: Address* GetAddresses() __gc[];
JScript .NET | public function GetAddresses() : Address[];

Return Value

Microsoft.DirectX.DirectPlay.Address[].


NatResolver.GetDevices()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.GetDevices Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the list of available devices on which the NAT Resolver can be started. Deprecated.

Definition

Visual Basic .NET | Public Function GetDevices() As ServiceProviderInformation()
C# | public ServiceProviderInformation[] GetDevices();
Managed C++ | public: ServiceProviderInformation GetDevices() __gc[];
JScript .NET | public function GetDevices() : ServiceProviderInformation[];

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


NatResolver.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


NatResolver.NatResolver

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.NatResolver Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NatResolver();
public NatResolver(InitializeFlags);


NatResolver.NatResolver(InitializeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.NatResolver Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public NatResolver(
InitializeFlags flags
);
Managed C++ public: NatResolver(
InitializeFlags flags
);
JScript .NET public function NatResolver(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags.


NatResolver.NatResolver()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.NatResolver Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NatResolver();
Managed C++ | public: NatResolver();
JScript .NET | public function NatResolver();


NatResolver.op_Equality(NatResolver,NatResolver)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As NatResolver, _
ByVal right As NatResolver _
) As Boolean
C# public static bool op_Equality(
NatResolver left,
NatResolver right
);
Managed C++ public: static bool op_Equality(
NatResolver *left,
NatResolver *right
);
JScript .NET public static function op_Equality(
left : NatResolver,
right : NatResolver
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.NatResolver. The NatResolver structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.NatResolver. The NatResolver structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


NatResolver.op_Inequality(NatResolver,NatResolver)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As NatResolver, _
ByVal right As NatResolver _
) As Boolean
C# public static bool op_Inequality(
NatResolver left,
NatResolver right
);
Managed C++ public: static bool op_Inequality(
NatResolver *left,
NatResolver *right
);
JScript .NET public static function op_Inequality(
left : NatResolver,
right : NatResolver
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.NatResolver. The NatResolver structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.NatResolver. The NatResolver structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


NatResolver.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


NatResolver.raise_Query(Object,NatResolverQueryEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.raise_Query Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Query( _
ByVal i1 As Object, _
ByVal i2 As NatResolverQueryEventArgs _
)
C# protected void raise_Query(
object i1,
NatResolverQueryEventArgs i2
);
Managed C++ protected: void raise_Query(
Object *i1,
NatResolverQueryEventArgs *i2
);
JScript .NET protected function raise_Query(
i1 : Object,
i2 : NatResolverQueryEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.NatResolverQueryEventArgs.


NatResolver.Start

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Start Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Overload List

public void Start();
public void Start(Address[]);


NatResolver.Start()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Start Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Definition

Visual Basic .NET | Public Sub Start()
C# | public void Start();
Managed C++ | public: void Start();
JScript .NET | public function Start();


NatResolver.Start(Address[])

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Start Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Definition

Visual Basic .NET Public Sub Start( _
ByVal devices() As Address _
)
C# public void Start(
Address[] devices
);
Managed C++ public: void Start(
Address *devices __gc[]
);
JScript .NET public function Start(
devices : Address[]
);

Parameters

devices Microsoft.DirectX.DirectPlay.Address[].


NatResolver.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


NatResolver.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a NatResolver.Disposing event, use the following code.

natResolver.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


NatResolver.Query

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolver.Query Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a query for a Nat Resolver has been received. Deprecated.

Definition

Visual Basic .NET | Public Event Query As NatResolverQueryEventHandler
C# | public event NatResolverQueryEventHandler Query;
Managed C++ | public: __event NatResolverQueryEventHandler Query;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.NatResolverQueryEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the NatResolver Query event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class NatResolverQueryEventArgs
Inherits EventArgs
C# | public sealed class NatResolverQueryEventArgs : EventArgs
Managed C++ | public __gc __sealed class NatResolverQueryEventArgs : public EventArgs
JScript .NET | public class NatResolverQueryEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
NatResolverQueryEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
RejectMessage
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
NatResolverQueryEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NatResolverQueryEventArgs.NatResolverQueryEventArgs(NatResolverQueryMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryEventArgs.NatResolverQueryEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As NatResolverQueryMessage _
)
C# public NatResolverQueryEventArgs(
NatResolverQueryMessage dpMessage
);
Managed C++ public: NatResolverQueryEventArgs(
NatResolverQueryMessage dpMessage
);
JScript .NET public function NatResolverQueryEventArgs(
dpMessage : NatResolverQueryMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.NatResolverQueryMessage.


NatResolverQueryEventArgs.RejectMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryEventArgs.RejectMessage Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Definition

Visual Basic .NET | Public Property RejectMessage As Boolean
C# | public bool RejectMessage { get; set; }
Managed C++ public: __property bool get_RejectMessage();
public: __property void set_RejectMessage(bool);
JScript .NET public function get RejectMessage() : boolean
public function set RejectMessage(boolean);

Property Value

System.Boolean .

This property is read/write.


NatResolverQueryEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As NatResolverQueryMessage
C# | public NatResolverQueryMessage Message;
Managed C++ | public: NatResolverQueryMessage Message;
JScript .NET | public var Message : NatResolverQueryMessage

Field Value

Microsoft.DirectX.DirectPlay.NatResolverQueryMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.NetworkPacket

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A network packet that can be sent to other members of this session. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class NetworkPacket
Inherits Object
Implements IDisposable
C# public sealed class NetworkPacket : Object,
IDisposable
Managed C++ public __gc __sealed class NetworkPacket : public Object,
IDisposable
JScript .NET public class NetworkPacket extends Object
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current data as a byte array. Deprecated.
NetworkPacket
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Read
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.
ReadString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet a string. Deprecated.
Write
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Properties

Property Description
Length
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Length of the network packet. Deprecated.
Position
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current position of the network packet. Deprecated.

Inheritance Hierarchy

Object Leave Site
NetworkPacket

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NetworkPacket.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


NetworkPacket.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~NetworkPacket();
Managed C++ | ~NetworkPacket();
JScript .NET | protected override function Finalize();


NetworkPacket.GetData()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.GetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current data as a byte array. Deprecated.

Definition

Visual Basic .NET | Public Function GetData() As Byte()
C# | public byte[] GetData();
Managed C++ | public: Byte GetData() __gc[];
JScript .NET | public function GetData() : byte[];

Return Value

System.Byte[].


NetworkPacket.NetworkPacket

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.NetworkPacket Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Overload List

public NetworkPacket();
public NetworkPacket(int);


NetworkPacket.NetworkPacket(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.NetworkPacket Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal initialSize As Integer _
)
C# public NetworkPacket(
int initialSize
);
Managed C++ public: NetworkPacket(
int initialSize
);
JScript .NET public function NetworkPacket(
initialSize : int
);

Parameters

initialSize System.Int32.


NetworkPacket.NetworkPacket()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.NetworkPacket Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NetworkPacket();
Managed C++ | public: NetworkPacket();
JScript .NET | public function NetworkPacket();


NetworkPacket.Read

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.

Overload List

public ValueType Read(Type);
public Array Read(Type, int[]);


NetworkPacket.Read(Type,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.

Definition

Visual Basic .NET Public Function Read( _
ByVal returnType As Type, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
Type returnType,
int[] ranks
);
Managed C++ public: Array* Read(
Type *returnType,
int ranks __gc[]
);
JScript .NET public function Read(
returnType : Type,
ranks : int[]
) : Array;

Parameters

returnType | System.Type.
ranks | System.Int32[].

Return Value

System.Array .


NetworkPacket.Read(Type)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.

Definition

Visual Basic .NET Public Function Read( _
ByVal returnType As Type _
) As ValueType
C# public ValueType Read(
Type returnType
);
Managed C++ public: ValueType* Read(
Type *returnType
);
JScript .NET public function Read(
returnType : Type
) : ValueType;

Parameters

returnType System.Type.

Return Value

System.ValueType .


NetworkPacket.ReadString()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.ReadString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet a string. Deprecated.

Definition

Visual Basic .NET | Public Function ReadString() As String
C# | public string ReadString();
Managed C++ | public: String* ReadString();
JScript .NET | public function ReadString() : String;

Return Value

System.String .


NetworkPacket.Write

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Overload List

public void Write(Array);
public void Write(string);
public void Write(ValueType);


NetworkPacket.Write(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Definition

Visual Basic .NET Public Sub Write( _
ByVal value As String _
)
C# public void Write(
string value
);
Managed C++ public: void Write(
String *value
);
JScript .NET public function Write(
value : String
);

Parameters

value System.String.


NetworkPacket.Write(Array)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Definition

Visual Basic .NET Public Sub Write( _
ByVal value As Array _
)
C# public void Write(
Array value
);
Managed C++ public: void Write(
Array *value
);
JScript .NET public function Write(
value : Array
);

Parameters

value System.Array.


NetworkPacket.Write(ValueType)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Definition

Visual Basic .NET Public Sub Write( _
ByVal value As ValueType _
)
C# public void Write(
ValueType value
);
Managed C++ public: void Write(
ValueType *value
);
JScript .NET public function Write(
value : ValueType
);

Parameters

value System.ValueType.


NetworkPacket.Length

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Length Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Length of the network packet. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Length As Integer
C# | public int Length { get; }
Managed C++ | public: __property int get_Length();
JScript .NET | public function get Length() : int

Property Value

System.Int32 .

This property is read-only.


NetworkPacket.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPacket.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current position of the network packet. Deprecated.

Definition

Visual Basic .NET | Public Property Position As Integer
C# | public int Position { get; set; }
Managed C++ public: __property int get_Position();
public: __property void set_Position(int);
JScript .NET public function get Position() : int
public function set Position(int);

Property Value

System.Int32 .

This property is read/write.


Microsoft.DirectX.DirectPlay.NoCapsException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCapsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The communication link that DirectPlay is attempting to use is not capable of this function. Deprecated.

Definition

Visual Basic .NET Public Class NoCapsException
Inherits DirectPlayException
C# | public class NoCapsException : DirectPlayException
Managed C++ | public __gc class NoCapsException : public DirectPlayException
JScript .NET | public class NoCapsException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoCapsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoCapsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoCapsException.NoCapsException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCapsException.NoCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoCapsException();
protected NoCapsException(SerializationInfo, StreamingContext);
public NoCapsException(string);
public NoCapsException(string, Exception);


NoCapsException.NoCapsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCapsException.NoCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoCapsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoCapsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoCapsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoCapsException.NoCapsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCapsException.NoCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoCapsException(
string message,
Exception inner
);
Managed C++ public: NoCapsException(
String *message,
Exception *inner
);
JScript .NET public function NoCapsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoCapsException.NoCapsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCapsException.NoCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoCapsException(
string message
);
Managed C++ public: NoCapsException(
String *message
);
JScript .NET public function NoCapsException(
message : String
);

Parameters

message System.String.


NoCapsException.NoCapsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoCapsException.NoCapsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoCapsException();
Managed C++ | public: NoCapsException();
JScript .NET | public function NoCapsException();


Microsoft.DirectX.DirectPlay.NoConnectionException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoConnectionException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No communication link was established. Deprecated.

Definition

Visual Basic .NET Public Class NoConnectionException
Inherits DirectPlayException
C# | public class NoConnectionException : DirectPlayException
Managed C++ | public __gc class NoConnectionException : public DirectPlayException
JScript .NET | public class NoConnectionException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoConnectionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoConnectionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoConnectionException.NoConnectionException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoConnectionException.NoConnectionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoConnectionException();
protected NoConnectionException(SerializationInfo, StreamingContext);
public NoConnectionException(string);
public NoConnectionException(string, Exception);


NoConnectionException.NoConnectionException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoConnectionException.NoConnectionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoConnectionException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoConnectionException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoConnectionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoConnectionException.NoConnectionException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoConnectionException.NoConnectionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoConnectionException(
string message,
Exception inner
);
Managed C++ public: NoConnectionException(
String *message,
Exception *inner
);
JScript .NET public function NoConnectionException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoConnectionException.NoConnectionException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoConnectionException.NoConnectionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoConnectionException(
string message
);
Managed C++ public: NoConnectionException(
String *message
);
JScript .NET public function NoConnectionException(
message : String
);

Parameters

message System.String.


NoConnectionException.NoConnectionException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoConnectionException.NoConnectionException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoConnectionException();
Managed C++ | public: NoConnectionException();
JScript .NET | public function NoConnectionException();


Microsoft.DirectX.DirectPlay.NoHostPlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoHostPlayerException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is currently no player acting as the host of the session. Deprecated.

Definition

Visual Basic .NET Public Class NoHostPlayerException
Inherits DirectPlayException
C# | public class NoHostPlayerException : DirectPlayException
Managed C++ | public __gc class NoHostPlayerException : public DirectPlayException
JScript .NET | public class NoHostPlayerException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoHostPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoHostPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoHostPlayerException.NoHostPlayerException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoHostPlayerException.NoHostPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoHostPlayerException();
protected NoHostPlayerException(SerializationInfo, StreamingContext);
public NoHostPlayerException(string);
public NoHostPlayerException(string, Exception);


NoHostPlayerException.NoHostPlayerException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoHostPlayerException.NoHostPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoHostPlayerException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoHostPlayerException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoHostPlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoHostPlayerException.NoHostPlayerException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoHostPlayerException.NoHostPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoHostPlayerException(
string message,
Exception inner
);
Managed C++ public: NoHostPlayerException(
String *message,
Exception *inner
);
JScript .NET public function NoHostPlayerException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoHostPlayerException.NoHostPlayerException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoHostPlayerException.NoHostPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoHostPlayerException(
string message
);
Managed C++ public: NoHostPlayerException(
String *message
);
JScript .NET public function NoHostPlayerException(
message : String
);

Parameters

message System.String.


NoHostPlayerException.NoHostPlayerException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoHostPlayerException.NoHostPlayerException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoHostPlayerException();
Managed C++ | public: NoHostPlayerException();
JScript .NET | public function NoHostPlayerException();


Microsoft.DirectX.DirectPlay.NoMoreAddressComponentsException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMoreAddressComponentsException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No more address components can be added to this address. Deprecated.

Definition

Visual Basic .NET Public Class NoMoreAddressComponentsException
Inherits DirectPlayException
C# | public class NoMoreAddressComponentsException : DirectPlayException
Managed C++ | public __gc class NoMoreAddressComponentsException : public DirectPlayException
JScript .NET | public class NoMoreAddressComponentsException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoMoreAddressComponentsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoMoreAddressComponentsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoMoreAddressComponentsException.NoMoreAddressComponentsException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoMoreAddressComponentsException();
protected NoMoreAddressComponentsException(SerializationInfo, StreamingContext);
public NoMoreAddressComponentsException(string);
public NoMoreAddressComponentsException(string, Exception);


NoMoreAddressComponentsException.NoMoreAddressComponentsException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoMoreAddressComponentsException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoMoreAddressComponentsException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoMoreAddressComponentsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoMoreAddressComponentsException.NoMoreAddressComponentsException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoMoreAddressComponentsException(
string message,
Exception inner
);
Managed C++ public: NoMoreAddressComponentsException(
String *message,
Exception *inner
);
JScript .NET public function NoMoreAddressComponentsException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoMoreAddressComponentsException.NoMoreAddressComponentsException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoMoreAddressComponentsException(
string message
);
Managed C++ public: NoMoreAddressComponentsException(
String *message
);
JScript .NET public function NoMoreAddressComponentsException(
message : String
);

Parameters

message System.String.


NoMoreAddressComponentsException.NoMoreAddressComponentsException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoMoreAddressComponentsException();
Managed C++ | public: NoMoreAddressComponentsException();
JScript .NET | public function NoMoreAddressComponentsException();


Microsoft.DirectX.DirectPlay.NoResponseException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoResponseException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was no response from the specified target. Deprecated.

Definition

Visual Basic .NET Public Class NoResponseException
Inherits DirectPlayException
C# | public class NoResponseException : DirectPlayException
Managed C++ | public __gc class NoResponseException : public DirectPlayException
JScript .NET | public class NoResponseException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoResponseException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoResponseException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoResponseException.NoResponseException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoResponseException.NoResponseException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoResponseException();
protected NoResponseException(SerializationInfo, StreamingContext);
public NoResponseException(string);
public NoResponseException(string, Exception);


NoResponseException.NoResponseException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoResponseException.NoResponseException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoResponseException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoResponseException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoResponseException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NoResponseException.NoResponseException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoResponseException.NoResponseException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoResponseException(
string message,
Exception inner
);
Managed C++ public: NoResponseException(
String *message,
Exception *inner
);
JScript .NET public function NoResponseException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NoResponseException.NoResponseException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoResponseException.NoResponseException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoResponseException(
string message
);
Managed C++ public: NoResponseException(
String *message
);
JScript .NET public function NoResponseException(
message : String
);

Parameters

message System.String.


NoResponseException.NoResponseException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoResponseException.NoResponseException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoResponseException();
Managed C++ | public: NoResponseException();
JScript .NET | public function NoResponseException();


Microsoft.DirectX.DirectPlay.NotAllowedException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotAllowedException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This function is not allowed on this object. Deprecated.

Definition

Visual Basic .NET Public Class NotAllowedException
Inherits DirectPlayException
C# | public class NotAllowedException : DirectPlayException
Managed C++ | public __gc class NotAllowedException : public DirectPlayException
JScript .NET | public class NotAllowedException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAllowedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotAllowedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.NotHostException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt by the client to connect to a nonhost computer. Additionally, this error value can be returned by a nonhost that tries to set the application description. Deprecated.

Definition

Visual Basic .NET Public Class NotHostException
Inherits DirectPlayException
C# | public class NotHostException : DirectPlayException
Managed C++ | public __gc class NotHostException : public DirectPlayException
JScript .NET | public class NotHostException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotHostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotHostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotHostException.NotHostException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostException.NotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotHostException();
protected NotHostException(SerializationInfo, StreamingContext);
public NotHostException(string);
public NotHostException(string, Exception);


NotHostException.NotHostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostException.NotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotHostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotHostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotHostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotHostException.NotHostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostException.NotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotHostException(
string message,
Exception inner
);
Managed C++ public: NotHostException(
String *message,
Exception *inner
);
JScript .NET public function NotHostException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotHostException.NotHostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostException.NotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotHostException(
string message
);
Managed C++ public: NotHostException(
String *message
);
JScript .NET public function NotHostException(
message : String
);

Parameters

message System.String.


NotHostException.NotHostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotHostException.NotHostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotHostException();
Managed C++ | public: NotHostException();
JScript .NET | public function NotHostException();


Microsoft.DirectX.DirectPlay.NotReadyException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotReadyException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not ready for use. Deprecated.

Definition

Visual Basic .NET Public Class NotReadyException
Inherits DirectPlayException
C# | public class NotReadyException : DirectPlayException
Managed C++ | public __gc class NotReadyException : public DirectPlayException
JScript .NET | public class NotReadyException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotReadyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotReadyException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotReadyException.NotReadyException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotReadyException.NotReadyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotReadyException();
protected NotReadyException(SerializationInfo, StreamingContext);
public NotReadyException(string);
public NotReadyException(string, Exception);


NotReadyException.NotReadyException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotReadyException.NotReadyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotReadyException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotReadyException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotReadyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotReadyException.NotReadyException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotReadyException.NotReadyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotReadyException(
string message,
Exception inner
);
Managed C++ public: NotReadyException(
String *message,
Exception *inner
);
JScript .NET public function NotReadyException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotReadyException.NotReadyException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotReadyException.NotReadyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotReadyException(
string message
);
Managed C++ public: NotReadyException(
String *message
);
JScript .NET public function NotReadyException(
message : String
);

Parameters

message System.String.


NotReadyException.NotReadyException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotReadyException.NotReadyException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotReadyException();
Managed C++ | public: NotReadyException();
JScript .NET | public function NotReadyException();


Microsoft.DirectX.DirectPlay.NotRegisteredException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotRegisteredException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This object is not registered. Deprecated.

Definition

Visual Basic .NET Public Class NotRegisteredException
Inherits DirectPlayException
C# | public class NotRegisteredException : DirectPlayException
Managed C++ | public __gc class NotRegisteredException : public DirectPlayException
JScript .NET | public class NotRegisteredException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotRegisteredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotRegisteredException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NotRegisteredException.NotRegisteredException

Microsoft DirectX 9.0 SDK Update (October 2004)

NotRegisteredException.NotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotRegisteredException();
protected NotRegisteredException(SerializationInfo, StreamingContext);
public NotRegisteredException(string);
public NotRegisteredException(string, Exception);


NotRegisteredException.NotRegisteredException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotRegisteredException.NotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotRegisteredException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NotRegisteredException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NotRegisteredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


NotRegisteredException.NotRegisteredException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotRegisteredException.NotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotRegisteredException(
string message,
Exception inner
);
Managed C++ public: NotRegisteredException(
String *message,
Exception *inner
);
JScript .NET public function NotRegisteredException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


NotRegisteredException.NotRegisteredException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NotRegisteredException.NotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NotRegisteredException(
string message
);
Managed C++ public: NotRegisteredException(
String *message
);
JScript .NET public function NotRegisteredException(
message : String
);

Parameters

message System.String.


NotRegisteredException.NotRegisteredException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NotRegisteredException.NotRegisteredException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NotRegisteredException();
Managed C++ | public: NotRegisteredException();
JScript .NET | public function NotRegisteredException();


Microsoft.DirectX.DirectPlay.Peer

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Peer object to create a peer-to-peer Microsoft® DirectPlay® session. Deprecated.

Definition

Visual Basic .NET Public Class Peer
Inherits MarshalByRefObject
Implements IDisposable
C# public class Peer : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Peer : public MarshalByRefObject,
IDisposable
JScript .NET public class Peer extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ApplicationDescriptionChanged
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.
AsyncOperationComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the async operation has completed. Deprecated.
ConnectComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
FindHostQuery
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.
FindHostResponse
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.
GroupCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.
GroupDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.
GroupInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.
HostMigrated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has been migrated. Deprecated.
IndicateConnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.
IndicatedConnectAborted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.
PeerInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.
PlayerAddedToGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
PlayerRemovedFromGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the peer object receives data. Deprecated.
SendComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.
SessionTerminated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Methods

Method Description
AddPlayerToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.
CancelAsyncOperation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.
Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.
CreateGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.
DestroyGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.
DestroyPeer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a peer from the session. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
FindHosts
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.
GetConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local application and the specified remote player. Deprecated.
GetGroupContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for the specified group. Deprecated.
GetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetLocalHostAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
GetPeerAddress
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified remote player in the session. Deprecated.
GetPeerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.
GetPlayerContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for the specified peer. Deprecated.
GetSendQueueInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Deprecated.
GetServiceProviders
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.
GetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.
Host
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
Peer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
raise_ApplicationDescriptionChanged
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_AsyncOperationComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostQuery
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostResponse
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_HostMigrated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicateConnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicatedConnectAborted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PeerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerAddedToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerRemovedFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SendComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionTerminated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RemovePlayerFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.
SendTo
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.
SetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.
SetPeerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.
SetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.
TerminateSession
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Terminates the current session. Deprecated.
UnregisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Peer object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
GroupMembers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.
Groups
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.
Players
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Peer

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Peer.AddPlayerToGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Overload List

public void AddPlayerToGroup(int, int, out int, SyncFlags);
public void AddPlayerToGroup(int, int, out int, SyncFlags, object);
public void AddPlayerToGroup(int, int, SyncFlags);
public void AddPlayerToGroup(int, int, SyncFlags, object);


Peer.AddPlayerToGroup(Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.AddPlayerToGroup(Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.CancelAsyncOperation

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Overload List

public void CancelAsyncOperation(CancelFlags);
public void CancelAsyncOperation(int);

Remarks

This method is useful when several methods of an object run asynchronously by default with each returning an asyncHandle parameter. To cancel a request before it is processed, pass that request's returned handle in this method's asyncHandle parameter.

To cancel all pending asynchronous operations, call this method with NULL in the asyncHandle parameter and DPNCANCEL_ALL_OPERATIONS in the flags parameter.

If you pass a specific handle to this method, do not set any flags.


Peer.CancelAsyncOperation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic .NET Public Sub CancelAsyncOperation( _
ByVal asyncHandle As Integer _
)
C# public void CancelAsyncOperation(
int asyncHandle
);
Managed C++ public: void CancelAsyncOperation(
int asyncHandle
);
JScript .NET public function CancelAsyncOperation(
asyncHandle : int
);

Parameters

asyncHandle System.Int32.

Remarks

This method is useful when several methods of an object run asynchronously by default with each returning an asyncHandle parameter. To cancel a request before it is processed, pass that request's returned handle in this method's asyncHandle parameter.

To cancel all pending asynchronous operations, call this method with NULL in the asyncHandle parameter and DPNCANCEL_ALL_OPERATIONS in the flags parameter.

If you pass a specific handle to this method, do not set any flags.


Peer.CancelAsyncOperation(CancelFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic .NET Public Sub CancelAsyncOperation( _
ByVal flags As CancelFlags _
)
C# public void CancelAsyncOperation(
CancelFlags flags
);
Managed C++ public: void CancelAsyncOperation(
CancelFlags flags
);
JScript .NET public function CancelAsyncOperation(
flags : CancelFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.CancelFlags.

Remarks

This method is useful when several methods of an object run asynchronously by default with each returning an asyncHandle parameter. To cancel a request before it is processed, pass that request's returned handle in this method's asyncHandle parameter.

To cancel all pending asynchronous operations, call this method with NULL in the asyncHandle parameter and DPNCANCEL_ALL_OPERATIONS in the flags parameter.

If you pass a specific handle to this method, do not set any flags.


Peer.Connect

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Overload List

public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags, object, object);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags, object, object);


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags,Object,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags, _
ByVal playerContext As Object, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags,
object playerContext,
object userContext
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
ConnectFlags flags,
Object *playerContext,
Object *userContext
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags,
playerContext : Object,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.
playerContext | System.Object.
userContext | System.Object.


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags,Object,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags, _
ByVal playerContext As Object, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags,
object playerContext,
object userContext
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
int *asyncHandle,
ConnectFlags flags,
Object *playerContext,
Object *userContext
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags,
playerContext : Object,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.
playerContext | System.Object.
userContext | System.Object.


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
ConnectFlags flags
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Connect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic .NET Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags
);
Managed C++ public: void Connect(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userConnectData,
int *asyncHandle,
ConnectFlags flags
);
JScript .NET public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userConnectData | Microsoft.DirectX.DirectPlay.NetworkPacket.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.ConnectFlags.


Peer.CreateGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Overload List

public void CreateGroup(GroupInformation, out int, SyncFlags);
public void CreateGroup(GroupInformation, out int, SyncFlags, object, object);
public void CreateGroup(GroupInformation, SyncFlags);
public void CreateGroup(GroupInformation, SyncFlags, object, object);


Peer.CreateGroup(GroupInformation,SyncFlags,Object,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
object groupContext,
object asyncContext
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
Object *groupContext,
Object *asyncContext
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
groupContext | System.Object.
asyncContext | System.Object.


Peer.CreateGroup(GroupInformation,Int32,SyncFlags,Object,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object groupContext,
object asyncContext
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags,
Object *groupContext,
Object *asyncContext
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
groupContext | System.Object.
asyncContext | System.Object.


Peer.CreateGroup(GroupInformation,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.CreateGroup(GroupInformation,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.DestroyGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Overload List

public void DestroyGroup(int, out int, SyncFlags);
public void DestroyGroup(int, out int, SyncFlags, object);
public void DestroyGroup(int, SyncFlags);
public void DestroyGroup(int, SyncFlags, object);


Peer.DestroyGroup(Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void DestroyGroup(
int groupID,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function DestroyGroup(
groupID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.DestroyGroup(Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void DestroyGroup(
int groupID,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.DestroyGroup(Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags
);
Managed C++ public: void DestroyGroup(
int groupID,
SyncFlags flags
);
JScript .NET public function DestroyGroup(
groupID : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.DestroyGroup(Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void DestroyGroup(
int groupID,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.DestroyPeer(Int32,NetworkPacket)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.DestroyPeer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a peer from the session. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyPeer( _
ByVal playerID As Integer, _
ByVal destroyData As NetworkPacket _
)
C# public void DestroyPeer(
int playerID,
NetworkPacket destroyData
);
Managed C++ public: void DestroyPeer(
int playerID,
NetworkPacket *destroyData
);
JScript .NET public function DestroyPeer(
playerID : int,
destroyData : NetworkPacket
);

Parameters

playerID | System.Int32.
destroyData | Microsoft.DirectX.DirectPlay.NetworkPacket.


Peer.Dispose

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Overload List

public override void Dispose();
public void Dispose(bool);

See Also

  • Peer.Disposed
  • Peer.Disposing


Peer.Dispose(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET Public Sub Dispose( _
ByVal closeImmediate As Boolean _
)
C# public void Dispose(
bool closeImmediate
);
Managed C++ public: void Dispose(
bool closeImmediate
);
JScript .NET public function Dispose(
closeImmediate : boolean
);

Parameters

closeImmediate System.Boolean.

See Also

  • Peer.Disposed
  • Peer.Disposing


Peer.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Peer.Disposed
  • Peer.Disposing


Peer.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Peer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Peer();
Managed C++ | ~Peer();
JScript .NET | protected override function Finalize();


Peer.FindHosts

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Overload List

public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int, object);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, object);


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
object userContext
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
Object *userContext
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.
userContext | System.Object.


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle,
object userContext
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
int *asyncHandle,
Object *userContext
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int,
userContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.
asyncHandle | System.Int32.
userContext | System.Object.


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.FindHosts Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic .NET Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle
);
Managed C++ public: void FindHosts(
ApplicationDescription applicationDescription,
Address *hostAddress,
Address *deviceInformation,
NetworkPacket *userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
int *asyncHandle
);
JScript .NET public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
hostAddress | Microsoft.DirectX.DirectPlay.Address.
deviceInformation | Microsoft.DirectX.DirectPlay.Address.
userEnumData | Microsoft.DirectX.DirectPlay.NetworkPacket.
count | System.Int32.
retryInterval | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.FindHostsFlags.
asyncHandle | System.Int32.


Peer.GetConnectionInformation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetConnectionInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local application and the specified remote player. Deprecated.

Definition

Visual Basic .NET Public Function GetConnectionInformation( _
ByVal playerID As Integer _
) As ConnectionInformation
C# public ConnectionInformation GetConnectionInformation(
int playerID
);
Managed C++ public: ConnectionInformation GetConnectionInformation(
int playerID
);
JScript .NET public function GetConnectionInformation(
playerID : int
) : ConnectionInformation;

Parameters

playerID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.ConnectionInformation .


Peer.GetGroupContext(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetGroupContext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for the specified group. Deprecated.

Definition

Visual Basic .NET Public Function GetGroupContext( _
ByVal groupID As Integer _
) As Object
C# public object GetGroupContext(
int groupID
);
Managed C++ public: Object* GetGroupContext(
int groupID
);
JScript .NET public function GetGroupContext(
groupID : int
) : Object;

Parameters

groupID System.Int32.

Return Value

System.Object .


Peer.GetGroupInformation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Function GetGroupInformation( _
ByVal groupID As Integer _
) As GroupInformation
C# public GroupInformation GetGroupInformation(
int groupID
);
Managed C++ public: GroupInformation GetGroupInformation(
int groupID
);
JScript .NET public function GetGroupInformation(
groupID : int
) : GroupInformation;

Parameters

groupID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.GroupInformation .


Peer.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Peer.GetLocalHostAddresses(LocalAddressFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetLocalHostAddresses Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Function GetLocalHostAddresses( _
ByVal flags As LocalAddressFlags _
) As Address()
C# public Address[] GetLocalHostAddresses(
LocalAddressFlags flags
);
Managed C++ public: Address* GetLocalHostAddresses(
LocalAddressFlags flags
) __gc[];
JScript .NET public function GetLocalHostAddresses(
flags : LocalAddressFlags
) : Address[];

Parameters

flags Microsoft.DirectX.DirectPlay.LocalAddressFlags.

Return Value

Microsoft.DirectX.DirectPlay.Address[].


Peer.GetPeerAddress(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetPeerAddress Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified remote player in the session. Deprecated.

Definition

Visual Basic .NET Public Function GetPeerAddress( _
ByVal playerID As Integer _
) As Address
C# public Address GetPeerAddress(
int playerID
);
Managed C++ public: Address* GetPeerAddress(
int playerID
);
JScript .NET public function GetPeerAddress(
playerID : int
) : Address;

Parameters

playerID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.Address .


Peer.GetPeerInformation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetPeerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic .NET Public Function GetPeerInformation( _
ByVal playerID As Integer _
) As PlayerInformation
C# public PlayerInformation GetPeerInformation(
int playerID
);
Managed C++ public: PlayerInformation GetPeerInformation(
int playerID
);
JScript .NET public function GetPeerInformation(
playerID : int
) : PlayerInformation;

Parameters

playerID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.PlayerInformation .


Peer.GetPlayerContext(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetPlayerContext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for the specified peer. Deprecated.

Definition

Visual Basic .NET Public Function GetPlayerContext( _
ByVal playerID As Integer _
) As Object
C# public object GetPlayerContext(
int playerID
);
Managed C++ public: Object* GetPlayerContext(
int playerID
);
JScript .NET public function GetPlayerContext(
playerID : int
) : Object;

Parameters

playerID System.Int32.

Return Value

System.Object .


Peer.GetSendQueueInformation(Int32,Int32,Int32,GetSendQueueInformationFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetSendQueueInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Deprecated.

Definition

Visual Basic .NET Public Sub GetSendQueueInformation( _
ByVal dpnidPlayer As Integer, _
ByRef numberMessages As Integer, _
ByRef numberBytes As Integer, _
ByVal flags As GetSendQueueInformationFlags _
)
C# public void GetSendQueueInformation(
int dpnidPlayer,
out int numberMessages,
out int numberBytes,
GetSendQueueInformationFlags flags
);
Managed C++ public: void GetSendQueueInformation(
int dpnidPlayer,
int *numberMessages,
int *numberBytes,
GetSendQueueInformationFlags flags
);
JScript .NET public function GetSendQueueInformation(
dpnidPlayer : int,
numberMessages : int,
numberBytes : int,
flags : GetSendQueueInformationFlags
);

Parameters

dpnidPlayer | System.Int32.
numberMessages | System.Int32.
numberBytes | System.Int32.
flags | Microsoft.DirectX.DirectPlay.GetSendQueueInformationFlags.


Peer.GetServiceProviders

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Overload List

public ServiceProviderInformation[] GetServiceProviders(bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, Guid, bool);


Peer.GetServiceProviders(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
getAll : boolean
) : ServiceProviderInformation[];

Parameters

getAll System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Peer.GetServiceProviders(Guid,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
Guid guidServiceProvider,
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
guidServiceProvider : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider | System.Guid.
getAll | System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Peer.GetServiceProviders(Guid,Guid,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal guidApplication As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
guidServiceProvider : Guid,
guidApplication : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider | System.Guid.
guidApplication | System.Guid.
getAll | System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Peer.GetSPCaps(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GetSPCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.

Definition

Visual Basic .NET Public Function GetSPCaps( _
ByVal guidServiceProvider As Guid _
) As ServiceProviderCaps
C# public ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
Managed C++ public: ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
JScript .NET public function GetSPCaps(
guidServiceProvider : Guid
) : ServiceProviderCaps;

Parameters

guidServiceProvider System.Guid.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderCaps .


Peer.Host

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Overload List

public void Host(ApplicationDescription, Address);
public void Host(ApplicationDescription, Address, HostFlags);
public void Host(ApplicationDescription, Address, object);
public void Host(ApplicationDescription, Address, object, HostFlags);
public void Host(ApplicationDescription, Address[]);
public void Host(ApplicationDescription, Address[], HostFlags);
public void Host(ApplicationDescription, Address[], object);
public void Host(ApplicationDescription, Address[], object, HostFlags);


Peer.Host(ApplicationDescription,Address[],Object,HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[],
Object *playerContext,
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].
playerContext | System.Object.
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Peer.Host(ApplicationDescription,Address,Object,HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress,
Object *playerContext,
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.
playerContext | System.Object.
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Peer.Host(ApplicationDescription,Address[],HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[],
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Peer.Host(ApplicationDescription,Address,HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress,
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Peer.Host(ApplicationDescription,Address[],Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[],
Object *playerContext
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].
playerContext | System.Object.


Peer.Host(ApplicationDescription,Address,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress,
Object *playerContext
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.
playerContext | System.Object.


Peer.Host(ApplicationDescription,Address[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[]
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[]
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].


Peer.Host(ApplicationDescription,Address)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.


Peer.op_Equality(Peer,Peer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Peer, _
ByVal right As Peer _
) As Boolean
C# public static bool op_Equality(
Peer left,
Peer right
);
Managed C++ public: static bool op_Equality(
Peer *left,
Peer *right
);
JScript .NET public static function op_Equality(
left : Peer,
right : Peer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Peer. The Peer structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Peer. The Peer structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Peer.op_Inequality(Peer,Peer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Peer, _
ByVal right As Peer _
) As Boolean
C# public static bool op_Inequality(
Peer left,
Peer right
);
Managed C++ public: static bool op_Inequality(
Peer *left,
Peer *right
);
JScript .NET public static function op_Inequality(
left : Peer,
right : Peer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Peer. The Peer structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Peer. The Peer structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Peer.Peer

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Peer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Peer();
public Peer(InitializeFlags);


Peer.Peer(InitializeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Peer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Peer(
InitializeFlags flags
);
Managed C++ public: Peer(
InitializeFlags flags
);
JScript .NET public function Peer(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags.


Peer.Peer()

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Peer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Peer();
Managed C++ | public: Peer();
JScript .NET | public function Peer();


Peer.raise_ApplicationDescriptionChanged(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_ApplicationDescriptionChanged Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ApplicationDescriptionChanged( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_ApplicationDescriptionChanged(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_ApplicationDescriptionChanged(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_ApplicationDescriptionChanged(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Peer.raise_AsyncOperationComplete(Object,AsyncOperationCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_AsyncOperationComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_AsyncOperationComplete( _
ByVal i1 As Object, _
ByVal i2 As AsyncOperationCompleteEventArgs _
)
C# protected void raise_AsyncOperationComplete(
object i1,
AsyncOperationCompleteEventArgs i2
);
Managed C++ protected: void raise_AsyncOperationComplete(
Object *i1,
AsyncOperationCompleteEventArgs *i2
);
JScript .NET protected function raise_AsyncOperationComplete(
i1 : Object,
i2 : AsyncOperationCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs.


Peer.raise_ConnectComplete(Object,ConnectCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_ConnectComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ConnectComplete( _
ByVal i1 As Object, _
ByVal i2 As ConnectCompleteEventArgs _
)
C# protected void raise_ConnectComplete(
object i1,
ConnectCompleteEventArgs i2
);
Managed C++ protected: void raise_ConnectComplete(
Object *i1,
ConnectCompleteEventArgs *i2
);
JScript .NET protected function raise_ConnectComplete(
i1 : Object,
i2 : ConnectCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ConnectCompleteEventArgs.


Peer.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Peer.raise_FindHostQuery(Object,FindHostQueryEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_FindHostQuery Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_FindHostQuery( _
ByVal i1 As Object, _
ByVal i2 As FindHostQueryEventArgs _
)
C# protected void raise_FindHostQuery(
object i1,
FindHostQueryEventArgs i2
);
Managed C++ protected: void raise_FindHostQuery(
Object *i1,
FindHostQueryEventArgs *i2
);
JScript .NET protected function raise_FindHostQuery(
i1 : Object,
i2 : FindHostQueryEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.FindHostQueryEventArgs.


Peer.raise_FindHostResponse(Object,FindHostResponseEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_FindHostResponse Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_FindHostResponse( _
ByVal i1 As Object, _
ByVal i2 As FindHostResponseEventArgs _
)
C# protected void raise_FindHostResponse(
object i1,
FindHostResponseEventArgs i2
);
Managed C++ protected: void raise_FindHostResponse(
Object *i1,
FindHostResponseEventArgs *i2
);
JScript .NET protected function raise_FindHostResponse(
i1 : Object,
i2 : FindHostResponseEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.FindHostResponseEventArgs.


Peer.raise_GroupCreated(Object,GroupCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_GroupCreated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_GroupCreated( _
ByVal i1 As Object, _
ByVal i2 As GroupCreatedEventArgs _
)
C# protected void raise_GroupCreated(
object i1,
GroupCreatedEventArgs i2
);
Managed C++ protected: void raise_GroupCreated(
Object *i1,
GroupCreatedEventArgs *i2
);
JScript .NET protected function raise_GroupCreated(
i1 : Object,
i2 : GroupCreatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.GroupCreatedEventArgs.


Peer.raise_GroupDestroyed(Object,GroupDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_GroupDestroyed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_GroupDestroyed( _
ByVal i1 As Object, _
ByVal i2 As GroupDestroyedEventArgs _
)
C# protected void raise_GroupDestroyed(
object i1,
GroupDestroyedEventArgs i2
);
Managed C++ protected: void raise_GroupDestroyed(
Object *i1,
GroupDestroyedEventArgs *i2
);
JScript .NET protected function raise_GroupDestroyed(
i1 : Object,
i2 : GroupDestroyedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.GroupDestroyedEventArgs.


Peer.raise_GroupInformation(Object,GroupInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_GroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_GroupInformation( _
ByVal i1 As Object, _
ByVal i2 As GroupInformationEventArgs _
)
C# protected void raise_GroupInformation(
object i1,
GroupInformationEventArgs i2
);
Managed C++ protected: void raise_GroupInformation(
Object *i1,
GroupInformationEventArgs *i2
);
JScript .NET protected function raise_GroupInformation(
i1 : Object,
i2 : GroupInformationEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.GroupInformationEventArgs.


Peer.raise_HostMigrated(Object,HostMigratedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_HostMigrated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_HostMigrated( _
ByVal i1 As Object, _
ByVal i2 As HostMigratedEventArgs _
)
C# protected void raise_HostMigrated(
object i1,
HostMigratedEventArgs i2
);
Managed C++ protected: void raise_HostMigrated(
Object *i1,
HostMigratedEventArgs *i2
);
JScript .NET protected function raise_HostMigrated(
i1 : Object,
i2 : HostMigratedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.HostMigratedEventArgs.


Peer.raise_IndicateConnect(Object,IndicateConnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_IndicateConnect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_IndicateConnect( _
ByVal i1 As Object, _
ByVal i2 As IndicateConnectEventArgs _
)
C# protected void raise_IndicateConnect(
object i1,
IndicateConnectEventArgs i2
);
Managed C++ protected: void raise_IndicateConnect(
Object *i1,
IndicateConnectEventArgs *i2
);
JScript .NET protected function raise_IndicateConnect(
i1 : Object,
i2 : IndicateConnectEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.IndicateConnectEventArgs.


Peer.raise_IndicatedConnectAborted(Object,IndicatedConnectAbortedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_IndicatedConnectAborted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_IndicatedConnectAborted( _
ByVal i1 As Object, _
ByVal i2 As IndicatedConnectAbortedEventArgs _
)
C# protected void raise_IndicatedConnectAborted(
object i1,
IndicatedConnectAbortedEventArgs i2
);
Managed C++ protected: void raise_IndicatedConnectAborted(
Object *i1,
IndicatedConnectAbortedEventArgs *i2
);
JScript .NET protected function raise_IndicatedConnectAborted(
i1 : Object,
i2 : IndicatedConnectAbortedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedEventArgs.


Peer.raise_PeerInformation(Object,PeerInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_PeerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PeerInformation( _
ByVal i1 As Object, _
ByVal i2 As PeerInformationEventArgs _
)
C# protected void raise_PeerInformation(
object i1,
PeerInformationEventArgs i2
);
Managed C++ protected: void raise_PeerInformation(
Object *i1,
PeerInformationEventArgs *i2
);
JScript .NET protected function raise_PeerInformation(
i1 : Object,
i2 : PeerInformationEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PeerInformationEventArgs.


Peer.raise_PlayerAddedToGroup(Object,PlayerAddedToGroupEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_PlayerAddedToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerAddedToGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerAddedToGroupEventArgs _
)
C# protected void raise_PlayerAddedToGroup(
object i1,
PlayerAddedToGroupEventArgs i2
);
Managed C++ protected: void raise_PlayerAddedToGroup(
Object *i1,
PlayerAddedToGroupEventArgs *i2
);
JScript .NET protected function raise_PlayerAddedToGroup(
i1 : Object,
i2 : PlayerAddedToGroupEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerAddedToGroupEventArgs.


Peer.raise_PlayerCreated(Object,PlayerCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_PlayerCreated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As PlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
PlayerCreatedEventArgs i2
);
Managed C++ protected: void raise_PlayerCreated(
Object *i1,
PlayerCreatedEventArgs *i2
);
JScript .NET protected function raise_PlayerCreated(
i1 : Object,
i2 : PlayerCreatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerCreatedEventArgs.


Peer.raise_PlayerDestroyed(Object,PlayerDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_PlayerDestroyed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerDestroyed( _
ByVal i1 As Object, _
ByVal i2 As PlayerDestroyedEventArgs _
)
C# protected void raise_PlayerDestroyed(
object i1,
PlayerDestroyedEventArgs i2
);
Managed C++ protected: void raise_PlayerDestroyed(
Object *i1,
PlayerDestroyedEventArgs *i2
);
JScript .NET protected function raise_PlayerDestroyed(
i1 : Object,
i2 : PlayerDestroyedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerDestroyedEventArgs.


Peer.raise_PlayerRemovedFromGroup(Object,PlayerRemovedFromGroupEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_PlayerRemovedFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerRemovedFromGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerRemovedFromGroupEventArgs _
)
C# protected void raise_PlayerRemovedFromGroup(
object i1,
PlayerRemovedFromGroupEventArgs i2
);
Managed C++ protected: void raise_PlayerRemovedFromGroup(
Object *i1,
PlayerRemovedFromGroupEventArgs *i2
);
JScript .NET protected function raise_PlayerRemovedFromGroup(
i1 : Object,
i2 : PlayerRemovedFromGroupEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerRemovedFromGroupEventArgs.


Peer.raise_Receive(Object,ReceiveEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_Receive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
Managed C++ protected: void raise_Receive(
Object *i1,
ReceiveEventArgs *i2
);
JScript .NET protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ReceiveEventArgs.


Peer.raise_SendComplete(Object,SendCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_SendComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SendComplete( _
ByVal i1 As Object, _
ByVal i2 As SendCompleteEventArgs _
)
C# protected void raise_SendComplete(
object i1,
SendCompleteEventArgs i2
);
Managed C++ protected: void raise_SendComplete(
Object *i1,
SendCompleteEventArgs *i2
);
JScript .NET protected function raise_SendComplete(
i1 : Object,
i2 : SendCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.SendCompleteEventArgs.


Peer.raise_SessionTerminated(Object,SessionTerminatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.raise_SessionTerminated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SessionTerminated( _
ByVal i1 As Object, _
ByVal i2 As SessionTerminatedEventArgs _
)
C# protected void raise_SessionTerminated(
object i1,
SessionTerminatedEventArgs i2
);
Managed C++ protected: void raise_SessionTerminated(
Object *i1,
SessionTerminatedEventArgs *i2
);
JScript .NET protected function raise_SessionTerminated(
i1 : Object,
i2 : SessionTerminatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.SessionTerminatedEventArgs.


Peer.RegisterLobby(Int32,Application)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.RegisterLobby Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub RegisterLobby( _
ByVal handle As Integer, _
ByVal lobbiedApplication As Application _
)
C# public void RegisterLobby(
int handle,
Application lobbiedApplication
);
Managed C++ public: void RegisterLobby(
int handle,
Application *lobbiedApplication
);
JScript .NET public function RegisterLobby(
handle : int,
lobbiedApplication : Application
);

Parameters

handle | System.Int32.
lobbiedApplication | Microsoft.DirectX.DirectPlay.Lobby.Application.


Peer.RemovePlayerFromGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Overload List

public void RemovePlayerFromGroup(int, int, out int, SyncFlags);
public void RemovePlayerFromGroup(int, int, out int, SyncFlags, object);
public void RemovePlayerFromGroup(int, int, SyncFlags);
public void RemovePlayerFromGroup(int, int, SyncFlags, object);


Peer.RemovePlayerFromGroup(Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.RemovePlayerFromGroup(Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.SendTo

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Overload List

public void SendTo(int, GCHandle, int, int, out int, SendFlags);
public void SendTo(int, GCHandle, int, int, out int, SendFlags, object);
public void SendTo(int, GCHandle, int, int, SendFlags);
public void SendTo(int, GCHandle, int, int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, out int, SendFlags);
public void SendTo(int, NetworkPacket, int, out int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, SendFlags);
public void SendTo(int, NetworkPacket, int, SendFlags, object);


Peer.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
int *asyncHandle,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Peer.SendTo(Int32,GCHandle,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Peer.SendTo(Int32,GCHandle,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Peer.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
int *asyncHandle,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Peer.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
int *asyncHandle,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Peer.SendTo(Int32,NetworkPacket,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Peer.SendTo(Int32,NetworkPacket,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Peer.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
int *asyncHandle,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Peer.SetGroupInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Overload List

public void SetGroupInformation(int, GroupInformation, out int, SyncFlags);
public void SetGroupInformation(int, GroupInformation, out int, SyncFlags, object);
public void SetGroupInformation(int, GroupInformation, SyncFlags);
public void SetGroupInformation(int, GroupInformation, SyncFlags, object);


Peer.SetGroupInformation(Int32,GroupInformation,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.SetGroupInformation(Int32,GroupInformation,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.SetPeerInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetPeerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Overload List

public void SetPeerInformation(PlayerInformation, out int, SyncFlags);
public void SetPeerInformation(PlayerInformation, out int, SyncFlags, object);
public void SetPeerInformation(PlayerInformation, SyncFlags);
public void SetPeerInformation(PlayerInformation, SyncFlags, object);


Peer.SetPeerInformation(PlayerInformation,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetPeerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic .NET Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
Managed C++ public: void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
JScript .NET public function SetPeerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.SetPeerInformation(PlayerInformation,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetPeerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic .NET Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void SetPeerInformation(
PlayerInformation playerInformation,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function SetPeerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Peer.SetPeerInformation(PlayerInformation,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetPeerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic .NET Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetPeerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.SetPeerInformation(PlayerInformation,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetPeerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic .NET Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetPeerInformation(
PlayerInformation playerInformation,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetPeerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Peer.SetSPCaps(Guid,ServiceProviderCaps)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SetSPCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.

Definition

Visual Basic .NET Public Sub SetSPCaps( _
ByVal guidServiceProvider As Guid, _
ByVal value As ServiceProviderCaps _
)
C# public void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
Managed C++ public: void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
JScript .NET public function SetSPCaps(
guidServiceProvider : Guid,
value : ServiceProviderCaps
);

Parameters

guidServiceProvider | System.Guid.
value | Microsoft.DirectX.DirectPlay.ServiceProviderCaps.


Peer.TerminateSession(NetworkPacket)

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.TerminateSession Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Terminates the current session. Deprecated.

Definition

Visual Basic .NET Public Sub TerminateSession( _
ByVal terminateData As NetworkPacket _
)
C# public void TerminateSession(
NetworkPacket terminateData
);
Managed C++ public: void TerminateSession(
NetworkPacket *terminateData
);
JScript .NET public function TerminateSession(
terminateData : NetworkPacket
);

Parameters

terminateData Microsoft.DirectX.DirectPlay.NetworkPacket.


Peer.UnregisterLobby()

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.UnregisterLobby Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Sub UnregisterLobby()
C# | public void UnregisterLobby();
Managed C++ | public: void UnregisterLobby();
JScript .NET | public function UnregisterLobby();


Peer.ApplicationDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.ApplicationDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.

Definition

Visual Basic .NET | Public Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; set; }
Managed C++ public: __property ApplicationDescription get_ApplicationDescription();
public: __property void set_ApplicationDescription(ApplicationDescription);
JScript .NET public function get ApplicationDescription() : ApplicationDescription
public function set ApplicationDescription(ApplicationDescription);

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription .

This property is read/write.


Peer.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Peer object. Deprecated.

Definition

Visual Basic .NET | Public Property Caps As Caps
C# | public Caps Caps { get; set; }
Managed C++ public: __property Caps get_Caps();
public: __property void set_Caps(Caps);
JScript .NET public function get Caps() : Caps
public function set Caps(Caps);

Property Value

Microsoft.DirectX.DirectPlay.Caps .

This property is read/write.


Peer.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


Peer.GroupMembers

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GroupMembers Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupMembers As GroupMembersList
C# | public GroupMembersList GroupMembers { get; }
Managed C++ | public: __property GroupMembersList* get_GroupMembers();
JScript .NET | public function get GroupMembers() : GroupMembersList

Property Value

Microsoft.DirectX.DirectPlay.GroupMembersList .

This property is read-only.


Peer.Groups

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Groups Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Groups As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Groups { get; }
Managed C++ | public: __property PlayersGroupsEnumerator* get_Groups();
JScript .NET | public function get Groups() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator .

This property is read-only.


Peer.Players

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Players Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Players As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Players { get; }
Managed C++ | public: __property PlayersGroupsEnumerator* get_Players();
JScript .NET | public function get Players() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator .

This property is read-only.


Peer.ApplicationDescriptionChanged

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.ApplicationDescriptionChanged Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.

Definition

Visual Basic .NET | Public Event ApplicationDescriptionChanged As ApplicationDescriptionEventHandler
C# | public event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
Managed C++ | public: __event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.AsyncOperationComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.AsyncOperationComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the async operation has completed. Deprecated.

Definition

Visual Basic .NET | Public Event AsyncOperationComplete As AsyncOperationCompleteEventHandler
C# | public event AsyncOperationCompleteEventHandler AsyncOperationComplete;
Managed C++ | public: __event AsyncOperationCompleteEventHandler AsyncOperationComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.ConnectComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.ConnectComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.

Definition

Visual Basic .NET | Public Event ConnectComplete As ConnectCompleteEventHandler
C# | public event ConnectCompleteEventHandler ConnectComplete;
Managed C++ | public: __event ConnectCompleteEventHandler ConnectComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Peer.Disposing event, use the following code.

peer.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Peer.FindHostQuery

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.FindHostQuery Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.

Definition

Visual Basic .NET | Public Event FindHostQuery As FindHostQueryEventHandler
C# | public event FindHostQueryEventHandler FindHostQuery;
Managed C++ | public: __event FindHostQueryEventHandler FindHostQuery;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.FindHostResponse

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.FindHostResponse Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.

Definition

Visual Basic .NET | Public Event FindHostResponse As FindHostResponseEventHandler
C# | public event FindHostResponseEventHandler FindHostResponse;
Managed C++ | public: __event FindHostResponseEventHandler FindHostResponse;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.GroupCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GroupCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.

Definition

Visual Basic .NET | Public Event GroupCreated As GroupCreatedEventHandler
C# | public event GroupCreatedEventHandler GroupCreated;
Managed C++ | public: __event GroupCreatedEventHandler GroupCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.GroupDestroyed

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GroupDestroyed Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.

Definition

Visual Basic .NET | Public Event GroupDestroyed As GroupDestroyedEventHandler
C# | public event GroupDestroyedEventHandler GroupDestroyed;
Managed C++ | public: __event GroupDestroyedEventHandler GroupDestroyed;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.GroupInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.GroupInformation Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET | Public Event GroupInformation As GroupInformationEventHandler
C# | public event GroupInformationEventHandler GroupInformation;
Managed C++ | public: __event GroupInformationEventHandler GroupInformation;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.HostMigrated

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.HostMigrated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has been migrated. Deprecated.

Definition

Visual Basic .NET | Public Event HostMigrated As HostMigratedEventHandler
C# | public event HostMigratedEventHandler HostMigrated;
Managed C++ | public: __event HostMigratedEventHandler HostMigrated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.IndicateConnect

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.IndicateConnect Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.

Definition

Visual Basic .NET | Public Event IndicateConnect As IndicateConnectEventHandler
C# | public event IndicateConnectEventHandler IndicateConnect;
Managed C++ | public: __event IndicateConnectEventHandler IndicateConnect;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.IndicatedConnectAborted

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.IndicatedConnectAborted Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.

Definition

Visual Basic .NET | Public Event IndicatedConnectAborted As IndicatedConnectAbortedEventHandler
C# | public event IndicatedConnectAbortedEventHandler IndicatedConnectAborted;
Managed C++ | public: __event IndicatedConnectAbortedEventHandler IndicatedConnectAborted;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.PeerInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.PeerInformation Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic .NET | Public Event PeerInformation As PeerInformationEventHandler
C# | public event PeerInformationEventHandler PeerInformation;
Managed C++ | public: __event PeerInformationEventHandler PeerInformation;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.PlayerAddedToGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.PlayerAddedToGroup Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerAddedToGroup As PlayerAddedToGroupEventHandler
C# | public event PlayerAddedToGroupEventHandler PlayerAddedToGroup;
Managed C++ | public: __event PlayerAddedToGroupEventHandler PlayerAddedToGroup;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.PlayerCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.PlayerCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerCreated As PlayerCreatedEventHandler
C# | public event PlayerCreatedEventHandler PlayerCreated;
Managed C++ | public: __event PlayerCreatedEventHandler PlayerCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.PlayerDestroyed

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.PlayerDestroyed Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerDestroyed As PlayerDestroyedEventHandler
C# | public event PlayerDestroyedEventHandler PlayerDestroyed;
Managed C++ | public: __event PlayerDestroyedEventHandler PlayerDestroyed;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.PlayerRemovedFromGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.PlayerRemovedFromGroup Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerRemovedFromGroup As PlayerRemovedFromGroupEventHandler
C# | public event PlayerRemovedFromGroupEventHandler PlayerRemovedFromGroup;
Managed C++ | public: __event PlayerRemovedFromGroupEventHandler PlayerRemovedFromGroup;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.Receive

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.Receive Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the peer object receives data. Deprecated.

Definition

Visual Basic .NET | Public Event Receive As ReceiveEventHandler
C# | public event ReceiveEventHandler Receive;
Managed C++ | public: __event ReceiveEventHandler Receive;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.SendComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SendComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.

Definition

Visual Basic .NET | Public Event SendComplete As SendCompleteEventHandler
C# | public event SendCompleteEventHandler SendComplete;
Managed C++ | public: __event SendCompleteEventHandler SendComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Peer.SessionTerminated

Microsoft DirectX 9.0 SDK Update (October 2004)

Peer.SessionTerminated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Definition

Visual Basic .NET | Public Event SessionTerminated As SessionTerminatedEventHandler
C# | public event SessionTerminatedEventHandler SessionTerminated;
Managed C++ | public: __event SessionTerminatedEventHandler SessionTerminated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.PeerInformationEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PeerInformationEventArgs
Inherits EventArgs
C# | public sealed class PeerInformationEventArgs : EventArgs
Managed C++ | public __gc __sealed class PeerInformationEventArgs : public EventArgs
JScript .NET | public class PeerInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PeerInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PeerInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PeerInformationEventArgs.PeerInformationEventArgs(PeerInformationMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationEventArgs.PeerInformationEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As PeerInformationMessage _
)
C# public PeerInformationEventArgs(
PeerInformationMessage dpMessage
);
Managed C++ public: PeerInformationEventArgs(
PeerInformationMessage dpMessage
);
JScript .NET public function PeerInformationEventArgs(
dpMessage : PeerInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.PeerInformationMessage.


PeerInformationEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As PeerInformationMessage
C# | public PeerInformationMessage Message;
Managed C++ | public: PeerInformationMessage Message;
JScript .NET | public var Message : PeerInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.PeerInformationMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.PlayerAddedToGroupEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAddedToGroupEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerAddedToGroup event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayerAddedToGroupEventArgs
Inherits EventArgs
C# | public sealed class PlayerAddedToGroupEventArgs : EventArgs
Managed C++ | public __gc __sealed class PlayerAddedToGroupEventArgs : public EventArgs
JScript .NET | public class PlayerAddedToGroupEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerAddedToGroupEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerAddedToGroupEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerAddedToGroupEventArgs.PlayerAddedToGroupEventArgs(AddPlayerToGroupMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAddedToGroupEventArgs.PlayerAddedToGroupEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As AddPlayerToGroupMessage _
)
C# public PlayerAddedToGroupEventArgs(
AddPlayerToGroupMessage dpMessage
);
Managed C++ public: PlayerAddedToGroupEventArgs(
AddPlayerToGroupMessage dpMessage
);
JScript .NET public function PlayerAddedToGroupEventArgs(
dpMessage : AddPlayerToGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.AddPlayerToGroupMessage.


PlayerAddedToGroupEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAddedToGroupEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As AddPlayerToGroupMessage
C# | public AddPlayerToGroupMessage Message;
Managed C++ | public: AddPlayerToGroupMessage Message;
JScript .NET | public var Message : AddPlayerToGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.AddPlayerToGroupMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.PlayerAlreadyInGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAlreadyInGroupException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is already included in the group. Deprecated.

Definition

Visual Basic .NET Public Class PlayerAlreadyInGroupException
Inherits DirectPlayException
C# | public class PlayerAlreadyInGroupException : DirectPlayException
Managed C++ | public __gc class PlayerAlreadyInGroupException : public DirectPlayException
JScript .NET | public class PlayerAlreadyInGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerAlreadyInGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerAlreadyInGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerAlreadyInGroupException();
protected PlayerAlreadyInGroupException(SerializationInfo, StreamingContext);
public PlayerAlreadyInGroupException(string);
public PlayerAlreadyInGroupException(string, Exception);


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerAlreadyInGroupException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PlayerAlreadyInGroupException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PlayerAlreadyInGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerAlreadyInGroupException(
string message,
Exception inner
);
Managed C++ public: PlayerAlreadyInGroupException(
String *message,
Exception *inner
);
JScript .NET public function PlayerAlreadyInGroupException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PlayerAlreadyInGroupException(
string message
);
Managed C++ public: PlayerAlreadyInGroupException(
String *message
);
JScript .NET public function PlayerAlreadyInGroupException(
message : String
);

Parameters

message System.String.


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerAlreadyInGroupException();
Managed C++ | public: PlayerAlreadyInGroupException();
JScript .NET | public function PlayerAlreadyInGroupException();


Microsoft.DirectX.DirectPlay.PlayerCreatedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerCreatedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayerCreatedEventArgs
Inherits EventArgs
C# | public sealed class PlayerCreatedEventArgs : EventArgs
Managed C++ | public __gc __sealed class PlayerCreatedEventArgs : public EventArgs
JScript .NET | public class PlayerCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerCreatedEventArgs.PlayerCreatedEventArgs(CreatePlayerMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerCreatedEventArgs.PlayerCreatedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As CreatePlayerMessage _
)
C# public PlayerCreatedEventArgs(
CreatePlayerMessage dpMessage
);
Managed C++ public: PlayerCreatedEventArgs(
CreatePlayerMessage dpMessage
);
JScript .NET public function PlayerCreatedEventArgs(
dpMessage : CreatePlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.CreatePlayerMessage.


PlayerCreatedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerCreatedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As CreatePlayerMessage
C# | public CreatePlayerMessage Message;
Managed C++ | public: CreatePlayerMessage Message;
JScript .NET | public var Message : CreatePlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.CreatePlayerMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.PlayerDestroyedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerDestroyedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDestroyed event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayerDestroyedEventArgs
Inherits EventArgs
C# | public sealed class PlayerDestroyedEventArgs : EventArgs
Managed C++ | public __gc __sealed class PlayerDestroyedEventArgs : public EventArgs
JScript .NET | public class PlayerDestroyedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerDestroyedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerDestroyedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerDestroyedEventArgs.PlayerDestroyedEventArgs(DestroyPlayerMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerDestroyedEventArgs.PlayerDestroyedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As DestroyPlayerMessage _
)
C# public PlayerDestroyedEventArgs(
DestroyPlayerMessage dpMessage
);
Managed C++ public: PlayerDestroyedEventArgs(
DestroyPlayerMessage dpMessage
);
JScript .NET public function PlayerDestroyedEventArgs(
dpMessage : DestroyPlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.DestroyPlayerMessage.


PlayerDestroyedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerDestroyedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As DestroyPlayerMessage
C# | public DestroyPlayerMessage Message;
Managed C++ | public: DestroyPlayerMessage Message;
JScript .NET | public var Message : DestroyPlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.DestroyPlayerMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.PlayerLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has lost the connection to the session. Deprecated.

Definition

Visual Basic .NET Public Class PlayerLostException
Inherits DirectPlayException
C# | public class PlayerLostException : DirectPlayException
Managed C++ | public __gc class PlayerLostException : public DirectPlayException
JScript .NET | public class PlayerLostException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerLostException.PlayerLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerLostException.PlayerLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerLostException();
protected PlayerLostException(SerializationInfo, StreamingContext);
public PlayerLostException(string);
public PlayerLostException(string, Exception);


PlayerLostException.PlayerLostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerLostException.PlayerLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerLostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PlayerLostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PlayerLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PlayerLostException.PlayerLostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerLostException.PlayerLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerLostException(
string message,
Exception inner
);
Managed C++ public: PlayerLostException(
String *message,
Exception *inner
);
JScript .NET public function PlayerLostException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PlayerLostException.PlayerLostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerLostException.PlayerLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PlayerLostException(
string message
);
Managed C++ public: PlayerLostException(
String *message
);
JScript .NET public function PlayerLostException(
message : String
);

Parameters

message System.String.


PlayerLostException.PlayerLostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerLostException.PlayerLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerLostException();
Managed C++ | public: PlayerLostException();
JScript .NET | public function PlayerLostException();


Microsoft.DirectX.DirectPlay.PlayerNotInGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotInGroupException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not included in the group. Deprecated.

Definition

Visual Basic .NET Public Class PlayerNotInGroupException
Inherits DirectPlayException
C# | public class PlayerNotInGroupException : DirectPlayException
Managed C++ | public __gc class PlayerNotInGroupException : public DirectPlayException
JScript .NET | public class PlayerNotInGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerNotInGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerNotInGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerNotInGroupException.PlayerNotInGroupException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerNotInGroupException();
protected PlayerNotInGroupException(SerializationInfo, StreamingContext);
public PlayerNotInGroupException(string);
public PlayerNotInGroupException(string, Exception);


PlayerNotInGroupException.PlayerNotInGroupException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerNotInGroupException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PlayerNotInGroupException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PlayerNotInGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PlayerNotInGroupException.PlayerNotInGroupException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerNotInGroupException(
string message,
Exception inner
);
Managed C++ public: PlayerNotInGroupException(
String *message,
Exception *inner
);
JScript .NET public function PlayerNotInGroupException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PlayerNotInGroupException.PlayerNotInGroupException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PlayerNotInGroupException(
string message
);
Managed C++ public: PlayerNotInGroupException(
String *message
);
JScript .NET public function PlayerNotInGroupException(
message : String
);

Parameters

message System.String.


PlayerNotInGroupException.PlayerNotInGroupException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerNotInGroupException();
Managed C++ | public: PlayerNotInGroupException();
JScript .NET | public function PlayerNotInGroupException();


Microsoft.DirectX.DirectPlay.PlayerNotReachableException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotReachableException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has tried to join a peer-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.

Definition

Visual Basic .NET Public Class PlayerNotReachableException
Inherits DirectPlayException
C# | public class PlayerNotReachableException : DirectPlayException
Managed C++ | public __gc class PlayerNotReachableException : public DirectPlayException
JScript .NET | public class PlayerNotReachableException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerNotReachableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerNotReachableException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerNotReachableException.PlayerNotReachableException

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerNotReachableException();
protected PlayerNotReachableException(SerializationInfo, StreamingContext);
public PlayerNotReachableException(string);
public PlayerNotReachableException(string, Exception);


PlayerNotReachableException.PlayerNotReachableException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerNotReachableException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PlayerNotReachableException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PlayerNotReachableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


PlayerNotReachableException.PlayerNotReachableException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerNotReachableException(
string message,
Exception inner
);
Managed C++ public: PlayerNotReachableException(
String *message,
Exception *inner
);
JScript .NET public function PlayerNotReachableException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


PlayerNotReachableException.PlayerNotReachableException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PlayerNotReachableException(
string message
);
Managed C++ public: PlayerNotReachableException(
String *message
);
JScript .NET public function PlayerNotReachableException(
message : String
);

Parameters

message System.String.


PlayerNotReachableException.PlayerNotReachableException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerNotReachableException();
Managed C++ | public: PlayerNotReachableException();
JScript .NET | public function PlayerNotReachableException();


Microsoft.DirectX.DirectPlay.PlayerRemovedFromGroupEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerRemovedFromGroupEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerRemovedFromGroup event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayerRemovedFromGroupEventArgs
Inherits EventArgs
C# | public sealed class PlayerRemovedFromGroupEventArgs : EventArgs
Managed C++ | public __gc __sealed class PlayerRemovedFromGroupEventArgs : public EventArgs
JScript .NET | public class PlayerRemovedFromGroupEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerRemovedFromGroupEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerRemovedFromGroupEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerRemovedFromGroupEventArgs.PlayerRemovedFromGroupEventArgs(RemovePlayerFromGroupMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerRemovedFromGroupEventArgs.PlayerRemovedFromGroupEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As RemovePlayerFromGroupMessage _
)
C# public PlayerRemovedFromGroupEventArgs(
RemovePlayerFromGroupMessage dpMessage
);
Managed C++ public: PlayerRemovedFromGroupEventArgs(
RemovePlayerFromGroupMessage dpMessage
);
JScript .NET public function PlayerRemovedFromGroupEventArgs(
dpMessage : RemovePlayerFromGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.RemovePlayerFromGroupMessage.


PlayerRemovedFromGroupEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerRemovedFromGroupEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As RemovePlayerFromGroupMessage
C# | public RemovePlayerFromGroupMessage Message;
Managed C++ | public: RemovePlayerFromGroupMessage Message;
JScript .NET | public var Message : RemovePlayerFromGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.RemovePlayerFromGroupMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides an enumerator for player and group lists. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class PlayersGroupsEnumerator
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class PlayersGroupsEnumerator : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class PlayersGroupsEnumerator : public Object,
IEnumerable, IEnumerator
JScript .NET public class PlayersGroupsEnumerator extends Object
implements IEnumerator, IEnumerable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns an array of Int32 representing the player or group id's of the members of the list. Deprecated.
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
GetUserData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the user data Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.
Item
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current user or group name. Deprecated.

Inheritance Hierarchy

Object Leave Site
PlayersGroupsEnumerator

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayersGroupsEnumerator.GetData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.GetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns an array of Int32 representing the player or group id's of the members of the list. Deprecated.

Definition

Visual Basic .NET | Public Function GetData() As Integer()
C# | public int[] GetData();
Managed C++ | public: int GetData() __gc[];
JScript .NET | public function GetData() : int[];

Return Value

System.Int32[].


PlayersGroupsEnumerator.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator .


PlayersGroupsEnumerator.GetUserData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.GetUserData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the user data Deprecated.

Definition

Visual Basic .NET | Public Function GetUserData() As Byte()
C# | public byte[] GetUserData();
Managed C++ | public: Byte GetUserData() __gc[];
JScript .NET | public function GetUserData() : byte[];

Return Value

System.Byte[].


PlayersGroupsEnumerator.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean .


PlayersGroupsEnumerator.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();


PlayersGroupsEnumerator.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 .

This property is read-only.


PlayersGroupsEnumerator.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object .

This property is read-only.


PlayersGroupsEnumerator.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal index As Integer _
) As Integer
C# public int this[
int index
] { get; }
Managed C++ public: __property int get_Item(
int index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

System.Int32 .

This property is read-only.

Parameters

index System.Int32.


PlayersGroupsEnumerator.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayersGroupsEnumerator.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current user or group name. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Name As String
C# | public string Name { get; }
Managed C++ | public: __property String* get_Name();
JScript .NET | public function get Name() : String

Property Value

System.String .

This property is read-only.


Microsoft.DirectX.DirectPlay.ReceiveEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ReceiveEventArgs
Inherits EventArgs
C# | public sealed class ReceiveEventArgs : EventArgs
Managed C++ | public __gc __sealed class ReceiveEventArgs : public EventArgs
JScript .NET | public class ReceiveEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ReceiveEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ReceiveEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReceiveEventArgs.ReceiveEventArgs(ReceiveMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveEventArgs.ReceiveEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ReceiveMessage _
)
C# public ReceiveEventArgs(
ReceiveMessage dpMessage
);
Managed C++ public: ReceiveEventArgs(
ReceiveMessage dpMessage
);
JScript .NET public function ReceiveEventArgs(
dpMessage : ReceiveMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ReceiveMessage.


ReceiveEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ReceiveMessage
C# | public ReceiveMessage Message;
Managed C++ | public: ReceiveMessage Message;
JScript .NET | public var Message : ReceiveMessage

Field Value

Microsoft.DirectX.DirectPlay.ReceiveMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.SendCompleteEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SendCompleteEventArgs
Inherits EventArgs
C# | public sealed class SendCompleteEventArgs : EventArgs
Managed C++ | public __gc __sealed class SendCompleteEventArgs : public EventArgs
JScript .NET | public class SendCompleteEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SendCompleteEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SendCompleteEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SendCompleteEventArgs.SendCompleteEventArgs(SendCompleteMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteEventArgs.SendCompleteEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As SendCompleteMessage _
)
C# public SendCompleteEventArgs(
SendCompleteMessage dpMessage
);
Managed C++ public: SendCompleteEventArgs(
SendCompleteMessage dpMessage
);
JScript .NET public function SendCompleteEventArgs(
dpMessage : SendCompleteMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.SendCompleteMessage.


SendCompleteEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As SendCompleteMessage
C# | public SendCompleteMessage Message;
Managed C++ | public: SendCompleteMessage Message;
JScript .NET | public var Message : SendCompleteMessage

Field Value

Microsoft.DirectX.DirectPlay.SendCompleteMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.SendTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

SendTooLargeException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The send was too large. Deprecated.

Definition

Visual Basic .NET Public Class SendTooLargeException
Inherits DirectPlayException
C# | public class SendTooLargeException : DirectPlayException
Managed C++ | public __gc class SendTooLargeException : public DirectPlayException
JScript .NET | public class SendTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SendTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
SendTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SendTooLargeException.SendTooLargeException

Microsoft DirectX 9.0 SDK Update (October 2004)

SendTooLargeException.SendTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SendTooLargeException();
protected SendTooLargeException(SerializationInfo, StreamingContext);
public SendTooLargeException(string);
public SendTooLargeException(string, Exception);


SendTooLargeException.SendTooLargeException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendTooLargeException.SendTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SendTooLargeException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SendTooLargeException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SendTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SendTooLargeException.SendTooLargeException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendTooLargeException.SendTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SendTooLargeException(
string message,
Exception inner
);
Managed C++ public: SendTooLargeException(
String *message,
Exception *inner
);
JScript .NET public function SendTooLargeException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SendTooLargeException.SendTooLargeException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendTooLargeException.SendTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SendTooLargeException(
string message
);
Managed C++ public: SendTooLargeException(
String *message
);
JScript .NET public function SendTooLargeException(
message : String
);

Parameters

message System.String.


SendTooLargeException.SendTooLargeException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SendTooLargeException.SendTooLargeException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SendTooLargeException();
Managed C++ | public: SendTooLargeException();
JScript .NET | public function SendTooLargeException();


Microsoft.DirectX.DirectPlay.Server

Microsoft DirectX 9.0 SDK Update (October 2004)

Server Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to create and manage the server for a Microsoft® DirectPlay® client/server transport session. Deprecated.

Definition

Visual Basic .NET Public Class Server
Inherits MarshalByRefObject
Implements IDisposable
C# public class Server : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Server : public MarshalByRefObject,
IDisposable
JScript .NET public class Server extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ApplicationDescriptionChanged
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.
AsyncOperationComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.
ClientInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
FindHostQuery
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.
GroupCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.
GroupDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.
GroupInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.
IndicateConnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.
IndicatedConnectAborted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.
PlayerAddedToGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
PlayerRemovedFromGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the server object receives data. Deprecated.
SendComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.
ServerInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Methods

Method Description
AddPlayerToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.
CancelAsyncOperation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.
CreateGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.
DestroyClient
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a client from the session. Deprecated.
DestroyGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetClientAddress
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified player in the session. Deprecated.
GetClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.
GetConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local server and the specified remote client. Deprecated.
GetGroupContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for a group. Deprecated.
GetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetLocalHostAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
GetPlayerContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for a client. Deprecated.
GetSendQueueInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should slow the rate that messages are sent. Deprecated.
GetServiceProviders
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.
GetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.
Host
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_ApplicationDescriptionChanged
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_AsyncOperationComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostQuery
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicateConnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicatedConnectAborted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerAddedToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerRemovedFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SendComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RemovePlayerFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.
SendTo
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.
Server
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.
SetServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.
SetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the structure for the specified service provider. Deprecated.
UnregisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Server object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
GroupMembers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.
Groups
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.
Players
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the application. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Server

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Server.AddPlayerToGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Overload List

public void AddPlayerToGroup(int, int, out int, SyncFlags);
public void AddPlayerToGroup(int, int, out int, SyncFlags, object);
public void AddPlayerToGroup(int, int, SyncFlags);
public void AddPlayerToGroup(int, int, SyncFlags, object);


Server.AddPlayerToGroup(Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.AddPlayerToGroup(Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.AddPlayerToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic .NET Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void AddPlayerToGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.CancelAsyncOperation

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.

Overload List

public void CancelAsyncOperation(CancelFlags);
public void CancelAsyncOperation(int);


Server.CancelAsyncOperation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.

Definition

Visual Basic .NET Public Sub CancelAsyncOperation( _
ByVal asyncHandle As Integer _
)
C# public void CancelAsyncOperation(
int asyncHandle
);
Managed C++ public: void CancelAsyncOperation(
int asyncHandle
);
JScript .NET public function CancelAsyncOperation(
asyncHandle : int
);

Parameters

asyncHandle System.Int32.


Server.CancelAsyncOperation(CancelFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CancelAsyncOperation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.

Definition

Visual Basic .NET Public Sub CancelAsyncOperation( _
ByVal flags As CancelFlags _
)
C# public void CancelAsyncOperation(
CancelFlags flags
);
Managed C++ public: void CancelAsyncOperation(
CancelFlags flags
);
JScript .NET public function CancelAsyncOperation(
flags : CancelFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.CancelFlags.


Server.CreateGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Overload List

public void CreateGroup(GroupInformation, out int, SyncFlags);
public void CreateGroup(GroupInformation, out int, SyncFlags, object, object);
public void CreateGroup(GroupInformation, SyncFlags);
public void CreateGroup(GroupInformation, SyncFlags, object, object);


Server.CreateGroup(GroupInformation,SyncFlags,Object,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
object groupContext,
object asyncContext
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
Object *groupContext,
Object *asyncContext
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
groupContext | System.Object.
asyncContext | System.Object.


Server.CreateGroup(GroupInformation,Int32,SyncFlags,Object,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object groupContext,
object asyncContext
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags,
Object *groupContext,
Object *asyncContext
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
groupContext | System.Object.
asyncContext | System.Object.


Server.CreateGroup(GroupInformation,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.CreateGroup(GroupInformation,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.CreateGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic .NET Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void CreateGroup(
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.DestroyClient(Int32,NetworkPacket)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.DestroyClient Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a client from the session. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyClient( _
ByVal playerID As Integer, _
ByVal destroyData As NetworkPacket _
)
C# public void DestroyClient(
int playerID,
NetworkPacket destroyData
);
Managed C++ public: void DestroyClient(
int playerID,
NetworkPacket *destroyData
);
JScript .NET public function DestroyClient(
playerID : int,
destroyData : NetworkPacket
);

Parameters

playerID | System.Int32.
destroyData | Microsoft.DirectX.DirectPlay.NetworkPacket.


Server.DestroyGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Overload List

public void DestroyGroup(int, out int, SyncFlags);
public void DestroyGroup(int, out int, SyncFlags, object);
public void DestroyGroup(int, SyncFlags);
public void DestroyGroup(int, SyncFlags, object);


Server.DestroyGroup(Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void DestroyGroup(
int groupID,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function DestroyGroup(
groupID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.DestroyGroup(Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void DestroyGroup(
int groupID,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.DestroyGroup(Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags
);
Managed C++ public: void DestroyGroup(
int groupID,
SyncFlags flags
);
JScript .NET public function DestroyGroup(
groupID : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.DestroyGroup(Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.DestroyGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic .NET Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void DestroyGroup(
int groupID,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.Dispose

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Overload List

public override void Dispose();
public void Dispose(bool);

See Also

  • Server.Disposed
  • Server.Disposing


Server.Dispose(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET Public Sub Dispose( _
ByVal closeImmediate As Boolean _
)
C# public void Dispose(
bool closeImmediate
);
Managed C++ public: void Dispose(
bool closeImmediate
);
JScript .NET public function Dispose(
closeImmediate : boolean
);

Parameters

closeImmediate System.Boolean.

See Also

  • Server.Disposed
  • Server.Disposing


Server.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Server.Disposed
  • Server.Disposing


Server.GetClientAddress(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetClientAddress Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified player in the session. Deprecated.

Definition

Visual Basic .NET Public Function GetClientAddress( _
ByVal playerID As Integer _
) As Address
C# public Address GetClientAddress(
int playerID
);
Managed C++ public: Address* GetClientAddress(
int playerID
);
JScript .NET public function GetClientAddress(
playerID : int
) : Address;

Parameters

playerID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.Address .


Server.GetClientInformation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.

Definition

Visual Basic .NET Public Function GetClientInformation( _
ByVal playerID As Integer _
) As PlayerInformation
C# public PlayerInformation GetClientInformation(
int playerID
);
Managed C++ public: PlayerInformation GetClientInformation(
int playerID
);
JScript .NET public function GetClientInformation(
playerID : int
) : PlayerInformation;

Parameters

playerID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.PlayerInformation .


Server.GetConnectionInformation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetConnectionInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local server and the specified remote client. Deprecated.

Definition

Visual Basic .NET Public Function GetConnectionInformation( _
ByVal playerID As Integer _
) As ConnectionInformation
C# public ConnectionInformation GetConnectionInformation(
int playerID
);
Managed C++ public: ConnectionInformation GetConnectionInformation(
int playerID
);
JScript .NET public function GetConnectionInformation(
playerID : int
) : ConnectionInformation;

Parameters

playerID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.ConnectionInformation .


Server.GetGroupContext(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetGroupContext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for a group. Deprecated.

Definition

Visual Basic .NET Public Function GetGroupContext( _
ByVal groupID As Integer _
) As Object
C# public object GetGroupContext(
int groupID
);
Managed C++ public: Object* GetGroupContext(
int groupID
);
JScript .NET public function GetGroupContext(
groupID : int
) : Object;

Parameters

groupID System.Int32.

Return Value

System.Object .


Server.GetGroupInformation(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Function GetGroupInformation( _
ByVal groupID As Integer _
) As GroupInformation
C# public GroupInformation GetGroupInformation(
int groupID
);
Managed C++ public: GroupInformation GetGroupInformation(
int groupID
);
JScript .NET public function GetGroupInformation(
groupID : int
) : GroupInformation;

Parameters

groupID System.Int32.

Return Value

Microsoft.DirectX.DirectPlay.GroupInformation .


Server.GetLocalHostAddresses(LocalAddressFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetLocalHostAddresses Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Function GetLocalHostAddresses( _
ByVal flags As LocalAddressFlags _
) As Address()
C# public Address[] GetLocalHostAddresses(
LocalAddressFlags flags
);
Managed C++ public: Address* GetLocalHostAddresses(
LocalAddressFlags flags
) __gc[];
JScript .NET public function GetLocalHostAddresses(
flags : LocalAddressFlags
) : Address[];

Parameters

flags Microsoft.DirectX.DirectPlay.LocalAddressFlags.

Return Value

Microsoft.DirectX.DirectPlay.Address[].


Server.GetPlayerContext(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetPlayerContext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for a client. Deprecated.

Definition

Visual Basic .NET Public Function GetPlayerContext( _
ByVal playerID As Integer _
) As Object
C# public object GetPlayerContext(
int playerID
);
Managed C++ public: Object* GetPlayerContext(
int playerID
);
JScript .NET public function GetPlayerContext(
playerID : int
) : Object;

Parameters

playerID System.Int32.

Return Value

System.Object .


Server.GetSendQueueInformation(Int32,Int32,Int32,GetSendQueueInformationFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetSendQueueInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should slow the rate that messages are sent. Deprecated.

Definition

Visual Basic .NET Public Sub GetSendQueueInformation( _
ByVal dpnidPlayer As Integer, _
ByRef numberMessages As Integer, _
ByRef numberBytes As Integer, _
ByVal flags As GetSendQueueInformationFlags _
)
C# public void GetSendQueueInformation(
int dpnidPlayer,
out int numberMessages,
out int numberBytes,
GetSendQueueInformationFlags flags
);
Managed C++ public: void GetSendQueueInformation(
int dpnidPlayer,
int *numberMessages,
int *numberBytes,
GetSendQueueInformationFlags flags
);
JScript .NET public function GetSendQueueInformation(
dpnidPlayer : int,
numberMessages : int,
numberBytes : int,
flags : GetSendQueueInformationFlags
);

Parameters

dpnidPlayer | System.Int32.
numberMessages | System.Int32.
numberBytes | System.Int32.
flags | Microsoft.DirectX.DirectPlay.GetSendQueueInformationFlags.


Server.GetServiceProviders

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Overload List

public ServiceProviderInformation[] GetServiceProviders(bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, Guid, bool);


Server.GetServiceProviders(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
getAll : boolean
) : ServiceProviderInformation[];

Parameters

getAll System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Server.GetServiceProviders(Guid,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
Guid guidServiceProvider,
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
guidServiceProvider : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider | System.Guid.
getAll | System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Server.GetServiceProviders(Guid,Guid,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetServiceProviders Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic .NET Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal guidApplication As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
Managed C++ public: ServiceProviderInformation GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
) __gc[];
JScript .NET public function GetServiceProviders(
guidServiceProvider : Guid,
guidApplication : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider | System.Guid.
guidApplication | System.Guid.
getAll | System.Boolean.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[].


Server.GetSPCaps(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GetSPCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.

Definition

Visual Basic .NET Public Function GetSPCaps( _
ByVal guidServiceProvider As Guid _
) As ServiceProviderCaps
C# public ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
Managed C++ public: ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
JScript .NET public function GetSPCaps(
guidServiceProvider : Guid
) : ServiceProviderCaps;

Parameters

guidServiceProvider System.Guid.

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderCaps .


Server.Host

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Overload List

public void Host(ApplicationDescription, Address);
public void Host(ApplicationDescription, Address, HostFlags);
public void Host(ApplicationDescription, Address, object);
public void Host(ApplicationDescription, Address, object, HostFlags);
public void Host(ApplicationDescription, Address[]);
public void Host(ApplicationDescription, Address[], HostFlags);
public void Host(ApplicationDescription, Address[], object);
public void Host(ApplicationDescription, Address[], object, HostFlags);


Server.Host(ApplicationDescription,Address[],Object,HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[],
Object *playerContext,
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].
playerContext | System.Object.
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Server.Host(ApplicationDescription,Address,Object,HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress,
Object *playerContext,
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.
playerContext | System.Object.
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Server.Host(ApplicationDescription,Address[],HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[],
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Server.Host(ApplicationDescription,Address,HostFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
HostFlags flags
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress,
HostFlags flags
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
flags : HostFlags
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.
flags | Microsoft.DirectX.DirectPlay.HostFlags.


Server.Host(ApplicationDescription,Address[],Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[],
Object *playerContext
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].
playerContext | System.Object.


Server.Host(ApplicationDescription,Address,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress,
Object *playerContext
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.
playerContext | System.Object.


Server.Host(ApplicationDescription,Address[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress __gc[]
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[]
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address[].


Server.Host(ApplicationDescription,Address)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Host Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic .NET Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress
);
Managed C++ public: void Host(
ApplicationDescription applicationDescription,
Address *deviceAddress
);
JScript .NET public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address
);

Parameters

applicationDescription | Microsoft.DirectX.DirectPlay.ApplicationDescription.
deviceAddress | Microsoft.DirectX.DirectPlay.Address.


Server.op_Equality(Server,Server)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Equality(
Server left,
Server right
);
Managed C++ public: static bool op_Equality(
Server *left,
Server *right
);
JScript .NET public static function op_Equality(
left : Server,
right : Server
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Server. The Server structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Server. The Server structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Server.op_Inequality(Server,Server)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Inequality(
Server left,
Server right
);
Managed C++ public: static bool op_Inequality(
Server *left,
Server *right
);
JScript .NET public static function op_Inequality(
left : Server,
right : Server
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.Server. The Server structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.Server. The Server structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Server.raise_ApplicationDescriptionChanged(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_ApplicationDescriptionChanged Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ApplicationDescriptionChanged( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_ApplicationDescriptionChanged(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_ApplicationDescriptionChanged(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_ApplicationDescriptionChanged(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


Server.raise_AsyncOperationComplete(Object,AsyncOperationCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_AsyncOperationComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_AsyncOperationComplete( _
ByVal i1 As Object, _
ByVal i2 As AsyncOperationCompleteEventArgs _
)
C# protected void raise_AsyncOperationComplete(
object i1,
AsyncOperationCompleteEventArgs i2
);
Managed C++ protected: void raise_AsyncOperationComplete(
Object *i1,
AsyncOperationCompleteEventArgs *i2
);
JScript .NET protected function raise_AsyncOperationComplete(
i1 : Object,
i2 : AsyncOperationCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs.


Server.raise_ClientInformation(Object,ClientInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_ClientInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ClientInformation( _
ByVal i1 As Object, _
ByVal i2 As ClientInformationEventArgs _
)
C# protected void raise_ClientInformation(
object i1,
ClientInformationEventArgs i2
);
Managed C++ protected: void raise_ClientInformation(
Object *i1,
ClientInformationEventArgs *i2
);
JScript .NET protected function raise_ClientInformation(
i1 : Object,
i2 : ClientInformationEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ClientInformationEventArgs.


Server.raise_FindHostQuery(Object,FindHostQueryEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_FindHostQuery Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_FindHostQuery( _
ByVal i1 As Object, _
ByVal i2 As FindHostQueryEventArgs _
)
C# protected void raise_FindHostQuery(
object i1,
FindHostQueryEventArgs i2
);
Managed C++ protected: void raise_FindHostQuery(
Object *i1,
FindHostQueryEventArgs *i2
);
JScript .NET protected function raise_FindHostQuery(
i1 : Object,
i2 : FindHostQueryEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.FindHostQueryEventArgs.


Server.raise_GroupCreated(Object,GroupCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_GroupCreated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_GroupCreated( _
ByVal i1 As Object, _
ByVal i2 As GroupCreatedEventArgs _
)
C# protected void raise_GroupCreated(
object i1,
GroupCreatedEventArgs i2
);
Managed C++ protected: void raise_GroupCreated(
Object *i1,
GroupCreatedEventArgs *i2
);
JScript .NET protected function raise_GroupCreated(
i1 : Object,
i2 : GroupCreatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.GroupCreatedEventArgs.


Server.raise_GroupDestroyed(Object,GroupDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_GroupDestroyed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_GroupDestroyed( _
ByVal i1 As Object, _
ByVal i2 As GroupDestroyedEventArgs _
)
C# protected void raise_GroupDestroyed(
object i1,
GroupDestroyedEventArgs i2
);
Managed C++ protected: void raise_GroupDestroyed(
Object *i1,
GroupDestroyedEventArgs *i2
);
JScript .NET protected function raise_GroupDestroyed(
i1 : Object,
i2 : GroupDestroyedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.GroupDestroyedEventArgs.


Server.raise_GroupInformation(Object,GroupInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_GroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_GroupInformation( _
ByVal i1 As Object, _
ByVal i2 As GroupInformationEventArgs _
)
C# protected void raise_GroupInformation(
object i1,
GroupInformationEventArgs i2
);
Managed C++ protected: void raise_GroupInformation(
Object *i1,
GroupInformationEventArgs *i2
);
JScript .NET protected function raise_GroupInformation(
i1 : Object,
i2 : GroupInformationEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.GroupInformationEventArgs.


Server.raise_IndicateConnect(Object,IndicateConnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_IndicateConnect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_IndicateConnect( _
ByVal i1 As Object, _
ByVal i2 As IndicateConnectEventArgs _
)
C# protected void raise_IndicateConnect(
object i1,
IndicateConnectEventArgs i2
);
Managed C++ protected: void raise_IndicateConnect(
Object *i1,
IndicateConnectEventArgs *i2
);
JScript .NET protected function raise_IndicateConnect(
i1 : Object,
i2 : IndicateConnectEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.IndicateConnectEventArgs.


Server.raise_IndicatedConnectAborted(Object,IndicatedConnectAbortedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_IndicatedConnectAborted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_IndicatedConnectAborted( _
ByVal i1 As Object, _
ByVal i2 As IndicatedConnectAbortedEventArgs _
)
C# protected void raise_IndicatedConnectAborted(
object i1,
IndicatedConnectAbortedEventArgs i2
);
Managed C++ protected: void raise_IndicatedConnectAborted(
Object *i1,
IndicatedConnectAbortedEventArgs *i2
);
JScript .NET protected function raise_IndicatedConnectAborted(
i1 : Object,
i2 : IndicatedConnectAbortedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedEventArgs.


Server.raise_PlayerAddedToGroup(Object,PlayerAddedToGroupEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_PlayerAddedToGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerAddedToGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerAddedToGroupEventArgs _
)
C# protected void raise_PlayerAddedToGroup(
object i1,
PlayerAddedToGroupEventArgs i2
);
Managed C++ protected: void raise_PlayerAddedToGroup(
Object *i1,
PlayerAddedToGroupEventArgs *i2
);
JScript .NET protected function raise_PlayerAddedToGroup(
i1 : Object,
i2 : PlayerAddedToGroupEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerAddedToGroupEventArgs.


Server.raise_PlayerCreated(Object,PlayerCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_PlayerCreated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As PlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
PlayerCreatedEventArgs i2
);
Managed C++ protected: void raise_PlayerCreated(
Object *i1,
PlayerCreatedEventArgs *i2
);
JScript .NET protected function raise_PlayerCreated(
i1 : Object,
i2 : PlayerCreatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerCreatedEventArgs.


Server.raise_PlayerDestroyed(Object,PlayerDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_PlayerDestroyed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerDestroyed( _
ByVal i1 As Object, _
ByVal i2 As PlayerDestroyedEventArgs _
)
C# protected void raise_PlayerDestroyed(
object i1,
PlayerDestroyedEventArgs i2
);
Managed C++ protected: void raise_PlayerDestroyed(
Object *i1,
PlayerDestroyedEventArgs *i2
);
JScript .NET protected function raise_PlayerDestroyed(
i1 : Object,
i2 : PlayerDestroyedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerDestroyedEventArgs.


Server.raise_PlayerRemovedFromGroup(Object,PlayerRemovedFromGroupEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_PlayerRemovedFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_PlayerRemovedFromGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerRemovedFromGroupEventArgs _
)
C# protected void raise_PlayerRemovedFromGroup(
object i1,
PlayerRemovedFromGroupEventArgs i2
);
Managed C++ protected: void raise_PlayerRemovedFromGroup(
Object *i1,
PlayerRemovedFromGroupEventArgs *i2
);
JScript .NET protected function raise_PlayerRemovedFromGroup(
i1 : Object,
i2 : PlayerRemovedFromGroupEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.PlayerRemovedFromGroupEventArgs.


Server.raise_Receive(Object,ReceiveEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_Receive Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
Managed C++ protected: void raise_Receive(
Object *i1,
ReceiveEventArgs *i2
);
JScript .NET protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ReceiveEventArgs.


Server.raise_SendComplete(Object,SendCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_SendComplete Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_SendComplete( _
ByVal i1 As Object, _
ByVal i2 As SendCompleteEventArgs _
)
C# protected void raise_SendComplete(
object i1,
SendCompleteEventArgs i2
);
Managed C++ protected: void raise_SendComplete(
Object *i1,
SendCompleteEventArgs *i2
);
JScript .NET protected function raise_SendComplete(
i1 : Object,
i2 : SendCompleteEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.SendCompleteEventArgs.


Server.raise_ServerInformation(Object,ServerInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.raise_ServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ServerInformation( _
ByVal i1 As Object, _
ByVal i2 As ServerInformationEventArgs _
)
C# protected void raise_ServerInformation(
object i1,
ServerInformationEventArgs i2
);
Managed C++ protected: void raise_ServerInformation(
Object *i1,
ServerInformationEventArgs *i2
);
JScript .NET protected function raise_ServerInformation(
i1 : Object,
i2 : ServerInformationEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ServerInformationEventArgs.


Server.RegisterLobby(Int32,Application)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.RegisterLobby Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Public Sub RegisterLobby( _
ByVal handle As Integer, _
ByVal lobbiedApplication As Application _
)
C# public void RegisterLobby(
int handle,
Application lobbiedApplication
);
Managed C++ public: void RegisterLobby(
int handle,
Application *lobbiedApplication
);
JScript .NET public function RegisterLobby(
handle : int,
lobbiedApplication : Application
);

Parameters

handle | System.Int32.
lobbiedApplication | Microsoft.DirectX.DirectPlay.Lobby.Application.


Server.RemovePlayerFromGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Overload List

public void RemovePlayerFromGroup(int, int, out int, SyncFlags);
public void RemovePlayerFromGroup(int, int, out int, SyncFlags, object);
public void RemovePlayerFromGroup(int, int, SyncFlags);
public void RemovePlayerFromGroup(int, int, SyncFlags, object);


Server.RemovePlayerFromGroup(Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.RemovePlayerFromGroup(Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.RemovePlayerFromGroup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic .NET Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void RemovePlayerFromGroup(
int groupID,
int clientID,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
clientID | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.SendTo

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Overload List

public void SendTo(int, GCHandle, int, int, out int, SendFlags);
public void SendTo(int, GCHandle, int, int, out int, SendFlags, object);
public void SendTo(int, GCHandle, int, int, SendFlags);
public void SendTo(int, GCHandle, int, int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, out int, SendFlags);
public void SendTo(int, NetworkPacket, int, out int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, SendFlags);
public void SendTo(int, NetworkPacket, int, SendFlags, object);


Server.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
int *asyncHandle,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Server.SendTo(Int32,GCHandle,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Server.SendTo(Int32,GCHandle,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Server.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
int *asyncHandle,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
gcbuffer | System.Runtime.InteropServices.GCHandle.
bufferSize | System.Int32.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Server.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
int *asyncHandle,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Server.SendTo(Int32,NetworkPacket,Int32,SendFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags,
object context
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
SendFlags flags,
Object *context
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.
context | System.Object.


Server.SendTo(Int32,NetworkPacket,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Server.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendTo Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic .NET Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags
);
Managed C++ public: void SendTo(
int playerID,
NetworkPacket *sendData,
int timeOut,
int *asyncHandle,
SendFlags flags
);
JScript .NET public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID | System.Int32.
sendData | Microsoft.DirectX.DirectPlay.NetworkPacket.
timeOut | System.Int32.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SendFlags.


Server.Server

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Server Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Server();
public Server(InitializeFlags);


Server.Server(InitializeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Server Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Server(
InitializeFlags flags
);
Managed C++ public: Server(
InitializeFlags flags
);
JScript .NET public function Server(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags.


Server.Server()

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Server Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public Server();
Managed C++ | public: Server();
JScript .NET | public function Server();


Server.SetGroupInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Overload List

public void SetGroupInformation(int, GroupInformation, out int, SyncFlags);
public void SetGroupInformation(int, GroupInformation, out int, SyncFlags, object);
public void SetGroupInformation(int, GroupInformation, SyncFlags);
public void SetGroupInformation(int, GroupInformation, SyncFlags, object);


Server.SetGroupInformation(Int32,GroupInformation,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.SetGroupInformation(Int32,GroupInformation,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetGroupInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID | System.Int32.
groupInformation | Microsoft.DirectX.DirectPlay.GroupInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.SetServerInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Overload List

public void SetServerInformation(PlayerInformation, out int, SyncFlags);
public void SetServerInformation(PlayerInformation, out int, SyncFlags, object);
public void SetServerInformation(PlayerInformation, SyncFlags);
public void SetServerInformation(PlayerInformation, SyncFlags, object);


Server.SetServerInformation(PlayerInformation,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
Managed C++ public: void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
JScript .NET public function SetServerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.SetServerInformation(PlayerInformation,Int32,SyncFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags
);
Managed C++ public: void SetServerInformation(
PlayerInformation playerInformation,
int *asyncHandle,
SyncFlags flags
);
JScript .NET public function SetServerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.


Server.SetServerInformation(PlayerInformation,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetServerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.SetServerInformation(PlayerInformation,Int32,SyncFlags,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetServerInformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic .NET Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
Managed C++ public: void SetServerInformation(
PlayerInformation playerInformation,
int *asyncHandle,
SyncFlags flags,
Object *asyncContext
);
JScript .NET public function SetServerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation | Microsoft.DirectX.DirectPlay.PlayerInformation.
asyncHandle | System.Int32.
flags | Microsoft.DirectX.DirectPlay.SyncFlags.
asyncContext | System.Object.


Server.SetSPCaps(Guid,ServiceProviderCaps)

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SetSPCaps Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the structure for the specified service provider. Deprecated.

Definition

Visual Basic .NET Public Sub SetSPCaps( _
ByVal guidServiceProvider As Guid, _
ByVal value As ServiceProviderCaps _
)
C# public void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
Managed C++ public: void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
JScript .NET public function SetSPCaps(
guidServiceProvider : Guid,
value : ServiceProviderCaps
);

Parameters

guidServiceProvider | System.Guid.
value | Microsoft.DirectX.DirectPlay.ServiceProviderCaps.


Server.UnregisterLobby()

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.UnregisterLobby Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Sub UnregisterLobby()
C# | public void UnregisterLobby();
Managed C++ | public: void UnregisterLobby();
JScript .NET | public function UnregisterLobby();


Server.ApplicationDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.ApplicationDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.

Definition

Visual Basic .NET | Public Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; set; }
Managed C++ public: __property ApplicationDescription get_ApplicationDescription();
public: __property void set_ApplicationDescription(ApplicationDescription);
JScript .NET public function get ApplicationDescription() : ApplicationDescription
public function set ApplicationDescription(ApplicationDescription);

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription .

This property is read/write.


Server.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Server object. Deprecated.

Definition

Visual Basic .NET | Public Property Caps As Caps
C# | public Caps Caps { get; set; }
Managed C++ public: __property Caps get_Caps();
public: __property void set_Caps(Caps);
JScript .NET public function get Caps() : Caps
public function set Caps(Caps);

Property Value

Microsoft.DirectX.DirectPlay.Caps .

This property is read/write.


Server.GroupMembers

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GroupMembers Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupMembers As GroupMembersList
C# | public GroupMembersList GroupMembers { get; }
Managed C++ | public: __property GroupMembersList* get_GroupMembers();
JScript .NET | public function get GroupMembers() : GroupMembersList

Property Value

Microsoft.DirectX.DirectPlay.GroupMembersList .

This property is read-only.


Server.Groups

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Groups Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Groups As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Groups { get; }
Managed C++ | public: __property PlayersGroupsEnumerator* get_Groups();
JScript .NET | public function get Groups() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator .

This property is read-only.


Server.Players

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Players Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the application. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Players As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Players { get; }
Managed C++ | public: __property PlayersGroupsEnumerator* get_Players();
JScript .NET | public function get Players() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator .

This property is read-only.


Server.ApplicationDescriptionChanged

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.ApplicationDescriptionChanged Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.

Definition

Visual Basic .NET | Public Event ApplicationDescriptionChanged As ApplicationDescriptionEventHandler
C# | public event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
Managed C++ | public: __event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.AsyncOperationComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.AsyncOperationComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.

Definition

Visual Basic .NET | Public Event AsyncOperationComplete As AsyncOperationCompleteEventHandler
C# | public event AsyncOperationCompleteEventHandler AsyncOperationComplete;
Managed C++ | public: __event AsyncOperationCompleteEventHandler AsyncOperationComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.ClientInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.ClientInformation Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.

Definition

Visual Basic .NET | Public Event ClientInformation As ClientInformationEventHandler
C# | public event ClientInformationEventHandler ClientInformation;
Managed C++ | public: __event ClientInformationEventHandler ClientInformation;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.FindHostQuery

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.FindHostQuery Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.

Definition

Visual Basic .NET | Public Event FindHostQuery As FindHostQueryEventHandler
C# | public event FindHostQueryEventHandler FindHostQuery;
Managed C++ | public: __event FindHostQueryEventHandler FindHostQuery;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.GroupCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GroupCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.

Definition

Visual Basic .NET | Public Event GroupCreated As GroupCreatedEventHandler
C# | public event GroupCreatedEventHandler GroupCreated;
Managed C++ | public: __event GroupCreatedEventHandler GroupCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.GroupDestroyed

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GroupDestroyed Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.

Definition

Visual Basic .NET | Public Event GroupDestroyed As GroupDestroyedEventHandler
C# | public event GroupDestroyedEventHandler GroupDestroyed;
Managed C++ | public: __event GroupDestroyedEventHandler GroupDestroyed;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.GroupInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.GroupInformation Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic .NET | Public Event GroupInformation As GroupInformationEventHandler
C# | public event GroupInformationEventHandler GroupInformation;
Managed C++ | public: __event GroupInformationEventHandler GroupInformation;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.IndicateConnect

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.IndicateConnect Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.

Definition

Visual Basic .NET | Public Event IndicateConnect As IndicateConnectEventHandler
C# | public event IndicateConnectEventHandler IndicateConnect;
Managed C++ | public: __event IndicateConnectEventHandler IndicateConnect;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.IndicatedConnectAborted

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.IndicatedConnectAborted Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.

Definition

Visual Basic .NET | Public Event IndicatedConnectAborted As IndicatedConnectAbortedEventHandler
C# | public event IndicatedConnectAbortedEventHandler IndicatedConnectAborted;
Managed C++ | public: __event IndicatedConnectAbortedEventHandler IndicatedConnectAborted;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.PlayerAddedToGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.PlayerAddedToGroup Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerAddedToGroup As PlayerAddedToGroupEventHandler
C# | public event PlayerAddedToGroupEventHandler PlayerAddedToGroup;
Managed C++ | public: __event PlayerAddedToGroupEventHandler PlayerAddedToGroup;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.PlayerCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.PlayerCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerCreated As PlayerCreatedEventHandler
C# | public event PlayerCreatedEventHandler PlayerCreated;
Managed C++ | public: __event PlayerCreatedEventHandler PlayerCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.PlayerDestroyed

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.PlayerDestroyed Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerDestroyed As PlayerDestroyedEventHandler
C# | public event PlayerDestroyedEventHandler PlayerDestroyed;
Managed C++ | public: __event PlayerDestroyedEventHandler PlayerDestroyed;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.PlayerRemovedFromGroup

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.PlayerRemovedFromGroup Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.

Definition

Visual Basic .NET | Public Event PlayerRemovedFromGroup As PlayerRemovedFromGroupEventHandler
C# | public event PlayerRemovedFromGroupEventHandler PlayerRemovedFromGroup;
Managed C++ | public: __event PlayerRemovedFromGroupEventHandler PlayerRemovedFromGroup;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.Receive

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.Receive Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the server object receives data. Deprecated.

Definition

Visual Basic .NET | Public Event Receive As ReceiveEventHandler
C# | public event ReceiveEventHandler Receive;
Managed C++ | public: __event ReceiveEventHandler Receive;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.SendComplete

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.SendComplete Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.

Definition

Visual Basic .NET | Public Event SendComplete As SendCompleteEventHandler
C# | public event SendCompleteEventHandler SendComplete;
Managed C++ | public: __event SendCompleteEventHandler SendComplete;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Server.ServerInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

Server.ServerInformation Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic .NET | Public Event ServerInformation As ServerInformationEventHandler
C# | public event ServerInformationEventHandler ServerInformation;
Managed C++ | public: __event ServerInformationEventHandler ServerInformation;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.ServerInformationEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ServerInformationEventArgs
Inherits EventArgs
C# | public sealed class ServerInformationEventArgs : EventArgs
Managed C++ | public __gc __sealed class ServerInformationEventArgs : public EventArgs
JScript .NET | public class ServerInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ServerInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ServerInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ServerInformationEventArgs.ServerInformationEventArgs(ServerInformationMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationEventArgs.ServerInformationEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As ServerInformationMessage _
)
C# public ServerInformationEventArgs(
ServerInformationMessage dpMessage
);
Managed C++ public: ServerInformationEventArgs(
ServerInformationMessage dpMessage
);
JScript .NET public function ServerInformationEventArgs(
dpMessage : ServerInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ServerInformationMessage.


ServerInformationEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As ServerInformationMessage
C# | public ServerInformationMessage Message;
Managed C++ | public: ServerInformationMessage Message;
JScript .NET | public var Message : ServerInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.ServerInformationMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.SessionFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFullException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The request to connect to the host or server failed because the maximum number of players allotted for the session has been reached. Deprecated.

Definition

Visual Basic .NET Public Class SessionFullException
Inherits DirectPlayException
C# | public class SessionFullException : DirectPlayException
Managed C++ | public __gc class SessionFullException : public DirectPlayException
JScript .NET | public class SessionFullException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SessionFullException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
SessionFullException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionFullException.SessionFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFullException.SessionFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SessionFullException();
protected SessionFullException(SerializationInfo, StreamingContext);
public SessionFullException(string);
public SessionFullException(string, Exception);


SessionFullException.SessionFullException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFullException.SessionFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SessionFullException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SessionFullException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SessionFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


SessionFullException.SessionFullException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFullException.SessionFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SessionFullException(
string message,
Exception inner
);
Managed C++ public: SessionFullException(
String *message,
Exception *inner
);
JScript .NET public function SessionFullException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


SessionFullException.SessionFullException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFullException.SessionFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SessionFullException(
string message
);
Managed C++ public: SessionFullException(
String *message
);
JScript .NET public function SessionFullException(
message : String
);

Parameters

message System.String.


SessionFullException.SessionFullException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFullException.SessionFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SessionFullException();
Managed C++ | public: SessionFullException();
JScript .NET | public function SessionFullException();


Microsoft.DirectX.DirectPlay.SessionTerminatedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionTerminatedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SessionTerminated event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class SessionTerminatedEventArgs
Inherits EventArgs
C# | public sealed class SessionTerminatedEventArgs : EventArgs
Managed C++ | public __gc __sealed class SessionTerminatedEventArgs : public EventArgs
JScript .NET | public class SessionTerminatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SessionTerminatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SessionTerminatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionTerminatedEventArgs.SessionTerminatedEventArgs(TerminateSessionMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionTerminatedEventArgs.SessionTerminatedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As TerminateSessionMessage _
)
C# public SessionTerminatedEventArgs(
TerminateSessionMessage dpMessage
);
Managed C++ public: SessionTerminatedEventArgs(
TerminateSessionMessage dpMessage
);
JScript .NET public function SessionTerminatedEventArgs(
dpMessage : TerminateSessionMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.TerminateSessionMessage.


SessionTerminatedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionTerminatedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As TerminateSessionMessage
C# | public TerminateSessionMessage Message;
Managed C++ | public: TerminateSessionMessage Message;
JScript .NET | public var Message : TerminateSessionMessage

Field Value

Microsoft.DirectX.DirectPlay.TerminateSessionMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.TableFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

TableFullException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The table is full. Deprecated.

Definition

Visual Basic .NET Public Class TableFullException
Inherits DirectPlayException
C# | public class TableFullException : DirectPlayException
Managed C++ | public __gc class TableFullException : public DirectPlayException
JScript .NET | public class TableFullException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TableFullException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
TableFullException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TableFullException.TableFullException

Microsoft DirectX 9.0 SDK Update (October 2004)

TableFullException.TableFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TableFullException();
protected TableFullException(SerializationInfo, StreamingContext);
public TableFullException(string);
public TableFullException(string, Exception);


TableFullException.TableFullException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

TableFullException.TableFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TableFullException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: TableFullException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function TableFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo.
context | System.Runtime.Serialization.StreamingContext.


TableFullException.TableFullException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

TableFullException.TableFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TableFullException(
string message,
Exception inner
);
Managed C++ public: TableFullException(
String *message,
Exception *inner
);
JScript .NET public function TableFullException(
message : String,
inner : Exception
);

Parameters

message | System.String.
inner | System.Exception.


TableFullException.TableFullException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

TableFullException.TableFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public TableFullException(
string message
);
Managed C++ public: TableFullException(
String *message
);
JScript .NET public function TableFullException(
message : String
);

Parameters

message System.String.


TableFullException.TableFullException()

Microsoft DirectX 9.0 SDK Update (October 2004)

TableFullException.TableFullException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TableFullException();
Managed C++ | public: TableFullException();
JScript .NET | public function TableFullException();


Microsoft.DirectX.DirectPlay.ThreadCreatedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadCreatedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadCreated event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ThreadCreatedEventArgs
Inherits EventArgs
C# | public sealed class ThreadCreatedEventArgs : EventArgs
Managed C++ | public __gc __sealed class ThreadCreatedEventArgs : public EventArgs
JScript .NET | public class ThreadCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ThreadCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ThreadCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ThreadCreatedEventArgs.ThreadCreatedEventArgs(CreateThreadMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadCreatedEventArgs.ThreadCreatedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As CreateThreadMessage _
)
C# public ThreadCreatedEventArgs(
CreateThreadMessage dpMessage
);
Managed C++ public: ThreadCreatedEventArgs(
CreateThreadMessage dpMessage
);
JScript .NET public function ThreadCreatedEventArgs(
dpMessage : CreateThreadMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.CreateThreadMessage.


ThreadCreatedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadCreatedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As CreateThreadMessage
C# | public CreateThreadMessage Message;
Managed C++ | public: CreateThreadMessage Message;
JScript .NET | public var Message : CreateThreadMessage

Field Value

Microsoft.DirectX.DirectPlay.CreateThreadMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.ThreadDestroyedEventArgs

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadDestroyedEventArgs Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadDestroyed event. Deprecated.

Definition

Visual Basic .NET NotInheritable Public Class ThreadDestroyedEventArgs
Inherits EventArgs
C# | public sealed class ThreadDestroyedEventArgs : EventArgs
Managed C++ | public __gc __sealed class ThreadDestroyedEventArgs : public EventArgs
JScript .NET | public class ThreadDestroyedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ThreadDestroyedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ThreadDestroyedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ThreadDestroyedEventArgs.ThreadDestroyedEventArgs(DestroyThreadMessage)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadDestroyedEventArgs.ThreadDestroyedEventArgs Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal dpMessage As DestroyThreadMessage _
)
C# public ThreadDestroyedEventArgs(
DestroyThreadMessage dpMessage
);
Managed C++ public: ThreadDestroyedEventArgs(
DestroyThreadMessage dpMessage
);
JScript .NET public function ThreadDestroyedEventArgs(
dpMessage : DestroyThreadMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.DestroyThreadMessage.


ThreadDestroyedEventArgs.Message

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadDestroyedEventArgs.Message Field

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This field is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Message As DestroyThreadMessage
C# | public DestroyThreadMessage Message;
Managed C++ | public: DestroyThreadMessage Message;
JScript .NET | public var Message : DestroyThreadMessage

Field Value

Microsoft.DirectX.DirectPlay.DestroyThreadMessage .

This field is read/write.


Microsoft.DirectX.DirectPlay.ThreadPool

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the ThreadPool object to manage threads in a Microsoft® DirectPlay® application Deprecated.

Definition

Visual Basic .NET Public Class ThreadPool
Inherits MarshalByRefObject
Implements IDisposable
C# public class ThreadPool : MarshalByRefObject,
IDisposable
Managed C++ public __gc class ThreadPool : public MarshalByRefObject,
IDisposable
JScript .NET public class ThreadPool extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
ThreadCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been created. Deprecated.
ThreadDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been destroyed. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
DoWork
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs work that is currently scheduled. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetThreadCount
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of threads for the specified processor or all processors. Deprecated.
static (Shared in Visual Basic .NET) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic .NET) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ThreadCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ThreadDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetThreadCount
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the number of threads for a specified processor or all processors. Deprecated.
ThreadPool
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ThreadPool

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ThreadPool.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • ThreadPool.Disposed
  • ThreadPool.Disposing


ThreadPool.DoWork(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.DoWork Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs work that is currently scheduled. Deprecated.

Definition

Visual Basic .NET Public Sub DoWork( _
ByVal allowedTimeSlice As Integer _
)
C# public void DoWork(
int allowedTimeSlice
);
Managed C++ public: void DoWork(
int allowedTimeSlice
);
JScript .NET public function DoWork(
allowedTimeSlice : int
);

Parameters

allowedTimeSlice System.Int32.


ThreadPool.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


ThreadPool.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ThreadPool();
Managed C++ | ~ThreadPool();
JScript .NET | protected override function Finalize();


ThreadPool.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


ThreadPool.GetThreadCount(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.GetThreadCount Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of threads for the specified processor or all processors. Deprecated.

Definition

Visual Basic .NET Public Function GetThreadCount( _
ByVal processorNumber As Integer _
) As Integer
C# public int GetThreadCount(
int processorNumber
);
Managed C++ public: int GetThreadCount(
int processorNumber
);
JScript .NET public function GetThreadCount(
processorNumber : int
) : int;

Parameters

processorNumber System.Int32.

Return Value

System.Int32 .


ThreadPool.op_Equality(ThreadPool,ThreadPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As ThreadPool, _
ByVal right As ThreadPool _
) As Boolean
C# public static bool op_Equality(
ThreadPool left,
ThreadPool right
);
Managed C++ public: static bool op_Equality(
ThreadPool *left,
ThreadPool *right
);
JScript .NET public static function op_Equality(
left : ThreadPool,
right : ThreadPool
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.ThreadPool. The ThreadPool structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.ThreadPool. The ThreadPool structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


ThreadPool.op_Inequality(ThreadPool,ThreadPool)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As ThreadPool, _
ByVal right As ThreadPool _
) As Boolean
C# public static bool op_Inequality(
ThreadPool left,
ThreadPool right
);
Managed C++ public: static bool op_Inequality(
ThreadPool *left,
ThreadPool *right
);
JScript .NET public static function op_Inequality(
left : ThreadPool,
right : ThreadPool
) : boolean;

Parameters

left | Microsoft.DirectX.DirectPlay.ThreadPool. The ThreadPool structure to the left of the equality operator.
right | Microsoft.DirectX.DirectPlay.ThreadPool. The ThreadPool structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


ThreadPool.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object.
i2 | System.EventArgs.


ThreadPool.raise_ThreadCreated(Object,ThreadCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.raise_ThreadCreated Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ThreadCreated( _
ByVal i1 As Object, _
ByVal i2 As ThreadCreatedEventArgs _
)
C# protected void raise_ThreadCreated(
object i1,
ThreadCreatedEventArgs i2
);
Managed C++ protected: void raise_ThreadCreated(
Object *i1,
ThreadCreatedEventArgs *i2
);
JScript .NET protected function raise_ThreadCreated(
i1 : Object,
i2 : ThreadCreatedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ThreadCreatedEventArgs.


ThreadPool.raise_ThreadDestroyed(Object,ThreadDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.raise_ThreadDestroyed Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET Protected Sub raise_ThreadDestroyed( _
ByVal i1 As Object, _
ByVal i2 As ThreadDestroyedEventArgs _
)
C# protected void raise_ThreadDestroyed(
object i1,
ThreadDestroyedEventArgs i2
);
Managed C++ protected: void raise_ThreadDestroyed(
Object *i1,
ThreadDestroyedEventArgs *i2
);
JScript .NET protected function raise_ThreadDestroyed(
i1 : Object,
i2 : ThreadDestroyedEventArgs
);

Parameters

i1 | System.Object.
i2 | Microsoft.DirectX.DirectPlay.ThreadDestroyedEventArgs.


ThreadPool.SetThreadCount(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.SetThreadCount Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the number of threads for a specified processor or all processors. Deprecated.

Definition

Visual Basic .NET Public Sub SetThreadCount( _
ByVal processorNumber As Integer, _
ByVal numThreads As Integer _
)
C# public void SetThreadCount(
int processorNumber,
int numThreads
);
Managed C++ public: void SetThreadCount(
int processorNumber,
int numThreads
);
JScript .NET public function SetThreadCount(
processorNumber : int,
numThreads : int
);

Parameters

processorNumber | System.Int32.
numThreads | System.Int32.


ThreadPool.ThreadPool

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.ThreadPool Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ThreadPool();
public ThreadPool(InitializeFlags);


ThreadPool.ThreadPool(InitializeFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.ThreadPool Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public ThreadPool(
InitializeFlags flags
);
Managed C++ public: ThreadPool(
InitializeFlags flags
);
JScript .NET public function ThreadPool(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags.


ThreadPool.ThreadPool()

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.ThreadPool Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ThreadPool();
Managed C++ | public: ThreadPool();
JScript .NET | public function ThreadPool();


ThreadPool.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


ThreadPool.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime. Deprecated.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a ThreadPool.Disposing event, use the following code.

threadPool.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


ThreadPool.ThreadCreated

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.ThreadCreated Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been created. Deprecated.

Definition

Visual Basic .NET | Public Event ThreadCreated As ThreadCreatedEventHandler
C# | public event ThreadCreatedEventHandler ThreadCreated;
Managed C++ | public: __event ThreadCreatedEventHandler ThreadCreated;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


ThreadPool.ThreadDestroyed

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadPool.ThreadDestroyed Event

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This event is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been destroyed. Deprecated.

Definition

Visual Basic .NET | Public Event ThreadDestroyed As ThreadDestroyedEventHandler
C# | public event ThreadDestroyedEventHandler ThreadDestroyed;
Managed C++ | public: __event ThreadDestroyedEventHandler ThreadDestroyed;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.


Microsoft.DirectX.DirectPlay.TimedOutException

Microsoft DirectX 9.0 SDK Update (October 2004)

TimedOutException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.

Definition

Visual Basic .NET Public Class TimedOutException
Inherits DirectPlayException
C# | public class TimedOutException : DirectPlayException
Managed C++ | public __gc class TimedOutException : public DirectPlayException
JScript .NET | public class TimedOutException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TimedOutException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
TimedOutException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectPlay.UserCancelException

Microsoft DirectX 9.0 SDK Update (October 2004)

UserCancelException Class

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This class is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.

Definition

Visual Basic .NET Public Class UserCancelException
Inherits DirectPlayException
C# | public class UserCancelException : DirectPlayException
Managed C++ | public __gc class UserCancelException : public DirectPlayException
JScript .NET | public class UserCancelException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UserCancelException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
UserCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CancelFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

CancelFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancel all asynchronous requests. Deprecated.

Definition

Visual Basic .NET | Public Enum CancelFlags
C# | public enum CancelFlags
Managed C++ | __value public enum CancelFlags
JScript .NET | public enum CancelFlags

Members

Member | Value | Description
PlayerSendsPriorityLow | -2147221504
PlayerSendsPriorityNormal | -2147352576
PlayerSendsPriorityHigh | -2147418112
PlayerSends | -2147483648
Send | 4 | Cancel an asynchronous
FindHosts | 2
Connect | 1 | Cancel an asynchronous
AllOperations | 32768

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.

Definition

Visual Basic .NET | Public Enum ConnectFlags
C# | public enum ConnectFlags
Managed C++ | __value public enum ConnectFlags
JScript .NET | public enum ConnectFlags

Members

Member | Value | Description
Sync | -2147483648 | Process the connection request synchronously. Setting this flag does not generate a
OkToQueryForAddressing | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DestroyGroupFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyGroupFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum DestroyGroupFlags
C# | public enum DestroyGroupFlags
Managed C++ | __value public enum DestroyGroupFlags
JScript .NET | public enum DestroyGroupFlags

Members

Member | Value | Description
SessionTerminated | 3
AutoDestinationructed | 2
Normal | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DestroyPlayerFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyPlayerFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum DestroyPlayerFlags
C# | public enum DestroyPlayerFlags
Managed C++ | __value public enum DestroyPlayerFlags
JScript .NET | public enum DestroyPlayerFlags

Members

Member | Value | Description
HostDestroyedPlayer | 4
SessionTerminated | 3
ConnectionLost | 2
Normal | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum FindHostsFlags
C# | public enum FindHostsFlags
Managed C++ | __value public enum FindHostsFlags
JScript .NET | public enum FindHostsFlags

Members

Member | Value | Description
Sync | -2147483648
NoBroadcastFallback | 2
OkToQueryForAddressing | 1
None | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GetSendQueueInformationFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

GetSendQueueInformationFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum GetSendQueueInformationFlags
C# | public enum GetSendQueueInformationFlags
Managed C++ | __value public enum GetSendQueueInformationFlags
JScript .NET | public enum GetSendQueueInformationFlags

Members

Member | Value | Description
PriorityLow | 4
PriorityHigh | 2
PriorityNormal | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum GroupFlags
C# | public enum GroupFlags
Managed C++ | __value public enum GroupFlags
JScript .NET | public enum GroupFlags

Members

Member | Value | Description
AutoDestinationruct | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HostFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

HostFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.

Definition

Visual Basic .NET | Public Enum HostFlags
C# | public enum HostFlags
Managed C++ | __value public enum HostFlags
JScript .NET | public enum HostFlags

Members

Member | Value | Description
OkToQueryForAddressing | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InitializeFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

InitializeFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.

Definition

Visual Basic .NET | Public Enum InitializeFlags
C# | public enum InitializeFlags
Managed C++ | __value public enum InitializeFlags
JScript .NET | public enum InitializeFlags

Members

Member | Value | Description
DisableLinkTuning | 4
LanSessionHint | 2
DisableParameterValidation | 1
None | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


LocalAddressFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

LocalAddressFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic .NET | Public Enum LocalAddressFlags
C# | public enum LocalAddressFlags
Managed C++ | __value public enum LocalAddressFlags
JScript .NET | public enum LocalAddressFlags

Members

Member | Value | Description
Combined | 1
None | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerID Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default system player id's. Deprecated.

Definition

Visual Basic .NET | Public Enum PlayerID
C# | public enum PlayerID
Managed C++ | __value public enum PlayerID
JScript .NET | public enum PlayerID

Members

Member | Value | Description
AllPlayers | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ResultCode

Microsoft DirectX 9.0 SDK Update (October 2004)

ResultCode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result codes that can be returned via events. Deprecated.

Definition

Visual Basic .NET | Public Enum ResultCode
C# | public enum ResultCode
Managed C++ | __value public enum ResultCode
JScript .NET | public enum ResultCode

Members

Member | Value | Description
ConnectionLost | -2146074272
UserCancel | -2146073008
TimedOut | -2146073040
SessionFull | -2146073072
PlayerNotReachable | -2146073200
PlayerNotInGroup | -2146073216
PlayerLost | -2146073232
PlayerAlreadyInGroup | -2146073248
NotReady | -2146073280
NotHost | -2146073296
NotAllowed | -2146073312
NoResponse | -2146073328
NoHostPlayer | -2146073456
NoConnection | -2146073472
HostTerminatedSession | -2146074000
HostRejectedConnection | -2146074016
DoesNotExist | -2146074240
CannotCreatePlayer | -2146074320
CannotCreateGroup | -2146074336
CannotCancel | -2146074352
Aborted | -2146074576
Success | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SendFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SendFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum SendFlags
C# | public enum SendFlags
Managed C++ | __value public enum SendFlags
JScript .NET | public enum SendFlags

Members

Member | Value | Description
Coalesce | 256
PriorityHigh | 128
PriorityLow | 64
NoLoopback | 32
NonSequential | 16
Guaranteed | 8
CompleteOnProcess | 4
NoComplete | 2
NoCopy | 1
Sync | -2147483648

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum SessionFlags
C# | public enum SessionFlags
Managed C++ | __value public enum SessionFlags
JScript .NET | public enum SessionFlags

Members

Member | Value | Description
FastSigned | 512
FullSigned | 1024
NoEnumerations | 256
RequirePassword | 128
NoDpnServer | 64
MigrateHost | 4
ClientServer | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SyncFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

SyncFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This enum is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic .NET | Public Enum SyncFlags
C# | public enum SyncFlags
Managed C++ | __value public enum SyncFlags
JScript .NET | public enum SyncFlags

Members

Member | Value | Description
PeerInformation | -2147483648
ServerInformation | -2147483648
ClientInformation | -2147483648
GroupInformation | -2147483648
OperationSynchronous | -2147483648
RemovePlayerFromGroup | -2147483648
AddPlayerToGroup | -2147483648
DestroyGroup | -2147483648
CreateGroup | -2147483648

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AddPlayerToGroupMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

AddPlayerToGroupMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidAddPlayerToGroupDplay message when a player has been added to a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidAddPlayerToGroupDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure AddPlayerToGroupMessage
C# | public struct AddPlayerToGroupMessage
Managed C++ | public __value struct AddPlayerToGroupMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
AddPlayerToGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group to add the player. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player added to the group. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AddPlayerToGroupMessage.AddPlayerToGroupMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

AddPlayerToGroupMessage.AddPlayerToGroupMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AddPlayerToGroupMessage();
Managed C++ | public: AddPlayerToGroupMessage();
JScript .NET | public function AddPlayerToGroupMessage();


AddPlayerToGroupMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

AddPlayerToGroupMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


AddPlayerToGroupMessage.GroupContext

Microsoft DirectX 9.0 SDK Update (October 2004)

AddPlayerToGroupMessage.GroupContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
Managed C++ | public: __property Object* get_GroupContext();
JScript .NET | public function get GroupContext() : Object

Property Value

System.Object .

This property is read-only.


AddPlayerToGroupMessage.GroupID

Microsoft DirectX 9.0 SDK Update (October 2004)

AddPlayerToGroupMessage.GroupID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group to add the player. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
Managed C++ | public: __property int get_GroupID();
JScript .NET | public function get GroupID() : int

Property Value

System.Int32 .

This property is read-only.


AddPlayerToGroupMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

AddPlayerToGroupMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


AddPlayerToGroupMessage.PlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

AddPlayerToGroupMessage.PlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player added to the group. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
Managed C++ | public: __property int get_PlayerID();
JScript .NET | public function get PlayerID() : int

Property Value

System.Int32 .

This property is read-only.


ApplicationDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the settings for a Microsoft® DirectPlay® application. Deprecated.

Definition

Visual Basic .NET | Public Structure ApplicationDescription
C# | public struct ApplicationDescription
Managed C++ | public __value struct ApplicationDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ApplicationDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
CurrentPlayers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD specifying the number of players currently connected to the session. This member is is set only by the Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, and Play8serverGetapplicationdescDplay methods. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags describing application behavior. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Application GUID. Deprecated.
GuidInstance
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID that is generated by Microsoft® DirectPlay® at startup . This member is an [out] parameter when calling Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, or Play8serverGetapplicationdescDplay. It is an optional [in] parameter when calling the Play8peerConnectDplay and Play8clientConnectDplay methods. It must be set to GUID_NULL when you call the Play8peerSetapplicationdescDplay or Play8serverSetapplicationdescDplay methods. You cannot obtain this GUID by calling the Play8serverHostDplay or Play8peerHostDplay methods. You must obtain the GUID by calling a GetApplicationDesc method. Deprecated.
MaxPlayers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD, specifying the maximum number of players allowed in the session. Set this member to 0 to specify an unlimited number of players. Deprecated.
Password
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the Unicode password that is required to connect to the session. This must be NULL if the DPNSESSION_REQUIREPASSWORD is not set in thedwFlags member. Deprecated.
SessionName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the name of the session. This member is set by the host or server only for informational purposes. A client cannot use this name to connect to a host or server. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ApplicationDescription.ApplicationDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.ApplicationDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ApplicationDescription();
Managed C++ | public: ApplicationDescription();
JScript .NET | public function ApplicationDescription();


ApplicationDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ApplicationDescription.CurrentPlayers

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.CurrentPlayers Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD specifying the number of players currently connected to the session. This member is is set only by the Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, and Play8serverGetapplicationdescDplay methods. Deprecated.

Definition

Visual Basic .NET | Public Property CurrentPlayers As Integer
C# | public int CurrentPlayers { get; set; }
Managed C++ public: __property int get_CurrentPlayers();
public: __property void set_CurrentPlayers(int);
JScript .NET public function get CurrentPlayers() : int
public function set CurrentPlayers(int);

Property Value

System.Int32 .

This property is read/write.


ApplicationDescription.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags describing application behavior. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As SessionFlags
C# | public SessionFlags Flags { get; set; }
Managed C++ public: __property SessionFlags get_Flags();
public: __property void set_Flags(SessionFlags);
JScript .NET public function get Flags() : SessionFlags
public function set Flags(SessionFlags);

Property Value

Microsoft.DirectX.DirectPlay.SessionFlags .

This property is read/write.


ApplicationDescription.GuidApplication

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.GuidApplication Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Application GUID. Deprecated.

Definition

Visual Basic .NET | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
Managed C++ public: __property Guid get_GuidApplication();
public: __property void set_GuidApplication(Guid);
JScript .NET public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid .

This property is read/write.


ApplicationDescription.GuidInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.GuidInstance Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID that is generated by Microsoft® DirectPlay® at startup . This member is an [out] parameter when calling Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, or Play8serverGetapplicationdescDplay. It is an optional [in] parameter when calling the Play8peerConnectDplay and Play8clientConnectDplay methods. It must be set to GUID_NULL when you call the Play8peerSetapplicationdescDplay or Play8serverSetapplicationdescDplay methods. You cannot obtain this GUID by calling the Play8serverHostDplay or Play8peerHostDplay methods. You must obtain the GUID by calling a GetApplicationDesc method. Deprecated.

Definition

Visual Basic .NET | Public Property GuidInstance As Guid
C# | public Guid GuidInstance { get; set; }
Managed C++ public: __property Guid get_GuidInstance();
public: __property void set_GuidInstance(Guid);
JScript .NET public function get GuidInstance() : Guid
public function set GuidInstance(Guid);

Property Value

System.Guid .

This property is read/write.


ApplicationDescription.MaxPlayers

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.MaxPlayers Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD, specifying the maximum number of players allowed in the session. Set this member to 0 to specify an unlimited number of players. Deprecated.

Definition

Visual Basic .NET | Public Property MaxPlayers As Integer
C# | public int MaxPlayers { get; set; }
Managed C++ public: __property int get_MaxPlayers();
public: __property void set_MaxPlayers(int);
JScript .NET public function get MaxPlayers() : int
public function set MaxPlayers(int);

Property Value

System.Int32 .

This property is read/write.


ApplicationDescription.Password

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.Password Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the Unicode password that is required to connect to the session. This must be NULL if the DPNSESSION_REQUIREPASSWORD is not set in thedwFlags member. Deprecated.

Definition

Visual Basic .NET | Public Property Password As String
C# | public string Password { get; set; }
Managed C++ public: __property String* get_Password();
public: __property void set_Password(String*);
JScript .NET public function get Password() : String
public function set Password(String);

Property Value

System.String .

This property is read/write.


ApplicationDescription.SessionName

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescription.SessionName Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the name of the session. This member is set by the host or server only for informational purposes. A client cannot use this name to connect to a host or server. Deprecated.

Definition

Visual Basic .NET | Public Property SessionName As String
C# | public string SessionName { get; set; }
Managed C++ public: __property String* get_SessionName();
public: __property void set_SessionName(String*);
JScript .NET public function get SessionName() : String
public function set SessionName(String);

Property Value

System.String .

This property is read/write.


AsyncOperationCompleteMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the AsyncOperationComplete event. Deprecated.

Definition

Visual Basic .NET | Public Structure AsyncOperationCompleteMessage
C# | public struct AsyncOperationCompleteMessage
Managed C++ | public __value struct AsyncOperationCompleteMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
AsyncOperationCompleteMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AsyncOperationHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the asynchronous operation. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supplied user context. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AsyncOperationCompleteMessage.AsyncOperationCompleteMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteMessage.AsyncOperationCompleteMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public AsyncOperationCompleteMessage();
Managed C++ | public: AsyncOperationCompleteMessage();
JScript .NET | public function AsyncOperationCompleteMessage();


AsyncOperationCompleteMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


AsyncOperationCompleteMessage.AsyncOperationHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteMessage.AsyncOperationHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AsyncOperationHandle As Integer
C# | public int AsyncOperationHandle { get; }
Managed C++ | public: __property int get_AsyncOperationHandle();
JScript .NET | public function get AsyncOperationHandle() : int

Property Value

System.Int32 .

This property is read-only.


AsyncOperationCompleteMessage.ResultCode

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteMessage.ResultCode Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the asynchronous operation. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
Managed C++ | public: __property ResultCode get_ResultCode();
JScript .NET | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode .

This property is read-only.


AsyncOperationCompleteMessage.UserContext

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteMessage.UserContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supplied user context. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
Managed C++ | public: __property Object* get_UserContext();
JScript .NET | public function get UserContext() : Object

Property Value

System.Object .

This property is read-only.


Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when setting and retrieving general parameters for Microsoft® DirectPlay®. Deprecated.

Definition

Visual Basic .NET | Public Structure Caps
C# | public struct Caps
Managed C++ | public __value struct Caps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Caps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectRetries
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of connection retries Microsoft® DirectPlay® should make during the connection process. Deprecated.
ConnectTimeout
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® should wait before it retries a connection request. Deprecated.
DropThresholdRate
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage of dropped packets allowed before is applied. Deprecated.
MaxHardDisconnectPeriod
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum period of time in milliseconds between each hard disconnect frame sent. Deprecated.
MaxReceiveMessageSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of received messages, in bytes. Deprecated.
MaxSendRetryInterval
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of times applications can try to send a message before the connection is considered dead. Deprecated.
NumberHardDisconnectSends
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the Close.Immediate flag is specified. Deprecated.
NumberSendRetries
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the DPNCLOSE_IMMEDIATE flag is specified. Deprecated.
ThrottleRate
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage to reduce the send queue when applying message throttling. Deprecated.
TimeoutUntilKeepAlive
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® waits since the last time it received a packet from an endpoint, before it sends a keep alive message. The actual delay can vary from the specified value to as much as twice the specified value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Caps.ConnectRetries

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ConnectRetries Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of connection retries Microsoft® DirectPlay® should make during the connection process. Deprecated.

Definition

Visual Basic .NET | Public Property ConnectRetries As Integer
C# | public int ConnectRetries { get; set; }
Managed C++ public: __property int get_ConnectRetries();
public: __property void set_ConnectRetries(int);
JScript .NET public function get ConnectRetries() : int
public function set ConnectRetries(int);

Property Value

System.Int32 .

This property is read/write.


Caps.ConnectTimeout

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ConnectTimeout Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® should wait before it retries a connection request. Deprecated.

Definition

Visual Basic .NET | Public Property ConnectTimeout As Integer
C# | public int ConnectTimeout { get; set; }
Managed C++ public: __property int get_ConnectTimeout();
public: __property void set_ConnectTimeout(int);
JScript .NET public function get ConnectTimeout() : int
public function set ConnectTimeout(int);

Property Value

System.Int32 .

This property is read/write.


Caps.DropThresholdRate

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.DropThresholdRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage of dropped packets allowed before is applied. Deprecated.

Definition

Visual Basic .NET | Public Property DropThresholdRate As Integer
C# | public int DropThresholdRate { get; set; }
Managed C++ public: __property int get_DropThresholdRate();
public: __property void set_DropThresholdRate(int);
JScript .NET public function get DropThresholdRate() : int
public function set DropThresholdRate(int);

Property Value

System.Int32 .

This property is read/write.


Caps.MaxHardDisconnectPeriod

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardDisconnectPeriod Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum period of time in milliseconds between each hard disconnect frame sent. Deprecated.

Definition

Visual Basic .NET | Public Property MaxHardDisconnectPeriod As Integer
C# | public int MaxHardDisconnectPeriod { get; set; }
Managed C++ public: __property int get_MaxHardDisconnectPeriod();
public: __property void set_MaxHardDisconnectPeriod(int);
JScript .NET public function get MaxHardDisconnectPeriod() : int
public function set MaxHardDisconnectPeriod(int);

Property Value

System.Int32 .

This property is read/write.


Caps.MaxReceiveMessageSize

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxReceiveMessageSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of received messages, in bytes. Deprecated.

Definition

Visual Basic .NET | Public Property MaxReceiveMessageSize As Integer
C# | public int MaxReceiveMessageSize { get; set; }
Managed C++ public: __property int get_MaxReceiveMessageSize();
public: __property void set_MaxReceiveMessageSize(int);
JScript .NET public function get MaxReceiveMessageSize() : int
public function set MaxReceiveMessageSize(int);

Property Value

System.Int32 .

This property is read/write.


Caps.MaxSendRetryInterval

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxSendRetryInterval Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of times applications can try to send a message before the connection is considered dead. Deprecated.

Definition

Visual Basic .NET | Public Property MaxSendRetryInterval As Integer
C# | public int MaxSendRetryInterval { get; set; }
Managed C++ public: __property int get_MaxSendRetryInterval();
public: __property void set_MaxSendRetryInterval(int);
JScript .NET public function get MaxSendRetryInterval() : int
public function set MaxSendRetryInterval(int);

Property Value

System.Int32 .

This property is read/write.


Caps.NumberHardDisconnectSends

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NumberHardDisconnectSends Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the Close.Immediate flag is specified. Deprecated.

Definition

Visual Basic .NET | Public Property NumberHardDisconnectSends As Integer
C# | public int NumberHardDisconnectSends { get; set; }
Managed C++ public: __property int get_NumberHardDisconnectSends();
public: __property void set_NumberHardDisconnectSends(int);
JScript .NET public function get NumberHardDisconnectSends() : int
public function set NumberHardDisconnectSends(int);

Property Value

System.Int32 .

This property is read/write.


Caps.NumberSendRetries

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.NumberSendRetries Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the DPNCLOSE_IMMEDIATE flag is specified. Deprecated.

Definition

Visual Basic .NET | Public Property NumberSendRetries As Integer
C# | public int NumberSendRetries { get; set; }
Managed C++ public: __property int get_NumberSendRetries();
public: __property void set_NumberSendRetries(int);
JScript .NET public function get NumberSendRetries() : int
public function set NumberSendRetries(int);

Property Value

System.Int32 .

This property is read/write.


Caps.ThrottleRate

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ThrottleRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage to reduce the send queue when applying message throttling. Deprecated.

Definition

Visual Basic .NET | Public Property ThrottleRate As Integer
C# | public int ThrottleRate { get; set; }
Managed C++ public: __property int get_ThrottleRate();
public: __property void set_ThrottleRate(int);
JScript .NET public function get ThrottleRate() : int
public function set ThrottleRate(int);

Property Value

System.Int32 .

This property is read/write.


Caps.TimeoutUntilKeepAlive

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.TimeoutUntilKeepAlive Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® waits since the last time it received a packet from an endpoint, before it sends a keep alive message. The actual delay can vary from the specified value to as much as twice the specified value. Deprecated.

Definition

Visual Basic .NET | Public Property TimeoutUntilKeepAlive As Integer
C# | public int TimeoutUntilKeepAlive { get; set; }
Managed C++ public: __property int get_TimeoutUntilKeepAlive();
public: __property void set_TimeoutUntilKeepAlive(int);
JScript .NET public function get TimeoutUntilKeepAlive() : int
public function set TimeoutUntilKeepAlive(int);

Property Value

System.Int32 .

This property is read/write.


ClientInformationMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure ClientInformationMessage
C# | public struct ClientInformationMessage
Managed C++ | public __value struct ClientInformationMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ClientInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ClientID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the client for client information. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClientInformationMessage.ClientInformationMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationMessage.ClientInformationMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ClientInformationMessage();
Managed C++ | public: ClientInformationMessage();
JScript .NET | public function ClientInformationMessage();


ClientInformationMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ClientInformationMessage.ClientID

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationMessage.ClientID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the client for client information. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ClientID As Integer
C# | public int ClientID { get; }
Managed C++ | public: __property int get_ClientID();
JScript .NET | public function get ClientID() : int

Property Value

System.Int32 .

This property is read-only.


ClientInformationMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


ConnectCompleteMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure ConnectCompleteMessage
C# | public struct ConnectCompleteMessage
Managed C++ | public __value struct ConnectCompleteMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectCompleteMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ApplicationReplyData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connection reply data returned from the host or server. Deprecated.
AsyncOperationHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.
LocalPlayerId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the DPNID of the local player. Deprecated.
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT describing the result of the connection attempt. See the Return Values section in the Play8peerConnectDplay or Play8clientConnectDplay method for more information. Additionally, DPNERR_PLAYERNOTREACHABLE will be returned if a player has tried to join a peer-to-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied when the Play8peerConnectDplay or Play8clientConnectDplay methods are called. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectCompleteMessage.ConnectCompleteMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage.ConnectCompleteMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectCompleteMessage();
Managed C++ | public: ConnectCompleteMessage();
JScript .NET | public function ConnectCompleteMessage();


ConnectCompleteMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConnectCompleteMessage.ApplicationReplyData

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage.ApplicationReplyData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connection reply data returned from the host or server. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ApplicationReplyData As NetworkPacket
C# | public NetworkPacket ApplicationReplyData { get; }
Managed C++ | public: __property NetworkPacket* get_ApplicationReplyData();
JScript .NET | public function get ApplicationReplyData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read-only.


ConnectCompleteMessage.AsyncOperationHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage.AsyncOperationHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AsyncOperationHandle As Integer
C# | public int AsyncOperationHandle { get; }
Managed C++ | public: __property int get_AsyncOperationHandle();
JScript .NET | public function get AsyncOperationHandle() : int

Property Value

System.Int32 .

This property is read-only.


ConnectCompleteMessage.LocalPlayerId

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage.LocalPlayerId Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the DPNID of the local player. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property LocalPlayerId As Integer
C# | public int LocalPlayerId { get; }
Managed C++ | public: __property int get_LocalPlayerId();
JScript .NET | public function get LocalPlayerId() : int

Property Value

System.Int32 .

This property is read-only.


ConnectCompleteMessage.ResultCode

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage.ResultCode Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT describing the result of the connection attempt. See the Return Values section in the Play8peerConnectDplay or Play8clientConnectDplay method for more information. Additionally, DPNERR_PLAYERNOTREACHABLE will be returned if a player has tried to join a peer-to-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
Managed C++ | public: __property ResultCode get_ResultCode();
JScript .NET | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode .

This property is read-only.


ConnectCompleteMessage.UserContext

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteMessage.UserContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied when the Play8peerConnectDplay or Play8clientConnectDplay methods are called. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
Managed C++ | public: __property Object* get_UserContext();
JScript .NET | public function get UserContext() : Object

Property Value

System.Object .

This property is read-only.


ConnectionInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to retrieve statistics for the connection between you and a remote computer that you are connected to. Deprecated.

Definition

Visual Basic .NET | Public Structure ConnectionInformation
C# | public struct ConnectionInformation
Managed C++ | public __value struct ConnectionInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BytesDropped
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been dropped. Deprecated.
BytesReceivedGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been received. Deprecated.
BytesReceivedNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been received. Deprecated.
BytesRetried
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been retried. Deprecated.
BytesSentGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been sent. Deprecated.
BytesSentNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been sent. Deprecated.
MessagesReceived
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of messages that have been received. Deprecated.
MessagesTimedOutHighPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have timed out. Deprecated.
MessagesTimedOutLowPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low priority messages that have timed out. Deprecated.
MessagesTimedOutNormalPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have timed out. Deprecated.
MessagesTransmittedHighPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have been transmitted. Deprecated.
MessagesTransmittedLowPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low-priority messages that have been transmitted. Deprecated.
MessagesTransmittedNormalPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have been transmitted. Deprecated.
PacketsDropped
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets that have been dropped. Deprecated.
PacketsReceivedGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been received. Deprecated.
PacketsReceivedNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been received. Deprecated.
PacketsRetried
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount of packets that have been retried. Deprecated.
PacketsSentGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been sent. Deprecated.
PacketsSentNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been sent. Deprecated.
PeakThroughputBps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Peak throughput, in bytes per second (Bps) for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.
RoundTripLatencyMs
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate time, in milliseconds (ms), it takes a packet to reach the remote computer and be returned to the local computer. This number will change throughout the session as link conditions change. Deprecated.
ThroughputBps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate throughput, in bytes per second (Bps), for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectionInformation.ConnectionInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.ConnectionInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ConnectionInformation();
Managed C++ | public: ConnectionInformation();
JScript .NET | public function ConnectionInformation();


ConnectionInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ConnectionInformation.BytesDropped

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.BytesDropped Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been dropped. Deprecated.

Definition

Visual Basic .NET | Public Property BytesDropped As Integer
C# | public int BytesDropped { get; set; }
Managed C++ public: __property int get_BytesDropped();
public: __property void set_BytesDropped(int);
JScript .NET public function get BytesDropped() : int
public function set BytesDropped(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.BytesReceivedGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.BytesReceivedGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been received. Deprecated.

Definition

Visual Basic .NET | Public Property BytesReceivedGuaranteed As Integer
C# | public int BytesReceivedGuaranteed { get; set; }
Managed C++ public: __property int get_BytesReceivedGuaranteed();
public: __property void set_BytesReceivedGuaranteed(int);
JScript .NET public function get BytesReceivedGuaranteed() : int
public function set BytesReceivedGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.BytesReceivedNonGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.BytesReceivedNonGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been received. Deprecated.

Definition

Visual Basic .NET | Public Property BytesReceivedNonGuaranteed As Integer
C# | public int BytesReceivedNonGuaranteed { get; set; }
Managed C++ public: __property int get_BytesReceivedNonGuaranteed();
public: __property void set_BytesReceivedNonGuaranteed(int);
JScript .NET public function get BytesReceivedNonGuaranteed() : int
public function set BytesReceivedNonGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.BytesRetried

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.BytesRetried Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been retried. Deprecated.

Definition

Visual Basic .NET | Public Property BytesRetried As Integer
C# | public int BytesRetried { get; set; }
Managed C++ public: __property int get_BytesRetried();
public: __property void set_BytesRetried(int);
JScript .NET public function get BytesRetried() : int
public function set BytesRetried(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.BytesSentGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.BytesSentGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been sent. Deprecated.

Definition

Visual Basic .NET | Public Property BytesSentGuaranteed As Integer
C# | public int BytesSentGuaranteed { get; set; }
Managed C++ public: __property int get_BytesSentGuaranteed();
public: __property void set_BytesSentGuaranteed(int);
JScript .NET public function get BytesSentGuaranteed() : int
public function set BytesSentGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.BytesSentNonGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.BytesSentNonGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been sent. Deprecated.

Definition

Visual Basic .NET | Public Property BytesSentNonGuaranteed As Integer
C# | public int BytesSentNonGuaranteed { get; set; }
Managed C++ public: __property int get_BytesSentNonGuaranteed();
public: __property void set_BytesSentNonGuaranteed(int);
JScript .NET public function get BytesSentNonGuaranteed() : int
public function set BytesSentNonGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.MessagesReceived

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.MessagesReceived Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of messages that have been received. Deprecated.

Definition

Visual Basic .NET | Public Property MessagesReceived As Integer
C# | public int MessagesReceived { get; set; }
Managed C++ public: __property int get_MessagesReceived();
public: __property void set_MessagesReceived(int);
JScript .NET public function get MessagesReceived() : int
public function set MessagesReceived(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.MessagesTimedOutHighPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.MessagesTimedOutHighPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have timed out. Deprecated.

Definition

Visual Basic .NET | Public Property MessagesTimedOutHighPriority As Integer
C# | public int MessagesTimedOutHighPriority { get; set; }
Managed C++ public: __property int get_MessagesTimedOutHighPriority();
public: __property void set_MessagesTimedOutHighPriority(int);
JScript .NET public function get MessagesTimedOutHighPriority() : int
public function set MessagesTimedOutHighPriority(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.MessagesTimedOutLowPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.MessagesTimedOutLowPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low priority messages that have timed out. Deprecated.

Definition

Visual Basic .NET | Public Property MessagesTimedOutLowPriority As Integer
C# | public int MessagesTimedOutLowPriority { get; set; }
Managed C++ public: __property int get_MessagesTimedOutLowPriority();
public: __property void set_MessagesTimedOutLowPriority(int);
JScript .NET public function get MessagesTimedOutLowPriority() : int
public function set MessagesTimedOutLowPriority(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.MessagesTimedOutNormalPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.MessagesTimedOutNormalPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have timed out. Deprecated.

Definition

Visual Basic .NET | Public Property MessagesTimedOutNormalPriority As Integer
C# | public int MessagesTimedOutNormalPriority { get; set; }
Managed C++ public: __property int get_MessagesTimedOutNormalPriority();
public: __property void set_MessagesTimedOutNormalPriority(int);
JScript .NET public function get MessagesTimedOutNormalPriority() : int
public function set MessagesTimedOutNormalPriority(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.MessagesTransmittedHighPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.MessagesTransmittedHighPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have been transmitted. Deprecated.

Definition

Visual Basic .NET | Public Property MessagesTransmittedHighPriority As Integer
C# | public int MessagesTransmittedHighPriority { get; set; }
Managed C++ public: __property int get_MessagesTransmittedHighPriority();
public: __property void set_MessagesTransmittedHighPriority(int);
JScript .NET public function get MessagesTransmittedHighPriority() : int
public function set MessagesTransmittedHighPriority(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.MessagesTransmittedLowPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.MessagesTransmittedLowPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low-priority messages that have been transmitted. Deprecated.

Definition

Visual Basic .NET | Public Property MessagesTransmittedLowPriority As Integer
C# | public int MessagesTransmittedLowPriority { get; set; }
Managed C++ public: __property int get_MessagesTransmittedLowPriority();
public: __property void set_MessagesTransmittedLowPriority(int);
JScript .NET public function get MessagesTransmittedLowPriority() : int
public function set MessagesTransmittedLowPriority(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.MessagesTransmittedNormalPriority

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.MessagesTransmittedNormalPriority Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have been transmitted. Deprecated.

Definition

Visual Basic .NET | Public Property MessagesTransmittedNormalPriority As Integer
C# | public int MessagesTransmittedNormalPriority { get; set; }
Managed C++ public: __property int get_MessagesTransmittedNormalPriority();
public: __property void set_MessagesTransmittedNormalPriority(int);
JScript .NET public function get MessagesTransmittedNormalPriority() : int
public function set MessagesTransmittedNormalPriority(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.PacketsDropped

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.PacketsDropped Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets that have been dropped. Deprecated.

Definition

Visual Basic .NET | Public Property PacketsDropped As Integer
C# | public int PacketsDropped { get; set; }
Managed C++ public: __property int get_PacketsDropped();
public: __property void set_PacketsDropped(int);
JScript .NET public function get PacketsDropped() : int
public function set PacketsDropped(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.PacketsReceivedGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.PacketsReceivedGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been received. Deprecated.

Definition

Visual Basic .NET | Public Property PacketsReceivedGuaranteed As Integer
C# | public int PacketsReceivedGuaranteed { get; set; }
Managed C++ public: __property int get_PacketsReceivedGuaranteed();
public: __property void set_PacketsReceivedGuaranteed(int);
JScript .NET public function get PacketsReceivedGuaranteed() : int
public function set PacketsReceivedGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.PacketsReceivedNonGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.PacketsReceivedNonGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been received. Deprecated.

Definition

Visual Basic .NET | Public Property PacketsReceivedNonGuaranteed As Integer
C# | public int PacketsReceivedNonGuaranteed { get; set; }
Managed C++ public: __property int get_PacketsReceivedNonGuaranteed();
public: __property void set_PacketsReceivedNonGuaranteed(int);
JScript .NET public function get PacketsReceivedNonGuaranteed() : int
public function set PacketsReceivedNonGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.PacketsRetried

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.PacketsRetried Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount of packets that have been retried. Deprecated.

Definition

Visual Basic .NET | Public Property PacketsRetried As Integer
C# | public int PacketsRetried { get; set; }
Managed C++ public: __property int get_PacketsRetried();
public: __property void set_PacketsRetried(int);
JScript .NET public function get PacketsRetried() : int
public function set PacketsRetried(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.PacketsSentGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.PacketsSentGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been sent. Deprecated.

Definition

Visual Basic .NET | Public Property PacketsSentGuaranteed As Integer
C# | public int PacketsSentGuaranteed { get; set; }
Managed C++ public: __property int get_PacketsSentGuaranteed();
public: __property void set_PacketsSentGuaranteed(int);
JScript .NET public function get PacketsSentGuaranteed() : int
public function set PacketsSentGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.PacketsSentNonGuaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.PacketsSentNonGuaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been sent. Deprecated.

Definition

Visual Basic .NET | Public Property PacketsSentNonGuaranteed As Integer
C# | public int PacketsSentNonGuaranteed { get; set; }
Managed C++ public: __property int get_PacketsSentNonGuaranteed();
public: __property void set_PacketsSentNonGuaranteed(int);
JScript .NET public function get PacketsSentNonGuaranteed() : int
public function set PacketsSentNonGuaranteed(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.PeakThroughputBps

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.PeakThroughputBps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Peak throughput, in bytes per second (Bps) for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.

Definition

Visual Basic .NET | Public Property PeakThroughputBps As Integer
C# | public int PeakThroughputBps { get; set; }
Managed C++ public: __property int get_PeakThroughputBps();
public: __property void set_PeakThroughputBps(int);
JScript .NET public function get PeakThroughputBps() : int
public function set PeakThroughputBps(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.RoundTripLatencyMs

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.RoundTripLatencyMs Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate time, in milliseconds (ms), it takes a packet to reach the remote computer and be returned to the local computer. This number will change throughout the session as link conditions change. Deprecated.

Definition

Visual Basic .NET | Public Property RoundTripLatencyMs As Integer
C# | public int RoundTripLatencyMs { get; set; }
Managed C++ public: __property int get_RoundTripLatencyMs();
public: __property void set_RoundTripLatencyMs(int);
JScript .NET public function get RoundTripLatencyMs() : int
public function set RoundTripLatencyMs(int);

Property Value

System.Int32 .

This property is read/write.


ConnectionInformation.ThroughputBps

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectionInformation.ThroughputBps Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate throughput, in bytes per second (Bps), for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.

Definition

Visual Basic .NET | Public Property ThroughputBps As Integer
C# | public int ThroughputBps { get; set; }
Managed C++ public: __property int get_ThroughputBps();
public: __property void set_ThroughputBps(int);
JScript .NET public function get ThroughputBps() : int
public function set ThroughputBps(int);

Property Value

System.Int32 .

This property is read/write.


CreateGroupMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateGroupMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateGroupDplay message when a group is created.The structure contains information for the DpnMsgidCreateGroupDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure CreateGroupMessage
C# | public struct CreateGroupMessage
Managed C++ | public __value struct CreateGroupMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreateGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the created group. Deprecated.
OwnerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Owner context value. Deprecated.
OwnerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the group's owner. This value is only set for groups that have the DPNGROUP_AUTODESTRUCT flag set in the dwGroupFlags member of the DpnGroupInfoDplay structure. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CreateGroupMessage.CreateGroupMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateGroupMessage.CreateGroupMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CreateGroupMessage();
Managed C++ | public: CreateGroupMessage();
JScript .NET | public function CreateGroupMessage();


CreateGroupMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateGroupMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CreateGroupMessage.GroupContext

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateGroupMessage.GroupContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic .NET | Public Property GroupContext As Object
C# | public object GroupContext { get; set; }
Managed C++ public: __property Object* get_GroupContext();
public: __property void set_GroupContext(Object*);
JScript .NET public function get GroupContext() : Object
public function set GroupContext(Object);

Property Value

System.Object .

This property is read/write.


CreateGroupMessage.GroupID

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateGroupMessage.GroupID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the created group. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
Managed C++ | public: __property int get_GroupID();
JScript .NET | public function get GroupID() : int

Property Value

System.Int32 .

This property is read-only.


CreateGroupMessage.OwnerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateGroupMessage.OwnerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Owner context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OwnerContext As Object
C# | public object OwnerContext { get; }
Managed C++ | public: __property Object* get_OwnerContext();
JScript .NET | public function get OwnerContext() : Object

Property Value

System.Object .

This property is read-only.


CreateGroupMessage.OwnerID

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateGroupMessage.OwnerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the group's owner. This value is only set for groups that have the DPNGROUP_AUTODESTRUCT flag set in the dwGroupFlags member of the DpnGroupInfoDplay structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property OwnerID As Integer
C# | public int OwnerID { get; }
Managed C++ | public: __property int get_OwnerID();
JScript .NET | public function get OwnerID() : int

Property Value

System.Int32 .

This property is read-only.


CreatePlayerMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

CreatePlayerMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreatePlayerDplay message when a player is added to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidCreatePlayerDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure CreatePlayerMessage
C# | public struct CreatePlayerMessage
Managed C++ | public __value struct CreatePlayerMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreatePlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player that was added to the session. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CreatePlayerMessage.CreatePlayerMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreatePlayerMessage.CreatePlayerMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CreatePlayerMessage();
Managed C++ | public: CreatePlayerMessage();
JScript .NET | public function CreatePlayerMessage();


CreatePlayerMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreatePlayerMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CreatePlayerMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

CreatePlayerMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public Property PlayerContext As Object
C# | public object PlayerContext { get; set; }
Managed C++ public: __property Object* get_PlayerContext();
public: __property void set_PlayerContext(Object*);
JScript .NET public function get PlayerContext() : Object
public function set PlayerContext(Object);

Property Value

System.Object .

This property is read/write.


CreatePlayerMessage.PlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

CreatePlayerMessage.PlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player that was added to the session. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
Managed C++ | public: __property int get_PlayerID();
JScript .NET | public function get PlayerID() : int

Property Value

System.Int32 .

This property is read-only.


CreateThreadMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateThreadMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateThreadDplay message when a new thread is created.The structure contains information for the DpnMsgidCreateThreadDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure CreateThreadMessage
C# | public struct CreateThreadMessage
Managed C++ | public __value struct CreateThreadMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreateThreadMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.
ProcessorNum
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the processor index to which this thread is bound. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CreateThreadMessage.CreateThreadMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateThreadMessage.CreateThreadMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public CreateThreadMessage();
Managed C++ | public: CreateThreadMessage();
JScript .NET | public function CreateThreadMessage();


CreateThreadMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateThreadMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CreateThreadMessage.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateThreadMessage.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Flags As Integer
C# | public int Flags { get; }
Managed C++ | public: __property int get_Flags();
JScript .NET | public function get Flags() : int

Property Value

System.Int32 .

This property is read-only.


CreateThreadMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateThreadMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


CreateThreadMessage.ProcessorNum

Microsoft DirectX 9.0 SDK Update (October 2004)

CreateThreadMessage.ProcessorNum Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the processor index to which this thread is bound. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ProcessorNum As Integer
C# | public int ProcessorNum { get; }
Managed C++ | public: __property int get_ProcessorNum();
JScript .NET | public function get ProcessorNum() : int

Property Value

System.Int32 .

This property is read-only.


DestroyGroupMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyGroupMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyGroupDplay message when a group is destroyed from a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyGroupDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure DestroyGroupMessage
C# | public struct DestroyGroupMessage
Managed C++ | public __value struct DestroyGroupMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DestroyGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group deleted from the session. Deprecated.
Reason
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be set to indicate why the player was destroyed. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DestroyGroupMessage.DestroyGroupMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyGroupMessage.DestroyGroupMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DestroyGroupMessage();
Managed C++ | public: DestroyGroupMessage();
JScript .NET | public function DestroyGroupMessage();


DestroyGroupMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyGroupMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DestroyGroupMessage.GroupContext

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyGroupMessage.GroupContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
Managed C++ | public: __property Object* get_GroupContext();
JScript .NET | public function get GroupContext() : Object

Property Value

System.Object .

This property is read-only.


DestroyGroupMessage.GroupID

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyGroupMessage.GroupID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group deleted from the session. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
Managed C++ | public: __property int get_GroupID();
JScript .NET | public function get GroupID() : int

Property Value

System.Int32 .

This property is read-only.


DestroyGroupMessage.Reason

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyGroupMessage.Reason Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be set to indicate why the player was destroyed. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Reason As DestroyGroupFlags
C# | public DestroyGroupFlags Reason { get; }
Managed C++ | public: __property DestroyGroupFlags get_Reason();
JScript .NET | public function get Reason() : DestroyGroupFlags

Property Value

Microsoft.DirectX.DirectPlay.DestroyGroupFlags .

This property is read-only.


DestroyPlayerMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyPlayerMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyPlayerDplay message when a player leaves a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyPlayerDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure DestroyPlayerMessage
C# | public struct DestroyPlayerMessage
Managed C++ | public __value struct DestroyPlayerMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DestroyPlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the session. Deprecated.
Reason
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags indicating why the player was destroyed. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DestroyPlayerMessage.DestroyPlayerMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyPlayerMessage.DestroyPlayerMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DestroyPlayerMessage();
Managed C++ | public: DestroyPlayerMessage();
JScript .NET | public function DestroyPlayerMessage();


DestroyPlayerMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyPlayerMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DestroyPlayerMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyPlayerMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


DestroyPlayerMessage.PlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyPlayerMessage.PlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the session. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
Managed C++ | public: __property int get_PlayerID();
JScript .NET | public function get PlayerID() : int

Property Value

System.Int32 .

This property is read-only.


DestroyPlayerMessage.Reason

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyPlayerMessage.Reason Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags indicating why the player was destroyed. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Reason As DestroyPlayerFlags
C# | public DestroyPlayerFlags Reason { get; }
Managed C++ | public: __property DestroyPlayerFlags get_Reason();
JScript .NET | public function get Reason() : DestroyPlayerFlags

Property Value

Microsoft.DirectX.DirectPlay.DestroyPlayerFlags .

This property is read-only.


DestroyThreadMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyThreadMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyThreadDplay message when a thread is shut down.The structure contains information for the DpnMsgidDestroyThreadDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure DestroyThreadMessage
C# | public struct DestroyThreadMessage
Managed C++ | public __value struct DestroyThreadMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DestroyThreadMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.
ProcessorNumber
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Processor Number this thread was created on. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DestroyThreadMessage.DestroyThreadMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyThreadMessage.DestroyThreadMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public DestroyThreadMessage();
Managed C++ | public: DestroyThreadMessage();
JScript .NET | public function DestroyThreadMessage();


DestroyThreadMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyThreadMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DestroyThreadMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyThreadMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


DestroyThreadMessage.ProcessorNumber

Microsoft DirectX 9.0 SDK Update (October 2004)

DestroyThreadMessage.ProcessorNumber Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Processor Number this thread was created on. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ProcessorNumber As Integer
C# | public int ProcessorNumber { get; }
Managed C++ | public: __property int get_ProcessorNumber();
JScript .NET | public function get ProcessorNumber() : int

Property Value

System.Int32 .

This property is read-only.


FindHostsQueryMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the FindHostQuery event. Deprecated.

Definition

Visual Basic .NET | Public Structure FindHostsQueryMessage
C# | public struct FindHostsQueryMessage
Managed C++ | public __value struct FindHostsQueryMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
FindHostsQueryMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetResponseData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response data from the enumeration. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.
AddressSender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.
MaxResponseDataSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum allowed size for the enumeration response. Deprecated.
ReceivedData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Network packet that contains the received data. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostsQueryMessage.FindHostsQueryMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage.FindHostsQueryMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public FindHostsQueryMessage();
Managed C++ | public: FindHostsQueryMessage();
JScript .NET | public function FindHostsQueryMessage();


FindHostsQueryMessage.SetResponseData(NetworkPacket)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage.SetResponseData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response data from the enumeration. Deprecated.

Definition

Visual Basic .NET Public Sub SetResponseData( _
ByVal data As NetworkPacket _
)
C# public void SetResponseData(
NetworkPacket data
);
Managed C++ public: void SetResponseData(
NetworkPacket *data
);
JScript .NET public function SetResponseData(
data : NetworkPacket
);

Parameters

data Microsoft.DirectX.DirectPlay.NetworkPacket.


FindHostsQueryMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FindHostsQueryMessage.AddressDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage.AddressDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
Managed C++ | public: __property Address* get_AddressDevice();
JScript .NET | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


FindHostsQueryMessage.AddressSender

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage.AddressSender Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressSender As Address
C# | public Address AddressSender { get; }
Managed C++ | public: __property Address* get_AddressSender();
JScript .NET | public function get AddressSender() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


FindHostsQueryMessage.MaxResponseDataSize

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage.MaxResponseDataSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum allowed size for the enumeration response. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property MaxResponseDataSize As Integer
C# | public int MaxResponseDataSize { get; }
Managed C++ | public: __property int get_MaxResponseDataSize();
JScript .NET | public function get MaxResponseDataSize() : int

Property Value

System.Int32 .

This property is read-only.


FindHostsQueryMessage.ReceivedData

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsQueryMessage.ReceivedData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Network packet that contains the received data. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ReceivedData As NetworkPacket
C# | public NetworkPacket ReceivedData { get; }
Managed C++ | public: __property NetworkPacket* get_ReceivedData();
JScript .NET | public function get ReceivedData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read-only.


FindHostsResponseMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® sends the DpnMsgidEnumHostsResponseDplay message to a peer or client's message handler to convey the host's response to an enumeration request.The structure contains information for the DpnMsgidEnumHostsResponseDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure FindHostsResponseMessage
C# | public struct FindHostsResponseMessage
Managed C++ | public __value struct FindHostsResponseMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
FindHostsResponseMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.
AddressSender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application description. Deprecated.
ResponseData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a response context value. This value will be passed to the host's message handler with the DpnMsgidReturnBufferDplay message as the pvUserContext member of the associated structure. Deprecated.
RoundTripLatencyMs
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Latency measured in milliseconds. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the user context value. This value is the same as the user context value passed to Play8peerEnumhostsDplay or Play8clientEnumhostsDplay. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostsResponseMessage.FindHostsResponseMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.FindHostsResponseMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public FindHostsResponseMessage();
Managed C++ | public: FindHostsResponseMessage();
JScript .NET | public function FindHostsResponseMessage();


FindHostsResponseMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


FindHostsResponseMessage.AddressDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.AddressDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
Managed C++ | public: __property Address* get_AddressDevice();
JScript .NET | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


FindHostsResponseMessage.AddressSender

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.AddressSender Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressSender As Address
C# | public Address AddressSender { get; }
Managed C++ | public: __property Address* get_AddressSender();
JScript .NET | public function get AddressSender() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


FindHostsResponseMessage.ApplicationDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.ApplicationDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application description. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; }
Managed C++ | public: __property ApplicationDescription get_ApplicationDescription();
JScript .NET | public function get ApplicationDescription() : ApplicationDescription

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription .

This property is read-only.


FindHostsResponseMessage.ResponseData

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.ResponseData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a response context value. This value will be passed to the host's message handler with the DpnMsgidReturnBufferDplay message as the pvUserContext member of the associated structure. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ResponseData As NetworkPacket
C# | public NetworkPacket ResponseData { get; }
Managed C++ | public: __property NetworkPacket* get_ResponseData();
JScript .NET | public function get ResponseData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read-only.


FindHostsResponseMessage.RoundTripLatencyMs

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.RoundTripLatencyMs Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Latency measured in milliseconds. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property RoundTripLatencyMs As Integer
C# | public int RoundTripLatencyMs { get; }
Managed C++ | public: __property int get_RoundTripLatencyMs();
JScript .NET | public function get RoundTripLatencyMs() : int

Property Value

System.Int32 .

This property is read-only.


FindHostsResponseMessage.UserContext

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostsResponseMessage.UserContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the user context value. This value is the same as the user context value passed to Play8peerEnumhostsDplay or Play8clientEnumhostsDplay. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
Managed C++ | public: __property Object* get_UserContext();
JScript .NET | public function get UserContext() : Object

Property Value

System.Object .

This property is read-only.


GroupInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static group information. Deprecated.

Definition

Visual Basic .NET | Public Structure GroupInformation
C# | public struct GroupInformation
Managed C++ | public __value struct GroupInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.
GroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupFlags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD that can be set to the following description flag. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the group. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupInformation.GetData()

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformation.GetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.

Definition

Visual Basic .NET | Public Function GetData() As Byte()
C# | public byte[] GetData();
Managed C++ | public: Byte GetData() __gc[];
JScript .NET | public function GetData() : byte[];

Return Value

System.Byte[].


GroupInformation.GroupInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformation.GroupInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public GroupInformation();
Managed C++ | public: GroupInformation();
JScript .NET | public function GroupInformation();


GroupInformation.SetData(Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformation.SetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.

Definition

Visual Basic .NET Public Sub SetData( _
ByVal value() As Byte _
)
C# public void SetData(
byte[] value
);
Managed C++ public: void SetData(
Byte value __gc[]
);
JScript .NET public function SetData(
value : byte[]
);

Parameters

value System.Byte[].


GroupInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


GroupInformation.GroupFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformation.GroupFlags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD that can be set to the following description flag. Deprecated.

Definition

Visual Basic .NET | Public Property GroupFlags As GroupFlags
C# | public GroupFlags GroupFlags { get; set; }
Managed C++ public: __property GroupFlags get_GroupFlags();
public: __property void set_GroupFlags(GroupFlags);
JScript .NET public function get GroupFlags() : GroupFlags
public function set GroupFlags(GroupFlags);

Property Value

Microsoft.DirectX.DirectPlay.GroupFlags .

This property is read/write.


GroupInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the group. Deprecated.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


GroupInformationMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure GroupInformationMessage
C# | public struct GroupInformationMessage
Managed C++ | public __value struct GroupInformationMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GroupInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group for group information. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupInformationMessage.GroupInformationMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationMessage.GroupInformationMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public GroupInformationMessage();
Managed C++ | public: GroupInformationMessage();
JScript .NET | public function GroupInformationMessage();


GroupInformationMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


GroupInformationMessage.GroupContext

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationMessage.GroupContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
Managed C++ | public: __property Object* get_GroupContext();
JScript .NET | public function get GroupContext() : Object

Property Value

System.Object .

This property is read-only.


GroupInformationMessage.GroupID

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationMessage.GroupID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group for group information. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
Managed C++ | public: __property int get_GroupID();
JScript .NET | public function get GroupID() : int

Property Value

System.Int32 .

This property is read-only.


HostMigratedMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure HostMigratedMessage
C# | public struct HostMigratedMessage
Managed C++ | public __value struct HostMigratedMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
HostMigratedMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NewHostID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the new host. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HostMigratedMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


IndicateConnectMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure IndicateConnectMessage
C# | public struct IndicateConnectMessage
Managed C++ | public __value struct IndicateConnectMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
IndicateConnectMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetReplyData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the data used to reply to this event. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the device receiving the connect attempt. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.
AddressPlayer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the connecting player. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context preset. Deprecated.
UserConnectData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Data of the connecting player. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IndicateConnectMessage.IndicateConnectMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage.IndicateConnectMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public IndicateConnectMessage();
Managed C++ | public: IndicateConnectMessage();
JScript .NET | public function IndicateConnectMessage();


IndicateConnectMessage.SetReplyData(NetworkPacket)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage.SetReplyData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the data used to reply to this event. Deprecated.

Definition

Visual Basic .NET Public Sub SetReplyData( _
ByVal data As NetworkPacket _
)
C# public void SetReplyData(
NetworkPacket data
);
Managed C++ public: void SetReplyData(
NetworkPacket *data
);
JScript .NET public function SetReplyData(
data : NetworkPacket
);

Parameters

data Microsoft.DirectX.DirectPlay.NetworkPacket.


IndicateConnectMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


IndicateConnectMessage.AddressDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage.AddressDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the device receiving the connect attempt. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
Managed C++ | public: __property Address* get_AddressDevice();
JScript .NET | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


IndicateConnectMessage.AddressPlayer

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage.AddressPlayer Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the connecting player. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressPlayer As Address
C# | public Address AddressPlayer { get; }
Managed C++ | public: __property Address* get_AddressPlayer();
JScript .NET | public function get AddressPlayer() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


IndicateConnectMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context preset. Deprecated.

Definition

Visual Basic .NET | Public Property PlayerContext As Object
C# | public object PlayerContext { get; set; }
Managed C++ public: __property Object* get_PlayerContext();
public: __property void set_PlayerContext(Object*);
JScript .NET public function get PlayerContext() : Object
public function set PlayerContext(Object);

Property Value

System.Object .

This property is read/write.


IndicateConnectMessage.UserConnectData

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectMessage.UserConnectData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Data of the connecting player. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property UserConnectData As NetworkPacket
C# | public NetworkPacket UserConnectData { get; }
Managed C++ | public: __property NetworkPacket* get_UserConnectData();
JScript .NET | public function get UserConnectData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read-only.


IndicatedConnectAbortedMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure IndicatedConnectAbortedMessage
C# | public struct IndicatedConnectAbortedMessage
Managed C++ | public __value struct IndicatedConnectAbortedMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
IndicatedConnectAbortedMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IndicatedConnectAbortedMessage.IndicatedConnectAbortedMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedMessage.IndicatedConnectAbortedMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public IndicatedConnectAbortedMessage();
Managed C++ | public: IndicatedConnectAbortedMessage();
JScript .NET | public function IndicatedConnectAbortedMessage();


IndicatedConnectAbortedMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


IndicatedConnectAbortedMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


NatResolverQueryMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the NatResolverQuery event. Deprecated.

Definition

Visual Basic .NET | Public Structure NatResolverQueryMessage
C# | public struct NatResolverQueryMessage
Managed C++ | public __value struct NatResolverQueryMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
NatResolverQueryMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.
AddressSender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.
UserString
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User specified string included in this query. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NatResolverQueryMessage.NatResolverQueryMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryMessage.NatResolverQueryMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public NatResolverQueryMessage();
Managed C++ | public: NatResolverQueryMessage();
JScript .NET | public function NatResolverQueryMessage();


NatResolverQueryMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


NatResolverQueryMessage.AddressDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryMessage.AddressDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
Managed C++ | public: __property Address* get_AddressDevice();
JScript .NET | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


NatResolverQueryMessage.AddressSender

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryMessage.AddressSender Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AddressSender As Address
C# | public Address AddressSender { get; }
Managed C++ | public: __property Address* get_AddressSender();
JScript .NET | public function get AddressSender() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address .

This property is read-only.


NatResolverQueryMessage.UserString

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryMessage.UserString Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User specified string included in this query. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property UserString As String
C# | public string UserString { get; }
Managed C++ | public: __property String* get_UserString();
JScript .NET | public function get UserString() : String

Property Value

System.String .

This property is read-only.


PeerInformationMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure PeerInformationMessage
C# | public struct PeerInformationMessage
Managed C++ | public __value struct PeerInformationMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PeerInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PeerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the peer for peer information. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PeerInformationMessage.PeerInformationMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationMessage.PeerInformationMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PeerInformationMessage();
Managed C++ | public: PeerInformationMessage();
JScript .NET | public function PeerInformationMessage();


PeerInformationMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PeerInformationMessage.PeerID

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationMessage.PeerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the peer for peer information. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PeerID As Integer
C# | public int PeerID { get; }
Managed C++ | public: __property int get_PeerID();
JScript .NET | public function get PeerID() : int

Property Value

System.Int32 .

This property is read-only.


PeerInformationMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


PlayerInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static player information. Deprecated.

Definition

Visual Basic .NET | Public Structure PlayerInformation
C# | public struct PlayerInformation
Managed C++ | public __value struct PlayerInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.
PlayerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Host
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is the host. Deprecated.
Local
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is local. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the player. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerInformation.GetData()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation.GetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.

Definition

Visual Basic .NET | Public Function GetData() As Byte()
C# | public byte[] GetData();
Managed C++ | public: Byte GetData() __gc[];
JScript .NET | public function GetData() : byte[];

Return Value

System.Byte[].


PlayerInformation.PlayerInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation.PlayerInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public PlayerInformation();
Managed C++ | public: PlayerInformation();
JScript .NET | public function PlayerInformation();


PlayerInformation.SetData(Byte[])

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation.SetData Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.

Definition

Visual Basic .NET Public Sub SetData( _
ByVal value() As Byte _
)
C# public void SetData(
byte[] value
);
Managed C++ public: void SetData(
Byte value __gc[]
);
JScript .NET public function SetData(
value : byte[]
);

Parameters

value System.Byte[].


PlayerInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


PlayerInformation.Host

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation.Host Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is the host. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Host As Boolean
C# | public bool Host { get; }
Managed C++ | public: __property bool get_Host();
JScript .NET | public function get Host() : boolean

Property Value

System.Boolean .

This property is read-only.


PlayerInformation.Local

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation.Local Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is local. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Local As Boolean
C# | public bool Local { get; }
Managed C++ | public: __property bool get_Local();
JScript .NET | public function get Local() : boolean

Property Value

System.Boolean .

This property is read-only.


PlayerInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the player. Deprecated.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


ReceiveMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic .NET | Public Structure ReceiveMessage
C# | public struct ReceiveMessage
Managed C++ | public __value struct ReceiveMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ReceiveMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Coalesced
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this messaged was coalesced. Deprecated.
Guaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value of the player that sent the message. Deprecated.
ReceiveData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the message data buffer. This buffer is normally only valid while the DpnMsgidReceiveDplay message is being processed by the callback message handler. Deprecated.
SenderID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReceiveMessage.Coalesced

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.Coalesced Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this messaged was coalesced. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Coalesced As Boolean
C# | public bool Coalesced { get; }
Managed C++ | public: __property bool get_Coalesced();
JScript .NET | public function get Coalesced() : boolean

Property Value

System.Boolean .

This property is read-only.


ReceiveMessage.Guaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.Guaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Guaranteed As Boolean
C# | public bool Guaranteed { get; }
Managed C++ | public: __property bool get_Guaranteed();
JScript .NET | public function get Guaranteed() : boolean

Property Value

System.Boolean .

This property is read-only.


ReceiveMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value of the player that sent the message. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


ReceiveMessage.SenderID

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveMessage.SenderID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SenderID As Integer
C# | public int SenderID { get; }
Managed C++ | public: __property int get_SenderID();
JScript .NET | public function get SenderID() : int

Property Value

System.Int32 .

This property is read-only.


RemovePlayerFromGroupMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

RemovePlayerFromGroupMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidRemovePlayerFromGroupDplay message when a player has been deleted from a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidRemovePlayerFromGroupDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure RemovePlayerFromGroupMessage
C# | public struct RemovePlayerFromGroupMessage
Managed C++ | public __value struct RemovePlayerFromGroupMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
RemovePlayerFromGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group that the player was deleted from. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the group. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


RemovePlayerFromGroupMessage.RemovePlayerFromGroupMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

RemovePlayerFromGroupMessage.RemovePlayerFromGroupMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public RemovePlayerFromGroupMessage();
Managed C++ | public: RemovePlayerFromGroupMessage();
JScript .NET | public function RemovePlayerFromGroupMessage();


RemovePlayerFromGroupMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

RemovePlayerFromGroupMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


RemovePlayerFromGroupMessage.GroupContext

Microsoft DirectX 9.0 SDK Update (October 2004)

RemovePlayerFromGroupMessage.GroupContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
Managed C++ | public: __property Object* get_GroupContext();
JScript .NET | public function get GroupContext() : Object

Property Value

System.Object .

This property is read-only.


RemovePlayerFromGroupMessage.GroupID

Microsoft DirectX 9.0 SDK Update (October 2004)

RemovePlayerFromGroupMessage.GroupID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group that the player was deleted from. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
Managed C++ | public: __property int get_GroupID();
JScript .NET | public function get GroupID() : int

Property Value

System.Int32 .

This property is read-only.


RemovePlayerFromGroupMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

RemovePlayerFromGroupMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


RemovePlayerFromGroupMessage.PlayerID

Microsoft DirectX 9.0 SDK Update (October 2004)

RemovePlayerFromGroupMessage.PlayerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the group. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
Managed C++ | public: __property int get_PlayerID();
JScript .NET | public function get PlayerID() : int

Property Value

System.Int32 .

This property is read-only.


SendCompleteMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure SendCompleteMessage
C# | public struct SendCompleteMessage
Managed C++ | public __value struct SendCompleteMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SendCompleteMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AsyncOperationHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.
Coalesced
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was coalesced. Deprecated.
FirstFrameRetryCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.
FirstFrameReturnTripTime
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.
Guaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT indicating the result of the send message request. Deprecated.
SendTime
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total time, in milliseconds, between send call and completion. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied in the Play8clientSendDplay, Play8peerSendtoDplay and Play8serverSendtoDplay methods. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SendCompleteMessage.SendCompleteMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.SendCompleteMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public SendCompleteMessage();
Managed C++ | public: SendCompleteMessage();
JScript .NET | public function SendCompleteMessage();


SendCompleteMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


SendCompleteMessage.AsyncOperationHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.AsyncOperationHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property AsyncOperationHandle As Integer
C# | public int AsyncOperationHandle { get; }
Managed C++ | public: __property int get_AsyncOperationHandle();
JScript .NET | public function get AsyncOperationHandle() : int

Property Value

System.Int32 .

This property is read-only.


SendCompleteMessage.Coalesced

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.Coalesced Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was coalesced. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Coalesced As Boolean
C# | public bool Coalesced { get; }
Managed C++ | public: __property bool get_Coalesced();
JScript .NET | public function get Coalesced() : boolean

Property Value

System.Boolean .

This property is read-only.


SendCompleteMessage.FirstFrameRetryCount

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.FirstFrameRetryCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property FirstFrameRetryCount As Integer
C# | public int FirstFrameRetryCount { get; }
Managed C++ | public: __property int get_FirstFrameRetryCount();
JScript .NET | public function get FirstFrameRetryCount() : int

Property Value

System.Int32 .

This property is read-only.


SendCompleteMessage.FirstFrameReturnTripTime

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.FirstFrameReturnTripTime Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property FirstFrameReturnTripTime As Integer
C# | public int FirstFrameReturnTripTime { get; }
Managed C++ | public: __property int get_FirstFrameReturnTripTime();
JScript .NET | public function get FirstFrameReturnTripTime() : int

Property Value

System.Int32 .

This property is read-only.


SendCompleteMessage.Guaranteed

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.Guaranteed Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property Guaranteed As Boolean
C# | public bool Guaranteed { get; }
Managed C++ | public: __property bool get_Guaranteed();
JScript .NET | public function get Guaranteed() : boolean

Property Value

System.Boolean .

This property is read-only.


SendCompleteMessage.ResultCode

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.ResultCode Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT indicating the result of the send message request. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
Managed C++ | public: __property ResultCode get_ResultCode();
JScript .NET | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode .

This property is read-only.


SendCompleteMessage.SendTime

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.SendTime Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total time, in milliseconds, between send call and completion. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property SendTime As Integer
C# | public int SendTime { get; }
Managed C++ | public: __property int get_SendTime();
JScript .NET | public function get SendTime() : int

Property Value

System.Int32 .

This property is read-only.


SendCompleteMessage.UserContext

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteMessage.UserContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied in the Play8clientSendDplay, Play8peerSendtoDplay and Play8serverSendtoDplay methods. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
Managed C++ | public: __property Object* get_UserContext();
JScript .NET | public function get UserContext() : Object

Property Value

System.Object .

This property is read-only.


ServerInformationMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure ServerInformationMessage
C# | public struct ServerInformationMessage
Managed C++ | public __value struct ServerInformationMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServerInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
ServerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the server for server information. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ServerInformationMessage.ServerInformationMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationMessage.ServerInformationMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ServerInformationMessage();
Managed C++ | public: ServerInformationMessage();
JScript .NET | public function ServerInformationMessage();


ServerInformationMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ServerInformationMessage.PlayerContext

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationMessage.PlayerContext Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
Managed C++ | public: __property Object* get_PlayerContext();
JScript .NET | public function get PlayerContext() : Object

Property Value

System.Object .

This property is read-only.


ServerInformationMessage.ServerID

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationMessage.ServerID Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the server for server information. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ServerID As Integer
C# | public int ServerID { get; }
Managed C++ | public: __property int get_ServerID();
JScript .NET | public function get ServerID() : int

Property Value

System.Int32 .

This property is read-only.


ServiceProviderCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve parameters for service providers. Deprecated.

Definition

Visual Basic .NET | Public Structure ServiceProviderCaps
C# | public struct ServiceProviderCaps
Managed C++ | public __value struct ServiceProviderCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BuffersPerThread
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The number of outstanding receive buffers allocated for each DirectPlay thread. If you increase the number of receive buffers, DirectPlay can pull more data out of the operating system buffers. However, you can also increase latency if data is arriving faster than your application can process it. Deprecated.
DefaultCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration count. Deprecated.
DefaultEnumRetryInterval
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default retry interval, in milliseconds. Deprecated.
DefaultEnumTimeout
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration timeout value, in milliseconds. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to determine various capabilities of the service provider. Deprecated.
MaxEnumPayloadSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of the payload information. Deprecated.
NumberThreads
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of threads the service provider will use for servicing network requests. The default value for this is based on an algorithm that takes into account the number of processors on the system. Most applications will not need to modify this value. Deprecated.
SystemBufferSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size of the operating system buffer. This buffer holds data from the communications device when your application cannot process data as fast as it arrives. The purpose of this buffer is to prevent data loss if you receive a sudden burst of data, or if the receive threads are momentarily stalled. Increasing SystemBufferSize can increase latency if your application cannot process the received data fast enough. You can eliminate the operating system buffer by setting SystemBufferSize to 0. However, if you do so, you run the risk of losing data if you cannot process the received data as fast as it arrives. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ServiceProviderCaps.ServiceProviderCaps()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.ServiceProviderCaps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ServiceProviderCaps();
Managed C++ | public: ServiceProviderCaps();
JScript .NET | public function ServiceProviderCaps();


ServiceProviderCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ServiceProviderCaps.BuffersPerThread

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.BuffersPerThread Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The number of outstanding receive buffers allocated for each DirectPlay thread. If you increase the number of receive buffers, DirectPlay can pull more data out of the operating system buffers. However, you can also increase latency if data is arriving faster than your application can process it. Deprecated.

Definition

Visual Basic .NET | Public Property BuffersPerThread As Integer
C# | public int BuffersPerThread { get; set; }
Managed C++ public: __property int get_BuffersPerThread();
public: __property void set_BuffersPerThread(int);
JScript .NET public function get BuffersPerThread() : int
public function set BuffersPerThread(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderCaps.DefaultCount

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.DefaultCount Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration count. Deprecated.

Definition

Visual Basic .NET | Public Property DefaultCount As Integer
C# | public int DefaultCount { get; set; }
Managed C++ public: __property int get_DefaultCount();
public: __property void set_DefaultCount(int);
JScript .NET public function get DefaultCount() : int
public function set DefaultCount(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderCaps.DefaultEnumRetryInterval

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.DefaultEnumRetryInterval Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default retry interval, in milliseconds. Deprecated.

Definition

Visual Basic .NET | Public Property DefaultEnumRetryInterval As Integer
C# | public int DefaultEnumRetryInterval { get; set; }
Managed C++ public: __property int get_DefaultEnumRetryInterval();
public: __property void set_DefaultEnumRetryInterval(int);
JScript .NET public function get DefaultEnumRetryInterval() : int
public function set DefaultEnumRetryInterval(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderCaps.DefaultEnumTimeout

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.DefaultEnumTimeout Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration timeout value, in milliseconds. Deprecated.

Definition

Visual Basic .NET | Public Property DefaultEnumTimeout As Integer
C# | public int DefaultEnumTimeout { get; set; }
Managed C++ public: __property int get_DefaultEnumTimeout();
public: __property void set_DefaultEnumTimeout(int);
JScript .NET public function get DefaultEnumTimeout() : int
public function set DefaultEnumTimeout(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderCaps.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to determine various capabilities of the service provider. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As ServiceProviderCapsFlags
C# | public ServiceProviderCapsFlags Flags { get; set; }
Managed C++ public: __property ServiceProviderCapsFlags get_Flags();
public: __property void set_Flags(ServiceProviderCapsFlags);
JScript .NET public function get Flags() : ServiceProviderCapsFlags
public function set Flags(ServiceProviderCapsFlags);

Property Value

Microsoft.DirectX.DirectPlay.ServiceProviderCapsFlags .

This property is read/write.


ServiceProviderCaps.MaxEnumPayloadSize

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.MaxEnumPayloadSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of the payload information. Deprecated.

Definition

Visual Basic .NET | Public Property MaxEnumPayloadSize As Integer
C# | public int MaxEnumPayloadSize { get; set; }
Managed C++ public: __property int get_MaxEnumPayloadSize();
public: __property void set_MaxEnumPayloadSize(int);
JScript .NET public function get MaxEnumPayloadSize() : int
public function set MaxEnumPayloadSize(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderCaps.NumberThreads

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.NumberThreads Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of threads the service provider will use for servicing network requests. The default value for this is based on an algorithm that takes into account the number of processors on the system. Most applications will not need to modify this value. Deprecated.

Definition

Visual Basic .NET | Public Property NumberThreads As Integer
C# | public int NumberThreads { get; set; }
Managed C++ public: __property int get_NumberThreads();
public: __property void set_NumberThreads(int);
JScript .NET public function get NumberThreads() : int
public function set NumberThreads(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderCaps.SystemBufferSize

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCaps.SystemBufferSize Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size of the operating system buffer. This buffer holds data from the communications device when your application cannot process data as fast as it arrives. The purpose of this buffer is to prevent data loss if you receive a sudden burst of data, or if the receive threads are momentarily stalled. Increasing SystemBufferSize can increase latency if your application cannot process the received data fast enough. You can eliminate the operating system buffer by setting SystemBufferSize to 0. However, if you do so, you run the risk of losing data if you cannot process the received data as fast as it arrives. Deprecated.

Definition

Visual Basic .NET | Public Property SystemBufferSize As Integer
C# | public int SystemBufferSize { get; set; }
Managed C++ public: __property int get_SystemBufferSize();
public: __property void set_SystemBufferSize(int);
JScript .NET public function get SystemBufferSize() : int
public function set SystemBufferSize(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderCapsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers for the system, including those that are not available to the application or do not have devices installed. Deprecated.

Definition

Visual Basic .NET | Public Structure ServiceProviderCapsFlags
C# | public struct ServiceProviderCapsFlags
Managed C++ | public __value struct ServiceProviderCapsFlags
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderCapsFlags
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NetworkSimulator
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies that the service provider is the network simulator. Deprecated.
SupportsAllAdapters
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will use all devices on the system. There is no need to specify a device element. Deprecated.
SupportsBroadcast
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
On IP and IPX applications, the service provider has the ability to broadcast to find games if not enough addressing information is passed. Deprecated.
SupportsDpnServer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNSVR.EXE will provide port sharing for the given SP. Currently this flag is available on Internet Protocol (IP) and Internetwork Packet Exchange (IPX) only. Deprecated.
SupportsThreadPool
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will support the thread pool. Deprecated.
Value
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bitwise or'd combination of flags. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ServiceProviderCapsFlags.ServiceProviderCapsFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ServiceProviderCapsFlags();
public ServiceProviderCapsFlags(int);
public ServiceProviderCapsFlags(int[]);


ServiceProviderCapsFlags.ServiceProviderCapsFlags(Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal initCaps() As Integer _
)
C# public ServiceProviderCapsFlags(
int[] initCaps
);
Managed C++ public: ServiceProviderCapsFlags(
int initCaps __gc[]
);
JScript .NET public function ServiceProviderCapsFlags(
initCaps : int[]
);

Parameters

initCaps System.Int32[].


ServiceProviderCapsFlags.ServiceProviderCapsFlags(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET Public Sub New( _
ByVal initialCap As Integer _
)
C# public ServiceProviderCapsFlags(
int initialCap
);
Managed C++ public: ServiceProviderCapsFlags(
int initialCap
);
JScript .NET public function ServiceProviderCapsFlags(
initialCap : int
);

Parameters

initialCap System.Int32.


ServiceProviderCapsFlags.ServiceProviderCapsFlags()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ServiceProviderCapsFlags();
Managed C++ | public: ServiceProviderCapsFlags();
JScript .NET | public function ServiceProviderCapsFlags();


ServiceProviderCapsFlags.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ServiceProviderCapsFlags.NetworkSimulator

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.NetworkSimulator Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies that the service provider is the network simulator. Deprecated.

Definition

Visual Basic .NET | Public Property NetworkSimulator As Boolean
C# | public bool NetworkSimulator { get; set; }
Managed C++ public: __property bool get_NetworkSimulator();
public: __property void set_NetworkSimulator(bool);
JScript .NET public function get NetworkSimulator() : boolean
public function set NetworkSimulator(boolean);

Property Value

System.Boolean .

This property is read/write.


ServiceProviderCapsFlags.SupportsAllAdapters

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.SupportsAllAdapters Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will use all devices on the system. There is no need to specify a device element. Deprecated.

Definition

Visual Basic .NET | Public Property SupportsAllAdapters As Boolean
C# | public bool SupportsAllAdapters { get; set; }
Managed C++ public: __property bool get_SupportsAllAdapters();
public: __property void set_SupportsAllAdapters(bool);
JScript .NET public function get SupportsAllAdapters() : boolean
public function set SupportsAllAdapters(boolean);

Property Value

System.Boolean .

This property is read/write.


ServiceProviderCapsFlags.SupportsBroadcast

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.SupportsBroadcast Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
On IP and IPX applications, the service provider has the ability to broadcast to find games if not enough addressing information is passed. Deprecated.

Definition

Visual Basic .NET | Public Property SupportsBroadcast As Boolean
C# | public bool SupportsBroadcast { get; set; }
Managed C++ public: __property bool get_SupportsBroadcast();
public: __property void set_SupportsBroadcast(bool);
JScript .NET public function get SupportsBroadcast() : boolean
public function set SupportsBroadcast(boolean);

Property Value

System.Boolean .

This property is read/write.


ServiceProviderCapsFlags.SupportsDpnServer

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.SupportsDpnServer Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNSVR.EXE will provide port sharing for the given SP. Currently this flag is available on Internet Protocol (IP) and Internetwork Packet Exchange (IPX) only. Deprecated.

Definition

Visual Basic .NET | Public Property SupportsDpnServer As Boolean
C# | public bool SupportsDpnServer { get; set; }
Managed C++ public: __property bool get_SupportsDpnServer();
public: __property void set_SupportsDpnServer(bool);
JScript .NET public function get SupportsDpnServer() : boolean
public function set SupportsDpnServer(boolean);

Property Value

System.Boolean .

This property is read/write.


ServiceProviderCapsFlags.SupportsThreadPool

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.SupportsThreadPool Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will support the thread pool. Deprecated.

Definition

Visual Basic .NET | Public Property SupportsThreadPool As Boolean
C# | public bool SupportsThreadPool { get; set; }
Managed C++ public: __property bool get_SupportsThreadPool();
public: __property void set_SupportsThreadPool(bool);
JScript .NET public function get SupportsThreadPool() : boolean
public function set SupportsThreadPool(boolean);

Property Value

System.Boolean .

This property is read/write.


ServiceProviderCapsFlags.Value

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderCapsFlags.Value Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bitwise or'd combination of flags. Deprecated.

Definition

Visual Basic .NET | Public Property Value As Integer
C# | public int Value { get; set; }
Managed C++ public: __property int get_Value();
public: __property void set_Value(int);
JScript .NET public function get Value() : int
public function set Value(int);

Property Value

System.Int32 .

This property is read/write.


ServiceProviderInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when enumerating information for a specific service provider. Deprecated.

Definition

Visual Basic .NET | Public Structure ServiceProviderInformation
C# | public struct ServiceProviderInformation
Managed C++ | public __value struct ServiceProviderInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
Guid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID for the service provider. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the service provider. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ServiceProviderInformation.ServiceProviderInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformation.ServiceProviderInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ServiceProviderInformation();
Managed C++ | public: ServiceProviderInformation();
JScript .NET | public function ServiceProviderInformation();


ServiceProviderInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ServiceProviderInformation.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformation.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic .NET | Public Property Flags As ServiceProviderInformationFlags
C# | public ServiceProviderInformationFlags Flags { get; set; }
Managed C++ public: __property ServiceProviderInformationFlags get_Flags();
public: __property void set_Flags(ServiceProviderInformationFlags);
JScript .NET public function get Flags() : ServiceProviderInformationFlags
public function set Flags(ServiceProviderInformationFlags);

Property Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformationFlags .

This property is read/write.


ServiceProviderInformation.Guid

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformation.Guid Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID for the service provider. Deprecated.

Definition

Visual Basic .NET | Public Property Guid As Guid
C# | public Guid Guid { get; set; }
Managed C++ public: __property Guid get_Guid();
public: __property void set_Guid(Guid);
JScript .NET public function get Guid() : Guid
public function set Guid(Guid);

Property Value

System.Guid .

This property is read/write.


ServiceProviderInformation.Name

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformation.Name Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the service provider. Deprecated.

Definition

Visual Basic .NET | Public Property Name As String
C# | public string Name { get; set; }
Managed C++ public: __property String* get_Name();
public: __property void set_Name(String*);
JScript .NET public function get Name() : String
public function set Name(String);

Property Value

System.String .

This property is read/write.


ServiceProviderInformationFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformationFlags Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the service provider. Deprecated.

Definition

Visual Basic .NET | Public Structure ServiceProviderInformationFlags
C# | public struct ServiceProviderInformationFlags
Managed C++ | public __value struct ServiceProviderInformationFlags
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderInformationFlags
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NetworkSimulatorDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Device is available to the network simulator service provider. Deprecated.
Value
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ServiceProviderInformationFlags.ServiceProviderInformationFlags()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformationFlags.ServiceProviderInformationFlags Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public ServiceProviderInformationFlags();
Managed C++ | public: ServiceProviderInformationFlags();
JScript .NET | public function ServiceProviderInformationFlags();


ServiceProviderInformationFlags.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformationFlags.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


ServiceProviderInformationFlags.NetworkSimulatorDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformationFlags.NetworkSimulatorDevice Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Device is available to the network simulator service provider. Deprecated.

Definition

Visual Basic .NET | Public Property NetworkSimulatorDevice As Boolean
C# | public bool NetworkSimulatorDevice { get; set; }
Managed C++ public: __property bool get_NetworkSimulatorDevice();
public: __property void set_NetworkSimulatorDevice(bool);
JScript .NET public function get NetworkSimulatorDevice() : boolean
public function set NetworkSimulatorDevice(boolean);

Property Value

System.Boolean .

This property is read/write.


ServiceProviderInformationFlags.Value

Microsoft DirectX 9.0 SDK Update (October 2004)

ServiceProviderInformationFlags.Value Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic .NET | Public Property Value As Integer
C# | public int Value { get; set; }
Managed C++ public: __property int get_Value();
public: __property void set_Value(int);
JScript .NET public function get Value() : int
public function set Value(int);

Property Value

System.Int32 .

This property is read/write.


TerminateSessionMessage

Microsoft DirectX 9.0 SDK Update (October 2004)

TerminateSessionMessage Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This struct is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidTerminateSessionDplay message when a session is terminated by the host.The structure contains information for the DpnMsgidTerminateSessionDplay system message. Deprecated.

Definition

Visual Basic .NET | Public Structure TerminateSessionMessage
C# | public struct TerminateSessionMessage
Managed C++ | public __value struct TerminateSessionMessage
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
TerminateSessionMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the session was terminated. This member is set to DPNERR_HOSTTERMINATEDSESSION if the session was peer-to-peer, and the host called Play8peerTerminatesessionDplay. If the session was ended by the host calling Play8peerCloseDplay, or if the host stops responding, hResultCode is set to DPNERR_CONNECTIONLOST. Deprecated.
TerminateData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Termination data. If hResultCode is set to DPNERR_HOSTTERMINATEDSESSION, pvTerminateData points to the data block that the host passed through the pvTerminateData parameter of Play8peerTerminatesessionDplay. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


TerminateSessionMessage.TerminateSessionMessage()

Microsoft DirectX 9.0 SDK Update (October 2004)

TerminateSessionMessage.TerminateSessionMessage Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic .NET | Public Sub New()
C# | public TerminateSessionMessage();
Managed C++ | public: TerminateSessionMessage();
JScript .NET | public function TerminateSessionMessage();


TerminateSessionMessage.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

TerminateSessionMessage.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This method is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


TerminateSessionMessage.ResultCode

Microsoft DirectX 9.0 SDK Update (October 2004)

TerminateSessionMessage.ResultCode Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the session was terminated. This member is set to DPNERR_HOSTTERMINATEDSESSION if the session was peer-to-peer, and the host called Play8peerTerminatesessionDplay. If the session was ended by the host calling Play8peerCloseDplay, or if the host stops responding, hResultCode is set to DPNERR_CONNECTIONLOST. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
Managed C++ | public: __property ResultCode get_ResultCode();
JScript .NET | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode .

This property is read-only.


TerminateSessionMessage.TerminateData

Microsoft DirectX 9.0 SDK Update (October 2004)

TerminateSessionMessage.TerminateData Property

Language:
Note: This documentation is preliminary and is subject to change.

Warning: This property is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Termination data. If hResultCode is set to DPNERR_HOSTTERMINATEDSESSION, pvTerminateData points to the data block that the host passed through the pvTerminateData parameter of Play8peerTerminatesessionDplay. Deprecated.

Definition

Visual Basic .NET | Public ReadOnly Property TerminateData As NetworkPacket
C# | public NetworkPacket TerminateData { get; }
Managed C++ | public: __property NetworkPacket* get_TerminateData();
JScript .NET | public function get TerminateData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket .

This property is read-only.


ApplicationDescriptionEventHandler(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ApplicationDescriptionEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This message indicates that the application description has been changed. There is no accompanying structure. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ApplicationDescriptionEventHandler( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C# public sealed delegate void ApplicationDescriptionEventHandler(
object sender,
EventArgs e
);
Managed C++ public: __gc __delegate void ApplicationDescriptionEventHandler(
Object *sender,
EventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | System.EventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AsyncOperationCompleteEventHandler(Object,AsyncOperationCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

AsyncOperationCompleteEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the AsyncOperationComplete event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub AsyncOperationCompleteEventHandler( _
ByVal sender As Object, _
ByVal e As AsyncOperationCompleteEventArgs _
)
C# public sealed delegate void AsyncOperationCompleteEventHandler(
object sender,
AsyncOperationCompleteEventArgs e
);
Managed C++ public: __gc __delegate void AsyncOperationCompleteEventHandler(
Object *sender,
AsyncOperationCompleteEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ClientInformationEventHandler(Object,ClientInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ClientInformationEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ClientInformationEventHandler( _
ByVal sender As Object, _
ByVal e As ClientInformationEventArgs _
)
C# public sealed delegate void ClientInformationEventHandler(
object sender,
ClientInformationEventArgs e
);
Managed C++ public: __gc __delegate void ClientInformationEventHandler(
Object *sender,
ClientInformationEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.ClientInformationEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ConnectCompleteEventHandler(Object,ConnectCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ConnectCompleteEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ConnectCompleteEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectCompleteEventArgs _
)
C# public sealed delegate void ConnectCompleteEventHandler(
object sender,
ConnectCompleteEventArgs e
);
Managed C++ public: __gc __delegate void ConnectCompleteEventHandler(
Object *sender,
ConnectCompleteEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.ConnectCompleteEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostQueryEventHandler(Object,FindHostQueryEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostQueryEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostQuery event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub FindHostQueryEventHandler( _
ByVal sender As Object, _
ByVal e As FindHostQueryEventArgs _
)
C# public sealed delegate void FindHostQueryEventHandler(
object sender,
FindHostQueryEventArgs e
);
Managed C++ public: __gc __delegate void FindHostQueryEventHandler(
Object *sender,
FindHostQueryEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.FindHostQueryEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FindHostResponseEventHandler(Object,FindHostResponseEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

FindHostResponseEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostResponse event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub FindHostResponseEventHandler( _
ByVal sender As Object, _
ByVal e As FindHostResponseEventArgs _
)
C# public sealed delegate void FindHostResponseEventHandler(
object sender,
FindHostResponseEventArgs e
);
Managed C++ public: __gc __delegate void FindHostResponseEventHandler(
Object *sender,
FindHostResponseEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.FindHostResponseEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupCreatedEventHandler(Object,GroupCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupCreatedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupCreated event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub GroupCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As GroupCreatedEventArgs _
)
C# public sealed delegate void GroupCreatedEventHandler(
object sender,
GroupCreatedEventArgs e
);
Managed C++ public: __gc __delegate void GroupCreatedEventHandler(
Object *sender,
GroupCreatedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.GroupCreatedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupDestroyedEventHandler(Object,GroupDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupDestroyedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupDestroyed event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub GroupDestroyedEventHandler( _
ByVal sender As Object, _
ByVal e As GroupDestroyedEventArgs _
)
C# public sealed delegate void GroupDestroyedEventHandler(
object sender,
GroupDestroyedEventArgs e
);
Managed C++ public: __gc __delegate void GroupDestroyedEventHandler(
Object *sender,
GroupDestroyedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.GroupDestroyedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GroupInformationEventHandler(Object,GroupInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

GroupInformationEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub GroupInformationEventHandler( _
ByVal sender As Object, _
ByVal e As GroupInformationEventArgs _
)
C# public sealed delegate void GroupInformationEventHandler(
object sender,
GroupInformationEventArgs e
);
Managed C++ public: __gc __delegate void GroupInformationEventHandler(
Object *sender,
GroupInformationEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.GroupInformationEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HostMigratedEventHandler(Object,HostMigratedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

HostMigratedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub HostMigratedEventHandler( _
ByVal sender As Object, _
ByVal e As HostMigratedEventArgs _
)
C# public sealed delegate void HostMigratedEventHandler(
object sender,
HostMigratedEventArgs e
);
Managed C++ public: __gc __delegate void HostMigratedEventHandler(
Object *sender,
HostMigratedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.HostMigratedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IndicateConnectEventHandler(Object,IndicateConnectEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicateConnectEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub IndicateConnectEventHandler( _
ByVal sender As Object, _
ByVal e As IndicateConnectEventArgs _
)
C# public sealed delegate void IndicateConnectEventHandler(
object sender,
IndicateConnectEventArgs e
);
Managed C++ public: __gc __delegate void IndicateConnectEventHandler(
Object *sender,
IndicateConnectEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.IndicateConnectEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IndicatedConnectAbortedEventHandler(Object,IndicatedConnectAbortedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

IndicatedConnectAbortedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub IndicatedConnectAbortedEventHandler( _
ByVal sender As Object, _
ByVal e As IndicatedConnectAbortedEventArgs _
)
C# public sealed delegate void IndicatedConnectAbortedEventHandler(
object sender,
IndicatedConnectAbortedEventArgs e
);
Managed C++ public: __gc __delegate void IndicatedConnectAbortedEventHandler(
Object *sender,
IndicatedConnectAbortedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NatResolverQueryEventHandler(Object,NatResolverQueryEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

NatResolverQueryEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the NatResolverQuery event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub NatResolverQueryEventHandler( _
ByVal sender As Object, _
ByVal e As NatResolverQueryEventArgs _
)
C# public sealed delegate void NatResolverQueryEventHandler(
object sender,
NatResolverQueryEventArgs e
);
Managed C++ public: __gc __delegate void NatResolverQueryEventHandler(
Object *sender,
NatResolverQueryEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.NatResolverQueryEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PeerInformationEventHandler(Object,PeerInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PeerInformationEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PeerInformationEventHandler( _
ByVal sender As Object, _
ByVal e As PeerInformationEventArgs _
)
C# public sealed delegate void PeerInformationEventHandler(
object sender,
PeerInformationEventArgs e
);
Managed C++ public: __gc __delegate void PeerInformationEventHandler(
Object *sender,
PeerInformationEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.PeerInformationEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerAddedToGroupEventHandler(Object,PlayerAddedToGroupEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerAddedToGroupEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerAddedToGroup event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PlayerAddedToGroupEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerAddedToGroupEventArgs _
)
C# public sealed delegate void PlayerAddedToGroupEventHandler(
object sender,
PlayerAddedToGroupEventArgs e
);
Managed C++ public: __gc __delegate void PlayerAddedToGroupEventHandler(
Object *sender,
PlayerAddedToGroupEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.PlayerAddedToGroupEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerCreatedEventHandler(Object,PlayerCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerCreatedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PlayerCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerCreatedEventArgs _
)
C# public sealed delegate void PlayerCreatedEventHandler(
object sender,
PlayerCreatedEventArgs e
);
Managed C++ public: __gc __delegate void PlayerCreatedEventHandler(
Object *sender,
PlayerCreatedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.PlayerCreatedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerDestroyedEventHandler(Object,PlayerDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerDestroyedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDestroyed event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PlayerDestroyedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerDestroyedEventArgs _
)
C# public sealed delegate void PlayerDestroyedEventHandler(
object sender,
PlayerDestroyedEventArgs e
);
Managed C++ public: __gc __delegate void PlayerDestroyedEventHandler(
Object *sender,
PlayerDestroyedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.PlayerDestroyedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PlayerRemovedFromGroupEventHandler(Object,PlayerRemovedFromGroupEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

PlayerRemovedFromGroupEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerRemovedFromGroup event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub PlayerRemovedFromGroupEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerRemovedFromGroupEventArgs _
)
C# public sealed delegate void PlayerRemovedFromGroupEventHandler(
object sender,
PlayerRemovedFromGroupEventArgs e
);
Managed C++ public: __gc __delegate void PlayerRemovedFromGroupEventHandler(
Object *sender,
PlayerRemovedFromGroupEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.PlayerRemovedFromGroupEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ReceiveEventHandler(Object,ReceiveEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ReceiveEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ReceiveEventHandler( _
ByVal sender As Object, _
ByVal e As ReceiveEventArgs _
)
C# public sealed delegate void ReceiveEventHandler(
object sender,
ReceiveEventArgs e
);
Managed C++ public: __gc __delegate void ReceiveEventHandler(
Object *sender,
ReceiveEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.ReceiveEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SendCompleteEventHandler(Object,SendCompleteEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendCompleteEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SendComplete event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub SendCompleteEventHandler( _
ByVal sender As Object, _
ByVal e As SendCompleteEventArgs _
)
C# public sealed delegate void SendCompleteEventHandler(
object sender,
SendCompleteEventArgs e
);
Managed C++ public: __gc __delegate void SendCompleteEventHandler(
Object *sender,
SendCompleteEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.SendCompleteEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ServerInformationEventHandler(Object,ServerInformationEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ServerInformationEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ServerInformationEventHandler( _
ByVal sender As Object, _
ByVal e As ServerInformationEventArgs _
)
C# public sealed delegate void ServerInformationEventHandler(
object sender,
ServerInformationEventArgs e
);
Managed C++ public: __gc __delegate void ServerInformationEventHandler(
Object *sender,
ServerInformationEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.ServerInformationEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SessionTerminatedEventHandler(Object,SessionTerminatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

SessionTerminatedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionTerminated event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub SessionTerminatedEventHandler( _
ByVal sender As Object, _
ByVal e As SessionTerminatedEventArgs _
)
C# public sealed delegate void SessionTerminatedEventHandler(
object sender,
SessionTerminatedEventArgs e
);
Managed C++ public: __gc __delegate void SessionTerminatedEventHandler(
Object *sender,
SessionTerminatedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.SessionTerminatedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ThreadCreatedEventHandler(Object,ThreadCreatedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadCreatedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadCreated event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ThreadCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As ThreadCreatedEventArgs _
)
C# public sealed delegate void ThreadCreatedEventHandler(
object sender,
ThreadCreatedEventArgs e
);
Managed C++ public: __gc __delegate void ThreadCreatedEventHandler(
Object *sender,
ThreadCreatedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.ThreadCreatedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ThreadDestroyedEventHandler(Object,ThreadDestroyedEventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ThreadDestroyedEventHandler Delegate

 Language:
Note: This documentation is preliminary and is subject to change.

Warning: This delegate is deprecated. Deprecated components of Microsoft® DirectX® 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of Microsoft® DirectX® 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadDestroyed event. Deprecated.

Definition

Visual Basic .NET Public Delegate Sub ThreadDestroyedEventHandler( _
ByVal sender As Object, _
ByVal e As ThreadDestroyedEventArgs _
)
C# public sealed delegate void ThreadDestroyedEventHandler(
object sender,
ThreadDestroyedEventArgs e
);
Managed C++ public: __gc __delegate void ThreadDestroyedEventHandler(
Object *sender,
ThreadDestroyedEventArgs *e
);
JScript .NET In JScript .NET, you can use delegates, but you cannot define your own.

Parameters

sender | System.Object.
e | Microsoft.DirectX.DirectPlay.ThreadDestroyedEventArgs.

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectSound

Note: This documentation is preliminary and is subject to change.

Microsoft® DirectSound® provides a system to capture sounds from input devices and play sounds through various playback devices using advanced 3-D positioning effects, and filters for echo, distortion, reverberation, and other effects. The following tables list the members exposed by the Microsoft.DirectX.DirectSound namespace.

Classes

AccessDeniedException | The request failed because access was denied.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
BadFormatException | The specified wave format is not supported.
BadSendBufferGuidException | The globally unique identifier (GUID) specified in an audiopath file does not match a valid mix-in buffer.
Buffer | Contains methods and properties used to manage sound buffers.
Buffer3D | Contains methods and properties used to retrieve and set parameters that describe the position, orientation, and environment of a sound buffer in 3-D space.
BufferDescription | Contains properties and methods that describe the characteristics of a new buffer object.
BufferLostException | The buffer memory has been lost and must be restored.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
Capture | Contains properties and methods used to create sound capture buffers.
CaptureAcousticEchoCancellationEffect | Represents a DirectSound capture effects object used to set and retrieve parameters on a capture buffer that supports acoustic echo cancellation. This object requires Microsoft Windows® XP or later.
CaptureBuffer | Contains properties and methods used to manipulate sound capture buffers.
CaptureDevicesCollection | Represents a collection of DeviceInformation structures for each available capture device.
CaptureNoiseSuppressEffect | Represents a DirectSound capture effects object used to set and retrieve parameters on a capture buffer that supports noise suppression. This object requires Microsoft Windows XP or later.
ChorusEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports chorus.
CompressorEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports compression.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
Device | Contains methods and properties used to create buffer objects, manage devices, and set up the environment.
DevicesCollection | Represents a collection of DeviceInformation structures for each available sound device.
DistortionEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports distortion.
DSoundHelper | Contains helper methods and fields for DirectSound.
EchoEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports echo.
EffectsUnavailableException | The effects requested could not be found on the system, or they are in the wrong order or in the wrong location; for example, an effect expected in hardware was found in software.
FlangerEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports flange.
FullDuplex | Represents a full-duplex stream.
GargleEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports amplitude modulation.
Interactive3DLevel2ReverbEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Interactive 3-D Audio Level 2 (I3DL2) reverberation effects.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
Listener3D | Retrieves and sets parameters that describe a listener's position, orientation, and listening environment in 3-D space.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given GUID is not a valid DirectSound device ID.
Notify | Sets up notification events for a playback or capture buffer.
ObjectNotFoundException | The requested object was not found.
OtherApplicationHasPriorityException | Another application has a higher priority level, preventing this call from succeeding.
ParamEqEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports parametric equalizer effects.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.
SecondaryBuffer | Contains methods and properties used to manage sound buffers that can support effects.
SendLoopException | A circular loop of send effects was detected.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.
WavesReverbEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Waves reverberation.

Enumerations

BufferDescriptionFlags | Contains constants for specifying the capabilities of sound buffers.
BufferPlayFlags | Contains constants for specifying the play behavior of the buffer.
BufferSize | Contains constants for the minimum and maximum buffer size.
CaptureEffectsReturnValue | Contains constants for a CaptureBuffer object's effects status.
CooperativeLevel | Contains constants for a Device object's cooperative level.
EffectsEnvironmentPreset | Containts constants for reverberation presets for an Interactive3DLevel2ReverbEffect object.
EffectsReturnValue | Contains constants that describe the status of an effect object returned from a SecondaryBuffer object.
EffectStatus | Contains constants that describe the success of the effect in canceling the echo using a CaptureAcousticEchoCancellationEffect object.
Frequency | Contains constants that describe the range of frequency, in samples per second, at which a software buffer can play.
LockFlag | Contains constants that describe how to lock a buffer while reading or writing to it.
Mode3D | Contains constents that describe the operation mode for 3-D sound processing.
OperationMode | Contains constants that describe the mode of a CaptureAcousticEchoCancellationEffect object.
Pan | Contains constants which describe how a buffer plays a sound in the stereo (2-channel) field.
PositionNotifyFlag | Contains constants that are used to signify types of position notifications.
Volume | Contains constants that describe the minimum and maximum volume at which a buffer can play.
WaveFormatTag | Contains constants that describe waveform-audio format types.

Structures

Angles | Contains properties that describe the inside and outside angles of the sound projection cone.
Buffer3DSettings | Contains properties that describe all the information necessary to uniquely describe the location, orientation, and motion of a 3-D sound buffer.
BufferCaps | Contains properties that describe the capabilities of a Buffer object or a SecondaryBuffer object.
BufferPositionNotify | Contains properties that describe a notification position.
BufferStatus | Contains properties that describe the status of a buffer.
Caps | Contains properties that describe the capabilities of a DirectSound Device object.
CaptureBufferCaps | Contains properties that describe the capabilities of a CaptureBuffer object.
CaptureBufferDescription | Contains properties that describe a CaptureBuffer object.
CaptureCaps | Contains properties that describes the capabilities of the capture device.
CaptureEffectDescription | Contains properties for an effect associated with a CaptureBuffer object.
CaptureEffectsAcousticEchoCancellation | Contains properties for acoustic echo cancellation in a capture buffer.
CaptureEffectsNoiseSuppress | Contains parameters for noise suppression in a capture buffer.
DeviceInformation | Contains properties that describe information about a device.
EffectDescription | Contains properties that describe an effect associated with a buffer.
EffectsChorus | Contains parameters for a chorus effect.
EffectsCompressor | Contains parameters for a compressor effect.
EffectsDistortion | Contains parameters for a distortion effect.
EffectsEcho | Contains parameters for an echo effect.
EffectsFlanger | Contains parameters for a flange effect.
EffectsGargle | Contains parameters for an amplitude modulation effect.
EffectsInteractive3DLevel2Reverb | Contains parameters for an I3DL2 (Interactive 3D Audio Level 2) reverberation effect.
EffectsParamEq | Contains parameters for a parametric equalizer effect.
EffectsWavesReverb | Contains parameters for a Waves reverberation effect.
Listener3DOrientation | Contains properties that encompass the front and top 3-D vectors for listeners orientation.
Listener3DSettings | Contains properties that describes the 3-D world parameters and the position of the listener.
Speakers | Contains properties that define various speaker configurations.
WaveFormat | Contains properties that define the format of waveform-audio data.


Microsoft.DirectX.DirectSound.AccessDeniedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AccessDeniedException Class

Language:
Note: This documentation is preliminary and is subject to change.

The request failed because access was denied.

Definition

Visual Basic .NET Public Class AccessDeniedException
Inherits SoundException
C# | public class AccessDeniedException : SoundException
Managed C++ | public __gc class AccessDeniedException : public SoundException
JScript .NET | public class AccessDeniedException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AccessDeniedException | Initializes a new instance of the AccessDeniedException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
AccessDeniedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AccessDeniedException.AccessDeniedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AccessDeniedException.AccessDeniedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AccessDeniedException class.

Overload List

public AccessDeniedException();
protected AccessDeniedException(SerializationInfo, StreamingContext);
public AccessDeniedException(string);
public AccessDeniedException(string, Exception);


AccessDeniedException.AccessDeniedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AccessDeniedException.AccessDeniedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AccessDeniedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AccessDeniedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AccessDeniedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


AccessDeniedException.AccessDeniedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AccessDeniedException.AccessDeniedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AccessDeniedException(
string message,
Exception inner
);
Managed C++ public: AccessDeniedException(
String *message,
Exception *inner
);
JScript .NET public function AccessDeniedException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


AccessDeniedException.AccessDeniedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AccessDeniedException.AccessDeniedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AccessDeniedException(
string message
);
Managed C++ public: AccessDeniedException(
String *message
);
JScript .NET public function AccessDeniedException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


AccessDeniedException.AccessDeniedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AccessDeniedException.AccessDeniedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public AccessDeniedException();
Managed C++ | public: AccessDeniedException();
JScript .NET | public function AccessDeniedException();


Microsoft.DirectX.DirectSound.AllocatedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocatedException Class

Language:
Note: This documentation is preliminary and is subject to change.

The request failed because resources, such as a priority level, were already in use by another caller.

Definition

Visual Basic .NET Public Class AllocatedException
Inherits SoundException
C# | public class AllocatedException : SoundException
Managed C++ | public __gc class AllocatedException : public SoundException
JScript .NET | public class AllocatedException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AllocatedException | Initializes a new instance of the AllocatedException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
AllocatedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


AllocatedException.AllocatedException

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocatedException.AllocatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AllocatedException class.

Overload List

public AllocatedException();
protected AllocatedException(SerializationInfo, StreamingContext);
public AllocatedException(string);
public AllocatedException(string, Exception);


AllocatedException.AllocatedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocatedException.AllocatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AllocatedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: AllocatedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function AllocatedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


AllocatedException.AllocatedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocatedException.AllocatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AllocatedException(
string message,
Exception inner
);
Managed C++ public: AllocatedException(
String *message,
Exception *inner
);
JScript .NET public function AllocatedException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


AllocatedException.AllocatedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocatedException.AllocatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public AllocatedException(
string message
);
Managed C++ public: AllocatedException(
String *message
);
JScript .NET public function AllocatedException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


AllocatedException.AllocatedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

AllocatedException.AllocatedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public AllocatedException();
Managed C++ | public: AllocatedException();
JScript .NET | public function AllocatedException();


Microsoft.DirectX.DirectSound.BadFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

BadFormatException Class

Language:
Note: This documentation is preliminary and is subject to change.

The specified wave format is not supported.

Definition

Visual Basic .NET Public Class BadFormatException
Inherits SoundException
C# | public class BadFormatException : SoundException
Managed C++ | public __gc class BadFormatException : public SoundException
JScript .NET | public class BadFormatException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BadFormatException | Initializes a new instance of the BadFormatException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BadFormatException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BadFormatException.BadFormatException

Microsoft DirectX 9.0 SDK Update (October 2004)

BadFormatException.BadFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadFormatException class.

Overload List

public BadFormatException();
protected BadFormatException(SerializationInfo, StreamingContext);
public BadFormatException(string);
public BadFormatException(string, Exception);


BadFormatException.BadFormatException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadFormatException.BadFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BadFormatException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: BadFormatException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function BadFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


BadFormatException.BadFormatException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadFormatException.BadFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BadFormatException(
string message,
Exception inner
);
Managed C++ public: BadFormatException(
String *message,
Exception *inner
);
JScript .NET public function BadFormatException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


BadFormatException.BadFormatException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadFormatException.BadFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public BadFormatException(
string message
);
Managed C++ public: BadFormatException(
String *message
);
JScript .NET public function BadFormatException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


BadFormatException.BadFormatException()

Microsoft DirectX 9.0 SDK Update (October 2004)

BadFormatException.BadFormatException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public BadFormatException();
Managed C++ | public: BadFormatException();
JScript .NET | public function BadFormatException();


Microsoft.DirectX.DirectSound.BadSendBufferGuidException

Microsoft DirectX 9.0 SDK Update (October 2004)

BadSendBufferGuidException Class

Language:
Note: This documentation is preliminary and is subject to change.

The globally unique identifier (GUID) specified in an audiopath file does not match a valid mix-in buffer.

Definition

Visual Basic .NET Public Class BadSendBufferGuidException
Inherits SoundException
C# | public class BadSendBufferGuidException : SoundException
Managed C++ | public __gc class BadSendBufferGuidException : public SoundException
JScript .NET | public class BadSendBufferGuidException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BadSendBufferGuidException | Initializes a new instance of the BadSendBufferGuidException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BadSendBufferGuidException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BadSendBufferGuidException.BadSendBufferGuidException

Microsoft DirectX 9.0 SDK Update (October 2004)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadSendBufferGuidException class.

Overload List

public BadSendBufferGuidException();
protected BadSendBufferGuidException(SerializationInfo, StreamingContext);
public BadSendBufferGuidException(string);
public BadSendBufferGuidException(string, Exception);


BadSendBufferGuidException.BadSendBufferGuidException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BadSendBufferGuidException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: BadSendBufferGuidException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function BadSendBufferGuidException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


BadSendBufferGuidException.BadSendBufferGuidException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BadSendBufferGuidException(
string message,
Exception inner
);
Managed C++ public: BadSendBufferGuidException(
String *message,
Exception *inner
);
JScript .NET public function BadSendBufferGuidException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


BadSendBufferGuidException.BadSendBufferGuidException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public BadSendBufferGuidException(
string message
);
Managed C++ public: BadSendBufferGuidException(
String *message
);
JScript .NET public function BadSendBufferGuidException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


BadSendBufferGuidException.BadSendBufferGuidException()

Microsoft DirectX 9.0 SDK Update (October 2004)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public BadSendBufferGuidException();
Managed C++ | public: BadSendBufferGuidException();
JScript .NET | public function BadSendBufferGuidException();


Microsoft.DirectX.DirectSound.Buffer

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains methods and properties used to manage sound buffers.

Definition

Visual Basic .NET Public Class Buffer
Inherits MarshalByRefObject
Implements IDisposable
C# public class Buffer : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Buffer : public MarshalByRefObject,
IDisposable
JScript .NET public class Buffer extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Buffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Buffer | Initializes a new instance of the Buffer class.
Clone | Duplicates the buffer object.
Dispose | Immediately releases the unmanaged resources used by the Buffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Buffer object to free resources before it is destroyed by the garbage collector.
GetCurrentPosition | Retrieves the position of the play and write cursors in the sound buffer.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Play | Begin playing the sound buffer, starting at the play cursor.
raise_Disposing | Raises the Buffer.Disposing event when called from within a derived class.
Read | Reads the current data in the buffer.
Restore | Restores the memory allocation for a lost sound buffer.
SetCurrentPosition | Sets the position of the play cursor, which is the point at which the next byte of data is read from the buffer.
Stop | Causes the sound buffer to stop playing.
Write | Writes data to the buffer.

Properties

Property | Description
Caps | Retrieves the capabilities of the buffer object.
Disposed | Gets a value that indicates whether the object is disposed.
Format | Retrieves or sets a description of the sound data format in the buffer.
Frequency | Retrieves or sets the frequency, in samples per second, at which the buffer is playing.
NotVirtualized | Retrieves a value that indicates whether the buffer is virtualized.
Pan | Retrieves or sets the relative volume of the left and right audio channels.
PlayPosition | Retrieves the position of the play cursor in the sound buffer.
Status | Retrieves the status of the sound buffer.
Volume | Retrieves or sets the attenuation of the sound.
WritePosition | Retrieves the position of the write cursor in the sound buffer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Buffer
SecondaryBuffer

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Buffer.Buffer

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Overload List

public Buffer(BufferDescription, Device);
public Buffer(IntPtr, Device);
public Buffer(Stream, BufferDescription, Device);
public Buffer(Stream, Device);
public Buffer(Stream, int, BufferDescription, Device);
public Buffer(Stream, int, Device);
public Buffer(string, BufferDescription, Device);
public Buffer(string, Device);

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,Int32,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
int length,
Device parent
);
Managed C++ public: Buffer(
Stream *source,
int length,
Device *parent
);
JScript .NET public function Buffer(
source : Stream,
length : int,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
length | System.Int32. An integer that represents the size of the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
Device parent
);
Managed C++ public: Buffer(
Stream *source,
Device *parent
);
JScript .NET public function Buffer(
source : Stream,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(String,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String, _
ByVal parent As Device _
)
C# public Buffer(
string fileName,
Device parent
);
Managed C++ public: Buffer(
String *fileName,
Device *parent
);
JScript .NET public function Buffer(
fileName : String,
parent : Device
);

Parameters

fileName | System.String. A String Leave Site that represents the file name of the file that contains source data for the buffer.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,BufferDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
BufferDescription desc,
Device parent
);
Managed C++ public: Buffer(
Stream *source,
BufferDescription *desc,
Device *parent
);
JScript .NET public function Buffer(
source : Stream,
desc : BufferDescription,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,Int32,BufferDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
int length,
BufferDescription desc,
Device parent
);
Managed C++ public: Buffer(
Stream *source,
int length,
BufferDescription *desc,
Device *parent
);
JScript .NET public function Buffer(
source : Stream,
length : int,
desc : BufferDescription,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
length | System.Int32. An integer that represents the size of the buffer to create.
desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(String,BufferDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
string fileName,
BufferDescription desc,
Device parent
);
Managed C++ public: Buffer(
String *fileName,
BufferDescription *desc,
Device *parent
);
JScript .NET public function Buffer(
fileName : String,
desc : BufferDescription,
parent : Device
);

Parameters

fileName | System.String. A String Leave Site that represents the file name of the file that contains source data for the buffer.
desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(IntPtr,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal parent As Device _
)
C# public Buffer(
IntPtr lp,
Device parent
);
Managed C++ public: Buffer(
IntPtr lp,
Device *parent
);
JScript .NET public function Buffer(
lp : IntPtr,
parent : Device
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundBuffer8, which allows unmanaged COM clients to create an instance of the managed buffer class. Not supported.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(BufferDescription,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Buffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
BufferDescription desc,
Device parent
);
Managed C++ public: Buffer(
BufferDescription *desc,
Device *parent
);
JScript .NET public function Buffer(
desc : BufferDescription,
parent : Device
);

Parameters

desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Clone(Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Duplicates the buffer object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal parent As Device _
) As Buffer
C# public Buffer Clone(
Device parent
);
Managed C++ public: Buffer* Clone(
Device *parent
);
JScript .NET public function Clone(
parent : Device
) : Buffer;

Parameters

parent Microsoft.DirectX.DirectSound.Device. The Device object associated with the buffer.

Return Value

Microsoft.DirectX.DirectSound.Buffer . A Buffer object that represents the cloned buffer.

Remarks

This method is not valid for buffers created with BufferCaps.ControlEffects set to true.

Initially, the duplicate buffer will have the same parameters as the original buffer. However, the application can change the parameters of each buffer independently, and each can be played or stopped without affecting the other.

Exceptions
ArgumentNullException Leave Site | The parent parameter is null.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
InvalidCallException | The method call is invalid for the current state of this object.
ArgumentException Leave Site | An invalid parameter was passed to the method.

Applies To

SecondaryBuffer


Buffer.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Buffer object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

Applies To

SecondaryBuffer

See Also

  • Buffer.Disposed
  • Buffer.Disposing


Buffer.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

SecondaryBuffer


Buffer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Buffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Buffer();
Managed C++ | ~Buffer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

SecondaryBuffer


Buffer.GetCurrentPosition(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.GetCurrentPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the position of the play and write cursors in the sound buffer.

Definition

Visual Basic .NET Public Sub GetCurrentPosition( _
ByRef currentPlayPosition As Integer, _
ByRef currentWritePosition As Integer _
)
C# public void GetCurrentPosition(
out int currentPlayPosition,
out int currentWritePosition
);
Managed C++ public: void GetCurrentPosition(
int *currentPlayPosition,
int *currentWritePosition
);
JScript .NET public function GetCurrentPosition(
currentPlayPosition : int,
currentWritePosition : int
);

Parameters

currentPlayPosition | System.Int32. An integer that receives the offset, in bytes, of the play cursor position in the sound buffer.
currentWritePosition | System.Int32. An integer that receives the offset, in bytes, of the write cursor position in the sound buffer.

Remarks

The write cursor is the point in the buffer ahead of which it is safe to write data to the buffer. Data should not be written to the part of the buffer after the play cursor and before the write cursor.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

Applies To

SecondaryBuffer


Buffer.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundBuffer8, which allows unmanaged COM clients to create an instance of the managed Buffer class. Not supported.

Applies To

SecondaryBuffer


Buffer.op_Equality(Buffer,Buffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Buffer, _
ByVal right As Buffer _
) As Boolean
C# public static bool op_Equality(
Buffer left,
Buffer right
);
Managed C++ public: static bool op_Equality(
Buffer *left,
Buffer *right
);
JScript .NET public static function op_Equality(
left : Buffer,
right : Buffer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Buffer. The Buffer object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Buffer. The Buffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

Applies To

SecondaryBuffer


Buffer.op_Inequality(Buffer,Buffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Buffer, _
ByVal right As Buffer _
) As Boolean
C# public static bool op_Inequality(
Buffer left,
Buffer right
);
Managed C++ public: static bool op_Inequality(
Buffer *left,
Buffer *right
);
JScript .NET public static function op_Inequality(
left : Buffer,
right : Buffer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Buffer. The Buffer object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Buffer. The Buffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

Applies To

SecondaryBuffer


Buffer.Play(Int32,BufferPlayFlags)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Play Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begin playing the sound buffer, starting at the play cursor.

Definition

Visual Basic .NET Public Sub Play( _
ByVal priority As Integer, _
ByVal flags As BufferPlayFlags _
)
C# public void Play(
int priority,
BufferPlayFlags flags
);
Managed C++ public: void Play(
int priority,
BufferPlayFlags flags
);
JScript .NET public function Play(
priority : int,
flags : BufferPlayFlags
);

Parameters

priority | System.Int32. An integer that represents the Priority for the sound, used by the voice manager when assigning hardware mixing resources. The lowest priority is 0, and the highest priority is 0xFFFFFFFF. If the buffer was created with the BufferCaps.LocationDefer property set to false, this value must be 0.
flags | Microsoft.DirectX.DirectSound.BufferPlayFlags. One or more BufferPlayFlags enumerated values.

Applies To

SecondaryBuffer


Buffer.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Buffer.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.

Applies To

SecondaryBuffer


Buffer.Read

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads the current data in the buffer.

Overload List

public void Read(int, Stream, int, LockFlag);
public Array Read(int, Type, LockFlag, int[]);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


Buffer.Read(Int32,Type,LockFlag,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads the current data in the buffer.

Definition

Visual Basic .NET Public Function Read( _
ByVal bufferStartingLocation As Integer, _
ByVal returnedDataType As Type, _
ByVal flag As LockFlag, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
int bufferStartingLocation,
Type returnedDataType,
LockFlag flag,
int[] ranks
);
Managed C++ public: Array* Read(
int bufferStartingLocation,
Type *returnedDataType,
LockFlag flag,
int ranks __gc[]
);
JScript .NET public function Read(
bufferStartingLocation : int,
returnedDataType : Type,
flag : LockFlag,
ranks : int[]
) : Array;

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin reading from the buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
returnedDataType | System.Type. Value that indicates the Type Leave Site of the returned array.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site of type returnDataType that contains the data read from the buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Read(Int32,Stream,Int32,LockFlag)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads the current data in the buffer.

Definition

Visual Basic .NET Public Sub Read( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToRead As Integer, _
ByVal flag As LockFlag _
)
C# public void Read(
int bufferStartingLocation,
Stream data,
int numberBytesToRead,
LockFlag flag
);
Managed C++ public: void Read(
int bufferStartingLocation,
Stream *data,
int numberBytesToRead,
LockFlag flag
);
JScript .NET public function Read(
bufferStartingLocation : int,
data : Stream,
numberBytesToRead : int,
flag : LockFlag
);

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin reading from the buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
data | System.IO.Stream. A Stream Leave Site object that receives the data read from the buffer.
numberBytesToRead | System.Int32. An integer that represents the number of bytes read into data from the buffer. The buffer is conceptually circular, so this number can exceed the number of bytes between bufferStartingLocation and the end of the buffer.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Restore()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Restore Method

 Language:
Note: This documentation is preliminary and is subject to change.

Restores the memory allocation for a lost sound buffer.

Definition

Visual Basic .NET | Public Sub Restore()
C# | public void Restore();
Managed C++ | public: void Restore();
JScript .NET | public function Restore();

Remarks

If the application does not have the input focus, Buffer.Restore might not succeed. For example, if the application with the input focus has the CooperativeLevel.WritePrimary cooperative level, no other application will be able to restore its buffers. Similarly, an application with the CooperativeLevel.WritePrimary cooperative level must have the input focus to restore its primary sound buffer.

After Microsoft® DirectSound® restores the buffer memory, the application must rewrite the buffer with valid sound data. DirectSound can only restore the memory itself, not the contents of the memory.

The application can receive notification that a buffer is lost when the following methods are called:

  • Buffer.Play
  • Buffer.Read
  • Buffer.Write

These methods throw BufferLostException to indicate a lost buffer. The Buffer.Status property can also be used to retrieve the status of the sound buffer and test the BufferStatus.BufferLost property.

Exceptions
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.SetCurrentPosition(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.SetCurrentPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the position of the play cursor, which is the point at which the next byte of data is read from the buffer.

Definition

Visual Basic .NET Public Sub SetCurrentPosition( _
ByVal newPosition As Integer _
)
C# public void SetCurrentPosition(
int newPosition
);
Managed C++ public: void SetCurrentPosition(
int newPosition
);
JScript .NET public function SetCurrentPosition(
newPosition : int
);

Parameters

newPosition System.Int32. An integer that represents the offset of the play cursor, in bytes, from the beginning of the buffer.

Remarks

This method cannot be called on the primary sound buffer.

If the buffer is playing, the cursor immediately moves to the new position and play continues from that point. If it is not playing, playback will begin from the new position the next time the Buffer.Play method is called.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Stop()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Stop Method

 Language:
Note: This documentation is preliminary and is subject to change.

Causes the sound buffer to stop playing.

Definition

Visual Basic .NET | Public Sub Stop()
C# | public void Stop();
Managed C++ | public: void Stop();
JScript .NET | public function Stop();

Remarks

For secondary sound buffers, Buffer.Stop sets the play cursor to the sample that follows the last sample played. This means that when the Buffer.Play method is next called on the buffer, it will continue playing where it left off.

For the primary buffer, if an application has the CooperativeLevel.WritePrimary level, this method will stop the buffer and reset the play cursor to 0 (the beginning of the buffer). This is necessary because the primary buffers on most sound cards can play only from the beginning of the buffer.

However, if Buffer.Stop is called on a primary buffer and the application has a cooperative level other than CooperativeLevel.WritePrimary, this method simply reverses the effects of Buffer.Play. It configures the primary buffer to stop if no secondary buffers are playing. If other buffers are playing in this or other applications, the primary buffer will not actually stop until they are stopped. This method is useful because playing the primary buffer consumes processing overhead even if the buffer is playing sound data with the amplitude of 0 decibels.

Exceptions
PriorityLevelNeededException A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Write

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes data to the buffer.

Overload List

public void Write(int, Array, LockFlag);
public void Write(int, Stream, int, LockFlag);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


Buffer.Write(Int32,Array,LockFlag)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes data to the buffer.

Definition

Visual Basic .NET Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Array, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Array data,
LockFlag flag
);
Managed C++ public: void Write(
int bufferStartingLocation,
Array *data,
LockFlag flag
);
JScript .NET public function Write(
bufferStartingLocation : int,
data : Array,
flag : LockFlag
);

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin writing into the buffer.
data | System.Array. An Array Leave Site that contains the data to write into the buffer.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Write(Int32,Stream,Int32,LockFlag)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes data to the buffer.

Definition

Visual Basic .NET Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToWrite As Integer, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Stream data,
int numberBytesToWrite,
LockFlag flag
);
Managed C++ public: void Write(
int bufferStartingLocation,
Stream *data,
int numberBytesToWrite,
LockFlag flag
);
JScript .NET public function Write(
bufferStartingLocation : int,
data : Stream,
numberBytesToWrite : int,
flag : LockFlag
);

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin writing into the buffer.
data | System.IO.Stream. A Stream Leave Site object that contains the data to write into the buffer.
numberBytesToWrite | System.Int32. An integer that represents the number of bytes to write into the buffer.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the capabilities of the buffer object.

Definition

Visual Basic .NET | Public ReadOnly Property Caps As BufferCaps
C# | public BufferCaps Caps { get; }
Managed C++ | public: __property BufferCaps get_Caps();
JScript .NET | public function get Caps() : BufferCaps

Property Value

Microsoft.DirectX.DirectSound.BufferCaps . A BufferCaps object that describes the capabilities of the buffer.

This property is read-only.

Remarks

The BufferCaps structure contains similar information to the BufferDescription class passed to the Buffer constructor, with some additional information. This additional information can include the buffer's location, either in hardware or software, and performance measures.

The BufferCaps properties are the same properties used by the BufferDescription class. The only difference is that in the BufferCaps structure, either BufferCaps.LocateInHardware or BufferCaps.LocateInSoftware will be set to true according to the location of the buffer memory. In the BufferDescription class, setting the properties are optional and, depending on which property is set, force the buffer to be located in either hardware or software.

Applies To

SecondaryBuffer


Buffer.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

SecondaryBuffer


Buffer.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a description of the sound data format in the buffer.

Definition

Visual Basic .NET | Public Property Format As WaveFormat
C# | public WaveFormat Format { get; set; }
Managed C++ public: __property WaveFormat get_Format();
public: __property void set_Format(WaveFormat);
JScript .NET public function get Format() : WaveFormat
public function set Format(WaveFormat);

Property Value

Microsoft.DirectX.DirectSound.WaveFormat . A WaveFormat object that represents the current sound data format in the buffer or sound data format values to set.

This property is read/write.

Remarks

The Buffer.Format property sets the format of the primary buffer. Whenever this application has the input focus, Microsoft® DirectSound® will set the primary buffer to the specified format.

The format of the primary buffer should be set before secondary buffers are created.

Setting the property fails if the application has the CooperativeLevel.Normal cooperative level.

If the application is using DirectSound at the CooperativeLevel.WritePrimary cooperative level, the buffer must be stopped before Buffer.Format is called to set a new WaveFormat. If the format is not supported, the method fails.

If the cooperative level is CooperativeLevel.Priority, DirectSound stops the primary buffer, changes the format, and restarts the buffer. The method succeeds even if the hardware does not support the requested format; DirectSound sets the buffer to the closest supported format. To determine whether this has happened, an application can obtain the WaveFormat object using Buffer.Format property for the primary buffer and compare the result with the format that was set using Buffer.Format property.

This property is not available for secondary sound buffers. If a new format is required, the application must create a new Buffer object.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
BadFormatException | The specified wave format is not supported.
InvalidCallException | The method call is invalid for the current state of this object.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.
UnsupportedException | The function called is not supported at this time.

Applies To

SecondaryBuffer


Buffer.Frequency

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Frequency Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the frequency, in samples per second, at which the buffer is playing.

Definition

Visual Basic .NET | Public Property Frequency As Integer
C# | public int Frequency { get; set; }
Managed C++ public: __property int get_Frequency();
public: __property void set_Frequency(int);
JScript .NET public function get Frequency() : int
public function set Frequency(int);

Property Value

System.Int32 . Value that represents the frequency, in hertz (Hz), to set or retrieve. A value of Frequency.Original resets the frequency to the default value of the buffer format.

This property is read/write.

Remarks

The frequency value for software buffers is in the range of Frequency.Min to Frequency.Max. Hardware buffers can return other values.

Increasing or decreasing the frequency changes the perceived pitch of the audio data. This property does not affect the format of the buffer.

Before setting the frequency, you should ascertain whether the frequency is supported by checking Caps.MinSecondarySampleRate and Caps.MaxSecondarySampleRate for the device. Some operating systems do not support frequencies greater than 100,000 Hz.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.NotVirtualized

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.NotVirtualized Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether the buffer is virtualized.

Definition

Visual Basic .NET | Public ReadOnly Property NotVirtualized As Boolean
C# | public bool NotVirtualized { get; }
Managed C++ | public: __property bool get_NotVirtualized();
JScript .NET | public function get NotVirtualized() : boolean

Property Value

System.Boolean . Set to true if a requested 3-D algorithm was not available and stereo panning was substituted; otherwise, false.

This property is read-only.

Remarks

If a buffer is created using one of the head-related transfer function (HRTF) algorithms and the HRTF algorithm is not available on the system (for example, a non-WDM system), Buffer.NotVirtualized is set to true.

Applies To

SecondaryBuffer


Buffer.Pan

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Pan Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the relative volume of the left and right audio channels.

Definition

Visual Basic .NET | Public Property Pan As Integer
C# | public int Pan { get; set; }
Managed C++ public: __property int get_Pan();
public: __property void set_Pan(int);
JScript .NET public function get Pan() : int
public function set Pan(int);

Property Value

System.Int32 . Value that represents the relative volume between the left and right channels, to set or retrieve.

This property is read/write.

Remarks

The value set or retrieved is measured in hundredths of a decibel (dB), in the range of Pan.Left to Pan.Right. These values are defined as -10,000 and 10,000 respectively. The value Pan.Left means the right channel is effectively silent. The value Pan.Right means the left channel is effectively silent. The neutral value is Pan.Center, defined as 0, which means that both channels are at full volume. When one channel is attenuated, the other remains at full volume.

The pan control acts cumulatively with the volume control.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.PlayPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.PlayPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the position of the play cursor in the sound buffer.

Definition

Visual Basic .NET | Public ReadOnly Property PlayPosition As Integer
C# | public int PlayPosition { get; }
Managed C++ | public: __property int get_PlayPosition();
JScript .NET | public function get PlayPosition() : int

Property Value

System.Int32 . Value that represents the position of the play cursor.

This property is read-only.

Applies To

SecondaryBuffer

See Also

  • Buffer.GetCurrentPosition
  • Buffer.SetCurrentPosition


Buffer.Status

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Status Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the status of the sound buffer.

Definition

Visual Basic .NET | Public ReadOnly Property Status As BufferStatus
C# | public BufferStatus Status { get; }
Managed C++ | public: __property BufferStatus get_Status();
JScript .NET | public function get Status() : BufferStatus

Property Value

Microsoft.DirectX.DirectSound.BufferStatus . A BufferStatus object that contains the status of the sound buffer.

This property is read-only.

Remarks

BufferStatus.Playing is set if the buffer is being heard. Because of latency, a call to Buffer.Play or Buffer.Stop might not immediately change the status.

Applies To

SecondaryBuffer


Buffer.Volume

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Volume Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the attenuation of the sound.

Definition

Visual Basic .NET | Public Property Volume As Integer
C# | public int Volume { get; set; }
Managed C++ public: __property int get_Volume();
public: __property void set_Volume(int);
JScript .NET public function get Volume() : int
public function set Volume(int);

Property Value

System.Int32 . Value that represents the attenuation, in hundredths of a decibel (dB).

This property is read/write.

Remarks

The return value is between Volume.Min and Volume.Max. These values are defined as 0 and -10,000, respectively. The value Volume.Max represents the original, unadjusted volume of the sound. The value Volume.Min indicates an audio volume attenuated by 100 dB, which, for practical purposes, is silence.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.WritePosition

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.WritePosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the position of the write cursor in the sound buffer.

Definition

Visual Basic .NET | Public ReadOnly Property WritePosition As Integer
C# | public int WritePosition { get; }
Managed C++ | public: __property int get_WritePosition();
JScript .NET | public function get WritePosition() : int

Property Value

System.Int32 . Value that represents the position of the write cursor.

This property is read-only.

Applies To

SecondaryBuffer

See Also

  • Buffer.GetCurrentPosition
  • Buffer.SetCurrentPosition


Buffer.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Buffer object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Buffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Buffer object indicates whether that object has been disposed.

Applies To

SecondaryBuffer


Microsoft.DirectX.DirectSound.Buffer3D

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains methods and properties used to retrieve and set parameters that describe the position, orientation, and environment of a sound buffer in 3-D space.

Definition

Visual Basic .NET Public Class Buffer3D
Inherits MarshalByRefObject
Implements IDisposable
C# public class Buffer3D : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Buffer3D : public MarshalByRefObject,
IDisposable
JScript .NET public class Buffer3D extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Buffer3D object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Buffer3D | Initializes a new instance of the Buffer3D class.
Dispose | Immediately releases the unmanaged resources used by the Buffer3D object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Buffer3D object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Buffer3D.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets the 3-D properties of the sound buffer.
ConeAngles | Retrieves or sets the inside and outside angles of the sound projection cone.
ConeOrientation | Retrieves or sets the orientation of the sound projection cone.
ConeOutsideVolume | Retrieves or sets the amount of attenuation to apply to the sound outside of the sound projection cone.
Deferred | Determines whether changes to the Buffer3D object are deferred or applied immediately.
Disposed | Gets a value that indicates whether the object is disposed.
MaxDistance | Retrieves or sets the maximum distance, from the listener, beyond which sounds in this buffer are no longer attenuated.
MinDistance | Retrieves or sets the minimum distance, from the listener, at which sounds in this buffer begin to be attenuated.
Mode | Retrieves or sets the operation mode for 3-D sound processing.
Position | Retrieves or sets the position of the sound source.
Velocity | Retrieves or sets the velocity of the sound source.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Buffer3D

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Buffer3D.Buffer3D

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Buffer3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer3D class.

Overload List

public Buffer3D(Buffer);
public Buffer3D(IntPtr, Buffer);
public Buffer3D(IntPtr, SecondaryBuffer);
public Buffer3D(SecondaryBuffer);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Buffer3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As SecondaryBuffer _
)
C# public Buffer3D(
IntPtr lp,
SecondaryBuffer buff
);
Managed C++ public: Buffer3D(
IntPtr lp,
SecondaryBuffer *buff
);
JScript .NET public function Buffer3D(
lp : IntPtr,
buff : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DBuffer8, which allows unmanaged COM clients to create an instance of the managed buffer class. Not supported.
buff | Microsoft.DirectX.DirectSound.SecondaryBuffer. A SecondaryBuffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(IntPtr,Buffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Buffer3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As Buffer _
)
C# public Buffer3D(
IntPtr lp,
Buffer buff
);
Managed C++ public: Buffer3D(
IntPtr lp,
Buffer *buff
);
JScript .NET public function Buffer3D(
lp : IntPtr,
buff : Buffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DBuffer8, which allows unmanaged COM clients to create an instance of the managed buffer class. Not supported.
buff | Microsoft.DirectX.DirectSound.Buffer. A Buffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Buffer3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As SecondaryBuffer _
)
C# public Buffer3D(
SecondaryBuffer lp
);
Managed C++ public: Buffer3D(
SecondaryBuffer *lp
);
JScript .NET public function Buffer3D(
lp : SecondaryBuffer
);

Parameters

lp Microsoft.DirectX.DirectSound.SecondaryBuffer. A SecondaryBuffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(Buffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Buffer3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As Buffer _
)
C# public Buffer3D(
Buffer lp
);
Managed C++ public: Buffer3D(
Buffer *lp
);
JScript .NET public function Buffer3D(
lp : Buffer
);

Parameters

lp Microsoft.DirectX.DirectSound.Buffer. A Buffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Buffer3D object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Buffer3D.Disposed
  • Buffer3D.Disposing


Buffer3D.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Buffer3D.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Buffer3D object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Buffer3D();
Managed C++ | ~Buffer3D();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Buffer3D.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Buffer3D.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DBuffer8, which allows unmanaged COM clients to create an instance of the managed Buffer3D class. Not supported.


Buffer3D.op_Equality(Buffer3D,Buffer3D)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Buffer3D, _
ByVal right As Buffer3D _
) As Boolean
C# public static bool op_Equality(
Buffer3D left,
Buffer3D right
);
Managed C++ public: static bool op_Equality(
Buffer3D *left,
Buffer3D *right
);
JScript .NET public static function op_Equality(
left : Buffer3D,
right : Buffer3D
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Buffer3D. The Buffer3D object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Buffer3D. The Buffer3D object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Buffer3D.op_Inequality(Buffer3D,Buffer3D)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Buffer3D, _
ByVal right As Buffer3D _
) As Boolean
C# public static bool op_Inequality(
Buffer3D left,
Buffer3D right
);
Managed C++ public: static bool op_Inequality(
Buffer3D *left,
Buffer3D *right
);
JScript .NET public static function op_Inequality(
left : Buffer3D,
right : Buffer3D
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Buffer3D. The Buffer3D object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Buffer3D. The Buffer3D object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Buffer3D.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Buffer3D.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Buffer3D.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the 3-D properties of the sound buffer.

Definition

Visual Basic .NET | Public Property AllParameters As Buffer3DSettings
C# | public Buffer3DSettings AllParameters { get; set; }
Managed C++ public: __property Buffer3DSettings get_AllParameters();
public: __property void set_AllParameters(Buffer3DSettings);
JScript .NET public function get AllParameters() : Buffer3DSettings
public function set AllParameters(Buffer3DSettings);

Property Value

Microsoft.DirectX.DirectSound.Buffer3DSettings . A Buffer3DSettings object that contains the information necessary to describe a 3-D sound buffer.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.ConeAngles

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.ConeAngles Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the inside and outside angles of the sound projection cone.

Definition

Visual Basic .NET | Public Property ConeAngles As Angles
C# | public Angles ConeAngles { get; set; }
Managed C++ public: __property Angles get_ConeAngles();
public: __property void set_ConeAngles(Angles);
JScript .NET public function get ConeAngles() : Angles
public function set ConeAngles(Angles);

Property Value

Microsoft.DirectX.DirectSound.Angles . An Angles structure that contains the inside and outside angles to set or retrieve.

This property is read/write.

Remarks

The minimum, maximum, and default cone angles are defined as DSoundHelper.MinConeAngle, DSoundHelper.MaxConeAngle, and DSoundHelper.DefaultConeAngle.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Sound Cones in 3-D Buffers


Buffer3D.ConeOrientation

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.ConeOrientation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the orientation of the sound projection cone.

Definition

Visual Basic .NET | Public Property ConeOrientation As Vector3
C# | public Vector3 ConeOrientation { get; set; }
Managed C++ public: __property Vector3 get_ConeOrientation();
public: __property void set_ConeOrientation(Vector3);
JScript .NET public function get ConeOrientation() : Vector3
public function set ConeOrientation(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that specifies the coordinates of the sound cone orientation in 3-D space.

This property is read/write.

Remarks

This method has no effect unless the cone angle and cone outside volume also have been set to values other than the default.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Sound Cones in 3-D Buffers


Buffer3D.ConeOutsideVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.ConeOutsideVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the amount of attenuation to apply to the sound outside of the sound projection cone.

Definition

Visual Basic .NET | Public Property ConeOutsideVolume As Integer
C# | public int ConeOutsideVolume { get; set; }
Managed C++ public: __property int get_ConeOutsideVolume();
public: __property void set_ConeOutsideVolume(int);
JScript .NET public function get ConeOutsideVolume() : int
public function set ConeOutsideVolume(int);

Property Value

System.Int32 . Value that represents the attenuation, in hundredths of a decibel (dB).

This property is read/write.

Remarks

Volume levels are expressed as attenuation, in hundredths of a decibel. Allowable values are between Volume.Max (no attenuation) and Volume.Min (silence). The default value is DSoundHelper.DefaultConeOutsideVolume (no attenuation). Microsoft® DirectSound® does not support amplification.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Sound Cones in 3-D Buffers


Buffer3D.Deferred

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Deferred Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether changes to the Buffer3D object are deferred or applied immediately.

Definition

Visual Basic .NET | Public Property Deferred As Boolean
C# | public bool Deferred { get; set; }
Managed C++ public: __property bool get_Deferred();
public: __property void set_Deferred(bool);
JScript .NET public function get Deferred() : boolean
public function set Deferred(boolean);

Property Value

System.Boolean . Set to true for deferred operations, or false to apply setting changes immediately.

This property is read/write.

Remarks

The default value is false. Settings are applied immediately, causing the system to recalculate the 3-D coordinates for all 3-D sound buffers.

Every change to 3-D sound buffer and listener settings causes remixing, at the expense of CPU cycles. To minimize the performance impact of changing 3-D settings, use deferred operations (set to true) to allow the application to change several settings and generate a single recalculation. To commit deferred operations, call Listener3D.CommitDeferredSettings.

See Also

  • Listener3D


Buffer3D.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Buffer3D.MaxDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.MaxDistance Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the maximum distance, from the listener, beyond which sounds in this buffer are no longer attenuated.

Definition

Visual Basic .NET | Public Property MaxDistance As Single
C# | public float MaxDistance { get; set; }
Managed C++ public: __property float get_MaxDistance();
public: __property void set_MaxDistance(float);
JScript .NET public function get MaxDistance() : float
public function set MaxDistance(float);

Property Value

System.Single . Maximum distance in meters to set or retrieve.

This property is read/write.

Remarks

The default maximum distance, defined as DSoundHelper.DefaultMaxDistance, is effectively infinite.

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Buffer3D.MinDistance


Buffer3D.MinDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.MinDistance Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the minimum distance, from the listener, at which sounds in this buffer begin to be attenuated.

Definition

Visual Basic .NET | Public Property MinDistance As Single
C# | public float MinDistance { get; set; }
Managed C++ public: __property float get_MinDistance();
public: __property void set_MinDistance(float);
JScript .NET public function get MinDistance() : float
public function set MinDistance(float);

Property Value

System.Single . Minimum distance in meters to set or retrieve.

This property is read/write.

Remarks

The default minimum distance, DSoundHelper.DefaultMinDistance, is defined as 1.0 (corresponding to 1.0 meter at the default distance factor of 1.0 meters per unit).

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Buffer3D.MaxDistance


Buffer3D.Mode

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Mode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the operation mode for 3-D sound processing.

Definition

Visual Basic .NET | Public Property Mode As Mode3D
C# | public Mode3D Mode { get; set; }
Managed C++ public: __property Mode3D get_Mode();
public: __property void set_Mode(Mode3D);
JScript .NET public function get Mode() : Mode3D
public function set Mode(Mode3D);

Property Value

Microsoft.DirectX.DirectSound.Mode3D . Value of the Mode3D enumeration that represents the sound processing mode to set or retrieve.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position of the sound source.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that specifies the coordinates of the sound source in 3-D space.

This property is read/write.

Remarks

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.Velocity

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Velocity Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the velocity of the sound source.

Definition

Visual Basic .NET | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
Managed C++ public: __property Vector3 get_Velocity();
public: __property void set_Velocity(Vector3);
JScript .NET public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3 . A Vector3 object that specifies the coordinates of the sound source's velocity vector, in meters per second by default.

This property is read/write.

Remarks

Velocity is used for Doppler effects only. It does not actually move the buffer.

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3D.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Buffer3D object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Buffer3D.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Buffer3D object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.BufferDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains properties and methods that describe the characteristics of a new buffer object.

Definition

Visual Basic .NET Public Class BufferDescription
Inherits MarshalByRefObject
Implements IDisposable
C# public class BufferDescription : MarshalByRefObject,
IDisposable
Managed C++ public __gc class BufferDescription : public MarshalByRefObject,
IDisposable
JScript .NET public class BufferDescription extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferDescription | Initializes a new instance of the BufferDescription class.
Dispose | Immediately releases the unmanaged resources used by the BufferDescription object.
Finalize | Allows the BufferDescription object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
BufferBytes | Retrieves or sets the size of the new buffer.
CanGetCurrentPosition | Determines whether the application can get a more accurate play cursor.
Control3D | Determines whether the buffer has 3-D control capability.
ControlEffects | Specifies whether the buffer supports effects processing.
ControlFrequency | Specifies whether the buffer has frequency control capability.
ControlPan | Specifies whether the buffer has pan control capability.
ControlPositionNotify | Specifies whether the buffer has position notification capability.
ControlVolume | Specifies whether the buffer has volume control capability.
DeferLocation | Specifies whether the buffer can be assigned to a hardware or software resource at play time.
Flags | Retrieves or sets the capabilities of the buffer.
Format | Retrieves or sets the the waveform format for the buffer.
GlobalFocus | Specifies whether the buffer is a global sound buffer.
Guid3DAlgorithm | Retrieves or sets the unique identifier of the two-speaker virtualization algorithm to be used by DirectSound3D hardware emulation.
LocateInHardware | Specifies whether the buffer must use hardware mixing.
LocateInSoftware | Specifies whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.
Mute3DAtMaximumDistance | Specifies whether the sound is reduced to silence at the maximum distance.
PrimaryBuffer | Specifies whether the buffer is a primary sound buffer.
StaticBuffer | Specifies whether the buffer is placed in on-board hardware memory, if available.
StickyFocus | Specifies whether the buffer has sticky focus.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BufferDescription

Remarks

When creating a primary buffer, applications must set the BufferBytes member to zero. Microsoft® DirectSound® will determine the best buffer size for the particular sound device in use. To determine the size of a created primary buffer, check the BufferBytes property of the BufferCaps structure for the primary buffer.

On virtual device drivers (VxD), a sound buffer created with ControlPositionNotify is always a software buffer, because the VxD driver model does not support notifications. With Windows Driver Model (WDM) drivers, a notification-enabled buffer can be in hardware, if hardware resources are available.

The LocateInHardware and LocateInSoftware flags are optional and mutually exclusive. LocateInHardware forces the buffer to reside in hardware, meaning that it will be mixed by the sound card. LocateInSoftware forces the buffer to reside in software, where it is mixed by the CPU.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BufferDescription.BufferDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.BufferDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferDescription class.

Overload List

public BufferDescription();
public BufferDescription(WaveFormat);


BufferDescription.BufferDescription(WaveFormat)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.BufferDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferDescription class.

Definition

Visual Basic .NET Public Sub New( _
ByVal wfx As WaveFormat _
)
C# public BufferDescription(
WaveFormat wfx
);
Managed C++ public: BufferDescription(
WaveFormat wfx
);
JScript .NET public function BufferDescription(
wfx : WaveFormat
);

Parameters

wfx Microsoft.DirectX.DirectSound.WaveFormat. A WaveFormat object that defines the format of waveform-audio data.


BufferDescription.BufferDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.BufferDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferDescription class.

Definition

Visual Basic .NET | Public Sub New()
C# | public BufferDescription();
Managed C++ | public: BufferDescription();
JScript .NET | public function BufferDescription();


BufferDescription.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the BufferDescription object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();


BufferDescription.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the BufferDescription object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~BufferDescription();
Managed C++ | ~BufferDescription();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


BufferDescription.BufferBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.BufferBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the size of the new buffer.

Definition

Visual Basic .NET | Public Property BufferBytes As Integer
C# | public int BufferBytes { get; set; }
Managed C++ public: __property int get_BufferBytes();
public: __property void set_BufferBytes(int);
JScript .NET public function get BufferBytes() : int
public function set BufferBytes(int);

Property Value

System.Int32 . Value that represents the size of the new buffer, in bytes, to set or retrieve.

This property is read/write.

Remarks

This value must be 0 when creating a buffer with BufferDescription.PrimaryBuffer set to true.


BufferDescription.CanGetCurrentPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.CanGetCurrentPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the application can get a more accurate play cursor.

Definition

Visual Basic .NET | Public Property CanGetCurrentPosition As Boolean
C# | public bool CanGetCurrentPosition { get; set; }
Managed C++ public: __property bool get_CanGetCurrentPosition();
public: __property void set_CanGetCurrentPosition(bool);
JScript .NET public function get CanGetCurrentPosition() : boolean
public function set CanGetCurrentPosition(boolean);

Property Value

System.Boolean . This value is set to true if the application can get a more accurate play cursor from the buffer; otherwise, false.

This property is read/write.

Remarks

The Buffer.GetCurrentPosition method uses the new behavior of the play cursor. In Microsoft® DirectSound® included with Microsoft DirectX® 1, the play cursor was significantly ahead of the actual playing sound on emulated sound cards; it was directly behind the write cursor. Now, if CanGetCurrentPosition is set to true, the application can get a more accurate play cursor. If this property is set to false, the old behavior is preserved for compatibility.

CanGetCurrentPosition affects only emulated sound cards. If a DirectSound driver is present, the play cursor is accurate for DirectSound in all versions of DirectX.


BufferDescription.Control3D

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.Control3D Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the buffer has 3-D control capability.

Definition

Visual Basic .NET | Public Property Control3D As Boolean
C# | public bool Control3D { get; set; }
Managed C++ public: __property bool get_Control3D();
public: __property void set_Control3D(bool);
JScript .NET public function get Control3D() : boolean
public function set Control3D(boolean);

Property Value

System.Boolean . This value is set to true if the buffer has 3-D control capability; otherwise, false.

This property is read/write.

Remarks

BufferDescription.Control3D cannot be combined with BufferDescription.ControlPan, and cannot be set for a buffer with a stereo format in WaveFormat.


BufferDescription.ControlEffects

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.ControlEffects Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer supports effects processing.

Definition

Visual Basic .NET | Public Property ControlEffects As Boolean
C# | public bool ControlEffects { get; set; }
Managed C++ public: __property bool get_ControlEffects();
public: __property void set_ControlEffects(bool);
JScript .NET public function get ControlEffects() : boolean
public function set ControlEffects(boolean);

Property Value

System.Boolean . This value is set to true if the buffer supports effects processing; otherwise, false.

This property is read/write.

Remarks

The format in WaveFormat must be an 8-bit or 16-bit PCM format with no more than two channels, and the buffer must be large enough to hold at least BufferSize.EffectsMin milliseconds of data.


BufferDescription.ControlFrequency

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.ControlFrequency Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer has frequency control capability.

Definition

Visual Basic .NET | Public Property ControlFrequency As Boolean
C# | public bool ControlFrequency { get; set; }
Managed C++ public: __property bool get_ControlFrequency();
public: __property void set_ControlFrequency(bool);
JScript .NET public function get ControlFrequency() : boolean
public function set ControlFrequency(boolean);

Property Value

System.Boolean . This value is set to true if the buffer has frequency control capability; otherwise, false.

This property is read/write.


BufferDescription.ControlPan

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.ControlPan Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer has pan control capability.

Definition

Visual Basic .NET | Public Property ControlPan As Boolean
C# | public bool ControlPan { get; set; }
Managed C++ public: __property bool get_ControlPan();
public: __property void set_ControlPan(bool);
JScript .NET public function get ControlPan() : boolean
public function set ControlPan(boolean);

Property Value

System.Boolean . This value is set to true if the buffer has pan control capability; otherwise, false.

This property is read/write.

Remarks

BufferDescription.ControlPan cannot be combined with BufferDescription.Control3D.


BufferDescription.ControlPositionNotify

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.ControlPositionNotify Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer has position notification capability.

Definition

Visual Basic .NET | Public Property ControlPositionNotify As Boolean
C# | public bool ControlPositionNotify { get; set; }
Managed C++ public: __property bool get_ControlPositionNotify();
public: __property void set_ControlPositionNotify(bool);
JScript .NET public function get ControlPositionNotify() : boolean
public function set ControlPositionNotify(boolean);

Property Value

System.Boolean . This value is set to true if the buffer has position notification capability; otherwise, false.

This property is read/write.

Remarks

Because the virtual device driver model (VXD) does not support notifications, a sound buffer created with BufferDescription.ControlPositionNotify set to true is always a software buffer when using VXD drivers. With the Windows Driver Model (WDM), a notification-enabled buffer can be in hardware, if hardware resources are available.


BufferDescription.ControlVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.ControlVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer has volume control capability.

Definition

Visual Basic .NET | Public Property ControlVolume As Boolean
C# | public bool ControlVolume { get; set; }
Managed C++ public: __property bool get_ControlVolume();
public: __property void set_ControlVolume(bool);
JScript .NET public function get ControlVolume() : boolean
public function set ControlVolume(boolean);

Property Value

System.Boolean . This value is set to true if the buffer has volume control capability; otherwise, false.

This property is read/write.


BufferDescription.DeferLocation

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.DeferLocation Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer can be assigned to a hardware or software resource at play time.

Definition

Visual Basic .NET | Public Property DeferLocation As Boolean
C# | public bool DeferLocation { get; set; }
Managed C++ public: __property bool get_DeferLocation();
public: __property void set_DeferLocation(bool);
JScript .NET public function get DeferLocation() : boolean
public function set DeferLocation(boolean);

Property Value

System.Boolean . This value is set to true if if the buffer can be assigned to a hardware or software resource at play time; otherwise, false.

This property is read/write.

Remarks

Note: This property must be set for buffers that use voice management.


BufferDescription.Flags

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.Flags Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the capabilities of the buffer.

Definition

Visual Basic .NET | Public Property Flags As BufferDescriptionFlags
C# | public BufferDescriptionFlags Flags { get; set; }
Managed C++ public: __property BufferDescriptionFlags get_Flags();
public: __property void set_Flags(BufferDescriptionFlags);
JScript .NET public function get Flags() : BufferDescriptionFlags
public function set Flags(BufferDescriptionFlags);

Property Value

Microsoft.DirectX.DirectSound.BufferDescriptionFlags . A bitwise OR combination of BufferDescriptionFlags enumeration values that describes the capabilities of the buffer.

This property is read/write.


BufferDescription.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the the waveform format for the buffer.

Definition

Visual Basic .NET | Public Property Format As WaveFormat
C# | public WaveFormat Format { get; set; }
Managed C++ public: __property WaveFormat get_Format();
public: __property void set_Format(WaveFormat);
JScript .NET public function get Format() : WaveFormat
public function set Format(WaveFormat);

Property Value

Microsoft.DirectX.DirectSound.WaveFormat . A WaveFormat structure that contains a description of the waveform format that is used by the buffer.

This property is read/write.


BufferDescription.GlobalFocus

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.GlobalFocus Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer is a global sound buffer.

Definition

Visual Basic .NET | Public Property GlobalFocus As Boolean
C# | public bool GlobalFocus { get; set; }
Managed C++ public: __property bool get_GlobalFocus();
public: __property void set_GlobalFocus(bool);
JScript .NET public function get GlobalFocus() : boolean
public function set GlobalFocus(boolean);

Property Value

System.Boolean . This value is set to true if the buffer is a global buffer; otherwise, false.

This property is read/write.

Remarks

With GlobalFocus set to true, an application using Microsoft® DirectSound® can continue to play its buffers if the user switches focus to another application, even if the new application uses DirectSound. The one exception is that the global sounds from other applications will not be audible if you switch focus to a DirectSound application that uses the CooperativeLevel.WritePrimary flag for its cooperative level.


BufferDescription.Guid3DAlgorithm

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.Guid3DAlgorithm Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the unique identifier of the two-speaker virtualization algorithm to be used by DirectSound3D hardware emulation.

Definition

Visual Basic .NET | Public Property Guid3DAlgorithm As Guid
C# | public Guid Guid3DAlgorithm { get; set; }
Managed C++ public: __property Guid get_Guid3DAlgorithm();
public: __property void set_Guid3DAlgorithm(Guid);
JScript .NET public function get Guid3DAlgorithm() : Guid
public function set Guid3DAlgorithm(Guid);

Property Value

System.Guid . A Guid Leave Site that represents the algorithm identifier to set or retrieve.

This property is read/write.

Remarks

Use the Guid Leave Site fields in the DSoundHelper class to obtain a virtualization algorithm's Guid Leave Site to set in this method.


BufferDescription.LocateInHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.LocateInHardware Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer must use hardware mixing.

Definition

Visual Basic .NET | Public Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; set; }
Managed C++ public: __property bool get_LocateInHardware();
public: __property void set_LocateInHardware(bool);
JScript .NET public function get LocateInHardware() : boolean
public function set LocateInHardware(boolean);

Property Value

System.Boolean . This value is set to true if the buffer must use hardware mixing; otherwise, false.

This property is read/write.

Remarks

If an attempt is made to create a Buffer or SecondaryBuffer with BufferDescription.LocateInHardware set to true on a system where hardware acceleration is not available, the constructor method will fail.

The application must ensure that a mixing channel is available for the buffer.

If neither BufferDescription.LocateInHardware nor BufferDescription.LocateInSoftware is specified, the buffer is placed in hardware if resources are available, or in software if hardware resources are not available. Hardware buffers are not supported in 64-bit operating systems.


BufferDescription.LocateInSoftware

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.LocateInSoftware Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.

Definition

Visual Basic .NET | Public Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; set; }
Managed C++ public: __property bool get_LocateInSoftware();
public: __property void set_LocateInSoftware(bool);
JScript .NET public function get LocateInSoftware() : boolean
public function set LocateInSoftware(boolean);

Property Value

System.Boolean . This value is set to true if the buffer must use software mixing; otherwise, false.

This property is read/write.


BufferDescription.Mute3DAtMaximumDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.Mute3DAtMaximumDistance Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the sound is reduced to silence at the maximum distance.

Definition

Visual Basic .NET | Public Property Mute3DAtMaximumDistance As Boolean
C# | public bool Mute3DAtMaximumDistance { get; set; }
Managed C++ public: __property bool get_Mute3DAtMaximumDistance();
public: __property void set_Mute3DAtMaximumDistance(bool);
JScript .NET public function get Mute3DAtMaximumDistance() : boolean
public function set Mute3DAtMaximumDistance(boolean);

Property Value

System.Boolean . This value is set to true to mute sound at the maximum distance; otherwise, false.

This property is read/write.

Remarks

The buffer will stop playing when the maximum distance is exceeded, so that processor time is not wasted. Applies only to software buffers.


BufferDescription.PrimaryBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.PrimaryBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer is a primary sound buffer.

Definition

Visual Basic .NET | Public Property PrimaryBuffer As Boolean
C# | public bool PrimaryBuffer { get; set; }
Managed C++ public: __property bool get_PrimaryBuffer();
public: __property void set_PrimaryBuffer(bool);
JScript .NET public function get PrimaryBuffer() : boolean
public function set PrimaryBuffer(boolean);

Property Value

System.Boolean . This value is set to true if the buffer is a primary sound buffer; otherwise, false.

This property is read/write.

Remarks

This property cannot be combined with BufferDescription.ControlEffects.


BufferDescription.StaticBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.StaticBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer is placed in on-board hardware memory, if available.

Definition

Visual Basic .NET | Public Property StaticBuffer As Boolean
C# | public bool StaticBuffer { get; set; }
Managed C++ public: __property bool get_StaticBuffer();
public: __property void set_StaticBuffer(bool);
JScript .NET public function get StaticBuffer() : boolean
public function set StaticBuffer(boolean);

Property Value

System.Boolean . This value is set to true if the buffer is a static buffer; otherwise, false.

This property is read/write.

Remarks

No error occurs if on-board hardware memory is not available. This flag has no effect on cards using the peripheral component interconnect (PCI) bus.

This property cannot be combined with BufferDescription.ControlEffects.


BufferDescription.StickyFocus

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescription.StickyFocus Property

Language:
Note: This documentation is preliminary and is subject to change.

Specifies whether the buffer has sticky focus.

Definition

Visual Basic .NET | Public Property StickyFocus As Boolean
C# | public bool StickyFocus { get; set; }
Managed C++ public: __property bool get_StickyFocus();
public: __property void set_StickyFocus(bool);
JScript .NET public function get StickyFocus() : boolean
public function set StickyFocus(boolean);

Property Value

System.Boolean . This value is set to true if the buffer has sticky focus; otherwise, false.

This property is read/write.

Remarks

If the user switches to another application not using Microsoft® DirectSound®, the application's normal buffers are muted, but sticky focus buffers are still audible.


Microsoft.DirectX.DirectSound.BufferLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferLostException Class

Language:
Note: This documentation is preliminary and is subject to change.

The buffer memory has been lost and must be restored.

Definition

Visual Basic .NET Public Class BufferLostException
Inherits SoundException
C# | public class BufferLostException : SoundException
Managed C++ | public __gc class BufferLostException : public SoundException
JScript .NET | public class BufferLostException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BufferLostException | Initializes a new instance of the BufferLostException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BufferLostException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BufferLostException.BufferLostException

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferLostException.BufferLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferLostException class.

Overload List

public BufferLostException();
protected BufferLostException(SerializationInfo, StreamingContext);
public BufferLostException(string);
public BufferLostException(string, Exception);


BufferLostException.BufferLostException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferLostException.BufferLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BufferLostException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: BufferLostException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function BufferLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


BufferLostException.BufferLostException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferLostException.BufferLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BufferLostException(
string message,
Exception inner
);
Managed C++ public: BufferLostException(
String *message,
Exception *inner
);
JScript .NET public function BufferLostException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


BufferLostException.BufferLostException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferLostException.BufferLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public BufferLostException(
string message
);
Managed C++ public: BufferLostException(
String *message
);
JScript .NET public function BufferLostException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


BufferLostException.BufferLostException()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferLostException.BufferLostException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public BufferLostException();
Managed C++ | public: BufferLostException();
JScript .NET | public function BufferLostException();


Microsoft.DirectX.DirectSound.BufferTooSmallException

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferTooSmallException Class

Language:
Note: This documentation is preliminary and is subject to change.

The buffer size is not large enough to enable effects processing.

Definition

Visual Basic .NET Public Class BufferTooSmallException
Inherits SoundException
C# | public class BufferTooSmallException : SoundException
Managed C++ | public __gc class BufferTooSmallException : public SoundException
JScript .NET | public class BufferTooSmallException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BufferTooSmallException | Initializes a new instance of the BufferTooSmallException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BufferTooSmallException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


BufferTooSmallException.BufferTooSmallException

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferTooSmallException.BufferTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferTooSmallException class.

Overload List

public BufferTooSmallException();
protected BufferTooSmallException(SerializationInfo, StreamingContext);
public BufferTooSmallException(string);
public BufferTooSmallException(string, Exception);


BufferTooSmallException.BufferTooSmallException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferTooSmallException.BufferTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BufferTooSmallException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: BufferTooSmallException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function BufferTooSmallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


BufferTooSmallException.BufferTooSmallException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferTooSmallException.BufferTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BufferTooSmallException(
string message,
Exception inner
);
Managed C++ public: BufferTooSmallException(
String *message,
Exception *inner
);
JScript .NET public function BufferTooSmallException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


BufferTooSmallException.BufferTooSmallException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferTooSmallException.BufferTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public BufferTooSmallException(
string message
);
Managed C++ public: BufferTooSmallException(
String *message
);
JScript .NET public function BufferTooSmallException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


BufferTooSmallException.BufferTooSmallException()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferTooSmallException.BufferTooSmallException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public BufferTooSmallException();
Managed C++ | public: BufferTooSmallException();
JScript .NET | public function BufferTooSmallException();


Microsoft.DirectX.DirectSound.Capture

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains properties and methods used to create sound capture buffers.

Definition

Visual Basic .NET Public Class Capture
Inherits MarshalByRefObject
Implements IDisposable
C# public class Capture : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Capture : public MarshalByRefObject,
IDisposable
JScript .NET public class Capture extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Capture object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Capture | Initializes a new instance of the Capture class using the default Microsoft DirectSound® capture device.
Dispose | Immediately releases the unmanaged resources used by the Capture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Capture object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Capture.Disposing event when called from within a derived class.

Properties

Property | Description
Caps | Retrieves the capabilities of the capture device.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Capture

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Capture.Capture

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Capture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Capture class using the default Microsoft® DirectSound® capture device.

Overload List

public Capture();
public Capture(Guid);
public Capture(IntPtr);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Capture(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Capture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Capture class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr _
)
C# public Capture(
IntPtr lp
);
Managed C++ public: Capture(
IntPtr lp
);
JScript .NET public function Capture(
lp : IntPtr
);

Parameters

lp System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCapture8, which allows unmanaged COM clients to create an instance of the managed Capture class. Not supported.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Capture(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Capture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Capture class using the Microsoft® DirectSound® capture device specified by its device globally unique identifier (GUID).

Definition

Visual Basic .NET Public Sub New( _
ByVal guidDev As Guid _
)
C# public Capture(
Guid guidDev
);
Managed C++ public: Capture(
Guid guidDev
);
JScript .NET public function Capture(
guidDev : Guid
);

Parameters

guidDev System.Guid. The Microsoft® DirectSound® capture device's globally unique identifier (GUID).

Remarks

To get a capture device's globally unique identifier (GUID), first enumerate the devices using the CaptureDevicesCollection object. Then get the GUID from the DriverGuid property of the DeviceInformation structure of the device you want to use.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Capture()

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Capture Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Capture class using the default Microsoft® DirectSound® capture device.

Definition

Visual Basic .NET | Public Sub New()
C# | public Capture();
Managed C++ | public: Capture();
JScript .NET | public function Capture();

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Capture object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Capture.Disposed
  • Capture.Disposing


Capture.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Capture.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Capture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Capture();
Managed C++ | ~Capture();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Capture.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Capture.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCapture8 , which allows unmanaged COM clients to create an instance of the managed Capture class. Not supported.


Capture.op_Equality(Capture,Capture)

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Capture, _
ByVal right As Capture _
) As Boolean
C# public static bool op_Equality(
Capture left,
Capture right
);
Managed C++ public: static bool op_Equality(
Capture *left,
Capture *right
);
JScript .NET public static function op_Equality(
left : Capture,
right : Capture
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Capture. The Capture object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Capture. The Capture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Capture.op_Inequality(Capture,Capture)

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Capture, _
ByVal right As Capture _
) As Boolean
C# public static bool op_Inequality(
Capture left,
Capture right
);
Managed C++ public: static bool op_Inequality(
Capture *left,
Capture *right
);
JScript .NET public static function op_Inequality(
left : Capture,
right : Capture
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Capture. The Capture object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Capture. The Capture object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Capture.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Capture.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Capture.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the capabilities of the capture device.

Definition

Visual Basic .NET | Public ReadOnly Property Caps As CaptureCaps
C# | public CaptureCaps Caps { get; }
Managed C++ | public: __property CaptureCaps get_Caps();
JScript .NET | public function get Caps() : CaptureCaps

Property Value

Microsoft.DirectX.DirectSound.CaptureCaps . The capabilities of the capture device.

This property is read-only.


Capture.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Capture.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Capture.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Capture object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Capture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Capture object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect Class

Language:
Note: This documentation is preliminary and is subject to change.

Represents a Microsoft® DirectSound® capture effects object used to set and retrieve parameters on a capture buffer that supports acoustic echo cancellation. This object requires Microsoft® Windows® XP or later.

Definition

Visual Basic .NET Public Class CaptureAcousticEchoCancellationEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class CaptureAcousticEchoCancellationEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class CaptureAcousticEchoCancellationEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class CaptureAcousticEchoCancellationEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CaptureAcousticEchoCancellationEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the CaptureAcousticEchoCancellationEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CaptureAcousticEchoCancellationEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CaptureAcousticEchoCancellationEffect.Disposing event when called from within a derived class.
Reset | Resets the effect to its initial state.

Properties

Property | Description
AllParameters | Retrieves or sets capture acoustic echo cancellation parameters of a CaptureBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.
Status | Retrieves the status of the capture acoustic echo cancellation effect.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
CaptureAcousticEchoCancellationEffect

Remarks

Obtain this object by calling the GetObjectInPath method of a CaptureBuffer object that is using the effect.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CaptureAcousticEchoCancellationEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the CaptureAcousticEchoCancellationEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • CaptureAcousticEchoCancellationEffect.Disposed
  • CaptureAcousticEchoCancellationEffect.Disposing


CaptureAcousticEchoCancellationEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CaptureAcousticEchoCancellationEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the CaptureAcousticEchoCancellationEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~CaptureAcousticEchoCancellationEffect();
Managed C++ | ~CaptureAcousticEchoCancellationEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


CaptureAcousticEchoCancellationEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


CaptureAcousticEchoCancellationEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureFXAec8, which allows unmanaged COM clients to create an instance of the managed CaptureAcousticEchoCancellationEffect class. Not supported.


CaptureAcousticEchoCancellationEffect.op_Equality(CaptureAcousticEchoCancellationEffect,CaptureAcousticEchoCancellationEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As CaptureAcousticEchoCancellationEffect, _
ByVal right As CaptureAcousticEchoCancellationEffect _
) As Boolean
C# public static bool op_Equality(
CaptureAcousticEchoCancellationEffect left,
CaptureAcousticEchoCancellationEffect right
);
Managed C++ public: static bool op_Equality(
CaptureAcousticEchoCancellationEffect *left,
CaptureAcousticEchoCancellationEffect *right
);
JScript .NET public static function op_Equality(
left : CaptureAcousticEchoCancellationEffect,
right : CaptureAcousticEchoCancellationEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect. The CaptureAcousticEchoCancellationEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect. The CaptureAcousticEchoCancellationEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CaptureAcousticEchoCancellationEffect.op_Inequality(CaptureAcousticEchoCancellationEffect,CaptureAcousticEchoCancellationEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As CaptureAcousticEchoCancellationEffect, _
ByVal right As CaptureAcousticEchoCancellationEffect _
) As Boolean
C# public static bool op_Inequality(
CaptureAcousticEchoCancellationEffect left,
CaptureAcousticEchoCancellationEffect right
);
Managed C++ public: static bool op_Inequality(
CaptureAcousticEchoCancellationEffect *left,
CaptureAcousticEchoCancellationEffect *right
);
JScript .NET public static function op_Inequality(
left : CaptureAcousticEchoCancellationEffect,
right : CaptureAcousticEchoCancellationEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect. The CaptureAcousticEchoCancellationEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect. The CaptureAcousticEchoCancellationEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


CaptureAcousticEchoCancellationEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the CaptureAcousticEchoCancellationEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


CaptureAcousticEchoCancellationEffect.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the effect to its initial state.

Definition

Visual Basic .NET | Public Sub Reset()
C# | public void Reset();
Managed C++ | public: void Reset();
JScript .NET | public function Reset();

Remarks

Applications should not reset an effect except when necessary because it has entered an incorrect state. This might be done in response to user input. An effect must not be reset arbitrarily at start-up, because another application might be using the same effect.


CaptureAcousticEchoCancellationEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets capture acoustic echo cancellation parameters of a CaptureBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As CaptureEffectsAcousticEchoCancellation
C# | public CaptureEffectsAcousticEchoCancellation AllParameters { get; set; }
Managed C++ public: __property CaptureEffectsAcousticEchoCancellation get_AllParameters();
public: __property void set_AllParameters(CaptureEffectsAcousticEchoCancellation);
JScript .NET public function get AllParameters() : CaptureEffectsAcousticEchoCancellation
public function set AllParameters(CaptureEffectsAcousticEchoCancellation);

Property Value

Microsoft.DirectX.DirectSound.CaptureEffectsAcousticEchoCancellation . Contains parameters for capture acoustic echo cancellation effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


CaptureAcousticEchoCancellationEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


CaptureAcousticEchoCancellationEffect.Status

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.Status Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the status of the capture acoustic echo cancellation effect.

Definition

Visual Basic .NET | Public ReadOnly Property Status As EffectStatus
C# | public EffectStatus Status { get; }
Managed C++ | public: __property EffectStatus get_Status();
JScript .NET | public function get Status() : EffectStatus

Property Value

Microsoft.DirectX.DirectSound.EffectStatus . The capture acoustic echo cancellation effect.

This property is read-only.


CaptureAcousticEchoCancellationEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureAcousticEchoCancellationEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the CaptureAcousticEchoCancellationEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CaptureAcousticEchoCancellationEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CaptureAcousticEchoCancellationEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.CaptureBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains properties and methods used to manipulate sound capture buffers.

Definition

Visual Basic .NET Public Class CaptureBuffer
Inherits Object
C# | public class CaptureBuffer : Object
Managed C++ | public __gc class CaptureBuffer : public Object
JScript .NET | public class CaptureBuffer extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CaptureBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
CaptureBuffer | Initializes a new instance of the CaptureBuffer class.
Dispose | Immediately releases the unmanaged resources used by the CaptureBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CaptureBuffer object to free resources before it is destroyed by the garbage collector.
GetCurrentPosition | Retrieves the position of the capture and read cursors in the CaptureBuffer object.
GetEffectsStatus | Retrieves the status of capture effects.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetObjectInPath | Retrieves a capture effect object associated with the CaptureBuffer object.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CaptureBuffer.Disposing event when called from within a derived class.
Read | Reads current data in the capture buffer.
Start | Begins capturing data into the buffer.
Stop | Stops the buffer so that it is no longer capturing data.
Write | Writes data to the capture buffer.

Properties

Property | Description
Caps | Retrieves the capabilities of the capture buffer.
Capturing | Retrieves whether the capture buffer is currently capturing.
Disposed | Gets a value that indicates whether the object is disposed.
Format | Retrieves the waveform format of the capture buffer.
Looping | Retrieves whether the capture buffer is currently looping.

Inheritance Hierarchy

Object Leave Site
CaptureBuffer

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CaptureBuffer.CaptureBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.CaptureBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureBuffer class.

Overload List

public CaptureBuffer(CaptureBufferDescription, Capture);
public CaptureBuffer(IntPtr, Capture);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.


CaptureBuffer.CaptureBuffer(IntPtr,Capture)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.CaptureBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureBuffer class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal device As Capture _
)
C# public CaptureBuffer(
IntPtr lp,
Capture device
);
Managed C++ public: CaptureBuffer(
IntPtr lp,
Capture *device
);
JScript .NET public function CaptureBuffer(
lp : IntPtr,
device : Capture
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureBuffer8, which allows unmanaged COM clients to create an instance of the managed CaptureBuffer class. Not supported.
device | Microsoft.DirectX.DirectSound.Capture. The Capture object that represents the parent capture device to use with the capture buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.


CaptureBuffer.CaptureBuffer(CaptureBufferDescription,Capture)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.CaptureBuffer Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal desc As CaptureBufferDescription, _
ByVal parent As Capture _
)
C# public CaptureBuffer(
CaptureBufferDescription desc,
Capture parent
);
Managed C++ public: CaptureBuffer(
CaptureBufferDescription desc,
Capture *parent
);
JScript .NET public function CaptureBuffer(
desc : CaptureBufferDescription,
parent : Capture
);

Parameters

desc | Microsoft.DirectX.DirectSound.CaptureBufferDescription. A CaptureBufferDescription structure that describes the capture buffer to create.
parent | Microsoft.DirectX.DirectSound.Capture. The Capture object that represents the parent capture device to use with the capture buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.


CaptureBuffer.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the CaptureBuffer object.

Definition

Visual Basic .NET | Public Sub Dispose()
C# | public void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public function Dispose();

See Also

  • CaptureBuffer.Disposed
  • CaptureBuffer.Disposing


CaptureBuffer.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CaptureBuffer.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the CaptureBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~CaptureBuffer();
Managed C++ | ~CaptureBuffer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


CaptureBuffer.GetCurrentPosition(Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.GetCurrentPosition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the position of the capture and read cursors in the CaptureBuffer object.

Definition

Visual Basic .NET Public Sub GetCurrentPosition( _
ByRef currentCapturePosition As Integer, _
ByRef currentReadPosition As Integer _
)
C# public void GetCurrentPosition(
out int currentCapturePosition,
out int currentReadPosition
);
Managed C++ public: void GetCurrentPosition(
int *currentCapturePosition,
int *currentReadPosition
);
JScript .NET public function GetCurrentPosition(
currentCapturePosition : int,
currentReadPosition : int
);

Parameters

currentCapturePosition | System.Int32. An integer that receives the offset, in bytes, of the capture cursor position in the capture buffer.
currentReadPosition | System.Int32. An integer that receives the offset, in bytes, of the read cursor position in the capture buffer.

Remarks

The capture cursor is ahead of the read cursor. The data after the read position, up to and including the capture position, is not necessarily valid data.


CaptureBuffer.GetEffectsStatus(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.GetEffectsStatus Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the status of capture effects.

Definition

Visual Basic .NET Public Function GetEffectsStatus( _
ByVal numEffects As Integer _
) As CaptureEffectsReturnValue()
C# public CaptureEffectsReturnValue[] GetEffectsStatus(
int numEffects
);
Managed C++ public: CaptureEffectsReturnValue GetEffectsStatus(
int numEffects
) __gc[];
JScript .NET public function GetEffectsStatus(
numEffects : int
) : CaptureEffectsReturnValue[];

Parameters

numEffects System.Int32. The number of capture effects to retrieve.

Return Value

Microsoft.DirectX.DirectSound.CaptureEffectsReturnValue[]. An array of values from the CaptureEffectsReturnValue enumeration that describe the status of capture effects in the CaptureBuffer object.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


CaptureBuffer.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


CaptureBuffer.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureBuffer8, which allows unmanaged COM clients to create an instance of the managed CaptureBuffer class. Not supported.


CaptureBuffer.GetObjectInPath(Guid,Int32,Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.GetObjectInPath Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a capture effect object associated with the CaptureBuffer object.

Definition

Visual Basic .NET Public Function GetObjectInPath( _
ByVal guidObject As Guid, _
ByVal index As Integer, _
ByVal guidInterface As Guid _
) As Object
C# public object GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
Managed C++ public: Object* GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
JScript .NET public function GetObjectInPath(
guidObject : Guid,
index : int,
guidInterface : Guid
) : Object;

Parameters

guidObject | System.Guid. Unique class identifier of the object being searched for, such as DSoundHelper.CaptureEffectsMsAcousticEchoCancellation.
index | System.Int32. Index of the capture effect to retrieve from the CaptureBuffer object.
guidInterface | System.Guid. Unique identifier of the desired interface, such as DSoundHelper.InterfaceCaptureEffectsAcousticEchoCancellation.

Return Value

System.Object . A capture effect used by the CaptureBuffer object.

Remarks

The value in index is the index of the object within the array of effects in the CaptureBufferDescription structure used in the CaptureBuffer constructor.

An object is returned solely on the basis of whether it matches guidObject and index. It is up to the application to ensure that guidInterface specifies an interface that can be expected to be found on the object.

Since this method returns the type of Object Leave Site, be sure to cast it to the correct type of the capture effect that you are retrieving.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all Microsoft® DirectSound® Exceptions. Derives from DirectXException.


CaptureBuffer.op_Equality(CaptureBuffer,CaptureBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As CaptureBuffer, _
ByVal right As CaptureBuffer _
) As Boolean
C# public static bool op_Equality(
CaptureBuffer left,
CaptureBuffer right
);
Managed C++ public: static bool op_Equality(
CaptureBuffer *left,
CaptureBuffer *right
);
JScript .NET public static function op_Equality(
left : CaptureBuffer,
right : CaptureBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CaptureBuffer. The CaptureBuffer object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CaptureBuffer. The CaptureBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CaptureBuffer.op_Inequality(CaptureBuffer,CaptureBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As CaptureBuffer, _
ByVal right As CaptureBuffer _
) As Boolean
C# public static bool op_Inequality(
CaptureBuffer left,
CaptureBuffer right
);
Managed C++ public: static bool op_Inequality(
CaptureBuffer *left,
CaptureBuffer *right
);
JScript .NET public static function op_Inequality(
left : CaptureBuffer,
right : CaptureBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CaptureBuffer. The CaptureBuffer object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CaptureBuffer. The CaptureBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


CaptureBuffer.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the CaptureBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


CaptureBuffer.Read

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads current data in the capture buffer.

Overload List

public void Read(int, Stream, int, LockFlag);
public Array Read(int, Type, LockFlag, int[]);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Read(Int32,Type,LockFlag,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads current data in the capture buffer.

Definition

Visual Basic .NET Public Function Read( _
ByVal bufferStartingLocation As Integer, _
ByVal returnedDataType As Type, _
ByVal flag As LockFlag, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
int bufferStartingLocation,
Type returnedDataType,
LockFlag flag,
int[] ranks
);
Managed C++ public: Array* Read(
int bufferStartingLocation,
Type *returnedDataType,
LockFlag flag,
int ranks __gc[]
);
JScript .NET public function Read(
bufferStartingLocation : int,
returnedDataType : Type,
flag : LockFlag,
ranks : int[]
) : Array;

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin reading from the capture buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
returnedDataType | System.Type. Value that indicates the Type Leave Site of the returned array.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.
ranks | System.Int32[]. Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array. The maximum number of ranks allowed is three.

Return Value

System.Array . An Array Leave Site of type returnedDataType that contains the data read from the buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Read(Int32,Stream,Int32,LockFlag)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads current data in the capture buffer.

Definition

Visual Basic .NET Public Sub Read( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToRead As Integer, _
ByVal flag As LockFlag _
)
C# public void Read(
int bufferStartingLocation,
Stream data,
int numberBytesToRead,
LockFlag flag
);
Managed C++ public: void Read(
int bufferStartingLocation,
Stream *data,
int numberBytesToRead,
LockFlag flag
);
JScript .NET public function Read(
bufferStartingLocation : int,
data : Stream,
numberBytesToRead : int,
flag : LockFlag
);

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin reading from the capture buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
data | System.IO.Stream. A Stream Leave Site object that receives the data read from the capture buffer.
numberBytesToRead | System.Int32. An integer that represents the number of bytes read into data from the buffer. The buffer is conceptually circular, so this number can exceed the number of bytes between bufferStartingLocation and the end of the buffer.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Start(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Start Method

 Language:
Note: This documentation is preliminary and is subject to change.

Begins capturing data into the buffer.

Definition

Visual Basic .NET Public Sub Start( _
ByVal looping As Boolean _
)
C# public void Start(
bool looping
);
Managed C++ public: void Start(
bool looping
);
JScript .NET public function Start(
looping : boolean
);

Parameters

looping System.Boolean. Set to true if, after the end of the buffer is reached, capture restarts at the beginning and continues until explicitly stopped; otherwise, false.

Remarks

If the buffer is already capturing, the method has no effect.

If the buffer is already capturing, a call to this method using a different value in looping might not change the value returned by Looping.

If the application is multithreaded, the thread that starts the buffer must continue to exist as long as the buffer is capturing. Buffers created on Windows Driver Model (WDM) drivers stop capturing when the thread is terminated.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid DirectSound device identifier (ID).


CaptureBuffer.Stop()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Stop Method

 Language:
Note: This documentation is preliminary and is subject to change.

Stops the buffer so that it is no longer capturing data.

Definition

Visual Basic .NET | Public Sub Stop()
C# | public void Stop();
Managed C++ | public: void Stop();
JScript .NET | public function Stop();

Remarks

If the buffer is not capturing, the method has no effect.

Exceptions
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid DirectSound device identifier (ID).


CaptureBuffer.Write

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes data to the capture buffer.

Overload List

public void Write(int, Array, LockFlag);
public void Write(int, Stream, int, LockFlag);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Write(Int32,Array,LockFlag)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes data to the capture buffer.

Definition

Visual Basic .NET Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Array, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Array data,
LockFlag flag
);
Managed C++ public: void Write(
int bufferStartingLocation,
Array *data,
LockFlag flag
);
JScript .NET public function Write(
bufferStartingLocation : int,
data : Array,
flag : LockFlag
);

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin writing into the capture buffer.
data | System.Array. An Array Leave Site that contains the data to write into the capture buffer.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Write(Int32,Stream,Int32,LockFlag)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes data to the capture buffer.

Definition

Visual Basic .NET Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToWrite As Integer, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Stream data,
int numberBytesToWrite,
LockFlag flag
);
Managed C++ public: void Write(
int bufferStartingLocation,
Stream *data,
int numberBytesToWrite,
LockFlag flag
);
JScript .NET public function Write(
bufferStartingLocation : int,
data : Stream,
numberBytesToWrite : int,
flag : LockFlag
);

Parameters

bufferStartingLocation | System.Int32. An integer that represents the offet, in bytes, of where to begin writing into the capture buffer.
data | System.IO.Stream. A Stream Leave Site object that contains the data to write into the capture buffer.
numberBytesToWrite | System.Int32. An integer that represents the number of bytes to write into the capture buffer.
flag | Microsoft.DirectX.DirectSound.LockFlag. A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the capabilities of the capture buffer.

Definition

Visual Basic .NET | Public ReadOnly Property Caps As CaptureBufferCaps
C# | public CaptureBufferCaps Caps { get; }
Managed C++ | public: __property CaptureBufferCaps get_Caps();
JScript .NET | public function get Caps() : CaptureBufferCaps

Property Value

Microsoft.DirectX.DirectSound.CaptureBufferCaps . A CaptureBufferCaps structure that describes the capibilites of the CaptureBuffer object.

This property is read-only.


CaptureBuffer.Capturing

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Capturing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture buffer is currently capturing.

Definition

Visual Basic .NET | Public ReadOnly Property Capturing As Boolean
C# | public bool Capturing { get; }
Managed C++ | public: __property bool get_Capturing();
JScript .NET | public function get Capturing() : boolean

Property Value

System.Boolean . Value that is set to true if the capture buffer is currently capturing; otherwise, false.

This property is read-only.


CaptureBuffer.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


CaptureBuffer.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the waveform format of the capture buffer.

Definition

Visual Basic .NET | Public ReadOnly Property Format As WaveFormat
C# | public WaveFormat Format { get; }
Managed C++ | public: __property WaveFormat get_Format();
JScript .NET | public function get Format() : WaveFormat

Property Value

Microsoft.DirectX.DirectSound.WaveFormat . A WaveFormat structure that describes the waveform format of the capture buffer.

This property is read-only.


CaptureBuffer.Looping

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Looping Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture buffer is currently looping.

Definition

Visual Basic .NET | Public ReadOnly Property Looping As Boolean
C# | public bool Looping { get; }
Managed C++ | public: __property bool get_Looping();
JScript .NET | public function get Looping() : boolean

Property Value

System.Boolean . Value that is set to true if the capture buffer is currently looping; otherwise, false.

This property is read-only.


CaptureBuffer.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBuffer.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the CaptureBuffer object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CaptureBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CaptureBuffer object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.CaptureDevicesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Represents a collection of DeviceInformation structures for each available capture device.

Definition

Visual Basic .NET NotInheritable Public Class CaptureDevicesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class CaptureDevicesCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class CaptureDevicesCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class CaptureDevicesCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureDevicesCollection | Initializes a new instance of the CaptureDevicesCollection class.
GetEnumerator | Retrieves an enumerator for the CaptureDevicesCollection object.
MoveNext | Advances to the next DeviceInformation structure in the CaptureDevicesCollection object.
Reset | Sets the CaptureDevicesCollection object to its initial position.

Properties

Property | Description
Count | Gets the number of DeviceInformation structures in the CaptureDevicesCollection object.
Current | Gets the current element from the enumeration of the CaptureDevicesCollection object.
Item | Retrieves a DeviceInformation structure at a particular index.

Inheritance Hierarchy

Object Leave Site
CaptureDevicesCollection

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CaptureDevicesCollection.CaptureDevicesCollection()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection.CaptureDevicesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureDevicesCollection class.

Definition

Visual Basic .NET | Public Sub New()
C# | public CaptureDevicesCollection();
Managed C++ | public: CaptureDevicesCollection();
JScript .NET | public function CaptureDevicesCollection();


CaptureDevicesCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an enumerator for the CaptureDevicesCollection object.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator . An enumerator for the CaptureDevicesCollection object.


CaptureDevicesCollection.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances to the next DeviceInformation structure in the CaptureDevicesCollection object.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean . Returns true if the CaptureDevicesCollection object was successfully advanced, and false if the CaptureDevicesCollection object has passed the end of the collection.


CaptureDevicesCollection.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the CaptureDevicesCollection object to its initial position.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();

Remarks

The initial position of the CaptureDevicesCollection object is before the first DeviceInformation structure.


CaptureDevicesCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the number of DeviceInformation structures in the CaptureDevicesCollection object.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 . The number of DeviceInformation structures.

This property is read-only.


CaptureDevicesCollection.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the current element from the enumeration of the CaptureDevicesCollection object.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object . The current element from the enumeration of the CaptureDevicesCollection object.

This property is read-only.

Remarks

Since this method has a return value type of Object Leave Site, you must cast it into a DeviceInformation structure to access its properties and method. See the example below:

[C#]
CaptureDevicesCollection devices = new CaptureDevicesCollection();
while (devices.MoveNext())
{
    DeviceInformation di = (DeviceInformation)devices.Current;
}


CaptureDevicesCollection.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureDevicesCollection.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a DeviceInformation structure at a particular index.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal index As Integer _
) As DeviceInformation
C# public DeviceInformation this[
int index
] { get; }
Managed C++ public: __property DeviceInformation get_Item(
int index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.DirectSound.DeviceInformation . The DeviceInformation structure in the CaptureDevicesCollection at the index from the index parameter.

This property is read-only.

Parameters

index System.Int32. The index of the DeviceInformation structure to retrieve.

Remarks

Exceptions
ArgumentOutOfRangeException Leave Site The index parameter is out of range of the collection.


Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect Class

Language:
Note: This documentation is preliminary and is subject to change.

Represents a Microsoft® DirectSound® capture effects object used to set and retrieve parameters on a capture buffer that supports noise suppression. This object requires Microsoft Windows XP or later.

Definition

Visual Basic .NET Public Class CaptureNoiseSuppressEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class CaptureNoiseSuppressEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class CaptureNoiseSuppressEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class CaptureNoiseSuppressEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CaptureNoiseSuppressEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the CaptureNoiseSuppressEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CaptureNoiseSuppressEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CaptureNoiseSuppressEffect.Disposing event when called from within a derived class.
Reset | Resets the effect to its initial state.

Properties

Property | Description
AllParameters | Retrieves or sets capture noise suppress parameters of a CaptureBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
CaptureNoiseSuppressEffect

Remarks

Obtain this object by calling the GetObjectInPath method of a CaptureBuffer object that is using the effect.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CaptureNoiseSuppressEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the CaptureNoiseSuppressEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • CaptureNoiseSuppressEffect.Disposed
  • CaptureNoiseSuppressEffect.Disposing


CaptureNoiseSuppressEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CaptureNoiseSuppressEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the CaptureNoiseSuppressEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~CaptureNoiseSuppressEffect();
Managed C++ | ~CaptureNoiseSuppressEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


CaptureNoiseSuppressEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


CaptureNoiseSuppressEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureFXNoiseSuppress8 , which allows unmanaged COM clients to create an instance of the managed CaptureNoiseSuppressEffect class. Not supported.


CaptureNoiseSuppressEffect.op_Equality(CaptureNoiseSuppressEffect,CaptureNoiseSuppressEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As CaptureNoiseSuppressEffect, _
ByVal right As CaptureNoiseSuppressEffect _
) As Boolean
C# public static bool op_Equality(
CaptureNoiseSuppressEffect left,
CaptureNoiseSuppressEffect right
);
Managed C++ public: static bool op_Equality(
CaptureNoiseSuppressEffect *left,
CaptureNoiseSuppressEffect *right
);
JScript .NET public static function op_Equality(
left : CaptureNoiseSuppressEffect,
right : CaptureNoiseSuppressEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect. The CaptureNoiseSuppressEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect. The CaptureNoiseSuppressEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CaptureNoiseSuppressEffect.op_Inequality(CaptureNoiseSuppressEffect,CaptureNoiseSuppressEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As CaptureNoiseSuppressEffect, _
ByVal right As CaptureNoiseSuppressEffect _
) As Boolean
C# public static bool op_Inequality(
CaptureNoiseSuppressEffect left,
CaptureNoiseSuppressEffect right
);
Managed C++ public: static bool op_Inequality(
CaptureNoiseSuppressEffect *left,
CaptureNoiseSuppressEffect *right
);
JScript .NET public static function op_Inequality(
left : CaptureNoiseSuppressEffect,
right : CaptureNoiseSuppressEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect. The CaptureNoiseSuppressEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect. The CaptureNoiseSuppressEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


CaptureNoiseSuppressEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the CaptureNoiseSuppressEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


CaptureNoiseSuppressEffect.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resets the effect to its initial state.

Definition

Visual Basic .NET | Public Sub Reset()
C# | public void Reset();
Managed C++ | public: void Reset();
JScript .NET | public function Reset();

Remarks

Applications should not reset an effect except when necessary because it has entered an incorrect state. This might be done in response to user input. An effect must not be reset arbitrarily at start-up, because another application might be using the same effect.


CaptureNoiseSuppressEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets capture noise suppress parameters of a CaptureBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As CaptureEffectsNoiseSuppress
C# | public CaptureEffectsNoiseSuppress AllParameters { get; set; }
Managed C++ public: __property CaptureEffectsNoiseSuppress get_AllParameters();
public: __property void set_AllParameters(CaptureEffectsNoiseSuppress);
JScript .NET public function get AllParameters() : CaptureEffectsNoiseSuppress
public function set AllParameters(CaptureEffectsNoiseSuppress);

Property Value

Microsoft.DirectX.DirectSound.CaptureEffectsNoiseSuppress . Contains parameters for capture noise suppress effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


CaptureNoiseSuppressEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


CaptureNoiseSuppressEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureNoiseSuppressEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the CaptureNoiseSuppressEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CaptureNoiseSuppressEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CaptureNoiseSuppressEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.ChorusEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports chorus.

Definition

Visual Basic .NET Public Class ChorusEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class ChorusEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class ChorusEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class ChorusEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ChorusEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) DelayMax | Retrieves the maximum value for the EffectsChorus.Delay property.
static (Shared in Visual Basic .NET) DelayMin | Retrieves the minimum value for the EffectsChorus.Delay property.
static (Shared in Visual Basic .NET) DepthMax | Retrieves the maximum value for the EffectsChorus.Depth property.
static (Shared in Visual Basic .NET) DepthMin | Retrieves the minimum value for the EffectsChorus.Depth property.
static (Shared in Visual Basic .NET) FeedbackMax | Retrieves the maximum value for the EffectsChorus.Feedback property.
static (Shared in Visual Basic .NET) FeedbackMin | Retrieves the minimum value for the EffectsChorus.Feedback property.
static (Shared in Visual Basic .NET) FrequencyMax | Retrieves the maximum value for the EffectsChorus.Frequency property.
static (Shared in Visual Basic .NET) FrequencyMin | Retrieves the minimum value for the EffectsChorus.Frequency property.
static (Shared in Visual Basic .NET) Phase180 | Retrieves the value of 180 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic .NET) Phase90 | Retrieves the value of 90 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic .NET) PhaseMax | Retrieves the maximum value for the EffectsChorus.Phase property.
static (Shared in Visual Basic .NET) PhaseMin | Retrieves the minimum value for the EffectsChorus.Phase property.
static (Shared in Visual Basic .NET) PhaseNegative180 | Retrieves the value of negative 180 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic .NET) PhaseNegative90 | Retrieves the value of negative 90 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic .NET) PhaseZero | Retrieves the value of no phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic .NET) WaveSin | Retrieves the value for a sine waveform for the EffectsChorus.Waveform property.
static (Shared in Visual Basic .NET) WaveTriangle | Retrieves the value for a triangle waveform for the EffectsChorus.Waveform property.
static (Shared in Visual Basic .NET) WetDryMixMax | Retrieves the maximum value for the EffectsChorus.WetDryMix property.
static (Shared in Visual Basic .NET) WetDryMixMin | Retrieves the maximum value for the EffectsChorus.WetDryMix property.

Methods

Method | Description
ChorusEffect | Initializes a new instance of the ChorusEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Dispose | Immediately releases the unmanaged resources used by the ChorusEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ChorusEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the ChorusEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets chorus parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ChorusEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ChorusEffect.ChorusEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.ChorusEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ChorusEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public ChorusEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: ChorusEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function ChorusEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXChorus8, which allows unmanaged COM clients to create an instance of the managed ChorusEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the ChorusEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


ChorusEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the ChorusEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • ChorusEffect.Disposed
  • ChorusEffect.Disposing


ChorusEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ChorusEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the ChorusEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ChorusEffect();
Managed C++ | ~ChorusEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


ChorusEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


ChorusEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXChorus8, which allows unmanaged COM clients to create an instance of the managed ChorusEffect class. Not supported.


ChorusEffect.op_Equality(ChorusEffect,ChorusEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As ChorusEffect, _
ByVal right As ChorusEffect _
) As Boolean
C# public static bool op_Equality(
ChorusEffect left,
ChorusEffect right
);
Managed C++ public: static bool op_Equality(
ChorusEffect *left,
ChorusEffect *right
);
JScript .NET public static function op_Equality(
left : ChorusEffect,
right : ChorusEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.ChorusEffect. The ChorusEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.ChorusEffect. The ChorusEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ChorusEffect.op_Inequality(ChorusEffect,ChorusEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As ChorusEffect, _
ByVal right As ChorusEffect _
) As Boolean
C# public static bool op_Inequality(
ChorusEffect left,
ChorusEffect right
);
Managed C++ public: static bool op_Inequality(
ChorusEffect *left,
ChorusEffect *right
);
JScript .NET public static function op_Inequality(
left : ChorusEffect,
right : ChorusEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.ChorusEffect. The ChorusEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.ChorusEffect. The ChorusEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


ChorusEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the ChorusEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


ChorusEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets chorus parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsChorus
C# | public EffectsChorus AllParameters { get; set; }
Managed C++ public: __property EffectsChorus get_AllParameters();
public: __property void set_AllParameters(EffectsChorus);
JScript .NET public function get AllParameters() : EffectsChorus
public function set AllParameters(EffectsChorus);

Property Value

Microsoft.DirectX.DirectSound.EffectsChorus . Contains parameters for a chorus effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


ChorusEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


ChorusEffect.DelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.DelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsChorus.Delay property.

Definition

Visual Basic .NET | Public Shared DelayMax As Single
C# | public static Single DelayMax;
Managed C++ | public: static Single DelayMax;
JScript .NET | public static var DelayMax : Single

Field Value

System.Single . Maximum value for the EffectsChorus.Delay property.

This field is read-only.

See Also

  • EffectsChorus.Delay


ChorusEffect.DelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.DelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsChorus.Delay property.

Definition

Visual Basic .NET | Public Shared DelayMin As Single
C# | public static Single DelayMin;
Managed C++ | public: static Single DelayMin;
JScript .NET | public static var DelayMin : Single

Field Value

System.Single . Minimum value for the EffectsChorus.Delay property.

This field is read-only.

See Also

  • EffectsChorus.Delay


ChorusEffect.DepthMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.DepthMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsChorus.Depth property.

Definition

Visual Basic .NET | Public Shared DepthMax As Single
C# | public static Single DepthMax;
Managed C++ | public: static Single DepthMax;
JScript .NET | public static var DepthMax : Single

Field Value

System.Single . Maximum value for the EffectsChorus.Depth property.

This field is read-only.

See Also

  • EffectsChorus.Depth


ChorusEffect.DepthMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.DepthMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsChorus.Depth property.

Definition

Visual Basic .NET | Public Shared DepthMin As Single
C# | public static Single DepthMin;
Managed C++ | public: static Single DepthMin;
JScript .NET | public static var DepthMin : Single

Field Value

System.Single . Minimum value for the EffectsChorus.Depth property.

This field is read-only.

See Also

  • EffectsChorus.Depth


ChorusEffect.FeedbackMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.FeedbackMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsChorus.Feedback property.

Definition

Visual Basic .NET | Public Shared FeedbackMax As Single
C# | public static Single FeedbackMax;
Managed C++ | public: static Single FeedbackMax;
JScript .NET | public static var FeedbackMax : Single

Field Value

System.Single . Maximum value for the EffectsChorus.Fedeback property.

This field is read-only.

See Also

  • EffectsChorus.Feedback


ChorusEffect.FeedbackMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.FeedbackMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsChorus.Feedback property.

Definition

Visual Basic .NET | Public Shared FeedbackMin As Single
C# | public static Single FeedbackMin;
Managed C++ | public: static Single FeedbackMin;
JScript .NET | public static var FeedbackMin : Single

Field Value

System.Single . Minimum value for the EffectsChorus.Feedback property.

This field is read-only.

See Also

  • EffectsChorus.Feedback


ChorusEffect.FrequencyMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.FrequencyMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsChorus.Frequency property.

Definition

Visual Basic .NET | Public Shared FrequencyMax As Single
C# | public static Single FrequencyMax;
Managed C++ | public: static Single FrequencyMax;
JScript .NET | public static var FrequencyMax : Single

Field Value

System.Single . Maximum value for the EffectsChorus.Frequency property.

This field is read-only.

See Also

  • EffectsChorus.Frequency


ChorusEffect.FrequencyMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.FrequencyMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsChorus.Frequency property.

Definition

Visual Basic .NET | Public Shared FrequencyMin As Single
C# | public static Single FrequencyMin;
Managed C++ | public: static Single FrequencyMin;
JScript .NET | public static var FrequencyMin : Single

Field Value

System.Single . Minimum value for the EffectsChorus.Frequency property.

This field is read-only.

See Also

  • EffectsChorus.Frequency


ChorusEffect.Phase180

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.Phase180 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of 180 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic .NET | Public Shared Phase180 As Int32
C# | public static Int32 Phase180;
Managed C++ | public: static Int32 Phase180;
JScript .NET | public static var Phase180 : Int32

Field Value

System.Int32 . Value of 180 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.Phase90

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.Phase90 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of 90 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic .NET | Public Shared Phase90 As Int32
C# | public static Int32 Phase90;
Managed C++ | public: static Int32 Phase90;
JScript .NET | public static var Phase90 : Int32

Field Value

System.Int32 . Value of 90 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.PhaseMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsChorus.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseMax As Int32
C# | public static Int32 PhaseMax;
Managed C++ | public: static Int32 PhaseMax;
JScript .NET | public static var PhaseMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.PhaseMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsChorus.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseMin As Int32
C# | public static Int32 PhaseMin;
Managed C++ | public: static Int32 PhaseMin;
JScript .NET | public static var PhaseMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseNegative180

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.PhaseNegative180 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of negative 180 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseNegative180 As Int32
C# | public static Int32 PhaseNegative180;
Managed C++ | public: static Int32 PhaseNegative180;
JScript .NET | public static var PhaseNegative180 : Int32

Field Value

System.Int32 . Value of negative 180 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseNegative90

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.PhaseNegative90 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of negative 90 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseNegative90 As Int32
C# | public static Int32 PhaseNegative90;
Managed C++ | public: static Int32 PhaseNegative90;
JScript .NET | public static var PhaseNegative90 : Int32

Field Value

System.Int32 . Value of negative 90 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseZero

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.PhaseZero Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of no phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseZero As Int32
C# | public static Int32 PhaseZero;
Managed C++ | public: static Int32 PhaseZero;
JScript .NET | public static var PhaseZero : Int32

Field Value

System.Int32 . Value of no phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.WaveSin

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.WaveSin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value for a sine waveform for the EffectsChorus.Waveform property.

Definition

Visual Basic .NET | Public Shared WaveSin As Int32
C# | public static Int32 WaveSin;
Managed C++ | public: static Int32 WaveSin;
JScript .NET | public static var WaveSin : Int32

Field Value

System.Int32 . Value for a sine waveform for the EffectsChorus.Waveform property.

This field is read-only.

See Also

  • EffectsChorus.Waveform


ChorusEffect.WaveTriangle

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.WaveTriangle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value for a triangle waveform for the EffectsChorus.Waveform property.

Definition

Visual Basic .NET | Public Shared WaveTriangle As Int32
C# | public static Int32 WaveTriangle;
Managed C++ | public: static Int32 WaveTriangle;
JScript .NET | public static var WaveTriangle : Int32

Field Value

System.Int32 . Value for a triangle waveform for the EffectsChorus.Waveform property.

This field is read-only.

See Also

  • EffectsChorus.Waveform


ChorusEffect.WetDryMixMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.WetDryMixMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsChorus.WetDryMix property.

Definition

Visual Basic .NET | Public Shared WetDryMixMax As Single
C# | public static Single WetDryMixMax;
Managed C++ | public: static Single WetDryMixMax;
JScript .NET | public static var WetDryMixMax : Single

Field Value

System.Single . Maximum value for the EffectsChorus.WetDryMix property.

This field is read-only.

See Also

  • EffectsChorus.WetDryMix


ChorusEffect.WetDryMixMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.WetDryMixMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsChorus.WetDryMix property.

Definition

Visual Basic .NET | Public Shared WetDryMixMin As Single
C# | public static Single WetDryMixMin;
Managed C++ | public: static Single WetDryMixMin;
JScript .NET | public static var WetDryMixMin : Single

Field Value

System.Single . Maximum value for the EffectsChorus.WetDryMix property.

This field is read-only.

See Also

  • EffectsChorus.WetDryMix


ChorusEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

ChorusEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the ChorusEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the ChorusEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ChorusEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.CompressorEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports compression.

Definition

Visual Basic .NET Public Class CompressorEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class CompressorEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class CompressorEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class CompressorEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CompressorEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) AttackMax | Retrieves the maximum value for the EffectsCompression.Attack property.
static (Shared in Visual Basic .NET) AttackMin | Retrieves the minimum value for the EffectsCompression.Attack property.
static (Shared in Visual Basic .NET) GainMax | Retrieves the maximum value for the EffectsCompression.Gain property.
static (Shared in Visual Basic .NET) GainMin | Retrieves the minimum value for the EffectsCompression.Gain property.
static (Shared in Visual Basic .NET) PreDelayMax | Retrieves the maximum value for the EffectsCompression.PreDelay property.
static (Shared in Visual Basic .NET) PreDelayMin | Retrieves the minimum value for the EffectsCompression.PreDelay property.
static (Shared in Visual Basic .NET) RatioMax | Retrieves the maximum value for the EffectsCompression.Ratio property.
static (Shared in Visual Basic .NET) RatioMin | Retrieves the minimum value for the EffectsCompression.Ratio property.
static (Shared in Visual Basic .NET) ReleaseMax | Retrieves the maximum value for the EffectsCompression.Release property.
static (Shared in Visual Basic .NET) ReleaseMin | Retrieves the minimum value for the EffectsCompression.Release property.
static (Shared in Visual Basic .NET) ThresholdMax | Retrieves the maximum value for the EffectsCompression.Threshold property.
static (Shared in Visual Basic .NET) ThresholdMin | Retrieves the minimum value for the EffectsCompression.Threshold property.

Methods

Method | Description
CompressorEffect | Initializes a new instance of the CompressorEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Dispose | Immediately releases the unmanaged resources used by the CompressorEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CompressorEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CompressorEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets compression parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
CompressorEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CompressorEffect.CompressorEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.CompressorEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CompressorEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public CompressorEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: CompressorEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function CompressorEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXCompressor8, which allows unmanaged COM clients to create an instance of the managed CompressorEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the CompressorEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


CompressorEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the CompressorEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • CompressorEffect.Disposed
  • CompressorEffect.Disposing


CompressorEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CompressorEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the CompressorEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~CompressorEffect();
Managed C++ | ~CompressorEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


CompressorEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


CompressorEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXCompressor8, which allows unmanaged COM clients to create an instance of the managed CompressorEffect class. Not supported.


CompressorEffect.op_Equality(CompressorEffect,CompressorEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As CompressorEffect, _
ByVal right As CompressorEffect _
) As Boolean
C# public static bool op_Equality(
CompressorEffect left,
CompressorEffect right
);
Managed C++ public: static bool op_Equality(
CompressorEffect *left,
CompressorEffect *right
);
JScript .NET public static function op_Equality(
left : CompressorEffect,
right : CompressorEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CompressorEffect. The CompressorEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CompressorEffect. The CompressorEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


CompressorEffect.op_Inequality(CompressorEffect,CompressorEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As CompressorEffect, _
ByVal right As CompressorEffect _
) As Boolean
C# public static bool op_Inequality(
CompressorEffect left,
CompressorEffect right
);
Managed C++ public: static bool op_Inequality(
CompressorEffect *left,
CompressorEffect *right
);
JScript .NET public static function op_Inequality(
left : CompressorEffect,
right : CompressorEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.CompressorEffect. The CompressorEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.CompressorEffect. The CompressorEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


CompressorEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the CompressorEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


CompressorEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets compression parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsCompressor
C# | public EffectsCompressor AllParameters { get; set; }
Managed C++ public: __property EffectsCompressor get_AllParameters();
public: __property void set_AllParameters(EffectsCompressor);
JScript .NET public function get AllParameters() : EffectsCompressor
public function set AllParameters(EffectsCompressor);

Property Value

Microsoft.DirectX.DirectSound.EffectsCompressor . Contains parameters for an compressor effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


CompressorEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


CompressorEffect.AttackMax

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.AttackMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsCompression.Attack property.

Definition

Visual Basic .NET | Public Shared AttackMax As Single
C# | public static Single AttackMax;
Managed C++ | public: static Single AttackMax;
JScript .NET | public static var AttackMax : Single

Field Value

System.Single . Maximum value for the EffectsCompression.Attack property.

This field is read-only.

See Also

  • EffectsCompression.Attack


CompressorEffect.AttackMin

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.AttackMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsCompression.Attack property.

Definition

Visual Basic .NET | Public Shared AttackMin As Single
C# | public static Single AttackMin;
Managed C++ | public: static Single AttackMin;
JScript .NET | public static var AttackMin : Single

Field Value

System.Single . Minimum value for the EffectsCompression.Attack property.

This field is read-only.

See Also

  • EffectsCompression.Attack


CompressorEffect.GainMax

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.GainMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsCompression.Gain property.

Definition

Visual Basic .NET | Public Shared GainMax As Single
C# | public static Single GainMax;
Managed C++ | public: static Single GainMax;
JScript .NET | public static var GainMax : Single

Field Value

System.Single . Maximum value for the EffectsCompression.Gain property.

This field is read-only.

See Also

  • EffectsCompression.Gain


CompressorEffect.GainMin

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.GainMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsCompression.Gain property.

Definition

Visual Basic .NET | Public Shared GainMin As Single
C# | public static Single GainMin;
Managed C++ | public: static Single GainMin;
JScript .NET | public static var GainMin : Single

Field Value

System.Single . Minimum value for the EffectsCompression.Gain property.

This field is read-only.

See Also

  • EffectsCompression.Gain


CompressorEffect.PreDelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.PreDelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsCompression.PreDelay property.

Definition

Visual Basic .NET | Public Shared PreDelayMax As Single
C# | public static Single PreDelayMax;
Managed C++ | public: static Single PreDelayMax;
JScript .NET | public static var PreDelayMax : Single

Field Value

System.Single . Maximum value for the EffectsCompression.PreDelay property.

This field is read-only.

See Also

  • EffectsCompression.PreDelay


CompressorEffect.PreDelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.PreDelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsCompression.PreDelay property.

Definition

Visual Basic .NET | Public Shared PreDelayMin As Single
C# | public static Single PreDelayMin;
Managed C++ | public: static Single PreDelayMin;
JScript .NET | public static var PreDelayMin : Single

Field Value

System.Single . Minimum value for the EffectsCompression.PreDelay property.

This field is read-only.

See Also

  • EffectsCompression.PreDelay


CompressorEffect.RatioMax

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.RatioMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsCompression.Ratio property.

Definition

Visual Basic .NET | Public Shared RatioMax As Single
C# | public static Single RatioMax;
Managed C++ | public: static Single RatioMax;
JScript .NET | public static var RatioMax : Single

Field Value

System.Single . Maximum value for the EffectsCompression.Ratio property.

This field is read-only.

See Also

  • EffectsCompression.Ratio


CompressorEffect.RatioMin

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.RatioMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsCompression.Ratio property.

Definition

Visual Basic .NET | Public Shared RatioMin As Single
C# | public static Single RatioMin;
Managed C++ | public: static Single RatioMin;
JScript .NET | public static var RatioMin : Single

Field Value

System.Single . Minimum value for the EffectsCompression.Ratio property.

This field is read-only.

See Also

  • EffectsCompression.Ratio


CompressorEffect.ReleaseMax

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.ReleaseMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsCompression.Release property.

Definition

Visual Basic .NET | Public Shared ReleaseMax As Single
C# | public static Single ReleaseMax;
Managed C++ | public: static Single ReleaseMax;
JScript .NET | public static var ReleaseMax : Single

Field Value

System.Single . Maximum value for the EffectsCompression.Release property.

This field is read-only.

See Also

  • EffectsCompression.Release


CompressorEffect.ReleaseMin

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.ReleaseMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsCompression.Release property.

Definition

Visual Basic .NET | Public Shared ReleaseMin As Single
C# | public static Single ReleaseMin;
Managed C++ | public: static Single ReleaseMin;
JScript .NET | public static var ReleaseMin : Single

Field Value

System.Single . Minimum value for the EffectsCompression.Release property.

This field is read-only.

See Also

  • EffectsCompression.Release


CompressorEffect.ThresholdMax

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.ThresholdMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsCompression.Threshold property.

Definition

Visual Basic .NET | Public Shared ThresholdMax As Single
C# | public static Single ThresholdMax;
Managed C++ | public: static Single ThresholdMax;
JScript .NET | public static var ThresholdMax : Single

Field Value

System.Single . Maximum value for the EffectsCompression.Threshold property.

This field is read-only.

See Also

  • EffectsCompression.Threshold


CompressorEffect.ThresholdMin

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.ThresholdMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsCompression.Threshold property.

Definition

Visual Basic .NET | Public Shared ThresholdMin As Single
C# | public static Single ThresholdMin;
Managed C++ | public: static Single ThresholdMin;
JScript .NET | public static var ThresholdMin : Single

Field Value

System.Single . Minimum value for the EffectsCompression.Threshold property.

This field is read-only.

See Also

  • EffectsCompression.Threshold


CompressorEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

CompressorEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the CompressorEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CompressorEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CompressorEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.ControlUnavailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

ControlUnavailableException Class

Language:
Note: This documentation is preliminary and is subject to change.

The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.

Definition

Visual Basic .NET Public Class ControlUnavailableException
Inherits SoundException
C# | public class ControlUnavailableException : SoundException
Managed C++ | public __gc class ControlUnavailableException : public SoundException
JScript .NET | public class ControlUnavailableException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ControlUnavailableException | Initializes a new instance of the ControlUnavailableException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
ControlUnavailableException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ControlUnavailableException.ControlUnavailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ControlUnavailableException class.

Overload List

public ControlUnavailableException();
protected ControlUnavailableException(SerializationInfo, StreamingContext);
public ControlUnavailableException(string);
public ControlUnavailableException(string, Exception);


ControlUnavailableException.ControlUnavailableException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ControlUnavailableException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ControlUnavailableException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ControlUnavailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


ControlUnavailableException.ControlUnavailableException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ControlUnavailableException(
string message,
Exception inner
);
Managed C++ public: ControlUnavailableException(
String *message,
Exception *inner
);
JScript .NET public function ControlUnavailableException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


ControlUnavailableException.ControlUnavailableException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ControlUnavailableException(
string message
);
Managed C++ public: ControlUnavailableException(
String *message
);
JScript .NET public function ControlUnavailableException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


ControlUnavailableException.ControlUnavailableException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ControlUnavailableException();
Managed C++ | public: ControlUnavailableException();
JScript .NET | public function ControlUnavailableException();


Microsoft.DirectX.DirectSound.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Device Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains methods and properties used to create buffer objects, manage devices, and set up the environment.

Definition

Visual Basic .NET Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# public class Device : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Device : public MarshalByRefObject,
IDisposable
JScript .NET public class Device extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Compact | This method has no effect.
Device | Initializes a new instance of the Device class.
Dispose | Immediately releases the unmanaged resources used by the Device object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Device object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Device.Disposing event when called from within a derived class.
SetCooperativeLevel | Sets the cooperative level of the application for this sound device.

Properties

Property | Description
Caps | Retrieves the capabilities of the hardware device.
Certified | Ascertains whether the device driver is certified for DirectX.
Disposed | Gets a value that indicates whether the object is disposed.
SpeakerConfig | Retrieves or sets the speaker configuration of the device.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Device.Compact()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Compact Method

 Language:
Note: This documentation is preliminary and is subject to change.

This method has no effect.

Definition

Visual Basic .NET | Public Sub Compact()
C# | public void Compact();
Managed C++ | public: void Compact();
JScript .NET | public function Compact();

Remarks

This method was formerly used for compacting the on-board memory of ISA sound cards.


Device.Device

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Device class.

Overload List

public Device();
public Device(Guid);
public Device(IntPtr);

Remarks

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Device(IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Device class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr _
)
C# public Device(
IntPtr lp
);
Managed C++ public: Device(
IntPtr lp
);
JScript .NET public function Device(
lp : IntPtr
);

Parameters

lp System.IntPtr. Pointer to the unmanaged interface, which allows unmanaged COM clients to create an instance of the managed Device class. Not supported.

Remarks

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Device(Guid)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Device class.

Definition

Visual Basic .NET Public Sub New( _
ByVal guidDev As Guid _
)
C# public Device(
Guid guidDev
);
Managed C++ public: Device(
Guid guidDev
);
JScript .NET public function Device(
guidDev : Guid
);

Parameters

guidDev System.Guid. The Guid Leave Site of the device to create an instanse of. See Remarks.

Remarks

To create an instance a particular Device object using its Guid Leave Site, first retrieve an available device's DeviceInformation from the DevicesCollection object, then get the Guid Leave Site from the DeviceInformation.DriverGuid property.

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Device()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Device Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Device class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Device();
Managed C++ | public: Device();
JScript .NET | public function Device();

Remarks

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Device object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Device.Disposed
  • Device.Disposing


Device.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound8, which allows unmanaged COM clients to create an instance of the managed Device class. Not supported.


Device.op_Equality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
Managed C++ public: static bool op_Equality(
Device *left,
Device *right
);
JScript .NET public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Device. The Device object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Device. The Device object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Device.op_Inequality(Device,Device)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
Managed C++ public: static bool op_Inequality(
Device *left,
Device *right
);
JScript .NET public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Device. The Device object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Device. The Device object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Device.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Device.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Device.SetCooperativeLevel

Device.SetCooperativeLevel Method

Note: This documentation is preliminary and is subject to change.

Sets the cooperative level of the application for this sound device.

Overload List

public void SetCooperativeLevel(Control, CooperativeLevel);
public void SetCooperativeLevel(IntPtr, CooperativeLevel);

Remarks

The application must set the cooperative level by calling this method before its buffers can be played.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetCooperativeLevel(IntPtr,CooperativeLevel)

Device.SetCooperativeLevel Method

Note: This documentation is preliminary and is subject to change.

Sets the cooperative level of the application for this sound device.

Definition

Visual Basic .NET Public Sub SetCooperativeLevel( _
ByVal owner As IntPtr, _
ByVal level As CooperativeLevel _
)
C# public void SetCooperativeLevel(
IntPtr owner,
CooperativeLevel level
);
Managed C++ public: void SetCooperativeLevel(
IntPtr owner,
CooperativeLevel level
);
JScript .NET public function SetCooperativeLevel(
owner : IntPtr,
level : CooperativeLevel
);

Parameters

owner | System.IntPtr.
level | Microsoft.DirectX.DirectSound.CooperativeLevel. The requested cooperative level. Specify one of the values shown in the following table

Remarks

The application must set the cooperative level by calling this method before its buffers can be played.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.SetCooperativeLevel(Control,CooperativeLevel)

Device.SetCooperativeLevel Method

Note: This documentation is preliminary and is subject to change.

Sets the cooperative level of the application for this sound device.

Definition

Visual Basic .NET Public Sub SetCooperativeLevel( _
ByVal owner As Control, _
ByVal level As CooperativeLevel _
)
C# public void SetCooperativeLevel(
Control owner,
CooperativeLevel level
);
Managed C++ public: void SetCooperativeLevel(
Control *owner,
CooperativeLevel level
);
JScript .NET public function SetCooperativeLevel(
owner : Control,
level : CooperativeLevel
);

Parameters

owner | System.Windows.Forms.Control. The System.Windows.Forms.Control Leave Site of the application that is using the Device object.
level | Microsoft.DirectX.DirectSound.CooperativeLevel. The requested cooperative level. Specify one of the values shown in the following table

Remarks

The application must set the cooperative level by calling this method before its buffers can be played.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Device.Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Caps Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the capabilities of the hardware device.

Definition

Visual Basic .NET | Public ReadOnly Property Caps As Caps
C# | public Caps Caps { get; }
Managed C++ | public: __property Caps get_Caps();
JScript .NET | public function get Caps() : Caps

Property Value

Microsoft.DirectX.DirectSound.Caps . The capabilities of this sound device.

This property is read-only.

Remarks

Information retrieved in the Caps structure describes the maximum capabilities of the sound device and those currently available, such as the number of hardware mixing channels and the amount of on-board sound memory. You can use this information to fine-tune performance and optimize resource allocation.

Because of resource-sharing requirements, the maximum capabilities in one area might be available only at the cost of another area.

Exceptions

SoundException | Root exception type for all Microsoft® DirectSound® exceptions. Derives from DirectXException.
ArgumentException Leave Site | An invalid parameter was passed to the called method.


Device.Certified

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Certified Property

Language:
Note: This documentation is preliminary and is subject to change.

Ascertains whether the device driver is certified for Microsoft® DirectX®.

Definition

Visual Basic .NET | Public ReadOnly Property Certified As Boolean
C# | public bool Certified { get; }
Managed C++ | public: __property bool get_Certified();
JScript .NET | public function get Certified() : boolean

Property Value

System.Boolean . Returns true when driver is certified for Microsoft® DirectX®; otherwise returns false.

This property is read-only.

Remarks

This method may attempt to retrieve certification information from the Internet.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
UnsupportedException | The function called is not supported at this time.


Device.SpeakerConfig

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.SpeakerConfig Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the speaker configuration of the device.

Definition

Visual Basic .NET | Public Property SpeakerConfig As Speakers
C# | public Speakers SpeakerConfig { get; set; }
Managed C++ public: __property Speakers get_SpeakerConfig();
public: __property void set_SpeakerConfig(Speakers);
JScript .NET public function get SpeakerConfig() : Speakers
public function set SpeakerConfig(Speakers);

Property Value

Microsoft.DirectX.DirectSound.Speakers . The speaker configuration for this device.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all Microsoft® DirectSound® exceptions. Derives from DirectXException.


Device.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Device.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Device.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Device object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.DevicesCollection

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection Class

Language:
Note: This documentation is preliminary and is subject to change.

Represents a collection of DeviceInformation structures for each available sound device.

Definition

Visual Basic .NET NotInheritable Public Class DevicesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# public sealed class DevicesCollection : Object,
IEnumerable, IEnumerator
Managed C++ public __gc __sealed class DevicesCollection : public Object,
IEnumerable, IEnumerator
JScript .NET public class DevicesCollection extends Object
implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DevicesCollection | Initializes a new instance of the DevicesCollection class.
GetEnumerator | Retrieves an enumerator for the DevicesCollection object.
MoveNext | Advances to the next DeviceInformation structure in the DevicesCollection object.
Reset | Sets the DevicesCollection object to its initial position.

Properties

Property | Description
Count | Gets the number of DeviceInformation structures in the DevicesCollection object.
Current | Retrives the element at the current position of the DevicesCollection object's enumeration.
Item | Retrieves a DeviceInformation structure at a particular index.

Inheritance Hierarchy

Object Leave Site
DevicesCollection

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DevicesCollection.DevicesCollection()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.DevicesCollection Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DevicesCollection class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DevicesCollection();
Managed C++ | public: DevicesCollection();
JScript .NET | public function DevicesCollection();


DevicesCollection.GetEnumerator()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.GetEnumerator Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an enumerator for the DevicesCollection object.

Definition

Visual Basic .NET | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
Managed C++ | public: IEnumerator* GetEnumerator();
JScript .NET | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator . An enumerator for the DevicesCollection object.


DevicesCollection.MoveNext()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.MoveNext Method

 Language:
Note: This documentation is preliminary and is subject to change.

Advances to the next DeviceInformation structure in the DevicesCollection object.

Definition

Visual Basic .NET | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
Managed C++ | public: bool MoveNext();
JScript .NET | public override function MoveNext() : boolean;

Return Value

System.Boolean . Indicates if DevicesCollection successfully advanced to the next DeviceInformation structure.

Remarks

Returns true if the DevicesCollection object was successfully advanced, and false if the DevicesCollection object has passed the end of the collection.


DevicesCollection.Reset()

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.Reset Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the DevicesCollection object to its initial position.

Definition

Visual Basic .NET | Overrides Public Sub Reset()
C# | public override void Reset();
Managed C++ | public: void Reset();
JScript .NET | public override function Reset();

Remarks

The initial position of the DevicesCollection object is before the first DeviceInformation structure.


DevicesCollection.Count

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.Count Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets the number of DeviceInformation structures in the DevicesCollection object.

Definition

Visual Basic .NET | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
Managed C++ | public: __property int get_Count();
JScript .NET | public function get Count() : int

Property Value

System.Int32 . The number of DeviceInformation structures.

This property is read-only.


DevicesCollection.Current

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.Current Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrives the element at the current position of the DevicesCollection object's enumeration.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
Managed C++ | public: __property virtual Object* get_Current();
JScript .NET | public function get Current() : Object

Property Value

System.Object . The current element from the DevicesCollection object's enumeration.

This property is read-only.

Remarks

Since this method has a return value type of Object Leave Site, you must cast it into a DeviceInformation structure to access its properties and method. See the example below:

[C#]
DevicesCollection devices = new DevicesCollection();
while (devices.MoveNext())
{
    DeviceInformation di = (DeviceInformation)devices.Current;
}


DevicesCollection.Item

Microsoft DirectX 9.0 SDK Update (October 2004)

DevicesCollection.Item Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a DeviceInformation structure at a particular index.

Definition

Visual Basic .NET Public ReadOnly Property Item( _
ByVal index As Integer _
) As DeviceInformation
C# public DeviceInformation this[
int index
] { get; }
Managed C++ public: __property DeviceInformation get_Item(
int index
);
JScript .NET In JScript .NET, you can use indexed properties, but you cannot define your own.

Property Value

Microsoft.DirectX.DirectSound.DeviceInformation . The DeviceInformation structure in the DevicesCollection at the index from the index parameter.

This property is read-only.

Parameters

index System.Int32. The index of the DeviceInformation structure to retrieve.

Remarks

Exceptions
ArgumentOutOfRangeException Leave Site The index parameter is out of range of the collection.


Microsoft.DirectX.DirectSound.DistortionEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports distortion.

Definition

Visual Basic .NET Public Class DistortionEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class DistortionEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class DistortionEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class DistortionEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the DistortionEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) EdgeMax | Retrieves the maximum value for the EffectsDistortion.Edge property.
static (Shared in Visual Basic .NET) EdgeMin | Retrieves the minimum value for the EffectsDistortion.Edge property.
static (Shared in Visual Basic .NET) GainMax | Retrieves the maximum value for the EffectsDistortion.Gain property.
static (Shared in Visual Basic .NET) GainMin | Retrieves the minimum value for the EffectsDistortion.Gain property.
static (Shared in Visual Basic .NET) PostEqBandwidthMax | Retrieves the maximum value for the EffectsDistortion.PostEqBandwidth property.
static (Shared in Visual Basic .NET) PostEqBandwidthMin | Retrieves the minimum value for the EffectsDistortion.PostEqBandwidth property.
static (Shared in Visual Basic .NET) PostEqCenterFrequencyMax | Retrieves the maximum value for the EffectsDistortion.PostEqCenterFrequency property.
static (Shared in Visual Basic .NET) PostEqCenterFrequencyMin | Retrieves the minimum value for the EffectsDistortion.PostEqCenterFrequency property.
static (Shared in Visual Basic .NET) PreLowPassCutoffMax | Retrieves the maximum value for the EffectsDistortion.PreLowPassCuttoff property.
static (Shared in Visual Basic .NET) PreLowPassCutoffMin | Retrieves the minimum value for the EffectsDistortion.PreLowPassCutoff property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the DistortionEffect object.
DistortionEffect | Initializes a new instance of the DistortionEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the DistortionEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the DistortionEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets distortion parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
DistortionEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DistortionEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the DistortionEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • DistortionEffect.Disposed
  • DistortionEffect.Disposing


DistortionEffect.DistortionEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.DistortionEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DistortionEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public DistortionEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: DistortionEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function DistortionEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXDistortion8, which allows unmanaged COM clients to create an instance of the managed DistortionEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the DistortionEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


DistortionEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


DistortionEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the DistortionEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~DistortionEffect();
Managed C++ | ~DistortionEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


DistortionEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


DistortionEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXDistortion8, which allows unmanaged COM clients to create an instance of the managed DistortionEffect class. Not supported.


DistortionEffect.op_Equality(DistortionEffect,DistortionEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As DistortionEffect, _
ByVal right As DistortionEffect _
) As Boolean
C# public static bool op_Equality(
DistortionEffect left,
DistortionEffect right
);
Managed C++ public: static bool op_Equality(
DistortionEffect *left,
DistortionEffect *right
);
JScript .NET public static function op_Equality(
left : DistortionEffect,
right : DistortionEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.DistortionEffect. The DistortionEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.DistortionEffect. The DistortionEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


DistortionEffect.op_Inequality(DistortionEffect,DistortionEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As DistortionEffect, _
ByVal right As DistortionEffect _
) As Boolean
C# public static bool op_Inequality(
DistortionEffect left,
DistortionEffect right
);
Managed C++ public: static bool op_Inequality(
DistortionEffect *left,
DistortionEffect *right
);
JScript .NET public static function op_Inequality(
left : DistortionEffect,
right : DistortionEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.DistortionEffect. The DistortionEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.DistortionEffect. The DistortionEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


DistortionEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the DistortionEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


DistortionEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets distortion parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsDistortion
C# | public EffectsDistortion AllParameters { get; set; }
Managed C++ public: __property EffectsDistortion get_AllParameters();
public: __property void set_AllParameters(EffectsDistortion);
JScript .NET public function get AllParameters() : EffectsDistortion
public function set AllParameters(EffectsDistortion);

Property Value

Microsoft.DirectX.DirectSound.EffectsDistortion . Contains parameters for a distortion effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


DistortionEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


DistortionEffect.EdgeMax

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.EdgeMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsDistortion.Edge property.

Definition

Visual Basic .NET | Public Shared EdgeMax As Single
C# | public static Single EdgeMax;
Managed C++ | public: static Single EdgeMax;
JScript .NET | public static var EdgeMax : Single

Field Value

System.Single . Maximum value for the EffectsDistortion.Edge property.

This field is read-only.

See Also

  • EffectsDistortion.Edge


DistortionEffect.EdgeMin

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.EdgeMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsDistortion.Edge property.

Definition

Visual Basic .NET | Public Shared EdgeMin As Single
C# | public static Single EdgeMin;
Managed C++ | public: static Single EdgeMin;
JScript .NET | public static var EdgeMin : Single

Field Value

System.Single . Minimum value for the EffectsDistortion.Edge property.

This field is read-only.

See Also

  • EffectsDistortion.Edge


DistortionEffect.GainMax

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.GainMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsDistortion.Gain property.

Definition

Visual Basic .NET | Public Shared GainMax As Single
C# | public static Single GainMax;
Managed C++ | public: static Single GainMax;
JScript .NET | public static var GainMax : Single

Field Value

System.Single . Maximum value for the EffectsDistortion.Gain property.

This field is read-only.

See Also

  • EffectsDistortion.Gain


DistortionEffect.GainMin

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.GainMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsDistortion.Gain property.

Definition

Visual Basic .NET | Public Shared GainMin As Single
C# | public static Single GainMin;
Managed C++ | public: static Single GainMin;
JScript .NET | public static var GainMin : Single

Field Value

System.Single . Minimum value for the EffectsDistortion.Gain property.

This field is read-only.

See Also

  • EffectsDistortion.Gain


DistortionEffect.PostEqBandwidthMax

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.PostEqBandwidthMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsDistortion.PostEqBandwidth property.

Definition

Visual Basic .NET | Public Shared PostEqBandwidthMax As Single
C# | public static Single PostEqBandwidthMax;
Managed C++ | public: static Single PostEqBandwidthMax;
JScript .NET | public static var PostEqBandwidthMax : Single

Field Value

System.Single . Maximum value for the EffectsDistortion.PostEqBandwidth property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqBandwidth


DistortionEffect.PostEqBandwidthMin

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.PostEqBandwidthMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsDistortion.PostEqBandwidth property.

Definition

Visual Basic .NET | Public Shared PostEqBandwidthMin As Single
C# | public static Single PostEqBandwidthMin;
Managed C++ | public: static Single PostEqBandwidthMin;
JScript .NET | public static var PostEqBandwidthMin : Single

Field Value

System.Single . Minimum value for the EffectsDistortion.PostEqBandwidth property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqBandwidth


DistortionEffect.PostEqCenterFrequencyMax

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.PostEqCenterFrequencyMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsDistortion.PostEqCenterFrequency property.

Definition

Visual Basic .NET | Public Shared PostEqCenterFrequencyMax As Single
C# | public static Single PostEqCenterFrequencyMax;
Managed C++ | public: static Single PostEqCenterFrequencyMax;
JScript .NET | public static var PostEqCenterFrequencyMax : Single

Field Value

System.Single . Maximum value for the EffectsDistortion.PostEqCenterFrequency property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqCenterFrequency


DistortionEffect.PostEqCenterFrequencyMin

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.PostEqCenterFrequencyMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsDistortion.PostEqCenterFrequency property.

Definition

Visual Basic .NET | Public Shared PostEqCenterFrequencyMin As Single
C# | public static Single PostEqCenterFrequencyMin;
Managed C++ | public: static Single PostEqCenterFrequencyMin;
JScript .NET | public static var PostEqCenterFrequencyMin : Single

Field Value

System.Single . Minimum value for the EffectsDistortion.PostEqCenterFrequency property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqCenterFrequency


DistortionEffect.PreLowPassCutoffMax

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.PreLowPassCutoffMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsDistortion.PreLowPassCuttoff property.

Definition

Visual Basic .NET | Public Shared PreLowPassCutoffMax As Single
C# | public static Single PreLowPassCutoffMax;
Managed C++ | public: static Single PreLowPassCutoffMax;
JScript .NET | public static var PreLowPassCutoffMax : Single

Field Value

System.Single . Maximum value for the EffectsDistortion.PreLowPassCutoff property.

This field is read-only.

See Also

  • EffectsDistortion.PreLowPassCutoff


DistortionEffect.PreLowPassCutoffMin

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.PreLowPassCutoffMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsDistortion.PreLowPassCutoff property.

Definition

Visual Basic .NET | Public Shared PreLowPassCutoffMin As Single
C# | public static Single PreLowPassCutoffMin;
Managed C++ | public: static Single PreLowPassCutoffMin;
JScript .NET | public static var PreLowPassCutoffMin : Single

Field Value

System.Single . Minimum value for the EffectsDistortion.PreLowPassCutoff property.

This field is read-only.

See Also

  • EffectsDistortion.PreLowPassCutoff


DistortionEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

DistortionEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the DistortionEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the DistortionEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the DistortionEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.DSoundHelper

DSoundHelper Class

Note: This documentation is preliminary and is subject to change.

Contains helper methods and fields for Microsoft® DirectSound®.

Definition

Visual Basic .NET NotInheritable Public Class DSoundHelper
Inherits Object
C# | public sealed class DSoundHelper : Object
Managed C++ | public __gc __sealed class DSoundHelper : public Object
JScript .NET | public class DSoundHelper extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) CaptureEffectsClassAcousticEchoCancellation | Retrieves the GUID class identifier for the acoustic echo cancellation capture effect.
static (Shared in Visual Basic .NET) CaptureEffectsClassNoiseSuppression | Retrieves the GUID class identifier for the noise suppression capture effect.
static (Shared in Visual Basic .NET) CaptureEffectsMsAcousticEchoCancellation | Retrieves the GUID class identifier for the Microsoft acoustic echo cancellation capture effect.
static (Shared in Visual Basic .NET) CaptureEffectsMsNoiseSuppression | Retrieves the GUID class identifier for the Microsoft noise suppression capture effect.
static (Shared in Visual Basic .NET) CaptureEffectsSystemAcousticEchoCancellation | Retrieves the GUID class identifier for the system acoustic echo cancellation capture effect.
static (Shared in Visual Basic .NET) CaptureEffectsSystemNoiseSuppression | Retrieves the GUID class identifier for the system noise suppression capture effect.
static (Shared in Visual Basic .NET) DefaultCaptureDevice | Retrieves the GUID for the system-wide default audio capture device.
static (Shared in Visual Basic .NET) DefaultConeAngle | Retrieves the default cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic .NET) DefaultConeOutsideVolume | Retrieves the default outside cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic .NET) DefaultDistanceFactor | Retrieves the default distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.
static (Shared in Visual Basic .NET) DefaultDopplerFactor | Retrieves the default ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.
static (Shared in Visual Basic .NET) DefaultMaxDistance | Retrieves the default maximum distance used by the Buffer3D.MaxDistance and Buffer3DSettings.MaxDistance properties, in meters.
static (Shared in Visual Basic .NET) DefaultMinDistance | Retrieves the default minimum distance used by the Buffer3D.MinDistance and Buffer3DSettings.MinDistance properties, in meters.
static (Shared in Visual Basic .NET) DefaultPlaybackDevice | Retrieves the GUID for the system-wide default audio playback device.
static (Shared in Visual Basic .NET) DefaultRolloffFactor | Retrieves the default ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.
static (Shared in Visual Basic .NET) DefaultVoiceCaptureDevice | Retrieves the GUID for the default voice capture device.
static (Shared in Visual Basic .NET) DefaultVoicePlaybackDevice | Retrieves the GUID for the default voice playback device.
static (Shared in Visual Basic .NET) Guid3DAlgorithmDefault | Retrieves the default 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.
static (Shared in Visual Basic .NET) Guid3DAlgorithmHrtfFull | Retrieves the high quality 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.
static (Shared in Visual Basic .NET) Guid3DAlgorithmHrtfLight | Retrieves the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.
static (Shared in Visual Basic .NET) Guid3DAlgorithmNoVirtualization | Retrieves the 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property that is mapped onto normal left and right stereo panning.
static (Shared in Visual Basic .NET) GuidAllObjects | Retrieves the GUID that can represent any DirectSound effect class identifier.
static (Shared in Visual Basic .NET) Interface3DBuffer | Retrieves the GUID for the Buffer3D interface.
static (Shared in Visual Basic .NET) Interface3DListener | Retrieves the GUID for the Listener3D interface.
static (Shared in Visual Basic .NET) InterfaceBuffer | Retrieves the GUID for the Buffer interface.
static (Shared in Visual Basic .NET) InterfaceCaptureBuffer | Retrieves the GUID for the CaptureBuffer interface.
static (Shared in Visual Basic .NET) InterfaceCaptureEffectsAcousticEchoCancellation | Retrieves the GUID for the acoustic echo cancellation capture effect interface.
static (Shared in Visual Basic .NET) InterfaceCaptureEffectsNoiseSuppress | Retrieves the GUID for the noise suppression capture effect interface.
static (Shared in Visual Basic .NET) InterfaceDirectSound | Retrieves the GUID for the Microsoft.DirectX.DirectSound interface.
static (Shared in Visual Basic .NET) InterfaceDirectSoundCapture | Retrieves the GUID for the Capture interface.
static (Shared in Visual Basic .NET) InterfaceEffectsChorus | Retrieves the GUID for the chorus effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsCompressor | Retrieves the GUID for the compressor effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsDistortion | Retrieves the GUID for the distortion effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsEcho | Retrieves the GUID for the echo effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsFlanger | Retrieves the GUID for the flanger effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsGargle | Retrieves the GUID for the gargle effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsInteractive3DLevel2Reverb | Retrieves the GUID for the interactive 3-D level2 reverb effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsParamEq | Retrieves the GUID for the parameteric equalizer effect interface.
static (Shared in Visual Basic .NET) InterfaceEffectsWavesReverb | Retrieves the GUID for the Waves reverb effect interface.
static (Shared in Visual Basic .NET) InterfaceNotify | Retrieves the GUID for the Notify interface.
static (Shared in Visual Basic .NET) InterfaceSecondaryBuffer | Retrieves the GUID for the SecondaryBuffer interface.
static (Shared in Visual Basic .NET) MaxConeAngle | Retrieves the maximum cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic .NET) MaxDistanceFactor | Retrieves the maximum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.
static (Shared in Visual Basic .NET) MaxDopplerFactor | Retrieves the maximum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.
static (Shared in Visual Basic .NET) MaxRolloffFactor | Retrieves the maximum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.
static (Shared in Visual Basic .NET) MinConeAngle | Retrieves the minimum cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic .NET) MinDistanceFactor | Retrieves the minimum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.
static (Shared in Visual Basic .NET) MinDopplerFactor | Retrieves the minimum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.
static (Shared in Visual Basic .NET) MinRolloffFactor | Retrieves the minimum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.
static (Shared in Visual Basic .NET) StandardChorusGuid | Retrieves the GUID class identifier for the chorus effect.
static (Shared in Visual Basic .NET) StandardCompressorGuid | Retrieves the GUID class identifier for the compressor effect.
static (Shared in Visual Basic .NET) StandardDistortionGuid | Retrieves the GUID class identifier for the distortion effect.
static (Shared in Visual Basic .NET) StandardEchoGuid | Retrieves the GUID class identifier for the echo effect.
static (Shared in Visual Basic .NET) StandardFlangerGuid | Retrieves the GUID class identifier for the flanger effect.
static (Shared in Visual Basic .NET) StandardGargleGuid | Retrieves the GUID class identifier for the gargle effect.
static (Shared in Visual Basic .NET) StandardInteractive3DLevel2ReverbGuid | Retrieves the GUID class identifier for the interactive 3-D level2 reverb effect.
static (Shared in Visual Basic .NET) StandardParamEqGuid | Retrieves the GUID class identifier for the parameteric equalizer effect.
static (Shared in Visual Basic .NET) StandardWavesReverbGuid | Retrieves the GUID class identifier for the Waves reverb effect.

Methods

Method | Description
static (Shared in Visual Basic .NET) GetObjectFromInterfaceGuid | Retrieves an object based on an interface globally unique identifier (GUID).

Inheritance Hierarchy

Object Leave Site
DSoundHelper

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DSoundHelper.GetObjectFromInterfaceGuid(IntPtr,Guid,Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.GetObjectFromInterfaceGuid Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object based on an interface globally unique identifier (GUID).

Definition

Visual Basic .NET Public Shared Function GetObjectFromInterfaceGuid( _
ByVal lpVal As IntPtr, _
ByVal iid As Guid, _
ByVal source As Object _
) As Object
C# public static object GetObjectFromInterfaceGuid(
IntPtr lpVal,
Guid iid,
object source
);
Managed C++ public: static Object* GetObjectFromInterfaceGuid(
IntPtr lpVal,
Guid iid,
Object *source
);
JScript .NET public static function GetObjectFromInterfaceGuid(
lpVal : IntPtr,
iid : Guid,
source : Object
) : Object;

Parameters

lpVal | System.IntPtr. The pointer to the unmanaged Component Object Model (COM) interface of the requested object.
iid | System.Guid. The interface globally unique identifier (GUID) of the requested object.
source | System.Object. The parent object of the requested object (see Remarks).

Return Value

System.Object . Returns the object that is requested.

Remarks

The source parameter is the requested object's parent object. As an example, if you are requesting a SecondaryBuffer object, you would pass the Device object to this method using the source parameter.


DSoundHelper.CaptureEffectsClassAcousticEchoCancellation

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.CaptureEffectsClassAcousticEchoCancellation Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) class identifier for the acoustic echo cancellation capture effect.

Definition

Visual Basic .NET | Public Shared CaptureEffectsClassAcousticEchoCancellation As Guid
C# | public static Guid CaptureEffectsClassAcousticEchoCancellation;
Managed C++ | public: static Guid CaptureEffectsClassAcousticEchoCancellation;
JScript .NET | public static var CaptureEffectsClassAcousticEchoCancellation : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the acoustic echo cancellation capture effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the CaptureEffectDescription structure to set the acoustic echo cancellation capture effect to a CaptureBuffer object.

Once the acoustic echo cancellation capture effect is set to a CaptureBuffer object, the CaptureAcousticEchoCancellationEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsClassNoiseSuppression

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.CaptureEffectsClassNoiseSuppression Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) class identifier for the noise suppression capture effect.

Definition

Visual Basic .NET | Public Shared CaptureEffectsClassNoiseSuppression As Guid
C# | public static Guid CaptureEffectsClassNoiseSuppression;
Managed C++ | public: static Guid CaptureEffectsClassNoiseSuppression;
JScript .NET | public static var CaptureEffectsClassNoiseSuppression : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the noise suppression capture effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the CaptureEffectDescription structure to set the noise suppression capture effect to a CaptureBuffer object.

Once the noise suppression capture effect is set to a CaptureBuffer object, the CaptureNoiseSuppressEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsMsAcousticEchoCancellation

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.CaptureEffectsMsAcousticEchoCancellation Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) class identifier for the Microsoft® acoustic echo cancellation capture effect.

Definition

Visual Basic .NET | Public Shared CaptureEffectsMsAcousticEchoCancellation As Guid
C# | public static Guid CaptureEffectsMsAcousticEchoCancellation;
Managed C++ | public: static Guid CaptureEffectsMsAcousticEchoCancellation;
JScript .NET | public static var CaptureEffectsMsAcousticEchoCancellation : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the Microsoft® acoustic echo cancellation capture effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the CaptureEffectDescription structure to set the Microsoft® acoustic echo cancellation capture effect to a CaptureBuffer object.

Once the Microsoft acoustic echo cancellation capture effect is set to a CaptureBuffer object, the CaptureAcousticEchoCancellationEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsMsNoiseSuppression

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.CaptureEffectsMsNoiseSuppression Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) class identifier for the Microsoft® noise suppression capture effect.

Definition

Visual Basic .NET | Public Shared CaptureEffectsMsNoiseSuppression As Guid
C# | public static Guid CaptureEffectsMsNoiseSuppression;
Managed C++ | public: static Guid CaptureEffectsMsNoiseSuppression;
JScript .NET | public static var CaptureEffectsMsNoiseSuppression : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the Microsoft® noise suppression capture effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the CaptureEffectDescription structure to set the Microsoft® noise suppression capture effect to a CaptureBuffer object.

Once the Microsoft noise suppression capture effect is set to a CaptureBuffer object, the CaptureNoiseSuppressEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsSystemAcousticEchoCancellation

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.CaptureEffectsSystemAcousticEchoCancellation Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) class identifier for the system acoustic echo cancellation capture effect.

Definition

Visual Basic .NET | Public Shared CaptureEffectsSystemAcousticEchoCancellation As Guid
C# | public static Guid CaptureEffectsSystemAcousticEchoCancellation;
Managed C++ | public: static Guid CaptureEffectsSystemAcousticEchoCancellation;
JScript .NET | public static var CaptureEffectsSystemAcousticEchoCancellation : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the system acoustic echo cancellation capture effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the CaptureEffectDescription structure to set the system acoustic echo cancellation capture effect to a CaptureBuffer object.

Once the system acoustic echo cancellation capture effect is set to a CaptureBuffer object, the CaptureAcousticEchoCancellationEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsSystemNoiseSuppression

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.CaptureEffectsSystemNoiseSuppression Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) class identifier for the system noise suppression capture effect.

Definition

Visual Basic .NET | Public Shared CaptureEffectsSystemNoiseSuppression As Guid
C# | public static Guid CaptureEffectsSystemNoiseSuppression;
Managed C++ | public: static Guid CaptureEffectsSystemNoiseSuppression;
JScript .NET | public static var CaptureEffectsSystemNoiseSuppression : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the system noise suppression capture effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the CaptureEffectDescription structure to set the system noise suppression capture effect to a CaptureBuffer object.

Once the system noise suppression capture effect is set to a CaptureBuffer object, the CaptureNoiseSuppressEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.DefaultCaptureDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultCaptureDevice Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the system-wide default audio capture device.

Definition

Visual Basic .NET | Public Shared DefaultCaptureDevice As Guid
C# | public static Guid DefaultCaptureDevice;
Managed C++ | public: static Guid DefaultCaptureDevice;
JScript .NET | public static var DefaultCaptureDevice : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the system-wide default audio capture device.

This field is read-only.


DSoundHelper.DefaultConeAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultConeAngle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default cone angle for an Angles structure, in degrees.

Definition

Visual Basic .NET | Public Shared DefaultConeAngle As Single
C# | public static Single DefaultConeAngle;
Managed C++ | public: static Single DefaultConeAngle;
JScript .NET | public static var DefaultConeAngle : Single

Field Value

System.Single . Returns the default cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.DefaultConeOutsideVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultConeOutsideVolume Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default outside cone angle for an Angles structure, in degrees.

Definition

Visual Basic .NET | Public Shared DefaultConeOutsideVolume As Int32
C# | public static Int32 DefaultConeOutsideVolume;
Managed C++ | public: static Int32 DefaultConeOutsideVolume;
JScript .NET | public static var DefaultConeOutsideVolume : Int32

Field Value

System.Int32 . Returns the default outside cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.DefaultDistanceFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultDistanceFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared DefaultDistanceFactor As Single
C# | public static Single DefaultDistanceFactor;
Managed C++ | public: static Single DefaultDistanceFactor;
JScript .NET | public static var DefaultDistanceFactor : Single

Field Value

System.Single . Returns the default distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

This field is read-only.


DSoundHelper.DefaultDopplerFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultDopplerFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared DefaultDopplerFactor As Single
C# | public static Single DefaultDopplerFactor;
Managed C++ | public: static Single DefaultDopplerFactor;
JScript .NET | public static var DefaultDopplerFactor : Single

Field Value

System.Single . Returns the default ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

This field is read-only.


DSoundHelper.DefaultMaxDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultMaxDistance Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default maximum distance used by the Buffer3D.MaxDistance and Buffer3DSettings.MaxDistance properties, in meters.

Definition

Visual Basic .NET | Public Shared DefaultMaxDistance As Single
C# | public static Single DefaultMaxDistance;
Managed C++ | public: static Single DefaultMaxDistance;
JScript .NET | public static var DefaultMaxDistance : Single

Field Value

System.Single . Returns the default maximum distance used by the Buffer3D.MaxDistance and Buffer3DSettings.MaxDistance properties, in meters.

This field is read-only.


DSoundHelper.DefaultMinDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultMinDistance Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default minimum distance used by the Buffer3D.MinDistance and Buffer3DSettings.MinDistance properties, in meters.

Definition

Visual Basic .NET | Public Shared DefaultMinDistance As Single
C# | public static Single DefaultMinDistance;
Managed C++ | public: static Single DefaultMinDistance;
JScript .NET | public static var DefaultMinDistance : Single

Field Value

System.Single . Returns the default minimum distance used by the Buffer3D.MinDistance and Buffer3DSettings.MinDistance properties, in meters.

This field is read-only.


DSoundHelper.DefaultPlaybackDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultPlaybackDevice Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the system-wide default audio playback device.

Definition

Visual Basic .NET | Public Shared DefaultPlaybackDevice As Guid
C# | public static Guid DefaultPlaybackDevice;
Managed C++ | public: static Guid DefaultPlaybackDevice;
JScript .NET | public static var DefaultPlaybackDevice : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the system-wide default audio playback device.

This field is read-only.


DSoundHelper.DefaultRolloffFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultRolloffFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared DefaultRolloffFactor As Single
C# | public static Single DefaultRolloffFactor;
Managed C++ | public: static Single DefaultRolloffFactor;
JScript .NET | public static var DefaultRolloffFactor : Single

Field Value

System.Single . Returns the default ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

This field is read-only.


DSoundHelper.DefaultVoiceCaptureDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultVoiceCaptureDevice Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the default voice capture device.

Definition

Visual Basic .NET | Public Shared DefaultVoiceCaptureDevice As Guid
C# | public static Guid DefaultVoiceCaptureDevice;
Managed C++ | public: static Guid DefaultVoiceCaptureDevice;
JScript .NET | public static var DefaultVoiceCaptureDevice : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the default voice capture device.

This field is read-only.


DSoundHelper.DefaultVoicePlaybackDevice

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.DefaultVoicePlaybackDevice Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the default voice playback device.

Definition

Visual Basic .NET | Public Shared DefaultVoicePlaybackDevice As Guid
C# | public static Guid DefaultVoicePlaybackDevice;
Managed C++ | public: static Guid DefaultVoicePlaybackDevice;
JScript .NET | public static var DefaultVoicePlaybackDevice : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the default playback capture device.

This field is read-only.


DSoundHelper.Guid3DAlgorithmDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.Guid3DAlgorithmDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

Definition

Visual Basic .NET | Public Shared Guid3DAlgorithmDefault As Guid
C# | public static Guid Guid3DAlgorithmDefault;
Managed C++ | public: static Guid Guid3DAlgorithmDefault;
JScript .NET | public static var Guid3DAlgorithmDefault : Guid

Field Value

System.Guid . Returns the default 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

This field is read-only.


DSoundHelper.Guid3DAlgorithmHrtfFull

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.Guid3DAlgorithmHrtfFull Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the high quality 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

Definition

Visual Basic .NET | Public Shared Guid3DAlgorithmHrtfFull As Guid
C# | public static Guid Guid3DAlgorithmHrtfFull;
Managed C++ | public: static Guid Guid3DAlgorithmHrtfFull;
JScript .NET | public static var Guid3DAlgorithmHrtfFull : Guid

Field Value

System.Guid . Returns the high quality 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

This field is read-only.

Remarks

This algorithm gives the highest quality 3-D audio effect, but uses more CPU cycles than the other 3-D algorithms..


DSoundHelper.Guid3DAlgorithmHrtfLight

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.Guid3DAlgorithmHrtfLight Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

Definition

Visual Basic .NET | Public Shared Guid3DAlgorithmHrtfLight As Guid
C# | public static Guid Guid3DAlgorithmHrtfLight;
Managed C++ | public: static Guid Guid3DAlgorithmHrtfLight;
JScript .NET | public static var Guid3DAlgorithmHrtfLight : Guid

Field Value

System.Guid . Returns the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

This field is read-only.

Remarks

This algorithm gives a good 3-D audio effect, but uses fewer CPU cycles than the other 3-D algorithms.


DSoundHelper.Guid3DAlgorithmNoVirtualization

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.Guid3DAlgorithmNoVirtualization Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property that is mapped onto normal left and right stereo panning.

Definition

Visual Basic .NET | Public Shared Guid3DAlgorithmNoVirtualization As Guid
C# | public static Guid Guid3DAlgorithmNoVirtualization;
Managed C++ | public: static Guid Guid3DAlgorithmNoVirtualization;
JScript .NET | public static var Guid3DAlgorithmNoVirtualization : Guid

Field Value

System.Guid . Returns the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm that is mapped onto normal left and right stereo panning.

This field is read-only.

Remarks

At 90 degrees to the left, the sound is coming out of only the left speaker; at 90 degrees to the right, sound is coming out of only the right speaker. The vertical axis is ignored except for scaling of volume due to distance. Doppler shift and volume scaling are still applied, but the 3-D filtering is not performed on this buffer.

This is the most efficient software implementation, but provides no virtual 3-D audio effect.


DSoundHelper.GuidAllObjects

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.GuidAllObjects Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) that can represent any Microsoft® DirectSound® effect class identifier.

Definition

Visual Basic .NET | Public Shared GuidAllObjects As Guid
C# | public static Guid GuidAllObjects;
Managed C++ | public: static Guid GuidAllObjects;
JScript .NET | public static var GuidAllObjects : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) that can represent any Microsoft® DirectSound® effect class identifier.

This field is read-only.

Remarks

This globally unique identifier (GUID) can be used for any class identifier when retrieving an effect using either the SecondaryBuffer.GetObjectInPath or CaptureBuffer.GetObjectInPath methods.


DSoundHelper.Interface3DBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.Interface3DBuffer Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the Buffer3D interface.

Definition

Visual Basic .NET | Public Shared Interface3DBuffer As Guid
C# | public static Guid Interface3DBuffer;
Managed C++ | public: static Guid Interface3DBuffer;
JScript .NET | public static var Interface3DBuffer : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the Buffer3D interface.

This field is read-only.


DSoundHelper.Interface3DListener

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.Interface3DListener Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the Listener3D interface.

Definition

Visual Basic .NET | Public Shared Interface3DListener As Guid
C# | public static Guid Interface3DListener;
Managed C++ | public: static Guid Interface3DListener;
JScript .NET | public static var Interface3DListener : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the Listener3D interface.

This field is read-only.


DSoundHelper.InterfaceBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceBuffer Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the Buffer interface.

Definition

Visual Basic .NET | Public Shared InterfaceBuffer As Guid
C# | public static Guid InterfaceBuffer;
Managed C++ | public: static Guid InterfaceBuffer;
JScript .NET | public static var InterfaceBuffer : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the Buffer interface.

This field is read-only.


DSoundHelper.InterfaceCaptureBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceCaptureBuffer Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the CaptureBuffer interface.

Definition

Visual Basic .NET | Public Shared InterfaceCaptureBuffer As Guid
C# | public static Guid InterfaceCaptureBuffer;
Managed C++ | public: static Guid InterfaceCaptureBuffer;
JScript .NET | public static var InterfaceCaptureBuffer : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the CaptureBuffer interface.

This field is read-only.


DSoundHelper.InterfaceCaptureEffectsAcousticEchoCancellation

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceCaptureEffectsAcousticEchoCancellation Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the acoustic echo cancellation capture effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceCaptureEffectsAcousticEchoCancellation As Guid
C# | public static Guid InterfaceCaptureEffectsAcousticEchoCancellation;
Managed C++ | public: static Guid InterfaceCaptureEffectsAcousticEchoCancellation;
JScript .NET | public static var InterfaceCaptureEffectsAcousticEchoCancellation : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the acoustic echo cancellation capture effect interface.

This field is read-only.

Remarks

This field is used to retrieve the CaptureAcousticEchoCancellationEffect object, that currently in a CaptureBuffer object, using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.InterfaceCaptureEffectsNoiseSuppress

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceCaptureEffectsNoiseSuppress Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the noise suppression capture effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceCaptureEffectsNoiseSuppress As Guid
C# | public static Guid InterfaceCaptureEffectsNoiseSuppress;
Managed C++ | public: static Guid InterfaceCaptureEffectsNoiseSuppress;
JScript .NET | public static var InterfaceCaptureEffectsNoiseSuppress : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the noise suppression capture effect interface.

This field is read-only.

Remarks

This field is used to retrieve the CaptureNoiseSuppressEffect object, that currently in a CaptureBuffer object, using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.InterfaceDirectSound

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceDirectSound Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the Microsoft.DirectX.DirectSound interface.

Definition

Visual Basic .NET | Public Shared InterfaceDirectSound As Guid
C# | public static Guid InterfaceDirectSound;
Managed C++ | public: static Guid InterfaceDirectSound;
JScript .NET | public static var InterfaceDirectSound : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the Microsoft.DirectX.DirectSound interface.

This field is read-only.


DSoundHelper.InterfaceDirectSoundCapture

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceDirectSoundCapture Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the Capture interface.

Definition

Visual Basic .NET | Public Shared InterfaceDirectSoundCapture As Guid
C# | public static Guid InterfaceDirectSoundCapture;
Managed C++ | public: static Guid InterfaceDirectSoundCapture;
JScript .NET | public static var InterfaceDirectSoundCapture : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the Capture interface.

This field is read-only.


DSoundHelper.InterfaceEffectsChorus

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsChorus Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the chorus effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsChorus As Guid
C# | public static Guid InterfaceEffectsChorus;
Managed C++ | public: static Guid InterfaceEffectsChorus;
JScript .NET | public static var InterfaceEffectsChorus : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the chorus effect interface.

This field is read-only.

Remarks

This field is used to retrieve the ChorusEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsCompressor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsCompressor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the compressor effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsCompressor As Guid
C# | public static Guid InterfaceEffectsCompressor;
Managed C++ | public: static Guid InterfaceEffectsCompressor;
JScript .NET | public static var InterfaceEffectsCompressor : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the compressor effect interface.

This field is read-only.

Remarks

This field is used to retrieve the CompressorEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsDistortion

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsDistortion Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the distortion effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsDistortion As Guid
C# | public static Guid InterfaceEffectsDistortion;
Managed C++ | public: static Guid InterfaceEffectsDistortion;
JScript .NET | public static var InterfaceEffectsDistortion : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the distortion effect interface.

This field is read-only.

Remarks

This field is used to retrieve the DistortionEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsEcho

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsEcho Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the echo effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsEcho As Guid
C# | public static Guid InterfaceEffectsEcho;
Managed C++ | public: static Guid InterfaceEffectsEcho;
JScript .NET | public static var InterfaceEffectsEcho : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the echo effect interface.

This field is read-only.

Remarks

This field is used to retrieve the EchoEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsFlanger

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsFlanger Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the flanger effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsFlanger As Guid
C# | public static Guid InterfaceEffectsFlanger;
Managed C++ | public: static Guid InterfaceEffectsFlanger;
JScript .NET | public static var InterfaceEffectsFlanger : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the flanger effect interface.

This field is read-only.

Remarks

This field is used to retrieve the FlangerEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsGargle

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsGargle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the gargle effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsGargle As Guid
C# | public static Guid InterfaceEffectsGargle;
Managed C++ | public: static Guid InterfaceEffectsGargle;
JScript .NET | public static var InterfaceEffectsGargle : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the gargle effect interface.

This field is read-only.

Remarks

This field is used to retrieve the GargleEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsInteractive3DLevel2Reverb

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsInteractive3DLevel2Reverb Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the interactive 3-D level2 reverb effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsInteractive3DLevel2Reverb As Guid
C# | public static Guid InterfaceEffectsInteractive3DLevel2Reverb;
Managed C++ | public: static Guid InterfaceEffectsInteractive3DLevel2Reverb;
JScript .NET | public static var InterfaceEffectsInteractive3DLevel2Reverb : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the interactive 3-D level2 reverb effect interface.

This field is read-only.

Remarks

This field is used to retrieve the Interactive3DLevel2ReverbEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsParamEq

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsParamEq Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the parameteric equalizer effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsParamEq As Guid
C# | public static Guid InterfaceEffectsParamEq;
Managed C++ | public: static Guid InterfaceEffectsParamEq;
JScript .NET | public static var InterfaceEffectsParamEq : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the parameteric equalizer effect interface.

This field is read-only.

Remarks

This field is used to retrieve the ParamEqEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsWavesReverb

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceEffectsWavesReverb Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the Waves reverb effect interface.

Definition

Visual Basic .NET | Public Shared InterfaceEffectsWavesReverb As Guid
C# | public static Guid InterfaceEffectsWavesReverb;
Managed C++ | public: static Guid InterfaceEffectsWavesReverb;
JScript .NET | public static var InterfaceEffectsWavesReverb : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the Waves reverb effect interface.

This field is read-only.

Remarks

This field is used to retrieve the WavesReverbEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceNotify

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceNotify Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the Notify interface.

Definition

Visual Basic .NET | Public Shared InterfaceNotify As Guid
C# | public static Guid InterfaceNotify;
Managed C++ | public: static Guid InterfaceNotify;
JScript .NET | public static var InterfaceNotify : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the Notify interface.

This field is read-only.


DSoundHelper.InterfaceSecondaryBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.InterfaceSecondaryBuffer Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) for the SecondaryBuffer interface.

Definition

Visual Basic .NET | Public Shared InterfaceSecondaryBuffer As Guid
C# | public static Guid InterfaceSecondaryBuffer;
Managed C++ | public: static Guid InterfaceSecondaryBuffer;
JScript .NET | public static var InterfaceSecondaryBuffer : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) for the SecondaryBuffer interface.

This field is read-only.


DSoundHelper.MaxConeAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MaxConeAngle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum cone angle for an Angles structure, in degrees.

Definition

Visual Basic .NET | Public Shared MaxConeAngle As Single
C# | public static Single MaxConeAngle;
Managed C++ | public: static Single MaxConeAngle;
JScript .NET | public static var MaxConeAngle : Single

Field Value

System.Single . Returns the maximum cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.MaxDistanceFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MaxDistanceFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared MaxDistanceFactor As Single
C# | public static Single MaxDistanceFactor;
Managed C++ | public: static Single MaxDistanceFactor;
JScript .NET | public static var MaxDistanceFactor : Single

Field Value

System.Single . Returns the maximum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

This field is read-only.


DSoundHelper.MaxDopplerFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MaxDopplerFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared MaxDopplerFactor As Single
C# | public static Single MaxDopplerFactor;
Managed C++ | public: static Single MaxDopplerFactor;
JScript .NET | public static var MaxDopplerFactor : Single

Field Value

System.Single . Returns the maximum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

This field is read-only.


DSoundHelper.MaxRolloffFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MaxRolloffFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared MaxRolloffFactor As Single
C# | public static Single MaxRolloffFactor;
Managed C++ | public: static Single MaxRolloffFactor;
JScript .NET | public static var MaxRolloffFactor : Single

Field Value

System.Single . Returns the maximum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

This field is read-only.


DSoundHelper.MinConeAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MinConeAngle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum cone angle for an Angles structure, in degrees.

Definition

Visual Basic .NET | Public Shared MinConeAngle As Single
C# | public static Single MinConeAngle;
Managed C++ | public: static Single MinConeAngle;
JScript .NET | public static var MinConeAngle : Single

Field Value

System.Single . Returns the minimum cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.MinDistanceFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MinDistanceFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared MinDistanceFactor As Single
C# | public static Single MinDistanceFactor;
Managed C++ | public: static Single MinDistanceFactor;
JScript .NET | public static var MinDistanceFactor : Single

Field Value

System.Single . Returns the minimum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

This field is read-only.


DSoundHelper.MinDopplerFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MinDopplerFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared MinDopplerFactor As Single
C# | public static Single MinDopplerFactor;
Managed C++ | public: static Single MinDopplerFactor;
JScript .NET | public static var MinDopplerFactor : Single

Field Value

System.Single . Returns the minimum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

This field is read-only.


DSoundHelper.MinRolloffFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.MinRolloffFactor Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

Definition

Visual Basic .NET | Public Shared MinRolloffFactor As Single
C# | public static Single MinRolloffFactor;
Managed C++ | public: static Single MinRolloffFactor;
JScript .NET | public static var MinRolloffFactor : Single

Field Value

System.Single . Returns the minimum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

This field is read-only.


DSoundHelper.StandardChorusGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardChorusGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the chorus effect.

Definition

Visual Basic .NET | Public Shared StandardChorusGuid As Guid
C# | public static Guid StandardChorusGuid;
Managed C++ | public: static Guid StandardChorusGuid;
JScript .NET | public static var StandardChorusGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the chorus effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the chorus effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardCompressorGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardCompressorGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the compressor effect.

Definition

Visual Basic .NET | Public Shared StandardCompressorGuid As Guid
C# | public static Guid StandardCompressorGuid;
Managed C++ | public: static Guid StandardCompressorGuid;
JScript .NET | public static var StandardCompressorGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the compressor effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the compressor effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardDistortionGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardDistortionGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the distortion effect.

Definition

Visual Basic .NET | Public Shared StandardDistortionGuid As Guid
C# | public static Guid StandardDistortionGuid;
Managed C++ | public: static Guid StandardDistortionGuid;
JScript .NET | public static var StandardDistortionGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the distortion effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the distortion effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardEchoGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardEchoGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the echo effect.

Definition

Visual Basic .NET | Public Shared StandardEchoGuid As Guid
C# | public static Guid StandardEchoGuid;
Managed C++ | public: static Guid StandardEchoGuid;
JScript .NET | public static var StandardEchoGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the echo effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the echo effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardFlangerGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardFlangerGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the flanger effect.

Definition

Visual Basic .NET | Public Shared StandardFlangerGuid As Guid
C# | public static Guid StandardFlangerGuid;
Managed C++ | public: static Guid StandardFlangerGuid;
JScript .NET | public static var StandardFlangerGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the flanger effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the flanger effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardGargleGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardGargleGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the gargle effect.

Definition

Visual Basic .NET | Public Shared StandardGargleGuid As Guid
C# | public static Guid StandardGargleGuid;
Managed C++ | public: static Guid StandardGargleGuid;
JScript .NET | public static var StandardGargleGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the gargle effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the gargle effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardInteractive3DLevel2ReverbGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardInteractive3DLevel2ReverbGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the interactive 3-D level2 reverb effect.

Definition

Visual Basic .NET | Public Shared StandardInteractive3DLevel2ReverbGuid As Guid
C# | public static Guid StandardInteractive3DLevel2ReverbGuid;
Managed C++ | public: static Guid StandardInteractive3DLevel2ReverbGuid;
JScript .NET | public static var StandardInteractive3DLevel2ReverbGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the interactive 3-D level2 reverb effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the interactive 3-D level2 reverb effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardParamEqGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardParamEqGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the parameteric equalizer effect.

Definition

Visual Basic .NET | Public Shared StandardParamEqGuid As Guid
C# | public static Guid StandardParamEqGuid;
Managed C++ | public: static Guid StandardParamEqGuid;
JScript .NET | public static var StandardParamEqGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the parameteric equalizer effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the parameteric equalizer effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardWavesReverbGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DSoundHelper.StandardWavesReverbGuid Field

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the Waves reverb effect.

Definition

Visual Basic .NET | Public Shared StandardWavesReverbGuid As Guid
C# | public static Guid StandardWavesReverbGuid;
Managed C++ | public: static Guid StandardWavesReverbGuid;
JScript .NET | public static var StandardWavesReverbGuid : Guid

Field Value

System.Guid . Returns the globally unique identifier (GUID) class identifier for the Waves reverb effect.

This field is read-only.

Remarks

This globally unique identifier (GUID) is used by the EffectDescription structure to set the Waves reverb effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


Microsoft.DirectX.DirectSound.EchoEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports echo.

Definition

Visual Basic .NET Public Class EchoEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class EchoEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class EchoEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class EchoEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the EchoEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) FeedbackMax | Retrieves the maximum value for the EffectsEcho.Feedback property.
static (Shared in Visual Basic .NET) FeedbackMin | Retrieves the minimum value for the EffectsEcho.Feedback property.
static (Shared in Visual Basic .NET) LeftDelayMax | Retrieves the maximum value for the EffectsEcho.LeftDelay property.
static (Shared in Visual Basic .NET) LeftDelayMin | Retrieves the minimum value for the EffectsEcho.LeftDelay property.
static (Shared in Visual Basic .NET) PanDelayMax | Retrieves the maximum value for the EffectsEcho.PanDelay property.
static (Shared in Visual Basic .NET) PanDelayMin | Retrieves the minimum value for the EffectsEcho.PanDelay property.
static (Shared in Visual Basic .NET) RightDelayMax | Retrieves the maximum value for the EffectsEcho.RightDelay property.
static (Shared in Visual Basic .NET) RightDelayMin | Retrieves the minimum value for the EffectsEcho.RightDelay property.
static (Shared in Visual Basic .NET) WetDryMixMax | Retrieves the maximum value for the EffectsEcho.WetDryMix property.
static (Shared in Visual Basic .NET) WetDryMixMin | Retrieves the minimum value for the EffectsEcho.WetDryMix property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the EchoEffect object.
EchoEffect | Initializes a new instance of the EchoEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the EchoEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the EchoEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets echo parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
EchoEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EchoEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the EchoEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • EchoEffect.Disposed
  • EchoEffect.Disposing


EchoEffect.EchoEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.EchoEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EchoEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public EchoEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: EchoEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function EchoEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXEcho8, which allows unmanaged COM clients to create an instance of the managed EchoEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the EchoEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


EchoEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EchoEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the EchoEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~EchoEffect();
Managed C++ | ~EchoEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


EchoEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


EchoEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXEcho8, which allows unmanaged COM clients to create an instance of the managed EchoEffect class. Not supported.


EchoEffect.op_Equality(EchoEffect,EchoEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As EchoEffect, _
ByVal right As EchoEffect _
) As Boolean
C# public static bool op_Equality(
EchoEffect left,
EchoEffect right
);
Managed C++ public: static bool op_Equality(
EchoEffect *left,
EchoEffect *right
);
JScript .NET public static function op_Equality(
left : EchoEffect,
right : EchoEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.EchoEffect. The EchoEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.EchoEffect. The EchoEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


EchoEffect.op_Inequality(EchoEffect,EchoEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As EchoEffect, _
ByVal right As EchoEffect _
) As Boolean
C# public static bool op_Inequality(
EchoEffect left,
EchoEffect right
);
Managed C++ public: static bool op_Inequality(
EchoEffect *left,
EchoEffect *right
);
JScript .NET public static function op_Inequality(
left : EchoEffect,
right : EchoEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.EchoEffect. The EchoEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.EchoEffect. The EchoEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


EchoEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the EchoEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


EchoEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets echo parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsEcho
C# | public EffectsEcho AllParameters { get; set; }
Managed C++ public: __property EffectsEcho get_AllParameters();
public: __property void set_AllParameters(EffectsEcho);
JScript .NET public function get AllParameters() : EffectsEcho
public function set AllParameters(EffectsEcho);

Property Value

Microsoft.DirectX.DirectSound.EffectsEcho . Contains parameters for an echo effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


EchoEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


EchoEffect.FeedbackMax

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.FeedbackMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsEcho.Feedback property.

Definition

Visual Basic .NET | Public Shared FeedbackMax As Single
C# | public static Single FeedbackMax;
Managed C++ | public: static Single FeedbackMax;
JScript .NET | public static var FeedbackMax : Single

Field Value

System.Single . Maximum value for the EffectsEcho.Feedback property.

This field is read-only.

See Also

  • EffectsEcho.Feedback


EchoEffect.FeedbackMin

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.FeedbackMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsEcho.Feedback property.

Definition

Visual Basic .NET | Public Shared FeedbackMin As Single
C# | public static Single FeedbackMin;
Managed C++ | public: static Single FeedbackMin;
JScript .NET | public static var FeedbackMin : Single

Field Value

System.Single . Minimum value for the EffectsEcho.Feedback property.

This field is read-only.

See Also

  • EffectsEcho.Feedback


EchoEffect.LeftDelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.LeftDelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsEcho.LeftDelay property.

Definition

Visual Basic .NET | Public Shared LeftDelayMax As Single
C# | public static Single LeftDelayMax;
Managed C++ | public: static Single LeftDelayMax;
JScript .NET | public static var LeftDelayMax : Single

Field Value

System.Single . Maximum value for the EffectsEcho.LeftDelay property.

This field is read-only.

See Also

  • EffectsEcho.LeftDelay


EchoEffect.LeftDelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.LeftDelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsEcho.LeftDelay property.

Definition

Visual Basic .NET | Public Shared LeftDelayMin As Single
C# | public static Single LeftDelayMin;
Managed C++ | public: static Single LeftDelayMin;
JScript .NET | public static var LeftDelayMin : Single

Field Value

System.Single . Minimum value for the EffectsEcho.LeftDelay property.

This field is read-only.

See Also

  • EffectsEcho.LeftDelay


EchoEffect.PanDelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.PanDelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsEcho.PanDelay property.

Definition

Visual Basic .NET | Public Shared PanDelayMax As Int32
C# | public static Int32 PanDelayMax;
Managed C++ | public: static Int32 PanDelayMax;
JScript .NET | public static var PanDelayMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsEcho.PanDelay property.

This field is read-only.

See Also

  • EffectsEcho.PanDelay


EchoEffect.PanDelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.PanDelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsEcho.PanDelay property.

Definition

Visual Basic .NET | Public Shared PanDelayMin As Int32
C# | public static Int32 PanDelayMin;
Managed C++ | public: static Int32 PanDelayMin;
JScript .NET | public static var PanDelayMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsEcho.PanDelay property.

This field is read-only.

See Also

  • EffectsEcho.PanDelay


EchoEffect.RightDelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.RightDelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsEcho.RightDelay property.

Definition

Visual Basic .NET | Public Shared RightDelayMax As Single
C# | public static Single RightDelayMax;
Managed C++ | public: static Single RightDelayMax;
JScript .NET | public static var RightDelayMax : Single

Field Value

System.Single . Maximum value for the EffectsEcho.RightDelay property.

This field is read-only.

See Also

  • EffectsEcho.RightDelay


EchoEffect.RightDelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.RightDelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsEcho.RightDelay property.

Definition

Visual Basic .NET | Public Shared RightDelayMin As Single
C# | public static Single RightDelayMin;
Managed C++ | public: static Single RightDelayMin;
JScript .NET | public static var RightDelayMin : Single

Field Value

System.Single . Minimum value for the EffectsEcho.RightDelay property.

This field is read-only.

See Also

  • EffectsEcho.RightDelay


EchoEffect.WetDryMixMax

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.WetDryMixMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsEcho.WetDryMix property.

Definition

Visual Basic .NET | Public Shared WetDryMixMax As Single
C# | public static Single WetDryMixMax;
Managed C++ | public: static Single WetDryMixMax;
JScript .NET | public static var WetDryMixMax : Single

Field Value

System.Single . Maximum value for the EffectsEcho.WetDryMix property.

This field is read-only.

See Also

  • EffectsEcho.WetDryMix


EchoEffect.WetDryMixMin

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.WetDryMixMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsEcho.WetDryMix property.

Definition

Visual Basic .NET | Public Shared WetDryMixMin As Single
C# | public static Single WetDryMixMin;
Managed C++ | public: static Single WetDryMixMin;
JScript .NET | public static var WetDryMixMin : Single

Field Value

System.Single . Minimum value for the EffectsEcho.WetDryMix property.

This field is read-only.

See Also

  • EffectsEcho.WetDryMix


EchoEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

EchoEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the EchoEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the EchoEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the EchoEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.EffectsUnavailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsUnavailableException Class

Language:
Note: This documentation is preliminary and is subject to change.

The effects requested could not be found on the system, or they are in the wrong order or in the wrong location; for example, an effect expected in hardware was found in software.

Definition

Visual Basic .NET Public Class EffectsUnavailableException
Inherits SoundException
C# | public class EffectsUnavailableException : SoundException
Managed C++ | public __gc class EffectsUnavailableException : public SoundException
JScript .NET | public class EffectsUnavailableException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
EffectsUnavailableException | Initializes a new instance of the EffectsUnavailableException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
EffectsUnavailableException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


EffectsUnavailableException.EffectsUnavailableException

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectsUnavailableException class.

Overload List

public EffectsUnavailableException();
protected EffectsUnavailableException(SerializationInfo, StreamingContext);
public EffectsUnavailableException(string);
public EffectsUnavailableException(string, Exception);


EffectsUnavailableException.EffectsUnavailableException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected EffectsUnavailableException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: EffectsUnavailableException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function EffectsUnavailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


EffectsUnavailableException.EffectsUnavailableException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public EffectsUnavailableException(
string message,
Exception inner
);
Managed C++ public: EffectsUnavailableException(
String *message,
Exception *inner
);
JScript .NET public function EffectsUnavailableException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


EffectsUnavailableException.EffectsUnavailableException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public EffectsUnavailableException(
string message
);
Managed C++ public: EffectsUnavailableException(
String *message
);
JScript .NET public function EffectsUnavailableException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


EffectsUnavailableException.EffectsUnavailableException()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsUnavailableException();
Managed C++ | public: EffectsUnavailableException();
JScript .NET | public function EffectsUnavailableException();


Microsoft.DirectX.DirectSound.FlangerEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports flange.

Definition

Visual Basic .NET Public Class FlangerEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class FlangerEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class FlangerEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class FlangerEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the FlangerEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) DelayMax | Retrieves the maximum value for the EffectsFlanger.Delay property.
static (Shared in Visual Basic .NET) DelayMin | Retrieves the minimum value for the EffectsFlanger.Delay property.
static (Shared in Visual Basic .NET) DepthMax | Retrieves the maximum value for the EffectsFlanger.Depth property.
static (Shared in Visual Basic .NET) DepthMin | Retrieves the minimum value for the EffectsFlanger.Depth property.
static (Shared in Visual Basic .NET) FeedbackMax | Retrieves the maximum value for the EffectsFlanger.Feedback property.
static (Shared in Visual Basic .NET) FeedbackMin | Retrieves the minimum value for the EffectsFlanger.Feedback property.
static (Shared in Visual Basic .NET) FrequencyMax | Retrieves the maximum value for the EffectsFlanger.Frequency property.
static (Shared in Visual Basic .NET) FrequencyMin | Retrieves the minimum value for the EffectsFlanger.Frequency property.
static (Shared in Visual Basic .NET) Phase180 | Retrieves the value of 180 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic .NET) Phase90 | Retrieves the value of 90 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic .NET) PhaseMax | Retrieves the maximum value for the EffectsFlanger.Phase property.
static (Shared in Visual Basic .NET) PhaseMin | Retrieves the minimum value for the EffectsFlanger.Phase property.
static (Shared in Visual Basic .NET) PhaseNeg180 | Retrieves the value of negative 180 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic .NET) PhaseNeg90 | Retrieves the value of negative 90 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic .NET) PhaseZero | Retrieves the value of zero degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic .NET) WaveSin | Retrieves the value for a sine waveform for the EffectsFlanger.Waveform property.
static (Shared in Visual Basic .NET) WaveTriangle | Retrieves the value for a triangle waveform for the EffectsFlanger.Waveform property.
static (Shared in Visual Basic .NET) WetDryMixMax | Retrieves the maximum value for the EffectsFlanger.WetDryMix property.
static (Shared in Visual Basic .NET) WetDryMixMin | Retrieves the minimum value for the EffectsFlanger.WetDryMix property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the FlangerEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the FlangerEffect object to free resources before it is destroyed by the garbage collector.
FlangerEffect | Initializes a new instance of the FlangerEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the FlangerEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets flanger parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
FlangerEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FlangerEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the FlangerEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • FlangerEffect.Disposed
  • FlangerEffect.Disposing


FlangerEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


FlangerEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the FlangerEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~FlangerEffect();
Managed C++ | ~FlangerEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


FlangerEffect.FlangerEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.FlangerEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FlangerEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public FlangerEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: FlangerEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function FlangerEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXFlanger8, which allows unmanaged COM clients to create an instance of the managed FlangerEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the FlangerEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


FlangerEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


FlangerEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXFlanger8, which allows unmanaged COM clients to create an instance of the managed FlangerEffect class. Not supported.


FlangerEffect.op_Equality(FlangerEffect,FlangerEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As FlangerEffect, _
ByVal right As FlangerEffect _
) As Boolean
C# public static bool op_Equality(
FlangerEffect left,
FlangerEffect right
);
Managed C++ public: static bool op_Equality(
FlangerEffect *left,
FlangerEffect *right
);
JScript .NET public static function op_Equality(
left : FlangerEffect,
right : FlangerEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.FlangerEffect. The FlangerEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.FlangerEffect. The FlangerEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


FlangerEffect.op_Inequality(FlangerEffect,FlangerEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As FlangerEffect, _
ByVal right As FlangerEffect _
) As Boolean
C# public static bool op_Inequality(
FlangerEffect left,
FlangerEffect right
);
Managed C++ public: static bool op_Inequality(
FlangerEffect *left,
FlangerEffect *right
);
JScript .NET public static function op_Inequality(
left : FlangerEffect,
right : FlangerEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.FlangerEffect. The FlangerEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.FlangerEffect. The FlangerEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


FlangerEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the FlangerEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


FlangerEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets flanger parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsFlanger
C# | public EffectsFlanger AllParameters { get; set; }
Managed C++ public: __property EffectsFlanger get_AllParameters();
public: __property void set_AllParameters(EffectsFlanger);
JScript .NET public function get AllParameters() : EffectsFlanger
public function set AllParameters(EffectsFlanger);

Property Value

Microsoft.DirectX.DirectSound.EffectsFlanger . Contains parameters for a flanger effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


FlangerEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


FlangerEffect.DelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.DelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsFlanger.Delay property.

Definition

Visual Basic .NET | Public Shared DelayMax As Single
C# | public static Single DelayMax;
Managed C++ | public: static Single DelayMax;
JScript .NET | public static var DelayMax : Single

Field Value

System.Single . Maximum value for the EffectsFlanger.Delay property.

This field is read-only.

See Also

  • EffectsFlanger.Delay


FlangerEffect.DelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.DelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsFlanger.Delay property.

Definition

Visual Basic .NET | Public Shared DelayMin As Single
C# | public static Single DelayMin;
Managed C++ | public: static Single DelayMin;
JScript .NET | public static var DelayMin : Single

Field Value

System.Single . Minimum value for the EffectsFlanger.Delay property.

This field is read-only.

See Also

  • EffectsFlanger.Delay


FlangerEffect.DepthMax

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.DepthMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsFlanger.Depth property.

Definition

Visual Basic .NET | Public Shared DepthMax As Single
C# | public static Single DepthMax;
Managed C++ | public: static Single DepthMax;
JScript .NET | public static var DepthMax : Single

Field Value

System.Single . Maximum value for the EffectsFlanger.Depth property.

This field is read-only.

See Also

  • EffectsFlanger.Depth


FlangerEffect.DepthMin

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.DepthMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsFlanger.Depth property.

Definition

Visual Basic .NET | Public Shared DepthMin As Single
C# | public static Single DepthMin;
Managed C++ | public: static Single DepthMin;
JScript .NET | public static var DepthMin : Single

Field Value

System.Single . Minimum value for the EffectsFlanger.Depth property.

This field is read-only.

See Also

  • EffectsFlanger.Depth


FlangerEffect.FeedbackMax

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.FeedbackMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsFlanger.Feedback property.

Definition

Visual Basic .NET | Public Shared FeedbackMax As Single
C# | public static Single FeedbackMax;
Managed C++ | public: static Single FeedbackMax;
JScript .NET | public static var FeedbackMax : Single

Field Value

System.Single . Maximum value for the EffectsFlanger.Feedback property.

This field is read-only.

See Also

  • EffectsFlanger.Feedback


FlangerEffect.FeedbackMin

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.FeedbackMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsFlanger.Feedback property.

Definition

Visual Basic .NET | Public Shared FeedbackMin As Single
C# | public static Single FeedbackMin;
Managed C++ | public: static Single FeedbackMin;
JScript .NET | public static var FeedbackMin : Single

Field Value

System.Single . Minimum value for the EffectsFlanger.Feedback property.

This field is read-only.

See Also

  • EffectsFlanger.Feedback


FlangerEffect.FrequencyMax

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.FrequencyMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsFlanger.Frequency property.

Definition

Visual Basic .NET | Public Shared FrequencyMax As Single
C# | public static Single FrequencyMax;
Managed C++ | public: static Single FrequencyMax;
JScript .NET | public static var FrequencyMax : Single

Field Value

System.Single . Maximum value for the EffectsFlanger.Frequency property.

This field is read-only.

See Also

  • EffectsFlanger.Frequency


FlangerEffect.FrequencyMin

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.FrequencyMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsFlanger.Frequency property.

Definition

Visual Basic .NET | Public Shared FrequencyMin As Single
C# | public static Single FrequencyMin;
Managed C++ | public: static Single FrequencyMin;
JScript .NET | public static var FrequencyMin : Single

Field Value

System.Single . Minimum value for the EffectsFlanger.Frequency property.

This field is read-only.

See Also

  • EffectsFlanger.Frequency


FlangerEffect.Phase180

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.Phase180 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of 180 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic .NET | Public Shared Phase180 As Int32
C# | public static Int32 Phase180;
Managed C++ | public: static Int32 Phase180;
JScript .NET | public static var Phase180 : Int32

Field Value

System.Int32 . Value of 180 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.Phase90

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.Phase90 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of 90 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic .NET | Public Shared Phase90 As Int32
C# | public static Int32 Phase90;
Managed C++ | public: static Int32 Phase90;
JScript .NET | public static var Phase90 : Int32

Field Value

System.Int32 . Value of 90 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseMax

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.PhaseMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsFlanger.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseMax As Int32
C# | public static Int32 PhaseMax;
Managed C++ | public: static Int32 PhaseMax;
JScript .NET | public static var PhaseMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseMin

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.PhaseMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsFlanger.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseMin As Int32
C# | public static Int32 PhaseMin;
Managed C++ | public: static Int32 PhaseMin;
JScript .NET | public static var PhaseMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseNeg180

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.PhaseNeg180 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of negative 180 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseNeg180 As Int32
C# | public static Int32 PhaseNeg180;
Managed C++ | public: static Int32 PhaseNeg180;
JScript .NET | public static var PhaseNeg180 : Int32

Field Value

System.Int32 . Value of negative 180 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseNeg90

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.PhaseNeg90 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of negative 90 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseNeg90 As Int32
C# | public static Int32 PhaseNeg90;
Managed C++ | public: static Int32 PhaseNeg90;
JScript .NET | public static var PhaseNeg90 : Int32

Field Value

System.Int32 . Value of negative 90 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseZero

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.PhaseZero Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value of zero degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic .NET | Public Shared PhaseZero As Int32
C# | public static Int32 PhaseZero;
Managed C++ | public: static Int32 PhaseZero;
JScript .NET | public static var PhaseZero : Int32

Field Value

System.Int32 . Value of zero degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.WaveSin

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.WaveSin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value for a sine waveform for the EffectsFlanger.Waveform property.

Definition

Visual Basic .NET | Public Shared WaveSin As Int32
C# | public static Int32 WaveSin;
Managed C++ | public: static Int32 WaveSin;
JScript .NET | public static var WaveSin : Int32

Field Value

System.Int32 . Value for a sine waveform for the EffectsFlanger.Waveform property.

This field is read-only.

See Also

  • EffectsFlanger.Waveform


FlangerEffect.WaveTriangle

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.WaveTriangle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value for a triangle waveform for the EffectsFlanger.Waveform property.

Definition

Visual Basic .NET | Public Shared WaveTriangle As Int32
C# | public static Int32 WaveTriangle;
Managed C++ | public: static Int32 WaveTriangle;
JScript .NET | public static var WaveTriangle : Int32

Field Value

System.Int32 . Value for a triangle waveform for the EffectsFlanger.Waveform property.

This field is read-only.

See Also

  • EffectsFlanger.Waveform


FlangerEffect.WetDryMixMax

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.WetDryMixMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsFlanger.WetDryMix property.

Definition

Visual Basic .NET | Public Shared WetDryMixMax As Single
C# | public static Single WetDryMixMax;
Managed C++ | public: static Single WetDryMixMax;
JScript .NET | public static var WetDryMixMax : Single

Field Value

System.Single . Maximum value for the EffectsFlanger.WetDryMix property.

This field is read-only.

See Also

  • EffectsFlanger.WetDryMix


FlangerEffect.WetDryMixMin

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.WetDryMixMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsFlanger.WetDryMix property.

Definition

Visual Basic .NET | Public Shared WetDryMixMin As Single
C# | public static Single WetDryMixMin;
Managed C++ | public: static Single WetDryMixMin;
JScript .NET | public static var WetDryMixMin : Single

Field Value

System.Single . Minimum value for the EffectsFlanger.WetDryMix property.

This field is read-only.

See Also

  • EffectsFlanger.WetDryMix


FlangerEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

FlangerEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the FlangerEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the FlangerEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the FlangerEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.FullDuplex

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex Class

Language:
Note: This documentation is preliminary and is subject to change.

Represents a full-duplex stream.

Definition

Visual Basic .NET Public Class FullDuplex
Inherits MarshalByRefObject
Implements IDisposable
C# public class FullDuplex : MarshalByRefObject,
IDisposable
Managed C++ public __gc class FullDuplex : public MarshalByRefObject,
IDisposable
JScript .NET public class FullDuplex extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the FullDuplex object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the FullDuplex object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the FullDuplex object to free resources before it is destroyed by the garbage collector.
FullDuplex | Initializes a new instance of the FullDuplex class.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the FullDuplex.Disposing event when called from within a derived class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
FullDuplex

Remarks

The FullDuplex object requires Microsoft Windows XP or later. Full duplex can be implemented on other operating systems, but the capture and rendering devices must be created separately.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FullDuplex.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the FullDuplex object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • FullDuplex.Disposed
  • FullDuplex.Disposing


FullDuplex.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


FullDuplex.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the FullDuplex object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~FullDuplex();
Managed C++ | ~FullDuplex();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


FullDuplex.FullDuplex

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.FullDuplex Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FullDuplex class.

Overload List

public FullDuplex(CaptureBufferDescription, BufferDescription, Control, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);
public FullDuplex(CaptureBufferDescription, BufferDescription, IntPtr, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);
public FullDuplex(Guid, Guid, CaptureBufferDescription, BufferDescription, Control, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);
public FullDuplex(Guid, Guid, CaptureBufferDescription, BufferDescription, IntPtr, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(CaptureBufferDescription,BufferDescription,Control,CooperativeLevel,CaptureBuffer,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.FullDuplex Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic .NET Public Sub New( _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As Control, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
Control owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
Managed C++ public: FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription *bufferDesc,
Control *owner,
CooperativeLevel level,
CaptureBuffer **captureBuffer,
SecondaryBuffer **buffer
);
JScript .NET public function FullDuplex(
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : Control,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

captureDesc | Microsoft.DirectX.DirectSound.CaptureBufferDescription. The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc | Microsoft.DirectX.DirectSound.BufferDescription. The BufferDescription that specifies the characteristics of the render buffer.
owner | System.Windows.Forms.Control. The Control Leave Site that is the application window.
level | Microsoft.DirectX.DirectSound.CooperativeLevel. Cooperative level for the device.
captureBuffer | Microsoft.DirectX.DirectSound.CaptureBuffer. A reference to the CaptureBuffer object that is used for capturing audio data.
buffer | Microsoft.DirectX.DirectSound.SecondaryBuffer. A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(Guid,Guid,CaptureBufferDescription,BufferDescription,Control,CooperativeLevel,CaptureBuffer,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.FullDuplex Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic .NET Public Sub New( _
ByVal guidCapture As Guid, _
ByVal guidRender As Guid, _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As Control, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
Control owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
Managed C++ public: FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription *bufferDesc,
Control *owner,
CooperativeLevel level,
CaptureBuffer **captureBuffer,
SecondaryBuffer **buffer
);
JScript .NET public function FullDuplex(
guidCapture : Guid,
guidRender : Guid,
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : Control,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

guidCapture | System.Guid. The globally unique identifier (GUID) of the capture device driver.
guidRender | System.Guid. The globally unique identifier (GUID) of the render device driver.
captureDesc | Microsoft.DirectX.DirectSound.CaptureBufferDescription. The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc | Microsoft.DirectX.DirectSound.BufferDescription. The BufferDescription that specifies the characteristics of the render buffer.
owner | System.Windows.Forms.Control. The Control Leave Site that is the application window.
level | Microsoft.DirectX.DirectSound.CooperativeLevel. Cooperative level for the device.
captureBuffer | Microsoft.DirectX.DirectSound.CaptureBuffer. A reference to the CaptureBuffer object that is used for capturing audio data.
buffer | Microsoft.DirectX.DirectSound.SecondaryBuffer. A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(CaptureBufferDescription,BufferDescription,IntPtr,CooperativeLevel,CaptureBuffer,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.FullDuplex Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic .NET Public Sub New( _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As IntPtr, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
IntPtr owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
Managed C++ public: FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription *bufferDesc,
IntPtr owner,
CooperativeLevel level,
CaptureBuffer **captureBuffer,
SecondaryBuffer **buffer
);
JScript .NET public function FullDuplex(
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : IntPtr,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

captureDesc | Microsoft.DirectX.DirectSound.CaptureBufferDescription. The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc | Microsoft.DirectX.DirectSound.BufferDescription. The BufferDescription that specifies the characteristics of the render buffer.
owner | System.IntPtr. The handle of the application window.
level | Microsoft.DirectX.DirectSound.CooperativeLevel. Cooperative level for the device.
captureBuffer | Microsoft.DirectX.DirectSound.CaptureBuffer. A reference to the CaptureBuffer object that is used for capturing audio data.
buffer | Microsoft.DirectX.DirectSound.SecondaryBuffer. A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(Guid,Guid,CaptureBufferDescription,BufferDescription,IntPtr,CooperativeLevel,CaptureBuffer,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.FullDuplex Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic .NET Public Sub New( _
ByVal guidCapture As Guid, _
ByVal guidRender As Guid, _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As IntPtr, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
IntPtr owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
Managed C++ public: FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription *bufferDesc,
IntPtr owner,
CooperativeLevel level,
CaptureBuffer **captureBuffer,
SecondaryBuffer **buffer
);
JScript .NET public function FullDuplex(
guidCapture : Guid,
guidRender : Guid,
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : IntPtr,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

guidCapture | System.Guid. The globally unique identifier (GUID) of the capture device driver.
guidRender | System.Guid. The globally unique identifier (GUID) of the render device driver.
captureDesc | Microsoft.DirectX.DirectSound.CaptureBufferDescription. The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc | Microsoft.DirectX.DirectSound.BufferDescription. The BufferDescription that specifies the characteristics of the render buffer.
owner | System.IntPtr. The handle of the application window.
level | Microsoft.DirectX.DirectSound.CooperativeLevel. Cooperative level for the device.
captureBuffer | Microsoft.DirectX.DirectSound.CaptureBuffer. A reference to the CaptureBuffer object that is used for capturing audio data.
buffer | Microsoft.DirectX.DirectSound.SecondaryBuffer. A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


FullDuplex.op_Equality(FullDuplex,FullDuplex)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As FullDuplex, _
ByVal right As FullDuplex _
) As Boolean
C# public static bool op_Equality(
FullDuplex left,
FullDuplex right
);
Managed C++ public: static bool op_Equality(
FullDuplex *left,
FullDuplex *right
);
JScript .NET public static function op_Equality(
left : FullDuplex,
right : FullDuplex
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.FullDuplex. The FullDuplex object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.FullDuplex. The FullDuplex object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


FullDuplex.op_Inequality(FullDuplex,FullDuplex)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As FullDuplex, _
ByVal right As FullDuplex _
) As Boolean
C# public static bool op_Inequality(
FullDuplex left,
FullDuplex right
);
Managed C++ public: static bool op_Inequality(
FullDuplex *left,
FullDuplex *right
);
JScript .NET public static function op_Inequality(
left : FullDuplex,
right : FullDuplex
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.FullDuplex. The FullDuplex object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.FullDuplex. The FullDuplex object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


FullDuplex.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the FullDuplex.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


FullDuplex.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


FullDuplex.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

FullDuplex.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the FullDuplex object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the FullDuplex.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the FullDuplex object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.GargleEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports amplitude modulation.

Definition

Visual Basic .NET Public Class GargleEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class GargleEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class GargleEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class GargleEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the GargleEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) RateHzMax | Retrieves the maximum value for the EffectsGargle.RateHz property.
static (Shared in Visual Basic .NET) RateHzMin | Retrieves the minimum value for the EffectsGargle.RateHz property.
static (Shared in Visual Basic .NET) WaveSquare | Retrieves the value for a square modulation waveform for the EffectsGargle.WaveShape property.
static (Shared in Visual Basic .NET) WaveTriangle | Retrieves the value for a triangle modulation waveform for the EffectsGargle.WaveShape property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the GargleEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the GargleEffect object to free resources before it is destroyed by the garbage collector.
GargleEffect | Initializes a new instance of the GargleEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the GargleEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets gargle parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
GargleEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GargleEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the GargleEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • GargleEffect.Disposed
  • GargleEffect.Disposing


GargleEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


GargleEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the GargleEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~GargleEffect();
Managed C++ | ~GargleEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


GargleEffect.GargleEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.GargleEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GargleEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public GargleEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: GargleEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function GargleEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXGargle8 Interface, which allows unmanaged COM clients to create an instance of the managed GargleEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the GargleEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


GargleEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


GargleEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXGargle8, which allows unmanaged COM clients to create an instance of the managed GargleEffect class. Not supported.


GargleEffect.op_Equality(GargleEffect,GargleEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As GargleEffect, _
ByVal right As GargleEffect _
) As Boolean
C# public static bool op_Equality(
GargleEffect left,
GargleEffect right
);
Managed C++ public: static bool op_Equality(
GargleEffect *left,
GargleEffect *right
);
JScript .NET public static function op_Equality(
left : GargleEffect,
right : GargleEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.GargleEffect. The GargleEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.GargleEffect. The GargleEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


GargleEffect.op_Inequality(GargleEffect,GargleEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As GargleEffect, _
ByVal right As GargleEffect _
) As Boolean
C# public static bool op_Inequality(
GargleEffect left,
GargleEffect right
);
Managed C++ public: static bool op_Inequality(
GargleEffect *left,
GargleEffect *right
);
JScript .NET public static function op_Inequality(
left : GargleEffect,
right : GargleEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.GargleEffect. The GargleEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.GargleEffect. The GargleEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


GargleEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the GargleEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


GargleEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets gargle parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsGargle
C# | public EffectsGargle AllParameters { get; set; }
Managed C++ public: __property EffectsGargle get_AllParameters();
public: __property void set_AllParameters(EffectsGargle);
JScript .NET public function get AllParameters() : EffectsGargle
public function set AllParameters(EffectsGargle);

Property Value

Microsoft.DirectX.DirectSound.EffectsGargle . Contains parameters for a gargle effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


GargleEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


GargleEffect.RateHzMax

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.RateHzMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsGargle.RateHz property.

Definition

Visual Basic .NET | Public Shared RateHzMax As Int32
C# | public static Int32 RateHzMax;
Managed C++ | public: static Int32 RateHzMax;
JScript .NET | public static var RateHzMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsGargle.RateHz property.

This field is read-only.

See Also

  • EffectsGargle.RateHz


GargleEffect.RateHzMin

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.RateHzMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsGargle.RateHz property.

Definition

Visual Basic .NET | Public Shared RateHzMin As Int32
C# | public static Int32 RateHzMin;
Managed C++ | public: static Int32 RateHzMin;
JScript .NET | public static var RateHzMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsGargle.RateHz property.

This field is read-only.

See Also

  • EffectsGargle.RateHz


GargleEffect.WaveSquare

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.WaveSquare Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value for a square modulation waveform for the EffectsGargle.WaveShape property.

Definition

Visual Basic .NET | Public Shared WaveSquare As Int32
C# | public static Int32 WaveSquare;
Managed C++ | public: static Int32 WaveSquare;
JScript .NET | public static var WaveSquare : Int32

Field Value

System.Int32 . Value for a square modulation waveform for the EffectsGargle.WaveShape property.

This field is read-only.

See Also

  • EffectsGargle.WaveShape


GargleEffect.WaveTriangle

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.WaveTriangle Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the value for a triangle modulation waveform for the EffectsGargle.WaveShape property.

Definition

Visual Basic .NET | Public Shared WaveTriangle As Int32
C# | public static Int32 WaveTriangle;
Managed C++ | public: static Int32 WaveTriangle;
JScript .NET | public static var WaveTriangle : Int32

Field Value

System.Int32 . Value for a triangle modulation waveform for the EffectsGargle.WaveShape property.

This field is read-only.

See Also

  • EffectsGargle.WaveShape


GargleEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

GargleEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the GargleEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the GargleEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the GargleEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Interactive 3-D Audio Level 2 (I3DL2) reverberation effects.

Definition

Visual Basic .NET Public Class Interactive3DLevel2ReverbEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class Interactive3DLevel2ReverbEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Interactive3DLevel2ReverbEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class Interactive3DLevel2ReverbEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Interactive3DLevel2ReverbEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) DecayHfRatioDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.
static (Shared in Visual Basic .NET) DecayHfRatioMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.
static (Shared in Visual Basic .NET) DecayHfRatioMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.
static (Shared in Visual Basic .NET) DecayTimeDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayTime property.
static (Shared in Visual Basic .NET) DecayTimeMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.
static (Shared in Visual Basic .NET) DecayTimeMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.
static (Shared in Visual Basic .NET) DensityDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Density property.
static (Shared in Visual Basic .NET) DensityMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Density property.
static (Shared in Visual Basic .NET) DensityMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Density property.
static (Shared in Visual Basic .NET) DiffusionDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Diffusion property.
static (Shared in Visual Basic .NET) DiffusionMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.
static (Shared in Visual Basic .NET) DiffusionMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.
static (Shared in Visual Basic .NET) HfReferenceDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.HfReference property.
static (Shared in Visual Basic .NET) HfReferenceMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.HfReference property.
static (Shared in Visual Basic .NET) HfReferenceMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.HfReference property.
static (Shared in Visual Basic .NET) QualityDefault | Retrieves the default value for the Interactive3DLevel2ReverbEffect.Quality property.
static (Shared in Visual Basic .NET) QualityMax | Retrieves the maximum value for the Interactive3DLevel2ReverbEffect.Quality property.
static (Shared in Visual Basic .NET) QualityMin | Retrieves the minimum value for the Interactive3DLevel2ReverbEffect.Quality property.
static (Shared in Visual Basic .NET) ReflectionsDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reflections property.
static (Shared in Visual Basic .NET) ReflectionsDelayDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.
static (Shared in Visual Basic .NET) ReflectionsDelayMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.
static (Shared in Visual Basic .NET) ReflectionsDelayMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.
static (Shared in Visual Basic .NET) ReflectionsMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reflections property.
static (Shared in Visual Basic .NET) ReflectionsMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reflections property.
static (Shared in Visual Basic .NET) ReverbDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reverb property.
static (Shared in Visual Basic .NET) ReverbDelayDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.
static (Shared in Visual Basic .NET) ReverbDelayMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.
static (Shared in Visual Basic .NET) ReverbDelayMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.
static (Shared in Visual Basic .NET) ReverbMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reverb property.
static (Shared in Visual Basic .NET) ReverbMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reverb property.
static (Shared in Visual Basic .NET) RoomDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Room property.
static (Shared in Visual Basic .NET) RoomHfDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomHf property.
static (Shared in Visual Basic .NET) RoomHfMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.
static (Shared in Visual Basic .NET) RoomHfMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.
static (Shared in Visual Basic .NET) RoomMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Room property.
static (Shared in Visual Basic .NET) RoomMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Room property.
static (Shared in Visual Basic .NET) RoomRollOffFactorDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.
static (Shared in Visual Basic .NET) RoomRollOffFactorMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.
static (Shared in Visual Basic .NET) RoomRollOffFactorMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Interactive3DLevel2ReverbEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Interactive3DLevel2ReverbEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
Interactive3DLevel2ReverbEffect | Initializes a new instance of the Interactive3DLevel2ReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Interactive3DLevel2ReverbEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets interactive 3-D level 2 (I3DL2) environmental reverberation parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.
Preset | Retrieves or sets a standard reverberation parameters of a SecondaryBuffer object.
Quality | Retrieves or sets the quality of the environmental reverberation effect.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Interactive3DLevel2ReverbEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Interactive3DLevel2ReverbEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Interactive3DLevel2ReverbEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Interactive3DLevel2ReverbEffect.Disposed
  • Interactive3DLevel2ReverbEffect.Disposing


Interactive3DLevel2ReverbEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Interactive3DLevel2ReverbEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Interactive3DLevel2ReverbEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Interactive3DLevel2ReverbEffect();
Managed C++ | ~Interactive3DLevel2ReverbEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Interactive3DLevel2ReverbEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Interactive3DLevel2ReverbEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXI3DL2Reverb8, which allows unmanaged COM clients to create an instance of the managed Interactive3DLevel2ReverbEffect class. Not supported.


Interactive3DLevel2ReverbEffect.Interactive3DLevel2ReverbEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Interactive3DLevel2ReverbEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Interactive3DLevel2ReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public Interactive3DLevel2ReverbEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: Interactive3DLevel2ReverbEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function Interactive3DLevel2ReverbEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXI3DL2Reverb8, which allows unmanaged COM clients to create an instance of the managed Interactive3DLevel2ReverbEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the Interactive3DLevel2ReverbEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


Interactive3DLevel2ReverbEffect.op_Equality(Interactive3DLevel2ReverbEffect,Interactive3DLevel2ReverbEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Interactive3DLevel2ReverbEffect, _
ByVal right As Interactive3DLevel2ReverbEffect _
) As Boolean
C# public static bool op_Equality(
Interactive3DLevel2ReverbEffect left,
Interactive3DLevel2ReverbEffect right
);
Managed C++ public: static bool op_Equality(
Interactive3DLevel2ReverbEffect *left,
Interactive3DLevel2ReverbEffect *right
);
JScript .NET public static function op_Equality(
left : Interactive3DLevel2ReverbEffect,
right : Interactive3DLevel2ReverbEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect. The Interactive3DLevel2ReverbEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect. The Interactive3DLevel2ReverbEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Interactive3DLevel2ReverbEffect.op_Inequality(Interactive3DLevel2ReverbEffect,Interactive3DLevel2ReverbEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Interactive3DLevel2ReverbEffect, _
ByVal right As Interactive3DLevel2ReverbEffect _
) As Boolean
C# public static bool op_Inequality(
Interactive3DLevel2ReverbEffect left,
Interactive3DLevel2ReverbEffect right
);
Managed C++ public: static bool op_Inequality(
Interactive3DLevel2ReverbEffect *left,
Interactive3DLevel2ReverbEffect *right
);
JScript .NET public static function op_Inequality(
left : Interactive3DLevel2ReverbEffect,
right : Interactive3DLevel2ReverbEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect. The Interactive3DLevel2ReverbEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect. The Interactive3DLevel2ReverbEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Interactive3DLevel2ReverbEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Interactive3DLevel2ReverbEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Interactive3DLevel2ReverbEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets interactive 3-D level 2 (I3DL2) environmental reverberation parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsInteractive3DLevel2Reverb
C# | public EffectsInteractive3DLevel2Reverb AllParameters { get; set; }
Managed C++ public: __property EffectsInteractive3DLevel2Reverb get_AllParameters();
public: __property void set_AllParameters(EffectsInteractive3DLevel2Reverb);
JScript .NET public function get AllParameters() : EffectsInteractive3DLevel2Reverb
public function set AllParameters(EffectsInteractive3DLevel2Reverb);

Property Value

Microsoft.DirectX.DirectSound.EffectsInteractive3DLevel2Reverb . Contains parameters for a I3DL2 environmental reverberation effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


Interactive3DLevel2ReverbEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Interactive3DLevel2ReverbEffect.Preset

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Preset Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets a standard reverberation parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property Preset As EffectsEnvironmentPreset
C# | public EffectsEnvironmentPreset Preset { get; set; }
Managed C++ public: __property EffectsEnvironmentPreset get_Preset();
public: __property void set_Preset(EffectsEnvironmentPreset);
JScript .NET public function get Preset() : EffectsEnvironmentPreset
public function set Preset(EffectsEnvironmentPreset);

Property Value

Microsoft.DirectX.DirectSound.EffectsEnvironmentPreset .

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Interactive3DLevel2ReverbEffect.Quality

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Quality Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the quality of the environmental reverberation effect.

Definition

Visual Basic .NET | Public Property Quality As Integer
C# | public int Quality { get; set; }
Managed C++ public: __property int get_Quality();
public: __property void set_Quality(int);
JScript .NET public function get Quality() : int
public function set Quality(int);

Property Value

System.Int32 . Quality of the effect.

This property is read/write.

Remarks

Higher values produce better quality at the expense of processing time.

Can range from Interactive3DLevel2ReverbEffect.QualityMin to Interactive3DLevel2ReverbEffect.QualityMax.

The default value is 2.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Interactive3DLevel2ReverbEffect.DecayHfRatioDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DecayHfRatioDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

Definition

Visual Basic .NET | Public Shared DecayHfRatioDefault As Single
C# | public static Single DecayHfRatioDefault;
Managed C++ | public: static Single DecayHfRatioDefault;
JScript .NET | public static var DecayHfRatioDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayHfRatio


Interactive3DLevel2ReverbEffect.DecayHfRatioMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DecayHfRatioMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

Definition

Visual Basic .NET | Public Shared DecayHfRatioMax As Single
C# | public static Single DecayHfRatioMax;
Managed C++ | public: static Single DecayHfRatioMax;
JScript .NET | public static var DecayHfRatioMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayHfRatio


Interactive3DLevel2ReverbEffect.DecayHfRatioMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DecayHfRatioMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

Definition

Visual Basic .NET | Public Shared DecayHfRatioMin As Single
C# | public static Single DecayHfRatioMin;
Managed C++ | public: static Single DecayHfRatioMin;
JScript .NET | public static var DecayHfRatioMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayHfRatio


Interactive3DLevel2ReverbEffect.DecayTimeDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DecayTimeDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

Definition

Visual Basic .NET | Public Shared DecayTimeDefault As Single
C# | public static Single DecayTimeDefault;
Managed C++ | public: static Single DecayTimeDefault;
JScript .NET | public static var DecayTimeDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayTime


Interactive3DLevel2ReverbEffect.DecayTimeMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DecayTimeMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

Definition

Visual Basic .NET | Public Shared DecayTimeMax As Single
C# | public static Single DecayTimeMax;
Managed C++ | public: static Single DecayTimeMax;
JScript .NET | public static var DecayTimeMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayTime


Interactive3DLevel2ReverbEffect.DecayTimeMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DecayTimeMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

Definition

Visual Basic .NET | Public Shared DecayTimeMin As Single
C# | public static Single DecayTimeMin;
Managed C++ | public: static Single DecayTimeMin;
JScript .NET | public static var DecayTimeMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayTime


Interactive3DLevel2ReverbEffect.DensityDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DensityDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Density property.

Definition

Visual Basic .NET | Public Shared DensityDefault As Single
C# | public static Single DensityDefault;
Managed C++ | public: static Single DensityDefault;
JScript .NET | public static var DensityDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.Density property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Density


Interactive3DLevel2ReverbEffect.DensityMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DensityMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Density property.

Definition

Visual Basic .NET | Public Shared DensityMax As Single
C# | public static Single DensityMax;
Managed C++ | public: static Single DensityMax;
JScript .NET | public static var DensityMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.Density property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Density


Interactive3DLevel2ReverbEffect.DensityMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DensityMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Density property.

Definition

Visual Basic .NET | Public Shared DensityMin As Single
C# | public static Single DensityMin;
Managed C++ | public: static Single DensityMin;
JScript .NET | public static var DensityMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.Density property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Density


Interactive3DLevel2ReverbEffect.DiffusionDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DiffusionDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

Definition

Visual Basic .NET | Public Shared DiffusionDefault As Single
C# | public static Single DiffusionDefault;
Managed C++ | public: static Single DiffusionDefault;
JScript .NET | public static var DiffusionDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Diffusion


Interactive3DLevel2ReverbEffect.DiffusionMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DiffusionMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

Definition

Visual Basic .NET | Public Shared DiffusionMax As Single
C# | public static Single DiffusionMax;
Managed C++ | public: static Single DiffusionMax;
JScript .NET | public static var DiffusionMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Diffusion


Interactive3DLevel2ReverbEffect.DiffusionMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.DiffusionMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

Definition

Visual Basic .NET | Public Shared DiffusionMin As Single
C# | public static Single DiffusionMin;
Managed C++ | public: static Single DiffusionMin;
JScript .NET | public static var DiffusionMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Diffusion


Interactive3DLevel2ReverbEffect.HfReferenceDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.HfReferenceDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.HfReference property.

Definition

Visual Basic .NET | Public Shared HfReferenceDefault As Single
C# | public static Single HfReferenceDefault;
Managed C++ | public: static Single HfReferenceDefault;
JScript .NET | public static var HfReferenceDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.HfReference property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.HfReference


Interactive3DLevel2ReverbEffect.HfReferenceMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.HfReferenceMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

Definition

Visual Basic .NET | Public Shared HfReferenceMax As Single
C# | public static Single HfReferenceMax;
Managed C++ | public: static Single HfReferenceMax;
JScript .NET | public static var HfReferenceMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.HfReference


Interactive3DLevel2ReverbEffect.HfReferenceMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.HfReferenceMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

Definition

Visual Basic .NET | Public Shared HfReferenceMin As Single
C# | public static Single HfReferenceMin;
Managed C++ | public: static Single HfReferenceMin;
JScript .NET | public static var HfReferenceMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.HfReference


Interactive3DLevel2ReverbEffect.QualityDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.QualityDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the Interactive3DLevel2ReverbEffect.Quality property.

Definition

Visual Basic .NET | Public Shared QualityDefault As Int32
C# | public static Int32 QualityDefault;
Managed C++ | public: static Int32 QualityDefault;
JScript .NET | public static var QualityDefault : Int32

Field Value

System.Int32 . Default value for the Interactive3DLevel2ReverbEffect.Quality property.

This field is read-only.

See Also

  • Interactive3DLevel2ReverbEffect.Quality


Interactive3DLevel2ReverbEffect.QualityMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.QualityMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the Interactive3DLevel2ReverbEffect.Quality property.

Definition

Visual Basic .NET | Public Shared QualityMax As Int32
C# | public static Int32 QualityMax;
Managed C++ | public: static Int32 QualityMax;
JScript .NET | public static var QualityMax : Int32

Field Value

System.Int32 . Maximum value for the Interactive3DLevel2ReverbEffect.Quality property.

This field is read-only.

See Also

  • Interactive3DLevel2ReverbEffect.Quality


Interactive3DLevel2ReverbEffect.QualityMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.QualityMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the Interactive3DLevel2ReverbEffect.Quality property.

Definition

Visual Basic .NET | Public Shared QualityMin As Int32
C# | public static Int32 QualityMin;
Managed C++ | public: static Int32 QualityMin;
JScript .NET | public static var QualityMin : Int32

Field Value

System.Int32 . Minimum value for the Interactive3DLevel2ReverbEffect.Quality property.

This field is read-only.

See Also

  • Interactive3DLevel2ReverbEffect.Quality


Interactive3DLevel2ReverbEffect.ReflectionsDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReflectionsDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reflections property.

Definition

Visual Basic .NET | Public Shared ReflectionsDefault As Int32
C# | public static Int32 ReflectionsDefault;
Managed C++ | public: static Int32 ReflectionsDefault;
JScript .NET | public static var ReflectionsDefault : Int32

Field Value

System.Int32 . Default value for the EffectsInteractive3DLevel2Reverb.Reflections property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reflections


Interactive3DLevel2ReverbEffect.ReflectionsDelayDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReflectionsDelayDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

Definition

Visual Basic .NET | Public Shared ReflectionsDelayDefault As Single
C# | public static Single ReflectionsDelayDefault;
Managed C++ | public: static Single ReflectionsDelayDefault;
JScript .NET | public static var ReflectionsDelayDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReflectionsDelay


Interactive3DLevel2ReverbEffect.ReflectionsDelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReflectionsDelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

Definition

Visual Basic .NET | Public Shared ReflectionsDelayMax As Single
C# | public static Single ReflectionsDelayMax;
Managed C++ | public: static Single ReflectionsDelayMax;
JScript .NET | public static var ReflectionsDelayMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReflectionsDelay


Interactive3DLevel2ReverbEffect.ReflectionsDelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReflectionsDelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

Definition

Visual Basic .NET | Public Shared ReflectionsDelayMin As Single
C# | public static Single ReflectionsDelayMin;
Managed C++ | public: static Single ReflectionsDelayMin;
JScript .NET | public static var ReflectionsDelayMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReflectionsDelay


Interactive3DLevel2ReverbEffect.ReflectionsMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReflectionsMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

Definition

Visual Basic .NET | Public Shared ReflectionsMax As Int32
C# | public static Int32 ReflectionsMax;
Managed C++ | public: static Int32 ReflectionsMax;
JScript .NET | public static var ReflectionsMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reflections


Interactive3DLevel2ReverbEffect.ReflectionsMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReflectionsMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

Definition

Visual Basic .NET | Public Shared ReflectionsMin As Int32
C# | public static Int32 ReflectionsMin;
Managed C++ | public: static Int32 ReflectionsMin;
JScript .NET | public static var ReflectionsMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reflections


Interactive3DLevel2ReverbEffect.ReverbDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReverbDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reverb property.

Definition

Visual Basic .NET | Public Shared ReverbDefault As Int32
C# | public static Int32 ReverbDefault;
Managed C++ | public: static Int32 ReverbDefault;
JScript .NET | public static var ReverbDefault : Int32

Field Value

System.Int32 . Default value for the EffectsInteractive3DLevel2Reverb.Reverb property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reverb


Interactive3DLevel2ReverbEffect.ReverbDelayDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReverbDelayDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

Definition

Visual Basic .NET | Public Shared ReverbDelayDefault As Single
C# | public static Single ReverbDelayDefault;
Managed C++ | public: static Single ReverbDelayDefault;
JScript .NET | public static var ReverbDelayDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReverbDelay


Interactive3DLevel2ReverbEffect.ReverbDelayMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReverbDelayMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

Definition

Visual Basic .NET | Public Shared ReverbDelayMax As Single
C# | public static Single ReverbDelayMax;
Managed C++ | public: static Single ReverbDelayMax;
JScript .NET | public static var ReverbDelayMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReverbDelay


Interactive3DLevel2ReverbEffect.ReverbDelayMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReverbDelayMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

Definition

Visual Basic .NET | Public Shared ReverbDelayMin As Single
C# | public static Single ReverbDelayMin;
Managed C++ | public: static Single ReverbDelayMin;
JScript .NET | public static var ReverbDelayMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReverbDelay


Interactive3DLevel2ReverbEffect.ReverbMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReverbMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

Definition

Visual Basic .NET | Public Shared ReverbMax As Int32
C# | public static Int32 ReverbMax;
Managed C++ | public: static Int32 ReverbMax;
JScript .NET | public static var ReverbMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reverb


Interactive3DLevel2ReverbEffect.ReverbMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.ReverbMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

Definition

Visual Basic .NET | Public Shared ReverbMin As Int32
C# | public static Int32 ReverbMin;
Managed C++ | public: static Int32 ReverbMin;
JScript .NET | public static var ReverbMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reverb


Interactive3DLevel2ReverbEffect.RoomDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Room property.

Definition

Visual Basic .NET | Public Shared RoomDefault As Int32
C# | public static Int32 RoomDefault;
Managed C++ | public: static Int32 RoomDefault;
JScript .NET | public static var RoomDefault : Int32

Field Value

System.Int32 . Default value for the EffectsInteractive3DLevel2Reverb.Room property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Room


Interactive3DLevel2ReverbEffect.RoomHfDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomHfDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

Definition

Visual Basic .NET | Public Shared RoomHfDefault As Int32
C# | public static Int32 RoomHfDefault;
Managed C++ | public: static Int32 RoomHfDefault;
JScript .NET | public static var RoomHfDefault : Int32

Field Value

System.Int32 . Default value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomHf


Interactive3DLevel2ReverbEffect.RoomHfMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomHfMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

Definition

Visual Basic .NET | Public Shared RoomHfMax As Int32
C# | public static Int32 RoomHfMax;
Managed C++ | public: static Int32 RoomHfMax;
JScript .NET | public static var RoomHfMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomHf


Interactive3DLevel2ReverbEffect.RoomHfMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomHfMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

Definition

Visual Basic .NET | Public Shared RoomHfMin As Int32
C# | public static Int32 RoomHfMin;
Managed C++ | public: static Int32 RoomHfMin;
JScript .NET | public static var RoomHfMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomHf


Interactive3DLevel2ReverbEffect.RoomMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Room property.

Definition

Visual Basic .NET | Public Shared RoomMax As Int32
C# | public static Int32 RoomMax;
Managed C++ | public: static Int32 RoomMax;
JScript .NET | public static var RoomMax : Int32

Field Value

System.Int32 . Maximum value for the EffectsInteractive3DLevel2Reverb.Room property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Room


Interactive3DLevel2ReverbEffect.RoomMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Room property.

Definition

Visual Basic .NET | Public Shared RoomMin As Int32
C# | public static Int32 RoomMin;
Managed C++ | public: static Int32 RoomMin;
JScript .NET | public static var RoomMin : Int32

Field Value

System.Int32 . Minimum value for the EffectsInteractive3DLevel2Reverb.Room property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Room


Interactive3DLevel2ReverbEffect.RoomRollOffFactorDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomRollOffFactorDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Definition

Visual Basic .NET | Public Shared RoomRollOffFactorDefault As Single
C# | public static Single RoomRollOffFactorDefault;
Managed C++ | public: static Single RoomRollOffFactorDefault;
JScript .NET | public static var RoomRollOffFactorDefault : Single

Field Value

System.Single . Default value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomRollOffFactor


Interactive3DLevel2ReverbEffect.RoomRollOffFactorMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomRollOffFactorMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Definition

Visual Basic .NET | Public Shared RoomRollOffFactorMax As Single
C# | public static Single RoomRollOffFactorMax;
Managed C++ | public: static Single RoomRollOffFactorMax;
JScript .NET | public static var RoomRollOffFactorMax : Single

Field Value

System.Single . Maximum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomRollOffFactor


Interactive3DLevel2ReverbEffect.RoomRollOffFactorMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.RoomRollOffFactorMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Definition

Visual Basic .NET | Public Shared RoomRollOffFactorMin As Single
C# | public static Single RoomRollOffFactorMin;
Managed C++ | public: static Single RoomRollOffFactorMin;
JScript .NET | public static var RoomRollOffFactorMin : Single

Field Value

System.Single . Minimum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomRollOffFactor


Interactive3DLevel2ReverbEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Interactive3DLevel2ReverbEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Interactive3DLevel2ReverbEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Interactive3DLevel2ReverbEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Interactive3DLevel2ReverbEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.InvalidCallException

Microsoft DirectX 9.0 SDK Update (October 2004)

InvalidCallException Class

Language:
Note: This documentation is preliminary and is subject to change.

The method call is invalid. For example, a method's parameter might not be valid.

Definition

Visual Basic .NET Public Class InvalidCallException
Inherits SoundException
C# | public class InvalidCallException : SoundException
Managed C++ | public __gc class InvalidCallException : public SoundException
JScript .NET | public class InvalidCallException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCallException | Initializes a new instance of the InvalidCallException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
InvalidCallException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.DirectSound.Listener3D

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D Class

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets parameters that describe a listener's position, orientation, and listening environment in 3-D space.

Definition

Visual Basic .NET Public Class Listener3D
Inherits MarshalByRefObject
Implements IDisposable
C# public class Listener3D : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Listener3D : public MarshalByRefObject,
IDisposable
JScript .NET public class Listener3D extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Listener3D object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) DistanceFactorDefault | Retrieves the default value for the Listener3D.DistanceFactor property.
static (Shared in Visual Basic .NET) DistanceFactorMax | Retrieves the maximum value for the Listener3D.DistanceFactor property.
static (Shared in Visual Basic .NET) DistanceFactorMin | Retrieves the minimum value for the Listener3D.DistanceFactor property.

Methods

Method | Description
CommitDeferredSettings | Commits any deferred settings made since the last call to this method.
Dispose | Immediately releases the unmanaged resources used by the Listener3D object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Listener3D object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
Listener3D | Initializes a new instance of the Listener3D class.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Listener3D.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves and sets all 3-D parameters of the sound environment and the listener.
Deferred | Determines if settings are set immediately or deferred.
Disposed | Gets a value that indicates whether the object is disposed.
DistanceFactor | Retrieves or sets the distance factor, which is the number of meters in a vector unit.
DopplerFactor | Retrieves or sets the multiplier for the Doppler effect.
Orientation | Retrieves or sets the orientation of the listener's head.
Position | Retrieves or sets the listener's position.
RolloffFactor | Retrieves and sets the rolloff factor, which determines the rate of attenuation over distance.
Velocity | Retrieves or sets the listener's velocity.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Listener3D

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Listener3D.CommitDeferredSettings()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.CommitDeferredSettings Method

 Language:
Note: This documentation is preliminary and is subject to change.

Commits any deferred settings made since the last call to this method.

Definition

Visual Basic .NET | Public Sub CommitDeferredSettings()
C# | public void CommitDeferredSettings();
Managed C++ | public: void CommitDeferredSettings();
JScript .NET | public function CommitDeferredSettings();


Listener3D.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Listener3D object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Listener3D.Disposed
  • Listener3D.Disposing


Listener3D.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Listener3D.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Listener3D object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Listener3D();
Managed C++ | ~Listener3D();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Listener3D.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Listener3D.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DListener8, which allows unmanaged COM clients to create an instance of the managed Listener3D class. Not supported.


Listener3D.Listener3D

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Listener3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Listener3D class.

Overload List

public Listener3D(Buffer);
public Listener3D(IntPtr, Buffer);
public Listener3D(IntPtr, SecondaryBuffer);


Listener3D.Listener3D(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Listener3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As SecondaryBuffer _
)
C# public Listener3D(
IntPtr lp,
SecondaryBuffer buff
);
Managed C++ public: Listener3D(
IntPtr lp,
SecondaryBuffer *buff
);
JScript .NET public function Listener3D(
lp : IntPtr,
buff : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed Listener3D class. Not supported.
buff | Microsoft.DirectX.DirectSound.SecondaryBuffer. A SecondaryBuffer object that acts as the sound source for the listener.


Listener3D.Listener3D(IntPtr,Buffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Listener3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As Buffer _
)
C# public Listener3D(
IntPtr lp,
Buffer buff
);
Managed C++ public: Listener3D(
IntPtr lp,
Buffer *buff
);
JScript .NET public function Listener3D(
lp : IntPtr,
buff : Buffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed Listener3D class. Not supported.
buff | Microsoft.DirectX.DirectSound.Buffer. A Buffer object that acts as the sound source for the listener.


Listener3D.Listener3D(Buffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Listener3D Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object using a primary Buffer object.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As Buffer _
)
C# public Listener3D(
Buffer lp
);
Managed C++ public: Listener3D(
Buffer *lp
);
JScript .NET public function Listener3D(
lp : Buffer
);

Parameters

lp Microsoft.DirectX.DirectSound.Buffer. A primary Buffer object that acts as the sound source for the listener.

Remarks

The Buffer object passed to this method must have the PrimaryBuffer property set to true in its BufferDescription.


Listener3D.op_Equality(Listener3D,Listener3D)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Listener3D, _
ByVal right As Listener3D _
) As Boolean
C# public static bool op_Equality(
Listener3D left,
Listener3D right
);
Managed C++ public: static bool op_Equality(
Listener3D *left,
Listener3D *right
);
JScript .NET public static function op_Equality(
left : Listener3D,
right : Listener3D
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Listener3D. The Listener3D object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Listener3D. The Listener3D object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Listener3D.op_Inequality(Listener3D,Listener3D)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Listener3D, _
ByVal right As Listener3D _
) As Boolean
C# public static bool op_Inequality(
Listener3D left,
Listener3D right
);
Managed C++ public: static bool op_Inequality(
Listener3D *left,
Listener3D *right
);
JScript .NET public static function op_Inequality(
left : Listener3D,
right : Listener3D
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Listener3D. The Listener3D object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Listener3D. The Listener3D object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Listener3D.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Listener3D.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Listener3D.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets all 3-D parameters of the sound environment and the listener.

Definition

Visual Basic .NET | Public Property AllParameters As Listener3DSettings
C# | public Listener3DSettings AllParameters { get; set; }
Managed C++ public: __property Listener3DSettings get_AllParameters();
public: __property void set_AllParameters(Listener3DSettings);
JScript .NET public function get AllParameters() : Listener3DSettings
public function set AllParameters(Listener3DSettings);

Property Value

Microsoft.DirectX.DirectSound.Listener3DSettings . Contains the 3-D parameters for the sound environment and the listener.

This property is read/write.

Remarks

If the Deferred property of the Listener3D object is set to true, the parameters are not applied until the application calls the CommitDeferredSettings method of the Listener3D object. Otherwise, the parameters are applied immediately, causing the system to recalculate the 3-D coordinates.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Deferred

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Deferred Property

Language:
Note: This documentation is preliminary and is subject to change.

Determines if settings are set immediately or deferred.

Definition

Visual Basic .NET | Public Property Deferred As Boolean
C# | public bool Deferred { get; set; }
Managed C++ public: __property bool get_Deferred();
public: __property void set_Deferred(bool);
JScript .NET public function get Deferred() : boolean
public function set Deferred(boolean);

Property Value

System.Boolean . Value that is false if the settings are set immediately at play time, or true if settings are set with the CommitDeferredSettings mothod.

This property is read/write.

Remarks

Every change to 3-D sound buffer and listener settings causes remixing, at the expense of CPU cycles. To minimize the performance impact of changing 3-D settings, set the Deferred property of the Listener3D object to true. Then call the CommitDeferredSettings method to execute all of the deferred commands at once.

Deferred settings are overwritten by immediate settings.


Listener3D.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Listener3D.DistanceFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.DistanceFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the distance factor, which is the number of meters in a vector unit.

Definition

Visual Basic .NET | Public Property DistanceFactor As Single
C# | public float DistanceFactor { get; set; }
Managed C++ public: __property float get_DistanceFactor();
public: __property void set_DistanceFactor(float);
JScript .NET public function get DistanceFactor() : float
public function set DistanceFactor(float);

Property Value

System.Single . The distance factor, which is the number of meters in a vector unit.

This property is read/write.

Remarks

Can range from Listener3D.DistanceFactorMin to Listener3D.DistanceFactorMax.

The default value is 1 meter or Listener3D.DistanceFactorDefault.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.DopplerFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.DopplerFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the multiplier for the Doppler effect.

Definition

Visual Basic .NET | Public Property DopplerFactor As Single
C# | public float DopplerFactor { get; set; }
Managed C++ public: __property float get_DopplerFactor();
public: __property void set_DopplerFactor(float);
JScript .NET public function get DopplerFactor() : float
public function set DopplerFactor(float);

Property Value

System.Single . The multiplier for the Doppler effect.

This property is read/write.

Remarks

The Doppler factor has a range of 0.0 (no Doppler effects) to 10.0 (ten times the Doppler effects found in the real world). The default value is 1.0.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Orientation

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Orientation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the orientation of the listener's head.

Definition

Visual Basic .NET | Public Property Orientation As Listener3DOrientation
C# | public Listener3DOrientation Orientation { get; set; }
Managed C++ public: __property Listener3DOrientation get_Orientation();
public: __property void set_Orientation(Listener3DOrientation);
JScript .NET public function get Orientation() : Listener3DOrientation
public function set Orientation(Listener3DOrientation);

Property Value

Microsoft.DirectX.DirectSound.Listener3DOrientation . The orientation of the listener's head.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the listener's position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The listener's position.

This property is read/write.

Remarks

By default, measurement units are in meters. This can be changed using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.RolloffFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.RolloffFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the rolloff factor, which determines the rate of attenuation over distance.

Definition

Visual Basic .NET | Public Property RolloffFactor As Single
C# | public float RolloffFactor { get; set; }
Managed C++ public: __property float get_RolloffFactor();
public: __property void set_RolloffFactor(float);
JScript .NET public function get RolloffFactor() : float
public function set RolloffFactor(float);

Property Value

System.Single . The rolloff factor, which determines the rate of attenuation over distance.

This property is read/write.

Remarks

The rolloff factor has a range of 0.0 (no rolloff) to 10.0 (ten times the rolloff found in the real world). The default value is 1.0.

The rolloff factor is global. To change the effect of distance for an individual sound buffer, you can set the minimum distance for the buffer.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Velocity

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Velocity Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the listener's velocity.

Definition

Visual Basic .NET | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
Managed C++ public: __property Vector3 get_Velocity();
public: __property void set_Velocity(Vector3);
JScript .NET public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The listener's velocity.

This property is read/write.

Remarks

Velocity is used only for Doppler effects. It does not actually move the listener. To change the listener's position, use the Listener3D.Position property. The default velocity is (0,0,0).

By default, measurement units are meters per second. This can be changed using the Listener3D.DistanceFactor property.


Listener3D.DistanceFactorDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.DistanceFactorDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the Listener3D.DistanceFactor property.

Definition

Visual Basic .NET | Public Shared DistanceFactorDefault As Single
C# | public static Single DistanceFactorDefault;
Managed C++ | public: static Single DistanceFactorDefault;
JScript .NET | public static var DistanceFactorDefault : Single

Field Value

System.Single . Default value for the Listener3D.DistanceFactor property in meters. Default value is 1.0.

This field is read-only.


Listener3D.DistanceFactorMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.DistanceFactorMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the Listener3D.DistanceFactor property.

Definition

Visual Basic .NET | Public Shared DistanceFactorMax As Single
C# | public static Single DistanceFactorMax;
Managed C++ | public: static Single DistanceFactorMax;
JScript .NET | public static var DistanceFactorMax : Single

Field Value

System.Single . Maximum value for the Listener3D.DistanceFactor property in meters.

This field is read-only.


Listener3D.DistanceFactorMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.DistanceFactorMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the Listener3D.DistanceFactor property.

Definition

Visual Basic .NET | Public Shared DistanceFactorMin As Single
C# | public static Single DistanceFactorMin;
Managed C++ | public: static Single DistanceFactorMin;
JScript .NET | public static var DistanceFactorMin : Single

Field Value

System.Single . Minimum value for the Listener3D.DistanceFactor property in meters.

This field is read-only.


Listener3D.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3D.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Listener3D object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Listener3D.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Listener3D object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.NoAggregationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAggregationException Class

Language:
Note: This documentation is preliminary and is subject to change.

The object does not support aggregation.

Definition

Visual Basic .NET Public Class NoAggregationException
Inherits SoundException
C# | public class NoAggregationException : SoundException
Managed C++ | public __gc class NoAggregationException : public SoundException
JScript .NET | public class NoAggregationException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoAggregationException | Initializes a new instance of the NoAggregationException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
NoAggregationException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoAggregationException.NoAggregationException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAggregationException.NoAggregationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoAggregationException class.

Overload List

public NoAggregationException();
protected NoAggregationException(SerializationInfo, StreamingContext);
public NoAggregationException(string);
public NoAggregationException(string, Exception);


NoAggregationException.NoAggregationException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAggregationException.NoAggregationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoAggregationException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoAggregationException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoAggregationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


NoAggregationException.NoAggregationException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAggregationException.NoAggregationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoAggregationException(
string message,
Exception inner
);
Managed C++ public: NoAggregationException(
String *message,
Exception *inner
);
JScript .NET public function NoAggregationException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


NoAggregationException.NoAggregationException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAggregationException.NoAggregationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoAggregationException(
string message
);
Managed C++ public: NoAggregationException(
String *message
);
JScript .NET public function NoAggregationException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


NoAggregationException.NoAggregationException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoAggregationException.NoAggregationException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoAggregationException();
Managed C++ | public: NoAggregationException();
JScript .NET | public function NoAggregationException();


Microsoft.DirectX.DirectSound.NoDriverException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverException Class

Language:
Note: This documentation is preliminary and is subject to change.

No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft® DirectSound® device ID.

Definition

Visual Basic .NET Public Class NoDriverException
Inherits SoundException
C# | public class NoDriverException : SoundException
Managed C++ | public __gc class NoDriverException : public SoundException
JScript .NET | public class NoDriverException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDriverException | Initializes a new instance of the NoDriverException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
NoDriverException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NoDriverException.NoDriverException

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverException.NoDriverException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoDriverException class.

Overload List

public NoDriverException();
protected NoDriverException(SerializationInfo, StreamingContext);
public NoDriverException(string);
public NoDriverException(string, Exception);


NoDriverException.NoDriverException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverException.NoDriverException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDriverException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: NoDriverException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function NoDriverException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


NoDriverException.NoDriverException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverException.NoDriverException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDriverException(
string message,
Exception inner
);
Managed C++ public: NoDriverException(
String *message,
Exception *inner
);
JScript .NET public function NoDriverException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


NoDriverException.NoDriverException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverException.NoDriverException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public NoDriverException(
string message
);
Managed C++ public: NoDriverException(
String *message
);
JScript .NET public function NoDriverException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


NoDriverException.NoDriverException()

Microsoft DirectX 9.0 SDK Update (October 2004)

NoDriverException.NoDriverException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public NoDriverException();
Managed C++ | public: NoDriverException();
JScript .NET | public function NoDriverException();


Microsoft.DirectX.DirectSound.Notify

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify Class

Language:
Note: This documentation is preliminary and is subject to change.

Sets up notification events for a playback or capture buffer.

Definition

Visual Basic .NET Public Class Notify
Inherits MarshalByRefObject
Implements IDisposable
C# public class Notify : MarshalByRefObject,
IDisposable
Managed C++ public __gc class Notify : public MarshalByRefObject,
IDisposable
JScript .NET public class Notify extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Notify object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Notify object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Notify object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
Notify | Initializes a new instance of the Notify class.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Notify.Disposing event when called from within a derived class.
SetNotificationPositions | Sets the notification positions for triggering events during capture or playback.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Notify

Remarks

A SecondaryBuffer object will support notification events only if its BufferDescription.ControlPositionNotify is set to true.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Notify.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the Notify object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • Notify.Disposed
  • Notify.Disposing


Notify.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Notify.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the Notify object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~Notify();
Managed C++ | ~Notify();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


Notify.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Notify.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundNotify8, which allows unmanaged COM clients to create an instance of the managed Notify class. Not supported.


Notify.Notify

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Notify Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Notify class.

Overload List

public Notify(Buffer);
public Notify(CaptureBuffer);
public Notify(SecondaryBuffer);


Notify.Notify(CaptureBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Notify Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Notify class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As CaptureBuffer _
)
C# public Notify(
CaptureBuffer lp
);
Managed C++ public: Notify(
CaptureBuffer *lp
);
JScript .NET public function Notify(
lp : CaptureBuffer
);

Parameters

lp Microsoft.DirectX.DirectSound.CaptureBuffer. The CaptureBuffer that will trigger the notification events.


Notify.Notify(SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Notify Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Notify class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As SecondaryBuffer _
)
C# public Notify(
SecondaryBuffer lp
);
Managed C++ public: Notify(
SecondaryBuffer *lp
);
JScript .NET public function Notify(
lp : SecondaryBuffer
);

Parameters

lp Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that will trigger the notification events.


Notify.Notify(Buffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Notify Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Notify class.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As Buffer _
)
C# public Notify(
Buffer lp
);
Managed C++ public: Notify(
Buffer *lp
);
JScript .NET public function Notify(
lp : Buffer
);

Parameters

lp Microsoft.DirectX.DirectSound.Buffer. The Buffer that will trigger the notification events.


Notify.op_Equality(Notify,Notify)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Notify, _
ByVal right As Notify _
) As Boolean
C# public static bool op_Equality(
Notify left,
Notify right
);
Managed C++ public: static bool op_Equality(
Notify *left,
Notify *right
);
JScript .NET public static function op_Equality(
left : Notify,
right : Notify
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Notify. The Notify object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Notify. The Notify object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


Notify.op_Inequality(Notify,Notify)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Notify, _
ByVal right As Notify _
) As Boolean
C# public static bool op_Inequality(
Notify left,
Notify right
);
Managed C++ public: static bool op_Inequality(
Notify *left,
Notify *right
);
JScript .NET public static function op_Inequality(
left : Notify,
right : Notify
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.Notify. The Notify object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.Notify. The Notify object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


Notify.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the Notify.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


Notify.SetNotificationPositions

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.SetNotificationPositions Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the notification positions for triggering events during capture or playback.

Overload List

public void SetNotificationPositions(BufferPositionNotify[]);
public void SetNotificationPositions(BufferPositionNotify[], int);

Remarks

During capture or playback, the associated event is signaled whenever the read or play cursor reaches one of the notification positions set by this method.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.

See Also

  • BufferPositionNotify


Notify.SetNotificationPositions(BufferPositionNotify[],Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.SetNotificationPositions Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the notification positions for triggering events during capture or playback.

Definition

Visual Basic .NET Public Sub SetNotificationPositions( _
ByVal notify() As BufferPositionNotify, _
ByVal numNotificationPositions As Integer _
)
C# public void SetNotificationPositions(
BufferPositionNotify[] notify,
int numNotificationPositions
);
Managed C++ public: void SetNotificationPositions(
BufferPositionNotify notify __gc[],
int numNotificationPositions
);
JScript .NET public function SetNotificationPositions(
notify : BufferPositionNotify[],
numNotificationPositions : int
);

Parameters

notify | Microsoft.DirectX.DirectSound.BufferPositionNotify[]. An array of BufferPositionNotify structures that describe the notification positions.
numNotificationPositions | System.Int32. Length of notify.

Remarks

During capture or playback, the associated event is signaled whenever the read or play cursor reaches one of the notification positions set by this method.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.

See Also

  • BufferPositionNotify


Notify.SetNotificationPositions(BufferPositionNotify[])

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.SetNotificationPositions Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the notification positions for triggering events during capture or playback.

Definition

Visual Basic .NET Public Sub SetNotificationPositions( _
ByVal notify() As BufferPositionNotify _
)
C# public void SetNotificationPositions(
BufferPositionNotify[] notify
);
Managed C++ public: void SetNotificationPositions(
BufferPositionNotify notify __gc[]
);
JScript .NET public function SetNotificationPositions(
notify : BufferPositionNotify[]
);

Parameters

notify Microsoft.DirectX.DirectSound.BufferPositionNotify[]. An array of BufferPositionNotify structures that describe the notification positions.

Remarks

During capture or playback, the associated event is signaled whenever the read or play cursor reaches one of the notification positions set by this method.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.

See Also

  • BufferPositionNotify


Notify.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


Notify.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

Notify.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the Notify object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Notify.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Notify object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.ObjectNotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectNotFoundException Class

Language:
Note: This documentation is preliminary and is subject to change.

The requested object was not found.

Definition

Visual Basic .NET Public Class ObjectNotFoundException
Inherits SoundException
C# | public class ObjectNotFoundException : SoundException
Managed C++ | public __gc class ObjectNotFoundException : public SoundException
JScript .NET | public class ObjectNotFoundException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ObjectNotFoundException | Initializes a new instance of the ObjectNotFoundException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
ObjectNotFoundException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ObjectNotFoundException.ObjectNotFoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectNotFoundException.ObjectNotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ObjectNotFoundException class.

Overload List

public ObjectNotFoundException();
protected ObjectNotFoundException(SerializationInfo, StreamingContext);
public ObjectNotFoundException(string);
public ObjectNotFoundException(string, Exception);


ObjectNotFoundException.ObjectNotFoundException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectNotFoundException.ObjectNotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ObjectNotFoundException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: ObjectNotFoundException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function ObjectNotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


ObjectNotFoundException.ObjectNotFoundException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectNotFoundException.ObjectNotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ObjectNotFoundException(
string message,
Exception inner
);
Managed C++ public: ObjectNotFoundException(
String *message,
Exception *inner
);
JScript .NET public function ObjectNotFoundException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


ObjectNotFoundException.ObjectNotFoundException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectNotFoundException.ObjectNotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public ObjectNotFoundException(
string message
);
Managed C++ public: ObjectNotFoundException(
String *message
);
JScript .NET public function ObjectNotFoundException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


ObjectNotFoundException.ObjectNotFoundException()

Microsoft DirectX 9.0 SDK Update (October 2004)

ObjectNotFoundException.ObjectNotFoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public ObjectNotFoundException();
Managed C++ | public: ObjectNotFoundException();
JScript .NET | public function ObjectNotFoundException();


Microsoft.DirectX.DirectSound.OtherApplicationHasPriorityException

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException Class

Language:
Note: This documentation is preliminary and is subject to change.

Another application has a higher priority level, preventing this call from succeeding.

Definition

Visual Basic .NET Public Class OtherApplicationHasPriorityException
Inherits SoundException
C# | public class OtherApplicationHasPriorityException : SoundException
Managed C++ | public __gc class OtherApplicationHasPriorityException : public SoundException
JScript .NET | public class OtherApplicationHasPriorityException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OtherApplicationHasPriorityException | Initializes a new instance of the OtherApplicationHasPriorityException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
OtherApplicationHasPriorityException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OtherApplicationHasPriorityException class.

Overload List

public OtherApplicationHasPriorityException();
protected OtherApplicationHasPriorityException(SerializationInfo, StreamingContext);
public OtherApplicationHasPriorityException(string);
public OtherApplicationHasPriorityException(string, Exception);


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OtherApplicationHasPriorityException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: OtherApplicationHasPriorityException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function OtherApplicationHasPriorityException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OtherApplicationHasPriorityException(
string message,
Exception inner
);
Managed C++ public: OtherApplicationHasPriorityException(
String *message,
Exception *inner
);
JScript .NET public function OtherApplicationHasPriorityException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public OtherApplicationHasPriorityException(
string message
);
Managed C++ public: OtherApplicationHasPriorityException(
String *message
);
JScript .NET public function OtherApplicationHasPriorityException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException()

Microsoft DirectX 9.0 SDK Update (October 2004)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public OtherApplicationHasPriorityException();
Managed C++ | public: OtherApplicationHasPriorityException();
JScript .NET | public function OtherApplicationHasPriorityException();


Microsoft.DirectX.DirectSound.ParamEqEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports parametric equalizer effects.

Definition

Visual Basic .NET Public Class ParamEqEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class ParamEqEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class ParamEqEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class ParamEqEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ParamEqEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) BandwidthMax | Retrives the maximum value for the EffectsParamEq.Bandwidth property.
static (Shared in Visual Basic .NET) BandwidthMin | Retrives the minimum value for the EffectsParamEq.Bandwidth property.
static (Shared in Visual Basic .NET) CenterMax | Retrives the maximum value for the EffectsParamEq.Center property.
static (Shared in Visual Basic .NET) CenterMin | Retrives the minimum value for the EffectsParamEq.Center property.
static (Shared in Visual Basic .NET) GainMax | Retrieves the maximum value for the EffectsParamEq.Gain property.
static (Shared in Visual Basic .NET) GainMin | Retrieves the minimum value for the EffectsParamEq.Gain property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the ParamEqEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ParamEqEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
ParamEqEffect | Initializes a new instance of the ParamEqEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
raise_Disposing | Raises the ParamEqEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets parametric equalizer parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ParamEqEffect

Remarks

Obtain this object by calling on the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ParamEqEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the ParamEqEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • ParamEqEffect.Disposed
  • ParamEqEffect.Disposing


ParamEqEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ParamEqEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the ParamEqEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~ParamEqEffect();
Managed C++ | ~ParamEqEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


ParamEqEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


ParamEqEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXParamEq8, which allows unmanaged COM clients to create an instance of the managed ParamEqEffect class. Not supported.


ParamEqEffect.op_Equality(ParamEqEffect,ParamEqEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As ParamEqEffect, _
ByVal right As ParamEqEffect _
) As Boolean
C# public static bool op_Equality(
ParamEqEffect left,
ParamEqEffect right
);
Managed C++ public: static bool op_Equality(
ParamEqEffect *left,
ParamEqEffect *right
);
JScript .NET public static function op_Equality(
left : ParamEqEffect,
right : ParamEqEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.ParamEqEffect. The ParamEqEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.ParamEqEffect. The ParamEqEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


ParamEqEffect.op_Inequality(ParamEqEffect,ParamEqEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As ParamEqEffect, _
ByVal right As ParamEqEffect _
) As Boolean
C# public static bool op_Inequality(
ParamEqEffect left,
ParamEqEffect right
);
Managed C++ public: static bool op_Inequality(
ParamEqEffect *left,
ParamEqEffect *right
);
JScript .NET public static function op_Inequality(
left : ParamEqEffect,
right : ParamEqEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.ParamEqEffect. The ParamEqEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.ParamEqEffect. The ParamEqEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


ParamEqEffect.ParamEqEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.ParamEqEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the ParamEqEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public ParamEqEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: ParamEqEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function ParamEqEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXParamEq8, which allows unmanaged COM clients to create an instance of the managed ParamEqEffect class. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the ParamEqEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


ParamEqEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the ParamEqEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


ParamEqEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves or sets parametric equalizer parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsParamEq
C# | public EffectsParamEq AllParameters { get; set; }
Managed C++ public: __property EffectsParamEq get_AllParameters();
public: __property void set_AllParameters(EffectsParamEq);
JScript .NET public function get AllParameters() : EffectsParamEq
public function set AllParameters(EffectsParamEq);

Property Value

Microsoft.DirectX.DirectSound.EffectsParamEq . Contains parameters for a parametric equalizer effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • Effect Parameters


ParamEqEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


ParamEqEffect.BandwidthMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.BandwidthMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrives the maximum value for the EffectsParamEq.Bandwidth property.

Definition

Visual Basic .NET | Public Shared BandwidthMax As Single
C# | public static Single BandwidthMax;
Managed C++ | public: static Single BandwidthMax;
JScript .NET | public static var BandwidthMax : Single

Field Value

System.Single . Maximum value for the EffectsParamEq.Bandwidth property.

This field is read-only.

See Also

  • EffectsParamEq.Bandwidth


ParamEqEffect.BandwidthMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.BandwidthMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrives the minimum value for the EffectsParamEq.Bandwidth property.

Definition

Visual Basic .NET | Public Shared BandwidthMin As Single
C# | public static Single BandwidthMin;
Managed C++ | public: static Single BandwidthMin;
JScript .NET | public static var BandwidthMin : Single

Field Value

System.Single . Minimum value for the EffectsParamEq.Bandwidth property.

This field is read-only.

See Also

  • EffectsParamEq.Bandwidth


ParamEqEffect.CenterMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.CenterMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrives the maximum value for the EffectsParamEq.Center property.

Definition

Visual Basic .NET | Public Shared CenterMax As Single
C# | public static Single CenterMax;
Managed C++ | public: static Single CenterMax;
JScript .NET | public static var CenterMax : Single

Field Value

System.Single . Maximum value for the EffectsParamEq.Center.

This field is read-only.

See Also

  • EffectsParamEq.Center


ParamEqEffect.CenterMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.CenterMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrives the minimum value for the EffectsParamEq.Center property.

Definition

Visual Basic .NET | Public Shared CenterMin As Single
C# | public static Single CenterMin;
Managed C++ | public: static Single CenterMin;
JScript .NET | public static var CenterMin : Single

Field Value

System.Single . Minimum value for the EffectsParamEq.Center.

This field is read-only.

See Also

  • EffectsParamEq.Center


ParamEqEffect.GainMax

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.GainMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsParamEq.Gain property.

Definition

Visual Basic .NET | Public Shared GainMax As Single
C# | public static Single GainMax;
Managed C++ | public: static Single GainMax;
JScript .NET | public static var GainMax : Single

Field Value

System.Single . Maximum value for the EffectsParamEq.Gain property.

This field is read-only.

See Also

  • EffectsParamEq.Gain


ParamEqEffect.GainMin

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.GainMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsParamEq.Gain property.

Definition

Visual Basic .NET | Public Shared GainMin As Single
C# | public static Single GainMin;
Managed C++ | public: static Single GainMin;
JScript .NET | public static var GainMin : Single

Field Value

System.Single . Minimum value for the EffectsParamEq.Gain property.

This field is read-only.

See Also

  • EffectsParamEq.Gain


ParamEqEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

ParamEqEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the ParamEqEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the ParamEqEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ParamEqEffect object indicates whether that object has been disposed.


Microsoft.DirectX.DirectSound.PriorityLevelNeededException

Microsoft DirectX 9.0 SDK Update (October 2004)

PriorityLevelNeededException Class

Language:
Note: This documentation is preliminary and is subject to change.

A cooperative level of Priority or higher is required.

Definition

Visual Basic .NET Public Class PriorityLevelNeededException
Inherits SoundException
C# | public class PriorityLevelNeededException : SoundException
Managed C++ | public __gc class PriorityLevelNeededException : public SoundException
JScript .NET | public class PriorityLevelNeededException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PriorityLevelNeededException | Initializes a new instance of the PriorityLevelNeededException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
PriorityLevelNeededException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


PriorityLevelNeededException.PriorityLevelNeededException

Microsoft DirectX 9.0 SDK Update (October 2004)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PriorityLevelNeededException class.

Overload List

public PriorityLevelNeededException();
protected PriorityLevelNeededException(SerializationInfo, StreamingContext);
public PriorityLevelNeededException(string);
public PriorityLevelNeededException(string, Exception);


PriorityLevelNeededException.PriorityLevelNeededException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PriorityLevelNeededException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: PriorityLevelNeededException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function PriorityLevelNeededException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


PriorityLevelNeededException.PriorityLevelNeededException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PriorityLevelNeededException(
string message,
Exception inner
);
Managed C++ public: PriorityLevelNeededException(
String *message,
Exception *inner
);
JScript .NET public function PriorityLevelNeededException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


PriorityLevelNeededException.PriorityLevelNeededException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public PriorityLevelNeededException(
string message
);
Managed C++ public: PriorityLevelNeededException(
String *message
);
JScript .NET public function PriorityLevelNeededException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


PriorityLevelNeededException.PriorityLevelNeededException()

Microsoft DirectX 9.0 SDK Update (October 2004)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public PriorityLevelNeededException();
Managed C++ | public: PriorityLevelNeededException();
JScript .NET | public function PriorityLevelNeededException();


Microsoft.DirectX.DirectSound.SecondaryBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

SecondaryBuffer Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains methods and properties used to manage sound buffers that can support effects.

Definition

Visual Basic .NET Public Class SecondaryBuffer
Inherits Buffer
C# | public class SecondaryBuffer : Buffer
Managed C++ | public __gc class SecondaryBuffer : public Buffer
JScript .NET | public class SecondaryBuffer extends Buffer

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SecondaryBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
AcquireResources | Allocates resources for a SecondaryBuffer object that was created with the DeferLocation flag set in the BufferDescription.
Clone | Duplicates the SecondaryBuffer object.
Clone | Duplicates the buffer object. Inherited from Buffer.
Dispose | Immediately releases the unmanaged resources used by the SecondaryBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SecondaryBuffer object to free resources before it is destroyed by the garbage collector.
GetCurrentPosition | Retrieves the position of the play and write cursors in the sound buffer. Inherited from Buffer.
GetEffects | Retrieves a Microsoft® DirectSound® effect object or objects from a SecondaryBuffer object.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
GetObjectInPath | Retrieves a DirectSound effect object at a particular index from a SecondaryBuffer object.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Buffer.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Buffer.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Play | Begin playing the sound buffer, starting at the play cursor. Inherited from Buffer.
raise_Disposing | Raises the SecondaryBuffer.Disposing event when called from within a derived class.
Read | Reads the current data in the buffer. Inherited from Buffer.
Restore | Restores the memory allocation for a lost sound buffer. Inherited from Buffer.
SecondaryBuffer | Initializes a new instance of the SecondaryBuffer class.
SetCurrentPosition | Sets the position of the play cursor, which is the point at which the next byte of data is read from the buffer. Inherited from Buffer.
SetEffects | Enables effects on a SecondaryBuffer object.
Stop | Causes the sound buffer to stop playing. Inherited from Buffer.
Write | Writes data to the buffer. Inherited from Buffer.

Properties

Property | Description
Caps | Retrieves the capabilities of the buffer object. Inherited from Buffer.
Disposed | Gets a value that indicates whether the object is disposed.
Format | Retrieves or sets a description of the sound data format in the buffer. Inherited from Buffer.
Frequency | Retrieves or sets the frequency, in samples per second, at which the buffer is playing. Inherited from Buffer.
NotVirtualized | Retrieves a value that indicates whether the buffer is virtualized. Inherited from Buffer.
Pan | Retrieves or sets the relative volume of the left and right audio channels. Inherited from Buffer.
PlayPosition | Retrieves the position of the play cursor in the sound buffer. Inherited from Buffer.
Status | Retrieves the status of the sound buffer. Inherited from Buffer.
Volume | Retrieves or sets the attenuation of the sound. Inherited from Buffer.
WritePosition | Retrieves the position of the write cursor in the sound buffer. Inherited from Buffer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Buffer
SecondaryBuffer

Remarks

SecondaryBuffer objects are derived from the Buffer class and can support effects; Buffer objects do not support effects.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SecondaryBuffer.AcquireResources(Int32,Int32)

SecondaryBuffer.AcquireResources Method

Note: This documentation is preliminary and is subject to change.

Allocates resources for a SecondaryBuffer object that was created with the DeferLocation flag set in the BufferDescription.

Definition

Visual Basic .NET Public Function AcquireResources( _
ByVal flags As Integer, _
ByVal effectsCount As Integer _
) As EffectsReturnValue()
C# public EffectsReturnValue[] AcquireResources(
int flags,
int effectsCount
);
Managed C++ public: EffectsReturnValue AcquireResources(
int flags,
int effectsCount
) __gc[];
JScript .NET public function AcquireResources(
flags : int,
effectsCount : int
) : EffectsReturnValue[];

Parameters

flags | System.Int32. Specifies how resources are to be allocated for the SecondaryBuffer object. For a list of values, see the voice management and voice allocation flags in the BufferPlayFlags enumeration.
effectsCount | System.Int32. Number of Microsoft® DirectSound® effect objects in the SecondaryBuffer set by the SetEffects method.

Return Value

Microsoft.DirectX.DirectSound.EffectsReturnValue[]. An array that contains one element for each of the Microsoft® DirectSound® effect objects that was assigned to the SecondaryBuffer object by the SetEffects method. One of the following values is returned for each Microsoft® DirectSound® effect object.

Remarks

In order to use the BufferPlayFlags enumeration in the flags parameter, you must cast it to an integer, as done in the following code.

[C#]
int flags = (int)(BufferPlayFlags.LocateInSoftware | BufferPlayFlags.TerminateByTime);
EffectsReturnValue[] returnval = buffer.AcquireResources(flags,1);

If the DeferLocation flag is not set in the BufferDescription of the SecondaryBuffer object, an InvalidCallException is thrown.

If one of the BufferPlayFlags is set in the flags parameter and is not supported, a ControlUnavailableException is thrown.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | A parameter is null.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Clone(Device)

SecondaryBuffer.Clone Method

Note: This documentation is preliminary and is subject to change.

Duplicates the SecondaryBuffer object.

Definition

Visual Basic .NET Public Function Clone( _
ByVal parent As Device _
) As SecondaryBuffer
C# public SecondaryBuffer Clone(
Device parent
);
Managed C++ public: SecondaryBuffer* Clone(
Device *parent
);
JScript .NET public function Clone(
parent : Device
) : SecondaryBuffer;

Parameters

parent Microsoft.DirectX.DirectSound.Device. The Device object associated with the SecondaryBuffer object.

Return Value

Microsoft.DirectX.DirectSound.SecondaryBuffer . A SecondaryBuffer object that represents the cloned SecondaryBuffer object.

Remarks

This method is not valid for buffers created with BufferCaps.ControlEffects set to true.

Initially, the duplicate buffer will have the same parameters as the original buffer. However, the application can change the parameters of each buffer independently, and each can be played or stopped without affecting the other.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the method.
ArgumentNullException Leave Site | The parent parameter is null.
InvalidCallException | The method call is invalid for the current state of this object.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Dispose()

SecondaryBuffer.Dispose Method

Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the SecondaryBuffer object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • SecondaryBuffer.Disposed
  • SecondaryBuffer.Disposing
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Equals(Object)

SecondaryBuffer.Equals Method

Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Finalize()

SecondaryBuffer.Finalize Method

Note: This documentation is preliminary and is subject to change.

Allows the SecondaryBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~SecondaryBuffer();
Managed C++ | ~SecondaryBuffer();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetEffects

SecondaryBuffer.GetEffects Method

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves a Microsoft® DirectSound® effect object or objects from a SecondaryBuffer object.

Overload List

public object GetEffects(int);
public object[] GetEffects(int, int);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all Microsoft® DirectSound® exceptions. Derives from DirectXException.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.SetEffects
  • GetObjectInPath
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetEffects(Int32,Int32)

SecondaryBuffer.GetEffects Method

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves a range of Microsoft® DirectSound® effect objects from a SecondaryBuffer object.

Definition

Visual Basic .NET Public Function GetEffects( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As Object()
C# public object[] GetEffects(
int startIndex,
int count
);
Managed C++ public: Object* GetEffects(
int startIndex,
int count
) __gc[];
JScript .NET public function GetEffects(
startIndex : int,
count : int
) : Object[];

Parameters

startIndex | System.Int32. Starting index of the range of Microsoft® DirectSound® effect objects to retrieve from the SecondaryBuffer object.
count | System.Int32. The number of Microsoft® DirectSound® effect objects to retrieve from the SecondaryBuffer object.

Return Value

System.Object[]. An array of Microsoft® DirectSound® effect objects, such as EchoEffect, from the SecondaryBuffer object.

Remarks

To retrieve an effect object out of the returned array, first retrieve it as an object, than cast it into the appropriate effect object type as seen in the example below.

[C#]
object[] effects_objects = buffer.GetEffects(0,1);
WavesReverbEffect wre = (WavesReverbEffect)effects_objects[0];

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all Microsoft® DirectSound® exceptions. Derives from DirectXException.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.SetEffects
  • GetObjectInPath
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetEffects(Int32)

SecondaryBuffer.GetEffects Method

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves a Microsoft® DirectSound® effect object at a particular index from a SecondaryBuffer object.

Definition

Visual Basic .NET Public Function GetEffects( _
ByVal index As Integer _
) As Object
C# public object GetEffects(
int index
);
Managed C++ public: Object* GetEffects(
int index
);
JScript .NET public function GetEffects(
index : int
) : Object;

Parameters

index System.Int32. Index of Microsoft® DirectSound® effect object to retrieve from the SecondaryBuffer object.

Return Value

System.Object . A Microsoft® DirectSound® effect object, such as EchoEffect, from the SecondaryBuffer object.

Remarks

When retrieving an effect object, you must cast it into the appropriate effect object type as seen in the example below.

[C#]
WavesReverbEffect wre = (WavesReverbEffect)buffer.GetEffects(0);

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all Microsoft® DirectSound® exceptions. Derives from DirectXException.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.SetEffects
  • GetObjectInPath
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetHashCode()

SecondaryBuffer.GetHashCode Method

Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetObjectByValue(Int32)

SecondaryBuffer.GetObjectByValue Method

Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundBuffer8, which allows unmanaged COM clients to create an instance of the managed SecondaryBuffer class. Not supported.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetObjectInPath(Guid,Int32,Guid)

SecondaryBuffer.GetObjectInPath Method

Note: This documentation is preliminary and is subject to change.

Retrieves a Microsoft® DirectSound® effect object at a particular index from a SecondaryBuffer object.

Definition

Visual Basic .NET Public Function GetObjectInPath( _
ByVal guidObject As Guid, _
ByVal index As Integer, _
ByVal guidInterface As Guid _
) As Object
C# public object GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
Managed C++ public: Object* GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
JScript .NET public function GetObjectInPath(
guidObject : Guid,
index : int,
guidInterface : Guid
) : Object;

Parameters

guidObject | System.Guid. Unique class identifier of the object being searched for, such as DSoundHelper.StandardEchoGuid.
index | System.Int32. Index of Microsoft® DirectSound® effect object to retrieve from the SecondaryBuffer object.
guidInterface | System.Guid. Unique identifier of the desired interface, such as DSoundHelper.InterfaceEffectsEcho

Return Value

System.Object . A Microsoft® DirectSound® effect object, such as EchoEffect, from the SecondaryBuffer object you are searching.

Remarks

Any DirectX Media Object (DMO) that has been set on a buffer by using SetEffects method can be retrieved, even if it has not been allocated resources.

The following interfaces can be retrieved for the various DMOs supplied with Microsoft® DirectX®.

Effect guidObject guidInterface
ChorusEffect DSoundHelper.StandardChorusGuid DSoundHelper.InterfaceEffectsChorus
CompressorEffect DSoundHelper.StandardCompressorGuid DSoundHelper.InterfaceEffectsCompressor
DistortionEffect DSoundHelper.StandardDistortionGuid DSoundHelper.InterfaceEffectsDistortion
EchoEffect DSoundHelper.StandardEchoGuid DSoundHelper.InterfaceEffectsEcho
FlangerEffect DSoundHelper.StandardFlangerGuid DSoundHelper.InterfaceEffectsFlanger
GargleEffect DSoundHelper.StandardGargleGuid DSoundHelper.InterfaceEffectsGargle
Interactive3DLevel2ReverbEffect DSoundHelper.StandardInteractive3DLevel2ReverbGuid DSoundHelper.InterfaceEffectsInteractive3DLevel2Reverb
ParamEqEffect DSoundHelper.StandardParamEqGuid DSoundHelper.InterfaceEffectsParamEq
WavesReverbEffect DSoundHelper.StandardWavesReverbGuid DSoundHelper.InterfaceEffectsWavesReverb

The value of the index is the index of the object within the array of effects passed to SetEffects. This is not necessarily the actual position of the object in the effects chain, because some effects might not have been created.

An object is returned solely on the basis of whether it matches guidObject and index. It is up to the application to ensure that guidInterface specifies an interface that can be expected to be found on the object.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all Microsoft® DirectSound® Exceptions. Derives from DirectXException.

See Also

  • DSoundHelper
  • ChorusEffect
  • CompressorEffect
  • DistortionEffect
  • EchoEffect
  • FlangerEffect
  • GargleEffect
  • Interactive3DLevel2ReverbEffect
  • ParamEqEffect
  • WavesReverbEffect
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.op_Equality(SecondaryBuffer,SecondaryBuffer)

SecondaryBuffer.op_Equality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As SecondaryBuffer, _
ByVal right As SecondaryBuffer _
) As Boolean
C# public static bool op_Equality(
SecondaryBuffer left,
SecondaryBuffer right
);
Managed C++ public: static bool op_Equality(
SecondaryBuffer *left,
SecondaryBuffer *right
);
JScript .NET public static function op_Equality(
left : SecondaryBuffer,
right : SecondaryBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.op_Inequality(SecondaryBuffer,SecondaryBuffer)

SecondaryBuffer.op_Inequality Method

Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As SecondaryBuffer, _
ByVal right As SecondaryBuffer _
) As Boolean
C# public static bool op_Inequality(
SecondaryBuffer left,
SecondaryBuffer right
);
Managed C++ public: static bool op_Inequality(
SecondaryBuffer *left,
SecondaryBuffer *right
);
JScript .NET public static function op_Inequality(
left : SecondaryBuffer,
right : SecondaryBuffer
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.raise_Disposing(Object,EventArgs)

SecondaryBuffer.raise_Disposing Method

Note: This documentation is preliminary and is subject to change.

Raises the SecondaryBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Overload List

public SecondaryBuffer(BufferDescription, Device);
public SecondaryBuffer(Stream, BufferDescription, Device);
public SecondaryBuffer(Stream, Device);
public SecondaryBuffer(Stream, int, BufferDescription, Device);
public SecondaryBuffer(Stream, int, Device);
public SecondaryBuffer(string, BufferDescription, Device);
public SecondaryBuffer(string, Device);

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,Int32,Device)

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
int length,
Device parent
);
Managed C++ public: SecondaryBuffer(
Stream *source,
int length,
Device *parent
);
JScript .NET public function SecondaryBuffer(
source : Stream,
length : int,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
length | System.Int32. An integer that represents the size of the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,Device)

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
Device parent
);
Managed C++ public: SecondaryBuffer(
Stream *source,
Device *parent
);
JScript .NET public function SecondaryBuffer(
source : Stream,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(String,Device)

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
string fileName,
Device parent
);
Managed C++ public: SecondaryBuffer(
String *fileName,
Device *parent
);
JScript .NET public function SecondaryBuffer(
fileName : String,
parent : Device
);

Parameters

fileName | System.String. A String Leave Site that represents the file name of the file that contains source data for the buffer.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,Int32,BufferDescription,Device)

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
int length,
BufferDescription desc,
Device parent
);
Managed C++ public: SecondaryBuffer(
Stream *source,
int length,
BufferDescription *desc,
Device *parent
);
JScript .NET public function SecondaryBuffer(
source : Stream,
length : int,
desc : BufferDescription,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
length | System.Int32. An integer that represents the size of the buffer to create.
desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,BufferDescription,Device)

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal source As Stream, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
BufferDescription desc,
Device parent
);
Managed C++ public: SecondaryBuffer(
Stream *source,
BufferDescription *desc,
Device *parent
);
JScript .NET public function SecondaryBuffer(
source : Stream,
desc : BufferDescription,
parent : Device
);

Parameters

source | System.IO.Stream. A Stream Leave Site object that contains the source data for the buffer.
desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(String,BufferDescription,Device)

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal fileName As String, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
string fileName,
BufferDescription desc,
Device parent
);
Managed C++ public: SecondaryBuffer(
String *fileName,
BufferDescription *desc,
Device *parent
);
JScript .NET public function SecondaryBuffer(
fileName : String,
desc : BufferDescription,
parent : Device
);

Parameters

fileName | System.String. A String Leave Site that represents the file name of the file that contains source data for the buffer.
desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(BufferDescription,Device)

SecondaryBuffer.SecondaryBuffer Constructor

Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic .NET Public Sub New( _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
BufferDescription desc,
Device parent
);
Managed C++ public: SecondaryBuffer(
BufferDescription *desc,
Device *parent
);
JScript .NET public function SecondaryBuffer(
desc : BufferDescription,
parent : Device
);

Parameters

desc | Microsoft.DirectX.DirectSound.BufferDescription. A BufferDescription object that describes the buffer to create.
parent | Microsoft.DirectX.DirectSound.Device. A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft® DirectSound® does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | Microsoft® DirectSound® could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SetEffects(EffectDescription[])

SecondaryBuffer.SetEffects Method

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Enables effects on a SecondaryBuffer object.

Definition

Visual Basic .NET Public Function SetEffects( _
ByVal dsEff() As EffectDescription _
) As EffectsReturnValue()
C# public EffectsReturnValue[] SetEffects(
EffectDescription[] dsEff
);
Managed C++ public: EffectsReturnValue SetEffects(
EffectDescription dsEff __gc[]
) __gc[];
JScript .NET public function SetEffects(
dsEff : EffectDescription[]
) : EffectsReturnValue[];

Parameters

dsEff Microsoft.DirectX.DirectSound.EffectDescription[]. An Array of EffectDescription structures that contains descriptions of the effects to set in the SecondaryBuffer object.

Return Value

Microsoft.DirectX.DirectSound.EffectsReturnValue[]. An array that contains one element for each of the Microsoft® DirectSound® effect objects that was assigned to the SecondaryBuffer object. One of the following values is returned for each Microsoft® DirectSound® effect object.

Remarks

If the method fails, the return value for each effect in EffectsReturnValue is either Present or Unknown. Check these values to determine which effects caused the failure.

For the method to succeed, the buffer must have been created with the BufferDescription.ControlEffects set to true and must not be playing or locked.

If the method throws a SoundException, check the result code array for Present or Unknown to ascertain which effect caused the error. If the method throws an ArgumentException Leave Site, check the result codes for Failed to see which effects failed to acquire resources.

An effect must be set on a buffer before the effect interface can be obtained. To obtain the effect interface, use SecondaryBuffer.GetEffects or SecondaryBuffer.GetObjectInPath.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.
SoundException | Root exception type for all Microsoft® DirectSound® Exceptions. Derives from DirectXException.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.GetEffects
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Disposed

SecondaryBuffer.Disposed Property

Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Disposing

SecondaryBuffer.Disposing Event

Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the SecondaryBuffer object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the SecondaryBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SecondaryBuffer object indicates whether that object has been disposed.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.DirectSound.SendLoopException

Microsoft DirectX 9.0 SDK Update (October 2004)

SendLoopException Class

Language:
Note: This documentation is preliminary and is subject to change.

A circular loop of send effects was detected.

Definition

Visual Basic .NET Public Class SendLoopException
Inherits SoundException
C# | public class SendLoopException : SoundException
Managed C++ | public __gc class SendLoopException : public SoundException
JScript .NET | public class SendLoopException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SendLoopException | Initializes a new instance of the SendLoopException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
SendLoopException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SendLoopException.SendLoopException

Microsoft DirectX 9.0 SDK Update (October 2004)

SendLoopException.SendLoopException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SendLoopException class.

Overload List

public SendLoopException();
protected SendLoopException(SerializationInfo, StreamingContext);
public SendLoopException(string);
public SendLoopException(string, Exception);


SendLoopException.SendLoopException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendLoopException.SendLoopException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SendLoopException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SendLoopException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SendLoopException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


SendLoopException.SendLoopException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendLoopException.SendLoopException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SendLoopException(
string message,
Exception inner
);
Managed C++ public: SendLoopException(
String *message,
Exception *inner
);
JScript .NET public function SendLoopException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


SendLoopException.SendLoopException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SendLoopException.SendLoopException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SendLoopException(
string message
);
Managed C++ public: SendLoopException(
String *message
);
JScript .NET public function SendLoopException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


SendLoopException.SendLoopException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SendLoopException.SendLoopException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public SendLoopException();
Managed C++ | public: SendLoopException();
JScript .NET | public function SendLoopException();


Microsoft.DirectX.DirectSound.SoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundException Class

Language:
Note: This documentation is preliminary and is subject to change.

Root exception type for all Microsoft® DirectSound® exceptions. Derives from DirectXException.

Definition

Visual Basic .NET Public Class SoundException
Inherits DirectXException
C# | public class SoundException : DirectXException
Managed C++ | public __gc class SoundException : public DirectXException
JScript .NET | public class SoundException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SoundException | Initializes a new instance of the SoundException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
AccessDeniedException
AllocatedException
BadFormatException
BadSendBufferGuidException
BufferLostException
BufferTooSmallException
ControlUnavailableException
EffectsUnavailableException
InvalidCallException
NoAggregationException
NoDriverException
ObjectNotFoundException
OtherApplicationHasPriorityException
PriorityLevelNeededException
SendLoopException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SoundException.GetExceptionFromResultInternal(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundException.GetExceptionFromResultInternal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an Exception Leave Site object that represents the result code passed in.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32. Integer that represents the result code of the exception.

Return Value

System.Exception . An Exception Leave Site object that represents the error that occurred.

Applies To

AccessDeniedException, AllocatedException, BadFormatException, BadSendBufferGuidException, BufferLostException, BufferTooSmallException, ControlUnavailableException, EffectsUnavailableException, InvalidCallException, NoAggregationException, NoDriverException, ObjectNotFoundException, OtherApplicationHasPriorityException, PriorityLevelNeededException, SendLoopException, UnsupportedException


SoundException.SoundException

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundException.SoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SoundException class.

Overload List

public SoundException();
protected SoundException(SerializationInfo, StreamingContext);
public SoundException(string);
public SoundException(string, Exception);


SoundException.SoundException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundException.SoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SoundException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SoundException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: SoundException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function SoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


SoundException.SoundException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundException.SoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SoundException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SoundException(
string message,
Exception inner
);
Managed C++ public: SoundException(
String *message,
Exception *inner
);
JScript .NET public function SoundException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


SoundException.SoundException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundException.SoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SoundException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public SoundException(
string message
);
Managed C++ public: SoundException(
String *message
);
JScript .NET public function SoundException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


SoundException.SoundException()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundException.SoundException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the SoundException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public SoundException();
Managed C++ | public: SoundException();
JScript .NET | public function SoundException();


Microsoft.DirectX.DirectSound.UnsupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException Class

Language:
Note: This documentation is preliminary and is subject to change.

The function called is not supported at this time.

Definition

Visual Basic .NET Public Class UnsupportedException
Inherits SoundException
C# | public class UnsupportedException : SoundException
Managed C++ | public __gc class UnsupportedException : public SoundException
JScript .NET | public class UnsupportedException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic .NET) EnableExceptions | Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedException | Initializes a new instance of the UnsupportedException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsupportedException.UnsupportedException

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedException class.

Overload List

public UnsupportedException();
protected UnsupportedException(SerializationInfo, StreamingContext);
public UnsupportedException(string);
public UnsupportedException(string, Exception);


UnsupportedException.UnsupportedException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: UnsupportedException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function UnsupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedException.UnsupportedException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedException(
string message,
Exception inner
);
Managed C++ public: UnsupportedException(
String *message,
Exception *inner
);
JScript .NET public function UnsupportedException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error message to display.
inner | System.Exception. An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedException.UnsupportedException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public UnsupportedException(
string message
);
Managed C++ public: UnsupportedException(
String *message
);
JScript .NET public function UnsupportedException(
message : String
);

Parameters

message System.String. String that contains the error message to display.


UnsupportedException.UnsupportedException()

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsupportedException.UnsupportedException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public UnsupportedException();
Managed C++ | public: UnsupportedException();
JScript .NET | public function UnsupportedException();


Microsoft.DirectX.DirectSound.WavesReverbEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft® DirectSound® effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Waves reverberation.

Definition

Visual Basic .NET Public Class WavesReverbEffect
Inherits MarshalByRefObject
Implements IDisposable
C# public class WavesReverbEffect : MarshalByRefObject,
IDisposable
Managed C++ public __gc class WavesReverbEffect : public MarshalByRefObject,
IDisposable
JScript .NET public class WavesReverbEffect extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the WavesReverbEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic .NET) HighFrequencyRtRatioDefault | Retrieves the default value for the EffectsWavesReverb.HighFrequencyRtRatio property.
static (Shared in Visual Basic .NET) HighFrequencyRtRatioMax | Retrieves the maximum value for the EffectsWavesReverb.HighFrequencyRtRatio property.
static (Shared in Visual Basic .NET) HighFrequencyRtRatioMin | Retrieves the minimum value for the EffectsWavesReverb.HighFrequencyRtRatio property.
static (Shared in Visual Basic .NET) InGainDefault | Retrieves the default value for the EffectsWavesReverb.InGain property.
static (Shared in Visual Basic .NET) InGainMax | Retrieves the maximum value for the EffectsWavesReverb.InGain property.
static (Shared in Visual Basic .NET) InGainMin | Retrieves the minimum value for the EffectsWavesReverb.InGain property.
static (Shared in Visual Basic .NET) ReverbMixDefault | Retrieves the default value for the EffectsWavesReverb.ReverbMix property.
static (Shared in Visual Basic .NET) ReverbMixMax | Retrieves the maximum value for the EffectsWavesReverb.ReverbMix property.
static (Shared in Visual Basic .NET) ReverbMixMin | Retrieves the minimum value for the EffectsWavesReverb.ReverbMix property.
static (Shared in Visual Basic .NET) ReverbTimeDefault | Retrieves the default value for the EffectsWavesReverb.ReverbTime property.
static (Shared in Visual Basic .NET) ReverbTimeMax | Retrieves the maximum value for the EffectsWavesReverb.ReverbTime property.
static (Shared in Visual Basic .NET) ReverbTimeMin | Retrieves the minimum value for the EffectsWavesReverb.ReverbTime property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the WavesReverbEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the WavesReverbEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the WavesReverbEffect.Disposing event when called from within a derived class.
WavesReverbEffect | Initializes a new instance of the WavesReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
AllParameters | Retrieves or sets Waves reverb parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
WavesReverbEffect

Remarks

Obtain this object by calling on the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

The Waves reverberation DirectX Media Object (DMO) is based on the Waves MaxxVerb technology, which is licensed to Microsoft®.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers


WavesReverbEffect.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by the WavesReverbEffect object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • WavesReverbEffect.Disposed
  • WavesReverbEffect.Disposing


WavesReverbEffect.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object to compare to this object.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


WavesReverbEffect.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the WavesReverbEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~WavesReverbEffect();
Managed C++ | ~WavesReverbEffect();
JScript .NET | protected override function Finalize();

Remarks

Called during garbage collection.


WavesReverbEffect.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


WavesReverbEffect.GetObjectByValue(Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.GetObjectByValue Method

 Language:
Note: This documentation is preliminary and is subject to change.

This member supports the infrastructure for Microsoft® DirectX® 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic .NET Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
Managed C++ public: IntPtr GetObjectByValue(
int objId
);
JScript .NET public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32. Object identifier.

Return Value

System.IntPtr . Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed WavesReverbEffect class. Not supported.


WavesReverbEffect.op_Equality(WavesReverbEffect,WavesReverbEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As WavesReverbEffect, _
ByVal right As WavesReverbEffect _
) As Boolean
C# public static bool op_Equality(
WavesReverbEffect left,
WavesReverbEffect right
);
Managed C++ public: static bool op_Equality(
WavesReverbEffect *left,
WavesReverbEffect *right
);
JScript .NET public static function op_Equality(
left : WavesReverbEffect,
right : WavesReverbEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.WavesReverbEffect. The WavesReverbEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.WavesReverbEffect. The WavesReverbEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are the same; otherwise, false.


WavesReverbEffect.op_Inequality(WavesReverbEffect,WavesReverbEffect)

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As WavesReverbEffect, _
ByVal right As WavesReverbEffect _
) As Boolean
C# public static bool op_Inequality(
WavesReverbEffect left,
WavesReverbEffect right
);
Managed C++ public: static bool op_Inequality(
WavesReverbEffect *left,
WavesReverbEffect *right
);
JScript .NET public static function op_Inequality(
left : WavesReverbEffect,
right : WavesReverbEffect
) : boolean;

Parameters

left | Microsoft.DirectX.DirectSound.WavesReverbEffect. The WavesReverbEffect object to the left of the equality operator.
right | Microsoft.DirectX.DirectSound.WavesReverbEffect. The WavesReverbEffect object to the right of the equality operator.

Return Value

System.Boolean . Returns true if the objects are different; otherwise, false.


WavesReverbEffect.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises the WavesReverbEffect.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference; should be this object.
i2 | System.EventArgs. Arguments to pass to the event handler.


WavesReverbEffect.WavesReverbEffect(IntPtr,SecondaryBuffer)

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.WavesReverbEffect Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WavesReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic .NET Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public WavesReverbEffect(
IntPtr lp,
SecondaryBuffer source
);
Managed C++ public: WavesReverbEffect(
IntPtr lp,
SecondaryBuffer *source
);
JScript .NET public function WavesReverbEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp | System.IntPtr. Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed WavesReverbEffect. Not supported.
source | Microsoft.DirectX.DirectSound.SecondaryBuffer. The SecondaryBuffer that is using this effect.

Remarks

Obtain the WavesReverbEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


WavesReverbEffect.AllParameters

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.AllParameters Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves or sets Waves reverb parameters of a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Property AllParameters As EffectsWavesReverb
C# | public EffectsWavesReverb AllParameters { get; set; }
Managed C++ public: __property EffectsWavesReverb get_AllParameters();
public: __property void set_AllParameters(EffectsWavesReverb);
JScript .NET public function get AllParameters() : EffectsWavesReverb
public function set AllParameters(EffectsWavesReverb);

Property Value

Microsoft.DirectX.DirectSound.EffectsWavesReverb . Contains parameters for a Waves reverb effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • Effect Parameters


WavesReverbEffect.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Returns true if the object is disposed; otherwise, false.

This property is read-only.


WavesReverbEffect.HighFrequencyRtRatioDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.HighFrequencyRtRatioDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsWavesReverb.HighFrequencyRtRatio property.

Definition

Visual Basic .NET | Public Shared HighFrequencyRtRatioDefault As Single
C# | public static Single HighFrequencyRtRatioDefault;
Managed C++ | public: static Single HighFrequencyRtRatioDefault;
JScript .NET | public static var HighFrequencyRtRatioDefault : Single

Field Value

System.Single . Default value for the EffectsWavesReverb.HighFrequencyRtRatio property.

This field is read-only.

See Also

  • EffectsWavesReverb.HighFrequencyRtRatio


WavesReverbEffect.HighFrequencyRtRatioMax

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.HighFrequencyRtRatioMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

Definition

Visual Basic .NET | Public Shared HighFrequencyRtRatioMax As Single
C# | public static Single HighFrequencyRtRatioMax;
Managed C++ | public: static Single HighFrequencyRtRatioMax;
JScript .NET | public static var HighFrequencyRtRatioMax : Single

Field Value

System.Single . Maximum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

This field is read-only.

See Also

  • EffectsWavesReverb.HighFrequencyRtRatio


WavesReverbEffect.HighFrequencyRtRatioMin

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.HighFrequencyRtRatioMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

Definition

Visual Basic .NET | Public Shared HighFrequencyRtRatioMin As Single
C# | public static Single HighFrequencyRtRatioMin;
Managed C++ | public: static Single HighFrequencyRtRatioMin;
JScript .NET | public static var HighFrequencyRtRatioMin : Single

Field Value

System.Single . Minimum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

This field is read-only.

See Also

  • EffectsWavesReverb.HighFrequencyRtRatio


WavesReverbEffect.InGainDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.InGainDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsWavesReverb.InGain property.

Definition

Visual Basic .NET | Public Shared InGainDefault As Single
C# | public static Single InGainDefault;
Managed C++ | public: static Single InGainDefault;
JScript .NET | public static var InGainDefault : Single

Field Value

System.Single . Default value for the EffectsWavesReverb.InGain property.

This field is read-only.

See Also

  • EffectsWavesReverb.InGain


WavesReverbEffect.InGainMax

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.InGainMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsWavesReverb.InGain property.

Definition

Visual Basic .NET | Public Shared InGainMax As Single
C# | public static Single InGainMax;
Managed C++ | public: static Single InGainMax;
JScript .NET | public static var InGainMax : Single

Field Value

System.Single . Maximum value for the EffectsWavesReverb.InGain property.

This field is read-only.

See Also

  • EffectsWavesReverb.InGain


WavesReverbEffect.InGainMin

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.InGainMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsWavesReverb.InGain property.

Definition

Visual Basic .NET | Public Shared InGainMin As Single
C# | public static Single InGainMin;
Managed C++ | public: static Single InGainMin;
JScript .NET | public static var InGainMin : Single

Field Value

System.Single . Minimum value for the EffectsWavesReverb.InGain property.

This field is read-only.

See Also

  • EffectsWavesReverb.InGain


WavesReverbEffect.ReverbMixDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.ReverbMixDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsWavesReverb.ReverbMix property.

Definition

Visual Basic .NET | Public Shared ReverbMixDefault As Single
C# | public static Single ReverbMixDefault;
Managed C++ | public: static Single ReverbMixDefault;
JScript .NET | public static var ReverbMixDefault : Single

Field Value

System.Single . Default value for the EffectsWavesReverb.ReverbMix property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbMix


WavesReverbEffect.ReverbMixMax

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.ReverbMixMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsWavesReverb.ReverbMix property.

Definition

Visual Basic .NET | Public Shared ReverbMixMax As Single
C# | public static Single ReverbMixMax;
Managed C++ | public: static Single ReverbMixMax;
JScript .NET | public static var ReverbMixMax : Single

Field Value

System.Single . Maximum value for the EffectsWavesReverb.ReverbMix property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbMix


WavesReverbEffect.ReverbMixMin

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.ReverbMixMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsWavesReverb.ReverbMix property.

Definition

Visual Basic .NET | Public Shared ReverbMixMin As Single
C# | public static Single ReverbMixMin;
Managed C++ | public: static Single ReverbMixMin;
JScript .NET | public static var ReverbMixMin : Single

Field Value

System.Single . Minimum value for the EffectsWavesReverb.ReverbMix property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbMix


WavesReverbEffect.ReverbTimeDefault

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.ReverbTimeDefault Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the default value for the EffectsWavesReverb.ReverbTime property.

Definition

Visual Basic .NET | Public Shared ReverbTimeDefault As Single
C# | public static Single ReverbTimeDefault;
Managed C++ | public: static Single ReverbTimeDefault;
JScript .NET | public static var ReverbTimeDefault : Single

Field Value

System.Single . Default value for the EffectsWavesReverb.ReverbTime property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbTime


WavesReverbEffect.ReverbTimeMax

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.ReverbTimeMax Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for the EffectsWavesReverb.ReverbTime property.

Definition

Visual Basic .NET | Public Shared ReverbTimeMax As Single
C# | public static Single ReverbTimeMax;
Managed C++ | public: static Single ReverbTimeMax;
JScript .NET | public static var ReverbTimeMax : Single

Field Value

System.Single . Maximum value for the EffectsWavesReverb.ReverbTime property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbTime


WavesReverbEffect.ReverbTimeMin

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.ReverbTimeMin Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for the EffectsWavesReverb.ReverbTime property.

Definition

Visual Basic .NET | Public Shared ReverbTimeMin As Single
C# | public static Single ReverbTimeMin;
Managed C++ | public: static Single ReverbTimeMin;
JScript .NET | public static var ReverbTimeMin : Single

Field Value

System.Single . Minimum value for the EffectsWavesReverb.ReverbTime property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbTime


WavesReverbEffect.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

WavesReverbEffect.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the WavesReverbEffect object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the WavesReverbEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the WavesReverbEffect object indicates whether that object has been disposed.


BufferDescriptionFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferDescriptionFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants for specifying the capabilities of sound buffers.

Definition

Visual Basic .NET | Public Enum BufferDescriptionFlags
C# | public enum BufferDescriptionFlags
Managed C++ | __value public enum BufferDescriptionFlags
JScript .NET | public enum BufferDescriptionFlags

Members

Member | Value | Description
LocateInHardware | 4 | The buffer must use hardware mixing.
LocateInSoftware | 8 | The buffer must be in software memory and use software mixing.
StickyFocus | 16384 | The buffer has sticky focus. If the user switches to another application not using Microsoft® DirectSound®, the application's normal buffers are muted, but sticky focus buffers are still audible.
StaticBuffer | 2 | No error occurs if such memory is not available. This flag has no effect on cards using the Peripheral Component Interconnect (PCI) bus. Cannot be combined with ControlEffects.
PrimaryBuffer | 1 | The buffer is a primary buffer. Cannot be combined with ControlEffects.
Mute3DAtMaximumDistance | 131072 | The sound is reduced to silence at the maximum distance. Applies only to software buffers.
GlobalFocus | 32768 | The buffer is a global sound buffer. With this flag set, an application using Microsoft® DirectSound® can continue to play its buffers if the user switches focus to another application, even if the new application uses Microsoft® DirectSound®.
CanGetCurrentPosition | 65536 | The buffer can get an more accurate accurate play cursor.
ControlVolume | 128 | The buffer has volume control capability.
ControlPositionNotify | 256 | The buffer has position notification capability.
ControlPan | 64 | The buffer has pan control capability. Cannot be combined with Control3D.
ControlEffects | 512 | The buffer supports effects processing.
ControlFrequency | 32 | The buffer has frequency control capability.
Control3D | 16 | The buffer has 3-D control capability. Cannot be combined with ControlPan, and cannot be set for a buffer with a stereo format in WaveFormat.
DeferLocation | 262144 | The buffer can be assigned to a hardware or software resource at play time. This flag must be set for buffers that use voice management.

Remarks

This enumeration is used by the BufferDescription.Flags property to set the capabilities using flags.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • BufferDescription.Flags


BufferPlayFlags

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferPlayFlags Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants for specifying the play behavior of the buffer.

Definition

Visual Basic .NET | Public Enum BufferPlayFlags
C# | public enum BufferPlayFlags
Managed C++ | __value public enum BufferPlayFlags
JScript .NET | public enum BufferPlayFlags

Members

Member | Value | Description
TerminateByPriority | 32 | If the hardware has no available voices, a currently playing buffer will be stopped to make room for the new buffer. The buffer prematurely terminated will be the one with the lowest priority as set by the priority parameter Play method for the buffer.
TerminateByDistance | 16 | If the hardware has no available voices, a currently playing buffer will be stopped to make room for the new buffer. The buffer prematurely terminated will be selected from buffers that have the buffer's BufferDescription.Mute3DAtMaximumDistance property set to true and are beyond their maximum distance. If there are no such buffers, the method fails.
TerminateByTime | 8 | If the hardware has no available voices, a currently playing nonlooping buffer will be stopped to make room for the new buffer. The buffer prematurely terminated is the one with the least time left to play.
LocateInSoftware | 4 | Play this voice in a software buffer only. This flag cannot be combined with LocateInHardware or any voice management flag.
LocateInHardware | 2 | Play this voice in a hardware buffer only. If the hardware has no available voices and no voice management flags are set, the Play method fails. This flag cannot be combined with LocateInSoftware.
Looping | 1 | After the end of the audio buffer is reached, play restarts at the beginning of the buffer. Play continues until explicitly stopped. This flag must be set when playing a primary buffer.
Default | 0 | Play this voice with the default settings.

Remarks

This enumeration is used by the Play method of a buffer to specify the play behavior of the buffer.

This enumeration is also used by the SecondaryBuffer.AquireResources method to set the capabilities of a SecondaryBuffer object that was created with the DeferLocation flag set in the BufferDescription in order to use the use voice allocation and management.

When using this enumeration in the SecondaryBuffer.AquireResources method, you must cast it to an integer, as done in the following code.

[C#]
int flags = (int)(BufferPlayFlags.LocateInSoftware | BufferPlayFlags.TerminateByTime);
EffectsReturnValue[] returnval = buffer.AcquireResources(flags,1);

Voice allocation flags (LocateInSoftware, LocateInHardware)

The voice allocation flags are valid only for buffers created with the DeferLocation flag set in the BufferDescription. One of the following flags can be used to force the processing of the sound into hardware or software. If neither LocateInHardware nor LocateInSoftware is set, the sound is played in either software or hardware, depending on the availability of resources at the time the method is called.

Voice management flags (TerminateByPriority, TerminateByDistance, TerminateByTime)

The voice management flags are valid only for buffers created with the DeferLocation flag set in the BufferDescription, and are used for sounds that are to play in hardware. These flags enable hardware resources that are already in use to be yielded to the current sound. Only buffers created with the DeferLocation flag set in the BufferDescription are candidates for premature termination.

The following table shows the behavior of the method under various combinations of the voice allocation and voice management flags when no free hardware voices are available.
LocateInHardware | Neither LocateInHardware nor LocateInSoftware | LocateInSoftware
TerminateByDistance | If any sounds currently playing in hardware are beyond their maximum distance and have the BufferDescription.Mute3DAtMaximumDistance property set to true, one of them is terminated and the new sound plays in hardware. Otherwise, the call fails. | If any sounds currently playing in hardware are beyond their maximum distance and have the BufferDescription.Mute3DAtMaximumDistance property set to true, one of them is terminated and the new sound plays in hardware. Otherwise, the new sound plays in software. | New sound plays in software.
TerminateByPriority | If the new sound's priority is higher than or equal to that of any sound currently playing in hardware, one of the lowest-priority sounds is terminated and the new sound plays in hardware. Otherwise, the call fails. | If the new sound's priority is higher than or equal to that of any sound currently playing in hardware, one of the lowest-priority sounds is terminated and the new sound plays in hardware. Otherwise, the new sound plays in software. | New sound plays in software.
TerminateByTime | The sound with the least time left to play is terminated and the new sound plays on the released voice. | The sound with the least time left to play is terminated and the new sound plays on the released voice. | New sound plays in software.

If the buffer specified in the method is already playing, the call to the method succeeds and the buffer continues to play. However, the flags defined in the most recent call supersede flags defined in previous calls.

TerminateByTime and TerminateByDistance cannot be combined, but either may be combined with TerminateByPriority, in which case the TerminateByTime or TerminateByDistance flag is used to determine which buffer should be terminated in the event of a priority tie.

If the method is called with a voice allocation or voice management flag set on a buffer that was not created with the DeferLocation flag set in the BufferDescription, the call fails with ArgumentException Leave Site.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • SecondaryBuffer.AquireResources
  • Buffer.Play


BufferSize

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferSize Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants for the minimum and maximum buffer size.

Definition

Visual Basic .NET | Public Enum BufferSize
C# | public enum BufferSize
Managed C++ | __value public enum BufferSize
JScript .NET | public enum BufferSize

Members

Member | Value | Description
EffectsMin | 150 | Minimum length for a buffer using effects, in milliseconds.
Max | 268435455 | Maximum length for a buffer, in bytes.
Min | 4 | Minimum length for a buffer (Other than the primary buffer), in bytes.

Remarks

A primary buffer must have a length of 0.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


CaptureEffectsReturnValue

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsReturnValue Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants for a CaptureBuffer object's effects status.

Definition

Visual Basic .NET | Public Enum CaptureEffectsReturnValue
C# | public enum CaptureEffectsReturnValue
Managed C++ | __value public enum CaptureEffectsReturnValue
JScript .NET | public enum CaptureEffectsReturnValue

Members

Member | Value | Description
LocatedInSoftware | 32 | Effect is instantiated in hardware.
LocatedInHardware | 16 | Effect is instantiated in software.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureBuffer.GetEffectsStatus


CooperativeLevel

Microsoft DirectX 9.0 SDK Update (October 2004)

CooperativeLevel Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants for a Device object's cooperative level.

Definition

Visual Basic .NET | Public Enum CooperativeLevel
C# | public enum CooperativeLevel
Managed C++ | __value public enum CooperativeLevel
JScript .NET | public enum CooperativeLevel

Members

Member | Value | Description
Normal | 1 | Sets the normal level. This level has the smoothest multitasking and resource-sharing behavior, but because it does not allow the primary buffer format to change, output is restricted to the default 8-bit format.
Priority | 2 | Sets the priority level. Applications with this cooperative level can have buffers that use the Format property and devices that call the Compact method.
WritePrimary | 4 | Sets the write-primary level. The application has write access to the primary buffer. No secondary buffers can be played. This level cannot be set if the DirectSound driver is being emulated for the device; that is, if the Device.Caps property returns the EmulateDriver flag in the Caps structure.

Remarks

The application must set the cooperative level by calling this method before its buffers can be played. The recommended cooperative level is Priority.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Device.SetCooperativeLevel


EffectsEnvironmentPreset

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEnvironmentPreset Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Containts constants for reverberation presets for an Interactive3DLevel2ReverbEffect object.

Definition

Visual Basic .NET | Public Enum EffectsEnvironmentPreset
C# | public enum EffectsEnvironmentPreset
Managed C++ | __value public enum EffectsEnvironmentPreset
JScript .NET | public enum EffectsEnvironmentPreset

Members

Member | Value | Description
Plate | 29 | Simulates a classic plate reverb.
LargeHall | 28 | Simulates the reverberation of a long hall.
MediumHall | 27 | Simulates the reverberation of being in a medium hall.
LargeRoom | 26 | Simulates the reverberation of being in a large room.
MediumRoom | 25 | Simulates the reverberation of being in a medium room.
SmallRoom | 24 | Simulates the reverberation of being in a small room.
UnderWater | 23 | Simulates the reverberation of being underwater.
SewerPipe | 22 | Simulates the reverberation of being in a sewer pipe.
ParkingLot | 21 | Simulates the reverberation of being in a parking lot.
Plain | 20 | Simulates the reverberation of being on a plain.
Quarry | 19 | Simulates the reverberation of being in a quarry.
Mountains | 18 | Simulates the reverberation of being in the mountains.
City | 17 | Simulates the reverberation of being in a city.
Forest | 16 | Simulates the reverberation of being in a forest.
Alley | 15 | Simulates the reverberation of being in an alley
StoneCorridor | 14 | Simulates the reverberation of being in a stone corridor.
Hallway | 13 | Simulates the reverberation of being in a normal hallway.
CarpetedHallway | 12 | Simulates the reverberation of being in a hallway with carpet.
Hangar | 11 | Simulates the reverberation of being in a hangar.
Arena | 10 | Simulates the reverberation of being in an arena.
Cave | 9 | Simulates the reverberation of being in a cave.
ConcertHall | 8 | Simulates the reverberation of being in a concert hall.
Auditorium | 7 | Simulates the reverberation of being in an auditorium.
StoneRoom | 6 | Simulates the reverberation of being in a room made of stone.
Livingroom | 5 | Simulates the reverberation of being in a living room.
Bathroom | 4 | Simulates the reverberation of being in a bathroom.
Room | 3 | Simulates the reverberation of being in a normal room.
PaddedCell | 2 | Simulates the reverberation of being in a padded room.
Generic | 1 | Preset uses generic settings.
Default | 0 | Preset uses default settings.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Interactive3DLevel2ReverbEffect.Preset


EffectsReturnValue

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsReturnValue Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that describe the status of an effect object returned from a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Enum EffectsReturnValue
C# | public enum EffectsReturnValue
Managed C++ | __value public enum EffectsReturnValue
JScript .NET | public enum EffectsReturnValue

Members

Member | Value | Description
Failed | 4 | No effect was created because resources weren't available.
LocatedInHardware | 1 | Effect is instantiated in hardware.
LocatedInSoftware | 2 | Effect is instantiated in software.
Present | 0 | Effect is available but was not created because one of the other effects requested could not be created. If any of the effects requested cannot be created, none of them are, and the call fails.
SendLoop | 6 | A circular loop of send effects was detected.
Unallocated | 3 | Effect has not yet been assigned to hardware or software. This value is returned if the buffer was created with the BufferDescription.DeferLocation flag set to true.
Unknown | 5 | Effect is not registered on the system, and the method failed as a result.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • SecondaryBuffer.SetEffects
  • SecondaryBuffer.AcquireResources


EffectStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectStatus Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that describe the success of the effect in canceling the echo using a CaptureAcousticEchoCancellationEffect object.

Definition

Visual Basic .NET | Public Enum EffectStatus
C# | public enum EffectStatus
Managed C++ | __value public enum EffectStatus
JScript .NET | public enum EffectStatus

Members

Member | Value | Description
CurrentlyConverged | 8 | The Acoustic Echo Cancellation (AEC) algorithm is currently converged.
PreviouslyDiverged | 2 | The Acoustic Echo Cancellation (AEC) algorithm lost convergence. The convergence history remains in this state until the algorithm is reset or timely data is no longer arriving on the capture or render stream.
ContinuouslyConverged | 1 | When the Acoustic Echo Cancellation (AEC) algorithm has converged.
Uninitialized | 0 | Initial state of the Acoustic Echo Cancellation (AEC) algorithm.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureAcousticEchoCancellationEffect.Status


Frequency

Microsoft DirectX 9.0 SDK Update (October 2004)

Frequency Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that describe the range of frequency, in samples per second, at which a software buffer can play.

Definition

Visual Basic .NET | Public Enum Frequency
C# | public enum Frequency
Managed C++ | __value public enum Frequency
JScript .NET | public enum Frequency

Members

Member | Value | Description
Original | 0 | Orignal buffer frequency.
Max | 200000 | Maximum buffer frequency.
Min | 100 | Minimum buffer frequency.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer.Frequency


LockFlag

Microsoft DirectX 9.0 SDK Update (October 2004)

LockFlag Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that describe how to lock a buffer while reading or writing to it.

Definition

Visual Basic .NET | Public Enum LockFlag
C# | public enum LockFlag
Managed C++ | __value public enum LockFlag
JScript .NET | public enum LockFlag

Members

Member | Value | Description
None | 0 | Do not lock the buffer.
EntireBuffer | 2 | Lock the entire buffer.
FromWriteCursor | 1 | Start the lock at the write cursor.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer.Read
  • Buffer.Write
  • CaptureBuffer.Read
  • CaptureBuffer.Write


Mode3D

Microsoft DirectX 9.0 SDK Update (October 2004)

Mode3D Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constents that describe the operation mode for 3-D sound processing.

Definition

Visual Basic .NET | Public Enum Mode3D
C# | public enum Mode3D
Managed C++ | __value public enum Mode3D
JScript .NET | public enum Mode3D

Members

Member | Value | Description
Disable | 2 | Processing of 3-D sound is disabled. The sound seems to originate from the center of the listener's head.
HeadRelative | 1 | Sound parameters (position, velocity, and orientation) are relative to the listener's parameters. In this mode, the absolute parameters of the sound are updated automatically as the listener's parameters change so that the relative parameters remain constant.
Normal | 0 | Normal processing. This is the default mode.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer3D.Mode


OperationMode

Microsoft DirectX 9.0 SDK Update (October 2004)

OperationMode Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that describe the mode of a CaptureAcousticEchoCancellationEffect object.

Definition

Visual Basic .NET | Public Enum OperationMode
C# | public enum OperationMode
Managed C++ | __value public enum OperationMode
JScript .NET | public enum OperationMode

Members

Member | Value | Description
FullDuplex | 2 | The effect is passing through capture and render data without modifying it.
HalfDuplex | 1 | The effect is running in half duplex mode. Not presently supported.
PassThrough | 0 | The effect is passing through capture and render data without modifying it.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureEffectsAcousticEchoCancellation.Mode


Pan

Microsoft DirectX 9.0 SDK Update (October 2004)

Pan Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants which describe how a buffer plays a sound in the stereo (2-channel) field.

Definition

Visual Basic .NET | Public Enum Pan
C# | public enum Pan
Managed C++ | __value public enum Pan
JScript .NET | public enum Pan

Members

Member | Value | Description
Center | 0 | Equal volume in both channels.
Right | 10000 | The right channel is at normal volume, and the left channel is effectively silent.
Left | -10000 | The left channel is at normal volume, and the right channel is effectively silent.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer.Pan


PositionNotifyFlag

Microsoft DirectX 9.0 SDK Update (October 2004)

PositionNotifyFlag Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that are used to signify types of position notifications.

Definition

Visual Basic .NET | Public Enum PositionNotifyFlag
C# | public enum PositionNotifyFlag
Managed C++ | __value public enum PositionNotifyFlag
JScript .NET | public enum PositionNotifyFlag

Members

Member | Value | Description
OffsetStop | -1 | Causes the event to be signaled when playback or capture stops.
None | 0 | No event is raised.

Remarks

This enumeration can be used by the BufferPositionNotify.Offset property to signify events that are not absolute offset times. In order to use this enumeration as such, you must cast it to an integer, as in the following code:

[C#]
int offsetStop = (int)PositionNotifyFlag.OffsetStop;
BufferPositionNotify.Offset = offsetStop;

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • BufferPositionNotify.Offset


Volume

Microsoft DirectX 9.0 SDK Update (October 2004)

Volume Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that describe the minimum and maximum volume at which a buffer can play.

Definition

Visual Basic .NET | Public Enum Volume
C# | public enum Volume
Managed C++ | __value public enum Volume
JScript .NET | public enum Volume

Members

Member | Value | Description
Max | 0 | Maximum volume. The buffer volume is not attenuated.
Min | -10000 | Minimum volume. The buffer volume is effectively silent.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer.Volume
  • Buffer3D.ConeOutsideVolume


WaveFormatTag

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormatTag Enumeration

 Language:
Note: This documentation is preliminary and is subject to change.

Contains constants that describe waveform-audio format types.

Definition

Visual Basic .NET | Public Enum WaveFormatTag
C# | public enum WaveFormatTag
Managed C++ | __value public enum WaveFormatTag
JScript .NET | public enum WaveFormatTag

Members

Member | Value | Description
Pcm | 1 | Waveform-audio format is one- or two-channel PCM data.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • WaveFormat.FormatTag


Angles

Microsoft DirectX 9.0 SDK Update (October 2004)

Angles Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe the inside and outside angles of the sound projection cone.

Definition

Visual Basic .NET | Public Structure Angles
C# | public struct Angles
Managed C++ | public __value struct Angles
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Angles | Initializes a new instance of the Angles structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Inside | Retrieves the inside angle of the sound projection cone, in degrees.
Outside | Retrieves the outside angle of the sound projection cone, in degrees.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer3D.ConeAngles


Angles.Angles()

Microsoft DirectX 9.0 SDK Update (October 2004)

Angles.Angles Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Angles structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Angles();
Managed C++ | public: Angles();
JScript .NET | public function Angles();


Angles.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Angles.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Angles.Inside

Microsoft DirectX 9.0 SDK Update (October 2004)

Angles.Inside Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the inside angle of the sound projection cone, in degrees.

Definition

Visual Basic .NET | Public Property Inside As Integer
C# | public int Inside { get; set; }
Managed C++ public: __property int get_Inside();
public: __property void set_Inside(int);
JScript .NET public function get Inside() : int
public function set Inside(int);

Property Value

System.Int32 . The inside angle of the sound projection cone, in degrees.

This property is read/write.

Remarks

This is the angle within which the sound is at its normal volume.


Angles.Outside

Microsoft DirectX 9.0 SDK Update (October 2004)

Angles.Outside Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the outside angle of the sound projection cone, in degrees.

Definition

Visual Basic .NET | Public Property Outside As Integer
C# | public int Outside { get; set; }
Managed C++ public: __property int get_Outside();
public: __property void set_Outside(int);
JScript .NET public function get Outside() : int
public function set Outside(int);

Property Value

System.Int32 . The outside angle of the sound projection cone, in degrees.

This property is read/write.

Remarks

This is the angle outside of which the sound is at its outside volume.


Buffer3DSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe all the information necessary to uniquely describe the location, orientation, and motion of a 3-D sound buffer.

Definition

Visual Basic .NET | Public Structure Buffer3DSettings
C# | public struct Buffer3DSettings
Managed C++ | public __value struct Buffer3DSettings
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Buffer3DSettings | Initializes a new instance of the Buffer3DSettings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ConeOrientation | Retrieves and sets the current orientation of this 3-D buffer's sound projection cone.
ConeOutsideVolume | Retrieves and sets the volume of the sound outside the outside angle of the sound projection cone.
InsideConeAngle | Retrieves and sets the angle of the inside sound projection cone.
MaxDistance | Retrieves and sets the maximum attenuation distance.
MinDistance | Retrieves and sets the minimum attenuation distance.
Mode | Retrieves and sets the 3-D sound processing mode to be set.
OutsideConeAngle | Retrieves and sets the angle of the outside sound projection cone.
Position | Retrieves and sets the current position of the 3-D sound buffer.
Velocity | Retrieves and sets the current velocity of the 3-D sound buffer.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer3D.AllParameters


Buffer3DSettings.Buffer3DSettings()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.Buffer3DSettings Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Buffer3DSettings structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Buffer3DSettings();
Managed C++ | public: Buffer3DSettings();
JScript .NET | public function Buffer3DSettings();


Buffer3DSettings.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Buffer3DSettings.ConeOrientation

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.ConeOrientation Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the current orientation of this 3-D buffer's sound projection cone.

Definition

Visual Basic .NET | Public Property ConeOrientation As Vector3
C# | public Vector3 ConeOrientation { get; set; }
Managed C++ public: __property Vector3 get_ConeOrientation();
public: __property void set_ConeOrientation(Vector3);
JScript .NET public function get ConeOrientation() : Vector3
public function set ConeOrientation(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The current orientation of this 3-D buffer's sound projection cone.

This property is read/write.


Buffer3DSettings.ConeOutsideVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.ConeOutsideVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the volume of the sound outside the outside angle of the sound projection cone.

Definition

Visual Basic .NET | Public Property ConeOutsideVolume As Integer
C# | public int ConeOutsideVolume { get; set; }
Managed C++ public: __property int get_ConeOutsideVolume();
public: __property void set_ConeOutsideVolume(int);
JScript .NET public function get ConeOutsideVolume() : int
public function set ConeOutsideVolume(int);

Property Value

System.Int32 . The the volume of the sound outside the outside angle of the sound projection cone.

This property is read/write.


Buffer3DSettings.InsideConeAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.InsideConeAngle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the angle of the inside sound projection cone.

Definition

Visual Basic .NET | Public Property InsideConeAngle As Integer
C# | public int InsideConeAngle { get; set; }
Managed C++ public: __property int get_InsideConeAngle();
public: __property void set_InsideConeAngle(int);
JScript .NET public function get InsideConeAngle() : int
public function set InsideConeAngle(int);

Property Value

System.Int32 . The angle of the inside sound projection cone.

This property is read/write.


Buffer3DSettings.MaxDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.MaxDistance Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the maximum attenuation distance.

Definition

Visual Basic .NET | Public Property MaxDistance As Single
C# | public float MaxDistance { get; set; }
Managed C++ public: __property float get_MaxDistance();
public: __property void set_MaxDistance(float);
JScript .NET public function get MaxDistance() : float
public function set MaxDistance(float);

Property Value

System.Single . The maximum attenuation distance.

This property is read/write.

Remarks

This property is the distance from the listener beyond which sounds in this buffer are no longer attenuated.


Buffer3DSettings.MinDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.MinDistance Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the minimum attenuation distance.

Definition

Visual Basic .NET | Public Property MinDistance As Single
C# | public float MinDistance { get; set; }
Managed C++ public: __property float get_MinDistance();
public: __property void set_MinDistance(float);
JScript .NET public function get MinDistance() : float
public function set MinDistance(float);

Property Value

System.Single . The minimum attenuation distance.

This property is read/write.

Remarks

This property is the distance from the listener at which sounds in this buffer begin to be attenuated.


Buffer3DSettings.Mode

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.Mode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the 3-D sound processing mode to be set.

Definition

Visual Basic .NET | Public Property Mode As Mode3D
C# | public Mode3D Mode { get; set; }
Managed C++ public: __property Mode3D get_Mode();
public: __property void set_Mode(Mode3D);
JScript .NET public function get Mode() : Mode3D
public function set Mode(Mode3D);

Property Value

Microsoft.DirectX.DirectSound.Mode3D . The 3-D sound processing mode to be set.

This property is read/write.


Buffer3DSettings.OutsideConeAngle

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.OutsideConeAngle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the angle of the outside sound projection cone.

Definition

Visual Basic .NET | Public Property OutsideConeAngle As Integer
C# | public int OutsideConeAngle { get; set; }
Managed C++ public: __property int get_OutsideConeAngle();
public: __property void set_OutsideConeAngle(int);
JScript .NET public function get OutsideConeAngle() : int
public function set OutsideConeAngle(int);

Property Value

System.Int32 . The angle of the outside sound projection cone.

This property is read/write.


Buffer3DSettings.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the current position of the 3-D sound buffer.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The current position of the 3-D sound buffer.

This property is read/write.


Buffer3DSettings.Velocity

Microsoft DirectX 9.0 SDK Update (October 2004)

Buffer3DSettings.Velocity Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the current velocity of the 3-D sound buffer.

Definition

Visual Basic .NET | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
Managed C++ public: __property Vector3 get_Velocity();
public: __property void set_Velocity(Vector3);
JScript .NET public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The current velocity of the 3-D sound buffer.

This property is read/write.


BufferCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe the capabilities of a Buffer object or a SecondaryBuffer object.

Definition

Visual Basic .NET | Public Structure BufferCaps
C# | public struct BufferCaps
Managed C++ | public __value struct BufferCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferCaps | Initializes a new instance of the BufferCaps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferBytes | Retrieves the size of the new buffer.
CanGetCurrentPosition | Retrieves whether the application can get a more accurate play cursor.
Control3D | Retrieves whether the buffer has 3-D control capability.
ControlEffects | Retrieves whether the buffer supports effects processing.
ControlFrequency | Retrieves whether the buffer has frequency control capability.
ControlPan | Retrieves whether the buffer has pan control capability.
ControlPositionNotify | Retrieves whether the buffer has position notification capability.
ControlVolume | Retrieves whether the buffer has volume control capability.
GlobalFocus | Retrieves whether the buffer is a global sound buffer.
LocateInHardware | Retrieves whether the buffer must use hardware mixing.
LocateInSoftware | Retrieves whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.
LocationDefer | Retrieves whether the buffer can be assigned to a hardware or software resource at play time.
Mute3DAtMaximumDistance | Retrieves whether the sound is reduced to silence at the maximum distance.
PlayCpuOverhead | Retrieves the processing overhead, as a percentage, of main processor cycles needed to mix this sound buffer.
PrimaryBuffer | Retrieves whether the buffer is a primary sound buffer.
StaticBuffer | Retrieves whether the buffer is placed in on-board hardware memory, if available.
StickyFocus | Retrieves whether the buffer has sticky focus.
UnlockTransferRate | Retrieves the rate, in kilobytes per second, at which data is transferred to the buffer memory when reading and writing to a buffer.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer.Caps


BufferCaps.BufferCaps()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.BufferCaps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferCaps structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public BufferCaps();
Managed C++ | public: BufferCaps();
JScript .NET | public function BufferCaps();


BufferCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


BufferCaps.BufferBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.BufferBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the new buffer.

Definition

Visual Basic .NET | Public ReadOnly Property BufferBytes As Integer
C# | public int BufferBytes { get; }
Managed C++ | public: __property int get_BufferBytes();
JScript .NET | public function get BufferBytes() : int

Property Value

System.Int32 . Value that represents the size of the new buffer, in bytes.

This property is read-only.

Remarks

This value will always be 0 for a buffer created with BufferDescription.PrimaryBuffer set to true.


BufferCaps.CanGetCurrentPosition

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.CanGetCurrentPosition Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the application can get a more accurate play cursor.

Definition

Visual Basic .NET | Public ReadOnly Property CanGetCurrentPosition As Boolean
C# | public bool CanGetCurrentPosition { get; }
Managed C++ | public: __property bool get_CanGetCurrentPosition();
JScript .NET | public function get CanGetCurrentPosition() : boolean

Property Value

System.Boolean . Value that is set to true if the application can get a more accurate play cursor from the buffer; otherwise, false.

This property is read-only.

Remarks

The Buffer.GetCurrentPosition method uses the new behavior of the play cursor. In Microsoft® DirectSound® in Microsoft DirectX® 1, the play cursor was significantly ahead of the actual playing sound on emulated sound cards; it was directly behind the write cursor. Now, if CanGetCurrentPosition is true, the application can get a more accurate play cursor. If this property is false, the old behavior is preserved for compatibility.

CanGetCurrentPosition only matters with emulated sound cards. If a DirectSound driver is present, the play cursor is accurate for DirectSound in all versions of DirectX.


BufferCaps.Control3D

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.Control3D Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer has 3-D control capability.

Definition

Visual Basic .NET | Public ReadOnly Property Control3D As Boolean
C# | public bool Control3D { get; }
Managed C++ | public: __property bool get_Control3D();
JScript .NET | public function get Control3D() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer has 3-D control capability; otherwise, false.

This property is read-only.


BufferCaps.ControlEffects

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.ControlEffects Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer supports effects processing.

Definition

Visual Basic .NET | Public ReadOnly Property ControlEffects As Boolean
C# | public bool ControlEffects { get; }
Managed C++ | public: __property bool get_ControlEffects();
JScript .NET | public function get ControlEffects() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer supports effects processing; otherwise, false.

This property is read-only.


BufferCaps.ControlFrequency

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.ControlFrequency Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer has frequency control capability.

Definition

Visual Basic .NET | Public ReadOnly Property ControlFrequency As Boolean
C# | public bool ControlFrequency { get; }
Managed C++ | public: __property bool get_ControlFrequency();
JScript .NET | public function get ControlFrequency() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer has frequency control capability; otherwise, false.

This property is read-only.


BufferCaps.ControlPan

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.ControlPan Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer has pan control capability.

Definition

Visual Basic .NET | Public ReadOnly Property ControlPan As Boolean
C# | public bool ControlPan { get; }
Managed C++ | public: __property bool get_ControlPan();
JScript .NET | public function get ControlPan() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer has pan control capability; otherwise, false.

This property is read-only.


BufferCaps.ControlPositionNotify

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.ControlPositionNotify Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer has position notification capability.

Definition

Visual Basic .NET | Public ReadOnly Property ControlPositionNotify As Boolean
C# | public bool ControlPositionNotify { get; }
Managed C++ | public: __property bool get_ControlPositionNotify();
JScript .NET | public function get ControlPositionNotify() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer has position notification capability; otherwise, false.

This property is read-only.

Remarks

Because the virtual device driver model (VXD) does not support notifications, a sound buffer created with BufferDescription.ControlPositionNotify set to true is always a software buffer when using VXD drivers. With the Windows Driver Model (WDM), a notification-enabled buffer can be in hardware, if hardware resources are available.


BufferCaps.ControlVolume

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.ControlVolume Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer has volume control capability.

Definition

Visual Basic .NET | Public ReadOnly Property ControlVolume As Boolean
C# | public bool ControlVolume { get; }
Managed C++ | public: __property bool get_ControlVolume();
JScript .NET | public function get ControlVolume() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer has volume control capability; otherwise, false.

This property is read-only.


BufferCaps.GlobalFocus

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.GlobalFocus Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer is a global sound buffer.

Definition

Visual Basic .NET | Public ReadOnly Property GlobalFocus As Boolean
C# | public bool GlobalFocus { get; }
Managed C++ | public: __property bool get_GlobalFocus();
JScript .NET | public function get GlobalFocus() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer is a global buffer; otherwise, false.

This property is read-only.

Remarks

When GlobalFocus is set to true, an application using Microsoft® DirectSound® can continue to play its buffers if the user switches focus to another application, even if the new application uses DirectSound. The one exception is that the global sounds from other applications will not be audible if you switch focus to a DirectSound application that uses the CooperativeLevel.WritePrimary flag for its cooperative level.


BufferCaps.LocateInHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.LocateInHardware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer must use hardware mixing.

Definition

Visual Basic .NET | Public ReadOnly Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; }
Managed C++ | public: __property bool get_LocateInHardware();
JScript .NET | public function get LocateInHardware() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer must use hardware mixing; otherwise, false.

This property is read-only.


BufferCaps.LocateInSoftware

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.LocateInSoftware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.

Definition

Visual Basic .NET | Public ReadOnly Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; }
Managed C++ | public: __property bool get_LocateInSoftware();
JScript .NET | public function get LocateInSoftware() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer must use software mixing; otherwise, false.

This property is read-only.


BufferCaps.LocationDefer

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.LocationDefer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer can be assigned to a hardware or software resource at play time.

Definition

Visual Basic .NET | Public ReadOnly Property LocationDefer As Boolean
C# | public bool LocationDefer { get; }
Managed C++ | public: __property bool get_LocationDefer();
JScript .NET | public function get LocationDefer() : boolean

Property Value

System.Boolean . Value that is set to true if if the buffer can be assigned to a hardware or software resource at play time; otherwise, false.

This property is read-only.


BufferCaps.Mute3DAtMaximumDistance

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.Mute3DAtMaximumDistance Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the sound is reduced to silence at the maximum distance.

Definition

Visual Basic .NET | Public ReadOnly Property Mute3DAtMaximumDistance As Boolean
C# | public bool Mute3DAtMaximumDistance { get; }
Managed C++ | public: __property bool get_Mute3DAtMaximumDistance();
JScript .NET | public function get Mute3DAtMaximumDistance() : boolean

Property Value

System.Boolean . Value that is set to true to mute sound at the maximum distance; otherwise, false.

This property is read-only.

Remarks

The buffer will stop playing when the maximum distance is exceeded, so that processor time is not wasted. Applies only to software buffers.


BufferCaps.PlayCpuOverhead

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.PlayCpuOverhead Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the processing overhead, as a percentage, of main processor cycles needed to mix this sound buffer.

Definition

Visual Basic .NET | Public ReadOnly Property PlayCpuOverhead As Integer
C# | public int PlayCpuOverhead { get; }
Managed C++ | public: __property int get_PlayCpuOverhead();
JScript .NET | public function get PlayCpuOverhead() : int

Property Value

System.Int32 . The processing overhead, as a percentage, of main processor cycles needed to mix this sound buffer.

This property is read-only.

Remarks

For hardware buffers, this member will be zero because the mixing is performed by the sound device. For software buffers, this member depends on the buffer format and the speed of the system processor.


BufferCaps.PrimaryBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.PrimaryBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer is a primary sound buffer.

Definition

Visual Basic .NET | Public ReadOnly Property PrimaryBuffer As Boolean
C# | public bool PrimaryBuffer { get; }
Managed C++ | public: __property bool get_PrimaryBuffer();
JScript .NET | public function get PrimaryBuffer() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer is a primary sound buffer; otherwise, false.

This property is read-only.


BufferCaps.StaticBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.StaticBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer is placed in on-board hardware memory, if available.

Definition

Visual Basic .NET | Public ReadOnly Property StaticBuffer As Boolean
C# | public bool StaticBuffer { get; }
Managed C++ | public: __property bool get_StaticBuffer();
JScript .NET | public function get StaticBuffer() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer is a static buffer; otherwise, false.

This property is read-only.


BufferCaps.StickyFocus

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.StickyFocus Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer has sticky focus.

Definition

Visual Basic .NET | Public ReadOnly Property StickyFocus As Boolean
C# | public bool StickyFocus { get; }
Managed C++ | public: __property bool get_StickyFocus();
JScript .NET | public function get StickyFocus() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer has sticky focus; otherwise, false.

This property is read-only.

Remarks

If the user switches to another application not using Microsoft® DirectSound®, the application's normal buffers are muted, but sticky focus buffers are still audible.


BufferCaps.UnlockTransferRate

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferCaps.UnlockTransferRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the rate, in kilobytes per second, at which data is transferred to the buffer memory when reading and writing to a buffer.

Definition

Visual Basic .NET | Public ReadOnly Property UnlockTransferRate As Integer
C# | public int UnlockTransferRate { get; }
Managed C++ | public: __property int get_UnlockTransferRate();
JScript .NET | public function get UnlockTransferRate() : int

Property Value

System.Int32 . The rate, in kilobytes per second, at which data is transferred to the buffer memory when reading and writing to a buffer.

This property is read-only.


BufferPositionNotify

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferPositionNotify Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe a notification position.

Definition

Visual Basic .NET | Public Structure BufferPositionNotify
C# | public struct BufferPositionNotify
Managed C++ | public __value struct BufferPositionNotify
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferPositionNotify | Initializes a new instance of the BufferPositionNotify structure.

Properties

Property | Description
EventNotifyHandle | Retrieves and sets the handle to the event to be signaled when the offset has been reached.
Offset | Retrieves and sets the offset from the beginning of the buffer where the notify event is to be triggered, or PositionNotifyFlag.OffsetStop.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Notify.NotificationPositions


BufferPositionNotify.BufferPositionNotify()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferPositionNotify.BufferPositionNotify Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferPositionNotify structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public BufferPositionNotify();
Managed C++ | public: BufferPositionNotify();
JScript .NET | public function BufferPositionNotify();


BufferPositionNotify.EventNotifyHandle

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferPositionNotify.EventNotifyHandle Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the handle to the event to be signaled when the offset has been reached.

Definition

Visual Basic .NET | Public Property EventNotifyHandle As IntPtr
C# | public IntPtr EventNotifyHandle { get; set; }
Managed C++ public: __property IntPtr get_EventNotifyHandle();
public: __property void set_EventNotifyHandle(IntPtr);
JScript .NET public function get EventNotifyHandle() : IntPtr
public function set EventNotifyHandle(IntPtr);

Property Value

System.IntPtr . The handle to the event to be signaled when the offset has been reached.

This property is read/write.


BufferPositionNotify.Offset

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferPositionNotify.Offset Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the offset from the beginning of the buffer where the notify event is to be triggered, or PositionNotifyFlag.OffsetStop.

Definition

Visual Basic .NET | Public Property Offset As Integer
C# | public int Offset { get; set; }
Managed C++ public: __property int get_Offset();
public: __property void set_Offset(int);
JScript .NET public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32 . The offset from the beginning of the buffer where the notify event is to be triggered, or PositionNotifyFlag.OffsetStop.

This property is read/write.

Remarks

Setting this property to PositionNotifyFlag.OffsetStop causes the event to be signaled when playback or capture stops, either because the end of the buffer has been reached (and playback or capture is not looping) or because the application called stop method of the buffer.

In order to set this property with the PositionNotifyFlag.OffsetStop flag, you must cast it to an integer, as done in the following code.

[C#]
BufferPositionNotify.Offset = (int)PositionNotifyFlag.OffsetStop;

When a playback buffer was created with BufferDescription.DeferLocation and BufferDescription.ControlPositionNotify along with any voice management flag, it is possible that a sound that has notifications set, but not yet reached, will be terminated by the voice manager. In this case, no event is signaled.


BufferStatus

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe the status of a buffer.

Definition

Visual Basic .NET | Public Structure BufferStatus
C# | public struct BufferStatus
Managed C++ | public __value struct BufferStatus
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferStatus | Initializes a new instance of the BufferStatus structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferLost | Retrieves whether a buffer is lost and must be restored before it is played or locked.
LocatedInHardware | Retrieves whether a buffer is located in hardware.
LocatedInSoftware | Retrieves whether a buffer is located in software.
Looping | Retrieves whether the buffer is looping.
Playing | Retrieves whether the buffer is playing.
Terminated | Retrieves whether the buffer has terminated.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer.Status


BufferStatus.BufferStatus()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.BufferStatus Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the BufferStatus structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public BufferStatus();
Managed C++ | public: BufferStatus();
JScript .NET | public function BufferStatus();


BufferStatus.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


BufferStatus.BufferLost

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.BufferLost Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether a buffer is lost and must be restored before it is played or locked.

Definition

Visual Basic .NET | Public ReadOnly Property BufferLost As Boolean
C# | public bool BufferLost { get; }
Managed C++ | public: __property bool get_BufferLost();
JScript .NET | public function get BufferLost() : boolean

Property Value

System.Boolean . Value that is set to true if a buffer is lost and must be restored; otherwise, false.

This property is read-only.


BufferStatus.LocatedInHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.LocatedInHardware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether a buffer is located in hardware.

Definition

Visual Basic .NET | Public ReadOnly Property LocatedInHardware As Boolean
C# | public bool LocatedInHardware { get; }
Managed C++ | public: __property bool get_LocatedInHardware();
JScript .NET | public function get LocatedInHardware() : boolean

Property Value

System.Boolean . Value that is set to true if a buffer is located in hardware; otherwise, false.

This property is read-only.

Remarks

This property is set only for buffers created with the BufferDescription.DeferLocation set to true.


BufferStatus.LocatedInSoftware

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.LocatedInSoftware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether a buffer is located in software.

Definition

Visual Basic .NET | Public ReadOnly Property LocatedInSoftware As Boolean
C# | public bool LocatedInSoftware { get; }
Managed C++ | public: __property bool get_LocatedInSoftware();
JScript .NET | public function get LocatedInSoftware() : boolean

Property Value

System.Boolean . Value that is set to true if a buffer is located in software; otherwise, false.

This property is read-only.

Remarks

This property is set only for buffers created with the BufferDescription.DeferLocation set to true.


BufferStatus.Looping

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.Looping Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer is looping.

Definition

Visual Basic .NET | Public ReadOnly Property Looping As Boolean
C# | public bool Looping { get; }
Managed C++ | public: __property bool get_Looping();
JScript .NET | public function get Looping() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer is looping; otherwise, false.

This property is read-only.

Remarks

This property is only set in combination with Playing


BufferStatus.Playing

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.Playing Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer is playing.

Definition

Visual Basic .NET | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
Managed C++ | public: __property bool get_Playing();
JScript .NET | public function get Playing() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer is playing; otherwise, false.

This property is read-only.

Remarks

This property is set if the buffer is being heard. When making a call to play or stop a buffer, this property might not immediately change the status because of latency.


BufferStatus.Terminated

Microsoft DirectX 9.0 SDK Update (October 2004)

BufferStatus.Terminated Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer has terminated.

Definition

Visual Basic .NET | Public ReadOnly Property Terminated As Boolean
C# | public bool Terminated { get; }
Managed C++ | public: __property bool get_Terminated();
JScript .NET | public function get Terminated() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer has terminated; otherwise, false.

This property is read-only.


Caps

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe the capabilities of a Microsoft® DirectSound® Device object.

Definition

Visual Basic .NET | Public Structure Caps
C# | public struct Caps
Managed C++ | public __value struct Caps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Caps | Initializes a new instance of the Caps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Certified | Retrieves whether the driver is a certified Windows Driver Module (WDM) device driver.
ContinuousRate | Retrieves whether the Device object supports all sample rates between the MinSecondarySampleRate and MaxSecondarySampleRate values.
EmulateDriver | Retrieves whether the Device object does not have a DirectSound driver installed.
FreeHardware3DAllBuffers | Retrieves the number of unallocated 3-D buffers.
FreeHardware3DStaticBuffers | Retrieves the number of unallocated static 3-D buffers.
FreeHardware3DStreamingBuffers | Retrieves the number of unallocated streaming 3-D buffers.
FreeHardwareMemoryBytes | Retrieves the size, in bytes, of the free memory on the sound card.
FreeHardwareMixingAllBuffers | Retrieves the number of unallocated buffers.
FreeHardwareMixingStaticBuffers | Retrieves the number of unallocated static buffers.
FreeHardwareMixingStreamingBuffers | Retrieves the number of unallocated streaming buffers.
MaxContigousFreeHardwareMemoryBytes | Retrieves the size, in bytes, of the largest contiguous block of free memory on the sound card.
MaxHardware3DAllBuffers | Retrieves the maximum number of 3-D buffers.
MaxHardware3DStaticBuffers | Retrieves the maximum number of static 3-D buffers.
MaxHardware3DStreamingBuffers | Retrieves the maximum number of streaming 3-D buffers.
MaxHardwareMixingAllBuffers | Retrieves the number of buffers that can be mixed in hardware.
MaxHardwareMixingStaticBuffers | Retrieves the maximum number of static buffers.
MaxHardwareMixingStreamingBuffers | Retrieves the maximum number of streaming sound buffers.
MaxSecondarySampleRate | Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.
MinSecondarySampleRate | Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.
PlayCpuOverheadSoftwareBuffers | Retrieves the processing overhead, as a percentage of main processor cycles, needed to mix software buffers.
Primary16Bit | Retrieves whether the Device object supports a primary buffer with 16-bit samples.
Primary8Bit | Retrieves whether the Device object supports primary buffers with 8-bit samples.
PrimaryBuffers | Retrieves the number of primary buffers supported.
PrimaryMono | Retrieves whether the Device object supports monophonic primary buffers.
PrimaryStereo | Retrieves whether the Device object supports stereo primary buffers.
Secondary16Bit | Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 16-bit samples.
Secondary8Bit | Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 8-bit samples.
SecondaryMono | Retrieves whether the Device object supports hardware-mixed monophonic SecondaryBuffer objects.
SecondaryStereo | Retrieves whether the Device object supports hardware-mixed stereo SecondaryBuffer objects.
TotalHardwareMemoryBytes | Retrieves the size, in bytes, of the amount of memory on the sound card that stores static sound buffers.
UnlockTransferRateHardwareBuffers | Retrieves the rate, in kilobytes per second, at which data can be transferred to hardware static sound buffers.

Remarks

Some audio cards may be unable to report accurately the number of available or free hardware buffers. This can happen, for example, when the card can play more sounds at lower sampling rates than at higher rates. In general, a nonzero value in any of the members relating to number of free hardware buffers signifies that at least one hardware resource of the appropriate type is available.

The unlock transfer rate for software buffers is 0, because the data need not be transferred anywhere. Similarly, the play processing overhead for hardware buffers is 0 because the mixing is done by the sound device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Device.Caps


Caps.Caps()

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Caps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Caps structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Caps();
Managed C++ | public: Caps();
JScript .NET | public function Caps();


Caps.Certified

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Certified Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the driver is a certified Windows Driver Module (WDM) device driver.

Definition

Visual Basic .NET | Public ReadOnly Property Certified As Boolean
C# | public bool Certified { get; }
Managed C++ | public: __property bool get_Certified();
JScript .NET | public function get Certified() : boolean

Property Value

System.Boolean . Value that is set to true if the driver is a certified Windows Driver Module (WDM) device driver; otherwise, false.

This property is read-only.


Caps.ContinuousRate

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.ContinuousRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports all sample rates between the MinSecondarySampleRate and MaxSecondarySampleRate values.

Definition

Visual Basic .NET | Public ReadOnly Property ContinuousRate As Boolean
C# | public bool ContinuousRate { get; }
Managed C++ | public: __property bool get_ContinuousRate();
JScript .NET | public function get ContinuousRate() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports all sample rates between the MinSecondarySampleRate and MaxSecondarySampleRate values; otherwise, false.

This property is read-only.

Remarks

Typically, this means that the actual output rate will be within +/- 10 hertz (Hz) of the requested frequency.


Caps.EmulateDriver

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.EmulateDriver Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object does not have a Microsoft® DirectSound® driver installed.

Definition

Visual Basic .NET | Public ReadOnly Property EmulateDriver As Boolean
C# | public bool EmulateDriver { get; }
Managed C++ | public: __property bool get_EmulateDriver();
JScript .NET | public function get EmulateDriver() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object does not have a Microsoft® DirectSound® driver installed; otherwise, false.

This property is read-only.

Remarks

If this property is true, the Device object is being emulated through the waveform-audio functions. Performance degradation should be expected.


Caps.FreeHardware3DAllBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FreeHardware3DAllBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of unallocated 3-D buffers.

Definition

Visual Basic .NET | Public ReadOnly Property FreeHardware3DAllBuffers As Integer
C# | public int FreeHardware3DAllBuffers { get; }
Managed C++ | public: __property int get_FreeHardware3DAllBuffers();
JScript .NET | public function get FreeHardware3DAllBuffers() : int

Property Value

System.Int32 . The number of unallocated 3-D buffers.

This property is read-only.


Caps.FreeHardware3DStaticBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FreeHardware3DStaticBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of unallocated static 3-D buffers.

Definition

Visual Basic .NET | Public ReadOnly Property FreeHardware3DStaticBuffers As Integer
C# | public int FreeHardware3DStaticBuffers { get; }
Managed C++ | public: __property int get_FreeHardware3DStaticBuffers();
JScript .NET | public function get FreeHardware3DStaticBuffers() : int

Property Value

System.Int32 . The number of unallocated static 3-D buffers.

This property is read-only.


Caps.FreeHardware3DStreamingBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FreeHardware3DStreamingBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of unallocated streaming 3-D buffers.

Definition

Visual Basic .NET | Public ReadOnly Property FreeHardware3DStreamingBuffers As Integer
C# | public int FreeHardware3DStreamingBuffers { get; }
Managed C++ | public: __property int get_FreeHardware3DStreamingBuffers();
JScript .NET | public function get FreeHardware3DStreamingBuffers() : int

Property Value

System.Int32 . The number of unallocated streaming 3-D buffers.

This property is read-only.


Caps.FreeHardwareMemoryBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FreeHardwareMemoryBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size, in bytes, of the free memory on the sound card.

Definition

Visual Basic .NET | Public ReadOnly Property FreeHardwareMemoryBytes As Integer
C# | public int FreeHardwareMemoryBytes { get; }
Managed C++ | public: __property int get_FreeHardwareMemoryBytes();
JScript .NET | public function get FreeHardwareMemoryBytes() : int

Property Value

System.Int32 . The size, in bytes, of the free memory on the sound card.

This property is read-only.


Caps.FreeHardwareMixingAllBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FreeHardwareMixingAllBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of unallocated buffers.

Definition

Visual Basic .NET | Public ReadOnly Property FreeHardwareMixingAllBuffers As Integer
C# | public int FreeHardwareMixingAllBuffers { get; }
Managed C++ | public: __property int get_FreeHardwareMixingAllBuffers();
JScript .NET | public function get FreeHardwareMixingAllBuffers() : int

Property Value

System.Int32 . The number of unallocated buffers.

This property is read-only.

Remarks

On Windows Driver Model (WDM) drivers, this includes FreeHardware3DAllBuffers.


Caps.FreeHardwareMixingStaticBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FreeHardwareMixingStaticBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of unallocated static buffers.

Definition

Visual Basic .NET | Public ReadOnly Property FreeHardwareMixingStaticBuffers As Integer
C# | public int FreeHardwareMixingStaticBuffers { get; }
Managed C++ | public: __property int get_FreeHardwareMixingStaticBuffers();
JScript .NET | public function get FreeHardwareMixingStaticBuffers() : int

Property Value

System.Int32 . The number of unallocated static buffers.

This property is read-only.


Caps.FreeHardwareMixingStreamingBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.FreeHardwareMixingStreamingBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of unallocated streaming buffers.

Definition

Visual Basic .NET | Public ReadOnly Property FreeHardwareMixingStreamingBuffers As Integer
C# | public int FreeHardwareMixingStreamingBuffers { get; }
Managed C++ | public: __property int get_FreeHardwareMixingStreamingBuffers();
JScript .NET | public function get FreeHardwareMixingStreamingBuffers() : int

Property Value

System.Int32 . The number of unallocated streaming buffers.

This property is read-only.


Caps.MaxContigousFreeHardwareMemoryBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxContigousFreeHardwareMemoryBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size, in bytes, of the largest contiguous block of free memory on the sound card.

Definition

Visual Basic .NET | Public ReadOnly Property MaxContigousFreeHardwareMemoryBytes As Integer
C# | public int MaxContigousFreeHardwareMemoryBytes { get; }
Managed C++ | public: __property int get_MaxContigousFreeHardwareMemoryBytes();
JScript .NET | public function get MaxContigousFreeHardwareMemoryBytes() : int

Property Value

System.Int32 . The size, in bytes, of the largest contiguous block of free memory on the sound card.

This property is read-only.


Caps.MaxHardware3DAllBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardware3DAllBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of 3-D buffers.

Definition

Visual Basic .NET | Public ReadOnly Property MaxHardware3DAllBuffers As Integer
C# | public int MaxHardware3DAllBuffers { get; }
Managed C++ | public: __property int get_MaxHardware3DAllBuffers();
JScript .NET | public function get MaxHardware3DAllBuffers() : int

Property Value

System.Int32 . The maximum number of 3-D buffers.

This property is read-only.


Caps.MaxHardware3DStaticBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardware3DStaticBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of static 3-D buffers.

Definition

Visual Basic .NET | Public ReadOnly Property MaxHardware3DStaticBuffers As Integer
C# | public int MaxHardware3DStaticBuffers { get; }
Managed C++ | public: __property int get_MaxHardware3DStaticBuffers();
JScript .NET | public function get MaxHardware3DStaticBuffers() : int

Property Value

System.Int32 . The maximum number of static 3-D buffers.

This property is read-only.


Caps.MaxHardware3DStreamingBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardware3DStreamingBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of streaming 3-D buffers.

Definition

Visual Basic .NET | Public ReadOnly Property MaxHardware3DStreamingBuffers As Integer
C# | public int MaxHardware3DStreamingBuffers { get; }
Managed C++ | public: __property int get_MaxHardware3DStreamingBuffers();
JScript .NET | public function get MaxHardware3DStreamingBuffers() : int

Property Value

System.Int32 . The maximum number of streaming 3-D buffers.

This property is read-only.


Caps.MaxHardwareMixingAllBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardwareMixingAllBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of buffers that can be mixed in hardware.

Definition

Visual Basic .NET | Public ReadOnly Property MaxHardwareMixingAllBuffers As Integer
C# | public int MaxHardwareMixingAllBuffers { get; }
Managed C++ | public: __property int get_MaxHardwareMixingAllBuffers();
JScript .NET | public function get MaxHardwareMixingAllBuffers() : int

Property Value

System.Int32 . The number of buffers that can be mixed in hardware.

This property is read-only.

Remarks

This member can be less than the sum of MaxHardwareMixingStaticBuffers and MaxHardwareMixingStreamingBuffers. Resource tradeoffs frequently occur.


Caps.MaxHardwareMixingStaticBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardwareMixingStaticBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of static buffers.

Definition

Visual Basic .NET | Public ReadOnly Property MaxHardwareMixingStaticBuffers As Integer
C# | public int MaxHardwareMixingStaticBuffers { get; }
Managed C++ | public: __property int get_MaxHardwareMixingStaticBuffers();
JScript .NET | public function get MaxHardwareMixingStaticBuffers() : int

Property Value

System.Int32 . The maximum number of static buffers.

This property is read-only.


Caps.MaxHardwareMixingStreamingBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxHardwareMixingStreamingBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum number of streaming sound buffers.

Definition

Visual Basic .NET | Public ReadOnly Property MaxHardwareMixingStreamingBuffers As Integer
C# | public int MaxHardwareMixingStreamingBuffers { get; }
Managed C++ | public: __property int get_MaxHardwareMixingStreamingBuffers();
JScript .NET | public function get MaxHardwareMixingStreamingBuffers() : int

Property Value

System.Int32 . The maximum number of streaming sound buffers.

This property is read-only.


Caps.MaxSecondarySampleRate

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MaxSecondarySampleRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

Definition

Visual Basic .NET | Public ReadOnly Property MaxSecondarySampleRate As Integer
C# | public int MaxSecondarySampleRate { get; }
Managed C++ | public: __property int get_MaxSecondarySampleRate();
JScript .NET | public function get MaxSecondarySampleRate() : int

Property Value

System.Int32 . The maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

This property is read-only.


Caps.MinSecondarySampleRate

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.MinSecondarySampleRate Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

Definition

Visual Basic .NET | Public ReadOnly Property MinSecondarySampleRate As Integer
C# | public int MinSecondarySampleRate { get; }
Managed C++ | public: __property int get_MinSecondarySampleRate();
JScript .NET | public function get MinSecondarySampleRate() : int

Property Value

System.Int32 . The maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

This property is read-only.


Caps.PlayCpuOverheadSoftwareBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PlayCpuOverheadSoftwareBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the processing overhead, as a percentage of main processor cycles, needed to mix software buffers.

Definition

Visual Basic .NET | Public ReadOnly Property PlayCpuOverheadSoftwareBuffers As Integer
C# | public int PlayCpuOverheadSoftwareBuffers { get; }
Managed C++ | public: __property int get_PlayCpuOverheadSoftwareBuffers();
JScript .NET | public function get PlayCpuOverheadSoftwareBuffers() : int

Property Value

System.Int32 . The processing overhead, as a percentage of main processor cycles, needed to mix software buffers.

This property is read-only.

Remarks

This property varies according to the bus type, the processor type, and the clock speed.


Caps.Primary16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Primary16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports a primary buffer with 16-bit samples.

Definition

Visual Basic .NET | Public ReadOnly Property Primary16Bit As Boolean
C# | public bool Primary16Bit { get; }
Managed C++ | public: __property bool get_Primary16Bit();
JScript .NET | public function get Primary16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports a primary buffer with 16-bit samples; otherwise, false.

This property is read-only.


Caps.Primary8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Primary8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports primary buffers with 8-bit samples.

Definition

Visual Basic .NET | Public ReadOnly Property Primary8Bit As Boolean
C# | public bool Primary8Bit { get; }
Managed C++ | public: __property bool get_Primary8Bit();
JScript .NET | public function get Primary8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports primary buffers with 8-bit samples; otherwise, false.

This property is read-only.


Caps.PrimaryBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PrimaryBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of primary buffers supported.

Definition

Visual Basic .NET | Public ReadOnly Property PrimaryBuffers As Integer
C# | public int PrimaryBuffers { get; }
Managed C++ | public: __property int get_PrimaryBuffers();
JScript .NET | public function get PrimaryBuffers() : int

Property Value

System.Int32 . The number of primary buffers supported.

This property is read-only.

Remarks

This value will always be 1.


Caps.PrimaryMono

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PrimaryMono Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports monophonic primary buffers.

Definition

Visual Basic .NET | Public ReadOnly Property PrimaryMono As Boolean
C# | public bool PrimaryMono { get; }
Managed C++ | public: __property bool get_PrimaryMono();
JScript .NET | public function get PrimaryMono() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports monophonic primary buffers; otherwise, false.

This property is read-only.


Caps.PrimaryStereo

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.PrimaryStereo Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports stereo primary buffers.

Definition

Visual Basic .NET | Public ReadOnly Property PrimaryStereo As Boolean
C# | public bool PrimaryStereo { get; }
Managed C++ | public: __property bool get_PrimaryStereo();
JScript .NET | public function get PrimaryStereo() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports stereo primary buffers; otherwise, false.

This property is read-only.


Caps.Secondary16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Secondary16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 16-bit samples.

Definition

Visual Basic .NET | Public ReadOnly Property Secondary16Bit As Boolean
C# | public bool Secondary16Bit { get; }
Managed C++ | public: __property bool get_Secondary16Bit();
JScript .NET | public function get Secondary16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports hardware-mixed SecondaryBuffer objects with 16-bit samples; otherwise, false.

This property is read-only.


Caps.Secondary8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.Secondary8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 8-bit samples.

Definition

Visual Basic .NET | Public ReadOnly Property Secondary8Bit As Boolean
C# | public bool Secondary8Bit { get; }
Managed C++ | public: __property bool get_Secondary8Bit();
JScript .NET | public function get Secondary8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports hardware-mixed SecondaryBuffer objects with 8-bit samples; otherwise, false.

This property is read-only.


Caps.SecondaryMono

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SecondaryMono Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports hardware-mixed monophonic SecondaryBuffer objects.

Definition

Visual Basic .NET | Public ReadOnly Property SecondaryMono As Boolean
C# | public bool SecondaryMono { get; }
Managed C++ | public: __property bool get_SecondaryMono();
JScript .NET | public function get SecondaryMono() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports hardware-mixed monophonic SecondaryBuffer objects; otherwise, false.

This property is read-only.


Caps.SecondaryStereo

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.SecondaryStereo Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the Device object supports hardware-mixed stereo SecondaryBuffer objects.

Definition

Visual Basic .NET | Public ReadOnly Property SecondaryStereo As Boolean
C# | public bool SecondaryStereo { get; }
Managed C++ | public: __property bool get_SecondaryStereo();
JScript .NET | public function get SecondaryStereo() : boolean

Property Value

System.Boolean . Value that is set to true if the Device object supports hardware-mixed stero SecondaryBuffer objects; otherwise, false.

This property is read-only.


Caps.TotalHardwareMemoryBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.TotalHardwareMemoryBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size, in bytes, of the amount of memory on the sound card that stores static sound buffers.

Definition

Visual Basic .NET | Public ReadOnly Property TotalHardwareMemoryBytes As Integer
C# | public int TotalHardwareMemoryBytes { get; }
Managed C++ | public: __property int get_TotalHardwareMemoryBytes();
JScript .NET | public function get TotalHardwareMemoryBytes() : int

Property Value

System.Int32 . The size, in bytes, of the amount of memory on the sound card that stores static sound buffers.

This property is read-only.


Caps.UnlockTransferRateHardwareBuffers

Microsoft DirectX 9.0 SDK Update (October 2004)

Caps.UnlockTransferRateHardwareBuffers Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the rate, in kilobytes per second, at which data can be transferred to hardware static sound buffers.

Definition

Visual Basic .NET | Public ReadOnly Property UnlockTransferRateHardwareBuffers As Integer
C# | public int UnlockTransferRateHardwareBuffers { get; }
Managed C++ | public: __property int get_UnlockTransferRateHardwareBuffers();
JScript .NET | public function get UnlockTransferRateHardwareBuffers() : int

Property Value

System.Int32 . The rate, in kilobytes per second, at which data can be transferred to hardware static sound buffers.

This property is read-only.

Remarks

This and the number of bytes transferred determines the duration of a call to the Buffer.Read and Buffer.Write methods.


CaptureBufferCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe the capabilities of a CaptureBuffer object.

Definition

Visual Basic .NET | Public Structure CaptureBufferCaps
C# | public struct CaptureBufferCaps
Managed C++ | public __value struct CaptureBufferCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureBufferCaps | Initializes a new instance of the CaptureBufferCaps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferBytes | Retrieves the size, in bytes, of the CaptureBuffer object.
WaveMapped | Retrieves whether the buffer wave mapped.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureBuffer.Caps


CaptureBufferCaps.CaptureBufferCaps()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferCaps.CaptureBufferCaps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureBufferCaps structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public CaptureBufferCaps();
Managed C++ | public: CaptureBufferCaps();
JScript .NET | public function CaptureBufferCaps();


CaptureBufferCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CaptureBufferCaps.BufferBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferCaps.BufferBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size, in bytes, of the CaptureBuffer object.

Definition

Visual Basic .NET | Public ReadOnly Property BufferBytes As Integer
C# | public int BufferBytes { get; }
Managed C++ | public: __property int get_BufferBytes();
JScript .NET | public function get BufferBytes() : int

Property Value

System.Int32 . The size, in bytes, of the CaptureBuffer object.

This property is read-only.


CaptureBufferCaps.WaveMapped

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferCaps.WaveMapped Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the buffer wave mapped.

Definition

Visual Basic .NET | Public ReadOnly Property WaveMapped As Boolean
C# | public bool WaveMapped { get; }
Managed C++ | public: __property bool get_WaveMapped();
JScript .NET | public function get WaveMapped() : boolean

Property Value

System.Boolean . Value that is set to true if the buffer wave mapped; otherwise, false.

This property is read-only.


CaptureBufferDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe a CaptureBuffer object.

Definition

Visual Basic .NET | Public Structure CaptureBufferDescription
C# | public struct CaptureBufferDescription
Managed C++ | public __value struct CaptureBufferDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureBufferDescription | Initializes a new instance of the CaptureBufferDescription structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferBytes | Retrieves and sets the size of the capture buffer to create, in bytes.
CaptureEffectDescription | Retrieves and sets an array of CaptureEffectDescription structures that describe capture effects supported by the CaptureBuffer object.
ControlEffects | Retrieves and sets whether the CaptureBuffer object supports capture effects.
Format | Retrieves and sets the format in which to capture the audio data.
WaveMapped | Retrieves and sets whether the Microsoft® Win32® wave mapper will be used for formats not supported by the device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureBuffer constructor
  • FullDuplex constructor


CaptureBufferDescription.CaptureBufferDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription.CaptureBufferDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureBufferDescription structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public CaptureBufferDescription();
Managed C++ | public: CaptureBufferDescription();
JScript .NET | public function CaptureBufferDescription();


CaptureBufferDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CaptureBufferDescription.BufferBytes

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription.BufferBytes Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the size of the capture buffer to create, in bytes.

Definition

Visual Basic .NET | Public Property BufferBytes As Integer
C# | public int BufferBytes { get; set; }
Managed C++ public: __property int get_BufferBytes();
public: __property void set_BufferBytes(int);
JScript .NET public function get BufferBytes() : int
public function set BufferBytes(int);

Property Value

System.Int32 . The size of the capture buffer to create, in bytes.

This property is read/write.


CaptureBufferDescription.CaptureEffectDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription.CaptureEffectDescription Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets an array of CaptureEffectDescription structures that describe capture effects supported by the CaptureBuffer object.

Definition

Visual Basic .NET | Public Property CaptureEffectDescription As CaptureEffectDescription()
C# | public CaptureEffectDescription[] CaptureEffectDescription { get; set; }
Managed C++ public: __property CaptureEffectDescription get_CaptureEffectDescription();
public: __property void set_CaptureEffectDescription(CaptureEffectDescription);
JScript .NET public function get CaptureEffectDescription() : CaptureEffectDescription[]
public function set CaptureEffectDescription(CaptureEffectDescription[]);

Property Value

Microsoft.DirectX.DirectSound.CaptureEffectDescription[] . An array of CaptureEffectDescription structures that describe capture effects supported by the CaptureBuffer object.

This property is read/write.


CaptureBufferDescription.ControlEffects

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription.ControlEffects Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the CaptureBuffer object supports capture effects.

Definition

Visual Basic .NET | Public Property ControlEffects As Boolean
C# | public bool ControlEffects { get; set; }
Managed C++ public: __property bool get_ControlEffects();
public: __property void set_ControlEffects(bool);
JScript .NET public function get ControlEffects() : boolean
public function set ControlEffects(boolean);

Property Value

System.Boolean . Value set that is set to true if the CaptureBuffer object supports capture effects; otherwise, false.

This property is read/write.


CaptureBufferDescription.Format

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription.Format Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the format in which to capture the audio data.

Definition

Visual Basic .NET | Public Property Format As WaveFormat
C# | public WaveFormat Format { get; set; }
Managed C++ public: __property WaveFormat get_Format();
public: __property void set_Format(WaveFormat);
JScript .NET public function get Format() : WaveFormat
public function set Format(WaveFormat);

Property Value

Microsoft.DirectX.DirectSound.WaveFormat . The format in which to capture the audio data.

This property is read/write.


CaptureBufferDescription.WaveMapped

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureBufferDescription.WaveMapped Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the Microsoft® Win32® wave mapper will be used for formats not supported by the device.

Definition

Visual Basic .NET | Public Property WaveMapped As Boolean
C# | public bool WaveMapped { get; set; }
Managed C++ public: __property bool get_WaveMapped();
public: __property void set_WaveMapped(bool);
JScript .NET public function get WaveMapped() : boolean
public function set WaveMapped(boolean);

Property Value

System.Boolean . Value that is set to true if the Microsoft® Win32® wave mapper will be used for formats not supported by the device; otherwise, false.

This property is read/write.


CaptureCaps

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describes the capabilities of the capture device.

Definition

Visual Basic .NET | Public Structure CaptureCaps
C# | public struct CaptureCaps
Managed C++ | public __value struct CaptureCaps
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureCaps | Initializes a new instance of the CaptureCaps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Certified | Retrieves whether the driver for the device is a certified Windows Driver Model (WDM) driver.
Channels | Retrieves the number of channels supported by the device.
EmulatedDriver | Retrieves whether there is no Microsoft® DirectSound® capture driver for the device.
Format11KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 11Khz, 16-bit, mono wave format.
Format11KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, mono wave format.
Format11KhzStereo16Bit | Retrieves whet,er the capture device supports capturing audio with the 11Khz, 16-bit, stereo wave format.
Format11KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, stereo wave format.
Format22KhzMono16Bit | Retrieves whet,er the capture device supports capturing audio with the 22Khz, 16-bit, mono wave format.
Format22KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, mono wave format.
Format22KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 22Khz, 16-bit, stereo wave format.
Format22KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, stereo wave format.
Format44KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, mono wave format.
Format44KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, mono wave format.
Format44KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, stereo wave format.
Format44KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, stereo wave format.
Format48KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, mono wave format.
Format48KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, mono wave format.
Format48KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, stereo wave format.
Format48KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, stereo wave format.
Format96KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, mono wave format.
Format96KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, mono wave format.
Format96KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, stereo wave format.
Format96KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, stereo wave format.
MultipleCapture | Retrieves whether multiple capture objects can be used simultaneously on the capture device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Capture.Caps


CaptureCaps.CaptureCaps()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.CaptureCaps Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureCaps structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public CaptureCaps();
Managed C++ | public: CaptureCaps();
JScript .NET | public function CaptureCaps();


CaptureCaps.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CaptureCaps.Certified

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Certified Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the driver for the device is a certified Windows Driver Model (WDM) driver.

Definition

Visual Basic .NET | Public ReadOnly Property Certified As Boolean
C# | public bool Certified { get; }
Managed C++ | public: __property bool get_Certified();
JScript .NET | public function get Certified() : boolean

Property Value

System.Boolean . Value that is set to true if the driver for the device is a certified WDM driver; otherwise, false.

This property is read-only.


CaptureCaps.Channels

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Channels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of channels supported by the device.

Definition

Visual Basic .NET | Public ReadOnly Property Channels As Integer
C# | public int Channels { get; }
Managed C++ | public: __property int get_Channels();
JScript .NET | public function get Channels() : int

Property Value

System.Int32 . The number of channels supported by the device.

This property is read-only.

Remarks

Mono is one channel, stereo is two channels, and so on.


CaptureCaps.EmulatedDriver

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.EmulatedDriver Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether there is no Microsoft® DirectSound® capture driver for the device.

Definition

Visual Basic .NET | Public ReadOnly Property EmulatedDriver As Boolean
C# | public bool EmulatedDriver { get; }
Managed C++ | public: __property bool get_EmulatedDriver();
JScript .NET | public function get EmulatedDriver() : boolean

Property Value

System.Boolean . Value that is set to true if there is no Microsoft® DirectSound® Capture driver for the device; otherwise, false.

This property is read-only.

Remarks

If this property is true, the standard waveform audio functions are being used.


CaptureCaps.Format11KhzMono16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format11KhzMono16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 11Khz, 16-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format11KhzMono16Bit As Boolean
C# | public bool Format11KhzMono16Bit { get; }
Managed C++ | public: __property bool get_Format11KhzMono16Bit();
JScript .NET | public function get Format11KhzMono16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 11Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format11KhzMono8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format11KhzMono8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format11KhzMono8Bit As Boolean
C# | public bool Format11KhzMono8Bit { get; }
Managed C++ | public: __property bool get_Format11KhzMono8Bit();
JScript .NET | public function get Format11KhzMono8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 11Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format11KhzStereo16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format11KhzStereo16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whet,er the capture device supports capturing audio with the 11Khz, 16-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format11KhzStereo16Bit As Boolean
C# | public bool Format11KhzStereo16Bit { get; }
Managed C++ | public: __property bool get_Format11KhzStereo16Bit();
JScript .NET | public function get Format11KhzStereo16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 11Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format11KhzStereo8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format11KhzStereo8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format11KhzStereo8Bit As Boolean
C# | public bool Format11KhzStereo8Bit { get; }
Managed C++ | public: __property bool get_Format11KhzStereo8Bit();
JScript .NET | public function get Format11KhzStereo8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 11Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzMono16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format22KhzMono16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whet,er the capture device supports capturing audio with the 22Khz, 16-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format22KhzMono16Bit As Boolean
C# | public bool Format22KhzMono16Bit { get; }
Managed C++ | public: __property bool get_Format22KhzMono16Bit();
JScript .NET | public function get Format22KhzMono16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 22Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzMono8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format22KhzMono8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format22KhzMono8Bit As Boolean
C# | public bool Format22KhzMono8Bit { get; }
Managed C++ | public: __property bool get_Format22KhzMono8Bit();
JScript .NET | public function get Format22KhzMono8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 22Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzStereo16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format22KhzStereo16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 22Khz, 16-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format22KhzStereo16Bit As Boolean
C# | public bool Format22KhzStereo16Bit { get; }
Managed C++ | public: __property bool get_Format22KhzStereo16Bit();
JScript .NET | public function get Format22KhzStereo16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 22Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzStereo8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format22KhzStereo8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format22KhzStereo8Bit As Boolean
C# | public bool Format22KhzStereo8Bit { get; }
Managed C++ | public: __property bool get_Format22KhzStereo8Bit();
JScript .NET | public function get Format22KhzStereo8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 22Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzMono16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format44KhzMono16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format44KhzMono16Bit As Boolean
C# | public bool Format44KhzMono16Bit { get; }
Managed C++ | public: __property bool get_Format44KhzMono16Bit();
JScript .NET | public function get Format44KhzMono16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 44Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzMono8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format44KhzMono8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format44KhzMono8Bit As Boolean
C# | public bool Format44KhzMono8Bit { get; }
Managed C++ | public: __property bool get_Format44KhzMono8Bit();
JScript .NET | public function get Format44KhzMono8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 44Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzStereo16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format44KhzStereo16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format44KhzStereo16Bit As Boolean
C# | public bool Format44KhzStereo16Bit { get; }
Managed C++ | public: __property bool get_Format44KhzStereo16Bit();
JScript .NET | public function get Format44KhzStereo16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 44Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzStereo8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format44KhzStereo8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format44KhzStereo8Bit As Boolean
C# | public bool Format44KhzStereo8Bit { get; }
Managed C++ | public: __property bool get_Format44KhzStereo8Bit();
JScript .NET | public function get Format44KhzStereo8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 44Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzMono16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format48KhzMono16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format48KhzMono16Bit As Boolean
C# | public bool Format48KhzMono16Bit { get; }
Managed C++ | public: __property bool get_Format48KhzMono16Bit();
JScript .NET | public function get Format48KhzMono16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 48Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzMono8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format48KhzMono8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format48KhzMono8Bit As Boolean
C# | public bool Format48KhzMono8Bit { get; }
Managed C++ | public: __property bool get_Format48KhzMono8Bit();
JScript .NET | public function get Format48KhzMono8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 48Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzStereo16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format48KhzStereo16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format48KhzStereo16Bit As Boolean
C# | public bool Format48KhzStereo16Bit { get; }
Managed C++ | public: __property bool get_Format48KhzStereo16Bit();
JScript .NET | public function get Format48KhzStereo16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 48Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzStereo8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format48KhzStereo8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format48KhzStereo8Bit As Boolean
C# | public bool Format48KhzStereo8Bit { get; }
Managed C++ | public: __property bool get_Format48KhzStereo8Bit();
JScript .NET | public function get Format48KhzStereo8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 48Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzMono16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format96KhzMono16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format96KhzMono16Bit As Boolean
C# | public bool Format96KhzMono16Bit { get; }
Managed C++ | public: __property bool get_Format96KhzMono16Bit();
JScript .NET | public function get Format96KhzMono16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 96Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzMono8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format96KhzMono8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, mono wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format96KhzMono8Bit As Boolean
C# | public bool Format96KhzMono8Bit { get; }
Managed C++ | public: __property bool get_Format96KhzMono8Bit();
JScript .NET | public function get Format96KhzMono8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 96Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzStereo16Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format96KhzStereo16Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format96KhzStereo16Bit As Boolean
C# | public bool Format96KhzStereo16Bit { get; }
Managed C++ | public: __property bool get_Format96KhzStereo16Bit();
JScript .NET | public function get Format96KhzStereo16Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 96Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzStereo8Bit

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.Format96KhzStereo8Bit Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, stereo wave format.

Definition

Visual Basic .NET | Public ReadOnly Property Format96KhzStereo8Bit As Boolean
C# | public bool Format96KhzStereo8Bit { get; }
Managed C++ | public: __property bool get_Format96KhzStereo8Bit();
JScript .NET | public function get Format96KhzStereo8Bit() : boolean

Property Value

System.Boolean . Value that is set to true if the capture device supports capturing audio with the 96Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.MultipleCapture

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureCaps.MultipleCapture Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves whether multiple capture objects can be used simultaneously on the capture device.

Definition

Visual Basic .NET | Public ReadOnly Property MultipleCapture As Boolean
C# | public bool MultipleCapture { get; }
Managed C++ | public: __property bool get_MultipleCapture();
JScript .NET | public function get MultipleCapture() : boolean

Property Value

System.Boolean . Value that is set to true if multiple capture objects can be used simultaneously on the capture device; otherwise, false.

This property is read-only.


CaptureEffectDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties for an effect associated with a CaptureBuffer object.

Definition

Visual Basic .NET | Public Structure CaptureEffectDescription
C# | public struct CaptureEffectDescription
Managed C++ | public __value struct CaptureEffectDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureEffectDescription | Initializes a new instance of the CaptureEffectDescription structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
GuidEffectsClass | Retrieves and sets the class identifier of the capture effect.
GuidEffectsInstance | Retrieves and sets the unique identifier of the preferred capture effect.
LocateInHardware | Retrieves or sets whether the capture effect must be in hardware.
LocateInSoftware | Retrieves or sets whether the capture effect must be in software.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureBuffer.GetObjectInPath


CaptureEffectDescription.CaptureEffectDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectDescription.CaptureEffectDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureEffectDescription structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public CaptureEffectDescription();
Managed C++ | public: CaptureEffectDescription();
JScript .NET | public function CaptureEffectDescription();


CaptureEffectDescription.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectDescription.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CaptureEffectDescription.GuidEffectsClass

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectDescription.GuidEffectsClass Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the class identifier of the capture effect.

Definition

Visual Basic .NET | Public Property GuidEffectsClass As Guid
C# | public Guid GuidEffectsClass { get; set; }
Managed C++ public: __property Guid get_GuidEffectsClass();
public: __property void set_GuidEffectsClass(Guid);
JScript .NET public function get GuidEffectsClass() : Guid
public function set GuidEffectsClass(Guid);

Property Value

System.Guid . The class identifier of the capture effect.

This property is read/write.

Remarks

When setting capture effects to a CaptureBuffer object, use the DSoundHelper class to get the globally unique identifier (GUID) for this property.


CaptureEffectDescription.GuidEffectsInstance

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectDescription.GuidEffectsInstance Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the unique identifier of the preferred capture effect.

Definition

Visual Basic .NET | Public Property GuidEffectsInstance As Guid
C# | public Guid GuidEffectsInstance { get; set; }
Managed C++ public: __property Guid get_GuidEffectsInstance();
public: __property void set_GuidEffectsInstance(Guid);
JScript .NET public function get GuidEffectsInstance() : Guid
public function set GuidEffectsInstance(Guid);

Property Value

System.Guid . The unique identifier of the preferred capture effect.

This property is read/write.

Remarks

When setting capture effects to a CaptureBuffer object, use the DSoundHelper class to get the globally unique identifier (GUID) for this property.


CaptureEffectDescription.LocateInHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectDescription.LocateInHardware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets whether the capture effect must be in hardware.

Definition

Visual Basic .NET | Public Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; set; }
Managed C++ public: __property bool get_LocateInHardware();
public: __property void set_LocateInHardware(bool);
JScript .NET public function get LocateInHardware() : boolean
public function set LocateInHardware(boolean);

Property Value

System.Boolean . Value that is set to true if the capture effect must be in hardware; otherwise, false.

This property is read/write.

Remarks

Because Microsoft® DirectX® 9.0 does not support hardware acceleration of capture effects, this flag should not be used.


CaptureEffectDescription.LocateInSoftware

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectDescription.LocateInSoftware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets whether the capture effect must be in software.

Definition

Visual Basic .NET | Public Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; set; }
Managed C++ public: __property bool get_LocateInSoftware();
public: __property void set_LocateInSoftware(bool);
JScript .NET public function get LocateInSoftware() : boolean
public function set LocateInSoftware(boolean);

Property Value

System.Boolean . Value that is set to true if the capture effect must be in software; otherwise, false.

This property is read/write.

Remarks

In Microsoft® DirectX® 9.0, all capture effects are in software regardless of whether this flag is set.


CaptureEffectsAcousticEchoCancellation

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsAcousticEchoCancellation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties for acoustic echo cancellation in a capture buffer.

Definition

Visual Basic .NET | Public Structure CaptureEffectsAcousticEchoCancellation
C# | public struct CaptureEffectsAcousticEchoCancellation
Managed C++ | public __value struct CaptureEffectsAcousticEchoCancellation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureEffectsAcousticEchoCancellation | Initializes a new instance of the CaptureEffectsAcousticEchoCancellation structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Enable | Retrieves and sets whether the effect is enabled.
Mode | Retrieves and sets the operation mode of the effect.
NoiseFill | Retrieves and sets whether to enable background comfort noise for the effect.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureAcousticEchoCancellationEffect.AllParameters


CaptureEffectsAcousticEchoCancellation.CaptureEffectsAcousticEchoCancellation()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsAcousticEchoCancellation.CaptureEffectsAcousticEchoCancellation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureEffectsAcousticEchoCancellation structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public CaptureEffectsAcousticEchoCancellation();
Managed C++ | public: CaptureEffectsAcousticEchoCancellation();
JScript .NET | public function CaptureEffectsAcousticEchoCancellation();


CaptureEffectsAcousticEchoCancellation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsAcousticEchoCancellation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CaptureEffectsAcousticEchoCancellation.Enable

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsAcousticEchoCancellation.Enable Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the effect is enabled.

Definition

Visual Basic .NET | Public Property Enable As Boolean
C# | public bool Enable { get; set; }
Managed C++ public: __property bool get_Enable();
public: __property void set_Enable(bool);
JScript .NET public function get Enable() : boolean
public function set Enable(boolean);

Property Value

System.Boolean . Value that is set to true if the effect is enabled; otherwise, false.

This property is read/write.


CaptureEffectsAcousticEchoCancellation.Mode

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsAcousticEchoCancellation.Mode Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the operation mode of the effect.

Definition

Visual Basic .NET | Public Property Mode As OperationMode
C# | public OperationMode Mode { get; set; }
Managed C++ public: __property OperationMode get_Mode();
public: __property void set_Mode(OperationMode);
JScript .NET public function get Mode() : OperationMode
public function set Mode(OperationMode);

Property Value

Microsoft.DirectX.DirectSound.OperationMode . The operation mode of the effect.

This property is read/write.


CaptureEffectsAcousticEchoCancellation.NoiseFill

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsAcousticEchoCancellation.NoiseFill Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether to enable background comfort noise for the effect.

Definition

Visual Basic .NET | Public Property NoiseFill As Boolean
C# | public bool NoiseFill { get; set; }
Managed C++ public: __property bool get_NoiseFill();
public: __property void set_NoiseFill(bool);
JScript .NET public function get NoiseFill() : boolean
public function set NoiseFill(boolean);

Property Value

System.Boolean . Value that is set to true if the effect enables background comfort noise; otherwise, false.

This property is read/write.

Remarks

Enabling background comfort noise for the effect makes the capture signal sound more natural by preventing periods of dead silence.

By default, background comfort noise is not enabled.


CaptureEffectsNoiseSuppress

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsNoiseSuppress Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains parameters for noise suppression in a capture buffer.

Definition

Visual Basic .NET | Public Structure CaptureEffectsNoiseSuppress
C# | public struct CaptureEffectsNoiseSuppress
Managed C++ | public __value struct CaptureEffectsNoiseSuppress
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureEffectsNoiseSuppress | Initializes a new instance of the CaptureEffectsNoiseSuppress structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Enable | Retrieves and sets whether the effect is enabled in the CaptureEffectsNoiseSuppress structure.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CaptureNoiseSuppressEffect.AllParameters


CaptureEffectsNoiseSuppress.CaptureEffectsNoiseSuppress()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsNoiseSuppress.CaptureEffectsNoiseSuppress Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the CaptureEffectsNoiseSuppress structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public CaptureEffectsNoiseSuppress();
Managed C++ | public: CaptureEffectsNoiseSuppress();
JScript .NET | public function CaptureEffectsNoiseSuppress();


CaptureEffectsNoiseSuppress.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsNoiseSuppress.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


CaptureEffectsNoiseSuppress.Enable

Microsoft DirectX 9.0 SDK Update (October 2004)

CaptureEffectsNoiseSuppress.Enable Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the effect is enabled in the CaptureEffectsNoiseSuppress structure.

Definition

Visual Basic .NET | Public Property Enable As Boolean
C# | public bool Enable { get; set; }
Managed C++ public: __property bool get_Enable();
public: __property void set_Enable(bool);
JScript .NET public function get Enable() : boolean
public function set Enable(boolean);

Property Value

System.Boolean . Specifies whether the effect is enabled.

This property is read/write.


DeviceInformation

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describe information about a device.

Definition

Visual Basic .NET | Public Structure DeviceInformation
C# | public struct DeviceInformation
Managed C++ | public __value struct DeviceInformation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceInformation | Initializes a new instance of the DeviceInformation structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Description | Retrieves a textual description of the DirectSound device.
DriverGuid | Retrieves the globally unique identifier (GUID) of a DirectSound driver.
ModuleName | Retrieves the module name of the Microsoft® DirectSound® driver corresponding to this device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • CapturedevicesCollection.Reset
  • CapturedevicesCollection.Count
  • CapturedevicesCollection.Current
  • CapturedevicesCollection.Item
  • CapturedevicesCollection
  • CapturedevicesCollection.MoveNext
  • Device constructor
  • DeviceCollection
  • DeviceCollection.Count
  • DeviceCollection.Current
  • DeviceCollection.Item
  • DeviceCollection.MoveNext
  • DeviceCollection.Reset


DeviceInformation.DeviceInformation()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.DeviceInformation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DeviceInformation structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public DeviceInformation();
Managed C++ | public: DeviceInformation();
JScript .NET | public function DeviceInformation();


DeviceInformation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


DeviceInformation.Description

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.Description Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a textual description of the Microsoft® DirectSound® device.

Definition

Visual Basic .NET | Public ReadOnly Property Description As String
C# | public string Description { get; }
Managed C++ | public: __property String* get_Description();
JScript .NET | public function get Description() : String

Property Value

System.String . A textual description of the Microsoft® DirectSound® device.

This property is read-only.


DeviceInformation.DriverGuid

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.DriverGuid Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the globally unique identifier (GUID) of a Microsoft® DirectSound® driver.

Definition

Visual Basic .NET | Public ReadOnly Property DriverGuid As Guid
C# | public Guid DriverGuid { get; }
Managed C++ | public: __property Guid get_DriverGuid();
JScript .NET | public function get DriverGuid() : Guid

Property Value

System.Guid . The globally unique identifier (GUID) of a Microsoft® DirectSound® driver.

This property is read-only.

Remarks

The primary device can have more than one globally unique identifier (GUID). The first is always null. This null GUID is used when the device is used as the primary device. Its actual GUID is used when it is used by its actual device identifier.


DeviceInformation.ModuleName

Microsoft DirectX 9.0 SDK Update (October 2004)

DeviceInformation.ModuleName Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the module name of the Microsoft® DirectSound® driver corresponding to this device.

Definition

Visual Basic .NET | Public ReadOnly Property ModuleName As String
C# | public string ModuleName { get; }
Managed C++ | public: __property String* get_ModuleName();
JScript .NET | public function get ModuleName() : String

Property Value

System.String . The module name of the Microsoft® DirectSound® driver corresponding to this device.

This property is read-only.


EffectDescription

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Contains properties that describe an effect associated with a buffer.

Definition

Visual Basic .NET | Public Structure EffectDescription
C# | public struct EffectDescription
Managed C++ | public __value struct EffectDescription
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectDescription | Initializes a new instance of the EffectDescription structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
GuidEffectClass | Retrieves and sets the class identifier of the effect.
LocateInHardware | Retrieves or sets whether the effect must be in hardware.
LocateInSoftware | Retrieves or sets whether the effect must be in software.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Secondarybuffer.SetEffects


EffectDescription.EffectDescription()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.EffectDescription Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the EffectDescription structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectDescription();
Managed C++ | public: EffectDescription();
JScript .NET | public function EffectDescription();


EffectDescription.GuidEffectClass

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.GuidEffectClass Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves and sets the class identifier of the effect.

Definition

Visual Basic .NET | Public Property GuidEffectClass As Guid
C# | public Guid GuidEffectClass { get; set; }
Managed C++ public: __property Guid get_GuidEffectClass();
public: __property void set_GuidEffectClass(Guid);
JScript .NET public function get GuidEffectClass() : Guid
public function set GuidEffectClass(Guid);

Property Value

System.Guid . The class identifier of the effect.

This property is read/write.

Remarks

When setting effects to a sound buffer, use the DSoundHelper class to get the globally unique identifier (GUID) for this property.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


EffectDescription.LocateInHardware

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.LocateInHardware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets whether the effect must be in hardware.

Definition

Visual Basic .NET | Public Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; set; }
Managed C++ public: __property bool get_LocateInHardware();
public: __property void set_LocateInHardware(bool);
JScript .NET public function get LocateInHardware() : boolean
public function set LocateInHardware(boolean);

Property Value

System.Boolean . Value that is set to true if the effect must be in hardware; otherwise, false.

This property is read/write.

Remarks

Because Microsoft® DirectX® 9.0 does not support hardware acceleration of effects, this flag should not be used.


EffectDescription.LocateInSoftware

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectDescription.LocateInSoftware Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets whether the effect must be in software.

Definition

Visual Basic .NET | Public Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; set; }
Managed C++ public: __property bool get_LocateInSoftware();
public: __property void set_LocateInSoftware(bool);
JScript .NET public function get LocateInSoftware() : boolean
public function set LocateInSoftware(boolean);

Property Value

System.Boolean . Value that is set to true if the effect must be in software; otherwise, false.

This property is read/write.

Remarks

In Microsoft® DirectX® 9.0, all effects are in software regardless of whether this flag is set.


EffectsChorus

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for a chorus effect.

Definition

Visual Basic .NET | Public Structure EffectsChorus
C# | public struct EffectsChorus
Managed C++ | public __value struct EffectsChorus
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsChorus | Initializes a new instance of the EffectsChorus structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Delay | Retrieves and sets the number of milliseconds the input is delayed before it is played back, in the EffectsChorus structure.
Depth | Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator, in hundredths of a percentage point, in the EffectsChorus structure.
Feedback | Retrieves and sets the percentage of output signal to feed back into the effect's input, in the EffectsChorus structure.
Frequency | Retrieves and sets the frequency of the LFO, in the EffectsChorus structure.
Phase | Retrieves and sets the phase differential between left and right LFOs, in the EffectsChorus structure.
Waveform | Retrieves and sets the waveform shape of the LFO, in the EffectsChorus structure.
WetDryMix | Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal, in the EffectsChorus structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • ChorusEffect.AllParameters


EffectsChorus.EffectsChorus()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.EffectsChorus Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsChorus structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsChorus();
Managed C++ | public: EffectsChorus();
JScript .NET | public function EffectsChorus();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsChorus.Delay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.Delay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the number of milliseconds the input is delayed before it is played back, in the EffectsChorus structure.

Definition

Visual Basic .NET | Public Property Delay As Single
C# | public float Delay { get; set; }
Managed C++ public: __property float get_Delay();
public: __property void set_Delay(float);
JScript .NET public function get Delay() : float
public function set Delay(float);

Property Value

System.Single . Number of milliseconds the input is delayed before it is played back.

This property is read/write.

Remarks

Can range from ChorusEffect.DelayMin to ChorusEffect.DelayMax.

The default value is 16 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Depth

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.Depth Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator, in hundredths of a percentage point, in the EffectsChorus structure.

Definition

Visual Basic .NET | Public Property Depth As Single
C# | public float Depth { get; set; }
Managed C++ public: __property float get_Depth();
public: __property void set_Depth(float);
JScript .NET public function get Depth() : float
public function set Depth(float);

Property Value

System.Single . Percentage by which the delay time is modulated by the low-frequency oscillator, in hundredths of a percentage point.

This property is read/write.

Remarks

Can range from ChorusEffect.DepthMin to ChorusEffect.DepthMax.

The default value is 10.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Feedback

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.Feedback Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of output signal to feed back into the effect's input, in the EffectsChorus structure.

Definition

Visual Basic .NET | Public Property Feedback As Single
C# | public float Feedback { get; set; }
Managed C++ public: __property float get_Feedback();
public: __property void set_Feedback(float);
JScript .NET public function get Feedback() : float
public function set Feedback(float);

Property Value

System.Single . Percentage of output signal to feed back into the effect's input.

This property is read/write.

Remarks

Can range from ChorusEffect.FeedbackMin to ChorusEffect.FeedbackMax.

The default value is 25.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Frequency

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.Frequency Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the frequency of the LFO, in the EffectsChorus structure.

Definition

Visual Basic .NET | Public Property Frequency As Single
C# | public float Frequency { get; set; }
Managed C++ public: __property float get_Frequency();
public: __property void set_Frequency(float);
JScript .NET public function get Frequency() : float
public function set Frequency(float);

Property Value

System.Single . Frequency of the LFO.

This property is read/write.

Remarks

Can range from ChorusEffect.FrequencyMin to ChorusEffect.FrequencyMax.

The default value is 1.1.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Phase

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.Phase Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the phase differential between left and right LFOs, in the EffectsChorus structure.

Definition

Visual Basic .NET | Public Property Phase As Integer
C# | public int Phase { get; set; }
Managed C++ public: __property int get_Phase();
public: __property void set_Phase(int);
JScript .NET public function get Phase() : int
public function set Phase(int);

Property Value

System.Int32 . Phase differential between left and right LFOs.

This property is read/write.

Remarks

Can range from ChorusEffect.PhaseMin to ChorusEffect.PhaseMax.

Can be set by the one values below:

  • ChorusEffect.PhaseZero
  • ChorusEffect.Phase90
  • ChorusEffect.PhaseNegative90
  • ChorusEffect.Phase180
  • ChorusEffect.PhaseNegative180

The default value is ChorusEffect.Phase90.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Waveform

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.Waveform Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the waveform shape of the LFO, in the EffectsChorus structure.

Definition

Visual Basic .NET | Public Property Waveform As Integer
C# | public int Waveform { get; set; }
Managed C++ public: __property int get_Waveform();
public: __property void set_Waveform(int);
JScript .NET public function get Waveform() : int
public function set Waveform(int);

Property Value

System.Int32 . Waveform shape of the LFO.

This property is read/write.

Remarks

Can be set by the one values below:

  • ChorusEffect.WaveSin
  • ChorusEffect.WaveTrianlge

The default value is ChorusEffect.WaveSin.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.WetDryMix

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsChorus.WetDryMix Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal, in the EffectsChorus structure.

Definition

Visual Basic .NET | Public Property WetDryMix As Single
C# | public float WetDryMix { get; set; }
Managed C++ public: __property float get_WetDryMix();
public: __property void set_WetDryMix(float);
JScript .NET public function get WetDryMix() : float
public function set WetDryMix(float);

Property Value

System.Single . Ratio of wet (processed) signal to dry (unprocessed) signal.

This property is read/write.

Remarks

Can range from ChorusEffect.WetDryMixMin to ChorusEffect.WetDryMixMax.

The default value is 50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for a compressor effect.

Definition

Visual Basic .NET | Public Structure EffectsCompressor
C# | public struct EffectsCompressor
Managed C++ | public __value struct EffectsCompressor
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsCompressor | Initializes a new instance of the EffectsCompressor structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Attack | Retrieves and sets the time before compression reaches its full value, in the EffectsCompressor structure.
Gain | Retrieves and sets the output gain of signal after compression, in the EffectsCompressor structure.
Predelay | Retrieves and sets the time after Threshold is reached before attack phase is started, in milliseconds, in the EffectsCompressor structure.
Ratio | Retrieves and sets the compression ratio, in the EffectsCompressor structure.
Release | Retrieves and sets the speed at which compression is stopped after input drops below Threshold, in the EffectsCompressor structure.
Threshold | Retrieves and sets the point at which compression begins, in the EffectsCompressor structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • ChorusEffect.AllParameters


EffectsCompressor.EffectsCompressor()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.EffectsCompressor Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsCompressor structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsCompressor();
Managed C++ | public: EffectsCompressor();
JScript .NET | public function EffectsCompressor();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsCompressor.Attack

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.Attack Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the time before compression reaches its full value, in the EffectsCompressor structure.

Definition

Visual Basic .NET | Public Property Attack As Single
C# | public float Attack { get; set; }
Managed C++ public: __property float get_Attack();
public: __property void set_Attack(float);
JScript .NET public function get Attack() : float
public function set Attack(float);

Property Value

System.Single . Time before compression reaches its full value.

This property is read/write.

Remarks

Can range from CompressorEffect.AttackMin to CompressorEffect.AttackMax.

The default value is 10 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Gain

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.Gain Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the output gain of signal after compression, in the EffectsCompressor structure.

Definition

Visual Basic .NET | Public Property Gain As Single
C# | public float Gain { get; set; }
Managed C++ public: __property float get_Gain();
public: __property void set_Gain(float);
JScript .NET public function get Gain() : float
public function set Gain(float);

Property Value

System.Single . Output gain of signal after compression.

This property is read/write.

Remarks

Can range from CompressorEffect.GainMin to CompressorEffect.GainMax.

The default value is 0 dB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Predelay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.Predelay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the time after Threshold is reached before attack phase is started, in milliseconds, in the EffectsCompressor structure.

Definition

Visual Basic .NET | Public Property Predelay As Single
C# | public float Predelay { get; set; }
Managed C++ public: __property float get_Predelay();
public: __property void set_Predelay(float);
JScript .NET public function get Predelay() : float
public function set Predelay(float);

Property Value

System.Single . Time after Threshold is reached before attack phase is started, in milliseconds.

This property is read/write.

Remarks

Can range from CompressorEffect.PredelayMin to CompressorEffect.PredelayMax.

The default value is 4 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Ratio

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.Ratio Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the compression ratio, in the EffectsCompressor structure.

Definition

Visual Basic .NET | Public Property Ratio As Single
C# | public float Ratio { get; set; }
Managed C++ public: __property float get_Ratio();
public: __property void set_Ratio(float);
JScript .NET public function get Ratio() : float
public function set Ratio(float);

Property Value

System.Single . Compression ratio.

This property is read/write.

Remarks

Can range from CompressorEffect.RatioMin to CompressorEffect.RatioMax.

The default value is 3, which means 3:1 compression.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Release

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.Release Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the speed at which compression is stopped after input drops below Threshold, in the EffectsCompressor structure.

Definition

Visual Basic .NET | Public Property Release As Single
C# | public float Release { get; set; }
Managed C++ public: __property float get_Release();
public: __property void set_Release(float);
JScript .NET public function get Release() : float
public function set Release(float);

Property Value

System.Single . Speed at which compression is stopped after input drops below Threshold.

This property is read/write.

Remarks

Can range from CompressorEffect.ReleaseMin to CompressorEffect.ReleaseMax.

The default value is 200 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Threshold

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsCompressor.Threshold Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the point at which compression begins, in the EffectsCompressor structure.

Definition

Visual Basic .NET | Public Property Threshold As Single
C# | public float Threshold { get; set; }
Managed C++ public: __property float get_Threshold();
public: __property void set_Threshold(float);
JScript .NET public function get Threshold() : float
public function set Threshold(float);

Property Value

System.Single . Point at which compression begins.

This property is read/write.

Remarks

Can range from CompressorEffect.ThresholdMin to CompressorEffect.ThresholdMax.

The default value is -20 dB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for a distortion effect.

Definition

Visual Basic .NET | Public Structure EffectsDistortion
C# | public struct EffectsDistortion
Managed C++ | public __value struct EffectsDistortion
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsDistortion | Initializes a new instance of the EffectsDistortion structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Edge | Retrieves and sets the percentage of distortion intensity, in the EffectsDistortion structure.
Gain | Retrieves and sets the amount of signal change after distortion, in the EffectsDistortion structure.
PostEqBandwidth | Retrieves and sets the width of frequency band that determines range of harmonic content addition, in the EffectsDistortion structure.
PostEqCenterFrequency | Retrieves and sets the center frequency of harmonic content addition, in the EffectsDistortion structure.
PreLowpassCutoff | Retrieves and sets the filter cutoff for high-frequency harmonics attenuation, in the EffectsDistortion structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • DistortionEffect.AllParameters


EffectsDistortion.EffectsDistortion()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion.EffectsDistortion Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsDistortion structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsDistortion();
Managed C++ | public: EffectsDistortion();
JScript .NET | public function EffectsDistortion();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsDistortion.Edge

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion.Edge Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of distortion intensity, in the EffectsDistortion structure.

Definition

Visual Basic .NET | Public Property Edge As Single
C# | public float Edge { get; set; }
Managed C++ public: __property float get_Edge();
public: __property void set_Edge(float);
JScript .NET public function get Edge() : float
public function set Edge(float);

Property Value

System.Single . Percentage of distortion intensity.

This property is read/write.

Remarks

Can range from DistortionEffect.EdgeMin to DistortionEffect.EdgeMax.

The default value is 15.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.Gain

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion.Gain Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the amount of signal change after distortion, in the EffectsDistortion structure.

Definition

Visual Basic .NET | Public Property Gain As Single
C# | public float Gain { get; set; }
Managed C++ public: __property float get_Gain();
public: __property void set_Gain(float);
JScript .NET public function get Gain() : float
public function set Gain(float);

Property Value

System.Single . Amount of signal change after distortion.

This property is read/write.

Remarks

Can range from DistortionEffect.GainMin to DistortionEffect.GainMax.

The default value is -18 dB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.PostEqBandwidth

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion.PostEqBandwidth Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the width of frequency band that determines range of harmonic content addition, in the EffectsDistortion structure.

Definition

Visual Basic .NET | Public Property PostEqBandwidth As Single
C# | public float PostEqBandwidth { get; set; }
Managed C++ public: __property float get_PostEqBandwidth();
public: __property void set_PostEqBandwidth(float);
JScript .NET public function get PostEqBandwidth() : float
public function set PostEqBandwidth(float);

Property Value

System.Single . Width of frequency band that determines range of harmonic content addition.

This property is read/write.

Remarks

Can range from DistortionEffect.PostEqBandwidthMin to DistortionEffect.PostEqBandwidthMax.

The default value is 2400Hz.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.PostEqCenterFrequency

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion.PostEqCenterFrequency Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the center frequency of harmonic content addition, in the EffectsDistortion structure.

Definition

Visual Basic .NET | Public Property PostEqCenterFrequency As Single
C# | public float PostEqCenterFrequency { get; set; }
Managed C++ public: __property float get_PostEqCenterFrequency();
public: __property void set_PostEqCenterFrequency(float);
JScript .NET public function get PostEqCenterFrequency() : float
public function set PostEqCenterFrequency(float);

Property Value

System.Single . Center frequency of harmonic content addition.

This property is read/write.

Remarks

Can range from DistortionEffect.PostEqCenterFrequencyMin to DistortionEffect.PostEqCenterFrequency.

The default value is 2400 Hz.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.PreLowpassCutoff

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsDistortion.PreLowpassCutoff Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the filter cutoff for high-frequency harmonics attenuation, in the EffectsDistortion structure.

Definition

Visual Basic .NET | Public Property PreLowpassCutoff As Single
C# | public float PreLowpassCutoff { get; set; }
Managed C++ public: __property float get_PreLowpassCutoff();
public: __property void set_PreLowpassCutoff(float);
JScript .NET public function get PreLowpassCutoff() : float
public function set PreLowpassCutoff(float);

Property Value

System.Single . Filter cutoff for high-frequency harmonics attenuation.

This property is read/write.

Remarks

Can range from DistortionEffect.PreLowpassCutoffMin to DistortionEffect.PreLowpassCutoffMax.

The default value is 15.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for an echo effect.

Definition

Visual Basic .NET | Public Structure EffectsEcho
C# | public struct EffectsEcho
Managed C++ | public __value struct EffectsEcho
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsEcho | Initializes a new instance of the EffectsEcho structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Feedback | Retrieves and sets the percentage of output fed back into input, in the EffectsEcho structure.
LeftDelay | Retrieves and sets the delay for left channel, in milliseconds, in the EffectsEcho structure.
PanDelay | Retrieves and sets the value that specifies whether to swap left and right delays with each successive echo, in the EffectsEcho structure.
RightDelay | Retrieves and sets the delay for right channel, in milliseconds, in the EffectsEcho structure.
WetDryMix | Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal in the EffectsEcho structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • EchoEffect.AllParameters


EffectsEcho.EffectsEcho()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho.EffectsEcho Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsEcho structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsEcho();
Managed C++ | public: EffectsEcho();
JScript .NET | public function EffectsEcho();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsEcho.Feedback

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho.Feedback Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of output fed back into input, in the EffectsEcho structure.

Definition

Visual Basic .NET | Public Property Feedback As Single
C# | public float Feedback { get; set; }
Managed C++ public: __property float get_Feedback();
public: __property void set_Feedback(float);
JScript .NET public function get Feedback() : float
public function set Feedback(float);

Property Value

System.Single . Percentage of output fed back into input.

This property is read/write.

Remarks

Can range from EchoEffect.FeedbackMin to EchoEffect.FeedbackMax.

The default value is 50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.LeftDelay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho.LeftDelay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the delay for left channel, in milliseconds, in the EffectsEcho structure.

Definition

Visual Basic .NET | Public Property LeftDelay As Single
C# | public float LeftDelay { get; set; }
Managed C++ public: __property float get_LeftDelay();
public: __property void set_LeftDelay(float);
JScript .NET public function get LeftDelay() : float
public function set LeftDelay(float);

Property Value

System.Single . Delay for left channel, in milliseconds.

This property is read/write.

Remarks

Can range from EchoEffect.LefttDelayMin to EchoEffect.LeftDelayMax.

The default value is 500 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.PanDelay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho.PanDelay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the value that specifies whether to swap left and right delays with each successive echo, in the EffectsEcho structure.

Definition

Visual Basic .NET | Public Property PanDelay As Integer
C# | public int PanDelay { get; set; }
Managed C++ public: __property int get_PanDelay();
public: __property void set_PanDelay(int);
JScript .NET public function get PanDelay() : int
public function set PanDelay(int);

Property Value

System.Int32 . Value that specifies whether to swap left and right delays with each successive echo.

This property is read/write.

Remarks

Can range from EchoEffect.PanDelayMin to EchoEffect.PanDelayMax.

The default value is zero, meaning no swap.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.RightDelay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho.RightDelay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the delay for right channel, in milliseconds, in the EffectsEcho structure.

Definition

Visual Basic .NET | Public Property RightDelay As Single
C# | public float RightDelay { get; set; }
Managed C++ public: __property float get_RightDelay();
public: __property void set_RightDelay(float);
JScript .NET public function get RightDelay() : float
public function set RightDelay(float);

Property Value

System.Single . Delay for right channel, in milliseconds.

This property is read/write.

Remarks

Can range from EchoEffect.RightDelayMin to EchoEffect.RightDelayMax.

The default value is 500 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.WetDryMix

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsEcho.WetDryMix Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal in the EffectsEcho structure.

Definition

Visual Basic .NET | Public Property WetDryMix As Single
C# | public float WetDryMix { get; set; }
Managed C++ public: __property float get_WetDryMix();
public: __property void set_WetDryMix(float);
JScript .NET public function get WetDryMix() : float
public function set WetDryMix(float);

Property Value

System.Single . Ratio of wet (processed) signal to dry (unprocessed) signal.

This property is read/write.

Remarks

Can range from EchoEffect.WetDryMixMin to EchoEffect.WetDryMixMax.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for a flange effect.

Definition

Visual Basic .NET | Public Structure EffectsFlanger
C# | public struct EffectsFlanger
Managed C++ | public __value struct EffectsFlanger
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsFlanger | Initializes a new instance of the EffectsFlanger structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Delay | Retrieves and sets the number of milliseconds the input is delayed before it is played back in the EffectsFlanger structure.
Depth | Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator (LFO), in hundredths of a percentage point in the EffectsFlanger structure.
Feedback | Retrieves and sets the percentage of output signal to feed back into the effect's input in the EffectsFlanger structure.
Frequency | Retrieves and sets the frequency of the LFO in the EffectsFlanger structure.
Phase | Retrieves and sets the phase differential between left and right LFOs in the EffectsFlanger structure.
Waveform | Retrieves and sets the waveform shape of the LFO in the EffectsFlanger structure.
WetDryMix | Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal of the EffectsFlanger structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • FlangerEffect.AllParameters


EffectsFlanger.EffectsFlanger()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.EffectsFlanger Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsFlanger();
Managed C++ | public: EffectsFlanger();
JScript .NET | public function EffectsFlanger();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsFlanger.Delay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.Delay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the number of milliseconds the input is delayed before it is played back in the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Property Delay As Single
C# | public float Delay { get; set; }
Managed C++ public: __property float get_Delay();
public: __property void set_Delay(float);
JScript .NET public function get Delay() : float
public function set Delay(float);

Property Value

System.Single . Number of milliseconds the input is delayed before it is played back.

This property is read/write.

Remarks

Can range from FlangerEffect.DelayMin to FlangerEffect.DelayMax.

The default value is 2ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Depth

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.Depth Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator (LFO), in hundredths of a percentage point in the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Property Depth As Single
C# | public float Depth { get; set; }
Managed C++ public: __property float get_Depth();
public: __property void set_Depth(float);
JScript .NET public function get Depth() : float
public function set Depth(float);

Property Value

System.Single . Percentage by which the delay time is modulated by the low-frequency oscillator (LFO), in hundredths of a percentage point.

This property is read/write.

Remarks

Can range from FlangerEffect.DepthMin to FlangerEffect.DepthMax.

The default value is 100.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Feedback

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.Feedback Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of output signal to feed back into the effect's input in the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Property Feedback As Single
C# | public float Feedback { get; set; }
Managed C++ public: __property float get_Feedback();
public: __property void set_Feedback(float);
JScript .NET public function get Feedback() : float
public function set Feedback(float);

Property Value

System.Single . Percentage of output signal to feed back into the effect's input.

This property is read/write.

Remarks

Can range from FlangerEffect.FeedbackMin to FlangerEffect.FeedbackMax.

The default value is -50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Frequency

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.Frequency Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the frequency of the LFO in the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Property Frequency As Single
C# | public float Frequency { get; set; }
Managed C++ public: __property float get_Frequency();
public: __property void set_Frequency(float);
JScript .NET public function get Frequency() : float
public function set Frequency(float);

Property Value

System.Single . Frequency of the LFO.

This property is read/write.

Remarks

Can range from FlangerEffect.FrequencyMin to FlangerEffect.FrequencyMax.

The default value is 0.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Phase

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.Phase Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the phase differential between left and right LFOs in the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Property Phase As Integer
C# | public int Phase { get; set; }
Managed C++ public: __property int get_Phase();
public: __property void set_Phase(int);
JScript .NET public function get Phase() : int
public function set Phase(int);

Property Value

System.Int32 . Phase differential between left and right LFOs.

This property is read/write.

Remarks

Can be set to on of the following:

  • FlangerEffect.PhaseNeg180
  • FlangerEffect.PhaseNeg90
  • FlangerEffect.PhaseZero
  • FlangerEffect.Phase90
  • FlangerEffect.Phase180

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Waveform

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.Waveform Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the waveform shape of the LFO in the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Property Waveform As Integer
C# | public int Waveform { get; set; }
Managed C++ public: __property int get_Waveform();
public: __property void set_Waveform(int);
JScript .NET public function get Waveform() : int
public function set Waveform(int);

Property Value

System.Int32 . Waveform shape of the LFO.

This property is read/write.

Remarks

Can be set to on of the following:

  • FlangerEffect.WaveSine (default)
  • FlangerEffect.WaveTriangle

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.WetDryMix

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsFlanger.WetDryMix Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal of the EffectsFlanger structure.

Definition

Visual Basic .NET | Public Property WetDryMix As Single
C# | public float WetDryMix { get; set; }
Managed C++ public: __property float get_WetDryMix();
public: __property void set_WetDryMix(float);
JScript .NET public function get WetDryMix() : float
public function set WetDryMix(float);

Property Value

System.Single . Ratio of wet (processed) signal to dry (unprocessed) signal.

This property is read/write.

Remarks

Can range from FlangerEffect.WetDryMixMin to FlangerEffect.WetDryMixMax.

The default value is 50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsGargle

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsGargle Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for an amplitude modulation effect.

Definition

Visual Basic .NET | Public Structure EffectsGargle
C# | public struct EffectsGargle
Managed C++ | public __value struct EffectsGargle
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsGargle | Initializes a new instance of the EffectsGargle structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
RateHz | Retrieves and sets the rate of modulation, in Hertz, of the EffectsGargle structure.
WaveShape | Retrieves and sets the shape of the modulation waveform of the EffectsGargle structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • GargleEffect.AllParameters


EffectsGargle.EffectsGargle()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsGargle.EffectsGargle Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsGargle structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsGargle();
Managed C++ | public: EffectsGargle();
JScript .NET | public function EffectsGargle();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsGargle.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsGargle.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsGargle.RateHz

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsGargle.RateHz Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the rate of modulation, in Hertz, of the EffectsGargle structure.

Definition

Visual Basic .NET | Public Property RateHz As Integer
C# | public int RateHz { get; set; }
Managed C++ public: __property int get_RateHz();
public: __property void set_RateHz(int);
JScript .NET public function get RateHz() : int
public function set RateHz(int);

Property Value

System.Int32 . Rate of modulation, in Hertz.

This property is read/write.

Remarks

Can range from GargleEffect.RateHzMin to GargleEffect.RateHzMax.

The default value is 20.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsGargle.WaveShape

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsGargle.WaveShape Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the shape of the modulation waveform of the EffectsGargle structure.

Definition

Visual Basic .NET | Public Property WaveShape As Integer
C# | public int WaveShape { get; set; }
Managed C++ public: __property int get_WaveShape();
public: __property void set_WaveShape(int);
JScript .NET public function get WaveShape() : int
public function set WaveShape(int);

Property Value

System.Int32 . Shape of the modulation waveform.

This property is read/write.

Remarks

Can be set to one of the following:

  • GargleEffect.WaveTriangle (default)
  • GargleEffect.WaveSquare

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for an I3DL2 (Interactive 3D Audio Level 2) reverberation effect.

Definition

Visual Basic .NET | Public Structure EffectsInteractive3DLevel2Reverb
C# | public struct EffectsInteractive3DLevel2Reverb
Managed C++ | public __value struct EffectsInteractive3DLevel2Reverb
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsInteractive3DLevel2Reverb | Initializes a new instance of the EffectsInteractive3DLevel2Reverb structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DecayHfRatio | Retrieves and sets the ratio of the decay time at high frequencies to the decay time at low frequencies, of the EffectsInteractive3DLevel2Reverb structure.
DecayTime | Retrieves and sets the decay time, in seconds, of the EffectsInteractive3DLevel2Reverb structure.
Density | Retrieves and sets the modal density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.
Diffusion | Retrieves and sets the echo density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.
HfReference | Retrieves and sets the reference high frequency, in hertz, of the EffectsInteractive3DLevel2Reverb structure.
Reflections | Retrieves and sets the attenuation of early reflections relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.
ReflectionsDelay | Retrieves and sets the delay time of the first reflection relative to the direct path, in seconds, of the EffectsInteractive3DLevel2Reverb structure.
Reverb | Retrieves and sets the attenuation of late reverberation relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.
ReverbDelay | Retrieves and sets the time limit between the early reflections and the late reverberation relative to the time of the first reflection, in seconds, of the EffectsInteractive3DLevel2Reverb structure.
Room | Retrieves and sets the attenuation of the room effect, in millibels (mB), of the EffectsInteractive3DLevel2Reverb structure.
RoomHf | Retrieves and sets the attenuation of the room high-frequency effect, in mB, of the EffectsInteractive3DLevel2Reverb structure.
RoomRolloffFactor | Retrieves and sets the rolloff factor for the reflected signals of the EffectsInteractive3DLevel2Reverb structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • Interactive3DLevel2ReverbEffect.AllParameters


EffectsInteractive3DLevel2Reverb.EffectsInteractive3DLevel2Reverb()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.EffectsInteractive3DLevel2Reverb Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsInteractive3DLevel2Reverb();
Managed C++ | public: EffectsInteractive3DLevel2Reverb();
JScript .NET | public function EffectsInteractive3DLevel2Reverb();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsInteractive3DLevel2Reverb.DecayHfRatio

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.DecayHfRatio Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of the decay time at high frequencies to the decay time at low frequencies, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property DecayHfRatio As Single
C# | public float DecayHfRatio { get; set; }
Managed C++ public: __property float get_DecayHfRatio();
public: __property void set_DecayHfRatio(float);
JScript .NET public function get DecayHfRatio() : float
public function set DecayHfRatio(float);

Property Value

System.Single . Ratio of the decay time at high frequencies to the decay time at low frequencies.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DecayHfRatioMin to Interactive3DLevel2ReverbEffect.DecayHfRatioMax.

The default value is Interactive3DLevel2ReverbEffect.DecayHfRatioDefault or 0.83.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.DecayTime

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.DecayTime Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the decay time, in seconds, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property DecayTime As Single
C# | public float DecayTime { get; set; }
Managed C++ public: __property float get_DecayTime();
public: __property void set_DecayTime(float);
JScript .NET public function get DecayTime() : float
public function set DecayTime(float);

Property Value

System.Single . Decay time, in seconds.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DecayTimeMin to Interactive3DLevel2ReverbEffect.DecayTimeMax.

The default value is Interactive3DLevel2ReverbEffect.DecayTimeDefault or 1.49 seconds.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Density

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.Density Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the modal density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property Density As Single
C# | public float Density { get; set; }
Managed C++ public: __property float get_Density();
public: __property void set_Density(float);
JScript .NET public function get Density() : float
public function set Density(float);

Property Value

System.Single . Modal density in the late reverberation decay, in percent

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DensityMin to Interactive3DLevel2ReverbEffect.DensityMax.

The default value is Interactive3DLevel2ReverbEffect.DensityDefault or 100 percent.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Diffusion

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.Diffusion Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the echo density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property Diffusion As Single
C# | public float Diffusion { get; set; }
Managed C++ public: __property float get_Diffusion();
public: __property void set_Diffusion(float);
JScript .NET public function get Diffusion() : float
public function set Diffusion(float);

Property Value

System.Single . Echo density in the late reverberation decay, in percent.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DiffusionyMin to Interactive3DLevel2ReverbEffect.DiffusionMax.

The default value is Interactive3DLevel2ReverbEffect.DiffusionDefault or 100 percent.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.HfReference

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.HfReference Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the reference high frequency, in hertz, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property HfReference As Single
C# | public float HfReference { get; set; }
Managed C++ public: __property float get_HfReference();
public: __property void set_HfReference(float);
JScript .NET public function get HfReference() : float
public function set HfReference(float);

Property Value

System.Single . Reference high frequency, in hertz.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.HfReferenceyMin to Interactive3DLevel2ReverbEffect.HfReferenceMax.

The default value is Interactive3DLevel2ReverbEffect.HfReferenceDefault or 5000.0 Hz.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Reflections

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.Reflections Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of early reflections relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property Reflections As Integer
C# | public int Reflections { get; set; }
Managed C++ public: __property int get_Reflections();
public: __property void set_Reflections(int);
JScript .NET public function get Reflections() : int
public function set Reflections(int);

Property Value

System.Int32 . Attenuation of early reflections relative to Room, in mB.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReflectionsMin to Interactive3DLevel2ReverbEffect.ReflectionsMax.

The default value is Interactive3DLevel2ReverbEffect.ReflectionsDefault or -2602 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.ReflectionsDelay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.ReflectionsDelay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the delay time of the first reflection relative to the direct path, in seconds, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property ReflectionsDelay As Single
C# | public float ReflectionsDelay { get; set; }
Managed C++ public: __property float get_ReflectionsDelay();
public: __property void set_ReflectionsDelay(float);
JScript .NET public function get ReflectionsDelay() : float
public function set ReflectionsDelay(float);

Property Value

System.Single . Delay time of the first reflection relative to the direct path, in seconds.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReflectionsDelayMin to Interactive3DLevel2ReverbEffect.ReflectionsDelayMax.

The default value is Interactive3DLevel2ReverbEffect.ReflectionsDelayDefault or 0.007 seconds.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Reverb

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.Reverb Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of late reverberation relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property Reverb As Integer
C# | public int Reverb { get; set; }
Managed C++ public: __property int get_Reverb();
public: __property void set_Reverb(int);
JScript .NET public function get Reverb() : int
public function set Reverb(int);

Property Value

System.Int32 . Attenuation of late reverberation relative to Room, in mB.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReverbMin to Interactive3DLevel2ReverbEffect.ReverbMax.

The default value is Interactive3DLevel2ReverbEffect.ReverbDefault or -200 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.ReverbDelay

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.ReverbDelay Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the time limit between the early reflections and the late reverberation relative to the time of the first reflection, in seconds, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property ReverbDelay As Single
C# | public float ReverbDelay { get; set; }
Managed C++ public: __property float get_ReverbDelay();
public: __property void set_ReverbDelay(float);
JScript .NET public function get ReverbDelay() : float
public function set ReverbDelay(float);

Property Value

System.Single . Time limit between the early reflections and the late reverberation relative to the time of the first reflection, in seconds.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReverbDelayMin to Interactive3DLevel2ReverbEffect.ReverbDelayMax.

The default value is Interactive3DLevel2ReverbEffect.ReverbDelayDefault or 0.011 seconds.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Room

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.Room Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of the room effect, in millibels (mB), of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property Room As Integer
C# | public int Room { get; set; }
Managed C++ public: __property int get_Room();
public: __property void set_Room(int);
JScript .NET public function get Room() : int
public function set Room(int);

Property Value

System.Int32 . Attenuation of the room effect, in millibels (mB).

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.RoomMin to Interactive3DLevel2ReverbEffect.RoomMax.

The default value is Interactive3DLevel2ReverbEffect.RoomDefault or -1000 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.RoomHf

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.RoomHf Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of the room high-frequency effect, in mB, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property RoomHf As Integer
C# | public int RoomHf { get; set; }
Managed C++ public: __property int get_RoomHf();
public: __property void set_RoomHf(int);
JScript .NET public function get RoomHf() : int
public function set RoomHf(int);

Property Value

System.Int32 . Attenuation of the room high-frequency effect, in mB.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.RoomHfMin to Interactive3DLevel2ReverbEffect.RoomHfMax.

The default value is Interactive3DLevel2ReverbEffect.RoomHfDefault or -100 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.RoomRolloffFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsInteractive3DLevel2Reverb.RoomRolloffFactor Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the rolloff factor for the reflected signals of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic .NET | Public Property RoomRolloffFactor As Single
C# | public float RoomRolloffFactor { get; set; }
Managed C++ public: __property float get_RoomRolloffFactor();
public: __property void set_RoomRolloffFactor(float);
JScript .NET public function get RoomRolloffFactor() : float
public function set RoomRolloffFactor(float);

Property Value

System.Single .

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.RoomRolloffFactorMin to Interactive3DLevel2ReverbEffect.RoomRolloffFactorMax.

The default value is Interactive3DLevel2ReverbEffect.RoomRolloffFactorDefault or 0.0.

The rolloff factor for the direct path is controlled by the DirectSound listener.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsParamEq Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for a parametric equalizer effect.

Definition

Visual Basic .NET | Public Structure EffectsParamEq
C# | public struct EffectsParamEq
Managed C++ | public __value struct EffectsParamEq
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsParamEq | Initializes a new instance of the EffectsParamEq structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Bandwidth | Retrieves and sets the bandwidth, in semitones, of the EffectsParamEq structure.
Center | Retrieves and sets the center frequency, in hertz, of the EffectsParamEq structure.
Gain | Retrieves and sets the gain, of the EffectsParamEq structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • ParamEqEffect.AllParameters


EffectsParamEq.EffectsParamEq()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsParamEq.EffectsParamEq Constructor

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsParamEq structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsParamEq();
Managed C++ | public: EffectsParamEq();
JScript .NET | public function EffectsParamEq();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsParamEq.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


EffectsParamEq.Bandwidth

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsParamEq.Bandwidth Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the bandwidth, in semitones, of the EffectsParamEq structure.

Definition

Visual Basic .NET | Public Property Bandwidth As Single
C# | public float Bandwidth { get; set; }
Managed C++ public: __property float get_Bandwidth();
public: __property void set_Bandwidth(float);
JScript .NET public function get Bandwidth() : float
public function set Bandwidth(float);

Property Value

System.Single . Bandwidth, in semitones.

This property is read/write.

Remarks

Can range from ParamEqEffect.BandwidthMin to ParamEqEffect.BandwidthMax.

The default value is 12.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq.Center

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsParamEq.Center Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the center frequency, in hertz, of the EffectsParamEq structure.

Definition

Visual Basic .NET | Public Property Center As Single
C# | public float Center { get; set; }
Managed C++ public: __property float get_Center();
public: __property void set_Center(float);
JScript .NET public function get Center() : float
public function set Center(float);

Property Value

System.Single . Center frequency, in hertz.

This property is read/write.

Remarks

Can range from ParamEqEffect.CenterMin to ParamEqEffect.CenterMax.

The default value is 8000.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq.Gain

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsParamEq.Gain Property

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the gain, of the EffectsParamEq structure.

Definition

Visual Basic .NET | Public Property Gain As Single
C# | public float Gain { get; set; }
Managed C++ public: __property float get_Gain();
public: __property void set_Gain(float);
JScript .NET public function get Gain() : float
public function set Gain(float);

Property Value

System.Single . Gain.

This property is read/write.

Remarks

Can range from ParamEqEffect.GainMin to ParamEqEffect.GainMax.

The default value is 0.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsWavesReverb

Microsoft DirectX 9.0 SDK Update (October 2004)

EffectsWavesReverb Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Contains parameters for a Waves reverberation effect.

Definition

Visual Basic .NET | Public Structure EffectsWavesReverb
C# | public struct EffectsWavesReverb
Managed C++ | public __value struct EffectsWavesReverb
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsWavesReverb | Initializes a new instance of the EffectsWavesReverb structure.
ToString | Retrieves a string representation of the current instance.

Properties

Property | Description
HighFrequencyRtRatio | Retrieves and sets the high-frequency reverb time ratio of the EffectsWavesReverb structure.
InGain | Retrieves and sets the input gain of signal, in decibels (dB), of the EffectsWavesReverb structure.
ReverbMix | Retrieves and sets the reverb mix, in decibels (dB), of the EffectsWavesReverb structure.
ReverbTime | Retrieves and sets the reverb time, in milliseconds, of the EffectsWavesReverb structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • WavesReverbEffect.AllParameters


EffectsWavesReverb.EffectsWavesReverb()

EffectsWavesReverb.EffectsWavesReverb Constructor

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsWavesReverb structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public EffectsWavesReverb();
Managed C++ | public: EffectsWavesReverb();
JScript .NET | public function EffectsWavesReverb();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.ToString()

EffectsWavesReverb.ToString Method

Note: This documentation is preliminary and is subject to change.

Retrieves a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.HighFrequencyRtRatio

EffectsWavesReverb.HighFrequencyRtRatio Property

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the high-frequency reverb time ratio of the EffectsWavesReverb structure.

Definition

Visual Basic .NET | Public Property HighFrequencyRtRatio As Single
C# | public float HighFrequencyRtRatio { get; set; }
Managed C++ public: __property float get_HighFrequencyRtRatio();
public: __property void set_HighFrequencyRtRatio(float);
JScript .NET public function get HighFrequencyRtRatio() : float
public function set HighFrequencyRtRatio(float);

Property Value

System.Single . High-frequency reverb time ratio.

This property is read/write.

Remarks

Can range from WavesReverbEffect.HighFrequencyRtRationMin to WavesReverbEffect.HighFrequencyRtRationMax.

The default value is 0.001 or WavesReverbEffect.HighFrequencyRtRationDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.InGain

EffectsWavesReverb.InGain Property

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the input gain of signal, in decibels (dB), of the EffectsWavesReverb structure.

Definition

Visual Basic .NET | Public Property InGain As Single
C# | public float InGain { get; set; }
Managed C++ public: __property float get_InGain();
public: __property void set_InGain(float);
JScript .NET public function get InGain() : float
public function set InGain(float);

Property Value

System.Single . Input gain of signal, in decibels (dB).

This property is read/write.

Remarks

Can range from WavesReverbEffect.InGainMin to WavesReverbEffect.InGainMax.

The default value is 0 db or WavesReverbEffect.InGainDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.ReverbMix

EffectsWavesReverb.ReverbMix Property

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the reverb mix, in decibels (dB), of the EffectsWavesReverb structure.

Definition

Visual Basic .NET | Public Property ReverbMix As Single
C# | public float ReverbMix { get; set; }
Managed C++ public: __property float get_ReverbMix();
public: __property void set_ReverbMix(float);
JScript .NET public function get ReverbMix() : float
public function set ReverbMix(float);

Property Value

System.Single . Reverb mix, in decibels (dB).

This property is read/write.

Remarks

Can range from WavesReverbEffect.ReverbMixMin to WavesReverbEffect.ReverbMixMax.

The default value is 0 db or WavesReverbEffect.ReverbMixDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.ReverbTime

EffectsWavesReverb.ReverbTime Property

Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Use Effect Parameters

Retrieves and sets the reverb time, in milliseconds, of the EffectsWavesReverb structure.

Definition

Visual Basic .NET | Public Property ReverbTime As Single
C# | public float ReverbTime { get; set; }
Managed C++ public: __property float get_ReverbTime();
public: __property void set_ReverbTime(float);
JScript .NET public function get ReverbTime() : float
public function set ReverbTime(float);

Property Value

System.Single . Reverb time, in milliseconds.

This property is read/write.

Remarks

Can range from WavesReverbEffect.ReverbTimeMin to WavesReverbEffect.ReverbTimeMax.

The default value is 1000 ms or WavesReverbEffect.ReverbTimeDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Listener3DOrientation

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DOrientation Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that encompass the front and top 3-D vectors for listeners orientation.

Definition

Visual Basic .NET | Public Structure Listener3DOrientation
C# | public struct Listener3DOrientation
Managed C++ | public __value struct Listener3DOrientation
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Listener3DOrientation | Initializes a new instance of the Listener3DOrientation structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Front | Retrieves and sets the front of the listener's orientation.
Top | Retrieves and sets the top of the listener's orientation.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Listener3D.Orientation


Listener3DOrientation.Listener3DOrientation

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DOrientation.Listener3DOrientation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Listener3DOrientation structure.

Overload List

public Listener3DOrientation();
public Listener3DOrientation(Vector3, Vector3);


Listener3DOrientation.Listener3DOrientation(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DOrientation.Listener3DOrientation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Listener3DOrientation structure.

Definition

Visual Basic .NET Public Sub New( _
ByVal front As Vector3, _
ByVal top As Vector3 _
)
C# public Listener3DOrientation(
Vector3 front,
Vector3 top
);
Managed C++ public: Listener3DOrientation(
Vector3 front,
Vector3 top
);
JScript .NET public function Listener3DOrientation(
front : Vector3,
top : Vector3
);

Parameters

front | Microsoft.DirectX.Vector3.
top | Microsoft.DirectX.Vector3.


Listener3DOrientation.Listener3DOrientation()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DOrientation.Listener3DOrientation Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Listener3DOrientation structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Listener3DOrientation();
Managed C++ | public: Listener3DOrientation();
JScript .NET | public function Listener3DOrientation();


Listener3DOrientation.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DOrientation.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Listener3DOrientation.Front

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DOrientation.Front Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the front of the listener's orientation.

Definition

Visual Basic .NET | Public Property Front As Vector3
C# | public Vector3 Front { get; set; }
Managed C++ public: __property Vector3 get_Front();
public: __property void set_Front(Vector3);
JScript .NET public function get Front() : Vector3
public function set Front(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The front of the listener's orientation.

This property is read/write.


Listener3DOrientation.Top

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DOrientation.Top Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the top of the listener's orientation.

Definition

Visual Basic .NET | Public Property Top As Vector3
C# | public Vector3 Top { get; set; }
Managed C++ public: __property Vector3 get_Top();
public: __property void set_Top(Vector3);
JScript .NET public function get Top() : Vector3
public function set Top(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The top of the listener's orientation.

This property is read/write.


Listener3DSettings

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that describes the 3-D world parameters and the position of the listener.

Definition

Visual Basic .NET | Public Structure Listener3DSettings
C# | public struct Listener3DSettings
Managed C++ | public __value struct Listener3DSettings
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Listener3DSettings | Initializes a new instance of the Listener3DSettings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DistanceFactor | Retrieves and sets the number of meters in a vector unit.
DopplerFactor | Retrieves and sets the ratio of Doppler effect to that in the real world.
OrientFront | Retrieves and sets the listener's front orientation.
OrientTop | Retrieves and sets the listener's top orientation.
Position | Retrieves and sets the listener's position.
RolloffFactor | Retrieves and sets the ratio of attenuation over distance to that in the real world.
Velocity | Retrieves and sets the listener's velocity.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Listener3D.AllParameters


Listener3DSettings.Listener3DSettings()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.Listener3DSettings Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Listener3DSettings structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Listener3DSettings();
Managed C++ | public: Listener3DSettings();
JScript .NET | public function Listener3DSettings();


Listener3DSettings.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Listener3DSettings.DistanceFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.DistanceFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the number of meters in a vector unit.

Definition

Visual Basic .NET | Public Property DistanceFactor As Single
C# | public float DistanceFactor { get; set; }
Managed C++ public: __property float get_DistanceFactor();
public: __property void set_DistanceFactor(float);
JScript .NET public function get DistanceFactor() : float
public function set DistanceFactor(float);

Property Value

System.Single . The number of meters in a vector unit.

This property is read/write.

Remarks

Can range from Listener3D.DistanceFactorMin to Listener3D.DistanceFactorMax.

The default value is 1 meter or Listener3D.DistanceFactorDefault.


Listener3DSettings.DopplerFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.DopplerFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the ratio of Doppler effect to that in the real world.

Definition

Visual Basic .NET | Public Property DopplerFactor As Single
C# | public float DopplerFactor { get; set; }
Managed C++ public: __property float get_DopplerFactor();
public: __property void set_DopplerFactor(float);
JScript .NET public function get DopplerFactor() : float
public function set DopplerFactor(float);

Property Value

System.Single . The ratio of Doppler effect to that in the real world.

This property is read/write.

Remarks

This property has a range of 0.0 (no Doppler effects) to 10.0 (10 times the Doppler effects found in the real world). The default value is 1.0.


Listener3DSettings.OrientFront

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.OrientFront Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the listener's front orientation.

Definition

Visual Basic .NET | Public Property OrientFront As Vector3
C# | public Vector3 OrientFront { get; set; }
Managed C++ public: __property Vector3 get_OrientFront();
public: __property void set_OrientFront(Vector3);
JScript .NET public function get OrientFront() : Vector3
public function set OrientFront(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The listener's front orientation.

This property is read/write.


Listener3DSettings.OrientTop

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.OrientTop Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the listener's top orientation.

Definition

Visual Basic .NET | Public Property OrientTop As Vector3
C# | public Vector3 OrientTop { get; set; }
Managed C++ public: __property Vector3 get_OrientTop();
public: __property void set_OrientTop(Vector3);
JScript .NET public function get OrientTop() : Vector3
public function set OrientTop(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The listener's top orientation.

This property is read/write.


Listener3DSettings.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the listener's position.

Definition

Visual Basic .NET | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
Managed C++ public: __property Vector3 get_Position();
public: __property void set_Position(Vector3);
JScript .NET public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The listener's position.

This property is read/write.

Remarks

By default, measurement units are meters, but this can be changed by changing the Listener3DSettings.DistanceFactor property.


Listener3DSettings.RolloffFactor

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.RolloffFactor Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the ratio of attenuation over distance to that in the real world.

Definition

Visual Basic .NET | Public Property RolloffFactor As Single
C# | public float RolloffFactor { get; set; }
Managed C++ public: __property float get_RolloffFactor();
public: __property void set_RolloffFactor(float);
JScript .NET public function get RolloffFactor() : float
public function set RolloffFactor(float);

Property Value

System.Single . The ratio of attenuation over distance to that in the real world.

This property is read/write.

Remarks

This property has a range of 0.0 (no rolloff) to 10.0 (10 times the rolloff found in the real world). The default value is 1.0.

Rolloff factor is global. To change the effect of distance for an individual sound buffer, you can set the minimum distance for the buffer.


Listener3DSettings.Velocity

Microsoft DirectX 9.0 SDK Update (October 2004)

Listener3DSettings.Velocity Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the listener's velocity.

Definition

Visual Basic .NET | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
Managed C++ public: __property Vector3 get_Velocity();
public: __property void set_Velocity(Vector3);
JScript .NET public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3 . The listener's velocity.

This property is read/write.

Remarks

Velocity is used only for Doppler effects. It does not actually move the listener. To change the listener's position, use the Listener3DSettings.Position property. The default velocity is (0,0,0).

By default, measurement units are meters per second, but this can be changed by changing the Listener3DSettings.DistanceFactor property.


Speakers

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that define various speaker configurations.

Definition

Visual Basic .NET | Public Structure Speakers
C# | public struct Speakers
Managed C++ | public __value struct Speakers
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Speakers | Initializes a new instance of the Speakers structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
FivePointOne | Retrieves and sets whether the audio will be played through a speaker arrangement of five surround speakers with a subwoofer.
GeometryMax | Retrieves and sets whether the speakers are directed over an arc of 180 degrees.
GeometryMin | Retrieves and sets whether the speakers are directed over an arc of 5 degrees.
GeometryNarrow | Retrieves and sets whether the speakers are directed over an arc of 10 degrees.
GeometryWide | Retrieves and sets whether the speakers are directed over an arc of 20 degrees.
Headphone | Retrieves and sets whether the audio will be played through headphones.
Mono | Retrieves and sets whether the audio will be played through a monaural speaker type.
Quad | Retrieves and sets whether the audio will be played through a quadraphonic speaker type.
SevenPointOne | Retrieves and sets whether the audio will be played through a speaker arrangement of seven surround speakers with a subwoofer.
Stereo | Retrieves and sets whether the audio will be played through a stereo speaker type.
Surround | Retrieves and sets whether the audio will be played through a surround sound speaker type.

Remarks

A Speakers object should have one of the following speaker type properties set to true:

  • FivePointOne
  • Headphone
  • Mono
  • Quad
  • SevenPointOne
  • Stereo
  • Surround

A Speakers object, in combination with the speaker type mention above, should have one of the following geometry type properties set to true:

  • GeometryMax
  • GeometryMin
  • GeometryNarrow
  • GeometryWide

This structure is used to control a global Windows setting that affect all users and applications on the system. It is provided only for use by configuration utilities provided by audio device vendors. No other applications should call it.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Device.SpeakerConfig


Speakers.Speakers()

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.Speakers Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Speakers structure.

Definition

Visual Basic .NET | Public Sub New()
C# | public Speakers();
Managed C++ | public: Speakers();
JScript .NET | public function Speakers();


Speakers.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Speakers.FivePointOne

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.FivePointOne Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the audio will be played through a speaker arrangement of five surround speakers with a subwoofer.

Definition

Visual Basic .NET | Public Property FivePointOne As Boolean
C# | public bool FivePointOne { get; set; }
Managed C++ public: __property bool get_FivePointOne();
public: __property void set_FivePointOne(bool);
JScript .NET public function get FivePointOne() : boolean
public function set FivePointOne(boolean);

Property Value

System.Boolean . A value set to true if the audio will be played through a speaker arrangement of five surround speakers with a subwoofer; otherwise, false.

This property is read/write.


Speakers.GeometryMax

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.GeometryMax Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the speakers are directed over an arc of 180 degrees.

Definition

Visual Basic .NET | Public Property GeometryMax As Boolean
C# | public bool GeometryMax { get; set; }
Managed C++ public: __property bool get_GeometryMax();
public: __property void set_GeometryMax(bool);
JScript .NET public function get GeometryMax() : boolean
public function set GeometryMax(boolean);

Property Value

System.Boolean . A value set to true if the speakers are directed over an arc of 180 degrees; otherwise, false.

This property is read/write.


Speakers.GeometryMin

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.GeometryMin Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the speakers are directed over an arc of 5 degrees.

Definition

Visual Basic .NET | Public Property GeometryMin As Boolean
C# | public bool GeometryMin { get; set; }
Managed C++ public: __property bool get_GeometryMin();
public: __property void set_GeometryMin(bool);
JScript .NET public function get GeometryMin() : boolean
public function set GeometryMin(boolean);

Property Value

System.Boolean . A value set to true if the speakers are directed over an arc of 5 degrees; otherwise, false.

This property is read/write.


Speakers.GeometryNarrow

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.GeometryNarrow Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the speakers are directed over an arc of 10 degrees.

Definition

Visual Basic .NET | Public Property GeometryNarrow As Boolean
C# | public bool GeometryNarrow { get; set; }
Managed C++ public: __property bool get_GeometryNarrow();
public: __property void set_GeometryNarrow(bool);
JScript .NET public function get GeometryNarrow() : boolean
public function set GeometryNarrow(boolean);

Property Value

System.Boolean . A value set to true if the speakers are directed over an arc of 10 degrees; otherwise, false.

This property is read/write.


Speakers.GeometryWide

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.GeometryWide Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the speakers are directed over an arc of 20 degrees.

Definition

Visual Basic .NET | Public Property GeometryWide As Boolean
C# | public bool GeometryWide { get; set; }
Managed C++ public: __property bool get_GeometryWide();
public: __property void set_GeometryWide(bool);
JScript .NET public function get GeometryWide() : boolean
public function set GeometryWide(boolean);

Property Value

System.Boolean . A value set to true if the speakers are directed over an arc of 20 degrees; otherwise, false.

This property is read/write.


Speakers.Headphone

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.Headphone Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the audio will be played through headphones.

Definition

Visual Basic .NET | Public Property Headphone As Boolean
C# | public bool Headphone { get; set; }
Managed C++ public: __property bool get_Headphone();
public: __property void set_Headphone(bool);
JScript .NET public function get Headphone() : boolean
public function set Headphone(boolean);

Property Value

System.Boolean . A value set to true if the audio will be played through headphones; otherwise, false.

This property is read/write.


Speakers.Mono

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.Mono Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the audio will be played through a monaural speaker type.

Definition

Visual Basic .NET | Public Property Mono As Boolean
C# | public bool Mono { get; set; }
Managed C++ public: __property bool get_Mono();
public: __property void set_Mono(bool);
JScript .NET public function get Mono() : boolean
public function set Mono(boolean);

Property Value

System.Boolean . A value set to true if the audio will be played through a monaural speaker type; otherwise, false.

This property is read/write.


Speakers.Quad

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.Quad Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the audio will be played through a quadraphonic speaker type.

Definition

Visual Basic .NET | Public Property Quad As Boolean
C# | public bool Quad { get; set; }
Managed C++ public: __property bool get_Quad();
public: __property void set_Quad(bool);
JScript .NET public function get Quad() : boolean
public function set Quad(boolean);

Property Value

System.Boolean . A value set to true if the audio will be played through a quadraphonic speaker type; otherwise, false.

This property is read/write.


Speakers.SevenPointOne

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.SevenPointOne Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the audio will be played through a speaker arrangement of seven surround speakers with a subwoofer.

Definition

Visual Basic .NET | Public Property SevenPointOne As Boolean
C# | public bool SevenPointOne { get; set; }
Managed C++ public: __property bool get_SevenPointOne();
public: __property void set_SevenPointOne(bool);
JScript .NET public function get SevenPointOne() : boolean
public function set SevenPointOne(boolean);

Property Value

System.Boolean . A value set to true if the audio will be played through a speaker arrangement of seven surround speakers with a subwoofer; otherwise, false.

This property is read/write.


Speakers.Stereo

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.Stereo Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the audio will be played through a stereo speaker type.

Definition

Visual Basic .NET | Public Property Stereo As Boolean
C# | public bool Stereo { get; set; }
Managed C++ public: __property bool get_Stereo();
public: __property void set_Stereo(bool);
JScript .NET public function get Stereo() : boolean
public function set Stereo(boolean);

Property Value

System.Boolean . A value set to true if the audio will be played through a stereo speaker type; otherwise, false.

This property is read/write.


Speakers.Surround

Microsoft DirectX 9.0 SDK Update (October 2004)

Speakers.Surround Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets whether the audio will be played through a surround sound speaker type.

Definition

Visual Basic .NET | Public Property Surround As Boolean
C# | public bool Surround { get; set; }
Managed C++ public: __property bool get_Surround();
public: __property void set_Surround(bool);
JScript .NET public function get Surround() : boolean
public function set Surround(boolean);

Property Value

System.Boolean . A value set to true if the audio will be played through a surround sound speaker type; otherwise, false.

This property is read/write.


WaveFormat

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Contains properties that define the format of waveform-audio data.

Definition

Visual Basic .NET | Public Structure WaveFormat
C# | public struct WaveFormat
Managed C++ | public __value struct WaveFormat
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
WaveFormat | Initializes a new instance of the WaveFormat sturcture.

Properties

Property | Description
AverageBytesPerSecond | Retrieves and sets the required average data-transfer rate, in bytes per second, for the format type.
BitsPerSample | Retrieves and sets the bits per sample for the format type.
BlockAlign | Retrieves and sets the minimum atomic unit of data, in bytes, for the format type.
Channels | Retrieves and sets the number of channels in the waveform-audio data, for the format type.
FormatTag | Retrieves and sets the waveform-audio format type, for the format type.
SamplesPerSecond | Retrieves and sets the sample rate, in samples per second (hertz), for the format type.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Buffer.Format
  • BufferDescription constructor
  • CaptureBuffer.Format
  • CaptureBufferDescription.Format


WaveFormat.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


WaveFormat.WaveFormat()

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.WaveFormat Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the WaveFormat sturcture.

Definition

Visual Basic .NET | Public Sub New()
C# | public WaveFormat();
Managed C++ | public: WaveFormat();
JScript .NET | public function WaveFormat();


WaveFormat.AverageBytesPerSecond

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.AverageBytesPerSecond Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the required average data-transfer rate, in bytes per second, for the format type.

Definition

Visual Basic .NET | Public Property AverageBytesPerSecond As Integer
C# | public int AverageBytesPerSecond { get; set; }
Managed C++ public: __property int get_AverageBytesPerSecond();
public: __property void set_AverageBytesPerSecond(int);
JScript .NET public function get AverageBytesPerSecond() : int
public function set AverageBytesPerSecond(int);

Property Value

System.Int32 . The required average data-transfer rate, in bytes per second, for the format type.

This property is read/write.

Remarks

Because Microsoft® DirectX® 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm, the AverageBytesPerSecond property should be a product of BlockAlign and SamplesPerSecond


WaveFormat.BitsPerSample

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.BitsPerSample Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the bits per sample for the format type.

Definition

Visual Basic .NET | Public Property BitsPerSample As Short
C# | public short BitsPerSample { get; set; }
Managed C++ public: __property short get_BitsPerSample();
public: __property void set_BitsPerSample(short);
JScript .NET public function get BitsPerSample() : short
public function set BitsPerSample(short);

Property Value

System.Int16 . Bits per sample for the format type.

This property is read/write.

Remarks

Because Microsoft® DirectX® 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm, the value of the BitsPerSample property should be equal to 8 or 16.


WaveFormat.BlockAlign

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.BlockAlign Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the minimum atomic unit of data, in bytes, for the format type.

Definition

Visual Basic .NET | Public Property BlockAlign As Short
C# | public short BlockAlign { get; set; }
Managed C++ public: __property short get_BlockAlign();
public: __property void set_BlockAlign(short);
JScript .NET public function get BlockAlign() : short
public function set BlockAlign(short);

Property Value

System.Int16 . The minimum atomic unit of data, in bytes, for the format type.

This property is read/write.

Remarks

The value of the BlockAlign property must be equal to the product of Channels and BitsPerSample divided by 8 (bits per byte).

Software must process a multiple of BlockAlign bytes of data at a time. Data written to and read from a device must always start at the beginning of a block. For example, it is illegal to start playback of Pulse Code Modulation (PCM) data in the middle of a sample (that is, on a non-block-aligned boundary).


WaveFormat.Channels

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.Channels Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the number of channels in the waveform-audio data, for the format type.

Definition

Visual Basic .NET | Public Property Channels As Short
C# | public short Channels { get; set; }
Managed C++ public: __property short get_Channels();
public: __property void set_Channels(short);
JScript .NET public function get Channels() : short
public function set Channels(short);

Property Value

System.Int16 . The number of channels in the waveform-audio data, for the format type.

This property is read/write.

Remarks

Monaural data uses one channel and stereo data uses two channels.


WaveFormat.FormatTag

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.FormatTag Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the waveform-audio format type, for the format type.

Definition

Visual Basic .NET | Public Property FormatTag As WaveFormatTag
C# | public WaveFormatTag FormatTag { get; set; }
Managed C++ public: __property WaveFormatTag get_FormatTag();
public: __property void set_FormatTag(WaveFormatTag);
JScript .NET public function get FormatTag() : WaveFormatTag
public function set FormatTag(WaveFormatTag);

Property Value

Microsoft.DirectX.DirectSound.WaveFormatTag . The waveform-audio format type, for the format type.

This property is read/write.

Remarks

Microsoft® DirectX® 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm.


WaveFormat.SamplesPerSecond

Microsoft DirectX 9.0 SDK Update (October 2004)

WaveFormat.SamplesPerSecond Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves and sets the sample rate, in samples per second (hertz), for the format type.

Definition

Visual Basic .NET | Public Property SamplesPerSecond As Integer
C# | public int SamplesPerSecond { get; set; }
Managed C++ public: __property int get_SamplesPerSecond();
public: __property void set_SamplesPerSecond(int);
JScript .NET public function get SamplesPerSecond() : int
public function set SamplesPerSecond(int);

Property Value

System.Int32 . The sample rate, in samples per second (hertz), for the format type.

This property is read/write.

Remarks

Because Microsoft® DirectX® 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm, the SamplesPerSecond property should be a common value such as 8.0 kHz, 11.025 kHz, 22.05 kHz, or 44.1 kHz.


Microsoft.DirectX.PrivateImplementationDetails

Note: This documentation is preliminary and is subject to change.

The PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® API. These structures and interfaces are not intended to be used directly from your code.

Structures

_BUFFERDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DADAPTER_IDENTIFIER9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DBOX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DCAPS9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DCLIPSTATUS9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DCOLORVALUE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DDEVICE_CREATION_PARAMETERS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DDEVINFO_RESOURCEMANAGER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DDISPLAYMODE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DGAMMARAMP | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DINDEXBUFFER_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DLIGHT9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DLOCKED_BOX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DLOCKED_RECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DMATERIAL9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DMATRIX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DPRESENT_PARAMETERS_ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DPSHADERCAPS2_0 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DRASTER_STATUS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DRECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DRECTPATCH_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DSURFACE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DTRIPATCH_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVECTOR | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVERTEXBUFFER_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVERTEXELEMENT9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVIEWPORT9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVOLUME_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVSHADERCAPS2_0 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXATTRIBUTERANGE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXATTRIBUTEWEIGHTS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXBONECOMBINATION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXCONSTANT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXCONSTANTTABLE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEFFECT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEFFECTDEFAULT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEFFECTINSTANCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEVENT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXF_FILELOADMEMORY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFONT_DESCA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFONT_DESCW | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFRAGMENT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFRAME | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFUNCTION_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXIMAGE_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXKEY_CALLBACK | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXKEY_QUATERNION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXKEY_VECTOR3 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMACRO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMATERIAL | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMATRIXA16 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMESHCONTAINER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMESHDATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXPARAMETER_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXPASS_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXPATCHINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXRTE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXRTS_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXSEMANTIC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXSHMATERIAL | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXTECHNIQUE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXTRACK_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXWELDEPSILONS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDBLTFX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDCAPS_DX7 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDCOLORCONTROL | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDCOLORKEY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDGAMMARAMP | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDOVERLAYFX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDPIXELFORMAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDSCAPS2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDSURFACEDESC2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DEV_BROADCAST_DEVICEINTERFACE_A | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DEV_BROADCAST_HDR | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIACTIONA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIACTIONFORMATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DICOLORSET | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DICONFIGUREDEVICESPARAMSA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIDATAFORMAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIDEVICEIMAGEINFOA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIDEVICEIMAGEINFOHEADERA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIMOUSESTATE2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIOBJECTDATAFORMAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_APPLICATION_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_CONNECT_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_CONNECTION_SETTINGS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_MESSAGE_CONNECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_MESSAGE_CONNECTION_SETTINGS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_MESSAGE_RECEIVE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_PROGRAM_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_APPLICATION_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_CAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_CAPS_EX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_CONNECTION_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_GROUP_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_PLAYER_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_SERVICE_PROVIDER_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_SP_CAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_CONNECT_COMPLETE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_ENUM_HOSTS_QUERY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_ENUM_HOSTS_RESPONSE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_INDICATE_CONNECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_NAT_RESOLVER_QUERY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_RECEIVE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_TERMINATE_SESSION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DS3DBUFFER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DS3DLISTENER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSBCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSBPOSITIONNOTIFY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSBUFFERDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCBCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCBUFFERDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCEFFECTDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCFXAec | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCFXNoiseSuppress | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSEFFECTDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXChorus | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXCompressor | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXDistortion | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXEcho | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXFlanger | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXGargle | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXI3DL2Reverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXParamEq | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXWavesReverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DXDIAG_INIT_PARAMS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_GLYPHMETRICSFLOAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_GUID | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_ICONINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_IMAGE_DOS_HEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_MMCKINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_MMIOINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_OVERLAPPED | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_RGNDATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_SECURITY_ATTRIBUTES | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXCOLOR | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXFLOAT16 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXMATRIX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXPLANE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXQUATERNION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR2_16F | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR3 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR3_16F | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR4 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR4_16F | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DICONDITION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DICONSTANTFORCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DICUSTOMFORCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVICEINSTANCEA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVICEOBJECTDATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVICEOBJECTINSTANCEA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIEFFECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIEFFECTINFOA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIEFFESCAPE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIENVELOPE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIFILEEFFECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIJOYSTATE2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPERIODIC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPCPOINTS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPDWORD | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPPOINTER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPRANGE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPSTRING | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIRAMPFORCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVCLIENTCONFIG | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVCOMPRESSIONINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVMSG_HOSTMIGRATED | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVMSG_SETTARGETS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVSESSIONDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVSOUNDDEVICECONFIG | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
FileHeader | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HACMDRIVER__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HACMSTREAM__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HBITMAP__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HBRUSH__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HDC__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HFONT__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HICON__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HINSTANCE__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HMMIO__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HMONITOR__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HPEN__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HWND__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAllocateHierarchy | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAnimationCallbackHandler | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAnimationController | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAnimationSet | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXBaseEffect | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXBaseMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXCompressedAnimationSet | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXConstantTable | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffect | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffectCompiler | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffectPool | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffectStateManager | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFile | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileEnumObject | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileSaveData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileSaveObject | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFont | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFragmentLinker | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXInclude | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXKeyframedAnimationSet | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXLine | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXLoadUserData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXMatrixStack | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPatchMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPRTBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPRTCompBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPRTEngine | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXRenderToEnvMap | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXRenderToSurface | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSaveUserData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSkinInfo | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSPMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSprite | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXTextureGutterHelper | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXTextureShader | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3D9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DBaseTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DCubeTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DDevice9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DIndexBuffer9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DPixelShader9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DQuery9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DResource9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DStateBlock9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DSurface9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DSwapChain9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVertexBuffer9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVertexDeclaration9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVertexShader9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVolume9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVolumeTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDraw7 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawClipper | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawColorControl | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawGammaControl | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawPalette | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawSurface7 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectInput8A | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectInputDevice8A | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectInputEffect | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Address | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Client | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8LobbiedApplication | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8LobbyClient | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8NATResolver | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Peer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Server | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8ThreadPool | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlayVoiceClient | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlayVoiceServer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlayVoiceTest | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound3DBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound3DListener | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound8 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundBuffer8 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCapture | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureBuffer8 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureFXAec | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureFXNoiseSuppress | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFullDuplex | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXChorus | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXCompressor | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXDistortion | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXEcho | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXFlanger | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXGargle | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXI3DL2Reverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXParamEq | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXWavesReverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundNotify | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDxDiagContainer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDxDiagProvider | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IUnknown | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ManagedD3DXEffectStateManager | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
pcmwaveformat_tag | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tACMSTREAMHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAP | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAPFILEHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAPINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAPINFOHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagDDDEVICEIDENTIFIER2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagLOGBRUSH | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagPALETTEENTRY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagPOINT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagPROPVARIANT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagRECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagVARIANT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tWAVEFORMATEX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
wavefilter_tag | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.


_BUFFERDESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_BUFFERDESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _BUFFERDESC
C# | public struct _BUFFERDESC
Managed C++ | public __value struct _BUFFERDESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DADAPTER_IDENTIFIER9

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DADAPTER_IDENTIFIER9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DADAPTER_IDENTIFIER9
C# | public struct _D3DADAPTER_IDENTIFIER9
Managed C++ | public __value struct _D3DADAPTER_IDENTIFIER9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DBOX

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DBOX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DBOX
C# | public struct _D3DBOX
Managed C++ | public __value struct _D3DBOX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DCAPS9

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DCAPS9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DCAPS9
C# | public struct _D3DCAPS9
Managed C++ | public __value struct _D3DCAPS9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DCLIPSTATUS9

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DCLIPSTATUS9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DCLIPSTATUS9
C# | public struct _D3DCLIPSTATUS9
Managed C++ | public __value struct _D3DCLIPSTATUS9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DCOLORVALUE

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DCOLORVALUE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DCOLORVALUE
C# | public struct _D3DCOLORVALUE
Managed C++ | public __value struct _D3DCOLORVALUE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DDEVICE_CREATION_PARAMETERS

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DDEVICE_CREATION_PARAMETERS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DDEVICE_CREATION_PARAMETERS
C# | public struct _D3DDEVICE_CREATION_PARAMETERS
Managed C++ | public __value struct _D3DDEVICE_CREATION_PARAMETERS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DDEVINFO_RESOURCEMANAGER

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DDEVINFO_RESOURCEMANAGER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DDEVINFO_RESOURCEMANAGER
C# | public struct _D3DDEVINFO_RESOURCEMANAGER
Managed C++ | public __value struct _D3DDEVINFO_RESOURCEMANAGER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DDISPLAYMODE

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DDISPLAYMODE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DDISPLAYMODE
C# | public struct _D3DDISPLAYMODE
Managed C++ | public __value struct _D3DDISPLAYMODE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DGAMMARAMP

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DGAMMARAMP Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DGAMMARAMP
C# | public struct _D3DGAMMARAMP
Managed C++ | public __value struct _D3DGAMMARAMP
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DINDEXBUFFER_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DINDEXBUFFER_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DINDEXBUFFER_DESC
C# | public struct _D3DINDEXBUFFER_DESC
Managed C++ | public __value struct _D3DINDEXBUFFER_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DLIGHT9

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DLIGHT9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DLIGHT9
C# | public struct _D3DLIGHT9
Managed C++ | public __value struct _D3DLIGHT9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DLOCKED_BOX

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DLOCKED_BOX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DLOCKED_BOX
C# | public struct _D3DLOCKED_BOX
Managed C++ | public __value struct _D3DLOCKED_BOX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DLOCKED_RECT

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DLOCKED_RECT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DLOCKED_RECT
C# | public struct _D3DLOCKED_RECT
Managed C++ | public __value struct _D3DLOCKED_RECT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DMATERIAL9

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DMATERIAL9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DMATERIAL9
C# | public struct _D3DMATERIAL9
Managed C++ | public __value struct _D3DMATERIAL9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DMATRIX

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DMATRIX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DMATRIX
C# | public struct _D3DMATRIX
Managed C++ | public __value struct _D3DMATRIX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DPRESENT_PARAMETERS_

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DPRESENT_PARAMETERS_ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DPRESENT_PARAMETERS_
C# | public struct _D3DPRESENT_PARAMETERS_
Managed C++ | public __value struct _D3DPRESENT_PARAMETERS_
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DPSHADERCAPS2_0

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DPSHADERCAPS2_0 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DPSHADERCAPS2_0
C# | public struct _D3DPSHADERCAPS2_0
Managed C++ | public __value struct _D3DPSHADERCAPS2_0
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DRASTER_STATUS

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DRASTER_STATUS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DRASTER_STATUS
C# | public struct _D3DRASTER_STATUS
Managed C++ | public __value struct _D3DRASTER_STATUS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DRECT

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DRECT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DRECT
C# | public struct _D3DRECT
Managed C++ | public __value struct _D3DRECT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DRECTPATCH_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DRECTPATCH_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DRECTPATCH_INFO
C# | public struct _D3DRECTPATCH_INFO
Managed C++ | public __value struct _D3DRECTPATCH_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DSURFACE_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DSURFACE_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DSURFACE_DESC
C# | public struct _D3DSURFACE_DESC
Managed C++ | public __value struct _D3DSURFACE_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DTRIPATCH_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DTRIPATCH_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DTRIPATCH_INFO
C# | public struct _D3DTRIPATCH_INFO
Managed C++ | public __value struct _D3DTRIPATCH_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DVECTOR

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DVECTOR Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DVECTOR
C# | public struct _D3DVECTOR
Managed C++ | public __value struct _D3DVECTOR
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DVERTEXBUFFER_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DVERTEXBUFFER_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DVERTEXBUFFER_DESC
C# | public struct _D3DVERTEXBUFFER_DESC
Managed C++ | public __value struct _D3DVERTEXBUFFER_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DVERTEXELEMENT9

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DVERTEXELEMENT9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DVERTEXELEMENT9
C# | public struct _D3DVERTEXELEMENT9
Managed C++ | public __value struct _D3DVERTEXELEMENT9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DVIEWPORT9

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DVIEWPORT9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DVIEWPORT9
C# | public struct _D3DVIEWPORT9
Managed C++ | public __value struct _D3DVIEWPORT9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DVOLUME_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DVOLUME_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DVOLUME_DESC
C# | public struct _D3DVOLUME_DESC
Managed C++ | public __value struct _D3DVOLUME_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DVSHADERCAPS2_0

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DVSHADERCAPS2_0 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DVSHADERCAPS2_0
C# | public struct _D3DVSHADERCAPS2_0
Managed C++ | public __value struct _D3DVSHADERCAPS2_0
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXATTRIBUTERANGE

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXATTRIBUTERANGE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXATTRIBUTERANGE
C# | public struct _D3DXATTRIBUTERANGE
Managed C++ | public __value struct _D3DXATTRIBUTERANGE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXATTRIBUTEWEIGHTS

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXATTRIBUTEWEIGHTS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXATTRIBUTEWEIGHTS
C# | public struct _D3DXATTRIBUTEWEIGHTS
Managed C++ | public __value struct _D3DXATTRIBUTEWEIGHTS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXBONECOMBINATION

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXBONECOMBINATION Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXBONECOMBINATION
C# | public struct _D3DXBONECOMBINATION
Managed C++ | public __value struct _D3DXBONECOMBINATION
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXCONSTANT_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXCONSTANT_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXCONSTANT_DESC
C# | public struct _D3DXCONSTANT_DESC
Managed C++ | public __value struct _D3DXCONSTANT_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXCONSTANTTABLE_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXCONSTANTTABLE_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXCONSTANTTABLE_DESC
C# | public struct _D3DXCONSTANTTABLE_DESC
Managed C++ | public __value struct _D3DXCONSTANTTABLE_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXEFFECT_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXEFFECT_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXEFFECT_DESC
C# | public struct _D3DXEFFECT_DESC
Managed C++ | public __value struct _D3DXEFFECT_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXEFFECTDEFAULT

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXEFFECTDEFAULT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXEFFECTDEFAULT
C# | public struct _D3DXEFFECTDEFAULT
Managed C++ | public __value struct _D3DXEFFECTDEFAULT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXEFFECTINSTANCE

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXEFFECTINSTANCE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXEFFECTINSTANCE
C# | public struct _D3DXEFFECTINSTANCE
Managed C++ | public __value struct _D3DXEFFECTINSTANCE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXEVENT_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXEVENT_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXEVENT_DESC
C# | public struct _D3DXEVENT_DESC
Managed C++ | public __value struct _D3DXEVENT_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXF_FILELOADMEMORY

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXF_FILELOADMEMORY Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXF_FILELOADMEMORY
C# | public struct _D3DXF_FILELOADMEMORY
Managed C++ | public __value struct _D3DXF_FILELOADMEMORY
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXFONT_DESCA

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXFONT_DESCA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXFONT_DESCA
C# | public struct _D3DXFONT_DESCA
Managed C++ | public __value struct _D3DXFONT_DESCA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXFONT_DESCW

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXFONT_DESCW Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXFONT_DESCW
C# | public struct _D3DXFONT_DESCW
Managed C++ | public __value struct _D3DXFONT_DESCW
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXFRAGMENT_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXFRAGMENT_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXFRAGMENT_DESC
C# | public struct _D3DXFRAGMENT_DESC
Managed C++ | public __value struct _D3DXFRAGMENT_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXFRAME

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXFRAME Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXFRAME
C# | public struct _D3DXFRAME
Managed C++ | public __value struct _D3DXFRAME
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXFUNCTION_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXFUNCTION_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXFUNCTION_DESC
C# | public struct _D3DXFUNCTION_DESC
Managed C++ | public __value struct _D3DXFUNCTION_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXIMAGE_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXIMAGE_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXIMAGE_INFO
C# | public struct _D3DXIMAGE_INFO
Managed C++ | public __value struct _D3DXIMAGE_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXKEY_CALLBACK

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXKEY_CALLBACK Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXKEY_CALLBACK
C# | public struct _D3DXKEY_CALLBACK
Managed C++ | public __value struct _D3DXKEY_CALLBACK
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXKEY_QUATERNION

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXKEY_QUATERNION Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXKEY_QUATERNION
C# | public struct _D3DXKEY_QUATERNION
Managed C++ | public __value struct _D3DXKEY_QUATERNION
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXKEY_VECTOR3

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXKEY_VECTOR3 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXKEY_VECTOR3
C# | public struct _D3DXKEY_VECTOR3
Managed C++ | public __value struct _D3DXKEY_VECTOR3
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXMACRO

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXMACRO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXMACRO
C# | public struct _D3DXMACRO
Managed C++ | public __value struct _D3DXMACRO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXMATERIAL

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXMATERIAL Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXMATERIAL
C# | public struct _D3DXMATERIAL
Managed C++ | public __value struct _D3DXMATERIAL
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXMATRIXA16

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXMATRIXA16 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXMATRIXA16
C# | public struct _D3DXMATRIXA16
Managed C++ | public __value struct _D3DXMATRIXA16
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXMESHCONTAINER

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXMESHCONTAINER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXMESHCONTAINER
C# | public struct _D3DXMESHCONTAINER
Managed C++ | public __value struct _D3DXMESHCONTAINER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXMESHDATA

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXMESHDATA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXMESHDATA
C# | public struct _D3DXMESHDATA
Managed C++ | public __value struct _D3DXMESHDATA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXPARAMETER_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXPARAMETER_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXPARAMETER_DESC
C# | public struct _D3DXPARAMETER_DESC
Managed C++ | public __value struct _D3DXPARAMETER_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXPASS_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXPASS_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXPASS_DESC
C# | public struct _D3DXPASS_DESC
Managed C++ | public __value struct _D3DXPASS_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXPATCHINFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXPATCHINFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXPATCHINFO
C# | public struct _D3DXPATCHINFO
Managed C++ | public __value struct _D3DXPATCHINFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXRTE_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXRTE_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXRTE_DESC
C# | public struct _D3DXRTE_DESC
Managed C++ | public __value struct _D3DXRTE_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXRTS_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXRTS_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXRTS_DESC
C# | public struct _D3DXRTS_DESC
Managed C++ | public __value struct _D3DXRTS_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXSEMANTIC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXSEMANTIC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXSEMANTIC
C# | public struct _D3DXSEMANTIC
Managed C++ | public __value struct _D3DXSEMANTIC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXSHMATERIAL

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXSHMATERIAL Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXSHMATERIAL
C# | public struct _D3DXSHMATERIAL
Managed C++ | public __value struct _D3DXSHMATERIAL
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXTECHNIQUE_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXTECHNIQUE_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXTECHNIQUE_DESC
C# | public struct _D3DXTECHNIQUE_DESC
Managed C++ | public __value struct _D3DXTECHNIQUE_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXTRACK_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXTRACK_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXTRACK_DESC
C# | public struct _D3DXTRACK_DESC
Managed C++ | public __value struct _D3DXTRACK_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_D3DXWELDEPSILONS

Microsoft DirectX 9.0 SDK Update (October 2004)

_D3DXWELDEPSILONS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _D3DXWELDEPSILONS
C# | public struct _D3DXWELDEPSILONS
Managed C++ | public __value struct _D3DXWELDEPSILONS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDBLTFX

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDBLTFX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDBLTFX
C# | public struct _DDBLTFX
Managed C++ | public __value struct _DDBLTFX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDCAPS_DX7

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDCAPS_DX7 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDCAPS_DX7
C# | public struct _DDCAPS_DX7
Managed C++ | public __value struct _DDCAPS_DX7
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDCOLORCONTROL

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDCOLORCONTROL Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDCOLORCONTROL
C# | public struct _DDCOLORCONTROL
Managed C++ | public __value struct _DDCOLORCONTROL
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDCOLORKEY

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDCOLORKEY Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDCOLORKEY
C# | public struct _DDCOLORKEY
Managed C++ | public __value struct _DDCOLORKEY
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDGAMMARAMP

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDGAMMARAMP Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDGAMMARAMP
C# | public struct _DDGAMMARAMP
Managed C++ | public __value struct _DDGAMMARAMP
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDOVERLAYFX

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDOVERLAYFX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDOVERLAYFX
C# | public struct _DDOVERLAYFX
Managed C++ | public __value struct _DDOVERLAYFX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDPIXELFORMAT

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDPIXELFORMAT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDPIXELFORMAT
C# | public struct _DDPIXELFORMAT
Managed C++ | public __value struct _DDPIXELFORMAT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDSCAPS2

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDSCAPS2 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDSCAPS2
C# | public struct _DDSCAPS2
Managed C++ | public __value struct _DDSCAPS2
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DDSURFACEDESC2

Microsoft DirectX 9.0 SDK Update (October 2004)

_DDSURFACEDESC2 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DDSURFACEDESC2
C# | public struct _DDSURFACEDESC2
Managed C++ | public __value struct _DDSURFACEDESC2
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DEV_BROADCAST_DEVICEINTERFACE_A

Microsoft DirectX 9.0 SDK Update (October 2004)

_DEV_BROADCAST_DEVICEINTERFACE_A Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DEV_BROADCAST_DEVICEINTERFACE_A
C# | public struct _DEV_BROADCAST_DEVICEINTERFACE_A
Managed C++ | public __value struct _DEV_BROADCAST_DEVICEINTERFACE_A
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DEV_BROADCAST_HDR

Microsoft DirectX 9.0 SDK Update (October 2004)

_DEV_BROADCAST_HDR Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DEV_BROADCAST_HDR
C# | public struct _DEV_BROADCAST_HDR
Managed C++ | public __value struct _DEV_BROADCAST_HDR
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DIACTIONA

Microsoft DirectX 9.0 SDK Update (October 2004)

_DIACTIONA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DIACTIONA
C# | public struct _DIACTIONA
Managed C++ | public __value struct _DIACTIONA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DIACTIONFORMATA

Microsoft DirectX 9.0 SDK Update (October 2004)

_DIACTIONFORMATA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DIACTIONFORMATA
C# | public struct _DIACTIONFORMATA
Managed C++ | public __value struct _DIACTIONFORMATA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DICOLORSET

Microsoft DirectX 9.0 SDK Update (October 2004)

_DICOLORSET Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DICOLORSET
C# | public struct _DICOLORSET
Managed C++ | public __value struct _DICOLORSET
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DICONFIGUREDEVICESPARAMSA

Microsoft DirectX 9.0 SDK Update (October 2004)

_DICONFIGUREDEVICESPARAMSA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DICONFIGUREDEVICESPARAMSA
C# | public struct _DICONFIGUREDEVICESPARAMSA
Managed C++ | public __value struct _DICONFIGUREDEVICESPARAMSA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DIDATAFORMAT

Microsoft DirectX 9.0 SDK Update (October 2004)

_DIDATAFORMAT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DIDATAFORMAT
C# | public struct _DIDATAFORMAT
Managed C++ | public __value struct _DIDATAFORMAT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DIDEVICEIMAGEINFOA

Microsoft DirectX 9.0 SDK Update (October 2004)

_DIDEVICEIMAGEINFOA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DIDEVICEIMAGEINFOA
C# | public struct _DIDEVICEIMAGEINFOA
Managed C++ | public __value struct _DIDEVICEIMAGEINFOA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DIDEVICEIMAGEINFOHEADERA

Microsoft DirectX 9.0 SDK Update (October 2004)

_DIDEVICEIMAGEINFOHEADERA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DIDEVICEIMAGEINFOHEADERA
C# | public struct _DIDEVICEIMAGEINFOHEADERA
Managed C++ | public __value struct _DIDEVICEIMAGEINFOHEADERA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DIMOUSESTATE2

Microsoft DirectX 9.0 SDK Update (October 2004)

_DIMOUSESTATE2 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DIMOUSESTATE2
C# | public struct _DIMOUSESTATE2
Managed C++ | public __value struct _DIMOUSESTATE2
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DIOBJECTDATAFORMAT

Microsoft DirectX 9.0 SDK Update (October 2004)

_DIOBJECTDATAFORMAT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DIOBJECTDATAFORMAT
C# | public struct _DIOBJECTDATAFORMAT
Managed C++ | public __value struct _DIOBJECTDATAFORMAT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPL_APPLICATION_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPL_APPLICATION_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPL_APPLICATION_INFO
C# | public struct _DPL_APPLICATION_INFO
Managed C++ | public __value struct _DPL_APPLICATION_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPL_CONNECT_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPL_CONNECT_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPL_CONNECT_INFO
C# | public struct _DPL_CONNECT_INFO
Managed C++ | public __value struct _DPL_CONNECT_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPL_CONNECTION_SETTINGS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPL_CONNECTION_SETTINGS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPL_CONNECTION_SETTINGS
C# | public struct _DPL_CONNECTION_SETTINGS
Managed C++ | public __value struct _DPL_CONNECTION_SETTINGS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPL_MESSAGE_CONNECT

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPL_MESSAGE_CONNECT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPL_MESSAGE_CONNECT
C# | public struct _DPL_MESSAGE_CONNECT
Managed C++ | public __value struct _DPL_MESSAGE_CONNECT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPL_MESSAGE_CONNECTION_SETTINGS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPL_MESSAGE_CONNECTION_SETTINGS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPL_MESSAGE_CONNECTION_SETTINGS
C# | public struct _DPL_MESSAGE_CONNECTION_SETTINGS
Managed C++ | public __value struct _DPL_MESSAGE_CONNECTION_SETTINGS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPL_MESSAGE_RECEIVE

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPL_MESSAGE_RECEIVE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPL_MESSAGE_RECEIVE
C# | public struct _DPL_MESSAGE_RECEIVE
Managed C++ | public __value struct _DPL_MESSAGE_RECEIVE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPL_PROGRAM_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPL_PROGRAM_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPL_PROGRAM_DESC
C# | public struct _DPL_PROGRAM_DESC
Managed C++ | public __value struct _DPL_PROGRAM_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_APPLICATION_DESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_APPLICATION_DESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_APPLICATION_DESC
C# | public struct _DPN_APPLICATION_DESC
Managed C++ | public __value struct _DPN_APPLICATION_DESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_CAPS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_CAPS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_CAPS
C# | public struct _DPN_CAPS
Managed C++ | public __value struct _DPN_CAPS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_CAPS_EX

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_CAPS_EX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_CAPS_EX
C# | public struct _DPN_CAPS_EX
Managed C++ | public __value struct _DPN_CAPS_EX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_CONNECTION_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_CONNECTION_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_CONNECTION_INFO
C# | public struct _DPN_CONNECTION_INFO
Managed C++ | public __value struct _DPN_CONNECTION_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_GROUP_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_GROUP_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_GROUP_INFO
C# | public struct _DPN_GROUP_INFO
Managed C++ | public __value struct _DPN_GROUP_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_PLAYER_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_PLAYER_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_PLAYER_INFO
C# | public struct _DPN_PLAYER_INFO
Managed C++ | public __value struct _DPN_PLAYER_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_SERVICE_PROVIDER_INFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_SERVICE_PROVIDER_INFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_SERVICE_PROVIDER_INFO
C# | public struct _DPN_SERVICE_PROVIDER_INFO
Managed C++ | public __value struct _DPN_SERVICE_PROVIDER_INFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPN_SP_CAPS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPN_SP_CAPS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPN_SP_CAPS
C# | public struct _DPN_SP_CAPS
Managed C++ | public __value struct _DPN_SP_CAPS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPNMSG_CONNECT_COMPLETE

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPNMSG_CONNECT_COMPLETE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPNMSG_CONNECT_COMPLETE
C# | public struct _DPNMSG_CONNECT_COMPLETE
Managed C++ | public __value struct _DPNMSG_CONNECT_COMPLETE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPNMSG_ENUM_HOSTS_QUERY

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPNMSG_ENUM_HOSTS_QUERY Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPNMSG_ENUM_HOSTS_QUERY
C# | public struct _DPNMSG_ENUM_HOSTS_QUERY
Managed C++ | public __value struct _DPNMSG_ENUM_HOSTS_QUERY
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPNMSG_ENUM_HOSTS_RESPONSE

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPNMSG_ENUM_HOSTS_RESPONSE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPNMSG_ENUM_HOSTS_RESPONSE
C# | public struct _DPNMSG_ENUM_HOSTS_RESPONSE
Managed C++ | public __value struct _DPNMSG_ENUM_HOSTS_RESPONSE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPNMSG_INDICATE_CONNECT

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPNMSG_INDICATE_CONNECT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPNMSG_INDICATE_CONNECT
C# | public struct _DPNMSG_INDICATE_CONNECT
Managed C++ | public __value struct _DPNMSG_INDICATE_CONNECT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPNMSG_NAT_RESOLVER_QUERY

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPNMSG_NAT_RESOLVER_QUERY Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPNMSG_NAT_RESOLVER_QUERY
C# | public struct _DPNMSG_NAT_RESOLVER_QUERY
Managed C++ | public __value struct _DPNMSG_NAT_RESOLVER_QUERY
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPNMSG_RECEIVE

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPNMSG_RECEIVE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPNMSG_RECEIVE
C# | public struct _DPNMSG_RECEIVE
Managed C++ | public __value struct _DPNMSG_RECEIVE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DPNMSG_TERMINATE_SESSION

Microsoft DirectX 9.0 SDK Update (October 2004)

_DPNMSG_TERMINATE_SESSION Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DPNMSG_TERMINATE_SESSION
C# | public struct _DPNMSG_TERMINATE_SESSION
Managed C++ | public __value struct _DPNMSG_TERMINATE_SESSION
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DS3DBUFFER

Microsoft DirectX 9.0 SDK Update (October 2004)

_DS3DBUFFER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DS3DBUFFER
C# | public struct _DS3DBUFFER
Managed C++ | public __value struct _DS3DBUFFER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DS3DLISTENER

Microsoft DirectX 9.0 SDK Update (October 2004)

_DS3DLISTENER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DS3DLISTENER
C# | public struct _DS3DLISTENER
Managed C++ | public __value struct _DS3DLISTENER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSBCAPS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSBCAPS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSBCAPS
C# | public struct _DSBCAPS
Managed C++ | public __value struct _DSBCAPS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSBPOSITIONNOTIFY

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSBPOSITIONNOTIFY Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSBPOSITIONNOTIFY
C# | public struct _DSBPOSITIONNOTIFY
Managed C++ | public __value struct _DSBPOSITIONNOTIFY
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSBUFFERDESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSBUFFERDESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSBUFFERDESC
C# | public struct _DSBUFFERDESC
Managed C++ | public __value struct _DSBUFFERDESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSCAPS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSCAPS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSCAPS
C# | public struct _DSCAPS
Managed C++ | public __value struct _DSCAPS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSCBCAPS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSCBCAPS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSCBCAPS
C# | public struct _DSCBCAPS
Managed C++ | public __value struct _DSCBCAPS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSCBUFFERDESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSCBUFFERDESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSCBUFFERDESC
C# | public struct _DSCBUFFERDESC
Managed C++ | public __value struct _DSCBUFFERDESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSCCAPS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSCCAPS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSCCAPS
C# | public struct _DSCCAPS
Managed C++ | public __value struct _DSCCAPS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSCEFFECTDESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSCEFFECTDESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSCEFFECTDESC
C# | public struct _DSCEFFECTDESC
Managed C++ | public __value struct _DSCEFFECTDESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSCFXAec

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSCFXAec Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSCFXAec
C# | public struct _DSCFXAec
Managed C++ | public __value struct _DSCFXAec
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSCFXNoiseSuppress

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSCFXNoiseSuppress Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSCFXNoiseSuppress
C# | public struct _DSCFXNoiseSuppress
Managed C++ | public __value struct _DSCFXNoiseSuppress
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSEFFECTDESC

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSEFFECTDESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSEFFECTDESC
C# | public struct _DSEFFECTDESC
Managed C++ | public __value struct _DSEFFECTDESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXChorus

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXChorus Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXChorus
C# | public struct _DSFXChorus
Managed C++ | public __value struct _DSFXChorus
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXCompressor

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXCompressor Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXCompressor
C# | public struct _DSFXCompressor
Managed C++ | public __value struct _DSFXCompressor
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXDistortion

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXDistortion Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXDistortion
C# | public struct _DSFXDistortion
Managed C++ | public __value struct _DSFXDistortion
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXEcho

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXEcho Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXEcho
C# | public struct _DSFXEcho
Managed C++ | public __value struct _DSFXEcho
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXFlanger

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXFlanger Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXFlanger
C# | public struct _DSFXFlanger
Managed C++ | public __value struct _DSFXFlanger
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXGargle

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXGargle Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXGargle
C# | public struct _DSFXGargle
Managed C++ | public __value struct _DSFXGargle
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXI3DL2Reverb

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXI3DL2Reverb Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXI3DL2Reverb
C# | public struct _DSFXI3DL2Reverb
Managed C++ | public __value struct _DSFXI3DL2Reverb
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXParamEq

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXParamEq Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXParamEq
C# | public struct _DSFXParamEq
Managed C++ | public __value struct _DSFXParamEq
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DSFXWavesReverb

Microsoft DirectX 9.0 SDK Update (October 2004)

_DSFXWavesReverb Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DSFXWavesReverb
C# | public struct _DSFXWavesReverb
Managed C++ | public __value struct _DSFXWavesReverb
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_DXDIAG_INIT_PARAMS

Microsoft DirectX 9.0 SDK Update (October 2004)

_DXDIAG_INIT_PARAMS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _DXDIAG_INIT_PARAMS
C# | public struct _DXDIAG_INIT_PARAMS
Managed C++ | public __value struct _DXDIAG_INIT_PARAMS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_GLYPHMETRICSFLOAT

Microsoft DirectX 9.0 SDK Update (October 2004)

_GLYPHMETRICSFLOAT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _GLYPHMETRICSFLOAT
C# | public struct _GLYPHMETRICSFLOAT
Managed C++ | public __value struct _GLYPHMETRICSFLOAT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_GUID

Microsoft DirectX 9.0 SDK Update (October 2004)

_GUID Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _GUID
C# | public struct _GUID
Managed C++ | public __value struct _GUID
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_ICONINFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_ICONINFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _ICONINFO
C# | public struct _ICONINFO
Managed C++ | public __value struct _ICONINFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_IMAGE_DOS_HEADER

Microsoft DirectX 9.0 SDK Update (October 2004)

_IMAGE_DOS_HEADER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _IMAGE_DOS_HEADER
C# | public struct _IMAGE_DOS_HEADER
Managed C++ | public __value struct _IMAGE_DOS_HEADER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_MMCKINFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_MMCKINFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _MMCKINFO
C# | public struct _MMCKINFO
Managed C++ | public __value struct _MMCKINFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_MMIOINFO

Microsoft DirectX 9.0 SDK Update (October 2004)

_MMIOINFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _MMIOINFO
C# | public struct _MMIOINFO
Managed C++ | public __value struct _MMIOINFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_OVERLAPPED

Microsoft DirectX 9.0 SDK Update (October 2004)

_OVERLAPPED Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _OVERLAPPED
C# | public struct _OVERLAPPED
Managed C++ | public __value struct _OVERLAPPED
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_RGNDATA

Microsoft DirectX 9.0 SDK Update (October 2004)

_RGNDATA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _RGNDATA
C# | public struct _RGNDATA
Managed C++ | public __value struct _RGNDATA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


_SECURITY_ATTRIBUTES

Microsoft DirectX 9.0 SDK Update (October 2004)

_SECURITY_ATTRIBUTES Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure _SECURITY_ATTRIBUTES
C# | public struct _SECURITY_ATTRIBUTES
Managed C++ | public __value struct _SECURITY_ATTRIBUTES
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXCOLOR

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXCOLOR Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXCOLOR
C# | public struct D3DXCOLOR
Managed C++ | public __value struct D3DXCOLOR
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXFLOAT16

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXFLOAT16 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXFLOAT16
C# | public struct D3DXFLOAT16
Managed C++ | public __value struct D3DXFLOAT16
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXMATRIX

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXMATRIX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXMATRIX
C# | public struct D3DXMATRIX
Managed C++ | public __value struct D3DXMATRIX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXPLANE

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXPLANE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXPLANE
C# | public struct D3DXPLANE
Managed C++ | public __value struct D3DXPLANE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXQUATERNION

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXQUATERNION Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXQUATERNION
C# | public struct D3DXQUATERNION
Managed C++ | public __value struct D3DXQUATERNION
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXVECTOR2

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXVECTOR2 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXVECTOR2
C# | public struct D3DXVECTOR2
Managed C++ | public __value struct D3DXVECTOR2
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXVECTOR2_16F

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXVECTOR2_16F Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXVECTOR2_16F
C# | public struct D3DXVECTOR2_16F
Managed C++ | public __value struct D3DXVECTOR2_16F
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXVECTOR3

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXVECTOR3 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXVECTOR3
C# | public struct D3DXVECTOR3
Managed C++ | public __value struct D3DXVECTOR3
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXVECTOR3_16F

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXVECTOR3_16F Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXVECTOR3_16F
C# | public struct D3DXVECTOR3_16F
Managed C++ | public __value struct D3DXVECTOR3_16F
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXVECTOR4

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXVECTOR4 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXVECTOR4
C# | public struct D3DXVECTOR4
Managed C++ | public __value struct D3DXVECTOR4
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


D3DXVECTOR4_16F

Microsoft DirectX 9.0 SDK Update (October 2004)

D3DXVECTOR4_16F Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure D3DXVECTOR4_16F
C# | public struct D3DXVECTOR4_16F
Managed C++ | public __value struct D3DXVECTOR4_16F
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DICONDITION

Microsoft DirectX 9.0 SDK Update (October 2004)

DICONDITION Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DICONDITION
C# | public struct DICONDITION
Managed C++ | public __value struct DICONDITION
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DICONSTANTFORCE

Microsoft DirectX 9.0 SDK Update (October 2004)

DICONSTANTFORCE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DICONSTANTFORCE
C# | public struct DICONSTANTFORCE
Managed C++ | public __value struct DICONSTANTFORCE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DICUSTOMFORCE

Microsoft DirectX 9.0 SDK Update (October 2004)

DICUSTOMFORCE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DICUSTOMFORCE
C# | public struct DICUSTOMFORCE
Managed C++ | public __value struct DICUSTOMFORCE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIDEVCAPS

Microsoft DirectX 9.0 SDK Update (October 2004)

DIDEVCAPS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIDEVCAPS
C# | public struct DIDEVCAPS
Managed C++ | public __value struct DIDEVCAPS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIDEVICEINSTANCEA

Microsoft DirectX 9.0 SDK Update (October 2004)

DIDEVICEINSTANCEA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIDEVICEINSTANCEA
C# | public struct DIDEVICEINSTANCEA
Managed C++ | public __value struct DIDEVICEINSTANCEA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIDEVICEOBJECTDATA

Microsoft DirectX 9.0 SDK Update (October 2004)

DIDEVICEOBJECTDATA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIDEVICEOBJECTDATA
C# | public struct DIDEVICEOBJECTDATA
Managed C++ | public __value struct DIDEVICEOBJECTDATA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIDEVICEOBJECTINSTANCEA

Microsoft DirectX 9.0 SDK Update (October 2004)

DIDEVICEOBJECTINSTANCEA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIDEVICEOBJECTINSTANCEA
C# | public struct DIDEVICEOBJECTINSTANCEA
Managed C++ | public __value struct DIDEVICEOBJECTINSTANCEA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIEFFECT

Microsoft DirectX 9.0 SDK Update (October 2004)

DIEFFECT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIEFFECT
C# | public struct DIEFFECT
Managed C++ | public __value struct DIEFFECT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIEFFECTINFOA

Microsoft DirectX 9.0 SDK Update (October 2004)

DIEFFECTINFOA Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIEFFECTINFOA
C# | public struct DIEFFECTINFOA
Managed C++ | public __value struct DIEFFECTINFOA
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIEFFESCAPE

Microsoft DirectX 9.0 SDK Update (October 2004)

DIEFFESCAPE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIEFFESCAPE
C# | public struct DIEFFESCAPE
Managed C++ | public __value struct DIEFFESCAPE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIENVELOPE

Microsoft DirectX 9.0 SDK Update (October 2004)

DIENVELOPE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIENVELOPE
C# | public struct DIENVELOPE
Managed C++ | public __value struct DIENVELOPE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIFILEEFFECT

Microsoft DirectX 9.0 SDK Update (October 2004)

DIFILEEFFECT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIFILEEFFECT
C# | public struct DIFILEEFFECT
Managed C++ | public __value struct DIFILEEFFECT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIJOYSTATE2

Microsoft DirectX 9.0 SDK Update (October 2004)

DIJOYSTATE2 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIJOYSTATE2
C# | public struct DIJOYSTATE2
Managed C++ | public __value struct DIJOYSTATE2
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIPERIODIC

Microsoft DirectX 9.0 SDK Update (October 2004)

DIPERIODIC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIPERIODIC
C# | public struct DIPERIODIC
Managed C++ | public __value struct DIPERIODIC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIPROPCPOINTS

Microsoft DirectX 9.0 SDK Update (October 2004)

DIPROPCPOINTS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIPROPCPOINTS
C# | public struct DIPROPCPOINTS
Managed C++ | public __value struct DIPROPCPOINTS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIPROPDWORD

Microsoft DirectX 9.0 SDK Update (October 2004)

DIPROPDWORD Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIPROPDWORD
C# | public struct DIPROPDWORD
Managed C++ | public __value struct DIPROPDWORD
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIPROPHEADER

Microsoft DirectX 9.0 SDK Update (October 2004)

DIPROPHEADER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIPROPHEADER
C# | public struct DIPROPHEADER
Managed C++ | public __value struct DIPROPHEADER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIPROPPOINTER

Microsoft DirectX 9.0 SDK Update (October 2004)

DIPROPPOINTER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIPROPPOINTER
C# | public struct DIPROPPOINTER
Managed C++ | public __value struct DIPROPPOINTER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIPROPRANGE

Microsoft DirectX 9.0 SDK Update (October 2004)

DIPROPRANGE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIPROPRANGE
C# | public struct DIPROPRANGE
Managed C++ | public __value struct DIPROPRANGE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIPROPSTRING

Microsoft DirectX 9.0 SDK Update (October 2004)

DIPROPSTRING Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIPROPSTRING
C# | public struct DIPROPSTRING
Managed C++ | public __value struct DIPROPSTRING
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DIRAMPFORCE

Microsoft DirectX 9.0 SDK Update (October 2004)

DIRAMPFORCE Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DIRAMPFORCE
C# | public struct DIRAMPFORCE
Managed C++ | public __value struct DIRAMPFORCE
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DVCLIENTCONFIG

Microsoft DirectX 9.0 SDK Update (October 2004)

DVCLIENTCONFIG Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DVCLIENTCONFIG
C# | public struct DVCLIENTCONFIG
Managed C++ | public __value struct DVCLIENTCONFIG
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DVCOMPRESSIONINFO

Microsoft DirectX 9.0 SDK Update (October 2004)

DVCOMPRESSIONINFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DVCOMPRESSIONINFO
C# | public struct DVCOMPRESSIONINFO
Managed C++ | public __value struct DVCOMPRESSIONINFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DVMSG_HOSTMIGRATED

Microsoft DirectX 9.0 SDK Update (October 2004)

DVMSG_HOSTMIGRATED Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DVMSG_HOSTMIGRATED
C# | public struct DVMSG_HOSTMIGRATED
Managed C++ | public __value struct DVMSG_HOSTMIGRATED
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DVMSG_SETTARGETS

Microsoft DirectX 9.0 SDK Update (October 2004)

DVMSG_SETTARGETS Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DVMSG_SETTARGETS
C# | public struct DVMSG_SETTARGETS
Managed C++ | public __value struct DVMSG_SETTARGETS
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DVSESSIONDESC

Microsoft DirectX 9.0 SDK Update (October 2004)

DVSESSIONDESC Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DVSESSIONDESC
C# | public struct DVSESSIONDESC
Managed C++ | public __value struct DVSESSIONDESC
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DVSOUNDDEVICECONFIG

Microsoft DirectX 9.0 SDK Update (October 2004)

DVSOUNDDEVICECONFIG Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure DVSOUNDDEVICECONFIG
C# | public struct DVSOUNDDEVICECONFIG
Managed C++ | public __value struct DVSOUNDDEVICECONFIG
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


FileHeader

Microsoft DirectX 9.0 SDK Update (October 2004)

FileHeader Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure FileHeader
C# | public struct FileHeader
Managed C++ | public __value struct FileHeader
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HACMDRIVER__

Microsoft DirectX 9.0 SDK Update (October 2004)

HACMDRIVER__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HACMDRIVER__
C# | public struct HACMDRIVER__
Managed C++ | public __value struct HACMDRIVER__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HACMSTREAM__

Microsoft DirectX 9.0 SDK Update (October 2004)

HACMSTREAM__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HACMSTREAM__
C# | public struct HACMSTREAM__
Managed C++ | public __value struct HACMSTREAM__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HBITMAP__

Microsoft DirectX 9.0 SDK Update (October 2004)

HBITMAP__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HBITMAP__
C# | public struct HBITMAP__
Managed C++ | public __value struct HBITMAP__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HBRUSH__

Microsoft DirectX 9.0 SDK Update (October 2004)

HBRUSH__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HBRUSH__
C# | public struct HBRUSH__
Managed C++ | public __value struct HBRUSH__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HDC__

Microsoft DirectX 9.0 SDK Update (October 2004)

HDC__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HDC__
C# | public struct HDC__
Managed C++ | public __value struct HDC__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HFONT__

Microsoft DirectX 9.0 SDK Update (October 2004)

HFONT__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HFONT__
C# | public struct HFONT__
Managed C++ | public __value struct HFONT__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HICON__

Microsoft DirectX 9.0 SDK Update (October 2004)

HICON__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HICON__
C# | public struct HICON__
Managed C++ | public __value struct HICON__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HINSTANCE__

Microsoft DirectX 9.0 SDK Update (October 2004)

HINSTANCE__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HINSTANCE__
C# | public struct HINSTANCE__
Managed C++ | public __value struct HINSTANCE__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HMMIO__

Microsoft DirectX 9.0 SDK Update (October 2004)

HMMIO__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HMMIO__
C# | public struct HMMIO__
Managed C++ | public __value struct HMMIO__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HMONITOR__

Microsoft DirectX 9.0 SDK Update (October 2004)

HMONITOR__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HMONITOR__
C# | public struct HMONITOR__
Managed C++ | public __value struct HMONITOR__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HPEN__

Microsoft DirectX 9.0 SDK Update (October 2004)

HPEN__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HPEN__
C# | public struct HPEN__
Managed C++ | public __value struct HPEN__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


HWND__

Microsoft DirectX 9.0 SDK Update (October 2004)

HWND__ Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure HWND__
C# | public struct HWND__
Managed C++ | public __value struct HWND__
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXAllocateHierarchy

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXAllocateHierarchy Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXAllocateHierarchy
C# | public struct ID3DXAllocateHierarchy
Managed C++ | public __value struct ID3DXAllocateHierarchy
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXAnimationCallbackHandler

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXAnimationCallbackHandler Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXAnimationCallbackHandler
C# | public struct ID3DXAnimationCallbackHandler
Managed C++ | public __value struct ID3DXAnimationCallbackHandler
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXAnimationController

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXAnimationController Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXAnimationController
C# | public struct ID3DXAnimationController
Managed C++ | public __value struct ID3DXAnimationController
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXAnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXAnimationSet Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXAnimationSet
C# | public struct ID3DXAnimationSet
Managed C++ | public __value struct ID3DXAnimationSet
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXBaseEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXBaseEffect Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXBaseEffect
C# | public struct ID3DXBaseEffect
Managed C++ | public __value struct ID3DXBaseEffect
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXBaseMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXBaseMesh Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXBaseMesh
C# | public struct ID3DXBaseMesh
Managed C++ | public __value struct ID3DXBaseMesh
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXBuffer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXBuffer
C# | public struct ID3DXBuffer
Managed C++ | public __value struct ID3DXBuffer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXCompressedAnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXCompressedAnimationSet Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXCompressedAnimationSet
C# | public struct ID3DXCompressedAnimationSet
Managed C++ | public __value struct ID3DXCompressedAnimationSet
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXConstantTable

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXConstantTable Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXConstantTable
C# | public struct ID3DXConstantTable
Managed C++ | public __value struct ID3DXConstantTable
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXEffect Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXEffect
C# | public struct ID3DXEffect
Managed C++ | public __value struct ID3DXEffect
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXEffectCompiler

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXEffectCompiler Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXEffectCompiler
C# | public struct ID3DXEffectCompiler
Managed C++ | public __value struct ID3DXEffectCompiler
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXEffectPool

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXEffectPool Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXEffectPool
C# | public struct ID3DXEffectPool
Managed C++ | public __value struct ID3DXEffectPool
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXEffectStateManager

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXEffectStateManager Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXEffectStateManager
C# | public struct ID3DXEffectStateManager
Managed C++ | public __value struct ID3DXEffectStateManager
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXFile

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXFile Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXFile
C# | public struct ID3DXFile
Managed C++ | public __value struct ID3DXFile
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXFileData

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXFileData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXFileData
C# | public struct ID3DXFileData
Managed C++ | public __value struct ID3DXFileData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXFileEnumObject

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXFileEnumObject Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXFileEnumObject
C# | public struct ID3DXFileEnumObject
Managed C++ | public __value struct ID3DXFileEnumObject
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXFileSaveData

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXFileSaveData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXFileSaveData
C# | public struct ID3DXFileSaveData
Managed C++ | public __value struct ID3DXFileSaveData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXFileSaveObject

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXFileSaveObject Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXFileSaveObject
C# | public struct ID3DXFileSaveObject
Managed C++ | public __value struct ID3DXFileSaveObject
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXFont

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXFont Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXFont
C# | public struct ID3DXFont
Managed C++ | public __value struct ID3DXFont
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXFragmentLinker

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXFragmentLinker Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXFragmentLinker
C# | public struct ID3DXFragmentLinker
Managed C++ | public __value struct ID3DXFragmentLinker
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXInclude

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXInclude Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXInclude
C# | public struct ID3DXInclude
Managed C++ | public __value struct ID3DXInclude
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXKeyframedAnimationSet

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXKeyframedAnimationSet Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXKeyframedAnimationSet
C# | public struct ID3DXKeyframedAnimationSet
Managed C++ | public __value struct ID3DXKeyframedAnimationSet
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXLine

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXLine Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXLine
C# | public struct ID3DXLine
Managed C++ | public __value struct ID3DXLine
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXLoadUserData

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXLoadUserData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXLoadUserData
C# | public struct ID3DXLoadUserData
Managed C++ | public __value struct ID3DXLoadUserData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXMatrixStack

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXMatrixStack Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXMatrixStack
C# | public struct ID3DXMatrixStack
Managed C++ | public __value struct ID3DXMatrixStack
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXMesh Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXMesh
C# | public struct ID3DXMesh
Managed C++ | public __value struct ID3DXMesh
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXPatchMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXPatchMesh Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXPatchMesh
C# | public struct ID3DXPatchMesh
Managed C++ | public __value struct ID3DXPatchMesh
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXPMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXPMesh Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXPMesh
C# | public struct ID3DXPMesh
Managed C++ | public __value struct ID3DXPMesh
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXPRTBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXPRTBuffer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXPRTBuffer
C# | public struct ID3DXPRTBuffer
Managed C++ | public __value struct ID3DXPRTBuffer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXPRTCompBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXPRTCompBuffer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXPRTCompBuffer
C# | public struct ID3DXPRTCompBuffer
Managed C++ | public __value struct ID3DXPRTCompBuffer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXPRTEngine

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXPRTEngine Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXPRTEngine
C# | public struct ID3DXPRTEngine
Managed C++ | public __value struct ID3DXPRTEngine
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXRenderToEnvMap

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXRenderToEnvMap Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXRenderToEnvMap
C# | public struct ID3DXRenderToEnvMap
Managed C++ | public __value struct ID3DXRenderToEnvMap
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXRenderToSurface

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXRenderToSurface Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXRenderToSurface
C# | public struct ID3DXRenderToSurface
Managed C++ | public __value struct ID3DXRenderToSurface
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXSaveUserData

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXSaveUserData Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXSaveUserData
C# | public struct ID3DXSaveUserData
Managed C++ | public __value struct ID3DXSaveUserData
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXSkinInfo

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXSkinInfo Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXSkinInfo
C# | public struct ID3DXSkinInfo
Managed C++ | public __value struct ID3DXSkinInfo
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXSPMesh

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXSPMesh Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXSPMesh
C# | public struct ID3DXSPMesh
Managed C++ | public __value struct ID3DXSPMesh
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXSprite

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXSprite Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXSprite
C# | public struct ID3DXSprite
Managed C++ | public __value struct ID3DXSprite
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXTextureGutterHelper

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXTextureGutterHelper Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXTextureGutterHelper
C# | public struct ID3DXTextureGutterHelper
Managed C++ | public __value struct ID3DXTextureGutterHelper
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ID3DXTextureShader

Microsoft DirectX 9.0 SDK Update (October 2004)

ID3DXTextureShader Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ID3DXTextureShader
C# | public struct ID3DXTextureShader
Managed C++ | public __value struct ID3DXTextureShader
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3D9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3D9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3D9
C# | public struct IDirect3D9
Managed C++ | public __value struct IDirect3D9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DBaseTexture9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DBaseTexture9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DBaseTexture9
C# | public struct IDirect3DBaseTexture9
Managed C++ | public __value struct IDirect3DBaseTexture9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DCubeTexture9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DCubeTexture9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DCubeTexture9
C# | public struct IDirect3DCubeTexture9
Managed C++ | public __value struct IDirect3DCubeTexture9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DDevice9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DDevice9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DDevice9
C# | public struct IDirect3DDevice9
Managed C++ | public __value struct IDirect3DDevice9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DIndexBuffer9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DIndexBuffer9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DIndexBuffer9
C# | public struct IDirect3DIndexBuffer9
Managed C++ | public __value struct IDirect3DIndexBuffer9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DPixelShader9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DPixelShader9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DPixelShader9
C# | public struct IDirect3DPixelShader9
Managed C++ | public __value struct IDirect3DPixelShader9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DQuery9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DQuery9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DQuery9
C# | public struct IDirect3DQuery9
Managed C++ | public __value struct IDirect3DQuery9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DResource9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DResource9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DResource9
C# | public struct IDirect3DResource9
Managed C++ | public __value struct IDirect3DResource9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DStateBlock9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DStateBlock9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DStateBlock9
C# | public struct IDirect3DStateBlock9
Managed C++ | public __value struct IDirect3DStateBlock9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DSurface9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DSurface9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DSurface9
C# | public struct IDirect3DSurface9
Managed C++ | public __value struct IDirect3DSurface9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DSwapChain9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DSwapChain9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DSwapChain9
C# | public struct IDirect3DSwapChain9
Managed C++ | public __value struct IDirect3DSwapChain9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DTexture9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DTexture9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DTexture9
C# | public struct IDirect3DTexture9
Managed C++ | public __value struct IDirect3DTexture9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DVertexBuffer9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DVertexBuffer9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DVertexBuffer9
C# | public struct IDirect3DVertexBuffer9
Managed C++ | public __value struct IDirect3DVertexBuffer9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DVertexDeclaration9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DVertexDeclaration9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DVertexDeclaration9
C# | public struct IDirect3DVertexDeclaration9
Managed C++ | public __value struct IDirect3DVertexDeclaration9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DVertexShader9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DVertexShader9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DVertexShader9
C# | public struct IDirect3DVertexShader9
Managed C++ | public __value struct IDirect3DVertexShader9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DVolume9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DVolume9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DVolume9
C# | public struct IDirect3DVolume9
Managed C++ | public __value struct IDirect3DVolume9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirect3DVolumeTexture9

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirect3DVolumeTexture9 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirect3DVolumeTexture9
C# | public struct IDirect3DVolumeTexture9
Managed C++ | public __value struct IDirect3DVolumeTexture9
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectDraw7

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectDraw7 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectDraw7
C# | public struct IDirectDraw7
Managed C++ | public __value struct IDirectDraw7
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectDrawClipper

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectDrawClipper Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectDrawClipper
C# | public struct IDirectDrawClipper
Managed C++ | public __value struct IDirectDrawClipper
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectDrawColorControl

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectDrawColorControl Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectDrawColorControl
C# | public struct IDirectDrawColorControl
Managed C++ | public __value struct IDirectDrawColorControl
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectDrawGammaControl

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectDrawGammaControl Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectDrawGammaControl
C# | public struct IDirectDrawGammaControl
Managed C++ | public __value struct IDirectDrawGammaControl
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectDrawPalette

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectDrawPalette Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectDrawPalette
C# | public struct IDirectDrawPalette
Managed C++ | public __value struct IDirectDrawPalette
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectDrawSurface7

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectDrawSurface7 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectDrawSurface7
C# | public struct IDirectDrawSurface7
Managed C++ | public __value struct IDirectDrawSurface7
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectInput8A

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectInput8A Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectInput8A
C# | public struct IDirectInput8A
Managed C++ | public __value struct IDirectInput8A
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectInputDevice8A

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectInputDevice8A Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectInputDevice8A
C# | public struct IDirectInputDevice8A
Managed C++ | public __value struct IDirectInputDevice8A
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectInputEffect

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectInputEffect Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectInputEffect
C# | public struct IDirectInputEffect
Managed C++ | public __value struct IDirectInputEffect
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8Address

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8Address Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8Address
C# | public struct IDirectPlay8Address
Managed C++ | public __value struct IDirectPlay8Address
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8Client

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8Client Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8Client
C# | public struct IDirectPlay8Client
Managed C++ | public __value struct IDirectPlay8Client
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8LobbiedApplication

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8LobbiedApplication Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8LobbiedApplication
C# | public struct IDirectPlay8LobbiedApplication
Managed C++ | public __value struct IDirectPlay8LobbiedApplication
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8LobbyClient

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8LobbyClient Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8LobbyClient
C# | public struct IDirectPlay8LobbyClient
Managed C++ | public __value struct IDirectPlay8LobbyClient
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8NATResolver

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8NATResolver Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8NATResolver
C# | public struct IDirectPlay8NATResolver
Managed C++ | public __value struct IDirectPlay8NATResolver
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8Peer

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8Peer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8Peer
C# | public struct IDirectPlay8Peer
Managed C++ | public __value struct IDirectPlay8Peer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8Server

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8Server Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8Server
C# | public struct IDirectPlay8Server
Managed C++ | public __value struct IDirectPlay8Server
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlay8ThreadPool

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlay8ThreadPool Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlay8ThreadPool
C# | public struct IDirectPlay8ThreadPool
Managed C++ | public __value struct IDirectPlay8ThreadPool
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlayVoiceClient

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlayVoiceClient Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlayVoiceClient
C# | public struct IDirectPlayVoiceClient
Managed C++ | public __value struct IDirectPlayVoiceClient
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlayVoiceServer

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlayVoiceServer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlayVoiceServer
C# | public struct IDirectPlayVoiceServer
Managed C++ | public __value struct IDirectPlayVoiceServer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectPlayVoiceTest

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectPlayVoiceTest Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectPlayVoiceTest
C# | public struct IDirectPlayVoiceTest
Managed C++ | public __value struct IDirectPlayVoiceTest
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSound

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSound Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSound
C# | public struct IDirectSound
Managed C++ | public __value struct IDirectSound
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSound3DBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSound3DBuffer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSound3DBuffer
C# | public struct IDirectSound3DBuffer
Managed C++ | public __value struct IDirectSound3DBuffer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSound3DListener

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSound3DListener Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSound3DListener
C# | public struct IDirectSound3DListener
Managed C++ | public __value struct IDirectSound3DListener
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSound8

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSound8 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSound8
C# | public struct IDirectSound8
Managed C++ | public __value struct IDirectSound8
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundBuffer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundBuffer
C# | public struct IDirectSoundBuffer
Managed C++ | public __value struct IDirectSoundBuffer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundBuffer8

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundBuffer8 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundBuffer8
C# | public struct IDirectSoundBuffer8
Managed C++ | public __value struct IDirectSoundBuffer8
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundCapture

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundCapture Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundCapture
C# | public struct IDirectSoundCapture
Managed C++ | public __value struct IDirectSoundCapture
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundCaptureBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundCaptureBuffer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundCaptureBuffer
C# | public struct IDirectSoundCaptureBuffer
Managed C++ | public __value struct IDirectSoundCaptureBuffer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundCaptureBuffer8

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundCaptureBuffer8 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundCaptureBuffer8
C# | public struct IDirectSoundCaptureBuffer8
Managed C++ | public __value struct IDirectSoundCaptureBuffer8
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundCaptureFXAec

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundCaptureFXAec Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundCaptureFXAec
C# | public struct IDirectSoundCaptureFXAec
Managed C++ | public __value struct IDirectSoundCaptureFXAec
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundCaptureFXNoiseSuppress

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundCaptureFXNoiseSuppress Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundCaptureFXNoiseSuppress
C# | public struct IDirectSoundCaptureFXNoiseSuppress
Managed C++ | public __value struct IDirectSoundCaptureFXNoiseSuppress
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFullDuplex

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFullDuplex Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFullDuplex
C# | public struct IDirectSoundFullDuplex
Managed C++ | public __value struct IDirectSoundFullDuplex
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXChorus

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXChorus Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXChorus
C# | public struct IDirectSoundFXChorus
Managed C++ | public __value struct IDirectSoundFXChorus
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXCompressor

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXCompressor Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXCompressor
C# | public struct IDirectSoundFXCompressor
Managed C++ | public __value struct IDirectSoundFXCompressor
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXDistortion

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXDistortion Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXDistortion
C# | public struct IDirectSoundFXDistortion
Managed C++ | public __value struct IDirectSoundFXDistortion
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXEcho

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXEcho Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXEcho
C# | public struct IDirectSoundFXEcho
Managed C++ | public __value struct IDirectSoundFXEcho
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXFlanger

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXFlanger Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXFlanger
C# | public struct IDirectSoundFXFlanger
Managed C++ | public __value struct IDirectSoundFXFlanger
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXGargle

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXGargle Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXGargle
C# | public struct IDirectSoundFXGargle
Managed C++ | public __value struct IDirectSoundFXGargle
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXI3DL2Reverb

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXI3DL2Reverb Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXI3DL2Reverb
C# | public struct IDirectSoundFXI3DL2Reverb
Managed C++ | public __value struct IDirectSoundFXI3DL2Reverb
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXParamEq

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXParamEq Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXParamEq
C# | public struct IDirectSoundFXParamEq
Managed C++ | public __value struct IDirectSoundFXParamEq
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundFXWavesReverb

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundFXWavesReverb Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundFXWavesReverb
C# | public struct IDirectSoundFXWavesReverb
Managed C++ | public __value struct IDirectSoundFXWavesReverb
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDirectSoundNotify

Microsoft DirectX 9.0 SDK Update (October 2004)

IDirectSoundNotify Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDirectSoundNotify
C# | public struct IDirectSoundNotify
Managed C++ | public __value struct IDirectSoundNotify
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDxDiagContainer

Microsoft DirectX 9.0 SDK Update (October 2004)

IDxDiagContainer Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDxDiagContainer
C# | public struct IDxDiagContainer
Managed C++ | public __value struct IDxDiagContainer
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IDxDiagProvider

Microsoft DirectX 9.0 SDK Update (October 2004)

IDxDiagProvider Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IDxDiagProvider
C# | public struct IDxDiagProvider
Managed C++ | public __value struct IDxDiagProvider
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


IUnknown

Microsoft DirectX 9.0 SDK Update (October 2004)

IUnknown Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure IUnknown
C# | public struct IUnknown
Managed C++ | public __value struct IUnknown
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


ManagedD3DXEffectStateManager

Microsoft DirectX 9.0 SDK Update (October 2004)

ManagedD3DXEffectStateManager Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure ManagedD3DXEffectStateManager
C# | public struct ManagedD3DXEffectStateManager
Managed C++ | public __value struct ManagedD3DXEffectStateManager
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


pcmwaveformat_tag

Microsoft DirectX 9.0 SDK Update (October 2004)

pcmwaveformat_tag Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure pcmwaveformat_tag
C# | public struct pcmwaveformat_tag
Managed C++ | public __value struct pcmwaveformat_tag
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tACMSTREAMHEADER

Microsoft DirectX 9.0 SDK Update (October 2004)

tACMSTREAMHEADER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tACMSTREAMHEADER
C# | public struct tACMSTREAMHEADER
Managed C++ | public __value struct tACMSTREAMHEADER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagBITMAP

Microsoft DirectX 9.0 SDK Update (October 2004)

tagBITMAP Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagBITMAP
C# | public struct tagBITMAP
Managed C++ | public __value struct tagBITMAP
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagBITMAPFILEHEADER

Microsoft DirectX 9.0 SDK Update (October 2004)

tagBITMAPFILEHEADER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagBITMAPFILEHEADER
C# | public struct tagBITMAPFILEHEADER
Managed C++ | public __value struct tagBITMAPFILEHEADER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagBITMAPINFO

Microsoft DirectX 9.0 SDK Update (October 2004)

tagBITMAPINFO Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagBITMAPINFO
C# | public struct tagBITMAPINFO
Managed C++ | public __value struct tagBITMAPINFO
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagBITMAPINFOHEADER

Microsoft DirectX 9.0 SDK Update (October 2004)

tagBITMAPINFOHEADER Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagBITMAPINFOHEADER
C# | public struct tagBITMAPINFOHEADER
Managed C++ | public __value struct tagBITMAPINFOHEADER
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagDDDEVICEIDENTIFIER2

Microsoft DirectX 9.0 SDK Update (October 2004)

tagDDDEVICEIDENTIFIER2 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagDDDEVICEIDENTIFIER2
C# | public struct tagDDDEVICEIDENTIFIER2
Managed C++ | public __value struct tagDDDEVICEIDENTIFIER2
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagLOGBRUSH

Microsoft DirectX 9.0 SDK Update (October 2004)

tagLOGBRUSH Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagLOGBRUSH
C# | public struct tagLOGBRUSH
Managed C++ | public __value struct tagLOGBRUSH
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagPALETTEENTRY

Microsoft DirectX 9.0 SDK Update (October 2004)

tagPALETTEENTRY Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagPALETTEENTRY
C# | public struct tagPALETTEENTRY
Managed C++ | public __value struct tagPALETTEENTRY
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagPOINT

Microsoft DirectX 9.0 SDK Update (October 2004)

tagPOINT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagPOINT
C# | public struct tagPOINT
Managed C++ | public __value struct tagPOINT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagPROPVARIANT

Microsoft DirectX 9.0 SDK Update (October 2004)

tagPROPVARIANT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagPROPVARIANT
C# | public struct tagPROPVARIANT
Managed C++ | public __value struct tagPROPVARIANT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagRECT

Microsoft DirectX 9.0 SDK Update (October 2004)

tagRECT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagRECT
C# | public struct tagRECT
Managed C++ | public __value struct tagRECT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tagVARIANT

Microsoft DirectX 9.0 SDK Update (October 2004)

tagVARIANT Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tagVARIANT
C# | public struct tagVARIANT
Managed C++ | public __value struct tagVARIANT
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


tWAVEFORMATEX

Microsoft DirectX 9.0 SDK Update (October 2004)

tWAVEFORMATEX Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure tWAVEFORMATEX
C# | public struct tWAVEFORMATEX
Managed C++ | public __value struct tWAVEFORMATEX
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


wavefilter_tag

Microsoft DirectX 9.0 SDK Update (October 2004)

wavefilter_tag Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft® DirectX® application programming interface (API). This is not intended to be used directly from your code.

Definition

Visual Basic .NET | Public Structure wavefilter_tag
C# | public struct wavefilter_tag
Managed C++ | public __value struct wavefilter_tag
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Microsoft.DirectX.Security.Permissions

Note: This documentation is preliminary and is subject to change.

Allows security actions to be applied to code using declarative security. The following tables list the members exposed by the Microsoft.DirectX.Security.Permissions namespace.

Classes

GraphicsPermissionAttribute | Allows security actions for GraphicsPermission to be applied to code using declarative security.
InputPermissionAttribute | Allows security actions for InputPermission to be applied to code using declarative security.
NetworkPermissionAttribute | Allows security actions for NetworkPermission to be applied to code using declarative security.
SoundPermissionAttribute | Allows security actions for SoundPermission to be applied to code using declarative security.


Microsoft.DirectX.Security.Permissions.GraphicsPermissionAttribute

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermissionAttribute Class

Language:
Note: This documentation is preliminary and is subject to change.

Allows security actions for GraphicsPermission to be applied to code using declarative security.

Definition

Visual Basic .NET NotInheritable Public Class GraphicsPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class GraphicsPermissionAttribute : CodeAccessSecurityAttribute
Managed C++ | public __gc __sealed class GraphicsPermissionAttribute : public CodeAccessSecurityAttribute
JScript .NET | public class GraphicsPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Creates a new permission.
GraphicsPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Use | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
GraphicsPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GraphicsPermissionAttribute.CreatePermission()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermissionAttribute.CreatePermission Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new permission.

Definition

Visual Basic .NET | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
Managed C++ | public: IPermission* CreatePermission();
JScript .NET | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission .


GraphicsPermissionAttribute.GraphicsPermissionAttribute(SecurityAction)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermissionAttribute.GraphicsPermissionAttribute Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal action As SecurityAction _
)
C# public GraphicsPermissionAttribute(
SecurityAction action
);
Managed C++ public: GraphicsPermissionAttribute(
SecurityAction action
);
JScript .NET public function GraphicsPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction.


GraphicsPermissionAttribute.Use

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermissionAttribute.Use Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the type of access.

Definition

Visual Basic .NET | Public Property Use As Boolean
C# | public bool Use { get; set; }
Managed C++ public: __property bool get_Use();
public: __property void set_Use(bool);
JScript .NET public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.Security.Permissions.InputPermissionAttribute

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermissionAttribute Class

Language:
Note: This documentation is preliminary and is subject to change.

Allows security actions for InputPermission to be applied to code using declarative security.

Definition

Visual Basic .NET NotInheritable Public Class InputPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class InputPermissionAttribute : CodeAccessSecurityAttribute
Managed C++ | public __gc __sealed class InputPermissionAttribute : public CodeAccessSecurityAttribute
JScript .NET | public class InputPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Creates a new permission.
InputPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Use | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
InputPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputPermissionAttribute.CreatePermission()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermissionAttribute.CreatePermission Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new permission.

Definition

Visual Basic .NET | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
Managed C++ | public: IPermission* CreatePermission();
JScript .NET | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission .


InputPermissionAttribute.InputPermissionAttribute(SecurityAction)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermissionAttribute.InputPermissionAttribute Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal action As SecurityAction _
)
C# public InputPermissionAttribute(
SecurityAction action
);
Managed C++ public: InputPermissionAttribute(
SecurityAction action
);
JScript .NET public function InputPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction.


InputPermissionAttribute.Use

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermissionAttribute.Use Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the type of access.

Definition

Visual Basic .NET | Public Property Use As Boolean
C# | public bool Use { get; set; }
Managed C++ public: __property bool get_Use();
public: __property void set_Use(bool);
JScript .NET public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.Security.Permissions.NetworkPermissionAttribute

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermissionAttribute Class

Language:
Note: This documentation is preliminary and is subject to change.

Allows security actions for NetworkPermission to be applied to code using declarative security.

Definition

Visual Basic .NET NotInheritable Public Class NetworkPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class NetworkPermissionAttribute : CodeAccessSecurityAttribute
Managed C++ | public __gc __sealed class NetworkPermissionAttribute : public CodeAccessSecurityAttribute
JScript .NET | public class NetworkPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Create a new permission.
NetworkPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Host | Gets or sets the type of access.
Join | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
NetworkPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NetworkPermissionAttribute.CreatePermission()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermissionAttribute.CreatePermission Method

 Language:
Note: This documentation is preliminary and is subject to change.

Create a new permission.

Definition

Visual Basic .NET | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
Managed C++ | public: IPermission* CreatePermission();
JScript .NET | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission .


NetworkPermissionAttribute.NetworkPermissionAttribute(SecurityAction)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermissionAttribute.NetworkPermissionAttribute Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal action As SecurityAction _
)
C# public NetworkPermissionAttribute(
SecurityAction action
);
Managed C++ public: NetworkPermissionAttribute(
SecurityAction action
);
JScript .NET public function NetworkPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction.


NetworkPermissionAttribute.Host

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermissionAttribute.Host Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the type of access.

Definition

Visual Basic .NET | Public Property Host As Boolean
C# | public bool Host { get; set; }
Managed C++ public: __property bool get_Host();
public: __property void set_Host(bool);
JScript .NET public function get Host() : boolean
public function set Host(boolean);

Property Value

System.Boolean .

This property is read/write.


NetworkPermissionAttribute.Join

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermissionAttribute.Join Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the type of access.

Definition

Visual Basic .NET | Public Property Join As Boolean
C# | public bool Join { get; set; }
Managed C++ public: __property bool get_Join();
public: __property void set_Join(bool);
JScript .NET public function get Join() : boolean
public function set Join(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.Security.Permissions.SoundPermissionAttribute

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermissionAttribute Class

Language:
Note: This documentation is preliminary and is subject to change.

Allows security actions for SoundPermission to be applied to code using declarative security.

Definition

Visual Basic .NET NotInheritable Public Class SoundPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class SoundPermissionAttribute : CodeAccessSecurityAttribute
Managed C++ | public __gc __sealed class SoundPermissionAttribute : public CodeAccessSecurityAttribute
JScript .NET | public class SoundPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Creates a new permission.
SoundPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Use | Gets or sets the type of access.
UseCapture | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
SoundPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SoundPermissionAttribute.CreatePermission()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermissionAttribute.CreatePermission Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a new permission.

Definition

Visual Basic .NET | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
Managed C++ | public: IPermission* CreatePermission();
JScript .NET | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission .


SoundPermissionAttribute.SoundPermissionAttribute(SecurityAction)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermissionAttribute.SoundPermissionAttribute Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal action As SecurityAction _
)
C# public SoundPermissionAttribute(
SecurityAction action
);
Managed C++ public: SoundPermissionAttribute(
SecurityAction action
);
JScript .NET public function SoundPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction.


SoundPermissionAttribute.Use

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermissionAttribute.Use Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the type of access.

Definition

Visual Basic .NET | Public Property Use As Boolean
C# | public bool Use { get; set; }
Managed C++ public: __property bool get_Use();
public: __property void set_Use(bool);
JScript .NET public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean .

This property is read/write.


SoundPermissionAttribute.UseCapture

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermissionAttribute.UseCapture Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the type of access.

Definition

Visual Basic .NET | Public Property UseCapture As Boolean
C# | public bool UseCapture { get; set; }
Managed C++ public: __property bool get_UseCapture();
public: __property void set_UseCapture(bool);
JScript .NET public function get UseCapture() : boolean
public function set UseCapture(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.Security

Note: This documentation is preliminary and is subject to change.

Controls permissions related to Microsoft® Direct3D®, Microsoft DirectInput®, Microsoft DirectPlay®, and Microsoft DirectSound®. The following tables list the members exposed by the Microsoft.DirectX.Security namespace.

Classes

GraphicsPermission | Controls the permissions related to DirectX Graphics.
InputPermission | Controls the permissions related to DirectX Input.
NetworkPermission | Controls the permissions related DirectPlay.
SoundPermission | Controls the permissions related DirectX Audio.


Microsoft.DirectX.Security.GraphicsPermission

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission Class

Language:
Note: This documentation is preliminary and is subject to change.

Controls the permissions related to DirectX Graphics.

Definition

Visual Basic .NET NotInheritable Public Class GraphicsPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# public sealed class GraphicsPermission : CodeAccessPermission,
IUnrestrictedPermission
Managed C++ public __gc __sealed class GraphicsPermission : public CodeAccessPermission,
IUnrestrictedPermission
JScript .NET public class GraphicsPermission extends CodeAccessPermission
implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
GraphicsPermission | Initializes a new instance of the object.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Use | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
GraphicsPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GraphicsPermission.Copy()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.Copy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns an identical copy of the current permission.

Definition

Visual Basic .NET | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
Managed C++ | public: IPermission* Copy();
JScript .NET | public override function Copy() : IPermission;

Return Value

System.Security.IPermission .


GraphicsPermission.FromXml(SecurityElement)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.FromXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic .NET Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
Managed C++ public: void FromXml(
SecurityElement *securityElement
);
JScript .NET public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement.


GraphicsPermission.GraphicsPermission

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.GraphicsPermission Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Overload List

public GraphicsPermission(bool);
public GraphicsPermission(PermissionState);


GraphicsPermission.GraphicsPermission(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.GraphicsPermission Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal canUse As Boolean _
)
C# public GraphicsPermission(
bool canUse
);
Managed C++ public: GraphicsPermission(
bool canUse
);
JScript .NET public function GraphicsPermission(
canUse : boolean
);

Parameters

canUse System.Boolean.


GraphicsPermission.GraphicsPermission(PermissionState)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.GraphicsPermission Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal state As PermissionState _
)
C# public GraphicsPermission(
PermissionState state
);
Managed C++ public: GraphicsPermission(
PermissionState state
);
JScript .NET public function GraphicsPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState.


GraphicsPermission.Intersect(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
Managed C++ public: IPermission* Intersect(
IPermission *target
);
JScript .NET public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


GraphicsPermission.IsSubsetOf(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.IsSubsetOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic .NET Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
Managed C++ public: bool IsSubsetOf(
IPermission *target
);
JScript .NET public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission.

Return Value

System.Boolean .


GraphicsPermission.IsUnrestricted()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.IsUnrestricted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic .NET | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
Managed C++ | public: bool IsUnrestricted();
JScript .NET | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean .


GraphicsPermission.ToXml()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.ToXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic .NET | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
Managed C++ | public: SecurityElement* ToXml();
JScript .NET | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement .


GraphicsPermission.Union(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.Union Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
Managed C++ public: IPermission* Union(
IPermission *target
);
JScript .NET public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


GraphicsPermission.Use

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsPermission.Use Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the access represented by the permission.

Definition

Visual Basic .NET | Public Property Use As Boolean
C# | public bool Use { get; set; }
Managed C++ public: __property bool get_Use();
public: __property void set_Use(bool);
JScript .NET public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.Security.InputPermission

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission Class

Language:
Note: This documentation is preliminary and is subject to change.

Controls the permissions related to DirectX Input.

Definition

Visual Basic .NET NotInheritable Public Class InputPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# public sealed class InputPermission : CodeAccessPermission,
IUnrestrictedPermission
Managed C++ public __gc __sealed class InputPermission : public CodeAccessPermission,
IUnrestrictedPermission
JScript .NET public class InputPermission extends CodeAccessPermission
implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
InputPermission | Initializes a new instance of the object.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Use | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
InputPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


InputPermission.Copy()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.Copy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns an identical copy of the current permission.

Definition

Visual Basic .NET | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
Managed C++ | public: IPermission* Copy();
JScript .NET | public override function Copy() : IPermission;

Return Value

System.Security.IPermission .


InputPermission.FromXml(SecurityElement)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.FromXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic .NET Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
Managed C++ public: void FromXml(
SecurityElement *securityElement
);
JScript .NET public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement.


InputPermission.InputPermission(PermissionState)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.InputPermission Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal state As PermissionState _
)
C# public InputPermission(
PermissionState state
);
Managed C++ public: InputPermission(
PermissionState state
);
JScript .NET public function InputPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState.


InputPermission.Intersect(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
Managed C++ public: IPermission* Intersect(
IPermission *target
);
JScript .NET public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


InputPermission.IsSubsetOf(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.IsSubsetOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic .NET Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
Managed C++ public: bool IsSubsetOf(
IPermission *target
);
JScript .NET public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission.

Return Value

System.Boolean .


InputPermission.IsUnrestricted()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.IsUnrestricted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic .NET | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
Managed C++ | public: bool IsUnrestricted();
JScript .NET | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean .


InputPermission.ToXml()

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.ToXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic .NET | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
Managed C++ | public: SecurityElement* ToXml();
JScript .NET | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement .


InputPermission.Union(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.Union Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
Managed C++ public: IPermission* Union(
IPermission *target
);
JScript .NET public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


InputPermission.Use

Microsoft DirectX 9.0 SDK Update (October 2004)

InputPermission.Use Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the access represented by the permission.

Definition

Visual Basic .NET | Public Property Use As Boolean
C# | public bool Use { get; set; }
Managed C++ public: __property bool get_Use();
public: __property void set_Use(bool);
JScript .NET public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.Security.NetworkPermission

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission Class

Language:
Note: This documentation is preliminary and is subject to change.

Controls the permissions related DirectPlay.

Definition

Visual Basic .NET NotInheritable Public Class NetworkPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# public sealed class NetworkPermission : CodeAccessPermission,
IUnrestrictedPermission
Managed C++ public __gc __sealed class NetworkPermission : public CodeAccessPermission,
IUnrestrictedPermission
JScript .NET public class NetworkPermission extends CodeAccessPermission
implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
NetworkPermission | Initializes a new instance of the object.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Host | Gets or sets the access represented by the permission.
Join | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
NetworkPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


NetworkPermission.Copy()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.Copy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns an identical copy of the current permission.

Definition

Visual Basic .NET | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
Managed C++ | public: IPermission* Copy();
JScript .NET | public override function Copy() : IPermission;

Return Value

System.Security.IPermission .


NetworkPermission.FromXml(SecurityElement)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.FromXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic .NET Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
Managed C++ public: void FromXml(
SecurityElement *securityElement
);
JScript .NET public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement.


NetworkPermission.Intersect(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
Managed C++ public: IPermission* Intersect(
IPermission *target
);
JScript .NET public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


NetworkPermission.IsSubsetOf(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.IsSubsetOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic .NET Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
Managed C++ public: bool IsSubsetOf(
IPermission *target
);
JScript .NET public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission.

Return Value

System.Boolean .


NetworkPermission.IsUnrestricted()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.IsUnrestricted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic .NET | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
Managed C++ | public: bool IsUnrestricted();
JScript .NET | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean .


NetworkPermission.NetworkPermission(PermissionState)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.NetworkPermission Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal state As PermissionState _
)
C# public NetworkPermission(
PermissionState state
);
Managed C++ public: NetworkPermission(
PermissionState state
);
JScript .NET public function NetworkPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState.


NetworkPermission.ToXml()

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.ToXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic .NET | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
Managed C++ | public: SecurityElement* ToXml();
JScript .NET | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement .


NetworkPermission.Union(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.Union Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
Managed C++ public: IPermission* Union(
IPermission *target
);
JScript .NET public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


NetworkPermission.Host

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.Host Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the access represented by the permission.

Definition

Visual Basic .NET | Public Property Host As Boolean
C# | public bool Host { get; set; }
Managed C++ public: __property bool get_Host();
public: __property void set_Host(bool);
JScript .NET public function get Host() : boolean
public function set Host(boolean);

Property Value

System.Boolean .

This property is read/write.


NetworkPermission.Join

Microsoft DirectX 9.0 SDK Update (October 2004)

NetworkPermission.Join Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the access represented by the permission.

Definition

Visual Basic .NET | Public Property Join As Boolean
C# | public bool Join { get; set; }
Managed C++ public: __property bool get_Join();
public: __property void set_Join(bool);
JScript .NET public function get Join() : boolean
public function set Join(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX.Security.SoundPermission

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission Class

Language:
Note: This documentation is preliminary and is subject to change.

Controls the permissions related DirectX Audio.

Definition

Visual Basic .NET NotInheritable Public Class SoundPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# public sealed class SoundPermission : CodeAccessPermission,
IUnrestrictedPermission
Managed C++ public __gc __sealed class SoundPermission : public CodeAccessPermission,
IUnrestrictedPermission
JScript .NET public class SoundPermission extends CodeAccessPermission
implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
SoundPermission | Initializes a new instance of the object.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Use | Gets or sets the access represented by the permission.
UseCapture | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
SoundPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


SoundPermission.Copy()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.Copy Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns an identical copy of the current permission.

Definition

Visual Basic .NET | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
Managed C++ | public: IPermission* Copy();
JScript .NET | public override function Copy() : IPermission;

Return Value

System.Security.IPermission .


SoundPermission.FromXml(SecurityElement)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.FromXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic .NET Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
Managed C++ public: void FromXml(
SecurityElement *securityElement
);
JScript .NET public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement.


SoundPermission.Intersect(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.Intersect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
Managed C++ public: IPermission* Intersect(
IPermission *target
);
JScript .NET public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


SoundPermission.IsSubsetOf(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.IsSubsetOf Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic .NET Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
Managed C++ public: bool IsSubsetOf(
IPermission *target
);
JScript .NET public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission.

Return Value

System.Boolean .


SoundPermission.IsUnrestricted()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.IsUnrestricted Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic .NET | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
Managed C++ | public: bool IsUnrestricted();
JScript .NET | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean .


SoundPermission.SoundPermission(PermissionState)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.SoundPermission Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the object.

Definition

Visual Basic .NET Public Sub New( _
ByVal state As PermissionState _
)
C# public SoundPermission(
PermissionState state
);
Managed C++ public: SoundPermission(
PermissionState state
);
JScript .NET public function SoundPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState.


SoundPermission.ToXml()

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.ToXml Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic .NET | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
Managed C++ | public: SecurityElement* ToXml();
JScript .NET | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement .


SoundPermission.Union(IPermission)

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.Union Method

 Language:
Note: This documentation is preliminary and is subject to change.

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic .NET Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
Managed C++ public: IPermission* Union(
IPermission *target
);
JScript .NET public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission.

Return Value

System.Security.IPermission .


SoundPermission.Use

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.Use Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the access represented by the permission.

Definition

Visual Basic .NET | Public Property Use As Boolean
C# | public bool Use { get; set; }
Managed C++ public: __property bool get_Use();
public: __property void set_Use(bool);
JScript .NET public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean .

This property is read/write.


SoundPermission.UseCapture

Microsoft DirectX 9.0 SDK Update (October 2004)

SoundPermission.UseCapture Property

Language:
Note: This documentation is preliminary and is subject to change.

Gets or sets the access represented by the permission.

Definition

Visual Basic .NET | Public Property UseCapture As Boolean
C# | public bool UseCapture { get; set; }
Managed C++ public: __property bool get_UseCapture();
public: __property void set_UseCapture(bool);
JScript .NET public function get UseCapture() : boolean
public function set UseCapture(boolean);

Property Value

System.Boolean .

This property is read/write.


Microsoft.DirectX

Note: This documentation is preliminary and is subject to change.

This namespace provides utility operations and data storage for Microsoft® DirectX® application programming, including exception handling, simple helper methods, and structures used for matrix, clipping plane, quaternion, and vector manipulation. The following tables list the members exposed by the Microsoft.DirectX namespace.

Classes

DirectXException | Describes the root exception class for all DirectX 9.0 for Managed Code exceptions.
DXHelp | Contains miscellaneous helper functions for DirectX 9.0 for Managed Code.
GraphicsStream | Contains a graphics data stream.
MatrixStack | Contains methods and properties that applications use to manipulate a matrix stack.
UnsafeNativeMethods Defines high-performance utility methods for matrix, plane, quaternion, and vector manipulation. This class is a container of classes. See the individual classes for more information.
Note: For programming in Microsoft Visual Basic® .NET or Microsoft JScript® .NET, use the methods of the Microsoft.DirectX Structures.
UnsafeNativeMethods.Matrix Describes and manipulates a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Matrix structure.
UnsafeNativeMethods.Plane Describes and manipulates a plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Plane structure.
UnsafeNativeMethods.Quaternion Describes and manipulates a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Quaternion structure.
UnsafeNativeMethods.Vector2 Describes and manipulates a vector in two-dimensional (2-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector2 structure.
UnsafeNativeMethods.Vector3 Describes and manipulates a vector in three-dimensional (3-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector3 structure.
UnsafeNativeMethods.Vector4 Describes and manipulates a vector in four-dimensional (4-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector4 structure.

Structures

Matrix | Describes and manipulates a matrix.
Plane | Describes and manipulates a plane.
Quaternion | Describes a quaternion.
Single16 | Describes and manipulates a 16-bit floating-point value.
Vector2 | Describes and manipulates a vector in two-dimensional (2-D) space.
Vector3 | Describes and manipulates a vector in three-dimensional (3-D) space.
Vector4 | Describes a vector in four-dimensional (4-D) space.


Microsoft.DirectX.DirectXException

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectXException Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes the root exception class for all Microsoft® DirectX® 9.0 for Managed Code exceptions.

Definition

Visual Basic .NET Public Class DirectXException
Inherits ApplicationException
C# | public class DirectXException : ApplicationException
Managed C++ | public __gc class DirectXException : public ApplicationException
JScript .NET | public class DirectXException extends ApplicationException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled.

Methods

Method | Description
DirectXException | Initializes a new instance of the DirectXException class.
static (Shared in Visual Basic .NET) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing.
static (Shared in Visual Basic .NET) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code.
static (Shared in Visual Basic .NET) GetExceptionFromResultInternal | Retrieves the Exception Leave Site object associated with the resultCode passed in.
static (Shared in Visual Basic .NET) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing.
ToString | Obtains the string representation of the current instance.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code.
static (Shared in Visual Basic .NET) LastError | Retrieves the error status for the last operation that failed.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
DirectPlayException
GraphicsException
GraphicsException
InputException
SoundException

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DirectXException.DirectXException

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectXException.DirectXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DirectXException class.

Overload List

public DirectXException();
protected DirectXException(SerializationInfo, StreamingContext);
public DirectXException(string);
public DirectXException(string, Exception);


DirectXException.DirectXException(SerializationInfo,StreamingContext)

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectXException.DirectXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DirectXException class.

Definition

Visual Basic .NET Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DirectXException(
SerializationInfo info,
StreamingContext context
);
Managed C++ protected: DirectXException(
SerializationInfo *info,
StreamingContext context
);
JScript .NET protected function DirectXException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info | System.Runtime.Serialization.SerializationInfo. A SerializationInfo Leave Site object that contains serialization information for the current exception.
context | System.Runtime.Serialization.StreamingContext. A StreamingContext Leave Site object that contains the context for the current exception.


DirectXException.DirectXException(String,Exception)

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectXException.DirectXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DirectXException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DirectXException(
string message,
Exception inner
);
Managed C++ public: DirectXException(
String *message,
Exception *inner
);
JScript .NET public function DirectXException(
message : String,
inner : Exception
);

Parameters

message | System.String. String that contains the error text for the exception.
inner | System.Exception. An Exception Leave Site object that contains the inner exception.


DirectXException.DirectXException(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectXException.DirectXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DirectXException class.

Definition

Visual Basic .NET Public Sub New( _
ByVal message As String _
)
C# public DirectXException(
string message
);
Managed C++ public: DirectXException(
String *message
);
JScript .NET public function DirectXException(
message : String
);

Parameters

message System.String. String that contains the error text for the exception.


DirectXException.DirectXException()

Microsoft DirectX 9.0 SDK Update (October 2004)

DirectXException.DirectXException Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the DirectXException class.

Definition

Visual Basic .NET | Public Sub New()
C# | public DirectXException();
Managed C++ | public: DirectXException();
JScript .NET | public function DirectXException();


DirectXException.EnableExceptions()

DirectXException.EnableExceptions Method

Note: This documentation is preliminary and is subject to change.

Enables Microsoft® DirectX® 9.0 for Managed Code exception throwing.

Definition

Visual Basic .NET | Public Shared Sub EnableExceptions()
C# | public static void EnableExceptions();
Managed C++ | public: static void EnableExceptions();
JScript .NET | public static function EnableExceptions();

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.GetDirectXErrorString(Int32)

DirectXException.GetDirectXErrorString Method

Note: This documentation is preliminary and is subject to change.

Retrieves a string that contains the name of the Microsoft® DirectX® error code.

Definition

Visual Basic .NET Public Shared Function GetDirectXErrorString( _
ByVal errorCode As Integer _
) As String
C# public static string GetDirectXErrorString(
int errorCode
);
Managed C++ public: static String* GetDirectXErrorString(
int errorCode
);
JScript .NET public static function GetDirectXErrorString(
errorCode : int
) : String;

Parameters

errorCode System.Int32. Result code of the failed method that caused this exception.

Return Value

System.String . A string that contains the name of the error code.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.GetExceptionFromResultInternal(Int32)

DirectXException.GetExceptionFromResultInternal Method

Note: This documentation is preliminary and is subject to change.

Retrieves the Exception Leave Site object associated with the resultCode passed in.

Definition

Visual Basic .NET Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
Managed C++ public: static Exception* GetExceptionFromResultInternal(
int resultCode
);
JScript .NET public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32. Result code of the failed method that caused this exception.

Return Value

System.Exception . An Exception Leave Site object that contains the new exception created from passing in resultCode.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.IgnoreExceptions()

DirectXException.IgnoreExceptions Method

Note: This documentation is preliminary and is subject to change.

Disables Microsoft® DirectX® 9.0 for Managed Code exception throwing.

Definition

Visual Basic .NET | Public Shared Sub IgnoreExceptions()
C# | public static void IgnoreExceptions();
Managed C++ | public: static void IgnoreExceptions();
JScript .NET | public static function IgnoreExceptions();

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.ToString()

DirectXException.ToString Method

Note: This documentation is preliminary and is subject to change.

Obtains the string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.ErrorCode

DirectXException.ErrorCode Property

Note: This documentation is preliminary and is subject to change.

Retrieves or sets the integer value result code.

Definition

Visual Basic .NET | Public Property ErrorCode As Integer
C# | public int ErrorCode { get; set; }
Managed C++ public: __property int get_ErrorCode();
public: __property void set_ErrorCode(int);
JScript .NET public function get ErrorCode() : int
public function set ErrorCode(int);

Property Value

System.Int32 . Integer that represents the result code.

This property is read/write.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.ErrorString

DirectXException.ErrorString Property

Note: This documentation is preliminary and is subject to change.

Retrieves the error string that is specific to Microsoft® DirectX® 9.0 for Managed Code.

Definition

Visual Basic .NET | Public ReadOnly Property ErrorString As String
C# | public string ErrorString { get; }
Managed C++ | public: __property String* get_ErrorString();
JScript .NET | public function get ErrorString() : String

Property Value

System.String . String that contains the error message.

This property is read-only.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.LastError

DirectXException.LastError Property

Note: This documentation is preliminary and is subject to change.

Retrieves the error status for the last operation that failed.

Definition

Visual Basic .NET | Public Shared ReadOnly Property LastError As Integer
C# | public static int LastError { get; }
Managed C++ | public: __property static int get_LastError();
JScript .NET | public static function get LastError() : int

Property Value

System.Int32 . Integer that represents the last error code.

This property is read-only.

Remarks

LastError should be called immediately if a method fails, otherwise a subsequent method call may overwrite the last error code.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


DirectXException.IsExceptionIgnored

DirectXException.IsExceptionIgnored Field

Note: This documentation is preliminary and is subject to change.

Specifies whether Microsoft® DirectX® 9.0 for Managed Code exceptions are enabled or disabled.

Definition

Visual Basic .NET | Public Shared IsExceptionIgnored As Boolean
C# | public static Boolean IsExceptionIgnored;
Managed C++ | public: static Boolean IsExceptionIgnored;
JScript .NET | public static var IsExceptionIgnored : Boolean

Field Value

System.Boolean . Value that is true if exceptions are enabled, or false if they are disabled.

This field is read/write.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.DXHelp

Microsoft DirectX 9.0 SDK Update (October 2004)

DXHelp Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains miscellaneous helper functions for Microsoft® DirectX® 9.0 for Managed Code.

Definition

Visual Basic .NET NotInheritable Public Class DXHelp
Inherits Object
C# | public sealed class DXHelp : Object
Managed C++ | public __gc __sealed class DXHelp : public Object
JScript .NET | public class DXHelp extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) CopyObjectDataToPointer | Copies a managed object to an unmanaged pointer.
static (Shared in Visual Basic .NET) CopyPointerDataToObject | Copies an unmanaged pointer to a managed object.
static (Shared in Visual Basic .NET) GetObjectSize | Retrieves an object's size.
static (Shared in Visual Basic .NET) GetTypeSize | Retrieves the size of the Type Leave Site.

Inheritance Hierarchy

Object Leave Site
DXHelp

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


DXHelp.CopyObjectDataToPointer(Object,IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

DXHelp.CopyObjectDataToPointer Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies a managed object to an unmanaged pointer.

Definition

Visual Basic .NET Public Shared Sub CopyObjectDataToPointer( _
ByVal objectData As Object, _
ByVal pointerData As IntPtr _
)
C# public static void CopyObjectDataToPointer(
object objectData,
IntPtr pointerData
);
Managed C++ public: static void CopyObjectDataToPointer(
Object *objectData,
IntPtr pointerData
);
JScript .NET public static function CopyObjectDataToPointer(
objectData : Object,
pointerData : IntPtr
);

Parameters

objectData | System.Object. Source Object Leave Site to copy to the unmanaged pointer.
pointerData | System.IntPtr. Destination pointer to which the source object is copied.

Remarks

This method copies strings and arrays of strings, but it is not a fast process.

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


DXHelp.CopyPointerDataToObject(Object,IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

DXHelp.CopyPointerDataToObject Method

 Language:
Note: This documentation is preliminary and is subject to change.

Copies an unmanaged pointer to a managed object.

Definition

Visual Basic .NET Public Shared Sub CopyPointerDataToObject( _
ByRef objectData As Object, _
ByVal pointerData As IntPtr _
)
C# public static void CopyPointerDataToObject(
ref object objectData,
IntPtr pointerData
);
Managed C++ public: static void CopyPointerDataToObject(
Object **objectData,
IntPtr pointerData
);
JScript .NET public static function CopyPointerDataToObject(
objectData : Object,
pointerData : IntPtr
);

Parameters

objectData | System.Object. [ref] Destination Object Leave Site to which the pointer data is copied.
pointerData | System.IntPtr. Source pointer data that is copied to the object.

Remarks

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


DXHelp.GetObjectSize(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

DXHelp.GetObjectSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an object's size.

Definition

Visual Basic .NET Public Shared Function GetObjectSize( _
ByVal objectSize As Object _
) As Integer
C# public static int GetObjectSize(
object objectSize
);
Managed C++ public: static int GetObjectSize(
Object *objectSize
);
JScript .NET public static function GetObjectSize(
objectSize : Object
) : int;

Parameters

objectSize System.Object. Reference to the Object Leave Site whose size is being returned.

Return Value

System.Int32 . Integer that represents the size of the object.

Remarks

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


DXHelp.GetTypeSize(Type)

Microsoft DirectX 9.0 SDK Update (October 2004)

DXHelp.GetTypeSize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the size of the Type Leave Site.

Definition

Visual Basic .NET Public Shared Function GetTypeSize( _
ByVal typeSize As Type _
) As Integer
C# public static int GetTypeSize(
Type typeSize
);
Managed C++ public: static int GetTypeSize(
Type *typeSize
);
JScript .NET public static function GetTypeSize(
typeSize : Type
) : int;

Parameters

typeSize System.Type. Reference to the Type Leave Site whose size is being returned.

Return Value

System.Int32 . Integer that represents the size of the type.

Remarks

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


Microsoft.DirectX.GraphicsStream

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream Class

Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams
  • Read and Write VertexBuffer Data With Arrays

Contains a graphics data stream.

Definition

Visual Basic .NET NotInheritable Public Class GraphicsStream
Inherits Stream
C# | public sealed class GraphicsStream : Stream
Managed C++ | public __gc __sealed class GraphicsStream : public Stream
JScript .NET | public class GraphicsStream extends Stream

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Close | Closes the current stream and releases any resources associated with it.
Dispose | Immediately releases the unmanaged resources used by an object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
Flush | Flushing the graphics stream is not supported.
GetHashCode | Returns the hash code for the current instance.
GraphicsStream | Initializes a new instance of the GraphicsStream class.
Read | Reads from the current stream and advances the position within it by the number of bytes read.
Seek | Sets the position within the current stream.
SetLength | Resizing the graphics stream is not supported.
Write | Writes to the current stream and advances the current position within it by the number of bytes written.

Properties

Property | Description
CanRead | Retrieves a value that indicates whether the current stream supports reading.
CanSeek | Retrieves a value that indicates whether the current stream supports seeking.
CanWrite | Retrieves a value that indicates whether the current stream supports writing.
InternalBuffer | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
InternalBufferPointer | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
InternalData | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
InternalDataPointer | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
Length | Retrieves the length of the stream in bytes.
Position | Retrieves or sets the position within the current stream.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Stream Leave Site
GraphicsStream

How Do I...?

Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Read and Write VertexBuffer Data With Arrays

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a FVF type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft® Direct3D® resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


GraphicsStream.Close()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Close Method

 Language:
Note: This documentation is preliminary and is subject to change.

Closes the current stream and releases any resources associated with it.

Definition

Visual Basic .NET | Overrides Public Sub Close()
C# | public override void Close();
Managed C++ | public: void Close();
JScript .NET | public override function Close();


GraphicsStream.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic .NET | Public Sub Dispose()
C# | public void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public function Dispose();


GraphicsStream.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


GraphicsStream.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~GraphicsStream();
Managed C++ | ~GraphicsStream();
JScript .NET | protected override function Finalize();


GraphicsStream.Flush()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Flush Method

 Language:
Note: This documentation is preliminary and is subject to change.

Flushing the graphics stream is not supported.

Definition

Visual Basic .NET | Overrides Public Sub Flush()
C# | public override void Flush();
Managed C++ | public: void Flush();
JScript .NET | public override function Flush();


GraphicsStream.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


GraphicsStream.GraphicsStream

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.GraphicsStream Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsStream class.

Overload List

public GraphicsStream(IntPtr, long, bool, bool);
public GraphicsStream(IntPtr, long, IntPtr);
public GraphicsStream(void, long, bool, bool);
public GraphicsStream(void, long, void);


GraphicsStream.GraphicsStream(IntPtr,Int64,Boolean,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.GraphicsStream Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic .NET Public Sub New( _
ByVal dataPointer As IntPtr, _
ByVal size As Long, _
ByVal read As Boolean, _
ByVal write As Boolean _
)
C# public GraphicsStream(
IntPtr dataPointer,
long size,
bool read,
bool write
);
Managed C++ public: GraphicsStream(
IntPtr dataPointer,
long size,
bool read,
bool write
);
JScript .NET public function GraphicsStream(
dataPointer : IntPtr,
size : long,
read : boolean,
write : boolean
);

Parameters

dataPointer | System.IntPtr. Reference to the graphics data in the stream buffer.
size | System.Int64. Size of the data referenced by dataPointer.
read | System.Boolean. Set to true if the buffer is readable; otherwise, false.
write | System.Boolean. Set to true if buffer is writable; otherwise, false.


GraphicsStream.GraphicsStream(Void,Int64,Boolean,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.GraphicsStream Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pDataPointer As Void, _
ByVal size As Long, _
ByVal read As Boolean, _
ByVal write As Boolean _
)
C# public GraphicsStream(
void pDataPointer,
long size,
bool read,
bool write
);
Managed C++ public: GraphicsStream(
void pDataPointer,
long size,
bool read,
bool write
);
JScript .NET public function GraphicsStream(
pDataPointer : void,
size : long,
read : boolean,
write : boolean
);

Parameters

pDataPointer | System.Void. Reference to the graphics data in the stream buffer.
size | System.Int64. Size of the data referenced by dataPointer.
read | System.Boolean. Set to true if the buffer is readable; otherwise, false.
write | System.Boolean. Set to true if buffer is writable; otherwise, false.


GraphicsStream.GraphicsStream(IntPtr,Int64,IntPtr)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.GraphicsStream Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic .NET Public Sub New( _
ByVal dataPointer As IntPtr, _
ByVal size As Long, _
ByVal bufferPointer As IntPtr _
)
C# public GraphicsStream(
IntPtr dataPointer,
long size,
IntPtr bufferPointer
);
Managed C++ public: GraphicsStream(
IntPtr dataPointer,
long size,
IntPtr bufferPointer
);
JScript .NET public function GraphicsStream(
dataPointer : IntPtr,
size : long,
bufferPointer : IntPtr
);

Parameters

dataPointer | System.IntPtr. Reference to the graphics data in the stream buffer.
size | System.Int64. Size of the data referenced by dataPointer.
bufferPointer | System.IntPtr. Reference to the actual stream buffer.


GraphicsStream.GraphicsStream(Void,Int64,Void)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.GraphicsStream Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic .NET Public Sub New( _
ByVal pDataPointer As Void, _
ByVal size As Long, _
ByVal bufferPointer As Void _
)
C# public GraphicsStream(
void pDataPointer,
long size,
void bufferPointer
);
Managed C++ public: GraphicsStream(
void pDataPointer,
long size,
void bufferPointer
);
JScript .NET public function GraphicsStream(
pDataPointer : void,
size : long,
bufferPointer : void
);

Parameters

pDataPointer | System.Void. Reference to the graphics data in the stream buffer.
size | System.Int64. Size of the data referenced by dataPointer.
bufferPointer | System.Void. Reference to the actual stream buffer.


GraphicsStream.Read

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads from the current stream and advances the position within it by the number of bytes read.

Overload List

public string Read(bool);
public override int Read(byte[], int, int);
public ValueType Read(Type);
public Array Read(Type, int[]);

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads from the current stream and advances the position within it by the number of bytes read.

Definition

Visual Basic .NET Public Function Read( _
ByVal unicode As Boolean _
) As String
C# public string Read(
bool unicode
);
Managed C++ public: String* Read(
bool unicode
);
JScript .NET public function Read(
unicode : boolean
) : String;

Parameters

unicode System.Boolean. Set to true if the graphics stream is Unicode. Set to false if the graphics stream is ASCII.

Return Value

System.String . A String Leave Site that contains the data to read from the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Type,Int32[])

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads from the current stream and advances the position within it by the number of bytes read.

Definition

Visual Basic .NET Public Function Read( _
ByVal returnType As Type, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
Type returnType,
int[] ranks
);
Managed C++ public: Array* Read(
Type *returnType,
int ranks __gc[]
);
JScript .NET public function Read(
returnType : Type,
ranks : int[]
) : Array;

Parameters

returnType | System.Type. Value that indicates the Type Leave Site of the returned array.
ranks | System.Int32[]. An array of Int32 Leave Site values that represent the size of each dimension of the returning array.

Return Value

System.Array . An Array Leave Site of type returnType that contains the data read from the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Type)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads from the current stream and advances the position within it by the number of bytes read.

Definition

Visual Basic .NET Public Function Read( _
ByVal returnType As Type _
) As ValueType
C# public ValueType Read(
Type returnType
);
Managed C++ public: ValueType* Read(
Type *returnType
);
JScript .NET public function Read(
returnType : Type
) : ValueType;

Parameters

returnType System.Type. Value that indicates the Type Leave Site of the returned array.

Return Value

System.ValueType . A ValueType Leave Site of type returnType that contains the data read from the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Byte[],Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Read Method

 Language:
Note: This documentation is preliminary and is subject to change.

Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

Definition

Visual Basic .NET Overrides Public Function Read( _
ByVal buffer() As Byte, _
ByVal offset As Integer, _
ByVal count As Integer _
) As Integer
C# public override int Read(
byte[] buffer,
int offset,
int count
);
Managed C++ public: int Read(
Byte buffer __gc[],
int offset,
int count
);
JScript .NET public override function Read(
buffer : byte[],
offset : int,
count : int
) : int;

Parameters

buffer | System.Byte[]. Reference to a Byte Leave Site array that is used as the read buffer.
offset | System.Int32. Value that specifies the offset of the data read from buffer.
count | System.Int32. Value that specifies the number of bytes to read.

Return Value

System.Int32 . Integer that represents the number of bytes read into buffer from the graphics stream.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Seek(Int64,SeekOrigin)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Seek Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets the position within the current stream.

Definition

Visual Basic .NET Overrides Public Function Seek( _
ByVal newposition As Long, _
ByVal origin As SeekOrigin _
) As Long
C# public override long Seek(
long newposition,
SeekOrigin origin
);
Managed C++ public: long Seek(
long newposition,
SeekOrigin origin
);
JScript .NET public override function Seek(
newposition : long,
origin : SeekOrigin
) : long;

Parameters

newposition | System.Int64. Value that represents the new position within the stream buffer.
origin | System.IO.SeekOrigin. Member of the SeekOrigin Leave Site enumeration that specifies where to begin seeking.

Return Value

System.Int64 . New position within the stream buffer.

Remarks

Exceptions
ArgumentException Leave Site The new location is either less than 0 or greater than the stream buffer's data size.


GraphicsStream.SetLength(Int64)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.SetLength Method

 Language:
Note: This documentation is preliminary and is subject to change.

Resizing the graphics stream is not supported.

Definition

Visual Basic .NET Overrides Public Sub SetLength( _
ByVal newLength As Long _
)
C# public override void SetLength(
long newLength
);
Managed C++ public: void SetLength(
long newLength
);
JScript .NET public override function SetLength(
newLength : long
);

Parameters

newLength System.Int64.


GraphicsStream.Write

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes to the current stream and advances the current position within it by the number of bytes written.

Overload List

public void Write(Array);
public override void Write(byte[], int, int);
public void Write(string);
public void Write(string, bool);
public void Write(ValueType);

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(String)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic .NET Public Sub Write( _
ByVal value As String _
)
C# public void Write(
string value
);
Managed C++ public: void Write(
String *value
);
JScript .NET public function Write(
value : String
);

Parameters

value System.String. Reference to a String Leave Site that contains the data to write into the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(String,Boolean)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic .NET Public Sub Write( _
ByVal value As String, _
ByVal isUnicodeString As Boolean _
)
C# public void Write(
string value,
bool isUnicodeString
);
Managed C++ public: void Write(
String *value,
bool isUnicodeString
);
JScript .NET public function Write(
value : String,
isUnicodeString : boolean
);

Parameters

value | System.String. Reference to a String Leave Site that contains the data to write into the stream buffer.
isUnicodeString | System.Boolean. Set to true if the graphics stream is Unicode. Set to false if the graphics stream is ASCII.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(Array)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic .NET Public Sub Write( _
ByVal value As Array _
)
C# public void Write(
Array value
);
Managed C++ public: void Write(
Array *value
);
JScript .NET public function Write(
value : Array
);

Parameters

value System.Array. Reference to an Array Leave Site that contains the data to write into the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(ValueType)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic .NET Public Sub Write( _
ByVal value As ValueType _
)
C# public void Write(
ValueType value
);
Managed C++ public: void Write(
ValueType *value
);
JScript .NET public function Write(
value : ValueType
);

Parameters

value System.ValueType. Value that specifies the ValueType Leave Site of the data to write into the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(Byte[],Int32,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Write Method

 Language:
Note: This documentation is preliminary and is subject to change.

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic .NET Overrides Public Sub Write( _
ByVal buffer() As Byte, _
ByVal offset As Integer, _
ByVal count As Integer _
)
C# public override void Write(
byte[] buffer,
int offset,
int count
);
Managed C++ public: void Write(
Byte buffer __gc[],
int offset,
int count
);
JScript .NET public override function Write(
buffer : byte[],
offset : int,
count : int
);

Parameters

buffer | System.Byte[]. Reference to a Byte Leave Site array that is used as the write buffer.
offset | System.Int32. Value that specifies the offset of the data to write from buffer.
count | System.Int32. Value that specifies the number of bytes to write.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.CanRead

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.CanRead Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether the current stream supports reading.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property CanRead As Boolean
C# | public override bool CanRead { get; }
Managed C++ | public: __property virtual bool get_CanRead();
JScript .NET | public function get CanRead() : boolean

Property Value

System.Boolean . Value that is true if the stream supports reading, or false if it does not.

This property is read-only.


GraphicsStream.CanSeek

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.CanSeek Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether the current stream supports seeking.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property CanSeek As Boolean
C# | public override bool CanSeek { get; }
Managed C++ | public: __property virtual bool get_CanSeek();
JScript .NET | public function get CanSeek() : boolean

Property Value

System.Boolean . Value that is true if the stream supports seeking, or false if it does not.

This property is read-only.


GraphicsStream.CanWrite

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.CanWrite Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates whether the current stream supports writing.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property CanWrite As Boolean
C# | public override bool CanWrite { get; }
Managed C++ | public: __property virtual bool get_CanWrite();
JScript .NET | public function get CanWrite() : boolean

Property Value

System.Boolean . Value that is true if the stream supports writing, or false if it does not.

This property is read-only.


GraphicsStream.InternalBuffer

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.InternalBuffer Property

Language:
Note: This documentation is preliminary and is subject to change.

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic .NET | Public ReadOnly Property InternalBuffer As IntPtr
C# | public IntPtr InternalBuffer { get; }
Managed C++ | public: __property IntPtr get_InternalBuffer();
JScript .NET | public function get InternalBuffer() : IntPtr

Property Value

System.IntPtr . Retrieves a pointer to the stream object's internal buffer.

This property is read-only.


GraphicsStream.InternalBufferPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.InternalBufferPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic .NET | Public ReadOnly Property InternalBufferPointer
C# | public void InternalBufferPointer { get; }
Managed C++ | public: __property void get_InternalBufferPointer();
JScript .NET | public function get InternalBufferPointer() : void

Property Value

System.Void . Retrieves a void pointer to the stream object's internal buffer.

This property is read-only.


GraphicsStream.InternalData

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.InternalData Property

Language:
Note: This documentation is preliminary and is subject to change.

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic .NET | Public ReadOnly Property InternalData As IntPtr
C# | public IntPtr InternalData { get; }
Managed C++ | public: __property IntPtr get_InternalData();
JScript .NET | public function get InternalData() : IntPtr

Property Value

System.IntPtr . Retrieves a pointer to the stream object's internal data.

This property is read-only.


GraphicsStream.InternalDataPointer

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.InternalDataPointer Property

Language:
Note: This documentation is preliminary and is subject to change.

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic .NET | Public ReadOnly Property InternalDataPointer
C# | public void InternalDataPointer { get; }
Managed C++ | public: __property void get_InternalDataPointer();
JScript .NET | public function get InternalDataPointer() : void

Property Value

System.Void . Retrieves a void pointer to the stream object's internal data.

This property is read-only.


GraphicsStream.Length

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Length Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the length of the stream in bytes.

Definition

Visual Basic .NET | Overrides Public ReadOnly Property Length As Long
C# | public override long Length { get; }
Managed C++ | public: __property virtual long get_Length();
JScript .NET | public function get Length() : long

Property Value

System.Int64 . Stream length in bytes.

This property is read-only.


GraphicsStream.Position

Microsoft DirectX 9.0 SDK Update (October 2004)

GraphicsStream.Position Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the position within the current stream.

Definition

Visual Basic .NET | Overrides Public Property Position As Long
C# | public override long Position { get; set; }
Managed C++ public: __property virtual long get_Position();
public: __property virtual void set_Position(long);
JScript .NET public function get Position() : long
public function set Position(long);

Property Value

System.Int64 . Value that represents the position to set or retrieve.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site The position is greater than the stream buffer's data size.


Microsoft.DirectX.UnsafeNativeMethods.Matrix

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the methods of the Microsoft.DirectX.Matrix structure.

Definition

Visual Basic .NET NotInheritable Public Class Matrix
Inherits Object
C# | public sealed class Matrix : Object
Managed C++ | public __gc __sealed class Matrix : public Object
JScript .NET | public class Matrix extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic .NET) AffineTransformation2D Builds a 2-D affine transformation matrix in the xy plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Invert Calculates the inverse of a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) LookAtLH Builds a left-handed look-at matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) LookAtRH Builds a right-handed look-at matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Multiply Determines the product of two matrices.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) MultiplyTranspose Calculates the transposed product of two matrices.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) RotationAxis Builds a matrix that rotates around an arbitrary axis.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) RotationQuaternion Builds a matrix from a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Scaling Builds a matrix that scales along the x-axis, y-axis, and z-axis.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Transformation Builds a transformation matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Transformation2D Builds a 2-D transformation matrix in the xy plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Translation Builds a matrix using specified offsets.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Matrix

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Microsoft.DirectX.Matrix Structure


UnsafeNativeMethods.Matrix.AffineTransformation2D(Matrix,Single,Vector2,Single,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.AffineTransformation2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a 2-D affine transformation matrix in the xy plane.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function AffineTransformation2D( _
ByVal pOut As Matrix, _
ByVal scaling As Single, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix AffineTransformation2D(
Matrix pOut,
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
Managed C++ public: static Matrix AffineTransformation2D(
Matrix pOut,
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript .NET public static function AffineTransformation2D(
pOut : Matrix,
scaling : float,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that is an affine transformation matrix.
scaling | System.Single. Scaling factor. A value of zero indicates no scaling.
rotationCenter | Microsoft.DirectX.Vector2. A Vector2 structure that represents a point identifying the center of rotation. Use an empty Vector2 for no rotation.
rotation | System.Single. Angle of rotation. A value of zero indicates no rotation.
translation | Microsoft.DirectX.Vector2. A Vector2 structure that represents the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is an affine transformation matrix.

Remarks

The AffineTransformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

Mout = Ms * (Mrc)-1 * Mr * Mrc * Mt

where:

  • Mout = output matrix (pOut)
  • Ms = scaling matrix (scaling)
  • Mrc = center of rotation matrix (rotationCenter)
  • Mr = rotation matrix (rotation)
  • Mt = translation matrix (translation)

The return value for this method is the same value returned in the pOut parameter. Resultantly, the AffineTransformation2D method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.AffineTransformation2D


UnsafeNativeMethods.Matrix.Invert

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the inverse of a matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Overload List

public static Matrix Invert(Matrix, Matrix);
public static Matrix Invert(Matrix, float, Matrix);

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Invert method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Invert


UnsafeNativeMethods.Matrix.Invert(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the inverse of a matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Invert( _
ByVal pOut As Matrix, _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
Matrix pOut,
Matrix source
);
Managed C++ public: static Matrix Invert(
Matrix pOut,
Matrix source
);
JScript .NET public static function Invert(
pOut : Matrix,
source : Matrix
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that is the result of the operation.
source | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Invert method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Invert


UnsafeNativeMethods.Matrix.Invert(Matrix,Single,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the inverse of a matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Invert( _
ByVal pOut As Matrix, _
ByVal determinant As Single, _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
Matrix pOut,
float determinant,
Matrix source
);
Managed C++ public: static Matrix Invert(
Matrix pOut,
float determinant,
Matrix source
);
JScript .NET public static function Invert(
pOut : Matrix,
determinant : float,
source : Matrix
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that is the result of the operation.
determinant | System.Single. A Single Leave Site value that contains the determinant of the matrix. If the determinant is not needed, the parameter is omitted.
source | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Invert method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Invert


UnsafeNativeMethods.Matrix.LookAtLH(Matrix,Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.LookAtLH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a left-handed look-at matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function LookAtLH( _
ByVal pOut As Matrix, _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtLH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
Managed C++ public: static Matrix LookAtLH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript .NET public static function LookAtLH(
pOut : Matrix,
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that is a left-handed look-at matrix.
cameraPosition | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera look-at target.
cameraUpVector | Microsoft.DirectX.Vector3. A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a left-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraTarget - cameraPosition)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

The return value for this method is the same value returned in the pOut parameter. Resultantly, the LookAtLH method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.LookAtRH
  • Microsoft.DirectX.Matrix.LookAtLH


UnsafeNativeMethods.Matrix.LookAtRH(Matrix,Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.LookAtRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a right-handed look-at matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function LookAtRH( _
ByVal pOut As Matrix, _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtRH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
Managed C++ public: static Matrix LookAtRH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript .NET public static function LookAtRH(
pOut : Matrix,
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that is a right-handed look-at matrix.
cameraPosition | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera look-at target.
cameraUpVector | Microsoft.DirectX.Vector3. A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a right-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraPosition - cameraTarget)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

The return value for this method is the same value returned in the pOut parameter. Resultantly, the LookAtRH method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.LookAtLH
  • Microsoft.DirectX.Matrix.LookAtRH


UnsafeNativeMethods.Matrix.Multiply(Matrix,Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of two matrices.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Multiply( _
ByVal pOut As Matrix, _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Multiply(
Matrix pOut,
Matrix left,
Matrix right
);
Managed C++ public: static Matrix Multiply(
Matrix pOut,
Matrix left,
Matrix right
);
JScript .NET public static function Multiply(
pOut : Matrix,
left : Matrix,
right : Matrix
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that is the product of two matrices.
left | Microsoft.DirectX.Matrix. Source Matrix structure.
right | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the product of two matrices.

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Multiply method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Quaternion.Multiply
  • Microsoft.DirectX.Matrix.Multiply


UnsafeNativeMethods.Matrix.MultiplyTranspose(Matrix,Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.MultiplyTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the transposed product of two matrices.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function MultiplyTranspose( _
ByVal pOut As Matrix, _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix MultiplyTranspose(
Matrix pOut,
Matrix left,
Matrix right
);
Managed C++ public: static Matrix MultiplyTranspose(
Matrix pOut,
Matrix left,
Matrix right
);
JScript .NET public static function MultiplyTranspose(
pOut : Matrix,
left : Matrix,
right : Matrix
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that is the product and transposition of two matrices.
left | Microsoft.DirectX.Matrix. Source Matrix structure.
right | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix .

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the MultiplyTranspose method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.Multiply
  • Microsoft.DirectX.UnsafeNativeMethods.Quaternion.Multiply
  • Microsoft.DirectX.Matrix.Multiply


UnsafeNativeMethods.Matrix.RotationAxis(Matrix,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.RotationAxis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that rotates around an arbitrary axis.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function RotationAxis( _
ByVal pOut As Matrix, _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationAxis(
Matrix pOut,
Vector3 axisRotation,
float angle
);
Managed C++ public: static Matrix RotationAxis(
Matrix pOut,
Vector3 axisRotation,
float angle
);
JScript .NET public static function RotationAxis(
pOut : Matrix,
axisRotation : Vector3,
angle : float
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. Rotated Matrix structure.
axisRotation | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the axis about which to rotate the matrix.
angle | System.Single.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

Remarks

The input rotation angle is in radians.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the RotationAxis method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.RotationAxis


UnsafeNativeMethods.Matrix.RotationQuaternion(Matrix,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.RotationQuaternion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix from a quaternion.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function RotationQuaternion( _
ByVal pOut As Matrix, _
ByVal quat As Quaternion _
) As Matrix
C# public static Matrix RotationQuaternion(
Matrix pOut,
Quaternion quat
);
Managed C++ public: static Matrix RotationQuaternion(
Matrix pOut,
Quaternion quat
);
JScript .NET public static function RotationQuaternion(
pOut : Matrix,
quat : Quaternion
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. Rotated Matrix structure.
quat | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

Remarks

For information about how to calculate quaternion values from a direction vector (x, y, z) and an angle of rotation, see Quaternion.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the RotationQuaternion method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.RotationAxis
  • Microsoft.DirectX.Matrix.RotationQuaternion


UnsafeNativeMethods.Matrix.Scaling(Matrix,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Scaling Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Scaling( _
ByVal pOut As Matrix, _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Scaling(
Matrix pOut,
Vector3 v
);
Managed C++ public: static Matrix Scaling(
Matrix pOut,
Vector3 v
);
JScript .NET public static function Scaling(
pOut : Matrix,
v : Vector3
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. Scaled Matrix structure.
v | Microsoft.DirectX.Vector3. A Vector3 structure containing three values that represent the scaling factors applied along the x-axis, y-axis, and z-axis.

Return Value

Microsoft.DirectX.Matrix . Scaled Matrix structure.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Scaling method can be used as a parameter for another method.


UnsafeNativeMethods.Matrix.Transformation(Matrix,Vector3,Quaternion,Vector3,Vector3,Quaternion,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Transformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a transformation matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Transformation( _
ByVal pOut As Matrix, _
ByVal scalingCenter As Vector3, _
ByVal scalingRotation As Quaternion, _
ByVal scalingFactor As Vector3, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
) As Matrix
C# public static Matrix Transformation(
Matrix pOut,
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
Managed C++ public: static Matrix Transformation(
Matrix pOut,
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript .NET public static function Transformation(
pOut : Matrix,
scalingCenter : Vector3,
scalingRotation : Quaternion,
scalingFactor : Vector3,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. Resulting Matrix structure.
scalingCenter | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the scaling center point.
scalingRotation | Microsoft.DirectX.Quaternion. A Quaternion structure that specifies the scaling rotation. Use Quaternion.Identity to specify no scaling.
scalingFactor | Microsoft.DirectX.Vector3. A Vector3 structure that is the scaling vector.
rotationCenter | Microsoft.DirectX.Vector3. A Vector3 structure that is a point identifying the center of rotation.
rotation | Microsoft.DirectX.Quaternion. A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation | Microsoft.DirectX.Vector3. A Vector3 structure that represents the translation. Use Vector3.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix . Resulting Matrix structure.

Remarks

The Transformation method calculates the transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (the return value)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scalingFactor)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Transformation method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Transformation
  • Transformation2D


UnsafeNativeMethods.Matrix.Transformation2D(Matrix,Vector2,Single,Vector2,Vector2,Single,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Transformation2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a 2-D transformation matrix in the xy plane.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Transformation2D( _
ByVal pOut As Matrix, _
ByVal scalingCenter As Vector2, _
ByVal scalingRotation As Single, _
ByVal scaling As Vector2, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix Transformation2D(
Matrix pOut,
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
Managed C++ public: static Matrix Transformation2D(
Matrix pOut,
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript .NET public static function Transformation2D(
pOut : Matrix,
scalingCenter : Vector2,
scalingRotation : float,
scaling : Vector2,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that contains the transformation matrix.
scalingCenter | Microsoft.DirectX.Vector2. A Vector2 structure that is a point identifying the scaling center.
scalingRotation | System.Single. Scaling rotation factor. Use a zero value to specify no rotation.
scaling | Microsoft.DirectX.Vector2. A Vector2 structure that is a point identifying the scale. Use Vector2.Empty to specify no scaling.
rotationCenter | Microsoft.DirectX.Vector2. A Vector2 structure that is a point identifying the rotation center.
rotation | System.Single. Angle of rotation, in radians.
translation | Microsoft.DirectX.Vector2. A Vector2 structure that identifies the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that contains the transformation matrix.

Remarks

The Transformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order:

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (pOut)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scaling)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Transformation2D method can be used as a parameter for another method.

For 3-D transformations, use Transformation.

See Also

  • Microsoft.DirectX.Matrix.Transformation2D
  • Transformation


UnsafeNativeMethods.Matrix.Translation(Matrix,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Matrix.Translation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix using specified offsets.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Translation( _
ByVal pOut As Matrix, _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Translation(
Matrix pOut,
Vector3 v
);
Managed C++ public: static Matrix Translation(
Matrix pOut,
Vector3 v
);
JScript .NET public static function Translation(
pOut : Matrix,
v : Vector3
) : Matrix;

Parameters

pOut | Microsoft.DirectX.Matrix. A Matrix structure that contains a translated transformation matrix.
v | Microsoft.DirectX.Vector3. A Vector3 structure that contains the x-coordinate, y-coordinate, and z-coordinate offsets.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that contains a translated transformation matrix.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Translation method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Translation


Microsoft.DirectX.MatrixStack

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack Class

Language:
Note: This documentation is preliminary and is subject to change.

Contains methods and properties that applications use to manipulate a matrix stack.

Definition

Visual Basic .NET Public Class MatrixStack
Inherits MarshalByRefObject
Implements IDisposable
C# public class MatrixStack : MarshalByRefObject,
IDisposable
Managed C++ public __gc class MatrixStack : public MarshalByRefObject,
IDisposable
JScript .NET public class MatrixStack extends MarshalByRefObject
implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
LoadIdentity | Loads identity in the current matrix.
LoadMatrix | Loads a given matrix into the current matrix.
MatrixStack | Initializes a new instance of the MatrixStack class.
MultiplyMatrix | Determines the product of the current matrix and a given matrix.
MultiplyMatrixLocal | Determines the product of a given matrix and the current matrix.
Pop | Removes the current matrix from the top of the stack.
Push | Adds a matrix to the stack.
raise_Disposing | Raises a MatrixStack.Disposing event when called from within a derived class.
RotateAxis | Determines the product of the current matrix and the computed rotation matrix.
RotateAxisLocal | Determines the product of the current matrix and the computed rotation matrix.
RotateYawPitchRoll | Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.
RotateYawPitchRollLocal | Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.
Scale | Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).
ScaleLocal | Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.
Translate | Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).
TranslateLocal | Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Properties

Property | Description
Disposed | Retrieves a value that is true if the object is disposed; otherwise the value is false.
Top | Retrieves the current matrix at the top of the stack.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
MatrixStack

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


MatrixStack.Dispose()

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Dispose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic .NET | Overrides Public Sub Dispose()
C# | public override void Dispose();
Managed C++ | public: void Dispose();
JScript .NET | public override function Dispose();

See Also

  • MatrixStack.Disposed
  • MatrixStack.Disposing


MatrixStack.Finalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Finalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic .NET | Overrides Protected Sub Finalize()
C# | ~MatrixStack();
Managed C++ | ~MatrixStack();
JScript .NET | protected override function Finalize();


MatrixStack.LoadIdentity()

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.LoadIdentity Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads identity in the current matrix.

Definition

Visual Basic .NET | Public Sub LoadIdentity()
C# | public void LoadIdentity();
Managed C++ | public: void LoadIdentity();
JScript .NET | public function LoadIdentity();

Remarks

In an identity matrix, all coefficients are 0.0 except the [1,1][2,2][3,3][4,4] coefficients, which are set to 1.0. The identity matrix is special in that when it is applied to vertices, they are unchanged. The identity matrix is used as the starting point for matrices that modify vertex values to create rotations, translations, and any other transformations that can be represented by a 4x4 matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


MatrixStack.LoadMatrix(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.LoadMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Loads a given matrix into the current matrix.

Definition

Visual Basic .NET Public Sub LoadMatrix( _
ByVal value As Matrix _
)
C# public void LoadMatrix(
Matrix value
);
Managed C++ public: void LoadMatrix(
Matrix value
);
JScript .NET public function LoadMatrix(
value : Matrix
);

Parameters

value Microsoft.DirectX.Matrix. New Matrix to load into the current matrix.

Remarks

This method does not add an item to the stack; rather, it replaces the current matrix with the supplied matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.LoadIdentity


MatrixStack.MatrixStack()

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.MatrixStack Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the MatrixStack class.

Definition

Visual Basic .NET | Public Sub New()
C# | public MatrixStack();
Managed C++ | public: MatrixStack();
JScript .NET | public function MatrixStack();


MatrixStack.MultiplyMatrix(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.MultiplyMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and a given matrix.

Definition

Visual Basic .NET Public Sub MultiplyMatrix( _
ByVal value As Matrix _
)
C# public void MultiplyMatrix(
Matrix value
);
Managed C++ public: void MultiplyMatrix(
Matrix value
);
JScript .NET public function MultiplyMatrix(
value : Matrix
);

Parameters

value Microsoft.DirectX.Matrix. A Matrix to multiply with the current matrix.

Remarks

This method right-multiplies the given matrix by the current matrix (transformation is about the current world origin). The method does not add an item to the stack; rather, it replaces the current matrix with the product of the current matrix and the given matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.MultiplyMatrixLocal


MatrixStack.MultiplyMatrixLocal(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.MultiplyMatrixLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a given matrix and the current matrix.

Definition

Visual Basic .NET Public Sub MultiplyMatrixLocal( _
ByVal value As Matrix _
)
C# public void MultiplyMatrixLocal(
Matrix value
);
Managed C++ public: void MultiplyMatrixLocal(
Matrix value
);
JScript .NET public function MultiplyMatrixLocal(
value : Matrix
);

Parameters

value Microsoft.DirectX.Matrix. A Matrix to multiply with the current matrix.

Remarks

This method left-multiplies the given matrix by the current matrix (transformation is about the local origin of the object). The method does not add an item to the stack; rather, it replaces the current matrix with the product of the given matrix and the current matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.MultiplyMatrixLocal


MatrixStack.Pop()

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Pop Method

 Language:
Note: This documentation is preliminary and is subject to change.

Removes the current matrix from the top of the stack.

Definition

Visual Basic .NET | Public Sub Pop()
C# | public void Pop();
Managed C++ | public: void Pop();
JScript .NET | public function Pop();

Remarks

This method decrements the count of items on the stack by 1, effectively removing the current matrix from the top of the stack and promoting a different matrix to that position. If the current count of items on the stack is 0, this method returns without taking any action. If the current count of items is 1, the method empties the stack.

See Also

  • MatrixStack.Push
  • MatrixStack.Top


MatrixStack.Push()

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Push Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds a matrix to the stack.

Definition

Visual Basic .NET | Public Sub Push()
C# | public void Push();
Managed C++ | public: void Push();
JScript .NET | public function Push();

Remarks

This method increments the count of items on the stack by 1. The stack grows dynamically as more items are added.

See Also

  • MatrixStack.Pop
  • MatrixStack.Top


MatrixStack.raise_Disposing(Object,EventArgs)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.raise_Disposing Method

 Language:
Note: This documentation is preliminary and is subject to change.

Raises a MatrixStack.Disposing event when called from within a derived class.

Definition

Visual Basic .NET Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
Managed C++ protected: void raise_Disposing(
Object *i1,
EventArgs *i2
);
JScript .NET protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 | System.Object. Invoking object reference. Should be the current object.
i2 | System.EventArgs. Arguments to pass into the event handler.

Remarks

This method is a protected member.


MatrixStack.RotateAxis(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.RotateAxis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed rotation matrix.

Definition

Visual Basic .NET Public Sub RotateAxis( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxis(
Vector3 axisRotation,
float angle
);
Managed C++ public: void RotateAxis(
Vector3 axisRotation,
float angle
);
JScript .NET public function RotateAxis(
axisRotation : Vector3,
angle : float
);

Parameters

axisRotation | Microsoft.DirectX.Vector3. A Vector3 structure that represents the rotation axis to use for the calculation.
angle | System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Remarks

This method right-multiplies the current matrix by the computed rotation matrix, counterclockwise about the given axis with the given angle (rotation is about the current world origin).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxisLocal
  • MatrixStack.RotateYawPitchRoll
  • MatrixStack.RotateYawPitchRollLocal


MatrixStack.RotateAxisLocal(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.RotateAxisLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed rotation matrix.

Definition

Visual Basic .NET Public Sub RotateAxisLocal( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxisLocal(
Vector3 axisRotation,
float angle
);
Managed C++ public: void RotateAxisLocal(
Vector3 axisRotation,
float angle
);
JScript .NET public function RotateAxisLocal(
axisRotation : Vector3,
angle : float
);

Parameters

axisRotation | Microsoft.DirectX.Vector3. A Vector3 structure that represents the rotation axis to use for the calculation.
angle | System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Remarks

This method left-multiplies the current matrix with the computed rotation matrix, counterclockwise around the given axis with the given angle (rotation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxis
  • MatrixStack.RotateYawPitchRoll
  • MatrixStack.RotateYawPitchRollLocal


MatrixStack.RotateYawPitchRoll(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.RotateYawPitchRoll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.

Definition

Visual Basic .NET Public Sub RotateYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
Managed C++ public: void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript .NET public function RotateYawPitchRoll(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw | System.Single. Floating-point value that represents the yaw around the y-axis, in radians.
pitch | System.Single. Floating-point value that represents the pitch around the x-axis, in radians.
roll | System.Single. Floating-point value that represents the roll around the z-axis, in radians.

Remarks

This method right-multiplies the current matrix by the computed rotation matrix. All angles are counterclockwise and rotation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxis
  • MatrixStack.RotateAxisLocal
  • MatrixStack.RotateYawPitchRollLocal


MatrixStack.RotateYawPitchRollLocal(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.RotateYawPitchRollLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.

Definition

Visual Basic .NET Public Sub RotateYawPitchRollLocal( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRollLocal(
float yaw,
float pitch,
float roll
);
Managed C++ public: void RotateYawPitchRollLocal(
float yaw,
float pitch,
float roll
);
JScript .NET public function RotateYawPitchRollLocal(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw | System.Single. Floating-point value that represents the yaw around the y-axis, in radians.
pitch | System.Single. Floating-point value that represents the pitch around the x-axis, in radians.
roll | System.Single. Floating-point value that represents the roll around the z-axis, in radians.

Remarks

This method left-multiplies the current matrix with the computed rotation matrix. All angles are counterclockwise and rotation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxis
  • MatrixStack.RotateAxisLocal
  • MatrixStack.RotateYawPitchRoll


MatrixStack.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).

Overload List

public void Scale(float, float, float);
public void Scale(Vector3);

Remarks

This method right-multiplies the current matrix by the computed scale matrix. The transformation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.ScaleLocal


MatrixStack.Scale(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).

Definition

Visual Basic .NET Public Sub Scale( _
ByVal scale As Vector3 _
)
C# public void Scale(
Vector3 scale
);
Managed C++ public: void Scale(
Vector3 scale
);
JScript .NET public function Scale(
scale : Vector3
);

Parameters

scale Microsoft.DirectX.Vector3. A Vector3 object that represents the scale values to use in the calculation.

Remarks

This method right-multiplies the current matrix by the computed scale matrix. The transformation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.ScaleLocal


MatrixStack.Scale(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).

Definition

Visual Basic .NET Public Sub Scale( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Scale(
float x,
float y,
float z
);
Managed C++ public: void Scale(
float x,
float y,
float z
);
JScript .NET public function Scale(
x : float,
y : float,
z : float
);

Parameters

x | System.Single. Floating-point value that represents the scaling component in the x-direction.
y | System.Single. Floating-point value that represents the scaling component in the y-direction.
z | System.Single. Floating-point value that represents the scaling component in the z-direction.

Remarks

This method right-multiplies the current matrix by the computed scale matrix. The transformation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.ScaleLocal


MatrixStack.ScaleLocal

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.ScaleLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.

Overload List

public void ScaleLocal(float, float, float);
public void ScaleLocal(Vector3);

Remarks

This method left-multiplies the current matrix with the computed scale matrix. The transformation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Scale


MatrixStack.ScaleLocal(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.ScaleLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.

Definition

Visual Basic .NET Public Sub ScaleLocal( _
ByVal scale As Vector3 _
)
C# public void ScaleLocal(
Vector3 scale
);
Managed C++ public: void ScaleLocal(
Vector3 scale
);
JScript .NET public function ScaleLocal(
scale : Vector3
);

Parameters

scale Microsoft.DirectX.Vector3. A Vector3 object that represents the scale values to use in the calculation.

Remarks

This method left-multiplies the current matrix with the computed scale matrix. The transformation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Scale


MatrixStack.ScaleLocal(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.ScaleLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.

Definition

Visual Basic .NET Public Sub ScaleLocal( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void ScaleLocal(
float x,
float y,
float z
);
Managed C++ public: void ScaleLocal(
float x,
float y,
float z
);
JScript .NET public function ScaleLocal(
x : float,
y : float,
z : float
);

Parameters

x | System.Single. Floating-point value that represents the scaling component in the x-direction.
y | System.Single. Floating-point value that represents the scaling component in the y-direction.
z | System.Single. Floating-point value that represents the scaling component in the z-direction.

Remarks

This method left-multiplies the current matrix with the computed scale matrix. The transformation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Scale


MatrixStack.Translate

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Translate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).

Overload List

public void Translate(float, float, float);
public void Translate(Vector3);

Remarks

This method right-multiplies the current matrix by the computed translation matrix. The transformation is around the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.TranslateLocal


MatrixStack.Translate(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Translate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).

Definition

Visual Basic .NET Public Sub Translate( _
ByVal trans As Vector3 _
)
C# public void Translate(
Vector3 trans
);
Managed C++ public: void Translate(
Vector3 trans
);
JScript .NET public function Translate(
trans : Vector3
);

Parameters

trans Microsoft.DirectX.Vector3. A Vector3 object that represents the translation factors to use in the calculation.

Remarks

This method right-multiplies the current matrix by the computed translation matrix. The transformation is around the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.TranslateLocal


MatrixStack.Translate(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Translate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).

Definition

Visual Basic .NET Public Sub Translate( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Translate(
float x,
float y,
float z
);
Managed C++ public: void Translate(
float x,
float y,
float z
);
JScript .NET public function Translate(
x : float,
y : float,
z : float
);

Parameters

x | System.Single. Floating-point value that represents the translation factor in the x-direction.
y | System.Single. Floating-point value that represents the translation factor in the y-direction.
z | System.Single. Floating-point value that represents the translation factor in the z-direction.

Remarks

This method right-multiplies the current matrix by the computed translation matrix. The transformation is around the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.TranslateLocal


MatrixStack.TranslateLocal

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.TranslateLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Overload List

public void TranslateLocal(float, float, float);
public void TranslateLocal(Vector3);

Remarks

This method left-multiplies the current matrix by the computed translation matrix (transformation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Translate


MatrixStack.TranslateLocal(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.TranslateLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Definition

Visual Basic .NET Public Sub TranslateLocal( _
ByVal trans As Vector3 _
)
C# public void TranslateLocal(
Vector3 trans
);
Managed C++ public: void TranslateLocal(
Vector3 trans
);
JScript .NET public function TranslateLocal(
trans : Vector3
);

Parameters

trans Microsoft.DirectX.Vector3. A Vector3 object that represents the translation factors to use in the calculation.

Remarks

This method left-multiplies the current matrix by the computed translation matrix (transformation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Translate


MatrixStack.TranslateLocal(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.TranslateLocal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Definition

Visual Basic .NET Public Sub TranslateLocal( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void TranslateLocal(
float x,
float y,
float z
);
Managed C++ public: void TranslateLocal(
float x,
float y,
float z
);
JScript .NET public function TranslateLocal(
x : float,
y : float,
z : float
);

Parameters

x | System.Single. Floating-point value that represents the translation factor in the x-direction.
y | System.Single. Floating-point value that represents the translation factor in the y-direction.
z | System.Single. Floating-point value that represents the translation factor in the z-direction.

Remarks

This method left-multiplies the current matrix by the computed translation matrix (transformation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Translate


MatrixStack.Disposed

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Disposed Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that is true if the object is disposed; otherwise the value is false.

Definition

Visual Basic .NET | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
Managed C++ | public: __property bool get_Disposed();
JScript .NET | public function get Disposed() : boolean

Property Value

System.Boolean . Value that indicates whether the object is disposed.

This property is read-only.


MatrixStack.Top

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Top Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the current matrix at the top of the stack.

Definition

Visual Basic .NET | Public ReadOnly Property Top As Matrix
C# | public Matrix Top { get; }
Managed C++ | public: __property Matrix get_Top();
JScript .NET | public function get Top() : Matrix

Property Value

Microsoft.DirectX.Matrix . The Matrix at the top of the matrix stack.

This property is read-only.


MatrixStack.Disposing

Microsoft DirectX 9.0 SDK Update (October 2004)

MatrixStack.Disposing Event

Language:
Note: This documentation is preliminary and is subject to change.

Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft® .NET common language runtime.

Definition

Visual Basic .NET | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
Managed C++ | public: __event EventHandler Disposing;
JScript .NET | In JScript .NET, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a MatrixStack.Disposing event, use the following C# code.

[C#]
ms.Disposing += new System.EventHandler(this.DisposingEventHandler);

The Dispose property of an object indicates whether that object has been disposed.


Microsoft.DirectX.UnsafeNativeMethods.Plane

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a plane.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the methods of the Microsoft.DirectX.Plane structure.

Definition

Visual Basic .NET NotInheritable Public Class Plane
Inherits Object
C# | public sealed class Plane : Object
Managed C++ | public __gc __sealed class Plane : public Object
JScript .NET | public class Plane extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic .NET) Dot Computes the dot product of a plane and a vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) DotCoordinate Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) DotNormal Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) FromPointNormal Constructs a plane from a point and a normal.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) FromPoints Constructs a plane from three points.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) IntersectLine Finds the intersection between a plane and a line.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Normalize Returns the normal of a plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Scale Scales the plane with a given scaling factor.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Transform Transforms a plane by a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformArray Transforms an array of planes by a matrix. The vectors that describe each plane must be normalized.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Plane

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Microsoft.DirectX.Plane Structure


UnsafeNativeMethods.Plane.Dot(Plane,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of a plane and a vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal pPlane As Plane, _
ByVal pV As Vector4 _
) As Single
C# public static float Dot(
Plane pPlane,
Vector4 pV
);
Managed C++ public: static float Dot(
Plane pPlane,
Vector4 pV
);
JScript .NET public static function Dot(
pPlane : Plane,
pV : Vector4
) : float;

Parameters

pPlane | Microsoft.DirectX.Plane. Source Plane structure.
pV | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

System.Single . A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal
  • Microsoft.DirectX.Plane.Dot


UnsafeNativeMethods.Plane.DotCoordinate(Plane,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.DotCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 1.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function DotCoordinate( _
ByVal pPlane As Plane, _
ByVal pV As Vector3 _
) As Single
C# public static float DotCoordinate(
Plane pPlane,
Vector3 pV
);
Managed C++ public: static float DotCoordinate(
Plane pPlane,
Vector3 pV
);
JScript .NET public static function DotCoordinate(
pPlane : Plane,
pV : Vector3
) : float;

Parameters

pPlane | Microsoft.DirectX.Plane. Source Plane structure.
pV | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 3-D vector (x, y, z) the return value of this function is a*x + b*y + c*z + d*1. The DotCoordinate method is useful for determining the plane's relationship with a coordinate in 3-D space.


UnsafeNativeMethods.Plane.DotNormal(Plane,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.DotNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function DotNormal( _
ByVal pPlane As Plane, _
ByVal pV As Vector3 _
) As Single
C# public static float DotNormal(
Plane pPlane,
Vector3 pV
);
Managed C++ public: static float DotNormal(
Plane pPlane,
Vector3 pV
);
JScript .NET public static function DotNormal(
pPlane : Plane,
pV : Vector3
) : float;

Parameters

pPlane | Microsoft.DirectX.Plane.
pV | Microsoft.DirectX.Vector3.

Return Value

System.Single . A Single Leave Site value that represents the dot product of the plane and the 3-D vector.

Remarks

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*0. The DotNormal method is useful for calculating the angle between the normal of the plane and another normal.

See Also

  • Microsoft.DirectX.Plane.DotNormal


UnsafeNativeMethods.Plane.FromPointNormal(Plane,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.FromPointNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs a plane from a point and a normal.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function FromPointNormal( _
ByVal pOut As Plane, _
ByVal pPoint As Vector3, _
ByVal pNormal As Vector3 _
) As Plane
C# public static Plane FromPointNormal(
Plane pOut,
Vector3 pPoint,
Vector3 pNormal
);
Managed C++ public: static Plane FromPointNormal(
Plane pOut,
Vector3 pPoint,
Vector3 pNormal
);
JScript .NET public static function FromPointNormal(
pOut : Plane,
pPoint : Vector3,
pNormal : Vector3
) : Plane;

Parameters

pOut | Microsoft.DirectX.Plane. A Plane structure constructed from the point and the normal.
pPoint | Microsoft.DirectX.Vector3. A Vector3 structure that defines the point used to construct the plane.
pNormal | Microsoft.DirectX.Vector3. A Vector3 structure that defines the normal used to construct the plane.

Return Value

Microsoft.DirectX.Plane . A Plane structure constructed from the point and the normal.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the FromPointNormal method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane Structure
  • Microsoft.DirectX.Plane.PointNormal


UnsafeNativeMethods.Plane.FromPoints(Plane,Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.FromPoints Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs a plane from three points.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function FromPoints( _
ByVal pOut As Plane, _
ByVal pPoint1 As Vector3, _
ByVal pPoint2 As Vector3, _
ByVal pPoint3 As Vector3 _
) As Plane
C# public static Plane FromPoints(
Plane pOut,
Vector3 pPoint1,
Vector3 pPoint2,
Vector3 pPoint3
);
Managed C++ public: static Plane FromPoints(
Plane pOut,
Vector3 pPoint1,
Vector3 pPoint2,
Vector3 pPoint3
);
JScript .NET public static function FromPoints(
pOut : Plane,
pPoint1 : Vector3,
pPoint2 : Vector3,
pPoint3 : Vector3
) : Plane;

Parameters

pOut | Microsoft.DirectX.Plane. A Plane structure constructed from the given points.
pPoint1 | Microsoft.DirectX.Vector3. A Vector3 structure that defines one of the points used to construct the plane.
pPoint2 | Microsoft.DirectX.Vector3. A Vector3 structure that defines one of the points used to construct the plane.
pPoint3 | Microsoft.DirectX.Vector3. A Vector3 structure that defines one of the points used to construct the plane.

Return Value

Microsoft.DirectX.Plane . A Plane structure constructed from the given points.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the FromPoints method can be used as a parameter for another method.

See Also

  • FromPointNormal
  • Microsoft.DirectX.Plane.FromPoints


UnsafeNativeMethods.Plane.IntersectLine(Vector3,Plane,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.IntersectLine Method

 Language:
Note: This documentation is preliminary and is subject to change.

Finds the intersection between a plane and a line.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function IntersectLine( _
ByVal pOut As Vector3, _
ByVal pPlane As Plane, _
ByVal pV1 As Vector3, _
ByVal pV2 As Vector3 _
) As Vector3
C# public static Vector3 IntersectLine(
Vector3 pOut,
Plane pPlane,
Vector3 pV1,
Vector3 pV2
);
Managed C++ public: static Vector3 IntersectLine(
Vector3 pOut,
Plane pPlane,
Vector3 pV1,
Vector3 pV2
);
JScript .NET public static function IntersectLine(
pOut : Vector3,
pPlane : Plane,
pV1 : Vector3,
pV2 : Vector3
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the intersection between the specified plane and line.
pPlane | Microsoft.DirectX.Plane. Source Plane structure.
pV1 | Microsoft.DirectX.Vector3. Source Vector3 structure that defines a line starting point.
pV2 | Microsoft.DirectX.Vector3. Source Vector3 structure that defines a line ending point.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the intersection between the specified plane and line.

Remarks

If the line is parallel to the plane, a null pointer is returned.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the IntersectLine method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane.IntersectLine


UnsafeNativeMethods.Plane.Normalize(Plane,Plane)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a plane.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal pOut As Plane, _
ByVal pPlane As Plane _
) As Plane
C# public static Plane Normalize(
Plane pOut,
Plane pPlane
);
Managed C++ public: static Plane Normalize(
Plane pOut,
Plane pPlane
);
JScript .NET public static function Normalize(
pOut : Plane,
pPlane : Plane
) : Plane;

Parameters

pOut | Microsoft.DirectX.Plane. A Plane structure that represents the normal of the plane.
pPlane | Microsoft.DirectX.Plane. Source Plane structure.

Return Value

Microsoft.DirectX.Plane . A Plane structure that represents the normal of the plane.

Remarks

This method normalizes a plane so that |a, b, c| == 1.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Normalize method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane.Normalize


UnsafeNativeMethods.Plane.Scale(Plane,Plane,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales the plane with a given scaling factor.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal pOut As Plane, _
ByVal pPlane As Plane, _
ByVal s As Single _
) As Plane
C# public static Plane Scale(
Plane pOut,
Plane pPlane,
float s
);
Managed C++ public: static Plane Scale(
Plane pOut,
Plane pPlane,
float s
);
JScript .NET public static function Scale(
pOut : Plane,
pPlane : Plane,
s : float
) : Plane;

Parameters

pOut | Microsoft.DirectX.Plane. The Plane structure that represents the scaled plane.
pPlane | Microsoft.DirectX.Plane. Pointer to the source Plane structure.
s | System.Single. Scale factor.

Return Value

Microsoft.DirectX.Plane . The Plane structure that represents the scaled plane.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Scale method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane.Scale


UnsafeNativeMethods.Plane.Transform(Plane,Plane,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a plane by a matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal pOut As Plane, _
ByVal pPlane As Plane, _
ByVal pMatrix As Matrix _
) As Plane
C# public static Plane Transform(
Plane pOut,
Plane pPlane,
Matrix pMatrix
);
Managed C++ public: static Plane Transform(
Plane pOut,
Plane pPlane,
Matrix pMatrix
);
JScript .NET public static function Transform(
pOut : Plane,
pPlane : Plane,
pMatrix : Matrix
) : Plane;

Parameters

pOut | Microsoft.DirectX.Plane. A Plane structure that represents the transformed plane.
pPlane | Microsoft.DirectX.Plane. Input Plane structure, which contains the plane to be transformed. The vector (a,b,c) that describes the plane must be normalized before this method is called.
pMatrix | Microsoft.DirectX.Matrix. Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.

Return Value

Microsoft.DirectX.Plane . A Plane structure that represents the transformed plane.

Remarks

The input matrix is the inverse transpose of the actual transformation.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Transform method can be used as a parameter for another method.

See Also

  • Normalize
  • Microsoft.DirectX.Plane.Transform


UnsafeNativeMethods.Plane.TransformArray(Plane,Int32,Plane,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Plane.TransformArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms an array of planes by a matrix. The vectors that describe each plane must be normalized.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformArray( _
ByVal pOut As Plane, _
ByVal outStride As Integer, _
ByVal pPlane As Plane, _
ByVal vectorStride As Integer, _
ByVal pMatrix As Matrix, _
ByVal count As Integer _
) As Plane
C# public static Plane TransformArray(
Plane pOut,
int outStride,
Plane pPlane,
int vectorStride,
Matrix pMatrix,
int count
);
Managed C++ public: static Plane TransformArray(
Plane pOut,
int outStride,
Plane pPlane,
int vectorStride,
Matrix pMatrix,
int count
);
JScript .NET public static function TransformArray(
pOut : Plane,
outStride : int,
pPlane : Plane,
vectorStride : int,
pMatrix : Matrix,
count : int
) : Plane;

Parameters

pOut | Microsoft.DirectX.Plane. A Plane structure that represents the transformed plane.
outStride | System.Int32. The stride of each transformed plane.
pPlane | Microsoft.DirectX.Plane. Input Plane structure, which contains the plane to be transformed. The vector (a,b,c) that describes the plane must be normalized before this method is called.
vectorStride | System.Int32. The stride of each non-transformed plane.
pMatrix | Microsoft.DirectX.Matrix. Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.
count | System.Int32. The number of planes to transform.

Return Value

Microsoft.DirectX.Plane . A Plane structure that represents the transformed plane.

Remarks

The input matrix is the inverse transpose of the actual transformation.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformArray method can be used as a parameter for another method.

See Also

  • Normalize
  • Transform


Microsoft.DirectX.UnsafeNativeMethods.Quaternion

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a quaternion.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the methods of the Microsoft.DirectX.Quaternion structure.

Definition

Visual Basic .NET NotInheritable Public Class Quaternion
Inherits Object
C# | public sealed class Quaternion : Object
Managed C++ | public __gc __sealed class Quaternion : public Object
JScript .NET | public class Quaternion extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic .NET) BaryCentric Returns a quaternion in barycentric coordinates.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Conjugate Returns the conjugate of a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Dot Returns the dot product of two quaternions.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Exp Calculates the exponential.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Invert Conjugates and re-normalizes a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Length Returns the length of a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) LengthSq Returns the square of a quaternion's length.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Ln Calculates the natural logarithm.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Multiply Multiplies two quaternions.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Normalize Returns the normal of a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) RotationAxis Builds a quaternion that is rotated around an arbitrary axis.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) RotationMatrix Builds a quaternion from a rotation matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Slerp Interpolates between two quaternions, using spherical linear interpolation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Squad Interpolates between quaternions, using spherical quadrangle interpolation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) SquadSetup Sets up control points for spherical quadrangle interpolation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) ToAxisAngle Computes a quaternion's axis and angle of rotation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Quaternion

Remarks

Quaternions add a fourth element to the [ x, y, z] values that define a vector, resulting in arbitrary 4-D vectors. However, the following example illustrates how each element of a unit quaternion relates to an axis-angle rotation, where q represents a unit quaternion (x, y, z, w), axis is normalized, and theta is the desired counterclockwise (CCW) rotation around the axis.

q.x = sin(theta/2) * axis.x

q.y = sin(theta/2) * axis.y

q.z = sin(theta/2) * axis.z

q.w = cos(theta/2)

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Vectors, Vertices, and Quaternions
  • Microsoft.DirectX.Quaternion Structure


UnsafeNativeMethods.Quaternion.BaryCentric(Quaternion,Quaternion,Quaternion,Quaternion,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a quaternion in barycentric coordinates.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion, _
ByVal pQuat3 As Quaternion, _
ByVal f As Single, _
ByVal g As Single _
) As Quaternion
C# public static Quaternion BaryCentric(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
Quaternion pQuat3,
float f,
float g
);
Managed C++ public: static Quaternion BaryCentric(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
Quaternion pQuat3,
float f,
float g
);
JScript .NET public static function BaryCentric(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuat2 : Quaternion,
pQuat3 : Quaternion,
f : float,
g : float
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. Resulting Quaternion structure in barycentric coordinates.
pQuat1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuat2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuat3 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Quaternion . Resulting Quaternion structure in barycentric coordinates.

Remarks

To compute the barycentric coordinates, the BaryCentric method implements the following series of spherical linear interpolation operations.

Slerp(Slerp(pQuat1, pQuat2, f + g))

Slerp(pQuat1, pQuat3, f + g)

g/(f + g)

The return value for this method is the same value returned in the pOut parameter. Resultantly, the BaryCentric method can be used as a parameter for another method.

See Also

  • Slerp
  • Microsoft.DirectX.Quaternion.BaryCentric


UnsafeNativeMethods.Quaternion.Conjugate(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Conjugate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the conjugate of a quaternion.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Conjugate( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Conjugate(
Quaternion pOut,
Quaternion pQuat
);
Managed C++ public: static Quaternion Conjugate(
Quaternion pOut,
Quaternion pQuat
);
JScript .NET public static function Conjugate(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is the conjugate of the pQuat parameter.
pQuat | Microsoft.DirectX.Quaternion. Source Quaternion.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the conjugate of the pQuat parameter.

Remarks

Given a quaternion (x, y, z, w), the Conjugate method returns the quaternion (-x, -y, -z, w).

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Conjugate method can be used as a parameter for another method.

See Also

  • Invert
  • Microsoft.DirectX.Quaternion.Conjugate


UnsafeNativeMethods.Quaternion.Dot(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the dot product of two quaternions.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion _
) As Single
C# public static float Dot(
Quaternion pQuat1,
Quaternion pQuat2
);
Managed C++ public: static float Dot(
Quaternion pQuat1,
Quaternion pQuat2
);
JScript .NET public static function Dot(
pQuat1 : Quaternion,
pQuat2 : Quaternion
) : float;

Parameters

pQuat1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuat2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

System.Single . Dot product of two quaternions.

See Also

  • Microsoft.DirectX.Quaternion.Dot


UnsafeNativeMethods.Quaternion.Exp(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Exp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the exponential.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Exp( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Exp(
Quaternion pOut,
Quaternion pQuat
);
Managed C++ public: static Quaternion Exp(
Quaternion pOut,
Quaternion pQuat
);
JScript .NET public static function Exp(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. The Quaternion structure that is the exponential of the pQuat parameter.
pQuat | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . The Quaternion structure that is the exponential of the pQuat parameter.

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Exp method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Quaternion.Exp


UnsafeNativeMethods.Quaternion.Invert(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Conjugates and re-normalizes a quaternion.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Invert( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Invert(
Quaternion pOut,
Quaternion pQuat
);
Managed C++ public: static Quaternion Invert(
Quaternion pOut,
Quaternion pQuat
);
JScript .NET public static function Invert(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is the inverse of the quaternion passed into the pQuat parameter.
pQuat | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the inverse of the quaternion passed into the pQuat parameter.

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Invert method can be used as a parameter for another method.

See Also

  • Conjugate
  • Normalize
  • Microsoft.DirectX.Quaternion.Invert


UnsafeNativeMethods.Quaternion.Length(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a quaternion.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal pQuat As Quaternion _
) As Single
C# public static float Length(
Quaternion pQuat
);
Managed C++ public: static float Length(
Quaternion pQuat
);
JScript .NET public static function Length(
pQuat : Quaternion
) : float;

Parameters

pQuat Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

System.Single . A Single Leave Site value that represents the quaternion's length.

See Also

  • LengthSq
  • Microsoft.DirectX.Quaternion.Length


UnsafeNativeMethods.Quaternion.LengthSq(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of a quaternion's length.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal pQuat As Quaternion _
) As Single
C# public static float LengthSq(
Quaternion pQuat
);
Managed C++ public: static float LengthSq(
Quaternion pQuat
);
JScript .NET public static function LengthSq(
pQuat : Quaternion
) : float;

Parameters

pQuat Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

System.Single . A Single Leave Site value that represents the quaternion's squared length.

See Also

  • Length
  • Microsoft.DirectX.Quaternion.LengthSq


UnsafeNativeMethods.Quaternion.Ln(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Ln Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the natural logarithm.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Ln( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Ln(
Quaternion pOut,
Quaternion pQuat
);
Managed C++ public: static Quaternion Ln(
Quaternion pOut,
Quaternion pQuat
);
JScript .NET public static function Ln(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is the natural logarithm of the quaternion passed into the pQuat parameter.
pQuat | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the natural logarithm of the quaternion passed into the pQuat parameter.

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Ln method can be used as a parameter for another method.

See Also

  • Exp
  • Squad
  • Microsoft.DirectX.Quaternion.Ln


UnsafeNativeMethods.Quaternion.Multiply(Quaternion,Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies two quaternions.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Multiply( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion _
) As Quaternion
C# public static Quaternion Multiply(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2
);
Managed C++ public: static Quaternion Multiply(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2
);
JScript .NET public static function Multiply(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuat2 : Quaternion
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is the product of two quaternions.
pQuat1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuat2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the product of two quaternions.

Remarks

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Multiply method can be used as a parameter for another method.

See Also

  • Multiply
  • Microsoft.DirectX.Quaternion.Multiply


UnsafeNativeMethods.Quaternion.Normalize(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a quaternion.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Normalize(
Quaternion pOut,
Quaternion pQuat
);
Managed C++ public: static Quaternion Normalize(
Quaternion pOut,
Quaternion pQuat
);
JScript .NET public static function Normalize(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is the normal of the quaternion.
pQuat | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the normal of the quaternion.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Normalize method can be used as a parameter for another method.

See Also

  • Invert
  • Microsoft.DirectX.Quaternion.Normalize


UnsafeNativeMethods.Quaternion.RotationAxis(Quaternion,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.RotationAxis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a quaternion that is rotated around an arbitrary axis.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function RotationAxis( _
ByVal pOut As Quaternion, _
ByVal pAxis As Vector3, _
ByVal angle As Single _
) As Quaternion
C# public static Quaternion RotationAxis(
Quaternion pOut,
Vector3 pAxis,
float angle
);
Managed C++ public: static Quaternion RotationAxis(
Quaternion pOut,
Vector3 pAxis,
float angle
);
JScript .NET public static function RotationAxis(
pOut : Quaternion,
pAxis : Vector3,
angle : float
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is rotated around the specified axis.
pAxis | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the axis about which to rotate the quaternion.
angle | System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is rotated around the specified axis.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the RotationAxis method can be used as a parameter for another method.

See Also

  • RotationMatrix
  • Microsoft.DirectX.Quaternion.RotationAxis


UnsafeNativeMethods.Quaternion.RotationMatrix(Quaternion,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.RotationMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a quaternion from a rotation matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function RotationMatrix( _
ByVal pOut As Quaternion, _
ByVal pMatrix As Matrix _
) As Quaternion
C# public static Quaternion RotationMatrix(
Quaternion pOut,
Matrix pMatrix
);
Managed C++ public: static Quaternion RotationMatrix(
Quaternion pOut,
Matrix pMatrix
);
JScript .NET public static function RotationMatrix(
pOut : Quaternion,
pMatrix : Matrix
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure built from a rotation matrix.
pMatrix | Microsoft.DirectX.Matrix. Source Matrix structure that defines the rotation.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure built from a rotation matrix.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the RotationMatrix method can be used as a parameter for another method.

See Also

  • RotationAxis
  • Microsoft.DirectX.Quaternion.RotationMatrix


UnsafeNativeMethods.Quaternion.Slerp(Quaternion,Quaternion,Quaternion,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Slerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Interpolates between two quaternions, using spherical linear interpolation.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Slerp( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Slerp(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
float t
);
Managed C++ public: static Quaternion Slerp(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
float t
);
JScript .NET public static function Slerp(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuat2 : Quaternion,
t : float
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is the result of the interpolation.
pQuat1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuat2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
t | System.Single. A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the result of the interpolation.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Slerp method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Quaternion.Slerp


UnsafeNativeMethods.Quaternion.Squad(Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.Squad Method

 Language:
Note: This documentation is preliminary and is subject to change.

Interpolates between quaternions, using spherical quadrangle interpolation.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Squad( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuata As Quaternion, _
ByVal pQuatb As Quaternion, _
ByVal pQuatc As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Squad(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuata,
Quaternion pQuatb,
Quaternion pQuatc,
float t
);
Managed C++ public: static Quaternion Squad(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuata,
Quaternion pQuatb,
Quaternion pQuatc,
float t
);
JScript .NET public static function Squad(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuata : Quaternion,
pQuatb : Quaternion,
pQuatc : Quaternion,
t : float
) : Quaternion;

Parameters

pOut | Microsoft.DirectX.Quaternion. A Quaternion structure that is the result of the spherical quadrangle interpolation.
pQuat1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuata | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuatb | Microsoft.DirectX.Quaternion. Source Quaternion structure.
pQuatc | Microsoft.DirectX.Quaternion. Source Quaternion structure.
t | System.Single. A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the result of the spherical quadrangle interpolation.

Remarks

This method uses the following sequence of spherical linear interpolation operations.

Slerp(Slerp(pQuat1, pQuatc, t), Slerp(pQuata, pQuatb, t), 2t(1 - t))

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Squad method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Quaternion.Squad


UnsafeNativeMethods.Quaternion.SquadSetup(Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.SquadSetup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets up control points for spherical quadrangle interpolation.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Sub SquadSetup( _
ByVal pOutA As Quaternion, _
ByVal pOutB As Quaternion, _
ByVal pOutC As Quaternion, _
ByVal pQ0 As Quaternion, _
ByVal pQ1 As Quaternion, _
ByVal pQ2 As Quaternion, _
ByVal pQ3 As Quaternion _
)
C# public static void SquadSetup(
Quaternion pOutA,
Quaternion pOutB,
Quaternion pOutC,
Quaternion pQ0,
Quaternion pQ1,
Quaternion pQ2,
Quaternion pQ3
);
Managed C++ public: static void SquadSetup(
Quaternion pOutA,
Quaternion pOutB,
Quaternion pOutC,
Quaternion pQ0,
Quaternion pQ1,
Quaternion pQ2,
Quaternion pQ3
);
JScript .NET public static function SquadSetup(
pOutA : Quaternion,
pOutB : Quaternion,
pOutC : Quaternion,
pQ0 : Quaternion,
pQ1 : Quaternion,
pQ2 : Quaternion,
pQ3 : Quaternion
);

Parameters

pOutA | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the outA value.
pOutB | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the outB value.
pOutC | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the outC value.
pQ0 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q0 input control point.
pQ1 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q1 input control point.
pQ2 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q2 input control point.
pQ3 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q3 input control point.

Remarks

This method takes four control points, which are supplied to the inputs as q0, q1, q2, and q3, and alters their values to find a curve that flows along the shortest path. The values of q0, q2, and q3 are calculated as shown below.

q0 = |q0 + q1| < |q0 - q1| ? -q0 : q0
q2 = |q1 + q2| < |q1 - q2| ? -q2 : q2
q3 = |q2 + q3| < |q2 - q3| ? -q3 : q3
Having calculated the new q values, the values for outA, outB, and outC are calculated as shown below.
outA = q1 * exp[-0.25 *( Ln[Exp(q1)*q2] + Ln[Exp(q1)*q0] ) ]

outB = q2 * exp[-0.25 *( Ln[Exp(q2)*q3] + Ln[Exp(q2)*q1] ) ]

outC = q2
Note: In the preceding example, Ln is the application programming interface (API) method Quaternion.Ln, and Exp is the API method Quaternion.Exp.

Examples

The following example shows how to use a set of quaternion keys (Q0, Q1, Q2, Q3) to compute the inner quadrangle points (A, B, C). This ensures that the tangents are continuous across adjacent segments.
        A     B
  Q0    Q1    Q2    Q3
 The following C# code example shows how you can interpolate between Q1 and Q2.
[C#]
// Rotation about the z-axis
Quaternion Q0 =  new Quaternion(0f,  0f, 0.707f, -.707f);
Quaternion Q1 = new Quaternion(0f,  0f, 0.000f, 1.000f);
Quaternion Q2 = new Quaternion(0f,  0f, 0.707f, 0.707f);
Quaternion Q3 = new Quaternion(0f,  0f, 1.000f, 0.000f);
Quaternion A = new Quaternion();
Quaternion B = new Quaternion();
Quaternion C = new Quaternion();
Quaternion Qt = new Quaternion();

Single time = 0.5f;

Quaternion.SquadSetup(ref A, ref B, ref C, Q0, Q1, Q2, Q3);
Qt = Quaternion.Squad(Q1, A, B, C, time);
 Note:
  • C is +/- Q2 depending on the result of the function
  • Qt is the result of the function
The result is a rotation of 45 degrees around the z-axis for time = 0.5.

See Also

  • Microsoft.DirectX.Quaternion.SquadSetup


UnsafeNativeMethods.Quaternion.ToAxisAngle(Quaternion,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Quaternion.ToAxisAngle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a quaternion's axis and angle of rotation.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Sub ToAxisAngle( _
ByVal pQuat As Quaternion, _
ByVal pAxis As Vector3, _
ByVal pAngle As Single _
)
C# public static void ToAxisAngle(
Quaternion pQuat,
Vector3 pAxis,
float pAngle
);
Managed C++ public: static void ToAxisAngle(
Quaternion pQuat,
Vector3 pAxis,
float pAngle
);
JScript .NET public static function ToAxisAngle(
pQuat : Quaternion,
pAxis : Vector3,
pAngle : float
);

Parameters

pQuat | Microsoft.DirectX.Quaternion. Source Quaternion structure. See Remarks.
pAxis | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the quaternion's axis of rotation.
pAngle | System.Single. A Single Leave Site value that identifies the quaternion's angle of rotation, in radians.

Remarks

This method requires unit quaternions.

See Also

  • Microsoft.DirectX.Quaternion.ToAxisAngle


Microsoft.DirectX.UnsafeNativeMethods

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods Class

Language:
Note: This documentation is preliminary and is subject to change.

Defines high-performance utility methods for matrix, plane, quaternion, and vector manipulation. This class is a container of classes. See the individual classes for more information.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the methods of the Microsoft.DirectX Structures.

Definition

Visual Basic .NET NotInheritable Public Class UnsafeNativeMethods
Inherits Object
C# | public sealed class UnsafeNativeMethods : Object
Managed C++ | public __gc __sealed class UnsafeNativeMethods : public Object
JScript .NET | public class UnsafeNativeMethods extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Classes

Classes Description
UnsafeNativeMethods.Matrix Describes and manipulates a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Matrix structure.
UnsafeNativeMethods.Plane Describes and manipulates a plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Plane structure.
UnsafeNativeMethods.Quaternion Describes and manipulates a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Quaternion structure.
UnsafeNativeMethods.Vector2 Describes and manipulates a vector in two-dimensional (2-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector2 structure.
UnsafeNativeMethods.Vector3 Describes and manipulates a vector in three-dimensional (3-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector3 structure.
UnsafeNativeMethods.Vector4 Describes and manipulates a vector in four-dimensional (4-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector4 structure.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Microsoft.DirectX.Matrix Structure
  • Microsoft.DirectX.Plane Structure
  • Microsoft.DirectX.Quaternion Structure
  • Microsoft.DirectX.Vector2 Structure
  • Microsoft.DirectX.Vector3 Structure
  • Microsoft.DirectX.Vector4 Structure


Microsoft.DirectX.UnsafeNativeMethods.Vector2

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2 Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a vector in two-dimensional (2-D) space.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the methods of the Microsoft.DirectX.Vector2 structure.

Definition

Visual Basic .NET NotInheritable Public Class Vector2
Inherits Object
C# | public sealed class Vector2 : Object
Managed C++ | public __gc __sealed class Vector2 : public Object
JScript .NET | public class Vector2 extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic .NET) Add Adds two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) BaryCentric Returns a point in barycentric coordinates, using specified 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) CatmullRom Performs a Catmull-Rom interpolation using specified 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Ccw Returns the z component by calculating the cross product of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Dot Determines the dot product of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Hermite | Performs a Hermite spline interpolation using specified 2-D vectors.
static (Shared in Visual Basic .NET) Length Returns the length of a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) LengthSq Returns the square of the length of a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Lerp Performs a linear interpolation between two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Maximize Returns a 2-D vector that is made up of the largest components of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Minimize Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Normalize Returns the normalized version of a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Scale Scales a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Subtract Subtracts two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Transform Transforms a 2-D vector or an array of 2-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformArray Transforms an array of 2-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformCoordinate Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformCoordinateArray Transforms array (x, y, 0, 1) by a given matrix, and projects the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformNormal Transforms the 2-D vector normal by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformNormalArray Transforms array (x, y, 0, 0) by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Vector2

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsafeNativeMethods.Vector2.Add(Vector2,Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Add(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
Managed C++ public: static Vector2 Add(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript .NET public static function Add(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. Sum of the two source Vector2 structures.
pLeft | Microsoft.DirectX.Vector2. Source Vector2.
pRight | Microsoft.DirectX.Vector2. Source Vector2.

Return Value

Microsoft.DirectX.Vector2 . Sum of the two source Vector2 structures.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Add method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Add


UnsafeNativeMethods.Vector2.BaryCentric(Vector2,Vector2,Vector2,Vector2,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a point in barycentric coordinates, using specified 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal pOut As Vector2, _
ByVal pV1 As Vector2, _
ByVal pV2 As Vector2, _
ByVal pV3 As Vector2, _
ByVal f As Single, _
ByVal g As Single _
) As Vector2
C# public static Vector2 BaryCentric(
Vector2 pOut,
Vector2 pV1,
Vector2 pV2,
Vector2 pV3,
float f,
float g
);
Managed C++ public: static Vector2 BaryCentric(
Vector2 pOut,
Vector2 pV1,
Vector2 pV2,
Vector2 pV3,
float f,
float g
);
JScript .NET public static function BaryCentric(
pOut : Vector2,
pV1 : Vector2,
pV2 : Vector2,
pV3 : Vector2,
f : float,
g : float
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure in barycentric coordinates.
pV1 | Microsoft.DirectX.Vector2. Source Vector2 structure.
pV2 | Microsoft.DirectX.Vector2. Source Vector2 structure.
pV3 | Microsoft.DirectX.Vector2. Source Vector2 structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of its actual location. This method returns the resulting point by using the following equation.

pV1 + f(pV2 - pV1) + g(pV3 - pV1)

Any point in the plane pV1pV2pV3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which pV2 gets weighted into the result, and the f parameter controls the extent to which pV3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which pV1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle pV1pV2pV3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line pV1pV3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line pV1pV2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line pV2pV3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the BaryCentric method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.BaryCentric


UnsafeNativeMethods.Vector2.CatmullRom(Vector2,Vector2,Vector2,Vector2,Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.CatmullRom Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Catmull-Rom interpolation using specified 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function CatmullRom( _
ByVal pOut As Vector2, _
ByVal pPosition1 As Vector2, _
ByVal pPosition2 As Vector2, _
ByVal pPosition3 As Vector2, _
ByVal pPosition4 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 CatmullRom(
Vector2 pOut,
Vector2 pPosition1,
Vector2 pPosition2,
Vector2 pPosition3,
Vector2 pPosition4,
float weightingFactor
);
Managed C++ public: static Vector2 CatmullRom(
Vector2 pOut,
Vector2 pPosition1,
Vector2 pPosition2,
Vector2 pPosition3,
Vector2 pPosition4,
float weightingFactor
);
JScript .NET public static function CatmullRom(
pOut : Vector2,
pPosition1 : Vector2,
pPosition2 : Vector2,
pPosition3 : Vector2,
pPosition4 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is the result of the Catmull-Rom interpolation.
pPosition1 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
pPosition2 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
pPosition3 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
pPosition4 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of pPosition1, v2 is the contents of pPosition2, p3 is the contents of pPosition3, p4 is the contents of pPosition4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields:
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This can be rearranged as:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

The return value for this method is the same value returned in the pOut parameter. Resultantly, the CatmullRom method can be used as a parameter for another method.

See Also

  • Vector3.CatmullRom
  • Vector4.CatmullRom
  • Microsoft.DirectX.Vector2.CatmullRom


UnsafeNativeMethods.Vector2.Ccw(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Ccw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the z component by calculating the cross product of two 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Ccw( _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Single
C# public static float Ccw(
Vector2 pLeft,
Vector2 pRight
);
Managed C++ public: static float Ccw(
Vector2 pLeft,
Vector2 pRight
);
JScript .NET public static function Ccw(
pLeft : Vector2,
pRight : Vector2
) : float;

Parameters

pLeft | Microsoft.DirectX.Vector2. Source Vector2 structure.
pRight | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . The z component.

Remarks

This method determines the z component by calculating the cross product based on the following formula.

((x1,y1,0) cross (x2,y2,0))

The following C# code fragment provides an example.

[C#]
left->x * right->y - left->y * right->x

If the z component's value is positive, the vector right is counterclockwise from the vector left. This information is useful for back-face culling.

See Also

  • Microsoft.DirectX.Vector2.Ccw


UnsafeNativeMethods.Vector2.Dot(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the dot product of two 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Single
C# public static float Dot(
Vector2 pLeft,
Vector2 pRight
);
Managed C++ public: static float Dot(
Vector2 pLeft,
Vector2 pRight
);
JScript .NET public static function Dot(
pLeft : Vector2,
pRight : Vector2
) : float;

Parameters

pLeft | Microsoft.DirectX.Vector2. Source Vector2 structure.
pRight | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . Dot product.

See Also

  • Ccw
  • Microsoft.DirectX.Vector2.Dot


UnsafeNativeMethods.Vector2.Hermite(Vector2,Vector2,Vector2,Vector2,Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Hermite Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Hermite spline interpolation using specified 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Hermite( _
ByVal pOut As Vector2, _
ByVal pPosition As Vector2, _
ByVal pTangent As Vector2, _
ByVal pPosition2 As Vector2, _
ByVal pTangent2 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 Hermite(
Vector2 pOut,
Vector2 pPosition,
Vector2 pTangent,
Vector2 pPosition2,
Vector2 pTangent2,
float weightingFactor
);
Managed C++ public: static Vector2 Hermite(
Vector2 pOut,
Vector2 pPosition,
Vector2 pTangent,
Vector2 pPosition2,
Vector2 pTangent2,
float weightingFactor
);
JScript .NET public static function Hermite(
pOut : Vector2,
pPosition : Vector2,
pTangent : Vector2,
pPosition2 : Vector2,
pTangent2 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is the result of the Hermite spline interpolation.
pPosition | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
pTangent | Microsoft.DirectX.Vector2. Source Vector2 structure that is a tangent vector.
pPosition2 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
pTangent2 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a tangent vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (pPosition, pTangent) to (pPosition2, pTangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of ease-in, ease-out spline interpolation. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of pPosition, v2 is the contents of pPosition2, t1 is the contents of pTangent, t2 is the contents of pTangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, and D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

The preceding example yields the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Hermite method can be used as a parameter for another method.

See Also

  • Hermite


UnsafeNativeMethods.Vector2.Length(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 2-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal pSource As Vector2 _
) As Single
C# public static float Length(
Vector2 pSource
);
Managed C++ public: static float Length(
Vector2 pSource
);
JScript .NET public static function Length(
pSource : Vector2
) : float;

Parameters

pSource Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . Vector length.

See Also

  • LengthSq
  • Microsoft.DirectX.Vector2.Length


UnsafeNativeMethods.Vector2.LengthSq(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 2-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal pSource As Vector2 _
) As Single
C# public static float LengthSq(
Vector2 pSource
);
Managed C++ public: static float LengthSq(
Vector2 pSource
);
JScript .NET public static function LengthSq(
pSource : Vector2
) : float;

Parameters

pSource Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . Vector's squared length.

See Also

  • Length
  • Microsoft.DirectX.Vector2.LengthSq


UnsafeNativeMethods.Vector2.Lerp(Vector2,Vector2,Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a linear interpolation between two 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2, _
ByVal interpolater As Single _
) As Vector2
C# public static Vector2 Lerp(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight,
float interpolater
);
Managed C++ public: static Vector2 Lerp(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight,
float interpolater
);
JScript .NET public static function Lerp(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2,
interpolater : float
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is the result of the linear interpolation.
pLeft | Microsoft.DirectX.Vector2. Source Vector2 structure.
pRight | Microsoft.DirectX.Vector2. Source Vector2 structure.
interpolater | System.Single. Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

pLeft + interpolater(pRight - pLeft).

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Lerp method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Lerp


UnsafeNativeMethods.Vector2.Maximize(Vector2,Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Maximize( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Maximize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
Managed C++ public: static Vector2 Maximize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript .NET public static function Maximize(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is made up of the largest components of the two vectors.
pLeft | Microsoft.DirectX.Vector2. Source Vector2 structure.
pRight | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is made up of the largest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Maximize method can be used as a parameter for another method.

See Also

  • Minimize
  • Microsoft.DirectX.Vector2.Maximize


UnsafeNativeMethods.Vector2.Minimize(Vector2,Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Minimize( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Minimize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
Managed C++ public: static Vector2 Minimize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript .NET public static function Minimize(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is made up of the smallest components of the two vectors.
pLeft | Microsoft.DirectX.Vector2. Source Vector2 structure.
pRight | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is made up of the smallest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Minimize method can be used as a parameter for another method.

See Also

  • Maximize
  • Microsoft.DirectX.Vector2.Minimize


UnsafeNativeMethods.Vector2.Normalize(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 2-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2 _
) As Vector2
C# public static Vector2 Normalize(
Vector2 pOut,
Vector2 pSource
);
Managed C++ public: static Vector2 Normalize(
Vector2 pOut,
Vector2 pSource
);
JScript .NET public static function Normalize(
pOut : Vector2,
pSource : Vector2
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is the normalized version of the vector.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the normalized version of the vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Normalize method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Normalize


UnsafeNativeMethods.Vector2.Scale(Vector2,Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 2-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2, _
ByVal scalingFactor As Single _
) As Vector2
C# public static Vector2 Scale(
Vector2 pOut,
Vector2 pSource,
float scalingFactor
);
Managed C++ public: static Vector2 Scale(
Vector2 pOut,
Vector2 pSource,
float scalingFactor
);
JScript .NET public static function Scale(
pOut : Vector2,
pSource : Vector2,
scalingFactor : float
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is the scaled vector.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.
scalingFactor | System.Single. Scaling value.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the scaled vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Scale method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Scale


UnsafeNativeMethods.Vector2.Subtract(Vector2,Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 2-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Subtract(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
Managed C++ public: static Vector2 Subtract(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript .NET public static function Subtract(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is the result of the operation.
pLeft | Microsoft.DirectX.Vector2. Source Vector2 structure to the left of the subtraction operator.
pRight | Microsoft.DirectX.Vector2. Source Vector2 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Subtract method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Subtract


UnsafeNativeMethods.Vector2.Transform(Vector4,Vector2,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal pOut As Vector4, _
ByVal pSource As Vector2, _
ByVal pSourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector4 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
JScript .NET public static function Transform(
pOut : Vector4,
pSource : Vector2,
pSourceMatrix : Matrix
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the method.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

This method transforms the pSource vector (x, y, 0, 1) by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Transform method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Transform


UnsafeNativeMethods.Vector2.TransformArray(Vector4,Int32,Vector2,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.TransformArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms an array of 2-D vectors by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformArray( _
ByVal pOut As Vector4, _
ByVal outStride As Integer, _
ByVal pSource As Vector2, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector4
C# public static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
Managed C++ public: static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript .NET public static function TransformArray(
pOut : Vector4,
outStride : int,
pSource : Vector2,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the method.
outStride | System.Int32. Stride between vectors in the output data stream.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.
vectorStride | System.Int32. Stride between vectors in the input data stream.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.
count | System.Int32. Number of elements in the array.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

This method transforms the array of vectors, pSource (x, y, 0, 1), by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformArray method can be used as a parameter for another method.


UnsafeNativeMethods.Vector2.TransformCoordinate(Vector2,Vector2,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformCoordinate( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2, _
ByVal pSourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformCoordinate(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
Managed C++ public: static Vector2 TransformCoordinate(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
JScript .NET public static function TransformCoordinate(
pOut : Vector2,
pSource : Vector2,
pSourceMatrix : Matrix
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that represents the results of the method.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that represents the results of the method.

Remarks

This method transforms the source vector, pOut (x, y, 0, 1), by the matrix pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformCoordinate method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.TransformCoordinate


UnsafeNativeMethods.Vector2.TransformCoordinateArray(Vector2,Int32,Vector2,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.TransformCoordinateArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms array (x, y, 0, 1) by a given matrix, and projects the result back into w = 1.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformCoordinateArray( _
ByVal pOut As Vector2, _
ByVal outStride As Integer, _
ByVal pSource As Vector2, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector2
C# public static Vector2 TransformCoordinateArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
Managed C++ public: static Vector2 TransformCoordinateArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript .NET public static function TransformCoordinateArray(
pOut : Vector2,
outStride : int,
pSource : Vector2,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that represents the results of the method.
outStride | System.Int32. The stride of each transformed array.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.
vectorStride | System.Int32. Stride between vectors in the input data stream.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.
count | System.Int32. Number of elements in the array.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the method.

Remarks

This method transforms the source vector, pSource (x, y, 0, 1), by the matrix pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformCoordinateArray method can be used as a parameter for another method.


UnsafeNativeMethods.Vector2.TransformNormal(Vector2,Vector2,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms the 2-D vector normal by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformNormal( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2, _
ByVal pSourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformNormal(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
Managed C++ public: static Vector2 TransformNormal(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
JScript .NET public static function TransformNormal(
pOut : Vector2,
pSource : Vector2,
pSourceMatrix : Matrix
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that contains the results of this method.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the pSource vector, by the pSourceMatrix source matrix.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformNormal method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.TransformNormal


UnsafeNativeMethods.Vector2.TransformNormalArray(Vector2,Int32,Vector2,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector2.TransformNormalArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms array (x, y, 0, 0) by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformNormalArray( _
ByVal pOut As Vector2, _
ByVal outStride As Integer, _
ByVal pSource As Vector2, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector2
C# public static Vector2 TransformNormalArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
Managed C++ public: static Vector2 TransformNormalArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript .NET public static function TransformNormalArray(
pOut : Vector2,
outStride : int,
pSource : Vector2,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector2;

Parameters

pOut | Microsoft.DirectX.Vector2. A Vector2 structure that is the result of the method.
outStride | System.Int32. Stride between vectors in the output data stream.
pSource | Microsoft.DirectX.Vector2. Source Vector2 structure.
vectorStride | System.Int32. Stride between vectors in the input data stream.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.
count | System.Int32. Number of elements in the array.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the pSource vector by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformNormalArray method can be used as a parameter for another method.


Microsoft.DirectX.UnsafeNativeMethods.Vector3

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3 Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a vector in three-dimensional (3-D) space.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the methods of the Microsoft.DirectX.Vector3 structure.

Definition

Visual Basic .NET NotInheritable Public Class Vector3
Inherits Object
C# | public sealed class Vector3 : Object
Managed C++ | public __gc __sealed class Vector3 : public Object
JScript .NET | public class Vector3 extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic .NET) Add Adds two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) BaryCentric Returns a point in barycentric coordinates, using specified 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) CatmullRom Performs a Catmull-Rom interpolation using specified 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Cross Determines the cross product of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Dot Determines the dot product of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Hermite Performs a Hermite spline interpolation using the specified 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Length Returns the length of a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) LengthSq Returns the square of the length of a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Lerp Performs a linear interpolation between two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Maximize Returns a 3-D vector that is made up of the largest components of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Minimize Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Normalize Returns the normalized version of a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Scale Scales a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Subtract Subtracts two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Transform Transforms a 3-D vector or an array of 3-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformArray Transforms an array of 3-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformCoordinate Transforms a 3-D vector by a given matrix, projecting the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformCoordinateArray Transforms array (x, y, z, 1) by a given matrix, and projects the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformNormal Transforms a 3-D vector normal by the given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformNormalArray Transforms array (x, y, z, 0) by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Vector3

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsafeNativeMethods.Vector3.Add(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Add(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
Managed C++ public: static Vector3 Add(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript .NET public static function Add(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. Sum of the two source Vector3 structures.
pLeft | Microsoft.DirectX.Vector3. Source Vector3.
pRight | Microsoft.DirectX.Vector3. Source Vector3.

Return Value

Microsoft.DirectX.Vector3 . Sum of the two source Vector3 structures.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Add method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Add


UnsafeNativeMethods.Vector3.BaryCentric(Vector3,Vector3,Vector3,Vector3,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a point in barycentric coordinates, using specified 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal pOut As Vector3, _
ByVal pV1 As Vector3, _
ByVal pV2 As Vector3, _
ByVal pV3 As Vector3, _
ByVal f As Single, _
ByVal g As Single _
) As Vector3
C# public static Vector3 BaryCentric(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2,
Vector3 pV3,
float f,
float g
);
Managed C++ public: static Vector3 BaryCentric(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2,
Vector3 pV3,
float f,
float g
);
JScript .NET public static function BaryCentric(
pOut : Vector3,
pV1 : Vector3,
pV2 : Vector3,
pV3 : Vector3,
f : float,
g : float
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure in barycentric coordinates.
pV1 | Microsoft.DirectX.Vector3. Source Vector3 structure.
pV2 | Microsoft.DirectX.Vector3. Source Vector3 structure.
pV3 | Microsoft.DirectX.Vector3. Source Vector3 structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

pV1 + f(pV2 - pV1) + g(pV3 - pV1)

Any point in the plane pV1pV2pV3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which pV2 gets weighted into the result, and the f parameter controls the extent to which pV3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which pV1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle pV1pV2pV3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line pV1pV3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line pV1pV2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line pV2pV3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the BaryCentric method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.BaryCentric


UnsafeNativeMethods.Vector3.CatmullRom(Vector3,Vector3,Vector3,Vector3,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.CatmullRom Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Catmull-Rom interpolation using specified 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function CatmullRom( _
ByVal pOut As Vector3, _
ByVal pPosition1 As Vector3, _
ByVal pPosition2 As Vector3, _
ByVal pPosition3 As Vector3, _
ByVal pPosition4 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 CatmullRom(
Vector3 pOut,
Vector3 pPosition1,
Vector3 pPosition2,
Vector3 pPosition3,
Vector3 pPosition4,
float weightingFactor
);
Managed C++ public: static Vector3 CatmullRom(
Vector3 pOut,
Vector3 pPosition1,
Vector3 pPosition2,
Vector3 pPosition3,
Vector3 pPosition4,
float weightingFactor
);
JScript .NET public static function CatmullRom(
pOut : Vector3,
pPosition1 : Vector3,
pPosition2 : Vector3,
pPosition3 : Vector3,
pPosition4 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the result of the Catmull-Rom interpolation.
pPosition1 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
pPosition2 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
pPosition3 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
pPosition4 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of pPosition1, v2 is the contents of pPosition2, p3 is the contents of pPosition3, p4 is the contents of pPosition4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation.

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
Substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

The return value for this method is the same value returned in the pOut parameter. Resultantly, the CatmullRom method can be used as a parameter for another method.

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom
  • Microsoft.DirectX.Vector3.CatmullRom


UnsafeNativeMethods.Vector3.Cross(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Cross Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the cross product of two 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Cross( _
ByVal pOut As Vector3, _
ByVal pV1 As Vector3, _
ByVal pV2 As Vector3 _
) As Vector3
C# public static Vector3 Cross(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2
);
Managed C++ public: static Vector3 Cross(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2
);
JScript .NET public static function Cross(
pOut : Vector3,
pV1 : Vector3,
pV2 : Vector3
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the cross product of two 3-D vectors.
pV1 | Microsoft.DirectX.Vector3. Source Vector3 structure.
pV2 | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the cross product of two 3-D vectors.

Remarks

The following C# example demonstrates how the Cross method finds the cross-product.

[C#]
Vector3 returnValue;
    returnValue.x = left.y * right.z - left.z * right.y;
    returnValue.y = left.z * right.x - left.x * right.z;
    returnValue.z = left.x * right.y - left.y * right.x;

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Cross method can be used as a parameter for another method.

See Also

  • Dot
  • Microsoft.DirectX.Vector3.Cross


UnsafeNativeMethods.Vector3.Dot(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the dot product of two 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Single
C# public static float Dot(
Vector3 pLeft,
Vector3 pRight
);
Managed C++ public: static float Dot(
Vector3 pLeft,
Vector3 pRight
);
JScript .NET public static function Dot(
pLeft : Vector3,
pRight : Vector3
) : float;

Parameters

pLeft | Microsoft.DirectX.Vector3. Source Vector3 structure.
pRight | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that is the dot product.

See Also

  • Cross
  • Microsoft.DirectX.Vector3.Dot


UnsafeNativeMethods.Vector3.Hermite(Vector3,Vector3,Vector3,Vector3,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Hermite Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Hermite spline interpolation using the specified 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Hermite( _
ByVal pOut As Vector3, _
ByVal pPosition As Vector3, _
ByVal pTangent As Vector3, _
ByVal pPosition2 As Vector3, _
ByVal pTangent2 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 Hermite(
Vector3 pOut,
Vector3 pPosition,
Vector3 pTangent,
Vector3 pPosition2,
Vector3 pTangent2,
float weightingFactor
);
Managed C++ public: static Vector3 Hermite(
Vector3 pOut,
Vector3 pPosition,
Vector3 pTangent,
Vector3 pPosition2,
Vector3 pTangent2,
float weightingFactor
);
JScript .NET public static function Hermite(
pOut : Vector3,
pPosition : Vector3,
pTangent : Vector3,
pPosition2 : Vector3,
pTangent2 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the result of the Hermite spline interpolation.
pPosition | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
pTangent | Microsoft.DirectX.Vector3. Source Vector3 structure that is a tangent vector.
pPosition2 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
pTangent2 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a tangent vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (pPosition, pTangent) to (pPosition2, pTangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of pPosition, v2 is the contents of pPosition2, t1 is the contents of pTangent, t2 is the contents of pTangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Hermite method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Hermite


UnsafeNativeMethods.Vector3.Length(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 3-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal pSource As Vector3 _
) As Single
C# public static float Length(
Vector3 pSource
);
Managed C++ public: static float Length(
Vector3 pSource
);
JScript .NET public static function Length(
pSource : Vector3
) : float;

Parameters

pSource Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that contains the vector's length.

See Also

  • LengthSq
  • Microsoft.DirectX.Vector3.Length


UnsafeNativeMethods.Vector3.LengthSq(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 3-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal pSource As Vector3 _
) As Single
C# public static float LengthSq(
Vector3 pSource
);
Managed C++ public: static float LengthSq(
Vector3 pSource
);
JScript .NET public static function LengthSq(
pSource : Vector3
) : float;

Parameters

pSource Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that contains the vector's squared length.

See Also

  • Length
  • Microsoft.DirectX.Vector3.LengthSq


UnsafeNativeMethods.Vector3.Lerp(Vector3,Vector3,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a linear interpolation between two 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3, _
ByVal interpolater As Single _
) As Vector3
C# public static Vector3 Lerp(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight,
float interpolater
);
Managed C++ public: static Vector3 Lerp(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight,
float interpolater
);
JScript .NET public static function Lerp(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3,
interpolater : float
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the result of the linear interpolation.
pLeft | Microsoft.DirectX.Vector3. Source Vector3 structure.
pRight | Microsoft.DirectX.Vector3. Source Vector3 structure.
interpolater | System.Single. Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

pLeft + interpolater(pRight - pLeft).

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Lerp method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Lerp


UnsafeNativeMethods.Vector3.Maximize(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Maximize( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Maximize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
Managed C++ public: static Vector3 Maximize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript .NET public static function Maximize(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is made up of the largest components of the two vectors.
pLeft | Microsoft.DirectX.Vector3. Source Vector3 structure.
pRight | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is made up of the largest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Maximize method can be used as a parameter for another method.

See Also

  • Minimize
  • Microsoft.DirectX.Vector3.Maximize


UnsafeNativeMethods.Vector3.Minimize(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Minimize( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Minimize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
Managed C++ public: static Vector3 Minimize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript .NET public static function Minimize(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is made up of the smallest components of the two vectors.
pLeft | Microsoft.DirectX.Vector3. Source Vector3 structure.
pRight | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is made up of the smallest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Minimize method can be used as a parameter for another method.

See Also

  • Maximize
  • Microsoft.DirectX.Vector3.Minimize


UnsafeNativeMethods.Vector3.Normalize(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 3-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3 _
) As Vector3
C# public static Vector3 Normalize(
Vector3 pOut,
Vector3 pSource
);
Managed C++ public: static Vector3 Normalize(
Vector3 pOut,
Vector3 pSource
);
JScript .NET public static function Normalize(
pOut : Vector3,
pSource : Vector3
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the normalized version of the specified vector.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the normalized version of the specified vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Normalize method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Normalize


UnsafeNativeMethods.Vector3.Scale(Vector3,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 3-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3, _
ByVal scalingFactor As Single _
) As Vector3
C# public static Vector3 Scale(
Vector3 pOut,
Vector3 pSource,
float scalingFactor
);
Managed C++ public: static Vector3 Scale(
Vector3 pOut,
Vector3 pSource,
float scalingFactor
);
JScript .NET public static function Scale(
pOut : Vector3,
pSource : Vector3,
scalingFactor : float
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the scaled vector.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure.
scalingFactor | System.Single. Scaling value.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the scaled vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Scale method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Scale


UnsafeNativeMethods.Vector3.Subtract(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 3-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Subtract(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
Managed C++ public: static Vector3 Subtract(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript .NET public static function Subtract(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the result of the operation.
pLeft | Microsoft.DirectX.Vector3. Source Vector3 structure to the left of the subtraction operator.
pRight | Microsoft.DirectX.Vector3. Source Vector3 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Subtract method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Subtract


UnsafeNativeMethods.Vector3.Transform(Vector4,Vector3,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal pOut As Vector4, _
ByVal pSource As Vector3, _
ByVal pSourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector4 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
JScript .NET public static function Transform(
pOut : Vector4,
pSource : Vector3,
pSourceMatrix : Matrix
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the method.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

This method transforms the pSource vector (x, y, z, 1) by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Transform method can be used as a parameter for another method.

See Also

  • TransformCoordinate
  • TransformNormal
  • Microsoft.DirectX.Vector3.Transform


UnsafeNativeMethods.Vector3.TransformArray(Vector4,Int32,Vector3,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.TransformArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms an array of 3-D vectors by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformArray( _
ByVal pOut As Vector4, _
ByVal outStride As Integer, _
ByVal pSource As Vector3, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector4
C# public static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
Managed C++ public: static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript .NET public static function TransformArray(
pOut : Vector4,
outStride : int,
pSource : Vector3,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the method.
outStride | System.Int32. Stride between vectors in the output data stream.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure array.
vectorStride | System.Int32. Stride between vectors in the input data stream.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.
count | System.Int32. Number of elements in the array.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

This method transforms the array of vectors, pSource (x, y, 0, 1), by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformArray method can be used as a parameter for another method.


UnsafeNativeMethods.Vector3.TransformCoordinate(Vector3,Vector3,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector by a given matrix, projecting the result back into w = 1.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformCoordinate( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3, _
ByVal pSourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformCoordinate(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
Managed C++ public: static Vector3 TransformCoordinate(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
JScript .NET public static function TransformCoordinate(
pOut : Vector3,
pSource : Vector3,
pSourceMatrix : Matrix
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that represents the results of the method.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that represents the results of the method.

Remarks

This method transforms the source vector, pSource (x, y, z, 1) by the pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformCoordinate method can be used as a parameter for another method.

See Also

  • Transform
  • TransformNormal
  • Microsoft.DirectX.Vector3.TransformCoordinate


UnsafeNativeMethods.Vector3.TransformCoordinateArray(Vector3,Int32,Vector3,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.TransformCoordinateArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms array (x, y, z, 1) by a given matrix, and projects the result back into w = 1.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformCoordinateArray( _
ByVal pOut As Vector3, _
ByVal outStride As Integer, _
ByVal pSource As Vector3, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector3
C# public static Vector3 TransformCoordinateArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
Managed C++ public: static Vector3 TransformCoordinateArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript .NET public static function TransformCoordinateArray(
pOut : Vector3,
outStride : int,
pSource : Vector3,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that represents the results of the method.
outStride | System.Int32. Stride between vectors in the output data stream.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure array.
vectorStride | System.Int32. Stride between vectors in the input data stream.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.
count | System.Int32. Number of elements in the array.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the method.

Remarks

This method transforms all vectors in the pSource parameter by the matrix pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformCoordinateArray method can be used as a parameter for another method.

See Also

  • TransformCoordinate


UnsafeNativeMethods.Vector3.TransformNormal(Vector3,Vector3,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector normal by the given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformNormal( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3, _
ByVal pSourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformNormal(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
Managed C++ public: static Vector3 TransformNormal(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
JScript .NET public static function TransformNormal(
pOut : Vector3,
pSource : Vector3,
pSourceMatrix : Matrix
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that contains the results of this method.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, z, 0) of the pSource vector by the pSourceMatrix source matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformNormal method can be used as a parameter for another method.

See Also

  • Transform
  • TransformCoordinate
  • Microsoft.DirectX.Vector3.TransformNormal


UnsafeNativeMethods.Vector3.TransformNormalArray(Vector3,Int32,Vector3,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector3.TransformNormalArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms array (x, y, z, 0) by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformNormalArray( _
ByVal pOut As Vector3, _
ByVal outStride As Integer, _
ByVal pSource As Vector3, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector3
C# public static Vector3 TransformNormalArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
Managed C++ public: static Vector3 TransformNormalArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript .NET public static function TransformNormalArray(
pOut : Vector3,
outStride : int,
pSource : Vector3,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector3;

Parameters

pOut | Microsoft.DirectX.Vector3. A Vector3 structure that is the result of the method.
outStride | System.Int32. Stride between vectors in the output data stream.
pSource | Microsoft.DirectX.Vector3. Source Vector3 structure array.
vectorStride | System.Int32. Stride between vectors in the input data stream.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.
count | System.Int32. Number of elements in the array.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the method.

Remarks

This method transforms the vector normals (x, y, z, 0) of the pSource parameter by the matrix pSourceMatrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformNormalArray method can be used as a parameter for another method.


Microsoft.DirectX.UnsafeNativeMethods.Vector4

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4 Class

Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a vector in four-dimensional (4-D) space.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the methods of the Microsoft.DirectX.Vector4 structure.

Definition

Visual Basic .NET NotInheritable Public Class Vector4
Inherits Object
C# | public sealed class Vector4 : Object
Managed C++ | public __gc __sealed class Vector4 : public Object
JScript .NET | public class Vector4 extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic .NET) Add Adds two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) BaryCentric Returns a point in barycentric coordinates, using the specified 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) CatmullRom Performs a Catmull-Rom interpolation using specified 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Cross Determines the cross product in four dimensions.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Dot Determines the dot product of two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Hermite Performs a Hermite spline interpolation using the specified 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Length Returns the length of a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) LengthSq Returns the square of the length of a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Lerp Performs a linear interpolation between two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Maximize Returns a 4-D vector that is made up of the largest components of two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Minimize Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Normalize Returns the normalized version of a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Scale Scales a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Subtract Subtracts two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) Transform Transforms a 4-D vector or an array of 4-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic .NET) TransformArray Transforms a vector array by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Vector4

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


UnsafeNativeMethods.Vector4.Add(Vector4,Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Add(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
Managed C++ public: static Vector4 Add(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript .NET public static function Add(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. Sum of the two Vector4 structures.
pLeft | Microsoft.DirectX.Vector4. Source Vector4.
pRight | Microsoft.DirectX.Vector4. Source Vector4.

Return Value

Microsoft.DirectX.Vector4 . Sum of the two Vector4 structures.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Add method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Add


UnsafeNativeMethods.Vector4.BaryCentric(Vector4,Vector4,Vector4,Vector4,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a point in barycentric coordinates, using the specified 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal pOut As Vector4, _
ByVal pV1 As Vector4, _
ByVal pV2 As Vector4, _
ByVal pV3 As Vector4, _
ByVal f As Single, _
ByVal g As Single _
) As Vector4
C# public static Vector4 BaryCentric(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3,
float f,
float g
);
Managed C++ public: static Vector4 BaryCentric(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3,
float f,
float g
);
JScript .NET public static function BaryCentric(
pOut : Vector4,
pV1 : Vector4,
pV2 : Vector4,
pV3 : Vector4,
f : float,
g : float
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure in barycentric coordinates.
pV1 | Microsoft.DirectX.Vector4. Source Vector4 structure.
pV2 | Microsoft.DirectX.Vector4. Source Vector4 structure.
pV3 | Microsoft.DirectX.Vector4. Source Vector4 structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

pV1 + f(pV2 - pV1) + g(pV3 - pV1)

Any point in the plane pV1pV2pV3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which pV2 gets weighted into the result, and the f parameter controls the extent to which pV3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which pV1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle pV1pV2pV3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line pV1pV3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line pV1pV2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line pV2pV3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the BaryCentric method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.BaryCentric


UnsafeNativeMethods.Vector4.CatmullRom(Vector4,Vector4,Vector4,Vector4,Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.CatmullRom Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Catmull-Rom interpolation using specified 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function CatmullRom( _
ByVal pOut As Vector4, _
ByVal pPosition1 As Vector4, _
ByVal pPosition2 As Vector4, _
ByVal pPosition3 As Vector4, _
ByVal pPosition4 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 CatmullRom(
Vector4 pOut,
Vector4 pPosition1,
Vector4 pPosition2,
Vector4 pPosition3,
Vector4 pPosition4,
float weightingFactor
);
Managed C++ public: static Vector4 CatmullRom(
Vector4 pOut,
Vector4 pPosition1,
Vector4 pPosition2,
Vector4 pPosition3,
Vector4 pPosition4,
float weightingFactor
);
JScript .NET public static function CatmullRom(
pOut : Vector4,
pPosition1 : Vector4,
pPosition2 : Vector4,
pPosition3 : Vector4,
pPosition4 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the Catmull-Rom interpolation.
pPosition1 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
pPosition2 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
pPosition3 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
pPosition4 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of pPosition1, v2 is the contents of pPosition2, p3 is the contents of pPosition3, p4 is the contents of pPosition4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the following Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

The return value for this method is the same value returned in the pOut parameter. Resultantly, the CatmullRom method can be used as a parameter for another method.

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom
  • Microsoft.DirectX.Vector4.CatmullRom


UnsafeNativeMethods.Vector4.Cross(Vector4,Vector4,Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Cross Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the cross product in four dimensions.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Cross( _
ByVal pOut As Vector4, _
ByVal pV1 As Vector4, _
ByVal pV2 As Vector4, _
ByVal pV3 As Vector4 _
) As Vector4
C# public static Vector4 Cross(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3
);
Managed C++ public: static Vector4 Cross(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3
);
JScript .NET public static function Cross(
pOut : Vector4,
pV1 : Vector4,
pV2 : Vector4,
pV3 : Vector4
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the cross product.
pV1 | Microsoft.DirectX.Vector4. Source Vector4 structure.
pV2 | Microsoft.DirectX.Vector4. Source Vector4 structure.
pV3 | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the cross product.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Cross method can be used as a parameter for another method.

See Also

  • Dot
  • Microsoft.DirectX.Vector4.Cross


UnsafeNativeMethods.Vector4.Dot(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the dot product of two 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Single
C# public static float Dot(
Vector4 pLeft,
Vector4 pRight
);
Managed C++ public: static float Dot(
Vector4 pLeft,
Vector4 pRight
);
JScript .NET public static function Dot(
pLeft : Vector4,
pRight : Vector4
) : float;

Parameters

pLeft | Microsoft.DirectX.Vector4. Source Vector4 structure.
pRight | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

System.Single . A Single Leave Site value that represents the dot product.

See Also

  • Cross
  • Microsoft.DirectX.Vector4.Dot


UnsafeNativeMethods.Vector4.Hermite(Vector4,Vector4,Vector4,Vector4,Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Hermite Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Hermite spline interpolation using the specified 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Hermite( _
ByVal pOut As Vector4, _
ByVal pPosition As Vector4, _
ByVal pTangent As Vector4, _
ByVal pPosition2 As Vector4, _
ByVal pTangent2 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 Hermite(
Vector4 pOut,
Vector4 pPosition,
Vector4 pTangent,
Vector4 pPosition2,
Vector4 pTangent2,
float weightingFactor
);
Managed C++ public: static Vector4 Hermite(
Vector4 pOut,
Vector4 pPosition,
Vector4 pTangent,
Vector4 pPosition2,
Vector4 pTangent2,
float weightingFactor
);
JScript .NET public static function Hermite(
pOut : Vector4,
pPosition : Vector4,
pTangent : Vector4,
pPosition2 : Vector4,
pTangent2 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the Hermite spline interpolation.
pPosition | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
pTangent | Microsoft.DirectX.Vector4. Source Vector4 structure that is a tangent vector.
pPosition2 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
pTangent2 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a tangent vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (pPosition, pTangent) to (pPosition2, pTangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of pPosition v2 is the contents of pPosition2, t1 is the contents of pTangent, t2 is the contents of pTangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Hermite method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Hermite


UnsafeNativeMethods.Vector4.Length(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 4-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal pSource As Vector4 _
) As Single
C# public static float Length(
Vector4 pSource
);
Managed C++ public: static float Length(
Vector4 pSource
);
JScript .NET public static function Length(
pSource : Vector4
) : float;

Parameters

pSource Microsoft.DirectX.Vector4. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that indicates the vector's length.

See Also

  • LengthSq
  • Microsoft.DirectX.Vector4.Length


UnsafeNativeMethods.Vector4.LengthSq(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 4-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal pSource As Vector4 _
) As Single
C# public static float LengthSq(
Vector4 pSource
);
Managed C++ public: static float LengthSq(
Vector4 pSource
);
JScript .NET public static function LengthSq(
pSource : Vector4
) : float;

Parameters

pSource Microsoft.DirectX.Vector4. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that indicates the vector's squared length.

See Also

  • Length
  • Microsoft.DirectX.Vector4.LengthSq


UnsafeNativeMethods.Vector4.Lerp(Vector4,Vector4,Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a linear interpolation between two 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4, _
ByVal interpolater As Single _
) As Vector4
C# public static Vector4 Lerp(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight,
float interpolater
);
Managed C++ public: static Vector4 Lerp(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight,
float interpolater
);
JScript .NET public static function Lerp(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4,
interpolater : float
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the linear interpolation.
pLeft | Microsoft.DirectX.Vector4. Source Vector4 structure.
pRight | Microsoft.DirectX.Vector4. Source Vector4 structure.
interpolater | System.Single. Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

pLeft + interpolater(pRight - pLeft).

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Lerp method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Lerp


UnsafeNativeMethods.Vector4.Maximize(Vector4,Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Maximize( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Maximize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
Managed C++ public: static Vector4 Maximize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript .NET public static function Maximize(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is made up of the largest components of the two vectors.
pLeft | Microsoft.DirectX.Vector4. Source Vector4 structure.
pRight | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is made up of the largest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Maximize method can be used as a parameter for another method.

See Also

  • Minimize
  • Microsoft.DirectX.Vector4.Maximize


UnsafeNativeMethods.Vector4.Minimize(Vector4,Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Minimize( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Minimize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
Managed C++ public: static Vector4 Minimize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript .NET public static function Minimize(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is made up of the smallest components of the two vectors.
pLeft | Microsoft.DirectX.Vector4. Source Vector4 structure.
pRight | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is made up of the smallest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Minimize method can be used as a parameter for another method.

See Also

  • Maximize
  • Microsoft.DirectX.Vector4.Minimize


UnsafeNativeMethods.Vector4.Normalize(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 4-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal pOut As Vector4, _
ByVal pSource As Vector4 _
) As Vector4
C# public static Vector4 Normalize(
Vector4 pOut,
Vector4 pSource
);
Managed C++ public: static Vector4 Normalize(
Vector4 pOut,
Vector4 pSource
);
JScript .NET public static function Normalize(
pOut : Vector4,
pSource : Vector4
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the normalized version of the specified vector.
pSource | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the normalized version of the specified vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Normalize method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Normalize


UnsafeNativeMethods.Vector4.Scale(Vector4,Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 4-D vector.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal pOut As Vector4, _
ByVal pSource As Vector4, _
ByVal scalingFactor As Single _
) As Vector4
C# public static Vector4 Scale(
Vector4 pOut,
Vector4 pSource,
float scalingFactor
);
Managed C++ public: static Vector4 Scale(
Vector4 pOut,
Vector4 pSource,
float scalingFactor
);
JScript .NET public static function Scale(
pOut : Vector4,
pSource : Vector4,
scalingFactor : float
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the scaled vector.
pSource | Microsoft.DirectX.Vector4. Source Vector4 structure.
scalingFactor | System.Single. Scaling value.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the scaled vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Scale method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Scale


UnsafeNativeMethods.Vector4.Subtract(Vector4,Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 4-D vectors.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Subtract(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
Managed C++ public: static Vector4 Subtract(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript .NET public static function Subtract(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the operation.
pLeft | Microsoft.DirectX.Vector4. Source Vector4 structure to the left of the subtraction operator.
pRight | Microsoft.DirectX.Vector4. Source Vector4 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Subtract method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Subtract


UnsafeNativeMethods.Vector4.Transform(Vector4,Vector4,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal pOut As Vector4, _
ByVal pSource As Vector4, _
ByVal pSourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 pOut,
Vector4 pSource,
Matrix pSourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector4 pOut,
Vector4 pSource,
Matrix pSourceMatrix
);
JScript .NET public static function Transform(
pOut : Vector4,
pSource : Vector4,
pSourceMatrix : Matrix
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the method.
pSource | Microsoft.DirectX.Vector4. Source Vector4 structure.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

The return value for this method is the same value returned in the pOut parameter. Resultantly, the Transform method can be used as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Transform


UnsafeNativeMethods.Vector4.TransformArray(Vector4,Int32,Vector4,Int32,Matrix,Int32)

Microsoft DirectX 9.0 SDK Update (October 2004)

UnsafeNativeMethods.Vector4.TransformArray Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a vector array by a given matrix.

Note: For programming in Microsoft® Visual Basic® .NET or Microsoft® JScript® .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic .NET Public Shared Function TransformArray( _
ByVal pOut As Vector4, _
ByVal outStride As Integer, _
ByVal pSource As Vector4, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector4
C# public static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector4 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
Managed C++ public: static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector4 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript .NET public static function TransformArray(
pOut : Vector4,
outStride : int,
pSource : Vector4,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector4;

Parameters

pOut | Microsoft.DirectX.Vector4. A Vector4 structure that is the result of the method.
outStride | System.Int32. Stride between vectors in the output data stream.
pSource | Microsoft.DirectX.Vector4. Source Vector4 structure array.
vectorStride | System.Int32. Stride between vectors in the input data stream.
pSourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.
count | System.Int32. Number of elements in the array.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

This method transforms the array pSource (x, y, 0, 1) by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. Resultantly, the TransformArray method can be used as a parameter for another method.


Matrix

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Set Up a Projection Matrix

Describes and manipulates a matrix.

Definition

Visual Basic .NET | Public Structure Matrix
C# | public struct Matrix
Managed C++ | public __value struct Matrix
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
M11 | Retrieves or sets the element in the first row and the first column of the matrix.
M12 | Retrieves or sets the element in the first row and the second column of the matrix.
M13 | Retrieves or sets the element in the first row and the third column of the matrix.
M14 | Retrieves or sets the element in the first row and the fourth column of the matrix.
M21 | Retrieves or sets the element in the second row and the first column of the matrix.
M22 | Retrieves or sets the element in the second row and the second column of the matrix.
M23 | Retrieves or sets the element in the second row and the third column of the matrix.
M24 | Retrieves or sets the element in the second row and the fourth column of the matrix.
M31 | Retrieves or sets the element in the third row and the first column of the matrix.
M32 | Retrieves or sets the element in the third row and the second column of the matrix.
M33 | Retrieves or sets the element in the third row and the third column of the matrix.
M34 | Retrieves or sets the element in the third row and the fourth column of the matrix.
M41 | Retrieves or sets the element in the fourth row and the first column of the matrix.
M42 | Retrieves or sets the element in the fourth row and the second column of the matrix.
M43 | Retrieves or sets the element in the fourth row and the third column of the matrix.
M44 | Retrieves or sets the element in the fourth row and the fourth column of the matrix.

Methods

Method | Description
static (Shared in Visual Basic .NET) Add | Adds two matrices.
AffineTransformation | Builds a 3-D affine transformation matrix.
static (Shared in Visual Basic .NET) AffineTransformation2D | Builds a 2-D affine transformation matrix in the xy plane.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
Invert | Calculates the inverse of a matrix.
static (Shared in Visual Basic .NET) LookAtLH | Builds a left-handed look-at matrix.
static (Shared in Visual Basic .NET) LookAtRH | Builds a right-handed look-at matrix.
Matrix | Initializes a new instance of the Matrix class.
Multiply | Determines the product of two matrices.
MultiplyTranspose | Calculates the transposed product of two matrices.
static (Shared in Visual Basic .NET) op_Addition | Adds two instances of the Matrix structure.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Multiply | Determines the product of two matrices.
static (Shared in Visual Basic .NET) op_Subtraction | Subtracts two instances of the Matrix structure.
static (Shared in Visual Basic .NET) OrthoLH | Builds a left-handed orthogonal projection matrix.
static (Shared in Visual Basic .NET) OrthoOffCenterLH | Builds a customized, left-handed orthogonal projection matrix.
static (Shared in Visual Basic .NET) OrthoOffCenterRH | Builds a customized, right-handed orthogonal projection matrix.
static (Shared in Visual Basic .NET) OrthoRH | Builds a right-handed orthogonal projection matrix.
static (Shared in Visual Basic .NET) PerspectiveFovLH | Builds a left-handed perspective projection matrix based on a field of view.
static (Shared in Visual Basic .NET) PerspectiveFovRH | Builds a right-handed perspective projection matrix based on a field of view (FOV).
static (Shared in Visual Basic .NET) PerspectiveLH | Builds a left-handed perspective projection matrix.
static (Shared in Visual Basic .NET) PerspectiveOffCenterLH | Builds a customized, left-handed perspective projection matrix.
static (Shared in Visual Basic .NET) PerspectiveOffCenterRH | Builds a customized, right-handed perspective projection matrix.
static (Shared in Visual Basic .NET) PerspectiveRH | Builds a right-handed perspective projection matrix.
Reflect | Builds a matrix that reflects the coordinate system about a plane.
RotateAxis | Rotates the matrix around an arbitrary axis.
RotateQuaternion | Rotates a matrix from a quaternion.
RotateX | Rotates a matrix around the x-axis.
RotateY | Rotates a matrix around the y-axis.
RotateYawPitchRoll | Rotates a matrix with a specified yaw, pitch, and roll.
RotateZ | Rotates the matrix around the z-axis.
static (Shared in Visual Basic .NET) RotationAxis | Builds a matrix that rotates around an arbitrary axis.
static (Shared in Visual Basic .NET) RotationQuaternion | Builds a matrix from a quaternion.
static (Shared in Visual Basic .NET) RotationX | Builds a matrix that rotates around the x-axis.
static (Shared in Visual Basic .NET) RotationY | Builds a matrix that rotates around the y-axis.
static (Shared in Visual Basic .NET) RotationYawPitchRoll | Builds a matrix with a specified yaw, pitch, and roll.
static (Shared in Visual Basic .NET) RotationZ | Builds a matrix that rotates around the z-axis.
Scale | Scales the matrix along the x-axis, y-axis, and z-axis.
static (Shared in Visual Basic .NET) Scaling | Builds a matrix that scales along the x-axis, y-axis, and z-axis.
Shadow | Builds a matrix that flattens geometry into a plane.
static (Shared in Visual Basic .NET) Subtract | Subtracts one matrix from another.
ToString | Obtains a string representation of the current instance.
Transform | Transforms the matrix.
static (Shared in Visual Basic .NET) Transformation | Builds a transformation matrix.
static (Shared in Visual Basic .NET) Transformation2D | Builds a 2-D transformation matrix in the xy plane.
Translate | Translates the matrix using specified offsets.
static (Shared in Visual Basic .NET) Translation | Builds a matrix using specified offsets.
Transpose | Transposes the matrix using a source matrix.
static (Shared in Visual Basic .NET) TransposeMatrix | Returns the matrix transpose of a given matrix.

Properties

Property | Description
Determinant | Retrieves the determinant of the matrix.
static (Shared in Visual Basic .NET) Identity | Retrieves the identity of the matrix.
static (Shared in Visual Basic .NET) Zero | Retrieves an empty matrix.

Remarks

This structure represents a 4x4 matrix of Single Leave Site values. The fields of this structure are named with the row number first, then the column number.

In Microsoft® Direct3D®, the M34 element of a projection matrix cannot be a negative number. If an application needs to use a negative value in this location, it should scale the entire projection matrix by -1 instead.

How Do I...?

Set Up a Projection Matrix

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

              [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Device.GetTransform
  • Device.SetTransform
  • Device.SetTransform
  • Microsoft.DirectX.UnsafeNativeMethods.Matrix Class


Matrix.Add(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two matrices.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Add(
Matrix left,
Matrix right
);
Managed C++ public: static Matrix Add(
Matrix left,
Matrix right
);
JScript .NET public static function Add(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left | Microsoft.DirectX.Matrix. A Matrix instance on the left side of the addition operator.
right | Microsoft.DirectX.Matrix. A Matrix instance on the right side of the addition operator.

Return Value

Microsoft.DirectX.Matrix . A Matrix instance that represents the result of the addition.


Matrix.AffineTransformation(Single,Vector3,Quaternion,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.AffineTransformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a 3-D affine transformation matrix.

Definition

Visual Basic .NET Public Sub AffineTransformation( _
ByVal scaling As Single, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
)
C# public void AffineTransformation(
float scaling,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
Managed C++ public: void AffineTransformation(
float scaling,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript .NET public function AffineTransformation(
scaling : float,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
);

Parameters

scaling | System.Single. Scaling factor. A value of zero indicates no scaling.
rotationCenter | Microsoft.DirectX.Vector3. A Vector3 structure that indicates the point at the center of rotation.
rotation | Microsoft.DirectX.Quaternion. A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation | Microsoft.DirectX.Vector3. A Vector3 structure that represents the translation. Use Vector2.Empty to specify no translation.

Remarks

The AffineTransformation method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

Mout = Ms * (Mrc)-1 * Mr * Mrc * Mt

where:

  • Mout = output matrix (this instance)
  • Ms = scaling matrix (scaling)
  • Mrc = center of rotation matrix (rotationCenter)
  • Mr = rotation matrix (rotation)
  • Mt = translation matrix (translation)

For 2-D affine transformations, use AffineTransformation2D.


Matrix.AffineTransformation2D(Single,Vector2,Single,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.AffineTransformation2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a 2-D affine transformation matrix in the xy plane.

Definition

Visual Basic .NET Public Shared Function AffineTransformation2D( _
ByVal scaling As Single, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix AffineTransformation2D(
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
Managed C++ public: static Matrix AffineTransformation2D(
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript .NET public static function AffineTransformation2D(
scaling : float,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

scaling | System.Single. Scaling factor. A value of zero indicates no scaling.
rotationCenter | Microsoft.DirectX.Vector2. A Vector2 structure that represents a point identifying the center of rotation. Use an empty Vector2 for no rotation.
rotation | System.Single. Angle of rotation. A value of zero indicates no rotation
translation | Microsoft.DirectX.Vector2. A Vector2 structure that represents the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is an affine transformation matrix.

Remarks

The AffineTransformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

Mout = Ms * (Mrc)-1 * Mr * Mrc * Mt

where:

  • Mout = output matrix (this instance)
  • Ms = scaling matrix (scaling)
  • Mrc = center of rotation matrix (rotationCenter)
  • Mr = rotation matrix (rotation)
  • Mt = translation matrix (translation)

For 3-D affine transformations, use AffineTransformation.


Matrix.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Matrix.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Matrix.Invert

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the inverse of a matrix.

Overload List

public void Invert();
public static Matrix Invert(Matrix);
public static Matrix Invert(ref float, Matrix);


Matrix.Invert()

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the inverse of a matrix.

Definition

Visual Basic .NET | Public Sub Invert()
C# | public void Invert();
Managed C++ | public: void Invert();
JScript .NET | public function Invert();


Matrix.Invert(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the inverse of a matrix.

Definition

Visual Basic .NET Public Shared Function Invert( _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
Matrix source
);
Managed C++ public: static Matrix Invert(
Matrix source
);
JScript .NET public static function Invert(
source : Matrix
) : Matrix;

Parameters

source Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the result of the operation.


Matrix.Invert(Single,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the inverse of a matrix.

Definition

Visual Basic .NET Public Shared Function Invert( _
ByRef determinant As Single, _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
ref float determinant,
Matrix source
);
Managed C++ public: static Matrix Invert(
float *determinant,
Matrix source
);
JScript .NET public static function Invert(
determinant : float,
source : Matrix
) : Matrix;

Parameters

determinant | System.Single. A Single Leave Site value that contains the determinant of the matrix. If the determinant is not needed, the parameter is omitted.
source | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the result of the operation.


Matrix.LookAtLH(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.LookAtLH Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Set Up a View Matrix

Builds a left-handed look-at matrix.

Definition

Visual Basic .NET Public Shared Function LookAtLH( _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtLH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
Managed C++ public: static Matrix LookAtLH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript .NET public static function LookAtLH(
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

cameraPosition | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera look-at target.
cameraUpVector | Microsoft.DirectX.Vector3. A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a left-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraTarget - cameraPosition)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

How Do I...?

Set Up a View Matrix

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

              [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));

See Also

  • Matrix.LookAtRH


Matrix.LookAtRH(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.LookAtRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a right-handed look-at matrix.

Definition

Visual Basic .NET Public Shared Function LookAtRH( _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtRH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
Managed C++ public: static Matrix LookAtRH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript .NET public static function LookAtRH(
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

cameraPosition | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget | Microsoft.DirectX.Vector3. A Vector3 structure that defines the camera look-at target.
cameraUpVector | Microsoft.DirectX.Vector3. A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a right-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraPosition - cameraTarget)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

See Also

  • Matrix.LookAtLH


Matrix.Matrix()

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Matrix Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Matrix class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Matrix();
Managed C++ | public: Matrix();
JScript .NET | public function Matrix();


Matrix.Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of two matrices.

Overload List

public void Multiply(Matrix);
public static Matrix Multiply(Matrix, Matrix);

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

See Also

  • Quaternion.Multiply


Matrix.Multiply(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of two matrices.

Definition

Visual Basic .NET Public Sub Multiply( _
ByVal source As Matrix _
)
C# public void Multiply(
Matrix source
);
Managed C++ public: void Multiply(
Matrix source
);
JScript .NET public function Multiply(
source : Matrix
);

Parameters

source Microsoft.DirectX.Matrix. Source Matrix structure to multiply by the current instance.

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

See Also

  • Quaternion.Multiply


Matrix.Multiply(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of two matrices.

Definition

Visual Basic .NET Public Shared Function Multiply( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Multiply(
Matrix left,
Matrix right
);
Managed C++ public: static Matrix Multiply(
Matrix left,
Matrix right
);
JScript .NET public static function Multiply(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left | Microsoft.DirectX.Matrix. Source Matrix structure.
right | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the product of two matrices.

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

See Also

  • Quaternion.Multiply


Matrix.MultiplyTranspose

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.MultiplyTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the transposed product of two matrices.

Overload List

public void MultiplyTranspose(Matrix);
public static Matrix MultiplyTranspose(Matrix, Matrix);

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

See Also

  • Matrix.Multiply
  • Quaternion.Multiply


Matrix.MultiplyTranspose(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.MultiplyTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the transposed product of two matrices.

Definition

Visual Basic .NET Public Sub MultiplyTranspose( _
ByVal source As Matrix _
)
C# public void MultiplyTranspose(
Matrix source
);
Managed C++ public: void MultiplyTranspose(
Matrix source
);
JScript .NET public function MultiplyTranspose(
source : Matrix
);

Parameters

source Microsoft.DirectX.Matrix. Source Matrix structure to multiply and transpose with the current instance.

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

See Also

  • Matrix.Multiply
  • Quaternion.Multiply


Matrix.MultiplyTranspose(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.MultiplyTranspose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the transposed product of two matrices.

Definition

Visual Basic .NET Public Shared Function MultiplyTranspose( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix MultiplyTranspose(
Matrix left,
Matrix right
);
Managed C++ public: static Matrix MultiplyTranspose(
Matrix left,
Matrix right
);
JScript .NET public static function MultiplyTranspose(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left | Microsoft.DirectX.Matrix. Source Matrix structure.
right | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the product and transposition of two matrices.

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

See Also

  • Matrix.Multiply
  • Quaternion.Multiply


Matrix.op_Addition(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.op_Addition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two instances of the Matrix structure.

Definition

Visual Basic .NET Public Shared Function op_Addition( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix op_Addition(
Matrix left,
Matrix right
);
Managed C++ public: static Matrix op_Addition(
Matrix left,
Matrix right
);
JScript .NET public static function op_Addition(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left | Microsoft.DirectX.Matrix. The Matrix structure to the left of the addition operator.
right | Microsoft.DirectX.Matrix. The Matrix structure to the right of the addition operator.

Return Value

Microsoft.DirectX.Matrix . Resulting Matrix structure.


Matrix.op_Equality(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Boolean
C# public static bool op_Equality(
Matrix left,
Matrix right
);
Managed C++ public: static bool op_Equality(
Matrix left,
Matrix right
);
JScript .NET public static function op_Equality(
left : Matrix,
right : Matrix
) : boolean;

Parameters

left | Microsoft.DirectX.Matrix. The Matrix structure to the left of the equality operator.
right | Microsoft.DirectX.Matrix. The Matrix structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Matrix.op_Inequality(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Boolean
C# public static bool op_Inequality(
Matrix left,
Matrix right
);
Managed C++ public: static bool op_Inequality(
Matrix left,
Matrix right
);
JScript .NET public static function op_Inequality(
left : Matrix,
right : Matrix
) : boolean;

Parameters

left | Microsoft.DirectX.Matrix. The Matrix structure to the left of the inequality operator.
right | Microsoft.DirectX.Matrix. The Matrix structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Matrix.op_Multiply(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of two matrices.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix op_Multiply(
Matrix left,
Matrix right
);
Managed C++ public: static Matrix op_Multiply(
Matrix left,
Matrix right
);
JScript .NET public static function op_Multiply(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left | Microsoft.DirectX.Matrix. Source Matrix structure.
right | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is the product of two matrices.

See Also

  • Multiply


Matrix.op_Subtraction(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.op_Subtraction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two instances of the Matrix structure.

Definition

Visual Basic .NET Public Shared Function op_Subtraction( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix op_Subtraction(
Matrix left,
Matrix right
);
Managed C++ public: static Matrix op_Subtraction(
Matrix left,
Matrix right
);
JScript .NET public static function op_Subtraction(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left | Microsoft.DirectX.Matrix. The Matrix structure to the left of the subtraction operator.
right | Microsoft.DirectX.Matrix. The Matrix structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Matrix . Resulting Matrix structure.


Matrix.OrthoLH(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.OrthoLH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a left-handed orthogonal projection matrix.

Definition

Visual Basic .NET Public Shared Function OrthoLH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix OrthoLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript .NET public static function OrthoLH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width | System.Single. Width of the view volume.
height | System.Single. Height of the view volume.
znearPlane | System.Single. Minimum z-value of the view volume, which is referred to as z-near.
zfarPlane | System.Single. Maximum z-value of the view volume, which is referred to as z-far.

Return Value

Microsoft.DirectX.Matrix . Pointer to a Matrix structure that is a left-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

All of the parameters of the OrthoLH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/width    0         0                                  0
0          2/height  0                                  0
0          0         1/(zfarPlane-znearPlane)           0
0          0         znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoRH
  • Matrix.OrthoOffCenterRH
  • Matrix.OrthoOffCenterLH


Matrix.OrthoOffCenterLH(Single,Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.OrthoOffCenterLH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a customized, left-handed orthogonal projection matrix.

Definition

Visual Basic .NET Public Shared Function OrthoOffCenterLH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix OrthoOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript .NET public static function OrthoOffCenterLH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left | System.Single. Minimum x-value of the view volume.
right | System.Single. Maximum x-value of the view volume.
bottom | System.Single. Minimum y-value of the view volume.
top | System.Single. Maximum y-value of the view volume.
znearPlane | System.Single. Minimum z-value of the view volume.
zfarPlane | System.Single. Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a customized, left-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

The OrthoLH method is a special case of the OrthoOffCenterLH method. To create the same projection using OrthoOffCenterLH, use the following values: left = -width/2, right = width/2, bottom = -height/2, and top = height/2.

All of the parameters of the OrthoOffCenterLH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/(right-l)           0                         0                                  0
0                     2/(top-bottom)            0                                  0
0                     0                         1/(zfarPlane-znearPlane)           0
(l+right)/(l-right)  (top+bottom)/(bottom-top)  znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoLH
  • Matrix.OrthoRH
  • Matrix.OrthoOffCenterRH


Matrix.OrthoOffCenterRH(Single,Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.OrthoOffCenterRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a customized, right-handed orthogonal projection matrix.

Definition

Visual Basic .NET Public Shared Function OrthoOffCenterRH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix OrthoOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript .NET public static function OrthoOffCenterRH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left | System.Single. Minimum x-value of the view volume.
right | System.Single. Maximum x-value of the view volume.
bottom | System.Single. Maximum y-value of the view volume.
top | System.Single. Minimum y-value of the view volume.
znearPlane | System.Single. Minimum z-value of the view volume.
zfarPlane | System.Single. Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a customized, right-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

The OrthoRH method is a special case of the OrthoOffCenterRH method. To create the same projection using OrthoOffCenterRH, use the following values: left = -width/2, right = width/2, bottom = -height/2, and top = height/2.

All of the parameters of the OrthoOffCenterRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/(right-left)         0                         0                                  0
0                      2/(top-bottom)            0                                  0
0                      0                         1/(znearPlane-zfarPlane)           0
(l+right)/(l-rright)  (top+bottom)/(bottom-top)  znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoLH
  • Matrix.OrthoRH
  • Matrix.OrthoOffCenterLH


Matrix.OrthoRH(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.OrthoRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a right-handed orthogonal projection matrix.

Definition

Visual Basic .NET Public Shared Function OrthoRH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix OrthoRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript .NET public static function OrthoRH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width | System.Single. Width of the view volume.
height | System.Single. Height of the view volume.
znearPlane | System.Single. Minimum z-value of the view volume.
zfarPlane | System.Single. Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix . Pointer to a Matrix structure that is a right-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

All of the parameters of the OrthoRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/width  0         0                                  0
0        2/height  0                                  0
0        0         1/(znearPlane-zfarPlane)           0
0        0         znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoLH
  • Matrix.OrthoOffCenterRH
  • Matrix.OrthoOffCenterLH


Matrix.PerspectiveFovLH(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.PerspectiveFovLH Method

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Set Up a Projection Matrix

Builds a left-handed perspective projection matrix based on a field of view.

Definition

Visual Basic .NET Public Shared Function PerspectiveFovLH( _
ByVal fieldOfViewY As Single, _
ByVal aspectRatio As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveFovLH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix PerspectiveFovLH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
JScript .NET public static function PerspectiveFovLH(
fieldOfViewY : float,
aspectRatio : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

fieldOfViewY | System.Single. Field of view in the y direction, in radians.
aspectRatio | System.Single. Aspect ratio, defined as the view space width divided by height.
znearPlane | System.Single. Z-value of the near view plane.
zfarPlane | System.Single. Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a left-handed perspective projection matrix.

Remarks

This method uses the following formula to compute the returned matrix. The view space height is represented by h, which is calculated from h = cot(fieldOfViewY/2). The view space width is represented by w, which is calculated from h = w / aspectRatio.

w       0       0                                             0
0       h       0                                             0
0       0       zfarPlane/(zfarPlane-znearPlane)              1
0       0       -znearPlane*zfarPlane/(zfarPlane-znearPlane)  0

How Do I...?

Set Up a Projection Matrix

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

              [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );

See Also

  • PerspectiveFovRH
  • PerspectiveLH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH
  • PerspectiveRH


Matrix.PerspectiveFovRH(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.PerspectiveFovRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a right-handed perspective projection matrix based on a field of view (FOV).

Definition

Visual Basic .NET Public Shared Function PerspectiveFovRH( _
ByVal fieldOfViewY As Single, _
ByVal aspectRatio As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveFovRH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix PerspectiveFovRH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
JScript .NET public static function PerspectiveFovRH(
fieldOfViewY : float,
aspectRatio : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

fieldOfViewY | System.Single. Field of view in the y direction, in radians.
aspectRatio | System.Single. Aspect ratio, defined as the view space width divided by height.
znearPlane | System.Single. Z-value of the near view plane.
zfarPlane | System.Single. Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a right-handed perspective projection matrix.

Remarks

This method uses the following formula to compute the returned matrix. The view space height is represented by h. It is calculated from h = cot(fieldOfViewY/2). The view space width is represented by w. It is calculated from h = w / aspectRatio.

w       0       0                                              0
0       h       0                                              0
0       0       zfarPlane/(znearPlane-zfarPlane)              -1
0       0       znearPlane*zfarPlane/(znearPlane-zfarPlane)    0

See Also

  • PerspectiveFovLH
  • PerspectiveLH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH
  • PerspectiveRH


Matrix.PerspectiveLH(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.PerspectiveLH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a left-handed perspective projection matrix.

Definition

Visual Basic .NET Public Shared Function PerspectiveLH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix PerspectiveLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript .NET public static function PerspectiveLH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width | System.Single. Width of the view volume at the near view plane.
height | System.Single. Height of the view volume at the near view plane.
znearPlane | System.Single. Z-value of the near view plane.
zfarPlane | System.Single. Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a left-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveLH method are distances in camera space. The parameters describe the dimensions of the view volume.

2*znearPlane/width  0                    0                                            0
0                   2*znearPlane/height  0                                            0
0                   0                    zfarPlane/(zfarPlane-znearPlane)             1
0                   0                    znearPlane*zfarPlane/(znearPlane-zfarPlane)  0

See Also

  • PerspectiveFovLH
  • PerspectiveRH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH
  • PerspectiveRH


Matrix.PerspectiveOffCenterLH(Single,Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.PerspectiveOffCenterLH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a customized, left-handed perspective projection matrix.

Definition

Visual Basic .NET Public Shared Function PerspectiveOffCenterLH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix PerspectiveOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript .NET public static function PerspectiveOffCenterLH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left | System.Single. Minimum x-value of the view volume.
right | System.Single. Maximum x-value of the view volume.
bottom | System.Single. Minimum y-value of the view volume.
top | System.Single. Maximum y-value of the view volume.
znearPlane | System.Single. Minimum z-value of the view volume.
zfarPlane | System.Single. Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix . Pointer to a Matrix structure that is a customized, left-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveOffCenterLH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2*znearPlane/(right-left)  0                           0                                            0
0                          2*znearPlane/(top-bottom)   0                                            0
(left+right)/(left-right)  (top+bottom)/(bottom-top)   zfarPlane/(zfarPlane-znearPlane)             1
0                          0                           znearPlane*zfarPlane/(znearPlane-zfarPlane)  0

See Also

  • PerspectiveFovLH
  • PerspectiveFovRH
  • PerspectiveRH
  • PerspectiveLH
  • PerspectiveOffCenterRH


Matrix.PerspectiveOffCenterRH(Single,Single,Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.PerspectiveOffCenterRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a customized, right-handed perspective projection matrix.

Definition

Visual Basic .NET Public Shared Function PerspectiveOffCenterRH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix PerspectiveOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript .NET public static function PerspectiveOffCenterRH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left | System.Single. Minimum x-value of the view volume.
right | System.Single. Maximum x-value of the view volume.
bottom | System.Single. Minimum y-value of the view volume.
top | System.Single. Maximum y-value of the view volume.
znearPlane | System.Single. Minimum z-value of the view volume.
zfarPlane | System.Single. Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that is a customized, right-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveOffCenterRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2*znearPlane/(right-left)   0                           0                                              0
0                           2*znearPlane*(top-bottom)   0                                              0
(left+right)/(right-left)  (top+bottom)/(top-bottom)    zfarPlane/(znearPlane-zfarPlane)              -1
0                           0                           znearPlane*zfarPlane/(znearPlane-zfarPlane)    0

See Also

  • PerspectiveFovLH
  • PerspectiveFovRH
  • PerspectiveRH
  • PerspectiveLH
  • PerspectiveOffCenterLH


Matrix.PerspectiveRH(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.PerspectiveRH Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a right-handed perspective projection matrix.

Definition

Visual Basic .NET Public Shared Function PerspectiveRH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
Managed C++ public: static Matrix PerspectiveRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript .NET public static function PerspectiveRH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width | System.Single. Width of the view volume at the near view plane.
height | System.Single. Height of the view volume at the near view plane.
znearPlane | System.Single. Z-value of the near view plane.
zfarPlane | System.Single. Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix . Pointer to a Matrix structure that is a right-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2*znearPlane/width  0                    0                                            0
0                   2*znearPlane/height  0                                            0
0                   0                    zfarPlane/(znearPlane-zfarPlane)            -1
0                   0                    znearPlane*zfarPlane/(znearPlane-zfarPlane)  0

See Also

  • PerspectiveFovLH
  • PerspectiveFovRH
  • PerspectiveLH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH


Matrix.Reflect(Plane)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Reflect Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that reflects the coordinate system about a plane.

Definition

Visual Basic .NET Public Sub Reflect( _
ByVal plane As Plane _
)
C# public void Reflect(
Plane plane
);
Managed C++ public: void Reflect(
Plane plane
);
JScript .NET public function Reflect(
plane : Plane
);

Parameters

plane Microsoft.DirectX.Plane. Source Plane structure.

Remarks

The Reflect method normalizes the plane equation before it creates the reflected matrix.

The method uses the following formula to compute the returned matrix.

P = normalize(plane);

-2 * P.a * P.a + 1  -2 * P.b * P.a      -2 * P.c * P.a        0
-2 * P.a * P.b      -2 * P.b * P.b + 1  -2 * P.c * P.b        0
-2 * P.a * P.c      -2 * P.b * P.c      -2 * P.c * P.c + 1    0
-2 * P.a * P.d      -2 * P.b * P.d      -2 * P.c * P.d        1


Matrix.RotateAxis(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotateAxis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the matrix around an arbitrary axis.

Definition

Visual Basic .NET Public Sub RotateAxis( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxis(
Vector3 axisRotation,
float angle
);
Managed C++ public: void RotateAxis(
Vector3 axisRotation,
float angle
);
JScript .NET public function RotateAxis(
axisRotation : Vector3,
angle : float
);

Parameters

axisRotation | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the axis about which to rotate the matrix.
angle | System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Matrix.RotateQuaternion
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateQuaternion(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotateQuaternion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates a matrix from a quaternion.

Definition

Visual Basic .NET Public Sub RotateQuaternion( _
ByVal quat As Quaternion _
)
C# public void RotateQuaternion(
Quaternion quat
);
Managed C++ public: void RotateQuaternion(
Quaternion quat
);
JScript .NET public function RotateQuaternion(
quat : Quaternion
);

Parameters

quat Microsoft.DirectX.Quaternion. Source Quaternion structure that defines the rotation.

Remarks

For information about how to calculate quaternion values from a direction vector ( x, y, z ) and an angle of rotation, see Quaternion.

See Also

  • Matrix.RotateAxis
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateX(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotateX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates a matrix around the x-axis.

Definition

Visual Basic .NET Public Sub RotateX( _
ByVal angle As Single _
)
C# public void RotateX(
float angle
);
Managed C++ public: void RotateX(
float angle
);
JScript .NET public function RotateX(
angle : float
);

Parameters

angle System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Matrix.RotateAxis
  • Matrix.RotateQuaternion
  • Matrix.RotateY
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateY(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotateY Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates a matrix around the y-axis.

Definition

Visual Basic .NET Public Sub RotateY( _
ByVal angle As Single _
)
C# public void RotateY(
float angle
);
Managed C++ public: void RotateY(
float angle
);
JScript .NET public function RotateY(
angle : float
);

Parameters

angle System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Matrix.RotateAxis
  • Matrix.Quaternion
  • Matrix.RotateX
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateYawPitchRoll(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotateYawPitchRoll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates a matrix with a specified yaw, pitch, and roll.

Definition

Visual Basic .NET Public Sub RotateYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
Managed C++ public: void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript .NET public function RotateYawPitchRoll(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw | System.Single. Yaw around the y-axis, in radians.
pitch | System.Single. Pitch around the x-axis, in radians.
roll | System.Single. Roll around the z-axis, in radians.

Remarks

The order of transformations is first roll, then pitch, then yaw. Relative to the object's local coordinate axis, this is equivalent to rotation around the z-axis, followed by rotation around the x-axis, followed by rotation around the y-axis.

Pitch Yaw Roll diagram

See Also

  • Matrix.RotateAxis
  • Matrix.Quaternion
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateZ


Matrix.RotateZ(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotateZ Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates the matrix around the z-axis.

Definition

Visual Basic .NET Public Sub RotateZ( _
ByVal angle As Single _
)
C# public void RotateZ(
float angle
);
Managed C++ public: void RotateZ(
float angle
);
JScript .NET public function RotateZ(
angle : float
);

Parameters

angle System.Single. Angle of rotation, in radians. Angles are measured clockwise when viewed from the rotation axis (positive side) toward the origin.

See Also

  • Matrix.RotateAxis
  • Matrix.Quaternion
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateYawPitchRoll


Matrix.RotationAxis(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotationAxis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that rotates around an arbitrary axis.

Definition

Visual Basic .NET Public Shared Function RotationAxis( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationAxis(
Vector3 axisRotation,
float angle
);
Managed C++ public: static Matrix RotationAxis(
Vector3 axisRotation,
float angle
);
JScript .NET public static function RotationAxis(
axisRotation : Vector3,
angle : float
) : Matrix;

Parameters

axisRotation | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the axis about which to rotate the matrix.
angle | System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

Remarks

The input rotation angle is in radians.

See Also

  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationQuaternion(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotationQuaternion Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix from a quaternion.

Definition

Visual Basic .NET Public Shared Function RotationQuaternion( _
ByVal quat As Quaternion _
) As Matrix
C# public static Matrix RotationQuaternion(
Quaternion quat
);
Managed C++ public: static Matrix RotationQuaternion(
Quaternion quat
);
JScript .NET public static function RotationQuaternion(
quat : Quaternion
) : Matrix;

Parameters

quat Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

Remarks

For information about how to calculate quaternion values from a direction vector (x, y, z) and an angle of rotation, see Quaternion.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationX(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotationX Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that rotates around the x-axis.

Definition

Visual Basic .NET Public Shared Function RotationX( _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationX(
float angle
);
Managed C++ public: static Matrix RotationX(
float angle
);
JScript .NET public static function RotationX(
angle : float
) : Matrix;

Parameters

angle System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

Remarks

The input rotation angle is in radians.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationY
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationY(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotationY Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that rotates around the y-axis.

Definition

Visual Basic .NET Public Shared Function RotationY( _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationY(
float angle
);
Managed C++ public: static Matrix RotationY(
float angle
);
JScript .NET public static function RotationY(
angle : float
) : Matrix;

Parameters

angle System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationYawPitchRoll(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotationYawPitchRoll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix with a specified yaw, pitch, and roll.

Definition

Visual Basic .NET Public Shared Function RotationYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
) As Matrix
C# public static Matrix RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
Managed C++ public: static Matrix RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript .NET public static function RotationYawPitchRoll(
yaw : float,
pitch : float,
roll : float
) : Matrix;

Parameters

yaw | System.Single. Yaw around the y-axis, in radians.
pitch | System.Single. Pitch around the x-axis, in radians.
roll | System.Single. Roll around the z-axis, in radians.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

Remarks

The order of transformations is first roll, then pitch, then yaw. Relative to the object's local coordinate axis, this is equivalent to rotation around the z-axis, followed by rotation around the x-axis, followed by rotation around the y-axis.

Pitch Yaw Roll diagram

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationZ


Matrix.RotationZ(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.RotationZ Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that rotates around the z-axis.

Definition

Visual Basic .NET Public Shared Function RotationZ( _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationZ(
float angle
);
Managed C++ public: static Matrix RotationZ(
float angle
);
JScript .NET public static function RotationZ(
angle : float
) : Matrix;

Parameters

angle System.Single. Angle of rotation, in radians. Angles are measured clockwise when viewed from the rotation axis (positive side) toward the origin.

Return Value

Microsoft.DirectX.Matrix . Rotated Matrix structure.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationYawPitchRoll


Matrix.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales the matrix along the x-axis, y-axis, and z-axis.

Overload List

public void Scale(float, float, float);
public void Scale(Vector3);


Matrix.Scale(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales the matrix along the x-axis, y-axis, and z-axis.

Definition

Visual Basic .NET Public Sub Scale( _
ByVal v As Vector3 _
)
C# public void Scale(
Vector3 v
);
Managed C++ public: void Scale(
Vector3 v
);
JScript .NET public function Scale(
v : Vector3
);

Parameters

v Microsoft.DirectX.Vector3. A Vector3 structure containing three values that represent the scaling factors applied along the x-axis, y-axis, and z-axis.


Matrix.Scale(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales the matrix along the x-axis, y-axis, and z-axis.

Definition

Visual Basic .NET Public Sub Scale( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Scale(
float x,
float y,
float z
);
Managed C++ public: void Scale(
float x,
float y,
float z
);
JScript .NET public function Scale(
x : float,
y : float,
z : float
);

Parameters

x | System.Single. Scaling factor that is applied along the x-axis.
y | System.Single. Scaling factor that is applied along the y-axis.
z | System.Single. Scaling factor that is applied along the z-axis.


Matrix.Scaling

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Scaling Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Overload List

public static Matrix Scaling(float, float, float);
public static Matrix Scaling(Vector3);


Matrix.Scaling(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Scaling Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Definition

Visual Basic .NET Public Shared Function Scaling( _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Scaling(
Vector3 v
);
Managed C++ public: static Matrix Scaling(
Vector3 v
);
JScript .NET public static function Scaling(
v : Vector3
) : Matrix;

Parameters

v Microsoft.DirectX.Vector3. A Vector3 structure containing three values that represent the scaling factors applied along the x-axis, y-axis, and z-axis.

Return Value

Microsoft.DirectX.Matrix . Scaled Matrix structure.


Matrix.Scaling(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Scaling Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Definition

Visual Basic .NET Public Shared Function Scaling( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
) As Matrix
C# public static Matrix Scaling(
float x,
float y,
float z
);
Managed C++ public: static Matrix Scaling(
float x,
float y,
float z
);
JScript .NET public static function Scaling(
x : float,
y : float,
z : float
) : Matrix;

Parameters

x | System.Single. Scaling factor that is applied along the x-axis.
y | System.Single. Scaling factor that is applied along the y-axis.
z | System.Single. Scaling factor that is applied along the z-axis.

Return Value

Microsoft.DirectX.Matrix . Scaled Matrix structure.


Matrix.Shadow(Vector4,Plane)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Shadow Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix that flattens geometry into a plane.

Definition

Visual Basic .NET Public Sub Shadow( _
ByVal light As Vector4, _
ByVal plane As Plane _
)
C# public void Shadow(
Vector4 light,
Plane plane
);
Managed C++ public: void Shadow(
Vector4 light,
Plane plane
);
JScript .NET public function Shadow(
light : Vector4,
plane : Plane
);

Parameters

light | Microsoft.DirectX.Vector4. A Vector4 structure that describes the light's position.
plane | Microsoft.DirectX.Plane. Source Plane structure.

Remarks

The Shadow method flattens geometry into a plane, as if it were casting a shadow from a light.

This method uses the following formula to compute the returned matrix.

P = normalize(Plane);
L = Light;
d = dot(P, L)

P.a * L.x + d  P.a * L.y      P.a * L.z      P.a * L.w
P.b * L.x      P.b * L.y + d  P.b * L.z      P.b * L.w
P.c * L.x      P.c * L.y      P.c * L.z + d  P.c * L.w
P.d * L.x      P.d * L.y      P.d * L.z      P.d * L.w + d
If the light's w-component is 0, the ray from the light's origin represents a directional light. If the w-component is 1, the light is a point light.


Matrix.Subtract(Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts one matrix from another.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Subtract(
Matrix left,
Matrix right
);
Managed C++ public: static Matrix Subtract(
Matrix left,
Matrix right
);
JScript .NET public static function Subtract(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left | Microsoft.DirectX.Matrix. A Matrix instance on the left side of the subtraction operation.
right | Microsoft.DirectX.Matrix. A Matrix instance on the right side of the subtraction operation.

Return Value

Microsoft.DirectX.Matrix . A Matrix instance that represents the result of the subtraction.


Matrix.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Matrix.Transform(Vector3,Quaternion,Vector3,Vector3,Quaternion,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms the matrix.

Definition

Visual Basic .NET Public Sub Transform( _
ByVal scalingCenter As Vector3, _
ByVal scalingRotation As Quaternion, _
ByVal scalingFactor As Vector3, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
)
C# public void Transform(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
Managed C++ public: void Transform(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript .NET public function Transform(
scalingCenter : Vector3,
scalingRotation : Quaternion,
scalingFactor : Vector3,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
);

Parameters

scalingCenter | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the scaling center point.
scalingRotation | Microsoft.DirectX.Quaternion. A Quaternion structure that specifies the scaling rotation. Use Quaternion.Identity to specify no scaling.
scalingFactor | Microsoft.DirectX.Vector3. A Vector3 structure that is the scaling vector.
rotationCenter | Microsoft.DirectX.Vector3. A Vector3 structure that is a point that identifies the center of rotation.
rotation | Microsoft.DirectX.Quaternion. A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation | Microsoft.DirectX.Vector3. A Vector3 structure that represents the translation. Use Vector3.Empty to specify no translation.

Remarks

The Transform method calculates the transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = transformation matrix
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scalingFactor)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

For 3-D affine transformations, use AffineTransformation.

See Also

  • Transformation
  • AffineTransformation


Matrix.Transformation(Vector3,Quaternion,Vector3,Vector3,Quaternion,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Transformation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a transformation matrix.

Definition

Visual Basic .NET Public Shared Function Transformation( _
ByVal scalingCenter As Vector3, _
ByVal scalingRotation As Quaternion, _
ByVal scalingFactor As Vector3, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
) As Matrix
C# public static Matrix Transformation(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
Managed C++ public: static Matrix Transformation(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript .NET public static function Transformation(
scalingCenter : Vector3,
scalingRotation : Quaternion,
scalingFactor : Vector3,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
) : Matrix;

Parameters

scalingCenter | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the scaling center point.
scalingRotation | Microsoft.DirectX.Quaternion. A Quaternion structure that specifies the scaling rotation. Use Quaternion.Identity to specify no scaling.
scalingFactor | Microsoft.DirectX.Vector3. A Vector3 structure that is the scaling vector.
rotationCenter | Microsoft.DirectX.Vector3. A Vector3 structure that is a point identifying the center of rotation.
rotation | Microsoft.DirectX.Quaternion. A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation | Microsoft.DirectX.Vector3. A Vector3 structure that represents the translation. Use Vector3.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix . Resulting Matrix structure.

Remarks

The Transformation method calculates the transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (the return value)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scalingFactor)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

For 3-D affine transformations, use AffineTransformation.

See Also

  • Transform
  • AffineTransformation
  • Transformation2D


Matrix.Transformation2D(Vector2,Single,Vector2,Vector2,Single,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Transformation2D Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a 2-D transformation matrix in the xy plane.

Definition

Visual Basic .NET Public Shared Function Transformation2D( _
ByVal scalingCenter As Vector2, _
ByVal scalingRotation As Single, _
ByVal scaling As Vector2, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix Transformation2D(
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
Managed C++ public: static Matrix Transformation2D(
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript .NET public static function Transformation2D(
scalingCenter : Vector2,
scalingRotation : float,
scaling : Vector2,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

scalingCenter | Microsoft.DirectX.Vector2. A Vector2 structure that is a point identifying the scaling center.
scalingRotation | System.Single. Scaling rotation factor. Use a zero value to specify no rotation.
scaling | Microsoft.DirectX.Vector2. A Vector2 structure that is a point identifying the scale. Use Vector2.Empty to specify no scaling.
rotationCenter | Microsoft.DirectX.Vector2. A Vector2 structure that is a point identifying the rotation center.
rotation | System.Single. Angle of rotation, in radians.
translation | Microsoft.DirectX.Vector2. A Vector2 structure that identifies the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that contains the transformation matrix.

Remarks

The Transformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order:

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (the return value)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scaling)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

For 3-D transformations, use Transformation.


Matrix.Translate

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Translate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Translates the matrix using specified offsets.

Overload List

public void Translate(float, float, float);
public void Translate(Vector3);


Matrix.Translate(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Translate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Translates the matrix using specified offsets.

Definition

Visual Basic .NET Public Sub Translate( _
ByVal v As Vector3 _
)
C# public void Translate(
Vector3 v
);
Managed C++ public: void Translate(
Vector3 v
);
JScript .NET public function Translate(
v : Vector3
);

Parameters

v Microsoft.DirectX.Vector3. A Vector3 structure that contains the x-coordinate, y-coordinate, and z-coordinate offsets.


Matrix.Translate(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Translate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Translates the matrix using specified offsets.

Definition

Visual Basic .NET Public Sub Translate( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Translate(
float x,
float y,
float z
);
Managed C++ public: void Translate(
float x,
float y,
float z
);
JScript .NET public function Translate(
x : float,
y : float,
z : float
);

Parameters

x | System.Single. X-coordinate offset.
y | System.Single. Y-coordinate offset.
z | System.Single. Z-coordinate offset.


Matrix.Translation

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Translation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix using specified offsets.

Overload List

public static Matrix Translation(float, float, float);
public static Matrix Translation(Vector3);


Matrix.Translation(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Translation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix using specified offsets.

Definition

Visual Basic .NET Public Shared Function Translation( _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Translation(
Vector3 v
);
Managed C++ public: static Matrix Translation(
Vector3 v
);
JScript .NET public static function Translation(
v : Vector3
) : Matrix;

Parameters

v Microsoft.DirectX.Vector3. A Vector3 structure that contains the x-coordinate, y-coordinate, and z-coordinate offsets.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that contains a translated transformation matrix.


Matrix.Translation(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Translation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a matrix using specified offsets.

Definition

Visual Basic .NET Public Shared Function Translation( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
) As Matrix
C# public static Matrix Translation(
float x,
float y,
float z
);
Managed C++ public: static Matrix Translation(
float x,
float y,
float z
);
JScript .NET public static function Translation(
x : float,
y : float,
z : float
) : Matrix;

Parameters

x | System.Single. X-coordinate offset.
y | System.Single. Y-coordinate offset.
z | System.Single. Z-coordinate offset.

Return Value

Microsoft.DirectX.Matrix . A Matrix structure that contains a translated transformation matrix.


Matrix.Transpose(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Transpose Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transposes the matrix using a source matrix.

Definition

Visual Basic .NET Public Sub Transpose( _
ByVal source As Matrix _
)
C# public void Transpose(
Matrix source
);
Managed C++ public: void Transpose(
Matrix source
);
JScript .NET public function Transpose(
source : Matrix
);

Parameters

source Microsoft.DirectX.Matrix. Source Matrix structure.


Matrix.TransposeMatrix(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.TransposeMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the matrix transpose of a given matrix.

Definition

Visual Basic .NET Public Shared Function TransposeMatrix( _
ByVal source As Matrix _
) As Matrix
C# public static Matrix TransposeMatrix(
Matrix source
);
Managed C++ public: static Matrix TransposeMatrix(
Matrix source
);
JScript .NET public static function TransposeMatrix(
source : Matrix
) : Matrix;

Parameters

source Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix . A Matrix object that is the matrix transpose of the matrix.


Matrix.Determinant

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Determinant Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the determinant of the matrix.

Definition

Visual Basic .NET | Public ReadOnly Property Determinant As Single
C# | public float Determinant { get; }
Managed C++ | public: __property float get_Determinant();
JScript .NET | public function get Determinant() : float

Property Value

System.Single . A Single Leave Site value that indicates the determinant of the matrix.

This property is read-only.


Matrix.Identity

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Identity Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the identity of the matrix.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Identity As Matrix
C# | public static Matrix Identity { get; }
Managed C++ | public: __property static Matrix get_Identity();
JScript .NET | public static function get Identity() : Matrix

Property Value

Microsoft.DirectX.Matrix . A Matrix structure that represents the matrix identity.

This property is read-only.

Remarks

In an identity matrix, all coefficients are 0 except the [1,1][2,2][3,3][4,4] coefficients, which are set to 1. The identity matrix is special in that when it is applied to vertices, they are unchanged. The identity matrix is used as the starting point for matrices that modify vertex values to create rotations, translations, and any other transformations that can be represented by a 4x4 matrix.


Matrix.Zero

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.Zero Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an empty matrix.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Zero As Matrix
C# | public static Matrix Zero { get; }
Managed C++ | public: __property static Matrix get_Zero();
JScript .NET | public static function get Zero() : Matrix

Property Value

Microsoft.DirectX.Matrix . Empty Matrix structure.

This property is read-only.


Matrix.M11

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M11 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the first row and the first column of the matrix.

Definition

Visual Basic .NET | Public M11 As Single
C# | public Single M11;
Managed C++ | public: Single M11;
JScript .NET | public var M11 : Single

Field Value

System.Single . A Single Leave Site value that represents the first row and the first column of the matrix.

This field is read/write.


Matrix.M12

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M12 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the first row and the second column of the matrix.

Definition

Visual Basic .NET | Public M12 As Single
C# | public Single M12;
Managed C++ | public: Single M12;
JScript .NET | public var M12 : Single

Field Value

System.Single . A Single Leave Site value that represents the first row and the second column of the matrix.

This field is read/write.


Matrix.M13

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M13 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the first row and the third column of the matrix.

Definition

Visual Basic .NET | Public M13 As Single
C# | public Single M13;
Managed C++ | public: Single M13;
JScript .NET | public var M13 : Single

Field Value

System.Single . A Single Leave Site value that represents the first row and the third column of the matrix.

This field is read/write.


Matrix.M14

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M14 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the first row and the fourth column of the matrix.

Definition

Visual Basic .NET | Public M14 As Single
C# | public Single M14;
Managed C++ | public: Single M14;
JScript .NET | public var M14 : Single

Field Value

System.Single . A Single Leave Site value that represents the first row and the fourth column of the matrix.

This field is read/write.


Matrix.M21

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M21 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the second row and the first column of the matrix.

Definition

Visual Basic .NET | Public M21 As Single
C# | public Single M21;
Managed C++ | public: Single M21;
JScript .NET | public var M21 : Single

Field Value

System.Single . A Single Leave Site value that represents the second row and the first column of the matrix.

This field is read/write.


Matrix.M22

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M22 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the second row and the second column of the matrix.

Definition

Visual Basic .NET | Public M22 As Single
C# | public Single M22;
Managed C++ | public: Single M22;
JScript .NET | public var M22 : Single

Field Value

System.Single . A Single Leave Site value that represents the second row and the second column of the matrix.

This field is read/write.


Matrix.M23

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M23 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the second row and the third column of the matrix.

Definition

Visual Basic .NET | Public M23 As Single
C# | public Single M23;
Managed C++ | public: Single M23;
JScript .NET | public var M23 : Single

Field Value

System.Single . A Single Leave Site value that represents the second row and the third column of the matrix.

This field is read/write.


Matrix.M24

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M24 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the second row and the fourth column of the matrix.

Definition

Visual Basic .NET | Public M24 As Single
C# | public Single M24;
Managed C++ | public: Single M24;
JScript .NET | public var M24 : Single

Field Value

System.Single . A Single Leave Site value that represents the second row and the fourth column of the matrix.

This field is read/write.


Matrix.M31

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M31 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the third row and the first column of the matrix.

Definition

Visual Basic .NET | Public M31 As Single
C# | public Single M31;
Managed C++ | public: Single M31;
JScript .NET | public var M31 : Single

Field Value

System.Single . A Single Leave Site value that represents the third row and the first column of the matrix.

This field is read/write.


Matrix.M32

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M32 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the third row and the second column of the matrix.

Definition

Visual Basic .NET | Public M32 As Single
C# | public Single M32;
Managed C++ | public: Single M32;
JScript .NET | public var M32 : Single

Field Value

System.Single . A Single Leave Site value that represents the third row and the second column of the matrix.

This field is read/write.


Matrix.M33

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M33 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the third row and the third column of the matrix.

Definition

Visual Basic .NET | Public M33 As Single
C# | public Single M33;
Managed C++ | public: Single M33;
JScript .NET | public var M33 : Single

Field Value

System.Single . A Single Leave Site value that represents the third row and the third column of the matrix.

This field is read/write.


Matrix.M34

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M34 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the third row and the fourth column of the matrix.

Definition

Visual Basic .NET | Public M34 As Single
C# | public Single M34;
Managed C++ | public: Single M34;
JScript .NET | public var M34 : Single

Field Value

System.Single . A Single Leave Site value that represents the third row and the fourth column of the matrix.

This field is read/write.

Remarks

In Microsoft® Direct3D®, the M34 element of a projection matrix cannot be a negative number. If an application needs to use a negative value in this location, it should scale the entire projection matrix by -1 instead.


Matrix.M41

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M41 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the fourth row and the first column of the matrix.

Definition

Visual Basic .NET | Public M41 As Single
C# | public Single M41;
Managed C++ | public: Single M41;
JScript .NET | public var M41 : Single

Field Value

System.Single . A Single Leave Site value that represents the fourth row and the first column of the matrix.

This field is read/write.


Matrix.M42

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M42 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the fourth row and the second column of the matrix.

Definition

Visual Basic .NET | Public M42 As Single
C# | public Single M42;
Managed C++ | public: Single M42;
JScript .NET | public var M42 : Single

Field Value

System.Single . A Single Leave Site value that represents the fourth row and the second column of the matrix.

This field is read/write.


Matrix.M43

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M43 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the fourth row and the third column of the matrix.

Definition

Visual Basic .NET | Public M43 As Single
C# | public Single M43;
Managed C++ | public: Single M43;
JScript .NET | public var M43 : Single

Field Value

System.Single . A Single Leave Site value that represents the fourth row and the third column of the matrix.

This field is read/write.


Matrix.M44

Microsoft DirectX 9.0 SDK Update (October 2004)

Matrix.M44 Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the element in the fourth row and the fourth column of the matrix.

Definition

Visual Basic .NET | Public M44 As Single
C# | public Single M44;
Managed C++ | public: Single M44;
JScript .NET | public var M44 : Single

Field Value

System.Single . A Single Leave Site value that represents the fourth row and the fourth column of the matrix.

This field is read/write.


Plane

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a plane.

Definition

Visual Basic .NET | Public Structure Plane
C# | public struct Plane
Managed C++ | public __value struct Plane
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
A | Retrieves or sets the 'A' coefficient of the clipping plane in the general plane equation.
B | Retrieves or sets the 'B' coefficient of the clipping plane in the general plane equation.
C | Retrieves or sets the 'C' coefficient of the clipping plane in the general plane equation.
D | Retrieves or sets the 'D' coefficient of the clipping plane in the general plane equation.

Methods

Method | Description
Dot | Computes the dot product of a plane and a vector.
static (Shared in Visual Basic .NET) DotNormal | Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
static (Shared in Visual Basic .NET) FromPointNormal | Constructs a plane from a point and a normal.
static (Shared in Visual Basic .NET) FromPoints | Constructs a plane from three points.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) IntersectLine | Finds the intersection between a plane and a line.
Normalize | Returns the normal of a plane.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Plane | Initializes a new instance of the Plane class.
Scale | Scales the plane with a given scaling factor.
ToString | Obtains a string representation of the current instance.
Transform | Transforms a plane by a matrix.

Properties

Property | Description
static (Shared in Visual Basic .NET) Empty | Retrieves an empty plane.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that ax + by + cz + dw = 0.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Plane Class


Plane.Dot

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of a plane and a vector.

Overload List

public float Dot(Vector3);
public float Dot(Vector4);

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal


Plane.Dot(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of a plane and a vector.

Definition

Visual Basic .NET Public Function Dot( _
ByVal v As Vector3 _
) As Single
C# public float Dot(
Vector3 v
);
Managed C++ public: float Dot(
Vector3 v
);
JScript .NET public function Dot(
v : Vector3
) : float;

Parameters

v Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal


Plane.Dot(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of a plane and a vector.

Definition

Visual Basic .NET Public Function Dot( _
ByVal v As Vector4 _
) As Single
C# public float Dot(
Vector4 v
);
Managed C++ public: float Dot(
Vector4 v
);
JScript .NET public function Dot(
v : Vector4
) : float;

Parameters

v Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

System.Single . A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal


Plane.DotNormal(Plane,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.DotNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.

Definition

Visual Basic .NET Public Shared Function DotNormal( _
ByVal p As Plane, _
ByVal v As Vector3 _
) As Single
C# public static float DotNormal(
Plane p,
Vector3 v
);
Managed C++ public: static float DotNormal(
Plane p,
Vector3 v
);
JScript .NET public static function DotNormal(
p : Plane,
v : Vector3
) : float;

Parameters

p | Microsoft.DirectX.Plane. Source Plane structure.
v | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that represents the dot product of the plane and the 3-D vector.

Remarks

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*0. The DotNormal method is useful for calculating the angle between the normal of the plane and another normal.


Plane.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the current instance is equal to the specified object, or false if it is not.


Plane.FromPointNormal(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.FromPointNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs a plane from a point and a normal.

Definition

Visual Basic .NET Public Shared Function FromPointNormal( _
ByVal point As Vector3, _
ByVal normal As Vector3 _
) As Plane
C# public static Plane FromPointNormal(
Vector3 point,
Vector3 normal
);
Managed C++ public: static Plane FromPointNormal(
Vector3 point,
Vector3 normal
);
JScript .NET public static function FromPointNormal(
point : Vector3,
normal : Vector3
) : Plane;

Parameters

point | Microsoft.DirectX.Vector3. A Vector3 structure that defines the point used to construct the plane.
normal | Microsoft.DirectX.Vector3. A Vector3 structure that defines the normal used to construct the plane.

Return Value

Microsoft.DirectX.Plane . A Plane structure constructed from the point and the normal.

See Also

  • Plane


Plane.FromPoints(Vector3,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.FromPoints Method

 Language:
Note: This documentation is preliminary and is subject to change.

Constructs a plane from three points.

Definition

Visual Basic .NET Public Shared Function FromPoints( _
ByVal p1 As Vector3, _
ByVal p2 As Vector3, _
ByVal p3 As Vector3 _
) As Plane
C# public static Plane FromPoints(
Vector3 p1,
Vector3 p2,
Vector3 p3
);
Managed C++ public: static Plane FromPoints(
Vector3 p1,
Vector3 p2,
Vector3 p3
);
JScript .NET public static function FromPoints(
p1 : Vector3,
p2 : Vector3,
p3 : Vector3
) : Plane;

Parameters

p1 | Microsoft.DirectX.Vector3. A Vector3 structure that defines one of the points used to construct the plane.
p2 | Microsoft.DirectX.Vector3. A Vector3 structure that defines one of the points used to construct the plane.
p3 | Microsoft.DirectX.Vector3. A Vector3 structure that defines one of the points used to construct the plane.

Return Value

Microsoft.DirectX.Plane . A Plane structure constructed from the given points.

See Also

  • FromPointNormal


Plane.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Plane.IntersectLine(Plane,Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.IntersectLine Method

 Language:
Note: This documentation is preliminary and is subject to change.

Finds the intersection between a plane and a line.

Definition

Visual Basic .NET Public Shared Function IntersectLine( _
ByVal p As Plane, _
ByVal v1 As Vector3, _
ByVal v2 As Vector3 _
) As Vector3
C# public static Vector3 IntersectLine(
Plane p,
Vector3 v1,
Vector3 v2
);
Managed C++ public: static Vector3 IntersectLine(
Plane p,
Vector3 v1,
Vector3 v2
);
JScript .NET public static function IntersectLine(
p : Plane,
v1 : Vector3,
v2 : Vector3
) : Vector3;

Parameters

p | Microsoft.DirectX.Plane. Source Plane structure.
v1 | Microsoft.DirectX.Vector3. Source Vector3 structure that defines a line starting point.
v2 | Microsoft.DirectX.Vector3. Source Vector3 structure that defines a line ending point.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the intersection between the specified plane and line.

Remarks

If the line is parallel to the plane, a Vector3 structure set to (0, 0, 0) is returned.


Plane.Normalize

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a plane.

Overload List

public void Normalize();
public static Plane Normalize(Plane);

Remarks

This method normalizes a plane so that |a, b, c| == 1.


Plane.Normalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a plane.

Definition

Visual Basic .NET | Public Sub Normalize()
C# | public void Normalize();
Managed C++ | public: void Normalize();
JScript .NET | public function Normalize();

Remarks

This method normalizes a plane so that |a, b, c| == 1.


Plane.Normalize(Plane)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a plane.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal p As Plane _
) As Plane
C# public static Plane Normalize(
Plane p
);
Managed C++ public: static Plane Normalize(
Plane p
);
JScript .NET public static function Normalize(
p : Plane
) : Plane;

Parameters

p Microsoft.DirectX.Plane. Source Plane structure.

Return Value

Microsoft.DirectX.Plane . A Plane structure that represents the normal of the plane.

Remarks

This method normalizes a plane so that |a, b, c| == 1.


Plane.op_Equality(Plane,Plane)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Plane, _
ByVal right As Plane _
) As Boolean
C# public static bool op_Equality(
Plane left,
Plane right
);
Managed C++ public: static bool op_Equality(
Plane left,
Plane right
);
JScript .NET public static function op_Equality(
left : Plane,
right : Plane
) : boolean;

Parameters

left | Microsoft.DirectX.Plane. The Plane structure to the left of the equality operator.
right | Microsoft.DirectX.Plane. The Plane structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Plane.op_Inequality(Plane,Plane)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Plane, _
ByVal right As Plane _
) As Boolean
C# public static bool op_Inequality(
Plane left,
Plane right
);
Managed C++ public: static bool op_Inequality(
Plane left,
Plane right
);
JScript .NET public static function op_Inequality(
left : Plane,
right : Plane
) : boolean;

Parameters

left | Microsoft.DirectX.Plane. The Plane structure to the left of the inequality operator.
right | Microsoft.DirectX.Plane. The Plane structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Plane.Plane

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Plane Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Plane class.

Overload List

public Plane();
public Plane(float, float, float, float);


Plane.Plane()

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Plane Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Plane class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Plane();
Managed C++ | public: Plane();
JScript .NET | public function Plane();


Plane.Plane(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Plane Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Plane class.

Definition

Visual Basic .NET Public Sub New( _
ByVal valuePointA As Single, _
ByVal valuePointB As Single, _
ByVal valuePointC As Single, _
ByVal valuePointD As Single _
)
C# public Plane(
float valuePointA,
float valuePointB,
float valuePointC,
float valuePointD
);
Managed C++ public: Plane(
float valuePointA,
float valuePointB,
float valuePointC,
float valuePointD
);
JScript .NET public function Plane(
valuePointA : float,
valuePointB : float,
valuePointC : float,
valuePointD : float
);

Parameters

valuePointA | System.Single. A Single Leave Site value used to set the initial value of the A field.
valuePointB | System.Single. A Single Leave Site value used to set the initial value of the B field.
valuePointC | System.Single. A Single Leave Site value used to set the initial value of the C field.
valuePointD | System.Single. A Single Leave Site value used to set the initial value of the D field.


Plane.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales the plane with a given scaling factor.

Overload List

public static Plane Scale(Plane, float);
public void Scale(float);


Plane.Scale(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales the plane with a given scaling factor.

Definition

Visual Basic .NET Public Sub Scale( _
ByVal s As Single _
)
C# public void Scale(
float s
);
Managed C++ public: void Scale(
float s
);
JScript .NET public function Scale(
s : float
);

Parameters

s System.Single. Scale factor.


Plane.Scale(Plane,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales the plane with a given scaling factor.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal p As Plane, _
ByVal s As Single _
) As Plane
C# public static Plane Scale(
Plane p,
float s
);
Managed C++ public: static Plane Scale(
Plane p,
float s
);
JScript .NET public static function Scale(
p : Plane,
s : float
) : Plane;

Parameters

p | Microsoft.DirectX.Plane. Pointer to the source Plane structure.
s | System.Single. Scale factor.

Return Value

Microsoft.DirectX.Plane . The Plane structure that represents the scaled plane.


Plane.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Plane.Transform

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a plane by a matrix.

Overload List

public void Transform(Matrix);
public static Plane Transform(Plane, Matrix);

Remarks

The input matrix is the inverse transpose of the actual transformation.

Examples

This C# code example transforms a plane by applying a non-uniform scale.
[C#]
Plane   planeNew;
Plane plane = new Plane(0, 1, 1, 0);
plane = Plane.Normalize(plane);

Matrix  matrix;
matrix = Matrix.Scaling(1.0f, 2.0f, 3.0f);
matrix = Matrix.Invert(matrix);
matrix.Transpose(matrix);
planeNew = Plane.Transform(plane, matrix);
 A plane is described by ax + by + cz + dw = 0. The first plane is created with (a, b, c, d) = (0, 1, 1, 0), which is a plane described by y + z = 0. After scaling, the new plane contains (a, b, c, d) = (0, 0.353f, 0.235f, 0), which shows the new plane to be described by 0.353y + 0.235z = 0.

The parameter m contains the inverse transpose of the transformation matrix. The inverse transpose is required by this method so that the normal vector of the transformed plane can be correctly transformed as well.

See Also

  • Normalize


Plane.Transform(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a plane by a matrix.

Definition

Visual Basic .NET Public Sub Transform( _
ByVal m As Matrix _
)
C# public void Transform(
Matrix m
);
Managed C++ public: void Transform(
Matrix m
);
JScript .NET public function Transform(
m : Matrix
);

Parameters

m Microsoft.DirectX.Matrix. Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.

Remarks

The input matrix is the inverse transpose of the actual transformation.

Examples

This C# code example transforms a plane by applying a non-uniform scale.
[C#]
Plane   planeNew;
Plane plane = new Plane(0, 1, 1, 0);
plane = Plane.Normalize(plane);

Matrix  matrix;
matrix = Matrix.Scaling(1.0f, 2.0f, 3.0f);
matrix = Matrix.Invert(matrix);
matrix.Transpose(matrix);
planeNew = Plane.Transform(plane, matrix);
 A plane is described by ax + by + cz + dw = 0. The first plane is created with (a, b, c, d) = (0, 1, 1, 0), which is a plane described by y + z = 0. After scaling, the new plane contains (a, b, c, d) = (0, 0.353f, 0.235f, 0), which shows the new plane to be described by 0.353y + 0.235z = 0.

The parameter m contains the inverse transpose of the transformation matrix. The inverse transpose is required by this method so that the normal vector of the transformed plane can be correctly transformed as well.

See Also

  • Normalize


Plane.Transform(Plane,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a plane by a matrix.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal p As Plane, _
ByVal m As Matrix _
) As Plane
C# public static Plane Transform(
Plane p,
Matrix m
);
Managed C++ public: static Plane Transform(
Plane p,
Matrix m
);
JScript .NET public static function Transform(
p : Plane,
m : Matrix
) : Plane;

Parameters

p | Microsoft.DirectX.Plane. Input Plane structure, which contains the plane to be transformed. The vector (a,b,c) that describes the plane must be normalized before this method is called.
m | Microsoft.DirectX.Matrix. Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.

Return Value

Microsoft.DirectX.Plane . A Plane structure that represents the transformed plane.

Remarks

The input matrix is the inverse transpose of the actual transformation.

Examples

This C# code example transforms a plane by applying a non-uniform scale.
[C#]
Plane   planeNew;
Plane plane = new Plane(0, 1, 1, 0);
plane = Plane.Normalize(plane);

Matrix  matrix;
matrix = Matrix.Scaling(1.0f, 2.0f, 3.0f);
matrix = Matrix.Invert(matrix);
matrix.Transpose(matrix);
planeNew = Plane.Transform(plane, matrix);
 A plane is described by ax + by + cz + dw = 0. The first plane is created with (a, b, c, d) = (0, 1, 1, 0), which is a plane described by y + z = 0. After scaling, the new plane contains (a, b, c, d) = (0, 0.353f, 0.235f, 0), which shows the new plane to be described by 0.353y + 0.235z = 0.

The parameter m contains the inverse transpose of the transformation matrix. The inverse transpose is required by this method so that the normal vector of the transformed plane can be correctly transformed as well.

See Also

  • Normalize


Plane.Empty

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.Empty Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an empty plane.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Empty As Plane
C# | public static Plane Empty { get; }
Managed C++ | public: __property static Plane get_Empty();
JScript .NET | public static function get Empty() : Plane

Property Value

Microsoft.DirectX.Plane . Empty Plane structure.

This property is read-only.


Plane.A

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.A Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the 'A' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic .NET | Public A As Single
C# | public Single A;
Managed C++ | public: Single A;
JScript .NET | public var A : Single

Field Value

System.Single . A Single Leave Site value that represents the 'A' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Plane.B

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.B Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the 'B' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic .NET | Public B As Single
C# | public Single B;
Managed C++ | public: Single B;
JScript .NET | public var B : Single

Field Value

System.Single . A Single Leave Site value that represents the 'B' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Plane.C

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.C Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the 'C' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic .NET | Public C As Single
C# | public Single C;
Managed C++ | public: Single C;
JScript .NET | public var C : Single

Field Value

System.Single . A Single Leave Site value that represents the 'C' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Plane.D

Microsoft DirectX 9.0 SDK Update (October 2004)

Plane.D Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the 'D' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic .NET | Public D As Single
C# | public Single D;
Managed C++ | public: Single D;
JScript .NET | public var D : Single

Field Value

System.Single . A Single Leave Site value that represents the 'D' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Quaternion

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a quaternion.

Definition

Visual Basic .NET | Public Structure Quaternion
C# | public struct Quaternion
Managed C++ | public __value struct Quaternion
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
W | Retrieves or sets the w component of the quaternion.
X | Retrieves or sets the x component of the quaternion.
Y | Retrieves or sets the y component of the quaternion.
Z | Retrieves or sets the z component of the quaternion.

Methods

Method | Description
static (Shared in Visual Basic .NET) Add | Adds two quaternions.
static (Shared in Visual Basic .NET) BaryCentric | Returns a quaternion in barycentric coordinates.
static (Shared in Visual Basic .NET) Conjugate | Returns the conjugate of a quaternion.
static (Shared in Visual Basic .NET) Dot | Returns the dot product of two quaternions.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Exp | Calculates the exponential.
GetHashCode | Returns the hash code for the current instance.
Invert | Conjugates and re-normalizes a quaternion.
Length | Returns the length of a quaternion.
LengthSq | Returns the square of a quaternion's length.
Ln | Calculates the natural logarithm.
Multiply | Multiplies two quaternions.
Normalize | Returns the normal of a quaternion.
static (Shared in Visual Basic .NET) op_Addition | Adds two quaternions.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Multiply | Determines the product of two quaternions.
static (Shared in Visual Basic .NET) op_Subtraction | Subtracts two quaternions.
Quaternion | Initializes a new instance of the Quaternion class.
RotateAxis | Rotates a quaternion around an arbitrary axis.
RotateMatrix | Builds a quaternion from a rotation matrix.
RotateYawPitchRoll | Builds a quaternion with the given yaw, pitch, and roll.
static (Shared in Visual Basic .NET) RotationAxis | Builds a quaternion that is rotated around an arbitrary axis.
static (Shared in Visual Basic .NET) RotationMatrix | Builds a quaternion from a rotation matrix.
static (Shared in Visual Basic .NET) RotationYawPitchRoll | Builds a quaternion with the given yaw, pitch, and roll.
static (Shared in Visual Basic .NET) Slerp | Interpolates between two quaternions, using spherical linear interpolation.
static (Shared in Visual Basic .NET) Squad | Interpolates between quaternions, using spherical quadrangle interpolation.
static (Shared in Visual Basic .NET) SquadSetup | Sets up control points for spherical quadrangle interpolation.
static (Shared in Visual Basic .NET) Subtract | Subtracts two quaternion instances.
static (Shared in Visual Basic .NET) ToAxisAngle | Computes a quaternion's axis and angle of rotation.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
static (Shared in Visual Basic .NET) Identity | Retrieves the identity quaternion.
static (Shared in Visual Basic .NET) Zero | Retrieves an empty quaternion.

Remarks

Quaternions add a fourth element to the [ x, y, z] values that define a vector, resulting in arbitrary 4-D vectors. However, the following example illustrates how each element of a unit quaternion relates to an axis-angle rotation, where q represents a unit quaternion (x, y, z, w), axis is normalized, and theta is the desired counterclockwise (CCW) rotation around the axis.

q.x = sin(theta/2) * axis.x

q.y = sin(theta/2) * axis.y

q.z = sin(theta/2) * axis.z

q.w = cos(theta/2)

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Vectors, Vertices, and Quaternions
  • Microsoft.DirectX.UnsafeNativeMethods.Quaternion Class


Quaternion.Add(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two quaternions.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal m1 As Quaternion, _
ByVal m2 As Quaternion _
) As Quaternion
C# public static Quaternion Add(
Quaternion m1,
Quaternion m2
);
Managed C++ public: static Quaternion Add(
Quaternion m1,
Quaternion m2
);
JScript .NET public static function Add(
m1 : Quaternion,
m2 : Quaternion
) : Quaternion;

Parameters

m1 | Microsoft.DirectX.Quaternion. Source Quaternion.
m2 | Microsoft.DirectX.Quaternion. Source Quaternion.

Return Value

Microsoft.DirectX.Quaternion . Sum of the two source Quaternion structures.


Quaternion.BaryCentric(Quaternion,Quaternion,Quaternion,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a quaternion in barycentric coordinates.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal q1 As Quaternion, _
ByVal q2 As Quaternion, _
ByVal q3 As Quaternion, _
ByVal f As Single, _
ByVal g As Single _
) As Quaternion
C# public static Quaternion BaryCentric(
Quaternion q1,
Quaternion q2,
Quaternion q3,
float f,
float g
);
Managed C++ public: static Quaternion BaryCentric(
Quaternion q1,
Quaternion q2,
Quaternion q3,
float f,
float g
);
JScript .NET public static function BaryCentric(
q1 : Quaternion,
q2 : Quaternion,
q3 : Quaternion,
f : float,
g : float
) : Quaternion;

Parameters

q1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
q2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
q3 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Quaternion . Resulting Quaternion structure in barycentric coordinates.

Remarks

To compute the barycentric coordinates, the BaryCentric method implements the following series of spherical linear interpolation operations.

Slerp(Slerp(q1, q2, f + g))

Slerp(q1, q3, f + g)

g/(f + g)

See Also

  • Quaternion.Slerp


Quaternion.Conjugate(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Conjugate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the conjugate of a quaternion.

Definition

Visual Basic .NET Public Shared Function Conjugate( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Conjugate(
Quaternion q
);
Managed C++ public: static Quaternion Conjugate(
Quaternion q
);
JScript .NET public static function Conjugate(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion. Source Quaternion.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the conjugate of the q parameter.

Remarks

Given a quaternion (x, y, z, w), the Conjugate method returns the quaternion (-x, -y, -z, w).

See Also

  • Invert


Quaternion.Dot(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the dot product of two quaternions.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal v1 As Quaternion, _
ByVal v2 As Quaternion _
) As Single
C# public static float Dot(
Quaternion v1,
Quaternion v2
);
Managed C++ public: static float Dot(
Quaternion v1,
Quaternion v2
);
JScript .NET public static function Dot(
v1 : Quaternion,
v2 : Quaternion
) : float;

Parameters

v1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
v2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

System.Single . Dot product of two quaternions.


Quaternion.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the instance is equal to the specified object, or false if it is not.


Quaternion.Exp

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Exp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the exponential.

Overload List

public void Exp();
public static Quaternion Exp(Quaternion);

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The SquadSetup method also can be used to set up the control points of a quaternion.


Quaternion.Exp()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Exp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the exponential.

Definition

Visual Basic .NET | Public Sub Exp()
C# | public void Exp();
Managed C++ | public: void Exp();
JScript .NET | public function Exp();

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The SquadSetup method also can be used to set up the control points of a quaternion.


Quaternion.Exp(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Exp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the exponential.

Definition

Visual Basic .NET Public Shared Function Exp( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Exp(
Quaternion q
);
Managed C++ public: static Quaternion Exp(
Quaternion q
);
JScript .NET public static function Exp(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . The Quaternion structure that is the exponential of the q parameter.

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The SquadSetup method also can be used to set up the control points of a quaternion.


Quaternion.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Quaternion.Invert

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Conjugates and re-normalizes a quaternion.

Overload List

public void Invert();
public static Quaternion Invert(Quaternion);

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

See Also

  • Quaternion.Conjugate
  • Quaternion.Normalize


Quaternion.Invert()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Conjugates and re-normalizes a quaternion.

Definition

Visual Basic .NET | Public Sub Invert()
C# | public void Invert();
Managed C++ | public: void Invert();
JScript .NET | public function Invert();

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

See Also

  • Quaternion.Conjugate
  • Quaternion.Normalize


Quaternion.Invert(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Invert Method

 Language:
Note: This documentation is preliminary and is subject to change.

Conjugates and re-normalizes a quaternion.

Definition

Visual Basic .NET Public Shared Function Invert( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Invert(
Quaternion q
);
Managed C++ public: static Quaternion Invert(
Quaternion q
);
JScript .NET public static function Invert(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the inverse of the quaternion passed into the q parameter.

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

See Also

  • Quaternion.Conjugate
  • Quaternion.Normalize


Quaternion.Length

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a quaternion.

Overload List

public float Length();
public static float Length(Quaternion);

See Also

  • LengthSq


Quaternion.Length()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a quaternion.

Definition

Visual Basic .NET | Public Function Length() As Single
C# | public float Length();
Managed C++ | public: float Length();
JScript .NET | public function Length() : float;

Return Value

System.Single . A Single Leave Site value that represents the quaternion's length.

See Also

  • LengthSq


Quaternion.Length(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a quaternion.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal v As Quaternion _
) As Single
C# public static float Length(
Quaternion v
);
Managed C++ public: static float Length(
Quaternion v
);
JScript .NET public static function Length(
v : Quaternion
) : float;

Parameters

v Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

System.Single . A Single Leave Site value that represents the quaternion's length.

See Also

  • LengthSq


Quaternion.LengthSq

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of a quaternion's length.

Overload List

public float LengthSq();
public static float LengthSq(Quaternion);

See Also

  • Length


Quaternion.LengthSq()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of a quaternion's length.

Definition

Visual Basic .NET | Public Function LengthSq() As Single
C# | public float LengthSq();
Managed C++ | public: float LengthSq();
JScript .NET | public function LengthSq() : float;

Return Value

System.Single . A Single Leave Site value that represents the quaternion's squared length.

See Also

  • Length


Quaternion.LengthSq(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of a quaternion's length.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal v As Quaternion _
) As Single
C# public static float LengthSq(
Quaternion v
);
Managed C++ public: static float LengthSq(
Quaternion v
);
JScript .NET public static function LengthSq(
v : Quaternion
) : float;

Parameters

v Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

System.Single . A Single Leave Site value that represents the quaternion's squared length.

See Also

  • Length


Quaternion.Ln

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Ln Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the natural logarithm.

Overload List

public void Ln();
public static Quaternion Ln(Quaternion);

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

See Also

  • Exp
  • Squad


Quaternion.Ln()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Ln Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the natural logarithm.

Definition

Visual Basic .NET | Public Sub Ln()
C# | public void Ln();
Managed C++ | public: void Ln();
JScript .NET | public function Ln();

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

See Also

  • Exp
  • Squad


Quaternion.Ln(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Ln Method

 Language:
Note: This documentation is preliminary and is subject to change.

Calculates the natural logarithm.

Definition

Visual Basic .NET Public Shared Function Ln( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Ln(
Quaternion q
);
Managed C++ public: static Quaternion Ln(
Quaternion q
);
JScript .NET public static function Ln(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the natural logarithm of the quaternion passed into the q parameter.

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

See Also

  • Exp
  • Squad


Quaternion.Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies two quaternions.

Overload List

public void Multiply(Quaternion);
public static Quaternion Multiply(Quaternion, Quaternion);

Remarks

The result represents the rotation m1 followed by the rotation m2 (return value = m1 * m2). This is done so that Multiply maintains the same semantics as Matrix, because unit quaternions can be considered as another way of representing rotation matrices.

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

See Also

  • Microsoft.DirectX.Matrix.Multiply


Quaternion.Multiply(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies two quaternions.

Definition

Visual Basic .NET Public Sub Multiply( _
ByVal q As Quaternion _
)
C# public void Multiply(
Quaternion q
);
Managed C++ public: void Multiply(
Quaternion q
);
JScript .NET public function Multiply(
q : Quaternion
);

Parameters

q Microsoft.DirectX.Quaternion. Source Quaternion structure.

Remarks

If the single parameter overload of this method is used, the current Quaternion instance is used as the m1 parameter and the quaternion that is passed in is treated as the m2 parameter.

The result represents the rotation m1 followed by the rotation m2 (return value = m1 * m2). This is done so that Multiply maintains the same semantics as Matrix, because unit quaternions can be considered as another way of representing rotation matrices.

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

See Also

  • Microsoft.DirectX.Matrix.Multiply


Quaternion.Multiply(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies two quaternions.

Definition

Visual Basic .NET Public Shared Function Multiply( _
ByVal m1 As Quaternion, _
ByVal m2 As Quaternion _
) As Quaternion
C# public static Quaternion Multiply(
Quaternion m1,
Quaternion m2
);
Managed C++ public: static Quaternion Multiply(
Quaternion m1,
Quaternion m2
);
JScript .NET public static function Multiply(
m1 : Quaternion,
m2 : Quaternion
) : Quaternion;

Parameters

m1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
m2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the product of two quaternions.

Remarks

The result represents the rotation m1 followed by the rotation m2 (return value = m1 * m2). This is done so that Multiply maintains the same semantics as Matrix, because unit quaternions can be considered as another way of representing rotation matrices.

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

See Also

  • Microsoft.DirectX.Matrix.Multiply


Quaternion.Normalize

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a quaternion.

Overload List

public void Normalize();
public static Quaternion Normalize(Quaternion);

See Also

  • Invert


Quaternion.Normalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a quaternion.

Definition

Visual Basic .NET | Public Sub Normalize()
C# | public void Normalize();
Managed C++ | public: void Normalize();
JScript .NET | public function Normalize();

See Also

  • Invert


Quaternion.Normalize(Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normal of a quaternion.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Normalize(
Quaternion q
);
Managed C++ public: static Quaternion Normalize(
Quaternion q
);
JScript .NET public static function Normalize(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the normal of the quaternion.

See Also

  • Invert


Quaternion.op_Addition(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.op_Addition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two quaternions.

Definition

Visual Basic .NET Public Shared Function op_Addition( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Quaternion
C# public static Quaternion op_Addition(
Quaternion left,
Quaternion right
);
Managed C++ public: static Quaternion op_Addition(
Quaternion left,
Quaternion right
);
JScript .NET public static function op_Addition(
left : Quaternion,
right : Quaternion
) : Quaternion;

Parameters

left | Microsoft.DirectX.Quaternion. The Quaternion structure to the left of the addition operator.
right | Microsoft.DirectX.Quaternion. The Quaternion structure to the right of the addition operator.

Return Value

Microsoft.DirectX.Quaternion . Resulting Quaternion structure.


Quaternion.op_Equality(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Boolean
C# public static bool op_Equality(
Quaternion left,
Quaternion right
);
Managed C++ public: static bool op_Equality(
Quaternion left,
Quaternion right
);
JScript .NET public static function op_Equality(
left : Quaternion,
right : Quaternion
) : boolean;

Parameters

left | Microsoft.DirectX.Quaternion. The Quaternion structure to the left of the equality operator.
right | Microsoft.DirectX.Quaternion. The Quaternion structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Quaternion.op_Inequality(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Boolean
C# public static bool op_Inequality(
Quaternion left,
Quaternion right
);
Managed C++ public: static bool op_Inequality(
Quaternion left,
Quaternion right
);
JScript .NET public static function op_Inequality(
left : Quaternion,
right : Quaternion
) : boolean;

Parameters

left | Microsoft.DirectX.Quaternion. The Quaternion structure to the left of the inequality operator.
right | Microsoft.DirectX.Quaternion. The Quaternion structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Quaternion.op_Multiply(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of two quaternions.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Quaternion
C# public static Quaternion op_Multiply(
Quaternion left,
Quaternion right
);
Managed C++ public: static Quaternion op_Multiply(
Quaternion left,
Quaternion right
);
JScript .NET public static function op_Multiply(
left : Quaternion,
right : Quaternion
) : Quaternion;

Parameters

left | Microsoft.DirectX.Quaternion. Source Quaternion structure.
right | Microsoft.DirectX.Quaternion. Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the product of two quaternions.

See Also

  • Multiply


Quaternion.op_Subtraction(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.op_Subtraction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two quaternions.

Definition

Visual Basic .NET Public Shared Function op_Subtraction( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Quaternion
C# public static Quaternion op_Subtraction(
Quaternion left,
Quaternion right
);
Managed C++ public: static Quaternion op_Subtraction(
Quaternion left,
Quaternion right
);
JScript .NET public static function op_Subtraction(
left : Quaternion,
right : Quaternion
) : Quaternion;

Parameters

left | Microsoft.DirectX.Quaternion. The Quaternion structure to the left of the subtraction operator.
right | Microsoft.DirectX.Quaternion. The Quaternion structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Quaternion . Resulting Quaternion structure.


Quaternion.Quaternion

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Quaternion Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Quaternion class.

Overload List

public Quaternion();
public Quaternion(float, float, float, float);


Quaternion.Quaternion()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Quaternion Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Quaternion class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Quaternion();
Managed C++ | public: Quaternion();
JScript .NET | public function Quaternion();


Quaternion.Quaternion(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Quaternion Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Quaternion class.

Definition

Visual Basic .NET Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single, _
ByVal valueZ As Single, _
ByVal valueW As Single _
)
C# public Quaternion(
float valueX,
float valueY,
float valueZ,
float valueW
);
Managed C++ public: Quaternion(
float valueX,
float valueY,
float valueZ,
float valueW
);
JScript .NET public function Quaternion(
valueX : float,
valueY : float,
valueZ : float,
valueW : float
);

Parameters

valueX | System.Single. Initial Single Leave Site value for the Quaternion.X member.
valueY | System.Single. Initial Single Leave Site value for the Quaternion.Y member.
valueZ | System.Single. Initial Single Leave Site value for the Quaternion.Z member.
valueW | System.Single. Initial Single Leave Site value for the Quaternion.W member.


Quaternion.RotateAxis(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.RotateAxis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Rotates a quaternion around an arbitrary axis.

Definition

Visual Basic .NET Public Sub RotateAxis( _
ByVal v As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxis(
Vector3 v,
float angle
);
Managed C++ public: void RotateAxis(
Vector3 v,
float angle
);
JScript .NET public function RotateAxis(
v : Vector3,
angle : float
);

Parameters

v | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the axis about which to rotate the quaternion.
angle | System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Quaternion.RotateMatrix
  • Quaternion.RotateYawPitchRoll


Quaternion.RotateMatrix(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.RotateMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a quaternion from a rotation matrix.

Definition

Visual Basic .NET Public Sub RotateMatrix( _
ByVal m As Matrix _
)
C# public void RotateMatrix(
Matrix m
);
Managed C++ public: void RotateMatrix(
Matrix m
);
JScript .NET public function RotateMatrix(
m : Matrix
);

Parameters

m Microsoft.DirectX.Matrix. Source Matrix structure that defines the rotation.

See Also

  • Quaternion.RotateAxis
  • Quaternion.RotateYawPitchRoll


Quaternion.RotateYawPitchRoll(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.RotateYawPitchRoll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a quaternion with the given yaw, pitch, and roll.

Definition

Visual Basic .NET Public Sub RotateYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
Managed C++ public: void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript .NET public function RotateYawPitchRoll(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw | System.Single. Yaw around the y-axis, in radians.
pitch | System.Single. Pitch around the x-axis, in radians.
roll | System.Single. Roll around the z-axis, in radians.

See Also

  • Quaternion.RotateAxis
  • Quaternion.RotateMatrix


Quaternion.RotationAxis(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.RotationAxis Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a quaternion that is rotated around an arbitrary axis.

Definition

Visual Basic .NET Public Shared Function RotationAxis( _
ByVal v As Vector3, _
ByVal angle As Single _
) As Quaternion
C# public static Quaternion RotationAxis(
Vector3 v,
float angle
);
Managed C++ public: static Quaternion RotationAxis(
Vector3 v,
float angle
);
JScript .NET public static function RotationAxis(
v : Vector3,
angle : float
) : Quaternion;

Parameters

v | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the axis about which to rotate the quaternion.
angle | System.Single. Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is rotated around the specified axis.

See Also

  • Quaternion.RotationYawPitchRollTopic
  • Quaternion.RotationMatrix


Quaternion.RotationMatrix(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.RotationMatrix Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a quaternion from a rotation matrix.

Definition

Visual Basic .NET Public Shared Function RotationMatrix( _
ByVal m As Matrix _
) As Quaternion
C# public static Quaternion RotationMatrix(
Matrix m
);
Managed C++ public: static Quaternion RotationMatrix(
Matrix m
);
JScript .NET public static function RotationMatrix(
m : Matrix
) : Quaternion;

Parameters

m Microsoft.DirectX.Matrix. Source Matrix structure that defines the rotation.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure built from a rotation matrix.

See Also

  • Quaternion.RotationAxis
  • Quaternion.RotationYawPitchRollTopic


Quaternion.RotationYawPitchRoll(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.RotationYawPitchRoll Method

 Language:
Note: This documentation is preliminary and is subject to change.

Builds a quaternion with the given yaw, pitch, and roll.

Definition

Visual Basic .NET Public Shared Function RotationYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
) As Quaternion
C# public static Quaternion RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
Managed C++ public: static Quaternion RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript .NET public static function RotationYawPitchRoll(
yaw : float,
pitch : float,
roll : float
) : Quaternion;

Parameters

yaw | System.Single. Yaw around the y-axis, in radians.
pitch | System.Single. Pitch around the x-axis, in radians.
roll | System.Single. Roll around the z-axis, in radians.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure with the specified yaw, pitch, and roll.

See Also

  • Quaternion.RotationMatrix
  • Quaternion.RotationAxis


Quaternion.Slerp(Quaternion,Quaternion,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Slerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Interpolates between two quaternions, using spherical linear interpolation.

Definition

Visual Basic .NET Public Shared Function Slerp( _
ByVal q1 As Quaternion, _
ByVal q2 As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Slerp(
Quaternion q1,
Quaternion q2,
float t
);
Managed C++ public: static Quaternion Slerp(
Quaternion q1,
Quaternion q2,
float t
);
JScript .NET public static function Slerp(
q1 : Quaternion,
q2 : Quaternion,
t : float
) : Quaternion;

Parameters

q1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
q2 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
t | System.Single. A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the result of the interpolation.


Quaternion.Squad(Quaternion,Quaternion,Quaternion,Quaternion,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Squad Method

 Language:
Note: This documentation is preliminary and is subject to change.

Interpolates between quaternions, using spherical quadrangle interpolation.

Definition

Visual Basic .NET Public Shared Function Squad( _
ByVal q1 As Quaternion, _
ByVal a As Quaternion, _
ByVal b As Quaternion, _
ByVal c As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Squad(
Quaternion q1,
Quaternion a,
Quaternion b,
Quaternion c,
float t
);
Managed C++ public: static Quaternion Squad(
Quaternion q1,
Quaternion a,
Quaternion b,
Quaternion c,
float t
);
JScript .NET public static function Squad(
q1 : Quaternion,
a : Quaternion,
b : Quaternion,
c : Quaternion,
t : float
) : Quaternion;

Parameters

q1 | Microsoft.DirectX.Quaternion. Source Quaternion structure.
a | Microsoft.DirectX.Quaternion. Source Quaternion structure.
b | Microsoft.DirectX.Quaternion. Source Quaternion structure.
c | Microsoft.DirectX.Quaternion. Source Quaternion structure.
t | System.Single. A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the result of the spherical quadrangle interpolation.

Remarks

This method uses the following sequence of spherical linear interpolation operations.

Slerp(Slerp(q1, c, t), Slerp(a, b, t), 2t(1 - t))


Quaternion.SquadSetup(Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.SquadSetup Method

 Language:
Note: This documentation is preliminary and is subject to change.

Sets up control points for spherical quadrangle interpolation.

Definition

Visual Basic .NET Public Shared Sub SquadSetup( _
ByRef outA As Quaternion, _
ByRef outB As Quaternion, _
ByRef outC As Quaternion, _
ByVal q0 As Quaternion, _
ByVal q1 As Quaternion, _
ByVal q2 As Quaternion, _
ByVal q3 As Quaternion _
)
C# public static void SquadSetup(
ref Quaternion outA,
ref Quaternion outB,
ref Quaternion outC,
Quaternion q0,
Quaternion q1,
Quaternion q2,
Quaternion q3
);
Managed C++ public: static void SquadSetup(
Quaternion *outA,
Quaternion *outB,
Quaternion *outC,
Quaternion q0,
Quaternion q1,
Quaternion q2,
Quaternion q3
);
JScript .NET public static function SquadSetup(
outA : Quaternion,
outB : Quaternion,
outC : Quaternion,
q0 : Quaternion,
q1 : Quaternion,
q2 : Quaternion,
q3 : Quaternion
);

Parameters

outA | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the outA value.
outB | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the outB value.
outC | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the outC value.
q0 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q0 input control point.
q1 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q1 input control point.
q2 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q2 input control point.
q3 | Microsoft.DirectX.Quaternion. A Quaternion instance that represents the q3 input control point.

Remarks

This method takes four control points, which are supplied to the inputs q0, q1, q2, and q3, and alters their values to find a curve that flows along the shortest path. The values of q0, q2, and q3 are calculated as shown below.

q0 = |q0 + q1| < |q0 - q1| ? -q0 : q0
q2 = |q1 + q2| < |q1 - q2| ? -q2 : q2
q3 = |q2 + q3| < |q2 - q3| ? -q3 : q3
Having calculated the new q values, the values for outA, outB, and outC are calculated as shown below.
outA = q1 * exp[-0.25 *( Ln[Exp(q1)*q2] + Ln[Exp(q1)*q0] ) ]

outB = q2 * exp[-0.25 *( Ln[Exp(q2)*q3] + Ln[Exp(q2)*q1] ) ]

outC = q2
Note: In the preceding example, Ln is the application programming interface (API) method Quaternion.Ln, and Exp is the API method Quaternion.Exp.

Examples

The following example shows how to use a set of quaternion keys (Q0, Q1, Q2, Q3) to compute the inner quadrangle points (A, B, C). This ensures that the tangents are continuous across adjacent segments.
        A     B
  Q0    Q1    Q2    Q3
 The following C# code example shows how you can interpolate between Q1 and Q2.
[C#]
// Rotation about the z-axis
Quaternion Q0 =  new Quaternion(0f,  0f, 0.707f, -.707f);
Quaternion Q1 = new Quaternion(0f,  0f, 0.000f, 1.000f);
Quaternion Q2 = new Quaternion(0f,  0f, 0.707f, 0.707f);
Quaternion Q3 = new Quaternion(0f,  0f, 1.000f, 0.000f);
Quaternion A = new Quaternion();
Quaternion B = new Quaternion();
Quaternion C = new Quaternion();
Quaternion Qt = new Quaternion();

Single time = 0.5f;

Quaternion.SquadSetup(ref A, ref B, ref C, Q0, Q1, Q2, Q3);
Qt = Quaternion.Squad(Q1, A, B, C, time);
 Note:
  • C is +/- Q2 depending on the result of the function
  • Qt is the result of the function
The result is a rotation of 45 degrees around the z-axis for time = 0.5.


Quaternion.Subtract(Quaternion,Quaternion)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two quaternion instances.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal m1 As Quaternion, _
ByVal m2 As Quaternion _
) As Quaternion
C# public static Quaternion Subtract(
Quaternion m1,
Quaternion m2
);
Managed C++ public: static Quaternion Subtract(
Quaternion m1,
Quaternion m2
);
JScript .NET public static function Subtract(
m1 : Quaternion,
m2 : Quaternion
) : Quaternion;

Parameters

m1 | Microsoft.DirectX.Quaternion. Source Quaternion structure to the left of the subtraction operator.
m2 | Microsoft.DirectX.Quaternion. Source Quaternion structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Quaternion . A Quaternion structure that is the result of the operation.


Quaternion.ToAxisAngle(Quaternion,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.ToAxisAngle Method

 Language:
Note: This documentation is preliminary and is subject to change.

Computes a quaternion's axis and angle of rotation.

Definition

Visual Basic .NET Public Shared Sub ToAxisAngle( _
ByVal q As Quaternion, _
ByRef axis As Vector3, _
ByRef angle As Single _
)
C# public static void ToAxisAngle(
Quaternion q,
ref Vector3 axis,
ref float angle
);
Managed C++ public: static void ToAxisAngle(
Quaternion q,
Vector3 *axis,
float *angle
);
JScript .NET public static function ToAxisAngle(
q : Quaternion,
axis : Vector3,
angle : float
);

Parameters

q | Microsoft.DirectX.Quaternion. Source Quaternion structure. See Remarks.
axis | Microsoft.DirectX.Vector3. A Vector3 structure that identifies the quaternion's axis of rotation.
angle | System.Single. A Single Leave Site value that identifies the quaternion's angle of rotation, in radians.

Remarks

This method requires unit quaternions.


Quaternion.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Quaternion.Identity

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Identity Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the identity quaternion.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Identity As Quaternion
C# | public static Quaternion Identity { get; }
Managed C++ | public: __property static Quaternion get_Identity();
JScript .NET | public static function get Identity() : Quaternion

Property Value

Microsoft.DirectX.Quaternion . A Quaternion structure that represents the identity quaternion.

This property is read-only.

Remarks

Given a quaternion (x, y, z, w), the Quaternion.Identity method returns the quaternion (0, 0, 0, 1).


Quaternion.Zero

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Zero Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an empty quaternion.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Zero As Quaternion
C# | public static Quaternion Zero { get; }
Managed C++ | public: __property static Quaternion get_Zero();
JScript .NET | public static function get Zero() : Quaternion

Property Value

Microsoft.DirectX.Quaternion . Empty Quaternion structure.

This property is read-only.


Quaternion.W

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.W Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the w component of the quaternion.

Definition

Visual Basic .NET | Public W As Single
C# | public Single W;
Managed C++ | public: Single W;
JScript .NET | public var W : Single

Field Value

System.Single . A Single Leave Site value that indicates the w component of the quaternion.

This field is read/write.


Quaternion.X

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of the quaternion.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . A Single Leave Site value that indicates the x component of the quaternion.

This field is read/write.


Quaternion.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of the quaternion.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . A Single Leave Site value that indicates the y component of the quaternion.

This field is read/write.


Quaternion.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

Quaternion.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of the quaternion.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . A Single Leave Site value that indicates the z component of the quaternion.

This field is read/write.


Single16

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a 16-bit floating-point value.

Definition

Visual Basic .NET | Public Structure Single16
C# | public struct Single16
Managed C++ | public __value struct Single16
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic .NET) AdditionRounding | Retrieves a value that indicates the largest value that is rounded.
static (Shared in Visual Basic .NET) DigitsOfPrecision | Retrieves a value that indicates the number of decimal digits of precision for the Single16.
static (Shared in Visual Basic .NET) Epsilon | Retrieves the smallest value that a Single Leave Site can hold.
static (Shared in Visual Basic .NET) ExponentRadix | Retrieves the exponent radix value.
static (Shared in Visual Basic .NET) MantissaBits | Retrieves the number of bits in a mantissa.
static (Shared in Visual Basic .NET) MaxBinaryExponent | Retrieves the maximum binary exponent.
static (Shared in Visual Basic .NET) MaxDecimalExponent | Retrieves the maximum decimal exponent.
static (Shared in Visual Basic .NET) MaxValue | Retrieves the maximum value for this type.
static (Shared in Visual Basic .NET) MinBinaryExponent | Retrieves the minimum binary exponent.
static (Shared in Visual Basic .NET) MinDecimalExponent | Retrieves the minimum decimal exponent.
static (Shared in Visual Basic .NET) MinValue | Retrieves the minimum value for this type.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Single16 | Initializes a new instance of the Single16 class.
ToString | Obtains a string representation of the current instance.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35


Single16.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the current instance is equal to the specified object, or false if it is not.


Single16.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Single16.op_Equality(Single16,Single16)

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Single16, _
ByVal right As Single16 _
) As Boolean
C# public static bool op_Equality(
Single16 left,
Single16 right
);
Managed C++ public: static bool op_Equality(
Single16 left,
Single16 right
);
JScript .NET public static function op_Equality(
left : Single16,
right : Single16
) : boolean;

Parameters

left | Microsoft.DirectX.Single16. The Quaternion structure to the left of the equality operator.
right | Microsoft.DirectX.Single16. The Quaternion structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Single16.op_Inequality(Single16,Single16)

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Single16, _
ByVal right As Single16 _
) As Boolean
C# public static bool op_Inequality(
Single16 left,
Single16 right
);
Managed C++ public: static bool op_Inequality(
Single16 left,
Single16 right
);
JScript .NET public static function op_Inequality(
left : Single16,
right : Single16
) : boolean;

Parameters

left | Microsoft.DirectX.Single16. The Quaternion structure to the left of the inequality operator.
right | Microsoft.DirectX.Single16. The Quaternion structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Single16.Single16(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.Single16 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Single16 class.

Definition

Visual Basic .NET Public Sub New( _
ByVal value As Single _
)
C# public Single16(
float value
);
Managed C++ public: Single16(
float value
);
JScript .NET public function Single16(
value : float
);

Parameters

value System.Single. A Single Leave Site value that is used to set the initial value.


Single16.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Single16.AdditionRounding

Single16.AdditionRounding Field

Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the largest value that is rounded.

Definition

Visual Basic .NET | Public Shared AdditionRounding As Int32
C# | public static Int32 AdditionRounding;
Managed C++ | public: static Int32 AdditionRounding;
JScript .NET | public static var AdditionRounding : Int32

Field Value

System.Int32 .

This field is read-only.
© 2004 Microsoft Corporation. All rights reserved. Terms of use.

Feedback? Please provide us with your comments on this topic.


Single16.DigitsOfPrecision

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.DigitsOfPrecision Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves a value that indicates the number of decimal digits of precision for the Single16.

Definition

Visual Basic .NET | Public Shared DigitsOfPrecision As Int32
C# | public static Int32 DigitsOfPrecision;
Managed C++ | public: static Int32 DigitsOfPrecision;
JScript .NET | public static var DigitsOfPrecision : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the number of decimal digits of precision for the Single16.

This field is read-only.


Single16.Epsilon

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.Epsilon Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the smallest value that a Single Leave Site can hold.

Definition

Visual Basic .NET | Public Shared Epsilon As Single
C# | public static Single Epsilon;
Managed C++ | public: static Single Epsilon;
JScript .NET | public static var Epsilon : Single

Field Value

System.Single . A Single Leave Site value that indicates the smallest value that the Single Leave Site can hold.

This field is read-only.

Remarks

This field's value is the smallest value for which the following equation is true:

1.0 + epsilon != 1


Single16.ExponentRadix

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.ExponentRadix Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the exponent radix value.

Definition

Visual Basic .NET | Public Shared ExponentRadix As Int32
C# | public static Int32 ExponentRadix;
Managed C++ | public: static Int32 ExponentRadix;
JScript .NET | public static var ExponentRadix : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the exponent radix value for the Single Leave Site.

This field is read-only.


Single16.MantissaBits

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.MantissaBits Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the number of bits in a mantissa.

Definition

Visual Basic .NET | Public Shared MantissaBits As Int32
C# | public static Int32 MantissaBits;
Managed C++ | public: static Int32 MantissaBits;
JScript .NET | public static var MantissaBits : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the number of bits in the mantissa.

This field is read-only.


Single16.MaxBinaryExponent

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.MaxBinaryExponent Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum binary exponent.

Definition

Visual Basic .NET | Public Shared MaxBinaryExponent As Int32
C# | public static Int32 MaxBinaryExponent;
Managed C++ | public: static Int32 MaxBinaryExponent;
JScript .NET | public static var MaxBinaryExponent : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the maximum binary exponent.

This field is read-only.


Single16.MaxDecimalExponent

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.MaxDecimalExponent Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum decimal exponent.

Definition

Visual Basic .NET | Public Shared MaxDecimalExponent As Int32
C# | public static Int32 MaxDecimalExponent;
Managed C++ | public: static Int32 MaxDecimalExponent;
JScript .NET | public static var MaxDecimalExponent : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the maximum decimal exponent.

This field is read-only.


Single16.MaxValue

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.MaxValue Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the maximum value for this type.

Definition

Visual Basic .NET | Public Shared MaxValue As Single
C# | public static Single MaxValue;
Managed C++ | public: static Single MaxValue;
JScript .NET | public static var MaxValue : Single

Field Value

System.Single . An Int32 Leave Site value that indicates the maximum value.

This field is read-only.


Single16.MinBinaryExponent

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.MinBinaryExponent Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum binary exponent.

Definition

Visual Basic .NET | Public Shared MinBinaryExponent As Int32
C# | public static Int32 MinBinaryExponent;
Managed C++ | public: static Int32 MinBinaryExponent;
JScript .NET | public static var MinBinaryExponent : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the minimum binary exponent.

This field is read-only.


Single16.MinDecimalExponent

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.MinDecimalExponent Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum decimal exponent.

Definition

Visual Basic .NET | Public Shared MinDecimalExponent As Int32
C# | public static Int32 MinDecimalExponent;
Managed C++ | public: static Int32 MinDecimalExponent;
JScript .NET | public static var MinDecimalExponent : Int32

Field Value

System.Int32 . An Int32 Leave Site value that indicates the minimum decimal exponent.

This field is read-only.


Single16.MinValue

Microsoft DirectX 9.0 SDK Update (October 2004)

Single16.MinValue Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves the minimum value for this type.

Definition

Visual Basic .NET | Public Shared MinValue As Single
C# | public static Single MinValue;
Managed C++ | public: static Single MinValue;
JScript .NET | public static var MinValue : Single

Field Value

System.Single . A Single Leave Site value that indicates the minimum value.

This field is read-only.


Vector2

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes and manipulates a vector in two-dimensional (2-D) space.

Definition

Visual Basic .NET | Public Structure Vector2
C# | public struct Vector2
Managed C++ | public __value struct Vector2
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
X | Retrieves or sets the x component of a 2-D vector.
Y | Retrieves or sets the y component of a 2-D vector.

Methods

Method | Description
Add | Adds two 2-D vectors.
static (Shared in Visual Basic .NET) BaryCentric | Returns a point in barycentric coordinates, using specified 2-D vectors.
static (Shared in Visual Basic .NET) CatmullRom | Performs a Catmull-Rom interpolation using specified 2-D vectors.
static (Shared in Visual Basic .NET) Ccw | Returns the z component by calculating the cross product of two 2-D vectors.
static (Shared in Visual Basic .NET) Dot | Determines the dot product of two 2-D vectors.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) Hermite | Performs a Hermite spline interpolation using specified 2-D vectors.
Length | Returns the length of a 2-D vector.
LengthSq | Returns the square of the length of a 2-D vector.
static (Shared in Visual Basic .NET) Lerp | Performs a linear interpolation between two 2-D vectors.
Maximize | Returns a 2-D vector that is made up of the largest components of two 2-D vectors.
Minimize | Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.
Multiply | Multiplies the current 2-D vector with a single value.
Normalize | Returns the normalized version of a 2-D vector.
static (Shared in Visual Basic .NET) op_Addition | Adds two 2-D vectors.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Multiply | Determines the product of a single value and a 2-D vector.
static (Shared in Visual Basic .NET) op_Subtraction | Subtracts two 2-D vectors.
static (Shared in Visual Basic .NET) op_UnaryNegation | Negates the vector.
Scale | Scales a 2-D vector.
Subtract | Subtracts two 2-D vectors.
ToString | Obtains a string representation of the current instance.
static (Shared in Visual Basic .NET) Transform | Transforms a 2-D vector or an array of 2-D vectors by a given matrix.
TransformCoordinate | Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.
TransformNormal | Transforms the 2-D vector normal by a given matrix.
Vector2 | Initializes a new instance of the Vector2 class.

Properties

Property | Description
static (Shared in Visual Basic .NET) Empty | Retrieves an empty 2-D vector.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Vector2 Class


Vector2.Add

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 2-D vectors.

Overload List

public void Add(Vector2);
public static Vector2 Add(Vector2, Vector2);


Vector2.Add(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 2-D vectors.

Definition

Visual Basic .NET Public Sub Add( _
ByVal v As Vector2 _
)
C# public void Add(
Vector2 v
);
Managed C++ public: void Add(
Vector2 v
);
JScript .NET public function Add(
v : Vector2
);

Parameters

v Microsoft.DirectX.Vector2. Source Vector2.


Vector2.Add(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Add(
Vector2 left,
Vector2 right
);
Managed C++ public: static Vector2 Add(
Vector2 left,
Vector2 right
);
JScript .NET public static function Add(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2.
right | Microsoft.DirectX.Vector2. Source Vector2.

Return Value

Microsoft.DirectX.Vector2 . Sum of the two source Vector2 structures.


Vector2.BaryCentric(Vector2,Vector2,Vector2,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a point in barycentric coordinates, using specified 2-D vectors.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal v1 As Vector2, _
ByVal v2 As Vector2, _
ByVal v3 As Vector2, _
ByVal f As Single, _
ByVal g As Single _
) As Vector2
C# public static Vector2 BaryCentric(
Vector2 v1,
Vector2 v2,
Vector2 v3,
float f,
float g
);
Managed C++ public: static Vector2 BaryCentric(
Vector2 v1,
Vector2 v2,
Vector2 v3,
float f,
float g
);
JScript .NET public static function BaryCentric(
v1 : Vector2,
v2 : Vector2,
v3 : Vector2,
f : float,
g : float
) : Vector2;

Parameters

v1 | Microsoft.DirectX.Vector2. Source Vector2 structure.
v2 | Microsoft.DirectX.Vector2. Source Vector2 structure.
v3 | Microsoft.DirectX.Vector2. Source Vector2 structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of its actual location. This method returns the resulting point by using the following equation.

v1 + f(v2 - v1) + g(v3 - v1)

Any point in the plane v1v2v3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which v2 gets weighted into the result, and the f parameter controls the extent to which v3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which v1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle v1v2v3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line v1v3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line v1v2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line v2v3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.


Vector2.CatmullRom(Vector2,Vector2,Vector2,Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.CatmullRom Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Catmull-Rom interpolation using specified 2-D vectors.

Definition

Visual Basic .NET Public Shared Function CatmullRom( _
ByVal position1 As Vector2, _
ByVal position2 As Vector2, _
ByVal position3 As Vector2, _
ByVal position4 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 CatmullRom(
Vector2 position1,
Vector2 position2,
Vector2 position3,
Vector2 position4,
float weightingFactor
);
Managed C++ public: static Vector2 CatmullRom(
Vector2 position1,
Vector2 position2,
Vector2 position3,
Vector2 position4,
float weightingFactor
);
JScript .NET public static function CatmullRom(
position1 : Vector2,
position2 : Vector2,
position3 : Vector2,
position4 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

position1 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
position2 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
position3 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
position4 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of position1, v2 is the contents of position2, p3 is the contents of position3, p4 is the contents of position4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields:
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This can be rearranged as:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

See Also

  • Vector3.CatmullRom
  • Vector4.CatmullRom


Vector2.Ccw(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Ccw Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the z component by calculating the cross product of two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Ccw( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Single
C# public static float Ccw(
Vector2 left,
Vector2 right
);
Managed C++ public: static float Ccw(
Vector2 left,
Vector2 right
);
JScript .NET public static function Ccw(
left : Vector2,
right : Vector2
) : float;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2 structure.
right | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . The z component.

Remarks

This method determines the z component by calculating the cross product based on the following formula.

((x1,y1,0) cross (x2,y2,0))

The following C# code fragment provides an example.

[C#]
left->x * right->y - left->y * right->x

If the z component's value is positive, the vector right is counterclockwise from the vector left. This information is useful for back-face culling.


Vector2.Dot(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the dot product of two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Single
C# public static float Dot(
Vector2 left,
Vector2 right
);
Managed C++ public: static float Dot(
Vector2 left,
Vector2 right
);
JScript .NET public static function Dot(
left : Vector2,
right : Vector2
) : float;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2 structure.
right | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . Dot product.

See Also

  • Ccw


Vector2.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the current instance is equal to the specified object, or false if it is not.


Vector2.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Vector2.Hermite(Vector2,Vector2,Vector2,Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Hermite Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Hermite spline interpolation using specified 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Hermite( _
ByVal position As Vector2, _
ByVal tangent As Vector2, _
ByVal position2 As Vector2, _
ByVal tangent2 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 Hermite(
Vector2 position,
Vector2 tangent,
Vector2 position2,
Vector2 tangent2,
float weightingFactor
);
Managed C++ public: static Vector2 Hermite(
Vector2 position,
Vector2 tangent,
Vector2 position2,
Vector2 tangent2,
float weightingFactor
);
JScript .NET public static function Hermite(
position : Vector2,
tangent : Vector2,
position2 : Vector2,
tangent2 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

position | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
tangent | Microsoft.DirectX.Vector2. Source Vector2 structure that is a tangent vector.
position2 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a position vector.
tangent2 | Microsoft.DirectX.Vector2. Source Vector2 structure that is a tangent vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (position, tangent) to (position2, tangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of ease-in, ease-out spline interpolation. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of position, v2 is the contents of position2, t1 is the contents of tangent, t2 is the contents of tangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, and D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

The preceding example yields the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.


Vector2.Length

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 2-D vector.

Overload List

public float Length();
public static float Length(Vector2);

See Also

  • LengthSq


Vector2.Length()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 2-D vector.

Definition

Visual Basic .NET | Public Function Length() As Single
C# | public float Length();
Managed C++ | public: float Length();
JScript .NET | public function Length() : float;

Return Value

System.Single . Vector length.

See Also

  • LengthSq


Vector2.Length(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 2-D vector.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal source As Vector2 _
) As Single
C# public static float Length(
Vector2 source
);
Managed C++ public: static float Length(
Vector2 source
);
JScript .NET public static function Length(
source : Vector2
) : float;

Parameters

source Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . Vector length.

See Also

  • LengthSq


Vector2.LengthSq

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 2-D vector.

Overload List

public float LengthSq();
public static float LengthSq(Vector2);

See Also

  • Length


Vector2.LengthSq()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 2-D vector.

Definition

Visual Basic .NET | Public Function LengthSq() As Single
C# | public float LengthSq();
Managed C++ | public: float LengthSq();
JScript .NET | public function LengthSq() : float;

Return Value

System.Single . Vector's squared length.

See Also

  • Length


Vector2.LengthSq(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 2-D vector.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal source As Vector2 _
) As Single
C# public static float LengthSq(
Vector2 source
);
Managed C++ public: static float LengthSq(
Vector2 source
);
JScript .NET public static function LengthSq(
source : Vector2
) : float;

Parameters

source Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

System.Single . Vector's squared length.

See Also

  • Length


Vector2.Lerp(Vector2,Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a linear interpolation between two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal left As Vector2, _
ByVal right As Vector2, _
ByVal interpolater As Single _
) As Vector2
C# public static Vector2 Lerp(
Vector2 left,
Vector2 right,
float interpolater
);
Managed C++ public: static Vector2 Lerp(
Vector2 left,
Vector2 right,
float interpolater
);
JScript .NET public static function Lerp(
left : Vector2,
right : Vector2,
interpolater : float
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2 structure.
right | Microsoft.DirectX.Vector2. Source Vector2 structure.
interpolater | System.Single. Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

left + interpolater(right - left).


Vector2.Maximize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Overload List

public void Maximize(Vector2);
public static Vector2 Maximize(Vector2, Vector2);

See Also

  • Vector2.Minimize


Vector2.Maximize(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Definition

Visual Basic .NET Public Sub Maximize( _
ByVal source As Vector2 _
)
C# public void Maximize(
Vector2 source
);
Managed C++ public: void Maximize(
Vector2 source
);
JScript .NET public function Maximize(
source : Vector2
);

Parameters

source Microsoft.DirectX.Vector2. Source Vector2 structure.

See Also

  • Vector2.Minimize


Vector2.Maximize(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Maximize( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Maximize(
Vector2 left,
Vector2 right
);
Managed C++ public: static Vector2 Maximize(
Vector2 left,
Vector2 right
);
JScript .NET public static function Maximize(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2 structure.
right | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is made up of the largest components of the two vectors.

See Also

  • Vector2.Minimize


Vector2.Minimize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Overload List

public void Minimize(Vector2);
public static Vector2 Minimize(Vector2, Vector2);

See Also

  • Vector2.Maximize


Vector2.Minimize(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Definition

Visual Basic .NET Public Sub Minimize( _
ByVal source As Vector2 _
)
C# public void Minimize(
Vector2 source
);
Managed C++ public: void Minimize(
Vector2 source
);
JScript .NET public function Minimize(
source : Vector2
);

Parameters

source Microsoft.DirectX.Vector2. Source Vector2 structure.

See Also

  • Vector2.Maximize


Vector2.Minimize(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Minimize( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Minimize(
Vector2 left,
Vector2 right
);
Managed C++ public: static Vector2 Minimize(
Vector2 left,
Vector2 right
);
JScript .NET public static function Minimize(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2 structure.
right | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is made up of the smallest components of the two vectors.

See Also

  • Vector2.Maximize


Vector2.Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies the current 2-D vector with a single value.

Overload List

public void Multiply(float);
public static Vector2 Multiply(Vector2, float);


Vector2.Multiply(Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies the current 2-D vector with a single value.

Definition

Visual Basic .NET Public Shared Function Multiply( _
ByVal source As Vector2, _
ByVal s As Single _
) As Vector2
C# public static Vector2 Multiply(
Vector2 source,
float s
);
Managed C++ public: static Vector2 Multiply(
Vector2 source,
float s
);
JScript .NET public static function Multiply(
source : Vector2,
s : float
) : Vector2;

Parameters

source | Microsoft.DirectX.Vector2. Source Vector2 structure.
s | System.Single. Source Single Leave Site value.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 that is the result of the source parameter multiplied by the s parameter.


Vector2.Multiply(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies the current 2-D vector with a single value.

Definition

Visual Basic .NET Public Sub Multiply( _
ByVal s As Single _
)
C# public void Multiply(
float s
);
Managed C++ public: void Multiply(
float s
);
JScript .NET public function Multiply(
s : float
);

Parameters

s System.Single. Source Single Leave Site value.


Vector2.Normalize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 2-D vector.

Overload List

public void Normalize();
public static Vector2 Normalize(Vector2);


Vector2.Normalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 2-D vector.

Definition

Visual Basic .NET | Public Sub Normalize()
C# | public void Normalize();
Managed C++ | public: void Normalize();
JScript .NET | public function Normalize();


Vector2.Normalize(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 2-D vector.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal source As Vector2 _
) As Vector2
C# public static Vector2 Normalize(
Vector2 source
);
Managed C++ public: static Vector2 Normalize(
Vector2 source
);
JScript .NET public static function Normalize(
source : Vector2
) : Vector2;

Parameters

source Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the normalized version of the vector.


Vector2.op_Addition(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_Addition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function op_Addition( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 op_Addition(
Vector2 left,
Vector2 right
);
Managed C++ public: static Vector2 op_Addition(
Vector2 left,
Vector2 right
);
JScript .NET public static function op_Addition(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. The Vector2 structure to the left of the addition operator.
right | Microsoft.DirectX.Vector2. The Vector2 structure to the right of the addition operator.

Return Value

Microsoft.DirectX.Vector2 . Resulting Vector2 structure.


Vector2.op_Equality(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Boolean
C# public static bool op_Equality(
Vector2 left,
Vector2 right
);
Managed C++ public: static bool op_Equality(
Vector2 left,
Vector2 right
);
JScript .NET public static function op_Equality(
left : Vector2,
right : Vector2
) : boolean;

Parameters

left | Microsoft.DirectX.Vector2. The Vector2 structure to the left of the equality operator.
right | Microsoft.DirectX.Vector2. The Vector2 structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Vector2.op_Inequality(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Boolean
C# public static bool op_Inequality(
Vector2 left,
Vector2 right
);
Managed C++ public: static bool op_Inequality(
Vector2 left,
Vector2 right
);
JScript .NET public static function op_Inequality(
left : Vector2,
right : Vector2
) : boolean;

Parameters

left | Microsoft.DirectX.Vector2. The Vector2 structure to the left of the inequality operator.
right | Microsoft.DirectX.Vector2. The Vector2 structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Vector2.op_Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a single value and a 2-D vector.

Overload List

public static Vector2 op_Multiply(float, Vector2);
public static Vector2 op_Multiply(Vector2, float);


Vector2.op_Multiply(Single,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a single value and a 2-D vector.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal right As Single, _
ByVal left As Vector2 _
) As Vector2
C# public static Vector2 op_Multiply(
float right,
Vector2 left
);
Managed C++ public: static Vector2 op_Multiply(
float right,
Vector2 left
);
JScript .NET public static function op_Multiply(
right : float,
left : Vector2
) : Vector2;

Parameters

right | System.Single. Source Single Leave Site structure.
left | Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the product of the right and left parameters.


Vector2.op_Multiply(Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a single value and a 2-D vector.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal left As Vector2, _
ByVal right As Single _
) As Vector2
C# public static Vector2 op_Multiply(
Vector2 left,
float right
);
Managed C++ public: static Vector2 op_Multiply(
Vector2 left,
float right
);
JScript .NET public static function op_Multiply(
left : Vector2,
right : float
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2 structure.
right | System.Single. Source Single Leave Site structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the product of the right and left parameters.


Vector2.op_Subtraction(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_Subtraction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function op_Subtraction( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 op_Subtraction(
Vector2 left,
Vector2 right
);
Managed C++ public: static Vector2 op_Subtraction(
Vector2 left,
Vector2 right
);
JScript .NET public static function op_Subtraction(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. The Vector2 structure to the left of the subtraction operator.
right | Microsoft.DirectX.Vector2. The Vector2 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector2 . Resulting Vector2 structure.


Vector2.op_UnaryNegation(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.op_UnaryNegation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Negates the vector.

Definition

Visual Basic .NET Public Shared Function op_UnaryNegation( _
ByVal vec As Vector2 _
) As Vector2
C# public static Vector2 op_UnaryNegation(
Vector2 vec
);
Managed C++ public: static Vector2 op_UnaryNegation(
Vector2 vec
);
JScript .NET public static function op_UnaryNegation(
vec : Vector2
) : Vector2;

Parameters

vec Microsoft.DirectX.Vector2. Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2 . The Vector2 structure that is the result of the negation operation.

Remarks

This method switches positive and negative values of the Vector2 structure's X and Y fields.


Vector2.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 2-D vector.

Overload List

public void Scale(float);
public static Vector2 Scale(Vector2, float);


Vector2.Scale(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 2-D vector.

Definition

Visual Basic .NET Public Sub Scale( _
ByVal scalingFactor As Single _
)
C# public void Scale(
float scalingFactor
);
Managed C++ public: void Scale(
float scalingFactor
);
JScript .NET public function Scale(
scalingFactor : float
);

Parameters

scalingFactor System.Single. Scaling value.


Vector2.Scale(Vector2,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 2-D vector.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal source As Vector2, _
ByVal scalingFactor As Single _
) As Vector2
C# public static Vector2 Scale(
Vector2 source,
float scalingFactor
);
Managed C++ public: static Vector2 Scale(
Vector2 source,
float scalingFactor
);
JScript .NET public static function Scale(
source : Vector2,
scalingFactor : float
) : Vector2;

Parameters

source | Microsoft.DirectX.Vector2. Source Vector2 structure.
scalingFactor | System.Single. Scaling value.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the scaled vector.


Vector2.Subtract

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 2-D vectors.

Overload List

public void Subtract(Vector2);
public static Vector2 Subtract(Vector2, Vector2);


Vector2.Subtract(Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 2-D vectors.

Definition

Visual Basic .NET Public Sub Subtract( _
ByVal source As Vector2 _
)
C# public void Subtract(
Vector2 source
);
Managed C++ public: void Subtract(
Vector2 source
);
JScript .NET public function Subtract(
source : Vector2
);

Parameters

source Microsoft.DirectX.Vector2. Source Vector2 a structure to subtract from the current Vector2 instance.


Vector2.Subtract(Vector2,Vector2)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 2-D vectors.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Subtract(
Vector2 left,
Vector2 right
);
Managed C++ public: static Vector2 Subtract(
Vector2 left,
Vector2 right
);
JScript .NET public static function Subtract(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left | Microsoft.DirectX.Vector2. Source Vector2 structure to the left of the subtraction operator.
right | Microsoft.DirectX.Vector2. Source Vector2 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that is the result of the operation.


Vector2.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Vector2.Transform

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Overload List

public static Vector4 Transform(Vector2, Matrix);
public static Vector4[] Transform(Vector2[], Matrix);


Vector2.Transform(Vector2[],Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal vector() As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector4()
C# public static Vector4[] Transform(
Vector2[] vector,
Matrix sourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector2 vector __gc[],
Matrix sourceMatrix
) __gc[];
JScript .NET public static function Transform(
vector : Vector2[],
sourceMatrix : Matrix
) : Vector4[];

Parameters

vector | Microsoft.DirectX.Vector2[]. Array of source Vector2 structures.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4[]. Array of Vector4 structures that are the result of the method.

Remarks

This method transforms an array of vectors passed into vector by the matrix sourceMatrix.


Vector2.Transform(Vector2,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal source As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector2 source,
Matrix sourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector2 source,
Matrix sourceMatrix
);
JScript .NET public static function Transform(
source : Vector2,
sourceMatrix : Matrix
) : Vector4;

Parameters

source | Microsoft.DirectX.Vector2. Source Vector2 structure.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

This method transforms the vector source (x, y, 0, 1) by the matrix sourceMatrix.


Vector2.TransformCoordinate

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Overload List

public void TransformCoordinate(Matrix);
public static Vector2 TransformCoordinate(Vector2, Matrix);
public static Vector2[] TransformCoordinate(Vector2[], Matrix);

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformCoordinate(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic .NET Public Sub TransformCoordinate( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformCoordinate(
Matrix sourceMatrix
);
Managed C++ public: void TransformCoordinate(
Matrix sourceMatrix
);
JScript .NET public function TransformCoordinate(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix. Source Matrix structure.

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformCoordinate(Vector2[],Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic .NET Public Shared Function TransformCoordinate( _
ByVal vector() As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2()
C# public static Vector2[] TransformCoordinate(
Vector2[] vector,
Matrix sourceMatrix
);
Managed C++ public: static Vector2 TransformCoordinate(
Vector2 vector __gc[],
Matrix sourceMatrix
) __gc[];
JScript .NET public static function TransformCoordinate(
vector : Vector2[],
sourceMatrix : Matrix
) : Vector2[];

Parameters

vector | Microsoft.DirectX.Vector2[]. Array of source Vector2 structures.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2[]. Array of Vector2 structures that represent the results of the method.

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformCoordinate(Vector2,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic .NET Public Shared Function TransformCoordinate( _
ByVal source As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformCoordinate(
Vector2 source,
Matrix sourceMatrix
);
Managed C++ public: static Vector2 TransformCoordinate(
Vector2 source,
Matrix sourceMatrix
);
JScript .NET public static function TransformCoordinate(
source : Vector2,
sourceMatrix : Matrix
) : Vector2;

Parameters

source | Microsoft.DirectX.Vector2. Source Vector2 structure.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that represents the results of the method.

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformNormal

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms the 2-D vector normal by a given matrix.

Overload List

public void TransformNormal(Matrix);
public static Vector2 TransformNormal(Vector2, Matrix);
public static Vector2[] TransformNormal(Vector2[], Matrix);

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.TransformNormal(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms the 2-D vector normal by a given matrix.

Definition

Visual Basic .NET Public Sub TransformNormal( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformNormal(
Matrix sourceMatrix
);
Managed C++ public: void TransformNormal(
Matrix sourceMatrix
);
JScript .NET public function TransformNormal(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix. Source Matrix structure.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.TransformNormal(Vector2[],Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms the 2-D vector normal by a given matrix.

Definition

Visual Basic .NET Public Shared Function TransformNormal( _
ByVal vector() As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2()
C# public static Vector2[] TransformNormal(
Vector2[] vector,
Matrix sourceMatrix
);
Managed C++ public: static Vector2 TransformNormal(
Vector2 vector __gc[],
Matrix sourceMatrix
) __gc[];
JScript .NET public static function TransformNormal(
vector : Vector2[],
sourceMatrix : Matrix
) : Vector2[];

Parameters

vector | Microsoft.DirectX.Vector2[]. Array of source Vector2 structures.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2[]. Array of Vector2 structures that contain the results of this method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.TransformNormal(Vector2,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms the 2-D vector normal by a given matrix.

Definition

Visual Basic .NET Public Shared Function TransformNormal( _
ByVal source As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformNormal(
Vector2 source,
Matrix sourceMatrix
);
Managed C++ public: static Vector2 TransformNormal(
Vector2 source,
Matrix sourceMatrix
);
JScript .NET public static function TransformNormal(
source : Vector2,
sourceMatrix : Matrix
) : Vector2;

Parameters

source | Microsoft.DirectX.Vector2. Source Vector2 structure.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2 . A Vector2 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.Vector2

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Vector2 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector2 class.

Overload List

public Vector2();
public Vector2(float, float);


Vector2.Vector2()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Vector2 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector2 class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Vector2();
Managed C++ | public: Vector2();
JScript .NET | public function Vector2();


Vector2.Vector2(Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Vector2 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector2 class.

Definition

Visual Basic .NET Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single _
)
C# public Vector2(
float valueX,
float valueY
);
Managed C++ public: Vector2(
float valueX,
float valueY
);
JScript .NET public function Vector2(
valueX : float,
valueY : float
);

Parameters

valueX | System.Single. Initial X value.
valueY | System.Single. Initial Y value.


Vector2.Empty

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Empty Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an empty 2-D vector.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Empty As Vector2
C# | public static Vector2 Empty { get; }
Managed C++ | public: __property static Vector2 get_Empty();
JScript .NET | public static function get Empty() : Vector2

Property Value

Microsoft.DirectX.Vector2 . Empty 2-D Vector2 instance.

This property is read-only.


Vector2.X

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of a 2-D vector.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . A Single Leave Site value that represents the x component of a 2-D vector.

This field is read/write.


Vector2.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector2.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of a 2-D vector.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . A Single Leave Site value that represents the y component of a 2-D vector.

This field is read/write.


Vector3

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3 Structure

 Language:
Note: This documentation is preliminary and is subject to change.
How Do I...?
  • Set Up a View Matrix

Describes and manipulates a vector in three-dimensional (3-D) space.

Definition

Visual Basic .NET | Public Structure Vector3
C# | public struct Vector3
Managed C++ | public __value struct Vector3
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
X | Retrieves or sets the x component of a 3-D vector.
Y | Retrieves or sets the y component of a 3-D vector.
Z | Retrieves or sets the z component of a 3-D vector.

Methods

Method | Description
Add | Adds two 3-D vectors.
static (Shared in Visual Basic .NET) BaryCentric | Returns a point in barycentric coordinates, using specified 3-D vectors.
static (Shared in Visual Basic .NET) CatmullRom | Performs a Catmull-Rom interpolation using specified 3-D vectors.
static (Shared in Visual Basic .NET) Cross | Determines the cross product of two 3-D vectors.
static (Shared in Visual Basic .NET) Dot | Determines the dot product of two 3-D vectors.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) Hermite | Performs a Hermite spline interpolation using the specified 3-D vectors.
Length | Returns the length of a 3-D vector.
LengthSq | Returns the square of the length of a 3-D vector.
static (Shared in Visual Basic .NET) Lerp | Performs a linear interpolation between two 3-D vectors.
Maximize | Returns a 3-D vector that is made up of the largest components of two 3-D vectors.
Minimize | Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.
Multiply | Multiplies a 3-D vector by a Single Leave Site value.
Normalize | Returns the normalized version of a 3-D vector.
static (Shared in Visual Basic .NET) op_Addition | Adds two vectors.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Multiply | Determines the product of a single value and a 3-D vector.
static (Shared in Visual Basic .NET) op_Subtraction | Subtracts two 3-D vectors.
static (Shared in Visual Basic .NET) op_UnaryNegation | Negates the vector.
Project | Projects a vector from object space into screen space.
Scale | Scales a 3-D vector.
Subtract | Subtracts two 3-D vectors.
ToString | Obtains a string representation of the current instance.
static (Shared in Visual Basic .NET) Transform | Transforms a 3-D vector or an array of 3-D vectors by a given matrix.
TransformCoordinate | Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.
TransformNormal | Transforms a 3-D vector normal by the given matrix.
Unproject | Projects a vector from screen space into object space.
Vector3 | Initializes a new instance of the Vector3 class.

Properties

Property | Description
static (Shared in Visual Basic .NET) Empty | Retrieves an empty 3-D vector.

How Do I...?

Set Up a View Matrix

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

              [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Vector3 Class


Vector3.Add

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 3-D vectors.

Overload List

public void Add(Vector3);
public static Vector3 Add(Vector3, Vector3);


Vector3.Add(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 3-D vectors.

Definition

Visual Basic .NET Public Sub Add( _
ByVal source As Vector3 _
)
C# public void Add(
Vector3 source
);
Managed C++ public: void Add(
Vector3 source
);
JScript .NET public function Add(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3.


Vector3.Add(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Add(
Vector3 left,
Vector3 right
);
Managed C++ public: static Vector3 Add(
Vector3 left,
Vector3 right
);
JScript .NET public static function Add(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3.
right | Microsoft.DirectX.Vector3. Source Vector3.

Return Value

Microsoft.DirectX.Vector3 . Sum of the two Vector3 structures.


Vector3.BaryCentric(Vector3,Vector3,Vector3,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a point in barycentric coordinates, using specified 3-D vectors.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal v1 As Vector3, _
ByVal v2 As Vector3, _
ByVal v3 As Vector3, _
ByVal f As Single, _
ByVal g As Single _
) As Vector3
C# public static Vector3 BaryCentric(
Vector3 v1,
Vector3 v2,
Vector3 v3,
float f,
float g
);
Managed C++ public: static Vector3 BaryCentric(
Vector3 v1,
Vector3 v2,
Vector3 v3,
float f,
float g
);
JScript .NET public static function BaryCentric(
v1 : Vector3,
v2 : Vector3,
v3 : Vector3,
f : float,
g : float
) : Vector3;

Parameters

v1 | Microsoft.DirectX.Vector3. Source Vector3 structure.
v2 | Microsoft.DirectX.Vector3. Source Vector3 structure.
v3 | Microsoft.DirectX.Vector3. Source Vector3 structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure in barycentric coordinates.

Remarks

The Vector3.BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

v1 + f(v2 - v1) + g(v3 - v1)

Any point in the plane v1v2v3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which v2 gets weighted into the result, and the f parameter controls the extent to which v3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which v1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle v1v2v3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line v1v3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line v1v2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line v2v3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.


Vector3.CatmullRom(Vector3,Vector3,Vector3,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.CatmullRom Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Catmull-Rom interpolation using specified 3-D vectors.

Definition

Visual Basic .NET Public Shared Function CatmullRom( _
ByVal position1 As Vector3, _
ByVal position2 As Vector3, _
ByVal position3 As Vector3, _
ByVal position4 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 CatmullRom(
Vector3 position1,
Vector3 position2,
Vector3 position3,
Vector3 position4,
float weightingFactor
);
Managed C++ public: static Vector3 CatmullRom(
Vector3 position1,
Vector3 position2,
Vector3 position3,
Vector3 position4,
float weightingFactor
);
JScript .NET public static function CatmullRom(
position1 : Vector3,
position2 : Vector3,
position3 : Vector3,
position4 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

position1 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
position2 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
position3 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
position4 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of position1, v2 is the contents of position2, p3 is the contents of position3, p4 is the contents of position4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation.

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
Substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom


Vector3.Cross(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Cross Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the cross product of two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Cross( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Cross(
Vector3 left,
Vector3 right
);
Managed C++ public: static Vector3 Cross(
Vector3 left,
Vector3 right
);
JScript .NET public static function Cross(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure.
right | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the cross product of two 3-D vectors.

Remarks

The following C# example demonstrates how the Cross method finds the cross-product.

[C#]
Vector3 returnValue;
    returnValue.x = left.y * right.z - left.z * right.y;
    returnValue.y = left.z * right.x - left.x * right.z;
    returnValue.z = left.x * right.y - left.y * right.x;

See Also

  • Dot


Vector3.Dot(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the dot product of two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Single
C# public static float Dot(
Vector3 left,
Vector3 right
);
Managed C++ public: static float Dot(
Vector3 left,
Vector3 right
);
JScript .NET public static function Dot(
left : Vector3,
right : Vector3
) : float;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure.
right | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that is the dot product.

See Also

  • Cross


Vector3.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the current instance is equal to the specified object, or false if it is not.


Vector3.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Vector3.Hermite(Vector3,Vector3,Vector3,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Hermite Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Hermite spline interpolation using the specified 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Hermite( _
ByVal position As Vector3, _
ByVal tangent As Vector3, _
ByVal position2 As Vector3, _
ByVal tangent2 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 Hermite(
Vector3 position,
Vector3 tangent,
Vector3 position2,
Vector3 tangent2,
float weightingFactor
);
Managed C++ public: static Vector3 Hermite(
Vector3 position,
Vector3 tangent,
Vector3 position2,
Vector3 tangent2,
float weightingFactor
);
JScript .NET public static function Hermite(
position : Vector3,
tangent : Vector3,
position2 : Vector3,
tangent2 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

position | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
tangent | Microsoft.DirectX.Vector3. Source Vector3 structure that is a tangent vector.
position2 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a position vector.
tangent2 | Microsoft.DirectX.Vector3. Source Vector3 structure that is a tangent vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (position, tangent) to (position2, tangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of position, v2 is the contents of position2, t1 is the contents of tangent, t2 is the contents of tangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.


Vector3.Length

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 3-D vector.

Overload List

public float Length();
public static float Length(Vector3);

See Also

  • LengthSq


Vector3.Length()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 3-D vector.

Definition

Visual Basic .NET | Public Function Length() As Single
C# | public float Length();
Managed C++ | public: float Length();
JScript .NET | public function Length() : float;

Return Value

System.Single . A Single Leave Site value that contains the vector's length.

See Also

  • LengthSq


Vector3.Length(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 3-D vector.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal source As Vector3 _
) As Single
C# public static float Length(
Vector3 source
);
Managed C++ public: static float Length(
Vector3 source
);
JScript .NET public static function Length(
source : Vector3
) : float;

Parameters

source Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that contains the vector's length.

See Also

  • LengthSq


Vector3.LengthSq

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 3-D vector.

Overload List

public float LengthSq();
public static float LengthSq(Vector3);

See Also

  • Length


Vector3.LengthSq()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 3-D vector.

Definition

Visual Basic .NET | Public Function LengthSq() As Single
C# | public float LengthSq();
Managed C++ | public: float LengthSq();
JScript .NET | public function LengthSq() : float;

Return Value

System.Single . A Single Leave Site value that contains the vector's squared length.

See Also

  • Length


Vector3.LengthSq(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 3-D vector.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal source As Vector3 _
) As Single
C# public static float LengthSq(
Vector3 source
);
Managed C++ public: static float LengthSq(
Vector3 source
);
JScript .NET public static function LengthSq(
source : Vector3
) : float;

Parameters

source Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

System.Single . A Single Leave Site value that contains the vector's squared length.

See Also

  • Length


Vector3.Lerp(Vector3,Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a linear interpolation between two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal left As Vector3, _
ByVal right As Vector3, _
ByVal interpolater As Single _
) As Vector3
C# public static Vector3 Lerp(
Vector3 left,
Vector3 right,
float interpolater
);
Managed C++ public: static Vector3 Lerp(
Vector3 left,
Vector3 right,
float interpolater
);
JScript .NET public static function Lerp(
left : Vector3,
right : Vector3,
interpolater : float
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure.
right | Microsoft.DirectX.Vector3. Source Vector3 structure.
interpolater | System.Single. Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

left + interpolater(right - left).


Vector3.Maximize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Overload List

public void Maximize(Vector3);
public static Vector3 Maximize(Vector3, Vector3);

See Also

  • Minimize


Vector3.Maximize(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Definition

Visual Basic .NET Public Sub Maximize( _
ByVal source As Vector3 _
)
C# public void Maximize(
Vector3 source
);
Managed C++ public: void Maximize(
Vector3 source
);
JScript .NET public function Maximize(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3. Source Vector3 structure.

See Also

  • Minimize


Vector3.Maximize(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Maximize( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Maximize(
Vector3 left,
Vector3 right
);
Managed C++ public: static Vector3 Maximize(
Vector3 left,
Vector3 right
);
JScript .NET public static function Maximize(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure.
right | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is made up of the largest components of the two vectors.

See Also

  • Minimize


Vector3.Minimize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Overload List

public void Minimize(Vector3);
public static Vector3 Minimize(Vector3, Vector3);

See Also

  • Maximize


Vector3.Minimize(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Definition

Visual Basic .NET Public Sub Minimize( _
ByVal source As Vector3 _
)
C# public void Minimize(
Vector3 source
);
Managed C++ public: void Minimize(
Vector3 source
);
JScript .NET public function Minimize(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3. Source Vector3 structure.

See Also

  • Maximize


Vector3.Minimize(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Minimize( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Minimize(
Vector3 left,
Vector3 right
);
Managed C++ public: static Vector3 Minimize(
Vector3 left,
Vector3 right
);
JScript .NET public static function Minimize(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure.
right | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is made up of the smallest components of the two vectors.

See Also

  • Maximize


Vector3.Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies a 3-D vector by a Single Leave Site value.

Overload List

public void Multiply(float);
public static Vector3 Multiply(Vector3, float);


Vector3.Multiply(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies a 3-D vector by a Single Leave Site value.

Definition

Visual Basic .NET Public Shared Function Multiply( _
ByVal source As Vector3, _
ByVal f As Single _
) As Vector3
C# public static Vector3 Multiply(
Vector3 source,
float f
);
Managed C++ public: static Vector3 Multiply(
Vector3 source,
float f
);
JScript .NET public static function Multiply(
source : Vector3,
f : float
) : Vector3;

Parameters

source | Microsoft.DirectX.Vector3. Source Vector3 structure.
f | System.Single. Source Single Leave Site value used as a multiplier.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is multiplied by the Single Leave Site value.


Vector3.Multiply(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies a 3-D vector by a Single Leave Site value.

Definition

Visual Basic .NET Public Sub Multiply( _
ByVal s As Single _
)
C# public void Multiply(
float s
);
Managed C++ public: void Multiply(
float s
);
JScript .NET public function Multiply(
s : float
);

Parameters

s System.Single. Source Single Leave Site value used as a multiplier.


Vector3.Normalize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 3-D vector.

Overload List

public void Normalize();
public static Vector3 Normalize(Vector3);


Vector3.Normalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 3-D vector.

Definition

Visual Basic .NET | Public Sub Normalize()
C# | public void Normalize();
Managed C++ | public: void Normalize();
JScript .NET | public function Normalize();


Vector3.Normalize(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 3-D vector.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal source As Vector3 _
) As Vector3
C# public static Vector3 Normalize(
Vector3 source
);
Managed C++ public: static Vector3 Normalize(
Vector3 source
);
JScript .NET public static function Normalize(
source : Vector3
) : Vector3;

Parameters

source Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the normalized version of the specified vector.


Vector3.op_Addition(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_Addition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two vectors.

Definition

Visual Basic .NET Public Shared Function op_Addition( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 op_Addition(
Vector3 left,
Vector3 right
);
Managed C++ public: static Vector3 op_Addition(
Vector3 left,
Vector3 right
);
JScript .NET public static function op_Addition(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure.
right | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that contains the sum of the parameters.


Vector3.op_Equality(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Boolean
C# public static bool op_Equality(
Vector3 left,
Vector3 right
);
Managed C++ public: static bool op_Equality(
Vector3 left,
Vector3 right
);
JScript .NET public static function op_Equality(
left : Vector3,
right : Vector3
) : boolean;

Parameters

left | Microsoft.DirectX.Vector3. The Vector3 structure to the left of the equality operator.
right | Microsoft.DirectX.Vector3. The Vector3 structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Vector3.op_Inequality(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Boolean
C# public static bool op_Inequality(
Vector3 left,
Vector3 right
);
Managed C++ public: static bool op_Inequality(
Vector3 left,
Vector3 right
);
JScript .NET public static function op_Inequality(
left : Vector3,
right : Vector3
) : boolean;

Parameters

left | Microsoft.DirectX.Vector3. The Vector3 structure to the left of the inequality operator.
right | Microsoft.DirectX.Vector3. The Vector3 structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Vector3.op_Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a single value and a 3-D vector.

Overload List

public static Vector3 op_Multiply(float, Vector3);
public static Vector3 op_Multiply(Vector3, float);


Vector3.op_Multiply(Single,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a single value and a 3-D vector.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal right As Single, _
ByVal left As Vector3 _
) As Vector3
C# public static Vector3 op_Multiply(
float right,
Vector3 left
);
Managed C++ public: static Vector3 op_Multiply(
float right,
Vector3 left
);
JScript .NET public static function op_Multiply(
right : float,
left : Vector3
) : Vector3;

Parameters

right | System.Single. Source Single Leave Site structure.
left | Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the product of the right and left parameters.


Vector3.op_Multiply(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a single value and a 3-D vector.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal left As Vector3, _
ByVal right As Single _
) As Vector3
C# public static Vector3 op_Multiply(
Vector3 left,
float right
);
Managed C++ public: static Vector3 op_Multiply(
Vector3 left,
float right
);
JScript .NET public static function op_Multiply(
left : Vector3,
right : float
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure.
right | System.Single. Source Single Leave Site structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the product of the right and left parameters.


Vector3.op_Subtraction(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_Subtraction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function op_Subtraction( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 op_Subtraction(
Vector3 left,
Vector3 right
);
Managed C++ public: static Vector3 op_Subtraction(
Vector3 left,
Vector3 right
);
JScript .NET public static function op_Subtraction(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. The Vector3 structure to the left of the subtraction operator.
right | Microsoft.DirectX.Vector3. The Vector3 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector3 . Resulting Vector3 structure.


Vector3.op_UnaryNegation(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.op_UnaryNegation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Negates the vector.

Definition

Visual Basic .NET Public Shared Function op_UnaryNegation( _
ByVal vec As Vector3 _
) As Vector3
C# public static Vector3 op_UnaryNegation(
Vector3 vec
);
Managed C++ public: static Vector3 op_UnaryNegation(
Vector3 vec
);
JScript .NET public static function op_UnaryNegation(
vec : Vector3
) : Vector3;

Parameters

vec Microsoft.DirectX.Vector3. Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3 . The Vector3 structure that is the result of the operation.

Remarks

This method switches positive and negative values of the Vector3 structure's X, Y, and Z fields.


Vector3.Project

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Project Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a vector from object space into screen space.

Overload List

public void Project(object, Matrix, Matrix, Matrix);
public static Vector3 Project(Vector3, object, Matrix, Matrix, Matrix);

See Also

  • Unproject


Vector3.Project(Object,Matrix,Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Project Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a vector from object space into screen space.

Definition

Visual Basic .NET Public Sub Project( _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
)
C# public void Project(
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
Managed C++ public: void Project(
Object *viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript .NET public function Project(
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
);

Parameters

viewport | System.Object. An Object Leave Site structure that represents the viewport. Only Viewport structures are valid for this parameter.
projection | Microsoft.DirectX.Matrix. A Matrix structure that represents the projection matrix.
view | Microsoft.DirectX.Matrix. A Matrix structure that represents the view matrix.
world | Microsoft.DirectX.Matrix. A Matrix structure that represents the world matrix.

See Also

  • Unproject


Vector3.Project(Vector3,Object,Matrix,Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Project Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a vector from object space into screen space.

Definition

Visual Basic .NET Public Shared Function Project( _
ByVal v As Vector3, _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
) As Vector3
C# public static Vector3 Project(
Vector3 v,
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
Managed C++ public: static Vector3 Project(
Vector3 v,
Object *viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript .NET public static function Project(
v : Vector3,
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
) : Vector3;

Parameters

v | Microsoft.DirectX.Vector3. The source Vector3 structure.
viewport | System.Object. An Object Leave Site structure that represents the viewport. Only Viewport structures are valid for this parameter.
projection | Microsoft.DirectX.Matrix. A Matrix structure that represents the projection matrix.
view | Microsoft.DirectX.Matrix. A Matrix structure that represents the view matrix.
world | Microsoft.DirectX.Matrix. A Matrix structure that represents the world matrix.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the vector projected from object space into screen space.

See Also

  • Unproject


Vector3.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 3-D vector.

Overload List

public void Scale(float);
public static Vector3 Scale(Vector3, float);


Vector3.Scale(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 3-D vector.

Definition

Visual Basic .NET Public Sub Scale( _
ByVal scalingFactor As Single _
)
C# public void Scale(
float scalingFactor
);
Managed C++ public: void Scale(
float scalingFactor
);
JScript .NET public function Scale(
scalingFactor : float
);

Parameters

scalingFactor System.Single. Scaling value.


Vector3.Scale(Vector3,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 3-D vector.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal source As Vector3, _
ByVal scalingFactor As Single _
) As Vector3
C# public static Vector3 Scale(
Vector3 source,
float scalingFactor
);
Managed C++ public: static Vector3 Scale(
Vector3 source,
float scalingFactor
);
JScript .NET public static function Scale(
source : Vector3,
scalingFactor : float
) : Vector3;

Parameters

source | Microsoft.DirectX.Vector3. Source Vector3 structure.
scalingFactor | System.Single. Scaling value.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the scaled vector.


Vector3.Subtract

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 3-D vectors.

Overload List

public void Subtract(Vector3);
public static Vector3 Subtract(Vector3, Vector3);


Vector3.Subtract(Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 3-D vectors.

Definition

Visual Basic .NET Public Sub Subtract( _
ByVal source As Vector3 _
)
C# public void Subtract(
Vector3 source
);
Managed C++ public: void Subtract(
Vector3 source
);
JScript .NET public function Subtract(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3. Source Vector3 structure to subtract from the current instance.


Vector3.Subtract(Vector3,Vector3)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 3-D vectors.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Subtract(
Vector3 left,
Vector3 right
);
Managed C++ public: static Vector3 Subtract(
Vector3 left,
Vector3 right
);
JScript .NET public static function Subtract(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left | Microsoft.DirectX.Vector3. Source Vector3 structure to the left of the subtraction operator.
right | Microsoft.DirectX.Vector3. Source Vector3 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the result of the operation.


Vector3.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Vector3.Transform

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Overload List

public static Vector4 Transform(Vector3, Matrix);
public static Vector4[] Transform(Vector3[], Matrix);

See Also

  • TransformCoordinate
  • TransformNormal


Vector3.Transform(Vector3[],Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal vector() As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector4()
C# public static Vector4[] Transform(
Vector3[] vector,
Matrix sourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector3 vector __gc[],
Matrix sourceMatrix
) __gc[];
JScript .NET public static function Transform(
vector : Vector3[],
sourceMatrix : Matrix
) : Vector4[];

Parameters

vector | Microsoft.DirectX.Vector3[]. Array of source Vector3 structures.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4[]. Array of Vector4 structures that are the result of the method.

Remarks

This method transforms an array of vectors passed into vector by the matrix sourceMatrix.

See Also

  • TransformCoordinate
  • TransformNormal


Vector3.Transform(Vector3,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal source As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector3 source,
Matrix sourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector3 source,
Matrix sourceMatrix
);
JScript .NET public static function Transform(
source : Vector3,
sourceMatrix : Matrix
) : Vector4;

Parameters

source | Microsoft.DirectX.Vector3. Source Vector3 structure.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.

Remarks

This method transforms the vector source (x, y, 0, 1) by the matrix sourceMatrix.

See Also

  • TransformCoordinate
  • TransformNormal


Vector3.TransformCoordinate

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Overload List

public void TransformCoordinate(Matrix);
public static Vector3 TransformCoordinate(Vector3, Matrix);
public static Vector3[] TransformCoordinate(Vector3[], Matrix);

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformCoordinate(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic .NET Public Sub TransformCoordinate( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformCoordinate(
Matrix sourceMatrix
);
Managed C++ public: void TransformCoordinate(
Matrix sourceMatrix
);
JScript .NET public function TransformCoordinate(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix. Source Matrix structure.

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformCoordinate(Vector3[],Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic .NET Public Shared Function TransformCoordinate( _
ByVal vector() As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3()
C# public static Vector3[] TransformCoordinate(
Vector3[] vector,
Matrix sourceMatrix
);
Managed C++ public: static Vector3 TransformCoordinate(
Vector3 vector __gc[],
Matrix sourceMatrix
) __gc[];
JScript .NET public static function TransformCoordinate(
vector : Vector3[],
sourceMatrix : Matrix
) : Vector3[];

Parameters

vector | Microsoft.DirectX.Vector3[]. Array of source Vector3 structures.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3[]. Array of Vector3 structures that represent the results of the method.

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformCoordinate(Vector3,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformCoordinate Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic .NET Public Shared Function TransformCoordinate( _
ByVal source As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformCoordinate(
Vector3 source,
Matrix sourceMatrix
);
Managed C++ public: static Vector3 TransformCoordinate(
Vector3 source,
Matrix sourceMatrix
);
JScript .NET public static function TransformCoordinate(
source : Vector3,
sourceMatrix : Matrix
) : Vector3;

Parameters

source | Microsoft.DirectX.Vector3. Source Vector3 structure.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that represents the results of the method.

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformNormal

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector normal by the given matrix.

Overload List

public void TransformNormal(Matrix);
public static Vector3 TransformNormal(Vector3, Matrix);
public static Vector3[] TransformNormal(Vector3[], Matrix);

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.TransformNormal(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector normal by the given matrix.

Definition

Visual Basic .NET Public Sub TransformNormal( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformNormal(
Matrix sourceMatrix
);
Managed C++ public: void TransformNormal(
Matrix sourceMatrix
);
JScript .NET public function TransformNormal(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix. Source Matrix structure.

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.TransformNormal(Vector3[],Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector normal by the given matrix.

Definition

Visual Basic .NET Public Shared Function TransformNormal( _
ByVal vector() As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3()
C# public static Vector3[] TransformNormal(
Vector3[] vector,
Matrix sourceMatrix
);
Managed C++ public: static Vector3 TransformNormal(
Vector3 vector __gc[],
Matrix sourceMatrix
) __gc[];
JScript .NET public static function TransformNormal(
vector : Vector3[],
sourceMatrix : Matrix
) : Vector3[];

Parameters

vector | Microsoft.DirectX.Vector3[]. Array of source Vector3 structures.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3[]. Array of Vector3 structures that contain the results of this method.

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.TransformNormal(Vector3,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.TransformNormal Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 3-D vector normal by the given matrix.

Definition

Visual Basic .NET Public Shared Function TransformNormal( _
ByVal source As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformNormal(
Vector3 source,
Matrix sourceMatrix
);
Managed C++ public: static Vector3 TransformNormal(
Vector3 source,
Matrix sourceMatrix
);
JScript .NET public static function TransformNormal(
source : Vector3,
sourceMatrix : Matrix
) : Vector3;

Parameters

source | Microsoft.DirectX.Vector3. Source Vector3 structure.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.Unproject

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Unproject Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a vector from screen space into object space.

Overload List

public void Unproject(object, Matrix, Matrix, Matrix);
public static Vector3 Unproject(Vector3, object, Matrix, Matrix, Matrix);

See Also

  • Project


Vector3.Unproject(Object,Matrix,Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Unproject Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a vector from screen space into object space.

Definition

Visual Basic .NET Public Sub Unproject( _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
)
C# public void Unproject(
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
Managed C++ public: void Unproject(
Object *viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript .NET public function Unproject(
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
);

Parameters

viewport | System.Object. An Object Leave Site that represents the viewport.
projection | Microsoft.DirectX.Matrix. A Matrix structure that represents the projection matrix.
view | Microsoft.DirectX.Matrix. A Matrix structure that represents the view matrix.
world | Microsoft.DirectX.Matrix. A Matrix structure that represents the world matrix.

See Also

  • Project


Vector3.Unproject(Vector3,Object,Matrix,Matrix,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Unproject Method

 Language:
Note: This documentation is preliminary and is subject to change.

Projects a vector from screen space into object space.

Definition

Visual Basic .NET Public Shared Function Unproject( _
ByVal v As Vector3, _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
) As Vector3
C# public static Vector3 Unproject(
Vector3 v,
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
Managed C++ public: static Vector3 Unproject(
Vector3 v,
Object *viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript .NET public static function Unproject(
v : Vector3,
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
) : Vector3;

Parameters

v | Microsoft.DirectX.Vector3. Source Vector3 structure.
viewport | System.Object. An Object Leave Site that represents the viewport.
projection | Microsoft.DirectX.Matrix. A Matrix structure that represents the projection matrix.
view | Microsoft.DirectX.Matrix. A Matrix structure that represents the view matrix.
world | Microsoft.DirectX.Matrix. A Matrix structure that represents the world matrix.

Return Value

Microsoft.DirectX.Vector3 . A Vector3 structure that is the vector projected from screen space into object space.

See Also

  • Project


Vector3.Vector3

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Vector3 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector3 class.

Overload List

public Vector3();
public Vector3(float, float, float);


Vector3.Vector3()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Vector3 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector3 class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Vector3();
Managed C++ | public: Vector3();
JScript .NET | public function Vector3();


Vector3.Vector3(Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Vector3 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector3 class.

Definition

Visual Basic .NET Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single, _
ByVal valueZ As Single _
)
C# public Vector3(
float valueX,
float valueY,
float valueZ
);
Managed C++ public: Vector3(
float valueX,
float valueY,
float valueZ
);
JScript .NET public function Vector3(
valueX : float,
valueY : float,
valueZ : float
);

Parameters

valueX | System.Single. Initial X value.
valueY | System.Single. Initial Y value.
valueZ | System.Single. Initial Z value.


Vector3.Empty

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Empty Property

Language:
Note: This documentation is preliminary and is subject to change.

Retrieves an empty 3-D vector.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Empty As Vector3
C# | public static Vector3 Empty { get; }
Managed C++ | public: __property static Vector3 get_Empty();
JScript .NET | public static function get Empty() : Vector3

Property Value

Microsoft.DirectX.Vector3 . Empty Vector3 structure.

This property is read-only.


Vector3.X

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of a 3-D vector.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . A Single Leave Site value that represents the x component of a 3-D vector.

This field is read/write.


Vector3.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of a 3-D vector.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . A Single Leave Site value that represents the y component of a 3-D vector.

This field is read/write.


Vector3.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector3.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of a 3-D vector.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . A Single Leave Site value that represents the z component of a 3-D vector.

This field is read/write.


Vector4

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4 Structure

 Language:
Note: This documentation is preliminary and is subject to change.

Describes a vector in four-dimensional (4-D) space.

Definition

Visual Basic .NET | Public Structure Vector4
C# | public struct Vector4
Managed C++ | public __value struct Vector4
JScript .NET | In JScript .NET, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
W | Retrieves or sets the w component of a 4-D vector.
X | Retrieves or sets the x component of a 4-D vector.
Y | Retrieves or sets the y component of a 4-D vector.
Z | Retrieves or sets the z component of a 4-D vector.

Methods

Method | Description
Add | Adds two 4-D vectors.
static (Shared in Visual Basic .NET) BaryCentric | Returns a point in barycentric coordinates, using the specified 4-D vectors.
static (Shared in Visual Basic .NET) CatmullRom | Performs a Catmull-Rom interpolation using specified 4-D vectors.
static (Shared in Visual Basic .NET) Cross | Determines the cross product in four dimensions.
static (Shared in Visual Basic .NET) Dot | Determines the dot product of two 4-D vectors.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic .NET) Hermite | Performs a Hermite spline interpolation using the specified 4-D vectors.
Length | Returns the length of a 4-D vector.
LengthSq | Returns the square of the length of a 4-D vector.
static (Shared in Visual Basic .NET) Lerp | Performs a linear interpolation between two 4-D vectors.
Maximize | Returns a 4-D vector that is made up of the largest components of two 4-D vectors.
Minimize | Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.
Multiply | Multiplies a 4-D vector by a Single Leave Site value.
Normalize | Returns the normalized version of a 4-D vector.
static (Shared in Visual Basic .NET) op_Addition | Adds two vectors.
static (Shared in Visual Basic .NET) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic .NET) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic .NET) op_Multiply | Determines the product of a Single Leave Site value and a 4-D vector.
static (Shared in Visual Basic .NET) op_Subtraction | Subtracts two 4-D vectors.
static (Shared in Visual Basic .NET) op_UnaryNegation | Negates the vector.
Scale | Scales a 4-D vector.
Subtract | Subtracts two 4-D vectors.
ToString | Obtains a string representation of the current instance.
Transform | Transforms a 4-D vector or an array of 4-D vectors by a given matrix.
Vector4 | Initializes a new instance of the Vector4 class.

Properties

Property | Description
static (Shared in Visual Basic .NET) Empty | Returns an empty 4-D vector.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Vector4 Class


Vector4.Add

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 4-D vectors.

Overload List

public void Add(Vector4);
public static Vector4 Add(Vector4, Vector4);


Vector4.Add(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 4-D vectors.

Definition

Visual Basic .NET Public Sub Add( _
ByVal source As Vector4 _
)
C# public void Add(
Vector4 source
);
Managed C++ public: void Add(
Vector4 source
);
JScript .NET public function Add(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4.


Vector4.Add(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Add Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two 4-D vectors.

Definition

Visual Basic .NET Public Shared Function Add( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Add(
Vector4 left,
Vector4 right
);
Managed C++ public: static Vector4 Add(
Vector4 left,
Vector4 right
);
JScript .NET public static function Add(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4.
right | Microsoft.DirectX.Vector4. Source Vector4.

Return Value

Microsoft.DirectX.Vector4 . Sum of the two Vector4 structures.


Vector4.BaryCentric(Vector4,Vector4,Vector4,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.BaryCentric Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a point in barycentric coordinates, using the specified 4-D vectors.

Definition

Visual Basic .NET Public Shared Function BaryCentric( _
ByVal v1 As Vector4, _
ByVal v2 As Vector4, _
ByVal v3 As Vector4, _
ByVal f As Single, _
ByVal g As Single _
) As Vector4
C# public static Vector4 BaryCentric(
Vector4 v1,
Vector4 v2,
Vector4 v3,
float f,
float g
);
Managed C++ public: static Vector4 BaryCentric(
Vector4 v1,
Vector4 v2,
Vector4 v3,
float f,
float g
);
JScript .NET public static function BaryCentric(
v1 : Vector4,
v2 : Vector4,
v3 : Vector4,
f : float,
g : float
) : Vector4;

Parameters

v1 | Microsoft.DirectX.Vector4. Source Vector4 structure.
v2 | Microsoft.DirectX.Vector4. Source Vector4 structure.
v3 | Microsoft.DirectX.Vector4. Source Vector4 structure.
f | System.Single. Weighting factor. See Remarks.
g | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure in barycentric coordinates.

Remarks

The Vector4.BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

v1 + f(v2 - v1) + g(v3 - v1)

Any point in the plane v1v2v3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which v2 gets weighted into the result, and the f parameter controls the extent to which v3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which v1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle v1v2v3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line v1v3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line v1v2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line v2v3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.


Vector4.CatmullRom(Vector4,Vector4,Vector4,Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.CatmullRom Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Catmull-Rom interpolation using specified 4-D vectors.

Definition

Visual Basic .NET Public Shared Function CatmullRom( _
ByVal position1 As Vector4, _
ByVal position2 As Vector4, _
ByVal position3 As Vector4, _
ByVal position4 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 CatmullRom(
Vector4 position1,
Vector4 position2,
Vector4 position3,
Vector4 position4,
float weightingFactor
);
Managed C++ public: static Vector4 CatmullRom(
Vector4 position1,
Vector4 position2,
Vector4 position3,
Vector4 position4,
float weightingFactor
);
JScript .NET public static function CatmullRom(
position1 : Vector4,
position2 : Vector4,
position3 : Vector4,
position4 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

position1 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
position2 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
position3 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
position4 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of position1, v2 is the contents of position2, p3 is the contents of position3, p4 is the contents of position4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the following Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom


Vector4.Cross(Vector4,Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Cross Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the cross product in four dimensions.

Definition

Visual Basic .NET Public Shared Function Cross( _
ByVal v1 As Vector4, _
ByVal v2 As Vector4, _
ByVal v3 As Vector4 _
) As Vector4
C# public static Vector4 Cross(
Vector4 v1,
Vector4 v2,
Vector4 v3
);
Managed C++ public: static Vector4 Cross(
Vector4 v1,
Vector4 v2,
Vector4 v3
);
JScript .NET public static function Cross(
v1 : Vector4,
v2 : Vector4,
v3 : Vector4
) : Vector4;

Parameters

v1 | Microsoft.DirectX.Vector4. Source Vector4 structure.
v2 | Microsoft.DirectX.Vector4. Source Vector4 structure.
v3 | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the cross product.

See Also

  • Dot


Vector4.Dot(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Dot Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the dot product of two 4-D vectors.

Definition

Visual Basic .NET Public Shared Function Dot( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Single
C# public static float Dot(
Vector4 left,
Vector4 right
);
Managed C++ public: static float Dot(
Vector4 left,
Vector4 right
);
JScript .NET public static function Dot(
left : Vector4,
right : Vector4
) : float;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4 structure.
right | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

System.Single . A Single Leave Site value that represents the dot product.

See Also

  • Cross


Vector4.Equals(Object)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Equals Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic .NET Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
Managed C++ public: bool Equals(
Object *compare
);
JScript .NET public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object. Object with which to make the comparison.

Return Value

System.Boolean . Value that is true if the current instance is equal to the specified object, or false if it is not.


Vector4.GetHashCode()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.GetHashCode Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the hash code for the current instance.

Definition

Visual Basic .NET | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
Managed C++ | public: int GetHashCode();
JScript .NET | public override function GetHashCode() : int;

Return Value

System.Int32 . Hash code for the instance.


Vector4.Hermite(Vector4,Vector4,Vector4,Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Hermite Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a Hermite spline interpolation using the specified 4-D vectors.

Definition

Visual Basic .NET Public Shared Function Hermite( _
ByVal position As Vector4, _
ByVal tangent As Vector4, _
ByVal position2 As Vector4, _
ByVal tangent2 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 Hermite(
Vector4 position,
Vector4 tangent,
Vector4 position2,
Vector4 tangent2,
float weightingFactor
);
Managed C++ public: static Vector4 Hermite(
Vector4 position,
Vector4 tangent,
Vector4 position2,
Vector4 tangent2,
float weightingFactor
);
JScript .NET public static function Hermite(
position : Vector4,
tangent : Vector4,
position2 : Vector4,
tangent2 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

position | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
tangent | Microsoft.DirectX.Vector4. Source Vector4 structure that is a tangent vector.
position2 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a position vector.
tangent2 | Microsoft.DirectX.Vector4. Source Vector4 structure that is a tangent vector.
weightingFactor | System.Single. Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (position, tangent) to (position2, tangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of position, v2 is the contents of position2, t1 is the contents of tangent, t2 is the contents of tangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.


Vector4.Length

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 4-D vector.

Overload List

public float Length();
public static float Length(Vector4);

See Also

  • LengthSq


Vector4.Length()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 4-D vector.

Definition

Visual Basic .NET | Public Function Length() As Single
C# | public float Length();
Managed C++ | public: float Length();
JScript .NET | public function Length() : float;

Return Value

System.Single . A Single Leave Site value that indicates the vector's length.

See Also

  • LengthSq


Vector4.Length(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Length Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the length of a 4-D vector.

Definition

Visual Basic .NET Public Shared Function Length( _
ByVal source As Vector4 _
) As Single
C# public static float Length(
Vector4 source
);
Managed C++ public: static float Length(
Vector4 source
);
JScript .NET public static function Length(
source : Vector4
) : float;

Parameters

source Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

System.Single . A Single Leave Site value that indicates the vector's length.

See Also

  • LengthSq


Vector4.LengthSq

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 4-D vector.

Overload List

public float LengthSq();
public static float LengthSq(Vector4);

See Also

  • Length


Vector4.LengthSq()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 4-D vector.

Definition

Visual Basic .NET | Public Function LengthSq() As Single
C# | public float LengthSq();
Managed C++ | public: float LengthSq();
JScript .NET | public function LengthSq() : float;

Return Value

System.Single . A Single Leave Site value that indicates the vector's squared length.

See Also

  • Length


Vector4.LengthSq(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.LengthSq Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the square of the length of a 4-D vector.

Definition

Visual Basic .NET Public Shared Function LengthSq( _
ByVal source As Vector4 _
) As Single
C# public static float LengthSq(
Vector4 source
);
Managed C++ public: static float LengthSq(
Vector4 source
);
JScript .NET public static function LengthSq(
source : Vector4
) : float;

Parameters

source Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

System.Single . A Single Leave Site value that indicates the vector's squared length.

See Also

  • Length


Vector4.Lerp(Vector4,Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Lerp Method

 Language:
Note: This documentation is preliminary and is subject to change.

Performs a linear interpolation between two 4-D vectors.

Definition

Visual Basic .NET Public Shared Function Lerp( _
ByVal left As Vector4, _
ByVal right As Vector4, _
ByVal interpolater As Single _
) As Vector4
C# public static Vector4 Lerp(
Vector4 left,
Vector4 right,
float interpolater
);
Managed C++ public: static Vector4 Lerp(
Vector4 left,
Vector4 right,
float interpolater
);
JScript .NET public static function Lerp(
left : Vector4,
right : Vector4,
interpolater : float
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4 structure.
right | Microsoft.DirectX.Vector4. Source Vector4 structure.
interpolater | System.Single. Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

left + interpolater(right - left).


Vector4.Maximize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Overload List

public void Maximize(Vector4);
public static Vector4 Maximize(Vector4, Vector4);

See Also

  • Minimize


Vector4.Maximize(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Definition

Visual Basic .NET Public Sub Maximize( _
ByVal source As Vector4 _
)
C# public void Maximize(
Vector4 source
);
Managed C++ public: void Maximize(
Vector4 source
);
JScript .NET public function Maximize(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4. Source Vector4 structure.

See Also

  • Minimize


Vector4.Maximize(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Maximize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Definition

Visual Basic .NET Public Shared Function Maximize( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Maximize(
Vector4 left,
Vector4 right
);
Managed C++ public: static Vector4 Maximize(
Vector4 left,
Vector4 right
);
JScript .NET public static function Maximize(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4 structure.
right | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is made up of the largest components of the two vectors.

See Also

  • Minimize


Vector4.Minimize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Overload List

public void Minimize(Vector4);
public static Vector4 Minimize(Vector4, Vector4);

See Also

  • Maximize


Vector4.Minimize(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Definition

Visual Basic .NET Public Sub Minimize( _
ByVal source As Vector4 _
)
C# public void Minimize(
Vector4 source
);
Managed C++ public: void Minimize(
Vector4 source
);
JScript .NET public function Minimize(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4. Source Vector4 structure.

See Also

  • Maximize


Vector4.Minimize(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Minimize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Definition

Visual Basic .NET Public Shared Function Minimize( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Minimize(
Vector4 left,
Vector4 right
);
Managed C++ public: static Vector4 Minimize(
Vector4 left,
Vector4 right
);
JScript .NET public static function Minimize(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4 structure.
right | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is made up of the smallest components of the two vectors.

See Also

  • Maximize


Vector4.Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies a 4-D vector by a Single Leave Site value.

Overload List

public void Multiply(float);
public static Vector4 Multiply(Vector4, float);


Vector4.Multiply(Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies a 4-D vector by a Single Leave Site value.

Definition

Visual Basic .NET Public Shared Function Multiply( _
ByVal source As Vector4, _
ByVal f As Single _
) As Vector4
C# public static Vector4 Multiply(
Vector4 source,
float f
);
Managed C++ public: static Vector4 Multiply(
Vector4 source,
float f
);
JScript .NET public static function Multiply(
source : Vector4,
f : float
) : Vector4;

Parameters

source | Microsoft.DirectX.Vector4. Source Vector4 structure.
f | System.Single. Source Single Leave Site value used as a multiplier.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is multiplied by the Single Leave Site value.


Vector4.Multiply(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Multiplies a 4-D vector by a Single Leave Site value.

Definition

Visual Basic .NET Public Sub Multiply( _
ByVal s As Single _
)
C# public void Multiply(
float s
);
Managed C++ public: void Multiply(
float s
);
JScript .NET public function Multiply(
s : float
);

Parameters

s System.Single. Source Single Leave Site value used as a multiplier.


Vector4.Normalize

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 4-D vector.

Overload List

public void Normalize();
public static Vector4 Normalize(Vector4);


Vector4.Normalize()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 4-D vector.

Definition

Visual Basic .NET | Public Sub Normalize()
C# | public void Normalize();
Managed C++ | public: void Normalize();
JScript .NET | public function Normalize();


Vector4.Normalize(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Normalize Method

 Language:
Note: This documentation is preliminary and is subject to change.

Returns the normalized version of a 4-D vector.

Definition

Visual Basic .NET Public Shared Function Normalize( _
ByVal source As Vector4 _
) As Vector4
C# public static Vector4 Normalize(
Vector4 source
);
Managed C++ public: static Vector4 Normalize(
Vector4 source
);
JScript .NET public static function Normalize(
source : Vector4
) : Vector4;

Parameters

source Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the normalized version of the specified vector.


Vector4.op_Addition(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_Addition Method

 Language:
Note: This documentation is preliminary and is subject to change.

Adds two vectors.

Definition

Visual Basic .NET Public Shared Function op_Addition( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 op_Addition(
Vector4 left,
Vector4 right
);
Managed C++ public: static Vector4 op_Addition(
Vector4 left,
Vector4 right
);
JScript .NET public static function op_Addition(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4 structure.
right | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that contains the sum of the parameters.


Vector4.op_Equality(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_Equality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic .NET Public Shared Function op_Equality( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Boolean
C# public static bool op_Equality(
Vector4 left,
Vector4 right
);
Managed C++ public: static bool op_Equality(
Vector4 left,
Vector4 right
);
JScript .NET public static function op_Equality(
left : Vector4,
right : Vector4
) : boolean;

Parameters

left | Microsoft.DirectX.Vector4. The Vector4 structure to the left of the equality operator.
right | Microsoft.DirectX.Vector4. The Vector4 structure to the right of the equality operator.

Return Value

System.Boolean . Value that is true if the objects are the same, or false if they are different.


Vector4.op_Inequality(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_Inequality Method

 Language:
Note: This documentation is preliminary and is subject to change.

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic .NET Public Shared Function op_Inequality( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Boolean
C# public static bool op_Inequality(
Vector4 left,
Vector4 right
);
Managed C++ public: static bool op_Inequality(
Vector4 left,
Vector4 right
);
JScript .NET public static function op_Inequality(
left : Vector4,
right : Vector4
) : boolean;

Parameters

left | Microsoft.DirectX.Vector4. The Vector4 structure to the left of the inequality operator.
right | Microsoft.DirectX.Vector4. The Vector4 structure to the right of the inequality operator.

Return Value

System.Boolean . Value that is true if the objects are different, or false if they are the same.


Vector4.op_Multiply

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a Single Leave Site value and a 4-D vector.

Overload List

public static Vector4 op_Multiply(float, Vector4);
public static Vector4 op_Multiply(Vector4, float);


Vector4.op_Multiply(Single,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a Single Leave Site value and a 4-D vector.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal right As Single, _
ByVal left As Vector4 _
) As Vector4
C# public static Vector4 op_Multiply(
float right,
Vector4 left
);
Managed C++ public: static Vector4 op_Multiply(
float right,
Vector4 left
);
JScript .NET public static function op_Multiply(
right : float,
left : Vector4
) : Vector4;

Parameters

right | System.Single. Source Single Leave Site structure.
left | Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the product of the right and left parameters.


Vector4.op_Multiply(Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_Multiply Method

 Language:
Note: This documentation is preliminary and is subject to change.

Determines the product of a Single Leave Site value and a 4-D vector.

Definition

Visual Basic .NET Public Shared Function op_Multiply( _
ByVal left As Vector4, _
ByVal right As Single _
) As Vector4
C# public static Vector4 op_Multiply(
Vector4 left,
float right
);
Managed C++ public: static Vector4 op_Multiply(
Vector4 left,
float right
);
JScript .NET public static function op_Multiply(
left : Vector4,
right : float
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4 structure.
right | System.Single. Source Single Leave Site structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the product of the right and left parameters.


Vector4.op_Subtraction(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_Subtraction Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 4-D vectors.

Definition

Visual Basic .NET Public Shared Function op_Subtraction( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 op_Subtraction(
Vector4 left,
Vector4 right
);
Managed C++ public: static Vector4 op_Subtraction(
Vector4 left,
Vector4 right
);
JScript .NET public static function op_Subtraction(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. The Vector4 structure to the left of the subtraction operator.
right | Microsoft.DirectX.Vector4. The Vector4 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector4 . Resulting Vector4 structure.


Vector4.op_UnaryNegation(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.op_UnaryNegation Method

 Language:
Note: This documentation is preliminary and is subject to change.

Negates the vector.

Definition

Visual Basic .NET Public Shared Function op_UnaryNegation( _
ByVal vec As Vector4 _
) As Vector4
C# public static Vector4 op_UnaryNegation(
Vector4 vec
);
Managed C++ public: static Vector4 op_UnaryNegation(
Vector4 vec
);
JScript .NET public static function op_UnaryNegation(
vec : Vector4
) : Vector4;

Parameters

vec Microsoft.DirectX.Vector4. Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4 . The Vector4 structure that is the result of the operation.

Remarks

This method switches positive and negative values of the Vector4 structure's X, Y, and Z fields.


Vector4.Scale

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 4-D vector.

Overload List

public void Scale(float);
public static Vector4 Scale(Vector4, float);


Vector4.Scale(Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 4-D vector.

Definition

Visual Basic .NET Public Sub Scale( _
ByVal scalingFactor As Single _
)
C# public void Scale(
float scalingFactor
);
Managed C++ public: void Scale(
float scalingFactor
);
JScript .NET public function Scale(
scalingFactor : float
);

Parameters

scalingFactor System.Single. Scaling value.


Vector4.Scale(Vector4,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Scale Method

 Language:
Note: This documentation is preliminary and is subject to change.

Scales a 4-D vector.

Definition

Visual Basic .NET Public Shared Function Scale( _
ByVal source As Vector4, _
ByVal scalingFactor As Single _
) As Vector4
C# public static Vector4 Scale(
Vector4 source,
float scalingFactor
);
Managed C++ public: static Vector4 Scale(
Vector4 source,
float scalingFactor
);
JScript .NET public static function Scale(
source : Vector4,
scalingFactor : float
) : Vector4;

Parameters

source | Microsoft.DirectX.Vector4. Source Vector4 structure.
scalingFactor | System.Single. Scaling value.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the scaled vector.


Vector4.Subtract

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 4-D vectors.

Overload List

public void Subtract(Vector4);
public static Vector4 Subtract(Vector4, Vector4);


Vector4.Subtract(Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 4-D vectors.

Definition

Visual Basic .NET Public Sub Subtract( _
ByVal source As Vector4 _
)
C# public void Subtract(
Vector4 source
);
Managed C++ public: void Subtract(
Vector4 source
);
JScript .NET public function Subtract(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4. Source Vector4 structure to subtract from the current instance.


Vector4.Subtract(Vector4,Vector4)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Subtract Method

 Language:
Note: This documentation is preliminary and is subject to change.

Subtracts two 4-D vectors.

Definition

Visual Basic .NET Public Shared Function Subtract( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Subtract(
Vector4 left,
Vector4 right
);
Managed C++ public: static Vector4 Subtract(
Vector4 left,
Vector4 right
);
JScript .NET public static function Subtract(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left | Microsoft.DirectX.Vector4. Source Vector4 structure to the left of the subtraction operator.
right | Microsoft.DirectX.Vector4. Source Vector4 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the operation.


Vector4.ToString()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.ToString Method

 Language:
Note: This documentation is preliminary and is subject to change.

Obtains a string representation of the current instance.

Definition

Visual Basic .NET | Overrides Public Function ToString() As String
C# | public override string ToString();
Managed C++ | public: String* ToString();
JScript .NET | public override function ToString() : String;

Return Value

System.String . String that represents the object.


Vector4.Transform

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Overload List

public void Transform(Matrix);
public static Vector4 Transform(Vector4, Matrix);
public static Vector4[] Transform(Vector4[], Matrix);


Vector4.Transform(Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Definition

Visual Basic .NET Public Sub Transform( _
ByVal sourceMatrix As Matrix _
)
C# public void Transform(
Matrix sourceMatrix
);
Managed C++ public: void Transform(
Matrix sourceMatrix
);
JScript .NET public function Transform(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix. Source Matrix structure.


Vector4.Transform(Vector4[],Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal vector() As Vector4, _
ByVal sourceMatrix As Matrix _
) As Vector4()
C# public static Vector4[] Transform(
Vector4[] vector,
Matrix sourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector4 vector __gc[],
Matrix sourceMatrix
) __gc[];
JScript .NET public static function Transform(
vector : Vector4[],
sourceMatrix : Matrix
) : Vector4[];

Parameters

vector | Microsoft.DirectX.Vector4[]. Array of source Vector4 structures.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4[]. Array of Vector4 structures that are the result of the method.


Vector4.Transform(Vector4,Matrix)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Transform Method

 Language:
Note: This documentation is preliminary and is subject to change.

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Definition

Visual Basic .NET Public Shared Function Transform( _
ByVal source As Vector4, _
ByVal sourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 source,
Matrix sourceMatrix
);
Managed C++ public: static Vector4 Transform(
Vector4 source,
Matrix sourceMatrix
);
JScript .NET public static function Transform(
source : Vector4,
sourceMatrix : Matrix
) : Vector4;

Parameters

source | Microsoft.DirectX.Vector4. Source Vector4 structure.
sourceMatrix | Microsoft.DirectX.Matrix. Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4 . A Vector4 structure that is the result of the method.


Vector4.Vector4

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Vector4 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector4 class.

Overload List

public Vector4();
public Vector4(float, float, float, float);


Vector4.Vector4()

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Vector4 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector4 class.

Definition

Visual Basic .NET | Public Sub New()
C# | public Vector4();
Managed C++ | public: Vector4();
JScript .NET | public function Vector4();


Vector4.Vector4(Single,Single,Single,Single)

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Vector4 Constructor

 Language:
Note: This documentation is preliminary and is subject to change.

Initializes a new instance of the Vector4 class.

Definition

Visual Basic .NET Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single, _
ByVal valueZ As Single, _
ByVal valueW As Single _
)
C# public Vector4(
float valueX,
float valueY,
float valueZ,
float valueW
);
Managed C++ public: Vector4(
float valueX,
float valueY,
float valueZ,
float valueW
);
JScript .NET public function Vector4(
valueX : float,
valueY : float,
valueZ : float,
valueW : float
);

Parameters

valueX | System.Single. Initial X value.
valueY | System.Single. Initial Y value.
valueZ | System.Single. Initial Z value.
valueW | System.Single. Initial W value.


Vector4.Empty

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Empty Property

Language:
Note: This documentation is preliminary and is subject to change.

Returns an empty 4-D vector.

Definition

Visual Basic .NET | Public Shared ReadOnly Property Empty As Vector4
C# | public static Vector4 Empty { get; }
Managed C++ | public: __property static Vector4 get_Empty();
JScript .NET | public static function get Empty() : Vector4

Property Value

Microsoft.DirectX.Vector4 . Empty Vector4.

This property is read-only.


Vector4.W

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.W Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the w component of a 4-D vector.

Definition

Visual Basic .NET | Public W As Single
C# | public Single W;
Managed C++ | public: Single W;
JScript .NET | public var W : Single

Field Value

System.Single . A Single Leave Site value that represents the w component of the 4-D vector.

This field is read/write.


Vector4.X

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.X Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the x component of a 4-D vector.

Definition

Visual Basic .NET | Public X As Single
C# | public Single X;
Managed C++ | public: Single X;
JScript .NET | public var X : Single

Field Value

System.Single . A Single Leave Site value that represents the x component of the 4-D vector.

This field is read/write.


Vector4.Y

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Y Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the y component of a 4-D vector.

Definition

Visual Basic .NET | Public Y As Single
C# | public Single Y;
Managed C++ | public: Single Y;
JScript .NET | public var Y : Single

Field Value

System.Single . A Single Leave Site value that represents the y component of the 4-D vector.

This field is read/write.


Vector4.Z

Microsoft DirectX 9.0 SDK Update (October 2004)

Vector4.Z Field

 Language:
Note: This documentation is preliminary and is subject to change.

Retrieves or sets the z component of a 4-D vector.

Definition

Visual Basic .NET | Public Z As Single
C# | public Single Z;
Managed C++ | public: Single Z;
JScript .NET | public var Z : Single

Field Value

System.Single . A Single Leave Site value that represents the z component of the 4-D vector.

This field is read/write.


Projection Transformation

Note: This documentation is preliminary and is subject to change.

The projection transformation can be thought of as controlling the camera's internals; it is analogous to choosing a lens for the camera. This is the most complicated of the three transformation types. This discussion of the projection transformation is organized into the following topics.

  • What Is the Projection Transformation?
  • Setting Up a Projection Matrix
  • A W-Friendly Projection Matrix


Setting Up a Projection Matrix

Note: This documentation is preliminary and is subject to change.

The following ProjectionMatrix sample function sets the front and back clipping planes, as well as the horizontal and vertical field-of-view angles. This C# code parallels the approach discussed in What Is the Projection Transformation?. The fields of view should be less than pi radians.

          [C#]

private Matrix ProjectionMatrix(float near_plane, float far_plane,
                                float fov_horiz, float fov_vert)
{
   float h,w,Q;

   w =  1/(float)Math.Tan(fov_horiz*0.5); // 1/tan(x) == cot(x)
   h =  1/(float)Math.Tan(fov_vert*0.5); // 1/tan(x) == cot(x)
   Q = far_plane/(far_plane - near_plane);

   Matrix ret = new Matrix();

   ret.M11 = w;
   ret.M22 = h;
   ret.M33 = Q;
   ret.M43 = -Q*near_plane;
   ret.M34 = 1;

   return ret;

}

After creating the matrix, set it with SetTransform, specifying TransformType.Projection, or pass the matrix to the Device.Transform.Projection property.

Microsoft® DirectX® 9.0 for Managed Code provides the following functions to help you set up a projection matrix.

  • Matrix.PerspectiveLH
  • Matrix.PerspectiveRH
  • Matrix.PerspectiveFovLH
  • Matrix.PerspectiveFovRH
  • Matrix.PerspectiveOffCenterLH
  • Matrix.PerspectiveOffCenterRH


A W-Friendly Projection Matrix

Note: This documentation is preliminary and is subject to change.

Microsoft® Direct3D® can use the w-component of a vertex that has been transformed by the world, view, and projection matrices to perform depth-based calculations in depth-buffer or fog effects. Computations such as these require that a projection matrix normalize w to be equivalent to world-space z. In short, if a projection matrix includes a (3,4) coefficient that is not 1, you must scale all of the coefficients by the inverse of the (3,4) coefficient to make a proper matrix. If you do not provide a compliant matrix, fog effects and depth buffering are not applied correctly. The projection matrix recommended in What Is the Projection Transformation? is compliant with w-based calculations.

The following illustration shows a noncompliant projection matrix, and the same matrix scaled so that eye-relative fog is enabled.

Eye Relative Matrix

In the preceding matrices, all variables are assumed to be nonzero. For more information about eye-relative fog, see Eye-Relative vs. Z-Based Depth. For more information about w-based depth buffering, see Depth Buffers.

Note: Direct3D uses the currently set projection matrix in its w-based depth calculations. As a result, applications must set a compliant projection matrix to receive the desired w-based features, even if they do not use the Direct3D transformation pipeline.


What Is the Projection Transformation?

Note: This documentation is preliminary and is subject to change.

The projection matrix is typically a scale and perspective projection. The projection transformation converts the viewing frustum into a cuboid shape. The near end of the viewing frustum is smaller than the far end, which has the effect of expanding objects that are near to the camera. This is how perspective is applied to the scene.

In the viewing frustum, the distance between the camera and the origin of the viewing transformation space is defined arbitrarily as D, so the projection matrix looks like the following illustration.

projection Matrix 1

The viewing matrix translates the camera to the origin by translating in the z-direction by -D. The translation matrix is as follows.

projection Matrix 2

Multiplying the translation matrix by the projection matrix (T*P) gives the composite projection matrix. It looks like the following illustration.

projection Matrix 3

The following illustration shows how the perspective transformation converts a viewing frustum to a new coordinate space. Notice that the frustum becomes cuboid and also that the origin moves from the upper-right corner of the scene to the center.

In the perspective transformation, the limits of the x- and y-directions are -1 and 1. The limits of the z-direction are 0 for the front plane and 1 for the back plane.

This matrix translates and scales objects based on a specified distance from the camera to the near clipping plane, but it does not consider the field of view (fov), and the z-values that it produces for objects in the distance can be nearly identical, making depth comparisons difficult. The following matrix addresses these issues, and it adjusts vertices to account for the aspect ratio of the viewport, making it a good choice for the perspective projection.

Projection Matrix X1

In the following matrix, Zn is the z-value of the near clipping plane. The variables w, h, and Q have the following meanings. Note that fovw and fovk represent the viewport's horizontal and vertical fields of view, in radians.

Projection Matrix X2

For your application, using field-of-view angles to define the x- and y-scaling coefficients might not be as convenient as using the viewport's horizontal and vertical dimensions (in camera space). As the math works out, the following two formulas for w and h use the viewport's dimensions, and are equivalent to the preceding formulas.

Projection Matrix X3

In these formulas, Zn represents the position of the near clipping plane, and the Vw and Vh variables represent the width and height of the viewport, in camera space.

For a managed application, these two dimensions correspond directly to the Width and Height members of the Viewport structure.

Whatever formula you decide to use, be sure to set Z to as large a value as possible, because z-values extremely close to the camera do not vary by much. This makes depth comparisons using 16-bit z-buffers somewhat complicated.

As with the world and view transformations, you call the Device.SetTransform method to set the projection transformation.


AnimationController.ICloneable.Clone()

Microsoft DirectX 9.0 SDK Update (October 2004)

AnimationController.ICloneable.Clone Method

 Language:
Note: This documentation is preliminary and is subject to change.

Makes a copy of the AnimationController.

Definition

Visual Basic .NET | Public Function ICloneable.Clone() As Object
C# | public object ICloneable.Clone();
Managed C++ | public: Object* ICloneable.Clone();
JScript .NET | public function ICloneable.Clone() : Object;

Return Value

System.Object . Cloned object.

Remarks

Exceptions
OutOfMemoryException Leave Site Microsoft® Direct3D® could not allocate sufficient memory to complete the call.